Explicit and Tactical RSVP-TE LSP Optimization

The Explicit RSVP-TE L SP Optimization tool minimizes congestion by optimizing the placement of primary
and secondary paths for selected RSV P LSPs. By default, WAE Design minimizes the utilization across
primary paths under normal operation and creates digjoint secondary paths so that a single failure cannot
disrupt both paths simultaneously.

Thedefault isto optimize utilization on all interfaces using all RSV P L SPs on those interfaces. Another default
isto remove CSPF constraints, such as affinities and hop limits. For example, WAE Design sets the setup
bandwidth to 0, thus providing the greatest flexibility when setting these explicit paths.

Upon completion, WAE Design tags the RSV P L SPs with expopt and generates a new plan file with an -eopt
suffix. Thisplan file opens, showing the L SPstable that isfiltered to these rerouted (and newly tagged) RSV P
L SPs. Saving this plan file then simplifies the process of identifying which RSV P L SPs to reconfigure in the
network.

WAE Design also writes areport containing the results of the optimization. To access this information later,
choose Window > Reports.

This section contains the following topics:

* Running the RSVP-TE L SP Optimization Tool, on page 1
* Tactical Explicit RSVP-TE LSP Optimization, on page 6

Running the RSVP-TE LSP Optimization Tool

Step 1

Step 2
Step 3

Step 4

Choose Tools > RSVP L SP Optimization > Explicit Opt. (See Table 1: Explicit RSVP-TE L SP Optimization Options
, on page 2 for field descriptions.)

Specify objectives for primary, secondary, and tertiary paths.
Identify which interfaces to optimize.

Thedefault isto optimize RSVP L SP paths on all selected interfaces, and by default, all interfaces are considered sel ected.
You can, however, optimize alimited number of interfaces or specify a set of RSV P LSPs by preselecting them or by
using tags.

Click OK.
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. Running the RSVP-TE LSP Optimization Tool

What to do next

Table 1: Explicit RSVP-TE LSP Optimization Options

Field

Description

Primary Path Options

Primary paths

Define whether to reroute primary RSVP L SP paths:
* Optimized—Create optimized explicit primary paths based on the objectives selected.
« Keep—Route RSV P L SPs aong the existing primary paths.

Primary paths are optimized using the following three objectives in order of priority. The
first two objectives move RSV P L SPs away from their shortest latency path in an attempt
to reduce the utilizations of the most highly utilized interfaces in the network.

1. Minimize # of interfaces with
utilization > x %

Specify a percentage and minimize the number of selected interfaces with utilizations over that
percentage under normal operation (default).

2. Minimize maximum interface
utilization

Route primary paths so that the maximum interface utilization over al selected interfacesis
minimized under normal operation.

3. Balance across equal latency
paths

Balance utilizations over lower utilized interfaces. For example, use this option to balance
utilizations on parallel interfaces between two nodes if the two interfaces have the same latency.

« Utilization threshol d—Keep the number of interfaces with utilization greater than thisvalue
as low as possible without significantly increasing the latencies of the primary paths.

« Latency tolerance—Permit this percentage of additional latency.

Enforce latency bounds

Enforce latency bounds that can be specified for some or all demandsin the planfile. If checked,
this option takes precedence over all of the preceding objectives.

Secondary Path Options
Secondary paths Define whether and how to route secondary paths.
» Optimized—Create optimized explicit secondary paths based on the objectives selected.
» Dynamic—Route secondary paths dynamically. No explicit hopswill be created for the path.
« None—No secondary paths are created; existing paths are removed.
For optimized secondary paths, the objectives are used in order of priority listed.
Hot Standby Set the secondary path to be a hot standby, which meansit is established at the same time as the

primary peth, rather than after the primary path fails.
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Running the RSVP-TE LSP Optimization Tool .

Field

Description

1. Maximize primary/secondary
path disjointness with respect to

Define primary and secondary paths for each RSVP L SP that are digjoint with respect to circuit,
SRLG, node, and Layer 1 (L1) link failures, depending on what is selected.

« Circuits—No circuit is used by both the primary and secondary paths (default = 1).

* SRLGs—No SRLG is used by both the primary and secondary paths (default = 2).

* Nodes—No node is used by both the primary and secondary paths (default = 3).

* L1 Nodes—No L1 node is used by both the primary and secondary paths (default = 3).
e L1 Links—No L1 link is used by both the primary and secondary paths (default = 3).

« Traffic digointness only—A path is acceptable even if it uses similar circuits, SRLGs, or
nodes as other paths provided there is no traffic routed over the RSV P LSP when failures
occur.

You can specify the degree of digjointness of primary and secondary paths. The lower the
number, the higher the disjointness priority. For example, if it isimportant that the paths are
node digoint and the SRL G digjointness are less important, you could change the setting to
circuits 1, nodes 2, and SRLGs 3.

Note that the network topology sometimes makes it impossible to fulfill al the selected
digointness requirements. In this case, paths are selected that are maximally disjoint. That
is, they are digjoint for as many circuits, SRLGs, nodes, L1 nodes, and L1 links as possible.

2. Minimize # of interfaces with
utilization> __ %—

Options 2 and 3 both operate on the sel ected failure scenarios (circuits, SRL Gs, nodes, L1 nodes,
and L1 links) listed in the “Failures to consider” options listed under 3. These choices are the
failure scenarios over which the simulation is performed at the end of the optimization. Note that
this selection of failure scenariosis distinct from the failure scenarios sel ected for the digjointness
objective 1.

Use option 2 to minimize the number of interfaces with utilizations over the specified percentage
across al selected failure scenarios.

3. Minimize maximum interface
utilization

Use option 3 to minimize the maximum interface utilization over al interfaces and over all selected
failure scenarios.

Tertiary Path Options

Tertiary paths Define whether to create tertiary paths:
» Dynamic—Create dynamic tertiary paths.
* None—No tertiary paths are created.
Hot Standby Set thetertiary path to be a hot standby path, which meansit is brought up with the primary path,
rather than after the primary path fails.
Other Options

Optimized Interfaces

Identify which interfaces to optimize: all interfaces, those selected prior to opening the dialog
box, or those with specific tags.
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Field Description

Using RSVP LSPs Specify which L SPs are candidates for rerouting. The default is al the LSPs currently routed on
the selected interfaces.

Tag changed LSPs Create and add tags to all L SPs rerouted during optimization. Using tags makes it easier to find
the L SPsthat need to be reconfigured in the actual network according to the optimization results.
By default, newly optimized RSV P L SPs are tagged as expopt .

New plan for result This default option creates anew plan with the results of the optimization. Unless anameis
specified, WAE Design attaches an -eopt suffix to the current plan filename. If unchecked, WAE
Design changes the current plan file with the updated information.

Details button See Setting Optimization Details, on page 4.

Setting Optimization Details

Step 1 Choose Tools > RSVP L SP Optimization > Explicit Opt. (See Table 1: Explicit RSVP-TE L SP Optimization Options
, on page 2 for field descriptions.)

Step 2 Click the Details button to identify less frequently used parameters, such astraffic levels and how to treat non-optimized
interfaces.

» Non-optimized interfaces—You can specify whether to ignore non-optimized interfaces or set the acceptable level
of utilization for them.

If setting an acceptable utilization level and if both options are selected, WAE Design uses the higher of the two.
These settings are calculated on a per-interface basis.

 Acceptable utilization of optimized interfaces:  %—Thisvalueis the same as the utilization threshold set
in the Primary Path area (Minimize# of interfaceswith utilization > %, where the default is 80). To change
this value, you must change it in the Primary Path area.

If using the Tactical Explicit RSVP-TE L SP Optimization tool, thisfield is equivalent to, and thus only
changeable in, the Acceptable Utilization % field.

e Current utilization + ___ % —Current utilization of non-optimized interfaces plus the added percentage.

Mon-optimized interfaces

@ Acceptable utilization is maximum of:

] Acceptable utilization of optimized interfaces: 80%
W]  current utilization + 0 %

Ignore

Example: There are two non-optimized interfaces: crl.chi_crl.miahas a utilization of 60% and cr2.5jc_cr2.okc hasa
utilization of 78%.

The acceptabl e utilization settings for non-optimized interfaces are:
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* The primary path utilization threshold is 80%.
* The current utilization has 5% added to it.

.‘: Explicit LSP Optimization Settings

Primary Paths

Mon-optimized interfaces 1. [¥] Minimize # of interfaces with utilization > 80 %

@ Acceptable utilization is maximum of:

[¥]  Acceptable utilization of optimized interfaces: 80%

[¥] current utilization + 5 %

‘ .‘: Tactical Explicit LSP Optimization Settings ‘

Acceptable interface utilization: 80 Yo

381050

Result: The maximum utilization for each interface isindividually calculated. The acceptable level of utilization for
crl.chi_crl.miais 80%, and the acceptable level of utilization for cr2.5c_cr2.okc is 83% (78 + 5).

* LSP Configuration > Create fully explicit named paths for—BY default, WAE Design creates named paths across
the RSVP L SPs that were selected if areroute is required to achieve the optimization objectives. For example, if a
selected dynamically routed RSV P L SP has an acceptable route, WAE Design does not create a named path for it.

To change this default, click All selected L SPs. WAE Design then creates and routes fully explicit named paths for
all selected RSVP LSPs.

LSP Configuration

Create fully explicit named paths for
All selected LSPs
@ Rerouted LSPs only

11046

el
)

« LSP Configuration > In addition—BYy default, WAE Design sets the Setup BW to zero, providing the greatest
flexibility when creating explicit routes. Aswell, all affinities and hop limits are removed, and the setup and hold
priorities are set to 7. These changes apply only to the RSV P LSPs with newly created or changed explicit named
paths.

You can turn off these defaults, and you can also set them individually after the optimization is performed using the
L SP Paths Properties dialog box. (In the LSP Paths table, right-click an RSV P L SP path and choose Properties.)
If these defaults are turned off, the original parameters are preserved.

In addition:
] Set Setup BW to zero

etz

Remove affinities

1

Remaove Hop Limit
Set Setup Priority, Hold Priority to 7

=

< E <
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« Traffic Level—Choose thetraffic level you want used in the utilization cal cul ations and optimizations. For information
on traffic levels, see Traffic Demand Modeling .

« Rerouting Preference—BY default, preferences on which RSV P L SPs to reroute are not based on traffic volume.
You can select high-traffic or low-traffic options to sequentially give priority to RSV P L SPs with higher and lower
traffic.

Step 3 Click OK to close the Details dialog box.
Step 4 Click OK.

Tactical Explicit RSVP-TE LSP Optimization

The Tactical Explicit RSVP-TE L SP Optimization tool is areduced version of the Explicit RSVP-TE LSP
Optimization tool. Thistool optimizes only primary paths using the minimum number of path changesrequired
to bring utilizations below an acceptable level. It is useful when you need to reduce congestion in a specific
area of the network with alimited number of RSV P L SP reconfigurations.

If you need to target specific interfaces or RSV P L SPs to confine the optimization to problem areas, select
those interfaces or RSVP LSPsfirst. Then choose Tools > RSVP L PS Optimization > Tactical Explicit
Opt.
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