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Explicit and Tactical RSVP-TE LSP Optimization

This chapter describes two RSVP-TE LSP optimization tools:

• Explicit RSVP-TE LSP Optimization

• Tactical Explicit RSVP-TE LSP Optimization

Explicit RSVP-TE LSP Optimization
The Explicit RSVP-TE LSP Optimization tool minimizes congestion by optimizing the placement of 
primary and secondary paths for selected RSVP LSPs. By default, WAE Design minimizes the utilization 
across primary paths under normal operation and creates disjoint secondary paths so that a single failure 
cannot disrupt both paths simultaneously.

The default is to optimize utilization on all interfaces using all RSVP LSPs on those interfaces. Another 
default is to remove CSPF constraints, such as affinities and hop limits. For example, WAE Design sets 
the setup bandwidth to 0, thus providing the greatest flexibility when setting these explicit paths.

Upon completion, WAE Design tags the RSVP LSPs with expopt and generates a new plan file with an 
-eopt suffix. This plan file opens, showing the LSPs table that is filtered to these rerouted (and newly 
tagged) RSVP LSPs. Saving this plan file then simplifies the process of identifying which RSVP LSPs 
to reconfigure in the network. 

WAE Design also writes a report containing the results of the optimization. To access this information 
later, choose Window > Reports.

Running the RSVP-TE LSP Optimization Tool

Step 1 Choose Tools > RSVP LSP Optimization > Explicit Opt. (See Table 21-1 for field descriptions.)

Step 2 Specify objectives for primary, secondary, and tertiary paths.

Step 3 Identify which interfaces to optimize.

The default is to optimize RSVP LSP paths on all selected interfaces, and by default, all interfaces are 
considered selected. You can, however, optimize a limited number of interfaces or specify a set of RSVP 
LSPs by preselecting them or by using tags.

Step 4 Click OK.
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Table 21-1 Explicit RSVP-TE LSP Optimization Options

Field Description

Primary Path Options

Primary paths Define whether to reroute primary RSVP LSP paths:

• Optimized—Create optimized explicit primary paths based on the objectives 
selected.

• Keep—Route RSVP LSPs along the existing primary paths.

Primary paths are optimized using the following three objectives in order of priority. 
The first two objectives move RSVP LSPs away from their shortest latency path in an 
attempt to reduce the utilizations of the most highly utilized interfaces in the network. 

1. Minimize # of interfaces with 
utilization > x %

Specify a percentage and minimize the number of selected interfaces with utilizations 
over that percentage under normal operation (default). 

2. Minimize maximum interface 
utilization

Route primary paths so that the maximum interface utilization over all selected 
interfaces is minimized under normal operation. 

3. Balance across equal latency 
paths

Balance utilizations over lower utilized interfaces. For example, use this option to 
balance utilizations on parallel interfaces between two nodes if the two interfaces have 
the same latency. 

• Utilization threshold—Keep the number of interfaces with utilization greater than 
this value as low as possible without significantly increasing the latencies of the 
primary paths.

• Latency tolerance—Permit this percentage of additional latency. 

Enforce latency bounds Enforce latency bounds that can be specified for some or all demands in the plan file. 
If checked, this option takes precedence over all of the preceding objectives.

Secondary Path Options

Secondary paths Define whether and how to route secondary paths. 

• Optimized—Create optimized explicit secondary paths based on the objectives 
selected.

• Dynamic—Route secondary paths dynamically. No explicit hops will be created for 
the path.

• None—No secondary paths are created; existing paths are removed. 

For optimized secondary paths, the objectives are used in order of priority listed.

Hot Standby Set the secondary path to be a hot standby, which means it is established at the same 
time as the primary path, rather than after the primary path fails.
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1. Maximize primary/secondary 
path disjointness with respect to

Define primary and secondary paths for each RSVP LSP that are disjoint with respect 
to circuit, SRLG, node, and Layer 1 (L1) link failures, depending on what is selected.

• Circuits—No circuit is used by both the primary and secondary paths (default = 1).

• SRLGs—No SRLG is used by both the primary and secondary paths (default = 2).

• Nodes—No node is used by both the primary and secondary paths (default = 3).

• L1 Nodes—No L1 node is used by both the primary and secondary paths (default 
= 3).

• L1 Links—No L1 link is used by both the primary and secondary paths (default = 
3).

• Traffic disjointness only—A path is acceptable even if it uses similar circuits, 
SRLGs, or nodes as other paths provided there is no traffic routed over the RSVP 
LSP when failures occur.

You can specify the degree of disjointness of primary and secondary paths. The lower 
the number, the higher the disjointness priority. For example, if it is important that the 
paths are node disjoint and the SRLG disjointness are less important, you could change 
the setting to circuits 1, nodes 2, and SRLGs 3.

Note that the network topology sometimes makes it impossible to fulfill all the selected 
disjointness requirements. In this case, paths are selected that are maximally disjoint. 
That is, they are disjoint for as many circuits, SRLGs, nodes, L1 nodes, and L1 links as 
possible.

2. Minimize # of interfaces with 
utilization > ___ %—

Options 2 and 3 both operate on the selected failure scenarios (circuits, SRLGs, nodes, 
L1 nodes, and L1 links) listed in the “Failures to consider” options listed under 3. These 
choices are the failure scenarios over which the simulation is performed at the end of 
the optimization. Note that this selection of failure scenarios is distinct from the failure 
scenarios selected for the disjointness objective 1.

Use option 2 to minimize the number of interfaces with utilizations over the specified 
percentage across all selected failure scenarios. 

3. Minimize maximum interface 
utilization

Use option 3 to minimize the maximum interface utilization over all interfaces and over 
all selected failure scenarios. 

Tertiary Path Options

Tertiary paths Define whether to create tertiary paths:

• Dynamic—Create dynamic tertiary paths.

• None—No tertiary paths are created.

Hot Standby Set the tertiary path to be a hot standby path, which means it is brought up with the 
primary path, rather than after the primary path fails.

Other Options

Optimized Interfaces Identify which interfaces to optimize: all interfaces, those selected prior to opening the 
dialog box, or those with specific tags.

Using RSVP LSPs Specify which LSPs are candidates for rerouting. The default is all the LSPs currently 
routed on the selected interfaces.

Table 21-1 Explicit RSVP-TE LSP Optimization Options (continued)

Field Description
21-3
Cisco WAE Design 7.0.1 User Guide

   



   

Chapter 21      Explicit and Tactical RSVP-TE LSP Optimization
  Running the RSVP-TE LSP Optimization Tool
Setting Optimization Details

Step 1 Choose Tools > RSVP LSP Optimization > Explicit Opt. (See Table 21-1 for field descriptions.)

Step 2 Click the Details button to identify less frequently used parameters, such as traffic levels and how to 
treat non-optimized interfaces.

• Non-optimized interfaces—You can specify whether to ignore non-optimized interfaces or set the 
acceptable level of utilization for them. 

If setting an acceptable utilization level and if both options are selected, WAE Design uses the higher 
of the two. These settings are calculated on a per-interface basis.

– Acceptable utilization of optimized interfaces: ___%—This value is the same as the utilization 
threshold set in the Primary Path area (Minimize # of interfaces with utilization > ___%, where 
the default is 80). To change this value, you must change it in the Primary Path area.

If using the Tactical Explicit RSVP-TE LSP Optimization tool, this field is equivalent to, and 
thus only changeable in, the Acceptable Utilization ___% field.

– Current utilization + ___%—Current utilization of non-optimized interfaces plus the added 
percentage.

Example: There are two non-optimized interfaces: cr1.chi_cr1.mia has a utilization of 60% and 
cr2.sjc_cr2.okc has a utilization of 78%.

The acceptable utilization settings for non-optimized interfaces are:

– The primary path utilization threshold is 80%.

– The current utilization has 5% added to it.

Tag changed LSPs Create and add tags to all LSPs rerouted during optimization. Using tags makes it easier 
to find the LSPs that need to be reconfigured in the actual network according to the 
optimization results. By default, newly optimized RSVP LSPs are tagged as expopt.

New plan for result This default option creates a new plan with the results of the optimization. Unless a 
name is specified, WAE Design attaches an -eopt suffix to the current plan filename. If 
unchecked, WAE Design changes the current plan file with the updated information.

Details button See Setting Optimization Details.

Table 21-1 Explicit RSVP-TE LSP Optimization Options (continued)

Field Description
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Result: The maximum utilization for each interface is individually calculated. The acceptable level 
of utilization for cr1.chi_cr1.mia is 80%, and the acceptable level of utilization for cr2.sjc_cr2.okc 
is 83% (78 + 5).

• LSP Configuration > Create fully explicit named paths for—By default, WAE Design creates named 
paths across the RSVP LSPs that were selected if a reroute is required to achieve the optimization 
objectives. For example, if a selected dynamically routed RSVP LSP has an acceptable route, WAE 
Design does not create a named path for it. 

To change this default, click All selected LSPs. WAE Design then creates and routes fully explicit 
named paths for all selected RSVP LSPs.

• LSP Configuration > In addition—By default, WAE Design sets the Setup BW to zero, providing 
the greatest flexibility when creating explicit routes. As well, all affinities and hop limits are 
removed, and the setup and hold priorities are set to 7. These changes apply only to the RSVP LSPs 
with newly created or changed explicit named paths.

You can turn off these defaults, and you can also set them individually after the optimization is 
performed using the LSP Paths Properties dialog box. (In the LSP Paths table, right-click an RSVP 
LSP path and choose Properties.) If these defaults are turned off, the original parameters are 
preserved.

• Traffic Level—Choose the traffic level you want used in the utilization calculations and 
optimizations. For information on traffic levels, see Traffic Demand Modeling.
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• Rerouting Preference—By default, preferences on which RSVP LSPs to reroute are not based on 
traffic volume. You can select high-traffic or low-traffic options to sequentially give priority to 
RSVP LSPs with higher and lower traffic.

Step 3 Click OK to close the Details dialog box.

Step 4 Click OK.

Tactical Explicit RSVP-TE LSP Optimization
The Tactical Explicit RSVP-TE LSP Optimization tool is a reduced version of the Explicit RSVP-TE 
LSP Optimization tool. This tool optimizes only primary paths using the minimum number of path 
changes required to bring utilizations below an acceptable level. It is useful when you need to reduce 
congestion in a specific area of the network with a limited number of RSVP LSP reconfigurations.

If you need to target specific interfaces or RSVP LSPs to confine the optimization to problem areas, 
select those interfaces or RSVP LSPs first. Then choose Tools > RSVP LPS Optimization > Tactical 
Explicit Opt.
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