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Overview
These tutorials take you through the WAE Design GUI in a structured way so that you quickly get an overview of the user interface,
including the basics of failure simulations.

• Getting Started with WAE Design—Introduces you to the GUI, explains how to use the controls and menus, and shows you the
basics of how to modify simulated traffic (demands).

• Getting Started with Simulation Analysis—Demonstrates how to generate failure scenarios and how to examine your network
for component failure vulnerabilities.

Getting Started with WAE Design
The WAE Design GUI operates on plan files, or plans, that contain the components of information that display the network. In this
tutorial, you use sample plan files that come with the WAE Design application. Topics include:

• WAE Design GUI display and behavior, including network plot, toolbars, tables, selection methods, and shortcuts.

• Customizing displays for circuit capacities and traffic utilizations.

• Traffic demands, which are the foundation for network modeling and simulation in WAE Design.

WAE Design works on both measured and simulated traffic. Traffic is simulated through demands (which are explained in Simulate
Traffic Using Demands). Unless otherwise noted, the instructions and diagrams are for simulated traffic.

This tutorial references $CARIDEN_HOME, which is the directory in which the Cisco WAE executables and binaries
are installed. On Linux, the default $CARIDEN_HOME is /opt/cariden/software/mate/current, where
/opt/cariden is the default installation directory.

Note

Launch WAE Design and Open a Plan File
To view the network topology and perform WAE Design operations, you must open a plan file. To use WAE Design effectively, it
is helpful to understand the main GUI components.

Task: Launch WAE Design, open a plan file, and develop a basic understanding of the GUI.

Procedure

Step 1 Double-click the wae_design icon in the $CARIDEN_HOME directory, which is the directory in which WAE Design is
installed.

Step 2 If a license message is displayed, click OK to continue. (You don't need a license to use the sample plans.)
Step 3 Choose File > Open.
Step 4 Browse to $CARIDEN_HOME/samples and open the euro4.txt file, which is a sample European network.
Step 5 Locate each of the following GUI components:
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• Menus—Menu selections for network modeling, simulation, and optimization.

• Visualization toolbar—Drop-down lists and icons that control how the network is displayed.

• Network plot—A visual representation of the network topology.

• Tables—Network properties, including both measured and simulated information, for the network plan.

• Context menus—Right-click anywhere in the plots or tables to view actions that you can take.

Figure 1: Main GUI Components

Step 6 If continuing with these tutorials, keep this plan open for the next task. If stopping here, choose File > Close to close the
file without saving it.

View Network, Site, and Interface Plots
Upon opening the plan file used in this tutorial, the network plot shows sites (square icons) that appear to be connected by circuits,
though they actually connect to nodes (routers) within each site. The nodes within the sites are connected with intrasite circuits. Each
circuit consists of two interfaces that are delineated by the line in the middle of the circuit.

Note that sites can also contain other sites, and nodes do not have to be contained within sites.

Task: View network, site, and interface plots.
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Procedure

Step 1 If the euro4.txt file is not open, choose File > Open. Browse to $CARIDEN_HOME/samples and open the
euro4.txt file.

Step 2 In the network plot, notice the four sites. These are connected by 622 Mbps (OC12/STM4) circuits. LON and AMS are
connected by two such circuits. This information is listed in the Capacity Sim column of the Interfaces table.

Figure 2: Network Plot of Sample European Plan File

Step 3 Open a site plot.
a) Double-click the LON site to see its details. Notice that the LON site contains three nodes connected by intrasite

circuits.
b) Click each of the outbound interfaces and notice the selection (blue highlight) of the same interface in the network

plot.
c) Close the site plot by clicking the top right X.

Step 4 Open an interface plot.
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a) Click the orange interface coming out of LON and going towards AMS.
b) Press and hold the Ctrl key (Cmd on a Mac) while selecting the green interfacing coming out of LON going towards

PAR. Both interfaces are now selected.
c) Right-click either of these interfaces and choose Plot Interfaces. An interface plot opens.
d) Click in an empty plot area to deselect them from both the interface and the network plots.
e) Click each of the interfaces in the interface plot and notice that they are selected in the network plot.
f) Close the interface plot by clicking the top right X.

Figure 3: Interface Plot
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Step 5 If continuing with these tutorials, keep this plan open for the next task. If stopping here, choose File > Close to close the
file without saving it.

Work with Tables and Object Selections
This section familiarizes you with the basic dynamics between tables and objects, such as nodes, sites, circuits, interfaces, and ports.
When you select an object in a table, it is automatically selected in the network plot. Conversely, whatever you select in the network
plot is selected in the tables.

Task: Show different tables and select objects. Each time you make a selection, observe what happens in the tables and in the network
plot to see their relationships.

Procedure

Step 1 Ifeuro4.txt file is not open, chooseFile >Open. Browse to$CARIDEN_HOME/samples and open the euro4.txt
file.

Step 2 Notice that the Interfaces tab is selected. Click the Sites tab to show the Sites table.
Step 3 In the network plot, click various sites, and each time notice the blue highlight in the left column of the Sites table. Also

notice that each time you select a new site, the other is no longer selected. This is because selecting an individual object
deselects all others.

Step 4 Show the Circuits table, which is not in the default table tabs.
a) Right-click any of the table tabs and choose Show/Hide Tables.
b) Click the empty F (false) box on the Circuits row to toggle to T (true).
c) Click OK.
d) Click the Circuits tab to show the Circuits table.

Step 5 In the Circuits table, select the PAR-LON circuit. Press and hold Ctrl (Cmd on a Mac) while clicking the AMS-FRA
circuit. Notice that both rows are highlighted as are the corresponding circuits in the network plot. This selects four
interfaces (two interfaces per circuit). To verify these selections, in the Circuits table right-click either of the two selected
circuits, and choose Filter to Interfaces. The Interfaces table shows the four interfaces that are selected in the network
plot.

Step 6 In the Interfaces table, click Show All.
Step 7 Click the top row of the Interfaces table. Press and hold Shift while clicking the fourth row. All four interfaces are selected

both in the table and in the plot. Two of these interfaces are intrasite as indicated by the small square on top of the AMS
site.
a) Double-click the AMS site to see the selected interface.
b) Close the site plot by clicking the top right X.
c) Click in an empty plot area to deselect the interfaces.
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Step 8 If continuing with these tutorials, keep this plan open for the next task. If stopping here, choose File > Close to close the
file without saving it.

Change Circuit Capacity Width
Circuits are drawn to show the relationship of their capacity to their utilization. By default, the width of the circuit is proportional to
the capacity, down to a predefined minimum width, and the interfaces appear without explanatory text. The Plot Options icon opens
a dialog box where you can change the relationship between width and capacity, and control the minimum width and rate at which
the width changes for different capacities.

Task: Change the relationship between circuits’ width and their capacity.

Procedure

Step 1 If the euro4.txt file is not open, choose File > Open. Browse to $CARIDEN_HOME/samples and open the
euro4.txt file.
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Step 2 Click the Plot Options icon in the top right of the visualization toolbar; the Plot Options dialog box opens.

Step 3 In the Design Circuits tab, change the value in the “Circuits set to min width for capacity below” field from 580 to 50,
and click OK.

Step 4 Notice that all circuits are wider than the minimum now because their capacities all exceed 50 Mbps.

Step 5 Double-click the LON site to open its site plot. Notice that some circuits show at the minimum width with no fill color;
this is because these circuits do not have a specified capacity.

Step 6 Reopen the Plot Options dialog box, change the setting back to the default of 580, and click OK.
Step 7 If continuing with these tutorials, keep this plan open for the next task. If stopping here, choose File > Close to close the

file without saving it.

Determine Traffic Utilization
WAE Design shows either measured network traffic or simulated traffic, depending on the view. The color fill of an interface shows
the bandwidth utilization for traffic leaving that interface in proportion to the interface capacity. That is, it shows the traffic utilization.

The exact utilization of any circuit is listed in the tables where all quantitative parameters of the network are available. You can
customize the colors and thresholds from the Utilization Color menu.
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Task: Determine the traffic utilization threshold using color fills, Util Sim column, and textual representations.

Procedure

Step 1 If euro4.txt file is not open, choose File > Open. Browse to $CARIDEN_HOME/samples and open the
euro4.txt file.

Step 2 Click the green drop-down arrow in the Utilization Color menu. The range indicates that if an interface is green, its traffic
utilization is between 30-50%.

Step 3 In the network plot, click the green part of the circuit between LON and PAR. Right-click this interface and choose Filter
to Selection. The Interfaces table opens and shows only this interface.

Step 4 Note that the Util Sim (simulated) column shows a utilization of 47.75% for this interface, which is between the 30-50%
level denoted by green as shown in the Utilization Color drop-down menu. The interface is filled with green that extends
to fill almost half of this interface. The other half of the circuit displays the traffic utilization for the reverse direction,
which is 0% for this interface.

Step 5 In the Interfaces table, click Show All.
Step 6 Identify the percentages by displaying them on all interfaces.

a) Click the Plot Options icon; the Plot Options dialog box opens.
b) In the Design Circuits tab, Interface Text list, choose Percentage of Interface filled.
c) Click OK. The interfaces now show the numeric utilization percentage. Compare these numbers to those in the Util

Sim column to see they are the same.
d) Reopen the Plot Options dialog box, change the Interface Text back to None, and click OK.
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Figure 4: Traffic Utilization on cr1.lon-cr1.par Interface

Figure 5: Traffic Utilization in Text Format

Step 7 If continuing with these tutorials, keep this plan open for the next task. If stopping here, choose File > Close to close the
file without saving it.
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Most Highly Utilized Interface
There are two ways to identify the most utilized interfaces, which is useful when analyzing large, complex networks.

Task: Determine the most highly utilized interfaces in the network using each of the following methods.

Method: Sort Util Sim Column

Procedure

Step 1 Ifeuro4.txt file is not open, chooseFile >Open. Browse to$CARIDEN_HOME/samples and open the euro4.txt
file.

Step 2 In the Interfaces table, click the Util Sim column heading to sort the interfaces by descending order. Click it two more
times; the column sort toggles between ascending and descending order.

Step 3 Notice that the most utilized interface is at 87.06% of capacity, which is the top row. Click this top row. The interface
highlighted in the plot is the most highly utilized interface.

Step 4 Use the down arrow to move down row by row, each time finding the next most highly utilized interface. Each selection
is highlighted in the plot and its exact utilization value is visible in the Util Sim column.

Step 5 Click in an empty plot area to deselect the interfaces.

Method: Select Max Value in Utilization Color Menu

Procedure

Step 1 Click the purple drop-down arrow in the Utilization Color menu to see that the maximum utilization value is 100%.
Choose Max. This resets the maximum threshold percentage to the most highly utilized interface, which color fills that
interface, cr2.lon-cr1.ams, to purple.

Step 2 Click the purple drop-down arrow again to see that maximum is now 87.06%. Verify this by reading its Util Sim value
in the Interfaces table, which is also 87.06%.

Step 3 Click the purple drop-down arrow again and choose < 87.06%. This highlights the second most highly utilized interface,
which is cr1.ams-cr2.fra.
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Step 4 Set the maximum utilization back to 100% by restoring the system default colors:
a) Choose Edit > Plot > Plot Options > Apply System Defaults.
b) Click the purple drop-down arrow again to see that maximum is now 100%.

Figure 6: Interface with Highest (Max) Utilization

Step 5 If continuing with these tutorials, keep this plan open for the next task. If stopping here, choose File > Close to close the
file without saving it.

Simulate Traffic Using Demands
Several WAE Design tables have columns that identify how much traffic is being carried or what percentage of the capacity is being
utilized. For example, the Interfaces table has a Util Sim column that reflects simulated traffic utilization. The two basic inputs to the
simulation are the network configuration itself and a set of traffic demands. A demand is a request for a specified amount of traffic
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to be sent from one node, the source, to another node, the destination. The routes taken are based on traffic, topology, network health,
as well as the protocols used.

Task: Determine which service classes are associated with demands, read demand traffic and latency, and identify demands route in
the network plot.

Procedure

Step 1 Choose File > Open. Browse to $CARIDEN_HOME/samples and open the euro4.txt file.
Step 2 Click the Demands tab to show the Demands table. Notice that this network contains only six demands, all from the

er1.lon edge node in the LON site to the edge notes in other sites.
Step 3 Show the Service Class column:

a) Right-click any heading in the Demands table and choose Show/Hide Columns.
b) In the Search field, enter the word “service” and press Enter. The search feature locates all columns and column

descriptions containing this word.
c) Check the empty F (false) check box on the Service Class row to toggle to T (true).
d) Click OK. The Service Class column appears.

Figure 7: Search for and Show Column Names

Step 4 Click the Service Class column heading to sort demands by service class, noting that half the demands represent Internet
traffic and half represent voice traffic.

Step 5 Read the Traffic column values to determine how much traffic each demand is attempting to route.
Step 6 Determine the sum of the delays for all the interfaces on the longest path taken by each demand:

a) In the Demands table, right-click the Maximum Latency column heading to see that its sum value is zero.
b) Click the Interfaces tab, and then right-click any of its headings and choose Show/Hide Columns.
c) Check the empty F (false) check box on the Delay Sim row to toggle to T (true).
d) Click OK. The Delay Sim column appears.
e) Right-click the Delay Sim column heading to see that its sum value is zero.

Step 7 In the Demands table, click the demand from er1.lon to er1.par. The network plot shows this demand from LON to
PAR sites using a blue arrow to show the route, an A to show the source, and a Z to show the destination.
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Figure 8: Single-Path Demand Route

Step 8 Use the up and down arrow keys to move from row to row in the Demands table, highlighting each demand and showing
its routing in the network.

Notice the er1.lon to er1.ams demand takes two equal-cost multipath (ECMP) routes along two parallel circuits. Two
blue lines show 50% of the traffic flowing through each of these circuits.

Step 9 Right-click the er1.lon to er1.ams demand and choose Plot Demands. This view shows the details of the demand route.
Step 10 Close the demands plot.
Step 11 Click in an empty plot area to deselect the demand.
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Figure 9: ECMP Demand Route and Associated Demand Plot

Step 12 If continuing with these tutorials, keep this plan open for the next task. If stopping here, choose File > Close to close
the file without saving it.

Modify Demand Traffic

You can modify demand traffic to determine the effects such changes in traffic have on the network. These modifications can be
applied to regions or sites, or they can apply uniformly over the network, such as in the following task.

For instance, you might increase demand traffic to plan for future traffic growth by simulating an overall traffic growth trend. Another
example use might be to determine the network impact of an anticipated increase in sales of a particular service, such as video on
demand.

Task: Simulate an increase in voice traffic by 50%.

Procedure

Step 1 Choose File > Open. Browse to $CARIDEN_HOME/samples and open the euro4.txt file.
Step 2 Locate all voice demands by filtering:

a) Click the Demands tab to show the Demands table.
b) Click the Filter control menu; the Filter dialog box opens.
c) In the Service Class contains row, enter voice.
d) Click OK. The Demands table shows only three demands representing voice traffic.
e) Notice the values listed in the Traffic column are 63, 89, and 142 Mbps.
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Figure 10: Filter to Voice Demands

Step 3 Increase the demand traffic for all voice demands by 50%:
a) Select all rows that are currently showing in the Demands table by selecting one demand and then pressing Ctrl-A

(Cmd-A on Mac).
b) Right-click any row and choose Modify Demand Traffic.
c) In the “Change traffic by ___ %” field, enter 50 and click OK.

Figure 11: Modify Voice Demand Traffic

Step 4 Click anywhere in the empty plot area to remove the demand selections.
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Step 5 Read the values in the Traffic column and note they have increased by 50% to 94.5, 133.5, and 213Mbps. The plot shows
that modifying this traffic created severe congestion between LON and AMS as noted by the purple color fill. Compare,
for example, the color of interfaces between LON and AMS to those prior to the simulated traffic increase.

Figure 12: Voice Demand Traffic Increased by 50%

Step 6 Choose File > Close to close the file without saving it.

Edit Topology
WAEDesign tools let you edit the network topology so that you can add, delete, and move objects. Some tools, such as the duplication
function, greatly simplify the redesign of a complex network.

Once topology changes are made, demands are rerouted, showing the resulting utilization changes in the new network.

Task: Create a new site by duplicating an existing one, place it in its geographically correct location, and observe how traffic is
rerouted as a result of the topology change.

Procedure
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Step 1 Choose File > Open. Browse to $CARIDEN_HOME/samples and open the euro4.txt file.
Step 2 Because you are determining the effect of adding a site, view the demand route before editing the topology:

a) Click the Demands tab to show the Demands table.
b) Click the er1.lon-er1.fra demand. Notice that the demand goes from LON (source) through AMS and to FRA

(destination).
c) Click anywhere in the empty plot to deselect the demand.

Step 3 Create a BRU site by duplicating the AMS site:
a) Right-click the AMS site and choose Duplicate.
b) Enter BRU as the name of the new site and click OK. The new site appears with the same intrasite and intersite circuit

structure.
c) Double-click the new BRU site to see that the nodes have been duplicated from the old site, but renamed appropriately.

Close this site plot.
d) Right-click the newly created BRU site and choose Properties. The Properties dialog box opens. The Location was

copied as AMS, and the Longitude and Latitude fields give the airport location code for AMS.
e) Change the Location field to BRU and press Enter (do not press OK yet). The Location, Longitude, and Latitude

fields update to show the airport location for Brussels.
f) Click OK.

Figure 13: Duplicate AMS Site and Name it BRU

Step 4 Place the site on the plot using its newly updated geographic location:
a) Click the Sites tab to show the Sites table.
b) Click Show All.
c) In the Sites table, select one site and then press Ctrl-A (Cmd-A on Mac) to select all the sites.
d) Right-click the plot background and choose Arrange.
e) Click the Earth icon. The BRU moves to its proper geographic location. The

$CARIDEN_HOME/samples/euro4_bru.txt file shows the same network with this change.
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Figure 14: New BRU Site

Step 5 Observe the effect of adding this new site as it reroutes the er1.lon-er1.fra demand:
a) Click the Demands tab to show the Demands table.
b) Click the er1.lon-er1.fra demand. Half the traffic now routes through AMS and half through BRU.

Figure 15: Rerouted Demand

Step 6 Choose File > Close to close the file without saving it.
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Getting Started with Simulation Analysis
WAE Design Simulation lets you perform failure analysis, which can be useful in long-term planning and short-term preparation.
For example, WAE Design simulates reroutings and changes in traffic utilization under individual failure events, as well as across
multiple failure scenarios that cause worst-case utilizations. This tutorial guides you through a sample of these failure analysis tasks.

For detailed information about simulating and analyzing failures, see the Cisco WAE Design User Guide.

This tutorial references $CARIDEN_HOME, which is the directory in which the Cisco WAE executables and binaries
are installed. On Linux, the default $CARIDEN_HOME is /opt/cariden/software/mate/current, where
/opt/cariden is the default installation directory.

Note

Failures
One of the most useful features of WAE Design is its ability to show network behavior when objects fail. For example, your network
might show utilizations are well under 100% under normal operation. But what happens under failure?

Task: Determine the effects on the network if a single circuit fails.

Procedure

Step 1 Choose File > Open. Browse to $CARIDEN_HOME/samples and open the us_wan.txt file.
Step 2 Notice all traffic utilization is under 100%. You can tell this because none of the interfaces are purple, which by default

means over 100% utilized. Also, the Util Sim column in the Interfaces table shows no values over 100.
Step 3 Right-click the wdc side of the wdc-nyc circuit (cr2.wdc-cr1.nyc interface) and choose Filter to Demands Through

Interfaces > All.
Step 4 Click the er1.atl to er1.bos (first) demand to see its route. The solid blue arrow shows the demand path.
Step 5 Right-click the wdc-nyc circuit and choose Fail. The red cross on the circuit indicates a failure. Notice the difference in

traffic utilization colors in the plot. For example, the kcy-wdc circuit is now congested.
Step 6 Notice how the demand has been rerouted. The dashed line shows the current demand path under failure. Continue clicking

different demands to see how they are rerouted.
Step 7 To restore the failed circuit, right-click it and choose Recover.
Step 8 Click anywhere in an empty plot area to deselect the demand.
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Figure 16: Reroute of Demand Under Circuit Failure

Step 9 If continuing with this tutorial, keep this plan open for the next task. If stopping here, choose File > Close to close the
file without saving it.

SRLG Failures

A shared-risk link group (SRLG) is a group of objects that would likely fail due to a common cause. In a production network, the
most common type of SRLG is one that contains circuits that share a common fiber. If the fiber fails, all circuits fail.

Several WAE Design tools let you simulate SRLG behavior; for example, Simulation Analysis can provide a worst-case analysis of
utilizations over SRLG failures. Metric Optimization can optimize routing over failure scenarios that include SRLGs.

Task: Create an SRLG and fail it to observe the consequences to network traffic.

Procedure

Step 1 If the us_wan.txt file is not open, choose File > Open. Browse to $CARIDEN_HOME/samples and open the
us_wan.txt file.

Step 2 Create an SRLG:
a) Choose Insert > SRLG.
b) From the Object Type list, choose Circuits. Check the F check box for these circuits to toggle them to T (true):

• cr1.chi-cr2.sea

• cr1.sjc-cr1.kcy
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• cr2.chi-cr1.sjc

c) Retain the default name (SRLG1) and click OK.

Step 3 Verify the SRLG1 is in the SRLGs table.
Step 4 Right-click SRLG1 and choose Fail. The followng figure shows the circuits that belong to the failed SRLG and the

resulting severe congestion. The red crosses with white fill mean these circuits are still active, but are not operational
because of other failures.

Step 5 To recover the SRLG, right-click in an empty plot area and choose Recover.

Figure 17: SRLG Failure

Step 6 Keep this plan open and continue to the next task. If you are stopping here and plan to continue later, choose File > Save
As and save the plan file to a different location.
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Simulation Analysis
The Simulation Analysis tool simulates network behavior across multiple failure scenarios, multiple traffic levels, and over multiple
service classes.

Task: Determine the network repercussions of failing single circuits and SRLGs to their worst-case utilizations.

Procedure

Step 1 This task uses the us_wan.txt file that contains the SRLG created and saved in the preceding section. If it is not open,
choose File > Open and browse to its location to open it.

Step 2 Choose Tools > Simulation Analysis and choose the failure scenarios over which to run the analysis.
Step 3 Check the Circuits and SRLGs check boxes.
Step 4 Retain all defaults and click OK. By default, the tool records up to 10 failure scenarios per interface that cause the

worst-case utilization.

WAE Design now performs a simulation for each possible circuit failure and each SRLG failure in the network, and
calculates the utilization for these failure scenarios. The plot shows the resulting congestion in the Worst-Case Traffic
view.

Step 5 Find the interface.
Step 6 When all simulations are complete, a report displays the results.

a) In the Report window, click Simulations in the left navigation pane. Each row in the table represents one of the
simulations that was performed to construct the analysis. The first three columns describe the failure scenario, service
class, and traffic level used in the simulation. The next two columns show that there was always complete connectivity
in the network, and that all demands were always able to be routed.

b) Notice details are listed by failure. To find which failure scenario caused the highest utilization, click the Max Util
column to sort from highest to lowest.

c) Close the Report window.
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Figure 18: Worst-Case Simulation

Step 7 Keep this plan open for the next task.

Worst-Case Failure Analysis: Example 1

In the Worst-Case Traffic view the interfaces are colored based on their worst-case utilizations over all the scenarios specified for
the simulation analysis. This view is useful to see which circuits would become congested under different failure scenarios, and to
discover the cause of their worst-case loading on a circuit-by-circuit basis.

To better understand the meaning of the plot, imagine that for each simulation case (here, each possible circuit or SRLG failure) a
transparent plot was generated. After all scenarios are run, the plots are placed on top of one another and the worst-case utilization
for all circuits is displayed in the plot. It is likely that different failure scenarios produce the worst-case utilization for different circuits.

Task: Determine which interface had the worst-case traffic utilization under this failure scenario, and determine the failures causing
it.

Procedure
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Step 1 Continue using the us_wan.txt file on which you created an SRLG and ran a worst-case simulation analysis. If you
are reopening the file, it must contain the SRLG, and you must perform the previous task that runs a simulation analysis
to fail circuits and SRLGs to their worst case.

Step 2 To find the interface with the worst-case utilization over all failure scenarios calculated for this simulation analysis, click
the WC Util column in the Interfaces table to toggle it to the highest-to-lowest sort order. The cr1.lax to cr2.hst interface
has the most with 134.34%.

Step 3 Look at theWCFailures column to note which failures cause the worst-case utilization on this interface. Here, the SRLG1
failure is the culprit.

Step 4 Keep this plan open for the next task.

Worst-Case Failure Analysis: Example 2

Task: View the failure scenarios that cause the worst-case utilization for the cr1.nyc to cr2.wdc interface and simulate one to determine
how the network would react to this failure.

Procedure

Step 1 Continue using the us_wan.txt file on which you ran a worst-case simulation analysis across circuits and SRLGs.
Step 2 In the Interfaces table, right-click the interface going from node cr1.nyc to cr2.wdc and choose Fail to WC. The dialog

box that opens lists two failures that would cause worst-case utilization on this interface. Select the first one,
ct{cr1.kcy|{to_cr1.sjc}|cr1.sjc{to_cr1.kcy}}, and click OK.

The plot now shows the effects of this failure scenario, and therefore changes to a Simulated Traffic view.

Step 3 To recover the failed circuit, right-click in an empty plot area and choose Recover.
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Figure 19: Fail cr1.nyc-cr2.wdc to a Worst-Case Failure

Step 4 Keep this plan open for the next task.

Worst-Case Failure Analysis: Example 3

Task: View the worst-case information over a subset of the failure set without rerunning the analysis.

Procedure

Step 1 Continue using the us_wan.txt file on which you previously ran a worst-case simulation analysis across circuits and
SRLGs.

Step 2 From the Network Plot View drop-down list, choose Worst-Case Traffic.
Step 3 Click the red X in the top right of the visualization toolbar. A dialog box lets you select a subset of the simulated failure

scenarios to view.
Step 4 Uncheck the SRLGs check box and click OK.

The network plot changes to reflect utilizations over circuit failures only. The WC Util column in the Interfaces table
changes to show maximum utilizations over circuit failures only. The WC Failures column shows only circuit failures
resulting in these utilizations.
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Figure 20: Worst-Case Analysis for Circuit Failures Only

Step 5 Keep this plan open for the next task.

Failure Impact Analysis

The Failure Impact view colors each node and circuit to the maximum utilization level that would be caused elsewhere in the network
if it were to fail. For example, by default red means a circuit is between 90 to 100% utilized. A circuit that is red in the Failure Impact
view means that if that circuit were to fail, it would cause other nodes or circuits to go to 90-100% utilization. This Failure Impact
analysis is automatically calculated each time you run Simulation Analysis.

Task: View the Failure Impact to note the impact circuit failures would have on the network.

Procedure

Step 1 Continue using the us_wan.txt file on which you ran a simulation analysis in the previous task on circuits only. If
you are reopening the file, you must run a worst-case simulation analysis that fails only circuits.

Step 2 From the Network Plot View drop-down list, choose Failure Impact.
Step 3 Show the Failure Impact row in the Interfaces table:

a) Right-click any column heading and choose Show/Hide Columns.
b) Check the empty F (false) check box on the Failure Impact row to toggle to T (true).
c) Click OK.

Step 4 Study the plot to determine potential problems for the network should a circuit fail.

27



a) There are 10 interfaces (representing 5 circuits) showing purple in the network plot, but there are 12 interfaces showing
utilization over 100% in the Failure Impact column. (By default, purple indicates over 100% utilization.)

b) Double-click the chi site to see the sixth purple circuit.

If any one of these purple circuits were to fail, it would cause another circuit in the network to spike to over 100%
utilization.

The cr2.lax-cr2.sjc circuit shows red, indicating that if it were to fail, another circuit would increase its utilization to
90-100%.

c) Notice the various circuit colors and borders surrounding the sites. If you do not remember what the colors mean,
use the drop-down color arrows to find their utilization range.

Figure 21: Failure Impact View

Step 5 Choose File > Close to close the file without saving it.
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