
   

   
C H A P T E R 30

Reports

WAE Design enables you to generate reports that compare IP/MPLS topology and configuration 
information, demand routings, LSP routings, or traffic between two plan files. You can also generate a 
complete plan comparison. Following are a few examples of how these reports could be used. 

• Plan for upgrades—Compare plan files before and after topology and configuration changes are 
made to a current network. For example, you could compare the original plan file to a proposed new 
plan in which circuits or nodes were added or upgraded.

• Mitigate congestion—Compare plans before and after making configuration changes to mitigate 
congestion due to a failure or planned maintenance, such as metric changes or LSP additions and 
reroutings.

• Validate simulations—Compare the simulated traffic under failure in one plan to the measured 
traffic after a failure has occurred in another plan to validate the accuracy of the simulation. 

• Plan audit—Review any changes between two plan files.

• Identify demand and LSP reroutes—Compare plans to determine which demands or LSPs 
experienced routing changes, for example as the result of an interface metric change or capacity 
upgrades.

Upon comparing plan files, a report of the results automatically opens. You can access this report later 
by selecting the Window->Reports menu.

Plan Comparison Reports
Comparison reports enable you to compare objects between two plan files to determine

• Which objects are present in one plan, but not in the other, and

• Which objects are present in both plans and which, if any, have different properties.

For More Information... See...

Reports on LSP path routes MPLS Simulation chapter

Reports on L1 circuit routes Layer 1 Simulation chapter

Reports on demand groupings and demand grouping costs Forecasting Traffic chapter

Cost Modeling chapter

Reports on infrastructure costs Cost Modeling chapter
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You can run four types of plan comparison reports, as follows.

• IP/MPLS topology and configuration—-Objects describing the topology (such as nodes, circuits, 
and interfaces), configured objects (such as LSPs and LSP paths), and related properties (such as 
IGP metrics and capacity). For a complete list of compared objects and properties, see .

• Demand routings—Demand paths and the properties that indicate routing changes, such as Path 
Length and Max Latency. For a complete list of compared properties, see Table 30-1.

• LSP routings—Properties of LSPs that indicate routing changes, such as TE Path Metric and Active 
Path Sim. For a complete list of compared properties, see Table 30-2.

• Complete plan comparison—All tables in the table schema are compared, except for internal 
simulation caching tables. For a complete list of these tables, refer to the 
$CARIDEN_HOME/docs/table_schema file. 

Report Columns
Each WAE Design table has key columns that uniquely identify objects. For example, the key columns 
in the Interfaces table are the Node and Interface columns, which represent the name of the node 
containing the interface and the name of the interface itself. In a Plan Comparison report, an object in 
one plan is identified with an object in another plan only if the key columns of the two objects match. 
That is, key columns determine if an object is present in both plans or in only one of the plans.

The Plan Comparison report displays three other types of columns. Table 30-1, Table 30-2, and 
Table 30-3 list the properties reported upon and their associated column type.

• Information only (Info)—There are no comparisons made. Information is reported for the plan file 
from which you are running the report (Plan 1).

• Differences (Diff)—Specific properties are compared for each object that has matching key columns 
across the two plan files. Objects are then identified as belonging in either Plan 1 only (file from 
which you are running the report), in Plan 2 only (plan file to which you are comparing), or in both 
Plan 1 and Plan 2. If the object exists in both plan files, but has different properties, a Diff column 
shows T (true) if there are any differences or F (false) if there are none.

Differences are based on the current state of the open plan files. For instance, if a circuit is currently 
failed, the demand routings change to route around the failure.
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• Summary Differences (Summ Diff)—These are not columns within WAE Design tables. They are 
T/F (true or false) values, depending on some differences in the table objects that are not represented 
in the table columns. For example, if a common LSP path is configured differently between plans, 
this difference would be represented in a summary difference column in the LSP section. If demand 
routings are different, this would be represented in a summary difference column in the Demands 
section.

Note For easy reference, the following tables list columns in the order of type first: Key, Info, Diff, and Summ 
Diff. Properties within each column type are alphabetical.

Table 30-1 Plans Comparison Report: IP/MPLS Topology and Configuration

Compared 
Table Compared Columns

Comparison 
Column Type Summary Difference Description

Interfaces Name Key

Node Key

Remote Node Info

Affinities Diff

Area Diff

Capacity Diff

Circuit Diff

Description Diff

FRR Protect Diff

IGP Metric Diff

IP Address Diff

PC Min BW Diff

PC Min Links Diff

Resv BW Diff

TE Metric Diff

Circuits InterfaceA Key

InterfaceB Key

NodeA Key

NodeB Key

Name Info

Active Diff

Capacity Diff

Delay Diff

Nodes Name Key

Active Diff

AS Diff

BGP ID Diff
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ECMP Max Diff

IP Address Diff

IP Manage Diff

Model Diff

OS Diff

Vendor Diff

LSPs Node Key

Source Key

Active Diff

Destination Diff

Exclude Diff

FRR Link Protect Diff

Hold Pri Diff

Hop Limit Diff

Include Diff

Include Any Diff

Load Share Diff

Metric Diff

Metric Type Diff

Setup BW Diff

Setup Pri Diff

Unresolved 
Destination

Diff

LSPs Path Diff Summ Diff T (true) if there are any differences in the LSP Paths table for 
this LSP. If two LSPs have differences in their named path hops 
or LSP paths, these differences are propagated to this column.

LSP Paths Node Key

Path Option Key

Source Key

Exclude Diff

Hold Pri Diff

Hop Limit Diff

Include Diff

Include Any Diff

Path Name Diff

Setup BW Diff

Table 30-1 Plans Comparison Report: IP/MPLS Topology and Configuration

Compared 
Table Compared Columns

Comparison 
Column Type Summary Difference Description
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Setup Pri Diff

Standby Diff

Named Path Diff Summ Diff T (true) if there are any differences in the Named Paths table for 
this LSP path.

Named Paths Active Key

Name Key

Source Key

Named Path Hops Diff Summ Diff T (true) if there are any differences in the Named Path Hops 
table for this named LSP path.

Named Path 
Hops

Name Key

Source Key

Step Key

Interface Diff

IP Address Diff

Node Diff

Type Diff

Unresolved Hop Diff

Table 30-2 Plans Comparison Report: Demand Routings

Compared 
Table Compared Columns

Comparison Column 
Type Summary Difference Description

Demands Destination Key

Name Key

Service Class Key

Source Key

Destination Site Info

Source Site Info

Active Diff

ECMP Min % Diff

Max Latency Diff

Path Metric Diff

Path Diff Summ Diff T (true) if there are any differences in routing of the demand.

Table 30-1 Plans Comparison Report: IP/MPLS Topology and Configuration

Compared 
Table Compared Columns

Comparison 
Column Type Summary Difference Description
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Report Sections
The opening section, Summary, gives a numeric summary of the number of objects in each plan file, as 
well as the number of objects in both plan files and of these in both, the number of objects with property 
differences (Figure 30-1). 

Example: Nodes A, B, and C are in Plan 1, and B, C, and D are in Plan 2. Nodes B and C have matching 
key columns. The B nodes have identical properties, but the C nodes have different IP addresses. 
Therefore, in the Summary section, the In Both Plans column shows 2, and the Different Properties 
column shows 1.

An individual section is generated for each object that appears in only one plan file and if there are 
differences between the properties, a section is generated showing these differences. Thus, there is the 
potential of generating one to three sections per compared table: one for objects appearing only in Plan 
1, one for objects appearing only in Plan 2, and one listing objects existing in both plan files, along with 
their differences noted with a T (true) or F (false). 

Table 30-3 Plans Comparison Report: LSP Routings

Compared 
Table Compared Columns

Comparison Column 
Type Summary Difference Description

LSPs Name Key

Source Key

Active Path Sim Diff

Destination Diff

Routed Diff

Shortest TE Path Diff

TE Path Metric Diff

Actual Path Diff Summ Diff T (true) if there are any differences in routing of the 
actual LSP path.

Simulated Path Diff Summ Diff T (true) if there are any differences in routing of the 
LSP.
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Figure 30-1 Example Plan Comparison Report Summary

Other than Summary, the report sections and columns (properties) that appear depend on the options 
selected when generating the report. 

• If you select to show only properties with differences, only those columns with differences in 
properties appear in the report. If only one value is different, all objects are listed (not just the one 
with the different property).

• If you select to show all properties compared, all compared properties appear in the report whether 
there are differences between the two plan files or not.

Create Plan File Comparison Reports

Step 1 Open the two plan files you want to compare. 

Step 2 In either of these two plan files, select the Tools->Reports->Compare Plans menu. A Compare Plans 
dialog box appears. 

Step 3 Select the plan file to which you are comparing the open plan.

Step 4 Select the type of comparisons you want to generate.

• IP/MPLS topology and configuration

• Demand routings

• LSP routings

• Complete plan files

Step 5 Select whether to show only properties with differences or whether to show all properties compared.

Step 6 Click OK.

Traffic Comparison Reports
Traffic Comparison reports compare traffic values within a single plan or between two plan files. You 
can compare traffic on one object at a time (nodes, interfaces, circuits, demands, LSPs, multicast flows, 
and flows). Each object has a different set of comparisons from which to choose. For example, interface 
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traffic and capacity can be compared, and LSP traffic and setup bandwidth can be compared. Another 
example would be to compare the simulated interface traffic in a plan file before a failure to the measured 
interface traffic of a plan file in which a failure has occurred. Such a comparison would enable you to 
determine which interfaces show the greatest differences.

For each plan file compared, the current traffic level and either the selected service class or queue are 
used. They can be different in each plan.

The opening section, Summary, gives a high-level summary of what is being compared. Additionally, a 
section of the difference on the selected object and traffic columns is generated and named accordingly. 

Create Traffic Comparison Reports

Step 1 If comparing traffic from the open plan file to another, open the other plan file.

Step 2 In each plan file, select the travel levels and select either the service class or queue traffic you want to 
compare.

Step 3 Select the Tools->Reports->Compare Traffic menu. This plan file is identified as Plan 1 in the Compare 
Traffic dialog box that appears. 

Step 4 Select the object type on which you want to compare traffic: interfaces, nodes, LSPs, demands, multicast 
flows, or flows.

Step 5 Select the traffic column in the current plan that you want to compare (Plan 1).
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Step 6 The default Plan 2 is the current plan file. To change this, select a different plan file for Plan 2. 

Step 7 Select the traffic column being compared for Plan 2.

Step 8 Click OK.

View or Export Reports
Upon generating a report, it automatically opens in a window. From there you can select the various 
sections of the report from the left navigation pane.

To view a report after having closed it, select the Window->Reports menu. All reports generated on that 
plan file appear and are selectable from one report window.

If you want to save these reports for later use, you must save the plan file. However, running the report 
again overwrites the report. To preserve the information, you can export the data by report section. 
Right-click any of the sections from the left navigation pane, and select Export Tables.
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