
    

    
C H A P T E R 3

Getting Started with Simulation Analysis

WAE Design Simulation enables you to perform several types of failure analysis, which can be useful in 
long-term planning and short-term maintenance preparation. For instance, WAE Design simulates 
reroutings and changes in traffic utilization under individual failure events, as well as across multiple 
failure scenarios causing worst-case utilizations. This tutorial guides you through a sample of these 
failure analysis tasks.

For more detailed information about simulating and analyzing failures, see the WAE Design User Guide.

Note This tutorial references $CARIDEN_HOME, which is the directory in which the WAE Design, WAE Live, 
and WAE Collector executables and binaries are installed. On Linux, the default $CARIDEN_HOME is 
/opt/cariden/software/mate/current, where /opt/cariden is the default installation directory.

Failures
One of the most useful features of WAE Design is its ability to show network behavior when one or more 
objects fail. For example, your network might show utilizations are well under 100% under normal 
operation. But what happens under failure? 

Task: Determine the effects on the network if a single circuit were to fail.

Step 1 Select the File > Open menu. Browse to the $CARIDEN_HOME/samples directory and open the us_wan.txt 
file.

Step 2 Notice all traffic utilization is under 100%. You can tell this in two ways. None of the interfaces are 
purple, which by default means over 100% utilized. The Util Sim column in the Interfaces table shows 
no values over 100.

Step 3 Right-click on the wdc side of the wdc-nyc circuit (cr2.wdc-cr1.nyc interface), and select Filter to 
Demands Through Interfaces > All from the context menu.

Step 4 Select the er1.atl to er1.bos (first) demand to see its route. The solid blue arrow shows the demand path.

Step 5 Right-click on the wdc-nyc circuit and select Fail from the context menu. The red cross appearing on the 
circuit indicates a failure. Notice the difference in traffic utilization colors in the plot. For example, the 
kcy-wdc circuit is now congested. 

Step 6 Notice how the demand has been rerouted. The dashed line shows the current demand path under failure 
(Figure 3-1). Continue clicking on different demands to see how they are rerouted.

Step 7 To restore the failed circuit, right-click on it and select Recover. 
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Step 8 Click anywhere in an empty plot area to deselect the demand.

Step 9 If continuing with this tutorial, keep this plan open for the next task. If stopping here, select the File > 
Close menu to close this file without saving it.

Figure 3-1 Reroute of Demand Under Circuit Failure

SRLGs Failures
An SRLG (shared-risk link group) is a group of objects that would likely fail due to a common cause. In 
a live network, the most common type of SRLG is one that contains circuits that share a common fiber. 
If the fiber fails, all circuits will fail.

Several WAE Design tools enable you to simulate SRLG behavior, such as Simulation Analysis, which 
can provide a worst-case analysis of utilizations over SRLG failures. Metric Optimization can optimize 
routing over failure scenarios that can include SRLGs. 

Task: Create an SRLG and fail it to observe the consequences to network traffic.

Step 1 If us_wan.txt file is not open, select the File > Open menu. Browse to the $CARIDEN_HOME/samples 
directory and open the us_wan.txt file.

Step 2 Create an SRLG.

a. Select the Insert > SRLG menu to open a New SRLG dialog box.

b. Select Circuits from the Object Type list, and click the F on the rows for each of these circuits to set 
them to T (true).

– cr1.sjc-cr1.kcy

– cr2.chi-cr1.sjc

– cr1.chi-cr2.sea
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c. Keep the name created by default (SRLG1), and click OK.

Step 3 Verify the SRLG1 is in the SRLG table. 

Step 4 Right-click on SRLG1 and select Fail from the context menu. Figure 3-2 shows the circuits that belong 
to this SRLG failed and the resulting severe congestion occurring as a result. The red crosses with white 
fill mean these circuits are still active, but are not operational because of other failures.

Step 5 To restore the SRLG, right-click in an empty plot area, and select Recover. 

Step 6 Keep this plan open and continue to the next task. If you are stopping here and plan to continue later, 
select File > Save As and save the plan file to a different location.

Figure 3-2 SRLG Failure

Simulation Analysis
The Simulation Analysis tool simulates network behavior across multiple failure scenarios, multiple 
traffic levels, and over multiple service classes.
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Task: Determine the network repercussions of failing single circuits and SRLGs to their worst-case 
utilizations.

Step 1 This task uses the us_wan.txt file containing the SRLG created and saved in the last section. If it is not 
open, select the File > Open menu, browse to its location to open it.

Step 2 Select the Tools > Simulation Analysis menu. A dialog box appears that allows you to select the set of 
failure scenarios over which the analysis will be run.

Step 3 Select both the Circuits and SRLGs options.

Step 4 Leave all defaults, and click OK. By default, the tool records up to 10 failure scenarios per interface that 
cause the worst-case utilization. 

WAE Design now performs a simulation for each possible circuit failure and each SRLG failure in the 
network, and calculates the utilization for these failure scenarios. The plot shows the resulting 
congestion in the Worst-Case Traffic view, which is located in the upper, left corner of the Visualization 
toolbar (Figure 3-3).

Step 5 Find the interface.

Step 6 When all the simulations are complete, a report opens to display the results. 

a. Within this Report window, select the Simulations table from the left navigation pane. Each row in 
the table represents one of the simulations that was performed to construct the analysis. The first 
three columns describe the failure scenario, service class, and traffic level used in the simulation. 
The next two columns show that under none of these scenarios were there any break points in the 
network (there was always complete connectivity in the network), and that all demands were always 
able to be routed. 

b. Notice details are listed by failure. To find which failure scenario causing the highest utilization, 
click the Max Util column to sort from highest to lowest.

c. Close the Report window.

Step 7 Keep this plan open for the next task.
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Figure 3-3 Worst-Case Simulation

Worst-Case Failure Analysis
In the Worst-Case Traffic view the interfaces are colored based on their worst-case utilizations over all 
the scenarios specified for the simulation analysis (Figure 3-4). This view is very useful for seeing which 
circuits would become congested under different failure scenarios, and for discovering the cause of their 
worst-case loading on a circuit-by-circuit basis. 

To better understand the meaning of the plot, imagine that for each simulation case (here, each possible 
circuit or SRLG failure) a transparent plot was generated. After all scenarios are run, the plots are placed 
on top of one another and the worst-case utilization for all circuits is displayed in the plot. It is likely 
that different failure scenarios produce the worst-case utilization for different circuits. 

Task: Determine which interface had the worst-case traffic utilization under this failure scenario, and 
determine the failures causing it. 
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Step 1 Continue using the us_wan.txt file on which you created an SRLG and ran a worst-case simulation 
analysis. If you are re-opening the file, it must contain the SRLG, and you must perform the previous 
task that runs a simulation analysis to fail circuits and SRLGs to their worst case. 

Step 2 To find the interface with the worst-case utilization over all failure scenarios calculated for this 
simulation analysis, click on the WC Util column heading in the Interfaces table to toggle it to the 
highest-to-lowest sort order. The cr1.lax to cr2.hst interface has the most with 134.34% (Figure 3-3).

Step 3 Look at the WC Failures column to note which failures result in this worst-case utilization on this 
interface. Here, it is the failure of SRLG1 that is the culprit.

Step 4 Keep this plan open for the next task.

Task: View the failure scenarios that cause the worst-case utilization for the cr1.nyc to cr2.wdc interface 
and simulate one to determine how the network would react to this failure.

Step 1 Continue using the us_wan.txt file on which you ran a worst-case simulation analysis across circuits 
and SRLGs. 

Step 2 In the Interfaces table, right-click on the interface going from node cr1.nyc to cr2.wdc, and select Fail 
to WC from the context menu. The dialog box that appears lists two failures that would cause worst-case 
utilization on this interface. Select the first one, ct{cr1.kcy|{to_cr1.sjc}|cr1.sjc{to_cr1.kcy}}, and click 
OK. 

The plot now shows the effects of this failure scenario, and therefore changes to a Simulated Traffic view 
(Figure 3-4). 

Step 3 To restore the failed circuit, right-click in an empty plot area and select Recover.

Step 4 Keep this plan open for the next task.
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Figure 3-4 Fail cr1.nyc-cr2.wdc to a Worst-Case Failure

Task: View the worst-case information over a subset of the failure set without re-running the analysis.

Step 1 Continue using the us_wan.txt file on which you previously ran a worst-case simulation analysis across 
circuits and SRLGs.

Step 2 Select the Worst-Case Traffic view from the Network Plot View drop-down list (in the top left 
visualization toolbar). 

Step 3 Click the red cross in the top, right of the visualization toolbar. A dialog box appears, allowing you to 
select a subset of the simulated failure scenarios to view. 

Step 4 Deselect the SRLGs option, and click OK.

The network plot changes to reflect utilizations over circuit failures only (Figure 3-5). The WC Util 
column in the Interfaces table changes to show maximum utilizations over circuit failures only. The WC 
Failure column shows only circuit failures resulting in these utilizations. 

Step 5 Keep this plan open for the next task.
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Figure 3-5 Worst-Case Analysis for Circuit Failures Only

Failure Impact Analysis
The Failure Impact view colors each node and circuit to the maximum utilization level that would be 
caused elsewhere in the network if it were to fail. For example, by default red means a circuit is between 
90 to 100% utilized. Thus, a circuit that is red in the Failure Impact view means that if that circuit were 
to fail, it would cause other nodes or circuits to go to 90-100% utilization. This Failure Impact analysis 
is automatically calculated each time you run Simulation Analysis.

Task: View the Failure Impact to note the impact circuit failures would have on the network.

Step 1 Continue using the us_wan.txt file on which you ran a simulation analysis in the previous task on 
circuits only. If you are re-opening the file, you must run a worst-case simulation analysis that fails only 
circuits.

Step 2 Select Failure Impact from the Network Plot View drop-down list in the visualization toolbar.

Step 3 Show the Failure Impact row in the Interfaces table.

a. Right-click on any of the column heading and select Show/Hide Columns from the context menu.

b. Click on the empty F (false) box on the Failure Impact row to turn this F to T (true).
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c. Click OK.

Step 4 Study the plot to determine potential problems for the network should a circuit fail (Figure 3-6).

a. There are 10 interfaces (representing 5 circuits) showing purple in the network plot, but there are 12 
interfaces showing utilization over 100% in the Failure Impact column. (By default, purple indicates 
over 100% utilization.)

Double-click the chi site to see this sixth purple circuit.

– If any one of these purple circuits were to fail, it would cause another circuit in the network to 
spike to over 100% utilization. 

– The cr2.lax-cr2.sjc circuit shows red, indicating that if it were to fail, another circuit would 
increase its utilization to 90-100%.

b. Notice the various circuit colors and borders surrounding the sites. If you do not remember what 
each of these colors mean, use the drop-down color utilization lists to find their utilization range.

Step 5 Select the File > Close menu to close the file without saving it.

Figure 3-6 Failure Impact View
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