
    

    
C H A P T E R 2

Getting Started with WAE Design

This tutorial introduces you to the WAE Design GUI, which operates on plan files, or plans, that contain 
the components of information that display the network. In this tutorial, you use sample plan files that 
come with the WAE Design application. Topics include the following. 

• WAE Design GUI display and behavior, including network plot, toolbars, tables, selection methods, 
and shortcuts.

• Customizing displays for circuit capacities and traffic utilizations. 

• Traffic demands, which are the foundation for network modeling and simulation in WAE Design.

WAE Design works on both measured and simulated traffic. Traffic is simulated through demands 
(which are explained in the Simulate Traffic Using Demands section). Unless otherwise noted, the 
instructions and diagrams are for simulated traffic. 

Note This tutorial references $CARIDEN_HOME, which is the directory in which the WAE Design, WAE Live, 
and WAE Collector executables and binaries are installed. On Linux, the default $CARIDEN_HOME is 
/opt/cariden/software/mate/current, where /opt/cariden is the default installation directory.

Launch WAE Design and a Open Plan File
To view the network topology and perform WAE Design operations, you must open a plan file. To use 
WAE Design effectively, it is helpful to understand the main GUI components.

Task: Launch WAE Design, open a plan file, and develop a basic understanding of the GUI.

Step 1 Double-click the mate icon in the $CARIDEN_HOME directory, which is the directory in which WAE Design 
is installed. 

Step 2 If a license message is displayed, click OK to continue since you do not need a license to use the sample 
plans.

Step 3 Select the File->Open menu.

Step 4 Browse to the $CARIDEN_HOME/samples directory and open the euro4.txt file, which is a sample 
European network. 

Step 5 Locate each of the following GUI components (Figure 2-1).

• Menus—Menu selections for network modeling, simulation, and optimization.

• Visualization toolbar—Drop-down lists and icons that control how the network is displayed. 
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• Network plot—Displays a visual representation of the network topology.

• Tables—Display network properties, including both measured and simulated information, for the 
network plan. 

• Context menus—Enable you to right-click anywhere in the plots or tables to view a list of actions 
that you can take. 

Step 6 If continuing with these tutorials, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.

Figure 2-1 Main Components of WAE Design GUI

View Network, Site, and Interface Plots
Upon opening the plan file used in this tutorial, the network plot shows sites (square icons) that appear 
to be connected by circuits, though they actually connect to nodes (routers) within each site. The nodes 
within the sites are connected with intrasite circuits. Each circuit consists of two interfaces that are 
delineated by the line in the middle of the circuit.

Note that sites can also contain other sites, and nodes do not have to be contained within sites.

Task: View network, site, and interface plots. 
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Step 1 If euro4.txt file is not open, select the File->Open menu. Browse to the $CARIDEN_HOME/samples 
directory and open the euro4.txt file.

Step 2 In the network plot (Figure 2-2), notice the four sites. These are connected by 622 Mbps (OC12/STM4) 
circuits. LON and AMS are connected by two such circuits. This information is listed in the Capacity 
Sim column of the Interfaces table.

Figure 2-2 Network Plot of Sample European Plan File 

Step 3 Open a site plot. 

a. Double-click on the LON site to see its details. Notice that the LON site contains three nodes 
connected by intrasite circuits.

b. Click each of the outbound interfaces and notice the selection (blue highlight) of the same interface 
in the network plot.

c. Close the site plot by clicking on the top, right X.

Step 4 Open an interface plot.
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a. Click the orange interface coming out of LON and going towards AMS. 

b. Press and hold the Ctrl key (Cmd on Mac) while selecting the green interfacing coming out of LON 
going towards PAR. Both interfaces are now selected.

c. Right-click on either of these interfaces and select Plot Interfaces from the context menu. An 
interface plot appears (Figure 2-3).

d. Click in an ow plot area to deselect them from both the interface and the network plots. 

Now click on each of the interfaces in the interface plot and notice that they are selected in the 
network plot.

e. Close the interface plot by clicking on the top, right X.

Step 5 If continuing with these tutorials, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.

Figure 2-3 Interface Plot
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Work with Tables and Object Selections
This section familiarizes you with the basic dynamics between tables and objects, such as nodes, sites, 
circuits, interfaces, and ports. When you select an object in a table, it is automatically selected in the 
network plot. Conversely, whatever you select in the network plot is selected in the tables. 

Task: Show different tables and select objects. Each time you make a selection, observe what happens 
in the tables and in the network plot to see their relationships.

Step 1 If euro4.txt file is not open, select the File->Open menu. Browse to the $CARIDEN_HOME/samples 
directory and open the euro4.txt file.

Step 2 Notice that the Interfaces tab is selected. Click on the Sites tab to show the Sites table.

Step 3 In the network plot, click on various sites, and each time notice the blue highlight in the left column of 
the Sites table. Also notice that each time you select a new site, the other is no longer selected. This is 
because selecting an individual object deselects all others.

Step 4 Show the Circuits table, which is not in the default table tabs.

a. Right-click on any of the table tabs and select Show/Hide Tables from the context menu.

b. Click on the empty F (false) box on the Circuits row to turn this F to T (true).

c. Click OK. The Circuits table tab appears.

d. Click on the Circuits tab to show the Circuits table.

Step 5 In the Circuits table, select on the PAR-LON circuit. Press and hold Ctrl (Cmd on Mac) while clicking 
on the AMS-FRA circuit. Notice that both rows are highlighted as are the corresponding circuits in the 
network plot. 

This selects four interfaces, which is two interfaces per circuit. To verify these selections, in the Circuits 
table right-click on either of the two selected circuits, and select Filter to Interfaces from the context 
menu. The Interfaces table shows the four interfaces that are selected in the network plot.

Step 6 In the Interfaces table, click the Show All button.

Step 7 Click the top row of the Interfaces table. Press and hold Shift while clicking on the fourth row. All four 
interfaces are selected both in the table and in the plot. Two of these interfaces are intrasite as indicated 
by the small square appearing on top of the AMS site. 

a. Double-click on the AMS site to see the selected interface. 

b. Close the site plot by clicking on the top, right X. 

c. Click in an empty plot area to deselect the interfaces.
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Step 8 If continuing with these tutorials, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.

Change Circuit Capacity Width
Circuits are drawn to show the relationship of their capacity to their utilization. By default, the width of 
the circuit is proportional to the capacity, down to a predefined minimum width, and the interfaces 
appear without explanatory text. The Plot Options icon opens a dialog box where you can change the 
relationship between width and capacity, and control the minimum width and rate at which the width 
changes for different capacities.

Task: Change the relationship between circuits’ width and their capacity.

Step 1 If euro4.txt file is not open, select the File->Open menu. Browse to the $CARIDEN_HOME/samples 
directory and open the euro4.txt file.

Step 2 Click the Plot Options icon in the top, right of the visualization toolbar; a Plot Options dialog box 
appears.

Step 3 In the Design Circuits tab, change the value in the “Circuits set to min width for capacity below” field 
from 580 to 50, and click OK.
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Step 4 Notice that all circuits are wider than the minimum now because their capacities all exceed 50 Mbps. 
Notice how much wider the circuits are now.

Step 5 Double-click on the LON site to open its site plot. Notice that some circuits show at the minimum width 
with no fill color; this is because these circuits do not have a specified capacity.

Step 6 Re-open the Plot Options dialog box and change the setting back to the default of 580, and press OK.

Step 7 If continuing with these tutorials, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.

Determine Traffic Utilization
WAE Design shows either measured network traffic or simulated traffic, depending on the view. The 
color fill of an interface shows the bandwidth utilization for traffic leaving that interface in proportion 
to the interface capacity. That is, it shows the traffic utilization.

The exact utilization of any circuit is listed in the tables where all the quantitative parameters of the 
network are available. The colors and thresholds are fully customizable from the Utilization Color menu.

Task: Determine the traffic utilization threshold using color fills, Util Sim column, and textual 
representations.

Step 1 If euro4.txt file is not open, select the File->Open menu. Browse to the $CARIDEN_HOME/samples 
directory and open the euro4.txt file.

Step 2 Select the green drop-down list in the Utilization Color menu. The range indicates that if an interface is 
green, its traffic utilization is between 30-50%.
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Step 3 In the network plot, select the green part of the circuit between LON and PAR. Right-click on this same 
interface and select Filter to Selection from the context menu. The Interfaces table opens and shows only 
this interface.

Step 4 Note that the Util Sim (simulated) column shows a utilization of 47.75% for this interface, which is 
between the 30-50% level denoted by green as shown in the Utilization Color drop-down menu 
(Figure 2-4). The interface is filled with green that extends to fill almost half of this interface. The other 
half of the circuit displays the traffic utilization for the reverse direction, which is 0% for this interface.

Step 5 In the Interfaces table, click the Show All button.

Step 6 Identify the percentages by displaying them on all interfaces.

a. Click on the Plot Options icon; the Plot Options dialog box appears.

b. In the Design Circuits tab, Interface Text list, select “Percentage of interface filled.”

c. Click OK. The interfaces now show the numeric utilization percentage (Figure 2-5).

Compare these numbers to those in the Util Sim column to see they are the same.

d. Re-open the Plot Options dialog box, change the Interface Text back to None, and click OK.

Step 7 If continuing with these tutorials, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.
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Figure 2-4 Traffic Utilization on cr1.lon-cr1.par Interface
2-9
Cisco WAE Design 6.3 Tutorials

    



    

Chapter 2      Getting Started with WAE Design
  Determine Traffic Utilization
Figure 2-5 Traffic Utilization in Text Format

Most Highly Utilized Interface
There are two ways to identify the most utilized interfaces, which is useful when analyzing large, 
complex networks.

Task: Determine the most highly utilized interfaces in the network using each of the following methods.

Method: Sort Util Sim Column

Step 1 If euro4.txt file is not open, select the File->Open menu. Browse to the $CARIDEN_HOME/samples 
directory and open the euro4.txt file.

Step 2 In the Interfaces table, click on the Util Sim column heading to sort the interfaces by descending order. 
Click it two more times to notice this is a toggle for sorting columns between ascending and descending 
order. 

Step 3 Notice that the most utilized interface is at 87.06% of capacity, which is the top row. Select this top row. 
The interface highlighted in the plot is the most highly utilized interface.

Step 4 Use the down arrow to move downward row to row, each time finding the next most highly utilized 
interface. Each selection is highlighted in the plot and its exact utilization value is visible in the Util Sim 
column of the selected row. 
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Step 5 Click in an empty plot area to deselect the interfaces.

Method: Select Max Value in Utilization Color Menu

Step 1 Select the purple drop-down list in the Utilization Color menu to see that the maximum utilization value 
is 100%. Select Max. This resets the maximum threshold percentage to the most highly utilized interface, 
which color fills that interface, cr2.lon-cr1.ams, to purple. 

Step 2 Select the purple drop-down list again to see that maximum is now 87.06%. Verify this by reading its 
Util Sim value in the Interfaces table, which is also 87.06% (Figure 2-6). 

Step 3 In this same purple drop-down list, select <87.06%. This highlights the second most highly utilized 
interface, which is cr1.ams-cr2.fra. 

Step 4 Set the maximum utilization back to 100% by restoring the system default colors.

a. Select the Edit->Plot->Plot Options->Apply System Defaults menu.

b. Select the purple drop-down list again to see that maximum is now 100%.

Step 5 If continuing with these tutorials, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.
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Figure 2-6 Interface with Highest (Max) Utilization

Simulate Traffic Using Demands
Several WAE Design tables have columns that identify how much traffic is being carried or what 
percentage of the capacity is being utilized. For example, the Interfaces table has a Util Sim column that 
reflects simulated traffic utilization. The two basic inputs to the simulation are the network configuration 
itself and a set of traffic demands. A demand is a request for a specified amount of traffic to be sent from 
one node, the source, to another node, the destination. The routes taken are based on traffic, topology, 
network health, as well as the protocols used.

Task: Determine which service classes are associated with demands, read demand traffic and latency, 
and identify demands route in the network plot.

Step 1 Select the File->Open menu. Browse to the $CARIDEN_HOME/samples directory and open the euro4.txt 
file.
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Step 2 Click the Demands tab to show the Demands table. Notice that this network contains only six demands, 
all from the er1.lon edge node in the LON site to the edge notes in other sites.

Step 3 Show the Service Class column (Figure 2-7).

a. Right-click on any heading in the Demands table and select Show/Hide Columns.

b. In the top, right Search field, enter the word “service” and press Enter. The search feature locates 
all columns and column descriptions containing this word. 

c. Click the empty F (false) box on the Service Class row to turn this F to T (true).

d. Click OK. The Service Class column appears.

Figure 2-7 Search for and Show Column Names

Step 4 Click the Service Class column heading to sort demands by service class, noting that half the demands 
represent Internet traffic and half represent voice traffic.

Step 5 Read the Traffic column values to determine how much traffic each demand is attempting to route. 

Step 6 Determine the sum of the delays for all the interfaces on the longest path taken by each demand.

a. In the Demands table, right-click the Maximum Latency column heading to see that its sum value is 
zero.

b. Verify this value by reading the Delay Sim column in the Interfaces table. They, too, are zero. 

Select the Interfaces table tab, and then right-click on any of its headings and select Show/Hide 
Columns.

Click the empty F (false) box on the Delay Sim row to turn this F to T (true).

Click OK. The Delay Sim column appears.

Right-click this Delay Sim column heading to see that its sum value is zero.

Step 7 In the Demands table, select the demand from er1.lon to er1.par. The network plot shows this demand 
from LON to PAR sites using a blue arrow to show the route, an A to show the source, and a Z to show 
the destination (Figure 2-8). 
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Figure 2-8 Single-Path Demand Route

Step 8 Use the up and down arrow keys to move from row to row in the Demands table, highlighting each 
demand and showing its routing in the network. 

Notice the er1.lon to er1.ams demand takes two equal-cost multipath (ECMP) routes along two parallel 
circuits. Two blue lines show 50% of the traffic flowing through each of these circuits (Figure 2-9).

Step 9 Right-click the er1.lon to er1.ams demand, and select Plot Demand from the context menu. This view 
shows the details of the demand route (Figure 2-9).

Step 10 Close the demand plot. 

Step 11 Click in an empty plot area to deselect the demand.

If continuing with these tutorials, keep this plan open for the next task. If stopping here, select the 
File->Close menu to close this file without saving it.
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Figure 2-9 ECMP Demand Route and Associated Demand Plot

Modify Demand Traffic
You can modify demand traffic to determine the effects such changes in traffic have on the network. 
These modifications can be applied to regions or sites, or they can apply uniformly over the network, 
such as in the following task. 

For instance, you might increase demand traffic to plan for future traffic growth by simulating an overall 
traffic growth trend. Another example use might be to determine the network impact of an anticipated 
increase in sales of a particular service, such as video on demand. 

Task: Simulate an increase in voice traffic by 50%.

Step 1 Select the File->Open menu. Browse to the $CARIDEN_HOME/samples directory and open the euro4.txt 
file.

Step 2 Locate all voice demands by filtering to them. 

a. Click the Demands tab to show the Demands table. 

b. Click the Filter control menu; the Filter dialog box appears (Figure 2-10).

c. In the empty field on the Service Class Contains row, enter voice.

d. Click OK. The Demands table shows only three demands representing voice traffic.

e. Notice the values listed in the Traffic column are 63, 89, and 142 Mbps.
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Figure 2-10 Filter to Voice Demands

Step 3 Increase the demand traffic for all voice demands by 50% (Figure 2-11).

a. Select all rows that are currently showing in the Demands table by select one demand and then 
pressing Ctrl-A (Cmd-A on Mac).

b. Right-click on any row and select Modify Demand Traffic from the context menu.

c. Enter the value “50” in the “Change traffic by ___ %” field, and click OK.

Figure 2-11 Modify Voice Demand Traffic

Step 4 Click anywhere in the empty plot area to remove the demand selections.
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Step 5 Read the values in the Traffic column and note they have increased by 50% to 94.5, 133.5, and 213 Mbps. 
The plot shows that modifying this traffic created severe congestion between LON and AMS as noted 
by the purple color fill (Figure 2-12). Compare, for example, the color of interfaces between LON and 
AMS to those prior to the simulated traffic increase (Figure 2-8).

Step 6 Select the File->Close menu to close this file without saving it.

Figure 2-12 Voice Demand Traffic Increased by 50%

Edit Topology
WAE Design tools enable you to edit the network topology so that you can add, delete, and move objects. 
Some tools, such the duplication function, can greatly simplify the redesign of a complex network. 

Once topology changes are made, demands are rerouted, showing the resulting utilization changes in the 
new network.

Task: Create a new site by duplicating an existing one, place it in its geographically correct location, 
and observe how traffic is rerouted as a result of the topology change. 
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Step 1 Select the File->Open menu. Browse to the $CARIDEN_HOME/samples directory and open the euro4.txt 
file.

Step 2 Since you are determining the effect of adding a site, view the demand route before editing the topology. 

a. Click the Demands tab to show the Demands table. 

b. Select the er1.lon-er1.fra demand. Notice that the demand goes from LON (source) through AMS 
and to FRA (destination)

c. Click anywhere in the empty plot to deselect the demand.

Step 3 Create a BRU site by duplicating the AMS site. 

a. Right-click on the AMS site, and select Duplicate from the context menu. 

b. Enter BRU as the name of the new site, and click OK. The new site appears with the same intrasite 
and intersite circuit structure. 

c. Double-click on the new BRU site to see that the nodes have been duplicated from the old site, but 
renamed appropriately. Close this site plot.

d. Right-click on the newly created BRU site, and select Properties from the context menu. The 
Properties dialog box appears (Figure 2-13). The Location was copied as AMS, and the Longitude 
and Latitude fields give the airport location code for AMS.

Change the Location field to BRU and press Enter (do not press OK yet). The Location, Longitude, 
and Latitude fields update to show the airport location for Brussels.

Click OK. 

Figure 2-13 Duplicate AMS Site and Name it BRU

Step 4 Place the site on the plot using its newly updated geographic location (Figure 2-14). 

a. Click on the Sites table tab to show the Sites table.

b. Click the Show All button.

c. In the Sites table, select one site and then press Ctrl-A (Cmd-A on Mac) to select all the sites.

d. Right-click the plot background, and select Arrange from the context menu.
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e. Click the Earth icon. The BRU moves to its proper geographic location. The 
$CARIDEN_HOME/samples/euro4_bru.txt file shows the same network with this change.

Figure 2-14 New BRU Site

Step 5 Observe the effect of adding this new site as it reroutes the er1.lon-er1.fra demand. 

a. Click on the Demands tab to show the Demands table. 

b. Select the er1.lon-er1.fra demand (Figure 2-15). Half the traffic now routes through AMS and half 
through BRU.

Step 6 Select the File->Close menu to close the file without saving it.
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Figure 2-15 Rerouted Demand
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	Step 4 Click the Service Class column heading to sort demands by service class, noting that half the demands represent Internet traffic and half represent voice traffic.
	Step 5 Read the Traffic column values to determine how much traffic each demand is attempting to route.
	Step 6 Determine the sum of the delays for all the interfaces on the longest path taken by each demand.
	Step 7 In the Demands table, select the demand from er1.lon to er1.par. The network plot shows this demand from LON to PAR sites using a blue arrow to show the route, an A to show the source, and a Z to show the destination (Figure 2-8).
	Figure 2-8 Single-Path Demand Route

	Step 8 Use the up and down arrow keys to move from row to row in the Demands table, highlighting each demand and showing its routing in the network.
	Step 9 Right-click the er1.lon to er1.ams demand, and select Plot Demand from the context menu. This view shows the details of the demand route (Figure 2-9).
	Step 10 Close the demand plot.
	Step 11 Click in an empty plot area to deselect the demand.
	Figure 2-9 ECMP Demand Route and Associated Demand Plot

	Modify Demand Traffic
	Step 1 Select the File->Open menu. Browse to the $CARIDEN_HOME/samples directory and open the euro4.txt file.
	Step 2 Locate all voice demands by filtering to them.
	Figure 2-10 Filter to Voice Demands

	Step 3 Increase the demand traffic for all voice demands by 50% (Figure 2-11).
	Figure 2-11 Modify Voice Demand Traffic

	Step 4 Click anywhere in the empty plot area to remove the demand selections.
	Step 5 Read the values in the Traffic column and note they have increased by 50% to 94.5, 133.5, and 213 Mbps. The plot shows that modifying this traffic created severe congestion between LON and AMS as noted by the purple color fill (Figure 2-12). C...
	Step 6 Select the File->Close menu to close this file without saving it.
	Figure 2-12 Voice Demand Traffic Increased by 50%



	Edit Topology
	Step 1 Select the File->Open menu. Browse to the $CARIDEN_HOME/samples directory and open the euro4.txt file.
	Step 2 Since you are determining the effect of adding a site, view the demand route before editing the topology.
	Step 3 Create a BRU site by duplicating the AMS site.
	Figure 2-13 Duplicate AMS Site and Name it BRU

	Step 4 Place the site on the plot using its newly updated geographic location (Figure 2-14).
	Figure 2-14 New BRU Site

	Step 5 Observe the effect of adding this new site as it reroutes the er1.lon-er1.fra demand.
	Step 6 Select the File->Close menu to close the file without saving it.
	Figure 2-15 Rerouted Demand



