
   

   
C H A P T E R 21

LSP Optimization

This chapter describes two LSP optimization tools.

• The Explicit LSP Optimization tool optimizes the placement of primary and secondary paths for 
selected LSPs. 

• The Tactical Explicit LSP Optimization tool is a subset of the functions in the Explicit LSP 
Optimization tool for quicker mitigation of local congestion.

Explicit LSP Optimization 
The Explicit LSP Optimization tool minimizes congestion by optimizing the placement of primary and 
secondary paths for selected LSPs. By default, WAE Design minimizes the utilization across primary 
paths under normal operation and creates disjoint secondary paths so that a single failure cannot disrupt 
both paths simultaneously. 

Select the Tools->Explicit LSP Optimization menu. 

• Objectives for optimizing explicit LSP paths are specified in the Primary Paths, Secondary Paths, 
and Tertiary Paths sections of the dialog box. 

• Selections and Results, such as which interfaces and LSPs to operate on, whether to tag the new LSP 
routes, and whether to open plan files are specified in the lower, right section of the dialog box.

• Further Optimization Details, such as how to handle non-optimized interfaces and whether to 
maintain or discard LSP properties, are set by clicking the Details button.

The default is to optimize utilization on all interfaces using all LSPs on those interfaces. Another default 
is to remove CSPF constraints, such as affinities and hop limits. For example, WAE Design sets the setup 
bandwidth to 0, thus providing the greatest flexibility when setting these explicit paths. Note that you 
can change these and other default behaviors.

Upon completion, WAE Design tags the LSPs with expopt and generates a new plan file named with an 
-eopt suffix. This plan file opens, showing the LSPs table that is filtered to these rerouted (and newly 
tagged) LSPs. Saving this plan file then simplifies the process of identifying which LSPs to reconfigure 
in the network. 

WAE Design also writes a report containing the results of the optimization. To access this information 
later, select the Window->Reports menu. 
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Primary Paths 
This section of the dialog box enables you to specify objectives for primary path selections.

• Primary Paths—Define whether to reroute primary LSP paths. 

– Optimized—Create optimized explicit primary paths based on the objectives selected. 

– Keep—Route LSPs along the existing primary paths.

Primary paths are optimized using the following three objectives in order of priority. The first two 
objectives (1 and 2) move LSPs away from their shortest latency path in an attempt to reduce the 
utilizations of the most highly utilized interfaces in the network. 

• 1. Minimize # of interfaces with utilization > _[80]_ x% —Specify a percentage and minimize the 
number of selected interfaces with utilizations over that percentage under normal operation 
(default). 

• 2. Minimize maximum interface utilization—Route primary paths so that the maximum interface 
utilization over all selected interfaces is minimized under normal operation. 

• 3. Balance across equal latency paths—Balance utilizations over lower utilized interfaces. For 
example, use this option to balance utilizations on parallel interfaces between two nodes if the two 
interfaces have the same latency. 

– Utilization threshold—Keep the number of interfaces with utilization greater than this value as 
low as possible without significantly increasing the latencies of the primary paths.

– Latency tolerance—Permit this percentage of additional latency. 

• Enforce latency bounds—Enforce latency bounds that can be specified for some or all demands in 
the plan file. If selected, this option takes precedence over all of the above objectives. For 
information on setting latency bounds, see the Plan Objects chapter. 

Secondary Paths 
This section enables you to specify objectives for secondary path selections.

• Secondary Paths—Define whether and how to route secondary paths. 

– Optimized—Create optimized explicit secondary paths based on the objectives selected.

– Dynamic—Route secondary paths dynamically. No explicit hops will be created for the path.

– None—No secondary paths are created; existing paths are removed. 
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• Hot Standby—Set the secondary path to be a hot standby, which means it is established at the same 
time as the primary path, rather than after the primary path fails.

For optimized secondary paths, the following three objectives are used in order of priority listed. 

• 1. Maximize primary/secondary path disjointness with respect to—Define primary and secondary 
paths for each LSP that are disjoint with respect to circuit, SRLG, node, and Layer 1 (L1) link 
failures, depending on what is selected. 

– Circuits—No circuit is used by both the primary and secondary paths (default = 1).

– SRLGs—No SRLG is used by both the primary and secondary paths (default = 2).

– Nodes—No node is used by both the primary and secondary paths (default = 3).

– L1 Nodes—No L1 node is used by both the primary and secondary paths (default = 3).

– L1 Links—No L1 link is used by both the primary and secondary paths (default = 3).

– Traffic disjointness only—A path is acceptable even if it uses similar circuits, SRLGs, or nodes 
as other paths provided there is no traffic routed over the LSP when failures occur.

You can specify the degree of disjointness of primary and secondary paths. The lower the number, 
the higher the disjointness priority. For example, if it is important that the paths are node disjoint 
and the SRLG disjointness are less important, you could change the setting to circuits 1, nodes 2, 
and SRLGs 3.

Note that the network topology sometimes makes it impossible to fulfill all the selected disjointness 
requirements. In this case, paths are selected that are maximally disjoint. That is, they are disjoint 
for as many circuits, SRLGs, nodes, L1 nodes, and L1 links as possible. 

• Options 2 and 3 both operate on the selected failure scenarios (circuits, SRLGs, nodes, L1 nodes, 
and L1 links) listed in the “Failures to consider” options listed under 3. These choices are the failure 
scenarios over which the simulation is performed at the end of the optimization. Note that this 
selection of failure scenarios is distinct from the failure scenarios selected for the disjointness 
objective 1.

– 2. Minimize # of interfaces with utilization > ___ % —Minimize the number of interfaces with 
utilizations over the specified percentage across all selected failure scenarios. 

– 3. Minimize maximum interface utilization—Minimize the maximum interface utilization over 
all interfaces and over all selected failure scenarios. 
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Tertiary Paths 
This section specifies the tertiary path configuration.

• Tertiary Paths—Define whether to create tertiary paths. 

– Dynamic—Create dynamic tertiary paths.

– None—No tertiary paths are created.

• Hot Standby—Set the tertiary path to be a hot standby path, which means it is brought up with the 
primary path, rather than after the primary path fails. 

Selections and Results 
These options identify which interfaces are used, whether LSPs are tagged, and whether to create new 
plan files containing the results.

The default is to optimize LSP paths on all selected interfaces, and by default, all interfaces are 
considered selected. You can, however, optimize a limited number of interfaces or specify a set of LSPs 
by pre-selecting them or by using tags.

• Optimized Interfaces—Identify which interfaces to optimize: all interfaces, those selected prior to 
opening the dialog box, or those with specific tags. 

• Using LSPs—Specify which LSPs are candidates for rerouting. The default is all the LSPs currently 
routed on the selected interfaces.

• Tag changed LSPs—Create and add tags to all LSPs rerouted during optimization. Using tags makes 
it easier to find the LSPs that need to be reconfigured in the actual network according to the 
optimization results. By default, newly optimized LSPs are tagged as expopt.

• New plan for result—This default option creates a new plan with the results of the optimization. 
Unless a name is specified, WAE Design attaches an -eopt suffix to the current plan file name. If not 
selected, WAE Design changes the current plan file with the updated information.

Further Optimization Details
The Details button opens a dialog box wherein you can identify less frequently used parameters, such as 
traffic levels and how to treat non-optimized interfaces.

• Non-Optimized Interfaces—You can specify whether to ignore non-optimized interfaces or set the 
acceptable level of utilization for them. 
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If setting an acceptable utilization level and if both options are selected, WAE Design uses the higher 
of the two. These settings are calculated on a per-interface basis.

– Acceptable utilization of optimized interfaces: ___% —This value is the same as the utilization 
threshold set in the Primary Path section, option 1 (Minimize # of interfaces with utilization > 
___%, where the default is 80). Therefore to change this value, you must change it in the 
Primary Path section.

If using the Tactical Explicit LSP Optimization tool, this field is equivalent to, and thus only 
changeable in, the Acceptable Utilization ___% field.

– Current utilization + ___% —Current utilization of non-optimized interfaces plus the added 
percentage.

Example: There are two non-optimized interfaces: cr1.chi_cr1.mia has a utilization of 60% and 
cr2.sjc_cr2.okc has a utilization of 78%.

The acceptable utilization settings for non-optimized interfaces are as follows.

– The primary path utilization threshold is 80%.

– The current utilization has 5% added to it.

Result: The maximum utilization for each interface is individually calculated. The acceptable level 
of utilization for cr1.chi_cr1.mia is 80%, and the acceptable level of utilization for cr2.sjc_cr2.okc 
is 83% (78 + 5).

• LSP Configuration, Create Fully Explicit Named Paths For—By default, WAE Design creates 
named paths across the LSPs that were selected if a reroute is required to achieve the optimization 
objectives. For instance, if a selected dynamically routed LSP has an acceptable route, WAE Design 
does not create a named path for it. 
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To change this default, select “all selected LSPs.” WAE Design then creates and routes fully explicit 
named paths for all selected LSPs.

• LSP Configuration, In Addition—By default, WAE Design sets the Setup BW to zero, providing the 
greatest flexibility when creating explicit routes. As well, all affinities and hop limits are removed, 
and the setup and hold priorities are set to 7. These changes apply only to the LSPs with newly 
created or changed explicit named paths.

You can turn off these defaults, and you can also set them individually after the optimization is 
performed using the LSP Paths Properties dialog box. (In the LSP Paths table, right-click an LSP 
path and select Properties.) If these defaults are turned off, the original parameters are preserved.

• Traffic Level—Select the traffic level you want used in the utilization calculations and 
optimizations. For information on traffic levels, see the Traffic Demand Modeling chapter.

• Rerouting Preference—By default, preferences on which LSPs to reroute are not based on traffic 
volume. You can select high-traffic or low-traffic options to sequentially give priority to LSPs with 
higher and lower traffic, respectively. 

Tactical Explicit LSP Optimization
The Tactical Explicit LSP Optimization tool is a reduced version of the Explicit LSP Optimization tool. 
This tool optimizes only primary paths using the minimum number of path changes required to bring 
utilizations below an acceptable level. It is useful when you need to reduce congestion in a specific area 
of the network with a limited number of LSP reconfigurations.
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As described in the Selections and Results section, if you need to target specific interfaces or LSPs to 
confine the optimization to problem areas., then select those interfaces or LSPs first. Then select the 
Tools->Tactical Explicit LSP Optimization menu.

• Acceptable interface utilization___% — Maximum allowable traffic utilization on interfaces used 
in the optimization.

• Details button—See the Further Optimization Details section.

• All other options—See the Selections and Results section.

Related Topics
• MPLS Simulation chapter

• RSVP-TE Simulation chapter

• RSVP-TE Optimization chapter

• LSP Loadshare Optimization chapter
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