
   

   
C H A P T E R 15

BGP Simulation

This chapter describes how WAE Design models multi-AS networks and simulates basic BGP routing. 
WAE Design does not directly emulate BGP routing configurations, such as local prefs and MEDs. 
Rather, it provides a high-level modeling of typical peering policies, such as standard customer, transit, 
and settlement-free arrangements for service providers. This model enables you to quickly and easily 
evaluate the effects of peering locations and basic policy variations.

Additionally, you can extend these high-level models to significantly more complex policy-based routing 
situations using external endpoints as demand sources and destinations. For information on demands and 
on external endpoints, see the Traffic Demand Modeling chapter and Advanced Routing with External 
Endpoints chapter, respectively.

Internal and External AS Types
To model a multi-AS network, each node is assigned an AS, and each AS is defined as either internal or 
external. A typical multi-AS model in WAE Design consists of the following. 

• A single internal AS representing the full topology of your network.

• Individual peering nodes of neighboring external AS’s.

• Peering circuits connecting the internal AS to the nodes in the external AS’s.

Thus, generally, there are a large number of external AS’s in the plan file, but usually only one or a small 
number of internal AS’s. All nodes in an external AS are typically placed in the same site, although you 
can place them in any site. Figure 15-1 shows an example model with two internal AS’s and four external 
AS’s.

AS names and their types are defined in the AS Properties dialog box and listed in the AS table. Nodes 
are assigned to AS’s in the node Properties dialog box.
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Figure 15-1 Example Multi-AS Model

Inter-AS Routing 

Route Selection between Internal AS’s
Demands routed within a single AS have a specified source node and destination node where traffic 
originates and terminates. Demands routed between two connecting internal AS’s are specified in the 
same manner: with a source node in the first AS and a destination node in the second.

WAE Design routes within an AS, to and from the border exit point, are determined by the IGP protocols. 
The selection of border exit point is modeled by the Routing Policy, which is set to either Shortest Exit 
or Respect MEDs. This property is set in the Edit AS Relationships dialog box, which is accessed 
through the AS Properties dialog box.

• Shortest exit—The border exit node is selected, which is closest to the source node, within the IGP 
of the source AS. If there is a tie, the exit node with the lowest BGP ID is used.

• Respect MEDs—The border exit node is selected, which is closest to the destination node, within 
the IGP of the destination AS. If there is a tie, the exit node with the lowest BGP ID is chosen. 

Figure 15-2 shows these modeled as two internal AS’s: AS A and AS B. The same demand (A1 to B4) 
is routed using each of the two different routing policies. 
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Figure 15-2 Route Selection Based on Routing Policy

Routes Between External and Internal AS’s
Table 15-1 lists typical routing configurations that can be constructed by applying different 
combinations of Routing Policies for traffic in both directions between two AS's. 

• In a peer relationship, routing in both directions is Shortest Exit, which means each controls its own 
border exit points. 

• For a customer relationship, the customer determines the border exit points for traffic in both 
directions. 

• For a transit relationship, the transit AS provides paid transit to the internal AS, so the internal AS 
determines all border exit points. 

Like traffic routed within an AS, traffic routed between AS’s is represented by demands. However, for 
demands from and/or to external AS’s, the external AS is defined as the source or destination of the 
demand. Optionally, the specific node in the external AS from which the traffic enters or exits the 
internal AS is also specified. 

Failover between nodes in the external AS can be modeled. For example, if the traffic is sourced from 
an external AS and if the peering circuit from which traffic is entering the internal AS under normal 
operation fails, the traffic can enter the internal AS from a different interface or peering node in the same 
external AS. In the Demands table, the sources and destinations are represented as follows.

AS{<ASN>}:if{node_name|interface_name}

Example: AS{33287}:if{cr01.newyork.ny|POS3/7/0/0}

For more detailed information on demand sources and destinations, see the Traffic Demand Modeling 
chapter.

Table 15-1 Typical AS Routing Configurations

Type Policy To Policy From

Peer Shortest Exit Shortest Exit

Customer Respect MEDs Shortest Exit

Transit Shortest Exit Respect MEDs
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The AS that controls the routing chooses which peering node to use. If the internal AS controls the 
routing, then because the topology of the internal AS is known, you can simulate the routing to the 
peering node. However, since WAE Design has limited knowledge of the external AS topology, if the 
external AS controls the routing, you cannot predict how traffic will be distributed among the exit points. 

The AS that controls the routing is determined by the AS type, direction of the demand, and the Routing 
Policy property as described in Table 15-2. 

Two AS’s can be in one of four different routing relationships to one another, depending on which of the 
two routing policies is chosen in each direction (Table 15-3). 

• If traffic is routed to an external AS when it has control and there is no knowledge of its topology, 
a set of demands is created from the source in the internal AS (or from another external AS), each 
with a destination set to one of the border nodes in the external AS. This way, any division of traffic 
between the exit points can be modeled. 

• If traffic is routed to an external AS when an internal AS has control, a single demand is created 
from the source to the AS itself. WAE Design simulations determine the correct exit point for this 
single demand based on the source.

• If traffic is to be routed from an external AS when it has control, then a demand is created from each 
node in the external AS to each node in the internal AS.

• If traffic is to be routed from an external AS when an internal AS has control, then a demand is 
created to each node in the internal AS using the external AS as the source. The demand originates 
from one or multiple nodes in the external AS, depending on the topology and the metric cost to 
reach the destination node. For example, a single demand from an external AS to a specific node 
could be sourced from two different nodes in the external AS, each carrying 50% of the demand 
traffic.

Table 15-2 Determining the AS that Controls the Routing

Direction Routing Policy AS with Routing Control

External AS to Internal AS 
(Ingress)

Respect MEDs Internal

Shortest Exit External

Internal AS to External AS 
(Egress)

Respect MEDs External

Shortest Exit Internal
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External Meshes
An external mesh consists of two or more external AS’s with a Type property of External. An internal 
AS typically restricts advertisement of BGP routes for some external AS’s to other external AS’s. For 
example, destinations reachable through the transit network would not be advertised to a peer, or vice 
versa. In WAE Design, these restrictions are represented by the absence of demands between the two 
external AS’s.

Each AS has a property called External Mesh, which WAE Design uses when inserting demand meshes 
into a plan. Demands are created for external AS’s only if one or both AS’s have External Mesh set to 
Include. If both AS’s are set to Exclude, no demands are created for the external AS. For example, in 
Figure 15-3 the peer and transit AS’s are both set to Exclude, so no demands are created between those 
AS’s. All other external AS demands are included in the demand mesh. Table 15-4 shows the External 
Mesh settings for common AS relationships.

The External Mesh property is set in the AS Properties dialog box.

For internal AS’s, the External Mesh property is ignored. More complex route advertisement policies 
cannot be represented by these simple External Mesh settings. In this case, demand mesh creation must 
be performed in several steps, possibly using a script and the dmd_mesh_creator CLI tool.

Table 15-3 Effects of Routing Policy and Routing Control

Direction Routing Policy
AS with Routing 
Control

Demand Source or Destination 
Endpoint in Remote AS

Number of 
Demands

External AS to Internal AS 
(Ingress)

Respect MEDs Internal Entire external AS One only

Shortest Exit External Border nodes One for each node

Internal AS to External AS 
(Egress)

Respect MEDs External Border nodes One for each node

Shortest Exit Internal Entire external AS One only

Table 15-4 External Mesh Settings for Common AS Relationships

Relationship External Mesh Setting Result

Peer Exclude Demands permitted to/from customers only

Customer Include Demands permitted to/from all external AS’s

Transit Exclude Demands permitted to/from customers only
15-5
Cisco WAE Design 6.3.1 User Guide

   



   

Chapter 15      BGP Simulation
  BGP Simulations
Figure 15-3 External Mesh Control

BGP Simulations
As with all WAE Design simulations, AS routing uses demands. An IP simulation for a particular failure 
scenario and traffic level performs these steps. 

Step 1 Demands are routed using the established LSPs (if applicable) and using the specified BGP protocols 
given the specified failure scenarios. 

Step 2 Interface utilizations are calculated from the demand traffic using the specified traffic level. 

WAE Design allows routes to be calculated between selected nodes even if no demands are present. In 
this case, only the first step applies. 

BGP demands do not failover between external AS’s. That is, all traffic to or from an external AS 
behaves the same under peering failures to an external AS. You can change this default behavior using 
external endpoints to simulate specific external AS nodes where traffic goes in and out of the network, 
as well as set priorities so that if one traffic source or destination goes down, the traffic can still be 
sourced from or delivered to another external AS node.
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BGP Routing Details

BGP Multihop

WAE Collector automatically constructs BGP pseudonodes where necessary when BGP multihops are 
detected.

WAE Design models the nodes in external AS’s that are directly connected, for example through eBGP, 
to nodes in internal AS’s. One exception is that you can model BGP multihops by setting the node Type 
property to psn (pseudonode), such as might occur at a peering exchange. This pseudonode can represent 
the switch that connects a number of external AS nodes to the same internal AS node. In this instance, 
multiple external AS nodes are connected by circuits to a BGP psn node, and this node is connected to 
a node in the internal AS.

Note In all cases, eBGP multipaths across parallel border circuits is assumed.

BGP Load Balancing

BGP load balancing to an external AS uses eBGP multipaths or eBGP multihops. WAE Design models 
these two eBGP load balancing designs in the same manner, though in the GUI they are identified only 
as multipaths. BGP multipath options are disabled by default.

To set BGP multipath options globally, follow these steps.

Step 1 Select the Edit->Network Options menu or the Network Options icon from the Visualization tool bar.

Step 2 Select the Protocols tab.

Step 3 For each BGP multipath option that you want enabled, select Enabled, and then click OK.

• EBGP Multipath—Turns on eBGP multipath within the internal AS’s. Demand routings through the 
internal AS to an external AS are divided among external routes with equal-cost BGP exit routes. 

• EBGP Multipath Incoming—Turns on eBGP multipath in all external AS’s. Demand routings from 
external AS’s into an internal AS are divided among external routes with equal-cost BGP exit routes.

• IBGP Multipath—Turns on iBGP multipath within the internal AS’s. Demand routes through an 
internal AS to an external AS are divided among internal paths to equal-cost BGP exit routes.
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BGP Next Hop

In networks, there are two common configurations for the BGP next-hop IGP metric used in the path 
selection. One is to set the next-hop self on the iBGP peers (next-hop self = on). The other is to configure 
IGP metrics on eBGP interfaces, and to inject the interface prefix into the IGP database by setting the 
interface to be a passive IGP interface (next-hop self = off).

WAE Design does not have an explicit next-hop self setting so it simulates paths as if next-hop self is 
off. That is, the IGP metric of the egress peering interface is included in the IGP distance to the peering 
router and is used in the iBGP path selection. However, next-hop self to an external AS can effectively 
be simulated by setting the metrics on all egress interfaces to that external AS to 0. (You can set the IGP 
metric in either the Interfaces Properties or Circuit Properties dialog box accessed through the context 
menu.)

Trim AS’s
A plan file created through WAE Collector BGP discovery typically has more external AS’s in the plot 
than you are interested in viewing or simulating. Some AS’s might have very low traffic levels and others 
might have only one circuit connecting into the internal AS. You can trim these unwanted AS’s to 
simplify the network. Trimming removes the AS from the plan file, but retains the traffic in and out of 
the AS for simulation. That is, its interface traffic is still included in the total traffic of connected nodes.

Typically, plan files are trimmed before demands are created. However, you can optionally trim demands 
in a plan file. If any demand is sourced from a trimmed external AS, the demand source is moved to the 
first hop on the demand path in the remaining network. Likewise, if a demand has a destination that is a 
trimmed external AS, the demand destination is moved to the last hop in the remaining network. If two 
or more demands in the same service class are trimmed so that their resulting source and destination 
nodes are equal, these demands are aggregated into one demand with their traffic summed. Demands 
split by ECMPs are converted into multiple demands, each with traffic divided proportionally to the split 
ECMP.

Note that multicast demands are removed, and cannot be trimmed.

Step 1 Select one or more AS’s to trim from the AS table.

For example, sort the AS’s by traffic level and then select all AS’s that are below the level of interest. 
Alternatively, filter the table for traffic using the less than operator (<) and the traffic level, and then 
select the filtered AS’s.

Step 2 Right-click one of the selected AS’s and select Trim from the context menu.

Step 3 Optional: Select the option to trim demands. 

By default, the moved demands are named “Trimmed,” though you can enter a different name.

Step 4 Click Yes to confirm the action.
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Create AS’s
Follow these steps to create an empty AS. After creating the AS, you still need to associate nodes with 
it and create the relationship between this AS and others. See Associate Nodes with an AS and Edit AS 
Routing Policies, respectively.

Step 1 Either select the Insert->AS menu, or right-click in the empty plot and select New->AS. The AS 
Properties dialog box appears.

Step 2 Configure the AS properties.

• ASN—AS number, which is a text string that can be a number or name.

• Name—AS name.

• Type—Internal AS’s have a full topology, and external AS’s have a collapsed topology with just 
border nodes and a virtual node.

• External Mesh—When creating a demand mesh, this option tells WAE Design whether to create 
external meshes. When one or both AS’s are set to Include, WAE Design creates a mesh between the 
external AS’s (default). If both are set to Exclude, no demands are created. 

• Description—A text description of the AS.

Step 3 The change the routing policy, click Edit AS Relationships. (The default is Respect MEDs.) For 
information on how these options affect simulation, see the Route Selection between Internal AS’s 
section.

Step 4 Click OK. This creates an empty AS. 
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Associate Nodes with an AS

Step 1 Select one ore more nodes, and double-click any on of them to open a node Properties dialog box.

Step 2 In the drop-down AS list, select the AS to which you want to assign the nodes. Then click OK. 

Edit AS Routing Policies
The way to create AS relationships is to set the Routing Policy. For a description of AS relationships, 
see the Inter-AS Routing section.

Step 1 Select one or more AS’s from the AS table.

Step 2 Follow one of these methods to access the Edit AS Relationships dialog box. 

• Select the Edit->AS Relationships menu.

• Right-click one of the selected AS’s, and select Edit AS Relationships from the context menu.

• Right-click one of the selected AS’s, and select Properties from the context menu. Click Edit AS 
Relationships.
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Step 3 Select the AS pair that you want to configure. There is a separate line for each direction in the 
relationship so you can configure them independently.

Step 4 Click Edit.

a. Set the Routing Policy to Respected MEDs (default) or Shortest Exit.

b. Click OK.

Step 5 Click OK again.

Assign Names to ASNs
WAE Design can assign names to ASNs by looking them up in the $CARIDEN_HOME/etc/ASNs.txt file. 
This file contains a list of all assigned ASNs with their names and descriptions.

Step 1 Select one or more AS’s from the AS table. If no AS’s are selected, names are assigned to all AS’s in the 
plan.

Step 2 Either select the Initializers->Assign Names to ASNs menu, or right-click a selected AS and select 
Assign Names to ASNs from the context menu. 

Step 3 To assign names only if the ASN does not have one, select the “Only those with blank Name fields” 
option. Then click OK. 

Related Topics
• Advanced Routing with External Endpoints chapter
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• Traffic Demand Modeling chapter

• Simulation chapter
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