
   

   
C H A P T E R 17

LSP Optimization

This chapter describes three LSP optimization tools.

• The Explicit LSP Optimization tool optimizes the placement of primary and secondary paths for 
selected LSPs. 

• The Tactical Explicit LSP Optimization tool is a subset of the functions in the Explicit LSP 
Optimization tool for quicker mitigation of local congestion.

• The LSP Loadshare Optimization tool optimizes LSP load balancing percentages between parallel 
LSPs.

Explicit LSP Optimization 
The Explicit LSP Optimization tool minimizes congestion by optimizing the placement of primary and 
secondary paths for selected LSPs. By default, WAE Design minimizes the utilization across primary 
paths under normal operation and creates disjoint secondary paths so that a single failure cannot disrupt 
both paths simultaneously. 

Select the Tools->Explicit LSP Optimization menu. 

• Objectives for optimizing explicit LSP paths are specified in the Primary Paths, Secondary Paths, 
and Tertiary Paths sections of the dialog box. 

• Selections and Results, such as which interfaces and LSPs to operate on, whether to tag the new LSP 
routes, and whether to open plan files are specified in the lower, right section of the dialog box.

• Further Optimization Details, such as how to handle non-optimized interfaces and whether to 
maintain or discard LSP properties, are set by clicking the Details button.

The default is to optimize utilization on all interfaces using all LSPs on those interfaces. Another default 
is to remove CSPF constraints, such as affinities and hop limits. For example, WAE Design sets the setup 
bandwidth to 0, thus providing the greatest flexibility when setting these explicit paths. Note that you 
can change these and other default behaviors.

Upon completion, WAE Design tags the LSPs with expopt and generates a new plan file named with an 
-eopt suffix. This plan file opens, showing the LSPs table that is filtered to these rerouted (and newly 
tagged) LSPs. Saving this plan file then simplifies the process of identifying which LSPs to reconfigure 
in the network. 

WAE Design also writes a report containing the results of the optimization. To access this information 
later, select the Window->Reports menu. 
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Primary Paths 
This section of the dialog box enables you to specify objectives for primary path selections.

• Primary Paths—Define whether to reroute primary LSP paths. 

– Optimized—Create optimized explicit primary paths based on the objectives selected. 

– Keep—Route LSPs along the existing primary paths.

Primary paths are optimized using the following three objectives in order of priority. The first two 
objectives (1 and 2) move LSPs away from their shortest latency path in an attempt to reduce the 
utilizations of the most highly utilized interfaces in the network. 

• 1. Minimize # of interfaces with utilization > _[80]_ x% —Specify a percentage and minimize the 
number of selected interfaces with utilizations over that percentage under normal operation 
(default). 

• 2. Minimize maximum interface utilization—Route primary paths so that the maximum interface 
utilization over all selected interfaces is minimized under normal operation. 

• 3. Balance across equal latency paths—Balance utilizations over lower utilized interfaces. For 
example, use this option to balance utilizations on parallel interfaces between two nodes if the two 
interfaces have the same latency. 

– Utilization threshold—Keep the number of interfaces with utilization greater than this value as 
low as possible without significantly increasing the latencies of the primary paths.

– Latency tolerance—Permit this percentage of additional latency. 

• Enforce latency bounds—Enforce latency bounds that can be specified for some or all demands in 
the plan file. If selected, this option takes precedence over all of the above objectives. For 
information on setting latency bounds, see the Plan Objects chapter. 

Secondary Paths 
This section enables you to specify objectives for secondary path selections.

• Secondary Paths—Define whether and how to route secondary paths. 

– Optimized—Create optimized explicit secondary paths based on the objectives selected.

– Dynamic—Route secondary paths dynamically. No explicit hops will be created for the path.

– None—No secondary paths are created; existing paths are removed. 

• Hot Standby—Set the secondary path to be a hot standby, which means it is established at the same 
time as the primary path, rather than after the primary path fails.
17-2
Cisco WAE Design 6.2 User Guide

   



   

Chapter 17      LSP Optimization
  Explicit LSP Optimization
For optimized secondary paths, the following three objectives are used in order of priority listed. 

• 1. Maximize primary/secondary path disjointness with respect to—Define primary and secondary 
paths for each LSP that are disjoint with respect to circuit, SRLG, node, and Layer 1 (L1) link 
failures, depending on what is selected. 

– Circuits—No circuit is used by both the primary and secondary paths (default = 1).

– SRLGs—No SRLG is used by both the primary and secondary paths (default = 2).

– Nodes—No node is used by both the primary and secondary paths (default = 3).

– L1 Nodes—No L1 node is used by both the primary and secondary paths (default = 3).

– L1 Links—No L1 link is used by both the primary and secondary paths (default = 3).

– Traffic disjointness only—A path is acceptable even if it uses similar circuits, SRLGs, or nodes 
as other paths provided there is no traffic routed over the LSP when failures occur.

You can specify the degree of disjointness of primary and secondary paths. The lower the number, 
the higher the disjointness priority. For example, if it is important that the paths are node disjoint 
and the SRLG disjointness are less important, you could change the setting to circuits 1, nodes 2, 
and SRLGs 3.

Note that the network topology sometimes makes it impossible to fulfill all the selected disjointness 
requirements. In this case, paths are selected that are maximally disjoint. That is, they are disjoint 
for as many circuits, SRLGs, nodes, L1 nodes, and L1 links as possible. 

• Options 2 and 3 both operate on the selected failure scenarios (circuits, SRLGs, nodes, L1 nodes, 
and L1 links) listed in the “Failures to consider” options listed under 3. These choices are the failure 
scenarios over which the simulation is performed at the end of the optimization. Note that this 
selection of failure scenarios is distinct from the failure scenarios selected for the disjointness 
objective 1.

– 2. Minimize # of interfaces with utilization > ___ % —Minimize the number of interfaces with 
utilizations over the specified percentage across all selected failure scenarios. 

– 3. Minimize maximum interface utilization—Minimize the maximum interface utilization over 
all interfaces and over all selected failure scenarios. 

Tertiary Paths 
This section specifies the tertiary path configuration.

• Tertiary Paths—Define whether to create tertiary paths. 

– Dynamic—Create dynamic tertiary paths.
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– None—No tertiary paths are created.

• Hot Standby—Set the tertiary path to be a hot standby path, which means it is brought up with the 
primary path, rather than after the primary path fails. 

Selections and Results 
These options identify which interfaces are used, whether LSPs are tagged, and whether to create new 
plan files containing the results.

The default is to optimize LSP paths on all selected interfaces, and by default, all interfaces are 
considered selected. You can, however, optimize a limited number of interfaces or specify a set of LSPs 
by pre-selecting them or by using tags.

• Optimized Interfaces—Identify which interfaces to optimize: all interfaces, those selected prior to 
opening the dialog box, or those with specific tags. 

• Using LSPs—Specify which LSPs are candidates for rerouting. The default is all the LSPs currently 
routed on the selected interfaces.

• Tag changed LSPs—Create and add tags to all LSPs rerouted during optimization. Using tags makes 
it easier to find the LSPs that need to be reconfigured in the actual network according to the 
optimization results. By default, newly optimized LSPs are tagged as expopt.

• New plan for result—This default option creates a new plan with the results of the optimization. 
Unless a name is specified, WAE Design attaches an -eopt suffix to the current plan file name. If not 
selected, WAE Design changes the current plan file with the updated information.

Further Optimization Details
The Details button opens a dialog box wherein you can identify less frequently used parameters, such as 
traffic levels and how to treat non-optimized interfaces.

• Non-Optimized Interfaces—You can specify whether to ignore non-optimized interfaces or set the 
acceptable level of utilization for them. 

If setting an acceptable utilization level and if both options are selected, WAE Design uses the higher 
of the two. These settings are calculated on a per-interface basis.
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– Acceptable utilization of optimized interfaces: ___% —This value is the same as the utilization 
threshold set in the Primary Path section, option 1 (Minimize # of interfaces with utilization > 
___%, where the default is 80). Therefore to change this value, you must change it in the 
Primary Path section.

If using the Tactical Explicit LSP Optimization tool, this field is equivalent to, and thus only 
changeable in, the Acceptable Utilization ___% field.

– Current utilization + ___% —Current utilization of non-optimized interfaces plus the added 
percentage.

Example: There are two non-optimized interfaces: cr1.chi_cr1.mia has a utilization of 60% and 
cr2.sjc_cr2.okc has a utilization of 78%.

The acceptable utilization settings for non-optimized interfaces are as follows.

– The primary path utilization threshold is 80%.

– The current utilization has 5% added to it.

Result: The maximum utilization for each interface is individually calculated. The acceptable level 
of utilization for cr1.chi_cr1.mia is 80%, and the acceptable level of utilization for cr2.sjc_cr2.okc 
is 83% (78 + 5).

• LSP Configuration, Create Fully Explicit Named Paths For—By default, WAE Design creates 
named paths across the LSPs that were selected if a reroute is required to achieve the optimization 
objectives. For instance, if a selected dynamically routed LSP has an acceptable route, WAE Design 
does not create a named path for it. 

To change this default, select “all selected LSPs.” WAE Design then creates and routes fully explicit 
named paths for all selected LSPs.
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• LSP Configuration, In Addition—By default, WAE Design sets the Setup BW to zero, providing the 
greatest flexibility when creating explicit routes. As well, all affinities and hop limits are removed, 
and the setup and hold priorities are set to 7. These changes apply only to the LSPs with newly 
created or changed explicit named paths.

You can turn off these defaults, and you can also set them individually after the optimization is 
performed using the LSP Paths Properties dialog box. (In the LSP Paths table, right-click an LSP 
path and select Properties.) If these defaults are turned off, the original parameters are preserved.

• Traffic Level—Select the traffic level you want used in the utilization calculations and 
optimizations. For information on traffic levels, see the Traffic Demand Modeling chapter.

• Rerouting Preference—By default, preferences on which LSPs to reroute are not based on traffic 
volume. You can select high-traffic or low-traffic options to sequentially give priority to LSPs with 
higher and lower traffic, respectively. 

Tactical Explicit LSP Optimization
The Tactical Explicit LSP Optimization tool is a reduced version of the Explicit LSP Optimization tool. 
This tool optimizes only primary paths using the minimum number of path changes required to bring 
utilizations below an acceptable level. It is useful when you need to reduce congestion in a specific area 
of the network with a limited number of LSP reconfigurations.

As described in the Selections and Results section, if you need to target specific interfaces or LSPs to 
confine the optimization to problem areas., then select those interfaces or LSPs first. Then select the 
Tools->Tactical Explicit LSP Optimization menu.
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• Acceptable interface utilization___% — Maximum allowable traffic utilization on interfaces used 
in the optimization.

• Details button—See the Further Optimization Details section.

• All other options—See the Selections and Results section.

LSP Loadshare Optimization
The LSP Loadshare Optimization tool automates the process of finding and setting the most favorable 
loadshare ratios across parallel LSPs to balance traffic and avoid congestion. This optimization is based 
on which of the following options are selected. Only interfaces using parallel LSPs are included in the 
optimization.

• Minimize max interface util—Minimize the maximum interface utilization over all interfaces on the 
LSP routes. WAE Design attempts to minimize the number of loadshare parameter changes required 
to do so.

• Minimize number of interfaces with util > ___ %—Minimize the number of interfaces that have a 
utilization greater than the specified value. This is a looser constraint than minimizing the maximum 
interface utilization. Therefore, WAE Design has the opportunity to modify as few Loadshare values 
as possible, thus reducing the amount of reconfiguration required.

• Number of flow bins—Routers typically cannot divide flows arbitrarily between parallel LSPs, but 
instead allocate them to a fixed number of "bins" of approximately equal size. The bins are then 
divided between the parallel LSPs. This option enables you to specify the total number of bins, 
which in turns places a constraint on the traffic division.
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Upon completion, WAE Design tags the LSPs with LSPLoadshare and generates a new plan file named 
with an -Lshare suffix. This plan file opens, showing the LSPs table that is filtered to these rerouted (and 
newly tagged) LSPs. Saving this plan file then simplifies the process of identifying which LSPs to 
reconfigure in the network. Both the tags and the new plan file names are editable.

Also upon completion a report is generated, identifying how many LSPs and interfaces were affected, 
the number of bins used, the resulting maximum interface utilization, and if applicable, the number of 
interfaces with utilization over the specified threshold.

Optimized Loadshare Examples
Minimization Example: The base plan for this example, Acme_Network, contains two sets of parallel 
LSPs, each with a Loadshare value of 1 and each using strict hops on named paths to reach its 
destination. All of these LSPs have a Traff Sim of 3,000 Mbps. The interfaces to which these LSPs filter 
all have a Traff Sim value of 3,000 Mbps, except for sjc-to-okc, which has 6,000 Mbps of simulated 
traffic (Figure 17-1).

• Using the Acme_Network plan file (Figure 17-1), if you minimize the maximum interface 
utilization across all LSPs, all four Loadshare parameters change, and the maximum interface 
utilization is 40% (Figure 17-2). The default plan file name and default LSP tags are used, thus 
naming the new plan Acme_Network-Lshare and the tags as LSPLoadshare.

• Using the Acme_Network plan file (Figure 17-1), if you minimize the number of interfaces with 
utilization greater than 50%, only two of the Loadshare values change (Figure 17-3). Notice in the 
figure how Loadshare values are relative to the other Loadshare values for parallel LSPs, and not to 
all LSPs in the table. Also, only the affected LSPs are tagged.

For More Information... See....

Comprehensive description of how loadshare simulations work, and how 
to set the Loadshare property manually

MPLS Simulation 
chapter
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Figure 17-1 Example Acme Network Before LSP Loadshare Optimization
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Figure 17-2 Example Acme Network After Minimizing Maximum Interface Utilization
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Figure 17-3 Example Acme Network After Minimizing Number of Interfaces with Utilization > 50%

Bin Example: In this example, a node uses a maximum of 32 bins, and the optimal traffic allocation is 
45% of the traffic through LSP A and 55% of the traffic through LSP B. The node that sources these two 
LSPs, however, cannot do this exact split. The optimization divides the traffic into 32 bins, each with the 
same amount of traffic in them. Thus, each bin has 3.125% of the traffic (100% of the traffic divided by 
32). The optimization also determines how the node should split the traffic. In this case, the split is to 
give 43.75% (which is 14 bins of 3.125% each) to LSP A and 56.25% (which is 18 bins of 3.125% each) 
to LSP B. Thus, it optimizes and distributes 32 (14+18) bins of traffic. This is as close as possible to the 
optimal 45%/55% split using 32 bins.
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Run LSP Loadshare Optimization Tool

Step 1 Select one or more LSPs. If you do not select any LSPs, the tool uses all LSPs in the plan file.

Step 2 Select the Tools->LSP Loadshare Optimization menu.

Step 3 Select which LSPs on which you want to optimize the Loadshare value.

Step 4 Select which method of optimization to use.

• Minimize max interface util

• Minimize number of interfaces with util > ___ %

Step 5 If distributing the traffic to bins, enter the total number of flow bins to use.

Step 6 Optional: Select which traffic level to optimize.

Step 7 Optional: Change the LSP tag name.

Step 8 Optional: Select whether to create a new plan file based on the results, and change how to name it.
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