
   

   
C H A P T E R 15

Layer 1 Simulation

Although WAE Design focuses on IP/MPLS Layer 3 (L3) network views and traffic, you can also create 
and view Layer 1 (L1) topologies, thus giving a more complete view of the network. Using the L3 and 
L1 topologies together, you can specify how L3 circuits route over L1 links. These Layer 3-to-Layer 1 
associations enable you to simulate individual L1 link and L1 node failures, or to include L1 links and 
L1 node failures in a Simulation Analysis to determine the effects on L3 traffic. Additionally, you can 
include L1 links and L1 nodes in SRLGs. With this interaction of layers, you can better design the 
network to meet performance requirements.

Note Aside from this chapter, throughout this guide the term circuit means a circuit with L3 properties. In this 
chapter, for purposes of clarity, L3 circuit and L1 circuit refer to objects defined in the Circuits and L1 
Circuits tables, respectively, whereas circuit refers to the actual network element.

L1 and L3 Views
Figure 15-1 shows an example L1 view in comparison to an L3 view. Notice the different uses of circuits. 
In the L3 view, L3 circuits are relevant to IP/MPLS routing and show traffic. The L1 view shows the 
physical topology with no traffic; if selected, it also shows the L1 circuit paths taken across the L1 links. 
L3 is the default view unless the plan file does not contain L3 nodes.

Note that to more easily find relationships between L3 and L1 objects, including interfaces, L3 circuits, 
L3 nodes, ports, port circuits, L1 nodes, L1 circuits, and L1 links, right-click the object and select the 
appropriate filter from the context menu.

Alternate Views
To alternate between these two views, use one of these methods. 

• Click the Layer View button in the top, left of the Visualization toolbar. This button is a toggle 
between Layer 3 (L3) and Layer 1 (L1), and tells you which layer you are viewing.

• Select the View->Layer 1 View or View->Layer 3 View menus.

• Use keyboard shortcuts Ctrl-1 for L1 and Ctrl-3 for L3. (On a Mac, use the Alt-1 and Alt-3.)
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Figure 15-1 Comparison of L1 and L3 Views

Multi-Layer Views
To show relationships between the L1 and L3 views, you can simultaneously view both of them in either 
view (Figure 15-2). If you are in the L1 view, then L3 objects appear in the background. If you are in an 
L3 view, then L1 objects appear in the background

In the Plot Options dialog box, select the Layer 1 tab, and then select options to determine whether to 
show Layer 1 objects in the Layer 3 view, and vice versa. For more information on these and related plot 
options such as how to configure the opacity of the background objects, see the Edit L1 Plot Options 
section.

The ability to move, select, and edit properties for an object in the background is toggled on and off with 
the View->Preferences->Enable Selection of Background Objects. To save this and other preferences 
that appear in the same menu, select View->Preferences->Save Preferences.
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Figure 15-2 Joint Layer 1 and Layer 3 Views

L1 Topology
An L1 topology consists of a unique set of objects (Table 15-1) that are distinct from IP/MPLS L3 
topology and objects. However, two of the objects, L1 circuits and L3 circuits, represent the same circuit.

• An L3 circuit contains L3 properties of the circuit. 

• An L1 circuit contains L1 properties, specifically L1 routing, of the circuit.

WAE Collector does not discover L1 objects, but you can easily create the objects and generate an L1 
topology in WAE Design using these methods. 

• Import L1 topology from a another plan file. This method creates the same L1 topology and the same 
L1 link, L1 circuit, and L3 mappings as in the source file from which you are copying. Note that you 
can also copy L1 topology from a template plan file.

• Construct an L1 topology based on all or part of an existing L3 topology in the same plan file. This 
method creates an L1 topology that mirrors the L3 one, and automatically generates the mappings 
between L1 links, L1 circuits, and L3 circuits based on the selected sites or L3 nodes. It also 
automatically generates one standby L1 circuit path per each L1 circuit and sets its Path Option to 
1. L1 link metrics are all set to 1.

• Individually creating the L1 nodes, L1 links, L1 circuits, L1 circuit paths, and L1 circuit path hops. 
You can add both L1 nodes and L1 links to SRLGs for simulation purposes. This is typically done 
to represent ducts containing multiple fiber segments, where a break in the duct could cause multiple 
L1 link failures, and thus potentially multiple L3 circuit failures for each of these L1 links.
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• Create the L1 topology directly in the tables in the plan file, such as by editing the L1 tables using 
the Plan Tables as Database tool under the Edit menu or by creating the table in the plan file using 
a text editor.

L1 Objects
For information on the visualization of L1 objects, see the Plot Legend for Design Layouts chapter. 

For More Information... See...

Import L1 model (objects and tags) WAE Design Integration and Development 
Guide

Create L1 topology based on L3 topology using the 
Insert tool

Create L1 Topology from L3 Topology section

Copy L1 topology from a template WAE Network Visualization Guide

Modify how the L1 topology appears in the plot WAE Network Visualization Guide

Table 15-1 L1 Objects

L1 Object Description

L1 node Models L1 devices and is listed in the L1 Nodes table.

L1 link Models the fiber segments connecting the L1 nodes. These are listed in the L1 Links table and 
are highlighted in blue upon selecting them.

L1 circuits are routed over L1 links, which is how these L1 links can be mapped to the IP/MPLS 
topology in the L3 view. For more information, see L1 Simulations and Relationships Between 
L1 and L3.

L1 link waypoint Models network devices (that are not L1 nodes) that reside in the L1 link path. Each waypoint 
has a set of coordinates that identify a point on an L1 link. They are used for visualization 
purposes and for calculations executed by the Latency and Distance initializer. They are not 
used in simulations. 

L1 circuit Models the L1 properties of a circuit, such as which L1 nodes are connected to it and the 
physical path and distance. These are listed in the L1 Circuits table and are highlighted in green 
upon selecting them. 

An L1 circuit can be associated with either an L3 circuit or L3 port circuit. For more 
information, see Relationships Between L1 and L3.

L3-L1 link Models the physical relationship between an L3 node and an L1 node.

L1 circuit path Models the paths available for the L1 circuits. These are listed in the L1 Circuit Paths table and 
are highlighted in green upon selecting them. The number on the highlighted path indicates the 
Path Option number.

L1 circuit path hop Models the L1 node or L1 links in the L1 circuit path. These are listed in the L1 Circuit Path 
Hops table.

Actual L1 circuit path hop Discovered L1 circuit path hops. Although WAE Collector does not discover these, if you have 
a discovered set of L1 circuit path hops, you can manually add them using the Actual tab in the 
L1 circuit path Properties dialog box. You can also edit the .txt plan file to add an 
<ActualL1CircuitPathHops> table.
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Both L1 links and L1 nodes can be failed, set to an inactive state, and included in Simulation Analysis 
to calculate a worst-case failure analysis. Additionally, they can both be included in SRLGs, which in 
turn can also be failed and included in Simulation Analysis. These capabilities enable you to assess the 
effect of L1 outages on the IP/MPLS network, thus improving your ability to design around and plan for 
potential service disruptions. For information, see the L1 Failures and Inactive States and L1 Simulation 
Analysis sections.

L1 Waypoints

Waypoints are only viewable in the geographic view, and by default, they are visible in the network plot. 
There is an option to show or hide them in the Layer 1 tab of the Plot Options dialog box. For sites, the 
“Use schematic view for sites containing only nodes” must be deselected in the General Options tab of 
the Plot Options dialog box.

• The Order property represents the proximity to L1 node A, where 1 is the closest waypoint to the 
L1 node A and each subsequent number is farther away.

• Default Longitude and Latitude properties are based on the L1 link on which they are created, 
though you can change them. 

Sites
All sites are listed in the Sites table whether they contain L1 nodes, L3 nodes, or both. To determine how 
many L1 nodes, if any, are in a site, show the L1 Node Count column. By default, sites containing only 
L1 nodes appear only in the L1 view, and sites containing only L3 nodes appear only in the L3 view. You 
can change this default in the Plot Options dialog box. Empty sites appear in both views. 

For More Information... See...

Create or edit L1 nodes Create L1 Nodes section

Create or edit L1 links Create L1 Links section

Create or edit L1 circuits Create L1 Circuits section

Create L1 and L3 Mappings section

Create or edit L3-L1 links Create L3-L1 Links between Nodes section

Create L1 circuit paths Create L1 Circuit Paths section

Create explicit L1 circuit path hops Individually: Create Individual L1 Circuit Path Hops 
section

Automatically: Explicit L1 Circuit Path Initializer 
section

Create L1 waypoints Create L1 Waypoints section

Set L1 link metrics using an initializer tool Layer 1 Link Metric Initializer section

Initialize the distance and delay of L1 links Simulation chapter
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L1 Simulations
When reading the L1 tables, the derived Established and Routed properties indicate simulation 
capabilities.

• Established—Identifies whether an L1 circuit or L1 circuit path is routed when there are no failures. 
Note that while an L1 circuit or L1 circuit path has Established equals F (false), it might be routable 
under failures (Figure 15-17).

• Routed—Identifies whether and how an L1 circuit or L1 circuit path is routed.

– Unrouted

– Actual (if being routed through actual L1 circuit path hops)

– Simulated (if being routed and not using actual L1 circuit path hops)

Active L1 Path Selection
Since multiple L1 circuit paths can be routed for a single L1 circuit, WAE Design uses the Active Path 
Sim property to determine which L1 circuit path to use to set the derived properties for each L1 circuit, 
such as Distance Sim and Delay Sim. The Active Path Sim property is copied from the user-specified 
Active Path property if it has been set and if it is routable. Figure 15-6 shows an example of the Active 
Path Sim changing due to a change in an L1 circuit Feasibility Limit property.

Standby Paths and Path Options
The user-specified L1 circuit path’s Standby property sets the path to standby (T) or non-standby (F). 
The user-configurable Path Option property is an integer that identifies the order in which the routing of 
L1 circuit paths is explored. The lower the value, the higher the priority to attempt to route the L1 circuit 
path.

If other L1 circuit paths must be explored, the standby L1 circuit path with the lowest Path Option value 
is used provided it is routable. If it is not routable, attempts are made for each Path Option with the next 
lowest value (next highest priority). If none of the standby L1 circuit paths are routable, WAE Design 
then follows the same procedure with non-standby L1 circuit paths, starting with the one with the highest 
priority Path Option. 

Create L1 circuits that are automatically mapped to L3 circuits Create L1 and L3 Mappings section

Associate port circuits or ports with L1 circuits or L1 nodes, 
respectively

Create L1 and L3 Mappings section

Consider L1 node and L1 links when running the Metric 
Optimization tool

Metric Optimization chapter

Consider L1 node and L1 links when creating secondary paths 
using the Explicit LSP Optimization tool

LSP Optimization chapter

Show or hide sites containing only L1 nodes or only L3 nodes (for 
the entire L1 or L3 view)

Edit L1 Plot Options section

Hide individual nodes or sites WAE Network Visualization Guide

For More Information... See...
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L1 Circuit Path Routing Order
• WAE Design always attempts to route L1 circuit paths that have their Standby property set to T 

(true), regardless of whether they are set as the active path. If they are routable, they are routed in 
the order of this priority. 

– Actual L1 circuit path hops have first priority. Note that while these are not discovered by WAE 
Collector, if they are discovered through another means, you can manually add them using the 
Actual tab of the L1 circuit paths Properties dialog box or by adding an 
<ActualL1CircuitPathHops> table to the .txt plan file. 

– L1 circuits paths with explicit Lambdas or Lambdas defined through L1 circuit path hops are 
then routed. For information on lambdas, see the Lambda Assignments section.

– Thereafter, L1 circuit paths that do not have Lambda properties set explicitly or through L1 
circuit path hops are routed.

• After attempting to route standby L1 circuit paths, WAE Design determines whether and how to 
route non-standby L1 circuit paths (Standby property set to F (false)). 

– WAE Design determines if the non-standby L1 circuit path should route by checking the 
following L1 circuit properties in this order.

• If the L1 circuit Active Path property is set to this L1 circuit path, WAE Design attempts to 
route the non-standby L1 circuit path.

• If the number of routed L1 circuit paths is less than the associated L1 circuit’s Min Routed 
Paths property, then WAE Design attempts to route the non-standby L1 circuit paths.

– Non-standby L1 circuit paths are routed based on their Path Option setting (lower numbers are 
routed first). For each of these paths, the route order is based on the same criteria as described 
above for standby L1 circuit paths (actual L1 circuit path hops, then Lambda values, and then 
L1 circuit path hops that do not have Lambda values).

Within each of the above routing instances, WAE Design routes the L1 circuit path based on the 
following criteria regardless of whether the L1 circuit path is standby or non-standby. 

• Routes are based on the lowest Setup Priority value and then deterministically. For example, 
amongst L1 circuit paths with actual L1 circuit path hops, those with higher Setup Priority are routed 
first. See the L1 Circuit Path Setup Priority section. 

• L1 circuit paths that do not require automatic wavelength assignments to route have higher priority 
than those that do. For information on the Auto Lambda property, see the Lambda Assignments 
section.

View L1 Circuit Paths

To view the actual paths or simulated paths of L1 circuits, select the View->L1 Circuits menu. Note that 
given the priority of routing, if the actual L1 circuit path hops path is valid, then the actual and simulated 
paths are the same. You can also choose to view the shortest latency path from this menu.

Rerouted simulated L1 circuit paths show automatically when they are rerouted due to failures, 
regardless of whether you are showing simulated paths.
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L1 Circuit Path Hops
You can force an L1 circuit path to choose a different route by setting one or more node hops or link hops. 

Generally, node hops are used for simplicity, but link hops are useful for when you need to distinguish 
between two parallel L1 links. To do this, set a loose hop on the L1 node preceding the link hop, and 
then set a strict hop on the parallel L1 link over which you want to route this L1 circuit.

You can set L1 circuit path hops in an L1 circuit path Properties dialog box. Since WAE Design always 
uses the shortest path, remember to set as many hops as needed to achieve the desired path, and put them 
in the order of the desired path. The L1 Circuits Path Hops table identifies the path and the steps.

Note Since L1 circuits paths are bidirectional, to simulate L1 circuit path hops WAE Design automatically 
adds the initial L1 node in the path as a strict hop. 

Node Hops Link Hops

• Loose—The path must pass through the 
node, but the node does not have to be 
connected directly to the previous hop.

• Strict—The node must be directly connected 
to the previous node.

• Exclude—This node cannot be in the path.

• Strict—The L1 link must be in the path in the 
specified order.

• Exclude—This L1 link cannot be in the path.
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Example: Figure 15-3 shows an example of a default shortest path being used, as well as an alternate 
circuit path created using a loose nyc node hop. It also demonstrates that you could achieve the same 
path by setting only an exclude link hop on wdc-bos. 

Figure 15-3 Shortest L1 Circuit Paths Versus Paths Determined by L1 Circuit Path Hops

Explicit L1 Circuit Path Initializer

The Explicit L1 Circuit Paths Initializer automates the process of creating explicitly routed L1 circuit 
paths. It can optionally use disjoint groups or create disjoint paths in the process. Two L1 circuit paths 
are disjoint if they do not route over common L1 objects. This is useful, for instance, when planning L1 
circuit paths, particularly when multiple L1 circuit paths connect the same pair of L1 nodes. Using 
disjointness on these L1 circuit paths can help improve availability. 

If any L1 circuit path is unrouted, no L1 circuit path hops are created for it. If the simulated Lambda of 
a L1 circuit path is different than the user-specified Lambda on the path, then the initializer sets the 
Lambda value of the L1 circuit path to the simulated Lambda. To retain existing L1 circuit path hops, 
select the “Respect existing L1 circuit path hops” option.

The initializer creates L1 circuit paths based on either current routes or on modified routes.

• Follow current simulated routes—Use only the existing simulated L1 circuit path routes and do not 
create disjoint groups

• Create disjoint paths between L1 Circuits in Disjoint Groups—Create disjoint L1 circuit paths for 
L1 circuits that are in the same disjoint group. For example, if two L1 circuits are in the same disjoint 
group and each has two path options, all four L1 circuit paths will become disjoint from each other.

For More Information... See...

Automate the process of setting up L1 circuit 
hops

Explicit L1 Circuit Path Initializer

Set L1 circuit hops per L1 node or L1 link Create Individual L1 Circuit Path Hops
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The prerequisite for this option is that the L1 circuits must first be added to the disjoint groups in 
the L1 circuits’ Properties dialog boxes. Here, you can also assign priorities to L1 circuits within 
these groups. Higher priority L1 circuits are assigned shorter path routes based on L1 link metrics. 
The higher the number, the lower the priority. For information on entering and selecting fields in 
this Properties dialog box, see the Create L1 Circuits section. The L1 Circuit table lists these 
properties, if applicable.

• Create disjoint paths within L1 Circuits—Create disjoint paths within L1 circuits. For instance, if 
two L1 circuits each have two path options, each set of L1 circuit paths will be disjoint from each 
other, but they may or may not be disjoint from the L1 circuit paths belonging to the other L1 circuit. 

These objects are configurable and can be L1 links, L1 nodes, sites, and SRLGs. These objects have 
a disjointness priority specified, which is used if complete disjointness is not possible. 

The L1 Circuit Path Hops table lists the newly created the L1 circuit path hops. See the L1 Circuit Path 
Hops section for a description of these fields.

Step 1 Select one or more L1 circuit paths. If you select none, the default is to create L1 circuit path hops for 
all L1 circuit paths.

Step 2 Either select the Initializers->Explicit Layer 1 Circuit Paths menu, or right-click an L1 circuit path and 
select Explicit Layer 1 Circuit Paths. The Layer 1 Circuit Paths Initializer appears.

Step 3 Select whether to use the existing L1 circuit path hops.

Step 4 Select how to create the explicitly routed L1 circuit path hops. 

• Follow current simulated routes

• Modify existing routes to use disjoint L1 circuit paths, select whether to create the disjoint paths for 
each L1 circuit or to create disjoint paths between path options within the same L1 circuit.
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Step 5 To modify the disjoint priorities that determine which L1 objects are considered in the paths, click Edit. 
Then select the priorities from the drop-down L1 object menus, and click OK. For example, if you want 
L1 links and SRLGs to be equally considered, but not nodes or sites, you could set both L1 links and 
SRLGs to 1, and set site and L1 nodes to Ignore.

Step 6 Click OK.

L1 Circuit Route Reports

You can create reports on L1 circuits based on the L1 circuit path identified as the Active Path Sim for 
each L1 circuit. Additionally, the report contains all other columns in an L1 Circuits table, though they 
are initially hidden. 

Step 1 Select the Tools->Reports->Layer 1 Circuit Routes menu.

Step 2 Click OK.

After closing the report, you can access it again by selecting the Windows->Reports menu.

To export the report, right-click the Routes report name in the left Reports navigation pane, and select 
Export Routes.

L1 Link Metrics
When L1 circuit paths are routed over L1 links, by default they are established along the shortest path 
between the L1 nodes. This shortest path is defined as the path with the lowest metric, and the metric of 
an L1 circuit path is defined as the sum of the L1 link metrics in the path. To move L1 circuit paths away 
from an L1 link, raise the metric on that L1 link. 

Since you can simultaneously edit multiple L1 link Metric properties, this method is useful for altering 
numerous L1 circuit paths at a time. For exact path specification per L1 circuit path, however, you need 
to set explicit L1 circuit path hops. 

If two shortest L1 circuit paths have the same metric, WAE Design chooses one arbitrarily provided no 
other properties are impacting the route.

Note that in contrast to an interface IGP metric, this L1 metric does not represent an actual configurable 
quantity in the network.

Example: Figure 15-3 shows an example L1 circuit from sjc to kcy. When the sjc-slc L1 link has a metric 
of 2.7, the shortest L1 circuit path is sjc-slc-kcy. By raising the sjc-slc metric, the shortest L1 circuit path 
becomes sjc-sea-slc-kcy.
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Figure 15-4 Example Effect of L1 Link Metric on Routing L1 Circuits

Layer 1 Link Metric Initializer 

The L1 Link Metric Initializer sets L1 metrics based on L1 link distances. WAE Design calculates the 
metric by multiplying each L1 link’s Distance value by the multiplier you specify. You also set a 
minimum value for the resulting metric. WAE Design then uses the higher of the two values. 

Example: If the L1 Distance value is 7, the multiplier value is 3, and the minimum value is 1, the 
resulting L1 metric is 21 (Distance * Multiplier). However, if the minimum value were 25, the resulting 
L1 metric would be 25.

Step 1 Make your selections. 

• Select one or more L1 links.

• If you make no selections, metrics are calculated for all L1 links.

Step 2 Either select the Initializers->Layer 1 Metric menu, or right-click an L1 link, and select Initialize L1 
Metric from the context menu.

Step 3 Enter a multiplier and minimum value, and click OK.
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L1 Circuit Path Setup Priority
The Setup Priority property identifies the order in which L1 circuits paths are routed when they share 
the same L1 link. The lower the number, the higher the priority. Figure 15-7 and Figure 15-9 show 
examples of rerouting L1 circuit paths based on Setup Priority.

To set the Setup Priority, right-click one or more L1 circuit paths, and select Properties from the context 
menu. This value appears in the L1 Circuit Paths table in the Setup Priority column.

L1 Circuit Wavelengths
The L1 circuit lambda (wavelength) properties include those that identify transmission feasibility and 
lambda assignments. Using these properties, you can answer such questions as the following.

• Can I add an L3 circuit that uses a specific L1 circuit?

• How will my network choose a new L1 circuit path under L1 failure?

• Can I modify an existing L1 circuit for an L3 circuit? 

• How many available wavelengths are there in my L1 topology?

• What happens to the network when there are L1 failures? Does optical restoration select a new L1 
circuit path, and if so, which path?

Note The terms lambda and wavelength are interchangeable.

Transmission Feasibility

In a real network, the quality of an L1 circuit deteriorates as it passes through L1 links. Using feasibility 
properties, WAE Design enables you to simulate this weakening of L1 circuits to determine if they have 
degraded to the point of being unroutable.

Note Although the feasibility properties are predominantly used for tracking the quality of an L1 circuit’s 
wavelength as it passes through L1 links, it is an abstract property. You could optionally use it for other 
purposes, such as for representing latency restrictions. For example, for an L1 circuit, the stricter the 
requirements on latency, the lower the Feasibility Limit you would set. In this example the Feasibility 
Metric of L1 links would be set to their respective Delay values.

L1 Object Feasibility Property Description

L1 link Feasibility Metric Identifies how much an L1 circuit is degraded when it passes through that L1 
link.
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Routing Based on Feasibility Properties

The Feasibility properties affect routing as follows. 

• If there is no Feasibility Limit, the shortest path is based on the L1 link Metric property, and Feasible 
Transmission is set to “na.” 

• If the L1 circuit has a Feasibility Limit, then the shortest L1 circuit path is based on the L1 links that 
result in a L1 circuit path’s Feasibility Metric Sim value that is lower than the L1 circuit’s Feasibility 
Limit. The Feasible Transmission of the L1 circuit path is set to T (true).

• If the L1 circuit path Feasibility Metric Sim is higher than the L1 circuit’s Feasibility Limit, then it 
is not routed, and the Feasible Transmission is set to F (false) except when actual L1 circuit path 
hops exist.

Example: Figure 15-5 shows a series of changing L1 link Feasibility Metric values and the effects on 
the L1 circuit paths when the L1 circuit has a Feasibility Limit of 20. 

• Row 1 shows that all Feasibility Metrics are 10, so the L1 circuit path routes directly from sea to boi. 

• Row 2 shows that the L1 link between sea and boi has increased its Feasibility Metric to 23, thus 
exceeding the L1 circuit’s Feasibility Limit. The L1 circuit path reroutes across two links whose 
total Feasibility Metric total is 20 as shown in the Feasibility Metric Sim column. 

• Row 3 shows the Feasibility Metric on the slc-boi L1 link was raised to 15, thus making it impossible 
for the sea-boi L1 circuit path to route because the sum of the L1 link Feasibility Metrics is now 
higher than the L1 circuit’s Feasibility Limitation. The L1 circuit path’s Feasibility Metric Sim 
changes to “na” and its Feasible Transmission changes to F (false).

L1 circuit Feasibility Limit Identifies the acceptable quality of the L1 circuit.

Feasibility Metric Sim This is copied from the Feasibility Metric Sim of the active L1 circuit path.

Feasible Transmission Identifies whether the L1 circuit can be transmitted. This is copied from the 
Feasible Transmission of the active L1 circuit path. If all L1 circuit paths have a 
higher Feasibility Metric Sim than the L1 circuit’s Feasibility Limit, this value 
is F (false), and the L1 circuit cannot route.

This value is set to “na” if there is no Feasibility Limit. 

L1 circuit path Feasibility Metric Sim The sum of the Feasibility Metric of the L1 links over which the L1 circuit path 
is routed. 

Feasible Transmission Identifies whether the L1 circuit path can be transmitted. If the L1 circuit’s 
Feasibility Limit is more than the sum of the Feasibility Metrics for the L1 links 
that the L1 circuit path traverses, this value is T (true) and the L1 circuit path can 
route. 

This value is set to “na” if there is no L1 circuit Feasibility Limit. 

Note This property is not applicable if an L1 circuit is using actual L1 circuit 
path hops.

L1 Object Feasibility Property Description
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Figure 15-5 Example Effects of L1 Link Feasibility Metric on Routing L1 Circuit Paths

Example: Figure 15-6 demonstrates the effects of changing the L1 circuit’s Feasibility Limit. All L1 
links have a Feasibility Metric value of 10. The L1 circuit has two L1 circuit paths: Path Option 1 uses 
a route of sea-slc-hst-boi, and Path Option 2 uses sea-boi. 

• Row 1 shows an L1 circuit Feasibility Limit of 35. The Feasibility Metric Sim of Path Option 1 is 
30 since it routes over three L1 links, each having a Feasibility Metric of 10. Path Option 2 has a 
Feasibility Metric Sim of 10. Since the Feasibility Metric Sim value of each L1 circuit path is under 
the L1 circuit’s Feasibility Limit, each one can route. The Active Path Sim for the L1 circuit is based 
on the Path Option with the highest priority, which is Path Option 1. All Feasible Transmission 
values are T (true).

• Row 2 shows that the L1 circuit’s Feasibility Limit was lowered to 20. Now the Feasibility Metric 
Sim of Path Option 1 is greater than the Feasibility Limit, and therefore cannot route. The L1 circuit 
now uses Path Option 2 as its Active Path Sim. 

• Row 3 shows that the L1 circuit has lowered its Feasibility Limit to 5. Now the Feasibility Metric 
Sim of Path Option 2 is greater than the Feasibility Limit, and therefore cannot route. All Feasible 
Transmission values become F (false), and all Feasibility Metric Sim values become “na,” as does 
the L1 circuit’s Active Path Sim value. 
15-15
Cisco WAE Design 6.2 User Guide

   



   

Chapter 15      Layer 1 Simulation
  L1 Simulations
Figure 15-6 Example Effects of L1 Circuit Feasibility Limit on Routing L1 Circuit Paths

Lambda Assignments

Since multiple L1 circuit paths are transmitted in the same fiber, it is required that they each occupy a 
different lambda as they cross an L1 link. The lambda corresponds to a specific frequency range 
(wavelength) in the optical fiber. 

In WAE Design, the Lambda property identifies the L1 circuit path wavelength. To simulate changes in 
the Lambda values (regenerators) along an L1 circuit path, you can manually set Lambda values for each 
L1 circuit path hop.

• Each L1 circuit path traversing an L1 link must have a unique Lambda while on that L1 link. If more 
than one L1 circuit path has the same Lambda as they cross the L1 link, lambda blocking occurs. 
That is, the L1 circuit path with the highest Setup Priority property (lowest number) is routed, and 
the others are blocked. 

• Each L1 circuit path must use the same Lambda value on all L1 links that it traverses unless Lambda 
values are set on the L1 circuit path hops. This requirement is called the lambda continuity 
constraint.
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L1 Object Feasibility Property Description

L1 circuit Lambda Sim Simulated wavelength number, which is copied from the Lambda Sim of the active L1 
circuit path.

This value is set to “na” if no L1 circuit path can be routed. 

Lambda Blocking True (T) means the L1 circuit cannot be routed because there is lambda blocking on all 
of its L1 circuit paths.

L1 circuit 
path

Lambda The Lambda value of the L1 circuit path. 

• If there is no Lambda value entered, then the Lambda value of the most recently 
used L1 circuit path hop Lambda value is copied here.

• If there are no L1 circuit path hops or if there are no Lambdas assigned to L1 
circuit path hops, then this value is set to “na.”

The maximum Lambda value (integer) allowed for an L1 circuit path is limited by the 
lowest Resv Num L1 Circuit Paths Sim value of all L1 links in its path. For more 
information, see the Reservable L1 Circuits Paths on L1 Links section.

Lambda Sim Simulated wavelength number, which is copied from one of these values in this order 
of priority.

• Lambda Sim value of the first actual L1 circuit path hop

• Lambda Sim value of the first L1 circuit path hop

• Lambda value of this L1 circuit

If Auto Lambda is invoked, then WAE Design changes the Lambda Sim in order to 
route the L1 circuit path.

This value is set to “na” if the L1 circuit path cannot be routed. 

Lambda Blocking True (T) means this L1 circuit path cannot be routed either because it has the same 
Lambda value as another L1 circuit path going over an L1 link, or the Lambda Sim 
exceeds the Resv Num L1 Circuits Paths Sim on any L1 link in its path.

Auto Lambda If lambda blocking occurs and if Auto Lambda is T (true), the L1 circuit path attempts 
to use another lambda if it is available.

This property is useful for simulating optical restoration when there are L1 failures.
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Routing Based on Lambdas

Lambda properties affect L1 circuit path routing as follows.

• If the Lambda is not set and cannot be derived, or if there is no lambda blocking, the L1 circuit path 
is routed.

• If there is lambda blocking, WAE Design checks the Auto Lambda property for each L1 circuit path. 

– If F (false), the L1 circuit path is not routed. 

– If T (true), WAE Design attempts to route the L1 circuit path on the first Lambda that is 
continuously available on all L1 links over which it is routed. If no such Lambda is found, then 
the L1 circuit path is not routed. 

Note that the Export Lambda Utilization tool enables you to create and export a file that identifies all of 
the L1 circuit Lambda Sim values being used on each L1 link. This tool is accessed through the 
File->Export->Lambda Utilization menu. For information, see the WAE Design Integration and 
Development Guide.

Example: Figure 15-7 shows two L1 circuit paths attempting to route over a common L1 link (chi-nyc). 

• Path Option 1 uses sea-boi-chi-nyc.

• Path Option 2 uses sea-slc-hst-okc-chi-nyc.

Both have a Lambda value of 7. Both have Auto Lambda set to F (false). Path Option 1 can route due to 
its lower Setup Priority value. Path Option 2 cannot route due to Lambda Blocking being T (true). Notice 
that the Established column is F (false) and the Routed column is Unrouted. 

Example: Figure 15-8 shows that Path Option 2 can route after its Auto Lambda property is set to T 
(true). As a result, its Lambda Sim automatically changes to an unused Lambda value so that there is no 
lambda blocking. The Lambda Blocking column changes to F (false), the Established to T (true), and the 
Routed to Simulated. The reason Path Option 1 can still route, even though its Auto Lambda is still set 
to F, is because it has a lower Setup Priority value. Thus, WAE Design uses Lambda 7 for this path. 

L1 circuit 
path hop

Lambda The user-specified wavelength of the L1 circuit hop.

The Lambda is used for all of the subsequent hops if no other change is specified.

This value is set to “na” if it is not explicitly set. 

Lambda Sim Simulated wavelength number, which is copied from one of these values in this order 
of priority. 

• The hop’s Lambda value.

• The Lambda of the first preceding L1 circuit path hop that has a Lambda value.

• The Lambda property of its L1 circuit path.

When you manually create L1 circuit path hops, WAE Design automatically creates the 
first L1 circuit path hop to be the first L1 node in the path. It also copies the L1 circuit 
path’s Lambda Sim value to this hop. 

If Auto Lambda is used, then this value is set to the Lambda Sim value of the L1 circuit 
path.

This value is set to “na” if no Lambda values have been specified for this L1 circuit 
path hop or if the L1 circuit path cannot be routed. 

L1 Object Feasibility Property Description
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Figure 15-7 Example Lambda Blocking

Figure 15-8 Example Auto Lambda

Reservable L1 Circuits Paths on L1 Links
Reserving L1 circuit paths provides another mechanism for influencing the routing of L1 circuit paths. 
The properties used to reserve L1 circuit paths are the L1 link’s Max L1 Circuit Paths and Resv L1 
Circuit Paths. To set these properties, right-click one or more L1 links, and select Properties from the 
context menu.
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• The number of L1 circuit paths using an L1 link cannot exceed the L1 link Resv L1 Circuit Paths 
value. If there is no Resv L1 Circuit Paths value, then the number of L1 circuit paths using an L1 
link cannot exceed the Max L1 Circuit Paths value.

• If multiple L1 circuit paths are attempting to use the same L1 link, then the L1 circuit path with the 
lowest Setup Priority value is used.

Example: Figure 15-9 shows an slc-hst L1 link with no Max L1 Circuit Paths property. One L1 circuit 
from slc to wdc filters to three L1 circuit paths that use this slc-hst L1 link. 

• By changing the L1 link’s Max L1 Circuit Paths property to 2, only the two L1 circuit paths with the 
lowest Setup Priority value can route over the L1 link. These are Path Options 1 and 2. 

• By adding an L1 link’s Resv L1 Circuit Paths value of 1, only Path Option 1, which has the lowest 
Setup Priority, can route over this slc-hst L1 link.

L1 Link Properties Description

Max L1 Circuit Paths Total number of L1 circuit paths that the L1 link can carry. If not specified, the L1 link has no 
L1 circuit path restrictions. 

Resv L1 Circuit Paths Number of L1 circuit paths that can be reserved to be routed over the L1 link.

Resv L1 Circuit Paths Sim (Derived) If a Resv L1 Circuit Paths value is entered, this is copied to the Resv L1 Circuit Paths 
Sim column. If the Resv L1 Circuit Paths is empty, the Max L1 Circuit Paths value is copied to 
the Resv L1 Circuit Paths Sim column.

The maximum Lambda value (integer) allowed for an L1 circuit path is limited by the lowest 
Resv Num L1 Circuit Paths Sim value of all L1 links in its path. For more information on 
lambdas and the potential for the Resv L1 Circuit Path blocking the route of an L1 circuit, see 
the Lambda Assignments section.

Avail L1 Circuit Paths (Derived) Number of additional L1 circuit paths that are available to route through the L1 link. 
This does not include the paths that are currently being routed over the L1 link. The calculation 
is Resv L1 Circuit Paths Sim minus Num L1 Circuit Paths.

Util Sim Number of L1 circuit paths that traverse this L1 link as a percentage of the maximum number 
of L1 circuit paths that can traverse this L1 link. 

Num L1 Circuit Paths / Max L1 Circuit Paths
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Figure 15-9 Example Maximum L1 Circuit Paths and Resv L1 Circuit Paths

Relationships Between L1 and L3
Although L1 circuits and L3 circuits represent the same circuit, they are distinct objects in different 
tables and views. However, you can map the L1 circuits to the L3 circuits so as to see the effect of failed 
and inactive L1 links on the L3 network. By mapping L1 to L3 circuits, you are effectively adding L1 
properties to a circuit whose L3 properties are defined in the Circuits table. Note that you need not map 
all L1 circuits to L3 circuits and vice versa.

Similarly, you can map L1 circuits to circuits within a LAG (port channel). Again, this has the effect of 
adding L1 properties to a port circuit whose L3 properties are defined in the Port Circuits table.

Selecting an L3 circuit or port circuit that has an L1 circuit mapped to it highlights the associated L1 
path in green in the L1 view.

Example: This example demonstrates the dynamics between an L1 link and L3 circuits. Figure 15-10 
shows an L1 link named kcy-slc that is filtered to its associated L1 circuits. Each L1 circuit path has one 
L1 circuit path (labeled “1” on the path) where the end L1 nodes are labeled A and B. Figure 15-11 
shows the association of these L1 circuits with L3 circuits. 
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This L1 Link... Is Used By These L1 Circuits... Which Are Mapped to These L3 Circuits

kcy-slc chi-sea cr1.chi-cr2.sea

chi-sjc cr2.chi-cr1.sjc

kcy-sjc cr1.sjc-cr1.kcy

For More Information... See...

Map L3 circuits to L1 circuits Map an L1 Circuit to an L3 Circuit

Map L3 circuits to L1 port circuits Create L3-L1 Links between Nodes
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Figure 15-10 Relationship Between L1 Links and L1 Circuits
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Figure 15-11 Relationship Between L1 Circuits and L3 Circuits

Delay and Distance
Both Delay and Distance are properties that can be set in the L1 link and L1 circuit path Properties dialog 
boxes. To automate the process of setting these, use the Latency and Distance Initializer. For 
information, see the Simulation chapter. 
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Example: Figure 15-11 shows how L1 link Delay and Distance properties affect L1 circuit path 
properties (and thus, L1 circuit properties), and how they can potentially affect L3 circuit properties. 

• One L1 circuit, which is mapped to an L3 circuit, has two L1 circuit paths. 

• Since the active L1 circuit path (Path Option 2) has neither a Delay, nor a Distance set, its Delay 
Sim and Distance Sim columns are derived by adding together the Distance and Delay values of the 
L1 links over which it traverses. The combined Delay of these three L1 links is 6.880 ms, and the 
combined Distance is 900 km. The L1 circuit inherits these in its Distance Sim and Delay Sim 
columns.

• Since the L3 circuit mapped to the L1 circuit does not have a Delay or Distance property, its Delay 
Sim and Distance Sim values are copied from the L1 circuit Delay Sim and Distance Sim columns.

Table Column Description

L1 Links Delay One-way transmission latency over the L1 link in milliseconds (ms).

Distance Distance of the L1 link in kilometers (km).

L1 
Circuits

Delay Sim • (Derived) This valued is copied from the L1 circuit path Delay Sim column of the active 
path.

• If no L3 Delay is explicitly set for the L3 circuit, the Delay Sim column in the (L3) Circuits 
table is copied from the Delay Sim column of the mapped L1 circuit, which is based on the 
L1 circuit path being used as the active path.

Distance Sim • (Derived) This valued is copied from the L1 circuit path Distance Sim column of the active 
path.

• If no L3 Distance is explicitly set for the L3 circuit, the Distance Sim column in the (L3) 
Circuits table is copied from the Distance Sim column of the mapped L1 circuit, which is 
based on the L1 circuit path being used as the active path.

L1 Circuit 
Paths

Delay One-way transmission latency over the L1 circuit path in milliseconds (ms).

Delay Sim (Derived) If the L1 circuit path Delay value is entered, it is copied to the Delay Sim column. 
Otherwise, this is set to the sum of the delays of the L1 links over which this L1 circuit path is 
routed.

Distance Distance of the L1 circuit path in kilometers (km).

Distance Sim (Derived) If the L1 circuit path Distance value is entered, it is copied to the Distance Sim 
column. Otherwise, this is set to the sum of the distances of the L1 links over which this L1 
circuit path is routed.
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• Note that if the L1 circuit’s active path were to change to 1 (Path Option 1), the L1 circuit and its 
mapped L3 circuit would have a Distance Sim of 1400 km and a Delay Sim of 10.880.

Figure 15-12 Example Effect of L1 Link Delay and Distance

L1 Failures and Inactive States
Just as L1 links and L1 nodes can be set to failed states, they can also be set to inactive states, similarly 
to L3 circuits and nodes in the L3 topology. Table 15-2 and Table 15-3 show the icons used in the L1 
view for these states. Note that sites containing failed or inactive L1 links and L1 nodes indicate as such.
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Table 15-2 L1 Link Failure and Inactive States

L1 Link Description

L1 link failed.

L1 link is not operational because of one of the following reasons.

• L1 node failed that is connected to the L1 link.

• A site failed that contains the L1 link.

• An SRLG failed that contains the L1 link.

• An SRLG failed that contains an L1 node connected to the L1 link.

L1 link is inactive.

L1 link is inactive for one of the following reasons.

• An L1 node that is connected to the L1 link is inactive.

• An inactive SRLG contains the L1 link.

Table 15-3 L1 Node Failure and Inactive States

L1 Node Description

L1 node failed.

Node is not operational because it is contained in a failed site or SRLG.

L1 node is inactive.

L1 node is not operational because an SRLG containing it is inactive.

For More Information... See...

Fail objects and recover them from failure Simulation chapter

Set objects to active or inactive
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L1 Failure Effects on L3
L3 circuits are rerouted due to L1 failures if the L3 circuit is mapped to an L1 circuit that would traverse 
a failed L1 node or L1 link under normal operations.

Example: Drawing upon the example L1 link, L1 circuits, and L3 circuits relationships shown in 
Figure 15-10 and Figure 15-11, Figure 15-13 shows the effects of failing the kcy-slc L1 link. It also 
shows the effect of an slc L1 node failure. If an L1 node fails, the connected L1 links are non-operational. 
In this example, both the L1 link and L1 node failure have the effect of making the same L3 circuits 
non-operational.

Example: Drawing upon the example in Figure 15-13, Figure 15-14 demonstrates what would happen 
if the kcy-sjc L1 circuit path were rerouted. The L1 circuit path takes a southern route, and the L3 circuit 
continues to route traffic. The L3 view continues to show active routing, and by selecting the mapped L3 
circuit, you can switch to the L1 view to see both the original (solid green) and rerouted, rerouted L1 
path (dashed lined). Alternatively, you could see the impact of the L1 failure directly in the L3 view by 
showing L1 objects in the background (Figure 15-14). Note that the L3 circuit Delay Sim value (in the 
Circuits table) might change due to the rerouting of the L1 circuit path.

Figure 15-13 Example Effect of Failing an L1 Link or L1 Node on L3 Circuits
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Figure 15-14 Example Effect of Rerouting L1 Circuit Paths

Figure 15-15 Multi-Layer View of Rerouting L1 Circuit Paths
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Resiliency under L1 Failures
L1 circuit paths can be rerouted around failures using either standby (static) or non-standby (dynamic) 
L1 circuit paths. If no restrictions have been specified with respect to path hops, this reroute takes the 
best path available based on L1 link metrics.

• Standby paths are always established (available) to route. If there are multiple standby L1 circuit 
paths, then WAE Design attempts to route each available standby L1 circuit path based on their Path 
Option values (the lower the value, the higher the priority). In this way you can simulate optical 
circuit protection, such as might be configured for 1+1 protection (one primary and one backup 
path). 

• Non-standby paths are dynamically available. That is, they are available only if WAE Design has 
attempted to route all standby paths and if the number of routed standby paths is less than the L1 
circuit’s Min Routed Paths property. Thereafter, WAE Design attempts to route each non-standby 
L1 circuit path in the order of its Path Option value. This behavior models optical circuit restoration.

For details on how L1 circuit paths are routed, see the L1 Simulations section.

Example: The L1C_chi-atl L1 circuit has three L1 circuit paths (Figure 15-15).

• Path Option 1 is standby, and has no hops.

• Path Option 2 is standby, and has a strict kcy hop, and an exclude hst hop.

• Path Option 3 is non-standby and has no hops.

The non-standby Path Option 3 is not routed until both standby paths are unroutable due to failure. 
Notice the Routed column changes for all three paths, indicating which paths are routable or simulated. 
Also notice that the Established column remains consistent. This is because whether or not an L1 circuit 
path is available for routing under normal operation has no bearing on whether it is routable under 
failure.
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Figure 15-16 Example of Dynamic Non-Standby Path Routing Under Failure

Minimum Routed Paths

The number of L1 circuit paths that WAE Design attempts to route is defined by the L1 circuit’s Min 
Routed Paths property. If the number of routed standby paths is less than the Min Routed Paths property, 
then WAE Design attempts to route non-standby paths. This can be useful when modeling 1+1+R 
resilience schemes. 

Example: Figure 15-17 shows an L1 circuit with Min Routed Paths set to 1. It has three L1 circuit paths; 
two are standby and one is non-standby. When one standby L1 circuit path cannot be rerouted under 
failure, there is no attempt to route the non-standby path. By changing the Min Routed Path to 2, the 
non-standby path is routed. 
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Figure 15-17 Example Resilience Scheme Using Minimum Routed Paths Property

Inactive State
Setting an L1 link or L1 node to inactive reroutes L1 circuit paths using that L1 link or L1 node. It has 
no effect on the operational state of L3 circuits unless the L1 circuit path cannot be rerouted, in which 
case the associated L3 circuit becomes operationally down. Note that the L3 circuit Delay Sim value (in 
the Circuits table) might change due to the rerouting of an L1 circuit path.

Example: Figure 15-17 shows a rerouted hst-wdc L1 circuit path when an L1 link that it traverses is set 
to inactive. The same L1 circuit path reroute occurs as a result of the atl L1 node being set to inactive.
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Figure 15-18 Example Reroute of L1 Circuit when L1 Link or L1 Node is Inactive

L1 Simulation Analysis
Like L3 objects, L1 links and L1 nodes can be included in Simulation Analysis either as single objects 
or as part of SRLGs. 

Worst-Case Simulations
When included in the Simulation Analysis, their impact on L3 worst-case traffic utilization is reflected 
in the L3 Worst-Case Traffic view. Similarly, an L1 link or L1 node is the cause of worst-case traffic 
utilization, it is reflected in the WC Failure column in the Interfaces and Circuits tables. 

The L1 view does not show worst-case utilization in the network plot. However, the L1 Links table 
updates the following columns when you include L1 links or L1 nodes in the Simulation Analysis.

• WC Num L1 Circuit Paths—Number of L1 circuit paths that traverse this L1 link under worst-case 
L1 failure simulations.

• WC Util Sim—Number of L1 circuit paths that traverse this L1 link under worst-case L1 failure 
simulations as a percentage of the maximum number of L1 circuit paths that can traverse this L1 
link without failures.

Number of L1 circuit paths that traverse this L1 link under worst-case L1 failure simulations / Max 
L1 Circuit Paths (property value)

Failure Impact
The L1 Failure Impact view is available upon running a Simulation Analysis on L1 links. The L1 plot in 
this view colors the L1 links according to the maximum L3 interface traffic utilization level that would 
be caused should an L1 link fail. The color indicates the resulting L3 utilization and severity of the L3 
congestion.

Example: In the L1 Failure Impact view, if the chi-bos L1 link shows a utilization of 80-90% and its 
color representation is orange, then if that chi-bos L1 link were to fail, one or more L3 interfaces would 
react by exceeding a 80% utilization level.

Note The network plot in the L1 Failure Impact view does not show utilizations unless L1 links are included 
in Simulation Analysis.
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The following columns in the L1 Links table show the failure impact of failing L1 links in Simulation 
Analysis.

• Failure Impact—Worst-case traffic utilization of L3 interfaces if this L1 link were to fail. For 
instance, if the value is 70.13%, it means that if this L1 circuit failed, the resulting traffic utilization 
on one or more L3 interfaces would exceed 70.13%.

• Failure Impact Interface—The L3 interface that will experience the highest utilization as a result of 
the L1 link going down.

Format = if{Node|Interface}

Example: if{cr2.par|to_cr1.fra}} means if the L1 link goes down, it will have the greatest traffic 
impact on the cr2.par to cr1.fra interface.

The following columns in the L1 Nodes table show the failure impact of failing L1 nodes in Simulation 
Analysis.

• Failure Impact—Worst-case traffic utilization of L3 interfaces if this L1 node were to fail. For 
instance, if the value is 70.13%, it means that if this L1 node failed, the resulting traffic utilization 
on one or more L3 interfaces would exceed 70.13%.

• Failure Impact Interface—The L3 interface that will experience the highest utilization as a result of 
the L1 node going down.

Format = if{Node|Interface}

Example: if{cr1.chi|to_cr2.mia}} means if the L1 node goes down, it will have the greatest traffic 
impact on the cr1.chir to cr2.mia interface.

Worst-Case Failures
After running a Simulation Analysis, you can view the L1 failure scenarios that caused the worst-case 
utilization for an L3 interface. Right-click an L3 interface or L3 circuit, and select Fail to WC. A dialog 
box appears from which you can select the failure scenario you want to observe. Upon clicking OK, the 
network plot changes to show this particular failure scenario. If you are in the L3 view and the worst-case 
failure is an L1 object, switch views to see the failure in the L1 view.

Create L1 Topology

Create L1 Topology from L3 Topology
WAE Design provides a tool that constructs a complete L1 topology using an existing L3 topology as a 
model. You have an option to create the topology based on sites or L3 nodes. WAE Design then shows 
the same site in the L1 view and constructs the following L1 topology.

• Creates L1 nodes. 

For More Information... See...

Run a Simulation Analysis on L1 links and L1 nodes Simulation Analysis chapter

Fail L1 links and L1 nodes to worst-case utilization

Protect L1 links and L1 nodes from inclusion in Simulation Analysis
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– Create L1 nodes from sites—WAE Design creates one L1 node within each selected site 
regardless of the number of L3 nodes within that site. The L1 nodes are assigned the same name 
as their sites. No L1 nodes are created for L3 nodes that are not residing in sites.

– Create L1 nodes from L3 nodes—WAE Design creates one L1 node for each L3 node selected. 
The L1 nodes are assigned the same name as the L3 nodes. If the L3 node resides within a site, 
the L1 node is placed there as well.

• Creates L1 links between all L1 nodes whose corresponding L3 nodes have connectivity between 
them. 

• Creates an L1 circuit and L1 circuit path between each pair of L1 nodes connected by L1 links. 

• Creates the mapping between L1 circuits and L3 circuits. For more information on these mappings, 
see Relationships Between L1 and L3.

Follow these steps to create an L1 topology from an L3 topology. You can be in either an L1 or L3 view 
while performing these steps. 

Step 1 If you want to create an L1 topology based on only specific L3 objects, select those sites or L3 nodes 
from the L3 view. If you do not select sites or nodes, the topology is based on all sites or all L3 nodes, 
depending on your selection in step #3.

Step 2 Either select the Insert->Layer 1->L1 Topology from L3 Topology menu, or right-click the plot and 
select New->Layer 1->L1 Topology from L3 Topology from the context menu. A dialog box appears 
asking you to use selected sites or nodes. 

Step 3 Select either sites or nodes, and click OK. 

Create L1 Nodes

Step 1 Either select the Insert->Layer 1->L1 Node menu, or right-click the plot and select New->Layer 1->L1 
Node from the context menu. An L1 Node dialog box appears.

Step 2 Enter a unique L1 node name.

Step 3 Either select the site to which you want this L1 node to belong, or select None if you do not want the l1 
node to reside in a site.

Step 4 Optional: Enter a description.

Step 5 Optional: Select the Identification tab to enter more descriptive information.

Step 6 Click OK.
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Create L1 Links
Each L1 link name and L1 node combination must be unique.

Step 1 Either select the Insert->Layer 1->L1 Link menu, or right-click the plot and select New->Layer 1->L1 
Link from the context menu. An L1 Link dialog box appears.

Step 2 Enter an L1 link name and description. If the L1 link has the same source and destination as another L1 
link, then it must have a unique name. Otherwise, it is not required.

Step 3 Required: Select the two nodes you want to connect with this L1 link by first selecting the site and then 
selecting the node.
15-36
Cisco WAE Design 6.2 User Guide

   



   

Chapter 15      Layer 1 Simulation
  Create L1 Topology
Step 4 Optional selections are as follows.

Step 5 Click OK.

Create L1 Circuits
Each L1 circuit name and L1 node combination must be unique.

Step 1 Either select the Insert->Layer 1->L1 Circuit menu, or right-click the plot and select New->Layer 1->L1 
Circuit from the context menu. An L1 Circuit dialog box appears.

Step 2 Enter an L1 circuit name. If the L1 circuit has the same source and destination as another L1 circuit, then 
it must have a unique name. Otherwise, it is not required.

Step 3 Required: Select the two L1 nodes you want to connect with this L1 circuit by first selecting the site (if 
applicable) and then selecting the L1 node.

Step 4 Optional selections are as follows. 

Field For Information...

Metric L1 Link Metrics section

Distance, Delay Delay and Distance section

Feasibility Metric L1 Circuit Wavelengths section

Resv L1 Circuits, Max L1 Circuits Reservable L1 Circuits Paths on L1 Links section 

Protected, Active, Failed Simulation and Simulation Analysis chapters

Field For Information...

Disjoint Group, Disjoint Priority Explicit L1 Circuit Path Initializer

Bandwidth See below

Feasibility Limit L1 Circuit Wavelengths

Active Path Active L1 Path Selection

Min Routed Paths Minimum Routed Paths
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Bandwidth—Enter a value for the bandwidth required by the L1 circuit. This value is not used for 
routing. It is copied to the BW Sim column in the L1 Circuits table. If no value is entered, the BW Sim 
column is set to the simulated capacity of the L3 circuit that is mapped to this L1 circuit. The total BW 
Sim for all L1 circuits routing over an L1 Link is listed in the Circuit BW Sim column of the L1 Links 
table.

Step 5 Click OK.

Create L1 Circuit Paths

Step 1 Select one or more L1 circuits. If you do not select any, L1 circuit paths are created for all of the L1 
circuits. 

Step 2 Access an L1 circuit path in one of these ways. 

• Select the Insert->Layer 1->L1 Circuit Paths menu.

• Right-click an L1 circuit in the L1 Circuits table and select Insert L1 Circuit paths from the context 
menu.

• Right-click the plot and select New->Layer 1->L1 Circuit Paths from the context menu.

Step 3 Select or enter a path option.

Step 4 Select whether the L1 circuit path is a Standby path, and click OK.

Edit L1 Circuit Paths

If editing L1 circuit paths, you can change the L1 circuit to which the L1 circuit path is mapped, 
including the sites and L1 nodes. Other options include the following.

Field For Information...

Path Options Standby Paths and Path Options

Delay, Distance Delay and Distance

Setup Priority L1 Circuit Path Setup Priority

Auto Lambda, Lambda L1 Circuit Wavelengths
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Create Individual L1 Circuit Path Hops
To manually create L1 circuit path hops, the L1 nodes and/or L1 links must already exist. Alternatively, 
you can use the Explicit L1 Circuit Path Initializer to set explicit L1 circuit paths.

Step 1 Either right-click an L1 circuit path in the L1 Circuits Paths table and select the Properties menu, or 
double-click an L1 circuit path. An L1 Circuit Paths dialog box appears.

Step 2 In the Hops area Starts From drop-down list, select the first L1 node hop in the path as either A or B. 

Step 3 If you are editing an existing hop, double-click it from the Hops list. 

If you are creating a hop on this path for the first time, click Insert After in the Hops area. 

If you are creating a hop on this path and other hops already exist, select an existing hop and then click 
either Insert Before or Insert After, depending on the required order of the hops. The L1 Circuit Hops 
dialog box appears.

Step 4 Create or edit the node or link hop as follows. 

Standby Standby Paths and Path Options and Resiliency under L1 Failures

Hops Explicit L1 Circuit Path Initializer and Create Individual L1 Circuit Path 
Hops

Field For Information...
15-39
Cisco WAE Design 6.2 User Guide

   



   

Chapter 15      Layer 1 Simulation
  Create L1 Topology
Step 5 Optional: Add a lambda value for this L1 circuit path hop.

Step 6 Repeat steps #3 and #5 for each hop in the path. Since WAE Design always chooses the shortest path, 
you must enter enough hops to create an alternate, longer path. 

Step 7 Click OK.

Step 8 In the L1 circuit path’s dialog box, verify that the list of finished hops is in the order of the desired path, 
and then click OK.

Create L1 Waypoints
To view an L1 waypoint, you must be in the geographic view and the Layer 1 option to view them must 
be enabled. If a site does not include other sites, to view L1 waypoints in sites the “Use schematic view 
for sites containing only nodes” must be deselected in the General Options tab of the Plot Options dialog 
box. Therefore, to create them, it is recommended that you set the plot options to be able to view them 
first. For information on plot options, see the Edit L1 Plot Options section.

The only method in which you can manually specify the Order value is through the L1 link context menu. 

Note Once you enter the waypoint order value, you cannot edit it. To change its value, you must delete and 
re-create it, or insert another waypoint that would then alter the order value accordingly.

L1 Circuit Node Hops L1 Circuit Link Hops

1. In the Node Hop area, select the site and its 
L1 node that you want to set as the hop.

2. Select the type as loose, strict, or exclude.

3. Click OK.

1. Click the Link Hop option.

2. Select both endpoints (site and node) of the L1 
link hop you are setting.

3. Select the L1 link name you are creating. Only 
those L1 links with the endpoints you selected 
are listed.

4. Select the type as strict or exclude.

5. Click OK.
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If no longitude and latitude coordinates are specified, then the waypoint is inserted in the middle between 
L1 node B and the waypoint closest to L1 node B. If no other waypoints exist on the link, then the new 
waypoint is inserted in the middle of the L1 link. 

L1 Link Properties

Step 1 Either right-click an L1 link and select Properties, or double-click an L1 link. 

Step 2 Select the Waypoints tab.

Step 3 If you are creating a waypoint for the first time, click Insert After. 

If you are creating a waypoint on this L1 link and other waypoints already exist, select an existing 
waypoint and then click either Insert Before or Insert After, depending on the required order of the 
waypoints. 

Step 4 Optional: Enter a description, longitude, and latitude.

Step 5 Click OK.

L1 Link Context Menu

Step 1 Right-click an L1 link and select Insert L1 Link Waypoint.

Step 2 Enter the number representing the order in which you want this waypoint to appear in proximity to L1 
node A.

Step 3 Optional: Enter a description, longitude, and latitude.

Step 4 Click OK.

L1 Waypoint Context Menu

Step 1 Right-click an L1 waypoint and select Insert L1 Link Waypoint->Before/After Selected Waypoint.

Step 2 Optional: Enter a description, longitude, and latitude.

Step 3 Click OK.

Duplicate L1 Objects
To duplicate an L1 link, L1 circuit, or L1 circuit path right-click one, and select Duplicate from the 
context menu. Duplicating an L1 circuit or L1 circuit path also duplicates its L1 circuit path hops.

When duplicating an L3 circuit, you have the option to duplicate its associated L1 circuit if one exists 
and create an automatic mapping to it. If you select no, the newly duplicated L3 circuit maps to the 
existing L1 circuit.
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Create L1 and L3 Mappings

Create L3-L1 Links between Nodes

You can model the physical relationship between an L3 node and an L1 node to create an L3-L1 link, 
which is an object listed in the L3-L1 Links table. Creating these relationships can greatly expedite the 
process of creating L1 circuits from L3 circuits. For information on how these are used in that process, 
see the Map Multiple L1 Circuits to L3 Circuits section. 

Note For L3-L1 links to be valid for creating L1 circuits, there must a pair of them. That is, there must be one 
entry for each L3 end node of the L3 circuit. The L1 circuit that is created uses the L1 nodes to which 
those L3 nodes are mapped.

Example: This L3-L1 Links table shows an example of three L3-L1 links, as follows.

• L3 node cr1.hst is connected to (linked to) the L1 node hst.

• L3 node cr1.okc is connected to the L1 node okc.

• L3 node cr2.wdc is connected to the L1 node wdc.

Step 1 Either select the Insert->Layer 1->L3-L1 Link menu, or right-click in an empty area and select 
New->Layer 1->L3-L1 Link from the context menu.

Note that pre-selecting an L3 node or L1 node has no effect on the selections opened in the dialog box.

Step 2 Select the L3 node and the site in which it is contained, if applicable.

Step 3 Select the L1 node and the site in which it is contained, if applicable. Then click OK.
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Map Multiple L1 Circuits to L3 Circuits

Note For L3-L1 links to be valid for creating L1 circuits, there must a pair of them. That is, there must be one 
entry for each L3 end node of the L3 circuit. The L1 circuit that is created uses the L1 nodes to which 
those L3 nodes are mapped.

The “L1 Circuits for L3 Circuits” tool creates L1 circuits based on L3 circuits and associates them with 
the L3 circuits using the following sequence of priorities. For each L1 circuit created, an associated L1 
circuit path is also created. Nested objects are taken into account.

• If the L3 circuit already has an associated L1 circuit, one is not created.

• WAE Design checks the L3-L1 Links table for valid entries. 

– If multiple pairs of L3-L1 links exist that could create the L1 circuit, one is randomly used.

– If no valid L3-L1 link entry exists and if “Require L3-L1 Links” is selected, no L1 circuit is 
created.

– If no valid L3-L1 link entry exists and if “Do not require or create L3-L1 Links” is selected, for 
each L3 circuit WAE Design checks for sites that contain both the L3 end node and at least one 
L1 node. 

• If multiple L1 nodes are co-located within the same sites as the L3 nodes, then one is randomly 
selected.

• If this co-location is not found, WAE Design checks for L1 nodes within the parent sites of the 
sites containing the L3 end nodes. If none are found, an L1 circuit is not created.

• If “Create L3-L1 Links” is selected, then the L3-L1 links are created that map the respective L3 and 
L1 nodes.

If needed, you can later make changes to the L1 circuit’s endpoints and the L3-L1 links that are created 
by editing their respective Properties dialog boxes.

Examples

Figure 15-19 shows a plan file containing six L3 circuits and four L3-L1 links. All sites except sea 
contain one L3 node and one L1 node. The sea site contains two L3 nodes and one L1 node. Refer to the 
diagram for details of the objects’ relationships and to see the objects in the L3-L1 Links table. There 
are no L1 circuits. 
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Figure 15-19 Topology and Existing L3-L1 Links

If you select the Require L3-L1 Links option, WAE Design creates three L1 circuits: one between hst 
and boi, and two between from sea and boi.

If you select not to require or create L3-L1 Links, WAE Design creates six L1 circuits: three using the 
L3-L1 Links table and the remaining three by determining that the source and destination sites both 
contain L3 and L1 nodes. 
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Using the same topology as in Figure 15-19 but with no pre-existing L3-L1 Links, if you select the 
Create L3-L1 Link option, WAE Design creates the same six L1 circuits as if you had selected no 
options. However, it also creates five L3-L1 Links: one for each L3 node having an L3 circuit for which 
an L1 circuit was created.

Process for Creating Multiple L1 Circuits from L3 Circuits

Step 1 In this process, you can optionally use L3-L1 links. If you are using them, verify you have the set of 
L3-L1 links you need, and if not, create them. For information, see the Create L3-L1 Links between 
Nodes section.

Step 2 If you want to create L1 circuits for only selected L3 circuits, first select those L3 circuits. Otherwise, 
L1 circuits are created for as many L3 circuits as possible.

Step 3 Either right-click in an empty area, and select Layer 1 -> L1 Circuits for L3 Circuits from the context 
menu, or select the Insert-> Layer 1->L1 Circuits for L3 Circuits menu.
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Step 4 Select either to require the use of existing L3-L1 Links, to create them, or neither. Then click OK.

Map an L1 Circuit to an L3 Circuit

Step 1 Either right-click an L3 circuit in the Circuits table and select Properties, or double-click an L3 circuit. 

Step 2 Select the Advanced tab.

Step 3 In the L1 Circuit area, select both L1 Node A and L1 Node B site and nodes.

Step 4 Either create and map a new L1 circuit to the L3 circuit, or map an existing one to the L3 circuit. Then 
click OK. 

• Map existing L1 circuit—Choose the Select option, and select the L1 circuit from the drop-down 
list.

• Create L1 circuit—Choose the Create option, and enter a new name for the L1 circuit.

Map an L1 Node to an L3 Port

Step 1 Either right-click a port in the Ports table and select Properties, or double-click a port. 

Step 2 Select the Layer 1 tab.

Step 3 If applicable, select the L1 node’s site.

Step 4 Select the L1 Node A, and click OK.
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Map an L1 Circuit to an L3 Port Circuit

Step 1 Either right-click a port circuit in the Port Circuits table and select Properties, or double-click a port 
circuit. 

Step 2 Select the Layer 1 tab.

Step 3 In the L1 Circuit area, select both L1 Node A and L1 Node B site and nodes.

Step 4 Either create and map a new L1 circuit to the L3 circuit, or map an existing one to the L3 circuit. Then 
click OK.

• Map existing L1 circuit—Choose the Select option, and select the L1 circuit from the drop-down 
list.

• Create L1 circuit—Choose the Create option, and enter a new name for the L1 circuit.

Visualize L1 Network
Many of the visualization tools available for the L3 view are also available for L1, as follows. These tools 
are described in the WAE Network Visualization Guide.

• Assign Sites to Nodes—Automatically create sites based on L1 node names and a set of parameters 
that define which part of the node name to use. 

• Arrange Sites and Nodes—Arrange sites and nodes using tools that offer a variety of alignment 
options or arrange sites to specific geographic locations. You can also show and hide sites, as well 
as change where their site name is displayed in the plot.

• Set Plot Backgrounds—Set the background for the network plot, including schematic view, outline 
of a geographic background, and detailed geographic background. 

• Create or Edit Layouts—Create multiple Design layouts for a single plan file, each containing its 
own set of visual properties.

Edit L1 Plot Options
The Plot Options dialog box has a L1 tab that enables you to change how L1 links appear, whether to 
view another layer in the background, and whether to show or hide sites from another layer. Since these 
are plot options, they apply to the current layout and are saved on a per-layout basis when you save the 
plan file. You can also save them as user defaults. For information on user and system defaults, see the 
WAE Network Visualization Guide.

Step 1 Click the Plot Options icon in the top, right of the Visualization toolbar, or select the Edit->Plot->Plot 
Options->Edit Options menu.

Step 2 Select the Layer 1 tab.

Step 3 Edit Layer 1 fields as described in the following sections, and then click OK.

Step 4 Once you are finished editing all field, to save these changes so that they appear in the plan file when 
you next open it.
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L1 Link Appearance

• L1 Link Width—The L1 link width is based on its capacity (the higher the capacity, the wider the 
circuit). Use this option to set the minimum width and the capacity it represents.

• L1 Link Text—By default, there is no text on L1 links. Use this option to display the link name, 
distance, delay, or the number of L1 circuit paths using the link.

• Show L1 Link Waypoints—This toggle shows or hides L1 waypoints in the network plot.

Multi-Layer Visualization

The first two background options are toggles that enable you to show or hide Layer 1 in the Layer 3 view, 
and vice versa.

You can also set the degree of opacity of the background objects. The higher the value, the denser 
(darker) the background objects appear.

By default, sites containing only L1 nodes are hidden in the L3 view, and sites containing only L3 nodes 
are hidden in the L1 view. Use these selections to toggle whether to hide sites containing only L1 or L3 
nodes. Note that if you are showing a layer in the background, then you cannot hide per-layer sites within 
that view. You can show and hide individual sites by right-clicking on one and selecting 
Layout->Hide/Show Site.
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