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Managing ITP Networks Using SGM

This chapter provides details on using SGM to discover and manage your ITP 
networks. It includes the following sections:

• Becoming the Root User (Solaris Only), page 3-2

• Configuring SNMP, page 3-2

• Discovering the Network, page 3-6

• Configuring Seed Files, page 3-18

• Working with Views, page 3-23

• Working with Linksets, page 3-34

• Working with Nodes, page 3-81

• Working with Links, page 3-111

• Working with Events, page 3-143

• Viewing the Topology of the Network, page 3-163

• Finding Information in a Window, page 3-177

• Resizing, Sorting, and Hiding Table Columns, page 3-178

• Viewing Online Help, page 3-179

• Editing an ITP Route Table File, page 3-180

• Editing a Global Title Translation Table, page 3-188

• Working with SGM Statistics Reports, page 3-218

• Printing SGM Windows, page 3-283

• Connecting to a New Server, page 3-284
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• Integrating SGM with Other Products, page 3-285

• Using the Windows Start Menu, page 3-288

Becoming the Root User (Solaris Only)
Some SGM procedures require you to be logged in as the root user.

Caution As the root user, you can adversely affect your operating environment if you are 
unaware of the effects of the commands you use. If you are a relatively 
inexperienced UNIX user, limit your activities as the root user to the tasks 
described in this manual.

If you are not logged in, log in as the root user:

> login: root

> Password: root-password 

If you are already logged in, but not as the root user, use the su command to 
change your login to root:

# su

# Password: root-password

Configuring SNMP
If SGM User-Based Access is disabled, or if it is enabled and you are a Network 
Administrator or System Administrator, SGM enables you to view and change 
some SNMP settings. (For more information about user authorization levels in 
SGM, see the “Configuring SGM User Authentication Levels (Solaris Only)” 
section on page 4-6.)

Note If you want to change SNMP settings, do so before running Discovery.
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To change SNMP settings in SGM:

Step 1 Start the SGM client, as described in the “Starting SGM” section on page 2-2.

Step 2 Select Edit>SNMP Configuration from the SGM Main Menu. SGM displays the 
SNMP Configuration Dialog (Figure 3-1).

Figure 3-1 SNMP Configuration Dialog

The SNMP settings table displays SNMP information for nodes in SGM.

Step 3 (Optional) To delete a node, select it and click Delete.
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Step 4 (Optional) To change the IP address or DNS name of a node, select the node and 
enter the new address or name in the IP Address Range or Hostname field.

• IP addresses use the format x.x.x.x, where each x has one of the following 
values:

– An integer in the range 0 through 255.

– A range of integers separated by a dash (-), such as 10-60.

– An asterisk (*), which is equivalent to specifying 0-255.

• Unlike IP addresses, you cannot specify a range of node names or use 
wildcards in node names. Each node name corresponds to a single node in the 
network.

The default value for this field is the IP address *.*.*.*, which SGM uses for all 
nodes not covered by other IP address ranges or names.

Click Update to apply the new IP address to the selected node.

Step 5 (Optional) Nodes use SNMP community names for read access to the information 
maintained by the SNMP agent on the router. To change the SNMP community 
name for a node, select the node and enter the new name in the Read Community 
field. This name must match the name used by the node. The default name is 
public.

Click Update to apply the new SNMP community name to the selected node.

For information about exporting SNMP community names from CiscoWorks2000 
Resource Manager Essentials (RME), see the “Importing SNMP Community 
Names from CiscoWorks2000 (Solaris Only)” section on page 5-2.

Step 6 (Optional) If you determine that SGM waits too long for a response from a node, 
or does not wait long enough, you can change the timeout value. To change the 
time, in seconds, that SGM waits for a response from a node, select the node and 
enter the new timeout value in the Timeout (secs) field. The valid range is 1 to 60 
seconds. The default value is 1 second.

Click Update to apply the new timeout to the selected node.

Step 7 (Optional) If you determine that SGM retries a node too many times, or not 
enough times, you can change the number of retries. To change the number of 
times SGM attempts to connect to a node, select the node and enter the new 
number in the Retries field. The valid range is 0 to 99. The default value is 
2 retries.

Click Update to apply the new retries value to the selected node.
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Step 8 (Optional) If you determine that SGM polls a node too often, or not often enough, 
you can change the poll interval. To change the time, in minutes, between polls 
for a node, select the node and enter the new interval in the Poll Interval (mins) 
field. The valid range is 5 to 1440. The default value is 15 minutes.

Click Update to apply the new poll interval to the selected node.

Step 9 (Optional) To add a new node or range of nodes, enter the SNMP information in 
the appropriate fields and click Add. The new SNMP settings are added to the 
SGM database.

When you are satisfied with all of your changes to the SNMP settings, select the 
File >Save menu option. SGM saves the changes, updates the SNMP information 
on the SGM server in real time, and closes the SNMP Configuration Dialog.

Note If another user modifies and saves the SNMP configuration before you 
save your changes, SGM asks if you want to overwrite that user’s 
changes. If you choose to do so, the other user’s changes are overwritten 
and lost. If you choose not to do so, your changes are lost.

For more information about SNMP, refer to “Configuring SNMP Support” in the 
Cisco IOS Release 12.2 Configuration Fundamentals Configuration Guide, 
Part 3, Cisco IOS System Management.

SGM also provides the following SNMP-related commands:

• To set a new default SNMP read community name, use the sgm snmpcomm 
command.

• To change the file used for SNMP parameters, such as community names, 
timeouts, and retries, use the sgm snmpconf command.

• To query a host using SNMP GetRequests, use the sgm snmpget command.

• To query a host using SNMP GetNextRequests, use the sgm snmpnext 
command.

• To query a host, using SNMP GetNextRequests to “walk” through the MIB, 
use the sgm snmpwalk command.

For more information on the use of these commands, see the “SGM Commands 
and Descriptions” section on page B-2.
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Discovering the Network
SGM uses a Discovery process to populate the SGM database, discovering the 
nodes, linksets, and links in your network.

You can run Discovery if SGM User-Based Access is disabled, or if it is enabled 
and you are a Network Administrator or System Administrator. (For more 
information about user authorization levels in SGM, see the “Configuring SGM 
User Authentication Levels (Solaris Only)” section on page 4-6.)

Related Topics:

• Backing Up or Restoring SGM Files (Solaris Only), page 5-44

• Configuring Seed Files, page 3-18

• Investigating Data Problems, page 6-2

• Verifying Discovery, page 6-1

To discover the network in SGM:

Step 1 Start the SGM client, as described in the “Starting SGM” section on page 2-2.

Step 2 Select Edit>Network Discovery from the SGM Main Menu. SGM displays the 
Discovery Dialog (Figure 3-2).
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Figure 3-2 Discovery Dialog

If you start the SGM client and the SGM database is empty (including the very 
first time you start the SGM client), SGM automatically opens the Discovery 
Dialog so you can run Discovery and populate the database.

Step 3 Select the Seed Settings tab, if it is not already selected. SGM displays the Seed 
Settings panel, which enables you to create, save, load, and delete SGM seed files. 
Seed files are lists of seed nodes, which SGM uses to discover the nodes, linksets, 
and links in your network.

Step 4 Load one or more seed nodes, using one of the following procedures:

• Enter the name or IP address of a seed node in the IP Address or DNS 
Hostname field, and click Add Node.

SGM displays details of the SNMP settings for the seed nodes in the right 
pane of the window.

Continue adding seed nodes until you are certain that SGM will be able to 
discover the entire network.
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• If you have already created and saved a seed file, select File> Load Seeds 
from the Discovery Dialog menu. SGM displays the Load File Dialog - Seed 
File List dialog (Figure 3-3).

Figure 3-3 Load File Dialog - Seed File List Dialog

The Load File Dialog - Seed File List dialog contains the following fields:

– Type—Icon indicating whether the item in the table is a file or a folder.

– Name—Name of the seed file or folder.
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– Last Modified—Date and time the seed file or folder was last modified.

– Size (bytes)—Size of the seed file or folder, in bytes.

– Make this my preferred start option—Specifies whether the selected 
seed file is to be loaded automatically whenever this SGM client is 
started. By default, this checkbox is cleared for all seed files. That is, no 
seed file is loaded automatically when the SGM client is started.

– Number of Files—Total number of seed files and folders (displayed in 
bottom left corner).

To load a seed file, select the seed file in the list and click OK.

SGM closes the Load File Dialog - Seed File List dialog, loads the seed file, 
and returns to the Discovery Dialog. SGM lists all of the seed nodes in the 
seed file in the left pane of the window, and displays details of the SNMP 
settings for the seed nodes in the right pane.

To close the Load File Dialog - Seed File List dialog without loading a seed 
file, click Cancel.

Step 5 Select the Discovery tab, or click Next. SGM displays the Discovery panel 
(Figure 3-4), which enables you to discover the nodes, linksets, and links in your 
network. (If you enter a seed node IP address or name in the IP Address or DNS 
Hostname field, then click Next, SGM automatically adds the seed node before 
displaying the Discovery panel.) 
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Figure 3-4 Discovery Panel

Step 6 (Optional) Specify the extent of the network discovery.

• To discover the entire network, select the Entire Network checkbox. This is 
called recursive discovery, and it is the default setting. Select this checkbox 
when you run Discovery for the very first time.

With this checkbox selected, SGM discovers all seed nodes and attempts to 
manage them; then attempts to discover and manage all ITP nodes that are 
adjacent to those seed nodes (unless the nodes are connected by serial links 
only); then attempts to discover and manage all ITP nodes that are adjacent 
to those nodes; and so on, until SGM has discovered the entire network.

• To rediscover only seed nodes, clear the Entire Network checkbox. This is 
called nonrecursive discovery.

With this checkbox cleared, SGM discovers all seed nodes and attempts to 
manage them, then labels all nodes that are adjacent to those seed nodes 
Unmanaged.
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Note If you run Discovery with Entire Network cleared, then you run 
Discovery with Entire Network selected, any Unmanaged nodes in the 
first Discovery are not rediscovered by the second Discovery.

To recover from this situation and generate a new, complete, and reliable 
SGM database, you must perform one of the following procedures:

1. Run Discovery again, with both Entire Network and Delete Existing 
Data selected.

2. Change the Unmanaged nodes to managed status. See the 
“Unmanaging and Managing a Node” section on page 3-108 for more 
information.

3. Poll the nodes that were Unmanaged in the first Discovery. See the 
“Polling a Node” section on page 3-109 for more information.

Step 7 (Optional) Specify whether SGM is to keep or delete the existing database when 
discovering the network:

• To keep all existing network data in the SGM database before rediscovering 
the network, clear the Delete Existing Data checkbox. This is the default 
setting. Clear this checkbox when you run Discovery for the very first time.

• To delete all existing network data from the SGM database before 
rediscovering the network, select the Delete Existing Data checkbox. 
Choose this option if you know that network elements have been deleted from 
your network since the last Discovery.

Note If you discover the network with Delete Existing Data selected, and you 
are using a custom view, SGM automatically resets your view to the 
DEFAULT view. To reload your custom view, wait until Discovery is 
complete, then select Edit > Network Views, then File > Load.

If you discover the network with Delete Existing Data selected, SGM 
stops any real-time polls that are running and issues appropriate 
messages.
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Step 8 Click Discover Network to begin Discovery.

When Discovery begins:

• The Discover Network button is grayed-out.

• The “Discovery In Progress” message is displayed at the bottom of the 
Discovery Dialog.

• The “Discovery In Progress” message is displayed in the title bar of all SGM 
client windows.

Discovery progresses in bursts. You might see a number of updates, followed by 
a pause, followed by more updates. The information displayed in SGM windows 
is not fully updated until Discovery is complete.

Because SGM is an asynchronous system, with the SGM server contacting clients 
one at a time, and because clients might run at different speeds, the information 
displayed by SGM clients during Discovery might not always be in sync.

Step 9 (Optional) To stop the Discovery process at any time, click Stop Discovery. For 
example, if you click Discover Network, then you realize that you loaded a seed 
node that you did not intend to load, you can click Stop Discovery to stop the 
Discovery process.

Note If you stop the Discovery process, the information in the SGM database 
is incomplete and unreliable. To generate a new, complete, and reliable 
SGM database, you must run Discovery again, with Delete Existing 
Data selected.

Step 10 When the “Discovery In Progress” message disappears, Discovery is complete. 
The Discovered Nodes section of the Discovery panel (Figure 3-4) lists all nodes 
that were discovered by SGM. By default, this table is sorted by Status.
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Figure 3-5 Discovery Panel with Discovered Nodes

The Discovered Nodes section displays the following information for each 
discovered node:

• Name—Name or IP address of the discovered node.

• Primary SNMP Address—IP address of the node, used by SNMP to poll the 
node.

• Point Code—Point code of the node.

• Device Type—Device type of the node. Possible values are:

– Cisco2600—Cisco 2651 series router

– Cisco7202—Cisco 7202 series router

– Cisco7204—Cisco 7204VXR series router

– Cisco7206—Cisco 7206VXR series router

– Cisco7507—Cisco 7507 series router

– Cisco7513—Cisco 7513 series router
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– IPDevice—IP device, other than Cisco 2651, 7202, 7204VXR, 
7206VXR, 7507, or 7513 series router. You can assign this icon to an 
unknown node if you know that it is an IP device.

– Unknown—SGM is unable to determine the device type.

• Notes—Indicates whether there is a note associated with the node.

• Events—Indicates whether there is a recent event associated with the node.

During Discovery, SGM might flag most nodes with an event icon. If the 
event icons are too distracting, select Edit> Clear Event Icon >All from the 
SGM Main Menu to remove them.

• Status—Current status of the node. Possible values are:

– Active (green ball)—The node is currently fully functional.

– Discovering (gray ball)—The node is being discovered, and SNMP 
queries have been sent to the device.

– Polling (gray ball)—The node is being polled.

– Unknown (red ball)—The node failed to respond to an SNMP request. 
The node and all associated linksets and links are set to Unknown.

– Unmanaged (gray ball)—One of the following situations exists:

–The node is known indirectly by SGM. In other words, SGM knows the 
device exists but there is no known SNMP stack on the device for 
SGM to query.

–An SGM user has set the node to Unmanaged status, to prevent SGM 
from collecting statistics for the node.

– Waiting (gray ball)—The node is in the Discovery queue but is not 
currently being discovered.

– Warning (yellow ball)—The node is active, but one or more associated 
links or linksets is in Failed, Unavailable, Unknown, or Warning status 
and is not Ignored.
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All discovered nodes are placed in a DEFAULT configuration view, which is 
stored on the SGM server and shared by all SGM clients. Initially, all clients use 
the DEFAULT view. Clients can then create their own views, which are subsets of 
the DEFAULT view, to meet their individual needs. However, the DEFAULT view 
stored on the SGM server cannot be modified by the clients. It is always available, 
for users who need to view the entire network.

All other SGM windows (Node, Linkset, Topology, and so on) are also populated 
with the newly discovered network data.

Step 11 (Optional) To delete a node or nodes from the Discovery database, select the 
nodes and click Delete Node. SGM deletes the nodes without asking for 
confirmation.

Step 12 (Optional) Examine the Discovered Nodes table to verify that SGM discovered all 
of the nodes in the network. If you suspect that SGM did not discover all of the 
nodes, see the “Verifying Discovery” section on page 6-1 for troubleshooting 
information. You might need to add more seed nodes and run Discovery again.

Step 13 When you are satisfied that SGM discovered all of the nodes in the network, save 
the list of seed nodes in a seed file, using one of the following procedures:

• To save the changes you have made to the seed file without changing the name 
of the file, select File >Save from the Discovery Dialog menu.

• To save the changes you have made to the seed file with a new name, select 
File >Save As from the Discovery Dialog menu. SGM displays the Save File 
Dialog - Seed File List dialog (Figure 3-6).
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Figure 3-6 Save File Dialog - Seed File List Dialog

The Save File Dialog - Seed File List dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the seed file or folder.

• Last Modified—Date and time the seed file or folder was last modified.

• Size (bytes)—Size of the seed file or folder, in bytes.
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• Filename—Name by which you want to save the seed file.

If you create a new seed file name, you can use any letters, numbers, or 
characters in the name that are allowed by your operating system.

• Make this my preferred start option—Specifies whether the selected seed 
file is to be loaded automatically whenever this SGM client is started. By 
default, this checkbox is cleared for all seed files. That is, no seed file is 
loaded automatically when the SGM client is started.

• Number of Files—Total number of seed files and folders (displayed in 
bottom left corner).

To save the seed file with a new name, use one of the following procedures:

• To save the file with a completely new name, enter the new name and click 
OK.

• To save the file with an existing name, overwriting an old seed file, select the 
name in the list and click OK.

SGM saves the seed file with the new name, closes the Save File Dialog - Seed 
File List dialog, and returns to the Discovery Dialog.

Note If another user modifies and saves the seed file before you save your 
changes, SGM asks if you want to overwrite that user’s changes. If you 
choose to do so, the other user’s changes are overwritten and lost. If you 
choose not to do so, your changes are lost, unless you save the seed file to 
a different filename.

SGM stores the seed file in the seed file directory on the SGM server:

• If you installed SGM in the default directory, /opt, then the SGM seed file 
directory is /opt/CSCOsgm/seeds.

• If you installed SGM in a different directory, then the SGM seed file directory 
is located in that directory.

To delete a seed file from the seed file list, select a file and click Delete. SGM 
issues an informational message containing the name and location of the deleted 
file.
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To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Save File Dialog - Seed File List dialog.

To close the Save File Dialog - Seed File List dialog without saving the seed file 
or saving any changes to the seed file list, click Cancel.

You can run Discovery multiple times to attempt to discover additional nodes 
based on the IP address defined in the Stream Control Transmission Protocol 
(SCTP) linksets. If you are using a separate management VLAN to manage your 
nodes, but private or unreachable IP addresses for your SCTP connectivity, clear 
the Entire Network checkbox in the Discovery Dialog. Otherwise, Discovery 
attempts to reach those nodes continuously. Instead, enter all nodes to be 
discovered directly into the seed list and do a nonrecursive Discovery.

Configuring Seed Files
SGM enables you to create, save, load, and delete SGM seed files.

This section includes the following information:

• Creating a New Seed File, page 3-18

• Modifying an Existing Seed File, page 3-20

• Creating and Modifying Seed Files Using a Text Editor, page 3-22

Related Topics:

• Discovering the Network, page 3-6

Creating a New Seed File
To create a new seed file in SGM:

Step 1 Select Edit>Network Discovery from the SGM Main Menu. SGM displays the 
Discovery Dialog (Figure 3-2).

Step 2 Select the Seed Settings tab, if it is not already selected. SGM displays the Seed 
Settings panel.
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Step 3 Enter the name or IP address of a seed node in the IP Address or DNS Hostname 
field, and click Add Node. SGM displays details of the SNMP settings for the 
seed node in the right pane of the window.

Continue to add as many seed nodes as necessary.

Step 4 When you are ready to save the list of seed nodes in a new seed file, select 
File >Save As from the Discovery Dialog menu. SGM displays the Save File 
Dialog - Seed File List dialog (Figure 3-6).

The Save File Dialog - Seed File List dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the seed file or folder.

• Last Modified—Date and time the seed file or folder was last modified.

• Size (bytes)—Size of the seed file or folder, in bytes.

• Filename—Name by which you want to save the seed file. You can use any 
letters, numbers, or characters in the name that are allowed by your operating 
system.

• Make this my preferred start option—Specifies whether the selected seed 
file is to be loaded automatically whenever this SGM client is started. By 
default, this checkbox is cleared for all seed files. That is, no seed file is 
loaded automatically when the SGM client is started.

• Number of Files—Total number of seed files and folders (displayed in 
bottom left corner).

Enter the new name and click OK. SGM saves the seed file with the new name, 
closes the Save File Dialog - Seed File List dialog, and returns to the Discovery 
Dialog.

SGM stores the new seed file in the seed file directory on the SGM server:

• If you installed SGM in the default directory, /opt, then the SGM seed file 
directory is /opt/CSCOsgm/seeds.

• If you installed SGM in a different directory, then the SGM seed file directory 
is located in that directory.
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Modifying an Existing Seed File
To modify an existing seed file in SGM:

Step 1 Select Edit>Network Discovery from the SGM Main Menu. SGM displays the 
Discovery Dialog (Figure 3-2).

Step 2 Select the Seed Settings tab, if it is not already selected. SGM displays the Seed 
Settings panel.

Step 3 Select File >Load Seeds from the Discovery Dialog menu. SGM displays the 
Load File Dialog - Seed File List dialog (Figure 3-3).

The Load File Dialog - Seed File List dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the seed file or folder.

• Last Modified—Date and time the seed file or folder was last modified.

• Size (bytes)—Size of the seed file or folder, in bytes.

• Make this my preferred start option—Specifies whether the selected seed 
file is to be loaded automatically whenever this SGM client is started. By 
default, this checkbox is cleared for all seed files. That is, no seed file is 
loaded automatically when the SGM client is started.

• Number of Files—Total number of seed files and folders (displayed in 
bottom left corner).

To load a seed file, select the seed file in the list and click OK.

SGM closes the Load File Dialog - Seed File List dialog, loads the seed file, and 
returns to the Discovery Dialog. SGM lists all of the seed nodes in the seed file in 
the left pane of the window, and displays details of the SNMP settings for the seed 
nodes in the right pane.

To close the Load File Dialog - Seed File List dialog without loading a seed file, 
click Cancel.

Step 4 (Optional) To add another seed node to the seed file, enter the name or IP address 
of the seed node in the IP Address or DNS Hostname field, and click Add Node.

Step 5 (Optional) To delete a seed node from the seed file, select the seed node and click 
Delete Node.
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Step 6 When you are ready to save the modified seed file, use one of the following 
procedures:

• To save the changes you have made to the seed file without changing the name 
of the file, select File >Save from the Discovery Dialog menu.

• To save the changes you have made to the seed file with a new name, select 
File >Save As from the Discovery Dialog menu. SGM displays the Save File 
Dialog - Seed File List dialog (Figure 3-6).

The Save File Dialog - Seed File List dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the seed file or folder.

• Last Modified—Date and time the seed file or folder was last modified.

• Size (bytes)—Size of the seed file or folder, in bytes.

• Filename—Name by which you want to save the seed file.

If you create a new seed file name, you can use any letters, numbers, or 
characters in the name that are allowed by your operating system.

• Make this my preferred start option—Specifies whether the selected seed 
file is to be loaded automatically whenever this SGM client is started. By 
default, this checkbox is cleared for all seed files. That is, no seed file is 
loaded automatically when the SGM client is started.

• Number of Files—Total number of seed files and folders (displayed in 
bottom left corner).

To save the seed file with a new name, use one of the following procedures:

• To save the file with a completely new name, enter the new name and click 
OK.

• To save the file with an existing name, overwriting an old seed file, select the 
name in the list and click OK.

SGM saves the seed file with the new name, closes the Save File Dialog - Seed 
File List dialog, and returns to the Discovery Dialog.

Note If another user modifies and saves the seed file before you save your changes, 
SGM asks if you want to overwrite that user’s changes. If you choose to do so, the 
other user’s changes are overwritten and lost. If you choose not to do so, your 
changes are lost, unless you save the seed file to a different filename.
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SGM stores the seed file in the seed file directory on the SGM server:

• If you installed SGM in the default directory, /opt, then the SGM seed file 
directory is /opt/CSCOsgm/seeds.

• If you installed SGM in a different directory, then the SGM seed file directory 
is located in that directory.

To delete a seed file from the seed file list, select a file and click Delete. SGM 
issues an informational message containing the name and location of the deleted 
file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog - Seed File List dialog.

To close the Save File Dialog - Seed File List dialog without saving the seed file 
or saving any changes to the seed file list, click Cancel.

Creating and Modifying Seed Files Using a Text Editor
A seed file is simply an unformatted list of seed node names. To create a seed file 
using a text editor, simply create a file and list the seed node names, one on each 
line, with no other formatting:

new-york-a

new-york-b

chicago-c

When you save and name the seed file, keep the following considerations in mind:

• You can use any letters, numbers, or characters in the name that are allowed 
by your operating system.

• SGM saves the seed file with a .see file extension.

• SGM saves the seed file in the SGM server’s seed file directory, seeds:

– If you installed SGM in the default directory, /opt, then the seed file 
directory is /opt/CSCOsgm/seeds/.

– If you installed SGM in a different directory, then the seed file directory 
is located in that directory.
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When SGM loads the seed file, it verifies the syntax of the file, deleting blank 
lines and extraneous leading and trailing spaces as needed. SGM also verifies that 
each seed node name resolves to a valid IP address. If a name does not resolve to 
a valid IP address, SGM logs the erroneous entry and ignores it.

For example, given the following seed file:

new-york-a<space>

<space>new-york-b

zzzzzzzzzzzz

<blank line>

<tab>chicago-c<tab>

SGM loads the following entries:

new-york-a

new-york-b

chicago-c

Working with Views
When SGM discovers your network, all discovered nodes, linksets, and links are 
placed in a DEFAULT configuration view, which is stored on the SGM server and 
shared by all SGM clients. The DEFAULT view cannot be modified by the clients. 
It is always available, for users who need to view the entire network.

Initially, all clients use the DEFAULT view. However, SGM enables you to create 
your own, client-specific views, which are subsets of the DEFAULT view, to meet 
your individual needs.

You can choose the nodes you are interested in managing, remove all other nodes 
from your view, and modify the layout of the topology map in the Topology 
window. You can save all of this customized information in a view, set that view 
as the default view for the SGM client, and use the SGM client from then on to 
manage only the part of the network you are interested in, with the settings you 
prefer.
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You can also create many different views on a given SGM client, with each view 
devoted to a different aspect of the network. You can then switch between views 
to manage different parts of the network, or switch to the DEFAULT view to see 
the entire network.

If a given SGM client is used by more than one person, each user can create his 
or her own personal view.

To help you keep track of which view you are currently using, most SGM 
windows display the following information:

• In the title bar, the name of the system on which the SGM server is running.

• In the bottom right corner:

– The name of the current view.

– The text (New Nodes Exist), if there is at least one newly discovered 
node in the network that has not been added to your current view. To add 
the node to your current view, see the “Viewing the Topology of the 
Network” section on page 3-163. To exclude the node from your current 
view, see Step 5 in this section.

– The text (Modified), if the view has been modified but not yet saved. You 
must save the view if you want to save your changes. See Step 11 in this 
section for more details.

If your personal default view has been deleted, then the next time you launch the 
client SGM informs you that your default view has been deleted and that your 
view has been reset to the DEFAULT view. To choose another view as your default 
view, use the Load File Dialog - View List. See the “Loading a Client-Specific 
View” section on page 3-32 for details.

This section includes the following information:

• Creating a View, page 3-25

• Loading the DEFAULT View, page 3-32

• Loading a Client-Specific View, page 3-32

Related Topics:

• Discovering the Network, page 3-6

• Modifying Preference Settings, page 5-3

• Modifying the Message Display, page 5-19

• Viewing the Topology of the Network, page 3-163
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Creating a View
To create a client-specific network view:

Step 1 Before creating a client-specific network view, make sure that Discovery has been 
run at least once, and there is data in the server’s SGM database. See the 
“Discovering the Network” section on page 3-6 for details.

Step 2 Select Edit>Network Views from the SGM Main Menu. SGM displays the 
Network View Editor window (Figure 3-7).

Figure 3-7 Network View Editor Window

The Nodes In Current View pane lists the name, primary SNMP address, and 
primary point code of every node that is in the current view.
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With Show New Nodes Only selected, the Nodes Not In Current View pane lists 
the name, primary SNMP address, and primary point code of every newly 
discovered node that is not in the current view.

With Show Excluded Nodes Only selected, the Nodes Not In Current View pane 
lists the name, primary SNMP address, and primary point code of every existing 
or newly discovered node that has been excluded from the current view.

Step 3 (Optional) If you have already saved a view and you want to modify it, select the 
File >Load menu option. SGM prompts you for the name of the view you want to 
load. Enter the name of the view, or accept the default view name, then click OK 
to load the view.

Step 4 (Optional) If there are nodes listed in the Nodes In Current View pane that you do 
not want to manage, you can remove them from the current view:

a. Select one or more nodes in the Nodes In Current View pane,

b. Select Show Excluded Nodes Only.

c. Click Remove. SGM removes the nodes from the current view and moves 
them from the Nodes In Current View table to the list of excluded nodes in 
the Nodes Not In Current View table.

Step 5 (Optional) If SGM discovers one or more new nodes in the network, the following 
actions take place:

• SGM broadcasts the discovery of the new nodes to all SGM clients.

• SGM displays the text (New Nodes Exist) in the bottom right corner of most 
SGM windows.

• SGM adds the newly discovered nodes to the list of new nodes in the Nodes 
Not In Current View pane as soon as they are discovered.

• SGM adds graphical elements for the newly discovered nodes to the topology 
new nodes panel in the left pane of the Topology window. For more 
information, see the “Viewing the Topology of the Network” section on 
page 3-163.

If you want to manage the newly discovered nodes, you need to add them to your 
current view:

a. Select Show New Nodes Only.

b. Select one or more new nodes.

c. Click Add. SGM adds the nodes to the current view and moves them from the 
list of new nodes to the Nodes In Current View table.
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If you do not want to manage the newly discovered nodes, you need to exclude 
them from your current view:

a. Select Show New Nodes Only.

b. Select one or more new nodes.

c. Click Exclude New Node. SGM excludes the nodes from the current view 
and from the list of new nodes. (You can see excluded nodes by selecting 
Show Excluded Nodes Only.) New nodes that are excluded are never added 
to the list of new nodes, not even when other new nodes are discovered and 
added.

Step 6 (Optional) At times, you might want to make an existing node a new node:

a. Select one or more nodes in the Nodes In Current View table.

b. Select Show New Nodes Only.

c. Click Remove. SGM removes the nodes from the current view and adds them 
to the list of new nodes in the Nodes Not In Current View table.

Step 7 (Optional) To see every new node in the network that is not in the current view, 
select Show New Nodes Only. SGM displays the list of new nodes in the Nodes 
Not In Current View pane.

Step 8 (Optional) To see every excluded node in the network that is not in the current 
view, select Show Excluded Nodes Only. SGM displays the list of excluded new 
nodes in the Nodes Not In Current View pane.

Step 9 (Optional) To move an excluded node back into the current view:

a. Select Show Excluded Nodes Only.

b. Select one or more excluded nodes.

c. Click Add. SGM adds the nodes to the current view and moves them from the 
list of excluded nodes to the Nodes In Current View table.

Step 10 (Optional) To apply the changes you have made at any time without closing the 
Network View Editor window, click File>Apply. SGM applies the changes to all 
SGM windows immediately.
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Step 11 When you are satisfied with the changes you have made to the view, use one of 
the following procedures to save the view:

• To save the changes you have made to the view without changing the name of 
the file, select File >Save from the Network View Editor menu.

Note You cannot save changes to the DEFAULT view. If you are currently 
using the DEFAULT view and you select File >Save, SGM displays 
the Save File Dialog - View List dialog (Figure 3-8).

• To save the changes you have made to the view with a new name, select 
File >Save As from the Discovery Dialog menu. SGM displays the Save File 
Dialog - View List dialog (Figure 3-8).
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Figure 3-8 Save File Dialog - View List Dialog

The Save File Dialog - View List dialog contains the following fields:

– Type—Icon indicating whether the item in the table is a file or a folder.

– Name—Name of the view file or folder.

– Last Modified—Date and time the view file or folder was last modified.

– Size (bytes)—Size of the view file or folder, in bytes.
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– Filename—Name by which you want to save the view. You must specify 
a name other than DEFAULT. You cannot save changes to the DEFAULT 
view.

If you create a new view name, you can use any letters, numbers, or 
characters in the name that are allowed by your operating system.

– Make this my preferred start option—Specifies whether the selected 
view is to be loaded automatically whenever the associated preferences 
file is loaded:

- To load the selected view, select the view, then select this checkbox.

- To load the last-used view, clear the checkbox. This is the default 
setting.

– Number of Files—Total number of view files and folders (displayed in 
bottom left corner).

To save the view with a new name, use one of the following procedures:

– To save the file with a completely new name, enter the new name and 
click OK.

– To save the file with an existing name, overwriting an old view, select the 
name in the list and click OK.

SGM saves the view with the new name, closes the Save File Dialog - View 
List dialog, and returns to the Discovery Dialog.

Note If another user modifies and saves the view before you save your 
changes, SGM asks if you want to overwrite that user’s changes. If 
you choose to do so, the other user’s changes are overwritten and lost. 
If you choose not to do so, your changes are lost, unless you save the 
view to a different filename.

SGM stores the view in the view file directory on the SGM server:

– If you installed SGM in the default directory, /opt, then the SGM view 
file directory is /opt/CSCOsgm/views.

– If you installed SGM in a different directory, then the SGM view file 
directory is located in that directory.
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To delete a view from the view list, select a file and click Delete. SGM issues 
an informational message containing the name and location of the deleted 
file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog - View List dialog.

To close the Save File Dialog - View List dialog without saving the view or 
saving any changes to the view list, click Cancel.

Step 12 (Optional) To close the Network View Editor window at any time, click 
File >Close. If you have modified the view, SGM asks if you want to apply the 
changes before leaving the window:

• Click Yes to apply the changes to the current view. SGM applies the changes 
to all SGM windows immediately. SGM then asks if you want to make this 
the default view:

– Click Yes to make this view the new default view. In the future, when this 
client is started, this will be the default view.

– Click No to retain your old default view.

SGM closes the Network View Editor window.

• Click No to keep the current view as-is, without applying any changes. SGM 
closes the Network View Editor window.

• Click Cancel to close the prompt window and return to the Network View 
Editor window without applying any changes to the current view.

If you are working in a custom view (that is, not in the DEFAULT view) and you 
exit the SGM client, SGM automatically saves any changes you made to the view.
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Loading the DEFAULT View
To load the DEFAULT network view:

Step 1 Select Edit>Network Views from the SGM Main Menu. SGM displays the 
Network View Editor window (Figure 3-7).

Step 2 Select File>Load DEFAULT View from the Discovery Dialog menu. SGM loads 
the DEFAULY view.

Loading a Client-Specific View
To load a client-specific network view:

Step 1 Select Edit>Network Views from the SGM Main Menu. SGM displays the 
Network View Editor window (Figure 3-7).

Step 2 Select File >Load from the Discovery Dialog menu. SGM displays the Load File 
Dialog - View List dialog (Figure 3-9).
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Figure 3-9 Load File Dialog - View List Dialog

The Load File Dialog - View List dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the view file or folder.

• Last Modified—Date and time the view file or folder was last modified.

• Size (bytes)—Size of the view file or folder, in bytes.
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• Make this my preferred start option—Specifies whether the selected view 
is to be loaded automatically whenever the associated preferences file is 
loaded:

– To load the selected view, select the view, then select this checkbox.

– To load the last-used view, clear the checkbox. This is the default setting.

• Number of Files—Total number of view files and folders (displayed in 
bottom left corner).

To load a view, select the view in the list and click OK.

SGM closes the Load File Dialog - View List dialog, loads the view, and returns 
to the Network View Editor window.

To close the Load File Dialog - View List dialog without loading a view, click 
Cancel.

Working with Linksets
SGM enables you to view information about all discovered linksets, including 
their associated nodes, status, and other important information.

This section includes the following information:

• Viewing Basic Information for Linksets, page 3-35

• Viewing Detailed Information for a Linkset, page 3-39

• Viewing ITP Link Statistics for a Linkset, page 3-65

• Editing a Linkset, page 3-74

• Viewing Notes for a Linkset, page 3-76

• Deleting a Linkset, page 3-77

• Ignoring a Linkset, page 3-79

• Viewing Ignored Linksets, page 3-80
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Related Topics:

• Working with Nodes, page 3-81

• Working with Links, page 3-111

• Viewing the Topology of the Network, page 3-163

• Resizing, Sorting, and Hiding Table Columns, page 3-178

• Modifying Preference Settings, page 5-3

Viewing Basic Information for Linksets
To view basic information for linksets, select View >Linksets from the SGM 
Main Menu. SGM displays the Linkset Window (Figure 3-10).

Figure 3-10 Linkset Window

The Linkset Window displays information about the linksets that have been 
discovered by SGM.

By default, SGM displays all of the columns in the Linkset Window except 
Internal ID, Name, Local Point Code, Adj Point Code, and Notes. To display 
these columns, or to hide other columns, see the procedures in the “Modifying 
Linkset Table Column Settings” section on page 5-17.
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To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-178 for more details.

The Linkset Window displays the following information for each discovered 
linkset:

• Internal ID—The internal ID of the linkset. The internal ID is a unique ID 
for every event, link, linkset, and node, assigned by SGM for its own internal 
use. It can also be useful when the TAC is debugging problems.

• Name—Name of the linkset.

• Node—Name of primary node for the linkset.

Note SGM considers the node that it discovered first to be the primary 
node, and the other node to be the adjacent node. If, in the next 
Discovery, SGM discovers the adjacent node first, it considers that 
node to be the primary node and the former primary node to be the 
new adjacent node. Thus, in SGM, linkset sgm-2600a-to-sgm-7500j 
is equivalent to sgm-7500j-to-sgm-2600a.

• Local Point Code—Point code of the primary node for the linkset.

• Adjacent Node—Name of adjacent node for the linkset.

• Adj Point Code—Point code of the adjacent node for the linkset.
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• Linkset Type—Type of linkset, which SGM determines by examining the 
links defined in the linkset. Possible linkset types are:

– HSL—The links in this linkset use the SS7-over-ATM (Asynchronous 
Transfer Mode) high-speed protocol.

– SCTPIP—The links in this linkset use the Stream Control Transmission 
Protocol (SCTP) IP transport protocol.

– Serial—The links in this linkset use the serial SS7 signaling protocol.

– Mixed—The links in this linkset are of two or more types. (This 
arrangement is not recommended.)

– Other—No links have been defined for this linkset.

• Links—Total number of links in the linkset.

• Active Links—Number of links in the linkset that are Active.

• Congested Links—Number of links in the linkset that are Congested.

• Ignored—Indicates whether the linkset is to be included when aggregating 
and displaying SGM status information.

• Notes— Indicates whether there is a note associated with the linkset.

• Events—Indicates whether there is a recent event associated with the linkset.

– To delete the event icon from SGM displays for a specific linkset, select 
the linkset and click the icon.

– To delete the event icon from SGM displays for all linksets, select 
Edit>Clear Event Icon> All from the SGM Main Menu.

Note During Discovery, SGM might flag most linksets with an event 
icon. If the event icons are too distracting, use the Edit>Clear 
Event Icon> All menu option to remove them.
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• Status—Current status of the linkset. Possible values are:

– Active (green ball)—The linkset is currently fully functional.

– Unavailable (red ball)—An error is preventing traffic from flowing on 
this linkset.

– Shutdown (blue ball)—A router administrator has set the linkset to 
prevent traffic from flowing. When a linkset is set to Shutdown, all its 
associated links are set to Failed by Cisco IOS.

– Unknown (red ball)—Either the node associated with this linkset has 
failed to respond to an SNMP request, or SGM found that the linkset no 
longer exists.

– Warning (yellow ball)—The linkset is active, but one or more links in 
the linkset is congested or is in Failed, Unknown, or Warning status, 
and is not Ignored. At least one link is available and can carry traffic.

There is no Unshut or No Shut status.
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Viewing Detailed Information for a Linkset
To view detailed information about a linkset, including its associated nodes, links, 
events, status, and other information:

Step 1 Select a linkset in the Linkset window (Figure 3-10) or Topology window 
(Figure 3-54).

Step 2 Select View > Details from the SGM Main Menu. SGM displays the Details 
Window for the linkset (Figure 3-11).

Figure 3-11 Details Window, Showing Linkset Configuration Data

If the Linkset Details pane is not already displayed, click Linkset in the left pane. 
SGM displays detailed information for the linkset in the right pane.
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The Poll Interval section at the top right of the Details window displays the time 
of the last poll, and enables you to change the poll interval:

• The Last Poll field initially displays the phrase Waiting for first poll. After 
the first polling cycle, SGM populates this field with the actual time of the 
last poll.

• To change the poll interval, enter a new value (in seconds) and click Apply. 
The valid range is 15 to 999 seconds. The default value is 15 seconds.

The Error Message section of the Details window displays the last error messages 
received by the node and by the adjacent node.

Updates for the linkset that are received from the SGM server are reflected 
automatically in this window.

Note The Details window polls your network periodically. To prevent 
unnecessary traffic on your network, close this window when you no 
longer need to refer to it.

The Linkset Details pane displays the following detailed information for the 
linkset (some of which is also displayed in the Linkset Window), with details for 
the selected linkset in the left column and for the adjacent linkset in the right 
column.

Note Each node is polled individually, so timing considerations might cause 
small discrepancies in the data between the left and right columns.

Step 3 (Optional) To view naming information for the linkset, select the Configuration 
Data tab. SGM displays configuration data for the linkset in the right panel 
(Figure 3-11).

SGM displays the Naming Information table for the selected linkset in the left 
column, and for the adjacent linkset in the right column:

• Name—Name of the linkset.

• Local Point Code—Point code of the primary node for the linkset.
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• Adj Point Code—Point code of the adjacent node for the linkset.

• Internal ID—Internal ID of the linkset. The internal ID is a unique ID for 
every event, link, linkset, and node, assigned by SGM for its own internal use. 
It can also be useful when the TAC is debugging problems.

Step 4 (Optional) To view descriptive information for the linkset, select the 
Configuration Data tab. SGM displays the Description table for the selected 
linkset in the left column, and for the adjacent linkset in the right column. If the 
linkset has no description, the table is blank.

Step 5 (Optional) To view general information for the linkset, select the Configuration 
Data tab. SGM displays the General Information table for the selected linkset in 
the left column, and for the adjacent linkset in the right column:

• Linkset Type—Type of linkset, which SGM determines by examining the 
links defined in the linkset. Possible linkset types are:

– HSL—The links in this linkset use the SS7-over-ATM (Asynchronous 
Transfer Mode) high-speed protocol.

– SCTPIP—The links in this linkset use the Stream Control Transmission 
Protocol (SCTP) IP transport protocol.

– Serial—The links in this linkset use the serial SS7 signaling protocol.

– Mixed—The links in this linkset are of two or more types. (This 
arrangement is not recommended.)

– Other—No links have been defined for this linkset.

• Is Ignored—Indicates whether the linkset is Ignored (that is, whether the 
linkset is to be included when aggregating and displaying SGM status 
information).

• Accounting Enabled—Indicates whether the collection of SS7 accounting 
statistics is enabled for the linkset.

• Inbound ACL—Inbound IP access control list (ACL) for the linkset. If there 
is no inbound ACL for the linkset, this field displays 0.

• Outbound ACL—Outbound ACL for the linkset. If there is no outbound 
ACL for the linkset, this field displays 0.
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Step 6 (Optional) To view links information for the linkset, select the Configuration Data 
tab. SGM displays the Links Information table for the selected linkset in the left 
column, and for the adjacent linkset in the right column:

• Links—Total number of links in the linkset.

• Active Links—Number of links in the linkset that are Active.

• Congested Links—Number of links in the linkset that are Congested.

Step 7 (Optional) To view status information for the linkset, select the Statistics tab. 
SGM displays statistics for the linkset in the right panel (Figure 3-12).

Figure 3-12 Details Window, Showing Linkset Statistics
3-42
Cisco Signaling Gateway Manager User Guide

78-15204-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Linksets
SGM displays the Status Information table for the selected linkset in the left 
column, and for the adjacent linkset in the right column:

• Status—Current status of the linkset. Possible values are:

– Active (green ball)—The linkset is currently fully functional.

– Unavailable (red ball)—An error is preventing traffic from flowing on 
this linkset.

– Shutdown (blue ball)—A router administrator has set the linkset to 
prevent traffic from flowing. When a linkset is set to Shutdown, all its 
associated links are set to Failed by Cisco IOS.

– Unknown (red ball)—Either the node associated with this linkset has 
failed to respond to an SNMP request, or SGM found that the linkset no 
longer exists.

– Warning (yellow ball)—The linkset is active, but one or more links in 
the linkset is congested or is in Failed, Unknown, or Warning status, 
and is not Ignored. At least one link is available and can carry traffic.

There is no Unshut or No Shut status.

• Last State Change—Date and time that the status of the linkset last changed.

Step 8 (Optional) To view packet information for the linkset, select the Statistics tab. 
SGM displays the Packet Information table for the selected linkset in the left 
column, and for the adjacent linkset in the right column:

• Packets Received Per Sec—Number of packets received by the linkset per 
second. This field initially displays the phrase Waiting for second poll. After 
two polling cycles, SGM populates this field with actual calculated rates.

• Packets Sent Per Sec—Number of packets sent by the linkset per second. 
This field initially displays the phrase Waiting for second poll. After two 
polling cycles, SGM populates this field with actual calculated rates.

• Drops—Total number of packets that have been dropped by the linkset.
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Step 9 (Optional) To view bit information for the linkset (or byte information, if you 
cleared the Show Details in Bits Instead of Bytes checkbox in the Preferences 
Window), select the Statistics tab. SGM displays the Bit Information table (or 
Byte Information table) for the selected linkset in the left column, and for the 
adjacent linkset in the right column:

• Bits Received Per Sec or Bytes Received Per Sec—Number of bits or bytes 
received by the linkset per second. This field initially displays the phrase 
Waiting for second poll. After two polling cycles, SGM populates this field 
with actual calculated rates.

• Bits Sent Per Sec or Bytes Sent Per Sec—Number of bits or bytes sent by 
the linkset per second. This field initially displays the phrase Waiting for 
second poll. After two polling cycles, SGM populates this field with actual 
calculated rates.

Step 10 (Optional) To view LSSU information for the linkset, select the Statistics tab. 
SGM displays the LSSU Information table for the selected linkset in the left 
column, and for the adjacent linkset in the right column:

• LSSU Packets Received—Total number of SS7 Message Transfer Part Layer 
2 (MTP2) Links Status Signal Unit (LSSU) packets received by the linkset.

• LSSU Packets Sent—Total number of LSSU packets sent by the linkset.

Step 11 (Optional) To view utilization information for the linkset, select the Statistics tab. 
SGM displays the Utilization Information table for the selected linkset in the left 
column, and for the adjacent linkset in the right column:

• Receive Plan Capacity—Planned capacity of the linkset to receive, in bits 
per second.

– For a linkset of type Serial or HSL, available bandwidth for the linkset.

– For a linkset of type SCTPIP or Mixed, set on the router using the 
plan-capacity CS7 linkset configuration command. If Receive Plan 
Capacity is not set on the router for this linkset, this field displays the 
value 0.

– For a linkset of type Other, this field always displays the value 0.
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• Receive Utilization—Amount of the linkset’s receive capacity being used, as 
a percentage or in Erlangs, calculated using the following formula:

Receive Utilization = (Bits Received Per Sec)/Receive Plan Capacity

This field initially displays the phrase Waiting for second poll. After two 
polling cycles, SGM populates this field with actual calculated rates.

– For a linkset of type SCTPIP or Mixed, if Receive Plan Capacity is not 
set on the router for this linkset, this field displays the phrase Set Plan 
Capacity on Router.

– For a linkset of type Other, this field always displays the phrase Set Plan 
Capacity on Router.

• Send Plan Capacity—Planned capacity of the linkset to send, in bits per 
second.

– For a linkset of type Serial or HSL, available bandwidth for the linkset.

– For a linkset of type SCTPIP or Mixed, set on the router using the 
plan-capacity CS7 linkset configuration command. If Send Plan 
Capacity is not set on the router for this linkset, this field displays the 
value 0.

– For a linkset of type Other, this field always displays the value 0.

• Send Utilization—Amount of the linkset’s send capacity being used, as a 
percentage or in Erlangs, calculated using the following formula:

Send Utilization = (Bits Sent Per Sec)/Planned Capacity

This field initially displays the phrase Waiting for second poll. After two 
polling cycles, SGM populates this field with actual calculated rates.

– For a linkset of type SCTPIP or Mixed, if Send Plan Capacity is not set 
on the router for this linkset, this field displays the phrase Set Plan 
Capacity on Router.

– For a linkset of type Other, this field always displays the phrase Set Plan 
Capacity on Router.
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Step 12 (Optional) To view notes for the linkset, select the Notes tab. SGM displays notes 
for the linkset in the right panel (Figure 3-13).

Figure 3-13 Details Window, Showing Linkset Notes

SGM displays the following information in the Notes table:

• Notes associated with the selected linkset in the left column.

• Notes associated with the adjacent linkset in the right column.

• The date and time the notes associated with each linkset were last updated.

• The phrase No Notes if there are no notes associated with the linkset.

Step 13 (Optional) To view information about all recent events associated with the linkset, 
select the Recent Events tab. SGM displays recent events for the linkset in the 
right panel (Figure 3-14).
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Figure 3-14 Details Window, Showing Linkset Events

SGM displays the following information in the Recent Events table:

• By default, SGM displays only unacknowledged events in this table. To 
display acknowledged events in the table, see Step 7 in the “Modifying 
Overall Preference Settings” section on page 5-5.

• Ack—Indicates whether the event has been acknowledged:

– To acknowledge an unacknowledged event, select this checkbox.

– To make a previously acknowledged event unacknowledged, clear this 
checkbox.

• Note—Indicates whether there is a note associated with the event.

• Severity—Severity of the event. Default values are:

– Admin—The default color is cyan.

– Error—The default color is coral.

– None—The default color is white.

– Normal—The default color is light green.

– Warning—The default color is yellow.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-25 for more 
information.
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• Time—Date and time the event was logged.

• Message—Text of the message.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-25 for more 
information.

Step 14 (Optional) To view a received utilization chart for the linkset, select the 
Real-Time Data Charts tab. SGM displays the chart in the right panel 
(Figure 3-15).

Figure 3-15 Details Window, Showing Linkset Received Utilization
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SGM displays the following information in the ReceivedUtilization chart:

• Linkset—Drop-down list box used to select the linkset for which data is to 
be displayed. By default, data is displayed for the selected linkset. To display 
data for the alternate linkset, select it in this list box.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
Received Utilization Chart. You cannot edit this field directly. Instead, edit 
the Poll Interval (secs) field at the top right of the Details window.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Received Utilization Chart. Valid selections are 1, 2, 
5, 10, 20, 40, or 60 minutes. The default selection is 5 minutes.

• Received Utilization Chart—Displays the average Receive Utilization % 
for all links on the linkset as a function of time, and optionally the Receive 
Utilization % for up to 16 individual links on the linkset.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the receive utilization percentage for that data point.

To remove the data for a link or for the average from the chart, click the icon 
in the SLC field. To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.
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To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Received Utilization Chart, up to 16 total 
links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.

• Show threshold line for:—Draws a horizontal line on the Received 
Utilization Chart, indicating the receive threshold for the selected link.

If you do not want to draw a threshold line, select None. This is the default 
setting.

• Scale to threshold—Scales the Received Utilization Chart in order to draw 
the threshold selected in the Show threshold line for field:

– To scale the chart, select this checkbox.

– To remove the scaling from the chart, clear this checkbox. This is the 
default setting.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Step 15 (Optional) To view a send utilization chart for the linkset, select the Real-Time 
Data Charts tab. SGM displays the chart in the right panel (Figure 3-16).
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Figure 3-16 Details Window, Showing Linkset Send Utilization

SGM displays the following information in the SendUtilization chart:

• Linkset—Drop-down list box used to select the linkset for which data is to 
be displayed. By default, data is displayed for the selected linkset. To display 
data for the alternate linkset, select it in this list box.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
Send Utilization Chart. You cannot edit this field directly. Instead, edit the 
Poll Interval (secs) field at the top right of the Details window.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Send Utilization Chart. Valid selections are 1, 2, 5, 10, 
20, 40, or 60 minutes. The default selection is 5 minutes.
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• Send Utilization Chart—Displays the average Send Utilization % for all 
links on the linkset as a function of time, and optionally the Send 
Utilization % for up to 16 individual links on the linkset.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the send utilization percentage for that data point.

To remove the data for a link or for the average from the chart, click the icon 
in the SLC field. To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Send Utilization Chart, up to 16 total 
links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.
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• Show threshold line for:—Draws a horizontal line on the Send Utilization 
Chart, indicating the send threshold for the selected link.

If you do not want to draw a threshold line, select None. This is the default 
setting.

• Scale to threshold—Scales the Send Utilization Chart in order to draw the 
threshold selected in the Show threshold line for field:

– To scale the chart, select this checkbox.

– To remove the scaling from the chart, clear this checkbox. This is the 
default setting.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Step 16 (Optional) To view a packets-received-per-second chart for the linkset, select the 
Real-Time Data Charts tab. SGM displays the chart in the right panel 
(Figure 3-17).
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Figure 3-17 Details Window, Showing Linkset Packets Received Per Second

SGM displays the following information in the PktsRcvdPerSec chart:

• Linkset—Drop-down list box used to select the linkset for which data is to 
be displayed. By default, data is displayed for the selected linkset. To display 
data for the alternate linkset, select it in this list box.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
Packets Received Chart. You cannot edit this field directly. Instead, edit the 
Poll Interval (secs) field at the top right of the Details window.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Packets Received Chart. Valid selections are 1, 2, 5, 
10, 20, 40, or 60 minutes. The default selection is 5 minutes.
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• Packets Received Chart—Displays the Packets Received Per Sec for the 
linkset as a function of time, including data for up to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of packets received per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Packets Received Chart. To remove the data for a link from the chart, click 
the icon in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.
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Step 17 (Optional) To view a packets-sent-per-second chart for the linkset, select the 
Real-Time Data Charts tab. SGM displays the chart in the right panel 
(Figure 3-18).

Figure 3-18 Details Window, Showing Linkset Packets Sent Per Second

SGM displays the following information in the PktsSentPerSec chart:

• Linkset—Drop-down list box used to select the linkset for which data is to 
be displayed. By default, data is displayed for the selected linkset. To display 
data for the alternate linkset, select it in this list box.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
Packets Sent Chart. You cannot edit this field directly. Instead, edit the Poll 
Interval (secs) field at the top right of the Details window.
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• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Packets Sent Chart. Valid selections are 1, 2, 5, 10, 20, 
40, or 60 minutes. The default selection is 5 minutes.

• Packets Sent Chart—Displays the Packets Sent Per Sec for the linkset as a 
function of time, including data for up to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of packets sent per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Packets Sent Chart. To remove the data for a link from the chart, click the 
icon in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.
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Step 18 (Optional) To view a bits-received-per-second chart for the linkset (or a 
bytes-received-per-second chart, if you cleared the Show Details in Bits Instead 
of Bytes checkbox in the Preferences Window), select the Real-Time Data Charts 
tab. SGM displays the chart in the right panel (Figure 3-19).

Figure 3-19 Details Window, Showing Linkset Bits Received Per Second
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SGM displays the following information in the BitsRcvdPerSec or 
BytesRcvdPerSec chart:

• Linkset—Drop-down list box used to select the linkset for which data is to 
be displayed. By default, data is displayed for the selected linkset. To display 
data for the alternate linkset, select it in this list box.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
Bits Received Chart or Bytes Received Chart. You cannot edit this field 
directly. Instead, edit the Poll Interval (secs) field at the top right of the 
Details window.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Bits Received Chart or Bytes Received Chart. Valid 
selections are 1, 2, 5, 10, 20, 40, or 60 minutes. The default selection is 
5 minutes.

• Bits Received Chart or Bytes Received Chart—Displays the Bits Received 
Per Sec or Bytes Received Per Sec for the linkset as a function of time, 
including data for up to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of bits or bytes received per second for that data 
point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.
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To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Bits Received Chart or Bytes Received Chart. To remove the data for a link 
from the chart, click the icon in this field. To return the data to the chart, click 
the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Step 19 (Optional) To view a bits-sent-per-second chart for the linkset (or a 
bytes-sent-per-second chart, if you cleared the Show Details in Bits Instead of 
Bytes checkbox in the Preferences Window), select the Real-Time Data Charts 
tab. SGM displays the chart in the right panel (Figure 3-20).
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Figure 3-20 Details Window, Showing Linkset Bits Sent Per Second

SGM displays the following information in the BitsSentPerSec or 
BytesSentPerSec chart:

• Linkset—Drop-down list box used to select the linkset for which data is to 
be displayed. By default, data is displayed for the selected linkset. To display 
data for the alternate linkset, select it in this list box.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
Bits Sent Chart or Bytes Sent Chart. You cannot edit this field directly. 
Instead, edit the Poll Interval (secs) field at the top right of the Details 
window.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Bits Sent Chart or Bytes Sent Chart. Valid selections 
are 1, 2, 5, 10, 20, 40, or 60 minutes. The default selection is 5 minutes.
3-61
Cisco Signaling Gateway Manager User Guide

78-15204-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Linksets
• Bits Sent Chart or Bytes Sent Chart—Displays the Bits Sent Per Sec or 
Bytes Sent Per Sec for the linkset as a function of time, including data for up 
to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of bits or bytes sent per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Bits Sent Chart or Bytes Sent Chart. To remove the data for a link from the 
chart, click the icon in this field. To return the data to the chart, click the icon 
again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.
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Step 20 (Optional) To view a drops chart for the linkset, select the Real-Time Data Charts 
tab. SGM displays the chart in the right panel (Figure 3-21).

Figure 3-21 Details Window, Showing Linkset Drops

SGM displays the following information in the Drops chart:

• Linkset—Drop-down list box used to select the linkset for which data is to 
be displayed. By default, data is displayed for the selected linkset. To display 
data for the alternate linkset, select it in this list box.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
Drops Chart. You cannot edit this field directly. Instead, edit the Poll 
Interval (secs) field at the top right of the Details window.
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• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Drops Chart. Valid selections are 1, 2, 5, 10, 20, 40, or 
60 minutes. The default selection is 5 minutes.

• Drops Chart—Displays the Drops for the linkset as a function of time, 
including data for up to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of drops for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Drops Chart. To remove the data for a link from the chart, click the icon in 
this field. To return the data to the chart, click the icon again.
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To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Viewing ITP Link Statistics for a Linkset
The SGM Real-Time Charts - Link Statistics window displays link statistics for a 
linkset, such as received utilization percentage and packets received per second. 
The SGM Real-Time Charts - Link Statistics window is a “subset” of the Linkset 
Details pane (Figure 3-15), showing only the real-time data charts 
(ReceivedUtilization, SendUtilization, and so on).

To access the SGM Real-Time Charts - Link Statistics window, select a linkset in 
the Linkset or Topology window, then select Drill Down> Show Link Statistics 
from the right-click menu.

The SGM Real-Time Charts - Link Statistics window displays the following 
information for all charts:

• Node—Node with which the selected linkset is associated.

• Linkset—Drop-down list box used to select the linkset for which data is to 
be displayed. By default, data is displayed for the selected linkset. To display 
data for the alternate linkset, select it in this list box.

• Poll Interval (secs)—Drop-down list box used to specify the poll interval, in 
seconds, used to collect data for the Received Utilization Chart. Valid 
selections are 15, 30, 45, 60, 90, or 120 seconds. The default selection is 
15 seconds.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Received Utilization Chart. Valid selections are 1, 2, 
5, 10, 20, 40, or 60 minutes. The default selection is 5 minutes.

• APC—Point code of the adjacent node for the linkset.
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• Status—Current status of the linkset. Possible values are:

– Active (green ball)—The linkset is currently fully functional.

– Unavailable (red ball)—An error is preventing traffic from flowing on 
this linkset.

– Shutdown (blue ball)—A router administrator has set the linkset to 
prevent traffic from flowing. When a linkset is set to Shutdown, all its 
associated links are set to Failed by Cisco IOS.

– Unknown (red ball)—Either the node associated with this linkset has 
failed to respond to an SNMP request, or SGM found that the linkset no 
longer exists.

– Warning (yellow ball)—The linkset is active, but one or more links in 
the linkset is congested or is in Failed, Unknown, or Warning status, 
and is not Ignored. At least one link is available and can carry traffic.

There is no Unshut or No Shut status.

• Avail. Links—Number of links in the linkset that are available.

• Tot. Links—Total number of links in the linkset.

• Last Poll Error—Date and time the last polling error message was received 
by the node. If there have been no polling errors, SGM displays None.

• Reset—If you scrolled or zoomed the chart, resets the chart to the default 
view and scaling.

• Grid On—Superimposes a graphic grid on the chart. The grid can make the 
data easier to read.

• Grid Off—Removes the graphic grid from the chart.

• Close—Closes the SGM Real-Time Charts - Link Statistics window.

• Help—Displays online help for the current window.
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The SGM Real-Time Charts - Link Statistics window displays the following 
information in the ReceivedUtilization chart:

• Received Utilization Chart—Displays the average Receive Utilization % 
for all links on the linkset as a function of time, and optionally the Receive 
Utilization % for up to 16 individual links on the linkset.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the receive utilization percentage for that data point.

To remove the data for a link or for the average from the chart, click the icon 
in the SLC field. To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Received Utilization Chart, up to 16 total 
links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.
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• Show threshold line for:—Draws a horizontal line on the Received 
Utilization Chart, indicating the receive threshold for the selected link.

If you do not want to draw a threshold line, select None. This is the default 
setting.

• Scale to threshold—Scales the Received Utilization Chart in order to draw 
the threshold selected in the Show threshold line for field:

– To scale the chart, select this checkbox.

– To remove the scaling from the chart, clear this checkbox. This is the 
default setting.

The SGM Real-Time Charts - Link Statistics window displays the following 
information in the SendUtilization chart:

• Send Utilization Chart—Displays the average Send Utilization % for all 
links on the linkset as a function of time, and optionally the Send 
Utilization % for up to 16 individual links on the linkset.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the send utilization percentage for that data point.

To remove the data for a link or for the average from the chart, click the icon 
in the SLC field. To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.
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To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Send Utilization Chart, up to 16 total 
links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.

• Show threshold line for:—Draws a horizontal line on the Send Utilization 
Chart, indicating the send threshold for the selected link.

If you do not want to draw a threshold line, select None. This is the default 
setting.

• Scale to threshold—Scales the Send Utilization Chart in order to draw the 
threshold selected in the Show threshold line for field:

– To scale the chart, select this checkbox.

– To remove the scaling from the chart, clear this checkbox. This is the 
default setting.

The SGM Real-Time Charts - Link Statistics window displays the following 
information in the PktsRcvdPerSec chart:

• Packets Received Chart—Displays the Packets Received Per Sec for the 
linkset as a function of time, including data for up to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of packets received per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.
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New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Packets Received Chart.

To remove the data for a link from the chart, click the icon in this field. To 
return the data to the chart, click the icon again.

The SGM Real-Time Charts - Link Statistics window displays the following 
information in the PktsSentPerSec chart:

• Packets Sent Chart—Displays the Packets Sent Per Sec for the linkset as a 
function of time, including data for up to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of packets sent per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.
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New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Packets Sent Chart.

To remove the data for a link from the chart, click the icon in this field. To 
return the data to the chart, click the icon again.

The SGM Real-Time Charts - Link Statistics window displays the following 
information in the BitsRcvdPerSec or BytesRcvdPerSec chart:

• Bits Received Chart or Bytes Received Chart—Displays the Bits Received 
Per Sec or Bytes Received Per Sec for the linkset as a function of time, 
including data for up to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of bits or bytes received per second for that data 
point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.
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New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Bits Received Chart or Bytes Received Chart.

To remove the data for a link from the chart, click the icon in this field. To 
return the data to the chart, click the icon again.

The SGM Real-Time Charts - Link Statistics window displays the following 
information in the BitsSentPerSec or BytesSentPerSec chart:

• Bits Sent Chart or Bytes Sent Chart—Displays the Bits Sent Per Sec or 
Bytes Sent Per Sec for the linkset as a function of time, including data for up 
to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of bits or bytes sent per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.
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New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Bits Sent Chart or Bytes Sent Chart.

To remove the data for a link from the chart, click the icon in this field. To 
return the data to the chart, click the icon again.

The SGM Real-Time Charts - Link Statistics window displays the following 
information in the Drops chart:

• Drops Chart—Displays the Drops for the linkset as a function of time, 
including data for up to 16 links.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of drops for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.
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New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Drops Chart.

To remove the data for a link from the chart, click the icon in this field. To 
return the data to the chart, click the icon again.

Editing a Linkset
SGM enables you to annotate a linkset, attaching a descriptive string to the 
linkset.

To annotate a linkset:

Step 1 Select a linkset in the Linkset window (Figure 3-10) or Topology window 
(Figure 3-54).

Step 2 Select Edit>Selected Item in the SGM Main Menu. SGM displays the Edit 
Linkset Dialog (Figure 3-22).
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Figure 3-22 Edit Linkset Dialog

If both ends of the linkset are known to SGM, one is displayed in the top half of 
the Edit Linkset Dialog, the other in the bottom half. If only one end is known to 
SGM, only that end is displayed.

The Edit Linkset Dialog displays the name of the linkset and the date and time the 
Notes field for the linkset was last updated. If there is no note currently associated 
with the linkset, the Note Last Updated field displays the value Not Set.
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Step 3 In the Notes field, enter any important information about the linkset, such as a 
detailed description, its location, its service history, and so on.

Step 4 Click Save to save the annotations and exit the Edit Linkset Dialog.

Viewing Notes for a Linkset
SGM enables you to view the notes that have been attached to linksets.

To view a note, use one of the following procedures:

• Select a linkset in the Linkset Window or Topology Window, then select 
View >Notes from the SGM Main Menu.

• Right-click a linkset in the Linkset Window or Topology Window, then select 
View >Notes in the right-click menu.

If the linkset has an attached note, SGM displays the Linkset Notes dialog 
(Figure 3-23). (If the linkset does not have an attached note, SGM displays the 
message, “The linkset pair does not have any notes.”)

Figure 3-23 Linkset Notes Dialog
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If both ends of the linkset are known to SGM, notes for one end are displayed in 
the left half of the Linkset Notes dialog, and notes for the other end are displayed 
in the right half. If only one end is known to SGM, only notes for that end are 
displayed.

The Linkset Notes dialog displays the following information:

• Name—Name of the linkset.

• Note Last Updated—Date and time the Notes field for the linkset was last 
updated.

• Notes—Notes associated with the linkset.

Click OK to close the Linkset Notes dialog.

Deleting a Linkset
After Discovery, the linksets in your network are known to SGM and added to the 
SGM database. Physically deleting linksets from your network is not the same as 
deleting them from the SGM database. The following sections describe the 
differences between deleting linksets from your network and from the SGM 
database, and the procedures for doing so:

• Deleting a Linkset from Your Network, page 3-77

• Deleting a Linkset from the SGM Database, page 3-78

Deleting a Linkset from Your Network

If you physically delete a known linkset from your network, it remains in the SGM 
database, SGM labels it Unknown, and it is the system administrator’s 
responsibility to delete it from the SGM database, if you choose to do so. SGM 
labels all associated nodes Warning and all associated links Unknown.

When you redefine the linkset (that is, when you define a linkset with the same 
destination point code as the original linkset, but not necessarily with the same 
linkset name), SGM rediscovers the linkset and labels it with the appropriate 
status (such as Active).
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Deleting a Linkset from the SGM Database

Typically, you delete a linkset in the SGM database for one of the following 
reasons:

• You have physically deleted the linkset from your network. This is the most 
common reason for deleting a linkset from the SGM database.

• The linkset is Unknown or Unavailable, you are aware of the reason, and you 
no longer want to see it in SGM displays. For example, the linkset might be 
associated with a node that was removed from the network, or it might be a 
previously discovered linkset associated with a test lab device.

If you have physically deleted a known linkset from your network, and you then 
delete it from SGM, it is no longer in the SGM database, it does not appear in 
SGM windows, and it is not discovered when you run Discovery.

If you have not physically deleted a known linkset from your network, and you 
delete it from SGM, SGM also automatically deletes all associated links from the 
SGM database. However, at the next poll SGM finds the linkset and associated 
links and adds them back to the SGM database, setting the status appropriately. If 
this happens, do not delete the linkset again. Instead, set it to Ignored. See the 
“Ignoring a Linkset” section on page 3-79 for more information.

Note If you delete a linkset from the SGM database, the linkset is deleted for all SGM 
clients and views connected to that SGM server.

If you delete all linksets to an Unmanaged node, SGM does not automatically 
delete the node. Instead, you must manually delete the node. See the “Deleting a 
Node” section on page 3-105 for more information.

To delete a linkset from the SGM database, use one of the following procedures:

• Select one or more linksets in the Linkset window (Figure 3-10) or Topology 
window (Figure 3-54), then select Edit>Delete from the SGM Main Menu.

• Right-click a linkset in the Linkset Window or Topology Window, then select 
Delete Linkset in the right-click menu. (You cannot delete more than one 
linkset at a time from the right-click menu.)
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SGM asks you to confirm the deletion:

• Select Yes to delete the selected linksets. SGM deletes the linksets and all 
associated links from the SGM database. However, if the linksets were not 
physically deleted from your network, then at the next poll SGM finds the 
linksets and their associated links and adds them back to the SGM database, 
setting the status appropriately.

• Select No to return to the Linkset window or Topology window without 
deleting any linksets or links from the SGM database.

You can also use the sgm delete linkset command to delete one or more linksets 
from the SGM database. See the “SGM Commands and Descriptions” section on 
page B-2 for more information on the use of this command.

Ignoring a Linkset
You can instruct SGM to ignore a linkset when it aggregates and displays network 
data. Setting linksets to Ignored prevents known linkset problems from affecting 
SGM displays for associated nodes. In effect, you are preventing a known 
problem from distracting you from other, more urgent network problems.

For example, you can set a linkset to Ignored before shutting down the linkset for 
maintenance.

Note If you set a linkset to Ignored, the linkset is ignored for all SGM clients and views 
connected to that SGM server.

Also, if you set a linkset to Ignored, make a note of the change, and do not forget 
to reset the linkset when the problem is corrected or the maintenance is complete.

You can set a linkset to Ignored in either the Linkset window or the Topology 
window.

• To set a linkset to Ignored in the Linkset Window, select the Ignored 
checkbox for the linkset you want SGM to ignore.

• To set a linkset to Ignored in the Topology window (Figure 3-54), select a 
linkset in the topology map, then, in the left pane, select the Ignored 
checkbox for the linkset you want SGM to ignore.
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Viewing Ignored Linksets
To display all linksets that are Ignored:

Step 1 Select View > Ignored Items from the SGM Main Menu. SGM displays the 
Ignored Items Dialog (Figure 3-24).

Figure 3-24 Ignored Items Dialog, Showing Ignored Linksets

Step 2 Click the Linksets tab to display all linksets that are Ignored.

Step 3 (Optional) To stop ignoring one or more linksets, select the linksets, then click 
Unignore.

Step 4 (Optional) To stop ignoring all linksets, click Unignore All.
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Working with Nodes
SGM enables you to view information about all discovered nodes, including their 
IP addresses, status, and other important information.

This section includes the following information:

• Viewing Basic Information for Nodes, page 3-81

• Viewing Detailed Information for a Node, page 3-85

• Viewing CPU Statistics for a Node, page 3-97

• Editing a Node, page 3-99

• Viewing Notes for a Node, page 3-103

• Deleting a Node, page 3-105

• Unmanaging and Managing a Node, page 3-108

• Polling a Node, page 3-109

• Excluding a Node from a View, page 3-111

Related Topics:

• Modifying Preference Settings, page 5-3

• Resizing, Sorting, and Hiding Table Columns, page 3-178

• Viewing the Topology of the Network, page 3-163

• Working with Links, page 3-111

• Working with Linksets, page 3-34

Viewing Basic Information for Nodes
To view basic information for nodes, select View > Nodes from the SGM Main 
Menu. SGM displays the Node Window (Figure 3-25).
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Figure 3-25 Node Window

The Node Window displays information about the nodes that have been 
discovered by SGM.

By default, SGM displays all of the columns in the Node Window except Internal 
ID, CLLI Code, Secondary Point Code, Capability Point Code, and Notes. To 
display these columns, or to hide other columns, see the procedures in the 
“Modifying Node Table Column Settings” section on page 5-15.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-178 for more details. By default, this table is sorted by Status.

The Node Window displays the following information for each discovered node:

• Internal ID—Internal ID of the node. The internal ID is a unique ID for every 
event, link, linkset, and node, assigned by SGM for its own internal use. It can 
also be useful when the TAC is debugging problems.

• Name—Name or IP address of the node.
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• CLLI Code—COMMON LANGUAGE Location Code for the node. A CLLI 
code is a standardized 11-character identifier that uniquely identifies the 
geographic location of the node. If the node has no CLLI code configured, 
this field is blank.

• Primary SNMP Address—IP address of the node, used by SNMP to poll the 
node.

• Point Code—Primary point code of the node.

• Secondary Point Code—Secondary point code of the node. If the node has 
no secondary point code, this field is blank.

• Capability Point Code—Capability point code of the node. A capability 
point code, also called an alias point code, is one that is shared by more than 
one node, each of which is also assigned a “real” point code. If the node has 
no capability point code, this field is blank.

• Device Type—Device type of the node. Possible values are:

– Cisco2600—Cisco 2651 series router

– Cisco7202—Cisco 7202 series router

– Cisco7204—Cisco 7204VXR series router

– Cisco7206—Cisco 7206VXR series router

– Cisco7507—Cisco 7507 series router

– Cisco7513—Cisco 7513 series router

– IPDevice—IP device, other than Cisco 2651, 7202, 7204VXR, 
7206VXR, 7507, or 7513 series router. You can assign this icon to an 
unknown node if you know that it is an IP device.

– Unknown—SGM is unable to determine the device type.

• Notes—Indicates whether there is a note associated with the node.
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• Events—Indicates whether there is a recent event associated with the node.

– To delete the event icon from SGM displays for a specific node, select the 
node and click the icon.

– To delete the event icon from SGM displays for all nodes, select 
Edit>Clear Event Icon> All from the SGM Main Menu.

Note During Discovery, SGM might flag most nodes with an event icon. If 
the event icons are too distracting, use the Edit> Clear Event 
Icon>All menu option to remove them.

• Status—Current status of the node. Possible values are:

– Active (green ball)—The node is currently fully functional.

– Discovering (gray ball)—The node is being discovered, and SNMP 
queries have been sent to the device.

– Polling (gray ball)—The node is being polled.

– Unknown (red ball)—The node failed to respond to an SNMP request. 
The node and all associated linksets and links are set to Unknown.

– Unmanaged (gray ball)—One of the following situations exists:

– The node is known indirectly by SGM. In other words, SGM knows the 
device exists but there is no known SNMP stack on the device for SGM 
to query.

– An SGM user has set the node to Unmanaged status, to prevent SGM 
from collecting statistics for the node.

– Waiting (gray ball)—The node is in the Discovery queue but is not 
currently being discovered.

– Warning (yellow ball)—The node is active, but one or more associated 
links or linksets is in Failed, Unavailable, Unknown, or Warning status 
and is not Ignored.
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Viewing Detailed Information for a Node
To view detailed information about a node, including its CLLI code, point code, 
status, and other information:

Step 1 Select a node in the Node window (Figure 3-25) or Topology window 
(Figure 3-54).

Step 2 Select View > Details from the SGM Main Menu. SGM prompts you to select a 
linkset associated with the node. (To find out how to disable this prompt, see Step 
4 in the “Modifying Overall Preference Settings” section on page 5-5.)

Step 3 Select a linkset.

Step 4 Click OK. SGM displays the Details Window for that node, linkset, and 
associated links, with configuration data for the node in the right panel 
(Figure 3-26).

Figure 3-26 Details Window, Showing Node Configuration Data
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If the Node Details pane is not already displayed, click Node in the left pane. 
SGM displays detailed information for the node in the right pane.

To display detailed information for the adjacent node, select AdjNode in the left 
pane of the Details window.

Note SGM considers the node that it discovered first to be the primary node, 
and the other node to be the adjacent node. If, in the next Discovery, SGM 
discovers the adjacent node first, it considers that node to be the primary 
node and the former primary node to be the new adjacent node. Thus, in 
SGM, linkset sgm-2600a-to-sgm-7500j is equivalent to 
sgm-7500j-to-sgm-2600a.

If you are viewing details for a full connection (node, adjacent node, and 
the associated linksets and links) then this window polls your network 
periodically. To prevent unnecessary traffic on your network, close this 
window when you no longer need to refer to it.

If you are viewing details for a node only (no adjacent node, linksets, or 
links), then this window does not poll your network periodically, and 
updates for the node are not reflected automatically in this window. If you 
close the window, the data is updated the next time you open the window.

The Poll Interval section at the top right of the Details window displays the time 
of the last poll, and enables you to change the poll interval:

• The Last Poll field initially displays the phrase Waiting for first poll. After 
the first polling cycle, SGM populates this field with the actual time of the 
last poll.

• To change the poll interval, enter a new value (in seconds) and click Apply. 
The valid range is 15 to 999 seconds. The default value is 15 seconds.

The Error Message section of the Details window displays the last error messages 
received by the node and by the adjacent node.

Updates for the node that are received from the SGM server are reflected 
automatically in this window.

Changes you make in this pane might not be reflected throughout SGM until the 
next poll (by default, every 15 seconds). For information about changing the 
polling interval, see the “Viewing Detailed Information for a Node” section on 
page 3-85.
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Step 5 (Optional) To view naming information for the node, select the Configuration 
Data tab. SGM displays the Naming Information table, which contains the 
following information:

• Display Name—Name of the node.

• IP Address or DNS Hostname—IP address or DNS name of the node, as 
discovered by SGM. However, if you modified your preferences to identify 
nodes by their IP addresses, point codes, or CLLI codes, then that is how the 
node is identified in this field. For more information, see the “Modifying 
Overall Preference Settings” section on page 5-5.

• CLLI Code—COMMON LANGUAGE Location Code for the node. A CLLI 
code is a standardized 11-character identifier that uniquely identifies the 
geographic location of the node. If the node has no CLLI code configured, 
this field is blank.

• Icon Name—Name of the graphic icon to assign to this node in topology 
maps. SGM automatically assigns an appropriate icon to each discovered 
Cisco router, and to Unknown nodes, but you can use this field to assign a 
different icon. Valid values are:

– Cisco2600—Cisco 2651 series router

– Cisco7202—Cisco 7202 series router

– Cisco7204—Cisco 7204VXR series router

– Cisco7206—Cisco 7206VXR series router

– Cisco7507—Cisco 7507 series router

– Cisco7513—Cisco 7513 series router

– IPDevice—IP device, other than Cisco 2651, 7202, 7204VXR, 
7206VXR, 7507, or 7513 series router. You can assign this icon to an 
unknown node if you know that it is an IP device.

– MSC—Mobile switching center. You can assign this icon to an unknown 
node if you know that it is an MSC.

– SCP—Service control point. You can assign this icon to an unknown 
node if you know that it is an SCP.

– SSP—Service switching point. You can assign this icon to an unknown 
node if you know that it is an SSP.
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– STP—Signal transfer point. You can assign this icon to an unknown node 
if you know that it is an STP.

– Unknown—SGM is unable to determine the node type.

When you click Save, the Topology Window is updated automatically to 
reflect the new icon.

• Device Type—Device type of the node. Possible values are:

– Cisco2600—Cisco 2651 series router

– Cisco7202—Cisco 7202 series router

– Cisco7204—Cisco 7204VXR series router

– Cisco7206—Cisco 7206VXR series router

– Cisco7507—Cisco 7507 series router

– Cisco7513—Cisco 7513 series router

– IPDevice—IP device, other than Cisco 2651, 7202, 7204VXR, 
7206VXR, 7507, or 7513 series router. You can assign this icon to an 
unknown node if you know that it is an IP device.

– Unknown—SGM is unable to determine the device type.

• First Discovered—Date and time that the node was first discovered by SGM.

• Internal ID—Internal ID of the node. The internal ID is a unique ID for every 
event, link, linkset, and node, assigned by SGM for its own internal use. It can 
also be useful when the TAC is debugging problems.
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Step 6 (Optional) To view descriptive information for the node, select the Configuration 
Data tab. SGM displays the Descriptive Information table, which contains the 
following information:

• Description—Description of the node. If the node has no description, this 
field is blank.

• Router Version—Version of IOS that is installed on the router.

• Recognized MIB Level—MIB conformance level used by the router, such as 
ITP MB5.

Note Router Version and Recognized MIB Level might not have a one-to-one 
correspondence, because multiple router versions can use the same MIB 
level if there are no changes to the MIBs between versions. For example, 
router versions 12.2(4)MB5 and 12.2(4)MB6 both use MIB level 
ITP MB5.

Step 7 (Optional) To view point code information for the node, select the Configuration 
Data tab. SGM displays the Point Code Information table, which contains the 
following information:

• Point Code—Primary point code of the node.

• Secondary Point Code—Secondary point code of the node. If the node has 
no secondary point code, this field is blank.

• Capability Point Code—Capability point code of the node. A capability, or 
alias, point code is one that is shared by more than one node, each of which 
is also assigned a “real” point code. If the node has no capability point code, 
this field is blank.

Step 8 (Optional) To view point QoS for the node, select the Configuration Data tab. 
SGM displays the QoS Information table, which displays the quality of service 
(QoS) class of the node, mapped in tabular format to the type of service (ToS) or 
IP differentiated-services-code-point (DSCP).
3-89
Cisco Signaling Gateway Manager User Guide

78-15204-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Nodes
Step 9 (Optional) To view the IP addresses associated with this node that are intended for 
SNMP, select the Configuration Data tab. SGM displays the IP Addresses for 
SNMP table:

• IP Address—IP addresses associated with this node, including the primary 
SNMP address and all backup IP addresses, that are intended for SNMP.

• Last Full Router Poll—Date and time of the last full poll of the node for 
ITP-related MIBs (as opposed to a demand poll for just one linkset’s worth of 
data).

If the IP address has never been polled, SGM displays the phrase Never 
Polled.

If there are no IP addresses defined for the node that are intended for SNMP, 
this field displays the phrase There are no other IP addresses defined for 
this node.

Step 10 (Optional) To view the IP addresses associated with this node that are not intended 
for SNMP, select the Configuration Data tab. SGM displays the IP Addresses Not 
for SNMP table, which includes the following information:

• IP Address—IP addresses associated with this node that are not intended for 
SNMP.

If there are no IP addresses defined for the node that are not intended for 
SNMP, this field displays the phrase There are no other IP addresses 
defined for this node.
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Step 11 (Optional) To view general statistics for the node, select the Statistics tab. SGM 
displays statistics for the node in the right panel (Figure 3-27).

Figure 3-27 Details Window, Showing Node Statistics

SGM displays the General Stats table:

• Router Up Time—Time the router has been up, in weeks, days, hours, and 
minutes.

• Reboot Reason—Reason for the last reboot of the router.
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Step 12 (Optional) To view poll statistics for the node, select the Statistics tab. SGM 
displays the Poll Stats table:

• Status—Current status of the node. Possible values are:

– Active (green ball)—The node is currently fully functional.

– Discovering (gray ball)—The node is being discovered, and SNMP 
queries have been sent to the device.

– Polling (gray ball)—The node is being polled.

– Unknown (red ball)—The node failed to respond to an SNMP request. 
The node and all associated linksets and links are set to Unknown.

– Unmanaged (gray ball)—One of the following situations exists:

- The node is known indirectly by SGM. In other words, SGM knows the 
device exists but there is no known SNMP stack on the device for SGM 
to query.

- An SGM user has set the node to Unmanaged status, to prevent SGM 
from polling the node. SGM asks if you also want to automatically 
delete all associated links and linksets, as well as all linksets that 
reference the node as an adjacent node.

– Waiting (gray ball)—The node is in the Discovery queue but is not 
currently being discovered.

– Warning (yellow ball)—The node is active, but one or more associated 
links or linksets is in Failed, Unavailable, Unknown, or Warning status 
and is not Ignored.

• Last State Change—Date and time that the status of the node last changed.

• Last Poll IP Address—Last IP address that was polled for this node. For a 
non-ITP node, this field is left blank.

• Last Full Router Poll—Date and time of the last full poll of the node for 
ITP-related MIBs (as opposed to a demand poll for just one linkset’s worth of 
data). For a non-ITP node, this field is left blank.

• Last SGM Poll Response (secs)—Time, in seconds, taken by this node to 
respond to the last SGM poll request. For a non-ITP node, this field is left 
blank.

• Avg. SGM Poll Response (secs)—Average time, in seconds, taken by this 
node to respond to SGM poll requests. For a non-ITP node, this field is left 
blank.
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Step 13 (Optional) To view notes associated with the node, select the Notes tab. SGM 
displays notes for the node in the right panel (Figure 3-28).

Figure 3-28 Details Window, Showing Node Notes

SGM displays the following information:

• Notes associated with the node.

• The date and time the notes were last updated.

• The phrase No Notes if there are no notes associated with the node.

Step 14 (Optional) To view recent events associated with the node, select the Recent 
Events tab. SGM displays recent events for the node in the right panel 
(Figure 3-29).
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Figure 3-29 Details Window, Showing Node Events

SGM displays the following information:

• By default, SGM displays only unacknowledged events in this table. To 
display acknowledged events in the table, see Step 7 in the “Modifying 
Overall Preference Settings” section on page 5-5.

• Ack—Indicates whether the event has been acknowledged:

– To acknowledge an unacknowledged event, select this checkbox.

– To make a previously acknowledged event unacknowledged, clear this 
checkbox.

• Note—Indicates whether there is a note associated with the event.

• Severity—Severity of the event. Default values are:

– Admin—The default color is cyan.

– Error—The default color is coral.

– None—The default color is white.

– Normal—The default color is light green.

– Warning—The default color is yellow.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-25 for more 
information.
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• Time—Date and time the event was logged.

• Message—Text of the message.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-25 for more 
information.

Step 15 (Optional) To view a CPU utilization chart for the node, select the Real-Time Data 
Charts tab. (The Real-Time Data Charts tab is not available if the node is in 
Discovery, Polling, Unknown, or Unmanaged status.) SGM displays the chart in 
the right panel (Figure 3-30).

Figure 3-30 Details Window, Showing Node CPU Utilization
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SGM displays one CPU Utilization Percentage chart for the active Route Switch 
Processor (RSP) CPU.

• Node—Node for which data is to be displayed.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
CPU Utilization Chart. You cannot edit this field directly. Instead, edit the 
Poll Interval (secs) field at the top right of the Details window.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the CPU Utilization Chart. Valid selections are 1, 2, 5, 10, 
20, 40, or 60 minutes. The default selection is 5 minutes.

• CPU Utilization Chart—Displays the CPU utilization percentage for the 
node as a function of time.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the CPU utilization percentage for that data point.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.
3-96
Cisco Signaling Gateway Manager User Guide

78-15204-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Nodes
• Time Average—Displays three color-coded icons, one for each average 
calculation: 5 seconds, 1 minute, and 5 minutes.

To remove the data for a given average from the chart, click the icon in this field. 
To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Viewing CPU Statistics for a Node
The SGM Real-Time Charts - CPU Statistics window displays the CPU utilization 
percentage for a node as a function of time. SGM displays one CPU Utilization 
Percentage chart for the active Route Switch Processor (RSP) CPU.

The SGM Real-Time Charts - CPU Statistics window is a “subset” of the Node 
Details pane (Figure 3-30), showing only the CPU utilization chart.

To access the SGM Real-Time Charts - CPU Statistics window, select a node in 
the Node or Topology window, then select Drill Down> Show CPU Statistics 
from the right-click menu. (This option is available only if SGM can poll the 
node.)

The SGM Real-Time Charts - CPU Statistics window displays the following 
information for the selected node:

• Node—Name of the node for which CPU statistics are being displayed. To 
see detailed information for the node, click the node name.

• Poll Interval (secs)—Drop-down list box used to specify the poll interval, in 
seconds, used to collect data for the CPU Utilization Chart. Valid selections 
are 15, 30, 45, 60, 90, or 120 seconds. The default selection is 15 seconds.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the CPU Utilization Chart. Valid selections are 1, 2, 5, 10, 
20, 40, or 60 minutes. The default selection is 5 minutes.

• Last Poll Error—Date and time the last polling error message was received 
by the node. If there have been no polling errors, SGM displays None.
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• CPU Utilization Chart—Displays the CPU utilization percentage for the 
node as a function of time.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the CPU utilization percentage for that data point.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• Time Average—Displays three color-coded icons, one for each average 
calculation: 5 seconds, 1 minute, and 5 minutes.

To remove the data for a given average from the chart, click the icon in this 
field. To return the data to the chart, click the icon again.

• Reset—If you scrolled or zoomed the chart, resets the chart to the default 
view and scaling.

• Grid On—Superimposes a graphic grid on the chart. The grid can make the 
data easier to read.

• Grid Off—Removes the graphic grid from the chart.

• Close—Closes the SGM Real-Time Charts - CPU Statistics window.

• Help—Displays online help for the current window.
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Editing a Node
By default, when SGM discovers a node, it displays the node's DNS name in 
windows. However, if you modified your preferences to identify nodes by their 
IP addresses, point codes, or CLLI codes, then that is how the node is identified 
in windows. For more information, see the “Modifying Overall Preference 
Settings” section on page 5-5.

You can also specify a new, more meaningful name for the node if you want to, 
and you can also annotate a node, attaching a descriptive string. 

To change a node’s name or annotate the node: 

Step 1 Select a node in the Node window or the Topology window.

Step 2 Select Edit > Selected Item in the SGM Main Menu. SGM displays the Edit Node 
Dialog (Figure 3-31).
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Figure 3-31 Edit Node Dialog

Step 3 (Optional) Initially, the Name field displays the node's DNS name, as discovered 
by SGM.

Note This field might display the IP address, point code, or CLLI code of the 
node instead of its DNS name, depending on the Node Name setting in 
your preferences file. See the “Modifying Overall Preference Settings” 
section on page 5-5 for more information.
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If you want to change the displayed name of the node to a new, more meaningful 
name, enter the new name in the Name field, keeping in mind the following 
considerations:

• You can change an ITP node's name to a new name or IP address.

• You can change a non-ITP legacy node's name to a new name, but not to a new 
point code.

• A new name can be from 1 to 30 characters, and can contain any letters, 
numbers, or special characters, but no periods (.). If you enter a name that 
contains a period, SGM beeps and retains the current name

• A new IP address must use the x.x.x.x format, where x is between 0 and 255, 
and must contain only numbers and periods, but no letters or special 
characters. If you enter an IP address that contains any letters or special 
characters, SGM beeps and retains the current name.

• If you leave the Name field blank, SGM reverts to the node’s default name 
(the DNS name for an ITP node, the point code for a non-ITP node).

• The new node name is used when launching context-based applications, such 
as CiscoWorks2000. Therefore, if the new name you enter is not the node's 
DNS name, and the application knows the node by its DNS name, context 
links into the application for that node might not work. 

Step 4 (Optional) SGM automatically assigns an appropriate icon to each discovered 
Cisco router, and to Unknown nodes. If you want to change to a different icon 
(for example, if you know that a given Unknown node is a mobile switching 
center), select a new icon from the Icon Name drop-down list box. Valid values 
are:

• Cisco2600—Cisco 2651 series router

• Cisco7202—Cisco 7202 series router

• Cisco7204—Cisco 7204VXR series router

• Cisco7206—Cisco 7206VXR series router

• Cisco7507—Cisco 7507 series router

• Cisco7513—Cisco 7513 series router

• IPDevice—IP device, other than Cisco 2651, 7202, 7204VXR, 7206VXR, 
7507, or 7513 series router. You can assign this icon to an unknown node if 
you know that it is an IP device.
3-101
Cisco Signaling Gateway Manager User Guide

78-15204-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Nodes
• MSC—Mobile switching center. You can assign this icon to an unknown 
node if you know that it is an MSC.

• SCP—Service control point. You can assign this icon to an unknown node if 
you know that it is an SCP.

• SSP—Service switching point. You can assign this icon to an unknown node 
if you know that it is an SSP.

• STP—Signal transfer point. You can assign this icon to an unknown node if 
you know that it is an STP.

• Unknown—SGM is unable to determine the node type.

Step 5 (Optional) If the selected node is an ITP node, the IP Addresses for SNMP field 
lists all IP addresses associated with the node that SGM can use for SNMP 
polling, and the Available Router IP Addresses field lists all IP addresses 
associated with the node that you do not want SGM to use for SNMP polling. 
SGM does not send SNMP queries to IP addresses in the Available Router IP 
Addresses list.

By default, SGM places all discovered IP addresses in the IP Addresses for 
SNMP list, in the order in which they are discovered. SGM uses the IP address at 
the top of the list as the primary SNMP address for the node.

During SNMP polling of the node (both status polling and demand polling), SGM 
first tries the primary SNMP address. If the primary is unavailable, SGM tries the 
other IP addresses, one-by-one, in descending order.

To assign a new primary SNMP address, or to change the order of the secondary 
IP addresses, use the Raise Priority and Lower Priority buttons to move the IP 
addresses up and down in the IP Addresses for SNMP list.

You can also select IP addresses that you do not want SGM to use for SNMP 
polling. This is useful, for example, to separate management traffic from SMS 
traffic. To remove an IP address from the IP Addresses for SNMP list, click 
Remove. The IP address is removed from the IP Addresses for SNMP list and 
appears in the Available Router IP Addresses list, and is no longer used by SGM 
for SNMP polling.

To enable an IP address for SNMP polling again, select the address in the 
Available Router IP Addresses list and click Add. The IP address moves back 
into the IP Addresses for SNMP list and is again available for SNMP polling.

If you remove all IP addresses from the IP Addresses for SNMP list, you in effect 
remove the node from the network, and SGM automatically labels the node 
Unmanaged in all SGM windows.
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When you click Save, all SGM windows are updated automatically to reflect the 
changes.

This menu option is displayed only for ITP nodes.

Step 6 (Optional) SGM automatically assigns an IP address to each discovered node. 
However, if a node has more than one IP address, you can select which interface 
SGM is to use as the primary SNMP address for all subsequent SNMP polling 
(both status polling and demand polling). This enables you to, for example, 
separate the management traffic from the SMS traffic.

To select a new interface, select a new IP address from the IP Address List 
drop-down list box. All IP addresses associated with the node are included in the 
list box, including the primary SNMP address and all backup IP addresses.

Step 7 (Optional) To attach a note to the node, use the Notes field. In this field, you can 
enter any important information about the node, such as a detailed description, its 
location, its service history, and so on. When you annotate a node, the topology 
map in the Topology window displays a note icon in the upper left corner of the 
node element.

The Note Last Updated field displays the date and time the Notes field was last 
updated. If there is no note currently associated with this node, this field displays 
the value Not Set.

Step 8 When you are satisfied with your changes, click Save. SGM saves your changes 
and updates all SGM windows to reflect your changes.

Viewing Notes for a Node
SGM enables you to view the notes that have been attached to nodes.

To view a note, use one of the following procedures:

• Select a node in the Node Window or Topology Window, then select 
View >Notes from the SGM Main Menu.

• Right-click a node in the Node Window or Topology Window, then select 
View >Notes in the right-click menu.

If the node has an attached note, SGM displays the Notes for Node dialog 
(Figure 3-32). (If the node does not have an attached note, SGM displays the 
message, “Node name does not have a note.”)
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Figure 3-32 Notes for Node Dialog

The Notes for Node dialog displays the following information:

• The name of the node is displayed in the title of the window (for example, 
Notes for sgm-2600a.)

• Last Updated—Date and time the Notes field for the node was last updated.

• Notes—Notes associated with the node.

Click OK to close the Notes for Node dialog.
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Deleting a Node
After Discovery, the nodes in your network are known to SGM and added to the 
SGM database. Physically deleting nodes from your network is not the same as 
deleting them from the SGM database. The following sections describe the 
differences between deleting nodes from your network, from the SGM database, 
and from the SGM Discovery database, and the procedures for doing so:

• Deleting a Node from Your Network, page 3-105

• Deleting a Node from the SGM Database, page 3-105

• Deleting a Node from the SGM Discovery Database, page 3-107

Deleting a Node from Your Network

If you physically delete a known node from your network (for example, by 
powering down a router), it remains in the SGM database, SGM labels it 
Unknown, and it is the system administrator’s responsibility to delete it from the 
SGM database, if you choose to do so. SGM also labels all associated linksets and 
links Unknown because SGM attempts to poll the node and gets no response.

Deleting a Node from the SGM Database

Typically, you delete a node from the SGM database for one of the following 
reasons:

• You have physically deleted the node from your network. This is the most 
common reason for deleting a node from the SGM database.

• The node is Unknown or Unmanaged, you are aware of the reason, and you 
no longer want to see it in SGM displays. For example, the node might be a 
test lab device.

• If you delete all linksets to an Unmanaged node, SGM does not 
automatically delete the node. Instead, you must manually delete the node.

If you have physically deleted a known node from your network, and you then 
delete it from SGM, it is no longer in the SGM database, it does not appear in 
SGM windows, and it is not discovered when you run Discovery.
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Be aware of the following special situations:

• If you have not physically deleted a known node from your network, and you 
delete it from SGM, SGM removes the node from the poll list, and at the next 
poll SGM returns the node to the DEFAULT view, and labels the node as a 
new node if you are using a custom view.

• If a node has at least one adjacent node in Active, Discovering, Waiting, or 
Warning state, you cannot delete the node. If you try to do so, SGM cancels 
the deletion.

If either of these situations occurs, do not delete the node again. Instead, perform 
one of the following actions:

• Label the node Unmanaged. See the “Unmanaging and Managing a Node” 
section on page 3-108 for more details.

• Remove the node from your view. See the “Working with Views” section on 
page 3-23 for more details.

Note If you delete a node from the SGM database, the node is deleted for all SGM 
clients and views connected to that SGM server.

To delete a node from the SGM database, use one of the following procedures:

• Select one or more nodes in the Node window (Figure 3-25) or Topology 
window (Figure 3-54), then select Edit>Delete from the SGM Main Menu.

• Right-click a node in the Node Window or Topology Window, then select 
Delete Node in the right-click menu. (You cannot delete more than one node 
at a time from the right-click menu.)

SGM asks you to confirm the deletion:

• Select Yes to delete the selected nodes. SGM deletes the nodes from the SGM 
database.

• Select No to return to the Node window or Topology window without deleting 
any nodes from the SGM database.

You can also use the sgm delete node command to delete one or more nodes from 
the SGM database. See the “SGM Commands and Descriptions” section on 
page B-2 for more information on the use of this command.
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Note If you delete a node from the SGM database, SGM removes it from the Nodes In 
Current View pane of the Network View Editor window. If SGM then rediscovers 
the node, SGM places it in the new nodes list in the Nodes Not In Current View 
pane of the Network View Editor window. To restore the node to your current 
view, you must add it to the Nodes In Current View pane. For more information, 
see the “Working with Views” section on page 3-23.

Deleting a Node from the SGM Discovery Database

If you want to completely eliminate a given node from the SGM database, you can 
delete it from the SGM Discovery database, ensuring that it is never even 
discovered by SGM.

Note If you delete a node from the SGM Discovery database, the node is deleted for all 
SGM clients and views connected to that SGM server.

To delete a node from the SGM Discovery database:

Step 1 Select Edit>Network Discovery from the SGM Main Menu. SGM displays the 
Discovery Dialog (Figure 3-2).

Step 2 Select the Discovery tab. SGM displays the Discovery panel (Figure 3-4).

Step 3 In the Discovered Nodes table, select the node or nodes you want to delete.

Step 4 Click Delete Node. SGM deletes the nodes from the Discovery database, without 
asking for confirmation. The nodes will no longer be discovered by SGM.
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Unmanaging and Managing a Node
SGM enables you to label a node Unmanaged, and to remove the Unmanaged 
status from a node.

In some situations, you might not want to see a given node or nodes in SGM 
displays, but you might be unable to delete it from the SGM database. For 
example:

• If you have not physically deleted a known node from your network, and you 
delete it from SGM, SGM removes the node from the poll list, and at the next 
poll SGM returns the node to the DEFAULT view, and labels the node as a 
new node if you are using a custom view.

• If a node has at least one adjacent node in Active, Discovering, Waiting, or 
Warning state, you cannot delete the node. If you try to do so, SGM cancels 
the deletion.

If these situations, you can label the node Unmanaged. When you label a node 
Unmanaged, SGM removes the node from the poll list.

Note If you label a node Unmanaged, the node is Unmanaged for all SGM clients and 
views connected to that SGM server.

To label a node Unmanaged:

Step 1 Select one or more nodes in the Node window (Figure 3-25) or Topology window 
(Figure 3-54).

You cannot label a node Unmanaged if it has a Device Type of Unknown:

• If you select a node with a Device Type of Unknown, then this menu option 
is grayed-out and cannot be selected.

• If you select more than one node, and at least one of them has a Device Type 
of Unknown, then this menu option is grayed-out and cannot be selected.

Step 2 Select Edit>Unmanage from the SGM Main Menu, or Unmanage from the 
right-click menu. SGM labels the selected nodes Unmanaged and removes them 
from the poll list.
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You can also remove the Unmanaged status from a node, when you are ready to 
return the node to the SGM poll list. To remove the Unmanaged status from a 
node:

Step 1 Select one or more nodes in the Node window (Figure 3-25) or Topology window 
(Figure 3-54).

You cannot remove the Unmanaged status from a node with a Device Type of 
Unknown:

• If you select a node with a Device Type of Unknown, then this menu option 
is grayed-out and cannot be selected.

• If you select more than one node, and at least one of them has a Device Type 
of Unknown, then this menu option is grayed-out and cannot be selected.

Step 2 Select Edit> Manage from the SGM Main Menu, or Manage from the right-click 
menu. SGM removes the Unmanaged status from the selected node or nodes, 
returns them to the poll list, and polls them immediately.

Polling a Node
SGM automatically polls nodes at specified intervals. However, you can also 
request an immediate poll for a node.

To poll a node from the Discovery Dialog, use the following procedure:

Step 1 Select Edit>Network Discovery from the SGM Main Menu. SGM displays the 
Discovery Dialog (Figure 3-2).

Step 2 Select the Discovery tab. SGM displays the Discovery panel (Figure 3-5). The 
Discovered Nodes section of the Discovery panel lists all discovered nodes.

Step 3 Select one or more nodes. You cannot poll a node with a Primary SNMP Address 
of N/A:

• If you select a node with a Primary SNMP Address of N/A, then the Poll 
Node button is grayed-out and cannot be selected.

• If you select more than one node, and even one of them has a Primary SNMP 
Address of N/A, then the Poll Node button is grayed-out and cannot be 
selected.
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Step 4 Click Poll Node. SGM begins a poll of the selected nodes. During polling, the 
Poll Node button is grayed-out, the “Selected nodes are being polled” message is 
displayed at the bottom of the Discovery Dialog, and individual nodes might 
display the Polling status.

• If the node has only one IP address for SGM to poll, and the poll fails or times 
out, SGM issues an error message.

• If the node has more than one IP address for SGM to poll, and the polls of one 
or more IP addresses fail or time out, SGM issues warning messages. If all 
polls fail or time out, SGM issues an error message.

Step 5 When the “Selected nodes are being polled” message disappears and no nodes are 
in Polling status, polling is complete. The SGM database immediately reflects 
any new or changed data for the selected nodes.

To poll one or more nodes, retaining all currently known linksets in the SGM 
database, use one of the following procedures:

• Select one or more nodes in the Node Window or Topology Window, then 
select Edit> Poll Nodes>Normal Poll in the SGM Main Menu. SGM polls 
all selected ITP nodes.

• Select one or more linksets in the Linkset Window or Topology Window, then 
select Edit> Poll Nodes>Normal Poll in the SGM Main Menu. SGM polls 
all primary and adjacent ITP nodes associated with the selected linksets.

• Select an ITP node or adjacent node in the Details Window, then select 
Edit>Poll Nodes >Normal Poll in the SGM Main Menu. SGM polls that 
node.

• Select a linkset or link in the Details Window, then select Edit> Poll 
Nodes >Normal Poll in the SGM Main Menu. SGM polls the ITP node and 
adjacent node associated with the linkset or link.

• Right-click an ITP node in the Node Window or Topology Window, then 
select Poll Node >Normal Poll in the right-click menu. SGM polls the node.

Normal Poll retains all linksets associated with polled nodes, even linksets that 
have been deleted and are therefore in Unknown status.
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To poll one or more nodes, removing and then rediscovering all associated 
linksets, use one of the following procedures:

• Select one or more nodes in the Node Window or Topology Window, then 
select Edit>Poll Nodes> Clean Poll in the SGM Main Menu. SGM polls all 
selected ITP nodes.

• Select one or more linksets in the Linkset Window or Topology Window, then 
select Edit>Poll Nodes> Clean Poll in the SGM Main Menu. SGM polls all 
primary and adjacent ITP nodes associated with the selected linksets.

• Select an ITP node or adjacent node in the Details Window, then select 
Edit>Poll Nodes> Clean Poll in the SGM Main Menu. SGM polls that node.

• Select a linkset or link in the Details Window, then select Edit> Poll 
Nodes >Clean Poll in the SGM Main Menu. SGM polls the ITP node and 
adjacent node associated with the linkset or link.

• Right-click an ITP node in the Node Window or Topology Window, then 
select Poll Node> Clean Poll in the right-click menu. SGM polls the node.

Clean Poll removes all associated linksets before polling the nodes.

Excluding a Node from a View
To exclude a node from the current view, right-click the node in the Node Window 
or Topology Window, then select Exclude Node from View in the right-click 
menu. SGM excludes the node from the current view. See the “Creating a View” 
section on page 3-25 for more information about excluding nodes from views.

Working with Links
SGM enables you to view detailed information about all discovered links, 
including their associated nodes, status, events, and other information.

This section includes the following information:

• Viewing Detailed Information for a Link, page 3-112

• Deleting a Link, page 3-140

• Ignoring a Link, page 3-142

• Viewing Ignored Links, page 3-142
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Related Topics:

• Working with Linksets, page 3-34

• Working with Nodes, page 3-81

• Viewing the Topology of the Network, page 3-163

• Modifying Preference Settings, page 5-3

Viewing Detailed Information for a Link
To view detailed information for a link:

Step 1 Select a node or linkset in the Linkset, Node, or Topology window, then select 
View >Details from the SGM Main Menu. If you are viewing details for a node, 
you might need to select a specific linkset. SGM displays the Details window 
(Figure 3-11).

Step 2 The turner beside Linkset in the left pane displays the list of links associated with 
the linkset. If there is no turner, there are no links associated with the linkset.

Each link is identified by its signaling link code ID (SLC). An asterisk in the SLC 
indicates a link that is not configured, or that a poll could not get data for the link. 
For example, SLC (*)3 means there is no link associated with the selected linkset 
for SLC 3, and SLC 3(*) means there is no link associated with the adjacent 
linkset for SLC 3.

Step 3 Select an SLC. SGM displays the Link Details window, with configuration data 
for that link in the right panel (Figure 3-33).
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Figure 3-33 Details Window, Showing Link Configuration Data

Information for links associated with the selected linkset are displayed in the left 
column, and for links associated with the adjacent linkset in the right column.

The Poll Interval section at the top right of the Details window displays the time 
of the last poll, and enables you to change the poll interval:

• The Last Poll field initially displays the phrase Waiting for first poll. After 
the first polling cycle, SGM populates this field with the actual time of the 
last poll.

• To change the poll interval, enter a new value (in seconds) and click Apply. 
The valid range is 15 to 999 seconds. The default value is 15 seconds.

The Error Message section of the Details window displays the last error messages 
received by the node and by the adjacent node.

Updates for the links that are received from the SGM server are reflected 
automatically in this window.

Note This window polls your network periodically. To prevent unnecessary 
traffic on your network, close this window when you no longer need to 
refer to it.
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Step 4 (Optional) To view naming information for the link, select the Configuration Data 
tab. SGM displays the Naming Information table, which contains the following 
information:

• Type—Type of link. Possible link types are:

– HSL—The link uses the SS7-over-ATM (Asynchronous Transfer Mode) 
high-speed protocol.

– SCTPIP—The link uses the Stream Control Transmission Protocol 
(SCTP) IP transport protocol.

– Serial—The link uses the serial SS7 signaling protocol.

• Is Ignored—Indicates whether the link is Ignored (that is, whether the link 
is to be included when aggregating and displaying SGM status information).

• Signal Link Test—Indicates whether the link acknowledged a Signal Link 
Test Message (SLTM), which tests the link's ability to carry data.

Step 5 (Optional) To view interface information for the link, select the Configuration 
Data tab. SGM displays the Interface Information table, which contains the 
following information:

• QoS—Quality of service (QoS) class of the link.

• Local Port—Local port for the link.

• Remote Port—Remote port for the link.

Step 6 (Optional) To view information about the local IP addresses for the link, select the 
Configuration Data tab. SGM displays the Local IP Address Information table, 
which contains the following information:

• IP Address—Local IP address associated with the link.

• Status—Current status of the IP address. Possible values are:

– Active (green ball)—The IP address is currently fully functional.

– Inactive (red ball)—The IP address is not currently functional.
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Step 7 (Optional) To view information about the remote IP addresses for the link, select 
the Configuration Data tab. SGM displays the Remote IP Address Information 
table, which contains the following information:

• IP Address—Remote IP address associated with the link.

• Type—Indicates the designated primary IP address for the link (Primary) 
and the IP address currently being used by the link (Effective).

Usually, the same IP address is both Primary and Effective. However, if the 
primary IP address is down for some reason, a different IP address is used by 
the link and is labeled Effective.

• Status—Current status of the IP address. Possible values are:

– Active (green ball)—The IP address is currently fully functional.

– Inactive (red ball)—The IP address is not currently functional.

Step 8 (Optional) To view information about the configured local IP addresses for the 
link, select the Configuration Data tab. SGM displays the Configured Local IP 
Address Information table, which contains the following information:

• IP Address—Configured local IP address associated with the link.

• Interface Name—For serial and HSL links, this field displays the interface 
name of the link.

For SCTP links, this field displays the primary IP address and interface name 
of the link. The primary IP address is the first CS7 local IP address configured 
in the router. For example, if the following IP addresses are configured in the 
router:

cs7 local-peer 4180
local-ip 128.3.0.77
local-ip 128.3.0.254

Then SGM uses 128.3.0.77 as the primary IP address. If at any time that IP 
address is deleted from the router configuration, or if a new IP address is 
added to the beginning of the list, SGM detects the change and automatically 
updates this field to reflect the new primary IP address.

If the link has no interface name, this field is blank.

Step 9 (Optional) To view status information for the link, select the Status Summary tab. 
SGM displays status information for the link in the right panel (Figure 3-34).
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Figure 3-34 Details Window, Showing Link Status

SGM displays the Status Information table, which contains the following 
information:

• Status—Current status of the IP address. Possible values are:

– Active (green ball)—The link is currently fully functional.

– Blocked (red ball)—Traffic on this link is disabled by protocol.

– Failed (red ball)—An error is preventing traffic from flowing on this 
link, or the associated linkset has been set to Shutdown status.

A link can be Failed from an MTP3 perspective, but control messages 
might still be sent or received on the link, resulting in changing 
packet/second and bit/second rates. The rates might also be different at 
each end of the link, depending on the reason for the failure and the 
timing related to each endpoint.

– InhibitLoc (blue ball)—A local router administrator has set the link to 
prevent traffic from flowing.

– InhibitRem (blue ball)—A remote router administrator has set the link 
to prevent traffic from flowing.
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– Shutdown (blue ball)—A router administrator has set the link to prevent 
traffic from flowing.

– Unknown (red ball)—Either the node associated with this link has failed 
to respond to an SNMP request, or SGM found that the link no longer 
exists.

– When you physically delete a link, the Status field displays Unknown 
until you delete the link from the SGM database.

– Warning (yellow ball)—The link is active and traffic is flowing, but one 
or more situations has occurred:

- The link is congested.

- The link has exceeded the defined Receive Utilization % or Send 
Utilization %.

• One or more of the local or remote IP addresses defined for SCTP is not 
active.Last State Change—Date and time that the status of the link last 
changed.

• Congestion Level—Indicates whether there is congestion on the link. A link 
is congested if it has too many packets waiting to be sent. This condition 
could be caused by the failure of an element in your network.

Possible values for the Congestion Level field are:

– None—The link is not congested.

– Low—The link is slightly congested.

– High—The link is congested.

– Very High—The link is very congested.

Low, High, and Very High correspond roughly to equivalent ANSI, 
China standard, and ITU congestion levels.

• Receive Utilization—Indicates whether, on average, the link is under its 
configured receive utilization threshold (UnderThreshold) or over the 
threshold (OverThreshold).

• Send Utilization—Indicates whether, on average, the link is under its 
configured send utilization threshold (UnderThreshold) or over the 
threshold (OverThreshold).
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Step 10 (Optional) To view status information for the link’s local IP addresses, select the 
Status Summary tab. SGM displays the Local IP Address Information table, which 
contains the following information:

• IP Address—Local IP address associated with the link.

• Status—Current status of the IP address. Possible values are:

– Active (green ball)—The IP address is currently fully functional.

– Inactive (red ball)—The IP address is not currently functional.

Step 11 (Optional) To view status information for the link’s remote IP addresses, select the 
Status Summary tab. SGM displays the Remote IP Address Information table, 
which contains the following information:

• IP Address—Remote IP address associated with the link.

• Type—Indicates the designated primary IP address for the link (Primary) 
and the IP address currently being used by the link (Effective).

Usually, the same IP address is both Primary and Effective. However, if the 
primary IP address is down for some reason, a different IP address is used by 
the link and is labeled Effective.

• Status—Current status of the link. Possible values are:

– Active (green ball)—The IP address is currently fully functional.

– Inactive (red ball)—The IP address is not currently functional.
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Step 12 (Optional) To view packet information for the link, select the Statistics tab. SGM 
displays statistics for the link in the right panel (Figure 3-35).

Figure 3-35 Details Window, Showing Link Statistics

SGM displays the Packet Information table, which contains the following 
information:

• Packets Received Per Sec—Number of packets received by the link per 
second. This field initially displays the phrase Waiting for second poll. After 
two polling cycles, SGM populates this field with actual calculated rates.

• Packets Sent Per Sec—Number of packets sent by the link per second. This 
field initially displays the phrase Waiting for second poll. After two polling 
cycles, SGM populates this field with actual calculated rates.

• Drops—Total number of packets that have been dropped by the link.

• Transmit Queue Depth—Number of packets waiting to be sent on by the 
link.
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Step 13 (Optional) To view bit information for the link, select the Statistics tab. SGM 
displays the Bit Information table (or the Byte Information table, if you cleared 
the Show Details in Bits Instead of Bytes checkbox in the Preferences Window), 
which contains the following information:

• Bits Received Per Sec or Bytes Received Per Sec—Number of bits or bytes 
received by the link per second. This field initially displays the phrase 
Waiting for second poll. After two polling cycles, SGM populates this field 
with actual calculated rates.

• Bits Sent Per Sec or Bytes Sent Per Sec—Number of bits or bytes sent by 
the link per second. This field initially displays the phrase Waiting for 
second poll. After two polling cycles, SGM populates this field with actual 
calculated rates.

Step 14 (Optional) To view LSSU information for the link, select the Statistics tab. SGM 
displays the LSSU Information table, which contains the following information:

• LSSU Packets Received—Total number of SS7 Message Transfer Part Layer 
2 (MTP2) Links Status Signal Unit (LSSU) packets received by the link.

• LSSU Packets Sent—Total number of LSSU packets sent by the link.

Step 15 (Optional) To view utilization information for the link, select the Statistics tab. 
SGM displays the Utilization Information table, which contains the following 
information:

• Receive Plan Capacity—Planned capacity of the link to receive, in bits per 
second.

– For a link of type Serial or HSL, available bandwidth for the link.

– For a link of type SCTPIP or Mixed, set on the router using the 
plan-capacity CS7 link configuration command. If Receive Plan 
Capacity is not set on the router for this link, this field displays the value 
0.

– For a link of type Other, this field always displays the value 0.
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• Receive Utilization—Amount of the link’s receive capacity being used, as a 
percentage or in Erlangs, calculated using the following formula:

Receive Utilization = (Bits Received Per Sec)/Receive Plan Capacity

This field initially displays the phrase Waiting for second poll. After two 
polling cycles, SGM populates this field with actual calculated rates.

– For a link of type SCTPIP or Mixed, if Receive Plan Capacity is not set 
on the router for this link, this field displays the phrase Set Plan 
Capacity on Router.

– For a link of type Other, this field always displays the phrase Set Plan 
Capacity on Router.

• Receive Threshold %—Indicates when a cItpSpLinkRcvdUtilChange is to 
be generated for the link, as a percent of its total receive capacity. For 
example, if Receive Plan Capacity is 64000 bits per second, and Receive 
Threshold % is 50, then a cItpSpLinkRcvdUtilChange notification is 
generated when the link reaches 50% of 64000, or 32000 bits per second.

• Send Plan Capacity—Planned capacity of the link to send, in bits per 
second.

– For a link of type Serial or HSL, available bandwidth for the link.

– For a link of type SCTPIP or Mixed, set on the router using the 
plan-capacity CS7 link configuration command. If Send Plan Capacity 
is not set on the router for this link, this field displays the value 0.

– For a link of type Other, this field always displays the value 0.

• Send Utilization—Amount of the link’s send capacity being used, as a 
percentage or in Erlangs, calculated using the following formula:

Send Utilization = (Bits Sent Per Sec)/Planned Capacity

This field initially displays the phrase Waiting for second poll. After two 
polling cycles, SGM populates this field with actual calculated rates.

– For a link of type SCTPIP or Mixed, if Send Plan Capacity is not set 
on the router for this link, this field displays the phrase Set Plan 
Capacity on Router.

– For a link of type Other, this field always displays the phrase Set Plan 
Capacity on Router.
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• Send Threshold %—Indicates when a cItpSpLinkSentUtilChange is to be 
generated for the link, as a percent of its total send capacity. For example, if 
Send Plan Capacity is 64000 bits per second, and Send Threshold % is 50, 
then a cItpSpLinkSentUtilChange notification is generated when the link 
reaches 50% of 64000, or 32000 bits per second.

Step 16 (Optional) To view information all recent events associated with the link, select 
the Recent Events tab. SGM displays recent events for the link in the right panel 
(Figure 3-36).

Figure 3-36 Details Window, Showing Link Events

SGM displays the Recent Events table, which contains the following information:

• By default, SGM displays only unacknowledged events in this table. To 
display acknowledged events in the table, see Step 7 in the “Modifying 
Overall Preference Settings” section on page 5-5.

• Ack—Indicates whether the event has been acknowledged:

– To acknowledge an unacknowledged event, select this checkbox.

– To make a previously acknowledged event unacknowledged, clear this 
checkbox.

• Note—Indicates whether there is a note associated with the event.
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• Severity—Severity of the event. Default values are:

– Admin—The default color is cyan.

– Error—The default color is coral.

– None—The default color is white.

– Normal—The default color is light green.

– Warning—The default color is yellow.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-25 for more 
information.

• Time—Date and time the event was logged.

• Message—Text of the message.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-25 for more 
information.

Step 17 (Optional) To view a received utilization chart for the link, select the Real-Time 
Data Charts tab. SGM displays the chart in the right panel (Figure 3-37).
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Figure 3-37 Details Window, Showing Link ReceivedUtilization

SGM displays the following information in the ReceivedUtilization chart:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
alternate linkset, select it in this list box.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
Received Utilization Chart. You cannot edit this field directly. Instead, edit 
the Poll Interval (secs) field at the top right of the Details window.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Received Utilization Chart. Valid selections are 1, 2, 
5, 10, 20, 40, or 60 minutes. The default selection is 5 minutes.
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• Received Utilization Chart—Displays the Receive Utilization % for the 
link as a function of time, as well as the average Receive Utilization % for 
all links on the linkset.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the receive utilization percentage for that data point.

To remove the data for a link or for the average from the chart, click the icon 
in the SLC field. To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Received Utilization Chart, up to 16 total 
links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.
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To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Step 18 (Optional) To view a send utilization chart for the link, select the Real-Time Data 
Charts tab. SGM displays the chart in the right panel (Figure 3-38).

Figure 3-38 Details Window, Showing Link SendUtilization
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SGM displays the following information in the SendUtilization chart:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
alternate linkset, select it in this list box.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
Send Utilization Chart. You cannot edit this field directly. Instead, edit the 
Poll Interval (secs) field at the top right of the Details window.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Send Utilization Chart. Valid selections are 1, 2, 5, 10, 
20, 40, or 60 minutes. The default selection is 5 minutes.

• Send Utilization Chart—Displays the Send Utilization % for the link as a 
function of time, as well as the average Send Utilization % for all links on 
the linkset.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the send utilization percentage for that data point.

To remove the data for a link or for the average from the chart, click the icon 
in the SLC field. To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.
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To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 17 color-coded icons:

– One for each link (SLC) in the Send Utilization Chart, up to 16 total 
links.

– One for the average of all SLCs.

To remove the data for a link or for the average from the chart, click the icon 
in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Step 19 (Optional) To view a packets-received-per-second chart for the link, select the 
Real-Time Data Charts tab. SGM displays the chart in the right panel 
(Figure 3-39).
3-128
Cisco Signaling Gateway Manager User Guide

78-15204-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with Links
Figure 3-39 Details Window, Showing Link Packets Received Per Second

SGM displays the following information in the PktsRcvdPerSec chart:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
alternate linkset, select it in this list box.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
Packets Received Chart. You cannot edit this field directly. Instead, edit the 
Poll Interval (secs) field at the top right of the Details window.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Packets Received Chart. Valid selections are 1, 2, 5, 
10, 20, 40, or 60 minutes. The default selection is 5 minutes.
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• Packets Received Chart—Displays the Packets Received Per Sec for the 
link as a function of time.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of packets received per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Packets Received Chart. To remove the data for a link from the chart, click 
the icon in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Step 20 (Optional) To view a packets-sent-per-second chart for the link, select the 
Real-Time Data Charts tab. SGM displays the chart in the right panel 
(Figure 3-40).
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Figure 3-40 Details Window, Showing Link Packets Sent Per Second

SGM displays the following information in the PktsSentPerSec chart:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
alternate linkset, select it in this list box.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
Packets Sent Chart. You cannot edit this field directly. Instead, edit the Poll 
Interval (secs) field at the top right of the Details window.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Packets Sent Chart. Valid selections are 1, 2, 5, 10, 20, 
40, or 60 minutes. The default selection is 5 minutes.
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• Packets Sent Chart—Displays the Packets Sent Per Sec for the link as a 
function of time.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of packets sent per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Packets Sent Chart. To remove the data for a link from the chart, click the 
icon in this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.
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Step 21 (Optional) To view a bits-received-per-second chart for the link (or a 
bytes-received-per-second chart, if you cleared the Show Details in Bits Instead 
of Bytes checkbox in the Preferences Window), select the Real-Time Data Charts 
tab. SGM displays the chart in the right panel (Figure 3-41).

Figure 3-41 Details Window, Showing Link Bits Received Per Second
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SGM displays the following information in the BitsRcvdPerSec or 
BytesRcvdPerSec chart:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
alternate linkset, select it in this list box.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
Bits Received Chart or Bytes Received Chart. You cannot edit this field 
directly. Instead, edit the Poll Interval (secs) field at the top right of the 
Details window.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Bits Received Chart or Bytes Received Chart. Valid 
selections are 1, 2, 5, 10, 20, 40, or 60 minutes. The default selection is 
5 minutes.

• Bits Received Chart or Bytes Received Chart—Displays the Bits Received 
Per Sec or Bytes Received Per Sec for the link as a function of time.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of bits or bytes received per second for that data 
point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.
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To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Bits Received Chart or Bytes Received Chart. To remove the data for a link 
from the chart, click the icon in this field. To return the data to the chart, click 
the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Step 22 (Optional) To view a bits-sent-per-second chart for the link (or a 
bytes-sent-per-second chart, if you cleared the Show Details in Bits Instead of 
Bytes checkbox in the Preferences Window), select the Real-Time Data Charts 
tab. SGM displays the chart in the right panel (Figure 3-42).
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Figure 3-42 Details Window, Showing Link Bits Sent Per Second

SGM displays the following information in the BitsSentPerSec or 
BytesSentPerSec chart:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
alternate linkset, select it in this list box.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
Bits Sent Chart or Bytes Sent Chart. You cannot edit this field directly. 
Instead, edit the Poll Interval (secs) field at the top right of the Details 
window.
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• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Bits Sent Chart or Bytes Sent Chart. Valid selections 
are 1, 2, 5, 10, 20, 40, or 60 minutes. The default selection is 5 minutes.

• Bits Sent Chart or Bytes Sent Chart—Displays the Bits Sent Per Sec or 
Bytes Sent Per Sec for the link as a function of time.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of bits or bytes sent per second for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.

• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Bits Sent Chart or Bytes Sent Chart. To remove the data for a link from the 
chart, click the icon in this field. To return the data to the chart, click the icon 
again.
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To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Step 23 (Optional) To view a drops chart for the link, select the Real-Time Data Charts 
tab. SGM displays the chart in the right panel (Figure 3-43).

Figure 3-43 Details Window, Showing Link Drops
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SGM displays the following information in the Drops chart:

• Linkset—Drop-down list box used to select the linkset from whose 
perspective data is to be displayed. By default, data is displayed from the 
perspective of the selected linkset. To display data from the perspective of the 
alternate linkset, select it in this list box.

• Poll Interval (secs)—Poll interval, in seconds, used to collect data for the 
Drops Chart. You cannot edit this field directly. Instead, edit the Poll 
Interval (secs) field at the top right of the Details window.

• Time Window (mins)—Drop-down list box used to specify the length of 
time displayed in the Drops Chart. Valid selections are 1, 2, 5, 10, 20, 40, or 
60 minutes. The default selection is 5 minutes.

• Drops Chart—Displays the Drops for the link as a function of time.

To see the exact time and data coordinates for a data point, left-click the data 
point. The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

– hh:mm:ss is the time for that data point in hours, minutes, and seconds.

– dd.dd is the number of drops for that data point.

To remove the data for a link from the chart, click the icon in the SLC field. 
To return the data to the chart, click the icon again.

The time between poll data points is specified in the Poll Interval (secs) field. 
The total time displayed in the chart is specified in the Time Window (mins) 
field.

New data points are added to the right side of the chart. When the chart 
reaches the end of the time window (for example, after 5 minutes, if the Time 
Window (mins) field is set to 5), new data points continue to be added to the 
right side of the chart, while old data points “drop off” the left side of the 
chart.

If a poll is missed (for example, as a result of an SNMP timeout), SGM 
ignores the missing data point, stops drawing the line, and waits for the next 
valid data point to begin drawing the line again.

To scroll left, right, up, or down in the chart, drag the cursor while holding 
down Shift and the left mouse button.

To zoom in on a section of the chart, drag the cursor while holding down Ctrl 
and the left mouse button.

To reset the chart to the default view and scaling, click Reset.
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• SLC—Displays up to 16 color-coded icons, one for each link (SLC) in the 
Drops Chart. To remove the data for a link from the chart, click the icon in 
this field. To return the data to the chart, click the icon again.

To superimpose a graphic grid on the chart, which can make the data easier to 
read, click Grid On.

To remove the graphic grid from the chart, click Grid Off.

To display online help for the window, click Help.

Deleting a Link
After Discovery, the links in your network are known to SGM and added to the 
SGM database. Physically deleting links from your network is not the same as 
deleting them from the SGM database. The following sections describe the 
differences between deleting links from your network and from the SGM 
database, and the procedures for doing so:

• Deleting a Link from Your Network, page 3-140

• Deleting a Link from the SGM Database, page 3-141

Deleting a Link from Your Network

If you physically delete a known link from your network, it remains in the SGM 
database, and SGM labels it Unknown, and it is the system administrator’s 
responsibility to delete it from the SGM database, if you choose to do so. The Link 
Details pane of the Details window also displays -1 in the Xmit Queue field. SGM 
labels all associated nodes and linksets Warning.

When you redefine the link (that is, when you define a link with the same 
signaling link code ID [SLC] as the original link), SGM rediscovers the link and 
labels it with the appropriate status (such as Active).
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Deleting a Link from the SGM Database

Typically, you delete a link in the SGM database for one of the following reasons:

• You have physically deleted the link from your network. This is the most 
common reason for deleting a link from the SGM database.

• The link is Blocked, Failed, or Unknown, you are aware of the reason, and 
you no longer want to see it in SGM displays. For example, the link might be 
associated with a linkset that was removed from the network, or it might be a 
previously discovered link associated with a test lab device.

If you have physically deleted a known link from your network, and you then 
delete it from SGM, it is no longer in the SGM database, it does not appear in 
SGM windows, and it is not discovered when you run Discovery.

If you have not physically deleted a known link from your network, and you delete 
it from SGM, at the next poll SGM finds the link and adds it back to the SGM 
database, setting the status appropriately. If this happens, do not delete the link 
again. Instead, set it to Ignored. See the “Ignoring a Link” section on page 3-142 
for more information.

Note If you delete a link from the SGM database, the link is deleted for all SGM clients 
and views connected to that SGM server.

To delete a link from the SGM database, use one of the following procedures:

• Select a link in the Link Details window (Figure 3-33), then select 
Edit>Delete from the SGM Main Menu.

• Right-click a link in the Link Details window, then select Delete Link from 
the right-click menu.

SGM asks you to confirm the deletion.

• Select Yes to delete the selected link. SGM deletes the link from the SGM 
database. However, if the link was not physically deleted from your network, 
then at the next poll SGM finds the link and adds it back to the SGM database, 
setting the status appropriately.

• Select No to return to the Link Details window without deleting the link from 
the SGM database.
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Ignoring a Link
You can instruct SGM to ignore a link when it aggregates and displays network 
data. Setting links to Ignored prevents known link problems from affecting SGM 
displays for associated linksets and nodes. In effect, you are preventing a known 
problem from distracting you from other, more urgent network problems.

For example, you can set a link to Ignored before shutting down the link for 
maintenance.

Note If you set a link to Ignored, the link is ignored for all SGM clients and views 
connected to that SGM server.

Also, if you set a link to Ignored, make a note of the change, and do not forget to 
reset the link when the problem is corrected or the maintenance is complete.

To set a link to Ignored, right-click the link in the Link Details window 
(Figure 3-33), then select Ignore from the right-click menu.

Viewing Ignored Links
To display all links that are Ignored:

Step 1 Select View > Ignored Items from the SGM Main Menu. SGM displays the 
Ignored Items Dialog (Figure 3-24).

Step 2 Click the Links tab to display all links that are Ignored (Figure 3-44).
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Figure 3-44 Ignored Items Dialog, Showing Ignored Links

Step 3 (Optional) To stop ignoring one or more links, select the links, then click 
Unignore.

Step 4 (Optional) To stop ignoring all links, click Unignore All.

Working with Events
SGM enables you to view detailed information about all discovered events, 
including their associated nodes, linksets, links, and other information.

This section includes the following information:

• Viewing Basic Information for Events, page 3-144

• Viewing Detailed Information for an Event, page 3-148

• Setting an Event Filter, page 3-151

• Editing an Event, page 3-160

• Viewing Notes for an Event, page 3-161
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Related Topics:

• Modifying the SGM Event Configuration File (Solaris Only), page 5-25

• Modifying Preference Settings, page 5-3

• Setting Sounds for Events at an SGM Client, page 5-38

• Viewing the Topology of the Network, page 3-163

• Working with Links, page 3-111

• Working with Linksets, page 3-34

• Working with Nodes, page 3-81

Viewing Basic Information for Events
To view basic information for events, use one of the following procedures:

• To display the Event Window, with events displayed for all nodes, linksets, 
and links in the current network view, select View >Events> All from the 
SGM Main Menu. SGM displays the Event Window (Figure 3-45).

• To display the Event Dialog, with events displayed for only the selected 
nodes, linksets, or links, select one or more nodes, linksets, or links, then 
select View > Events> Selected Item from the SGM Main Menu. SGM 
displays the Event Window (Figure 3-45).

• To display the Event Dialog, with events displayed for only a selected node 
and its associated linksets and links, right-click a node in the Node or 
Topology Window, then select View >Events  in the right-click menu. SGM 
displays the Event Dialog (Figure 3-45).

• To display the Event Dialog, with events displayed for only a selected linkset 
and its associated links, right-click a linkset in the Linkset or Topology 
Window, then select View> Events  in the right-click menu. SGM displays the 
Event Dialog (Figure 3-45).
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Figure 3-45 Event Window

The Event Window displays information about the events delivered by the SGM 
event logger and event processor.

Figure 3-46 Event Dialog
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The Event Dialog displays information about the events delivered by the SGM 
event logger and event processor, for only the selected nodes, linksets, and links.

Note You can display more than one Event Window or Dialog at one time. This enables 
you to view multiple Event Windows and Dialogs at the same time, with different 
event filtering in each window or dialog.

By default, SGM displays only unacknowledged events in this table. To display 
acknowledged events in the table, see Step 7 in the “Modifying Overall Preference 
Settings” section on page 5-5.

By default, SGM displays all of the columns in the table except Internal ID, 
Note, Ack By, Node, and Linkset. To display these columns, or to hide other 
columns, see the procedures in the “Modifying Event Table Column Settings” 
section on page 5-18.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-178 for more details.

The Event Window displays the following information for each event:

• Internal ID—Internal ID of the event. The internal ID is a unique ID for 
every event, link, linkset, and node, assigned by SGM for its own internal use. 
It can also be useful when the TAC is debugging problems.

• Ack—Indicates whether the event has been acknowledged:

– To acknowledge an unacknowledged event, select this checkbox.

– To make a previously acknowledged event unacknowledged, clear this 
checkbox.

• Category—Type of the event. Default values are:

– Create—Creation event, such as the creation of a seed file.

– Delete—Deletion event, such as the deletion of a node or linkset.

– Discover—Discovery event, such as Discovery beginning.
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– Edit—Edit event. A user has edited an event, linkset, or node.

– Ignore—Ignore event. A user has Ignored a link or linkset.

– Login—Login event. A user has logged in to SGM.

– LoginDisable—LoginDisable event. SGM has disabled a user’s 
User-Based Access authentication as a result of too many failed attempts 
to log in to SGM.

– LoginFail—LoginFail event. An attempt by a user to log in to SGM has 
failed.

– OverWrite—OverWrite event. An existing file, such as a seed file or 
route file, has been overwritten.

– Poll—Poll event, such as an SNMP poll.

– Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and SGM has deleted the existing SGM 
database.

– Status—Status change message generated.

– Trap—SNMP trap message generated.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-25 for more 
information.

• Severity—Severity of the event. Default values are:

– Admin—The default color is cyan.

– Error—The default color is coral.

– None—The default color is white.

– Normal—The default color is light green.

– Warning—The default color is yellow.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-25 for more 
information.

• Note—Indicates whether there is a note associated with the event.

• Time—Date and time the event was logged.

• Ack By—Name of the device that last acknowledged the event. If no one has 
acknowledged the event, this field is blank.
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• Node—Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

• Linkset—Name of the linkset associated with the event. If there is no linkset 
associated with the event, None is displayed.

• Message—Message associated with the event.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-25 for more 
information.

Viewing Detailed Information for an Event
To view detailed information for an event, double-click an event in the Event 
Window (Figure 3-45) or Event Dialog (Figure 3-45). SGM displays the Event 
Details dialog (Figure 3-47).
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Figure 3-47 Event Details Dialog

The Event Details dialog displays the following detailed information for the 
event:

• Show Notes—If there are notes associated with this event, click this button 
to display the Event Notes dialog. If there are no notes associated with this 
event, this button is grayed-out.

• Message—Message text for the event. You can customize this field. See the 
“Modifying the SGM Event Configuration File (Solaris Only)” section on 
page 5-25 for more information.

• Category—Type of the event. Default values are:

– Create—Creation event, such as the creation of a seed file.

– Delete—Deletion event, such as the deletion of a node or linkset.

– Discover—Discovery event, such as Discovery beginning.
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– Edit—Edit event. A user has edited an event, linkset, or node.

– Ignore—Ignore event. A user has Ignored a link or linkset.

– Login—Login event. A user has logged in to SGM.

– LoginDisable—LoginDisable event. SGM has disabled a user’s 
User-Based Access authentication as a result of too many failed attempts 
to log in to SGM.

– LoginFail—LoginFail event. An attempt by a user to log in to SGM has 
failed.

– OverWrite—OverWrite event. An existing file, such as a seed file or 
route file, has been overwritten.

– Poll—Poll event, such as an SNMP poll.

– Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and SGM has deleted the existing SGM 
database.

– Status—Status change message generated.

– Trap—SNMP trap message generated.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-25 for more 
information.

• Severity—Severity of the event. Default values are:

– Admin—The default color is cyan.

– Error—The default color is coral.

– None—The default color is white.

– Normal—The default color is light green.

– Warning—The default color is yellow.

You can customize this field. See the “Modifying the SGM Event 
Configuration File (Solaris Only)” section on page 5-25 for more 
information.

• Timestamp—Date and time the event was logged.

• Acknowledged—Indicates whether the event has been acknowledged.

• Acknowledged By—Name of the device that last acknowledged the event. If 
no one has acknowledged the event, this field is blank.
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• Ack Timestamp—Date and time the event was last acknowledged.

• Node—Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

• Linkset—Name of the linkset associated with the event. If there is no linkset 
associated with the event, None is displayed.

Setting an Event Filter
To modify the way SGM presents event information, use the following procedure:

Step 1 Select Event Tools >Set Filter from the SGM Main Menu. SGM displays the 
Event Filter dialog with the Properties tab selected (Figure 3-48).
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Figure 3-48 Event Filter Dialog, Showing Event Properties

Note The more complex the filter, the longer it takes to apply to events. This is 
especially true of filters that check unique data in an event, such as 
Message Text and Match Case.
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Step 2 (Optional) To specify which event categories you want to display in the Event 
Window, select the Properties tab and modify the following settings:

• Status—Checkbox used to indicate whether Status events are to be displayed 
in the Event Window. The default setting for this checkbox is selected.

• Edit—Checkbox used to indicate whether Edit events are to be displayed in 
the Event Window. The default setting for this checkbox is selected.

• OverWrite—Checkbox used to indicate whether OverWrite events are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.

• Trap—Checkbox used to indicate whether Trap events are to be displayed in 
the Event Window. The default setting for this checkbox is selected.

• Ignore—Checkbox used to indicate whether Ignore events are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.

• Poll—Checkbox used to indicate whether Poll events are to be displayed in 
the Event Window. The default setting for this checkbox is selected.

• Create—Checkbox used to indicate whether Create events are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.

• Login—Checkbox used to indicate whether Login events are to be displayed 
in the Event Window. The default setting for this checkbox is selected.

• Purge—Checkbox used to indicate whether Purge events are to be displayed 
in the Event Window. The default setting for this checkbox is selected.

• Delete—Checkbox used to indicate whether Delete events are to be displayed 
in the Event Window. The default setting for this checkbox is selected.

• LoginDisable—Checkbox used to indicate whether LoginDisable events are 
to be displayed in the Event Window. The default setting for this checkbox is 
selected.

• Discover—Checkbox used to indicate whether Discover events are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.

• LoginFail—Checkbox used to indicate whether LoginFail events are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.
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To select all event category checkboxes. click Select All.

To clear all event category checkboxes, click Deselect All.

Note These are the default categories; there might be additional categories, as 
defined by the SGM system administrator. For information about custom 
categories, see the “Modifying the SGM Event Configuration File 
(Solaris Only)” section on page 5-25.

Step 3 (Optional) To specify which event severities you want to display in the Event 
Window, select the Properties tab and modify the following settings:

• None—Checkbox used to indicate whether events of severity None are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.

• Normal—Checkbox used to indicate whether events of severity Normal are 
to be displayed in the Event Window. The default setting for this checkbox is 
selected.

• Admin—Checkbox used to indicate whether events of severity Admin are to 
be displayed in the Event Window. The default setting for this checkbox is 
selected.

• Warning—Checkbox used to indicate whether events of severity Warning are 
to be displayed in the Event Window. The default setting for this checkbox is 
selected.

• Error—Checkbox used to indicate whether events of severity Error are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.

Note There might be additional custom severities, as defined by your SGM 
System Administrator. For information, see the “Modifying the SGM 
Event Configuration File (Solaris Only)” section on page 5-25.
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Step 4 (Optional) To further define the event filter for the Event Window, select the 
Properties tab and modify the following settings:

• Acknowledged—Checkbox used to indicate whether only acknowledged 
events are to be displayed in the Event Window. The default setting for this 
checkbox is cleared.

• Unacknowledged—Checkbox used to indicate whether only 
unacknowledged events are to be displayed in the Event Window. The default 
setting for this checkbox is selected.

• Time Before—Checkbox used to indicate whether only events logged by 
SGM prior to a specified date and time are to be displayed in the Event 
Window. The default setting for this checkbox is cleared.

• Time Before Field—Specifies the date and time prior to which events logged 
by SGM are to be displayed in the Event Window. This field is grayed-out 
unless the Time Before checkbox is selected. If the Time Before checkbox 
is selected, the default setting for this field is the date and time of the most 
recent event logged by SGM.

• Time After—Checkbox used to indicate whether only events logged by SGM 
after a specified date and time are to be displayed in the Event Window. The 
default setting for this checkbox is cleared.

• Time After Field—Specifies the date and time after which events logged by 
SGM are to be displayed in the Event Window. This field is grayed-out unless 
the Time After checkbox is selected. If the Time After checkbox is selected, 
the default setting for this field is the date and time of the earliest event 
logged by SGM.

• Message Contains—Checkbox used to indicate whether only events that 
contain the specified message text are to be displayed in the Event Window. 
The default setting for this checkbox is cleared.

• Match Case—Checkbox used to indicate whether only events that match the 
case of the text in the Message Text field are to be displayed in the Event 
Window. This field is grayed-out unless the Message Contains checkbox is 
selected. If the Message Contains checkbox is selected, the default setting 
for this checkbox is cleared.
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Step 5 (Optional) To specify the nodes for which SGM is to display events in the Event 
Window, select the Source Nodes tab. SGM displays the Event Filter dialog with 
the Source Nodes tab highlighted (Figure 3-49).

Figure 3-49 Event Filter Dialog, Showing Event Source Nodes
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You can modify the following settings:

• Included Nodes—Indicates the nodes for which events are to be displayed in 
the Event Window. By default, this table includes all nodes in the current 
network view.

To remove events for one or more nodes from the Event Window, select the 
nodes in this list and click Remove. The selected nodes are moved to the 
Excluded Nodes list.

• Excluded Nodes—Indicates the nodes for which events are not to be 
displayed in the Event Window. By default, this table contains no nodes.

To add events for one or more nodes to the Event Window, select the nodes in 
this list and click Add. The selected nodes are moved to the Included Nodes 
list.

• To display events that are not associated with any node in the Event Window, 
select the Include events with no associated node checkbox.

Step 6 (Optional) To load an existing event filter, click Load in the Event Filter dialog. 
SGM displays the Load File Dialog - Load Filter dialog (Figure 3-50).

Figure 3-50 Load File Dialog - Load Filter Dialog

The Load File Dialog - Load Filter dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the event filter file or folder.
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• Last Modified—Date and time the event filter file or folder was last 
modified.

• Size (bytes)—Size of the event filter file or folder, in bytes.

• Number of Files—Total number of event filter files and folders (displayed in 
bottom left corner).

To load an event filter file, enter the name of the file or select it in the list and click 
OK. SGM loads the event filter file, closes the Load File Dialog - Load Filter 
dialog, and returns to the Event Filter dialog.

To delete an event filter file from the event filter file list, select a file and click 
Delete. SGM issues an informational message containing the name and location 
of the deleted file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog - Load Filter dialog.

To close the Load File Dialog - Load Filter dialog without loading an event filter 
file or saving any changes to the event filter file list, click Cancel.

Step 7 (Optional) To apply any changes you made to the event filter without closing the 
Event Filter dialog, click Apply.

Step 8 (Optional) To close the Event Filter dialog without saving any changes to the 
event filter file or event filter file list, click Cancel.

Step 9 When you are satisfied with the filter settings, click Save. SGM displays the Save 
File Dialog - Save Filter dialog (Figure 3-51).
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Figure 3-51 Save File Dialog - Save Filter Dialog

The Save File Dialog - Save Filter dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the event filter file or folder.

• Last Modified—Date and time the event filter file or folder was last 
modified.

• Size (bytes)—Size of the event filter file or folder, in bytes.

• Filename—Name by which you want to save the event filter file.

If you create a new event filter file name, you can use any letters, numbers, 
or characters in the name that are allowed by your operating system.

• Number of Files—Total number of event filter files and folders (displayed in 
bottom left corner).

To save the event filter file with a new name, use one of the following procedures:

• To save the file with a completely new name, enter the new name and click 
OK.

• To save the file with an existing name, overwriting an old event filter file, 
select the name in the list and click OK.

SGM saves the event filter file with the new name, closes the Save File Dialog - 
Save Filter dialog, and returns to the Event Filter dialog.
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To delete an event filter file from the event filter file list, select a file and click 
Delete. SGM issues an informational message containing the name and location 
of the deleted file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog - Save Filter dialog.

To close the Save File Dialog - Save Filter dialog without saving the event filter 
file or saving any changes to the event filter file list, click Cancel.

Editing an Event
SGM enables you to annotate an event, attaching a descriptive string to the event.

To annotate an event, use one of the following procedures:

• Select an event in a window and select Edit>Selected Item in the SGM Main 
Menu.

• Right-click an event in the Event Window, then select Edit Event in the 
right-click menu.

SGM displays the Edit Event Dialog (Figure 3-52).
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Figure 3-52 Edit Event Dialog

The Edit Event Dialog displays the name of the event and the date and time the 
Notes field for the event was last updated. If there is no note currently associated 
with the event, the Note Last Updated field displays the value Not Set.

In the Notes field, enter any important information about the event, such as its 
associated node or linkset, what triggered the event, how often it has occurred, and 
so on.

Click Save to save the annotations and exit the Edit Event Dialog.

Viewing Notes for an Event
SGM enables you to view the notes that have been attached to events.

To view a note, use one of the following procedures:

• Select an event in a window, then select View> Notes from the SGM Main 
Menu.

• Right-click an event in the Event Window, then select View >Notes in the 
right-click menu.

If the event has an attached note, SGM displays the Event Notes dialog 
(Figure 3-53). (If the event does not have an attached note, SGM displays the 
message, “The event does not have any notes.”)
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Figure 3-53 Event Notes Dialog

The Event Notes dialog displays the following information:

• Name—Name of the event.

• Note Last Updated—Date and time the Notes field for the event was last 
updated.

• Notes—Notes associated with the event.

Click OK to close the Event Notes dialog.
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Viewing the Topology of the Network
In addition to tabular (text) views of your network, SGM provides a topology 
(graphical) view of the ITP nodes and linksets in your network, including adjacent 
legacy SS7 devices, and enables you to customize the view to meet your needs.

Related Topics:

• Modifying Preference Settings, page 5-3

• Working with Links, page 3-111

• Working with Linksets, page 3-34

• Working with Nodes, page 3-81

• Working with Views, page 3-23

To view the topology of your network:

Step 1 Use one of the following procedures:

• Select View > Topology >Overview from the SGM Main Menu.

• Select a node, linkset, or event and select View >Topology >Zoomed from 
the SGM Main Menu.

• Right-click a node, linkset, or event, then select View >Zoomed Topo in the 
right-click menu.

SGM displays the Topology window (Figure 3-54).
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Figure 3-54 Topology Window

The Topology Window displays tabular information about nodes and linksets in 
the left pane and the graphical topology map in the right pane.

SGM automatically assigns the following node elements:

• Cisco 2651 series router

• Cisco 7202 series router

• Cisco 7204VXR series router

• Cisco 7206VXR series router

• Cisco 7507 series router

• Cisco 7513 series router

• IP device, other than Cisco 2651, 7202, 7204VXR, 7206VXR, 7507, or 7513 
series router (if assigned by a user; see the “Editing a Node” section on 
page 3-99 for more details)

• SS7—SGM is unable to determine the node type.
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In addition, users can assign the following node elements (see the “Editing a 
Node” section on page 3-99 for more details):

• MSC—Mobile switching center

• SCP—Service control point

• SSP—Service switching point

• STP—Signal transfer point

A line indicates a single logical connection configured between two nodes:

• A line that ends in a diamond indicates that the connection has a configured 
linkset, associated with that node.

• A line that does not end in a diamond indicates that the linkset does not exist 
or cannot be displayed because SGM cannot manage that node.

• A heavy line that ends in a split diamond indicates that there are two linksets 
configured between two nodes.

• A heavy line that ends in a half diamond indicates that there are two linksets 
configured on one node and one linkset configured on the other (the node with 
the half diamond).

The color of a graphical element indicates its current status.

• For nodes, the possible colors are:

– Green—The node is currently in Active status.

– Yellow—The node is currently in Warning status.

– Gray—The node is currently in Discovering, Polling, Unmanaged, or 
Waiting status.

– Red—The node is currently in Unknown status.

• For linksets (diamonds), the possible colors are:

– Green—The linkset is in Active status.

– Blue—The linkset is in Shutdown status.

– Yellow—The linkset is in Warning status.

– Red—The linkset is in either Unavailable or Unknown status.
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A split diamond with half one color and half another indicates that there are two 
linksets configured between the nodes, and each linkset has a different status. For 
example, a diamond that is half green and half yellow indicates that there is one 
linkset in Active status and one in Warning status.

A half diamond indicates that there are two linksets configured on one node and 
one linkset configured on the other (the node with the half diamond).

A note icon in the upper left corner of a node element means the node has been 
annotated. That is, a user has attached a descriptive string to the node. A dot in 
the diamond at the end of the line means the linkset has been annotated.

An event icon (orange triangle) in the upper right corner of a node element means 
there is a recent event associated with the node.

Step 2 The topology node table in the left pane of the Topology window displays the 
name and status of the nodes that are currently displayed in the topology map. To 
display the topology node table, select the Tables tab in the left pane.

Step 3 The topology linkset table in the left pane of the Topology window displays the 
name and status of the linksets that are displayed in the topology map.

Step 4 (Optional) In the topology linkset table, you can select the Ignored checkbox to 
ignore a linkset when displaying SGM data, or clear the checkbox to include the 
linkset. To display the topology linkset table, select the Tables tab in the left pane, 
then select a node in the topology node table or in the topology map. The topology 
linkset table is displayed below the topology node table. For more information, 
see the “Ignoring a Linkset” section on page 3-79.
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Step 5 (Optional) To highlight an element in the topology node table or topology linkset 
table in the left pane, click it in the topology map:

• Click a node to highlight the node in the topology node table, and to display 
any associated linksets in the topology linkset table.

• Click a single line, a heavy line, or a diamond, to display the following 
information:

– Highlight the closest associated node in the topology node table. For 
example, if there is a line connecting node sgm-2600a and node 
sgm-2600b, and you click the line closer to node sgm-2600a, then that 
node is highlighted in the topology node table.

– Display all linksets (if any) associated with that node in the topology 
linkset table.

– Highlight the clicked linkset (if it is configured) in the topology linkset 
table.

Step 6 To see mouse over help popup in the topology map, place the cursor over a node 
or linkset. When you place the cursor over a linkset, the mouse over help popup 
is displayed from the perspective of the closest node.

Note You can turn off mouse over help. For details, see Step 5 in the 
“Modifying Overall Preference Settings” section on page 5-5.

Step 7 (Optional) To make the topology map twice as large, click the Zoom the map by 
a factor of 200% button, or select Topology Tools >Zoom> In from the SGM 
Main Menu.

Step 8 (Optional) To make the topology map half as large, click the Zoom the map by a 
factor of 50% button, or select Topology Tools> Zoom>Out from the SGM 
Main Menu.

Step 9 (Optional) To zoom the topology map by a selected percentage, click the Select a 
map viewing factor button, then either select a percentage from the drop-down 
list box, or enter a percentage and click Enter. Valid values are integers in the 
range 5 through 400.

Step 10 (Optional) To zoom in on a selected area of the topology map, click in the map, 
then click the Zoom in on an area button, or select Topology 
Tools> Zoom >Area from the SGM Main Menu.
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Step 11 (Optional) To adjust the size of the topology map to fit in the window, click the 
Zoom to fit window button, or select Topology Tools >Zoom>Fit from the SGM 
Main Menu. This is the default setting the first time the map is displayed.

Step 12 (Optional) To display the topology map in a circular layout, click the Circular 
layout button, or select Topology Tools> Layout>Circular from the SGM Main 
Menu.

Step 13 (Optional) To display the topology map in a spring layout, click the Spring layout 
button, or select Topology Tools> Layout>Spring In a spring layout, nodes with 
the most links are drawn closer to the center of the map, while nodes with fewer 
links are drawn farther away. This is the default setting the first time the map is 
displayed.

Note You can modify how far apart nodes are spaced when SGM draws the 
spring layout. For details, see Step 5 in the “Modifying Overall 
Preference Settings” section on page 5-5.

Step 14 (Optional) To create a custom layout for the topology map, move the nodes 
around, grouping them or isolating them to meet your needs.

To move a single node, click the left mouse button to select the node in the map 
and, while holding down the left mouse button, move the mouse to move the node 
to its new position.

To move more than one node at the same time, use the following procedure:

a. Press and hold down the Shift key on your keyboard.

b. Still holding down Shift, click the left mouse button to select the nodes you 
want to move in the map.

c. Still holding down Shift, select one of the nodes you want to move and hold 
down the left mouse button.

d. Still holding down both Shift and the left mouse button, move the mouse to 
move the nodes to their new position. The moved nodes keep their positions 
relative to each other.

e. Release both Shift and the left mouse button.

When you are satisfied with the new topology map layout, select File >Save View 
from the SGM Main Menu. SGM saves the changes you have made to the network 
view, including any changes you have made to the topology map layout.
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Step 15 (Optional) To restore the topology map to the way it looked in the last saved view, 
select Topology Tools >Restore Positions from the SGM Main Menu. SGM 
restores the view.

Step 16 (Optional) Some topology maps are so large and complex that it can be difficult 
to find a specific node or linkset.

If the node or linkset is listed in the tables in the left pane of the Topology 
Window, simply select the node or linkset, and SGM highlights it in the topology 
map.

If the node or linkset is not listed in the tables, use the following procedure:

a. Click the Find nodes or linksets (binoculars) button in the Topology 
Window, or select Edit>Find from the SGM Main Menu. SGM displays the 
Find Nodes or Linksets dialog.

b. In the Search string field, enter a character string for which SGM is to 
search.

c. To search for a linkset, select the Linksets checkbox. To search for a node, 
select the Nodes checkbox, then select or clear the Name, IP Address, and 
Point Code checkboxes, to further widen or refine the search.

d. Click Search to launch the search.

If no matching node or linkset is found, SGM displays an appropriate 
message.

If exactly one node or linkset is found that matches the Search string, SGM 
highlights the node or linkset in the Tables panel of the Topology window, and 
zooms in on the selected node or linkset in the topology map.

If more than one node or linkset is found that matches the Search string, 
SGM displays the Choose dialog, enabling you to select from a list of the 
found objects. SGM then highlights the selected node or linkset in the Tables 
panel of the Topology window, and zooms in on the selected node or linkset 
in the topology map.

Step 17 (Optional) To scroll around in the topology map, click anywhere in the map, then 
click the arrow, Page Up, and Page Down keys.

Step 18 (Optional) To redraw the topology map centered on a specific node or linkset, 
double-click on the node or linkset in the topology node table in the left pane of 
the window.
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Step 19 (Optional) To display detailed information about an element in the map, 
double-click it, then respond to SGM’s prompts:

• Double-click a node to display the Node Details pane for that node. If more 
than one linkset is associated with the node, SGM asks you to select one of 
the linksets. (SGM also gives you the option of disabling the linkset-selection 
function.)

• Double-click a single line, or a diamond at the end of a single line, to display 
the Linkset Details pane for that linkset.

• Double-click a heavy line, or a diamond at the end of a heavy line, and select 
a linkset to display the Linkset Details pane for that linkset. (SGM also gives 
you the option of disabling the linkset-selection function.)

Step 20 (Optional) To display the topology new nodes panel, select the New Nodes tab in 
the left pane. The topology new nodes panel displays graphical elements for 
newly discovered nodes, based on the following criteria:

• If you are using an SGM client with the DEFAULT view set, this panel never 
contains any nodes. In the DEFAULT view, SGM adds all newly discovered 
nodes to the topology map as soon as they are discovered.

• If you are using an SGM client with a custom view set, this panel contains all 
nodes discovered since the Topology window was opened in this session that 
have not been excluded in the Nodes Not In Current View pane of the 
Network View Editor window.

a. (Optional) To add a newly discovered node to the topology map, select the 
node in the topology new nodes panel and drag it to the map while holding 
down the left mouse button.

b. (Optional) To exclude a newly discovered node from the topology new nodes 
panel, see the “Working with Views” section on page 3-23.

Step 21 (Optional) To display the topology excluded nodes panel, select the Excluded 
Nodes tab in the left pane. The topology new nodes panel displays graphical 
elements for excluded nodes. Excluded nodes are nodes that you have chosen not 
to manage, that you have moved to the Nodes Not In Current View pane of the 
Network View Editor window. (See the “Creating a View” section on page 3-25 
for more information about excluding nodes from views.)

To add an excluded node to the topology map, select the node and drag it to the 
map while holding down the left mouse button. When you do so, the node is no 
longer an excluded node, and it is removed from the Nodes Not In Current View 
pane of the Network View Editor window.
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Step 22 (Optional) To print the topology map, see the “Printing SGM Windows” section 
on page 3-283.

Step 23 (Optional) To save the topology map as a JPEG file, select Topology Tools >Save 
as JPEG from the SGM Main Menu. SGM displays the Save as JPEG dialog 
(Figure 3-55).

Figure 3-55 Save as JPEG Dialog

The Save as JPEG dialog provides the following options:

• To save the entire topology map as a JPEG file, select All.

• To save just the portion of the topology map displayed in the current window 
as a JPEG file, select Current Window.

• To specify the quality of the JPEG file, select a Quality level, from 0 (lowest 
quality) to 1.0 (highest quality). The default setting is 0.7, which is sufficient 
for most JPEG files.

• To specify the size of the JPEG file, in pixels, choose a value from the Max. 
Size drop-down list box. The valid range is 400 pixels to 2400 pixels. The 
default value is 400 pixels, which is sufficient for most JPEG files.
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• To specify a name for the JPEG file, enter the name in the Name field, or 
accept the default filename, out.jpg.

The default directory for the JPEG file is the directory in which you installed 
the SGM client:

– In Solaris, the default installation directory for the SGM client is 
/opt/CSCOsgmClient.

– In Windows, the default installation directory for the SGM client is 
C:\Program Files\SGMClient\.

– If you installed the SGM client in a different directory, then the 
installation directory is located in that directory.

To save the JPEG file in the default directory, click Save. SGM saves the 
JPEG file and closes the Save as JPEG dialog. Continue with Step 24.

If you do not want to save the JPEG file to the default directory, click Browse 
to select a different directory. SGM displays the Save dialog for a topology 
map (Figure 3-56).

Figure 3-56 Save Dialog for a Topology Map
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The Save dialog for a topology map provides the following options:

– To select the directory in which you want to save the topology map JPEG 
file, either accept the default directory displayed in the Save In field, or 
select a new directory from the drop-down list box.

– To display the sub-folders and files that are in the folder that is up one 
level from the currently displayed folder, click the Up One Level button.

– To display the sub-folders and files that are on your workstation desktop, 
click the Desktop button.

– To create a new sub-folder in the displayed folder, click the Create New 
Folder button.

– To display only icons for sub-folders and files, click the List button.

– To display detailed information for sub-folders and files, including their 
size, type, date they were last modified, and so on, click the Details 
button.

– To specify a name for the JPEG file, enter the name in the File Name 
field, or select a file from those listed in the Save In field.

– To specify the type of file to save, and to display all files of that type in 
the selected directory, select a file type from the Files of Type drop-down 
list box:

– All files—Displays all files in the selected directory, and saves the 
topology map file as a JPEG file.

– jpg files—Displays only JPEG files in the selected directory, and saves 
the topology map file as a JPEG file.

When you are satisfied with the settings, click Save. SGM closes the Save 
dialog for a topology map and populates the Name field in the Save as JPEG 
dialog with the new name and directory.

To save the JPEG file in the new directory, click Save. SGM saves the JPEG 
file and closes the Save as JPEG dialog.

Step 24 (Optional) You can activate a magnetic grid on the topology map. With the grid 
activated, objects “snap” to align with the grid when you move them.

To activate or modify the magnetic topology grid, select Topology 
Tools> Magnetic Grid from the SGM Main Menu. SGM displays the Magnetic 
Grid Settings dialog (Figure 3-57).
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Figure 3-57 Magnetic Grid Settings Dialog

The Magnetic Grid Settings dialog provides the following options:

• To activate the grid, select the Grid Activated checkbox.

To deactivate the grid, clear the Grid Activated checkbox.

• To display the grid on the topology map, select the Grid Activated checkbox, 
then select the Display Grid checkbox.

To hide the grid on the topology map, clear the Display Grid checkbox.

• To specify the spacing between lines on the grid, in pixels, select the Grid 
Activated checkbox, then select a Grid Spacing level. The valid range is 
0 pixels to 150 pixels. The default setting is 50 pixels, which is sufficient for 
most topology maps.

• To specify a color for the grid, select the Grid Activated checkbox, then click 
Select in the Grid Color field. SGM opens the Pick Grid Color dialog 
(Figure 3-58).
3-174
Cisco Signaling Gateway Manager User Guide

78-15204-01



 

Chapter 3 Managing ITP Networks Using SGM
Viewing the Topology of the Network
Figure 3-58 Pick Grid Color Dialog

The Pick Grid Color dialog provides the following options:

– To select a grid color from a set of color swatches (the recommended 
method), click the Swatches tab and select a swatch.

– To select a grid color based on color hue, saturation, and brightness 
(HSB), click the HSB tab, then use one of the following procedures:

- Select a color range on the vertical color bar, then select a specific color 
by moving the cursor around on the color square.

- Enter specific values in the hue (H), saturation (S), and brightness (B) 
fields.
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– To select a grid color based on the red, green, and blue (RGB) content of 
the color, click the RGB tab, then select values for the Red, Green, and 
Blue fields.

– To reset the grid color to its initial setting, click Reset.

Whichever method you choose, the selected color is displayed in the Preview 
field. When you are satisfied with the color, click OK. SGM saves the grid 
color setting and closes the Pick Grid Color dialog.

When you are satisfied with the magnetic grid settings, click OK. SGM saves the 
new grid settings and closes the Magnetic Grid Settings dialog

Note Magnetic grid settings, including the grid color, are not saved when you 
save the view.

To close the Magnetic Grid Settings dialog without changing any settings, click 
Cancel.

Step 25 (Optional) To hide all non-ITP nodes and linksets on the topology map, click the 
Hide/Show Non-ITP Devices button. (The hidden nodes and linksets are still 
shown in the left panel.) To display all hidden nodes and linksets on the topology 
map, click the Hide/Show Non-ITP Devices button again. This setting, with 
non-ITP nodes and linksets either hidden or shown, is saved when you save the 
view.

Step 26 When you are ready to close the Topology Window, select File>Save View from 
the SGM Main Menu. SGM prompts you to save any changes you made to the 
network view, including any changes you have made to the topology map layout, 
and closes the window.
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Finding Information in a Window
Sometimes it can be difficult to find a specific piece of information, such as a node 
name or event text, in a window. SGM enables you to search for a character string 
in the Node, Linkset, and Event Windows.

Note To find a specific node or linkset in the Topology Window, see Step 16 in the 
“Viewing the Topology of the Network” section on page 3-163.

Related Topics:

• Working with Events, page 3-143

• Working with Linksets, page 3-34

• Working with Nodes, page 3-81

To find a character string in a window:

Step 1 In the Node, Linkset, or Event Window, select Edit> Find from the SGM Main 
Menu. SGM displays the Find dialog (Figure 3-59).

Figure 3-59 Find Dialog

Step 2 In the What field, enter the character string for which you want SGM to search. 
This can be any character string: all or part of a node name, linkset name, point 
code, event text, status, and so on.

Step 3 (Optional) If you want SGM to search for only character strings that match the 
case of the text in the What field, select the Match Case checkbox. If you do not 
care about case-matching, clear the checkbox. (This is the default setting.)
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Step 4 (Optional) If you want SGM to search forward (down and to the right) in the 
window, select the Search Forward radio button. This is the default setting.

If you want SGM to search backward (up and to the left) in the window, select the 
Search Backward radio button.

The Search Forward and Search Backward radio buttons are mutually 
exclusive.

Step 5 Click Find. SGM launches the search:

• If a matching character string is found in the window, SGM highlights the 
first line that contains the string.

To find the next occurrence of the string, click Find again.

You can continue to click Find until there are no more matches in the window. 
At that time, SGM displays an appropriate message in the dialog, such as 
Bottom of table reached.

• If no matching character string is found, SGM displays an appropriate 
message in the dialog, such as Bottom of table reached.

Step 6 When you are done searching, click Close. SGM closes the Find dialog.

Resizing, Sorting, and Hiding Table Columns
The columns in some tables in SGM can be resized, sorted, or hidden to meet your 
specific needs.

• To make a column wider or narrower, click the column divider in the header 
and move the divider to the right or left while holding down the left or right 
mouse button.

Depending on your system, as well as other factors, SGM windows can 
sometimes display so small that text is illegible, and columns and text entry 
fields are very narrow and unusable. If this happens, resize the window and 
widen the individual columns until the information is again legible and the 
columns and text entry fields are usable.

• To sort a table based on the data in a column, left-click in the column header. 
The table is sorted alphanumerically from top to bottom, based on the data in 
the selected column. To sort the table in reverse order, left-click in the column 
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header a second time. If two entries in the selected column are identical, SGM 
sorts those rows based on the data in the remaining table columns, moving left 
to right.

• To sort a route table, click Sort Table. SGM sorts the entries in the route table 
field-by-field, beginning with Dest. Point Code, then Mask, Cost, 
Dest.Linkset, and finally QoS.

• To delete a column altogether, see the “Modifying Preference Settings” 
section on page 5-3.

Related Topics:

• Viewing the Topology of the Network, page 3-163

• Working with Links, page 3-111

• Working with Linksets, page 3-34

• Working with Nodes, page 3-81

Viewing Online Help
SGM provides the following online help options in the SGM Main Menu:

• To display the table of contents for the SGM online help in a Web browser, 
select Help> Topics.

• To display online help for the current window in a Web browser, click 
Help>Window.

• To display build date, version, SSL support, and copyright information about 
the SGM application in a Web browser, click Help> About.

Related Topics:

• Viewing the SGM Technical Documentation, page 7-81
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Editing an ITP Route Table File
ITP uses a route table to select the appropriate signaling path for each message, 
or signal unit, that it must forward. The route table provides the destination point 
code of the packet and the linkset name that can be used to forward the packet.

SGM enables you to edit ITP route table files for a router.

To edit a route table file using SGM:

Step 1 Open the route table file, using one of the following procedures:

• To open a route table file from a file, select Edit>Route Table> From File 
from the SGM Main Menu, select the name of a route table file, then click 
OK.

If the selected route table file contains incorrect linkset entries (for example, 
if your network configuration changed since the last time the route table file 
was saved), SGM displays the Replace Linkset Dialog (Figure 3-59).

Figure 3-60 Replace Linkset Dialog
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The Replace Linkset Dialog enables you to quickly replace incorrect linkset 
entries in route table files:

– To replace an incorrect linkset with a correct linkset, select an incorrect 
linkset in the Linksets That Are No Longer Valid table, then select a 
correct linkset from the Auto Replace with Linkset drop-down list box, 
then click Apply. SGM automatically replaces the incorrect linkset with 
the selected correct linkset in all affected entries in the route table file.

– To remove all entries that contain an incorrect linkset from the route table 
fie, select an incorrect linkset in the Linksets That Are No Longer Valid 
table, then select the Remove Entries Containing Selected Linkset 
checkbox, then click Apply. SGM automatically removes all entries that 
contain the incorrect linkset from the route table file.

– When you have corrected all incorrect linksets in the route table file, 
click Done. SGM displays the Route Table Dialog (Figure 3-61).

If the selected route table file does not contain any incorrect linkset entries, 
SGM displays the Route Table Dialog (Figure 3-61).

• To open a route table file from a router, use one of the following procedures:

– Select a node or linkset on the Node, Linkset, or Topology window, then 
select Edit>Route Table> From Router from the SGM Main Menu. (If 
you select an Unmanaged node, this option is grayed-out and cannot be 
selected.)

– Right-click a node on the Node or Topology window, then select Edit 
Route Table from the right-click menu. (If you select an Unmanaged 
node, this option is grayed-out and cannot be selected.)

SGM reads the active route table from the router and displays it in the Route 
Table Dialog (Figure 3-61).
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Figure 3-61 Route Table Dialog

The route table lists destination point codes and associated destination linkset 
names, as well as other important information used to route packets on a node.

Press Enter to move down to the next row in the route table; press Tab to move 
to the next field.

Step 2 You can resize each column in the route table, but you cannot sort the table based 
on the information in one of the columns. See the “Resizing, Sorting, and Hiding 
Table Columns” section on page 3-178 for more details.

Step 3 The Row # field displays a unique number for each entry in the route table. You 
cannot edit this field, but the number might change as you add entries to or delete 
entries from the route table.
3-182
Cisco Signaling Gateway Manager User Guide

78-15204-01



 

Chapter 3 Managing ITP Networks Using SGM
Editing an ITP Route Table File
Step 4 The Dest. Point Code field displays the destination point code for packets on the 
selected node. The destination point code is the point code to which a given packet 
is routed. To edit the destination point code, enter the new code in this field.

If you enter a new destination point code that is less restrictive than the mask, 
SGM displays a message to that effect at the bottom of the Route Table Dialog, 
and performs one of the following actions:

• If you modified an existing point code, SGM restores the previous point code.

• If you entered an entirely new point code, SGM leaves this field blank.

For example, a destination point code of 7.7.7, which specifies 14 bits, is less 
restrictive than a mask of 7.255.0, which specifies only 11 bits. SGM ignores the 
extra bits in the last digit of the destination point code and converts it to 7.7.0.

Step 5 The Mask field specifies the significant bits of the point code:

• For ANSI and China standard networks using the default 24-bit point code 
format, the default mask is 255.255.255.

• For ITU networks using the default 14-bit point code format, the default mask 
is 7.255.7.

To edit the mask, make the changes in this field.

If you enter a new mask, the binary conversion of the mask must contain only ones 
(1), no zeros (0). For example:

• 7.255.7 is a valid mask because it converts to binary 111.11111111.111.

• 7.255.1 is not a valid mask because it converts to binary 111.11111111.001.

If you enter an invalid mask, such as 7.255.1, SGM displays a message to that 
effect at the bottom of the Route Table Dialog, and performs one of the following 
actions:

• If you modified an existing mask, SGM restores the previous mask.

• If you entered an entirely new mask, SGM leaves this field blank.
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If you enter a new mask that is more restrictive than the destination point code, 
SGM asks if you want to adjust the point code automatically based on the new 
mask:

• Click Yes if you want to adjust the point code. For example, if the point code 
is 7.7.7, and you enter the new mask 7.255.0, SGM automatically adjusts the 
point code to 7.7.0.

• Click No if you do not want to adjust the point code:

– If you modified an existing mask, SGM restores the previous mask.

– If you entered an entirely new mask, SGM leaves this field blank.

Step 6 The Cost field displays the cost of the route to the destination, relative to other 
routes. To edit the cost, select a cost from the drop-down list box in this field. The 
valid costs range from 1 (lowest cost and highest priority) through 9 (highest cost 
and lowest priority).

Note If you configure two routes to the same device and do not specify a cost 
for one of them, then the cost for that device defaults automatically to 5. 
The default cost appears here in the Cost column, and in the output of 
the show cs7 route command.

Similarly, if you add a new line to this table and leave the Cost column 
blank, SGM automatically enters a default cost of 5.

Linksets with the same cost form a combined linkset. Do not specify 
more than two linksets with the same cost, under the same destination 
point code and mask.

Step 7 The Dest. Linkset field displays the destination linkset associated with the 
destination point code. The destination linkset is also known as the output linkset. 
To edit the destination linkset, select a destination linkset from the drop-down list 
box in this field.

Step 8 (Optional) The QoS field displays the quality of service (QoS) class of the route, 
as configured by the network administrator. To edit the QoS class of the route, 
select a QoS class from the drop-down list box in this field.

Step 9 (Optional) To add a new route to the route table, select the Dest. Point Code field 
in a blank row, then fill in the fields with values for the new route.
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Step 10 (Optional) To delete an existing route from the route table, select one or more 
routes and click Delete. SGM removes the selected route or routes from the route 
table, without asking for confirmation.

Step 11 (Optional) To load an existing route table file, or to modify the list of route table 
files, select File> Load from the route table menu. SGM displays the Load File 
Dialog - Route Table File List (Figure 3-62).

Figure 3-62 Load File Dialog - Route Table File List

The Load File Dialog - Route Table File List contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the route table file or folder.

• Last Modified—Date and time the route table file or folder was last 
modified.

• Size (bytes)—Size of the route table file or folder, in bytes.

• Number of Files—Total number of route table files and folders (displayed in 
bottom left corner).

To load a route table file, enter the name of the file or select it in the list and click 
OK. SGM loads the route table file, closes the Load File Dialog - Route Table File 
List, and returns to the Route Table Dialog.

To delete a route table file from the route table file list, select a file and click 
Delete. SGM issues an informational message containing the name and location 
of the deleted file.
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To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog - Route Table File List.

To close the Load File Dialog - Route Table File List without loading a route table 
file or saving any changes to the route table file list, click Cancel.

Step 12 (Optional) To save the changes you have made to the route table file, or to modify 
the list of route table files, use one of the following procedures:

• To save the changes you have made to the route table file without changing 
the name of the file, select File >Save from the route table menu.

• To save the changes you have made to the route table file with a new name, 
select File >Save As from the route table menu. SGM displays the Save File 
Dialog - Route Table File List dialog (Figure 3-63).

Figure 3-63 Save File Dialog - Route Table File List Dialog

The Save File Dialog - Route Table File List dialog contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the route table file or folder.

• Last Modified—Date and time the route table file or folder was last 
modified.

• Size (bytes)—Size of the route table file or folder, in bytes.
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• Filename—Name by which you want to save the route table file.

If you create a new route table file name, you can use any letters, numbers, or 
characters in the name that are allowed by your operating system.

• Number of Files—Total number of route table files and folders (displayed in 
bottom left corner).

To save the route table file with a new name, use one of the following procedures:

• To save the file with a completely new name, enter the new name and click 
OK.

• To save the file with an existing name, overwriting an old route table file, 
select the name in the list and click OK.

SGM saves the route table file with the new name, closes the Save File Dialog - 
Route Table File List dialog, and returns to the Route Table Dialog.

Note If another user modifies and saves the route table file before you save your 
changes, SGM asks if you want to overwrite that user’s changes. If you 
choose to do so, the other user’s changes are overwritten and lost. If you 
choose not to do so, your changes are lost, unless you save the route table 
file to a different filename.

SGM stores the modified route table file in the route table file directory on the 
SGM server:

• If you installed SGM in the default directory, /opt, then the SGM route table 
file directory is /opt/CSCOsgm/routes.

• If you installed SGM in a different directory, then the SGM route table file 
directory is located in that directory.

You can use the sgm routedir command to change the directory in which SGM 
stores ITP route table files. See the “SGM Commands and Descriptions” section 
on page B-2 for information about the use of this command.

To delete a route table file from the route table file list, select a file and click 
Delete. SGM issues an informational message containing the name and location 
of the deleted file.
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To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog - Route Table File List dialog.

To close the Save File Dialog - Route Table File List dialog without saving the 
route table file or saving any changes to the route table file list, click Cancel.

Step 13 (Optional) To exit the Route Table Dialog without saving any changes, click 
Cancel.

Step 14 Copy the modified route table file from the SGM routes directory to a location that 
the router can reach via TFTP.

Step 15 TFTP the modified route table file back to the router.

Editing a Global Title Translation Table
SGM enables you to configure Global Title Translation (GTT) entries using the 
SGM GUI.

A global title is an application address, such as an 800 number, calling card 
number, or mobile subscriber identification number. GTT is the process by which 
the Signaling Connection Control Part (SCCP) translates a global title into the 
point code and subsystem number (SSN) of the destination service switching 
point (SSP) where higher layer protocol processing occurs. GTT entries are stored 
in GTT files, which are comma-separated value (CSV) text files with point codes 
written in hexadecimal notation.

Note SGM 2.2 supports only GTT files with file format version 1.0. You can load GTT 
files that use higher file format versions, but fields or features that are unique to 
the higher version are not displayed, and they are removed from the GTT file the 
next time it is saved.

For more detailed information about GTT, including configuration procedures and 
scenarios, see the IP Transfer Point (ITP) feature module for Cisco IOS software 
release 12.2(4)MB4 or later.
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To edit a GTT file using SGM:

Step 1 Launch the SGM GTT client, using one of the following procedures:

• Select Products> Global Title Configurator from the SGM Main Menu.

• Select Start>Programs>Cisco SGM Client> Launch SGM GTT Client 
in Windows.

• Enter the sgm gttclient command. See the “SGM Commands and 
Descriptions” section on page B-2 for more information on the use of this 
command.

Note The GTT Configurator runs as a separate application in SGM, so it 
requires a separate login, just like the SGM client.

SGM displays the GTT Configurator window, with the Selectors and GTA tab 
selected (Figure 3-64).
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Figure 3-64 GTT Configurator, Showing Selectors and GTA Tab

The GTT Configurator window provides a set of tabs, each of which launches a 
specific GTT panel. Each panel is composed of a series of tables that contain GTT 
data. Some of the tables might be blank at first, while others are populated with 
rows of data.

You can edit the values in each row in each table, either by typing over the current 
value, or by selecting a new value from a drop-down list box.

To reset a cell to its previous value, press Esc. (If you have edited more than one 
cell in a row, pressing Esc resets all cells in the row.) To commit your changes, 
click outside the row. Once you have committed your changes, pressing Esc does 
not reset the cells in the row.

Step 2 (Optional) SGM enables you to modify the following aspects of the GTT 
Configurator window to meet your needs:

• Size and location of the main GTT Configurator window

• Variant and version of the last saved GTT file

• Current selected tab (Selectors and GTA, App Group, MAPs, or CPC)
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• For each panel, the location of tables on that panel

• For each table:

– Column widths

– Which columns are visible

– Sort-by column, and whether the sort is ascending or descending

SGM also enables you to save your modifications in a GTT preferences file, load 
an existing GTT preferences file, and modify the list of GTT preferences files.

To save your current preferences, or to modify the list of GTT preferences files, 
use one of the following procedures:

• To save the changes you have made to the GTT preferences file without 
changing the name of the file, select Edit>Preferences> Save from the GTT 
menu.

• To save the changes you have made to the GTT preferences file with a new 
name, select Edit> Preferences>Save As from the GTT menu. SGM 
displays the Save File Dialog - GTT Preferences File List (Figure 3-65).

Figure 3-65 Save File Dialog - GTT Preferences File List

The Save File Dialog - GTT Preferences File List contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the GTT preferences file or folder.

• Last Modified—Date and time the GTT preferences file or folder was last 
modified.
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• Size (bytes)—Size of the GTT preferences file or folder, in bytes.

• Filename—Name by which you want to save the GTT preferences file. If you 
create a new GTT preferences file name, you can use any letters, numbers, or 
characters in the name that are allowed by your operating system.

• Make this my preferred start option—Specifies whether the selected 
preferences file is to be loaded automatically whenever this SGM client is 
started:

– To load the selected preferences file when the SGM client is started, 
select the file, then select this checkbox.

– To load the preferences that you are currently using when the SGM client 
is started, clear the checkbox. This is the default setting.

• Number of Files—Total number of GTT preferences files and folders 
(displayed in bottom left corner).

To save the GTT preferences file with a new name, use one of the following 
procedures:

• To save the file with a completely new name, enter the new name and click 
OK.

• To save the file with an existing name, overwriting an old GTT preferences 
file, select the name in the list and click OK.

SGM saves the GTT file with the new name, closes the Save File Dialog - GTT 
Preferences File List, and returns to the GTT Configuration window.

Note If another user modifies and saves the GTT preferences file before you 
save your changes, SGM asks if you want to overwrite that user’s 
changes. If you choose to do so, the other user’s changes are overwritten 
and lost. If you choose not to do so, your changes are lost, unless you 
save the GTT preferences file to a different filename.

When you save a GTT file or GTT preferences file, SGM makes note of your 
preferences on the SGM client and server, including the variant and version of 
GTT being used.

Thereafter, whenever you launch the GTT client, SGM searches for your GTT 
preferences. If SGM finds your preferences on the SGM server, SGM launches the 
GTT client with those preferences. Otherwise, SGM launches the GTT client with 
the default GTT preferences file (ITU variant and version 1.0).
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To delete a GTT preferences file from the GTT preferences file list, select a file 
and click Delete. SGM issues an informational message containing the name and 
location of the deleted file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog - GTT Preferences File List.

To close the Save File Dialog - GTT Preferences File List without saving the GTT 
preferences file or saving any changes to the GTT preferences file list, click 
Cancel.

Step 3 (Optional) To load an existing GTT preferences file, select 
Edit>Preferences> Load from the GTT menu. SGM displays the Load File 
Dialog - GTT Preferences File List (Figure 3-66).

Figure 3-66 Load File Dialog - GTT Preferences File List

The Load File Dialog - GTT Preferences File List contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the GTT preferences file or folder.

• Last Modified—Date and time the GTT preferences file or folder was last 
modified.

• Size (bytes)—Size of the GTT preferences file or folder, in bytes.

• Number of Files—Total number of GTT preferences files and folders 
(displayed in bottom left corner).

To load a GTT preferences file, enter the name of the file or select it in the list and 
click OK. SGM loads the GTT preferences file, closes the Load File Dialog - GTT 
Preferences File List, and returns to the GTT Configuration window.
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To delete a GTT preferences file from the GTT file list, select a file and click 
Delete. SGM issues an informational message containing the name and location 
of the deleted file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog - GTT Preferences File List.

To close the Load File Dialog - GTT Preferences File List without loading a GTT 
preferences file or saving any changes to the GTT preferences file list, click 
Cancel.

Step 4 Select the Selectors and GTA tab if you are primarily interested in displaying 
data for a specific GTT selector, and seeing the GTA entries for that selector. SGM 
displays the Selectors and GTA panel.

A GTT selector defines the parameters that select the translation table used to 
translate an SCCP message to its next or final destination.

A Global Title Address (GTA) entry is associated with a selector and defines the 
result of a translation for a particular address mask. The result of a GTA entry can 
be either a final translation or an intermediate translation

When you first launch the Selectors and GTA panel, only the Selector Table is 
populated with data.

• To populate the GTA Table, select a row in the Selector Table. The GTA Table 
is populated with all associated GTA entries. If the GTA Table remains blank, 
the selected row has no associated GTA entries.

• To populate the App Group Table, select a row in the GTA Table that has an 
associated App. Group. The App Group Table is populated with all 
application group entries for that application group name.

• To populate the MAP Table, select a row in the GTA Table that does not have 
an associated App. Group. The MAP Table is populated with all MAP entries 
that match the selected row's point code-SSN combination.

• To populate the CPC List, select a row in the MAP Table that has an 
associated CPC List Name. The CPC List is populated with all point codes 
in that CPC list.

The Selector Table displays the following information:

• Name—Name of the selector.

• Translation Type—Translation type used by the selector. Valid values are 
integers in the range 0 through 255.
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• Global Title Indicator—Global title indicator for the selector. Valid values 
are integers in the range 2 and 4.

• Numbering Plan—Numbering plan for the selector. Valid values are integers 
in the range 0 through 15.

• Nature of Addr. Indicator—Nature of address indicator for the selector. 
Valid values are integers in the range 0 through 127.

• QoS—Quality of service (QoS) class of the selector. Valid QoS classes range 
from 1 through 7. ALL indicates that the selector accepts all QoS classes.

The GTA Table displays the following information:

• Selector Name—Name of the selector associated with this GTA.

• Global Title Addr. Digits—Address digits for the GTA.

• Point Code—Destination point code for the GTA.

• Routing Indicator—Routing indicator for the GTA. Valid values are:

– none—No routing indicator.

– gt—Route on the global title.

– pcssn—Route on the point code and SSN.

This field is grayed-out if Configure By App Group is selected.

• Subsystem Number—Destination SSN for the GTA. Valid values are 
integers in the range 2 through 255.

• New Translation Type—Translation type to be used by the GTA. Valid 
values are integers in the range 0 through 255.

• App. Group—Name of the application group that is to provide the point 
code, routing indicator, and SSN to be used by the GTA.

• QoS—Quality of service (QoS) class of the GTA. Valid QoS classes range 
from 1 through 7. ALL indicates that the GTA accepts all QoS classes.
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The App Group Table displays the following information:

• App. Group—Name of the application group.

• Multiplicity—Multiplicity setting for the application group. Valid values 
are:

– sha—Share equally between all destinations.

– cos—Use the destination with the least cost, if available.

• Cost—Relative cost of the application group. Valid values are integers in the 
range 1 through 8.

• Point Code—Destination point code for the application group.

• Routing Indicator—Routing indicator for the application group. Valid 
values are:

– none—No routing indicator.

– gt—Route on the global title. This is the default routing indicator.

– pcssn—Route on the point code and SSN.

• Subsystem Number—Destination SSN for the application group. Valid 
values are integers in the range 2 through 255.

The MAP Table displays the following information:

• Primary Pt. Code—Primary point code for the MAP.

• Primary SSN—Primary SSN for the MAP. Valid values are integers in the 
range 2 through 255.

• Multiplicity—Multiplicity setting for the MAP. Valid values are:

– dom—Dominant. Always translate to the primary point code-SSN 
combination if it is available. Translate to the backup point code-SSN 
combination only if the primary combination is not available.

– sha—Share equally between the primary point code-SSN combination 
and the backup point code-SSN combination.

– sol—Solitary MAP. There is no alternate if the point code or SSN is not 
available.

• Backup Pt. Code—Backup point code for the MAP.

• Backup SSN—Backup SSN for the MAP. Valid values are integers in the 
range 2 through 255.
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• CPC List Name—Name of the CPC list associated with this MAP.

• Re-route if Congested—Indicates whether the MAP is to be routed to the 
backup point code-SSN combination if the primary combination is 
congested:

– If the checkbox is selected, the MAP is routed to the backup combination 
when the primary combination is congested.

– If the checkbox is cleared, the MAP is not routed to the backup.

• Adjacency—Indicates whether a point code-SSN combination is to be 
considered adjacent to the local node for SCCP management:

– If the checkbox is selected, the point code-SSN combination is 
considered adjacent to the local node.

– If the checkbox is cleared, the point code-SSN combination is not 
considered adjacent to the local node.

The CPC List displays the following information:

• Point Code—Point codes in the selected CPC list.

Step 5 Select the App Group tab if you are primarily interested in displaying data for 
application groups. SGM displays the App Group panel.

An application group is an alternative result for the explicit point code and SSN 
in a GTA entry. You can use an application group entry for intermediate 
translation, for load-sharing across more than two destinations, or for 
load-sharing of intermediate translation.

When you first launch the App Group panel, only the App Group Table and 
Selector Table are populated with data.

• To populate the MAP Table, select a row in the App Group Table. The MAP 
Table is populated with all MAP entries that match the selected row's point 
code-SSN combination.

• To populate the CPC List, select a row in the MAP Table that has an 
associated CPC List Name. The CPC List is populated with all point codes 
in that CPC list.

• To populate the GTA Table, select a row in the Selector Table. The GTA Table 
is populated with all associated GTA entries. If the GTA Table remains blank, 
the selected row has no associated GTA entries.

The App Group panel displays the same information as the Selectors and GTA 
panel, but from the perspective of the application groups.
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Step 6 Select the MAPs tab if you are primarily interested in displaying data for MAPs. 
SGM displays the MAPs panel.

A mated application (MAP) entry has two main purposes:

• MAP entries are used internally by the SCCP application to track point code 
states and SSN states, such as congestion and availability.

• MAP entries are used to define backups or alternates for point code-SSN 
combination.

When you first launch the MAPs panel, only the MAP Table and Selector Table 
are populated with data.

• To populate the CPC List, select a row in the MAP Table that has an 
associated CPC List Name. The CPC List is populated with all point codes 
in that CPC list.

• To populate the App Group Table and GTA Table, select a row in the MAP 
Table. The App Group Table and GTA Table are populated with all 
application group and GTA entries that match the selected row's point 
code-SSN combination. If the App Group Table or GTA Table remains blank, 
the selected row has no associated application group or GTA entries.

The MAPs panel displays the same information as the Selectors and GTA panel, 
but from the perspective of the MAPs.
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Step 7 Select the CPC tab if you are primarily interested in displaying data for concerned 
point code names. SGM displays the CPC panel (Figure 3-67).

Figure 3-67 GTT Configurator, Showing CPC Tab

A concerned point code (CPC) is a node that is to be notified when the status of 
the associated SSN changes.

When you first launch the CPC panel, only the Concerned Pt. Code Name List is 
populated with data. To populate the CPC List and MAP Table, select a row in the 
Concerned Pt. Code Name List. The CPC List and MAP Table are populated with 
all point codes and MAP entries that match that concerned point code name.

The CPC panel displays the CPC List and MAP Table, as well as the Concerned 
Pt. Code Name List. The Concerned Pt. Code Name List displays the CPC List 
Name, which is the name of the CPC list to be added. Enter 1-to-12-character 
alphanumeric string.
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To copy one or more point codes from one CPC list to another, select a CPC list 
in the CPC List Name column. SGM displays the point codes associated with that 
CPC list in the Point Code column. Select one or more of the point codes and drag 
them to the new CPC list while holding down the left mouse button.

Note SGM copies the point codes to the new CPC list; it does not move them 
from the old CPC list. If you want to move the point codes, you must 
copy them to the new CPC list, then delete them from the old CPC list.

Step 8 (Optional) To add a new selector to a Selector Table, select a Selector Table, then 
use one of the following procedures:

• Select Edit>Add from the GTT menu.

• Select Add from the right-click menu.

SGM displays the Selector Add Dialog (Figure 3-68).

Figure 3-68 Selector Add Dialog
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The Selector Add Dialog contains the following fields:

• Selector Name—Name of the selector to be added. Enter 1-to-12-character 
alphanumeric string.

• Translation Type—Translation type to be used by the selector. Enter an 
integer in the range 0 through 255.

• Global Title Indicator—Global title indicator for the selector. Select a value 
from the drop-down list box. Valid values are:

– 2

– 4—This is the default value.

• Numbering Plan—Numbering plan for the selector. Enter an integer in the 
range 0 through 15. This field is grayed-out if Global Title Indicator is set 
to 2.

• Nature of Addr. Indicator—Nature of address indicator for the selector. 
Enter an integer in the range 0 through 127. This field is grayed-out if Global 
Title Indicator is set to 2.

• QoS—Quality of service (QoS) class of the selector. Select a value from the 
drop-down list box. Valid QoS classes range from 1 through 7. Select ALL if 
you want the selector to accept all QoS classes. The default value is ALL.

Enter or select values for the new selector, then click Add. SGM adds the selector 
to the Selector Table.

When you are done adding selectors, click Close to close the Selector Add Dialog.

Step 9 (Optional) To add a new GTA entry to a GTA Table, select a GTA Table, then use 
one of the following procedures:

• Select Edit>Add from the GTT menu.

• Select Add from the right-click menu.

SGM displays the Selector Add Dialog (Figure 3-69).
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Figure 3-69 GTA Add Dialog

The GTA Add Dialog contains the following fields:

• Selector Name—Name of the selector associated with this GTA. You cannot 
edit this field.

• Global Title Addr. Digits—Address digits for the GTA. Enter a 1 to 15 digit 
hexadecimal string.

• QoS—Quality of service (QoS) class of the GTA. Select a value from the 
drop-down list box. Valid QoS classes range from 1 through 7. Select ALL if 
you want the GTA to accept all QoS classes. The default value is ALL.
3-202
Cisco Signaling Gateway Manager User Guide

78-15204-01



 

Chapter 3 Managing ITP Networks Using SGM
Editing a Global Title Translation Table
• Configure By App Group—Indicates whether to configure the GTA by point 
code or application group:

– To configure the GTA by point code, clear the checkbox. The Config By 
Point Code fields are made available, and the Config By App Group 
fields are grayed-out. This is the default setting.

– To configure the GTA by application group, select the checkbox. The 
Config By App Group fields are made available, and the Config By 
Point Code fields are grayed-out. The point code, routing indicator, and 
SSN to be used by the GTA are provided by a specified application group.

• Point Code—Destination point code for the GTA. Enter a point code. This 
field is grayed-out if Configure By App Group is selected.

• Routing Indicator—Routing indicator for the GTA. Select a value from the 
drop-down list box. Valid values are:

– gt—Route on the global title. This is the default routing indicator.

– pcssn—Route on the point code and SSN.

This field is grayed-out if Configure By App Group is selected.

• Subsystem Number—Destination SSN for the GTA. Enter an integer in the 
range 2 through 255. This field is mutually exclusive with the New 
Translation Type field. This field is grayed-out if Configure By App Group 
is selected.

• New Translation Type—Translation type to be used by the GTA. Enter an 
integer in the range 0 through 255. This field is mutually exclusive with the 
Subsystem Number field. This field is grayed-out if Configure By App 
Group is selected.

• App. Group—Name of the application group that is to provide the point 
code, routing indicator, and SSN to be used by the GTA. Enter the name of an 
application group. This field is grayed-out if Configure By Point Code is 
selected.

Enter or select values for the new GTA entry, then click Add. SGM adds the GTA 
entry to the GTA Table.

When you are done adding GTA entries, click Close to close the GTA Add Dialog.
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Step 10 (Optional) To search the GTA Table for the Global Title Address Digits for a 
specific selector, select the Selectors and GTA tab, then select View >Phone 
Number Config from the GTT menu. SGM displays the The Phone Number 
Lookup Dialog (Figure 3-70).

Figure 3-70 Phone Number Lookup Dialog

The Phone Number Lookup Dialog contains the following fields:

• Phone Number—GTA digits to be searched for in the GTA Table. Enter a 
telephone number or prefix as a 1 to 15 digit hexadecimal string. For 
example, to search for a specific telephone number, such as 919-555-6384, 
enter 9195556384. To search for all entries that begin with the 919-555 
telephone prefix, enter 919555.

Enter the GTA digits in the Phone Number field, then click OK. SGM searches 
for the GTA digits, closes the Phone Number Lookup Dialog, and displays the 
entries that contained the GTA digits in the GTA Table. If SGM found no 
matching entries, SGM displays 0 Entries in the GTA Table table header.

To close the Phone Number Lookup Dialog without searching for the GTA digits, 
click Cancel.

Step 11 (Optional) To add a new application group entry to an App Group Table, select an 
App Group Table, then use one of the following procedures:

• Select Edit>Add from the GTT menu.

• Select Add from the right-click menu.

SGM displays the App Group Add Dialog (Figure 3-71).
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Figure 3-71 App Group Add Dialog

The App Group Add Dialog contains the following fields:

• App. Group—Name of the application group to be added. Enter 
1-to-12-character alphanumeric string.

• Multiplicity—Multiplicity setting for the application group. Select a value 
from the drop-down list box. Valid values are:

– sha—Share equally between all destinations. This is the default value.

– cos—Use the destination with the least cost, if available.

• Cost—Relative cost of the application group. Select a relative cost, 
1 through 8, from the drop-down list box. The default value is 1.

• Point Code—Destination point code for the application group. Enter a point 
code.

• Routing Indicator—Routing indicator for the application group. Select a 
value from the drop-down list box. Valid values are:

– gt—Route on the global title. This is the default routing indicator.

– pcssn—Route on the point code and SSN.

• Subsystem Number—Destination SSN for the application group. Enter an 
integer in the range 2 through 255.
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Enter or select values for the new application group entry, then click Add. SGM 
adds the application group entry to the App Group Table.

When you are done adding application group entries, click Close to close the App 
Group Add Dialog.

Step 12 (Optional) To add a new MAP entry to a MAP Table, select a MAP Table, then 
use one of the following procedures:

• Select Edit>Add from the GTT menu.

• Select Add from the right-click menu.

SGM displays the MAP Add Dialog (Figure 3-72).

Figure 3-72 MAP Add Dialog

The MAP Add Dialog contains the following fields:

• Primary Pt. Code—Primary point code for the MAP. Enter a point code.

• Primary SSN—Primary SSN for the MAP. Enter an integer in the range 
2 through 255.
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• Multiplicity—Multiplicity setting for the MAP. Select a value from the 
drop-down list box. Valid values are:

– dom—Dominant. Always translate to the primary point code-SSN 
combination if it is available. Translate to the backup point code-SSN 
combination only if the primary combination is not available.

– sha—Share equally between the primary point code-SSN combination 
and the backup point code-SSN combination. This is the default value.

– sol—Solitary MAP. There is no alternate if the point code or SSN is not 
available.

• Backup Pt. Code—Backup point code for the MAP. Enter a point code.

• Backup SSN—Backup SSN for the MAP. Enter an integer in the range 
2 through 255.

• CPC List Name—Name of the CPC list to be associated with this MAP. 
Enter a CPC list name.

• Re-route if Congested—Indicates whether the MAP is to be routed to the 
backup point code-SSN combination if the primary combination is 
congested:

– If you want to route the MAP to the backup combination when the 
primary combination is congested, select the checkbox.

– If you do not want to route the MAP to the backup, clear the checkbox. 
This is the default setting.

• Adjacency—Indicates whether a point code-SSN combination is to be 
considered adjacent to the local node for SCCP management:

– If you want the point code-SSN combination be considered adjacent to 
the local node, select the checkbox.

– If you do not want the point code-SSN combination be considered 
adjacent to the local node, clear the checkbox. This is the default setting.

Enter or select values for the new MAP entry, then click Add. SGM adds the MAP 
entry to the MAP Table.

When you are done adding MAP entries, click Close to close the MAP Add 
Dialog.
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Step 13 (Optional) To add a new CPC list to a CPC Table, select a Concerned Pt. Code 
Name List or a CPC List, then use one of the following procedures:

• Select Edit>Add from the GTT menu.

• Select Add from the right-click menu.

SGM displays the CPC Add Dialog (Figure 3-73).

Figure 3-73 CPC Add Dialog

The CPC Add Dialog contains the following fields:

• CPC List Name—Name of the CPC list to be added. Enter 1-to-12-character 
alphanumeric string.

• Concerned Pt. Code List—One or more CPCs to be added to the new CPC 
list. Enter one or more CPCs, separated by spaces.

Enter or select values for the new CPC list, then click Add. SGM adds the CPC 
list to the MAP Table.

When you are done adding CPC lists, click Close to close the CPC Add Dialog.
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Step 14 (Optional) To delete one or more rows from a table, select the rows, then select 
Edit>Delete from the GTT menu or Delete from the right-click menu. SGM 
displays the Confirm Delete Dialog to confirm the deletion:

• To delete the selected rows, click Yes. The rows are deleted from the table and 
the Confirm Delete Dialog is closed.

• To retain the selected rows, click No. The rows are kept in the table and the 
Confirm Delete Dialog is closed.

You can select more than one row to delete, but all selected rows must be in the 
same table. For example, you cannot delete rows from both the Selector Table and 
the MAP Table at the same time.

If deleting a row from a table “orphans” one or more rows in the table, such that 
no remaining entries reference the orphaned rows, SGM displays the number of 
orphaned rows and asks whether you want to also delete the orphaned rows. (SGM 
displays the number of rows and not the rows themselves, because there could be 
thousands of orphaned rows.)

Step 15 (Optional) To create a new GTT file, select File> New Table from the GTT menu. 
SGM displays the Create New Table Dialog (Figure 3-74).

Figure 3-74 Create New File Dialog
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The Create New Table Dialog contains the following fields:

• Variant—Point code format to be used by the new GTT. Select a point code 
format from the drop-down list box. Valid formats are:

– ANSI—Formats point codes using the 24-bit format American National 
Standards Institute (ANSI) standard, xxx.yyy.zzz format, where:

– xxx is the 8-bit network identification

– yyy is the 8-bit network cluster

– zzz is the 8-bit network cluster member

– China—Formats point codes using the 24-bit format China standard, 
xxx.yyy.zzz format, where:

– xxx is the 8-bit network identification

– yyy is the 8-bit network cluster

– zzz is the 8-bit network cluster member

– ITU—Formats point codes using the 14-bit format International 
Telecommunication Union (ITU) standards, x.yyy.z format, where:

– x is the 3-bit zone identification

– yyy is the 8-bit region identification

– z is the 3-bit signal-point

This is the default setting.

• Version—Version of the file format to be used by the GTT. Valid versions are:

– 1.0—This is the default version, and the only version that is currently 
available.

Select a variant and version for the new GTT file, then click OK. SGM creates the 
new GTT file and closes the Create New Table Dialog.

To close the Create New Table Dialog without creating a new GTT file, click 
Cancel.
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Step 16 (Optional) To load an existing GTT file, or to modify the list of GTT files, select 
File >Load from the GTT menu. SGM displays the Load File Dialog - GTT File 
List (Figure 3-75).

Figure 3-75 Load File Dialog - GTT File List

The Load File Dialog - GTT File List contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the GTT file or folder.

• Last Modified—Date and time the GTT file or folder was last modified.

• Size (bytes)—Size of the GTT file or folder, in bytes.

• Number of Files—Total number of GTT files and folders (displayed in 
bottom left corner).

To load a GTT file, enter the name of the file or select it in the list and click OK. 
SGM closes the Load File Dialog - GTT File List and displays the Progress Dialog 
(Figure 3-76).
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Figure 3-76 Progress Dialog

The Progress Dialog displays the progress of the GTT file load, as well as any 
messages generated while loading the file.

To stop loading the file, click Cancel.

When the file has been loaded, click OK. SGM closes the Progress Dialog, loads 
the GTT file, and returns to the GTT Configuration window.

When you load a GTT file, the name of the server associated with the GTT client 
and the filename are displayed in the window name:

SGM: GTT Configurator - sgm-sun8 -- GTT.File.1

If you have not yet loaded or saved a GTT file, SGM displays No File Loaded in 
place of the GTT file name.

To delete a GTT file from the GTT file list, select a file and click Delete. SGM 
issues an informational message containing the name and location of the deleted 
file.
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To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog - GTT File List.

To close the Load File Dialog - GTT File List without loading a GTT file or saving 
any changes to the GTT file list, click Cancel.

Step 17 (Optional) SGM enables you to check the semantics of a GTT file against a 
specific router, validating the following data in the GTT file:

• Router Point Code—The point code in the GTT file cannot be the same as 
the router's primary, secondary, or capability point code. If it is the same, 
SGM generates an Error.

• Route Table—All point codes in the GTT file must also be in the router's 
route table. If they are not, SGM generates an Error.

• Route Status—All route entries for point codes in the GTT file must be 
available. If they are not, SGM generates a Warning.

To check the semantics of a GTT file, select File> Semantic Check from the GTT 
menu. SGM displays the Semantic Check GTT dialog (Figure 3-77).

Figure 3-77 Semantic Check GTT Dialog

The Semantic Check GTT dialog contains the following fields:

• Router Name or IP Address—Name or IP address of the router against 
which to check the GTT file.

Enter the name or IP address of a router and click OK. SGM closes the Semantic 
Check GTT dialog and opens the Progress Dialog (Figure 3-76).

The Progress Dialog displays the progress of the semantic check for the GTT file, 
as well as any messages generated while checking the file.

To cancel the check, click Cancel.

When the check is complete, click OK. SGM closes the Progress Dialog and 
returns to the Semantic Check GTT dialog.
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To close the Semantic Check GTT dialog without checking the semantics of the 
GTT file, click Cancel.

Note You can also use the sgm gttcheck command to semantics of a GTT file. 
For more information on the use of this command, see the “SGM 
Commands and Descriptions” section on page B-2.

Step 18 (Optional) To display basic information about the currently displayed GTT file, 
select View >GTT Table Info from the GTT menu. SGM displays the GTT Table 
Info Dialog (Figure 3-78).

Figure 3-78 GTT Table Info Dialog

The GTT Table Info Dialog contains the following fields:

• Filename—Name of the GTT file.

• Version—Version of the file format to be used by the GTT. Valid versions are:

– 1.0—This is the default version, and the only version that is currently 
available.
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• Variant—Point code format to be used by the GTT. Valid formats are:

– ANSI—Formats point codes using the 24-bit format American National 
Standards Institute (ANSI) standard, xxx.yyy.zzz format, where:

– xxx is the 8-bit network identification

– yyy is the 8-bit network cluster

– zzz is the 8-bit network cluster member

– China—Formats point codes using the 24-bit format China standard, 
xxx.yyy.zzz format, where:

– xxx is the 8-bit network identification

– yyy is the 8-bit network cluster

– zzz is the 8-bit network cluster member

– ITU—Formats point codes using the 14-bit format International 
Telecommunication Union (ITU) standards, x.yyy.z format, where:

– x is the 3-bit zone identification

– yyy is the 8-bit region identification

– z is the 3-bit signal-point

This is the default setting.

• Last Modified—Date and time the GTT file was last modified.

• Total Entries—Total number of entries in the GTT file.

Click OK to close the GTT Table Info Dialog.

Step 19 (Optional) To save the changes you have made to the GTT file, or to modify the 
list of GTT files, use one of the following procedures:

• To save the changes you have made to the GTT file without changing the 
name of the file, select File>Save from the GTT menu.

• To save the changes you have made to the GTT file with a new name, select 
File >Save As from the GTT menu. SGM displays the Save File Dialog - GTT 
File List (Figure 3-79).
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Figure 3-79 Save File Dialog - GTT File List

The Save File Dialog - GTT File List contains the following fields:

• Type—Icon indicating whether the item in the table is a file or a folder.

• Name—Name of the GTT file or folder.

• Last Modified—Date and time the GTT file or folder was last modified.

• Size (bytes)—Size of the GTT file or folder, in bytes.

• Filename—Name by which you want to save the GTT file.

If you create a new GTT file name, you can use any letters, numbers, or 
characters in the name that are allowed by your operating system.

• Number of Files—Total number of GTT files and folders (displayed in 
bottom left corner).

To save the GTT file with a new name, use one of the following procedures:

• To save the file with a completely new name, enter the new name and click 
OK.

• To save the file with an existing name, overwriting an old GTT file, select the 
name in the list and click OK.

SGM closes the Save File Dialog - GTT File List and displays the Progress Dialog 
(Figure 3-76).
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The Progress Dialog displays the progress of the GTT file save, as well as any 
messages generated while saving the file.

To stop saving the file, click Cancel.

When the file has been saved, click OK. SGM closes the Progress Dialog, saves 
the GTT file with the new name, and returns to the GTT Configuration window.

Note If another user modifies and saves the GTT file before you save your 
changes, SGM asks if you want to overwrite that user’s changes. If you 
choose to do so, the other user’s changes are overwritten and lost. If you 
choose not to do so, your changes are lost, unless you save the GTT file 
to a different filename.

To delete a GTT file from the GTT file list, select a file and click Delete. SGM 
issues an informational message containing the name and location of the deleted 
file.

To save any changes you made to the list of files, click OK. SGM saves the 
changes and closes the Load File Dialog - GTT File List.

To close the Save File Dialog - GTT File List without saving the GTT file or 
saving any changes to the GTT file list, click Cancel.

Step 20 When you are ready to exit the GTT Configurator window, select File>Exit from 
the GTT menu.

If you have made any changes to the GTT file, SGM asks if you want to save the 
changes before leaving the window:

• Click Yes to save the changes.

SGM opens the Save File Dialog - GTT File List, which enables you to save 
the GTT file with a new name, or overwrite an existing GTT file.

SGM then opens the Save File Dialog - GTT Preferences File List, which 
enables you to save the GTT preferences file with a new name, or overwrite 
an existing GTT preferences file.

• Click No to close the prompt window.

SGM automatically saves your GTT preferences, then closes the GTT 
Configurator window without saving any changes to the GTT file.
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By default, GTT files and GTT preferences files are located in the SGM 
installation directory:

• If you installed SGM in the default directory, /opt, then the default directory 
is /opt/CSCOsgm/gtt.

• If you installed SGM in a different directory, then the default directory is 
located in that directory.

To change the directory in which SGM stores GTT files, use the sgm gttdir 
command. See the “SGM Commands and Descriptions” section on page B-2 form 
more information on the use of this command.

Working with SGM Statistics Reports
Once every hour, SGM gathers critical information from all known nodes, 
linksets, and links. SGM then uses that information to calculate statistics, and 
generates reports based on those statistics.

SGM enables you to:

• View and export detailed network link and linkset statistics summary reports.

• View and export detailed accounting statistics reports.

• Create, view, and export custom statistics reports.

• View and export point code inventory reports.

• Modify the way SGM displays information in reports.

By default, SGM stores all reports in the report files directory, /reports:

• If you installed SGM in the default directory, /opt, then the default report files 
directory is /opt/CSCOsgm/reports.

• If you installed SGM in a different directory, then the default report files 
directory is located in that directory.

The /reports directory contains the following subdirectories:

• /daily—Contains all daily report files, stored in .Z format.

• /exportdaily—Contains all daily report files, edited and formatted for export, 
stored as Zip files.

• /hourly—Contains all hourly report files, stored in .Z format.
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• /exporthourly—Contains all hourly report files, edited and formatted for 
export, stored as Zip files.

• /exportrolling—Contains all rolling report files, edited and formatted for 
export, stored as Zip files. SGM rebuilds the files in this subdirectory every 
hour.

• /custom—Contains all custom report files. These are the report files 
generated using the sgm accstats and sgm linkstats commands.

Each file is identified with a unique ID tag, specified when the sgm accstats 
or sgm linkstats command was entered. If the user did not specify an ID tag, 
SGM uses the process ID of the sgm accstats or sgm linkstats command.

• /etc—Contains additional files used by the SGM reporting scripts and Web 
pages, including the nodes.include, linksets.include, nodes.exclude, and 
linksets.exclude files, if they exist.

This section includes the following information:

• Modifying the Way SGM Handles Statistics Reports (Solaris Only), 
page 3-220

• Changing the SGM Reports Directory (Solaris Only), page 3-227

• Viewing SGM Network Statistics Reports, page 3-228

• Viewing SGM Accounting Statistics Reports, page 3-248

• Generating and Viewing Custom SGM Statistics Reports, page 3-254

• Viewing SGM Point Code Inventory Reports, page 3-275

• Viewing SGM Statistics Reports Logs, page 3-279
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Modifying the Way SGM Handles Statistics Reports (Solaris 
Only)

SGM enables you to modify the following aspects of statistics reports:

• To specify whether SGM is to generate network statistics reports, enter the 
sgm statreps [disable | enable] command:

– To generate network statistics reports, enter sgm statreps enable. This is 
the default setting.

– To not generate network statistics reports, enter sgm statreps disable.

• To specify whether SGM is to generate network statistics reports in export 
format, enter the sgm statreps [export | noexport] command:

– To generate network statistics reports in export format, enter 
sgm statreps export. This is the default setting.

– To not generate network statistics reports in export format, enter 
sgm statreps noexport.

• To specify whether SGM is to generate accounting statistics reports, enter the 
sgm statreps [acct | noacct] command:

– To generate accounting statistics reports, enter sgm statreps acct.

– To not generate accounting statistics reports, enter sgm statreps noacct. 
This is the default setting.

• To specify whether SGM is to include links that use the Stream Control 
Transmission Protocol (SCTP) IP transport protocol in network statistics 
reports, enter the sgm statreps [iplinks | noiplinks] command:

– To include SCTPIP links, enter sgm statreps iplinks. This is the default 
setting.

– To not include SCTPIP links, enter sgm statreps noiplinks.

• To specify whether SGM is to include links that do not have planned send and 
receive capacities in network statistics reports, enter the sgm statreps 
[nullcaps | nonullcaps] command:

– To include links that do not have planned send and receive capacities, 
enter sgm statreps nullcaps. This is the default setting.

– To not include links that do not have planned send and receive capacities, 
enter sgm statreps nonullcaps.
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• To set the time mode for dates in network statistics reports, enter the 
sgm statreps timemode [12 | 24] command:

– To use 24-hour time, also called military time, enter sgm statreps 
timemode 24. 1:00 in the afternoon is 13:00. This is the default setting.

– To use 12-hour time, with AM and PM, enter sgm statreps 
timemode 12. 1:00 in the afternoon is 1:00 PM.

• To specify whether SGM is to verify that a disk has at least 10 MB of space 
remaining before generating network statistics reports, enter the 
sgm statreps [diskcheck | nodiskcheck] command:

– To verify the disk space, enter sgm statreps diskcheck. This is the 
default setting.

– To not verify the disk space, enter sgm statreps nodiskcheck.

• To specify whether SGM is to display a gray background in the Send 
Utilization or Receive Utilization cell in a network statistics report, if the 
following condition is met:

Current Utilization > factor * Long-Term Utilization

enter the sgm statreps utilratio command. The default value for factor is 1.5.

• To specify whether SGM is to display a gray background in the InSrv cell in 
a network statistics report, if the following condition is met:

Current In-Service < factor * Long-Term In-Service

enter the sgm statreps servratio command. The default value for factor 
is 0.95.

• To set the maximum number of days SGM is to archive hourly network 
statistics reports, enter the sgm statreps hourlyage or sgm rephourlyage 
command. The default setting is 31  days.

• To set the maximum number of days SGM is to archive daily network 
statistics reports, enter the sgm statreps dailyage or sgm repdailyage 
command. The default setting is 90  days.

• To set the maximum number of days SGM is to archive custom network 
statistics reports, enter the sgm repcustage command. The default setting is 
10  days.
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• To specify whether SGM is to show real node names or display names in Web 
pages, enter the sgm webnames command:

– To show the real DNS names of nodes, as discovered by SGM, enter sgm 
webnames real. This is the default setting.

– To show display names, enter sgm webnames display. Display names 
are new names that you specify for nodes. For more information about 
display names, see the “Editing a Node” section on page 3-99.

• To specify whether SGM is to display send and receive utilization for linksets 
and links as percentages or in Erlangs in Web pages, enter the sgm webutil 
command:

– To display utilization as a percentage, enter sgm webutil percent. This 
is the default setting.

– To show display utilization in Erlangs, enter sgm webutil erlangs.

See the “Working with SGM Statistics Reports” section on page 3-218 for 
more information on send and receive utilization for linksets and links.

• To display the current status of all SGM network statistics report parameters, 
enter the sgm statreps status command.

• To display the timer file for SGM network statistics reports, enter the 
sgm statreps timer command. The timer file is useful for identifying how 
much time SGM spends gathering report data and generating reports.
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• To include only specific nodes in reports, create the user-defined 
nodes.include file and list the nodes in the file. Only those nodes will be 
included in automatically generated SGM accounting statistics and network 
statistics reports, as well as in custom reports that were generated with the 
default keyword (or no node-list keyword at all) on the sgm accstats or 
sgm linkstats command.

Keep in mind the following considerations:

– If you installed SGM in the default directory, /opt, then the nodes.include 
file is located at /opt/CSCOsgm/reports/etc/nodes.include.

If you installed SGM in a different directory, or if you moved the report 
files directory using the sgm repdir command, then the 
/reports/etc/nodes.include file is located in that directory.

– Each line in the nodes.include file must contain a single node name that 
matches exactly the real, fully qualified node name of the node, and each 
line must end with a colon (:). For example:

sgm-75-59a.cisco.com:

sgm-26-51a.cisco.com:

– Wildcard matching is not supported.

– If a node appears in both the nodes.include file and the nodes.exclude 
file, it is excluded. That is, excluding a node overrides including the same 
node.

– If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the nodes.include file. See the “Including 
Specific Nodes in Custom Reports” section on page 3-259 for more 
information on the special include file.
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• To include only specific linksets in reports, create the user-defined 
linksets.include file and list the linksets in the file. Only those linksets will be 
included in automatically generated SGM accounting statistics and network 
statistics reports, as well as in custom reports that were generated with the 
default keyword (or no node-list keyword at all) on the sgm accstats or 
sgm linkstats command.

Keep in mind the following considerations:

– If you installed SGM in the default directory, /opt, then the 
linksets.include file is located at 
/opt/CSCOsgm/reports/etc/linksets.include.

If you installed SGM in a different directory, or if you moved the report 
files directory using the sgm repdir command, then the 
/reports/etc/linksets.include file is located in that directory.

– Each line in the linksets.include file must contain a single linkset name 
that matches exactly the real, fully qualified linkset name of the linkset. 
For example:

sgm-75-59a.cisco.com:linkset2

sgm-26-51a.cisco.com:linkset1

– Wildcard matching is not supported.

– If a linkset appears in both the linksets.include file and the 
linksets.exclude file, it is excluded. That is, excluding a linkset overrides 
including the same linkset.

– If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the linksets.include file. See the “Including 
Specific Nodes in Custom Reports” section on page 3-259 for more 
information on the special include file.
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• To exclude specific nodes from reports, create the user-defined nodes.exclude 
file and list the nodes in the file. Those nodes will be excluded from 
automatically generated SGM accounting statistics and network statistics 
reports, as well as from custom reports that were generated with the default 
keyword (or no node-list keyword at all) on the sgm accstats or 
sgm linkstats command.

Keep in mind the following considerations:

– If you installed SGM in the default directory, /opt, then the nodes.exclude 
file is located at /opt/CSCOsgm/reports/etc/nodes.exclude.

If you installed SGM in a different directory, or if you moved the report 
files directory using the sgm repdir command, then the 
/reports/etc/nodes.exclude file is located in that directory.

– Each line in the nodes.exclude file must contain a single node name that 
matches exactly the real, fully qualified node name of the node, and each 
line must end with a colon (:). For example:

sgm-75-59a.cisco.com:

sgm-26-51a.cisco.com:

– Wildcard matching is not supported.

– If a node appears in both the nodes.include file and the nodes.exclude 
file, it is excluded. That is, excluding a node overrides including the same 
node.

– If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the nodes.exclude file. See the “Including 
Specific Nodes in Custom Reports” section on page 3-259 for more 
information on the special include file.
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• To exclude specific linksets from reports, create the user-defined 
linksets.exclude file and list the linksets in the file. Those linksets will be 
excluded from automatically generated SGM accounting statistics and 
network statistics reports, as well as from custom reports that were generated 
with the default keyword (or no node-list keyword at all) on the sgm accstats 
or sgm linkstats command.

Keep in mind the following considerations:

– If you installed SGM in the default directory, /opt, then the 
linksets.exclude file is located at 
/opt/CSCOsgm/reports/etc/linksets.exclude.

If you installed SGM in a different directory, or if you moved the report 
files directory using the sgm repdir command, then the 
/reports/etc/linksets.exclude file is located in that directory.

– Each line in the linksets.exclude file must contain a single linkset name 
that matches exactly the real, fully qualified linkset name of the linkset. 
For example:

sgm-75-59a.cisco.com:linkset2

sgm-26-51a.cisco.com:linkset1

– Wildcard matching is not supported.

– If a linkset appears in both the linksets.include file and the 
linksets.exclude file, it is excluded. That is, excluding a linkset overrides 
including the same linkset.

– If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the linksets.exclude file. See the “Including 
Specific Nodes in Custom Reports” section on page 3-259 for more 
information on the special include file.

• To use PAGER to display the contents of the system reports log, enter the 
sgm replog command. The reports log lists all messages related to the 
creation and maintenance of SGM reports.

To clear the log and restart the server, enter sgm replog clear.

To display the contents of the log in reverse order, with the most recent 
commands at the beginning of the log, enter sgm replog -r.

For more information about the reports log, see the “Viewing the SGM 
System Reports Log” section on page 3-279.
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• To remove all data from SGM network statistics reports, restoring the reports 
to a “clean” state, enter the sgm statreps clean command.

• To remove all data from one or more SGM custom statistics reports, restoring 
the reports to a “clean” state, enter the sgm statreps cleancustom command.

– To clean all custom reports, enter sgm statreps cleancustom.

– To clean a single custom report, enter sgm statreps cleancustom tag, 
where tag is the ID tag of the custom report you want to clean.

For more information about each of these commands, including valid ranges and 
default settings, see the “SGM Commands and Descriptions” section on page B-2.

Each of these commands requires you to be logged in as the root user, as described 
in the “Becoming the Root User (Solaris Only)” section on page 3-2, or as a super 
user, as described in the “Specifying a Super User (Solaris Only)” section on 
page 4-22.

Changing the SGM Reports Directory (Solaris Only)
You can change the directory in which SGM stores reports.

To change the SGM report files directory, log in as the root user, as described in 
the “Becoming the Root User (Solaris Only)” section on page 3-2, or as a super 
user, as described in the “Specifying a Super User (Solaris Only)” section on 
page 4-22, and enter the following commands:

# cd /opt/CSCOsgm/bin

# ./sgm repdir directory

where directory is the new directory.

Note This command copies all files in the current directory to the new directory. If you 
are logged in as the super user, and you do not own the new directory, you might 
not be able to copy the files. If that is the case, you must specify a directory that 
you own, or you must log in as the root user.
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Viewing SGM Network Statistics Reports
SGM enables you to view hourly and daily statistics summary reports for links 
and linksets. You can also export the reports.

SGM enables you to view the following network statistics reports for linksets:

• Viewing the Linkset Statistics Hourly Reports, page 3-228

• Viewing the Linkset Statistics Daily Summary Reports, page 3-231

SGM enables you to view the following network statistics reports for links:

• Viewing the Link Statistics Hourly Reports, page 3-234

• Viewing the Link Statistics Daily Summary Reports, page 3-238

• Viewing the Five Day Link Utilization Report, page 3-243

SGM enables you to view the following network statistics reports export files:

• Viewing the Hourly Network Statistics Export Files, page 3-246

• Viewing the Daily Network Statistics Export Files, page 3-247

• Viewing the Rolling Network Statistics Export Files, page 3-247

Viewing the Linkset Statistics Hourly Reports

SGM enables you to view hourly summaries of statistics for all linksets known to 
SGM on the specified date and hour.

To view hourly summaries of statistics, select Linkset Hourly from the menu bar 
of any SGM Network Statistics or Accounting Statistics Web page. SGM displays 
the Linkset Statistics - Hourly Reports page, which displays hourly linkset 
statistics summary reports, archived by date, and by hour:

• To view an archived report showing all hourly linkset statistics summary 
reports for an entire day, click a date. SGM displays the Linkset Statistics - 
Daily All Hours Report page for that date.

• To view an archived report showing all hourly linkset statistics summary 
reports for a specific date and hour, click an hour. SGM displays the Linkset 
Statistics - Hourly Report page for that date and hour.
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The Linkset Statistics - Daily All Hours Report and Linkset Statistics - Hourly 
Report pages both display the following information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• ID—Internal ID, assigned by SGM, of the selected hourly linkset statistics 
summary report.

To see the entire detailed report, click the ID. SGM displays the Linkset Data 
Record page for that linkset, date, and hour, in text format. The Linkset Data 
Record can be useful when the TAC is debugging problems.

• Hour—(Linkset Statistics - Daily All Hours Report page only) Hour for 
which the link statistics summary report was created, for the specified date.

• Node—Name of node for the linkset. To see statistics for only a selected 
node, click the node name.

• Linkset Name—Name of the linkset. To see statistics for only a selected 
linkset, click the linkset name.

• Hourly InSrv—Percentage of time the linkset was in service on the specified 
date and hour.

• Long Term InSrv—Average percentage of time the linkset was in service 
since SGM polling began for the linkset, or since SGM last reset the averages 
as a result of bad data.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.
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SGM enables you to modify the way information is presented in the Linkset 
Statistics - Daily All Hours Report and Linkset Statistics - Hourly Report pages:

• You can sort the pages based on the information in one of the columns. See 
the “Resizing, Sorting, and Hiding Table Columns” section on page 3-178 for 
more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.
3-230
Cisco Signaling Gateway Manager User Guide

78-15204-01



 

Chapter 3 Managing ITP Networks Using SGM
Working with SGM Statistics Reports
• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To reset the Top preferences for this Web page to the default settings for the 
SGM server, click the DefPrefs menu option.

Viewing the Linkset Statistics Daily Summary Reports

SGM enables you to view a daily summary of statistics for all linksets known to 
SGM on a specified date.

To view a daily summary of statistics, select Linkset Daily from the menu bar of 
any SGM Network Statistics or Accounting Statistics Web page. SGM displays 
the Linkset Statistics - Daily Summary Reports page, which displays daily linkset 
statistics summary reports, archived by date. Each archived file contains a daily 
summary of statistics for all linksets known to SGM on a specified date.

To view an archived linkset statistic summary report, click a date. SGM displays 
the Linkset Statistics - Daily Summary Report page for that date.
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The Linkset Statistics - Daily Summary Report table displays the following 
information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• Node—Name of node for the linkset. To see statistics for only a selected 
node, click the node name.

• Linkset Name—Name of the linkset. To see statistics for only a selected 
linkset, click the linkset name.

• Daily InSrv—Average percentage of time the linkset was in service on the 
specified date.

• Long Term InSrv—Average percentage of time the linkset was in service 
since SGM polling began for the linkset, or since SGM last reset the averages 
as a result of bad data.

• Daily Low InSrv—Lowest hourly in-service percentage for the linkset, for 
the specified date.

• Low Srv Hour—Hour in which the lowest in-service percentage occurred, 
for the specified date.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.

SGM enables you to modify the way information is presented in the Linkset 
Statistics - Daily Summary Report page:

• You can sort the Linkset Statistics - Daily Summary Report page based on the 
information in one of the columns. See the “Resizing, Sorting, and Hiding 
Table Columns” section on page 3-178 for more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To reset the Top preferences for this Web page to the default settings for the 
SGM server, click the DefPrefs menu option.

Viewing the Link Statistics Hourly Reports

SGM enables you to view hourly link statistics summary reports for an entire day, 
or for a specific date and hour.

To view hourly link statistics summary reports, select Link Hourly from the 
menu bar of any SGM Network Statistics or Accounting Statistics Web page. 
SGM displays the Link Statistics - Hourly Reports page, which displays hourly 
link statistics summary reports, archived by date, and by hour:

• To view an archived report showing all hourly link statistics summary reports 
for an entire day, click a date. SGM displays the Link Statistics - Daily All 
Hours Report page for that date.

• To view an archived report showing all hourly link statistics summary reports 
for a specific date and hour, click an hour. SGM displays the Link Statistics - 
Hourly Report page for that date and hour.

The Link Statistics - Daily All Hours Report and Link Statistics - Hourly Report 
pages both display the following information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• ID—Internal ID, assigned by SGM, of the selected hourly link statistics 
summary report.

To see the entire detailed report, click the ID. SGM displays the Link Data 
Record page for that link, date, and hour, in text format. The Link Data 
Record can be useful when the TAC is debugging problems.
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• Hour—(Link Statistics - Daily All Hours Report page only) Hour for which 
the link statistics summary report was created, for the specified date.

• Node—Name of node for the link. To see statistics for only a selected node, 
click the node name.

• Link Name—Name of the link. To see statistics for only a selected link, click 
the link name.

• Type—Type of link. Possible link types are:

– HSL—The link uses the SS7-over-ATM (Asynchronous Transfer Mode) 
high-speed protocol.

– SCTP—The link uses the Stream Control Transmission Protocol (SCTP) 
IP transport protocol.

– Serial—The link uses the serial SS7 signaling protocol.

• Send Util or Send Erls—Average Send Utilization for the link, expressed as 
either a utilization percentage or a number of Erlangs, for the specified date 
and hour.

If the planned send capacity is not set for the link, this field displays NoCap.

• L Term Send Util or L Term Send Erls—For the specified date and hour, 
average Send Utilization for the link, expressed as either a utilization 
percentage or a number of Erlangs, since SGM polling began for the link, or 
since SGM last reset the averages as a result of bad data.

If the planned send capacity is not set for the link, this field displays NoCap.

• Recv Util or Recv Erls—Average Receive Utilization for the link, expressed 
as either a utilization percentage or a number of Erlangs, for the specified date 
and hour.

If the planned receive capacity is not set for the link, this field displays 
NoCap.

• L Term Recv Util or L Term Recv Erls—For the specified date and hour, 
average Receive Utilization for the link, expressed as either a utilization 
percentage or a number of Erlangs, since SGM polling began for the link, or 
since SGM last reset the averages as a result of bad data.

If the planned receive capacity is not set for the link, this field displays 
NoCap.

• Send MSUs—Total number of MTP3 MSUs sent on the specified date and 
hour.
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• Recv MSUs—Total number of MTP3 MSUs received on the specified date 
and hour.

• Drop—Total number of drops on the specified date and hour.

• Hourly InSrv—Percentage of time the link was in service on the specified 
date and hour.

• Long Term InSrv—Average percentage of time the link was in service since 
SGM polling began for the link, or since SGM last reset the averages as a 
result of bad data.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.

SGM enables you to modify the way information is presented in the Link 
Statistics - Daily All Hours Report and Link Statistics - Hourly Report pages:

• You can sort the pages based on the information in one of the columns. See 
the “Resizing, Sorting, and Hiding Table Columns” section on page 3-178 for 
more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To display only records for links that are not of type SCTP, click the NoSCTP 
menu option.

To display all records, including those for links that are of type SCTP, click 
the YesSCTP menu option. This is the default setting.
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• To display all records, including those for links that do not have planned send 
and receive capacities, click the YesNullCaps menu option.

To display only records for links that have planned send and receive 
capacities, click the NoNullCaps menu option. This is the default setting.

• To reset the Top, SCTP, and NullCaps preferences for this Web page to the 
default settings for the SGM server, click the DefPrefs menu option.

Viewing the Link Statistics Daily Summary Reports

SGM enables you to view a daily summary of statistics for all links known to 
SGM on a specified date.

To view a daily summary of statistics, use one of the following procedures:

• Select Web Links >Reports>Network Statistics from the SGM Main 
Menu.

• Select Network Statistics Reports from the SGM Server Home Page.

• Select Link Daily from the menu bar of any SGM Network Statistics or 
Accounting Statistics Web page.

SGM displays the Link Statistics - Daily Summary Reports page, which displays 
daily link statistics summary reports are archived by date. Each archived file 
contains a daily summary of statistics for all links known to SGM on a specified 
date.

To view an archived link statistic summary report, click a date. SGM displays the 
Link Statistics - Daily Summary Report page for that date (Figure 3-1).
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Figure 3-80 Link Statistics - Daily Summary Report Page

The Link Statistics - Daily Summary Report page displays the following 
information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• Node—Name of node for the link. To see statistics for only a selected node, 
click the node name.

• Link Name—Name of the link. To see statistics for only a selected link, click 
the link name.
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• Type—Type of link. Possible link types are:

HSL—The link uses the SS7-over-ATM (Asynchronous Transfer Mode) 
high-speed protocol.

SCTP—The link uses the Stream Control Transmission Protocol (SCTP) IP 
transport protocol.

Serial—The link uses the serial SS7 signaling protocol.

• Avg Send Util or Avg Send Erls—Average Send Utilization for the link, 
expressed as either a utilization percentage or a number of Erlangs, for the 
specified date.

If the planned send capacity is not set for the link, this field displays NoCap.

• Peak Send Util or Peak Send Erls—Highest hourly Average Send 
Utilization for the link, expressed as either a utilization percentage or a 
number of Erlangs, for the specified date.

• Peak Send Hour—Hour in which the Peak Send Utilization for the link 
occurred, for the specified date.

• L Term Send Util or L Term Send Erls—For the specified date, average 
Send Utilization for the link, expressed as either a utilization percentage or a 
number of Erlangs, since SGM polling began for the link, or since SGM last 
reset the averages as a result of bad data.

If the planned send capacity is not set for the link, this field displays NoCap.

• Avg Recv Util or Avg Recv Erls—Average Receive Utilization for the link, 
expressed as either a utilization percentage or a number of Erlangs, for the 
specified date.

If the planned receive capacity is not set for the link, this field displays 
NoCap.

• Peak Recv Util or Peak Recv Erls—Highest hourly Average Receive 
Utilization for the link, expressed as either a utilization percentage or a 
number of Erlangs, for the specified date.

• Peak Recv Hour—Hour in which the Peak Receive Utilization for the link 
occurred, for the specified date.
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• L Term Recv Util or L Term Recv Erls—For the specified date, average 
Receive Utilization for the link, expressed as either a utilization percentage 
or a number of Erlangs, since SGM polling began for the link, or since SGM 
last reset the averages as a result of bad data.

If the planned receive capacity is not set for the link, this field displays 
NoCap.

• Send MSUs—Total number of MTP3 MSUs sent on the specified date.

• Recv MSUs—Total number of MTP3 MSUs received on the specified date.

• Drop—Total number of drops on the specified date.

• Daily InSrv—Average percentage of time the link was in service on the 
specified date.

• Long Term InSrv—Average percentage of time the link was in service since 
SGM polling began for the link, or since SGM last reset the averages as a 
result of bad data.

• Daily Low InSrv—Lowest hourly in-service percentage for the link, for the 
specified date.

• Low Srv Hour—Hour in which the lowest in-service percentage occurred, 
for the specified date.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.

SGM enables you to modify the way information is presented in the Link 
Statistics - Daily Summary Report page:

• You can sort the Link Statistics - Daily Summary Report page based on the 
information in one of the columns. See the “Resizing, Sorting, and Hiding 
Table Columns” section on page 3-178 for more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To display only records for links that are not of type SCTP, click the NoSCTP 
menu option.

To display all records, including those for links that are of type SCTP, click 
the YesSCTP menu option. This is the default setting.

• To display all records, including those for links that do not have planned send 
and receive capacities, click the YesNullCaps menu option.

To display only records for links that have planned send and receive 
capacities, click the NoNullCaps menu option. This is the default setting.

• To reset the Top, SCTP, and NullCaps preferences for this Web page to the 
default settings for the SGM server, click the DefPrefs menu option.

Viewing the Five Day Link Utilization Report

The Five Day Link Utilization Report page displays send and receive utilization 
percentages for all links for the last five (5) days.

To access the Five Day Link Utilization Report page, select Five Day Link Util 
from the menu bar of any SGM Network Statistics or Accounting Statistics Web 
page. SGM displays the five day utilization report for the specified link.

The Five Day Link Utilization Report page displays the following information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• Node—Name of node for the link. To see statistics for only a selected node, 
click the node name.

• Link Name—Name of the link. To see statistics for only a selected link, click 
the link name.
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• Send Util or Send Erls—Send Utilization for the link, expressed as either a 
utilization percentage or a number of Erlangs, for each of the last five days. 
If the planned send capacity is not set for the link, this field displays NoCap.

• Recv Util or Recv Erls—Receive Utilization for the link, expressed as either 
a utilization percentage or a number of Erlangs, for each of the last five days. 
If the planned receive capacity is not set for the link, this field displays 
NoCap.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.

SGM enables you to modify the way information is presented in the Five Day 
Link Utilization Report page:

• You can sort the Five Day Link Utilization Report page based on the 
information in one of the columns. See the “Resizing, Sorting, and Hiding 
Table Columns” section on page 3-178 for more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To display only records for links that are not of type SCTP, click the NoSCTP 
menu option.

To display all records, including those for links that are of type SCTP, click 
the YesSCTP menu option. This is the default setting.
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• To display all records, including those for links that do not have planned send 
and receive capacities, click the YesNullCaps menu option.

To display only records for links that have planned send and receive 
capacities, click the NoNullCaps menu option. This is the default setting.

• To reset the Top, SCTP, and NullCaps preferences for this Web page to the 
default settings for the SGM server, click the DefPrefs menu option.

Viewing the Hourly Network Statistics Export Files

The Hourly Network Statistics Export Files page displays all archived SGM 
hourly network statistics summary reports, for all links and linksets known to 
SGM, for the server to which you are connected, stored as downloadable Zip files.

To access the Hourly Network Statistics Export Files page, select Hourly Export 
from the menu bar of any SGM Network Statistics or Accounting Statistics Web 
page.

On the Hourly Network Statistics Export Files page, the Zip files are archived by 
type (linkset or link), date, and hour. For example, 
sgmLinksetStats.2002-10-15-08.zip is the Zip file that contains the hourly 
linkset statistics summary report for the 8th hour on October 15, 2002.

Each archived Zip file contains a comma-separated value (CSV) text file with an 
hourly network statistics summary report for all links or linksets that were known 
to SGM on that date and hour. You can download the Zip files and unzip them.

To download a Zip file, click a filename, then save the file to a location of your 
choice.

See the “SGM Link Statistics Hourly Export File Format” section on page F-4 for 
detailed information about the format of hourly link statistics export files.

See the “SGM Linkset Statistics Hourly Export File Format” section on page F-6 
for detailed information about the format of hourly link and linkset statistics 
export files.
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Viewing the Daily Network Statistics Export Files

The Daily Network Statistics Export Files page displays all archived SGM daily 
network statistics summary reports, for all links and linksets known to SGM, for 
the server to which you are connected, stored as downloadable Zip files.

To access the Daily Network Statistics Export Files page, select Daily Export 
from the menu bar of any SGM Network Statistics or Accounting Statistics Web 
page.

On the Daily Network Statistics Export Files page, the Zip files are archived by 
type (linkset or link) and date. For example, 
sgmLinksetStats.DailySum.2002-10-15.zip is the Zip file that contains the daily 
linkset statistics summary report for October 15, 2002.

Each archived Zip file contains a comma-separated value (CSV) text file with a 
daily network statistics summary report for all links or linksets that were known 
to SGM on that date and hour. You can download the Zip files and unzip them.

To download a Zip file, click a filename, then save the file to a location of your 
choice.

See the “SGM Link Statistics Daily Export File Format” section on page F-3 for 
detailed information about the format of daily link statistics export files.

See the “SGM Linkset Statistics Daily Export File Format” section on page F-5 
for detailed information about the format of daily link and linkset statistics export 
files.

Viewing the Rolling Network Statistics Export Files

The Rolling Network Statistics Export Files page displays concatenated SGM 
hourly and daily network statistics summary reports, for all links and linksets 
known to SGM, for the server to which you are connected, stored as downloadable 
Zip files.

To access the Rolling Network Statistics Export Files page, select Rolling Export 
from the menu bar of any SGM Network Statistics or Accounting Statistics Web 
page.
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On the Rolling Network Statistics Export Files page, the Zip files are archived by 
type (linkset or link) and number of days (7 or 30). For example:

• sgmLinksetStats.RollingSevenDayAllHours.zip is the Zip file that 
contains the hourly linkset statistics summary reports for the last seven (7) 
days, concatenated into one comma-separated value (CSV) text file.

• sgmLinksetStats.Rolling30DayAllDays.zip is the Zip file that contains the 
daily linkset statistics summary reports for the last 30 days, concatenated into 
one comma-separated value (CSV) text file.

• sgmLinkStats.RollingSevenDayAllHours.zip is the Zip file that contains 
the hourly link statistics summary reports for the last seven (7) days, 
concatenated into one comma-separated value (CSV) text file.

• sgmLinkStats.Rolling30DayAllDays.zip is the Zip file that contains the 
daily link statistics summary reports for the last 30 days, concatenated into 
one comma-separated value (CSV) text file.

SGM creates a new set of files every hour.

You can download the Zip files and unzip them.

To download a Zip file, click a filename, then save the file to a location of your 
choice.

See the “SGM Rolling Network Statistics Export File Formats” section on 
page F-7 for detailed information about the format of rolling statistics export files.

Viewing SGM Accounting Statistics Reports
SGM enables you to view accounting statistics reports. You can also export the 
reports.

SGM enables you to view the following accounting statistics reports:

• Viewing the Accounting Statistics Daily Detail Reports, page 3-249

• Viewing the Daily Accounting Statistics Export Files, page 3-253
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Viewing the Accounting Statistics Daily Detail Reports

SGM enables you to view a daily summary of accounting statistics for SGM on a 
specified date. Accounting statistics are displayed based on the node, linkset, 
originating point code (OPC), the destination point code (DPC), the type of SS7 
traffic (such as ISUP or SCCP), and whether the traffic passed or failed the 
Gateway Screening test at the ITP.

To view a daily summary of accounting statistics, use one of the following 
procedures:

• Select Web Links >Reports>Accounting Statistics from the SGM Main 
Menu.

• Select Accounting Statistics Reports from the SGM Server Home Page.

• Select Accounting Daily from the menu bar of any SGM Network Statistics 
or Accounting Statistics Web page.

SGM displays the Accounting Statistics - Daily Detail Reports page, which 
displays daily accounting statistics reports, archived by date. Each archived file 
contains a daily summary of accounting statistics for SGM on a specified date.

To view an archived accounting statistic report, click a date. SGM displays the 
Accounting Statistics - Daily Detail Report page for that date.

To view an archived link statistic summary report, click a date. SGM displays the 
Link Statistics - Daily Summary Report page for that date (Figure 3-1).
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Figure 3-81 Accounting Statistics - Daily Detail Report Page

The Accounting Statistics - Daily Detail Report page displays the following 
information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• ID—Internal ID, assigned by SGM, of the selected hourly accounting 
statistics report.

To see the entire detailed report, click the ID. SGM displays the Accounting 
Data Record for that date and hour. The Accounting Data Record can be 
useful when the TAC is debugging problems.

• Node—Name of node for the linkset. To see statistics for only a selected 
node, click the node name.

• Linkset Name—Name of the linkset. To see statistics for only a selected 
linkset, click the linkset name.
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• Gateway Screening—Indicates whether the traffic passed or failed the 
Gateway Screening test at the ITP. To see only statistics that passed or failed 
for a specific linkset, select a linkset and click Pass or Fail.

• OPC—Originating point code of the traffic, which is a unique identifier for 
each set of statistics. To see only statistics that match a specific OPC for a 
given linkset, find the linkset and click the point code.

• DPC—Destination point code of the traffic. To see only statistics that match 
a specific DPC for a given linkset, find the linkset and click the point code.

• SI—Service indicator, which indicates the type of SS7 traffic, such as ISUP 
or SCCP. To see only detailed information for a specific type of SI, click the 
SI type.

• Send MSUs—Total number of MTP3 MSUs sent on the specified date.

• Recv MSUs—Total number of MTP3 MSUs received on the specified date.

• Send Bytes—Total number of bytes sent on the specified date.

• Recv Bytes—Total number of bytes received on the specified date.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.

SGM enables you to modify the way information is presented in the Accounting 
Statistics - Daily Detail Report page:

• You can sort the Accounting Statistics - Daily Detail Report page based on 
the information in one of the columns. See the “Resizing, Sorting, and Hiding 
Table Columns” section on page 3-178 for more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To reset the Top preferences for this Web page to the default settings for the 
SGM server, click the DefPrefs menu option.

Viewing the Daily Accounting Statistics Export Files

The Daily Accounting Statistics Export Files page displays all archived SGM 
daily accounting statistics reports for the server to which you are connected, 
stored as downloadable Zip files.

To access the Daily Accounting Statistics Export Files page, select Accounting 
Export from the menu bar of any SGM Network Statistics or Accounting 
Statistics Web page.

On the Daily Accounting Statistics Export Files page, the Zip files are archived 
by date. For example, sgmAccStats.DailyDetail.2002-10-15.zip is the Zip file 
that contains the daily accounting statistics report for October 15, 2002.

Each archived Zip file contains a comma-separated value (CSV) text file with a 
daily accounting statistics report for that date. You can download the Zip files and 
unzip them.

To download a Zip file, click a filename, then save the file to a location of your 
choice.

See the “SGM Daily and Hourly Accounting Statistics Export File Format” 
section on page F-2 for detailed information about the format of accounting 
statistics export files.
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Generating and Viewing Custom SGM Statistics Reports
SGM enables you to create custom link and linkset statistics summary reports, and 
custom accounting reports. You can also export the reports.

This section contains the following information:

• Generating a Custom Network Statistics Report, page 3-254

• Generating a Custom Accounting Statistics Report, page 3-257

• Including Specific Nodes in Custom Reports, page 3-259

• Including Specific Linksets in Custom Reports, page 3-261

• Excluding Specific Nodes from Custom Reports, page 3-262

• Excluding Specific Linksets from Custom Reports, page 3-263

• Viewing the Custom Network Statistics Export Files, page 3-264

• Viewing a Custom Accounting Statistics Report, page 3-265

• Viewing a Custom Link Statistics Summary Report, page 3-268

• Viewing a Custom Linkset Statistics Summary Report, page 3-272

Generating a Custom Network Statistics Report

To create a custom link and linkset statistics summary report for SGM, use the 
following procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Solaris 
Only)” section on page 3-2, or as a super user, as described in the “Specifying a 
Super User (Solaris Only)” section on page 4-22.

Step 2 Enter the following commands:

# cd /opt/CSCOsgm/bin

# ./sgm linkstats [node-list [id-tag]] [sort-option] [quiet]
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• (Optional) To include or exclude specific nodes or linksets in the report, use 
the node-list argument. See the following sections for more information:

– Including Specific Nodes in Custom Reports, page 3-259

– Including Specific Linksets in Custom Reports, page 3-261

– Excluding Specific Nodes from Custom Reports, page 3-262

– Excluding Specific Linksets from Custom Reports, page 3-263

• (Optional) If you specify a node-list, you can also specify an id-tag to identify 
the report. The id-tag can be any meaningful character string, but it cannot 
contain any spaces. The default value for id-tag is the process ID of the 
sgm linkstats command.

• (Optional) To specify a sort order for the report, specify one of the following 
keywords for the sort-option argument:

– -sis—Sort based on average in-service percentage for each link (Daily 
InSrv), in descending order.

– -sls—Sort based on the linkset name, in ascending order.

– -sos—Sort based on the average out-of-service percentage for each link, 
in descending order.

– -sru—Sort based on the average Receive Utilization for each link (Avg 
Receive Util or Avg Receive Erls), in descending order.

– -ssu—Sort based on the average Send Utilization for each link (Avg Send 
Util or Avg Send Erls), in descending order. This is the default setting.

• (Optional) To disable automatic output to the terminal when running this 
command in a script, specify the quiet keyword. SGM generates the report in 
export format, which you can view using the SGM Web interface.

For example, to generate a custom link and linkset statistics summary report, that 
includes only links and linksets associated with node sgm-2600a.cisco.com, 
sorted in ascending order based on the linkset name, and identified by ID tag 
test1, enter the following command:

# ./sgm linkstats sgm-2600a.cisco.com test1 -sls
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Step 3 (Optional) If this is the first time you are using the sgm linkstats command to 
generate a report, you must enter the command two more times:

• The first entry gets the first set of raw data.

• The second entry calculates begins calculating useful link and linkset 
statistics.

• The third entry continues to calculate statistics, calculates long-term 
averages, and, if the data being collected appears valid, begins generating the 
report.

Thereafter, you need only enter this command once to generate the report.

Step 4 SGM generates the custom link and linkset statistics summary report and stores it 
in the /custom directory, identified by its ID tag.

For example, if you entered the command:

# ./sgm linkstats sgm-2600a.cisco.com test1 -sls

SGM generates the following reports:

sgmLinkStats.custom.test1.2002-10-27.zip

sgmLinksetStats.custom.test1.2002-10-27.zip

If you installed SGM in the default directory, /opt, then the /custom directory is 
located at /opt/CSCOsgm/reports/custom.

If you installed SGM in a different directory, or if you moved the report files 
directory using the sgm repdir command, then the /custom directory is located in 
that directory.

Step 5 For information on viewing the report, see the “Viewing the Custom Network 
Statistics Export Files” section on page 3-264.
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Generating a Custom Accounting Statistics Report

To create a custom accounting statistics report for SGM, use the following 
procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Solaris 
Only)” section on page 3-2, or as a super user, as described in the “Specifying a 
Super User (Solaris Only)” section on page 4-22.

Step 2 Enter the following commands:

# cd /opt/CSCOsgm/bin

# ./sgm accstats [node-list [id-tag]] [sort-option] [quiet]

• (Optional) To include or exclude specific nodes or linksets in the report, use 
the node-list argument. See the following sections for more information:

– Including Specific Nodes in Custom Reports, page 3-259

– Including Specific Linksets in Custom Reports, page 3-261

– Excluding Specific Nodes from Custom Reports, page 3-262

– Excluding Specific Linksets from Custom Reports, page 3-263

• (Optional) If you specify a node-list, you can also specify an id-tag to identify 
the report. The id-tag can be any meaningful character string, but it cannot 
contain any spaces. The default value for id-tag is the process ID of the 
sgm accstats command.

• (Optional) To specify a sort order for the report, specify one of the following 
keywords for the sort-option argument:

– -sdp—Sort based on the destination point code (DPC) of the node, in 
descending order.

– -sno—Sort based on the node name, in ascending order.

– -sop—Sort based on the originating point code (OPC) of the node, in 
descending order.

– -srb—Sort based on number of bytes received, in descending order.

– -srm—Sort based on number of MTP3 MSUs received, in descending 
order.

– -ssb—Sort based on number of bytes sent, in descending order.
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– -ssi—Sort numerically based on service indicator (SI), in ascending 
order.

– -ssm—Sort based on number of MTP3 MSUs sent, in descending order.

• (Optional) To disable automatic output to the terminal when running this 
command in a script, specify the quiet keyword. SGM generates the report in 
export format, which you can view using the SGM Web interface.

For example, to generate a custom accounting statistics report, that includes only 
information for node sgm-2600a.cisco.com, sorted in ascending order based on 
the node name, and identified by ID tag test1, enter the following command:

# ./sgm accstats sgm-2600a.cisco.com test1 -sno

Step 3 (Optional) If this is the first time you are using the sgm accstats command to 
generate a report, you must enter the command two more times:

• The first entry gets the first set of raw data.

• The second entry calculates begins calculating useful accounting statistics.

• The third entry continues to calculate statistics, calculates long-term 
averages, and, if the data being collected appears valid, begins generating the 
report.

Thereafter, you need only enter this command once to generate the report.

Step 4 SGM generates the custom accounting statistics report and stores it in the /custom 
directory, identified by its ID tag.

For example, if you entered the command:

# ./sgm accstats sgm-2600a.cisco.com test1 -sno

SGM generates the following reports:

sgmAccStats.custom.test1.2002-10-27.zip

sgmAccStats.custom.test1.2002-10-27.zip
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If you installed SGM in the default directory, /opt, then the /custom directory is 
located at /opt/CSCOsgm/reports/custom.

If you installed SGM in a different directory, or if you moved the report files 
directory using the sgm repdir command, then the /custom directory is located in 
that directory.

Step 5 For information on viewing the report, see the “Viewing the Custom Network 
Statistics Export Files” section on page 3-264.

Including Specific Nodes in Custom Reports

When you generate a custom accounting statistics or network statistics report, 
SGM enables you to limit the report to one or more specific nodes.

• To generate a report that includes all nodes known to SGM, specify all in 
place of the node-list argument in the sgm accstats or sgm linkstats 
command. For example, the following command generates an accounting 
statistics report for all nodes:

./sgm accstats all

• To generate a report for a single node, specify the node name in place of the 
node-list argument in the sgm accstats or sgm linkstats command. The node 
name must match exactly the node name as discovered by SGM, including the 
domain name. For example, the following command generates an accounting 
statistics report for node sgm-2600a.cisco.com:

./sgm accstats sgm-2600a.cisco.com

• To generate a report that includes only the nodes listed in the user-defined 
nodes.include file, create the file, then specify default in place of the 
node-list argument in the sgm accstats or sgm linkstats command. This is 
also the default setting for this command, if you do not specify a node-list 
keyword.

For example, the following command generates an accounting statistics 
report that includes only the nodes specified in the nodes.include file:

./sgm accstats default
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Keep in mind the following considerations:

– If you installed SGM in the default directory, /opt, then the nodes.include 
file is located at /opt/CSCOsgm/reports/etc/nodes.include.

If you installed SGM in a different directory, or if you moved the report 
files directory using the sgm repdir command, then the 
/reports/etc/nodes.include file is located in that directory.

– Each line in the nodes.include file must contain a single node name that 
matches exactly the real, fully qualified node name of the node, and each 
line must end with a colon (:). For example:

sgm-75-59a.cisco.com:

sgm-26-51a.cisco.com:

– Wildcard matching is not supported.

– If a node appears in both the nodes.include file and the nodes.exclude 
file, it is excluded. That is, excluding a node overrides including the same 
node.

– If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the nodes.include file.

• To generate a report that includes only a group of nodes other than the nodes 
listed in the nodes.include file, create a file that contains the list of nodes to 
included and specify the full path and name of the file in place of the node-list 
argument in the sgm accstats or sgm linkstats command.

For example, the following command generates an accounting statistics 
report that includes only the nodes specified in the 
/opt/CSCOsgm/reports/etc/specialnodes.include file:

./sgm accstats /opt/CSCOsgm/reports/etc/specialnodes.include
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Keep in mind the following considerations:

– Each line in the special include file must contain a single node name that 
matches exactly the real, fully qualified node name of the node, and each 
line must end with a colon (:). For example:

sgm-75-59a.cisco.com:

sgm-26-51a.cisco.com:

– Wildcard matching is not supported.

– If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the nodes.include, linksets.include, 
nodes.exclude, and linksets.exclude files, if they exist.

Including Specific Linksets in Custom Reports

When you generate a custom accounting statistics or network statistics report, 
SGM enables you to limit the report to one or more specific linksets.

To generate a report that includes only the linksets listed in the user-defined 
linksets.include file, create the file, then specify default in place of the node-list 
argument in the sgm accstats or sgm linkstats command.

For example, the following command generates an accounting statistics report 
that includes only the linksets specified in the linksets.include file:

./sgm accstats default
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Keep in mind the following considerations:

• If you installed SGM in the default directory, /opt, then the linksets.include 
file is located at /opt/CSCOsgm/reports/etc/linksets.include.

If you installed SGM in a different directory, or if you moved the report files 
directory using the sgm repdir command, then the 
/reports/etc/linksets.include file is located in that directory.

• Each line in the linksets.include file must contain a single linkset name that 
matches exactly the real, fully qualified linkset name of the linkset. For 
example:

sgm-75-59a.cisco.com:linkset2

sgm-26-51a.cisco.com:linkset1

• Wildcard matching is not supported.

• If a linkset appears in both the linksets.include file and the linksets.exclude 
file, it is excluded. That is, excluding a linkset overrides including the same 
linkset.

• If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the linksets.include file.

Excluding Specific Nodes from Custom Reports

When you generate a custom accounting statistics or network statistics report, 
SGM enables you to exclude one or more specific nodes from the report.

To generate a report that excludes the nodes listed in the user-defined 
nodes.exclude file, create the file, then specify default in place of the node-list 
argument in the sgm accstats or sgm linkstats command.

For example, the following command generates an accounting statistics report 
that excludes the nodes specified in the nodes.exclude file:

./sgm accstats default
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Keep in mind the following considerations:

• If you installed SGM in the default directory, /opt, then thenodes.exclude file 
is located at /opt/CSCOsgm/reports/etc/nodes.exclude.

If you installed SGM in a different directory, or if you moved the report files 
directory using the sgm repdir command, then the/reports/etc/nodes.exclude 
file is located in that directory.

• Each line in the nodes.exclude file must contain a single node name that 
matches exactly the real, fully qualified node name of the node, and each line 
must end with a colon (:). For example:

sgm-75-59a.cisco.com:

sgm-26-51a.cisco.com:

• Wildcard matching is not supported.

• If a node appears in both the nodes.include file and the nodes.exclude file, it 
is excluded. That is, excluding a node overrides including the same node.

• If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the nodes.exclude file.

Excluding Specific Linksets from Custom Reports

When you generate a custom accounting statistics or network statistics report, 
SGM enables you to exclude one or more specific linksets from the report.

To generate a report that excludes the linksets listed in the user-defined 
linksets.exclude file, create the file, then specify default in place of the node-list 
argument in the sgm accstats or sgm linkstats command.

For example, the following command generates an accounting statistics report 
that excludes the linksets specified in the linksets.exclude file:

./sgm accstats default
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Keep in mind the following considerations:

• If you installed SGM in the default directory, /opt, then the linksets.exclude 
file is located at /opt/CSCOsgm/reports/etc/linksets.exclude.

If you installed SGM in a different directory, or if you moved the report files 
directory using the sgm repdir command, then the 
/reports/etc/linksets.exclude file is located in that directory.

• Each line in the linksets.exclude file must contain a single linkset name that 
matches exactly the real, fully qualified linkset name of the linkset. For 
example:

sgm-75-59a.cisco.com:linkset2

sgm-26-51a.cisco.com:linkset1

• Wildcard matching is not supported.

• If a linkset appears in both the linksets.include file and the linksets.exclude 
file, it is excluded. That is, excluding a linkset overrides including the same 
linkset.

• If you specify a special include file on the sgm accstats or sgm linkstats 
command, SGM ignores the linksets.exclude file.

Viewing the Custom Network Statistics Export Files

The Custom Network Statistics Export Files page displays all archived SGM 
custom network and accounting statistics reports for the server to which you are 
connected, stored as downloadable Zip files. Custom statistics reports are those 
that are generated using the sgm accstats and sgm linkstats commands.

To access the Custom Network Statistics Export Files page, select Custom 
Export from the menu bar of any SGM Network Statistics or Accounting 
Statistics Web page.
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The Custom Network Statistics Export Files page displays the following 
information:

• Export File—Name of the custom statistics export ZIP file, archived by type 
(linkset or link), date, and hour. For example, 
sgmLinksetStats.custom.20867.2002-10-15-16.zip is the Zip file that 
contains the custom linkset statistics summary report with ID tag 20867 for 
the 16th hour on October 15, 2002.

Each archived Zip file contains a comma-separated value (CSV) text file with 
a daily statistics report for that date. You can download the Zip files and unzip 
them.

To download a Zip file, click a filename, then save the file to a location of 
your choice.

See the “SGM Custom Network Statistics Export File Formats” section on 
page F-2 for detailed information about the format of custom statistics export 
files.

• ID Tag—Identifier for the custom report, specified when you entered the 
sgm accstats or sgm linkstats command. If you did not specify an ID tag, 
this field displays the process ID of the command that generated the report.

• Start—Date and time the custom report began.

• Finish—Date and time the custom report ended.

• View—Enables you to view the custom report in HTML or ASCII.

For more information about viewing custom reports, see the following 
sections:

– Viewing a Custom Accounting Statistics Report, page 3-265

– Viewing a Custom Link Statistics Summary Report, page 3-268

– Viewing a Custom Linkset Statistics Summary Report, page 3-272

Viewing a Custom Accounting Statistics Report

The Accounting Statistics - Custom Detail Report page displays a custom 
summary of accounting statistics for SGM. Accounting statistics are displayed 
based on the node, linkset, originating point code (OPC), the destination point 
code (DPC), the type of SS7 traffic (such as ISUP or SCCP), and whether the 
traffic passed or failed the Gateway Screening test at the ITP.
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To access the Accounting Statistics - Custom Detail Report page, click HTML in 
the View column beside a custom accounting statistics report on the Custom 
Network Statistics Export Files page. SGM displays the custom accounting 
statistics report.

The Accounting Statistics - Custom Detail Report page displays the following 
information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• ID—Internal ID, assigned by SGM, of the selected hourly accounting 
statistics report.

To see the entire detailed report, click the ID. SGM displays the Accounting 
Data Record for that date and hour, in text format. The Accounting Data 
Record can be useful when the TAC is debugging problems.

• Node—Name of node for the linkset. To see statistics for only a selected 
node, click the node name.

• Linkset Name—Name of the linkset. To see statistics for only a selected 
linkset, click the linkset name.

• Gateway Screening—Indicates whether the traffic passed or failed the 
Gateway Screening test at the ITP. To see only statistics that passed or failed 
for a specific linkset, select a linkset and click Pass or Fail.

• OPC—Originating point code of the traffic, which is a unique identifier for 
each set of statistics. To see only statistics that match a specific OPC for a 
given linkset, find the linkset and click the point code.

• DPC—Destination point code of the traffic. To see only statistics that match 
a specific DPC for a given linkset, find the linkset and click the point code.

• SI—Service indicator, which indicates the type of SS7 traffic, such as ISUP 
or SCCP. To see only detailed information for a specific type of SI, click the 
SI type.

• Send MSUs—Total number of MTP3 MSUs sent on the specified date.

• Recv MSUs—Total number of MTP3 MSUs received on the specified date.

• Send Bytes—Total number of bytes sent on the specified date.

• Recv Bytes—Total number of bytes received on the specified date.
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If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.

SGM enables you to modify the way information is presented in the Accounting 
Statistics - Custom Detail Report page:

• You can sort the Accounting Statistics - Custom Detail Report page based on 
the information in one of the columns. See the “Resizing, Sorting, and Hiding 
Table Columns” section on page 3-178 for more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To reset the Top preferences for this Web page to the default settings for the 
SGM server, click the DefPrefs menu option.

Viewing a Custom Link Statistics Summary Report

SGM enables you to view custom link statistics summary reports.

To view a custom link statistics summary report, click HTML in the View column 
beside a custom link statistics summary report on the Custom Network Statistics 
Export Files page. SGM displays the custom link statistics summary report, which 
is a custom summary of statistics for all links known to SGM when the report was 
generated.
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The Link Statistics - Custom Detail Report page displays the following 
information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• ID—Internal ID, assigned by SGM, of the selected hourly link statistics 
summary report.

To see the entire detailed report, click the ID. SGM displays the Link Data 
Record page for that link, date, and hour, in text format. The Link Data 
Record can be useful when the TAC is debugging problems.

• Hour—Hour for which the link statistics summary report was created, for the 
specified date.

• Node—Name of node for the link. To see statistics for only a selected node, 
click the node name.

• Link Name—Name of the link. To see statistics for only a selected link, click 
the link name.

• Type—Type of link. Possible link types are:

– HSL—The link uses the SS7-over-ATM (Asynchronous Transfer Mode) 
high-speed protocol.

– SCTP—The link uses the Stream Control Transmission Protocol (SCTP) 
IP transport protocol.

– Serial—The link uses the serial SS7 signaling protocol.

• Send Util or Send Erls—Average Send Utilization for the link, expressed as 
either a utilization percentage or a number of Erlangs, for the specified date 
and hour.

If the planned send capacity is not set for the link, this field displays NoCap.

• L Term Send Util or L Term Send Erls—For the specified date and hour, 
average Send Utilization for the link, expressed as either a utilization 
percentage or a number of Erlangs, since SGM polling began for the link, or 
since SGM last reset the averages as a result of bad data.

If the planned send capacity is not set for the link, this field displays NoCap.
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• Recv Util or Recv Erls—Average Receive Utilization for the link, expressed 
as either a utilization percentage or a number of Erlangs, for the specified date 
and hour.

If the planned receive capacity is not set for the link, this field displays 
NoCap.

• L Term Recv Util or L Term Recv Erls—For the specified date and hour, 
average Receive Utilization for the link, expressed as either a utilization 
percentage or a number of Erlangs, since SGM polling began for the link, or 
since SGM last reset the averages as a result of bad data.

If the planned receive capacity is not set for the link, this field displays 
NoCap.

• Send MSUs—Total number of MTP3 MSUs sent on the specified date and 
hour.

• Recv MSUs—Total number of MTP3 MSUs received on the specified date 
and hour.

• Drop—Total number of drops on the specified date and hour.

• Hourly InSrv—Percentage of time the link was in service on the specified 
date and hour.

• Long Term InSrv—Average percentage of time the link was in service since 
SGM polling began for the link, or since SGM last reset the averages as a 
result of bad data.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.
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SGM enables you to modify the way information is presented in the Link 
Statistics - Custom Detail Report page:

• You can sort the pages based on the information in one of the columns. See 
the “Resizing, Sorting, and Hiding Table Columns” section on page 3-178 for 
more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To display only records for links that are not of type SCTP, click the NoSCTP 
menu option.

To display all records, including those for links that are of type SCTP, click 
the YesSCTP menu option. This is the default setting.

• To display all records, including those for links that do not have planned send 
and receive capacities, click the YesNullCaps menu option.

To display only records for links that have planned send and receive 
capacities, click the NoNullCaps menu option. This is the default setting.

• To reset the Top, SCTP, and NullCaps preferences for this Web page to the 
default settings for the SGM server, click the DefPrefs menu option.

Viewing a Custom Linkset Statistics Summary Report

SGM enables you to view custom linkset statistics summary reports.

To view a custom linkset statistics summary report, click HTML in the View 
column beside a custom linkset statistics summary report on the Custom Network 
Statistics Export Files page. SGM displays the custom linkset statistics summary 
report, which is a custom summary of statistics for all linksets known to SGM 
when the report was generated.
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The Linkset Statistics - Custom Detail Report page displays the following 
information:

• Number and Sort Order (in header)—Displays the number of records in 
the table, the column by which the table is sorted, and whether the sort is in 
ascending or descending order.

• ID—Internal ID, assigned by SGM, of the selected hourly linkset statistics 
summary report.

To see the entire detailed report, click the ID. SGM displays the Linkset Data 
Record page for that linkset, date, and hour, in text format. The Linkset Data 
Record can be useful when the TAC is debugging problems.

• Hour—Hour for which the link statistics summary report was created, for the 
specified date.

• Node—Name of node for the linkset. To see statistics for only a selected 
node, click the node name.

• Linkset Name—Name of the linkset. To see statistics for only a selected 
linkset, click the linkset name.

• Hourly InSrv—Percentage of time the linkset was in service on the specified 
date and hour.

• Long Term InSrv—Average percentage of time the linkset was in service 
since SGM polling began for the linkset, or since SGM last reset the averages 
as a result of bad data.

If a statistics calculation results in an impossible value, such as a number divided 
by zero, or a number that is impossible based on the configuration, SGM displays 
MathError in the field.
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SGM enables you to modify the way information is presented in the Linkset 
Statistics - Custom Detail Report page:

• You can sort the pages based on the information in one of the columns. See 
the “Resizing, Sorting, and Hiding Table Columns” section on page 3-178 for 
more details.

• To display only the top 10 or bottom 10 records, based on the column by 
which the table is sorted, click the Top 10 menu option:

– If the column is sorted in descending order, displays only the top 10 
records.

– If the column is sorted in ascending order, displays only the bottom 10 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 20 or bottom 20 records, based on the column by 
which the table is sorted, click the Top 20 menu option:

– If the column is sorted in descending order, displays only the top 20 
records.

– If the column is sorted in ascending order, displays only the bottom 20 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 50 or bottom 50 records, based on the column by 
which the table is sorted, click the Top 50 menu option:

– If the column is sorted in descending order, displays only the top 50 
records.

– If the column is sorted in ascending order, displays only the bottom 50 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 100 or bottom 100 records, based on the column by 
which the table is sorted, click the Top 100 menu option:

– If the column is sorted in descending order, displays only the top 100 
records.

– If the column is sorted in ascending order, displays only the bottom 100 
records.

– To switch between the two displays, left-click the column header.
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• To display only the top 300 or bottom 300 records, based on the column by 
which the table is sorted, click the Top 300 menu option:

– If the column is sorted in descending order, displays only the top 300 
records.

– If the column is sorted in ascending order, displays only the bottom 300 
records.

– To switch between the two displays, left-click the column header.

• To display only the top 500 or bottom 500 records, based on the column by 
which the table is sorted, click the Top 500 menu option:

– If the column is sorted in descending order, displays only the top 500 
records.

– If the column is sorted in ascending order, displays only the bottom 500 
records.

– To switch between the two displays, left-click the column header.

• To display up to 15,000 records in the table, click the Max menu option.

• To reset the Top preferences for this Web page to the default settings for the 
SGM server, click the DefPrefs menu option.

Viewing SGM Point Code Inventory Reports
SGM enables you to view current and daily point code inventory reports. You can 
also export the reports.

SGM enables you to view the following point code inventory reports:

• Viewing the Current Point Code Inventory, page 3-276

• Viewing the Daily Point Code Inventory Daily Reports, page 3-277

• Viewing the Daily Point Code Inventory Export Files, page 3-278
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Viewing the Current Point Code Inventory

The Current Point Code Inventory page displays all point codes that are currently 
being used by all nodes that are known to SGM.

To access the Current Point Code Inventory page, use one of the following 
procedures:

• Select Web Links >Reports>Point Code Inventory from the SGM Main 
Menu.

• Select Point Code Inventory Reports from the SGM Server Home Page.

• Select Current Point Codes from the menu bar of any SGM Point Code 
Inventory Web page.

SGM displays the Current Point Code Inventory page (Figure 3-1).

Figure 3-82 Current Point Code Inventory Page
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The Current Point Code Inventory page displays the following information:

• Number and Sort Order (in header)—Displays the number of point codes 
in the table, the column by which the table is sorted, and whether the sort is 
in ascending or descending order.

• Point Code—Point code that is currently being used by a node.

To sort the point codes by point code in ascending order, click the Point 
Codes header. This is the default display.

Click again to sort the point codes in descending order.

• Node Name—Name or IP address of the node.

To see detailed information for the node, click the node name.

To sort the point codes by node in descending order, click the Node Name 
header.

Click again to sort the point codes in ascending order.

• Point Code Type—Type of point code:

– Primary—Main point code used by a node.

– Secondary—Alternate or backup point code used by a node.

– Capability—Shared by more than one node, each of which is also 
assigned a “real” point code. Also called an alias point code.

To sort the point codes by type in ascending order, click the Point Code Type 
header.

Click again to sort the point codes in descending order.

Viewing the Daily Point Code Inventory Daily Reports

The Point Code Inventory - Daily Reports page displays all archived SGM daily 
point code inventory reports for the server to which you are connected.

To access the Point Code Inventory - Daily Reports page, select Daily Point 
Codes from the menu bar of any SGM Point Code Inventory Web page.

On the Point Code Inventory - Daily Reports page, point code inventory reports 
are archived by date. Each archived file contains a list of all point codes that were 
being used by all nodes that were known to SGM on that date.
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To view an archived point code inventory report, click a date. SGM displays the 
Point Code Inventory - Date page, which displays the archived list of point codes 
for that date, including the following information:

• Number and Sort Order (in header)—Displays the number of point codes 
in the table, the column by which the table is sorted, and whether the sort is 
in ascending or descending order.

• Point Code—Point code that was being used by a node on the specified date.

To sort the point codes by point code in ascending order, click the Point 
Codes header. This is the default display.

Click again to sort the point codes in descending order.

• Node Name—Name or IP address of the node.

To see detailed information for the node, click the node name.

To sort the point codes by node in descending order, click the Node Name 
header.

Click again to sort the point codes in ascending order.

• Point Code Type—Type of point code:

– Primary—Main point code used by a node.

– Secondary—Alternate or backup point code used by a node.

– Capability—Shared by more than one node, each of which is also 
assigned a “real” point code. Also called an alias point code.

To sort the point codes by type in ascending order, click the Point Code Type 
header.

Click again to sort the point codes in descending order.

Viewing the Daily Point Code Inventory Export Files

The Daily Point Code Inventory Export Files page displays all archived SGM 
daily point code inventory reports for the server to which you are connected, 
stored as downloadable Zip files.

To access the Daily Point Code Inventory Export Files page, select Daily Point 
Code Export from the menu bar of any SGM Point Code Inventory Web page.
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On the Daily Point Code Inventory Export Files page, the Zip files are archived 
by date. For example, sgmPointCodes.DailyInv.2002-10-15.zip is the Zip file 
that contains the daily point code inventory report for October 15, 2002.

Each archived Zip file contains a comma-separated value (CSV) text file with a 
list of all point codes that were being used by all nodes that were known to SGM 
on that date. You can download the Zip files and unzip them.

To download a Zip file, click a filename, then save the file to a location of your 
choice.

See the “SGM Point Code Inventory Export File Format” section on page F-6 for 
detailed information about the format of point code inventory export files.

Viewing SGM Statistics Reports Logs
SGM enables you to view a log that contains all messages pertaining to SGM 
reports, and a display of the current values of SGM report parameters and timers.

This section contains the following information:

• Viewing the SGM System Reports Log, page 3-279

• Viewing the SGM System Report Parameters and Timers, page 3-280

Viewing the SGM System Reports Log

The SGM System Reports Log - Last Messages page displays the message log for 
SGM reports for the server to which you are connected, and which is currently 
running the SGM server.

To access the SGM System Reports Log - Last Messages page, use one of the 
following procedures:

• Select System Report Log from the SGM Server Home Page.

• Select Log from the menu bar of any SGM Network Statistics or Accounting 
Statistics Web page.

• Enter the sgm replog command. See the “SGM Commands and Descriptions” 
section on page B-2 for more information on the use of this command.
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The SGM System Reports Log - Last Messages page displays the following 
information:

• Last Update (in header)—Date and time the information on the page was 
last updated by SGM.

• Row—Message number, assigned to the message by SGM.

• Time—Date and time the message was logged.

• Type—Type of message. Possible types are:

– Error

– Info

• Message—Text of the message.

Viewing the SGM System Report Parameters and Timers

The SGM System Report Parameters and Timers page displays the current values 
of report parameters and timers for the server to which you are connected, and 
which is currently running the SGM server.

To access the SGM System Report Parameters and Timers page, select System 
Report Parameters from the SGM Server Home Page, or select Params from the 
menu bar of any SGM Network Statistics or Accounting Statistics Web page.

The SGM System Report Parameters and Timers page displays the following 
information:

• Server Name (in header)—Name of the SGM server for which report 
parameter and timer settings are being displayed.

• Report Dir—Path and name of the directory in which SGM stores reports. 
The default reports directory is /opt/CSCOsgm/reports, but you can change 
the reports directory using the sgm repdir command. For more information, 
see the description of the sgm repdir command in the “SGM Commands and 
Descriptions” section on page B-2.

• Status—Indicates whether SGM is to generate network statistics reports. For 
more information, see the description of the sgm statreps [disable | enable] 
command in the “SGM Commands and Descriptions” section on page B-2.
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• ExportReports—Indicates whether SGM is to generate network statistics 
reports in export format. For more information, see the description of the sgm 
statreps [export | noexport] command in the “SGM Commands and 
Descriptions” section on page B-2.

• AcctReports—Indicates whether SGM is to generate accounting statistics 
reports. For more information, see the description of the sgm statreps 
[acct | noacct] command in the “SGM Commands and Descriptions” section 
on page B-2.

• IPLinks—Indicates whether SGM is to include links that use the Stream 
Control Transmission Protocol (SCTP) IP transport protocol in network 
statistics reports. For more information, see the description of the sgm 
statreps [iplinks | noiplinks] command in the “SGM Commands and 
Descriptions” section on page B-2.

• NullCaps—Indicates whether SGM is to include links that do not have 
planned send and receive capacities in network statistics reports. For more 
information, see the description of the sgm statreps [nullcaps | nonullcaps] 
command in the “SGM Commands and Descriptions” section on page B-2.

• TimeMode—Indicates the time mode for dates in network statistics reports. 
For more information, see the description of the sgm statreps timemode 
[12 | 24] command in the “SGM Commands and Descriptions” section on 
page B-2.

• DiskCheck—Indicates whether SGM is to verify that a disk has at least 
10 MB of space remaining before generating network statistics reports. For 
more information, see the description of the sgm statreps 
[diskcheck | nodiskcheck] command in the “SGM Commands and 
Descriptions” section on page B-2.

• UtilRatio—Indicates whether SGM is to display a gray background in the 
Send Utilization or Receive Utilization cell in a network statistics report, if 
the following condition is met:

Current Utilization > factor * Long-Term Utilization

For more information, see the description of the sgm statreps utilratio 
command in the “SGM Commands and Descriptions” section on page B-2.
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• ServRatio—Indicates whether SGM is to display a gray background in the 
InSrv cell in a network statistics report, if the following condition is met:

Current In-Service < factor * Long-Term In-Service

For more information, see the description of the sgm statreps 
[disable | enable] command in the “SGM Commands and Descriptions” 
section on page B-2.

• HourlyAge—Indicates the maximum number of days SGM is to archive 
hourly network statistics reports. For more information, see the description of 
the sgm statreps hourlyage and sgm rephourlyage commands in the “SGM 
Commands and Descriptions” section on page B-2.

• DailyAge—Indicates the maximum number of days SGM is to archive daily 
network statistics reports. For more information, see the description of the 
sgm statreps dailyage and sgm repdailyage commands in the “SGM 
Commands and Descriptions” section on page B-2.

• CustomAge—Indicates the maximum number of days SGM is to archive 
custom network statistics reports. For more information, see the description 
of the sgm repcustage command in the “SGM Commands and Descriptions” 
section on page B-2.

• WebNames—Indicates whether SGM is to show real node names or display 
names in Web pages. For more information, see the description of the sgm 
webnames [display | real] command in the “SGM Commands and 
Descriptions” section on page B-2.

• WebUtil—Indicates whether SGM is to display send and receive utilization 
for linksets and links as percentages or in Erlangs, in Web pages. For more 
information, see the description of the sgm webutil [percent | erlangs] 
command in the “SGM Commands and Descriptions” section on page B-2.

• Timer file for last report run—Indicates timer activities during the last 
report run by SGM. The timer file is useful for identifying how much time 
SGM spends gathering report data and generating reports.
3-282
Cisco Signaling Gateway Manager User Guide

78-15204-01



 

Chapter 3 Managing ITP Networks Using SGM
Printing SGM Windows
Printing SGM Windows
You can print most SGM windows, as well as the topology map, for those times 
when you need hardcopy.

To print an SGM window, use one of the following procedures:

• From most SGM windows, select File> Print from the SGM Main Menu.

• From the Topology Window, select File> Print> All from the SGM Main 
Menu, if you want to print the map of your entire network, not just the part 
that is visible in the current topology map view.

• From the Topology Window, select File> Print> Display from the SGM 
Main Menu, if you want to print just the part of your network that is visible 
in the current topology map, not the map of your entire network.

SGM displays the Print dialog (Figure 3-83).

Figure 3-83 Print Dialog
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The Print dialog enables you to specify print settings, such as which printer to 
print to, whether to send output to a file (the default location for the print file is 
your home directory), and whether to print duplex.

When you are satisfied with your print settings, click Print. SGM prints the map.

To exit the Print dialog at any time without printing, click Cancel.

Connecting to a New Server
SGM enables you to connect the client to a new SGM server. For example, you 
can monitor two or more networks from the same SGM client, simply by 
switching servers. Or, if you have two SGM servers monitoring the same network, 
and one server fails, the SGM client automatically switches to the secondary 
server.

To connect the client to a new server:

Step 1 (Optional) If you want to determine the default host name before you connect to 
the new server, it is contained in the SERVER_NAME entry in the 
System.properties file:

• If you installed SGM in the default directory, /opt, then the location of the 
System.properties file is /opt/CSCOsgm/properties/System.properties.

• If you installed SGM in a different directory, then the System.properties file 
is located in that directory.

Step 2 Select File >Connect to New Server from the SGM Main Menu. SGM displays 
the Connect to New Server Dialog (Figure 3-84).

Figure 3-84 Connect to New Server Dialog
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Step 3 Enter the name of the new server, or its IP address, in the Server Name or IP 
Address field.

Step 4 Enter the SGM Naming Server UDP port number for the new server in the Name 
Server Port field. The default value is 44742.

Step 5 Click OK. SGM stops the SGM client, then restarts the client connected to the 
new server.

Integrating SGM with Other Products
SGM does not require either CiscoWorks2000 or HP OpenView, but SGM does 
integrate with those products to provide added value. See the following sections 
for more information:

• Integrating SGM with HP OpenView, page 3-285

• Integrating SGM with CiscoWorks2000, page 3-286

Integrating SGM with HP OpenView
SGM can integrate with HP OpenView during installation, registering to receive 
forwarded traps. See the “Installing SGM on Solaris” chapter of the Cisco 
Signaling Gateway Manager Installation Guide for more information.

You can also integrate SGM with HP OpenView after installation, using the 
sgm trapsetup command. See the “SGM Command Reference” section on 
page B-1 for more information.

If you select HP OpenView as the source of traps in SGM, keep the following 
considerations in mind:

• If HP OpenView is not running when you start the SGM servers, SGM’s 
sgmTrapReceiver process cannot start and is labeled Stopped.

• If HP OpenView is running when you start the SGM servers, but ovtrapd (HP 
OpenView’s trap receiver process) is not running, sgmTrapReceiver starts and 
is reported as Running, but it cannot receive traps.
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• If you start the SGM servers, then start HP OpenView, sgmTrapReceiver does 
not start automatically. You must start sgmTrapReceiver using the Process 
Manager.

• If sgmTrapReceiver is running and HP OpenView is stopped using the ovstop 
command, sgmTrapReceiver stops itself, and does not start automatically 
when HP OpenView is restarted. You must start sgmTrapReceiver using the 
Process Manager.

• If sgmTrapReceiver is running and ovtrapd stops running for any reason, 
sgmTrapReceiver cannot detect that ovtrapd is no longer running. 
sgmTrapReceiver continues running but cannot receive traps until ovtrapd is 
restarted. When ovtrapd is restarted, sgmTrapReceiver begins receiving traps 
again automatically.

Integrating SGM with CiscoWorks2000
SGM can integrate with CiscoWorks2000 during installation, registering with 
CiscoWorks2000 as an installed application. See the “Installing SGM on Solaris” 
and “Installing SGM on Windows” chapters of the Cisco Signaling Gateway 
Manager Installation Guide for more information.

You can also integrate SGM with CiscoWorks2000 after installation, using the 
sgm cw2ksetup command. See the “SGM Command Reference” section on 
page B-1 for more information.

When SGM is integrated with CiscoWorks2000, you can launch the 
CiscoWorks2000 Device Center and CiscoView from the SGM Main Menu. See 
the following sections for more information:

• Launching the CiscoWorks2000 Device Center, page 3-287

• Launching CiscoView, page 3-287
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Launching the CiscoWorks2000 Device Center

The CiscoWorks2000 Device Center provides a number of useful Web-based 
device-monitoring functions, including reachability trends, response time trends, 
interface status, Syslog browsing, and a detailed inventory.

To link SGM to the Device Center:

Step 1 Make sure CiscoWorks2000 is installed in the network.

Step 2 Select a node that you know CiscoWorks2000 is monitoring, or an associated 
linkset, in the Linkset, Node, or Topology window. If you select a non-ITP node, 
or a node with a status of Unmanaged or a Device Type of Unknown, the 
CiscoWorks2000 menu option is grayed-out.

Step 3 Select Products>CiscoWorks2000 >Device Center from the SGM Main Menu.

Step 4 At the prompt, enter a CiscoWorks2000 user ID and password. SGM links to 
CiscoWorks2000 Device Center dashboard.

Launching CiscoView

CiscoView provides a real-time, color-coded, graphical representation of Cisco 
routers and switches. You can use CiscoView to quickly identify an incorrect 
status on a port or interface. If you are running CiscoWorks2000 on UNIX or 
Windows, you can access CiscoView through the link to the Web version of 
CiscoWorks2000.

To link SGM to CiscoView:

Step 1 Select a node that you know CiscoWorks2000 is monitoring, or an associated 
linkset, in the Linkset, Node, or Topology window. If you select a non-ITP node, 
or a node with a status of Unmanaged or a Device Type of Unknown, the 
CiscoWorks2000 menu option is grayed-out.

Step 2 Select Products> CiscoWorks2000 >CiscoView from the SGM Main Menu.

Step 3 At the prompt, enter a CiscoWorks2000 user ID and password. SGM links to 
CiscoView.
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Using the Windows Start Menu
This section includes the following information:

• Launching the SGM Client, page 3-288

• Launching the SGM GTT Client, page 3-288

• Changing the Default SGM Server Name, page 3-289

• Changing the Default SGM Telnet Path, page 3-289

• Launching the SGM DOS Prompt, page 3-290

• Launching the SGM SSL Certificate Tool, page 3-290

• Uninstalling SGM, page 3-290

• Viewing the SGM README File, page 3-290

Launching the SGM Client
To launch the SGM Client, use one of the following procedures:

• Double-click the SGM icon on the desktop.

• Select Start>Programs>Cisco SGM Client> Launch SGM Client from 
the Windows Start menu.

SGM launches the SGM Client.

Launching the SGM GTT Client
To launch the SGM GTT Client, select Start>Programs> Cisco SGM Client> 
Launch SGM GTT Client from the Windows Start menu.

SGM launches the SGM GTT Client.
3-288
Cisco Signaling Gateway Manager User Guide

78-15204-01



 

Chapter 3 Managing ITP Networks Using SGM
Using the Windows Start Menu
Changing the Default SGM Server Name
If there is a failure of the IP address or host name to which your SGM client is 
bound, you can change the default SGM server name from the Windows Start 
menu.

To change the default SGM server name, use the following procedure:

Step 1 Close all open SGM windows.

Step 2 Select Start>Programs>Cisco SGM Client> Modify Default SGM Server  
Name. SGM opens a DOS window, and asks you to enter the name of the new 
default SGM server.

Step 3 Type the name of the new default SGM server, and press Enter. SGM sets the 
default server to the new name you entered.

See the “Connecting to a New Server” section on page 3-284 for more 
information about changing the default SGM server name.

Changing the Default SGM Telnet Path
SGM provides a default Telnet interface for Telnet sessions, but you can also 
specify a path to a different Telnet application, if you prefer.

To specify the path to the new Telnet application, use the following procedure:

Step 1 Select Start>Programs>Cisco SGM Client> Modify Default SGM Telnet  
Path. SGM opens a DOS window, and asks you to enter the full Telnet executable 
pathname.

Step 2 Type the new pathname, and press Enter. If you do not enter a new pathname, 
SGM uses the system default Telnet executable. SGM asks you to enter any 
special parameters you want to pass to the new Telnet application. The default is 
n, for no special parameters.
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Step 3 Type the special parameters you want to pass to the new Telnet application, and 
press Enter. SGM uses the new Telnet application for all Telnet sessions on the 
SGM client, such as when you select View> Telnet to> Router.

Step 4 Close the DOS window.

Launching the SGM DOS Prompt
To launch a DOS prompt for SGM from the Windows Start menu, select 
Start> Programs>Cisco SGM Client> SGM DOS Prompt. SGM opens a DOS 
window, starting in the bin directory:

• If you installed the SGM client in the default directory, C:\Program Files, 
then the DOS prompt starts at C:\Program Files\SGMClient\bin.

• If you installed the SGM client in a different directory, then the bin directory 
is located in that directory.

Launching the SGM SSL Certificate Tool
To launch the SGM SSL Certificate Tool from the Windows Start menu, select 
Start> Programs>Cisco SGM Client> SGM SSL Certificate Tool.

Uninstalling SGM
You can uninstall SGM from the Windows Start menu. For details, see the 
“Uninstalling SGM” section of the Cisco Signaling Gateway Manager 
Installation Guide.

Viewing the SGM README File
The SGM README file contains late-breaking information about SGM that 
might not be found in the other product documentation. To open the SGM 
README file from the Windows Start menu, select Start> Programs> 
Cisco SGM Client>View README.
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