
  
C H A P T E R 7

Viewing Devices, Links, and Services in Maps

Vision client maps display a variety of information in a topological view, such as devices, physical and 
logical connections, network services, and so forth. Whenever you open a map, Prime Network refreshes 
the map information. How to create a map is described in Workflow for Creating a Map, page 4-2. These 
topics describe how to use maps to get the information you need about your network:

• Opening Maps, page 7-2

• Interpreting NE Icons, Badges, and Colors, page 7-4

• Zooming In and Out To Get More Details, page 7-6

• Viewing a Table of NEs and Their Properties (List View), page 7-7

• How to Find Entities Inside and Outside Of Maps, page 7-11

• Finding Out Which Maps Include an NE, page 7-14

• Viewing Very Large Maps Using an Overview Window, page 7-15

• Drilling Down Into NE Groups (Aggregations), page 7-16

• Finding Services Using Map Overlays, page 7-17

• Viewing and Managing Links, page 7-20

• Making Changes to the Device Appearance in the Map, page 7-32

• Adding and Removing NEs from Existing Maps, page 7-33

• Grouping NEs Using Aggregations, page 7-35

• Closing Maps, Renaming Maps, and Other Map Operations, page 7-36

• Changing the Vision Client Default Behavior, page 7-37
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Opening Maps
You can work on a maximum of five maps at any given time. Like all Prime Network clients, the Vision 
client is password-protected. When you log in, client updates (if any) are automatically applied. 

Note You can change your password at anytime by choosing Tools > Change User Password from the main 
menu.

Step 1 Launch the Vision client.

If you want the Vision client to prompt you to open the last map you used, you can configure it to do so 
as described in Changing Vision Client Default Settings (Sound, Display, Events Age), page 4-15.

Step 2 Select File > Open Map from the Vision client menu bar.

Step 3 Select a map and click OK.

Figure 7-1 provides an overview of the Vision client with an open map, followed by a description of the 
map window.

If You Are Using 
Prime Network: Launch the Vision client by choosing:

As part of suite Assure > Prime Network > Vision from the REPLACE main menu bar

As a standalone 
application

http://gateway-ip:6080/ana/services/install/install/webstart.html

Start > Programs > Cisco Prime Network > Cisco Prime Network Vision
7-2
Cisco Prime Network 5.2 User Guide



  

Chapter 7      Viewing Devices, Links, and Services in Maps
  Opening Maps
Figure 7-1 Vision Client Window with Map View

Why You Cannot See Everything in a Map or Perform All Actions in a Map

What you can see and do in maps is determined by your user account settings. If you try to view an NE 
but you do not have the required permissions, the Vision client will display an error message.

• NEs—If you do not have permission to view an NE, it is displayed with a lock. The Vision client 
will also not display tickets for those NEs.

• Links—If one of a link’s endpoints is outside your permissions, the link is greyed-out.

1 Main menu—Opening, closing, and 
changing map layouts, launching CCM, 
online help and icon reference, etc.

5 Status bar (shows commands sent to 
gateway, memory used by client, and 
gateway connection status).

2 Toolbar—Map tools, overlays, links, filters, 
NE labels, and zoom controls.

6 Tickets and latest events related to all NEs in 
the map.

3 Tabs for active maps, lists of managed NEs, 
and views for Ethernet Flow and VTP 
Domains, and Compute Services.

7 Toggle for hiding/displaying ticket pane.

4 Content pane showing map view—Shows the 
map NEs and their relationships. Colors such 
as red and orange indicate problems on the 
NE. See Troubleshooting a Ticket, 
page 11-12.

8 Inventory window—Displays all NEs in the 
map. Double-clicking an NE opens the 
physical and logical inventory for the NE in 
the content pane.
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• Vision client choices—If you do not have permission to execute a menu choice, button, and so forth, 
they are greyed-out.

These guide also apply when you view an NE’s physical or logical inventory, or perform any actions 
from the inventory windows. Permissions are described in Permissions for Vision Client Maps, 
page B-2.

Saving a Changed Map Layout and Changing Map Display Defaults

When you close a map, Prime Network automatically saves most of your changes. If you made a change 
that Prime Network will not automatically save, the Vision client prompts you to manually save the map 
by clicking Save Map Appearance from the main toolbar.

You can also customize which items are displayed in maps, how items are displayed in maps, whether 
to use audio sounds, and when to remove NE tickets and events from the map. To change these settings, 
choose Tools > Options from the Vision client main menu. For more information, see Changing Vision 
Client Default Settings (Sound, Display, Events Age), page 4-15.

Interpreting NE Icons, Badges, and Colors

Tip To view an icon reference, choose Help > Icon Reference from the main menu.

Are There Problems That No One Is Aware of?

The Vision client conveys critical information using colors and alarm badges. These can indicate a 
problem, its severity, and whether anyone is aware of the problem.

Alarm Badge Color Severity

Red Critical 

Orange Major

Yellow Minor

Light Blue Warning

Medium Blue Information 
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These examples show how an NE with a major ticket is displayed, depending on where you are in the 
Vision client.

The alarm badge is displayed on top of a managed NE icon. In Figure 7-2 the NE icon is for a Cisco MDS 
device.

Figure 7-2 What NE Icon Badges Signify

Is The Device Working Properly?

A badge displayed at the bottom right of the icon signals a reachability problem between Prime Network 
and the device, as shown in Figure 7-3.

Dark blue Indeterminate

Green Cleared, Normal, or OK

Alarm Badge Color Severity

Value Navigation Pane Map Ticket Pane

Element with ticket of 
Major severity  

Description What this example shows: Conclusion:

1 Network element icon and color: The NE still has a Major 
uncleared ticket.• Icon represents NE type NE is a Cisco MDS device.

• Color represents NE’s most 
serious ticket that has not been 
cleared (cleared means it is no 
longer a problem)

Orange means the NE has at 
least one uncleared ticket, and 
its severity is Major.

2 Color represents NE’s most serious 
ticket that is unacknowledged 
(acknowledged means someone is 
aware of the problem)

Green means the NE has no 
unacknowledged tickets.

Someone is aware of the 
NE’s Major uncleared 
ticket.
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Figure 7-3 Element with Overlay Badges

A complete list of all NE icons, severity icons, and device reachability icons is provided in Icon 
Reference, page A-1. For information on how to respond to NE tickets, see Managing Tickets with the 
Vision Client, page 11-1.

Zooming In and Out To Get More Details
Use these menu choices to manipulate a map:

Description What this example shows: Conclusion:

1 Color represents NE’s most serious 
ticket that is unacknowledged

Light blue means the NE still at 
least one unacknowledged ticket, 
and its severity is Warning.

No one is aware of the 
NE’s uncleared Warning 
ticket.

2 Network element icon and color: The NE still has an 
uncleared Warning 
ticket.

• Icon represents NE type NE is a Cisco 7600 router.

• Color represents NE’s most 
serious ticket that has not been 
cleared (that is, the problem no 
longer exists)

Light blue means the NE still at 
least one uncleared ticket, and 
its severity is Warning.

3 Icon represents the state of the 
device 

The Cisco 7600 router is only 
partially reachable.

There may be a 
communication problem 
between Prime Network 
and the 7600 router.

1

2

3 31
05

17

From Vision Client Main Menu To do the following

View > Zoom In Zoom in on the map

View > Zoom Selection Select an area in a map to zoom in on by clicking and dragging

View > Fit In Window Fit the entire map in the display area

View > Pan Move around in a map by clicking and dragging

View > Zoom Out Zoom out of the map.
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As you zoom in, the Vision client displays more NE detail. As you zoom out, the Vision client displays 
the NE’s topological relationships, as shown in the following examples.

Viewing a Table of NEs and Their Properties (List View)
To get a quick look at the properties of devices in a map, change to a list view by clicking Show List 
View from the Vision client toolbar. This view provides a table of all NEs with details about 
IP addresses, the device model and software image it is running, how long it has been up, and 
virtualization information.

Note If a cell’s contents do not fit in the table, hover your mouse cursor over the table cell.

Huge Large Normal Tiny (Overview)
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Figure 7-4 Vision Client Window with List View

The Network Elements tab lists all NEs in the map which you have permission to view. If you do not 
have permission to view a map’s NE, it is listed under the Restricted Elements tab and displayed with a 
lock icon. From here you can perform the following operations:

To perform this table operation:
Click this toolbar 
button from List View: Button Name

Searches for the string you enter Find

Exports the selected information to a CSV file Export to CSV

Arrange existing data according to sort operations 
that you specify (see Sorting Tables, page 7-9)

Sort Table 
Values

Only display information that matches the filter (see 
Filtering Tables, page 7-10)

Filter

Clear the existing filter Clear Filter
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These topics explain how to sort and filter tabular information.

Sorting Tables

Sorting a table lets you arrange existing data in various ways, while filtering a table only displays the 
information that matches the filter.

Step 1 In the table toolbar, click Sort Table Values. The Sort dialog box is displayed. 

Figure 7-5 Sort Dialog Box

Step 2 In the Sort Operation field, specify the frequency of the sort operation:

• Only Once—Sorts the information in the table only once according to the specified criteria. When 
this option is selected, newly added rows will always be listed at the bottom of the table, regardless 
of their sort criteria value. Also, if an existing row's value changes, the row will remain where it is.

• Continuously/Repeatedly—Sorts the information in the table continuously according to the 
specified criteria. 

If you select this option, the  icon is displayed next to the selected column heading.

Step 3 In the Sort By field, specify the first sort criterion:

a. In the first drop-down list, choose the column to use for the first sort criterion. 

b. In the second drop-down list, choose Ascending or Descending to indicate the sort order.

Step 4 Add and adjust the criteria as needed, and click OK. The table data is sorted.

Display all table rows that meet the current filtering 
criteria

Show All Rows

Display only selected table rows Show Only 
Selected Rows

To perform this table operation:
Click this toolbar 
button from List View: Button Name
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Filtering Tables

Use filters for tables that contain many entries. You cannot apply a filter until the table has loaded; for 
tables with many entries, this can take a while. Once the entries are populated, the filter tool becomes 
available.

You can check whether a filter is applied by hovering your mouse cursor over the filter button.

Note These operations are performed from the table of NEs in a List View. These filters are different from 
filters that can be configured, saved, and used at a later time. For information on those filters, see 
Viewing Tickets and Latest Events for All Devices in a Map, page 11-3

Step 1 In table toolbar, click Filter. The Filter dialog is shown in Figure 7-6.

Figure 7-6 Table Filter Dialog Box

Step 2 In the Match drop-down list, choose All or Any.

Step 3 For each criterion, specify the following:

a. In the first drop-down list, choose the primary match category (the drop-down list contains all table 
columns). 

b. In the second drop-down list, choose a rule. 

c. In the third field, choose from the available values, or enter text (using a drop-down list or free text). 

Tip You can use the “Greater than” or “Less than” rule with a string for filtering. For example, if you 
want to include all interfaces above Ethernet0/0/3, you can select Greater than and enter the 
string Ethernet0/0/3 to view interfaces Ethernet0/0/4, Ethernet0/0/5, and so on. 

Step 4 Click  to add another criterion. 

Step 5 Add and adjust the criteria, then click OK. The table data is displayed using the defined filter. 
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How to Find Entities Inside and Outside Of Maps
The Vision client provides a variety of ways to locate the NEs, technologies, and services you are 
interested in by using search, filters, business tags, and overlays. If you do not have sufficient 
permissions to view an NE, it is displayed with a lock icon. If you try to view the NE details, the Vision 
client displays a warning message.

To search for: See this section or use this method:

NEs by name or IP address Finding NEs Using Basic NE 
Information (Name, Vendor, 
IP address), page 7-12

NEs by vendor

NEs by model number (12404) or device type (router)

NEs by device series (Catalyst, Nexus, 3750) Finding NEs Using Advanced Filters, 
page 7-12NEs by software version

NEs with tickets of certain severities

NEs with unacknowledged tickets

NEs by connectivity state (down, up

NEs with Data Center virtual devices and associated virtual 
machines

NEs with Data Center associated compute servers

NEs affected by a ticket Right-click ticket and choose Find 
Affected Elements

NEs by their label (customer or subscriber names, provider 
connections) 

Finding NEs By Searching for NE 
Labels, Subscribers, and Provider 
Connections, page 7-13

NEs in current map, using a search string Edit > Find in Map

Maps that contain specified NEs Right-click the NE and choose Open 
Relevant Maps

Link types: Data links, physical links, VPN links Using Link Filters to Find Links, 
page 7-21

Links by their level Table 7-1 on page 7-25

Ethernet Flow Domains Network Inventory > Ethernet Flow 
Domains from Vision client main menu

VTP Domains Network Inventory > VTP Domains 
from Vision client main menu

Services: Ethernet, MPLS-TP tunnels, network clock, 
pseudowire, VLAN, VPLS, VPNs

Finding Services Using Map Overlays, 
page 7-17

Network TP tunnels Click Show List View, then click 
TP Tunnels tab
7-11
Cisco Prime Network 5.2 User Guide



  

Chapter 7      Viewing Devices, Links, and Services in Maps
  How to Find Entities Inside and Outside Of Maps
Finding NEs Using Basic NE Information (Name, Vendor, IP address)

Use this method when you have a large number of NEs to find the NEs that match your criteria. 

Note You do not have to clear the results to start a new search. The Vision client always starts the search using 
all managed NEs.

Step 1 From the Vision client, click the Network Elements tab.

Step 2 Click Search.

Step 3 Enter the search criteria. It is not case sensitive, and you can enter fragments.

Click Go. The Vision client lists all devices that match your criteria, and which you have permission to 
view. 

To start a search using different criteria, you do not have to clear the results. Just select your new choice 
from the drop-down list and enter your criteria.

Step 4 To open the NE’s inventory, double-click the NE from the list.

Finding NEs Using Advanced Filters

Use this method to search for NEs by advanced criteria, such as communication state, ticket severity, and 
similar detailed criteria. Some of the criteria provide drop-down lists for choices. 

These filter buttons are listed above the table of NEs.

Step 1 From the Vision client, click the Network Elements tab.

Step 2 Click Show All. (Depending on the number of NEs, the table may require a few minutes to load.) 
Devices that you do not have permission to view are displayed with a lock.

Criteria Examples Example Search Strings

Element type—NE model Cisco 12404 12404, 124, 12

IP address 198.51.100.1 198, 51, 198.51

Name—Name assigned when NE was added using 
the Administration client

c7-sw6 c7, sw, c7-

Product—NE family Eth-switch Eth, switch

System name—Name from NE MIB p1 p1, p, 1

Vendor Cisco cisco, cisc, Cis

Filter—Turn on filter.

If a filter is currently applied to the table contents, hover over this button to display the filter 
rules (such as ‘Name’ Contains Cisco).

Clear Filter—Turn off filter and revert to original list.

If this button is enabled, a filter is currently applied to the table contents. 
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Step 3 Click the Filter button and enter the search criteria using the logical operators to create rules. 

Step 4 Click OK. To start a search using different criteria, clear the results by clicking the Clear Filter button.

Step 5 To open the NE’s inventory, double-click the NE from the list.

Finding NEs By Searching for NE Labels, Subscribers, and Provider Connections

A business tag is a string that is meaningful to the business, and which can be used to label a component 
of a network element for use in Prime Network screens and reports. Business tags allow you to label NEs 
in the manner that best fits your deployment.

Business tags are normally applied to business elements, which are constructions or organizations of 
certain network elements and their properties into a logical entities (for example, Layer 2 VPNs, Layer 3 
VPNs, and virtual routers). 

To search for a business tag:

Step 1 Choose Edit > Find Business Tag from the main menu. 

Step 2 In the Find Business Tag dialog box, enter the search criteria.

These are some examples of the criteria you can enter:

Step 3 Click Find Business Tag. Figure 7-7 shows the results of a search for any label type business tags with 
notes that contain the string San Jose.

Criteria Example Search Strings

Severity N/a; drop-down list

Unacknowledged

Device communication state
Device investigation state

Vendor

Product

Device software versions 12.2, SG2, 3.8

Device series Nexus, Catalyst, CRS, 3750

Location Bangalore, Bang, Jose, San Jose, San

Up Since (dd-mm-yyyy) 3-May, 2013, Aug

Node role primary, standby, secondary

Field Enter: Vision client will search for NEs with business tags that:

Unique Key Letter or 
number string

Have a unique key that contain the string

Name Have a business tag name that contains the string

Notes Have notes that contain the string

Type From 
drop-down list

Have a business tag of that type (Label, Subscriber, Provider 
Connection, All types)
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Figure 7-7 Find Business Tag Dialog Box With Results

Double-click the entity hyperlink to open the NE’s inventory window. If the results display an NE with 
a lock icon, it means you do not have sufficient permissions to view it.

Finding Out Which Maps Include an NE
If you have a problematic NE, you may want know all other maps that include the NE to get an overall 
view of the impact of the NE’s ticket. To find out which maps include a specified NE, right-click the NE 
in a map and choose Open Relevant Maps. The Vision client will display the Open Map dialog box with 
a list of all maps that include the selected element. From there, you can open the maps in which you are 
interested.
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Viewing Very Large Maps Using an Overview Window
The Overview window provides a condensed view of all elements in a map. This is especially useful for 
large maps.

Step 1 To open the Overview window, choose View > Overview from the main menu. Figure 7-8 shows an 
example of the Overview window. If you do not have permission to view an NE, it is displayed with a 
lock icon or greyed-out.

Figure 7-8 Overview Window

Note To view an icon reference, choose Help > Icon Reference from the main menu.

Dots represent elements, lines indicate links, and the blue rectangle represents the current selection area. 
In other words, when you open the map named 123, it displays all of the items inside the blue rectangle.

Step 2 To change the overview:

a. Click inside the blue window and drag the rectangle to the desired map area. 

b. Use the corner handles to resize the selection area. 
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Drilling Down Into NE Groups (Aggregations)

Tip To view an icon reference, choose Help > Icon Reference from the main menu.

Aggregations are groups of NEs. An aggregation can contain network elements, services, and other 
aggregations. Aggregations are displayed as a single entity, as shown in the following figure. 

If you cannot create an aggregation, it is because you do not have a sufficient user access level, or you 
do not have permission to manage the NE.

To view an aggregation’s contents, expand (open) it by right-clicking the aggregation and choosing 
Show Thumbnail. A thumbnail is an aggregation that has been opened. The Vision client will adjust the 
location of other NEs in the map so you can view the thumbnail contents, and then move them back when 
you close the thumbnail. As you traverse an aggregation, you will need to know the meaning of these 
terms:

• The aggregation parent is the next level up.

• The aggregation root is the map that contains the aggregation.

Figure 7-9 provides an example of two aggregation thumbnails— Aggr1122 and VLANs. In this 
example, the Aggr1122 aggregation contains the VLANs aggregation. The dashed gray border around 
c7-sw6 indicates that c7-sw6 resides inside the Aggr1122 thumbnail but not at the current map level.

Note Multi-chassis devices are also displayed as aggregations.
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Figure 7-9 Aggregation Thumbnails

This table lists the ways to move between aggregations and parent maps.

Finding Services Using Map Overlays
When you apply an overlay to a map, you can isolate the parts of a network that are being used by a 
specific service such as VPLS, network pseudowire, MPLS-TP tunnels, and so forth. Prime Network 
models and manages many more technologies and services which you can view from a device’s inventory 
window. Those technologies and services are described in other topics in this guide.

If you want to... Do this...

View and drill into only the aggregation (not other NEs 
in the map)

Double-click the thumbnail frame (or the 
aggregation itself, if it is closed)

From an aggregation, go up one level (parent level) Double-click the inner level background

Open and close thumbnail Click the plus/minus sign at the top right of 
the aggregation
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Applying a Map Service Overlay

Step 1 From the map toolbar, choose Choose Overlay Type > overlay-type, where overlay-type is one of the 
following.

The dialog box also displays the date and time at which the list was generated. To update the list, click 
Refresh.

Step 2 Select the overlay that you want to apply to the map. Figure 7-10 shows an example of the Select 
Pseudowire Overlay dialog box. 

Overlay Option Search Criteria

Ethernet Service EVC Terminating EFPs, ethernet service name, system name. See Applying 
Ethernet Service Overlays, page 18-126.

MPLS-TP Tunnel Description, MPLS-TP tunnel name, system name. See Applying an MPLS-TP 
Tunnel Overlay, page 17-17.

Network Clock Name. See Applying a Network Clock Service Overlay, page 26-48.

Pseudowire Description, Is Multisegment Pseudowire, pseudowire name, pseudowire role, 
pseudowire type, system name. See Applying Pseudowire Overlays, 
page 18-115.

VLAN EFD name, EFD system name, VLAN ID, VLAN name, system name. See 
Displaying VLANs By Applying VLAN Overlays to a Map, page 18-77; Viewing 
REP Information in VLAN Domain Views and VLAN Overlays, page 18-80; and 
Viewing STP Information in VLAN Domain Views and VLAN Overlays, 
page 18-83.

VPLS Name, system-defined name, VPN ID. See Applying VPLS Instance Overlays, 
page 18-98 and Viewing Pseudowire Tunnel Links in VPLS Overlays, 
page 18-99.

VPN Description, VPN name. See Applying VPN Overlays, page 17-25.
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Figure 7-10 Select Pseudowire Overlay Dialog Box

Step 3 In the Select Overlay dialog box, do either of the following: 

• Choose Show All to list all overlays of that service type.

• Choose Search to find the service using the following criteria. (Search strings are case-sensitive.)

Step 4 Click OK, and the elements and links that are used by the overlay are displayed in the map, and the 
overlay name and date are displayed in the toolbar. 

Note The overlay is a snapshot taken at a specific point in time. To update the overlay, click Refresh 
Overlay in the toolbar.
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Figure 7-11 Clock Service Overlay Example

Hiding and Removing Service Overlays from a Map

To temporarily hide an overlay or remove it completely:

• Temporarily hide a map overlay by clicking Hide Overlay/Show Overlay in the toolbar. The button 
toggles depending on whether the overlay is currently displayed or hidden. 

• Delete an overlay from the map by choosing Choose Overlay Type > None.

Viewing and Managing Links
Links are the physical and logical connections that exist between elements in the network. You can get 
link property information for links that are:

• Between two devices.

• Between a device (Device A) and an aggregation, where a device inside the aggregation is connected 
to Device A.

• Between two aggregations that contain devices that cross the aggregations.

In Vision client maps, a single link can actually represent multiple links—for example, a physical 
ethernet link and an MPLS link. Drill down into the link to get this information. These topics explain 
how to manage links using the Vision client:

• Using Link Filters to Find Links, page 7-21

• Interpreting Link Colors, Widths, and Symbols, page 7-21

• Viewing Link Details, page 7-22

• Checking the Impact of Link Problems (Impact Analysis), page 7-27

• Managing Missing Links (Static Links), page 7-29
7-20
Cisco Prime Network 5.2 User Guide



  

Chapter 7      Viewing Devices, Links, and Services in Maps
  Viewing and Managing Links
Using Link Filters to Find Links
Use a link filter when you want to locate specific link types, such as physical links, VPN links, data links, 
and so forth. Sometimes it may not be clear if a link filter is already applied to a map. To verify whether 
a map is using a link filter, check the map toolbar. 

To create a link filter:

Step 1 Click Link Filter in the main toolbar.

Step 2 Select the specific links you want to view, or select a links group from the drop-down list.

Step 3 Click Apply and OK. If any links are grey, it means you do not have sufficient permissions to view them. 
By default, the Vision client only displays a link if you have permission to view both of the link’s end 
points.

If you want to remove the filter later (and show all links), repeat the previous steps but choose All from 
the group drop-down list.

Step 4 To interpret the information displayed by the Vision client, see Viewing Link Information Displayed at 
the Map Level (Tool Tips and Quick View), page 7-23.

Interpreting Link Colors, Widths, and Symbols
The following tables provide keys for understanding the link information displayed by the Vision client.

Link Colors:

A link filter is applied to the map. To clear the filter, click this icon and choose None from 
the Group drop-down list.

A link filter is not applied. To apply a link filter, see Using Link Filters to Find Links, 
page 7-21.

To display these links: Choose

Data links (ATM, Frame Relay) Data

Physical layer links Physical

VPN links (GRE, Pseudowire, VPN, VPN IPv6) VPN

Link types that you want to choose (your choices will be saved for 
the next time you open the link filter)

Custom

All links All

Link has a critical alarm Red

Link has a major alarm Orange

Link has a minor alarm Yellow
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Solid or Dashed Link 5.2

Link Widths

Arrowheads

Viewing Link Details
These topics explain how to traverse from the map level down to the link property details:

Link is operating normally Green

Link is selected Blue

Physical, topological, or service 
link, such as a link between two 
devices.

Solid line

Association or business link 
between such elements as EVCs, 
VPLS service instances, or VPN 
components. 

Dashed line

Link represents multiple links of the 
same group (business, GRE, MPLS-TP, 
Pseudowire, VLAN, all others)

Normal 
width

Line represents an aggregated link that 
contain links of different groups. 

Use high zoom level to view aggregated 
links.

Wide 
width

Line represents a tunnel, with the center 
color representing the severity of any 
alarms on the link. 

Tunnel

Bidirectional link No arrowhead

Unidirectional link, with the flow in the 
direction of the arrowhead

Arrowhead
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• Viewing Link Information Displayed at the Map Level (Tool Tips and Quick View), page 7-23

• View Links at Different Levels in Aggregations and Maps (Links View), page 7-24

• Viewing Link Status and Detailed Link Properties, page 7-25

Viewing Link Information Displayed at the Map Level (Tool Tips and Quick View)

To view the link count and end points, hover your mouse cursor over the link to display the link tool tip, 
as shown in the following figure.

Figure 7-12 Vision Client Window with Link Tooltip

To display the link quick view, click the tooltip. 

Figure 7-13 Link Quick View Example
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The link quick view in Figure 7-13 provides the following information.

View Links at Different Levels in Aggregations and Maps (Links View)

You can launch a links view from a map or from an aggregation thumbnail. When you open the links 
view, it shows links at the current level and for all nested aggregations (all links must have both endpoints 
in the map or aggregation). 

To open a links view, click Show Links View from the main toolbar. Figure 7-14 shows an example of 
the links view launched from a map view.

Note If some links are missing, your map may be using a link filter. To clear a link filter, click Link Filter, 
choose All from the group drop-down box (to display all links), and click Apply and OK.

Figure 7-14 Links View 

1 Number of links represented by the single link in the map (in this example, 27 links).

2 Link endpoints.

3 List of all links represented by the link, including the link type, detail, and alarm status (color). 
This example shows 3 pseudowire links and one physical link. 

4 Hyperlink to the link properties window. The Properties button is available for physical, 
topographical, and service links, but is not available for business links (dashed links). See Viewing 
Link Status and Detailed Link Properties, page 7-25.
7-24
Cisco Prime Network 5.2 User Guide



  

Chapter 7      Viewing Devices, Links, and Services in Maps
  Viewing and Managing Links
Note the following:

• The context field may be empty if one side of the link is not included in the map, or the link is filtered 
out of all contexts. A blue background indicates an external link (a link with only one endpoint in 
the map or aggregation).

• The A End-Point is the element or site that is the source of the link; The Z End-Point is the 
destination. For unidirectional links, traffic is from A to Z.

Note If you load a map with many links (for example, thousands of links), it can take a while for the complete 
list of links to load. The filtering options in the table are unavailable until the table has completely 
loaded. 

The links view provides buttons that allow you to traverse among link levels, as follows:

Viewing Link Status and Detailed Link Properties

To view link details, click the link (it will turn blue), then right-click the link and choose Properties. As 
shown in Figure 7-15, the link properties window provides general information about the selected link, 
details of the link connection, and technology-specific information appropriate for the link. If multiple 
links exist between the elements or aggregations, the link properties window displays information for all 
the links. 

Table 7-1 Ways to Traverse Link Levels

To do the following: Do the following, or click icon:

View a link in a map Right-click link and choose 
Select Link in Map (link will be 
blue)

View all link properties (see Viewing Link Status and Detailed 
Link Properties, page 7-25)

Right-click link and choose 
Properties

Display all links the map or selected aggregation, including 
external links (All Links icon).

Display links that have only one side in the selected map or 
aggregation (External Links). (These are indicated with the blue 
background in the previous figure.)

Display links in the selected map or aggregation, excluding links 
in any closed aggregations (Flat Links).

Display for the selected aggregation and any nested aggregations 
with both endpoints in the map or aggregation (Deep Links). This 
is the default.
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Figure 7-15 Link Properties Window

The links listed on the left display the left and right link identifiers between the two nodes, the device 
alias, and the Connection Termination Point (CTP). When you select a link, the properties area is 
populated with extensive information about the selected link, most of which is self-explanatory. These 
items are especially important:

• Under General Properties, the type can be either dynamic or static.

– Dynamic links are real links between devices or aggregations.

– Static links are not real links, but are created by Prime Network advanced users to represent a 
real link (for example, when a real link is not discovered). Static links provide allow Prime 
Network to perform correlation flows through the link.

• Link status is displayed under the Connection Information.

Speed, port type, port admin and operational status, and other information is displayed for connections 
of types such as Ethernet CSMA/CD, Gigabit Ethernet, LAG, MLPPP, MP-BGP, MPLS Link 
Information, PPP, Pseudowire, T1, and VRF.

Users with advanced privileges can click Calculate Affected to see which resource pairs would be 
impacted by a problem with the link. (If the link had a ticket, the same information would be 
automatically generated and displayed in the ticket under the Affected Parties tab.) See Checking the 
Impact of Link Problems (Impact Analysis), page 7-27.
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These tools are provided for working with specific technologies:

• Labels—For Ethernet links, lists all LSPs and their source and destination labels. For more 
information, see Viewing LSPs Configured on an Ethernet Link, page 17-13. 

• VCs—For ATM links, lists configured and misconfigured VCs. For more information, see Viewing 
ATM VPI and VCI Properties, page 26-10.

Checking the Impact of Link Problems (Impact Analysis)
The Vision client provides a feature that, for a selected network link, calculates the elements that might 
be affected if the link were to go down. 

Note Impact analysis applies only to physical links.

To calculate impact analysis:

Step 1 Select a map or aggregation in the navigation pane, and click Show Links View in the main toolbar. The 
links view is displayed in the content pane. 

Step 2 In the table toolbar, click Link Filter. The Link Filter dialog box is displayed. For information about the 
Link Filter dialog box, see Using Link Filters to Find Links, page 7-21.

Step 3 In the Filter dialog box: 

a. In the Match drop-down list, choose All. 

b. In the field drop-down list, choose Link Type. 

c. In the operand drop-down list, choose Equals.

d. In the matching criteria drop-down list, choose Physical Layer. 

e. Click OK. 

Only physical links are displayed in the links view.

Step 4 In the links view, right-click the required link and choose Properties. The Topological Link Properties 
window is displayed.

Note Resize the window as needed to view all the information.
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Figure 7-16 Topological Link Properties Window

Step 5 Click Calculate Affected. The total number of potentially affected parties is displayed in the Affected 
Parties area.

Step 6 Click Show Affected. The Affected Parties window is displayed as shown in Figure 7-17. For 
information on the status (Potential, Real, Recovered), see Viewing a Ticket’s Affected Parties Tab 
(Resource Pairs), page 11-15.
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Figure 7-17 Affected Parties Window

Step 7 To view the potentially affected destinations if a link were go to down, click an entry in the Source table. 
The potentially affected destinations are displayed in the Destination table. 

Step 8 To view source or destination properties in inventory, click the required hyperlinked entry. 

Managing Missing Links (Static Links)
Prime Network allows you to create static links that do not perform any configuration or provisioning 
on a device or in the network. Static links are created in the Prime Network model and are not updated. 
Static links are useful for map visualization and network correlation; for example, if Prime Network 
does not discover a link that you know exists in the network, you can create a static link that is displayed 
in the map. For correlation purposes, Prime Network treats the static link as if it were a physical or 
logical link and allows correlation flows to go through the static link. Prime Network supports 10 or 100 
Gigabit Ethernet link between an ASR9K device and Cloud VNE. Only advanced users can create static 
links; see Permissions for Vision Client Links, page B-6. For information on creating static links, see 
Managing Missing Links (Static Links), page 7-29.

Link Discovery and Flickering Ethernet Topology Links

Prime Network discovers topology links using various protocols, such as STP, CDP, and LLDP. In some 
situations, the link configurations themselves can prevent Prime Network from discovering the correct 
information. For example, if Layer 2 protocol tunneling is configured and the discovery protocols are 
tunneled, Prime Network can create an incorrect link. This scenario results in a flickering link that is 
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first created incorrectly due to tunneled discovery information, and then disconnected when the Prime 
Network counters test discovers that the counters on the edges of the link do not match. During the next 
topology cycle, Prime Network recreates the link, which is disconnected again during the counters test. 

A link is considered flickering when it is connected, disconnected, and reconnected when using the same 
connection technique because the topology information is conflicting. When this situation occurs, Prime 
Network generates a system event with the message “Physical Link discovery inconsistent.”

To prevent an ongoing cycle of link creation and disconnecting, Prime Network detects such case of 
flickering links, creates a system event with the message “Inconsistent Physical Link Discovery between 
system:interface1 and system:interface2, and stops the link from flickering by disconnecting it. 

To remedy the situation, we recommend that you wait until the link disappears from the map and then 
create a static link. 

In addition, you can add a new link using the Administration client. For more information, see the 
Cisco Prime Network 5.2 Administrator Guide.

Adding a Static Link to a Map

Note Only advanced users can create static links. See Permissions for Vision Client Links, page B-6.

To create a static link, select a device or port and define it as the A side. Then define a second device or 
port as the Z side. Prime Network validates the new link after the two ports are selected. Validation 
checks the consistency of the port types (for example, RJ45 on both sides), and Layer 2 technology type 
(for example, ATM OC-3 on both sides). 

You can also create static links between Ethernet Link Aggregation Groups (LAGs) by choosing a LAG 
and the desired port channel for the A or Z side as described in the following procedure. 

When you add a new link, the color of the link reflects its current state. For example, if the operation 
status of a port is down, the link is colored red. You can add links from either a map or from an NE’s 
inventory window. 

Step 1 Right-click the required A Side device in the navigation pane or in a map, and choose Topology > Mark 
as A Side. 

Step 2 Right-click the required Z Side device or LAG in the navigation pane or properties pane to display the 
right-click menu and choose Topology > Mark as Z Side. The Create Static Link window is displayed 
as shown in Figure 7-18, so that you can select the ports to connect.
7-30
Cisco Prime Network 5.2 User Guide

http://www.cisco.com/c/en/us/support/cloud-systems-management/prime-network/products-maintenance-guides-list.html


  

Chapter 7      Viewing Devices, Links, and Services in Maps
  Viewing and Managing Links
Figure 7-18 Create Static Link Window

Step 3 Select the required port on both the A Side device and the Z Side device.

Step 4 Click Create to validate the connection and create the new link. 

A success message is displayed.

A warning message is displayed if any of the following apply:

• A validation check fails.

• The operation status of one port is Up and the other port is Down.

• The selected ports are not of the same type.

• The Layer 2 technology type is not the same.

• One of the ports is part of another link.

Adding a Link Using the Inventory Window

Step 1 Open the inventory window for the required A Side device.

Step 2 In the navigation pane, navigate to the required port or LAG.

Step 3 Right-click the required port or LAG and choose Topology > Mark as A Side. 

Step 4 Repeat Step 1 and Step 2 for the Z Side port or LAG.

Step 5 Right-click the required port or LAG and choose Topology > Mark as Z Side. A confirmation message 
is displayed.
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Step 6 Click Yes. 

The ports are connected, and a link is created between the selected ports.

A warning message is displayed if any of the following conditions exist: 

• One of the validation checks fails.

• The operation status of one port is Up and the other port is Down.

• The ports selected are not of the same type.

• The Layer 2 technology type is not the same.

• One of the ports is part of another link.

For information about removing a static link, see the Cisco Prime Network 5.2 Administrator Guide.

Making Changes to the Device Appearance in the Map
Maps present Prime Network’s model of your network devices and connections. This information is 
constantly updated in a variety of ways to keep the model current. It is important to understand when 
you are making a change to the Prime Network model of a device versus when you are making a change 
to an actual device. 

The following table lists actions you can perform from a map. These actions only affect the Prime 
Network model, not the real network element. Whether you can perform these actions depends on your 
permissions; see Permissions for Vision Client Maps, page B-2.

To do the following: Right-click the NE in a map and select:

Change the name of an NE Apply a business tag to the NE (seeLabelling NEs 
to Associate Them with Customers (Business 
Tags), page 4-9)

Add a virtual link between two devices so 
correlation can proceed through the link but no 
alarms are generated (for example, if a link goes 
down)

Right-click the device port or LAG and choose 
Topology (see Adding a Static Link When a 
Network Link is Missing, page 4-13)

Group the NE with other NEs in the map Create an aggregation (see Grouping Network 
Elements into Aggregations, page 4-7)

Change the location of an NE in a map Drag the NE to the desired location

Change the size of an NE icon Right-click the NE and choose Resize

Change the size of the text that is displayed with 
the NE icon

Changing Vision Client Default Settings (Sound, 
Display, Events Age), page 4-15

Do not display an acknowledged badge with NE 
icon when ticket is acknowledged

Only display severity status badge at NE icon 
level (not in NE inventory where event occurred)
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Prime Network provides many context-sensitive commands that you can use to make changes in the 
network. You can launch these commands by right-clicking an NE and choosing Commands. Your 
permissions determine whether you can run these commands, and the commands that are available 
depend on the device type, operating system, and if a service or technology is supported and enabled on 
the device. These commands are documented throughout this guide with the service or technology to 
which they apply. A complete list of commands, along with the devices that support them, is provided 
in Addendum: Additional VNE Support for Cisco Prime Network 5.2. You can also add support for new 
commands by downloading and installing Prime Network Device Packages (DPs). For information on 
DPs, see the discussion about adding new VNE support in the Cisco Prime Network 5.2 Administrator 
Guide. For information on commands that change basic NE properties (for example, SNMP 
configurations, port and interface properties, an NE’s DNS server, and so forth), see Drilling Down into 
the Properties of a Network Element, page 8-2. 

Adding and Removing NEs from Existing Maps
When you add an element to a map, the map is automatically saved in the Prime Network database. You 
can display all NEs by selecting Show All in Step 3, but devices you do not have permission to view are 
displayed with a lock icon; they are also not returned in search results.

To add an element to a map: 

Step 1 Choose File > Open and select a map from the map list.

Step 2 Choose File > Add to Map > element.

Figure 7-19 shows the type of elements you can add to maps.

Figure 7-19 Available Elements to Add to Maps

Note If you choose to add a new VPN, the Create VPN dialog box is displayed. For information on 
creating a VPN, see Creating a VPN, page 17-22. In all other instances, the Vision client 
presents a dialog box similar to Figure 7-20.
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Figure 7-20 Add Element Dialog Box

Step 3 Use one of the following tools to locate the NEs you want to add to the map. 

• Search for the elements you want to add to the map. For example, you can search Ethernet Services 
by the system name, NEs element type, pseudowires by their role, and so forth. 

Note If you are working with a large number of NEs, use the search filter. Otherwise, it may take 
some time for all of the NEs to be listed.

• To view all available elements, choose Show All. If you do not have permission to view an NE, it is 
shown with a lock icon.

The available elements are displayed in the dialog box in table format. The dialog box also displays the 
date and time at which the list was generated. To update the list, click Refresh.

Step 4 Select the elements that you want to add.

Step 5 Click OK. If you selected a large number of elements (for example, more than 25 VLANs or VPLS 
instances), the action may take a while to complete.

The NEs are added to the map and are displayed in the navigation pane and content area. In addition, 
any associated tickets are displayed in the ticket pane.
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Removing Elements from a Map 

When you delete an element from a map, it is removed from the map in the database. However, it 
continues to be managed by Prime Network. Your user account permissions determine whether you can 
remove items from a map. 

To remove a network element from a map, right-click the NE and choose Remove from Map.

Grouping NEs Using Aggregations
Drilling Down Into NE Groups (Aggregations), page 7-16, explains how to traverse between nested 
aggregations—that is, aggregations that contain other aggregations. Aggregations can contain network 
elements, services, other aggregations, and so forth. 

Note If you cannot create an aggregation, you either do not have sufficient privileges or the device is not in 
your scope. See Permissions for Vision Client NE-Related Operations, page B-4.

To aggregate network elements:

Step 1 Select multiple NEs and aggregate them by choosing Node > Aggregate.

Step 2 In the Aggregation dialog box, enter a unique name for the aggregation and click OK. The aggregation 
is displayed in the navigation pane and the map pane. Aggregations are displayed as a single entity with 
the aggregation icon and a plus sign, as in the following two examples:

The aggregation icon changes color according to the alarm severity. For more information about severity 
colors, see Interpreting NE Icons, Badges, and Colors, page 7-4.
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Making Changes to Aggregations

This table shows how to make changes to aggregations:

Closing Maps, Renaming Maps, and Other Map Operations

Note If you cannot perform these tasks, you do not have sufficient privileges.

If you want to... Do this...

Add an NE to an aggregation (certain 
restrictions exist; for example, you cannot 
add an EVC to a VLAN)

1. Double click the thumbnail frame so only the 
aggregation is displayed.

2. Select File > Add to Map and select the NE. You can 
choose NEs that are not in the parent map (the NE 
will have a dotted grey border around it).

Remove an NE from an aggregation 1. Double click the thumbnail frame so only the 
aggregation is displayed.

2. Right-click the device you want to remove and 
choose Remove from Map. The device is removed 
from the aggregation but not the parent map.

Ungroup (disaggregate) an aggregation 
(nested aggregations will be moved up one 
level)

1. Go to the parent map level. (If you are in a thumbnail, 
double-click the thumbnail background.)

2. Right-click the aggregation and choose 
Disaggregate. 

To perform this operation: Choose or do the following:

Close a map File > Close

Rename a map File >Save as New Map

or

1. Select File > Open.

2. From the Open Map Dialog, select the map and click 
Rename Map in the toolbar.

Save a map’s appearance File > Save Map

Save the map as an image File > Save as Image

Print the map File > Print

Display all maps that include a specified 
NE

Right-click an NE in a map and choose Open Relevant 
Maps

Delete a map from the Vision client and 
Prime Network database

1. Select File > Open.

2. From the Open Map Dialog, select the map and click 
Delete from Map in the toolbar.
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Changing the Vision Client Default Behavior
All users can change their Vision client defaults. The defaults apply only to the client machines—that 
is, the machine from which you launch the Vision client. You can change:

• What is displayed when you start the Vision client

• Audio alerts and sounds

• NE text (font sizes, whether you can label NEs with business tags)

• Ticket severity information that is displayed with an NE icon

• Age of tickets that are displayed in the Vision client

To change these settings, see Changing Vision Client Default Settings (Sound, Display, Events Age), 
page 4-15.
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