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Setting Up Vision Client Maps

Vision client maps display devices and their physical and logical relationships, including relationships 
with logical NEs such as services. From a map, users can drill down into both the physical and logical 
NE details and perform other operations, such as launching command scripts and external applications. 
These topics explain how to set up maps:

• Workflow for Creating a Map, page 4-2

• Creating a New Map and Add NEs to the Map, page 4-3

• Applying a Background Image To a Map, page 4-12

• Grouping Network Elements into Aggregations, page 4-7

• Labelling NEs to Associate Them with Customers (Business Tags), page 4-9

• Adding a Static Link When a Network Link is Missing, page 4-13

• Changing Vision Client Default Settings (Sound, Display, Events Age), page 4-15

• Changing You Vision Client Password, page 4-16

Whether you can perform these setup tasks depends on your account privileges. See Vision Client 
Permissions, page B-1 for more information.
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Workflow for Creating a Map
Use maps to highlight different segments of your environment. For example, you could create one map 
to display the BGP architecture and relationships between NEs, and another map to display the physical 
connectivity of the network. You can create maps that cover specific network segments, customer 
networks, services, or any other mix of network elements required. Network maps provide a graphic 
display of active faults and alarms and serve as access points for activating services. When you create a 
map, it is saved in the database and made available to other users if they have sufficient access and 
security privileges. When you delete a map, it is removed from the database.

You can only perform these tasks if you have the required privileges. See Vision Client Permissions, 
page B-1.

The following table provides the basic workflow for setting creating maps.

After creating a map and adding devices to it, you can view the NE properties as described in Opening 
Maps, page 7-2.

Description See:

Step 1 Launch the Vision client and create an empty map using a 
name that reflects the map purpose, and add elements or 
services to the map.

Creating a New Map and Add NEs to 
the Map, page 4-3

Step 2 Apply optional customizations to the map:

Group NEs into aggregations, which are displayed as a single 
entity by default (but can be opened for NE details).

Grouping Network Elements into 
Aggregations, page 4-7

Apply a layout or drag NEs to a desired layout Applying a Layout to a Map, page 4-7

Label important NEs by creating and applying business tags, 
allowing users to search for NEs using labels created for your 
deployment’s needs.

Labelling NEs to Associate Them with 
Customers (Business Tags), page 4-9

Apply background images to maps. Applying a Background Image To a 
Map, page 4-12

Step 3 Create logical links to ensure that correlation flows are not 
interrupted.

Adding a Static Link When a Network 
Link is Missing, page 4-13

Step 4 Adjust Vision client settings that affect maps (audio alarms, 
display defaults, and so forth).

Changing Vision Client Default Settings 
(Sound, Display, Events Age), 
page 4-15

Step 5 (Optional) Create ticket (or event) filters and save them so 
you can use them as needed. 

Table 11-2Regular and Resynced 
Events Processing, page 11-6

Step 6 Check the global settings that can impact map operations (for 
example, whether users can view maps created by others).

Check Global Settings for Vision Client 
Maps, page 4-14

Step 7 (Optional) Extend the Vision client to model and display 
additional NE properties; support new devices, software 
versions, and modules; display commands that users can 
launch from an NE’s right-click menu; launch external 
applications; integrate with northbound applications; and 
many other customizations.

Extending Prime Network Features, 
page 2-6
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Creating a New Map and Add NEs to the Map
Naming Your Maps

The name you assign a map is a significant way to organize the NEs in your network. Use these guide 
5.1 when naming maps:

• Give each map a specific function. For example, do not mix network and service elements together 
in a map.

• Give each map a name that reflects the map function, such as:

– Core Devices for a network map named 

– MPLS for a service map named 

Step 1 Launch the Vision client.

Step 2 To create a new map, choose File > New Map in the Vision client main menu and enter a map name that 
reflects the map function. To add elements to the map, do one of the following:

Creating a Service Map

This procedure explains how to locate services in the network so you can add them to a map. When 
Vision client users open the map, they will only be permitted to view a service if the NE associated with 
the service is in their device scope.

If you have a very large network, you can alternatively generate a service report by choosing Reports > 
Run Report > Network Service Reports and choosing Ethernet Services, Pseudowire, or VPLs.

If You Are Using 
Prime Network: Launch the Vision client by choosing:

As part of suite Assure > Prime Network > Vision from the REPLACE main menu bar

As a standalone 
application

Start > Programs > Cisco Prime Network > Cisco Prime Network Vision 
from your local machine

For this map function: Examples See:

A map of services in the 
network

Cross connects, Ethernet services, MPLS-TP 
tunnels, pseudowires, unassociated bridges, 
VLANs, VPLs, VPNs

Creating a Service Map, 
page 4-3

A map of the network’s 
physical topology

Core devices with their physical links Creating a Physical 
Topology Map, 
page 4-4

A map of NEs that are 
connected using a specific 
type of link

Data links: ATM, Frame Relay

Tunneling: GRE, Layer 2 TP, pseudowires, 
MPLS-TE, GRE Tunnels

Protocol architectures: BGP

Creating a 
Special-Purpose Map, 
page 4-5
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Step 1 Choose File > New Map, and enter a map name that reflects the service.

Step 2 Click the tab for your new map and choose File >Add to Map. The following figure shows the service 
types you can choose.

If you choose VPN > New, the Create VPN dialog box is displayed. For information on creating a VPN, 
see Creating a VPN, page 17-22.

Step 3 Choose a service (such as VPLS) and Prime Network displays all services of that type.

Step 4 If you are working with a very large number of NEs that are affected by the services, click Search. The 
search criteria depends on the entity type. For example, you can search for Ethernet Services by the 
system name, pseudowires by their role, and so forth. 

Step 5 Choose the services and click OK.

Creating a Physical Topology Map

This procedure explains how to locate physical NEs in the network so you can add them to a map. When 
a Vision client user opens the map, they will be able to see the map devices, but devices outside their 
device scope will be displayed with a lock icon.

If you have a very large network, you can alternatively generate a service report by choosing Reports > 
Run Report > Inventory Reports and choosing a hardware report.

Step 1 Choose File > New Map, and enter a map name that reflects the map purpose (such as Core Devices).

Step 2 Choose File >Add to Map > Network Elements. 

Step 3 Click Search to find NEs by their vendor, element type, IP address, and so forth; or click Show All to 
list all NEs. A locked device icon means the device is not in your scope. For example, to find all 
Cisco 7600 series routers, click the Filter button, choose Element Type as your filter criteria, and enter 
76 in the text box.
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Step 4 Choose the NEs and click OK.

Creating a Special-Purpose Map

You can create a special-purpose map by selecting specific link types for your map, such as a map that 
shows all the BGP links in the network.

Tip Do not mix logical and physical links into one map because they can be displayed the same way. Link 
types can only be ascertained by hovering the mouse over the link.

By default, Vision client users will only be able to view links if both link endpoints are in their device 
scope. (This can be changed using the Registry Controller; see the Cisco Prime Network 5.1 
Administrator Guide.)

Keep in mind that this procedure effectively filters in or filters out certain link types. If subsequent users 
want to filter the map, the links offered for filtering are limited to what you specify in this procedure.

Step 1 Choose File > New Map, and enter a map name 

Step 2 In the Create Map dialog box, and click Advanced. The Link Filter dialog displays link types, as shown 
in Figure 4-1. 
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Figure 4-1 Link Filter Dialog

These are some examples of what you can create using the various link types:

• Process map with all BFD links

• Traffic map with all Frame Relay links

• Tunnel map with all GRE tunnels

The link type also determines the algorithm Prime Network will use for the may layouts (symmetrical, 
orthogonal, and so forth).

Step 3 Check the link type you want to include in your map and click Apply to apply the defined link filter 
settings and continue with more selections.

Step 4 Click OK when you have completed your selections. 

Step 5 In the Create Map dialog box, enter a name for the new map and click OK. An empty new map is 
displayed in the navigation pane and content area, and the map toolbar displays the Link Filter Applied 
button, which indicates that a link filter is currently applied to the map. 

Step 6 Add the required elements to the map by choosing Choose File >Add to Map.

Indicates a link filter is currently applied to the map. If you want to clear the filter, click 
this icon and choose None from the Group drop-down list.
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Grouping Network Elements into Aggregations
An aggregation is a group of NEs. You specify the NEs to add to the group, and then name the 
aggregation as needed. These are some examples of ways to use aggregations:

• Group NEs that are in a logical segment of the network

• Group NEs located in a geographical fragment of the network.

• Group NEs that have the same device type or role

Note You cannot aggregate service entities that exist within a service. For example, you cannot aggregate 
VRFs that exist within a VLAN. 

To aggregate network elements, follow this procedure. The aggregation name can include Chinese 
characters.

Step 1 Select multiple NEs by pressing Ctrl.

Step 2 Aggregate the network elements by choosing Node > Aggregate.

Step 3 In the Aggregation dialog box, enter a unique name for the aggregation and click OK. The aggregation 
is displayed in the navigation pane and the map pane. The aggregation icon changes color according to 
the alarm severity. For more information about severity colors, see Severity Icons and Colors for Events, 
Tickets, and NEs, page A-15.

Applying a Layout to a Map
The Vision client provides four standard layouts that you can apply to your map. The layout determines 
how the topology should be displayed: Circular, hierarchical, orthogonal, or symmetric. By default, 
maps use a circular topology. To select a layout, choose View > Layout from the main menu. You can 
also move individual NEs as desired. When you have finished, choose File > Save Map.

The following screen shots provide examples of the same map using the different layouts.
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Figure 4-2 Hierarchical Map Layout

Figure 4-3 Circular Map Layout (The Default Layout)
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Figure 4-4 Orthogonal Map Layout

Figure 4-5 Symmetrical Map Layout

Labelling NEs to Associate Them with Customers (Business 
Tags)

A business tag is a string that is meaningful to the business, and which can be used to label a component 
of a network element for use in Prime Network screens and reports. Figure 4-6 shows two devices with 
a business tag named ABC Company. 
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Figure 4-6 Find Business Tag Dialog Box With Results

Business tags are normally applied to business elements, which are constructions or organizations of 
certain network elements and their properties into a logical entity (such as Layer 2 VPNs, Layer 3 VPNs, 
and virtual routers). You can also apply business tags to individual entities, such as a single port or 
interface. Business tags allow you track business elements and individual entities in a way that makes 
sense from your business perspective. For example, a business tag might identify a new subscriber to a 
port, or other information that is relevant in your environment. 

Note Business tags support Chinese characters, but your system must be properly configured to support this. 
See the Cisco Prime Network 5.1 Installation Guide.

By default, business tags replace the NE name. If you want to change this setting, or disable business 
tags completely, see Changing Vision Client Default Settings (Sound, Display, Events Age), page 4-15.

Step 1 Right-click the required network object and choose Attach Business Tag. 
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Step 2 Enter the information for the business tag in the Attach Business Tag dialog box:

Step 3 Figure 4-7 provides an example. (After the tag is attached, the Vision client allows you to search for 
business tags based on type or on partial strings that appear in the Unique Key, Name, and Notes fields.

Figure 4-7 Attach Business Tag Dialog Box

Step 4 Click Save. The business tag is attached to the network object and displayed throughout the Vision 
client. A new Business Tag tab is also added to the device’s inventory window, as shown in Figure 4-8. 
(The tab is displayed when you select the entity that contains the business tag.)

Field Description

Unique Key A letter or number string that identifies the entity throughout the deployment. For 
example, if three devices have the ABC Company business tag, you could use 
abc1, abc2, and abc3.

Name Name that is displayed in the clients. Names are case-sensitive.

Type Subscriber, Provider Connection, or Label.

Note If you select Label, the name of the network object changes to display the 
business tag name if the Replace name with Business Tag option is selected 
in the Options dialog box (Tools > Options). For more information about 
display options, see Changing Vision Client Default Settings (Sound, 
Display, Events Age), page 4-15.

Notes Text-free message.
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Figure 4-8 Vision Cllient Device Inventory—Business Tag Tab

You can edit or delete business tags by right-clicking them and using the appropriate command.

Applying a Background Image To a Map
You can apply GIF, JPG/JPEG, and PNG images as a map background. Subordinate windows (such as a 
detailed view of an aggregation) can use the same or a different image. 

Step 1 Navigate to the required map in the Vision client. 

Step 2 Right-click the map background and choose Set Map Background. 

Step 3 In the Manage Map Background dialog box, provide the following information. 

Table 4-1 Manage Map Background Options

Field Description

Select Image Applies the selected image to the current map background: 

1. Choose Select Image. 

2. Click Browse. 

3. In the Open dialog box, select the desired image and click OK. 

4. Click OK in the Manage Map Background dialog box.

Use Image From 
Upper Level

Indicates whether the selected subordinate map should use the same image as the 
parent map or a different image: 

• To use the same image, choose Use Image from Upper Level. 

• To use a different image, choose Select Image and complete the steps.

Remove Image Removes the current image from the map background. 
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Step 4 Click OK. The current map background is updated as specified. 

Step 5 To retain the background image for subsequent logins, choose File > Save. 

Adding a Static Link When a Network Link is Missing
If Prime Network does not discover a link that you know exists in the network, you can create a static 
link that will be displayed in the map, but exists only at the model level. This allows correlation flows 
to go through the links, as if they were real physical or logical links. Static link properties are not updated 
because the links do not really exist in the network, but the link will change color under certain 
conditions, such as when a port is down.

You can also use static links to create a link between a device and an unmanaged network, or to connect 
a tunnel to a VPN.

Static links are created between a device or port on the A side, and a device or port as the Z side. Prime 
Network validates the new link by checking the consistency of the port types (for example, RJ45 on both 
sides), and Layer 2 technology type (for example, ATM OC-3 on both sides). You can also create static 
links between Ethernet Link Aggregation Groups (LAGs) by choosing a LAG and the desired port 
channel for the A or Z side as described in the following procedure. 

Step 1 Right-click the required A Side device in the navigation pane or in a map, and choose Topology > Mark 
as A Side. (You can also perform this operation from the inventory window.)

Step 2 Right-click the required Z Side device or LAG in the navigation pane or properties pane to display the 
right-click menu and choose Topology > Mark as Z Side. The Create Static Link window is displayed 
as shown in Figure 4-9, so that you can select the ports to connect.
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Figure 4-9 Create Static Link Window

Step 3 Select the required port on both the A Side device and the Z Side device.

Step 4 Click Create to validate the connection and create the new link. 

For information about removing a static link, see the Cisco Prime Network 5.1 Administrator Guide.

Check Global Settings for Vision Client Maps
The following map behavior is controlled from the Administration client:

• The Vision client actions users can perform, and the devices users can view and manage. When a 
user account is created, the administrator assigns:

– A user access level to the user account (Viewer, Operator, Operator Plus, Configurator, or 
Administrator). It controls what actions the user can perform using the Vision client, such as 
adding and removing NEs from a map, or applying a background image to a map.

– One or more device scopes. Device scopes determine which devices a user has permission to 
access, and the actions a user can perform on those devices. For example, a user might have 
sufficient privileges to add a device to a map, but the user can only do so if the device is in their 
device scope. 

For a matrix of actions users can perform depending on their user access level and device scope 
assignments, see Vision Client Permissions, page B-1.
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• Which maps users are permitted to use. By default, Vision client users can view all maps made by 
other users. Administrators can instead control which maps users can see using the Registry 
Controller.

• Whether users can view links with only one endpoint in their device scope. By default, users will be 
permitted to see links only if both link endpoints are in their scope.

Users with Administrator privileges can change these settings by following the directions in the Cisco 
Prime Network 5.1 Administrator Guide. For information on fault-related settings that affect all of the 
Prime Network clients, see Changing Vision Client Default Settings (Sound, Display, Events Age), 
page 4-15.

Changing Vision Client Default Settings (Sound, Display, Events 
Age)

All map users can adjust these Vision client options. Changing these options applies only to the client 
machine (that is, the machine from where the client is launched).

These options control which items are displayed in maps, how items are displayed in maps, whether to 
use audio sounds, and when to remove NE tickets and events from the map. To change them, choose 
Tools > Options from the main menu.

To Do the Following: Select the following from Tools > Options Default

When Vision client 
starts, display Open 
Map dialog with last 
maps viewed

Startup tab—Load Workspace on Startup Enabled 

Change NE Label 
Font Size

Display tab—Map Labels Font Size 30pt

Change what severity 
information is 
displayed with NE 
icons

Severity tab—Show Severity Text Enabled

Severity tab—Show Acknowledged Enabled

Severity tab—Show Propagated Enabled

Change how labels 
(business tags) are 
displayed
(choose one)

Display Name tab—Do not use business tags Disabled (tags 
are enabled)

Display Name tab—Add business tags to name Disabled (tag 
replaces name)

Display Name tab—Replace name with business tag Enabled
4-15
Cisco Prime Network 5.1 User Guide

http://www.cisco.com/c/en/us/support/cloud-systems-management/prime-network/products-maintenance-guides-list.html
http://www.cisco.com/c/en/us/support/cloud-systems-management/prime-network/products-maintenance-guides-list.html
http://www.cisco.com/c/en/us/support/cloud-systems-management/prime-network/products-maintenance-guides-list.html
http://www.cisco.com/c/en/us/support/cloud-systems-management/prime-network/products-maintenance-guides-list.html
http://www.cisco.com/c/en/us/support/cloud-systems-management/prime-network/products-maintenance-guides-list.html
http://www.cisco.com/c/en/us/support/cloud-systems-management/prime-network/products-maintenance-guides-list.html


  

Chapter 4      Setting Up Vision Client Maps
  Changing You Vision Client Password
Changing You Vision Client Password
Users can change their own Vision client passwords at any time by selecting Tools > Change User 
Password from the Vision client main menu. You may be required to change your password on a regular 
basis according to the password rules set by the Administrator.

Enable or disable 
audio alerts and 
control audio sounds

Audio tab—Enable Audio Response for Alarm Disabled

Audio tab—Critical, Major, Minor
If audio is enabled, specifies .wav file for sound.

(see client)

Audio tab—Loop Sound on Critical Alarm
If audio is enabled, continuously plays .wav file for critical 
event.

Disabled

Control how long 
events are displayed in 
inventory window

Maximum age of events to display in the Tickets and Latest 
Events tabs. To only display active events, enter 0 (zero). The 
default (6 hours) is controlled from the Administration client 
client. 

Note Prime Network also has a limit of 15,000 events that 
can be sent from the server to clients. Older events 
are purged when either the maximum age or the 
maximum number of events is exceeded. The purging 
mechanism runs once per minute.

6 hours 

To Do the Following: Select the following from Tools > Options Default
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