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Finding Available Network Paths Using 
PathTracer

Cisco PathTracer uses Prime Network’s inner logic to show available paths between two network 
elements. It creates a virtual path, without modifying any real network elements, and shows all devices 
and components the path flows through, including performance data. 

The following topics describe Cisco PathTracer and how to use it: 

• Cisco PathTracer, page 13-1

• Launching Path Tracer, page 13-2

• Viewing Path Traces, page 13-12

• Saving and Opening Cisco PathTracer Map Files, page 13-17

• Saving Cisco PathTracer Counter Values, page 13-17

• Rerunning a Path and Comparing Results, page 13-18

• Viewing Q-in-Q Path Information, page 13-18

• Viewing L2TP Path Information, page 13-19

• Using Cisco PathTracer in MPLS Networks, page 13-20

Cisco PathTracer
Cisco PathTracer enables you to launch end-to-end route traces and view related performance 
information for Layer 1, Layer 2, and Layer 3 traffic. Upon receiving a path's start and endpoint, 
Cisco PathTracer visually traces the route through the network. For example, in an ATM network 
environment, Cisco PathTracer identifies all information regarding the connection of a subscriber to a 
provider, including all ATM PVCs, ATM switching tables, ATM class of service (CoS) definitions, 
IP-related information, and so on. 

You can also use Cisco PathTracer to: 

• Trace paths using IPv4, IPv6, or both IPv4 and IPv6 addresses for the source and destination.

• Trace a hypothetical Ethernet frame from a VLAN interface to a specified MAC address.

• Trace a hypothetical Ethernet frame from an Ethernet interface to a specified MAC address within 
a specific VLAN identifier.
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In MPLS and Carrier Ethernet environments, Cisco PathTracer can trace paths across: 

• Carrier Supporting Carrier (CSC) configurations—A path trace along a CSC flow follows the path 
from the customer CE through the customer carrier VPN, across the customer backbone carrier 
VPN, back to the customer carrier VPN, and to the destination CE.

• VLANs—A path trace across VLANs follows the path based on the forwarding table, which means 
that the trace follows ports in the Forwarding STP state.

• Q-in-Q—A path trace across Q-in-Q creates a single path trace (if the MAC address is learned) or a 
multiple-path (multipath) trace if the MAC address is not in the forwarding table. If the VLAN 
bridge has not learned a given MAC address, the bridge floods the Ethernet frame to the confines of 
a given VLAN or switching entity and across those ports that allow the given VLAN identifier. A 
MAC/VLAN path trace can be conducted from a customer edge (CE) VLAN interface across a 
service provider (SP) VLAN; that is, across Q-in-Q configurations with the CE-VLAN identifier as 
the inner VLAN identifier and Cisco PathTracer detecting the outer SP-VLAN identifier that 
encapsulates the CE-VLAN.

• Pseudowires (also known as EoMPLS)—A MAC/VLAN path trace can be conducted from a VLAN 
interface across a VLAN attachment to a pseudowire.

• VLAN-VPLS-VLAN configurations—A multiple-point MAC/VLAN path trace can be conducted 
on CE-VLANs across a service provider VPLS transport from a VLAN interface that attaches to the 
VPLS.

In addition, Cisco PathTracer can trace a path: 

• If the destination MAC address is not reachable—If Cisco PathTracer cannot complete a 
MAC/VLAN path trace to a specified destination MAC address across an MPLS core, VPLS, or 
H-VPLS, then Cisco PathTracer displays the portion of the path that Cisco PathTracer can trace 
toward the destination MAC address.

• That contains a simulated Ethernet frame—Cisco PathTracer can trace a simulated Ethernet frame 
from a VLAN port, across a VLAN (VLAN-based flow domain fragment), VPLS (VPLS-based flow 
domain fragment), and VLAN, for an end-to-end MAC address trace.

Prime Network derives the various paths on the network from its up-to-date knowledge of the network. 
After a user selects a source and destination, Cisco PathTracer finds and retrieves the path of a specified 
service, and displays the path in the Cisco PathTracer window. The retrieved information contains 
network elements in the path, including all properties at Layer 1, Layer 2, and Layer 3, plus alarm 
information, counters, and more, all of which is available via Cisco PathTracer.

Launching Path Tracer 
Cisco PathTracer can be launched from a bridge, switching entity, Ethernet interface, Ethernet flow 
point, VLAN interface, ATM VC, DLCI, or IP interface entry point. Ethernet flow points can be starting 
points whether they are associated with an interface, bridge, or LAG. 

The virtual route is found according to the cross connect table of each ATM switch or Frame Relay 
device. The IP routing and path-finding process is enabled according to the VRF tables of each router, 
and the Ethernet-simulated path is found according to the various Layer 2 forwarding tables, such as 
bridges or VSIs. 

To view a specific path, you must specify an initial point and a destination, such as an IP or MAC 
address. If you specify VC or DLCI information, which ends in a router, Cisco PathTracer finds the next 
hop according to the destination IP address. If you do not specify a destination IP or MAC address, 
Cisco PathTracer uses the default gateway in the router. Any business tags that are associated with the 
physical or logical entities are also displayed. 
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Note A path can also be launched if a business tag attached to an endpoint that can be used as the starting 
point.

Path Traces and Blocked Ports

The following conditions apply for blocked ports: 

• You can launch a path trace from a blocked port. This action is equivalent to launching a path trace 
from a bridge.

• You can specify a blocked port as a destination. 

• If Cisco PathTracer encounters a blocked port in its path to the destination, the path trace stops. Path 
traces do not traverse blocked ports. 

Table 13-1 identifies the available path trace launching points and their locations within the Vision 
client. Cisco PathTracer is available in each location as a right-click menu option. 

Supported Launch Points for Cisco PathTracer
Cisco PathTracer is launched by using right-click menu options. Table 13-1 identifies the launching 
points for the different types of elements. 

Table 13-1 Cisco PathTracer Right-Click Menu Options

Element Location

Affected Parties • Inventory window

• Ticket Properties window (Affected Parties tab)

Bridge Inventory window

Business tag The path can be found using a business tag, which is attached to the 
VPI/VCI, or using an IP interface by entering its key. The path can 
then be opened from the Find Business Tag dialog box.

Ethernet flow point • Map view or navigation pane

• Inventory window

IP interface • Inventory window

• Affected entry

Layer 2 MPLS tunnel Inventory window

MPLS-TE tunnel Inventory window

MPLS-TP tunnel endpoint • Map view or navigation pane

• Inventory window

Port Inventory window

Pseudowire endpoint • Map view or navigation pane

• Inventory window

Site Map view

Switching entity Map view
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Starting a Path Trace
To start a path trace:

Step 1 Start the path trace in one of the following ways:

Note If you select an IP interface as the launch point, the right-click menu displays IPv4 and IPv6 
options. These options are enabled or dimmed, depending on whether the IP interface has an 
IPv4 IP address, an IPv6 address, or both IPv4 and IPv6 addresses. For an example, see 
Figure 13-3.

Virtual connection Inventory window:

• Cross Connect window

• VC Table window

VLAN • Navigation pane

• Map view

Table 13-1 Cisco PathTracer Right-Click Menu Options (continued)

Element Location

Launch Point Steps

VLAN (from 
map view)

1. Double-click a VLAN to view its entities. 

2. Right-click the required item and choose PathTracer > From Here to 
Destination or PathTracer > Start Here.

VPN (from 
map view)

1. Double-click the VPN to view its entities.

2. Right-click the site and choose PathTracer > From Here to Destination or 
PathTracer > Start Here.

Ethernet Flow 
Point (from 
map view)

1. Choose Network Inventory > Ethernet Flow Domains.

2. In the Ethernet Flow Domain List Properties window, double-click the required 
domain. 

3. In the Ethernet Flow Domain Properties window, right-click the required element 
and choose PathTracer > From Here to Destination or PathTracer > Start 
Here.

NE physical or 
logical 
inventory

1. Right-click one of the following:

– IP interface

– MPLS-TP tunnel endpoint

– Port

– Pseudowire endpoint

– VLAN bridge

2. Choose PathTracer > From Here to Destination or PathTracer > Start Here.
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Step 2 If you choose PathTracer > From Here to Destination, complete the Path Information dialog box 
(Figure 13-1). 

Figure 13-1 Path Information Dialog Box 

a. In the Path Information dialog box, enter the required information. The contents depend on your 
launch point.

b. Click OK. 

Step 3 If you choose Start Here, navigate to the destination interface, port, or bridge, right-click it, and choose 
End Here. The Cisco PathTracer window is displayed showing the path or paths that were found. 

Step 4 To view additional details regarding the path traces, select one or more paths in the paths pane. 

Step 5 In the toolbar, click Cisco PathTracer. 

• If you select one or more paths in the paths pane, each selected path is displayed in its own window 
with the Layer 1, Layer 2, Layer 3, and Business Tag tabs.

• If you select nothing in the Paths pane, each path found is displayed in its own window with the 
Layer 1, Layer 2, Layer 3, and Business Tag tabs.

For more information about the end-to-end path and networking layer details, see Saving and Opening 
Cisco PathTracer Map Files, page 13-17.

Field Description

Destination IP Specify an IPv4 or IPv6 address.

Destination MAC MAC address

VLAN ID VLAN identifier (you must enter an IP address or a MAC address)

Inner VLAN ID Inner VLAN identifier

Stop trace after Check this check box to enter a maximum of hops that Cisco PathTracer makes 
in its attempt to reach the destination
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Examples of Launching Cisco PathTracer 
The following topics provide examples for launching Cisco PathTracer from different locations in the 
Vision client: 

• Using an Ethernet Flow Point, page 13-6

• Using an IP Interface, page 13-7

• Using a VLAN Bridge, page 13-8

• Using an Ethernet Port, page 13-9

• Using a Pseudowire, page 13-10

• Using an MPLS-TP Tunnel Endpoint, page 13-11

Using an Ethernet Flow Point

A network VLAN is required for you to start a path trace using an Ethernet flow point. 

To launch a path trace from an Ethernet flow point: 

Step 1 In the Vision client navigation pane or map pane, expand the required network VLAN. 

Step 2 In the VLAN, right-click the required Ethernet flow point and choose PathTracer > From Here to 
Destination. The Path Information dialog box is displayed as shown in Figure 13-2. 

Figure 13-2 Ethernet Flow Point Path Trace Launch Point
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Step 3 Specify the destination. 

Step 4 To limit the number of hops for the path trace, check the Stop trace after check box, and enter the 
maximum number of hops for the path trace.

Step 5 Click OK. The Cisco PathTracer window is displayed with the resulting path trace.

Using an IP Interface

Both IPv4 and IPv6 addresses are supported as valid path trace sources and destinations as illustrated in 
the following procedure.

Step 1 In logical inventory, right-click the required IP interface (Logical Inventory > Routing 
Entities > Routing Entity > ip-interface).

The right-click menu displays IPv4 and IPv6 options. These options are enabled or dimmed, depending 
on whether the IP interface has an IPv4 address, an IPv6 address, or both IPv4 and IPv6 addresses. See 
Figure 13-3. 

Figure 13-3 IP Interface Path Trace Launch Point - Right-Click Menu

Step 2 Choose PathTracer > From Here to Destination. The Path Information dialog box is displayed as 
shown in Figure 13-4.
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Figure 13-4 IP Interface Path Trace Launch Point - Path Information Dialog Box

Step 3 In the Destination IP field, enter the IPv4 or IPv6 address. 

Step 4 To limit the number of hops for the path trace, check the Stop trace after check box, and enter the 
maximum number of hops for the path trace.

Step 5 Click OK. 

Using a VLAN Bridge

You can launch path traces from VLAN bridges. Additionally, MAC addresses in the VLAN bridge 
forwarding table can be path trace destinations. 

Step 1 In logical inventory, right-click the required bridge (Logical Inventory > Bridges > bridge) and choose 
one of the following options as shown in Figure 13-5: 

• PathTracer > From Here to Destination 

• PathTracer > Start Here 
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Figure 13-5 VLAN Bridge Path Trace Launch Point

Step 2 If you choose From Here to Destination in Step 1, the Path Information dialog box is displayed. 
Specify the required destination.

Step 3 If you choose Start Here, navigate to the destination, right-click it, and choose End Here. Destination 
options include: 

• IP interface—Logical Inventory > Routing Entities > Routing Entity > IP-interface

• Bridge—Logical Inventory > Bridges > bridge

• MAC address—Logical Inventory > Bridges > bridge > Bridge Table > MAC-address 

• Ethernet port—Physical Inventory > chassis > slot > port 

When a destination is selected, the system extracts the relevant IP address from this point and uses it as 
the destination.

Using an Ethernet Port

To launch a path trace from an Ethernet port: 

Step 1 In physical inventory, right-click the required port (Physical 
Inventory > Chassis > slot > subslot > port) and choose one of the following options as shown in 
Figure 13-6:

• PathTracer > From Here to Destination 

• PathTracer > Start Here 
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Figure 13-6 Ethernet Port Path Trace Launch Point 

Step 2 Depending on your choice in Step 1, specify the required destination information or select the path trace 
endpoint. 

The Cisco PathTracer window appears, displaying the resulting path trace.

Using a Pseudowire

To launch a path trace from a network pseudowire endpoint: 

Step 1 In the navigation pane or map pane, expand the required network pseudowire. 

Step 2 Right-click the required pseudowire endpoint and choose PathTracer > From Here to Destination. 

The Path Information dialog box is displayed as shown in Figure 13-7. 
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Figure 13-7 Path Information Dialog Box for a Network Pseudowire

Step 3 Specify the destination. 

Step 4 To limit the number of hops for the path trace, check the Stop trace after check box, and enter the 
maximum number of hops for the path trace.

The Cisco PathTracer window appears, displaying the resulting path trace.

Using an MPLS-TP Tunnel Endpoint

To launch a path trace from an MPLS-TP tunnel endpoint: 

Step 1 In the navigation pane or map pane, expand the required MPLS-TP tunnel. 

Step 2 Right-click the required MPLS-TP tunnel endpoint and choose PathTracer > From Here to 
Destination. 

The Path Information dialog box is displayed as shown in Figure 13-8. 
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Figure 13-8 MPLS-TP Tunnel Endpoint Path Trace Launch

Step 3 Specify the destination. 

Step 4 To limit the number of hops for the path trace, check the Stop trace after check box, and enter the 
maximum number of hops for the path trace.

The Cisco PathTracer window appears, displaying the resulting path trace.

Viewing Path Traces
The Cisco PathTracer window displays all discovered paths for the specified source and destination of 
the path trace, including the devices and physical links. Form the window you can:

• View multiple paths for a selected source and destination either sequentially or simultaneously.

• View individual paths with networking layer details.

• Save a map with multiple paths to a file.

• Run Cisco PathTracer again, using the same trace or with a different limit number of hops.
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Figure 13-9 shows an example of the Cisco PathTracer window with a multiple-path trace.

Figure 13-9 Cisco PathTracer Window - Multiple-Path Trace

Window 
Area Description

1 Menu bar —

2 Toolbar Cisco PathTracer Toolbar, page 13-16

3 Trace tab Displays the discovered path with a tab that displays the date and time when Prime 
Network started the path tracing process (snapshot time). New runs are represented 
in new tabs. To use a saved path in the same window, the source and destination must 
be the same.

4 Paths pan Lists all the paths discovered in the path trace (one path for each source and 
destination pair, identified by a number). If you launch a path trace with a specific 
hop count, the paths pane displays First n Hops where n is the number of hops 
specified. You can choose different paths in the path pane or by using the toolbar 
icons. Click Clear Path Selection to de-select a path.

5 Status bar —

6 Path trace 
pane

Displays the devices, links, and topological paths in path trace. All links and nodes 
are labeled with their relevant path numbers. The starting point is labeled with a 
Starting Point callout. All other edge points are displayed as clouds. The same 
coloring conventions that are used for links in the Prime Network content pane are 
used to display links in the Cisco PathTracer path trace pane. (See Links, 
page A-11.)
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Click PathTracer from the toolbar to display the following information:

• Each NE’s relevant parameters for each interface on all layers along the path; for each layer, an 
indication of a mismatch between the parameters of the interfaces on both sides of a link; and traffic 
statistics along the path.

• Status and traffic information for all links along the path.

• View In and Out port properties. 

If you select multiple paths, a separate window is opened for each path. Figure 13-10 shows an example 
of the Cisco PathTracer details window. 

Figure 13-10 Cisco PathTracer Details Window
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1 Menu bar —

2 Toolbar —

3 Path trace pane Displays information related to the selected tab (for example, Layer 2). If you 
choose an element or link in the path trace pane, the related parameters are 
highlighted in the details pane. By default, the path trace pane includes:

• Edge points

• Elements included in the path trace, including badges

• Links included in the path trace

Hovering your mouse over an element displays a tooltip that contains the 
element name, device type, and IP address. Hovering your mouse over the link 
to the right or left of the element displays the associated incoming or outgoing 
interface for that element and link. 

4 Hide/display 
path trace pane

—

5 Details pane Selecting a device or link in the path trace pane automatically highlights the 
related parameters in the details pane.

Displays information about device or link selected in Path trace pane, such as 
Layer and Business tabs, supported parameters of the selected element in a table, 
with the ingress and egress ports along the top and the parameters on the left.

Colors indicate any inconsistencies between the two connected ports.

The information parameters are arranged as follows:

• Layer n tabs—Provide information about each network element, including 
ingress and egress port information. The information is either plain data that 
is extracted from the element or calculated data, such as rates or statistics. 
This information is displayed in the Layer 1, Layer 2, and Layer 3 tabs, as 
follows: 

– Layer 1—Displays the Layer 1 information in the selected path and the 
link parameters, device name, subslot, slot, and port details. 

– Layer 2—Displays the Layer 2 information in the selected path and the 
link and connection parameters. For each device, the name and MAC 
address are displayed, as well as the VPI/VCI in an ATM link or the 
DLCI in a Frame Relay link. (This tab is active by default.). 

– Layer 3—Displays the Layer 3 information in the selected path and the 
link parameters and devicenames.

Fields are only displayed if they are populated. For example, if none of the 
interfaces is configured for MTU, the MTU row is not displayed in the table. 

• Business tab—Provides the name and key of business tags that are attached 
to the network entities displayed, including ports, devices (physical 
entities), VCIs, VPIs, DLCIs, contexts (logical entities), or MPLS. 

6 Layer and 
Business tabs

—

7 Status bar —
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Cisco PathTracer Toolbar

Table 13-2 describes the options available in the Cisco PathTracer toolbar. 

Table 13-2 Cisco PathTracer Toolbar Options

Button Function

Displays the previous path in the path trace pane.

Displays the next path in the path trace pane.

Clears the path selection made in the path trace pane.

Opens the Cisco PathTracer details window. A map is displayed for the selected path, 
including network element details, links, and property information. For more information, 
see Saving and Opening Cisco PathTracer Map Files, page 13-17.

Saves the current multiple-path trace to an XML file on your local system. For more 
information, see Saving and Opening Cisco PathTracer Map Files, page 13-17.

Offers the following options for running Cisco PathTracer again for the same source and 
destination:

• Change Hop Count—Enables you to enter a new hop count. 

• Repeat Last Trace—Runs the previous trace with the same settings. 

• Run Full Path Trace—Runs the previous trace without a hop count limit.

The new path trace map is displayed in the path trace pane. 

A new tab with the up-to-date (or refreshed) path map is created for each run, with each tab 
representing a run and the tab label indicating the snapshot time.

Opens a window displaying a high level view of the path trace currently displayed in the 
path trace pane.

Specifies how the elements are arranged in the path trace pane: circular, hierarchical, 
orthogonal, or symmetric.

Fits the entire path trace in the path trace pane.

Activates the normal selection mode. The button toggles when selected or deselected.

Activates the zoom selection mode, which enables you to select a specific area in the path 
to zoom in on by clicking and dragging. The button toggles when selected or deselected.

Activates the pan mode, which enables you to move around in the path trace by clicking and 
dragging. The button toggles when selected or deselected.
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Saving and Opening Cisco PathTracer Map Files
Prime Network enables you to export multiple-path trace maps that are displayed in the Cisco PathTracer 
window to an XML file. You can view the data later to assess whether anything has changed.

Saving Cisco PathTracer Map Files

To save Cisco PathTracer map files:

Step 1 Open the Cisco PathTracer window as described in Launching Path Tracer, page 13-2.

Step 2 Click Save MultiPath in the toolbar.

Step 3 In the Save dialog box, navigate to the directory where you want to save the file and enter a name for the 
map file.

Step 4 Click Save. The map file is saved in the selected directory.

Opening Cisco PathTracer Map Files

Prime Network enables you to open saved XML-formatted path-tracing maps.

The following conditions apply when working with multiple-path trace files: 

• When you load a multiple-path trace file, Prime Network queries the file (not the network), and 
loads the persisted information. 

• If you load a multiple-path trace file that does not contain the same start and end points, the map is 
automatically opened in a new Cisco PathTracer window.

To open Cisco PathTracer map files:

Step 1 In the Vision client, choose File > Load MultiPath from the main menu. The Open dialog box is 
displayed.

Step 2 Navigate to the directory of the saved file and select the file.

Step 3 Click Open. The previously saved map is displayed in the Cisco PathTracer window.

Saving Cisco PathTracer Counter Values
Prime Network enables you to export, over a period of time, the counter values of the path displayed in 
the Cisco PathTracer window to a CSV file. The data can then be viewed later, as required.

Note This topic applies to the Cisco PathTracer details window only.

To save Cisco PathTracer counter values that are generated over a period of time: 

Step 1 Open the Cisco PathTracer details window as described in Launching Path Tracer, page 13-2. 

Step 2 Click Start Saving to File in the toolbar.
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Step 3 In the Export Table to File dialog box, navigate to the directory where you want to save the 
Cisco PathTracer counter values. 

Step 4 In the File name field, enter a name for the file in which to save the counter values.

Step 5 Click Save. Cisco PathTracer starts saving the counter values to the specified file.

Step 6 To stop exporting counter values to the file, click Stop Saving to File in the toolbar.

Cisco PathTracer stops exporting the counter values to the file.

Rerunning a Path and Comparing Results
If you save a path to a file (see Saving and Opening Cisco PathTracer Map Files, page 13-17), you can 
use the file to rerun the same path automatically with the same source and destination. You can also 
compare the saved path to a newly run path to determine if the path has changed or to assess a problem. 

To rerun a saved path: 

Step 1 Load the required map file as described in Saving and Opening Cisco PathTracer Map Files, page 13-17. 
The Cisco PathTracer window is displayed with the previously saved map file.

Step 2 Click Run Again in the toolbar.

The path trace runs automatically using the same source and destination as the loaded map file, and a 
new tab is displayed in the Cisco PathTracer window with the updated map. The tab displays the date 
and time when the path was rerun.

Step 3 Compare the previous map to the updated one by switching between the tabs in the Cisco PathTracer 
window.

Note • If you load a Cisco PathTracer map file that does not contain the same source and destination 
information as the map that is currently displayed in the window, the map is automatically opened 
in a new Cisco PathTracer window.

• If you load a Cisco PathTracer map file that contains the same source and destination information 
as a map that is currently displayed in the window, the map is loaded in a new tab in the same 
window.

Viewing Q-in-Q Path Information 
The Q-in-Q (IEEE 802.1) tagging technology (also known as Dot1q tunneling) allows the nesting of 
another VLAN tag in a packet, in addition to an existing one. Either VLAN tag is considered an 802.1Q 
header.
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Cisco PathTracer uses the VLAN tags of the Ethernet header and the port configuration to trace the path 
from one interface to another over the network. Among other things, you can:

• View a Layer 2 path across a LAN domain with all the VLAN tag information.

• For each network element, view the relevant parameters for each interface on all layers along the 
path.

Q-in-Q and Dot1q information is displayed in the Cisco PathTracer window when a path is traced over 
Ethernet ports with Dot1q and a Q-in-Q configuration.

As described in Launching Path Tracer, page 13-2, to view a specific path, you must specify an initial 
start point, such as an IP interface, and then an endpoint, such as a destination IP address. 

To trace a Q-in-Q path, you start the path from any:

• Router or switch that is part of the Ethernet domain with Dot1q and Q-in-Q configurations.

• IP destination that can be reached from that point of the network.

After you select the endpoint, the Cisco PathTracer window is displayed. From this window, you can 
open the Cisco PathTracer details window, with the appropriate Q-in-Q information displayed in the 
Layer 2 tab. 

The Layer 2 tab can display the following information specific to Q-in-Q and VLAN port configurations:

• VLAN Mode—The work mode for the interface: Unknown, Access, Trunk, or Dot1Q Tunnel. Trunk 
mode also refers to multiple tagging.

• Native VLAN ID—The VLAN identifier that is used to tag untagged traffic received on a trunked 
interface: 

– If VLAN tagging is enabled, the default native VLAN identifier is 1.

– If VLAN tagging is disabled, the native VLAN identifier is 0 (zero) or “no VLAN ID.” 

• CE VLAN ID—The customer edge device VLAN identifier.

• SP VLAN ID—The service provider VLAN identifier.

Viewing L2TP Path Information
Cisco PathTracer uses VC ID encapsulation information to trace the path from one tunnel interface to 
another over the network. The Cisco PathTracer tool enables you to:

• View a path for the defined Layer 2 Tunneling Protocol (L2TP) session across the network.

• For each network element, view the relevant parameters for each interface on all layers along the 
path.

The Layer 3 tab displays the peer name for L2TP tunnels. 

Table 13-3 describes the information that is displayed in the Layer 2 tab for L2TP tunnels. 

Table 13-3 Layer 2 Tab Information for L2TP Tunnels

Field Description

Encapsulation Type Encapsulation type, such as Point-to-Point Protocol over ATM (PPPoA).

Binding Information Name of the subscriber.

Binding Status Binding status: bound or unbound.

Tunnel Session Count Number of current sessions.
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Using Cisco PathTracer in MPLS Networks
You can open and view Cisco PathTracer information between service endpoints, such as an IP interface 
that is attached to the VRF over an MPLS network. The LSP in the MPLS network is found according 
to the cross-connect table of each router.

Note An LSP can be traced and displayed by Cisco PathTracer as part of an end-to-end tracing of a service; 
for example, when viewing a path between one CE device and another. Cisco PathTracer traces the path 
that goes over circuits or VLANs in the access networks. It also traces the LSPs between the VRFs going 
through all intermediate devices such as CE devices, aggregation switches, PE routers, and core routers.

To view a specific path, you must specify an initial starting point, such as an IP interface; specifying a 
destination IP address is optional. If the traced path (for example, a VC or VLAN) ends in a router, 
Cisco PathTracer finds the next hop according to the destination IP address. If you select an endpoint, 
Cisco PathTracer extracts the relevant IP address from this point and uses it as the destination.

The following topics provide more information on using Cisco PathTracer in MPLS networks: 

• Cisco PathTracer MPLS Start and Endpoints, page 13-21

• Using Cisco PathTracer for CSC Configurations, page 13-22

• Using Cisco PathTracer for Layer 3 VPNs, page 13-22

• Using Cisco PathTracer for Layer 2 VPNs, page 13-23

• Using Cisco PathTracer for MPLS TE Tunnels, page 13-24

Tunnel Remote ID Remote tunnel identifier.

Tunnel ID Local tunnel identifier.

Tunnel Name Name of the subscriber and the tunnel identifier.

Session ID Session identifier.

Traffic > L2TPSession
Counters

Number of ingress traffic packets passing through the L2TP tunnel.

Traffic < 
L2TPSessionCounters

Number of egress traffic packets passing through the L2TP tunnel.

Tunnel Ctl Errors Number of control errors.

Tunnel State Tunnel state: unknown, idle, connecting, established, or disconnecting.

Session Type Session type: unknown, LAC, or LNS.

Peer Name Peer name.

Tunnel Remote IP Remote IP address of the tunnel.

Last Error Code Value of the last error code that caused the tunnel disconnection.

Session State Session state: unknown, idle, connecting, established, or disconnecting.

Remote Session ID Remote session identifier.

Table 13-3 Layer 2 Tab Information for L2TP Tunnels (continued)

Field Description
13-20
Cisco Prime Network 4.3.1 User Guide



  

Chapter 13      Finding Available Network Paths Using PathTracer
  Using Cisco PathTracer in MPLS Networks
Cisco PathTracer MPLS Start and Endpoints
You can open Cisco PathTracer by right-clicking a starting point and entering the required destination 
IP address. Table 13-4 lists the Cisco PathTracer starting points.

If you choose the Start Here option, Table 13-5 lists the endpoints that can be selected as path 
destinations.

The Cisco PathTracer window is displayed. From this window you can open the Cisco PathTracer details 
window with the VPN information displayed in the Layer 2 and Layer 3 tabs. 

Note If multiple paths are selected in the paths pane, or if nothing is selected in the paths pane, all available 
paths are opened automatically, and each is displayed in a separate Cisco PathTracer window.

Table 13-4 Cisco PathTracer MPLS Starting Points

Element Location Start Options

IP interface • Inventory window

• Affected entity (enabled only if the 
affected entity has an IP interface)

• From Here to Destination

• Start Here

MPLS-TP tunnel 
endpoint

• Navigation or map pane

• Inventory window

• From Here to Destination

• Start Here

Site Service view map • From Here to Destination

• To Subnet Destination

• Start Here

Business tag 
attached to the 
VPI/VCI or IP 
interface 

The path can be found using a business tag, 
which is attached to the VPI/VCI or IP 
interface by entering its key. It can then be 
opened from the Find Business Tag window.

From Here to Destination

Layer 2 MPLS 
Tunnel

Inventory window From Here to Destination

Table 13-5 Cisco PathTracer MPLS Endpoints

Element Location End Options

IP interface • Inventory window

• Affected entity (enabled only if the 
affected entity has an IP interface)

End Here

MPLS-TP tunnel 
endpoint

Inventory window End Here

Site Service view map End Here
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Using Cisco PathTracer for CSC Configurations
Cisco PathTracer traces a CSC flow from the customer CE through the customer carrier VPN, across the 
customer backbone carrier VPN, back to the customer carrier VPN, and to the destination CE. 

To launch a path trace for a CSC configuration: 

Step 1 In a map, double-click the required CE device.

Step 2 In the Inventory window, choose Logical Inventory > Routing Entities > Routing Entity. 

Step 3 In the IP Interfaces table, right-click the required interface and choose PathTracer > Start Here > IPvn 
where IPvn represents IPv4 or IPv6. 

Step 4 Navigate to the destination CE device and double-click it.

Step 5 In the Inventory window, choose Logical Inventory > Routing Entities > Routing Entity. 

Step 6 In the IP Interfaces table, right-click the required interface and choose PathTracer > End Here. 

The path trace is displayed in the Cisco PathTracer window.

Step 7 To view the detailed pane, click Cisco PathTracer in the toolbar. 

The Layer 2 tab displays a single outer label and two inner labels for each interface, reflecting the CSC 
configuration. (See Figure 13-11.) 

Figure 13-11 CSC Configuration Path Trace

Using Cisco PathTracer for Layer 3 VPNs
Cisco PathTracer uses VRF routing and label switching information to trace the path from one VRF 
interface to another. If you choose a launch point and destination from the right-click menu, you can 
open the Cisco PathTracer for Layer 3 VPNs. The Cisco PathTracer window shows the VPN topology 
map. From this window, you can open the Cisco PathTracer details window with the appropriate VPN 
information displayed in the Layer 2 and Layer 3 tabs. 
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For Layer 3 path information, Prime Network uses VRF routing and label switching information to trace 
the path from one VRF interface to another. Layer 3 path trace information is displayed in the 
Cisco PathTracer window when the path goes over connections and ends in VRFs. 

If a VRF table includes more than one path toward a destination, Cisco PathTracer shows all paths.

To view Layer 3 path information, choose the Layer 3 tab and choose Show All from the View menu. 
The path information is displayed in the active tab.

The table displays the Layer 3 VPN information on the device that has a VRF. The following Layer 3 
properties displayed in the Layer 3 tab relate specifically to VPNs:

• Name—The name of the site. For example, ATM4/0.100(10.0.0.1) is a combination of the interface 
name and IP address used to reach the site. Each site belongs to a particular VPN, so the address 
must be unique within the VPN.

• IP Address—The IP address of the interface.

• Mask—The mask of the specific network.

• State—The state of the interface (up or down).

• VRF Name—The name of the VRF.

Cisco PathTracer does not display or trace EXP bits for Layer 3 VPNs that use policy-based tunnel 
selection (PBTS). 

Using Cisco PathTracer for Layer 2 VPNs
Cisco PathTracer uses VC ID and label switching information to trace the path from one tunnel interface 
to another over the MPLS network.

Cisco PathTracer also covers end-to-end Layer 2 VPN service paths from one CE router to another. The 
path goes over circuits (such as a VC) or VLANs in access networks and over LSP between the Layer 2 
tunnel edge.

The Cisco PathTracer window shows the VPN topology map for the relevant devices and links. From 
this window, you can open the Cisco PathTracer details window with the appropriate VPN information 
displayed in the Layer 2 and Layer 3 tabs. 

For Layer 2 path information, Cisco PathTracer uses VC ID and label switching information to trace the 
path from one tunnel interface to another. Layer 2 path trace information is displayed in the 
Cisco PathTracer window when the path goes over pseudowire tunnels.

To view Layer 2 path information, choose the Layer 2 tab and then View > Show All. The path 
information is displayed in the active tab.

Table 13-6 describes the Layer 2 properties that can be displayed in the Layer 2 tab specifically for 
VPNs.

Table 13-6 Cisco PathTracer Layer 2 Properties for VPNs

Field Description

Top Label Details of the outer MPLS label.

Label Stack Details of the inner MPLS label.

MAC Address MAC address.

Tunnel ID Tunnel identifier. The identifier and the router IP address of the two 
tunnel edges identify the pseudowire tunnel.
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Using Cisco PathTracer for MPLS TE Tunnels
Cisco PathTracer uses label switching information to trace the end-to-end path of a TE tunnel path from 
one PE router to another.

Using MPLS TE technology, Cisco PathTracer enables you to:

• View a path or list of devices.

• View the following information for each network element:

– The relevant parameters for each interface on all layers along the path.

– The path for the defined MPLS TE-LSP across the network.

The Cisco PathTracer window is displayed showing the MPLS TE tunnel topology map. From this 
window, you can open the Cisco PathTracer details window with the appropriate MPLS TE tunnel 
information displayed in the Layer 2 tab.

Note Cisco PathTracer does not display or trace EXP bits for Layer 3 VPNs that use PBTS. 

Layer 2 and Layer 3 path trace information is displayed in the Cisco PathTracer details window when a 
path is traced over MPLS TE tunnels. To view Layer 2 path information, choose the Layer 2 tab and then 
View > Show All. The path information is displayed in the active tab.

Tunnel Type Tunnel type: 

• 0—Unknown

• 1—PWE3

• 2—TE

Tunnel Status Operational state of the tunnel: Up or Down.

Tunnel Local VC Label MPLS label that is used by the router to identify or access the tunnel. It 
is inserted in the MPLS label stack by the local router.

Tunnel Peer VC Label MPLS label that is used by the router to identify or access the tunnel. It 
is inserted in the MPLS label stack by the peer router.

Tunnel Local Router IP IP address of the tunnel edge, which is used as the MPLS router 
identifier.

Tunnel Peer Router IP IP address of the peer tunnel edge, which is used as the MPLS router 
identifier.

Distribution Protocol 
Type

Protocol used by MPLS to build the tunnel, such as LDP or TDP.

Peer OID Tunnel identifier and device name.

Table 13-6 Cisco PathTracer Layer 2 Properties for VPNs (continued)

Field Description
13-24
Cisco Prime Network 4.3.1 User Guide



  

Chapter 13      Finding Available Network Paths Using PathTracer
  Using Cisco PathTracer in MPLS Networks
Table 13-7 describes the Layer 2 properties that can be displayed in the Layer 2 tab specifically for 
MPLS TE tunnels. 

Table 13-7 Cisco PathTracer Layer 2 Properties for MPLS TE Tunnels

Field Description

MPLS TE Properties MPLS TE data set in an MPLS interface, primarily bandwidth allocation 
levels and signaling protocol.

Tunnel Oper Status Operational status of the tunnel: Up or Down. 

If this value is Up, the Tunnel Admin Status must also be Up. See Tunnel 
Admin Status properties for additional information. 

Tunnel Bandwidth Kbps Configured bandwidth (in Kb/s) for the tunnel. 

Tunnel Description Description of the tunnel.

Tunnel Name Interface name.

Tunnel Admin Status Administrative status of the tunnel (Up or Down) with the following 
caveats:

• If the Tunnel Oper Status value is Up, the Tunnel Admin Status 
value must also be Up. 

• If the Tunnel Admin Status value is Down, the Tunnel Oper Status 
value must also be Down.

Tunnel Lockdown Whether or not the tunnel can be rerouted:

• Enabled—The tunnel cannot be rerouted.

• Disabled—The tunnel can be rerouted.

Tunnel LSP ID LSP identifier. 

Tunnel Auto Route Whether or not destinations behind the tunnel are routed through the 
tunnel: Enabled or disabled.

Tunnel Hold Priority Tunnel priority after path setup. 

Tunnel Setup Priority Tunnel priority upon path setup.

Tunnel Path Option Tunnel path option:

• Dynamic—The tunnel is routed along the ordinary routing 
decisions after taking into account the tunnel constraints such as 
attributes, priority, and bandwidth. 

• Explicit—The route is explicitly mapped with the included and 
excluded links.

Tunnel Out Label TE tunnel MPLS label distinguishing the LSP selection in the adjacent 
device.

Tunnel Affinity Tunnel’s preferential bits for specific links.

Tunnel Destination Address IP address of the device in which the tunnel ends.

Tunnel Peak Rate Kbps Peak flow specification (in Kb/s) for this tunnel.

Tunnel Out Interface Interface through which the tunnel exits the device.

Tunnel Burst Kbps Burst flow specification (in Kb/s) for this tunnel.
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Tunnel Average Rate Kbps Tunnel average rate in Kb/s.

Tunnel Affinity Mask Tunnel affinity bits that should be compared to the link attribute bits.

Table 13-7 Cisco PathTracer Layer 2 Properties for MPLS TE Tunnels (continued)

Field Description
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