CHAPTER

2

Modeling and Displaying Additional NE
Properties
Prime Network models and displays a fixed set of network element properties in the Inventory windows.
If there are additional properties you want to display and monitor, you can do so using Soft Properties.
These topics explain how to use Soft Properties to add new network element properties to the Inventory
window and control how these new properties are displayed:

Note

•

What are Soft Properties?, page 2-1

•

Steps for Adding New NE Property Information to the Inventory, page 2-3

•

Displaying a New Property in the Inventory Window, page 2-4

•

Adding a New Inventory Table Containing SNMP get Details, page 2-11

•

Making the Soft Property Available to Other NEs, page 2-14

We recommend that the users who manage Soft Properties have the following:
•

For their user account—Configurator or higher default permissions.

•

For all assigned device scopes—Configurator or higher security level.

What are Soft Properties?
Soft properties are definitions that contain rules for retrieving new NE information, parsing the retrieved
information, and displaying it in the Inventory window, either as an additional property or as a table. In
effect, soft properties can be used to extend the default subset of device properties that Prime Network
models. Using soft properties allows you to quickly adapt to new software upgrades and new
requirements that arise during ongoing operation and deployment.
For example, consider the case where the Prime Network system monitors the port parameters of an
ATM switch, and the operator installs a new software version on the switch that is capable of reporting
the bit error rate (BER) for each of the ports. Since this capability was not supported in previous software
versions of the NE, the Prime Network VNE might not support the property. To avoid the need for a new
VNE from Cisco, you can immediately support the new BER feature by creating a soft property.
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What are Soft Properties?

A soft property is implemented through a set of definitions that determine how to retrieve, parse, and
display a certain MIB variable from the NE. Information can be retrieved from the NE using SNMP or
Telnet/SSH, and the definitions are stored in the XML registry. You define the protocol and rules using
the Soft Properties GUI client. The new properties are applied in runtime and do not require system
restart.
You can also associate alarm conditions with a soft property and create a new TCA that will be displayed
in the Prime Network Vision and Events GUI clients. Creating TCAs is described in Creating a New
Threshold-Crossing Alarm, page 7-1.
When you develop the soft property, only the specific NE instance is affected so that you can debug it
and determine any impact it may have on the VNE. When you restart the VNE, the soft property is
applied to all similar components on that VNE. Then you can apply it to multiple devices and
components.

Cisco Prime Network 4.3.1 Customization Guide

2-2

Chapter 2

Modeling and Displaying Additional NE Properties
Steps for Adding New NE Property Information to the Inventory

Steps for Adding New NE Property Information to the
Inventory
Figure 2-1 illustrates the steps required to define a new soft property.
Figure 2-1

Flow for Creating New Soft Properties
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show new properties

Define the general properties:
ID, display label, polling rate, etc.
Table type soft property

Property type soft property

Define SNMP get OID command
to retrieve information

Define SNMP get OID or Telnet/SSH
command to retrieve information

Create rules that will take the
retrieved data and parse it into
the desired table format

Create rules that will take the retrieved data and
parse it so only the required data is displayed

Test the rules by simulating the execution of
individual rules, and the simulation of the
entire rule sequence
Create
a TCA?

Debug and validate the soft property
by executing it on the NE

No

Yes

See documentation
on creating TCAs

Reopen the Inventory window
to view the soft property

Make the soft property available to
other managed NEs in the network

285993

Restart the VNE to apply the soft
property to similar NEs on the VNE

The steps are described in these topics:
•

Displaying a New Property in the Inventory Window, page 2-4

•

Adding a New Inventory Table Containing SNMP get Details, page 2-11

•

Creating a New Threshold-Crossing Alarm, page 7-1
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Displaying a New Property in the Inventory Window
This procedure leads you through the process of creating a new Property type so that new NE attributes
can be modeled and displayed in the Inventory window. This allows you to monitor a new attribute on
an ongoing basis.
To create a new Property type soft property:
Step 1

In Prime Network Vision, right-click the node on which you want to apply a new soft property. The node
can be the NE itself or an inventory node. For example, you can create a soft property on a port.

Step 2

Choose Management > Soft Properties Management.
The Soft Properties Manager dialog box opens and displays any existing soft properties for the selected
node. As shown in Figure 2-2, the choices in the Properties Panel drop-down list align to the panels in
the Inventory window for the selected node. For example, the properties panels for an ATM port are
Location Information, ATM, and DS3.
Figure 2-2

Soft Properties Manager Dialog Box

Step 3

From the Panel Properties drop-down list, choose the inventory panel in which you want the new
property to be displayed.

Step 4

Open the Add Soft Property dialog box by choosing File > New Element.

Step 5

In the General tab, define the general parameters for the soft property.
Field

Description

Example

Name

Enter a unique identifier for the soft property.

sp01

Label

Identifying text that will be displayed in Inventory window.

My Soft
Property

Description

(Optional) Description of the soft property

Example of soft
property

Type

Type of soft property, which determines the format of the
information. In this case, select Property to display the defined
information in the form of an additional field in the Inventory
window. Telnet/SSH or SNMP is used to retrieve and parse
information from the NE.

Property

Cisco Prime Network 4.3.1 Customization Guide

2-4

Chapter 2

Modeling and Displaying Additional NE Properties
Displaying a New Property in the Inventory Window

Step 6

Field

Description

Example

Polling Rate

Rate at which Prime Network will poll the NE for the information. Status
Prime Network applies the appropriate default. Do not change this
unless you are familiar with polling and the implications of
choosing different rates.

Enabled

Whether the VNE is running the command. This field allows you to [selected]
temporarily disable soft properties, if needed.

In the Parsing tab, select the protocol you want to use to retrieve the information.
Protocol

Description

Use SNMP get(OID) SNMP retrieval expression. The SNMP OID must start with a dot.
1.

Enter the OID in the text box; for example:
.1.3.6.1.2.1.2.2.1.16.

2.

With the cursor in the text box, click Ctrl-Spacebar to display the available
fields and their current values.

3.

Choose a field from the drop-down list and press Enter. The variable is
populated in the text box with surrounding $ characters. This example
retrieves the interface OutOctets:
.1.3.6.1.2.1.2.2.1.16.$ifIndex$

Use Telnet/SSH

The Telnet/SSH retrieval expression. (To use Telnet, it must be enabled on the
device.)
1.

Enter the Telnet/SSH command in the text box; for example:
show interface

With the cursor in the text box, click Ctrl-Spacebar to display the available
fields and their current values. For example:

2.

Choose a field from the drop-down list and press Enter. The variable is
populated in the text box with surrounding $ characters. For example, when
this command is executed, $portalias$ will be replaced with Ethernet1/0:
.1.3.6.1.2.1.2.2.1.16.$portAlias$

Step 7

Define parsing rules. You can create multiple rules in order to retrieve exactly the information you
require. Click Add to start defining your parsing rules.
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The Add/Edit Parsing Rule dialog box appears.
Figure 2-3

1

Add/Edit Parsing Rule Dialog Box

Input Buffer—Determines what input will be used for the parsing rule. The drop-down list in this field contains a blank
item representing the default input, and a list of variables created by redirecting the output of previous rules (if any).
If the input buffer is blank (default), the output of the previous parsing rule is used as this rule’s input unless the output
of the previous rule was directed to an output variable. In this case, the default input is the output of the last rule that was
not directed to an output variable. For example, you create Rule 1. Then you create Rule 2 and Rule 3, but you redirect
Rule 3’s output to a variable. When you create Rule 4, it will use the output from Rule 2 as its input. That is because
Rule 2 is the last rule with output that was not redirected.

2

Operator—Specifies a parsing operator. The operator you choose determines the fields that appear below it (Remove
Lines, Match, Parse Integer, and so forth). See Supported Parsing Rules and Operators, page A-1.

3

Direct result to output buffer variable check box—When checked, you can save the parsing output as a variable with a
unique name. This means that the output will not automatically be used as the input for the next rule, but the variable will
be available for selection as the input for subsequent rules defined for this soft property.

4

Simulation panel—Allows you to test the rule by entering your rule and clicking Test Expression. This information is
not saved when you close the window.

5

The parsed result that is displayed after clicking Test Expression. This information is not saved when you close the
window.
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Step 8

To simulate the parsing rule without sending the command to the device:
a.

Enter the text into the top Simulation window. For example:
Name
example

b.

Default RD
55:55

Interfaces

Click Test Expression. The parsing rule result is displayed, as shown in Figure 2-4.

Figure 2-4

Match Parsing Rule
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Step 9

Click OK. The rule is added to the Parsing tab, as shown in Figure 2-5.
Figure 2-5

Step 10

Parsing Tab with Match Parsing Rule

Click Add to create another parsing rule. For example:
Operator

Substring

From Index

1

Length

1

Simulation text box

55
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Step 11

Click Test Expression. The result 5 is displayed in the Result text box, as shown in Figure 2-6.
Figure 2-6

Step 12

Substring Parsing Rule

Click OK. The rule is added to the Parsing tab, as shown in Figure 2-7.
Figure 2-7

Parsing Tab with Match and Substring Parsing Rules
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Step 13

Step 14

To simulate the rule sequence without sending any commands to the device:
a.

From the Add Soft Property dialog box (Parsing tab), click Test to open the Test Parsing Rules
dialog box.

b.

Copy the output of the native commands into the Input Buffer.

c.

Click Test (in the Test Parsing Rules dialog) and verify the results.

a.

Click Close.

To send the command to the device to check its validity, in the Add Soft Properties dialog box, click
Debug.

Note

No notification message is displayed when a VNE fails to collect properties. The properties are
simply not populated in the GUI.

The results of the test are displayed Debug Soft Property dialog box.
Step 15

The Debug Soft Property dialog box is displayed.
Figure 2-8

Step 16

Debug Soft Property Dialog Box

After the Status is returned as valid, confirm that the input parameters have returned the correct values;
for example:
Telnet Commands=[show ip vrf example]

Step 17

Click Close to exit the Debug Soft Property window.
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Step 18

Click OK to exit the Add Soft Property dialog box. The new soft property is listed in the Soft Properties
Manager dialog box, as shown in Figure 2-9.
Figure 2-9

Step 19

Soft Properties Manager Window

Click Close to exit the Soft Properties Manager.
The soft property is activated on the NE. You should see the new information in your Inventory window
the next time you open it. When you restart the VNE, the soft property is applied to all similar
components on the VNE.

Take the appropriate next steps:
•

To add a TCA to the soft property, see Creating a New Threshold-Crossing Alarm, page 7-1.

•

To make other NEs display the property, see Making the Soft Property Available to Other NEs,
page 2-14.

Adding a New Inventory Table Containing SNMP get Details
This procedure leads you through the process of creating a new Table type soft property that extracts
information from the MIB and displays it (in a table) in the Inventory window.
To create a new Table type soft property:
Step 1

In Prime Network Vision, right-click the node on which you want to apply a new soft property. The node
can be the NE itself or an inventory node. For example, you can create a soft property on a port.

Step 2

Choose Management > Soft Properties Management.
The Soft Properties Manager dialog box opens and displays any existing soft properties for the selected
node. As shown in Figure 2-2, the choices in the Properties Panel drop-down list align to the panels in
the Inventory window for the selected node. For example, the properties panels for an ATM port are
Location Information, ATM, and DS3.
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Step 3

From the Panel Properties drop-down list, choose NE inventory panel in which you want the new
property table to be displayed.

Step 4

Open the Add Soft Property dialog box by choosing File > New Element.

Step 5

Define the general parameters for the soft property in the General tab.

Step 6

Field

Description

Example

Name

Enter a unique identifier for the soft property.

sp02

Label

Identifying text that will be displayed in Inventory window.

My Soft Table

Description

(Optional) Description of soft property

Example of a
Soft Table

Type

Type of soft property, which determines the format of the
information. In this case, select Table to display the defined
information in tabular format. An SNMP get is performed to
retrieve NE information and display it in tabular form in the
Inventory window.

Table

Polling Rate

Rate at which Prime Network will poll the NE for the information. Status
Prime Network applies the appropriate default. Do not change this
unless you are familiar with polling and the implications of
choosing different rates.

Enabled

Whether the VNE is running the command. This field allows you to (Selected)
temporarily disable soft properties, if needed.

Define the SNMP retrieval expression. The SNMP OID must start with a dot.
a.

Enter the OID in the text box; for example:
.1.3.6.1.2.1.4.20.1.

Step 7

Step 8

b.

With the cursor in the text box, click Ctrl-Spacebar to display the available fields and their current
values.

c.

Choose a field from the drop-down list and press Enter.

Click Add and define the column and data information in the Add Edit Column Controller dialog box.
For example:
Column Title

My First Column

Column Data

2

Add more column titles and data as needed; for example:
Column Title

My Second Column

Column Data

5

When you are done, click OK. See the example in Figure 2-10.
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Figure 2-10

Step 9

Add Soft Property Dialog Box

To send the command to the device to check its validity, in the Add Soft Properties dialog box, click
Debug.

Note

No notification message is displayed when a VNE fails to collect properties. The properties are
simply not populated in the GUI.

When you finish testing the rules, click Close to close the Debug Soft Property dialog box.
Step 10

Click OK to exit the Add Soft Property dialog box.

Step 11

Click Close to exit the Soft Properties Manager dialog box.

Step 12

Click Close to exit the Soft Properties Manager.
The soft property is activated on the NE. You should see the new information in your Inventory window
the next time you open it. When you restart the VNE, the soft property is applied to all similar
components on the VNE.

To make other NEs display the property, see Making the Soft Property Available to Other NEs,
page 2-14.
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Making the Soft Property Available to Other NEs
A property definition is applicable to all objects of the same type in the selected NE. After the soft
property has been defined and tested on a specific instance of a managed element, it can be published
and applied to a wider scope of managed NEs in the network. This requires moving the property
definition from the specific NE instance to a higher level in the registry hierarchy.
The Soft Properties Publish Controller dialog box enables you to publish the soft property to one or more
locations across the inheritance hierarchy (as defined in the system). In other words, you define the scope
where the soft property is to be applied in the hierarchy.

Note

Users with Configurator privileges can add and publish soft properties on all devices.
Figure 2-11 shows an example of the inheritance hierarchy. In this example, the top level of the hierarchy
is All devices, and the lowest level of the hierarchy is Device XYZ.
Figure 2-11

Inheritance Hierarchy Example

All devices

Cisco devices

Cisco routers

Device XYZ

180326

Cisco 7200

When a soft property is published to a node in the hierarchy, it overrides any inherited soft properties
from a higher level and applies automatically to all its children. For example, if a soft property is
published to Cisco 7200 devices, it overrides any variant of this soft property which is defined at a higher
level, and is assigned to all devices of type Cisco 7200 in the system.

Caution

Soft property publishing can affect system memory usage, device utilization, and system performance.
For example, publishing a property that contains the show running-config command to many devices
could negatively impact system memory usage and device utilization. We strongly recommend that you
measure the effect of publishing the soft property on system memory usage before you publish the soft
property. To view the changes, you must restart the VNE or unit for the publishing to take effect.
To publish a soft property:

Step 1

In Prime Network Vision, right-click a managed element, then choose Management > Soft Properties
Management. This opens the Soft Properties Manager window.

Step 2

Select the soft property you want to publish. Remember that the soft properties that are displayed depend
on the NE, and the choice you make in the Properties Panel drop-down list.
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Step 3

Open the hierarchy manager by choosing Tools > Hierarchy Manager.
Each row that is displayed in the hierarchy manager table represents a different level of the hierarchy.
The rows are displayed in descending order; the top row is the highest level of the hierarchy and the
bottom row is the lowest level of the hierarchy.
The following information is displayed in the table:
•

Exist—When a node in the hierarchy is selected, it indicates that a local variant of the soft property
exists for that node.

•

VNE Hierarchy Location—The hierarchy path, as defined in the registry.

•

IMO Class Name—Currently unavailable in this version.

Table 2-1 describes the icons that appear.
Table 2-1

Icon

Hierarchy Manager Window Tools

Name

Description

Copy

Copies the soft property from a selected node in the hierarchy to another node in
the hierarchy. A copy icon is displayed to the left of the selected node.

Cut

Cuts the soft property from a selected node in the hierarchy to move it to another
node in the hierarchy. A cut icon is displayed to the left of the selected node.

Paste

Pastes the soft property that was copied or cut from a selected node in the
hierarchy to another node in the hierarchy. A paste icon is displayed to the left of
the selected node.

Delete

Deletes the soft property from the selected node in the hierarchy.
Note

If the soft property has been deleted from all nodes, it is removed from
the list in the main dialog box of the Soft Properties Manager.

Step 4

Select the node in the hierarchy from which you want to publish the soft property.

Step 5

Click the Copy or Cut icons to perform the required action.

Step 6

Select the node in the hierarchy where you want to publish the soft property, and click the Paste icon.

Step 7

Restart the VNE on which you want to publishing to take effect.
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