CH A P T E R

3

Working with the Soft Properties Manager
This chapter describes the Soft Properties Manager working environment and how to access Soft
Properties Manager tools. In addition, it describes the process from creating to publishing a soft
property.
Topics include:

Note

•

Launching Soft Properties Manager, page 3-2

•

Soft Properties Manager Window, page 3-3

•

Soft Properties Manager Workflow, page 3-6

•

Creating or Editing a Soft Property, page 3-7

•

Defining the Soft Property General Parameters, page 3-7

•

Defining the Soft Property Parsing Parameters, page 3-9

•

Testing the Parsing Rules, page 3-14

•

Defining TCA Parameters, page 3-14

•

Debugging the Soft Property, page 3-17

•

Viewing the Soft Property in the Inventory Window, page 3-19

•

Publishing the Soft Property, page 3-19

•

Deleting a Soft Property, page 3-22

•

Importing and Exporting a Soft Property, page 3-22

We recommend that the users who manage Soft Properties have the following:
•

For their user account, the Configurator default permissions.

•

For all assigned device scopes, the Configurator security level.

Creating users with a combination of security access roles lesser than Configurator may have security
implications.
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Launching Soft Properties Manager
Soft Properties Manager is launched from a specific network element, which could be a managed
element or a selected object within a managed element, such as a port. This network element is used to
develop and test the soft property. The content that is displayed in the Soft Properties Manager window
is based on the location from which it is launched.
Once the soft property has been completed, it can be published and attached to a wider scope of managed
elements.

Note

Initially the soft property applies only to the specific object that you are working on during runtime.
Once a soft property has been published and the system has been restarted, it is applied to all objects of
the same type, according to the location to which it is published.
To open Soft Properties Manager:

Step 1

Step 2

Do one of the following:
•

In the Prime Network Vision tree pane or workspace, right-click a managed element to display a
shortcut menu. (For more information about the Prime Network Vision window, see the Cisco Prime
Network 3.8 User Guide.)

•

Open the Inventory window for the required managed element, then right-click the required object
in the network element; for example, a port or card. (For more information about the Inventory
window, see the Cisco Prime Network 3.8 User Guide.)

Choose Management > Soft Properties Management from the shortcut menu. The Soft Properties
Manager window is displayed.
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Soft Properties Manager Window
Figure 3-1 shows an example of the Soft Properties Manager window.
Figure 3-1

Soft Properties Manager Window

1

Menu bar

2

Toolbar

3

Properties panel

4

Element properties table

The Soft Properties Manager window displays a table of all existing soft properties according to the
selected entity from which it has been launched. In addition, the applicable properties panels for the
managed entity from which the Soft Properties Manager was launched are displayed. For example, the
properties panels for an ATM port are Location Information, ATM, and DS3.

Note

No soft properties are displayed in the Soft Properties Manager window for a managed element or
required object in the network element when it is opened for the first time.
The Soft Properties Manager enables you to:
•

Add a new soft property.

•

Edit an existing soft property.

•

Delete a soft property.

•

Import and export soft properties.

•

Test a soft property on the selected managed element.
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•

Publish a soft property and attach it to a wider scope of managed elements.

The Soft Properties Manager consists of the following:
•

Properties Panel, page 3-4

•

Element Properties Table, page 3-4

•

Soft Properties Manager Menu Bar, page 3-4

•

Soft Properties Toolbar, page 3-5

Properties Panel
The properties panel is a drop-down list that contains a list of panels equivalent to the panels displayed
in Prime Network Vision for the selected network element from which the Soft Properties Manager was
launched. For example, if an ATM port is selected as the launching point, the properties panel contains
Location Information, ATM, and OC3 properties. You can then select the panel to which to add the
property.

Element Properties Table
The content displayed in the element properties table changes according to the selection made in the
properties panel. The following information is displayed in the element properties table of the Soft
Properties Manager window:
•

Label—The name of the property as displayed in the GUI; for example, Port Type. For tables, this
is the table name displayed in the tab.

•

Type—The soft property type, such as Property or Table.

•

Polling—The polling group specified for the property, such as system or status.

•

Enabled—Runs (true) or does not run (false) the command.

•

Command Line—The command execution for this protocol that should be sent to the NE to retrieve
the property. This command can be either a Telnet/SSH command or an SNMP GET command for
a specific object identifier (OID).

A table can be sorted:
•

According to a column by clicking the column heading. The sort icon is displayed next to the
selected column heading.

•

In ascending or descending order by clicking the column heading. A triangle is displayed next to the
selected column heading.

Click a red triangle in a cell to expand the cell and display all information in the cell.
The Location field displays the number of selected rows and the total number of rows in the table, such
as 2/16 Selected. In addition, it displays the location of the selected row in the table, such as Line 3.

Soft Properties Manager Menu Bar
This section provides a description of each option available in the Soft Properties Manager menus:
•

Soft Properties File Menu, page 3-5

•

Soft Properties Tools Menu, page 3-5
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Soft Properties File Menu
The File menu provides the following options:
•

New Element—Create a new soft property. For more information, see Creating or Editing a Soft
Property, page 3-7.

•

Edit Element—Edit an existing soft property. For more information, see Defining the Soft Property
General Parameters, page 3-7.

•

Delete Element—Delete a soft property whether or not it has been published. For more information,
see Deleting a Soft Property, page 3-22.

Soft Properties Tools Menu
The Tools menu provides the following options:
•

Export Element—Save a soft property to a file that can later be imported to another managed
element. For more information, see Importing and Exporting a Soft Property, page 3-22.

•

Import Element—Copy a soft property from an exported file and import this soft property to another
managed element. For more information, see Importing and Exporting a Soft Property, page 3-22.

•

Hierarchy Manager—Move the soft property to a different location or change the scope of the soft
property across the network hierarchy (publishing). For more information, see Publishing the Soft
Property, page 3-19.

Soft Properties Toolbar
Table 3-1 identifies the buttons that appear in Soft Properties Manager.
Table 3-1

Icon

Soft Properties Manager Toolbar

Name

Description

New Element

Create a new soft property. For more information, see Creating or Editing a
Soft Property, page 3-7.

Edit Element

Edit an existing soft property. For more information, see Defining the Soft
Property General Parameters, page 3-7.

Delete Element Delete a soft property whether or not it has been published. For more
information, see Deleting a Soft Property, page 3-22.
Export
Element

Save a soft property to a file that can later be imported to another managed
element. For more information, see Importing and Exporting a Soft Property,
page 3-22.

Import
Element

Copy a soft property from an exported file and import this soft property to
another managed element. For more information, see Importing and
Exporting a Soft Property, page 3-22.

Hierarchy
Manager

Move the soft property to a different location or change the scope of the soft
property across the network hierarchy. For more information, see Publishing
the Soft Property, page 3-19.
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Soft Properties Manager Workflow
Figure 3-2 illustrates the steps required to define a new soft property definition using Soft Properties
Manager and the order in which they must be performed.
Figure 3-2
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At any point after the soft property has been defined, it can be tested and published to a wider scope of
managed elements or network elements.
For more information, see the following sections:
•

Creating or Editing a Soft Property, page 3-7

•

Defining the Soft Property General Parameters, page 3-7

•

Defining the Soft Property Parsing Parameters, page 3-9

•

Testing the Parsing Rules, page 3-14

•

Defining TCA Parameters, page 3-14

•

Debugging the Soft Property, page 3-17

•

Viewing the Soft Property in the Inventory Window, page 3-19

•

Publishing the Soft Property, page 3-19
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•

Deleting a Soft Property, page 3-22

•

Importing and Exporting a Soft Property, page 3-22

Creating or Editing a Soft Property
Soft Properties Manager enables you to create or edit an existing soft property using the Add Soft
Property dialog box. First, you must determine the managed element or selected object in the network
element to which the soft property should be added.
To create a soft property:
Step 1

In Prime Network Vision:
•

Right-click a managed element in Prime Network Vision or the workspace.

•

Open the Inventory window for the required managed element, then right-click the required object.

Step 2

Choose Management > Soft Properties Management. The Soft Properties Manager window is
displayed.

Step 3

Open the Add Soft Property dialog box in one of the following ways:
•

Click New Element in the toolbar.

•

Choose File > New Element.

The Add Soft Property dialog box is divided into the following tabs (configuration categories):
•

General—Configure general definitions for the soft property. For more information, see Defining
the Soft Property General Parameters, page 3-7.

•

Parsing—Configure parsing definitions for the soft property. For more information, see Defining the
Soft Property Parsing Parameters, page 3-9.

•

TCA Alarms—Configure alarm threshold management for the soft property. For more information,
see Defining TCA Parameters, page 3-14.

Defining the Soft Property General Parameters
The General tab enables you to configure general definitions for the soft property. You can also configure
just a single soft property field or an entire soft property table.
To define the general parameters:
Step 1

Select the General tab in the Add Soft Property dialog box.
The following fields are displayed:
•

Name—The soft property identifier, which is unique to the location and IMO scope. This field is
mandatory.

Note

A warning message appears if the name specified already exists. You are asked whether to
override the existing soft property implementation.
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•

Label—The soft property name that is displayed in the GUI and which is unique to the location and
IMO scope. For tables, this is the table name that is displayed in the tab. This field is mandatory.

•

Description—A description of the soft property.

The following drop-down lists are displayed:
•

Type—The soft property type, either Property (default value) or Table. The fields displayed in the
Parsing tab depend on your selection.

Note
•

If you select Table, the TCA Alarms tab does not appear in the Add Soft Property dialog box.

Polling Rate—The polling rate group to which the soft property is assigned:
– topo_I2
– topo_I1
– configuration
– status
– system

The following check box is displayed:
•

Enabled—Indicates whether the VNE is to run the command. This option is enabled by default.

The following buttons are displayed in the Add Soft Property dialog box:
•

OK—Validates the changes according to the field’s rules; that is, the definitions defined in the
General, Parsing, and TCA Alarms tabs. If validation is successful, the changes are saved and the
Add Soft Property dialog box closes.

Note

Step 2

A warning message is displayed if the validation is unsuccessful.

•

Cancel—Closes the Add Soft Property dialog box without saving any changes.

•

Debug—Opens the Debug Soft Property dialog box, displaying the status of the soft property debug.

Define the soft property’s general parameters.

Note

If you select the soft property type Table, proceed to Defining the Parsing Parameters of a Soft
Property Table, page 3-13 to continue creating the soft property.

Proceed to Defining the Soft Property Parsing Parameters, page 3-9 to define the parsing parameters of
the soft property.
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Defining the Soft Property Parsing Parameters
The Parsing tab enables you to configure, view, and edit parsing definitions defined for the soft property.
To define the parsing parameters:
Step 1

Select the Parsing tab in the Add Soft Property dialog box. (The Parsing tab is available if you select
the type Property in the General tab.)

Note

If you select the type Table in the General tab, only the SNMP option is available. For more
information about defining parsing parameters for a soft property table, see Defining the Parsing
Parameters of a Soft Property Table, page 3-13.

The Parsing tab enables you to specify either a Telnet/SSH command or a MIB OID for an SNMP GET
command.
The following radio buttons are displayed in the Parsing tab:
•

Use SNMP get(OID)—The SNMP retrieval expression. The text field is enabled and mandatory
when this option is selected. The expression can include environmental arguments.

Note

When Use SNMP get(OID) is selected, press Ctrl-Spacebar in the text box to view a list of
all parameters available for all protocols.

Figure 3-3 shows an example of the output if you press Ctrl-Spacebar for a port.
Figure 3-3

Output

Sometimes, when building a soft property, the Telnet/SNMP command is context sensitive. A good
example of this is when you want to retrieve port-related data through SNMP. Searching all ports to
find the relevant port each time is not efficient and can greatly affect system performance. To solve
this problem, instrumentation data is available for the soft property. Instrumentation data is a variant
between different elements in the system, depending on the context object you want to add the soft
property to.
In this example, the instrumentation data is the port ifIndex. To use the ifIndex in the OID, use
1.3.1.6......$ifIndex$.5.6.4. To determine the instrumentation data that is available for your context
object, press Ctrl-Spacebar while the cursor is in the command field.
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•

Use Telnet/SSH—The Telnet/SSH retrieval expression. The text field is enabled and mandatory
when this option is selected. The expression can include environmental.

Note

When Use Telnet/SSH is selected, press Ctrl-Spacebar in the text box to open a list of all
parameters available for all protocols.

The text area in the Parsing tab enables you to enter the command line of the protocol. For example,
for SNMP enter the OID of the SNMP packet, and for Telnet enter the Telnet command line.

Note

The SNMP OID must start with a dot. For example, if you want to retrieve the OID value of
1.3.6…. you must enter .1.3.6…..

The following columns are displayed in the table of the Parsing tab:
•

Index—Displays the order of the parsing rules.

•

Operation—Displays the parsing operator type selected in the Add/Edit Parsing Rule dialog box.
For more information about parsing operators, see Chapter 5, “Parsing Operators/Rules.”

The following buttons are displayed in the Parsing tab:
•

Add—Add a new operator. The Add/Edit Parsing Rule dialog box is displayed.

•

Edit—Edit an existing operator. The Add/Edit Parsing Rule dialog box is displayed.

Note
•

Delete—Delete the selected operator from the table.

Note
•

You can also edit an operator by double-clicking the required operator in the table.

Delete an operator by selecting it in the table, then clicking Delete.

Test—Enables you to test the soft property parsing. The Test Parsing Rules dialog box is displayed.
For more information, see Testing the Parsing Rules, page 3-14.
The reorder arrows enable you to move the rules up and down within the sequence to change the
parsing order.

Step 2

Select the type of retrieval expression: Use SNMP get(OID) or Use Telnet/SSH.
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Step 3

Click Add. The Add/Edit Parsing Rule dialog box is displayed (see Figure 3-4).
Figure 3-4

Add/Edit Parsing Rule Dialog Box
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The Add/Edit Parsing Rule dialog box is used for adding, editing, and testing parsing operators. Once
the required operator is selected, the corresponding arguments are displayed.
The following drop-down lists are displayed in the Add/Edit Parsing Rule dialog box:
•

Input Buffer—Displays the list of output arguments defined in previous operators and the default
(the standard output buffer of the last predecessor operator that was not redirected into an output
argument). This field is mandatory.
The parsing result of operator N is available by default as input for operator N+1 (it appears as
Default in the Input Buffer field). The parsing result of operator N might be directed to a locally
defined environment argument. In this case, the input for operator N+1 is the same as for operator
N. Changing the default input buffer is supported by selecting an input buffer other than Default.
The available input buffers for Operator N+1 are the set of output arguments defined in Operators 1
through N.
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The fields displayed in the Expression area of the window change depending on your selection in
the Operator drop-down list, which is mandatory. When an operator is selected, the corresponding
arguments are displayed. The Operator drop-down list enables you to select one of the available
parsing operators:
– Header And Footer—Removes a specified number of lines from the header and footer of the

input text. For more information, see Header and Footer, page 5-1.
– Remove Lines—Removes a range of lines from the specified starting row to the specified end

row of the input text. For more information, see Remove Lines, page 5-3.
– Select Lines—Extracts a range of lines from the specified starting row to the specified ending

row of the input text. For more information, see Select Lines, page 5-4.
– Replace—Finds one substring or all occurrences of a substring, which matches a specified

regular expression, and replaces it with a specified value. For more information, see Replace,
page 5-5.
– Match—Finds and extracts a substring that matches a specified regular expression. If no match

can be found, the output buffer receives an empty string. For more information, see Match,
page 5-6.
– Set—Formats the input buffer and local arguments defined in previous operators using a regular

expression. For more information, see Set, page 5-7.
– Substring—Extracts a substring of a specified length from a specified starting point. For more

information, see Substring, page 5-8.
– Parse Integer—Uses the substring rule and, when a result is received with the substring,

converts it into an integer value. For more information, see Parse Integer, page 5-9.

Note

If the substring operator contains any characters, the parsing integer operator fails.

The Argument 1 and Argument n fields displayed in the Add/Edit Parsing Rule dialog box are dynamic
and list arguments according to the selected operator. For more information about operators and
corresponding arguments, see Chapter 5, “Parsing Operators/Rules.”
The Direct result to output buffer variable check box and corresponding field enable you to direct the
parsing output to the provided argument instead of it being the input value for the next operator. The text
box is enabled only when the check box is selected. A unique (within the complete parsing sequence of
this soft property instance) argument name must be provided in this field.
The Simulation area is divided into two text areas:
•

The Source text box is used to enter or paste parsing information.

•

The Result text box is used to view the parsed result.

The information entered and displayed in the Simulation area is not saved when the dialog box is closed.
The Test Expression button parses the information entered in the Source text box according to the
parsing operator defined and displays the result in the Result text box.
The following buttons are displayed in the Add/Edit Parsing Rule dialog box:

Step 4

•

OK—Validates the operator according to the selected operator’s validation rules. Saves the changes
and closes the Add/Edit Parsing Rule dialog box.

•

Cancel—Closes the Add/Edit Parsing Rule dialog box without saving the changes.

Define the parsing rules.
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Proceed to Testing the Parsing Rules, page 3-14 to test the parsing rules.

Defining the Parsing Parameters of a Soft Property Table
The fields that appear in the Parsing tab depend on your selection in the Type drop-down list in the
General tab. For example, if you select Table in the Type drop-down list in the General tab, the
Telnet/SSH options do not appear in the Parsing tab.
To define the Parsing parameters of a soft property table:
Step 1

Select the Parsing tab in the Add Soft Property dialog box.
The following radio button is displayed in the Parsing tab:
•

Use SNMP get(OID)—The SNMP retrieval expression. The text field is mandatory when this option
is selected. The expression can include environmental arguments.

Note

When Use SNMP get(OID) is selected, press Ctrl-Spacebar in the text box to view a list of
all parameters available for all protocols.

The following columns are displayed in the table of the Parsing tab:
•

Title—Displays the column headings of the table.

•

OID—Displays the column information for the table.
For more information about the buttons displayed in this tab, see Defining the Soft Property Parsing
Parameters, page 3-9.

Step 2

Click Add. The Add/Edit Column Controller dialog box is displayed.
The Add/Edit Column Controller dialog box enables you to add or edit the columns and information
displayed in the table.
The following fields are displayed in the Add/Edit Column Controller dialog box:
•

Column Title—The column heading displayed in the table.

•

Column Data—The column information displayed in the table.

The following buttons are displayed in the Add/Edit Column Controller dialog box:
•

OK—Saves the column information and closes the Add/Edit Column Controller dialog box.

•

Cancel—Closes the Add/Edit Column Controller dialog box without saving any changes.

•

Apply—Saves the column information; the Add/Edit Column Controller dialog box remains open.

Step 3

Define the soft property’s table information.

Step 4

Click OK. The Parsing tab is displayed along with the newly defined table information.

Proceed to Debugging the Soft Property, page 3-17 to debug the soft property table.
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Testing the Parsing Rules
The Soft Properties Manager provides testing functions, which enable you to simulate each parsing rule
as well as the whole parsing sequence. In addition, you can test and debug the property on the NE.
You can test and simulate the actual input parsing according to the parsing operators and display the
parsing result. This tests all defined parsing rules in the order in which they are given.
To test the parsing rules:
Step 1

Click Test Expression in the Add/Edit Parsing Rule dialog box. The Test Parsing Rules dialog box is
displayed.
The Input Buffer area enables you to enter the input to parse. You can copy and paste the parsing input
or it can be retrieved from the device. The Input Buffer area is mandatory.
The Output Buffer area displays the parsing result log. It can contain the final parsing result or the entire
parsing log with comments for each parser used.
The following buttons are displayed in the Test Parsing Rules dialog box:
•

Close—Closes the Test Parsing Rules dialog box.

•

Test—Parses the input entered in the Input Buffer area according to the parsing operators. The
parsing result is displayed in the Output Buffer area.

Step 2

Click Test. The results of the test are displayed Test Parsing Rules dialog box.

Step 3

Click Close. The Add/Edit Parsing Rule dialog box is displayed.

Step 4

Click OK. The Parsing tab is displayed.

Proceed to Defining TCA Parameters, page 3-14 to define the TCA parameters for the soft property.

Defining TCA Parameters
The TCA Alarms tab enables you to set threshold conditions for the soft property value, which generates
an alarm when crossed.
This feature allows you to:
•

Select the severity level to associate with an alarm.

•

Enable or disable an alarm.

•

Select the threshold type.

You can define multiple alarms for the same soft property. The alarm is displayed in the ticket pane of
the Prime Network Vision window.
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To define TCA parameters:
Step 1

Select the TCA Alarms tab.

Note

The TCA Alarms tab is displayed only if you select the type Property in the General tab.

The following columns are displayed in the TCA Alarms tab:
•

Description—A free text area used to describe the alarm.

•

Trigger—Displays the details of the trigger selected; that is, what causes the alarm to be sent. For
more information, see Chapter 6, “Alarm Threshold Triggers.”

•

Enabled—Displays the status of the alarm: enabled (true) or disabled (false), as defined in the
General tab of the Add TCA dialog box.

The following buttons are displayed in the TCA Alarms tab:
•

Add—Opens the Add TCA dialog box, enabling you to define the parameters of the TCA.

•

Edit—Opens the Add TCA dialog box, enabling you to edit the parameters of a previously defined
TCA.

Note
•

Delete—Deletes the selected TCA from the TCA Alarms tab.

Note
Step 2

Edit the parameters of a TCA by selecting it in the table, then clicking Edit.

Delete a TCA by selecting it in the table, then clicking Delete.

Click Add. The Add TCA dialog box is displayed. It is divided into the following tabs:
•

General—Define the general parameters, such as the severity and name, of the TCA.

•

Trigger—Define the alarm threshold trigger for the TCA. For more information, see Chapter 6,
“Alarm Threshold Triggers.”

The following fields are displayed in the General tab of the Add TCA dialog box:
•

Name—The alarm name that is displayed in the ticket pane when the alarm is triggered.

•

Description—A description of the alarm.

The following check boxes are displayed in the General tab of the Add TCA dialog box:
•

Enabled—Enables or disables the alarm; select this option to enable the alarm.

•

Can be correlated to other alarms—Select this option to correlate this alarm to other alarms. For
more information about correlating alarms, see the Cisco Prime Network 3.8 User Guide.

•

Other alarms can correlate to this alarm—Select this option to enable other alarms to be correlated
to this alarm. For more information about correlating alarms, see the Cisco Prime Network 3.8 User
Guide.
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The following drop-down list is displayed in the General tab of the Add TCA dialog box:
•

Alarm Severity—Select the severity level associated with the alarm:
– Critical
– Major
– Minor
– Warning
– Normal

For more information about alarm severity, see the Cisco Prime Network 3.8 User Guide.
The following buttons are displayed in the General tab of the Add TCA dialog box:
•

OK—Saves the parameters of the TCA and closes the Add TCA dialog box.

•

Cancel—Closes the Add TCA dialog box without saving any changes.

Step 3

Define the General parameters for the TCA.

Step 4

Select the Trigger tab and define the Trigger parameters for the TCA:
In the Trigger drop-down list, select a threshold type:
•

Value Equal—The alarm condition is reached when the soft property value is equal to the value
defined in Alarm Value, regardless of whether or not it is numeric. For more information, see Value
Equal, page 6-1.

•

Value Not Equal—The alarm condition is reached when the soft property value is not equal to the
value defined in the Alarm Value, regardless of whether or not it is numeric. For more information,
see Value Not Equal, page 6-2.

•

Upper Threshold—The upper threshold value which, when crossed, triggers the alarm for the
defined numeric properties. For more information, see Upper Threshold, page 6-2.

•

Lower Threshold—The lower threshold value which, when crossed, triggers the alarm for the
defined numeric properties. For more information, see Lower Threshold, page 6-2.

•

Upper Rate—The upper rate threshold value for the performance counters which, when crossed,
triggers the alarm for the defined numeric properties. For more information, see Upper Rate,
page 6-3.

•

Lower Rate—The lower rate threshold value for the performance counters which, when crossed,
triggers the alarm for the defined numeric properties. For more information, see Lower Rate,
page 6-3.

For more information about triggers, see Chapter 6, “Alarm Threshold Triggers.”
If you do not want the alarm to be triggered immediately, select the check box and specify the number
of seconds the trigger condition should persist until the alarm is triggered.
Step 5

Click OK. The TCA Alarms tab is displayed.

Proceed to Debugging the Soft Property, page 3-17 to debug the soft property.
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Editing a Soft Property
You can edit an existing soft property. The soft property that is edited affects only the local instance.
When an inherited soft property is edited, the new local instance overrides the generic soft property
definition for the specific managed element.
To edit a soft property:
Step 1

In the Soft Properties Manager window, select the soft property that you want to edit.

Step 2

Open the hierarchy manager table in one of the following ways:
•

Click Edit Element in the toolbar.

•

Choose File > Edit Element.

•

Right-click the soft property, then choose Edit Element.

The hierarchy manager table is displayed.

Note

If user-friendly VNE names exist in the schema, the hierarchy manager table displays the
user-friendly registry location names in the VNE Hierarchy Location column. A user-friendly
VNE name is a hierarchy path that has been defined in the registry and is then displayed in the
hierarchy manager table. For more information, see Publishing the Soft Property, page 3-19.

Step 3

Select the required version of the soft property from the hierarchy manager, then click OK. The Edit Soft
Property dialog box is displayed for the selected soft property.

Step 4

Edit the soft property as required by changing the existing information using the Soft Properties Manager
window.

Step 5

When the soft property has been successfully edited, click OK in the Edit Soft Property dialog box to
save your changes. The edited soft property is supported and appears in the Soft Properties Manager
window.

For information about viewing edited soft properties, see Viewing the Soft Property in the Inventory
Window, page 3-19. For information about publishing edited soft properties, see Publishing the Soft
Property, page 3-19.

Debugging the Soft Property
You can debug the soft property on the managed element or selected object in the network element by
opening the Debug Soft Property dialog box, which displays the status of the soft property when it is
debugged. For example, you might want to confirm that a selected device supports Telnet. (See
Chapter 4, “Soft Property Examples” for more information.)

Note

No notification message is displayed when a VNE fails to collect properties. The properties are not
populated in the GUI.
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To debug the soft property:
Step 1

Click Debug in the Add Soft Property dialog box. The Debug Soft Property dialog box is displayed with
the results of the debug.
Figure 3-5

Debug Soft Property Dialog Box

Step 2

Click Close. The Add Soft Property dialog box reappears.

Step 3

Click OK. The Soft Properties Manager window is displayed with the newly created soft property
displayed in the element properties table.

Step 4

Click Close. The Prime Network Vision or Inventory window is displayed, depending on your original
selection.

Proceed to Viewing the Soft Property in the Inventory Window, page 3-19 to view the results of the soft
property in the Inventory window.
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Viewing the Soft Property in the Inventory Window
After creating or editing a soft property, you can view the results in the Properties pane of the Inventory
window for the managed element or selected object in the network element.
Note

You can view the soft property in the Inventory window only after it has been closed and reopened. For
example, if you open the Inventory window for a VNE and add a property to one of the ports, it is
displayed only after you close and reopen the Inventory window for the VNE.
To view the soft property:

Step 1

Right-click the required managed element in the tree pane or workspace of the Prime Network Vision
window, then select Inventory. The Inventory window for the required managed element is displayed
with the newly defined soft property or soft property table.

Step 2

Click the top right corner to close the Inventory window.

Proceed to Publishing the Soft Property, page 3-19 to publish the soft property.

Publishing the Soft Property
A property definition is applicable to all objects of the same type in the selected NE. However, you might
want to apply the same property definitions to all NEs of the same type or family. This requires moving
the property definition from the specific NE instance to a higher level in the registry hierarchy.
After the soft property has been defined and tested on a specific instance of a managed element, it can
be published and applied to a wider scope of managed elements in the network.
The Soft Properties Publish Controller dialog box enables you to publish the soft property to one or more
locations across the inheritance hierarchy (as defined in the system). In other words, you define the scope
where the soft property is to be applied in the hierarchy.

Note

User with a Configurator role can add and publish soft properties on all devices regardless of the device
scope defined for the user.
Different variations of a soft property can be used for different managed elements and network elements,
where the implementation of the soft property is different for each managed element or network element.
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Figure 3-6 shows an example of an inheritance hierarchy. In this example, the top level of the hierarchy
is All devices, and the lowest level of the hierarchy is Device XYZ.
Figure 3-6

Inheritance Hierarchy Example

All devices

Cisco devices

Cisco routers

Device XYZ

180326

Cisco 7200

When a soft property is published to a node in the hierarchy, it overrides any inherited soft properties
from a higher level and applies automatically to all its children. For example, if a soft property is
published to Cisco 7200 devices, it overrides any variant of this soft property which is defined at a higher
level, and is assigned to all devices of type Cisco 7200 in the system.

Note

We strongly recommend that you measure the effect of publishing the soft property on system memory
usage before you publish the soft property. To view the changes, you must restart the VNE or unit for
the publishing to take effect. For more information about measuring the effect of publishing the soft
property, contact your Cisco account representative.

Note

Soft property publishing sometimes deeply affects system memory usage, device utilization, and system
performance. For example, you can add a property that contains the show running-config command to
a device and publish it to a group of devices. This is likely to cause both system memory usage and
device utilization to jump.
To publish a soft property:

Step 1

In Prime Network Vision, do one of the following:
•

Right-click a managed element in the tree pane or workspace.

•

Open the Inventory window for the required managed element, then right-click the required object.

Step 2

Choose Management > Soft Properties Management.

Step 3

Select the required properties panel and soft property in the element properties table.

Step 4

Open the hierarchy manager table in one of the following ways:
•

Click Hierarchy Manager in the toolbar.

•

Choose Tools > Hierarchy Manager.

•

Right-click the item, then choose Hierarchy Manager.
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If user-friendly VNE names exist in the schema, the hierarchy manager table displays these
user-friendly registry location names in the VNE Hierarchy Location column. A user-friendly
VNE name is a hierarchy path that has been defined in the registry and is then displayed in the
hierarchy manager table. For more information, see Publishing the Soft Property, page 3-19.

Note

Each row that is displayed in the hierarchy manager table represents a different level of the hierarchy.
The rows are displayed in descending order; the top row is the highest level of the hierarchy and the
bottom row is the lowest level of the hierarchy.
The following information is displayed in the table:
•

Exist—When a node in the hierarchy is selected, it indicates that a local variant of the soft property
exists for that node.

•

VNE Hierarchy Location—The hierarchy path, as defined in the registry.

•

IMO Class Name—Currently unavailable in this version.

Table 3-2 describes the icons that appear.
Table 3-2

Icon

Hierarchy Manager Window Tools

Name

Description

Copy

Copies the soft property from a selected node in the hierarchy to another node in
the hierarchy. A copy icon is displayed to the left of the selected node.

Cut

Cuts the soft property from a selected node in the hierarchy to move it to another
node in the hierarchy. A cut icon is displayed to the left of the selected node.

Paste

Pastes the soft property that was copied or cut from a selected node in the
hierarchy to another node in the hierarchy. A paste icon is displayed to the left of
the selected node.

Delete

Deletes the soft property from the selected node in the hierarchy.
Note

If the soft property has been deleted from all nodes, it is removed from
the list in the main dialog box of the Soft Properties Manager.

The following button is displayed:
•

Close—Closes the Hierarchy Manager window without publishing the soft property.

Step 5

Select the node in the hierarchy from which you want to publish the soft property.

Step 6

Click Copy or Cut in the toolbar to copy or cut the soft property.

Step 7

Select the node in the hierarchy where you want to publish the soft property.

Step 8

Click Paste on the toolbar to paste the soft property.

Step 9

Restart the VNE on which you want to publishing to take effect.
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Deleting a Soft Property
Soft properties that you create are, by default, always created as a local instance. A soft property that is
defined locally is selected in the Soft Properties Publish Controller dialog box. You can delete soft
properties whether or not they have been published.
To delete a soft property:
Step 1

Select the soft property that you want to delete in the element properties table of the Soft Properties
Manager dialog box.

Step 2

Delete the soft property in one of the following ways:
•

Click Delete Element in the toolbar.

•

Choose File > Delete Element.

•

Right-click the soft property, then choose Delete Element.

A warning message is displayed.
Step 3

Click Yes. The soft property is deleted and no longer appears in the element properties table of the Soft
Properties Manager window.

Importing and Exporting a Soft Property
The Soft Properties Manager enables you to export (save) a soft property definition to a file. The soft
property definition can then be imported (copied) to another managed element.
In addition, you can export and import a soft property definition to a file and publish it to multiple places
in the Hierarchy Manager window.

Exporting a Soft Property
To export a soft property:
Step 1

Select the soft property that you want to export in the element properties table of the Soft Properties
Manager dialog box.

Step 2

Open the Export dialog box in one of the following ways:
•

Click Export Element in the toolbar.

•

Choose Tools > Export Element.

•

Right-click the property, then choose Export Element.

The Export dialog box is displayed.

Note

If user-friendly VNE names exist in the schema, the hierarchy manager table displays these
user-friendly registry location names in the VNE Hierarchy Location column. A user-friendly
VNE name is a hierarchy path that has been defined in the registry and is then displayed in the
hierarchy manager table. For more information, see Publishing the Soft Property, page 3-19.
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Step 3

Select the version that you want to export in the table of the Export window. The version is selected in
the table.

Step 4

Click OK. The Export Property dialog box is displayed.

Step 5

Browse to the directory where you want to save the soft property.

Step 6

In the File name field, enter a name and extension (for example, .txt) for the soft property.

Step 7

Click Save. The soft property is saved in the selected directory. The Export dialog box is displayed.

Step 8

Click Close. The Soft Properties Manager window is displayed.

Importing a Soft Property
To import a soft property:
Step 1

Open the Import Element dialog box in one of the following ways:
•

Click Import Element in the toolbar.

•

Choose Tools > Import Element.

Step 2

Browse to the directory and soft property that you want to import.

Step 3

Click Open. The Import Elements window is displayed.

Step 4

Select the version that you want to import in the table of the Import Elements window. The version is
selected in the table.

Step 5

Click OK. The Soft Properties Manager window is displayed.

Step 6

Click Close. The soft property is imported to the selected managed element or network element and
displayed in the Soft Properties Manager window.
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