Managing Address Space
Address blocks provide an organizational structure for addresses used across the network. Address blocks
can consist of static addresses or dynamic addresses allocated to DHCP servers for lease assignment. An
address block can have any number of child address blocks and can culminate in one or more child subnets.
The address block administrator is responsible for these objects. This administrator can create parent and child
address blocks or subnets, which are always the leaf nodes of the address space. Static subnets can be further
subdivided into one or more IP address ranges. However, dynamically added subnets create their own subnets
that the administrator cannot modify or delete.

Note

For IPv6 address management, see the Viewing IPv6 Address Space, on page 13
• Address Block Administrator Role, on page 1
• Address Blocks and Subnets, on page 2
• Pulling and Pushing, on page 8
• Viewing Address Space, on page 10

Address Block Administrator Role
The address block administrator role manages address space at a higher level than that of specific subnet or
static address allocations. This is actually a middle manager role, because there is likely to be a higher authority
handing out address blocks to the system.

Related Topics
Required Permissions, on page 1
Role Functions, on page 2

Required Permissions
To exercise the functions available to the address administrator, you must have at the:
• Regional cluster—The regional-addr-admin role assigned. This role should probably be unencumbered
by further lease-history, ipv6-management, byod-management, and dhcp-management subrole restrictions.
• Local cluster—The addrblock-admin role assigned.

Managing Address Space
1

Managing Address Space
Role Functions

Role Functions
These functions are available to the address block administrator at the:
• Regional cluster:
• Address aggregation. For example, if the 10.0.0.0/16 address block exists at the regional cluster and
a local cluster administrator creates the 10.1.1.0/24 address block, the local address block (through
replication) is rolled up under its parent at the regional cluster. This allows a unified view of the
address space at the regional cluster without affecting the local cluster configuration.
• Address delegation. Administrators can delegate address space to the local cluster, thereby giving
up authority of the delegated object.
• DHCP utilization reports. The regional cluster supports DHCP utilization reporting across regions,
protocol servers, and sets of network hardware.
• Lease history reports. This provides a single vantage point on the lease history of multiple DHCP
servers. The administrator can query the history data at the local cluster to constrain the scope of
the history report. Lease histories can be queried by VPN (if defined), time range and criteria that
contain the following choices: IP address, MAC address, IP address range, or all. This is an important
feature to meet government and other agency mandates concerning address traceability. For details
on querying lease history, see Querying Leases.
• Polling configurations. The administrator can control the intervals and periods of local cluster polling
for replication, IP histories, and DHCP utilization. You can also set the lease history trimming ages
and compacting intervals at the CCM server level. (See the "Managing the Central Configuration"
chapter in Cisco Prime IP Express 9.1 Administrator Guide)
• Check the DHCP and address data consistency.
• Local cluster:
• Manage address blocks, subnets, and address types.
• Check the DHCP and address data consistency.

Address Blocks and Subnets
An address block is an aggregate of IP addresses based on a power-of-two address space that can be delegated
to an authority. For example, the 192.168.0.0/16 address block (part of the RFC 1918 private address space)
includes 216 (or 65536) addresses. Address blocks can be further divided into child address blocks and subnets.
For example, you might want to delegate the 192.168.0.0/16 address block further into four child address
blocks—192.168.0.0/18, 192.168.64.0/18, 192.168.128.0/18, and 192.168.192.0/18.

Note

The DHCP server also uses address blocks to manage subnet allocation for on-demand address pools (see
Configuring Subnet Allocation). Address blocks used for dynamic address pools must be created using the
dhcp-address-block command in the CLI. The unified address view in the web UI also displays these dynamic
address blocks, but does not provide an edit link to them, because they have been delegated in their entirety
to the DHCP server. They should not be further subdivided for subnet allocation. The DHCP server
automatically handles these address blocks as it receives subnet requests. These address pools are indicated
by a D (for “Delegated”).
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A subnet is the leaf node of the address space and cannot be further subdivided. If you create the
192.168.50.0/24 subnet, you can subsequently create an address block by that same name, and the subnet will
become a child of the address block. However, you cannot further subdivide or delegate the 192.168.50.0/24
subnet.
Subnets can have one or more defined address ranges. Address blocks cannot have address ranges. When you
create an address range for a subnet by using the web UI, it becomes a static range, meaning that it cannot be
allocated dynamically using DHCP. However, the web UI shows any dynamic ranges defined by DHCP
scopes for the subnet. Displaying the ranges as such indicates where overlaps may occur between assigning
static addresses for the address space and dynamic addresses for scopes.
The address space view shows the hierarchy of address block and subnets and their parent-child relationships.
The hierarchy does not go down to the level of address ranges for each subnet. These are displayed when you
access the subnet.

Related Topics
Viewing Address Blocks, Subnets, and Address Types, on page 12
Knowing When to Add Address Blocks, on page 4
Adding Address Blocks, on page 4
Delegating Address Blocks, on page 6
Pushing Subnets to Local DHCP Servers, on page 9
Creating Reverse Zones from Subnets, on page 6
Reclaiming Subnets, on page 7
Adding Children to Address Blocks, on page 7
Adding Address Ranges to Subnets, on page 8
Viewing Address Utilization for Address Blocks, Subnets, and Scopes, on page 10

Subnet Allocation and DHCP Address Blocks
Cisco Prime IP Express supports creating on-demand address pools as a network infrastructure for address
provisioning and VPNs. Traditionally, the DHCP server is limited to interact with individual host devices.
Through subnet allocation, the server can interact with VPN routers and other provisioning devices to provision
entire IP subnets. This Cisco Prime IP Express feature enhances the on-demand address pool capability
currently supported by the Cisco IOS Relay Agent.
Cisco Prime IP Express supports explicitly provisioned subnets. You must explicitly configure the DHCP
server address space and subnet allocation policies before the server can allocate pools or leases. You can
thereby configure a server as a pool manager to manage subnets and delegate them to client devices.
You manage DHCP subnet allocation using DHCP server address block objects in Cisco Prime IP Express.
A DHCP address block is a range of contiguous IP addresses delegated to the DHCP server for assignment.
The server expects to subdivide these addresses into pools so that it or other servers or devices can allocate
them. DHCP address blocks are parents to subnets. These DHCP address blocks are distinct from the address
blocks you can create using the Cisco Prime IP Express web UI, which are static. DHCP address blocks cannot
include static address ranges or lease reservations.
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The image below shows a sample environment where a DHCP server allocates entire subnets to access
concentrators or other provisioning devices, in addition to servicing individual clients. The traditional
client/server relationship is shown on the left of the diagram, while the subnet allocation to access concentrators
is shown on the right of the diagram. Dialup customers, for example, connect to the service provider network
at two ISP gateways (routers), which connect to the management network segment where the DHCP server
resides. The gateways provision addresses to their connected clients based on the subnet requested from the
DHCP server.
Figure 1: Sample DHCP Subnet Allocation Configuration

Knowing When to Add Address Blocks
This use case describes the set of user actions associated with adding a new address block to the network in
a shared management network. These preconditions are assumed:
1. From summary IP address utilization reports, an address block administrator notes that the top level
address block of the company is nearing the 90% utilization mark.
2. The address block administrator submits a request for more address space from ARIN (or some other
numbering authority) and the request is granted.
Once the address space is made available, the regional address administrator:
1. Adds the new blocks to the central address block map, and based on a review of the utilization reports,
creates and delegates address blocks to be used by the local clusters. The action of delegating the address
blocks causes them to be pushed to the local clusters.
2. Allocates the new address space to network elements as needed using failover synchronization to simplify
the configuration tasks:
• Allocates subnets to a failover pair (gets a scope template for the subnet, either from the subnet or
the failover pair).
• Finds a free subnet (finds the address block of the right type).
• Allocates the free subnet to an address destination (DHCP server or other destination).

Adding Address Blocks
Once you configure your network, you can add DHCPv4 address blocks.
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Local Advanced and Regional Advanced Web UI
To view the CCM address blocks, from the Design menu, choose Address Blocks under the DHCPv4 submenu
to open the List/Add DHCP Address Blocks page.
To add an address block, click the Add Address Block icon in the Address Blocks pane on the left. Enter its
network address in the Address field, then choose the address mask from the drop-down list. For example,
enter 192.168.50.0 in the Address field, then choose 24 in the drop-down list to create the 192.168.50.0/24
address block, which is all the addresses in the range 192.168.50.0 through 192.168.50.255.
For a review of the number of available addresses for each subnet mask, see the table below. These available
hosts exclude the two network and broadcast addresses in each range.
Table 1: Subnet Masking

Network Mask

Octet Designation

Available Hosts in Each Address
Range

/8

255.0.0.0

16777214

/9

255.128.0.0

8338606

/10

255.192.0.0

4194302

/11

255.224.0.0

2097150

/12

255.240.0.0

1048574

/13

255.248.0.0

524286

/14

255.252.0.0

262142

/15

255.254.0.0

131070

/16

255.255.0.0

65534

/17

255.255.128.0

32766

/18

255.255.192.0

16382

/19

255.255.224.0

8190

/20

255.255.240.0

4084

/21

255.255.248.0

2046

/22

255.255.252.0

1022

/23

255.255.254.0

510

/24

255.255.255.0

254

/25

255.255.255.128

126

/26

255.255.255.192

62

/27

255.255.255.224

30
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Network Mask

Octet Designation

Available Hosts in Each Address
Range

/28

255.255.255.240

14

/29

255.255.255.248

6

/30

255.255.255.252

2

CLI Command
Use address-block [vpn-name/]address/mask create [attribute=value ...]. For example:
nrcmd> address-block 192.168.0.0/16 create

Delegating Address Blocks
Address block delegation is the coordinated actions of marking the delegated address block at the regional
cluster as being delegated to a local cluster and creating the delegated address block in the local cluster. To
delegate an address block to a local cluster, the address block cannot have child address blocks or subnets.
The delegated address block created at the local server must have the same address size as the one at the
regional cluster.
You can delegate only one address block to one local cluster at a time; you cannot delegate it to multiple local
clusters. You can also delegate an address block to an owner.
To delegate an address block, you must:
1. Have the central configuration administrator create a local cluster to which to delegate the address block
(see the “Configuring Server Clusters” section in Cisco Prime IP Express 9.1 Administrator Guide).
2. Have the central configuration administrator synchronize the regional cluster with the local cluster (see
the “Synchronizing with Local Clusters” section in Cisco Prime IP Express 9.1 Administrator Guide).
The local cluster will have address source references to the regional cluster through the synchronization
process.
3. Delegate the address block to the cluster or an owner.

CLI Command
When connected to a regional cluster, you can use the address-block name delegate cluster-name command.

Creating Reverse Zones from Subnets
You can create reverse zones from subnets directly on the List/Add Subnets page instead of having to do so
manually (see the "Adding Reverse Zones from Subnets" section in Cisco Prime IP Express 9.1 Authoritative
and Caching DNS User Guide). Click the Reverse Zone tab and choose a configured zone template from the
drop-down list, then click Report to show the changesets for the creation. Confirm the creation by clicking
Run.

Related Topics
Reclaiming Subnets, on page 7
Adding Address Ranges to Subnets, on page 8
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Viewing Address Utilization for Address Blocks, Subnets, and Scopes, on page 10
Pushing Subnets to Local DHCP Servers, on page 9

Reclaiming Subnets
Once you delegate a subnet to the DHCP server or router, you can reclaim it if necessary.
Local Advanced and Regional Web UI

Step 1

From the Design menu, choose Subnets under the DHCPv4 submenu to open the List/Add Subnets page.

Step 2

Select the subnet from the Subnets pane on the left to open the corresponding Edit Subnet page.

Step 3

Click Reclaim at the top of the page. This opens the Reclaim Subnet page.

Step 4

If you want to force deleting the subnet, check the Force Delete check box.

Step 5

Click Reclaim Subnet.
Note

When you push or reclaim subnets for a managed or virtual router, this sets the primary and secondary
relationships that are set for the router for all the related subnets and scopes as well.

CLI Command
When connected to a regional cluster, you can use the subnet name reclaim [-force] command.

Adding Children to Address Blocks
You might want to subdivide undelegated address blocks into child address blocks or subnets.
Local Advanced and Regional Advanced Web UI

Step 1

From the Design menu, choose Address Blocks under the DHCPv4 submenu to open the List/Add Address Blocks page.

Step 2

Click the name of an address block that is not marked as delegated (D). This opens the Edit Address Block page.

Step 3

To add a child address block, add an address that is part of the address block network address in the Address/Mask field
of the Child Address Blocks section. Choose a higher mask value than the parent address block, then click Add.
An error message appears if you try to set the same network address for a child address block as for a child subnet.
Omitting a value when you click Add automatically adds the subdivisions of the parent address space with the appropriate
mask value. For example, if the parent space is 192.168.50.0/24, you omit any child subnet value, and click Add, the
web UI adds the children in this order:
192.168.50.0/26
192.168.50.64/26
192.168.50.128/26
192.168.50.192/26

Step 4

To add a child subnet, add an address in the Address/Mask field of the Child Subnets section of the page that is part of
the address block network address, but choose a higher mask value than the parent address block. Then click Add.
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An error message appears if you try to set the same network address for a child address block as for a child subnet.
If you omit a value when you click Add, this automatically adds the subdivisions of the parent address space with the
appropriate mask value. For example, if the parent space is 192.168.50.0/24, you omit any child subnet value, and click
Add, the web UI adds the children in this order:
192.168.50.0/26
192.168.50.64/26
192.168.50.128/26
192.168.50.192/26

Adding Address Ranges to Subnets
You can edit the subnet data and add any number of address ranges to a subnet. These ranges must be in the
designated network of the subnet.
Local Advanced and Regional Web UI

Step 1

From the Design menu, choose Subnets under the DHCPv4 submenu to open the List/Add Subnets page.

Step 2

Click the name of the subnet to which you want to add address ranges, in the Subnets pane on the left. This opens the
Edit Subnet page.

Step 3

Enter the starting address of the range in the Start field in the IP Ranges area of the page, then add the ending address in
the End field. If you add just the host numbers in these fields, the relative address in the range determined by the address
mask is used.

Step 4

Click Add IP Range.

Step 5

Click Save to save the changes.

Pulling and Pushing
Pulling Replica Address Space from Local Clusters
You may choose to pull address space from the replica data of the local clusters instead of explicitly creating
it.

Note

Pulling replica address space from a local cluster where IPv4 subnets were removed does not clear the server
name on the subnet. Although the subnet is no longer used, it is still considered allocated to the server. Hence,
the delete operation does not appear for the subnet, so that you cannot delete the subnet from the regional
cluster. To push or reallocate the subnet to a different cluster, or remove it from the regional cluster, you must
first reclaim the subnet (see Reclaiming Subnets, on page 7). This clears the reference to the local server.
Regional Advanced Web UI
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Step 1

In the DHCP Address Tree (or DHCPv6 Address Tree) page, click the Pull Data icon in the Address Tree pane.

Step 2

In the Select Pull Replica Address Space (or Select Pull Replica IPv6 Address Space) page:
• To omit reservations while pulling replica, check the Omit Reservations check box.
• Select the Data Synchronization Mode (Update, Complete or Exact)

Step 3

Click Report at the top or bottom of the page.

Step 4

Confirm the summary and click OK.

CLI Commands
When connected to a regional cluster, you can use the following pull commands:
• ccm pullAddressSpace < update | complete | exact > [-omitreservations] [-report-only] [-report]
• ccm pullIPv6AddressSpace < update | complete | exact > [-report-only] [-report]

Pushing Subnets to Local DHCP Servers
You can push subnets to local DHCP servers.
Local Advanced and Regional Web UI

Step 1

Have the central configuration administrator create a local cluster and resynchronize it with the local cluster.

Step 2

Create a subnet at the regional cluster:
a) From the Design menu, choose Subnets under the DHCPv4 submenu. This opens the List/Add Subnets page.
b) Click the Add Subnet icon in the Subnets pane on the left.
c) Enter at least the network address and choose the mask of the subnet, then click Add Subnet.

Step 3

Have the central configuration administrator create a scope template so that it can create a scope to contain a subnet:
a) Log into the regional cluster as the central configuration administrator.
b) From the Design menu, choose Scope Templates under the DHCPv4 submenu to open the List/Add DHCP Scope
Templates page.
c) Click the Add Scope Templates icon in the left pane, to open the Add DHCP Scope Template page.
d) Enter the name for the scope template and click Add Scope Template.
e) In the Edit DHCP Scope Template scopename page, among other entries on this page, enter the create-range
expression in the Range Expression field to create a scope with that subnet. (If you choose a policy for the scope
template, be sure that the policy exists at the local cluster, or you must push the policy to the local cluster. See the
"Pushing Policies to Local Clusters" section in Cisco Prime IP Express 9.1 Administrator Guide.)

Step 4

As regional address administrator, add the subnet to the local cluster DHCP server:
a) Log into the regional cluster as the regional address administrator.
b) From the Design menu, choose Subnets under the DHCPv4 submenu to open the List/Add Subnets page.
c) Select the subnet from the Subnets pane on the left, to open the corresponding Edit Subnet page.
d) Click Push at the top of the page. This opens the Push Subnet page.
e) Choose the scope template from the drop-down list.
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f) Choose the cluster from the drop-down list.
g) Click Push Subnet.

CLI Command
When connected to a regional cluster, you can use the subnet name push cluster/failover-pair
[-template=template-name] command.

Viewing Address Space
The address space is a hierarchical tree of address blocks and subnets in IPv4 and prefixes in IPv6, sorted in
IP address order. You can choose the level of depth at which to display the tree. You can also expand and
contract nodes, which recursively expands or contracts all child nodes. If you pick a new level, this overrides
the previous expansion or contraction.
Local Advanced and Regional Advanced Web UI
To view the address space as a hierarchical tree:
• From the Design menu, choose Address Tree under the DHCPv4 submenu to open the DHCP Address
Tree page. Note that you can choose a VPN (if configured).
• From the Design menu, choose Address Tree under the DHCPv6 submenu to open the DHCP v6 Address
Tree page. Note that you can choose a VPN (if configured).

Viewing Address Utilization for Address Blocks, Subnets, and Scopes
You can view the current address utilization for address blocks, subnets, and scopes.

Tip

For address utilization for IPv6 prefixes, see Viewing Address Utilization for Prefixes, on page 13.
Local Advanced and Regional Advanced Web UI
The function is available on the DHCP Address Tree page, List/Add DHCP Address Blocks page, and List/Add
Subnets page. When you click the Current Usage tab, the utilization detail appears.

Note

To ensure the proper subnet-to-server mapping on this page, you must update the regional address space view
so that it is consistent with the relevant local cluster. Do this by pulling the replica address space, or reclaiming
the subnet to push to the DHCP server (see Reclaiming Subnets, on page 7). Also ensure that the particular
DHCP server is running.
The other columns in the Current Usage tab identify:
• Type—Whether the address space is an address block, subnet, or scope.
• Utilization—Displays a progress bar which indicates the usage and availability of addresses.
• View Utilization History—Appears at the regional cluster only. Clicking the Report icon ( ) opens
the Utilization History Details page.
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In the Current Usage tab, the Utilization Detail column items are expandable so that you can view the scope
data for an address block or subnet. If you click the View Details icon ( ) next to the address block, subnet,
or scope name in this column, this opens the Utilization Details page for selected item.
The Utilization Details page is read-only, and shows detailed address utilization attributes for the address
block, subnet, or scope in the form of chart and table. If you want to drill down to the actual breakup of the
usage, you can click the View Details icon on the row and an overlay with the breakup in the form of a chart
with appropriate legends is displayed. You can hover on different parts of the chart to get more details about
that particular type of usage. Click the Table tab to view the address utilization attributes described in the
table below.
Table 2: Address Utilization Attributes

Utilization Attribute

Description

aggregation-level

Granularity of this utilization data. The scope-level
is the most detailed data available from the DHCP
server. Aggregated counters are reported at the
subnet-level and addr-block-level or at the
network-level. These are the sum of scope-level data
in a given subnet, address block, or network.

Total Addresses
total-dynamic

Total number of leases, excluding reserved ones.

total-reserved

Total number of reserved leases.

Free Dynamic
avail

Number of dynamic leases that are currently available
for issue to clients.

other-avail

Number of dynamic leases that the DHCP failover
partner currently has available for issue to clients.

Active Dynamic
offered

Number of dynamic leases that are currently offered
to clients, but not yet acknowledged as being leased.

leased

Number of dynamic leases that are currently
acknowledged as leased to clients.

expired

Number of dynamic leases that are past the lease
expiration period, but will not be available for other
clients (except after the policy grace-period expires).

pend-avail

Number of dynamic leases that are waiting
acknowledgement from the failover partner that it did
not reissue the lease.

Reserved
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Utilization Attribute

Description

reserved-active

Number of reserved leases that clients are actively
using.

reserved-inactive

Number of reserved leases that clients are not actively
using.

Unavailable
unavail

Number of unreserved dynamic leases that a client
declines or the server marks with an address conflict
(usually indicating configurations that need
correcting).

reserved-unavail

Number of reserved leases that a client declines or the
server marks with an address conflict (usually
indicating configurations that need correcting).

Deactivated
deactivated

Number of dynamic and reserved leases that clients
are actively leasing (that are not offered, expired, or
released), but that an administrator deactivated.

leased-deactivated

Number of dynamic leases that clients are actively
leasing (that are not offered, expired, or released), but
that an administrator deactivated.

reserved-leased- deactivated

Number of reserved leases that clients are actively
leasing (that are not offered, expired, or released), but
that an administrator deactivated.

Additional Attributes
primary-subnet

The primary-subnet for this subnet-level or scope-level
utilization data.

selection-tags

The comma-separated list of selection tags associated
with scope-level utilization data.

Viewing Address Blocks, Subnets, and Address Types
You can view the address blocks and subnets created for a network.
Local Advanced and Regional Advanced Web UI
From the Design menu, choose Address Tree under the DHCPv4 submenu to open the DHCP Address Tree
page.
To choose a level of depth for the address space, click one of the addresses in the Address Tree pane on the
left. The details about the address appear in the page. The Address Type column identifies the type of object
displayed, an address block or a subnet. The Owner column identifies the owner of the address space, and the
Region column identifies the assigned region for the address space.
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Address spaces that were assigned dynamically are indicated by a D (for “Delegated”) in the Address Type
column. You cannot delete this delegated address space.
To refresh the view, click the Refresh icon.
You can add, modify, and delete address types. From the Design menu, choose Address Types under the
DHCP Settings submenu to open the List/Add Address Types page. Click the Add Address Types icon in
the Address Types pane on the left to open the Add Address Space Type page, and modify settings on the
Edit Address Type page. You can also pull replica address types and push address types to the local clusters
on the List/Add Address Types page.

Viewing IPv6 Address Space
From the Design menu, choose Address Tree under the DHCPv6 submenu, in the local advanced or regional
advanced web UI, to view the DHCP v6 Address Tree page. This page is like the DHCP Address Tree page
for IPv4 (see Viewing Address Space, on page 10). On the View Unified v6 Address Space page you can:
• Set a VPN for the address space from the VPN submenu under the Settings drop-down list at the top of
the web UI.
• Add a prefix by clicking the Add IPv6 Prefix icon in the Address Tree pane, enter the prefix name,
address, and choose a prefix type and prefix template. Click Add IPv6 Prefix (see Creating and Editing
Prefixes).
• Edit a prefix by selecting its name in the Address Tree pane. This opens the Edit Prefix page (see Creating
and Editing Prefixes).
• View the current usage of the prefix space (see Viewing Address Utilization for Prefixes, on page 13).

Viewing Address Utilization for Prefixes
You can view the current address utilization for prefixes.
Local Advanced and Regional Web UI
The function is available on the DHCP v6 Address Tree page Viewing Address Space, on page 10.

Tip

You can use the DHCP v6 Address Tree page to push and reclaim prefixes. Click the Push or Reclaim icon
for the desired prefix. (See Creating and Editing Prefixes for details.)
When you click the Current Usage tab, the utilization detail appears.

Note

To ensure the proper prefix-to-server mapping on this page, you must update the regional address space view
so that it is consistent with the relevant local cluster. Do this by pulling the v6 replica address space or pushing
the prefix to the DHCP server. Also ensure that the particular DHCP server is running.
The other columns under the Current Usage tab identify:
• Range—Address range of the prefix.
• Type—Whether the address space is a prefix or link.
• Active Dynamic—Addresses that are part of a dynamic range managed by DHCP and that are currently
leased, but not reserved.
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• Active Reserved—Appears at the regional cluster only. Addresses that are part of a dynamic range and
are reserved.
• View Utilization History—Appears at the regional cluster only. Clicking the Report icon ( ) opens
the Utilization History Details page.
In the Current Usage tab, the Utilization Detail column are expandable so that you can view the prefix or
parent prefix data. If you click the View Details icon ( ) next to the prefix or the parent prefix in this column,
this opens the Utilization Details page for selected item.
The Utilization Details page is a read-only page that shows detailed address utilization attributes for the prefix
or the parent prefix (identified as Totals). If you want to drill down to the actual breakup of the usage, you
can click the View Details icon on the row and an overlay with the breakup in the form of a chart with
appropriate legends is displayed. You can hover on different parts of the chart to get more details about that
particular type of usage. Click the Table tab to view the address utilization attributes described in the table
below.
Table 3: Address Utilization Attributes

Utilization Attribute

Description

aggregation-level

Granularity of the utilization data. Prefix-level indicates the data is for the
specific prefix; totals indicates the data is for the parent prefix, which is the
sum of its prefix-level counters.

dhcp-type

DHCP address assignment type, which can be dhcp (stateful), stateless (option
configuration), prefix-delegation, or infrastructure (maps a client address to
a link without an address pool).

Total Addresses
active-dynamic

Total number of dynamic leases in active use (leased, offered, released, expired,
or revoked. The Active Dynamic category shows the states of these leases.

total-reserved

Total number of reserved leases.

Active Dynamic
offered

Number of dynamic (unreserved) leases that are currently offered to clients,
but not yet acknowledged as being leased.

leased

Number of dynamic leases that are currently acknowledged as leased to clients.

expired

Number of dynamic leases that are past the lease expiration period, but will
not be available for other clients (except after the policy grace-period expires).

revoked

Number of dynamic leases that the client can no longer use, but that some
other client could be using.

Reserved
reserved-active

Number of reserved leases that clients are actively using.

reserved-inactive

Number of reserved leases that clients are not actively using.

Unavailable
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Utilization Attribute

Description

unavail

Number of unreserved dynamic leases that a client declines or the server marks
with an address conflict (usually indicating configurations that need correcting).

reserved-unavail

Number of reserved leases that a client declines or the server marks with an
address conflict (usually indicating configurations that need correcting).

Deactivated
deactivated

Number of dynamic and reserved leases that clients are actively leasing (that
are not offered, expired, or released), but that an administrator deactivated.

leased-deactivated

Number of dynamic leases that an administrator deactivated.

reserved-leased- deactivated Number of reserved leases that an administrator deactivated.
Prefix Delegation Lease Counts
max-pd-balancing-length

Prefix length used for counting the prefix delegation leases.

prefixes-in-use

Number of prefixes, of the max-pd-balancing-length prefix length, that are in
use.

prefixes-available

Number of prefixes, of the max-pd-balancing-length prefix length, available
to any client on this server.

prefixes-other-available

Number of prefixes, of the max-pd-balancing-length prefix length, available
to any client on the failover partner.

prefixes-in-transition

Number of prefixes, of the max-pd-balancing-length prefix length, in transition
between the failover partners.

Failover Related
available

Number of prefix delegation leases available to any client on this server. This
is the count of the number of lease objects and not the number of prefixes of
a specific prefix-length.

other-available

Number of prefix delegation leases that this server believes the partner has
available to any client.

pending-available

Number of leases that are in the pending-available state.

pending-delete

Number of leases that are in the pending-delete state.

Additional Attributes
cluster-id

Local cluster that reported this utilization data.

link-name

Link for this prefix-level utilization data.

owner

Owner associated with this prefix or link.

region

Region associated with this prefix or link.
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Utilization Attribute

Description

selection-tags

Comma-separated list of selection tags associated with prefix-level utilization
data.

timestamp

Time when this utilization data was collected.
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