Licenses and Software Updates

This section contains the following topics:

* Prime Infrastructure Licensing , on page 1
* Controller Licensing, on page 5

* MSE Licensing , on page 7

* Assurance Licensing , on page 12

* Smart Licensing, on page 14

* Manage Software Updates, on page 22

Prime Infrastructure Licensing

You purchase licenses to access the Prime Infrastructure features required to manage your network. Each
license also controls the number of devices you can manage using those features.

The Administration > Licenses and Software Updates > Licenses page allows you to manage traditional
Cisco Prime Infrastructure, wireless LAN controllers, and Mobility Services Engine (MSE) licenses.

Although Prime Infrastructure and MSE licenses can be fully managed from the Administration > Licenses
and Software Updates > Licenses page, you can only view Cisco Wireless LAN Controllers (WLC). You
must use Cisco WLC or Cisco License Manager (CLM) to manage Cisco WLC licenses.

The Administration > Licenses and Software Updates > Smart Software Licensing page allows you to
manage smart licenses.

You need a base license and the corresponding feature licenses (such as Assurance licenses) to get full access
to the respective Prime Infrastructure features to manage a set number of devices.

If you have installed Prime Infrastructure for the first time you may access the lifecycle and assurance features
using the built-in evaluation license that is available by default. The default evaluation license is valid for 60
days for 100 devices. You can send a request to ask-prime-infrastructure@cisco.com if:

* You need to extend the evaluation period
* You need to increase the device count
* You already have a particular feature license and need to evaluate the other feature licenses

You will need to order a base license and then purchase the corresponding feature license before the evaluation
license expires. The license that you purchase must be sufficient to:

* Enable access to all the Prime Infrastructure features you want to use to manage your network.
* Include all the devices in your network that you want to manage using Prime Infrastructure.
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. Purchase Prime Infrastructure Licenses

\}

To ensure you have the licenses to achieve these goals, do the following:

1. Familiarize yourself with the types of license packages available to you, and their requirements.
2. View the existing licenses. See for help on ordering and downloading licenses.

3. Calculate the number of licenses you will need, based both on the package of features you want and the
number of devices you need to manage.

4. Add new licenses.
5. Delete existing licenses.

Note

As Prime Infrastructure no longer supports the node-locked licensing approach, the UDI information required
to generate licenses are limited to a standard syntax as shown below:

* PID = PRIME-NCS-APL (For Physical Appliance)
PID = PRIME-NCS-VAPL (For Virtual Appliance/Virtual Machine)
* SN = ANY:ANY

You must provide the subtleties in the mentioned format to generate new licenses.

For more information, see Cisco Prime Infrastructure Ordering and Licensing Guide.

Related Topics
Verify License Details , on page 2
Add Licenses , on page 3
Delete Licenses, on page 3

Purchase Prime Infrastructure Licenses

Prime Infrastructure licenses control the features you can use and the number of devices you can manage
using those features. For more information about Prime Infrastructure license types and how to order them,
see the Cisco Prime Infrastructure Ordering and Licensing Guide for the version of Prime Infrastructure that
you want to use.

You can ignore warning messages like “Base license is missing” or “Multiple base licenses present, use only
one” displayed in the Administration > Licenses and Software Updates > Licenses > Files > License Files
area.

Verify License Details

Before you order new licenses, you might want to get details about your existing licenses. For example,
number of devices managed by your system.

To verify license details, choose Administration > Licenses and Software Updates > Licenses.

Related Topics
Prime Infrastructure Licensing , on page 1
Controller Licensing, on page 5
MSE Licensing , on page 7
Assurance Licensing , on page 12
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Add Licenses

You need to add new licenses when:

* You have purchased a new Prime Infrastructure license.
* You are already using Prime Infrastructure and have bought additional licenses.

Step 1 Choose Administration > Licenses and Software Updates > Licenses.
Step 2 In the Summary folder, click Files, then click License Files.

Step 3 Click Add.

Step 4 Browse to the location of the license file, then click OK.

Related Topics
Delete Licenses, on page 3
Troubleshoot Licenses, on page 3
MSE License Structure Matrix, on page 7
Verify Assurance License Details, on page 12

Delete Licenses

When you delete licenses from Prime Infrastructure, all licensing information is removed from the server.
Make a copy of your original license file in case you want to add it again later. There are several reasons you
might want to delete licenses:

* You installed temporary licenses and want to delete them before applying your permanent licenses.

* You want to move your licenses to a different server. You must first delete the licenses from the original
server, then send an email to licensing@cisco.com requesting a re-host for your licenses. You can then
apply the re-hosted licenses to the new server.

Step 1 Choose Administration > Licenses and Software Updates > Licenses.
Step 2 Click Files > License Files.
Step 3 Select the license file you want to delete, then click Delete.

Related Topics
Add Licenses , on page 3
Troubleshoot Licenses, on page 3
MSE License Structure Matrix, on page 7
Verify Assurance License Details, on page 12

Troubleshoot Licenses

To troubleshoot licenses, you will need to get details about the licenses that are installed on your system. to:

* Get a quick list of the licenses you have: Click Help > About Prime Infrastructure.
* Get license details: Choose Administration > Licenses and Software Updates > Licenses.

Licenses and Software Updates [JJjj



Licenses and Software Updates |
Troubleshoot Licenses

When troubleshooting licenses, it is important to remember that Prime Infrastructure has six types of licenses:

* Base: Required for every Prime Infrastructure installation. The requirement stems primarily from the
need to do accurate royalty accounting by knowing how many Prime Infrastructure instances have been
purchased. A Base license is required for each instance of Prime Infrastructure, and is a prerequisite for
all other license types.

» Lifecycle: Regulates the total number of devices under Prime Infrastructure management. Lifecycle
license is consumed only for admin VDC in Prime Infrastructure. The child VDC does not consume any
license. It is either auto-added by admin or added separately.

» Assurance: Regulates the total number of NetFlow devices under Prime Infrastructure management.

« Collector: Regulates the total number of NetFlow data flows per second that Prime Infrastructure can
process.

Lifecycle and Assurance licenses are supplied in either evaluation or permanent form (there is no explicit
evaluation version of the Base or Collector licenses):

« Evaluation: These licenses permit or extend access to Prime Infrastructure for a pre-set period. You can
apply only one evaluation license of each type (that is, only one Lifecycle evaluation license, one Assurance
evaluation license, and so on). You cannot apply an evaluation license over a permanent form of the
same license.

» Permanent License: These permit access to Prime Infrastructure features as specified and are not
time-limited. Permanent licenses can be applied over evaluation licenses, and can also be applied
incrementally (that is, you can have multiple permanent Assurance licenses, and so on).

Prime Infrastructure also performs the following basic license checks:

* A Lifecycle license is a required prerequisite for Assurance licenses.
* An Assurance license is a required prerequisite for Collector licenses.

Also note that:

* From Release 3.0 Prime Infrastructure enables the user to set threshold limit for generating an alarm for
all licenses. To set threshold limit for licenses, see “Configuring Notifications” in Related Topics.

* Prime Infrastructure hides Assurance-related features, menu options and links until an Assurance license
is applied. Even if you have purchased an Assurance license, these features remain hidden until you
apply it.

* Whenever you apply an Assurance license, you automatically apply a Collector license permitting an
instance of Prime Infrastructure to process up to 20,000 NetFlow data flows per second. Collector licenses
permitting 80,000 flows per second can be applied only with the Professional or equivalent configurations,
due to the hard disk requirements imposed by this data rate.

* You can add Lifecycle and Assurance permanent licenses incrementally. However, you can add only
one Collector 80K license, and then only with the Professional or equivalent configuration.

The following table provides some scenarios and tips for troubleshooting.

Table 1: Troubleshooting Scenarios

Scenario

Possible Cause

Resolution

Prime Infrastructure
reports a Licensing
error.

The license file may be corrupted and unusable.
This can occur anyone attempts to modify the
license file.

1. Delete the existing license.
2. Download and install a new license.
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Controller Licensing .

Collector license (a Collector license is added
automatically with the Assurance license).

Scenario Possible Cause Resolution

Unable to add new Some types of license must be added in the correct | 1. Add the Base license

licenses. order. The Base license is a prerequisite for adding | 2. Add Lifecycle licenses
Lifecycle licenses. A Lifecycle license is a 3. Add Assurance licenses
prerequisite for adding an Assurance license. An 4. Add Datacenter licenses
Assurance license is a prerequisite for adding a 5 Add Collector licenses

The state of the devices
has changed to
unmanaged.

The device limit must be less than or equal to
lifecycle license limit. The state of the inventoried
devices will change to unmanaged if you add or
delete devices.

To verify that the status of the inventoried devices has
changed to “managed” after synchronization:

1.
2.

Delete the additional devices.

The state of the devices will change to managed after
the 24 hours synchronization.

Choose Monitor > Network Devices.

Check the Inventory Collection Status column for
the row listing the devices in which you are
interested. This will give you a summary of current
collection status efforts for those devices.

For details about the collection status, hover the
mouse cursor over the cross-hair icon in the Inventory
Collection Status column.

Related Topics
Configure Notifications
Add Licenses , on page 3
Delete Licenses, on page 3
MSE License Structure Matrix, on page 7

Verify Assurance License Details, on page 12

Controller Licensing

To view controller licenses, choose Administration > Licenses and Software Updates > Licenses, then
select Files > Controller Files from the left sidebar menu.

)

Note

Prime Infrastructure does not directly manage controller licenses, rather it simply monitors the licenses. To
manage the licenses you can use command-line interface (CLI) commands, Web UI, or Cisco License Manager

(CLM), or Cisco Smart Software Manager(CSSM).

This page displays the following parameters:

 Controller Name

» Controller IP—The IP Address of the controller.

* Feature—License features include wplus-ap-count, wplus, base-ap-count, and base.
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For every physical license installed, two license files display in the controller: a feature level license and an
ap-count license. For example if you install a “WPlus 500” license on the controller, “wplus” and
“wplus-ap-count” features are displayed. There are always two of these features active at any one time that
combine to enable the feature level (WPlus or Base) and the AP count.

You can have both a WPlus and a Base license, but only one can be active at any given time.
* AP Limit

AP Limit—The maximum capacity of access points allowed to join this controller.

* EULA status—Displays the status of the End User License Agreement and is either Accepted or Not
Accepted.

* Comments

Comments—User entered comments when the license is installed.
* Type
Type—The four different types of licenses are as follows:

¢ Permanent

Permanent—Licenses are node locked and have no usage period associated with them. They are
issued by Cisco licensing portal and must be installed using management interfaces on the device.
Upon installation of these licenses, you have the necessary permissions across different versions.

* Evaluation—Licenses are non-node locked and are valid only for a limited time period. They are
used only when no permanent, extension, or grace period licenses exist. Before using an evaluation
license, you must accept an End User License Agreement (EULA). Even though they are non-node
locked, their usage is recorded on the device. The number of days left displays for the evaluation
license with the fewest number of remaining active license days.

» Extension—Licenses are node locked and metered. They are issued by Cisco licensing portal and
must be installed using management interfaces on the device. Before using an extension license,
you must accept a EULA during installation.

* Grace Period—Licenses are node locked and metered. These licenses are issued by Cisco licensing
portal as part of the permission ticket to rehost a license. They are installed on the device as part of
the rehost operation, and you must accept a EULA as part of the rehost operation.

Types other than Permanent display the number of days left until the license expires. Licenses not currently
in use do not have their counts reduced until they become “In Use.”

* Status

* In Use—The license level and the license are in use.

* Inactive—The license level is being used, but this license is not being used.

* Not In Use—The license level is not being used and this license is not currently recognized.

*» Expired In Use—The license is being used, but is expired and will not be used upon next reboot.
*» Expired Not In Use—The license has expired and can no longer be used.

* Count Consumed—The ap-count license is In Use.

If you need to filter the list of license files, you can enter a controller name, feature, or type and click Go.
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MSE Licensing

The MSE packages together multiple product features related to network topology, design such as NMSP,
Network Repository along with related Service Engines, and application processes, such as the following:

 Context-Aware Service

» Wireless Intrusion Prevention System(WIPS)

To enable smooth management of MSE and its services, various licenses are offered.
You must have a Cisco Prime Infrastructure license to use MSE and its associated services.

Related Topics
MSE License Structure Matrix, on page 7
Sample MSE License File, on page 7
Revoke and Reuse an MSE License, on page 8
MSE Services Coexistence, on page 9
Manage MSE Licenses, on page 9

MSE License Structure Matrix

The following table lists the breakdown of the licenses between the High end, Low end and Evaluation licenses
for MSE, Location services, SCM, wIPS, and MIR.

Table 2: MSE License Structure Matrix

High End Low End Evaluation

MSE Platform High-end appliance and infrastructure Low-end appliance and infrastructure |—
platform, such as the Cisco 3350 and 3355 | platform, such as Cisco 3310 mobility

mobility services engines services engine
Context Aware |25,000 Tags 2000 Tags Validity 60 days, 100 Tags
Service and 100 Elements

25,000 Elements 2000 Elements
wIPS 3000 access points 2000 access points Validity 60 days, 20 access

points

Related Topics
Sample MSE License File, on page 7
Revoke and Reuse an MSE License, on page 8
MSE Services Coexistence, on page 9
Manage MSE Licenses, on page 9

Sample MSE License File

The following is a sample MSE license file:
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FEATURE MSE cisco 1.0 permanent uncounted \
VENDOR_STRING=UDI=udi,COUNT=1\

HOST ID=ANY \
NOTICE="<LicFileID>MSELicense</LicFileID><LicLinelD>0</LicLineID>\
<PAK>dummyPak</PAK>" \

SIGN="0C04 1EBA BE34 F208 404F 98ED 43EC \

45D7 F881 08F6 7FAS5 4DED 43BC AF5C C359 0444 36B2 45CF 6EA6 \
1DBI1 899F 413F F543 F426 B055 4C7A D95D 2139 191F 04DE"

This sample file has five license entries. The first word of the first line of any license entry tells you what type
of license it is. It can either be a Feature or Increment license. A feature license is a static lone item to license.
There can be multiple services engines running in MSE. An Increment license is an additive license. In MSE,
the individual service engines are treated as increment licenses.

The second word of the first line defines the specific component to be licensed. For example, MSE,
LOCATION_TAG. The third word depicts the vendor of the license, for example Cisco. The fourth word
denotes the version of the license, for example 1.0. The fifth word denotes the expiration date; this can be
permanent for licenses that never expire or a date in the format dd-mm-yyyy. The last word defines whether
this license is counted.

Related Topics
MSE License Structure Matrix, on page 7
Revoke and Reuse an MSE License, on page 8
MSE Services Coexistence, on page 9
Manage MSE Licenses, on page 9

Revoke and Reuse an MSE License

You can revoke an MSE appliance license from one system and reuse it on another system. When you revoke
a license, the license file is deleted from the system. If you want to reuse the license on another system, then
the license needs to be rehosted.

If you want to reuse a license with an upgrade stock keeping unit (SKU) on another system, then you must
have the corresponding base license SKU installed in the system to which you want to reuse the upgrade SKU.
You cannot reuse the upgrade license SKU in a system if the corresponding base license SKU is deleted from
it.

When you revoke a license, MSE restarts the individual service engines to reflect the changes to the licenses.
Then the service engines receives the updated capacity from MSE during startup.
Related Topics

MSE License Structure Matrix, on page 7

Sample MSE License File, on page 7

MSE Services Coexistence, on page 9

Manage MSE Licenses, on page 9
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MSE Services Coexistence
With MSE 6.0 and later, you can enable multiple services (Context Aware and wIPS) to run concurrently.
Before Version 6.0, mobility services engines only supported one active service at a time.

The following must be considered with coexistence of multiple services:

* Coexistence of services might be impacted by license enforcement. As long as the license is not expired,
you can enable multiple services.

\}

Note Limits for individual services differ. For example, a low-end mobility services engine (MSE-3310) tracks a
total of 2,000 CAS elements; a high-end mobility services engine (MSE-3350) tracks a total of 25,000 CAS
elements.A low-end mobility services engine has a maximum limit of 2000 wIPS elements; a high-end mobility
services engine has a maximum limit of 3000 wIPS elements.

* Expired evaluation licenses prevent the service from coming up.

» If a CAS license is added or removed, this process restarts all services on the mobility services engine
including wIPS. If a wIPS license is added or removed, the process does not impact CAS; only wIPS
restarts.

* Other services can be enabled in evaluation mode even if a permanent license for the maximum number
of elements has been applied.

Whenever one of the services has been enabled to run with its maximum license, another service cannot be
enabled to run concurrently because the capacity of the MSE is not sufficient to support both services
concurrently. For example, on MSE-3310, if you install a wIPS license of 2000, then you cannot enable CAS
to run concurrently. However, evaluation licenses are not subject to this limitation.
Related Topics

MSE License Structure Matrix, on page 7

Sample MSE License File, on page 7

Revoke and Reuse an MSE License, on page 8

Manage MSE Licenses, on page 9

Manage MSE Licenses

To view Mobility Services Engine (MSE) licenses, choose Administration > Licenses and Software Updates
> Licenses, then select Files > MSE Files from the left sidebar menu.

The page displays the MSE licenses found and includes the following information:

* MSE License File—Indicates the MSE License.
* MSE—Indicates the MSE name.

» Type—Indicates the type of mobility services engine (client elements, wIPS local mode or wIPS monitor
mode access points).

* Limit—Displays the total number of client elements or wIPS monitor mode access points licensed across
the mobility services engine.

* License Type—Permanent licenses are the only license types displayed on this page. Permanent licenses
are node locked and have no usage period associated with them. They are issued by Cisco licensing portal
and must be installed using management interfaces on the device. Upon installation of these licenses,
you have the necessary permissions across different versions.
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. Register Product Authorization Keys

Tag licenses are installed using the AeroScout System Manager only if the tags are tracked using the Partner
engine. Otherwise the tags will be counted along with the CAS element license. Because tag licenses are
added and managed using appropriate vendor applications, tag licenses are not displayed in this page. For
more information, see the AeroScout Support Page in Related Topics. Evaluation (demo) licenses are also
not displayed.

For more information, see AeroScout Support Page.

Related Topics
Register Product Authorization Keys, on page 10
Install Client and wIPS License Files, on page 11
Delete Mobility Services Engine License Files, on page 11

Register Product Authorization Keys

Step 1

Step 2
Step 3

Step 4

Step 5

Step 6

Step 7
Step 8

You receive a product authorization key (PAK) when you order a client, wIPS, or tag license from Cisco.
You must register the PAK to receive the license file for installation on the mobility services engine. License
files are emailed to you after successfully registering a PAK.

Client and wIPS PAKs are registered with Cisco.

Tag PAKs are registered with AeroScout. To register your tag PAK, navigate to the AeroScout Support Page
given in Related Topics.

To register a product authoritative key (PAK) and obtain a license file for installation, follow these steps:

Point your browser to the Cisco Product License Registration Portal (see Related Topics).

You can also access this site by clicking the Product License Registration link located on the License Center page of
Prime Infrastructure.

Enter the PAK and click SUBMIT.
Verify the license purchase. Click Continue if correct. The licensee entry page appears.

If the license is incorrect, click the TAC Service Request Tool link to report the problem.

In the Designate Licensee page, enter the mobility service engine UDI in the host ID text box. This is the mobility services
engine on which the license will be installed.

UDI information for a mobility services engine is found in the General Properties area at Services > Mobility Services
Engine > Device Name > System.

Select the Agreement check box. Registrant information appears beneath the check box.
Modify information as necessary.

Ensure that the phone number does not include any characters in the string for the registrant and end user. For example,
enter 408 555 1212 rather than 408.555.1212 or 408-555-1212.

If registrant and end user are not the same person, select the License (End-User) check box beneath registrant information
and enter the end-user information.

Click Continue.

At the Finish and Submit page, review registrant and end-user data. Click Edit Details to correct information, if necessary,
then click Submit. For more information, see AeroScout Support Page and Cisco Product License Registration Portal.
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Related Topics
Install Client and wIPS License Files, on page 11
Delete Mobility Services Engine License Files, on page 11

Install Client and wiPS License Files
You can install CAS element licenses and wIPS licenses from Prime Infrastructure.
Tag licenses are installed using the AeroScout System Manager. See the AeroScout Support Page.

To add a client or wiPS license to Prime Infrastructure after registering the PAK, follow these steps

Step 1 Choose Administration > Licenses and Software Updates > Licenses.
Step 2 From the left sidebar menu, choose Files > MSE Files.
Step 3 Click Add to open the Add a License File dialog box.

Step 4 From the MSE Name drop-down list, choose the mobility services engine to which you want to add the license file.
Note Verify that the UDI of the selected mobility services engine matches the one you entered when registering the
PAK.
Step 5 Enter the license file in the License File text box or browse to the applicable license file.
Step 6 Once displayed in the License File text box, click Upload. Newly added license appears in mobility services engine

license file list.

Note » A Context Aware Service (CAS) restarts if a client or tag license is installed; a wIPS service restarts if a
wIPS license is installed.

* Services must come up before attempting to add or delete another license.

Related Topics
Delete Mobility Services Engine License Files, on page 11

Delete Mobility Services Engine License Files

Step 1 Choose Administration > Licenses and Software Updates > Licenses, then select Files > MSE Files from the left
sidebar menu.

Step 2 Select the check box of the mobility services engine license file that you want to delete.
Step 3 Click Delete, then click OK to confirm the deletion.

Related Topics
Register Product Authorization Keys, on page 10
Install Client and wIPS License Files, on page 11
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Assurance Licensing

As explained in “Purchasing Prime Infrastructure Licenses” (see Related Topics), licenses for Assurance
features are based on the number of NetFlow-monitored devices and Network Analysis Module (NAM) data
collection-enabled devices you have in your network. You manage, verify, and troubleshoot Assurance licenses
much as you do with other feature licenses, as explained in “Add Licenses”, “Delete Licenses” and
“Troubleshoot Licenses”.

In addition to these functions, Prime Infrastructure also lets you choose which NetFlow and NAM devices

you want to manage using Assurance features. For example, if you have only 50 Assurance feature licenses
and more than 50 NetFlow and NAM devices, you can choose to manage only your most critical devices. If
you later purchase additional Assurance licenses, you can add license coverage for the devices previously left

unmanaged.

Related Topics
Purchase Prime Infrastructure Licenses, on page 2
Verify Assurance License Details, on page 12
Add Licenses , on page 3
Delete Licenses, on page 3
Troubleshoot Licenses, on page 3

Verify Assurance License Details

Before you buy new Assurance licenses, you may want to get details about your existing Assurance licenses
and how they are being used. You can find Assurance license information using the resources in the following
table.

Table 3: Finding Assurance License Information

To see

Choose

The NetFlow-enabled devices in your network that are under Assurance Administration > Licenses and Software Updates
management, as a percentage of the total number of Assurance licenses you |> Licenses > Summary.

have.

The total number of Assurance licenses you have and the files associated with | Administration > Licenses and Software Updates

them. > Licenses > Files.
A list of the devices sending NetFlow or NAM polling data to Prime Administration > Licenses and Software Updates
Infrastructure.

> Licenses > Assurance Licenses (link is in upper

The number of Assurance Licenses in use.

right corner of the page)

The maximum number of Assurance licenses available to you.

By default, the total count of Assurance licenses on the Assurance Licenses page and on the Summary and
Files > License Files pages is always updated whenever you add or delete Assurance licenses. Addition or
removal of devices covered under these added or deleted Assurance licenses takes place as part of a System
Defined Job, which runs automatically once every 12 hours. It can take up to 12 hours for the added or deleted
devices to appear.
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Add License Coverage For NetFlow and NAM Devices .

You can always access the Administration > Licenses and Software Updates > Licenses > Assurance
Licenses page from the Assurance Licenses link in the upper right corner of the Administration > Licenses
and Software Updates > Licenses > Summary and Administration > Licenses and Software Updates >
Licenses > Files pages.
Related Topics

Install Client and wIPS License Files, on page 11

Delete Mobility Services Engine License Files, on page 11

Add License Coverage For NetFlow and NAM Devices

Step 1

Step 2
Step 3

Step 4

You want to add license coverage for NetFlow or NAM devices when:

* You have purchased new or additional Assurance licenses.
* You have NetFlow and NAM devices not already licensed for Assurance management.

Choose Administration > Licenses and Software Updates > Licenses > Assurance Licenses (the Assurance Licenses
link is in the upper right corner of the page).

Above the list of devices currently under Assurance management, click Add Device.

Select the check box next to each device you want to put under Assurance management, then click Add License. Prime
Infrastructure adds the devices immediately.

When you are finished, click Cancel.

Related Topics
Delete License Coverage for NetFlow and NAM Devices, on page 13

Delete License Coverage for NetFlow and NAM Devices

Step 1

Step 2

You may need to delete license coverage for a NetFlow or NAM device when:

* You have too many NetFlow and NAM devices for the number of Assurance licenses you have.
* You want to stop using Assurance management features with one or more NetFlow and NAM devices.

Choose Administration > Licenses and Software Updates > Licenses > Assurance Licenses (the Assurance Licenses
link is in the upper right corner of the page).

Prime Infrastructure displays the list of devices currently under Assurance management. It also displays the total number
of Assurance licenses you have, and the total number of devices under Assurance management.

Select the check box next to each device you want to remove from Assurance management, then click Remove Device.

Related Topics
Add License Coverage For NetFlow and NAM Devices , on page 13
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Smart Licensing

Smart Licensing feature provides a standardized licensing platform that simplifies user experience. When
Smart Licensing is first enabled, Prime Infrastructure is in Evaluation mode until you register Prime
Infrastructure with the Smart Software Manager (which resides on a centralized Cisco web site).

If you are currently using traditional licensing, Cisco recommends that you convert to Smart Licensing. For
information on the differences between the two types of licensing, refer to the Cisco Smart Licensing Overview
on Cisco.com .

The purpose of the smart licensing feature is to reduce license-related complexity by enabling users to:

* Purchase additional licenses and automatically update the information.

* Monitor current purchases and entitlements (duration and number of units).
* Monitor current usage information and trending information.

* Easily track if adequate licenses are purchased.

* Save time with the ability to transfer licenses across the company.

\}

Note From Cisco Prime Infrastructure Release 3.5, Smart Licensing is supported for Operation Center.

The limitations of smart licensing feature are:

 In HA (High Awvailability), you can perform smart license actions (enable, register, deregister and disable)
on the HA Primary server and these actions are not permitted on the HA Secondary server.

» While performing backup and restore operation, the license supported during backup will be restored.
Smart licensing registration state cannot be restored on another server and in that case user has to register
once again on the restored setup.

* While performing an upgrade from an older version, the license supported in the older version will be
enabled by default in the new version.

Related Topics
Set Up Cisco Smart Licensing on Prime Infrastructure, on page 14
Set Up the Transport Mode Between Prime Infrastructure and Cisco Smart Software Manager, on page
15
Enable Smart License on Prime Infrastructure, on page 16
Register Prime Infrastructure with the Cisco Smart Software Manager, on page 17
Choose Smart Software Licenses, on page 18
Configure License Thresholds for the Prime Infrastructure License Dashboard, on page 19
Perform Additional Actions, on page 21
View the Licensing Dashboard, on page 19
Reference: Product Registration and License Authorization Statuses, on page 21

Set Up Cisco Smart Licensing on Prime Infrastructure

Follow these steps to set up Cisco Smart Licensing. If you are currently using traditional licensing, use these
same procedures to convert to Cisco Smart Licensing.
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Step See:

1. | Create a Smart Account with Cisco Systems. Go to: Smart Account Request and follow the
instructions on the web site

2. | Set up communication between Prime Infrastructure and | Setting Up the Transport Mode Between Prime
the Cisco Smart Software Manager (CSSM) on Infrastructure and Cisco Smart Software
Cisco.com. Manager

3. | Enable Smart Licensing in Prime Infrastructure (you |Enabling Smart License on Prime Infrastructure
will have to restart the web GUI).

4. | Register Prime Infrastructure with the CSSM on Registering Prime Infrastructure with the Cisco
Cisco.com, then enter the license tokens into the Prime | Smart Software Manager

Infrastructure web GUI (you will have to restart the web
GUI).

5. | Choose the licenses you want to use in Prime Choosing Smart Software Licenses
Infrastructure.

6. | Set up the Smart License Dashboard to signal when you | Configuring License Thresholds for the Prime
are running out of licenses. Infrastructure License Dashboard

Set Up the Transport Mode Between Prime Infrastructure and Cisco Smart
Software Manager

Step 1

Step 2

Step 3
Step 4

Choose Administration > Settings > System Settings > General > Account Credentials and select Smart Licensing
Transport tab.

Alternatively, you can click the link mentioned in the Smart Software Licensing page to direct you to the Smart
Licensing Transport tab to set up transport settings.

You can select any of the following three modes:

* Direct mode—Select this option to send data directly to Cisco cloud. The Smart Call Home Server URL is a read-only
and cannot be modified.

* Transport Gateway—Uses a Cisco Call Home transport gateway or a Cisco Smart Licensing Software satellite. (A
Cisco Smart Licensing Software satellite is installed on customer premises and provides a subset of CSSM
functionality. See Cisco.com for more information about satellites.) Specify an appropriate DNS mapped URL for
the respective Smart Software Manager Satellite or Smart Software Manager. Refer Smart Software Manager User
Guide for details.

* HTTP Proxy—Select this option to use an intermediate HTTP/HTTPS proxy between Prime Infrastructure and the
Cisco cloud. To enable this option, you must first configure the proxy settings in the Proxy tab.

Click Test Connectivity to test the connection status. Click Save to update the smart licensing transport mode.

Proceed to Enabling Smart License on Prime Infrastructure .

Related Topics
Smart Licensing, on page 14
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Set Up Cisco Smart Licensing on Prime Infrastructure, on page 14

Enable Smart License on Prime Infrastructure, on page 16

Perform Additional Actions, on page 21

View the Licensing Dashboard, on page 19

Reference: Product Registration and License Authorization Statuses, on page 21

Enable Smart License on Prime Infrastructure

To enable smart license, follow these steps:

Before you begin

Make sure you have set up the transport mode. See "Set Up the Transport Mode Between Prime Infrastructure
and Cisco Smart Software Manager" in Related Topics.

Step 1 Choose Administration > Licenses and Software Updates > Smart Software Licensing.

Step 2 In the Licensing Settings tab, select Smart Software Licensing.

Step 3 Choose Prime Infrastructure from the Product Name drop-down list.

Step 4 Click Enable Smart Software Licensing. Prime Infrastructure displays a dialog box informing you that you must log

out of Prime Infrastructure and log back in, before you can proceed to the configuration step.
Step 5 Click OK in the dialog box.

Once the smart license is enabled and before it is registered, the product will be in Evaluation Mode for 90 days and
you can manage any number of devices.

Step 6 Perform one of the following:

a. If you have not yet registered with the CSSM on Cisco.com, proceed to Registering Prime Infrastructure with the
Cisco Smart Software Manager.

b. If you have registered with the CSSM, proceed to Choosing Smart Software Licenses.

Note If you prefer traditional licenses, then in the Licensing Settings tab, select Traditional Licensing as the
Licensing Mode and click Register. The Administration > Licenses and Software Updates > Licenses page
is displayed.

Related Topics
Set Up Cisco Smart Licensing on Prime Infrastructure, on page 14
Register Prime Infrastructure with the Cisco Smart Software Manager, on page 17

Set Up the Transport Mode Between Prime Infrastructure and Cisco Smart Software Manager, on page
15

Perform Additional Actions, on page 21

View the Licensing Dashboard, on page 19

Disable Smart Licensing, on page 20

Reference: Product Registration and License Authorization Statuses, on page 21
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Register Prime Infrastructure with the Cisco Smart Software Manager

This procedure creates a token which you will use to register your product instance with the CSSM. For
information on how to use the CSSM, see the Cisco Smart Software Manager User Guide.

\}

Note Refer to the Cisco Smart Software Manager User Guide for information on other actions you can perform
from the CSSM—for example, renewing license registration and license authorization, unregistering the
product from Cisco Smart Licensing, and so forth.

Related Topics
Generate Token ID, on page 17
Register Product Instance, on page 18

Generate Token ID

Step 1
Step 2
Step 3
Step 4
Step 5

Step 6
Step 7

If this is a new installation (you are not converting from traditional licensing), follow these steps:

Before you begin

If your organization does not have a Smart Account, go to software.cisco.com, choose Request a Smart
Account (under Administration), and follow the instructions to create an account. If you are converting from
traditional licensing, refer Converting from Traditional Licensing.

Go to the Cisco Software Central web site ( software.cisco.com ).

On Cisco Software Central, choose License > Smart Software Licensing.

Select the appropriate virtual account (virtual accounts are automatically created when you create a Smart Account).
Click the General tab, then click New Token.

Follow the instructions to provide a name, duration, and export compliance applicability before accepting the terms and
responsibilities.

Click Create Token.
Copy the Token ID to your clipboard and proceed to Registering Product Instance.

Convert from Traditional Licensing

Step 1
Step 2
Step 3
Step 4

Step 5

If you are converting from traditional licensing, follow these steps:

Go to the Cisco Software Central web site ( software.cisco.com ).
On Cisco Software Central, choose License > Traditional Licensing.
Click Continue to Product License Registration.

In the Manage area of the Product License Registration page, click the PAKs/Tokens tab and choose the entitlements
you want to convert.

From the Actions drop-down list, choose Convert to Smart Entitlements.
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Step 6 Copy the Token ID to your clipboard and proceed to Registering Product Instance.

Register Product Instance

Enter the token IDs into the Prime Infrastructure web GUI and register the product.

Step 1 Choose Administration > Licenses and Software Updates > Smart Software Licensing.
Step 2 Under the Licensing Settings tab, paste your token into the Registration Token field.
Step 3 Click Register.

Step 4 Log out of Prime Infrastructure, then log back in.

Step 5 Proceed to Choosing Smart Software Licenses.

Related Topics
Set Up Cisco Smart Licensing on Prime Infrastructure, on page 14
Choose Smart Software Licenses, on page 18
Smart Licensing, on page 14
Enable Smart License on Prime Infrastructure, on page 16

Set Up the Transport Mode Between Prime Infrastructure and Cisco Smart Software Manager, on page
15

Perform Additional Actions, on page 21
View the Licensing Dashboard, on page 19
Reference: Product Registration and License Authorization Statuses, on page 21

Choose Smart Software Licenses

Step 1 If this is the first time you are choosing Smart licenses:
a) Choose Administration > Licenses and Software Updates > Licenses.

After a few moments, Prime Infrastructure displays a dialog box informing you that you cannot access the page
because you are not using traditional licensing. This is normal.

b) In the dialog box, click Smart License Settings.
¢) Click the Licensing Settings tab.

Step 2 If you are already using Smart Licensing:
a) Choose Administration > Licenses and Software Updates > Smart Software Licensing.
b) Click the Licensing Settings tab.

Step 3 Click Smart Software Licensing radio button.

Step 4 Select the licenses in the Available Licenses dialog box, then click Save.

Step 5 Proceed to Configuring License Thresholds for the Prime Infrastructure License Dashboard.
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Configure License Thresholds for the Prime Infrastructure License Dashhoard

Step 1

Step 2
Step 3
Step 4

To manage your licenses more efficiently, configure the License Dashboard to indicate when you are nearing
the point where your license count is depleted. The settings you configure here apply across the system.

Choose Administration > Licenses and Software Updates > Smart Software Licensing, then click the License
Dashboard Settings tab.

Select a license from the License Type drop-down list.

Enter a value in the Threshold Value field.

Click Save.

The threshold value is displayed as a straight line in the graphical representation of the License Summary and the Device
Distribution for License dashlets.

Related Topics
View the Licensing Dashboard, on page 19
Choose Smart Software Licenses, on page 18
Set Up Cisco Smart Licensing on Prime Infrastructure, on page 14
Enable Smart License on Prime Infrastructure, on page 16
Register Prime Infrastructure with the Cisco Smart Software Manager, on page 17
Disable Smart Licensing, on page 20
Reference: Product Registration and License Authorization Statuses, on page 21

View the Licensing Dashboard

From the Licensing dashboard, you can determine whether traditional or smart software licensing is enabled
(indicated in the Active Licensing Mode field at the top of the dashboard) and view the number of licenses
that are currently in use. You can set the licensing mode from the Smart Software Licensing page
(Administration > Licenses and Software Updates > Smart Software Licensing).

To open this dashboard, do one of the following:

* Choose Administration > Dashboards > Licensing Dashboard.

» Click the Licensing Dashboard link from the top-right corner of the Smart Software Licensing page.
The information displayed in the dashboard depends on the licensing mode that is enabled. If smart software
licensing is currently enabled, the following dashlets are displayed:

» License Summary Count area—Displays the number of licenses consumed and the compliance status
for each license type. The number of licenses displayed is based on the current date.

« License Summary dashlet—Displays a bar chart that graphs the number of licenses consumed for each
license type during a particular time period. To view additional information, place your cursor over the
chart.

» Device Distribution for License dashlet—To view the device distribution chart for a particular license,
click its link from the top of the chart displayed in the License Summary dashlet. To view additional
information, place your cursor over the chart.
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Note

The information displayed in the License Dashboard is refreshed daily after the SmartLicense job runs at
02:00 A.M. (its pre-configured run time). To view this job in the Job Dashboard, choose Administration >
Dashboards > Job Dashboard.

If traditional licensing is currently enabled, the Licensing dashboard displays the Traditional Licensing
dashlet. Specify whether you want to view information about Lifecycle or Assurance licenses by choosing
the corresponding option from the License Type drop-down list. The dashlet updates, displaying information
such as the device families with that license type, the number of tokens allocated to each device in those
families, as well as the number of tokens that are not being used at the moment.

Note

The token consumption is based on the number devices, for example for a stack switch having 4 switches the
number of tokens consumed is 4.

Related Topics
Set Up Cisco Smart Licensing on Prime Infrastructure, on page 14
Enable Smart License on Prime Infrastructure, on page 16
Register Prime Infrastructure with the Cisco Smart Software Manager, on page 17
Configure License Thresholds for the Prime Infrastructure License Dashboard, on page 19
Disable Smart Licensing, on page 20
Reference: Product Registration and License Authorization Statuses, on page 21

Disable Smart Licensing

Step 1 Disable Smart licensing.
a) Choose Administration > Licenses and Software Updates > Smart Software Licensing, then click the Licensing
Settings tab.
b) At the bottom of the window, click Disable Smart Licensing and confirm your choice.

Step 2 Enable traditional licensing. (This is done from the Smart License Settings page.)
a) Choose Administration > Licenses and Software Updates > Licenses.
b) In the dialog box, click Smart License Settings.
¢) Click the Licensing Settings tab.
d) For the Licensing Mode, select Traditional Licensing.
e) Click Register.

Related Topics
Configure License Thresholds for the Prime Infrastructure License Dashboard, on page 19
Enable Smart License on Prime Infrastructure, on page 16
Set Up Cisco Smart Licensing on Prime Infrastructure, on page 14
Register Prime Infrastructure with the Cisco Smart Software Manager, on page 17
Perform Additional Actions, on page 21
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Perform Additional Actions

Choose any of the following actions from the Actions drop-down list. To know more about the status of
licenses and product registration, refer Reference: Product Registration and License Authorization Statuses.

* Renew Authorization Now—Click Renew Authorization Now to renew authorization with CSSM to
enable Prime Infrastructure to remain compliant. By default, authorization periods are renewed every 30
days.

* Renew Registration Now—Click Renew Registration Now to renew the ID certificate that needs to be
renewed every year for Prime Infrastructure to remain registered.

* Deregister—Prime Infrastructure will be de-registered from Smart Software Licensing and goes back to
evaluation mode.

* Disable Smart Software Licensing—Prime Infrastructure will be unregistered from Smart Licensing and
will be unlicensed. Once disabled, only Administration menu will be available on logging in. See
Disable Smart Licensing.

Related Topics
Reference: Product Registration and License Authorization Statuses, on page 21
Set Up Cisco Smart Licensing on Prime Infrastructure, on page 14
View the Licensing Dashboard, on page 19
Enable Smart License on Prime Infrastructure, on page 16

Set Up the Transport Mode Between Prime Infrastructure and Cisco Smart Software Manager, on page
15

Register Prime Infrastructure with the Cisco Smart Software Manager, on page 17
Disable Smart Licensing, on page 20

Reference: Product Registration and License Authorization Statuses

Product Registration Status

The Product Registration Status reflects whether the product is properly registered with Cisco Smart Software
Licensing on Cisco.com.

Product Registration Status | Description

Unregistered Smart Software Licensing is enabled on Prime Infrastructure, but Prime
Infrastructure is not registered with the CSSM.

Registered Prime Infrastructure is registered with the CSSM. Prime Infrastructure has
received an ID certificate that will be used for future communication with the
Cisco licensing authority.

Registration Expired Prime Infrastructure did not successfully renew its registration prior to the
expiration date and has been removed from CSSM.

License Authorization Status

The License Authorization Status reflects usage against purchased licenses and whether you are in compliance
with Cisco Smart Licensing. If you exceed the number of purchased licenses, you will be Out of Compliance.
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License Authorization Status | Description

Evaluation Mode Prime Infrastructure is running in evaluation mode until the evaluation period
expires (90 days).
Authorized Prime Infrastructure has a valid Smart Account and is registered. All licenses

requested by the product are authorized for use.

Out of Compliance Prime Infrastructure has exceeded the number of licenses that were
purchased.The Virtual account containing the product instance has a shortage
of one or more of license types used.

Evaluation Expired The Evaluation period has expired and Prime Infrastructure will be in
unlicensed state.

Authorization Expired Prime Infrastructure did not successfully renew its license authorization prior
to the authorization expiration date.

Related Topics
Smart Licensing, on page 14
Enable Smart License on Prime Infrastructure, on page 16
Set Up Cisco Smart Licensing on Prime Infrastructure, on page 14
Register Prime Infrastructure with the Cisco Smart Software Manager, on page 17
Perform Additional Actions, on page 21

Manage Software Updates

» What Are Software Updates?, on page 22

* View the Installed Product Software Version, on page 23

* Enable or Disable Notifications About Software Updates, on page 23
* View Installed Software Updates, on page 23

What Are Software Updates?

Cisco provides updates to the Prime Infrastructure software periodically. These updates fall into the following
three categories:

* Critical Fixes—Provide critical fixes to the software. We strongly recommend that you download and
apply all of these updates as soon as they are available.

* Device Support—Adds support for managing devices which Prime Infrastructure did not support at
release time.

* Add-ons—Provide new features, which can include GUI screens and functionality, to supplement the
Prime Infrastructure version you are using. This includes Prime Infrastructure maintenance packs and
maintenance pack point patches.

The update notifications that Prime Infrastructure displays depend on the Notification Settings specified by
your administrator. See Enable or Disable Notifications About Software Updates, on page 23 . All software
updates are packaged in .ubf files. A large update can contain individual smaller updates, from which you can
choose what you want to install. When you install an update, Prime Infrastructure does the following:
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* Verifies that the file publisher is Cisco Systems and the file has not been tampered with.
» Automatically installs any other updates that are required.
If you have connectivity to http://www.cisco.com , you can download and install the updates directly from

Cisco.com. If you do not have internet connectivity, copy the update from a server that has the necessary
connectivity and install it from there.

View the Installed Product Software Version

Use one of these methods to check the Prime Infrastructure product version:
* From the Ul, choose Help > About Prime Infrastructure.
* From the UI, Click settings icon on the top right of the page and click About Prime Infrastructure.
» From the CLI, execute the following command to view the Installed Product software version.

#ishow version

To use the CLI, see Establish an SSH Session With the Prime Infrastructure Server.

View Installed Software Updates

If you are not logged in to the web GUI, you can view a pop-up window that lists the software updates by
clicking View Installed Updates from the login page.

If you are logged in to the web GUI, you can view the software updates in two ways:

« From the About Prime Infrastructure page, by clicking the settings icon at the top right of the page
and clicking About Prime Infrastructure, and then clicking View Installed Updates. (The View
Installed Updates link is also available from the login page.)

* By choosing Administration > Licenses and Software Updates > Software Update (this method
provides the most detail).
The Software Update page displays two tabs:

« Installed Updates—Updates that Prime Infrastructure is currently using.

+ Uploaded Update Files—Update files that have been uploaded to the server (including those that are
not being used). The Corresponding Updates field lists any prerequisite updates that were also uploaded.

If an update file has not yet been installed, it can be deleted. Select the file and click the Delete button.

Enable or Disable Notifications About Software Updates

By default, Prime Infrastructure displays information about all available updates in the Software Updates
page. Because the list can be quite long, you may want to adjust what is displayed and the updates for which
you are notified. You can also disable all notifications and re-enable them later.

Step 1 Configure the default Cisco.com credentials so that Prime Infrastructure can get information about available updates.
a) Choose Administration > Settings > System Settings, then choose General > Account Settings.
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Step 2

b) Click the Cisco.com Credentials tab, enter the credentials, then click Save.

Configure your software update notification settings.
a) Choose Administration > Settings > System Settings, then choose General > Software Update.

b) Under Notification Settings, select or deselect the update categories. To disable all notifications, make sure no
categories are selected. For an explanation of the categories, see What Are Software Updates?, on page 22

¢) Click Save.

Validate Images (ISO and OVA) Before Installing Them

Step 1
Step 2

Step 3

Step 4

Before installing any software, you should verify the authenticity of the publisher by making sure the image
is signed. This ensures that the image is from Cisco Systems and that it has not been tampered with.

Prime Infrastructure software is provided in the following formats:

« .ubf files that you can download and install using the Software Update web GUI feature

* ISO or OVA images that are provided during major product releases and updates

You do not have to manually validate UBF packages that are downloaded using the Software Update feature.
This is because Prime Infrastructure automatically validates the .ubf files during the Software Update installation
process. If a file is not signed, Prime Infrastructure generates an error message and will not install the .ubf
file. If this occurs, contact your Cisco representative.

You do need to manually validate ISO and OVA images. Use the following procedure to validate them before
installation.

If you do not have openssl installed, download and install it (see http://www.openssl.org).

Place the following files in a temporary directory:

* The product file to be verified (*.is0 or *.0va).
* The signature file (*.signature) that is packaged with the product file.
* The certificate file (*.pem). The same certificate is used to verify OVA and ISO images.

Move to the temporary directory and run the following command as the Linux CLI root user (see Log In and Out as the
Linux CLI root User):

openssl dgst -sha512 -verify cert-file -signature sig-file content-file

Where:
« cert-file is the Prime Infrastructure certificate file
» sig-file is the Prime Infrastructure signature file

» content-file is the Prime Infrastructure ISO file or OVA image to be verified

If the result is Verified OK:
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* For an ISO file, proceed with the installation (you do not have to perform any more steps as part of this validation
procedure).

* For an OVA package, proceed to the next steps.

Step 5 (OVA package only) Verify that Cisco Systems is the publisher.

a) Inthe VMware vSphere client, choose File > Deploy OVF Template.
b) Browse to the OVA file (*.ova), select it, and click Next.

¢) Verify that the Publisher field in the OVF Template Details window displays Cisco Systems, Inc. with a green
check mark next to it. Proceed to the next step.

Note Do not validate the image using the Vendor field. This field does not authenticate Cisco Systems as the publisher.

Note Do not proceed if the Publisher field displays No certificate present. This indicates the image is not signed,
is not from Cisco Systems, or has been tampered with.

Step 6 Check the certificate chain.

a) In the OVF Template Details window, click the Cisco Systems, Inc. hyperlink in the Publisher field.
b) In the Certificate window, click the Certification Path tab.

¢) In the Certification Path tab (which lists the certificate chain), ensure that the Certification Path area displays
Cisco Systems, Inc. and the Certification Status area displays The certificate is OK.

Download and Install a Software Update from Cisco.com

These steps explain how to download a software update from cisco.com and then install it on the Prime
Infrastructure server.

If you are using high availability, see How to Patch New HA Servers.

Before you begin

Make sure you have an account on Cisco.com.

Step 1 Back up your data. See Perform a Manual Backup.
Step 2 Download the file to your local machine, then upload it from your local machine to the Prime Infrastructure server.

a) Log into cisco.com and go to the Prime Infrastructure Software Download site.
b) Locate the .ubf file you want to download, and download it to your local machine.

Step 3 Copy the file from your local machine to the Prime Infrastructure server as described in Copy a File from a Client Machine
to the Prime Infrastructure Server, on page 26.

Step 4 Log in to the Prime Infrastructure web GUI as a user with Administrator privileges.

Step 5 Upload the file to the Prime Infrastructure server.

a) Choose Administration > Licenses and Software Updates > Software Update.
b) Click Upload at the top of the page.
¢) Use one of the following options to upload the UBF file.

1. Upload from local computer
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Step 6

Step 7

* Click the Upload from local computer radio button in the Upload Update window.

* Click Browse, navigate to the file, and click OK. After the successful upload, the software will appear under
the Files tab.

2. Copy from server's local disk

* Click the Copy from server's local disk radio button in the Upload Update window.

* Click Select , select the UBF file from the Select file from local disk pop-up and click Select. After the
successful upload, the software will appear under the Files tab.

Select the software update, click Install, and then click Yes in the confirmation pop-up window.

If the .ubf file is not signed or has been modified since it was downloaded from Cisco.com, Prime Infrastructure
will abort the installation. Contact your Cisco representative.

Prime Infrastructure will auto-restart and the web GUI will not be accessible for some time. (If it does not, restart it by
following the procedure in Stop and Restart Prime Infrastructure.)

When the web GUI is accessible, log in and check the version on the Software Update page.

a) Choose Administration > Licenses and Software Updates > Software Update.
b) Verify the information under the Updates tab.

What to do next

Instruct all users to clear their browser cache before opening the Prime Infrastructure web GUI.

Copy a File from a Client Machine to the Prime Infrastructure Server

Use the following SCP command to retrieve files from your client machine and copy them to the Prime
Infrastructure server's default local repository (/localdisk/defaultRepo). You should run this command as the
Linux CLI root user (see Log In and Out as the Linux CLI root User).

scp clientUsername@clientIP:/fullpath-to-file [/localdisk/defaultRepo
Where:

« clientUsername is your username on the client machine
* clientl P is the IP address of the client machine where the file resides
« fullpath-to-file is the full pathname of the file on the client machine

For example:

scp jsmith@123.456.789.101:/temp/myfile.tar.gz /localdisk/defaultRepo

Before you begin

Make sure SCP is enabled on your client machine, and the required ports are open (see the Cisco Prime
Infrastructure Quick Start Guide).
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