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Managing Reports
Cisco Prime Infrastructure reporting is necessary to monitor the system and network health as well as
troubleshoot network problems. A number of reports can be generated to run on an immediate or a
scheduled basis. Reports can also be combined to form composite reports. Each report type has a number
of user-defined criteria to aid in defining the reports. The reports can be formatted as a summary, tabular,
or combined (tabular and graphical) layout. After they have been defined, the reports can be saved for
future diagnostic use or scheduled to run on a regular basis.
Reports are saved in these formats:
•

CSV: The standard format. Whenever any CSV report exceeds 15,000 records, Prime Infrastructure
creates a ZIP file and stores all the CSV files for that report in the ZIP file.

•

PDF: These reports are either saved to a file on Prime Infrastructure to be downloaded later or
emailed to a specific email address.

Report categories are:
•

Current—Provides a snapshot of data that is not time-dependent.

•

Historical—Retrieves data from the device periodically and stores it in the Prime Infrastructure
database.

•

Trend—Generates a report using aggregated data. Data can be periodically collected from devices
and a schedule can be established for report generation.

•

Top N—Generates reports based on top utilization.

With Prime Infrastructure, you also have the ability to export any report that you can view, sort reports
into logical groups, and archive for long-term storage.
The Reports menu provides access to all Prime Infrastructure reports as well as currently saved and
scheduled reports, which includes:
•

Report Launch Pad—The hub for all Prime Infrastructure reports. From this page, you can access
specific types of reports and create new reports.

•

Scheduled Run Results—Allows you to access and manage all currently scheduled runs in Prime
Infrastructure, and to access and manage on-demand exports as well as emailed reports.

•

Saved Report Templates—Allows you to access and manage all currently saved report templates in
Prime Infrastructure.

For information about the report field descriptions, See “Field Reference for Cisco Prime Infrastructure
Reports” in Related Topics.
Related Topics
•

Generating Reports
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Generating Reports
The Report Launch Pad provides access to all Prime Infrastructure reports from a single page. You can
create and save new reports, view current reports, open specific types of reports, schedule a report to run
later, customize the results of a report, and combine multiple reports in to one single report.
To see more report details, hover the cursor over the tool tip next to the report type.
Related Topics
•

Managing Reports

•

Creating, Scheduling, and Running a New Report

•

Combining Reports

•

Customizing Report Results

•

About Scheduled Reports

•

About Saved Report Templates

•

Prime Infrastructure Report Data Retention Periods

Creating, Scheduling, and Running a New Report
To create, schedule, and run a new report:
Step 1

Choose Reports > Report Launch Pad.

Step 2

Choose a category from the left sidebar menu to see the report types for each report category, click New
corresponding to the appropriate report in the main area of the Report Launch Pad.

Step 3

In the Report Details page, complete the fields as described in the Report Launch Pad > Report Type
> New section. See “Field Reference for Cisco Prime Infrastructure Reports” in Related topics. The
parameters shown in the Report Details will vary with the report type. With some reports, you will need
to customize the report results.

Step 4

If you plan to run this report later or as a recurring report, enter Schedule parameters as described in the
Report Launch Pad > Report Type > New section. See “Field Reference for Cisco Prime Infrastructure
Reports” in Related topics.

Step 5

To run the report, choose one of the following options:
•

Note

Run—Click to run the report without saving the report setup.

By default, the ‘Run’ button is disabled in the Unique Clients and Users Summary report. You can
schedule this report to run during low utilization hours of Prime Infrastructure.

Cisco Prime Infrastructure 3.1.4 User Guide

59-ii

Chapter 59

Managing Reports
Generating Reports

Note

•

Save—Click to save this report setup without immediately running the report. If you have entered
Schedule parameters, the report runs automatically at the scheduled date and time.

•

Run and Save—Click to save this report setup and run the report immediately.

By default, the ‘Run and Save’ button is disabled in the Unique Clients and Users Summary report. You
can schedule this report to run during low utilization hours of Prime Infrastructure.
•

Save and Export—Click to save the report, run it, and export the results to a file. You will be
prompted to:
– Select the file format (CSV or PDF) of the exported report.
– Choose whether to send an email when the report has been generated. If you choose this option,

you must enter the destination email address and the email subject line content, and choose
whether you want the exported file included as an attachment to the email.
– Click OK.

If the CSV file fails to open correctly, make sure you specify a comma as the List Separator in one
of the following locations:
– Control Panel > Region/Language/Region and Language > Formats > Additional Settings
– In Excel: File > Options > Advanced > Use System Separators.
•

Save and Email—Click to save the report, run it, export the results as a file, and email the file. You
will be prompted to:
– Select the exported report file format.
– Enter the destination email address and the email subject line content
– Click OK.

•

Cancel—Click to return to the previous page without running or saving this report.

Step 6

Choose Administration > Dashboards > Job Dashboard > User Jobs.

Step 7

Click Report Status to view the status of the job.

Step 8

Click the report name to view the last five job instances. However, you will not be able to perform any
actions available under Edit and Job Series drop-down lists.

If a report has been saved for a specific report type, you can access the current reports from the Report
Launch Pad.
You cannot change or update generated reports for all subdomains at the same time. You can open and
change the reports individually through their respective subdomains. To update all reports, delete the
reports created on subdomains and regenerate virtual domain reports with the changes.
If you upgrade the Prime Infrastructure server to a higher version, you must delete and recreate the
reports that were already modified and saved in the older version.
Related Topics
•

Field Reference for Cisco Prime Infrastructure Reports

•

Combining Reports

•

Customizing Report Results
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Combining Reports
Two or more reports can be combined and information can be filtered based on requirements. Users can
select multiple reports and combine them instead of creating special reports for different scenarios.
Composite reports can be created from a pre-defined list of supported reports.
To create a new composite report:
Step 1

Choose Reports > Report Launch Pad. You can create a new report in one of the following ways:
a.

From the left sidebar menu, choose Composite > Composite Report, and then click New.

b.

On the Report Launch Pad page, scroll down to view the Composite section, then click New.

Step 2

In the New Custom Composite Report page, enter the report title.

Step 3

From the Report Category drop-down list, choose a category.

Step 4

Select the required reports from the available list and add them to the Selected Reports text box. You
can also remove the selected reports.

Step 5

Choose the appropriate Report By category from the drop-down list. The categories differ for each
report.

Step 6

The Report Criteria field allows you to sort your results depending on the previous Report By selection
made. Click Edit to open the Filter Criteria page and select the required filter criteria.

Step 7

If you plan to run this report later or as a recurring report, enter the Schedule parameters given in the
Schedule section.

Step 8

To run the report, choose one of the following options:
•

Run—Click to run the report without saving the report setup.

•

Save—Click to save the report setup without immediately running the report. If you have entered
the Schedule parameters, the report runs at the scheduled date and time.

•

Run and Save—Click to save the report setup and run the report immediately.

•

Save and Export—Click to save the report, run it, and export the results to a file or as an email
attachment. For this you need to:
– Choose the exported report file format (CSV or PDF).
– Check the first check box if you want to send an email when the report has been generated. You

must enter the destination email address and email subject line content.
– Check the second check box if you want the exported file to be included as an attachment in the

email.
Click OK.
•

Save and Email—Click to save the report, run it, export the results as a file, and email the file. You
will be prompted to:
– Choose the exported report file format.
– Enter the destination email address and email subject line content.

Click OK.
•

Cancel—Click to return to the previous page without running or saving the report.

You can access the saved composite reports from the Saved Reports Template.
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Related Topics
•

Field Reference for Cisco Prime Infrastructure Reports

•

Creating, Scheduling, and Running a New Report

•

Customizing Report Results

Customizing Report Results
Many reports allow you to customize their results, so that you can include / exclude the information you
need. If the report you are creating permits this, it will display a Customize button. You can click this
button to access the Create Custom Report page and customize the report results.
Customizing report results is sometimes required. For example, adding Flexible NetFlow (FNF)
Extension parameters to the Traffic Analysis, Application, or Voice Video Data monitoring template
makes those parameters part of your Prime Infrastructure monitoring setup. However, this does not mean
that the collected FNF extension monitoring data will automatically appear in the corresponding
Conversations reports for Core, Application Response Time (ART), and RTP performance. To ensure
that FNF data is included in Conversations reports, you must add the FNF parameters to the “Data fields
to include” column using the Create Custom Report page. See the Customizing page in “Field Reference
for Cisco Prime Infrastructure Reports” in Related topics.
To customize report results:
Step 1

Choose Reports > Report Launch Pad.

Step 2

Click the Report Title link for the appropriate report.

Step 3

In the Report Details page, click Customize.

Step 4

On the Create Custom Report page, complete the required information, then click Apply to confirm the
changes.
The changes made in the Create Custom Report page are not saved until you click Save in the Report
Details page.

Related Topics
•

Field Reference for Cisco Prime Infrastructure Reports

•

Creating, Scheduling, and Running a New Report

•

Combining Reports

About Scheduled Reports
To view all scheduled reports in Prime Infrastructure, choose Reports > Scheduled Run Results.
The scheduled report tasks are not visible outside the Virtual Domain they run in. The results of the
scheduled report tasks are visible in the Reports Run Results page of the respective domains.
The list of scheduled runs can be sorted by report category, report type, time frame, and report generation
method. For information about the fields on this page, see the Scheduled Run Results page in “Field
Reference for Cisco Prime Infrastructure Reports” in Related topics.

Cisco Prime Infrastructure 3.1.4 User Guide

59-v

Chapter 59

Managing Reports

About Saved Report Templates

Related Topics
•

Field Reference for Cisco Prime Infrastructure Reports

•

Creating, Scheduling, and Running a New Report

•

Combining Reports

•

Customizing Report Results

•

Managing Reports

•

About Saved Report Templates

•

Prime Infrastructure Report Data Retention Periods

About Saved Report Templates
Saved report templates are available at Reports > Saved Report Templates. From the Saved Report
Templates page, you can create report templates and manage saved report templates. You can also
enable, disable, delete, or run saved reports, and you can filter and sort report templates by category,
type, and status. For information about the fields on the Saved Report Templates page and filtering saved
report templates, see “Field Reference for Cisco Prime Infrastructure Reports” in Related topics.
The Saved Report Templates page displays the following information:
•

Report Title—Identifies the user-assigned report name.
Click the report title to view the details for this report.

•

Report Type—Identifies the specific report type.

•

Scheduled—Indicates whether this report is enabled or disabled.

•

Virtual Domain—Identifies the name of the virtual domain under which this report is scheduled.

•

Run Now—Click the run icon to immediately run the current report.

When you execute any domain based report for a sub virtual domain, the report displays all of the device
attributes that are mapped to the virtual domain where you are currently logged-in.
Related Topics
•

Field Reference for Cisco Prime Infrastructure Reports

•

Creating, Scheduling, and Running a New Report

•

Customizing Report Results

•

Managing Reports

•

Prime Infrastructure Report Data Retention Periods

•

About Scheduled Reports

Prime Infrastructure Report Data Retention Periods
The report shows hourly, daily or weekly data depending on the data retention period configured by
choosing Administration > Settings > System Settings > Data Retention. The data is retrieved from
the database based on the following conditions.
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If the period is:
1.

Up to last 1 day, the data is fetched from raw table.

2.

From last 2 days to 4 weeks, the data is fetched from a hourly aggregated table.

3.

From previous month calendar to last 12 week, the data is fetched from daily aggregated table.

4.

From last 6 months to last 1 year, the data is fetched from a weekly aggregated table.

The valid range for performance data retention period is:
1.

Short term Data Retain Period:1 to 31 days.

2.

Long term Data Retain Period: 2 to 756 days.

3.

Medium term Data Retain Period: 7 to365 days.

4.

Hourly Data Retain Period: Valid Range: is 1 to 31 hours.

5.

Daily Data Retain Period: 7 to 365 hours.

6.

Weekly Data Retain Period: 2 to 108 hours.

You can edit the the maximum number of records saved, the age of the records and the estimated memory
usage for each table by clicking Advanced Settings.
For detailed information about Prime Infrastructure reports, see “Field Reference for Cisco Prime
Infrastructure Reports” in Related topics.
Related Topics
•

Field Reference for Cisco Prime Infrastructure Reports
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