Sample Configlets
This appendix provides sample configlets for MPLS VPN provisioning in Prime Fulfillment. It contains the following sections:
•Overview
•L2 Access into L3 MPLS VPN
•CE-PE L3 MPLS VPN (BGP with full-mesh)
•CE-PE L3 MPLS VPN (BGP with SOO)
•CE-PE L3 MPLS VPN
•N-PE L3 MPLS VPN (IPv4, IOS XR, OSPF)
•N-PE L3 MPLS VPN (IPv6, IOS XR, EIGRP)
•PE L3 MPLS VPN (Dual-stack, Static [IPv4], BGP [IPv6], IOS)
•CE-PE L3 MPLS VPN (Q-in-Q/Second VLAN ID, IOS)
•CE-PE L3 MPLS VPN (Q-in-Q/Second VLAN ID, IOS XR)
•PE L3 MPLS VPN (with Multicast, IPv4 and IPv6 Enabled VPN, IOS XR)
•PE L3 MPLS VPN (Static, IOS, IPv6)
•PE L3 MPLS VPN (BGP, IOS)
•PE L3 MPLS VPN (BGP, IOS, IPv6)
•PE L3 MPLS VPN (BGP, IOS XR)
•PE L3 MPLS VPN (BGP, RD Format, IOS XR)
•PE L3 MPLS VPN (BGP, Maximum Prefix/Restart, IOS XR)
•PE L3 MPLS VPN (BGP, Default Information Originate, IOS XR)
•PE L3 MPLS VPN (OSPF, IOS)
•PE L3 MPLS VPN (OSPF, IOS XR)
•L3 MPLS VPN (OSPF, Default Information Originate, IOS XR)
•PE L3 MPLS VPN (EIGRP, Authentication Keychain Name, IOS XR)
•PE L3 MPLS VPN (Independent VRF, IOS XR)
•PE L3 MPLS VPN (Independent RTs for IPv4 and IPv6, IOS XR)
•PE L3 MPLS VPN (Bundle-Ether Interface, IOS XR)
•PE L3 MPLS VPN (Outgoing Interface + Next Hop IP Address, Static Route Configuration, IOS XR and IOS)
Overview
The configlets provided in this appendix show the CLIs generated by Prime Fulfillment for particular services and features. Each configlet example provides the following information:
•Service.
•Feature.
•Devices configuration (network role, hardware platform, relationship of the devices and other relevant information).
•Sample configlets for each device in the configuration.
•Comments.
Note The configlets generated by Prime Fulfillment are only the delta between what needs to be provisioned and what currently exists on the device. This means that if a relevant CLI is already on the device, it does not show up in the associated configlet.
Note All examples in this appendix assume an MPLS core.
For information on how to view configlets, see Chapter 47, "Viewing Service Request Configlets".
L2 Access into L3 MPLS VPN
Configuration
•Service: L2VPN/Metro Ethernet.
•Feature: Access into L3 MPLS VPN.
•Device configuration:
–The CE is a Cisco 3550 with IOS 12.1(22)EA1.
Interface(s): F0/13 <-> F0/4.
–The U-PE is a Cisco 3550 with IOS 12.1(22)EA1.
Interface(s): F0/14.
–The N-PE is a Cisco 7609 with IOS 12.2(18)SXF.
Interface(s): F2/8.
–VLAN = 3101.
Configlets
|
|
|
interface FastEthernet0/13
switchport trunk
encapsulation dot1q
switchport trunk allowed
vlan 1,3101
description By VPNSC: Job
Id# = 13
ip address 10.19.19.10
255.255.255.252
|
interface FastEthernet0/14
switchport trunk encapsulation
dot1q
switchport trunk allowed vlan
1,3101
interface FastEthernet0/4
switchport trunk encapsulation
dot1q
switchport trunk allowed vlan
3101
mac access-group
ISC-FastEthernet0/4 in
mac access-list extended
ISC-FastEthernet0/4
deny any host 0100.0ccc.cccc
deny any host 0100.0ccc.cccd
deny any host 0100.0ccd.cdd0
deny any host 0180.c200.0000
|
route-target import
100:1602
route-target import
100:1603
route-target export
100:1602
interface FastEthernet2/8
interface
FastEthernet2/8.3101
description
FastEthernet2/8.3101 dot1q
vlan id=3101. By VPNSC:
Job Id# = 13
ip vrf forwarding
V5:VPN_sample
ip address 10.19.19.9
255.255.255.252
address-family ipv4 vrf
V5:VPN_sample
exit-address-family |
Comments
•IP Numbered scenario with Dot1q encapsulation for VPN Link.
•The VRF is created on the N-PE device (-s designates that the VRF is joining the VPN as a spoke in a hub-n-spoke topology.
•On the N-PE, the VRF is added to iBGP routing instance with user configured redistribution of connected and static options.
•The VRF is created on the NPE with forwarding associated with the U-PE facing interface.
CE-PE L3 MPLS VPN (BGP with full-mesh)
Configuration
•Service: L3 MPLS VPN.
•Feature: CE-PE BGP with full-mesh.
•Device configuration:
–The PE is a Cisco 7609 with IOS 12.2(18)SXF.
Interface(s): F2/5.
–The CE is a Cisco 3550 with IOS 12.2(22)EA1.
Interface(s): F0/13.
–Routing protocol = BGP.
Configlets
|
|
interface FastEthernet0/13
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 62
description By VPNSC: Job Id# = 29
ip address 10.19.19.42 255.255.255.252
neighbor 10.19.19.41 remote-as 100
|
route-target import 99:3204
route-target export 99:3204
interface FastEthernet2/5.62
description FastEthernet2/5.62 dot1q vlan
id=62. By VPNSC: Job Id# = 29
ip vrf forwarding V9:mpls_vpn1
ip address 10.19.19.41 255.255.255.252
address-family ipv4 vrf V9:mpls_vpn1
neighbor 10.19.19.42 remote-as 10
neighbor 10.19.19.42 activate
neighbor 10.19.19.42 allowas-in 2
|
Comments
•A full-mesh configuration is created by means of the CERC selected for the VPN policy. As a result, route-target import and route-target export are identical.
•BGP is the routing protocol on the CE-PE access link.
•IP Numbered scenario with dot1q encapsulation for the VPN link.
•The VRF is created on the PE device.
•The VRF is created on the PE with forwarding associated with the CE facing interface.
CE-PE L3 MPLS VPN (BGP with SOO)
Configuration
•Service: L3 MPLS VPN.
•Feature: CE-PE.
•Device configuration:
–The PE is a Cisco 7609 with IOS 12.2(18)SXF.
Interface(s): FE2/3.
–The CE created in Prime Fulfillment.
Interface(s): FE1/0/14.
–Routing protocol = BGP.
–VPN = hub.
Configlets
|
|
interface FastEthernet1/0/14
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,3100
description By VPNSC: Job Id# = 12
ip address 10.19.19.6 255.255.255.252
network 10.19.19.4 0.0.0.3 area 12345
|
route-target import 100:1602
route-target export 100:1603
interface FastEthernet2/3.3100
description FastEthernet2/3.3100 dot1q vlan
id=3100. By VPNSC: Job Id# = 12
ip vrf forwarding V4:VPN_sample-s
ip address 10.19.19.5 255.255.255.252
router ospf 2500 vrf V4:VPN_sample-s
redistribute bgp 100 subnets
network 10.19.19.4 0.0.0.3 area 12345
address-family ipv4 vrf V4:VPN_sample-s
redistribute ospf 2500 vrf V4:VPN_sample-s
match internal external 1 external 2
|
Comments
•IP Numbered scenario with dot1q encapsulation for the VPN link.
•The VRF is created on PE device (VPN is joining as a spoke).
•On PE, the VRF is added to iBGP routing instance with user configured redistribution of connected and static options.
•The VRF is created on the PE with forwarding associated with the CE-facing interface.
•This example is for an IOS device. Site-of-origin (SOO) is also supported for IOS XR devices. In the case of an IOS XR device, the resulting configlet is different. For an IOS XR device, the configlet generated for SOO would be of the form site-of-origin 64512:500.
CE-PE L3 MPLS VPN
Configuration
•Service: L3 MPLS VPN.
•Feature: CE-PE.
•Device configuration:
–The PE is a Cisco 7603 with IOS 12.2(18)SXD7.
Interface(s): FE2/25.
–The CE is an Cisco 3750ME-I5-M with IOS 12.2(25)EY2.
Interface(s): FE1/0/6.
–VPN = spoke.
Configlets
|
|
interface FastEthernet1/0/6
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 890
description By VPNSC: Job Id# = 336 : SR
Id# = 336 ip address 10.10.75.2
255.255.255.252 no shutdown !
neighbor 10.10.75.1 remote-as 100
|
route-target import 100:1891
route-target export 100:1892
interface FastEthernet2/25.890
description FastEthernet2/25.890 dot1q vlan
id=890. By VPNSC: Job Id# = 336 : SR Id# =
336 encapsulation dot1Q 890 ip vrf
forwarding V60:TestVPN-s ip address
10.10.75.1 255.255.255.252 no shutdown !
address-family ipv4 vrf V60:TestVPN-s
neighbor 10.10.75.2 remote-as 120
neighbor 10.10.75.2 activate
neighbor 10.10.75.2 route-map
SetSOO_V60:TestVPN-s_100:100 in
exit-address-family !
route-map SetSOO_V60:TestVPN-s_100:100
permit 10 set extcommunity soo 100:100
|
Comments
•IP Numbered scenario with dot1q encapsulation for the VPN link.
•The VRF is created on the PE device.
•neighbor 10.10.75.2 remote-as 120
is created as a result of the policy having the CE BGP AS ID set to 120.
•The VRF is created on the PE with forwarding associated with the CE-facing interface.
•On the PE, BGP defines a route-map for the CE neighbor.
•The associated route map sets the extended community attribute to SOO, which is the community value (SOO pool value defined in Prime Fulfillment).
•This example is for an IOS device. Site-of-origin (SOO) is also supported for IOS XR devices. In the case of an IOS XR device, the resulting configlet is different. For an IOS XR device, the configlet generated for SOO would be of the form site-of-origin 64512:500.
N-PE L3 MPLS VPN (IPv4, IOS XR, OSPF)
Configuration
•Service: L3 MPLS VPN.
•Feature: IPv4 with IOS XR.
•Device configuration:
–The N-PE is a Cisco 12000 router with IOS XR.
–Routing protocol = OSPF.
Configlets
|
(See the extended code example below.) |
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<Name>GigabitEthernet0/1/1/1.856</Name>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<Name>GigabitEthernet0/1/1/1.856</Name>
<Description>GigabitEthernet0/1/1/1.856 dot1q vlan id=856. By VPNSC: Job Id# =
116</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VlanType>VLANTypeDot1q</VlanType>
<IPAddress>10.10.56.1</IPAddress>
<Mask>255.255.255.252</Mask>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<OSPFInstanceName>100</OSPFInstanceName>
<RedistType>21</RedistType>
<DefaultMetric>20000</DefaultMetric>
<InstanceName>100</InstanceName>
<VRFName>ICICI_VPN_1</VRFName>
<VRFStart>true</VRFStart>
<ProtocolType>rip</ProtocolType>
<InstanceName>rip</InstanceName>
<Classful>false</Classful>
<ProtocolType>static</ProtocolType>
<InstanceName>static</InstanceName>
<Classful>false</Classful>
<IntegerID>100</IntegerID>
<Interface>GigabitEthernet0/1/1/1.856</Interface>
<AlwaysAdvertise>true</AlwaysAdvertise>
Comments
•In IOS XR, device configuration is specified in XML format.
•With respect to the XML schemas, different versions of IOS XR generates different XML configlets. However the configurations are almost identical, except for changes in the XML schema.
•There are different cases to consider. For example, when a service request is decommissioned or modified, the XML configurations are slightly different.
N-PE L3 MPLS VPN (IPv6, IOS XR, EIGRP)
Configuration
•Service: L3 MPLS VPN.
•Feature: N-PE running IOS XR 3.5.x.
•Device configuration:
–The N-PE is a Cisco 12000 router with IOS XR 3.5.x.
–Routing protocol = EIGRP.
Configlets
|
(See the extended code example below.) |
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
interface GigabitEthernet0/1/1/1.840
ipv6 address fec0:140:9834::/64
<Configuration Source="CurrentConfig">
<VRFName>V10:ICICI_VPN</VRFName>
<VRF_AFType>IPv4</VRF_AFType>
<InterfaceConfigurationTable>
<Name>GigabitEthernet0/1/1/1.840</Name>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<Name>GigabitEthernet0/1/1/1.840</Name>
<Description>GigabitEthernet0/1/1/1.840 dot1q vlan id=840. By VPNSC: Job Id# =
50</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VlanType>VLANTypeDot1q</VlanType>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<Name>V10:ICICI_VPN</Name>
<EIGRPInstanceName>120</EIGRPInstanceName>
<VRFName>V10:ICICI_VPN</VRFName>
<VRF_AFType>IPv4</VRF_AFType>
<SecondASNumber>100</SecondASNumber>
<PolicySpecified>false</PolicySpecified>
<Reliability>200</Reliability>
<InterfaceName>GigabitEthernet0/1/1/1.840</InterfaceName>
<AutonomousSystem>120</AutonomousSystem>
•In IOS XR, device configuration is specified in XML format.
•With respect to the XML schemas, different versions of IOS XR generates different XML configlets. However the configurations are almost identical, except for changes in the XML schema.
•There are different cases to consider. For example, when a service request is decommissioned or modified, the XML configurations are slightly different.
PE L3 MPLS VPN (Dual-stack, Static [IPv4], BGP [IPv6], IOS)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request with VPN routing protocol as Static and BGP (dual-stack) on an IOS device.
•Device configuration:
–The PE is running IOS version 12.2(33) SRD2.
Interface(s): GigabitEthernet2/3.345.
–Routing protocol = STATIC (IPv4), BGP (IPv6).
Configlets
|
(See the extended code sample below.) |
route-target import 64512:73647
route-target import 64512:73648
route-target export 64512:73647
mdt data 225.4.4.2 0.0.0.0 threshold 2343
route-target import 64512:73647
route-target import 64512:73648
route-target export 64512:73647
interface GigabitEthernet2/3.345
description GigabitEthernet2/3.345 dot1q vlan id=345. By VPNSC: Job Id# = 42
ip address 44.5.5.5 255.255.255.0
ip multicast vrf UP-Tony-1 route-limit 12343
ip multicast-routing vrf UP-Tony-1
ip pim vrf UP-Tony-1 autorp listener
ip pim vrf UP-Tony-1 rp-address 4.3.3.4 list132 override
address-family ipv4 vrf UP-Tony-1
default-information originate
address-family ipv6 vrf UP-Tony-1
neighbor 535::2 remote-as 35
neighbor 535::2 as-override
neighbor 535::2 allowas-in 1
neighbor 535::2 send-community both
neighbor 535::2 advertisement-interval 34
neighbor 535::2 maximum-prefix 455 23 restart 2345
ip route vrf UP-Tony-1 34.5.3.3 255.255.255.255 GigabitEthernet2/3.345 4.5.3.2 234
ip route vrf UP-Tony-1 44.3.4.4 255.255.255.255 GigabitEthernet2/3.345 4.5.3.2 23
Comments
•None
CE-PE L3 MPLS VPN (Q-in-Q/Second VLAN ID, IOS)
Configuration
•Service: L3 MPLS VPN.
•Feature: CE-PE. Q-in-Q (second VLAN ID) is configured on the PE.
•Device configuration:
–The N-PE is a Cisco 7606-S with IOS 12.2(33)SRC, and with an ES20 line card.
Interface(s): GE2/0/15.
–The CE is a Cisco 2811.
Interface(s): FE0/0.
–VPN = spoke.
Configlets
|
|
interface FastEthernet0/0.158
description FastEthernet0/0.158 dot1q vlan
id=158. By VPNSC: Job Id# = 239
ip address 10.1.1.98 255.255.255.252
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0.158
|
route-target import 100:7000
route-target import 100:7001
route-target export 100:7000
interface GigabitEthernet2/0/15.158
description GigabitEthernet2/0/15.158 dot1q
vlan id=158. By VPNSC: Job Id# = 239
encapsulation dot1Q 158 second-dot1q 1502
ip vrf forwarding V15:MPLS-1
ip address 10.1.1.97 255.255.255.252
address-family ipv4 vrf V15:MPLS-1
|
Comments
•Encapsulation must be dot1q; SVI disabled.
•The resulting CLI configuration command is:
encapsulation dot1Q <VID-1> second-dot1q <VID-2>
–VID-1 can be assigned by Prime Fulfillment VLAN ID resource pools, or manually.
–VID-2 must be added manually. There is no support for autopick ID for the second VLAN ID.
•Platforms/IOS versions which support the command include, but are not limited to:
–Cisco 7600/SRBx with ES-20, SIP400 + 2, and 5-port GE-V2 SPA.
–Cisco 7600/SRCx ES-20, SIP400 + 2, 5-port GE-V2 SPA, and 10GE-V2 SPA.
–Cisco 7200 NPE-G1 with IOS 12.4 mainline.
–Cisco 7200 NPE-G2 with IOS 12.4(4)XD.
•Q-in-Q is also supported for IOS XR devices.
•There is a template variable for second VLAN ID: Second_PE_Vlan_ID.
•Network configurations supported include:
–PE only.
–PE-CE with managed and unmanaged CEs.
Note Q-in-Q/second VLAN ID is configured only on the PE, irrespective of whether the CE is managed or unmanaged.
For additional coverage of Q-in-Q support in Prime Fulfillment, see the coverage of the Second VLAN ID attribute in the section Chapter 25, "Creating an MPLS VPN PE-CE Service Request".
CE-PE L3 MPLS VPN (Q-in-Q/Second VLAN ID, IOS XR)
Configuration
•Service: L3 MPLS VPN.
•Feature: CE-PE. Q-in-Q (second VLAN ID) is configured on the PE.
•Device configuration:
–The PE is a Cisco GSR 12008 with IOS XR versions 3.8.1 or 3.9.0.
Interface(s): TenGigE0/0/0/0.
Configlets
|
The code examples below show CLI and XML configlets. All configlets are deployed on the PE device. |
Sample CLI Configlets
The following is a sample CLI configlet for an IOS XR device running IOS XR 3.8.1.
address-family ipv4 unicast
address-family ipv6 unicast
interface TenGigE0/0/0/0.1825
description TenGigE0/0/0/0.1825 dot1q vlan id=1825. By VPNSC: Job Id# = 29
ipv4 address 6.8.14.15 255.255.255.0
address-family ipv4 unicast
address-family ipv6 unicast
The following is a sample CLI configlet for an IOS XR device running IOS XR 3.9.0.
address-family ipv4 unicast
address-family ipv6 unicast
interface GigabitEthernet0/3/0/1.488
description GigabitEthernet0/3/0/1.488 dot1q vlan id=488. By VPNSC: Job Id# = 30
ipv4 address 25.14.12.4 255.255.255.0
address-family vpnv4 unicast
address-family vpnv6 unicast
address-family ipv4 unicast
address-family ipv6 unicast
Sample XML Configlets
The following is a sample XML configlet for for an IOS XR device running IOS XR 3.8.1.
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
address-family ipv6 unicast
import route-target 64512:9688
import route-target 64512:9689
export route-target 64512:9688
interface TenGigE0/0/0/0.1825
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<Name>TenGigE0/0/0/0.1825</Name>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<Configuration Source="CurrentConfig">
<Name>V3:Vpn-Apr-30</Name>
<Topology>default</Topology>
<InterfaceConfigurationTable>
<Name>TenGigE0/0/0/0.1825</Name>
<Description>TenGigE0/0/0/0.1825 dot1q vlan id=1825. By VPNSC: Job Id# =
29</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>1825</FirstTag>
<SecondTag>869</SecondTag>
<IPAddress>6.8.14.15</IPAddress>
<Mask>255.255.255.0</Mask>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<Name>V3:Vpn-Apr-30</Name>
The following is a sample XML configlet for for an IOS XR device running IOS XR 3.9.0.
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
address-family ipv6 unicast
import route-target 64512:9688
import route-target 64512:9689
export route-target 64512:9688
interface GigabitEthernet0/3/0/1.488
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<InterfaceName>GigabitEthernet0/3/0/1.488</InterfaceName>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<Configuration Source="CurrentConfig">
<VRFName>V3:Vpn-Apr-30</VRFName>
<SAFName>Unicast</SAFName>
<TopologyName>default</TopologyName>
<InterfaceConfigurationTable>
<InterfaceName>GigabitEthernet0/3/0/1.488</InterfaceName>
<Description>GigabitEthernet0/3/0/1.488 dot1q vlan id=488. By VPNSC: Job Id# =
30</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VlanType>VLANTypeDot1q</VlanType>
<SecondTag>758</SecondTag>
<Address>25.14.12.4</Address>
<Netmask>255.255.255.0</Netmask>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<VRFName>V3:Vpn-Apr-30</VRFName>
<AFName>IPv4Unicast</AFName>
<AFName>IPv6Unicast</AFName>
<AFName>VPNv4Unicast</AFName>
<AFName>VPNv6Unicast</AFName>
Comments
•None.
PE L3 MPLS VPN (with Multicast, IPv4 and IPv6 Enabled VPN, IOS XR)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request with multicast IPv4 and IPv6 enabled on IOS XR.
•Device configuration:
–The PE is an iscind-12010-1 (GSR) with IOS XR version 3.7.1[00].
Interface(s): GigabitEthernet0/1/0/1.
–Routing protocol = None.
Configlets
|
The code examples below show CLI and XML configlets for the MPLS service request. |
CLI Configlets
address-family ipv4 unicast
address-family ipv6 unicast
interface GigabitEthernet0/1/0/1.2589
description GigabitEthernet0/1/0/1.2589 dot1q vlan id=2589. By VPNSC: Job Id# = 54
ipv4 address 115.106.116.122 255.255.255.0
ipv6 address 1125::254/24
address-family ipv4 unicast
address-family ipv6 unicast
vrf V18:VPN_Verve1 address-family ipv4
interface GigabitEthernet0/1/0/1.2589
mdt data 224.10.0.5/32 threshold 8002
mdt default ipv4 224.10.0.4
vrf V18:VPN_Verve1 address-family ipv6
interface GigabitEthernet0/1/0/1.2589
mdt default ipv4 224.10.0.4
router pim vrf V18:VPN_Verve1 address-family ipv4
rp-address 115.101.110.122 list1
router pim vrf V18:VPN_Verve1 address-family ipv6
rp-address 1114::122 list2
XML Configlets
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
address-family ipv6 unicast
import route-target 100:19916
import route-target 100:19917
export route-target 100:19916
interface GigabitEthernet0/1/0/1.2589
ipv6 address 1125::254/24
mdt data 224.10.0.5/32 threshold 8002
interface GigabitEthernet0/1/0/1.2589
vrf V18:VPN_Verve1 address-family ipv6
interface GigabitEthernet0/1/0/1.2589
router pim vrf V18:VPN_Verve1 address-family ipv4 rp-address 115.101.110.122 list1
router pim vrf V18:VPN_Verve1 address-family ipv6 rp-address 1114::122 list2
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<Name>GigabitEthernet0/1/0/1.2589</Name>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<Configuration Source="CurrentConfig">
<Name>V18:VPN_Verve1</Name>
<Topology>default</Topology>
<InterfaceConfigurationTable>
<Name>GigabitEthernet0/1/0/1.2589</Name>
<Description>GigabitEthernet0/1/0/1.2589 dot1q vlan id=2589. By VPNSC: Job Id# =
54</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>2589</FirstTag>
<VRF>V18:VPN_Verve1</VRF>
<IPAddress>115.106.116.122</IPAddress>
<Mask>255.255.255.0</Mask>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<Name>V18:VPN_Verve1</Name>
Comments
•This service request uses the MPLS VPN PE_NO_CE policy.
•This service request has multicast IPv4 and IPv6 enabled VPN and also static RPs, as shown in the in the configlets.
PE L3 MPLS VPN (Static, IOS, IPv6)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request with VPN routing protocol as Static on an IOS device using IPv6 addressing.
•Device configuration:
–The PE is running IOS 12.2(33) SRD2.
Interface(s): GigabitEthernet2/3.455.
–Routing protocol = STATIC.
Configlets
|
vrf definition test-vpn-1
route-target import 64512:73647
route-target import 64512:73648
route-target export 64512:73647
interface GigabitEthernet2/3.455
description GigabitEthernet2/3.455 dot1q vlan id=455. By VPNSC: Job Id# = 87
vrf forwarding test-vpn-1
address-family ipv6 vrf test-vpn-1
default-information originate
ipv6 route vrf test-vpn-1 54::4/128 GigabitEthernet2/3.455 24::5 45
|
Comments
•None.
PE L3 MPLS VPN (BGP, IOS)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request with VPN routing protocol as BGP on IOS.
•Device configuration:
–The PE is an iscind-7600-2 with IOS version 12.2(17r) S2.
Interface(s): FastEthernet2/14.
–Routing protocol = BGP.
Configlets
|
route-target import 100:19906
route-target import 100:19907
route-target export 100:19906
interface FastEthernet2/14.2691
description FastEthernet2/14.2691 dot1q vlan id=2691. By VPNSC: Job Id# = 59
ip vrf forwarding V21:VPN
ip address 115.123.102.122 255.255.255.0
address-family ipv4 vrf V21:VPN
neighbor 115.102.123.102 remote-as 100
neighbor 115.102.123.102 activate
neighbor 115.102.123.102 allowas-in 5
neighbor 115.102.123.102 send-community both
neighbor 115.102.123.102 advertisement-interval 122
neighbor 115.102.123.102 maximum-prefix 122 12 restart 122
neighbor 5.2.2.5 route-map TESTING_IN in
neighbor 5.2.2.5 route-map TESTING_OUT out
|
Comments
•This service request uses the MPLS VPN PE_NO_CE policy.
•In this service request, the Neighbor Send Community attribute (which generates the send-community configuration command) is set to "Both".
PE L3 MPLS VPN (BGP, IOS, IPv6)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request with VPN routing protocol as BGP on an IOS device using IPv6 addressing.
•Device configuration:
–The PE is running IOS version 12.2(33) SRD2.
Interface(s): GigabitEthernet2/3.1234.
–Routing protocol = BGP.
Configlets
|
route-target import 64512:73647
route-target import 64512:73648
route-target export 64512:73647
interface GigabitEthernet2/3.1234
description GigabitEthernet2/3.1234 dot1q vlan id=1234. By VPNSC: Job Id# = 86
address-family ipv6 vrf VPN-test
neighbor 345::2 remote-as 44
neighbor 345::2 as-override
neighbor 345::2 allowas-in 4
neighbor 345::2 send-community both
neighbor 345::2 advertisement-interval 123
neighbor 345::2 maximum-prefix 4567 23 restart 234
|
Comments
•None
PE L3 MPLS VPN (BGP, IOS XR)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request with VPN routing protocol as BGP on IOS XR.
•Device configuration:
–The PE is a an iscind-12010-1 (GSR) with IOS XR version 3.7.1[00].
Interface(s): GigabitEthernet0/1/0/1.
–Routing protocol = BGP.
Configlets
|
The code examples below show CLI and XML configlets for the MPLS service request. |
CLI Configlets
address-family ipv4 unicast
interface GigabitEthernet0/1/0/1.2841
description GigabitEthernet0/1/0/1.2841 dot1q vlan id=2841. By VPNSC: Job Id# = 86
ipv4 address 125.101.122.125 255.255.255.0
address-family ipv4 unicast
advertisement-interval 122
address-family ipv4 unicast
XML Configlets
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<Name>GigabitEthernet0/1/0/1.2841</Name>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<Configuration Source="CurrentConfig">
<Topology>default</Topology>
<InterfaceConfigurationTable>
<Name>GigabitEthernet0/1/0/1.2841</Name>
<Description>GigabitEthernet0/1/0/1.2841 dot1q vlan id=2841. By VPNSC: Job Id# =
86</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>2841</FirstTag>
<IPAddress>125.101.122.125</IPAddress>
<Mask>255.255.255.0</Mask>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<IPV4Address>112.120.102.112</IPV4Address>
<Activate>true</Activate>
<IPV4Address>112.120.102.112</IPV4Address>
<IPV4Address>112.120.102.112</IPV4Address>
<RoutePolicyIn>verve</RoutePolicyIn>
<RoutePolicyIn>verve</RoutePolicyIn>
<IPV4Address>112.120.102.112</IPV4Address>
<RoutePolicyOut>verve</RoutePolicyOut>
<RoutePolicyOut>verve</RoutePolicyOut>
<IPV4Address>112.120.102.112</IPV4Address>
<Activate>true</Activate>
<AdvertisementInterval>122</AdvertisementInterval>
Comments
•This service request is using the MPLS VPN PE_NO_CE policy.
•In this service request, the Neighbor Send Community attribute (which generates the send-community configuration command) is set as "None".
•In this service request, a route-policy name has been supplied using the Route Map/Policy In (Out) attribute(s).
Note The route policy is already present on the device.
The deployment used that name only, as shown in the configlets.
•If no route-map name had been supplied, then Prime Fulfillment would have added IscDefaultPassAll as the default. This default is only added in the case of IOS XR devices. No default is added for IOS devices.
PE L3 MPLS VPN (BGP, RD Format, IOS XR)
Configuration
•Service: L3 MPLS VPN
•Feature: MPLS service request with BGP protocol and RD IP address format on IOS XR.
•Device configuration:
–The PE is a Cisco IOX device with IOS XR version 3.7.1.
Interface(s): GigabitEthernet.
–Routing protocol = BGP.
Configlets
|
The code examples below show CLI and XML configlets for the MPLS service request. |
MPLS Service Request CLI Configlet
address-family ipv6 unicast
address-family ipv6 unicast
MPLS Service Request XML Configlets
<Type> IPV4Address </Type>
<AddrIndex>14540</AddrIndex>
Comments
•None.
PE L3 MPLS VPN (BGP, Maximum Prefix/Restart, IOS XR)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request using the BGP routing protocol and specifying the number of maximum prefixes and restart value.
•Device configuration:
–The PE is an IOS XR device running IOS XR version 3.8.1 or 3.9.0.
Interface(s): Various.
–Routing protocol = BGP.
Configlets
|
The code examples below show CLI and XML configlets. All configlets are deployed on the PE device. |
Sample CLI Configlets
The following is a sample CLI configlet for an IOS XR device running IOS XR 3.8.1.
address-family ipv4 unicast
address-family ipv6 unicast
address-family ipv4 unicast
maximum-prefix 101 91 restart 81
address-family ipv6 unicast
maximum-prefix 124 46 restart 6711
The following is a sample CLI configlet for an IOS XR device running IOS XR 3.9.0. This is an example showing restart configlets.
address-family ipv4 unicast
address-family ipv6 unicast
address-family ipv4 unicast
maximum-prefix 160 80 restart 300
address-family ipv6 unicast
maximum-prefix 200 26 restart 214
The following is a sample CLI configlet for an IOS XR device running IOS XR 3.9.0. This is an example showing warning-only configlets.
address-family ipv4 unicast
address-family ipv6 unicast
address-family ipv4 unicast
maximum-prefix 160 80 warning-only
address-family ipv6 unicast
maximum-prefix 200 26 warning-only
Sample XML Configlets
The following is a sample XML configlet for for an IOS XR device running IOS XR 3.8.1.
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<Configuration Source="CurrentConfig">
<IPV4Address>1.2.5.4</IPV4Address>
<WarningPercentage>91</WarningPercentage>
<RestartTime>81</RestartTime>
<WarningOnly>false</WarningOnly>
<IPV6Address>11::69</IPV6Address>
<WarningPercentage>46</WarningPercentage>
<RestartTime>6711</RestartTime>
<WarningOnly>false</WarningOnly>
The following is a sample XML configlet for for an IOS XR device running IOS XR 3.9.0.
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<Configuration Source="CurrentConfig">
<VRFName>V23:27Cerc2</VRFName>
<AFName>IPv4Unicast</AFName>
<AFName>IPv6Unicast</AFName>
<IPV4Address>8.5.2.33</IPV4Address>
<AFName>IPv4Unicast</AFName>
<PrefixLimit>160</PrefixLimit>
<WarningPercentage>80</WarningPercentage>
<RestartTime>300</RestartTime>
<WarningOnly>false</WarningOnly>
<IPV6Address>25::9</IPV6Address>
<AFName>IPv6Unicast</AFName>
<PrefixLimit>200</PrefixLimit>
<WarningPercentage>26</WarningPercentage>
<RestartTime>214</RestartTime>
<WarningOnly>false</WarningOnly>
Comments
•If the user gives both warning only and restart values, Prime Fulfillment validates and gives the higher priority to the restart value for all IOS and IOS XR versions.
•For individual values (like warning-only or restart, if either is given), Prime Fulfillment configures accordingly.
PE L3 MPLS VPN (BGP, Default Information Originate, IOS XR)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request using the BGP routing protocol and specifying setting the Default Information Originate attribute to cause the BGP speaker (local router) to send a default route to a neighbor.
•Device configuration:
–The PE is an IOS XR device running IOS XR version 3.8.1 or 3.9.0.
Interface(s): Various.
–Routing protocol = BGP.
Configlets
|
The code examples below show CLI and XML configlets. All configlets are deployed on the PE device. |
Sample CLI Configlets
The following is a sample CLI configlet for an IOS XR device running IOS XR 3.8.1.
address-family ipv4 unicast
address-family ipv6 unicast
address-family ipv4 unicast
default-originate route-policy dinesh
address-family ipv4 unicast
address-family ipv6 unicast
default-originate disable
The following is a sample CLI configlet for an IOS XR device running IOS XR 3.9.0.
address-family ipv4 unicast
address-family ipv6 unicast
address-family ipv4 unicast
default-originate route-policy dinesh
address-family ipv4 unicast
address-family ipv6 unicast
default-originate inheritance-disable
Sample XML Configlets
The following is a sample XML configlet for for an IOS XR device running IOS XR 3.8.1.
<BGP MajorVersion="30" MinorVersion="2">
<BGPRunning>true</BGPRunning>
<IPV4Address>1.1.1.1</IPV4Address>
<Activate>true</Activate>
<RoutePolicy>dinesh</RoutePolicy>
<IPV6Address>2002::23</IPV6Address>
<Activate>true</Activate>
<IPV6Address>2002::23</IPV6Address>
<Activate>true</Activate>
Comments
•None.
PE L3 MPLS VPN (OSPF, IOS)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request with VPN routing protocol as OSPF on IOS.
•Device configuration:
–The PE is an iscind-7600-2 with IOS version 12.2(17r) S2.
–Routing protocol = OSPF.
Configlets
|
no interface FastEthernet2/14.2685
interface FastEthernet2/14.2677
description FastEthernet2/14.2677 dot1q vlan id=2677. By VPNSC: Job Id# = 60
ip vrf forwarding Tester1
ip address 112.126.102.106 255.255.255.0
router ospf 1266 vrf Tester1
redistribute bgp 100 subnets
network 112.126.102.0 0.0.0.255 area 23693
address-family ipv4 vrf Tester1
redistribute ospf 1266 vrf Tester1 metric 1263 route-map verve match internal external 1
external 2
|
Comments
•This service request is using the MPLS VPN PE_NO_CE policy.
•OSPF Match Criteria is set as "Both". So internal, external1, and external2 configuration commands are generated in the configlet.
•There is no support for external type 1 or external type 2 commands in the IOS XR variation of this command, but they are support in IOS.
PE L3 MPLS VPN (OSPF, IOS XR)
Configuration
•Service: L3 MPLS VPN
•Feature: MPLS service request with VPN routing protocol as OSPF on IOS XR.
•Device configuration:
–The PE is an mlpe7 with IOS XR version 3.6.1[00].
Interface(s): GigabitEthernet0/1/0/1.
–Routing protocol = OSPF.
Configlets
|
The code examples below show CLI and XML configlets for the MPLS service request. |
MPLS Service Request CLI Configlet
address-family ipv4 unicast
interface GigabitEthernet0/1/1/4.2693
description GigabitEthernet0/1/1/4.2693 dot1q vlan id=2693. By VPNSC: Job Id# = 90
ipv4 address 123.33.102.112 255.255.255.0
interface GigabitEthernet0/1/1/4.2693
address-family ipv4 unicast
redistribute ospf 1238 match internal external metric 2581 route-policy verve
MPLS Service Request XML Configlets
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<Name>GigabitEthernet0/1/1/4.2693</Name>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<Name>GigabitEthernet0/1/1/4.2693</Name>
<Description>GigabitEthernet0/1/1/4.2693 dot1q vlan id=2693. By VPNSC: Job Id# =
90</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>2693</FirstTag>
<IPAddress>123.33.102.112</IPAddress>
<Mask>255.255.255.0</Mask>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<OSPFInstanceName>1238</OSPFInstanceName>
<RedistType>21</RedistType>
<DefaultMetric>2581</DefaultMetric>
<InstanceName>1238</InstanceName>
<VRFName>V28:Cisco5</VRFName>
<VRFStart>true</VRFStart>
<ProtocolType>bgp</ProtocolType>
<InstanceName>bgp</InstanceName>
<BGP_AS_YY>100</BGP_AS_YY>
<Classful>false</Classful>
<IntegerID>29871</IntegerID>
<Interface>GigabitEthernet0/1/1/4.2693</Interface>
Comments
•This service request uses the MPLS VPN PE_NO_CE policy.
•OSPF Match Criteria is set as "Both". So internal and external configuration commands are generated in the configlets.
•There is no support for external type 1 or external type 2 in the IOS XR variation of this command, but the support exists in IOS.
L3 MPLS VPN (OSPF, Default Information Originate, IOS XR)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request using the OSPF routing protocol and setting the Default Information Originate to generate a default external route into an OSPF routing domain.
•Device configuration:
–The PE is an IOS XR device running IOS XR version 3.9.0.
Interface(s): Various.
–Routing protocol = OSPF.
Configlets
|
The code examples below show CLI and XML configlets. All configlets are deployed on the PE device. |
Sample CLI Configlets
The following is a sample CLI configlet for an IOS XR device running IOS XR 3.9.0.
address-family ipv4 unicast
address-family ipv6 unicast
interface GigabitEthernet0/15/1/1.947
description GigabitEthernet0/15/1/1.947 dot1q vlan id=947. By VPNSC: Job Id# = 191
ipv4 address 26.27.28.21 255.255.255.0
ipv6 address 2165::541/32
default-information originate always metric 652 metric-type 2 route-policy dinesh
interface GigabitEthernet0/15/1/1.947
address-family ipv4 unicast
redistribute ospf 1611 match internal metric 325
address-family ipv6 unicast
Sample XML Configlets
The following is a sample XML configlet for for an IOS XR device running IOS XR 3.9.0.
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
address-family ipv6 unicast
import route-target 64512:2776
import route-target 64512:2777
export route-target 64512:2776
interface GigabitEthernet0/15/1/1.947
ipv6 address 2165::541/32
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<InterfaceName>GigabitEthernet0/15/1/1.947</InterfaceName>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<Configuration Source="CurrentConfig">
<VRFName>V35:apr26-vpn9</VRFName>
<SAFName>Unicast</SAFName>
<TopologyName>default</TopologyName>
<InterfaceConfigurationTable>
<InterfaceName>GigabitEthernet0/15/1/1.947</InterfaceName>
<Description>GigabitEthernet0/15/1/1.947 dot1q vlan id=947. By VPNSC: Job Id# =
191</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VlanType>VLANTypeDot1q</VlanType>
<VRF>V35:apr26-vpn9</VRF>
<Address>26.27.28.21</Address>
<Netmask>255.255.255.0</Netmask>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<VRFName>V35:apr26-vpn9</VRFName>
<AFName>IPv4Unicast</AFName>
<InstanceName>1611</InstanceName>
<RedistType>01</RedistType>
<DefaultMetric>325</DefaultMetric>
<AFName>IPv6Unicast</AFName>
<ProcessName>1611</ProcessName>
<VRFName>V35:apr26-vpn9</VRFName>
<VRFStart>true</VRFStart>
<AlwaysAdvertise>true</AlwaysAdvertise>
<MetricType>Type2</MetricType>
<InterfaceName>GigabitEthernet0/15/1/1.947</InterfaceName>
Comments
•None.
PE L3 MPLS VPN (EIGRP, Authentication Keychain Name, IOS XR)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request using the EIGRP routing protocol and specifying a keychain name to authentic EIGRP protocol traffic on an interface.
•Device configuration:
–The PE is an IOS XR device running IOS XR version 3.8.1 or 3.9.0.
Interface(s): Various.
–Routing protocol = EIGRP.
Configlets
|
The code examples below show CLI and XML configlets. All configlets are deployed on the PE device. |
Sample CLI Configlets
The following is a sample CLI configlet for an IOS XR device.
address-family ipv4 unicast
address-family ipv6 unicast
interface TenGigE0/0/0/3.841
description TenGigE0/0/0/3.841 dot1q vlan id=841. By VPNSC: Job Id# = 188
ipv4 address 31.32.33.23 255.255.255.0
address-family ipv4 unicast
address-family ipv6 unicast
default-metric 1509 1842 196 187 1657
interface TenGigE0/0/0/3.841
authentication keychain keychain-ipv4
default-metric 1624 1428 186 127 1095
interface TenGigE0/0/0/3.841
authentication keychain keychain-ipv6
Sample XML Configlets
The following is a sample XML configlet for for an IOS XR device.
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
address-family ipv6 unicast
import route-target 64512:2764
import route-target 64512:2765
export route-target 64512:2764
interface TenGigE0/0/0/3.841
<Configuration Source="CurrentConfig">
<VRFName>V67:apr26-vpn2</VRFName>
<VRF_AFType>IPv4</VRF_AFType>
<VRF_AFType>IPv6</VRF_AFType>
<InterfaceConfigurationTable>
<Name>TenGigE0/0/0/3.841</Name>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<Configuration Source="CurrentConfig">
<Name>V67:apr26-vpn2</Name>
<Topology>default</Topology>
<InterfaceConfigurationTable>
<Name>TenGigE0/0/0/3.841</Name>
<Description>TenGigE0/0/0/3.841 dot1q vlan id=841. By VPNSC: Job Id# =
188</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VlanType>VLANTypeDot1q</VlanType>
<VRF>V67:apr26-vpn2</VRF>
<IPAddress>31.32.33.23</IPAddress>
<Mask>255.255.255.0</Mask>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<Name>V67:apr26-vpn2</Name>
<EIGRPInstanceName>1324</EIGRPInstanceName>
<EIGRPInstanceName>1321</EIGRPInstanceName>
<VRFName>V67:apr26-vpn2</VRFName>
<VRF_AFType>IPv4</VRF_AFType>
<SecondASNumber>64512</SecondASNumber>
<PolicySpecified>false</PolicySpecified>
<Reliability>196</Reliability>
<InterfaceName>TenGigE0/0/0/3.841</InterfaceName>
<Keychain>keychain-ipv4</Keychain>
<AutonomousSystem>1324</AutonomousSystem>
<VRF_AFType>IPv6</VRF_AFType>
<SecondASNumber>64512</SecondASNumber>
<PolicySpecified>false</PolicySpecified>
<Reliability>186</Reliability>
<InterfaceName>TenGigE0/0/0/3.841</InterfaceName>
<Keychain>keychain-ipv6</Keychain>
<AutonomousSystem>1321</AutonomousSystem>
Comments
•None.
PE L3 MPLS VPN (Independent VRF, IOS XR)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request using an independent VRF on IOS XR
•Device configuration:
–The PE is an iscind-12010-1 (GSR) with IOS XR version 3.7.1[00].
Interface(s): GigabitEthernet0/1/0/1.
–Routing protocol = None.
Configlets
|
The code examples below show CLI and XML configlets for both the MPLS service request and the VRF object. |
MPLS Service Request CLI Configlets
interface GigabitEthernet0/1/0/0.3233
description GigabitEthernet0/1/0/0.3233 dot1q vlan id=3233. By VPNSC: Job Id# = 64
ipv4 address 126.112.102.102 255.255.255.0
ipv6 address 1365::126/28
address-family ipv4 unicast
address-family ipv6 unicast
vrf VRF112 address-family ipv4
interface GigabitEthernet0/1/0/0.3233
vrf VRF112 address-family ipv6
interface GigabitEthernet0/1/0/0.3233
MPLS Service Requesets XML Configlets
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
interface GigabitEthernet0/1/0/0.3233
ipv6 address 1365::126/28
interface GigabitEthernet0/1/0/0.3233
vrf VRF112 address-family ipv6
interface GigabitEthernet0/1/0/0.3233
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<Name>GigabitEthernet0/1/0/0.3233</Name>
<Shutdown>true</Shutdown>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
<Configuration Source="CurrentConfig">
<InterfaceConfigurationTable>
<Name>GigabitEthernet0/1/0/0.3233</Name>
<Description>GigabitEthernet0/1/0/0.3233 dot1q vlan id=3233. By VPNSC: Job Id# =
64</Description>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<VlanType>VLANTypeDot1q</VlanType>
<FirstTag>3233</FirstTag>
<IPAddress>126.112.102.102</IPAddress>
<Mask>255.255.255.0</Mask>
</InterfaceConfiguration>
</InterfaceConfigurationTable>
VRF Service Request CLI Configlets
address-family ipv4 unicast
address-family ipv6 unicast
vrf VRF112 address-family ipv4
mdt data 224.10.0.9/32 threshold 8024
mdt default ipv4 224.10.0.8
vrf VRF112 address-family ipv6
mdt default ipv4 224.10.0.8
router pim vrf VRF112 address-family ipv4
rp-address 112.101.122.102 list1
router pim vrf VRF112 address-family ipv6
rp-address 1253::214 list2
VRF Service Request XML Configlets
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
address-family ipv6 unicast
import route-target 100:19890
import route-target 100:19891
export route-target 100:19890
mdt data 224.10.0.9/32 threshold 8024
vrf VRF112 address-family ipv6
router pim vrf VRF112 address-family ipv4 rp-address 112.101.122.102 list1
router pim vrf VRF112 address-family ipv6 rp-address 1253::214 list2
<Configuration Source="CurrentConfig">
<Topology>default</Topology>
<Addr>112.101.112.101</Addr>
<AddrIndex>1263</AddrIndex>
</Request>
Comments
•This service request uses the MPLS VPN PE_NO_CE policy.
•This service request has multicast IPv4 and IPv6 enabled VPN and also static RPs, as shown in the in the configlets.
PE L3 MPLS VPN (Independent RTs for IPv4 and IPv6, IOS XR)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request using independent RTs for IPv4 and IPv6.
•Device configuration:
–The PE is an iscind-12010-1 (GSR) with IOS XR version 3.7.1[00].
Interface(s): Various.
–Routing protocol = None.
Configlets
|
The code examples below show CLI and XML configlets for the specified independent RT configurations, as noted. All configlets are deployed on the PE device. |
Sample CLI Configlets
The following examples show CLI configlets for the specified independent RT configurations.
Example 1: CE-PE with CERC Type set as IPv4.
address-family ipv4 unicast
address-family ipv6 unicast
Note If the CERC were tagged as IPv6, the RTs would be configured under ipv6 address-family.
Example 2: PE-CE with CERC Type set as IPv4+IPv6.
address-family ipv4 unicast
address-family ipv6 unicast
Note If there were additional IPv4 or IPv6 CERCs selected and tagged, they would be incrementally added into the above format under the appropriate address-family CLIs.
Example 3: Adding More VPNs
When adding more VPNs to the configuration, then one VPN name shows up in the configlet with the the string -etc appended, as shown below.
address-family ipv4 unicast
Sample XML Configlets
The following is a sample XML configlet for PE-CE with CERC Type set as IPv4+IPv6. Key XML tags are shown in bold text.
<?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
address-family ipv6 unicast
import route-target <?xml version="1.0" encoding="UTF-8"?>
<Request MajorVersion="1" MinorVersion="0">
address-family ipv6 unicast
import route-target 64512:25428
import route-target 64512:25429
export route-target 64512:25428
interface GigabitEthernet0/3/0/2.3039
<Configuration Source="CurrentConfig">
<Name>V6:Verve_VPN32</Name>
<Topology>default</Topology>
<ASIndex>254288</ASIndex>
<ASIndex>254299</ASIndex>
<ASIndex>254288</ASIndex>
Comments
•None.
PE L3 MPLS VPN (Bundle-Ether Interface, IOS XR)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request using a Bundle-Ethernet interface.
•Device configuration:
–The PE is an iscind-12010-1 (GSR) with IOS XR version 3.7.1[00].
Interface(s): Bundle-Ether147.
–Routing protocol = None.
Configlets
|
The code examples below show CLI and XML configlets for a Bundle-Ethernet interface, as noted. All configlets are deployed on the PE device. |
Sample CLI Configlets
The following example is a CLI configlet for the bundle interface feature. The configlet is deployed on the PE device.
interface Bundle-Ether147
interface Bundle-Ether147.369
ipv4 address 66.174.25.3 255.255.255.254
ipv6 address 2001:4888:10:100::3/64
Sample XML Configlets
The following is a sample XML configlet for the bundle interface feature. The configlet is deployed on the PE device.
<Name>Bundle-Ether147</Name>
<InterfaceVirtual>true</InterfaceVirtual>
<Description>Bun</Description>
</InterfaceConfiguration>
<Name>Bundle-Ether147.369</Name>
<InterfaceModeNonPhysical>Default</InterfaceModeNonPhysical>
<Description>subbun</Description>
<VRF MajorVersion="3" MinorVersion="3">ISC521</VRF>
<IPV4Network MajorVersion="5" MinorVersion="0">
<IPAddress>66.174.25.3</IPAddress>
<Mask>255.255.255.254</Mask>
<VLANSubConfiguration MajorVersion="2" MinorVersion="1">
<VlanType>VLANTypeDot1q</VlanType>
</InterfaceConfiguration>
Comments
•None.
PE L3 MPLS VPN (Outgoing Interface + Next Hop IP Address, Static Route Configuration, IOS XR and IOS)
Configuration
•Service: L3 MPLS VPN.
•Feature: MPLS service request using the static routing protocol and specifying an outgoing interface and next hop IP address.
•Device configuration:
–The PE is an iscind-12010-1 (GSR) with IOS XR version 3.7.1[00].
Interface(s): Various.
–Routing protocol = Static.
Configlets
|
The code examples below show CLI and XML configlets. All configlets are deployed on the PE device. |
Sample CLI Configlets
The following is a sample CLI configlet for an IOS device.
address-family ipv4 vrf V14:July7_VPN
ip route vrf V14:July7_VPN 15.18.16.17 255.255.255.255 GigabitEthernet0/3/0/0 10.12.16.19
78
The following is a sample CLI configlet for an IOS XR device.
address-family ipv4 unicast
12.23.34.34/32 GigabitEthernet0/3/0/2 10.14.54.18 45
address-family ipv6 unicast
15:16:17:13:14:15:17:18/128 GigabitEthernet0/3/0/2 18:12:13:14:16:13:16:14
Sample XML Configlets
The following is a sample XML configlet for IPv4 address family.
<VRFName>V1:VPN_June22</VRFName>
<IPV4Address>10.77.66.58</IPV4Address>
<Interface>GigabitEthernet0/3/0/0</Interface>
<IPV4Address>10.12.16.19</IPV4Address>
The following is a sample XML configlet for IPv6 address family.
<VRFName>V39:techm_vpn</VRFName>
<IPV6Address>10::19</IPV6Address>
<Interface>GigabitEthernet0/3/0/0</Interface>
<IPV6Address>45::10</IPV6Address>
Comments
•None.