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Editing an ITP Global Title Translation Table
You can use the Global Title Translation (GTT) Editor of the Cisco Mobile Wireless Transport Manager
(MWTM) to configure GTT entries.
A global title is an application address, such as a toll-free telephone number, calling card number, or
mobile subscriber identification number. GTT is the process by which the Signaling Connection Control
Part (SCCP) translates a global title into the point code and subsystem number (SSN) of the destination
service switching point (SSP), where higher-layer protocol processing occurs. GTT entries reside in
GTT files, which are comma-separated value (CSV) text files with point codes written in hexadecimal
notation.

Note

The MWTM 6.1.6 supports GTT files with file format versions 3.1, 4.0, 4.1, 4.2, 4.3, 4.4, 4.5, or 4.6.
You can load GTT files that use lower or higher file-format versions; but, fields or features that are
unique to the lower or higher version are not visible and they disappear from the GTT file the next time
you save the file. The file is saved as a version 3.1 file if the file is lower than version 3.1; or, as a version
4.6 file if the file is higher than version 4.6.
For more detailed information about GTT, including configuration procedures and scenarios, see the
IP Transfer Point (ITP) feature module for Cisco IOS software release 12.2(25)SW4 or later.
This chapter contains:
•

Launching the GTT Editor, page 15-2

•

Editing a GTT Table, page 15-15

•

Adding a Selector to a Selector Table, page 15-16

•

Adding a GTA Entry to a GTT, page 15-17

•

Searching the GTA Table for GTA Digits, page 15-19

•

Adding an Application Group Entry to an App Group Table, page 15-21

•

Adding a MAP Entry to a GTT, page 15-22

•

Adding a CPC List to a GTT, page 15-23

•

Adding a GTT Address Conversion Table, page 15-24

•

Adding an Entry to a GTT Conversion Table Entry, page 15-25

•

Deleting Rows from a Table, page 15-26

•

Creating a New GTT File, page 15-27

•

Loading an Existing GTT File, page 15-29
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•

Loading a GTT File from a Node, page 15-30

•

Loading a GTT File from the Archive, page 15-31

•

Displaying the Progress Dialog Box, page 15-32

•

Checking the Semantics of a GTT File, page 15-33

•

Deploying a GTT File, page 15-34

•

Displaying Basic Information About a GTT File, page 15-34

•

Supporting Cross-Instance GTT Files, page 15-36

•

Saving a GTT File, page 15-38

•

Reverting to the Last Saved GTT File, page 15-40

Launching the GTT Editor
The MWTM provides you with a GTT Editor to edit GTT files. The GTT Editor runs as a separate
application in the MWTM; so, it requires a separate login, just like the MWTM client.
To launch the GTT Editor, use one of these procedures:
•

Choose Tools > Global Title Translator Editor from the MWTM main menu.

•

Enter the mwtm gttclient command (see mwtm gttclient, page B-116).

The Startup Options dialog box appears, which you use to load a specific GTT file or create a new GTT
file.
The Startup Options dialog box provides options to load GTT data from:
Field or Button

Description

New File

Opens the Create New Table dialog box, which you use to create a new GTT
file (see Creating a New GTT File, page 15-27). Create the new GTT file.

File

Opens the Load File dialog box: GTT File List, which you use to load a
specific GTT file and change the list of GTT files (see Loading an Existing
GTT File, page 15-29). Select a GTT file to load.

ITP

Opens the Load GTT from ITP wizard, which you use to choose the node and
signaling point whose GTT file you want to edit (see Loading a GTT File
from a Node, page 15-30).

Archive

Opens the Load GTT from Archive wizard, which you use to choose the node
and signaling point whose GTT file you want to edit (see Loading a GTT File
from the Archive, page 15-31).

When you close the Startup Options dialog box by creating a new GTT file or loading an existing GTT
file, the GTT Editor window appears with the Selectors and GTA tab clicked.
The GTT Editor window provides a set of tabs. Each tab contains a series of tables with GTT data. Some
of the tables may be blank at first, while others contain rows of data.
In each table, you can edit the values in each row by typing over the current value or selecting a new
value from a drop-down list box.
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To reset a cell to its previous value, press Esc. (If you have edited more than one cell in a row, pressing
Esc resets all cells in the row.) To save your changes, click outside the row. Once you save your changes,
pressing Esc does not reset the cells in the row.
To add a row to a table, select the table, then choose Edit > Add from the GTT menu or Add from the
right-click menu.
To delete one or more rows from a table, select the rows, then choose Edit > Delete from the GTT menu
or Delete from the right-click menu (see Deleting Rows from a Table, page 15-26).
The GTT Editor window contains:
•

GTT Menu, page 15-3

•

GTT Editor: Selectors and GTA Tab, page 15-5

•

GTT Editor: App Group Tab, page 15-9

•

GTT Editor: MAPs Tab, page 15-10

•

GTT Editor: CPC Tab, page 15-11

•

GTT Editor: Address Conversion Tab, page 15-12

GTT Menu
The menu on the GTT Editor window contains:
Menu Command

Description

File > New Table
(Ctrl-N)

Opens the Create New Table dialog box.

File > Load > Load From
Archive (Ctrl-H)

Opens the Load GTT from Archive wizard from which you choose
the node and signaling point whose GTT file you want to edit (see
Loading a GTT File from the Archive, page 15-31).
If you have implemented MWTM User-Based Access, this option is
available to users with authentication level Network Operator (level
3) and higher.

File > Load > Load From File
(Ctrl-L)

Loads an already existing GTT file. The MWTM prompts you for
the name of the GTT file you want to load:
•

Enter the name of the GTT file; or, choose the file from the list,
then click OK to load the GTT file.

•

Click Cancel to close the prompt window without loading a
GTT file.

See Loading an Existing GTT File, page 15-29.
File > Load > Load From Node
(Ctrl-T)

Opens the Load GTT from Node wizard, which you use to choose
the node and signaling point whose GTT file you want to edit (see
Loading a GTT File from a Node, page 15-30).
If you implement MWTM User-Based Access, this option is
available to users with authentication level Network Operator (level
3) and higher.

File > Revert
(Ctrl-R)

Reverts to the last saved version of the GTT file.
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Menu Command

Description

File > Save
(Ctrl-S)

Saves the changes you made to the GTT file.

File > Save As

Opens the Save File dialog box: GTT File List, which you use to
save the GTT file with a new name or overwrite an existing GTT
file.

File > Semantic Check
(Ctrl-K)

Opens the Semantic Check GTT dialog box, which you use to check
the semantics of a GTT file against a specific ITP.

File > Deploy
(Ctrl-Y)

Opens the Deployment wizard, which you use to validate a GTT
file, upload it to an ITP, and activate it on the ITP.

File > Exit
(Ctrl-Q)

Closes the GTT Editor window. If you make any changes to the GTT
file, the MWTM asks if you want to save the changes before leaving
the window. Click:
•

Yes to save the changes.
The MWTM opens the Save File dialog box: GTT File List,
which you use to save the GTT file with a new name, or
overwrite an existing GTT file.

•

No to close the prompt window.
The MWTM closes the GTT Editor window without saving any
changes to the GTT file.

Edit > Version and Instance
(Ctrl-I)

Opens the Edit GTT Table dialog box, which you use to change the
variant, version, and instance number of a GTT file.

Edit > Add
(Ctrl-E)

Opens the Add dialog box for the chosen table.

Edit > Delete
(Ctrl-Delete)

Deletes one or more chosen rows from a GTT table. The Confirm
Delete dialog box appears, in which you confirm the deletion. To:

For example, if you click the Selector Table, opens the Selector Add
dialog box.

•

Delete the chosen rows, click Yes. The rows disappear from the
table and the Confirm Delete dialog box closes.

•

Retain the chosen rows, click No. The rows remain in the table
and the Confirm Delete dialog box closes.

You can select more than one row to delete; but, all chosen rows
must reside in the same table. For example, you cannot
simultaneously delete rows from the Selector Table and the MAP
(mated application) Table.
If deleting a row from a table causes one or more rows in the table
to remain at the top of the page or the bottom of the next, such that
no remaining entries reference the single rows, the MWTM shows
the number of single rows and asks whether you also want to delete
the single rows. (The MWTM shows the number of rows and not the
rows themselves; because, a document could contain thousands of
single rows.)
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Menu Command

Description

Edit > Node Archive
Management

Opens the Archive Management dialog box, which you use to
manage archived GTT, route table, and MLR address table files.
If you have implemented MWTM User-Based Access, this option is
available to users with authentication level Network Administrator
(level 4) and higher.

Edit > Node File Management

Opens the Node File Management dialog box, which you use to
manage GTT files and route table files.
If you implement MWTM User-Based Access, this option is
available to users with authentication level Network Administrator
(level 4) and higher.

View > Phone Number Config
(Ctrl-P)

Opens the Phone Number Lookup dialog box in which you search
the GTA Table for the Global Title Address Digits for a specific
selector.

View > GTT Table Info
(Ctrl-G)

Opens the GTT Table Info dialog box, which shows basic
information about the currently visible GTT file.

View > Network Name
Configuration
(Ctrl-F)

Opens the Network Name Configuration dialog box, which maps
network names to variants and network indicators, in support of
cross-instance GTT files.

Help > Topics
(F1)

Shows the table of contents for the MWTM online help.

Help > Window
(Shift-F1)

Shows online help for the current window.

Help > About
(F3)

Shows build date, version, SSL support, and copyright information
about the MWTM application.

GTT Editor: Selectors and GTA Tab
Click the Selectors and GTA tab to display data for a specific GTT selector and see the GTA entries for
that selector.
A GTT selector defines the parameters that select the translation table that the MWTM uses to translate
an SCCP message to its next or final destination.
A Global Title Address (GTA) entry is associated with a selector and defines the result of a translation
for a particular address mask. The result of a GTA entry can be a final translation or an intermediate
translation.
The GTT Editor: Selectors and GTA tab contains:
•

Selector Table, page 15-6

•

GTA Table, page 15-7

•

App Group Table, page 15-8

•

MAP Table, page 15-9

•

CPC List, page 15-9
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When you click the GTT Editor: Selectors and GTA tab, the MWTM might populate the Selector Table
and the other tables with data. To populate the:
•

Selector Table, right-click in the table and choose Add. See Adding a Selector to a Selector Table,
page 15-16.

•

GTA Table, select a row in the Selector Table. The MWTM populates the GTA Table with all
associated GTA entries.
If the GTA Table remains blank, the chosen row has no associated GTA entries. You can also add
entries to the GTA Table, by right-clicking in the table and choosing Add from the right-click menu
(see Adding a GTA Entry to a GTT, page 15-17).

•

App Group Table, select a row in the GTA Table that has an associated Application Group. The
MWTM populates the App Group Table with all application group entries for that application group
name.
You can also add entries to the App Group Table, by right-clicking in the table and choosing Add
from the right-click menu (see Adding an Application Group Entry to an App Group Table,
page 15-21).

•

MAP Table, select a row in the GTA Table that does not have an associated Application Group. The
MWTM populates the MAP Table with all MAP entries that match the chosen row's point code-SSN
combination.
To add entries to the MAP Table, right-click in the table and choose Add from the right-click menu
(see Adding a MAP Entry to a GTT, page 15-22).

•

CPC List, select a row in the MAP Table that has an associated CPC List Name. The MWTM
populates the CPC List with all point codes in that CPC list.
To add entries to the CPC List, right-click in the list and choose Add from the right-click menu (see
Adding a CPC List to a GTT, page 15-23).

Selector Table
The Selector Table contains:
Column

Description

Name

Name of the selector.

Translation Type

Translation type that the selector uses. Valid values are in the range
0 through 255.

Global Title Indicator

(China, ITU, NTT, and TTC only) Global title indicator for the selector.
Valid values are in the range 2 and 4.

Numbering Plan

(China, ITU, NTT, and TTC only) Numbering plan for the selector.
Valid values are in the range 0 through 15.

Nature of Address Indicator (China, ITU, NTT, and TTC only) Nature of address indicator for the
selector. Valid values are in the range 0 through 127.
Pre-Address Conversion

GTT address conversion table to apply prior to performing local GTT
translation. If:
•

This field contains an address conversion table name, the referenced
table must exist and contain at least one address-conversion entry.

•

This field is blank, no address conversion is necessary.
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Column

Description

Post-Address Conversion

GTT address conversion table to apply after performing local GTT
translation. If:
•

This field contains an address conversion table name, the referenced
table must exist and contain at least one address conversion entry.

•

This field is blank, no address conversion is necessary.

QoS

Quality of service (QoS) class of the selector. Valid QoS classes range
from 1 through 7. ALL indicates that the selector accepts all QoS
classes.

Next Table

(This column appears only for the GTT file with version 4.6) MWTM
supports the Next Table option within an instance/signaling point.

GTA Table
The GTA Table contains:
Column

Description

Name

Selector name for this GTA.

Global Title Address Digits

Address digits for the GTA.

Point Code

Destination point code for the GTA.

Routing Indicator

Routing indicator for the GTA. Valid values are:
•

none—No routing indicator.

•

gt—Route on the global title.

•

pcssn—Route on the point code and SSN.

This field is dimmed if you check Configure By App Group (see Adding
a GTA Entry to a GTT, page 15-17).
Subsystem Number

Destination SSN for the GTA. Valid values are in the range
2 through 255.

New Translation Type

Translation type that the GTA uses. Valid values are in the range
0 through 255.

Application Group

Name of the application group that should provide the point code,
routing indicator, and SSN that the GTA uses.

Application Server Name

Name of the application server that should provide the point code,
routing indicator, and SSN that the GTA uses.

QoS

Quality of service (QoS) class of the GTA. Valid QoS classes range from
1 through 7. ALL indicates that the GTA accepts all QoS classes.
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App Group Table
The App Group Table contains:
Column

Description

Name

Name of the application group.
For ITPs with multiple instances enabled, do not use the same application
group name in two or more different instances. For example, if you use
application group name appgrp1 in instance 1, then do not use appgrp1 in
instance 0, or any other instance.

Multiplicity

Weight Factor or Cost

Multiplicity setting for the application group. Valid values are:
•

cgp—Use SCCP calling party address (CGPA) load sharing, if
available. CGPA load sharing uses a weighting factor to choose the
destination. This is applicable to GTT versions 4.0 and higher.

•

cos—Use the destination with the least cost, if available.

•

sha—Share equally among all destinations.

•

wrr—Weighted balancing sccp class 0 and class 1 traffic based on
weighed factor. This is applicable to GTT versions 4.5 and higher.

If you set multiplicity to cgp, this field specifies the relative weighting
factor of the application group. Choose a relative cost, 1 through 999,
from the drop-down list box. The default value is 1.
If you set multiplicity to cos or sha, this field specifies the relative cost of
the application group. Choose a relative cost, 1 through 8, from the
drop-down list box. The default value is 1.
If you set multiplicity to wrr, this field specifies the relative cost of the
application group. Choose a relative cost, 1 through 10, from the
drop-down list box. The default value is 1.
For file format 4.4, the cost range is from 1 through 64.

Point Code

Destination point code for the application group.

Routing Indicator

Routing indicator for the application group. Valid values are:
•

none—No routing indicator.

•

gt—Route on the global title. This is the default routing indicator.

•

pcssn—Route on the point code and SSN.

Subsystem Number

Destination SSN for the application group. Valid values are in the range
2 through 255.

Application Server Name

Name of the application server.

Network Name

Network name that the application group uses.

New Translation Type

(Available in version 4.4 and later) Translation type that the selector uses.
Valid values are in the range 0 through 255.

Rate Limit

(Available in version 4.5 and later) Traffic rate limitation (MSU/sec) for the
associated PC/SSN or AS directing over-flow traffic to the higher cost
DPC/ASNAME. Rate-limit is only valid for multiplicity cost mode.
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MAP Table
The MAP Table contains:
Column

Description

Primary Pt. Code

Primary point code for the MAP.

Primary SSN

Primary SSN for the MAP. Valid values are in the range 2 through 255.

Multiplicity

Multiplicity setting for the MAP. Valid values are:
•

dom—Dominant. Always translate to the primary point-code-SSN
combination if it is available. Translate to the backup point code-SSN
combination only if the primary combination is not available.

•

sha—Share equally between the primary point-code-SSN combination
and the backup point-code-SSN combination.

•

sol—Solitary MAP. No alternate if the point code or SSN is not
available.

Backup Pt. Code

Backup point code for the MAP.

Backup SSN

Backup SSN for the MAP. Valid values are in the range 2 through 255.

Re-route if Congested

Indicates whether to route the MAP to the backup point-code-SSN
combination if the primary combination is congested. If you:

Adjacency

•

Check the check box, you route the MAP to the backup combination
when the primary combination is congested.

•

Uncheck the check box, you do not route the MAP to the backup.

Indicates whether to consider a point-code-SSN combination adjacent to the
local node for SCCP management. If you:

CPC List Name

•

Check the check box, you do consider the point code-SSN combination
adjacent to the local node.

•

Uncheck the check box, you do not consider the point code-SSN
combination adjacent to the local node.

Name of the CPC list associated with this MAP.

CPC List
The CPC List contains:
Field

Description

Point Code

Point codes in the chosen CPC list.

GTT Editor: App Group Tab
Click the App Group tab to display data for application groups. The App Group tab shows the same
information as the Selectors and GTA tab; but, from the perspective of the application groups.
An application group is an alternative result for the explicit point code and SSN in a GTA entry. You can
use an application group entry for:
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•

Intermediate translation.

•

Load-sharing across more than two destinations.

•

Load-sharing of intermediate translation.

The GTT Editor: App Group tab contains:
•

App Group Table, page 15-8

•

MAP Table, page 15-9

•

CPC List, page 15-9

•

Selector Table, page 15-6

•

GTA Table, page 15-7

When you click the GTT Editor: App Group tab, the App Group Table and Selector Table might
contain data. To:
•

Add entries to the App Group Table, right-click in the table and choose Add from the right-click
menu (see Adding an Application Group Entry to an App Group Table, page 15-21).

•

Add entries to the Selector Table, right-click in the table and choose Add from the right-click menu
(see Adding a Selector to a Selector Table, page 15-16).

•

Populate the MAP Table, select a row in the App Group Table. The MAP Table contains all MAP
entries that match the chosen row's point code-SSN combination.
You can also add entries to the MAP Table, by right-clicking in the table and choosing Add from
the right-click menu (see Adding a MAP Entry to a GTT, page 15-22).

•

Populate the CPC List, select a row in the MAP Table that has an associated CPC List Name. The
CPC List contains all point codes in that CPC list.
You can also add entries to the CPC List, by right-clicking in the list and choosing Add from the
right-click menu (see Editing an ITP Global Title Translation Table, page 15-1).

•

Populate the GTA Table, select a row in the Selector Table. The GTA Table contains all associated
GTA entries.
If the GTA Table remains blank, the chosen row has no associated GTA entries. You can also add
entries to the GTA Table, by right-clicking in the table and choosing Add from the right-click menu
(see Editing an ITP Global Title Translation Table, page 15-1).
You can also add entries to the Selector Table, by right-clicking in the list and choosing Add from
the right-click menu (see Adding a Selector to a Selector Table, page 15-16).

GTT Editor: MAPs Tab
Click the MAPs tab if you are primarily interested in displaying data for MAPs. The MAPs tab shows
the same information as the Selectors and GTA tab, but from the perspective of the MAPs.
A mated application (MAP) entry has two uses:
•

The SCCP application uses MAP entries internally to track point code states and SSN states, such
as congestion and availability.

•

To define backups or alternates for point code-SSN combination.

The GTT Editor: Maps tab contains:
•

MAP Table, page 15-9

•

CPC List, page 15-9
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•

Selector Table, page 15-6

•

GTA Table, page 15-7

•

App Group Table, page 15-8

When you launch the GTT Editor: MAPs tab, the MAP Table and Selector Table might or might not be
populated with data. To:
•

Add entries to the MAP Table, right-click in the table and choose Add from the right-click menu
(see Adding a MAP Entry to a GTT, page 15-22).

•

Add entries to the Selector Table, right-click in the table and choose Add from the right-click menu
(see Adding a Selector to a Selector Table, page 15-16).

•

Populate the CPC List, select a row in the MAP Table that has an associated CPC List Name. The
CPC List contains all point codes in that CPC list.
You can also add entries to the CPC List, by right-clicking in the list and choosing Add from the
right-click menu (see Editing an ITP Global Title Translation Table, page 15-1).

•

Populate the App Group Table and GTA Table, select a row in the MAP Table. The App Group Table
and GTA Table contain all application group and GTA entries that match the chosen row's point
code-SSN combination.
If the App Group Table or GTA Table remains blank, the chosen row has no associated application
group or GTA entries.
You can add entries to the App Group Table, by right-clicking in the table and choosing Add from
the right-click menu (see Adding an Application Group Entry to an App Group Table, page 15-21).
You can add entries to the GTA Table, by right-clicking in the table and choosing Add from the
right-click menu (see Editing an ITP Global Title Translation Table, page 15-1).

GTT Editor: CPC Tab
A concerned point code (CPC) is a node that should be notified when the status of the associated SSN
changes.
Click the CPC tab if you are primarily interested in displaying data for concerned point code names. The
CPC tab appears.
The GTT Editor: CPC tab contains:
•

Concerned Pt. Code Name List, page 15-12

•

CPC List, page 15-9

•

MAP Table, page 15-9

When you launch the GTT Editor: CPC tab, the Concerned Pt. Code Name List contains data. To
populate the CPC List and MAP Table, select a row in the Concerned Pt. Code Name List. The CPC List
and MAP Table contain all point codes and MAP entries that match that concerned point code name.
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Concerned Pt. Code Name List
The Concerned Pt. Code Name List contains:
Field

Description

CPC List Name

Name of the CPC list to add. Enter an alphanumeric string between 1
and 12 characters.

CPC List

List of point codes associated with the entered CPC list name.

To copy one or more point codes from one CPC list to another, select a CPC list in the CPC List Name
column. The MWTM shows the point codes that are associated with that CPC list in the Point Code
column. Select one or more of the point codes and drag them to the new CPC list.

Note

The MWTM copies the point codes to the new CPC list; it does not move them from the old CPC list. If
you want to move the point codes, you must copy them to the new CPC list, then delete them from the
old CPC list.

GTT Editor: Address Conversion Tab
You use GTT address conversion tables to specify mappings such as E.212-to-E.214 address conversion
and E.212-to-E.164 address conversion in ITU networks.
Click the Address Conversion tab to display GTT address conversion tables. The Address Conversion
tab appears.
The GTT Editor: Address Conversion tab contains:
•

Address Conversion Table, page 15-12

•

Conversion Entry Table, page 15-13

•

Selector Table for Address Conversion, page 15-14

Address Conversion Table
The Address Conversion Table contains:
Field

Description

Name

Name of the GTT address conversion table. Enter a 1- to
12-character name.
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Field

Description

Numbering Plan

(China, ITU, NTT, and TTC only) Numbering plan associated with
the address conversion table. For all addresses that are converted,
the numbering plan is converted to the value of this field.
The valid range is 0 to 15.

Nature of Address Indicator

(China, ITU, NTT, and TTC only) Nature of address indicator
associated with the address conversion table. For all addresses that
are converted, the nature of address indicator is converted to the
value of this field.
The valid range is 0 to 127.

Conversion Entry Table
The Conversion Entry Table contains:
Field

Description

In Address

Input SCCP address entry. Enter an address as a 1- to 15-digit
hexadecimal string.

Out Address

Output SCCP address entry. Enter an address as a 1- to 15-digit
hexadecimal string.

Numbering Plan

(China, ITU, NTT, and TTC only) Numbering plan associated with
this entry in the address conversion table. If specified, the value of
this field overrides the value of the Numbering Plan field in the
Address Conversion Table for this entry.
The valid range is 0 to 15.

Nature of Address Indicator

(China, ITU, NTT, and TTC only) Nature of address indicator
associated with this entry in the address conversion table. If
specified, the value of this field overrides the value of the Nature of
Address Indicator field in the Address Conversion Table for this
entry.
The valid range is 0 to 127.

Encoding Scheme

Remove Digits

The encoding scheme to be used for output GTT address:
•

Unknown—Encoding scheme is not specified at the address
level

•

bcdOdd—Use BCD odd encoding scheme

•

bcdEven—Use BCD even encoding scheme

•

National—National specific

Specifies the number of digits that should be removed from the
original address prefix when the in-address prefix is matched
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Selector Table for Address Conversion
The Selector Table for Address Conversion contains:
Column

Description

Name

Name of the selector.

Translation Type

Translation type that the selector uses. Valid values are in the range
0 through 255.

Global Title Indicator

(China, ITU, NTT, and TTC only) Global title indicator for the selector.
Valid values are in the range 2 and 4.

Numbering Plan

(China, ITU, NTT, and TTC only) Numbering plan for the selector.
Valid values are in the range 0 through 15.

Nature of Address Indicator (China, ITU, NTT, and TTC only) Nature of address indicator for the
selector. Valid values are in the range 0 through 127.
Pre-Address Conversion

GTT address conversion table to apply prior to performing local GTT
translation.
If this field contains an address conversion table name, the referenced
table must exist and it must contain at least one address-conversion
entry.
If this field is blank, no address conversion is necessary.

Post-Address Conversion

GTT address conversion table to apply after performing local GTT
translation.
If this field contains an address-conversion table name, the referenced
table must exist and it must contain at least one address conversion entry.
If this field is blank, no address conversion is necessary.

QoS

Quality of service (QoS) class of the selector. Valid QoS classes range
from 1 through 7. ALL indicates that the selector accepts all QoS
classes.

Next Table

(This column appears only for the GTT file with version 4.6) MWTM
supports the Next Table option within an instance/signaling point.
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Editing a GTT Table
You use the MWTM to change the variant and instance number associated with a GTT file.
To change the variant and instance number associated with a GTT file choose Edit > Version and
Instance from the GTT menu. The Edit GTT Table dialog box appears.
Field or Button

Description

Variant

SS7 protocol variant. You cannot edit this field.

Version

Version of the file format that the GTT uses. Valid versions are:
•

3.1—Corresponds to ITP software releases 12.2(4)MB9 and 12.2(4)MB9a.
Two or more entries in the same application group can have the same cost. This
version is the default in the MWTM.

•

4.0—Corresponds to ITP software release 12.2(4)MB10 or higher. Supports
multiple instances on a single node.

•

4.1—Corresponds to ITP software release 12.2(20)SW or higher. Supports
multiple instances on a single node.

•

4.2—Corresponds to ITP software release 12.2(21)SW1 or higher. Supports
subsystem numbers equal to zero (0) for GTA entries and application group
entries.

•

4.3—Corresponds to these ITP software releases:
– 12.2(25)SW1 or higher
– 12.2(18)IXA or higher
– 12.4(11)SW or higher

Supports latest encoding scheme (not for ANSI).
•

4.4—Corresponds to these ITP software releases:
– 12.2(18)IXE or higher
– 12.4(15)SW or higher

Supports higher destination cost and removing digits.
•

4.5—Corresponds to these ITP software releases:
– 12.2(33)IRD or higher
– 12.4(15)SW4 or higher

•

4.6—Corresponds to these ITP software releases:
– 12.2(33) IRE or higher
– 12.4(15) SW5 or higher

The MWTM 6.1.6 supports GTT files with file format versions 3.1, 4.0, 4.1, 4.2,
4.3, 4.4, 4.5, or 4.6. You can load GTT files that use lower or higher file format
versions; but, fields or features that are unique to the lower or higher version are
not visible and they disappear from the GTT file the next time you save. The
MWTM automatically saves the file as a version 3.1 file if the file is lower than
version 3.1; or, as a version 4.6 file if the file is higher than version 4.6.
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Field or Button

Description

Instance Number Number of the instance that the GTT uses. Valid IDs are 0 to 7. The default instance
number is 0.
This list box is available only if you choose version 4.0.
Network Name

Network name that the GTT uses.
If you change the network name for an existing GTT file, the new network name
must use the same variant.
This field is available only if you choose version 4.1 or higher.

OK

Saves the changes to the GTT file.
Enter or choose values for the new variant and instance number, then click OK. The
MWTM saves your changes to the GTT file.

Cancel

Closes the Edit GTT Table dialog box without saving any changes to the GTT file.
To close the Edit GTT Table dialog box at any time without saving any changes to
the GTT file, click Cancel.

Help

Shows online help for the current window.

Adding a Selector to a Selector Table
You use the MWTM to add a selector to a GTT. A GTT selector defines the parameters that select the
translation table used to translate an SCCP message to its next or final destination.
To add a new selector to a Selector Table, choose a Selector Table in the GTT Editor window, then use
one of these procedures. From the:
•

GTT menu, choose Edit > Add.

•

Right-click menu, choose Add.

The Selector Add dialog box appears.
Field or Button

Description

Selector Name

Name of the selector to add. Enter 1- to 12-character alphanumeric string.

Translation Type

Translation type that the selector uses. Enter a value in the range
0 through 255.

Global Title Indicator

(China, ITU, NTT, and TTC only) Global title indicator for the selector.
Choose a value from the drop-down list box. Valid values are:
•

2

•

4

The default value is 4.
Numbering Plan

(China, ITU, NTT, and TTC only) Numbering plan for the selector. Enter
a value in the range 0 through 15.
This field is dimmed if Global Title Indicator is set to 2.
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Field or Button

Description

Nature of Addr. Indicator

(China, ITU, NTT, and TTC only) Nature of address indicator for the
selector. Enter a value in the range 0 through 127.
This field is dimmed if Global Title Indicator is set to 2.

Pre-Conversion Table
Name

GTT address conversion table to apply prior to performing local GTT
translation.
If this field contains an address conversion table name, the referenced
table must exist and it must contain at least one address conversion entry.
If this field is blank, no address conversion is necessary.

Post-Conversion Table
Name

GTT address conversion table to apply after performing local GTT
translation.
If this field contains an address conversion table name, the referenced
table must exist and it must contain at least one address conversion entry.
If this field is blank, no address conversion is necessary.

QoS

Quality of service (QoS) class of the selector. Choose a value from the
drop-down list box. Valid QoS classes range from 1 through 7. Choose
ALL if you want the selector to accept all QoS classes. The default value
is ALL.

Next Table

(This column appears only for the GTT file with version 4.6) MWTM
supports the Next Table option within an instance/signaling point.

Add

Adds the selector to the GTT.
Enter or choose values for the new selector, then click Add. The MWTM
adds the selector to the Selector Table.

Close

Closes the Selector Add dialog box.
When you finish adding selectors, click Close.

Help

Shows online help for the current window.

Related Topic:

Editing an ITP Global Title Translation Table, page 15-1.

Adding a GTA Entry to a GTT
You use the MWTM to add a Global Title Address (GTA) entry to a GTT. A GTA entry is associated
with a selector and defines the result of a translation for a particular address mask. The result of a GTA
entry can be a final translation or an intermediate translation.
To add a new GTA entry to a GTA Table, choose a selector in the GTT Editor window and a GTA Table;
then, use one of these procedures.
From the:
•

GTT menu, choose Edit > Add.

•

Right-click menu, choose Add.

The GTA Add dialog box appears.
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Field

Description

Selector Name

Name of the selector associated with this GTA. You cannot edit this
field.

Global Title Addr. Digits

Address digits for the GTA. Enter a 1- to 15-digit hexadecimal string.
Enter ‘default’ to create a default GTA.

QoS

Quality of service (QoS) class of the GTA. Choose a value from the
drop-down list box. Valid QoS classes range from 1 through 7. Choose
ALL if you want the GTA to accept all QoS classes. The default value
is ALL.

Configure By Point Code

Indicates whether to configure the GTA by point code. To configure the
GTA by point code, click this radio button.
The MWTM makes the Config By Point Code fields available, and dims
the Config By App Group fields. This is the default setting.

Configure By App Group

Indicates whether to configure the GTA by application group. To
configure the GTA by application group, click this radio button.
The MWTM makes the Config By App Group fields available and, dims
the Config By Point Code fields.

Configure By Application
Server Name

Indicates whether to configure the GTA by application server name. To
configure the GTA by application server name, click this radio button.
The MWTM replaces the Config By Point Code fields with the Config
By Application Server name fields, and dims the Config By App Group
fields.

Point Code

Destination point code for the GTA. Enter a point code.
This field is available only if you choose Configure By Point Code.

Routing Indicator

Routing indicator for the GTA. Choose a value from the drop-down list
box. Valid values are:
•

gt—Route on the global title. This is the default routing indicator.

•

pcssn—Route on the point code and SSN.

This field is available only if you chose Configure By Point Code or
Configure By Application Server Name.
Subsystem Number

Destination SSN for the GTA. Enter a value in the range 2 through 255.
This field is mutually exclusive with the New Translation Type field.
This field is available only if you chose Configure By Point Code or
Configure By Application Server Name.

New Translation Type

Translation type that the GTA uses. Enter a value in the range
0 through 255.
This field is mutually exclusive with the Subsystem Number field.
This field is available only if you chose Configure By Point Code or
Configure By Application Server Name.

User Guide for the Cisco Mobile Wireless Transport Manager 6.1.6

15-18

OL-24032-01

Chapter 15

Editing an ITP Global Title Translation Table
Searching the GTA Table for GTA Digits

Field

Description

App. Group

Name of the application group that should provide the point code,
routing indicator, and SSN that the GTA uses. Enter the name of an
application group.
This field is available only if Configure By App Group is checked (see
Adding a GTA Entry to a GTT, page 15-17).

Application Server Name

Name of the application server that should provide the point code,
routing indicator, and SSN that the GTA uses. Enter the name of an
application server.
This field is available only if you chose Configure By Application
Server Name.

Add

Adds the GTA to the GTT.
Enter or choose values for the new GTA entry, then click Add. The
MWTM adds the GTA entry to the GTA Table.

Close

Closes the GTA Add dialog box.
When you finish adding GTA entries, click Close to close the GTA Add
dialog box.

Help

Shows online help for the current window.

Related Topic:

Editing an ITP Global Title Translation Table, page 15-1.

Searching the GTA Table for GTA Digits
You use the MWTM to search the GTA Table for the Global Title Address Digits for a specific selector.
The MWTM shows the entries that contain the GTA digits in the GTA Table.
To search the GTA Table, click the Selectors and GTA tab in the GTT Editor window, then choose
View > Phone Number Config from the GTT menu. The Phone Number Lookup dialog box appears.
Table, Field, or
Button
Selector Table

Description
Selector Table associated with the GTA Table to search. Choose one or more
Selector Tables.
For descriptions of the fields in this table, see Selector Table, page 15-6.

Phone Number

GTA digits to search for in the GTA Table.
Choose a Selector Table and enter a telephone number or prefix as a 1- to 15-digit
hexadecimal string with no spaces, dashes, or other special characters.
For example, to search for a specific telephone number, such as 919-555-6384,
enter 9195556384. To search for all entries that begin with the 919-555 telephone
prefix, enter 919555.
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Table, Field, or
Button

Description

Perform Lookup

Launches the search for the GTA digits. If:
•

It finds one or more matching entries, shows the entries that contain the GTA
digits in the GTA Table.

•

The Selector Table being searched performs pre-address conversion, the
converted address, numbering plan, and nature of address indicator are
visible in the Pre-Address Conversion Results field.

•

The Selector Table being searched performs post-address conversion, the
converted address, numbering plan, and nature of address indicator are
visible in the Post-Address Conversion Results field.

•

It does not find matching entries or the Selector Table has no associated GTA
Table, an error message appears at the bottom of the window:
Could not find GTA for selector and phone number

Pre-Address
Conversion Entry
Used

Entry in the GTT address conversion table used for pre-address conversion, if the
Selector Table being searched performs pre-address conversion.
For China, ITU, NTT, and TTC variants, pre-address conversion might result in
a numbering plan or nature of address indicator that is different from the chosen
Selector Table. If this occurs, the MWTM searches for a selector in the Selector
Table that matches the new numbering plan and nature of address indicator. If the
MWTM:
•

Finds a matching selector, it uses that selector to complete the search.

•

Does not find a matching selector, the search fails.

Pre-Address
Results of the pre-address conversion (converted address, numbering plan, and
Conversion Results nature of address indicator), if the Selector Table being searched performs
pre-address conversion.
Selector Entry Used Selector Entry that was searched.
For descriptions of the fields in this table, see Selector Table, page 15-6.
GTA Entry Found

GTA Table in which the GTA digits reside.
For descriptions of the fields in this table, see GTA Table, page 15-7.

MAP Table

MAP Table, if any, associated with the GTA Table in which the GTA digits were
found.
For descriptions of the fields in this table, see MAP Table, page 15-9.

CPC List

CPC List, if any, associated with the GTA Table in which the GTA digits reside.
For descriptions of the fields in this list, see CPC List, page 15-9.

Post-Address
Conversion Entry
Used

Entry in the GTT address conversion table used for post-address conversion, if
the Selector Table being searched performs post-address conversion.

Post-Address
Results of the post-address conversion (converted address, numbering plan, and
Conversion Results nature of address indicator), if the Selector Table being searched performs
post-address conversion.
Related Topic:

Launching the GTT Editor, page 15-2.
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Adding an Application Group Entry to an App Group Table
You use the MWTM to add an application group to a GTT. An application group is an alternative result
for the explicit point code and SSN in a GTA entry. You can use an application group entry for:
•

Intermediate translation.

•

Load-sharing across more than two destinations.

•

Load-sharing of intermediate translation.

To add an application group to a GTT, choose an App Group Table in the GTT Editor window, then use
one of these procedures.
From the:
•

GTT menu, choose Edit > Add.

•

Right-click menu, choose Add.

The App Group Add dialog box appears.
Field or Button

Description

App. Group

Name of the application group to add. Enter 1- to 12-character
alphanumeric string.

Multiplicity

Multiplicity setting for the application group. Choose a value from the
drop-down list box. Valid values are:

Weight Factor or Cost

•

cos—Use the destination with the least cost, if available.

•

sha—Share equally between all destinations. This is the default value.

•

wrr—Weighted balancing sccp class 0 and class 1 traffic based on
weighed factor. This is applicable to GTT versions 4.5 and higher.

If Multiplicity is set to cgp, this field specifies the relative weighting factor
of the application group. Choose a relative cost, 1 through 999, from the
drop-down list box. The default value is 1.
If Multiplicity is set to cos or sha, this field specifies the relative cost of
the application group. Choose a relative cost, 1 through 8, from the
drop-down list box. The default value is 1.
If Multiplicity is set to wrr, this field specifies the relative cost of the
application group. Choose a relative cost, 1 through 10, from the
drop-down list box. The default value is 1.

Configure By Pt Code or
AS Name: Point Code

Destination point code for the application group. Click this radio button
and enter a point code. This field is mutually exclusive with the
Application Server Name field.

Configure By Pt Code or
AS Name: Application
Server Name

Name of the application server. Click this radio button and enter an
application server name. This field is mutually exclusive with the Point
Code field.

Routing Indicator

Routing indicator for the application group. Choose a value from the
drop-down list box.

Network Name

Network name that the application group uses. Choose a network name
from the drop-down list box.
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Field or Button

Description

Subsystem Number

Destination SSN for the application group. Enter a value in the range
2 through 255.

New Translation Type

(Available in version 4.4 and later) Translation type that the selector uses.
Valid values are in the range 0 through 255.

Rate Limit

(Available in version 4.5 and later) Traffic rate limitation (MSU/sec) for the
associated PC/SSN or AS directing over-flow traffic to the higher cost
DPC/ASNAME. Rate-limit is only valid for multiplicity cost mode.

Add

Adds the application group to the GTT.
Enter or choose values for the new application group entry, then click Add.
The MWTM adds the application group entry to the App Group Table.

Close

Closes the App Group Add dialog box.
When you finish adding application group entries, click Close to close the
App Group Add dialog box.

Help

Shows online help for the current window.

Related Topic:

Editing an ITP Global Title Translation Table, page 15-1.

Adding a MAP Entry to a GTT
You use the MWTM to add a mated application (MAP) entry to a GTT.
A MAP entry has two purposes:
•

The SCCP application uses them internally to track point-code states and SSN states, such as
congestion and availability.

•

To define backups or alternates for point-code-SSN combination.

To add a MAP entry, choose a MAP Table in the GTT Editor window, then use one of these procedures.
From the:
•

GTT menu, choose Edit > Add.

•

Right-click menu, choose Add.

(Optional) To add a new MAP entry to a MAP Table, choose a MAP Table, then use one of these
procedures.
From the:
•

GTT menu, choose Edit > Add.

•

Right-click menu, choose Add.

The MAP Add dialog box appears.
Field or Button

Description

Primary Pt. Code

Primary point code for the MAP. Enter a point code.

Primary SSN

Primary SSN for the MAP. Enter a value in the range 2 through 255.
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Field or Button

Description

Multiplicity

Multiplicity setting for the MAP. Choose a value from the drop-down list
box. Valid values are:
•

dom—Dominant. Always translate to the primary point-code-SSN
combination if it is available. Translate to the backup point-code-SSN
combination only if the primary combination is not available.

•

sha—Share equally between the primary point-code-SSN combination
and the backup point code-SSN combination. This is the default value.

•

sol—Solitary MAP. No alternate if the point code or SSN is not
available.

Backup Pt. Code

Backup point code for the MAP. Enter a point code.

Backup SSN

Backup SSN for the MAP. Enter an a value in the range 2 through 255.

CPC List Name

Name of the CPC list to be associated with this MAP. Enter a CPC list name.

Re-route if Congested

Indicates whether the MAP should be routed to the backup point code-SSN
combination if the primary combination is congested. If you:

Adjacency

Add

•

Want to route the MAP to the backup combination when the primary
combination is congested, check the check box.

•

Do not want to route the MAP to the backup, uncheck the check box.
This is the default setting.

Indicates whether a point code-SSN combination should be considered
adjacent to the local node for SCCP management. If you:
•

Want the point code-SSN combination be considered adjacent to the
local node, check the check box.

•

Do not want the point code-SSN combination be considered adjacent to
the local node, uncheck the check box. This is the default setting.

Adds the MAP to the GTT.
Enter or choose values for the new MAP entry, then click Add. The MWTM
adds the MAP entry to the MAP Table.

Close

Closes the MAP Add dialog box.
When you finish adding MAP entries, click Close to close the MAP Add
dialog box.

Help

Shows online help for the current window.

Related Topic:

Editing an ITP Global Title Translation Table, page 15-1.

Adding a CPC List to a GTT
You use the MWTM to add a new concerned point code (CPC) list to a GTT. A CPC is a node that should
be notified when the status of the associated SSN changes.
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To add a new CPC list, choose a Concerned Pt. Code Name List or a CPC List in the GTT Editor window,
then use one of these procedures. From the:
•

GTT menu, choose Edit > Add.

•

Right-click menu, choose Add.

The CPC Add dialog box appears.
Field or Button

Description

CPC List Name

Name of the CPC list to be added. Enter 1- to 12-character alphanumeric
string.

Concerned Pt. Code List

One or more CPCs to be added to the new CPC list. Enter one or more
CPCs, separated by spaces.

Add

Adds the CPC list to the GTT.
Enter or choose values for the new CPC list, then click Add. The
MWTM adds the CPC list to the MAP Table.

Close

Closes the CPC Add dialog box.
When you finish adding CPC lists, click Close to close the CPC Add
dialog box.

Help

Shows online help for the current window.

Adding a GTT Address Conversion Table
You use the MWTM to add a new address conversion table to a GTT. To do so, choose an Address
Conversion Table in the GTT Editor window, then use one of these procedures. From the:
•

GTT menu, choose Edit > Add.

•

Right-click menu, choose Add.

The Address Conversion Add dialog for a Table window appears.
Field or Button

Description

Name

Name of the GTT address conversion table. Enter a 1- to 12-character name.

Numbering Plan

(China, ITU, NTT, and TTC only) Numbering plan associated with the
address conversion table. For all addresses that are converted, the numbering
plan is converted to the value of this field.
The valid range is 0 to 15.

Nature of Addr.
Indicator

(China, ITU, NTT, and TTC only) Nature of address indicator associated
with the address conversion table. For all addresses that are converted, the
nature of address indicator is converted to the value of this field.
The valid range is 0 to 127.

Add

Adds the address conversion table to the GTT.
Enter or choose values for the new Address Conversion Table, then click
Add. The MWTM adds the Address Conversion Table to the GTT file.

User Guide for the Cisco Mobile Wireless Transport Manager 6.1.6

15-24

OL-24032-01

Chapter 15

Editing an ITP Global Title Translation Table
Adding an Entry to a GTT Conversion Table Entry

Field or Button

Description

Close

Closes the Address Conversion Add dialog box for a table.
When you finish adding Address Conversion Tables, click Close to close the
Address Conversion Add dialog box for a table.

Help

Shows online help for the current window.

Related Topic:

Editing an ITP Global Title Translation Table, page 15-1.

Adding an Entry to a GTT Conversion Table Entry
You use the MWTM to add a new entry to a GTT Conversion Entry Table. To do so, choose a Conversion
Entry Table in the Address Conversion tab of the GTT Editor, then use one of these procedures. From
the:
•

GTT menu, choose Edit > Add.

•

Right-click menu, choose Add.

The Address Conversion Add dialog for an entry window appears.
Field or Button

Description

Name

Name of the GTT address conversion table. Enter a 1- to 12-character name.
If the table name does not already exist, the MWTM creates a new address
conversion table with this name.

Table Numbering Plan

(China, ITU, NTT, and TTC only) Numbering plan associated with the
address conversion table. For all addresses that are converted, the numbering
plan is converted to the value of this field.
The valid range is 0 to 15.

Table Nature of Addr.
Indicator

(China, ITU, NTT, and TTC only) Nature of address indicator associated
with the address conversion table. For all addresses that are converted, the
nature of address indicator is converted to the value of this field.
The valid range is 0 to 127.

In Address

Input SCCP address entry. Enter an address as a 1- to 15-digit hexadecimal
string.

Out Address

Output SCCP address entry. Enter an address as a 1- to 15-digit hexadecimal
string.

Numbering Plan

(China, ITU, NTT, and TTC only) Numbering plan associated with this entry
in the address conversion table. If specified, the value of this field overrides
the value of the Numbering Plan field in the Address Conversion Table, for
this entry.
The valid range is 0 to 15.
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Field or Button

Description

Nature of Address
Indicator

(China, ITU, NTT, and TTC only) Nature of address indicator associated
with this entry in the address conversion table. If specified, the value of this
field overrides the value of the Nature of Address Indicator field in the
Address Conversion Table, for this entry.
The valid range is 0 to 127.

Encoding Scheme

•

Unknown - encoding scheme is not specified at the address level.

•

bcdOdd - Use BCD odd encoding scheme

•

bcdEven - Use BCD even encoding scheme

•

National - national specific

Remove Digits

Specifies the number of digits that should be removed from the original
address prefix when the in-address prefix is matched.

Add

Adds the address conversion table to the GTT.
Enter or choose values for the new entry, then click Add. The MWTM adds
the entry to the Conversion Entry Table.

Close

Closes the Address Conversion Add dialog box for a table.
When you finish adding entries, click Close to close the Address Conversion
Add dialog box for an entry.

Help

Shows online help for the current window.

Related Topic:

Editing an ITP Global Title Translation Table, page 15-1.

Deleting Rows from a Table
To delete one or more rows from a table, select the rows, then choose Edit > Delete from the GTT menu
or Delete from the right-click menu. The Confirm Delete dialog box appears to confirm the deletion. To:
•

Delete the chosen rows, click Yes. The rows are deleted from the table and the Confirm Delete dialog
box closes.

•

Retain the chosen rows, click No. The rows are kept in the table and the Confirm Delete dialog box
closes.

You can select more than one row to delete, but all chosen rows must be in the same table. For example,
you cannot delete rows from both the Selector Table and the MAP Table at the same time.
If deleting a row from a table causes one or more rows in the table to remain at the top of the page or the
bottom of the next, such that no remaining entries reference the single rows, the MWTM shows the
number of single rows and asks whether you want to also delete the single rows. (The MWTM shows the
number of rows and not the rows themselves, because there could be thousands of single rows.)
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Creating a New GTT File
You use the MWTM to create a new GTT file. To do so, choose File > New Table from the GTT menu.
The Create New Table dialog box appears.
Field or Button

Description

Variant

SS7 protocol variant. Choose a variant from the drop-down list box. Valid variants
are:

Version

•

ANSI

•

China

•

ITU

•

NTT

•

TTC

Version of the file format that the GTT uses. Choose a version from the drop-down
list box. Valid versions are:
•

3.1—Corresponds to ITP software releases 12.2(4)MB9 and 12.2(4)MB9a.
Two or more entries in the same application group can have the same cost. This
is the default version in the MWTM.

•

4.0—Corresponds to ITP software release 12.2(4)MB10 or higher. Supports
multiple instances on a single node.

•

4.1—Corresponds to ITP software release 12.2(20)SW or higher. Supports
multiple instances on a single node.
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Field or Button
Version
(continued)

Description
•

4.2—Corresponds to ITP software release 12.2(21)SW1 or higher. Supports
subsystem numbers equal to zero (0) for GTA entries and application group
entries.

•

4.3—Corresponds to these ITP software releases:
– 12.2(25)SW1 or higher
– 12.2(18)IXA or higher
– 12.4(11)SW or higher

Supports latest encoding scheme (not for ANSI).
•

4.4—Corresponds to these ITP software releases:
– 12.2(18)IXE or higher
– 12.4(15)SW or higher

Supports higher destination cost and removing digits.
•

4.5—Corresponds to these ITP software releases:
– 12.2(33)IRD or higher
– 12.4(15)SW4 or higher

•

4.6—Corresponds to these ITP software releases:
– 12.2(33) IRE or higher
– 12.4(15) SW5 or higher

The MWTM 6.1.6 supports GTT files with file format versions 3.1, 4.0, 4.1, 4.2,
4.3, 4.4, 4.5, or 4.6. You can load GTT files that use lower or higher file format
versions; but, fields or features that are unique to the lower or higher version are
not visible and they are removed from the GTT file the next time it is saved. The
file is saved as a version 3.1 file if the file is lower than version 3.1, or as a version
4.6 file if the file is higher than version 4.6.
Instance Number Number of the instance that the GTT uses. Choose an instance number from the
drop-down list box. Valid IDs are 0 to 7. The default instance number is 0.
This list box is available only if you chose version 4.0.
Network Name

Network name that the GTT uses. Choose a network name from the drop-down list
box. When you choose the network name, The MWTM automatically sets the
corresponding variant in the Variant field.
If you change the network name for an existing GTT file, the new network name
must use the same variant.
This list box is available only if you chose version 4.1 or higher.

OK

Creates the new GTT file and closes the Create New Table dialog box.
Choose a variant, version, and instance for the new GTT file, then click OK. The
MWTM creates the new GTT file and closes the Create New Table dialog box.

Cancel

Closes the Create New Table dialog box without creating a new GTT file.

Help

Shows online help for the current window.
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Loading an Existing GTT File
You use the MWTM to load a specific GTT file and change the list of GTT files.
When you load a GTT file, the name of the server associated with the GTT Editor and the filename are
visible in the window name:
MWTM: GTT Editor -- mwtm-sun8 -- GTT.File.1

If you have not yet loaded or saved a GTT file, the MWTM displays a No File Loaded message in place
of the GTT filename.

Note

The MWTM 6.1.6 supports GTT files with file format versions 3.1, 4.0, 4.1, 4.2, 4.3, 4.4, 4.5, or 4.6.
You can load GTT files that use lower or higher file-format versions; but, fields or features that are
unique to the lower or higher version are not visible and they disappear from the GTT file the next time
you save. The file is saved as a version 3.1 file if the file is lower than version 3.1, or as a version 4.6
file if the file is higher than version 4.6.
To load an existing GTT file, or to change the list of GTT files, choose File > Load > Load From File
from the GTT menu. The Load File dialog box: GTT File List appears.
Field or Button

Description

Type

Icon indicating whether the item in the table is a file or a
folder.

Name

Name of the GTT file or folder.

Last Modified

Date and time the GTT file or folder was last modified.

Size (bytes)

Size of the GTT file or folder, in bytes.

Number of Files
(visible in bottom left corner)

Total number of GTT files and folders.

OK

Loads the chosen GTT file, saves any changes you make to
the list of files, closes the Load File dialog box: GTT File
List, opens the Progress dialog box, and begins loading the
GTT file.
To load a GTT file, double-click it in the list; select it in the
list and click OK; or enter the name of the file and click OK.
The MWTM closes the Load File dialog box: GTT File List
and the Progress dialog box appears.
The Progress dialog box shows the progress of the GTT file
load, as well as any messages that appear while loading the
file.
When the file is loaded, click OK. The MWTM closes the
Progress dialog box, loads the GTT file, and returns to the
GTT Configuration window.

Delete

Deletes the chosen file from the GTT file list. The MWTM
issues an informational message containing the name and
location of the deleted file.
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Field or Button

Description

Cancel

Closes the dialog box without loading a GTT file or saving
any changes to the GTT file list.

Help

Shows online help for the dialog box.

Related Topics
•

Launching the GTT Editor, page 15-2

•

Loading a GTT File from a Node, page 15-30

•

Loading a GTT File from the Archive, page 15-31

Loading a GTT File from a Node
You use the Load GTT from Node wizard to choose the node and signaling point whose GTT file you
want to edit.
To launch the Load GTT from Node wizard, choose File > Load > Load From Node from the GTT
menu. Or, from the Startup Options dialog box, choose Load GTT Data From: Node. If you have
implemented MWTM User-Based Access, this option is available to users with authentication level
Network Operator (level 3) and higher.
The Load GTT from Node wizard appears. The left pane of the Load GTT from Node wizard contains:
Step

Description

Select Node/SP

You can choose the signaling point from which to load the GTT file. You can
optionally check the Filter by Node check box, which limits signaling point
selection to a specific node.
Choose a signaling point and node (optional) from the drop-down list boxes. The
MWTM retrieves GTT filenames from the chosen signaling point.
If no GTT filenames are available, the process ends with errors. If GTT filenames
are available, the MWTM proceeds directly to the Login step.

Login

You can log in to the signaling point. Once you have logged in initially, the MWTM
skips this step. Enter the:
•

Log in username and password.

•

Enable username and password.

Note

Load

To avoid entering username and password information each time, you can
set up credentials (see Configuring Login Credentials, page 5-19).

Reads the GTT table from the node and loads it into the GTT Editor.

The bottom line of the Load GTT from Node wizard contains:
Field or Button

Description

Progress Bar

Indicates that the file is being validated or uploaded.

Show Log/Hide Log

Shows or hides the session between the MWTM and the node.
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Field or Button

Description

Next >

Advances to the next step in the wizard.

Finish

Closes the wizard. The Finish button appears when deployment completes
successfully; or, when it detects errors and cancels the process.

Cancel

Closes the wizard without deploying the file.

Help

Shows online help for the wizard.

Related Topics
•

Launching the GTT Editor, page 15-2

•

Loading a GTT File from the Archive, page 15-31

Loading a GTT File from the Archive
You use the Load GTT from Archive wizard to choose the node and signaling point whose archived GTT
file you want to edit.
To launch the Load GTT from Archive wizard, choose File > Load > Load From Archive from the GTT
menu; or, from the Startup Options dialog box, choose Load GTT Data From: Archive. If you
implement MWTM User-Based Access, this option is available to users with authentication level
Network Operator (level 3) and higher.
The Load GTT from Archive wizard appears.
The left pane of the Load GTT from Archive wizard contains:
Step

Description

Select Node/SP

You can choose the signaling point from which to load the GTT file. You can
optionally check the Filter by Node check box, which limits signaling-point
selection to a specific node.
Choose a signaling point and node (optional) from the drop-down list boxes. The
MWTM retrieves GTT filenames from the chosen signaling point.
If no GTT filenames are available, the process ends with errors. If GTT filenames
are available, the MWTM proceeds directly to the Select Version step.

Select Version

Select a previously deployed version of the configuration from the archive.

Load

Checks the archived GTT file for errors and loads the file into the GTT Editor.

The bottom line of the Load GTT from Archive wizard contains:
Field or Button

Description

Progress Bar

Indicates that the file is being validated or uploaded.

Next >

Advances to the next step in the wizard.

Finish

Closes the wizard. The Finish button appears when deployment is
successful; or, it encounters errors and cancels the process.
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Field or Button

Description

Cancel

Closes the wizard without deploying the file.

Help

Shows online help for the wizard.

Displaying the Progress Dialog Box
The Progress dialog box shows the percent of a GTT file that was loaded, saved, or checked semantically,
as well as any messages that appear while loading or checking the file.
To display the Progress dialog box, use one of these procedures.
Choose:
•

File > Load > Load From File or Load From ITP from the GTT menu, then select a GTT file from
the Load File dialog box: GTT File List and click OK.

•

File > Save As from the GTT menu, then select a GTT file from the Load File dialog box: GTT File
List and click OK.

•

File > Semantic Check from the GTT menu, then enter an ITP’s name or IP address in the Semantic
Check GTT dialog box and click OK.

The Progress dialog box appears.
Field or Button

Description

Progress Bar

Indicates the percent of the GTT file that was loaded, saved, or checked.

Messages

Messages that appear while loading, saving, or checking the GTT file.

OK

Closes the Progress dialog box.
This button is dimmed until the MWTM finishes loading, saving, or checking the
GTT file; or, until you click Cancel to stop loading, saving, or checking the file.
When the file is loaded, saved, or checked, click OK. The MWTM closes the
Progress dialog box and returns to the GTT Configuration window.

Cancel

Stops loading, saving, or checking the GTT file.
This button is dimmed when the MWTM finishes loading, saving, or checking the
GTT file; or, if loading, saving, or checking stops.

Help

Shows online help for the current window.

Related Topics
•

Checking the Semantics of a GTT File, page 15-33

•

Launching the GTT Editor, page 15-2

•

Loading an Existing GTT File, page 15-29

•

Saving a GTT File, page 15-38
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Checking the Semantics of a GTT File
The MWTM strongly recommends that you check the semantics of a GTT file against a specific ITP and
validate this data in the GTT file:
•

ITP Point Code—For version 2.0 GTT files, the point code in the GTT file must differ from the
primary, secondary, or capability point code of the ITP. If the file is the same, the MWTM generates
an error. This restriction is not for GTT files of version 3.0 or later.

•

Route Table—The ITP route table must contain all point codes in the GTT file, other than the
primary, secondary, or capability point code of the ITP. If the route table does not contain the point
codes, the MWTM generates an error.

•

Route Status—All route entries for point codes in the GTT file, other than the ITP’s primary,
secondary, or capability point code, must be available. If they are not, the MWTM generates a
warning.

•

GTA and Application Group—If an application server configures the GTA or the application
group, then that application server must reside on the ITP. If it does not, the MWTM generates an
error.
If the application server resides on the ITP, but it is not available, the MWTM generates a warning.

For example, ITP limits XUA configuration to instance 0. The MWTM semantic check verifies that XUA
is not configured on any other instance.
To check the semantics of a GTT file, choose File > Semantic Check from the GTT menu. The Semantic
Check GTT dialog box appears.
Field or Button

Description

ITP Name or IP Address

Name or IP address of the ITP against which to check the GTT file.

OK

Closes the Semantic Check GTT dialog box and opens the Progress
dialog box, which shows the progress of the semantic check for the
GTT file.
Enter the name or IP address of an ITP, and click OK. The MWTM
closes the Semantic Check GTT dialog box and opens the Progress
dialog box.
The Progress dialog box shows the progress of the semantic check for
the GTT file and any messages that appear while checking the file.
After the check, click OK. The MWTM closes the Progress dialog box
and returns to the Semantic Check GTT dialog box.

Cancel

Note

Closes the Semantic Check GTT dialog box without checking the
semantics of the GTT file.

You can also use the mwtm checkgtt command to semantics of a GTT file (see mwtm checkgtt,
page B-108).
Related Topic:

Editing an ITP Global Title Translation Table, page 15-1.
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Deploying a GTT File
You use the Deployment wizard to validate a GTT file, upload it to an ITP, archive the file, and activate
it on the ITP. To launch the Deployment wizard for a GTT file, choose File > Deploy from the GTT menu
(see Deploying ITP Files, page 4-33).

Displaying Basic Information About a GTT File
You use the MWTM to view basic information about the current GTT file. Choose View > GTT Table
Info from the GTT menu. The GTT Table Info dialog box appears.
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Field or Button

Description

Filename

Name of the GTT file.

Version

Version of the file format that the GTT uses. Valid versions are:
•

3.1—Corresponds to ITP software releases 12.2(4)MB9 and
12.2(4)MB9a. Two or more entries in the same application group can
have the same cost. This is the default version in the MWTM.

•

4.0—Corresponds to ITP software release 12.2(4)MB10 or higher.
Supports multiple instances on a single node.

•

4.1—Corresponds to ITP software release 12.2(20)SW or higher.
Supports multiple instances on a single node.

•

4.2—Corresponds to ITP software release 12.2(21)SW1 or higher.
Supports subsystem numbers equal to zero (0) for GTA entries and
application group entries.

•

4.3—Corresponds to these ITP software releases:
– 12.2(25)SW1 or higher
– 12.2(18)IXA or higher
– 12.4(11)SW or higher

Supports latest encoding scheme (not for ANSI).
•

4.4—Corresponds to these ITP software releases:
– 12.2(18)IXE or higher
– 12.4(15)SW or higher

•

4.5—Corresponds to these ITP software releases:
– 12.2(33)IRD or higher
– 12.4(15)SW4 or higher

•

4.6—Corresponds to these ITP software releases:
– 12.2(33) IRE or higher
– 12.4(15) SW5 or higher

Supports higher destination cost and removing digits.
The MWTM 6.1.6 supports GTT files with file format versions 3.1, 4.0, 4.1,
4.2, 4.3,4.4, 4.5, or 4.6. You can load GTT files that use lower or higher file
format versions; but, fields or features that are unique to the lower or higher
version are not visible and they disappear from the GTT file the next time
you save. The file is saved as a version 3.1 file if the file is lower than version
3.1 or as a version 4.6 file if the file is higher than version 4.6.
Variant

SS7 protocol variant. Valid variants are:
•

ANSI

•

China

•

ITU

•

NTT

•

TTC
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Field or Button

Description

Network Name

Network name that the GTT file uses.
This field appears only for GTT files of version 4.1 or higher.

Instance Number

Number of the instance that the GTT uses. Valid numbers are 0 to 7. The
default instance number is 0.
If no instance is associated with the GTT, this field contains N/A. This field
appears only for GTT files of version 4.0.

Last Modified

Date and time the GTT file was last modified.

Total Entries

Total number of entries in the GTT file.

OK

Closes the GTT Table Info dialog box.

Related Topic:

Editing an ITP Global Title Translation Table, page 15-1.

Supporting Cross-Instance GTT Files
You use the ITP Multiple Instance feature to connect an ITP to more than one network at the same time,
each with specific variant and network indicator values. The ITP treats each combination of variant and
network indicator as a separate instance with its own local point code, routing table, and GTT file on the
ITP. Instances in the same network must have the same network name.
In support of the Multiple Instance feature, ITP Instance Translation enables the conversion of packets
between instances of any variants. Each instance is a separate domain with a defined variant, network
indicator, ITP point code, optional capability point code, and optional secondary point code.
For more information about the ITP Multiple Instance and Instance Translation features, see the
IP Transfer Point (ITP) feature module for Cisco IOS software release 12.2(4)MB10 or later.
GTT files that support the Multiple Instance and Instance Translation features are called cross-instance
GTT files, because they contain application groups that reference point codes in other GTT files.
To handle cross-instance GTT files, the MWTM uses a server-wide network name mapping file, which
maps the available network names to GTT variants and network indicators. The MWTM looks up
network names in the file to parse point codes correctly, based on the user’s cross-instance configuration.
When the MWTM discovers your network, it automatically creates and populates the network
name-mapping file. Therefore, in most cases, you do not need to manually create the network name
mapping file. For more information about running Discovery, see Managing and Deploying ITP Files,
page 4-24.
In some cases, you might want to create the network name mapping file manually; for example, if you
have not run Discovery yet, but you want to prepare for a future GTT configuration. Also, while you
cannot change or delete entries that the MWTM automatically populated, you can add entries manually,
and you can change or delete those manual entries.
To create the network name mapping file manually; or, to add, change, or delete manual entries, choose
View > Network Name Configuration from the GTT menu. If you have implemented MWTM
User-Based Access, this option is available to users with authentication level System Administrator
(level 5). The Network Name Configuration dialog box appears.
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The Network Name Configuration dialog box contains:
•

Network Name Configuration Dialog Box Menu, page 15-37

•

Network Name Configuration Dialog Box Table, page 15-38

Network Name Configuration Dialog Box Menu
The menu on the Network Name Configuration dialog box contains:
Menu Command
File > Revert
(Ctrl-R)

Description
Loads the most recent network name mapping file from the MWTM server.
If the MWTM discovers new entries for the network name mapping file while
you are editing a GTT file (for example, if it adds a new network instance or it
discovers a new network), the GTT Editor is unaware of the new entries and
they are not visible in the Network Name Configuration dialog box. To see the
new entries in the dialog box, choose File > Revert. (You can also restart the
GTT Editor to automatically load the most recent network name mapping file
from the MWTM server.)

File > Save
(Ctrl-S)

Saves the changes you make to the network name mapping file.

File > Print
(Ctrl-P)

Prints the contents of the network name mapping file.

File > Close
(Ctrl-W)

Closes the network name mapping file without saving any additions, changes,
or deletions.

Edit > Add
(Alt-A)

Adds an entry to the network name mapping file.

Edit > Delete
(Delete)

Deletes the chosen entry from the network name mapping file.

Help > Topics
(F1)

Shows the table of contents for the MWTM online help.

Help > Window
(Shift-F1)

Shows online help for the current window.

Help > About
(F3)

Shows build date, version, SSL support, and copyright information about the
MWTM application.

After you add, change, or delete entries and save the file, the MWTM uses the
file the next time it discovers the network. However, if the MWTM discovers
entries that conflict with manual entries in the file, the MWTM uses (and
shows in the Network Name Configuration dialog box) the discovered entries,
not the manual entries.
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Network Name Configuration Dialog Box Table
The Network Name Configuration dialog box table contains:
Field

Description

Network Name

Network name that the GTT file uses.
If you change the network name for an existing GTT file, the new network
name must use the same variant.

Variant

Network Indicator

Discovered

SS7 protocol variant. Valid variants are:
•

ANSI

•

China

•

ITU

•

NTT

•

TTC

Type of call that is placed. Valid values are:
•

National—National-bound call. The MWTM routes national calls
through the national network.

•

NationalSpare—National-bound call, used in countries in which more
than one carrier can share a point code. In those countries, the Network
Indicator differentiates networks.

•

International—International-bound call. The MWTM forwards
international-bound calls to an STP pair that acts as an international
gateway.

•

InternationalSpare—International-bound call, used in countries in
which more than one carrier can share a point code. In those countries,
the Network Indicator differentiates networks.

Indicates whether the MWTM (Yes) or a user manually (No) discovered the
entry.

Related Topic:

Editing an ITP Global Title Translation Table, page 15-1

Saving a GTT File
You use the MWTM to save a specific GTT file and change the list of GTT files.

Note

The MWTM 6.1.6 supports GTT files with file format versions 3.1, 4.0, 4.1, 4.2, 4.3, 4.4, 4.5, or 4.6.
You can load GTT files that use lower or higher file format versions; but, fields or features that are unique
to the lower or higher version are not visible and they disappear from the GTT file the next time you
save. The file is saved as a version 3.1 file if the file is lower than version 3.1 or as a version 4.6 file if
the file is higher than version 4.6.
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To save the changes make to a GTT file or change the list of GTT files, use one of these procedures. To
save the changes you have made to the GTT file:
•

Without changing the name of the file, choose File > Save from the GTT menu.

•

With a new name, choose File > Save As from the GTT menu. The Save File dialog box: GTT File
List appears.

Field or Button

Description

Type

Icon indicating whether the item in the table is a file or a
folder.

Name

Name of the GTT file or folder.

Last Modified

Date and time the GTT file or folder was last modified.

Size (bytes)

Size of the GTT file or folder, in bytes.

Filename

Name by which you want to save the GTT file.
If you create a new GTT filename, you can use any letters,
numbers, or characters in the name that your operating
system allows. However, if you include any spaces in the new
name, the MWTM converts those spaces to hyphens (-). For
example, the MWTM saves file a b c as a-b-c.

Number of Files
(visible in bottom left corner)

Total number of GTT files and folders.

OK

Saves the GTT file or any changes you make to the list of files
and closes the dialog box.
To save the GTT file with a new name, use one of these
procedures. To save the file with:
•

A completely new name, enter the new name and click
OK.

•

An existing name, overwriting an old GTT file, choose
the name from the list and click OK.

The MWTM closes the Save File dialog box: GTT File List
and the Progress dialog box appears.
The Progress dialog box shows the progress of the GTT file
save, as well as any messages that appear while saving the
file.
When the file is saved, click OK. The MWTM closes the
Progress dialog box, saves the GTT file with the new name,
and returns to the GTT Configuration window.
Note

Delete

If another user modifies and saves the GTT file before
you save your changes, the MWTM asks if you want
to overwrite that user’s changes. If you do, the other
user’s changes are overwritten and lost. If you choose
not to, your changes are lost; unless you save the GTT
file to a different filename.

Deletes the chosen file from the GTT file list. An
informational message appears that contains the name and
location of the deleted file.
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Field or Button

Description

Cancel

Closes the dialog box without saving the GTT file or any
changes to the GTT file list.

Help

Shows online help for the dialog box.

When you are ready to exit the GTT Editor window, choose File > Exit from the GTT menu.
If you make any changes to the GTT file, the MWTM asks if you want to save the changes before leaving
the window. Click:
•

Yes to save the changes.
The MWTM opens the Save File dialog box: GTT File List, which you use to save the GTT file with
a new name, or overwrite an existing GTT file.

•

No to close the prompt window.
The MWTM closes the GTT Editor window without saving any changes to the GTT file.

By default, GTT files reside in the MWTM installation directory. If you installed the MWTM in:
•

The default directory, /opt, then the default directory is /opt/CSCOsgm/gtt.

•

A different directory, then the default directory resides in that directory.

To change the directory in which the MWTM stores GTT files, use the mwtm gttdir command (see
mwtm gttdir, page B-117).

Reverting to the Last Saved GTT File
To revert to the last saved version of the GTT file, choose File > Revert from the GTT menu. The
MWTM shows the last saved version of the file.
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