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This chapter describes the basics of working with Cisco Media Gateway Controller (MGC) Node 
Manager (MNM). Topics include:

• Starting and Quitting a Cisco MNM Session, page 3-1

• Opening, Closing and Switching Cisco MNM Applications, page 3-3

• Basic Operations in Cisco MNM, page 3-6

• Using the Map Viewer, page 3-10

• Understanding Cisco MNM Dialog Boxes, page 3-26

Starting and Quitting a Cisco MNM Session
This section describes how to start and quit a Cisco MNM session.

Note If you are using VNC on Solaris 10 to access Cisco MNM, see the following URL for instructions on 
installing and configuring the VNC on the Solaris 10 platform from the Sun Microsystems website

http://www.sun.com/bigadmin/jsp/descFile.jsp?url=descAll/install_and_configu

In the configuration procedure described in the above URL, use the following line to replace the 
corresponding line when you are editing /etc/dt/config/Xservers.

:1   Local local_uid@console root /opt/sfw/bin/Xvnc :1 -httpd /opt/sfw/vnc/classes -depth 24 
-geometry 1024x768 -r fbwait 120000 -rfbauth /opt/sfw/vnc/.vnc/passwd -rfbport 5901 
-httpport 5801 -fp tcp/localhost:7100 -alwaysshared -co /usr/openwin/lib/X11/rgb
-fp /usr/openwin/lib/X11/fonts/misc/, /usr/openwin/lib/X11/fonts/75dpi/

Starting a Cisco MNM Session
You can start a Cisco MNM session when Cisco EMF is running. Use the following steps to start a Cisco 
MNM session:
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Step 1 Log in as root.

Step 2 From the command line on the terminal window enter

# cd <CEMF_ROOT>/bin

Where <CEMF_ROOT> is the Cisco MNM installation root directory (for example, /opt/cemf).

Note Because Cisco EMF is the element management framework upon which Cisco MNM is built, you need 
go into the <CEMF_ROOT> directory to start a Cisco MNM session.

Step 3 Verify that Cisco EMF is running.

Step 4 Enter

# cemf query

You should see CEMF Manager 3.2 initialized followed by a list of running Cisco EMF processes.

Step 5 If Cisco EMF is not running, start it by entering the following command:

# cemf start

Step 6 From the command line on the terminal window, enter

# <CEMF_ROOT>/bin/cemf session

Where <CEMF_ROOT> is the Cisco MNM installation root directory (for example, /opt/cemf). 

The Cisco EMF Login window displays, as shown in Figure 3-1.

Figure 3-1 Cisco EMF Login Window

Step 7 Enter your user name and password, and click OK.

Note • The default user name and password is admin.

• If an unknown user name or password is entered, an error message displays. You are given three 
attempts to enter a valid user name and corresponding password. After three invalid entries, the 
session does not start and the Login window closes.

When a valid user name and password is entered, the session starts and the Cisco EMF Launchpad 
window displays, as shown in Figure 3-2.

Step 8 Continue to the “Opening an Application” section on page 3-4.
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Quitting a Cisco MNM Session
You can quit a Cisco MNM session at any time. Quitting Cisco MNM closes any open applications or 
dialog boxes, but does not stop Cisco EMF. Use the following procedure to quit a Cisco MNM session:

Step 1 Do one of the following:

• From the File menu, select Quit.

• Press Ctrl-Q.

• Click the Close tool on the toolbar. 

You are asked if you want to quit the Cisco EMF Manager system.

Step 2 Click Yes to quit the session.

All active applications are closed and the session terminates. Cisco EMF continues to run. 

Note To stop Cisco EMF, you must be the root user. 

Opening, Closing and Switching Cisco MNM Applications
Cisco MNM applications are the major groupings of network management functions. They include:

• Map Viewer—You can view, build, and monitor a network with Map Viewer. You can monitor the 
networks using network object connections.

• Object Group Manager—You can organize network elements into object groups with the Object 
Group manager. You can create, delete, and modify object groups.

• Access Manager—The Access menu allows an administrator to set up users and user groups, assign 
passwords, and define access parameters.

• Event Browser—Clicking the Events button initiates the Event Browser and Query Editor. You can 
create object groups or browse events from these windows.

• Discovery—Because Cisco MNM requires a log in and password to communicate with a device, the 
Cisco EMF Automatic Discovery feature is not supported by Cisco MNM. Cisco MNM discovers 
(and can automatically rediscover) device components and configurations once the device has been 
deployed: IP address, host name, and login information entered into Cisco MNM, as described in 
Chapter 5, “Deploying Your Network in Cisco MNM.”

• Cisco MNM Manuals—Opens a Mozilla browser window and displays links to the following 
documents: 

– Cisco Media Gateway Control Node Manager End-User Guides
You can also see these documents at
http://www.cisco.com/en/US/products/sw/netmgtsw/ps1912/products_user_guide_list.html.

Note If the Cisco MNM is installed co-resident with another CEMF element manager, a button for that 
product’s manual also displays.

• Event Manager
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– Notify—You can create notification profiles that consist of a series of notifications that should 
be carried out as a result of the profile being triggered.

– Thresholds—You can configure the management system to actively monitor the network and 
notify the operator when some aspect of the network performance has deviated from preset 
criteria.

– Event Groups—You can filter and organize events based on specified criteria, such as severity, 
state, or type of network element, and then create a scoreboard to show the state of the group at 
a glance.

– PreFilter—Pre-filter some messages collected in Cisco MNM according to the defined rules.

– Version—Display the version and patch information for Cisco MNM and Cisco VSPT (if 
installed together with Cisco MNM).

Once you have started a Cisco MNM session, you can open, close, and switch between applications.

Opening an Application
The Cisco EMF Launchpad (shown in Figure 3-2) is used to access Cisco MNM applications. You can 
open multiple applications, and you can open more than one instance of an application.

Figure 3-2 Cisco EMF Launchpad 

Use the following procedure to open an application:

On the Launchpad, click the icon to open the desired application. A busy icon and a message in the status 
bar displays while it is opening.
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Note If an application is already open, it displays in the drop-down menu on the Window toolbar. Click 
Window, and choose the desired application.

Closing an Application
Closing an application closes only the current instance of the application. Other instances of the 
application are unaffected. For example, if you separately opened an Event Browser for a Cisco BAMS 
and an Event Browser for a Cisco PGW 2200 Softswitch host, closing the Cisco PGW 2200 Softswitch 
host Event Browser window does not close the Cisco BAMS Event Browser window.

Use one of the following procedures to close an application:

• Choose File > Close.

• Click the window Close button.

• If the window has a toolbar, click the Close tool .

• Press Alt-F4.

Switching Between Open Application Windows
Working in Cisco MNM often involves having several windows open at the same time. You can view the 
list of open windows and switch between them from the drop-down menu on the Window toolbar, as 
shown in Figure 3-3.

Use the following steps to switch between windows:

Step 1 Click Window on the toolbar. The drop-down menu displays and lists all open windows.

Figure 3-3 Window Pull-Down Menu

Step 2 Choose the desired window. 
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Basic Operations in Cisco MNM
This section describes basic operations that apply to Cisco MNM:

• Using the mouse, shortcut keys, or toolbar to access Cisco MNM features

• Selecting items in lists

• Printing the contents of a window

• Viewing Cisco MNM status information

Note If you have problems printing the contents of a window, consult your system administrator to verify that 
your operating system is configured for printing.

Using the Mouse
The left, middle, and right mouse buttons are used for the following Cisco MNM functions:

• Click the left mouse button to

– Select.

– Activate.

– Set the location of the cursor.

• Click the middle mouse button to

– Copy.

– Move.

– Drag.

• To access context menus, click the right mouse button on a managed object within an application 
such as the Map Viewer, the Object Group Manager, and events in the Event Browser.

Using Shortcut Keys

Ctrl-Key

Standard Cisco MNM menus are available on the toolbar. You can click to select items from the menus 
or you can enter shortcut keys, as shown in Table 3-1 and Table 3-2.

Table 3-1 File Menu Shortcut Keys

Key Sequence File Menu Function

Ctrl-Q Quit

Ctrl-W Close

Ctrl-P Print

Ctrl-S Save
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Note When a menu option is grayed out, it is not available for selection.

Alt-Key

Items in the Cisco MNM menus and dialog boxes may be displayed with the first (initial) letter 
underlined (for example, Actions.) This means that you can either select this option by clicking the 
mouse, or you can press Alt-A. 

Tip You can use the X windows standard Alt-4 to close the current window.

Using the Toolbar
In Cisco MNM application windows, a toolbar contains tool buttons for commonly used menu options. 
You can toggle the toolbar on or off and choose to display or hide tooltips.

In Figure 3-4, the toolbar contains tool buttons for the following functions common to many dialog 
boxes:

• Close the current window.

• Print the contents of the window.

Figure 3-4 Example Toolbar

Note If you have problems printing the contents of a window, consult your system administrator to verify that 
your operating system is configured for printing.

Ctrl-N New

Ctrl-O Open

Table 3-2 Edit Menu Shortcut Keys

Key Sequence File Menu Function

Ctrl-Z Undo

Ctrl-X Cut

Ctrl-C Copy

Ctrl-V Paste

Ctrl-A Select all

Ctrl-D Deselect all

Table 3-1 File Menu Shortcut Keys (continued)
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• Toggle dynamic update mode to allow viewing or not viewing real-time changes.

• Refresh the window to update the information when dynamic update mode is off.

• Acknowledge that you have seen dynamically updated dialog box changes.

Hiding or Showing the Toolbar

To toggle the display of the toolbar for the current window, choose Options > Show Toolbar.

Hiding or Showing Tooltips

Tooltips provide a brief description of a toolbar button or window panel. Tooltips appear when the cursor 
is positioned over the item. You can choose to show or hide tooltips. 

To toggle the display of tooltips for the toolbar in the current window, choose Options > Enable Tooltip.

Selecting from Lists
To perform an operation on more than one item, you can select:

• A block of items

• Multiple items in different areas of a list

• All items

You can also deselect all items. For instructions, see the “Use the following steps to deselect all items:” 
task on page 3-9 

Use the following steps to select a block of items:

Step 1 Click the first item in the block.

The item is highlighted.

Step 2 Press and hold the Shift key.

Step 3 Click the last item in the block.

Step 4 Release the Shift key.

All items between the first and last item are highlighted.

Use the following steps to select multiple items in different areas of a list:

Step 1 Click the first item.

The item is highlighted.

Step 2 Press Ctrl and click the next item you want to select.

The item is highlighted.

Step 3 Repeat Step 2 and Step 3 until all the desired items are highlighted.

Use the following steps to select all items:
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Step 1 Place the cursor anywhere in the window. 

Step 2 Press and hold the right mouse button.

A context menu displays. 

Step 3 Choose Select All.

Note This option is not available in all windows.

All items in the list are highlighted. 

Use the following steps to deselect all items:

Step 1 Place the cursor anywhere in the window. 

Step 2 Press and hold the right mouse button.

A context menu displays. 

Step 3 Choose Deselect.

Note This option is not available in all windows.

All items in the list are deselected. 

Printing the View Displayed in the Window
In most windows you can print the contents.

Note If you have problems printing the contents of a window, consult your system administrator to verify that 
your operating system is configured for printing.

To print the contents of the current window, do one of the following:

• From the File menu, choose Print.

• Press Ctrl-P.

• Click the Print tool on the toolbar.

The current view is printed.

Viewing Cisco MNM Status Information
The status bar at the bottom of most windows displays status information about the current Cisco MNM 
application status (not about network status). 
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To view previous status messages, double-click in the status bar. The Status Dialog displays, as shown 
in Figure 3-5. 

Figure 3-5 Status Dialog 

Using the Map Viewer
The Map Viewer organizes the network display into various views and is the starting point for most 
Cisco MNM network management operations. Each view represents a different way of containing and 
grouping the network elements, such as device type, Cisco PGW 2200 Softswitch node, and physical or 
network view. 

In the Map Viewer you can

• Deploy an entire network or a single new device.

• See at a glance which devices have generated alarms. Because the alarm display is propagated from 
the originating object up through the containing objects, you can quickly drill down to find the 
source of the problem. 

Note Propagation applies to the node and physical views. Alarms are not propagated in device views.

• Identify information about a device by its graphical representation. State icon, color, cross-hatching 
pattern are some of the indicators that give you a quick graphical read of the network condition.

• Access network devices by navigating through one of the views to the desired object and then 
right-clicking to open any of the Cisco MNM services relevant to that device.

• View the network in different ways. For example, you can use the physical view to see where devices 
are located, the device view to perform an operation on all devices of a particular type, and the node 
view to see node-specific elements such as signaling components.

Note The term “object” refers to the graphical representation of a network element in Cisco MNM and the 
term “device” refers to the real-world counterpart that is represented and manipulated by the object.
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This section describes the basics of how to use the Map Viewer. The Map Viewer display is based on the 
Cisco MNM object model of the network. For an explanation of the concepts and some of the technical 
details behind the Map Viewer, see Chapter 1, “Overview of Cisco Media Gateway Controller Node 
Manager,” “How Cisco MNM Models the Network” section on page 1-9. 

This section describes:

• The Map Viewer window and views.

• How to expand a view, to get to an object, and collapse a view.

• How to read the visual symbols associated with objects in the Map Viewer.

• How to use the context menu to open a Cisco MNM service for the current object. (This is your entry 
point to most network management functions.)

For more information on the Map Viewer, refer to “Map Viewer” in the Cisco EMF online help.

Map Viewer Window
Until you have deployed a network in Cisco MNM, the Map Viewer displays only empty container 
objects.

Figure 3-6 Map Viewer Before a Network Is Deployed

When you deploy a network, (see Chapter 5, “Deploying Your Network in Cisco MNM”) the views are 
populated with the graphical objects that represent your network devices. Initially, the view is collapsed, 
as shown in Figure 3-7.
3-11
Cisco Media Gateway Controller Node Manager User Guide

OL-18339-03



 

Chapter 3      Getting Started with Cisco MNM
Using the Map Viewer
Figure 3-7 Map Viewer After Deployment

When a view is expanded, the Map Viewer looks similar to the illustration shown in Figure 3-8.

Figure 3-8 Typical Appearance of the Map Viewer 

• The Map Viewer window is divided into two panes. The left pane is a hierarchy browser. The right 
pane displays a map of the object selected in the right pane. The map is a detailed depiction of the 
selected device or site.

• Resize the hierarchy browser pane and map pane by positioning your cursor over the boundary and 
dragging.

• Use the scroll bars to view all information in the left and right panes. 

• You can open a service on a device object by right-clicking the object and choosing the service from 
the context menu. To open a service on multiple devices, select the devices, and then right-click.
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Note The context menu displays the list of services available for the selected device or devices. Services 
available depend on your access privileges. If multiple objects are selected, only services common to all 
selected objects are available. 

Map Viewer Views
This section describes the various Map Viewer views.

Node View

The node view shows all the devices in the node, as well as the Cisco PGW 2200 Softswitch host 
signaling, dial plan, and trunking components. 

Use the node view to: 

• Deploy a node and devices within a node. In a conventional node, you deploy one or a pair of 
Cisco PGW 2200 Softswitch hosts under the node. In a farm, you deploy a farm under the node, and 
then deploy one or a pair of Cisco PGW 2200 Softswitch hosts under the farm, as shown in 
Figure 3-12.

• View alarm propagation. Alarms are propagated from child devices to parent devices anywhere in 
the node, and you can drill down through the tree to find the element raising the alarm. 

• View signaling, trunking, and dial plan information.

• Open applications for signaling, trunking, and dial plan components.

Figure 3-9 shows an example of the node view. Figure 3-10 and Figure 3-11 show expansions of the 
signaling and trunking folders. Figure 3-12 shows an example of a farm folder.

Figure 3-9 Node View
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Figure 3-10 Signaling Folder

Figure 3-11 Trunking Folder 

Figure 3-12 Farm Folder
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Device Views

The device views group devices by their type. Use device views to view and manage all the devices of a 
particular type.

Note Alarms are not propagated in device views. Use the node view or physical view to propagate alarms.

Tip To open a Cisco MNM service for a group of devices, open the service from the device view. The dialog 
box lists all the devices. You can select each desired device in turn.

Cisco PGW 2200 Softswitch Host View

This view shows all Cisco PGW 2200 Softswitch hosts. Use host view to:

• View and manage all hosts

• View and manage host system components, such as disk, RAM, memory, processor, and interfaces

Figure 3-13 Cisco PGW 2200 Softswitch Host View 

Cisco ITP-L View

Note Cisco IP Transfer Point LinkExtender (ITP-L) is the new name for Cisco Signaling Link Terminal (SLT). 
Over time, ITP-L will replace SLT in publications and the product.

This view shows all the Cisco ITP-Ls, integrated ITP-Ls and integrated ITP-L coresident EMs. Use 
Cisco ITP-L view to:

• View and manage all of the Cisco ITP-Ls

• View and manage ITP-L interfaces, including TDM interfaces

Different icons are used for different types of ITP-Ls, as shown below.
3-15
Cisco Media Gateway Controller Node Manager User Guide

OL-18339-03



 

Chapter 3      Getting Started with Cisco MNM
Using the Map Viewer
Figure 3-14 Cisco ITP-L View

Cisco LAN Switch View

This view shows all Cisco LAN switches. Use this view to:

• View and manage all Cisco LAN switches

• View and manage switch components, such as interfaces, modules, and ports

Type of ITP-L Icon

Standalone ITP-L

Integrated ITP-L
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Figure 3-15 LAN Switch View

BAMS View

This view shows all Cisco BAMS machines. Use BAMS view to:

• View and manage all Cisco BAMS machines

• View and manage Cisco BAMS system components, including disk, RAM, memory, and interfaces
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Figure 3-16 BAMS View 

HSI View

This view shows all Cisco HSI servers. Use this view to:

• View and manage all Cisco HSI servers

• View and manage Cisco HSI system components, including disk, RAM, memory, and interfaces

Figure 3-17 HSI View

Physical View

This view organizes the network by physical location. You can define a hierarchy of regions and sites, 
such as cities, buildings, and floors (see Figure 3-18). When you deploy the network, you can identify 
the physical region or site associated with each network device. 
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Use the physical view to:

• Deploy regions and sites—Select the container object for the level you want to deploy. For example, 
select a Southeast region object to deploy an Atlanta site.

• View alarm propagation—Alarms are propagated from child devices to parent devices. Drill down 
through the tree to find the element raising the alarm. 

• Identify where a problem device is located—For example, in Figure 3-18, a problem is indicated in 
the Stonybrook building, which is propagated upward to the Raleigh and Southeast sites.

• Visualize the physical network.

Figure 3-18 Physical View 

Network View

This view shows the IP addresses of the network devices. 

Figure 3-19 Network View 

Expanding or Collapsing a View
In the left hierarchy browser pane, a plus sign (+) next to an object means it contains other objects and 
can be expanded. A minus sign (-) means that the object is fully expanded.

• To expand a view, click the + next to the object, as shown in Figure 3-20. 
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• To drill down to an object, continue expanding the view until you see the desired object.

• To collapse a view, click the - next to the object.

Tip When you see an alarm symbol next to an object, drill down to find the object generating the alarm.

Figure 3-20 Expanding a View in the Map Viewer

Understanding Map Viewer Symbols
Indicators in the Map Viewer reflect the status of the associated object and the occurrence of alarm 
events. For example, a polling icon indicates that a device or its child is being polled. In this way, the 
states of the Cisco PGW 2200 Softswitch subobjects are propagated up to the 
Cisco PGW 2200 Softswitch node object. 

Similarly, alarm events, indicated with a color-coded circle in the left pane and a balloon in the right 
pane, are propagated up in the physical and node view. 

For some states, a small symbol is placed near the top of the icon. Cross-hatching is used to indicate state 
information. 

Table 3-3 lists and describes status and event symbols. Table 3-4 displays the color-coding used for 
alarm events. For more information about alarm events, see Chapter 6, “Managing Faults with 
Cisco MNM.”

Collapsed View Expanded View

Table 3-3 Status and Event Symbols

Symbol Description

(In the left pane) Indicates the number of child devices. In the physical and 
network views, a circle indicates an event on one or more child devices, 
color-coded to severity. The highest severity is displayed. 

(In the right pane) A balloon indicates events, color-coded to severity. The 
number indicates the number of the most severe events in the category. The 
letter indicates the highest unacknowledged event severity in the category. 
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Use the Map Viewer to open a function, such as the Performance Manager or a Properties dialog box, 
for a device or group of devices.Use the following steps to open a function for a device:

Step 1 In the Map Viewer, navigate to the desired object. 

Indicates that the device has not been discovered. (This is the icon that 
displays when the device is initially deployed.)

Indicates that the device is in the process of discovering or rediscovering. 
The object icon itself has a hatch pattern.

Indicates that the device has some outage or operational problem and is, 
therefore, out-of-service. Icons also have a hatch pattern.

Indicates that the device is performing polling.

Indicates that the device is not SNMP reachable. This may be because the 
device is off the network or its SNMP agent is not responding.

Indicates that some major service or software process on the device has 
failed. The icons also have a hatch pattern.

Indicates that the device is off-duty or administratively down.

Indicates that the device is providing service.

Indicates that the device is running in warm-standby mode.

Indicates that the device is running in an unknown (other) mode.

Indicates that the device is being tested.

A hatch-pattern (without any corresponding state symbol) is used to indicate 
that the device is not being managed.

Table 3-4 Colors Used to Indicate Event Severity

Color Severity of Event

Red Critical

Orange Major

Yellow Minor

Cyan Warning

Green Normal

White Informational

Table 3-3 Status and Event Symbols (continued)

Symbol Description
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Note To open a Cisco MNM service for a group of devices, open the service from the device view. 
The dialog box contains a list box of all the devices. You can select each desired device in turn.

Step 2 Right-click the object. The context menu displays showing the functions available for the selected object 
or objects. 

Step 3 Choose the desired option. Table 3-5 summarizes how to access various services. 

A window opens for the service. For example, if you choose Properties, a Properties dialog box displays 
the properties of the selected device.

Note • Some functions can be opened from the Event Browser as well as the Map Viewer. 

• If SSH is enabled, functions that normally invoke Telnet or ftp instead invoke their SSH 
counterparts, ssh or sftp. 

Table 3-5 Opening Cisco MNM Functions

Function
Select This View or 
Object

Command: Right-Click and 
Choose... Description

Cisco PGW 2200
Softswitch Node 

Deployment

MGC-Node-View Deployment > Deploy MGC 
Node

Deploys a new 
Cisco PGW 2200 Softsw
itch node

Cisco PGW 2200
Softswitch Host 

Deployment

Host-View

Cisco PGW 2200 S
oftswitch Node

Deployment > Deploy MGC 
Host

Deployment > Deploy MGC 
Node Component

Deploys a new 
Cisco PGW 2200 Softsw
itch host 

ITP-L 
Deployment

ITP-L-View

Cisco PGW 2200 S
oftswitch Node

Deployment > Deploy ITP-L

Deployment > Deploy MGC 
Node Component

Deploys a new 
Cisco ITP-L or 
integrated ITP-L

LAN Switch 
Deployment

Switch-View

Cisco PGW 2200 S
oftswitch Node

Deployment > Deploy LAN 
Switch

Deployment > Deploy MGC 
Node Component

Deploys a new 
Cisco LAN switch 

BAMS 
Deployment

BAMS-View

Cisco PGW 2200 S
oftswitch Node

Deployment > Deploy BAMS

Deployment > Deploy MGC 
Node Component

Deploys a new 
Cisco BAMS

HSI Deployment HSI-View

Cisco PGW 2200 S
oftswitch Node

Deployment > Deploy HSI

Deployment > Deploy MGC 
Node Component

Deploys a new Cisco HSI 
host device

Seed File 
Deployment

Any view icon 
(action applies to 
entire network)

Deployment > Deploy Network 
Seed File

Displays Seed File 
deployment dialog
3-22
Cisco Media Gateway Controller Node Manager User Guide

OL-18339-03



 

Chapter 3      Getting Started with Cisco MNM
Using the Map Viewer
Performance 
Manager

Cisco PGW 2200 S
oftswitch Node, 
BAMS, HSI, ITP-L, 
or LAN Switch at 
level of managed 
element

Tools > Performance Manager Opens Performance 
Manager application to 
monitor performance 
measurements

Cisco PGW 2200
Softswitch Node 

States

MGC-Node-View, 
Cisco PGW 2200 S
oftswitch Node

MGC Node States Opens MGC Node States 
dialog

Cisco PGW 2200
Softswitch Host 

Properties

Host-View or Node 
View, 
Cisco PGW 2200 S
oftswitch Host

Properties Opens Host Properties 
dialog

Cisco PGW 2200
Softswitch Host 

File System 
Properties

Host-View or Node 
View, 
Cisco PGW 2200 S
oftswitch Host

File Systems Opens Host File System 
properties dialog

Cisco PGW 2200
Softswitch Host 

System 
Component 
Properties

Cisco PGW 2200 S
oftswitch Host

Devices, then the desired 
component: Disk Partition, 
Processor, RAM, or Virtual 
Memory

Opens the properties 
dialog for the selected 
system component

Cisco PGW 2200
Softswitch Host 

States

Host-View or Node 
View, 
Cisco PGW 2200 S
oftswitch Host

States Opens Host States dialog

Cisco PGW 2200
Softswitch Host 

Accounts

Host-View or Node 
View, 
Cisco PGW 2200 S
oftswitch Host

Accounts Opens Host Accounts 
dialog

Cisco PGW 2200
Softswitch Host 

Diagnostics

Host-View or Node 
View, 
Cisco PGW 2200 S
oftswitch Host

Tools > MGC Host Diagnostics Opens Host Diagnostic 
dialog

ITP-L Properties ITP-L-View or 
Node View, ITP-L

Properties Opens ITP-L Properties 
dialog

ITP-L States ITP-L-View, ITP-L States Opens ITP-L States 
dialog

ITP-L Accounts ITP-L-View, ITP-L Accounts Opens ITP-L Accounts 
dialog

ITP-L 
Diagnostics

ITP-L-View, ITP-L Tools > ITP-L Diagnostics Opens ITP-L Diagnostic 
dialog

Table 3-5 Opening Cisco MNM Functions (continued)

Function
Select This View or 
Object

Command: Right-Click and 
Choose... Description
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LAN Switch 
Properties

Switch-View or 
Node View, LAN 
Switch

Properties Opens LAN Switch 
Properties dialog

LAN Switch 
States

Switch-View or 
Node View, LAN 
Switch

States Opens LAN Switch 
States dialog

LAN Switch 
Accounts

Switch-View or 
Node View, LAN 
Switch

Accounts Opens LAN Switch 
Accounts dialog

LAN Switch 
Diagnostics

Switch-View or 
Node View, LAN 
Switch

Tools > LAN Switch Diagnostics Opens LAN Switch 
Diagnostic dialog

BAMS Properties BAMS-View or 
Node View, BAMS

Properties Opens BAMS Properties 
dialog

BAMS File 
System 
Properties

BAMS-View or 
Node View, BAMS

File Systems Opens BAMS File 
System properties dialog

BAMS System 
Component 
Properties

BAMS Devices, then the desired 
component: Disk Partition, 
Processor, RAM, or Virtual 
Memory

Opens the properties 
dialog for the selected 
system component

BAMS States BAMS-View or 
Node View, BAMS

States Opens BAMS States 
dialog

BAMS Accounts BAMS-View or 
Node View, BAMS

Accounts Opens BAMS Accounts 
dialog

BAMS 
Diagnostics

BAMS-View or 
Node View, BAMS

Tools > BAMS Diagnostics Opens BAMS Diagnostic 
dialog

BAMS Node 
Properties

BAMS-View or 
Node View

Properties Opens BAMS Node 
Properties dialog

BAMS Node 
Diagnostics

BAMS-View or 
Node View

Tools > BAMS Diagnostics Opens BAMS Node 
Diagnostic dialog

Trunking 
Configuration 
Audit

BAMS Tools > BAMS Diagnostics > 
Audit

Opens the Configuration 
Audit dialog

H323 Properties HSI-View, HSI 
Host

Properties Opens the H323 
Properties dialog

H323 File 
Systems

HSI-View, HSI 
Host

File Systems Opens the H323 File 
Systems dialog

H323 States HSI-View, HSI 
Host

States Opens the H323 States 
dialog

H323 Accounts HSI-View, HSI 
Host

Accounts Opens the H323 
Accounts dialog

Table 3-5 Opening Cisco MNM Functions (continued)

Function
Select This View or 
Object

Command: Right-Click and 
Choose... Description
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H323 
Diagnostics

HSI-View, HSI 
Host

Tools > Diagnostics Opens the H323 
Diagnostics dialog

H323 
Administration 
Tool

HSI-View, HSI 
Host

Administration Tool Opens the H323 
Administration Tool 
dialog

Signaling 
Dialogs

Signaling folder, all 
signaling 
components

Properties Opens the various 
signaling component 
property dialogs, one for 
each type of signaling 
component

Trunking Dialogs Trunking folder, all 
trunk group 
components

Properties Opens the various 
trunking component 
property dialogs, one for 
each type of component

Dial Plan 
Properties 
Dialogs

Dial plan folder, all 
routing components

Properties Opens the various dial 
plan component property 
dialogs, one for each type 
of routing component

Network 
Interface or 
Component 
Properties

The individual 
interface or 
component under a 
device

Properties Opens the properties 
dialog for the selected 
network interface or 
component (interface, 
port, slot, and so forth)

Network 
Interface or 
Component 
Properties, a set 
of components

The device Component Type > Component 
Properties, for example, 
Interfaces > TDM Properties

Opens the properties 
dialog for all components 
of that type on the 
selected device

Event Browser 
(can also be 
opened from 
Launchpad)

Any device that 
forwards traps to 
Cisco MNM

Tools > Open Event Browser Opens Event Browser for 
the selected device(s)

Performance 
Manager

Any device that 
collects 
performance data 
and is in polling 
state

Tools > Performance Manager Opens Performance 
Manager for the selected 
device(s)

Voice Services 
Provisioning 
Tool

Cisco PGW 2200 S
oftswitch Host, 
BAMS

Tools > Voice Services 
Provisioning Tool

Starts Cisco Voice 
Services Provisioning 
Tool application (detects 
correct release for 
Cisco PGW 2200 Softsw
itch software and correct 
level of user privileges).

Table 3-5 Opening Cisco MNM Functions (continued)

Function
Select This View or 
Object

Command: Right-Click and 
Choose... Description
3-25
Cisco Media Gateway Controller Node Manager User Guide

OL-18339-03



 

Chapter 3      Getting Started with Cisco MNM
Understanding Cisco MNM Dialog Boxes
Understanding Cisco MNM Dialog Boxes
Cisco MNM dialog boxes are summarized below:

• Many dialog boxes display popup field descriptions when you pass your pointer over a field name. 

• If a container object is selected when the dialog box is opened, the dialog box can be used to view 
or manipulate properties for any of the selected devices.

• Because Cisco MNM supports multiple releases of the Cisco PGW 2200 Softswitch software, some 
fields in property dialog boxes may not apply to your release.

• Some dialog boxes display information received from a managed device and others display 
information about that device residing in the Cisco  MNM database. Toolbar buttons in the dialog 
box can help you recognize the difference and how the information can be updated.

Cisco PGW 2200
Softswitch 

Toolbar

Cisco PGW 2200 S
oftswitch Host

Tools > MGC Host Toolbar Opens MGC Host toolbar 
applications

HSI Alarm 
Viewer

HSI Host Tools > HSI Alarm Viewer Launches HSI Alarm 
Viewer application

HSI Log Viewer HSI Host Tools > HSI Log Viewer Launches HSI Log 
Viewer application

XTerm Cisco PGW 2200 S
oftswitch Host, 
BAMS, HSI server

Tools > Xterm Opens an XTerm window

CiscoView LAN Switch, ITP-L Tools > CiscoView Opens CiscoView 
application

Connection 
Service

Cisco PGW 2200 S
oftswitch Host, 
BAMS, HSI server, 
ITP-L, LAN Switch

Tools > Connection Service Opens UNIX Telnet 
application or SSH, 
depending on whether 
SSH is enabled on both 
Cisco MNM and the 
device its connecting to

Web Browser 
(Mozilla)

ITP-L, Catalyst 
2900XL

Tools > Web Browser Opens a web browser, 
pointing to the internal 
web server on 
Cisco ITP-Ls and 
Catalyst 2900XLs 

Administration 
tool (system 
administrators 
only)

Cisco PGW 2200 S
oftswitch Host, 
BAMS, HSI server, 
ITP-L, LAN 
Switch, or device 
view for all devices 
of the same type

Tools > Administration Tool Opens the device 
administration dialog 
box to allow rebooting or 
shutting down the device

Table 3-5 Opening Cisco MNM Functions (continued)

Function
Select This View or 
Object

Command: Right-Click and 
Choose... Description
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The features of Cisco MNM dialog boxes are described in the following sections.

Displaying Field Descriptions
In many dialog boxes, you can view a description of the current field by slowly passing the cursor across 
the field name, as shown in Figure 3-21.

Figure 3-21 Context Help

Displaying Information for Multiple Devices 
You can open a dialog box on multiple devices of the same type. For example, you can:

• Select a device view to open a service on all devices of that type.

• Select a device chassis to open a Properties dialog box on all subcomponents of a particular type.

Use the following steps to display information for multiple devices:

Step 1 Select the devices. See the “Selecting from Lists” section on page 3-8 for details on selecting multiple 
objects.

Step 2 Right-click, and choose the desired option. 

Note If an option is not available for the multiple devices you have selected, the option name is 
dimmed.

The dialog box opens. A list box in the left pane lists the selected devices. Figure 3-22 shows an example 
(properties for all TDM interfaces of a Cisco ITP-L). 

Step 3 To view or manipulate information for a particular device, select the device in the list box. The 
information on the right changes to reflect the current selection.
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Figure 3-22 Dialog Box with Information on Multiple Devices

Properties for Multiple Releases of the Cisco PGW 2200 SoftswitchSoftware 
Each new release of the Cisco PGW 2200 Softswitch software supports additional properties of the 
Cisco PGW 2200 Softswitch node elements. 

Because Cisco MNM supports multiple Cisco PGW 2200 Softswitchsoftware releases, some dialog 
boxes may display some fields that might not be applicable to your release of the 
Cisco PGW 2200 Softswitch software. For example, the H.248 Path Properties dialog box includes the 
property, Label, for Cisco PGW 2200 Softswitch software Release 9.8. If you are using 
Cisco PGW 2200 Softswitch software Release 9.7, this field is empty.

In general, Cisco MNM is tested and supported only on Cisco PGW 2200 Softswitch Releases 9.8(1), 
9.7(3), and 9.6(1).
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Figure 3-23 A Dialog Box with Properties for Multiple Cisco PGW 2200 Softswitch Releases

Working with Various Types of Dialog Box Information
Cisco MNM dialog boxes display two kinds of information about network devices:

• Information that comes from the device itself, such as properties or alarm events, or from 
Cisco MNM interaction with the device, such as state information

• Information that resides in the Cisco MNM database and is used by Cisco MNM to communicate 
with the device, such as account information

Information that comes from the device is display-only and cannot be edited or modified. To turn on 
“Dynamic Update” mode for real-time monitoring of the device, see the “Monitoring 
Dynamically-Updated Information” section on page 3-30.

Note Information that resides in the Cisco MNM database can typically be changed. However, you are 
changing only the Cisco MNM database and not information stored on the device itself. 

This section describes

• How to recognize and work with a dialog box that displays dynamically updated information

• How to recognize and use field changes that are applied to the device from a dialog box where 
information is display only
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Monitoring Dynamically-Updated Information

Many dialog boxes display in near real-time information received from a managed device. With dynamic 
update on, incoming changes from a device are highlighted in blue (see Figure 3-24). The status bar 
indicates whether dynamic updating is on or off. This kind of information is display only; it cannot be 
changed.

Figure 3-24 Dialog Box with Dynamic Updating

The toolbar in these dialog boxes includes the three tool buttons in Figure 3-25 used for managing 
updates:

• Toggle dynamic update mode, to allow viewing of real time changes.

• Refresh the window, to update the information manually when dynamic update mode is off.

• Acknowledge that you have seen dynamically updated dialog box changes. When clicked, the blue 
highlighting is removed.

Note Some dialog boxes include both dynamically updatable information from managed devices and 
information about the network maintained in the Cisco MNM database. The toolbar in Figure 3-25 also 
includes a Save tool used for saving changes to database information, as described in the “Making 
Changes to Cisco MNM Device Information” section on page 3-31. 

Field contents
highlighted in
blue after an
update

Update mode
Status of
last update
or save

6
2
1
5
0
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Figure 3-25 Dialog Box Toolbar with Dynamic Update and Database Save Functions

Making Changes to Cisco MNM Device Information

Some dialog boxes display information that you can edit. For example, if the login ID for a device 
changes, you can use the Accounts dialog box for that device to update the information in the 
Cisco MNM database. In dialog boxes that include editable information, the toolbar includes a Save tool 
button, as shown in Figure 3-25. 

To make changes to the Cisco MNM database, enter the new information, and click the Save tool button.

Note If you try to make a change but the Save tool button remains dimmed, the field is not editable.

Navigating between Dialog Boxes for a Given Component
For most Cisco PGW 2200 Softswitch node components, you can navigate from one dialog box to 
another without having to reselect the component in the Map Viewer and right-click. For example, from 
the File Systems dialog box for a given Cisco BAMS, you can navigate to the Properties, Accounts, 
States, or Diagnostics dialog box for that Cisco BAMS. 

Perform the following steps to navigate from one dialog box to another not-yet-open dialog box for a 
given component:

Step 1 In the open dialog box, choose Navigation. A menu appears listing options to open other dialog boxes 
for this component. See Table 3-6 for a list of components and dialog boxes that provide the Navigation 
menu.

Step 2 Choose the desired menu option. The selected dialog box opens. 

Note Once a dialog box is open, use the Window menu on the toolbar to navigate between windows.

Toggle dynamic
update mode

Refresh

Acknowledge
changesInformation

from the
device

Information
in the 

Cisco MNM
database Save 62

15
1
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Table 3-6 Components with Dialog-Box Navigation Menus 

Component Dialog Boxes with the Navigation Menu

Cisco PGW 2200 Softswitch 
Host

Properties, Accounts, File Systems, States, Diagnostics.

Cisco BAMS Properties, Accounts, File Systems, States, Diagnostics.

Csico HSI server Properties, Accounts, File Systems, States, Diagnostics.

Cisco ITP-L Properties, Accounts, States, Diagnostics.

Cisco LAN switch Properties, Accounts, States, Diagnostics.

All components that have 
Properties dialog boxes

Properties: You can navigate from any Properties dialog box for the 
component to any other valid Properties dialog box for that component.

Note The Navigation menu may display options that are not valid for 
the current component. Service invocation fails if you select an 
invalid properties dialog box. 
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