Managing Faults

This chapter describes the process of fault management, and details the options available in Cisco MGM to locate, diagnose and correct network problems. This chapter includes the following information:

- 9.1 What Is Fault Management?
- 9.2 Where Can I Get Information on Affected Services and Customers?
- 9.3 What Fault Information Can I See?
- 9.4 Is the Service Working?
- 9.5 Where Is the Fault?
- 9.6 How Can I Use Advanced Debugging to Find the Cause of the Fault?
- 9.7 What Is the Fault Priority?
- 9.8 Who Is Responsible for Managing the Fault?
- 9.9 How Did You Manage the Fault?

9.1 What Is Fault Management?

Fault management (FM) is the process of locating, diagnosing, and correcting network problems. This is important for increasing network reliability and effectiveness, and for increasing the productivity of network users. Fault management is more than just handling emergencies. It is the detection, isolation, and correction of abnormal conditions in the network and its environment. It provides functions for managing problems with services and handling customer-facing service problems.

Efficient fault management can:

- Reduce repair costs through efficient fault detection, location, and correction.
- Improve customer care through efficient trouble administration.
- Improve service availability and equipment reliability through proactive maintenance and through measurement, review, and corrective action.

One responsibility of fault management is to detect faults. A piece of equipment, a transmission medium, a software module, or a database is said to be in a fault state if it cannot perform its intended function and meet all of the requirements placed on that function. The onset of a fault is called a failure event and is usually signaled by one or more alarm reports. The termination of a fault state is called a clear event.

Fault management is responsible for determining, from a variety of information sources, the root cause of a fault, and for its repair. In certain cases, the root cause of a fault may be in a connecting network. In such cases, fault management is responsible for reporting the problem through appropriate channels.
Service assurance is the overall process of ensuring that the purchased level of service is delivered. The Element Management System (EMS) plays a key role in maintaining the health of both network elements and transmission facilities. This is done in conjunction with other systems, typically at the network management layer and service management layer. The EMS can be the primary repository of detailed history of NE-specific faults and events, technician action, and performance data.

The steps for successful fault management are:
1. Identify a problem by gathering data about the state of the network (polling and trap generation).
2. Restore any services that have been lost.
3. Isolate the cause, and decide if the fault should be managed.
4. Correct the fault if possible.

### 9.1.1 What the NE Provides

NEs can provide the following information that is required for effective fault management:

Currently deployed, intelligent NEs provide the management system with the following, which are required for effective fault management:

- Detection of the four main types of failure:
  - Equipment failure—Detected through failure detection mechanisms built into the hardware, and through routine exercises and diagnostics.
  - Software failure—Detected through failure of software checks, and through routine audits.
  - Communications failure—Detected through defects in the incoming signal or communicated from the distant end of a trail in an embedded operations channel by the signal processing chip sets, and through continuous or periodic measurements of incoming and outgoing signal characteristics. Defects include line coding errors, framing bit errors, parity errors, cyclic redundancy check errors, and addressing errors. Signal characteristics include, optical or electrical power, analog signal to noise ratio, and deviation from required voltage or wavelength.
  - Environmental failure—Defects could include power faults such as overheating.
- Notification of failure—NEs notify Cisco MGM when a failure occurs by generating an alarm report. The NE can also report a summary of current fault states, or replay its log of historical failures and clears.
- Notification of changes in the operational state of the NE's components—If a component of the NE is in the fault state, then Cisco MGM should not receive (or expect to receive) further alarms, alerts, or scheduled performance data from that component if the alarm is not cleared.

Cisco MGM forwards information northbound and integrates with other third party management systems to give options not directly available in Cisco MGM.

### 9.1.2 Fault Notification and Maintenance

Fault notification and maintenance can be proactive or reactive:

- Proactive notification—Where X notifies Y of a problem regarding a service delivered from X to Y.
- Reactive maintenance—Where Y contacts X to query X on potential problems in X’s domain.
9.1.2.1 Proactive Maintenance

Automated detection tests and surveillance software enable rapid initiation of the repair process, sometimes even before customers have noticed a problem. This is called proactive maintenance and promotes customer satisfaction.

Proactive maintenance consists of functions and processes associated with the detection, analysis, isolation, and resolution of problems by means that are independent of customer trouble reports. The problems may be faults or degradations in equipment or transmission media.

The goals of proactive maintenance are to:

- Detect and fix service quality problems before the customer calls to establish a trouble report (ideally), or at least to start the repair process before the customer calls, thereby minimizing the time, as perceived by the customer, before service is restored.
- Maintain the transport network at a high level of quality by identifying the facilities that perform relatively poorly and rehabilitating them.

9.1.2.2 Reactive Maintenance

Reactive maintenance is required when a failure occurs. This type of problem can be time-consuming and costly. It requires accurate administration of trouble reports, rapid analysis and repair of service affecting faults, and notifications to customers of restoration of service, all of which also promote customer satisfaction.

9.1.3 Root Cause Analysis

The root cause is the most basic reason for an undesirable condition or problem that, if eliminated or corrected, would have prevented the problem from existing or occurring. The outcome of the root cause analysis is not a restatement of the most obvious symptom, but is the result of a methodical analysis of the problem situation, leading to the most basic cause.

Root cause analysis captures additional information about defects for the purpose of identifying preventive actions.

Cisco MGM includes advanced debugging features which capture additional information about defects.

9.2 Where Can I Get Information on Affected Services and Customers?

The first thing to do in fault management is to identify what services and which customers are affected by the fault. Cisco MGM provides a number of options for viewing this information, including:

- 9.2.1 Dashboard
- 9.2.2 Tooltips
- 9.2.3 Domain Explorer
- 9.2.4 Alarm Browser
- 9.2.5 Network Map
- 9.2.6 Diagnostic Center
Then you need to identify the alarms:

- **9.3.1 How Are Alarms Displayed?**

When a module is under maintenance, you can suppress the alarms so that they are not displayed on the Cisco MGX Alarm or History tab or on any other client:

- **9.3.2 Suppressing Alarms**

### 9.2.1 Dashboard

The Dashboard shows useful alarm and NE information in one easily accessible location. See Figure 9-1.

**Figure 9-1 Dashboard**

- Returns you to the Domain Explorer, Cisco MGM home window.
- Opens the Alarm Browser.
- Opens a filtered Alarm Browser that shows EMS generated alarms in the domain. Enabled only if the user has Read/Write permission on the "Show Cisco MGM EMS Alarms/Events" operation.
- Indicates the total number of NEs in the domain. When you click on the NE count, the Domain NE Table appears.
- Indicates the total number of critical, major, minor, warning, and unacknowledged alarms on NEs in the domain and on Cisco MGM. The box outline indicates a change in Cisco MGM status. If you click on a specific severity alarm count, the alarm browser is displayed and filtered to show alarm information corresponding to the alarm severity selected.
- Server number
- If the pushpin is down, the dashboard is not brought in front of all windows when there is an alarm count change. If the pushpin is up, the dashboard is brought in front of all windows when there is an alarm count change.
- When blinking, indicates that alarm count or NE count has changed.
- Displays online help.
- Closes the dashboard.
- Restores the windows.
- Minimizes all other Cisco MGM windows from the display.
9.2.2 Tooltips

A tooltip appears with the actual alarm counters when the cursor is positioned over a managed object (domain, group, NE, or board). The tooltip displays a count for each of the following severities:

- CR—Critical
- MJ—Major
- MN—Minor
- WR—Warning
- UA—Total number of alarms unacknowledged

9.2.3 Domain Explorer

The Domain Explorer is the home window and provides a logical view of the network plus alarm, connectivity, and operational status. (See Figure 9-2.) It is divided into two sections:

- Hierarchy pane—Consists of the different components, which appear in a hierarchical format. The top level of the hierarchy is the management domain, followed by groups, and then NEs. Groups and NEs may be repositioned in the hierarchy using either cut/paste or drag and drop operation. Groups and NEs can exist in multiple locations in the tree.
- Property sheet—Displays information about the component selected in the Hierarchy pane. There are three property sheets: Management Domain Properties, Group Properties, and Network Element Properties.
SuperUsers or Network Administrators use the Domain Explorer to create groups of NEs and to organize the domain in a hierarchy. By default, the Domain Explorer contains the following groups that are visible to SuperUsers and Network Administrators only:

- **Discovered NEs**—Contains NEs that have been automatically discovered by the server. Discovered NEs are added to the Discovered NEs group by default and then managed automatically. Refer to the “4.2.4 Network Element Discovery” section on page 4-7 for more information on discovery service.

- **Deleted NEs**—Contains NEs that have been deleted. An NE appears in this group only when the last instance of that NE has been deleted.

- **Lost and Found**—The client performs a minimal check at initialization to verify that the tree representation for the administrator’s domain is valid. If there are any mismatches between the groups and NEs in the domain and those in the administrator’s domain, the mismatched NEs or groups are shown in the Lost and Found group in the Domain Explorer Hierarchy pane. If the administrator moves the NEs or groups in the Lost and Found group to another group and then clicks **Refresh Data** or restarts the client, the Lost and Found group disappears.

**Note**

The Discovered NEs, Deleted NEs, or Lost and Found groups may not be deleted or renamed.

**Note**

The server time is displayed on the lower right side of the Domain Explorer.
Note
Clicking **Refresh Data** in the Domain Explorer window refreshes all data for the entire client and closes all open windows (except the Domain Explorer window). Depending on the number of NEs in the network, there might be some delay while the data refreshes. The status bar shows the status after the Domain Explorer refreshes. It will show “Refresh Data Complete.”

The Fault menu and associated toolbar tools are listed next to their corresponding menu options in [A.3.3 Fault Menu](#).

### 9.2.4 Alarm Browser

The Alarm Browser displays standing alarms and conditions in the managed domain that are assigned a severity level of critical, major, minor, or warning. It also shows cleared alarms that are not acknowledged. See Figure 9-3. The Alarm Browser and Alarm Log views provide a robust listing of all current and historical alarms and events. See the “9.9.1 Archiving Alarm Log” section on page 9-50 for more information about the Alarm Log.

To display the Alarm Browser, select an NE, group, or domain node from the Domain Explorer, or Network Map; then, choose **Fault > Alarm Browser** (or click the Open Alarm Browser tool from the Dashboard). Use the toolbar buttons to manage the alarm display. These buttons are described in “A.3.1 File Menu” section on page A-7.

![Alarm Browser](image)

**Figure 9-3** Alarm Browser

Table 9-1 provides descriptions of the fields in the Alarm Browser.

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm Type</td>
<td>Critical</td>
</tr>
<tr>
<td>Acknowledged</td>
<td>No</td>
</tr>
<tr>
<td>Source</td>
<td>Secondary Confirmed present</td>
</tr>
<tr>
<td>Probable Cause</td>
<td>Critical alarm aggregate alarm</td>
</tr>
<tr>
<td>Affected Object</td>
<td>Secondary Confirmed present</td>
</tr>
<tr>
<td>Module Name</td>
<td>MXMG Stat</td>
</tr>
<tr>
<td>Physical Location</td>
<td>Slot 1</td>
</tr>
<tr>
<td>Status</td>
<td>OK</td>
</tr>
</tbody>
</table>

Table 9-1 provides descriptions of the fields in the Alarm Browser.
## Where Can I Get Information on Affected Services and Customers?

Table 9-1  **Field Descriptions for the Alarm Browser Window**

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm ID</td>
<td>Indicates the unique number that the system uses to identify a particular alarm.</td>
</tr>
<tr>
<td>Perceived Severity</td>
<td>Displays the perceived severity of the selected alarm (critical, major, minor, or warning). The background color also indicates the severity, where:</td>
</tr>
<tr>
<td></td>
<td>- Red = Critical&lt;br&gt;- Orange = Major&lt;br&gt;- Yellow = Minor&lt;br&gt;- Cyan (blue-green) = Warning&lt;br&gt;- Green = Cleared</td>
</tr>
<tr>
<td>Acknowledged</td>
<td>Indicates whether the selected alarm has been acknowledged by the user. Values are Yes and No.</td>
</tr>
<tr>
<td>Note</td>
<td>Displays any notes that were entered for the selected alarm. This field also shows the login name of the user who entered the note and the time when the note was entered.</td>
</tr>
<tr>
<td>Source ID</td>
<td>Displays the name of the network element where the selected alarm occurred.</td>
</tr>
<tr>
<td>Probable Cause</td>
<td>Displays the probable cause of the selected alarm. Displays Not Applicable/Unknown if no additional information is available.</td>
</tr>
<tr>
<td>Affected Object</td>
<td>Displays the name of the object where the selected alarm occurred.</td>
</tr>
<tr>
<td>Module Name</td>
<td>Displays the name of the module where the selected alarm occurred.</td>
</tr>
<tr>
<td>Physical Location</td>
<td>Displays the physical location of the equipment where the selected alarm occurred, such as slot, and port numbers.</td>
</tr>
<tr>
<td>Alarm Time Stamp</td>
<td>Displays the date and time when the alarm occurred on the server.</td>
</tr>
<tr>
<td>NE Alarm Time Stamp</td>
<td>Displays the date and time when the alarm occurred on the NE.</td>
</tr>
<tr>
<td>Service Affecting</td>
<td>Indicates whether the alarm condition is service affecting (SA); values are Yes and No.</td>
</tr>
<tr>
<td>Clear Time Stamp</td>
<td>Displays the date and time when the alarm was cleared on the server.</td>
</tr>
<tr>
<td>NE Clear Time Stamp</td>
<td>Displays the date and time when the alarm was cleared on the NE.</td>
</tr>
<tr>
<td>Acknowledged Time Stamp</td>
<td>Displays the date and time when the user acknowledged the selected alarm.</td>
</tr>
<tr>
<td>Acknowledged Username</td>
<td>Displays the login name of the user who acknowledged the selected alarm.</td>
</tr>
<tr>
<td>Alarm Status</td>
<td>Displays the status of the selected alarm (active or cleared).</td>
</tr>
<tr>
<td>Description</td>
<td>Displays additional information about the selected alarm. If there is no additional information, this field is blank.</td>
</tr>
</tbody>
</table>
9.2.5 Network Map

The Network Map window displays a geographical layout of the network. (See Figure 9-4.) It consists of three areas:

- The right side displays a map with the individual groups and NEs icons.
- The upper left side displays the position of the map on the right side with respect to a larger world map.
- The lower left side displays the NE, or group properties, including the number of alarms and ID.

A Network Map window can be opened for an NE, group, or the domain. Select a node in the Domain Explorer Hierarchy pane and choose File > Network Map (or click the Open Network Map tool).

The Network Map is organized into a multilevel hierarchy that corresponds to the structure of the Domain Explorer when launched from the respective window. The Network Map hierarchy consists of management domains, groups, and NEs, that are represented by icons plotted automatically in a map. Zooming capabilities are provided and the node positions, node icons, and background map images can be customized.

Figure 9-4 Network Map
9.2.6 Diagnostic Center

The Diagnostic Center provides a hierarchical representation of network elements, which include networks, nodes, cards, lines and ports displayed in tree format in the Hierarchy pane of the Diagnostic Center's main window. Associated information about a selected network element is displayed in table format in the right panel of the Diagnostic Center window (See Figure 9-5).

Each network element managed by Cisco MGM has its own attributes and fits into the network’s physical or logical hierarchy. The Diagnostic Center presents the network elements that are discovered, managed, and controlled in a hierarchical view for all networks populated in the tables by Cisco MGM processes.

The Diagnostic Center displays the network elements in a hierarchical format based on either a physical or logical relationship among the various network elements. Networks are displayed at the root level of the component tree; nodes are displayed beneath the networks in a parent/child relationship.

The Diagnostic Center also displays informational messages in a multiline text display; other types of messages can be displayed in response to user actions.

The Diagnostic Center can be opened for an NE, group, or the domain. Select a node in the Domain Explorer Hierarchy pane and choose Fault > MGX8880/8850 MG > Diagnostic Center.

The Diagnostic Center has two access tabs:

- Diagnostic—Displays the diagnostic status and test results for the network elements.
- Manageability—Monitors the statistics events for network manageability

The Diagnostic Center allows users to:

- Diagnose network elements, for example, networks, nodes, cards, lines, ports, or paths. By diagnosing network elements, you can:
  - Monitor real-time counters.
  - Extend support for the Node Resync process to allow for two different levels.
  - Configure bit error rate test (BERT) to verify the integrity of a network element by measuring error statistics.

- Monitor statistic events for network manageability to collect element management health-related statistics. In addition, you can:
  - Verify that all the nodes in the network are managed correctly by Cisco MGM.
  - Identify general network problems.
  - Provide success rates, failure rates, and throughput of Cisco MGM to protocols such as FTP, and SNMP.
  - Create a trouble ticket that extracts all the information from the History Panel.

- Diagnose connections to:
  - Access fault management capabilities in the form of diagnostic tests for connections, which include continuity (integrity) facility for PNNI soft permanent virtual connection (SPVC).
  - Perform general test operations such as up and down connections, and connection loopback.
9.3 What Fault Information Can I See?

An alarm is represented by a notification from a managed NE that a certain condition has just occurred. These alarms usually represent error conditions on NEs. Each alarm is associated with the NE for which it provides notification, and an NE can have a number of alarms related to itself at any time.

Each NE shown in the Domain Explorer Hierarchy pane has a corresponding alarm icon that indicates the highest severity alarm that affects the NE. Management domain nodes and group nodes have alarm icons that reflect the highest alarm condition of the NEs contained in the domain or group.

The user-defined Domain Explorer Network views have “bubble-up” alarm severity propagation and drill-down capabilities to isolate fault conditions and to identify service-delivery impact.

In Cisco MGM you can see:

- 9.3.1 How Are Alarms Displayed?

There are occasions when it is useful to control the alarm display:

- 9.3.2 Suppressing Alarms
9.3.1 How Are Alarms Displayed?

Each node displays an icon, which uses an industry-standard color scheme that indicates the current alarm status. The multicolor displays are updated in real-time in response to events occurring in the network. Icons representing network nodes change color dynamically to reflect the status of the node, which allows rapid recognition of network faults as they occur.

In the Diagnostic Center, Configuration Center, Chassis View, and Statistics Report, you can display the color legend for alarms, choose **Help > Color Legend**.

Table 9-2 lists the color legend for alarms.

<table>
<thead>
<tr>
<th>Color</th>
<th>Alarm State</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Clear</td>
</tr>
<tr>
<td>Yellow</td>
<td>Minor</td>
</tr>
<tr>
<td>Orange</td>
<td>Major</td>
</tr>
<tr>
<td>Red</td>
<td>Critical</td>
</tr>
<tr>
<td>Grey</td>
<td>Unmanaged</td>
</tr>
<tr>
<td>Blue</td>
<td>Unknown</td>
</tr>
<tr>
<td>Purple</td>
<td>LineHasLoopback</td>
</tr>
</tbody>
</table>

You can set the Alarm Browser or Alarm Log to display full background color for the entire selected row. The color corresponds to the alarm status and severity. In the Domain Explorer window, choose **Edit > User Preferences**. The User Preferences dialog box appears. On the FM Preferences tab, check the **Color Entire Row in Table View** check box.

In the Dashboard, Map Viewer, Alarm Browser, and the Domain Explorer, the color of the border surrounding a component, or the background color, indicates the operational status of the component. When status changes, the border or the background color changes as indicated in Table 9-3.

<table>
<thead>
<tr>
<th>Color</th>
<th>Severity</th>
<th>Meaning</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Cleared</td>
<td>Component is active.</td>
<td>The component is operating normally.</td>
</tr>
<tr>
<td>Yellow</td>
<td>Minor</td>
<td>Minor failure.</td>
<td>The component is down; both administrative and operational values are down. This does not necessarily indicate a fault condition; the component might be disabled.</td>
</tr>
<tr>
<td>Orange</td>
<td>Major</td>
<td>Component is down.</td>
<td>Administrative status is up and operational value is down.</td>
</tr>
<tr>
<td>Red</td>
<td>Critical</td>
<td>Component failed.</td>
<td>Physical hardware failure.</td>
</tr>
<tr>
<td>Cyan (blue-green)</td>
<td>Warning</td>
<td>Interface is dormant.</td>
<td>The interface cannot pass packets, but is in a pending state waiting for some external event to place it in the up state. The interface might have packets to transmit before establishing a connection to a remote system, or a remote system might be establishing a connection to the interface. When the pending event occurs, the interface changes to the up state.</td>
</tr>
</tbody>
</table>
9.3.2 Suppressing Alarms

Suppressing alarms prevents alarms from appearing on the Cisco MGX Alarm or History tab or on any other clients. Alarms are suppressed when the NE is under maintenance. See 5.3.1 Changing the Operational State of an NE.

9.4 Is the Service Working?

Network devices will report symptoms of problems by generating events. An event in this context is a message indicating that a device or application in your network has discovered something of note. The network devices will generate many types of events automatically.

In addition, you can use thresholds to define or modify the conditions under which events are generated. A threshold is a trigger, set up on a continuous data stream, that is a point of interest that generates events when that point is satisfied.

The events generated need to be analyzed to determine whether they represent a fault condition or problem in your network.

It is important to generate events when there is a problem in the EMS. It is also important to limit the number of events generated to prevent an excessive load on the network. The EMS performs a number of self-monitoring tasks where threshold limits can be set. The threshold limits are set in the Self Monitor Table. If one of these thresholds is crossed, then an EMS alarm will be generated.

The user can obtain information regarding how the system is performing and how long certain tasks are taking to complete by selecting Administration > Control Panel then Alarm Configuration > Threshold EMS Alarms or Alarm Configuration > Non-Threshold EMS Alarms. (See 9.4.3 Setting Up and Viewing Alarm Configuration Parameters.) By monitoring this data, you can identify potential system problems before they become critical in the operation of the EMS. Associated with each parameter that is monitored are three alarm thresholds. The administrator can set a minor, major, and critical threshold value for each parameter. If any of these thresholds are crossed, then an alarm will be raised to provide notification of the situation.

Threshold alarms are raised when their limit exceeds the value set for Critical, Major, Minor, or Warning thresholds. For example, you can set threshold alarms for disk usage for 90%, 80%, 70%, and 60%, meaning a warning alarm is raised when the disk becomes 61% full and a critical alarm is raised when the disk becomes 91% full. The server checks these parameters at every polling interval that is set in the Poll Frequency field.

Non-threshold alarms do not have an alarm threshold. Instead, non-threshold alarms occur when a condition occurs, such as loss of connectivity to an NE. Use the Non-Threshold EMS Alarms tab to set the severity level (critical, major, minor, or warning) for which a non-threshold alarm should be raised when that condition occurs.

Caution

Changing the EMS alarm severities can affect the alarm status seen by listeners on the EMS's OSS interfaces.

The following sections provide information on network elements:

- 9.4.1 Viewing Service Status
- 9.4.2 Viewing Alarms
- 9.4.3 Setting Up and Viewing Alarm Configuration Parameters
9.4.1 Viewing Service Status

You can monitor the different services that run on the server. To view service status, choose Administration > Service Monitor in the Domain Explorer window. The Service Monitor Table appears and displays the status of the services that are currently running on the server. The table displays the following information:

- Service Name—Name of the service
- Logged In At—Time that the user last logged in
- IP Address—IP address of the service
- Session ID—Unique session ID

Note: The showmgm command from the CLI is an alternate way of viewing processes or services that are currently running on the server.
9.4.2 Viewing Alarms

The Alarm Browser has a specific selection context, which means that it displays alarm information that corresponds to the view where it was launched. If you launch the Alarm Browser from the management domain node, the browser shows all NE alarms, and all EMS alarms (if you have permission to see EMS alarms). If you launch the Alarm Browser from a group, or NE node, the browser shows only NE alarms for that group, or NE node. If you launch the Alarm Browser from the Dashboard, the browser shows all NE alarms for the domain.

The Alarm Log window shows alarms that have transitioned from the Alarm Browser. Cleared alarms are transitioned when you acknowledge them or when automatic acknowledgment has been enabled. In addition, the Alarm Log shows a history of cleared and acknowledged alarms and all transient conditions (also known as events or autonomous nonalarmed messages).

You can locate the equipment for an existing alarm in the Domain Explorer, choose Fault > Alarm Browser or Fault > Alarm Log (or click the Open Alarm Browser or Open Alarm Log tool).

9.4.3 Setting Up and Viewing Alarm Configuration Parameters

The Alarm Configuration property sheet allows you to configure alarm severities for system parameters. The Self Monitor Table displays information about threshold parameters. These parameters are collected and evaluated based on the NE model types. To set up and view alarm configuration parameters:

---

**Step 1**

In the Domain Explorer window, choose Administration > Control Panel.

Click Alarm Configuration to open the Alarm Configuration property sheet. The Threshold EMS Alarms tab displays the information detailed in Table 9-4:
Table 9-4  Alarm Configuration—Threshold EMS Alarms Tab

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Poll Frequency</td>
<td>Displays the polling interval, in minutes, at which the Cisco MGM server checks parameters.</td>
</tr>
</tbody>
</table>
| Parameter Name     | This column displays the name of the parameter as follows:  
  - CPU Usage (%): Percentage of CPU time utilized for executing user, system, and I/O tasks.  
  - Config Resynch Time (seconds): Time it takes for Cisco MGM to collect alarm and inventory information from the NE.  
  - Disk Usage (%): Percentage of disk space used in a particular partition. Cisco MGM database and partitions are monitored separately.  
  - Memory Usage RAM (%): Percentage of RAM memory used for all processes of the system.  
  - Memory Usage SWAP (%): Percentage of SWAP memory used for all processes of the system.  
  - NE Synch Time (seconds): Time it takes to synchronize Cisco MGM server with the NEs.  
  - PM Collection Time (seconds): Time it takes to collect PM data for an NE. It is the sum of the time it takes to read the PM data and the time it takes to update the database.  
  - Prune Time Audit Log (seconds): Time it takes to prune audit log data.  
  - Prune Time Audit Trail Log (seconds): Time it takes to prune audit trail log data.  
  - Prune Time Error Log (seconds): Time it takes to prune Error Log data.  
  - Prune Time FM (seconds): Time it takes to prune FM data.  
  - Prune Time Job Monitor (seconds): Time it takes to prune job monitor data.  
  - Prune Time PM (seconds): Time it takes to prune PM data.  
  - Prune Time Purge NE (seconds): Time it takes to prune NE purge data.  
  - Prune Time Server Monitor (seconds): Time it takes to prune server monitor data. |
| Enable             | This column displays whether or not the corresponding parameter in the Parameter Name column is enabled (checked) or disabled (unchecked). When checked, it enables monitoring for the selected parameter. If an EMS threshold alarm is outstanding when you disable monitoring, the EMS clears the alarm. |
| Critical           | This column displays the amount of time, in minutes, that must elapse before triggering a critical alarm.                               |
| Major              | This column displays the amount of time, in minutes, that must elapse before triggering a major alarm.                               |
| Minor              | This column displays the amount of time, in minutes, that must elapse before triggering a minor alarm.                              |
### Step 2
In the **Non-Threshold EMS Alarms** tab, you can select the severity level that will be assigned to the non-threshold alarm parameter. See Table 9-5 for details.

#### Table 9-5  
**Alarm Configuration—Non-Threshold EMS Alarm Tab**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter Name</td>
<td>The Parameter Name column displays the following parameters:</td>
</tr>
<tr>
<td></td>
<td>• Loss of Communication</td>
</tr>
<tr>
<td></td>
<td>• Memory Auto or Manual Backup Failure</td>
</tr>
<tr>
<td></td>
<td>• Maximum Login Attempts Exceeded</td>
</tr>
<tr>
<td></td>
<td>• Alarm Resync Unsuccessful</td>
</tr>
<tr>
<td></td>
<td>• Cisco MGM failed authentication by NE</td>
</tr>
<tr>
<td></td>
<td>• A critical process is hanging, Cisco MGM will shut down in 5 minutes</td>
</tr>
<tr>
<td></td>
<td>• Communication through Secondary IP Address</td>
</tr>
<tr>
<td></td>
<td>• Sync-Up has not started yet</td>
</tr>
<tr>
<td></td>
<td>• Currently in Sync-Up</td>
</tr>
<tr>
<td></td>
<td>• Partial Sync-Up</td>
</tr>
<tr>
<td></td>
<td>• Sync-Up Failed</td>
</tr>
<tr>
<td></td>
<td>• Server in Partial Sync-Up</td>
</tr>
<tr>
<td></td>
<td>• Server Sync-Up Failed</td>
</tr>
<tr>
<td></td>
<td>• FTP Transfer failure</td>
</tr>
<tr>
<td></td>
<td>• FTP file size mismatch</td>
</tr>
<tr>
<td></td>
<td>• FTP transfer failed</td>
</tr>
<tr>
<td></td>
<td>• Upload File Error</td>
</tr>
<tr>
<td></td>
<td>• Minus 2 Trap</td>
</tr>
<tr>
<td></td>
<td>• Card Lost Trap</td>
</tr>
<tr>
<td></td>
<td>• SNMP Retry exceeded</td>
</tr>
<tr>
<td></td>
<td>• FTP Retry exceeded</td>
</tr>
</tbody>
</table>
Is the Service Working?

Step 3

Click Save.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter Name</td>
<td>• Sync-up Failed&lt;br&gt;• Stats File Error&lt;br&gt;• Stats File Transfer Error&lt;br&gt;• SNMP Throttle Error&lt;br&gt;• Backoff failed&lt;br&gt;• SNMP timeout&lt;br&gt;• FTP Session timeout&lt;br&gt;• FTP Transfer timeout&lt;br&gt;• Unknown Error&lt;br&gt;• Initialization Error&lt;br&gt;• Configuration Error&lt;br&gt;• Communication Error in ILOG&lt;br&gt;• Communication Error in shared memory&lt;br&gt;• Communication Error in CORBA&lt;br&gt;• NTS Registration failed&lt;br&gt;• NTS Trap loss&lt;br&gt;• DataBroker Sync-Up Complete&lt;br&gt;• Process Restarted&lt;br&gt;• PM Fail EMS Alarm&lt;br&gt;• PM Lost EMS Alarm</td>
</tr>
<tr>
<td>Severity</td>
<td>Allows you to click in the appropriate cell and select the alarm severity level from the available options (Critical, Major, Minor, or Warning) for each of the corresponding parameters listed in the Parameter Name column. If an EMS alarm is outstanding when you change its severity, the outstanding EMS alarm’s severity remains the same. The next time the alarm is raised, the severity changes to the new setting.</td>
</tr>
</tbody>
</table>

9.4.4 Displaying the Status of all Nodes in the Network

To display the status of all nodes in the network:

Step 1

In the Diagnostic Center, click the Elements tab, and double-click or drag the network to the right hand pane to display the diagnostics at the network level. By default, the Diagnostics tab is selected in the right hand pane.
Step 2  The status of the following attributes at the network level are displayed:

- Node ID
- Node Name
- Current sync status of all the nodes of the network
- All out-of-sync nodes in the network
- A total of partially synced and failed synced nodes

9.4.5 Displaying the Status of a Node

To display the status of a node:

Step 1  In Diagnostic Center, click the Elements tab, and double-click or drag the node to the right hand pane to display the diagnostics at the node level. By default, Diagnostics tab is selected in the right hand pane.

Step 2  Verify the status of the following attributes at the node level:

- Current sync status of the node
- All out-of-sync cards in the node
- Node level statistics if applicable

9.4.6 Displaying the Status of a Card

Depending on the type of card, you can perform one or all of the functions from the following tabs:

- Paths in Loopback—Displays the paths in the loopback. (See 9.4.10 Displaying the Paths in Loopback for the VXSM-OC3 Card.)
- Lines in Loopback—Displays all lines that currently have loopback running. (See 9.4.12 Displaying the Lines in Loopback for the Voice Cards.)
- VXSM Features—Displays details of the Media Gateway Links, CIDs, RUDP Sessions, and XGCP MGC. (See 9.4.13 Managing the Status for the VXSM Features.)
- Running Berts—Display all lines that currently have a Bit Error Rate Test (BERT) running. (See 9.4.11 Displaying the Status for a Bit Error Rate Test for the Voice Cards.)

To display the status of a card:

Step 1  In the Diagnostic Center, click the Elements tab, and double-click or drag the card from the Hierarchy pane to the right hand pane to display the diagnostics at the card level.

Step 2  Verify the status of the attributes at the card level.

Step 3  Click Refresh to update the Card Diagnostics window.
### 9.4.7 Displaying the Status for Lines or Ports

To display the status for lines or ports:

**Step 1**  
In the Diagnostic Center, click the Elements tab, and double-click or drag the line or port from the Hierarchy pane to the right hand pane to display the diagnostics at the line or port level. See Figure 9-6. Depending upon the card type, you can also configure Bit Error Rate Test (BERT). For more information, see 9.4.17 Configuring Bit Error Rate Test.

You can also see if a line is in loopback. See 9.4.9 Displaying the Status for Lines in a Loopback.

**Step 2**  
Click the Delta Mode radio button or Absolute Mode radio button. See Table 9-6.

**Step 3**  
Choose the polling interval time from the Poll Interval (Sec) drop-down arrow.

**Step 4**  
Verify the statistics name and statistics value.

Appendix E, “Real-Time Counters” gives details of the real-time counters displayed in the Diagnostic Center.

Appendix D, “Statistics Summary” gives details of the statistics that are collected from the Cisco MGX 8880 and Cisco MGX 8850.

**Step 5**  
Check the Poll All check box to initiate polling for the statistics. To select individual counters for polling, check the counter check box.

<table>
<thead>
<tr>
<th>Table 9-6 Diagnostic Center—Delta Mode and Absolute Mode Radio Buttons</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Radio Button</strong></td>
</tr>
<tr>
<td>Delta Mode</td>
</tr>
<tr>
<td>Absolute Mode</td>
</tr>
</tbody>
</table>
9.4.8 Displaying the Status for Paths in a Loopback for the VXSM-OC3 Card

To display the paths for a loopback for the VXSM-OC3 card:

Step 1  In the Diagnostic Center, click the Elements tab, and double-click or drag the card from the Hierarchy pane to the right hand pane to display the diagnostics at the path level.

Step 2  Click the Paths In Loopback tab.

Step 3  Verify the following parameters for the path:
- Path Id
- Path Type
- Loopback Type

Step 4  Click Refresh to update the settings for the Path Diagnostics window.
9.4.9 Displaying the Status for Lines in a Loopback

To display the lines for a loopback:

**Step 1** In the Diagnostic Center, click the Elements tab, and double-click or drag the card from the Hierarchy pane to the right hand pane to display the line in the loopback.

**Step 2** Click the **Lines In Loopback** tab.

**Step 3** Verify the following parameters for the line:
- Line Number
- Loopback Type

**Step 4** Click **Refresh** to update the settings for the Line Diagnostics window.

9.4.10 Displaying the Paths in Loopback for the VXSM-OC3 Card

To display the paths in loopback for the VXSM-OC3 card for both SONET and SDH lines:

**Step 1** In the Diagnostic Center, click the Elements tab, and double-click or drag the VXSM-OC3 card from the Hierarchy pane to the right hand pane to display the diagnostics at the card level. See Figure 9-7.

**Step 2** Click the **Paths In Loopback** tab.

**Step 3** Verify the following parameters for the path:
- Path Id
- Path Type
- Loopback Type

**Step 4** Click the **Delta Mode** radio button or **Absolute Mode** radio button. See Table 9-6.

**Step 5** Choose the polling interval time from the **Poll Interval (Sec)** drop-down arrow.

**Step 6** Verify the statistics name and statistics value for the real-time counters.

**Step 7** Check the **Poll All** check box to initiate polling for the statistics. To select individual counters for polling, check the counter check box.

**Step 8** Click **Refresh** to update the settings for the paths in loopback for the VXSM-OC3 card for both SONET and SDH lines.
### 9.4.11 Displaying the Status for a Bit Error Rate Test for the Voice Cards

You can setup BERT options on the looped back connection and use the available test patterns displayed in the BERT Configuration window. See 9.4.17 Configuring Bit Error Rate Test

To display the status for a BERT for the VXSM card for a T1E1 line and VISM-PR cards:

**Step 1** In the Diagnostic Center, click the Elements tab, and double-click or drag the VXSM-48T1E1 card or VISM-PR card from the Hierarchy pane to the right hand pane to display the diagnostics at the card level. See Figure 9-8.

**Step 2** Click the Running Berts tab.

**Step 3** Verify the following parameters for the BERT test:

- Entity Id
- Entity Type
- Operation Status
- Bits Received
- Bits Received (Wrap Count)
- Bits Received In Error
- Bits Received In Error (Wrap Count)
Step 4  Click the **Delta Mode** radio button or **Absolute Mode** radio button. See Table 9-6.

Step 5  Choose the polling interval time from the **Poll Interval (Sec)** drop-down arrow.

Step 6  Verify the statistics name and statistics value for the real-time counters.

Step 7  Check the **Poll All** check box to initiate polling for the statistics. To select individual counters for polling, check the counter check box.

Step 8  Click **Refresh** to update the settings for the lines in loopback for VXSM.

---

**9.4.12 Displaying the Lines in Loopback for the Voice Cards**

To display the lines in loopback for the VXSM card for both SONET and T1E1 lines and the VISM-PR cards:

Step 1  In the Diagnostic Center, click the Elements tab, and double-click or drag the VXSM or VISM-PR card from the Hierarchy pane to the right hand pane to display the diagnostics at the card level. See Figure 9-7.

Step 2  Click the **Lines In Loopback** tab.
Step 3  Verify the following parameters for the path:
  • Line Number
  • Loopback Type

Step 4  Click the Delta Mode radio button or Absolute Mode radio button. See Table 9-6.

Step 5  Choose the polling interval time from the Poll Interval (Sec) drop-down arrow.

Step 6  Verify the statistics name and statistics value for the real-time counters.

Step 7  Check the Poll All check box to initiate polling for the statistics. To select individual counters for polling, check the counter check box.

Step 8  Click Refresh to update the settings for the lines in loopback for VXSM.

9.4.13 Managing the Status for the VXSM Features

These tasks are used to manage the status for the VXSM features:
  • 9.4.13.1 Displaying the Status for Media Gateway Links for the Voice Cards
  • 9.4.13.2 Displaying the Status for Reliable User Datagram Protocol for the Voice Cards
  • 9.4.13.3 Displaying the Status for Xternal Gateway Control Protocol for the Voice Cards

9.4.13.1 Displaying the Status for Media Gateway Links for the Voice Cards

Note
A session of the type of object must be available before it can be polled.

To display the Media Gateway Links (MGL) for voice cards for both SONET and T1E1 lines:

Step 1  In the Diagnostic Center, click the Elements tab, and double-click or drag the VXSM card from the Hierarchy pane to the right hand pane to display the diagnostics at the card level.

Step 2  Click the VXSM Features tab and choose Media Gateway Links from the drop-down box.

Step 3  Verify the following parameters for the path:
  • Gateway Link ID
  • Gateway IP Address
  • Gateway Port
  • Control Protocol
  • Gateway Link Operational State

Step 4  Click the Delta Mode radio button or Absolute Mode radio button. See Table 9-6.

Step 5  Choose the polling interval time from the Poll Interval (Sec) drop-down arrow.
Step 6 Verify the statistics name and statistics value for the real-time counters.

Step 7 Check the Poll All check box to initiate polling for the statistics. To select individual counters for polling, check the counter check box.

Step 8 Click Refresh to update the settings for the Media Gateway Links for VXSM.

### 9.4.13.2 Displaying the Status for Reliable User Datagram Protocol for the Voice Cards

**Note** A session of the type of object must be available before it can be polled.

To display the Reliable User Datagram Protocol (RUDP) for VXSM card for both SONET and T1E1 lines:

**Step 1** In the Diagnostic Center, click the Elements tab, and double-click or drag the VXSM card from the Hierarchy pane to the right hand pane to display the diagnostics at the card level. See Figure 9-9.

**Step 2** Click the VXSM Features tab and choose the RUDP Sessions option from the drop-down arrow.

**Step 3** Verify the following RUDP session parameters:

- **RUDP Session Number**—Specifies the session group where the group belongs. One group has a maximum of four sessions. The range is from 1-64.
- **State**—Specifies the following RUDP session states:
  - oos—Out of Service. When an RUDP session is created, the session state is oos.
  - Is—in Service. The state is changes to Is after the VXSM sent a start message to the MGC. The message is sent after a channel is created between the VXSM and the MGC.
  - unknown
- **Local IP**—Specifies the IP address of the local VXSM.
- **Remote IP**—Specifies the IP address of the remote VXSM.

**Step 4** Click the Delta Mode radio button or Absolute Mode radio button. See Table 9-6.

**Step 5** Choose the polling interval time from the Poll Interval (Sec) drop-down arrow.

**Step 6** Verify the statistics name and statistics value for the real-time counters.

**Step 7** Check the Poll All check box to initiate polling for the statistics. To select individual counters for polling, check the counter check box.

Appendix E, “Real-Time Counters” gives details of the real-time counters displayed in the Diagnostic Center.

Appendix D, “Statistics Summary” gives details of the statistics that are collected from the Cisco MGX 8880 and Cisco MGX 8850.

**Step 8** Click Refresh to update the settings for the RUDP sessions for VXSM.
9.4.13.3 Displaying the Status for Xternal Gateway Control Protocol for the Voice Cards

**Note**
A session of the type of object must be available before it can be polled.

To display the Xternal Gateway Control Protocol (XGCP) for VXSM card for both SONET and T1E1 lines:

**Step 1** In the Diagnostic Center, click the Elements tab, and double-click or drag the VXSM card from the Hierarchy pane to the right hand pane to display the diagnostics at the card level. See Figure 9-9.

**Step 2** Click the VXSM Features tab.

**Step 3** Choose the XGCP MGC option from the drop-down arrow.

**Step 4** Verify the following XGCP peer group parameters:
- **MGC Group Number**—Specifies the media gateway controller number. The range is from 1-8.
- **Gateway IP Address**—The Gateway IP Address Index parameter defines the media gateway address that relates to the PVC control type. The range is from 1-16.
- **Protocol Index**—Specifies the media gateway protocol number. The range is from 1-3.
- **Gateway UDP Port**—Specifies the Gateway User Datagram Protocol (UDP) port.

**Step 5** Click the Delta Mode radio button or Absolute Mode radio button. See Table 9-6.
Is the Service Working?

9.4.14 Managing the Status for the VISM-PR Features

This task is used to manage the status for the VISM-PR features:


To display the status for the Simple Resource Coordination Protocol (SRCP) peer group for both VISM-PR cards:

- Choose the polling interval time from the **Poll Interval (Sec)** drop-down arrow.
- Verify the statistics name and statistics value for the real-time counters.
- Check the **Poll All** check box to initiate polling for the statistics. To select individual counters for polling, check the counter check box.

  - Appendix E, “Real-Time Counters” gives details of the real-time counters displayed in the Diagnostic Center.
  - Appendix D, “Statistics Summary” gives details of the statistics that are collected from the Cisco MGX 8880 and Cisco MGX 8850.

- Click **Refresh** to update the settings for the XGCP peer group for VISM-PR.

---

9.4.14 Managing the Status for the VISM-PR Features

This task is used to manage the status for the VISM-PR features:


To display the status for the Simple Resource Coordination Protocol (SRCP) peer group for both VISM-PR cards:

- Choose the polling interval time from the **Poll Interval (Sec)** drop-down arrow.
- Verify the statistics name and statistics value for the real-time counters.
- Check the **Poll All** check box to initiate polling for the statistics. To select individual counters for polling, check the counter check box.

- Click **Refresh** to update the settings for the SRCP peer group for VISM-PR.
9.15 Diagnosing Connections

The Diagnostic Center is used to diagnose connections. The key functions are the ability to test status, delay and integrity of SPVC connections.

This task is used to test SPVC connection:

- **9.4.15.1 Polling a Connection for an SPVC**

You can test the integrity of any existing connection that is nondisruptive to user traffic. The operation is similar to the `tstcon` command. For more information on the `tstcon` command, refer to the *Cisco WAN Switching Command Reference, Release 9.3.30*.

9.4.15.1 Polling a Connection for an SPVC

To poll a connection:

**Step 1**
In the Domain Explorer, select the node and choose Configuration > MGX8880/8850 MG > Configuration Center.

**Step 2**
Click the Connections tab to display the Connection Browser window.

**Step 3**
Drag the node from the Hierarchy pane to the right hand pane to display the connection details. Click the Connection List tab. See Figure 7-1.

**Step 4**
Click More Filters to display the Filter Settings window. See Figure 7-2.

**Step 5**
Choose the filter settings from the Filter Settings window. For example, check both the Status check box and the OK check box if you want to retrieve only active connections.

**Step 6**
Click OK to apply the filter settings.

**Step 7**
Enter the number of connections that you want to retrieve in the Connection Count to be retrieved field. To retrieve all the connections, enter *.

**Step 8**
Click Get to retrieve the connections. For example, you can retrieve both local and remote endpoints. The Connection Browser window appears with the number of connections matching the filtering criteria. A list of connections that have either local or remote endpoints are displayed in the connection list.

**Step 9**
You now test the connection. Right-click the SPVC connection from the list of connections and choose Diagnostic Center.

**Step 10**
In the Diagnostic Center, click the Test Connection tab.

**Step 11**
There are three radio button options:

- Click the Test Conn radio button to initiate an end-to-end integrity test of the selected connection.
- Click the Test Delay radio button to initiate an end-to-end measurement of round-trip delay.

**Step 12**
Check the Poll Local or Poll Remote Endpoint check box to initiate polling for the statistics. To select individual counters for polling, check the counter check box.

**Step 13**
Click the Delta Mode radio button or Absolute Mode radio button. See Table 9-6.

**Step 14**
Choose the polling interval time from the Poll Interval (Sec) drop-down arrow.
Chapter 9      Managing Faults

Is the Service Working?

Step 15 Verify the statistics name and statistics value for the real-time counters.
Step 16 Click **Start Test Connection** to proceed with testing.
Step 17 Click **Abort Test Connection** to stop the test.

9.4.16 Bit Error Rate Test

Bit Error Rate Test (BERT) verifies the integrity of a network element by measuring error statistics that result from sending known bit patterns, analyzing a remote interface, and analyzing the pattern that is returned. BERT is used on DS3, DS1, and DS0/DS0 bundle interfaces.

BERT generates a known data sequence into a transmission device, and examines the received sequence at the same device or a remote device for errors. Tests are run on a full T1E1 line or a fractional T1E1, for example, single DS0 or a group of DS0s. BERT tests the quality of links by directly comparing a pseudo-random or repetitive test pattern with an identical, local-generated test pattern.

**Note**

SRME, SRME/B, VXSM, VISM-PR, and AXSME card types support BERT.

BERT includes the following functions:

- Configures a local loopback on a line or port, or specifies a remote loopback be used instead.
- Defines the bit pattern.
- Specifies a duration for the BERT session after the session automatically terminates.
- Specifies BERT can start on a designated line or port.
- Lists BERT tests that are initiated from Cisco MGM.
- Refreshes the display to update the output for the current BERT.
- Stops a BERT started from Cisco MGM.

9.4.17 Configuring Bit Error Rate Test

You can setup BERT options on the looped back connection and use the available test patterns displayed in the BERT Configuration window. Before you configure the BERT options in the BERT Configuration window, make sure a line or port is selected from a BERT-supported service module.

In Cisco MGM, BERTs are only applicable on:

- AXSME 32 T1E1 (on DS1 Line)
- VXSM 48 T1E1 (on DS1 Line)
- VXSM OC3 (on DS1 Paths)
- VISM PR 8T1E1 (accompanied by an SRM Card, on DS1 Line)

This section also includes the following details:

- 9.4.17.1 Stopping Bit Error Rate Test
- 9.4.17.2 Modifying Bit Error Rate Test
To configure a BERT session:

**Step 1** In the Diagnostic Center, double-click or drag the line or port that is supported by BERT from the Hierarchy pane to the right hand pane to display the Line and Port Configuration window.

**Step 2** Click the **Bert** tab to display the BERT Configuration window. See Figure 9-10.

**Note** Not all the BERT configuration parameters are applicable for all card types.

**Step 3** Choose the test pattern options from the **Test Pattern** drop-down arrow.

The default option is **allZeros**.

**Step 4** Choose one of the following Invert Rx Test options from the **Invert Rx Test Pattern** drop-down arrow:

- **Not Inverted**
- **Inverted**

**Step 5** Choose one of the following Invert Rx Test options from the **Invert Tx Test Pattern** drop-down arrow:

- **Not Inverted**
- **Inverted**

**Step 6** Ensure that the type of end device and loopback device option is correct from the **Device To Loop** drop-down arrow.

**Step 7** Choose the error insertion option from the **Error Insertion** drop-down arrow.

The insert constant-rate error option verifies that the transmitted pattern is being properly received and errors are properly detected. Once set to send continuous errors, errors are inserted at the configured rate until set to **no Error** option.

If you set the value to insert errors while the test is not running, the test is not affected. However, when the test is started again, errors are inserted at the configured rate.

**Step 8** Click **Start Bert** to initiate the BERT session. Note that once BERT is started, you can restart it with the modified options.
9.4.17.1 Stopping Bit Error Rate Test

While the BERT session is running, you can stop the session from the BERT Configuration window that is applicable to your selected line or port. From the BERT Configuration window, click **Stop Bert** to stop the session.

9.4.17.2 Modifying Bit Error Rate Test

After you stop a BERT session, you can modify the session.

To modify a BERT:

**Step 1** Choose one of the following single-bit error options from the **Insert Single Bit Error** drop-down arrow:
- No Error
- Insert Error

**Step 2** Click **Modify Bert** to modify the BERT line by inserting a single-bit error in the transmitted BERT pattern.
### 9.4.18 Displaying Bit Error Rate Test

After initiating a BERT session, you can view the status of all initiated BERT sessions at once. To display BERT status:

**Step 1** In the Diagnostic Center, double-click or drag the line or port that is supported by BERT from the Hierarchy pane to the right hand pane to display the Line and Port Configuration window.

**Step 2** Click the Monitored BERTs tab to display the Monitored BERTs window. See Figure 9-10.

Table 9-7 describes the parameters for the BERT statistics. Select the BERT entry to update the statistics, and click Refresh.

<table>
<thead>
<tr>
<th>Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Date and Time</td>
<td>Specifies the start date and time.</td>
</tr>
<tr>
<td>Operation Status</td>
<td>Specifies the current operation status of BERT.</td>
</tr>
<tr>
<td>Failed Reason</td>
<td>Defines the reason for the BERT failure. If the Operation Status parameter is set to BERT Failed, more information is available.</td>
</tr>
<tr>
<td>Bits Transmitted</td>
<td>Specifies the total number of bits.</td>
</tr>
<tr>
<td>Bits Received In Error</td>
<td>Receives the total number of bit errors.</td>
</tr>
<tr>
<td>Error Inject Count</td>
<td>Specifies the total number of injected bit errors.</td>
</tr>
</tbody>
</table>

### 9.5 Where Is the Fault?

You need to be able to quickly troubleshoot problems on the network, identify when network capacity is being reached, and provide information to management on the number and types of devices being used on the network. If the network goes down, one of the first things you will need to know is what devices are running on the network. You will want to know the types of devices you are dealing with as well as the names, addresses, and interfaces associated with each device in order to begin troubleshooting the problem. The more information you have about all your devices in one central place, the easier it is to locate necessary information, resolve problems quickly, and provide detailed information to interested parties.

9.5.1 Sources of Information

9.5.2 Identifying and Monitoring Alarms

9.5.3 Using Visual and Audible Alarm Notifications

9.5.4 Sources of EMS Raised Alarms

9.5.5 Viewing Fault Management Data for a Set of NEs
9.5.1 Sources of Information

Fault management receives and processes information from the following sources:

- Autonomous reports of failures from NEs
- Trouble reports from customers and peer systems
- Results of diagnostics, exercises and audits from NEs
- Impairment indications from performance management
- Network configuration data from configuration management.

Cisco MGM constantly updates the alarm status of the network based on the alarm and event notifications sent by the monitored NEs and generated by the EMS itself. It performs alarm synchronization with the NE each time the connection to the NE is established or re-established and the NE is in service.

9.5.2 Identifying and Monitoring Alarms

There are a number of options available to identify and monitor alarms on the entire domain or in a group of NEs:

- In the Domain Explorer Hierarchy pane, select the management domain node or a group node. If it shows a critical, major, minor, or warning alarm icon, it means that one or more NEs within the management domain or group are experiencing an alarm.
- Select the management domain node or group node and choose Fault > Alarm Browser (or right-click the node and choose Alarm Browser in the popup menu). This opens the Alarm Browser window, which shows all the NEs in the management domain or group that are experiencing a critical, major, minor, or warning alarm. See Figure 9-3.
- Click an alarm count box in the Dashboard, the Alarm Browser appears, prefilled for the selected alarm severity.
- Click the Open Alarm Browser tool from the Dashboard to show Cisco MGM specific EMS alarms in the Alarm Browser.
- Click the Open Cisco MGM EMS Alarm Browser tool from the Dashboard to show alarms on Cisco MGM in the Alarm Browser.

To identify and monitor alarms on specific NEs:

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Select an in-service NE in the Domain Explorer Hierarchy pane that shows an alarm icon.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Choose Fault &gt; Alarm Browser, or right-click and choose Alarm Browser in the popup menu.</td>
</tr>
</tbody>
</table>

**Note** Alarms relating to PM collection indicate that the load on the system is high. Reduce the load on the system before proceeding.
9.5.3 Using Visual and Audible Alarm Notifications

To use visual and audible alarm notifications:

Step 1 In the Domain Explorer window, choose **Edit > User Preferences**.

Step 2 The User Preferences dialog box appears. On the Event Notification tab, in the Show Notification Dialog area, select whether or not an alert popup opens when a specific alarm or informational event occurs on NEs in the management domain or in the application.

The Event Notification dialog box opens whenever a new alarm or event occurs. According to your User Preferences selection, you will receive popup notification about alarms by severity and information on events from the network element (NE) or from Cisco MGM. The Event Notification popup remains open until one of the following occurs:

- You click OK to close the dialog box.
- It is replaced by an Event Notification dialog box with a higher severity.
- You click Disable to disable all event notifications.

The Event Notification displays the information shown in Table 9-8.

Step 3 In the Play Audible Notification area, select whether or not an audible alert is sounded when a specific alarm or informational event occurs on the NE or in the application. You can also select whether or not a continuous audible alert is sounded when there is an update in the Dashboard. Check the **Continuous Alarm for Dashboard notifications** check box.

Note To stop the continuous audible alert, choose **Fault > Stop Continuous Beep** in the Domain Explorer.

Step 4 Check the **Save current settings** check box and click **OK**.

Tip Click **Disable** on the popup window itself to disable additional popups.

<table>
<thead>
<tr>
<th>Table 9-8 Event Notification Dialog Box Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field</td>
</tr>
<tr>
<td>Source</td>
</tr>
<tr>
<td>Time</td>
</tr>
<tr>
<td>Category</td>
</tr>
<tr>
<td>Probable Cause</td>
</tr>
<tr>
<td>Affected Object</td>
</tr>
</tbody>
</table>
9.5.4 Sources of EMS Raised Alarms

In addition to reporting NE-generated alarms, the EMS monitors and reports alarms on the EMS itself; for example, loss of connectivity to NE, and so forth.

The EMS monitors and reports the NE-specific alarms (see Table 9-9) and non-NE-specific alarms (see Table 9-10).

See Appendix F, “Cisco MGM CORBA Gateway Events” for details of the Cisco MGM CORBA Gateway events.

Note

NE-specific alarms can be viewed and accessed by users who are assigned to the particular NE.

<table>
<thead>
<tr>
<th>Table 9-8</th>
<th>Event Notification Dialog Box Descriptions (continued)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>Description</td>
<td>Displays a brief description of the alarm or event.</td>
</tr>
<tr>
<td>Service Affecting</td>
<td>Indicates whether the alarm or event affects service.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 9-9</th>
<th>EMS-NE-Specific Alarms</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>NE-Specific Alarms</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Loss of communication to an NE</td>
<td>When the system detects loss of connectivity to an NE, an EMS alarm is generated in the Alarm Browser. This EMS alarm is cleared when the system reestablishes connectivity to the NE or when the NE is marked Out of Service.</td>
</tr>
<tr>
<td>Automatic or manual memory backup failure</td>
<td>If an automatic or manual memory backup job fails, an EMS alarm is generated in the Alarm Browser. An individual EMS alarm is generated for each memory backup failure that occurs. All instances of the backup-related EMS alarms are cleared (for that particular NE) when the memory backup succeeds or when the NE is marked Out of Service.</td>
</tr>
<tr>
<td>Switching IP addresses</td>
<td>When an active IP address switches from the primary to the secondary IP address, an alarm will be generated. It is only cleared when the address is switched back to the primary IP address or when communication to the NE is lost.</td>
</tr>
<tr>
<td>Failed PM data retrieval</td>
<td>An alarm will be generated for every PM data retrieval failure. PM 15-min Retrieval Fail Alarms are generated if the system has not retrieved 15-min PM data after the number of times to retrieve PM data has been reached. These alarms can be cleared manually or cleared automatically if a Lost PM alarm is generated or if PM data is retrieved.</td>
</tr>
</tbody>
</table>
| Lost PM data | An alarm will be generated for all lost PM data. PM lost alarm 15-minute is generated when:  
* The EMS is not able to collect PM data for 15 minutes and the NE’s PM collection is set to 15 Min.  
* The EMS is not able to collect 15-minute PM data after 8 hours. If there are outstanding PM 15-min Retrieval Fail Alarms, these alarms will be cleared and the PM 15-min Lost PM Bucket Alarm is generated.  
These alarms can be cleared manually. Lost PM data alarms are generated only if the PM collection is set to 15-Min. |
Chapter 9  Managing Faults

Where Is the Fault?

9.5.5 Viewing Fault Management Data for a Set of NEs

To view fault management data for an NE:

Step 1  In the Domain Explorer Hierarchy pane, select the management domain, group, or NE node for which to view the data.

Step 2  Open an Alarm Browser, choose Fault > Alarm Browser.

Note  A preliminary filter is always applied based on the object selected in the tree view or map.

Step 3  In the table, click the Filter Data tool (or choose File > Filter). The Filter dialog box appears.

Step 4  Most fault management tables (for example, the Alarm Browser and Alarm Log tables) have a filter tool for filtering data for a set of NEs. In the Filter dialog box, select the NEs that will be included in the filter. Specify other filter parameters, as needed. See 9.7.2 Filtering the Alarm Log.

Step 5  Click OK to show the results in a table.

<table>
<thead>
<tr>
<th>Non-NE-Specific Alarms</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum number of login attempts exceeded</td>
<td>By default, users have a maximum of five login attempts. The user account is locked after the fifth unsuccessful login attempt and an EMS alarm is generated in the Alarm Browser. The alarm is cleared once the user account is unlocked or the account is deleted.</td>
</tr>
<tr>
<td>System self-monitor alarm</td>
<td>Threshold parameters such as CPU usage, memory usage, disk usage, circuit creation time, PM collection time, and resynch time are collected and evaluated to monitor the server performance. An alarm is generated if any of these parameters cross their threshold values with their corresponding severity level. The alarms are cleared only after the corresponding parameter value falls below the minor threshold. Subsequent threshold crossings for the same parameter will not generate further alarms. Only the severity level is changed to indicate the current severity level for the specific parameter.</td>
</tr>
<tr>
<td></td>
<td>Note</td>
</tr>
<tr>
<td></td>
<td>Alarms associated with circuit creation, configuration resynchronization, NE synchronization, and PM collection indicate that the load on the system is high. Reduce the load on the system before proceeding.</td>
</tr>
<tr>
<td></td>
<td>Alarms associated with pruning times also indicate that the load on the system is high. Reschedule pruning at a time when the system has less activity.</td>
</tr>
</tbody>
</table>

Table 9-10  Non-NE-Specific Alarms
Chapter 9      Managing Faults

9.6 How Can I Use Advanced Debugging to Find the Cause of the Fault?

Advanced debugging captures additional information about defects. The EMS should correlate events and determine the faults that exist in the network. To correlate events means to look for relationships between them.

Advanced debugging can be carried out using information from the following sources:

- 9.6.1 Setting an EMS Process as Critical
- 9.6.2 Setting Up and Viewing Error Logs
- 9.6.3 Setting Debug Options

9.6.1 Setting an EMS Process as Critical

You can mark an EMS service as critical for process monitoring purposes. To set a process as critical:

<table>
<thead>
<tr>
<th>Step 1</th>
<th>In the Domain Explorer window, choose Administration &gt; Control Panel.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click Recovery Properties to open the Recovery Properties sheet.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click the Process Monitoring tab. Table 9-11 describes the fields within the Process Monitoring tab. The system services listed are:</td>
</tr>
<tr>
<td></td>
<td>• Service Manager</td>
</tr>
<tr>
<td></td>
<td>• Oracle Service</td>
</tr>
<tr>
<td></td>
<td>• OS Agent</td>
</tr>
<tr>
<td></td>
<td>• GateWay/CORBA Service</td>
</tr>
<tr>
<td></td>
<td>• MGX8880/8850 NE Service</td>
</tr>
<tr>
<td></td>
<td>• MGX8880/8850 PM Service</td>
</tr>
<tr>
<td>Step 4</td>
<td>Check the Critical check box beside each service to indicate that the service is critical.</td>
</tr>
</tbody>
</table>

**Note**

The Service Manager, Oracle Service, and OS Agent are permanently critical. You cannot uncheck the Critical check boxes for these services.

**Note**

If a critical process stops running or it fails to poll monitoring services for a long time, the server will be shut down and the client will generate an alarm.
9.6.2 Setting Up and Viewing Error Logs

The Error Log tables display server error information that is useful for debugging Cisco MGM processes. In most cases, the Error Log is requested by service personnel for debugging a problem on the Cisco MGM server. The Error Log captures abnormal and significant events based on severity level. Critical, major, minor, and informational errors are saved in the database.

There are two types of Error Log available in Cisco MGM:

- Error logs for the Diagnostic Center, Configuration Center, Statistics Report and Chassis View. These Error Logs are accessed directly from the log directory on the server at /opt/root/log.
- Error logs for the other applications in Cisco MGM. Choose Administration > Error Log to view these Error Logs.

As the default, the Error Log displays information about significant events that occurred during the last four hours. You can change the default time period in the User Preferences dialog box.

The Error Log Configuration property sheet allows the user to control the volume of messages that are created by the server. All changes take effect immediately and do not require restart of the server. To reduce the amount of information logged to the database, turn off entire components. To set up and view Error Logs:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Service Name</td>
<td>Displays the process monitoring service name.</td>
</tr>
<tr>
<td>Critical</td>
<td>If checked, the selected service is designated as critical for process monitoring. Service Manager, Oracle Service, and OS Agent cannot be unchecked.</td>
</tr>
</tbody>
</table>

**Table 9-11 Recovery Properties—Process Monitoring Tab**

In the Domain Explorer window, choose Administration > Control Panel.

Click Error Log Properties to open the Error Log Configuration property sheet. The Error Log property sheet displays the information in Table 9-12:
How Can I Use Advanced Debugging to Find the Cause of the Fault?

Step 2

In the Error Level field, choose the error level that will be included in the Error Log (Critical, Major, Minor, Informational, Debug, or Trace). Critical, major, minor, and informational errors are logged to the database; trace and debug information is logged to a log file.

**Caution**

When the trace or debug option is left on, it can lead to an insufficient disk space situation. Use these options only when troubleshooting with a customer support engineer.

Step 3

Click **Save**.

To open the Error Log, choose **Administration > Error Log** in the Control Panel window menu bar. The Error Log displays the information shown in Table 9-13.

---

### Table 9-12 Field Descriptions for the Error Log Properties

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco MGM Server and GateWay/SNMP</td>
<td>Allows you to choose the error level to include in the Error Log for services related to the Cisco MGM server and GateWay/SNMP. Critical, major, minor, and informational errors are logged to the database; trace and debug information is logged to a log file.</td>
</tr>
<tr>
<td><strong>Caution</strong></td>
<td>Cisco MGM performance will degrade significantly if the trace or debug option is left on. All operations will slow down and you may lose alarm and event notifications. Use trace or debug only when troubleshooting with a customer support engineer.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Trace and debug information does not appear in the Error Log table.</td>
</tr>
<tr>
<td>SM Service</td>
<td>Allows you to choose the error level to include in the Error Log for the SM service. Critical, major, minor, and informational errors are logged to the database; trace and debug information is logged to a log file.</td>
</tr>
<tr>
<td><strong>Caution</strong></td>
<td>Cisco MGM performance will degrade significantly if the trace or debug option is left on. All operations will slow down and you may lose alarm and event notifications. Use trace or debug only when troubleshooting with a customer support engineer.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Trace and debug information does not appear in the Error Log table.</td>
</tr>
<tr>
<td>SNMP Trap Service</td>
<td>Allows you to choose the error level to include in the Error Log for the SNMP Trap service. Critical, major, minor, and informational errors are logged to the database; trace and debug information is logged to a log file.</td>
</tr>
<tr>
<td><strong>Caution</strong></td>
<td>Cisco MGM performance will degrade significantly if the trace or debug option is left on. All operations will slow down and you may lose alarm and event notifications. Use trace or debug only when troubleshooting with a customer support engineer.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>Trace and debug information does not appear in the Error Log table.</td>
</tr>
</tbody>
</table>
**Table 9-13  Error Log Descriptions**

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco MGM Time Stamp</td>
<td>Displays the date and time when the error occurred on the Cisco MGM server.</td>
</tr>
<tr>
<td>Module</td>
<td>Displays the name of the module where the error occurred.</td>
</tr>
<tr>
<td>Severity</td>
<td>Displays the severity level of the error (see Table 9-15 for a description of the severity levels).</td>
</tr>
<tr>
<td>Submodule</td>
<td>Displays the name of the submodule where the error occurred.</td>
</tr>
<tr>
<td>Filename</td>
<td>Displays the name of the file where the error occurred.</td>
</tr>
<tr>
<td>Line</td>
<td>Describes the exact line where the error occurred.</td>
</tr>
<tr>
<td>Message</td>
<td>Displays the text of the error message.</td>
</tr>
</tbody>
</table>

**Note**  
Each NE service and PM service has an error level selection. For example, choose Control Panel > NE Service or PM Service > MGX8850 or MGX8880. In the Error Level drop-down list, choose the error level to include in the Error Log for the selected NE service or PM service. Click Save.

**Step 4**  
You can filter the Error Log data according to criteria that you select and to display the results in the Error Log table. Table 9-14 details the options available:

**Table 9-14  Error Log Filter Dialog Box Descriptions**

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time Stamp (time zone)</td>
<td>Allows you to filter Error Log data for a specified time period, ranging from the past hour to the past 6 months. You can click the User Specified radio button to specify an exact filter starting and ending time by month, day, year, and hour. The time zone can be Greenwich mean time (GMT), a user-defined offset from GMT, or local time, depending on what is specified in the User Preferences dialog box. If you want to filter Error Log data and the time period is not important, click No Time Specified.</td>
</tr>
<tr>
<td>Modules</td>
<td>Allows you to filter Error Log data by Cisco MGM module.</td>
</tr>
<tr>
<td>Submodules</td>
<td>Allows you to select Cisco MGM server submodules to filter Error Log data.</td>
</tr>
<tr>
<td>Severity</td>
<td>Allows you to filter Error Log data based on severity level: Critical, Major, Minor, and Informational.</td>
</tr>
</tbody>
</table>
How Can I Use Advanced Debugging to Find the Cause of the Fault?

The Error Log window shows Cisco MGM server error information that is useful for debugging purposes. The Error Log captures abnormal and significant events based on severity. Table 9-15 shows the severity levels.

Table 9-15 Severity Levels and Error Log

<table>
<thead>
<tr>
<th>Severity Level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>critical, major, minor, informational</td>
<td>When set to any of these severity levels, all messages corresponding to critical, major, and minor severity levels are logged to the database and all informational messages are stored in the log file.</td>
</tr>
<tr>
<td>debug, trace</td>
<td>When set to debug or trace, all informational and higher messages are logged to the database. All debug and trace messages are logged to the log files.</td>
</tr>
</tbody>
</table>

All messages are logged to the following files in the /opt/CiscoMGMServer/log directory:

- MGMTL1FWDerror.log
- MGX8880NEService-number.log
- MGX8880NEService-numberError.log
- MGX8880PMService-number.log
- MGX8880PMService-numberError.log
- UnmanagedNEService-number.log
- UnmanagedNEService-numberError.log
- SnmpTrapService.log
- SnmpTrapServiceError.log
- CORBAGWService.log
- CORBAGWServiceError.log

Note The default directory /opt/CiscoMGMServer may have been changed during installation of the Cisco MGM server.

After resetting the Error Log level to critical, major, minor, or informational, remove the log files to free disk space. Each time a new log file is started, a backup of the previous file is kept in the log-file.bak file. Remove the backup file at any time.

9.6.3 Setting Debug Options

In Cisco MGM, the debug option gives you information to investigate, diagnose and fix a problem.

Note If required, set the debug levels for specific Cisco MGX NE backend processes by updating the debug parameter in the configuration file for that process in the /opt/svplus/config directory. See Table 9-16. When the changes are made, stop, then restart the Cisco MGM server.
How Can I Use Advanced Debugging to Find the Cause of the Fault?

Specifying the debug options allows you to choose the parameters that will be displayed in the debug log. To set the debug options:

**Step 1** In the Domain Explorer, choose File > Debug Options.

**Step 2** Specify the debug options. The options available in the Debug Options dialog box are described in Table 9-17.

**Step 3** Click Apply.

### Table 9-16 Cisco MGM Processes and Configuration Files

<table>
<thead>
<tr>
<th>Process</th>
<th>ConfigFile</th>
<th>Parameter</th>
<th>Range</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>AuditLogger</td>
<td>AuditLogger.conf</td>
<td>DB_LEVEL</td>
<td>[1..5]</td>
<td>5</td>
</tr>
<tr>
<td>cmgrd</td>
<td>-none-</td>
<td>-none-</td>
<td></td>
<td></td>
</tr>
<tr>
<td>cmsvr</td>
<td>cmsvr.conf</td>
<td>LOG_LEVEL</td>
<td>[1..7]</td>
<td>7</td>
</tr>
<tr>
<td>configserver</td>
<td>configserver.conf</td>
<td>LOG_LEVEL</td>
<td>[1..7]</td>
<td>7</td>
</tr>
<tr>
<td>cwmftpd</td>
<td>cwmftpd.conf</td>
<td>LOG_LEVEL</td>
<td>[1..7]</td>
<td>7</td>
</tr>
<tr>
<td>cwmsmap</td>
<td>-none-</td>
<td>-none-</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DCServer</td>
<td>DCServer.conf</td>
<td>LOG_LEVEL</td>
<td>[1..7]</td>
<td>7</td>
</tr>
<tr>
<td>dmd</td>
<td>dmd.conf</td>
<td>LOG_LEVEL</td>
<td>[1..7]</td>
<td>7</td>
</tr>
<tr>
<td></td>
<td></td>
<td>SYNCUP_LOG_LEVEL</td>
<td>[1..7]</td>
<td>4</td>
</tr>
<tr>
<td>eventd</td>
<td>-none-</td>
<td>-none-</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ILMITopoc</td>
<td>ILMITopoc.conf</td>
<td>Debug Level</td>
<td>[1..5]</td>
<td>2</td>
</tr>
<tr>
<td>NMServer</td>
<td>NMServer.conf</td>
<td>LOG_LEVEL</td>
<td>[1..7]</td>
<td>7</td>
</tr>
<tr>
<td></td>
<td></td>
<td>STARTUP_LOG_LEVEL</td>
<td>[1..7]</td>
<td>7</td>
</tr>
<tr>
<td>nts</td>
<td>nts.conf</td>
<td>DEBUG_LEVEL</td>
<td>[1..5]</td>
<td>5</td>
</tr>
<tr>
<td>ooemc</td>
<td>emd.conf</td>
<td>OODebug Level</td>
<td>[1..7]</td>
<td>6</td>
</tr>
<tr>
<td>pmcollector</td>
<td>pmcollector.conf</td>
<td>LOG_LEVEL</td>
<td>[1..7]</td>
<td>7</td>
</tr>
<tr>
<td>RtmProxy</td>
<td>SNMPProxy.conf</td>
<td>-none-</td>
<td></td>
<td></td>
</tr>
<tr>
<td>sdbroker</td>
<td>sdbroker.conf</td>
<td>LOG_LEVEL</td>
<td>[1..7]</td>
<td>7</td>
</tr>
<tr>
<td></td>
<td></td>
<td>SYNCUP_LOG_LEVEL</td>
<td>[1..7]</td>
<td>4</td>
</tr>
<tr>
<td>snmpcomm</td>
<td>snmpcomm.conf</td>
<td>DEBUG_LEVEL</td>
<td>[1..5]</td>
<td>4</td>
</tr>
<tr>
<td>srtserver</td>
<td>srtserver.conf</td>
<td>LOG_LEVEL</td>
<td>[1..7]</td>
<td>7</td>
</tr>
<tr>
<td>statsparser</td>
<td>statsparser.conf</td>
<td>LOG_LEVEL</td>
<td>[1..7]</td>
<td>7</td>
</tr>
<tr>
<td>topod</td>
<td>Topod.conf</td>
<td>Debug Level</td>
<td>[1..5]</td>
<td>2</td>
</tr>
</tbody>
</table>
### Table 9-17  Field Descriptions for the Debug Options Dialog Box

<table>
<thead>
<tr>
<th>Field</th>
<th>Subfield</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modules</td>
<td>—</td>
<td>Select modules that will display debug messages. Use the <strong>Add</strong> and <strong>Remove</strong> buttons to move modules to the Selected list or remove modules from the list.</td>
</tr>
<tr>
<td>Debug Level</td>
<td>Fatal</td>
<td>Instructs the Debug Log to display messages with a severity level of at least Fatal.</td>
</tr>
<tr>
<td></td>
<td>Warning</td>
<td>Instructs the Debug Log to display messages with a severity level of at least Warning.</td>
</tr>
<tr>
<td></td>
<td>Info</td>
<td>Instructs the Debug Log to display messages with a severity level of at least Info.</td>
</tr>
<tr>
<td></td>
<td>Debug</td>
<td>Instructs the Debug Log to display messages with a severity level of at least Debug.</td>
</tr>
</tbody>
</table>

**Caution**  
Cisco MGM performance will degrade significantly if the Debug option is left on. All operations will slow down and you may lose alarm and event notifications. Use Debug only when troubleshooting with a Cisco customer support engineer.

<table>
<thead>
<tr>
<th>Field</th>
<th>Subfield</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trace</td>
<td></td>
<td>Instructs the Debug Log to display messages with a severity level of at least Trace.</td>
</tr>
</tbody>
</table>

**Caution**  
Cisco MGM performance will degrade significantly if the Trace option is left on. All operations will slow down and you may lose alarm and event notifications. Use Trace only when troubleshooting with a Cisco customer support engineer.
After you have gathered information about the faults, it is then important to prioritize that information. There are several ways to determine the priority of a fault. You can simply assign a priority to an NE or group, or you can try to derive this information from a knowledge of the network.

The priority of a fault can vary depending on a variety of factors, such as:

- Influences outside of the network (for example, the time of day an outage occurs)
- Amount and type of traffic that will be affected
- Who specifically is affected by the fault
- Potential financial consequences

You can decide to filter events. Filtering means to identify events that do not need to be processed immediately, or might never need to be processed. Because the volume of events to be processed can be high, it is important to filter unwanted events as soon as possible.

You can get information for prioritizing faults in the following sections:

- 9.7.1 Alarm Severity Levels
- 9.7.2 Filtering the Alarm Log
- 9.7.3 Filtering Data by Time

### Table 9-17 Field Descriptions for the Debug Options Dialog Box (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Subfield</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Max File Size</td>
<td></td>
<td>Enter the maximum file size for the Debug Log, in bytes.</td>
</tr>
<tr>
<td>Telnet</td>
<td></td>
<td>Check the Telnet check box to write the Debug Log to a Telnet port.</td>
</tr>
<tr>
<td>Console</td>
<td></td>
<td>Check the Console check box to write the Debug Log to the console.</td>
</tr>
</tbody>
</table>

**Note**: `<version_number>` is replaced by the version number of the installed Cisco MGM client.
9.7.1 Alarm Severity Levels

Cisco MGM supports the following alarm severities in the Alarm Browser:

- Critical (CR)—Red
- Major (MJ)—Orange
- Minor (MN)—Yellow
- Warning (WR)—Cyan (blue-green)

9.7.2 Filtering the Alarm Log

By default, the Alarm Log shows alarm and event information that occurred during the last 4 hours. Use the drop-down menu to the right of the time-based filter tool to filter event data for the past 4 hours, past 8 hours, past 12 hours, past day, or past week.

**Step 1** In the Domain Explorer Hierarchy pane, select a domain, group, or NE and choose **Fault > Alarm Log**.

**Step 2** To set the filter time to start immediately, choose **Fault > Reset All Events**.

To filter the data in the log, click the **Filter Data** tool (or choose **File > Filter**). The Alarm Log Filter dialog box contains the information detailed in **Table 9-18**.

**Step 3** When all filter criteria have been specified, click **OK** to run the filter.

<table>
<thead>
<tr>
<th><strong>Table 9-18</strong></th>
<th><strong>Field Descriptions for the Alarm Log Filter Dialog Box</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Tab</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Cisco MGM Time Stamp (time zone)</td>
<td>Allows you to filter alarm and event data for a specified time period, ranging from the past hour to the past 6 months. Additionally, you can click the <strong>User Specified</strong> radio button to specify an exact filter starting and ending time by month, day, year, and hour. The time zone can be Greenwich mean time (GMT), a user-defined offset from GMT, or local time, depending on what is specified in the User Preferences dialog box. If you want to filter alarms and events and the time period is not important, click <strong>No Time Specified</strong>. Click <strong>From Now Onward</strong> to set the filter time to start immediately and continue until you change filter parameters.</td>
</tr>
<tr>
<td>Source ID</td>
<td>Allows you to move network elements (NEs) back and forth between the list of Available Source IDs and Selected Source IDs and then run the Alarm Log Filter. If you have the appropriate user permission, you can filter Cisco MGM EMS alarms and events by selecting <strong>MGM</strong> and adding it to the Selected Source ID list. If more than 100 NEs are selected, the Source ID tab becomes gray and all devices are included in the filter criteria you specify.</td>
</tr>
<tr>
<td>Module Name</td>
<td>Allows you to specify which module types you want to include in the filter. The modules displayed depend on the NE selection in the Domain Explorer Hierarchy pane when the Alarm Log is opened. Use the <strong>Add</strong> and <strong>Remove</strong> buttons to filter the display to specific modules. The Alarm Log displays events for modules listed under Selected Module Name.</td>
</tr>
</tbody>
</table>
**Table 9-18  Field Descriptions for the Alarm Log Filter Dialog Box (continued)**

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Affected Object</td>
<td>Allows you to specify which objects you want to include in the filter. The objects displayed depend on the NE selection in the Domain Explorer Hierarchy pane when the Alarm Log is opened. Use the Add and Remove buttons to filter the display to specific objects. The Alarm Log displays events for entities listed under Selected Affected Object. To filter NE-specific EMS alarms, select MGM and add it to the Selected Affected Object list.</td>
</tr>
<tr>
<td>PS</td>
<td>Allows you to filter data based on the perceived severity (PS) of the alarm or event. Additionally, you can filter service affecting alarms and events, non-service affecting alarms and events, and/or not-available alarms and events (alarms and events where the service affecting status is not known).</td>
</tr>
<tr>
<td>Physical Location</td>
<td>Allows you to filter data based on the physical location of an NE or its components. To view the tab, an NE must be selected in the Domain Explorer Hierarchy pane. The filters that are available depend on the NE selected.</td>
</tr>
<tr>
<td>ID</td>
<td>Allows you to filter data based on alarm or event ID. Enter a starting ID and an ending ID; then, run the filter to see only the alarms or events that occurred within the specified range of IDs. Check the Disregard All The Other Filter Criteria check box to ignore all other filter specifications. In addition, you can filter the view to only alarms, only events, or both alarms and events.</td>
</tr>
<tr>
<td>NE Alarm Time (time zone)</td>
<td>Allows you to filter alarm data for a specified time period, ranging from the past hour to the past 6 months. Additionally, you can click the User Specified radio button to specify an exact filter starting and ending time by month, day, year, and hour. The time zone can be Greenwich mean time (GMT), a user-defined offset from GMT, or local time, depending on what is specified in the User Preferences dialog box. If you want to filter alarms and the time period is not important, click No Time Specified. Click From Now Onward to set the filter time to start immediately and continue until you change filter parameters.</td>
</tr>
</tbody>
</table>

### 9.7.3 Filtering Data by Time

Most fault management tables (for example, the Alarm Browser and Alarm Log tables) have a filter tool for filtering data for a set of NEs. A preliminary filter is always applied based on the object selected in the tree view or map.

To filter data by time:

**Step 1**
In the Domain Explorer Hierarchy pane, select the node for which to filter time-based fault management data. Choose **Fault > Alarm Browser**.

**Step 2**
In the Alarm Browser, click the **Filter Data** tool (or choose **File > Filter**). The Filter dialog box appears.
9.8 Who Is Responsible for Managing the Fault?

To manage faults effectively, you must know who is taking responsibility for managing each case. Cisco MGM offers the following options:

- **9.8.1 Configuring Alarm Acknowledgement and Alarm Notes**
- **9.8.2 Acknowledging and Unacknowledging Alarms**

### 9.8.1 Configuring Alarm Acknowledgement and Alarm Notes

To configure alarm acknowledgment, and enable or disable the alarm note feature:

**Step 1**
In the Domain Explorer window, choose Administration > Control Panel and click UI Properties.

**Step 2**
Under fault management, select either Manual or Automatic Alarm Acknowledgement.

- If you choose Manual Alarm Acknowledgment, alarms must be acknowledged manually. Cleared alarms move from the Alarm Browser to the Alarm Log once they are acknowledged.
- If you choose Automatic Alarm Acknowledgment, the server automatically acknowledges alarms when they are cleared and moves them from the Alarm Browser to the Alarm Log.

---

**Note**
Clicking Refresh Data resets the time-based filter. The filter retrieves data for the specified interval, beginning when the Refresh Data tool is clicked. For example, if the specified interval is Past Hour and Refresh Data is clicked at 3:02 P.M., the filter retrieves data that occurred between 2:02 P.M. and 3:02 P.M. If the specified interval is From Now Onward at 8:00 P.M., data is retrieved beginning at 8:00 P.M. and the time is reset only after From Now Onward is clicked again.
Active alarms are not automatically acknowledged.

If the alarms are initially set to Manual Alarm Acknowledgement, and then you switch to Automatic Alarm Acknowledgement, all the alarms in the Alarm Browser will be cleared and acknowledged automatically. This might take a while, depending on the number of alarms in the database that have not been acknowledged manually.

You can still acknowledge alarms manually even if Automatic Alarm Acknowledgment is set.

**Step 3** Use the Overwrite Alarm Notes option to enable or disable the ability to overwrite alarm notes created by another user.

**Step 4** Select either Enable or Disable Alarm Un-Acknowledgement.

- If you choose **Enable Alarm Un-Acknowledgement**, you can unacknowledge alarms in the Alarm Browser.
- If you choose **Disable Alarm Un-Acknowledgment**, alarms can only be acknowledged in the Alarm Browser.

**Step 5** Click **Save**.

### 9.8.2 Acknowledging and Unacknowledging Alarms

If you enable automatic alarm acknowledgment in the Control Panel > User Interface Properties sheet, the server automatically acknowledges alarms when they are cleared and transitions the alarms to the Alarm Log. If you enable manual alarm acknowledgment, you manually acknowledge a cleared alarm; then, the alarm transitions to the Alarm Log.

The alarm acknowledgement feature acknowledges selected alarms or all alarms with a single click. See Appendix A, “Icons and Menus” for more information about alarm acknowledgment tools.

To acknowledge or unacknowledge alarms:

**Step 1** In the Domain Explorer window, select an NE and choose **Fault > Alarm Browser**. This opens the Alarm Browser window for the selected NE.

The Alarm Browser window lists critical, major, minor, and warning alarms that have not been cleared or cleared alarms that have not been acknowledged.

**Step 2** Select the alarms to be acknowledged and choose **Fault > Acknowledge Alarms** (or click the **Acknowledge Selected Alarm(s)** tool). Click **Yes** in the confirmation dialog box. Click the **Refresh Data** tool to see the changes. A check mark icon provides a visual indication of acknowledged alarms.

When cleared alarms are acknowledged, they transition from the Alarm Browser to the Alarm Log. For more information about the Alarm Log, see the “9.9.1 Archiving Alarm Log” section on page 9-50.
Step 3  Click the **Acknowledge Selected Alarm(s)** tool again to unacknowledge the selected alarms. Click **Yes** in the confirmation dialog box. Click **Refresh Data** to see the changes. The check mark will be removed, indicating that the alarm has been unacknowledged.

---

**Note**  Alarm unacknowledgement is disabled by default. Make sure to enable the alarm unacknowledgement feature in the Control Panel before unacknowledging an alarm. See the “9.8.1 Configuring Alarm Acknowledgement and Alarm Notes” section on page 9-48 for more information.

Step 4  To acknowledge all alarms in the view, choose **Fault > Acknowledge All Alarms** (or click the **Acknowledge All Alarms** tool). Click **Yes** in the confirmation dialog box.

Choose **Fault > Show Alarm Note** (or click the **Show Alarm Note** tool) to read any comments that have been entered for the selected alarm and to enter additional comments. You can add comments to the previous comments, click the **Append** radio button. To overwrite the previous comments, click **Replace**. To delete the comments, click **Delete**.

---

**Note**  You can enable and disable the Replace and Delete functions in the **Control Panel > User Interface Properties sheet**.

### 9.9 How Did You Manage the Fault?

Alarm information can be useful to evaluate the actions taken, for a number of reasons:

- How sure are you that the problem cannot recur?
- What other devices need the same fix?
- Do you know the root cause of the problem?
- What can you do to prevent this problem from reoccurring?
- What new problems could occur when you apply this fix?

In Cisco MGM, you can get information to make this assessment by doing the following:

- 9.9.1 Archiving Alarm Log
- 9.9.2 Exporting Alarms and Events to a Text File

#### 9.9.1 Archiving Alarm Log

The Alarm Log window contains alarms that have transitioned from the Alarm Browser. In order for an alarm to transition from the Alarm Browser to the Alarm Log, it must be cleared and acknowledged. In addition, the Alarm Log shows all transient conditions (also known as events). Events have a single possible severity of Indeterminate and do not have associated clear messages. Events are placed directly into the Alarm Log. They do not appear in the Alarm Browser.
By default, the Alarm Log shows alarm and event information that occurred during the last 4 hours. To view the Alarm Log:

**Step 1** In the Domain Explorer Hierarchy pane, select a domain, group, or NE.

**Step 2** Choose **Fault > Alarm Log**. The Alarm Log appears and displays the information detailed in **Table 9-19**.

### Table 9-19  Field Descriptions for the Alarm Log Window

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Unique number that the system uses to identify a particular alarm or event.</td>
</tr>
<tr>
<td>Source ID</td>
<td>NE or EMS where the selected alarm or event occurred.</td>
</tr>
<tr>
<td>Affected Object</td>
<td>Object where the selected alarm or event occurred. For NE-specific alarms,</td>
</tr>
<tr>
<td></td>
<td>the affected object fields will display “MGM”. For the non-NE specific</td>
</tr>
<tr>
<td></td>
<td>alarms:</td>
</tr>
<tr>
<td></td>
<td>• Maximum number of login attempts exceeded alarm—The affected object</td>
</tr>
<tr>
<td></td>
<td>field displays the user ID associated with the alarm.</td>
</tr>
<tr>
<td></td>
<td>• Cisco MGM self monitor alarm—The affected object field displays the</td>
</tr>
<tr>
<td></td>
<td>threshold parameter associated with the alarm.</td>
</tr>
<tr>
<td>Module Name</td>
<td>Name of the module where the selected alarm or event occurred.</td>
</tr>
<tr>
<td>Physical Location</td>
<td>Physical location of the equipment where the selected alarm or event</td>
</tr>
<tr>
<td></td>
<td>occurred.</td>
</tr>
<tr>
<td>Probable Cause</td>
<td>Probable cause of the selected alarm or event.</td>
</tr>
<tr>
<td>PS</td>
<td>Perceived severity of the alarm before it was cleared. Severity can be</td>
</tr>
<tr>
<td></td>
<td>Critical, Major, Minor, Warning, or Indeterminate. The background color</td>
</tr>
<tr>
<td></td>
<td>of the column indicates the alarm status. A green background indicates</td>
</tr>
<tr>
<td></td>
<td>that the alarm is cleared.</td>
</tr>
<tr>
<td>SA</td>
<td>Indicates whether the alarm or event is service affecting. Values are:</td>
</tr>
<tr>
<td></td>
<td>• Yes if its service affecting</td>
</tr>
<tr>
<td></td>
<td>• No if its not service affecting</td>
</tr>
<tr>
<td></td>
<td>• N/A if no information is provided by the NE</td>
</tr>
<tr>
<td>MGM Time Stamp (GMT)</td>
<td>Date and time when the alarm or event occurred on the server.</td>
</tr>
<tr>
<td>MGM Clear Time</td>
<td>Date and time when the alarm was cleared on the server.</td>
</tr>
<tr>
<td>MGM Duration</td>
<td>Amount of time required to clear an alarm (MGM Clear Time Stamp – MGM</td>
</tr>
<tr>
<td></td>
<td>Time Stamp) in dddd:hh:mm:ss format.</td>
</tr>
<tr>
<td>NE Time Stamp</td>
<td>Date and time when the alarm or event occurred on the NE.</td>
</tr>
<tr>
<td>NE Clear Time</td>
<td>Date and time when the alarm or event was cleared on the NE.</td>
</tr>
<tr>
<td>Description</td>
<td>Brief description of the selected alarm or event. If no description is</td>
</tr>
<tr>
<td></td>
<td>entered, this field is blank.</td>
</tr>
</tbody>
</table>
9.9.2 Exporting Alarms and Events to a Text File

Use the Event Export Manager to export alarms and events to a text file as they occur. In addition, you can use the Event Export Manager to set various export parameters to refine the export.

**Step 1** In the Domain Explorer window, choose **Fault > Event Export Manager**.

**Step 2** The Event Export Manager appears. In the Available Network Elements list, select the NEs that you want to export and click **Add**. In the Selected Network Elements list, select the NEs that you do not want to export and click **Remove**.

**Step 3** To export Cisco MGM-specific alarms and events, check the **Export Cisco MGM EMS Alarms/Events** check box.

**Step 4** In the Severity area, check the **Critical, Major, Minor, Warning, Indeterminate**, and/or **Cleared** check boxes. Alarms and events with a corresponding severity level will be exported.

**Step 5** Specify a destination for the file in the Export To area. Click **Browse** to browse for a particular destination. The files can also be overwritten or appended.

**Step 6** Select a field separator type in the Export Options area. In addition, check the **Stop Export when** check box, and enter a number of records. The Event Export Manager will stop exporting after the user-specified number of records are exported.

**Step 7** Click the **Start Export** tool. The Event Export Manager exports alarms and events to the specified file until **Stop Export** is selected, or until the current Cisco MGM session ends.