CHAPTER

Interface Performance

There are two performance options in CGM: performance menus and the Performance Manager. The
difference between these two options is that the Performance Manager displays historical data as well as
current data in the form of a line chart, bar chart, or table; performance menus display only current data
in a raw numerical format.

This chapter contains the following information:
¢ Interfaces and Related Technology-Specific Windows
e Starting or Stopping Global Performance Logging
e SONET Interface Performance
e DS-3 Interface Performance
¢ Ethernet Interface Performance

e Performance Manager

Interfaces and Related Technology-Specific Windows

Interfaces on line cards can support multiple technologies. Performance windows are
technology-specific. For example, an POS interface supports two technologies:

e Generic
e SONET
Therefore, to view the performance of a POS interface, you need to view two windows:
e Generic Interface Performance window
e SONET Interface Performance window
This same process is applicable to all different types of interfaces: POS, DS-3, ATM, or Ethernet. The

following table outlines which technology-specific performance windows apply to each interface type.

Table 9-1 Interface Types and Performance Windows

Interface Type Technology-Specific Performance Window
DS-3 Generic

DS-3
ATM Generic

SONET
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Table 9-1 Interface Types and Performance Windows

Interface Type Technology-Specific Performance Window
Ethernet Generic

Ethernet
POS Generic

SONET

Starting or Stopping Global Performance Logging

You can enable global performance logging on a chassis object, which puts every object within the
chassis into performance logging mode. Any objects within the chassis that are capable of collecting
performance data are enabled (such as GRPs and interfaces).

To start global performance logging on a chassis, proceed as follows:

Step 1 Right-click a chassis object, then choose CGM Management>Physical>Chassis>Configuration. The
Chassis Configuration window appears, with the Configuration tab displayed.
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Figure 9-1 Chassis Configuration Window— Configuration Tab
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Step2  Choose the relevant chassis from the list displayed at left.
Step3  Click the Start button in the Global Performance Logging area.

Performance data can now be viewed through performance menus or through the Performance Manager.

Tips  Performance logging can also be started or stopped on a per module (GRP) or physical
interface basis. For details on how to start performance logging for a selected module
(GRP), refer to “Module Performance.” For details on how to start performance logging for
a selected physical interface (such as POS, Ethernet, ATM, or DS-3), refer to “Stopping or
Starting Performance Logging” section on page 9-5.
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Generic Interface Performance

The Generic Interface Performance section covers the following areas:
e Viewing the Generic Interface Performance Window
¢ Stopping or Starting Performance Logging

¢ Generic Interface Performance Window—Detailed Description

Viewing the Generic Interface Performance Window

To view the Interface Performance window, proceed as follows:

Step1  Right-click on a selected interface, then choose CGM Management>Physical>Interface>Generic>

Performance. The Performance 1 tab appears.

Figure 9-2 Interface Performance Window—Performance 1 Tab

Not applicable to CGM

0702

Step 2 Choose the relevant chassis, module, and interface from the list boxes at left. The interface performance

information for the selected interface appears in the tabs at right.
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Stopping or Starting Performance Logging

Tips

You can start or stop performance logging on a selected interface by clicking the appropriate button.

e Starting performance logging allows performance data to be gathered for the selected module.
Performance polling occurs every 15 minutes. Performance data is then gathered and stored for
historical review. Current performance data can be viewed in the performance windows, or you can
view historical performance data in Performance Manager.

If either Stop or Start has already been selected, that button will not be available. You must
start performance logging if you want to view historical data in the Performance Manager
or if you want to view current data in the performance menus.

Generic Interface Performance Window—Detailed Description

The Interface Performance window contains two tabs: Performance (1) and Performance (2).

Performance (1) Tab

General Information

The Performance (1) tab contains three areas: General Information, Packets/Octets Statistics, and
Performance Logging.

The General area contains the following fields:
Resets—Number of times the interface is internally reset.
Transmitted Bandwidth Utilization—Percentage of transmitted bandwidth utilization.

Received Bandwidth Utilization—Percentage of received bandwidth utilization.

Packets/Octets Statistics

The Packets/Octets Statistics area contains the following fields:

In Octets—Total number of packets received on the interface, including framing characters.

Out Octets—Total number of packets transmitted out of the interface, including framing characters.
In Bits/sec—Five-minute exponentially decayed moving average of input bits per second.

Out Bits/sec—Five-minute exponentially decayed moving average of output bits per second.

In Packets/sec—Five-minute exponentially decayed moving average of input packets per second.
Out Packets/sec—Five-minute exponentially decayed moving average of output packets per second.

In Unicast Packets—Total number of packets received by the layer which were not addressed as
multicast or broadcast.

Out Unicast Packets—Total number of packets transmitted by the layer which were not addressed as
multicast or broadcast.

In Multicast Packets—Not applicable to CGM.
Out Multicast Packets—Not applicable to CGM.
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In Broadcast Packets—Not applicable to CGM.
Out Broadcast Packets—Not applicable to CGM.

Performance Logging

You can either start or stop performance logging by clicking the appropriate button.

Performance (2) Tab

The Performance (2) tab appears as follows.

Figure 9-3 Interface Performance Window —Performance 2 Tab
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The Performance (2) tab contains one area, Error Statistics.

Error Statistics

The Error Statistics area contains the following fields:

Runts—Number of packets input which were smaller than the physical media permitted.
In Errored Packets—Number of inbound packets that contained errors.
Giants—Number of input packets which were larger than the physical media permitted.

In Discarded Packets—Number of inbound packets chosen to be discarded even though no errors were
found.

Cisco GSR Manager User Guide
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Collisions—Number of output collisions detected on this interface.

In Packets Dropped—Number of packets dropped because the input queue was full.

Aborted Packets—Number of input packets which were aborted.

Out Errored Packets—Number of outbound packets that could not be transmitted because of errors.
Ignored Packets—Number of input packets which were ignored by the interface.

Out Packets Dropped—Number of packets dropped because the output queue was full.

Misaligned Packets—Number of input packets which were misaligned.

CRC Errored Packets—Number of input packets which had cyclic redundancy checksum errors.

SONET Interface Performance

The SONET Interface Performance section covers the following areas:
e Viewing the SONET Interface Performance Window
¢ SONET Performance Window—Detailed Description

Viewing the SONET Interface Performance Window

To view the SONET Interface Performance window, proceed as follows:

Step 1 Right-click on a selected interface, then choose CGM Management>Physical>Interface>SONET>
Performance. The SONET Interface Performance window appears with the Section tab displayed.

Cisco GSR Manager User Guide
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Figure 9-4 SONET Interface Performance — Section Tab
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Step 2 Choose the relevant chassis, module, and SONET interface from the list boxes at left. The interface
performance information for the selected interface appears in the tabs at right.

SONET Performance Window—Detailed Description

The SONET Performance window has four tabs:
e Section
e Line
e Path
e Virtual Tributary (not applicable to CGM)

Cisco GSR Manager User Guide
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Section Tab

The Section tab displays the following fields:
Errored Seconds—Total number of errored seconds encountered by SONET interface.
Severely Errored Seconds—Number of severely errored seconds encountered by the SONET interface.

Severely Errored Framing Seconds—Number of severely errored framing seconds encountered by the
SONET interface.

Coding Violations—Number of coding violations encountered by the SONET interface.
Line Tab
The Line tab appears as follows.

Figure 9-5 SONET Interface Performance—Line Tab
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The Line tab has two areas, Line and Far End Line.
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Line
The Line area displays the following fields:
Errored Seconds—Total number of errored seconds encountered by the SONET line.
Severely Errored Seconds—Number of severely errored seconds encountered by the SONET line.
Unavailable Seconds—Total number of unavailable seconds encountered by the SONET line.

Coding Violations—Number of coding violations encountered by the SONET line.

Far End Line

The Far End Line area displays the following fields:
Errored Seconds—Total number of far end errored seconds encountered by the SONET line.

Severely Errored Seconds—Number of far end severely errored seconds encountered by the SONET
line.

Unavailable Seconds—Total number of far end unavailable seconds encountered by the SONET line.

Coding Violations—Number of far end coding violations encountered by the SONET line.

Path Tab

The Path tab appears as follows.
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Figure 9-6 SONET Interface Performance —Path Tab
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The Path tab has two areas, Path and Far End Path.

Path
The Path area displays the following fields:
Errored Seconds—Total number of errored seconds encountered by the SONET path.
Severely Errored Seconds—Number of severely errored seconds encountered by the SONET path.
Unavailable Seconds—Total number of unavailable seconds encountered by SONET path.
Coding Violations—Number of coding violations encountered by the SONET path.
Far End Path

The Far End Path area displays the following fields:

Errored Seconds—Total number of far end errored seconds encountered by the SONET path.
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Severely Errored Seconds—Number of far end severely errored seconds encountered by the SONET
path.

Unavailable Seconds—Total number of far end unavailable seconds encountered by the SONET path.

Coding Violations—Number of far end coding violations encountered by the SONET path.

Virtual Tributary Tab

The Virtual Tributary tab is not applicable to CGM.

DS-3 Interface Performance

The DS-3 Interface Performance section covers the following areas:
e Viewing the DS-3 Interface Performance Window

e DS-3 Performance Window — Detailed Description

Viewing the DS-3 Interface Performance Window

To view the DS-3 Interface Performance window, proceed as follows:

Step 1 Right-click on a selected DS-3 interface, then choose CGM Management>Physical>Interface>
DS-3>Performance. The DS-3 Interface Performance window appears.

Cisco GSR Manager User Guide
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Figure 9-7 DS3 Interface Performance Window
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Step 2 Choose the relevant chassis, module, and DS-3 interface from the list boxes at left. The interface
performance information for the selected interface appears in the tabs at right.

DS-3 Performance Window — Detailed Description

The DS-3 Performance tab has two areas: DS-3 Statistics and Far End DS-3 Statistics.

DS-3 Statistics

The DS-3 Statistics frame on the Performance-DS-3 tab displays the errors encountered by the interface.
C-bit Errored Seconds—Number of C-bit errored seconds detected by the interface.

C-bit Severely Errored Seconds—Number of times C-bit severely errored seconds detected by the
interface.

C-bit Coding Violations—Number of C-bit coding violations encountered by the interface.

Cisco GSR Manager User Guide
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P-bit Errored Seconds—Number of times P-bit errored seconds detected by the interface.

P-bit Severely Errored Seconds—Number of P-bit severely errored seconds encountered by the
interface.

P-bit Coding Violations—Number of P-bit coding violations detected by the interface.
Line Errored Seconds—Number of line errored seconds detected by the interface.

Severely Errored Framing Seconds—Number of times severely errored framing seconds detected by the
interface.

Line Coding Violations—Number of code line violations.

Unavailable Seconds—Count of the unavailable seconds encountered by interface.

Far End DS-3 Statistics
The Far End DS-3 Statistics frame on the Performance DS-3 tab displays the following errors:

C-bit Errored Seconds—Number of far end C-bit errored seconds detected by the interface.

C-bit Severely Errored Seconds—Number of times far end C-bit severely errored seconds detected by
the interface.

C-bit Coding Violations—Number of far end C-bit coding violations encountered by the interface.

Unavailable Seconds—Count of the far end unavailable seconds encountered by the interface.

Ethernet Interface Performance

The Ethernet Interface Performance section covers the following areas:
e Viewing the Ethernet Interface Performance Window

e Ethernet Performance Window—Detailed Description

Viewing the Ethernet Interface Performance Window

To view the Ethernet Interface Performance window, proceed as follows:

Step 1 Right-click on an Ethernet interface, then choose CGM Management>Physical>Interface>
Ethernet>Performance.

Cisco GSR Manager User Guide
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Figure 9-8 Ethernet Interface Performance Window
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Not applicable for CGM

Step 2 Choose the relevant chassis, module, and interface from the list boxes at left. The Ethernet interface
performance information for the selected interface appears in the tabs at right.

Ethernet Performance Window—Detailed Description

The Ethernet Interface Performance tab has two areas: General Statistics and Collision Statistics.

General Statistics

The General Statistics frame on the Performance—Ethernet tab displays the following statistics:

Alignment Error—Frames received count with alignment error status.

Cisco GSR Manager User Guide
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Frame Check Sequence Errors—Frames received count with Frame Check Sequence Error status.

Multiple Collision Frames—Count of frames transmitted across an interface where more than one
collision exists.

Single Collision Frames—Count of frames transmitted across an interface with one collision.

Single Quality Errors (SQE)—Count of SQE error messages generated by the interface.

Deferred Transmissions—Number of first transmissions attempts delayed because the medium was busy.

Late Collisions—Number of times a collision is detected in the interface.

Excessive Collisions—Number of time transmission failed due to excessive collision.

Internal MAC Transmit Errors—Count of frames transmitted that failed due to an external transmit error.

Internal MAC Receive Errors—Number of frames transmitted failed due to internal receive error.

Frames Too Long—Number of frames transmitted, where the size of the frames being larger than
permissible frame size.

Carrier Sense Errors—Number of times the carrier sense was lost while transferring frames.

Collision Statistics

The Collision Statistics frame is not applicable to CGM.

Performance Manager

Step 1

The Performance Manager collects historical performance data for interfaces. You can only view
performance information in Performance Manager if you have enabled performance logging. You can do
this either globally or individually on interfaces.

The Performance Manager collects data for all different technologies on an interface. For example, if
you want to view Performance Manager data for an ATM interface, performance attributes are listed for
Generic and SONET technologies, because both apply to ATM interfaces.

You can open the Performance Manager for a selected interface within the Map Viewer (Viewer)
application. Once you have opened the Map Viewer application, perform the following steps:

Right-click on a selected interface, then choose Tools>Performance Manager. The Performance
Manager window appears, with the Line Chart tab displayed by default.

Cisco GSR Manager User Guide
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Step 2

Step 3

Step 4

Step 5

Performance Manager

Figure 9-9 Performance Window (Line Chart Tab)
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The Performance Manager window consists of four left hand panes, and three tabbed sections at right.
First, choose the fields you want from the left hand areas. The data is displayed in the tabs at right.

Choose the attribute you want to monitor from the Monitored Attributes pane (for details on this pane,
refer to “Performance Manager Window—Detailed Description.”) You can choose multiple contiguous
attributes in a list by holding down the Shift key and then selecting the first and last attributes in the list.
You can choose multiple individual attributes by holding down the Ctrl key and clicking on individual
items. Only the first selected attribute is shown in the line chart or bar chart. The table display tab shows
all selected attributes.

Now, choose the time fields in the Time Period area.

Set the start date. Enter the date on which you want to begin viewing performance data in the Start Date
entry boxes. The format must be mm/dd/yyyy.

Set the start time. Enter the time you want the performance data to start on in the Start Time data entry
boxes. Set a start time and an end time using the 24 hour clock notation. The times are inclusive.

Set the end date. You have two options when setting the end date. Enter the date on which you want to
stop viewing performance data in the End Date entry boxes. The format must be mm/dd/yyyy. Or, check
the Now checkbox to view the data from the selected start date to the current time. By selecting this
option, you do not have to update the end date and time fields.

| Software Release 2.0.1
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Step 6

Step 7

Step 8

Step 9

Set the end time. You have two options when setting the end time. Enter the end date on which you wish
to stop viewing performance data in the End Time entry boxes. The format must be mm/dd/yyyy. Or,
check the Now checkbox to view the data from the selected start date to the current time. By selecting
this option, you do not have to update the end date and time fields.

Choose the summary interval from the drop down list. The summary interval is the period of time over
which the rule is applied. This varies according to the attribute selected. You can choose the Raw option,
which displays performance data in its most detailed format, not summarized.

~

Note  When you choose Raw, the bar chart view is not available, and the Summary Rule
option is grayed out.

Click Refresh Screen. This initiates your request for data. Refresh Screen is blue when it is available
for selection and grayed out when not available. Refresh Screen is available for selection when Now is
selected or when any criteria has changed and you have moved the cursor away from the changed value
(for example, by pressing the Tab key or by using the mouse).

A line chart of the performance information you requested is displayed at right. You can click on any of
the three tabs to display your data differently.

~

Note  The performance information corresponds to the attributes’ raw values. If you
choose a summary period, the information is displayed according to the summary
rule. No summary period is associated with raw data.

Performance Manager Window—Detailed Description

The Performance Manager window has one primary pane at left: the Monitored Attributes pane. The
Performance Manager window also contains three tabs: the Line Chart tab, Bar Chart tab, and Table
Display tab.

Monitored Attributes

Line Chart Tab

The monitored attributes list at left allows you to select which specific attribute you want to view

performance information for. The fields in this list change, depending upon which type of interface you
have selected. For example, if your selected interface is an ATM line card, you will be able to select all
the performance fields that can be found on the following performance windows: SONET Performance,
and Generic Performance. Both of these technologies apply to ATM line cards, therefore all performance

information for both technologies is listed in the Performance Manager. This list can be rather extensive.

The Line Chart tab displays the retrieved data in a graphical format. The X-axis depicts the time at
which the polling was done, and the Y-axis depicts the value retrieved or the value when the equipment
did not respond properly.

Further information regarding the element, units, and missed polls is provided, using the appropriate
color coding displayed at the top of the chart. Blue represents the values retrieved and red identifies any
polled values missed.

Cisco GSR Manager User Guide
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Performance Manager W

Bar Chart Tab

The information on this tab is shown as a bar chart with the retrieved data. Blue represents the values
retrieved and red identifies any polled values missed.

Table Display Tab

This tab displays the data retrieved in a tabular format. The first column shows the time of polling, and
the second column shows the retrieved values. Blue represents the values retrieved and red identifies any
polled values missed.

Missed Polls

In some circumstances, possibly due to Cisco EMF being shut down or heavy network loads, an object
might fail to be monitored. This is known as a missed poll. All missed polls are indicated on Performance
Manager graphs and charts by a yellow point. The last valid value collected is shown. A missed poll
affects the summary data and you should not rely upon such data.

Performance Manager graphs and charts also indicate when an attribute started and stopped being polled
due to history storage criteria being added, edited or removed. Start and stop polling events are shown
in charts and tables. The start polling events point is shown in green, and the stop polling events point is
shown in red.

A polling events key is displayed for selection.

Cisco GSR Manager User Guide
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