Configure Devices

This chapter provides the following topics:

* Ways to Configure Devices Using Cisco Evolved Programmable Network Manager, on page 1
» Which Devices Support the Configuration Operations?, on page 2

* Identify the Commands Used In a CLI Configuration Template, on page 2

* Change a Device's Credentials and Protocol Settings, on page 3

* Change Basic Device Properties, on page 3

* Enable and Disable Interfaces, on page 4

* Configure Physical Attributes of Device Interfaces, on page 5

* Configure Circuit Emulation , on page 9

* Synchronize the Clock Using Sync-E, BITS, and PTP, on page 28

* Configure IP SLAs (TWAMP Responder/TWAMP Light Responder), on page 34
* Configure Interfaces, on page 37

* Configure Devices Using the Chassis View, on page 65

* Configure Optical Cards, on page 80

* Discover and Configure MPLS LDP and MPLS-TE Links, on page 94

* Analyze Ports Using SPAN and RSPAN, on page 97

* Configure and View Ethernet Link Aggregation Groups , on page 99

* Configure Routing Protocols and Security, on page 102

* Configure Segment Routing, on page 110

* Configure EOAM Fault and Performance Monitoring, on page 118

* Configure Quality of Service (QoS) , on page 124

* Save Your Device Changes, on page 137

* Launch Cisco Transport Controller to Manage Cisco NCS and Cisco ONS Devices, on page 138

Ways to Configure Devices Using Cisco Evolved Programmable
Network Manager

Cisco EPN Manager provides two ways to change the physical devices in your network. The actions you can
perform depend on your user account privileges and the types of devices in your network.
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. Which Devices Support the Configuration Operations?

Launch Points for | Use this method to:
Configuring
Devices

Configuration Click on a Device Name, then click the Configuration tab.
menu from
left-side
navigation menu

You can configure device features on the selected device. You can also view the list of
applied and scheduled feature templates that were deployed to the device.

Create and deploy | Perform common network management tasks on one or more devices using system
configuration templates—for example, adding a hostname or configuring a routing protocol. You can
templates also create your own templates to fit your deployment needs. Because they can be applied
to multiple devices, templates normally apply to specific device operating systems or
device types. When you use a configuration template, Cisco EPN Manager only displays
devices that meet the template criteria.

\)

Note  You can also edit device properties from the Network Devices table (Configuration > Network >
Network Devices) by choosing a device and clicking Edit. This launches the device Edit Wizard.
However, changes you make using the wizard are limited to device credentials, and any changes you
make do not affect the physical device; they only update device information that is stored in the database.

For optical devices, you can also configure devices using Cisco Transport Controller, which you can launch
from Cisco EPN Manager. See Launch Cisco Transport Controller to Manage Cisco NCS and Cisco ONS
Devices, on page 138

After you make your changes, save your changes to the database and optionally collect the device's physical
and logical inventory. For more information, see Collect a Device's Inventory Now (Sync), on page 137.

Which Devices Support the Configuration Operations?

Configuration operations are supported on a device if:

* The device model is supported by Cisco EPN Manager.
* The device operating system is supported by Cisco EPN Manager.

» The applicable technology or service is supported by Cisco EPN Manager and is enabled on the device.

To find out what is supported, see Cisco Evolved Programmable Network Manager Supported Devices.

Identify the Commands Used In a CLI Configuration Template

Use this procedure to view the exact commands that are used by any of the commands you launch from the
CLI Templates drawer.

Step 1 Choose Configuration > Templates > Features and Technologies, then choose CLI Templates. For example:

. Configure Devices


http://www.cisco.com/c/en/us/support/cloud-systems-management/evolved-programmable-network-epn-manager/products-device-support-tables-list.html

| Configure Devices
Change a Device's Credentials and Protocol Settings .

* Out-of-the-box templates are under System Templates - CLI.

* Customized templates are under My Templates.

Step 2 Double-click the template in the left sidebar Templates menu.
Step 3 In the Template Detail area, choose the CLI Content tab. The commands are displayed in that tab.

Change a Device's Credentials and Protocol Settings

Use the following procedure to update device credentials and protocol settings. When you save the settings
to the database, you can also perform an inventory collection to gather all physical and logical device changes
and save those changes to the database, rather than wait for the daily inventory collection.

Step 1 Choose Inventory > Network Devices.
Step 2 Select the device you want to edit, and click Edit. You can also choose several devices and make bulk changes.
Step 3 Double-click the parameters you want to change. Depending on the device type, you can edit:

* Credential profile being used by device

* Group the device belongs to

* SNMP port, retries, timeout, credentials, and SNMPv3 authentication information
* Telnet/SSH2 credentials and timeout

* HTTP/HTTPS credentials, port, timeout

* TL1 credentials and proxy IP address (for GNE/ENEs)

* Civic Location

Step 4 Check that the new credentials are the same as those on the physical device by clicking Verify Credentials.
Step 5 Save your changes:

 Update saves your changes in the database.

 Update & Sync saves your changes to the database, but also collects device physical and logical inventory and
saves all changes to the database.

Change Basic Device Properties

Cisco EPN Manager provides command templates that you can use to make basic property changes on your
physical devices. To use these templates, choose Configuration > Templates > Features & Technologies,
then choose CLI Templates > System Templates — CLI from the Templates pane on the left.
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Note

The operations that you perform here are different from those you perform with the Edit wizard (which

you can launch from the Network Devices table). The Edit wizard changes the device property information
that is saved in the database. It does not change properties on physical devices.

CLI Configuration Template Name |Use it to: Required Input Values
Add-Host-Name-10S and -IOS-XR | Configure the client host name Host name
Remove-Host-Name-I0S and

-I0S-XR

Syslog-Host-Logging-10S and Specify host to which messages of a Host name

-I0S-XR

certain level will be logged

Add-Tacacs-Server-IOS and
-I0OS-XR

Remove-Tacacs-Server-IOS and
-IOS-XR

Add-Tacacs-Plus-Server-IOS and
-IOS-XR

Remove-Tacacs-Plus-Server-IOS
and -I0S-XR

Configure the TACACS or TACACS+
server to use for authentication

Host address, key value,
authentication list name,
group name

Add-SNMP-Configuration-IOS and
-IOS-XR

Remove-SNMP-Configuration-I0S
and -I0S-XR

Configure SNMP version, password,
password encryption, server and group
settings, UDP port, and so forth

Host name, community
name, SystemOwner

Enable-Traps-ASR903

Disable-Traps-ASR903

Enable and disable traps on the Cisco ASR
903

Enable-Traps-10S and -I0S-XR

Disable-Traps-10S and -I0S-XR

Enable and disable traps on Cisco IOS and
Cisco I0S XR devices

Trap name (a list is
provided)

Enable-Trap-Host-10S and IOS-XR

Set a target host for SNMP traps

Host IP address,
community string

Show-Users-on-Device-IOS and
-IOS-XR

Display user session information for Cisco
IOS and Cisco I0S XR devices

(Executed from selected
device; no input required)

Enable and Disable Interfaces

Use the Interface 360 view to quickly enable and disable an interface. While you can perform these same
actions from a Device Details page, using the Interface 360 view may be more efficient (for example, when
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responding to an alarm). The top right of the Interface 360 view provides an Actions menu that provides

enable and disable options.

To launch an Interface 360 view, see Get a Quick Look at a Device Interface: Interface 360 View.

To enable and disable an interface from a device's Device Details page, see the interface configuration topics
(Ethernet, Loopback, Serial, Tunnel, and so forth).

Configure Physical Attributes of Device Interfaces

Using Cisco EPN Manager, you can configure the physical attributes of your device's interfaces. Attributes
such as card operating modes, bandwidth allocation per slot, slot pluggable types (such as VCoP), and AINS
settings are configurable.

Step 1
Step 2
Step 3
Step 4
Step 5

To configure the physical attributes of interfaces:

Choose Configuration > Network Devices.

Select the device that you want to configure by clicking the device’s name hyperlink.
Click the Logical View tab.

To configure the interfaces, navigate to the paths described in the table below.

To make your changes, click the controller/card name hyperlink and click the Edit icon at the top right corner of the page.
Make your changes and click Save.

Table 1: Physical Attributes Configuration for Interfaces

Physical Interface
Configuration

Navigation

Comments/Descriptions

Supported
Slots/Controllers

Configure card
type as 5G or 10G.

Physical > Card
Mode

You can change the configuration from 10G to 5G but
the other way around is not supported. Depending on the
device you select, the default card mode is set to either
5G or 10G. For mode detailed information on the
supported card modes, see Supported Devices for Cisco
EPN Manager

Note You cannot configure the card modes on slots

that are part of active circuits.

For more information
about the device slots
and supported card
mode types, see table
below (Device Sots
and Supported Card
Mode Types).

Configure card
modes as T1 or
El.

Physical > Card
Mode

You can change the configuration from T1 to E1 or vice
versa depending on the device and card you select.

T1 and E1 modes represent the type of channelization
mode used on the card.

Note You cannot configure the card modes on slots

that are part of active circuits.

Configure Devices .



bk-cisco-evolved-programmable-manager-5-0-1-user-and-administrator-guide_chapter3.pdf#nameddest=unique_155
http://www.cisco.com/c/en/us/support/cloud-systems-management/evolved-programmable-network-epn-manager/products-device-support-tables-list.html
http://www.cisco.com/c/en/us/support/cloud-systems-management/evolved-programmable-network-epn-manager/products-device-support-tables-list.html

. Configure Physical Attributes of Device Interfaces

Configure Devices |

Physical Interface
Configuration

Navigation

Comments/Descriptions

Supported
Slots/Controllers

Configure card
modes as OC3 or
OcCl12.

Physical > Card
Mode

You can set the card modes of A900-IMA4OS cards (of
Cisco ASR 903 routers) as OC3 or OC12.

0OC3 and OC12 modes represent the data transmission
rates on the different optical transmission lines.

Configure Card
Protection

Physical > Card
Protection

Configure cards to act as primary or backup members
(interfaces). A primary interface and its backup interface
together make up a Protection Group (denoted by a unique
integer). Associating cards with backup members ensures
that when the primary interface fails, the protecting
interface quickly assumes the traffic load from the primary
interface. Cards displayed as the Active members are
cards functioning as the protecting members of the
service.

Ensure that the Primary and Backup members are of the
same type. For example, if you choose a T1 interface as
a Primary member, the Backup member must also be a
T1 interface.

Hold-Off Timer is available for 1+1 card protection (NCS
42XX devices having IOS-XE version 16.10.1 or higher).
It is used to prevent the successive switching in case of
network inconsistency. The valid range is from 0 to 10
seconds. Default value is 5.

The Admin Mode for the protection group is configured
in the order Lockout > Force Switch > Manual Switch >
None. For more information about these modes and the
revert timer, see the descriptions in Configure APS or
MSP and UPSR or SNCP Protection Groups, on page 15.

Configure
NCS4200-1T16G-PS
cards on NCS42xx
devices.

Physical > Card
Mode

You can view all the card modes of NCS4200-1T16G-PS
cards, irrespective of the slot numbers.

Once you configure NCS4200-1T16G-PS card
on some slots of NCS42xx devices, the
configurations on those slots will be reset to
the default values.

Note

Configure
AY0IMARCT1Z-M
and
AY0-IMASCS1Z-M
cards on ASR9xx
devices.

Physical > Card
Mode

You can view and configure the card modes of
A900-IMASCT1Z-M and A900-IMASCS1Z-M cards.
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Physical Interface | Navigation Comments/Descriptions Supported
Configuration Slots/Controllers
Configure the Physical > Use the Cards tab to configure the right controller types | -
interface module | Automatic for AINS. In case of manual insertion and removal of
type for In-Service cards, the AINS values are populated after a 20 min delay.
ﬁ:g:;lvailgg (AINS) (AINS) The ports/controllers tabs list all the AINS enabled ports
and controllers. The supported ports and controllers are:
Ethernet, E1, E3, T1, T3, and SONET and SDH. You can
use the Edit icon to set the Secondary Admin State and
Soak Timer (in hours or in minutes) values.
Note: Enabling AINS on a port/controller is an operation
to be performed on the device manually.
Following are the Secondary Admin State values that you
can set:
* I[S_AINS—indicates that the device is in Automatic
In-Service state.
* [S—indicates that the device is in in-service state.
* OOS_MT—indicates that the device is in
maintenance state.
Use the Soak Timer Hours field to set the soak timer in
hours. The valid range is 0-48 hours. Use the Soak Timer
Minutes drop-down list to set the soak timer in minutes.
The available values are: 15, 30, and 45 minutes. The
default value is 15 minutes.
Configure Physical > The bandwidth you specify is reserved for the selected | You can reserve a
bandwidth that Bandwidth slot and made available to the slot irrespective of whether | pre-configured
must be reserved the slot is operational or not. In cases when the selected | bandwidth value of 80
for the selected slot/card is down, and then back online after sometime, |or 100 Gbps on
device slots. the configured bandwidth will be available for use based | NCS4200-1T16G-PS
on the values specified in this field. cards on NCS4216
devices.
Configure the Physical > Use this menu to select the right port types for VCoP -
interface Pluggable Type |enabled interfaces. For example, the port types can be
pluggable type for 0C3, 0OC12, or DS3.

virtual Container
over Packet
(VCoP).

Note VCoP smart SFP provides an ability to forward
the SONET signal transparently across the
packet network. The VCoP smart SFP is a
special type of optical transceiver which
encapsulates SONET bit stream at STS1 or

STS-3c or STS-12c level into packet format.
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Conditions and Limitations: Following are the conditions and limitations for configuring controller modes on Cisco
ASR 900 Series Route Switch Processor 2 (RSP2A) modules (A900-RSP2A-128) that are supported on Cisco ASR 920,
Cisco NCS4202, and Cisco NCS 4206 devices:

* The maximum bandwidth that can be configured is OC-48. A maximum of 20 ports on the module can be configured:

* Ports 0-11 are T1 ports
* Ports 12-15 are T3/E3 ports
* Ports 16-19 are OC3/0OC12 ports.

Note If a given port is configured as OC48, then only one of the given port can be configured since the

maximum configurable bandwidth is OC48.

* Configuration limitations on the Cisco A900-RSP2A-128 modules:
* You cannot configure SDH/E3/E1/DSO0 controller modes.

* Configuring Ethernet as the controller mode is not supported.
* The protection type UPSR cannot be configured.

* Once you deploy the controller mode configuration to the device, you cannot undo the configuration using
Cisco EPN Manager.

Table 2: Device Slots and Supported Card Mode Types

Cisco NCS 4206 Devices

Cisco NCS 4216 Devices

Cisco ASR903 Devices

Cisco ASR907 Devices

* Slot 0, 1 - Not
supported

e Slot 2, 3,4, 5 - Default
Mode 10G

» Slot 0, 1 - Not
supported

*Slot3,4,7,8, 11, and
12 - Default Mode 10G

«Slot2,5,6,9, 10, 13,
14 and 15 - Default
Mode 5G

* Slot 0, 1 - Not
supported

e Slot 2, 3,4, 5 - Default
Mode 10G

* Slot 0, 1 - Not
supported

*Slot3,4,7,8, 11, and
12 - Default Mode 10G

«Slot2,5,6,9, 10, 13,
14 and 15 - Default
Mode 5G

Table 3: Controller Modes and Supported Port Types

SONET (0-3)

SONET (4-7)

e Max of 2.5G

* Can support OC48/0C12/0OC3 but total of 2.5G

« Example if Port 0 configured with OC48, Port1/2/3

can't be used.

e Max of 2.5G

* Ifa port group has OC12/0OC3/1G it means OC48 can't

be allowed
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Configure Circuit Emulation

Cisco EPN Manager supports the provisioning of Circuit Emulation (CEM) which provides a bridge between
traditional TDM network and packet switched network (PSN). CEM is a way to carry TDM (or PDH) circuits
over packet switched network. Circuit Emulation (CEM) is the imitation of a physical connection. This feature
allows you to use your existing IP network to provide leased-line emulation services or to carry data streams
or protocols that do not meet the format requirements of other multiservice platform interfaces.

Cisco EPN Manager supports the following CEM modes:

* Structure-Agnostic time-division multiplexing (TDM) over Packet (SAToP)—This is the unstructured
mode in which the incoming TDM data is considered as an arbitrary bit stream. It disregards any structure
that may be imposed on the bit stream. SAToP encapsulates the TDM bit streams as pseudowire (PWs)
over PSN.

* Circuit Emulation over Packet (CEP)—This mode is used to emulate Synchronous Optical
Network/Synchronous Digital Hierarchy (SONET/SDH) circuits and services over MPLS. To transport
SONET/SDH circuits through a packet-oriented network, the Synchronous Payload Envelope (SPE) or
Virtual Tributary ( VT) is broken into fragments. A CEP header and optionally an RTP header are
prepended to each fragment.

For more information about CEM in Cisco EPN Manager, see, Supported Circuit Emulation Services.

When a line is channelized, it is logically divided into smaller bandwidth channels called higher-order paths
(HOP) and lower-order paths (LOP). These paths carry the SONET payload. When a line is not channelized,
the full bandwidth of the line is dedicated to a single channel that carries broadband services. Cisco EPN
Manager enables you to channelize the T3 or E3 channels into T1s, and channelize the T1s further into DSO
time slots. Before you provision CEM services using Cisco EPN Manager, you must first configure the
parameters for the HOP and LOP by configuring the interfaces for CEM.

A channelized SONET interface is a composite of STS streams, which are maintained as independent frames
with unique payload pointers. The frames are multiplexed before transmission. SONET uses Synchronous
Transport Signal (STS) framing while SDH uses Synchronous Transport Mode (STM) framing. An STS is
the electrical equivalent to an optical carrier 1 (OC-1) and an STM-1 is the electrical equivalent to 3 optical
carrier 1s (OC-1s).

This section describes how you can use Cisco EPN Manager to first configure your interfaces for CEM. You
can then provision CEM services using these interfaces configured with appropriate controller modes and
protection groups.

Pre-requisites for Configuring CEM Services

Before you provision a CEM service (see Provision Circuit Emulation Services), ensure that the following
pre-requisites are met:

* Configure the required loopback settings for CEM on the device. See, Configure Loopback Interfaces,
on page 39.

* Configure the required CEM parameters on SONET, SDH, PDH, HOP, and HOP controllers. See,
Configure Interfaces for CEM, on page 11.

* Configure the working and backup interface groups to provide APS protection. See, Configure APS or
MSP and UPSR or SNCP Protection Groups, on page 15.
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SONET Modes Configuration Examples

The following configuration commands and examples shows how to configure STS-1 modes.
Configure STS-1 Modes

To configure STS-1 modes, use the following commands:

enable
configure terminal
controller sonet 0/5/0

sts-1 1
mode vt-15
end

\)

Note There is no default mode. The modes vt-15, mode ct3, mode t3, mode unframed, mode vt-2 are supported.
To restore the system to its default condition, use the no form of the command.

Configuring DS1/T1 CT3 mode of STS-1:
To configure DS1/T1 CT3 mode of STS-1, you can configure the T1 link using the following steps:

enable

configure terminal
controller sonet 0/5/0
sts-1 1

mode ct3

tl 1 clock source internal
tl 1 framing unframed

end

)

Note To restore the system to its default condition, use the no form of the command.

Configuring STS-Nc - Contiguous Concatenation

To configure STS-Nc - contiguous concatenation, use the following commands:

enable

configure terminal
controller sonet 0/5/0
sts-1 1-3 mode sts-3c
end
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\)

Note To restore the system to its default condition, use the no form of the command. Also, to configure STS-3¢
or STS-12c, use the numbers as multiples for 3 or 12, respectively.

Configuring CEM Group for Sonet Mode VT1.5-T1 in CESoPSN
To configure CEM group in VT 1.5 mode of STS-1 for CESoPSN, use the following commands

enable

configure terminal

controller sonet 0/5/0

sts-1 2

mode vt-15

vtg 1 t1 1 cem-group 56 timeslots 1 - 8
end

Configuring CEM Group for Sonet Mode CT3-T1 in CESoPSN
To configure CEM group in CT3 mode of STS-1 for CESoPSN, use the following commands:

enable

configure terminal

controller sonet 0/5/0

sts-1 1

mode ct3

tl 3 cem-group 28 timeslots 1 - 7
end

Configure Interfaces for CEM

Using Cisco EPN Manager, you can configure your interfaces with Circuit Emulation (CEM). To do this, you
must set the appropriate controller modes on your interfaces and then configure the PDH (E1, T1, E3, T3),
SONET, and SDH controllers for CEM. After you configure the interfaces with CEM, you can then use the
interfaces for provisioning CEM services. See Provision Circuit Emulation Services.

To configure the interfaces for CEM:

Step 1 Choose Configuration > Network Devices.

Step 2 Select the device that you want to configure by clicking the device name hyperlink.
Step 3 Click the Logical View tab.

Step 4 To configure CEM parameters, navigate to the configuration options as described in the following table.

Step 5 To make your changes, click the controller/card name hyperlink and click the Edit icon at the top-right corner of the page.
Make your changes and click Save.
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Example

Table 4: CEM Interface Configuration Options
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CEM Interface
Configuration

Navigation

Comments /
Descriptions

Supported
Slots/Controllers

Configure controller
modes as SONET, SDH,
Ethernet, T3, or E1, E3,
or STS1E.

Circuit Emulation > Controller
Mode

The
controller
mode options
displayed for
selection are
based on the
selected
media type.
For details,
see
Controller
Modes and
Supported
Port Types.

Configure PDH (E1, T1,
E3, and T3) controllers

Circuit Emulation > PDH

For a
description of
the different
PDH
parameters,
see CEM
Interface
(PDH,
SONET, and
SDH) Field
Descriptions,
on page 19

Configure SONET and
SDH controllers for CEM

Circuit Emulation > SONET and
SDH

Fora
description of
the different
SONET and
SDH
parameters,
see CEM
Interface
(PDH,
SONET, and
SDH) Field
Descriptions,
on page 19

For more information
about the device ports and
supported controller types,
see following table
(Controller Modes and
Supported Port Types).
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CEM Interface Navigation Comments/ |Supported
Configuration Descriptions | Slots/Controllers
Configure a working and | Circuit Emulation > Protection See -
protecting member Group Configure
interface for CEM APS or MSP
provisioning. and UPSR or

SNCP

Protection

Groups, on

page 15

Controller Modes and Supported Port Types
* There are pair wise restrictions for EOWYN IM. Valid pairs are (0,1) (2,3) (4,5) (6,7).

N

Note For each pair, you can configure maximum of 2.5Gbps(OC48)
bandwidth(both ports combined).

* You can only configure rates OC3/0OC12/0C48 for ports 0-7 and only rate OC192 on port 8.

Table 5: Bandwidth used by different rates OCN -> n * 51.84 Mbit/s

Rate Configuration Bandwidth

OCl1 51.84 Mb/s

0C3 155.52 Mb/s

0C12 622.08 Mb/s

0C438 2488.32 Mb/s ~= 2.5 Gb/s
0C192 9953.28 Mb/s ~= 10 Gb/s

Configure MediaType Controller

To configure MediaType Controller, use the following commands:

enable

configure terminal
controller MediaType 0/5/0
mode sonet

end

Configure SONET Ports

To configure SONET ports, use the following commands:

enable

configure terminal
controller MediaType 0/5/0
mode sonet

controller sonet 0/5/0
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rate
end

The earlier example shows how to configure SONET ports in OC-12 mode.

OoC1l2

Configure STS1E Ports

To configure STS1E ports, use the following commands:

NCS4200-120.33#sh run | sec 0/4/0
controller MediaType 0/4/0

mode stsle

controller STSIE 0/4/0

no snmp trap link-status

no ais-shut

alarm-report all
secondary-admin-state auto-in-service
clock source internal

cablelength short

overhead jO tx length 64-byte
overhead jO0 expected length 64-byte

sts-

11

CEM Interface Configuration Example:
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* The following example shows the sample CEM interface configuration that is deployed to the
device for CEM framing type 'unframed', c-11 mode, clock source of type 'internet’, and ACR

values associated with the Protection Group 'acr 255"

NCS4206-120.32#show running-config | section 0/4/0

controller MediaType 0/4/0

mode sonet

controller SONET 0/4/0

rate OC3

no ais-shut

framing sonet

clock source line

loopback network

|

sts-1 1

clock source internal

mode unframed

cem-group 1 cep

|

sts-1 2

clock source internal

loopback network

mode unframed

cem-group 2 cep

|

sts-1 3

clock source internal

mode vt-15

vtg 1 vt 1 protection-group 15 working
vtg 1 vt 3 protection-group 16 working
vtg 1 vt 4 protection-group 17 working
|
aps group acr 255
aps protect 1 6.6.6.6 / aps working 1

interface CEM0/4/0

no ip address

cem 1
|
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cem 2
|

connect sam CEM0/4/0 1 CEMO/4/0 2
1

NCS4206-120.32#

* The following example show the sample CEM interface configuration with STS1E.

controller STS1E 0/4/1
sts-1 1
mode vt-15
vtg 1 tl 1 cem-group 0 cep
interface CEM0/4/1
no ip address

cem 0
|

controller STS1E 0/4/0
sts-1 1
clock source internal
mode unframed
cem-group 0 cep

interface CEM0/4/0

no ip address

cem 0
|

Configure APS or MSP and UPSR or SNCP Protection Groups

Viewing the protection groups for CEM helps you understand the enabled Automatic Protection Switching
(APS), Unidirectional Path Switched Ring (UPSR), Multiplex Service Protection (MSP) and Subnetwork
Connection Protection (SNCP) interfaces for your devices. APS and UPSR refers to the mechanism of using
a protect interface in the SONET network as the backup for the working interface. Associating your interfaces
with APS or UPSR protection groups, ensures that when the working interface fails, the protect interface
quickly assumes its traffic load. The working interfaces and their protect interfaces together make up a
Protection Group. SONET Protection Groups offer recovery from fiber (external) or equipment (interface and
internal) failures at the SONET line layer. Using Cisco EPN Manager, you can view the working member for
a SONET controller which acts as the main functioning controller for the CEM circuit. The Protecting Member
acts as a backup for the main working controller. To view these details, ensure that the interfaces have been
set with the required controller modes as explained in Configure Interfaces for CEM, on page 11.

MSP and SNCP refer to the mechanism of using a protect interface in the SDH network as the backup for the
working interface. Associating your interface with MSP or SNCP protection groups, ensures that when the
working interface fails, the protect interface quickly assumes its traffic load. The working interfaces and their
protect interface together make up a Protection Groups.

MSP is a protection mechanism in SDH for a port level protection, which provides 1+1 protection mechanism.
In network topology map, all modes are supported including revertive, unidirectional, bidirectional, and acr/dcr
modes. MSP in SDH is similar to APS in SONET. For example, in NCS 4206 device it has both working and
protection modes.

SDH-MSP feature provides port level redundancy for SDH controller across Interface Module (IM). You can
configure ports of different IM with one in working mode and the other port in protect mode.
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Step 1
Step 2
Step 3
Step 4
Step 5

Step 6

SNCP is a protection mechanism for SDH networks that enables SDH connections to switch to another SDH
circuit when a circuit failure occurs. A protection interface serves as the backup interface for the working
interface. When the working interface fails the protection interface quickly assumes its traffic load. The
switchover to a protection path occurs in the nonrevertive mode. If protection is switched to the protection
path due to a transmission fault, there is no automatic switch-back to the original path once the fault is rectified.
The functional equivalent of SNCP in SONET is called UPSR. You can provision CEM services and SNCP
through Provision wizard or through CLI. The supported modes are VC4 16C, VC4 4C, VC4, AU4 VCI12,
AU4-VCl11, AU3-VC12, AU3-VCI1.

\)

Note Mix mode support is not available.

Some Limitations are:

* SDH supported modes with SNCP is not supported on STM64 port.
* LOOPBACK and Bit Error Rate Testing (BERT) can be configured only on physical member controllers.

* The supported scale is limited to 336 circuits

Before you modify the protection groups ensure to add controllers/interfaces to protection.

To configure APS/MSP protection groups and view UPSR/SNCP interfaces:

Choose Configuration > Network Devices.

Select the device that is configured with protection groups, by clicking the device’s name hyperlink.
Click the Logical View tab.

Choose Circuit Emulation > Protection Group.

To configure the APS/MSP parameters, click the APS/MSP tab, click the Protection Group hyperlink of the group that
you want to modify, and click the Edit icon at the top right corner of the page.

You can view and configure the following fields.

» The Working Member represents the SONET/SDH controller which acts as the main functioning controller for
the circuit.

* The Protecting Member represents the SONET /SDH controller which acts as the backup to the working member
for the circuit.

* The Protection Status indicates whether the group is an active or inactive member for the circuit.

* The Hello Time and Hold Time fields represent the time range for the protecting and working members. The hello
timer defines the time between hello packets. The hold timer sets the time before the protect interface process declares
a working interface's router to be down. By default, the hold time is greater than or equal to three times the hello
time.

* The Loopback IP determines the configuration for the protect interface which includes the IP address of the router
(normally its loopback address) that has the working interface.

* The Revertive Time , in minutes, enables automatic switchover from the protect interface to the working interface
based on the configured time after the working interface becomes available. If revertive time is zero then the protection
is non-revertive.

* The Directional drop-down menu represents the direction in which the backup protection must be enabled.
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* In the bidirectional mode, a failure on a working member triggers an APS/MSP switchover of the working
member to the Protecting member. Here the receive and transmit channels are switched as a pair.

* In the unidirectional mode, failure on a working member triggers an APS/MSP switchover of only the failed
member to the corresponding line of the Protection interface.

» The ADM checkbox, if enabled, associates Add Drop Multiplexers (ADMs) with the protecting member.

» The APS Request drop-down menu enables you to configure the following values. The values can be configured
in the order Lockout > Force Switch > Manual Switch > No Mode. For example, if Force Switch is currently
configured on the device, then you can configure only Manual Switch or No Mode values. You cannot configure
Lockout when Force Switch is configured.

» Lockout: Prevents a working interface from switching to a protect interface. For example, if the protect interface
is configured as circuit 1, the Lockout option prevents the protect interface from becoming active.

» Manual Switch: Manually switches a circuit to a protect interface, unless a request of equal or higher priority
is in effect.

* Force Switch: Manually switches a circuit to a protect interface, unless a request of equal or higher priority is
in effect. For example, if the protect interface is configured as a particular circuit, the force command sets the
protect interface to active.

* No Mode: Removes the current APS/MSP request configuration from the protection group on the device.

Note To clear the protection group of SONET or SDH , choose either SONET or SDH protection group ID and then
click the delete (X icon).

Step 7 To view similar parameters associated with UPSR/SNCP interfaces, click the UPSR/SNCP tab.

You can view information such as the protection group number, working and protecting members configured on the
device, the active paths for the group, and its current protection status. This information cannot be modified.

Note During shutdown or removal of IM that have UPSR/SNCP over SDH configured, you can validate the changes
in the Ul and check for the Online Insertion Removal (OIR) of each interface module. Use the show
protection-group command.

* To view the following status changes:

* Manual —The status is displayed whrn you maually configure the SNCP protection group.

* Clear—Clears previously set external command.

» Auto—The status is displayed when you configure the SNCP protection group for the first time.
» Force—The status is displayed when you manual switch over.

* Fail—The status is displayed when protected and working paths are down.

* Signal Failure—The status goes to SF when there is a link failure.

* Signal Degrade—The status is displayed when the working path is down.

 Lockout—Prevents a working interface from switching to a protect interface.

Step 8 Choose Circuit Emulation > SONET and SDH.
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Step 9 To view or configure the ACR Controller, High-order Path, Low-order Path parameters, click the relevant tabs. Click the
SONET or SDH hyperlink that you want to modify, and then click the Edit icon at the top right corner of the page. For
more information about configuration of SDH see, Configure Modes of SDH in EPNM, on page 25, Configure SDH
Parameters , on page 24 and Configure SDH Line and Section Parameters, on page 26 SDH VC Configuration Parameters
for SAToP, on page 28 SDH T1/E1 Configuration Parameters, on page 27 SDH T3/E3 Configuration Parameters, on
page 27
Use the ACR Controller tab to view the virtual SONET Access Circuit Redundancy (ACR) /SDH Access Circuit
Redundancy (ACR) details for SONET/SDH protection groups .

Configure Clocking for CEM

Clocking modes define multiple ways to achieve the same clock in the transmitting and receiving ends of a
CEM circuit. Cisco EPN Manager enables you to configure clock recovery and distribution in these ways:

* Synchronous Clocking — with synchronous clocking, PDH (TDM) lines on the source and destination
are synchronized to the same clock delivered by some means of physical clock distribution (SONET,
SDH, and so on). The clock on the particular TDM line can be delivered from

* Line: the transmit clock is from the receiver of the same physical line.
* Internal: the controller will clock its sent data using the internal clock.

* Free Running: the transmit clock is taken from line card and can be derived from an internal free
running oscillator.

* Recovered: the transmit clock is derived from an in-band pseudowire-based activeclock recovery
on a CEM interface.

To set these clocking values in Cisco EPN Manager, see Configure CEM Interfaces.

* Adaptive Clocking — adaptive clocking is used when the routers do not have a common clock source.
The clock is derived based on packet arrival rates based on dejitter buffer fill level. You can set the size
of the Dejitter Buffer (in the range of 1-32) during provisioning of CEM services in Cisco EPN Manager.
The size of the Dejitter Buffer determines the ability of the circuit to tolerate network jitter.

» Differential clocking — differential clocking is used when the cell site and aggregation routers have a
common clock source but the TDM lines are clocked by a different source. The TDM clocks are derived
from differential information in the RTP header of the packet with respect to the common clock.
Differential clock recovery is based on time stamps received in the RTP header.

To configure clock recovery for CEM:

Step 1 Click the Configuration tab, then click the Logical View left side tab.
Step 2 Choose Clock > Recovered Clock.

Step 3 To add a new interface from which the clock source must be derived, click the Add (‘+”) icon.

Step 4 To edit the existing recovered clock configuration, click the Recovering Interface hyperlink and click the ‘Edit’ icon at
the top right of the page.

Step 5 Specify the following recovered clock values:
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Step 6

CEM Interface (PDH, SONET, and SDH) Field Descriptions .

Enter a unique numerical value for the Recovered Clock ID for easy identification of the recovered clock configuration.
This ID can then be used to associate the CEM interfaces directly with this the recovered clock configuration.

From the Recover Mode drop-down list choose:

» Adaptive— when devices do not have a common clock source, the recovered clock is derived from packet
arrival rate on the controller selected as the Protecting Member for the associated Protection Group.

+ Differential— when the edge devices have a common clock source, the recovered clock is derived from timing
information in packets and the related difference from the common clock.
Enter a unique numerical value for easy identification of the CEM Group Number. This identifies the CEM group

associated with the clock.

Choose the required controller from the Recovering Interface drop-down list. This controller associated with the
clock is the virtual CEM interface from which the clock is derived when a backup clock source is required.

Click Save.

Your changes are saved and deployed to the device.

CEM Interface (PDH, SONET, and SDH) Field Descriptions

Step 1

Step 2

To configure the CEM parameters listed in the following table:

Configure the required CEM parameters on SONET, PDH, HOP, and HOP controllers. See, Configure Interfaces for
CEM, on page 11.

Configure clock distribution and recovery for CEM. See Configure Clocking for CEM, on page 18.
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Table 6: CEM Interface (SONET, SDH, and PDH) Field Descriptions

Configure Devices |

64.

A channelized OC-192 line with STM level
64. OC-192 is an optical carrier network line
with transmission data rate of up to 9.6Gbps.

Fields Descriptions |Values Descriptions Applicable
Controller
Modes
Rate Identifies the |LR DSR OC1 STMO Indicates the layer rate supported on the STS1E
rate at which channelized OC-1 line with STM level 0.
the data gets OC-1 is an optical carrier network line with
transported. It transmission data rate of up to 51.84 Mbit/s.
depends on the
SFP (Small LR DSR OC3 STM1 Indicates the layer rate supported on the SONET
Form-factor channelized OC-3 line with STM level 1. |/SDH
Pluggable). OC-3 is an optical carrier network line with
transmission data rate of up to 155.52 Mbit/s.
LR DSR OC12 STM4 Indicates the layer rate supported on the SONET/SDH
channelized OC-12 line with STM level 4.
OC-12 is an optical carrier network line with
transmission data rate of up to 622.08 Mbit/s.
LR DSR 0OC48 STMI16 Indicates the layer rate supported on the SONET
channelized OC-48 line with STM level 16. | /SDH
OC-48 is an optical carrier network line with
transmission data rate of up to 2.4Gbps.
LR DSR OC192 STM64 |Indicates the layer rate supported on the SONET
channelized OC-192 line with STM level |/SDH
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CEM Interface (PDH, SONET, and SDH) Field Descriptions .

Fields Descriptions | Values Descriptions Applicable
Controller
Modes
Mode Identifies the |High- Order Path values: * STS-n: Mode with Synchronous HOP and
?}/l;;erelr(l)eflization STS3C, STS12C, STS4SC, Zﬁz\s}z?;t Signal (STS) channelization | LOP
such as | STS192C, T3, UNFRAMED, '
Synchronous VT15, VT2, and CT3. « T1, E1, T3, and E3: Indicates the
Transport Low Order Path values: channelization mode used on the
Sional of level controller. T1 or E1 circuit has a
n (gSTS-n) f\;r VTI15,Tl, and E1. transmission data rate of up to 1.544
high-order and | Note Supported modes Mblt/s", The T3 or E3 circuit has a
low-order for STS1E: transmission data rate of up to 44.736
Mbit/s.
paths. High- Order Path
values: T3 and ¢ VT 1.5: Indicates that the controller is
UNFRAMED a virtual tributary network line with
transmission data rate of up to 1.728
Low Order Path Mbit/s.
values: CT3 and
VTI15 « VT 2: Indicates that the controller is a
virtual tributary network line with
transmission data rate of up to 2.304
Mbit/s.
* Unframed: Indicates that a single CEM
channel is used for all T1/E1 timeslots.
VC4 16C, VC4 _4C,VC4, |Supported SDH modes HOP and
AU4 VC12, AU4-VCI11, LOP
AU3-VCI12, AU3-VCI1, T3,
E3, VC1X, TUG3
Clock Identifies the |Line Controller clock its sent data using the clock | All
Source source of the recovered from the line’s receive data
clock signal stream.
sent on
SONET or Internal The transmit clock is taken from line card | All
SDH ports. and can be derived either from an internal
physical line.
Recovered In-band pseudowire-based activeclock SONET,
recovery on a CEM interface which is used | SDH, HOP,
to drive the transmit clock. and LOP.
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Configure Devices |

Fields Descriptions | Values Descriptions Applicable
Controller
Modes
Framing Framing mode | CRC and NO_CRC. CRC: represents the faming type with cyclic | SONET/
used for the redundancy check. SDH
CEM channel.
Unframed, DSX1_ESF,  Unframed: indicates that a single CEM | PDH, HOP,
DSX1_SF, Auto Detect, channel is used for all timeslots. LOP, and
C_BIT, and M13. Lo STSIE.
- * DSX1_SF: indicates that the DS1 type
of interface has the framing type as
super frame. SF uses 12 frames per
super frame for in-band signaling
extraction.
* DSX1_ ESF: indicates that DS1 type of
interface has the framing type as
extended super frame. ESF uses 24
frames per ESF.
Loopback | Specifies the |Local, Network Line, For a detailed explanation about the different | All
loopback value | Remote, Remote Line, loopback values, refer the latest IOS
associated with | Network Payload, and Command References.
the CEM Unknown.
interface.
Diag, Local Payload, Remote | — PDH
ESF Payload, Remote ESF
Line, Remote ESF Line CSU,
Remote ESF Line NIU,
Remote Iboc, Remote Iboc
CSU, Remote Iboc FACI,
Remote Iboc, and FAC2.
Protection |Identifies the | WORKING The recovered clock is obtained from a clock | SONET/
Role priority based with the highest priority. SDH
on which the
recovered PROTECT The recovered clock is obtained from a clock | SONET/
clock must be with a lower priority than the primary clock. | SDH
obtained.
Cable Sets the transmission attenuation according to the length of the cable. For example, if you | PDH
Length choose short 115, the cable length is from 0 to 115 feet. Choose Short 220 if the cable length
is from 110 to 220 feet, and so on. Your values are between Short 110 to Short 550, Shot
LT 225, and Long GT 225.
Line Coding | Line encoding method for the controller: PDH
* For E1, the options is Alternate Mark Inversion (AMI).
* For T1, the options are AMI and bipolar with 8 zero substitution (B8ZS).
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CEM Interface (PDH, SONET, and SDH) Field Descriptions .

Fields Descriptions | Values Descriptions Applicable
Controller
Modes
Channelization | Indicates the channelization mode that must be used on the controller. A T1 or El circuit |PDH
Mode has a transmission data rate of up to 1.544 Mbit/s. Your values are T1, E1, and
Unchannelized.
Note For T3 controllers view or modify the channelized T1/E1 properties and for E3
controller view or modify the channelized T1/E1 properties.
Protection | Identifies the protection number or ACR group. SONET
Group /SDH
Number
Protection |Identifies the name of the loopback interface on the device. SONET/
Loopback SDH
Name
Protection | Identifies the IP address of the loopback interface on the device. SONET/
Loopback IP SDH
Protection |For any failure on working line, the software switches to protection line and when the SONET
Revertive | working line recovers, it waits based on the revertive timer and reverts back to working line | /SDH
Time as active link.
Protection | When the signal fails, the software switches to the protection line and does not automatically
Non-Revertive | revert back to the working line. This is the default option.
Time
Operational | Operational Up, Down, and * Down— the interface is down. SONET,
Status status of the | Not-Applicable. ) ) SDH, HOP,
CEM interface. . Not-Apphcable'— the interface has an LOP, and
This field unknown operational status. STSIE
cannot be » Up— the interface is up.
edited.
Admin Administrative | Up, Down, and * Up— the CEM interface is SONET,
Status status of the | Not-Applicable. administratively up. SDH, HOP,
CEM interface. . . LOP, and
* Down— the CEM interface is
. . STSIE.
administratively down.
* Not-Applicable— the administrative
status is unknown.
Recovered | Unique identifier for the clock settings associated with the CEM interface. To configure the | PDH, HOP,
Clock ID Recovered Clock ID, see Configure Clocking for CEM. and LOP.
Aug Type | An Administrative Unit Group (AUG) consists of one or more administrative units occupying | SDH

units, defined positions at STM level. AUG-3 Grouping and AUG-4 Grouping are the
supported Aug Types.

Configure Devices .




Configure Devices |
. Configure SDH Parameters

Configure SDH Parameters

To configure SDH CEM channelization modes refer the following table.

Table 7: Controller Modes and Supported Port Types

SDH Modes CEM Ports Applicable Controller
Modes
VC4 _l6¢ CEP STM16 HOP
VC4 4c CEP STM4, STM16 HOP
VC4 CEP OC3/STM1, HOP
OC12/STM4,
0C48/STM16
VC1X CEP OC3/STMI, HOP
OC12/STM4,
OC48/STM16
TUG3-E3 SATop OC3/STMI, HOP
OC12/STM4,
OC48/STM16
TUG-3-T3 SATop OC3/STMI, HOP
OC12/STM4,
OC48/STM16
VCI1_TI SATop OC3/STMI, LOP
OC12/STM4,
OC48/STM16
VC12_E1l SATop STM1, STM4, STM16 |LOP
VCIl1 CEP OC3/STMI, LOP
OC12/STM4,
OC48/STM16
VC12 CEP OC3/STM1, LOP
OC12/STM4,
OC48/STM16

Configure Mediatype Controllers

Each SFP port (16-19) can be configured as STM1, STM4, STM16. You must select the MediaType controller
to configure and enter the controller configuration mode. You must configure the controller as a SDH port.

To configure MediaType Controller:
enable

configure terminal controller
MediaType 0/0/16

mode sdh

end

Configure Rates on SDH Ports
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To configure rate on SDH ports:
enable

configure terminal

controller MediaType 0/0/16

mode sdh

end

\)

Note The configuration of no form of the command is not supported. To restore to the default condition, use
no mode sdh command under Mediatype controller after removing all configuration under that port.

Configure Modes of SDH in EPNM

A Synchronous Transport Module (STM) signal is the Synchronous Digital Hierarchy (SDH) equivalent of
the SONET STS. In this document, STM term refers to both path widths and optical line rates. The paths
within an STM signals are called administrative units (AUs). An AU is the information structure that provides
adaptation between the higher-order path layer and the multiplex section layer. It consists of an information
payload (the higher-order VC) and an AU pointer, which indicates the offset of the payload frame start relative
to the multiplex section frame start. The AU-3 pointer is composed of 3 bytes; the AU-4 pointer is composed
of 9 bytes. The payload of the STM-1 frame consists of one AU-4 unit or three AU-3 units. Augment Mapping
An administrative unit group (AUG) consists of one or more administrative units occupying fixed, defined
positions in an STM payload. Augment mapping is supported at STM1 level.

The following types of augment mapping are supported:.

* Augment Mapping AU-4

\)

Note This is the default augment mapping mode

» Augment Mapping AU-3
The supported modes of SDH are:
* AU-4_16¢ (VC4-16¢)
* AU-4 4c¢ (VC4-4c)
* AU-4 (VC4)
» AU-4 — TUG-3 — DS3
* AU-4—TUG-3 — T3
* AU-4 — TUG-3 —E3
* AU-4 —TUG-3 — TUG-2 — VC-11 — T1
* AU-4 — TUG-3 — TUG-2 — VC-12 —E1
* AU-4 — TUG-3 — TUG-2 — VC-11
* AU-4 — TUG-3 — TUG-2 — VC-12
* AU-3—T3
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* AU-3 — TUG-2 — VC-11—T1
* AU-3 —TUG-2 — VC-12—E1
* AU-3 —TUG-2 — VC-11

* AU-3 —TUG-2 — VC-12

* AU-3 —E3

To configure Administration Units Group (AUG) mapping; for example, Configuring AU-3 or AU-4 Mapping
use the following configuration commands:

configure terminal
aug mapping [au-3 | au-4]
end

\)

Note The aug mapping command is available only when the SDH framing is configured. The AUG mode
is AUG-4 by default and it is supported at STM-1 level.

Configure SDH Line and Section Parameters

The following parameters affect SDH configuration at the line and section levels.
Loopback
Sets a loopback to test the SDH ports.

* local —Loops the signal from Tx to Rx path. Sends alarm indication signal (AIS) to network.

* network— Loops the signal from Rx to Tx path.

Configuring Line Loopback

To configure loopback:
enable

configure terminal
controller sdh 0/0/16
loopback [local | network]
end

\)

Note  To restore the system to its default condition, use the no form of the command.

Clock Source
Specifies the clock source, where:
* line—The link uses the recovered clock from the line.

« internal— The link uses the internal clock source. This is the default setting.

To configure clock, use the following commands:
enable

configure terminal

controller sdh 0/0/16
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clock source [line | internal]
end

\)

Note The default mode is internal. To restore the system to its default condition, use the no form of the
command.

Configuring Network-Clock SDH

To configure network-clock SDH, use the following commands:
enable

configure terminal

controller sdh 0/0/16

clock source line

end

enable

configure terminal

network-clock input-source 1 controller sdh 0/0/16

end

SDH T1/E1 Configuration Parameters

The following parameters affect SDH T1/E1 configuration:

* Clock — Specifies the clock source for T1 or El interface.
* Description — Specifies the description of the controller.

* Loopback — Sets the T1 or E1 interface in the loopback mode.

Configuring SDH T1/E1 Parameters

To configure T1/El parameters:
enable

configure terminal

controller sdh 0/0/16

rate stmé

au-3 1

mode vclx

tug-2 1 payload vcll

tl 1 loopback [local | network line]
tl 1 clock source [line | internal | recovered]
end

SDH T3/E3 Configuration Parameters

The following parameters affect SDH T3/E3 configuration:
* Clock— Specifies the clock source for T3 or E3 link.

* Loopback— Sets the T3 or E3 link in the loopback mode.

Configuring SDH T3/E3 Parameters

To configure SDH T3/E3 parameters configuration:
enable

configure terminal

controller sdh 0/0/16
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rate stm4

au-4 1

mode tug 3

tug-3 1

mode e3

e3 1 clock source [line | internal | recovered]

e3 framing [ml3 | c-bit ] (applicable to for mode e3)
e3 1 loopback [local | network line]

e3 bert pattern Os interval 2

tug-3 2

mode t3

t3 1 clock source [line | internal | recovered]

t3 framing [ml3 | c-bit ] (applicable to for mode t3)

t3 1 loopback [local | network line]
end

\)
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Note

This is applicable to AUG mapping AU-4 mode T3 and AU-3 mode T3.

SDH VC Configuration Parameters for SAToP

The following parameters affect SDH VC configuration:

* Clock — Specifies the clock source for VC.
* Loopback— Sets the VC in the loopback mode.

Configuring VC Parameters

To configure VC parameters:
enable

configure terminal
controller sdh 0/0/16

rate stm4

au-3 1

mode vclx

tug-2 1 payload vcll

vc 1 loopback [local | network]
vc 1 clock source internal
end

Synchronize the Clock Using Sync-E, BITS, and PTP

Synchronous Ethernet (Sync-E):

Using Cisco EPN Manager, you can enable frequency synchronization to provide high-quality bit clocks
synchronization over Ethernet interfaces. Synchronous Ethernet (Sync-E) provides this required synchronization

at the physical level.

To do this you need to configure Sync-E that helps routers identify the clock in the network with the highest
priority. This clock is also called the Primary Clock. All the other devices (members) on the network reset
their clocks based on the primary clock’s settings. Messages are constantly exchanged between the primary
clock and its members to ensure efficient continued synchronization of all clocks in the network. Cisco EPN
Manager enables you to specify this primary clock and also set the Sync-E parameters at the global and
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interface levels. Once the Sync-E properties have been configured, you can view the logical hierarchy and
topology between the devices on the network topology overlay.

\)

Note Sync-E configuration is supported only on Ethernet interfaces.

Building Integrated Timing Supply (BITS):

BITS is the method by which clocking information is provided by a Building Integrated Timing Supply (BITS)
port clock. In Sync-E, Ethernet links are synchronized by timing their bit clocks from high-quality,
stratum-1-traceable clock signals in the same manner as SONET/SDH. Operations messages like SSM and
ESMC maintain Sync-E links and ensure that a node always derives its timing from the most reliable source.

Precision Time Protocol (PTP):

In networks that employ TDM, periodic synchronization of device clocks is required to ensure that the receiving
device knows which channel is the right channel for accurate reassembly of the data stream. The Precision
Time Protocol (PTP) standard:

* Specifies a clock synchronization protocol that enables this synchronization.

* Applies to distributed systems that consist of one or more nodes communicating over a network.

PTP uses the concept of primary and subordinate devices to achieve precise clock synchronization. With the
help of Cisco EPN Manager, you can use PTP to configure the primary device which periodically starts a
message exchange with the subordinate devices. After noting the times at which the messages are sent and
received, each subordinate device calculates the difference between its system time and the system time of
the primary device. The subordinate device then adjusts its clock so that it is synchronized with the primary
device. When the primary device initiates the next message exchange, the subordinate device again calculates
the difference and adjusts its clock. This repetitive synchronization ensures that device clocks are coordinated
and that data stream reassembly is accurate. The PTP clock port commands are used to modify PTP on
individual interfaces. Once the PTP properties have been configured, you can view the logical hierarchy and
topology between the devices on the network topology overlay.

\}

Note Due to the limitations on the device, you can configure a maximum of 4 clock sources on interface
modules, with a maximum of 2 per interface module. This limitation applies to both Sync-E and TDM
interfaces.

To configure Sync-E, BITS, and PTP:

Step 1 Choose Configuration > Network Devices.
Step 2 Select the device that you want to configure by clicking the device’s name hyperlink.
Step 3 Set the global Sync-E properties.

a) Click the Logical View tab.

b) Click Clock > Sync-E. All available Sync-E global settings are listed.

¢) To create a new set of global Sync-E properties, click the *+” icon. You can create only one set of Sync-E global
parameters.

d) Specify the global parameters for Sync-E. For a detailed description about these parameters, see the table below.
e) Click Save.
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Your changes are saved and the global Sync-E configuration is deployed to the device. You can now specify the
interfaces that you want to associate with this configuration.

Step 4 Specify the associated interfaces and interface specific Sync-E parameters.
a) Select the Sync-E global configuration created in the above steps from Clock > Sync-E.
b) Click the Interface Input Source tab.
¢) Click ‘+’ to specify the required interfaces.

You can configure only one interface per synchronization type.

d) Use the Interface Name drop-down menu to select the required interface.
e) Specify the interface level Sync-E parameters. For a detailed description about these parameters, see table below.
f) Click Save.

Step 5 Specify the frequency settings for BITS (for XE devices):

a) Click the Logical View tab.
b) Click Clock > BITS-Frequency.
¢) Specify the following BITS values:

* Source Slot: The values are RO and R1.
* Priority: Numeric value within the range 1 to 250.

* Clock Type: The values are 2.048 MHz and 10 MHz.

d) Click Save.

Step 6 Specify the interface settings for BITS:

a) Click the Logical View tab.
b) Click Clock > BITS-Interface.
c) Specify the following BITS values:

For XE devices:
* Source Slot: The oprions are RO and R1.
* Priority: Numeric value within the range 1 to 250.

* Clock Type: The options are E1 and T1.
Note The SSM option must be OPTION2 GEN1 or OPTION2 GEN2 to configure the BITS interface as T1.

For XR devices:
* Clock Interface: The options are BITSO_IN, BITSO_OUT, BITS1_IN, and BITS1 OUT.
* Clock Type: The options are E1, T1, J1, 2M, and 64K.
d) Click Save.
e) Specify the BITS clock settings for the interface:

1. Navigate to Clock > BITS-Interface and click on the Source Slot of the BITS Interface settings created in the
above step.

2. Click the Bits Clock Settings tab and specify the clock settings as described in the table below.
3. Click Save.
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Step 7 Specify the PTP clock settings:
a) Click the Logical View tab.
b) Click Clock > PTP.
c) Click '+ to specify a new set of PTP values, or click the Clock Mode hyperlink and then click the Edit icon at the top
right corner of the page.
d) Specify the following common PTP parameters and click Save.

* Clock Mode: Choose the mode of PTP operation. Your options are Ordinary, Boundary, and E2E Transparent.
E2E stands for End-to-end transparent clock mode.

» Domain No: Enter the number of the domains used for PTP traffic. A single network can contain multiple
domains. Range is from 1 to 127.

* Hybrid Clock: Enable or disable hybrid cloud.
e) Click the Clock Mode hyperlink and click the Port tab to specify the port details that must be associated with the

common properties.
f) Specify the following Port details and click Save.

» Port Name: Enter the name of the PTP port clock.
* Port Mode: Choose the PTP role of the clock, Primary or Subordinate.
* Loopback Interface Number: Enter the clock identifier derived from the device interface.

» Announce Timeout: Enter the number of PTP announcement intervals before the session times out. Range is
1 to 10.

+ Delay Request Interval: Choose the time when the interface is in PTP primary mode and the selected interval
is specified to member devices for delay request messages. The intervals use base 2 values.

« Sync Interval: Choose the time interval for sending PTP synchronization messages.
» Announce Interval: Choose the time interval for sending PTP announcement packets.
g) Click the Port Name hyperlink and click the Clock Source tab.

h) Click '+ to add a new interface, or click the source address hyperlink and click Edit at the top right corner of the page.
i) Specify the Source Address and the Priority for the clock.

» No Priority- Assigns the priority value as 0.

* Priority 1- Checks the first value for clock selection. The clock with the lowest priority takes precedence and
the value 1 is assigned.

* Priority 2- If two or more clocks have the same value in the Priority 1 field, the value in this field is used for
clock selection. This assigns the priority value of 2.
j) Click Save to deploy your changes to the device.

For detailed descriptions about all Sync-E global and interface level parameters, see the table below:

Fields Descriptions

Clock > Sync-E Common Properties (Global Level)
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Fields

Descriptions

Automatic Selection process

Indicates the type of method used for synchronization of the clocks. The values
are: Automatic, Forced, Manual, and Cisco.

Note- You can configure only one interface per synchronization type.

Clock Type Indicates the Ethernet Equipment Clock (EEC) option to be used:
Option 1- represents EEC-Option I of the European time zone.
Option 2- represents EEC-Option II of the American time zone.

QL Mode Enabled Indicates whether the clock is to be used with the Quality Level (QL) function:
Enabled or Disabled.

ESMC Enabled Indicates the status of the Ethernet Synchronization Message Channel (ESMC):
Enabled or Disabled.

SSM Option Indicates the Synchronization Status Message (SSM) option being used:

Option 1- represents ITU-T Option I
Option 2- GENI1- represents ITU-T Option II Generation 1
Option 2- GEN2- represents ITU-T Option II Generation 2

Hold Off Time (global level)

Indicates the length of time (in milliseconds) for a device to wait before issuing
a protection response to a failure event.

A valid range is between 300 and 1800 milliseconds.

Wait To Restore Time (global level)

Indicates the length of time (in seconds) to wait after a failure is fixed before
the span returns to its original state.

A valid range is between 0 and 86400 seconds.

Revert Enabled

Specifies whether the network clock is to use Revertive mode: Enabled or
Disabled.

Sync-E > Interface Input Source (Inte

rface Level) Properties

Interface Name

Name and hyperlink of the Gigabit or 10 Gigabit interface associated with
Sync-E.

Active clock

Indicates whether the interface is currently chosen as the active clock. This
interface can either be a primary or secondary interface, however, the interface
that is currently enabled for Sync-E is considered to be the active interface.

Priority

Indicates the value used for selecting a Sync-E interface for clocking if more
than one interface is configured. Values are from 1 to 250, with 1 being the
highest priority.

The highest priority clock represents the primary clock.

Hold Off Time (interface level)

Indicates the length of time (in milliseconds) to wait after a clock source goes
down before removing the source.

A valid range is a value between 300 and 1800 milliseconds.

. Configure Devices



| Configure Devices

Synchronize the Clock Using Sync-E, BITS, and PTP .

Fields

Descriptions

Wait To Restore Time (interface level)

Indicates the length of time (in seconds) to wait after a failure is fixed before
the interface returns to its original state.

A valid range is a value between 0 and 86400 seconds.

Rx Exact/QL Use

Indicates the QL Receive function with which the clock must be used.

Tx Exact/QL Send

Indicates the QL Transmit function with which the clock must be used.

Clock > BITS-Frequency and BITS-Interface Properties

Source Slot

Indicates whether the clock source is RO or R1 (for XE devices).

Clock Interface

Indicates whether the clock source is BITSO_IN, BITSO OUT, BITS1 _IN, or
BITS1_OUT (for XR devices).

Priority Indicates the value used for selecting a BITS interface for clocking if more
than one interface is configured. Values are from 1 to 250, with 1 being the
highest priority.

The highest priority clock represents the primary clock.
Clock Type Indicates whether the clock type that must be used is from an E1 line or a T1

line (for XE devices). For XR devices, the line can be E1, T1, J1, 2M, or 64K.

In case of the BITS Interface parameters, the clock type indicates the frequency
values that must be associated with the clock.

Supported clock types for XE devices:
* BITS Frequency: Supported options are 2.048 MHz and 10 MHz.

* BITS Interface: Supported options are T1 and E1.

Supported clock types for XR devices:
* BITS Interface: Supported options are T1, E1, J1, 2M, and 64K.

Bits Framing

Framing values (such as CAS) that must be associated with the BITS
configuration.

* Supported Bits Framing values for XE devices: E1 CAS CRC4,E1 CAS,
E1 CRC4,E1 FAS, Tl D4, T1 ESF, and T1_SF

* Supported Bits Framing values for XR devices: E1 CRC4, E1_FAS,
J1 D4,J1 ESF, T1 D4, and T1 ESF

Impedance

The impedance value that is associated with the clock in OHMS format.
Supported impedance values are 75 ohms and 120 ohms.

Bits Sub Framing

The supported Bits sub framing values for XR devices with E1 clock type are
SA4, SAS5, SA6, SA7, and SAS.
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Fields

Descriptions

Line Code

The line code value that must be associated with the BITS interface.
Supported line code values for XE devices:

e For E1 interface: The values are AMI and HDB3.

e For T1 interface: The values are AMI and B8ZS.

Supported line code values for XR devices:

* For E1 interface: The values are AMI and HDB3.
e For J1 interface: The values are AMI and B8ZS.
e For T1 interface: The values are AMI and B8ZS.

Line Build Out

The line build-out value that must be associated with the BITS interface. This
field is supported only for T1 interface.

Supported line build-out values for XE devices:
e For T1 interface: The values are 0-133ft, 133-266ft, 266-3991t, 399-533ft,
and 533-655ft.
Supported line build-out values for XR devices:
* For T1 BITSO_OUT interface: The values are 0, 1, 2, 3, and 4.

* For T1 BITS1 OUT interface: The values are 0, 1, 2, 3, and 4.

What to do next

(Optional) You can view the Sync-E and PTP device properties on the network topology overlay. See Show
Clock Synchronization Networks on a Network Topology Map:

* Sync-E overlay: shows the topology and hierarchy of the Sync-E network. It shows the primary clock
and the primary and secondary clock inputs for each device.

» PTP overlay: shows the clock synchronization tree topology, the hierarchy of the Precision Time Protocol,
and the clock role of each device in the tree (primary, boundary, subordinate, or transparent).

Configure IP SLAs (TWAMP Responder/TWAMP Light

Responder)

The IETF Two-Way Active Measurement Protocol (TWAMP) defines a standard for measuring round-trip
IP performance between any two devices that support TWAMP. The TWAMP-Control protocol is used to
set up performance measurement sessions by sending and receiving performance-measurement probes. Once
a session is created, TWAMP test packets are transmitted to help calculate the performance statistics including
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packet loss, delay etc. TWAMP Light differs from standard TWAMP by simplyifing the control protocol used
to establish the test sessions.

TWAMP Responder is supported for both Cisco IOS XE (NCS 42xx) and Cisco IOS XR (ASR 9000, NCS
540, NCS 560, NCS 5500) devices. The TWAMP Light Responder is supported only for Cisco IOS XR (ASR
9000, NCS 540, NCS 560, NCS 5500) devices. TWAMP Light supports IPv4 and IPv6 addresses while
standard TWAMP is supported for IPv4 addresses only.

For more information on configuring TWAMP interfaces, see:
* Configure TWAMP Responder, on page 35
* Configure TWAMP Light Responder, on page 35

Configure TWAMP Responder

When you configure TWAMP using Cisco EPN Manager, the device you select is configured as a TWAMP
server. The TWAMP server listens for connection and control requests on the specified port. The Inactivity
Value that you specify will be configured as the inactivity timer (in seconds) for a TWAMP control session.

Use the following procedure to add or edit entries for TWAMP:

Step 1 Choose Configuration > Network Devices.

Step 2 Select the device that you want to configure by clicking the device hyperlink to launch its Device Details page.
Step 3 Click Logical View tab.

Step 4 Choose IP SLA > TWAMP Responder to add or edit the TWAMP Responder configuration.

Step 5 Click the '+' icon to add the TWAMP parameters to the selected device. To edit existing parameters, click the Port Name
hyperlink and click the Edit icon at the top right corner of the page. You can only add one set of TWAMP parameters
per device.

Step 6 Edit the following parameters as necessary. All parameters are mandatory.

* Port- Use a numeric value between 1 and 65535 to specify the port that must be configured for the TWAMP server
to listen for connection and control requests. The default value is 862.

« Inactivity Timeout- Use a numeric value between 1 and 604800 to specify the time that must be configured as the
inactivity time (in seconds) for a TWAMP responder test session. The default value is 900 seconds.

« Server Inactivity Timeout- Use a numeric value between 1 and 6000 to specify the time that must be configured
as the TWAMP server inactivity time (in seconds) for a TWAMP control session. The default value is 900 seconds.

Step 7 Click Save to deploy your changes to the device.

Configure TWAMP Light Responder

Use the following procedures to manage interfaces for the TWAMP Light Responder:
* Add a TWAMP Light Responder, on page 36

» Edit TWAMP Light Responder configuration, on page 36
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* Delete a TWAMP Light Responder configuration, on page 37

* Commands to view TWAMP Light session details, on page 37

Add a TWAMP Light Responder
Use the following procedure to add an entry for TWAMP Light Responder:

Step 1 Choose Configuration > Network Devices.

Step 2 Select the device that you want to configure by clicking the device hyperlink to launch its Device Details page.
Step 3 Click Logical View from the tab on the left.

Step 4 Choose IP SLA > TWAMP Light Responder.

Step 5 Click the '+' icon in the TWAMP Light Responder page.

Step 6 Enter appropriate values in the displayed fields. Hover your mouse over the tooltip next to a particular field to get
information on the range of permissible values.

a) Session ID - Specify a Session ID. You can configure up to 65535 test sessions.

b) Timeout - (optional) Specify the inactivity time between 60 and 86400 (in seconds) for a TWAMP Light responder
test session. Default is No Timeout.

¢) Local IP address - Specify an IPv4 address or IPv6 address.
d) Local Port - Use a numeric value between 1 and 65535 to specify the port you want to configure for the session.
e) Remote IP address - Specify an IPv4 address or IPv6 address.

Note Ifthe specified Local IP address is an [IPv4 address, then the Remote IP address must be an IPv4 address.
Similarly, if the specified Local IP address is an IPv6 address, then the Remote IP address must also be
an IPv6 address.

f) Remote Port - Use a numeric value between 1 and 65535 to specify the port for the session.

g) VRF Name - Select any VRF Name from the drop-down list.
Step 7 Click Save to deploy your changes to the device.

Edit TWAMP Light Responder configuration
To edit an existing TWAMP Light Responder configuration:

Step 1 Choose Configuration > Network Devices.

Step 2 Select the device that you want to configure by clicking the device hyperlink to launch its Device Details page.
Step 3 Click Logical View from the tab on the left.

Step 4 Choose IP SLA > TWAMP Light Responder.

Step 5 Click Session ID to edit parameters of the selected session.

Note Only Timeout can be modified.

Step 6 Click Save to deploy your changes to the device.
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Delete a TWAMP Light Responder configuration
To delete an existing TWAMP Light Responder configuration:

Step 1 Choose Configuration > Network Devices.

Step 2 Select the device that you want to configure by clicking the device hyperlink to launch its Device Details page.
Step 3 Click Logical View from the tab on the left.

Step 4 Choose IP SLA > TWAMP Light Responder.

Step 5 Select the check box next to the Session ID you want to delete.

Step 6 Click 'X' and then click Delete to confirm and delete the selected configuration.

Commands to view TWAMP Light session details

Use the following commands to view session details on the device.

Command Usage

show ipsla twamp session To list all TWAMP Light sessions that are enabled.
show running-config ipsla responder To view details of a specific TWAMP Light session.
twamp-light test-session <test session ID>

Configure Interfaces

Using Cisco EPN Manager, you can configure your CE and Optical Interfaces using the following configuration
options:

Before you configure the interfaces, ensure that the device's Inventory Collection status is 'Completed'.
* Configure Ethernet Interfaces and Subinterfaces, on page 38
* Configure Loopback Interfaces, on page 39
* Enable or Disable Tunnel Interfaces, on page 42
* Configure Switch Port Interfaces, on page 42
* Configure Ethernet Interfaces, on page 42
* View Virtual Template Interfaces, on page 43
» View VLAN Interfaces, on page 43
* Configure Network Team (Link Aggregation)
* Create or Modify an IP Access-List to Filter Network Traffic
* Configure Protection Profiles, on page 57
* Change the Loopback Settings on an Optical Interface, on page 44

 Continuous Verification of the Connection Status, on page 45
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* Configure PRBS on ODU Controllers, on page 47
* Enable and Disable OSC, on page 48
* Provision Optical Interfaces , on page 49

* Change the Admin Status of an Optical Interface, on page 56

* Configure Protection Profiles, on page 57

* Configure TCM and TTI Parameters, on page 58

* Change the Port Mode/Payload and Breakout Settings, on page 60

* Configure OTN Interfaces, on page 61

* Enable and Disable GCC Connections, on page 62

* Configure Squelch Mode, on page 62

* Configure Squelch Mode and Hold Off Timer for NCS 1004 interfaces, on page 63

» Example: Change the Admin Status for Cisco NCS 2006 Interface, on page 64

Configure Ethernet Interfaces and Subinterfaces

Step 1
Step 2
Step 3
Step 4
Step5

The Configuration tab on the Device Details page lists the current interface configurations on the device.
Depending on your device configuration and user account privileges, you can create, edit, delete, enable, and
disable these interfaces.

Choose Configuration > Network Devices.

Click the device hyperlink to launch its Device Details page.
Click the Logical View tab.

Choose Interfaces > Ethernet.

To add an Ethernet subinterface:

a) Choose an Ethernet interface and click Add Subinterface.

Note This button is enabled depending on the device that you select. For example, on Cisco ASR903 devices, this
button is disabled.

a) Inthe Basic Configuration area, at a minimum, enter the Interface Number (if not already populated) and optionally
provide a description for the subinterface.

b) Inthe VLAN Number field, enter a numerical value that can be used to represent the VLAN ID for this subinterface.
Note that only the 802.1Q type of encapsulation is supported.

¢) To use the same VLAN number as the native VLAN ID, enable the Native VLAN checkbox.

d) In the Dataplane Loopback drop-down menu, select the value that must be set as the loopback value. Your options
are: Blank (makes no change in the configuration), None (removes the Ethernet loopback from the interface), Internal,
and External. The value that is already configured on the device is highlighted in the bold font.

e) Ifyou are creating an IPv4 subinterface, in the IPv4 Interface area, select an IP Type. Your options are:

* None
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« Static IP, with the IP address and subnet mask.
* DHCP IP, with the pool name.

* DHCP Negotiated, with the hostname and client ID (None, Interface, Port Channel).

You can also enter a secondary IP address with mask.

f) If you are adding an IPv6 subinterface, in the IPv6 Address area, select a type from the Add drop-down list. Your
options are: Global, Unnumbered, Link Local, Auto Configuration, and DHCP.

* Global, with the IP address and subnet mask, and type (General, EUI-64, Anycast, CGA).
» Unnumbered, and enter text in the Interface Unnumbered To text box.

* Link Local, auto-configured or manually-configured (requires IPv6 address).

* Autoconfiguration.

* DHCP (with option to enable two-message exchange for address allocation).
If you choose to edit an existing interface or subinterface, you are allowed to change all values except the Interface
Number value.

Note To avoid unusual behavior, do not use the § character in the Description field.

g) Click Save to add the subinterface to the selected interface of the device.
Step 6 To enable, disable, or delete interfaces and subinterfaces, select the interfaces and click the appropriate buttons.

The Delete Subinterface button may only be enabled on some supported devices, such as, Cisco ASR903 devices.

Step 7 Click Save to deploy your changes to the device.

Configure Loopback Interfaces

You can change the loopback state of an interface to test how your optical network is performing. Before
changing the loopback setting, ensure that the device is either in Managed state or ideally in Complete state.

To change the loopback settings on an interface:

Step 1 Choose Configuration > Network Devices.
Step 2 Select the device that you want to configure by clicking the device hyperlink to launch its Device Details page.
Step 3 Click the Logical View tab.
Step 4 Choose Interfaces > Loopback.
Step 5 To specify a new loopback interface, click Add.
a) In the Basic Configuration tab, specify the Loopback Interface Number (if not pre-populated).
b) If you are creating an IPv4 loopback interface, specify an IP Type:

* None.
* Static: along with the IP address and subnet mask of the static IP address.
* DHCP IP: along with the DHCP pool name.
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You can also enter a secondary IP address with its mask so that it can be used as the backup loopback interface.

¢) If you are adding an IPv6 loopback interface, in the [IPv6 Address area, select a type from the Add drop-down list.
Your options are:

* Global- which also requires you to specify the IP address, subnet mask, and type (General, EUI-64, Anycast,
CGA).

» Unnumbered- which requires you to enter text in the Interface Unnumbered To text box.

* Link Local- which is either auto-configured or manually-configured and only applies to requires [Pv6 address.

* Autoconfiguration

* DHCP- which also allows you to set the option to enable two-message exchange for automatic address allocation.

Step 6 To edit an existing loopback interface, select the interface and click the Edit button to change only the speed, duplex,
and other settings. The Interface Number cannot be edited.

Step 7 To enable the above loopback settings on the interfaces, select the required loopback process and click Enable.

Step 8 Click Save to deploy these configuration changes on the device.

Enable or Disable 10T Interfaces

The Configuration tab in the Device Details page lists the current interface configurations on the device.
Depending on your device configuration and user account privileges, you can enable and disable IOT interfaces.
This is applicable for EM, C3794, X.21, and serial interfaces (RS232, RS485, and RS422). If you
Enable/Disable an interface all the Controllers will be listed for the above technologies.

)

Note Ifan interface is not present, commands for Enabling/Disabling of interface will not be sent to the device.

\}

Note There is no QoS support for all the IOT services.

Step 1 Choose Configuration > Network Devices.
Step 2 Click the device hyperlink to launch its Device Details page.
Step 3 In the Chassis View tab, view all serial controllers that are listed for the configured CEM or channel group.
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Figure 1: Chassis View
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Step 5 Choose Interfaces > Serial.
Step 6 In the right pane, view all the list of serial controllers that are supported in EPNM and check one controller at a time to

enable or disable.
Step 7 Click Save.
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Enable or Disable Tunnel Interfaces

The Configuration tab in the Device Details page lists the current interface configurations on the device.
Depending on your device configuration and user account privileges, you can enable and disable these

interfaces.
Step 1 Choose Configuration > Network Devices.
Step 2 Click the device hyperlink to launch its Device Details page.
Step 3 Click the Logical View tab and choose Interfaces > Tunnel from the left side menu.
Step 4 To enable or disable a tunnel interface, select the interfaces and click the Enable or Disable button.

Note MPLS TE tunnel interfaces can be enabled or disabled here. For information on creating or editing MPLS TE
tunnels, see Create and Provision an MPLS TE Tunnel.

Configure Switch Port Interfaces

The Configuration tab in the Device Details page lists the current interface configurations on the device.
Depending on your device configuration and user account privileges, you can edit, delete, enable, and disable
these interfaces.

Step 1 Choose Configuration > Network Devices.
Step 2 Click the device hyperlink to launch its Device Details page.
Step 3 Click the Logical View tab.

Note The Configuration tab appears only for the supported devices.

Step 4 Choose Interfaces > Switch Port.
Step 5 To edit an interface, select the interface and click Edit.

* Choose and Administrative Mode: Static, Trunk 802.1Q, or Routed.

* Enable or disable the port fast setting, and adjust the speed and duplex, if needed.

Step 6 Click Save.

Configure Ethernet Interfaces

The Configuration tab in the Device Details page lists the current interface configurations on the device.
Depending on your device configuration and user account privileges, you can edit, delete, enable, and disable
the ethernet interfaces.

Limitations:

» For NCS 4202 and ASR 901, speed and duplex are supported for mediatype RJ45 Gigabit Ethernet.
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Step 1
Step 2
Step 3

Step 4
Step 5

Step 6

View Virtual Template Interfaces .

* Dropdowns are disabled for speed and duplex if mediatype is not configured.

* For other IOS/XE device types, drop downs are disabled and you will not be able to set speed and duplex
values from EPNM.

» For NCS 4202, if speed is set as 1 Gig, only full duplex option is supported, else for 10 and 100 Mbps,
both half and full duplex is supported.

* For ASR 901, for all 10, 100, 1000 Mbps speed, half and full duplex is supported.

* If you select Auto option in speed dropdown, both speed and duplex dropdown will reflect Auto and
user will be able to set the negotiation mode as Auto in this case.

* Select speed and duplex manually from dropdown and "no negotiation auto" command will be sent to
device with appropriate speed and duplex values.

Choose Configuration > Network Devices.
Click the device hyperlink to launch its Device Details page.
Click the Logical View tab.

Note The Configuration tab appears only for the supported devices.

Choose Interfaces > Ethernet.

To edit an interface, select the interface and click Edit.

You can now modify the required details.

Click Save.

View Virtual Template Interfaces

Step 1
Step 2
Step 3
Step 4

The Configuration tab in the Device Details page lists the current interface configurations on the device. Note
that you can only view the virtual template interfaces from this page. You cannot add, edit, enable, or disable
the interfaces.

Choose Configuration > Network Devices.

Click the device hyperlink to launch its Device Details page.
Click the Logical View tab.

Choose Interfaces > Virtual Template.

View VLAN Interfaces

The Configuration tab in the Device Details page lists the current interface configurations on the device. Note
that you can only view the VLAN interfaces from this page. You cannot add, edit, enable, or disable the
interfaces.

Configure Devices .



Configure Devices |
. Configure Optical Interfaces

Step 1 Choose Configuration > Network Devices.

Step 2 Click the device hyperlink to launch its Device Details page.
Step 3 Click the Logical View tab.

Step 4 Choose Interfaces > Vlan.

Configure Optical Interfaces

Using EPN Manager, you can configure your optical interfaces to change their admin settings, enable standard
FEC modes on them, modify their payload settings, and change their loopback settings. To do this, use the
Configuration tab in the Device Details page which lists the current interface configurations on the device.
Depending on your device configuration and user account privileges, you can create, edit, delete, enable, and
disable these interfaces.

You can configure optical interfaces in the following ways:
* Change the Loopback Settings on an Optical Interface, on page 44
* Continuous Verification of the Connection Status, on page 45
* Configure PRBS on ODU Controllers, on page 47
* Enable and Disable OSC, on page 48
* View and Acknowledge Unverified Alarms, on page 49
* Provision Optical Interfaces , on page 49
* Change the Admin Status of an Optical Interface, on page 56
* Configure Protection Profiles, on page 57
* Configure TCM and TTI Parameters, on page 58
* Change the Port Mode/Payload and Breakout Settings, on page 60
* Configure OTN Interfaces, on page 61
* Enable and Disable GCC Connections, on page 62
* Configure Squelch Mode, on page 62
* Configure Squelch Mode and Hold Off Timer for NCS 1004 interfaces, on page 63

» Example: Change the Admin Status for Cisco NCS 2006 Interface, on page 64

Change the Loopback Settings on an Optical Interface

You can change the loopback state of an interface to test how your optical network is performing. Before
changing the loopback setting, ensure that the device is either in Managed state or ideally in Complete state.
The interface that you want to modify must be in Maintenance (OOS, MT) admin state. EPN Manager allows
you to edit the loopback settings only on SONET, SDH, Ethernet, FC/FICON, and OTN interface types.

To change the loopback settings on an interface:
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Step 1
Step 2
Step 3

Step 4

Step 5

Step 6

Continuous Verification of the Connection Status .

Choose Configuration > Network Devices.

Click the device hyperlink to launch its Device Details page.

Click the Configuration tab.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device
Details page.

Choose Optical Interfaces > Maintenance > Loopback.

The interfaces of the selected device are displayed along with their loopback settings. Interfaces that are not supported,
for example, Data Storage, OTS, or Video, are not displayed.

To edit the loopback settings, select the interface name (hyperlink) and click Edit to make your changes. Ensure that the
device is in Managed or Complete state and the interface is in Maintenance (OOS, MT) admin state.

a) Internal—this applies the same configuration applied in Terminal loopback.

b) Line—this applies the same configuration applied in Facility loopback.

¢) No Loopback—Select this option to set no loopback values on the interface.

Before you change the loopback state ensure that you first clear the current loopback setting using the No_loopback
option from the drop-down menu and then re-apply the setting of your choice.

Click Save to save your edits.
A pop-up notification notifies you about the status of your changes.

Note If the Edit task fails, check if the device is in Managed or Completed state and ensure that Cisco EPN Manager
is in sync with the device configuration. If not, resync the device with Cisco EPN Manager. See, Collect a
Device's Inventory Now (Sync), on page 137.

Continuous Verification of the Connection Status

Step 1
Step 2
Step 3

Step 4

Step 5

Using the Connection Verification feature, you can view the power levels of optical interfaces and verify the
interfaces for connectivity and insertion loss. Verifying the connectivity indicates whether the cable is in a
connected state and verifying the insertion loss indicates whether the cable loss is within an expected value.
The parameters for insertion losses are collected for every possible optical path inside the network element
in order to predict possible failures.

Using Cisco EPN Manager you can view the Connection Verification parameters and opt to enable or disable
Connection Verification on interfaces. You can also set the acknowledgment values for associated alarms.

To verify the connection status for your optical interfaces:

Choose Configuration > Network Devices.

Click the device hyperlink to launch its Device Details page.

Click the Configuration tab.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device
Details page.

To enable or disable the Connection Verification feature and set the common threshold vales, click Optical Interfaces
> Provisioning > Connection Verification.

Click the Edit icon at the top right corner of the page to edit common parameters.

Configure Devices .
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Step 6 Enter the following threshold parameters for the selected device and click Save:

» Connection Verification Enabled- Set to True or False to enable or disable this feature on the selected device.

* Fail IL Threshold (dB)- Enter a numerical value ranging from 0 to 20. When this threshold value is exceeded, an
alarm is generated.

* Degree IL Threshold (dB)- Enter a value lesser than the failed IL threshold value.

Step 7 Click Optical Interfaces > Maintenance > Connection Verification Entry.
For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device
Details page.

Step 8 Click the A Side hyperlink to view the following values of the connection:

+ A Side- Displays the originating slot for connection verification.
* Z Side- Displays the destination slot for connection verification.

* Last Refresh- Displays the date and time when the connection verification and insertion loss verification was run
previously.

* Connectivity Last Change- Displays the date and time when the connectivity information was previously changed.
+» Connectivity Verification- Displays the status of connectivity:

* Connected- Cable or patch cord is connected.

* Disconnected- Cable or patch cord is disconnected.

* Disabled- Cable or patch cord is excluded from connection verification.

» Not Measurable- Power source not detected; cable or patch cord cannot be tested for connection verification.

* Not Verified- Cable or patch cord is yet to be tested for connection verification.

* Excess Insertion Loss (dB)- Display the excess insertion loss that is higher than the set threshold.

* Insertion Loss Last Change- Displays the date and time when the insertion loss verification information was
previously changed.

* Display names for- A and Z Side, A and Z Side Modules- identification names of the connection for A and Z Side,
and A and Z Side Modules.

* Insertion Loss Verification- Displays the insertion loss verification status which is one of the following:

* Not Verified- Cable or patchcord is yet to be tested for insertion loss verification (this is the default status at
first boot).

» Not Measurable- Power source not detected; cable or patchcord cannot be tested for insertion loss verification.
* Loss OK- Cable or patchcord insertion loss is within expected value.
* Degrade- Cable or patchcord insertion loss is degrading.

When the Insertion Loss is greater than the Insertion Loss Degrade Threshold and less than the Insertion Loss
Fail Threshold, the Insertion Loss Verification of the patch cord is Degrade. The corresponding row of the
patch cord in the Connection Verification pane is highlighted in yellow.
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Step 9

Step 10

Configure PRBS on 0DU Controllers .

* Fail- Cable or patchcord insertion loss crossed the fail threshold. When this condition occurs, the patchcord
is highlighted in the GUI to indicate the Fail condition.

When the Insertion Loss is greater than the Insertion Loss Fail Threshold, the Insertion Loss Verification of
the patch cord is Fail. The corresponding row of the patch cord in the Connection Verification pane is
highlighted in orange.

* Disabled- Cable or patchcord is excluded from connection verification.

» Acknowledgement- Displays the set value for the associated alarms. The values can be set to True or False.

In the Connection Verification Action drop-down menu, choose an action that must be taken when the configured
threshold values are reached, and click Save. Your options are: Verify loss and connectivity, Disable verification,
and Acknowledge loss alarm.

(Optional) Select one of the following values to specify how alarms must be generated with respect to the Connection
Verification parameters:

» Acknowledge Loss Alarm - allows the interfaces to operate beyond the Fail IL Threshold thresholds without
raising an alarm. If the Fil IL Threshold further increases, alarms are raised again.

+ Clear Acknowledge - indicates that the Fail IL Threshold thresholds are set to default and alarms are re-evaluated.
If thresholds are exceeded, an alarm is raised.

Configure PRBS on ODU Controllers

Step 1
Step 2
Step 3

Step 4

Step 5
Step 6

Pseudo Random Binary Sequence (PRBS) is a testing mechanism used to ensure that the selected overhead
bytes can be used to transport the header and trailer data safely. Both the transmitting node and receiving node
must be aware that PRBS testing is taking place. To do this you can use Cisco EPN Manager to enable
appropriate PRBS modes on the nodes. Cisco EPN Manager allows you to configure PRBS only on the
non-channelized ODU controllers of an optical device.

PRBS also enables trunk ports to generate the PRBS 31 pattern and detect PRBS 11, PRBS 23, and PRBS 31
patterns.

Choose Configuration > Network Devices.
Click the device hyperlink to launch its Device Details page.
Navigate to the Configuration tab.

* For NCS 1004 devices, this option is available Chassis View > Configuration > PRBS Configuration. Go to Step
5.

 For NCS 4000 devices, this option is under the Logical View tab on the top left of the Device Details page

Choose Optical Interfaces > Maintenance > PRBS Configuration. All ODU controllers and their current PRBS
parameters are displayed. If the controllers are not listed, ensure that the above stated pre-requisites are met.

To configure PRBS, click the controller’s name hyperlink and click the Edit icon at the top right corner of the page.
Make your modifications to the following parameters.

a) Inthe Admin State drop-down list, select a valid admin state for the ODU controller. Your options are 00S-MT
(maintenance), OOS-DSBLD (disabled), and IS (in-service).
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The PRBS parameters can be edited only if you set the Admin State to 00S-MT (maintenance) state.

To edit only the admin state of the controller, set the PRBS mode to Disabled, and choose the admin state of your
choice.

b) Select the PRBS Test value as Enabled or Disabled.

c) Select the PRBS mode for the controller. When you set one controller with the values in column one (see below),
ensure that the second controller (node 2) is set with the corresponding values shown in the second column of this

table:
Controller 1 Mode (Node 1) Controller 2 Mode (Node 2)
Source Sink
Sink Source
Source-Sink Loopback
Loopback Source-Sink

d) From the Pattern drop-down list, select one of the following PRBS patterns. This pattern will be either generated or
detected by the line cards:

* NONE

* PN11

* PN23

* PN31

« INVERTEDPNI11
* INVERTEDPN31

Step 7 Click Save to deploy the updated configuration to the device.

Step 8 (Optional) To verify, view updated PRBS parameters in the Configuration tab for the selected controller, under Optical
Interfaces > Provisioning > PRBS. To run a PRBS test on ODU UNI circuits, see, Run PRBS Test on Circuits (ODU
UNI).

Enable and Disable 0SC

Using Cisco EPN Manager, you enable or disable the Optical Service Channel (OSC) terminations on the
interfaces of optical devices. OSC can be configured on OC3 lines, and on FastEthernet (FSTE) and
GigabitEthernet (GigE) interfaces of the following cards:

* Transmission Network Control System (TNCS)
* Transport Node Controller - Enhanced (TNCE)

* Transport Node Controller (TNC)

For ONS15454 NEs, the supported interfaces are OC3 interfaces of the following cards:
* Optical Service Channel Modem (OSCM)
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Step 1
Step 2
Step 3

Step 4

Step 5
Step 6

Step 7
Step 8
Step 9

View and Acknowledge Unverified Alarms .

* Optical Service Channel and Combiner/Separator Module (OSC-CSM)

To configure OSC on optical devices:

Choose Configuration > Network Devices.
Click the device hyperlink to launch its Device Details page.
Click the Configuration tab.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device
Details page.

Choose Optical Interfaces > Comm Channels.
All configurable G709 enabled interfaces of the selected device are displayed.
Click the OSC tab.

Choose the communication channel that that you want to configure by clicking the communication channel’s name
hyperlink.

The communication channel name and current OSC setting is displayed.
Click the Edit icon at the top right of the page.

Use the OSC checkbox to enable or disable OSC on the selected communication channel.
Click Save.

Your changes are saved and the updated configuration is deployed to the device. To verify, view the OSC settings for
the selected communication channel under Optical Interfaces > Provisioning > Comm Channels.

View and Acknowledge Unverified Alarms

Step 1
Step 2
Step 3

Step 4
Step 5

Based on the alarm generated on your devices, you can view the details of the alarm in Unverified status and
then mark them Acknowledged so that they no longer appear as unread alarm notifications on the device. To
do this:

Choose Configuration > Network Devices.

Click the device hyperlink to launch its Device Details page.

Click the Configuration tab.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device
Details page.

Choose Optical Interfaces > Maintenance > Unverified Alarms to view the alarms with the Unverified status.

Once you have reviewed the alarms and taken the required action, select the alarms and click the Acknowledge button
to mark these alarms Verified directly on the device.

Provision Optical Interfaces

You can use Cisco EPN Manager to enable the following configuration options on your optical devices.
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Note

The following configuration options are enabled or disabled depending on the device you select. To
check whether your device supports these options, see Supported Devices for Cisco EPN Manager.

Ethernet MTU

Using Cisco EPN Manager you can configure the MTU values on the Ethernet interfaces of your optical
devices. The MTU is the Maximum Transmission Size, in bytes, of a packet passing through the interface.
You can use Cisco EPN Manager to modify the MTU values on all Ethernet interfaces except Gigabit
Ethernet and Fast Ethernet interfaces on TNC and ECU modules.

To verify that your new Ethernet MTU values are configured on the device, navigate to your device’s
Device Details page and click the Ethernet Interface tab.

GMPLS

Using Generalized Multi-Protocol Label Switching (GMPLS), you can define and view the fiber and
alien wavelength parameters that are used during GMPLS circuit creation. It ranges the packet based
data on the MPLS protocol to allow the creation and maintenance of channels across the networks. It
supports non-packet switching devices. This means that GMPLS extends the packet based MPLS protocol
to allow creation and maintenance of tunnels across networks that consist of non-packet switching devices.
GMPLS tunnels can traverse Time-Division Multiplex (TDM) interfaces and switching types.

To configure GMPLS, you can use the Configuration tab in Cisco EPN Manager which allows you to
configure GMPLS on all LMP enabled optical controllers. The enabling of LMP which is a pre-requisite
for GMPLS configuration can also be done using the same Configuration tab.

\}

Note  You cannot disable GMPLs on LMP enabled controllers that are part of

active optical circuits.

Packet Termination

Using Cisco EPN Manager you can set up packet termination on the ODU controllers of your optical
devices. To do this, ensure that packet termination is pre-configured on the device for Ethernet packets.
You can then edit the configuration that is already created on the device and discovered by Cisco EPN
Manager.

To configure packet termination, you must specify both the Termination Mode and Mapping Mode
values.

LMP

The Link Management Protocol (LMP) helps in managing channels and links that are required between
nodes for routing, signaling, and link management. LMP is also used to manage the Traffic Engineering
(TE) link. It allows multiple data links into a single Traffic Engineering (TE) link that runs between a
pair of nodes.

To create an LMP neighbor using Cisco EPN Manager, you need to specify the neighbor’s name, link
ID, router ID, and interface ID, and the common link and interface IDs. You can add only one LMP link
per controller on your optical device.
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While the LMP configuration can be successfully deployed to a single device using Cisco EPN Manager,
for LMP to function effectively, you need to configure it on both sets of devices that are participating in
the link. This ensures that the LMP link is activated.

Limitations:

* You cannot edit the Numbering value of an LMP link after it has been created. To edit the Numbering
value, delete the LMP link and recreate it with the new Numbering value.

* You cannot have duplicate Neighbor Router IDs between two LMP neighbors.

* When you add an LMP link, ensure that the controller is not already associated with another LMP
link. This will cause your deploy to fail.

OTN Topology

You can use the Configuration tab to add or modify the topology instance and Area ID associated with
an optical OTN controller. If the controller does not have a pre-configured Topology Instance and Area
ID, Cisco EPN Manager automatically sets the topology instance to OTN and the Area ID to 0.

Cisco EPN Manager does not allow you to use the same topology instance and Area ID that is already
pre-configured on other controllers. To know the Topology Instance and Area ID that is pre-configured
on the device, go to Maps > Network Topology.

NNI

You can configure your optical interfaces to act as network-node interfaces (NNIs). An NNI indicates
that the interface connects to other network nodes. Cisco EPN Manager allows you to configure NNIs
on the OTU controllers of your optical device. These interfaces can further be configured to act as source
and destination ports.

If a device is not part of a topology, configuring its NNI controller creates an OTN topology instance
for that controller with an Area ID 0.

You can create only one NNI configuration per controller for every controller present on the device.
Note: You cannot delete NNI controllers that are pre-configured with a Topology Instance.
Breakout

Enabling breakout on your optical devices utilizes the multilane architecture of the optics and cables to
enable you to split single higher density ports into multiple lower density ports. For example, a 100G
port can be configured to operate as ten different 10G ports. Or a single 40G port can act as four different
10G ports. To configure breakout using Cisco EPN Manager, see the table below.

Pre-requisite:

Ensure that Breakout is pre-configured on the interface by changing the interface’s Port Mode value to
Breakout. See Change the Port Mode/Payload and Breakout Settings, on page 60. This changes all other
port mode parameters of that interface to ‘None’ enabling breakout on the port, thus allowing you to
configure lanes. You can add up to ten lanes per interface.

Limitations:
* All lanes that belong to a particular interface must have the same mapping type.
* OTU2 and OTU2e controllers are supported only if they are in the packet termination mode.

* In Cisco NCS 5.2.4x devices, breakout lanes can only be created when the port modes are of type
Ethernet.
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* 10G clients that are mapped to OPU2e¢ framing type are not supported.

* Breakout cannot be configured on SONET and SDH controllers.

Example configuration:

If you select a controller optics 0/0/0/0 and enable Breakout with GFPF as its mapping mode and with
a framing value of OPU2, then the configuration pushed to the device is:

controller optics 0/0/0/0 breakout-mode 1 ethernet framing opu2 mapping gFpF
Performance Monitoring

Performance Monitoring (PM) helps you gather performance counters for system maintenance and
troubleshooting. You can retrieve both current and historical PM counters at regular intervals. You can
enable and disable performance monitoring on OTU and ODU controllers of an optical device.

To configure performance monitoring at the TCM controller level, you must configure OTN interfaces
and their associated TCM performance counters, see:

* Reference—Performance Counters for OTN-FEC Interfaces
e Reference—Performance Counters for OTN-ODU Interfaces

¢ Reference—Performance Counters for OTN-OTU Interfaces

Channelize ODU (LO) Controllers:

Associate your ODU controllers with multiple lower order ODU sub-controllers and configure tributary
port number (TPN) and tributary slots (TS) for those ODU sub-controllers. A valid range of TPN is from
1 to 80. If a TS string is separated using a colon (:), this indicates individual tributary slot. If a TS string
is separated using an en-dash (-), this indicates a range of tributary slots.

When you select the ODU level for the sub-controllers, ensure that the sub-controller's ODU level is
lower than that of the main controller you are associating it with. For example, if you are associating
sub-controllers with an ODU controller of ODU3 level, then the sub-controllers cab be of levels ODU2,
ODU1, or ODUL.

Configuring OTDR Settings:

Using this feature, you can configure OTDR scans to begin automatically on a fiber span that has been
repaired or on the startup of an OSC channel. To do this, ensure that the 'Auto Scan on LOS' parameter
is enabled. A fiber is considered to be repaired when the LOS on the fiber is cleared and an alarm is
raised based on the following criteria:

* If you check the Enable Absolute Threshold checkbox, the ' OTDR-LOSS-THR-EXCEEDED' alarm
is raised when the insertion loss measured for the OTDR scan is greater than the Absolute Event
Loss Threshold (dB) value configured.

« If the total back reflection for the OTDR scan is less than the Total Back Reflection (dB) value that
you specify.

« If the Absolute Pass Fail Criteria is disabled, the Loss and Back Reflection values from the baseline
scan in the previous release are considered as threshold values. In this scenario, the
OTDR-LOSS-THR-EXCEEDED alarm is raised.

Depending on how you want the auto scans to be triggered, you can configure the following parameters:

Devices
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* Auto Scan on Span Loss Increase- OTDR scan starts automatically on the fiber if the measured span
loss on the fiber is greater than the threshold value configured. The default threshold value is 2.

* Enable OLR continuous measurement on Rx direction- measures the span loss in the LINE-RX port
(input) of the card depending on the configured threshold value.

* Enable WDM Side from WSON Provisioning- prevents creation of circuits when the Loss and Back
reflection threshold values are crossed during an OTDR scan.

You can configure the Event Loss Threshold value within which the total span loss on the fiber is
permitted. If the measured span loss on the fiber is greater than the Event Loss Threshold value, then the
OTDR scan is triggered on the fiber.

Configure Automatic Laser Shutdown (ALS):

Automatic Laser Shutdown (ALS) is a technique used to automatically shut down the output power of
the transmitter in case of issues such as a fiber break. This is a safety feature that prevents dangerous
levers of laser light from leaking out of a broken fiber, provided ALS is provisioned on both ends of the
fiber pair. Once an interface has been shut down, you can configure the action the action that must be
taken to restart the interface by setting the ALS mode to:

+ Disabled mode—If mode is disabled, ALS is disabled. Loss Of Signal (LOS) will not cause laser
shutdown.

» Manual restart mode—The laser is turned off when the ALS agent detects an LOS for 500 ms.
After ALS is engaged, a manual command is issued that turns on the laser for the time period of
the pulse width. The laser is turned on when the LOS has been cleared for 100 ms.

» Automatic restart mode—The laser is shut down for the time period of pulse spacing when the
ALS agent detects a LOS for 500 ms. Then, the laser automatically turns on for the time period of
the selected pulse width. If an LOS still exists at that time, the laser is shut down again. This pattern
continues until the LOS is cleared for 100 ms; then, the laser will stay on.

Cisco EPN Manager enables you to set the ALS mode, the ALS recovery interval (in seconds), and the
recovery pulse width (in seconds). If the ALS Mode for the interface has been set to Manual Restart, you
need to manually restart the interface. To do this, navigate to the device's Device Details page, choose
Optical > Automatic Laser Shutdown, locate the interface set to the Manual Restart ALS mode, and
click the Restart button.

Using the SNTP Server to Set the Date and Time:

Simple Network Time Protocol (SNTP) is an internet protocol used to synchronize the clocks of computers
to a time reference. Using the SNTP server ensures that all NEs use the same date and time reference.
The server synchronizes the node’s time after power outages or software upgrades.

To use the SNTP server to set the date and time you must first specify the current time along with the
time zone value and then set the primary and backup servers that can be used as a point of reference for
the date and time. Before you set the timezone values, ensure that the SNTP server values are not
configured. When you delete an SNTP server, ensure that you first delete the Backup server and only
then the Primary server. You cannot delete only the Primary server.

Configuring the Wavelength:

Cisco EPN Manager enables you to provision the wavelength frequency for your optics controllers. You
can view the current wavelengths configured on the optics controllers and then depending on the type
of card selected, you can change the wavelength frequency.
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Table- Provisioning Optical Interfaces

To configure your optical devices with the above features:

Step 1
Step 2
Step 3

Choose Configuration > Network Devices.

Click the device hyperlink to launch its Device Details page.
Click the Configuration tab.

Configure Devices |

You can configure the wavelengths on an optics controller only when it is configured as a DWDM optics
port. The optics port must not be in the In Service state when you are changing the wavelength.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device

Details page.
Step 4

Table 8: Table- Configuring Optical Interfaces

Navigate to the required configuration menu as described in the table below, and specify the required values.

Task Supported Interfaces/Controllers Navigation Notes
Configuring All Ethernet interfaces except Gigabit/Fast | Optical Interfaces > -
Ethernet MTU | Ethernet interfaces on TNC and ECU Provisioning > Ethernet
modules. MTU
Configuring LMP enabled optical controllers. Optical Interfaces > -
GMPLS Provisioning > GMPLS
Configuring ODU controllers pre-configured with Optical Interfaces > Applicable only to Ethernet
Packet Packet Termination. Provisioning > OTN > packets.
Termination Packet Termination

Configuring an

All optical controllers.

Optical Interfaces >

Neighbor Router ID cannot

LMP Neighbor Provisioning > LMP be duplicated between
neighbors

Configuring All optical OTN controllers. Optical Interfaces > -
OTN Topology Provisioning > OTN >

Topology
Configuring All OTU controllers. Optical Interfaces > -
NNI Provisioning > OTN > NNI
Configuring All optical controllers with Port Mode Optical Interfaces > -
Breakout values set to ‘Breakout’. Provisioning > Port Mode >

Breakout tab
Configuring All OTU and ODU controllers. Optical Interfaces > -
Performance Provisioning > Performance
Monitoring Monitoring
Channelize All ODU controllers. Optical Interfaces > -
ODU (LO) Provisioning > ODU
Controllers Channelization >

Sub-Controllers tab
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Configuring - Optical Interfaces > -
OTDR Settings Provisioning > OTDR
Settings
Configuring All ALS supported interfaces Optical Interfaces > -
ALS Provisioning > Automatic
Laser Shutdown
Setting the Date | - * To specify the primary |-
and Time using and backup servers for
SNTP SNTP:
Choose Optical
Interfaces >
Provisioning > NTP
Settings
* To specify the current
time and time zone that
can be used by SNTP:
Choose Optical
Interfaces >
Provisioning > Time
Zone Settings
Configure All optics controllers Optical Interfaces > -
Wavelength Provisioning > Wavelength
Configure TCM | - See Configure TCM and TTI | -
and TTI Parameters, on page 58
Configure - See Configure Protection |-
Protection Profiles, on page 57
Profiles
Configure the |- See Change the Port -
Payload and Mode/Payload and Breakout
Breakout Settings, on page 60
Settings
Configure the |- See Change the Admin -
Admin Status Status of an Optical
Interface, on page 56
Configure FEC | - See Configure OTN -
Mode Interfaces, on page 61
Enabling and |- See, Enable and Disable -
Disabling GCC GCC Connections, on page
62
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Configure See, Configure Squelch
Squelch Mode Mode, on page 62

Change the Admin Status of an Optical Interface

Step 1
Step 2
Step 3

Step 4

Step 5
Step 6

Step 7

Cisco EPN Manager enables you to change the admin state of an interface to enhance the performance testing
abilities for your optical network. The Admin Status of an interface defines whether the interface is being
managed by Cisco EPN Manager, whether it is down, or whether it is in maintenance mode. When the admin
status of an interface is down, it indicates that the interface is in an unreachable state, or that the device is not
supported by Cisco EPN Manager. Changing the admin status to Up enables Cisco EPN Manager to manage
the interface and thus provide better monitoring capabilities. To change the admin state on an interface:

Choose Configuration > Network Devices.

Click the device hyperlink to launch its Device Details page.

Click the Configuration tab.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device
Details page.

Choose Optical Interfaces > Provisioning > Admin Status.

The interfaces of the selected device are displayed along with their Admin State settings. Interfaces on which you cannot
modify the admin state, for example, PCHAN and PLINE interfaces are not displayed.

Click either the Optical Controllers or Ethernet Controllers tab to edit the required controllers.

To edit the admin status, select the interface by clicking the interface's Name hyperlink, and then click the Edit icon at
the top right corner of the page. Ensure that the device's inventory collection status is in Managed or Completed state.

Choose one of the following values:

a) DOWN-—implies that the interface will be administratively down.

b) UP—implies that the interface will be administratively up.

c¢) TESTING— implies that the interface is in Maintenance state and that the administrator is performing tests using
it.

Click Save to save to deploy your changes to the device.

A pop-up notification notifies you about the status of your changes. To see an example of the admin status being changed
on a Cisco NCS2K device, see Example: Change the Admin Status for Cisco NCS 2006 Interface, on page 64.

Note If the Edit task fails, check if the device is in Managed or Completed state and ensure that Cisco EPN Manager
is in sync with the device configuration. If not, re-sync the device with Cisco EPN Manager as described in
Collect a Device's Inventory Now (Sync), on page 137.

Change the Admin Status of an Optical Interface in Chassis View

Cisco EPN Manager enables you to change the admin state of an interface to enhance the performance testing
abilities for your optical network. The Admin Status of an interface defines whether the interface is being

managed by Cisco EPN Manager, whether it is down, or whether it is in maintenance mode. When the admin
status of an interface is down, it indicates that the interface is in an unreachable state, or that the device is not
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Step 1
Step 2
Step 3

Step 4

Step 5

Configure Protection Profiles .

supported by Cisco EPN Manager. Changing the admin status to Up enables Cisco EPN Manager to manage
the interface and thus provide better monitoring capabilities. To change the admin state on an interface:

Before you begin

Choose Configuration > Network Devices.

Click the device hyperlink to launch its Device Details page.

In the Chassis View window, click the Configuration tab and then Line.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device
Details page.

To edit the admin status, select the interface by clicking the interface's Name hyperlink, and then click the Edit icon at
the top right corner of the page. Ensure that the device's inventory collection status is in Managed or Completed state.

Choose one of the following values:

a) DOWN—implies that the interface will be administratively down.
b) UP—implies that the interface will be administratively up.

¢) TESTING— implies that the interface is in Maintenance state and that the administrator is performing tests using
it.

d) UP AINS—implies that the interface will be administratively up and in service.

Note The UP AINS status will only appear in the chassis view.

Click Save to save to deploy your changes to the device.
A pop-up notification notifies you about the status of your changes.

Note If the Edit task fails, check if the device is in Managed or Completed state and ensure that Cisco EPN Manager
is in sync with the device configuration. If not, re-sync the device with Cisco EPN Manager as described in
Collect a Device's Inventory Now (Sync), on page 137.

Configure Protection Profiles

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6

Using Cisco EPN Manager, you can provision different protection profiles (or groups) for your optical devices.
This ensures availability and improved reliability for these devices. Protection profiles define whether Automatic
Protection Switching (APS) must be enabled on the cards and they also set the direction for traffic flow in
case of failures. The cards on the device can either be set to support unidirectional regeneration of configuration
or can be set to ensure that both transmit and receive channels will switch when a failure occurs on one.

Choose Configuration > Network Devices.

Click the device hyperlink to launch its Device Details page.

Click the Logical View tab that is at the top of the Device Details page.
Choose Optical Interfaces > Provisioning > Protection Profile.

To add a protection profile, click the + symbol.

Provide a unique name for the protection profile. The name is a mandatory field and should not contain space or exceed
32 characters.

Configure Devices .
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Step 7

Step 8
Step 9

Step 10

Step 11

Step 12

Step 13
Step 14

Select the required type for the protection profile. Your options are:

* One plus one BDIR APS- Enables one plus one Automatic Protection Switching (APS) and configures the card
to be bidirectional.

* One plus one UNIDIR APS- Enables one plus one APS and configures the card to be unidirectional.
* One plus one UNIDIR NO APS- Enables one plus one with no APS and configures the card to be unidirectional.
* One plus one PLUS R BIDIR APS - Enables one plus one plus R APS and configures the card to be bidirectional.

Note * BDIR (bidirectional) indicates that both transmit and the receive channels will switch if a failure occurs
on one.

* UNIDIR (unidirectional) indicates that the card supports unidirectional regeneration of configuration.
Hence the ports can only be used as the link source if they are transmit ports and as the link destination
if they are receive ports.

Select the protection mode for the profile as Revertive or Non-Revertive. Revertive mode ensures that the node returns
traffic towards the working port post a failure condition after the amount of time specified as the Wait to Restore Time
(step 9).

Select the sub network connection mode as SNC_N (default), SNC_I, or SNC_S.

When you select the sub network connection mode as SNC_S, you can then select TCM-ID value from the TCM

drop-down list. By default, TCM-4 is selected once you select SNC_S as Sub Network Connection mode. You can
change the TCM-ID column value from TCM4 to TCM1-TCM6 for SNC_S.

Note For SNC I and SNC_N, you are not allowed to change the TCM-ID value. It should be set to None.

Enter a value for the Wait to Restore Time in seconds using a number between 0 and 720. For any value greater than
0, ensure that the value is greater than 300 and in intervals of 30 seconds. The wait to restore time defines the time the
system must wait to restore a circuit. If you have selected the protection mode as Revertive, then the default wait to
restore time is 300, else it is 0.

Enter a value for the Hold Off Time in milliseconds. This value defines the time the system waits before switching to
the alternate path. The valid range is from 100 to 10,000 seconds. Default value is 0.

Click Save to deploy the updated changes to your device.

(Optional) To verify, view the updated protection profile parameters in the Configuration tab for the selected controller,
under Optical Interfaces > Provisioning > Protection Profile.

Note The above-mentioned steps are not applicable for NCS2K devices.

Configure TCM and TTI Parameters

Using Cisco EPN Manager you can configure Tandem Connection Monitoring (TCM) and Trail Trace
Identifiers (TTI) on ODU controllers of ODU Tunnel circuits. This helps you enable and disable performance
monitoring capabilities on these controllers.

You can further monitor your device’s capabilities by configuring the threshold for signal failure and signal
degradation in the TCM connections of these ODU controllers. You can also modify the source and destination
access point identifiers. To do this, ensure that the following prerequisites are met.
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Step 1
Step 2
Step 3

Step 4

Step 5
Step 6
Step 7

Configure TCM and TTI Parameters .

Before you begin

* Ensure that the device’s inventory collection status is ‘Completed’.

* Ensure that the controllers are configured for Loopback. If not, change the controllers loopback settings
under Optical Interfaces > Maintenance > Loopback. See Configure Loopback Interfaces, on page
39.

N

Note For the endpoints of an ODU UNI circuit, TCM is supported only on OTUx-ODUx controllers.

Choose Configuration > Network Devices.

Click the device hyperlink to launch its Device Details page.

Click the Configuration tab.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device
Details page.

To configure TCM/TTI parameters, choose Optical Interfaces > Provisioning > TCM Configuration.

Alternatively you can navigate to the device's Chassis View tab, select a card from the Chassis Explorer, click the
Configuration tab, and choose OTN > Trail Trace Identifier.

Note To configure TCM parameters for NCS2K devices, navigate to the device's Chassis View tab, select a card
from the Chassis Explorer, click the Configuration tab, and choose OTN > Trail Trace Identifier.

To view or edit the TCM parameters of any of the listed controllers, click the TCM ID hyperlink of that controller.
To edit these parameters, click the Edit icon at the top right corner of the page.
Make your changes to the following TCM parameters:

Editable TCM Parameters Descriptions
State Configures the state of TCM properties on the device as enabled or disabled.
Signal Failure Threshold Configures the threshold value for signal failures on ODUk controllers. The

values are E6, E7, E8, and E9.

Sent API Configures the source access point identifier of the TTI.

Enter a value of up to 14 bytes in length.

Sent DAPI Configures the destination access point identifier of the TTI. Enter a value of
up to 14 bytes in length.

Sent Operator Specific String Type Configures the type of the operator-specific string of the TTI as hexadecimal
or ASCII type.

Sent Operator Specific String Configures the operator-specific string of the TTI.

Enter a value of up to 32 characters in length.

Performance Monitor Enables or disables performance monitoring on an ODUk controller.

Signal Degrade Threshold Configures the signal degrade threshold value.

The values are: E6, E7, E8, and E9.

Configure Devices .
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Step 8
Step 9

Step 10

Step 11

Editable TCM Parameters Descriptions

Expected SAPI Configures the current source access point identifier of the TTI. Enter a value
of up to 14 bytes in length.

Expected DAPI Configures the current destination access point identifier of the TTI. Enter a
value of up to 14 bytes in length.

Expected Operator Specific String Configures the type of the operator-specific string of the TTI as hexadecimal
Type or ASCII type.

Expected Operator Specific String Configures the operator-specific string of the TTI.

Enter a value of up to 32 characters in length.

Click Save to deploy the updated configuration to the device.

(Optional) To verify, view the selected device’s TCM parameters in the Configuration tab, under Optical Interfaces
> Provisioning > TCM Configuration.

(Optional) You can view these updated TCM and TTI parameters in the Device Details and Port 360 view of the selected
device. See View Device Details and View a Specific Device's Interfaces: Device 360 View.

(Optional) The TCM parameters are also represented on the network topology overlay. To view these parameters,
navigate to Maps > Network Topology and select an optical circuit with these associated TCM parameters.

Change the Port Mode/Payload and Breakout Settings

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6

Step 7
Step 8

Step 9

Using the Device Configuration tab, you can view and modify the type of the payload for packets on SONET
and SDH interfaces and enable breakout on them. Before changing the payload setting, ensure that the device
is in sync with Cisco EPN Manager. Enabling breakout on your optical devices utilizes the multilane architecture
of the optics and cables to enable you to split single higher density ports into multiple higher density ports.
For example, a 100G port can be configured to operate as ten different 10G ports. Or a single 40G port can
act as four different 10G ports.

To change the payload and breakout setting on an interface:

Choose Configuration > Network Devices.

Click the device hyperlink to launch its Device Details page.

Click the Logical View tab that is at the top of the Device Details page.

Choose Optical Interfaces > Provisioning.

Depending on the type of device that you have selected, choose Payload Type or Port Mode.
Click the name (hyperlink) of the interface that you want to modify.

Common properties of the interface such as its name and its payload type are displayed.

Click the name (hyperlink) of the OTN interface that you want to modify and click the Edit icon.

Make your changes to the Port Mode, Framing, Mapping Type, Rate, and Bit Rate values. Ensure that these values do
not exceed the card's bandwidth limitations.

To associate breakout lanes for Ethernet and OTN packets on this interface, click the Breakout tab. This tab is only
displayed if the device has breakout pre-configured.
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Step 10

Configure OTN Interfaces .

a) Click the “+’ icon to add a new lane. You can add up to 10 lanes per controller. To modify existing lanes, click the
Lane hyperlink.

b) Specify the breakout parameters such as the lane number, the port mode and mapping type for the breakout lane,
the owning port number, and the framing value.

Click Save to deploy your changes to the device.
A pop-up notification notifies you about the status of your changes.

Note If the Edit task fails, check if the interface is in Managed state and ensure that Cisco EPN Manager is in sync
with the device's configuration. If not, resync the device with Cisco EPN Manager. See Save Your Device
Changes, on page 137. You also need to ensure that the payload does not exceed the card's bandwidth limitation.

Note Instructions given in Steps 6—10 are not applicable for NCS2K devices.

Configure OTN Interfaces

Step 1
Step 2
Step 3

Step 4
Step 5

Step 6

Step 7
Step 8

The FEC Mode defines an OTN circuit's forward error correction (FEC) mechanism. The forward error
correction (FEC) mechanism provides performance gains for improved margins and extended optical reach.
To change the FEC Mode setting to Standard, you need to use the Device Configuration tab.

Before changing the FEC mode setting, ensure that the admin state of the interface you are trying to modify
is in Down (out of service) state with G709 configuration enabled. To enable G709 configuration, use the
OTN Lines configuration in the Chassis view.

To change the FEC mode on an interface:

Choose Configuration > Network Devices.

Click the device hyperlink to launch its Device Details page.

Click the Configuration tab.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device
Details page.

Choose Optical Interfaces > Provisioning.

Change the admin state of OTN interfaces for which FEC needs to be modified to Down. See Change the Admin Status
of an Optical Interface, on page 56.

Depending on your device type, choose one of the following and select the interface you want to modify:

* OTN Lines > OTNFEC
« OTN > FEC

All configurable G709 enabled interfaces of the selected device are displayed.

Alternatively, you can navigate to the device's Chassis View tab, select a card from the Chassis Explorer, click the
Configuration tab, and choose OTN > OTN Lines. This option enables you to configure additional parameters such
as enabling the sync messages, choosing the admin SSM, enable the Provide Sync parameter, and set the G709 value
to true or false.

Select the interface you want to edit, and click the Edit icon at the top right of the window.
Select the required FEC Mode. The default is None.
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Step 9

Step 10

(Cisco NCS 2000 devices only) Select the required SDBER value. Signal Degrade Bit Error Rate (SDBER) condition
indicates that a signal degrade alarm will occur for line degradation based on the threshold value that you set.

Click Save to save your changes.
A pop-up notification notifies you about the status of your changes.

Note If the Edit task fails, check if the interface is in Managed or Completed state and ensure that Cisco EPN
Manager is in sync with the device's configuration. You also need to ensure that G709 configuration is enabled
on the device. To change the admin state of the interface see, Change the Admin Status of an Optical Interface,
on page 56.

Enable and Disable GCC Connections

Step 1
Step 2
Step 3
Step 4

Step 5
Step 6
Step 7
Step 8

Step 9

Cisco EPN Manager supports the provisioning of Generic Communication Channel (GCC) connection on the
interfaces of optical devices. GCC can be configured on trunk ports of TXP or MXP cards and on OTN, OTU,
and ODU controllers. The GCC configuration can be modified irrespective of the FEC modes and admin
statuses configured on the interfaces.

To configure GCC on optical devices:

Choose Configuration > Network Devices. All Cisco EPN Manager devices are displayed.
Select the optical device that you want to configure by clicking the device name hyperlink.
Click the Configuration tab and choose Optical Interfaces > Provisioning.

Depending on your device type, choose one of the following:

« Comm Channels > GCC
«OTN>GCC

All configurable G709 enabled interfaces of the selected device are displayed.

Click the OTU Controllers or ODU Controllers tab based on the type of controller that you want to edit.
To edit the GCC configuration of any of the listed controllers, click the controller’s name hyperlink.
Click the Edit icon at the top right of the page.

Use the GCC check box to enable or disable GCC on the selected controller. The value configured on ODU controllers
is GCC1 and that on OTU controllers is GCCO.

Click Save. Your changes are saved and the updated configuration is deployed to the device.

To verify, view the GCC parameters for the selected controller under Optical Interfaces > Provisioning.

When GCC is enabled on a Cisco NCS device with 400G-XC trunk ports, Cisco EPN Manager discovers the
OUT link between the trunk ports.

Configure Squelch Mode

Using Cisco EPN Manager, you can configure different squelch modes on the interfaces of optical devices.
Squelch modes help shut down the far-end laser in response to certain defects. Squelch modes can be configured

. Configure Devices



| Configure Devices
Configure Squelch Mode and Hold Off Timer for NCS 1004 interfaces .

on OCH, OTN, SONET or SDH, FC or FICON, Ethernet, Video, and Data Storage interfaces of optical
devices.

Step 1 Choose Configuration > Network Devices.
Step 2 Click the device hyperlink to launch its Device Details page.
Step 3 Click the Configuration tab.
For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device

Details page.
Step 4 Choose Optical Interfaces > Provisioning > Squelch Mode.
Step 5 Choose the interface that that you want to configure by clicking the interface's name hyperlink.

The interface's name and current squelch mode setting are displayed.

Step 6 Click the Edit icon at the top right corner of the page.

Step 7 Select the required squelch mode for the interface. Your options are:

* DISABLE- Squelch is disabled.

* AIS- Alarm Indication Signal (AIS) is enabled.
* NONE- Transparent mode is enabled.

* SQUELCH- Squelch is enabled.

* ODU_AIS

* G_AIS- Generis AIS is enabled.

* NOS- Squelch is disabled in FC payloads.
*LF

Step 8 Click Save.

Your changes are saved and the updated configuration is deployed to the device. To verify, view the squelch mode
parameters of the selected interface under Optical Interfaces > Squelch Mode.

Configure Squelch Mode and Hold Off Timer for NCS 1004 interfaces

Squelch modes help shut down the far-end laser in response to certain defects. To configure squelch mode
and hold off time for NCS 1004 interfaces:

Step 1 Choose Configuration > Network Devices.

Step 2 Click the device hyperlink to launch its Device Details page.
Step 3 Click the Configuration tab and select the Ethernet tab.

Step 4 Select the interface that you want to edit and click the Edit icon.

The Edit Ethernet Controller window appears.

Step 5 Select a Squelch Mode from the drop down list.

Configure Devices .
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. Example: Change the Admin Status for Cisco NCS 2006 Interface

Step 6 Enter the Hold Off Timer.
The hold off time ranges from 0 to 3000 milliseconds.

Step 7 Click Apply.

Example: Change the Admin Status for Cisco NCS 2006 Interface

This example illustrates how to change the admin status for a Cisco NCS 2006 VLINE interface. In this
example, the configuration change is launched from the Device Details page, but under the Logical View tab.
(For other devices, configuration changes are performed under the Configuration tab.)

Step 1 On the Device Details page under the Logical View tab, click the hyperlink for the interface you want to edit.

M | ... / Device Management / Network Devices f Device Group / All Devices

Chassis Wiew Logical View Device Details

Admin Status

Features
_ Optical Controllers Ethernet Controllers
¥ (Optical Interfaces
P haint
AINENANCe Name Display Name Admin Status
¥ Provisioning ,
[ e
¥ OTN Lines
Adrminstatus O [ vunE-5-7-1-1-10 YLINE-5-7-1-1-10 up
Automatic Laser Shutdown (] WLME-5-7-1-1-11 YLINE-5-7-1-1-11 up
Comm Channels ] VLINE-5-7-1-1-2 VLINE-5-7-1-1-2 up
EemELM YLINE-5-7-1-1-3 YLINE-5-7-1-1-3 up
MNTP Settings
YUINE-5-7-1-1-6 YLINE-5-7-1-1-6 up
OTDR Autoscan i
WUINE-5-7-1-1-7 YLINE-5-7-1-1-7 up g
Payload by
Step 2 In the interface's Common Properties window, click the Edit icon at the top right corner of the window.
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| .../ Device Management / Network Devices / Device Group / All Devices
Chassis View Logical View Device Detalls
Features VLINE-5-7-1-1-10

Adrmin Status

) Common Properties A

¥ Optical Interfaces Name “LINE-5-7-1-1-10

P Maintenance
g Display Name “LINE-5-7-1-1-10
¥ Provisioning

P OTHM Lines
Admin Status UP

Adrminstatus

Automatic Laser Shutdown

414925

Comm Channels

Step 3 Choose a new setting from the Admin Status drop-down list, then click Save.

M .../ Device Management / Network Devices / Device Group [ All Devices

Chassis Wiew Logical View Device Details

Features VLINE-5-7-1-1-10
Admin Status

Commaon Froperties

oy

¥ Optical Interfaces Name

» Maintenance

¥ Pravisioning Rlglayiars
¥ OTH Lines Admin Status | ) A
Adminstatus up
Automatic Laser Shutcown DI
Cormm Channels TESTING I
5
Ethernet MTL g

Configure Devices Using the Chassis View

You can configure devices and cards from the devices' Chassis View. This can only be done from the
Configuration sub-tab in the Chassis View. The sub-tabs are displayed depending on the type of device you
select in the Network Devices page.

)

Note This feature is available only for Cisco NCS 2000 and Cisco ONS devices.
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Step 1
Step 2

Step 3
Step 4

Step 5
Step 6

Step 7
Step 8

Step 9

Step 10
Step 11

Step 12

e bk d Prograrmmeable
A | .../ Inventory Network Devices / Device Groups / All Devices / NCS2KE-234-252

Chassis View Logical Yiew Device Details

o

+ u NCSZKE-234-252 A @ @
NCSZKE-234-252

» General

» Network

» Security

» Internal.patchcord

v Alien.wavelength

From the left sidebar, choose Configuration > Network Devices.

Select the device that you want to configure by clicking the device's name hyperlink. The Chassis View tab for the
device appears.

In the right pane, click the Configuration sub-tab.

Expand the General area, and then enter the details of the device such as the node name, node alias, and select the
location where you want to provision the device.

Set up the synchronization time for the device to synchronize with its associated controllers. You can either use the
NTP/SNTP server time or set up a manual date and time for synchronization.

Check the Enable Manual Cooling check box to manually change the cooling profile of the device. The cooling profile
allows you to control the speed of the fans in the device’s shelf.

Click Apply. The changes in the settings are updated.

Expand the Network area, select the network setting you want to modify, and then click the edit icon at the top left of
the Network area. The Edit Network General Settings window appears.

Modify the required settings, and then click Apply.
Note You cannot modify the Node Address, Net/SubnetMask Length, Mask, and MAC Address of the device.

Configure security settings for a device. See Create and Manage Users and User Logins for a Device, on page 66.

Configure the origination (TX) and termination (RX) patchcords for a device. See Configure Patchcords for a Device,
on page 67.

Configure the alien wavelength for a device. See Configure GMPLS and WSON Properties, on page 77.

Create and Manage Users and User Logins for a Device

Step 1
Step 2

Step 3
Step 4

Use this procedure to create users and assign roles to manage a device. You can also view the list of users
who are accessing the device at a time.

From the left sidebar, choose Configuration > Network Devices.

Select the device that you want to configure by clicking the device's name hyperlink. The Chassis View tab for the device
appears.

In the right pane, click the Configuration sub-tab, and then expand the Security area.
In the Users tab, click the + icon to add a user.
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Step 5
Step 6

Step 7

Configure Patchcords for a Device .

Enter the user name.

From the Security Level drop-down list, choose one of the following options:

* Retriever—Users with this security level can view and retrieve information from the device, but cannot modify the
configuration.

* Maintenance—Users with this security level can retrieve information from the device and perform limited maintenance
operations such as card resets, Manual/Force/Lockout on cross-connects or in protection groups, and BLSR
maintenance.

* Provisioning—Users with this security level can perform all maintenance operations and provisioning actions except
those that are restricted to super users.

* Super User—Users with this security level can perform all provisioning user actions, plus creating and deleting user
security profiles, setting basic system parameters such as time, date, node name, and IP address, and doing database
backup and restoration.

Enter your password, and then click Save. The user is added to the Users table.

You can select a user to edit or delete the user. However, you cannot edit the user name. Moreover, you cannot
delete a user who has added the device to Cisco EPN Manager.

In the Security area, click the ActiveLogins tab to view the list of users who have logged in to the device
using CTC, TL1 session, or Cisco EPN Manager. You can choose to logout a user or multiple users when the
maximum login sessions for a device is reached.

Configure Patchcords for a Device

Step 1
Step 2

Step 3
Step 4
Step 5

The client card trunk ports and the DWDM filter ports can be located in different nodes or in the same
single-shelf or multi-shelf node. A virtual link is required between the client card trunk ports and the DWDM
filter ports. The internal patchcords provide virtual links between the two sides of a DWDM shelf, either in
single-shelf or multishelf node. The patchcords are bidirectional, however, each direction is managed as a
separate patchcord.

This feature is only supported on Cisco NCS 2000 and Cisco ONS devices.

This procedure explains how to configure internal patchcords using the Chassis View using ANS (automatic
node setup) for WDMs (wavelength division multiplexing). You can use the Chassis View to create and delete
these internal patchcords. To configure origination (TX) and termination (RX) patchcords for a device:

In the left sidebar, choose Configuration > Network Devices.

Select the device that you want to configure by clicking the device's name hyperlink. The Chassis View tab for the device
appears.

In the right pane, click the Configuration subtab, and then expand the Internal.patchcord area.
Click the + icon, and then choose the required origination (TX) and termination (RX) patchcords for the device.
Click Finish. The patchcords are added to the Internal Patchcords table.
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. External Patchcords

\)

Note Once you have created the patchcord, you cannot modify it. However, you can delete it.

You can select a patchcord or multiple patchcords in the Internal Patchcords table to view the direction of the
patchcords in the Chassis View of the device, which is displayed in the left pane (as shown in the figure
below).

alialie 7 O v .
e cisco e 49 root - ROOT-DOI

A .../ Device Groups / Device Type / Inventory Optical Networking / NCS2006- node3-19

Chassis View Logical View Device Details

RACK-1
n NCS2006-nede3-19 [ B &) mo
NCS2006-node3-19

Alarms Configuration Inventory Circuits Image Configuration Archive
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¥ Internal.patchcord
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+ snow | Al v |
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AD-16-FS ABDEGT4... (]  MF-UPG-4 PSHELF-1/PS..(7) N/A
MF-2MPO-ADP  PSHELF-1/PS...(;) MF-UPG4 PSHELF-/PS...(;) N/A
AD-16-FS. VABDEG14.._ (1) MF-UPG-4 PSHELF-1/PS..(7)  NIA
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External Patchcords

External patch cords are required when the transponders or ITU-T line cards are installed in a device that does
not house the OCH filter ports. You can configure the external patch cords using only the NCS 2000 Cisco
Transport Controller. These patch cords then appear in the EPN Manager as OTS links.

This feature is only supported on Cisco NCS 2000 and Cisco ONS devices.

The following procedure explains how to view external patchcords using the Chassis View:

Step 1 In the left sidebar, choose Configuration > Network Devices.
Step 2 Select the device that you want to configure by clicking the device name's hyperlink. The Chassis View tab for the device
appears.

Step 3 In the right pane, click the Configuration subtab, and then expand the Maintenance area.
Step 4 Click the External Patchcords subtab.

Configure a Protection Group for a Shelf in a Device

Use this procedure to create a protection group for a shelf in a device.

. Configure Devices
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Note  You cannot configure a protection group for a rack.

Before you begin
Following are the prerequisites before creating a protection group for a shelf:

* To create a Y Cable protection group, ensure that two cards of the same type that are configured with
client ports are plugged in to the same shelf.

* To create a Splitter protection group, ensure that at least one OTU2XP card that is configured with trunk
port 3-1 and trunk 4-1, is plugged in to the shelf.

Step 1 From the left sidebar, choose Configuration > Network Devices.

Step 2 Select the device that you want to configure by clicking the device's name hyperlink. The Chassis View tab for the
device appears.

Step 3 Expand the Chassis View Explorer, and then select the shelf for which you want to configure the protection group.

Step 4 In the right pane, click the Configuration sub-tab, and then expand the Protection area.

Step 5 Click the + icon to open the Create Protection Group window.

Step 6 From the Type drop-down list, choose one of the following protection type:

* Splitter—This protection type is applicable only when a MXPP/TXPP card is used. These cards provides splitter
(line-level) protection (trunk protection typically on TXPP or MXPP transponder cards).

* Y Cable—This protection type is applicable only when two transponder or two muxponder cards that are configured
with client ports, are plugged in to the same shelf in a device.

Step 7 Choose a protect port and a working port for the shelf.

Note You will be able to select these ports only if you have completed the prerequisites listed at the beginning of
this procedure.

Step 8 Choose if the protection type is unidirectional or bidirectional. In the bidirectional mode, a failure on a active interface
triggers a switchover of the traffic from the active interface to the protecting/backup interface.

Step 9 Click the Revertive toggle radio button to revert the shelf from the protected port to the original port after the failure
is fixed.

Step 10 Choose the hold off time in milliseconds. Hold off time is the period that the shelf on the protected port must wait

before switching to the original port after the failure is fixed. The shelf can revert to the original port after the hold time
expires. The minimum value of hold off time must be 0.5.

Step 11 Click Apply. The protection group is added to the Protection table.

Configure Line Card Operating Mode

To configure the NCS1K4-OTN-XP card operating mode for NCS 1004 devices and to activate or deactivate
a line card:
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Configure Devices |
. Configure Slices

Step 1 Launch the Chassis View as described in Open the Chassis View.

Step 2 Click the Configuration tab from the window displayed on the right.

Step 3 Expand the Line Card Operating Mode sub-tab.

Step 4 To edit the line card operating mode, select the card operating mode and click Edit.

Step 5 Select the Card Operating Mode from the drop-down list and assign the desired action to it from the Action drop-down
list.

Step 6 Click Apply to deploy the changes.

Configure Slices

Using Cisco EPN Manager you can configure the slice by controlling the bitrate on the client and trunk ports
and by configuring the FEC and encryption types for each slice.

You must configure the five client ports of the slice at the same bitrate. Also, ensure that both trunk ports are
always set to the same FEC mode.

\)

Note Slice configuration is currently only supported for Cisco NCS 1002 and NCS 1004 devices.

Configure Slices for NCS 1002 Devices

To configure the slice for Cisco NCS 1002 device:

Step 1 Launch the Chassis View as described in Open the Chassis View.

Step 2 Click the Configuration tab from the window displayed on the right.

Step 3 Expand the Slice Configuration sub-tab.

Step 4 To add new slice configuration, click the + (Add) button and specify the following details:

Slice Configuration | Descriptions

Parameters

Slice Number Numerical value that represents the Slice ID. You can create only one set of configuration per
slice.

Client Bitrate Total number of bits per second (in gigabits per second) to be configured on the client ports
of the slice.

Trunk Bitrate Total number of bits per second (in gigabits per second) to be configured on the trunk ports
of the slice.

FEC FEC value to be set on the trunk ports.
Before changing the FEC mode setting, ensure that the admin state of the interface you are
trying to modify is in Down (out of service) state with G709 configuration enabled.

Encryption Configures the slice to function with encrypted or unencrypted traffic.
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Step 5 Click Apply to deploy the changes to the device immediately.

You can add only one set of parameters per slice and not all parameters are editable once saved. To edit the parameters,
delete the configuration for the slice and add it again.

Note The slice configuration cannot be deleted if the admin state is UP.

Configure Slices for NCS 1004 Devices
To configure the slice for NCS1004 devices:

Step 1 Launch the Chassis View as described in Open the Chassis View.
Step 2 From the Chassis Explorer, select the slot that you want to configure.
Step 3 Click the Configuration tab from the window displayed on the right.
Step 4 Expand the Slice Configuration sub-tab.

Step 5 From the Card Mode drop-down list select the applicable option.

The available options are Slice Mode, Muxponder Mode, and Regen Mode.

Step 6 To add new slice configuration, click the + (Add) button and specify the following details:

Slice Configuration Descriptions

Parameters

Slice Number Numerical value that represents the Slice ID. This value cannot be changed for NCS 1004
devices.

Client Bitrate Total number of bits per second (in gigabits per second) to be configured on the client ports
of the slice. The options available to select from are 100GE and OTU4. 100GE is applicable
for both Slice Mode and Muxponder Mode. OTU4 is only applicable for Muxponder Mode.

Trunk Bitrate Total number of bits per second (in gigabits per second) to be configured on the trunk ports
of the slice.

Note When in Regen Mode the Trunk Bitrate is only applicable for configuration.

Step 7 Click Apply to deploy the changes to the device immediately.

You can add only one set of parameters per slice and not all parameters are editable once saved. To edit the parameters,
delete the configuration for the slice and add it again.

Note The slice configuration cannot be deleted if the admin state is UP.

Configure Interfaces from the Device Details Page

Complete the following procedure to configure an interface from the Device Details page:
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. Update Cisco NCS 1000 Interface Settings

Step 1

Step 2
Step 3
Step 4

With a device’s Chassis View open, click the Launch Configuration link.

The Device Details page opens.

Click the Logical View tab.
From the Features pane, choose Interfaces > the interface type you want to configure.

Complete the instructions specific to the interface type you chose to add or edit an interface (see Configure Interfaces,
on page 37).

Update Cisco NCS 1000 Interface Settings

Step 1

Step 2

Step 3
Step 4

You can quickly update the Admin Status, Wavelength (nm), and Loopback settings for interfaces configured
on a Cisco NCS 1000 Series device from its Device Details page. To do so, complete the following procedure.

Open the Device Details page for a Cisco NCS 1000 Series device, as described in Get Complete Device Information:
Device Details Page.

Click the Configuration tab.
The page updates, displaying 3 sub-tabs: Optics, Ethernet, and Coherent DSP.

Click the sub-tab for the interface type you want to update.

Make the necessary changes:

Method 1

a. In the interfaces table, locate the interface you want to update.

b. Click the parameter you want to change to open a drop-down list.

c. Choose the value you want to set, then click Save.

Method 2
a. Click the radio button for the interface you want to update, then click the pencil (Edit) icon.
The Edit interface type dialog box opens.

b. Choose the value you want to set from the available drop-down lists, then click Apply.

c. Click OK to confirm your changes.

Note the following:
* For Optics interfaces:
* You can update the Admin Status and Wavelength (nm) parameters.

* You can only set a new wavelength value if the Optics Type parameter is set to DWDM.

* For Coherent DSP and Ethernet interfaces:

* You can update the Admin Status and Loopback parameters.

* You can only set a new loopback value if the Admin Status parameter is set to Testing.
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Configure Controllers (Optics, 0TS, OCH, DSP, and DWDM) .

* If you set the Loopback parameter to Line, Cisco EPN Manager applies the same configuration applied for a
facility loopback. A facility loopback tests the line interface unit (LIU) of a card, the electrical interface assembly
(EIA), and related cabling.

* If you set the Loopback parameter to Internal, Cisco EPN Manager applies the same configuration applied
for a terminal loopback.

Configure Controllers (Optics, OTS, OCH, DSP, and DWDM)

Step 1
Step 2
Step 3
Step 4

Step 5
Step 6

Step 7

Step 8

Using Cisco EPN Manager, you can configure optical device controller parameters such as the wavelength,
FEC, SD, and SF BER reporting and thresholds, and more for controllers of type OTS, OTS OCH, DWDM,
and more.

The Optical Transport Section (OTS) controller holds all the optical parameters for the OTS optical interfaces.
The optical interface has different capabilities depending on its hardware components such as VOA and
amplifier. Hence, the parameters that are enabled or disabled on the OTS controller depend on the actual
hardware capability on the specific optical interface. You can configure parameters such as amplifier gain
range, amplifier tilt, and optical safety remote interlock (OSRI) for the OTS controller.

The Optical Transport Section OCH (OTS OCH) controller represents the OCM device available on the OTS
optical interface. This controller has channel granularity over the OTS interface. The OTS OCH controller
contains the wavelength information. You can configure only the admin status for the OTS OCH controller.

To ensure that you complete the slice configuration before configuring the controllers, see, Configure Slices
for NCS 1002 Devices, on page 70.

To configure the optical controller parameters:

Launch the Chassis View as described in Open the Chassis View.
Click the Configuration tab from the window displayed on the right.
Expand the Controllers sub-tab. Depending on your device selection, supported tabs are displayed.

To edit the configuration on optical controllers, click Optics, choose the required settings, and click the modify icon
to make your changes.

To edit the configuration on OTS controllers, click OTS, choose the required settings, and click the modify icon to
make your changes.

To edit the configuration on OTS-OCH controllers, click Ots-Och, choose the required settings, and click the modify
icon to make your changes.

To configure coherent DSPs, click Coherent DSPs, choose the required settings, and click the modify icon to make
your changes.

Note You cannot edit any parameter when the transport admin status is set to IS.

To edit the configuration on DWDM controllers, click DWDM, choose the required settings, and click the modify icon
to make your changes.

Category Parameters Description
Common * Name Name- (Display only) Displays the port number.
Optics,
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Category Parameters Description

OTS-OCH, * Admin Status Admin Status-Defines whether the interface is managed (Up), down, or in

DSP, and . maintenance mode. You cannot modify the controller properties when the

DWDM * Operational status of the interface is Up.

Controller Status . . . . .

Parameters | Operational Status — Defines whether the interface is operational and is

* Transport Admin | yerforming as provisioned.
Status

Transport Admin Status — Defines the transport administration state of the
controller.

Common Actual Wavelength Displays the actual wavelength utilized by the channel.

Optics and (nm)

DWDM

Parameters

- Wavelength (nm) Displays the wavelength value configured on the channel. Once the device
Inventory Collection status is completed, the Actual Wavelength and
Wavelength values will match.

- FEC Mode FEC value to be set on the controllers.
Before changing the FEC mode setting, ensure that the admin state of the
interface you are trying to modify is in Down (out of service) state with G709
configuration enabled.

Optics Speed Set the speed values (in gigabits per second) that the controllers must operate

Parameters on.

- DAC Rate Select the DAC rate from the drop-down list.

Min Chromatic
Dispersion

Enter the minimum chromatic dispersion value.

Max Chromatic
Dispersion

Enter the maximum chromatic dispersion value.

Configured Tx Power

Enter the transmit power.

- Modulation Type Set the modulation type from the drop-down list.

- Differential Enable or disable Differential Encoding (DE) based on the configured speed
Modulation values.

- Loopback Configure the loopback as:

* Internal - All packets are looped back internally within the router before
reaching an external interface. It tests the internal Rx to Tx path and
stops the traffic to egress out from the Physical port.

* Line - Incoming network packets are looped back through the external
interface.

- SD BER Set the signal degrade bit error rate. Your options are E-5, E-6, E-7, E-§, or
E-9.
- SF BER Set the signal fail bit error rate. Your options are E-3, E-4, or E-5.
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Category Parameters Description

DWDM Loopback Configure the loopback as:

Parameters * Internal - All packets are looped back internally within the router before
reaching an external interface. It tests the internal Rx to Tx path and
stops the traffic to egress out from the Physical port.

* Line - Incoming network packets are looped back through the external
interface.
- * OTU-SD Configure SF (signal fail) and SD (signal degrade) BER reporting and
thresholds.
* OTU-SF
Depending on whether the alarm is an OTU or ODU alarm, the alarm
* ODU-SD represents that SM BER is in excess based on the SD BER threshold or SF
« ODU-SF BER threshold.
OTS Port Role Current operational state of the port.
Parameters In case of a protection switch, the Com work role is displayed, whereas, in
case of an amplifier module, the Com Line/Osc or Com Check role is
displayed.
- Rx/Tx Low Threshold | Configures the receiver/transponder low receive power threshold. The valid
(dBm) range is from -500 to 300.

- Ampli Channel Power | Configures the amplifier per channel power set point. The valid range is -500
(dBm) to 300. The default value is 0.0.

- Channel Power Max | Configures the maximum difference among all the measured channel powers.
Delta (dBm) The valid range is from 0 to 200.

- Ampli Gain and Ampli | Configures the amplifier gain set point. The valid mode for the range is normal
Gain Range or extended.

Note The amplifier gain range is configurable only when the controller
is in shutdown state.
- Ampli Safety Configures the safety control mode as auto or disabled.
Controller Mode

- OSRI Configures the optical safety remote interlock as on or off.

- Ampli Tilt Configures the amplifier tilt using a number between -50 to +50.

Note The values you see in IOS-XR (RON) optical controller edit screen, is the running configuration on the device.

When Not Set is selected for Optics Controller DAC Rate, FEC and Modulation Type attributes, EPNM
removes the existing configuration from device and it shows the operational value of those attributes on the
user interface once GI completes.

Step 9

Click Apply to deploy your changes to the device immediately.
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Step 10

(Optional) To change the unit of the DWDM grid value to either wavelength or frequency, go to Administrator >
Settings > System Settings > Circuits/VCs Display, and under the DWDM Grid Unit area, choose either Wavelength
(Nanometer (nm)) or Frequency (Tatrahertx (THz)).

Configure Passive Units

Step 1
Step 2
Step 3
Step 4

Step 5
Step 6

Step 7
Step 8

Step 9

Passive units are passive cards provisioned using Cisco EPN Manager for optical devices. Cisco EPN Manager
maintains these passive units in its database and does not deploy them to devices. Once configured, you can
view these passive units in the Device Details and Inventory pages and use them to create managed links in

the Network Topology.

)

Note Passive Unit configuration is currently only supported for Cisco NCS 1001 device.

To add and delete passive units:

Before you begin

Ensure that you have either 'Administrator’ or 'Config Manager' user privilege before you perform this task.

Launch the Chassis View as described in Open the Chassis View.

Click the Configuration tab from the window displayed on the right.
Expand the Passive Units sub-tab.

To add a passive unit click the Add (+) icon and specify the following details:

* Equipment ID: Choose the unique identifier for the passive unit. You can add up to 9 passive units per device.

» Equipment Type: Choose the equipment type that determines if the slot is provisioned as a 48-channel
muxponder/demuxponder or as an odd/even unit. Your options are CME, ODDE, and EVENE.

* (Optional) Serial Number: Serial number that is unique to each passive unit. Cisco EPN Manager does not deploy
this configuration to the device and maintains it only in its database.

Click Apply to deploy your changes to the device.

(Optional) To verify successful creation of the passive units, navigate to the Interfaces tab or to the Device Details tab
and use the Interface Name filter to locate the passive units.

The naming convention used for the passive units is:

PUnit<number of the card> <equipment ID of the passive unit>
For example, PUnit/1/16.

To edit the configuration of the passive units delete them and configure the details again using the same equipment ID.

To delete the passive units, select the required passive unit and click the Delete (X) icon. Passive units associated with
links can also be deleted. This causes the links to switch to the Partial state.

(Optional) To match multiple passive units with same values, select the required passive unit and click Match. Select
the simulated passive unit number from the dropdown list and click Apply.
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Step 10

Edit Amplifier Module Settings on Optical Cards .

(Optional) To configure manual links using these passive ports, navigate to the network topology and create the links
as described in Manually Add Links to the Topology Map.

Edit Amplifier Module Settings on Optical Cards

Step 1
Step 2
Step 3
Step 4

Step 5
Step 6

You can modify the settings of amplifier modules inserted in optical slots of your device by changing the grid
modes, node types, and UDC Vlan settings.

To edit the amplifier module settings:

Before you begin

Ensure that you have either 'Administrator’ or 'Config Manager' user privilege before you perform this task.

Launch the Chassis View as described in Open the Chassis View.
Click the Configuration tab from the window displayed on the right.
Expand the Amplifier Module Settings sub-tab.

Select the settings that you want to edit, click the Edit icon, and specify the following parameters:
* Grid Mode: Defines the optical spectrum on the interfaces of the amplifier module.

* Node Type: Defines the type of the node in which the amplifier is set to work. Your options are: Terminal, Line,
and Not Set.

* Udc Vlan: Defines the VLAN associated to the selected slot and its UDC port.

Note Ensure that the Udc Vlan that you specify is unique on the device. Duplicate values are not supported.

Click Apply to deploy your changes to the device.

(Optional) To configure the Ethernet Controllers, expand the Ethernet sub-tab. Select the controller that you want to
edit, click the Edit icon, and make the required changes. Click Apply to save the changes to the device.

Configure GMPLS and WSON Properties

GMPLS UNIs:

The Generalized Multiprotocol Label Switching (GMPLS) User Network Interface (UNI) creates a circuit
connection between two clients (UNI-C) of an optical network. This connection is achieved by signal exchanges
between UNI Client (UNI-C) and UNI Network (UNI-N) nodes, where UNI-C nodes are router nodes and
UNI-N nodes are optical nodes.

GMPLS UNI is supported only on the 100G and 200G trunk ports of the Cisco NCS 1002 node. The prerequisite
for the OCH trail circuit is to create a Link Management Protocol (LMP) link between the optical channel
Add/Drop NCS 2000 series interface on the NCS 2000 series node and the NCS 1002 interface on the NCS
1002 node.

UNI is divided into client (UNI-C) and network (UNI-N) roles. A UNI-C network element requests and accepts
the circuit provisioning information. A UNI-N network element is the node that is adjacent to the UNI-C node
and accepts and transports circuit provisioning information across the core network.

Configure Devices .
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For UNI circuit provisioning, the network must meet the following requirements:

* An NE must be configured in as UNI-C and connected to a UNI-N NE.
* An NE must be configured as UNI-N and connected to a UNI-C NE.

Static UNIs:

Link Management Protocol (LMP) is a logical link that is created on the trunk optics controller on the source
and destination nodes of the tunnel. You can create static LMP links (Static UNIs) between the ports of two
different devices. For example, between a Cisco NCS 2000 series node and a Cisco NCS 1002 node. This
helps to configure an LMP neighbor for a GMPLS UNI tunnel.

While configuring a Static UNI using Cisco EPN Manager, choose the RX Port and TX Port, and identify the
card, shelf, or slot that you want to engage in the UNI. While the RX Port represents the source for the UNI,
the TX Port represents the destination.

Use the Remote Device field to specify the management IP address of the selected node. Use the Remote
Client Interface field to choose the LMP link IP address of the optics controller.

Alien Wavelength:

Use the Alien Wavelength tab to view and configure the port and wavelength parameters of the alien
wavelength. You can also specify the required alien wavelength type, trunk mode, and the forward error
correction (FEC) mode.

Fiber Attributes:

You can configure the parameters that are used during the creation of the GMPLS UNI by configuring values
such as the fiber type (by choosing Dispersion-Shifted (DS), True-Wave Classic (TWC), or other values).
You can also specify the fiber length and specify the Polarization Mode Dispersion fiber coefficient.

The Attenuator In value identifies the input optical attenuation in dB between the node output port (for example,
a LINE-TX port) and the input parameter of the fiber. Similarly, the Attenuator Out value identifies the same
between the node input port (for example, a LINE-RX port) and the output parameter of the fiber.

You can choose the Channel Spacing value that configures the minimum frequency spacing between two
adjacent channels in the optical grid. To specify the maximum number of channels that are expected on the
span use the Channel Number field, ensure that the channel number and channel spacing values are consistent.
For example, there cannot be 80 channels with 100-GHz spacing.

Virtual Trunk:
LMP Termination:

You can use the LMP Termination tab to specify the Virtual Trunk, LMP Type, Remote Device, Remote
Interface, and Peering for a device. You can also edit the existing LMP Terminations in the LMP Termination
tab.

To configure GMPLS/WSON parameters:

Step 1 Launch the Chassis View as described in Open the Chassis View.
Step 2 Click the Configuration tab from the window that is displayed on the right.

Step 3 To configure these parameters, navigate to the paths described in the table below:
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Step 4
Step 5

Configure GMPLS and WSON Properties .

Task Navigation Description

Configure fiber | GMPLS/WSON sub-tab | Specify the fiber side, type, length, validation, channel spacing, channel

attributes > Fiber Attributes number, and domain values. You can also specify the attenuator (in and out)
values (optional).

Create and edit | GMPLS/WSON sub-tab * Add the RX and TX port remote controllers that must participate in the

static UNIs > Static UNIs UNI.

» The Remote Device field specifies the management IP address of the
node.

» The Remote Client Interface field specifies the link IP address of the
controller.

Note You can configure a remote TXP node using the above settings.
Create and edit | GMPLS/WSON sub-tab * Specify the ingress and egress ports for the GMPLS UNI and choose if
GMPLS UNIs |> GMPLS UNIs the UNI is of numbered or unnumbered type. Ensure that you specify if
the UNI is of type UNI-C or UNI-N.

* The trunk values are automatically configured to the respective alien
wavelength values depending on your GMPLS UNI configuration. If the
configured alien wavelength is supported on both trunk ports, then setting
it on one of the trunk ports automatically configures the same alien
wavelength on both trunk ports.

* For Cisco NCS 2000 devices, the GMPLS UNI trunk value can be set
to Default.

* Specify the local and remote interface IP, and remote system IP and
controller. These values enable the remote system connection for the
UNL
Note You can only specify remote system IPs of devices that are

managed by Cisco EPN Manager.
Configure GMPLS/WSON sub-tab | Specify the required alien wavelength type, trunk mode, and the FEC mode.
Alien > Alien Wavelength
Wavelength
parameters
Configure and | GMPLS/WSON sub-tab | Specify the Virtual Trunk, LMP Type, Remote Device, Remote Interface,

Edit LMP > LMP Termination and Peering.
Termination
Note For a Not-Signaled LMP, the commands will be pushed only on the local device. You have to push the

configuration either manually or using a configuration template to the remote device.

Make your changes and click Save.

To edit the values once configured, select the values and click the Edit icon in the toolbar. Make your changes and click

Save.
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For information on LMP link creation, see, Optical Channel (OCH) Trail User-to-Network Interface (UNI).

Enable or Disable Optical Safety Remote Interlock (OSRI) on OTS Ports

You can modify the optical safety remote interlock (OSRI) status for the configured ports on OTS interfaces.
To enable or disable OSRI:

Before you begin

Ensure that you have either 'Administrator’ or 'Config Manager' user privilege before you perform this task.

Step 1 Launch the Chassis View as described in Open the Chassis View.

Step 2 Click the Configuration tab from the window displayed on the right.

Step 3 Expand the Maintenance tab and click the OSRI sub tab.

Step 4 Select the port for which you want to enable or disable the OSRI.

Step 5 From the drop-down list, select Enable or Disable to enable or disable the OSRI.

Configure Optical Cards

* Configure Cards from the Chassis View, on page 80
* Reset a Card, on page 82
* Delete a Card, on page 81

* Configure cards: 400G-XP-LC, 100G-CK-C, 100ME-CK-C, 200G-CK-LC, 100GS-CK-C, 100G-LC-C,
100G-ME-C, and 10x10G-LC, on page 83

* Configure cards: OTU2-XP, MR-MXP, WSE, AR-XPE, AR-XP, AR-MXP, 40E-MXP-C, and
40ME-MXP-C, on page 82

* Configure SONET and Flex Line Cards, on page 86
* Edit and Delete Pluggable Port Modules and Card Mode Configuration, on page 89

* Cards and Supported Configuration for Cisco NCS 2000 Devices, on page 90

Configure Cards from the Chassis View

This procedure adds a card to Cisco EPN Manager using the Chassis View. After adding the card, you can
configure it by following the procedure in the relevant topic for that card type. Normally this is done before
you physically add the card to the slot.

Before you begin

This feature is only supported on Cisco NCS 2000 and Cisco ONS devices.
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Step 1
Step 2

Step 3
Step 4

Delete a Card .

Launch the Chassis View as described in Open the Chassis View.
Select the slot to which you want to add the card by doing one of the follow:

» Select the empty slot from the physical Chassis View, then click the Add Card link in the slot pop-up window.

Hi"

+ Use the Chassis View explorer to navigate to the empty slot, hover your mouse cursor over the "i" icon next to the

slot, then click the Add Card hyperlink in the informational popup window.

Cisco EPN Manager highlights the slot in the physical Chassis View (indicating it is pre-provisioned) and lists all of the
cards that are supported by that device type.

Note Make sure the card you select is appropriate for the physical slot type.

Locate the card you want to add, then click Add. Cisco EPN Manager displays a status message after the card is added.
If you want to configure the card right away, click Configure Now in the status popup message. Otherwise, click Ignore.

Delete a Card

Step 1
Step 2

When you delete a card, Cisco EPN Manager removes all information about the card including the card
operating mode configuration associated with the card. When you add this card again at a later point of time,
this information is not restored.

This feature is only supported on Cisco NCS 2000 and Cisco ONS devices.
To delete a card from Cisco EPN Manager:

Before you begin
Before you delete a card, make sure that:

* The associated payload values and card operating modes are deleted.

* The card does not have any active configuration running on the card (you will not able to restore the
configuration when you re-add the card).

Launch the Chassis View as described in Open the Chassis View.
Select the slot from which you want to delete the card by doing one of the follow:
» Select the card in the slot from the physical Chassis View, then click the Delete Card link in the pop-up window.

"i"

* Use the Chassis View explorer to navigate to the card, hover your mouse cursor over the "i" icon next to the card,

then click the Delete Card hyperlink in the popup window.

Cisco EPN Manager highlights the slot in the physical Chassis View (indicating it is pre-provisioned) and once you delete
all cards of a slot, the slot is left blank in the Chassis View.

After you delete a card, Cisco EPN Manager performs an inventory collection for the node.

Configure Devices .


bk-cisco-evolved-programmable-manager-5-0-1-user-and-administrator-guide_chapter3.pdf#nameddest=unique_137
bk-cisco-evolved-programmable-manager-5-0-1-user-and-administrator-guide_chapter3.pdf#nameddest=unique_137

Configure Devices |
. Reset a Card

Reset a Card

Resetting a card repositions the card in the chassis, which is similar to performing a sync operation. Cisco
EPN Manager does not modify any configuration changes, and instead saves the settings and triggers an
inventory collection.

This feature is only supported on Cisco NCS 2000 and Cisco ONS devices.

To reset a configured card:

Step 1 Launch the Chassis View as described in Open the Chassis View.

Step 2 Select the slot from which you want to delete the card by doing one of the follow:
» Select the card in the slot from the physical Chassis View, then click the Reset Card link in the pop-up window.
Hi"

* Use the Chassis View explorer to navigate to the card, hover your mouse cursor over the "i" icon next to the card,

then click the Reset Card hyperlink in the popup window.

Cisco EPN Manager highlights the slot in the physical Chassis View (indicating it is pre-provisioned). After you reset
the card, a sync is performed and inventory collection is triggered.

What to do next

Configure the properties of the card as described in Configure cards: 400G-XP-LC, 100G-CK-C, 100ME-CK-C,
200G-CK-LC, 100GS-CK-C, 100G-LC-C, 100G-ME-C, and 10x10G-LC, on page 83.

Configure cards: 0TU2-XP, MR-MXP, WSE, AR-XPE, AR-XP, AR-MXP,
40E-MXP-C, and 40ME-MXP-C

To configure card operating modes and Pluggable Port Modules (PPMs):

Before you begin

OTU2-XP and 40E-MXP-C cards can be configured with PPM directly without having to set the card operating
mode. However, if you want to configure card operating modes for other cards you can perform this
configuration directly via Cisco Transport Controller.

* Ensure that the device sync is complete and that the device's inventory collection status is 'Managed' or
'Completed'.

* Every time you add or delete a PPM, reactive inventory collection is triggered, and the device begins the
sync process. Ensure that you wait for reactive inventory collection to complete before you deploy further
configuration changes to the device. When the device sync is in progress, the deploy of PPM configuration
changes to the device will fail.

* Once the card operating modes are configured, ensure that the device sync is completed. If not, Cisco
EPN Manager will not be able to display the right Payload values for the selected cards.

* Ensure that granular inventory is enabled for all cards before performing any configuration changes on
the cards.
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Step 1
Step 2

Step 3
Step 4
Step 5

Step 6
Step 7
Step 8

Step 9

Step 10

Step 11
Step 12

Configure cards: 400G-XP-LC, 100G-CK-C, 100ME-CK-C, 200G-CK-LC, 100GS-CK-C, 100G-LC-C, 100G-ME-C, and 10x10G-LC .

* For all supported cards except 40E-MXP-C, 40ME-MXP-C, and OTU2-XP cards, you must first configure
the card operating modes using Cisco Transport Controller and then return to Cisco EPN Manager to
proceed with the following steps.

Choose Configuration > Network Devices.

Select the device that you want to configure by clicking the device's Name hyperlink to launch the device's Chassis
view. This feature is supported only on Cisco NCS 2000 devices.

Use the Chassis Explorer to select the card that you want to configure.

Click the Configuration sub-tab from the window displayed on the right.

Navigate to the CTC tool and configure the operating modes for the cards. Card mode configuration is not supported
on: OTU2-XP, MR-MXP, WSE, AR-XPE, AR-XP, and AR-MXP cards. For all other cards on Cisco NCS 2000 devices,
configure card operating modes as described in Configure cards: 400G-XP-LC, 100G-CK-C, 100ME-CK-C,
200G-CK-LC, 100GS-CK-C, 100G-LC-C, 100G-ME-C, and 10x10G-LC, on page 83.

Expand the Pluggable Port Modules section to configure port modules and their respective payload values.

Click the '+' (Add) icon in the Port Modules section to create port modules (PPMs).

Select the PPM number and then click Save. The PPM port is set to PPM (1 port) by default and cannot be modified.

Note The '+' (Add) button is disabled when the maximum number of PPMs for the selected card are created. You
must create all available ports before you can continue to the next step.

Click the '+' (Add) icon in the Pluggable Port Modules section.

Note For some PPMs, the respective payload values may not be enabled. To enable it, complete the card mode
configuration described in Step 5 above, and then try to re-configure the payload values.

Choose the port number, port type, and number of lanes that must be associated with the selected PPM. The Port
Type (payload) can be set to any supported client signals described in Table 2 below.

Note If the specified Port Type (payload) is not supported for the selected card operating mode or PPM, then the
changes are not deployed to the device successfully. Ensure that the Payload values you specify, are supported
on the selected card. See Table 2 below for reference.

Click Finish to deploy your changes to the device.

(Optional) If your changes are not visible in the Cisco EPN Manager, it could be because more than one person is
working on the same card mode configuration and the changes are not reflected dynamically. Click the Refresh icon
within each section to view the most recent changes.

If you encounter a deploy failure, navigate to the error logs folder /opt/CSCOIlumos/logs/config.log for more details
about the cause of the error.

Configure cards: 400G-XP-LC, 100G-CK-C, 100ME-CK-C, 200G-CK-LC,
100GS-CK-C, 100G-LC-C, 100G-ME-C, and 10x10G-LC

To configure card operating modes and PPMs:
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. Configure cards: 400G-XP-LC, 100G-CK-C, 100ME-CK-C, 200G-CK-LC, 100GS-CK-C, 100G-LC-C, 100G-ME-C, and 10x10G-LC

Step 1
Step 2

Step 3
Step 4
Step 5
Step 6

Step 7
Step 8

Step 9

Before you begin

* Ensure that the device sync is complete and that the device's inventory collection status is 'Completed'.
If the device sync is on, then the deploy of PPM configuration changes will fail.

* Card mode configuration is not supported on: OTU2-XP, MR-MXP, WSE, AR-XPE, AR-XP, and
AR-MXP cards. To configure the card operating modes on these cards, please use the Cisco Transport
Controller tool.

* Ensure that the device sync is complete and that the device's inventory collection status is 'Managed' or
'Completed'.

* Ensure that granular inventory is enabled for all cards before performing any configuration changes on
the cards.

* By default, device throttling is not enabled. To enable device throttling, navigate to cd
/opt/CSCOlumos/xmp_inventory/xde-home/inventoryDefaults and execute vi
onsTL1.def and add the following xml tag:

<default attribute="DEVICE_THROTTLING">noOfconnections</default>
Here, noOfconnections is number of the max TL1 session to the EPNM.

For example: <default attribute="DEVICE_ THROTTLING">6</default>

Choose Configuration > Network Devices.

Select the device that you want to configure by clicking the device's Name hyperlink to launch the device's Chassis
view.

Use the Chassis Explorer to select the card that you want to configure.
Click the Configuration sub-tab from the window displayed on the right.
Expand the Pluggable Port Modules section to configure port modules and their respective payload values.

Click the '+' (Add) icon in the Port Modules section to create port modules (PPMs). Select the PPM number and then
click Save. The PPM Port value is set to PPM (1 port) by default and cannot be modified.

Note * The '+' (Add) button is disabled when the maximum number of PPMs applicable for the selected card
are created. You must create the required number of PPMs for the selected card before proceeding to
the next step. For 100G-CK-C cards, you only need to create at least one PPM before proceeding to the
next step.

* For 400G-XP-LC cards, ensure that the PPMs 11 and 12 are created before configuring the card operating
modes described in the next step (although the card mode is being created for either of the trunk ports).
Without PPMs 11 and 12, the configuration changes deployed to the device will fail.

* This step is optional for 100G-LC-C, 100G-ME-C, 100G-CK-C, I00ME-CK-C, 200G-CK-LC, and
100GS-CK-C cards.

Expand the Card Operating Modes section to configure operating modes for the selected card.

Click the '+' (Add) icon to display a list of supported card operating modes or click the Edit icon to modify existing
card operating modes. For 10x10G-LC cards you can add up to 5 card operating modes (10 ports that can act as sets
of client or trunk ports), whereas for all other cards, only a single card operating mode can be set, after which, the +
(Add) button is disabled.

Select an operating mode from the panel on the left and make your changes to the parameters.
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Step 10
Step 11
Step 12

Configure cards: 400G-XP-LC, 100G-CK-C, 100ME-CK-C, 200G-CK-LC, 100GS-CK-C, 100G-LC-C, 100G-ME-C, and 10x10G-LC .

Note * Some card operating modes are disabled based on the card's peer configuration. Click on the 'i' icon next
to the operating modes to understand how they can be enabled. See Table 1 below to understand the
peer card configuration required to enable these operating modes.

* For MXP cards, ensure that the trunk, peer, and peer skip card configuration is in the order described

below:

Card Operating Modes | Trunk Card Peer Card Peer Skip Card

MXP_ 200G Slot 2 Slot 3 Slot 4

MXP 200G on ONS 100GS-CK-LC or Slots 3, 4 or 5, 6. Slots 3,4 or 5, 6.

15454 M6 devices 200G-CK-LC card in
slots 2 or 7.

MXP 200G on Cisco 100GS-CK-LC or MR-MXP cards in MR-MXP cards in

NCS 2015 devices 200G-CK-LC card in adjacent slots. adjacent slots.
slots 2, 7, 8, 13, or 14.

MXP 10x10G_100G Slot 7 Slot 6 Slot 5

MXP 10x10G_100G on | 100GS-CK-LC or MR-MXP cards in MR-MXP cards in

ONS 15454 M6 devices |200G-CK-LC card in adjacent slots 3,4 or 5, 6. | adjacent slots 3,4 or 5, 6.
slots 2 or 7

MXP 10x10G_100G on | 100GS-CK-LC or MR-MXP cards in MR-MXP cards in

Cisco NCS 2015 devices | 200G-CK-LC card in adjacent slots. adjacent slots.
slots 2,7, 8, 13, or 14.

MXP_CK 100G on ONS | 100GS-CK-LC or
15454 M6 devices 200G-CK-LC card and
the peer MR-MXP card
need to be in adjacent
slots 2-3, 4-5, 6-7.

MXP_CK 100G on Cisco | 100GS-CK-LC or

NCS 2015 devices 200G-CK-LC card and
the peer MR-MXP card
need to be in adjacent
slots 2-3, 4-5, 6-7, 8-9,
10-11, 12-13, 14-15.

For 400G-XP-LC cards, you can configure the OTNXC card operating mode with trunk operating mode of
M-100G/M-200G. Based on the trunk operating mode, the supported slice configuration (either "Slice 1 and Slice 4"
or slice 1, 2, 3, 4 respectively) are OPM-100G and OPM-10x10G.

The trunk operating mode configured on the trunk 11 reflects automatically in the trunk 12. For example, when you
configure M-200G on trunk 11, the trunk operating mode for trunk 12 will be greyed out; However, M-200G will be
automatically configured on trunk 12. It is possible to mix OPM_ 100G slices with OPM_10x10G slices, and each slice
will be independent.

Click Save to deploy your changes to the device.
Expand the Pluggable Port Modules section to configure the payload values for each PPM.
Click the '+' (Add) icon in the Pluggable Port Modules section.
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Note For some PPMs, the respective payload values may not be enabled. To enable it, complete the card mode
configuration described in Step 9 above, and then try to re-configure the payload values.

Step 13 Choose the port number, port type, and the number of lanes that must be associated with the selected PPM. The
Port Type (payload) can be set to any supported client signals described in the Table 1 below.

Note » Ifthe specified Port Type (payload) is not supported for the selected card mode or PPM, then the changes
are not deployed to the device successfully. Ensure that the Payload values you specify, are supported
on the selected card. See Table 1 for reference.

* You can configure the number of lanes only on cards that allow payload values to be split. For all other
cards, the Number of Lanes field is disabled.

Step 14 Click Finish to deploy your changes to the device.

Step 15 (Optional) If your changes are not visible in the Cisco EPN Manager, it could be because more than one person is
working on the same card mode configuration and the changes are not reflected dynamically. Click the Refresh icon
within each section to view the most recent changes.

If you encounter a deploy failure, navigate to the error logs folder /opt/CSCOIlumos/logs/config.log for more details
about the cause of the error.

Configure SONET and Flex Line Cards

This procedure describes how you can use Cisco EPN Manager to modify the line card configuration on
10X10G-LC SONET cards and 400G-XP, 200G-CK-LC, and 100GS-CK-LC Flex cards.

This feature is only supported on Cisco NCS 2000 and Cisco ONS devices.
To configure a SONET or Flex line card:

Before you begin

* To configure SONET line cards, ensure that you select a card with the operating mode MXP10X10G
and OC192 payload value.

* To delete the SONET or Flex line card configuration, you only need to delete the payload values associated
with the selected card. This deletes the SONET or Flex configuration from the device automatically. To
delete the payload values, use the Pluggable Port Modes area under the configuration sub-tab.

» While configuring the SONET or Flex line card configuration, if you want to change the Line card type
from SONET to SDH, or make other similar changes, you must first ensure that the admin state of the
device is set to OOS-Disabled. If the device state is not OOS-Disabled, the line configuration changes
deployed to the device will fail.

* To configuring Flex line card configuration, ensure that the card operating modes for the card have been
previously set. See Configure cards: 400G-XP-LC, 100G-CK-C, 100ME-CK-C, 200G-CK-LC,
100GS-CK-C, 100G-LC-C, 100G-ME-C, and 10x10G-LC, on page 83.

Step 1 Launch the Chassis View as described in Open the Chassis View.
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Step 2 Select the slot from which you want to configure the card by doing one of the follow:

* Select the card in the slot from the physical Chassis View using the zoom in and out options.

* Use the Chassis Explorer view to navigate to the card and select it.

Step 3 Click the Configuration sub-tab from the window displayed on the right.
Step 4 Expand the Line section and choose the SONET or Flex sub-tabs.

The supported cards for SONET configuration are only 10x10G-LC cards, and for Flex cards, it is 400G-XP, 200G-CK-LC,
and 100GS-CK-LC cards.

Step 5 Choose one of the following ways to edit the configuration:
* Select the SONET or Flex tab for configuration that you want to edit and click the Edit icon.
* Click the inline parameters that you want to edit one by one within the rows of the table.

Step 6 Make the required changes to the parameters described in the table below and click Save to deploy your changes to the
device.

While configuring SONET parameters:
* When you set the Type to SDH, the Sync Messages checkbox is automatically disabled and cannot be configured.

* When you enabled the Sync Message checkbox, the Admin SSM option is disabled and set to null.

While configuring Flex parameters:

* For 400G-XP-LC cards, Flex line cards can be configured only for trunk ports 11/12.
* For 100GS-CK-LC cards, Flex line cards can be configured only for trunk port 2.
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Table 9: SONET and Flex Line Configuration Parameters and Descriptions

Line Card Type | Line Card Configuration Descriptions
Parameters
SONET Port Number The port number of the SONET interface you are configuring.
Port Name Allows you to add a name for the SONET optical port.
SD BER Sets the signal degrade bit error rate.
SF BER Sets the signal fail bit error rate.
Type Defines the port as SONET or SDH.

Provides Sync

When checked, the card is provisioned as an NE timing reference.

Sync Messaging Enables synchronization status messages (S1 byte), which allow the node
to choose the best timing source.

Admin SSM In If the node does not receive an SSM signal, it defaults to synchronization
traceability unknown (STU). Admin SSM allows you to override the STU
value with one of the following:

* PRS—Primary reference source (Stratum 1)
* STS2—Stratum 2
* TNC—Transit node clock
* STS3E—Stratum 3E
* STS3—Stratum 3
* SMC—SONET minimum clock
* ST4—Stratum 4
Flex Port The port number of the Flex interface you are configuring.

Gridless Enables or disables the gridless tunability feature on the selected card.
When the feature is enabled, you can configure the frequency values on
the card. Your options are:

* Enabled- When selected, enables you to edit the frequency parameter
for Flex.
* Disabled- When selected, disables the frequency parameter for Flex.

Frequency Specifies the frequency on the port of the 400G-XP, 200G-CK-LC, and

100GS-CK-LC cards in the range 191350 to 196100.
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Edit and Delete Pluggable Port Modules and Card Mode Configuration

Before you begin
Pre-requisites for deleting PPMs:

* Ensure that the PPMs are not part of any Active or Provisioned circuits.

* PPMs and their respective payload values must be deleted only in the order described in the procedure
below. Ensure that you first manually delete client ports 1 to 10 before deleting associated PPMs.

* Ensure that device sync is completed and the device's inventory collection status is either 'Completed'
or 'Managed'.

Pre-requisite for deleting card operating modes:

* Ensure that the cards are not part of any Active or Provisioned circuits.

* For 400G-XP cards, PPMs 11 and 12 cannot be deleted. These PPMs are deleted automatically when
the associated card operating mode is deleted.

* The peer card or skip card must not be in Active state. You can delete the peer or skip card associations
using CTC and then retry deleting the card operating mode via Cisco EPN Manager. You can also try
directly deleting the card from Cisco EPN Manager. For more information, see Delete a Card, on page
81.

Step 1 Choose Configuration > Network Devices.

Step 2 Select the device that you want to configure by clicking the device's Name hyperlink to launch the device's Chassis view.
Step 3 Use the Chassis Explorer to select the card with the configuration you want to delete.

Step 4 Click the Configuration sub-tab from the window displayed on the right.

Step 5 Expand the Pluggable Port Modules section to delete Pluggable Port Modules (PPMs).

a) In the Pluggable Port Modules sub-section, select the associated payload values that you want to delete and click
the 'X" (delete) icon.

b) Click OK to confirm. The changes are deployed to the device.
¢) In the Port Modules sub-section, select the PPMs that you want to delete and click the 'X' (delete) icon.
d) Click OK to confirm. The changes are deployed to the device.

Note You must delete all payload values associated with a given PPM, before you can delete the PPM.

Step 6 Expand the Card Operating Modes section to delete the card configuration.

a) To edit the card mode configuration, ensure that you select only 400G-XP cards, and click the Edit icon to make your
changes. For all other cards, the configuration can be edited only by deleting the card mode configuration and
re-creating it with new values.

b) To delete the card mode configuration, select the required card mode configuration and click the 'X' (delete) icon.

¢) Click OK to confirm. The changes are deployed to the device.
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Cards and Supported Configuration for Cisco NCS 2000 Devices

Table 10: 100GS-CK-LC and 200G-CK-LC Cards: Supported Configuration

Card Operating | Trunk Card Peer card Peer Skip Supported Payload Types
Modes Card
MXP_200G 100GS-CK-LC or | MR-MXP cards | MR-MXP 100GE and OTU4
.2001G ;C‘f _7L (é C? ;d 11112510tls 53’ 6,9, Zarsdslgl slllo s OTU4 is supported only for the
g; 512 84158, 19, 12000 L "1 200G-CK-LC card.
’ ) Regeneration of any 100 G
configuration
10GE
10GE
100GE
MXP 10x10G 100G | 100GS-CK-LC or |10x10G-LC MR-MXP 100GE and OTU4
Islos 2 78 10 |60 ror 15 |45 10, 11 or | OTU4 s supported iy for the
or 14 O I ) 1,6 o 200G-CK-LC card.
’ ’ Regeneration of any 100 G
configuration
10GE
10GE
100GE
MXP_CK 100G 100GS-CK-LC or |N/A N/A 100GE and OTU4
ir(:g(t}}fK—I;C card OTU4 is supported only for the
pee 200G-CK-LC card.
MR-MXP card need .
. . Regeneration of any 100 G
to be in adjacent S fiouration
slots 2-3, 4-5, 6-7, contiguratio
8-9, 10-11, 12-13, 10GE
14-15. 10GE
100GE
RGN-100G 100GS-CK-LCor |N/A N/A 100GE and OTU4
200G-CK-LC card OTU4 is supported only for the
and the peer card
200G-CK-LC card.
100GS-CK-LC or Regeneration of any 100 G
200G-CK-LC need & : Y
. . configuration
to be in adjacent
slots 2-3, 4-5, 6-7, 10GE
8-9, 10-11, 12-13,
14-15. 10GE
100GE

. Configure Devices



| Configure Devices
Cards and Supported Configuration for Cisco NCS 2000 Devices .

TXP-100G 100GS-CK-LCor |N/A N/A N/A
200G-CK-LC

Table 11: 100G-CK-C and 100ME-CKC Cards: Supported Configuration

Card Operating | Trunk Card Peer card Skip Card Supported Payload
Modes Types
TXP-100G 100G-CK-C/ N/A N/A 100GE, OTU4
100ME-CKC .
— Regeneration of
any 100 G
configuration
40GE
RGN-100G 100G-CK-C/ 100ME-CKC card and the |N/A 100GE, OTU4
peer card — Regeneration of
100G-LC-C/ 100G-ME-C/ 100G-CK-C/ any 100 G
100ME-CKC need to be in adjacent slots configuration
2-3,4-5,6-7,8-9, 10-11, 12-13, 14-15. 40GE
MXP-2x40G 100G-CK-C/ N/A N/A 100GE, OTU4
100ME-CKC .
— Regeneration of
any 100 G
configuration
40GE
Table 12: 100G-LC-C and 100G-ME-C Cards: Supported Configuration
Card Operating | Trunk Card Peer card Skip Card Supported Payload
Modes Types
TXP-100G 100G-LC-C/ N/A N/A 100GE, OTU4
100G-ME-C — Regeneration of
any 100 G
configuration
40GE
RGN-100G 100G-LC-C/ 100G-ME-C card and the |N/A 100GE, OTU4

peer card 100G-LC-C/ 100G-ME-C/

100G-CK-C/ 100ME-CKC need to be in — Regeneration of

adjacent slots 2-3, 4-5, 6-7, 8-9, 10-11, zgz fiooriion
12-13, 14-15. gl
40GE
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Table 13: 10X10G-LC Cards: Supported Configuration

Configure Devices |

Card
Operating
Modes

Trunk Card

Peer
card

Skip Card

Supported Payload Types

TXPP-10G

10x10G-LC

N/A

N/A

OC192/STM-64, 10GE-LAN Phy, 10GE-WAN
Phy (using OC192), OTU2, OTU2e, 8G FC, 10G
FC, FICON

Only OC192/STM64 and 10GE are supported
when the 10x10G-LC card is connected with the
100GS-CK-LC card.

Only OC192/STM64, 10GE, and OTU2 are
supported when the 10x10G-LC card is
connected with the 200G-CK-LC card.

10GE-LAN Phy, OTU2

10GE-LAN Phy, OTU2e, OTU2,
0C192/STM-64, 8G FC, 10G FC, IB_5G

10GE, 10G FC
10GE
10GE, OTU2e

TXP-10G

10x10G-LC

N/A

N/A

OC192/STM-64, 10GE-LAN Phy, 10GE-WAN
Phy (using OC192), OTU2, OTU2e, 8G FC, 10G
FC, FICON

Only OC192/STM64 and 10GE are supported
when the 10x10G-LC card is connected with the
100GS-CK-LC card.

Only OC192/STM64, 10GE, and OTU?2 are
supported when the 10x10G-LC card is
connected with the 200G-CK-LC card.

10GE-LAN Phy, OTU2

10GE-LAN Phy, OTU2e, OTU2,
0OC192/STM-64, 8G FC, 10G FC, IB_5G

10GE, 10G FC
10GE
10GE, OTU2e
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MXP-10x10G

10x10G-LC card and
the peer 100G-LC-C,
100G-ME-C,
100G-CK-C,
100ME-CKC,
100GS-CK-LC or
200G-CK-LC card
need to be in adjacent
slots 2-3, 4-5, 6-7, 8-9,
10-11, 12-13, 14-15.

N/A

N/A

OC192/STM-64, 10GE-LAN Phy, 10GE-WAN
Phy (using OC192), OTU2, OTU2e, 8G FC, 10G
FC, FICON

Only OC192/STM64 and 10GE are supported
when the 10x10G-LC card is connected with the
100GS-CK-LC card.

Only OC192/STM64, 10GE, and OTU?2 are
supported when the 10x10G-LC card is
connected with the 200G-CK-LC card.

10GE-LAN Phy, OTU2

10GE-LAN Phy, OTU2e, OTU2,
OC192/STM-64, 8G FC, 10G FC, IB_5G

10GE, 10G FC
10GE
10GE, OTU2e

RGN-10G

10x10G-LC

N/A

N/A

OC192/STM-64, 10GE-LAN Phy, 10GE-WAN
Phy (using OC192), OTU2, OTU2e, 8G FC, 10G
FC, FICON

Only OC192/STM64 and 10GE are supported
when the 10x10G-LC card is connected with the
100GS-CK-LC card.

Only OC192/STM64, 10GE, and OTU?2 are
supported when the 10x10G-LC card is
connected with the 200G-CK-LC card.

10GE-LAN Phy, OTU2

10GE-LAN Phy, OTU2e, OTU2,
0C192/STM-64, 8G FC, 10G FC, IB_5G

10GE, 10G FC
10GE
10GE, OTU2e

LOW -
LATENCY

10x10G-LC

N/A

N/A

N/A
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FANOUT - | 10x10G-LC N/A N/A OC192/STM-64, 10GE-LAN Phy, 10GE-WAN
10X10G Phy (using OC192), OTU2, OTU2e, 8G FC, 10G
FC, FICON

Only OC192/STM64 and 10GE are supported
when the 10x10G-LC card is connected with the
100GS-CK-LC card.

Only OC192/STM64, 10GE, and OTU?2 are
supported when the 10x10G-LC card is
connected with the 200G-CK-LC card.

10GE-LAN Phy, OTU2

10GE-LAN Phy, OTU2e, OTU2,
0OC192/STM-64, 8G FC, 10G FC, IB_5G

10GE, 10G FC
10GE
10GE, OTU2e

400G-XP-LC and MR-MXP cards of Cisco NCS 2000 devices can be configured with the following card
operating mode and payload values:

* Payload types OTU2/0C192 are supported on MR-MXP cards,
* Payload types 16G-FC/OTU2 are supported on 400G-XP-LC cards,
* Slice operational mode OPM_6x16G_LC is supported on 400G-XP-LC cards.

Discover and Configure MPLS LDP and MPLS-TE Links

Using Cisco EPN Manager you can configure Label Distribution Protocol (LDP) and MPLS-TE links in an
MPLS network.

MPLS LDP

LDP provides a standard methodology for hop-by-hop (or dynamic label) distribution in an MPLS network
by assigning labels to routes that have been chosen by the underlying IGP routing protocols. The resulting
labeled paths, called label switch paths (LSPs), forward labeled traffic across an MPLS backbone. Cisco EPN
Manager enables you to configure the potential peers and establish LDP sessions with those peers to exchange
information.

To configure LDP using Cisco EPN Manager you need to know the network address and interface of the
device on which the LDP links must be configured and also subnet mask for the configured IP addresses.

\)

Note Before configuring MPLS LDP, ensure that the LDP ID is pre-configured on the device.

MPLS-TE

Cisco EPN Manager supports the provisioning of MPLS Traffic Engineering (MPLS-TE) services. MPLS-TE
enables an MPLS backbone to replicate and expand the TE capabilities of Layer 2 over Layer 3. MPLS TE
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Step 1
Step 2
Step 3

Step 4

Discover and Configure MPLS LDP and MPLS-TE Links .

uses Resource Reservation Protocol (RSVP) to establish and maintain label-switched path (LSP) across the
backbone. For more information, see, Supported MPLS Traffic Engineering Services.

To configure LDP and MPLS-TE parameters:

Choose Configuration > Network Devices.
Select the device that you want to configure by clicking the device hyperlink to launch its Device Details page.
Click the Logical View tab.

Note The Logical View tab may appear depending on the level of EPNM support provided for the device.

To configure LDP links:

a) Choose MPLS > LDP, click on Common Properties tab and and click '+' to specify new LDP parameters. To edit
existing parameters, click the LDP Address hyperlink and click the Edit icon at the top right corner of the page.

Note You can only add a single set of LDP settings per device.

b) Under the Common Properties tab, specify the LDP parameters described in the below table.

MPLS LDP Fields Field Descriptions

LDP Interface Choose the LDP interface that is the source loopback interface for the LDP
session on the device.

LDP Address Specify the IP address of the LDP interface. Once the LDP address is set, it
cannot be edited. To change the LDP address, delete the LDP session and create
a new session with the new LDP address.

Session Hold Time (Optional) Enter the time, in seconds, that the LDP session will go down if no
hellos have been received after the Hold timer expires. Range is 15 to 65535.

NSR Enabled Choose true or false to either enable or disable LDP nonstop routing (NSR).
Enabling NSR allows the LDP to continue to operate across a node failure
without losing peer sessions.

Discovery Hold time and (Optional) Enter the time, in seconds, an LDP source and a discovered LDP
Discovery Target Hold time neighbor is remembered without receipt of an LDP hello message from the
neighbor. Range is 1 to 65535.

Discovery Hold Interval and (Optional) Enter the time duration, in seconds, during which a LDP source and
Discovery Target Hold Interval | a discovered LDP neighbor is remembered. Range is 1 to 65535.

DownStream Min Label and (Optional) Enter the minimum and maximum number of hops permitted in an
DownStream Max Label LSP established by the Downstream on Demand method of label distribution.
Range is 16 to 32767 for ISO XE and 16000 to 1048575 for ISO XR devices.

DownStream Max Hop Count (Optional) Enter the number of hops permitted in an LSP established by the
Downstream on Demand method of label distribution. Range is 1 to 255.

IGP Hold Down Time (Optional) Enter the time, in seconds, to specify the time for which the declaration
of LDP sync state is delayed after session establishment upon link coming up.
Range is 1 to 2147483647 millisecond for ISO XE and 5 to 300 milliseconds
for ISO XR devices.
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MPLS LDP Fields

Field Descriptions

Entropy Enabled Choose true or false to either enable or disable the MPLS LDP Entropy Label
support feature which helps improve load balancing across MPLS networks
using entropy labels.

Explicit Null Enabled (Optional) Enable this value to advertise explicit-null labels for the directly

connected route. Values are Yes (enabled) or No (disabled).

Initial Back Off and Max Back Off | (Optional) Enter the initial and maximum back off delay value in seconds. Range
is 5t0 2147483.

c¢) Click Save to deploy your changes to the device.
d) Click on Interfaces tab and and click '+' to specify the Interface parameters.

MPLS LDP Fields

Field Descriptions

Interface Name

Specify the name of Interface to participate in the LDP session.

Label Distribution Method

Specify 'LDP' as the Label Distribution Method

Hello Interval

(Optional) Enter the time interval, in seconds, when hello messages will
be sent. Range is 1 to 65535.

e) Click Save to deploy your changes to the device. The same properties are configured on the peer devices. Once the
neighbor devices are formed, the details are populated in the Neighbors tab.

To configure MPLS-TE links:
a) Choose MPLS > MPLS-TE. .

b) Inthe MPLS-TE FRR area, check the MPLS TE Tunnel Enabled check box. The default values of MPLS-TE
parameters are displayed as described in the below table.

MPLS TE Tunnel Fields

Field Descriptions

MPLS TE Tunnel Enabled

Activates the display of the list of automatic bandwidth enabled tunnels, and
indicates if the current signaled bandwidth of the tunnel is identical to the
bandwidth that is applied by the automatic bandwidth

Auto Bandwidth Timer Frequency (Sec)

To set the interval (in seconds) at which the automatic bandwidth on a tunnel
interface is triggered.

Reoptimize Timer Frequency (Sec)

Set the value (in seconds) to trigger the reoptimization interval of all TE
tunnels.

Auto Backup Tunnel Enabled

To display information about automatically built MPLS-TE backup tunnels.

Backup Tunnel Min. Range and Backup
Tunnel Max. Range

Configures the range of backup autotunnel numbers to be between the specified
minimum and maximum value. Ensure that minimum range for the backup
tunnel is lower than the maximum range.
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MPLS TE Tunnel Fields Field Descriptions

SRLG Exclude Specifies an IP address to get SRLG values from, for exclusion. Choose one

of the following options, if required:
* Preferred
* Forced

* None

Note SRLG Exclude option is available only for IOS-XE.

Un-numbered Interface Enables IP processing on the specified interface without an explicit address.

Step 6 Click Save to deploy your changes to the device.

What to do next
Monitor LDP links on the Network Topology:
1. In the left sidebar, choose Maps > Topology Maps > Network Topology.

Click on the Device Groups button, select the required device group(s), and click Load.
Click Show in the topology toolbar and choose Links.

Select the LDP check box under Control Plane to display LDP links on the map.

o & b

Click on an LDP link to see details about the link.

For information on how to provision MPLS-TE services, see Provision MPLS Traffic Engineering Services.

Analyze Ports Using SPAN and RSPAN

Using Cisco EPN Manager, you can analyze network traffic passing through ports or VLANs by using SPAN
or RSPAN to send a copy of the traffic to another port on the switch or to a monitoring device. SPAN copies
(or mirrors) traffic received or sent (or both) on source ports or source VLANS to a destination port for analysis.
Traffic that enters or leaves source ports or traffic that enters or leaves source VLANSs are monitored.

If you configure SPAN to monitor incoming traffic, then traffic that gets routed from another VLAN to the
source VLAN cannot be monitored. However, traffic that is received on the source VLAN and routed to
another VLAN can be monitored.

Cisco EPN Manager allows you to configure only one Local SPAN session per device. Local SPAN sessions
copy traffic from one or more source ports in any VLAN to a destination port for analysis.

Using Remote SPAN you can configure source ports, source VLANSs, and destination ports on different
switches, enabling remote monitoring of multiple switches across your network. The traffic for each RSPAN
session is carried over a user-specified RSPAN VLAN that is dedicated for that RSPAN session in all
participating switches. The RSPAN traffic from the source ports or VLANSs is copied into the RSPAN VLAN
and forwarded over trunk ports carrying the RSPAN VLAN to a destination session monitoring the RSPAN
VLAN.
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Note To monitor ports, you must ensure that the ports are associated with one or more VLANS (source or
destination).

To enable port monitoring (or mirroring):

Choose Configuration > Network Devices.

Select the device that you want to configure by clicking the device hyperlink to launch its Device Details page.
Click the Logical View tab.
Configure an RSPAN session:

a)

b)

c)

d)
e)

d)
e)

Choose Port Analyzer > RSPAN > Destination Node to configure the destination node for RSPAN.
Click '+ to specify the RSPAN session ID. To edit existing settings, click the session ID hyperlink and click the Edit

icon at the top right corner of the page.
You can add up to 14 RSPAN and SPAN sessions.

Choose a session ID and click Save.
The session type Remote Destination (Remote RSPAN) is set by default and cannot be edited.

Click the session ID hyperlink to specify the source and destination settings for the destination node.

Click the Source Settings tab, choose a valid VLAN ID (auto populated based on the VLANs configured on the
selected device), and click Save.

You can add only a single VLAN as the source for the destination node. If no VLANS are configured, you need to
configure them and return to this step. See View VLAN Interfaces, on page 43.

Click the Destination Settings tab, select the interface that must act as the destination node for the RSPAN, and click
Save.
From the features panel, choose Port Analyzer > RSPAN > Source Node to configure the source node for RSPAN.

Click '+' to specify common RSPAN source node settings. To edit existing settings, click the session ID hyperlink
and click the Edit icon at the top right corner of the page.

Choose a session ID and click Save.

The session type Remote Source (Remote SPAN) is set by default and cannot be edited.

Click the session ID hyperlink to specify the source and destination settings for the source node.
Click the Source Settings tab, specify the following values, and click Save.

i) In the Interface drop-down menu, choose the interface that will act as the source interface for the RSPAN source
node.

An interface specified as a source node for RSPAN can also be used as the source/destination node for SPAN.

ii) In the Direction drop-down menu, choose direction in which the interface must be applied to the RSPAN source
node. Your options are:

» Transmit: monitors all packets sent by the source interface after all modification and processing is performed
by the switch. A copy of each packet sent by the source is sent to the destination port for that session. The copy
is provided after the packet is modified.

* Receive: monitors all packets received by the source interface or VLAN before any modification or processing
is performed by the switch. A copy of each packet received by the source is sent to the destination port for that
session.
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f)

Configure and View Ethernet Link Aggregation Groups .

* Both: (default value) monitors a port or VLAN for both received and sent packets.

You can add multiple interfaces to the source node for RSPAN and then associate a single VLAN ID to these interfaces.

Click the Destination Settings tab, choose a valid VLAN ID (auto populated based on the VLANs configured on
the selected device), and click Save.

Configure a SPAN session:

a)
b)

d)
e)

2)

Click Port Analyzer > SPAN.
Click the '+' to specify common SPAN source node settings. To edit existing settings, click the session ID hyperlink
and click the Edit icon at the top right corner of the page.

Interfaces configured as the source and destination node for RSPAN, cannot be used for SPAN.
Choose a session ID and click Save.
The session type Local (Local SPAN) is set by default and cannot be edited.

Click the session ID hyperlink to specify the source and destination settings for SPAN.
Click the Source Settings tab, and choose the interface and direction in which the interface must be applied for
SPAN, and click Save. For more details, see Step 4.

An interface specified as a source node for RSPAN can also be used as the source/destination node for SPAN.

Click the Destination Settings tab, choose a valid VLAN ID (auto populated based on the VLANS configured on
the selected device), and click Save.

(Optional) To verify that your changes were configured correctly, use the following command in your device CLI:

show monitor session all

Configure and View Ethernet Link Aggregation Groups

An Ethernet Link Aggregation Group (LAG) is a group of one or more ports that are aggregated together and
treated as a single link. Each bundle has a single MAC, a single IP address, and a single configuration set
(such as ACLs). LAGs provide the ability to treat multiple switch ports as one switch port. The port groups
act as a single logical port for high-bandwidth connections between two network elements. A single link
aggregation group balances the traffic load across the links in the channel. LAGs help provision services with
two links. If one of the links fails, traffic is moved to the other link.

The following figure illustrated a LAG created between two devices: Device A and Device B.
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GE1/0M4 GE1/0/4
GE1/0/1 0/
GE1/0/3

Device A

GE1/0/5 BAGG1 BAGG1 GE1/NS

405431

Cisco EPN Manager allows you to view and manage LAGs in the following ways:

* Create Link Aggregation Groups (LAG) Using Multiple Interfaces, on page 100
* View Ethernet LAG Properties, on page 101

Create Link Aggregation Groups (LAG) Using Multiple Interfaces

Using Cisco EPN Manager, you can create LAGs that provide the ability to treat multiple physical switch
ports as a single logical one.
Before you begin

* Only interfaces that are not already part of an existing LAG can be selected. An interface cannot be a
part of more than one LAG.

* The selected group of interfaces must all consist of the same bandwidth type.

* Inventory collection status for the devices that participate in the LAG must be Completed.

To create a LAG:
Step 1 Choose Configuration > Network Devices.
Step 2 Click the device hyperlink to launch its Device Details page.
Step 3 Click the Logical View tab.
Step 4 Choose Interfaces > Link Aggregation.
Step 5 Depending on the type of control method that you want to use, click the PAgP or the LACP tab.
Step 6 To create a new LAG, click the Add (+) sign.
Step 7 Enter a unique name for the LAG. Ensure that the channel group ID that you specify is part of the LAG name. For

example, for a channel group ID of 10, your LAG name should be:
* ‘Bundle-Ether10’ for Cisco IOS-XR devices.
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Step 8

Step 9

Step 10

Step 11

Step 12
Step 13

View Ethernet LAG Properties .

Enter a number between 1-16 to specify the Channel Group ID. The channel group ID ranges for different types of
devices is: 1-8 for Cisco ASR 90X devices, 1-64 for Cisco ASR 920X devices, 1-26 for Cisco ME3x00 devices, 1-48
for Cisco NCS42xx devices, and 1-65535 for Cisco ASR9000 devices.

Click the Member Port Settings tab to specify the member port values:
* LACP Modes: LACP can be configured with the following modes:

* Active- In this mode, the ports send LACP packets at regular intervals to the partner ports.

* Passive- In this mode, the ports do not send LACP packets until the partner port sends LACP packets. After
receiving LACP packets from the partner port, the ports then send LACP packets to the partner port.

* PAgP Modes: PAgP modes can be configured with AUTO, DESIRABLE, or ON. For ASRIK devices, only On
PAgP mode is enabled. ON implies that the mode is set to PAgP - manual.

Click Save.

Your changes are saved and you can now add interfaces to the created LAG.

To add interfaces to the created LAG, select the required channel group from the Link Aggregation table and click the
Edit icon.

Select the interfaces that you want to use to create the LAG.
Click Save.

The LAG is created using the interfaces that you selected.

View Ethernet LAG Properties

You can view properties for Ethernet LAGs in the following ways:
« Using the Device Configuration tab:
1. Go to Network Devices > Device Properties > Configuration tab.
2. Select the device on which you want to configure the LAG by clicking the device name hyperlink.
3. Click the Logical View tab.
4

Click Interfaces > Link Aggregation in the Features panel.

» Using the Device Details tab:

1. Go to Network Devices > Device Properties.

2. Select the device on which you want to configure the LAG by clicking the device name hyperlink.
3. Click the Device Details tab.
4

Click Interfaces > Ether Channel in the Features panel.

Configure Devices .



Configure Devices |

. Configure Routing Protocols and Security

Configure Routing Protocols and Security

Using Cisco EPN Manager, you can configure the following routing protocols for your CE and Optical devices.
You can also configure security for your devices using ACLs.

Before you configure routing protocols and ACLs, ensure that the device's Inventory Collection status is
'Completed'.

To view a device's routing table, open the Device 360 view and choose Actions > Routing Table Info > All.

* Configure BGP, on page 102

* Configure an IS-IS, on page 105

* Configure OSPF, on page 107

* Configure Static Routing, on page 109

* Configure ACLs, on page 109

Configure BGP

Step 1
Step 2
Step 3
Step 4

Step 5

Border Gateway Protocol (BGP) is a standardized exterior gateway protocol designed to exchange routing
and reachability information between autonomous systems (AS) in your network. By configuring BGP, your
device is enabled to make routing decisions based on paths, network policies, or rule-sets configured by a
network administrator.

Using the Cisco EPN Manager, you can configure BGP routing and establish a BGP routing process by
specifying the AS number and Router ID. You can then create a BGP neighbor which places the router in
neighbor configuration mode for BGP routing and configures the neighbor IP address as a BGP peer. To
configure the BGP neighbor, you need to provide the neighbor's IPv4 address and its peer AS number. BGP
neighbors should be configured as part of BGP routing. To enable BGP routing, at least one neighbor and at
least one address family must be pre-configured.

To view a device's BGP and BGP Neighbors routing table, open the Device 360 view, then choose Actions
> Routing Table Info.

To configure BGP routing protocol on a device:

Choose Configuration > Network Devices.

Select the required device by clicking the device name hyperlink.
Click the Logical View tab.
Choose Routing > BGP.

Note

The configuration changes on Cisco Catalyst 6500 Series devices with a quad-supervisor Virtual Switching
System (VSS) are not dynamically reflected on this page. To view these changes, ensure that the 24 hour
periodic device sync is completed. Alternatively, you can manually sync these devices with Cisco EPN
Manager.

To configure the BGP routing process, click the + icon or if BGP is already configured, click the AS number hyperlink
and then click the Edit icon to enter the BGP Process details described in the table below.
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Step 6
Step 7

Step 8

Step 9
Step 10

Configure BGP .

Click Save to deploy your changes to the device and to enable the BGP Address Family and BGP Neighbor tabs.

To configure the BGP address family details, click the BGP Address Family tab and choose the address family details
described in the table below, and click Save.

To configure the BGP neighbor, click the BGP Neighbor tab and choose the neighbor device by selecting the device's
IP address from the list.

To create a new BGP neighbor, click the Add (+) icon, specify the following details described in the table below.

Click Save. The updated BGP routing process values are saved and deployed to the selected device.

To verify that your changes were saved, go to Configuration > Network Devices, launch the Device Details page,
and click the Logical View tab. Choose Routing > BGP. You can view your BGP configuration details such as the
Neighbor Address, Remote AS, Address Family Type and Modifier, and Advertise Interval Time configured on the

device.
Fields Sub-field Descriptions
Common |AS Number |Enter the AS number using a numeric value from 1 to 4294967295.
BGP
Process
fields
Router ID * Enter the Router ID. The value can be an IPv4 address of the format:
* A.B.C.D- for IPv4 addresses, where A, B, C, and D are integers ranging from
0 to 255.
Log Neighbor | Select to track neighbor router changes.
Changes
BGP BGP Global * Address Family: Enter the BGP address family prefixes for the routing process. Your
Address | AF options are IPv4 and IPv6 (for unicast, multicast, and MVPN), VPNv4 and VPNv6
Family (for unicast), IPv4 (for MDT), and LZVPN_EVPN_AF (for EVPN based services).
fields
* Allocate Label: Choose the labeled unicast address prefixes.
* Allocate Label Custom Policy Name: Choose a custom policy to be associated with
the routing process.
Note The Allocate Label and Allocate Label Custom Policy Name fields are only
applicable for IOS device types.
BGP Specify the details for the paths that enable the advertisement of multiple paths through
Additional | the same peering session for the same prefix without the new paths implicitly replacing
Paths any previous paths.

« Additional Paths: Choose whether the device must send, receive, or send and receive
additional paths. This is done at the address family level or the neighbor level. During
session establishment, the specified BGP neighbors negotiate the Additional Path
capabilities (whether they can send and/or receive) between them.

Note While configuring Cisco CAT65000 devices, you can configure only Install

as the additional path value.
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Fields

Sub-field

Descriptions

* Best Value: This field is enabled only when the Additional Paths value that you choose
supports the configuration of the Best Value field.

BGP
Neighbor AF

Specify the address family details that the specified BGP neighbor belongs to:

* Neighbor Address: Choose the Router ID of the neighboring router. These values are
populated based on the BGP neighbors created in the Neighbor tab. The value can
be an IPv4 or an IPv6 address of the format:

* A.B.C.D- for IPv4 addresses, where A, B, C, and D are integers ranging from
0 to 255.

o XXXXXXXX XXXX XXXX XXXX:XXXX:XXXX:XXxX - for [IPv6 addresses, where x would
be a hexadecimal value and where the address uses eight sets of four hexadecimal
addresses (16 bits in each set), separated by a colon (:).

* Send Label: Choose the type of label that must be associated with the neighbor.

* Route Reflector Client: Enable this field to configure the router as the route reflector
and the specified neighbor as its client.

» AIGP: Select to enable the accumulated interior gateway protocol (AIGP) path
attribute.

* Send Community: Choose how the community attributes must be sent to an external
Border Gateway Protocol (eBGP) neighbor.

* Next Hop Self: Select to set the BGP next-hop attribute of routes being advertised
over a peering session to the local source address of the session.

* Incoming and Outgoing Route Map Name: Choose to indicate whether a route policy
must be applied to inbound or outbound updates from the neighbor.

BGP Network
Mask

* Network Address and Mask: Specify the network IP address and network mask for
the specified IP address.

* Back Door Route: Enable to set the administrative distance on an external Border
Gateway Protocol (eBGP) route to that of a locally sourced BGP route, causing it to
be less preferred than an Interior Gateway Protocol (IGP) route.

* Network Route Policy Name: Choose the route policy that will be used to select
prefixes for label allocation. This enables BGP to allocate labels for all or a filtered
set of global routes (as dictated by the route policy).

BGP
Neighbor
tab fields

. Configure Devices

Specify the following values:

* Peer AS Number- Enter the value for the autonomous system number using integers
in the range 1 to 4294967295.

* Neighbor Address- Enter the IP address of the BGP neighbor that you want to
configure.The value can be an IPv4 or an IPv6 address of the format

* A.B.C.D- for IPv4 addresses, where A, B, C, and D are integers ranging from
0 to 255.
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Fields

Sub-field Descriptions

* XXXXIXXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX - for [Pv6 addresses, where x would
be a hexadecimal value and where the address uses eight sets of four hexadecimal
addresses (16 bits in each set), separated by a colon (:).

* Local AS Number and Action: Specifies an autonomous-system number to prepend
to the AS_PATH attribute. The range of values is any valid autonomous system
number from 1 to 65535.

» Update Source: Use this option to establish a peer relationship (TCP connection)
using the loopback interface as an alternative instead of using the interface closest to
the peer router.

* Fall-over: Select a value to enable the BGP fast peering session deactivation for
improving the convergence and response time to adjacency changes with the specified
BGP neighbor.

* Password Encryption and Password: Specify whether password encryption is enabled
or not, and if enabled, what the password value is.

* (View only) Neighbor State: View the connection status of a neighbor device
participating in a BGP routing process. The states are: Idle, Connect, Active, Opensent,
Openconfirm, and Established.

The neighbor device generates events only when its connection status is Established.
Please check the connection status frequently in case there are updates from the device.

Note The neighbor state value is not updated during a granular inventory sync.
To see the updated values, wait for the sync to end successfully.

Configure an IS-IS

Intermediate System-to-Intermediate System (IS-IS) Protocol is an intra-domain OSI dynamic routing protocol
which uses a two-level hierarchy to support large routing domains (administratively divided into areas).
Routing within an area is referred to as Level 1 routing. Routing between areas is referred to as Level 2 routing.
In order to enable IS-IS for IP on a Cisco router and have it exchange routing information with other IS-IS
enabled routers, you must perform the following tasks:

* Enable the IS-IS routing process on the device and assign areas.

* Enable IS-IS IP routing on the required interfaces.

An interface with a valid IP address can be designated to act as a Level 1 (intra-area) router, a Level 1 _2 (both
a Level 1 router and a Level 2) router, or a Level 2 (an inter-area only) routing interface for a given IS-IS
instance. After the IS-IS routing starts working across the routers between the designated interfaces, the IS-IS
neighborhood is automatically generated.
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Note To enable IS-IS routing, at least one address family must be configured by default. In this release,
configuring address families cannot be done using Cisco EPN Manager.

To configure the IS-IS process on a device:

Step 1 Choose Configuration > Network Devices.

Step 2 Select the device on which you want to configure the IS-IS routing protocol by clicking the device name hyperlink.
Step 3 Click the Logical View tab.

Step 4 Choose Routing > IS-IS.

Step 5 To configure a new IS-IS process, click the '+' icon and enter the following parameters:

* Specify the 1S-1S Process ID using alphanumeric characters only. No spaces or special characters are allowed.
* Specify the NET ID in NSAP format. For example, your NET ID can be 49.0001.0000.0001.0010.00, where:
* 49 - represents the first portion of the area ID which represents the AFI (Authority and Format Indicator).
* 0001 - represents the second portion of the area ID.
* 0000.0001.0010 - represents the system ID.

* 00 - represents the N-selector which is always 0.

* Specify the type of IS-IS routing protocol in the 1S-1S Type field. Your options are: Level 1, Level 2, and Level

1.2
Step 6 Click Save.
Step 7 To configure this routing process on the selected device's interfaces:

a) Select the IS-IS protocol process created in the above steps from the Routing > IS-1S list.
b) Click the IS-IS process ID hyperlink.

c) Use the IS-IS Interfaces tab to specify the interfaces of the device on which the selected IS-IS configuration is to
be applied:

* Click the "+' icon to enter the interface details.

* From the Circuit Type drop-down menu, select the type of circuit to which this configuration is to be applied.
Your options are: Level 1, Level 2, and Level 1_2.

* From the Interface drop-down menu, select the required interfaces.

* (Optional) Specify the Level 1 and Level 2 metric and priority values. For the Priority field enter a value
between 1 to 127 and for the Metric, a value between 1 to 16777214.

* Enable the Point-to-Point checkbox to enable point to point connection.

* Click Save to deploy the configuration onto the selected interfaces.

Step 8 Click Save. The selected IS-IS process is configured on the specified interfaces of the device.
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Step 9

Step 10

configure 0SPF ]

(Optional) To view IS-IS neighbors associated with the selected device, click the IS-IS hyperlink and click the 1S-1S
Neighbors tab. You can view the configured neighbor's hostnames, IP addresses, system IDs, IS-IS types, their
connection states, the configured hold down time values, and the local interface names.

Note If the hostnames of the IS-IS neighbors are greater than 15 unique characters, the hostnames are not displayed
in Cisco EPN Manager. Ensure that the hostnames are not more than 15 unique characters.

(Optional) To delete IS-IS routing processes configured using Cisco EPN Manager:

a) Go to Configuration > Network Devices, launch the Device Details page, and choose Routing > 1S-1S.
b) Select the required IS-IS process from the list.

c) Click the 'X' icon to delete and click OK to confirm the delete operation.

Configure OSPF

Step 1
Step 2
Step 3
Step 4

Step 5

Step 6
Step 7

Step 8

Open Shortest Path First (OSPF) is a standards-based routing protocol that uses the Shortest Path First (SPF)
algorithm to determine the best route to its destination. OSPF sends Link State Advertisements (LSAs) to all
routers within the same configured area. OSPF sends routing updates only for the changes in the routing table;
it does not send the entire routing table at regular intervals.

Using Cisco EPN Manager you can configure OSPF for IPv4 and IPv6 addresses. To do this, ensure that you
know the router ID, the administrative distance that you want to configure on the router, and the maximum
path values to be set.

To configure the OSPF routing process:

Choose Configuration > Network Devices.

Select the device on which you want to enable OSPF by clicking the device name hyperlink. Select only IOS-XR devices.
Click the Logical View tab.

Choose Routing > OSPF .

Note The configuration changes on Cisco Catalyst 6500 Series devices with a quad-supervisor Virtual Switching

System (VSS) are not dynamically reflected on this page. To view these changes, ensure that the 24 hour
periodic device sync is completed. Alternatively, you can manually sync these devices with Cisco EPN Manager.

To add a new OSPF process, click the + sign. To modify existing OSPF processes, select the required process by clicking
the process ID hyperlink and click the Edit icon at the top right corner of the page.

Specify the common OSPF parameters as described in the table below.

Click Save. Your configuration changes are saved. To verify, click the Configuration tab, choose Routing > OSPF,
and view the displayed details.

Specify the OSPF Interfaces settings:

Once you have configured the OSPF process with basic properties, you can further deploy that configuration directly on
an entire network or on an OSPF area. To do this, you need to specify the OSPF area ID, the device's interface details,
the network type, etc. To change OSPF interface settings:

a) Choose Configuration > Network Devices.

b) Select the device on which you want to configure these changes by clicking the device name hyperlink.
¢) Click the Configuration tab and choose Routing > OSPF .

Configure Devices .
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d) Select the required process by clicking the process ID hyperlink.
e) Click the OSPF Interfaces tab.

f) Click the Add ('+") icon to add new settings to the interfaces associated with the selected device's OSPF process. To
edit existing values, click the Interface Name hyperlink and click the Edit icon at the top right of the page.

g) Specify the parameters as explained in the table below.
h) Click Save to deploy your changes to the device.

Option Description

OSPF Common Properties Description

Process ID Unique numerical value between 1 and 65535 that identifies the selected OSPF
process.

Router ID Router ID of the Area 0 router.

Cost Sets a cost for sending packets across the network, which is used by OSPF routers

to calculate the shortest path. This is not enabled for Cisco IOS-XE devices.

Enter a numeric value between 1 and 65535.

Topology Priority Displays the designated router for a subnet. Enter a numeric value between 1 and
255.

Maximum number of paths per route | Defines the highest number of paths that can be used by the router for load
balancing per route. The default value is 4. You can set a numeric value between
1 and 64.

Administrative Distance Specifies the distance that will be set for path selection. The default value is 110
and the available values are between 1 and 255.

External Area Distance Specify the distance for external type 5 and type 7 routes. Your options are any
numeric value between 1 and 255.

Inter Area Distance Specify the inter area distance for inter-area routes using a value between 1 and
255.

Intra Area Distance Specify the intra area distance for intra-area routes using a value between 1 and
255.

Routing > OSPF > OSPF Description

Interface/PEP Properties

Area ID Specify the OSPF area ID for the NEs using an integer between the 0 and
4294967295.
The ID cannot be 0.0.0.0.

Interface Name Device’s interface with which the specified OSPF interface/pep settings must be
associated.

Interface cost Cost of sending packets across the network. This cost is used by OSPF routers to

calculate the shortest path.

Interface Priority Designated router for a subnet.

Network Type Type of network associated with the OSPF process. Your options are: Broadcast,
NBMA, Point to Point, and Point to Multipoint.
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Configure Static Routing .

Option Description

Dead Interval Number of seconds that will pass while an OSPF router’s packets are not visible
before its neighbors declare the router down. The Cisco default is 40 seconds.

Hello Interval Number of seconds between OSPF hello packet advertisements sent by OSPF
routers. The Cisco default is 10 seconds.

Retransmit Interval Time that will elapse before a packet is resent. The Cisco default is 5 seconds.

Transmit Delay Service speed. The Cisco default is 1 second.

Configure Static Routing

Step 1
Step 2
Step 3
Step 4
Step 5

Step 6

Static routing is the simplest form of routing, where the network administrator manually enters routes into a
routing table. The route does not change until the network administrator changes it. Static routing is normally
used when there are very few devices to be configured and the administrator is very sure that the routes do
not change. The main drawback of static routing is that a change in the network topology or a failure in the
external network cannot be handled, because routes that are configured manually must be updated to fix any
lost connectivity.

Choose Configuration > Network Devices.

Click the device hyperlink to launch its Device Details page.

Click the Logical View tab.

Choose Routing > Static.

To configure static routing, click Add.

a) Ifyouare adding an IPv4 static route, in the [Pv4 Static Routes area, click the Add (+) icon. Enter the required details
in the following fields:

Destination Network, Network Mask, Next Hop IP, Outgoing Interface, Permanent Route, or Administrative Distance.

b) Ifyou are adding an IPv6 static route, in the IPv6 Static Routes area, click the Add (+) icon. Enter the required details
in the following fields:

Destination IPv6 Prefix, Prefix Length, Next Hop IPv6 Address, Outgoing interface, Administrative Distance, Cast
Type, or Tag Value.

Click Save.

Configure ACLs

The Configuration tab in the Device Details page lists the current CFM configuration on the device. Depending
on your device configuration and user account privileges, you can configure ACLs on the device.

To configure ACLs:

Configure Devices .
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. Configure Segment Routing

Step 1
Step 2
Step 3
Step 4
Step 5

Step 6
Step 7

Step 8

Step 9

Choose Configuration > Network Devices.

Click the device hyperlink to launch its Device Details page.
Click the Logical View tab.

Choose Security > ACL.

Specify the following parameters for the ACL:

a)

b)

<)

Name/Number- Specify a unique identifier for the ACL. You can use alphanumeric characters, hyphens, and
underscores.

Type- Specify whether the ACL is of type standard or extended. This drop-down menu is hidden depending on the
type of device you select. For example, for Cisco IOS-XR devices this drop-down menu is hidden.

(Optional) Description- Enter a description about the ACL for reference.

Click Save to save your values in the Cisco EPN Manager. This does not deploy your changes to the device.

Click the drop-down icon next to the ACL created in the above steps and specify the following ACE values:

a)

b)
<)

Click Add Row to add a new ACE or select an existing ACE and click Edit, to specify the Action (Permit or Deny),
Source IP, Destination IP and optionally the wild card source, port information and description that must be associated
with the ACE.

Click Save to save the values associated with the ACE.

Use the up and down arrows (buttons) to specify the order in which the ACEs must be applied on the device for the
selected ACL.

Select the ACL created in the above steps and click Apply to Interface to specify the interface(s) on which this ACL
must be applied.

Click OK to deploy the specified ACL values to the selected interfaces of the device.

Configure Segment Routing

Segment routing (SR) uses the concept of source routing, where the source chooses a path, either explicit or
Interior Gateway Protocol (IGP) shortest path and encodes the path in the packet header as an ordered list of
segments. Segments are sub-paths that a router can combine to form a complete route to a network destination.
Each segment is identified by a segment identifier (SID) that is distributed throughout the network, using new
IGP extensions.

From the Cisco EPN Manager GUI, you can leverage the following Segment Routing sub-menu options to
configure Segment Routing parameters on your devices. You can also view or edit Segment Routing settings
that have been configured from the CLI.

* Configure Segment Settings

* Configure Routing Process

* Configure PCE Server

* Configure Path Computation Client (PCC)
* Configure Affinity

* Configure On-Demand Policy

. Configure Devices



| Configure Devices

Configure Segment Settings

Step 1
Step 2
Step 3
Step 4
Step 5

Step 6

Configure Segment Settings .

The following table lists the devices for which Segment Routing parameters can be configured from the UI,

along with their supported software versions.

Device Series & Types Software Versions

NCS 540 6.5.3,6.6.1,7.0.1,7.1.1
NCS 560 6.5.3,6.6.1,7.0.1,7.1.1
NCS 5500 6.5.3,6.6.1,7.0.1,7.1.1
ASR 9000 6.5.3,6.6.1,7.0.1,7.1.1

To configure the global settings for Segment Routing for the selected device:

Choose Configuration > Network Devices.

Select the device for which you want to configure the segment routing settings by clicking the device name hyperlink.

Click the Logical View from the tab on the left.
Choose Segment Routing > Segment Settings.

Under the General tab, click '+ to enter the required values and click Save. To edit an existing configuration, click the

corresponding hyperlink.

Attributes Description

Global Block Min The Segment Routing Global Block (SRGB) is a range of
label values preserved for segment routing in the label

Global Block Max switching database. The SRGB label values are assigned
as prefix segment identifiers (SIDs) to SR-enabled nodes
and are valid across the domain.
Enter a value between 16000 and 1048575.

Local Block Min The Segment Routing Local Block (SRLB) is a range of
label values preserved for the manual allocation of

Local Block Max

adjacency segment identifiers (adj-SIDs). These labels are
locally significant and are only valid on the nodes that
allocate the labels.

Enter a value between 15000 and 1048575.

Binding SID

Select a value from the drop-down list.

Maximum SID Depth

The number of SIDs supported by a node or by a link on a
node. Enter a value between 1 and 255.

Note Run the following command to clear the label discrepancy for SRGB or SRLB changes to take effect.

#clear segment-routing local-block discrepancy all

Under the Mapping Server tab, click '+' to enter the required values and click Save. Click Ok to confirm that you want
to push your changes to the device. To delete an existing configuration, select the corresponding checkbox and click *X".
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Attribute Description

IP Address Prefix Enter an IPv4 address.

Mask Enter the subnet mask details.

Address Family Choose the address family as [Pv4.

Start of SID Range Enter a value between 0 and 1048575.

Number of Allocated SIDs Enter a value between 0 and 1048575. The default value is
1.

Step 7 Under the Adjacency SID Mapping tab, click '+' to enter the required values and click Save. Click OK to confirm that
you want to push your changes to the device. To delete an existing configuration, select the corresponding checkbox and

click 'X".
Attribute Description
Interface Select a loopback interface from the dropdown list.
Address Family Choose the address family as IPv4.
Next Hop Address Enter an IPv4 address for the next hop.
SID Mapping Type Select either Absolute or Index as the mapping type.
SID Value The valid range for the SID value varies according to the
SID mapping type.
* For Index type — 0 to 1048575
* For Absolute type — 15000 to 1048575

Configure Routing Process

To configure Routing Process parameters for Segment Routing for the selected device:

Before you begin

Before configuring Routing Process parameters, ensure that you have configured OSPF or ISIS routing process
on the device from Logical View > Routing page. See Configure Routing Protocols and Security, on page

102 for more information.

N

Note Cisco EPN Manger does not support OSPFV3 protocol in Segment Routing.

Step 1 Choose Configuration > Network Devices.
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Step 2 Select the device for which you want to configure the parameters by clicking the device name hyperlink.
Step 3 Click the Logical View from the tab on the left.
Step 4 Click Segment Routing > Routing Process.

Step 5 Enter values for the attributes as necessary under each tab by clicking the corresponding hyperlink and click Save.
Tab Attributes Description
Properties Process ID This field is populated automatically
with the process ID configured on the
device.
Process Type This field is populated automatically

as ISIS or OSPF based on the
configuration on the device.

Global Block Min The default SRGB range is from 16000
to 23999. The values entered here will
Global Block Max override the global values configured

in Segment Settings.

Adpvertise Local Prefix SID Mapping | By default, this field is enabled

Override LDP Labels Select this check box to override LDP
labels.

Receive Remote Prefix SID Mapping | Select this check box to receive Remote
Prefix SID Mapping

Avoid Microloop Select this check box to avoid

microloop.
Connected Prefix SID Mapping Ip Address Prefix Enter an [Pv4 address

Mask Enter subnet mask details

SID Mapping Type Select either Absolute or Index
mapping type from the drop-down list.

SID Value The valid range for the SID value
varies according to the SID mapping
type.

* For Index type — 0 to 1048575

* For Absolute type — 16000 to

1048575
Flex Algorithm Enter Flex Algorithm value between
128 and 255. This field is grayed out if
Strict SPF is enabled.
Strict SPF Select the check box if required

Replace Prefix SID with Explicit Null | Select the check box if required
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Tab Attributes Description
Interface Prefix SID Mapping SID Mapping Type Select either Absolute or Index
mapping type from the drop-down list.
SID Value The valid range for the SID value
varies according to the SID mapping
type.

* For Index type — 0 to 1048575

* For Absolute type — 16000 to
1048575

Strict SPF Select the check box if required

Replace Prefix SID with Explicit Null | Select the check box if required

Note * For ISIS routing process, you can configure either connected prefix or local prefix. For OSPF Routing
process, only local prefix SID configuration is supported.

* For configuring local prefix SID, only loop back interfaces where IP is configured will be modeled under
Routing Process.

* For local prefix SID, the device supports the following configuration:
» prefix-sid index/absolute 100 explicit-null (prefix-sid without algorithm/strict-spf)
» prefix-sid algorithm 128 index /absolute 16000 (prefix-sid with algorithm)

* prefix-sid strict-spf index/absolute 200 explicit-null (prefix-sid with strict-spf)

Configure Path Computation Client (PCC)

To configure PCC client parameters for the selected device:

Before you begin

» PCC is a one-time configuration that must be discovered in advance in order to be presented and modified
in EPNM.

Sample configuration:
segment-routing
traffic-eng
pcc

* To receive PCC-peer events, the device should be enabled with pcep peer-status logging under
segment-routing traffic-eng logging.
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Step 1 Choose Configuration > Network Devices.

Step 2 Select the device for which you want to configure the parameters by clicking the device name hyperlink.
Step 3 Click the Logical View from the tab on the left.

Step 4 Click Segment Routing > PCC.

Step 5 Enter values for the attributes as necessary under each tab by clicking the corresponding hyperlink and click Save. Confirm
that you want to push your changes to the device by clicking OKk.

Tab Attribute Description
PCC Source Address Enter an IPv4 address.
Report All Select the check box to set this value
to True.
PCC Centric Model Select the check box to set this value
to True.
Session Dead time Measured in seconds.

Enter a value between 0 and 255.

Session Keepalive Time Measured in seconds.

Enter a value between 0 and 255. Enter
0 if you wish to disable this parameter.

Delegated Policy Up Time Measured in seconds.

Enter a value between 0 and 3600.
Enter 0 if you wish to disable this

parameter.
PCE Initiated Orphan State Time Enter a value between 15 and 14400.
PCE Initiated Policy Delegation Time | Enter a value between 10 and 180
seconds.
PCC’s Peer Database PCE Address Enter an IPv4 address.
Precedence Enter a number between 0 and 255 to

set precedence. 0 is the most preferred
and 255 is the least preferred..

Password Enter password (clear text password)
. and keychain details for client-server
Keychain authentication.

Configure PCE Server

To configure the selected device as a PCE server:
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Step 1 Choose Configuration > Network Devices.

Step 2 Select the device for which you want to configure the parameters by clicking the device name hyperlink.
Step 3 Click the Logical View from the tab on the left.

Step 4 Click Segment Routing > PCE Server.

Step 5 Click the "+ to enter required values and click Save. Confirm that you want to push your changes to the device by clicking
Ok.
Tab Attribute Description
PCE Sever IP Address Enter an IPv4 address.
State Sync Address Enter multiple IPv4 addresses separated
by a comma.
Keepalive Time Measured in seconds.

Enter a value between 0 and 255. The
default value is 30. Enter O to disable
this parameter.

Password Enter password (clear text) to
authenticate client-sever details.

Minimum Peer Keepalive Interval Measured in seconds.

Enter a numeric value between 0 and
255. The default value is 20. Enter 0 to
disable this parameter.

Strict SIDs Only Select the check box to enable this
option. This option is not enabled by
default.

Topology Reoptimization Interval Measured in seconds.

Enter a value between 600 to 86400.
The default value is 1800.

\)

Note Due to device and network limitations, you cannot delete a PCE Server once you've configured it.

Configure Affinity

To configure Affinity parameters for Segment Routing for the selected device:

Step 1 Choose Configuration > Network Devices.
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Step 2
Step 3
Step 4
Step 5

Configure On-Demand Policy .

Select the device for which you want to configure the parameters by clicking the device name hyperlink.
Click the Logical View from the tab on the left.
Choose Segment Routing > Affinity.

Click the "+" icon to enter the required values and click Save. Click OK to confirm that you want to push your changes
to the device. To edit click the corresponding hyperlink. To delete an existing configuration, select the corresponding
checkbox and click 'X'.

Tab Attribute Description

Affinity Affinity Name Enter a name for the Affinity attribute.
Bit Position Enter a value between 0 and 255.

Affinity Mapping Interface Name Select a loopback interface from the

dropdown list to associate an interface
to the Affinity. You must associate at
least one Affinity with an interface.

Affinity Name Select the Affinity to be associated with
the interface from the drop-down list.

You can associate multiple affinities to
a single interface.

Metric value Enter a value between 0 and
2147485647

Configure On-Demand Policy

Step 1
Step 2
Step 3
Step 4
Step 5

To configure On-Demand policy parameters for Segment Routing for the selected device, complete the
following steps:

Choose Configuration > Network Devices.

Select the device for which you want to configure the parameters by clicking the device name hyperlink.
Click the Logical View in the tab on the left.

Click Segment Routing > On-Demand Policy.

Click the "+' icon to enter the required values and click Save. Click OK to confirm that you want to push your changes
to the device. To edit, click the corresponding hyperlink. To delete an existing configuration, select the corresponding
check box and click 'X'".
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Tab Attribute Description
On-Demand Policy Template Color Enter a value between 1 and
4294901295.
Bandwidth Enter a value between 1 and

4294967295 in kbps.

Path type Select a value in the drop-down list.

Max SID Limit Enter a value between 1 and 255.

Metric Margin Mode Select a value in the drop-down list.

Metric Type Select a metric type in the drop-down
list.

Metric Margin Value Enter a value between 0 and
2147483647.

Flex Algorithm Color This field is automatically populated

with the value that is entered in
On-Demand Policy Template tab.

Flex Algorithm Enter Prefix-SID algorithm value
between 128 and 255.

Disjoint Path Color This field is automatically populated
with the value that is entered in
On-Demand Policy Template tab.

Group Id Enter a value between 1 and 65535.

Disjointness Type Use the drop-down list to choose a
value.

Sub Group Id Enter a value between 1 and 65535.

To configure Segment Routing policies, see Create and Provision Segment Routing Policies.

Configure EOAM Fault and Performance Monitoring

Cisco EPN Manager enables you to prepare the devices in your network for using EOAM (Ethernet Operations,
Administration and Management) protocol for monitoring and troubleshooting Carrier Ethernet services. You
can perform connectivity and performance tests on the Ethernet services using sets of CLI commands available
as predefined templates in Cisco EPN Manager.
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Configure CFM

CFM Overview

CFM configuration sets the stage for using the EOAM protocol to monitor and troubleshoot Carrier Ethernet
services. CFM can be configured on the EVC level when creating and provisioning an EVC, as described in
Create and Provision a New Carrier Ethernet EVC.

Once CFM is configured, you can quickly and easily view the CFM settings on individual devices.

IEEE Connectivity Fault Management (CFM) is an end-to-end per-service Ethernet layer Operations,
Administration, and Maintenance (OAM) protocol. CFM includes proactive connectivity monitoring, fault
verification, and fault isolation for large Ethernet metropolitan-area networks (MANs) and WANS.

CFM operates on a per-Service-VLAN (or per-EVC) basis. It lets you know if an EVC has failed, and if so,
provides the tools to rapidly isolate the failure.

A CFM-enabled network is made up of maintenance domains, CFM services and maintenance points, as
described below.

Figure 3: CFM Maintenance Domains
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Maintenance Domains

Ethernet CFM, within any given service provider network, relies on a functional model consisting of hierarchical
maintenance domains. A maintenance domain is a management space on a network that is owned and operated
by a single entity and defined by a set of internal boundary ports. A domain is assigned a unique maintenance
level which defines the hierarchical relationship of domains. Maintenance domains may nest or touch, but
cannot intersect. If two domains nest, the outer domain must have a higher maintenance level than the one it
engulfs. A single device might participate in multiple maintenance domains.
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CFM Services

A CFM service (maintenance association) enables the partitioning of a CFM maintenance domain according
to the connectivity within the network. For example, if the network is divided into a number of virtual LANs
(VLANSs), a CFM service is created for each of these. CFM can then operate independently in each service.
A CFM service is always associated with the maintenance domain within which it operates, and therefore
with that domain's maintenance level. All CFM frames relating to the service carry the maintenance level of
the associated maintenance domain. There can be many CFM services within a domain. The CFM service
must be configured on a domain before MEPs can be configured.

Maintenance Points

A maintenance point demarcates an interface that participates in a CFM maintenance domain. A maintenance
point is an instance of a particular CFM service on a specific interface. CFM only operates on an interface if
there is a CFM maintenance point on the interface. A maintenance point is always associated with a particular
CFM service, and therefore with a particular maintenance domain at a particular level. Maintenance points
generally only process CFM frames at the same level as their associated maintenance domain. Frames at a
higher maintenance level are always forwarded transparently, while frames at a lower maintenance level are
normally dropped. This helps enforce the maintenance domain hierarchy and ensures that CFM frames for a
particular domain cannot leak out beyond the boundary of the domain. There are two types of maintenance
points:

» Maintenance endpoints (MEPs)—Created at the edge of the domain. Responsible for confining CFM
messages within the domain. Maintenance end points (MEPs) are members of a particular service within
a domain and are responsible for sourcing and sinking CFM frames. They periodically transmit continuity
check messages and receive similar messages from other MEPs within their domain. They also transmit
traceroute and loopback messages at the request of the administrator.

* Maintenance intermediate points (MIPs)—Internal to the domain. A MIP will forward CFM packets
while MEPs do not forward CFM packets because they must keep them within the domain. MIPs are not
explicitly configured on each interface. MIPs are created automatically according to the algorithm
specified in the CFM 802.1ag standard.

View CFM Maintenance Domains and Maintenance Associations (Services)

Step 1
Step 2
Step 3
Step 4

To view CFM settings on a device:

Choose Inventory > Network Devices from the left sidebar.

Locate the required device in the list of devices and click the device name hyperlink to open the device details window.
Click the Logical View tab.

Choose EOAM > CFM.

Perform EOAM Connectivity and Performance Checks

Cisco EPN Manager provides predefined EOAM-related configuration templates that can be used to monitor
the connectivity and performance of virtual connections (VCs) in a Carrier Ethernet network.

To use these templates, from the left sidebar, choose Configuration > Templates > Features & Technologies,
then choose CLI Templates > System Templates — CLI.
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The following table lists the available EOAM configuration templates, their purpose, and the mandatory input
parameters you are required to provide.

\)

Note

To see the results and/or output of template deployment, check the job details that are displayed when

Table 14: EOAM Templates

you deploy a change.

Template Name

Use it to...

Essential Input Values

Additional
Information

EOAM-CCDB-Content-
10S

Display the contents of a
maintenance intermediate point
(MIP) continuity check database
(CCDB) in order to verify CFM
operation or to check how EOAM
has been set up in the network.

None of the fields are mandatory.

Domain ID: Choose the way in which you want to
identify the maintenance domain and enter a value
in the corresponding field.

Service: Specify a maintenance association within
the domain, based on ICC MEG identifier, VLAN
ID or VPN ID.

EOAM-CCDB-Content-
I0S-XR

Display the contents of a
maintenance intermediate point
(MIP) continuity check database
(CCDB) in order to verify CFM
operation or to check how EOAM
has been set up in the network.

None of the fields are mandatory.

Node ID: The CFM CCM learning database for the
designated node, entered in the rack/slot/module
notation.

EOAM-CFM-Ping-10S

Check connectivity to a destination
MIP or MEP using CFM loopback

Ping Destination Type: Identify the destination
MEP, either by MAC address or MEP ID. Choose

and messages. Multicast if there are multiple destination MEPs.
EOAM-CFM-Ping- . . L ]
JOS-XR Maintenance domain name for destination MEP:

The name of the domain where the destination MEP
resides.

EOAM-CFM-Traceroute-
10S

10S devices: Trace the route to a
destination MEP to check the
number of hops and the
connectivity between hops.

Destination Type: Identify the destination MEP,
by MAC address, MEP ID or explore options.

Maintenance domain name for destination MEP:
The name of the domain where the destination MEP
resides.

Service Type: Identify the maintenance association
(MA) within the domain, either by name, ITU carrier
code (ICC), MA number, VLAN ID, or VPN ID.
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Template Name

Use it to...

Essential Input Values

Additional
Information

IOS-XR

EOAM-CFM-Traceroute-

I0S-XR devices: Trace the route
to a destination MEP to check the
number of hops and the
connectivity between hops.

Maintenance domain name for destination MEP:
The name of the domain where the destination MEP
resides.

Service Name: The name of the service instance
being monitored by the Maintenance Association
(MA) within the specified maintenance domain.

Destination Type: Identify the destination MEP,
either by MAC address, MEP ID or explore options.

Source MEP ID: Identify the maintenance
association (MA) within the domain, either by name,
ITU carrier code (ICC), MA number, VLAN ID, or
VPN ID.

Source Interface Type: The source interface type
of the locally defined CFM MEP.

Interface Path ID: The physical or virtual interface
name.

I0S-XR

EOAM-Configure-Y-
1731-PM-On-Demand-
Operation-CFM-Loopback-

Configure an on-demand Ethernet
SLA operation for CFM loopback.
By default, measures two-way
delay and jitter.

Probe Domain: Check the checkbox to enable the
probe.

Domain Name: The name of the maintenance
domain for the locally defined CFM MEP.

Domain Interface Type: The source interface type
of the locally defined CFM MEP.

Domain Interface Path ID: The physical or virtual
interface name.

Domain MAC Address or MEP-ID: Choose
whether you want to identify the domain by MAC
address or by MEP ID and provide the necessary
information in the relevant field below. For MEP
ID, enter an ID from 1 to 8191.

Optionally, you
can specify the
type of
statistics to
measure,
whether or not
to use bins for
aggregate type,
probe
frequency and
duration
values, and
more. The
values you
specify will
override the
default actions.
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Template Name

Use it to...

Essential Input Values

Additional
Information

EOAM-Configure-Y-
1731-PM-On-Demand-
Operation-CFM-Synthetic-
Loss-Measurement-10S-
XR

Configure an on-demand Ethernet
SLA operation for CFM synthetic
loss measurement. By default,
measures one-way Frame Loss
Ratio (FLR) in both directions.

Probe Domain: Check the checkbox to enable the
probe.

Domain Name: The name of the maintenance
domain for the locally defined CFM MEP.

Domain Interface Type: The source interface type
of the locally defined CFM MEP.

Domain Interface Path ID: The physical or virtual
interface name.

Domain MAC Address or MEP-ID: Choose
whether you want to identify the domain by MAC
address or by MEP ID and provide the necessary
information in the relevant field below. For MEP
ID, enter an ID from 1 to 8191.

Optionally, you
can specify the
type of
statistics to
measure,
whether or not
to use bins for
aggregate type,
probe
frequency and
duration
values, and
more. The
values you
specify will
override the
default actions.

EOAM-Configure-Y-
1731-PM-On-Demand-
Operation-CFM-Delay-
Measurement-IOS-XR

Configure an on-demand Ethernet
SLA operation for CFM delay
measurement. By default,
measures one-way delay and jitter
in both directions, and two-way
delay and jitter.

Probe Domain: Check the checkbox to enable the
probe.

Domain Name: The name of the maintenance
domain for the locally defined CFM MEP.

Domain Interface Type: The source interface type
of the locally defined CFM MEP.

Domain Interface Path ID: The physical or virtual
interface name.

Domain MAC Address or MEP-1D: Choose
whether you want to identify the domain by MAC
address or by MEP ID and provide the necessary
information in the relevant field below. For MEP
ID, enter an ID from 1 to 8191.

Optionally, you
can specify the
type of
statistics to
measure,
whether or not
to use bins for
aggregate type,
probe
frequency and
duration
values, and
more. The
values you
specify will
override the
default actions.

Configure Devices .




. Configure Quality of Service (Q0S)

Configure Devices |

Template Name

Use it to...

Essential Input Values

Additional
Information

EOAM-Configure-Y-
1731-PM-Direct-On-
Demand-IOS

Perform real-time troubleshooting
of Ethernet services in direct mode
where an operation is created and
run immediately.

Frame Type: The type of frame, either DMMv1
(frame delay) or SLM (frame loss).

Domain Name: The name of the maintenance
domain for the locally defined CFM MEP.

EVC or VLAN: Identify the EVC or VLAN on
which the test will be performed. The VLAN ID can
be between 1 and 4096.

Target MPID or MAC Address: Identify the MEP
at the destination, either by MPID (1 to 8191) or by
MAC Address.

CoS Value: The class of service level (0-7) that will
be applied to the CFM message for the specified
MEP.

Local MPID or MAC Address: Identify the MEP at
the source, either by MPID (1 to 8191) or by MAC
Address.

Burst or Continuous: Specify whether a continuous
stream of frames or bursts of frames will be sent
during the on-demand operation.

Aggregation Period: Specify the length of time in
seconds during which the performance
measurements are conducted, after which the
statistics are generated (1-900).

EOAM-Configure-Y-
1731-PM-Referenced-On-
Demand-I10S

Perform real-time troubleshooting
of Ethernet services in referenced
mode where a previously
configured operation is started and
run.

Frame Type: The type of probe, either DMMv1 or
SLM.

Operation Number: The number of the operation
being referenced.

Remove-CFM-MEP-10S

Remove the MEP configuration
from the device.

Interface Name, Service Instance Number, EVC
Name.

Remove-CFM-MEP-
IOSXR

Remove the MEP configuration
from the device.

Interface Name, Domain Name.

Remove-CFM-
Service-IOS

Remove the CFM service.

Interface Name, Service Instance Number, EVC
Name, Domain Name, Level, Service Name.

Configure Quality of Service (QoS)

Quality of Service (QoS) is a set of capabilities that allow the delivery of differentiated services for the network
traffic. QoS features provide better and more predictable network service by:
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* Giving preferential treatment to different classes of network traffic.
* Supporting dedicated bandwidth for critical users and applications.
* Controlling jitter and latency (required by real-time traffic).

* Avoiding and managing network congestion.

* Shaping network traffic to smooth the traffic flow.

* Setting traffic priorities across the network.

Using Cisco EPN Manager you can configure QoS on Carrier Ethernet interfaces. Before the appropriate QoS
actions can be applied, the relevant traffic must be differentiated by creating classification profiles, or class
maps. Packets arriving at the device are checked against the match criteria of the classification profile to
determine if the packet belongs to that class. Matching traffic is subjected to the actions defined in an action
profile, or policy map.

N

Note There is no QoS support for all the IOT services.

To configure classification profiles and action profiles, choose Configuration > QoS > Profiles in the left
sidebar.

This section includes the following topics:
* Create a QoS Classification Profile, on page 125
* Create a QoS Action Profile, on page 128
* Check Which QoS Profiles are Configured on a Device, on page 133
* Apply a QoS Action Profile to Interface(s), on page 133
* Import QoS Profiles Discovered from Devices, on page 134
* Dissociate a QoS Action Profile from Multiple Interfaces, on page 135

* Delete QoS Classification and Action Profiles from Devices, on page 135

Create a QoS Classification Profile

Step 1
Step 2
Step 3

Step 4

Create classification profiles (class maps) to differentiate traffic into different classes so that certain actions
can be applied to traffic that matches the classification criteria.

To create a classification profile:

Choose Configuration > QoS > Profiles in the left sidebar.
Click the Add (“+”) icon at the top of the Global QoS Classification Profiles pane.

Enter a unique name for the classification profile. The name should reflect the classification criteria defined in the
profile for easy identification. For further clarification, you can add a description.

Define the matching criteria for the profile:

» Match All—All the classification criteria must be met in order for the traffic to belong to this class.
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Step 5
Step 6

Configure Devices |

* Match Any—Any of the classification criteria can be met in order for the traffic to belong to this class.

Under QoS Classifications, click the plus icon to define classification criteria for the classification profile.

Select an action based on which the traffic will be classified, then click in the Value column and provide the relevant

value, as follows:

Action

Description

Value

ACL

The packet must be permitted by the specified
access control list (ACL).

The name of the ACL. A string of up to
32 alphanumeric characters.

MPLS - Imposition

The experimental (EXP) bit value on the imposed
label entry of the packet must match the MPLS
EXP value that you specify. Use either the MPLS
Imposition or the MPLS Topmost for matching
criteria. Once you have used one of the MPLS
criteria, the other one will no longer be available.

A number from 0 to 7. Up to 8
comma-separated values can be entered.

MPLS - Topmost

The experimental (EXP) bit value in the topmost
label must match the MPLS EXP value that you
specify.

A number from 0 to 7. Up to 8
comma-separated values can be entered.

Cascade This action is used to cascade one class map into | Reference the child class map.
another. It can be used when creating a new class
map which has classification policies similar to an
existing class map.
QoSClassification - The packet’s layer 2 class of service (CoS) bit value | A number from 0 to 7. Up to 8
COS must match the specified CoS value. comma-separated values can be entered.
QoSClassification - The specified value must match packet’s inner CoS | A number from 0 to 7. Up to 8
COS - Inner value of QinQ packets for Layer 2 class of service | comma-separated values can be entered.
(CoS) marking.
QoSClassification - The packet IP differentiated service code point Valid values are from 0 to 63. Up to 8
DSCP (DSCP) value must match one or more of the comma-separated values can be entered.
specified values.
QoSClassification - Match DSCP values for IPv4 packets. Valid values are from 0 to 63. Up to 8
DSCP - IPv4 only comma-separated values can be entered.
QoSClassification - The packet IP precedence value must match one or | A number from 0 to 7. Up to 8
Precedence more precedence values. comma-separated values can be entered.
QoSClassification - Match precedence values for IPv4 packets. A number from 0 to 7. Up to 8
Precedence - IPv4 only comma-separated values can be entered.
QoSClassification - Drop eligible indicator (DEI) is used to indicate |0 or 1.
DEI frames eligible to be dropped when there is

congestion. The packet must match the DEI value
specified.
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Step 7
Step 8

Step 9
Step 10

Step 11

Step 12
Step 13

Create a QoS Classification Profile .

Action Description Value
QoS-Group The packets must be permitted based on the selected | Up to 8 comma separated unique values
QoS group. ranging from or 0-55 or 0-99 or 0-511
based on the selected device. Ensure that
the value you enter is supported on the
device.
QoSClassification - Service Provider configurations have various Accepts any number of comma separated

Service Instance

service instances on the Provider Edge (PE) routers.
QoS policy-maps are applied on these service
instances or group of service instances.

values ranging from 1-8000 and/or
hyphenated value with each ranging from
1-8000.

Note This criteria is applicable only on Cisco
ASR 903.
QoSClassification - Match and classify traffic on the basis of the virtual | Accepts any number of comma separated
VLAN local-area network (VLAN) identification number. | values ranging from 1-4095 and/or
Note Click the + icon to add more than one lllfff(};;gated value with each ranging from
QOS Classification - VLAN and specify '
values.
QoSClassification - Match and classify traffic on the basis of the inner | Accepts any number of comma separated
VLAN - Inner virtual local-area network (VLAN) identification |values ranging from 1-4095 and/or
number. hyphenated value with each ranging from
Note Click the + icon to add more than one 1-4095.
QOS QOS classifcation -VLAN- inner
lines and specify values.
QoSClassification - Indicates that packets must be permitted/discarded | Accepted value is any number between
Discard Class based on the selected discard class. 0-7.
QoSClassification - Traffic class of the QoS configuration. Accepted value is any number between
Traffic Class 0-7.

Define additional QoS classifications, as required.

Click the Save button at the bottom of the window to save the profile. A notification in the bottom right corner will
confirm that the profile has been saved and the profile will appear in the list of profiles on the left.

Select the profile from the list and click the Deploy button to initiate deployment of the profile to devices.

If you want to create a new profile with the details of an existing Classification Profile , click the Clone button. This
profile will have the name of the classification profile that you cloned from, and the suffix -clone. You can edit the
name, matching criteria and any other details of this cloned profile.

If you want the selected profile to override any other class map that already exists on the device, check the Override
existing configuration check box. If this check box is not checked, the profile will be merged with the configurations

on the device.

Select the device(s) to which you want to deploy the QoS Classification profile.

Schedule the deployment, if required.
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Step 14

Click Submit. A notification in the bottom right corner will confirm that the profile has been deployed. To check the
status of the deployment job, choose Administration > Job Dashboard from the left sidebar. Select the relevant job
to view the job details and history in the lower section of the window. Click the Information icon for further details.

Create a QoS Action Profile

Step 1
Step 2
Step 3
Step 4
Step 5

Step 6

Create action profiles (policy maps) to specify the actions to be applied to traffic belonging to a specific traffic
class.

To create an action profile:

Choose Configuration > QoS > Profiles from the left sidebar.

From the QoS Profiles pane on the left, choose, User Defined Global QoS Profiles > Action Profiles.
Click the Add (“+”) icon at the top of the Create Action Profile pane

Enter a unique name for the action profile, and enter a description, if required.

Select the classification profiles for which you want to assign actions. Under Classification Profiles, click the plus icon,
select the required profile(s) from the list, and click OK.

Select the Classification Profile (class map) and define the actions to be applied if traffic matches the profile. You can
define Policing, Marking, Queuing, Shaping, RED actions, and Service Policy (H-QoS). There is a tab for each of these
action types and its definitions, as follows:

* Policer Action: Traffic policing manages the maximum rate of traffic allowed on an interface through a token
bucket algorithm. Traffic policing also provides a certain amount of bandwidth management by allowing you to
set the burst size (Bc) for the CIR. When the peak information rate (PIR) is supported, a second token bucket is
enforced and this two-rate policer can meter traffic at two independent rates: the committed information rate (CIR)
and the peak information rate (PIR). The committed token bucket can hold bytes up to the size of the committed
burst (bc) before overflowing and determines whether a packet conforms to or exceeds the CIR. The peak token
bucket can hold bytes up to the size of the peak burst (Be) before overflowing, and determines whether a packet
violates the PIR. Different actions can be taken if a packet conforms, exceeds, or violates the CIR/PIR. For instance,
packets that conform can be configured to be sent, packets that exceed can be configured to be sent with a decreased
priority, and packets that violate can be configured to be dropped.

In the Policer Action tab, specify the following:

* Committed Information Rate (CIR)—The long-term average transmission rate, specified in bits per second
(bps) or as a percentage of the available or unused bandwidth. Traffic that falls under this rate will always
conform. Ensure that the CIR value you enter is supported on the device and choose the right CIR unit value
(bps, kbps, mbps, gbps, or percent).

* Burst (Bc)—How large traffic bursts can be (in bytes) before some traffic exceeds the CIR.

* Peak Information Rate (PIR)—How much traffic bursts can peak before some traffic exceeds the PIR value
associated with the CIR. Ensure that the PIR value you enter is supported on the device and choose the same
unit value you chose for CIR (bps, kbps, mbps, gbps, or percent).

* Excess Burst (Be)}—How large traffic bursts can be (in bytes) before traffic exceeds the PIR.

* Under Traffic Coloring Behavior, select the action to be performed if the traffic conforms, exceeds, or violates
the rate limit. Provide values as required. To enable color-aware traffic policing specify the Conform Color
and Exceed Color values by associating them with respective class profiles. With color-aware policing, the
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following results occur based on the CIR, the PIR, and the conform actions, exceed actions, and violate
actions:

* Packets that have metering rates less than or equal to the CIR and belong to the specified class
(conform-color) are policed as conforming to the rate. These packets are also policed according to the
conform action specified. In this instance, the packets will be transmitted.

* Packets that have metering rates between the CIR and the PIR and belong to either to the conform-color
class or exceed-color class are policed as exceeding the CIR. These packets are also policed according
to the exceed action specified. In this instance, the precedence value of the packets will be set and the
packets transmitted.

* Packets that have metering rates higher than the PIR or belong to neither class conform-color or class
exceed-color are policed as violating the rate. These packets are also policed according to the violate
action specified. In this instance, the packets will be dropped.

» Marker Action: Packet marking allows you to partition your network into multiple priority levels or classes of
service. Marking of a traffic flow is performed by:

* Setting IP Precedence or DSCP bits in the IP Type of Service (ToS) byte .
* Setting CoS bits in the Layer 2 headers.
* Setting EXP bits within the imposed or the topmost Multiprotocol Label Switching (MPLS) label.

* Setting qos-group, traffic-class, and discard-class bits.

In the Marker Action tab, specify the following:

» Marking Feature and Marking Value—The method by which the traffic will be marked, and the required
value.

* Queueing Action: Queueing is used for traffic congestion management. It entails the creation of queues, assignment
of packets to those queues based on the classification of the packet, and scheduling of the packets in a queue for
transmission.

In the Queueing Action tab, select the method by which traffic will be queued, either Bandwidth or Priority, then
specify the following:

» Bandwidth—The amount of bandwidth to be assigned to the traffic class, either in kilobits per second, or as
a percentage of absolute guaranteed bandwidth. If you selected to queue by bandwidth, you can also assign
bandwidth as a percentage of remaining bandwidth.

* Queue Limit— The maximum number of packets/bytes/milliseconds for all the individual queues associated
with this class. When the queue size exceeds this value, packets will be dropped.

If you selected Bandwidth, specify the following:

* Enable Fair Queue—Check the check box to enable weighted fair queueing

* Individual Queue Size—Relevant if fair queueing is enabled. Specify the maximum number of packets allowed
in each per-class queue during periods of congestion.

If you selected Priority, specify the following:
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* Queue Burst Size (bytes)—The burst size configures the network to accommodate temporary bursts of traffic.
Range is 18 to 2000000 bytes. Default is 200 milliseconds of traffic at the configured bandwidth rate.

* Priority Level—Classes under a policy map can have different priority, from priority queue level 1 to 3.
Packets on these queues are subjected to less latency with respect to other queues. You cannot specify the
same priority level for two different classes in the same policy map.

« Shaping Action: Traffic shaping regulates traffic by shaping it to a specified rate.
In the Shaping Action tab, specify the following:

* Select Average or Peak rate traffic shaping—Average rate shaping limits the transmission rate to the CIR.
Peak rate shaping configures the router to send more traffic than the CIR. To determine the peak rate, the
router uses the following formula: peak rate = CIR(1 + Be / Bc) where Be is the Excess Burst size and Bc is
the Committed Burst size.

* If you selected Peak rate traffic shaping, specify the burst size and the excess burst size in bytes.

* If required, enable FECN Adaptive Shaping. Adaptive shaping estimates the available bandwidth when
backward explicit congestion notification (BECN) signals are received. With FECN adaptive shaping, the
router reflects forward explicit congestion notification (FECN) signals as BECN signals.

 If FECN Adaptive Shaping is enabled, specify the Adaptive Rate, which is the minimum bit rate to which
the traffic is shaped.

* RED Action: Weighted Random Early Detection (WRED) is a congestion avoidance technique that implements
a proactive queuing strategy that controls congestion before a queue reaches its queue limit. WRED combines the
capabilities of the random early detection (RED) mechanism with IP precedence, differential services code point
(DSCP), and discard-class to provide preferential handling of higher priority packets. When an interface starts to
become congested, WRED discards lower priority traffic with a higher probability. WRED controls the average
depth of Layer 3 queues.

In the RED Action tab, specify the following:

* Classification Mechanism—Select the basis upon which the WRED drop policies are defined. For WRED,
you define drop policies based on specific packet classification, as follows:

CLP—Configures a drop policy for WRED based on a cell loss priority (CLP) value. Valid values are 0 or
L.

CoS—Configures a drop policy for WRED based on the specified class of service (CoS) bit associated with
the packet. Valid values are from 0 to 7.

Discard Class—Configures a drop policy for WRED based on a discard-class value. Valid values are from
0 to 7. The discard-class value sets the per-hop behavior (PHB) for dropping traffic. WRED based on
discard-class is an egress function.

DSCP—Configures a drop policy for WRED based on a DSCP value. When configured, the router randomly
drops packets with the specified DSCP value, according to the WRED thresholds you configure.

Precedence—Configures a drop policy for WRED based on an IP precedence level. Valid values are from 0
to 7, where 0 typically represents low priority traffic that can be aggressively managed (dropped) and 7
represents high priority traffic. Traffic at a low precedence level typically has a higher drop probability. When
WRED drops packets, source hosts using TCP detect the drops and slow the transmission of packets.

DEI—The discard eligibility (DE) bit in the address field of a frame relay frame is used to prioritize the
discarding of frames in congested frame relay networks. The frame relay DE bit has only one bit and therefore
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only has two settings, 0 or 1. If congestion occurs in a frame relay network, frames with the DE bit set at 1
are discarded before frames with the DE bit set at 0.

RED Default—The default set of minimum thresholds, maximum thresholds, and Mark Probability
Denominator (MPD) settings for a class in the WRED profile.

* If required, enable ECN. ECN (Explicit Congestion Notification) marks packets instead of dropping them
when the average queue length exceeds a specific threshold value. Routers and end hosts use this marking
as a signal that the network is congested and slow down packet transmission.

* Define the thresholds and mark probability per valid value of the selected classification mechanism. For
example, if you are using Precedence, you can define thresholds for each of the 7 valid values. The minimum
threshold is the minimum number of packets allowed in the queue. When the average queue length reaches
the minimum threshold, WRED randomly drops some packets with the specified DSCP, IP precedence,
discard-class, or atm-clp value. Valid minimum threshold values are from 1 to 16,384. The maximum threshold
is the maximum number of packets allowed in the queue. When the average queue length exceeds the maximum
threshold, WRED drops all packets with the specified DSCP, IP precedence, discard-class, or atm-clp value.
Valid maximum threshold values are from the value of the minimum threshold to 16,384.

* Service Policy:

Using the Service Policy tab, you can configure Hierarchical QoS (H-QoS) which enables you to specify QoS
behavior at multiple levels of hierarchy. You can use H-QoS to specify multiple policy maps to shape multiple
queues together. All hierarchical policy types consist of a top-level parent policy and one or more child policies.
The service-policy command is used to apply a policy to another policy, and a policy to an interface.

To configure H-QoS, navigate to the Service Policy tab, select the Enable check box, and use the Service Policy
drop-down menu to select the child service policy. The selected child service policy will be associated to the parent
policy map that this action profile belongs to. Note that a child service policy cannot act as a parent policy of the
same policy map. For example, if a child service policy called X belongs to a parent policy map Y, then the child
policy X cannot contain the service policy map Y.

H-QoS Limitations: On Cisco I0S-XE devices such as Cisco ASR903, Cisco ASR907, Cisco ASR920, and Cisco
NCS42XX, the following H-QoS limitations are applicable:

* Parent policy map limitations:
* A parent policy map can be created only using the 'class-default' class.
* The parent policy map must contain a class with matching criterion such as an EFP (service instance).

* The parent policy map must contain a class with matching criterion such as VLANSs.

* Child policy map limitations:

* Child policy maps cannot be created with EFP (service instance) and VLAN as the match-type.

Step 7 Click the Save button at the bottom of the window to save the profile. A notification in the bottom right corner will
confirm that the profile has been saved and the profile will appear in the list of profiles on the left.
Step 8 From the Global QoS Action Profiles pane, select the profile, and click the Deploy button to initiate deployment of the

profile to devices.

Step 9 If you want to create a new profile with the details of an existing Action Profile , click the Clone button. This profile
will have the name of the action profile that you cloned from, and the suffix -clone. You can edit the name, actions and
any other details of this cloned profile.
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Step 10 If you want the selected profile to override any other policy map that already exists on the device, check the Override
existing configuration check box. If this check box is not checked, the profile will be merged with the configurations
on the device.

Step 11 Select the device(s) to which you want to deploy the QoS Action profile.
Step 12 Schedule the deployment, if required.
Step 13 Click Submit. A notification in the bottom right corner will confirm that the profile has been deployed. To check the

status of the deployment job, choose Administration > Job Dashboard from the left sidebar. Select the relevant job
to view the job details and history in the lower section of the window. Click the Information icon for further details.

Create a QoS Sub-Action Profile

An action profile (policy map) specifies the actions to be applied to traffic belonging to a specific traffic class.
They are associated with multiple Classification Profiles that define the actions to be applied if traffic matches
the profile. You can define Policing, Marking, Queuing, Shaping, RED actions, and Service Policy (H-QoS).

Sub-action profiles are action profiles that are associated with only a single classification profile. You can

use sub-action profiles during circuit/VC provisioning to associate a singular action based action profile with
the Circuit/VC.

To create a sub-action profile:

Step 1 Choose Configuration > QoS > Profiles from the left sidebar.

Step 2 From the QoS Profiles pane on the left, choose, User Defined Global QoS Profiles > Sub-Action Profiles.

Step 3 Click the Add (“+”) icon at the top of the Create Sub-Action Profile pane

Step 4 Enter a unique name for the sub-action profile, and optionally enter a description.

Step 5 Select the classification profile for which you want to assign actions. Under Classification Profiles, click the plus icon,
select the required profile from the list, and click OK.

You can add only a single classification profile to a sub-action profile. To associate multiple classification profiles, you
must create an action profile.

Step 6 Specify the required actions that need to be taken when the traffic matches the criteria specified in the classification
profiles. For a description of the various options, see, Create a QoS Action Profile, on page 128.

Import and Export QoS Action and Sub-Action Profiles

Step 1 Choose Configuration > QoS > Profiles from the left sidebar.
Step 2 To export Action Profiles, choose, User Defined Global QoS Profiles > Action Profiles from the pane on the left.
Step 3 To export Sub-Action Profiles, choose, User Defined Global QoS Profiles > Sub-Action Profiles from the pane on the

left.

Step 4 To export profiles, select the profiles that you want to export and click Export. The files are saved in the location that
you specify.

Step 5 To import profiles, click Import, choose the XML files (that contain information about the action or sub-action profiles)

that you want to import, and click OK. The imported profiles are listed under the Action Profiles or Sub-Action Profiles
pages respectively.

. Configure Devices



| Configure Devices

Check Which QoS Profiles are Configured on a Device .

Please note:

* Although there is no limit to the number of profiles you can import in a single instance, we recommend that you
choose a maximum of 10 profiles to ensure optimal performance.

* Ensure that the size of the file you want to import is below 20 MB.

* Files of only xml format can be imported.

Check Which QoS Profiles are Configured on a Device

Step 1
Step 2
Step 3
Step 4

To see the QoS profiles that have been deployed to a specific device:

Choose Inventory > Network Devices from the left sidebar.
Locate the required device and click on the device name hyperlink to display the device details.
Click the Logical View tab.

Click on the arrow next to QoS in the left pane, and select either Action Profiles or Classification Profiles. A table
listing the profiles that have been deployed to the selected device is displayed. Click on the profile name (blue hyperlink)
to display the details of the profile.

Apply a QoS Action Profile to Interface(s)

Step 1

Step 2
Step 3

You can select an action profile deployed to a device and apply it to multiple interfaces on that device. An
action profile enables you to specify the actions to be applied to traffic belonging to a specific traffic class.
Before applying an existing profile to interfaces, you can modify the profile or use it to create a new profile.
When you choose an interface that has an action profile already applied to it, Cisco EPN Manager notifies
you about it and enables you to override the existing profile. To be able to apply an action profile to interfaces,
you first need to ensure that the required profile has been deployed to the device. To do this, see Create a QoS
Action Profile, on page 128.

To apply an action profile to interfaces:

Choose Configuration > QoS > Interfaces from the left sidebar.

Cisco EPN Manager interfaces are displayed under the categories Ethernet CSMA/CD, IEEE8023 ADLAG, Gigabit
Ethernet, and L2 VLAN. All other ports are displayed under the User Defined category.

Select the interfaces that you want to associate to an Action profile.

Click Associate Action Profile to select the action profile and to set the direction in which it must be applied. The
available action profiles list and the interfaces it can be applied to are listed. The interfaces are listed by their name,
application direction, and the action profiles that already exist on the interface.

Note QoS scaling profile configuration is the prerequisite to associate action profiles for Bundle-ethernet interfaces
and subinterfaces. Configuration example:

hw-module profile gos bundle <high-scale|medium-scale|low-scale> location <card>

Configure Devices .
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. Import QoS Profiles Discovered from Devices

Step 4

Step 5

Step 6

Step 7

Select the required action profile from the Action Profiles drop-down menu. If the menu is empty, you need to create
action profile and then try to associate them with devices. See, Create a QoS Action Profile, on page 128.

In the Interfaces section, specify the direction in which the profile is to be applied. While applying a profile to a
subinterface, ensure that it is applied in a direction opposite to that of the main interface. To change the applied direction,
use the Edit icon at the top left corner of the dialog.

Note Policy Maps that contain queuing actions cannot be applied to interfaces in Ingress direction.

(Optional) You can also schedule the application of the selected action profile to a later date and time. To do this, expand
the Schedule section and specify the date and time and frequency for when you the profile to be applied. This task can
further be edited on the Jobs page if required.

Click OK to apply the action profile to the selected devices. A notification at the bottom right corner of the dialog will
confirm whether the profile has been successfully applied or if the job failed. Click the Show Details link for more
information.

To dissociate action profiles from the interfaces they are applied to, see Dissociate a QoS Action Profile from Multiple
Interfaces, on page 135

Import QoS Profiles Discovered from Devices

Step 1
Step 2
Step 3

Step 4

You can import QoS profiles discovered from the device directly into Cisco EPN Manager. Once the QoS
profiles are imported, they can be edited and further configured on the device using Cisco EPN Manager.
Profiles which are discovered from the device with profile names that match other profiles already present in
Cisco EPN Manager are represented as Global profiles. This is indicated in the Global column in the Global
Profiles page. Note that Global profiles could have the same names but different QoS configuration. While
importing global profiles, you can choose to either overwrite the existing profile (with the same name) using
the discovered profile or you can rename the profile before you import it.

To import QoS profiles discovered from devices:

Before you begin

Ensure that the device's Inventory Collection status is Completed. This ensures that the QoS profiles from the
devices are discovered by Cisco EPN Manager.

Choose Configuration > QoS > Profiles from the left sidebar to display all Cisco EPN Manager QoS profiles.

To import Action profiles, from the QoS Profiles pane on the left, choose, Discovered Profiles > Action Profiles.

To import Classification profiles, from the QoS Profiles pane on the left, choose, Discovered Profiles > Classification
Profiles.

To first select a device and choose the profiles discovered on that device:

a) Choose Configuration > Network Devices, and select the device by clicking the device's Name hyperlink.

b) Click the Logical View tab.

¢) Expand QoS.

d) Choose Action Profiles or Classification Profiles based on the type of profile you want to import from the device.

e) (Optional) After viewing the profiles, to import these profiles directly from the page that lists all QoS profiles
discovered by Cisco EPN Manager, click the Global Profile Page hyperlink, and skip to Step 5.

f) Select the profiles and click Make Global.
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Step 5
Step 6

Step 7

Step 8

Dissociate a QoS Action Profile from Multiple Interfaces .

g) Goto Step 6.
Select the profiles that you want to import and click Import. To ensure that you are importing profiles that are not already
present on the device, choose profiles that are not Global (marked as No in the Global column).

If there are duplicate profiles present in Cisco EPN Manager, you are asked to either rename the profile to create a profile
with a new name and the same QoS configuration or overwrite the existing profile. Make the required changes.

If you want to create a new profile with the details of an existing QoS Profile , click the Clone button. This profile will
have the name of the QoS profile that you cloned from, and the suffix -clone. You can edit any details of this cloned
profile.

Click Save to import the selected QoS profiles.

To apply the imported profiles to a given device's interfaces, see, Apply a QoS Action Profile to Interface(s), on page
133.

Dissociate a QoS Action Profile from Multiple Interfaces

Step 1

Step 2
Step 3
Step 4

Step 5

An action profile enables you to specify the actions to be applied to traffic belonging to a specific traffic class.
You can select an action profile deployed to a device and apply it to multiple interfaces on that device. After
you have applied the profile to the interfaces, you can choose to dissociate them from those interfaces if
required. To dissociate an action profile from interfaces, you first need to ensure that the required profile has
been applied to the device. See Apply a QoS Action Profile to Interface(s), on page 133.

To apply an action profile to interfaces:

Choose Configuration > QoS > Interfaces from the left sidebar.

Alternatively, you can navigate to Configuration > QoS > Profiles to first select the profile before dissociating it from
the interfaces it is applied to.

Cisco EPN Manager interfaces are displayed under the categories Ethernet CSMA/CD, IEEE8023 ADLAG, and L2
VLAN. All other ports are displayed under the User Defined category.

Select the interfaces from which you want to dissociate the action profile.
Click De-associate Action Profile.

(Optional) You can also schedule the de-association of action profiles to a later date and time. To do this, expand the
Schedule section and specify the date, time, and frequency based on which the profiles must be dissociated.

Click OK to confirm. The selected interfaces are dissociated from the action profiles that were applied to them. A
notification at the bottom right corner of the window will confirm whether the profile has been successfully dissociated
or if the job failed. Click the Show Details link for more information.

Delete QoS Classification and Action Profiles from Devices

To delete QoS classification and action profiles that are deployed to devices, navigate to the paths listed in
the table below.
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Configure Devices |
. Delete QoS Classification and Action Profiles from Devices

\)

Note  You cannot delete QoS action and classification profiles discovered directly from the device. Only
profiles created using (and imported into) Cisco EPN Manager can be deleted.

In order to avoid deletion of referenced profiles, the delete operation is not supported in the following scenarios:

* You cannot delete QoS classification profiles associated with other classification profiles. For example
if a classification profile uses the Cascade option to reference the selected classification profile, then the
delete operation for the selected profile will fail.

* You cannot delete a QoS classification profiles referenced by an action profile.
* Action profiles successfully applied to device interfaces cannot be deleted.

* An action profile cannot be deleted if it is referenced by another action profile. For example, if action
profiles are associated to other action profiles by use of a reference policy, then the delete operation of
such action profiles fails.

Table 15: Navigation paths to delete QoS action and classification profiles

Task Steps in the GUI

Delete user defined classification |1. Choose Configuration > QoS > Classification Profiles.

profiles . . .
2. Select the classification profile you want to remove from the devices

as well as from Cisco EPN Manager.
3. Click the X (delete) icon in the task bar.

4. Alternatively, you can click the device hyperlink to choose the
devices from which the selected classification profile must be
deleted.

5. Click Submit. You can view the status of the delete operation by
clicking the Job Details pop up window.

Delete user defined action profiles | 1. Choose Configuration > QoS > Action Profiles.

2. Select the action profile you want to remove from the devices as
well as from Cisco EPN Manager.

3. Click the X (delete) icon in the task bar.

4. Alternatively, you can click the device hyperlink to choose the
devices from which the selected action profile must be deleted.

5. Click Submit. You can view the status of the delete operation by
clicking the Job Details pop up window.
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Save Your Device Changes .

Save Your Device Changes

After you make a change to a device, save your changes to the database and, if desired, collect the device's
physical and logical inventory. See these topics for more information:

* Save Device Configuration Changes to the Database (Update), on page 137

* Collect a Device's Inventory Now (Sync), on page 137

Save Device Configuration Changes to the Database (Update)

After making a change to your devices, you should save those changes to the database by clicking Update in
the configuration window. If an Update button is not provided, perform a manual sync which will save your
changes, but also collect the device's physical and logical inventory and save it to the database. See Collect
a Device's Inventory Now (Sync), on page 137

Collect a Device's Inventory Now (Sync)

The Sync operation performs an immediate inventory collection for a device. When it performs a Sync, Cisco
EPN Manager collects the selected device's physical and logical inventory and synchronizes the database with
any updates. If you do not perform a Sync operation after making a change to a device, your change will not
be saved to the database until the daily inventory collection.

)

Note The Sync operation is different from the Update operation. Update saves configuration changes without
performing an inventory collection. If you want to use Update instead of Sync, see Save Device
Configuration Changes to the Database (Update), on page 137.

N

Note This Sync operation is different from working with out-of-sync device configuration files. An out-of-sync
device is a device that has a startup configuration files that is different from its running configuration
file. For more information, see Synchronize Running and Startup Device Configurations.

Use one of these methods to perform a manual Sync.

To collect the Do the following:
inventory for:

A single device * From the device's Device 360 view, choose Actions > Sync Now.

Note You can view the status of the sync operation on the device. For more
information, see Device Sync State, on page 138.

* From the Network Devices table, check the device's check box, then click Sync.

Multiple devices | From the Network Devices table, select the devices (by checking their check boxes), then
click Sync.
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. Device Sync State

Device Sync State

Device Sync State—Indicates status of the Sync operation performed on a device.

Table 16: Device Sync State

Icon Device Sync State Description

Q Synchronizing Device synchronization is in progress.

- Completed Device synchronization completed successfully.
o> Error/Warning List of errors or warnings indicated:

* Add Initiated

* Collection Failure

* Completed with Warning

* Delete In Progress

* In Service

* In Service Maintenance

* No License

« Partial Collection Failure

* SNMP Connectivity Failed
* SNMP User Authentication Failed
* Switch Port Trace

* Wrong CLI Credentials

)

Note In Service Maintenance filter is not available for Last inventory collection status.

Launch Cisco Transport Controller to Manage Cisco NCS and
Cisco ONS Devices

The Cisco Transport Controller (CTC) is the software interface for a subset of Cisco ONS and Cisco NCS
devices. CTC is a Java application that resides on the control cards. It is used to provision and administer
these devices.

You can launch CTC from Cisco EPN Manager. Only the latest CTC release is launched, regardless of the
NE release you selected. If you need to use other CTC releases, launch CTC from a web browser and connect
directly to the NE that has the required CTC release.

To launch CTC:
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Step 1
Step 2
Step 3

Step 4

Step 5
Step 6

Launch Cisco Transport Controller to Manage Cisco NCS and Cisco ONS Devices .

Before you begin

Make sure the devices are properly configured to launch CTC. See Configure Devices So They Can Be
Modeled and Monitored.

From the left sidebar, choose Inventory > Device Management > Network Devices.
Click the “i” icon next to the Cisco ONS or Cisco NCS device’s IP address to launch the Device 360 view.

In the Device 360 view, choose Actions > Launch CTC. The CTC launcher application is downloaded to your computer.
Note that this action will be disabled if launching CTC is not supported on the selected device type.

In the CTC Launcher window, choose one of the following connection mode:

» Use [IP—Connection to the device is established using the device’s IP address (default option).

* Use TL1 Tunnel—Connection to the device is established using a TL1 session. You can start a TL1 session from
CTC oruse a TL1 terminal. Note- Use this option to connect to the device that resides behind the third-party OSI-based
GNE. The CTC launcher creates a TL1 tunnel to transport the TCP traffic through the OSI-based GNE and the
provisioning occurs in CTC

Select the CTC Version, and then click Launch CTC.
Enter your CTC credentials.
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. Launch Cisco Transport Controller to Manage Cisco NCS and Cisco ONS Devices
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