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Check Circuits/VCs for Faults
Cisco EPN Manager provides several ways to see, at a glance, if there are any problems with circuits/VCs:

• Circuit list—The colored icon to the left of each circuit/VC name indicates the primary state of the
circuit/VC. If the primary state indicates a problem with the circuit/VC, you can access detailed alarm
information for the circuit/VC, as described below.

• Circuit/VC 360 view—The Alarms tab in the Circuit/VC 360 view shows all alarms on all devices over
which the circuit/VC is configured. Click the information icon next to the circuit/VC name to access the
Circuit/VC 360 view.

• Alarm Table—The alarm table shows all alarms for all devices, for a specific device group, or for a
specific device. Choose Monitor > Monitoring Tools >Alarms and Events to access the alarm table.
If you have identified an alarm in the Circuit/VC 360 view, you can get more details about the alarm in
the alarm table. You can search for the alarm or for the device/link that generated the alarm using the
quick filter or the advanced filter.Each alarm in the table can be expanded to show detailed information
about the alarm, including which circuits/VCs are affected by the alarm.

• Circuit/VC Overlay in the Network Topology—When a circuit/VC is selected in the Circuits/VCs list,
it is represented on the network topology as an overlay on top of the existing topology. If the alarm is
on a specific device, the alarm badge will appear on the device as usual. If the alarm is on the link between
the circuit/VC endpoints, the alarm badge will appear on the link.

• Multi-layer trace for optical circuits—See Trace and Visualize the Full Route of Circuits/VCs, on page
18.
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Identify Which Circuits/VCs are Affected by a Specific Fault
To identify which circuits/VCs are affected by a specific fault:

Step 1 From the left side bar, choose Monitor > Monitoring Tools > Alarms and Events.
Step 2 In the alarm table, locate the required alarm. You can use the simple or advanced filters to locate the alarm, if necessary.
Step 3 Click on the arrow to the left of the row to expand the row and display the alarm details.
Step 4 Locate the Impacted Circuits/VCs pane. All circuits/VCs that are affected by the selected alarm are listed in this pane,

with basic information for each circuit/VC. You can access the Circuit/VC 360 view to get more details about the circuit/VC
by clicking the i icon.

Step 5 If necessary, you can modify or delete the circuit/VC from the Impacted Circuits/VCs pane by selecting a circuit/VC and
clicking the Modify or Delete button. This opens the Provisioning Wizard. See Modify a Circuit/VC and Delete a
Circuit/VC for more information.
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Get More Information About a Circuit/VC Failure
Cisco EPNManager provides information about why the provisioning operation of a circuit/VC has failed so
that you can troubleshoot the issues. In the Circuits/VCs table, you can identify problems with a circuit/VC
by looking at the Provisioning state and the Serviceability and Discovery states. If there has been an error
during the provisioning of a circuit/VC and the circuit/VC could not be created, the Provisioning state will
be Create Failed. You can click the i icon in the Provisioning column to see the configuration of the devices
involved in the failure, as well as details about the specific error(s) that occurred.

For optical circuits, the combination of Serviceability state Down and Discovery state Partial can indicate a
problem with the circuit. In this case, you can click the i icon in the Serviceability column to see the reason
that the Serviceability state is Down.
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Information about a circuit/VC failure can also be accessed from the Circuit/VC 360 view. See Get Quick
Information About a Circuit/VC: Circuit/VC 360 View.

Note

To view additional information about a circuit/VC provisioning failure from the Circuits/VCs table:

Step 1 From the left sidebar, choose Maps > Topology Maps > Network Topology.
Step 2 In theNetwork Topologywindow, click theCircuits/VCs tab, and then click theCircuits/VCs hyperlink. A table listing

all the circuits is launched in a separate window.
Step 3 Locate the circuit for which the provisioning operation has failed. The Provisioning state will be Create Failed.
Step 4 Click the i icon next to the Provisioning column. A popup window is displayed and lists the devices on which the

provisioning errors occurred.
Step 5 Select a device to see its configuration and error details.
Step 6 Click the i icon next to the Serviceability column to view the Serviceability Details data pop-up window that displays

information about why the provisioning operation has failed for the circuit.

The i icon is available only if the serviceability status is down and the discovery status is partial.Note

For optical circuits, if the Serviceability state is Down and the Discovery state is Partial, click the i icon next
to the Serviceability column to view the Serviceability Details data pop-up window that displays information
about why the circuit's serviceability state is Down. You can also view the Serviceability Details data pop-up
window from the Circuit/VC 360 view. For information about how to access the Circuit/VC 360 view, see
Get Quick Information About a Circuit/VC: Circuit/VC 360 View.

Troubleshoot a Service Failure Using OAM Commands
Cisco EPN Manager provides the ping and traceroute features to troubleshoot service failures. You can use
OAM commands to access these features and monitor the connectivity and path between two endpoints in a
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service. You can then isolate and resolve the failure. The technologies that are supported for the different IOS
devices are:

• MPLS LSP, Pseudowire and CFM: Cisco IOS-XE and Cisco IOS-XR
• MPLS Bidirectional TE Flex LSP and VRFs: Cisco IOS-XE

The launch points for the OAM command vary based on:

• Technology type—Launching from Network Devices Table, on page 5 (This launch point for OAM
commands is supported only for the MPLS LSP technology.)

• Service type—Launching from Circuit 360, on page 5
• Event type—Launching from Alarm Browser, on page 6

You can perform ping or traceroute using the OAM commands to troubleshoot a service failure. See Perform
a Ping or Traceroute Using OAM Command, on page 7

Launching from Network Devices Table
To launch MPLS LSP technology OAM command from Network Devices table:

Step 1 Choose Inventory > Device Management > Network Devices.
Step 2 In the Network Devices table, select a MPLS enabled device.
Step 3 Click the >> icon above the Network Devices table and select OAM Commands.

Launching from Circuit 360
If you are launchingOAMcommand from the Service/Circuit 360, the service type is the criteria that determines
the technology that is supported. See Overview of Circuit/VC Discovery and Provisioning to know in detail
about the different service types.

To launch OAM command from Circuit 360:

Step 1 Choose Maps > Topology Maps > Network Topology.
Step 2 In the Network Topology window, click the Circuits/VCs tab and click the i icon next to the circuit to view the Circuit

360. Based on the service type of the circuit you selected, the supported technology OAM commands as mentioned in
this table are displayed.

Technology supportedService Type for which you can launch the OAM command:

• Segment Routing LSP

• Pseudowire
• CFM

Carrier Ethernet

• MPLS LSP
• Pseudowire
• Bidirectional TE (Flex LSP)

Circuit Emulation (CEM)
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Technology supportedService Type for which you can launch the OAM command:

• MPLS LSP
• VRF

L3VPN

• MPLS LSP
• Bidirectional TE (Flex LSP)

Bidirectional TE Tunnel (Flex LSP)

Step 3 Click Actions and select the Technology OAM that is displayed for the service type you chose.

Launching from Alarm Browser
If you are launching OAM command from the alarm browser, the event type is the criteria that determines
the technology that is supported.

To launch OAM command from an alarm browser:

Step 1 Choose Monitor > Monitoring Tools > Alarms and Events.
Step 2 In the Alarms table, select an alarm with an event type listed in the "Event Type for which you can launch the OAM

command" column in this table.

Event Type for which you can launch the OAM command:Technology supported

• mplsTunnelUp
• mplsTunnelDown
• mplstunnelReoptimized
• ROUTING-MPLS_TE-5-LSP_UPDOWN
• MPLS_TE-5-TUN
• MPLS_TE-5-LSP

MPLS Bidirectional TE
Tunnel (Flex LSP)

• mplsL3VpnVrfUp
• mplsL3VpnVrfDown
• mplsL3VpnNumVrfRouteMaxThreshCleared
• mplsL3VpnVrfNumVrfRouteMaxThreshExceeded
• mplsL3VpnVrfRouteMidThreshExceeded

VRFs in L3VPN

• cpwVcDown
• cpwVcUp
• XCONNECT-5-PW_STATUS Down
• L2-L2VPN_PW-3-UPDOWN

Pseudowires in Carrier
Ethernet and Circuit
Emulation

• E_CFM-3-REMOTE_MEP_DOWN_TIME_OUT
• L2-CFM-6-MEP_CHANGE

CFM in Carrier Ethernet

Step 3 Click Troubleshoot above the Alarms table and select OAM Commands.
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Perform a Ping or Traceroute Using OAM Command
To perform a ping or traceroute or multipath (only for SR) using OAM command:

Step 1 Launch the TechnologyOAM Command window. See Troubleshoot a Service Failure Using OAMCommands, on page
4 for the OAM command launch points for the supported technologies.

Step 2 Based on the launch point, select the required fields as displayed in this table for the selected technology type.

Launched from Service/Circuit 360Launched from Alarm BrowserTechnology Type

From the Pesudowire Endpoint
drop-down list, choose the endpoint
participating in the service.

Details are auto-populatedPseudowire

Specify the Source andDestination from
the drop-down lists.

In the Destination field,

• If a LDP enabled device is selected,
then Ping and Traceroute options are
enabled.

• If SR enabled device is selected, then
Ping, Traceroute,Multipath, Nil FEC
Ping and Nil FEC Traceroute options
are enabled. (Nil FEC options are
enabled only if Label,
OutputInterface and NextHop fields
are populated)

From the Destination LDP ID
drop-down list, choose the LDP ID
of the destination endpoint
participating in the service.

LSP

Choose the tunnel's path as Active,
Working, or Path-Protect for which you
want to perform a ping or traceroute.
Cisco EPNManager performs the ping or
traceroute on both directions, that is, from
headend to tailend and vice versa.

Choose the tunnel's path as Active,
Working, or Path-Protect for
which you want to perform a ping
or traceroute. Cisco EPN Manager
performs the ping or traceroute on
both directions, that is, from
headend to tailend and vice versa.

MPLS Bidirectional TE Tunnel (Flex
LSP)

From the Source End Points and
Destination End Points drop-down lists,
choose the source and destination
endpoints of another VRF that belongs to
the same VPN.

From the End Points drop-down
list, choose the endpoint of another
VRF that belongs to the same VPN.

VRF in L3VPN

From the Source MEP ID and
Destination MEP ID drop-down lists,
choose the MEP IDs of the source and
destination endpoints participating in the
service.

From the Destination MEP ID
drop-down list, choose the MEP ID
of the destination endpoint
participating in the service.

CFM in Carrier Ethernet

Monitor and Troubleshoot Circuits/VCs
7

Monitor and Troubleshoot Circuits/VCs
Perform a Ping or Traceroute Using OAM Command



Launched from Service/Circuit 360Launched from Alarm BrowserTechnology Type

From the Policy Name drop-down list,
choose a policy.

Note: This option is enabled for devices
configured over static and dynamic SR
policies or EVPN technology.

SR TE

Step 3 Choose Actions > Ping to perform a ping, choose Actions > Traceroute to perform a traceroute, and choose Actions >
Multipath to perform a multipath action.

The results of the ping, traceroute and multipath commands are displayed in the following formats:

• For MPLS bidirectional TE tunnels, the results are displayed for both directions, that is, from headend
to tailend and vice versa.

• For Pseudowire, the results are displayed in visual and tabular formats and as raw data.

Note

• Visual—The service with the endpoints and its hops is displayed on a map. Hover your mouse cursor
over the endpoints to view additional information such as the outgoing and incoming interfaces.

The traceroute command results for all the technologies are displayed in visual
format.

Note

• Table Data—The information such as the outgoing and incoming interfaces, device names, and labels
of the endpoints participating in the service are displayed in a tabular format.

The traceroute and multipath command results are displayed in tabular format.Note

• Raw Data—The information about the endpoints participating in the service is displayed as unformatted
source data.

Ping, traceroute and multipath command results are displayed as raw data.Note

Use EOAM Templates to Troubleshoot EVCs
Cisco EPN Manager provides several predefined templates that can be used to monitor the connectivity and
performance of virtual connections (VCs) in a Carrier Ethernet network. To use these templates, choose
Configuration > Templates > Features & Technologies > CLI Templates > System Templates - CLI.
See Perform EOAM Connectivity and Performance Checks for more information.
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Run a Performance Test on a Circuit/VC
When you run a performance test, Cisco EPNManager connects to the network elements to provide real-time
data. To get historical information, see View Performance Metrics and Reports for Circuits/VCs, on page 16.

• Performance Test Based on Y.1564 for EVCs, on page 9

• Performance Test Based on Y1731 for EVCs, on page 11

• Performance Test for Optical Circuits, on page 13

• Performance Test for Circuit Emulation Services, on page 15

Performance Test Based on Y.1564 for EVCs
CE performance tests verify the correct configuration and performance of CE EVCs at the time of activation.
You can also use the CE performance tests to troubleshoot an EVC that is already in operation.

The Y.1564 Ethernet service activation or performance test methodology allows turning up, installing, and
troubleshooting Ethernet-based services. Using this test, you can verify the service configuration and
performance from UNI to UNI. This ensures that the SLA will be met according to the bandwidth profile
purchased, and the promised class of service.

These tests provide complete validation of Ethernet service-level agreements (SLAs) in a single test. Using
a traffic generator performance profile, you can create the traffic based on your requirements. The network
performance, such as throughput, loss, and availability, are analyzed using Layer 2 traffic with various
bandwidth profiles.

You can only run performance tests on EVCs that are configured on the network and discovered by Cisco
EPN Manager.

Note

Supported Devices
The Y.1564 performance test is supported on the following devices running IOS 15.4(S) or IOS XE 3.12S
and higher:

• List of devices that can be specified as either source or destination:

• Cisco ASR 920

• Cisco ASR907 with RSP3 as both source and destination (loopback)

• Cisco ASR903 with RSP2, RSP3 as both source and destination (loopback)

• Cisco ASR 901

• Cisco ASR9K (as loopback)

• Cisco NCS 4201

• Cisco NCS 4202

• Cisco NCS 4206
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• Cisco NCS 4216

• NCS540 (as a loopback)

• Cisco NCS55xx (as loopback)

• Cisco ME 1200

• Cisco ME 3600

• Cisco ME3800 (loopback)

• List of devices that can be specified as destination (loopback) only:

• Cisco ME3800X

• Cisco NCS 4206

• Cisco ASR 903 RSP/RSP1

Running a Y.1564 Performance Test
To run a Y.1564 performance test on an EVC, do the following:

Before you begin

If you want to run a Y.1564 performance test on an EVC that resides on a ME1200 device, enter the following
QoS configuration on both the source and destination interfaces before you run the test:
Interface <interface-name>
qos map tag-cos pcp 0 dei 0 cos 0 dpl 0
qos map tag-cos pcp 0 dei 1 cos 0 dpl 1
qos map tag-cos pcp 1 dei 0 cos 1 dpl 0
qos map tag-cos pcp 1 dei 1 cos 1 dpl 1
qos map cos-tag cos 0 dpl 0 pcp 0 dei 0
qos map cos-tag cos 0 dpl 1 pcp 0 dei 1
qos map cos-tag cos 1 dpl 0 pcp 1 dei 0
qos map cos-tag cos 1 dpl 1 pcp 1 dei 1

Step 1 Choose Maps > Topology Maps > Network Topology to open the Network Topology page.
Step 2 From the toolbar, click Device Groups to open the Device Groups pop-up window.
Step 3 Locate and click the device group that contains the circuit/VC you want to test, then close the pop-up window.
Step 4 Click the Circuits/VCs tab, locate the relevant service, and then click its i (information) icon to open its Circuit/VC

360 view.
Step 5 From the top right corner of the view, choose Actions > Y.1564 Test to open the Y.1564 performance test settings page.

This test can also be initiated from the Circuit/VC tab in a device's Device 360 view and the Circuits/VCs &
Network Interfaces page. See View a Device Group's Circuits/VCs and View Circuits/VCs.

Note

Step 6 Configure the settings for the performance test:
a) In the Test Mode field, specify whether this will be a one- or two-way test by clicking the appropriate radio button.

Note that in the case of a two-way test, loopback will be created on the service instance of the destination device.
b) In the End Points area, choose the source and destination device, interface, and EFP ID from the drop-down lists.

Monitor and Troubleshoot Circuits/VCs
10

Monitor and Troubleshoot Circuits/VCs
Running a Y.1564 Performance Test

bk_CiscoEPNManager_4_0_UserAndAdministratorGuide_chapter17.pdf#nameddest=unique_166
bk_CiscoEPNManager_4_0_UserAndAdministratorGuide_chapter3.pdf#nameddest=unique_134


c) In the Service Configuration Test area, specify the duration of each iteration, the size of packets to be generated,
and the rate at which traffic will be generated.

• If you choose the CIR/EIR radio button, specify values (in kilobits per second) for the Committed Information
Rate (CIR) and Excess Information Rate (EIR). The CIR is the long-term average transmission rate, whereas
the EIR is the long-term average excess transmission rate.

• If you select the Color Aware Test check-box, specify the Class of Service (CoS) values between 0 to 7 for the
Conform Action and Exceed Action. The CoS values must be set different for Conform Action and Exceed
Action to differentiate and prioritize the traffic. Also, you may specify the values (in kilobytes per second) for
the Committed Burst Size (CBS) and Excess Burst Size (EBS) to define the committed or excess traffic that can
be transmitted in bursts at temporary rates above the CIR.

The Color Aware Test check-box will be enabled only for FPGA enabled devices with 10G ports.
“Color Aware” is used to describe the mode where the customer is marking each frame as green or
yellow, and the network takes this marking into account at the bandwidth profiler and traffic policer.

Note

• If you check the Step Load CIR check box, the test will generate traffic at four different levels: 25, 50, 75, and
100% of the CIR value you specify. Note that this option is not available if the CIR is set to a value lower than
8 kbps.

• If you choose the Custom Rates radio button, 1000 kbps is set by default. Change this value, if necessary.

• If you are running a one-way performance test, you can only specify a custom traffic rate.

d) In the Service Acceptance Criteria area, enter the highest acceptable frame loss ratio value (in percent) in the FLR
field.

• If you also want to set a frame transfer delay (FTD) and frame delay variation (FDV) value, check the
corresponding check box and then enter the appropriate value (in milliseconds).

• If any of the thresholds you set are exceeded during the performance test, the EVC will be deemed as having
failed the test.

e) (Optional) In the Frame Settings area, specify values for the following parameters:

• IP version—IPv4 or IPv6

• Inner and outer VLAN ID—Identify the source and destination VLAN ID you want to test

Step 7 Click Run Test.

When the test is completed, the results are displayed at the bottom of the Y.1564 performance test settings page.

Performance Test Based on Y1731 for EVCs
TheY.1731 PerformanceMonitoring (PM) provides a standard ethernet PM function that includesmeasurement
of ethernet frame delay, frame delay variation, frame loss, and frame throughput measurements specified by
the ITU-T Y-1731 standard and interpreted by the Metro Ethernet Forum (MEF) standards group. Using this
test, you can verify the delay and loss measurements such as the delay and loss probe status, delay and loss
probe availability, two-way delay, two-way jitter, loss forward, and loss backward for your circuit/VC.
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This performance test is supported on Cisco IOS, IOS-XR and IOS-XE devices.Note

Before you begin

Following are the prerequisites that must be met before you run a performance test based on Y.1731 for a
circuit/VC:

• The circuit/VC, along with the participating devices, on which you want to run the performance test,
must be operationally up.

• Ensure that the MEP ID matches the domain name for all the devices participating in the circuit/VC.

Step 1 From the left sidebar, choose Maps > Topology Maps > Network Topology.
Step 2 Click Device Groups, and then select the location that contains the circuit/VC you want to test.
Step 3 In the Network Topology window, click Circuits/VCs.
Step 4 Locate the required circuit/VC, and then click the information icon to access its Circuit/VC 360 view.
Step 5 Choose Actions > Y.1731 Test.

The performance test can also be initiated from the circuit/VC details window and from the expanded list of
circuits/VCs. See View a Device Group's Circuits/VCs and View Circuits/VCs.

Note

Step 6 Choose the required source and destination devices and their corresponding interfaces.
Step 7 From the CoS drop-down list, choose the priority of the probe. The default value is 0.
Step 8 Choose the required measurement type. The options are Delay, Loss, and Loss & Delay.

While delay measurement is done using Delay Measurement Message (DMM) probe, loss measurement is
done by Synthetic LossMeasurementMessage (SLM) probe. In case of ASR 1K devices, delay measurement
using Loss Measurement Message (LLM) probe is only supported.

Note

Step 9 If required, define the advanced performance test parameters as follows:

• Probe Length—Choose the length of the probe in seconds. For example, if the probe length is set to 30 seconds,
the statistical data is collected every 30 seconds and displayed in the test results area.

• Packet Size—Enter the size (in bytes) of the packets that you want to send for each probe.

• Burst Interval—Choose the burst interval in seconds. This defines the time interval between two sets of packets
that are sent for a probe.

• Packet Interval—Choose the packet interval in milliseconds. This defines the time interval between two packets
that are sent for a burst.

• Packet Count—Enter the number of packets that will be sent for a burst.

For example, if the burst interval, packet interval, and packet count are set to 30 sec, 1000 ms, and 10 respectively,
10 packets will be sent in the interval of 1000 ms between one packet and the next packet. Once all the 10 packets
are sent, there will be an interval of 30 sec after which the next set of 10 packets will be sent.
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Step 10 Click Run Test. When the test is completed, the results will be displayed at the bottom of the Performance Test page,
under the Test Results area.

Performance Test for Optical Circuits
Cisco EPN Manager performance test for optical circuits is based on the ITU-T recommendations as defined
in G.709 and G.798.

Cisco EPN Manager supports the following performance tests for Optical Circuits:

• Optical Performance Monitoring Parameters, on page 13

• Run PRBS Test on Circuits (ODU UNI), on page 14

Optical Performance Monitoring Parameters
Optical Performance Monitoring Parameters monitor the quality of optical signals and are used to measure
the average optical power transmitted and received between end points in optical circuits. From these
measurements, you can derive critical network performance parameters such as channel presence verification,
channel wavelength, ASE noise, optical signal power, and optical signal to noise ratio (OSNR) per channel.
You can then use these parameters to manage the network reliability and quality of service.

Follow the steps below to view the performance monitoring parameters for an optical circuit:

Step 1 From the left sidebar, choose Maps > Topology Maps > Network Topology.
Step 2 Select the device group that contains the circuit/VC you want to test.
Step 3 In the Circuits/VCs pane on the left, locate the required service and click the i icon to access its Circuit/VC 360 view.
Step 4 Choose Actions > Optical PM Parameters .

The performance test can also be initiated from the circuit/VC details window and from the expanded list of
circuits/VCs. See View a Device Group's Circuits/VCs and View Circuits/VCs.

Note

Step 5 Select an optical monitoring type based on which the performance data will be displayed. For more information about
the optical monitoring types and the associated performance counters, see Performance Counters for Optical Monitoring
Policies.

Step 6 Choose the performance monitoring time interval as 15 minutes or 24 hours to collect the performance data from the
device.

Step 7 Specify the time interval to automatically refresh the performance data.
Step 8 Click Auto Refresh. The performance data for the circuit is displayed as a tabular representation. For the detailed

descriptions of the performance data, see Performance Counters for Optical Monitoring Policies.

Based on the time interval specified to refresh the performance data, the newly retrieved data is displayed at the beginning
of the table. For example, if the time interval specified is 10 seconds, the performance data is automatically refreshed
every 10 seconds and the newly retrieved data is displayed at the beginning of the table. The table displays the last 20
entries of the performance data retrieved.

Monitor and Troubleshoot Circuits/VCs
13

Monitor and Troubleshoot Circuits/VCs
Performance Test for Optical Circuits

bk_CiscoEPNManager_4_0_UserAndAdministratorGuide_chapter17.pdf#nameddest=unique_166
bk_CiscoEPNManager_4_0_UserAndAdministratorGuide_chapter3.pdf#nameddest=unique_134
bk_CiscoEPNManager_4_0_UserAndAdministratorGuide_appendix4.pdf#nameddest=unique_153
bk_CiscoEPNManager_4_0_UserAndAdministratorGuide_appendix4.pdf#nameddest=unique_153
bk_CiscoEPNManager_4_0_UserAndAdministratorGuide_appendix4.pdf#nameddest=unique_153


Run PRBS Test on Circuits (ODU UNI)
PRBS test is supported for OTN Circuits of type ODU UNI. PRBS bit error count measures the reliability of
the link between the endpoints. This test is supported for NCS4K-20T-O-S cards. When PRBS test is run
between 2 endpoints (ODU Controller or sub-controller), the source device sends a bit pattern through one
or more midpoints (intermediate controller or sub-controller) and the same bit pattern is received by the
destination device, the test results can be viewed from both the endpoints. You can also run the PRBS test on
a controller, configuring the other endpoint as a loopback, source, or source-sink.

For information on configuring PRBS on an ODU controller, see Configure PRBS on ODU Controllers.

To run a PRBS performance test for an optical circuit:

Step 1 From the left sidebar, choose Maps > Topology Maps > Network Topology.
Step 2 Select the device group that contains the circuit/VC of type ODU UNI you want to test.
Step 3 In the Circuits/VCs pane on the left, locate the required service and click the i icon to access its Circuit/VC 360 view.
Step 4 Choose Actions > PRBS Test.
Step 5 To assign roles to the endpoints, in the Endpoint table, click the endpoint's role and select one of the following options

from the drop-down list:

• SOURCE—To set this role to either A or Z side.
• SINK—To set this role to either A or Z side.
• SOURCESINK—To set this role either to A side, Z side, or both.
• INVALID—To disable PRBS on the endpoint.

Step 6 To assign patterns to the endpoints, in the Endpoint table, click the endpoint's pattern and select the desired pattern
from the drop-down list.

Following patterns are supported for NCS4K-20T-O-S cards:

• PRBS 31

• PRBS 31 Inverted

• PRBS 11

• PRBS 11 Inverted

Step 7 To change the loopback mode, in the Loopbacks table, click the endpoint's or midpoint's loopback mode and select one
of the following options from the drop-down:

• NO_LOOPBACK—For testing without loopback.
• INTERNAL—For testing within the same network.
• LINE—For testing across different network.

Step 8 In the Test Results area, select the endpoint from the Sink Controller drop-down list.
Step 9 Click one of the following Interval radio button, to set the time interval to collect the data from the device:

• Current (every 10 seconds)—Displays past 15 minutes results every 10 seconds.
• 15 Minutes—Displays past 15 minutes historic performance data.
• 1 Day—Displays past 1 day historic performance data.

Step 10 Click Go.
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Step 11 Click Auto Refresh. The test result for the endpoints is displayed as a tabular representation which includes bit error
count, packets lost and found timestamps and packet lost and found counts.

Based on the time interval specified to refresh the test, the newly retrieved data is displayed at the beginning of the
table. For example, if the time interval specified is 10 seconds, the data is automatically refreshed every 10 seconds
and the newly retrieved data is displayed at the beginning of the table.

Performance Test for Circuit Emulation Services
Bit error rate test (BERT) allows you to test cables and diagnose signal problems in the field. This testing
mechanism is supported on the Cisco NCS 42xx Series (T1/E1 Ports and T3/E3 Ports). This test generates a
specific pattern on to the outgoing data stream of a circuit controller and then analyzes the incoming data
stream for the same pattern. The bits that do not match the expected pattern are counted as bit errors.

The bit error rate is determined by comparing the erroneous bits received with the total number of bits received.
You can view and analyze the total number of error bits transmitted and the total number of bits received on
the circuit. You can retrieve error statistics anytime during the test.

The following table lists the test patterns supported in Cisco NCS 42xx series (T1/E1 Ports and T3/E3 Ports)
devices.

DescriptionBERT Pattern

Pseudo-random repeating test pattern that consists of 2,048 bits.2^11

Pseudo-random repeating test pattern that consists of 32,767 bits.2^15

Pseudo-random repeating test pattern that consists of 1,048,575 bits.2^20-O151

Pseudo-random repeating test pattern that consists of 1,048,575 bits.2^20-O153

Pseudo-random 0.151 test pattern that is 8,388,607 bits in length.2^23

Pseudo-random 0.151 test pattern that is 2,147,483,647 bits in length.2^31

Pseudo-random 0.151 test pattern that is 511 bits in length.2^9

To run a BERT performance test for a CEM circuit:

Step 1 From the left sidebar, choose Inventory > Others > Circuits/VCs & Network Interfaces.
Step 2 In the Circuits/VCs tab, locate the required CEM service and click the i icon to access its Circuit/VC 360 view. In the

Circuit/VC 360 view, choose Actions > Performance Test > BERT.

Alternatively, you can reach this page throughMaps >Topology Maps >Network Topology and from theCircuits/VCs
pane, access the Circuit/VC 360 view of the required CEM circuit.

Step 3 In the Test tab, select the test direction, source and destination.

For easy understanding, the pictorial representation of the test in the circuit is displayed, once the source and destination
are selected.

Step 4 To refresh the test data automatically for a defined time interval, in the Settings area, enter the time interval in minutes.
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Step 5 Select the pattern from the BERT Pattern drop-down list.
Step 6 Click Run Test. The test result is displayed in the Test Results area. See View and Export the Results of the Performance

Test on Circuit Emulation Services, on page 16
Step 7 To terminate the test, in the Settings area, click Stop and click Clear Counters to reset the values in the Test Results

area.

In case of SONET interfaces, the Clear Counters button is disabled once you terminate the test.

View and Export the Results of the Performance Test on Circuit Emulation Services
At a time, BERT performance test can be performed on any number of CEM circuits but only one test can be
performed on a single CEM circuit. The results of the BERT performance test on a CEM circuit is displayed
in the Test Results area.

• At any point in time, the results of last run/currently running BERT performance test on a CEM circuit
is displayed in the Test Results area in the Test tab.

• If the Auto-refresh is enabled (ON), then the test results are auto-refreshed at the specified time period.

• In the Test Results area:

• No test results are displayed, when an Unmanaged Endpoint is chosen as destination for a test.

• Two set of test results are displayed, each for an endpoint, when a Managed Endpoint is chosen as
destination.

• Choose Monitor > Performance Tests > BERTs. Here, only a single entry for each CEM circuit is
available and it shows either the last run/currently running test on that CEM circuit. Select the required
CEM circuit to view its test results.

• To view the historical records of BERT performance results for a specific CEM circuit, in the History
tab, select the required test from the Test drop-down list to view the configuration and its result.

You can export the results of a BERT performance test by clicking the Export icon at the top right corner of
the Test and History tabs of the BERT page (from the Circuit/VC 360 view, choose Actions > Performance
Test > BERT).

You can also export the list of BERT performance tests from the following pages:

• Select BERT Test pop-up window (from the BERT page, click the History tab, and then click the Test
drop-down list to open the Select BERT Test pop-up window).

• BERT listing page (choose Monitor > Performance Tests > BERTs).

View Performance Metrics and Reports for Circuits/VCs
The Circuit/VC 360 view provides information about the circuit's recent history. Reports, on the other hand,
can retrieve all historical data stored in the database. For real-time information, run a performance test (see
Run a Performance Test on a Circuit/VC, on page 9).

• View Performance Graphs in the Circuit/VC 360 View , on page 17
• Use Performance Reports to Monitor and Troubleshoot Circuits/VCs, on page 17
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• Use Service Performance Dashboard to Monitor Circuits/VCs, on page 17

View Performance Graphs in the Circuit/VC 360 View
The Circuit/VC 360 view contains graphs showing various aspects of the circuit/VC performance. This view
is helpful if you want to see, at-a-glance, if there are any major issues with circuit/VC performance. For more
information, see Get Quick Information About a Circuit/VC: Circuit/VC 360 View.

To access the Circuit/VC 360 view:

Step 1 From the left side bar, choose Maps > Topology Maps > Network Topology. The network topology window opens.
See Visualize the Network Topology for a description of the Network Topology window and its functionality.

Step 2 In the Locations pane on the left, select the device group within which the required circuit/VC was created.
Step 3 In the Circuits/VCs pane, locate the required circuit/VC and click on the i icon next to the circuit/VC name. The Circuit/VC

360 view appears in a separate popup window.

Use Performance Reports to Monitor and Troubleshoot Circuits/VCs
Cisco EPNManager provides extensive reporting capabilities that enable you to retrieve in-depth performance
information for optical circuits and EVCs. The Report Launch Pad provides access to all Cisco EPNManager
reports. From the Report Launch Pad, you can create and save new reports, view current reports, open specific
types of reports, schedule a report to run later, and customize the results of a report.

Choose Reports > Report Launch Pad in the left navigation pane to access the reports and the reporting
functionality.

For information about Carrier Ethernet performance reports, see Carrier Ethernet Performance Reports.

For information about Optical performance reports, see Optical Performance Reports.

Use Service Performance Dashboard to Monitor Circuits/VCs
Service Performance dashboard provides a collection of graphical and tabular representation of Performance
measurement for the selected circuit/VC over time. This information is available in the form of customized
dashlets. The dashboard menu provides access to all the available Cisco EPN Manager dashboards.

From Service Performance Dashboard, you must select a circuit/VC from the Circuits/VCs drop-down list to
view the following information (dashlets):

• Average availability of service endpoints over time.

• Incoming and outgoing traffic measured in bits per second, for services over a specified time period.

• Average delay between the service endpoints over time.

• Average packet loss ratio between the service endpoints over time.

• List of services with highest incoming and outgoing traffic.

To launch the dashboard for a specific service from its Circuit/VC 360 view, click View and then choose
Dashboard.
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Formore information on the Service Performance dashboards and dashlets, see Service PerformanceDashboard
Overview.

For more information on managing dashboards and dashlets, see Get Started With Cisco EPN Manager.

Trace and Visualize the Full Route of Circuits/VCs
Use the Multilayer Trace view (MLT) to visualize a circuit in a graphical manner. This view displays the
complete circuit span and service trace between two endpoints and can be used to trace the connectivity of a
circuit by displaying the source node, the destination node, and any intermediate nodes in graphical format.

Note the following:

• Multilayer Trace view is not supported for Multipoint Carrier Ethernet circuits/VCs, Serial - Raw Socket
and L3VPN services.

• You can launch the Multilayer Trace view for optical circuits only when LMP is configured on the A
end device and also between devices participating in the optical circuit.

• For MPLS-TE and SR-TE tunnels, physical topology is required for the Multilayer Trace view, meaning
that the physical links must have been discovered using one of the supported protocols, for example,
CDP or LLDP.

To trace and visualize the full route of a circuit:

Step 1 From the left side bar, choose Maps > Topology Maps > Network Topology.
Step 2 Click Device Groups and then select the location in which the required circuit/VC was created.
Step 3 On the Network Topology page, click Circuits/VCs. The list of circuits/VCs associated with the selected device group

is displayed.
Step 4 Select a circuit/VC for which you want to view the full route. The overlay of the circuit is displayed on the map.
Step 5 Use one of the following ways to switch to the Multilayer Trace view:

• Click the Multilayer Trace hyperlink on the notification that appears right below the topology toolbar.

The Multilayer Trace hyperlink appears only if the Multilayer Trace view is supported for the selected
circuit/VC and if the primary state of the circuit/VC is not 'Missing'.

You can view the partial multilayer trace even when a full route of a circuit/VCs is not completely modeled
or if the route is broken. You can identify the root cause and the suggestions to overcome the error.

Note

• Click the information icon adjacent to the circuit/VC to open the Circuit/VC 360 view, and then click
View>Multilayer Trace.

The simplified three-dimensional view of the selected circuit/VC is displayed. In the simplified view, only the source
and destination endpoints of the participating devices are displayed. You can choose to either expand or collapse the
different layers in the circuit/VC. The animation of the route direction between the endpoints is displayed for some circuit
types. For more information, see View Specific Information of a Circuit in a Multilayer Trace View, on page 22.

In the case of a device with a circuit being traversed more than once (more incoming and outgoing connections),
the collapse option is disabled in both three-dimensional and linear views.

Note

The following figure shows the simplified view of a circuit/VC with the expand and collapse options.
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For more information about the details displayed in a three-dimensional view, see Three-Dimensional View of a Circuit
V/C Trace, on page 20.

To switch to the linear view, click Linear View. For more information about the details displayed in a linear view, see
Linear View of a Circuit/VC Trace, on page 21.

The Multilayer Trace view displays a graphical map that:

• Uses high-level span information such as NEs and links to display the circuit trace.

• Displays logical high-level view where the circuit is traced on the map using logical links. For example,
OCHCC circuits use OCH trail links for the trace.

• Displays physical high-level viewwhere the circuit is traced on the map using physical links. For example,
OCHCC circuits use OTS links for the trace.

• Displays badges on the devices that represent the most severe alarm on the device, irrespective of the
selected circuit. The alarm badges within the trace view show the alarms on each entity (for example the
link, node, or point).

• Highlights links according to the high-level view that you select.

• Highlights the layers with different shades and displays border lines that delineate the different layers in
the circuit. If a layer is not applicable for a device, that layer appears in gray color

• Displays a collapsible legend that lists the different icons and descriptions of each icon displayed in the
Multilayer Trace view.

• For optical circuits, indicates whether the devices or links in the circuit have Shared Risk Resource
Groups (SRRGs) assigned to them. Click on the SRRG label on the link or device to see a list of all the
SRRGs on that link/device. The SRRGs are color-coded based on whether they are the default on the
device, assigned, or yet to be assigned. Click on the question mark icon to see the legend.

• For OCHCC circuits, displays the LMP links between the source or destination node and the DWDM
controller.
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If one or more devices participating in the circuit/VC is not part of your virtual domain, the Multilayer Trace
will be partial. Instead of the inaccessible device, you will see an inaccessible device icon in the Multilayer
Trace view (as shown in the figure below).

Three-Dimensional View of a Circuit V/C Trace
This is the default view. It displays a three-dimensional view of the full route of a circuit/VC. For information
about how to access this view, see Trace and Visualize the Full Route of Circuits/VCs, on page 18.

This view displays the different paths available for the selected circuit. For example, if an optical circuit has
working path, protected path, and restoration path, the paths are color-coded and displayed in this view.
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To know about the navigation controls in the three-dimensional view, click the help icon in the tool bar. The
Navigation Controls data popup window shows the mouse, MAC Trackpad, and keyboard controls to pan,
zoom, and rotate in this view.

The MAC Trackpad controls are displayed only for MAC users.Note

Linear View of a Circuit/VC Trace
Using the linear view, you can trace and visualize the route of a circuit/VC in a two-dimensional view. For
information about how to access this view, see Trace and Visualize the Full Route of Circuits/VCs, on page
18.
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This view displays only one path of the circuit at a time. Choose Route, and then select Working, Protected,
or Restored to view the required path in the circuit trace. The path options will vary depending on the type
of circuit/VC you selected.

View Specific Information of a Circuit in a Multilayer Trace View
In the multilayer trace view of a circuit, you can choose what information you want to view by enabling the
specific check box from the Show menu. You can choose to view the labels, physical flows, links, route
directions, SRRG, port states, power levels, span loss, and faults in the circuit. The check boxes vary depending
on the type of circuit/VC you selected.
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You can view either the alarm status or the primary state of the ports. For a list of the port primary state icons
and a description of the states, seePort or Interface States.

The Route Direction check box to view the animation of the route direction in a circuit, will be enabled by
default, only for those circuits which have non-symmetrical paths:

• Unidirectional circuits with path from A to Z. For example, Unidirectional TE Tunnels.

• Bidirectional non-symmetrical circuits with the paths from A to Z and Z to A not being the same. For
example, a Carrier Ethernet or a CEM circuit traversing over a unidirectional TE Tunnel.

The Route Direction check box will not appear in the Show menu for circuits that have exactly the same
path from A to Z and Z to A i.e., bidirectional symmetrical circuits.

Note

By default, the route direction from A to Z end will appear. To view the animation in the opposite direction,

click the icon. But this icon will be enabled only for those circuits (bidirectional non-symmetrical
circuit) that has different A to Z and Z to A paths. For example, a Carrier Ethernet or a CEM circuit traversing
over two different unidirectional TE Tunnels. The switch icon does not appear for these circuits:

• Unidirectional circuits with path from A to Z. For example, Unidirectional TE Tunnels.
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• Bidirectional symmetrical circuits with the paths from A to Z and Z to A being exactly the same. For
example, Bidirectional Core Routed TE Tunnel (or Flex LSP).

When you apply filter to the layers, the Route Direction check box gets disabled depending on the chosen
layer. Once disabled, it does not get auto-enabled and you have to manually enable the check box to view the
route direction animation again.

In case of a partially discovered circuit or a problematic/unsupported circuit configuration, the default route
direction from A to Z might not launch. But these circuits may have a potential Z to A direction, which
traverses a different path. Click the Change Endpoints hyperlink to configure the endpoints to launch the
multilayer trace view in the opposite direction.

Actions You Can Perform from the Multilayer Trace View
You can do the following from the Multilayer Trace view:

• Choose Show, and then check the appropriate check boxes to view the labels, physical flows, links, port
states, power levels, span loss, and faults in the circuit. For more information, see View Specific
Information of a Circuit in a Multilayer Trace View, on page 22.

• Click the View 360 hyperlink that appears right below the toolbar in the Multilayer Trace to open the
Circuit/VC 360 view. See Get Quick Information About a Circuit/VC: Circuit/VC 360 View.

• Click the Port icon on the circuit trace to open the Interface 360 view. See Get a Quick Look at a Device
Interface: Interface 360 View.

• Click the device name or device IP address that appears at the top of the device to open the Device 360
view. See Get Basic Device Information: Device 360 View.

• Click a link in the Multilayer Trace to open the Link 360 view. See Get a Quick Look at a Specific Link:
Link 360 View.

• Click the Cross Connection icon on the circuit trace to open the Link Details popup window.

The Cross Connection icon appears on the links where internal ports are used by
the circuit/VC. The internal ports are not displayed in the Multilayer Trace view.

Note

The following figure shows the Link Details popup window that lists the affected internal ports, port
status, layer, and power levels. These details are listed for all the affected internal ports in both directions,
that is from A side to Z side and vice versa.
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• Choose Actions > Y.1564 Test to test the performance of the CE circuit/VC end to end. See Running
a Y.1564 Performance Test, on page 10.

• Choose Actions > BERT to test the performance of the Circuit Emulation Services. See Performance
Test for Circuit Emulation Services, on page 15.

• Choose Actions > Optical PM Parameters to view the real time performance monitoring data of the
optical circuit/VC. See Optical Performance Monitoring Parameters, on page 13.

• Choose Actions > PRBS Test to test the performance of the optical circuit/VC end to end. See Run
PRBS Test on Circuits (ODU UNI), on page 14.

• Choose Actions > Details to view further details about the circuit. See Get Comprehensive Information
About a Circuit/VC: Circuit/VC Details Window.

• Choose Actions > Restoration Actions > Upgrade Restore to upgrade the failed optical circuit to an
active route and delete the old route where the failure occurred. See Restore a Circuit (Optical).

• Choose Actions > Resync to resync the conditions for the circuit or VCs.
• Choose Actions > Restoration Actions > Manual Revert to revert the optical circuit to its original
route when the route is recovered from the failure. See Restore a Circuit (Optical).

• Choose Actions > Reroute Actions > Working Path or Protected Path to reroute the traffic through
the working path or protected path defined for the circuit. See Reroute a Circuit (Optical).

• Choose Actions > Activate to allow the traffic to pass through the optical circuit. See Activate a Circuit
(Optical).

• ChooseActions >Deactivate to stop the traffic passing through the optical circuit. See Activate a Circuit
(Optical).

• Choose Actions > Protection Actions, and then choose the required protection switch action to switch
over the traffic from one path to another path in a protected optical circuit. See Initiate a Protection Switch
Action on a Circuit (Optical)

• Click the filter icon in the Multilayer Trace view toolbar to view the various layers in the circuit. Choose
the layers that you want to be displayed.
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