View Device Details

The following topics explain how to get more information about your network devices. You can also generate a variety of device reports that provide hardware and software details, CPU and memory utilization, general device health, and so forth. For information on these reports, see Device Reports. For information on inventory collection, see How Is Inventory Collected?

- Find Devices, on page 1
- Get Basic Device Information: Device 360 View, on page 1
- View a Device's Local Topology from the Device 360 View, on page 5
- View the Network's Hardware Inventory, on page 6
- Get Complete Device Information: Device Details Page, on page 6
- View and Manage Devices Using the Chassis View, on page 8
- View Device Ports, on page 17
- View Device Interfaces, on page 18
- View Device Modules, on page 22
- View Environment Information (Power Supplies, Fans), on page 23
- View Device Neighbors, on page 23
- Get More Information About Links, on page 24
- View Circuits/VCs, on page 24
- View Satellites, on page 24
- Create User Defined Fields for Custom Values, on page 25

Find Devices

The quickest way to find a device is to use the quick search text boxes displayed at the top of the Network Devices table (Inventory > Device Management > Network Devices). You can enter partial strings for a device name, IP address, or software version, or choose from the values for reachability, admin status, and Inventory Collection. If user defined fields have been created, you can also search by user defined field values. Devices are also organized into device groups, which you can view by choosing Inventory > Device Management > Network Devices and selecting a device type from the Device Group list.

Get Basic Device Information: Device 360 View

The Device 360 view is a pop-up window that provides quick information about a device, its inventory, and its status. This includes device alarms, modules, interfaces, neighbors, and chassis.
To launch a Device 360 view:

- Click the "i" icon next to an IP address in almost any device table
- From the network topology, click a device in an expanded group, then click **View**

The Device 360 view provides general device and performance information at the top of the view, and more detailed interface information in tabs in the lower part of the view. The information the Device 360 view displays depends on the device type and configuration. The Device 360 view provides the following information.

<table>
<thead>
<tr>
<th>Information Provided in Device 360 View</th>
<th>Description</th>
</tr>
</thead>
</table>

Get Basic Device Information: Device 360 View
General information and tools

Device type, its OS type and version, its last configuration change, and its last inventory collection. Icons convey the status of the device.

**Note**
- If you have opened the Device 360 view for a Cisco NCS 6000 device that houses a Secure Domain Router (SDR), the SDR's name is also listed.
- If you have opened the Device 360 view for a Cisco Catalyst 6500 Series device with dual and quad-supervisor Virtual Switching System (VSS), the device's redundancy state, switch mode, and operational redundancy mode is also listed.

Using the menus in the top right of the popup window, you can also perform these tasks:

- **Troubleshoot**—Perform a ping or traceroute, launch the Alarm browser, open a Cisco support case, or get information from the Cisco Support Community (*Actions* menu)

- **Performance**—Check device CPU and memory (*View > Performance Graphs*)

- **Topology**—View the network topology and the device's local topology, up to 3 hops (*Actions* menu)

- **Check the device's routing table** (*Actions* menu)

- **Open the Device Console** to enter commands you want to run on the device (*Actions* menu)

- **View the configuration that is currently running on the device** (*Actions > Show Command*)

- **Collect the device's inventory and save it to the database using Sync Now** (*Actions* menu)

- **Open an HTTP, HTTPS, SSH, or Telnet session with the device** (*Actions* menu)

- **Launch Cisco Transport Controller for optical devices** (*Actions* menu)

- **Enable the automatic refresh of the view every 20 seconds** (*Actions* menu)

- **Open the Device Details page to view details about software image and configuration file management, and use the device's Chassis View (by clicking the device IP address hyperlink or choosing View > Details)**

- **Select a device for a side-by-side comparison with another device on the basis of information such as raised alarms and the current status of circuits, interfaces, and modules** (*Actions* menu)—see Compare Device Information and Status
Performance data | Charts reflecting various aspects of the device performance. If a device has multiple memory pools, the Device 360 view will display the average utilization for all of the memory pools. If you want to see information about individual memory pools, use the memory utilization dashlets in the Network Summary dashboard. See Network Summary Dashboard Overview.

Alarms tab | Current alarms for the device, including their severity, status, and the time they were generated. Depending on the alarm source, you can also launch other 360 views from this tab.

Modules tab | Modules that are configured on the device, including their name, type, state, ports, and location.

Interfaces tab | Interfaces that are configured on the device, including status information. You can also launch an Interface 360 view for a specific interface.

Neighbors tab | NEs that are connected to this device through CDP (Cisco Discovery Protocol). If the selected device does not support CDP, this tab is empty. Displayed information includes device type and name, and the local port and device port. To view the neighbors in a popup topology map, choose Actions > N Hop Topology from the top right of the Device 360 view (see View a Device's Local Topology from the Device 360 View, on page 5.

Circuit/VCs tab | Circuit/VC name, type, customer, status, and creation date for each circuit provisioned on the device. You can also launch a Circuit/VC 360 view for specific circuits/VCs.

Satellites tab | For Cisco ASR 9000 devices in a cluster configuration, lists a satellite’s name, type, description, status, and IP and MAC addresses. You can also launch a Satellite 360 view for a specific satellite.

Civic Location | Geographical information about device's location.

Recent Changes | The last five changes made on the device, classified as: Inventory, Config (Configuration Archive), or SWIM (Software Images). (These are the same types of changes that are displayed when you choose Inventory > Network Audit.)

SRRGs | Lists the Shared Risk Resource Groups (SRRGs) assigned to the device. Click this tab's ? (help) icon to view its legend. For more information about SRRGs, see View and Manage Shared Risk Resource Groups (SRRG) in the Geo Map.

You can also view a specific device in the topology map by choosing Actions > Network Topology (at the top right of the Device 360 view).

**Compare Device Information and Status**

From the **Comparison View**, you can perform a side-by-side comparison of multiple devices, viewing information such as raised alarms, the status of modules, interfaces, and circuits on those devices, and a summary of recent changes that have been made. To compare devices, do the following:
Step 1  Choose one of the following to open the Network Devices page:

- **Monitor > Managed Elements > Network Devices**
- **Inventory > Device Management > Network Devices**

**Step 2**  For each device you want to compare:

a) Open its **Device 360** view by clicking the \( i \) (information) icon in the **IP Address** column.

b) Choose **Actions > Add to Compare**.

The device you selected is displayed at the bottom of the page. You can select a maximum of 4 devices.

**Step 3**  Click **Compare**.

The **Comparison View** opens.

**Step 4**  From the drop-down list at the top of the view, specify whether the view will show all available information or just the information that is unique to each device.

**Step 5**  Click **Comparison View**, check the check box for the categories you want the view to display, and then click **Save**.

By default, all of the categories are already selected.

**Step 6**  Scroll down the page to view the information provided for each category you selected.

Note the following:

- The **Comparison View** only displays information for two devices at a time. If you selected more than two, you will need to toggle to the devices that are not currently displayed.

- To reorder the devices you have selected, click **Rearrange**.

- Each device’s **View** and **Actions** menu is identical to the ones provided in their **Device 360** view. If you select an option, the corresponding page opens.

- You can minimize and maximize the categories displayed, as needed.

- The **Comparison View** is also available for circuits and VCs, interfaces, and links. Whenever you select any of these elements from their respective 360 view for comparison, they are displayed in the corresponding tab. This allows you to switch between element types, as needed.

- When you are done comparing devices, click **Back** at the top of the view and then click **Clear All** at bottom of the page. If tabs for other element types are still displayed, you will need to clear them as well.

---

**View a Device's Local Topology from the Device 360 View**

You can launch a small topology window from the Device 360 view that displays the network topology around a device, up to 3 hops.

**Step 1**  Open the Device 360 View for the device in which you are interested.
• Click the "i" icon next to an IP address in almost any device table.
• From the network topology, click a device in an expanded group, then click View.

Step 2  Choose N-Hop Topology from the Actions drop-down menu (at the top right of the Device 360 view).
Step 3  Adjust the popup window to show the information you need.
  • Click the edit icon
  • Select a hop count (1-3) from the Hop drop-down list.
  • Select a topology map layout from the Layout drop-down list.

Step 4  Save your changes, and use the pan and zoom tools to view the results.

---

**View the Network's Hardware Inventory**

Use this procedure to view basic hardware information for all devices in the network—the product name, physical location, serial number, manufacture date, and so forth.

**Step 1**  To view device-level information:
1. Choose Inventory > Device Management > Network Inventory.
2. Use the Quick Filters to locate specific devices. For example, to list the hardware information for all ASR devices, enter *ASR* in the Product Name field.

**Step 2**  To view element-level information, use one of these methods:
• Get the information from the Device Details page. See Get Complete Device Information: Device Details Page, on page 6.
• Get the information from the Chassis View. See Open the Chassis View, on page 9.
• Run a hardware report. See Device Reports.

---

**Get Complete Device Information: Device Details Page**

For the most comprehensive information about a device, view the Device Details page. It provides in-depth inventory information and configuration options.
To launch the Device Details Page:

- From a Device 360 view—Click the IP address hyperlink or choose View > Details.
- From a network devices table—Click the device name hyperlink in a device table.

The tabs that are displayed here depend on your selection in the Chassis View. They are described in the following table:

<table>
<thead>
<tr>
<th>Tab Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chassis View</td>
<td>Provides inventory, service, and alarm information that is contextualized to the element you select. Also serves as launch point for configuration, Image management, and Configuration Archive features. (To configure logical elements, click the Logical View tab.) For information on using the Chassis View features, see Overview of the Chassis View Window, on page 10.</td>
</tr>
<tr>
<td>Logical View</td>
<td>Provides logical inventory information. Also provides configuration options for logical elements.</td>
</tr>
<tr>
<td>Device Details</td>
<td>Provides system information (environment, modules ports, interfaces, and other settings). The Summary page contains graphs indicating the average utilization of all CPUs and the average utilization of all memory components for the device.</td>
</tr>
<tr>
<td>Alarms</td>
<td>Get information about the alarms that have been raised on a device, a card, or a port. See View an Alarm's Details.</td>
</tr>
<tr>
<td>Configuration</td>
<td>Configure a device, card, or port. Elements are grouped by their physical location. (To configure elements that are grouped according to their logical function, click the Logical View tab.) See Ways to Configure Devices Using Cisco Evolved Programmable Network Manager.</td>
</tr>
</tbody>
</table>
### View and Manage Devices Using the Chassis View

The Chassis View provides an interactive model of a device chassis and its hardware elements. From the Chassis View you can:

- View the contents of a chassis.
- Check the state of chassis elements and quickly locate problems.

<table>
<thead>
<tr>
<th>Tab Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inventory</td>
<td>View detailed hardware information such as serial numbers and manufacture dates for a device or card.</td>
</tr>
<tr>
<td>Interfaces</td>
<td>View the status of interfaces configured on a device, card, or port. From here, you can also open the Interface 360 view for a particular interface. For links to topics that describe other ways to view interface information in Cisco EPN Manager, see View Device Interfaces.</td>
</tr>
</tbody>
</table>
| Performance    | View summary information and high-level performance metrics. Note the following:  
  • If you are viewing the chassis view for any device other than a Cisco Converged Broadband Router-8 (cBR-8) router, information is displayed for the selected interface on a card or port. The dashlets displayed in addition to the Interface Details dashlet will vary, depending on the interface type you chose. After choosing an interface from the Interface drop-down list, make sure to click Apply in order to refresh the information that is displayed.  
  • If you are viewing the chassis view for a Cisco cBR-8 router, information is also displayed for the device as a whole. You can view dashlets that provide information such as the number of voice calls that have been made and upstream/downstream utilization percentages. To ensure that information is collected and reported for the Cisco cBR-8 routers in your network, verify that Cable Policies is listed on the Monitoring Policies page (Monitor > Monitoring Tools > Monitoring Policies > Policies pane), is currently active, and has polling intervals set for its parameters.  
  Note: You can display up to 10 dashlets at a given point of time on the Performance tab. To choose these dashlets, click the Settings icon on the top right corner of the pane and use the Add Dashlet(s) option to make your selection. |
| Circuits       | View the circuits a device, card, or port participates in. For links to topics that describe other ways to view circuit information in Cisco EPN Manager, see View Circuits/VCs. |
| Image          | Manage the software image that is running on the device. See View the Images That Are Saved in the Image Repository.  
  Note: This tab is only available when a top-level chassis is selected. |
| Configuration  | Manage the device configuration file that is running on the device. See View All Archived Files.  
  Note: This tab is only available when a top-level chassis is selected. |
- View alarmed elements and launch views that provide alarm details.
- Configure interfaces (using the launch point that opens the Device Details page).

The elements that are displayed in the Chassis View depend on the device type and the elements that are configured on the device.

Note that Admin users do not have read/write access to chassis views by default. To enable access for this user group, open the Users, Roles & AAA page, choose User Groups, and then check the Chassis View Read and Write check box (under Network Monitoring in the Tasks Permissions tab). See View and Change the Tasks a Group Can Perform.

See these topics for information about how to launch and use the Chassis View:

## Open the Chassis View

The following table describes the various ways you can open the Chassis View. If a device does not provide these launch points, it means the device does not support the Chassis View. For a list of devices that support the Chassis View, see [https://www.cisco.com/c/en/us/support/cloud-systems-management/evolved-programmable-network-epn-manager/products-device-support-tables-list.html](https://www.cisco.com/c/en/us/support/cloud-systems-management/evolved-programmable-network-epn-manager/products-device-support-tables-list.html).

<table>
<thead>
<tr>
<th>To open a Chassis View from:</th>
<th>Do the following:</th>
<th>The Chassis View is displayed in:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network Devices table</td>
<td>Click ‹ next to the device IP address.</td>
<td>A pop-up window</td>
</tr>
<tr>
<td></td>
<td>Click a device name hyperlink.</td>
<td>A full-page view</td>
</tr>
<tr>
<td>Device 360 view</td>
<td>Choose View &gt; Chassis View from the top right of the Device 360 view.</td>
<td>A pop-up window</td>
</tr>
<tr>
<td></td>
<td>Choose View &gt; Details from the top right of the Device 360 view.</td>
<td>A full-page view</td>
</tr>
<tr>
<td>Device Details page</td>
<td>Click the Chassis View tab.</td>
<td>A full-page view</td>
</tr>
</tbody>
</table>

To open a full-page Chassis View from a Chassis View pop-up window, click the Launch Configuration link in the top right corner of the window.

## Permissions Required to View and Configure Devices Using the Chassis View

The following table describes the Chassis View permissions that are granted to members of the Cisco EPN Manager user groups. These permissions cannot be edited. For more information on user groups, see Control the Tasks Users Can Perform (User Groups)

- Full access (read and write)—Users in this group can view and configure devices using the Chassis View.
- Read-only access—Users in this group can use the Chassis View to view devices but not to configure them.
- Write-only access—Users in this group can use the Chassis View to configure devices but not view them (only applies to the NBI Write group).
• No access—Users in this group cannot access or use the Chassis View.

<table>
<thead>
<tr>
<th>Group Type</th>
<th>Read</th>
<th>Write</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web UI</td>
<td>Root</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Super Users</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Admin</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>Config Managers</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>System Monitoring</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>User-Defined 1-4</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Monitor Lite</td>
<td>X</td>
</tr>
<tr>
<td>NBI</td>
<td>NBI Credential</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>NBI Read</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>NBI Write</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td>North Bound API</td>
<td>X</td>
</tr>
</tbody>
</table>

**Overview of the Chassis View Window**

The following illustration shows the Chassis View for a Cisco ASR 903 router.

In this example, the user then clicked a port that is currently down.
The Chassis View updates, displaying only the line card module that the port resides on and zooming in on it. The port pulsates in the Chassis View to help the user locate it. The badges displayed on the ports in this module indicate the primary status of those port (see Port or Interface States, on page 13). Some elements may be surrounded by colored lines to indicate their state (out of service, pre-provisioned, and so forth). To open a key that explains the meaning of the badges and these other indicators, click at the bottom right of the Chassis View.

If a device has multiple chassis or shelves, each chassis or shelf is displayed in the same Chassis View (for an example, see View Mixed Chassis, Multi-Chassis, and Multi-Shelf Devices in the Chassis View, on page 14). If a card image cannot be retrieved, the Chassis View displays a question mark alongside the card name. Note the following:

- The colors rendered in the Chassis View may not match your physical device because the Chassis View displays a generic image that is packaged with Cisco EPN Manager.
- If you have opened the Chassis View for a Cisco NCS 6000 device that houses a Secure Domain Router (SDR), both the device type and the SDR's name are displayed at the top of the Chassis View. Keep in mind that there may be cases where the SDR label for a device that belongs to a cluster or a user-defined group is not displayed (since auto-clustering is applied to devices based on their proximity).

The following table describes the Chassis View’s components and their function:

<table>
<thead>
<tr>
<th>Chassis View Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Opens a field you can use to search for a particular rack, shelf, module, or interface on a device.</td>
</tr>
<tr>
<td></td>
<td>Opens the Chassis Explorer.</td>
</tr>
<tr>
<td>Chassis View Component</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>[ ]</td>
<td>Indicates the device’s reachability state (see Device Reachability and Admin States). This example indicates the device is reachable.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Indicates the device’s administrative status (see Device Reachability and Admin States). This example indicates the device is managed.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Opens the device’s <strong>Device 360</strong> view. See Get Basic Device Information: Device 360 View.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Opens the device’s Device Details page. The tabs displayed on this page will vary, depending on whether a device, module, or port is currently selected in the Chassis View. See Get Complete Device Information: Device Details Page.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Adds a shortcut to the device’s Chassis View in the <strong>Dock</strong> window. See Customize the Dock Window.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Closes the <strong>Chassis View</strong>.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Zooms in on an image.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Zooms out from an image.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Resizes an image so it can be viewed in its entirety within the <strong>Chassis View</strong>.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Opens a pop-up window that allows you to .</td>
</tr>
<tr>
<td>[ ]</td>
<td>Toggles between the front and rear Chassis View for a device that supports this feature. A callout that appears when you place your cursor over this icon indicates which view you are opening. This feature is supported by the following Cisco devices:</td>
</tr>
<tr>
<td></td>
<td>• ASR 901S</td>
</tr>
<tr>
<td></td>
<td>• cBR-8</td>
</tr>
<tr>
<td></td>
<td>• NCS 1001, 1002, 5001, 5002, and 5008</td>
</tr>
<tr>
<td>[ ]</td>
<td>Rotates the image of the module that is currently displayed. This icon is not available when an entire device is displayed.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Click to access the <strong>Enable Alarm Blinking</strong> check box. When checked, any alarm badges displayed for a module or port will blink in order to draw attention to them and make them easier to locate.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Opens a key that explains the significance of badges and colored lines displayed in the <strong>Chassis View</strong>.</td>
</tr>
</tbody>
</table>
View Network Element State Information in the Chassis View

Badges, lines, and colors provide information about the operational state, elements and components in a device. Click the Legends icon at the bottom right of the Chassis View to display a key that lists what the badges, lines and colors mean.

See these topics for more information:

- Equipment Operational States (Chassis View), on page 13
- Port or Interface States, on page 13

Note

Port state information is not shown for the CFP ports on an A9K-400G-DWDM-TR line card as these ports are not yet supported.

Equipment Operational States (Chassis View)

The equipment operational states represent the running state of the network element.

<table>
<thead>
<tr>
<th>Equipment Operational State</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>In Service</td>
<td>(none)</td>
<td>Equipment is operating properly.</td>
</tr>
<tr>
<td>Pre-provisioned</td>
<td>![Icon]</td>
<td>(Cisco NCS 2000 and Cisco ONS devices only) Equipment has been configured but is not physical present in the chassis.</td>
</tr>
<tr>
<td>Failed/Disabled/Down/Out of Service/Out of Service Maintenance</td>
<td>![Icon]</td>
<td>Equipment is not operating properly.</td>
</tr>
<tr>
<td>Unknown</td>
<td>![Icon]</td>
<td>Equipment operational state is unknown. No response (or insufficient response) from the device.</td>
</tr>
</tbody>
</table>

Port or Interface States

Port or Interface Primary States—Conveys the most important state information for a port or interface by combining the admin and operational states. The Multilayer Trace displays either a port's primary state or alarm status. For the Chassis View, if an element does not support the changing of color to indicate a state change, you can still get the state change information from the alarm that is generated.

Note

If there is an alarm associated with a port/interface, alarm icon will show up, port icon will not show.

<table>
<thead>
<tr>
<th>Port or Interface Primary State</th>
<th>Icon</th>
<th>Admin Status</th>
<th>Operational State</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unknown</td>
<td>![Icon]</td>
<td>Unknown</td>
<td>Unknown</td>
</tr>
</tbody>
</table>
Port or Interface Admin Status—Represents the configured state of the port or interface (for example, if an administrator has manually shut down a port).

<table>
<thead>
<tr>
<th>Port or Interface Admin Status</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unknown</td>
<td>🎁</td>
<td>Port or interface admin status is unknown. There is no response (or insufficient response) from the device.</td>
</tr>
<tr>
<td>Admin Down</td>
<td>🤔</td>
<td>Port or interface was manually shut down by the administrator.</td>
</tr>
<tr>
<td>Up</td>
<td>🟢</td>
<td>Port or interface is enabled by the administrator.</td>
</tr>
<tr>
<td>Test</td>
<td>🟢</td>
<td>Port or interface is being tested by the administrator.</td>
</tr>
</tbody>
</table>

Port or Interface Operational State—Conveys the port or interface's running state and whether it is working properly.

<table>
<thead>
<tr>
<th>Port or Interface Operational State</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unknown</td>
<td>🎁</td>
<td>Port or interface operational state is unknown. There is no response (or insufficient response) from the device.</td>
</tr>
<tr>
<td>Down</td>
<td>🠺</td>
<td>Port or interface is not working properly.</td>
</tr>
<tr>
<td>Up</td>
<td>🟢</td>
<td>Port or interface is receiving and transmitting data.</td>
</tr>
<tr>
<td>Auto Up</td>
<td>🟢</td>
<td>Port or interface is receiving and transmitting data (only certain devices support this state; other devices use &quot;Up&quot;).</td>
</tr>
</tbody>
</table>

View Mixed Chassis, Multi-Chassis, and Multi-Shelf Devices in the Chassis View

The following example shows a mixed Chassis View that has both Cisco NCS 2000 and Cisco ONS 15454 chassis. Shelf numbers are not consecutive because of the different types of chassis.
For mixed-chassis, multi-chassis, and multi-shelf devices, Cisco EPN Manager aggregates alarms to a chassis or shelf as explained in View Alarms in the Chassis View, on page 15.

For multi-chassis devices in a cluster, the Device 360 view’s Chassis tab identifies which chassis is the primary and which is the backup.

**Note**
Chassis View opened for a multi-shelf device will display only the first 4 racks, and requires the user to click the download button (displayed on the rack number 5 and above) to display the relevant rack information.

### View Alarms in the Chassis View

An alarm badge in the Chassis View represents one or more alarms that have been localized to a piece of equipment. For an element with multiple alarms, the badge icon will convey the most severe alarm.
To customize the Chassis View so that alarm icons blink (to bring your attention to them), click ![Enable Alarm Blinking](image) from the bottom right of the view, then check the **Enable Alarm Blinking** check box.

**Note**
If there is an alarm associated with a port/interface, alarm icon will show up, port icon will not show.

To view the alarms specific to a device, do the following:

**Step 1**
With a device's Chassis View open, click the **Launch Configuration** link.

The Device Details page opens.
Step 2 If not already selected, click the **Alarms** tab. All of the alarms that have been raised for the device are listed here.

Step 3 To view the alarms for a specific device component (such as a line card or port), do one of the following:

- Double-click the component in the Chassis View.

- Click to open the **Chassis Explorer**, then click its entry.

---

**View Routes of a Circuit in the Chassis View**

You can view the end-to-end physical route of a circuit using the Chassis View of a device participating in the circuit. You can also choose to view the power levels and span loss in the circuit.

**Note** This feature is available only for the OCH WSON Optical circuit type.

---

**Step 1** From the left sidebar, choose **Inventory > Device Management > Network Devices**.

**Step 2** From the Network Devices table, click the required device's name hyperlink to open the full-page view of the Chassis View.

**Step 3** Expand the Chassis View Explorer, and then select the shelf.

**Step 4** In the right pane, click the **Circuits** sub-tab, and then select the circuit for which you want to view the physical routes.

The Chassis View displays the physical routes of the circuit. The internal connections between the ports of the same card are displayed as dotted lines.

**Step 5** In the left pane, next to the Chassis View, click the eye icon to show or hide the physical routes, power levels, and span loss.

---

**View Device Ports**

You can get in-depth information about a device's physical ports from the Device Details page. You can also get basic port information from various 360 views.

To view a device chassis with its modules and ports, use the Chassis View. See **Open the Chassis View, on page 9**.

| To view this port information: | Do the following: |
View Device Interfaces

Cisco EPN Manager provides the following ways to view device interfaces:

<table>
<thead>
<tr>
<th>Ways to View Interfaces</th>
<th>For more information, see:</th>
</tr>
</thead>
<tbody>
<tr>
<td>View details about a specific interface</td>
<td>Get a Quick Look at a Device Interface: Interface 360 View, on page 19</td>
</tr>
</tbody>
</table>
| View a specific device's interfaces | • View a Specific Device's Interfaces: Device 360 View, on page 18  
• Get Comprehensive Information About a Device's Interfaces Using the Device Details Page, on page 21 |

View a Specific Device's Interfaces: Device 360 View

Use the Device 360 view to quickly check the status of a device's interfaces.

Step 1

Open the Device 360 view:

• Click the "i" icon next to an IP address in almost any device table
• From the network topology, click a device in an expanded group, then click View

Step 2

Click the Interfaces tab.
Get a Quick Look at a Device Interface: Interface 360 View

The Interface 360 view shows summary information for a specific interface including general interface details, interface status, alarms on the interface, circuits/VCs traversing the interface, and performance information. From the Interface 360 view's Actions menu, you can perform basic tasks such as enabling and disabling the interface, and so on. The Show in Topology option launches the topology map so that you can view the interface in the context of the map.

You can launch the Interface 360 view wherever you see an "i" icon next to an interface name—for example, in an alarms table, a links table or in a device 360 view.

The Interface 360 view provides general interface information at the top of the view, and more detailed interface information in tabs in the lower part of the view. The information the Interface 360 view displays depends on the interface configuration.

The tabs displayed vary depending on the type of interface for which you launched this view. For example, for optical interfaces you might see the Optical Physical tab or the ODU tab, depending on the type of optical interface.

Using the menus in the top right of the pop-up window, you can also perform these tasks:

- Open a chassis view that highlights the port or line card the interface is associated with (View menu). This feature comes in handy when you need to describe to an onsite technician where to find the source of an issue.

- Select the interface for a side-by-side comparison with another interface on the basis of information such as raised alarms and the current status of associated circuits and VCs (Actions menu)—see Compare Interface Information and Status, on page 20.

- View performance information in the relevant performance dashboard for the specific interface type by selecting View > Performance.

- Enable and disable the interface from the Actions menu.

- Enable and disable the lockout of an MPLS interface from the Actions menu. You would lock out an MPLS interface before doing maintenance work on the TE Tunnel link that the interface belongs to. After you lock out an MPLS interface, be sure to manually sync the device. Otherwise, you will not have the option to disable the lockout later.

- View the device on which the interface is located in a topology map (Actions menu).

- Set a baseline for performance data for optical interfaces (except for optical physical interfaces) for troubleshooting purposes. See Set a Baseline for Optical Performance Data, on page 21 for more information.

<table>
<thead>
<tr>
<th>Information Provided in Interface 360 View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General information</td>
<td>The interface name, status, description, type, device name; IP address, MAC address, and so forth.</td>
</tr>
<tr>
<td>Performance data</td>
<td>Launch point to the relevant performance dashboard from View &gt; Performance.</td>
</tr>
</tbody>
</table>
Current alarms for the interface, including their severity, status, and the time they were generated. Also provides a launch point to the Alarm Browser.

Name, interface type, and operational and admin status for each associated interface. Also provides a launch point for the Interface 360 view.

(For interfaces that participate in circuits) Circuit/VC name, type, customer, status, and creation date. Also provides a launch point for the Circuit/VC 360 view.

All EFPs associated with the interface (if relevant). Also provides their operational status, admin status, and EFP type.

Additional interface information and performance data in tabs relevant to the type of interface, for example, Optical Physical, ODU, FEC, and so on.

Real-time performance monitoring data for the interface. This data is collected every 10 seconds, and the results of the last 12 pollings are displayed here. For a listing of the counters that can be displayed, see Reference—Performance Counters for Physical Interfaces.

**Compare Interface Information and Status**

From the **Comparison View**, you can perform a side-by-side comparison of multiple interfaces, viewing information such as IP and MAC address, raised alarms, and associated circuits and VCs. To compare interfaces, do the following:

**Step 1**
For each interface you want to compare:

a) Open its **Interface 360** view, as described in Get a Quick Look at a Device Interface: Interface 360 View, on page 19.

b) Choose **Actions > Add to Compare**.

The interface you selected is displayed at the bottom of the page. You can select a maximum of 4 interfaces.

**Step 2**
Click **Compare**.

The **Comparison View** opens.

**Step 3**
From the drop-down list at the top of the view, specify whether the view will show all available information or just the information that is unique to each interface.

**Step 4**
Click **Comparison View**, check the check box for the categories you want the view to display, and then click **Save**.

By default, all of the categories are already selected.

**Step 5**
Scroll down the page to view the information provided for each category you selected.

Note the following:

- The **Comparison View** only displays information for two interfaces at a time. If you selected more than two, you will need to toggle to the interfaces that are not currently displayed.

- To reorder the interfaces you have selected, click **Rearrange**.
• Each interface's View and Actions menu is identical to the ones provided in its Interface 360 view. If you select an option, the corresponding page opens.

• You can minimize and maximize the categories displayed, as needed.

• The Comparison View is also available for circuits and VCs, devices, and links. Whenever you select any of these elements from their respective 360 view for comparison, they are displayed in the corresponding tab. This allows you to switch between element types, as needed.

• When you are done comparing interfaces, click Back at the top of the view and then click Clear All Items at bottom of the page. If tabs for other element types are still displayed, you will need to clear them as well.

Get Comprehensive Information About a Device's Interfaces Using the Device Details Page

Use the Device Details page to get extensive information about all of the interfaces that are configured on a device. For easier navigation, interfaces are grouped together by type.

Step 1
Open the Device Details page.
• Click the device name hyperlink which appears in many of the device tables
• Choose View > Details at the top right of the Device 360 view

Step 2
Under the Device Details tab, double-click Interfaces to display a list of all interfaces (of all types) that are configured on the device.

Step 3
To display all interfaces of the same type, click the type (such as Ethernet Interfaces).

Step 4
To get details about a specific interface, click the interface name hyperlink.

Set a Baseline for Optical Performance Data

Setting a baseline for optical interface performance data enables you to compare realtime network performance with a fixed set of performance statistics. In this way, you could compare normal baseline network performance with abnormal network behavior.

After you set a baseline, all new incoming performance statistics are recalculated based on the baseline values to show you the difference between the baseline values and the current realtime values (specifically, the current value minus the baseline value).

Optical interfaces that support this functionality will have a Set Baseline button in the relevant tab in the Interface 360 view.

To set a baseline for optical interface performance statistics:

SUMMARY STEPS

1. Open the Interface 360 view for the relevant interface.
2. Open the tab specific to the interface type, for example, FEC, OTU, and so on.
3. Click the **Set Baseline** button.
4. To go back to the realtime values (effectively removing the baseline), close the Interface 360 view and then reopen it.

**DETAILED STEPS**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>Open the Interface 360 view for the relevant interface.</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Open the tab specific to the interface type, for example, FEC, OTU, and so on.</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>Click the <strong>Set Baseline</strong> button. The rows in the table will be cleared. Each new row will have values that reflect the difference between the baseline values and the current realtime values.</td>
</tr>
<tr>
<td><strong>Step 4</strong></td>
<td>To go back to the realtime values (effectively removing the baseline), close the Interface 360 view and then reopen it.</td>
</tr>
</tbody>
</table>

**View Device Modules**

To view device module information, choose **Inventory > Device Management > Network Devices**, then launch a Device 360 or Device Details page, depending on how much information you want.

<table>
<thead>
<tr>
<th>To get this information:</th>
<th>Use this navigation:</th>
</tr>
</thead>
</table>
| Basic module information: Status, type, ports | From the Device 360 view, click the **Modules** tab. To open the Device 360 view:  
  - Click the “i” icon next to the device name in almost any device table  
  - From the Network Topology, click a device (in an expanded view), then click **View** |
| Module equipment type and power information | From the Device Details page, choose **System > Modules** under the Device Details tab.  
To open the Device Details page:  
  - Click the device name hyperlink which appears in many device tables  
  - Choose **View > Details** from the top right of the Device 360 view |

**Note** Due to a limitation in the retrieval of module related information, this page lists SFP transceivers of Cisco CAT6500 devices as ‘Unspecified’ products.
View Environment Information (Power Supplies, Fans)

Environment-related information, such as details about power supplies and fans, is displayed in a device’s Device Details page. To access this information:

Step 1
Do one of the following:

• Click the device name hyperlink that appears in many Cisco EPN Manager device tables and then click the Device Details tab (if it is not already selected).

• Choose View > Details from the top right of a Device 360 view and then click the Device Details tab (if it is not already selected).

Step 2
From the Features pane, choose System > Power Options & Fans.

View Device Neighbors

Device neighbor information, such as the neighbor name, port number, index, and duplex setting, is displayed in a device’s Device 360 view.

Step 1
Open the Device 360 view:

• Click the i (information) icon next to the device name in almost any device table

• From the network topology, click a device in an expanded group and click View

Step 2
Click the Neighbors tab.

Example

For example:

<table>
<thead>
<tr>
<th>Name</th>
<th>Index</th>
<th>Port</th>
<th>Duplex</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASR9K</td>
<td>7</td>
<td>TenGigE0/0/2/0</td>
<td>fullduplex</td>
</tr>
<tr>
<td>CPE-ISRG2</td>
<td>67</td>
<td>GigabitEthernet0/0/3</td>
<td>fullduplex</td>
</tr>
<tr>
<td>Astr_903</td>
<td>36</td>
<td>GigabitEthernet0/0/0</td>
<td>fullduplex</td>
</tr>
</tbody>
</table>
Get More Information About Links

Cisco EPN Manager provides a variety of ways that you can view links and get more details about them:

<table>
<thead>
<tr>
<th>To view link information for:</th>
<th>See the procedures in:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A specific link</td>
<td>Get a Quick Look at a Specific Link: Link 360 View</td>
</tr>
<tr>
<td>A specific link in a topology map</td>
<td>View a Specific Link in the Topology Map</td>
</tr>
<tr>
<td>A group in a topology map</td>
<td>View a Device Group's Links in a Network Topology Map</td>
</tr>
<tr>
<td>All of Cisco EPN Manager</td>
<td>View Link Tables</td>
</tr>
</tbody>
</table>

View Circuits/VCs

Cisco EPN Manager provides a variety of ways that you can view circuits/VCs:

<table>
<thead>
<tr>
<th>To view circuit/VC information for:</th>
<th>See the procedures in:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A specific circuit/VC in a topology map, in a Circuit/VC 360 view, or in a Circuit/VC Details page</td>
<td>• Get Quick Information About a Circuit/VC: Circuit/VC 360 View</td>
</tr>
<tr>
<td></td>
<td>• Get Comprehensive Information About a Circuit/VC: Circuit/VC Details Window</td>
</tr>
<tr>
<td>A device</td>
<td>View a Specific Device's Circuits/VCs</td>
</tr>
<tr>
<td>A device group in a topology map or in an expanded table</td>
<td>View a Device Group's Circuits/VCs</td>
</tr>
<tr>
<td>All of Cisco EPN Manager</td>
<td>View All Circuits/VCs in Cisco EPN Manager</td>
</tr>
</tbody>
</table>

View Satellites

Cisco EPN Manager provides the following ways to view satellite information for host-satellite configurations:

<table>
<thead>
<tr>
<th>Ways to View Satellites</th>
<th>For more information, see:</th>
</tr>
</thead>
<tbody>
<tr>
<td>View all satellites in a location group using a topology map</td>
<td>View Cisco ASR 9000 Host-Satellite Topologies in the Topology Map</td>
</tr>
<tr>
<td>View a specific device's satellites from a Device 360 view</td>
<td>• Identify the Satellites Connected to a Cisco ASR 9000 Host</td>
</tr>
<tr>
<td></td>
<td>• Get Basic Device Information: Device 360 View, on page 1</td>
</tr>
</tbody>
</table>
Create User Defined Fields for Custom Values

If you want to assign custom attributes to devices or circuits/VCs, you can create your own fields to be shown in the tables and you can define custom values in those fields. For example, you might want to label certain devices with a customer name. After you have created user defined fields and assigned values, you can search by these values in the device tables and in the maps.

To create user defined fields:

**Step 1** Choose **Administration > Settings > System Settings > Inventory > User Defined Fields**.

**Step 2** Click the ‘+’ icon and create a new label and description.

**Step 3** Assign values in your newly created user defined field for specific devices/circuits/VCs as follows:

a) Go to the device table or to the table of circuits/VCs.

b) Display your user defined field as a column in the table by clicking the settings icon at the top right of the page, choosing **Columns**, and then selecting your user defined field.

c) Go to the required device or circuit/VC in the table, enter a value in your user defined column, and click **Save**.