CONTENTS

Full Cisco Trademarks with Software License  7

PART I  Get Started with Cisco EPN Manager  37

CHAPTER 1  Get Started With Cisco EPN Manager  1

Web Client Requirements  1
Log In and Out  2
Setup Tasks That Should Be Completed Before Using Cisco EPN Manager  2
Change Your Password  3
Use the Main Window Controls  3
Change Your Default Home Page  5
Set Up and Use the Dashboards  6

Types of Dashboards  6

Service Performance Dashboard Overview  7
Performance Dashboard Overview  8
Network Summary Dashboard Overview  12
Cable Dashboard Overview  15
Device Trends Dashboard Overview  18
DWDM/OTN Performance Dashboard Overview  19

How to Use the Dashboards  19

Add a New Dashboard  21
Customize a Dashboard Tab  21
Add Dashlets to Dashboards  22
Customize the Dock Window  24
Find Out Why Data Is Missing from a Dashboard  25

Work In a Different Virtual Domain  25
Manage the Inventory 31

CHAPTER 2

Add and Organize Devices 33

Which Device Software Versions Are Supported by Cisco EPN Manager? 33

Generic Device Support 34

Add Devices to Cisco EPN Manager 35

Add Cisco ME1200 devices in Cisco EPN Manager 35

Add Devices Using Discovery 36

Verify SNMP Communication 37

Specify the Management IP Address Type (IPv4/IPv6) for Discovered Devices 37

Run Quick Discovery 37

Run Discovery With Customized Discovery Settings 38

Import Devices Using a CSV File 40

Create the CSV File 40

Import the CSV File 40

Add Devices Manually (New Device Type or Series) 41

Example: Add a Single Cisco NCS 2000 or NCS 4000 Series Device 42

Example: Add a Network Element as an ENE Using Proxy Settings 42

Example: Enabling a Single Session on Cisco NCS 2000 Series Devices 43

How Is Inventory Collected? 43

Configure Devices So They Can Be Modeled and Monitored 44

Configure Devices To Forward Events To Cisco EPN Manager 45

Required Settings—Cisco IOS and IOS-XE Device Operating System 45

Required Settings—Cisco IOS XR Device Operating System 46

Required Settings—Cisco NCS Series Devices 49

Required Settings—Cisco NCS 4000 Series Devices 49

Required Settings—Cisco NCS 4200 Series Devices 51

Required Settings—Cisco ONS Device Operating System 53

Required Configuration for IPv6 Devices 53
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Archive Logging on Devices</td>
<td>53</td>
</tr>
<tr>
<td>Apply Device Credentials Consistently Using Credential Profiles</td>
<td>54</td>
</tr>
<tr>
<td>Create a New Credential Profile</td>
<td>54</td>
</tr>
<tr>
<td>Apply a New or Changed Profile to Existing Devices</td>
<td>54</td>
</tr>
<tr>
<td>Delete a Credential Profile</td>
<td>55</td>
</tr>
<tr>
<td>Check a Device's Reachability State and Admin Status</td>
<td>55</td>
</tr>
<tr>
<td>Device Reachability and Admin States</td>
<td>56</td>
</tr>
<tr>
<td>Move a Device To and From Maintenance State</td>
<td>57</td>
</tr>
<tr>
<td>Validate Added Devices and Troubleshoot Problems</td>
<td>57</td>
</tr>
<tr>
<td>Find Devices With Inventory Collection or Discovery Problems</td>
<td>58</td>
</tr>
<tr>
<td>Retry Job for Device Modeling</td>
<td>59</td>
</tr>
<tr>
<td>Export Device Information to a CSV File</td>
<td>60</td>
</tr>
<tr>
<td>Create Groups of Devices for Easier Management and Configuration</td>
<td>61</td>
</tr>
<tr>
<td>How Groups Work</td>
<td>61</td>
</tr>
<tr>
<td>Network Device Groups</td>
<td>62</td>
</tr>
<tr>
<td>Port Groups</td>
<td>62</td>
</tr>
<tr>
<td>How Elements Are Added to Groups: Dynamic, Manual, and Mixed Groups</td>
<td>63</td>
</tr>
<tr>
<td>Groups and Virtual Domains</td>
<td>64</td>
</tr>
<tr>
<td>Create User-Defined Device Groups</td>
<td>64</td>
</tr>
<tr>
<td>Create Location Groups</td>
<td>65</td>
</tr>
<tr>
<td>Create Port Groups</td>
<td>67</td>
</tr>
<tr>
<td>Make Copies of Groups</td>
<td>67</td>
</tr>
<tr>
<td>Hide Groups That Do Not Have Any Members</td>
<td>68</td>
</tr>
<tr>
<td>Delete Groups</td>
<td>68</td>
</tr>
<tr>
<td>Delete Devices</td>
<td>68</td>
</tr>
</tbody>
</table>

**CHAPTER 3**

**View Device Details**  
Find Devices  
Get Basic Device Information: Device 360 View  
Compare Device Information and Status  
View a Device's Local Topology from the Device 360 View  
View the Network's Hardware Inventory  
Get Complete Device Information: Device Details Page  
View and Manage Devices Using the Chassis View
How Do I Find Out the Last Time Files Were Archived? 98
Back Up Device Configuration Files to the Archive 99
  What Is Backed Up to the Database? 99
  Back Up (Archive) Configuration Files 99
View the Device Configuration Files That Are Saved in the Archive 101
  View All Archived Files 101
  View Archived Files for a Specific Device 101
  View the Raw Content of an Archived Configuration File 102
View a Device's Running Configuration File (Raw Content) 102
Label Important Configuration Files With Tags 103
Synchronize Running and Startup Device Configurations 103
Download Configuration Files 103
Compare or Delete Device Configuration Files 104
Deploy an External Configuration File to a Device 105
Overwrite a Startup Configuration with a Running Configuration 106
Roll Back a Device's Configuration To an Archived Version 106
Export Configuration Files to a Local File System 107
Delete Archived Device Configuration Files 108
Check the Network Audit for Configuration Archive Operations 108

CHAPTER 5  Manage Device Software Images 111
Set Up Software Image Management 111
  Make Sure Devices Are Configured Correctly 112
  Verify the FTP/TFTP/SFTP/SCP Settings on the Cisco EPN Manager Server 112
  How to Control Images that are Saved to the Image Repository During Inventory Collection 112
  Adjust Criteria for Cisco.com Image Recommendations 113
  Adjust Image Transfer and Distribution Preferences 113
  Add a Software Image Management Server to Manage Groups of Devices 114
  Change Cisco.com Credentials for Software Image Operations 115
Copy Software Images from Devices to the Image Repository (Create a Baseline) 115
How Do I Find Out Which Images Are Used by Network Devices? 115
How Do I Know a Device Has the Latest Image? 116
View the Images That Are Saved in the Image Repository 116
Find Out Which Devices Are Using an Image 117
View Recommended and Available Software Images from Cisco.com 117
View Recommended Images on Cisco.com 117
View Available Images on Cisco.com 118
How Do I Know Whether I have Permission to Download Software from Cisco.com 119
Add (Import) Software Images to the Repository 119
Add a Software Image That Is Running on a Managed Device 119
Add a Software Image from an IPv4 or IPv6 Server (URL) 120
Add a Software Image for an FTP Protocol Server (Protocol) 121
Add a Software Image from a Client Machine File System 121
Change the Device Requirements for Upgrading a Software Image 122
Verify That Devices Meet Image Requirements (Upgrade Analysis) 122
Distribute a New Software Image to Devices 123
Activate a New Software Image on Devices 129
Activate, Deactivate, and Remove Cisco IOS XR Images from Devices 132
View and Upgrade FPD Images 132
Commit Cisco IOS XR Images Across Device Reloads 133
Roll Back Cisco IOS XR Images 133
Check the Network Audit for Software Image Operations 134
Delete Software Image Files from the Image Repository 135

CHAPTER 6
Perform Configuration Audits Using Compliance 137
How To Perform a Compliance Audit 137
Enable and Disable Compliance Auditing 138
Create a New Compliance Policy 139
Create Compliance Policy Rules 139
Examples—Rule Conditions and Actions 140
Example Conditions and Actions: DNS Servers Configured on Device 140
Example: Block Options 140
Example Conditions and Actions: Community Strings 142
Example Conditions and Actions: IOS Software Version 142
Example Conditions and Actions: NTP Server Redundancy 142
Create a Compliance Profile That Contains Policies and Rules 143
Run a Compliance Audit 144
View the Results of a Compliance Audit 145
View Violation Job Details 146
View Change Audit Details 146
View Audit Failure and Violation Summary Details 146
Fix Device Compliance Violations 147
View Audit Failure and Violation Summary Details 148
Import and Export Compliance Policies 149
View the Contents of a Compliance Policy XML File 149
View PSIRT and EOX Information 149
  View Device Security Vulnerabilities 150
  View Device Hardware and Software End-of-Life Report 150
  View Module Hardware End-of-Life Report 151
  View Field Notices for Device 151

PART III

Visualize the Network 153

CHAPTER 7

Visualize the Network Topology 155
  Network Topology Overview 155
  View Detailed Tables of Alarms, Network Interfaces, Circuits/VCs, and Links from a Network Topology Map 157
    Filter Data in the Detailed Tables 159
  Search for a Device in the Map 159
  Determine What is Displayed in the Topology Map 160
    Choose Which Device Group(s) to Display in the Network Topology Map 160
  View the Contents of a Sub-Group in the Topology Map 161
  Manually Add Devices and Networks to the Topology Map 162
  Manually Add Links to the Topology Map 162
    Delete a Manually Added Link 163
  Rename a Link 163
  Change Which Link and Device Types are Shown in the Network Topology Map 164
  Show/Hide Alarms and Labels in the Topology Map 165
  Save Global Preferences for the Map Display 165
  Load Global Preferences for the Map Display 166
  Isolate Specific Sections of a Large Topology Map 166
  Get More Information About Devices 167
View and Manage Optical Fiber Paths in the Geo Map 190
  Manage Fiber Paths 191
  Associate Links to Fibers 192
Visualize Circuits/VCs on the Geo Map 192
Import Location Data 193
  Import Device Locations from a CSV File 193
  Import Location Data from a KML File 194
Export Location Data from the Geo Map 196
Manage Shared Risk Resource Groups (SRRGs) in the Geo Map 196
  About SRRG Pools and SRRG IDs 197
  View Assigned and Unassigned SRRGs 198
  Manage SRRG Assignments 199
  Create and Manage SRRG Pools Types and Resource Pools 199

PART IV

Monitor the Network 201

CHAPTER 8

Monitor Device and Network Health and Performance 203
  How Device Health and Performance Is Monitored: Monitoring Policies 203
  Set Up Basic Device Health Monitoring 204
  Set Up Basic Interface Monitoring 205
  Use the Dashboards To Check Network and Device Health 207
  Check What Cisco EPN Manager Is Monitoring 208
    Check Which Parameters and Counters Are Polled By a Monitoring Policy 210
  Policies Pane Pop-Up Window 211
  Check a Monitoring Policy’s Device, Polling, Threshold, and Alarm Settings 211
  Adjust What Is Being Monitored 211
    Create a New Monitoring Policy Based On An Existing Policy 212
    Create a New Monitoring Policy Using Out-of-the-Box Policy Types 213
    Create a Monitoring Policy for Unsupported Parameters and Third-Party Devices 213
  Check the Status of Past Monitoring Policy Data Collections 214
  Change the Device Set a Policy is Monitoring 214
  Change the Polling for a Monitoring Policy 215
  Change Thresholds and Alarm Behavior for a Monitoring Policy 215
  Run Performance Tests 217
<table>
<thead>
<tr>
<th>Chapter 10</th>
<th>Monitor Cisco ASR 9000 Network Virtualization (nV) Satellites and Cluster Services</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monitor Cisco ASR 9000 nV Satellites</td>
<td>247</td>
</tr>
<tr>
<td>Satellite Considerations in Cisco EPN Manager</td>
<td>248</td>
</tr>
<tr>
<td>Minimum Device and OS Requirements for Cisco ASR 9000 nV Satellites</td>
<td>249</td>
</tr>
<tr>
<td>Get Quick Information About a Specific Satellite: Satellite 360 View</td>
<td>249</td>
</tr>
<tr>
<td>View Cisco ASR 9000 Host-Satellite Topologies in the Topology Map</td>
<td>250</td>
</tr>
<tr>
<td>Identify the Satellites Connected to a Cisco ASR 9000 Host</td>
<td>251</td>
</tr>
<tr>
<td>Identify the Hosts Connected to a Satellite</td>
<td>252</td>
</tr>
<tr>
<td>Monitor Cisco ASR 9000 nV Satellites for Faults</td>
<td>253</td>
</tr>
<tr>
<td>View Satellite Faults in a Topology Map</td>
<td>253</td>
</tr>
<tr>
<td>View Satellite Faults Using a Device 360 View</td>
<td>254</td>
</tr>
<tr>
<td>View Satellite Faults in the Alarms and Events Table</td>
<td>255</td>
</tr>
<tr>
<td>Monitor a Cisco ASR 9000 nV Edge Cluster</td>
<td>256</td>
</tr>
<tr>
<td>Minimum Device and OS Requirements for nV Edge</td>
<td>256</td>
</tr>
<tr>
<td>View a nV Edge Cluster in the Topology Map</td>
<td>256</td>
</tr>
<tr>
<td>Identify the Primary and Backup Devices in a Cluster</td>
<td>257</td>
</tr>
<tr>
<td>Monitor and Troubleshoot a Cisco ASR 9000 nV Edge Cluster Service</td>
<td>258</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 11</th>
<th>Manage Reports</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reports Overview</td>
<td>259</td>
</tr>
<tr>
<td>Available Reports</td>
<td>259</td>
</tr>
<tr>
<td>Carrier Ethernet Performance Reports</td>
<td>260</td>
</tr>
<tr>
<td>Optical Performance Reports</td>
<td>267</td>
</tr>
<tr>
<td>Performance Reports</td>
<td>272</td>
</tr>
</tbody>
</table>
Network Summary Reports 273
Device Reports 273
Create, Schedule, and Run a New Report 276
Customize Report Results 277
Filter and Customize Report Data Using User Defined Fields 277
Report Output Examples: Web GUI Output and CSV File Output 279
Troubleshooting Tips for an Empty Report 281

PART V

Configure Devices 283

CHAPTER 12

Configure Devices 285
Ways to Configure Devices Using Cisco Evolved Programmable Network Manager 285
Which Devices Support the Configuration Operations? 286
Identify the Commands Used In a CLI Configuration Template 286
Change a Device's Credentials and Protocol Settings 287
Change Basic Device Properties 287
Enable and Disable Interfaces 289
Configure Physical Attributes of Device Interfaces 289
Configure Circuit Emulation 292
Pre-requisites for Configuring CEM Services 293
SONET Modes Configuration Examples 293
Configure Interfaces for CEM 294
Configure APS or MSP and UPSR or SNCP Protection Groups 298
Configure Clocking for CEM 300
CEM Interface (PDH, SONET, and SDH) Field Descriptions 302
Configure SDH Parameters 306
Configure Modes of SDH in EPNM 307
Configure SDH Line and Section Parameters 308
SDH T1/E1 Configuration Parameters 309
SDH T3/E3 Configuration Parameters 309
SDH VC Configuration Parameters for SAToP 310
Synchronize the Clock Using Sync-E, BITS, and PTP 310
Configure IP SLAs (TWAMP Responder) 315
Configure Interfaces 316
Configure Ethernet Interfaces and Subinterfaces 317
Configure Loopback Interfaces 318
Enable or Disable IOT Interfaces 319
Enable or Disable Tunnel Interfaces 321
Configure SwitchPort Interfaces 321
Configure Virtual Template Interfaces 321
Configure VLAN Interfaces 322
Configure Optical Interfaces 323
  Change the Loopback Settings on an Optical Interface 324
  Continuous Verification of the Connection Status 324
  Configure PRBS on ODU Controllers 326
Enable and Disable OSC 327
View and Acknowledge Unverified Alarms 328
Provision Optical Interfaces 328
Configure Devices Using the Chassis View 343
  Create and Manage Users and User Logins for a Device 344
Configure Patchcords for a Device 345
Configure a Protection Group for a Shelf in a Device 346
Configure Slices 347
Configure Interfaces from the Device Details Page 348
  Update Cisco NCS 1000 Interface Settings 348
Configure Controllers (Optics, OTS, OCH, DSP, and DWDM) 349
Configure Passive Units 352
Edit Amplifier Module Settings on Optical Cards 353
Configure GMPLS and WSON Properties 353
Configure Optical Cards 355
  Configure Cards from the Chassis View 356
Delete a Card 356
Reset a Card 357
Configure SONET and Flex Line Cards 362
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit and Delete Pluggable Port Modules and Card Mode Configuration</td>
<td>365</td>
</tr>
<tr>
<td>Cards and Supported Configuration for Cisco NCS 2000 Devices</td>
<td>366</td>
</tr>
<tr>
<td>Discover and Configure MPLS LDP and MPLS-TE Links</td>
<td>370</td>
</tr>
<tr>
<td>Analyze Ports Using SPAN and RSPAN</td>
<td>373</td>
</tr>
<tr>
<td>Configure and View Ethernet Link Aggregation Groups</td>
<td>375</td>
</tr>
<tr>
<td>Create Link Aggregation Groups (LAG) Using Multiple Interfaces</td>
<td>376</td>
</tr>
<tr>
<td>View Ethernet LAG Properties</td>
<td>377</td>
</tr>
<tr>
<td>Configure Routing Protocols and Security</td>
<td>378</td>
</tr>
<tr>
<td>Configure BGP</td>
<td>378</td>
</tr>
<tr>
<td>Configure an IS-IS</td>
<td>381</td>
</tr>
<tr>
<td>Configure OSPF</td>
<td>383</td>
</tr>
<tr>
<td>Configure Static Routing</td>
<td>385</td>
</tr>
<tr>
<td>Configure ACLs</td>
<td>385</td>
</tr>
<tr>
<td>Configure EOAM Fault and Performance Monitoring</td>
<td>386</td>
</tr>
<tr>
<td>Configure CFM</td>
<td>386</td>
</tr>
<tr>
<td>CFM Overview</td>
<td>387</td>
</tr>
<tr>
<td>Configure CFM Maintenance Domains and Maintenance Associations (Services)</td>
<td>388</td>
</tr>
<tr>
<td>Perform EOAM Connectivity and Performance Checks</td>
<td>390</td>
</tr>
<tr>
<td>Configure Quality of Service (QoS)</td>
<td>394</td>
</tr>
<tr>
<td>Create a QoS Classification Profile</td>
<td>395</td>
</tr>
<tr>
<td>Create a QoS Action Profile</td>
<td>397</td>
</tr>
<tr>
<td>Create a QoS Sub-Action Profile</td>
<td>401</td>
</tr>
<tr>
<td>Import and Export QoS Action and Sub-Action Profiles</td>
<td>402</td>
</tr>
<tr>
<td>Check Which QoS Action Profiles are Configured on a Device</td>
<td>402</td>
</tr>
<tr>
<td>Apply a QoS Action Profile to Interface(s)</td>
<td>402</td>
</tr>
<tr>
<td>Import QoS Profiles Discovered from Devices</td>
<td>403</td>
</tr>
<tr>
<td>Dissociate a QoS Action Profile from Multiple Interfaces</td>
<td>404</td>
</tr>
<tr>
<td>Delete QoS Classification and Action Profiles from Devices</td>
<td>405</td>
</tr>
<tr>
<td>Save Your Device Changes</td>
<td>406</td>
</tr>
<tr>
<td>Save Device Configuration Changes to the Database (Update)</td>
<td>406</td>
</tr>
<tr>
<td>Collect a Device's Inventory Now (Sync)</td>
<td>406</td>
</tr>
<tr>
<td>Launch Cisco Transport Controller to Manage Cisco NCS and Cisco ONS Devices</td>
<td>407</td>
</tr>
</tbody>
</table>

**CHAPTER 13**

Create Templates To Automate Device Configuration Changes 409
Why Create New Configuration Templates? 409
Ways to Create Configuration Templates Using Cisco EPN Manager 410
Create a New CLI Configuration Template Using a Blank Template 410
Create a New CLI Configuration Template Using An Existing Template 411
Entering Variables in a Template 412
  Data Types 412
  Manage Database Variables in CLI Templates 413
  Use Validation Expressions 413
  Add Multi-line Commands 414
  Add Enable Mode Commands 415
  Add Interactive Commands 415
Use Global Variables in a Template 417
Import and Export a CLI Configuration Template 420
Create a New Composite Template 420
Create a Shortcut to Your Templates Using Tags 421
Deploy Templates to Devices 421
  Create Configuration Groups for Deploying Templates to Groups of Devices 421
  Deployment Flow for Configuration Group Using the Wizard 422
  Deployment Flow for CLI Templates using the Wizard 423
  Deployment Flow for Composite Templates Using the Wizard 424
  Deploy Templates to Devices Without Using Configuration Groups 425
Check the Status and Results of a Deployed Configuration Template 425

CHAPTER 14 Manage Cable Devices 427
Manage Cable Devices 427
  Features and Limitations 428
Cable Management Features and Supported User Groups 429
Configure Client Credentials for Cable Devices 431
Add a New Vendor OUI Mapping 432
  Upload an Updated Vendor OUI Mapping File 433
Add Cable Devices 433
Manage Cisco cBR-8 and RPDs Association 433
  Add cBR-8 and RPDs Pairing Information 434
    Add cBR-8 and RPDs Pairing Information Manually 435
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>PART VI</strong></td>
</tr>
<tr>
<td><strong>CHAPTER 15</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
Dense Wavelength Division Multiplexing (DWDM) Circuits 462
Optical Channel Network Connection (OCHNC) WSON 462
Optical Channel Client Connection (OCHCC) WSON 463
Optical Channel (OCH) Trail WSON 463
Optical Channel (OCH) Trail Connecting NCS 1002, NCS 55xx, and ASR 9K Devices 463
Optical Channel (OCH) Trail Hybrid Circuits 464
Optical Channel (OCH) Trail User-to-Network Interface (UNI) 464
Spectrum Switched Optical Network (SSON) Circuits 465
Optical Transport Network (OTN) Circuit 465
Optical Channel Data Unit User-to-Network Interface (ODU UNI) 466
Optical Channel Data Unit (ODU) Tunnel 467
Optical Channel Payload Unit (OPU) Over Optical Channel Data Unit (ODU) 467
Optical Channel Data Unit User-to-Network Interface (ODU UNI) Hairpin 467
Optical Channel Data Unit (ODU) 467
Supported Circuit Emulation Services 468
Supported L3VPN Services 469
Supported MPLS Traffic Engineering Services 470
Unidirectional TE Tunnel 471
Bidirectional TE Tunnel 471
Layer 3 Link 472
Supported Serial Services 472
Circuit/VC Discovery Overview 473

CHAPTER 16 Provision Circuits/VCs 475
Provision Circuits/VCs in Cisco EPN Manager 475
Set the Service Deployment Timeout Value 477
What Happens When a Deployment Fails 477
Troubleshoot Configuration Deployment Failures and Roll Back Failures 479
WAN Automation Engine Integration 480
Cisco WAN Automation Engine Integration with Cisco EPN Manager 480
Configure WAE Parameters 481
Provision EVCs in a Carrier Ethernet Network 481
Summary of Cisco EPN Manager Carrier Ethernet Provisioning Support 482
Prerequisites for EVC Provisioning 482
CHAPTER 17

View and Manage Discovered/Provisioned Circuits/VCs 583
Enable and Disable Service Discovery 583
Circuit or VC States 584
View Circuits/VCs 590
View a Specific Circuit/VC's Details 590
View a Specific Circuit/VC in the Topology Map 590
Get Quick Information About a Circuit/VC: Circuit/VC 360 View 593
Get Comprehensive Information About a Circuit/VC: Circuit/VC Details Window 597
View and Compare Versions of a Circuit (Optical) 599
View a Specific Device's Circuits/VCs 600
View a Device Group's Circuits/VCs 600
View a Device Group's Circuits/VCs List in the Topology Window 600
View a Device Group's Circuits/VCs in an Expanded Table 601
View All Circuits/VCs in Cisco EPN Manager 602
Identify and Manage Discovered Circuits/VCs 602
Show/Hide Implicit Circuits 603
Filter and Export the Circuit/VC list Based on a User Defined Field 603
Display the Routes Associated With a Circuit 604
Promote a Discovered Circuit/VC Before Modifying/Deleting 604
Modify a Circuit/VC 606
Activate a Circuit (Optical) 607
Restore a Circuit (Optical) 607
Reroute a Circuit (Optical) 608
Compare and Reconcile Provisioned and Discovered Versions of a Circuit/VC 608
Initiate a Protection Switch Action on a Circuit (Optical) 609
Resynchronize a Circuit/VC 611
Service Discovery Resync 611
Delete a Circuit/VC 612
Delete or Force Delete an L3VPN Service 613
Delete an L3VPN Service Endpoint 615
Delete or Force Delete an MPLS TE Service 616
Manage Provisioned Network Interfaces 617
Delete Network Interfaces 617

CHAPTER 18
Monitor and Troubleshoot Circuits/VCs 619
Check Circuits/VCs for Faults 619
Identify Which Circuits/VCs are Affected by a Specific Fault 620
Get More Information About a Circuit/VC Failure 621
Troubleshoot a Service Failure Using OAM Commands 622
  Launching from Network Devices Table 623
  Launching from Circuit 360 623
  Launching from Alarm Browser 624
  Perform a Ping or Traceroute Using OAM Command 625
Use EOAM Templates to Troubleshoot EVCs 626
Run a Performance Test on a Circuit/VC 626
  Performance Test Based on Y.1564 for EVCs 626
    Supported Devices 627
    Running a Y.1564 Performance Test 628
  Performance Test Based on Y1731 for EVCs 629
  Performance Test for Optical Circuits 630
    Optical Performance Monitoring Parameters 630
    Run PRBS Test on Circuits (ODU UNI) 631
  Performance Test for Circuit Emulation Services 632
    View and Export the Results of the Performance Test on Circuit Emulation Services 633
View Performance Metrics and Reports for Circuits/VCs 634
  View Performance Graphs in the Circuit/VC 360 View 634
Use Performance Reports to Monitor and Troubleshoot Circuits/VCs 635
Use Service Performance Dashboard to Monitor Circuits/VCs 635
Trace and Visualize the Full Route of Circuits/VCs 635
  Three-Dimensional View of a Circuit V/C Trace 638
Linear View of a Circuit/VC Trace 639
View Specific Information of a Circuit in a Multilayer Trace View 640
Actions You Can Perform from the Multilayer Trace View 642

PART VII
Administer the Cisco EPN Manager System 645
CHAPTER 19

Set Up the Cisco EPN Manager Server 647
Server Setup Tasks 647
Configure and Use LDAP Servers 649
Add an LDAP Server to Cisco EPN Manager 649
Configure LDAP Servers on the Cisco EPN Manager 650
Cisco WAN Automation Engine Integration with Cisco EPN Manager 651
Configure WAE Parameters 651
User Management Setup Tasks 652
Fault Management Setup Tasks 653
Web GUI Setup Tasks (Admin) 653
Customize the Web GUI Menus to Disable Cisco EPN Manager Features 654

CHAPTER 20

Licenses and Software Updates 655
View and Manage Licenses 655
Types of Cisco EPN Manager Licenses 655
Base License 655
Device Right-to-Manage (RTM) License 656
SBY License for High Availability 656
NBI License 656
Time-Based, Lab, and Permanent Licenses 656
Use Cisco Smart Licensing 656
Set Up Cisco Smart Licensing in Cisco EPN Manager 657
Choose Cisco EPN Manager Licenses Using Smart Licensing 660
Convert Traditional Licenses to Smart Entitlements 660
Configure License Thresholds for the Smart License Dashboard 661
Check Cisco EPN Manager License Usage 661
Disable Smart Licensing 661
Reference: Smart Product Registration and License Authorization Statuses 662
Use Traditional Licensing 663
View Traditional Licenses 663
Add and Delete Traditional Licenses 663
Move a Traditional License to Another Server 664
Renewing an Expired License 664
View the Licensing Dashboard  665
Manage Software Updates  666
  What Are Software Updates?  666
  View the Installed Product Software Version  666
  View Installed Software Updates  667
  Enable or Disable Notifications About Software Updates  667

CHAPTER 21  
Cisco EPN Manager Security  669
  Security Overview  669
  Secure Architecture  669
    Ports Used by Cisco EPN Manager  671
  Secure Default Configurations  673
  Harden Your Installation  673
    Configure the Built-In Application Firewall  674
    Set Up Exterior Network Firewalls  675
    Set Up Traffic Encryption  676
  Use SNMPv3 to Harden Communication Between Cisco EPN Manager and Devices  677
  Set Up External Authentication Using the CLI  677
  Harden SSH Against Brute-Force Password Attacks  678
  Harden NTP  680
  Set Up NTP on the Cisco EPN Manager Server  681
  Enable Authenticated NTP Updates  681
  Configure External NFS-Based Storage Servers  681
CSDL Process  682
  Cisco Security Issue Resolution Process  682

CHAPTER 22  
Backup and Restore  685
  Backup and Restore Concepts  685
    Backup Types: Application and Appliance  685
    Backup Scheduling  686
    Backup Repositories  686
    Backup Filenames  687
    Backup Validation Process  688
    Information That Is Backed Up  688
Contents

Delete CA Certificates 715
Establish an SSH Session With the Cisco EPN Manager Server 716
Set Up NTP on the Server 716
Set Up the Cisco EPN Manager Proxy Server 717
Set Up the SMTP E-Mail Server 717
Enable FTP/TFTP/SFTP Service on the Server 718
Configure Stored Cisco.com Credentials 718
Create a Login Banner (Login Disclaimer) 719
Stop and Restart Cisco EPN Manager 719
Configure Global SNMP Settings for Communication with Network Elements 719
Manage Administrative Passwords 720
  Change the FTP User Password 720
  Change the Web GUI Root User Password 721
Recovering Administrator Passwords on Virtual Appliances 721
Check Cisco EPN Manager Server Health, Jobs, Performance, and API Statistics Using the System Monitoring Dashboard 722
Improve the Cisco EPN Manager Server Performance 723
  Check the OVA Size 723
  Compact the Database 723
  Manage Server Disk Space Issues 724
Work With Server Internal SNMP Traps That Indicate System Problems 724
  Customize Server Internal SNMP Traps and Forward the Traps 724
  Troubleshoot Server Internal SNMP Traps 725
Set Up Defaults for Cisco Support Requests 726
Configure Cisco Product Feedback Settings 726
Monitor Backups 727

CHAPTER 24

Data Collection and Purging 729
Control Data Collection Jobs 729
  About System Jobs 729
How Data Retention Settings Affect Web GUI Data 737
Performance and System Health Data Retention 738
Specifying Data Retention By Database Table 738
Alarm, Event, and Syslog Purging 739
| Log Purging | 740 |
| Report Purging | 740 |
| Backup Purging | 740 |
| Device Configuration File Purging | 740 |
| Software Image File Purging | 741 |

**CHAPTER 25**

**User Permissions and Device Access** 743

User Interfaces, User Types, and How To Transition Between Them 743

User Interfaces and User Types 743

How to Transition Between the CLI User Interfaces in Cisco EPN Manager 745

Transition Between the Cisco EPN Manager admin CLI and Cisco EPN Manager config CLI 745

Log In and Out as the Linux CLI root User 746

Enable and Disable root Access for the Linux CLI and the Cisco EPN Manager Web GUI 747

Disable and Enable the Linux CLI Users in Cisco EPN Manager 2.x 747

Disable and Enable the Web GUI root User 747

Control the Tasks Users Can Perform (User Groups) 748

Types of User Groups 748

User Groups—Web UI 748

User Groups—NBI 749

View and Change the Tasks a User Can Perform 750

View and Change the Groups a User Belongs To 750

View User Groups and Their Members 751

Create a Customized User Group 751

View and Change the Tasks a Group Can Perform 752

Use Cisco EPN Manager User Groups with RADIUS and TACACS+ 752

Export the Cisco EPN Manager User Group and Role Attributes for RADIUS and TACACS+ 752

Add Users and Manage User Accounts 753

Create Web GUI Users with Administrator Privileges 754

Add and Delete Users 754

Disable (Lock) a User Account 755

Change a User’s Password 755

Find Out Which Users Are Currently Logged In 755
Fault Management Administration Tasks  781

Event Receiving, Forwarding, and Notifications  781
  Forward Alarms and Events as Email Notifications (Administrator Procedure)  782
  Configure Default Settings for E-Mail Notifications  783
  Forward Alarms and Events as SNMP Trap Notifications  783
Configure Global Display and Search Settings for Acknowledged, Cleared, and Assigned Alarms  784
Change Event Severity Levels  785
Customize the Troubleshooting Text for an Alarm  786
Change Alarm Auto-Clear Intervals  786
Change the Information Displayed in the Failure Source for Alarms  787
Change the Behavior of Expedited Events  787
  Granular Inventory Event Rate Flow Controller  788
Customize Generic Events That Are Displayed in the Web GUI  794
  Disable and Enable Generic Trap and Syslog Handling  794
CHAPTER 27  

Audits and Logs  799 

Audit Configuration Archive and Software Management Changes (Network Audit)  799 

Audit Changes Made By Users (Change Audit)  799 

Generate a Change Audit Report  799 

Enable Change Audit Notifications and Configure Syslog Receivers  800 

Audit Actions Executed from the GUI (System Audit)  801 

System Logs  801 

View and Manage General System Logs  802 

View the Logs for a Specific Job  802 

Adjust General Log File Settings and Default Sizes  802 

Download and E-Mail Log Files for Troubleshooting Purposes  803 

Forward System Audit Logs As Syslogs  804 

Enable SNMP Traces and Adjust SNMP Log Settings (Levels, Size)  804 

Synchronize System logs to an External Location  804 

Synchronize System Logs to an External Location  804 

Security Log  805 

Send Security Log to an External location  807 

CHAPTER 28  

Configure and Manage High Availability  809 

How High Availability Works  809 

Planning HA Deployments  811 

Network Throughput Restrictions on HA  811 

Using the Local Model  812 

Using the Campus Model  813 

Using the Remote Model  813 

Automatic Versus Manual Failover  814 

Set Up High Availability  814
APPENDIX A

Best Practices: Harden Your Cisco EPN Manager Security 845

Core Security Concepts 845
HTTPS 845
SSL Certificates 846
1-Way SSL Authentication 846
Cisco EPN Manager Security Hardening Overview 847

Harden the Cisco EPN Manager Web Server 848
Make Web Server Connectivity Secure By Using HTTPS 848
Set Up Certificate-Based Authentication for Web Clients 848
Configure and Manage OCSP on the Server 851
Configure a Custom OCSP Responder on the Server 851
Delete a Custom OCSP Responder from the Server 851

Harden the Cisco EPN Manager Server 851
Disable Insecure Ports and Services 852
Disable Accounts Not Needed for Day-to-Day Operations 853

Harden Your Cisco EPN Manager Storage 853
Harden NFS-Based Storage 853

APPENDIX B

Icon and State Reference 855
Device Reachability and Admin States 855
Port or Interface States 857
Circuit or VC States 858
Link Serviceability States 864
Link Characteristics 864
Equipment Operational States (Chassis View) 865
contents

alarm severity icons  865
device type icons  866
circuit or vc network topology overlay icons  868

appendix c

cisco epm notification mib  871

appendix d

monitoring policies reference  879

device health monitoring policy  879
interface health monitoring policy  880
custom mib polling monitoring policy  880
ip sla y.1731 monitoring policy  881
pseudowire emulation edge to edge monitoring policy  881
quality of service monitoring policy  882
cable policy  882
ip sla monitoring policy  883
me1200 evc qos monitoring policy  883
mpls link performance monitoring policy  884
bng sessions and ip pools monitoring policy  885
tdm/sonet ports monitoring policy  885
optical sfp monitoring policy  885
cable utilization  886
optical 1 day and optical 15 mins monitoring policies  886

cem monitoring policy  887
device sensor monitoring policy  887

performance counters for optical monitoring policies  888

reference—performance counters for physical interfaces  888
reference—performance counters for otf-fec interfaces  890
reference—performance counters for otf-odu interfaces  890
reference—performance counters for otf-otu interfaces  891
reference—performance counters for ethernet interfaces  892
reference—performance counters for sonet interfaces  893
reference—performance counters for sdh interfaces  894
PART

Get Started with Cisco EPN Manager

• Get Started With Cisco EPN Manager, on page 1
Get Started With Cisco EPN Manager

If you are an administrator and need to set up Cisco EPN Manager for its initial use, see Server Setup Tasks, on page 647.

- Web Client Requirements, on page 1
- Log In and Out, on page 2
- Setup Tasks That Should Be Completed Before Using Cisco EPN Manager, on page 2
- Change Your Password, on page 3
- Use the Main Window Controls, on page 3
- Change Your Default Home Page, on page 5
- Set Up and Use the Dashboards, on page 6
- Work In a Different Virtual Domain, on page 25
- Manage Jobs Using the Jobs Dashboard, on page 26
- Change User Preferences, on page 27
- Extend Cisco EPN Manager Functions, on page 28
- Check Cisco.com for the Latest Cisco EPN Manager Documentation, on page 29

Web Client Requirements

The following are the client and browser requirements for the Cisco EPN Manager Web GUI:

- Hardware—Mac or Windows laptop or desktop compatible with one of the tested and supported browsers listed below.
- Browsers:
  - Google Chrome versions 44 to 70
  - Mozilla Firefox ESR 38
  - Mozilla Firefox versions 39 to 63
  - Microsoft Internet Explorer (IE) 11.0

Note

Internet Explorer users have reported slower performance compared to other browsers, meaning that some GUI pages take longer to load in IE.
Log In and Out

To log into the GUI, enter the following in your web browser address field, where server-ip is the IP address of the Cisco EPN Manager server:

https://server-ip

Depending on your network configuration, the first time your browser connects to the Cisco EPN Manager web server, you may have to update your client browser to trust the server’s security certificate. This ensures the security of the connection between your client and the Cisco EPN Manager web server.

To log out, click Log Out at the top right of the Cisco EPN Manager window and choose Log Out.

For information on Cisco EPN Manager users and the actions they can perform, see:

- How to Transition Between the CLI User Interfaces in Cisco EPN Manager, on page 745—Describes all classes of users supported by Cisco EPN Manager, including the various CLI user accounts.

- Types of User Groups, on page 748—Describes the user group mechanism which allows you to control the functions that everyday web GUI users can perform. What you can see and do in the user interface is controlled by your user account privileges. This topic also describes the virtual domain mechanism, which manages Role-Based Access Control (RBAC) for devices.

Setup Tasks That Should Be Completed Before Using Cisco EPN Manager

Before you can use the Cisco EPN Manager features, these tasks should be completed by an administrator:

<table>
<thead>
<tr>
<th>Tasks to completed before using Cisco EPN Manager</th>
<th>For information, see:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set up and configure the Cisco EPN Manager server.</td>
<td>Server Setup Tasks, on page 647</td>
</tr>
<tr>
<td>Add devices to Cisco EPN Manager and create device groups to simplify device and network management.</td>
<td>Add and Organize Devices, on page 33</td>
</tr>
<tr>
<td>Enable monitoring for interfaces and technologies used by the network.</td>
<td>Monitor Device and Network Health and Performance, on page 203</td>
</tr>
<tr>
<td>Customize alarm and event behavior for your deployment (for example, alarm and event refresh rates and e-mail and trap receivers).</td>
<td>Set Alarm and Event Management Preferences, on page 229</td>
</tr>
</tbody>
</table>
Change Your Password

You can change your password at any time by clicking ☰ at the top right of the Cisco EPN Manager window and choosing Change Password. Click the information icon to review the password policy.

Use the Main Window Controls

The top left of the Cisco EPN Manager title bar provides the following controls.

| ☰ | Menu button—Toggles the main Cisco EPN Manager navigation menu on the left (also called the left sidebar menu) |
| 🏡 | Home button—Returns you to the home page (normally the Overview Dashboard) |

The right side of the title bar displays your user name and the virtual domain you are working in. A virtual domain is a logical grouping of devices. Virtual domains are used to control who has access to devices and areas of the network. To switch between virtual domains that are assigned to you, see Work In a Different Virtual Domain, on page 25.

Web GUI global settings button—Log out, change password, view your Cisco.com account profile, adjust your GUI preferences, check a Cisco.com support case, launch online help

When you click ☰ on the right side of the title bar, the window settings menu opens.
Finally, the Alarm Summary gives you a visual indicator of number of alarms in your network. The color indicates the highest severity alarm.

When you click the Alarm Summary button (circled in the following figure), Cisco EPN Manager opens the Alarm Summary popup window. You can customize the data that is displayed in both the button and the pop-up window. In this example, the button displays a count for Switches and Hubs and System alarms, and the Alarm Summary pop-up to show all of the alarm categories listed in the following illustration.
Change Your Default Home Page

You can specify which page you want to display when you perform either of the following tasks:

- You click 🏛 from the left side of the web GUI title bar.
- You log into the Cisco EPN Manager web GUI.

This setting is saved on a per-user basis. You can change it at any time without affecting other users.

**Step 1** While you have the page you want displayed, click 🏛 at the top right of the Cisco EPN Manager web GUI.

**Step 2** Choose Set Current Page as Home.
Set Up and Use the Dashboards

Dashboards provide at-a-glance views of the most important data in your network. They provide status as well as alerts, monitoring, performance, and reporting information. You can customize these dashboards so they contain only the information that is important to you. It may be helpful to set the **Network Summary** dashboard as your default home page. By doing so, this dashboard is displayed after you log in and you can quickly check overall network health before you do anything else. To set any dashboard as your default home page, see *Change Your Default Home Page*, on page 5.

Use the following dashboards to monitor and manage your network:

- **Network Summary** dashboard—To check the health of the entire network. See *Network Summary Dashboard Overview*.
- **Service Performance** dashboard—To monitor Carrier Ethernet and optical service performance. See *Service Performance Dashboard Overview*.
- **Performance** dashboard—To view high-level performance metrics for network components such as interfaces, QoS policies, and ITU-T Y.1731 probes. See *Performance Dashboard Overview*.
- **Device Trends** dashboard—To view performance information for a specific device, application, or service. See *Device Trends Dashboard Overview*.
- **DWDM/OTN Performance** dashboard—To view performance information for the dense wavelength division multiplexing (DWDM) and Optical Transport Network (OTN) interfaces in your network. See *DWDM/OTN Performance Dashboard Overview*.
- **Cable** dashboard—To view performance information for your cable network including the important issues currently affecting your network of Cisco cBR-8 devices. See *Cable Dashboard Overview*, on page 15.

Users with administrator privileges can also use the following dashboards:

- **Licensing** dashboard—See *View the Licensing Dashboard*.
- **System Monitoring** dashboard—See *Check Cisco EPN Manager Server Health, Jobs, Performance, and API Statistics Using the System Monitoring Dashboard*, on page 722.

Note the following:

- For an explanation of the parts of the dashboard window and how to use dashboard filters, see *How to Use the Dashboards*, on page 19.
- To troubleshoot dashboard data issues, see *Find Out Why Data Is Missing from a Dashboard*.

Types of Dashboards

The following topics describe the dashboards available in Cisco EPN Manager.
Service Performance Dashboard Overview

From the Service Performance dashboard, you can view the performance statistics for a particular circuit, VC, or service during the time frame you specify. To open this dashboard, choose Dashboard > Service Performance > any of the tabs described in the following table.

<table>
<thead>
<tr>
<th>Dashboard Tab</th>
<th>Information Provided</th>
</tr>
</thead>
</table>
| CEM           | For the selected Circuit Emulation (CEM) circuit:  
• Details such as its name, type, and creation date  
• Statistics (you can toggle between the statistics for the circuit's endpoints)  
• Number of packets lost during transmission  
• Number of packets re-ordered in the jitter buffer before they reached their destination  
• Number of jitter buffer overruns and underruns  
• Number of packets ordered incorrectly and subsequently dropped  
• Number of malformed packets  
• Number of seconds that were errored, serverely errored, or unavailable  
• Failed events  
• Dashlets that chart the number of Explicit Pointer Adjustment Relay counters (such L-bits and P-bits) that have been generated and received  
  
  **Note** To view these dashlets, both the CEM and Pseudowire Emulation Edge to Edge monitoring policies must be enabled. See Monitoring Policies Reference, on page 879. |
| TE Tunnel     | For the selected Traffic Engineering (TE) tunnel circuit:  
• Details such as its name, serviceability state, and associated endpoint  
• Service statistics  
• Outgoing traffic, bandwidth utilization, and reserved bandwidth  
• Service availability |
<table>
<thead>
<tr>
<th>Dashboard Tab</th>
<th>Information Provided</th>
</tr>
</thead>
<tbody>
<tr>
<td>CE/L3VPN</td>
<td>For the selected circuit or VC:</td>
</tr>
<tr>
<td></td>
<td>• Details such as its name, discovery state, and the last time it was modified</td>
</tr>
<tr>
<td></td>
<td>• Lists the circuits and VCs with the highest values for the following parameters:</td>
</tr>
<tr>
<td></td>
<td>• Average traffic between endpoints</td>
</tr>
<tr>
<td></td>
<td>• QoS class traffic and drops</td>
</tr>
<tr>
<td>Note</td>
<td>You can toggle between inbound and outbound data. In the Top N Service QoS Class Traffic dashlet, you can also toggle between pre- and post-policy data.</td>
</tr>
<tr>
<td></td>
<td>• Inbound and outbound QoS drops</td>
</tr>
<tr>
<td></td>
<td>• Service traffic and availability</td>
</tr>
<tr>
<td></td>
<td>• Two-way delay, one-way jitter, and service loss</td>
</tr>
<tr>
<td></td>
<td>• End-to-end performance statistics for service probes with a cross-launch to the IPSLA dashboard for EVCs or to the Y.1731 dashboard for L3VPN services.</td>
</tr>
<tr>
<td>Top CE/L3VPN</td>
<td>Lists the circuits and VCs with the highest values for the following parameters:</td>
</tr>
<tr>
<td></td>
<td>• Delay</td>
</tr>
<tr>
<td></td>
<td>• Jitter</td>
</tr>
<tr>
<td></td>
<td>• Service loss</td>
</tr>
<tr>
<td></td>
<td>• Traffic (both inbound and outbound)</td>
</tr>
<tr>
<td>Note</td>
<td>You can toggle between the information for CE and L3VPN services.</td>
</tr>
</tbody>
</table>

Note the following:

• Interface monitoring is not enabled by default. For information on how to check this, see Check What Cisco EPN Manager Is Monitoring, on page 208.

• For a description of how to customize the contents and layout of a dashboard tab, see Customize a Dashboard Tab.

Performance Dashboard Overview

From the Performance dashboard, you can view high-level performance metrics for network components such as interfaces, QoS policies, and ITU-T Y.1731 probes. To open this dashboard, choose Dashboard > Performance > any of the tabs described in the following table.
### Dashboard Tab | Information Provided
--- | ---
**Interfaces** | For the selected interface:
- Details such as its name, the IP address of the device it is located on, and its configured speed
- The average, minimum, and maximum values for the following performance metrics (you can toggle between the metrics collected for inbound and outbound data):
  - Traffic
  - Utilization
  - Errors
  - Discards
  - Cyclic redundancy check (CRC) errors

**Note** CRC error data is not polled by default. To enable the collection of this data, choose a polling frequency for the Interface Health monitoring policy's CRC parameter (see Change the Polling for a Monitoring Policy).
- Individual graphs that chart the performance metrics listed in the Interface Statistics dashlet
- Interface availability
- Top N QoS class map policy graph (inbound and outbound pre-policy rate, post-policy rate, and drops percentage)
- QoS class map policy statistics (inbound and outbound)

**QoS** | For the selected QoS policy:
- Summary information
- Statistics and graphs for pre-policy, post-policy, and dropped class map traffic
- Statistics and graphs for conforming, exceeding, and violating class map traffic

**IP SLA** | For Layer 3 services on the selected probe:
- Summary information
- IP Service Level Agreement (SLA) statistics
- Delay, jitter, and frame loss between endpoints
- Endpoint availability
<table>
<thead>
<tr>
<th>Dashboard Tab</th>
<th>Information Provided</th>
</tr>
</thead>
</table>
| Y1731         | For Layer 2 services on the selected probe:  
|               | • Summary information  
|               | • ITU-T Y.1731 statistics  
|               | • Delay, jitter, and frame loss between endpoints  
|               | • Endpoint availability |
| BNG Statistics | Broadband Network Gateway (BNG) information for the selected device:  
|               | • Details such as its name, IP address, product type, and software version  
|               | • Names of configured IP pools, as well as the number and percentage of available addresses used by each pool  
|               | • Chart that graphs the number of used or free addresses for the selected IP pools  
|               | • Charts that graph the number of sessions for authenticated and up subscribers by line card and session type |

Note the following:  
• Use the check boxes below the charts to select the items you want to view information for  
• Place your cursor over any point in the graphs to view the values for the selected items at that particular time
<table>
<thead>
<tr>
<th>Dashboard Tab</th>
<th>Information Provided</th>
</tr>
</thead>
</table>
| ME1200 QoS    | Quality of Service (QoS) information for the selected service on a Cisco ME 1200 device:  
• Details such as the name of the device, the customer associated with this device, and its user-network interface (UNI) port.  
• Average bit and frame rates for green (conforming), yellow (exceeding), red (violating), and discard traffic. You can toggle between inbound and outbound traffic data.  
• Graphs that chart the traffic measured for the traffic types listed in the **ME1200 QoS Statistics** dashlet.  
Note the following:  
• Five traffic graphs are provided: one for each traffic type as well as one consolidated graph.  
• You can toggle between viewing the data by frame rate (in frames per second) or bit rate (in kilobits per second).  
• You can specify the elements you want to view in a chart by checking the appropriate check box below that chart. In the consolidated traffic dashlet, you can specify traffic types. And in the individual traffic dashlets, you can specify one or multiple EVC Control Entries (ECEs) associated with the service. |
| Optical SFPs  | For the selected Small Form-Factor Pluggable (SFP) Transceiver Module interface:  
• Details such as its name, the name and IP address of the device on which the interface is located, and its configured speed  
• The average, minimum, and maximum values for the following operating metrics:  
  • Optical input and output power  
  • Operating temperature  
  • Transceiver supply voltage  
  • Laser bias current  
• Individual graphs that chart the operating metrics listed in the **SFP Statistics** dashlet |
### Network Summary Dashboard Overview

The **Network Summary** dashboard alerts you to the most important issues currently affecting your network. It also collects metrics from various sources to display a set of key performance indicators (KPIs). To open this dashboard, choose **Dashboard > Network Summary >** any of the tabs described in the following table.

<table>
<thead>
<tr>
<th>Dashboard Tab</th>
<th>Information Provided</th>
</tr>
</thead>
</table>
| **SONET/TDM** | For the selected SONET or time-division multiplexing (TDM) interface:  
  • Details such as its name, configured speed, and the IP address of the device it is located on  
  • The average, minimum, and maximum values for the following performance metrics:  
    • Errored seconds  
    • Severely errored seconds  
    • C-bit severely errored seconds  
    • P-bit severely errored seconds  
    • Unavailable seconds  
  Values are provided for both the near-end (the receiving end) and far-end (the transmitting end) of the interface  
  • Individual graphs that chart the performance metrics listed in the **SONET/TDM Statistics** dashlet |
| **Device Sensors** | For the sensors that reside on the selected device, details such as their name, the type of information they collect (such as temperature or voltage) and the corresponding unit of measure, and the value recorded during the last device poll.  
  **Note** Sensor data is not polled by default. To enable the collection of this data, create a monitoring policy based on the **Device Sensors** policy type (see Create a New Monitoring Policy Using Out-of-the-Box Policy Types). |

Note the following:

- Interface monitoring is not enabled by default. For information on how to check this, see Check What Cisco EPN Manager Is Monitoring, on page 208.

- For a description of how to customize the contents and layout of a dashboard tab, see Customize a Dashboard Tab.
### Dashboard Tab | Information Provided

#### Network Devices
- Status (ICMP reachability, SNMP reachability, device manageability), system health, and alarm summary metric dashlets

Note the following:
- To open a pop-up window that describes the information provided by a metric dashlet, place your cursor over its name and then click the ? icon.
- To open a page that lists the alarms or devices that correspond to a particular metric, click a dashlet value. For example, if the **SNMP Reachability Status** dashlet indicates that 50 devices are currently reachable via SNMP, click 50 to open the **Network Devices** page and view a listing of these devices.
- Top N devices by CPU utilization, memory utilization, and environmental temperature

For the **Top N Environmental Temperature** dashlet, note the following:
- Two temperature values are provided for each device: its highest recorded internal temperature (displayed in the Max Inlet Temp column) and its highest recorded ambient temperature (displayed in the Max Other Temp column). By default, devices are sorted by their internal temperature.
- To identify the sensor that recorded a particular temperature value, place your cursor over its i (information) icon.
- Network topology

#### Incidents
- System health and alarm summary metric dashlets

Note the following:
- To open a pop-up window that describes the information provided by a metric dashlet, place your cursor over its name and then click the ? icon.
- To open a page that lists the alarms that correspond to a particular metric, click a dashlet value. For example, if the **Alarm Summary** dashlet indicates that 12 critical alarms have been raised in your network, click 12 to open the **Alarms** page and view a listing of these alarms.
- Alarm count for the entire network and the Cisco EPN Manager server
- Top N alarm types
- Syslog summary
- Top N event types and their count
- Top N devices by number of syslogs sent
- Syslog details such as the corresponding device, severity, and message text
- Top N devices by number of alarms raised
### Dashboard Tab | Information Provided
--- | ---
Top N Interfaces | For the selected port group:
- Interface availability and utilization summaries
- Top N devices by interface traffic, errors and discards, cyclic redundancy check (CRC) errors, and utilization

Note the following:
- CRC error data is not polled by default. To enable the collection of this data, choose a polling frequency for the Interface Health monitoring policy's CRC parameter (see Change the Polling for a Monitoring Policy).
- Due to a limitation in the current release, the Interface Health monitoring policy polls all of the interfaces in your network for CRC error data, not just the ones associated with the port group you chose from the Port Groups drop-down list. Keep this in mind when you view the data provided by the Top N Interface CRC Errors dashlet.
- Bottom N devices by interface availability

Also note that the dashlets in this tab (except for the summary dashlets) allow you to open the 360 view for a device's adjacent device or interface by clicking its information icon.

Top N QoS | For the selected port group:
- Top N devices by QoS pre-policy, post-policy, and drop rates
- Top N devices by conforming, exceeding, and violating traffic rates

You can toggle between inbound and outbound traffic data.

Top N 1731 | Endpoints with the highest values for the following parameters:
- Delay (one- and two-way)
- Jitter (one-way)
- Frame loss

Top N MPLS Links Delay | Delay (one-way and two-way)

In the Top N Interfaces and Top N QoS tabs you can:
- Choose a specific device group and/or port group to view only information for those devices/ports.
  - To filter data for all the dashlets based on port/device groups, use the Port Groups filter at the top of the dashboard.
  - To filter data for a specific dashlet only, click the dashlet's Edit icon and choose a device/port group from the Port Groups and/or Device Groups drop-down list.
- Filter the data in the dashlets by Class Map (and you can choose to exclude the class-default).
• Click an interface's name link to view performance information for that interface in the **Performance** dashboard. If you click a link in the **Top N Interfaces** tab, the **Interfaces** tab opens. If you click a link in the **Top N QoS** tab, the **QoS** tab opens instead.

• Interface monitoring is not enabled by default. For information on how to check this, see **Check What Cisco EPN Manager Is Monitoring**, on page 208.

• For a description of how to customize the contents and layout of a dashboard tab, see **Customize a Dashboard Tab**.

---

**Cable Dashboard Overview**

The Cable dashboard provides an executive overview of your cable network including the important issues currently affecting your network of Cisco cBR-8 devices. To open this dashboard, choose **Dashboard > Cable > cBR-8 Dashboard**.

Since Cable dashboards can provide both a high level overview and detailed insights of the cable network, dashboards are equipped with filter conditions that help in refining the displayed information.

• Filter information based on location or capabilities. The location you choose could be the group or location to which multiple devices are assigned.

• Filter information associated with a specific Cisco cBR-8 device.

• In addition to the above filters, the dashlets are interactive and can refine data further based on your need:
  
  - To refine the information provided in the table, you can do two things: First, you can create and apply a filter. And second, you can click a particular graph element. For example, in the **cBR-8 Dashboard** tab, if you click the bar that corresponds to a Cisco IOS XE version in the **Software Version** bar graph, the **Software Version Details** table only displays the information specific to that version.

  - Filters applied within a tab are applicable to all dashlets within the tab. For example, in the **Cable Modem** tab, if you filter a specific Cisco cBR-8 device, then all dashlets (such as **Modem Count by Vendors** and **Modem Count by Capability**) display information associated only with the filtered Cisco cBR-8 device.

The information provided in these tabs is refreshed periodically and can be configured through cable policies. To export the details displayed in the table rows as a .csv file, use the **Export** button.

**Before you begin:**

To ensure that information is collected and reported for the Cisco cBR-8 routers in your network, verify that **Cable Policies** is listed on the **Monitoring Policies** page (**Monitor > Monitoring Tools > Monitoring Policies > Policies pane**), is currently active, and has polling intervals set for its parameters. To activate Cable monitoring policies, see, **Change Thresholds and Alarm Behavior for a Monitoring Policy**, on page 215.
<table>
<thead>
<tr>
<th>Dashboard Tab</th>
<th>Information Provided</th>
</tr>
</thead>
<tbody>
<tr>
<td>cBR-8 Dashboard</td>
<td>Provides interactive graphs that chart the following metrics for the Cisco Converged Broadband Router-8 (cBR-8) routers in your network:</td>
</tr>
<tr>
<td></td>
<td>• Software version—Indicates the number of routers (Cisco cBR-8 devices) running various Cisco IOS XE versions.</td>
</tr>
<tr>
<td></td>
<td>• License usage—Indicates the number of license types applied to the selected routers.</td>
</tr>
<tr>
<td></td>
<td>• License state—Indicates the number of routers with registered or unregistered licenses.</td>
</tr>
<tr>
<td></td>
<td>• High availability (HA)—Indicates the number of routers configured with stateful switchover (SSO).</td>
</tr>
<tr>
<td></td>
<td>• Remote physical device—Indicates the number of RPDs that are currently online, offline, being initialized with Cisco cBR-8 devices, in 'defined' state, or for whom deployment is pending.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>• Device statistics in the dashboard is available only for the RPDs associated with Cisco cBR-8 devices.</td>
</tr>
<tr>
<td></td>
<td>• RPD Polling information is displayed in the Cable Dashboard, and it can be dynamically changed by the user by editing the property file. For more information, see RPD Polling, on page 450.</td>
</tr>
<tr>
<td></td>
<td>• Supervisor FPGA Versions—Indicates the field programmable gate arrays (FPGAs) currently in use, broken down by type and version.</td>
</tr>
</tbody>
</table>

To view a table that provides additional information for one of these metrics, place your cursor over a metric and click anywhere within the resulting box that appears. For example, open the **High Availability Details** table and it provides information such as the name and IP address of Cisco cBR-8 routers, the amount of time they have been up, and the location of associated active and standby HA servers.

You can also open a device's 360 view (Device 360, RPD 360 and Interface 360) by clicking the relevant *i* (information) icons displayed in the device details columns.
Using interactive graphs for the alarms raised on Cisco cBR-8 routers in your network, the Alarm dashboard provides various statistics such as:

- **Alarm Severity**: Indicates the number of alarms with different severity levels (Critical, Major, Minor, Warning, and Cleared).
- **Alarm Category**: Indicates the number of alarms with a particular alarm category (such as CMTS System, CMTS Subscriber, Broadband Cable, etc.).
- **Group Location of Devices**: Indicates the number of alarms raised on devices belonging to specific groups.
- **cBR-8 Name**: Group alarms raised on a specific cBR-8 device.

You can filter alarms to view additional details about the alarm such as the alarm ID, failure source, time when the alarm was raised, the alarm protocol category, condition, and whether the alarm affects services. For more information about the alarm, use the Alarm ID hyperlink to navigate to the Alarms and Events page.

In addition to various filters, the alarm heatmap provides a comprehensive count of alarms from various geographic locations and cBR-8 devices. The data is periodically refreshed and also updated based on your selection of the group location, device, or alarm severity.

In case of certain hardware alarms, user can navigate from the Alarms and Events page to the chassis view of the associated cBR-8 platform by performing the steps below:

1. In the **Alarms and Events** page, under the **Failure Source** column, click on the **i** icon next to relevant event to open the Device 360 page.

2. In the **Device 360** page, click **View > Chassis View** to open the chassis view of the selected cBR-8 device. The failed module within the cBR-8 platform will be highlighted in the chassis view.

**Note**

The following are few sample alarm conditions that can be investigated by the user for a cBR-8 device:

- ceFcFruRemoved (when power supply and/or fan is removed)
- ceFcPowerStatusChange (when power supply becomes faulty)
- ceFcFanStatusChange (when fan becomes faulty)
Information Provided Dashboard Tab

Provides interactive graphs that chart the following metrics for cable modems associated with Cisco cBR-8 routers in your network:

- **Cable modem**—Indicates the total count and operational states (such as Online, Offline, and Initializing) of available modems.

- **Modem count by vendors**—Indicates the total number of online/offline cable modems from various vendors (such as Cisco, Aris), by mapping the MAC address in the cable modem to the corresponding vendor name and vendor count.

- **Modem count by capability**—Indicates the total number of online or offline cable modems with various DOCSIS versions (such as DOCSIS 2.0, DOCSIS 3.1, etc.).

**Note** If you choose All (devices) in the filter option, only those devices associated with cable modems are filtered. The dashlets do not represent information about cable devices with no cable modems.

Device Trends Dashboard Overview

From the **Device Trends** dashboard, you can view performance information for a specific device, application, or service. To open this dashboard, choose **Dashboard > Device Trends** > any of the tabs described in the following table.

<table>
<thead>
<tr>
<th>Dashboard Tab</th>
<th>Information Provided</th>
</tr>
</thead>
</table>
| Device        | For the selected device:  
|               | • CPU utilization and memory utilization  
|               | • Health information  
|               | • Port summary |
| Application   | For the selected application or service:  
|               | • Traffic rate and volume  
|               | • Top N clients, servers, and applications by traffic rate and volume |

Note the following:

- Interface monitoring is not enabled by default. For information on how to check this, see **Check What Cisco EPN Manager Is Monitoring**, on page 208.

- For a description of how to customize the contents and layout of a dashboard tab, see **Customize a Dashboard Tab**.
DWDM/OTN Performance Dashboard Overview

The **DWDM/OTN Performance** dashboard displays performance information for the dense wavelength division multiplexing (DWDM) and Optical Transport Network (OTN) interfaces that are traversed by a specific circuit. This includes physical, optical data unit (ODU), optical transport unit (OTU), Ethernet, Synchronous Optical Network (SONET), and Synchronous Digital Hierarchy (SDH) interfaces. The performance information is presented in different tabs per interface type.

To open this dashboard, do one of the following:

- Choose **Dashboard > DWDM/OTN Performance > Circuit**. Click on an interface name in the Interfaces dashlet. The relevant tab for the type of interface will open. For example, if you click on OTU interface, the OTU tab will open.

- From an interface's 360 view, choose **View > Performance**.

Note the following:

- Interface monitoring is not enabled by default. For information on how to check this, see Check What Cisco EPN Manager Is Monitoring, on page 208.

- For a description of how to customize the contents and layout of a dashboard tab, see Customize a Dashboard Tab.

### How to Use the Dashboards

The following figure illustrates the key parts of a dashboard window and the controls you can use to adjust them.

![Dashboard Figure]

**Table 2: Dashboard Elements**

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Dashboard filters—Filters all dashlets in the dashboard according to the selection. In this example, a time-based filter is used. The filters displayed depend on the dashboard type. For example, in the performance dashboards, you must select a specific interface, device, circuit, or VC.</td>
</tr>
<tr>
<td>2</td>
<td>Metric dashlets—Provides quick metrics for alarms, available devices, and so forth.</td>
</tr>
</tbody>
</table>
### Dashboard settings and controls:

- **Dashboard icons**—Allows you to launch online help, refresh the entire dashboard, and open the Dock window.
- **Dashboard Settings menu**—Allows you to add or rename a dashboard tab, add new dashlets (both standard and metric), adjust the dashboard's layout, reset all dashboards to their default settings, and export data from the selected dashlets.

**Note** The newly added or renamed dashboard tab can be viewed only in the Tab view. This change is not reflected in the Dashboard Menu.

### Standard dashlets

- Provides at-a-glance data that is relevant to the dashboard.

In the top right corner of each dashlet are icons that are activated when you use that dashlet. The dashlet type determines the icons that are available. The most common icons are displayed in the following figure:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit</td>
<td>Click to change a dashlet's properties, such as its title, refresh interval, and the number of devices that are displayed (applicable only to Top N and Bottom N dashlets).</td>
</tr>
<tr>
<td>Help</td>
<td>Click to open a pop-up window that describes the dashlet, indicates the monitoring policy that needs to be activated in order for the dashlet to collect data, and lists the filters that can be applied to the dashlet.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Click to refresh the information displayed in the dashlet.</td>
</tr>
<tr>
<td>Detach</td>
<td>Click to move the dashlet to another location in the dashboard.</td>
</tr>
<tr>
<td>Collapse/Expand</td>
<td>Click to toggle between a maximized and minimized dashlet.</td>
</tr>
<tr>
<td>Close</td>
<td>Click to remove the dashlet from the dashboard.</td>
</tr>
</tbody>
</table>

In the bottom right corner of dashlets that provide charts, you can find the buttons highlighted in the following figure. The buttons that are available will vary among dashlets.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart View</td>
<td>Click to view a dashlet's information as a chart.</td>
</tr>
</tbody>
</table>
**Table View button**—Click to view a dashlet's information as a table.

**Chart Type button**—Click to choose the type of chart a dashlet displays (such as a bar or pie chart) and any options you want to set (such as displaying a unique fill pattern for each element).

**Actions button**—Click to print the information provided by a dashlet or export the information as either a .csv or .pdf format file.

See these topics for additional information on dashboards:
- Types of Dashboards, on page 6
- Add Dashlets to Dashboards, on page 22
- Add a New Dashboard, on page 21
- Find Out Why Data Is Missing from a Dashboard

## Add a New Dashboard

Use this procedure to create a new dashboard. Your new dashboard will appear as a new tab under one of the dashboards listed in *Types of Dashboards, on page 6*.

**Step 1**
Open the relevant existing dashboard.
For example, if you want to create a new tab under the **Performance** dashboard, click any tab under **Dashboard > Performance**.

**Step 2**
Click the + (Add New Dashboard) tab.
The **Settings** menu opens.

**Step 3**
Enter a name for the new dashboard, then click **Apply**.

**Step 4**
Click the new dashboard tab, then add dashlets as described in *Add a Predefined Dashlet To a Dashboard, on page 22*.

## Customize a Dashboard Tab

To customize a tab in any of the dashboards that Cisco EPN Manager provides, complete the following procedure:

**Step 1**
Choose **Dashboard >** the dashboard tab you want to customize.
For example, if you want to customize the **Performance** dashboard's **BNG** tab, you would choose **Dashboard > Performance > BNG**.

**Step 2**
Adjust the dashboard tab as needed.
You can do things like:
- Drag dashlets to a different location on the dashboard.
- From the tab's **Settings** menu, rename a tab, add new dashlets (see *Add Dashlets to Dashboards*), and change the tab's layout.
The newly added or a renamed dashboard tab can be viewed only in the Tab view. This change is not reflected in the Dashboard Menu.

**Note** To open a pop-up window that provides an overview of a dashlet you are thinking about adding, expand the Add Dashlets drop-down list, locate the dashlet, and then place your cursor over its name.

- Use the filters to specify the information you want to view and the appropriate time frame, then click **Apply**.

**Step 3** If necessary, troubleshoot why the tab is not displaying any data.

See **Find Out Why Data Is Missing from a Dashboard** for more information.

---

**Add Dashlets to Dashboards**

You can add two types of dashlets to your dashboards:

- **Prepackaged dashlets that are provided with Cisco EPN Manager** — Some of the dashlets are displayed on dashboards by default; others are listed in the **Settings** menu, and you can add them as needed. These dashlets provide information you will likely monitor (for example, device CPU utilization, interface errors and discards, and traffic statistics). See **Add a Predefined Dashlet To a Dashboard**, on page 22.

- **Customized dashlets that you create to monitor device performance** — These dashlet types can only be added to the **Device Trends** dashboard. See **Add a Customized Dashlet to the Device Trends Dashboard**.

---

**Add a Predefined Dashlet To a Dashboard**

Cisco EPN Manager provides a predefined set of dashlets that will provide you with commonly-sought network data. By default, a subset of these dashlets is already included in the dashboards, to help you get started. Complete the following procedure to add another of these predefined dashlets to your dashboards.

**Note** To edit or remove a dashlet, click the appropriate icon from the top right corner of that dashlet. (See **How to Use the Dashboards**.)

---

**Step 1** From the sidebar menu, choose **Dashboard**, then select the dashboard you want to add a dashlet to.

For example, to add a **Device Memory Utilization** dashlet to the **Device Trends** dashboard, choose **Dashboard > Device Trends > Device**.

**Step 2** Identify the dashlet you want to add, then add it:

a) From the top right corner of the dashboard, click **Settings** and then choose **Add Dashlets**. Cisco EPN Manager lists the dashlets that can be added to that dashboard.

b) To open a pop-up window that provides an overview of a particular dashlet, place your cursor to the left of that dashlet's name. The pop-up window also lists the sources for the data the dashlet provides and the filters you can apply to the dashlet, as shown in the following illustration.
Add a Customized Dashlet to the Device Trends Dashboard

If none of the dashlets in the Device Trends dashboard provide the device performance information you need, you can add a dashlet that uses a customized template to poll devices for their SNMP MIB attributes. Complete the following procedure to add this dashlet to the dashboard.

**Before you begin**

Check the available monitoring policies to determine which policy collects the information you need. You will have to specify a policy during the dashlet creation process. If none of the policies meet your needs, you can create a policy that polls new parameters. See Create a Monitoring Policy for Unsupported Parameters and Third-Party Devices, on page 213.

**Step 1** Choose Dashboard > Device Trends > Device.

**Step 2** From the top right corner of the dashboard, click Settings and then choose Add Dashlets.

**Step 3** Expand the Device Dashlets list.

**Step 4** Locate Generic Dashlet, then click Add.

Cisco EPN Manager adds a blank generic dashlet to the Device Trends dashboard.

c) Click Add to add the selected dashlet to the dashboard.

**Step 3** Verify that the dashlet is populated with data.

If it is not, check whether the required monitoring policy is enabled. (Only the Device Health monitoring policy is enabled by default. It checks device availability, CPU and memory pool utilization, and environmental temperature.)

a) From the top right corner of the dashlet, click its ? (Help) icon to open the dashlet's pop-up window.

b) Check the information provided in the Data Sources area. If it lists a monitoring policy, check whether the policy is activated. See Check What Cisco EPN Manager Is Monitoring, on page 208.
Step 5  Configure the new dashlet as needed.
At a minimum, you should:

- Enter a meaningful title in the **Dashlet Title** field.
- Check the **Override Dashboard Time Filter** check box if you do not want to apply the time filters to all of the dashlets in the dashboard.
- In the **Type** drop-down list, choose whether the dashlet will display its data as a table or line chart. (Regardless of your choice, Cisco EPN Manager will display a toggle at the bottom of the dashlet that allows you to change the format.)
- In the **Policy Name** drop-down list, choose the monitoring policy that will collect the data for this dashlet. See **Monitoring Policies Reference, on page 879** for descriptions of the available monitoring policies.

Step 6  Click **Save and Close**.

If no data is displayed in the dashlet, see **Find Out Why Data Is Missing from a Dashboard**.

---

**Customize the Dock Window**

Use the **Dock** window for quick navigation to frequently used web GUI pages and pop-up windows (such as the 360 view for a particular device). From here, you can also access links to the 15 most recently visited pages and Cisco EPN Manager training materials. To open this window, click the **Dock** icon (located in the top right area of the page).

Complete the following procedure to update the links provided in the **Dock** window:

**Step 1**  Add a web GUI page link to the **Favorites** tab (**Dock** icon > **Links Visited** > **Favorites**):
a) Open the web GUI page you want to add.
b) Click its star (**Favorite**) icon, which is located in the top left area of the page.

**Step 2**  Add a pop-up window link to the **Docked Items** area (**Dock** icon > **Docked Items**):
 a) Open the pop-up window you want to add, then open its 360 view.
b) From the top right corner of the pop-up window, click the Add to Dock icon.

---

**Find Out Why Data Is Missing from a Dashboard**

If data is missing from a dashboard or dashlet, perform the following steps to identify the cause:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Step 1** | Check whether the dashlet data is filtered. If you see Edited next to the dashlet name, do the following:  
 | a) Click the Edit icon and adjust the current filter settings.  
 | b) Click Save and Close. |
| **Step 2** | Check whether there is a problem with the device. | See Get Basic Device Information: Device 360 View, on page 69. |
| **Step 3** | Check whether the device inventory is being collected properly. | See Find Devices With Inventory Collection or Discovery Problems, on page 58. |
| **Step 4** | Check whether Cisco EPN Manager is collecting the required data by viewing the monitoring policies it is using:  
 | a) Open the dashlet's overview pop-up window by clicking its Help icon.  
 | b) Note the monitoring policy listed under Data Sources.  
 | Monitoring policies are described in Monitoring Policies Reference, on page 879.  
 | c) Verify that this policy is listed and active in the Monitoring Policies page.  
 | To open this page, choose Monitor > Monitoring Tools > Monitoring Policies, then choose My Policies.  
 | • If the policy is not listed, proceed to Step 4d.  
 | • If the policy is listed and its status is Active, click Details to open the Collection Data pop-up window and see if the device is being monitored by the policy. If it is not, you must adjust the policy as described in Change the Device Set a Policy is Monitoring, on page 214. If the device is included in the policy, proceed to Step 5.  
 | • If the policy is listed and its status is Inactive, select the policy and click Activate.  
 | d) Create a new monitoring policy and activate it.  
 | See Adjust What Is Being Monitored, on page 211. |
| **Step 5** | Check whether the relevant data was purged from the system. | See How Data Retention Settings Affect Web GUI Data, on page 737. |

---

**Work In a Different Virtual Domain**

Virtual domains are logical groupings of devices and are used to control your access to specific sites and devices. Virtual domains can be based on physical sites, device types, user communities, or any other designation the administrator chooses. All devices belong to ROOT-DOMAIN, which is the parent domain for
Manage Jobs Using the Jobs Dashboard

If you have the appropriate user account privileges, you can manage Cisco EPN Manager jobs using the Jobs dashboard. To view the Jobs dashboard, choose Administration > Dashboards > Job Dashboard. From here, you can quickly see if a job was successful, partially successful, or failed.

If too many jobs are already running, Cisco EPN Manager will hold other jobs in the queue until resources are available. If this delays a scheduled job past its normal starting time, the job will not run. You will have to run it manually.

Some jobs may require approval. If this is the case, Cisco EPN Manager sends an email to users with Administrator privileges notifying them that a job was scheduled and needs approval. The job will only run after it is approved. See Configure Job Approvers and Approve Jobs

The following table describes the buttons displayed in the Jobs dashboard.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete Job</td>
<td>Removes a job from the Jobs dashboard.</td>
</tr>
<tr>
<td>Edit Job</td>
<td>Edit the settings configured for the selected job.</td>
</tr>
<tr>
<td>Edit Schedule</td>
<td>Displays the series schedule and lets you edit it (start time, interval, and end time).</td>
</tr>
<tr>
<td>Run</td>
<td>Runs a new instance of the selected job. Use this to rerun partially successful or failed jobs; the job will only run for the failed or partially successful components.</td>
</tr>
<tr>
<td>Abort</td>
<td>Stops a currently-running job, but allows you to rerun it later. Not all jobs can be aborted; Cisco EPN Manager will indicate when this is the case.</td>
</tr>
<tr>
<td>Cancel Series</td>
<td>Stops a currently-running job and does not allow anyone to rerun it. If the job is part of a series, future runs are not affected.</td>
</tr>
<tr>
<td>Pause Series</td>
<td>Pauses a scheduled job series. When a series is paused, you cannot run any instances of that series (using Run).</td>
</tr>
<tr>
<td>Button</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Resume Series</td>
<td>Resumes a scheduled job series that has been paused.</td>
</tr>
</tbody>
</table>

Note

The Delete Job, Abort, and Cancel Series buttons are not available for system and poller jobs.

To view the details of a job, follow these steps:

**Step 1** Choose Administration > Dashboards > Job Dashboard.

**Step 2** From the Jobs pane, choose a job series to get basic information (such as job type, status, job duration, and next start time).

**Step 3** To view the job interval, click a job instance hyperlink.

At the top of the job page, the Recurrence field indicates how often the job recurs. Job interval details will be added for every jobs that triggers.

**Step 4** To get details about a failed or partially successful job, click the job instance hyperlink and expand the entries provided on the resulting page.

This is especially helpful for inventory-related jobs. For example, if a user imported devices using a CSV file (a bulk import), the job will be listed in the Jobs sidebar menu under User Jobs > Device Bulk Import. The job details will list the devices that were successfully added and the devices that were not.

**Example**

To troubleshoot a failed software image import job:

1. Choose User Jobs > Software Image Import from the Jobs sidebar menu.
2. Locate the failed job in the table and then click its hyperlink.
3. Expand the job’s details (if not already expanded) to view the list of devices associated with the job and the status of the image import for each device.
4. To view the import details for a specific device, click that device’s i (information) icon in the Status column. This opens an Image Management Job Results pop-up window.
5. Examine each step and its status. For example, the Collecting image with Protocol: SFTP column might report that SFTP is not supported on the device.

**Change User Preferences**

To change the User Preferences, click the 🌃 icon in the upper-right corner of the screen, and choose My Preferences. After you make the desired changes, click Save to apply your changed settings.
<table>
<thead>
<tr>
<th>User Preference Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Items Per Page List</td>
<td>Use this setting to define the number of entries displayed on the Monitoring pages for APs, Controllers, Site Maps. By default, 50 entries are listed. <strong>Note</strong> This setting does not apply to Network Devices, Alarms and Events, configuration archive, software image management, or configuration.</td>
</tr>
<tr>
<td>Use Next Generation Maps</td>
<td>By default, this setting is enabled.</td>
</tr>
<tr>
<td>Automatically switch group selection to show all devices in the circuit/VC</td>
<td>By default, this setting is not enabled.</td>
</tr>
<tr>
<td>Refresh Interval for Tables</td>
<td>Use this setting to define the time interval at which the tables in the network topology view are refreshed. By default, the refresh interval for tables is 1 minute.</td>
</tr>
<tr>
<td>UI refresh interval</td>
<td>Use this setting to define how often the data in the UI is refreshed in the chassis view. By default, the UI refresh interval is 1 minute.</td>
</tr>
<tr>
<td>Use MSE Admin view</td>
<td>By default, this setting is enabled.</td>
</tr>
<tr>
<td>Logout idle user</td>
<td>Use this setting to define whether an idle user should be automatically logged out. By default, this option is enabled. <strong>Note</strong> To disable this setting, first ensure that the Global idle user is unchecked under System Settings.</td>
</tr>
<tr>
<td>Logout idle user after</td>
<td>This setting also enables you to set the idle time for auto logout. By default, the value is 10 mins. <strong>Note</strong> This value cannot exceed the value in the Global Idle timeout field under System Settings.</td>
</tr>
</tbody>
</table>

For information about user preference settings in Alarms and Events, see Set Up Your Alarm and Event Display Preferences, on page 230.

**Extend Cisco EPN Manager Functions**

Advanced users can extend Cisco EPN Manager using the following tools:

- Cisco Evolved Programmable Network Manager MTOSI API—Integrates Cisco EPN Manager with your operations support system (OSS).
- Cisco Evolved Programmable Network Manager REST API—Manages additional administrative operations.

To get information about these tools, click ☰ from the right side of the title bar and then choose Help > API Help. You can also download the following documents from Cisco.com:

- Cisco Evolved Programmable Network Manager MTOSI API Guide for OSS Integration
- Cisco Evolved Programmable Network Manager RESTCONF NBI Guide

Check Cisco.com for the Latest Cisco EPN Manager Documentation

Refer to the Cisco Evolved Programmable Network Manager Documentation Overview for information about and links to all of the documentation that is provided with Cisco EPN Manager.

Note
We sometimes update the documentation after original publication. Therefore, you should also review the documentation on Cisco.com for any updates.
PART II

Manage the Inventory

- Add and Organize Devices, on page 33
- View Device Details, on page 69
- Manage Device Configuration Files, on page 95
- Manage Device Software Images, on page 111
- Perform Configuration Audits Using Compliance, on page 137
Add and Organize Devices

- Which Device Software Versions Are Supported by Cisco EPN Manager?, on page 33
- Add Devices to Cisco EPN Manager, on page 35
- How Is Inventory Collected?, on page 43
- Configure Devices So They Can Be Modeled and Monitored, on page 44
- Apply Device Credentials Consistently Using Credential Profiles, on page 54
- Check a Device's Reachability State and Admin Status, on page 55
- Move a Device To and From Maintenance State, on page 57
- Validate Added Devices and Troubleshoot Problems, on page 57
- Export Device Information to a CSV File, on page 60
- Create Groups of Devices for Easier Management and Configuration, on page 61
- Delete Devices, on page 68

Which Device Software Versions Are Supported by Cisco EPN Manager?

All devices should be running a certified device software version. However, certain devices must be running the minimum device software version. Follow the instructions in the table below on how to find out about a device software version.

Cisco EPN Manager may report that a device is running an uncertified device software version. You will likely notice no differences in how Cisco EPN Manager manages devices running an uncertified device software version. It depends on whether the device software version contains fundamental changes (changes to XML interfaces, SNMP commands, MIBs, CLI commands, and so forth). In some cases, Cisco EPN Manager will recognize the device software version but may not provide full support for the device NEs such as new modules.

<table>
<thead>
<tr>
<th>To find this information:</th>
<th>Do the following:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A list of all certified device software versions</td>
<td>Refer to Cisco Evolved Programmable Network Manager Supported Devices. Choose Help &gt; Supported Devices and hover over the &quot;i&quot; in the Software Version column to display a popup.</td>
</tr>
</tbody>
</table>
Choose **Monitor > Managed Elements > Network Devices**, locate the device, and hover your cursor over the "i" in the **Last Inventory Collection** column. Check if the popup displays **Uncertified Software Version**.

From the device's Device Details page, under the Device Details tab, choose **System > Summary**.

Check if the Inventory area displays [Uncertified Software Version].

**Devices that require a minimum device software version**

Choose **Help > Supported Devices** and check the **Software Version** column for text similar to \( \geq x.x \) (For example, \( \geq 12.2 \) would indicate that the device must run at least device software version 12.2).

---

## Generic Device Support

Cisco EPN Manager provides management of generic Cisco and non-Cisco devices which are not officially supported (features), with limited inventory and fault functions.

*Table 4: Generic Device Support*

<table>
<thead>
<tr>
<th>Generic Device Type</th>
<th>Supported Features</th>
<th>Supported MIBs</th>
<th>Supported Faults</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco device</td>
<td>System - Summary</td>
<td>SNMPv2</td>
<td>Linkup/ Linkdown</td>
</tr>
<tr>
<td></td>
<td>System - Power Options &amp; Fans</td>
<td>ENTITY-MIB</td>
<td>Warm start</td>
</tr>
<tr>
<td></td>
<td>System - Civic Location</td>
<td>IF-MIB</td>
<td>Cold start</td>
</tr>
<tr>
<td></td>
<td>System - Modules</td>
<td>LLDP-MIB</td>
<td>Authentication Failure</td>
</tr>
<tr>
<td></td>
<td>System - Physical Ports</td>
<td>CISCO-ENTITY-FRU-CONTROL-MIB</td>
<td>BDI interface down/ up (Link down/up localized to BDI)</td>
</tr>
<tr>
<td></td>
<td>System - Sensor</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Interfaces - All Interfaces</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Interfaces - Ethernet</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Interfaces - Physical</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Physical Links</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Non-Cisco device</td>
<td>System - Summary</td>
<td>SNMPv2</td>
<td>Linkup/ Linkdown</td>
</tr>
<tr>
<td></td>
<td>System - Modules</td>
<td>ENTITY-MIB</td>
<td>Warm start</td>
</tr>
<tr>
<td></td>
<td>System - Physical Ports</td>
<td>IF-MIB</td>
<td>Cold start</td>
</tr>
<tr>
<td></td>
<td>Interfaces - All Interfaces</td>
<td>LLDP-MIB</td>
<td>Authentication Failure</td>
</tr>
<tr>
<td></td>
<td>Physical Links</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Generic Device Support*

Cisco EPN Manager provides management of generic Cisco and non-Cisco devices which are not officially supported (features), with limited inventory and fault functions.

*Table 4: Generic Device Support*

<table>
<thead>
<tr>
<th>Generic Device Type</th>
<th>Supported Features</th>
<th>Supported MIBs</th>
<th>Supported Faults</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco device</td>
<td>System - Summary</td>
<td>SNMPv2</td>
<td>Linkup/ Linkdown</td>
</tr>
<tr>
<td></td>
<td>System - Power Options &amp; Fans</td>
<td>ENTITY-MIB</td>
<td>Warm start</td>
</tr>
<tr>
<td></td>
<td>System - Civic Location</td>
<td>IF-MIB</td>
<td>Cold start</td>
</tr>
<tr>
<td></td>
<td>System - Modules</td>
<td>LLDP-MIB</td>
<td>Authentication Failure</td>
</tr>
<tr>
<td></td>
<td>System - Physical Ports</td>
<td>CISCO-ENTITY-FRU-CONTROL-MIB</td>
<td>BDI interface down/ up (Link down/up localized to BDI)</td>
</tr>
<tr>
<td></td>
<td>System - Sensor</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Interfaces - All Interfaces</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Interfaces - Ethernet</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Interfaces - Physical</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Physical Links</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Non-Cisco device</td>
<td>System - Summary</td>
<td>SNMPv2</td>
<td>Linkup/ Linkdown</td>
</tr>
<tr>
<td></td>
<td>System - Modules</td>
<td>ENTITY-MIB</td>
<td>Warm start</td>
</tr>
<tr>
<td></td>
<td>System - Physical Ports</td>
<td>IF-MIB</td>
<td>Cold start</td>
</tr>
<tr>
<td></td>
<td>Interfaces - All Interfaces</td>
<td>LLDP-MIB</td>
<td>Authentication Failure</td>
</tr>
<tr>
<td></td>
<td>Physical Links</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Add Devices to Cisco EPN Manager

Cisco Evolved Programmable Network Manager uses device, location, and port groups to organize elements in the network. When you view devices in a table or on a map (network topology), the devices are organized in terms of the groups they belong to. When a device is added to Cisco EPN Manager, it is assigned to a group named **Unassigned Group**. You can then move the device into the desired groups as described in *Create Groups of Devices for Easier Management and Configuration, on page 61.*

---

**Note**

- To add a Cisco WLC to Cisco EPN Manager, make sure it does not have any unsupported Access Points (APs), otherwise Cisco EPN Manager will not discover any APs from that WLC.

---

### Table 5: Methods for Adding Devices

<table>
<thead>
<tr>
<th>Supported Methods for Adding Devices</th>
<th>See:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add multiple devices by discovering the neighbors of a seed device using:</td>
<td>Add Devices Using Discovery, on page 36.</td>
</tr>
<tr>
<td>• Ping sweep and SNMP polling (Quick Discovery)</td>
<td>Run Quick Discovery, on page 37</td>
</tr>
<tr>
<td>• Customized protocol, credential, and filter settings (useful when you will be repeating the discovery job)</td>
<td>Run Discovery With Customized Discovery Settings, on page 38</td>
</tr>
<tr>
<td>Add multiple devices using the settings specified in a CSV file</td>
<td>Import Devices Using a CSV File, on page 40.</td>
</tr>
<tr>
<td>Add a single device (for example, for a new device type)</td>
<td>Add Devices Manually (New Device Type or Series), on page 41</td>
</tr>
</tbody>
</table>

These topics provide examples of how to add a Carrier Ethernet and an Optical device to Cisco EPN Manager:

- **Example:** Add a Single Cisco NCS 2000 or NCS 4000 Series Device, on page 42
- **Example:** Add a Network Element as an ENE Using Proxy Settings, on page 42

## Add Cisco ME1200 devices in Cisco EPN Manager

Follow these settings while adding Cisco ME1200 devices in Cisco EPN Manager:

- **SNMP** - Use the same SNMP settings as that of other devices.
- **CLI** - Ensure that the protocol setting is set to SSH2. Though the device can be reached via telnet using a port, it is recommended to use SSH protocol. If telnet is used, then the custom telnet port used must be 2323.
- **HTTP** - Ensure you specify the right http credentials.
• Remember that configuration changes to Cisco ME1200 devices are not automatically discovered by Cisco EPN Manager. After making a change, you must manually sync the device. To do this, select the required device(s) in the Network Devices table and click Sync.

### Add Devices Using Discovery

Cisco EPN Manager supports two discovery methods:

- Ping sweep from a seed device (Quick Discovery). The device name, SNMP community, seed IP address and subnet mask are required. This method is not supported for discovering optical devices. See Run Quick Discovery, on page 37

- Using customized discovery methods (Discovery Settings)—This method is recommended if you want to specify settings and rerun discovery in the future. If you want to discover optical devices, use this method. See Run Discovery With Customized Discovery Settings, on page 38.

---

**Note**

- If a discovery job rediscovers an existing device and the device's last inventory collection status is Completed, Cisco EPN Manager does not overwrite the existing credentials with those specified in the Discovery Settings. For all other statuses (on existing devices), Cisco EPN Manager overwrites the device credentials with those specified in the Discovery Settings.

- Service discovery might take longer than usual when a large number of devices is added during database maintenance windows. Therefore, we recommend that you avoid large-scale operations during the night and on weekends.

- Autonomous APs are filtered out of the discovery process to optimize the discovery time. You need to manually add Autonomous APs using Import Devices or Credential Profile.

The discovery process of a device is carried out in the sequence of steps listed below. As Cisco EPN Manager performs discovery, it sets the reachability state of a device, which is: Reachable, Ping Reachable, or Unreachable. A description of the states is provided in Device Reachability and Admin States, on page 56.

1. Cisco EPN Manager determines if a device is reachable using ICMP ping. If a device is not reachable, its reachability state is set to Unreachable.

2. Server checks if SNMP communication is possible or not.
   - If a device is reachable by ICMP but its SNMP communication is not possible, its reachability state is set to Ping Reachable.
   - If a device is reachable by both ICMP and SNMP, its reachability state is Reachable.

3. Verifies the device's Telnet and SSH credentials. If the credentials fail, details about the failure are provided in the Network Devices table in the Last Inventory Collection Status column (for example, Wrong CLI Credentials). The reachability state is not changed.

4. Modifies the device configuration to add a trap receiver so that Cisco EPN Manager can receive the necessary notifications (using SNMP).

5. Starts the inventory collection process to gather all device information.

6. Displays all information in the web GUI, including whether discovery was fully or partially successful.
When Cisco EPN Manager verifies a device’s SNMP read-write credentials, the device log is updated to indicate that a configuration change has been made by Cisco EPN Manager (identified by its IP address).

**Verify SNMP Communication**

Follow these steps if the reachability state of a device is set as **Ping Reachable**.

**Note**

For Cisco NCS 2000 devices, verify the TL1 credentials, in addition (or instead) of SNMP credentials.

**Step 1** Ensure that the credentials used by Cisco EPN Manager for device verification are correct.

**Step 2** Verify that SNMP is enabled on the device and that the SNMP credentials configured on the device match those configured on Cisco EPN Manager.

**Step 3** Check whether SNMP packets are being dropped due to configuration errors or due to your security settings (default behavior) in all the network devices that are participating in transporting SNMP packets between the managed devices and the Cisco EPN Manager server.

**Specify the Management IP Address Type (IPv4/IPv6) for Discovered Devices**

For discovered dual-home (IPv4/IPv6) devices, specify whether you want Cisco EPN Manager to use IPv4 or IPv6 addresses for management IP addresses.

**Step 1** Choose **Administration > Settings > System Settings**, then choose **Inventory > Discovery**.

**Step 2** From the **IPv4/IPv6 Preference for Management Address** drop-down list, choose either **V4** or **V6**.

**Step 3** Click **Save**.

**Run Quick Discovery**

Use this method when you want to perform a ping sweep using a single seed device. Only the device name, SNMP community, seed IP address and subnet mask are required. If you plan to use the configuration management features, you must provide the protocol, user name, password, and enable password.

**Before you begin**

See **Configure Devices So They Can Be Modeled and Monitored, on page 44** to make sure your devices are configured correctly.

**Step 1** Choose **Inventory > Device Management > Discovery**, then click the **Quick Discovery** link at the top right of the window.

**Step 2** At a minimum, enter the name, SNMP community, seed IP address, and subnet mask.
Step 3 Click **Run Now**.

**What to do next**

Click the job hyperlink in the **Discovery Job Instances** area to view the results.

**Run Discovery With Customized Discovery Settings**

Cisco EPN Manager can discover network devices using discovery profiles. A discovery profile contains a collection of settings that instructs Cisco EPN Manager how to find network elements, connect to them, and collect their inventory. For example, you can instruct Cisco EPN Manager to use CDP, LLDP, OSPF to discover devices, or just perform a simple ping sweep (an example of the results of a ping sweep is provided in **Sample IPv4 IP Addresses for Ping Sweep**, on page 38.) You can also create filters to fine-tune the collection, specify credential sets, and configure other discovery settings. You can create as many profiles as you need.

After you create a profile, create and run a discovery job that uses the profile. You can check the results of the discovery job on the Discovery page. You can also schedule the job to run again at regular intervals.

**Before you begin**

See **Configure Devices So They Can Be Modeled and Monitored**, on page 44 to make sure your devices are configured correctly so that Cisco EPN Manager can discover them.

**Step 1** Choose **Inventory > Device Management > Discovery**, then click **Discovery Settings** at the top right of the window. (If you do not see a Discovery Settings link, click the arrow icon next to the Quick Discovery link.)

**Step 2** In the **Discovery Settings** popup, click **New**.

**Step 3** Enter the settings in the **Discovery Settings** window. Click "?" next to a setting to get information about that setting. For example, if you click "?" next to **SNMPv2 Credentials**, the help pop-up provides a description of the protocol and any required attributes.

**Step 4** Click **Run Now** to run the job immediately, or **Save** to save your settings and schedule the discovery to run later.

**Sample IPv4 IP Addresses for Ping Sweep**

The following table provides an example of the results of a ping sweep.

<table>
<thead>
<tr>
<th>Subnet Range</th>
<th>Number of Bits</th>
<th>Number of IP Addresses</th>
<th>Sample Seed IP Address</th>
<th>Start IP Address</th>
<th>End IP Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>255.255.240.0</td>
<td>20</td>
<td>4094</td>
<td>205.169.62.11</td>
<td>205.169.48.1</td>
<td>205.169.63.254</td>
</tr>
</tbody>
</table>
**Example: Add Optical Devices Using Discovery**

The following example shows how to use a seed device and the OTS protocol to discover Cisco NCS 2000 devices.

**Step 1** Check [Configure Devices So They Can Be Modeled and Monitored, on page 44](#) to make sure the optical devices are configured correctly.

**Step 2** Choose [Inventory > Device Management > Discovery](#), then click [Discovery Settings](#) at the top right of the window.

**Step 3** In the Discovery Settings window, click [New](#) to create a new discovery profile.

a) Enter a discovery profile name—for example, **NCS2k_3 OTS**.

b) Enter the seed device and hop count information for the OTS protocol.

1. In the Protocol Settings area, click the arrow next to **Advanced Protocols** to open the discovery protocols list.
2. Click the arrow next to **OTS** to open the OTS protocol window.
3. Check the **Enable OTS** check box.
4. Click the Add Row ("+"?) icon.
5. Enter the seed device IP address and hop count (for example, **209.165.200.224 and 3**), then click **Save** to add the seed device information.
6. Click **Save** in the OTS protocol window to close the window. If necessary, click outside of the OTS Protocol window to close it.

C) Enter the TL1 device credentials for the Cisco NCS 2000 seed device.

1. In the Credential Settings area, click the arrow next to **TL1** to open the TL1 credentials window.
2. Click the Add Row ("+"?) icon.
3. Enter the seed device IP address, username, password, and (if required) proxy IP address.
4. For Secure TL1 access choose Enable from the SSH drop-down list, for Unsecured TL1 choose Disabled.
5. Click Save to add the credential information.
6. Click Save in the TL1 Credentials window to close the window. If necessary, click outside of the TL1 Credentials window to close it.

**Step 4**
Click Save to save the new discovery profile. The new NCS2k_3 OTS profile is added to the Discovery Settings window.

**Note**
If you receive an error message, make sure you have enabled the protocols. (This is a common error.)

**Step 5**
Select NCS2k_3 OTS, then click Run Now to begin the discovery job.

**Step 6**
Check the results of the job by choosing Inventory > Device Management > Discovery.

---

**Import Devices Using a CSV File**

Use a CSV file to add devices if you have an existing management system from which you want to import devices, or you want to specify different values in a spreadsheet.

- Create the CSV File, on page 40
- Import the CSV File, on page 40

**Create the CSV File**

Follow this procedure to create the CSV file.

**Step 1**
Create the bulk import CSV file using the template that is available from the Bulk Import dialog box. To open the dialog box, choose Inventory > Device Management > Network Devices, click the icon above the Network Devices table, and choose Bulk Import. Use the bulk device add sample template.

**Step 2**
To find out what the different fields mean and which fields are required, use the information that is in the web GUI. The information is the same for adding a single device or adding devices in bulk. To get this information, choose Inventory > Device Management > Network Devices, click the icon above the Network Devices table, then choose Add Device. Mandatory fields are indicated by an asterisk; fields that require an explanation display a question mark next to them (hover your mouse cursor over the question mark to view the field details).

**Step 3**
When you are done, save your changes and note the location of the file so you can import it as described in Import the CSV File, on page 40.

**Import the CSV File**

Follow this procedure to import devices using a CSV file.

**Before you begin**

See Configure Devices So They Can Be Modeled and Monitored, on page 44 to make sure your devices are configured correctly.
Step 1 Choose Inventory > Device Management > Network Devices.

Step 2 Click the + icon above the Network Devices table, then choose Bulk Import.

Step 3 In the Bulk Import dialog:
   a) Make sure Device is chosen from the Operation drop-down list.
   b) Click Browse, navigate to the CSV file, then click Import.

   **Note** Choose the CSV file that you have exported already as part of bulk device add sample template download. Do not edit the csv file manually.

Step 4 Check the status of the import by choosing Administration > Dashboards > Job Dashboard.

Step 5 Click the arrow to expand the job details and view the details and history for the import job. If you encounter any problems, see Validate Added Devices and Troubleshoot Problems, on page 57.

---

**Add Devices Manually (New Device Type or Series)**

Use this procedure to add a new device type and to test your settings before applying them to a group of devices.

**Before you begin**

See Configure Devices So They Can Be Modeled and Monitored, on page 44 to make sure your devices are configured correctly.

---

Step 1 Choose Inventory > Device Management > Network Devices.

Step 2 Click the + icon above the Network Devices table, then choose Add Device.

Step 3 In the Add Device dialog box, complete the required fields. Click the "?" next to a field for a description of that field.

   **Note** Telnet/SSH information is mandatory for devices such as most Cisco NCS devices.

Step 4 (Optional) Click Verify Credentials to validate the credentials before adding the device.

Step 5 Click Add to add the device with the settings you specified.

   **Note** For NCS 2000 devices, provide a TL1 user with SuperUser profile, otherwise the devices will go to Completed with Warning status and the Configuration > Security tab will not be available in Chassis View.

   **Note** For NCS 2000 devices, the "Enable Single Session TL1" setting takes effect only for devices running release 11.0 onwards.
Example: Add a Single Cisco NCS 2000 or NCS 4000 Series Device

Cisco NCS 2000 series devices are TL1-based devices, and Cisco EPN Manager uses the TL1 protocol to communicate with these devices. Cisco NCS 4000 series devices, on the other hand, are Cisco IOS-XR devices, and Cisco EPN Manager uses the SNMP and Telnet/SSH protocols to communicate with these devices.

Step 1: Check Configure Devices So They Can Be Modeled and Monitored, on page 44 to make sure the Cisco NCS devices are configured correctly.

Step 2: Click the + icon above the Network Devices table, then choose Add Device.

Step 3: In the Add Device dialog box, complete the required fields. Click the "?" next to a field for a description of that field.
   - Cisco NCS 2000 series and Cisco ONS 15454—Enter TL1 parameters
   - Cisco NCS 4000 series—Enter SNMP and Telnet/SSH parameters

Step 4: Click Verify Credentials to validate that Cisco EPN Manager can reach the device.

Step 5: Click Add to add the device to Cisco EPN Manager.

Example: Add a Network Element as an ENE Using Proxy Settings

Messages sent to a particular network element must pass through other NEs in the network. To pass messages, one or more nodes can be a Gateway Network Element (GNE) and connect other NEs in your network. A node becomes a GNE when you establish a TL1 session and enter a command that must be sent to another node. The node that receives the TL1 message from another node for processing is an End-point Network Element (ENE). Messages from an ENE are transmitted through a GNE to other NEs in the network.

Step 1: Check Configure Devices So They Can Be Modeled and Monitored, on page 44 to make sure your devices are configured correctly.

Step 2: Click the + icon above the Network Devices table, then choose Add Device.

Step 3: In the Add Device dialog box, under the General Parameters, enter the IP address or the DNS name of the ENE that you want to add. Click the "?" next to a field for a description of that field.

Step 4: Under the TL1 Parameters, enter the primary and secondary proxy IP address for the node that you are using as an ENE.
   - Note: The secondary proxy IP address is optional, and will be activated only in the event of failure of the primary proxy.

Step 5: Click Verify Credentials to validate that Cisco EPN Manager can connect to the device.
Step 6 Click **Add** to add the device to Cisco EPN Manager.

---

**Example: Enabling a Single Session on Cisco NCS 2000 Series Devices**

Cisco NCS 2000 series devices are TL1-based devices, and Cisco EPN Manager uses the TL1 protocol to communicate with these devices. You can edit a newly added device or configure an existing NCS 2000 devices to limit the machine (EMS) account with single session.

---

**Step 1** Choose **Inventory > Device Management > Network Devices >**.

**Step 2** Select a device and then click the **Edit** icon. The **Edit Device** window appears.

**Step 3** To edit a single session on a new device or on existing device, set the following parameters:

- a) Check the **Enable Single Session TL1** check box
- b) Enter the required parameters
- c) Do one of the following:
  - Click **Update** to update the single session settings only on the database.
  - Click **Update & Sync** to update both the database and device with the single session settings.

**Step 4** (Optional) You can also edit the single session through Bulk Import and Bulk Edit operations.

**Note** By default, the single session is disabled for the bulk edit. You must check the **Enable Single Session TL1** check box to enable it for all the devices to be imported. Selecting the Bulk Import option might affect the single session flag.

---

**What to do next**

To verify the enabled single session

1. Launch the Cisco Transport Controller and select the device for which the single session is enabled.

2. Choose **Provisioning > Security > Active Logins** to view all the active devices with single sessions. The devices for which the single session is disabled will not be displayed.

**Note** The credentials check is the only exception while performing the single session task

---

**How Is Inventory Collected?**

After devices are added and discovered, Cisco EPN Manager will collect physical and logical inventory information and save it to the database. The following table describes how inventory collection is triggered.
### Inventory Collection Trigger

<table>
<thead>
<tr>
<th>Description</th>
<th>Inventory Collection Trigger</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco EPN Manager receives an incoming NE SNMP trap, syslog, or TL1 message that signals a change on the NE. These incoming events include:</td>
<td>In response to incoming events</td>
</tr>
<tr>
<td>• Configuration change events that signal a change in the device configuration. These events are normally syslogs or traps.</td>
<td></td>
</tr>
<tr>
<td>• Other inventory events, such as tunnel up/down, link up/down, module in/out, and so forth.</td>
<td></td>
</tr>
<tr>
<td>Cisco EPN Manager reacts to these incoming events by collecting NE inventory and state information to make sure that information in its database conforms to that of the NE. Most events trigger granular inventory collection, where Cisco EPN Manager only collects data relevant to the change event; other events will trigger a complete collection (sync) of the NE physical and logical inventory. The data that Cisco EPN Manager collects is determined by information in the incoming event, along with metadata that is defined in Cisco EPN Manager. The metadata in Cisco EPN Manager uses a combination of mechanisms—expedited events, reactive inventory, and granular polling—to fine-tune what is collected. For example, if Cisco EPN Manager receives a GMPLS Tunnel State Change event, it will collect ODU tunnel inventory information to discover midpoints and the Z endpoint of the tunnel.</td>
<td>On demand</td>
</tr>
<tr>
<td>Users can perform an immediate inventory collection (called Sync) from:</td>
<td></td>
</tr>
<tr>
<td>• Network Devices page—Select one or more devices (by checking check boxes) and click Sync.</td>
<td></td>
</tr>
<tr>
<td>• Device 360 view—Choose Actions &gt; Sync Now.</td>
<td></td>
</tr>
<tr>
<td>See Collect a Device's Inventory Now (Sync), on page 406.</td>
<td>Scheduled (daily)</td>
</tr>
<tr>
<td>Normal inventory collection is usually performed overnight. Users with sufficient privileges can check when inventory is collected and the status of collection jobs by choosing Administration &gt; Dashboards &gt; Job Dashboard and choosing System Jobs &gt; Inventory and Discovery Jobs.</td>
<td></td>
</tr>
</tbody>
</table>

### Configure Devices So They Can Be Modeled and Monitored

- Configure Devices To Forward Events To Cisco EPN Manager, on page 45
- Required Settings—Cisco IOS and IOS-XE Device Operating System, on page 45
- Required Settings—Cisco IOS XR Device Operating System, on page 46
- Required Settings—Cisco NCS Series Devices, on page 49
- Required Settings—Cisco ONS Device Operating System, on page 53
- Required Configuration for IPv6 Devices, on page 53
Configure Devices To Forward Events To Cisco EPN Manager

To ensure that Cisco EPN Manager can query devices and receive events and notifications from them, you must configure devices to forward events to the Cisco EPN Manager server. For most devices, this means you must configure the devices to forward SNMP traps and syslogs.

For other devices (such as some optical devices), it means you must configure the devices to forward TL1 messages.

If you have a high availability deployment, you must configure devices to forward events to both the primary and secondary servers (unless you are using a virtual IP address; see Using Virtual IP Addressing With HA, on page 815).

In most cases, you should configure this using the `snmp-server host` command. Refer to the topics in this document that list the prerequisites for the different device operating systems.

### Required Settings—Cisco IOS and IOS-XE Device Operating System

```
snmp-server host server_IP
snmp-server community public-cmty RO
snmp-server community private-cmty RW
snmp-server ifindex persist

logging server_IP
logging on
logging buffered 64000 informational

logging source-interface interface_name
logging trap informational
logging event link-status default

DISABLE domain lookups to avoid delay in Telnet/SSH command response:

no ip domain-lookup

Enable SSH

crypto key generate rsa
ip ssh rsa keypair-name keypair-name
crypto key generate rsa usage-keys label key-label modulus modulus-size
ip ssh version [1 | 2]

Set up VTY options:
```

Note: For information on the required configuration for enabling granular inventory on devices, see, Cisco Evolved Programmable Network Manager Supported Syslogs.
line vty <number of vty>
exec-timeout
session-timeout
transport input ssh (required only if ssh is used)
transport output ssh (required only if ssh is used)

For SNMPv2 only, configure the community string:

```
snmp-server community ReadOnlyCommunityName RO
```

For SNMPv3 only, configure the following settings:

```
snmp-server user User Group v3 auth sha Password priv des Password
snmp-server view Group 1.3.6.1.1.1.2 included
snmp-server group Group v3 priv notify Group read Group
snmp-server group Group v3 priv read v1default write v1default notify v1default
snmp-server group Group v3 priv
snmp-server group Group v3 priv notify epnm read epnm
```

**Note**

- For the device to work seamlessly in Cisco EPN Manager, the SNMP EngineID generated/configured in the device should be unique in the network.
- For the credentials to work, SNMP users should be re-created if the SNMP EngineID is re-configured in the device.

Configure the cache settings at a global level to improve the SNMP interface response time using the configuration:

```
snmp-server cache
```

Syslogs are used by Cisco EPN Manager for alarm and event management. NTP settings ensure that Cisco EPN Manager receives the correct timestamps for events. To configure syslog on the device, add the following settings:

```
clock timezone TimeZone
service timestamps log datetime show-timezone msec year
ntp server NTP_Server
update-calendar
logging facility local7
logging Server_IP vrf default severity info [port default]
```

**Required Settings—Cisco IOS XR Device Operating System**

```
snmp-server community community_name SystemOwner
snmp-server community community_name RO
snmp-server entityindex persist
snmp-server ifindex persist
logging server_IP
logging on
logging buffered <307200-125000000>
logging source-interface interface_name
logging trap informational
logging events level informational
```
logging events link-status
logging events link-status software-interfaces
no cli whitespace completion
domain ipv4 host server_name server_IP

Set up VTY options:
line default
exec-timeout 10 0
session-limit 10
session-timeout 100
transport input ssh
transport output ssh
vty-pool default 0 99 line-template default

Telnet and SSH Settings:
telnet ipv4 server max-servers no-limit
telnet vrf default ipv4 server max-servers 100
ssh server v2
ssh server rate-limit 60
cinetd rate-limit 60

Configure the Netconf and XML agents:
xml agent tty
netconf agent tty

Monitor device with Virtual IP address:
ipv4 virtual address use-as-src-addr
ipv4 virtual address Virtual_IP_Address/Subnet.Mask

For SNMPv2 only, configure the community string:
snmp-server community ReadonlyCommunityName RO SystemOwner

For SNMPv3 only, configure the following settings:
snmp-server user User Group v3 auth sha encrypted Password priv des56 encrypted
Password SystemOwner
snmp-server view Group 1.3.6 included
snmp-server view Group 1.0.8802.1.1.2 included
snmp-server group Group v3 priv notify Group read Group
snmp-server group Group v3 priv read vdefault write vdefault notify vdefault

Alternatively, you can navigate to Configuration $ Templates $ Features & Technologies. From the Templates tab on the left side, select CLI Templates $ System Templates - CLI and deploy the Default_Manageability_Config-IOS-XR template to configure the IOS-XR device settings required for Cisco EPN Manager discovery.

- For the device to work seamlessly in Cisco EPN Manager, the SNMP EngineID generated/configured in the device should be unique in the network.
- For the credentials to work, SNMP users should be re-created if the SNMP EngineID is re-configured in the device.

Configure the following to improve the SNMP interface stats response time:
snmp-server ifmib stats cache

Configure SNMP traps for virtual interfaces to ensure that link-down scenarios are captured:

```plaintext
snmp-server interface subset 2 regular-expression Forty* notification linkupdown
snmp-server interface subset 3 regular-expression Ten* notification linkupdown
snmp-server interface subset 1 regular-expression Hun* notification linkupdown
snmp-server interface subset 1 regular-expression TwoHun* notification linkupdown
snmp-server interface subset 1 regular-expression FourHun* notification linkupdown
```

Syslogs are used by Cisco EPN Manager for alarm and event management. NTP settings ensure that Cisco EPN Manager receives the correct timestamps for events. To configure syslogs on the device, add the following settings:

```plaintext
clock timezone TimeZone
service timestamps log datetime show-timezone msec year
ntp server NTP_Server
logging facility local7
logging Server_IP vrf name
```

Enable performance management on all optical data unit (ODU) controllers:

```plaintext
controller oduX R/S/I/P
per-mon enable
```

Enable performance management for Tandem Connection Monitoring (TCM):

```plaintext
tcm id {1-6}
perf-mon enable
```

To open Cisco Transport Controller (CTC) from Cisco EPN Manager, enable the HTTP/HTTPS server:

```
http server ssl
```

If you plan to use the Configuration Archive, devices must be configured as secured. To configure devices from CTC:

1. Choose **Provisioning > Security > Access.**
2. Set **EMS Access** to secure.

---

**Note**

- Ensure that both the MPLS and K9 packages are installed on the device.
- Install the Cisco IOS XR Manageability Package (MGBL).
- Alternatively, all the above pre-requisite can also be applied through CLI Templates. Navigate to **Configuration > Templates > Features&Technologies.** From the **Templates** tab on the left pane, select **CLI Templates > System Templates-CLI** and deploy the **Default_Manageability_Config template.**
- For more information see, **Supported Traps** and **Supported Syslogs.**
Required Settings—Cisco NCS Series Devices

- Required Settings—Cisco NCS 4000 Series Devices, on page 49
- Required Settings—Cisco NCS 4200 Series Devices, on page 51

Required Settings—Cisco NCS 4000 Series Devices

**Attention**

Ensure that both the MPLS and K9 packages are installed on the device before completing the following steps.

- Cisco EPN Manager uses SSH to secure communication with Cisco NCS 4000 series devices. To enable SSH, apply the following configuration settings on the device:

  ```
  ssh server v2
  ssh server rate-limit 600
  ```

- In MPLS traffic engineering configuration mode, enable event logging:

  ```
  mpls traffic-eng logging events all
  ```

- Set the VTY options:

  ```
  line default
  exec-timeout 10 0
  session-limit 10
  session-timeout 100
  transport input ssh
  transport output ssh
  vty-pool default 0 99 line-template default
  ```

- Configure the LMP link:

  ```
  router-id ipv4 unicast local IP address
  ```

  where **local IP address** is the IP address of the device.

- Configure the Netconf and XML agents:

  ```
  xml agent tty
  netconf agent tty
  ```

- Configure SNMP on the device:

  ```
  snmp-server host server_IP
  snmp-server community public RO SystemOwner
  snmp-server community private RW SystemOwner
  snmp-server ifindex persist
  ```

  You can use either SNMPv2 or SNMPv3:

  - For SNMPv2 only, configure the community string:
    ```
    snmp-server community ReadonlyCommunityName RO SystemOwner
    ```

  - For SNMPv3 only, configure the following settings:
    ```
    snmp-server user User Group v3 auth sha encrypted Password priv des56 encrypted Password SystemOwner
    snmp-server view Group 1.3.6 included
    snmp-server group Group v3 priv notify Group read Group
    ```
For configuring the polling and configuration view, choose one of the following configuration options:

- SNMPv3 default configuration (used for SNMPv3 polling and viewing of the default configuration):
  ```
  snmp-server group Group v3 priv read v1default write v1default notify v1default
  ```

- SNMPv3 specific configuration:
  - For SNMPv3 polling only:
    ```
    snmp-server group Group v3 priv
    ```
  - For viewing configuration for SNMPv3 set, polling, and for traps/informs notifications:
    ```
    snmp-server group Group v3 priv notify epnm read epnm write epnm
    ```
  - For viewing SNMPv3 - LLDP MIB OID configuration:
    ```
    snmp-server view Group 1.0.8802.1.1.2 included
    ```

For viewing the LAG link, add the following configuration on device:
```
snmp-server view all 1.0.8802 included
```

---

**Note**

In the first line, *User* and *Group* are two distinct variables that you need to enter values for.

- Configure the stats command to improve the SNMP interface stats response time using the configuration:
  ```
  Snmp-server ifmib stats cache
  ```

- Configure SNMP traps for virtual interfaces to ensure that link-down scenarios are captured:
  ```
  snmp-server interface subset 1 regular-expression Hun* notification linkupdown
  snmp-server interface subset 2 regular-expression Forty* notification linkupdown
  snmp-server interface subset 3 regular-expression Ten* notification linkupdown
  ```

- Syslogs are used by Cisco EPN Manager for alarm and event management. NTP settings ensure that Cisco EPN Manager receives the correct timestamps for events. To configure syslogs on the device, add the following settings:
  ```
  clock timezone TimeZone
  service timestamps log datetime show-timezone msec year
  ntp server NTP_Server
  logging facility local7
  logging Server_IP vrf name
  ```

**Note** the following:

- When specifying the time zone, enter the time zone's acronym and its difference (in hours) from Coordinated Universal Time (UTC). For example, to specify the time zone for a device located in Los Angeles, you would enter `clock timezone PDT -7`. 
• Replace Server_IP with the IP address of the host Cisco EPN Manager is installed on.

• Configure the Virtual IP address:

```
ipv4 virtual address NCS4K_Virtual_IP_Address/Subnet_Mask
ipv4 virtual address use-as-src-addr
```

**Note**  
NCS4K_Virtual_IP_Address and Subnet_Mask are two distinct variables separated by a slash. Be sure to enter a value for both of these variables.

• Enable performance management on all optical data unit (ODU) controllers:

```
controller oduX R/S/I/P
per-mon enable
```

• Enable event logging of link status messages for optics controllers of Cisco NCS4000 devices running Cisco IOS release 6.1.42 or later:

```
controller Optics <x/y/z/w>
logging events link-status
```

• Enable performance management for Tandem Connection Monitoring (TCM):

```
tcm id {1-6}
perf-mon enable
```

• Configure the Telnet or SSH rate limit for accepting service requests:
  - For Telnet, set the number of requests accepted per second (between 1-100; the default is 1):

```
cinetd rate-limit 100
```
  - For SSH, set the number of request accepted per minute (between 1-600; the default is 60):

```
ssh server rate-limit 600
```

• To open Cisco Transport Controller (CTC) from Cisco EPN Manager (from a Device 360 view), enable the HTTP/HTTPS server:

```
http server ssl
```

• If you plan to use the Configuration Archive feature, devices must be configured as secured. To do this from CTC:

1. Choose **Provisioning > Security > Access**
2. Set EMS Access to **secure**.

• If you notice any performance issues because multiple Cisco NCS 4000 Series devices are sending information simultaneously, increase the number of Telnet sessions per second:

```
cinetd rate-limit 100
```

### Required Settings—Cisco NCS 4200 Series Devices

• Cisco EPN Manager uses SSH to secure communication with Cisco NCS 4200 series devices. To enable SSH, apply one the following configuration settings on the device:
• enable
  configure terminal
  hostname name
  ip domain-name name
  crypto key generate rsa

• enable
  configure terminal
  ip ssh rsa keypair-name keypair-name
  crypto key generate rsa usage-keys label key-label modulus modulus-size
  ip ssh version [1 | 2]

• Set the VTY options:
  line vty <#>
  exec-timeout
  session-timeout
  transport input ssh
  transport output ssh

• Configure SNMP on the device:
  snmp-server host server_IP
  snmp-server community public RO
  snmp-server community private RW

You can use either SNMPv2 or SNMPv3:

• For SNMPv2 only, configure the community string:
  snmp-server community ReadonlyCommunityName RO

• For SNMPv3 only, configure the following settings:
  snmp-server user User Group v3 auth sha Password priv des Password
  snmp-server view Group 1.3.6 included
  snmp-server group Group v3 priv notify Group

For configuring the polling and configuration view, choose one of the following configuration options:

• SNMPv3 default configuration (used for SNMPv3 polling and viewing of the default configuration):
  snmp-server group Group v3 priv read v1default write v1default notify v1default

• SNMPv3 specific configuration:
  • For SNMPv3 polling only:
    snmp-server group Group v3 priv

  • For viewing configuration for SNMPv3 set, polling, and for traps/informs notifications:
    snmp-server group Group v3 priv notify epnm read epnm

  • For viewing SNMPv3 - LLDP MIB OID configuration:
    snmp-server view Group 1.0.8802.1.1.2 included

Note In the first line, User and Group are two distinct variables that you need to enter values for.
• Configure the cache settings at a global level to improve the SNMP interface response time using the configuration `Snmp-server cache`.

• Syslogs are used by Cisco EPN Manager for alarm and event management. NTP settings ensure that Cisco EPN Manager receives the correct timestamps for events. To configure syslogs on the device, add the following settings:

```plaintext
clock timezone TimeZone
service timestamps log datetime show-timezone msec year
ntp server NTP_Server
update-calendar
logging facility local7
logging Server_IP vrf default severity info [port default]
mpls traffic-eng logging events all
mpls traffic-eng logging lsp setups
mpls traffic-eng logging lsp tear downs
```

Note the following:

• When specifying the time zone, enter the time zone's acronym and its difference (in hours) from Coordinated Universal Time (UTC). For example, to specify the time zone for a device located in Los Angeles, you would enter `clock timezone PDT -7`.

• Replace `Server_IP` with the IP address of the host Cisco EPN Manager is installed on.

### Required Settings—Cisco ONS Device Operating System

If you plan to use the Configuration Archive feature, devices must be configured as `secured`. You can do this from CTC:

1. From CTC, choose **Provisioning > Security > Access**.
2. Set EMS Access to secure.

### Required Configuration for IPv6 Devices

If you want to access a device that uses IPv6 addresses, configure the IPv6 address and static route on the Cisco EPN Manager server (virtual machine) by performing these steps:

1. Remove the `ipv6 address autoconfig` from the interface.
2. Configure the `ipv6 address` on the Cisco EPN Manager server.
3. Add a static route to the Cisco EPN Manager server.

### Enable Archive Logging on Devices

Follow these steps to enable archive logging on devices so that granular inventory can be enabled for those devices on Cisco EPN Manager:

**For Cisco IOS-XR devices:**

```plaintext
logging <epnm server ip> vrf default severity alerts
logging <epnm server ip> vrf default severity critical
logging <epnm server ip> vrf default severity error
logging <epnm server ip> vrf default severity warning
logging <epnm server ip> vrf default severity notifications
```
Apply Device Credentials Consistently Using Credential Profiles

Credential profiles are collections of device credentials for SNMP, Telnet/SSH, HTTP, and TL1. When you add devices, you can specify the credential profile the devices should use. This lets you apply credential settings consistently across devices.

If you need to make a credential change, such as changing a device password, you can edit the profile so that the settings are updated across all devices that use that profile.

To view the existing profiles, choose Inventory > Device Management > Credential Profiles.

Create a New Credential Profile

Use this procedure to create a new credential profile. You can then use the profile to apply credentials consistently across products, or when you add new devices.

Step 1 Select Inventory > Device Management > Credential Profiles.
Step 2 If an existing credential profile has most of the settings you need, select it and click Copy. Otherwise, click Add.
Step 3 Enter a profile name and description. If you will have many credential profiles, make the name and description as informative as possible because that information will be displayed on the Credential Profiles page.
Step 4 Enter the credentials for the profile. When a device is added or updated using this profile, the content you specify here is applied to the device.
   The SNMP read community string is required.
Step 5 Click Save Changes.

Apply a New or Changed Profile to Existing Devices

Use this procedure to perform a bulk edit of devices and change the credential profile the devices are associated with. This operation overwrites any existing association between a device and a credential profile. You can also use this operation to synchronize device configurations with the new settings.

Note: Make sure the profile’s credential settings are correct before following this procedure and selecting Update and Sync. That operation will synchronize the devices with the new profile.

Step 1 Configure the credential profile using one of these methods:
• Create a new credential profile by choosing **Inventory > Device Management > Credential Profiles**, and clicking **Add**.

• Edit an existing profile by choosing **Inventory > Device Management > Credential Profiles**, selecting the profile, and clicking **Edit**.

**Step 2** When you are satisfied with the profile, choose **Inventory > Device Management > Network Devices**.

**Step 3** Filter and select all of the devices you want to change (bulk edit).

**Step 4** Click **Edit**, and select the new credential profile from the Credential Profile drop-down list.

**Step 5** Save your changes:

- **Update** saves your changes to the Cisco EPN Manager database.

- **Update and Sync** saves your changes to the Cisco EPN Manager database, collects the device physical and logical inventory, and saves all inventory changes to the Cisco EPN Manager database.

---

### Delete a Credential Profile

This procedure deletes a credential profile from Cisco EPN Manager. If the profile is currently associated with any devices, you must disassociate them from the profile.

**Step 1** Check whether any devices are using the profile.

a) Go to **Inventory > Device Management > Credential Profiles**.

b) Select the credential profile to be deleted.

c) Click **Edit**, and check if any devices are listed on the Device List page. If any devices are listed, make note of them.

**Step 2** If required, disassociate devices from the profile.

a) Go to **Inventory > Device Management > Network Devices**.

b) Filter and select all of the devices you want to change (bulk edit).

c) Click **Edit**, and choose **--Select--** from the Credential Profile drop-down list.

d) Disassociate the devices from the old profile by clicking **OK** in the warning dialog box.

**Step 3** Delete the credential profile by choosing **Inventory > Device Management > Credential Profiles**, selecting the profile, and clicking **Delete**.

---

### Check a Device's Reachability State and Admin Status

Use this procedure to determine whether Cisco EPN Manager can communicate with a device (reachability state) and whether it is managing that device (admin status). The admin status also provides information on whether the device is being successfully managed by Cisco EPN Manager.

**Step 1** Choose **Inventory > Device Management > Network Devices**.

**Step 2** Locate your device in the Network Devices table.
a) From the **Show** drop-down list (at the top right of the table), choose **Quick Filter**.

b) Enter the device name (or part of it) in the text box under the **Device Name** column.

**Step 3** Check the information in the **Reachability** and **Admin Status** columns. See **Device Reachability and Admin States, on page 56** for descriptions of these states.

---

### Device Reachability and Admin States

**Device Reachability State**—Indicates whether Cisco EPN Manager can communicate with the device using all configured protocols.

**Table 6: Device Reachability State**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Device Reachability State</th>
<th>Description</th>
<th>Troubleshooting</th>
</tr>
</thead>
<tbody>
<tr>
<td>✔</td>
<td>Reachable</td>
<td>Cisco EPN Manager can reach the device using SNMP, or the NCS 2K device using ICMP.</td>
<td>—</td>
</tr>
<tr>
<td>!</td>
<td>Ping reachable</td>
<td>Cisco EPN Manager can reach the device using Ping, but not via SNMP.</td>
<td>Although ICMP ping is successful, check for all possible reasons why SNMP communication is failing. Check that device SNMP credentials are the same in both the device and in Cisco EPN Manager, whether SNMP is enabled on the device, or whether the transport network is dropping SNMP packets due to reasons such as mis-configuration, etc. See Change Basic Device Properties, on page 287.</td>
</tr>
<tr>
<td>✗</td>
<td>Unreachable</td>
<td>Cisco EPN Manager cannot reach the device using Ping.</td>
<td>Verify that the physical device is operational and connected to the network.</td>
</tr>
<tr>
<td>?</td>
<td>Unknown</td>
<td>Cisco EPN Manager cannot connect to the device.</td>
<td>Check the device.</td>
</tr>
</tbody>
</table>

**Device Admin State**—Indicates the configured state of the device (for example, if an administrator has manually shut down a device, as opposed to a device being down because it is not reachable by Ping).

**Table 7: Device Admin State**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Device Admin State</th>
<th>Description</th>
<th>Troubleshooting</th>
</tr>
</thead>
<tbody>
<tr>
<td>➔</td>
<td>Managed</td>
<td>Cisco EPN Manager is actively monitoring the device.</td>
<td>Not Applicable.</td>
</tr>
<tr>
<td>Icon</td>
<td>Status</td>
<td>Description</td>
<td>Step 1</td>
</tr>
<tr>
<td>------</td>
<td>----------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>🕵️</td>
<td>Maintenance</td>
<td>Cisco EPN Manager is checking the device for reachability but is not processing traps, syslogs, or TL1 messages.</td>
<td>To move a device back to Managed state, see Move a Device To and From Maintenance State, on page 57.</td>
</tr>
</tbody>
</table>
| 🚫  | Unmanaged | Cisco EPN Manager is not monitoring the device.                                                                                                                                                                | In the Network Devices table, locate the device and click the "i" icon next to the data in the Last Inventory Collection Status column. The popup window will provide details and troubleshooting tips. Typical reasons for collection problems are:  
  • Device SNMP credentials are incorrect.  
  • The Cisco EPN Manager deployment has exceeded the number of devices allowed by its license.  
  • A device is enabled for switch path tracing only.  
  If a device type is not supported, its Device Type will be Unknown. You can check if support for that device type is available from Cisco.com by choosing Administration > Licenses and Software Updates > Software Update and then clicking Check for Updates. |
| 🕵️  | Unknown   | Cisco EPN Manager cannot connect to the device.                                                                                                                                                               | Check the device.                                                                          |

**Move a Device To and From Maintenance State**

When a device's admin status is changed to Maintenance, Cisco EPN Manager will not poll the device for inventory changes, nor will it process any traps or syslogs that are generated by the device. However, Cisco EPN Manager will continue to maintain existing links and check the device for reachability.

See Device Reachability and Admin States, on page 56 for a list of all admin states and their icons.

**Step 1**  
From the Network Devices table, choose Admin State > Set to Maintenance State.

**Step 2**  
To return the device to the fully managed state, choose Admin State > Set to Managed State.

---

**Validate Added Devices and Troubleshoot Problems**

To monitor the discovery process, follow these steps:

**Step 1**  
To check the discovery process, choose Inventory > Device Management > Discovery.
Step 2  Expand the job instance to view its details, then click each of the following tabs to view details about that device's discovery:

- **Reachable** - Devices that were reached using ICMP. Devices may be reachable, but not modeled, this may happen due to various reasons as discussed in **Add Devices Using Discovery**, on page 36. Check the information in this tab for any failures.

- **Filtered** - Devices that were filtered out according to the customized discovery settings.

- **Ping Reachable** - Devices that were reachable by ICMP ping but could not be communicated using SNMP. This might be due to multiple reasons: invalid SNMP credentials, SNMP not enabled in device, network dropping SNMP packets, etc.

- **Unreachable** - Devices that did not respond to ICMP ping, with the failure reason.

- **Unknown** - Cisco EPN Manager cannot connect to the device by ICMP or by SNMP.

**Note** For devices that use the TL1 protocol, make sure that node names do not contain spaces. Otherwise, you will see a connectivity failure.

Step 3  To verify that devices were successfully added to Cisco EPN Manager, choose **Inventory > Device Management > Network Devices**. Then:

- Verify that the devices you have added appear in the list. Click a device name to view the device configurations and the software images that Cisco EPN Manager collected from the devices.

- View details about the information that was collected from the device by hovering your mouse cursor over the Inventory Collection Status field and clicking the icon that appears.

- Check the Device Reachability Status and Admin Status columns. See **Device Reachability and Admin States**, on page 56.

If you need to edit the device information, see **Change Basic Device Properties**, on page 287.

To verify that Cisco EPN Manager supports a device, refer to **Cisco Evolved Programmable Network Manager Supported Devices**.

To verify that Cisco EPN Manager supports a device, click the Settings icon ( ), then choose .

---

**Find Devices With Inventory Collection or Discovery Problems**

Use the quick filter to locate devices that have discovery or collection problems.

**Step 1** Choose **Monitor > Device Management > Network Devices** to open the Network Devices page.

**Step 2** Make sure **Quick Filter** is listed in the **Show** drop-down at the top left of the table.

**Step 3** Place your cursor in the quick filter field above the **Collection Status** and select a status from the drop-down list that is displayed. The devices are filtered according to that status. For troubleshooting steps, see **Validate Added Devices and Troubleshoot Problems**, on page 57.
Retry Job for Device Modeling

During device discovery, certain transient conditions can cause a device to have the Last Inventory Collection Status value as Completed with Warning. In such cases, the failed features of these devices will be automatically recovered using the Failed Feature Sync.

**Note**

Completed with Warning state is indicated when a device has become completed and usable from Cisco EPN Manager, but has certain features that have failed and are unusable. These failed features are specifically listed and can be recovered by the user by performing the recommended action.

**Note**

- The Failed Feature Sync job will be used only for devices with Completed with Warning status, for certain recoverable failures (for example, a timeout error). Permanent or system-based errors (for example, user authentication error or unknown error) cannot be auto-recovered. For more information on the error scenarios, please contact the administration team.

- The Failed Feature Sync job works only in the Cisco EPN Manager 3.0 version. For devices that were already in Completed with Warning state in previous versions of Cisco EPN Manager and upgraded to 3.0 version, user needs to perform a manual resync of the device before enabling the Failed Feature Sync job. As an alternative to manual resync, user can also wait for the daily sync job where the resync will automatically happen. For more information, see Switch Inventory job in About System Jobs, on page 729.

The Failed Feature Sync job (Go to Administration > Dashboard > Job Dashboard. In the left sidebar, choose System Jobs > Inventory and Discovery Jobs) is disabled by default, to prevent system overloading and needs to be manually enabled by the user. The default job interval (30 minutes) can be edited using the Edit Schedule option, though it is not recommended to run the job at a reduced interval, unless in case of emergency.

**Note**

If you have more number of devices with Completed with Warning status, it is recommended to run the Failed Feature Sync job as least often as possible.

Alternately, Cisco EPN Manager provides additional instructions for devices in Completed with Warning state that can be followed by the user to resolve failures and move the device to the Completed state. In the Network Devices table, locate the device and click the i icon next to the data in the Last Inventory Collection Status column. The popup window will provide details and troubleshooting tips (Failures, Impact, Possible Causes, and Recommended Actions). After user performs the recommended actions, the device can be moved to Completed state through a manual sync (applicable for errors such as Wrong CLI credentials), or automatically recovered in the next iteration of the Failed Feature Sync job.

Here are the some of the Completed with Warning scenarios and the corresponding recommended actions:
## Table 8: Completed with Warning state scenarios

<table>
<thead>
<tr>
<th>Possible Cause</th>
<th>Recommended Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connection to the device failed</td>
<td>Verify that the device accepts incoming CLI/SNMP connections and retry.</td>
</tr>
<tr>
<td>Connection to the device is closed</td>
<td>Verify that the device accepts incoming CLI/SNMP connections and retry.</td>
</tr>
<tr>
<td>Data cap exceeded</td>
<td>Collection Error: Please contact the administrator with inventory logs.</td>
</tr>
<tr>
<td>Unexpected condition in the TL1 protocol</td>
<td>Verify that the device accepts incoming TL1 connections and retry.</td>
</tr>
<tr>
<td>General unexpected condition in the HTTP protocol</td>
<td>Verify that the device accepts incoming HTTP connections and retry.</td>
</tr>
<tr>
<td>Error retrieving from NETCONF/XML</td>
<td>Verify that NETCONF/XML is configured and retry.</td>
</tr>
<tr>
<td>NETCONF reported an RPC error</td>
<td>Collection Error: Please contact the administrator with inventory logs.</td>
</tr>
<tr>
<td>Error in the CLI_SESSION_SCRIPT document</td>
<td>Verify that the device can accept a new CLI session and retry.</td>
</tr>
<tr>
<td>A pattern was matched indicating an error during session setup or tear down</td>
<td>Verify that the device can accept a new CLI session and retry.</td>
</tr>
<tr>
<td>Device not reachable</td>
<td>Please contact the administrator with inventory logs.</td>
</tr>
<tr>
<td>Failsafe timeout occurred when trying to communicate with the device</td>
<td>Verify device responsiveness and load.</td>
</tr>
<tr>
<td>A timeout occurred when trying to communicate with the device</td>
<td>Verify that the timeouts configured on the device do not stop CLI connections and retry.</td>
</tr>
<tr>
<td>No response for SNMP get request</td>
<td>Verify that the device can accept incoming SNMP requests and retry.</td>
</tr>
<tr>
<td>Failed to perform SNMP get request</td>
<td>Verify that the device can accept incoming SNMP requests and retry.</td>
</tr>
<tr>
<td>Response error for SNMP get request</td>
<td>Verify that the device can accept incoming SNMP requests and retry.</td>
</tr>
</tbody>
</table>

### Export Device Information to a CSV File

When you export the device list to a file, all device information is exported into a CSV file. The file is then compressed and encrypted using a password you select. The exported file contains information about the device's SNMP credentials, CLI settings, and geographical coordinates. The exported file includes device credentials but does not include credential profiles.
Caution
Exercise caution while using the CSV file as it lists all credentials for the exported devices. You will want to ensure that only users with special privileges can perform a device export.

Step 1
Choose Inventory > Device Management > Network Devices.

Step 2
Select the devices that you want to export, then click and choose Export Device.

Step 3
In the Export Device dialog box, enter a password that will be used to encrypt the exported CSV file. Users will need to supply this password to open the exported file.

Step 4
Confirm the encryption password and click Export. Depending on your browser configuration, you can save or open the compressed file.

Create Groups of Devices for Easier Management and Configuration

- How Groups Work, on page 61
- Create User-Defined Device Groups, on page 64
- Create Location Groups, on page 65
- Create Port Groups, on page 67
- Make Copies of Groups, on page 67
- Hide Groups That Do Not Have Any Members, on page 68
- Delete Groups, on page 68

Organizing your devices into logical groupings simplifies device management, monitoring, and configuration. Because you can apply operations to groups, grouping saves time and ensures that configuration settings are applied consistently across your network. In smaller deployments where all devices can be configured with the same settings, you may only need to create one general device group. The grouping mechanism also supports subgroups. You will see these groups in many of the Cisco EPN Manager GUI windows.

When a device is added to Cisco EPN Manager, it is assigned to a location group named Unassigned. If you are managing a large number of devices, be sure to move devices into other groups so that the Unassigned Group membership does not become too large.

How Groups Work

Groups are logical containers for network elements, such as devices and ports. You can create groups that are specific to your deployment—for example, by device type or location. You can set up a group so that new devices are automatically added if they match your criteria, or you may want to add devices manually.

For information on the specific types of groups, see the related topics Network Device Groups, on page 62 and Port Groups, on page 62.
For information on how elements are added to groups, see How Elements Are Added to Groups: Dynamic, Manual, and Mixed Groups, on page 63.

## Network Device Groups

The following table lists the supported types of network device groups. The device groups can be accessed from the Inventory.

<table>
<thead>
<tr>
<th>Network Device Group Type</th>
<th>Membership Criteria</th>
<th>Can Be Created or Edited By Users?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device Type</td>
<td>Devices are grouped by family (for example, Optical Networking, Routers, Switches and Hubs, and so forth). Under each device family, devices are further grouped by series. New devices are automatically assigned to the appropriate family and series groups. For example, a Cisco ASR 9006 would belong to Routers (family) and Cisco ASR 9000 Series Aggregation Services Routers (series). Note the following: • You cannot create a device type group; these are dynamic groups that are system-defined. Instead, use device criteria to create a user-defined group and give it an appropriate device name. • Device type groups are not displayed in Network Topology maps. • Unsupported devices discovered by Cisco EPN Manager are automatically assigned the <strong>Generic Cisco Device</strong> device type and are listed under <strong>Device Type &gt; Generic Cisco Device Family</strong>.</td>
<td>No</td>
</tr>
<tr>
<td>Location</td>
<td>Location groups allow you to group devices by location. You can create a hierarchy of location groups (such as theater, country, region, campus, building, and floor) by adding devices manually or by adding devices dynamically. A device should appear in one location group only, though a higher level “parent” group will also contain that device. For example, a device that belongs to a building location group might also indirectly belong to the parent campus group. By default, the top location of the hierarchy is the <strong>All Locations</strong> group. All devices that have not been assigned to a location appear under the Unassigned group under All Locations.</td>
<td>Yes</td>
</tr>
<tr>
<td>User Defined</td>
<td>Devices are grouped by a customizable combination of device and location criteria. You can customize group names and use whatever device and location criteria you need.</td>
<td>Yes</td>
</tr>
</tbody>
</table>

## Port Groups

The following table lists the supported types of port groups.
Port Group Type | Membership Criteria | Can be created or edited by users?
--- | --- | ---
Port Type | Grouped by port type, speed, name, or description. Ports on new devices are automatically assigned to the appropriate port group. You cannot create Port Type groups. Instead, use device criteria to create a user-defined group, and create subgroups under the user-defined group. | No; instead create a User Defined Group
System Defined | Grouped by port usage or state. Ports on new devices are automatically assigned to the appropriate port group. Link Ports—Ports that are connected to another Cisco device or other network devices and are operating on “VLAN” mode and are assigned to a VLAN. Trunk Ports—Ports that are connected to a Cisco device or other network devices (Switch/Router/Firewall/Third party devices) and operating on “Trunk” mode in which they carry traffic for all VLANs. If the status of a port goes down, it is automatically added to Unconnected Port group. You cannot delete the ports in this group, and you cannot re-create this group as a sub group of any other group. Wireless and Data Center devices use the other System Defined port groups: AVC Configured Interfaces, UCS Interfaces, UCS Uplink Interfaces, WAN Interfaces, and so forth. You cannot create System Defined Port groups. Instead, use device criteria to create a user-defined group, and create subgroups under the user-defined group. | No; instead create a User Defined Group
User Defined | Grouped by a customizable combination of port criteria, and you can name the group. If the group is dynamic and a port matches the criteria, it is added to the group. | Yes

How Elements Are Added to Groups: Dynamic, Manual, and Mixed Groups

How elements are added to a group depends on whether the group is dynamic, manual, or mixed.

<table>
<thead>
<tr>
<th>Method for Adding Devices</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dynamic</td>
<td>Cisco EPN Manager automatically adds a new element to the group if the element meets the group criteria. While there is no limit to the number of rules that you can specify, the performance for updates may be negatively impacted as you add more rules.</td>
</tr>
<tr>
<td>Manual</td>
<td>Users add the elements manually when creating the group or by editing the group.</td>
</tr>
<tr>
<td>Mixed</td>
<td>Elements are added through a combination of dynamic rules and manual additions.</td>
</tr>
</tbody>
</table>
The device inheritance in parent-child user defined and location groups are as follows:

- **User Defined Group**—When you create a child group:
  - If the parent and child groups are both dynamic, the child group can only access devices that are in the parent group.
  - If the parent group is static and the child group is dynamic, the child group can access devices that are outside of the parent group.
  - If the parent and child groups are dynamic and static, the child group “inherits” devices from the parent device group.

- **Location Group**—The parent group inherits the child group devices.

### Groups and Virtual Domains

While groups are logical containers for elements, access to the elements is controlled by virtual domains. This example shows the relationship between groups and virtual domains.

- A group named `SanJoseDevices` contains 100 devices.
- A virtual domain named `NorthernCalifornia` contains 400 devices. Those devices are from various groups and include 20 devices from the `SanJoseDevices` group.

Users with access to the `NorthernCalifornia` virtual domain will be able to access the 20 devices from the `SanJoseDevices` group, but not the other 80 devices in the group. For more details, see "Create Virtual Domains to Control User Access to Devices".

### Create User-Defined Device Groups

To create a new device type group, use the user-defined group mechanism. You must use this mechanism because device type groups are a special category used throughout Cisco EPN Manager. The groups you create will appear in the **User Defined** category.

**Note**

Cisco ASR satellites can only belong to location groups. For more information, see Satellite Considerations in Cisco EPN Manager, on page 248.

To create a new group, complete the following procedure:

**Step 1**  Choose **Inventory > Group Management > Network Device Groups**.

**Step 2**  In the **Device Groups** pane, click the + (Add) icon and then choose **Create User Defined Group**.

**Step 3**  Enter the group's name and description. If other user-defined device type groups already exist, you can set one as the parent group by choosing it from the **Parent Group** drop-down list. If you do not select a parent group, the new group will reside in the **User-Defined** folder (by default).

**Step 4**  Add devices to the new group:

- If you want to add devices that meet your criteria automatically, enter the criteria in the **Add Devices Dynamically** area. To group devices that fall within a specific range of IP addresses, enter that range in square brackets. For example, you can specify the following:
• IPv4-10.[101-155].[1-255].[1-255] and 10.126.170.[1-180]
• IPv6-2014::5217:[0000-ffff]:fe22:[1e40-1f41]

**Note** While there is no limit on the number of rules you can specify for a dynamic group, group update performance could become slower as the number of rules increases.

If you want to add devices manually, do the following:

1. Expand the *Add Devices Manually* area and then click *Add*.
2. In the *Add Devices* dialog box, check the check boxes for the devices you want to add, then click *Add*.

**Step 5** Click the *Preview* tab to see the members of your group.

**Step 6** Click *Save*.

The new device group appears in the folder you selected in Step 3.

---

**Create Location Groups**

**Note** Cisco ASR satellites can only belong to Location Groups. For more information, see Satellite Considerations in Cisco EPN Manager, on page 248.

To create a location group, follow these steps:

**Step 1** Choose *Inventory > Group Management > Network Device Groups*.

**Step 2** In the *Device Groups* pane on the left, click the *Add* icon, then choose *Create Location Group*.

**Step 3** Enter the name and description, and choose a group from the *Parent Group* drop-down list. By default, the group will be an All Locations subgroup (that is, displayed under the *All Locations* folder).

**Step 4** If you are creating a device group based on geographical location, for example, all devices located in a building at a specific address, select the Geographical Location check box and specify the GPS coordinates of the group or click the View Map link and click on the required location in the map. The GPS coordinates will be populated automatically in this case. Note that location groups defined with a geographic location are represented by a group icon in the geo map. The devices you add to the group will inherit the GPS coordinates of the group. See Device Groups in the Geo Map, on page 185 for more information. Note that if geographical location is the primary reason for grouping a set of devices, it is recommended that the devices you add to the group do not have their own GPS coordinates that are different from the group's.

**Step 5** If you want devices to be added automatically if they meet certain criteria, enter the criteria in the *Add Device Dynamically* area. Otherwise, leave this area blank.
While there is no limit on the number of rules that you can specify for a dynamic group, as the number of rules increases, the group update performance could become slower.

### Step 6
If you want to add devices manually:

a) Under **Add Devices Manually**, click **Add**.

b) In the **Add Devices** dialog box, locate devices you want to add, then click **Add**.

### Step 7
Click the **Preview** tab to see the group members.

### Step 8
Click **Save**, and the new location group appears under the folder you selected in Step 3 (**All Locations**, by default).
Create Port Groups

To create a port group, follow these steps:

**Step 1** Choose **Inventory > Group Management > Port Groups**.

**Step 2** From **Port Groups > User Defined**, hover your mouse over the "i" icon next to **User Defined** and click **Add SubGroup** from the popup window.

**Step 3** Enter the name and description, and choose a group from the **Parent Group** drop-down list. By default, the port group will be under the **User Defined** folder.

**Step 4** Choose the devices a port must belong to in order to be added to the group. From the **Device Selection** drop-down list, you can:
- **Device**—To choose devices from a flat list of all devices.
- **Device Group**—To choose device groups (Device Type, Location, and User Defined groups are listed).

**Step 5** If you want ports to be added automatically if they meet your criteria, enter the criteria in the **Add Port Dynamically** area. Otherwise, leave this area blank.

While there is no limit on the number of rules that you can specify for a dynamic group, as the number of rules increases, the group update performance could become slower.

**Step 6** If you want to add devices manually:
- **a)** Under **Add Ports Manually**, click **Add**.
- **b)** In the **Add Ports dialog** box, locate devices you want to add, then click **Add**.

**Step 7** Click the **Preview** tab to see the group members.

**Step 8** Click **Save**, and the new port group appears under the folder you selected in Step 3 (**User Defined**, by default).

Make Copies of Groups

When you create a duplicate of a group, Cisco EPN Manager names the group **CopyOf group-name** by default. You can change the name, if required.

To duplicate a group follow these steps:

**Step 1** Choose **Inventory > Group Management > Network Device Groups**.

**Step 2** Choose the group from the Device Groups pane on the left.

**Step 3** Locate the device group you want to copy, then click the "i" icon next to it to open the pop-up window.

**Step 4** Click **Duplicate Group** (do not make any changes yet) and click **Save**. Cisco EPN Manager creates a new group called **CopyOf group-name**.

**Step 5** Configure your group as described in **Create User-Defined Device Groups**, on page 64 and **Create Location Groups**, on page 65.

**Step 6** Verify your group settings by clicking the **Preview** tab and examining the group members.

**Step 7** Click **Save** to save the group.
Hide Groups That Do Not Have Any Members

By default, Cisco EPN Manager will display a group in the web GUI even if the group has no members. Users with Administrator privileges can change this setting so that empty groups are hidden—that is, they are not displayed in the web GUI. (Hidden groups are not deleted from Cisco EPN Manager.)

Step 1  Choose Administration > Settings > System Settings, then choose Inventory > Grouping.
Step 2  Uncheck Display groups with no members, and click Save.

We recommend that you leave the Display groups with no members check box selected if you have a large number of groups and devices. Unselecting it can slow system performance.

Delete Groups

Make sure the group you want to delete has no members, otherwise Cisco EPN Manager will not allow the operation to proceed.

Step 1  Choose Inventory > Group Management > Network Device Groups.
Step 2  Locate the device group you want to delete in the Device Groups pane on the left, then click the "i" icon next to it to open the pop-up window.
Step 3  Click Delete Group and click OK.

Delete Devices

When you delete a device, Cisco EPN Manager will no longer model or monitor it.

Before you begin

If a device has services on it that were provisioned using Cisco EPN Manager, you must delete those services before deleting the device. However, you will be permitted to delete devices that have discovered or provisioned services on it (that is, services that were not created by Cisco EPN Manager). To find out which services are on a device, use the Device 360 view; see View a Specific Device's Circuits/VCs, on page 600.

Step 1  Choose Inventory > Device Management > Network Devices to open the Network Devices page.
Step 2  Locate the device you want to delete. For example, navigate through the Groups list, or enter some text in the Quick Filter boxes.
Step 3  Select the device, and click Delete.
View Device Details

The following topics explain how to get more information about your network devices. You can also generate a variety of device reports that provide hardware and software details, CPU and memory utilization, general device health, and so forth. For information on these reports, see Device Reports, on page 273. For information on inventory collection, see How Is Inventory Collected?, on page 43.

- Find Devices, on page 69
- Get Basic Device Information: Device 360 View, on page 69
- View a Device's Local Topology from the Device 360 View, on page 73
- View the Network's Hardware Inventory, on page 74
- Get Complete Device Information: Device Details Page, on page 74
- View and Manage Devices Using the Chassis View, on page 77
- View Device Ports, on page 86
- View Device Interfaces, on page 86
- View Device Modules, on page 91
- View Environment Information (Power Supplies, Fans), on page 91
- View Device Neighbors, on page 92
- Get More Information About Links, on page 92
- View Circuits/VCs, on page 93
- View Satellites, on page 93
- Create User Defined Fields for Custom Values, on page 93

Find Devices

The quickest way to find a device is to use the quick search text boxes displayed at the top of the Network Devices table (Inventory > Device Management > Network Devices). You can enter partial strings for a device name, IP address, or software version, or choose from the values for reachability, admin status, and Inventory Collection. If user defined fields have been created, you can also search by user defined field values. Devices are also organized into device groups, which you can view by choosing Inventory > Device Management > Network Devices and selecting a device type from the Device Group list.

Get Basic Device Information: Device 360 View

The Device 360 view is a pop-up window that provides quick information about a device, its inventory, and its status. This includes device alarms, modules, interfaces, neighbors, and chassis.
To launch a Device 360 view:

- Click the "i" icon next to an IP address in almost any device table
- From the network topology, click a device in an expanded group, then click View

The Device 360 view provides general device and performance information at the top of the view, and more detailed interface information in tabs in the lower part of the view. The information the Device 360 view displays depends on the device type and configuration. The Device 360 view provides the following information.

<table>
<thead>
<tr>
<th>Information Provided in Device 360 View</th>
<th>Description</th>
</tr>
</thead>
</table>

---

Manage the Inventory

Get Basic Device Information: Device 360 View
General information and tools

Device type, its OS type and version, its last configuration change, and its last inventory collection. Icons convey the status of the device.

**Note**
- If you have opened the Device 360 view for a Cisco NCS 6000 device that houses a Secure Domain Router (SDR), the SDR’s name is also listed.
- If you have opened the Device 360 view for a Cisco Catalyst 6500 Series device with dual and quad-supervisor Virtual Switching System (VSS), the device's redundancy state, switch mode, and operational redundancy mode is also listed.

Using the menus in the top right of the popup window, you can also perform these tasks:

- Troubleshoot—Perform a ping or traceroute, launch the Alarm browser, open a Cisco support case, or get information from the Cisco Support Community (**Actions** menu)
- Performance—Check device CPU and memory (**View > Performance Graphs**)
- Topology—View the network topology and the device's local topology, up to 3 hops (**Actions** menu)
- Check the device's routing table (**Actions** menu)
- Open the **Device Console** to enter commands you want to run on the device (**Actions** menu)
- View the configuration that is currently running on the devie (**Actions > Show Command**)
- Collect the device's inventory and save it to the database using **Sync Now** (**Actions** menu)
- Open an HTTP, HTTPS, SSH, or Telnet session with the device (**Actions** menu)
- Launch Cisco Transport Controller for optical devices (**Actions** menu)
- Enable the automatic refresh of the view every 20 seconds (**Actions** menu)
- Open the Device Details page to view details about software image and configuration file management, and use the device's Chassis View (by clicking the device IP address hyperlink or choosing **View > Details**)
- Select a device for a side-by-side comparison with another device on the basis of information such as raised alarms and the current status of circuits, interfaces, and modules (**Actions** menu)—see **Compare Device Information and Status**
Performance data | Charts reflecting various aspects of the device performance. If a device has multiple memory pools, the Device 360 view will display the average utilization for all of the memory pools. If you want to see information about individual memory pools, use the memory utilization dashlets in the Network Summary dashboard. See Network Summary Dashboard Overview.

Alarms tab | Current alarms for the device, including their severity, status, and the time they were generated. Depending on the alarm source, you can also launch other 360 views from this tab.

Modules tab | Modules that are configured on the device, including their name, type, state, ports, and location.

Interfaces tab | Interfaces that are configured on the device, including status information. You can also launch an Interface 360 view for a specific interface.

Neighbors tab | NEs that are connected to this device through CDP (Cisco Discovery Protocol). If the selected device does not support CDP, this tab is empty. Displayed information includes device type and name, and the local port and device port. To view the neighbors in a popup topology map, choose Actions > N Hop Topology from the top right of the Device 360 view (see View a Device's Local Topology from the Device 360 View, on page 73.

Circuit/VCs tab | Circuit/VC name, type, customer, status, and creation date for each circuit provisioned on the device. You can also launch a Circuit/VC 360 view for specific circuits/VCs.

Satellites tab | For Cisco ASR 9000 devices in a cluster configuration, lists a satellite's name, type, description, status, and IP and MAC addresses. You can also launch a Satellite 360 view for a specific satellite.

Civic Location | Geographical information about device's location.

Recent Changes | The last five changes made on the device, classified as: Inventory, Config (Configuration Archive), or SWIM (Software Images). (These are the same types of changes that are displayed when you choose Inventory > Network Audit.)

SRRGs | Lists the Shared Risk Resource Groups (SRRGs) assigned to the device. Click this tab's ? (help) icon to view its legend. For more information about SRRGs, see Manage Shared Risk Resource Groups (SRRGs) in the Geo Map.

You can also view a specific device in the topology map by choosing Actions > Network Topology (at the top right of the Device 360 view).

**Compare Device Information and Status**

From the Comparison View, you can perform a side-by-side comparison of multiple devices, viewing information such as raised alarms, the status of modules, interfaces, and circuits on those devices, and a summary of recent changes that have been made. To compare devices, do the following:
Step 1  Choose one of the following to open the Network Devices page:

- Monitor > Managed Elements > Network Devices
- Inventory > Device Management > Network Devices

Step 2  For each device you want to compare:

a) Open its Device 360 view by clicking the \( i \) (information) icon in the IP Address column.
b) Choose Actions > Add to Compare.

The device you selected is displayed at the bottom of the page. You can select a maximum of 4 devices.

Step 3  Click Compare.

The Comparison View opens.

Step 4  From the drop-down list at the top of the view, specify whether the view will show all available information or just the information that is unique to each device.

Step 5  Click Comparison View, check the check box for the categories you want the view to display, and then click Save.

By default, all of the categories are already selected.

Step 6  Scroll down the page to view the information provided for each category you selected.

Note the following:

- The Comparison View only displays information for two devices at a time. If you selected more than two, you will need to toggle to the devices that are not currently displayed.
- To reorder the devices you have selected, click Rearrange.
- Each device’s View and Actions menu is identical to the ones provided in their Device 360 view. If you select an option, the corresponding page opens.
- You can minimize and maximize the categories displayed, as needed.
- The Comparison View is also available for circuits and VCs, interfaces, and links. Whenever you select any of these elements from their respective 360 view for comparison, they are displayed in the corresponding tab. This allows you to switch between element types, as needed.
- When you are done comparing devices, click Back at the top of the view and then click Clear All at bottom of the page. If tabs for other element types are still displayed, you will need to clear them as well.

---

**View a Device's Local Topology from the Device 360 View**

You can launch a small topology window from the Device 360 view that displays the network topology around a device, up to 3 hops.

Step 1  Open the Device 360 View for the device in which you are interested.
• Click the "i" icon next to an IP address in almost any device table.
• From the network topology, click a device in an expanded group, then click View.

**Step 2** Choose N-Hop Topology from the Actions drop-down menu (at the top right of the Device 360 view).

**Step 3** Adjust the popup window to show the information you need.
• Click the edit icon
• Select a hop count (1-3) from the Hop drop-down list.
• Select a topology map layout from the Layout drop-down list.

**Step 4** Save your changes, and use the pan and zoom tools to view the results.

---

**View the Network's Hardware Inventory**

Use this procedure to view basic hardware information for all devices in the network—the product name, physical location, serial number, manufacture date, and so forth.

**Step 1** To view device-level information:
1. Choose Inventory > Device Management > Network Inventory.
2. Use the Quick Filters to locate specific devices. For example, to list the hardware information for all ASR devices, enter *ASR* in the Product Name field.

**Step 2** To view element-level information, use one of these methods:
• Get the information from the Device Details page. See Get Complete Device Information: Device Details Page, on page 74.
• Get the information from the Chassis View. See Open the Chassis View, on page 77.
• Run a hardware report. See Device Reports, on page 273.

---

**Get Complete Device Information: Device Details Page**

For the most comprehensive information about a device, view the Device Details page. It provides in-depth inventory information and configuration options.
To launch the Device Details Page:

- From a Device 360 view—Click the IP address hyperlink or choose View > Details.
- From a network devices table—Click the device name hyperlink in a device table.

The tabs that are displayed here depend on your selection in the Chassis View. They are described in the following table:

<table>
<thead>
<tr>
<th>Tab Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chassis View</td>
<td>Provides inventory, service, and alarm information that is contextualized to the element you select. Also serves as a launch point for configuration, Image management, and Configuration Archive features. (To configure logical elements, click the Logical View tab.) For information on using the Chassis View features, see Overview of the Chassis View Window, on page 78.</td>
</tr>
<tr>
<td>Logical View</td>
<td>Provides logical inventory information. Also provides configuration options for logical elements.</td>
</tr>
<tr>
<td>Device Details</td>
<td>Provides system information (environment, modules, ports, interfaces, and other settings). The Summary page contains graphs indicating the average utilization of all CPUs and the average utilization of all memory components for the device.</td>
</tr>
<tr>
<td>Alarms</td>
<td>Get information about the alarms that have been raised on a device, a card, or a port. See View an Alarm's Details.</td>
</tr>
</tbody>
</table>
### Tab Name | Description
--- | ---
**Configuration** | Configure a device, card, or port. Elements are grouped by their physical location. (To configure elements that are grouped according to their logical function, click the **Logical View** tab.) See *Ways to Configure Devices Using Cisco Evolved Programmable Network Manager, on page 285.*

**Inventory** | View detailed hardware information such as serial numbers and manufacture dates for a device or card.

**Interfaces** | View the status of interfaces configured on a device, card, or port. From here, you can also open the **Interface 360** view for a particular interface. For links to topics that describe other ways to view interface information in Cisco EPN Manager, see *View Device Interfaces.*

**Performance** | View summary information and high-level performance metrics. Note the following:
- If you are viewing the chassis view for any device other than a Cisco Converged Broadband Router-8 (cBR-8) router, information is displayed for the selected interface on a card or port. The dashlets displayed in addition to the **Interface Details** dashlet will vary, depending on the interface type you chose. After choosing an interface from the **Interface** drop-down list, make sure to click **Apply** in order to refresh the information that is displayed.
- If you are viewing the chassis view for a Cisco cBR-8 router, information is also displayed for the device as a whole. You can view dashlets that provide information such as the number of voice calls that have been made and upstream/downstream utilization percentages. To ensure that information is collected and reported for the Cisco cBR-8 routers in your network, verify that **Cable Policies** is listed on the **Monitoring Policies** page (**Monitor** > **Monitoring Tools** > **Monitoring Policies** > **Policies pane**), is currently active, and has polling intervals set for its parameters.

*Note* | You can display up to 10 dashlets at a given point of time on the Performance tab. To choose these dashlets, click the Settings icon on the top right corner of the pane and use the **Add Dashlet(s)** option to make your selection.

**Circuits** | View the circuits a device, card, or port participates in. For links to topics that describe other ways to view circuit information in Cisco EPN Manager, see *View Circuits/VCs.*

**Image** | Manage the software image that is running on the device. See *View the Images That Are Saved in the Image Repository.*

*Note* | This tab is only available when a top-level chassis is selected.

**Configuration Archive** | Manage the device configuration file that is running on the device. See *View All Archived Files.*

*Note* | This tab is only available when a top-level chassis is selected.
View and Manage Devices Using the Chassis View

The Chassis View provides an interactive model of a device chassis and its hardware elements. From the Chassis View you can:

- View the contents of a chassis.
- Check the state of chassis elements and quickly locate problems.
- View alarmed elements and launch views that provide alarm details.
- Configure interfaces (using the launch point that opens the Device Details page).

The elements that are displayed in the Chassis View depend on the device type and the elements that are configured on the device.

Note that Admin users do not have read/write access to chassis views by default. To enable access for this user group, open the Users, Roles & AAA page, choose User Groups, and then check the Chassis View Read and Write check box (under Network Monitoring in the Tasks Permissions tab). See View and Change the Tasks a Group Can Perform.

See these topics for information about how to launch and use the Chassis View:

Open the Chassis View

The following table describes the various ways you can open the Chassis View. If a device does not provide these launch points, it means the device does not support the Chassis View. For a list of devices that support the Chassis View, see https://www.cisco.com/c/en/us/support/cloud-systems-management/evolved-programmable-network-epn-manager/products-device-support-tables-list.html.

<table>
<thead>
<tr>
<th>To open a Chassis View from:</th>
<th>Do the following:</th>
<th>The Chassis View is displayed in:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network Devices table</td>
<td>Click next to the device IP address.</td>
<td>A pop-up window</td>
</tr>
<tr>
<td></td>
<td>Click a device name hyperlink.</td>
<td>A full-page view</td>
</tr>
<tr>
<td>Device 360 view</td>
<td>Choose View &gt; Chassis View from the top right of the Device 360 view.</td>
<td>A pop-up window</td>
</tr>
<tr>
<td></td>
<td>Choose View &gt; Details from the top right of the Device 360 view.</td>
<td>A full-page view</td>
</tr>
<tr>
<td>Device Details page</td>
<td>Click the Chassis View tab.</td>
<td>A full-page view</td>
</tr>
</tbody>
</table>

To open a full-page Chassis View from a Chassis View pop-up window, click the Launch Configuration link in the top right corner of the window.
Permissions Required to View and Configure Devices Using the Chassis View

The following table describes the Chassis View permissions that are granted to members of the Cisco EPN Manager user groups. These permissions cannot be edited. For more information on user groups, see Control the Tasks Users Can Perform (User Groups), on page 748

- Full access (read and write)—Users in this group can view and configure devices using the Chassis View.
- Read-only access—Users in this group can use the Chassis View to view devices but not to configure them.
- Write-only access—Users in this group can use the Chassis View to configure devices but not view them (only applies to the NBI Write group).
- No access—Users in this group cannot access or use the Chassis View.

<table>
<thead>
<tr>
<th>Group Type</th>
<th>Read</th>
<th>Write</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web UI</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Root</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Super Users</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Admin</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Config Managers</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>System Monitoring</td>
<td>X</td>
<td>—</td>
</tr>
<tr>
<td>User-Defined 1-4</td>
<td>X</td>
<td>—</td>
</tr>
<tr>
<td>Monitor Lite</td>
<td>X</td>
<td>—</td>
</tr>
<tr>
<td>NBI</td>
<td></td>
<td></td>
</tr>
<tr>
<td>NBI Credential</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>NBI Read</td>
<td>X</td>
<td>—</td>
</tr>
<tr>
<td>NBI Write</td>
<td>—</td>
<td>X</td>
</tr>
<tr>
<td>North Bound API</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

Overview of the Chassis View Window

The following illustration shows the Chassis View for a Cisco ASR 903 router.
In this example, the user then clicked a port that is currently down.

The Chassis View updates, displaying only the line card module that the port resides on and zooming in on it. The port pulsates in the Chassis View to help the user locate it. The badges displayed on the ports in this module indicate the primary status of those port (see Port or Interface States, on page 82). Some elements may be surrounded by colored lines to indicate their state (out of service, pre-provisioned, and so forth). To open a key that explains the meaning of the badges and these other indicators, click the bottom right of the Chassis View.
If a device has multiple chassis or shelves, each chassis or shelf is displayed in the same Chassis View (for an example, see View Mixed Chassis, Multi-Chassis, and Multi-Shelf Devices in the Chassis View, on page 83). If a card image cannot be retrieved, the Chassis View displays a question mark alongside the card name.

Note the following:

- The colors rendered in the Chassis View may not match your physical device because the Chassis View displays a generic image that is packaged with Cisco EPN Manager.

- If you have opened the Chassis View for a Cisco NCS 6000 device that houses a Secure Domain Router (SDR), both the device type and the SDR’s name are displayed at the top of the Chassis View. Keep in mind that there may be cases where the SDR label for a device that belongs to a cluster or a user-defined group is not displayed (since auto-clustering is applied to devices based on their proximity).

The following table describes the Chassis View’s components and their function:

<table>
<thead>
<tr>
<th>Chassis View Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open a field you can use to search for a particular rack, shelf, module, or interface on a device.</td>
<td>Opens the Chassis Explorer.</td>
</tr>
<tr>
<td>Indicates the device’s reachability state (see Device Reachability and Admin States, on page 56). This example indicates the device is reachable.</td>
<td></td>
</tr>
<tr>
<td>Indicates the device’s administrative status (see Device Reachability and Admin States, on page 56). This example indicates the device is managed.</td>
<td>Opens the device’s Device 360 view. See Get Basic Device Information: Device 360 View.</td>
</tr>
<tr>
<td>Opens the device’s Device Details page. The tabs displayed on this page will vary, depending on whether a device, module, or port is currently selected in the Chassis View. See Get Complete Device Information: Device Details Page.</td>
<td>Launch Configuration link</td>
</tr>
<tr>
<td>Adds a shortcut to the device’s Chassis View in the Dock window. See Customize the Dock Window.</td>
<td></td>
</tr>
<tr>
<td>Closes the Chassis View.</td>
<td></td>
</tr>
<tr>
<td>Zooms in on an image.</td>
<td></td>
</tr>
<tr>
<td>Zooms out from an image.</td>
<td></td>
</tr>
<tr>
<td>Resizes an image so it can be viewed in its entirety within the Chassis View.</td>
<td></td>
</tr>
<tr>
<td>Opens a pop-up window that allows you to.</td>
<td></td>
</tr>
</tbody>
</table>
View Network Element State Information in the Chassis View

Badges, lines, and colors provide information about the operational state, elements and components in a device. Click the **Legends** icon at the bottom right of the Chassis View to display a key that lists what the badges, lines and colors mean.

See these topics for more information:

- Equipment Operational States (Chassis View), on page 81
- Port or Interface States, on page 82

---

**Note**

Port state information is not shown for the CFP ports on an A9K-400G-DWDM-TR line card as these ports are not yet supported.

### Equipment Operational States (Chassis View)

The equipment operational states represent the running state of the network element.

<table>
<thead>
<tr>
<th>Equipment Operational State</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>In Service</td>
<td>(none)</td>
<td>Equipment is operating properly.</td>
</tr>
<tr>
<td>Pre-provisioned</td>
<td>![Pre-provisioned Icon]</td>
<td>(Cisco NCS 2000 and Cisco ONS devices only) Equipment has been configured but is not physical present in the chassis.</td>
</tr>
</tbody>
</table>
Failed/Disabled/Down/Out of Service/Out of Service Maintenance

- Equipment is not operating properly.

Unknown

- Equipment operational state is unknown. No response (or insufficient response) from the device.

---

**Port or Interface States**

**Port or Interface Primary States**—Conveys the most important state information for a port or interface by combining the admin and operational states. The Multilayer Trace displays either a port's primary state or alarm status. For the Chassis View, if an element does not support the changing of color to indicate a state change, you can still get the state change information from the alarm that is generated.

---

**Note**

If there is an alarm associated with a port/interface, alarm icon will show up, port icon will not show.

<table>
<thead>
<tr>
<th>Port or Interface Primary State</th>
<th>Icon</th>
<th>Admin Status</th>
<th>Operational State</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unknown</td>
<td>![Question Mark]</td>
<td>Unknown</td>
<td>Unknown</td>
</tr>
<tr>
<td>Down</td>
<td>![Down Arrow]</td>
<td>Up</td>
<td>Down</td>
</tr>
<tr>
<td>Test</td>
<td>![Check Mark]</td>
<td>Test</td>
<td></td>
</tr>
<tr>
<td>Admin Down</td>
<td>![Cross]</td>
<td>Admin Down</td>
<td></td>
</tr>
<tr>
<td>Up</td>
<td>![Up Arrow]</td>
<td>Up</td>
<td>Up</td>
</tr>
<tr>
<td>Auto Up</td>
<td>![Auto Up Arrow]</td>
<td>Up</td>
<td>Auto Up</td>
</tr>
</tbody>
</table>

**Port or Interface Admin Status**—Represents the configured state of the port or interface (for example, if an administrator has manually shut down a port).

<table>
<thead>
<tr>
<th>Port or Interface Admin Status</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unknown</td>
<td>![Question Mark]</td>
<td>Port or interface admin status is unknown. There is no response (or insufficient response) from the device.</td>
</tr>
<tr>
<td>Admin Down</td>
<td>![Cross]</td>
<td>Port or interface was manually shut down by the administrator.</td>
</tr>
<tr>
<td>Up</td>
<td>![Up Arrow]</td>
<td>Port or interface is enabled by the administrator.</td>
</tr>
<tr>
<td>Test</td>
<td>![Check Mark]</td>
<td>Port or interface is being tested by the administrator.</td>
</tr>
</tbody>
</table>

**Port or Interface Operational State**—Conveys the port or interface's running state and whether it is working properly.
Port or Interface Operational State | Icon | Description
--- | --- | ---
Unknown | ![Icon](image) | Port or interface operational state is unknown. There is no response (or insufficient response) from the device.
Down | ![Icon](image) | Port or interface is not working properly.
Up | ![Icon](image) | Port or interface is receiving and transmitting data.
Auto Up | ![Icon](image) | Port or interface is receiving and transmitting data (only certain devices support this state; other devices use "Up").

View Mixed Chassis, Multi-Chassis, and Multi-Shelf Devices in the Chassis View

The following example shows a mixed Chassis View that has both Cisco NCS 2000 and Cisco ONS 15454 chassis. Shelf numbers are not consecutive because of the different types of chassis.

For mixed-chassis, multi-chassis, and multi-shelf devices, Cisco EPN Manager aggregates alarms to a chassis or shelf as explained in View Alarms in the Chassis View, on page 84.

For multi-chassis devices in a cluster, the Device 360 view’s Chassis tab identifies which chassis is the primary and which is the backup.
Chassis View opened for a multi-shelf device will display only the first 4 racks, and requires the user to click the download button (displayed on the rack number 5 and above) to display the relevant rack information.

View Alarms in the Chassis View

An alarm badge in the Chassis View represents one or more alarms that have been localized to a piece of equipment. For an element with multiple alarms, the badge icon will convey the most severe alarm.

To customize the Chassis View so that alarm icons blink (to bring your attention them), click from the bottom right of the view, then check the Enable Alarm Blinking check box.
If there is an alarm associated with a port/interface, alarm icon will show up, port icon will not show.

Note

To view the alarms specific to a device, do the following:

| Step 1 | With a device's Chassis View open, click the **Launch Configuration** link. The Device Details page opens. |
| Step 2 | If not already selected, click the **Alarms** tab. All of the alarms that have been raised for the device are listed here. |
| Step 3 | To view the alarms for a specific device component (such as a line card or port), do one of the following: • Double-click the component in the Chassis View. • Click ![Chart View](image) to open the **Chassis Explorer**, then click its entry. |

**View Routes of a Circuit in the Chassis View**

You can view the end-to-end physical route of a circuit using the Chassis View of a device participating in the circuit. You can also choose to view the power levels and span loss in the circuit.

Note

This feature is available only for the OCH WSON Optical circuit type.

| Step 1 | From the left sidebar, choose **Inventory > Device Management > Network Devices**. |
| Step 2 | From the Network Devices table, click the required device's name hyperlink to open the full-page view of the Chassis View. |
| Step 3 | Expand the Chassis View Explorer, and then select the shelf. |
| Step 4 | In the right pane, click the **Circuits** sub-tab, and then select the circuit for which you want to view the physical routes. The Chassis View displays the physical routes of the circuit. The internal connections between the ports of the same card are displayed as dotted lines. |
| Step 5 | In the left pane, next to the Chassis View, click the eye icon to show or hide the physical routes, power levels, and span loss. |
View Device Ports

You can get in-depth information about a device's physical ports from the Device Details page. You can also get basic port information from various 360 views.

To view a device chassis with its modules and ports, use the Chassis View. See Open the Chassis View, on page 77.

<table>
<thead>
<tr>
<th>To view this port information:</th>
<th>Do the following:</th>
</tr>
</thead>
</table>
| All Physical ports on a device (including port alias and residing module) | 1. Open the Device Details page.  
   • Choose View > Details from the top right of the Device 360 view.  
   • Click the device name hyperlink in a device table.  
   
2. Under the Device Details tab, choose System > Physical Ports >.. |
| An interface's ports | Check the Interface tab on a 360 view. |
| Ports connected to a module | Check the Modules tab on a Device 360 view. |
| Ports connected to a neighbor | Check the Neighbors tab on a Device 360 view. |

For a matrix of ports states and icons, see Port or Interface States, on page 82.

View Device Interfaces

Cisco EPN Manager provides the following ways to view device interfaces:

<table>
<thead>
<tr>
<th>Ways to View Interfaces</th>
<th>For more information, see:</th>
</tr>
</thead>
<tbody>
<tr>
<td>View details about a specific interface</td>
<td>Get a Quick Look at a Device Interface: Interface 360 View, on page 87</td>
</tr>
</tbody>
</table>
| View a specific device's interfaces | • View a Specific Device's Interfaces: Device 360 View, on page 86  
   • Get Comprehensive Information About a Device's Interfaces Using the Device Details Page, on page 90 |

View a Specific Device's Interfaces: Device 360 View

Use the Device 360 view to quickly check the status of a device's interfaces.
Step 1
Open the Device 360 view:
- Click the "i" icon next to an IP address in almost any device table
- From the network topology, click a device in an expanded group, then click View

Step 2
Click the Interfaces tab.

Get a Quick Look at a Device Interface: Interface 360 View

The Interface 360 view shows summary information for a specific interface including general interface details, interface status, alarms on the interface, circuits/VCs traversing the interface, and performance information. From the Interface 360 view's Actions menu, you can perform basic tasks such as enabling and disabling the interface, and so on. The Show in Topology option launches the topology map so that you can view the interface in the context of the map.

You can launch the Interface 360 view wherever you see an "i" icon next to an interface name—for example, in an alarms table, a links table or in a device 360 view.

The Interface 360 view provides general interface information at the top of the view, and more detailed interface information in tabs in the lower part of the view. The information the Interface 360 view displays depends on the interface configuration.
The tabs displayed vary depending on the type of interface for which you launched this view. For example, for optical interfaces you might see the Optical Physical tab or the ODU tab, depending on the type of optical interface.

Using the menus in the top right of the pop-up window, you can also perform these tasks:

• Open a chassis view that highlights the port or line card the interface is associated with (View menu). This feature comes in handy when you need to describe to an onsite technician where to find the source of an issue.

• Select the interface for a side-by-side comparison with another interface on the basis of information such as raised alarms and the current status of associated circuits and VCs (Actions menu)—see Compare Interface Information and Status, on page 89.

• View performance information in the relevant performance dashboard for the specific interface type by selecting View > Performance.

• Enable and disable the interface from the Actions menu.

• Enable and disable the lockout of an MPLS interface from the Actions menu. You would lock out an MPLS interface before doing maintenance work on the TE Tunnel link that the interface belongs to. After you lock out an MPLS interface, be sure to manually sync the device. Otherwise, you will not have the option to disable the lockout later.

• View the device on which the interface is located in a topology map (Actions menu).

• Set a baseline for performance data for optical interfaces (except for optical physical interfaces) for troubleshooting purposes. See Set a Baseline for Optical Performance Data, on page 90 for more information.

<table>
<thead>
<tr>
<th>Information Provided in Interface 360 View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General information</td>
<td>The interface name, status, description, type, device name; IP address, MAC address, and so forth.</td>
</tr>
<tr>
<td>Performance data</td>
<td>Launch point to the relevant performance dashboard from View &gt; Performance.</td>
</tr>
<tr>
<td>Alarms</td>
<td>Current alarms for the interface, including their severity, status, and the time they were generated. Also provides a launch point to the Alarm Browser.</td>
</tr>
<tr>
<td>Interfaces</td>
<td>Name, interface type, and operational and admin status for each associated interface. Also provides a launch point for the Interface 360 view.</td>
</tr>
<tr>
<td>Circuit/VCs</td>
<td>(For interfaces that participate in circuits) Circuit/VC name, type, customer, status, and creation date. Also provides a launch point for the Circuit/VC 360 view.</td>
</tr>
<tr>
<td>EFPs</td>
<td>All EFPs associated with the interface (if relevant). Also provides their operational status, admin status, and EFP type.</td>
</tr>
<tr>
<td>Detailed information relevant to a specific interface type.</td>
<td>Additional interface information and performance data in tabs relevant to the type of interface, for example, Optical Physical, ODU, FEC, and so on.</td>
</tr>
</tbody>
</table>
Optical Physical | Real-time performance monitoring data for the interface. This data is collected every 10 seconds, and the results of the last 12 pollings are displayed here. For a listing of the counters that can be displayed, see Performance Counters for Optical Monitoring Policies.

Compare Interface Information and Status

From the **Comparison View**, you can perform a side-by-side comparison of multiple interfaces, viewing information such as IP and MAC address, raised alarms, and associated circuits and VCs. To compare interfaces, do the following:

**Step 1** For each interface you want to compare:
   a) Open its **Interface 360** view, as described in Get a Quick Look at a Device Interface: Interface 360 View, on page 87.
   b) Choose **Actions > Add to Compare**.

   The interface you selected is displayed at the bottom of the page. You can select a maximum of 4 interfaces.

**Step 2** Click **Compare**.

The **Comparison View** opens.

**Step 3** From the drop-down list at the top of the view, specify whether the view will show all available information or just the information that is unique to each interface.

**Step 4** Click **Comparison View**, check the check box for the categories you want the view to display, and then click **Save**.

By default, all of the categories are already selected.

**Step 5** Scroll down the page to view the information provided for each category you selected.

Note the following:

- The **Comparison View** only displays information for two interfaces at a time. If you selected more than two, you will need to toggle to the interfaces that are not currently displayed.

- To reorder the interfaces you have selected, click **Rearrange**.

- Each interface’s **View** and **Actions** menu is identical to the ones provided in its **Interface 360** view. If you select an option, the corresponding page opens.

- You can minimize and maximize the categories displayed, as needed.

- The **Comparison View** is also available for circuits and VCs, devices, and links. Whenever you select any of these elements from their respective 360 view for comparison, they are displayed in the corresponding tab. This allows you to switch between element types, as needed.

- When you are done comparing interfaces, click **Back** at the top of the view and then click **Clear All Items** at bottom of the page. If tabs for other element types are still displayed, you will need to clear them as well.
Get Comprehensive Information About a Device’s Interfaces Using the Device Details Page

Use the Device Details page to get extensive information about all of the interfaces that are configured on a device. For easier navigation, interfaces are grouped together by type.

---

**Step 1**

Open the Device Details page.
- Click the device name hyperlink which appears in many of the device tables
- Choose View > Details at the top right of the Device 360 view

**Step 2**

Under the Device Details tab, double-click Interfaces to display a list of all interfaces (of all types) that are configured on the device.

**Step 3**

To display all interfaces of the same type, click the type (such as Ethernet Interfaces).

**Step 4**

To get details about a specific interface, click the interface name hyperlink.

---

Set a Baseline for Optical Performance Data

Setting a baseline for optical interface performance data enables you to compare realtime network performance with a fixed set of performance statistics. In this way, you could compare normal baseline network performance with abnormal network behavior.

After you set a baseline, all new incoming performance statistics are recalculated based on the baseline values to show you the difference between the baseline values and the current realtime values (specifically, the current value minus the baseline value).

Optical interfaces that support this functionality will have a Set Baseline button in the relevant tab in the Interface 360 view.

To set a baseline for optical interface performance statistics:

**SUMMARY STEPS**

1. Open the Interface 360 view for the relevant interface.
2. Open the tab specific to the interface type, for example, FEC, OTU, and so on.
3. Click the Set Baseline button.
4. To go back to the realtime values (effectively removing the baseline), close the Interface 360 view and then reopen it.

**DETAILED STEPS**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong></td>
<td>Open the Interface 360 view for the relevant interface.</td>
</tr>
<tr>
<td><strong>Step 2</strong></td>
<td>Open the tab specific to the interface type, for example, FEC, OTU, and so on.</td>
</tr>
<tr>
<td>Command or Action</td>
<td>Purpose</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------</td>
</tr>
<tr>
<td><strong>Step 3</strong></td>
<td>Click the Set Baseline button. The rows in the table will be cleared. Each new row will have values that reflect the difference between the baseline values and the current realtime values.</td>
</tr>
<tr>
<td><strong>Step 4</strong></td>
<td>To go back to the realtime values (effectively removing the baseline), close the Interface 360 view and then reopen it.</td>
</tr>
</tbody>
</table>

**View Device Modules**

To view device module information, choose **Inventory > Device Management > Network Devices**, then launch a Device 360 or Device Details page, depending on how much information you want.

<table>
<thead>
<tr>
<th>To get this information:</th>
<th>Use this navigation:</th>
</tr>
</thead>
</table>
| Basic module information: Status, type, ports | From the Device 360 view, click the Modules tab. To open the Device 360 view:  
  • Click the “i” icon next to the device name in almost any device table  
  • From the Network Topology, click a device (in an expanded view), then click View |
| Module equipment type and power information | From the Device Details page, choose System > Modules under the Device Details tab.  
To open the Device Details page:  
  • Click the device name hyperlink which appears in many device tables  
  • Choose View > Details from the top right of the Device 360 view |

**Note**  
Due to a limitation in the retrieval of module related information, this page lists SFP transceivers of Cisco CAT6500 devices as 'Unspecified' products.

**View Environment Information (Power Supplies, Fans)**

Environment-related information, such as details about power supplies and fans, is displayed in a device’s **Device Details** page. To access this information:

**Step 1**  
Do one of the following:  
• Click the device name hyperlink that appears in many Cisco EPN Manager device tables and then click the Device Details tab (if it is not already selected).  
• Choose View > Details from the top right of a Device 360 view and then click the Device Details tab (if it is not already selected).
Step 2  From the Features pane, choose System > Power Options & Fans.

View Device Neighbors

Device neighbor information, such as the neighbor name, port number, index, and duplex setting, is displayed in a device’s Device 360 view.

Step 1  Open the Device 360 view:
- Click the i (information) icon next to the device name in almost any device table
- From the network topology, click a device in an expanded group and click View

Step 2  Click the Neighbors tab.

Example

For example:

```
<table>
<thead>
<tr>
<th>Name</th>
<th>Index</th>
<th>Port</th>
<th>Duplex</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASR9K</td>
<td>7</td>
<td>TenGigE0/0/2/0</td>
<td>fullduplex</td>
</tr>
<tr>
<td>CPE-ISRG2</td>
<td>87</td>
<td>GigabitEthernet0/0/3</td>
<td>fullduplex</td>
</tr>
<tr>
<td>Asr_903</td>
<td>36</td>
<td>GigabitEthernet0/0/0</td>
<td>fullduplex</td>
</tr>
</tbody>
</table>
```

Get More Information About Links

Cisco EPN Manager provides a variety of ways that you can view links and get more details about them:

<table>
<thead>
<tr>
<th>To view link information for:</th>
<th>See the procedures in:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A specific link</td>
<td>Get a Quick Look at a Specific Link: Link 360 View, on page 167</td>
</tr>
<tr>
<td>A specific link in a topology map</td>
<td>View a Specific Link in the Topology Map, on page 170</td>
</tr>
<tr>
<td>A group in a topology map</td>
<td>View a Device Group's Links in a Network Topology Map, on page 170</td>
</tr>
<tr>
<td>All of Cisco EPN Manager</td>
<td>View Link Tables, on page 171</td>
</tr>
</tbody>
</table>
View Circuits/VCs

Cisco EPN Manager provides a variety of ways that you can view circuits/VCs:

<table>
<thead>
<tr>
<th>To view circuit/VC information for:</th>
<th>See the procedures in:</th>
</tr>
</thead>
</table>
| A specific circuit/VC in a topology map, in a Circuit/VC 360 view, or in a Circuit/VC Details page | • Get Quick Information About a Circuit/VC: Circuit/VC 360 View, on page 593  
• Get Comprehensive Information About a Circuit/VC: Circuit/VC Details Window, on page 597 |
| A device | View a Specific Device's Circuits/VCs, on page 600 |
| A device group in a topology map or in an expanded table | View a Device Group's Circuits/VCs, on page 600 |
| All of Cisco EPN Manager | View All Circuits/VCs in Cisco EPN Manager, on page 602 |

View Satellites

Cisco EPN Manager provides the following ways to view satellite information for host-satellite configurations:

<table>
<thead>
<tr>
<th>Ways to View Satellites</th>
<th>For more information, see:</th>
</tr>
</thead>
<tbody>
<tr>
<td>View all satellites in a location group using a topology map</td>
<td>View Cisco ASR 9000 Host-Satellite Topologies in the Topology Map, on page 250</td>
</tr>
</tbody>
</table>
| View a specific device's satellites from a Device 360 view | • Identify the Satellites Connected to a Cisco ASR 9000 Host, on page 251  
• Get Basic Device Information: Device 360 View, on page 69 |
| View details about a specific satellite, including the hosts it is connected to, using the Satellite 360 view | Identify the Hosts Connected to a Satellite, on page 252 |

Create User Defined Fields for Custom Values

If you want to assign custom attributes to devices or circuits/VCs, you can create your own fields to be shown in the tables and you can define custom values in those fields. For example, you might want to label certain devices with a customer name. After you have created user defined fields and assigned values, you can search by these values in the device tables and in the maps.

To create user defined fields:
Step 1  Choose Administration > Settings > System Settings > Inventory > User Defined Fields.
Step 2  Click the ‘+’ icon and create a new label and description.
Step 3  Assign values in your newly created user defined field for specific devices/circuits/VCs as follows:
   a) Go to the device table or to the table of circuits/VCs.
   b) Display your user defined field as a column in the table by clicking the settings icon at the top right of the page, choosing Columns, and then selecting your user defined field.
   c) Go to the required device or circuit/VC in the table, enter a value in your user defined column, and click Save.
Manage Device Configuration Files

- Set Up Device Configuration File Management, on page 95
- How Do I Find Out the Last Time Files Were Archived?, on page 98
- Back Up Device Configuration Files to the Archive, on page 99
- View the Device Configuration Files That Are Saved in the Archive, on page 101
- View a Device's Running Configuration File (Raw Content), on page 102
- Label Important Configuration Files With Tags, on page 103
- Synchronize Running and Startup Device Configurations, on page 103
- Download Configuration Files, on page 103
- Compare or Delete Device Configuration Files, on page 104
- Deploy an External Configuration File to a Device, on page 105
- Overwrite a Startup Configuration with a Running Configuration, on page 106
- Roll Back a Device’s Configuration To an Archived Version, on page 106
- Export Configuration Files to a Local File System, on page 107
- Delete Archived Device Configuration Files, on page 108
- Check the Network Audit for Configuration Archive Operations, on page 108

Set Up Device Configuration File Management

- Make Sure Devices Are Configured Correctly, on page 95
- Control How Archiving is Triggered, on page 96
- Set Up Event-Triggered Archiving, on page 96
- Specify Items to Be Excluded When Configuration Files Are Checked for Changes, on page 97
- Control the Timeouts for Configuration Archive Operations, on page 97
- Control How Many Files Can Be Archived In Parallel, on page 98
- Control When Device Configuration Files are Purged from the Database, on page 98

Make Sure Devices Are Configured Correctly

Before you start using the Configuration Archive features, make sure devices are configured according to the settings in Configure Devices So They Can Be Modeled and Monitored, on page 44.
Control How Archiving is Triggered

By default, Cisco EPN Manager saves device configuration files to the archive when:

- A new device is added to Cisco EPN Manager
- When a device change notification is received
- Archive collection is not carried out in case of full or granular sync.

Note: In there is an event occurrence, archive data is collected after the period of configured hold off timer.

Users with Administrator privileges can change those settings.

---

**Step 1**
Choose Administration > Settings > System Settings, then choose Inventory > Configuration Archive.

**Step 2**
Adjust the archiving settings depending on the following criteria.

<table>
<thead>
<tr>
<th>Check this check box:</th>
<th>To archive files:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Archive configuration out-of-box?</td>
<td>When a new device is added (enabled by default)</td>
</tr>
<tr>
<td>Archive configuration on receiving configuration change events?</td>
<td>When a configuration change notification is sent (enabled by default); see Set Up Event-Triggered Archiving, on page 96</td>
</tr>
</tbody>
</table>

**Step 3**
To schedule regular archiving for groups of devices (or single devices):

a) Choose Inventory > Device Management > Configuration Archive.

b) Under the Devices tab, select the devices or device groups that you want to archive on a regular basis.

c) Click Schedule Archive and complete the schedule settings in the Recurrence area. If the operation will be performed on a large number of devices, schedule the archiving for a time that is least likely to impact production.

Note: To enable device configuration collection via SFTP, the configuration is copied to the 'localdisk/sftp' directory. By default, this option is disabled. To enable it, locate the 'ifm_config_archive.properties' file under the '/opt/CSCOlumos/conf/ifm' folder, and set the 'COPY_CONFIGURATIONS_TO_LOCAL_STORAGE' value to true. This is applicable only to the newly archived configuration files. Configuration files that were archived in the past are not copied to this directory.

d) Click the Backup to Repository button to transfer device configuration periodically to external repository. You can configure or create the repository using CLI commands and the supported repositories are FTP, SSH FTP (SFTP) and Network File System (NFS).

---

Set Up Event-Triggered Archiving

By default, Cisco EPN Manager backs up a device’s configuration file whenever it receives a change notification event. This function will work only if devices are configured properly; see How Is Inventory Collected?, on page 43 For example, for devices running Cisco IOS XR and Cisco IOS XE, the following setting must be configured:
When Cisco EPN Manager receives a configuration change event, it waits 10 minutes (by default) before archiving in case more configuration change events are received. This prevents multiple collection processes from running at the same time. To check or change this setting, choose Administration > Settings > System Settings, then choose Inventory > Configuration Archive and adjust the Hold Off Timer.

The Hold Off Timer may be set to a shorter period for certain events, called expedited events. For more information, see Change the Behavior of Expedited Events, on page 787.

To turn off event-triggered archiving, choose Administration > Settings > System Settings, then choose Inventory > Configuration Archive and uncheck the Archive configuration on receiving configuration change events? check box.

Specify Items to Be Excluded When Configuration Files Are Checked for Changes

Some lines in device configuration files should be excluded when Cisco EPN Manager compares different versions to identify changes. Cisco EPN Manager excludes some lines by default, such as clock settings for routers and switches. If you have Administrator privileges, you can check which lines are excluded, and add more lines to be excluded.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose Administration &gt; Settings &gt; System Settings, then choose Inventory &gt; Configuration Archive.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Click the Advanced tab.</td>
</tr>
<tr>
<td>Step 3</td>
<td>In the Product Family list, choose the devices or groups to which you want to apply the command exclusions.</td>
</tr>
<tr>
<td>Step 4</td>
<td>In the Command Exclude List, enter a comma-separated list of configuration commands you want to exclude for that selection. These are the parameters Cisco EPN Manager will ignore when checking devices for configuration changes.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Click Save.</td>
</tr>
</tbody>
</table>

Control the Timeouts for Configuration Archive Operations

By default, Configuration Archive operations such as archiving, rolling back, and fetching configurations from devices will time out if a device does not respond for 6 minutes (360s). To adjust this setting, choose Administration > Settings > System Settings, then choose Inventory > Configuration Archive and change the setting in the Timeout field.

Control How Often Alarms are Triggered

By default, Cisco EPN Manager saves device configuration files to the archive based on the configured settings. However when these jobs fail, you can choose to generate an alarm notification.

When a Configuration Archive job fails, Cisco EPN Manager waits for 7 days or for more than 5 (by default) configuration files before triggering an alarm. The alarm has information about the cause for the trigger of the alarm and other related details associated with the configuration archives. To change the default settings
for how often the alarms are generated, choose Administration > Settings > System Settings, then choose Inventory > Configuration Archive and adjust the Alarm Threshold parameter for maximum number of configuration files (exceeding which an alarm is generated) and the number of days to wait before the alarm is triggered.

## Control How Many Files Can Be Archived In Parallel

Cisco EPN Manager uses 10 thread pools for copying configuration files to the archive. A larger number may be helpful when archiving of changes involving more than 1,000 devices; however, making the number too large can negatively impact system performance. To change this number, choose Administration > Settings > System Settings, then choose Inventory > Configuration Archive and adjust the Thread Pool Count value.

## Control When Device Configuration Files are Purged from the Database

Device configuration files cannot be automatically deleted from the database (you can manually delete the files); they can be periodically purged by Cisco EPN Manager based on your settings. Users with Administrator privileges can adjust when configuration files are purged as follows. If you do not want any configuration files purged, follow this procedure but leave both fields blank.

![Note](image)

For a description of how to manually delete a configuration file, see Delete Archived Device Configuration Files.

### Step 1
Choose Administration > Settings > System Settings, then choose Inventory > Configuration Archive.

### Step 2
Adjust the archiving settings depending on the following criteria.

<table>
<thead>
<tr>
<th>Use this field:</th>
<th>To purge files when:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum ___ configuration archives</td>
<td>The number of a device’s configuration files exceeds this setting (5 by default).</td>
</tr>
<tr>
<td>Maximum ___ days retained</td>
<td>A configuration file’s age exceeds this setting (7 days by default).</td>
</tr>
</tbody>
</table>

## How Do I Find Out the Last Time Files Were Archived?

### Step 1
To find out the most recent date when device running configuration files were backed up to the archive, choose Inventory > Device Management > Configuration Archive and click the Devices tab. The Latest Archive column lists the archiving time stamp for each device with the most recent archive listed first. The Created By column displays the archive trigger (for example, a syslog).

### Step 2
To view the contents of a device’s most recently-archived running configuration file, click the time stamp hyperlink. The Running Configuration window displays the contents of the file.
Back Up Device Configuration Files to the Archive

- What Is Backed Up to the Database?, on page 99
- Back Up (Archive) Configuration Files, on page 99

What Is Backed Up to the Database?

The configuration archive maintains copies of device configuration files, storing them in the database. Most configuration files are stored in readable format as received from the device and can be compared with earlier versions. Device configurations can be restored to earlier states using the files saved in the archive.

If the running and startup configurations on a device are the same, Cisco EPN Manager copies only the running configuration to the database. This is why in some cases, when you view the image repository, you will only see an archive for the running configuration.

If a configuration file has not changed since its last backup, Cisco EPN Manager does not archive the file. Cisco EPN Manager will report that the job was successful and the job result will display Already Exists.

Cisco EPN Manager collects and archives the following device configuration files.

<table>
<thead>
<tr>
<th>Device/Device OS</th>
<th>What is Backed Up</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco IOS and Cisco IOS XE</td>
<td>Latest startup, running, and VLAN configuration.</td>
</tr>
<tr>
<td>Cisco IOS XR</td>
<td>• Latest running configuration; includes active packages. Devices must be managed with system user because copy command is not available in command-line interface (CLI) for non-system users.</td>
</tr>
<tr>
<td></td>
<td>• Database configuration (binary file)</td>
</tr>
<tr>
<td></td>
<td>Note For Cisco NCS 4000 devices, the database is backed up as a .tgz file to a file system on your local machine.</td>
</tr>
<tr>
<td>Cisco NCS</td>
<td>Database configuration (binary file)</td>
</tr>
<tr>
<td></td>
<td>Note For Cisco NCS 2000 devices, the database is backed up as a binary file. Because it is not a text file, you cannot compare versions, but you can identify them by their file time stamp in the configuration archive.</td>
</tr>
</tbody>
</table>

Back Up (Archive) Configuration Files

When a configuration file is backed up, Cisco EPN Manager fetches a copy of the configuration file from the device and copies (backs it up) to the configuration archive (database). Before saving a copy to the archive, Cisco EPN Manager compares the fetched file with the last version in the archive (of the same type—running with running, startup with startup). Cisco EPN Manager archives the file only if the two files are different. If the number of archived versions exceeds the maximum (5, by default), the oldest archive is purged.
For devices that support both a running and startup configurations, Cisco EPN Manager identifies out-of-sync (unsynchronized) devices during the backup process by comparing the latest version of the startup configuration with the latest version of the running configuration file. For more information on out-of-sync devices, see Synchronize Running and Startup Device Configurations, on page 103.

The following table describes the supported backup methods and how they are triggered. To check or adjust the default settings, see Control How Archiving is Triggered, on page 96.

When you archive a Cisco NCS 2000 database, if you receive an error message saying the database or flash is busy, it is likely caused by one following:

- You are performing the archive operation in parallel with other Configuration Archive or Image Management operations. You should retry the operation after a short period of time.
- Multiple users are performing the same operation at the same time. You should retry the operation after a short period of time.
- The device has a software download alarm that has not been cleared. You should clear the alarm.

To enable device configuration collection via SFTP, the configuration is automatically copied to the 'localdisk/sftp' directory. This is applicable to only newly archived configuration files. Configuration files that were archived in the past are not copied to this directory. To disable this option, locate the 'ifm_config_archive.properties' file under the '/opt/CSCOlumos/conf/ifm' folder, and set the 'COPY_CONFIGURATIONS_TO_LOCAL_STORAGE' value to false.

<table>
<thead>
<tr>
<th>Backup Method</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>On-demand manual backup</td>
<td>Choose Inventory &gt; Configuration Archive, choose devices, and click Schedule Archive (run the job immediately or at a later time).</td>
<td>N/A</td>
</tr>
<tr>
<td>Regular scheduled backups</td>
<td>Choose Inventory &gt; Configuration Archive, choose devices, and click Schedule Archive. In the scheduler, specify a Recurrence.</td>
<td>N/A</td>
</tr>
<tr>
<td>Inventory collection backups</td>
<td>Cisco EPN Manager automatically performs backup if changes are detected during inventory collection.</td>
<td>Disabled by default</td>
</tr>
<tr>
<td>New device backups</td>
<td>Cisco EPN Manager automatically performs backup for new devices.</td>
<td>Enabled by default</td>
</tr>
<tr>
<td>Event-triggered backups (device change notifications)</td>
<td>Cisco EPN Manager automatically performs backup when it receives a syslog from a managed device.</td>
<td>Enabled by default</td>
</tr>
</tbody>
</table>
View the Device Configuration Files That Are Saved in the Archive

- View All Archived Files, on page 101
- View Archived Files for a Specific Device, on page 101

View All Archived Files

To view the configuration files that are saved in the database, choose **Inventory > Device Management > Configuration Archive**. Click the Archives or Devices tabs depending on where you want to start:

- **Archives** tab—A list of configuration files that have been archived, with the most recent archives listed first. The Out of Band column indicates whether the change was made by an application other than Cisco EPN Manager. Use the Groups list on the left to view archives by device types and families. From here you can:
  - Roll Back a Device’s Configuration To an Archived Version, on page 106
  - Overwrite a Startup Configuration with a Running Configuration, on page 106
  - Label Important Configuration Files With Tags, on page 103

- **Devices** tab—A flat list of devices with their archived configurations. From here you can:
  - Schedule backups to the archive (see **Back Up Device Configuration Files to the Archive**, on page 99).
  - View the archived file for a specific device by clicking the device name hyperlink (see View Archived Files for a Specific Device, on page 101).

By default, Cisco EPN Manager saves up to 5 versions of a file, and deletes any files that are older than 7 days; device configuration files cannot be manually deleted from the database. (To check the current purging settings, see **Control When Device Configuration Files are Purged from the Database**, on page 98.)

View Archived Files for a Specific Device

**Note**

If you only see a running configuration file and not a startup file, that is because the two files are the same. Cisco EPN Manager only backs up the startup configuration when it is different from the running configuration.

**Step 1** Choose **Inventory > Device Management > Configuration Archive**, then click the **Devices** tab.

**Step 2** Click a device name hyperlink. Cisco EPN Manager lists archived files according to their timestamps.
View the Raw Content of an Archived Configuration File

Use this procedure to view the startup, running, and (if supported) VLAN, database, and admin configuration files that have been saved to the configuration archive. You can choose versions according to time stamps and then compare them with other versions.

To quickly view a device's currently-running configuration, perform a `show run` from the Device 360 view. See View a Device's Running Configuration File (Raw Content), on page 102.

Note
For Cisco NCS 2000 and Cisco NCS 4000 devices, the database is backed up as a binary file. Because it is not a text file, you cannot view it or compare it with other versions, instead, you can export the file directly.

To view the contents of a running configuration file stored in the configuration archive:

**Step 1** Choose **Inventory > Device Management > Configuration Archive**, then click the **Devices** tab.

**Step 2** Click a device name hyperlink. Cisco EPN Manager lists archived files according to their timestamps.

**Step 3** Expand a time stamp to view the files that were archived at that time. You will see the details for Running Configuration, Startup Configuration, Admin Configuration, VLAN Configuration, and Database Configuration. Click the Details hyperlink under these categories, to see more information.

**Note** If you only see a running configuration file and not a startup file, that is because the two files are the same. Cisco EPN Manager only backs up the startup configuration when it is different from the running configuration.

**Step 4** Click a file under Configuration Type to view its raw data. The Raw Configuration tab lists the file contents, top to bottom.

**Step 5** To compare it with another file, click any of the hyperlinks under the Compare With column. The choices depend on the device type and number of configuration files that have been backed up to the archive. Color codes indicate what was updated, deleted, or added.

View a Device's Running Configuration File (Raw Content)

To view a device's running configuration, execute a CLI `sh run` command from the Device 360 view **Actions** menu.

**Step 1** Open the device's Device 360 view.
- Click the "i" icon next to an IP address in almost any device table
- From the network topology, click a device in an expanded group, then click **View**

**Step 2** Choose **Actions > Show Command**.

**Step 3** In the Run Show Commands dialog box, choose `sh run` from the drop-down list, then click **Run**.
Label Important Configuration Files With Tags

Assigning tags to configuration files is a clear method for identifying important configurations and convey critical information. The tag is displayed with the list of files on the Configuration Archive page. Tags can also be edited and deleted using the following procedure.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose <strong>Inventory &gt; Device Management &gt; Configuration Archive</strong>.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Under the <strong>Archives</strong> tab, locate the configuration file you want to label, and click <strong>Edit Tag</strong>.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Enter your content in the Edit Tag dialog box (or edit or delete existing tags) and click <strong>Save</strong>.</td>
</tr>
</tbody>
</table>

Synchronize Running and Startup Device Configurations

Devices that have startup configuration files and running configuration files may become out-of-sync (unsynchronized). A device is considered out-of-sync if its startup file (which is loaded when a device is restarted) is different from its running configuration. Unless a modified running configuration is also saved as the startup configuration, if the device is restarted, the modifications in the running configuration will be lost. The overwrite operation synchronizes the files by overwriting the device’s startup configuration with its current running configuration.

**Note**

This device configuration file synchronize operation is different from the Sync operation which performs *an immediate inventory collection for a device*. That Sync operation is described in Collect a Device's Inventory Now (Sync), on page 406.

| Step 1 | Identify the devices that are out-of-sync:  
| a) | Choose **Inventory > Device Management > Configuration Archive**.  
| b) | Under the Devices tab, check the Startup/Running Mismatch field.  
| c) | If any devices list **Yes**, make note of the devices. |
| Step 2 | To synchronize the devices:  
| a) | Under the Devices tab, select the out-of-sync devices, and click **Overwrite**. (See Overwrite a Startup Configuration with a Running Configuration, on page 106 for more information about the overwrite operation.) |
| Step 3 | To check the job details, choose **Administration > Job Dashboard** to view details about the overwrite jobs. |

Download Configuration Files

You can download the Startup and Running configuration files of up to a maximum of 1000 devices at a time, to your local system.
Choose Inventory > Device Management > Configuration Archive.

From the Export Latest Config drop-down list, select one of the following options to download the configuration files:

1. **Sanitized**—The device credential password will be masked in the downloaded file.
2. **Unsanitized**—The device credential password will be visible in the downloaded file.

This option downloads all supported configuration from the device as a csv file. To specifically download only the Startup or the Running configuration from the device, use the alternate steps below.

The Unsanitized option appears based on the user permission set in Role Based Access Control (RBAC).

You can also download the configuration files by doing the following:

- Click the device for which you want to download configuration files in the Inventory > Device Management > Configuration Archive page or Click the device for which you want to download configuration files in the Inventory > Device Management > Network Devices page and click Configuration Archive tab.
- Use the expand icon to display the required configuration details from the archive.
- Click Details.
- Select Sanitized or Unsanitized from the Export drop-down list.

**Remember** Before you upload this config file to your WLC, you need to add a keyword, `config` at the beginning of each line.

### Compare or Delete Device Configuration Files

The comparison feature displays two configuration files side by side with additions, deletions, and excluded values indicated by different colors. You can use this feature to view the differences between startup and running configuration files for out-of-sync devices, or to find out if similar devices are configured differently. You can then delete the configuration archives from the database.

Cisco EPN Manager excludes a small set of commands by default, such as the NTP clock rate (which constantly changes on a managed network element but is not considered a configuration change). You can change the excluded commands list as described in Specify Items to Be Excluded When Configuration Files Are Checked for Changes, on page 97.

**Note** File comparisons are not supported on the Cisco NCS 2000 devices because the files are saved in binary format. Only text-based files can be compared.

Choose Inventory > Device Management > Configuration Archive.

To delete the device configuration archive, under the Devices tab, locate the device with the configuration you want to delete and click the X delete button.

To compare device configuration archives:
a) Under the Devices tab, locate the device with the configuration you want to compare and click its device name hyperlink.
b) Expand a time stamp to view the files that were archived at that time.
c) Launch a comparison window by clicking any of the hyperlinks under the Compare With column. The choices depend on the device type and number of configuration files that have been backed up to the archive. Color codes indicate what was updated, deleted, or added.

In the Configuration Comparison window, you can peruse the configuration by looking at the raw files or by looking at certain portions of the files (configlets). Use the color codes at the bottom window to find what was updated, deleted, or added.

---

**Deploy an External Configuration File to a Device**

The Schedule Deploy operation updates a device’s configuration file with an external file. The difference between Rollback and Schedule deploy is that the Rollback uses an existing file from the archive, while Schedule Deploy uses an external file.

Depending on the type of device, you can specify the following settings for the deploy job:

- Overwrite the current startup configuration with the new version and optionally reboot the device after the deploy.
- Merge the new file with the current running configuration and optionally archive the file as the new startup configuration.
- Schedule the deploy of database configuration files in .tgz format.

Make sure you have the location of the file on your local machine.

---

**Step 1**

Open the device’s Device Details page, from which you will execute the deploy operation.

a) Choose **Inventory > Device Management > Network Devices**.
b) Click the device name hyperlink to open the Device Details page.

**Step 2**

Open the device’s Configuration Archive page by clicking the Configuration Archive tab.
For Cisco NCS 2000 and Cisco ONS devices, this choice is displayed on the right when you click the **Chassis View** tab.

**Step 3**

Click **Schedule Deploy** to open the deploy job dialog box.

**Step 4**

Choose the file you want to deploy by clicking **Browse**, navigating to the file’s location, and choosing the file.

*Note* To deploy database configuration files to Cisco for NCS 4000 devices, you must upload the files in .tgz format.

**Step 5**

Configure the job parameters, depending on the type of file you are deploying:

- Startup configuration—Choose **Overwrite Startup Configuration**. If you want to reboot the device after the deploy operation, check the **Reboot** check box.
- Running configuration—Choose **Merge with Running Configuration**. If you want to also save the file on the device as the startup configuration, check the **Save to Startup** check box.
- Database configuration—Choose **Deploy Database Configuration** and select a database file (in .tgz format for Cisco NCS 4000 devices and .cfg format for Cisco NCS2000 devices).
Overwrite a Startup Configuration with a Running Configuration

The overwrite operation copies a device’s running configuration to its startup configuration. If you make changes to a device’s running configuration without overwriting its startup configuration, when the device restarts, your changes will be lost.

Note
Do not use the Overwrite button in the Archives tab (shown when you choose Inventory > Device Management > Configuration Archive) because it only allows you to select a device but not select a configuration file.

Roll Back a Device’s Configuration To an Archived Version

The rollback operation copies files from the archive to devices, making the new files the current configuration. You can roll back running, startup, and VLAN configurations. By default, the operation is performed by merging the files. If you are rolling back a running configuration, you have the option to perform it using overwrite rather than merge. To roll back a configuration file to a previous version.

Step 1 Choose Inventory > Device Management > Network Devices.
Step 2 Click the device name hyperlink to open the device’s details page, then click the Configuration Archive tab. For Cisco NCS 2000 and Cisco ONS devices, this choice is displayed on the right when you click the Chassis View tab.
Step 3 Click Schedule Overwrite and set the job to run immediately or at a future time, then click Submit.
Step 4 Choose Administration > Job Dashboard to view the image activation job.

Step 1 Choose Inventory > Device Management > Configuration Archive.
Step 2 Click the Archives tab and check the device that has the configuration file you want to roll back, and click Rollback.
Step 3 Choose the file types you want to roll back. In the Schedule Configuration Rollback dialog box:
   a) Expand the Rollback Options area.
   b) From the Files to Rollback drop-down list, choose the file type. Choosing All applies the operation to startup, running, and VLAN configuration files.
Step 4 Click the specific configuration file version that you want to roll back to.
Step 5 Click Schedule Rollback and complete the following:
### Table 10: Roll Back Device Configuration

<table>
<thead>
<tr>
<th>Area</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rollback</td>
<td>Files to rollback</td>
<td>Select Database Configuration, Running Configuration, or Admin Configuration.</td>
</tr>
<tr>
<td>Reboot</td>
<td>(Startup only) After rolling back the startup configuration, reboot the device so the startup configuration becomes the running configuration.</td>
<td></td>
</tr>
<tr>
<td>Save to startup</td>
<td>(Running only) After rolling back the running configuration, save it to the startup configuration.</td>
<td></td>
</tr>
<tr>
<td>Archive before rollback</td>
<td>Back up the selected file(s) before beginning the rollback operation.</td>
<td></td>
</tr>
<tr>
<td>Overwrite running configuration</td>
<td>Overwrite (rather than merge) the old running configuration with the new one.</td>
<td></td>
</tr>
<tr>
<td>Continue rollback on archive failure</td>
<td>(If Archive before rollback is selected) Continue the rollback even if the selected files are not successfully backed up to the database.</td>
<td></td>
</tr>
<tr>
<td>Rollback</td>
<td>Rollback Database Configuration</td>
<td>Begin the rollback operation for database configuration files.</td>
</tr>
<tr>
<td>Schedule</td>
<td>(see web GUI)</td>
<td>Specify whether to perform the rollback immediately or at a later scheduled time.</td>
</tr>
</tbody>
</table>

### Step 6
Click Submit.

### Step 7

---

## Export Configuration Files to a Local File System

You can export running configuration files and startup configuration files.

### Note
For Cisco NCS 2000 devices, you can export database configurations as binary files to a file system on your local machine. With Cisco NCS 4000 devices, you can export database configurations as .tgz files. When you export it, your browser will prompt you to save or open the file.

### Step 1
Choose Inventory > Device Management > Configuration Archive.

### Step 2
Under the Devices tab, locate the device with the archive you want to export, and click its device name hyperlink.

### Step 3
Locate the configuration version you want to export and expand it.

### Step 4
Under the Configuration Type column, click the hyperlink for the file you want to export (Running Configuration or, if supported, Startup Configuration, or Database Configuration).
Step 5 In the file viewer page, click Export and save the file to your local machine.

Delete Archived Device Configuration Files

Provided you are a user who has the device configuration rollback privilege, you can complete one of the following procedures to manually delete archived device configuration files from the database.

(Method 1)
1. Choose Inventory > Device Management > Configuration Archive.
   The Configuration Archive page opens with the Devices tab selected.
2. From the Name column, click the link for the device whose configuration files you want to delete.
   Its Archive Details page opens.
3. Click the radio button for the configuration files you want to delete and then click the X (Delete) icon.
4. Click Yes to confirm deletion of the configuration files.

(Method 2)
1. Choose Inventory > Device Management > Configuration Archive.
   The Configuration Archive page opens with the Devices tab selected.
2. Click the Archives tab.
3. Check the check box for the configuration files you want to delete and then click the X (Delete) icon.
4. Click Yes to confirm deletion of the configuration files.

Check the Network Audit for Configuration Archive Operations

To get historical information about device software image changes, check the Network Audit.

Step 1 Choose Inventory > Device Management > Network Audit. To filter the results to show only image management operations, enter archive in the Audit Component field.
Step 2

Expand an event drawer to get details about a device change. For example, if you expand the drawer highlighted in the above figure, given in step 1, you can see that the device’s running configuration file was successfully backed up to the archive at that time.

<table>
<thead>
<tr>
<th>Device Name</th>
<th>IP Address</th>
<th>Audit Time</th>
<th>Audit Component</th>
<th>Audit Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>prime-ass00</td>
<td>209.165.201.1</td>
<td>2015-Jan-23 17:11:29 PST</td>
<td>FM Software Image Management</td>
<td>Image Distribution</td>
</tr>
</tbody>
</table>

For more information on the Network Audit feature, see Audit Configuration Archive and Software Management Changes (Network Audit), on page 799.
Check the Network Audit for Configuration Archive Operations
CHAPTER 5

Manage Device Software Images

- Set Up Software Image Management, on page 111
- Copy Software Images from Devices to the Image Repository (Create a Baseline), on page 115
- How Do I Find Out Which Images Are Used by Network Devices?, on page 115
- How Do I Know a Device Has the Latest Image?, on page 116
- View the Images That Are Saved in the Image Repository, on page 116
- Find Out Which Devices Are Using an Image, on page 117
- View Recommended and Available Software Images from Cisco.com, on page 117
- How Do I Know Whether I have Permission to Download Software from Cisco.com, on page 119
- Add (Import) Software Images to the Repository, on page 119
- Change the Device Requirements for Upgrading a Software Image, on page 122
- Verify That Devices Meet Image Requirements (Upgrade Analysis), on page 122
- Distribute a New Software Image to Devices, on page 123
- Activate a New Software Image on Devices, on page 129
- Activate, Deactivate, and Remove Cisco IOS XR Images from Devices, on page 132
- View and Upgrade FPD Images, on page 132
- Commit Cisco IOS XR Images Across Device Reloads, on page 133
- Roll Back Cisco IOS XR Images, on page 133
- Check the Network Audit for Software Image Operations, on page 134
- Delete Software Image Files from the Image Repository, on page 135

Set Up Software Image Management

- Make Sure Devices Are Configured Correctly, on page 112
- Verify the FTP/TFTP/SFTP/SCP Settings on the Cisco EPN Manager Server, on page 112
- How to Control Images that are Saved to the Image Repository During Inventory Collection, on page 112
- Adjust Criteria for Cisco.com Image Recommendations, on page 113
- Adjust Image Transfer and Distribution Preferences, on page 113
- Change Cisco.com Credentials for Software Image Operations, on page 115

Note

Software Image Management is not supported on Cisco IOS-XR devices configured with a management VRF.
Make Sure Devices Are Configured Correctly

Cisco EPN Manager can transfer files to and from devices only if the SNMP read-write community strings configured on your devices match the strings that were specified when the devices were added to Cisco EPN Manager. In addition, devices must be configured according to the settings in How Is Inventory Collected?, on page 43.

Note
To improve security, Cisco EPN Manager no longer uses some of the SSH CBC (Cipher Block Chaining) ciphers that older Cisco IOS-XE and IOS-XR versions use, as they have been deemed weak. For devices running Cisco IOS-XE, ensure that you upgrade to version 16.5.x or later. And for devices running Cisco IOS-XR, upgrade to version 6.1.2 or later. Otherwise, several Software Image Management operations will fail.

Although we do not recommend doing so (since it weakens security), you also have the option to add the CBC ciphers that Cisco EPN Manager stopped using back to its SSHD service configuration file. To do so, first configure the CBC ciphers in the ciphers line of the file located in the /etc/ssh/sshd_config directory (as shown in the example below), then restart the sshd service using the service sshd stop/start command.

Ciphers aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,cast128-cbc,aes192-cbc,aes256-cbc

Note
Software Image Management is not supported in the NAT environment. This means that image management features such as image import, upgrade, distribution, and activation, will not function in the NAT environment.

Verify the FTP/TFTP/SFTP/SCP Settings on the Cisco EPN Manager Server

If you will be using FTP, TFTP, SFTP, or SCP make sure that it is enabled and properly configured. See Enable FTP/TFTP/SFTP Service on the Server, on page 718.

How to Control Images that are Saved to the Image Repository During Inventory Collection

Because collecting software images can slow the data collection process, by default, Cisco EPN Manager does not collect and store device software images in the image repository when it performs inventory collection. Users with Administration privileges can change that setting using the following procedure.

Step 1 Choose Administration > Settings > System Settings, then choose Inventory > Image Management.
Step 2 To retrieve and store device images in the image repository when Cisco EPN Manager performs inventory collection, check the Collect images along with inventory collection check box.
Step 3 Click Save.
Adjust Criteria for Cisco.com Image Recommendations

You can use Cisco.com to get information about recommended images based on criteria you provide. The following procedure shows how you can adjust those recommendations. The following table also lists the default settings.

Note
To use these features, the device must support image recommendations.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose Administration &gt; Settings &gt; System Settings, then choose Inventory &gt; Image management.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Adjust the recommendation settings as follows.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recommend latest maintenance version of each major release</td>
<td>Only considers images if it is the latest maintenance version of each major release</td>
<td>Disabled</td>
</tr>
<tr>
<td>Recommend same image feature</td>
<td>Only considers images with same feature set as running device image</td>
<td>Disabled</td>
</tr>
<tr>
<td>Recommend versions higher than the current version</td>
<td>Only considers images that are higher than the running device image</td>
<td>Disabled</td>
</tr>
<tr>
<td>Include CCO for recommendation</td>
<td>Retrieves images from Cisco.com and the image repository</td>
<td>Enabled</td>
</tr>
</tbody>
</table>

Step 3 Click Save.

Adjust Image Transfer and Distribution Preferences

Use this procedure to specify the default protocols Cisco EPN Manager should use when transferring images from the software image management server to devices. You can also configure Cisco EPN Manager to perform, by default, a variety of tasks associated with image transfers and distributions—for example, whether to back up the current image before an upgrade, reboot the device after the upgrade, continue to the next device if a serial upgrade fails, and so forth. Users with Administration privileges can change that setting using the following procedure.

This procedure only sets the defaults. You can override these defaults when you perform the actual distribute operation.

Step 1 Choose Administration > Settings > System Settings, then choose Inventory > Image Management.

Step 2 Specify the default protocol Cisco EPN Manager should use when transferring images in the Image Transfer Protocol Order. Arrange the protocols in order of preference. If the first protocol listed fails, Cisco EPN Manager will use the next protocol in the list.
When distributing an image to a device, use the most secure protocols supported by the device (for example, SCP instead of TFTP). TFTP tends to time out when transferring very large files or when the server and client are geographically distant from each other. If you choose SCP for the image distribution, ensure that the device is managed in Cisco EPN Manager with full user privilege (Privileged EXEC mode); otherwise the distribution will fail due to copy privilege error (SCP: protocol error: Privilege denied).

**Step 3** Specify the default protocol Cisco EPN Manager should use when configuring images on devices in the Image Config Protocol Order area. Arrange the protocols in order of preference.

**Step 4** Specify the tasks that Cisco EPN Manager should perform when distributing images:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Continue distribution on failure</td>
<td>If distributing images to multiple devices and distribution to a device fails, continues the distribution to other devices</td>
<td>Enabled</td>
</tr>
<tr>
<td>TFTP fallback</td>
<td>Inserts the TFTP fallback command into the running image so that it can be reloaded if image distribution fails</td>
<td>Disabled</td>
</tr>
<tr>
<td></td>
<td>Inserts the TFTP fallback command into the running image so that it can be reloaded if image distribution fails</td>
<td></td>
</tr>
<tr>
<td>Backup current image</td>
<td>Before image distribution, backs up the running image to the TFTP server</td>
<td>Disabled</td>
</tr>
<tr>
<td>Insert boot command</td>
<td>After image distribution, inserts the boot command into the running image</td>
<td>Disabled</td>
</tr>
<tr>
<td></td>
<td>Inserts the boot command into the running image, after image distribution</td>
<td></td>
</tr>
</tbody>
</table>

**Step 5** Click Save.

---

**Add a Software Image Management Server to Manage Groups of Devices**

To distribute images to a group of devices, add a software image management server and specify the protocol it should use for image distribution. You can add a maximum of three servers.

**Step 1** Add the server.

a) Choose Administration > Servers > Software Image Management Servers.

b) Click the Add Row icon and enter the server name, IP address, and device group the server will support.

c) Click Save.

**Step 2** Configure the server protocol settings.

a) Check the check box next to the server name, then click Manage Protocols.

b) Click the Add Row icon and enter the software image management protocol details (username, password, and so forth).

c) Click Save.
Change Cisco.com Credentials for Software Image Operations

When Cisco EPN Manager connects to Cisco.com to perform software image management operations (for example, to check image recommendations), it uses the credentials stored in the Account Settings page. You can change those settings using the following procedure.

**Step 1** Choose Administration > Settings > System Settings, then choose General > Account Settings.

**Step 2** Click the Cisco.com Credentials tab.

**Step 3** Change the settings, then click Save.

Copy Software Images from Devices to the Image Repository (Create a Baseline)

Depending on your system settings, Cisco EPN Manager may copy device software images to the image repository during inventory collection (see How to Control Images that are Saved to the Image Repository During Inventory Collection, on page 112). If you need to perform this operation manually, use the following procedure, which imports software images directly from devices into the image repository.

Before you begin, ensure that images are physically present on the devices (rather than remotely loaded).

**Note** If you are importing many images, perform this operation at a time that is least likely to impact production.

**Step 1** Choose Inventory > Device Management > Software Images.

**Step 2** Click the Add/Import icon.

**Step 3** In the Import Images dialog box, complete the following:

a) In the Source area, select the devices (you may want to select one device group at a time).

b) In the Collection Options area, specify whether to import the files immediately or schedule the import for later.

**Step 4** Click Submit.

How Do I Find Out Which Images Are Used by Network Devices?

To view a list of the images used by network devices, choose Reports > Reports Launch Pad > Device > Detailed Software.

To list the top ten images use by network devices (and how many devices are using those images), choose Inventory > Device Management > Software Images. Click Software Image Repository under Useful Links, then then click the Image Dashboard icon in the top-right corner of the page.
How Do I Know a Device Has the Latest Image?

If your device type supports image recommendations, you can use the following procedure to check if a device has the latest image from Cisco.com. Otherwise, use the Cisco.com product support pages to get this information.

**Step 1**
Choose **Inventory > Device Management > Network Devices**, then click the device name hyperlink to open the Device Details page.

**Step 2**
Click the **Software Image** tab and scroll down to the Recommended Images area. Cisco EPN Manager lists all of the images from Cisco.com that are recommended for the device.

For Cisco NCS 2000 and Cisco ONS devices, this choice is displayed on the right when you click the **Chassis View** tab.

**Note**
The recommendations list is purely informational. To use any of the recommended images, you must get them from Cisco.com and add them to the image repository. See Add (Import) Software Images to the Repository, on page 119.

View the Images That Are Saved in the Image Repository

Use this procedure to list all of the software images saved in the image repository. The images are organized by image type and stored in the corresponding software image group folder.

**Step 1**
Choose **Inventory > Device Management > Software Images**. Cisco EPN Manager lists the images that are saved in the image repository within the **Software Image Summary** panel.

From here you can:

- Import new images into the image repository from network devices; file systems on client machines, IPv4 or IPv6 servers (URLs), FTP servers, and Cisco.com. You can use the web GUI to find out what images are available from Cisco.com, but images must be manually downloaded and then imported. See Add (Import) Software Images to the Repository, on page 119.

- Adjust the requirements that a device must meet in order to upgrade to this image. See Change the Device Requirements for Upgrading a Software Image, on page 122.

- Perform an upgrade analysis. See Verify That Devices Meet Image Requirements (Upgrade Analysis), on page 122.

- Copy new software images to devices. See Distribute a New Software Image to Devices, on page 123.

- Activate images, which makes a new image the device’s running image. See Activate a New Software Image on Devices, on page 129.

- Commit Cisco IOS XR images, which persists the image across device reloads and creates a rollback point. See Commit Cisco IOS XR Images Across Device Reloads, on page 133.

- Delete images from the image repository (images can only be deleted using the manual process). See Delete Software Image Files from the Image Repository, on page 135.
Find Out Which Devices Are Using an Image

Step 1 Choose Inventory > Device Management > Software Images.

Step 2 In the Software Image Summary panel, locate the image that you are interested in by expanding the image categories in the navigation area or entering partial text in one of the Quick Filter fields. For example, entering 3.1 in the Version field would list Versions 3.12.02S, 3.13.01S, and so forth.

Step 3 Click the image hyperlink to open the Software Image Summary page. Cisco EPN Manager lists all devices using that image in the Device Details area.

View Recommended and Available Software Images from Cisco.com

- View Recommended Images on Cisco.com, on page 117
- View Available Images on Cisco.com, on page 118

View Recommended Images on Cisco.com

If your devices support Cisco.com image recommendations, you can use this procedure to check which images your devices should be using.

Step 1 Choose Inventory > Device Management > Software Images.

Step 2 Click Software Image Repository under Useful Links.

Step 3 Navigate to and select the software image for which you want to change requirements.

Step 4 Choose the devices which you want to distribute the image from the Device List drop-down list and click Distribution New Version.

Step 5 Choose one of the following image sources:

- Recommend Image from Cisco.com to select an image available on Cisco.com. Specify options, click Start Recommendation, then skip ahead to Step 5.
Cisco EPN Manager displays recommended software images for your specific device types, but it does not allow you to download software images directly from cisco.com. You must manually download software images and then import the downloaded image file.

- **Select Image from Local Repository** to select an image stored locally. Then, under Local Repository:
  - Check the **Show All Images** check box to display all images available in the image repository.
  - Uncheck the **Show All Images** check box to display the software images applicable to the selected device.

**Step 6** Select the image to distribute, then click **Apply**.

**Step 7** Choose the image name in the Distribute Image Name field to change your selection and pick a new image, then click **Save**.

**Step 8** Specify Distribution Options. You can change the default options in **Administration > System Settings > Inventory > Image Management**.

**Step 9** Specify schedule options, then click **Submit**.

---

**View Available Images on Cisco.com**

Depending on your device type, Cisco EPN Manager can narrow the list of available images by maintenance versions, feature sets, versions, and so forth (see Adjust Criteria for Cisco.com Image Recommendations, on page 113).

Cisco EPN Manager will use the Cisco.com credentials that are set by the administrator. If default credentials are not set, you must enter valid credentials. (See Change Cisco.com Credentials for Software Image Operations, on page 115).

**Step 1** Choose **Inventory > Device Management > Software Images**.

**Step 2** Click the **Add/Import** tab.

**Note** Although you cannot use Cisco EPN Manager to download images directly from Cisco.com and import them into the Cisco EPN Manager server, you can use the Add/Import function to check Cisco.com for available software images. Then you can manually download the images and import them into the image repository.

**Step 3** In the Import Images dialog:
  a) Click **Cisco.com**.
  b) If the credentials are not auto-populated, enter a valid Cisco.com user name and password.
  c) Choose a device platform and software version from the drop-down lists. The remaining choices (for example, feature type) depend on the device platform and operating system you have chosen.

**Step 4** Perform a manual download of the images by going to the Cisco.com **Software Download** site. Enter your credentials and follow the instructions.

**Step 5** Import the newly-downloaded images into the image repository using the procedure in **Add a Software Image from a Client Machine File System, on page 121**.

**Step 6** Verify that the images are listed on the Software Images page (**Inventory > Device Management > Software Images**).
How Do I Know Whether I have Permission to Download Software from Cisco.com

Cisco EPN Manager displays the recommended latest software images for the device type you specify, and it allows you to download the software images directly from Cisco.com. In order to download a EULA or K9 software image from Cisco.com, you must accept/renew the EULA agreement or K9 Agreement periodically.

Cisco EPN Manager does not display deferred software images. For detailed information, see the Cisco EPN Manager 2.1 Supported Devices list.

Add (Import) Software Images to the Repository

Cisco EPN Manager displays the recommended latest software images for the device type you specify, and it allows you to download the software images directly from cisco.com. Cisco EPN Manager does not display deferred software images. For detailed information, see Cisco EPN Manager 2.1 Supported Devices list.

In order to download a K9 software image from cisco.com, you must accept/renew the https://software.cisco.com/download/eula.html K9 agreement periodically.

The following topics explain the different ways you can add software images to the image repository. For an example of how to troubleshoot a failed import, see Manage Jobs Using the Jobs Dashboard, on page 26.

- Add a Software Image That Is Running on a Managed Device, on page 119
- Add a Software Image from an IPv4 or IPv6 Server (URL), on page 120
- Add a Software Image for an FTP Protocol Server (Protocol), on page 121
- Add a Software Image from a Client Machine File System, on page 121

For Cisco NCS and Cisco ONS devices, you can only import software images using the procedure in Add a Software Image from a Client Machine File System, on page 121.

Add a Software Image That Is Running on a Managed Device

This method retrieves a software image from a managed device and saves it in the image repository.
When distributing an image to a device, use the most secure protocols supported by the device (for example, SCP instead of TFTP). TFTP tends to time out when transferring very large files or when the server and client are geographically distant from each other. If you choose SCP for the image distribution, ensure that the device is managed in Cisco EPN Manager with full user privilege (Privileged EXEC mode); otherwise, the distribution will fail due to copy privilege error (SCP: protocol error: Privilege denied).

Note that TFTP is supported only when copying images from the device to the server and not the other way around.

Limitations:

- For Cisco IOS-XR devices, direct import of images from the device is not supported by Cisco EPN Manager; SMU and PIE imports are also not supported on these devices.
- For Cisco IOS-XE devices, if the device is loaded with the ‘packages.conf’ file, then images cannot be imported directly from that device.

---

### Add a Software Image from an IPv4 or IPv6 Server (URL)

You can import software image from network-accessible IPv4 or IPv6 servers. The following file formats are supported: .bin, .tar, .aes, .pie, .mini, .vm, .gz, .ova, and .ros.

The file that you import must follow the recommended file naming convention. For example, the naming convention for .tar files is `image family-*`-image version.tar. Here, the image family must be in capital case. Based on the naming convention, the name for the NCS540.tar file must be `NCS540-iosxr-k9-6.0.2.tar`.

Cisco EPN Manager supports to import Non-Cisco standard image.

---

**Step 1** Choose **Inventory > Device Management > Software Images**.

**Step 2** Click the **Add/Import** icon.

**Step 3** In the Import Images dialog:

a) Click **Device** and under Collection Options, choose one or more devices.
b) In the Schedule area, schedule the job to run immediately, at a later time, or on a regular basis.
c) Click **Submit**.

**Step 4** To view the status of the job, click the job link in the pop-up message or choose **Administration > Job Dashboard**.

**Step 5** Verify that the image is listed on the Software Images page (**Inventory > Device Management > Software Images**).
Add a Software Image for an FTP Protocol Server (Protocol)

Step 1 Choose Inventory > Device Management > Software Images.
Step 2 Click the Add/Import icon.
Step 3 In the Import Images dialog:
   a) Click Protocol.
   b) Enter FTP in the Protocol field, then enter the FTP user name, password, server name or IP address, and file name. The following is a file name example:
      /ftpfolder/asr901-universalk9-mz.154-3.S4.bin
   c) In the Schedule area, schedule the job to run immediately, at a later time, or on a regular basis.
   d) Click Submit.
Step 4 To view the status of the job, click the job link in the pop-up message or choose Administration > Job Dashboard.
Step 5 Verify that the image is listed on the Software Images page (Inventory > Device Management > Software Images).

Add a Software Image from a Client Machine File System

Before you begin

When you import the software image file, the browser session is blocked temporarily. If the upload operation exceeds the idle timeout limit of the browser session, then you will be logged out of Cisco EPN Manager and the file import operation will be aborted. So it is recommended that you increase the idle timeout limit before you begin with this import operation. To increase the idle timeout, see Configure the Global Timeout for Idle Users, on page 757.

Step 1 Choose Inventory > Device Management > Software Images.
Step 2 Click the Add/Import icon.
Step 3 In the Import Images dialog:
   a) Click File.
   b) Click the Browse button and navigate to the software image file.
   c) In the Schedule area, schedule the job to run immediately, at a later time, or on a regular basis.
   d) Click Submit.
Step 4 To view the status of the job, click the job link in the pop-up message or choose Administration > Job Dashboard.
Step 5 Verify that the image is listed on the Software Images page (Inventory > Device Management > Software Images).

Change the Device Requirements for Upgrading a Software Image

Use this procedure to change the RAM, flash, and boot ROM requirements that a device must meet for a software image to be distributed to the device. These values are checked when you perform an upgrade analysis (see Verify That Devices Meet Image Requirements (Upgrade Analysis), on page 122).

Note This operation is not supported on the Cisco NCS 2000 and Cisco ONS families of devices.

Step 1 Choose Inventory > Device Management > Software Images.
Step 2 In the Software Image Summary panel, locate and select the software image by clicking its associated hyperlink.
Step 3 Click the software image name hyperlink to open its image information.
Step 4 Adjust the device requirements:
   • Minimum RAM (from 1 – 999999999999999)
   • Minimum FLASH (from 1 – 999999999999999)
   • Minimum Boot ROM Version
Step 5 Click Save.
Step 6 Click Restore Defaults, if you want to retain the previous requirements.

Verify That Devices Meet Image Requirements (Upgrade Analysis)

An upgrade analysis verifies that the device contains sufficient RAM or FLASH storage (depending on the device type), the image is compatible with the device family, and the software version is compatible with the image version running on the device. After the analysis, Cisco EPN Manager displays a report that provides the results by device. The report data is gathered from:

• The software image repository, which contains information about minimum RAM, minimum Flash, and so on, in the image header.
• The Cisco EPN Manager inventory, which contains information about the active images on the device, as well as Flash memory, modules, and processor details.
Upgrade analysis is supported on all Cisco IOS-XR devices (such as Cisco NCS 1000, Cisco NCS 4000, Cisco NCS 5000, Cisco NCS 5500, and Cisco NCS 6000), except on Cisco ASR 9000 devices.

If you want to adjust the device requirements for an image, see Change the Device Requirements for Upgrading a Software Image, on page 122.

---

**Step 1** Choose **Inventory > Device Management > Software Images**.

**Step 2** Click **Upgrade Analysis** under **Useful Links**. (Do not select an image from the Software Images page.)

**Step 3** In the Upgrade Analysis dialog:

   a) Choose the source for the software images (the image repository or Cisco.com).
   b) Select the devices you want to analyze.
   c) Select the software images you want to analyze the devices against.
   d) Click **Run Report**.

The report groups devices by their IP address.

---

**Distribute a New Software Image to Devices**

The image distribution operation copies a new software image to a specified location on a device. You can distribute images for similar devices in a single deployment, adjusting your choices per device. When you create the job, you determine whether the job runs immediately or at a scheduled time.

---

**Note**

Cisco EPN Manager does not support using TFTP to distribute images from a server to devices.

When you select an image to be distributed, Cisco EPN Manager only displays devices that are suitable for the image. When you create the distribution job, you specify whether Cisco EPN Manager should:

- Activate the image in the same job or skip the activation. Delaying the activation lets you perform these tasks before activating the image:
  - Find out if there is insufficient memory, clear the disk space for distributing the image or package.
  - Do an upgrade analysis to check the suitability of the device for the chosen image.

- (Cisco IOS XR only) Commit the image in the same job or skip the commit.

**Limitations:**

- When you distribute image to Cisco IOS-XR devices (except Cisco ASR 9000 devices), the image is copied to the device storage before the install package is activated and committed. With Cisco ASR 9000 devices, however, the image is install-added on the device directly from Cisco EPN Manager without being copied to the device storage. This will reduce the space consumed by the images on the devices. Use the following command to move the image to inactive state instead of copying the image to the device storage:
install add protocol://image path/image name

- For Cisco ASR 9000 devices, only up to 16 device-package pairs can be activated at the same time. Also, the activation of the .tar images must contain the same maximum number of packages.

- During the distribution process, if the protocols used for distribution are not supported by the device, then distribution might fail. For example, if you use the SCP protocol to distribute an image to Cisco ASR 9000 devices, then the distribution fails, because copy of the image onto the device storage is not supported in the device's command line.

The image can be distributed to any file system on the device, including folders in the root directory. This is supported only for NCS 42XX, NCS520 (IOS-XE) and ASR907 devices. If you choose a file system that has a stand by flash, then the image is distributed to both the active flash and the stand by flash. This means that when you choose to distribute the image to active flash, you are not required to re-distribute the image to the stand by flash.

Note
The option to distribute an image directly to a device folder is supported only on Cisco ASR907 and Cisco NCS42xx devices.

Cisco EPN Manager displays feedback and status as the operation proceeds. If you are distributing an image to many devices, you can stagger reboots so that service at a site is not completely down during the upgrade window. For image distribution to work efficiently, the device and server from which the distribution is performed must be in the same geographical location or site. The distribution job will return an error if the distribution takes more time due to network slowness or low speed.

Note
When distributing an image to a device, use the most secure protocols supported by the device (for example, SCP instead of TFTP). TFTP tends to time out when transferring very large files or when the server and client are geographically distant from each other. If you choose SCP protocol for the image distribution, ensure that the device is managed in Cisco EPN Manager with full user privilege (Privileged EXEC mode); otherwise the distribution will fail due to copy privilege error (SCP: protocol error: Privilege denied).

Before You Begin
- When distributing an image to a device, use the most secure protocols supported by the device (for example, SCP instead of TFTP). TFTP tends to time out when transferring very large files or when the server and client are geographically distant from each other. If you choose SCP protocol for the image distribution, ensure that the device is managed in Cisco EPN Manager with full user privilege (Privileged EXEC mode); otherwise the distribution will fail due to copy privilege error (SCP: protocol error: Privilege denied).

- When distributing images to Cisco ME 1200 devices, you will need to activate the image on the device immediately after distribution. Ensure that the device is ready for an image activation.

Step 1
Choose Inventory > Device Management > Software Images.

Step 2
Click the blue Distribute icon in the Software Image Management Lifecycle widget. Cisco EPN Manager displays the devices that are appropriate for the images. You can configure the image for each device when you create a distribution job.
Note  If the required device is not listed here, ensure that the Image Family associated with the file is same as the selected device's family. To verify the device family, type, version, size use the Image tab in the Device Details page.

Step 3  From the Image Selection tab, select the image that you want to distribute on devices.

Note  View the Image family, type, version, and size details for the selected image.

Step 4  From the Device Selection tab, select the devices for image distribution. You can further adjust the distribution settings for each device.

a) In the Image Deployment tab, Cisco EPN Manager displays one row per device and image.

b) For each device, check the location where the image will be copied. Cisco EPN Manager chooses the location based on its memory calculations.

Note  Locations are not supplied for the Cisco NCS 2000 and Cisco ONS families of devices.

To change the location, double-click the location value in the Distribute Image field and choose another location from the drop-down list.

After you click Save, Cisco EPN Manager calculates whether that location has adequate space for the image. If there is enough space, Cisco EPN Manager displays a green check mark (after you click Save). Otherwise you must choose another location, or select the Smart Flash Delete Before Distribution option in step 5. Note that running images are not deleted from the device.

The following is an example of a network audit event that is generated during image distribution.

```
406 / ... / Device Management / Network Audit
```

<table>
<thead>
<tr>
<th>Device Name</th>
<th>IP Address</th>
<th>Audit Time</th>
<th>Audit Component</th>
<th>Audit Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>prime-as500</td>
<td>209.166.201.1</td>
<td>2015-01-23 17:11:29 PST</td>
<td>IFM Software Image Management</td>
<td>Image Distribution</td>
</tr>
</tbody>
</table>

Step 5  From the Image Details Verification tab, select the file system on the device where the image must be distributed using the Distribute Location drop-down menu. This field displays the folders available on the device. To distribute the image to new folders, create the folder on the device manually, and return to this step. Alternatively, you can create a new folder during the distribution process automatically by choosing the 'swim_configuration.xml' file under '/opt/CSCOldomos/swim' and providing any new folder name of your choice. The folder is automatically created under this directory. The Verification State field displays the status of the software chosen. Based on the status (Success or Failure) you can decide on the compatibility state of the device chosen. For example, if the state is success then there is enough space to proceed with the distribution of an image.

Step 6  Configure the distribution settings.

In the Image Deployment tab area, configure the behavior for the distribution job—for example, in a bulk distribution job, whether to continue the distribution if it fails on a device. (The preferences are populated according to defaults set by the administrator. For more information, see Adjust Image Transfer and Distribution Preferences, on page 113).

Image Deployment Options:
• **Smart Flash Delete Before Distribution** - Delete any file (other than the running image) to recover disk space in case the device has insufficient memory (additional image files are deleted until adequate space is available in the selected flash).

• **Continue distribution on Failure** - Continue the distribution even if it fails on a device.

• **TFTP Fallback** - Reload an image if the distribution fails by inserting the TFTP failback command into the running image.

• **Insert Boot Command** - Insert the boot command into the running image after the image is distributed.

• **ISSU** - Activate In-Service Software Upgrade (ISSU) to update the software on the device with minimal service interruption.

• **Upgrade FPD Image** - Field Programmable Devices (FPDs) are hardware devices implemented on router cards that support separate software upgrades. Select this option to automatically choose FPD image packages for the upgrade during image distribution and activation processes. Additional features include:
  - Smart Flash Delete Before Distribution
  - Parallel Distribution
  - Continue distribution on failure

• **Interface Module Delay** - Adjusts the delay between the Online Insertion and Removal (OIR) of each Interface Module (IM).

• **Erase Running Image** - Erases the device's running image.

• **Distribute via VRF** - Check the Add Distribute via VRF checkbox to distribute images through VRF.
  - VRF Name - Enter an appropriate VPN routing and forwarding (VRF) name to be used during distribution of an image and for the file transfer.

  **Note**  This field is available only when the "Distribute via VRF" checkbox is enabled.

### Table 11: Support for Image Deployment options

<table>
<thead>
<tr>
<th>Devices</th>
<th>Smart Flash Delete Before Distribution</th>
<th>Continue distribution on Failure</th>
<th>TFTP Fallback</th>
<th>Insert Boot Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco IOS (ASR 901)</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
</tr>
<tr>
<td>Cisco IOS-XE (ASR 903/920)</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
</tr>
<tr>
<td>Cisco IOS XE (NCS 4200 / ASR 907)</td>
<td>Y</td>
<td>Y</td>
<td>-</td>
<td>Y</td>
</tr>
<tr>
<td>Cisco Nexus</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
</tr>
<tr>
<td>Cisco IOS (ME36X / ME38X)</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
</tr>
</tbody>
</table>
## Manage the Inventory

### Distribute a New Software Image to Devices

<table>
<thead>
<tr>
<th>Devices</th>
<th>Smart Flash Delete Before Distribution</th>
<th>Continue distribution on Failure</th>
<th>TFTP Fallback</th>
<th>Insert Boot Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco IOS-XR</td>
<td>Y (for Cisco ASR 9000 Devices, the .tar images with version lesser than the running image will be deleted)</td>
<td>Y</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Cisco NCS 2000 and Cisco ONS 15454</td>
<td>-</td>
<td>Y</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Cisco NCS 4000</td>
<td>Y</td>
<td>Y</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Cisco NCS 1000</td>
<td>Y</td>
<td>Y</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Cisco NCS 6000</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

**Table 12: Support for Image Deployment options**

<table>
<thead>
<tr>
<th>Devices</th>
<th>ISSU</th>
<th>Upgrade FPD Image</th>
<th>Interface Module Delay</th>
<th>Erase Running Image</th>
<th>Distribute via VRF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco IOS (ASR 901)</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>Y</td>
</tr>
<tr>
<td>Cisco IOS-XE (ASR 903/920)</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>Y</td>
</tr>
<tr>
<td>Cisco IOS XE (NCS 4200 / ASR 907)</td>
<td>Y (only if device is in 'Install' mode)</td>
<td>-</td>
<td>Y (only if ISSU is available)</td>
<td>-</td>
<td>Y</td>
</tr>
<tr>
<td>Cisco Nexus</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Cisco IOS (ME36X / ME38X)</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>Y</td>
<td>-</td>
</tr>
<tr>
<td>Cisco IOS-XR</td>
<td>Y</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Cisco NCS 2000 and Cisco ONS 15454</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Cisco NCS 4000</td>
<td>Y</td>
<td>Y</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Cisco NCS 1000</td>
<td>-</td>
<td>Y</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Cisco NCS 6000</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

**Step 7**

In the **Activate Job Options** window, choose the required settings:

- **Activate Options**: Sequential or Parallel
- **Continue on failure**: Continue the distribution even if it fails on a device.
- **Commit**: Commit the image on the device post distribution.
• FPDs Upgrade: Field Programmable Devices (FPDs) are hardware devices implemented on router cards that support separate software upgrades. If you enable this option, FPD image packages will be used for the upgrade.

**Step 8** Configure the image activation settings.

<table>
<thead>
<tr>
<th>Device OS</th>
<th>Settings</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco IOS and Cisco IOS XE</td>
<td>Check <strong>Insert Boot Command</strong> if you want the image to be activated when the device reloads, and:</td>
<td>If you choose to perform an ISSU upgrade, choose OFF from the drop-down list. This option is only applicable to some Cisco IOS XE devices such as Cisco NCS42xx.</td>
</tr>
<tr>
<td></td>
<td>• If you <em>do</em> want to reload the device at the end of the operation (and activate the image)—choose <strong>Sequentially</strong>, or <strong>Parallelly</strong> from the drop-down list. This option is not available for Cisco IOS XE devices.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• If you <em>do not</em> want to reload the device at the end of the operation—Choose <strong>OFF</strong> from the drop-down list.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If you did not check Insert Boot Command but you want to activate the image, choose <strong>Sequentially</strong>, or <strong>Parallelly</strong>.</td>
<td></td>
</tr>
<tr>
<td>Cisco IOS XR, Cisco NCS 2000 and</td>
<td>• If you <em>do</em> want to activate or reload the image, choose either <strong>Sequentially</strong>, or <strong>Parallelly</strong> from the drop-down list.</td>
<td>If you choose to perform an ISSU upgrade, choose OFF from the drop-down list. This option is applicable to all Cisco IOS XR devices.</td>
</tr>
<tr>
<td>Cisco ONS</td>
<td>• If you <em>do not</em> want to activate the image, choose <strong>OFF</strong> from the drop-down list.</td>
<td>If you choose OFF from the drop-down list, the <strong>Only image downgrade</strong> option is disabled. This option is applicable to all Cisco NCS 2000 devices.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td>If you choose OFF from the drop-down list, the <strong>Only image downgrade</strong> option is disabled. This option is applicable to all Cisco NCS 2000 devices.</td>
<td></td>
</tr>
</tbody>
</table>

The activation options are sometimes hidden because the ability to activate images during the distribution process has been disabled in the Admin settings. To activate images, please return to **Inventory > Device Management > Software Images** and click the **Activate** icon.

**Step 9** (Cisco IOS XR devices) Configure the image commit settings. To commit the image in this job, check **Commit**. If you want to commit the image later, do not check **Commit** and then use the procedure in **Commit Cisco IOS XR Images Across Device Reloads**, on page 133.

**Step 10** In the Schedule Distribution area, schedule the job to run immediately, at a later time, or on a regular basis.

**Step 11** Click **Submit**.

**Step 12** Choose **Administration > Job Dashboard** to view details about the image distribution job.

**Note** If the copy task takes longer than two hours, verify your connection speed from Cisco EPN Manager to the selected device.
What to do next
If you encounter the following image distribution error, please configure the device with the commands listed and try again:

**Problem:** You encounter the error- 'ssh connections not permitted from this terminal'.

**Cause:** Device is configured incorrectly.

**Solution:** Configure the device with the following commands

```bash
line vty 0 <number available in the device>
  transport input ssh
  transport output ssh

<number available in the device> - represents the unique identifier that varies from 15 to over 100 depending on the IOS version running on the device.
```

>Note

These commands are not supported on Cisco IOS-XR devices.

---

**Activate a New Software Image on Devices**

>Note

To activate Cisco IOS XR images, you can use this procedure or the procedure in [*Activate, Deactivate, and Remove Cisco IOS XR Images from Devices*, on page 132](#) (which performs the deactivate operation on single devices).

When a new image is activated on a device, it becomes the running image on the disk. Deactivated images are not removed when a new image is activated; you must manually delete the image from the device.

If you want to distribute and activate an image in the same job, see [*Distribute a New Software Image to Devices*, on page 123](#).

To activate an image without distributing a new image to a device — for example, when the device has the image you want to activate—use the following procedure. The activation uses the distribution operation but does not distribute a new image.

**Before you begin**

- Before activating or reverting images on Cisco NCS 2000 devices, ensure that you disable all suppressed alarms on the device.

- If you choose the **ISSU** option to activate an image in Bundle Mode, you can verify if the device is currently in bundle mode by running this command `show version | in image` to check if the image is of the format '.bin'. You can also check the format of the image by looking at the filename of the image in the **Image** tab of the Device Details view.

- During activation using the ISSU option, if the device is in subpackage mode, for example, if the image is of the format 'bootflash:ISSU/packages.conf', ensure that you use the same folder to activate the image.
Step 1  Choose **Inventory > Device Management > Software Images**.

Step 2  Click the **Activate** icon in the Software Image Management Lifecycle widget.

Step 3  **Note** You cannot perform the activation operation when the standby version is lower than the active version.

In the **Activation Source** tab, choose **Activate from Library** or **Activate from Completed Distribution Jobs** or **Activate from Standby/Alternate Images** as required.

Step 4  If you choose Activate from Completed Distribution Jobs, click the **Activate Job Options** tab.

Step 5  In the **Activate Job Options** window, choose the required settings and go to Step 10:

- **Activate Options**: Off, Sequential or Parallel
- **Continue on failure**: Continue the activation even if it fails on a device.
- **Commit**: Commit the image on the device post distribution.
- **Insert boot command**: Inserts the boot command into the running image after the image is distributed. This is a pre-requisite for activating devices with the ISSU option.
- **Activate Options**: Sequential or Parallel
- **Continue on failure**: Continue the distribution even if it fails on a device.
- **Commit**: Commit the image on the device post distribution.
- **FPDs Upgrade**: Field Programmable Devices (FPDs) are hardware devices implemented on router cards that support separate software upgrades. If you enable this option, FPD image packages will be used for the upgrade.

- **ISSU options**:
  - **Device Upgrade Mode**: Your options are:
    - **Bundle Mode**: If you choose the ISSU option to activate an image, choose the Bundle Mode to use a monolithic Cisco IOS image to boot. This ensures that the boot variable of the device pointing to a .bin file gets the device running in the Bundle mode. If you choose this option, you must reload the device after activation. To verify if the device is in bundle mode, run this command `show version | in image` to check if the image is of the format '.bin'. You can also check the format of the image by looking at the filename of the image in the **Image** tab of the Device Details view.
    - **Install Mode**: During activation using the ISSU option, use this option if the device is in the subpackage mode, for example, if the image is of the format `bootflash:ISSU/packages.conf`, the device is run in the Install mode. Ensure that you use the same folder to activate the image. Changing the folder location will cause a failure of the activate operation. If you choose the Install Mode for a device which is already running in the Image Mode, the device is activate without reloading (ISSU) and the boot image continues to point to the packages.conf file. In all other scenarios, the devices are reloading.
    - **Currently Exists**: If you want the device to be activated in the same mode that it is currently operating in (Install or Bundle), choose this option to activate the image using the same mode.
- **Interface Module Delay**: The time (in seconds) specified in this option adjusts the delay between the Online Insertion and Removal (OIR) of each Interface Module (IM). This option is enabled only when the Insert boot command and the ISSU options are enabled, and when a supported device is selected. It is recommended to set the value of the delay to 1200 seconds or more to ensure sufficient time for the upgrade.
Manage the Inventory

Activate a New Software Image on Devices

---

Step 6  If you choose Activate from Library in the Activation Source tab, then click the **Image Selection** tab.

Step 7  If you choose Activate from Standby Image, then go to Step 9.

Step 8  In the **Image Selection** tab, choose the software images that you want to distribute.

Step 9  Click the **Device Selection** tab and choose the devices for which the image must be activated.

By default, the devices for which the selected image is applicable are shown. For example, if you choose the **Activate from Standby/Alternate Images** option in Step 3, then the Device Selection tab displays only devices such as, Cisco NCS 2000, Cisco ONS 15454 devices, and Cisco ME1200 devices, which support activation of standby/alternate images.

Step 10  Click the **Activate Image** tab, and verify whether the selected devices and software images are mapped correctly for activation. While using standby images for activation, click the **Verify Image Selection** tab.

**Note**  When you are activating a standby/alternate image, if the version of the standby/alternate image is lower than that of the image running on the device, the Verification Status Message column displays in red that you are downgrading to a lower version.

Step 11  Click the **Activate Job Options** tab, and choose the required Activate Job options.

If you choose the ISSU option from the **Activate** drop-down list, the software image in the device will get upgraded without need for rebooting the device.

While activating a standby image, if the selected device supports a downgrade, then the **Only image downgrade** check box is displayed. Selecting this check box ensures that the devices are downgraded only if they support the downgrade operation (for example in case of Cisco NCS2000 devices) and any specified upgrade operation will fail.

Step 12  Click **Submit** to activate the software image in the selected devices.

See table below for information on Cisco devices and the protocols they support for image distribution:

*Table 13: Cisco Devices and Supported Image Distribution Protocols*

<table>
<thead>
<tr>
<th>Cisco Devices</th>
<th>TFTP</th>
<th>FTP</th>
<th>SCP</th>
<th>SFTP</th>
<th>HTTPS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco ASR1000</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Cisco ASR9000</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Cisco IOS-XR</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>(except Cisco ASR9000 devices)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cisco NCS42xx, Cisco ASR9XX, or Cisco ASR 1000</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Cisco ME1200</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Cisco NCS2000 and Cisco ONS devices</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Activate, Deactivate, and Remove Cisco IOS XR Images from Devices

You can perform activate, deactivate, and delete operations on specific devices from the Device Details page. That view lists all it becomes the running image on the disk.

**Before you begin**

Before activating or reverting images on Cisco NCS 2000 devices, ensure that you disable all suppressed alarms on the device.

**Step 1**
Open the Device Details page and click the **Image** tab.

**Step 2**
Expand the **Applied Images** area to display all of the images that are installed on the device.

- **Active**—Images that devices are actively using.
- **Inactive**—Images that are added to the boot device but are not activated.
- **Available**—Images that are physically present on the device but have not been added to the boot device.

**Step 3**
Identify the image you want to manage, and double-click its Status field. The field changes to an editable row.

**Step 4**
Choose the operation you want to perform from the **Status** drop-down list, then click **Save**. Your options are Active, Deactivate, and Remove.

**Step 5**
Click **Apply** above the images table.

**Step 6**
Choose Administration > Job Dashboard to view details about the image activation job.

---

View and Upgrade FPD Images

Field Programmable Devices (FPDs) are hardware devices implemented on router cards that support separate software upgrades. You can configure FPD image packages to be automatically chosen for the upgrade during image distribution and activation processes. Before performing an upgrade, you can view FPD details such as the device name, card type, hardware version, etc.

To do this:

**Step 1**
Choose Configuration > Network Devices.

**Step 2**
Locate and select the device with the FPD images.

**Step 3**
Click the **Images** tab.

You can now view the FPD device name, location, available card types and their hardware versions, the ATR values, the status of the image, and the running and programmed values.

**Step 4**
Once you have reviewed the FPD image details, click the **Upgrade FPD Image** button, to configure the upgrade settings.

**Step 5**
Schedule the upgrade to run immediately, at a later date and time, or on a regular basis.
Commit Cisco IOS XR Images Across Device Reloads

For Cisco IOS XR devices, we recommend that you do not commit the package change until the device runs with its configuration for a period of time, until you are sure the change is appropriate.

When you commit a Cisco IOS XR package to a device, it persists the package configuration across device reloads. The commit operation also creates a rollback point on the device which can be used for rollback operations.

If you want to distribute, activate, and commit an image in the same job, use the procedure described in Distribute a New Software Image to Devices, on page 123.

To commit an activated image, use the following procedure.

If you are only working on a single device, perform the commit operation from the Device Details page (click the Image tab, choose the image, and click Commit).

Step 1 Choose Inventory > Device Management > Software Images.
Step 2 Click the Commit icon in the Software Image Management Lifecycle widget.
Step 3 Select the devices with the image you want to commit and click Submit. (Images can only be committed if they have been activated.)
Step 4 Select the software image you want to activate, then click Submit.
Step 5 In the Schedule Distribution area, schedule the commit job to run immediately, at a later time, or on a regular basis.
Step 6 Click Submit.
Step 7 Choose Administration > Job Dashboard to view details about the image activation job.

Roll Back Cisco IOS XR Images

Rolling back a Cisco IOS XR image reverts the device image to a previous installation state—specifically, to an installation rollback point. If an image has been removed from a device, all rollback points associated with the package are also removed and it is no longer possible to roll back to that point.

A rollback job can only be performed on one device at a time. You cannot perform a rollback for multiple devices in the same job.
The rollback feature is only supported on Cisco IOS-XR devices such as Cisco ASR 9000 devices.

**Step 1** Choose **Inventory > Device Management > Network Devices**, then click the device name hyperlink for the device with the image you want to roll back.

**Step 2** Click the **Image** tab and expand the Rollback Info area.

**Step 3** Select the software image Commit ID you want to roll back to, and click **Rollback**. The Rollback Scheduler opens.

**Step 4** If you want to commit the image after the rollback operation completes, check **Commit After Rollback**.

**Step 5** In the Schedule Rollback area, schedule the rollback job to run immediately or at a later time, and click **Submit**.

---

**Check the Network Audit for Software Image Operations**

To get historical information about device software image changes, check the Network Audit. For more information on the Network Audit feature, see _Audit Configuration Archive and Software Management Changes (Network Audit)_

**Step 1** Choose **Inventory > Device Management > Network Audit**. To filter the results to show only image management operations, enter **software image** in the Audit Component field.

**Step 2** Expand an event drawer to get details about a device change. For example, if you expand the drawer highlighted in the above figure, you can see that the image listed in the job was successfully distributed to the device.
<table>
<thead>
<tr>
<th>Device/Module ID</th>
<th>544544</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distribution Option</td>
<td>ActivatePatches</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>BackUpCurrentImageFetch</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>CfgXferProtocolOrder</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>Commit</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>DeviceUpgradeMode</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>WaitUponError</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>ISSUUpgrade</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>ImgXferProtocolOrder</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>InsertBootCommand</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>JobDirectory</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>RebootImmediately</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>RebootMode</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>SCPDirectory</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>SkipDistribution</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>TftpDirectory</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>TftpFallback</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>UpgradeMode</td>
</tr>
<tr>
<td>Distribution Option</td>
<td>UseSSH</td>
</tr>
<tr>
<td>Operation</td>
<td>Starting distribution of image to device</td>
</tr>
<tr>
<td>Running Image File Name</td>
<td>asr903rsp1-universalk9_npe.03.13.00.S.154-3.5-ext.bin</td>
</tr>
<tr>
<td>Running Image File Name</td>
<td>asr903rsp1-universalk9_npe.03.13.00.S.154-3.5-ext.bin</td>
</tr>
</tbody>
</table>

## Delete Software Image Files from the Image Repository

Software images can only be manually deleted from the image repository; Cisco EPN Manager does not perform any automatic purging of the image repository. If you have sufficient privileges, you can use the following procedure to delete software image files from the image repository.

**Step 1** Choose **Inventory > Device Management > Software Images**.

**Step 2** From the **Software Images Summary** panel on the left, select the images that you want to delete.

**Step 3** Click **Delete**.
Delete Software Image Files from the Image Repository
How To Perform a Compliance Audit

The following table lists the basic steps for using the Compliance feature.

<table>
<thead>
<tr>
<th>Description</th>
<th>See:</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Create a compliance policy that contains a name and other descriptive text.</td>
<td>Create a New Compliance Policy, on page 139</td>
</tr>
<tr>
<td>2 Add rules to the compliance policy. The rules specify what constitutes a violation.</td>
<td>Create Compliance Policy Rules, on page 139</td>
</tr>
</tbody>
</table>
Create a compliance profile (which you will use to run an audit on network devices) and:

- Add a compliance policy to it.
- Choose the policy rules you want to include in the audit.

You can add multiple custom policies and/or predefined system policies to the same profile.

Run a compliance audit by selecting a profile and scheduling an audit job.

View the results of the compliance audit and if necessary, fix the violations.

### Enable and Disable Compliance Auditing

The Compliance feature uses device configuration baselines and audit policies to find and correct any configuration deviations in network devices. It is disabled by default because some of the compliance reports can impact system performance. To enable the Compliance feature, use the following procedure.

**To use the compliance feature, your system must meet the Professional sizing requirements, as specified in the **Cisco Evolved Programmable Network Manager Installation Guide.**

**Note**

In Cisco EPN Manager version 3.0, disabling compliance auditing disables the compliance from GUI and stops the compliance data collection in the background. User must restart the Cisco EPN Manager server and resync the devices for the compliance settings to be functional.

**Step 1** Choose Administration > Settings > System Settings, then choose General > Server.

**Step 2** Next to Compliance Services, click Enable, then click Save.

**Step 3** Restart the application.

**Step 4** Re-synchronize the device inventory: Choose Inventory > Network Devices, select all devices, then click Sync.

**Note**

If compliance was enabled in Cisco EPN Manager before upgrading to version 3.0, after upgrade the compliance will be disabled in System Settings. User must enable it manually as per the steps mentioned in this section. In this scenario, restarting the Cisco EPN Manager server and resync of devices is not required.
Create a New Compliance Policy

You can create a new compliance policy starting with a blank policy template.

**Step 1** Choose **Configuration > Compliance > Policies**.

**Step 2** Click the Create Compliance Policy (+) icon in the **Compliance Policies** navigation area on the left.

**Step 3** In the dialog box, enter a name and optional description, then click **Create**. The policy is added to the **Compliance Policies** navigation area on the left.

To duplicate the policy click the **i** icon and choose **Duplicate Policy**.

---

**What to do next**

Add rules to the compliance policy. See **Create Compliance Policy Rules**, on page 139.

Create Compliance Policy Rules

Compliance policy rules are platform-specific and define what is considered a device violation. A rule can also contain CLI commands that fix the violation. When you are designing the compliance audit job, you can select the rules you want to include in the audit (see **Run a Compliance Audit**, on page 144).

Cisco EPN Manager supports audit for AireOS Wireless LAN Controllers platform.

**Step 1** Choose **Configuration > Compliance > Policies**, then select a policy from the navigation area on the left.

**Step 2** From the work area pane, click **New** to add a new rule.

If a similar rule exists, you can copy the rule by clicking **Duplicate**, editing the rule, and saving it with a new name.

**Step 3** Configure the new rule by entering your rule criteria.

**Note** Cisco EPN Manager supports all Java-based regular expressions. See [http://www.rexegg.com/regex-quickstart.html](http://www.rexegg.com/regex-quickstart.html).

a) Enter a title, description, and other information in the **Rule Information** text fields. This information is free text and does not impact any of the rule settings.

b) Specify the devices for this rule in the **Platform Selection** area.

c) (Optional) In the **Rule Inputs** area, click **New** and specify the input fields that should be displayed to a user when they run a policy that contains this rule. For example, you could prompt a user for an IP address.

**Note** If you choose the **Accept Multiple Values** check box, the audit will pass only if all the rule inputs match in the condition.

d) In the **Conditions and Actions** area, click **New** and specify the criteria that will be checked. This will determine the rule pass and fail conditions. For example, see **Examples—Rule Conditions and Actions**, on page 140.

**Step 4** Click **Create**. The rule is added to the compliance policy.
You can create as many rules as you want. Remember that when you want to run the audit job, you can pick the rules you want to validate.

What to do next

Create a profile that contains the compliance policy and its rules, and then perform the audit using the profile. See Create a Compliance Profile That Contains Policies and Rules, on page 143.

Examples—Rule Conditions and Actions

- Example Conditions and Actions: DNS Servers Configured on Device, on page 140
- Example: Block Options, on page 140
- Example Conditions and Actions: Community Strings, on page 142
- Example Conditions and Actions: IOS Software Version, on page 142
- Example Conditions and Actions: NTP Server Redundancy, on page 142

Example Conditions and Actions: DNS Servers Configured on Device

This compliance policy checks if either IP name-server 1.2.3.4 or IP name-server 2.3.4.5 is configured on the device. If they are, the policy raises a violation with the message "DNS server must be configured as either 1.2.3.4 or 2.3.4.5."

<table>
<thead>
<tr>
<th>Tab</th>
<th>Tab Area</th>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Condition Details</td>
<td>Condition Scope Details</td>
<td>Condition Scope</td>
<td>Configuration</td>
</tr>
<tr>
<td></td>
<td>Condition Match Criteria</td>
<td>Operator</td>
<td>Matches the expression</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Value</td>
<td>ip name-server {1.2.3.4</td>
</tr>
<tr>
<td>Action Details</td>
<td>Select Match Action</td>
<td>Select Action</td>
<td>Does not raise a violation</td>
</tr>
<tr>
<td></td>
<td>Select Does Not Match Action</td>
<td>Select Action</td>
<td>Raise a violation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Violation Message Type</td>
<td>User Defined Violation Message</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Violation Text</td>
<td>DNS server must be configured as either 1.2.3.4 or 2.3.4.5</td>
</tr>
</tbody>
</table>

Example: Block Options

This compliance policy checks if there are any rogue or unauthorized SNMP community strings are defined in the given blocks. If they are detected in the blocks, the policy raises a violation with the message “Detected unauthorized community string <1.1>” and removes all non-compliant SNMP strings from the blocks.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Tab Area</th>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rule Information</td>
<td>Rule Title</td>
<td>sntp-server community having non-standard entries</td>
<td></td>
</tr>
</tbody>
</table>
### Condition 1

<table>
<thead>
<tr>
<th>Condition Details</th>
<th>Condition Scope Details</th>
<th>Condition Scope</th>
<th>Configuration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Block Options</td>
<td>Block Start Expression</td>
<td>^snmp-server community.*</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(This field will be enabled only when Parse as Blocks checkbox is selected)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Condition Match Criteria</td>
<td>Operator</td>
<td>Matches the expression</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Value</td>
<td>snmp-server community (.* )</td>
<td></td>
</tr>
</tbody>
</table>

**Action Details**
- **Select Match Action**
  - Select Action: Continue
- **Select Does Not Match Action**
  - Select Action: Does Not Raise a Violation

### Condition 2

<table>
<thead>
<tr>
<th>Condition Details</th>
<th>Condition Scope Details</th>
<th>Condition Scope</th>
<th>Previously Matched Blocks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Block Options</td>
<td>Block Start Expression</td>
<td>^snmp-server community.*</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(This field will be enabled only when Parse as Blocks checkbox is selected)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Condition Match Criteria</td>
<td>Operator</td>
<td>Matches the expression</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Value</td>
<td>snmp-server community ((public RO)</td>
<td>(private RW))</td>
</tr>
</tbody>
</table>

**Action Details**
- **Select Match Action**
  - Select Action: Continue
- **Select Does Not Match Action**
  - Select Action: Raise a Violation
  - Violation Message Type: User Defined Violation Message
  - Violation Text: Detected unauthorized community string <1,1>.

---

**Note**

In the above example, the matching criteria will be termed as 1.1, 1.2, and so on, for first condition. For the second condition, the matching criterial will be termed as 2.1, 2.2, and so on.
Example Conditions and Actions: Community Strings

This compliance policy checks if either `snmp-server community public` or `snmp-server community private` is configured on a device (which is undesirable). If it is, the policy raises a violation with the message "Community string xxxxx configured", where xxx is the first violation that was found.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Tab Area</th>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Condition Details</td>
<td>Condition Scope Details</td>
<td>Condition Scope</td>
<td>Configuration</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Operator</td>
<td>Matches the expression</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Value</td>
<td>`snmp-server community {public</td>
</tr>
<tr>
<td>Action Details</td>
<td>Select Match Action</td>
<td>Select Action</td>
<td>Raise a violation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Select Action</td>
<td>Continue</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Violation Message Type</td>
<td>User Defined Violation Message</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Violation Text</td>
<td>Community string xxxxx configured.</td>
</tr>
</tbody>
</table>

Example Conditions and Actions: IOS Software Version

This compliance policy checks if Cisco IOS software version `15.0(2)SE7` is installed on a device. If it is not, the policy raises a violation with the message "Output of show version contains the string xxxxx," where xxx is the Cisco IOS software version that does not match 15.0(2)SE7.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Tab Area</th>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Condition Details</td>
<td>Condition Scope Details</td>
<td>Condition Scope</td>
<td>Device Command Outputs</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Show Commands</td>
<td>show version</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Operator</td>
<td>Contains the string</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Value</td>
<td><code>15.0(2)SE7</code></td>
</tr>
<tr>
<td>Action Details</td>
<td>Select Match Action</td>
<td>Select Action</td>
<td>Continue</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Violation Message Type</td>
<td>User Defined Violation Message</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Violation Text</td>
<td>Output of show version contains the string xxxxx.</td>
</tr>
</tbody>
</table>

Example Conditions and Actions: NTP Server Redundancy

This compliance policy checks if the command `ntp server` appears at least twice on the device. If it does not, the policy raises a violation with the message "At least two NTP servers must be configured."
Create a Compliance Profile That Contains Policies and Rules

A compliance profile contains one or more compliance policies. When you add a compliance policy to a profile, all of the policy's rules are applied to the profile. You can customize the profile by selecting the policy rules you want to include (and ignoring the others). If you group several policies in a profile, you can select and deselect the rules for each policy.

If you login as a Root, Admin or Super User, you will be able to do the following actions:

- Create, edit or delete a profile.
- Select the rules that are created in the Policies page.

"Other" users need to enable the following task permissions to perform the relevant actions:

- **Compliance Audit Profile Access** to run the profile, refresh the profile and browse through the policies in the profile.
- **Compliance Audit Profile Edit Access** to create and edit a compliance audit profile.

The task permissions are located in the Administration > Users > Users, Roles & AAA > User Groups page.

If you do not select the **Compliance Audit Profile Access** task permission, you will not be able to view the Profile page, even if you have selected the **Compliance Audit Profile Edit Access** task permission.

---

### Step 1
Choose **Configuration > Compliance > Profiles**.

### Step 2
Click the Create Policy Profile (+) icon in the **Compliance Profiles** navigation area on the left. This opens the Add Compliance Policies dialog box.

### Step 3
Select the policies you want to include in the profile. User defined policies will be available under the User Defined category.

  a) In the Add Compliance Policies dialog box, choose the policies you want to add.
b) Click **OK**. The policies are added to the **Compliance Policy Selector** area.

**Step 4**
Select the rules you want to include in the policy.

a) Select a policy in the **Compliance Policy Selector** area. The policy's rules are displayed in the area on the right.
b) Select and deselect specific rules, then click **Save**.

**Note**

The choices you make here only apply to the *policy instance in this profile*. Your choices do not modify the original version of the compliance policy.

---

**What to do next**

Schedule the compliance audit job as described in *Run a Compliance Audit, on page 144*.

---

**Run a Compliance Audit**

To run a compliance audit, select a profile, choose the devices you want to audit (using the policies and rules in the profile), and schedule the audit job.

**Step 1**
Choose **Configuration > Compliance > Profiles**.

**Step 2**
Select a profile in the **Compliance Profiles** navigation area on the left.

**Step 3**
Click the Run Compliance Audit icon in the **Compliance Profiles** navigation area.

**Step 4**
Expand the **Devices and Configuration** area, select the required devices and configuration files that you want to audit.

a) Select the devices (or device groups).
b) Specify which configuration file you want to audit.

- **Use Latest Archived Configuration** — Audit the latest backup file from the archive. If no backup file is available, Cisco EPN Manager does not audit the device.

- **Use Current Device Configuration** — Poll and audit the device's running configuration. (For example, show command output will be from the device's running configuration.)

  When you select this option, Cisco EPN Manager first takes a backup of the configuration from device and then performs audit. This is useful when periodic or event triggered configuration backup is not enabled and also useful because archived configuration in Cisco EPN Manager is often out-of-sync with the device.

c) Click **Next**.

**Step 5**
Enter a value in the **Configure Idle Time Limit (min)** field. By default, the time limit is set to 5 minutes. Users can enter a number between 5 and 30 if they wish to change the time limit. The audit job will be aborted if it is idle for the configured time limit.

**Step 6**
Select **Now** to schedule the audit job immediately or select **Date** and enter a date and time to schedule it later.

Use the **Recurrence** option to repeat the audit job at regular intervals.

**Step 7**
Click **Finish**. An audit job is scheduled. A notification pop-up will appear once the audit job is scheduled. To view the status of the audit job, choose **Configuration > Compliance > Jobs**.

**Step 8**
You will receive an email after the job completion. The email subject line contains, Hostname: Job type: Profile name: Job status for an audit job and Hostname: Job type: Job status for a fix job. The subject line also contains the subject specified by the user in the **Mail Server Configuration** screen or the **Job Notification Mail** screen, if any.
Step 9 You can view the following details in the email triggered for an audit job; Job Name, Job Type, Status, LastRunStatus, PI HostName, PI Host IP, Policy Profile Name, Total Device Count, Audited Device Count, Non-Audited Device Count, and links to verify the profile and job details.

Step 10 You can view the following details in the email triggered for a fix job; Job Name, Job Type, Status, LastRunStatus, PI HostName, PI host IP, and link to verify the job details.

Step 11 You will receive the job details in CSV format as an attachment. The CSV file is not secured with password.

---

**What to do next**

Check the audit results as described in View the Results of a Compliance Audit, on page 145.

---

**View the Results of a Compliance Audit**

Use this procedure to check an audit job results. The results will tell you which devices were audited, which devices were skipped, which devices had violations, and so forth. There might be several different compliance policies running on a single device.

After a job is created, you can set the following preferences for the job:

- **Pause Series**—Can be applied only on jobs that are scheduled in the future. You cannot suspend a job that is running.
- **Resume Series**—Can be applied only on jobs that have been suspended.
- **Edit Schedule**—Reschedule a job that has been scheduled for a different time.

---

**Step 1** Choose **Configuration > Compliance > Jobs**.

**Step 2** Click the **Audit Jobs** tab, locate your job, and check the information in the **Last Run** column.

<table>
<thead>
<tr>
<th>Last Run Result Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Failure</td>
<td>One or more devices audited have a violation in the policies specified in the profile.</td>
</tr>
<tr>
<td>Partial Success</td>
<td>The compliance job contains a mix of both audited and non-audited devices, and the compliance status of audited devices is successful.</td>
</tr>
<tr>
<td>Success</td>
<td>All devices audited conform to the policies specified in the profile.</td>
</tr>
</tbody>
</table>

For a compliance audit job, the number of violations supported is 20000 for Standard setup and 80000 for Pro and above setup of Cisco EPN Manager.

**Step 3** If the audit check failed:

- To see which devices failed, hover over the "i" icon next to the **Failure** hyperlink to display a details popup.
- Launch a Device 360 view by selecting the job, clicking **View Job Details**, and clicking the "i" icon next to a device in the popup window.

**Step 4** For the most detail, click the **Failure** hyperlink to open the **Compliance Audit Violation Details** window.
Note: Use the Next and Previous buttons to traverse the Compliance Audit Violation Details window.

What to do next
To fix any of the violations, see Fix Device Compliance Violations, on page 147.

View Violation Job Details

The following table shows the details that can be viewed from the Violation Details page.

<table>
<thead>
<tr>
<th>To View:</th>
<th>Do the following</th>
</tr>
</thead>
<tbody>
<tr>
<td>The status of scheduled fixable jobs.</td>
<td>1. Go to the Violation Details page.</td>
</tr>
<tr>
<td></td>
<td>2. Click the Fixable column filter box and choose Running.</td>
</tr>
<tr>
<td>The details of Fixed violation jobs.</td>
<td>1. Go to the Violation Details page.</td>
</tr>
<tr>
<td></td>
<td>2. Click the Fixable column filter box and choose Fixed.</td>
</tr>
<tr>
<td></td>
<td>3. Click the Fixed link.</td>
</tr>
<tr>
<td>The details of Fix Failed violation jobs.</td>
<td>1. Go to the Violation Details page.</td>
</tr>
<tr>
<td></td>
<td>2. Click the Fixable column filter box and choose Fix Failed.</td>
</tr>
<tr>
<td></td>
<td>3. Click the Fix Failed link.</td>
</tr>
</tbody>
</table>

View Change Audit Details

Step 1 Log in to Cisco EPN Manager as an administrator
Step 2 Choose Monitor > Tools > Change Audit Dashboard.

The Change Audit Dashboard displays the network audit logs and change audit data of device management, user management, configuration template management, device community and credential changes, and inventory changes of devices. The Change Audit report and Change Audit dashboard display the details irrespective of the virtual domain you are logged in.

View Audit Failure and Violation Summary Details

You can view detailed violation information, export this data, and view details of compliance jobs. You can export detailed data for a specific job, or export summary data for multiple jobs.

Step 1 Choose Configuration > Compliance > Jobs.
To view the details for a specific audit job:

- Click the **Audit Jobs** tab and locate your job.
- Click the job's **Failure** hyperlink to view the **Compliance Audit Details** window.

You can view information about the policy name, the set rules, its compliance state, the total violation count, the job's instance count, its highest severity value, and the ignored count values.

To export these details use one of the following options:

- To export the violation details to a Microsoft Excel spreadsheet in XLS format, click **Export as XLS**.
- To export the violation details to a Microsoft Excel spreadsheet in comma-separated text, click **Export as CSV**.
- To export the violation details to an HTML file, click Export as HTML.

c) Click **Save File**.

To view a collective summary of all audit jobs:

- Click the **Violation Summary** tab.

You can view a collective report for all devices on which violations have occurred, their associated policy and profile names, their audit job IDs, their associated rules and rule severity values, details on whether the violations are fixable or not, or whether they are already fixed, and the message associated with the violation.

b) To export this detailed summary report, choose one of the following options from the drop-down menu:

- To export the summary to a Microsoft Excel spreadsheet in comma-separated text, click **Violation Report CSV**.
- To export the summary to a PDF file, click **Violation Report PDF**.

c) Click **Save File**.

---

**What to do next**

To fix any of the violations, see [Fix Device Compliance Violations, on page 147](#).

---

**Fix Device Compliance Violations**

Use this procedure to fix compliance violations for a failed compliance audit.

---

**Step 1** Choose **Configuration > Compliance > Jobs**.

**Step 2** Click the **Audit Jobs**, locate your job, and check the information in the **Last Run Result** column.

**Step 3** Click the **Failure** hyperlink to open the **Compliance Audit Violation Details** window.

**Note** Use the **Next** and **Previous** buttons to traverse the **Compliance Audit Violation Details** window.

**Step 4** In the **Job Details and Violations** area, click **Next**.

**Step 5** In the **Violations by Device** area, select the device and violation and click **Next**.

**Step 6** In the **Fix Rule Inputs** area, preview the fix commands that were previously defined in the policy, then click **Next**.
If custom policies are created with fix CLI ^<Rule input ID>^ as the action for the condition, then the Fix Rule Inputs tab is displayed. Enter the required fix rule values and click **Next** to continue.

**Step 7**  
Review the configuration that is displayed in the Preview Fix Command pop up.

**Step 8**  
Schedule the fix job so that the generated configuration can be deployed to the device, then Click **Schedule the Fix Job**.

**Note**  
User can add the compliance fix CLI to the device's startup configuration. This retains the fix CLI even when the device is rebooted.

---

**What to do next**

To view any of the violations job details, see View Audit Failure and Violation Summary Details, on page 146.

---

**View Audit Failure and Violation Summary Details**

You can view detailed violation information, export this data, and view details of compliance jobs. You can export detailed data for a specific job, or export summary data for multiple jobs.

**Step 1**  
Choose **Configuration > Compliance > Jobs**.

**Step 2**  
To view the details for a specific audit job:

a) Click the **Audit Jobs** tab and locate your job.

b) Click the job's **Failure** hyperlink to view the **Compliance Audit Details** window.

You can view information about the policy name, the set rules, its compliance state, the total violation count, the job's instance count, its highest severity value, and the ignored count values.

c) To export these details use one of the following options:

   • To export the violation details to a Microsoft Excel spreadsheet in XLS format, click **Export as XLS**.
   • To export the violation details to a Microsoft Excel spreadsheet in comma-separated text, click **Export as CSV**.
   • To export the violation details to an HTML file, click **Export as HTML**.

d) Click **Save File**.

**Step 3**  
To view a collective summary of all audit jobs:

a) Click the **Violation Summary** tab.

You can view a collective report for all devices on which violations have occurred, their associated policy and profile names, their audit job IDs, their associated rules and rule severity values, details on whether the violations are fixable or not, or whether they are already fixed, and the message associated with the violation.

b) To export this detailed summary report, choose one of the following options from the drop-down menu:

   • To export the summary to a Microsoft Excel spreadsheet in comma-separated text, click **Violation Report CSV**.
   • To export the summary to a PDF file, click **Violation Report PDF**.
c) Click Save File.

---

**What to do next**

To fix any of the violations, see Fix Device Compliance Violations, on page 147.

---

**Import and Export Compliance Policies**

Compliance policies are saved as XML files. You can export individual compliance policies and, if desired, import them into another server. Files can only be imported in XML format.

**Step 1** Choose Configuration > Compliance > Policies.

**Step 2** To export a compliance policy:

a) Mouse hover on "i" icon next to the policy in the Compliance Policies navigation area on the left.

b) In the popup window, click the Export Policy as XML hyperlink, and save the file.

**Step 3** To import a compliance policy:

a) Click the Import Policies icon above the Compliance Policies navigation area on the left.

b) In the Import Policies dialog box, click Choose Policies.

c) Browse to the XML file and select it.

d) Click Import.

---

**View the Contents of a Compliance Policy XML File**

Compliance policies are saved as XML files. To view the contents of a policy's XML file:

**Step 1** Choose Configuration > Compliance > Policies.

**Step 2** Locate the policy in the Compliance Policies navigation area on the left, then hover your mouse over the "i" icon next to the policy.

**Step 3** In the popup window, click the View Policy as XML hyperlink. Cisco EPN Manager displays the content in XML format.

---

**View PSIRT and EOX Information**

- View Device Security Vulnerabilities, on page 150
- View Device Hardware and Software End-of-Life Report, on page 150
- View Module Hardware End-of-Life Report, on page 151
View Device Security Vulnerabilities

You can run a report to determine if any devices in your network have security vulnerabilities as defined by the Cisco Product Security Incident Response Team (PSIRT). The report includes Device PSIRT, Device Hardware EOX, Device Software EOX, Module Hardware EOX and Field Notice information. You can also view documentation about the specific vulnerabilities that describes the impact of a vulnerability and any potential steps needed to protect your environment.

**Note**

PSIRT and EOX reports cannot be run for specific devices. When you schedule PSIRT and EOX jobs, the report is generated for all devices in Managed and Completed state (on the **Inventory > Configuration** > **Network Devices** page).

**Before you begin**

Sync the devices prior to scheduling the job. Choose **Configuration > Network Devices**, select the devices, then click **Sync**.

**Step 1** Choose **Reports > PSIRT and EoX**.

**Step 2** Schedule and run the job.

A job is created in which Device PSIRT, Device Hardware EOX, Device Software EOX, Module Hardware EOX and Field Notice information is gathered and reported. Separate jobs on each of the tabs need not be created.

**Step 3** Click **View Job Details** to view the current status of the PSIRT report.

**Step 4** When the report is completed, click the **Device PSIRT** tab to view PSIRT information.

**Step 5** In the **PSIRT Title** column, click the hyperlink to view the full description of a security vulnerability.

**Step 6** (Optional) You can export the device PSIRT details in PDF and CSV format for each device and for all devices collectively.

View Device Hardware and Software End-of-Life Report

You can run a report to determine if any Cisco device hardware or software in your network have reached end of life (EOX). This can help you determine product upgrade and substitution options.

**Step 1** Choose **Reports > PSIRT and EoX**.
**Manage the Inventory**

**View Module Hardware End-of-Life Report**

You can run a report to determine if any Cisco module hardware in your network have reached end of life (EOX). This can help you determine product upgrade and substitution options.

**Step 1** Choose **Reports > PSIRT and EOX**.

**Step 2** Click **Schedule Job**. A job is created in which Device PSIRT, Device Hardware EOX, Device Software EOX, Module Hardware EOX and Field Notice information is gathered and reported. You do not create separate jobs on each of the tabs.

**Step 3** Click the **Module Hardware EOX** tab to view the module hardware information.

**Step 4** (Optional) You can export these EOX details in PDF and CSV format for each module.

**View Field Notices for Device**

You can run a report to determine if any Cisco devices that are managed and have completed a full inventory collection have any field notices. Field Notices are notifications that are published for significant issues, other than security vulnerability-related issues, that directly involve Cisco products and typically require an upgrade, workaround, or other customer action.

**Step 1** Choose **Reports > PSIRT and EOX**.

**Step 2** Click **Schedule Job**. A job is created in which Device PSIRT, Device Hardware EOX, Device Software EOX, Module Hardware EOX and Field Notice information is gathered and reported. You do not create separate jobs on each of the tabs.

**Step 3** Click the **Field Notice** tab to view field notice information.

**Step 4** Click on the * icon in the Vulnerable column to open the Field Notice URL and Caveat Details dialog box. Click on the Field Notice URL to view more information on cisco.com.

**Step 5** (Optional) You can export the device field notice details in PDF and CSV format for each device and for all devices collectively.
View Field Notices for Device
PART III

Visualize the Network

• Visualize the Network Topology, on page 155
CHAPTER 7

Visualize the Network Topology

This chapter provides the following topics:

• Network Topology Overview, on page 155
• View Detailed Tables of Alarms, Network Interfaces, Circuits/VCs, and Links from a Network Topology Map, on page 157
• Search for a Device in the Map, on page 159
• Determine What is Displayed in the Topology Map, on page 160
• Get More Information About Devices, on page 167
• Get More Information About Links, on page 167
• Troubleshoot Link Issues, on page 172
• Show Bandwidth Utilization for Links on the Map, on page 173
• View Fault Information for Devices and Links, on page 174
• Change the Layout of a Network Topology Map, on page 175
• Add a Background Image to the Network Topology, on page 176
• Visualize and Trace Circuits/VCs, on page 177
• Show Clock Synchronization Networks on a Network Topology Map, on page 177
• Show Routing Networks on the Topology Map, on page 178
• View OMS Links, on page 180
• Save the Topology Map as an Image File, on page 183
• View Your Network on a Geographical Map (Geo Map), on page 183

Network Topology Overview

The Network Topology window presents a graphical, topological map view of devices, the links between them, and the active alarms on elements in the map. It also enables you to visualize circuits/VCs within the displayed topology map. In addition, the Network Topology window provides access to map element tools and functions, and allows you to drill-down to get detailed information about map elements.

The Network Topology window is accessed from the left sidebar (Maps > Topology > Network Topology). The content of the Network Topology window is determined by the device group(s) you have selected. To select a device group, click the Device Groups button in the toolbar and select one or more groups in the Device Groups panel. From the Device Groups panel you can access the central device grouping functionality to create new groups, add devices to groups, and so on. See Create Groups of Devices for Easier Management and Configuration, on page 61 for more information.
Each Network Topology map is divided into a left pane that contains alarms/circuits/VCs/links information, and a right pane that displays the map itself. From the left pane, use the toolbar to control the spacing of both panes. For example, if you select 100%, only the map will be shown. If you select 50%, the map and the left pane will share the screen equally. When the left pane is expanded, additional columns might be added to the tables in the tabs.

- Alarms, Circuits/VCs, and Links (left pane)—Provides information relevant to the devices and topology shown in the map.
  - Alarms tab—Shows a table listing the current alarms for the selected group(s) and their severity. You can select alarms and perform basic actions, such as clear, acknowledge, and so on. For full details of the alarms, click the Alarms Table link at the bottom of the Alarms tab.
  - Circuits/VCs tab—Lists the circuits/VCs relevant to the devices in the selected group(s), and indicates the primary state of each circuit/VC. The primary state reflects the most serious current state of the circuit, as derived from the provisioning, serviceability, discovery, and alarm states. See Circuit or...
VC States, on page 584. By default, the circuits/VCs are sorted by primary state, from most to least severe. Note that:

- Selecting a circuit/VC in the list displays a visual representation of the circuit/VC in the topology map.
- Clicking the Circuits/VCs link at the bottom of the tab launches a separate window with a table of circuits/VCs providing more details for each circuit/VC.
- Clicking the Network Interfaces link at the bottom of the tab launches a table listing the interfaces that have been configured for participation in circuits/VCs, such as UNIs and ENNIs.
- Clicking the appropriate toolbar icon allows you to perform actions such as creating a new circuit or running an ITU-T Y.1564 test on the selected circuit.

- Links tab—Lists the links relevant to the selected device group(s) and shows the highest severity alarm on the link. Selecting a link in the table highlights the link in the topology map. Clicking the Links Table link at the bottom of the tab launches a separate window with a table of links.

- Topology map (right pane)—Displays the topology of the selected device group(s) in graphical form. It displays the group’s devices and sub-groups (if any) and the links between them (Physical, Ethernet, and technology-specific links). It also displays the active alarms on the devices or links so that you can easily identify problems in the network. You can drill down from the topology map to detailed information about a device or link in order to troubleshoot problems. The topology map can be customized, filtered, and manipulated to show exactly the information you need.

You can toggle between the network topology map and the geographical map using the toggle buttons in the top right corner of the map.

---

**Note**

Based on the refresh time intervals for tables settings in User Preferences the topology map view on Circuits/VCs and Interfaces will be refreshed. For more information see, Change User Preferences.

---

**View Detailed Tables of Alarms, Network Interfaces, Circuits/VCs, and Links from a Network Topology Map**

From the Network Topology window, you can access extended tables that list and provide more information about the alarms, network interfaces, circuits/VCs and links in the selected device group. These extended tables open in a separate browser window.

The tables accessed from the Network Topology window contain information for the selected device group only. You can access a full list of all alarms/circuits/deleted circuits/network interfaces/links in the system by selecting Inventory > Other and then selecting the required table (links, network interfaces, and so on).

To open the extended details tables, click the Detach icon in the top right corner of the tab or click on the hyperlink at the bottom of a specific tab, for example, click on the Alarms Table link at the bottom of the Alarms tab.
The window displaying the extended tables has these tabs: Alarms, Circuits/VCs, Deleted Circuits/VCs, Network Interfaces, and Links.

Be aware of the following when working with the extended tables:

- When the extended tables window is open, the left pane of the Network Topology window is disabled. When you close the extended tables window, the tabs in the left pane of the Network Topology window become fully functional again.

- There is synchronization between the extended tables and the corresponding tabs in the Network Topology window. For example, if you select a circuit/VC in the extended Circuits/VCs table, that circuit will also be selected in the Circuits/VCs tab in the Network Topology window and the circuit/VC overlay will be shown in the topology map. Conversely, if you select a circuit/VC in the Network Topology window and then open the extended table, the same circuit/VC will be selected in the extended table.

- Alarms and circuits/VCs in both the Network Topology window and in the extended tables are refreshed based on the user preference settings. See Set Up Your Alarm and Event Display Preferences, on page 230 and Customize the Alarm Summary, on page 232.

- Click the Export icon at the top right of the table to export the data from the table to a file (either PDF or CSV format). Export is available for alarms, circuits/VCs and network interfaces.

  Note  
  If the table contains more than 1000 rows, you will not be able to export the data.

- Click the i icon next to the Provisioning column in the Circuits/VCs and Deleted Circuits/VCs tabs to view the details of configuration, configuration errors, rollback configuration, and rollback configuration errors for each device participating in the circuit/VC. The i icon is available for all provisioning states, except None.
You can customize the GUI display settings that control the Network Topology page for Circuits/VCs and Interfaces:

1. Click at the top right of the Cisco EPN Manager window, then choose My Preferences.
2. Under Network Topology, from the Refresh Intervals for Tables drop-down list, choose an option to set the refresh interval. The specified refresh interval will determine the time interval at which the tables in the topology page should be refreshed on Circuits/VCs and Interfaces.

Note: The available options are 1 minute, 2 minute, 5 minute and Do not Refresh. For example, if you set the time interval as 2 minutes, all the topology in the inventory will be refreshed every 2 minutes automatically.

Filter Data in the Detailed Tables

You can also filter the data to find specific alarms, circuits/VCs, network interfaces, or links using a quick filter or an advanced filter from the Show drop-down list. The quick filter narrows the content that is displayed in a column according to the text you enter above the column. The advanced filter allows you to narrow down the data in a table by applying a filter using multiple operators such as Does not contain, Does not equal, Ends with, Is empty, and so on. You can also create a user defined filter which, if saved, will be added to the Show drop-down menu.

To create and save a user-defined filter:

Step 1 From the Show drop-down list above the extended tables of alarms, circuits/VCs, network interfaces, and links, choose Advanced Filter.
Step 2 In the Advanced Filter data popup window, enter the advanced filter criteria, and then click Save As.
Step 3 In the Save Filter dialog box, enter a name for your filter and click Save.

To edit or remove a user-defined filter, choose Manage User Defined Filters from the Show drop-down list.

Search for a Device in the Map

You can search for devices in the topology map and in the geo map by the following criteria:

• Device name
• Device family
• IP address
• User defined field value

To search for specific devices in the map:

Step 1 Click the Search icon in the toolbar.
Determine What is Displayed in the Topology Map

- Choose Which Device Group(s) to Display in the Network Topology Map, on page 160
- View the Contents of a Sub-Group in theTopology Map, on page 161
- Manually Add Links to the Topology Map, on page 162
- Change Which Link and Device Types are Shown in the Network Topology Map, on page 164
- Show/Hide Alarms and Labels in the Topology Map, on page 165
- Isolate Specific Sections of a Large Topology Map, on page 166

Choose Which Device Group(s) to Display in the Network Topology Map

The topology map enables you to visualize the topology of a device group or multiple device groups. The selected group(s) might cover a specific network segment, a customer network, or any other combination of network elements. Device grouping is hierarchical. There are two top-level parent groups containing multiple sub-groups - Location groups and User Defined groups. You can display multiple groups within the same top-level parent group. For example, you can display multiple Location groups but you cannot display one Location group and one User Defined group.

To determine which devices are displayed in the topology map, click on the Device Groups button in the left pane and select one or more device groups.

After you have displayed the required group(s) in the topology map, you can access additional information about any device or link. See Get More Information About Devices and Get More Information About Links

The topology map only displays devices for which the logged in user has access privileges, based on the virtual domains to which the user has been assigned.

Note

If you encounter topology issues, such as topology components not rendering as expected or component data not being displaying on the map, we recommend that you clear your browser cache and try again.

To display network elements in the topology map:

Step 1 Choose Maps > Topology Maps > Network Topology.
Step 2 Click on the Device Groups button in the left pane to open the Device Groups panel.
Step 3 Click on the device group(s) you want to display in the topology map and click Load. The device group selections are displayed above the topology map.
Step 4 Customize the topology map as required by showing specific device/link types, adding manual links, and so on. See the following topics for more information:
  - Change Which Link and Device Types are Shown in the Network Topology Map, on page 164
View the Contents of a Sub-Group in the Topology Map

You can expand a sub-group to show its contents within the current context or you can drill down to see the contents of the sub-group independently of the current map context.

**Note**

When expanding sub-groups, be aware that if a device belongs to more than one group, the device will appear in one of the expanded groups only. It will not appear in all of the groups to which it belongs. If your setup has devices that belong to multiple groups, rather view the groups individually in the topology map by selecting them in the Device Groups pane. This will ensure that you will always see all the devices that belong to a specific group.

To view the contents of a sub-group:

**Step 1**

Click on a sub-group in the topology map.

**Step 2**

In the displayed popup, click one of the following:

- **Drill down group**—Displays the sub-group on its own in the topology map, meaning that the currently displayed group is replaced with the selected sub-group. Note that the sub-group name is selected in the Device Groups pane.

  **Note** You can double-click on the sub-group to quickly drill down into the group.

- **Expand group**—Adds the contents of the sub-group to the current topology map display.

In the figure below, the IL group is expanded.
Manually Add Devices and Networks to the Topology Map

You can display devices and networks that are not managed by the system on the topology map and on the geo map by adding them manually.

Step 1  In the topology toolbar, choose Create > Create Unmanaged Device or Create > Create Unmanaged Network.

Step 2  Click on the map to add the device/network to the map.

Step 3  Click on the newly-added device/network in the map. From the displayed panel, you can add the device/network to a group, rename the device/network, or delete the device/network.

After you have added a device or network to the topology map, it will also be available in the geo map. The unmanaged device will appear in the list of unmapped devices and you can set its location. See Place Unmapped Devices on the Geo Map, on page 186.

Manually Add Links to the Topology Map

If you know that two devices are connected but Cisco EPN Manager cannot discover the link and show it on the map, you can add the link manually. After you add this link, it will be shown by default whenever the relevant group is shown on the map.

Following are the most common scenarios in which manual links could be used:

• From the optical/DWDM controller of a trunk port on a Cisco NCS device running IOS-XR (NCS 4000, 9000, 5000, 1000) to an add/drop port pair in NCS 2000 devices.

• From the optical/DWDM controller of a client port on a Cisco NCS device running IOS-XR (NCS 4000, 9000, 5000, 1000) to NCS 2000 transponder client ports (representing connections for 10GE/100GE ports).

• From 10GE/100GE controllers of ports on a Cisco NCS device running IOS-XR (NCS 4000, 9000, 5000, 1000) to NCS 2000 transponder client ports (representing connections for 10GE/100GE ports).

• Between two trunk ports on Cisco NCS 2000 series devices with 400-G-XP linecards. This link must be created as a managed OTU link.

• From a Cisco NCS 2000 series device with 400-G-XP linecard and a Cisco NCS 4000 series device with 4H-OPW-QC2 linecards. This link must be created as a managed OTU link.

Manual links can be managed or unmanaged:

• Unmanaged links: For visualization purposes only. If you know that two devices are connected but you do not need full management of the link between them, you can add an unmanaged manual link to the map. The link will appear as a grey dashed line.

• Managed links: When you add a managed manual link, it is saved to the database and is included in all links tables. It is shown on the map as a solid line, the same as all other managed links. Cisco EPN Manager retrieves the link status from the managed device interfaces to which it is connected. The discovery status of a manually added managed link will be "Pre-provisioned." This indicates that it was not discovered by the system.
To manually add a link between two devices:

**Step 1**
In the topology toolbar, choose **Create > Create Unmanaged Link** or **Create > Create Managed Link**.

**Step 2**
Click and hold down the mouse on the first device in the topology map and drag it to the second device.

**Step 3**
In the Interface Details dialog, select the source interface on the first device and the target interface on the second device from the drop-down lists of available interfaces, and click **OK**.

The link between the two selected devices will be displayed on the map.

---

**Delete a Manually Added Link**

Links that were added manually to the map can be deleted from the system.

- Manually added managed links are deleted from the Links table, as described in the procedure below.
- Manually added unmanaged links are deleted by clicking on the link in the map and then clicking **Delete** in the Link panel.

To delete a manually added managed link:

**Step 1**
In the left sidebar, choose **Inventory > Other > Links**.

**Step 2**
Filter the Status column of the Links table to show Pre-provisioned links and select the required link.

**Step 3**
Click the Delete icon to delete the link. The Delete icon is only enabled for manually added links.

**Step 4**
Alternatively, to delete the manually created links, click the information (I) icon on the link that you want to delete.

In the **Link Details** window, a single link with **Type** as "Manual" appears.

**Step 5**
Choose the entry and then click the Delete (X) icon to delete the link.

To delete a manually added unmanaged link:

1. Filter the Status column of the Links table to show Pre-provisioned links and select the required link.
2. To delete the manually created unmanaged links, click the information (I) icon on the link that you want to delete.
   
   In the **Link Details** window, a single link with **Type** as "Manual" appears.

3. Choose the entry and then click the Delete (X) icon to delete the link.

---

**Rename a Link**

By default, the link name is generated automatically by the system based on the A- and Z-end interface name. You can rename any link, in which case the new name will represent the link in all link tables, in the Link 360 view, and on the map.

To rename a link:

**Step 1**
Go to any of the link tables.
**Change Which Link and Device Types are Shown in the Network Topology Map**

You can choose to display only certain types of links or devices in the network topology map. Click the **Show** button and select **Links** or **Device Families** to see a full list of link and device types and select the ones you want to display.

---

**Note**  
Link/device type filters are disabled when you select a specific circuit/VC to display on the map.

---

1. **Step 1** In the left sidebar, choose **Maps > Topology Maps > Network Topology**.
2. **Step 2** Click on the **Device Groups** button, select the required device group(s), and click **Load**.
3. **Step 3** Click **Show** in the topology toolbar and choose **Links** or **Device Families**.
4. **Step 4** In the Links dialog:
   - Select the types of links you want displayed in the topology map, for example, physical layer links, Ethernet layer links, and so on. The Links dialog only shows link types that exist in your network. If a link type exists in your network but not in the selected device group, it will be disabled.
   - If you want to differentiate aggregated links from single links, select the Display Aggregated Links as check box.
   - You can enable bandwidth utilization visualization on links that support this feature. See **Show Bandwidth Utilization for Links on the Map**, on page 173 for more information.
   - Click **OK**. The topology map will reflect your selections. Only the link types you selected will be displayed.

---

5. **Step 5** In the Devices dialog:
   - Select the device types you want displayed in the topology map, for example, routers, switches and hubs, optical networking, and so on. The Devices dialog only shows device types that exist in your network. If a device type exists in your network but not in the selected device group, it will be disabled.
   - Click **OK**. The topology map will reflect your selections. Only the device types you selected will be displayed.

---

**Note**  
If you have selected to display optical networks on the map, by default you will see the devices that serve as optical line amplifiers (if any). Deselect the Display Optical Line Amplifier check box under Device Functions if you do not want these optical line amplifier devices to be displayed on the map.
Show/Hide Alarms and Labels in the Topology Map

You can choose to hide the device name labels and you can hide alarms altogether or you can display alarms of specific severities only.

Step 1
In the left sidebar, choose Maps > Topology Maps > Network Topology.

Step 2
Click the Show button in the topology toolbar.

Step 3
Select the items you want displayed in the topology map:
- Labels—Labels associated with devices, such as device names.
- Faults—Deselect the check box to hide fault information altogether. Select the check box to show all alarms or use the slider to show only faults of a certain severity or higher.

Step 4
Close the Show dialog. Your selections are applied to the topology map.

Save Global Preferences for the Map Display

The Show button in the map toolbar allows you to choose the items that will be shown in your map display, including device names (labels), device types, link types, alarm severity, and so on.

If you are a Super User or Admin user, you can save your choices as global preferences which will be applied automatically for all new users and which can be loaded by any users on demand. You can also delete global preferences.

Note
Any user having Network Topology Edit permission, will be able to save and delete the global preference. You also need to have the Network Topology permission to access the topology maps.

The following items are saved as global preferences:
- Labels on/off
- Device families
- Link types
- Fault severity
- Bandwidth utilization

To save global preferences for map display:

Step 1
In the left sidebar, choose Maps > Topology Maps > Network Topology.

Step 2
Click on the Device Groups button, select the required device group(s) and click Load.

Step 3
Click Show in the topology toolbar and select the items you want to show on the map.

Step 4
Choose Global Preferences > Save.
Saved global preferences can be deleted if necessary by clicking **Delete**.

---

**Load Global Preferences for the Map Display**

The **Show** button in the map toolbar allows you to choose the items that will be shown in your map display, including device names (labels), device types, link types, alarm severity, and so on.

If global preferences have been defined for the map display, you can load them. You can then make your own changes to the map display as required.

The following items are saved as global preferences:

- Labels on/off
- Device families
- Link types
- Fault severity
- Bandwidth utilization

To load global preferences for map display:

**Step 1** In the left sidebar, choose **Maps > Topology Maps > Network Topology**.

**Step 2** Click on the **Device Groups** button, select the required device group(s) and click **Load**.

**Step 3** Choose **Global Preferences > Load**. This option is disabled if no global preferences have been defined.

---

**Isolate Specific Sections of a Large Topology Map**

In cases where a topology map is displaying thousands of devices, you might want to focus on specific devices or sets of devices. The Overview pane shows you the entire topology map in miniature and lets you select the area you want to display in the large topology map. It also provides an at-a-glance view of the alarm status of the elements in the topology map.

**Step 1** Click the Overview icon in the topology toolbar. The Overview pane appears in the at the bottom right of the topology map and displays the following:

- Dot—indicates any network element. The color of the dot indicates the severity of alarms associated with the network element.
- Line—indicates a link. The color of the line indicates the severity of the associated alarm.
- Blue rectangle—indicates the selection area. The area within the rectangle is displayed in the map pane. Handles on the corners enable you to resize the selection area.
- Pan mode cursor—cursor displayed within the selection area. Use this cursor to move the selection area, and thereby view different elements in the map pane.
- Zoom mode cursor—displayed outside the selection area. Use this cursor to define a new selection area or to zoom in on an existing selection area.
Step 2 Draw a rectangle by dragging the mouse over the area you want to see in the topology map.

Step 3 Click the ‘x’ in the upper right corner to close the Overview pane.

---

**Get More Information About Devices**

From the topology map, you can drill down to get more information about a device.

**Step 1** Click on the required device in the topology map. A popup appears showing basic device information and alarm information for the device.

**Step 2** Click View 360 to access the Device 360 view for detailed information about the device.

For more information, see, Get Basic Device Information: Device 360 View, on page 69.

---

**Get More Information About Links**

Cisco EPN Manager provides a variety of ways that you can view links and get more details about them:

<table>
<thead>
<tr>
<th>To view link information for:</th>
<th>See the procedures in:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A specific link</td>
<td>Get a Quick Look at a Specific Link: Link 360 View, on page 167</td>
</tr>
<tr>
<td>A specific link in a topology map</td>
<td>View a Specific Link in the Topology Map, on page 170</td>
</tr>
<tr>
<td>A group in a topology map</td>
<td>View a Device Group's Links in a Network Topology Map, on page 170</td>
</tr>
<tr>
<td>All of Cisco EPN Manager</td>
<td>View Link Tables, on page 171</td>
</tr>
</tbody>
</table>

**Get a Quick Look at a Specific Link: Link 360 View**

The Link 360 view gives you a quick look at the configuration and status of a device's links. Each Link 360 view provides information about the A- and Z-sides of the link (type, direction, capacity, and so forth). Depending on the link and device type, it also provides a wide range of metrics, such as power level, span loss, and bit errors.

You can launch the Link 360 view by clicking the "i" next to a link name in any of the link tables. This includes the tables that are opened by clicking Links Table in a topology map, or by choosing Inventory > Other > Links.

The Link 360 view provides general link and performance information at the top of the view, and more detailed link information in tabs in the lower part of the view.

<table>
<thead>
<tr>
<th>Information Provided in Link 360 View</th>
<th>Description</th>
</tr>
</thead>
</table>

---
### General information

The link name, serviceability status, highest severity alarm, type, direction, capacity, and utilization. Definitions of link serviceability states are provided in Link Serviceability States, on page 168.

If the link you are viewing is an OTS or OTU link, you can click the Utilization field's i (information) icon to open the Used Wavelengths pop-up window, which lists the optical channels configured on the link and the circuits that are currently using those channels.

### Performance data

Graphs or charts reflecting various aspects of link performance.

### Alarms

Current alarms for the link, including their severity, status, the time they were generated, the source of the alarm, and the alarm's ID. Also provides a launch point for the Alarm Browser.

### Links

(LAGs only) Status, name, and IP address for the A-side and Z-side port in the Link Aggregation Group.

### Endpoints

Devices and interfaces that serve as endpoints for the link. Provides a launch point for the Interface 360 view. For optical devices, this tab also displays the latest recorded power values for transmitted and received signals.

**Note**

Power values are not normally displayed for manual links. However, if you open the Link 360 view for a manual LMP or OTS link between a Cisco NCS 1000 and 2000 device, the view displays the power values for both endpoints.

### Circuit/VCs

(For a circuit/VC that traverses the link) Circuit/VC name, type, customer, status, and creation date. Also provides a launch point for the Circuit/VC 360 view.

### SRRGs

Lists the Shared Risk Resource Groups (SRRGs) assigned to the link or to the link endpoint devices. For each listed SRRG, you can see whether it is the default SRRG on the link/device or if it has been assigned to the link/device. For more information about SRRGs, see Manage Shared Risk Resource Groups (SRRGs) in the Geo Map.

### Link Serviceability States

<table>
<thead>
<tr>
<th>Serviceability State</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Admin Down</td>
<td><img src="image" alt="Admin Down" /></td>
<td>Link was purposefully shut down by the administrator.</td>
</tr>
<tr>
<td>Down</td>
<td><img src="image" alt="Down" /></td>
<td>Link is down (but it should not be).</td>
</tr>
<tr>
<td>Up</td>
<td><img src="image" alt="Up" /></td>
<td>Link is up and traffic is passing through the link.</td>
</tr>
<tr>
<td>Auto Up</td>
<td><img src="image" alt="Auto Up" /></td>
<td>Link is up because it detected a signal (this state is only supported by optical devices).</td>
</tr>
<tr>
<td>Unavailable</td>
<td><img src="image" alt="Unavailable" /></td>
<td>Link is not discovered yet or its status is unavailable.</td>
</tr>
</tbody>
</table>
Partial | | Link has a mismatch between requests, resources, or resource states. Examples:
* Link is processing a request to activate some service resources and deactivate others.
* Link has some active and some deactivated resources.
* Some link resources are up and others are down.
* The state for one of the link's resources is not known.

## Compare Link Information and Status

From the **Comparison View**, you can perform a side-by-side comparison of multiple links, viewing information such as raised alarms and the status of associated endpoints, circuits, and VCs. To compare links, do the following:

### Step 1
For each link you want to compare:
1. Open its **Link 360** view, as described in Get a Quick Look at a Specific Link: Link 360 View.
2. Choose **Actions > Add to Compare**.

   The link you selected is displayed at the bottom of the page. You can select a maximum of 4 links.

### Step 2
Click **Compare**.

The **Comparison View** opens.

### Step 3
From the drop-down list at the top of the view, specify whether the view will show all available information or just the information that is unique to each link.

### Step 4
Click **Comparison View**, check the check box for the categories you want the view to display, and then click **Save**.

By default, all of the categories are already selected.

### Step 5
Scroll down the page to view the information provided for each category you selected.

Note the following:

* The **Comparison View** only displays information for two links at a time. If you selected more than two, you will need to toggle to the links that are not currently displayed.

* To reorder the links you have selected, click **Rearrange**.

* Each link’s **Actions** menu is identical to the one provided in its **Link 360** view. If you select an option, the corresponding page opens.

* You can minimize and maximize the categories displayed, as needed.

* The **Comparison View** is also available for circuits and VCs, devices, and interfaces. Whenever you select any of these elements from their respective 360 view for comparison, they are displayed in the corresponding tab. This allows you to switch between element types, as needed.
• When you are done comparing links, click **Back** at the top of the view and then click **Clear All** at bottom of the page. If tabs for other element types are still displayed, you will need to clear them as well.

---

### View a Specific Link in the Topology Map

You can select a specific link from the following pages and view the link in the topology map:

- Launch the Link 360 view, and then choose **Actions > Show in Topology**. For information about how to launch the Link 360 view, see *Get a Quick Look at a Specific Link: Link 360 View*, on page 167.
- From the links table, select a specific link, and then choose **Actions > Show in Topology**. You can access the links table by clicking the Links Table hyperlink under the Links tab in the topology map, or by choosing **Inventory > Other > Links**.

### View a Device Group's Links in a Network Topology Map

Cisco EPN Manager uses the following conventions to represent links in the topology map:

- A solid line represents any type of discovered link between two elements in the topology map.
- A dotted line represents an unmanaged link that was manually drawn in the topology.
- (If enabled in the **Show > Links** menu) A dot-dash line represents an aggregated link.
- If there is a critical alarm on a link, the link will be colored red and the alarm icon will be displayed on the link.
- If an existing link is down and there is no critical alarm on the link, the link will be colored grey and a "?" icon will be displayed on the link. After 6 hours, the link will be removed automatically from the map but it can be deleted manually from the Links table or from the Link details view before that time if necessary.

If an alarm severity badge is displayed on a link, it represents the most severe alarm that is affecting the link. For aggregated links, it represents the most severe alarm affecting any of the links in the aggregation.

To get more information about links in a topology map:

- Hover over the link with your mouse to display a panel that provides "at-a-glance" useful information about that link, such as the most severe alarms, or bandwidth utilization information for the link, if available. If there are no alarms on the link and there is no bandwidth utilization information, this panel will not be displayed. If there are alarms on the link, you can click the number next to the alarm severity icon to display a table listing only those alarms.
- Click on a link to display a popup window with link information, including link type, the link's A- and Z-side devices and interfaces, and link utilization. For aggregated links, the popup window lists all the underlying links, as in the following example:
View Link Tables

Cisco EPN Manager provides a table that lists all of the links that it is managing. This provides a quick way to locate all links of a specific type or with a name that shares a common string. You can also identify links that have severe alarms, and launch Interface 360 views for view the affected sides. The table also provides a quick look at link utilization and capacity.

In addition, you can open a table showing links for the current group being displayed in the topology map. This table provides the same information and actions as the table of all links in the system.

**Step 1**
To display link tables:

- For all links: In the left sidebar, choose **Inventory > Other > Links**.
- For a selected device group's links: In the left pane of the topology map window, select the Links tab, then click the **Detach** icon in the top right corner or click the Links Table hyperlink at the bottom of the tab. The Links table is displayed in a separate window.

**Step 2**
From here you can do the following:

- Find specific types of links—for example, Physical, Pseudowire, LAG, ODU, and so forth. Place your mouse cursor in the Type field and select the link type from the drop-down list. You can also find Manual Links in this manner.

- Find links by name by entering text in the Link Name text box. You can also enter a partial string (for example, 3.3.3.3_).

- Find links with severe alarms by clicking in the Severity textbox to display a severity drop-down list, then choosing a severity. You can perform this same procedure from the A-side or Z-side. The table will indicate which side of the link has the more severe alarm, and you can launch an Interface 360 view for both sides.

- See the operational and discovery status of links in the Status column. Links can have an operational status of Up or Down. The discovery status can be one of the following:

  - Pre-provisioned: Managed links that were created manually by a user and were not discovered by the system. These links can be deleted from the system and from the map. Select the link and click the Delete icon.

  - Pre-provisioned-Incomplete: Manually created links that could not be fully discovered.

  - Discovered-Incomplete: Links that could not be fully discovered. These partially discovered links are not shown on the topology map.
• Unknown: Existing links that are down and therefore can no longer be discovered. These links remain on the topology map for 6 hours but they are colored grey and are identified by an “?” icon on the link. Links with Unknown status can be deleted by selecting the link in the table and clicking the **Delete** button.

• See bandwidth utilization for optical (OTS, OTN, ODU), packet (physical, LAG), and cable (L2TP) links. The Utilization column for each side of the link shows the actual usage data (for example, number of channels for OTS links), the percentage of total capacity used, and the default time period for which utilization is calculated (1 hour). The Capacity column shows the total bandwidth capacity of the link.

**Note** To show utilization for packet and cable links, an Interface Health monitoring policy must be created and enabled on the relevant devices. See [Set Up Basic Interface Monitoring, on page 205](#) for more information.

<table>
<thead>
<tr>
<th>Type</th>
<th>A End</th>
<th>A End Utilization</th>
<th>Z End</th>
<th>Z End Utilization</th>
<th>Capacity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Physical</td>
<td>Critical GigEEth...</td>
<td>9% (1.260099e-7 Gbps) 1h</td>
<td>GigEEth...</td>
<td>0% (2.431279e-7 Gbps) 1h</td>
<td>1 Gbps</td>
</tr>
<tr>
<td>Physical</td>
<td>Clear GigaE...</td>
<td>9% (1.574779e-7 Gbps) 1h</td>
<td>Clear GigaE...</td>
<td>0% (4.537592e-7 Gbps) 1h</td>
<td>1 Gbps</td>
</tr>
<tr>
<td>Physical</td>
<td>Clear GigabitGigabit...</td>
<td>9% (0.600044390136 Gbps) 1h</td>
<td>Clear GigabitGigabit...</td>
<td>0% (0.30003330002 Gbps) 1h</td>
<td>16 Gbps</td>
</tr>
<tr>
<td>Physical</td>
<td>Clear GigabitGigabit...</td>
<td>9% (0.60007105515 Gbps) 1h</td>
<td>Clear GigabitGigabit...</td>
<td>0% (0.00007004112 Gbps) 1h</td>
<td>16 Gbps</td>
</tr>
<tr>
<td>Physical</td>
<td>Clear GigabitGigabit...</td>
<td>9% (0.2127232e-9 Gbps) 1h</td>
<td>Clear GigabitGigabit...</td>
<td>0% (0.00000102271 Gbps) 1h</td>
<td>1 Gbps</td>
</tr>
<tr>
<td>Physical</td>
<td>Clear GigabitGigabit...</td>
<td>9% (0.619419e-6 Gbps) 1h</td>
<td>Clear GigabitGigabit...</td>
<td>0% (1.9693405e-7 Gbps) 1h</td>
<td>1 Gbps</td>
</tr>
<tr>
<td>Physical</td>
<td>Clear GigabitGigabit...</td>
<td>0.03% (0.002868682 Gbps) 1h</td>
<td>Clear GigabitGigabit...</td>
<td>0.03% (0.002868571 Gbps) 1h</td>
<td>1 Gbps</td>
</tr>
<tr>
<td>Physical</td>
<td>Clear GigabitGigabit...</td>
<td>0.05% (0.00047410090 Gbps) 1h</td>
<td>Clear GigabitGigabit...</td>
<td>0.01% (0.00006170 Gbps) 1h</td>
<td>1 Gbps</td>
</tr>
<tr>
<td>Physical</td>
<td>Clear GigabitGigabit...</td>
<td>9% (0.722009e-6 Gbps) 1h</td>
<td>Clear GigabitGigabit...</td>
<td>0% (0.596751e-6 Gbps) 1h</td>
<td>1 Gbps</td>
</tr>
<tr>
<td>Physical</td>
<td>Clear GigabitGigabit...</td>
<td>9% (0.716543e-6 Gbps) 1h</td>
<td>Clear GigabitGigabit...</td>
<td>0% (0.418490e-6 Gbps) 1h</td>
<td>1 Gbps</td>
</tr>
<tr>
<td>Physical</td>
<td>Clear GigabitGigabit...</td>
<td>1.25% (0.12504242 Gbps) 1h</td>
<td>Clear GigabitGigabit...</td>
<td>1.09% (0.10648439 Gbps) 1h</td>
<td>10 Gbps</td>
</tr>
<tr>
<td>Physical</td>
<td>Clear GigabitGigabit...</td>
<td>0.03% (0.00020062472 Gbps) 1h</td>
<td>Clear GigabitGigabit...</td>
<td>26.69% (0.2668724 Gbps) 1h</td>
<td>1 Gbps</td>
</tr>
<tr>
<td>Physical</td>
<td>Clear GigabitGigabit...</td>
<td>0.03% (0.00020062472 Gbps) 1h</td>
<td>Clear GigabitGigabit...</td>
<td>0.05% (0.00020062472 Gbps) 1h</td>
<td>10 Gbps</td>
</tr>
<tr>
<td>Physical</td>
<td>Clear GigabitGigabit...</td>
<td>17.36% (0.34864874 Gbps) 1h</td>
<td>Clear GigabitGigabit...</td>
<td>0.04% (0.00077391148 Gbps) 1h</td>
<td>2 Gbps</td>
</tr>
<tr>
<td>Physical</td>
<td>Clear GigabitGigabit...</td>
<td>1.1% (0.109563566 Gbps) 1h</td>
<td>Clear GigabitGigabit...</td>
<td>1.24% (0.1243847 Gbps) 1h</td>
<td>10 Gbps</td>
</tr>
</tbody>
</table>

• Depending on the link type, perform an action by choosing a link and making a selection from the **Actions** drop-down menu. (For example, for OTS links, you can run an OTDR Scan).

• View a specific link on the topology map by clicking **Actions > Network Topology**.

---

**Troubleshoot Link Issues**

This section presents suggested solutions for issues you might encounter when working with links.
<table>
<thead>
<tr>
<th>Link Issue</th>
<th>Possible Cause</th>
<th>Solution</th>
</tr>
</thead>
</table>
| Links that previously existed disappear from the topology map. | The hostname might have been changed on one of the endpoint devices. | 1. Delete the device on which the hostname was changed from the system and then add it again.  
2. Sync the device and all devices connected to it to make sure that all information is updated. |

**Show Bandwidth Utilization for Links on the Map**

In the topology map and in the geo map, you can enable visualization of how much bandwidth is utilized on optical links (OTS, OTN, and ODU), packet links (physical and LAG), and cable links (L2TP) over which circuits are provisioned. In this way, you can easily identify when a link is over-utilized or approaching over-utilization.

To enable bandwidth utilization, click on the arrow next to the Bandwidth Utilization icon in the top right corner of the topology map or the geo map and select the Utilization check box. For physical and LAG links, you can select the time frame in which to show the link utilization by clicking the arrow next to the Utilization check box.

When bandwidth utilization is enabled, a thicker link is shown in the map and is colored based on bandwidth utilization thresholds. Click the "?” icon in the Utilization panel at the top right of the map to see the color representations for bandwidth utilization on the supported link types. The thresholds for bandwidth utilization coloring can be set up in Administration > Settings > System Settings > Maps > Bandwidth Utilization. See Define Color Thresholds for Link Bandwidth Utilization, on page 174.

Bandwidth utilization data is provided in all link-related views, for example, the Link panel that is displayed when you click on a link, Links tables, the Link 360, and so on, even if bandwidth utilization visualization is disabled.

Bandwidth utilization is calculated as follows:

- For OTS links between NCS 2000 devices, link capacity is calculated from the fiber-attributes parameters configurable on the devices. If OTS links are configured to allow SSON circuits (channel number is set to "Nyquist"), capacity is assumed to be 96 channels. Bandwidth utilization is calculated in terms of the number of 50Ghz ITU channels used in relation to the capacity. For SSON circuits the result is approximated because each Carrier NC or Carrier Trail counts as one channel used, regardless of its actual size.

Click on the i icon in the Utilization column to display a dialog showing details of exactly which channels are being used and which circuits are using the channels.

**Note**
The dialog shows only 50Ghz ITU wavelengths/frequencies, therefore SSON carrier circuits might not be shown.

- For OTN and ODU links, bandwidth utilization is calculated based on the number of ODU0 timeslots reserved and is represented in gigabits per second.

---

Cisco Evolved Programmable Network Manager 3.0 User and Administrator Guide 173
For physical and LAG links, bandwidth utilization is calculated from the input and output data rate of the link interfaces. For these link types you can define whether you want to see the average utilization or the peak utilization. You can also specify the time period for which you want to show utilization data—15 minutes, 1 hour, 6 hours, or 1 day.

For cable L2TP links, L2TP utilization is calculated for available L2TP tunnels. If L2TP tunnels are present then L2TP link utilization is calculated per RPD by getting the OFDM channels utilization of the associated downstream controller.

To show utilization for packet and cable links, an Interface Health monitoring policy must be created and enabled on the relevant devices. See Set Up Basic Interface Monitoring, on page 205 for more information.

---

**Define Color Thresholds for Link Bandwidth Utilization**

When bandwidth utilization visualization is enabled, links in the map are colored based on the percentage of total bandwidth currently utilized on the link. See Show Bandwidth Utilization for Links on the Map, on page 173. Default thresholds are defined by the system, however, you can define your own thresholds to determine how bandwidth utilization will be reflected on the links.

To define color thresholds:

1. **Step 1** Select **Administration > Settings > System Settings > Maps > Bandwidth Utilization**.
2. **Step 2** Select the type of link for which you are defining thresholds.
3. **Step 3** In the Link Coloring Thresholds area, define the criteria for coloring the links. Each row defines a color and the bandwidth percentage range that the color will represent. The default thresholds are: Green - 0-25%, Yellow - 26-50%, Orange - 51-75%, and Red - 76-100%.

Note the following:

- A maximum of 4 thresholds can be defined.
- The first threshold must start from zero and the last threshold must end with 100.
- The thresholds must be sequential, meaning that each row's range must follow on from the previous row's range. For example, if the range in row 1 is 0-25%, row 2's range must start with 26%.

4. **Step 4** Click **Save**.

If you enable bandwidth utilization visualization in your map, the links will be colored according to these thresholds.

---

**View Fault Information for Devices and Links**

If a device or link has an alarm associated with it, an alarm badge is displayed on the device icon or on the link in the topology map. The color of the alarm badge corresponds with the alarm severity—minor (yellow), major (orange), or critical (red)—and matches the alarms displayed in the Alarm Browser.
For groups, the alarm badge represents the most severe alarm that is currently active for any of the group members.

Link-related alarms, such as Link Down, generate an alarm badge on the relevant link in the topology map. After the link up alarm is received, the link alarms and corresponding badges are cleared.

See Alarm Severity Icons, on page 233 for more information.

Change the Layout of a Network Topology Map

When you first open the topology map, it is displayed according to the default global layout. The global layout can be changed by users with network topology "edit" privileges. Any changes you make in the map are maintained for the current browser session only, meaning that when you next open the map, the global layout will be applied. If you want your own map layout to be preserved for future sessions, you can save your layout. Your saved layout overrides the global layout.

Click the Layout icon in the topology toolbar to access the layout options.

• A checkmark indicates which layout is currently being used. For example, a checkmark next to "Load" under Global Layout indicates that the global layout is currently being used.
• If you move devices around in the map and you want to save the new layout as the global layout for all users, click **Save** under **Global Layout**. This option is only available for users with network topology "edit" privileges.

• If you move devices around in the map and you want to save your own layout for the next browser session, click **Save** under **User Layout**.

• If the global layout is being used and you want to use your own saved layout, click **Load** under **User Layout**.

You can specify how the devices and other network elements (such as labels, nodes, and the connections between them) are arranged in the topology map by dragging them to the required position in the map or by selecting one of the predefined options:

• Symmetrical (default)—Maintains the symmetry that is inherent in the topology. This ensures that adjacent nodes are closer to each other and prevents node overlapping.

• Circular—Arranges the network elements in a circular style highlighting the clusters inherent in the network topology.

• Hierarchical—Ensures that the dependencies on the relationships and flows between elements are maintained.

• Incremental—Maintains the relative positions of specific elements while adjusting the positions of newly added elements. Use this layout to re-render nodes/links and to clean up overlaps.

---

Add a Background Image to the Network Topology

A background image can be applied to the topology map for any selected group. This is useful if, for example, you want to group your network according to geographic location. A sub-group can have a different image from its parent group. For example, you could apply a country map to one group and state maps to its sub-groups. Background images are saved per group and per user.

When a background image is applied, zoom functionality is supported and devices maintain their location on the image as you zoom in and zoom out.

The system provides some predefined images that you can select as background images. Alternatively, you can use your own custom background images.

**Before you begin**

When adding a custom background image, follow these guidelines:

• The background image file must reside on the server in a directory that is covered by high availability (HA), meaning that it will be moved to the secondary server in the case of primary server failure.

• Images should be in .png or .jpg format (.png is recommended).

• The file size should be as small as possible because the time taken to render the map is directly proportional to the size of the image.

---

**Step 1** In the left sidebar, choose **Maps > Topology Maps > Network Topology**.

**Step 2** In the Network Topology window, click the **Add Background Image** icon in the topology toolbar. The Manage Group Background Image dialog opens.

**Step 3** Choose the required group from the Select Group drop-down list.
Visualize and Trace Circuits/VCs

When working with circuits/VCs, it is very useful to see how a circuit/VC is deployed within the existing network topology. Cisco EPN Manager overlays the circuit/VC on an existing topology map, clearly indicating the endpoints and midpoints of the circuit/VC, the role of the endpoint (where relevant), and relevant fault information for the circuit/VC. If the selected group does not contain all the devices participating in the circuit/VC, a popup is displayed asking if you want to switch groups to show the full overlay. See View and Manage Discovered/Provisioned Circuits/VCs, on page 583 for more information.

Display Routes of a Circuit

For optical and CEM circuits, you can display routes associated with a specific circuit.

To do this use the Routes drop-down menu in the topology toolbar. The Routes menu calculates the routes from the links within a service. You can also see more data about the circuit routes. For example, the working path is represented with a ‘W’ label and the Protected path with a ‘P’ label on the links. See Display the Routes Associated With a Circuit, on page 604.

For Optical Channel (OCH) circuits, you can launch the Chassis View of a participating device and view the end-to-end physical route of the circuit. To do this, choose an OCH circuit for which you want to view the physical route. From the map, click any of the participating device to launch the Chassis View. The Chassis View displays the physical routes of the circuit. The internal connections between the ports of the same card are displayed as dotted lines. Use the eye icon in the Chassis View to show or hide the physical routes, power levels, and span loss.

Trace and Visualize the Full Route of a Circuit

You can do a full multi-layer trace of a circuit from the Network Topology window. See Trace and Visualize the Full Route of Circuits/VCs, on page 635 for more information.

Show Clock Synchronization Networks on a Network Topology Map

If Synchronous Ethernet (Sync-E) or Precision Time Protocol (PTP) clock synchronization is configured on the devices in your network, you can visualize the clock synchronization network on the topology map.

• The Sync-E overlay shows the topology and hierarchy of the sync-E network, including the primary clock and the primary and secondary clock inputs for each device. This allows the clock signal to be
traced from any Sync-E enabled device to the primary clock or from the primary clock to a Sync-E enabled device.

- The PTP overlay shows the clock synchronization tree topology, the PTP hierarchy, and the clock role of each device in the tree - master, boundary, slave, or transparent.

---

**Step 1**
In the left sidebar, choose Maps > Topology Maps > Network Topology.

**Step 2**
Click on the Device Groups button, select the required device group(s), and click Load.

**Step 3**
Click Show in the topology toolbar and choose Technology. Click the question mark icon for a description of what will be displayed on the map for each technology.

**Note**
Bandwidth Utilization option should be disabled before choosing Technology.

**Step 4**
Select the required technology and click OK.

The clock synchronization network is shown as an overlay over the existing network in the map. The legend at the bottom right explains the notations used in the map for the selected technology.

**Note**
If you select a different device group, the technology overlay will be removed.

---

**Show Routing Networks on the Topology Map**

Routing protocols used in your network can be graphically represented as an overlay on the topology map. Overlay of the following routing protocols is supported:

- **OSPF:**
  - The OSPF overlay shows the different OSPF domains in the network and the links between them, which are labeled as inter-area OSPF links. The overlay shows the OSPF area ID to which each link belongs and the role of each router, for example, Area Border Router (ABR), Designated Router (DR), and so on.
  - OSPF overlay is supported on devices running IOS-XE (ASR 90x, ASR 920, and NCS 42xx devices) as well as devices running IOS-XR (ASR 9000, NCS 4000 devices). OSPF overlay is also supported on XR-XE cross-platform devices.

- **BGP:**
  - The BGP overlay labels each device with the ID of the autonomous system to which it belongs and shows the links within and between autonomous systems.
  - If two connected routers belong to the same autonomous system, the link is an internal BGP link. If they belong to different autonomous systems, the link is marked as an external link.
  - Each unique autonomous system has a different color so that you can easily identify devices belonging to the same AS.
  - The overlay also marks the devices that serve as route reflectors or route clients.
  - BGP overlay is supported on ASR 920, ASR 901, ASR 901_10G, NCS 42xx and ASR 9000 devices.
• ISIS:

  • The ISIS overlay shows the devices (Intermediate Systems - IS) running ISIS as the Interior Gateway Protocol (IGP). Above these devices, you will see a notation that indicates the IS type, the area ID which identifies the different ISIS domains, and an indication if the device is a Designated Intermediate System (DIS). The notation shows the first 6 bytes of the NET address. Hovering over the notation displays a tooltip containing the complete NET address and the process ID.

  • The IS type can be L1 for intra-area routing, L2 for routing between areas, or L1L2 for both intra- and inter-area routing.

  • Each ISIS domain is represented in a different color.

  • A notation on the links in the ISIS network indicates the ISIS adjacency. For aggregated links where multiple adjacency types exist, multiple adjacency type notations will be shown on the link.

  • ISIS overlay is supported on devices running IOS-XE (ASR 903, ASR 907, and NCS 42xx devices) as well as devices running IOS-XR (ASR 9000, NCS 4000 devices).

---

**Note**

DIS indication is presented on the device level and not in the context of a specific IS level.

Following is an example of an ISIS overlay in the map:

![ISIS Overlay Example](image)

To show a technology overlay in the map:

**Step 1** In the left sidebar, choose **Maps > Topology Maps > Network Topology**.
View OMS Links

In EPNM, view the auto discovered OMS links for ROADM devices that are connected by means of sequence of OTS links. You can view the multitrace view of the OMS links, Circuit/VCs 360* view, and the characteristics of OMS links and alarm link layers of OMS.

To view the multitrace view of OMS links:

- Choose Administration > Maps > Topology.
- Click Circuit/VCs, choose the device then click the Multilayer Trace link to view the connected links. For example, the following image shows the multitrace view of OMS links along with OCH and OPS link layers.
Use the **Type** filter to select and view only the OMS link and its network.

To view the characteristics of the OMS link:
• Click the Show button and view where the OMS link is used in the Link Details dialog box. For the selected OMS link type, view the endpoints, the planned circuit VCs, if any and the sequence of OTS link details.

*Figure 4: Link Details and Link 360° View*

- Click the $i$ icon next to the OTS link name to view the Link 360° view of the OMS link type.
- View the alarm link layers for OMS links.
Save the Topology Map as an Image File

You can save the entire topology map or selected objects from the topology map as an image file. This will enable you to store copies of the topology map in a specific state which you can use as a point of reference in the future when multiple changes are made to the topology.

To save the topology map as an image file:

**Step 1** Choose Maps > Topology Maps > Network Topology.

**Step 2** Click on the Device Groups button, select the required device group(s), and click Load.

**Step 3** Make content and layout changes to the topology map as required.

**Step 4** Click the Save Image icon in the topology toolbar.

**Step 5** In the Save As Image dialog box, select the file type for the saved image.

**Step 6** Choose whether you want to save the entire topology or only the items currently selected in the topology map.

**Step 7** Choose a size setting for the image file.

**Step 8** Click OK. The image is saved in your local Temp folder.

View Your Network on a Geographical Map (Geo Map)

- Geo Map Overview, on page 184
Geo Map Overview

The geo map enables you to position your network devices on a world map and monitor them within their geographical context. The displayed world map is either imported by accessing the map provider's site over the Internet (online mode) or from locally installed map resources (offline mode).

Note

When working with the geo map in online mode, a connection to the Internet is required from each client or from the Cisco EPN Manager server if it is being used as a proxy.

The geo map is accessed via the topology map. To open the geo map:

Step 1  In the left sidebar, select Maps > Topology Maps > Network Topology
Step 2  Click on the Geographical Map toggle button in the top right corner of the map.

About the geo map:

- You can switch back and forth between the topology map and the geo map using the toggle buttons in the top right corner of the map.
- The geo map displays devices for which GPS coordinates have been defined. Devices that do not have GPS coordinates do not appear on the geo map and are called “unmapped devices.” See Place Unmapped Devices on the Geo Map, on page 186.
- You can click on a device in the geo map to see alarms, basic information, location coordinates and civic location (if it has been defined for the device).
- For optical devices that support GPS location configuration (NCS 2000 devices), any change that is made to the device's location in the geo map is synched with the device and vice versa (location changes made on the device itself will be reflected in the geo map).
- GPS coordinates are shown in DMM format (degrees and decimal minutes) but users can define GPS coordinates in DMM, DD (Decimal Degrees), or DMS (Degrees, Minutes, and Seconds) formats.
- If there are no devices on the geo map, the full world map is shown. If there are devices in a specific area, only that area of the world will be shown. The geo map shows only the portion of the world map that contains devices.
• As in the topology map, the geo map shows the devices in the selected device group. The device group selection is synchronized between the topology map and the geo map such that if you change the selection in one map, it will change in the other map as well.

• If there is a device group that has a defined geographical location within the selected device group it will be represented in the geo map with a device group icon. If the device group does not have a geographical location, its contained devices will be shown individually in the geo map. See Device Groups in the Geo Map, on page 185 for more information.

• The geo map groups devices that are close to one another geographically in clusters, represented by a cluster icon with a number indicating the number of devices in the cluster. Zoom in to see the individual devices. See Identify the Members of a Cluster, on page 189.

• As in the topology map, you can show a circuit/VC in the geo map. However, when initiating provisioning actions such as creating a circuit/VC or modifying a circuit/VC, the view will switch to the topology map.

Device Groups in the Geo Map

In addition to individual devices, the geo map shows device groups that have a defined location, for example, devices in a building at a specific address.

Take the following into consideration when viewing groups in the geo map:

• Only location-type device groups can be shown in the geo map, and they are only visible if they have a defined geographical location. The location is defined in the device group properties. To create or edit a location device group and define the geographical location of the group, go to Inventory > Group Management > Network Device Groups. See Create Location Groups, on page 65 for more information.

• Group members inherit the location of the group.

• If a group's location is the same as other devices/groups, it will be included in a cluster. The number displayed on the cluster icon represents the total number of devices in the cluster (including devices contained in groups).

• If there are alarms on any of the devices within a group, the highest severity alarm icon will be displayed on the device group icon.

• Click on the location group icon to see a panel containing information about the group, including its name, GPS coordinates, and alarm information. If civic location information is defined for the group, it will also be shown in this panel. Click on the Show Members link in the panel to show a list of the devices and sub-groups that belong to the group. Alternatively, double-click on the location group icon to achieve the same results.

• If a group member device is given a geographical location, the device will be shown on the geo map as an individual device and alarms will be shown on the device itself, not on the group. It is preferable to have all devices in a geographical location group inherit the GPS coordinates of the group in order to retain the significance of the group's location.

Geo Map Setup

The system is set up by default to get the map tiles from a specific Mapbox URL through a direct Internet connection from the client or via the EPN Manager server which acts as a proxy. If required, you can use a different map tiles provider by providing a specific URL. Both of these options require an Internet connection.
If you do not have an Internet connection, you can install the map resources locally and specify that you want the system to use the local map resources, which means that you are effectively working in offline mode.

The geo map setup can be managed in the System Settings. In the left navigation pane, select **Administration > Settings > System Settings > Maps > Network Topology.** In the Network Topology page, you can do the following:

- Enable/disable the geo map. By default, geo map is enabled, meaning that all clients will have the geo map functionality. You can deselect the **Enable geo map** checkbox to disable the functionality.
- Identify the source for the map tiles (using an Internet connection). The default map tiles provider is Mapbox. If you are working with another map tiles provider, you need to provide the URL for map tiles access. Be sure to request the exact format of this URL from the map tiles provider. Select **Custom** in the Map Provider dropdown list and enter the URL. Note that the geo map functionality has not been tested with map tiles from providers other than Mapbox.
- Make the Cisco EPN Manager server a proxy for accessing the Internet to retrieve the map tiles. For security reasons, you might not want direct Internet access from each client. If you enable the **Via management application proxy** check box, Internet access to the map provider URL is via the Cisco EPN Manager server, not directly via the clients.
- Specify that you want to display the geo map using installed map resources that do not require a connection to the Internet. Select **Installed Map Resources** in the Map Provider dropdown list. Refer to the **Cisco Evolved Programmable Network Manager Installation Guide** for instructions on how to install the map resources.

### Identify Which Devices are not Showing on the Geo Map (Unmapped Devices)

For any selected device group, only the devices that are defined with GPS coordinates will automatically be shown on the geo map. When you switch to the geo map or when you select a different device group, a popup message will indicate how many unmapped devices there are, meaning how many devices that do not have coordinates and therefore do not appear on the map.

To identify which devices are not being shown on the geo map, click the **Unmapped Devices** button above the map.

### Place Unmapped Devices on the Geo Map

You can either drag and drop unmapped devices onto the required location on the geo map or you can specify the GPS coordinates to define the device’s location on the geo map.

GPS coordinates can be specified in any of the following formats:

- Degrees and decimal minutes (DMM): 41 24.2028, 2 10.4418
- Decimal degrees (DD): 41.40338, 2.17403
- Degrees, minutes, and seconds (DMS): 41°24'12.2"N 2°10'26.5"E

**Note**

When using DMS format, please use a double quotation mark (""") to indicate the seconds.

To place unmapped devices on the geo map:
Step 1 In the left sidebar, select Maps > Topology Maps > Network Topology
Step 2 Click on the Geographical Map toggle button in the top right corner of the map.
Step 3 Click the Unmapped Devices button above the map.
Step 4 In the Unmapped Devices panel on the right, either:
  a) Drag and drop a device onto the map or select multiple devices and drag and drop them onto the map.
  b) Select the device(s) you want to place on the map and click Set Location. In the displayed dialog, specify the GPS coordinates, for example, Latitude 59.623325, Longitude-103.535156. Click Place Device.

Note If you select multiple devices, they will be consolidated into a cluster and placed on the same location on the map. The cluster icon indicates how many devices the cluster contains.

Change the Location of a Device on the Geo Map

To move a device to a different location on the geo map, you need to open the Edit Location dialog and then either drag the device to the required location on the map or set the coordinates manually. If the device is in a cluster, you must open the cluster to view the devices and then change the location of the device.

GPS coordinates can be specified in any of the following formats:

- Degrees and decimal minutes (DMM): 41 24.2028, 2 10.4418
- Decimal degrees (DD): 41.40338, 2.17403
- Degrees, minutes, and seconds (DMS): 41°24'12.2"N 2°10'26.5"E

Note When using DMS format, please use a double quotation mark (""") to indicate the seconds.

To change the location of a device:

Step 1 Click on the device on the geo map. A popup appears showing basic device information and alarm information for the device.
Step 2 Click Edit Location. The Edit Location dialog opens.
Step 3 Drag the device to the required location or change the GPS coordinates as required.
Step 4 Click Save.

Change the Location of a Device in a Cluster

Devices that are very close to each other in location are grouped in a cluster on the geo map. You can change the location of one or more of the devices in the cluster. The device will be removed from the cluster and will appear on the geo map as an individual device.

To change the location of a device in a cluster:
Step 1  Click on the cluster in the geo map. A popup appears showing basic information for the cluster.
Step 2  Click Show Devices. A panel is displayed to the right of the map and lists all the devices in the cluster.
Step 3  In the panel on the right, either:
    a) Drag and drop a device onto the map or select multiple devices and drag and drop them onto the map.
    b) Select the device(s) you want to place on the map and click Set Location. In the displayed dialog, specify the GPS coordinates, for example, Latitude 59.623325, Longitude-103.535156. Click Place Device.

The device(s) will be removed from the cluster and placed in the specified location on the map.

Remove a Device from the Geo Map

If you no longer want to display a device on the geo map, you can remove it. The removed device will appear in the Unmapped Devices list.

To remove a device from the geo map:

Step 1  Click on the device on the geo map. A popup appears showing basic device information and alarm information for the device.
Step 2  Click Edit Location.
Step 3  In the Edit Location dialog, click Remove Location.

Remove a Clustered Device from the Geo Map

Devices within clusters can be removed from the geo map. You can remove an individual clustered device or you can remove multiple devices in the same cluster at one time. The removed device(s) will appear in the Unmapped Devices list.

To remove clustered devices from the geo map:

Step 1  Click on the cluster containing the device(s) you want to remove. A popup appears showing basic device information and alarm information for the device.
Step 2  Click Show Devices. A list of the devices contained in the cluster is displayed.
Step 3  Select the device(s) you want to remove.
Step 4  Click Set Location.
Step 5  In the displayed dialog, click Remove Location.
Step 6  Click Yes in the warning message informing you that the devices will be moved to the Unmapped Devices list.
Identify the Members of a Cluster

A cluster is formed when two or more devices or device groups are located close to one another on the map. The cluster is represented on the geo map by a circle with a number in its center, indicating the number of devices in the cluster (including individual devices and devices within groups). Zoom in to see the individual cluster members on the map.

---

**Note**

If cluster members are very close to each other (approximately 8 meters apart or less), zooming in will not show the individual devices/groups. Follow the procedure below to see the individual members of the cluster.

To see a list of the devices/groups in a cluster:

---

**Step 1**
Click on the cluster icon.

**Step 2**
In the displayed popup, click **Show Members**. The devices or device groups contained in the cluster are listed in the panel to the right of the map. If the cluster contains groups, you can drill down to see the devices in the group. Use the navigation links at the top of the dialog to return to the previous list.

**Step 3**
You can change the location of a device by dragging it from the list onto the map or by clicking **Set Manually** and specifying new coordinates.

---

Search for a Specific Location in the Geo Map

You can search for a specific location in the geo map, for example, a state, country, town, or a specific address. If you enter a keyword in the search box, the results will show all locations that contain that keyword, down to the level of a specific street. You can then select the required location in the search results to pinpoint it in the map.

---

**Note**

Internet connectivity is required to perform this location search.

To search for a specific location in the geo map:

---

**Step 1**
Click the **Search** icon in the toolbar.

**Step 2**
Type the full or partial result in the search text box and press **Enter**. The Address tab in the search results panel lists locations that match your search.

**Step 3**
Select a location in the search results. The map pans and zooms to the specified location and a marker on the map indicates the exact location.

---

Location Filter in the Geo Map

To use the location filter in the geo map:
**Step 1**  
Go to the **Map > Topology Maps > Network Topology**, click the **Show** button and select **Location**.

**Step 2**  
In the **Location** pop-up window, check the **Enable Filter** option. Specify values for any of the following fields:

- **Civic location**: any civic location, regardless of the location the device.
- **Latitude/Longitude**: location coordinates (you can also click on the map, and the values are automatically populated)
- **Location by Device name**: name of the device (from the list of devices currently displayed in Geo Map).

**Step 3**  
Specify value for the **radius**, and all devices within the prescribed search area are displayed.

**Step 4**  
Once completed, click **Save**.

---

**View Link Layers in the Geo Map**

In the geo map, you can see a three-dimensional view of the links in your network, separated by link type.

Click the Link Layers icon on the right to access the 3D link layers view. Click the icon again to return to the full geo map.

The 3D link layers view consists of up to three separate layers. The lower layer shows the geo map with all its links and devices. The two upper layers show links of a specific link type category (e.g., physical layer, control plane, and so on), together with the relevant devices. The layers shown in the 3D link layers view correspond with the link type categories currently selected for display in the link filter (click the Filter icon in the toolbar and select Link Types).

---

**Note**  
Several operations such as pan, zoom, filter, and search are not available in the 3D link layers view.

---

**View and Manage Optical Fiber Paths in the Geo Map**

To view optical fibers in the geo map, you must create a KML file with the location data for the fibers and import it into Cisco EPN Manager. For information about importing fiber location data, see [Import Location Data from a KML File](#), on page 194.

After you import a KML file that contains fiber location data, the fibers are shown on the geo map. If you do not want to see them on the map, go to **Show > Links** and deselect **Fiber** under Physical Layer links.

Optical fibers are represented as follows in the geo map:
See Manage Fiber Paths, on page 191 and Associate Links to Fibers, on page 192 for information about editing/deleting fibers and associating fibers to links.

Manage Fiber Paths

Fiber paths that are displayed in the geo map can be edited, deleted, or associated to links in the Fiber Management dialog. Click the **Fibers** button in the geo map toolbar to open the Fiber Management dialog.

Note the following:

- The Fiber Management dialog lists fibers that are currently visible in the map only. If you cannot see the fibers in the geo map, they will not appear in the Fiber Management dialog. Set up your geo map so that the fibers you want to manage are being displayed.

- When you select a fiber in the Fiber Management dialog, the selected fiber is highlighted in purple in the geo map. If the fiber is associated with a link, the link will also be highlighted in purple in the map. When you click on a fiber in the geo map, the fiber is selected in the Fiber Management dialog.

- To show additional details about a specific fiber, click the arrow next to the fiber name to show the fiber description.

- You can edit the fiber name, length (in km), and description. To edit a fiber, select it in the list and click the **Edit** button. Click **Save** when you have completed your edits.

- To delete fibers, select the required fibers and click the **Delete** button.

- The Associated Link column shows the link to which the fiber is associated (if any). You can disassociate the link if necessary by selecting the fiber and clicking the Remove Fiber to Link Association icon above the table. See Associate Links to Fibers, on page 192 for more information.
Associate Links to Fibers

A fiber can be associated to an OTN or OTS link so that you can visualize both the fiber and its associated link on the map. To associate a fiber to a link, you must populate a KML file with the necessary information and then import the KML file into the system.

A KML template that outlines the format for providing fiber-link associations can be downloaded and then imported after you have added the required information.

To associate a link to a fiber:

---

Step 1  Download the KML template that contains the correct KML format and instructions for fiber-link associations:

- Click the **Import** icon in the geo map toolbar and choose **KML**.
- Download the KML template by clicking the link at the bottom of the displayed dialog.
- In the KML file, locate the folder called "Links association info". This folder contains the format and instructions for creating a fiber-link association.

Step 2  Enter the required information in the KML file, save it, and then import it into the system. See Import Location Data from a KML File, on page 194.

Step 3  In the geo map, check that your fibers are displayed, then click on **Fibers** in the toolbar. In the Fiber Management dialog, the links should show up in the Associated Links column. You can remove the link association by selecting the fiber and clicking the Remove Fiber to Link Association icon above the table.

---

Visualize Circuits/VCs on the Geo Map

The circuit/VC overlay functionality in the geo map is very similar to overlay in the topology map. However, because of some differences in the functioning of the maps, a few items regarding overlay functionality in the geo map need to be noted:

- To overlay a circuit on the geo map, select the circuit/VC in the Circuits/VCs tab on the left, as you would in the topology map.

- Select the **Show Participating Devices Only** check box to remove all devices from the map except for those participating in the selected circuit/VC.

- Click the **Participating Devices** link to show a list of all the devices participating in the circuit/VC. The list shows the role of the devices, for example, A-side and Z-side, and you can change the location of the devices or remove them from the map.

- If a participating device is in a cluster on the geo map, the badge denoting the role of the device is shown on the cluster icon. Zoom in to see the individual devices so that you can see exactly which device the role badge is marking. Alternatively, click on the **Participating Devices** link to see all the devices and their roles in the circuit/VC.

- If some of the participating devices are not currently displayed on the map, a message will be displayed and will enable you to open the list of unmapped devices. You can place them on the map by dragging and dropping the devices or click **Set Location** and enter their GPS coordinates.
Import Location Data

In addition to manually placing devices on the geo map, you can specify the coordinates of devices or fibers in an external file and then import the file. The system reads the coordinates from the file and places the devices/fibers on the map. This is useful for locating items on the map in bulk or for transferring location data from another system. You can also export your existing locations from the geo map, make changes, and then import the data back into the system.

You can import:

- Device locations from a CSV or KML file
- Device and fiber path locations and manually-created managed links from a KML file.

Keyhole Markup Language (KML) is a file format used to display geographic data in two- or three-dimensional maps or in Earth browsers like Google Earth. KML is based on the XML standard and uses a tag-based structure with nested elements and attributes.

For both file formats you can download a template from the GUI which will guide you as to the format in which you need to enter the information so that the system can read it. To download the template, click on the Import Locations icon above the geo map, select one of the options, and click on the template link.

See Import Device Locations from a CSV File, on page 193 and Import Location Data from a KML File, on page 194 for more information.

Import Device Locations from a CSV File

Device locations can be imported from a CSV file. The devices will be placed on the map according to the coordinates you specify in the file.

For CSV file import, GPS coordinates can be specified in any of the following formats:

- Degrees and decimal minutes (DMM): 41 24.2028, 210.4418
- Decimal degrees (DD): 41.40338, 2.17403
- Degrees, minutes, and seconds (DMS): 41°24′12.2″N 2°10′26.5″E

When using DMS format, please use a double quotation mark ("" ) to indicate the seconds.

To import device locations from a CSV file:

**Step 1**
Click the **Import Locations** icon in the geo map toolbar and choose **Device locations only** (CSV).

**Step 2**
Optionally download the CSV template by clicking the link at the bottom of the displayed dialog.

**Step 3**
Enter the IP address and longitude and latitude coordinates for each device in the CSV file and save it.

Following is an example of the format of the location information in the CSV file:

<table>
<thead>
<tr>
<th>IP Address</th>
<th>Longitude</th>
<th>Latitude</th>
</tr>
</thead>
<tbody>
<tr>
<td>x.x.x.x</td>
<td>-121.95823</td>
<td>37.41023</td>
</tr>
<tr>
<td>x.x.x.x</td>
<td>8 30.175781 e</td>
<td>23° 15′ 23.45″ N</td>
</tr>
</tbody>
</table>
Step 4   In the Import Locations dialog, browse to the location of your .csv file and click **Place Devices**. The devices will be placed on the map in the locations you specified.

---

**Import Location Data from a KML File**

Keyhole Markup Language (KML) is a file format used to display geographic data in two- or three-dimensional maps or in Earth browsers like Google Earth. KML is based on the XML standard and uses a tag-based structure with nested elements and attributes. You can create a KML file with your device and fiber path location data and import it in order to place your devices and fibers on the geo map. The following location data can be included in the KML file:

- Device location data
- Fiber location data
- Fiber to link associations
- Manually-created managed links. After import, the managed links will be displayed in the topology map and in the geo map (if both endpoints of the managed link are "mapped" in the geo map).

A template is provided to guide you as to the required format in which to enter information within the KML file.

---

**Note**  Coordinates must be entered in Decimal degrees (DD) format, for example, 41.40338, 2.17403.

---

Following is an example of the KML format for device locations:

```kml
<Placemark>
  <name>454A-234-157</name>
  <Point>
    <coordinates>-121.930938,37.411522</coordinates>
  </Point>
  <ExtendedData>
    <Data name="nodeIpAddress">
      <value>10.56.23.47</value>
    </Data>
  </ExtendedData>
</Placemark>
```

Following is an example of the KML format for fiber paths:

```kml
<Placemark>
  <name>Fiber-1</name>
  <description>Fiber-1 long description</description>
  <LineString>
    <coordinates> -121.930938,37.41522,0.0 -121.931405,37.413011,0.0 -121.929364,37.413588,0.0 -121.930973,37.414602,0.0 </coordinates>
  </LineString>
</Placemark>
```

Following is an example of the KML format for fiber-link associations, where you must:

- Define one link association per folder, with the name "linkAssociation".
- Specify the segments of the fiber in the sequence that follows the A to Z path of the link to be associated.
• Specify the IP address of the A and Z sides of the link to be associated.

```xml
<Folder>
  <name>Links association info</name>
  <Folder>
    <name>linksAssociation</name>
    <description>OTS link-1</description>
    <ExtendedData>
      <Data name="segments">
        <value>Fiber-1,Fiber-1-to-2-segment,Fiber-2</value>
      </Data>
      <Data name="nodeAIpAddress">
        <value>10.56.23.47</value>
      </Data>
      <Data name="nodeZIpAddress">
        <value>2001:cdba:0000:0000:0000:0000:3257:9652</value>
      </Data>
      <Data name="nodeAInterfaceName">
        <value>LINE-2-17-3-TX</value>
      </Data>
      <Data name="nodeZInterfaceName">
        <value>LINE-1-1-3-TX</value>
      </Data>
      <Data name="linktype">
        <value>OTS</value>
      </Data>
    </ExtendedData>
  </Folder>
</Folder>
```

Following is an example of the KML format for fiber-link associations, where you must:

• Define one link association per folder, with the name "linkAssociation".

• Specify the segments of the fiber in the sequence that follows the A to Z path of the link to be associated.

• Specify the IP address of the A and Z sides of the link to be associated.

```xml
<Folder>
  <name>Links association info</name>
  <Folder>
    <name>linksAssociation</name>
    <description>OTS link-1</description>
    <ExtendedData>
      <Data name="segments">
        <value>Fiber-1,Fiber-1-to-2-segment,Fiber-2</value>
      </Data>
      <Data name="nodeAIpAddress">
        <value>10.56.23.47</value>
      </Data>
      <Data name="nodeZIpAddress">
        <value>2001:cdba:0000:0000:0000:0000:3257:9652</value>
      </Data>
      <Data name="nodeAInterfaceName">
        <value>LINE-2-17-3-TX</value>
      </Data>
      <Data name="nodeZInterfaceName">
        <value>LINE-1-1-3-TX</value>
      </Data>
      <Data name="linktype">
        <value>OTS</value>
      </Data>
    </ExtendedData>
  </Folder>
</Folder>
```
To import location data from a KML file:

- **Step 1** Click the **Import** icon in the geo map toolbar and choose **KML**.
- **Step 2** Optionally download the KML template by clicking the link at the bottom of the displayed dialog.
- **Step 3** Create a KML file and enter device/fiber/link data using the format and information in the template as a guide. Save the KML file.
- **Step 4** In the Import KML dialog, browse to the saved KML file and click **Import**. The devices and fibers will be placed on the geo map in the locations you specified. Managed links will be displayed in the topology map. To see the imported managed links in the geo map, make sure that the devices on either side of the link are mapped in the geo map.

### Export Location Data from the Geo Map

You can export location data for devices, fibers, fibers with link associations, and manually-created managed links from the geo map to a KML file. Once you have the data in a KML file, you can edit it as required and then import it back into the geo map.

**Note** Fiber location data cannot be exported together with the other location data - it must be exported in a separate operation.

- **Step 1** Click the **Export KML** icon in the geo map toolbar.
- **Step 2** In the Export Options (KML) dialog, select the location data you want to export. Note that if you select Unassociated Fibers, the other options will be disabled because these fibers must be exported independently of the other location data.
- **Step 3** Click **Export**. A KML file with your selected location data is created.

### Manage Shared Risk Resource Groups (SRRGs) in the Geo Map

**Note** This feature is supported on optical devices and links only, specifically NCS 2000 and NCS 4000 devices and OTS, OTU and OCH links.

A Shared Risk Resource Group (SRRG) is a set of devices and links that share a common resource, which if it fails, would affect all the devices and links in the group and the circuits in which they participate. The devices and links in the group share the same risk of failure and are therefore considered to belong to the same SRRG. For example, links sharing a common fiber are said to be in the same SRRG because a fault with the fiber might cause all links in the group to fail.
Each SRRG has a 32-bit numeric identifier. For devices, the SRRG is configured on the global device level. For links, the same SRRG is configured on the A-side and Z-side interfaces.

The following SRRG functionality is available from the geo map, from the Shared Risks (SRRGs) button above the map:

- Visualization of the devices and links on which SRRGs have been configured.
- User-defined naming of an SRRG so that it is easier to identify than a numeric identifier.
- Creation of new SRRGs that can be assigned to SRRG resource pools.
- Cross-launch to the system settings window where you can create and manage SRRG pools and pool types.

When managing SRRGs, the map is filtered to show only devices that support SRRG.

For more information, see:

- About SRRG Pools and SRRG IDs, on page 197
- View Assigned and Unassigned SRRGs, on page 198
- Manage SRRG Assignments, on page 199
- Create and Manage SRRG Pools Types and Resource Pools, on page 199

### About SRRG Pools and SRRG IDs

Using SRRG pool types and resource pools, SRRGs can be grouped into categories for identification and ID allocation purposes. Each pool type has a range of SRRG IDs. You can create multiple SRRG resource pools of a specific pool type, each with a range of SRRG IDs that is within the range defined for the pool type. When you create a new SRRG for devices or links, you can assign it to a specific SRRG pool type and resource pool. The ID for the new SRRG will be created from the ID range of the selected resource pool.

Configlet Access permissions are required to manage SRRG pool types and pools.

See Create and Manage SRRG Pools Types and Resource Pools, on page 199 for more information.

### Pool Types

Before creating SRRG resource pools, you must create pool types. Pool types allow you to create categories of SRRGs according to your network.

There are 15 available pool types plus one pool type which is reserved. Each pool type has a range of IDs. The following table provides an example of SRRG pool type definitions:

<table>
<thead>
<tr>
<th>Pool Type ID</th>
<th>Binary</th>
<th>Pool Type Name</th>
<th>Range Start</th>
<th>Range End</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0000</td>
<td>Central Office</td>
<td>0</td>
<td>1048575</td>
</tr>
<tr>
<td>1</td>
<td>0001</td>
<td>ROADM Node</td>
<td>1048576</td>
<td>2097151</td>
</tr>
<tr>
<td>2</td>
<td>0010</td>
<td>ROADM Degree</td>
<td>2097152</td>
<td>3145727</td>
</tr>
<tr>
<td>3</td>
<td>0011</td>
<td>ROADM Add/Drop</td>
<td>3145728</td>
<td>4194303</td>
</tr>
</tbody>
</table>
After you have created pool types, you can create resource pools of a specific type. Each resource pool can have a range of IDs that is within the pool type's range. The pool ranges cannot overlap with one another.

You can assign new SRRGs to a specific resource pool. The SRRG's ID will be taken from the range defined for the resource pool.

The SRRG pool's identifier is 32-bit number which is made up of the following:

- **Bits 0-1**: Reserved. It will be set to 00
- **Bit 2**: Indicates that the SRRG is configured using Cisco EPN Manager. It will be set to 1.
- **Bits 3-7**: The groups/regions selected for the resource pool
- **Bits 8-11**: Pool type ID
- **Bits 12-31**: Pool ID range

**View Assigned and Unassigned SRRGs**

You can view a global list of the SRRGs configured on the managed devices. Since these SRRGs were discovered by the system or user-defined on specific devices or links, they are all "assigned" SRRGs. You can also see unassigned SRRGs. SRRGs can only be deleted from the system if they are unassigned.

Each SRRG has a numeric ID that cannot be changed but you can assign a label to the SRRG to provide a more easily identifiable name.

You can select an SRRG to show the devices/links to which it is assigned in the geo map.
To view and label SRRGs:

**Step 1** In the left sidebar, select Maps > Topology Maps > Network Topology.

**Step 2** Click on the Geographical Map toggle button in the top right corner of the map.

**Step 3** Click the Shared Risks (SRRGs) button above the map and select View and Name. The Shared Risk Resource Groups dialog is displayed. It contains two tabs showing assigned and unassigned SRRGs. Note that when viewing SRRG assignments, your device group selection is changed to the default All Locations group.

**Step 4** Select a SRRG to view it in the geo map. The devices and links on which the SRRG is defined will be highlighted in the map.

**Step 5** To rename a SRRG, click in the SRRG Label column alongside the relevant SRRG ID, type in the required unique name, and click Save.

**Note** SRRG Label column can be edited only for assigned SRRGs.

**Manage SRRG Assignments**

A simple wizard enables you to select specific devices and links, see which SRRGs are assigned to them and change the assignments as required.

To manage SRRG assignments:

**Step 1** In the left sidebar, select Maps > Topology Maps > Network Topology.

**Step 2** Click on the Geographical Map toggle button in the top right corner of the map.

**Step 3** Click the Shared Risks (SRRGs) button above the map and select Manage Assignments. The Manage SRRG Assignments wizard opens.

**Step 4** Select the devices/links for which you want to manage SRRG assignments. You can either click on the required devices/links in the map or click in the box in Step 1 of the wizard and select devices from the list.

**Step 5** Click Next. You will see a list of all the SRRGs common to all the devices/links you selected in the previous step. If an SRRG is assigned to one of the selected devices but not to the others, it will not be shown in the list. The SRRGs are color-coded based on whether they are the default on the device, assigned, or yet to be assigned. Click on the question mark icon to see the legend.

**Step 6** Click the Plus icon and select additional SRRGs for the selected devices/links or create a new SRRG on the fly by typing an SRRG name. If the name is unique, a Create New link will appear. Click on the link to create the SRRG.

**Step 7** If you created a new SRRG in the previous step, you can now choose a pool type and an SRRG resource pool of the selected type. The SRRG's ID will be taken from the range defined for the selected SRRG pool. The SRRG ID includes the bits for region and type in addition to the number within the range.

**Step 8** Click Next to see a summary of your selections and SRRG assignments.

**Step 9** Click Finish. You will be notified if the SRRG modification was successful. If it failed, an error dialog will provide details of the failure.

**Create and Manage SRRG Pools Types and Resource Pools**

Using SRRG pool types and resource pools, SRRGs can be grouped into categories for identification and ID allocation purposes. Each pool type has a range of SRRG IDs. You can create multiple SRRG resource pools...
of a specific pool type, each with a range of SRRG IDs that is within the range defined for the pool type. When you create a new SRRG for devices or links, you can assign it to a specific SRRG pool type and resource pool. The ID for the new SRRG will be created from the ID range of the selected resource pool.

**Note**
Configlet Access permissions are required to manage SRRG pool types and pools.

To create SRRG pool types and resource pools, go to Administration > System Settings > Inventory > Pool Types or select Pool Settings from the SRRGs menu in the geo map.

To create a new SRRG pool:

---

**Step 1**
Go to Administration > System Settings > Inventory > Pool Types and check the existing pool types for the relevant pool type for your new SRRG pool. If it doesn't exist, create a new pool type as follows:

a) In the SRRG Pool Types window, click the Plus icon to add a row to the table.
b) In the Name field, enter a unique name for the pool type that represents the grouping you want to create for the SRRGs. For example, "NCS 2000 devices".
c) In the Type ID field, enter an ID from 0 to 14. Refer to the table of pool type definitions in About SRRG Pools and SRRG IDs, on page 197 for guidance as to the available range of IDs per pool type ID.
d) Enter a value for the start and end of the ID range for this pool type. You can use the full range or a subset of the available range. The tooltip on the Start Range or End Range field displays the available range for the pool type.
e) Click Save.

**Step 2**
Create the SRRG pool as follows:

a) Go to Administration > System Settings > Inventory > SRRG Pool.
b) In the SRRG Pool window, click the Plus icon to add a row to the table.
c) In the SRRG Pool Details area, select the required pool type from the Type dropdown menu.
d) Enter a unique name for the SRRG pool and optionally, a description.
e) From the Group dropdown menu, select a device group for this SRRG pool.
f) Enter the start and end of the range of SRRG IDs for this pool. The range must be within the selected pool type's range.
g) Click Save.

The new SRRG pool is added to the SRRG Pools table. It will also be available for selection when creating an SRRG ID for selected devices or links.
PART IV

Monitor the Network

• Monitor Device and Network Health and Performance, on page 203
• Monitor Alarms and Events, on page 225
• Monitor Cisco ASR 9000 Network Virtualization (nV) Satellites and Cluster Services, on page 247
• Manage Reports, on page 259
Monitor Device and Network Health and Performance

• How Device Health and Performance Is Monitored: Monitoring Policies, on page 203
• Set Up Basic Device Health Monitoring, on page 204
• Set Up Basic Interface Monitoring, on page 205
• Use the Dashboards To Check Network and Device Health, on page 207
• Check What Cisco EPN Manager Is Monitoring, on page 208
• Check a Monitoring Policy’s Device, Polling, Threshold, and Alarm Settings, on page 211
• Adjust What Is Being Monitored, on page 211
• Check the Status of Past Monitoring Policy Data Collections, on page 214
• Change the Device Set a Policy is Monitoring, on page 214
• Change the Polling for a Monitoring Policy, on page 215
• Change Thresholds and Alarm Behavior for a Monitoring Policy, on page 215
• Run Performance Tests, on page 217
• Monitor Network Performance Using Reports, on page 222

How Device Health and Performance Is Monitored: Monitoring Policies

Monitoring policies control how Cisco EPN Manager monitors your network by controlling the following:

• What is monitored—The network and device attributes Cisco EPN Manager monitors.
• How often it is monitored—The rate at which parameters are polled.
• When to indicate a problem—Acceptable values for the polled attributes.
• How to indicate a problem—Whether Cisco EPN Manager should generate an alarm if a threshold is surpassed, and what the alarm severity should be.

Monitoring policies are important because apart from controlling what is monitored, they determine what data can be displayed in reports, dashboards, and other areas of Cisco EPN Manager. Monitoring policies do not make any changes on devices.

Only device health monitoring (that is, the Device Health monitoring policy) is enabled by default. Interface Health monitoring is not enabled by default to protect system performance in large deployments. Note that
the Device Health monitoring policy does not apply to the Cisco NCS 2000 and Cisco ONS families of devices. To monitor those device types, use the optical monitoring policies listed in Monitoring Policies Reference, on page 879.

These steps summarize how you can configure a monitoring policy.

1. Use a monitoring **policy type** as a template for your monitoring policy, and give the policy a name that is meaningful to you. Policy types are packaged with Cisco EPN Manager and make it easy for you to start monitoring different technologies and services, such as Quality of Service, Optical SFP, and TDM/SONET. A complete list is provided in Monitoring Policies Reference, on page 879.

2. Adjust your policy's polling frequencies or disable polling altogether for specific parameters.

3. Specify the threshold crossing alarms (TCAs) you want Cisco EPN Manager to generate if a parameter's threshold is surpassed. Some TCAs are configured by default; you can adjust or disable them, and configure new TCAs.

4. Specify the devices you want your policy to monitor. Devices are filtered depending on the policy type.

5. Activate your policy. The polled data will be displayed in dashboards, reports, the Alarms and Events table, and other areas of the web GUI.

To view and administer monitoring policies, choose **Monitor > Monitoring Tools > Monitoring Policies**.

<table>
<thead>
<tr>
<th>Navigation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automonitoring</td>
<td>Lists the policies that are enabled by default in Cisco EPN Manager. Only the Device Health monitoring policy is enabled by default. You can adjust the settings for this policy.</td>
</tr>
<tr>
<td>My Policies</td>
<td>The policy you create is listed here. When you choose a policy from My Policies, you can view the policy's details.</td>
</tr>
</tbody>
</table>

**Set Up Basic Device Health Monitoring**

The Device Health monitoring policy is enabled by default. It monitors both Cisco devices and third-party devices. For Cisco devices, the device health monitoring checks managed devices for CPU utilization, memory pool utilization, environment temperature, and device availability. For third party devices, the device health monitoring checks managed devices for device availability only. This policy also specifies thresholds for utilization and temperature which, if surpassed, trigger alarms that are displayed in the GUI client.

To view the current settings for this policy, choose **Monitor > Monitoring Tools > Monitoring Policies**, then select **Automonitoring** from the list on the left. You can also adjust the polling frequency and threshold for the different parameters. To adjust a polling frequency or threshold, use the drop-down lists that are provided in the GUI client.

You might also want to create a device health monitoring policy that monitors specific devices—for example, devices of a certain type or in a certain geographical location. For instructions on how to do this, see Adjust What Is Being Monitored, on page 211.
Set Up Basic Interface Monitoring

Interfaces are not monitored by default. This protects system performance for networks with large numbers of interfaces.

Use this procedure to set up basic interface monitoring.

To set up and enable interface monitoring:

**Step 1**  Choose **Monitor > Monitoring Tools > Monitoring Policies**, then select **My Policies** from the list on the left.

**Step 2**  Click **Add** to create a new policy.

*Figure 6: Add Monitoring Policies*

**Step 3**  Choose **Interface Health** for generic interface monitoring. If you are monitoring optical devices, choose **Optical 15 Mins** or another optical policy (see **Monitoring Policies Reference**, on page 879).

When you select a policy, Cisco EPN Manager populates the window with the policy settings.

**Step 4**  Enter a meaningful name and description.

**Step 5**  From the **Device Selection** drop-down list, click the appropriate radio button and then select the devices or device groups you want to monitor. If you chose the Interface Health monitoring policy, you can also select port groups.

Cisco EPN Manager only lists the devices or ports applicable to the policy you selected in Step 3.

Note the following:

- If you want to use the default settings for polling and thresholds, proceed to Step 8.

- Due to a limitation in the current release of Cisco EPN Manager, the Interface Health monitoring policy polls all of the interfaces in your network for cyclic redundancy check (CRC) error data, not just the ones associated with the selected port group. Keep this in mind whenever you view CRC error data.
Set Up Basic Interface Monitoring

Step 6  To adjust how often the interface is polled, select a value from the Polling Frequency drop-down list. Some policies allow you to set polling frequencies for different parameters, while other policies have only one polling frequency that is applied to all parameters.

For example, the following shows a policy that will monitor Cisco ASR 9000 interfaces. It uses the Interface Health policy type, where all parameters are polled using the same interval.

Policies / My Policies
ASR9K-IF-Health

* Name ASR9K-IF-Health
Author root
Description
Contact
Feature Category Interface Health
Status Active

Parameters and Thresholds

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Polling Frequency</th>
</tr>
</thead>
<tbody>
<tr>
<td>Statistics</td>
<td>15 min</td>
</tr>
<tr>
<td>CRC</td>
<td>No Polling</td>
</tr>
</tbody>
</table>

Alternatively, the following shows a policy that will monitor Cisco NCS 2000 interfaces. It uses the Optical 15 mins policy type, where each interface type has its own polling interval. You can edit the interval by double-clicking it.
Step 7  If the policy supports TCA customization, you can adjust the thresholds. See Change Thresholds and Alarm Behavior for a Monitoring Policy, on page 215.

Step 8  Click:

• **Save and Activate** to start monitoring immediately

• **Save and Close** to save the policy and activate it at a later time

---

**Use the Dashboards To Check Network and Device Health**

Cisco EPN Manager provides a variety of dashboards for monitoring your devices and network. The following are some examples of what dashboards can provide:

• Network-wide real-time status information, such as unreachable devices, interfaces that are down, and the most recent alarms.
Check What Cisco EPN Manager Is Monitoring

This topic explains how to get the following information:

- Which policies are activated, their status, and their history.
- The specific parameters that Cisco EPN Manager is polling, the frequency at which they are polled, and their threshold crossing alarm (TCA) settings.
- Who created the policy and which policy type they used as its basis.

To find out what a policy polls, when the policy last ran, and whether the policy is currently active, choose Monitor > Monitoring Tools > Monitoring Policies, then choose My Policies. Cisco EPN Manager lists the monitoring policies you created or have access to, with the following information.

<table>
<thead>
<tr>
<th>Policy Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Policy name (specified by the policy creator). To find out who created a policy, see the instructions that follow this table.</td>
</tr>
<tr>
<td>Description</td>
<td>Policy description (specified by the policy creator).</td>
</tr>
<tr>
<td>Type</td>
<td>Template (policy type) used to create this policy. For information on the policy types, see How Device Health and Performance Is Monitored: Monitoring Policies, on page 203.</td>
</tr>
<tr>
<td>Status</td>
<td>Active or Inactive.</td>
</tr>
<tr>
<td>Threshold</td>
<td>Whether the policy monitors parameter thresholds and generates TCAs. If Yes is displayed, you can check the TCA settings using the instructions that follow this table.</td>
</tr>
</tbody>
</table>
### Policy Field | Description
---|---
Activation History | Active monitoring policy—Displays the number of times the policy was activated, and provides a hyperlink to an Activation History popup window that tells you:
- When the policy was activated.
- Which devices were polled at each policy run. If the list is very long, hover your mouse cursor over the list in the Activated for column to launch a popup window.
Inactive monitoring policy—Displays Not Available.

Collection Status | Active monitoring policy—Provides a hyperlink to a Collection Status popup window that tells you:
- The Device name, IP address, and availability state of each device that was polled by the policy.
- Which parameters were polled at each policy run. If the list is very long, hover your mouse cursor over the list in the Parameters column to launch a popup window.
Inactive monitoring policy—Displays Not Available.

---

To view polling frequencies and TCA details, from **My Policies**, select a policy from the list on the left. Depending on the policy type, the following information is displayed.

**Note**
The Optical 1 day and Optical 15 minutes policies do not display polled parameters in the web GUI. That information is provided in Monitoring Policies Reference, on page 879.
Check Which Parameters and Counters Are Polled By a Monitoring Policy

Check What Cisco EPN Manager Is Monitoring, on page 208 explains how to find out which monitoring policies are currently activated. To find out which parameters are being polled by a policy, follow this procedure.

Note
Because Optical 1 Day and Optical 15 Mins parameters are not displayed in the web GUI, they are listed in Monitoring Policies Reference, on page 879.

You can use this procedure to check:
- Parameters polled by existing policies (regardless of whether a policy is active or inactive).
- Parameters used by a policy type. This is useful if you want to check what a new policy will poll before creating the policy.

Step 1
Choose Monitor > Monitoring Tools > Monitoring Policies, then choose My Policies. The web GUI lists the existing active and inactive monitoring policies.

Step 2
To check the parameters used by an existing policy:
- To view parameters that were polled most recently, locate the policy in the window on the right, then click Details in the Collection Status column. In the Collection Data dialog box, hover your mouse over the text in the Parameter column to list the polled parameters.
- To view the parameters along with their polling settings, expand My Policies in the navigation area on the left, then choose the policy you want to check. The window on the right displays the parameters and their polling settings.

Step 3
To check the parameters used by a specific policy type:
a) Click Edit. The supported policy types are listed in the navigation area on the left.
b) Choose a policy type. The window on the right displays the parameters polled by that policy, along with default polling and TCA settings. (These settings can be customized when a monitoring policy is created.)
Policies Pane Pop-Up Window

From the Policies pane in the Monitoring Policies page, you can open a pop-up window that provides summary information and action links for the corresponding policy or policy folder. To open a pop-up window, place your cursor over the appropriate (information) icon.

- If you open the pop-up window for a policy, it displays information such as the policy’s type, status, and timestamp for the last time it was updated. From the Actions area, you can click links to edit, delete, or duplicate the policy.

- If you open the pop-up window for a policy folder, it indicates the folder’s name and the number of policies that belong to it. From the Actions area, you can click links to delete the folder or add a new sub-folder. Note that you can only add and delete folders within My Policies. Also, when user-created folders are in place, you need to specify the destination folder whenever you create a new policy.

Check a Monitoring Policy’s Device, Polling, Threshold, and Alarm Settings

To check a monitoring policy’s threshold and alarm settings:

Step 1  Choose Monitor > Monitoring Tools > Monitoring Policies, then choose My Policies.
Step 2  Select the monitoring policy and click Edit to open the policy details.
Step 3  To find out which devices the policy is monitoring, click the Device Selection drop-down list. Devices that are monitored are indicated with a check mark. To add or remove devices, see Change the Device Set a Policy is Monitoring, on page 214.
Step 4  To find out the polling interval the policy is using, check the Polling Interval setting. For per-parameter polling, you must expand the individual parameters to see the setting. To adjust the polling settings, see Change the Polling for a Monitoring Policy, on page 215.

Optical policy polling frequencies cannot be changed; they can only be disabled.

Step 5  To find out the thresholds and alarm settings the policy is using, expand the parameter in the Polling and Thresholds area. To change the threshold and alarm settings, see Change Thresholds and Alarm Behavior for a Monitoring Policy, on page 215.

Optical policy thresholds cannot be customized.

Adjust What Is Being Monitored

To make adjustments to what Cisco EPN Manager is monitoring, use the guidance in the following table to find the best method for your needs.
Create a New Monitoring Policy Based On An Existing Policy

<table>
<thead>
<tr>
<th>If:</th>
<th>See:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cisco EPN Manager is collecting the data you need, and...</td>
<td>Change the Polling for a Monitoring Policy, on page 215</td>
</tr>
<tr>
<td>... you want to change the polling frequency</td>
<td>Change Thresholds and Alarm Behavior for a Monitoring Policy, on page 215</td>
</tr>
<tr>
<td>... you want to adjust the alarm behavior</td>
<td>Change the Device Set a Policy is Monitoring, on page 214</td>
</tr>
<tr>
<td>... you want to adjust which devices are monitored</td>
<td></td>
</tr>
<tr>
<td>Cisco EPN Manager is not collecting the data you need, and...</td>
<td>Create a New Monitoring Policy Based On An Existing Policy, on page 212</td>
</tr>
<tr>
<td>... a similar monitoring policy already exists</td>
<td>Create a New Monitoring Policy Using Out-of-the-Box Policy Types, on page 213</td>
</tr>
<tr>
<td>... no similar monitoring policies exist, but one of the policy types contains the parameters you want to monitor</td>
<td>Create a Monitoring Policy for Unsupported Parameters and Third-Party Devices, on page 213</td>
</tr>
<tr>
<td>... no similar monitoring policies exist, and none of the policy types contain the parameters you want to monitor</td>
<td></td>
</tr>
<tr>
<td>... you want it to monitor unsupported or third-party devices</td>
<td></td>
</tr>
</tbody>
</table>

Create a New Monitoring Policy Based On An Existing Policy

**Step 1**  
Check what is currently being monitored to verify that you need to create a new policy. See Check What Cisco EPN Manager Is Monitoring, on page 208.

**Step 2**  
Create the duplicate.  
a) Choose **Monitor > Monitoring Tools > Monitoring Policies**, then click **My Policies** from the list on the left.  
b) Locate the policy you want to duplicate.  
c) Select the policy, then click **Duplicate**.  
d) In the **Duplicate Policy Creation** dialog, choose the parent folder, enter a policy name and description, then click **OK**.

**Step 3**  
Make your changes to the duplicate.  
a) Locate the policy under **My Policies**.  
b) Select the policy and click **Edit**.  
c) Make your changes as needed. See:  
   - Change the Device Set a Policy is Monitoring, on page 214  
   - Change the Polling for a Monitoring Policy, on page 215  
   - Change Thresholds and Alarm Behavior for a Monitoring Policy, on page 215

**Step 4**  
Click:  
   - **Save and Activate** to save and activate the policy immediately on the selected devices.
Create a New Monitoring Policy Using Out-of-the-Box Policy Types

Step 1  Check what is currently being monitored. See Check What Cisco EPN Manager Is Monitoring, on page 208.
Step 2  Choose Monitor > Monitoring Tools > Monitoring Policies, then click Add.
Step 3  Select the policy type template you want to use from the Policy Types menu.
Step 4  Configure the new policy:
   a) Select the devices, device groups, or port groups from the Device Selection drop-down list. (Not all monitoring types can be applied to port groups.)
   b) Enter a name and contact, and edit the description.
   c) Under Parameters and Thresholds, configure the polling settings, parameter values, and alarm conditions. See Change the Polling for a Monitoring Policy, on page 215 and Change Thresholds and Alarm Behavior for a Monitoring Policy, on page 215.
Step 5  Click:
   * Save and Activate to save and activate the policy immediately on the selected devices.
   * Save and Close to save the policy and activate it at a later time.

Create a Monitoring Policy for Unsupported Parameters and Third-Party Devices

You can design custom MIB polling policies to monitor third-party or Cisco devices and device groups. You can also create custom MIB policies to monitor device features for which Cisco EPN Manager doesn’t provide default policies. Using this feature, you can:

• Upload the SNMP MIB for the device type, then choose devices and attributes to poll and the polling frequency.
• Upload a single MIB definition file or a group of MIBs with their dependencies as a ZIP file.
• Display the results as a line chart or a table.

This feature allows you to easily repeat polling for the same devices and attributes and customize the way Cisco devices are polled using SNMP.

You can create a maximum of 25 custom MIB polling policies.

To create a custom MIB polling policies, follow these steps:

Step 1  Choose Monitor > Monitoring Tools > Monitoring Policies, then choose My Policies and click Add.
Step 2  From the Policy Types menu, select Custom MIB Polling.
Step 3  Enter a name for the policy.
**Step 4** Under the **MIB Selection** tab, specify the polling frequency and enter the MIB information.

- If Cisco EPN Manager does not list the MIB you want to monitor in the MIBs drop-down list, download the MIBs you want to monitor from the following URL:

- To upload a MIB, specify a filename extension only if you are uploading a ZIP file.

- If you are uploading a ZIP file, ensure that all dependent MIB files are either included in the ZIP or already present in the system.

- Ensure your upload file and the MIB definition have the same name. If you are uploading a ZIP file, you may name it as you please, but the MIB files packaged inside it must also follow the same convention (for example: MyMibs.zip is acceptable, as long as all MIB files in the ZIP match their MIB names).

**Step 5** To test the policy you created on a device before activating it, click the **Test** tab and select a device on which to test the new policy.

**Step 6** Click **Save and Activate** to immediately activate the policy on the devices specified.

**Step 7** To view the MIB polling data, create a generic dashlet on the Performance dashboard using the name of the policy that you created.

**Note** To view the SNMP polling date for Cisco ASR devices, you should use the show platform hardware qfp active datapath utilization | inc Processing command for CPU utilization and show platform hardware qfp active infrastructure exmem statistics | sec DRAM command for memory utilization.

---

**Check the Status of Past Monitoring Policy Data Collections**

To check a monitoring policy's past data collection:

**Step 1** Choose **Monitor > Monitoring Tools > Monitoring Policies**, then click **My Policies**.

**Step 2** Locate the policy, and under the **Collection Status**, click **Details** to open the Collection Data dialog. To see which parameters were polled for a device, hover your mouse over the text in the Parameter column.

---

**Change the Device Set a Policy is Monitoring**

You can customize how often monitoring information is gathered (polling interval). Not all policies have all of these settings; for example, a policy may only collect statistics, so it would not have any thresholds or alarms associated with it.

**Step 1** Choose **Monitor > Monitoring Policies > My Policies** and select the policy you want to edit.

**Step 2** Check the policy you want to edit and click **Edit**.

**Step 3** Click the Device Selection drop-down list.

**Step 4** Select and deselect devices as needed.
Step 5 Click **Save and Activate** to save and activate the policy immediately on the selected devices.

---

### Change the Polling for a Monitoring Policy

You can customize how often monitoring information is gathered (polling interval). Not all policies have all of these settings; for example, a policy may only collect statistics, so it would not have any thresholds or alarms associated with it.

**Step 1** Choose **Monitor > Monitoring Tools > Monitoring Policies**, then click **My Policies**.

**Step 2** Select the policy you want to edit and click **Edit**.

**Step 3** Adjust the polling frequency. How to adjust polling depends on the monitoring policy type.

- Policies with one polling frequency that applies to all attributes—To adjust the polling frequency, select the new interval from the Polling Frequency drop-down list. To disable polling, deactivate the policy by clicking **Save and Deactivate** at the bottom of the page.

- Policies with per-attribute polling frequencies—To change the polling setting for a specific attribute, double-click the attribute line and change the setting. Choosing **No Polling** will disable polling for that attribute only.

To disable polling for all attributes in the policy, deactivate the policy by clicking **Save and Deactivate** at the bottom of the page. Do not proceed to the next step.

**Step 4** Click **Save and Activate** to save and activate the policy immediately on the selected devices.

---

### Change Thresholds and Alarm Behavior for a Monitoring Policy

You can customize the threshold value that indicates a problem and whether Cisco EPN Manager should generate an informational event or an alarm (of any severity) when a problem is detected. Not all policies have all of these settings; for example, a policy may only collect statistics, so it would not have any thresholds or alarms associated with it.

**Step 1** Choose **Monitor > Monitoring Tools > Monitoring Policies**, then choose **My Policies**.

**Step 2** Select the policy you want to edit and click **Edit**.

**Step 3** Locate the parameter you want to change. You can search for the parameter by entering a string in the **Parameter** text box.

**Step 4** Expand the parameter. You can change an existing condition or add new conditions, as in the following figure, which specifies thresholds and alarms for CPU utilization on Cisco ASR 9000 devices.
You can have only total of 50 thresholds for each metrics as given in the below tables.

**Step 5**

When you are done, click **Save and Activate** to save and activate the policy immediately on the selected devices.

<table>
<thead>
<tr>
<th>Metrics</th>
<th>Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU</td>
<td>CPU Utilization</td>
</tr>
<tr>
<td>MEMORY</td>
<td>Memory Pool Utilization</td>
</tr>
<tr>
<td>ENVTEMP</td>
<td>Environment Temperature</td>
</tr>
<tr>
<td>INTERFACE</td>
<td>Interface Inbound Errors, Interface Outbound Errors, Interface Inbound Discards, Interface Outbound Discards, Input Utilization, Output Utilization, Input Packet Broadcast Percent, Percentage drops in input queue, Percentage drops in output queue</td>
</tr>
<tr>
<td>QOS</td>
<td>Percent Drop per QoS Class</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Policy Name</th>
<th>Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Traffic Analysis</td>
<td>In Bytes, In Packets, Out Bytes, Out Packets</td>
</tr>
<tr>
<td>Traffic Analysis</td>
<td>Total Bytes, Total Packets, In Bytes, In Packets, Out Bytes, Out Packets</td>
</tr>
</tbody>
</table>

---

**Note**

You can have only total of 50 thresholds for each metrics as given in the below tables.
### Run Performance Tests

When you run a performance test, Cisco EPN Manager connects to the network devices in real time to retrieve the information. Reports, on the other hand, use historical data that is saved in the database. See these topics for more information, depending upon the type of test you want to run:

- **Performance Test Based on Y.1564 for EVCs**, on page 626
- **Performance Test Based on Y1731 for EVCs**, on page 629
- **Performance Test for Optical Circuits**, on page 630
- **Performance Test for Circuit Emulation Services**, on page 632

Cisco EPN Manager also supports running OTDR performance tests on OTS optical links. For more information, see **Run an OTDR Performance Test on an OTS Link**, on page 217.

### Run an OTDR Performance Test on an OTS Link

An Optical Time Domain Reflectometer (OTDR) test is a graphical signature of a fiber's attenuation along its length which provides insight into the performance of the link components (cable, connectors and splices). It allows remote diagnosis of OTS link related issues (such as degraded devices, splices and bends in the cables).

The OTDR test can be initiated only on OTS links that are connected to the OTDR port in the TNC card.

Some OTDR functions are limited to specific user groups, as described in the table below:

<table>
<thead>
<tr>
<th>Policy Name</th>
<th>Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Response Time</td>
<td>Average Network Time, Average Client Network Time, Average Server Network Time, Average Transaction Time, Average Server Response Time, Maximal Network Time, Maximal Client Network Time, Maximal Server Network Time, Maximal Transaction Time</td>
</tr>
<tr>
<td>Voice Video Data</td>
<td>Average MOS, Worst MOS, Jitter, Actual Packet Loss, Adjusted Packet Loss</td>
</tr>
</tbody>
</table>
### Run an OTDR Performance Test on an OTS Link

The OTDR scan can be accessed from the Actions menu in the Links tables or from the Interface 360 view. The OTDR Scan menu option is only available for links or interfaces on which OTDR is supported.

To run an OTDR scan:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
</table>
| Step 1 | Access the OTDR scan window in one of the following ways:  
  • Choose Inventory > Other > Links. Select the required OTS link, then choose Actions > OTDR Scan.  
  • Open the Interface 360 view for one of the sides of the link you want to test and choose Actions > OTDR Scan. |
| Step 2 | In the Configure tab, check the OTDR configuration settings on both sides of the link and modify them if necessary. See Configure OTDR Port Values, on page 219. |
| Step 3 | In the Scans tab, click on the arrow next to Change Scan Zone and Direction to expand the area and show the distance profile and direction settings. In the Scan Direction area, the A-side and Z-side of the selected OTS link are represented and you can select the direction in which you want to run the test. |
| Step 4 | Select the required sector from the Distance Profile drop-down list. |
| Step 5 | Under Scan Direction, select the direction of the test by clicking on the relevant arrow. Note that above each direction arrow is information indicating when the last scan for that direction was run. |
| Step 6 | Click Start Scan.  
  • A graphical representation of the scan result is displayed with the power readings (dB) over a specified distance profile (km). You can also view the baseline graph to compare with the last scan reading.  
  • A zoomed in view of the graph is available. Click +Show Graph Zoom to display it.  
  • A tabular representation of the reflection, loss, fiber end and ORL events for the selected direction and distance profile (sector) is displayed in the Scan Event Details area. Note that fiber end and ORL information is only available for devices running ONS 10.8.  
  • The Events tab displays a table with the distance (km), baseline reading (dB) and previous scan reading (dB). They display the relative/absolute threshold, which is the comparison of the baseline to the scan results. Use the Type field to filter Reflection, Insertion Loss, or Reflection with Loss type of event detail. You can analyze an event by selecting the event in the table and clicking Analyze Event. This causes the scan to be re-run with the specific location of the event. |

**Note** An alarm is raised if the threshold exceeds the value set on the device. The Reflection, Insertion Loss and Reflection with Loss information is represented with an icon in the Type field.
• Click **View on Geo Map** to see the scan results within the context of the geo map. See **View OTDR Scan Results in the Geo Map**, on page 221

*Figure 7: View Scan Event Details*

---

**Step 7**  
(Optional) Click **Set Baseline** to set an OTDR test baseline. Setting a baseline helps you to compare with the last scan results.

**Step 8**  
To export the scan results, see **Export the OTDR Scan Results**, on page 221.

**Step 9**  
To schedule the OTDR scan to be run at predefined regular intervals, see **Provision OTDR Scan Recurrence**, on page 220.

---

**Configure OTDR Port Values**

For the OTDR scan, you can either use the default settings for the TNCS cards for each sector or you can modify the settings as required.

---

**Step 1**  
Access the OTDR scan page as described in the **Run an OTDR Performance Test on an OTS Link** topic.

**Step 2**  
In the **Configure** tab, select a device from the **Device** drop-down list. A table is displayed listing all the sectors with the default values for the following columns:

- Scan Status—Cumulative status of the scans
- Loss Sensitivity (dB)
- Reflection Sensitivity (dB)
- Start Point (km)
- End Point (km)
- Pulse Width (microseconds)
• Resolution (m)
• Measure Time (s)
• Baseline—Baseline is not set by default
• Threshold Loss (dB)
• Threshold Reflection (dB)
• Recurrence—Recurrence is not set by default

The OTDR measurement ranges are categorized based on the fiber spans defined for each sector. Following are the OTDR measurement sectors:
- **Zone #1**—Distance 0 to 1 km
- **Zone #2**—Distance 0 to 25 km
- **Zone #3**—Distance 0 to 80 km
- **Zone #4**—Full distance
- **Expert Mode**—For custom distance settings, you can edit the start point and end point parameters
- **Auto Mode (System Detect)**—The end point parameter is defined automatically

**Note** The distance profiles parameters listed in the **Configure** tab are refreshed for every 30 seconds.

**Step 3** To modify the OTDR settings on the device, click the **Device OTDR Settings** hyperlink. For more details on the OTDR settings, see the 'Configuring OTDR Auto Scan' section in **Provision Optical Interfaces**, on page 328.

**Step 4** To edit the sector parameters, select the required Distance Profile in the table, and click **Edit**. A popup window is displayed.

**Step 5** In the popup window:
- For **Zone #1** to **Zone #4**—You can edit Loss Sensitivity (dB) and Reflection Sensitivity (dB), Threshold Loss (dB), Threshold Reflection (dB), and Recurrence values. For information on setting the scan recurrence, see **Provision OTDR Scan Recurrence**, on page 220.
- For **Expert Mode**—You can edit all the columns in the table, except scan status and baseline.
- For **Auto Mode**—You can edit Loss Sensitivity (dB) and Reflection Sensitivity (dB), Threshold Loss (dB), Threshold Reflection (dB), and Recurrence values. The End Point value (length of the fiber span for OTDR scan) is defined automatically. The other values for the scan (Pulse Width, Measure Time, and Resolution) are then configured based on the detected length of the fiber span.

To enable absolute threshold, you need to select Absolute Fiber Pass Fail Criteria check-box in the **OTDR Settings** page.

**Step 6** Click **Save**.

---

**Provision OTDR Scan Recurrence**

Follow the below procedure to set up OTDR scan recurrence on the selected ports:
**Step 1**  In the **Configure** tab of the OTDR Scan page, from the **Device** drop-down list, select the port on which you want to provision a recurring scan.

**Step 2**  Select the appropriate distance profile, and click **Edit**. A popup window is displayed.

**Step 3**  In the **Recurrence** area, set the scan frequency by choosing one of the following:

- **None**—No recurrence is set (default).
- **Weekly**—To schedule a weekly recurring scan, go to **Step 4**, on page 221.
- **Intervals**—To schedule a granular recurring scan, go to **Step 5**, on page 221.

**Step 4**  Select the desired day from the **on** drop-down list and enter the hours and minutes.

**Step 5**  Select the desired day range between 0 to 365 and enter the hours and minutes.

**Step 6**  Click **Save**.

---

**Export the OTDR Scan Results**

You can export the scan results to your local.

**Step 1**  Click **Export Scans**.

**Step 2**  Select the distance profile and the directions you want to export. By default, the directions and the distance profile of the current scan are selected. You can select more than one direction for the export.

**Step 3**  Click **Export**. The exported file (.sor format) will be downloaded to your local machine.

---

**View OTDR Scan Results in the Geo Map**

You can view the OTDR scan results in the context of the geo map in order to pinpoint the location of the fiber issues. For example, if the OTDR test reports a concentrated loss 20 km from the link endpoint, you can visualize on the map where this is geographically located.

**Prerequisites**:

- KML file containing fiber data and coordinates must be imported so that the fibers are visible on the geo map. See [Import Location Data from a KML File](page 194).
- The OTS link on which the OTDR scan is run must be associated with a fiber. See [Associate Links to Fibers](page 192).
- The A- and Z-side devices must be mapped on the geo map. See [Place Unmapped Devices on the Geo Map](page 186).

**Procedure**

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step 1</strong> Launch the OTDR scan.</td>
<td></td>
</tr>
<tr>
<td><strong>Step 2</strong> Define the scan parameters and run the scan.</td>
<td></td>
</tr>
<tr>
<td>Command or Action</td>
<td>Purpose</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------</td>
</tr>
<tr>
<td>Step 3 Click View on Geo Map.</td>
<td>The geo map opens. The OTDR scan results graph is displayed on the left. The geo map zooms to show the relevant devices, link and fiber (highlighted in purple).</td>
</tr>
<tr>
<td>Step 4 Click on a point in the OTDR scan results graph.</td>
<td>A location icon appears on the exact location on the fiber on the geo map and a popup panel provides information about that location, including the distance in kilometers along the fiber, the exact coordinates, and the physical address. <strong>Note</strong> If the exact location cannot be calculated, the location icon shows an approximate location that is within a certain radius of the exact location. The radius (in km) is shown in the popup panel and a circle around the location icon in the map indicates that this is an approximate location within a radius of the exact location.</td>
</tr>
<tr>
<td>Step 5 If necessary, click on the OTDR link below the OTDR scan results graph to return to the OTDR scan page.</td>
<td></td>
</tr>
</tbody>
</table>

### Monitor Network Performance Using Reports

Cisco EPN Manager provides a variety of reports to help you monitor your network's performance. The following are some examples:

- Environmental temperature, CPU and memory utilization
- Interface errors and discards
- For Carrier Ethernet devices—IPSLA Ethernet OAM, PWE3, QoS, and other CE reports
- For Optical devices—Ethernet, OTN, SDH/SONET, and other optical reports

When you run a performance report, retrieves historical data that has been saved in the database. Reports can only display data that Cisco EPN Manager has been configured to collect—in other words, data that is collected and monitored using monitoring policies. (No monitoring policies have to be enabled for event and alarm-related reports; that data is collected automatically.) For information on which monitoring policies must be enabled for the different reports, see Available Reports, on page 259.
Monitor Alarms and Events

• What Are Alarms and Events?, on page 225
• How are Alarms and Events Created and Updated?, on page 226
• Which Events Are Supported?, on page 229
• Set Alarm and Event Management Preferences, on page 229
• Interpret Event and Alarm Badges and Colors, on page 233
• Find and View Alarms, on page 233
• Track and Monitor Alarms, on page 235
• View a Specific Alarm in the Topology Map, on page 236
• View Root Cause and Correlated Alarms, on page 236
• Get Troubleshooting and Detailed Alarm Information, on page 237
• Acknowledge and Clear Alarms, on page 239
• Add Notes To an Alarm, on page 241
• Forward Alarms and Events as Email Notifications, on page 241
• Manage How Alarms are Triggered (Alarm Thresholds), on page 242
• View Events (Including Generic Events), on page 242
• View Syslogs (Historic), on page 243
• Export Alarms, Events or Syslogs to a CSV or PDF File, on page 244
• Get Support from Cisco, on page 245
• Respond to Problems Within Cisco EPN Manager, on page 245

What Are Alarms and Events?

An event is a distinct incident that occurs at a specific point in time, such as a port status change, or a device becoming unreachable. Events can indicate an errors, failures, or exceptional conditions in the network. Events can also indicate the clearing of those errors, failures, or conditions. Event have associated severities (which you can adjust as described in Change Event Severity Levels, on page 785).

An alarm is a Cisco EPN Manager response to one or more related events. Only certain events generate alarms. Alarms have a state (cleared or not cleared) and a severity (Critical, Major, Minor, and so forth). An alarm inherits the severity of its most recent event. Alarms remain open until a clearing event is generated (or if the alarm is manually cleared).

Related Topics
• How are Alarms and Events Created and Updated?, on page 226
• Acknowledge and Clear Alarms, on page 239
How are Alarms and Events Created and Updated?

The Cisco EPN Manager processes SNMP traps, syslogs, and TL1 messages from both IPv4 and IPv6 devices. It maintains an event catalog that determines how it should respond to these events. The flowchart below represents the manner in which these alarms and events are processed:

CISCO EPX Manager performs the following general steps when it processes an event:

1. Checks the event catalog to see if higher level processing is necessary (as opposed to just generic processing) for the incoming SNMP trap, syslog, or TL1 message (by examining the raw event for predefined patterns).

   - If it cannot match the raw event to the catalog, the event is considered a generic event and it undergoes generic processing. Generic events are displayed in the GUI and can be forwarded in notifications. (Generic event handling can be disabled; see Disable and Enable Generic Trap and Syslog Handling, on page 794). This is done so that none of the traps and syslogs received by Cisco EPN Manager is discarded i.e., they either go through generic processing to create generic events or higher level processing to create alarms/processed events.
   - If it can match the raw event to the catalog, the raw event is considered for higher level processing and Cisco EPN Manager creates a processed event with a severity and potentially an alarm.
2. Identifies the device and device component that is causing the event (localizes the event).

3. Checks whether the supported event triggers inventory collection.

   Some events have specific rules that instruct Cisco EPN Manager what information it should collect. For more information, see How Is Inventory Collected?, on page 43

4. Checks whether the event severity is INFO or CLEARED.

   • If it is INFO or CLEARED, Cisco EPN Manager saves the event and displays it in the GUI.
   • If it is any other severity, Cisco EPN Manager evaluates whether a new alarm should be opened (next step).

5. Checks whether an alarm already exists or a new alarm should be created.

   • If an alarm does exist, Cisco EPN Manager associates the event to the existing alarm. The alarm severity is changed to match the severity of the new event, and the alarm time stamp is updated. If it is a clearing event (for example, a link up event), the alarm will be cleared.

   **Note**

   In some cases, a device may not generate a clearing alarm. The administrator should set the alarm auto-clearing interval as described in Change Alarm Auto-Clear Intervals, on page 786.

   • If an alarm does not exist, Cisco EPN Manager creates a new alarm and assigns it the same severity as the event.

6. Checks whether the new or existing alarm can be correlated to any other alarms. (Note that here, alarms are being correlated with other alarms, not with events.) If they can be correlated, Cisco EPN Manager does the following:

   • Identifies the causing alarm as the **root cause alarm**.
   • Identifies the resulting alarm as a **symptom alarm**.

   You can identify uncleared correlated alarms by checking the Correlated Alarms tab in the Alarms and Events table. For more information on these kinds of alarms, see View Root Cause and Correlated Alarms, on page 236.

**Example: Link Down Alarm**

In this example, Cisco EPN Manager receives a Link Down trap that it receives from a device. Cisco EPN Manager generates a Link Down event and, because the port is operationally down, it also generates a Link Down alarm.
When Cisco EPN Manager receives a Link Up trap from the device, it generates a Link Up event and clears the alarm.

Flapping Events and Flow Controllers

Flapping is a flood of consecutive event notifications related to the same alarm. It can occur when a fault causes repeated event notifications (for example, a cable with a loosely fitting connector.) An event is identified as a flapping event if multiple events are of the same type, are associated with the same source, and recur in a short period of time. Cisco EPN Manager will generate an alarm for flapping events. This alarm is generated when there are five occurrences of the same event within 300 seconds. The five occurrences could be of a sequence such as, Interface Down, Interface Up, Interface Down, Interface Up, Interface Down, and so on.
When an alarm is generated for a flapping event, the devices often go into a continuous synchronization state. This can prevent deployment of device configuration such as service provisioning, OAM, etc, on the device. However, in Cisco EPN Manager, when a monitored device raises a Flapping alarm, Cisco EPN Manager detects this alarm and stops further updates of the alarm until the flapping condition on the device is cleared.

The alarm detected as a Flapping Event is cleared based on an exit condition, which is that when there is no occurrence of the same event within the next 300 seconds, the alarm is cleared. This helps control the flow of events to avoid unnecessary triggering of device synchronization.

**Which Events Are Supported?**

Refer to the following documents for information on the events that are supported by Cisco EPN Manager.

- Cisco Evolved Programmable Network Manager Supported Traps
- Cisco Evolved Programmable Network Manager Supported Syslogs
- Cisco Evolved Programmable Network Manager Supported TL1 Messages

For information about how unsupported events are handled, see View Events (Including Generic Events), on page 242.

**Set Alarm and Event Management Preferences**

- Set Up Your Alarm and Event Display Preferences, on page 230
- Customize the Alarm Summary, on page 232

---

**Note**

Advanced users can also use the Cisco EPN Manager Representational State Transfer (REST) API to access device fault information. For information on the API, click Help > API Help.
Set Up Your Alarm and Event Display Preferences

In the Alarms and Events tables, Cisco EPN Manager displays the last 4000 alarms or events, by default. Cisco EPN Manager can only display what is available in the cache (which may be less than 4000). If you want to see more than 4000 alarms or events, click Show All above the table.

The list of 4000 alarms and events also includes cleared alarms which are not displayed. Click Show All to see all the open alarms.

You can customize the following alarm and event display by clicking at the top right of the Cisco EPN Manager window and choosing My Preferences. After you make your changes, click Save to apply your new settings. Other settings, such as whether acknowledged, cleared, and assigned alarms are displayed, are controlled globally by the administrator. (see Configure Global Display and Search Settings for Acknowledged, Cleared, and Assigned Alarms, on page 784).

<table>
<thead>
<tr>
<th>User Preference Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatically refresh Alarms &amp; Events page</td>
<td>Enables or disables automatically refreshing of the Alarms and Events page. If enabled, the page is refreshed according to the setting in Refresh Alarm count in the Alarm Summary.</td>
</tr>
<tr>
<td>Refresh Alarm count in the Alarm Summary every ___ minutes/seconds</td>
<td>Sets the refresh interval for the alarm count in the Alarm Summary (1 minute by default) (see Customize the Alarm Summary, on page 232).</td>
</tr>
<tr>
<td>Enable Alarm Badging on Alarms &amp; Events page</td>
<td>When user enables Alarm Badging, alarm severity icons are displayed next to the device groups on the Monitor &gt; Monitoring Tools &gt; Alarms &amp; Events page.</td>
</tr>
<tr>
<td>Disable Alarm Acknowledge Warning Message</td>
<td>Note This setting is only configurable if Hide Acknowledged Alarms is also enabled; that setting is disabled by default (see the previous table). Disables the following message from displaying when user selects an alarm and chooses Change Status &gt; Acknowledge: Warning: This alarm will not be generated, if the original event recurs again, within next 7 days, as it is acknowledged now. Clearing the alarm instead of acknowledging will cause the alarm to be generated if the event recurs again. Proceed with alarm acknowledgment?</td>
</tr>
<tr>
<td>Disable confirmation prompt for “Clear all of this condition”</td>
<td>Disables the following message from displaying when user selects an alarm and chooses Change Status &gt; Clear all of this condition: Are you sure you want to clear all alarms of this condition? (Disabled by default)</td>
</tr>
</tbody>
</table>

Note

Cisco Evolved Programmable Network Manager 3.0 User and Administrator Guide
**User Preference Setting** | **Description**
--- | ---
Disable “Set severity to information” prompt for “Clear all of this condition” | Disables the following message which is displayed when user selects an alarm and chooses Change Status > Clear all of this condition:
Do you want to set the severity for the selected alarm's condition to Information? WARNING: This is a system-wide change that will prevent creation of future alarms of this condition. You can undo this change on the Severity Configuration page under System Settings. (Disabled by default)

**Note** Users with sufficient privileges can reset the severity to its original value using the procedure in Configure Global Display and Search Settings for Acknowledged, Cleared, and Assigned Alarms, on page 784.

Select alarm categories for Alarm Summary Toolbar | Controls what is displayed in the Alarm Summary (see Customize the Alarm Summary, on page 232).

When clearing all alarms of a condition, always set the condition's severity to Information | When user selects and alarm and chooses Change Status > Clear all of this condition. (Disabled by default)

Enable New Critical Alarm Count Notifications | Enables the notification pop-up that displays the count of critical alarms. The count gets updated once the alarm interval is refreshed depending on the interval set in Refresh Alarm count in the Alarm Summary (see Customize the Alarm Summary, on page 232). Only the outstanding critical alarms are displayed.

---

**View Critical Alarm Notifications**

The count of the critical alarms in the network is displayed as a notification pop-up in every page. The count gets refreshed every 1 minute or some interval depending on the interval set in the My Preferences page.

Click the Show Details hyperlink to view the list of critical alarms in the Monitor > Monitoring Tools > Alarms and Events > Alarms page.
Only the outstanding critical alarms are taken count and displayed.

The notification is not enabled by default and needs to be enabled from the My Preferences page. For details on how to enable the critical alarm count notification, see Set Up Your Alarm and Event Display Preferences, on page 230.

Customize the Alarm Summary

You can specify what alarm categories are displayed:

- In the Cisco EPN Manager title bar alarm count (bell). This gives you a quick visual count of alarms you are interested in.
- In the Alarm Summary pop-up window that is launched when you click the alarm count. The pop-up window gives you a quick look at alarm counts with their severity, as shown in the following figure.

To customize this information:

**Step 1** Click **Edit** at the top left of the Alarm Summary pop-up window. This opens your My Preferences page. You can also open this page by clicking **My Preferences** at the top right of web GUI window and choosing My Preferences.

**Step 2** Click the **Alarms & Events** tab.

**Step 3** To change the Alarm Summary refresh interval, select a number from the Refresh Alarms & Events page and Alarm count in the Alarm Summary every drop-down list.
Step 4  
To specify what is included in the Alarm Summary, Go to the Alarm Categories area. Select Alarm Summary from the Default category to display drop-down list. Enable or disable the required Alarm Category by selecting or deselecting the corresponding checkbox.

Step 5  
Click Save to confirm the changes made in the My Preferences window.

Interpret Event and Alarm Badges and Colors

When there is a problem in the network, Cisco EPN Manager flags the problem by displaying an alarm or event icon with the element that is experiencing the problem. Alarm Severity Icons, on page 233 lists the icons and their colors.

Alarm Severity Icons

The table below lists the alarm colors and their respective severity levels for the icons displayed in various parts of the web GUI.

<table>
<thead>
<tr>
<th>Severity Icon</th>
<th>Description</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>✗</td>
<td>Critical alarm</td>
<td>Red</td>
</tr>
<tr>
<td>⬇</td>
<td>Major alarm</td>
<td>Orange</td>
</tr>
<tr>
<td>⬆</td>
<td>Minor alarm</td>
<td>Yellow</td>
</tr>
<tr>
<td>🔄</td>
<td>Warning alarm</td>
<td>Light Blue</td>
</tr>
<tr>
<td>✔️</td>
<td>Alarm cleared; normal, OK</td>
<td>Green</td>
</tr>
<tr>
<td>🔴</td>
<td>Informational alarm</td>
<td>Medium Blue</td>
</tr>
<tr>
<td>🟡</td>
<td>Indeterminate alarm</td>
<td>Dark Blue</td>
</tr>
</tbody>
</table>

Find and View Alarms

To view alarms, go to Monitor > Monitoring Tools > Alarms and Events. From the displayed alarms table, you can search for specific alarms, as described in the table below. You can also create and save customized (preset) filters as described in the procedure that follows the table. To get more information about an alarm, see View an Alarm's Details, on page 237.
By default, acknowledged and cleared alarms are not included for any search criteria. This behavior is controlled by the system administrator. See Configure Global Display and Search Settings for Acknowledged, Cleared, and Assigned Alarms, on page 784

<table>
<thead>
<tr>
<th>To find these alarms:</th>
<th>Choose Monitor &gt; Monitoring Tools &gt; Alarms and Events and:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarms generated by specific device</td>
<td>For active alarms, click the “i” icon next to the device name to open the Device 360 view, then click the <strong>Alarms</strong> tab. For cleared alarms, refer to the Alarms and Events table. For cleared alarms or correlated alarms, click the appropriate tab and enter the device name or component in the <strong>Location</strong> column. You can use wild cards. For certain devices, you can also use the Chassis View to check device alarms. See View Alarms in the Chassis View, on page 84.</td>
</tr>
<tr>
<td></td>
<td><strong>Alarms</strong> generated by a specific circuit/VC</td>
</tr>
<tr>
<td></td>
<td>1. Click the “i” icon next to the device name to open the Device 360 view, then click the <strong>Circuit/VC</strong> tab.</td>
</tr>
<tr>
<td></td>
<td>2. Click the “i” icon next to the Circuit/VC name to open the Circuit/VC 360 view, then click the <strong>Alarms</strong> tab.</td>
</tr>
<tr>
<td></td>
<td>See Check Circuits/VCS for Faults, on page 619 for information on other ways to get circuit/VC alarm information.</td>
</tr>
<tr>
<td>All alarms in the network</td>
<td>Click the <strong>Show All</strong> link.</td>
</tr>
<tr>
<td>Alarms assigned to you</td>
<td>Click the <strong>Show</strong> drop-down filter list and choose <strong>Assigned to me</strong>. You can also use this filter in the Cleared/Correlated alarms tabs.</td>
</tr>
<tr>
<td>Unassigned alarms</td>
<td>Click the <strong>Show</strong> drop-down filter list and choose <strong>Unassigned Alarms</strong>. You can also use this filter in the Cleared/Correlated alarms tabs.</td>
</tr>
<tr>
<td>Cleared Alarms</td>
<td>Click the <strong>Show</strong> drop-down filter list and choose <strong>Cleared Alarms</strong>. You can also use this filter in the Cleared/Correlated alarms tabs.</td>
</tr>
<tr>
<td>Latest alarms according to the Cisco EPN Manager timestamp</td>
<td>For active alarms:</td>
</tr>
<tr>
<td></td>
<td>• Alarms in the last 30 minutes—Click the Show drop-down filter and choose the last 5, 15, or 30 minutes (<strong>CEPNM timestamp</strong>).</td>
</tr>
<tr>
<td></td>
<td>• Alarms in the last 24 hours—Click the Show drop-down filter and choose the last 1, 8, or 24 hours (<strong>CEPNM timestamp</strong>).</td>
</tr>
<tr>
<td></td>
<td>• Alarms in the last 7 days—Click the Show drop-down filter and choose the last 7 days (<strong>CEPNM timestamp</strong>).</td>
</tr>
<tr>
<td></td>
<td>You can use these same filters for cleared and correlated alarms. The filters do not have the (<strong>CEPNM timestamp</strong>) suffix because filtering by device timestamps is not supported for cleared and correlated alarms. For more information on (<strong>CEPNM timestamp</strong>) and (<strong>Device timestamp</strong>), see Device Timestamp and CEPNM Timestamp, on page 235.</td>
</tr>
</tbody>
</table>
To find these alarms: | Choose Monitor > Monitoring Tools > Alarms and Events and:
--- | ---
Latest alarms according to the device timestamp | Follow the same instructions as in the previous row, but choose the filters with the suffix (Device timestamp) This filter is not supported when searching for cleared or correlated alarms.
All alarms generated by a device group, series, or type | Choose a group from the navigation pane on the left. You can also use this filter for cleared and correlated alarms.
Alarms using customized filters | Create and save the advanced filter (see the procedure that follows this table).

You can also filter the data to find specific alarms using a quick filter or an advanced filter from the Show drop-down list. For information about how to filter the data, see Filter Data in the Detailed Tables, on page 159.

**Device Timestamp and CEPNM Timestamp**

While **Device timestamp** is the information embedded inside the syslog message, **CEPNM timestamp** is the time at which that message from the device is received at Cisco EPN Manager end.

The following configuration is recommended on the device:

```
service timestamps log datetime show-timezone msec year
```

Note that these are the default formats supported in case of a Device timestamp:

- yyyy MMM dd HH:mm:ss.SSS z
- yyyy MMM dd HH:mm:ss z
- MMM dd HH:mm:ss z
- yyyy MMM dd HH:mm:ss.SSS
- yyyy MMM dd HH:mm:ss
- MMM dd HH:mm:ss

Where *z* in the format implies a time zone.

**Note**

Only 3 letter time zones are supported and time zones with hour/minute offsets are not supported.

**Track and Monitor Alarms**

You can track and monitor alarms by setting the alarm auto-refresh interval to 10 seconds from the Refresh drop-down list. The list of alarms is refreshed and the latest 4000 alarms are displayed, along with the corresponding Alarm ID.

Clicking an Alarm ID displays the alarm's information in a new tab.
View a Specific Alarm in the Topology Map

From the Alarms table, you can select a specific alarm and launch the topology map to see the alarm on the map.

Step 1  To display the Alarms table, choose Monitor > Monitoring Tools > Alarms and Events.
Step 2  In the Alarms tab, locate and select the required alarm.
Step 3  Choose Troubleshoot > Network Topology.

The view switches to the topology map and the device with the alarm is highlighted in the map.

View Root Cause and Correlated Alarms

The Cisco EPN Manager correlation process determines the causality for alarms and alarm sequences. Alarms that support the correlation process are:

- A root cause alarm—An alarm that causes other alarms (the "correlating" alarm).
- A symptom alarm—An alarm that is the result of another alarm (the "correlated to" alarm).

Root cause and symptom alarms are displayed in a hierarchical manner to help you easily identify impacted network elements. The following figure is an example of an uncleared link down alarm that is the root cause for two other link down symptom alarms. To display an alarm tooltip in the hierarchy, hover your mouse over an alarm.

![Uncleared Root Cause and Correlated Alarms Example](image)

This view is especially helpful when alarm sequence has multiple hierarchies. All alarm sequences, regardless of the number of hierarchies, have only one root cause alarm.

To view uncleared correlated alarms,

Step 1  Choose Monitor > Alarms and Events.
Step 2  Click the Correlated Alarms tab.
Step 3 Click ☐ in the Correlation Type column to display more information about the alarm in a new view.

You can also view uncleared correlated alarms in the main Alarms and Events table. Click ☐ in the Correlation Type column to view more information about the alarm in a new view.

In this view, you can:
1. Perform actions such as Acknowledge and Clear the alarms. For more information, see Acknowledge and Clear Alarms, on page 239
2. Filter the list based on the severity, status and time stamp.
3. Choose the list of columns to be displayed by clicking ☐ at the top right corner of the table.

Cleared correlated alarms are displayed in the Cleared Alarms tab. Like uncleared alarms, the Correlation Type column will identify it as a cleared root cause alarm or symptom alarm.

Get Troubleshooting and Detailed Alarm Information

- View an Alarm's Details, on page 237
- Find Troubleshooting Information for an Active Alarm, on page 238
- Find Out Which Events Are Associated With An Alarm, on page 238
- Find Out If An Alarm Impacts Other Services or Network Elements, on page 239

View an Alarm's Details

To get more details about an alarm, expand it. You can do this from the Alarms list (by choosing Monitor > Monitoring Tools > Alarms and Events, or by clicking Details in the Alarm Summary pop-up). The circled areas are explained in the table that follows this figure.
Find Troubleshooting Information for an Active Alarm

Use this procedure to get an explanation for why an active alarm occurred, and the recommended response to the alarm.

Not all alarms have this information. Users with sufficient privileges can add or change the information that is displayed in the popup window. See Customize the Troubleshooting Text for an Alarm, on page 786.

**Step 1** Choose **Monitor > Monitoring Tools > Alarms and Events**, then click the **Alarms** tab. (For interface alarms, you can also get this information from the Interface 360 view under the **Alarms** tab.)

**Step 2** Locate the alarm, then click the "i" icon in the **Severity** column to open the popup window that provides the explanation and the recommended action that can be taken to troubleshoot the alarm.

If you take any actions, we recommend you document your actions. Choose the alarm, click **Annotation**.

Find Out Which Events Are Associated With An Alarm

To view the events that have been correlated to an alarm, from the Alarms table, click the “i” icon next to the **Severity**.

---

<table>
<thead>
<tr>
<th>General Information—When alarm was found and last updated, current and last severity, and how it was detected</th>
<th>Device Details—Managed device name, address, uptime, reachability status, collection status, and so forth</th>
</tr>
</thead>
<tbody>
<tr>
<td>Messages—Trap, syslog, or TL1 message</td>
<td>Device Events—Recent device events from past hour (of any type, in chronological order)</td>
</tr>
<tr>
<td>Impacted Circuits/VCs—Carrier Ethernet or Optical circuits/VCs affected by alarm</td>
<td></td>
</tr>
</tbody>
</table>
Find Out If An Alarm Impacts Other Services or Network Elements

The Alarms table contains a Service Affecting column which tells you if an alarm affects other parts of the network:

Service-affecting information is displayed for optical devices only.

- **SA** means it is a service-affecting alarm
- **NSA** means it is not a service-affecting alarm

To identify all alarms that can affect services, choose Quick Filter from the Show drop-down list and enter SA in the field above the Service Affecting column.

To find out which services are affected, expand the alarm and check the details in the Impacted Circuits/VCs area of the alarm details.

The Alarms table also contains a Correlation Type column which tells you if the alarm is causing other alarms (Root Cause Alarm), or if the alarm is a symptom of another alarm (Symptom Alarm). For more information, see View Root Cause and Correlated Alarms, on page 236.

Acknowledgment and Clear Alarms

An alarm can have a status of Not Acknowledged, Acknowledged, or Cleared.

Not Acknowledged

Not Acknowledged means the problem is not being worked on. It could indicate that a new fault condition in the network, or that a cleared fault condition that has recurred. Not Acknowledged alarms are not removed from the Alarms and Events tables until they are either acknowledged or cleared.

Acknowledged

Acknowledged means a fault condition has either been recognized and is being worked on, or it can be ignored. Moving an alarm to the acknowledged status is a manual operation and changes the alarm Status to Acknowledged. An acknowledged event is still considered to be open (that is, not cleared), so if any related events recur, the events are added to the alarm.

By default, acknowledged alarms are not removed from the Alarms list. This behavior depends on the Hide Acknowledge Alarms setting that is controlled by the Administrator.

Acknowledged alarms can be moved back to the Not Acknowledged status (for example, if you acknowledged the wrong alarm).

Cleared

Cleared means the fault condition no longer exists. If an alarm is cleared but an associated event recurs, Cisco EPN Manager opens a new alarm. An alarm can be cleared by a user or by the Cisco EPN Manager system. Cleared alarms are removed from the Alarms list (but you can still view them under the Cleared Alarms tab).
By default, cleared alarms will not be shown in the Alarms and Events page. To view the cleared alarms in the Alarms History table in the Alarms and Events page:

**Note**

When FRU alarms are generated, if inventory lacks location parameters then, generated alarms will not have location parameters. When the FRU alarms are cleared, the alarms may not have inventory location parameters.

- Choose **Administration > Settings > System settings**, then choose **Alarms and Events**.
- Under **Alarm Display Options**, uncheck the **Hide cleared Alarms** check box.

You can also clear an alarm by choosing **Clear all of this Condition**, which will clear all alarms that are having the same problem. You may also be prompted to change all alarms with that condition to Informational severity. This means that if an associated event recurs, a new alarm will not be opened. You should use that setting with care.

To change the status of an alarm:

**Step 1** Choose **Monitor > Monitoring Tools > Alarms & Events**.

**Step 2** Select an alarm, then choose **Change Status** and the appropriate status (Acknowledge, Unacknowledge, Clear, Clear all of this Condition).

**Note** **Clear all of this Condition** triggers a clearing event for **all alarms** with the same condition as the alarm you selected. When you choose this status, Cisco EPN Manager displays a dialog asking if you want to change the severity for the selected alarm condition to Information. This prevents Cisco EPN Manager from issuing alarms for the specified condition. To later reset the condition’s severity, choose **Administration > System Settings > Severity Configuration** and modify the severity. See **Change Event Severity Levels**, on page 785 for more information.

**Step 3** Click **Yes** to confirm that you want to clear all alarms of the specified condition.

---

**What are the Supported Alarm Clearing Mechanisms**

At times you may face a situation where there are so many alarms that are available irrespective of their events being cleared. If you encounter any such problems, here are some of the solutions supported in Cisco EPN Manager.

- **Default clearing of alarms**—The fault is resolved on the device and an event is triggered for the same. For example, a device-reachable event clears the device-unreachable event. This in-turn, clears the device-unreachable alarm.
- **Auto-clearing of alarms**—In some cases, a device may not generate a clearing alarm. In such cases, Cisco EPN Manager waits for 24 hours (default interval) and then auto-clears the alarm. You need to have administrator privileges to change the auto-clear duration and to know how to set that interval, see **Change Alarm Auto-Clear Intervals**, on page 786.
- **Clearing alarms based on inventory status of ports**—When a device is rebooted, a card is reloaded or an RSP failover happens, the inventory collection is triggered for that device. During this inventory synchronization, Cisco EPN Manager clears several types of alarms located on some specific ports based on the operational status of that particular port of the device. For example, when Cisco EPN Manager receives a Link Down trap from a device, it generates a Link Down alarm on the specific port since it is
operationally down. After a device reboot, if the operational status of the port changes to up, then the Link Down alarm is cleared automatically by Cisco EPN Manager.

- Syncing device to clear alarms—Here, the devices are synced so that Cisco EPN Manager gets the list of the outstanding active alarms and the events that does not exist are cleared. This is a different mechanism when compared to the event based alarm/event reporting (over traps/syslogs). Once the sync is over, the Alarms Table is refreshed to display only the outstanding active alarms.

**Note**
This feature is supported only for certain devices or for certain device functionalities. For example, this feature is supported for optical devices/optical part of devices such as NCS 4K, NCS 1K.

**Note**
This feature is also supported for certain packet devices such as NCS 42xx. See the Cisco Evolved Programmable Network Manager Supported Syslogs spreadsheet for the list of syslogs that are supported on the NCS 42xx devices. For the NCS 42xx devices, the alarm severity that is configured on the device will overwrite the alarm severity that is configured in the Cisco EPN Manager (Administration > System Settings > Alarms and Events > Alarm Severity and Auto Clear). This feature is not supported for other packet devices such as ASR 9K and 9xx.

- Manual clearing of alarms—In situations where the clearing event is missing, you can manually clear an alarm by choosing the particular alarm, and changing its status to Clear. For more information, see the Cleared section under Acknowledge and Clear Alarms, on page 239.

## Add Notes To an Alarm

The annotation feature allows you to add free-form text to the alarm, which is displayed in the Messages area of the alarm details. To add text to an alarm, choose the alarm in the Alarms and Events table, click Annotation, and enter your text. As with acknowledging, when you annotate an alarm, Cisco EPN Manager adds your user name and the annotation time stamp to the Messages area of the alarm details.

## Forward Alarms and Events as Email Notifications

You can configure Cisco EPN Manager to send email notifications for alarms and events. You can specify the severity for which you want to be notified, and the notification email destinations. The settings for the email subject line and body of the email are controlled globally by the administrator; you cannot adjust them.

**Step 1** Choose Monitor > Monitoring Tools > Alarms and Events.
**Step 2** Click Email Notification located in the >> drop down menu.
**Step 3** Configure the email notification contents.
   a) In the Enable column, select the check box for the alarm you want to include in the notification.
   b) Click the alarm name hyperlink and do the following:
• Select the severity levels for which you want a notification to be sent.
• Enter the email addresses in the To field.

Step 4  Click Save.

Manage How Alarms are Triggered (Alarm Thresholds)

You can customize how often information is gathered (polling interval), the threshold value that indicates a problem, and whether Cisco EPN Manager should generate an informational event or an alarm (of an severity) when a problem is detected. Not all policies have all of these settings; for example, a policy may only collect statistics, so it would not have any thresholds or alarms associated with it.

Step 1  Choose Monitor > Monitoring Tools > Monitoring Policies > My Policies and select the policy you want to edit.
Step 2  Locate the parameter you want to change. You can search for the parameter by entering a string in the Parameter text box.
Step 3  To adjust the polling interval, select the new interval from the Polling Frequency drop-down list. To disable polling, choose No Polling. Note that some polling frequencies are applied to groups of parameters. Changing the group interval will change the polling for all settings in the group. If a policy does not have any thresholds or events associated with it, Cisco EPN Manager prompts you to save the changes.
Step 4  To change a threshold value, expand the parameter and choose a value from the parameter’s drop-down list.
Step 5  To specify what Cisco EPN Manager should do when the threshold is surpassed, choose an alarm value from the parameter’s drop-down list. You can configure Cisco EPN Manager to generate an alarm of a specified severity, generate an informational event, or do nothing (if no reaction is configured).
Step 6  Click:
  • Save and Activate to save and activate the policy immediately on the selected devices.
  • Save and Close to save the policy and activate it at a later time.

View Events (Including Generic Events)

The Events tab displays supported and generic (unsupported) events. Supported events are events that Cisco EPN Manager generates based on information about the network. It receives this network information either through syslogs and traps generated by devices, or through polling and inventory collection. This process is described in How are Alarms and Events Created and Updated?, on page 226. Generic events are events that Cisco EPN Manager does not recognize. Rather than drop the events, Cisco EPN Manager assigns the events a Minor severity (this severity is applied to all generic events; to change it, see Change Event Severity Levels, on page 785). If desired, you can customize the information displayed by generic events; see Customize Generic Events That Are Displayed in the Web GUI, on page 794. For information about supported events, see Which Events Are Supported?, on page 229.

Generic event processing is disabled by default. Users with Administrator privileges can disable or re-enable it.
The Events tab provides a variety of filters that you can use to find the information you are looking for. You can also create and save customized (preset) filters using the same procedure described in Find and View Alarms, on page 233. The following table lists some of the ways you can filter events.

<table>
<thead>
<tr>
<th>To find these events:</th>
<th>Select Monitor &gt; Monitoring Tools &gt; Alarms and Events, click the Events tab, and:</th>
</tr>
</thead>
<tbody>
<tr>
<td>All events in the network</td>
<td>Click the Show All hyperlink</td>
</tr>
<tr>
<td>Latest 4,000 Events</td>
<td>Click the Show Latest 4000 Events hyperlink</td>
</tr>
<tr>
<td>All events generated by a device group, series, type, location group, or user-defined group</td>
<td>Choose a group from the left sidebar menu</td>
</tr>
<tr>
<td>Events in last x minutes, hours, or days</td>
<td>Click the Show drop-down filter list and choose the appropriate filter</td>
</tr>
<tr>
<td>Non-informational events generated in the last hour</td>
<td>From the Show drop-down filter list, choose Non-info events in last hour</td>
</tr>
<tr>
<td>Events using customized filters</td>
<td>Create and save an advanced filter (see Find and View Alarms, on page 233)</td>
</tr>
</tbody>
</table>

View Syslogs (Historic)

Cisco EPN Manager logs all syslogs from severity 0 through 7 (emergency through debugging messages) generated by all devices that are managed by Cisco EPN Manager. Syslogs from devices that are not managed are not logged or displayed. Cisco EPN Manager also logs all SNMP messages.

Cisco EPN Manager stores a maximum of 2,000,000 syslog messages with the following display limits:

- Live syslog streaming—Latest 2,000 syslog messages. For more information on live syslogs, see View Live Syslogs, on page 244.
- Historic syslogs—Maximum of 200,000 syslogs.

**Step 1** Choose Monitor > Monitoring Tools > Alarms and Events. Click the Syslogs tab.

You can also view the historic syslogs in the Historic tab in Monitor > Monitoring Tools > Syslog Viewer.

**Step 2** Click Custom Syslog Events to enable Cisco EPN Manager to create events for particular syslogs. You can specify a syslog message identifier, event severity and message to use when the specified syslog is received. Cisco EPN Manager creates an event with the settings you specify.

Also, if there is an existing syslog for which you want to create an event, select the syslog, then click Custom Syslog Events.

**Step 3** Click Add. Complete the required fields. If you selected an existing syslog in Step 2, the Message Type and Event Message fields are pre-populated with the values of the syslog you selected.

You can edit or delete the customized event that was created.
Step 4  Select a **Default Severity** level, then click **OK**. The Default Severity field controls the severity of the event that is created from the syslog. The syslog itself is not modified in any way.

Step 5  To export the syslogs to a CSV, click ☰ at the top right of the table/page on the particular syslog tab to open the **Export** dialog box.

Step 6  Click **Export**. The first 100000 records will be exported.

Step 7  Click ☰ to open a Support Case. See **Open a Cisco Support Case**, on page 796.

---

### View Live Syslogs

Cisco EPN Manager displays the live streaming of syslogs in **Monitor > Monitoring Tools > Syslog Viewer**.

**Note** However, this view is not recommended as it has a limitation of only 10 devices. Instead, you can view syslogs (historic) in the **Syslogs** tab in **Monitor > Monitoring Tools > Alarms and Events**. See **View Syslogs (Historic)**, on page 243.

---

### Export Alarms, Events or Syslogs to a CSV or PDF File

Use this procedure to save alarms, events or syslogs as a CSV or PDF file.

#### Step 1
Navigate to the data you want to export.
• Alarms—Choose Monitor > Monitoring Tools > Alarms and Events, then click the Alarms or Cleared Alarms or Correlated Alarms tab.

• Events—Choose Monitor > Monitoring Tools > Alarms and Events, then click the Events tab.

• Syslogs—Choose Monitor > Monitoring Tools > Alarms and Events, then click the Syslogs tab.

Step 2  If you have a very large amount of data, apply a filter; otherwise the export process may take some time.

Step 3  Click at the top right of the table to open the Export dialog box.

Step 4  Choose CSV or PDF, click OK, and save the file.

To export the events for a particular alarm, in the Alarms tab, hover the mouse over the "i" icon next to the particular alarm. In the pop-up window that opens, click at the top right corner to perform the export operation.

---

Get Support from Cisco

If you receive an alarm in Monitor > Monitoring Tools > Alarms and Events for which you cannot find a resolution in the Cisco Support Community (click an alarm, then choose Troubleshoot > Support Forum.), you can use Cisco EPN Manager to open a support request (click an alarm, then choose Troubleshoot > Support Case).

Respond to Problems Within Cisco EPN Manager

Cisco EPN Manager generates internal SNMP traps to monitor its own functions—such as server CPU and disk utilization, fan and power supply failures, and high availability (HA) state changes. For information on these types of events, see Troubleshoot Server Internal SNMP Traps, on page 725.
CHAPTER 10

Monitor Cisco ASR 9000 Network Virtualization (nV) Satellites and Cluster Services

- Monitor Cisco ASR 9000 nV Satellites, on page 247
- Monitor a Cisco ASR 9000 nV Edge Cluster, on page 256

Monitor Cisco ASR 9000 nV Satellites

- Minimum Device and OS Requirements for Cisco ASR 9000 nV Satellites, on page 249
- View Cisco ASR 9000 Host-Satellite Topologies in the Topology Map, on page 250
- Identify the Satellites Connected to a Cisco ASR 9000 Host, on page 251
- Identify the Hosts Connected to a Satellite, on page 252
- Monitor Cisco ASR 9000 nV Satellites for Faults, on page 253

The Cisco ASR 9000 nV satellite feature set allows one or more smaller satellite switches to be interconnected with an Cisco ASR9000 device to form a single, combined access, aggregation and edge system.

Cisco EPN Manager supports Cisco ASR 9000v, Cisco ASR 901, Cisco ASR 901S, Cisco ASR 903, and Cisco NCS 5001/2 devices as satellites. The Cisco ASR 9000v is a dedicated satellite switch that can only be used in nV satellite mode along with an Cisco ASR 9000 device. The Cisco ASR 901 and Cisco ASR 903 switches are “dual mode” switches. This means that they can operate both as standalone switches or as satellite switches within an nV system with an Cisco ASR 9000 device (in which case they are completely managed and controlled by the master Cisco ASR 9000).

The satellite feature allows for both redundant and non redundant interconnections between the satellite switches and the master Cisco ASR 9000s. The access side Ethernet ports of the satellite switches appear within the control and management planes of the host master Cisco ASR 9000 just like locally connected Ethernet ports. All features that can be configured on the host Cisco ASR 9000 can also be configured and executed identically on satellite located ports. Effectively the satellite switches are virtual line cards of the host Cisco ASR 9000. Chassis management functions of the satellites such as software upgrades, inventory and environmental monitoring of hardware sensors (voltage, temperature etc) on the satellites are also seamlessly integrated into the same functions of the host Cisco ASR 9000, just like any other line card of the host Cisco ASR 9000 chassis.

Cisco EPN Manager supports the following types of nV Satellite configurations:

- Dual home hub and spoke (inventory support only)
Satellite Considerations in Cisco EPN Manager

Satellites are not displayed in the Network Discovery page (Inventory > Device Management > Network Devices) because Cisco EPN Manager does not support satellite device management operations from that page.

Satellites can only belong to Location groups because, as network nodes, they are normally managed according to location. In addition, if you add a host device to a group, its satellites are not automatically added to the group unless the group meets the following guidelines.

- If you use Add Devices Manually—From the create (or edit) group page, click Add, then choose All Locations from the Filter by drop-down list. The satellites will be listed if they match your criteria.
- If you use Add Devices Dynamically—Make sure you are creating a location group; and from the create (or edit) group page, choose All Locations from the Parent Group at the top of the page.
Minimum Device and OS Requirements for Cisco ASR 9000 nV Satellites

The following are the minimum device and device operating system requirements for the nV satellite feature set.

- Hardware — Cisco ASR 9000 Series Aggregation Services Routers with Cisco ASR 9000 Enhanced Ethernet line cards as the location of Inter Chassis Links and Cisco ASR9000v, Cisco ASR 901, Cisco ASR 903, Cisco NCS 5001, or Cisco NCS 5002 routers as satellite devices.

  **Note**
  
  If the satellite is not an ASR 9000 device, its details will not be available in the host device’s chassis view.

- Software — Cisco IOS XR 5.2.0.

Additional support may be available. For more information see the [Cisco Evolved Programmable Network Manager Supported Devices](#).

Get Quick Information About a Specific Satellite: Satellite 360 View

The Satellite 360 view is a popup window that provides quick information about a satellite device, its inventory, and its status. This includes device alarms, modules, interfaces, and hosts.

To launch a Satellite 360 view:

- Click the "i" icon next to the device name in almost any device table
- From the network topology, click a device in an expanded group, then click View

The Satellite 360 view provides general satellite device information at the top of the view, and more detailed interface information in tabs in the lower part of the view.

<table>
<thead>
<tr>
<th>Information Provided in Satellite 360 View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General information</td>
<td>The satellite device type and name, status, last configuration change, and last inventory collection,</td>
</tr>
<tr>
<td>Modules</td>
<td>Modules that are configured on the satellite device, including their name, type, state, ports, and location.</td>
</tr>
<tr>
<td>Interfaces</td>
<td>Name, operational and admin status for each associated satellite device. Also provide a launch point for the Interface 360 view.</td>
</tr>
<tr>
<td>Hosts</td>
<td>Name, IP address, and role (Active or Standby) of host devices that are connected to the satellite.</td>
</tr>
</tbody>
</table>
View Cisco ASR 9000 Host-Satellite Topologies in the Topology Map

You can visualize the Cisco ASR 9000 host-satellite topologies and see, at a glance, whether there are active alarms on the host or satellites. From the topology map you can drill down to get further information about the host and satellite devices.

You can easily identify a satellite in the map by its label which includes the satellite ID and the IP address of the Cisco ASR 9000 host.

Note

To see the links between the devices in the satellite topology, you must enable the Inter-Chassis Control and ICCP links in the Link Types filter (top right corner above the map). ICCP protocol is used for host to host links.

To view Cisco ASR 9000 host-satellite topologies in the map:

Step 1
Choose Maps > Network Topology in the left navigation pane.

Step 2
From the Groups pane on the left, select the group that contains the Cisco ASR 9000 host and satellites. The topology map displays all the devices in the selected group.

Step 3
Locate the host or one of the satellites in the map.

Step 4
To display the links between host and satellites:
- Click the filter icon in the topology toolbar and choose Link Types.
- Check the Control Plane, Inter_Chassis_Control, and ICCP check boxes, then click OK.

Step 5
Click a satellite to launch a popup showing the satellite ID as well as the ID of the active and standby hosts.

Step 6
Click View 360 in the popup to see more details about the satellite and its hosts in the Satellite 360 view, as described in Identify the Satellites Connected to a Cisco ASR 9000 Host, on page 251.
Identify the Satellites Connected to a Cisco ASR 9000 Host

The Device 360 view for a selected Cisco ASR 9000 host contains information about the device itself as well as about the satellites connected to the host.

To identify the satellites connected to a Cisco ASR 9000 host:

Step 1 Choose Inventory > Network Devices in the left navigation pane.
Step 2 From the Device Group pane on the left, select the group that contains the Cisco ASR 9000 host.
Step 3 Locate the host in the device list on the right.
Step 4 Click the “i” icon next to the device IP address/DNS to open the Device 360 view for the host.

Note You can also access the Device 360 view from the map by clicking on the device and then clicking View 360 in the displayed popup.

The Satellites tab lists the satellites that are associated with the host and provides basic information about each satellite, such as type, description, IP address, and MAC address. It also indicates whether the satellite is currently connected to or disconnected from the host. The Satellites tab is only present in the Device 360 view for Cisco ASR 9000 host and satellite devices.

Step 5 Click the “i” icon next to the IP address in the Satellites tab to open the Device 360 view for the satellite. The Hosts tab lists the active and standby hosts associated with that satellite.
Identify the Hosts Connected to a Satellite

Usually the links in the map will clearly show the satellite topology including the host and the connected satellites. If for some reason the satellites are shown without links, it is easy to identify the hosts with which a satellite is associated.

To identify the hosts connected to a satellite:

**Step 1**  
Choose Maps > Network Topology in the left navigation pane.

**Step 2**  
From the Device Groups pane on the left, select the group that contains the Cisco ASR 9000 host and satellites. The map displays all the devices in the selected group.

**Step 3**  
Click a satellite device, identified by its label which begins with Satellite ID.

**Step 4**  
In the displayed popup, click View 360 to launch the Satellite 360 view.

The Hosts tab in the Satellite 360 view lists the host devices to which the satellite is connected and their role, either active or standby.
---

### Monitor Cisco ASR 9000 nV Satellites for Faults

When a fault occurs on a satellite, Cisco EPN Manager associates (localizes) the fault to either the host device or satellite device depending on the fault type.

- If a fault occurs on a physical entity, such as a port, fan, or module, Cisco EPN Manager identifies the satellite device as the fault location.
- If the fault occurs on a logical entity such as a sub-interface, Cisco EPN Manager identifies the host device as the fault location because the sub-interface is configured on the host.

If an alarm occurs on dual-homed satellite, the alarm is duplicated, with one alarm on the active host and another on the standby host.

### View Satellite Faults in a Topology Map

In the topology map, you will see an alarm badge overlaid on the alarm source: the satellite device, the host device, or the link between the satellite and host device.

---
If there are several alarms on the same entity, the alarm badge severity represents that of the most severe alarm.

Right-click the alarmed entity to display a popup that shows the count of all active alarms related to the entity. Link-related alarms, such as Link Down, generate an alarm badge on the relevant link in the topology map.

**View Satellite Faults Using a Device 360 View**

To find out which objects are affected by the device alarms, click View 360 from the popup menu and check the Affected Objects column. If you want to view details about a specific alarm, click the alarmID hyperlink.
View Satellite Faults in the Alarms and Events Table

To get satellite alarm information from the Alarm table, choose **Monitor > Monitoring Tools > Alarms and Events**, then click the **Alarms** tab.

Cisco EPN Manager lists the host device as the Failure Source. The Satellite ID and Location fields identify the satellite source.
Monitor a Cisco ASR 9000 nV Edge Cluster

- Minimum Device and OS Requirements for nV Edge, on page 256
- View a nV Edge Cluster in the Topology Map, on page 256
- Identify the Primary and Backup Devices in a Cluster, on page 257
- Monitor and Troubleshoot a Cisco ASR 9000 nV Edge Cluster Service, on page 258

nV Edge is a feature where two or more Cisco ASR 9000 Series Router chassis are combined to form a single logical switching or routing entity. This allows you to operate two Cisco ASR 9000 Series Router platforms as a single virtual Cisco ASR 9000 Series system. Effectively, they can logically link two physical chassis with a shared control plane, as if the chassis were two route switch processors (RSPs) within a single chassis.

There are two types of links in the nV edge topology:
- Control links, used for control traffic.
- Inter-Rack links, used for data generation and forwarding of data between chassis.

Minimum Device and OS Requirements for nV Edge

The following are the minimum device and device operating system requirements for nV edge:
- 2 Cisco ASR 9000 devices running Cisco IOS XR 5.2.0
- 4 10G SFP (for IRL)
- 4 1G SFP (for cluster/control links)
- 2 RSP nodes per chassis, with the exception of the Cisco ASR 9001 which is a single RSP system that supports cluster configuration

Additional support may be available. See the Cisco Evolved Programmable Network Manager Supported Devices.

View a nV Edge Cluster in the Topology Map

The nV edge cluster is represented in the topology map as a single object consisting of two linked chassis, one primary and one backup.

To view the Cisco ASR 9000 nV Edge topology in the map:

**Step 1** Choose Maps > Network Topology in the left navigation pane.
Identify the Primary and Backup Devices in a Cluster

The topology map clearly shows which chassis is primary and which is the backup chassis. Further details about the chassis are provided in the Device 360 view.

To identify the primary and backup devices and get more information:

**Step 1** Choose Maps > Network Topology in the left navigation pane.

**Step 2** From the Device Groups pane on the left, select the group that contains the Cisco ASR 9000 cluster setup. The map displays all the devices in the selected group.

**Step 3** Click the cluster representation.

**Step 4** In the displayed popup, click View 360.

Note that the Chassis tab in the Device 360 view lists and identifies the chassis in the cluster and provides information as to their status and their role (primary or backup).
Monitor and Troubleshoot a Cisco ASR 9000 nV Edge Cluster Service

Cisco EPN Manager displays alarm indicators on the cluster and provides graphs showing CPU and memory utilization for the primary chassis in the Device 360 view.
CHAPTER 11

MANAGE REPORTS

• Reports Overview, on page 259
• Available Reports, on page 259
• Create, Schedule, and Run a New Report, on page 276
• Customize Report Results, on page 277
• Filter and Customize Report Data Using User Defined Fields, on page 277
• Report Output Examples: Web GUI Output and CSV File Output, on page 279
• Troubleshooting Tips for an Empty Report, on page 281

Reports Overview

Cisco EPN Manager reports provide information about system and network health as well as fault information. You can customize and schedule reports to run on a regular basis. Reports can present data in a tabular, or graphical format (or a mixture of these formats). You can also save reports in CSV or PDF format. The CSV or PDF files can be saved on the Cisco EPN Manager server for later download, or sent to an e-mail address.

Cisco EPN Manager provides the following type of data:

• Current—Provides a snapshot of data that is not time-dependent.
• Historical—Periodically retrieves data from the device and stores it in the Cisco EPN Manager database.
• Trend—Generates a report using aggregated data, which is collected and summarized as minimums, maximums, and averages.

With Cisco EPN Manager, you can filter these reports based on a specific criteria. For example, IPSLA Y.1731 reports can be filtered based on probes and PWE3 reports can be filtered based on Virtual Connection Identifier (VCID). You can also export reports, sort reports into logical groups, and archive reports for long-term storage.

Available Reports

The Reports Launch Pad provides access to the following Cisco EPN Manager reports:

• Carrier Ethernet Performance Reports, on page 260
• Optical Performance Reports, on page 267
• Performance Reports, on page 272
• Network Summary Reports, on page 273
Carrier Ethernet Performance Reports

This section lists the Carrier Ethernet (CE) Performance reports supported by Cisco EPN Manager. It also includes the monitoring policies that must be enabled so that the proper report data is collected. For more information about monitoring policies, see How Device Health and Performance Is Monitored: Monitoring Policies, on page 203.

<table>
<thead>
<tr>
<th>Report Type</th>
<th>Provides:</th>
<th>Monitoring Policies That Must Be Enabled</th>
<th>Parameters That Must Be Activated</th>
</tr>
</thead>
<tbody>
<tr>
<td>IPSLA Graphs</td>
<td>Graphical representation of average delay backward, average delay forward, average delay two-way, jitter forward, jitter backward, average backward packet loss ratio, average forward packet loss ratio, and availability.</td>
<td>IPSLA</td>
<td>Response Time Avg, Response Time Max, Response Time Min, Jitter Neg DS Avg, Jitter Neg SD Avg, Jitter Pos DS Avg, Jitter Pos SD Avg, Packet Loss Overall Util Avg, Packet Loss DS Util Avg, Packet Loss SD Util Avg, Latency One Way SD Avg, Latency One Way SD Max, Latency One Way SD Min, Latency One Way DS Avg, Latency One Way DS Max, Latency One Way DS Min</td>
</tr>
<tr>
<td>IPSLA Statistics</td>
<td>Tabular representation of probe index, IPSLA probe type, TOS, target IP, VRF name, average delay two-way, average delay forward, average delay backward, packet loss ratio forward, packet loss ratio backward, average jitter forward, average jitter backward, average backward packet loss ratio, average forward packet loss ratio, and availability.</td>
<td>IPSLA</td>
<td>Jitter Neg DS Avg, Jitter Neg SD Avg, Jitter Pos DS Avg, Jitter Pos SD Avg, Packet Loss Overall Util Avg, Packet Loss DS Util Avg, Packet Loss SD Util Avg, Latency One Way SD Avg, Latency One Way SD Max, Latency One Way SD Min, Latency One Way DS Avg, Latency One Way DS Max, Latency One Way DS Min</td>
</tr>
<tr>
<td>Report Type</td>
<td>Provides:</td>
<td>Monitoring Policies That Must Be Enabled</td>
<td>Parameters That Must Be Activated</td>
</tr>
<tr>
<td>------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>IPSLA Top N</td>
<td>Tabular representation of probe index, IPSLA probe type, TOS, target IP, VRF name, average delay two-way, maximum delay two-way, minimum delay two-way, average delay forward, maximum delay forward, minimum delay forward, average delay backward, maximum delay backward, minimum delay backward, average forward packet loss ratio, average backward packet loss ratio, jitter forward, jitter backward and availability.</td>
<td><em>IPSLA</em> For details about the IPSLA monitoring policy, see IP SLA Monitoring Policy, on page 883.</td>
<td>Response Time Avg, Response Time Max, Response Time Min, Jitter Neg DS Avg, Jitter Neg SD Avg, Jitter Pos DS Avg, Jitter Pos SD Avg, Packet Loss Overall Util Avg, Packet Loss DS Util Avg, Packet Loss SD Util Avg, Latency One Way SD Avg, Latency One Way SD Max, Latency One Way SD Min, Latency One Way DS Avg, Latency One Way DS Max, Latency One Way DS Min</td>
</tr>
<tr>
<td>IPSLA Y.1731 Statistics</td>
<td>Tabular representation of operation type, CFM domain, source, destination, frame type, average delay two-way, average delay forward, average delay backward, average jitter, forward frame loss ratio, backward frame loss ratio, average forward jitter, average backward jitter, and availability of the Y.1731 probe.</td>
<td><em>IPSLA Y.1731</em> For details about the IPSLA Y.1731 monitoring policy, see IP SLA Y.1731 Monitoring Policy, on page 881.</td>
<td>Average Delay Two Way, Average Delay Forward, Average Delay Backward, Average Forward Frame Loss Ratio, Average Backward Frame Loss Ratio, Average Jitter</td>
</tr>
<tr>
<td>Report Type</td>
<td>Provides:</td>
<td>Monitoring Policies That Must Be Enabled</td>
<td>Parameters That Must Be Activated</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>IPSLA Y.1731 Top N</td>
<td>Tabular representation of operation type, CFM domain, source, destination, frame type, average delay two-way, maximum delay two-way, minimum delay two-way, average delay forward, maximum delay forward, minimum delay forward, average delay backward, maximum delay backward, minimum delay backward, average forward frame loss ratio, maximum forward frame loss ratio, minimum forward frame loss ratio, average backward frame loss ratio, maximum backward frame loss ratio, minimum backward frame loss ratio, jitter forward, jitter backward, and availability of the devices that are configured using the Y.1731 technology.</td>
<td><strong>IPSLA Y.1731</strong> For details about the IPSLA Y.1731 monitoring policy, see IP SLA Y.1731 Monitoring Policy, on page 881.</td>
<td>Average Delay Two Way, Average Delay Forward, Average Delay Backward, Average Positive Jitter Forward, Average Negative Jitter Forward, Average Positive Jitter Backward, Average Negative Jitter Backward, Average Forward Frame Loss Ratio, Average Backward Frame Loss Ratio</td>
</tr>
<tr>
<td>Interface Health</td>
<td>Displays the interface details for the devices in the network.</td>
<td><strong>Interface Health</strong> For details about the Interface Health monitoring policy, see Interface Health Monitoring Policy, on page 880.</td>
<td>Statistics</td>
</tr>
<tr>
<td>Interface Graphs</td>
<td>Graphical representation of the interface traffic statistics over time: in traffic, out traffic, in utilization and out utilization.</td>
<td><strong>Interface Health</strong> For details about the Interface Health monitoring policy, see Interface Health Monitoring Policy, on page 880.</td>
<td>Statistics</td>
</tr>
<tr>
<td>Report Type</td>
<td>Provides:</td>
<td>Monitoring Policies That Must Be Enabled</td>
<td>Parameters That Must Be Activated</td>
</tr>
<tr>
<td>----------------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>-----------------------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td>Interface Top N</td>
<td>Tabular representation of Top N reports of interface traffic statistics: maximum in traffic, average in traffic, maximum out traffic, average out traffic, maximum in utilization, maximum out utilization and current in utilization, current out utilization, in errors, out errors, in discards, out discards and interface availability.</td>
<td><em>Interface Health</em></td>
<td>Statistics</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For details about the Interface Health monitoring policy, see <em>Interface Health Monitoring Policy</em>, on page 880.</td>
<td></td>
</tr>
<tr>
<td>Interface Traffic</td>
<td>Tabular representation of interface traffic statistics: in traffic rate, out traffic rate, in utilization, out utilization, in errors, out errors, in discards, out discards, CRC errors and percentage.</td>
<td><em>Interface Health</em></td>
<td>Statistics and CRC</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For details about the Interface Health monitoring policy, see <em>Interface Health Monitoring Policy</em>, on page 880.</td>
<td></td>
</tr>
<tr>
<td>Link Optical SFP Power Level Reports</td>
<td>Tabular representation of the A end device, A end interface, Z end device, Z end interface, and their Tx and Rx power levels.</td>
<td><em>Optical SFP</em></td>
<td>Optical Tx Power, Optical Rx Power</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For more details about the Optical SFP monitoring policy, see <em>Optical SFP Monitoring Policy</em>, on page 885.</td>
<td></td>
</tr>
</tbody>
</table>

**Note** The prerequisite for this report is to have CDP/LLDP enabled links in the network.
<table>
<thead>
<tr>
<th>Report Type</th>
<th>Provides:</th>
<th>Monitoring Policies That Must Be Enabled</th>
<th>Parameters That Must Be Activated</th>
</tr>
</thead>
</table>
| Link Utilization                | Tabular representation of A end device, A end interface, A member of, A end in utilization, A end out utilization, Z end device, Z end interface, Z member of, event time, and the interface utilization of the interfaces participating in the link, including the link aggregate group they belong to. | *Interface Health*  
For details about the Interface Health monitoring policy, see [Interface Health Monitoring Policy](#), on page 880. | Statistics                       |
|                                 | **Note** The prerequisite for this report is to have CDP/LLDP enabled links in the network. |                                                                                                           |                                  |
| MPLS Link Statistics            | Representation of link delay and jitter in MPLS segment routing.          | *MPLS Link Statistics*  
For more details about the MPLS monitoring policy, see [MPLS Link Performance Monitoring Policy](#), on page 884. | Average Delay, Min Delay, Max Delay, RX Packets, TX Packets |
| Optical SFP interface report    | Tabular representation of transmit/receive power levels of the devices for interfaces. Includes device name, interface name, RxPower, TxPower, EVENTTIME. | *Optical SFP*  
For more details about the Optical SFP monitoring policy, see [Optical SFP Monitoring Policy](#), on page 885. | Optical Tx Power, Optical Rx Power |
<table>
<thead>
<tr>
<th>Report Type</th>
<th>Provides:</th>
<th>Monitoring Policies That Must Be Enabled</th>
<th>Parameters That Must Be Activated</th>
</tr>
</thead>
</table>
| PWE3 Statistics | Tabular representation of PWE3 traffic and availability statistics including device name, IP address, VC ID, peer address, VC type, current in bit rate, current out bit rate, current in byte rate, current out byte rate, current in packet rate, current out packet rate, global availability, in availability and out availability. | *Pseudowire Emulation Edge to Edge*  
For details about the Pseudowire Emulation Edge to Edge monitoring policy, see [Pseudowire Emulation Edge to Edge Monitoring Policy](#) on page 881. | PW VC Perf Total In HC Packets Rate, PW VC Perf Total In HC Bytes Rate, PW VC Perf Total Out HC Packets Rate, PW VC Perf Total Out HC Bytes Rate, PW VC Oper Status Up, PW VC Inbound Oper Status Up, PW VC Outbound Oper Status Up, PW VC Oper Status Down, PW VC Perf Total In HC Packets, PW VC Perf Total In HC Bytes, PW VC Perf Total Out HC Packets, PW VC Perf Total Out HC Bytes, PW VC Inbound Oper Status Down, PW VC Outbound Oper Status Down |
| PWE3 Top N | Tabular representation of Top N reports of PWE3 statistics including device name, IP address, VC ID, peer address, VC type, average in byte rate, average out byte rate, maximum in byte rate, maximum out byte rate, average in bit rate, average out bit rate, maximum in bit rate, maximum out bit rate, average in packet rate, average out packet rate, maximum in packet rate, maximum out packet rate, global inbound availability and global outbound availability. | *Pseudowire Emulation Edge to Edge*  
For details about the Pseudowire Emulation Edge to Edge monitoring policy, see [Pseudowire Emulation Edge to Edge Monitoring Policy](#) on page 881. | PW VC Perf Total In HC Packets Rate, PW VC Perf Total In HC Bytes Rate, PW VC Perf Total Out HC Packets Rate, PW VC Perf Total Out HC Bytes Rate, PW VC Oper Status Up, PW VC Inbound Oper Status Up, PW VC Outbound Oper Status Up, PW VC Oper Status Down, PW VC Perf Total In HC Packets, PW VC Perf Total In HC Bytes, PW VC Perf Total Out HC Packets, PW VC Perf Total Out HC Bytes, PW VC Inbound Oper Status Down, PW VC Outbound Oper Status Down |
<table>
<thead>
<tr>
<th>Report Type</th>
<th>Provides:</th>
<th>Monitoring Policies That Must Be Enabled</th>
<th>Parameters That Must Be Activated</th>
</tr>
</thead>
<tbody>
<tr>
<td>PWE3 Traffic Graphs</td>
<td>Graphical representation of PWE3 traffic including average in bit rate,</td>
<td><em>Pseudowire Emulation Edge to Edge</em></td>
<td>PW VC Perf Total In HC Packets Rate, PW VC Perf Total In HC Bytes Rate, PW VC Perf Total Out HC</td>
</tr>
<tr>
<td></td>
<td>average out bit rate, average in byte rate, average out byte rate,</td>
<td></td>
<td>Packets Rate, PW VC Perf Total Out HC Bytes Rate, PW VC Oper Status Up, PW VC Inbound Oper Status</td>
</tr>
<tr>
<td></td>
<td>average in packet rate, average out packet rate, global availability,</td>
<td></td>
<td>Up, PW VC Outbound Oper Status Up, PW VC Oper Status Down, PW VC Perf Total In HC Packets, PW VC</td>
</tr>
<tr>
<td></td>
<td>in availability and out availability.</td>
<td></td>
<td>Perf Total In HC Bytes, PW VC Perf Total Out HC Packets, PW VC Perf Total Out HC Bytes, PW VC</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Inbound Oper Status Down, PW VC Outbound Oper Status Down</td>
</tr>
<tr>
<td>QoS Policing</td>
<td>Tabular representation of the details about the policy map: ClassMap.</td>
<td><em>Quality of Service</em></td>
<td>Conformed Bytes Rate, Exceeded Bytes Rate, Violated Bytes Rate, Exceeded Packets, Violated Bytes,</td>
</tr>
<tr>
<td></td>
<td>The details include, direction of the policy map, average exceed byte</td>
<td></td>
<td>CIR, Conformed Bytes, Exceeded Bytes, PIR</td>
</tr>
<tr>
<td></td>
<td>rate, maximum exceed byte rate, maximum exceed date, average violate byte</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>rate, maximum violate byte rate, maximum violate date, average conformed</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>byte rate, maximum conformed byte rate, maximum conformed date, CIR</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>current rate and PIR current rate. Also, graphical representation of</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>exceed, violate and conformed byte rates.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Optical Performance Reports

Table 14: Optical Performance Reports lists the Optical Performance reports supported by Cisco EPN Manager. For all the graphical reports, ensure that you select a maximum of four interfaces when you schedule or run these reports. For all the tabular reports, use the Show field to specify the number of records to be displayed in a page when you schedule or run these reports.

The performance data displayed when you generate these reports depend on the monitoring policy parameter that you activate when you enable the monitoring policy. For a detailed list of monitoring type and the associated performance counters, see Monitoring Policies Reference, on page 879. For more information about monitoring policies, see Monitor Device and Network Health and Performance, on page 203. For information about how to interpret the report results, see Report Output Examples: Web GUI Output and CSV File Output, on page 279.
Enable the *Optical 1 day* or *Optical 15 mins* monitoring policies to populate data for these reports.

**Table 14: Optical Performance Reports**

<table>
<thead>
<tr>
<th>Report</th>
<th>Report Type</th>
<th>Provides:</th>
<th>Monitoring Policy Parameters That Must Be Activated</th>
<th>Parameters That Must Be Polled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ethernet</td>
<td>Ethernet Reports–NCS1K, NCS2K and NCS4K</td>
<td>Graphical and tabular reports that lists the total number of packets requested by the higher-level protocols to be transmitted, and which were not addressed to a multicast or broadcast address at this sub-layer, including those that were discarded or not sent. The details also include total number of multicast frames transmitted error free, total number of packets requested by higher-level protocols, total number of transmitted octets, total number of octets received on the interface and number of received packets that were discarded because of errors. To customize the report output for a new report, choose Reports &gt; Report Launch Pad &gt; Optical Performance &gt; Ethernet, click New, and then click Customize in the Settings area. To customize the report output for an existing report, choose Reports &gt; Report Launch Pad &gt; Optical Performance &gt; Ethernet, click the required report link, and then click Customize in the Settings area.</td>
<td><em>Optical 1 day</em> or <em>Optical 15 mins</em></td>
<td>Ethernet</td>
</tr>
</tbody>
</table>

For details about the information collected by optical monitoring policies, see Monitoring Policies Reference, on page 879. For information about how to interpret the report results, see Report Output Examples: Web GUI Output and CSV File Output, on page 279.
<table>
<thead>
<tr>
<th>Report</th>
<th>Report Type</th>
<th>Provides:</th>
<th>Monitoring Policy Parameters That Must Be Activated</th>
<th>Parameters That Must Be Polled</th>
</tr>
</thead>
</table>
| OTN                           | Section Monitoring NEnd & FEnd Reports- NCS1K, NCS2K and NCS4K | Graphical and tabular reports that list the OTN section monitoring details of devices and interfaces in the OTN circuit type. The details include number of background block errors and its ratio, number of errored seconds and its ratio, number of severely errored seconds and its ratio, number of unavailable seconds, and number of failure counts. | *Optical 1 day or*  *Optical 15 mins*  
For details about the information collected by optical monitoring policies, see *Monitoring Policies Reference*, on page 879.  
For information about how to interpret the report results, see  
*Report Output Examples: Web GUI Output and CSV File Output*, on page 279. | OTN DWDM Infrastructure¹ |
<p>| Path Monitoring NEnd &amp; FEnd Reports |                                                                 | Graphical and tabular reports that list the OTN path monitoring details of devices and interfaces in OTN circuit type. They provide details such as number of background block errors and its ratio, number of errored seconds and its ratio, number of severely errored seconds and its ratio, number of unavailable seconds, and number of failure counts. |                                                                                         | OTN                            |
| Forward Error Correction Reports- NCS1K, NCS2K and NCS4K |                                                                 | Graphical and tabular reports that list the OTN forward error correction details of devices and interfaces in the OTN circuit type. The details include the number of bit errors corrected, number of uncorrectable words, and Pre-forward error correction based bit error counts detected during the performance monitoring time interval. |                                                                                         | OTN                            |
| Tandem Connection Monitoring NEnd &amp; FEnd Reports |                                                                 | Graphical and tabular reports that provide the tandem connection monitoring details for the devices and interfaces in the OTN circuit type. The details include number of background block errors and its ratio, number of errored seconds and its ratio, number of severely errored seconds and its ratio, number of unavailable seconds, and number of failure counts. |                                                                                         | OTN                            |
| GFP Statistics Reports–NCS2K and NCS4K |                                                                 | Graphical and tabular reports that provide the generic framing procedure (GFP) statistics for the devices in the OTN circuit type. The GFP statistics include number of GFP frames and bytes received and transmitted, number of single and multiple bit errors received, number of packets received with CRC errors, invalid GFP type, and invalid CID, number of CMF frames received and transmitted, and number of cHEC and tHEC multiple bit errors. |                                                                                         | OTN DWDM Infrastructure¹ |</p>
<table>
<thead>
<tr>
<th>Report Type</th>
<th>Provides:</th>
<th>Monitoring Policy Parameters That Must Be Activated</th>
<th>Parameters That Must Be Polled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optical Power Reports-NCS1K, NCS2K, and NCS4K</td>
<td>Graphical and tabular reports that provide the average, minimum, and maximum percentage of optical input and output power of the received and transmitted signal for devices in a physical circuit type.</td>
<td>Optical 1 day or Optical 15 mins</td>
<td>Physical DWDM Infrastructure¹</td>
</tr>
<tr>
<td>Laser Bias Current Reports-NCS1K, NCS2K, and NCS4K</td>
<td>Graphical and tabular reports that provide the average, minimum, and maximum percentage of laser bias current. The laser bias current is the normalized value expressed as the integer percentage.</td>
<td>For details about the information collected by optical monitoring policies, see Monitoring Policies Reference, on page 879.</td>
<td></td>
</tr>
<tr>
<td>Optical Physical Report -NCS1K, NCS2K, NCS4K</td>
<td>Graphical and tabular reports that provide the average, minimum, and maximum value of optical power on the unidirectional port. The details include the average, minimum and maximum Optical Service Channel power level The details of average, minimum and maximum optical signal-to-noise ratio, optical power warning, chromatic dispersion, second order polarization mode dispersion, polarization dependent loss, differential group delay, polarization change rate, and phase noise.</td>
<td>For information about how to interpret the report results, see Report Output Examples: Web GUI Output and CSV File Output, on page 279.</td>
<td></td>
</tr>
<tr>
<td>Report</td>
<td>Report Type</td>
<td>Provides:</td>
<td>Monitoring Policy Parameters That Must Be Activated</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>SDH Or SONET</td>
<td>SDH Regenerator Section Report</td>
<td>Graphical and tabular reports that provide the performance monitoring details of the SDH regenerator section layer for the devices in your network. The details include the number of background block errors and its ratio, number of errored seconds and its ratio, number of severely errored seconds and its ratio, number of unavailable seconds, number of errored block, and number of out-of-frame seconds.</td>
<td><em>Optical 1 day</em> or <em>Optical 15 mins</em></td>
</tr>
<tr>
<td>SDH Multiplex Section NEnd &amp; FEnd Reports - NCS2K</td>
<td>SDH Multiplex Section NEnd &amp; FEnd Reports - NCS2K</td>
<td>Graphical and tabular reports that provide the performance monitoring details of SDH multiplex section layer for the devices in your network. The details include number of background block errors and its ratio, number of errored seconds and its ratio, number of severely errored seconds and its ratio, number of unavailable seconds, number of errored blocks, number of failure counts, protection switching — Switching count, ring count, span count, working count, duration, ring duration, span duration and working duration.</td>
<td>For details about the information collected by optical monitoring policies, see Monitoring Policies Reference, on page 879. For information about how to interpret the report results, see Report Output Examples: Web GUI Output and CSV File Output, on page 279.</td>
</tr>
<tr>
<td>SDH Multiplex Section NEnd &amp; FEnd Reports - NCS4K</td>
<td>SDH Multiplex Section NEnd &amp; FEnd Reports - NCS4K</td>
<td>Graphical and tabular reports that provide the performance monitoring details of SDH multiplex section layer for the devices in your network. The details include number of background block errors and its ratio, number of errored seconds and its ratio, number of severely errored seconds and its ratio, number of unavailable seconds, and number of errored blocks.</td>
<td></td>
</tr>
<tr>
<td>SONET Section Report</td>
<td>SONET Section Report</td>
<td>Graphical and tabular reports that provide performance monitoring details of SONET section layer for the devices in your network. The details include number of coding violations, number of errored seconds, number of severely errored seconds, and number severely errored frame seconds.</td>
<td></td>
</tr>
<tr>
<td>SONET Line NEnd &amp; FEnd Reports - NCS2K</td>
<td>SONET Line NEnd &amp; FEnd Reports - NCS2K</td>
<td>Graphical and tabular reports that provide performance monitoring details of SONET line layer for the devices in your network. The details include number of coding violations, number of errored seconds, number of severely errored seconds, number of unavailable seconds, number of failure counts, protection switching — Switching count, ring count, span count, working count, duration, ring duration, span duration and working duration.</td>
<td></td>
</tr>
<tr>
<td>SONET Line NEnd &amp; FEnd Reports - NCS4K</td>
<td>SONET Line NEnd &amp; FEnd Reports - NCS4K</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Performance Reports

This section lists the basic performance reports supported by Cisco EPN Manager. It also lists the monitoring policies and parameters that must be enabled for each of the report type. These reports are applicable for both Optical and Carrier Ethernet technologies.

#### Note

These reports are not supported for Cisco NCS 2000 devices.

For more information about monitoring policies, see Monitor Device and Network Health and Performance, on page 203.

<table>
<thead>
<tr>
<th>Report Type</th>
<th>Provides:</th>
<th>Monitoring Policies That Must Be Enabled</th>
<th>Parameters That Must Be Activated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Summary</td>
<td>Representation of the application configuration details.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Conversations</td>
<td>Displays the conversation details.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>End User Summary</td>
<td>Displays the end user summary reports for each client.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Environmental Temperature</td>
<td>Tabular representation of current, average, minimum, and maximum temperature for network devices.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Site Summary</td>
<td>Displays the site summary reports in the network.</td>
<td>NA</td>
<td>NA</td>
</tr>
</tbody>
</table>

1. You must activate this parameter for all Cisco Optical Networking Services (ONS) and Cisco Network Convergence System (NCS) 2000 series devices.
Parameters That Must Be Activated

Monitoring Policies That Must Be Enabled

Provides:

<table>
<thead>
<tr>
<th>Report Type</th>
<th>Provides:</th>
<th>Monitoring Policies That Must Be Enabled</th>
<th>Parameters That Must Be Activated</th>
</tr>
</thead>
</table>
| Threshold Violations  | Lists the threshold violation alarms data (source, event type, category and description) for your network in a table. | Interface Health  
For details about the Device Health monitoring policy, see Device Health Monitoring Policy, on page 879. | Admin Status Up/Down  
Operational Status Up/Down  
Admin Status Up and Operational Status Down Percentage |
| Voice Video Summary   | Lists the voice video summary reports in the network.                      | NA                                                                                                      | NA                                               |
| WAN Performance Analysis | Lists the WAN Application Performance Analysis in the network.         | NA                                                                                                      | NA                                               |
| WAN Traffic Analysis Summary | Displays the WAN traffic details.            | NA                                                                                                      | NA                                               |

**Network Summary Reports**

This section lists the Network Summary reports supported by Cisco EPN Manager. These reports provide information about the health of the network.

<table>
<thead>
<tr>
<th>Report Type</th>
<th>Provides:</th>
<th>Monitoring Policies That Must Be Enabled</th>
<th>Parameters That Must Be Polled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link Flap Report</td>
<td>Tabular representation of the A end device, A end interface, Z end device, Z end interface, link name and the number of flaps.</td>
<td>NA</td>
<td>NA</td>
</tr>
</tbody>
</table>

**Device Reports**

This section lists the device reports supported by Cisco EPN Manager. It also lists the monitoring policies and parameters that must be enabled for each of the report type. These reports are applicable for both Optical and Carrier Ethernet technologies.

**Note**

Device reports are not supported for Cisco NCS 2000 devices.

For more information about monitoring policies, see Monitor Device and Network Health and Performance, on page 203.
<table>
<thead>
<tr>
<th>Report Type</th>
<th>Provides:</th>
<th>Monitoring Policies That Must Be Enabled</th>
<th>Parameters That Must Be Activated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm Report</td>
<td>List of alarms for devices in the network. Includes severity, message, status, failure source, time stamp, creation time, device timestamp, owner, category, condition, location, service affecting, satellite ID.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>CPU Utilization</td>
<td>Table listing all devices with their average CPU usage for a specified time period.</td>
<td><em>Device Health</em>&lt;br&gt;For details about the Device Health monitoring policy, see <em>Device Health Monitoring Policy</em>, on page 879.</td>
<td>CPU Utilization</td>
</tr>
<tr>
<td>Detailed Hardware</td>
<td>Table listing all devices in ascending order according to their average CPU usage for a specified time period.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Detailed Software</td>
<td>Hardware information for the entire inventory or device types (for example, Switches and Hubs, Routers, and Optical Transport). Provides system information and the last time the system was updated.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Device Availability</td>
<td>Table listing all the available devices in the network and their reachability percentage.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Device Credential Verification</td>
<td>The credential status of the devices in your network. Includes the login, reachability, and protocol statuses of each device. Also, includes the last modified date and time for the device.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Device Health</td>
<td>CPU utilization, memory utilization, and availability information of the network devices for a specified time period. Includes minimum, maximum, and average for all CPU modules and memory pools on a device.</td>
<td><em>Device Health</em>&lt;br&gt;For details about the Device Health monitoring policy, see <em>Device Health Monitoring Policy</em>, on page 879.</td>
<td>CPU Utilization</td>
</tr>
<tr>
<td>DMVPN Reports</td>
<td>DMVPN information for the devices in the network.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Event Report</td>
<td>List of events for devices in your network. Includes description, failure source, time stamp, device timestamp, severity, category, condition.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>GET VPN Network Status</td>
<td>VPN Network Status for the devices in the network.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Identity Capability</td>
<td>Identity capability summary information for the switches in the network.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Interface Detail</td>
<td>Interface details for the devices in your network. Includes device name, port name, port description, MAC address, admin status, operational status.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Report Type</td>
<td>Provides:</td>
<td>Monitoring Policies That Must Be Enabled</td>
<td>Parameters That Must Be Activated</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>----------------------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td>Inventory</td>
<td>Basic inventory data for the devices in your network. Includes count of controllers by model, count of controllers by software version, controller inventory, count of APs by model, count of APs by software version, AP inventory, disassociated AP(s), autonomous AP inventory, maintenance mode AP(s), count of MSEs by version, MSEs, count of switches by model, count of switches by version, switch inventory, switch devices software images, count of routers by model, count of routers by version, router inventory, router devices software images, count of Cisco Interfaces and Modules devices by model, count of Cisco Interfaces and Modules devices by software version, Cisco Interfaces and Modules devices inventory, Cisco Interfaces and Modules - software images, count of storage networking devices by model, count of storage networking devices by software version, storage networking devices inventory, storage networking devices - software images, count of security and VPN by model, count of security and VPN by software version, security and VPN inventory.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Memory Utilization</td>
<td>Memory utilization information for a specified time period. Includes information for all memory pools/modules.</td>
<td>NA</td>
<td>Memory Pool Utilization</td>
</tr>
<tr>
<td>Port Capacity</td>
<td>Interface utilization percentages for the devices in the network.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>VLAN</td>
<td>VLAN information for the switches in the network.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Wired Detailed Device Inventory</td>
<td>Detailed inventory data for the wired devices in your network. Includes system information, chassis information, module information, module port interfaces, VLAN interfaces, software image information, memory pool information, flash devices, flash partition, flash file.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Up to 5 devices can be selected if you want to run the report immediately without saving it. To include more than 5 devices, save or schedule the report.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Wired Device Availability</td>
<td>List of wired devices with highest availability in your network. Includes device name, average availability (%).</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Wired Module Detail</td>
<td>Table listing detailed module information for wired devices in the network including device name, device IP, equipment name, number of ports, operational status, vendor equipment type, manufacturer, serial number, and UDI.</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>Wired Port Attribute</td>
<td>Port attribute information such as admin status, operational status, mac address, etc. Includes VLAN ID, access mode VLAN, device IP address, description, MAC address, Admin status, operational status, type, MTU, speed, duplex, IsTrunk, trunk encapsulation</td>
<td>NA</td>
<td>NA</td>
</tr>
</tbody>
</table>
Create, Schedule, and Run a New Report

The Report Launch Pad provides access to all Cisco EPN Manager reports from a single page. From this page, you can perform all report operations: Create, save, view, schedule, and customize.

To see more report details, hover the cursor over the tooltip next to the report type.

To create, schedule, and run a new report:

---

**Step 1**
From the left sidebar, choose Reports > Report Launch Pad.

**Step 2**
Locate the report you want to launch, then click New.

**Step 3**
In the Report Details page, enter the report title. You can edit the Report Title field.

**Step 4**
Choose the appropriate Report By category from the drop down list.

**Step 5**
The Report Criteria field allows you to sort your results depending on the previous Report By selection made.

---

**Note**
If you select the virtual domain checkbox at the top, edit button is enabled when one or more values present in the report criteria filter.

**Step 6**
Click Edit to open the device selection wizard and select the required device. Click on Preview tab to confirm the selected devices and click Ok. You can also remove the selected devices.

The parameters shown in the Report Details page depend on the report type you chose. With some reports, you are required to customize the report results. For more information about how to customize a report result, see Customize Report Results, on page 277.

---

**Note**
In Client reports, SSIDs are listed only if their Wireless LAN Controllers are mapped to a Virtual Domain.

**Step 7**
If you plan to run this report later or as a recurring report, enter the required Schedule parameters.

**Step 8**
To run the report, choose one of the following options:

- Run—Runs the report without saving the report setup.
- Save—Saves this report setup without immediately running the report. If you have entered Schedule parameters, the report runs automatically at the scheduled date and time.
- Run and Save—Saves this report setup and runs the report immediately.
- Save and Export—Saves the report, runs it, and exports the results to a file. You will be prompted to:
  - Select the exported report’s file format (CSV or PDF). Exported CSV file is a single .csv file which has capability to hold one million records. If the number of records exceeds one million, then another CSV file will be generated accommodating the remaining records. Finally, both the CSV files will be provided in zip format.
  - Choose whether to send an email when the report has been generated. If you choose this option, you must enter the destination email address and the email subject line content, and choose whether you want the exported file included as an attachment to the email.

When you are finished, click OK.

- Save and Email—Saves the report, runs it, exports the results as a file, and emails the file. You will be prompted to:
  - Select the exported report file format.
Note  The file size must not exceed 25 MB.

• Enter the destination email address and the email subject line content.
When you are finished, click OK.
• Cancel—Returns to the previous page without running or saving this report.

Customize Report Results

Many reports allow you to customize their results, letting you include or exclude different types of information. Reports that support this feature display a Customize button. Click this button to access the Create Custom Report page and customize the report results.

To customize a report result:

Step 1  Choose the report you want to customize:
a) Create a new report. Click Reports > Report Launch Pad.
b) Customize a recurring report. Click Reports > Saved Report Templates and, then click the report name hyperlink.

Step 2  In the Report Details page, click Customize.
Step 3  On the Create Custom Report page, complete the required information, then click Apply to confirm the changes.
Step 4  Click Save in the Report Details page.

Filter and Customize Report Data Using User Defined Fields

You can create custom attributes and assign values for the attributes. See Create User Defined Fields for Custom Values, on page 93 for information about how to create user defined fields (UDF). You can then use these UDFs to filter and customize the report results.

Cisco EPN Manager scans the values of UDFs created every two minutes and generates a UDF.json file, in which the metadata are saved. You can access this file from the /opt/CSCOlumos/conf/rfm/classes/com/cisco/server/reports/conf/UDF.json location.

Here is an example of how the metadata for the UDFs are displayed in the UDF.json file:

```json
[
    {
        "label": "internal",
        "hidden": true,
        "displayName": "Internal",
        "fixedColumn": false
    },
    {
        "label": "location",
        "hidden": true,
        "displayName": "Location",
        "fixedColumn": false
    }
]
```
In this example:

- the attribute, `label` is the user defined field created in the Administration > Settings > System Settings > Inventory > User Defined Fields page.

- the attribute, `hidden` is set to True, by default. If this attribute is set to True, the UDF is hidden on the Reports page. You need to set this attribute to False so that the UDF is available for selection when you customize the report results.

- the attribute, `displayName` is used to change the UDF name that will be displayed in the report results.

- The attribute, `fixedColumn` is applicable only when the hidden attribute is set to False.

After you made the required changes in the `UDF.json` file, you can customize the report results. See Customize Report Results, on page 277.

You can also change the filter type of the UDF in the `UDF.json` file. The default filter type is String.

Here are few examples of filter types and their definitions:

```json
{
    "label": "internal",
    "displayName": "Internal",
    "hidden": false,
    "fixedColumn": false,
    "filterMetadata": {
        "sqlDataType": "Boolean",
        "attr": "internal",
        "label": "UDF: Internal Used",
        "filterType": "boolean"
    }
},
{
    "label": "location",
    "displayName": "Location",
    "hidden": false,
    "fixedColumn": false
},
{
    "label": "quality",
    "displayName": "Quality",
    "hidden": false,
    "fixedColumn": false,
    "filterMetadata": {
        "sqlDataType": "Number",
        "selectItems": {
            "1": "High Quality",
            "2": "Mid Quality",
            "3": "Low Quality"
        },
        "attr": "quality",
        "label": "UDF: Quality",
        "filterType": "enumeration"
    }
}
```
After you made the required changes in the UDF.json file, use the Advanced Filter option in the Report Details page to filter the report data.

Report Output Examples: Web GUI Output and CSV File Output

In this example, a section monitoring report is generated for Cisco NCS 2000 series devices that are available in the near end of the network. You can choose to view the result, either at the bottom of the Report Details page, or export the results to a CSV or PDF file. For more information about how to create and run a report, see Create, Schedule, and Run a New Report, on page 276.
The following figures show how the results are displayed at the bottom of the Report Details page.

If scheduling is enabled and you choose to export the result to a CSV file, the report is saved in the repository named /localdisk/ftp/reports. You can adjust the location of the report repository. For more information, see Report Purging, on page 740.

Note

The file naming convention for the CSV file is ReportTitle_yyyymmdd_hhmmss.csv, where yyyymmdd is the year, month, and date, and hhmmss is the hours, minutes, and seconds when the report result was exported.

The following figure shows how the results are displayed in a CSV file.

<table>
<thead>
<tr>
<th>DeviceName</th>
<th>Device IP Address</th>
<th>Interface</th>
<th>DateTime</th>
<th>BBE-SM</th>
<th>BBER-SM</th>
<th>ES-SM</th>
<th>ESP-SM</th>
<th>SES-SM</th>
<th>SESE-SM</th>
<th>UAS-SM</th>
<th>FG-SM</th>
</tr>
</thead>
<tbody>
<tr>
<td>PN-01-144</td>
<td>192.58.295.144</td>
<td>CFW-2-2-2</td>
<td>2015-04-02, 12:00:00 IST</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>PN-01-145</td>
<td>192.58.295.145</td>
<td>CFW-2-2-2</td>
<td>2015-04-02, 15:00:00 IST</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>PN-01-146</td>
<td>192.58.295.146</td>
<td>CFW-2-2-2</td>
<td>2015-04-02, 20:00:00 IST</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>PN-01-147</td>
<td>192.58.295.147</td>
<td>CFW-2-2-2</td>
<td>2015-04-02, 23:00:00 IST</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

The following table explains how you can interpret the section monitoring report result.

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device Name</td>
<td>Name of the device that is in the near end of the network.</td>
</tr>
<tr>
<td>Device IP Address</td>
<td>IP address of the device.</td>
</tr>
<tr>
<td>Interface</td>
<td>Interface name of the device.</td>
</tr>
<tr>
<td>DateTime</td>
<td>Date and time when the section monitoring data was collected for the device. The value in this column depends on the report interval that you chose when you created the report. The report interval can be 15 minutes or 24 hours.</td>
</tr>
<tr>
<td>BBE-SM</td>
<td>Number of background block errors for the device.</td>
</tr>
<tr>
<td>Column Name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------</td>
</tr>
<tr>
<td>BBER-SM</td>
<td>Background block error ratio for the device.</td>
</tr>
<tr>
<td>ES-SM</td>
<td>Number of errored seconds for the device.</td>
</tr>
<tr>
<td>ESR-SM</td>
<td>Errored seconds ratio for the device.</td>
</tr>
<tr>
<td>SES-SM</td>
<td>Number of severely errored seconds for the device.</td>
</tr>
<tr>
<td>SESR-SM</td>
<td>Severely errored seconds ratio for the device.</td>
</tr>
<tr>
<td>UAS-SM</td>
<td>Number of unavailable seconds for the device.</td>
</tr>
<tr>
<td>FC-SM</td>
<td>Number of failure counts (AIS/RFI detected) for the device.</td>
</tr>
</tbody>
</table>

For detailed descriptions of performance counters that are displayed in the results of other optical performance reports, see Performance Counters for Optical Monitoring Policies, on page 888.

### Troubleshooting Tips for an Empty Report

If the report was run successfully but you do not have an output file that can be exported, you can try one of the following troubleshooting tips:

<table>
<thead>
<tr>
<th>Check if you have...</th>
<th>For example:</th>
</tr>
</thead>
<tbody>
<tr>
<td>... enabled the correct monitoring policy. For details on what monitoring policies must be enabled, see Monitoring Policies Reference, on page 879.</td>
<td>For QoS reports, QoS monitoring policy must be enabled.</td>
</tr>
</tbody>
</table>
| ... enabled the periodic collection. | For any System Monitoring Periodic reports (CPU/Disk/Memory), the periodic collection must be enabled. Once enabled, the report must be generated after 12 hours to see the output.  
**Note** Periodic collection can be enabled by clicking Periodic Collection Enable button under System Monitoring Setting in https://\<Server IP>/webacs/ncsDiag.do. |
<p>| ... chosen the correct device type for a particular report. | Do not choose NCS devices for generating CE Performance reports as they are optical devices. |
| ... selected the correct time period while generating a report. | You cannot choose a 2-week time period if you enabled the policy only 2 days ago. |
| ... configured the device properly. For more details, see Configure Devices So They Can Be Modeled and Monitored, on page 44. | For QoS reports, QoS must be configured/enabled on the device. |</p>
<table>
<thead>
<tr>
<th>Check if you have...</th>
<th>For example:</th>
</tr>
</thead>
<tbody>
<tr>
<td>... successful device inventory collection. For more details, see Find Devices With Inventory Collection or Discovery Problems, on page 58</td>
<td>For the reports to have data, the inventory collection status must be Completed.</td>
</tr>
</tbody>
</table>
PART V

Configure Devices

• Configure Devices, on page 285
• Create Templates To Automate Device Configuration Changes, on page 409
• Manage Cable Devices, on page 427
CHAPTER 12

Configure Devices

This chapter provides the following topics:

- Ways to Configure Devices Using Cisco Evolved Programmable Network Manager, on page 285
- Which Devices Support the Configuration Operations?, on page 286
- Identify the Commands Used In a CLI Configuration Template, on page 286
- Change a Device's Credentials and Protocol Settings, on page 287
- Change Basic Device Properties, on page 287
- Enable and Disable Interfaces, on page 289
- Configure Physical Attributes of Device Interfaces, on page 289
- Configure Circuit Emulation, on page 292
- Synchronize the Clock Using Sync-E, BITS, and PTP, on page 310
- Configure IP SLAs (TWAMP Responder), on page 315
- Configure Interfaces, on page 316
- Configure Devices Using the Chassis View, on page 343
- Configure Optical Cards, on page 355
- Discover and Configure MPLS LDP and MPLS-TE Links, on page 370
- Analyze Ports Using SPAN and RSPAN, on page 373
- Configure and View Ethernet Link Aggregation Groups, on page 375
- Configure Routing Protocols and Security, on page 378
- Configure EOAM Fault and Performance Monitoring, on page 386
- Configure Quality of Service (QoS), on page 394
- Save Your Device Changes, on page 406
- Launch Cisco Transport Controller to Manage Cisco NCS and Cisco ONS Devices, on page 407

Ways to Configure Devices Using Cisco Evolved Programmable Network Manager

Cisco EPN Manager provides two ways to change the physical devices in your network. The actions you can perform depend on your user account privileges and the types of devices in your network.
Which Devices Support the Configuration Operations?

Configuration operations are supported on a device if:

- The device model is supported by Cisco EPN Manager.
- The device operating system is supported by Cisco EPN Manager.
- The applicable technology or service is supported by Cisco EPN Manager and is enabled on the device.

To find out what is supported, see Cisco Evolved Programmable Network Manager Supported Devices.

Identify the Commands Used In a CLI Configuration Template

Use this procedure to view the exact commands that are used by any of the commands you launch from the CLI Templates drawer.

Step 1 Choose Configuration > Templates > Features and Technologies, then choose CLI Templates. For example:
• Out-of-the-box templates are under **System Templates - CLI**.

• Customized templates are under **My Templates**.

**Step 2**  
Double-click the template in the left sidebar Templates menu.

**Step 3**  
In the Template Detail area, choose the **CLI Content** tab. The commands are displayed in that tab.

---

## Change a Device's Credentials and Protocol Settings

Use the following procedure to update device credentials and protocol settings. When you save the settings to the database, you can also perform an inventory collection to gather all physical and logical device changes and save those changes to the database, rather than wait for the daily inventory collection.

**Step 1**  
Choose **Inventory > Network Devices**.

**Step 2**  
Select the device you want to edit, and click **Edit**. You can also choose several devices and make bulk changes.

**Step 3**  
Double-click the parameters you want to change. Depending on the device type, you can edit:

- Credential profile being used by device
- Group the device belongs to
- SNMP port, retries, timeout, credentials, and SNMPv3 authentication information
- Telnet/SSH2 credentials and timeout
- HTTP/HTTPS credentials, port, timeout
- IPSec parameters
- TL1 credentials and proxy IP address (for GNE/ENEs)

**Step 4**  
Check that the new credentials are the same as those on the physical device by clicking **Verify Credentials**.

**Step 5**  
Save your changes:

- **Update** saves your changes in the database.
- **Update & Sync** saves your changes to the database, but also collects device physical and logical inventory and saves all changes to the database.

---

## Change Basic Device Properties

Cisco EPN Manager provides command templates that you can use to make basic property changes on your physical devices. To use these templates, choose **Configuration > Templates > Features & Technologies**, then choose **CLI Templates > System Templates – CLI** from the Templates pane on the left.
The operations you perform here are different from those you perform with the Edit wizard (which you can launch from the Network Devices table). The Edit wizard changes the device property information that is saved in the database. It does not change properties on physical devices.

### CLI Configuration Template Name

<table>
<thead>
<tr>
<th>Configuration Template Name</th>
<th>Use it to:</th>
<th>Required Input Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add-Host-Name-IOS and -IOS-XR</td>
<td>Configure the client host name</td>
<td>Host name</td>
</tr>
<tr>
<td>Remove-Host-Name-IOS and -IOS-XR</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Syslog-Host-Logging-IOS and -IOS-XR</td>
<td>Specify host to which messages of a certain level will be logged</td>
<td>Host name</td>
</tr>
<tr>
<td>Add-Tacacs-Server-IOS and -IOS-XR</td>
<td>Configure the TACACS or TACACS+ server to use for authentication</td>
<td>Host address, key value, authentication list name, group name</td>
</tr>
<tr>
<td>Remove-Tacacs-Server-IOS and -IOS-XR</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add-Tacacs-Plus-Server-IOS and -IOS-XR</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove-Tacacs-Plus-Server-IOS and -IOS-XR</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add-SNMP-Configuration-IOS and -IOS-XR</td>
<td>Configure SNMP version, password, password encryption, server and group settings, UDP port, and so forth</td>
<td>Host name, community name, SystemOwner</td>
</tr>
<tr>
<td>Remove-SNMP-Configuration-IOS and -IOS-XR</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Enable-Traps-ASR903</td>
<td>Enable and disable traps on the Cisco ASR 903</td>
<td>Trap name (a list is provided)</td>
</tr>
<tr>
<td>Disable-Traps-ASR903</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Enable-Traps-IOS and -IOS-XR</td>
<td>Enable and disable traps on Cisco IOS and Cisco IOS XR devices</td>
<td></td>
</tr>
<tr>
<td>Disable-Traps-IOS and -IOS-XR</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Enable-Traps-ME3600 and -ME3800</td>
<td>Enable and disable traps on the Cisco ME3600 and ME3800</td>
<td></td>
</tr>
<tr>
<td>Disable-Traps-ME3600 and -ME3800</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Enable-Trap-Host-IOS and IOS-XR</td>
<td>Set a target host for SNMP traps</td>
<td>Host IP address, community string</td>
</tr>
<tr>
<td>Show-Users-on-Device-IOS and -IOS-XR</td>
<td>Display user session information for Cisco IOS and Cisco IOS XR devices</td>
<td>(Executed from selected device; no input required)</td>
</tr>
</tbody>
</table>
Enable and Disable Interfaces

Use the Interface 360 view to quickly enable and disable an interface. While you can perform these same actions from a Device Details page, using the Interface 360 view may be more efficient (for example, when responding to an alarm). The top right of the Interface 360 view provides an Actions menu that provides enable and disable options.

To launch an Interface 360 view, see Get a Quick Look at a Device Interface: Interface 360 View, on page 87.

To enable and disable an interface from a device's Device Details page, see the interface configuration topics (Ethernet, Loopback, Serial, Tunnel, and so forth).

Configure Physical Attributes of Device Interfaces

Using Cisco EPN Manager, you can configure the physical attributes of your device's interfaces. Attributes such as card operating modes, bandwidth allocation per slot, slot pluggable types (such as VCoP), and AINS settings are configurable.

To configure the physical attributes of interfaces:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Choose Configuration &gt; Network Devices.</td>
</tr>
<tr>
<td>2</td>
<td>Select the device that you want to configure by clicking the device’s name hyperlink.</td>
</tr>
<tr>
<td>3</td>
<td>Click the Configuration tab, then click the Logical View left side tab.</td>
</tr>
<tr>
<td>4</td>
<td>To configure the interfaces, navigate to the paths described in the table below.</td>
</tr>
<tr>
<td>5</td>
<td>To make your changes, click the controller/card name hyperlink and click the Edit icon at the top right corner of the page. Make your changes and click Save.</td>
</tr>
</tbody>
</table>

### Table 15: Physical Attributes Configuration for Interfaces

<table>
<thead>
<tr>
<th>Physical Interface Configuration</th>
<th>Navigation</th>
<th>Comments/Descriptions</th>
<th>Supported Slots/Controllers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure card type as 5G or 10G.</td>
<td><strong>Physical &gt; Card Mode</strong></td>
<td>You can change the configuration from 10G to 5G but the other way around is not supported. Depending on the device you select, the default card mode is set to either 5G or 10G. For mode detailed information on the supported card modes, see Supported Devices for Cisco EPN Manager. <strong>Note</strong> You cannot configure the card modes on slots that are part of active circuits.</td>
<td>For more information about the device slots and supported card mode types, see table below (Device Slots and Supported Card Mode Types).</td>
</tr>
<tr>
<td>Physical Interface Configuration</td>
<td>Navigation</td>
<td>Comments/Descriptions</td>
<td>Supported Slots/Controllers</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>------------</td>
<td>-----------------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td>Configure card modes as T1 or E1.</td>
<td>Physical &gt; Card Mode</td>
<td>You can change the configuration from T1 to E1 or vice versa depending on the device and card you select. T1 and E1 modes represent the type of channelization mode used on the card. <strong>Note</strong> You cannot configure the card modes on slots that are part of active circuits.</td>
<td>-</td>
</tr>
<tr>
<td>Configure card modes as OC3 or OC12.</td>
<td>Physical &gt; Card Mode</td>
<td>You can set the card modes of A900-IMA4OS cards (of Cisco ASR 903 routers) as OC3 or OC12. OC3 and OC12 modes represent the data transmission rates on the different optical transmission lines.</td>
<td>-</td>
</tr>
<tr>
<td>Configure Card Protection</td>
<td>Physical &gt; Card Protection</td>
<td>Configure cards to act as primary or backup members (interfaces). A primary interface and its backup interface together make up a Protection Group (denoted by a unique integer). Associated cards with backup members ensure that when the primary interface fails, the protecting interface quickly assumes the traffic load from the primary interface. Cards displayed as the Active members are cards functioning as the protecting members of the service. Ensure that the Primary and Backup members are of the same type. For example, if you choose a T1 interface as a Primary member, the Backup member must also be a T1 interface. The Admin Mode for the protection group is configured in the order Lockout &gt; Force Switch &gt; Manual Switch &gt; None. For more information about these modes and the revert timer, see the descriptions in Configure APS or MSP and UPSR or SNCP Protection Groups, on page 298.</td>
<td>-</td>
</tr>
<tr>
<td>Configure NCS4200-1T16G-PS cards on NCS42xx devices.</td>
<td>Physical &gt; Card Mode</td>
<td>You can view all the card modes of NCS4200-1T16G-PS cards, irrespective of the slot numbers. <strong>Note</strong> Once you configure NCS4200-1T16G-PS card on some slots of NCS42xx devices, the configurations on those slots will be reset to the default values.</td>
<td>-</td>
</tr>
<tr>
<td>Configure A900-IMA8CT1Z-M and A900-IMA8CS1Z-M cards on ASR9xx devices.</td>
<td>Physical &gt; Card Mode</td>
<td>You can view and configure the card modes of A900-IMA8CT1Z-M and A900-IMA8CS1Z-M cards.</td>
<td>-</td>
</tr>
</tbody>
</table>
**Physical Interface Configuration** | **Navigation** | **Comments/Descriptions** | **Supported Slots/Controllers**
--- | --- | --- | ---
Configure the interface module type for Automatic In-Service (AINS) | Physical > Automatic In-Service (AINS) | Use this menu to configure the right controller types for AINS. In case of manual insertion and removal of cards, the AINS values are populated after a 20 min delay. | -

Configure bandwidth that must be reserved for the selected device slots. | Physical > Bandwidth | The bandwidth you specify is reserved for the selected slot and made available to the slot irrespective of whether the slot is operational or not. In cases when the selected slot/card is down, and then back online after sometime, the configured bandwidth will be available for use based on the values specified in this field. | You can reserve a pre-configured bandwidth value of 80 or 100 Gbps on NCS4200-1T16G-PS cards on NCS42xx devices.

Configure the interface pluggable type for virtual Container over Packet (VCoP). | Physical > Pluggable Type | Use this menu to select the right port types for VCoP enabled interfaces. For example, the port types can be OC3, OC12, or DS3. **Note** VCoP smart SFP provides an ability to forward the SONET signal transparently across the packet network. The VCoP smart SFP is a special type of optical transceiver which encapsulates SONET bit stream at STS1 or STS-3c or STS-12c level into packet format. | -

**Conditions and Limitations:** Following are the conditions and limitations for configuring controller modes on Cisco ASR 900 Series Route Switch Processor 2 (RSP2A) modules (A900-RSP2A-128) that are supported on Cisco ASR 920, Cisco NCS4202, and Cisco NCS 4206 devices:

- The maximum bandwidth that can be configured is OC-48. A maximum of 20 ports on the module can be configured:
  - Ports 0-11 are T1 ports
  - Ports 12-15 are T3/E3 ports
  - Ports 16-19 are OC3/OC12 ports. **Note** If a given port is configured as OC48, then only one of the given port can be configured since the maximum configurable bandwidth is OC48.

- Configuration limitations on the Cisco A900-RSP2A-128 modules:
  - You cannot configure SDH/E3/E1/DS0 controller modes.
  - Configuring Ethernet as the controller mode is not supported.
  - The protection type UPSR cannot be configured.
  - Once you deploy the controller mode configuration to the device, you cannot undo the configuration using Cisco EPN Manager.
Configure Circuit Emulation

Cisco EPN Manager supports the provisioning of Circuit Emulation (CEM) which provides a bridge between traditional TDM network and packet switched network (PSN). CEM is a way to carry TDM (or PDH) circuits over packet switched network. Circuit Emulation (CEM) is the imitation of a physical connection. This feature allows you to use your existing IP network to provide leased-line emulation services or to carry data streams or protocols that do not meet the format requirements of other multiservice platform interfaces.

Cisco EPN Manager supports the following CEM modes:

- Structure-Agnostic time-division multiplexing (TDM) over Packet (SAToP)—This is the unstructured mode in which the incoming TDM data is considered as an arbitrary bit stream. It disregards any structure that may be imposed on the bit stream. SAToP encapsulates the TDM bit streams as pseudowire (PWs) over PSN.

- Circuit Emulation over Packet (CEP)—This mode is used to emulate Synchronous Optical Network/Synchronous Digital Hierarchy (SONET/SDH) circuits and services over MPLS. To transport SONET/SDH circuits through a packet-oriented network, the Synchronous Payload Envelope (SPE) or Virtual Tributary (VT) is broken into fragments. A CEP header and optionally an RTP header are prepended to each fragment.

For more information about CEM in Cisco EPN Manager, see, Supported Circuit Emulation Services, on page 468.
When a line is channelized, it is logically divided into smaller bandwidth channels called higher-order paths (HOP) and lower-order paths (LOP). These paths carry the SONET payload. When a line is not channelized, the full bandwidth of the line is dedicated to a single channel that carries broadband services. Cisco EPN Manager enables you to channelize the T3 or E3 channels into T1s, and channelize the T1s further into DS0 time slots. Before you provision CEM services using Cisco EPN Manager, you must first configure the parameters for the HOP and LOP by configuring the interfaces for CEM.

A channelized SONET interface is a composite of STS streams, which are maintained as independent frames with unique payload pointers. The frames are multiplexed before transmission. SONET uses Synchronous Transport Signal (STS) framing while SDH uses Synchronous Transport Mode (STM) framing. An STS is the electrical equivalent to an optical carrier 1 (OC-1) and an STM-1 is the electrical equivalent to 3 optical carrier 1s (OC-1s).

This section describes how you can use Cisco EPN Manager to first configure your interfaces for CEM. You can then provision CEM services using these interfaces configured with appropriate controller modes and protection groups.

**Pre-requisites for Configuring CEM Services**

Before you provision a CEM service (see Provision Circuit Emulation Services, on page 538), ensure that the following pre-requisites are met:

- Configure the required loopback settings for CEM on the device. See, Configure Loopback Interfaces, on page 318.
- Configure the required CEM parameters on SONET, SDH, PDH, HOP, and HOP controllers. See, Configure Interfaces for CEM, on page 294.
- Configure the working and backup interface groups to provide APS protection. See, Configure APS or MSP and UPSR or SNCP Protection Groups, on page 298.

**SONET Modes Configuration Examples**

The following configuration commands and examples shows how to configure STS-1 modes.

**Configure STS-1 Modes**

To configure STS-1 modes, use the following commands:

```
    enable
    configure terminal
    controller sonet 0/5/0
    sts-1 1
    mode vt-15
    end
```

There is no default mode. The modes vt-15, mode ct3, mode t3, mode unframed, mode vt-2 are supported. To restore the system to its default condition, use the **no** form of the command.

**Note**

Configuring DS1/T1 CT3 mode of STS-1:
To configure DS1/T1 CT3 mode of STS-1, you can configure the T1 link using the following steps:
To configure STS-Nc - contiguous concatenation, use the following commands:

```bash
enable
configure terminal
controller sonet 0/5/0
sts-1-3 mode sts-3c
end
```

To restore the system to its default condition, use the no form of the command. Also, to configure STS-3c or STS-12c, use the numbers as multiples for 3 or 12, respectively.

**Configuring CEM Group for Sonet Mode VT1.5-T1 in CESoPSN**

To configure CEM group in VT 1.5 mode of STS-1 for CESoPSN, use the following commands:

```bash
enable
configure terminal
controller sonet 0/5/0
sts-1 2
mode vt-15
vtg 1 t1-1 cem-group 56 timeslots 1 - 8
end
```

**Configuring CEM Group for Sonet Mode CT3-T1 in CESoPSN**

To configure CEM group in CT3 mode of STS-1 for CESoPSN, use the following commands:

```bash
enable
configure terminal
controller sonet 0/5/0
sts-1 1
mode ct3
t1 3 cem-group 28 timeslots 1 - 7
end
```

**Configure Interfaces for CEM**

Using Cisco EPN Manager, you can configure your interfaces with Circuit Emulation (CEM). To do this, you must first set appropriate controller modes on your interfaces and then configure the PDH (E1, T1, E3, T3), SONET, and SDH controllers for CEM. After you configure the interfaces with CEM, you can then use the interfaces for provisioning CEM services. See Provision Circuit Emulation Services, on page 538.

To configure the interfaces for CEM:
Step 1  Choose Configuration > Network Devices.
Step 2  Select the device that you want to configure by clicking the device’s name hyperlink.
Step 3  Click the Configuration tab, then click the Logical View left side tab.
Step 4  To configure CEM parameters, navigate to the configuration options as described in the table below.
Step 5  To make your changes, click the controller/card name hyperlink and click the Edit icon at the top right corner of the page. Make your changes and click Save.

Example

Table 18: CEM Interface Configuration Options

<table>
<thead>
<tr>
<th>CEM Interface Configuration</th>
<th>Navigation</th>
<th>Comments/Decisions</th>
<th>Supported Slots/Controllers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure controller modes as SONET, SDH, Ethernet, T3, or E1 or E3.</td>
<td>Circuit Emulation &gt; Controller Mode</td>
<td>The controller mode options displayed for selection are based on the selected media type.</td>
<td>–</td>
</tr>
<tr>
<td>Configure PDH (E1, T1, E3, and T3) controllers</td>
<td>Circuit Emulation &gt; PDH</td>
<td>For a description of the different PDH parameters, see CEM Interface (PDH, SONET, and SDH) Field Descriptions, on page 302</td>
<td>-</td>
</tr>
</tbody>
</table>
**Controller Modes and Supported Port Types**

- There are pair wise restrictions for EOWYN IM. Valid pairs are (0,1) (2,3) (4,5) (6,7).

  **Note** For each pair, you can configure maximum of 2.5Gbps(OC48) bandwidth(both ports combined).

- You can only configure rates OC3/OC12/OC48 for ports 0-7 and only rate OC192 on port 8.

*Table 19: Bandwidth used by different rates OCN -> n * 51.84 Mbit/s*

<table>
<thead>
<tr>
<th>Rate Configuration</th>
<th>Bandwidth</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 OC3</td>
<td>155.52 Mb/s</td>
</tr>
<tr>
<td>1 OC12</td>
<td>622.08 Mb/s</td>
</tr>
<tr>
<td>1 OC48</td>
<td>2488.32 Mb/s ~ 2.5 Gb/s</td>
</tr>
<tr>
<td>1 OC192</td>
<td>9953.28 Mb/s ~ 10 Gb/s</td>
</tr>
</tbody>
</table>

**Configure Media Type Controller**

To configure Media Type Controller, use the following commands:
Configure Devices

Configure Interfaces for CEM

enable
configure terminal
controller MediaType 0/5/0
mode sonet
end

**Configure SONET Ports**

To configure SONET ports, use the following commands:

```
enable
cfgure terminal
controller MediaType 0/5/0
mode sonet
controller sonet 0/5/0
rate OC12
end
```

The above example shows how to configure SONET ports in OC-12 mode.

**CEM Interface Configuration Example:**

The following example show the sample CEM interface configuration that is deployed to the device for CEM framing type 'unframed', c-11 mode, clock source of type 'internet', and ACR values associated with the Protection Group 'acr 255':

```
NCS4206-120.32#show running-config | section 0/4/0
controller MediaType 0/4/0
mode sonet
controller SONET 0/4/0
rate OC3
no ais-shut
framing sonet
clock source line
loopback network
!
sts-1
  clock source internal
  mode unframed
  cem-group 1 cep
!
sts-1 2
  clock source internal
  loopback network
  mode unframed
  cem-group 2 cep
!
sts-1 3
  clock source internal
  mode vt-15
  vtg 1 vt 1 protection-group 15 working
  vtg 1 vt 3 protection-group 16 working
  vtg 1 vt 4 protection-group 17 working
!
  aps group acr 255
  aps protect 1 6.6.6.6 / aps working 1
!
interface CEM0/4/0
no ip address
cem 1
!
cem 2
!
connect sam CEM0/4/0 1 CEM0/4/0 2
!
```
Configure APS or MSP and UPSR or SNCP Protection Groups

Viewing the protection groups for CEM helps you understand the enabled Automatic Protection Switching (APS), Unidirectional Path Switched Ring (UPSR), Multiplex Service Protection (MSP) and Subnetwork Connection Protection (SNCP) interfaces for your devices. APS and UPSR refers to the mechanism of using a protect interface in the SONET network as the backup for the working interface. Associating your interfaces with APS or UPSR protection groups, ensures that when the working interface fails, the protect interface quickly assumes its traffic load. The working interfaces and their protect interfaces together make up a Protection Group. SONET Protection Groups offer recovery from fiber (external) or equipment (interface and internal) failures at the SONET line layer. Using Cisco EPN Manager, you can view the working member for a SONET controller which acts as the main functioning controller for the CEM circuit. The Protecting Member acts as a backup for the main working controller. To view these details, ensure that the interfaces have been set with the required controller modes as explained in Configure Interfaces for CEM, on page 294.

MSP and SNCP refer to the mechanism of using a protect interface in the SDH network as the backup for the working interface. Associating your interface with MSP or SNCP protection groups, ensures that when the working interface fails, the protect interface quickly assumes its traffic load. The working interfaces and their protect interface together make up a Protection Groups.

MSP is a protection mechanism in SDH for a port level protection, which provides 1+1 protection mechanism. In network topology map, all modes are supported including revertive, unidirectional, bidirectional, and acr/dcr modes. MSP in SDH is similar to APS in SONET. For example, in NCS 4206 device it has both working and protection modes.

SDH-MSP feature provides port level redundancy for SDH controller across Interface Module (IM). You can configure ports of different IM with one in working mode and the other port in protect mode.

SNCP is a protection mechanism for SDH networks that enables SDH connections to switch to another SDH circuit when a circuit failure occurs. A protection interface serves as the backup interface for the working interface. When the working interface fails the protection interface quickly assumes its traffic load. The switchover to a protection path occurs in the nonrevertive mode. If protection is switched to the protection path due to a transmission fault, there is no automatic switch-back to the original path once the fault is rectified. The functional equivalent of SNCP in SONET is called UPSR. You can provision CEM services and SNCP through Provision wizard or through CLI. The supported modes are VC4_16C, VC4_4C, VC4, AU4_VC12, AU4-VC11, AU3-VC12, AU3-VC11.

Mix modes support is not available in Cisco EPN Manager 3.0.

Some Limitations are:

• SDH supported modes with SNCP is not supported on STM64 port.
• LOOPBACK and Bit Error Rate Testing (BERT) can be configured only on physical member controllers.
• The supported scale is limited to 336 circuits

Before you modify the protection groups ensure to add controllers/interfaces to protection.

To configure APS/MSP protection groups and view UPSR/SNCP interfaces:
Step 1 Choose Configuration > Network Devices.

Step 2 Select the device that is configured with protection groups, by clicking the device’s name hyperlink.

Step 3 Click the Configuration tab, then click the Logical View left side tab.

Step 4 Choose Circuit Emulation > Protection Group.

Step 5 To configure the APS/MSP parameters, click the APS/MSP tab, click the Protection Group hyperlink of the group that you want to modify, and click the Edit icon at the top right corner of the page.

Step 6 You can view and configure the following fields:

- **The Working Member** represents the SONET/SDH controller which acts as the main functioning controller for the circuit.
- **The Protecting Member** represents the SONET/SDH controller which acts as the backup to the working member for the circuit.
- **The Protection Status** indicates whether the group is an active or inactive member for the circuit.
- **The Hello Time and Hold Time** fields represent the time range for the protecting and working members. The hello timer defines the time between hello packets. The hold timer sets the time before the protect interface process declares a working interface's router to be down. By default, the hold time is greater than or equal to three times the hello time.
- **The Loopback IP** determines the configuration for the protect interface which includes the IP address of the router (normally its loopback address) that has the working interface.
- **The Revertive Time**, in minutes, enables automatic switchover from the protect interface to the working interface based on the configured time after the working interface becomes available. If revertive time is zero then the protection is non-revertive.
- **The Directional** drop-down menu represents the direction in which the backup protection must be enabled.
  - In the bidirectional mode, a failure on a working member triggers an APS/MSP switchover of the working member to the Protecting member. Here the receive and transmit channels are switched as a pair.
  - In the unidirectional mode, failure on a working member triggers an APS/MSP switchover of only the failed member to the corresponding line of the Protection interface.
- **The ADM checkbox**, if enabled, associates Add Drop Multiplexors (ADMs) with the protecting member.
- **The APS Request** drop-down menu enables you to configure the following values. The values can be configured in the order Lockout > Force Switch > Manual Switch > No Mode. For example, if Force Switch is currently configured on the device, then you can configure only Manual Switch or No Mode values. You cannot configure Lockout when Force Switch is configured.
  - **Lockout**: Prevents a working interface from switching to a protect interface. For example, if the protect interface is configured as circuit 1, the Lockout option prevents the protect interface from becoming active.
  - **Manual Switch**: Manually switches a circuit to a protect interface, unless a request of equal or higher priority is in effect.
  - **Force Switch**: Manually switches a circuit to a protect interface, unless a request of equal or higher priority is in effect. For example, if the protect interface is configured as a particular circuit, the force command sets the protect interface to active.
  - **No Mode**: Removes the current APS/MSP request configuration from the protection group on the device.
To clear the protection group of SONET or SDH, choose either SONET or SDH protection group ID and then click the delete (X icon).

**Step 7**

To view similar parameters associated with UPSR/SNCP interfaces, click the **UPSR/SNCP** tab.

You can view information such as the protection group number, working and protecting members configured on the device, the active paths for the group, and its current protection status. This information cannot be modified.

**Note**

During shutdown or removal of IM that have UPSR/SNCP over SDH configured, you can validate the changes in the UI and check for the Online Insertion Removal (OIR) of each interface module. Use the **show protection-group** command.

- To view the following status changes:
  - Manual — The status is displayed when you manually configure the SNCP protection group.
  - Clear — Prevents a working interface from switching to a protect interface.
  - Auto — The status is displayed when you configure the SNCP protection group for the first time.
  - Force — The status is displayed when you manually switch over.
  - Fail — The status is displayed when protected and working paths are down.
  - Signal Failure — The status goes to SF when there is a link failure.
  - Signal Degradation — The status is displayed when the working path is down.
  - Lockout — Prevents a working interface from switching to a protect interface.

**Step 8**

Choose **Circuit Emulation > SONET and SDH**.

**Step 9**

To view or configure the ACR Controller, High-order Path, Low-order Path parameters, click the relevant tabs. Click the SONET or SDH hyperlink that you want to modify, and then click the Edit icon at the top right corner of the page. For more information about configuration of SDH see, Configure Modes of SDH in EPNM, on page 307, Configure SDH Parameters, on page 306 and Configure SDH Line and Section Parameters, on page 308 SDH VC Configuration Parameters for SAToP, on page 310 SDH T1/E1 Configuration Parameters, on page 309 SDH T3/E3 Configuration Parameters, on page 309

Use the **ACR Controller** tab to view the virtual SONET Access Circuit Redundancy (ACR) /SDH Access Circuit Redundancy (ACR) details for SONET/SDH protection groups.

---

**Configure Clocking for CEM**

Clocking modes define multiple ways to achieve the same clock in the transmitting and receiving ends of a CEM circuit. Cisco EPN Manager enables you to configure clock recovery and distribution in these ways:

- Synchronous Clocking — with synchronous clocking, PDH (TDM) lines on the source and destination are synchronized to the same clock delivered by some means of physical clock distribution (SONET, SDH, and so on). The clock on the particular TDM line can be delivered from
  - Line: the transmit clock is from the receiver of the same physical line.
  - Internal: the controller will clock its sent data using the internal clock.
• Free Running: the transmit clock is taken from line card and can be derived from an internal free running oscillator.

• Recovered: the transmit clock is derived from an in-band pseudowire-based active clock recovery on a CEM interface.

To set these clocking values in Cisco EPN Manager, see Configure CEM Interfaces.

• Adaptive Clocking — adaptive clocking is used when the routers do not have a common clock source. The clock is derived based on packet arrival rates based on dejitter buffer fill level. You can set the size of the Dejitter Buffer (in the range of 1-32) during provisioning of CEM services in Cisco EPN Manager. The size of the Dejitter Buffer determines the ability of the circuit to tolerate network jitter.

• Differential clocking — differential clocking is used when the cell site and aggregation routers have a common clock source but the TDM lines are clocked by a different source. The TDM clocks are derived from differential information in the RTP header of the packet with respect to the common clock. Differential clock recovery is based on time stamps received in the RTP header.

To configure clock recovery for CEM:

**Step 1**
Click the **Configuration** tab, then click the **Logical View** left side tab.

**Step 2**
Choose **Clock > Recovered Clock**.

**Step 3**
To add a new interface from which the clock source must be derived, click the Add (‘+’) icon.

**Step 4**
To edit the existing recovered clock configuration, click the Recovering Interface hyperlink and click the ‘Edit’ icon at the top right of the page.

**Step 5**
Specify the following recovered clock values:

1. Enter a unique numerical value for the **Recovered Clock ID** for easy identification of the recovered clock configuration. This ID can then be used to associate the CEM interfaces directly with this the recovered clock configuration.

2. From the **Recover Mode** drop-down list choose:
   - **Adaptive** — when devices do not have a common clock source, the recovered clock is derived from packet arrival rate on the controller selected as the Protecting Member for the associated Protection Group.
   - **Differential** — when the edge devices have a common clock source, the recovered clock is derived from timing information in packets and the related difference from the common clock.

3. Enter a unique numerical value for easy identification of the **CEM Group Number**. This identifies the CEM group associated with the clock.

4. Choose the required controller from the **Recovering Interface** drop-down list. This controller associated with the clock is the virtual CEM interface from which the clock is derived when a backup clock source is required.

**Step 6**
Click **Save**.

Your changes are saved and deployed to the device.
To configure the CEM parameters listed in the table below:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Descriptions</th>
<th>Values</th>
<th>Descriptions</th>
<th>Applicable Controller Modes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rate</td>
<td>Identifies the rate at which the data gets transported. It is dependent on the SFP (Small Form-factor Pluggable) .</td>
<td>LR_DSR_OC3_STM1</td>
<td>Indicates the layer rate supported on the channelized OC-3 line with STM level 1. OC-3 is an optical carrier network line with transmission data rate of up to 155.52 Mbit/s.</td>
<td>SONET /SDH</td>
</tr>
<tr>
<td></td>
<td></td>
<td>LR_DSR_OC12_STM4</td>
<td>Indicates the layer rate supported on the channelized OC-12 line with STM level 4. OC-12 is an optical carrier network line with transmission data rate of up to 622.08 Mbit/s.</td>
<td>SONET/SDH</td>
</tr>
<tr>
<td></td>
<td></td>
<td>LR_DSR_OC48_STM16</td>
<td>Indicates the layer rate supported on the channelized OC-48 line with STM level 16. OC-48 is an optical carrier network line with transmission data rate of up to 2.4Gbps.</td>
<td>SONET /SDH</td>
</tr>
<tr>
<td></td>
<td></td>
<td>LR_DSR_OC192_STM64</td>
<td>Indicates the layer rate supported on the channelized OC-192 line with STM level 64. A channelized OC-192 line with STM level 64. OC-192 is an optical carrier network line with transmission data rate of up to 9.6Gbps.</td>
<td>SONET /SDH</td>
</tr>
</tbody>
</table>
## CEM Interface (PDH, SONET, and SDH) Field Descriptions

<table>
<thead>
<tr>
<th>Fields</th>
<th>Descriptions</th>
<th>Values</th>
<th>Descriptions</th>
<th>Applicable Controller Modes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mode</td>
<td>Identifies the type of channelization, such as Synchronous Transport Signal of level n (STS-n), for high-order and low-order paths.</td>
<td>High Order Path values: STS3C, STS12C, STS48C, STS192C, T3, UNFRAMED, VT15, VT2, CT3, and CT3_E1. Low Order Path values: VT15, T1, and E1.</td>
<td>• STS-n: Mode with Synchronous Transport Signal (STS) channelization of level n. • T1, E1, T3, and E3: Indicates the channelization mode used on the controller. T1 or E1 circuit has a transmission data rate of up to 1.544 Mbit/s. The T3 or E3 circuit has a transmission data rate of up to 44.736 Mbit/s. • VT 1.5: Indicates that the controller is a virtual tributary network line with transmission data rate of up to 1.728 Mbit/s. • VT 2: Indicates that the controller is a virtual tributary network line with transmission data rate of up to 2.304 Mbit/s. • Unframed: indicates that a single CEM channel is used for all T1/E1 timeslots.</td>
<td>HOP and LOP.</td>
</tr>
<tr>
<td>Clock Source</td>
<td>Identifies the source of the clock signal sent on SONET or SDH ports.</td>
<td>VC4_16C, VC4_4C, VC4, AU4_VC12, AU4-VC11, AU3-VC12, AU3-VC11, T3, E3, VC1X, TUG3</td>
<td>Supported SDH modes.</td>
<td>HOP and LOP.</td>
</tr>
<tr>
<td>Controller</td>
<td></td>
<td>Controller will clock its sent data using the clock recovered from the line's receive data stream.</td>
<td>All</td>
<td></td>
</tr>
<tr>
<td>Line</td>
<td></td>
<td>The transmit clock is taken from line card and can be derived either from an internal physical line.</td>
<td>All</td>
<td></td>
</tr>
<tr>
<td>Internal</td>
<td></td>
<td>The transmit clock is taken from line card and can be derived from an internal free running oscillator.</td>
<td>All</td>
<td></td>
</tr>
<tr>
<td>Free-Running</td>
<td></td>
<td>In-band pseudowire-based active clock recovery on a CEM interface which is used to drive the transmit clock.</td>
<td>SONET, SDH, HOP, and LOP.</td>
<td></td>
</tr>
<tr>
<td>Recovered</td>
<td></td>
<td>-</td>
<td>SONET, HOP, and LOP.</td>
<td></td>
</tr>
<tr>
<td>Enhanced</td>
<td></td>
<td>-</td>
<td>SONET, HOP, and LOP.</td>
<td></td>
</tr>
<tr>
<td>Fields</td>
<td>Descriptions</td>
<td>Values</td>
<td>Descriptions</td>
<td>Applicable Controller Modes</td>
</tr>
<tr>
<td>---------------</td>
<td>----------------------------------------------------------</td>
<td>-----------------------------------------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>------------------------------</td>
</tr>
<tr>
<td>Framing</td>
<td>Framing mode used for the CEM channel.</td>
<td>CRC and NO_CRC.</td>
<td>CRC: represents the framing type with cyclic redundancy check.</td>
<td>SONET/SDH</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Unframed, DSX1_ESF, DSX1_SF, Auto Detect, C_BIT, and M23.</td>
<td>• Unframed: indicates that a single CEM channel is used for all timeslots.</td>
<td>PDH, HOP, and LOP.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• DSX1_SF: indicates that the DS1 type of interface has the framing type as super frame. SF uses 12 frames per super frame for in-band signaling extraction.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• DSX1_ESF: indicates that DS1 type of interface has the framing type as extended super frame. ESF uses 24 frames per ESF.</td>
<td></td>
</tr>
<tr>
<td>Loopback</td>
<td>Specifies the loopback value associated with the CEM interface.</td>
<td>Local, Network Line, Remote, Remote Line, Network Payload, and Unknown.</td>
<td>For a detailed explanation about the different loopback values, refer the latest IOS Command References.</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>—</td>
<td>PDH</td>
</tr>
<tr>
<td>Protection Role</td>
<td>Identifies the priority based on which the recovered clock must be obtained.</td>
<td>WORKING</td>
<td>The recovered clock is obtained from a clock with the highest priority.</td>
<td>SONET/SDH</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PROTECT</td>
<td>The recovered clock is obtained from a clock with a lower priority than the primary clock.</td>
<td>SONET/SDH</td>
</tr>
<tr>
<td>Cable Length</td>
<td>Sets the transmission attenuation according to the length of the cable. For example, if you choose short 115, the cable length is from 0 to 115 feet. Choose Short 220 if the cable length is from 110 to 220 feet, and so on. Your values are between Short 110 to Short 550, Shot LT 225, and Long GT 225.</td>
<td></td>
<td>PDH</td>
<td></td>
</tr>
<tr>
<td>Line Coding</td>
<td>Line encoding method for the controller:</td>
<td>• For E1, the options is Alternate Mark Inversion (AMI).</td>
<td></td>
<td>PDH</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• For T1, the options are AMI and bipolar with 8 zero substitution (B8ZS).</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fields</td>
<td>Descriptions</td>
<td>Values</td>
<td>Applicable Controller Modes</td>
<td>Applicable Controller Modes</td>
</tr>
<tr>
<td>------------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-------------------------------</td>
<td>------------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>Channelization Mode</td>
<td>Indicates the channelization mode that must be used on the controller. A T1 or E1 circuit has a transmission data rate of up to 1.544 Mbit/s. Your values are T1, E1, and Unchannelized.</td>
<td>PDH</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> For T3 controllers view or modify the channelized T1/E1 properties and for E3 controller view or modify the channelized T1/E1 properties.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Protection Group Number</td>
<td>Identifies the protection number or ACR group.</td>
<td>SONET/SDH</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Protection Loopback Name</td>
<td>Identifies the name of the loopback interface on the device.</td>
<td>SONET/SDH</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Protection Loopback IP</td>
<td>Identifies the IP address of the loopback interface on the device.</td>
<td>SONET/SDH</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Protection Revertive Time</td>
<td>For any failure on working line, the software switches to protection line and when the working line recovers, it waits based on the revertive timer and reverts back to working line as active link.</td>
<td>SONET/SDH</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Protection Non-Revertive Time</td>
<td>When the signal fails, the software switches to the protection line and does not automatically revert back to the working line. This is the default option.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Operational Status</td>
<td>Operational status of the CEM interface. This field cannot be edited.</td>
<td>Up, Down, and Not-Applicable.</td>
<td>SONET, SDH, HOP, and LOP.</td>
<td></td>
</tr>
<tr>
<td>Admin Status</td>
<td>Administrative status of the CEM interface.</td>
<td>Up, Down, and Not-Applicable.</td>
<td>SONET, SDH, HOP, and LOP.</td>
<td></td>
</tr>
<tr>
<td>Recovered Clock ID</td>
<td>Unique identifier for the clock settings associated with the CEM interface. To configure the Recovered Clock ID, see Configure Clocking for CEM.</td>
<td>PDH, HOP, and LOP.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Aug Type</td>
<td>An Administrative Unit Group (AUG) consists of one or more administrative units occupying units, defined positions at STM level. AUG-3 Grouping and AUG-4 Grouping are the supported Aug Types.</td>
<td>SDH</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Configure SDH Parameters

To configure SDH CEM channelization modes refer the following table.

*Table 21: Controller Modes and Supported Port Types*

<table>
<thead>
<tr>
<th>SDH Modes</th>
<th>CEM</th>
<th>Ports</th>
<th>Applicable Controller Modes</th>
</tr>
</thead>
<tbody>
<tr>
<td>VC4_16c</td>
<td>CEP</td>
<td>STM16</td>
<td>HOP</td>
</tr>
<tr>
<td>VC4_4c</td>
<td>CEP</td>
<td>STM4, STM16</td>
<td>HOP</td>
</tr>
<tr>
<td>VC4</td>
<td>CEP</td>
<td>OC3/STM1, OC12/STM4, OC48/STM16</td>
<td>HOP</td>
</tr>
<tr>
<td>VC1X</td>
<td>CEP</td>
<td>OC3/STM1, OC12/STM4, OC48/STM16</td>
<td>HOP</td>
</tr>
<tr>
<td>TUG3-E3</td>
<td>SATop</td>
<td>OC3/STM1, OC12/STM4, OC48/STM16</td>
<td>HOP</td>
</tr>
<tr>
<td>TUG-3-T3</td>
<td>SATop</td>
<td>OC3/STM1, OC12/STM4, OC48/STM16</td>
<td>HOP</td>
</tr>
<tr>
<td>VC11_T1</td>
<td>SATop</td>
<td>OC3/STM1, OC12/STM4, OC48/STM16</td>
<td>LOP</td>
</tr>
<tr>
<td>VC12_E1</td>
<td>SATop</td>
<td>STM1, STM4, STM16</td>
<td>LOP</td>
</tr>
<tr>
<td>VC11</td>
<td>CEP</td>
<td>OC3/STM1, OC12/STM4, OC48/STM16</td>
<td>LOP</td>
</tr>
<tr>
<td>VC12</td>
<td>CEP</td>
<td>OC3/STM1, OC12/STM4, OC48/STM16</td>
<td>LOP</td>
</tr>
</tbody>
</table>

Configure Mediatype Controllers

Each SFP port (16-19) can be configured as STM1, STM4, STM16. You must select the Mediatype controller to configure and enter the controller configuration mode. You must configure the controller as a SDH port.

To configure Mediatype Controller:

```
enable
configure terminal controller
MediaType 0/0/16
mode sdh
end
```

Configure Rates on SDH Ports
To configure rate on SDH ports:
  enable
  configure terminal
  controller MediaType 0/0/16
  mode sdh
  end

The configuration of no form of the command is not supported. To restore to the default condition, use no mode sdh command under Mediatype controller after removing all configuration under that port.

**Configure Modes of SDH in EPNM**

A Synchronous Transport Module (STM) signal is the Synchronous Digital Hierarchy (SDH) equivalent of the SONET STS. In this document, STM term refers to both path widths and optical line rates. The paths within an STM signals are called administrative units (AUs). An AU is the information structure that provides adaptation between the higher-order path layer and the multiplex section layer. It consists of an information payload (the higher-order VC) and an AU pointer, which indicates the offset of the payload frame start relative to the multiplex section frame start. The AU-3 pointer is composed of 3 bytes; the AU-4 pointer is composed of 9 bytes. The payload of the STM-1 frame consists of one AU-4 unit or three AU-3 units. Augment Mapping

An administrative unit group (AUG) consists of one or more administrative units occupying fixed, defined positions in an STM payload. Augment mapping is supported at STM1 level.

The following types of augment mapping are supported:

- Augment Mapping AU-4

  **Note**  
  This is the default augment mapping mode

- Augment Mapping AU-3

The supported modes of SDH are:

- AU-4_16c (VC4-16c)
- AU-4_4c (VC4-4c)
- AU-4 (VC4)
- AU-4 — TUG-3 — DS3
- AU-4 — TUG-3 — T3
- AU-4 — TUG-3 — E3
- AU-4 — TUG-3 — TUG-2 — VC-11 — T1
- AU-4 — TUG-3 — TUG-2 — VC-12 — E1
- AU-4 — TUG-3 — TUG-2 — VC-11
- AU-4 — TUG-3 — TUG-2 — VC-12
- AU-3—T3
• AU-3 — TUG-2 — VC-11 — T1
• AU-3 — TUG-2 — VC-12 — E1
• AU-3 — TUG-2 — VC-11
• AU-3 — TUG-2 — VC-12
• AU-3 — E3

To configure Administration Units Group (AUG) mapping; for example, Configuring AU-3 or AU-4 Mapping use the following configuration commands:

```plaintext
configure terminal
aug mapping [au-3 | au-4]
end
```

**Note**
The `aug mapping` command is available only when the SDH framing is configured. The AUG mode is AUG-4 by default and it is supported at STM-1 level.

---

**Configure SDH Line and Section Parameters**

The following parameters affect SDH configuration at the line and section levels.

**Loopback**

Sets a loopback to test the SDH ports.

- **local** — Loops the signal from Tx to Rx path. Sends alarm indication signal (AIS) to network.
- **network** — Loops the signal from Rx to Tx path.

**Configuring Line Loopback**

To configure loopback:

```plaintext
enable
configure terminal
controller sdh 0/0/16
loopback [local | network]
end
```

**Note**
To restore the system to its default condition, use the no form of the command.

**Clock Source**

Specifies the clock source, where:

- **line** — The link uses the recovered clock from the line.
- **internal** — The link uses the internal clock source. This is the default setting.

To configure clock, use the following commands:

```plaintext
enable
configure terminal
controller sdh 0/0/16
```
The default mode is internal. To restore the system to its default condition, use the no form of the command.

**Configuring Network-Clock SDH**

To configure network-clock SDH, use the following commands:
```
enable
configure terminal
controller sdh 0/0/16
clock source line
end
enable
configure terminal
network-clock input-source 1 controller sdh 0/0/16
end
```

**SDH T1/E1 Configuration Parameters**

The following parameters affect SDH T1/E1 configuration:

- **Clock** — Specifies the clock source for T1 or E1 interface.
- **Description** — Specifies the description of the controller.
- **Loopback** — Sets the T1 or E1 interface in the loopback mode.

**Configuring SDH T1/E1 Parameters**

To configure T1/E1 parameters:
```
enable
configure terminal
controller sdh 0/0/16
rate stm4
au-3 1
mode vclx
tug-2 1 payload vcl1
t1 1 loopback [local | network line]
t1 1 clock source [line | internal | recovered]
end
```

**SDH T3/E3 Configuration Parameters**

The following parameters affect SDH T3/E3 configuration:

- **Clock** — Specifies the clock source for T3 or E3 link.
- **Loopback** — Sets the T3 or E3 link in the loopback mode.

**Configuring SDH T3/E3 Parameters**

To configure SDH T3/E3 parameters configuration:
```
enable
configure terminal
controller sdh 0/0/16
rate stm4
au-4 1
```
mode tug 3
tug-3 1
mode e3
e3 1 clock source [line | internal | recovered]
e3 framing [m13 | c-bit] (applicable to for mode e3)
e3 1 loopback [local | network line]
e3 bert pattern 0s interval 2
tug-3 2
mode t3
t3 1 clock source [line | internal | recovered]
t3 framing [m13 | c-bit] (applicable to for mode t3)
t3 1 loopback [local | network line]
end

This is applicable to AUG mapping AU-4 mode T3 and AU-3 mode T3.

SDH VC Configuration Parameters for SAToP

The following parameters affect SDH VC configuration:

• Clock — Specifies the clock source for VC.
• Loopback — Sets the VC in the loopback mode.

Configuring VC Parameters

To configure VC parameters:
enable
configure terminal
controller sdh 0/0/16
rate stm4
au-3 1
mode vc1x
tug-2 1 payload vc11
vc 1 loopback [local | network]
vc 1 clock source internal
end

Synchronize the Clock Using Sync-E, BITS, and PTP

Synchronous Ethernet (Sync-E):

Using Cisco EPN Manager, you can enable frequency synchronization to provide high-quality bit clocks synchronization over Ethernet interfaces. Synchronous Ethernet (Sync-E) provides this required synchronization at the physical level.

To do this you need to configure Sync-E that helps routers identify the clock in the network with the highest priority. This clock is also called the Master Clock. All the other devices (members) on the network reset their clocks based on the master clock’s settings. Messages are constantly exchanged between the master clock and its members to ensure efficient continued synchronization of all clocks in the network. Cisco EPN Manager enables you to specify this master clock and also set the Sync-E parameters at the global and interface levels. Once the Sync-E properties have been configured, you can view the logical hierarchy and topology between the devices on the network topology overlay.
Sync-E configuration is supported only on Ethernet interfaces.

**Building Integrated Timing Supply (BITS):**

BITS is the method by which clocking information is provided by a Building Integrated Timing Supply (BITS) port clock. In Sync-E, Ethernet links are synchronized by timing their bit clocks from high-quality, stratum-1-traceable clock signals in the same manner as SONET/SDH. Operations messages like SSM and ESMC maintain Sync-E links and ensure that a node always derives its timing from the most reliable source.

**Precision Time Protocol (PTP):**

In networks that employ TDM, periodic synchronization of device clocks is required to ensure that the receiving device knows which channel is the right channel for accurate reassembly of the data stream. The Precision Time Protocol (PTP) standard:

- Specifies a clock synchronization protocol that enables this synchronization.
- Applies to distributed systems that consist of one or more nodes communicating over a network.

PTP uses the concept of master and slave devices to achieve precise clock synchronization. With the help of Cisco EPN Manager, you can use PTP to configure the master device which periodically starts a message exchange with the slave devices. After noting the times at which the messages are sent and received, each slave device calculates the difference between its system time and the system time of the master device. The slave device then adjusts its clock so that it is synchronized with the master device. When the master device initiates the next message exchange, the slave device again calculates the difference and adjusts its clock. This repetitive synchronization ensures that device clocks are coordinated and that data stream reassembly is accurate. The PTP clock port commands are used to modify PTP on individual interfaces. Once the PTP properties have been configured, you can view the logical hierarchy and topology between the devices on the network topology overlay.

Due to the limitations on the device, you can configure a maximum of 4 clock sources on interface modules, with a maximum of 2 per interface module. This limitation applies to both Sync-E and TDM interfaces.

---

**Step 1**  Choose **Configuration > Network Devices**.

**Step 2**  Select the device that you want to configure by clicking the device’s name hyperlink.

**Step 3**  Set the global Sync-E properties.

a) Click the **Configuration** tab, then click the **Logical View** left side tab.

b) Click **Clock > Sync-E**. All available Sync-E global settings are listed.

c) To create a new set of global Sync-E properties, click the ‘+’ icon. You can create only one set of Sync-E global parameters.

d) Specify the global parameters for Sync-E. For a detailed description about these parameters, see the table below.

e) Click **Save**.

Your changes are saved and the global Sync-E configuration is deployed to the device. You can now specify the interfaces that you want to associate with this configuration.

**Step 4**  Specify the associated interfaces and interface specific Sync-E parameters.
Configure Devices

Synchronize the Clock Using Sync-E, BITS, and PTP

a) Select the Sync-E global configuration created in the above steps from **Clock > Sync-E**.
b) Click the **Interface Input Source** tab.
c) Click ‘+’ to specify the required interfaces.

You can configure only one interface per synchronization type.
d) Use the **Interface Name** drop-down menu to select the required interface.
e) Specify the interface level Sync-E parameters. For a detailed description about these parameters, see table below.
f) Click **Save**.

**Step 5** Specify the frequency settings for BITS:

a) Click the **Configuration** tab, then click the **Logical View** left side tab.
b) Click **Clock > BITS-Frequency**.
c) Specify the following BITS values:

- Source slot: Your options are RO and R1.
- Priority: Enter a numeric value within the range 1 to 250.
- Clock Type: Your options are E1 and T1.

**Note** The SSM option must be GEN2 to configure the BITS interface as T1.

d) Click **Save**.
e) Specify the BITS clock settings for the interface:

1. Navigate to **Clock > BITS-Frequency** and select the BITS Frequency settings created in the above step.
2. Click the **Bits Clock Settings** tab and specify the clock settings as described in the table below.
3. Click **Save**.

**Step 6** Specify the interface settings for BITS:

a) Click the **Configuration** tab, then click the **Logical View** left side tab.
b) Click **Clock > BITS-Interface**.
c) Specify the following BITSs values:

- Source slot: The values are RO and R1.
- Priority: Numeric value within the range 1 to 250.
- Clock Type: The values are 2.048MHz and 10MHz.

d) Click **Save**.

Your changes are saved and the selected interfaces are associated with the Sync-E parameters. To verify your changes view the Sync-E and BITS parameters under **Configuration** tab > **Clock** for the selected device.

**Step 7** Specify the PTP clock settings:

a) Click the **Configuration** tab, then click the **Logical View** left side tab.
b) Click **Clock > PTP**.
c) Click ‘+’ to specify a new set of PTP values, or click the Clock Mode hyperlink and then click the Edit icon at the top right corner of the page.
d) Specify the following common PTP parameters and click **Save**.
- **Clock Mode**: Choose the mode of PTP operation. Your options are Ordinary, Boundary, and E2E Transparent. E2E stands for End-to-end transparent clock mode.

- **Domain No**: Enter the number of the domains used for PTP traffic. A single network can contain multiple domains. Range is from 1 to 127.

- **Hybrid Clock**: Enable or disable hybrid cloud.

e) Click the Clock Mode hyperlink and click the Port tab to specify the port details that must be associated with the common properties.

f) Specify the following Port details and click Save.

   - **Port Name**: Enter the name of the PTP port clock.
   - **Port Mode**: Choose the PTP role of the clock, Master or Slave.
   - **Loopback Interface Number**: Enter the clock identifier derived from the device interface.
   - **Announce Timeout**: Enter the number of PTP announcement intervals before the session times out. Range is 1 to 10.
   - **Delay Request Interval**: Choose the time when the interface is in PTP master mode and the selected interval is specified to member devices for delay request messages. The intervals use base 2 values.
   - **Sync Interval**: Choose the time interval for sending PTP synchronization messages.
   - **Announce Interval**: Choose the time interval for sending PTP announcement packets.

g) Click the Port Name hyperlink and click the Clock Source tab.

h) Click ‘+’ to add a new interface, or click the source address hyperlink and click Edit at the top right corner of the page.

i) Specify the **Source Address** and the **Priority** for the clock.

   - **No Priority**: Assigns the priority value as 0.
   - **Priority 1**: Checks the first value for clock selection. The clock with the lowest priority takes precedence and the value 1 is assigned.
   - **Priority 2**: If two or more clocks have the same value in the Priority 1 field, the value in this field is used for clock selection. This assigns the priority value of 2.

j) Click Save to deploy your changes to the device.

For detailed descriptions about all Sync-E global and interface level parameters, see the table below:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Clock &gt; Sync-E Common Properties (Global Level)</strong></td>
<td></td>
</tr>
<tr>
<td>Automatic Selection Process</td>
<td>Indicates the type of method used for synchronization of the clocks. The values are: Automatic, Forced, Manual, and Cisco. Note- You can configure only one interface per synchronization type.</td>
</tr>
<tr>
<td>Clock Type</td>
<td>Indicates the Ethernet Equipment Clock (EEC) option to be used: Option 1- represents EEC-Option I of the European time zone. Option 2- represents EEC-Option II of the American time zone.</td>
</tr>
</tbody>
</table>
## Configure Devices

Synchronize the Clock Using Sync-E, BITS, and PTP

<table>
<thead>
<tr>
<th><strong>Fields</strong></th>
<th><strong>Descriptions</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>QL Mode Enabled</td>
<td>Indicates whether the clock is to be used with the Quality Level (QL) function: Enabled or Disabled.</td>
</tr>
<tr>
<td>ESMC Enabled</td>
<td>Indicates the status of the Ethernet Synchronization Message Channel (ESMC): Enabled or Disabled.</td>
</tr>
</tbody>
</table>
| SSM Option | Indicates the Synchronization Status Message (SSM) option being used:  
Option 1- represents ITU-T Option I  
Option 2- GEN1- represents ITU-T Option II Generation 1  
Option 2- GEN2- represents ITU-T Option II Generation 2 |
| Hold Off Time (global level) | Indicates the length of time (in milliseconds) for a device to wait before issuing a protection response to a failure event.  
A valid range is between 300 and 1800 milliseconds. |
| Wait To Restore Time (global level) | Indicates the length of time (in seconds) to wait after a failure is fixed before the span returns to its original state.  
A valid range is between 0 and 86400 seconds. |
| Revert Enabled | Specifies whether the network clock is to use Revertive mode: Enabled or Disabled. |

### Sync-E > Interface Input Source (Interface Level) Properties

| **Interface Name** | Name and hyperlink of the Gigabit or 10 Gigabit interface associated with Sync-E. |
| **Active clock** | Indicates whether the interface is currently chosen as the active clock. This interface can either be a primary or secondary interface, however, the interface that is currently enabled for Sync-E is considered to be the active interface. |
| **Priority** | Indicates the value used for selecting a Sync-E interface for clocking if more than one interface is configured. Values are from 1 to 250, with 1 being the highest priority.  
The highest priority clock represents the master clock. |
| **Hold Off Time (interface level)** | Indicates the length of time (in milliseconds) to wait after a clock source goes down before removing the source.  
A valid range is a value between 300 and 1800 milliseconds. |
| **Wait To Restore Time (interface level)** | Indicates the length of time (in seconds) to wait after a failure is fixed before the interface returns to its original state.  
A valid range is a value between 0 and 86400 seconds. |
| **Rx Exact/QL Use** | Indicates the QL Receive function with which the clock must be used. |
| **Tx Exact/QL Send** | Indicates the QL Transmit function with which the clock must be used. |

### Clock > BITS-Frequency and BITS-Interface Properties
### Fields | Descriptions
--- | ---
Source Slot | Indicates whether the clock source is R0 or R1.
Priority | Indicates the value used for selecting a BITS interface for clocking if more than one interface is configured. Values are from 1 to 250, with 1 being the highest priority.
The highest priority clock represents the master clock.
Clock Type | Indicates whether the clock type that must be used is from an E1 line or a T1 line.
In case of the Bits Interface parameters, the clock type indicates the frequency values that must be associated with the clock. The options are 2.048MHz and 10MHz.
Bits Framing | Framing values (such as CAS) that must be associated with the BITS configuration.
Impedance | The impedance value that is associated with the clock in OHMS format. The default value is 120 ohms.

---

**What to do next**

(Optional) You can view the Sync-E and PTP device properties on the network topology overlay. See Show Clock Synchronization Networks on a Network Topology Map, on page 177:

- **Sync-E overlay**: shows the topology and hierarchy of the Sync-E network. It shows the primary clock and the primary and secondary clock inputs for each device.
- **PTP overlay**: shows the clock synchronization tree topology, the hierarchy of the Precision Time Protocol, and the clock role of each device in the tree (master, boundary, slave, or transparent).

**Configure IP SLAs (TWAMP Responder)**

The IETF Two-Way Active Measurement Protocol (TWAMP) defines a standard for measuring round-trip IP performance between any two devices that support the TWAMP protocols. The TWAMP-Control protocol is used to set up performance measurement sessions. It is used to send and receive performance-measurement probes. TWAMP enables complete IP performance measurement and provides a flexible choice of solutions as it supports all devices deployed in a network.

When you configure TWAMP using Cisco EPN Manager, the device you select is configured as a TWAMP server and you enter the TWAMP server configuration mode. It then uses the port value that you specify to configure the port to be used by the TWAMP server that listens for connection and control requests. The Inactivity Value that you specify will be configured as the inactivity timer (in seconds) for a TWAMP control session.
When you configure IP SLA using Cisco EPN Manager, the IP SLA responder is automatically configured on the device. You do not have to use the command `ip sla responder twamp` to pre-configure the IP SLA responder.

To configure interfaces for TWAMP:

**Before you begin**

A TWAMP control-client and the session-sender must be pre-configured in your network before you can configure TWAMP responder using Cisco EPN Manager.

For IP SLAs TWAMP Responder v1.0, ensure that the TWAMP server and the session-reflector are configured on the same Cisco device.

---

**Step 1** Choose **Configuration > Network Devices**.

**Step 2** Select the device that you want to configure by clicking the device hyperlink to launch its Device Details page.

**Step 3** Click the **Configuration** tab, then click the **Logical View** left side tab.

**Step 4** Choose **IP SLA > TWAMP Responder** to add or edit the TWAMP Responder configuration.

**Step 5** Click the '+' icon to add the TWAMP parameters to the selected device. To edit existing parameters, click the Port Name hyperlink and click the Edit icon at the top right corner of the page. You can only add one set of TWAMP parameters per device.

**Step 6** Make your modifications to the following parameters. All parameters are mandatory.

- **Port**- Use a numeric value between 1 and 65535 to specify the port that must be configured for the TWAMP server to listen for connection and control requests. The default value is 862.

- **Inactivity Timeout**- Use a numeric value between 1 and 604800 to specify the time that must be configured as the inactivity time (in seconds) for a TWAMP responder test session. The default value is 900 seconds.

- **Server Inactivity Timeout**- Use a numeric value between 1 and 6000 to specify the time that must be configured as the TWAMP server inactivity time (in seconds) for a TWAMP control session. The default value is 900 seconds.

**Step 7** Click **Save** to deploy your changes to the device.

If the deploy fails, ensure that the device's Inventory Collection status is 'Completed'. You also need to ensure that the pre-requisites mentioned above are met.

---

**Configure Interfaces**

Using Cisco EPN Manager, you can configure your CE and Optical Interfaces using the following configuration options:

Before you configure the interfaces, ensure that the device's Inventory Collection status is 'Completed'.

- **Configure Ethernet Interfaces and Subinterfaces**, on page 317
- **Configure Loopback Interfaces**, on page 318
Configure Ethernet Interfaces and Subinterfaces

The Configuration tab on the Device Details page lists the current interface configurations on the device. Depending on your device configuration and user account privileges, you can create, edit, delete, enable, and disable these interfaces.

**Step 1** Choose **Configuration > Network Devices**.

**Step 2** Click the device hyperlink to launch its Device Details page.

**Step 3** Click the **Configuration** tab, then click the **Logical View** left side tab.

**Step 4** Choose **Interfaces > Ethernet**.

**Step 5** To add an **Interfaces > Ethernet**:

a) Choose an Ethernet interface and click **Add Subinterface**.

**Note** This button is enabled depending on the device that you select. For example, on Cisco ASR903 devices, this button is disabled.

a) In the Basic Configuration area, at a minimum, enter the **Interface Number** (if not already populated) and optionally provide a description for the subinterface.
b) In the VLAN Number field, enter a numerical value that can be used to represent the VLAN ID for this subinterface. Note that only the 802.1Q type of encapsulation is supported.

c) To use the same VLAN number as the native VLAN ID, enable the Native VLAN checkbox.

d) In the Dataplane Loopback drop-down menu, select the value that must be set as the loopback value. Your options are: Blank (makes no change in the configuration), None (removes the Ethernet loopback from the interface), Internal, and External. The value that is already configured on the device is highlighted in the bold font.

e) If you are creating an IPv4 subinterface, in the IPv4 Interface area, select an IP Type. Your options are:
   - None
   - Static IP, with the IP address and subnet mask.
   - DHCP IP, with the pool name.
   - DHCP Negotiated, with the hostname and client ID (None, Interface, Port Channel).

You can also enter a secondary IP address with mask.

f) If you are adding an IPv6 subinterface, in the IPv6 Address area, select a type from the Add drop-down list. Your options are: Global, Unnumbered, Link Local, Auto Configuration, and DHCP.
   - Global, with the IP address and subnet mask, and type (General, EUI-64, Anycast, CGA).
   - Unnumbered, and enter text in the Interface Unnumbered To text box.
   - Link Local, auto-configured or manually-configured (requires IPv6 address).
   - Autoconfiguration.
   - DHCP (with option to enable two-message exchange for address allocation).

If you choose to edit an existing interface or subinterface, you are allowed to change all values except the Interface Number value.

Note To avoid unusual behaviour, do not use the § character in the Description field.

g) Click Save to add the sub-interface to the selected interface of the device.

**Step 6** To enable, disable, or delete interfaces and subinterfaces, select the interfaces and click the appropriate buttons.

The Delete Subinterface button may only be enabled on some supported devices, such as, Cisco ASR903 devices.

**Step 7** Click Save to deploy your changes to the device.

---

**Configure Loopback Interfaces**

You can change the loopback state of an interface to test how your optical network is performing. Before changing the loopback setting, ensure that the device is either in Managed state or ideally in Complete state.

To change the loopback settings on an interface:

**Step 1** Choose Configuration > Network Devices.

**Step 2** Select the device that you want to configure by clicking the device hyperlink to launch its Device Details page.
Configure Devices

Enable or Disable IOT Interfaces

The Configuration tab in the Device Details page lists the current interface configurations on the device. Depending on your device configuration and user account privileges, you can enable and disable IOT interfaces. This is applicable for EM, C3794, X.21 and Serial interfaces (RS232, RS485 and RS422). If you Enable/Disable an interface all the Controllers will be listed for the above technologies.

---

**Step 1** Choose Configuration > Network Devices.

**Step 2** Click the device hyperlink to launch its Device Details page.

**Step 3** In the Chassis View tab, view all serial controllers listed for the configured CEM or channel group.

---

**Step 3** Click the Configuration tab, then click the Logical View left side tab.

**Step 4** Choose Interfaces > Loopback.

**Step 5** To specify a new loopback interface, click Add.

a) In the Basic Configuration tab, specify the Loopback Interface Number (if not pre-populated).

b) If you are creating an IPv4 loopback interface, specify an IP Type:

   - None.
   - Static: along with the IP address and subnet mask of the static IP address.
   - DHCP IP: along with the DHCP pool name.

   You can also enter a secondary IP address with its mask so that it can be used as the backup loopback interface.

c) If you are adding an IPv6 loopback interface, in the IPv6 Address area, select a type from the Add drop-down list. Your options are:

   - Global - which also requires you to specify the IP address, subnet mask, and type (General, EUI-64, Anycast, CGA).
   - Unnumbered - which requires you to enter text in the Interface Unnumbered To text box.
   - Link Local - which is either auto-configured or manually-configured and only applies to requires IPv6 address.
   - Autoconfiguration
   - DHCP - which also allows you to set the option to enable two-message exchange for automatic address allocation.

**Step 6** To edit an existing loopback interface, select the interface and click the Edit button to change only the speed, duplex, and other settings. The Interface Number cannot be edited.

**Step 7** To enable the above loopback settings on the interfaces, select the required loopback process and click Enable.

**Step 8** Click Save to deploy these configuration changes on the device.

---

**Note**

If an interface is not present, commands for Enabling/Disabling of interface will not be sent to the device.
Step 4  In the Logical View tab, view, enable or disable all the serial interfaces and also the X.21 interfaces.

Step 5  Choose Interfaces > Serial.

Step 6  In the right pane, view all the list of serial controllers supported in EPNM and check one controller at a time to enable or disable.

Step 7  Click Save.
### Enable or Disable Tunnel Interfaces

The Configuration tab in the Device Details page lists the current interface configurations on the device. Depending on your device configuration and user account privileges, you can enable and disable these interfaces.

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Choose Configuration &gt; Network Devices.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click the device hyperlink to launch its Device Details page.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click the Logical View tab and choose Interfaces &gt; Tunnel from the left side menu.</td>
</tr>
<tr>
<td>Step 4</td>
<td>To enable or disable a tunnel interface, select the interfaces and click the Enable or Disable button.</td>
</tr>
</tbody>
</table>

*Note*  
MPLS TE tunnel interfaces can be enabled or disabled here. For information on creating or editing MPLS TE tunnels, see Create and Provision an MPLS TE Tunnel, on page 549.

### Configure SwitchPort Interfaces

The Configuration tab in the Device Details page lists the current interface configurations on the device. Depending on your device configuration and user account privileges, you can create, edit, delete, enable, and disable these interfaces.

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Choose Configuration &gt; Network Devices.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click the device hyperlink to launch its Device Details page.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click the Configuration tab, then click the Logical View left side tab.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Choose Interfaces &gt; SwitchPort.</td>
</tr>
<tr>
<td>Step 5</td>
<td>To edit an interface, select the interface and click Edit.</td>
</tr>
<tr>
<td></td>
<td>• Choose and Administrative Mode: Static, Trunk 802.1Q, or Routed.</td>
</tr>
<tr>
<td></td>
<td>• Enable or disable the port fast setting, and adjust the speed and duplex, if needed.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Click Save.</td>
</tr>
</tbody>
</table>

### Configure Virtual Template Interfaces

The Configuration tab in the Device Details page lists the current interface configurations on the device. Depending on your device configuration and user account privileges, you can create, edit, delete, enable, and disable these interfaces.

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Choose Configuration &gt; Network Devices.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click the device hyperlink to launch its Device Details page.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click the Configuration tab, then click the Logical View left side tab.</td>
</tr>
</tbody>
</table>
Step 4 Choose Interfaces > Virtual Template.

Step 5 To create a new virtual template interface, click Add.

a) In the Basic Configuration area, at a minimum, enter the Interface Number (if not already populated), Type. Type can be Serial (with PPP, Slip, or FrameRelay encapsulation), Ethernet, or Tunnel (with tunnel mode).

b) If you are creating an IPv4 virtual template interface, select an IP Type:
   - Static, with the IP address and subnet mask
   - DHCP IP, with the pool name

   You can also enter a secondary IP address with mask.

c) If you are adding an IPv6 virtual template interface, in the IPv6 Address area, select a type from the Add drop-down list: Global, Unnumbered, Link Local, Auto Configuration, or DHCP.
   - Global, with the IP address and subnet mask, and type (General, EUI-64, Anycast, CGA)
   - Unnumbered, and enter text in the Interface Unnumbered To text box
   - Link Local, auto-configured or manually-configured (requires IPv6 address)
   - Autoconfiguration
   - DHCP (with option to enable two-message exchange for address allocation)

d) Optionally perform the advanced configurations:
   - Unnumbered, and enter text in the Interface Unnumbered To text box
   - Link Local, auto-configured or manually-configured (requires IPv6 address)
   - Autoconfiguration

e) Specify the tunnel source in the Advanced Configuration area by choosing Interface or IP address (with tunnel source interface, tunnel destination, and IPSec Profile).

Step 6 To edit an existing tunnel interface, you can change the speed, duplex setting, and other parameters listed in the previous step except the Interface Number parameter.

Step 7 To enable, disable, or delete a tunnel interface, select the interfaces and click the appropriate buttons.

Step 8 Click Save.

---

Configure VLAN Interfaces

The Configuration tab in the Device Details page lists the current interface configurations on the device. Depending on your device configuration and user account privileges, you can create, edit, delete, enable, and disable these interfaces.

Step 1 Choose Configuration > Network Devices.

Step 2 Click the device hyperlink to launch its Device Details page.

Step 3 Click the Configuration tab, then click the Logical View left side tab.

Step 4 Choose Interfaces > Vlan.

Step 5 To add a VLAN interface, click Add.

a) In the Basic Configuration area, at a minimum, enter the Interface Number (if not already populated). You can also enter a description, MTU (in bytes), and bandwidth (in Kbps).

b) If you are creating an IPv4 VLAN interface, select an IP Type:
• Static, with the IP address and subnet mask
• DHCP IP, with the pool name
You can also enter a secondary IP address with mask.

c) If you are adding an IPv6 VLAN interface, in the IPv6 Address area, select a type from the Add drop-down list: Global, Unnumbered, Link Local, Auto Configuration, or DHCP.

  • Global, with the IP address and subnet mask, and type (General, EUI-64, Anycast, CGA)
  • Unnumbered, and enter text in the Interface Unnumbered To text box
  • Link Local, auto-configured or manually-configured (requires IPv6 address)
  • Autoconfiguration
  • DHCP (with option to enable two-message exchange for address allocation)

Step 6 Click **Save**.

---

**Configure Optical Interfaces**

Using EPN Manager you can configure your optical interfaces to change their admin settings, enable standard FEC modes on them, modify their payload settings, and change their loopback settings. To do this, use the Configuration tab in the Device Details page which lists the current interface configurations on the device. Depending on your device configuration and user account privileges, you can create, edit, delete, enable, and disable these interfaces.

You can configure optical interfaces in the following ways:

• Change the Loopback Settings on an Optical Interface, on page 324
• Continuous Verification of the Connection Status, on page 324
• Configure PRBS on ODU Controllers, on page 326
• Enable and Disable OSC, on page 327
• View and Acknowledge Unverified Alarms, on page 328
• Provision Optical Interfaces, on page 328
  • Change the Admin Status of an Optical Interface, on page 334
  • Configure Protection Profiles, on page 335
  • Configure TCM and TTI Parameters, on page 336
  • Change the Payload and Breakout Settings, on page 338
  • Configure OTN Interfaces, on page 339
  • Enable and Disable GCC Connections, on page 340
  • Configure Squelch Mode, on page 340
• Example: Change the Admin Status for Cisco NCS 2006 Interface, on page 341
Change the Loopback Settings on an Optical Interface

You can change the loopback state of an interface to test how your optical network is performing. Before changing the loopback setting, ensure that the device is either in Managed state or ideally in Complete state. The interface that you want to modify must be in Maintenance (OOS, MT) admin state. EPN Manager allows you to edit the loopback settings only on SONET, SDH, Ethernet, FC/FICON, and OTN interface types.

To change the loopback settings on an interface:

---

**Step 1** Choose **Configuration > Network Devices**.

**Step 2** Click the device hyperlink to launch its Device Details page.

**Step 3** Click the **Configuration** tab.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device Details page.

**Step 4** Choose **Optical Interfaces > Maintenance > Loopback**.

The interfaces of the selected device are displayed along with their loopback settings. Interfaces that are not supported, for example, Data Storage, OTS, or Video, are not displayed.

**Step 5** To edit the loopback settings, select the interface name (hyperlink) and click **Edit** to make your changes. Ensure that the device is in Managed or Complete state and the interface is in Maintenance (OOS, MT) admin state.

a) **Internal**—this applies the same configuration applied in Terminal loopback.

b) **Line**—this applies the same configuration applied in Facility loopback.

c) **No_Loopback**—Select this option to set no loopback values on the interface.

Before you change the loopback state ensure that you first clear the current loopback setting using the No_loopback option from the drop-down menu and then re-apply the setting of your choice.

**Step 6** Click **Save** to save your edits.

A pop-up notification notifies you about the status of your changes.

**Note** If the Edit task fails, check if the device is in Managed or Completed state and ensure that Cisco EPN Manager is in sync with the device configuration. If not, resync the device with Cisco EPN Manager. See, Collect a Device's Inventory Now (Sync), on page 406.

---

Continuous Verification of the Connection Status

Using the Connection Verification feature, you can view the power levels of optical interfaces and verify the interfaces for connectivity and insertion loss. Verifying the connectivity indicates whether the cable is in a connected state and verifying the insertion loss indicates whether the cable loss is within an expected value. The parameters for insertion losses are collected for every possible optical path inside the network element in order to predict possible failures.

Using Cisco EPN Manager you can view the Connection Verification parameters and opt to enable or disable Connection Verification on interfaces. You can also set the acknowledgment values for associated alarms.

To verify the connection status for your optical interfaces:

---

**Step 1** Choose **Configuration > Network Devices**.
Step 2  Click the device hyperlink to launch its Device Details page.

Step 3  Click the Configuration tab.
For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device Details page.

Step 4  To enable or disable the Connection Verification feature and set the common threshold values, click Optical Interfaces > Provisioning > Connection Verification.

Step 5  Click the Edit icon at the top right corner of the page to edit common parameters.

Step 6  Enter the following threshold parameters for the selected device and click Save:
- Connection Verification Enabled- Set to True or False to enable or disable this feature on the selected device.
- Fail IL Threshold (dB)- Enter a numerical value ranging from 0 to 20. When this threshold value is exceeded, an alarm is generated.
- Degree IL Threshold (dB)- Enter a value lesser than the failed IL threshold value.

Step 7  Click Optical Interfaces > Maintenance > Connection Verification Entry.
For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device Details page.

Step 8  Click the A Side hyperlink to view the following values of the connection:
- A Side- Displays the originating slot for connection verification.
- Z Side- Displays the destination slot for connection verification.
- Last Refresh- Displays the date and time when the connection verification and insertion loss verification was run previously.
- Connectivity Last Change- Displays the date and time when the connectivity information was previously changed.
- Connectivity Verification- Displays the status of connectivity:
  - Connected- Cable or patch cord is connected.
  - Disconnected- Cable or patch cord is disconnected.
  - Disabled- Cable or patch cord is excluded from connection verification.
  - Not Measurable- Power source not detected; cable or patch cord cannot be tested for connection verification.
  - Not Verified- Cable or patch cord is yet to be tested for connection verification.
- Excess Insertion Loss (dB)- Display the excess insertion loss that is higher than the set threshold.
- Insertion Loss Last Change- Displays the date and time when the insertion loss verification information was previously changed.

Step 9  In the Connection Verification Action drop-down menu, choose an action that must be taken when the configured threshold values are reached, and click Save. Your options are: Verify loss and connectivity, Disable verification, and Acknowledge loss alarm.
Step 10  (Optional) Select one of the following values to specify how alarms must be generated with respect to the Connection Verification parameters:

- **Acknowledge Loss Alarm** - allows the interfaces to operate beyond the Fail IL Threshold thresholds without raising an alarm. If the Fil IL Threshold further increases, alarms are raised again.

- **Clear Acknowledge** - indicates that the Fail IL Threshold thresholds are set to default and alarms are re-evaluated. If thresholds are exceeded, an alarm is raised.

---

## Configure PRBS on ODU Controllers

Pseudo Random Binary Sequence (PRBS) is a testing mechanism used to ensure that the selected overhead bytes can be used to transport the header and trailer data safely. Both the transmitting node and receiving node must be aware that PRBS testing is taking place. To do this you can use Cisco EPN Manager to enable appropriate PRBS modes on the nodes. Cisco EPN Manager allows you to configure PRBS only on the non-channelized ODU controllers of an optical device.

PRBS also enables trunk ports to generate the PRBS_31 pattern and detect PRBS_11, PRBS_23, and PRBS_31 patterns.

---

### Step 1
Choose **Configuration** > **Network Devices**.

### Step 2
Click the device hyperlink to launch its Device Details page.

### Step 3
Click the **Configuration** tab.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device Details page.

### Step 4
Choose **Optical Interfaces** > **Maintenance** > **PRBS Configuration**. All ODU controllers and their current PRBS parameters are displayed. If the controllers are not listed, ensure that the above stated pre-requisites are met.

### Step 5
To configure PRBS, click the controller’s name hyperlink and click the Edit icon at the top right corner of the page.

### Step 6
Make your modifications to the following parameters.

a) In the **Admin State** drop-down list, select a valid admin state for the ODU controller. Your options are **00S-MT** (maintenance), **OOS-DSBLD** (disabled), and **IS** (in-service).

   The PRBS parameters can be edited only if you set the Admin State to 00S-MT (maintenance) state.

   To edit only the admin state of the controller, set the PRBS mode to Disabled, and choose the admin state of your choice.

b) Select the PRBS Test value as **Enabled** or **Disabled**.

c) Select the PRBS mode for the controller. When you set one controller with the values in column one (see below), ensure that the second controller (node 2) is set with the corresponding values shown in the second column of this table:

<table>
<thead>
<tr>
<th>Controller 1 Mode (Node 1)</th>
<th>Controller 2 Mode (Node 2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>Sink</td>
</tr>
<tr>
<td>Sink</td>
<td>Source</td>
</tr>
<tr>
<td>Source-Sink</td>
<td>Loopback</td>
</tr>
</tbody>
</table>
d) From the **Pattern** drop-down list, select one of the following PRBS patterns. This pattern will be either generated or detected by the line cards:

- NONE
- PN11
- PN23
- PN31
- INVERTEDPN11
- INVERTEDPN31

**Step 7**
Click **Save** to deploy the updated configuration to the device.

**Step 8**
(Optional) To verify, view updated PRBS parameters in the **Configuration** tab for the selected controller, under **Optical Interfaces > Provisioning > PRBS**. To run a PRBS test on ODU UNI circuits, see, **Run PRBS Test on Circuits (ODU UNI)**, on page 631.

---

### Enable and Disable OSC

Using Cisco EPN Manager, you enable or disable the Optical Service Channel (OSC) terminations on the interfaces of optical devices. OSC can be configured on OC3 lines, and on FastEthernet (FSTE) and GigabitEthernet (GigE) interfaces of the following cards:

- Transmission Network Control System (TNCS)
- Transport Node Controller - Enhanced (TNCE)
- Transport Node Controller (TNC)

For ONS15454 NEs, the supported interfaces are OC3 interfaces of the following cards:

- Optical Service Channel Modem (OSCM)
- Optical Service Channel and Combiner/Separator Module (OSC-CSM)

To configure OSC on optical devices:

**Step 1**
Choose **Configuration > Network Devices**.

**Step 2**
Click the device hyperlink to launch its Device Details page.

**Step 3**
Click the **Configuration** tab.
For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device Details page.

**Step 4**
Choose **Optical Interfaces > Comm Channels**.
All configurable G709 enabled interfaces of the selected device are displayed.
Step 5  Click the OSC tab.

Step 6  Choose the communication channel that you want to configure by clicking the communication channel’s name hyperlink.

The communication channel name and current OSC setting is displayed.

Step 7  Click the Edit icon at the top right of the page.

Step 8  Use the OSC checkbox to enable or disable OSC on the selected communication channel.

Step 9  Click Save.

Your changes are saved and the updated configuration is deployed to the device. To verify, view the OSC settings for the selected communication channel under **Optical Interfaces > Provisioning > Comm Channels**.

---

### View and Acknowledge Unverified Alarms

Based on the alarm generated on your devices, you can view the details of the alarm in Unverified status and then mark them Acknowledged so that they no longer appear as unread alarm notifications on the device. To do this:

Step 1  Choose Configuration > Network Devices.

Step 2  Click the device hyperlink to launch its Device Details page.

Step 3  Click the Configuration tab.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device Details page.

Step 4  Choose Optical Interfaces > Maintenance > Unverified Alarms to view the alarms with the Unverified status.

Step 5  Once you have reviewed the alarms and taken the required action, select the alarms and click the Acknowledge button to mark these alarms Verified directly on the device.

---

### Provision Optical Interfaces

You can use Cisco EPN Manager to enable the following configuration options on your optical devices.

#### Note

The following configuration options are enabled or disabled depending on the device you select. To check whether your device supports these options, see **Supported Devices for Cisco EPN Manager**.

- **Ethernet MTU**

  Using Cisco EPN Manager you can configure the MTU values on the Ethernet interfaces of your optical devices. The MTU is the Maximum Transmission Size, in bytes, of a packet passing through the interface. You can use Cisco EPN Manager to modify the MTU values on all Ethernet interfaces except Gigabit Ethernet and Fast Ethernet interfaces on TNC and ECU modules.

  To verify that your new Ethernet MTU values are configured on the device, navigate to your device’s Device Details page and click the Ethernet Interface tab.
• **GMPLS**

Using Generalized Multi-Protocol Label Switching (GMPLS), you can define and view the fiber and alien wavelength parameters that are used during GMPLS circuit creation. It ranges the packet based data on the MPLS protocol to allow the creation and maintenance of channels across the networks. It supports non-packet switching devices. This means that GMPLS extends the packet based MPLS protocol to allow creation and maintenance of tunnels across networks that consist of non-packet switching devices. GMPLS tunnels can traverse Time-Division Multiplex (TDM) interfaces and switching types.

To configure GMPLS, you can use the Configuration tab in Cisco EPN Manager which allows you to configure GMPLS on all LMP enabled optical controllers. The enabling of LMP which is a pre-requisite for GMPLS configuration can also be done using the same Configuration tab.

**Note**

You cannot disable GMPLS on LMP enabled controllers that are part of active optical circuits.

• **Packet Termination**

Using Cisco EPN Manager you can set up packet termination on the ODU controllers of your optical devices. To do this, ensure that packet termination is pre-configured on the device for Ethernet packets. You can then edit the configuration that is already created on the device and discovered by Cisco EPN Manager.

To configure packet termination, you must specify both the Termination Mode and Mapping Mode values.

• **LMP**

The Link Management Protocol (LMP) helps in managing channels and links that are required between nodes for routing, signaling, and link management. LMP is also used to manage the Traffic Engineering (TE) link. It allows multiple data links into a single Traffic Engineering (TE) link that runs between a pair of nodes.

To create an LMP neighbor using Cisco EPN Manager, you need to specify the neighbor’s name, link ID, router ID, and interface ID, and the common link and interface IDs. You can add only one LMP link per controller on your optical device.

While the LMP configuration can be successfully deployed to a single device using Cisco EPN Manager, for LMP to function effectively, you need to configure it on both sets of devices that are participating in the link. This ensures that the LMP link is activated.

Limitations:

- You cannot edit the Numbering value of an LMP link after it has been created. To edit the Numbering value, delete the LMP link and recreate it with the new Numbering value.

- You cannot have duplicate Neighbor Router IDs between two LMP neighbors.

- When you add an LMP link, ensure that the controller is not already associated with another LMP link. This will cause your deploy to fail.

• **OTN Topology**
You can use the Configuration tab to add or modify the topology instance and Area ID associated with an optical OTN controller. If the controller does not have a pre-configured Topology Instance and Area ID, Cisco EPN Manager automatically sets the topology instance to OTN and the Area ID to 0.

Cisco EPN Manager does not allow you to use the same topology instance and Area ID that is already pre-configured on other controllers. To know the Topology Instance and Area ID that is pre-configured on the device, go to **Maps > Network Topology**.

**• NNI**

You can configure your optical interfaces to act as network-node interfaces (NNIs). An NNI indicates that the interface connects to other network nodes. Cisco EPN Manager allows you to configure NNIs on the OTU controllers of your optical device. These interfaces can further be configured to act as source and destination ports.

If a device is not part of a topology, configuring its NNI controller creates an OTN topology instance for that controller with an Area ID 0.

You can create only one NNI configuration per controller for every controller present on the device.

Note: You cannot delete NNI controllers that are pre-configured with a Topology Instance.

**• Breakout**

Enabling breakout on your optical devices utilizes the multilane architecture of the optics and cables to enable you to split single higher density ports into multiple lower density ports. For example, a 100G port can be configured to operate as ten different 10G ports. Or a single 40G port can act as four different 10G ports. To configure breakout using Cisco EPN Manager, see the table below.

Pre-requisite:

Ensure that Breakout is pre-configured on the interface by changing the interface’s Port Mode value to Breakout. See **Change the Payload and Breakout Settings, on page 338**. This changes all other port mode parameters of that interface to ‘None’ enabling breakout on the port, thus allowing you to configure lanes. You can add up to ten lanes per interface.

Limitations:

• All lanes that belong to a particular interface must have the same mapping type.

• OTU2 and OTU2e controllers are supported only if they are in the packet termination mode.

• In Cisco NCS 5.2.4x devices, breakout lanes can only be created when the port modes are of type Ethernet.

• 10G clients that are mapped to OPU2e framing type are not supported.

• Breakout cannot be configured on SONET and SDH controllers.

Example configuration:

If you select a controller optics 0/0/0/0 and enable Breakout with GFPF as its mapping mode and with a framing value of OPU2, then the configuration pushed to the device is:

```
controller optics 0/0/0/0 breakout-mode 1 ethernet framing opu2 mapping gPpF
```

**• Performance Monitoring**

Performance Monitoring (PM) helps you gather performance counters for system maintenance and troubleshooting. You can retrieve both current and historical PM counters at regular intervals. You can enable and disable performance monitoring on OTU and ODU controllers of an optical device.
To configure performance monitoring at the TCM controller level, you must configure OTN interfaces and their associated TCM performance counters, see:

- Reference—Performance Counters for OTN-FEC Interfaces, on page 890
- Reference—Performance Counters for OTN-ODU Interfaces, on page 890
- Reference—Performance Counters for OTN-OTU Interfaces, on page 891

**Channelize ODU (LO) Controllers:**

Associate your ODU controllers with multiple lower order ODU sub-controllers and configure tributary port number (TPN) and tributary slots (TS) for those ODU sub-controllers. A valid range of TPN is from 1 to 80. If a TS string is separated using a colon (:), this indicates individual tributary slot. If a TS string is separated using an en-dash (-), this indicates a range of tributary slots.

When you select the ODU level for the sub-controllers, ensure that the sub-controller’s ODU level is lower than that of the main controller you are associating it with. For example, if you are associating sub-controllers with an ODU controller of ODU3 level, then the sub-controllers can be of levels ODU2, ODU1, or ODU1.

**Configuring OTDR Settings:**

Using this feature, you can configure OTDR scans to begin automatically on a fiber span that has been repaired or on the startup of an OSC channel. To do this, ensure that the ‘Auto Scan on LOS’ parameter is enabled. A fiber is considered to be repaired when the LOS on the fiber is cleared and an alarm is raised based on the following criteria:

- If you check the Enable Absolute Threshold checkbox, the ‘OTDR-LOSS-THR-EXCEEDED’ alarm is raised when the insertion loss measured for the OTDR scan is greater than the Absolute Event Loss Threshold (dB) value configured.
- If the total back reflection for the OTDR scan is less than the Total Back Reflection (dB) value that you specify.
- If the Absolute Pass Fail Criteria is disabled, the Loss and Back Reflection values from the baseline scan in the previous release are considered as threshold values. In this scenario, the OTDR-LOSS-THR-EXCEEDED alarm is raised.

Depending on how you want the auto scans to be triggered, you can configure the following parameters:

- Auto Scan on Span Loss Increase- OTDR scan starts automatically on the fiber if the measured span loss on the fiber is greater than the threshold value configured. The default threshold value is 2.
- Enable OLR continuous measurement on Rx direction- measures the span loss in the LINE-RX port (input) of the card depending on the configured threshold value.
- Enable WDM Side from WSON Provisioning- prevents creation of circuits when the Loss and Back reflection threshold values are crossed during an OTDR scan.

You can configure the Event Loss Threshold value within which the total span loss on the fiber is permitted. If the measured span loss on the fiber is greater than the Event Loss Threshold value, then the OTDR scan is triggered on the fiber.

**Configure Automatic Laser Shutdown (ALS):**

Automatic Laser Shutdown (ALS) is a technique used to automatically shut down the output power of the transmitter in case of issues such as a fiber break. This is a safety feature that prevents dangerous
levers of laser light from leaking out of a broken fiber, provided ALS is provisioned on both ends of the fiber pair. Once an interface has been shut down, you can configure the action the action that must be taken to restart the interface by setting the ALS mode to:

- **Disabled mode**—If mode is disabled, ALS is disabled. Loss Of Signal (LOS) will not cause laser shutdown.

- **Manual restart mode**—The laser is turned off when the ALS agent detects an LOS for 500 ms. After ALS is engaged, a manual command is issued that turns on the laser for the time period of the pulse width. The laser is turned on when the LOS has been cleared for 100 ms.

- **Automatic restart mode**—The laser is shut down for the time period of pulse spacing when the ALS agent detects a LOS for 500 ms. Then, the laser automatically turns on for the time period of the selected pulse width. If an LOS still exists at that time, the laser is shut down again. This pattern continues until the LOS is cleared for 100 ms; then, the laser will stay on.

Cisco EPN Manager enables you to set the ALS mode, the ALS recovery interval (in seconds), and the recovery pulse width (in seconds). If the ALS Mode for the interface has been set to Manual Restart, you need to manually restart the interface. To do this, navigate to the device's Device Details page, choose **Optical > Automatic Laser Shutdown**, locate the interface set to the Manual Restart ALS mode, and click the **Restart** button.

- **Using the SNTP Server to Set the Date and Time:**

  Simple Network Time Protocol (SNTP) is an internet protocol used to synchronize the clocks of computers to a time reference. Using the SNTP server ensures that all NEs use the same date and time reference. The server synchronizes the node’s time after power outages or software upgrades.

  To use the SNTP server to set the date and time you must first specify the current time along with the time zone value and then set the primary and backup servers that can be used as a point of reference for the date and time. Before you set the timezone values, ensure that the SNTP server values are not configured. When you delete an SNTP server, ensure that you first delete the Backup server and only then the Primary server. You cannot delete only the Primary server.

- **Configuring the Wavelength:**

  Cisco EPN Manager enables you to provision the wavelength frequency for your optics controllers. You can view the current wavelengths configured on the optics controllers and then depending on the type of card selected, you can change the wavelength frequency.

  You can configure the wavelengths on an optics controller only when it is configured as a DWDM optics port. To confirm this, navigate to the device's Device Details page, choose **Interfaces > Optical Interfaces**, and check if the Optics Type column for the interface is either **DWDM** or **Grey**.

**Table—Provisioning Optical Interfaces**

To configure your optical devices with the above features:

---

**Step 1** Choose **Configuration > Network Devices**.

**Step 2** Click the device hyperlink to launch its Device Details page.

**Step 3** Click the **Configuration** tab.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device Details page.

**Step 4** Navigate to the required configuration menu as described in the table below, and specify the required values.
<table>
<thead>
<tr>
<th>Task</th>
<th>Supported Interfaces/Controllers</th>
<th>Navigation</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuring Ethernet MTU</td>
<td>All Ethernet interfaces except Gigabit/Fast Ethernet interfaces on TNC and ECU modules.</td>
<td>Optical Interfaces &gt; Provisioning &gt; Ethernet MTU</td>
<td>-</td>
</tr>
<tr>
<td>Configuring GMPLS</td>
<td>LMP enabled optical controllers.</td>
<td>Optical Interfaces &gt; Provisioning &gt; GMPLS</td>
<td>-</td>
</tr>
<tr>
<td>Configuring Packet Termination</td>
<td>ODU controllers pre-configured with Packet Termination.</td>
<td>Optical Interfaces &gt; Provisioning &gt; OTN &gt; Packet Termination</td>
<td>Applicable only to Ethernet packets.</td>
</tr>
<tr>
<td>Configuring an LMP Neighbor</td>
<td>All optical controllers.</td>
<td>Optical Interfaces &gt; Provisioning &gt; LMP</td>
<td>Neighbor Router ID cannot be duplicated between neighbors</td>
</tr>
<tr>
<td>Configuring OTN Topology</td>
<td>All optical OTN controllers.</td>
<td>Optical Interfaces &gt; Provisioning &gt; OTN &gt; Topology</td>
<td>-</td>
</tr>
<tr>
<td>Configuring NNI</td>
<td>All OTU controllers.</td>
<td>Optical Interfaces &gt; Provisioning &gt; OTN &gt; NNI</td>
<td>-</td>
</tr>
<tr>
<td>Configuring Breakout</td>
<td>All optical controllers with Port Mode values set to ‘Breakout’.</td>
<td>Optical Interfaces &gt; Provisioning &gt; Port Mode &gt; Breakout tab</td>
<td>-</td>
</tr>
<tr>
<td>Configuring Performance Monitoring</td>
<td>All OTU and ODU controllers.</td>
<td>Optical Interfaces &gt; Provisioning &gt; Performance Monitoring</td>
<td>-</td>
</tr>
<tr>
<td>Channelize ODU (LO) Controllers</td>
<td>All ODU controllers.</td>
<td>Optical Interfaces &gt; Provisioning &gt; ODU Channelization &gt; Sub-Controllers tab</td>
<td>-</td>
</tr>
<tr>
<td>Configuring OTDR Settings</td>
<td>-</td>
<td>Optical Interfaces &gt; Provisioning &gt; OTDR Settings</td>
<td>-</td>
</tr>
<tr>
<td>Configuring ALS</td>
<td>All ALS supported interfaces</td>
<td>Optical Interfaces &gt; Provisioning &gt; Automatic Laser Shutdown</td>
<td>-</td>
</tr>
</tbody>
</table>
### Change the Admin Status of an Optical Interface

Cisco EPN Manager enables you to change the admin state of an interface to enhance the performance testing abilities for your optical network. The Admin Status of an interface defines whether the interface is being managed by Cisco EPN Manager, whether it is down, or whether it is in maintenance mode. When the admin status is set, it will

| Setting the Date and Time using SNTP | - | • To specify the primary and backup servers for SNTP: Choose Optical Interfaces > Provisioning > NTP Settings • To specify the current time and time zone that can be used by SNTP: Choose Optical Interfaces > Provisioning > Time Zone Settings | - |
| Configure Wavelength | All optics controllers | Optical Interfaces > Provisioning > Wavelength | - |
| Configure TCM and TTI | - | See Configure TCM and TTI Parameters, on page 336 | - |
| Configure Protection Profiles | - | See Configure Protection Profiles, on page 335 | - |
| Configure the Payload and Breakout Settings | - | See Change the Payload and Breakout Settings, on page 338 | - |
| Configure the Admin Status | - | See Change the Admin Status of an Optical Interface, on page 334 | - |
| Configure FEC Mode | - | See Configure OTN Interfaces, on page 339 | - |
| Enabling and Disabling GCC | - | See, Enable and Disable GCC Connections, on page 340 | - |
| Configure Squelch Mode | - | See, Configure Squelch Mode, on page 340 | - |
status of an interface is down, it indicates that the interface is in an unreachable state, or that the device is not supported by Cisco EPN Manager. Changing the admin status to Up enables Cisco EPN Manager to manage the interface and thus provide better monitoring capabilities. To change the admin state on an interface:

**Step 1** Choose Configuration > Network Devices.

**Step 2** Click the device hyperlink to launch its Device Details page.

**Step 3** Click the Configuration tab.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device Details page.

**Step 4** Choose Optical Interfaces > Provisioning > Admin Status.

The interfaces of the selected device are displayed along with their Admin State settings. Interfaces on which you cannot modify the admin state, for example, PCHAN and PLINE interfaces are not displayed.

**Step 5** Click either the Optical Controllers or Ethernet Controllers tab to edit the required controllers.

**Step 6** To edit the admin status, select the interface by clicking the interface's Name hyperlink, and then click the Edit icon at the top right corner of the page. Ensure that the device's inventory collection status is in Managed or Completed state.

Choose one of the following values:

a) **Down**—implies that the interface will be administratively down.

b) **Up**—implies that the interface will be administratively up.

c) **Testing**—implies that the interface is in Maintenance state and that the administrator is performing tests using it.

**Step 7** Click Save to save to deploy your changes to the device.

A pop-up notification notifies you about the status of your changes. To see an example of the admin status being changed on a Cisco NCS2K device, see Example: Change the Admin Status for Cisco NCS 2006 Interface, on page 341.

**Note** If the Edit task fails, check if the device is in Managed or Completed state and ensure that Cisco EPN Manager is in sync with the device configuration. If not, re-sync the device with Cisco EPN Manager as described in Collect a Device's Inventory Now (Sync), on page 406.

---

### Configure Protection Profiles

Using Cisco EPN Manager, you can provision different protection profiles (or groups) for your optical devices. This ensures availability and improved reliability for these devices. Protection profiles define whether Automatic Protection Switching (APS) must be enabled on the cards and they also set the direction for traffic flow in case of failures. The cards on the device can either be set to support unidirectional regeneration of configuration or can be set to ensure that both transmit and receive channels will switch when a failure occurs on one.

**Step 1** Choose Configuration > Network Devices.

**Step 2** Click the device hyperlink to launch its Device Details page.

**Step 3** Click the Configuration tab.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device Details page.

**Step 4** Choose Optical Interfaces > Provisioning > Protection Profile.

**Step 5** To add a protection profile, click the + symbol.
Step 6 Provide a unique name for the protection profile. The name is a mandatory field and should not contain space or exceed 32 characters.

Step 7 Select the required type for the protection profile. Your options are:

- **One plus one BDIR APS**: Enables one plus one Automatic Protection Switching (APS) and configures the card to be bidirectional.

- **One plus one UNIDIR APS**: Enables one plus one APS and configures the card to be unidirectional.

- **One plus one UNIDIR NO APS**: Enables one plus one with no APS and configures the card to be unidirectional.

- **One plus one PLUS R BIDIR APS**: Enables one plus one plus R APS and configures the card to be bidirectional.

**Note**

- **BDIR** (bidirectional) indicates that both transmit and the receive channels will switch if a failure occurs on one.

- **UNIDIR** (unidirectional) indicates that the card supports unidirectional regeneration of configuration. Hence the ports can only be used as the link source if they are transmit ports and as the link destination if they are receive ports.

Step 8 Select the protection mode for the profile as **Revertive** or **Non-Revertive**. Revertive mode ensures that the node returns traffic towards the working port post a failure condition after the amount of time specified as the Wait to Restore Time (step 9).

Step 9 Select the sub network connection mode as **SNC_N** (default), **SNC_I**, or **SNC_S**.

Step 10 When you select the sub network connection mode as **SNC_S**, you can then select TCM-ID value from the TCM drop-down list. By default, TCM-4 is selected once you select SNC_S as Sub Network Connection mode. You can change the TCM-ID column value from TCM4 to TCM1-TCM6 for SNC_S.

**Note** For SNC_I and SNC_N, you are not allowed to change the TCM-ID value. It should be set to **None**.

Step 11 Enter a value for the Wait to Restore Time in seconds using a number between 0 and 720. For any value greater than 0, ensure that the value is greater than 300 and in intervals of 30 seconds. The Wait to Restore time defines the time the system must wait to restore a circuit. If you have selected the protection mode as Revertive, then the default Wait to restore time is 300, else it is 0.

Step 12 Enter a value for the **Hold Off Time** in milliseconds. This value defines the time the system waits before switching to the alternate path. The valid range is from 100 to 10000 seconds. Default value is 0.

Step 13 Click **Save** to deploy the updated changes to your device.

Step 14 (Optional) To verify, view the updated protection profile parameters in the **Configuration** tab for the selected controller, under **Optical Interfaces > Provisioning > Protection Profile**.

### Configure TCM and TTI Parameters

Using Cisco EPN Manager, you can configure Tandem Connection Monitoring (TCM) and Trail Trace Identifiers (TTI) on ODU controllers of ODU Tunnel circuits. This helps you enable and disable performance monitoring capabilities on these controllers.

You can further monitor your device’s capabilities by configuring the threshold for signal failure and signal degrading in the TCM connections of these ODU controllers. You can also modify the source and destination access point identifiers. To do this, ensure that the following pre-requisites are met.
Before you begin

- Ensure that the device’s inventory collection status is ‘Completed’.
- Ensure that the controllers are configured for Loopback. If not, change the controllers loopback settings under Optical Interfaces > Maintenance > Loopback. See Configure Loopback Interfaces, on page 318.

Note: For the endpoints of an ODU UNI circuit, TCM is supported only on OTUx-ODUx controllers.

---

**Step 1**
Choose **Configuration > Network Devices**.

**Step 2**
Click the device hyperlink to launch its Device Details page.

**Step 3**
Click the **Configuration** tab.

For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device Details page.

**Step 4**
To configure TCM/TTI parameters, choose **Optical Interfaces > Provisioning > TCM Configuration**.

Alternatively you can navigate to the device’s Chassis View tab, select a card from the Chassis Explorer, click the **Configuration** tab, and choose **OTN > Trail Trace Identifier**.

**Step 5**
To view or edit the TCM parameters of any of the listed controllers, click the TCM ID hyperlink of that controller.

**Step 6**
To edit these parameters, click the Edit icon at the top right corner of the page.

**Step 7**
Make your changes to the following TCM parameters:

<table>
<thead>
<tr>
<th><strong>Editable TCM Parameters</strong></th>
<th><strong>Descriptions</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>State</td>
<td>Configures the state of TCM properties on the device as enabled or disabled.</td>
</tr>
<tr>
<td>Signal Failure Threshold</td>
<td>Configures the threshold value for signal failures on ODUk controllers. The values are E6, E7, E8, and E9.</td>
</tr>
<tr>
<td>Sent API</td>
<td>Configures the source access point identifier of the TTI. Enter a value of up to 14 bytes in length.</td>
</tr>
<tr>
<td>Sent DAPI</td>
<td>Configures the destination access point identifier of the TTI. Enter a value of up to 14 bytes in length.</td>
</tr>
<tr>
<td>Sent Operator Specific String Type</td>
<td>Configures the type of the operator specific string of the TTI as hexadecimal or ASCII type.</td>
</tr>
<tr>
<td>Sent Operator Specific String</td>
<td>Configures the operator specific string of the TTI. Enter a value of up to 32 characters in length.</td>
</tr>
<tr>
<td>Performance Monitor</td>
<td>Enables or disables performance monitoring on an ODUk controller.</td>
</tr>
<tr>
<td>Signal Degrade Threshold</td>
<td>Configures the signal degrade threshold value. The values are: E6, E7, E8, and E9.</td>
</tr>
<tr>
<td>Expected SAPI</td>
<td>Configures the current source access point identifier of the TTI. Enter a value of up to 14 bytes in length.</td>
</tr>
</tbody>
</table>
### Editable TCM Parameters

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expected DAPI</td>
<td>Configures the current destination access point identifier of the TTI. Enter a value of up to 14 bytes in length.</td>
</tr>
<tr>
<td>Expected Operator Specific String Type</td>
<td>Configures the type of the operator specific string of the TTI as hexadecimal or ASCII type.</td>
</tr>
<tr>
<td>Expected Operator Specific String</td>
<td>Configures the operator specific string of the TTI. Enter a value of up to 32 characters in length.</td>
</tr>
</tbody>
</table>

#### Change the Payload and Breakout Settings

Using the Device Configuration tab, you can view and modify the type of the payload for packets on SONET and SDH interfaces and enable breakout on them. Before changing the payload setting, ensure that the device is in sync with Cisco EPN Manager. Enabling breakout on your optical devices utilizes the multilane architecture of the optics and cables to enable you to split single higher density ports into multiple higher density ports. For example, a 100G port can be configured to operate as ten different 10G ports. Or a single 40G port can act as four different 10G ports.

To change the payload and breakout setting on an interface:

1. Choose **Configuration > Network Devices**.
2. Click the device hyperlink to launch its Device Details page.
3. Click the **Configuration** tab.
   - For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device Details page.
4. Choose **Optical Interfaces > Provisioning**.
5. Depending on the type of device that you have selected, choose **Payload Type** or **Port Mode**.
6. Click the name (hyperlink) of the interface that you want to modify.
   - Common properties of the interface such as its name and its payload type are displayed.
7. Click the name (hyperlink) of the OTN interface that you want to modify and click the Edit icon.
8. Make your changes to the Port Mode, Framing, Mapping Type, Rate, and Bit Rate values. Ensure that these values do not exceed the card's bandwidth limitations.
9. To associate breakout lanes for Ethernet and OTN packets on this interface, click the **Breakout** tab. This tab is only displayed if the device has breakout pre-configured.
Configure OTN Interfaces

The FEC Mode defines an OTN circuit's forward error correction (FEC) mechanism. The forward error correction (FEC) mechanism provides performance gains for improved margins and extended optical reach. To change the FEC Mode setting to Standard, you need to use the Device Configuration tab.

Before changing the FEC mode setting, ensure that the admin state of the interface you are trying to modify is in Down (out of service) state with G709 configuration enabled. To enable G709 configuration, use the OTN Lines configuration in the Chassis view.

To change the FEC mode on an interface:

Step 1 Choose Configuration > Network Devices.
Step 2 Click the device hyperlink to launch its Device Details page.
Step 3 Click the Configuration tab.
Step 4 Choose Optical Interfaces > Provisioning.
Step 5 Change the admin state of OTN interfaces for which FEC needs to be modified to Down. See Change the Admin Status of an Optical Interface, on page 334.
Step 6 Depending on your device type, choose one of the following and select the interface you want to modify:

- OTN Lines > OTNFEC
- OTN > FEC

All configurable G709 enabled interfaces of the selected device are displayed.
Alternatively, you can navigate to the device's Chassis View tab, select a card from the Chassis Explorer, click the Configuration tab, and choose OTN > OTN Lines. This option enables you to configure additional parameters such as enabling the sync messages, choosing the admin SSM, enable the Provide Sync parameter, and set the G709 value to true or false.

Step 7 Select the interface you want to edit, and click the Edit icon at the top right of the window.
Step 8 Select the required FEC Mode. The default is None.
Step 9 (Cisco NCS 2000 devices only) Select the required SDBER value. Signal Degrade Bit Error Rate (SDBER) condition indicates that a signal degrade alarm will occur for line degradation based on the threshold value that you set.
Enable and Disable GCC Connections

Cisco EPN Manager supports the provisioning of Generic Communication Channel (GCC) connection on the interfaces of optical devices. GCC can be configured on trunk ports of TXP or MXP cards and on OTN, OTU, and ODU controllers. The GCC configuration can be modified irrespective of the FEC modes and admin statuses configured on the interfaces.

To configure GCC on optical devices:

**Step 1** Choose **Configuration > Network Devices**. All Cisco EPN Manager devices are displayed.

**Step 2** Select the optical device that you want to configure by clicking the device name hyperlink.

**Step 3** Click the **Configuration** tab and choose **Optical Interfaces > Provisioning**.

**Step 4** Depending on your device type, choose one of the following:

- **Comm Channels > GCC**
- **OTN > GCC**

All configurable G709 enabled interfaces of the selected device are displayed.

**Step 5** Click the **OTU Controllers** or **ODU Controllers** tab based on the type of controller that you want to edit.

**Step 6** To edit the GCC configuration of any of the listed controllers, click the controller’s name hyperlink.

**Step 7** Click the Edit icon at the top right of the page.

**Step 8** Use the GCC check box to enable or disable GCC on the selected controller. The value configured on ODU controllers is GCC1 and that on OTU controllers is GCC0.

**Step 9** Click **Save**. Your changes are saved and the updated configuration is deployed to the device.

To verify, view the GCC parameters for the selected controller under **Optical Interfaces > Provisioning**.

When GCC is enabled on a Cisco NCS device with 400G-XC trunk ports, Cisco EPN Manager discovers the OUT link between the trunk ports.

Configure Squelch Mode

Using Cisco EPN Manager, you can configure different squelch modes on the interfaces of optical devices. Squelch modes help shut down the far-end laser in response to certain defects. Squelch modes can be configured on OCH, OTN, SONET or SDH, FC or FICON, Ethernet, Video, and Data Storage interfaces of optical devices.
Step 1  Choose Configuration > Network Devices.
Step 2  Click the device hyperlink to launch its Device Details page.
Step 3  Click the Configuration tab.
For Cisco NCS 2000 and Cisco ONS devices, this choice is under the Logical View tab that is at the top of the Device Details page.
Step 4  Choose Optical Interfaces > Provisioning > Squelch Mode.
Step 5  Choose the interface that that you want to configure by clicking the interface's name hyperlink.
The interface's name and current squelch mode setting are displayed.
Step 6  Click the Edit icon at the top right corner of the page.
Step 7  Select the required squelch mode for the interface. Your options are:
  • DISABLE- Squelch is disabled.
  • AIS- Alarm Indication Signal (AIS) is enabled.
  • NONE- Transparent mode is enabled.
  • SQUELCH- Squelch is enabled.
  • ODU_AIS
  • G_AIS- Generis AIS is enabled.
  • NOS- Squelch is disabled in FC payloads.
  • LF
Step 8  Click Save.
Your changes are saved and the updated configuration is deployed to the device. To verify, view the squelch mode parameters of the selected interface under Optical Interfaces > Squelch Mode.

Example: Change the Admin Status for Cisco NCS 2006 Interface

This example illustrates how to change the admin status for a Cisco NCS 2006 VLINE interface. In this example, the configuration change is launched from the Device Details page, but under the Logical View tab. (For other devices, configuration changes are performed under the Configuration tab.)

Step 1  On the Device Details page under the Logical View tab, click the hyperlink for the interface you want to edit.
Step 2  In the interface's Common Properties window, click the Edit icon at the top right corner of the window.

Step 3  Choose a new setting from the Admin Status drop-down list, then click Save.
Configure Devices Using the Chassis View

You can configure devices and cards from the devices' Chassis View. This can only be done from the Configuration sub-tab in the Chassis View. The sub-tabs are displayed depending on the type of device you select in the Network Devices page.

**Note**

This feature is available only for Cisco NCS 2000 and Cisco ONS devices.

**Step 1**  
From the left sidebar, choose **Configuration > Network Devices**.

**Step 2**  
Select the device that you want to configure by clicking the device's name hyperlink. The Chassis View tab for the device appears.

**Step 3**  
In the right pane, click the **Configuration** sub-tab.

**Step 4**  
Expand the **General** area, and then enter the details of the device such as the node name, node alias, and select the location where you want to provision the device.
Step 5: Set up the synchronization time for the device to synchronize with its associated controllers. You can either use the NTP/SNTP server time or set up a manual date and time for synchronization.

Step 6: Check the Enable Manual Cooling check box to manually change the cooling profile of the device. The cooling profile allows you to control the speed of the fans in the device’s shelf.

Step 7: Click Apply. The changes in the settings are updated.

Step 8: Expand the Network area, select the network setting you want to modify, and then click the edit icon at the top left of the Network area. The Edit Network General Settings window appears.

Step 9: Modify the required settings, and then click Apply.

Note: You cannot modify the Node Address, Net/SubnetMask Length, Mask, and MAC Address of the device.

Step 10: Configure security settings for a device. See Create and Manage Users and User Logins for a Device, on page 344.

Step 11: Configure the origination (TX) and termination (RX) patchcords for a device. See Configure Patchcords for a Device, on page 345.

Step 12: Configure the alien wavelength for a device. See Configure GMPLS and WSON Properties, on page 353.

Create and Manage Users and User Logins for a Device

Use this procedure to create users and assign roles to manage a device. You can also view the list of users who are accessing the device at a time.

Step 1: From the left sidebar, choose Configuration > Network Devices.

Step 2: Select the device that you want to configure by clicking the device’s name hyperlink. The Chassis View tab for the device appears.

Step 3: In the right pane, click the Configuration sub-tab, and then expand the Security area.

Step 4: In the Users tab, click the + icon to add a user.

Step 5: Enter the user name.

Step 6: From the Security Level drop-down list, choose one of the following options:

- Retriever—Users with this security level can view and retrieve information from the device, but cannot modify the configuration.
- Maintenance—Users with this security level can retrieve information from the device and perform limited maintenance operations such as card resets, Manual/Force/Lockout on cross-connects or in protection groups, and BLSR maintenance.
- Provisioning—Users with this security level can perform all maintenance operations and provisioning actions except those that are restricted to super users.
- Super User—Users with this security level can perform all provisioning user actions, plus creating and deleting user security profiles, setting basic system parameters such as time, date, node name, and IP address, and doing database backup and restoration.

Step 7: Enter your password, and then click Save. The user is added to the Users table.
You can select a user to edit or delete the user. However, you cannot edit the user name. Moreover, you cannot delete a user who has added the device to Cisco EPN Manager.

In the Security area, click the **ActiveLogins** tab to view the list of users who have logged in to the device using CTC, TL1 session, or Cisco EPN Manager. You can choose to logout a user or multiple users when the maximum login sessions for a device is reached.

## Configure Patchcords for a Device

The client card trunk ports and the DWDM filter ports can be located in different nodes or in the same single-shelf or multi-shelf node. A virtual link is required between the client card trunk ports and the DWDM filter ports. The internal patchcords provide virtual links between the two sides of a DWDM shelf, either in single-shelf or multishelf node. The patchcords are bidirectional, however, each direction is managed as a separate patchcord.

This feature is only supported on Cisco NCS 2000 and Cisco ONS devices.

This procedure explains how to configure internal patchcords using the Chassis View using ANS (automatic node setup) for WDMs (wavelength division multiplexing). You can use the Chassis View to create and delete these internal patchcords. To configure origination (TX) and termination (RX) patchcords for a device:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>From the left sidebar, choose <strong>Configuration &gt; Network Devices</strong>.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Select the device that you want to configure by clicking the device's name hyperlink. The Chassis View tab for the device appears.</td>
</tr>
<tr>
<td>Step 3</td>
<td>In the right pane, click the <strong>Configuration</strong> sub-tab, and then expand the <strong>Internal.patchcord</strong> area.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Click the + icon, and then choose the required origination (TX) and termination (RX) patchcords for the device.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Click <strong>Finish</strong>. The patchcords are added to the Internal Patchcords table.</td>
</tr>
</tbody>
</table>

*Note* Once you have created the patchcord, you cannot modify it. However, you can delete it.

You can select a patchcord or multiple patchcords in the Internal Patchcords table to view the direction of the patchcords in the Chassis View of the device, which is displayed in the left pane (as shown in the figure).
Configure a Protection Group for a Shelf in a Device

Use this procedure to create a protection group for a shelf in a device.

**Note**

You cannot configure a protection group for a rack.

**Before you begin**

Following are the prerequisites before creating a protection group for a shelf:

- To create a Y Cable protection group, ensure that two cards of the same type that are configured with client ports are plugged in to the same shelf.

- To create a Splitter protection group, ensure that at least one OTU2XP card that is configured with trunk port 3-1 and trunk 4-1, is plugged in to the shelf.

**Step 1**

From the left sidebar, choose **Configuration** > Network Devices.

**Step 2**

Select the device that you want to configure by clicking the device’s name hyperlink. The Chassis View tab for the device appears.

**Step 3**

Expand the Chassis View Explorer, and then select the shelf for which you want to configure the protection group.

**Step 4**

In the right pane, click the **Configuration** sub-tab, and then expand the **Protection** area.

**Step 5**

Click the + icon to open the Create Protection Group window.

**Step 6**

From the Type drop-down list, choose one of the following protection type:

- **Splitter**—This protection type is applicable only when a MXPP/TXPP card is used. These cards provides splitter (line-level) protection (trunk protection typically on TXPP or MXPP transponder cards).
• Y Cable—This protection type is applicable only when two transponder or two muxponder cards that are configured with client ports, are plugged in to the same shelf in a device.

**Step 7** Choose a protect port and a working port for the shelf.

*Note* You will be able to select these ports only if you have completed the prerequisites listed at the beginning of this procedure.

**Step 8** Choose if the protection type is uni-directional or bi-directional. In the bidirectional mode, a failure on an active interface triggers a switchover of the traffic from the active interface to the protecting/backup interface.

**Step 9** Click the **Revertive** toggle radio button to revert the shelf from the protected port to the original port after the failure is fixed.

**Step 10** Choose the hold off time in milliseconds. Hold off time is the period that the shelf on the protected port must wait before switching to the original port after the failure is fixed. The shelf can revert to the original port after the hold time expires. The minimum value of hold off time must be 0.5.

**Step 11** Click **Apply**. The protection group is added to the Protection table.

---

**Configure Slices**

Using Cisco EPN Manager you can configure the slice by controlling the bitrate on the client and trunk ports and by configuring the FEC and encryption types for each slice.

You must configure the five client ports of the slice at the same bitrate. Also, ensure that both trunk ports are always set to the same FEC mode.

---

**Note**
Slice configuration is currently only supported for Cisco NCS 1002 device.

To configure the slice:

**Step 1** Launch the **Chassis View** as described in **Open the Chassis View, on page 77**.

**Step 2** Click the **Configuration** tab from the window displayed on the right.

**Step 3** Expand the **Slice Configuration** sub-tab.

**Step 4** To add new slice configuration, click the + (Add) button and specify the following details:

<table>
<thead>
<tr>
<th>Slice Configuration Parameters</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slice Number</td>
<td>Numerical value that represents the Slice ID. You can create only one set of configuration per slice.</td>
</tr>
<tr>
<td>Client Bitrate</td>
<td>Total number of bits per second (in kilobits per second) to be configured on the client ports of the slice.</td>
</tr>
<tr>
<td>Trunk Bitrate</td>
<td>Total number of bits per second (in kilobits per second) to be configured on the trunk ports of the slice.</td>
</tr>
<tr>
<td>FEC</td>
<td>FEC value to be set on the trunk ports.</td>
</tr>
</tbody>
</table>
Before changing the FEC mode setting, ensure that the admin state of the interface you are trying to modify is in Down (out of service) state with G709 configuration enabled.

Encryption

Configures the slice to function with encrypted or unencrypted traffic.

Step 5
Click Apply to deploy the changes to the device immediately.

You can add only one set of parameters per slice and not all parameters are editable once saved. To edit the parameters, delete the configuration for the slice and add it again.

Note The slice configuration cannot be deleted if the admin state is UP.

Configure Interfaces from the Device Details Page

Complete the following procedure to configure an interface from the Device Details page:

Step 1
With a device’s Chassis View open, click the Launch Configuration link. The Device Details page opens.

Step 2
Click the Logical View tab.

Step 3
From the Features pane, choose Interfaces > the interface type you want to configure.

Step 4
Complete the instructions specific to the interface type you chose to add or edit an interface (see Configure Interfaces, on page 316).

Update Cisco NCS 1000 Interface Settings

You can quickly update the Admin Status, Wavelength (nm), and Loopback settings for interfaces configured on a Cisco NCS 1000 Series device from its Device Details page. To do so, complete the following procedure.

Step 1
Open the Device Details page for a Cisco NCS 1000 Series device, as described in Get Complete Device Information: Device Details Page, on page 74.

Step 2
Click the Configuration tab. The page updates, displaying 3 sub-tabs: Optics, Ethernet, and Coherent DSP.

Step 3
Click the sub-tab for the interface type you want to update.

Step 4
Make the necessary changes:

Method 1
1. In the interfaces table, locate the interface you want to update.
2. Click the parameter you want to change to open a drop-down list.
3. Choose the value you want to set, then click Save.
Method 2

1. Click the radio button for the interface you want to update, then click the pencil (Edit) icon. The Edit interface type dialog box opens.

2. Choose the value you want to set from the available drop-down lists, then click Apply.

3. Click OK to confirm your changes.

Note the following:

• For Optics interfaces:
  • You can update the Admin Status and Wavelength (nm) parameters.
  • You can only set a new wavelength value if the Optics Type parameter is set to DWDM.

• For Coherent DSP and Ethernet interfaces:
  • You can update the Admin Status and Loopback parameters.
  • You can only set a new loopback value if the Admin Status parameter is set to Testing.
  • If you set the Loopback parameter to Line, Cisco EPN Manager applies the same configuration applied for a facility loopback. A facility loopback tests the line interface unit (LIU) of a card, the electrical interface assembly (EIA), and related cabling.
  • If you set the Loopback parameter to Internal, Cisco EPN Manager applies the same configuration applied for a terminal loopback.

---

Configure Controllers (Optics, OTS, OCH, DSP, and DWDM)

Using Cisco EPN Manager, you can configure optical device controller parameters such as the wavelength, FEC, SD and SF BER reporting and thresholds, and more for controllers of type OTS, OTS OCH, DWDM, and more.

The Optical Transport Section (OTS) controller holds all the optical parameters for the OTS optical interfaces. The optical interface has different capabilities depending on its hardware components such as VOA and amplifier. Hence, the parameters enabled or disabled on the OTS controller depend on the actual hardware capability on the specific optical interface. You can configure parameters such as amplifier gain range, amplifier tilt, and OSRI for the OTS controller.

The Optical Transport Section OCH (OTS OCH) controller represents the OCM device available on the OTS optical interface. This controller has channel granularity over the OTS interface. The OTS OCH controller contains the wavelength information. You can configure only the admin status for the OTS OCH controller.

To ensure that you complete the slice configuration before configuring the controllers, see, Configure Slices, on page 347.

To configure the optical controller parameters:

---

Step 1

Launch the Chassis View as described in Open the Chassis View, on page 77.
Step 2  Click the **Configuration** tab from the window displayed on the right.

Step 3  Expand the **Controllers** sub-tab. Depending on your device selection, supported tabs are displayed.

Step 4  To edit the configuration on optical controllers, click **Optics**, choose the required settings, and click the modify icon to make your changes.

Step 5  To edit the configuration on OTS controllers, click **OTS**, choose the required settings, and click the modify icon to make your changes.

Step 6  To edit the configuration on OTS-OCH controllers, click **Ots-Och**, choose the required settings, and click the modify icon to make your changes.

Step 7  To configure coherent DSPs, click **Coherent DSPs**, choose the required settings, and click the modify icon to make your changes.

Note that you cannot edit any parameter when the transport admin status is set to IS.

Step 8  To edit the configuration on DWDM controllers, click **DWDM**, choose the required settings, and click the modify icon to make your changes.

<table>
<thead>
<tr>
<th>Category</th>
<th>Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Common Optics, OTS-OCH, DSP, and DWDM Controller Parameters</td>
<td>• Name</td>
<td>Name- (Display only) Displays the port number.</td>
</tr>
<tr>
<td></td>
<td>• Admin Status</td>
<td>Admin Status- Defines whether the interface is managed (Up), down, or in maintenance mode. You cannot modify the controller properties when the status of the interface is Up.</td>
</tr>
<tr>
<td></td>
<td>• Operational Status</td>
<td>Operational Status – Defines whether the interface is operational and is performing as provisioned.</td>
</tr>
<tr>
<td></td>
<td>• Transport Admin Status</td>
<td>Transport Admin Status – Defines the transport administration state of the controller.</td>
</tr>
<tr>
<td>Common Optics and DWDM Parameters</td>
<td>Actual Wavelength (nm)</td>
<td>Displays the actual wavelength utilized by the channel.</td>
</tr>
<tr>
<td></td>
<td>Wavelength (nm)</td>
<td>Displays the wavelength value configured on the channel. Once the device Inventory Collection status is completed, the Actual Wavelength and Wavelength values will match.</td>
</tr>
<tr>
<td></td>
<td>FEC Mode</td>
<td>FEC value to be set on the controllers. Before changing the FEC mode setting, ensure that the admin state of the interface you are trying to modify is in Down (out of service) state with G709 configuration enabled.</td>
</tr>
<tr>
<td>Optics Parameters</td>
<td>Speed</td>
<td>Set the speed values (in Gigabits per second) that the controllers must operate on.</td>
</tr>
<tr>
<td></td>
<td>Differential Modulation</td>
<td>Enable or disable Differential Encoding (DE) based on the configured speed values.</td>
</tr>
<tr>
<td></td>
<td>Loopback</td>
<td>Configure the loopback as:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Internal - All packets are looped back internally within the router before reaching an external interface. It tests the internal Rx to Tx path and stops the traffic to egress out from the Physical port.</td>
</tr>
</tbody>
</table>
### Description

- **Parameters:** SD BER
  - **Description:** Set the signal degrade bit error rate. Your options are E-5, E-6, E-7, E-8, or E-9.

- **Parameters:** SF BER
  - **Description:** Set the signal fail bit error rate. Your options are E-3, E-4, or E-5.

### DWDM Parameters

- **Parameters:** Loopback
  - **Description:** Configure the loopback as:
    - Internal - All packets are looped back internally within the router before reaching an external interface. It tests the internal Rx to Tx path and stops the traffic to egress out from the Physical port.
    - Line - Incoming network packets are looped back through the external interface.

### OTS Parameters

- **Parameters:** Port Role
  - **Description:** Current operational state of the port.

### OTU Parameters

- **Parameters:** OTU-SD
  - **Parameters:** OTU-SF
  - **Parameters:** ODU-SD
  - **Parameters:** ODU-SF
    - **Description:** Configure SF (signal fail) and SD (signal degrade) BER reporting and thresholds.
      - Depending on whether the alarm is an OTU or ODU alarm, the alarm represents that SM BER is in excess based on the SD BER threshold or SF BER threshold.

### Step 9

Click **Apply** to deploy your changes to the device immediately.
Step 10  
(Optional) To change the unit of the DWDM grid value to either wavelength or frequency, go to Administrator > Settings > System Settings > Circuits/VCs Display, and under the DWDM Grid Unit area, choose either Wavelength (Nanometer (nm)) or Frequency (Tatrahertx (THz)).

Configure Passive Units

Passive units are passive cards provisioned using Cisco EPN Manager for optical devices. Cisco EPN Manager maintains these passive units in its database and does not deploy them to devices. Once configured, you can view these passive units in the Device Details and Inventory pages and use them to create managed links in the Network Topology.

Note  
Passive Unit configuration is currently only supported for Cisco NCS 1001 device.

To add and delete passive units:

Before you begin

Ensure that you have either 'Administrator' or 'Config Manager' user privilege before you perform this task.

Step 1
Launch the Chassis View as described in Open the Chassis View, on page 77.

Step 2
Click the Configuration tab from the window displayed on the right.

Step 3
Expand the Passive Units sub-tab.

Step 4
To add a passive unit click the Add (+) icon and specify the following details:

- Equipment ID: Choose the unique identifier for the passive unit. You can add up to 9 passive units per device.

- Equipment Type: Choose the equipment type that determines if the slot is provisioned as a 48-channel muxponder/demuxponder or as an odd/even unit. Your options are CME, ODDE, and EVENE.

- (Optional) Serial Number: Serial number that is unique to each passive unit. Cisco EPN Manager does not deploy this configuration to the device and maintains it only in its database.

Step 5
Click Apply to deploy your changes to the device.

Step 6
(Optional) To verify successful creation of the passive units, navigate to the Interfaces tab or to the Device Details tab and use the Interface Name filter to locate the passive units.

The naming convention used for the passive units is:

PUnit<number of the card> <equipment ID of the passive unit>

For example, PUnit/1/16.

Step 7
To edit the configuration of the passive units delete them and configure the details again using the same equipment ID.

Step 8
To delete the passive units, select the required passive unit and click the Delete (X) icon. Passive units associated with links can also be deleted. This causes the links to switch to the Partial state.

Step 9
(Optional) To match multiple passive units with same values, select the required passive unit and click Match. Select the simulated passive unit number from the dropdown list and click Apply.
Step 10  (Optional) To configure manual links using these passive ports, navigate to the network topology and create the links as described in Manually Add Links to the Topology Map, on page 162.

### Edit Amplifier Module Settings on Optical Cards

You can modify the settings of amplifier modules inserted in optical slots of your device by changing the grid modes, node types, and UDC Vlan settings.

To edit the amplifier module settings:

**Before you begin**

Ensure that you have either 'Administrator' or 'Config Manager' user privilege before you perform this task.

---

**Step 1** Launch the **Chassis View** as described in Open the Chassis View, on page 77.

**Step 2** Click the **Configuration** tab from the window displayed on the right.

**Step 3** Expand the **Amplifier Module Settings** sub-tab.

**Step 4** Select the settings that you want to edit, click the Edit icon, and specify the following parameters:

- **Grid Mode**: Defines the optical spectrum on the interfaces of the amplifier module.
- **Node Type**: Defines the type of the node in which the amplifier is set to work. Your options are: Terminal, Line, and Not Set.
- **Udc Vlan**: Defines the VLAN associated to the selected slot and its UDC port.

**Note** Ensure that the Udc Vlan that you specify is unique on the device. Duplicate values are not supported.

**Step 5** Click **Apply** to deploy your changes to the device.

**Step 6** (Optional) To configure the Ethernet Controllers, expand the **Ethernet** sub-tab. Select the controller that you want to edit, click the Edit icon, and make the required changes. Click **Apply** to save the changes to the device.

---

### Configure GMPLS and WSON Properties

**GMPLS UNIs:**

The Generalized Multiprotocol Label Switching (GMPLS) User Network Interface (UNI) creates a circuit connection between two clients (UNI-C) of an optical network. This connection is achieved by signaling exchanges between UNI Client (UNI-C) and UNI Network (UNI-N) nodes, where UNI-C nodes are router nodes and UNI-N nodes are optical nodes.

GMPLS UNI is supported only on the 100G and 200G trunk ports of the Cisco NCS 1002 node. The prerequisite for the OCH trail circuit is to create a Link Management Protocol (LMP) link between the optical channel Add/Drop NCS 2000 series interface on the NCS 2000 series node and the NCS 1002 interface on the NCS 1002 node.

UNI is divided into client (UNI-C) and network (UNI-N) roles. A UNI-C network element requests and accepts circuit provisioning information. A UNI-N network element is the node adjacent to the UNI-C node and accepts and transports circuit provisioning information across the core network.
For UNI circuit provisioning, the network must meet the following requirements:

- An NE must be configured as UNI-C and connected to a UNI-N NE.
- An NE must be configured as UNI-N and connected to a UNI-C NE.

**Static UNIs:**

Link Management Protocol (LMP) is a logical link that is created on the trunk optics controller on the source and destination nodes of the tunnel. You can create static LMP links (Static UNIs) between the ports of two different devices. For example, between a Cisco NCS 2000 series node and a Cisco NCS 1002 node. This then helps configure an LMP neighbor for a GMPLS UNI tunnel.

While configuring a Static UNI using Cisco EPN Manager, the RX Port and TX Port that you choose identify the card, shelf, or slot that you want participating in the UNI. While the RX Port represents the source for the UNI, the TX Port represents the destination.

Use the Remote Device field to specify the management IP address of the selected node. Use the Remote Client Interface field to choose the LMP link IP address of the optics controller.

**Alien Wavelength:**

Use the Alien Wavelength tab to view and configure the port and wavelength parameters for the alien wavelength. You can also specify the required alien wavelength type, trunk mode and the forward error correction (FEC) mode.

**Fiber Attributes:**

You can configure the parameters used during creation of the GMPLS UNI by configuring values such as the fiber type (by choosing Dispersion-Shifted (DS), True-Wave Classic (TWC), or other values). You can also specify the fiber length and specify the Polarization Mode Dispersion fiber coefficient.

The Attenuator In value identifies the input optical attenuation in dB between the node output port (for example, a LINE-TX port) and the input parameter of the fiber. Similarly, the Attenuator Out value identifies the same between the node input port (for example, a LINE-RX port) and the output parameter of the fiber.

You can choose the Channel Spacing value that configures the minimum frequency spacing between two adjacent channels in the optical grid. To specify the maximum number of channels expected on the span use the Channel Number field. Ensure that the channel number and channel spacing values are consistent. For example, there cannot be 80 channels with 100 GHz spacing.

To configure GMPLS/WSON parameters:

**Step 1** Launch the Chassis View as described in Open the Chassis View, on page 77.

**Step 2** Click the Configuration tab from the window displayed on the right.

**Step 3** To configure these parameters, navigate to the paths described in the table below.

<table>
<thead>
<tr>
<th>Task</th>
<th>Navigation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure fiber attributes</td>
<td>GMPLS/WSON sub-tab &gt; Fiber Attributes</td>
<td>Specify the fiber side, type, length, validation, channel spacing, channel number, and domain values. You can optionally also specify the attenuator (in and out) values.</td>
</tr>
<tr>
<td>Create and edit static UNIs</td>
<td>GMPLS/WSON sub-tab &gt; Static UNIs</td>
<td>• Add the RX and TX port remote controllers that must participate in the UNI.</td>
</tr>
<tr>
<td>Task</td>
<td>Navigation</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------------</td>
<td>-----------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Create and edit GMPLS UNIs</td>
<td>GMPLS/WSON sub-tab &gt; GMPLS UNIs</td>
<td>• Specify the ingress and egress ports for the GMPLS UNI and choose if the UNI is of type numbered or unnumbered. Ensure that you specify if the UNI is of type UNI-C or UNI-N.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• The trunk values are automatically configured to the respective alien wavelength values depending on your GMPLS UNI configuration. If the configured alien wavelength is supported on both trunk ports, then setting it on one of the trunk ports automatically configures the same alien wavelength on both trunk ports.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• For Cisco NCS 2000 devices, the GMPLS UNI trunk value can be set to Default.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Specify the local and remote interface IP, and remote system IP and controller. These values enable the remote system connection for the UNI.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note: You can only specify remote system IPs of devices that are managed by Cisco EPN Manager.</td>
</tr>
<tr>
<td>Configure Alien Wavelength parameters</td>
<td>GMPLS/WSON sub-tab &gt; Alien Wavelength</td>
<td>Specify the required alien wavelength type, trunk mode and the FEC mode.</td>
</tr>
</tbody>
</table>

**Step 4** Make your changes and click **Save**.

**Step 5** To edit the values once configured, select the values and click the Edit icon in the toolbar. Make your changes and click **Save**.

For information on LMP link creation, see, Optical Channel (OCH) Trail User-to-Network Interface (UNI), on page 464.

---

**Configure Optical Cards**

- Configure Cards from the Chassis View, on page 356
- Reset a Card, on page 357
- Delete a Card, on page 356
Configure Cards from the Chassis View

This procedure adds a card to Cisco EPN Manager using the Chassis View. After adding the card, you can configure it by following the procedure in the relevant topic for that card type. Normally this is done before you physically add the card to the slot.

**Before you begin**

This feature is only supported on Cisco NCS 2000 and Cisco ONS devices.

**Step 1**
Launch the Chassis View as described in Open the Chassis View, on page 77.

**Step 2**
Select the slot to which you want to add the card by doing one of the follow:

- Select the empty slot from the physical Chassis View, then click the **Add Card** link in the slot pop-up window.
- Use the Chassis View explorer to navigate to the empty slot, hover your mouse cursor over the "i" icon next to the slot, then click the **Add Card** hyperlink in the informational popup window.

Cisco EPN Manager highlights the slot in the physical Chassis View (indicating it is pre-provisioned) and lists all of the cards that are supported by that device type.

**Note**
Make sure the card you select is appropriate for the physical slot type.

**Step 3**
Locate the card you want to add, then click **Add**. Cisco EPN Manager displays a status message after the card is added.

**Step 4**
If you want to configure the card right away, click **Configure Now** in the status popup message. Otherwise, click **Ignore**.

Delete a Card

When you delete a card, Cisco EPN Manager removes all information about the card including the card operating mode configuration associated with the card. When you add this card again at a later point of time, this information is not restored.

This feature is only supported on Cisco NCS 2000 and Cisco ONS devices.

To delete a card from Cisco EPN Manager:

**Before you begin**

Before you delete a card, make sure that:
• The associated payload values and card operating modes are deleted.
• The card does not have any active configuration running on the card (you will not be able to restore the configuration when you re-add the card).

Step 1
Launch the Chassis View as described in Open the Chassis View, on page 77.

Step 2
Select the slot from which you want to delete the card by doing one of the following:

• Select the card in the slot from the physical Chassis View, then click the Delete Card link in the pop-up window.
• Use the Chassis View explorer to navigate to the card, hover your mouse cursor over the "i" icon next to the card, then click the Delete Card hyperlink in the popup window.

Cisco EPN Manager highlights the slot in the physical Chassis View (indicating it is pre-provisioned) and once you delete all cards of a slot, the slot is left blank in the Chassis View.

After you delete a card, Cisco EPN Manager performs an inventory collection for the node.

## Reset a Card

Resetting a card repositions the card in the chassis, which is similar to performing a sync operation. Cisco EPN Manager does not modify any configuration changes, and instead saves the settings and triggers an inventory collection.

This feature is only supported on Cisco NCS 2000 and Cisco ONS devices.

To reset a configured card:

Step 1
Launch the Chassis View as described in Open the Chassis View, on page 77.

Step 2
Select the slot from which you want to delete the card by doing one of the following:

• Select the card in the slot from the physical Chassis View, then click the Reset Card link in the pop-up window.
• Use the Chassis View explorer to navigate to the card, hover your mouse cursor over the "i" icon next to the card, then click the Reset Card hyperlink in the popup window.

Cisco EPN Manager highlights the slot in the physical Chassis View (indicating it is pre-provisioned). After you reset the card, a sync is performed and inventory collection is triggered.

## What to do next

Configure the properties of the card as described in Configure cards: 400G-XP-LC, 100G-CK-C, 100ME-CK-C, 200G-CK-LC, 100GS-CK-C, 100G-LC-C, 100G-ME-C, and 10x10G-LC, on page 359.
Configure cards: OTU2-XP, MR-MXP, WSE, AR-XPE, AR-XP, AR-MXP, 40E-MXP-C, and 40ME-MXP-C

To configure card operating modes and Pluggable Port Modules (PPMs):

**Before you begin**

OTU2-XP and 40E-MXP-C cards can be configured with PPM directly without having to set the card operating mode. However, if you want to configure card operating modes for other cards you can perform this configuration directly via Cisco Transport Controller.

- Ensure that the device sync is complete and that the device's inventory collection status is 'Managed' or 'Completed'.
- Every time you add or delete a PPM, reactive inventory collection is triggered, and the device begins the sync process. Ensure that you wait for reactive inventory collection to complete before you deploy further configuration changes to the device. When the device sync is in progress, the deploy of PPM configuration changes to the device will fail.
- Once the card operating modes are configured, ensure that the device sync is completed. If not, Cisco EPN Manager will not be able to display the right Payload values for the selected cards.
- Ensure that granular inventory is enabled for all cards before performing any configuration changes on the cards.
- For all supported cards except 40E-MXP-C, 40ME-MXP-C, and OTU2-XP cards, you must first configure the card operating modes using Cisco Transport Controller and then return to Cisco EPN Manager to proceed with the following steps.

**Step 1** Choose **Configuration > Network Devices**.

**Step 2** Select the device that you want to configure by clicking the device's Name hyperlink to launch the device's Chassis view. This feature is supported only on Cisco NCS 2000 devices.

**Step 3** Use the **Chassis Explorer** to select the card that you want to configure.

**Step 4** Click the **Configuration** sub-tab from the window displayed on the right.

**Step 5** Navigate to the CTC tool and configure the operating modes for the cards. Card mode configuration is not supported on: OTU2-XP, MR-MXP, WSE, AR-XPE, AR-XP, and AR-MXP cards. For all other cards on Cisco NCS 2000 devices, configure card operating modes as described in **Configure cards: 400G-XP-LC, 100G-CK-C, 100ME-CK-C, 200G-CK-LC, 100GS-CK-C, 100G-LC-C, 100G-ME-C, and 10x10G-LC**, on page 359.

**Step 6** Expand the **Pluggable Port Modules** section to configure port modules and their respective payload values.

**Step 7** Click the ‘+’ (Add) icon in the **Port Modules** section to create port modules (PPMs).

**Step 8** Select the **PPM number** and then click **Save**. The PPM port is set to PPM (1 port) by default and cannot be modified.

**Note** The ‘+’ (Add) button is disabled when the maximum number of PPMs for the selected card are created. You must create all available ports before you can continue to the next step.

**Step 9** Click the ‘+’ (Add) icon in the **Pluggable Port Modules** section.

**Note** For some PPMs, the respective payload values may not be enabled. To enable it, complete the card mode configuration described in Step 5 above, and then try to re-configure the payload values.
Step 10 Choose the port number, port type, and number of lanes that must be associated with the selected PPM. The Port Type (payload) can be set to any supported client signals described in Table 2 below.

Note If the specified Port Type (payload) is not supported for the selected card operating mode or PPM, then the changes are not deployed to the device successfully. Ensure that the Payload values you specify, are supported on the selected card. See Table 2 below for reference.

Step 11 Click Finish to deploy your changes to the device.

Step 12 (Optional) If your changes are not visible in the Cisco EPN Manager, it could be because more than one person is working on the same card mode configuration and the changes are not reflected dynamically. Click the Refresh icon within each section to view the most recent changes.

If you encounter a deploy failure, navigate to the error logs folder /opt/CSCOlumos/logs/config.log for more details about the cause of the error.

---


To configure card operating modes and PPMs:

**Before you begin**

- Ensure that the device sync is complete and that the device's inventory collection status is 'Completed'. If the device sync is on, then the deploy of PPM configuration changes will fail.

- Card mode configuration is not supported on: OTU2-XP, MR-MXP, WSE, AR-XPE, AR-XP, and AR-MXP cards. To configure the card operating modes on these cards, please use the Cisco Transport Controller tool.

- Ensure that the device sync is complete and that the device's inventory collection status is 'Managed' or 'Completed'.

- Ensure that granular inventory is enabled for all cards before performing any configuration changes on the cards.

---

**Step 1** Choose Configuration > Network Devices.

**Step 2** Select the device that you want to configure by clicking the device's Name hyperlink to launch the device's Chassis view.

**Step 3** Use the Chassis Explorer to select the card that you want to configure.

**Step 4** Click the Configuration sub-tab from the window displayed on the right.

**Step 5** Expand the Pluggable Port Modules section to configure port modules and their respective payload values.

**Step 6** Click the ‘+’ (Add) icon in the Port Modules section to create port modules (PPMs). Select the PPM number and then click Save. The PPM Port value is set to PPM (1 port) by default and cannot be modified.
• The ‘+’ (Add) button is disabled when the maximum number of PPMs applicable for the selected card are created. You must create the required number of PPMs for the selected card before proceeding to the next step. For 100G-CK-C cards, you only need to create at least one PPM before proceeding to the next step.

• For 400G-XP-LC cards, ensure that the PPMs 11 and 12 are created before configuring the card operating modes described in the next step (although the card mode is being created for either of the trunk ports). Without PPMs 11 and 12, the configuration changes deployed to the device will fail.

• This step is optional for 100G-LC-C, 100G-CK-C, 100ME-CK-C, 100ME-C, 200G-CK-LC, and 100GS-CK-C cards.

Step 7
Expand the **Card Operating Modes** section to configure operating modes for the selected card.

Step 8
Click the ‘+’ (Add) icon to display a list of supported card operating modes or click the Edit icon to modify existing card operating modes. For 10x10G-LC cards you can add up to 5 card operating modes (10 ports that can act as sets of client or trunk ports), whereas for all other cards, only a single card operating mode can be set, after which, the + (Add) button is disabled.

Step 9
Select an operating mode from the panel on the left and make your changes to the parameters.
• Some card operating modes are disabled based on the card's peer configuration. Click on the 'i' icon next to the operating modes to understand how they can be enabled. See Table 1 below to understand the peer card configuration required to enable these operating modes.

• For MXP cards, ensure that the trunk, peer, and peer skip card configuration is in the order described below:

<table>
<thead>
<tr>
<th>Card Operating Modes</th>
<th>Trunk Card</th>
<th>Peer Card</th>
<th>Peer Skip Card</th>
</tr>
</thead>
<tbody>
<tr>
<td>MXP_200G</td>
<td>Slot 2</td>
<td>Slot 3</td>
<td>Slot 4</td>
</tr>
<tr>
<td>MXP_200G on ONS 15454 M6 devices</td>
<td>100GS-CK-LC or 200G-CK-LC card in slots 2 or 7.</td>
<td>Slots 3, 4 or 5, 6.</td>
<td>Slots 3, 4 or 5, 6.</td>
</tr>
<tr>
<td>MXP_10x10G_100G</td>
<td>Slot 7</td>
<td>Slot 6</td>
<td>Slot 5</td>
</tr>
<tr>
<td>MXP_10x10G_100G on ONS 15454 M6 devices</td>
<td>100GS-CK-LC or 200G-CK-LC card in slots 2 or 7</td>
<td>MR-MXP cards in adjacent slots 3, 4 or 5, 6.</td>
<td>MR-MXP cards in adjacent slots 3, 4 or 5, 6.</td>
</tr>
<tr>
<td>MXP_10x10G_100G on Cisco NCS 2015 devices</td>
<td>100GS-CK-LC or 200G-CK-LC card in slots 2, 7, 8, 13, or 14.</td>
<td>MR-MXP cards in adjacent slots.</td>
<td>MR-MXP cards in adjacent slots.</td>
</tr>
<tr>
<td>MXP_CK_100G on ONS 15454 M6 devices</td>
<td>100GS-CK-LC or 200G-CK-LC card and the peer MR-MXP card need to be in adjacent slots 2-3, 4-5, 6-7.</td>
<td>MR-MXP cards in adjacent slots 2-3, 4-5, 6-7, 8-9, 10-11, 12-13, 14-15.</td>
<td>MR-MXP cards in adjacent slots 2-3, 4-5, 6-7, 8-9, 10-11, 12-13, 14-15.</td>
</tr>
<tr>
<td>MXP_CK_100G on Cisco NCS 2015 devices</td>
<td>100GS-CK-LC or 200G-CK-LC card and the peer MR-MXP card need to be in adjacent slots 2-3, 4-5, 6-7, 8-9, 10-11, 12-13, 14-15.</td>
<td>MR-MXP cards in adjacent slots 2-3, 4-5, 6-7, 8-9, 10-11, 12-13, 14-15.</td>
<td>MR-MXP cards in adjacent slots 2-3, 4-5, 6-7, 8-9, 10-11, 12-13, 14-15.</td>
</tr>
</tbody>
</table>

For 400G-XP-LC cards, you can configure the OTNXC card operating mode with trunk operating mode of M-100G/M-200G. Based on the trunk operating mode, the supported slice configuration (either "Slice 1 and Slice 4" or slice 1, 2, 3, 4 respectively) are OPM-100G and OPM-10x10G.

The trunk operating mode configured on the trunk 11 reflects automatically in the trunk 12. For example, when you configure M-200G on trunk 11, the trunk operating mode for trunk 12 will be greyed out; However, M-200G will be automatically configured on trunk 12. It is possible to mix OPM_100G slices with OPM_10x10G slices, and each slice will be independent.

Step 10 Click **Save** to deploy your changes to the device.
Step 11 Expand the **Pluggable Port Modules** section to configure the payload values for each PPM.
Step 12 Click the '+' (Add) icon in the Pluggable Port Modules section.
Configure SONET and Flex Line Cards

This procedure describes how you can use Cisco EPN Manager to modify the line card configuration on 10X10G-LC SONET cards and 400G-XP, 200G-CK-LC, and 100GS-CK-LC Flex cards.

This feature is only supported on Cisco NCS 2000 and Cisco ONS devices.

To configure a SONET or Flex line card:

Before you begin

- To configure SONET line cards, ensure that you select a card with the operating mode MXP10X10G and OC192 payload value.

- To delete the SONET or Flex line card configuration, you only need to delete the payload values associated with the selected card. This deletes the SONET or Flex configuration from the device automatically. To delete the payload values, use the Pluggable Port Modes area under the configuration sub-tab.

- While configuring the SONET or Flex line card configuration, if you want to change the Line card type from SONET to SDH, or make other similar changes, you must first ensure that the admin state of the device is set to OOS-Disabled. If the device state is not OOS-Disabled, the line configuration changes deployed to the device will fail.

- To configuring Flex line card configuration, ensure that the card operating modes for the card have been previously set. See Configure cards: 400G-XP-LC, 100G-CK-C, 100ME-CK-C, 200G-CK-LC, 100GS-CK-C, 100G-LC-C, 100G-ME-C, and 10x10G-LC, on page 359.

Step 1

Launch the Chassis View as described in Open the Chassis View, on page 77.
Step 2  Select the slot from which you want to configure the card by doing one of the follow:
  • Select the card in the slot from the physical Chassis View using the zoom in and out options.
  • Use the Chassis Explorer view to navigate to the card and select it.

Step 3  Click the Configuration sub-tab from the window displayed on the right.

Step 4  Expand the Line section and choose the SONET or Flex sub-tabs.

The supported cards for SONET configuration are only 10x10G-LC cards, and for Flex cards, it is 400G-XP, 200G-CK-LC, and 100GS-CK-LC cards.

Step 5  Choose one of the following ways to edit the configuration:
  • Select the SONET or Flex tab for configuration that you want to edit and click the Edit icon.
  • Click the inline parameters that you want to edit one by one within the rows of the table.

Step 6  Make the required changes to the parameters described in the table below and click Save to deploy your changes to the device.

While configuring SONET parameters:
  • When you set the Type to SDH, the Sync Messages checkbox is automatically disabled and cannot be configured.
  • When you enabled the Sync Message checkbox, the Admin SSM option is disabled and set to null.

While configuring Flex parameters:
  • For 400G-XP-LC cards, Flex line cards can be configured only for trunk ports 11/12.
  • For 100GS-CK-LC cards, Flex line cards can be configured only for trunk port 2.
### Table 23: SONET and Flex Line Configuration Parameters and Descriptions

<table>
<thead>
<tr>
<th>Line Card Type</th>
<th>Line Card Configuration Parameters</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>SONET</strong></td>
<td>Port Number</td>
<td>The port number of the SONET interface you are configuring.</td>
</tr>
<tr>
<td></td>
<td>Port Name</td>
<td>Allows you to add a name for the SONET optical port.</td>
</tr>
<tr>
<td></td>
<td>SD BER</td>
<td>Sets the signal degrade bit error rate.</td>
</tr>
<tr>
<td></td>
<td>SF BER</td>
<td>Sets the signal fail bit error rate.</td>
</tr>
<tr>
<td></td>
<td>Type</td>
<td>Defines the port as SONET or SDH.</td>
</tr>
<tr>
<td></td>
<td>Provides Sync</td>
<td>When checked, the card is provisioned as an NE timing reference.</td>
</tr>
<tr>
<td></td>
<td>Sync Messaging</td>
<td>Enables synchronization status messages (S1 byte), which allow the node to choose the best timing source.</td>
</tr>
<tr>
<td></td>
<td>Admin SSM In</td>
<td>If the node does not receive an SSM signal, it defaults to synchronization traceability unknown (STU). Admin SSM allows you to override the STU value with one of the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• PRS—Primary reference source (Stratum 1)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• STS2—Stratum 2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• TNC—Transit node clock</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• STS3E—Stratum 3E</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• STS3—Stratum 3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• SMC—SONET minimum clock</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• ST4—Stratum 4</td>
</tr>
<tr>
<td><strong>Flex</strong></td>
<td>Port</td>
<td>The port number of the Flex interface you are configuring.</td>
</tr>
<tr>
<td></td>
<td>Gridless</td>
<td>Enables or disables the gridless tunability feature on the selected card. When the feature is enabled, you can configure the frequency values on the card. Your options are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Enabled- When selected, enables you to edit the frequency parameter for Flex.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Disabled- When selected, disables the frequency parameter for Flex.</td>
</tr>
<tr>
<td></td>
<td>Frequency</td>
<td>Specifies the frequency on the port of the 400G-XP, 200G-CK-LC, and 100GS-CK-LC cards in the range 191350 to 196100.</td>
</tr>
</tbody>
</table>
Edit and Delete Pluggable Port Modules and Card Mode Configuration

Before you begin

Pre-requisites for deleting PPMs:

- Ensure that the PPMs are not part of any Active or Provisioned circuits.
- PPMs and their respective payload values must be deleted only in the order described in the procedure below. Ensure that you first manually delete client ports 1 to 10 before deleting associated PPMs.
- Ensure that device sync is completed and the device's inventory collection status is either 'Completed' or 'Managed'.

Pre-requisite for deleting card operating modes:

- Ensure that the cards are not part of any Active or Provisioned circuits.
- For 400G-XP cards, PPMs 11 and 12 cannot be deleted. These PPMs are deleted automatically when the associated card operating mode is deleted.
- The peer card or skip card must not be in Active state. You can delete the peer or skip card associations using CTC and then retry deleting the card operating mode via Cisco EPN Manager. You can also try directly deleting the card from Cisco EPN Manager. For more information, see Delete a Card, on page 356.

Step 1
Choose Configuration > Network Devices.

Step 2
Select the device that you want to configure by clicking the device's Name hyperlink to launch the device's Chassis view.

Step 3
Use the Chassis Explorer to select the card with the configuration you want to delete.

Step 4
Click the Configuration sub-tab from the window displayed on the right.

Step 5
Expand the Pluggable Port Modules section to delete Pluggable Port Modules (PPMs).

a) In the Pluggable Port Modules sub-section, select the associated payload values that you want to delete and click the 'X' (delete) icon.
b) Click OK to confirm. The changes are deployed to the device.
c) In the Port Modules sub-section, select the PPMs that you want to delete and click the 'X' (delete) icon.
d) Click OK to confirm. The changes are deployed to the device.

Note You must delete all payload values associated with a given PPM, before you can delete the PPM.

Step 6
Expand the Card Operating Modes section to delete the card configuration.

a) To edit the card mode configuration, ensure that you select only 400G-XP cards, and click the Edit icon to make your changes. For all other cards, the configuration can be edited only by deleting the card mode configuration and re-creating it with new values.
b) To delete the card mode configuration, select the required card mode configuration and click the 'X' (delete) icon.
c) Click OK to confirm. The changes are deployed to the device.
## Cards and Supported Configuration for Cisco NCS 2000 Devices

**Table 24: 100GS-CK-LC and 200G-CK-LC Cards: Supported Configuration**

<table>
<thead>
<tr>
<th>Card Operating Modes</th>
<th>Trunk Card</th>
<th>Peer card</th>
<th>Peer Skip Card</th>
<th>Supported Payload Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>MXP_200G</td>
<td>100GS-CK-LC or 200G-CK-LC card in slots 2, 7, 8, 13, or 14.</td>
<td>MR-MXP cards in slots 3, 6, 9, 12 or 15.</td>
<td>MR-MXP cards in slots 4, 5, 10, 11 or 16.</td>
<td>100GE and OTU4 OTU4 is supported only for the 200G-CK-LC card. Regeneration of any 100 G configuration 10GE 10GE 100GE</td>
</tr>
<tr>
<td>MXP_10x10G_100G</td>
<td>100GS-CK-LC or 200G-CK-LC card in slots 2, 7, 8, 13, or 14.</td>
<td>10x10G-LC cards in slots 3, 6, 9, 12 or 15.</td>
<td>MR-MXP cards in slots 4, 5, 10, 11 or 16.</td>
<td>100GE and OTU4 OTU4 is supported only for the 200G-CK-LC card. Regeneration of any 100 G configuration 10GE 10GE 100GE</td>
</tr>
<tr>
<td>MXP_CK_100G</td>
<td>100GS-CK-LC or 200G-CK-LC card and the peer MR-MXP card need to be in adjacent slots 2-3, 4-5, 6-7, 8-9, 10-11, 12-13, 14-15.</td>
<td>N/A</td>
<td>N/A</td>
<td>100GE and OTU4 OTU4 is supported only for the 200G-CK-LC card. Regeneration of any 100 G configuration 10GE 10GE 100GE</td>
</tr>
<tr>
<td>RGN-100G</td>
<td>100GS-CK-LC or 200G-CK-LC card and the peer card 100GS-CK-LC or 200G-CK-LC need to be in adjacent slots 2-3, 4-5, 6-7, 8-9, 10-11, 12-13, 14-15.</td>
<td>N/A</td>
<td>N/A</td>
<td>100GE and OTU4 OTU4 is supported only for the 200G-CK-LC card. Regeneration of any 100 G configuration 10GE 10GE 100GE</td>
</tr>
<tr>
<td>Card Operating Modes</td>
<td>Trunk Card</td>
<td>Peer card</td>
<td>Skip Card</td>
<td>Supported Payload Types</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------</td>
<td>-----------</td>
<td>-----------</td>
<td>------------------------</td>
</tr>
<tr>
<td>TXP-100G</td>
<td>100G-CK-C/100ME-CKC</td>
<td>N/A</td>
<td>N/A</td>
<td>100GE, OTU4 — Regeneration of any 100 G configuration 40GE</td>
</tr>
<tr>
<td>RGN-100G</td>
<td>100G-CK-C/100ME-CKC card and the peer card 100G-LC-C/100G-ME-C/100G-CK-C/100ME-CKC need to be in adjacent slots 2-3, 4-5, 6-7, 8-9, 10-11, 12-13, 14-15.</td>
<td>N/A</td>
<td>N/A</td>
<td>100GE, OTU4 — Regeneration of any 100 G configuration 40GE</td>
</tr>
<tr>
<td>MXP-2x40G</td>
<td>100G-CK-C/100ME-CKC</td>
<td>N/A</td>
<td>N/A</td>
<td>100GE, OTU4 — Regeneration of any 100 G configuration 40GE</td>
</tr>
</tbody>
</table>

Table 26: 100G-LC-C and 100G-ME-C Cards: Supported Configuration

<table>
<thead>
<tr>
<th>Card Operating Modes</th>
<th>Trunk Card</th>
<th>Peer card</th>
<th>Skip Card</th>
<th>Supported Payload Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>TXP-100G</td>
<td>100G-LC-C/100G-ME-C</td>
<td>N/A</td>
<td>N/A</td>
<td>100GE, OTU4 — Regeneration of any 100 G configuration 40GE</td>
</tr>
<tr>
<td>RGN-100G</td>
<td>100G-LC-C/100G-ME-C card and the peer card 100G-LC-C/100G-ME-C/100G-CK-C/100ME-CKC need to be in adjacent slots 2-3, 4-5, 6-7, 8-9, 10-11, 12-13, 14-15.</td>
<td>N/A</td>
<td>N/A</td>
<td>100GE, OTU4 — Regeneration of any 100 G configuration 40GE</td>
</tr>
<tr>
<td>Card Operating Modes</td>
<td>Trunk Card</td>
<td>Peer card</td>
<td>Skip Card</td>
<td>Supported Payload Types</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------</td>
<td>-----------</td>
<td>-----------</td>
<td>-------------------------</td>
</tr>
</tbody>
</table>
| TXPP-10G             | 10x10G-LC  | N/A       | N/A       | OC192/STM-64, 10GE-LAN Phy, 10GE-WAN Phy (using OC192), OTU2, OTU2e, 8G FC, 10G FC, FICON  
Only OC192/STM64 and 10GE are supported when the 10x10G-LC card is connected with the 100GS-CK-LC card.  
Only OC192/STM64, 10GE, and OTU2 are supported when the 10x10G-LC card is connected with the 200G-CK-LC card.  
10GE-LAN Phy, OTU2  
10GE-LAN Phy, OTU2e, OTU2, OC192/STM-64, 8G FC, 10G FC, IB_5G  
10GE, 10G FC  
10GE  
10GE, OTU2e |
| TXP-10G              | 10x10G-LC  | N/A       | N/A       | OC192/STM-64, 10GE-LAN Phy, 10GE-WAN Phy (using OC192), OTU2, OTU2e, 8G FC, 10G FC, FICON  
Only OC192/STM64 and 10GE are supported when the 10x10G-LC card is connected with the 100GS-CK-LC card.  
Only OC192/STM64, 10GE, and OTU2 are supported when the 10x10G-LC card is connected with the 200G-CK-LC card.  
10GE-LAN Phy, OTU2  
10GE-LAN Phy, OTU2e, OTU2, OC192/STM-64, 8G FC, 10G FC, IB_5G  
10GE, 10G FC  
10GE  
10GE, OTU2e |
<table>
<thead>
<tr>
<th>Card Type</th>
<th>10x10G-LC Configuration</th>
<th>Modules Supported</th>
</tr>
</thead>
<tbody>
<tr>
<td>MXP-10x10G</td>
<td>10x10G-LC card and the peer 100G-LC-C, 100G-ME-C, 100G-CK-C, 100ME-CKC, 100GS-CK-LC or 200G-CK-LC card need to be in adjacent slots 2-3, 4-5, 6-7, 8-9, 10-11, 12-13, 14-15.</td>
<td>OC192/STM-64, 10GE-LAN Phy, 10GE-WAN Phy (using OC192), OTU2, OTU2e, 8G FC, 10G FC, FICON Only OC192/STM64 and 10GE are supported when the 10x10G-LC card is connected with the 100GS-CK-LC card. Only OC192/STM64, 10GE, and OTU2 are supported when the 10x10G-LC card is connected with the 200G-CK-LC card. 10GE-LAN Phy, OTU2 10GE-LAN Phy, OTU2e, OTU2, OC192/STM-64, 8G FC, 10G FC, IB_5G 10GE, 10G FC 10GE, OTU2e</td>
</tr>
<tr>
<td>RGN-10G</td>
<td>10x10G-LC</td>
<td>OC192/STM-64, 10GE-LAN Phy, 10GE-WAN Phy (using OC192), OTU2, OTU2e, 8G FC, 10G FC, FICON Only OC192/STM64 and 10GE are supported when the 10x10G-LC card is connected with the 100GS-CK-LC card. Only OC192/STM64, 10GE, and OTU2 are supported when the 10x10G-LC card is connected with the 200G-CK-LC card. 10GE-LAN Phy, OTU2 10GE-LAN Phy, OTU2e, OTU2, OC192/STM-64, 8G FC, 10G FC, IB_5G 10GE, 10G FC 10GE, OTU2e</td>
</tr>
<tr>
<td>LOW - LATENCY</td>
<td>10x10G-LC</td>
<td>N/A</td>
</tr>
</tbody>
</table>
OC192/STM-64, 10GE-LAN Phy, 10GE-WAN Phy (using OC192), OTU2, OTU2e, 8G FC, 10G FC, FICON

Only OC192/STM64 and 10GE are supported when the 10x10G-LC card is connected with the 100GS-CK-LC card.

Only OC192/STM64, 10GE, and OTU2 are supported when the 10x10G-LC card is connected with the 200G-CK-LC card.

10GE-LAN Phy, OTU2
10GE-LAN Phy, OTU2e, OTU2, OC192/STM-64, 8G FC, 10G FC, IB_5G
10GE, 10G FC
10GE
10GE, OTU2e

400G-XP-LC and MR-MXP cards of Cisco NCS 2000 devices can be configured with the following card operating mode and payload values:

- Payload types OTU2/OC192 are supported on MR-MXP cards,
- Payload types 16G-FC/OTU2 are supported on 400G-XP-LC cards,
- Slice operational mode OPM_6x16G_LC is supported on 400G-XP-LC cards.

---

## Discover and Configure MPLS LDP and MPLS-TE Links

Using Cisco EPN Manager you can configure Label Distribution Protocol (LDP) and MPLS-TE links in an MPLS network.

**MPLS LDP**

LDP provides a standard methodology for hop-by-hop (or dynamic label) distribution in an MPLS network by assigning labels to routes that have been chosen by the underlying IGP routing protocols. The resulting labeled paths, called label switch paths (LSPs), forward labeled traffic across an MPLS backbone. Cisco EPN Manager enables you to configure the potential peers and establish LDP sessions with those peers to exchange information.

To configure LDP using Cisco EPN Manager you need to know the network address and interface of the device on which the LDP links must be configured and also subnet mask for the configured IP addresses.

*Note* Before configuring MPLS LDP, ensure that the LDP ID is pre-configured on the device.

**MPLS-TE**

Cisco EPN Manager supports the provisioning of MPLS Traffic Engineering (MPLS-TE) services. MPLS-TE enables an MPLS backbone to replicate and expand the TE capabilities of Layer 2 over Layer 3. MPLS TE
uses Resource Reservation Protocol (RSVP) to establish and maintain label-switched path (LSP) across the backbone. For more information, see, Supported MPLS Traffic Engineering Services, on page 470.

To configure LDP and MPLS-TE parameters:

Step 1  Choose **Configuration > Network Devices**.

Step 2  Select the device that you want to configure by clicking the device hyperlink to launch its Device Details page.

Step 3  Click the **Configuration** tab, then click the **Logical View** left side tab.

Step 4  To configure LDP links:

a)  Choose **MPLS > LDP**, click on **Common Properties** tab and and click ‘+’ to specify new LDP parameters. To edit existing parameters, click the LDP Address hyperlink and click the Edit icon at the top right corner of the page.

   **Note**  You can only add a single set of LDP settings per device.

b)  Under the **Common Properties** tab, specify the LDP parameters described in the below table.

<table>
<thead>
<tr>
<th>MPLS LDP Fields</th>
<th>Field Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>LDP Interface</td>
<td>Choose the LDP interface that is the source loopback interface for the LDP session on the device.</td>
</tr>
<tr>
<td>LDP Address</td>
<td>Specify the IP address of the LDP interface. Once the LDP address is set, it cannot be edited. To change the LDP address, delete the LDP session and create a new session with the new LDP address.</td>
</tr>
<tr>
<td>Session Hold Time</td>
<td>(Optional) Enter the time, in seconds, that the LDP session will go down if no hellos have been received after the Hold timer expires. Range is 15 to 65535.</td>
</tr>
<tr>
<td>Discovery Hold time and Discovery Target Hold time</td>
<td>(Optional) Enter the time, in seconds, an LDP source and a discovered LDP neighbor is remembered without receipt of an LDP hello message from the neighbor. Range is 1 to 65535.</td>
</tr>
<tr>
<td>Discovery Hold Interval and Discovery Target Hold Interval</td>
<td>(Optional) Enter the time duration, in seconds, during which a LDP source and a discovered LDP neighbor is remembered. Range is 1 to 65535.</td>
</tr>
<tr>
<td>DownStream Min Label and DownStream Max Label</td>
<td>(Optional) Enter the minimum and maximum number of hops permitted in an LSP established by the Downstream on Demand method of label distribution. Range is 16 to 32767.</td>
</tr>
<tr>
<td>DownStream Max Hop Count</td>
<td>(Optional) Enter the number of hops permitted in an LSP established by the Downstream on Demand method of label distribution. Range is 1 to 255.</td>
</tr>
<tr>
<td>IGP Hold Down Time</td>
<td>(Optional) Enter the time, in seconds, to specify the time for which the declaration of LDP sync state is delayed after session establishment upon link coming up. Range is 1 to 2147483647.</td>
</tr>
<tr>
<td>Explicit Null Enabled</td>
<td>(Optional) Enable this value to advertise explicit-null labels for the directly connected route. Values are Yes (enabled) or No (disabled).</td>
</tr>
<tr>
<td>Initial Back Off and Max Back Off</td>
<td>(Optional) Enter the initial and maximum back off delay value in seconds. Range is 5 to 2147483.</td>
</tr>
</tbody>
</table>
Choose true or false to either enable or disable LDP nonstop routing (NSR). Enabling NSR allows the LDP to continue to operate across a node failure without losing peer sessions.

Choose true or false to either enable or disable the MPLS LDP Entropy Label support feature which helps improve load balancing across MPLS networks using entropy labels.

c) Click **Save** to deploy your changes to the device.
d) Click on **Interfaces** tab and and click '+' to specify the Interface parameters.

<table>
<thead>
<tr>
<th>MPLS LDP Fields</th>
<th>Field Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>NSR Enabled</td>
<td>Choose true or false to either enable or disable LDP nonstop routing (NSR). Enabling NSR allows the LDP to continue to operate across a node failure without losing peer sessions.</td>
</tr>
<tr>
<td>Entropy Enabled</td>
<td>Choose true or false to either enable or disable the MPLS LDP Entropy Label support feature which helps improve load balancing across MPLS networks using entropy labels.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>MPLS LDP Fields</th>
<th>Field Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interface Name</td>
<td>Specify the name of Interface to participate in the LDP session.</td>
</tr>
<tr>
<td>Label Distribution Method</td>
<td>Specify 'LDP' as the Label Distribution Method</td>
</tr>
<tr>
<td>Hello Interval</td>
<td>(Optional) Enter the time interval, in seconds, when hello messages will be sent. Range is 1 to 65535.</td>
</tr>
</tbody>
</table>

e) Click **Save** to deploy your changes to the device. The same properties are configured on the peer devices. Once the neighbor devices are formed, the details are populated in the **Neighbors** tab.

**Step 5**

To configure MPLS-TE links:
a) Choose **MPLS > MPLS-TE** .
b) In the MPLS-TE FRR area, check the **MPLS TE Tunnel Enabled** check box. The default values of MPLS-TE parameters are displayed as described in the below table.

<table>
<thead>
<tr>
<th>MPLS TE Tunnel Fields</th>
<th>Field Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>MPLS TE Tunnel Enabled</td>
<td>Activates the display of the list of automatic bandwidth enabled tunnels, and indicates if the current signaled bandwidth of the tunnel is identical to the bandwidth that is applied by the automatic bandwidth</td>
</tr>
<tr>
<td>Auto Bandwidth Timer Frequency (Sec)</td>
<td>To set the interval (in seconds) at which the automatic bandwidth on a tunnel interface is triggered.</td>
</tr>
<tr>
<td>Reoptimize Timer Frequency (Sec)</td>
<td>Set the value (in seconds) to trigger the reoptimization interval of all TE tunnels.</td>
</tr>
<tr>
<td>Auto Backup Tunnel Enabled</td>
<td>To display information about automatically built MPLS-TE backup tunnels.</td>
</tr>
<tr>
<td>Backup Tunnel Min. Range and Backup Tunnel Max. Range</td>
<td>Configures the range of backup autotunnel numbers to be between the specified minimum and maximum value. Ensure that minimum range for the backup tunnel is lower than the maximum range.</td>
</tr>
<tr>
<td>SRLG Exclude</td>
<td>Specifies an IP address to get SRLG values from, for exclusion. Choose one of the following options, if required:</td>
</tr>
<tr>
<td></td>
<td>• Preferred</td>
</tr>
<tr>
<td></td>
<td>• Forced</td>
</tr>
</tbody>
</table>
Analyze Ports Using SPAN and RSPAN

Using Cisco EPN Manager, you can analyze network traffic passing through ports or VLANs by using SPAN or RSPAN to send a copy of the traffic to another port on the switch or to a monitoring device. SPAN copies (or mirrors) traffic received or sent (or both) on source ports or source VLANs to a destination port for analysis. Traffic that enters or leaves source ports or traffic that enters or leaves source VLANs are monitored.

If you configure SPAN to monitor incoming traffic, then traffic that gets routed from another VLAN to the source VLAN cannot be monitored. However, traffic that is received on the source VLAN and routed to another VLAN can be monitored.

Cisco EPN Manager allows you to configure only one Local SPAN session per device. Local SPAN sessions copy traffic from one or more source ports in any VLAN to a destination port for analysis.

Using Remote SPAN you can configure source ports, source VLANs, and destination ports on different switches, enabling remote monitoring of multiple switches across your network. The traffic for each RSPAN session is carried over a user-specified RSPAN VLAN that is dedicated for that RSPAN session in all participating switches. The RSPAN traffic from the source ports or VLANs is copied into the RSPAN VLAN and forwarded over trunk ports carrying the RSPAN VLAN to a destination session monitoring the RSPAN VLAN.

Note

To monitor ports, you must ensure that the ports are associated with one or more VLANs (source or destination).
To enable port monitoring (or mirroring):

**Step 1**  Choose **Configuration > Network Devices**.

**Step 2**  Select the device that you want to configure by clicking the device hyperlink to launch its Device Details page.

**Step 3**  Click the **Configuration** tab, then click the **Logical View** left side tab.

**Step 4**  Configure an RSPAN session:

a) Choose **Port Analyzer > RSPAN > Destination Node** to configure the destination node for RSPAN.

b) Click ‘+’ to specify the RSPAN session ID. To edit existing settings, click the session ID hyperlink and click the Edit icon at the top right corner of the page.

   You can add up to 14 RSPAN and SPAN sessions.

c) Choose a session ID and click **Save**.

   The session type Remote Destination (Remote RSPAN) is set by default and cannot be edited.

d) Click the session ID hyperlink to specify the source and destination settings for the destination node.

e) Click the **Source Settings** tab, choose a valid VLAN ID (auto populated based on the VLANs configured on the selected device), and click **Save**.

   You can add only a single VLAN as the source for the destination node. If no VLANs are configured, you need to configure them and return to this step. See **Configure VLAN Interfaces**, on page 322.

f) Click the **Destination Settings** tab, select the interface that must act as the destination node for the RSPAN, and click **Save**.

   a) From the features panel, choose **Port Analyzer > RSPAN > Source Node** to configure the source node for RSPAN.

   b) Click ‘+’ to specify common RSPAN source node settings. To edit existing settings, click the session ID hyperlink and click the Edit icon at the top right corner of the page.

   c) Choose a session ID and click **Save**.

      The session type Remote Source (Remote SPAN) is set by default and cannot be edited.

   d) Click the session ID hyperlink to specify the source and destination settings for the source node.

   e) Click the **Source Settings** tab, specify the following values, and click **Save**.

      i) In the **Interface** drop-down menu, choose the interface that will act as the source interface for the RSPAN source node.

      An interface specified as a source node for RSPAN can also be used as the source/destination node for SPAN.

      ii) In the **Direction** drop-down menu, choose direction in which the interface must be applied to the RSPAN source node. Your options are:

      - **Transmit**: monitors all packets sent by the source interface after all modification and processing is performed by the switch. A copy of each packet sent by the source is sent to the destination port for that session. The copy is provided after the packet is modified.

      - **Receive**: monitors all packets received by the source interface or VLAN before any modification or processing is performed by the switch. A copy of each packet received by the source is sent to the destination port for that session.

      - **Both**: (default value) monitors a port or VLAN for both received and sent packets.

   You can add multiple interfaces to the source node for RSPAN and then associate a single VLAN ID to these interfaces.
f) Click the **Destination Settings** tab, choose a valid VLAN ID (auto populated based on the VLANs configured on the selected device), and click **Save**.

**Step 5** Configure a SPAN session:

a) Click **Port Analyzer > SPAN**.

b) Click the ‘+’ to specify common SPAN source node settings. To edit existing settings, click the session ID hyperlink and click the Edit icon at the top right corner of the page.

Interfaces configured as the source and destination node for RSPAN, cannot be used for SPAN.

c) Choose a session ID and click **Save**.

The session type Local (Local SPAN) is set by default and cannot be edited.

d) Click the session ID hyperlink to specify the source and destination settings for SPAN.

e) Click the **Source Settings** tab, and choose the interface and direction in which the interface must be applied for SPAN, and click **Save**. For more details, see Step 4.

An interface specified as a source node for RSPAN can also be used as the source/destination node for SPAN.

f) Click the **Destination Settings** tab, choose a valid VLAN ID (auto populated based on the VLANs configured on the selected device), and click **Save**.

g) (Optional) To verify that your changes were configured correctly, use the following command in your device CLI:

```
show monitor session all
```

---

**Configure and View Ethernet Link Aggregation Groups**

An Ethernet Link Aggregation Group (LAG) is a group of one or more ports that are aggregated together and treated as a single link. Each bundle has a single MAC, a single IP address, and a single configuration set (such as ACLs). LAGs provide the ability to treat multiple switch ports as one switch port. The port groups act as a single logical port for high-bandwidth connections between two network elements. A single link aggregation group balances the traffic load across the links in the channel. LAGs help provision services with two links. If one of the links fails, traffic is moved to the other link.

The following figure illustrated a LAG created between two devices: Device A and Device B.
Cisco EPN Manager allows you to view and manage LAGs in the following ways:

- Create Link Aggregation Groups (LAG) Using Multiple Interfaces, on page 376
- View Ethernet LAG Properties, on page 377

Create Link Aggregation Groups (LAG) Using Multiple Interfaces

Using Cisco EPN Manager, you can create LAGs that provide the ability to treat multiple physical switch ports as a single logical one.

Before you begin

- Only interfaces that are not already part of an existing LAG can be selected. An interface cannot be part of more than one LAG.
- The selected group of interfaces must all consist of the same bandwidth type.
- Inventory collection status for the devices that participate in the LAG must be Completed.

To create a LAG:

Step 1  Choose Configuration > Network Devices.

Step 2  Click the device hyperlink to launch its Device Details page.

Step 3  Click the Configuration tab, then click the Logical View left side tab.

Step 4  Choose Interfaces > Link Aggregation.

Step 5  Depending on the type of control method that you want to use, click the PAgP or the LACP tab.

Step 6  To create a new LAG, click the Add (+) sign.

Step 7  Enter a unique name for the LAG. Ensure that the channel group ID that you specify is part of the LAG name. For example, for a channel group ID of 10, your LAG name should be:

- ‘Bundle-Ether10’ for Cisco IOS-XR devices.
• 'Port-channel10' for Cisco IOS, Cisco ME3600, and Cisco ME3800 devices.

Step 8
Enter a number between 1 to 16 to specify the Channel Group ID. The channel group ID ranges for different types of devices is: 1-8 for Cisco ASR 90X devices, 1-64 for Cisco ASR 920X devices, 1-26 for Cisco ME3x00 devices, 1-48 for Cisco NCS42xx devices, and 1-65535 for Cisco ASR9000 devices.

Step 9
Click the Member Port Settings tab to specify the member port values:

• LACP Modes: LACP can be configured with the following modes:
  • Active- In this mode, the ports send LACP packets at regular intervals to the partner ports.
  • Passive- In this mode, the ports do not send LACP packets until the partner port sends LACP packets. After receiving LACP packets from the partner port, the ports then send LACP packets to the partner port.

  • PAgP Modes: PAgP modes can be configured with AUTO, DESIRABLE, or ON. For ASR9K devices, only On PAgP mode is enabled. ON implies that the mode is set to PAgP - manual.

Step 10
Click Save.
Your changes are saved and you can now add interfaces to the created LAG.

Step 11
To add interfaces to the created LAG, select the required channel group from the Link Aggregation table and click the Edit icon.

Step 12
Select the interfaces you want to use to create the LAG.

Step 13
Click Save.
The LAG is created using the interfaces you selected.

View Ethernet LAG Properties

You can view properties for Ethernet LAGs in the following ways:

• Using the Device Configuration tab:
  1. Go to Network Devices > Device Properties > Configuration tab.
  2. Select the device on which you want to configure the LAG by clicking the device name hyperlink.
  3. Click the Configuration tab, then click the Logical View left side tab.
  4. Click Interfaces > Link Aggregation in the Features panel.

• Using the Device Details tab:
  1. Go to Network Devices > Device Properties.
  2. Select the device on which you want to configure the LAG by clicking the device name hyperlink.
  3. Click the Device Details tab.
  4. Click Interfaces > Ether Channel in the Features panel.
Configure Routing Protocols and Security

Using Cisco EPN Manager, you can configure the following routing protocols for your CE and Optical devices. You can also configure security for your devices using ACLs.

Before you configure routing protocols and ACLs, ensure that the device's Inventory Collection status is 'Completed'.

To view a device's routing table, open the Device 360 view and choose Actions > Routing Table Info > All.

- Configure BGP, on page 378
- Configure an IS-IS, on page 381
- Configure OSPF, on page 383
- Configure Static Routing, on page 385
- Configure ACLs, on page 385

Configure BGP

Border Gateway Protocol (BGP) is a standardized exterior gateway protocol designed to exchange routing and reachability information between autonomous systems (AS) in your network. By configuring BGP, your device is enabled to make routing decisions based on paths, network policies, or rule-sets configured by a network administrator.

Using the Cisco EPN Manager, you can configure BGP routing and establish a BGP routing process by specifying the AS number and Router ID. You can then create a BGP neighbor which places the router in neighbor configuration mode for BGP routing and configures the neighbor IP address as a BGP peer. To configure the BGP neighbor, you need to provide the neighbor's IPv4 address and its peer AS number. BGP neighbors should be configured as part of BGP routing. To enable BGP routing, at least one neighbor and at least one address family must be pre-configured.

To view a device's BGP and BGP Neighbors routing table, open the Device 360 view, then choose Actions > Routing Table Info.

To configure BGP routing protocol on a device:

---

**Step 1** Choose Configuration > Network Devices.

**Step 2** Select the required device by clicking the device name hyperlink.

**Step 3** Click the Configuration tab, then click the Logical View left side tab.

**Step 4** Choose Routing > BGP.

**Note** The configuration changes on Cisco Catalyst 6500 Series devices with a quad-supervisor Virtual Switching System (VSS) are not dynamically reflected on this page. To view these changes, ensure that the 24 hour periodic device sync is completed. Alternatively, you can manually sync these devices with Cisco EPN Manager.

**Step 5** To configure the BGP routing process, click the + icon or if BGP is already configured, click the AS number hyperlink and then click the Edit icon to enter the BGP Process details described in the table below.
Step 6
Click Save to deploy your changes to the device and to enable the BGP Address Family and BGP Neighbor tabs.

Step 7
To configure the BGP address family details, click the BGP Address Family tab and choose the address family details described in the table below, and click Save.

Step 8
To configure the BGP neighbor, click the BGP Neighbor tab and choose the neighbor device by selecting the device's IP address from the list.

Step 9
To create a new BGP neighbor, click the Add (+) icon, specify the following details described in the table below.

Step 10
Click Save. The updated BGP routing process values are saved and deployed to the selected device.

To verify that your changes were saved, go to Configuration > Network Devices, launch the Device Details page, and click the Logical View tab. Choose Routing > BGP. You can view your BGP configuration details such as the Neighbor Address, Remote AS, Address Family Type and Modifier, and Advertise Interval Time configured on the device.

<table>
<thead>
<tr>
<th>Fields</th>
<th>Sub-field</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Common BGP Process fields</td>
<td>AS Number</td>
<td>Enter the AS number using a numeric value from 1 to 4294967295.</td>
</tr>
<tr>
<td></td>
<td>Router ID</td>
<td>• Enter the Router ID. The value can be an IPv4 address of the format:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• A.B.C.D- for IPv4 addresses, where A, B, C, and D are integers ranging from</td>
</tr>
<tr>
<td></td>
<td></td>
<td>0 to 255.</td>
</tr>
<tr>
<td>Log Neighbor Changes</td>
<td></td>
<td>Select to track neighbor router changes.</td>
</tr>
<tr>
<td>BGP Address Family fields</td>
<td>BGP Global AF</td>
<td>• Address Family: Enter the BGP address family prefixes for the routing process. Your options are IPv4 and IPv6 (for unicast, multicast, and MVPN), VPNv4 and VPNv6 (for unicast), and IPv4 (for MDT).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Allocate Label: Choose the labeled unicast address prefixes.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Allocate Label Custom Policy Name: Choose a custom policy to be associated with the routing process.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Specify the details for the paths that enable the advertisement of multiple paths through the same peering session for the same prefix without the new paths implicitly replacing any previous paths.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Additional Paths: Choose whether the device must send, receive, or send and receive additional paths. This is done at the address family level or the neighbor level. During session establishment, the specified BGP neighbors negotiate the Additional Path capabilities (whether they can send and/or receive) between them.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note While configuring Cisco CAT65000 devices, you can configure only Install as the additional path value.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Best Value: This field is enabled only when the Additional Paths value that you choose supports the configuration of the Best Value field.</td>
</tr>
</tbody>
</table>
### Configure Devices

<table>
<thead>
<tr>
<th>Fields</th>
<th>Sub-field</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>BGP Neighbor AF</strong></td>
<td></td>
<td>Specify the address family details that the specified BGP neighbor belongs to:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Neighbor Address: Choose the Router ID of the neighboring router. These values are populated based on the BGP neighbors created in the Neighbor tab. The value can be an IPv4 or an IPv6 address of the format:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• A.B.C.D - for IPv4 addresses, where A, B, C, and D are integers ranging from 0 to 255.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx - for IPv6 addresses, where x would be a hexadecimal value and where the address uses eight sets of four hexadecimal addresses (16 bits in each set), separated by a colon (:).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Send Label: Choose the type of label that must be associated with the neighbor.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Route Reflector Client: Enable this field to configure the router as the route reflector and the specified neighbor as its client.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• AIGP: Select to enable the accumulated interior gateway protocol (AIGP) path attribute.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Send Community: Choose how the community attributes must be sent to an external Border Gateway Protocol (eBGP) neighbor.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Next Hop Self: Select to set the BGP next-hop attribute of routes being advertised over a peering session to the local source address of the session.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Incoming and Outgoing Route Map Name: Choose to indicate whether a route policy must be applied to inbound or outbound updates from the neighbor.</td>
</tr>
<tr>
<td><strong>BGP Network Mask</strong></td>
<td></td>
<td>• Network Address and Mask: Specify the network IP address and network mask for the specified IP address.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Back Door Route: Enable to set the administrative distance on an external Border Gateway Protocol (eBGP) route to that of a locally sourced BGP route, causing it to be less preferred than an Interior Gateway Protocol (IGP) route.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Network Route Policy Name: Choose the route policy that will be used to select prefixes for label allocation. This enables BGP to allocate labels for all or a filtered set of global routes (as dictated by the route policy).</td>
</tr>
<tr>
<td><strong>BGP Neighbor tab fields</strong></td>
<td></td>
<td>Specify the following values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Peer AS Number- Enter the value for the autonomous system number using integers in the range 1 to 4294967295.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Neighbor Address- Enter the IP address of the BGP neighbor that you want to configure. The value can be an IPv4 or an IPv6 address of the format</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• A.B.C.D - for IPv4 addresses, where A, B, C, and D are integers ranging from 0 to 255.</td>
</tr>
<tr>
<td>Fields</td>
<td>Sub-field</td>
<td>Descriptions</td>
</tr>
<tr>
<td>--------</td>
<td>-----------</td>
<td>--------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx - for IPv6 addresses, where x would be a hexadecimal value and where the address uses eight sets of four hexadecimal addresses (16 bits in each set), separated by a colon (:).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Local AS Number and Action: Specifies an autonomous-system number to prepend to the AS_PATH attribute. The range of values is any valid autonomous system number from 1 to 65535.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Update Source: Use this option to establish a peer relationship (TCP connection) using the loopback interface as an alternative instead of using the interface closest to the peer router.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Fall-over: Select a value to enable the BGP fast peering session deactivation for improving the convergence and response time to adjacency changes with the specified BGP neighbor.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Password Encryption and Password: Specify whether password encryption is enabled or not, and if enabled, what the password value is.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• (View only) Neighbor State: View the connection status of a neighbor device participating in a BGP routing process. The states are: Idle, Connect, Active, Opensent, Openconfirm, and Established.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The neighbor device generates events only when its connection status is Established. Please check the connection status frequently in case there are updates from the device.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Note</strong> The neighbor state value is not updated during a granular inventory sync. To see the updated values, wait for the sync to end successfully.</td>
</tr>
</tbody>
</table>

**Configure an IS-IS**

Intermediate System-to-Intermediate System (IS-IS) Protocol is an intra-domain OSI dynamic routing protocol which uses a two-level hierarchy to support large routing domains (administratively divided into areas). Routing within an area is referred to as Level 1 routing. Routing between areas is referred to as Level 2 routing. In order to enable IS-IS for IP on a Cisco router and have it exchange routing information with other IS-IS enabled routers, you must perform the following tasks:

- Enable the IS-IS routing process on the device and assign areas.
- Enable IS-IS IP routing on the required interfaces.

An interface with a valid IP address can be designated to act as a Level 1 (intra-area) router, a Level 1_2 (both a Level 1 router and a Level 2) router, or a Level 2 (an inter-area only) routing interface for a given IS-IS instance. After the IS-IS routing starts working across the routers between the designated interfaces, the IS-IS neighborhood is automatically generated.
To enable IS-IS routing, at least one address family must be configured by default. In this release, configuring address families cannot be done using Cisco EPN Manager.

Note
To configure the IS-IS process on a device:

Step 1
Choose **Configuration** > **Network Devices**.

Step 2
Select the device on which you want to configure the IS-IS routing protocol by clicking the device name hyperlink.

Step 3
Click the **Configuration** tab, then click the **Logical View** left side tab.

Step 4
Choose **Routing** > **IS-IS**.

Step 5
To configure a new IS-IS process, click the '+' icon and enter the following parameters:

- Specify the **IS-IS Process ID** using alphanumeric characters only. No spaces or special characters are allowed.
- Specify the **NET ID** in NSAP format. For example, your NET ID can be 49.0001.0000.0001.0010.00, where:
  - 49 - represents the first portion of the area ID which represents the AFI (Authority and Format Indicator).
  - 0001 - represents the second portion of the area ID.
  - 0000.0001.0010 - represents the system ID.
  - 00 - represents the N-selector which is always 0.
- Specify the type of IS-IS routing protocol in the **IS-IS Type** field. Your options are: Level 1, Level 2, and Level 1_2.

Step 6
Click **Save**.

Step 7
To configure this routing process on the selected device's interfaces:

a) Select the IS-IS protocol process created in the above steps from the **Routing** > **IS-IS** list.
b) Click the IS-IS process ID hyperlink.
c) Use the **IS-IS Interfaces** tab to specify the interfaces of the device on which the selected IS-IS configuration is to be applied:
   - Click the '+' icon to enter the interface details.
   - From the **Circuit Type** drop-down menu, select the type of circuit to which this configuration is to be applied. Your options are: Level 1, Level 2, and Level 1_2.
   - From the **Interface** drop-down menu, select the required interfaces.
   - (Optional) Specify the Level 1 and Level 2 metric and priority values. For the **Priority** field enter a value between 1 to 127 and for the **Metric**, a value between 1 to 16777214.
   - Enable the **Point-to-Point** checkbox to enable point to point connection.
   - Click **Save** to deploy the configuration onto the selected interfaces.

Step 8
Click **Save**. The selected IS-IS process is configured on the specified interfaces of the device.
Step 9  (Optional) To view IS-IS neighbors associated with the selected device, click the IS-IS hyperlink and click the IS-IS Neighbors tab. You can view the configured neighbor's hostnames, IP addresses, system IDs, IS-IS types, their connection states, the configured hold down time values, and the local interface names.

**Note** If the hostnames of the IS-IS neighbors are greater than 15 unique characters, the hostnames are not displayed in Cisco EPN Manager. Ensure that the hostnames are not more than 15 unique characters.

Step 10  (Optional) To delete IS-IS routing processes configured using Cisco EPN Manager:

a) Go to Configuration > Network Devices, launch the Device Details page, and choose Routing > IS-IS.
b) Select the required IS-IS process from the list.
c) Click the 'x' icon to delete and click OK to confirm the delete operation.

---

**Configure OSPF**

Open Shortest Path First (OSPF) is a standards-based routing protocol that uses the Shortest Path First (SPF) algorithm to determine the best route to its destination. OSPF sends Link State Advertisements (LSAs) to all routers within the same configured area. OSPF sends routing updates only for the changes in the routing table; it does not send the entire routing table at regular intervals.

Using Cisco EPN Manager you can configure OSPF for IPv4 and IPv6 addresses. To do this, ensure that you know the router ID, the administrative distance that you want to configure on the router, and the maximum path values to be set.

To configure the OSPF routing process:

**Step 1** Choose Configuration > Network Devices.

**Step 2** Select the device on which you want to enable OSPF by clicking the device name hyperlink. Select only IOS-XR devices.

**Step 3** Click the Configuration tab, then click the Logical View left side tab.

**Step 4** Choose Routing > OSPF.

**Note** The configuration changes on Cisco Catalyst 6500 Series devices with a quad-supervisor Virtual Switching System (VSS) are not dynamically reflected on this page. To view these changes, ensure that the 24 hour periodic device sync is completed. Alternatively, you can manually sync these devices with Cisco EPN Manager.

**Step 5** To add a new OSPF process, click the + sign. To modify existing OSPF processes, select the required process by clicking the process ID hyperlink and click the Edit icon at the top right corner of the page.

**Step 6** Specify the common OSPF parameters as described in the table below.

**Step 7** Click Save. Your configuration changes are saved. To verify, click the Configuration tab, choose Routing > OSPF, and view the displayed details.

**Step 8** Specify the OSPF Interfaces settings:

Once you have configured the OSPF process with basic properties, you can further deploy that configuration directly on an entire network or on an OSPF area. To do this, you need to specify the OSPF area ID, the device's interface details, the network type, etc. To change OSPF interface settings:

a) Choose Configuration > Network Devices.

b) Select the device on which you want to configure these changes by clicking the device name hyperlink.
c) Click the **Configuration** tab and choose **Routing > OSPF**.
d) Select the required process by clicking the process ID hyperlink.
e) Click the **OSPF Interfaces** tab.
f) Click the Add (‘+’) icon to add new settings to the interfaces associated with the selected device's OSPF process. To edit existing values, click the Interface Name hyperlink and click the Edit icon at the top right of the page.
g) Specify the parameters as explained in the table below.
h) Click **Save** to deploy your changes to the device.

---

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>OSPF Common Properties</strong></td>
<td>Description</td>
</tr>
<tr>
<td>Process ID</td>
<td>Unique numerical value between 1 and 65535 that identifies the selected OSPF process.</td>
</tr>
<tr>
<td>Router ID</td>
<td>Router ID of the Area 0 router.</td>
</tr>
<tr>
<td>Cost</td>
<td>Sets a cost for sending packets across the network, which is used by OSPF routers to calculate the shortest path. This is not enabled for Cisco IOS-XE devices. Enter a numeric value between 1 and 65535.</td>
</tr>
<tr>
<td>Topology Priority</td>
<td>Displays the designated router for a subnet. Enter a numeric value between 1 and 255.</td>
</tr>
<tr>
<td>Maximum number of paths per route</td>
<td>Defines the highest number of paths that can be used by the router for load balancing per route. The default value is 4. You can set a numeric value between 1 and 64.</td>
</tr>
<tr>
<td>Administrative Distance</td>
<td>Specifies the distance that will be set for path selection. The default value is 110 and the available values are between 1 and 255.</td>
</tr>
<tr>
<td>External Area Distance</td>
<td>Specify the distance for external type 5 and type 7 routes. Your options are any numeric value between 1 and 255.</td>
</tr>
<tr>
<td>Inter Area Distance</td>
<td>Specify the inter area distance for inter-area routes using a value between 1 and 255.</td>
</tr>
<tr>
<td>Intra Area Distance</td>
<td>Specify the intra area distance for intra-area routes using a value between 1 and 255.</td>
</tr>
<tr>
<td><strong>Routing &gt; OSPF &gt; OSPF Interface/PEP Properties</strong></td>
<td>Description</td>
</tr>
<tr>
<td>Area ID</td>
<td>Specify the OSPF area ID for the NEs using an integer between the 0 and 4294967295. The ID cannot be 0.0.0.0.</td>
</tr>
<tr>
<td>Interface Name</td>
<td>Device’s interface with which the specified OSPF interface/pep settings must be associated.</td>
</tr>
<tr>
<td>Interface cost</td>
<td>Cost of sending packets across the network. This cost is used by OSPF routers to calculate the shortest path.</td>
</tr>
<tr>
<td>Interface Priority</td>
<td>Designated router for a subnet.</td>
</tr>
<tr>
<td>Network Type</td>
<td>Type of network associated with the OSPF process. Your options are: Broadcast, NBMA, Point to Point, and Point to Multipoint.</td>
</tr>
</tbody>
</table>
### Configure Static Routing

Static routing is the simplest form of routing, where the network administrator manually enters routes into a routing table. The route does not change until the network administrator changes it. Static routing is normally used when there are very few devices to be configured and the administrator is very sure that the routes do not change. The main drawback of static routing is that a change in the network topology or a failure in the external network cannot be handled, because routes that are configured manually must be updated to fix any lost connectivity.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dead Interval</td>
<td>Number of seconds that will pass while an OSPF router’s packets are not visible before its neighbors declare the router down. The Cisco default is 40 seconds.</td>
</tr>
<tr>
<td>Hello Interval</td>
<td>Number of seconds between OSPF hello packet advertisements sent by OSPF routers. The Cisco default is 10 seconds.</td>
</tr>
<tr>
<td>Retransmit Interval</td>
<td>Time that will elapse before a packet is resent. The Cisco default is 5 seconds.</td>
</tr>
<tr>
<td>Transmit Delay</td>
<td>Service speed. The Cisco default is 1 second.</td>
</tr>
</tbody>
</table>

### Configure ACLs

The Configuration tab in the Device Details page lists the current CFM configuration on the device. Depending on your device configuration and user account privileges, you can configure ACLs on the device.

To configure ACLs:

---

**Step 1** Choose Configuration > Network Devices.

**Step 2** Click the device hyperlink to launch its Device Details page.

**Step 3** Click the Configuration tab, then click the Logical View left side tab.

**Step 4** Choose Routing > Static.

**Step 5** To configure static routing, click Add.

a) If you are adding an IPv4 static route, in the IPv4 Static Routes area, click the Add (+) icon. Enter the required details in the following fields:

- Destination Network
- Network Mask
- Next Hop IP
- Outgoing Interface
- Permanent Route
- Administrative Distance

b) If you are adding an IPv6 static route, in the IPv6 Static Routes area, click the Add (+) icon. Enter the required details in the following fields:

- Destination IPv6 Prefix
- Prefix Length
- Next Hop IPv6 Address
- Outgoing interface
- Administrative Distance
- Cast Type
- Tag Value

**Step 6** Click Save.
Configure Devices

Configure EOAM Fault and Performance Monitoring

Cisco EPN Manager enables you to prepare the devices in your network for using EOAM (Ethernet Operations, Administration and Management) protocol for monitoring and troubleshooting Carrier Ethernet services. You can configure Connectivity Fault Management (CFM) on the devices participating in the Ethernet services. You can also perform connectivity and performance tests on the Ethernet services using sets of CLI commands available as predefined templates in Cisco EPN Manager.

Configure CFM

Cisco EPN Manager allows you to configure CFM domains, services, and maintenance endpoints on devices in your network. This CFM configuration sets the stage for using the EOAM protocol to monitor and troubleshoot Carrier Ethernet services. CFM must be configured on the endpoints of the service. This can be done per device using the procedure described in Configure CFM Maintenance Domains and Maintenance Associations (Services), on page 388. Alternatively, CFM can be configured on the EVC level when creating and provisioning an EVC, as described in Create and Provision a New Carrier Ethernet EVC, on page 483.

Once CFM is configured, you can quickly and easily view the CFM settings on individual devices and make changes if necessary. For example, if there is a problem with traffic flow across a specific EVC, you might want to make the continuity check interval shorter temporarily in order to analyze the problem, keeping in
mind that this will increase the management traffic and thus might impact network performance. You can change the setting on the specific device rather than re-provisioning the entire service.

See these topics for more information:

- CFM Overview, on page 387
- Configure CFM Maintenance Domains and Maintenance Associations (Services), on page 388

**CFM Overview**

IEEE Connectivity Fault Management (CFM) is an end-to-end per-service Ethernet layer Operations, Administration, and Maintenance (OAM) protocol. CFM includes proactive connectivity monitoring, fault verification, and fault isolation for large Ethernet metropolitan-area networks (MANs) and WANs.

CFM operates on a per-Service-VLAN (or per-EVC) basis. It lets you know if an EVC has failed, and if so, provides the tools to rapidly isolate the failure.

A CFM-enabled network is made up of maintenance domains, CFM services and maintenance points, as described below.

*Figure 11: CFM Maintenance Domains*

**Maintenance Domains**

Ethernet CFM, within any given service provider network, relies on a functional model consisting of hierarchical maintenance domains. A maintenance domain is a management space on a network that is owned and operated by a single entity and defined by a set of internal boundary ports. A domain is assigned a unique maintenance level which defines the hierarchical relationship of domains. Maintenance domains may nest or touch, but cannot intersect. If two domains nest, the outer domain must have a higher maintenance level than the one it engulfs. A single device might participate in multiple maintenance domains.
CFM Services

A CFM service (maintenance association) enables the partitioning of a CFM maintenance domain according to the connectivity within the network. For example, if the network is divided into a number of virtual LANs (VLANs), a CFM service is created for each of these. CFM can then operate independently in each service. A CFM service is always associated with the maintenance domain within which it operates, and therefore with that domain's maintenance level. All CFM frames relating to the service carry the maintenance level of the associated maintenance domain. There can be many CFM services within a domain. The CFM service must be configured on a domain before MEPs can be configured.

Maintenance Points

A maintenance point demarcates an interface that participates in a CFM maintenance domain. A maintenance point is an instance of a particular CFM service on a specific interface. CFM only operates on an interface if there is a CFM maintenance point on the interface. A maintenance point is always associated with a particular CFM service, and therefore with a particular maintenance domain at a particular level. Maintenance points generally only process CFM frames at the same level as their associated maintenance domain. Frames at a higher maintenance level are always forwarded transparently, while frames at a lower maintenance level are normally dropped. This helps enforce the maintenance domain hierarchy and ensures that CFM frames for a particular domain cannot leak out beyond the boundary of the domain. There are two types of maintenance points:

- Maintenance endpoints (MEPs)—Created at the edge of the domain. Responsible for confining CFM messages within the domain. Maintenance end points (MEPs) are members of a particular service within a domain and are responsible for sourcing and sinking CFM frames. They periodically transmit continuity check messages and receive similar messages from other MEPs within their domain. They also transmit traceroute and loopback messages at the request of the administrator.
- Maintenance intermediate points (MIPs)—Internal to the domain. A MIP will forward CFM packets while MEPs do not forward CFM packets because they must keep them within the domain. MIPs are not explicitly configured on each interface. MIPs are created automatically according to the algorithm specified in the CFM 802.1ag standard.

Configure CFM Maintenance Domains and Maintenance Associations (Services)

To enable CFM in your network, you need to create the relevant maintenance domains and define the maintenance points participating in the maintenance domain. For each device, you specify to which maintenance domain it belongs by assigning a maintenance domain level. You then define the CFM services, where you associate MEPs with the maintenance domain, that is, the interfaces on the device that belong to the maintenance domain.

To configure CFM on a device:

Before you begin

If you want to associate MEP parameters while configuring CFM, ensure that the following commands have been configured on the devices:

For Cisco IOS and Cisco IOS-XE devices:

```
interface <type of interface, gigabit/tengigabit> <interface number>
service instance <service instance number, for example 1> ethernet
encapsulation dot1q <vlan id>
```
Step 1  Choose **Inventory > Network Devices** from the left sidebar.

Step 2  Locate the required device in the list of devices and click the device name hyperlink to open the device details window.

Step 3  Click the **Configuration** tab, then click the **Logical View** left side tab.

Step 4  Choose **EOAM > CFM**.

Step 5  In the CFM window, click the ‘+’ icon to add a new CFM domain.

Step 6  Enter the following information:

- **Maintenance Domain Name**—Enter the name of the maintenance domain to which the device belongs.

  **Note**  Ensure that the CFM domain name is entered up to 42 characters in length.

  - For XE devices, if the CFM domain name is more than 35 characters, then the domain name will be truncated to 35 characters and pushed to the device.
  - For XR devices, if the CFM domain name is more than 15 characters, then the domain name will be truncated to 15 characters and pushed to the device.
  - For ME1200 devices, if the CFM domain name is more than 17 characters, then the domain name will be truncated to 17 characters and pushed to the device.
  - For services with 2 different devices, (for example, XE and XR) the domain name will be truncated to minimum of those devices and the truncated characters is displayed.

- **MEP Archive Hold Time**—Enter the number of minutes that data from a missing maintenance end point (MEP) is kept before it is purged. The range is 1 to 65535.

- **Level**—Select a maintenance level (0 to 7) from the **Level** drop-down menu. The level defines the maintenance domain to which the device belongs. A device might belong to more than one maintenance domain, in which case it would be assigned to more than one maintenance level.

Step 7  Click **Save**. The row is added to the table and the configurations are deployed to the device. Now you can define the CFM services and associate end points to the configured maintenance domain. Once the configuration is deployed to the device, you can edit only the MEP Archive Hold Time value in the row. The other values cannot be modified.

Step 8  Locate the maintenance domain name you just created in the table and click on the Maintenance Domain name hyperlink.

Step 9  Click the **Services** tab to add service details.

Step 10  Enter a name for the CFM service.

Step 11  For IOS devices: Enter a bridge domain name.

  For IOS-XR devices: Enter the X-connect group name and the name of the point to point connection within the cross connect group.

Step 12  Change the interval (10 to 600000 ms) between messages using the **Continuity Check Interval** drop-down menu.

Step 13  Locate the CFM service you just created in the table and click on the Maintenance Domain name hyperlink. This link was enabled when you saved the details.

Step 14  In the **MEP** tab, specify the interfaces that will serve as the MEPs in the Maintenance Entity Group. These are the interfaces on the device that belong to the specified maintenance domain, have the same level, and are on the same service provider VLAN (S-VLAN).

  If the **Interface** drop-down menu is empty, ensure that the device is configured with the pre-requisites mentioned above.

Step 15  For each MEP, enter the MEP ID (a value between 1 and 8191).
Step 16  Click Save to save your MEP definitions and close the dialog. To verify that your changes were saved, navigate to Inventory > Network Devices, and in the Configuration tab, click EOAM > CFM and view the maintenance domain details.

Delete a CFM Domain

You can delete CFM domains that have been created using Cisco EPN Manager. To delete a CFM domain:

Step 1  Choose Inventory > Network Devices from the left sidebar.
Step 2  Locate the required device in the list of devices and click the device name hyperlink to open the device details window.
Step 3  Click the Configuration tab, then click the Logical View left side tab.
Step 4  Choose EOAM > CFM.
Step 5  Select the domain that you want to delete and in the CFM window, click the 'X' icon to delete it. This deletes the configured maintenance domain both from the table and from the device. If the domain has defined CFM services and associated end points, then you will need to disassociate the services and the end points before deleting the domain.

Perform EOAM Connectivity and Performance Checks

Cisco EPN Manager provides predefined EOAM-related configuration templates that can be used to monitor the connectivity and performance of virtual connections (VCs) in a Carrier Ethernet network.

To use these templates, from the left sidebar, choose Configuration > Templates > Features & Technologies, then choose CLI Templates > System Templates – CLI.

The following table lists the available EOAM configuration templates, their purpose, and the mandatory input parameters you are required to provide.

<table>
<thead>
<tr>
<th>Template Name</th>
<th>Use it to...</th>
<th>Essential Input Values</th>
<th>Additional Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>EOAM-CCDB-Content-IOS</td>
<td>Display the contents of a maintenance intermediate point (MIP) continuity check database (CCDB) in order to verify CFM operation or to check how EOAM has been set up in the network.</td>
<td>None of the fields are mandatory. <strong>Domain ID:</strong> Choose the way in which you want to identify the maintenance domain and enter a value in the corresponding field. <strong>Service:</strong> Specify a maintenance association within the domain, based on ICC MEG identifier, VLAN ID or VPN ID.</td>
<td></td>
</tr>
<tr>
<td>Template Name</td>
<td>Use it to...</td>
<td>Essential Input Values</td>
<td>Additional Information</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------------</td>
<td>------------------------</td>
</tr>
</tbody>
</table>
| EOAM-CCDB-Content-IOS-XR| Display the contents of a maintenance intermediate point (MIP) continuity check database (CCDB) in order to verify CFM operation or to check how EOAM has been set up in the network. | None of the fields are mandatory.  
**Node ID:** The CFM CCM learning database for the designated node, entered in the rack/slot/module notation. |                       |
| EOAM-CFM-Ping-IOS and  | Check connectivity to a destination MIP or MEP using CFM loopback messages.    | Ping **Destination Type:** Identify the destination MEP, either by MAC address or MEP ID. Choose Multicast if there are multiple destination MEPs.  
Maintenance domain name for destination MEP: The name of the domain where the destination MEP resides. |                       |
| EOAM-CFM-Ping-IOS-XR    |                                                                                |                                                                                        |                       |
| EOAM-CFM-Traceroute-IOS | IOS devices: Trace the route to a destination MEP to check the number of hops and the connectivity between hops. | **Destination Type:** Identify the destination MEP, either by MAC address or MEP ID.  
**Maintenance domain name for destination MEP:** The name of the domain where the destination MEP resides.  
**Service Type:** Identify the maintenance association (MA) within the domain, either by name, ITU carrier code (ICC), MA number, VLAN ID, or VPN ID. |                       |
| EOAM-CFM-Traceroute-IOS-XR | IOS-XR devices: Trace the route to a destination MEP to check the number of hops and the connectivity between hops. | **Maintenance domain name for destination MEP:** The name of the domain where the destination MEP resides.  
**Service Name:** The name of the service instance being monitored by the Maintenance Association (MA) within the specified maintenance domain.  
**Destination Type:** Identify the destination MEP, either by MAC address or MEP ID.  
**Source MEP ID:** Identify the maintenance association (MA) within the domain, either by name, ITU carrier code (ICC), MA number, VLAN ID, or VPN ID.  
**Source Interface Type:** The source interface type of the locally defined CFM MEP.  
**Interface Path ID:** The physical or virtual interface name. |                       |
<table>
<thead>
<tr>
<th>Template Name</th>
<th>Use it to...</th>
<th>Essential Input Values</th>
<th>Additional Information</th>
</tr>
</thead>
</table>
| EOAM-Configure-Y-1731-PM-On-Demand-Operation-CFM-Loopback-IOS-XR | Configure an on-demand Ethernet SLA operation for CFM loopback. By default, measures two-way delay and jitter. | **Probe Domain**: Check the checkbox to enable the probe.  
**Domain Name**: The name of the maintenance domain for the locally defined CFM MEP.  
**Domain Interface Type**: The source interface type of the locally defined CFM MEP.  
**Domain Interface Path ID**: The physical or virtual interface name.  
**Domain MAC Address or MEP-ID**: Choose whether you want to identify the domain by MAC address or by MEP ID and provide the necessary information in the relevant field below. For MEP ID, enter an ID from 1 to 8191. | Optionally, you can specify the type of statistics to measure, whether or not to use bins for aggregate type, probe frequency and duration values, and more. The values you specify will override the default actions. |
| EOAM-Configure-Y-1731-PM-On-Demand-Operation-CFM-Synthetic-Loss-Measurement-IOS-XR | Configure an on-demand Ethernet SLA operation for CFM synthetic loss measurement. By default, measures one-way Frame Loss Ratio (FLR) in both directions. | **Probe Domain**: Check the checkbox to enable the probe.  
**Domain Name**: The name of the maintenance domain for the locally defined CFM MEP.  
**Domain Interface Type**: The source interface type of the locally defined CFM MEP.  
**Domain Interface Path ID**: The physical or virtual interface name.  
**Domain MAC Address or MEP-ID**: Choose whether you want to identify the domain by MAC address or by MEP ID and provide the necessary information in the relevant field below. For MEP ID, enter an ID from 1 to 8191. | Optionally, you can specify the type of statistics to measure, whether or not to use bins for aggregate type, probe frequency and duration values, and more. The values you specify will override the default actions. |
<table>
<thead>
<tr>
<th>Template Name</th>
<th>Use it to...</th>
<th>Essential Input Values</th>
<th>Additional Information</th>
</tr>
</thead>
</table>
| EOAM-Configure-Y-1731-PM-On-Demand-Operation-FM-Delay-Measurement-IOS-XR | Configure an on-demand Ethernet SLA operation for CFM delay measurement. By default, measures one-way delay and jitter in both directions, and two-way delay and jitter. | **Probe Domain:** Check the checkbox to enable the probe.  
**Domain Name:** The name of the maintenance domain for the locally defined CFM MEP.  
**Domain Interface Type:** The source interface type of the locally defined CFM MEP.  
**Domain Interface Path ID:** The physical or virtual interface name.  
**Domain MAC Address or MEP-ID:** Choose whether you want to identify the domain by MAC address or by MEP ID and provide the necessary information in the relevant field below. For MEP ID, enter an ID from 1 to 8191. | Optionally, you can specify the type of statistics to measure, whether or not to use bins for aggregate type, probe frequency and duration values, and more. The values you specify will override the default actions. |
| EOAM-Configure-Y-1731-PM-Direct-On-Demand-IOS | Perform real-time troubleshooting of Ethernet services in direct mode where an operation is created and run immediately. | **Frame Type:** The type of frame, either DMMv1 (frame delay) or SLM (frame loss).  
**Domain Name:** The name of the maintenance domain for the locally defined CFM MEP.  
**EVC or VLAN:** Identify the EVC or VLAN on which the test will be performed. The VLAN ID can be between 1 and 4096.  
**Target MPID or MAC Address:** Identify the MEP at the destination, either by MPID (1 to 8191) or by MAC Address.  
**CoS Value:** The class of service level (0-7) that will be applied to the CFM message for the specified MEP.  
**Local MPID or MAC Address:** Identify the MEP at the source, either by MPID (1 to 8191) or by MAC Address.  
**Burst or Continuous:** Specify whether a continuous stream of frames or bursts of frames will be sent during the on-demand operation.  
**Aggregation Period:** Specify the length of time in seconds during which the performance measurements are conducted, after which the statistics are generated (1-900). |
Configure Quality of Service (QoS)

Quality of Service (QoS) is a set of capabilities that allow the delivery of differentiated services for network traffic. QoS features provide better and more predictable network service by:

- Giving preferential treatment to different classes of network traffic.
- Supporting dedicated bandwidth for critical users and applications.
- Controlling jitter and latency (required by real-time traffic).
- Avoiding and managing network congestion.
- Shaping network traffic to smooth the traffic flow.
- Setting traffic priorities across the network.

Using Cisco EPN Manager you can configure QoS on Carrier Ethernet interfaces. Before the appropriate QoS actions can be applied, the relevant traffic must be differentiated by creating classification profiles, or class maps. Packets arriving at the device are checked against the match criteria of the classification profile to determine if the packet belongs to that class. Matching traffic is subjected to the actions defined in an action profile, or policy map.

To configure classification profiles and action profiles, choose Configuration > QoS > Profiles from the left sidebar.

This section includes the following topics:

- Create a QoS Classification Profile, on page 395
- Create a QoS Action Profile, on page 397
- Check Which QoS Profiles are Configured on a Device, on page 402
- Apply a QoS Action Profile to Interface(s), on page 402
- Import QoS Profiles Discovered from Devices, on page 403
Create a QoS Classification Profile

Create classification profiles (class maps) to differentiate traffic into different classes so that certain actions can be applied to traffic that matches the classification criteria.

To create a classification profile:

Step 1  Choose Configuration > QoS > Profiles in the left sidebar.
Step 2  Click the Add (“+”) icon at the top of the Global QoS Classification Profile pane.
Step 3  Enter a unique name for the classification profile. The name should reflect the classification criteria defined in the profile for easy identification. For further clarification, you can add a description.
Step 4  Define the matching criteria for the profile:
    • Match All—All the classification criteria must be met in order for the traffic to belong to this class.
    • Match Any—Any of the classification criteria can be met in order for the traffic to belong to this class.
Step 5  Under QoS Classifications, click the plus icon to define classification criteria for the classification profile.
Step 6  Select an action based on which the traffic will be classified, then click in the Value column and provide the relevant value, as follows:

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACL</td>
<td>The packet must be permitted by the specified access control list (ACL).</td>
<td>The name of the ACL. A string of up to 32 alphanumeric characters.</td>
</tr>
<tr>
<td>MPLS - Imposition</td>
<td>The experimental (EXP) bit value on the imposed label entry of the packet must match the MPLS EXP value that you specify. Use either the MPLS Imposition or the MPLS Topmost for matching criteria. Once you have used one of the MPLS criteria, the other one will no longer be available.</td>
<td>A number from 0 to 7. Up to 8 comma-separated values can be entered.</td>
</tr>
<tr>
<td>MPLS - Topmost</td>
<td>The experimental (EXP) bit value in the topmost label must match the MPLS EXP value that you specify.</td>
<td>A number from 0 to 7. Up to 8 comma-separated values can be entered.</td>
</tr>
<tr>
<td>Cascade</td>
<td>This action is used to cascade one class map into another. It can be used when creating a new class map which has classification policies similar to an existing class map.</td>
<td>Reference the child class map.</td>
</tr>
<tr>
<td>QoSClassification - COS</td>
<td>The packet's layer 2 class of service (CoS) bit value must match the specified CoS value.</td>
<td>A number from 0 to 7. Up to 8 comma-separated values can be entered.</td>
</tr>
<tr>
<td>Action</td>
<td>Description</td>
<td>Value</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>QoSClassification - COS - Inner</td>
<td>The specified value must match packet’s inner CoS value of QinQ packets for Layer 2 class of service (CoS) marking.</td>
<td>A number from 0 to 7. Up to 8 comma-separated values can be entered.</td>
</tr>
<tr>
<td>QoSClassification - DSCP</td>
<td>The packet IP differentiated service code point (DSCP) value must match one or more of the specified values.</td>
<td>Valid values are from 0 to 63. Up to 8 comma-separated values can be entered.</td>
</tr>
<tr>
<td>QoSClassification - DSCP - IPv4 only</td>
<td>Match DSCP values for IPv4 packets.</td>
<td>Valid values are from 0 to 63. Up to 8 comma-separated values can be entered.</td>
</tr>
<tr>
<td>QoSClassification - Precedence</td>
<td>The packet IP precedence value must match one or more precedence values.</td>
<td>A number from 0 to 7. Up to 8 comma-separated values can be entered.</td>
</tr>
<tr>
<td>QoSClassification - Precedence - IPv4 only</td>
<td>Match precedence values for IPv4 packets.</td>
<td>A number from 0 to 7. Up to 8 comma-separated values can be entered.</td>
</tr>
<tr>
<td>QoSClassification - DEI</td>
<td>Drop eligible indicator (DEI) is used to indicate frames eligible to be dropped when there is congestion. The packet must match the DEI value specified.</td>
<td>0 or 1.</td>
</tr>
<tr>
<td>QoS-Group</td>
<td>The packets must be permitted based on the selected QoS group.</td>
<td>Up to 8 comma separated unique values ranging from or 0-55 or 0-99 based on the selected device. Ensure that the value you enter is supported on the device.</td>
</tr>
<tr>
<td>QoSClassification - Service Instance</td>
<td>Service Provider configurations have various service instances on the Provider Edge (PE) routers. QoS policy-maps are applied on these service instances or group of service instances.</td>
<td>Accepts any number of comma separated values ranging from 1-4000 and/or hyphenated value with each ranging from 1-4000.</td>
</tr>
<tr>
<td>QoSClassification - VLAN</td>
<td>Match and classify traffic on the basis of the virtual local-area network (VLAN) identification number.</td>
<td>Accepts any number of comma separated values ranging from 1-4096 and/or hyphenated value with each ranging from 1-4096.</td>
</tr>
<tr>
<td>QoSClassification - VLAN - Inner</td>
<td>Match and classify traffic on the basis of the inner virtual local-area network (VLAN) identification number.</td>
<td>Accepts any number of comma separated values ranging from 1-4096 and/or hyphenated value with each ranging from 1-4096.</td>
</tr>
<tr>
<td>QoSClassification - Discard Class</td>
<td>Indicates that packets must be permitted/discarded based on the selected discard class.</td>
<td>Accepted value is any number between 0-7.</td>
</tr>
</tbody>
</table>
## Create a QoS Action Profile

Create action profiles (policy maps) to specify the actions to be applied to traffic belonging to a specific traffic class.

To create an action profile:

1. Choose **Configuration > QoS > Profiles** from the left sidebar.
2. From the QoS Profiles pane on the left, choose **User Defined Global QoS Profiles > Action Profiles**.
3. Click the Add (“+”) icon at the top of the Create Action Profile pane.
4. Enter a unique name for the action profile, and enter a description, if required.
5. Select the classification profiles for which you want to assign actions. Under Classification Profiles, click the plus icon, and select the required profile(s) from the list.
6. Select the Classification Profile (class map) and define the actions to be applied if traffic matches the profile. You can define Policing, Marking, Queuing, Shaping, RED actions, and Service Policy (H-QoS). There is a tab for each of these action types and its definitions, as follows:

   - **Policer Action**: Traffic policing manages the maximum rate of traffic allowed on an interface through a token bucket algorithm. Traffic policing also provides a certain amount of bandwidth management by allowing you to set the burst size (Bc) for the CIR. When the peak information rate (PIR) is supported, a second token bucket is enforced and this two-rate policer can meter traffic at two independent rates: the committed information rate (CIR) and the peak information rate (PIR). The committed token bucket can hold bytes up to the size of the committed burst (bc) before overflowing and determines whether a packet conforms to or exceeds the CIR. The peak token bucket can hold bytes up to the size of the peak burst (Be) before overflowing, and determines whether a packet violates the PIR. Different actions can be taken if a packet conforms, exceeds, or violates the CIR/PIR. For instance,
packets that conform can be configured to be sent, packets that exceed can be configured to be sent with a decreased priority, and packets that violate can be configured to be dropped.

In the Policer Action tab, specify the following:

- **Committed Information Rate (CIR)**—The long-term average transmission rate, specified in bits per second (bps) or as a percentage of the available or unused bandwidth. Traffic that falls under this rate will always conform. Ensure that the CIR value you enter is supported on the device and choose the right CIR unit value (bps, kbps, mbps, gbps, or percent).

- **Burst (Be)**—How large traffic bursts can be (in bytes) before some traffic exceeds the CIR.

- **Peak Information Rate (PIR)**—How much traffic bursts can peak before some traffic exceeds the PIR value associated with the CIR. Ensure that the PIR value you enter is supported on the device and choose the same unit value you chose for CIR (bps, kbps, mbps, gbps, or percent).

- **Excess Burst (Be)**—How large traffic bursts can be (in bytes) before traffic exceeds the PIR.

- **Under Traffic Coloring Behavior**, select the action to be performed if the traffic conforms, exceeds, or violates the rate limit. Provide values as required. To enable color-aware traffic policing specify the Conform Color and Exceed Color values by associating them with respective class profiles. With color-aware policing, the following results occur based on the CIR, the PIR, and the conform actions, exceed actions, and violate actions:

  - Packets that have metering rates less than or equal to the CIR and belong to the specified class (conform-color) are policed as conforming to the rate. These packets are also policed according to the conform action specified. In this instance, the packets will be transmitted.

  - Packets that have metering rates between the CIR and the PIR and belong to either the conform-color class or exceed-color class are policed as exceeding the CIR. These packets are also policed according to the exceed action specified. In this instance, the precedence value of the packets will be set and the packets transmitted.

  - Packets that have metering rates higher than the PIR or belong to neither class conform-color or class exceed-color are policed as violating the rate. These packets are also policed according to the violate action specified. In this instance, the packets will be dropped.

- **Marker Action**: Packet marking allows you to partition your network into multiple priority levels or classes of service. Marking of a traffic flow is performed by:

  - Setting IP Precedence or DSCP bits in the IP Type of Service (ToS) byte.

  - Setting CoS bits in the Layer 2 headers.

  - Setting EXP bits within the imposed or the topmost Multiprotocol Label Switching (MPLS) label.

  - Setting qos-group, traffic-class, and discard-class bits.

In the Marker Action tab, specify the following:

- **Marking Feature and Marking Value**—The method by which the traffic will be marked, and the required value.

- **Queueing Action**: Queueing is used for traffic congestion management. It entails the creation of queues, assignment of packets to those queues based on the classification of the packet, and scheduling of the packets in a queue for transmission.
In the Queueing Action tab, select the method by which traffic will be queued, either Bandwidth or Priority, then specify the following:

- **Bandwidth**—The amount of bandwidth to be assigned to the traffic class, either in kilobits per second, or as a percentage of absolute guaranteed bandwidth. If you selected to queue by bandwidth, you can also assign bandwidth as a percentage of remaining bandwidth.

- **Queue Limit**—The maximum number of packets/bytes/milliseconds for all the individual queues associated with this class. When the queue size exceeds this value, packets will be dropped.

If you selected Bandwidth, specify the following:

- **Enable Fair Queue**—Check the checkbox to enable weighted fair queueing.

- **Individual Queue Size**—Relevant if fair queueing is enabled. Specify the maximum number of packets allowed in each per-class queue during periods of congestion.

If you selected Priority, specify the following:

- **Queue Burst Size (bytes)**—The burst size configures the network to accommodate temporary bursts of traffic. Range is 18 to 2000000 bytes. Default is 200 milliseconds of traffic at the configured bandwidth rate.

- **Priority Level**—Classes under a policy map can have different priority, from priority queue level 1 to 3. Packets on these queues are subjected to less latency with respect to other queues. You cannot specify the same priority level for two different classes in the same policy map.

**Shaping Action:** Traffic shaping regulates traffic by shaping it to a specified rate.

In the Shaping Action tab, specify the following:

- **Select Average or Peak rate traffic shaping**—Average rate shaping limits the transmission rate to the CIR. Peak rate shaping configures the router to send more traffic than the CIR. To determine the peak rate, the router uses the following formula: peak rate = CIR(1 + Be / Bc) where Be is the Excess Burst size and Bc is the Committed Burst size.

- If you selected Peak rate traffic shaping, specify the burst size and the excess burst size in bytes.

- If required, enable FECN Adaptive Shaping. Adaptive shaping estimates the available bandwidth when backward explicit congestion notification (BECN) signals are received. With FECN adaptive shaping, the router reflects forward explicit congestion notification (FECN) signals as BECN signals.

- If FECN Adaptive Shaping is enabled, specify the Adaptive Rate, which is the minimum bit rate to which the traffic is shaped.

**RED Action:** Weighted Random Early Detection (WRED) is a congestion avoidance technique that implements a proactive queuing strategy that controls congestion before a queue reaches its queue limit. WRED combines the capabilities of the random early detection (RED) mechanism with IP precedence, differential services code point (DSCP), and discard-class to provide preferential handling of higher priority packets. When an interface starts to become congested, WRED discards lower priority traffic with a higher probability. WRED controls the average depth of Layer 3 queues.

In the RED Action tab, specify the following:

- **Classification Mechanism**—Select the basis upon which the WRED drop policies are defined. For WRED, you define drop policies based on specific packet classification, as follows:
**CLP**—Configures a drop policy for WRED based on a cell loss priority (CLP) value. Valid values are 0 or 1.

**CoS**—Configures a drop policy for WRED based on the specified class of service (CoS) bit associated with the packet. Valid values are from 0 to 7.

**Discard Class**—Configures a drop policy for WRED based on a discard-class value. Valid values are from 0 to 7. The discard-class value sets the per-hop behavior (PHB) for dropping traffic. WRED based on discard-class is an egress function.

**DSCP**—Configures a drop policy for WRED based on a DSCP value. When configured, the router randomly drops packets with the specified DSCP value, according to the WRED thresholds you configure.

**Precedence**—Configures a drop policy for WRED based on an IP precedence level. Valid values are from 0 to 7, where 0 typically represents low priority traffic that can be aggressively managed (dropped) and 7 represents high priority traffic. Traffic at a low precedence level typically has a higher drop probability. When WRED drops packets, source hosts using TCP detect the drops and slow the transmission of packets.

**DEI**—The discard eligibility (DE) bit in the address field of a frame relay frame is used to prioritize the discarding of frames in congested frame relay networks. The frame relay DE bit has only one bit and therefore only has two settings, 0 or 1. If congestion occurs in a frame relay network, frames with the DE bit set at 1 are discarded before frames with the DE bit set at 0.

**RED Default**—The default set of minimum thresholds, maximum thresholds, and Mark Probability Denominator (MPD) settings for a class in the WRED profile.

- If required, enable ECN. ECN (Explicit Congestion Notification) marks packets instead of dropping them when the average queue length exceeds a specific threshold value. Routers and end hosts use this marking as a signal that the network is congested and slow down packet transmission.

- Define the thresholds and mark probability per valid value of the selected classification mechanism. For example, if you are using Precedence, you can define thresholds for each of the 7 valid values. The minimum threshold is the minimum number of packets allowed in the queue. When the average queue length reaches the minimum threshold, WRED randomly drops some packets with the specified DSCP, IP precedence, discard-class, or atm-clp value. Valid minimum threshold values are from 1 to 16,384. The maximum threshold is the maximum number of packets allowed in the queue. When the average queue length exceeds the maximum threshold, WRED drops all packets with the specified DSCP, IP precedence, discard-class, or atm-clp value. Valid maximum threshold values are from the value of the minimum threshold to 16,384.

**Service Policy**:

Using the Service Policy tab, you can configure Hierarchical QoS (H-QoS) which enables you to specify QoS behavior at multiple levels of hierarchy. You can use H-QoS to specify multiple policy maps to shape multiple queues together. All hierarchical policy types consist of a top-level parent policy and one or more child policies. The service-policy command is used to apply a policy to another policy, and a policy to an interface.

To configure H-QoS, navigate to the Service Policy tab, select the Enable check box, and use the Service Policy drop-down menu to select the child service policy. The selected child service policy will be associated to the parent policy map that this action profile belongs to. Note that a child service policy cannot act as a parent policy of the same policy map. For example, if a child service policy called X belongs to a parent policy map Y, then the child policy X cannot contain the service policy map Y.

H-QoS Limitations: On Cisco IOS-XE devices such as Cisco ASR903, Cisco ASR907, Cisco ASR920, and Cisco NCS42XX, the following H-QoS limitations are applicable:

- Parent policy map limitations:
• A parent policy map can be created only using the 'class-default' class.
• The parent policy map must contain a class with matching criterion such as an EFP (service instance).
• The parent policy map must contain a class with matching criterion such as VLANs.

Child policy map limitations:
• Child policy maps cannot be created with EFP (service instance) and VLAN as the match-type.

Step 7 Click the Save button at the bottom of the window to save the profile. A notification in the bottom right corner will confirm that the profile has been saved and the profile will appear in the list of profiles on the left.
Step 8 From the Global QoS Action Profiles pane, select the profile, and click the Deploy button to initiate deployment of the profile to devices.
Step 9 If you want to create a new profile with the details of an existing Action Profile, click the Clone button. This profile will have the name of the action profile that you cloned from, and the suffix -clone. You can edit the name, actions and any other details of this cloned profile.
Step 10 If you want the selected profile to override any other policy map that already exists on the device, check the Override existing configuration check box. If this check box is not checked, the profile will be merged with the configurations on the device.
Step 11 Select the device(s) to which you want to deploy the QoS Action profile.
Step 12 Schedule the deployment, if required.
Step 13 Click Submit. A notification in the bottom right corner will confirm that the profile has been deployed. To check the status of the deployment job, choose Administration > Job Dashboard from the left sidebar. Select the relevant job to view the job details and history in the lower section of the window. Click the Information icon for further details.

Create a QoS Sub-Action Profile

An action profile (policy map) specifies the actions to be applied to traffic belonging to a specific traffic class. They are associated with multiple Classification Profiles that define the actions to be applied if traffic matches the profile. You can define Policing, Marking, Queueing, Shaping, RED actions, and Service Policy (H-QoS).

Sub-action profiles are action profiles that are associated with only a single classification profile. You can use sub-action profiles during circuit/VC provisioning to associate a singular action based action profile with the Circuit/VC.

To create a sub-action profile:

Step 1 Choose Configuration > QoS > Profiles from the left sidebar.
Step 2 From the QoS Profiles pane on the left, choose User Defined Global QoS Profiles > Sub-Action Profiles.
Step 3 Click the Add (“+”) icon at the top of the Create Sub-Action Profile pane
Step 4 Enter a unique name for the sub-action profile, and optionally enter a description.
Step 5 Select the classification profile for which you want to assign actions. Under Classification Profiles, click the plus icon, select the required profile from the list, and click OK.

You can add only a single classification profile to a sub-action profile. To associate multiple classification profiles, you must create an action profile.
Step 6  Specify the required actions that need to be taken when the traffic matches the criteria specified in the classification profiles. For a description of the various options, see, Create a QoS Action Profile, on page 397.

Import and Export QoS Action and Sub-Action Profiles

Step 1  Choose Configuration > QoS > Profiles from the left sidebar.

Step 2  To export Action Profiles, choose, User Defined Global QoS Profiles > Action Profiles from the pane on the left.

Step 3  To export Sub-Action Profiles, choose, User Defined Global QoS Profiles > Sub-Action Profiles from the pane on the left.

Step 4  To export profiles, select the profiles that you want to export and click Export. The files are saved in the location that you specify.

Step 5  To import profiles, click Import, choose the XML files (that contain information about the action or sub-action profiles) that you want to import, and click OK. The imported profiles are listed under the Action Profiles or Sub-Action Profiles pages respectively.

Please note:

- Although there is no limit to the number of profiles you can import in a single instance, we recommend that you choose a maximum of 10 profiles to ensure optimal performance.
- Ensure that the size of the file you want to import is below 20 MB.
- Files of only xml format can be imported.

Check Which QoS Profiles are Configured on a Device

To see the QoS profiles that have been deployed to a specific device:

Step 1  Choose Inventory > Network Devices from the left sidebar.

Step 2  Locate the required device and click on the device name hyperlink to display the device details.

Step 3  Click the Configuration tab, then click the Logical View left side tab.

Step 4  Click on the arrow next to QoS in the left pane, and select either Action Profiles or Classification Profiles. A table listing the profiles that have been deployed to the selected device is displayed. Click on the profile name (blue hyperlink) to display the details of the profile.

Apply a QoS Action Profile to Interface(s)

You can select an action profile deployed to a device and apply it to multiple interfaces on that device. An action profile enables you to specify the actions to be applied to traffic belonging to a specific traffic class. Before applying an existing profile to interfaces, you can modify the profile or use it to create a new profile. When you choose an interface that has an action profile already applied to it, Cisco EPN Manager notifies you about it and enables you to override the existing profile. To be able to apply an action profile to interfaces,
you first need to ensure that the required profile has been deployed to the device. To do this, see Create a QoS Action Profile, on page 397.

To apply an action profile to interfaces:

**Step 1** Choose **Configuration > QoS > Interfaces** from the left sidebar.
Cisco EPN Manager interfaces are displayed under the categories **Ethernet CSMA/CD, IEEE8023 ADLAG, Gigabit Ethernet,** and **L2 VLAN.** All other ports are displayed under the **User Defined** category.

**Step 2** Select the interfaces that you want to associate to an Action profile.

**Step 3** Click **Associate Action Profile** to select the action profile and to set the direction in which it must be applied. The available action profiles list and the interfaces it can be applied to are listed. The interfaces are listed by their name, application direction, and the action profiles that already exist on the interface.

**Note** QoS scaling profile configuration is the prerequisite to associate action profiles for Bundle-ethernet interfaces and sub-interfaces. Configuration example:

```
hw-module profile qos bundle <high-scale|medium-scale|low-scale> location <card>
```

**Step 4** Select the required action profile from the **Action Profiles** drop-down menu. If the menu is empty, you need to create action profile and then try to associate them with devices. See, Create a QoS Action Profile, on page 397.

**Step 5** In the **Interfaces** section, specify the direction in which the profile is to be applied. While applying a profile to a sub-interface, ensure that it is applied in a direction opposite to that of the main interface. To change the applied direction, use the **Edit** icon at the top left corner of the dialog.

**Note** Policy Maps that contain queuing actions cannot be applied to interfaces in Ingress direction.

**Step 6** (Optional) You can also schedule the application of the selected action profile to a later date and time. To do this, expand the **Schedule** section and specify the date and time and frequency for when you the profile to be applied. This task can further be edited on the Jobs page if required.

**Step 7** Click **OK** to apply the action profile to the selected devices. A notification at the bottom right corner of the dialog will confirm whether the profile has been successfully applied or if the job failed. Click the **Show Details** link for more information.

To dissociate action profiles from the interfaces they are applied to, see Dissociate a QoS Action Profile from Multiple Interfaces, on page 404

---

**Import QoS Profiles Discovered from Devices**

You can import QoS profiles discovered from the device directly into Cisco EPN Manager. Once the QoS profiles are imported, they can be edited and further configured on the device using Cisco EPN Manager. Profiles which are discovered from the device with profile names that match other profiles already present in Cisco EPN Manager are represented as Global profiles. This is indicated in the Global column in the Global Profiles page. Note that Global profiles could have the same names but different QoS configuration. While importing global profiles, you can choose to either overwrite the existing profile (with the same name) using the discovered profile or you can rename the profile before you import it.

To import QoS profiles discovered from devices:
Before you begin

Ensure that the device's Inventory Collection status is Completed. This ensures that the QoS profiles from the devices are discovered by Cisco EPN Manager.

---

**Step 1**
Choose Configuration > QoS > Profiles from the left sidebar to display all Cisco EPN Manager QoS profiles.

**Step 2**
To import Action profiles, from the QoS Profiles pane on the left, choose, Discovered Profiles > Action Profiles.

**Step 3**
To import Classification profiles, from the QoS Profiles pane on the left, choose, Discovered Profiles > Classification Profiles.

**Step 4**
To first select a device and choose the profiles discovered on that device:
- a) Choose Configuration > Network Devices, and select the device by clicking the device's Name hyperlink.
- b) Click the Configuration tab, then click the Logical View left side tab.
- c) Expand QoS.
- d) Choose Action Profiles or Classification Profiles based on the type of profile you want to import from the device.
- e) (Optional) After viewing the profiles, to import these profiles directly from the page that lists all QoS profiles discovered by Cisco EPN Manager, click the Global Profile Page hyperlink, and skip to Step 5.
- f) Select the profiles and click Make Global.
- g) Go to Step 6.

**Step 5**
Select the profiles that you want to import and click Import. To ensure that you are importing profiles that are not already present on the device, choose profiles that are not Global (marked as No in the Global column).

**Step 6**
If there are duplicate profiles present in Cisco EPN Manager, you are asked to either rename the profile to create a profile with a new name and the same QoS configuration or overwrite the existing profile. Make the required changes.

**Step 7**
If you want to create a new profile with the details of an existing QoS Profile, click the Clone button. This profile will have the name of the QoS profile that you cloned from, and the suffix -clone. You can edit any details of this cloned profile.

**Step 8**
Click Save to import the selected QoS profiles.

To apply the imported profiles to a given device's interfaces, see, Apply a QoS Action Profile to Interface(s), on page 402.

---

**Dissociate a QoS Action Profile from Multiple Interfaces**

An action profile enables you to specify the actions to be applied to traffic belonging to a specific traffic class. You can select an action profile deployed to a device and apply it to multiple interfaces on that device. After you have applied the profile to the interfaces, you can choose to dissociate them from those interfaces if required. To dissociate an action profile from interfaces, you first need to ensure that the required profile has been applied to the device. See Apply a QoS Action Profile to Interface(s), on page 402.

To apply an action profile to interfaces:

**Step 1**
Choose Configuration > QoS > Interfaces from the left sidebar.

Alternatively, you can navigate to Configuration > QoS > Profiles to first select the profile before dissociating it from the interfaces it is applied to.

Cisco EPN Manager interfaces are displayed under the categories Ethernet CSMA/CD, IEEE8023 ADLAG, and L2 VLAN. All other ports are displayed under the User Defined category.
Step 2  Select the interfaces from which you want to dissociate the action profile.

Step 3  Click Dis-associate Action Profile.

Step 4  (Optional) You can also schedule the de-association of action profiles to a later date and time. To do this, expand the Schedule section and specify the date, time, and frequency based on which the profiles must be dissociated.

Step 5  Click OK to confirm. The selected interfaces are dissociated from the action profiles that were applied to them. A notification at the bottom right corner of the window will confirm whether the profile has been successfully dissociated or if the job failed. Click the Show Details link for more information.

### Delete QoS Classification and Action Profiles from Devices

To delete QoS classification and action profiles that are deployed to devices, navigate to the paths listed in the table below.

#### Delete user defined classification profiles

<table>
<thead>
<tr>
<th>Task</th>
<th>Steps in the GUI</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete user defined classification profiles</td>
<td>1.  Choose Configuration &gt; QoS &gt; Classification Profiles. &lt;br&gt;2. Select the classification profile you want to remove from the devices as well as from Cisco EPN Manager. &lt;br&gt;3. Click the X (delete) icon in the task bar. &lt;br&gt;4. Alternatively, you can click the device hyperlink to choose the devices from which the selected classification profile must be deleted. &lt;br&gt;5. Click Submit. You can view the status of the delete operation by clicking the Job Details pop up window.</td>
</tr>
</tbody>
</table>

---

**Note**

You cannot delete QoS action and classification profiles discovered directly from the device. Only profiles created using (and imported into) Cisco EPN Manager can be deleted.

In order to avoid deletion of referenced profiles, the delete operation is not supported in the following scenarios:

- You cannot delete QoS classification profiles associated with other classification profiles. For example, if a classification profile uses the Cascade option to reference the selected classification profile, then the delete operation for the selected profile will fail.
- You cannot delete a QoS classification profiles referenced by an action profile.
- Action profiles successfully applied to device interfaces cannot be deleted.
- An action profile cannot be deleted if it is referenced by another action profile. For example, if action profiles are associated to other action profiles by use of a reference policy, then the delete operation of such action profiles fails.
Delete user defined action profiles

1. Choose **Configuration > QoS > Action Profiles**.
2. Select the action profile you want to remove from the devices as well as from Cisco EPN Manager.
3. Click the X (delete) icon in the task bar.
4. Alternatively, you can click the device hyperlink to choose the devices from which the selected action profile must be deleted.
5. Click **Submit**. You can view the status of the delete operation by clicking the Job Details pop up window.

---

### Save Your Device Changes

After you make a change to a device, save your changes to the database and, if desired, collect the device's physical and logical inventory. See these topics for more information:

- [Save Device Configuration Changes to the Database (Update), on page 406](#)
- [Collect a Device's Inventory Now (Sync), on page 406](#)

### Save Device Configuration Changes to the Database (Update)

After making a change to your devices, you should save those changes to the database by clicking **Update** in the configuration window. If an Update button is not provided, perform a manual **sync** which will save your changes, but also collect the device's physical and logical inventory and save it to the database. See [Collect a Device's Inventory Now (Sync), on page 406](#).

### Collect a Device's Inventory Now (Sync)

The Sync operation performs an immediate inventory collection for a device. When it performs a Sync, Cisco EPN Manager collects the selected device's physical and logical inventory and synchronizes the database with any updates. If you do not perform a Sync operation after making a change to a device, your change will not be saved to the database until the daily inventory collection.

---

**Note**

The Sync operation is different from the Update operation. Update saves configuration changes without performing an inventory collection. If you want to use Update instead of Sync, see [Save Device Configuration Changes to the Database (Update), on page 406](#).
This Sync operation is different from working with *out-of-sync device configuration files*. An out-of-sync device is a device that has a startup configuration files that is different from its running configuration file. For more information, see *Synchronize Running and Startup Device Configurations*, on page 103.

Use one of these methods to perform a manual Sync.

<table>
<thead>
<tr>
<th>To collect the inventory for:</th>
<th>Do the following:</th>
</tr>
</thead>
</table>
| A single device               | • From the device's Device 360 view, choose **Actions > Sync Now**.  
• From the Network Devices table, check the device's check box, then click **Sync**. |
| Multiple devices              | From the Network Devices table, select the devices (by checking their check boxes), then click **Sync**. |

**Launch Cisco Transport Controller to Manage Cisco NCS and Cisco ONS Devices**

The Cisco Transport Controller (CTC) is the software interface for a subset of Cisco ONS and Cisco NCS devices. CTC is a Java application that resides on the control cards. It is used to provision and administer these devices.

You can launch CTC from Cisco EPN Manager. Only the latest CTC release is launched, regardless of the NE release you selected. If you need to use other CTC releases, launch CTC from a web browser and connect directly to the NE that has the required CTC release.

To launch CTC:

**Before you begin**

Make sure the devices are properly configured to launch CTC. See *Configure Devices So They Can Be Modeled and Monitored*, on page 44.

**Step 1** From the left sidebar, choose **Inventory > Device Management > Network Devices**.

**Step 2** Click the “i” icon next to the Cisco ONS or Cisco NCS device’s IP address to launch the Device 360 view.

**Step 3** In the Device 360 view, choose **Actions > Launch CTC**. The CTC launcher application is downloaded to your computer. Note that this action will be disabled if launching CTC is not supported on the selected device type.

**Step 4** In the CTC Launcher window, choose one of the following connection mode:

• Use IP—Connection to the device is established using the device’s IP address (default option).

• Use TL1 Tunnel—Connection to the device is established using a TL1 session. You can start a TL1 session from CTC or use a TL1 terminal. Note- Use this option to connect to the device that resides behind the third-party OSI-based
GNE. The CTC launcher creates a TL1 tunnel to transport the TCP traffic through the OSI-based GNE and the provisioning occurs in CTC.

**Step 5**  Select the CTC Version, and then click **Launch CTC**.

**Step 6**  Enter your CTC credentials.
Create Templates To Automate Device Configuration Changes

This chapter has the following topics.

- Why Create New Configuration Templates?, on page 409
- Ways to Create Configuration Templates Using Cisco EPN Manager, on page 410
- Create a New CLI Configuration Template Using a Blank Template, on page 410
- Create a New CLI Configuration Template Using An Existing Template, on page 411
- Entering Variables in a Template, on page 412
- Use Global Variables in a Template, on page 417
- Import and Export a CLI Configuration Template, on page 420
- Create a New Composite Template, on page 420
- Create a Shortcut to Your Templates Using Tags, on page 421
- Deploy Templates to Devices, on page 421
- Check the Status and Results of a Deployed Configuration Template, on page 425

Why Create New Configuration Templates?

Cisco EPN Manager provides a number of out-of-the-box configuration templates that you can use to make changes on your network devices. Those are described in Create a New CLI Configuration Template Using An Existing Template, on page 411.

If you have sufficient privileges, you can also create new templates that meet the exact needs of your environment, and then make those templates available for others to use. You can make the templates as simple or as complex as needed, including grouping multiple templates together into a composite template. Finally, you can associate templates with particular devices by creating configuration groups.

Cisco EPN Manager provides out-of-the-box CLI commands that you can use in your templates. It also provides a blank CLI template you can use to create new CLI commands. You can use them singly or with other commands in a composite template.

How you use configuration templates can depend on factors such as how large your network is, the number of designers in your organization, and how much variation there is among devices configuration. For example:

- For a small network with only one or two designers and a limited number of device configurations, start by copying the CLI configurations you know are “good” into a set of templates. You could then combine them into composite templates and make them available to your operators.
• For a large network with many different device configurations, try to identify the configurations you can standardize. This lets you control the amount of exceptions to these standards, and lets you turn features on and off as needed.

Ways to Create Configuration Templates Using Cisco EPN Manager

Cisco EPN Manager provides different methods for creating new configuration templates, depending on your user account privileges. CLI configuration templates contain one or more CLI configuration commands (the same commands you would type when configuring a device). Composite configuration templates are comprised of two or more CLI or composite configuration templates. You can specify the order in which the commands are deployed to devices.

• Modify one of the out-of-the-box CLI templates. See Create a New Composite Template, on page 420.
• Use the blank CLI template and enter code by hand. See Create a New CLI Configuration Template Using a Blank Template, on page 410.
• Use the blank CLI template and copy and paste code from a command line configuration session, CLI script, or other stored set of configuration commands. See Create a New CLI Configuration Template Using An Existing Template, on page 411.
• Merge several existing out-of-the-box or user-defined templates into a single template. You specify the order in which the templates contained in the composite template are deployed to devices. See Create Configuration Groups for Deploying Templates to Groups of Devices, on page 421.

Once you have created a set of templates, you can export and import them.

Create a New CLI Configuration Template Using a Blank Template

Use templates to define a set of reusable device configuration commands. A description of CLI templates and how you can use them is displayed in the web GUI when you choose Configuration > Templates > Features & Technologies, then choose CLI Templates.

If you want to edit a template that is provided with Cisco EPN Manager, make a copy of the template, give it a new name, and then edit it. See Create a New CLI Configuration Template Using An Existing Template, on page 411.

Templates that you create are stored under My Templates.

Before you begin

Configuration templates are not supported by default on Cisco Optical Networking devices. To enable configuration templates support, select an existing pre-defined CLI configuration template, and in its Device Type section, enable the Optical Networking checkbox. Save this CLI template as a new template. The template is now saved as a user-defined template which lists all optical networking devices such as Cisco NCS 2000, Cisco NCS 4000 devices, and so on.

Step 1  Choose Configuration > Templates > Features & Technologies.
Step 2  Expand CLI Templates, then choose CLI.

Step 3  In the Template Basic area:
   a) Enter a meaningful name for the template. Templates are listed alphabetically in the web GUI.
   b) (Optional) Enter a short description that describes how the template should be used—for example, "enable traps on IOS devices."
   c) (Optional) Tag the template with an intuitive name. For information on tags, choose My Tags.
   d) Enter the device operating systems on which the template can be executed (for example, 12.2 or 15.3). When you execute the template, older device OS versions are filtered out. If you leave this field blank, the template will be applied all OSs for the specified devices.

Step 4  Specify the device configuration commands in the Template Detail area.
   a) Enter or paste the copied code into the CLI Content field. You can copy code from a command line configuration session, CLI script, or other stored set of configuration commands. You must enter code using Apache VTL (see http://velocity.apache.org/engine/devel/vtl-reference-guide.html).
   b) Configure your variables using the Add Variables dialog. Variables will prompt you for a value when you execute the template.
      • To create a variable using a name in the code, select the code (no spaces) and click the + sign at the top left of the Add Variables area. This creates a new (unconfigured) variable by that name in the Add Variables dialog.
      • Click the + sign at the top right of the Add Variables area. This adds a blank row to the Add Variables dialog.
   c) To see how the variable will be displayed when the template is executed, click Form View.
   d) To save your variables, click Add to CLI.

Step 5  Save your template. Click Save as New Template, specify the folder (in My Templates) in which you want to save the template, then click Save.

Note 1. Device configuration commands in the Template Detail area cannot contain special characters.

2. Entering XML specific special characters in the Description field under the Template Basic area causes the template export to fail.

Create a New CLI Configuration Template Using An Existing Template

The easiest way to create a new configuration template is to find a similar existing template, copy it, and edit it. You can also use this procedure to edit templates that you created. (You can only edit templates that you create.)

Step 1  Choose Configuration > Templates > Features & Technologies.
Step 2  Expand CLI Templates, then choose System Templates - CLI.
Step 3  In the Template navigation panel on the left, locate the template you want to copy, hover your mouse cursor over the i icon that is displayed next to the template name, then click Duplicate in the popup window.
**Step 4** In the **Duplicate Template Creation** dialog, specify a name and the folder (under **My Templates**) where you want the new template to be saved, and click **OK**.

For example, if you copy a template that resides under **CLI Templates > System Templates - CLI**, by default the template is saved under **My Templates > CLI Templates > System Templates - CLI (User Defined)**.

**Step 5** Add the validation criteria and CLI content as described in Create a New CLI Configuration Template Using a Blank Template, on page 410.

---

### Entering Variables in a Template

These topics provide information that will help you when entering variables into a template:

- Data Types, on page 412
- Manage Database Variables in CLI Templates, on page 413
- Use Validation Expressions, on page 413
- Add Multi-line Commands, on page 414
- Add Enable Mode Commands, on page 415
- Add Interactive Commands, on page 415

### Data Types

Table 1 lists data types that you can configure in the Manage Variables page.

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>String</td>
<td>Enables you to create a text box for CLI templates. To specify a validation expression and a default value, expand the row and configure the Default Value and Validation Expression fields.</td>
</tr>
<tr>
<td>Integer</td>
<td>Enables you to create a text box that accepts only numeric value. If you want to specify a range for the integer, expand the row and configure the Range From and To fields. To specify a validation expression and a default value, expand the row and configure the Default Value and Validation Expression fields.</td>
</tr>
<tr>
<td>DB</td>
<td>Enables you to specify a database type. See the Manage Database Variables in CLI Templates, on page 413.</td>
</tr>
<tr>
<td>IPv4 Address</td>
<td>Enables you to create a text box that accepts only IPv4 addresses for CLI templates. To specify a validation expression and a default value, expand the row and configure the Default Value and Validation Expression fields.</td>
</tr>
<tr>
<td>Drop-down</td>
<td>Enables you to create a list for CLI templates. To specify a validation expression and a default value, expand the row and configure the Default Value field (with a comma-separated value for multiple lists which appears in the UI).</td>
</tr>
<tr>
<td>Check box</td>
<td>Enables you to create a check box for CLI templates. To specify a validation expression and a default value, expand the row and configure the Default Value field.</td>
</tr>
</tbody>
</table>
Manage Database Variables in CLI Templates

You can use database (DB) variables for the following reasons:

- DB variables are one of the data types in CLI templates. You can use the DB variables to generate device-specific commands.

- DB variables are predefined variables. To view the list of predefined DB variables, see the CLITemplateDbVariablesQuery.properties file at the following location: folder/opt/CSCOIumos/conf/ifm/template/inventoryTagsInTemplate.

- For example, SysObjectID, IPAddress, ProductSeries, ImageVersion are DB variables. When a device is added to Cisco EPN Manager, the complete details of the device is collected in the DB variables. That is, the OID of the devices is collected in SysObjectID, product series in ProductSeries, image versions of the device in ImageVersion, and so on.

- Using the data collected by the DB variables, accurate commands can be generated to the device.

- You can select the DB variable in the Type field (using the Managed Variables page). Expand the name field and fill in the default value field with any of the DB variables which you want to use.

- When a device is discovered and added to Cisco EPN Manager, you can use the database values that were gathered during the inventory collection to create CLI templates.

Note

While it is possible to create a customized query using Enterprise JavaBeans Query Language (EJBQL), only advanced developers should attempt this. We recommend you use the variables defined in the CLITemplateDbVariablesQuery.properties file only.

Use Validation Expressions

The values that you define in the Validation Expression are validated with the associated component value. For example, if you enter a default value and a validation expression value in the design flow, this will be validated during the design flow. That is, if the default value does not match with the entered value in the validation expression, you will encounter a get error at the design flow.

Note

The validation expression value works only for the string data type field.

For example, choose Configuration > Templates > Features and Technologies, then choose CLI Templates > CLI. In the Template Detail area, click the Add Variable tab to view the list of Variables. Click the Add plus sign (+) in the Add Variables tab to add a row to the CLI template. Choose String in the Type
field, enter the remaining values, and click Save. From the list of variables, expand the details of this new variable and configure the regular expression, which will not allow a space in that text box. Enter the following expression in the Validation Expression field.

`^[\S]+$`

Default value (optional)—ncs
The value should match with regular expression in the validation expression field.
Save the template, and then select a device. Try to enter a space in the text field. You will encounter a regular expression error.

## Add Multi-line Commands

To enter multi-line commands in the CLI Content area, use the following syntax:

```xml
<MLTCMD>First Line of Multiline Command
Second Line of Multiline Command
......
......
Last Line of Multiline Command</MLTCMD>
```

where:
- `<MLTCMD>` and `</MLTCMD>` tags are case-sensitive and must be entered as uppercase.
- The multi-line commands must be inserted between the `<MLTCMD>` and `</MLTCMD>` tags.
- The tag cannot be started with a space.
- The `<MLTCMD>` and `</MLTCMD>` tags cannot be used in a single line.

### Example 1:

```xml
<MLTCMD>banner_motd Welcome to Cisco. You are using Multi-line commands.
</MLTCMD>
```

### Example 2:

```xml
<MLTCMD>banner motd ~ ${message}
</MLTCMD>
```

where `{message}` is a multi-line input variable.

### Restrictions for Using Multi-Line Banner Commands

Cisco EPN Manager does not support multi-line banner commands. You can use `banner file xyz format` as shown in the following example.

```bash
#conf t
Enter configuration commands, one per line. End with Ctrl-Z.
(config)#parameter-map type webauth global
(config-params-parameter-map)# type webauth
```
Add Enable Mode Commands

Use this syntax to add enable mode commands to your CLI templates:

```markdown
#MODE_ENABLE<<commands >>#MODE_END_ENABLE
```

Add Interactive Commands

An interactive command contains the input that must be entered following the execution of a command.

To enter an interactive command in the CLI Content area, use the following syntax:

```markdown
CLI Command<IQ>interactive question 1<R>command response 1 <IQ>interactive question 2<R>command response 2
```

where `<IQ>` and `<R>` tag are case-sensitive and must be entered as uppercase.

For example:

```markdown
#INTERACTIVE
crypto key generate rsa general-keys <IQ>yes/no<R> no
#ENDS_INTERACTIVE
```

Note: You must replace the `<IQ>` tag with the `<IQNONEWLINE>` tag for any interactive questions in which the default `<return>` or newline character is not required in the command for any of the controller devices. For example,

```markdown
#INTERACTIVE
transfer download start <IQNONEWLINE>y/N<R>y<IQNONEWLINE>y/N<R>y
#ENDS_INTERACTIVE
```
The `<IQ>` tag utilizes regular expressions for interactive questions. You must use the valid regular expressions for matching patterns.

**Format**

```
#INTERACTIVE
commands<iq>interactive question</i>response
#ENDS_INTERACTIVE
```

**Example for invalid content used in interactive question**

```
#INTERACTIVE
save config<iq>Are you sure you want to save? (y/n)</i>y
#ENDS_INTERACTIVE
```

Using the Question Mark "?" in between is invalid and does not match the pattern.

**Example for valid content used in interactive question**

```
#INTERACTIVE
save config<iq>{y/n}</i>y
#ENDS_INTERACTIVE
```

**Combining Interactive Enable Mode Commands**

Use this syntax to combine interactive Enable Mode commands:

```
#MODE_ENABLE
#INTERACTIVE
commands<iq>interactive question</i>response
#ENDS_INTERACTIVE
#MODE_END_ENABLE
```

**For example:**

```
#MODE_ENABLE
#INTERACTIVE
mkdir <iq>Create directory</i>XXX
#ENDS_INTERACTIVE
#MODE_END_ENABLE
```

**Adding Interactive Multi-line Commands**

This is an example of an interactive command that contains multiple lines:

```
#INTERACTIVE
macro name EgressQoS<iq>Enter macro</i><mltcmd>mls qos trust dscp
wrr-queue queue-limit 10 25 10 10 10 10 10 10 10
wrr-queue bandwidth 1 25 4 10 10 10 10 10 10
priority-queue queue-limit 15
wrr-queue random-detect 1
wrr-queue random-detect 2
wrr-queue random-detect 3
wrr-queue random-detect 4
wrr-queue random-detect 5
wrr-queue random-detect 6
wrr-queue random-detect 7
wrr-queue random-detect max-threshold 1 100 100 100 100
wrr-queue random-detect min-threshold 1 80 100 100 100
wrr-queue random-detect max-threshold 2 100 100 100 100
```
Use Global Variables in a Template

Cisco EPN Manager enables you to deploy customized CLI configuration to your devices by creating CLI templates which contain these customized configuration options. When you create CLI templates or modify existing ones, you can define the content of the template using global and/or template variables.

- **Template variables:** allow you to input values to the variable during CLI template or service creation.
- **Global variables:** are predefined and associated with the CLI template or with a service at a global level (by default). You cannot view a global variable or input its values during service creation.

All variables names start with words that identify them as global or template variable. Global variables are accessible to all Cisco EPN Manager templates such as CLI templates or Composite templates. They identify the type of service (CE, L3VPN, CEM, etc.) that the variable can be associated with. If you create a new global variable, you must ensure that you specify a name that starts with the letters 'gv' followed by other words that promote easy identification of the variable. Global variables that you create, can be further edited and deleted. The global variables available in Cisco EPN Manager by default, cannot be edited or deleted. While global variables are applicable to all template types, the variables created specifically during CLI template creation are applicable to that template alone. These variables created during CLI template creation cannot be associated with other CLI templates.

In the CLI template configuration example shown below, 'gv.service-ethernet-maintInterfaceName' represents the global variable. If this template is associated with a service, then during service creation, the dynamic part of the global variable, 'maintInterfaceName', is replaced by the values (such as the ethernet interface, in case of CE services) specified in the service. However, you will not be able to view or modify this global variable during service creation. '$descr' is a static value which represents the template variable. During service creation, this template variable will enable you to modify or specify a value of the type String (for the description field).

```
interface $gv.service-ethernet-maintInterfaceName
  description $descr
exit
```

To use global variables to create CLI templates:

---

**Step 1**  Choose **Configuration > Templates > Global Variable** to create new global variables.

To use existing global variables that are pre-populated in Cisco EPN Manager for each service type (CE, L3VPN, and CEM), skip to Step 4.

**Step 2**  Click the Add ‘+’ icon. To edit existing variables, select the global variable and click the Edit button.
Step 3 Specify the following parameters and click Save. Your changes are saved in the Cisco EPN Manager database and are not immediately deployed to the device.

- **Name**: Enter a unique name for the variable ensuring that the name starts with the letters 'gv' followed by the type of service this global variable is relevant to. You can use special characters such as the dot, hyphen, and underscore.
- **Description**: Enter a unique description for easy identification of the variable. This description is extremely important to help identify the purpose of this variable that may be used in CLI templates. The CLI templates could further be used to provision services (such as L2 and L3 services). And on the service creation page, you will rely completely on the variable description to identify the purpose of the variable.
- **Type**: Use one of the following options to specify the type of variable:
  - **String**: Enables you to create a text box for CLI templates. Only the string type of variable is applicable to CLI templates used in service provisioning.
  - **Integer**: Enables you to create a text box that accepts only numeric value. It can later be configured to specify a range for the value.
  - **IPv4 Address**: Enables you to create a text box that accepts only IPv4 addresses for CLI templates.
  - **Drop-down**: Enables you to create a drop-down list for CLI templates.
  - **Check box**: Enables you to create a check box field for CLI templates.
  - **Radio Button**: Enables you to create a radio button for CLI templates.
  - **TextArea**: Enables you to create a text area which allows multiline values for CLI templates.
- **Value**: Specify the values that must be generated based on the selected Type values explained above.
  If you want to specify the value during service creation or during CLI template creation, you can choose 'Not Available' as a place holder.
- **Display Label**: Enter how you want the variable to be displayed in the Cisco EPN Manager GUI.

Step 4 Associate the global variable with a CLI template:

- Navigate to **Configuration > Templates > Features & Technologies**.
- To create a new CLI template from scratch, see Create a New CLI Configuration Template Using a Blank Template, on page 410.
- To associate global variables with existing templates, see Create a New CLI Configuration Template Using An Existing Template, on page 411.
- To add global variables, from the Template Details section, use the Add Global Variable search field to locate the global variable. For easy identification, you can also use the Global Variable hyperlink displayed at the top right corner of the page. You can use global variables along with CLI, and/or template variables in the same CLI template.

You can identify the services that the variables belong to by looking at the variable name. Variables applicable to CE services, have variable names that start with the letters 'gv.ce-service-ethernet*'. Variables applicable to L3VPN services, have variable names that start with the letters 'gv.l3vpn-service-l3vpn*'. These variables can be associated with new or existing CLI templates.

- Make the required changes to the CLI template and click Save as New Template.
- The CLI template is now saved and displayed under My Templates > CLI Templates (User Defined).
- (Optional) Deploy the CLI template to the devices as explained in Deploy Templates to Devices, on page 421.
Step 5  (Optional) To provision services (L2, L3VPN, CEM, Flex LSP, Layer 3 link) using CLI templates (associated with global and template variables), see, *Extend a Circuit/VC Using Templates*, on page 575.

---

**Example**

Sample Global Variables Available in Cisco EPN Manager:

- Following are the sample global variables that can be used with L3VPN services:

<table>
<thead>
<tr>
<th>Variable Name</th>
<th>Description</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>gv.service-l3vpn-bgpASNumber</td>
<td>BGP AS Number</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-l3vpn-bgpNeighborASNumberList</td>
<td>BGP Neighbor AS Number</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-l3vpn-bgpNeighborAddressFamilyList</td>
<td>Neighbor Address Family</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-l3vpn-bgpNeighborList</td>
<td>BGP Neighbor</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-l3vpn-bgpRouterId</td>
<td>BGP Router ID</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-l3vpn-bridgeDomainIdList</td>
<td>Bridge Domain ID</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-l3vpn-egressServiceQoSPolicyName</td>
<td>Egress Service QoS Policy Name</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-l3vpn-egressUNIQoSPolicyName</td>
<td>Egress UNI QoS Policy Name</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-l3vpn-ingressServiceQoSPolicyName</td>
<td>Ingress Service QoS Policy Name</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-l3vpn-ingressUNIQoSPolicyName</td>
<td>Ingress UNI QoS Policy Name</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-l3vpn-maininterfaceNameList</td>
<td>Main Interface Name</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-l3vpn-serviceInterfaceNameList</td>
<td>Sub-Interface or BDI/BVI Name</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-l3vpn-vrfAddressFamilyList</td>
<td>VRF Routing Address Family</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-l3vpn-vrfName</td>
<td>VRF Name</td>
<td>String</td>
</tr>
</tbody>
</table>

- Following are the sample global variables that can be used with CEM services:

<table>
<thead>
<tr>
<th>Variable Name</th>
<th>Description</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>gv.service-cem-aunumber</td>
<td>AU (AU-3 or AU-4) number</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-cem-cemFrameType</td>
<td>CEM frame type</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-cem-cemGroupNumber</td>
<td>CEM group number</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-cem-cemGroupNumberList</td>
<td>CEM group number list for local connects</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-cem-cemInterfaceName</td>
<td>CEM interface name</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-cem-cemInterfaceNameList</td>
<td>CEM interface name list for local connects</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-cem-controllerInterfaceName</td>
<td>Controller name</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-cem-e1Number</td>
<td>E1 number</td>
<td>String</td>
</tr>
<tr>
<td>gv.service-cem-l2vpnContextName</td>
<td>L2VPN context name</td>
<td>String</td>
</tr>
</tbody>
</table>
Import and Export a CLI Configuration Template

These topics explain how to export and import configuration templates. Templates can be exported templates have an.xml file name; multiple templates are exported as a zip file.

- If you export multiple configuration templates, the.xml files are placed in a zip file with the prefix name Exported Templates.
- Single files are exported and imported as.xml files
- You can import multiple.xml files by selecting individual files or by importing a zip file.
- When you import CLI templates, the user-defined global variables that are part of the file are not imported automatically. You need to add these variables to the CLI template manually.

Step 1
Choose Configuration > Templates > Features & Technologies. > Templates > Features & Technologies.
Step 2
To export a configuration template:
  a) Select the template(s) that you want to export and click .
  b) Save the files at the desired location.
Step 3
To import a configuration template:
  a) Under the CLI Templates folder, hover your mouse cursor over the "i" next to CLI.
  b) Click Show All Templates, then click Import.
  c) In the Import Templates dialog box, choose the My Templates folder where you want to import the templates, then click Select Templates and navigate to the file you want to import.
  d) Confirm your choices, then click OK.

Create a New Composite Template

All out-of-the-box and user-created templates can be added to a single composite template, which aggregates all of the individual feature templates that you need. When you create a composite template, you can also specify the order in which member templates should be executed. You can use composite templates to make changes to single or groups of devices.

Step 1
Choose Configuration > Templates > Features & Technologies.
Step 2
Expand the Composite Templates folder and choose Composite Templates.
Step 3
In the Template Basic area, enter a name for the template.
Step 4
In the Template Detail area, choose the templates to include in the composite template. Using the arrows, place the templates in the in the order in which they should be deployed to the devices. For example, to create an ACL and associate it with an interface, put the ACL template first, followed by the interface template.
Step 5
Click Save as New Template. After you save the template, and apply it to your devices (see ).
Create a Shortcut to Your Templates Using Tags

When you apply a tag to a template, the template is listed under the My Tags folder. Tagging a configuration template helps you:

• Search a template using the tag name in the search field
• Use the tagged template as a reference to configure more devices

To tag an existing template, follow these steps:

**Step 1** Choose Configuration > Templates > Features & Technologies.

**Step 2** Expand the My Templates folder and choose the template that you want to tag.

**Step 3** Enter a tag name in the Tag as text box, then click Save.

Deploy Templates to Devices

These topics describe the ways you can deploy (run) groups of commands on devices using configuration templates:

• Create Configuration Groups for Deploying Templates to Groups of Devices
• Deployment Flow for Configuration Group Using the Wizard
• Deployment Flow for CLI Templates using the Wizard
• Deployment Flow for Composite Templates Using the Wizard
• Deploy Templatesto Devices Without Using Configuration Groups

Create Configuration Groups for Deploying Templates to Groups of Devices

If you have devices that require the same configuration, you can create a configuration group that contains devices and templates that can be applied to those devices. Creating a configuration group allows you to quickly apply new templates without remembering to which devices the new templates should be deployed.

Composite templates allow you to group smaller templates together, but configuration groups specify the relationship between the templates and the groups of devices, and the order in which commands are executed.

**Step 1** Choose Configuration > Templates > Configuration Groups.

**Step 2** In the Configuration Group Basic area, enter a name.

**Step 3** To display devices from which you can make selections, in the Template Selection area, add one or more templates by clicking Add and selecting the templates. This also populates the Device Type field.

**Step 4** Add additional templates by clicking Add in the Template Selection area. You cannot choose templates that are mutually-exclusive; for example, you cannot choose Add-Host-Name-IOS and Add-Host-Name-IOS-XR.

**Step 5** Select the devices on which you want to deploy the template, then click Next to choose the input option.

**Step 6** In the Device Selection area, select the devices you want to add to the configuration group.
Step 7 If you have multiple templates, the order in which templates will be listed by selecting one and clicking the up or down arrow.

Step 8 Click **Save as New Configuration Group**.

---

**Deployment Flow for Configuration Group Using the Wizard**

---

**Note** This deployment flow is not applicable for Controller based templates.

---

**Step 1** After you create a configuration group, click **Deploy**. The **Template Deployment -Prepare and Schedule** wizard page opens.

**Step 2** In the **Templates** area, view the templates that are added in the configuration group.

**Step 3** In the **Deployed on Devices** area and during creation of Configuration Group, view the devices that you have chosen during creation of configuration group.

**Step 4** In the **Value Assignment** area, from the **Select Template** drop-down list, choose a CLI template and an appropriate device. You can view the device details on which the template is going to be deployed, CLI Preview details, and so on. Click **Apply**.

**Step 5** (Optional) Schedule the deployment job in the **Schedule** area:

- Create a meaningful deployment job name, then specify whether to run the now or in the future.
- You can also schedule the job to run periodically on hourly, daily, weekly, monthly or yearly basis.
- You can configure the following job options:
  - **Failure Policy:**
    - **Ignore failure and continue**—This is the default option. The devices are randomly picked up for template deployment. If the job fails on a device, the job skips the device and continues with the remaining devices. The Job results show success/failure information for all the selected devices.
    - **Stop on failure**—If the job fails to execute on a device, the job is stopped. The job results are updated only for the devices on which the job was executed successfully and for other devices which didn’t undergo template deployment, “Not Attempted” message is shown. The order of devices chosen for deployment will be same as the device order in Value assignment pane.
    - **Copy Running Config to Startup**—If the template deployment job succeeds, the running configuration of the device is copied to startup configuration.
    - **Archive Config after deploy**—Creates a new config archive job and archives the configuration of devices after successfully deploying the template.

**Step 6** In the **Summary** area, view the summary of the deployment.

**Step 7** Click **OK** to deploy the template.

**Step 8** Click **Job Status** in the pop-up dialog box to launch the Job Dashboard to view the status of the job.
Deployment Flow for CLI Templates using the Wizard

Step 1  After creating the CLI template, click Deploy. The Deployment wizard page opens.

Step 2  Select the devices on which you want to deploy the template, then click Next to choose the input option.

Step 3  Select the devices on which you want to deploy the template from the Add devices table. The selected devices appear in the Devices to deploy table.

Step 4  Select the mode in which you want to deploy the template. The options are Work Flow and Export/Import CSV.

Step 5  Click the Work Flow option and click Next. See Step 6.

Step 6  Alternately, click Export/Import CSV option, to update all the template properties for the selected devices using the CSV Export/Import mechanism.

a) Uncheck the Do you want Optional Parameters check box, if you want to skip the optional fields while filling the configuration values in the CSV file.

b) Click Export CSV to download the CSV template to your local system.

c) Enter the configuration values for each specific device in the downloaded CSV template.

d) Click Import CSV to upload the updated CSV file. The input values automatically gets updated.

e) Click Next to input values.

Step 7  In the Input Values tab, you can toggle between Form and CLI view. Configure the following in the Input Values tab:

a) Enter all the mandatory fields for each template, then click Apply.

     If the validation is successful, then the border of the circle around the selected template changes to green.

     Note  The successful validation message means that the change has been applied only to the selected devices in the workflow. To complete the configuration, perform the remaining steps in the procedure.

Step 8  After entering the necessary configuration values, click Next or CLI to confirm the device and template configuration values.

Step 9  Schedule the deployment job using Schedule Deployment tab, if required:

• Create a meaningful deployment job name, then specify whether to run the now or in the future.

• You can also schedule the job to run periodically on hourly, daily, weekly, monthly or yearly basis.

• You can configure the following job options:

   Failure Policy:

   • Ignore failure and continue—This is the default option. The devices are randomly picked up for template deployment. If the job fails on a device, the job skips the device and continues with the remaining devices. The Job results show success/failure information for all the selected devices.

   • Stop on failure—If the job fails to execute on a device, the job is stopped. The job results are updated only for the devices on which the job was executed successfully and for other devices which didn’t undergo template deployment, “Not Attempted” message is shown. The order of devices chosen for deployment will be same as the device order in Value assignment pane.

   • Copy Running Config to Startup—If the template deployment job succeeds, the running configuration of the device is copied to startup configuration.

   • Archive Config after deploy—Creates a new config archive job and archives the configuration of devices after successfully deploying the template.
Step 10  Click Next to view the job deployment summary.

Step 11  On the Deployment Summary tab, you will see the CLI view for each of the device.

Step 12  Click Finish to deploy the template.

Step 13  Click Job Status in the pop-up dialog box to launch the Job Dashboard to view the status of the job.

---

**Deployment Flow for Composite Templates Using the Wizard**

**Step 1**  Choose Configuration > Templates > Features & Technologies > Composite Templates > Composite Templates.

**Step 2**  Enter the required information in the Template Basic section.

**Step 3**  In the Template Detail section, choose the templates to include in the composite template, and click Save as New Template.

**Step 4**  After creating the composite template, click Deploy. The Deployment wizard page opens.

**Step 5**  Select the devices on which you want to deploy the template.

**Step 6**  Select the devices on which you want to deploy the template from the Add devices table. The selected devices appear in the Devices to deploy table.

**Step 7**  Select the mode in which you want to deploy the template. The options are Work Flow and Export/Import CSV.

**Step 8**  Click the Work Flow option and click Next. See Step 6.

**Step 9**  Alternately, click Export/Import CSV option, to update all the template properties for the selected devices using the CSV Export/Import mechanism.

   a) Uncheck the Do you want Optional Parameters check box, if you want to skip the optional fields while filling the configuration values in the CSV file.

   b) Click Export CSV to download the CSV template to your local system.

   c) Enter the configuration values for each specific device in the downloaded CSV template.

   d) Click Import CSV to upload the updated CSV file. The input values automatically gets updated.

   e) Click Next to input values.

**Step 10**  In the Input Values tab, you can toggle between Form and CLI view. Configure the following in the Input Values tab:

   a) Select templates for a device from the navigation widget. To select templates, click the circle (T1, T2, T3, T4, T5 ...) in the upper right corner. If there are more than five templates, click three dots. The drop-down list will pop-up with all the available templates.

   b) Enter all the mandatory fields for each template, then click Apply.

      If the validation is successful, then the border of the circle around the selected template changes to green and green tick mark appears adjacent to the selected templates for the available templates in the popup.

**Step 11**  After entering the necessary configuration values, click Next or CLI to confirm the device and template configuration values.

**Step 12**  Schedule the deployment job using Schedule Deployment tab, if required:

   • Create a meaningful deployment job name, then specify whether to run the now or in the future.

   • You can also schedule the job to run periodically on hourly, daily, weekly, monthly or yearly basis.

   • You can configure the following job options:
Success policy:

- **Ignore failure and continue**—This is the default option. The devices are randomly picked up for template deployment. If the job fails on a device, the job skips the device and continues with the remaining devices. The Job results show success/failure information for all the selected devices.

- **Stop on failure**—If the job fails to execute on a device, the job is stopped. The job results are updated only for the devices on which the job was executed successfully and for other devices which didn’t undergo template deployment, “Not Attempted” message is shown. The order of devices chosen for deployment will be same as the device order in Value assignment pane.

- **Copy Running Config to Startup**—If the template deployment job succeeds, the running configuration of the device is copied to startup configuration.

- **Archive Config after deploy**—Creates a new config archive job and archives the configuration of devices after successfully deploying the template.

**Step 13**  
Click Next to view the job deployment summary.

**Step 14**  
On the Deployment Summary tab, you will see the CLI view for each of the device.

**Step 15**  
Click Finish to deploy the template.

**Step 16**  
Click Job Status in the pop-up dialog box to launch the Job Dashboard to view the status of the job.

---

**Deploy Templates to Devices Without Using Configuration Groups**

Once a template is saved, it can be deployed (run on) devices. You can deploy a template from the Configuration > Templates > Features & Technologies navigation area, or by using Configuration Groups, which is launched from Configuration > Templates > Configuration Groups (see Create Configuration Groups for Deploying Templates to Groups of Devices, on page 421).

To deploy a customized or system template from the Features & Technologies navigation area:

**Step 1**  
Choose Configuration > Templates > Features & Technologies

**Step 2**  
Expand the drawer that contains the template(s) you want to deploy.

**Step 3**  
Choose the templates you want to deploy, and click Deploy.

**Step 4**  
In the Template Deployment window, check the settings and schedule and click OK.

---

**Check the Status and Results of a Deployed Configuration Template**

When you deploy a configuration template, Cisco EPN Manager displays a dialog box with a hyperlink that directs you to the Jobs window. From here you can:

- View the results of the command by clicking the History tab and expanding the job instance.
- Repeat the deployment, or schedule it for a later time.
• Manage the job (delete it, pause it, resume it, and so forth).
CHAPTER 14

Manage Cable Devices

- Manage Cable Devices, on page 427
- Cable Management Features and Supported User Groups, on page 429
- Configure Client Credentials for Cable Devices, on page 431
- Add a New Vendor OUI Mapping, on page 432
- Add Cable Devices, on page 433
- Manage Cisco cBR-8 and RPDs Association, on page 433
- Smart PHY Global Settings, on page 439
- RPD 360 view, on page 440
- Manage Cable Service Definitions, on page 441
- View and Export Cable Device Information and Configuration Details, on page 445
- Monitor the Health of RPD to cBR-8 Links, on page 447
- Fiber Node Utilization of cBR-8 device, on page 448
- View the Cable Dashboard, on page 450
- Visualize the Topology of Cable Devices on the Network Topology, on page 451
- RPD MIB and Supported Alarms, on page 452
- Troubleshooting Cable Devices, on page 452

Manage Cable Devices

The Cisco cBR-8 Converged Broadband Router (Cisco cBR-8) is a 13 rack unit (RU) chassis. It supports multiple card modules and is designed with back-to-back midplanes; a front facing Digital Midplane and a rear facing RF Midplane. In a cable network with the Remote PHY architecture, multiple Remote PHY Devices (RPDs) connect to Cisco cBR-8 devices based on the Data Over Cable Systems Interface Standard (DOCSIS) and EuroDOCSIS standards that define two-way operation over the cable network.

Remote PHY is an architectural strategy that removes the PHY element from a product and places that PHY element in a separate access point interconnected with an IP network. The Cisco Remote-PHY solution leverages existing IP technologies like Ethernet PON (EPON), Gigabit-capable Passive Optical Networks (GPON), and Metro Ethernet (MetroE) equipment; it deploys DOCSIS in Multi Dwelling Units (MDUs) over digital fiber to enable two-way services over cable.

Using Cisco EPN Manager, you can add and discover Cisco cBR-8 and devices and RPDs, view their L2TP links and topology on the network topology, and further configure them. You can also continuously monitor the health of RPDs to Cisco cBR-8 device links. See Manage Cisco cBR-8 and RPDs Association, on page 433.
Cisco EPN Manager, enables you to create service definitions with profiles such as events profiles, downstream and upstream controller profiles, to associate the definitions with RPDs in bulk. As part of the service definition, you can also configure the Remote PHY timing values for the RPD, using the Remote DTI (R-DTI) protocol. To configure the R-DTI profile and other service definition parameters, see Manage Cable Service Definitions, on page 441.

For more information about cBR-8 devices, see http://www.cisco.com/c/en/us/td/docs/cable/cbr/cisco-cbr/index.html:

The process of managing cable devices in Cisco EPN Manager involves:

1. Ensuring that the cBR-8 devices and Cisco Smart PHY are up and available for configuring.
2. Configuring the required access in Cisco EPN Manager by providing Cisco Smart PHY credentials.
3. Adding the cBR-8 device and ensuring that the inventory collection status for the device is 'Completed'. See Add Devices to Cisco EPN Manager, on page 35
4. Adding RPD information to Cisco EPN Manager either manually or by importing RPD details from a CSV file.
5. Ensuring that the status of CBR-8 and RPD pairing is Online.
6. (Optional) Creating service definitions or using the default service definition and applying them to the RPDs.
7. (Optional) Monitoring the devices using the network topology to view the alarm and link information.

Features and Limitations

Cisco EPN Manager supports the following features to manage cable devices:

• Importing RPD cBR-8 pairing details in bulk.
• Monitoring and visualizing RPD to cBR-8 L2TP links in the network topology.
• Ability to place unmapped cable devices on the network topology.
• Creating service definitions and associating them with RPDs.
• Managing software images on cBR-8 devices.
• Performing configuration audit using compliance for cBR-8 devices.
• Viewing cBR-8 device 360, interface 360, and RPD 360 information.
• Viewing cBR-8 device details in the chassis view.
• Viewing cable device syslogs.
• Service group configuration details and Fiber Node utilization dashboard.
• Viewing RPD Traps.
• Viewing part of network topology based on user defined geographical location, device location and radius.
- Viewing cable modem details under serving RPD and also with associated Fiber Node.
- LLDP based discovery of cable devices.
- Configuring Cisco Smart PHY with Cisco EPN Manager.

Cable Management Features and Supported User Groups

The following table lists the various cBR-8 and RPD management tasks supported by Cisco EPN Manager and the supported user groups. See View and Change the Tasks a Group Can Perform, on page 752 for information on the tasks that pertain to each user group and the default settings.

Table 30: Cable Management Features and Supported User Groups

<table>
<thead>
<tr>
<th>Cable Management Features</th>
<th>Root/Super Users</th>
<th>Admin Users</th>
<th>Config Managers</th>
<th>System Monitor</th>
<th>Monitor Lite</th>
<th>NBI Credentials</th>
<th>NBI Read</th>
<th>NBI Write</th>
<th>NBI Assistant</th>
<th>Other Users</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding, editing, deleting, importing, and clearing RPDs. Editing RPD data using the inline editing option.</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>Yes</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Viewing the Cable RPD Association page and the Cable Service Definitions page</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>–</td>
<td>Yes</td>
<td>–</td>
<td>–</td>
<td>Yes</td>
<td>–</td>
</tr>
<tr>
<td>Listing RPDs.</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>–</td>
<td>Yes</td>
<td>–</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Exporting RPDs.</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>–</td>
<td>–</td>
<td>Yes</td>
<td>–</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Jobs menu, launch from Options menu (geo map location, assign/manage service definitions, global settings, network topology)</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Launch from Geo Map (RPD Association page, Manage Service Definition page)</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Cable Management Features</td>
<td>Root/ Super Users</td>
<td>Admin Users</td>
<td>Config Managers</td>
<td>System Monitor</td>
<td>Monitor Lite</td>
<td>NBI Credentials</td>
<td>NBI Read</td>
<td>NBI Write</td>
<td>NBI Assistant</td>
<td>User Assistant</td>
</tr>
<tr>
<td>---------------------------</td>
<td>------------------</td>
<td>-------------</td>
<td>-----------------</td>
<td>----------------</td>
<td>--------------</td>
<td>----------------</td>
<td>----------</td>
<td>------------</td>
<td>----------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Viewing cable devices in the network topology</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>-</td>
<td>-</td>
<td>Yes</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Launching, viewing, adding, and editing Cable Application (Cisco Smart PHY) client credentials.</td>
<td>Yes</td>
<td>Yes</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>Yes (only viewing details is permitted)</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Viewing Cisco cBR-8 device information (in the Configuration tab) such as the device’s license usage status, available sensor readings, IPv4 and IPv6 statistics, voice calls count, fan and power supply status, and other generic data. Also view slot level information such as FPGA/CPLD version numbers.</td>
<td>Yes</td>
<td>-</td>
<td>Yes</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>Yes</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>View Cisco cBR-8 device performance information (in the Performance tab) in the linecard upstream and downstream dashlet, power supply dashlet, CPU and memory utilization dashlet, fan tray dashlet, along with other general configuration details.</td>
<td>Yes</td>
<td>-</td>
<td>Yes</td>
<td>Yes</td>
<td>-</td>
<td>-</td>
<td>Yes</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Listing Service Definitions</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>-</td>
<td>Yes</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>
### Cable Management Features

<table>
<thead>
<tr>
<th>Root/ Super Users</th>
<th>Admin Users</th>
<th>Config Managers</th>
<th>System Monitor</th>
<th>Monitor Lite</th>
<th>NBI Credentials</th>
<th>NBI Read</th>
<th>NBI Write</th>
<th>NBI Assistant</th>
<th>Other Users</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>Yes</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

#### Creating, copying and deleting service definitions. Updating and assigning service definitions to RPDs. RPD assign (up arrow link).

#### Cable Dashboard settings (launch cBR-8 dashboard, access software version, license usage and status, cable modem, RPD status, FPGA version, alarm dashboard, cable modem, count by vendor and categories)

#### Smart PHY Global Settings (launching, RPD Global configuration, software compatibility)

#### Utilization tab (launching, configure thresholds, DS/US Channel popover, RPD/Modem popover, exporting table)

---

### Configure Client Credentials for Cable Devices

To manage Cisco cBR-8 devices and Cisco Remote-PHY devices (RPDs), you must first configure the Cisco Smart PHY client credentials. This enables Cisco EPN Manager to set up a connection with the Cisco Smart PHY application.

To configure Cisco Smart PHY credentials:
Before you begin

Ensure that you log in with the required credentials for configuring the Cisco Smart PHY client credentials. For information on the user groups and supported tasks, see Cable Management Features and Supported User Groups, on page 429.

For more information about Cisco Smart PHY, see https://www.cisco.com/c/en/us/td/docs/cable/cbr/administration/guide/cisco_smart_phy_application_user_guide/information_about_cisco_sdns_application.html.

Note: The Cisco Smart PHY application must not be configured with more than one Cisco EPN Manager server. If the Smart PHY credentials have to be updated, it is recommended that the RPDs are removed from Cisco EPN Manager before configuring the credentials in the Admin Settings page.

---

**Add a New Vendor OUI Mapping**

Cisco EPN Manager relies on the IEEE Organizational Unique Identifier (OUI) database to identify the client vendor name mapping. The User Defined OUI List page displays a list of vendor OUI mappings that user has created. When an OUI is added, Cisco EPN Manager verifies to see if the OUI exists in the IEEE database. If the OUI exists, Cisco EPN Manager updates the vendor name for the OUI. If the OUI does not exist, a new OUI entry is added to the vendor OUI mapping.

To add a new vendor OUI mapping:

---

**Add a New Vendor OUI Mapping**

**Step 1**

From the left sidebar, choose Administration > Settings > System Settings.

**Step 2**

Click Client and User and select Cisco Smart PHY Credentials.

**Step 3**

Specify the following Cable Application credentials:

a) IP Address or DNS name—The IPv4 address of the client or the DNS hostname of the Cisco Smart PHY application.

b) Port—Numeric port number for communication between the device and Cisco EPN Manager.

c) User name and password—Specify the login credentials to login to the client. You will need to re-enter the password for verification.

**Step 4**

Click Save to enable the client credentials.

You can now add CBR-8 to RPD pairing information and associate RPDs with cable service definitions. See Assign Cable Service Definitions to RPD, on page 443.

**Step 5**

Click Delete to remove an existing Smart PHY credential information from the Cisco EPN Manager database.

---

**Add a New Vendor OUI Mapping**

**Step 1**

Go to Administration > System Settings.

**Step 2**

From the left sidebar menu, click Client and User and select User Defined OUI. The User Defined OUI page is displayed.

**Step 3**

From the drop-down list on the right hand side, choose Add OUI Entries, and click Go.

**Step 4**

In the OUI field, enter a valid OUI.

**Step 5**

Click Check to verify if the OUI exists in the vendor OUI mapping.

**Step 6**

In the Name field, enter the display name of the vendor for the OUI.
Step 7: Select the **Change Vendor Name** check box to update the display name of the vendor, if the OUI exists in the vendor OUI mapping.

Step 8: Click **OK**.

### Upload an Updated Vendor OUI Mapping File

To upload the updated vendor OUI mapping file:

**Step 1:** Go to **Administration > System Settings**.

**Step 2:** From left sidebar menu, select **Client and User** and click **Upload OUI**.

**Step 3:** Choose **Update online from IEEE** option. This will download the latest OUI mapping file.

**Step 4:** Click **OK**.

### Add Cable Devices

Add the required cBR-8 devices to Cisco EPN Manager by device discovery, manual addition, or by importing device details using a CSV file. For more information about adding devices, see Add Devices to Cisco EPN Manager, on page 35.

After you add devices, and before you configure cable devices, you must first ensure that the inventory collection status for the devices is **Completed**. You can then proceed with adding RPDs and associating them with the cable devices. See Manage Cisco cBR-8 and RPDs Association, on page 433.

### Manage Cisco cBR-8 and RPDs Association

You can use Cisco EPN Manager to monitor and discover RPDs from Cisco cBR-8 devices. Once the devices are discovered, the pairing between the devices must be established as explained in the sections below.

Launch the Cable RPD Association page in one of the following ways:

- From the **Configuration > Cable > RPD Association** option in the left navigation panel.

- From the **Cable** drop-down menu in the network topology.

**RPD Auto Discovery:** As part of the Cisco cBR-8 device discovery, RPDs associated with the devices are automatically added to the Cisco EPN Manager database. In this scenario, you do not need to add or import the RPDs as shown below, however, the RPD will be visible in the **RPD Association** page with only minimal information.

---

**Note**

Only RPDs with Principal Role will be automatically discovered.

Manage cBR-8 devices and RPDs in the following ways:
Add cBR-8 and RPDs Pairing Information

Before you can manage Cisco cBR-8 devices and RPDs, you need to first discover the cBR-8 - RPDs pairing information to Cisco EPN Manager from the Cisco cBR-8 devices.

When Cisco cBR-8 devices are in sync with Cisco EPN Manager with a pending integration with the Cisco Smart PHY, the auto discovered service definitions (associated with RPDs) cannot be edited. Once the integration with the Cisco Smart PHY is complete, the service definitions that are marked as 'None' are auto assigned to the default service definition.

**Link Utilization:** After the pairing of the devices has been established, you can view the topology of the cable network in the network topology and monitor the health of the links between the devices. To do this:

<table>
<thead>
<tr>
<th>Manage cBR-8 to RPD Pairing</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add CBR-8 to RPDs pairing information manually</td>
<td>Add cBR-8 and RPDs Pairing Information Manually, on page 435</td>
</tr>
<tr>
<td>Import CBR-8 to RPDs pairing information using a CSV file</td>
<td>Import cBR-8 and RPDs Pairing Information in Bulk, on page 436</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Delete RPDs</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. From the left sidebar, choose <strong>Configuration &gt; Cable &gt; RPD Association.</strong></td>
<td></td>
</tr>
<tr>
<td>2. Select the RPDs you want to delete, and click the 'Delete' icon from the toolbar. Deleting RPDs will delete the associated links with Cisco cBR-8 devices and thus update the Cisco cBR-8 RPD links view in network topology.</td>
<td><strong>Note</strong> Once you delete a Cisco cBR-8 device, the RPDs associated with those devices are also deleted from Cisco EPN Manager. Bulk delete operations can be monitored using the Jobs feature. For more information, see <strong>RPD Job Status Summary, on page 436.</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Edit RPD</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. From the left sidebar, choose <strong>Configuration &gt; Cable &gt; RPD Association.</strong></td>
<td></td>
</tr>
<tr>
<td>2. Select the RPD you want to edit, and click the 'Edit' icon from the toolbar.</td>
<td></td>
</tr>
<tr>
<td>3. Make the required changes to the parameters. For more information about these parameters, see <strong>RPD Device Parameters and Descriptions, on page 437.</strong></td>
<td><strong>Note</strong> The RPD name may fail in Cisco EPN Manager if the RPD to be edited does not exist in Smart PHY. For more information, see <strong>Troubleshooting Cable Devices, on page 452.</strong></td>
</tr>
<tr>
<td>4. Click <strong>Save</strong> to update your changes. You can check the Service Status icon again to see the updated status.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Apply service definitions to RPD(s)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assign Cable Service Definitions to RPD, on page 443</td>
<td></td>
</tr>
</tbody>
</table>

2. Use the Cable drop-down menu to filter Cable devices. By default, the physical links between the Cisco cBR-devices and the RPDs are displayed.

3. Use the Show option and choose Links to filter Physical or L2TP links.

   For cable L2TP links, L2TP utilization (for available L2TP tunnels) is calculated per RPD by getting the OFDM channels utilization of the associated downstream controller. For more information, see, Show Bandwidth Utilization for Links on the Map, on page 173.

Pre-requisites:

- Add cBR-8 devices to Cisco EPN Manager. See Add Devices to Cisco EPN Manager, on page 35.
- Ensure that the inventory collection status for the cBR-8 device (associated with the RPDs you are importing) is 'Completed'.
- Ensure that you configure the Cisco Smart PHY client credentials. See Configure Client Credentials for Cable Devices, on page 431.

Add cBR-8 and RPDs Pairing Information Manually

To import cBR-8 and RPDs pairing information manually:

Step 1  From the left sidebar, choose Configuration > Cable > RPD Association.

Step 2  Click the + (Add) icon.

Step 3  Enter the RPDs parameters as described in RPD Device Parameters and Descriptions, on page 437 and click Save.

   Note  RPDs with only Name or MAC ID can also be added.

Step 4  To verify that the entered RPDs information is accurate:

   a) Hover over the Service Status icon for each RPD to understand the status of the pairing between the cBR-8 device and the RDP. To understand what each service state means, see Monitor the Health of RPD to cBR-8 Links, on page 447.

   b) To modify the parameters, click on the respective parameters and make the required changes.

   c) Click Save again to update your changes. You can then check the Service Status icon again to see the updated status.

Step 5  Click Clear to clear the association of CCAP Core and CCAP Core Interface for the selected RPDs.

Step 6  (Optional) Click the i (information) icon from the RPD MAC ID column to launch the RPD 360 view for the selected RPD. For more information, see RPD 360 view, on page 440

   Note  • RPDs should have MAC ID, Name, and configured Smart PHY settings to launch the RPD 360 view.

   • RPD 360 view is not available for auto-discovered RPDs with service definition name as UNKNOWN.

Step 7  (Optional) In RPD Association page, click the Options drop down menu and select the following shortcuts to launch the relevant pages:

   a) Click Apply Geo Map Location Filter to launch the Geographical Location Filter. For more information, see Filter RPDs by Geographical Location, on page 438.

   b) Click Assign Service Definition to assign service definitions to selected RPD(s). For more information, see Assign Cable Service Definitions to RPD, on page 443.
c) Click **Manage Service Definition** to view and modify the service definitions. For more information, see *Manage Cable Service Definitions, on page 441*

d) Click **Go to Global Settings** to view and modify the Smart PHY Global settings. For more information, see *Smart PHY Global Settings, on page 439*

e) Click **View Network Topology** to launch the topology view of the RPD.

---

**Import cBR-8 and RPDs Pairing Information in Bulk**

Cisco EPN Manager compares your entries with the current database to check for duplicate entries. If your entries are duplicate, the parameters that match are highlighted and you can choose to replace the existing entries one by one, in bulk, or skip the import operation altogether.

To import cBR-8 and RPDs pairing information using a CSV file:

**Step 1**

From the left sidebar, choose **Configuration > Cable > RPD Association**.

**Step 2**

Click the 'Import' icon.

**Step 3**

Use the template supported by Cisco EPN Manager for importing RPD information by following these steps:

a) Click the Download the 'Associate RPDs' template (*.csv) hyperlink to download a sample template for importing cBR-8 and RPDs pairing information in bulk.

b) Choose a location on your system where the file must be saved, and click **OK**.

**Step 4**

To import the cBR-8 and RPDs pairing information:

a) Ensure that the CSV file you are using to import is of the same template as the CSV file downloaded in Step 3 above.

   **Note**  
   RPD Name and MAC ID must be specified in the CSV file before you import.

b) Click the 'Import' icon.

c) Click **Browse** and locate the CSV file that you want to import.

d) Click **Import**.

   **Note**  
   You can also import the CSV file exported from Smart PHY application, by following the above step.

**Step 5**

To view status of bulk operations (Import/Export/Delete), click the **Jobs** button. For more information, see *RPD Job Status Summary, on page 436*.

**Step 6**

(Optional) Verify that the RPDs information imported is accurate:

a) Hover over the Status icon for each RPD to understand the status of the pairing between the cBR-8 device and the RPD. To understand what each service state means, see *Monitor the Health of RPD to cBR-8 Links, on page 447*.

b) To modify the parameters, click on the respective parameters and make the changes. For more information about the RPDs parameters, see *RPD Device Parameters and Descriptions, on page 437*.

c) Click **Save** to update your changes. You can then check the Service Status icon again to see the updated status.

---

**RPD Job Status Summary**

In a typical large network, there are several thousands of RPDs that get deployed to the system. The status of these bulk operations (bulk import/export/delete) can be monitored using the Jobs feature, that will display the list of jobs in the last 24 hours and their operational status.
In the RPD Association page, click the Jobs button and the Job Status Summary window is displayed. For every job status change, notifications are displayed on the job button (within 2 minutes). For more information about a successful/failed operation, click on View Details.

**Note**

The RPD Association page needs to be manually refreshed after every bulk import/delete operation to reflect the change.

The Jobs Status Summary window provides color-coded notifications to differentiate the status of the job:

*Table 31: Job Status Summary*

<table>
<thead>
<tr>
<th>Icon color</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>⬤</td>
<td>Job scheduled/ in progress</td>
</tr>
<tr>
<td>✔</td>
<td>Job successful</td>
</tr>
<tr>
<td>✗</td>
<td>Job failed</td>
</tr>
</tbody>
</table>

**RPD Device Parameters and Descriptions**

<table>
<thead>
<tr>
<th>RPD Device Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status</td>
<td>Status of the RPD device.</td>
</tr>
<tr>
<td>RPD Name</td>
<td>Hostname of the RPD device.</td>
</tr>
<tr>
<td>RPD MAC ID</td>
<td>MAC ID of the RPD.</td>
</tr>
<tr>
<td>Service Definition</td>
<td>Cisco EPN Manager cable service definition applied to the RPD.</td>
</tr>
<tr>
<td></td>
<td>When the Cisco Smart PHY client is not configured, this field is marked as 'Unknown'. This is applicable for auto-discovered RPDs.</td>
</tr>
<tr>
<td>CCAP Core</td>
<td>The Cisco cBR-8 device that the selected RPD should connect to.</td>
</tr>
<tr>
<td>CCAP Core Interface</td>
<td>Interface of the cBR-8 device that is physically connected to the RPD.</td>
</tr>
<tr>
<td>Downstream Data Service Group</td>
<td>All RPDs with the same data service group will share the Downstream controller for Data Service (Virtual Splitting for Data).</td>
</tr>
<tr>
<td>Upstream Data Service Group</td>
<td>All RPDs with the same data service group will share the Upstream controller for Data Service (Virtual Splitting for Data).</td>
</tr>
<tr>
<td>Data Primary RPD US Port</td>
<td>Value of this column can be 0, 1 or empty (no value). The value of this column must be same as the OOB Primary RPD US Port column.</td>
</tr>
<tr>
<td>Narrowcast Video Interface</td>
<td>Complete name of the TenGigabitEthernet DPIC Interface to be used for Narrowcast Video Service</td>
</tr>
</tbody>
</table>
### RPD Device Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Narrowcast Video Service Group</td>
<td>All RPDs with the same video service group will share the Narrowcast controller for Video Service.</td>
</tr>
<tr>
<td>Broadcast Video Interface</td>
<td>Complete name of the TenGigabitEthernet DPIC Interface to be used for Broadcast Video Service. Cannot be same as the Video Interface.</td>
</tr>
<tr>
<td>Broadcast Video Service Group</td>
<td>All RPDs with the same video service group will share the Broadcast controller for Video Service.</td>
</tr>
<tr>
<td>Out of Band Interface</td>
<td>Complete name of the TenGigabitEthernet DPIC Interface to be used for Out of Band Interface.</td>
</tr>
<tr>
<td>OOB Primary RPD US Port</td>
<td>Value of this column can be 0, 1 or empty (no value). The value of this column must be same as the Date Primary RPD US Port column.</td>
</tr>
<tr>
<td>Additional Cores</td>
<td>List of additional cores the RPD should connect to</td>
</tr>
<tr>
<td>Cable DSG TGs</td>
<td>Advanced-Mode DOCSIS Set-Top Gateway (A-DSG) tunnels associated to one or more downstream interfaces.</td>
</tr>
<tr>
<td>RPD Latitude</td>
<td>Represents the location coordinate of the RPD.</td>
</tr>
<tr>
<td>RPD Longitude</td>
<td>Represents the location coordinate of the RPD.</td>
</tr>
<tr>
<td>Pre Configure</td>
<td>This column is read-only, and is always set to true to ensure that the Cisco Smart PHY application validates a preconfiguration that is available on the Cisco eBR-8 router and applies the configuration immediately. This process saves the time in bringing the RPD online.</td>
</tr>
<tr>
<td>RPD Description</td>
<td>Description of the RPD device.</td>
</tr>
<tr>
<td>Information (i) icon</td>
<td>The information (i) icon allows you to launch the 360 view (RPD 360, Device 360, and Interface 360) for the selected Cisco eBR-8 device and its associated interfaces. For more information, see Get Basic Device Information: Device 360 View, on page 69.</td>
</tr>
</tbody>
</table>

### Filter RPDs by Geographical Location

Large volumes of RPDs can be efficiently handled by filtering them using their geographical location.

To use the geo filter:

#### Step 1
In the RPD Association page (Configuration > Cable > RPD Association), click on Options and select Apply Geo Map Location Filter. The geo filter settings from Topology page is displayed.

#### Step 2
Click the Apply to this page checkbox to apply the filter to the list of RPDs in the RPD Association page. A message "Location Filter Applied" is displayed to notify about the filter operation. If the checkbox is unchecked, the filter is removed and the entire RPD list is displayed.

#### Step 3
To edit or enable the geo filter (if the geo filter is disabled), click on Edit Filter on Geo Map. The navigation moves to the Network Topology page. For more information, see Location Filter in the Geo Map, on page 189.
Step 4  (Optional) After editing/enabling the geo map filter in Network Topology page, click on Cable > Associate RPDs to navigate to the RPD Association page.

---

## Smart PHY Global Settings

Cisco EPN Manager allows you to view and manage the Smart PHY Global settings.

Launch the Smart PHY Global Settings page in one of the following ways:

- From the Configuration > Cable > Smart PHY Global Settings option in the left navigation panel.
- In RPD Association page, click on Options > Go to Global Settings.
- In Network Topology page, click on Cable > Go to Global Settings.

## RPD Global Configuration

Cisco EPN Manager allows you to view and manage the RPD Global Configuration.

### Step 1

In the **Smart PHY Global Settings** page, choose the following parameters according to your requirement:

- **Configure Static Route**: Cisco Smart PHY application option adds a static route configuration on the cBR-8 device for IPv4/IPv6 network interfaces configured on the DPIC.
- **Validate Software Compatibility**: Cisco Smart PHY application checks the compatibility between the RPD version and the Cisco cBR-8 device version specified in the table.
- **Persist Running Configuration**: Cisco Smart PHY application makes the configuration persistent for every change made on the Cisco cBR-8 device.

The **Save Interval** option is enabled when Persist Running Configuration is enabled. The value can be a unique integer ranging from 10 to 10800.

### Step 2

Click **Save** to update your changes.

---

## Software Compatibility

Smart PHY Global Settings allows you to add, edit, or delete the software compatibility matrix. Fields that are not marked as optional are mandatory.

The Software Compatibility window displays a compatibility matrix for the RPD software versions and the Cisco cBR software versions. The Smart PHY application detects the software incompatibility between an RPD and a Cisco cBR-8 router, and alerts you about the incompatibility. After the alert appears, you can either manually upgrade the RPD software version or upgrade it through the Smart PHY application.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RPD Vendor</td>
<td>Name of the RPD Vendor.</td>
</tr>
</tbody>
</table>
RDP 360 view

The RDP 360 view is a pop-up window that provides quick information about the RPD, its inventory, and its status. This includes service groups, sessions, history and modem list.

Launch the RDP 360 page in one of the following ways:

- In **RPD Association** page, click the *i* icon in the **RPD MAC ID** column.
- In the **Cable Dashboard** page (**Dashboard > Cable > cBR-8 Dashboard**), select the 'RPD chart' to view the device list. Click the *i* icon in the **RPD IP Address** column.
- In the **Network Topology** page (**Maps > Network Topology**), select any RPD and click the **View 360** option.
- In the **Utilization** page, open the **RPD Count** window and click the *i* icon in the **RPD Name** field.

The RDP 360 view provides general device and performance information at the top of the view, and more detailed interface information in tabs in the lower part of the view.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RPD Software Version</td>
<td>Software version running on the RPD.</td>
</tr>
<tr>
<td>Router Vendor</td>
<td>Router Product type from the inventory.</td>
</tr>
<tr>
<td>Router Software Version</td>
<td>Software version of the router.</td>
</tr>
</tbody>
</table>
Table 33: RPD 360 view information

<table>
<thead>
<tr>
<th>Information provided in RPD 360 view</th>
<th>Description</th>
</tr>
</thead>
</table>
| General information                  | Attributes such as:  
  • RPD Name  
  • RPD Status (conveyed by the icon)  
  • Description  
  • MAC Address  
  • IP Address  
  • Associated cBR-8  
  • Interface  
  • Service Definition  
  • Lat. | Long.  
  • Serial Number  
  • Product Type  
  • Vendor  
  • Software  

  Note: 'None' will be displayed for attributes without any value. |
| Service Groups tab                   | Channel interface and the relevant service group information.  
  Note: 'Data not configured' is displayed if there are no values to display. |
| Sessions tab                         | Available DEPI sessions for the selected RPD.  
| History tab                          | Status history of the selected RPD.  
| Modems tab                           | List of modems serving under the selected RPD.  

Note: If 'No data available' is displayed for all the tabs (except the Modems tab), then the RPD is not available in Smart PHY.

Manage Cable Service Definitions

Cisco EPN Manager cable service definitions enable you to associate event and data service profile related information directly with one or multiple RPDs in bulk.
Launch the Service Definitions page in the following ways:

- Go to Configuration > Cable > Service Definitions
- In the RPD Association page, click Options and select Manage Service Definition.
- In the Network Topology page, click Cable drop-down menu and select Manage Service Definition.

You can manage cable service definitions in the following ways:

<table>
<thead>
<tr>
<th>Manage Cable Service Definitions</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create and edit cable service definitions</td>
<td>See Create and Edit Cable Service Definitions, on page 442.</td>
</tr>
</tbody>
</table>

**Copy service definitions**

1. From the left sidebar, choose Configuration > Cable > Service Definitions.
2. Select the Service Definitions you want to copy, and click Save Copy.
   The parameters of the selected service definition are populated onto a new service definition. You can modify the parameters, if required, and then save. Ensure that the names of the service definitions are unique.

**Delete cable service definitions**

1. From the left sidebar, choose Configuration > Cable > Service Definitions.
2. Select the Service Definitions you want to delete, and click Delete.
   **Note** You cannot delete default service definitions and the service definitions assigned to RPD(s). To delete a service definition, you must reassign the associated RPD(s) and assign a different service definition as the default before you can delete it.

**Set a new cable service definition as the default**

1. From the left sidebar, choose Configuration > Cable > Service Definitions.
2. Select the Service Definitions that must be set as the default.
3. Enable the Set as Default checkbox.
4. Click Update and Assign.
   **Note** When you import RPD information using a CSV file and leave the Service Definition field blank, the default service definition is automatically associated with the RPD(s).

---

**Create and Edit Cable Service Definitions**

To create cable service definitions:

**Step 1** From the left sidebar, choose Configuration > Cable > Service Definitions.

**Step 2** Click + Create New from the navigation panel on the left.
Step 3 Specify the service definition parameters as described in Cable Service Definition Parameters and Descriptions, on page 443.

Step 4 Click Save to save the definition or Save and Assign to assign the new definition to RPD(s) immediately. You can also further assign saved definitions to RPDs as described in Assign Cable Service Definitions to RPD, on page 443.

Assign Cable Service Definitions to RPD

Assign cable service definition to RPD(s) in the following ways:

- Using the Cisco EPN Manager GUI to select the service definition that must be assigned to the RPD(s).
- Importing RPD information using a CSV file that specifies the names of the service definitions associated with the MAC ID of the RPD(s).

To assign cable service definition to RPD(s):

Before you begin

- Add cBR-8 devices to Cisco EPN Manager and ensure that the inventory collection status for the devices is ‘Completed’. See Add Devices to Cisco EPN Manager, on page 35.

Step 1 From the left sidebar, choose Configuration > Cable > RPD Association.

Step 2 To select service definition and then apply them to RPD(s):

a) Click Options and select the Assign Service Definition.

b) Select the required Service Definition from the panel on the left and then select the required RPD(s) from the Cable Associate RPD(s) table.

c) Click Assign.

Step 3 To import service definition (associated with RPD) using a CSV file:

a) Follow the steps described in Import cBR-8 and RPDs Pairing Information in Bulk, on page 436.

b) Ensure that the Service definition field in the CSV file accurately represents the exact name of the service definition associated with the RPD(s).

Step 4 (Optional) To verify, check the numeric value displayed alongside the service definition. This number represents the total number of RPD(s) to which the service definition is assigned.

Cable Service Definition Parameters and Descriptions

The table below describes the parameters and values used in cable service definitions.

<table>
<thead>
<tr>
<th>Cable Service Definition Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the service definition. This name can be used to associate RPD(s) to service definitions automatically while importing RPD data into Cisco EPN Manager.</td>
</tr>
<tr>
<td><strong>Cable Service Definition Parameters</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Description (Optional)</td>
<td>A description that explains the purpose of the service profile.</td>
</tr>
<tr>
<td>Event Profile</td>
<td>Specifies the event parameter for RPD(s) associated with this service definition. Range from 0 to 63.</td>
</tr>
<tr>
<td>R-DTI Profile</td>
<td>Remote DOCSIS Timing Interface (R-DTI) Set. Defines the RFC 1588 clock profile parameters for the RPD. Range from 1 to 64.</td>
</tr>
<tr>
<td>Pilot Tone Profile</td>
<td>Specifies Pilot Tone Profile parameter for RPD(s). Range from 0 to 511.</td>
</tr>
<tr>
<td>Cable DSG TGs</td>
<td>Range from 1 to 65535, separated by semicolon (;).</td>
</tr>
</tbody>
</table>

**Primary Service Parameters**

| **Service Group Profile**          | Defines the channels and bonding parameters for the RPD(s) associated with this service definition. |
| **Downstream Controller Profile**  | Specified the RF parameter for Downstream Data Channel(s). Range from 0 to 255. |
| **Upstream Controller Profile**    | Specified the RF parameter for Upstream Data Channel(s). Range from 0 to 511. |
| **Enable MAC Domain Splitting**    | Enables the segregation of Upstream and Downstream data channels, used for multicast traffic. |

**Video Service Parameters (Optional)**

| **Narrowcast Video Controller Profile** | Specifies RF parameters for Narrowcast (Downstream Video Controller Profile) data channels. Range from 0 to 255. |
| **Broadcast Video Controller Profile** | Specifies the RF parameters for Broadcast (Downstream Video Controller Profile) data channels. Range from 0 to 255. |

**Out Of Band Parameters (Optional)**

**Note** You must choose to fill either all of the Out of Band parameter fields, or none at all.

| **Downstream VOM ID**           | ID required to configure the RPD to use OOB. This value specifies the RF parameters for out of band downstream VOM channels. Range from 0 to 10. |
| **Downstream and Upstream Profile IDs** | Specifies the RF parameters for out of band downstream/upstream profile channels. Range from 0 to 511. |
| **Upstream VARPD ID**           | Specifies the RF parameters for out of band upstream VARPD channels. Range from 1 to 32. |
View and Export Cable Device Information and Configuration Details

Using the Cisco EPN Manager Chassis View, you can view Cisco cBR-8 device information such as the device’s license usage status, sensor readings, IPv4 and IPv6 statistics, bandwidth utilization on the different channels and controllers, fan and power supply status, and more. You can also view slot level information such as FPGA/CPLD version numbers.

To view device and chassis information described in the table below:

Before you begin

To ensure that information is collected and reported for the Cisco cBR-8 routers in your network, verify that Cable Policies is listed on the Monitoring Policies page (Monitor > Monitoring Tools > Monitoring Policies > Policies pane), is currently active, and has polling intervals set for its parameters. To activate Cable monitoring policies, see, Change Thresholds and Alarm Behavior for a Monitoring Policy, on page 215.

For more information on cable policies, see Cable Policy, on page 882 and Cable Utilization, on page 886

Note

Step 1  From the left sidebar, choose Configuration > Network Devices.
Step 2  To view device or chassis information, click the device/chassis/supervisor (SUP) from the Chassis Explorer.
Step 3  To view the fan or power supply information, click fan or power supply module from the Chassis Explorer.
Step 4  Click the Configuration tab.
Step 5  Expand the tabs listed in the table below to view the corresponding information.

For a graphical representation of this info, navigate to the Performance tab and ensure that you add the required dashlet to the tab. You can display up to 10 dashlets at a given point of time on the Performance tab.

To filter mac domains, fiber nodes, or controllers based on the utilized bandwidth values or the stream types, use the Advanced Filter option in the Configuration tab. For example, you can filter mac domains that have average utilization values greater or lesser than a particular range. You can further add additional filters to list mac domains with a particular stream type (such as downstream or upstream).
Table 34: Cable Device Configuration Information

<table>
<thead>
<tr>
<th>Tabs</th>
<th>Chassis Explorer Selection</th>
<th>Requires Policy Activation</th>
<th>Information Available</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>Device, chassis, line cards, SUP, fan, and power supply unit.</td>
<td>No</td>
<td>• Generic device and chassis information: View information such as, device name, IP address, installed software version, system up time, device serial number, product ID, part number, device operational state (whether enabled or not), hardware version number, associated CLEI code, operating or configured redundancy state, the unique description associated with the device, number of ports that are up/down, and the device's current ICMP latency.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Fan information: Fan usage status in percentage format.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Power Supply information: Total power capacity and power consumed by the device in watts.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Line card information: View generic device information and the upstream and downstream bandwidth utilization of the card.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Voice Calls information: View the count of active high priority calls and all active calls. The count is refreshed periodically based on your settings in the Cable Monitoring policy settings.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• License State information: View license state information such as Registration status, Authorization, UDI and Serial Number.</td>
</tr>
<tr>
<td>License Usage Status</td>
<td>Device</td>
<td>No</td>
<td>Licenses usage information and reporting of the Cisco products on the Cisco cBR-8 device, along with the enforced state.</td>
</tr>
<tr>
<td>Sensor Readings</td>
<td>Line cards, fans, and power supply units.</td>
<td>Yes</td>
<td>General environmental status of each FRU since installation. You can view the name, sensor state, and threshold values. The sensor readings include the temperature conditions.</td>
</tr>
<tr>
<td>FPGA/CPLD Versions</td>
<td>SUPs</td>
<td>No</td>
<td>All available Supervisor FPGA or CPLD firmware on the router and their respective version numbers.</td>
</tr>
<tr>
<td>IPv4 and IPv6 Statistics</td>
<td>Device</td>
<td>Yes</td>
<td>Type of packets and number of packets being sent and received. This includes IPv4 ARP statistics, and IPv6 neighbor statistics.</td>
</tr>
<tr>
<td>Modem Details</td>
<td>Device</td>
<td>Yes</td>
<td>View the number of cable modems using different DOCSIS versions (such as DOCSIS 2.0 and DOCSIS 3.1) and belonging to different vendors.</td>
</tr>
</tbody>
</table>
Monitor the Health of RPD to cBR-8 Links

The link between cBR-8 device and its associated RPD(s) is represented with the link type L2TP in Cisco EPN Manager. To view the links in the network topology and display the associated link 360 details, see Get More Information About Links, on page 92.

The table below explains the link states once cBR-8 RPD(s) association details are added to the Cisco EPN Manager:

<table>
<thead>
<tr>
<th>Tabs</th>
<th>Chassis Explorer Selection</th>
<th>Requires Policy Activation</th>
<th>Information Available</th>
</tr>
</thead>
</table>
| DEPI Sessions | Device | No | DEPI (Downstream External-PHY Interface) is an IP Tunnel that exists between the CCAP Core and the Remote PHY using Layer 2 Tunneling Protocol (L2TP).

Using this tab, you can view the number of DEPI sessions for every RPD connected with the selected Cisco cBR-8 device. You can also view additional information about the remote device such as the associated tunnel IDs, L2TP class, device name, IP address, and state.

For detailed information about each DEPI session, navigate to the Network Topology, identify the RPD, and use the RPD 360 view for detailed information such as the DEPI session modes, remote states, associated pseudowires, etc. |
| Fiber Node Utilization | Device | Yes | View the list of fiber nodes on the selected device, their streaming modes (upstream or downstream), and the average utilization of each fiber node (average of all channels associated with the fiber node).

For a graphical representation of the percentage range of utilization mapped to the number of fiber nodes per range, view the Fiber Node Downstream/Upstream Utilization graph in the Performance tab. |
| Mac Domain Utilization | Device | Yes | View the list of MAC Domains available on the selected device, their streaming modes (upstream or downstream), and the average utilization values per Mac domain node (average of all channels associated with every Mac domain).

For a graphical representation of the percentage range of utilization mapped to the number of mac domains per range, view the MD Downstream/Upstream SG Utilization graph in the Performance tab. |
| Cable Controller Utilization | Line Card | Yes | View the configured controller types on the selected card, their streaming modes (upstream or downstream), and the average utilization of each controller (average of the bandwidth utilized on all channels associated with the controller). |

| Note | The recommended polling interval is 1 hour. |
The status of Cisco cBR-8 device to RPD association is discovered.

**InProgress**

The status of Cisco cBR-8 device to RPD association is not formed and the L2TP tunnel creation process is not initiated.

**Deployment Pending**

Cisco cBR-8 device to RPD association is not formed and hence the L2TP tunnel creation process is not initiated.

**Defined**

RPD device is created without MAC ID.

For more information about the service states icons in the Link 360 view, see [Link Serviceability States, on page 168](#).

### Fiber Node Utilization of cBR-8 device

The Fiber Node Utilization dashboard is a comprehensive dashboard where users can view details of upstream/downstream channel utilization, associated Mac Domain, RPDs, and cable modems against a fiber node. Users can configure the threshold values to help classify the utilization of upstream and downstream channels and get a broader picture for each cBR-8 device.

**Note**

Information about other interfaces such as Bundle, MAC Domain, Video, and Physical interfaces are displayed under the **Interface** tab in the Chassis View page.

The cable monitoring policies (specifically, the FiberNode Modem Count) must be enabled to use the Service Utilization feature. For more information on cable policies, see [Cable Policy, on page 882](#).

To view the service utilization:

1. Go to **Inventory > Device Management > Network Devices**, and click on any cBR-8 device under the **Device Name** column. This opens the Chassis View for the selected device.

2. Click on the **Utilization** tab. The fiber node utilization details for the selected cBR-8 device are displayed here.

The fiber node utilization percentages for upstream and downstream channels are displayed in various colored thresholds. Click the Utilization Settings icon (gear icon) to customize these utilization thresholds for Upstream and Downstream channel. The changes made here will be applicable for all devices. By default, the threshold values are 0-25%, 26-50%, 51-75% and 76-100%. Clicking on any of the threshold categories will filter the fiber node table as per category selected.
The **Restore to defaults** option in the Utilization Settings page restores the default threshold values for both upstream and downstream channel.

Each column in the Utilization tab, when clicked, gives information about the device metric. For example, when a downstream channel number is clicked, this opens the downstream pop-up window which gives information of the selected channels such as fiber node ID, description, utilization percentage (overall and channel-wise) etc. Similarly, clicking on an upstream channel number, RPD count number, or Modem count number opens the respective pop-up window which gives relevant information about the selected column.

### Table 35: Service Utilization

<table>
<thead>
<tr>
<th>Type of Service Utilization window</th>
<th>Available Information</th>
</tr>
</thead>
</table>
| Fiber Node Utilization / General Information | Fiber Node ID  
Fiber Node Description  
Downstream Details > DOCSIS Utilization & # Channels  
Upstream Details > DOCSIS Utilization & # Channels  
Service Group profile  
MAC Domain  
RPD Count  
Modem Count  
Offline Modem % |
| Downstream channels | Fiber Node ID  
Description  
DOCSIS Utilization %  
RF Resilience State  
Channel  
Utilization % (channel-wise)  
Type  
Frequency (Mhz)  
**Note** This pop-up window also indicates the number of downstream channels that are currently down. |
<table>
<thead>
<tr>
<th>Type of Service Utilization window</th>
<th>Available Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Upstream channels</td>
<td>Fiber Node ID</td>
</tr>
<tr>
<td></td>
<td>Description</td>
</tr>
<tr>
<td></td>
<td>DOCSIS Utilization %</td>
</tr>
<tr>
<td></td>
<td>Channel</td>
</tr>
<tr>
<td></td>
<td>Utilization % (channel-wise)</td>
</tr>
<tr>
<td></td>
<td>Type</td>
</tr>
<tr>
<td></td>
<td>Modulation Profile</td>
</tr>
<tr>
<td>RPD Count</td>
<td>Fiber Node ID</td>
</tr>
<tr>
<td></td>
<td>Description</td>
</tr>
<tr>
<td></td>
<td>DPIC Port</td>
</tr>
<tr>
<td></td>
<td>Status</td>
</tr>
<tr>
<td></td>
<td>RPD Name</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>RPD 360 page can be launched by clicking the i icon here.</td>
</tr>
<tr>
<td></td>
<td>MAC ID</td>
</tr>
<tr>
<td>Modem Count</td>
<td>Modern Status % (Offline, Online, Initialization, Partial Online, Other)</td>
</tr>
<tr>
<td></td>
<td>Status</td>
</tr>
<tr>
<td></td>
<td>MAC Address</td>
</tr>
<tr>
<td></td>
<td>IP Address</td>
</tr>
<tr>
<td>Offline Modems</td>
<td>Offline Modem count percentage</td>
</tr>
</tbody>
</table>

### View the Cable Dashboard

The Cable dashboard provides an executive overview of your cable network including the important issues currently affecting your network of Cisco cBR-8 devices. For more information, see Cable Dashboard Overview, on page 15.

### RPD Polling

The RPD polling information, displayed in the Cable Dashboard, can be dynamically changed by the user by editing the property file located at `/opt/CSCOlumos/conf/cable_poller.properties`.

The customizable attributes are as follows:

```bash
# RPD Polling task
rpd_12tp=10
# Power Supply task
cable_powerSupplyStatus=10
```
# HA Inventory task
cable_inventory_ha_core_redundancy=10
# License Dashboard task
cable_dashboard_license=10
# License Usage Dashboard task
cable_dashboard_license_usage=10
# Fan Status task
cable_FanStatus=10

**Note**
The default polling interval is 10 minutes, and the minimum polling time is 2 minutes. Caution is advised while editing the polling attributes as it can impact the server and device performance. For more information, please contact the administration team.

By default, Cisco EPN Manager polls all the connected devices, but user can customize it by specifying the IP address of the device that needs to be polled. However, if the IP address entered is incorrect or in the wrong format, none of the devices will be polled.

For example, in the instruction below specifies two device IP addresses to be polled at an interval of 10 minutes:

rpd_l2tp=10,10.20.123.222,10.20.133.111

User can enable or disable poll timer for a particular attribute by using the comment tag ('#') in the relevant instruction in the property file. While changing polling interval or adding IP address can be done dynamically, enabling or disabling a polling attribute requires the Cisco EPN Manager to be restarted.

For example, the instruction below (from the above example) has been commented out by using the comment tag ('#'):

#rpd_l2tp=10,10.20.123.222,10.20.133.111

---

**Visualize the Topology of Cable Devices on the Network Topology**

When RPDs are discovered from Cisco cBR-8 devices, you can view the L2TP and physical links, and other alarm information in the topology map. You can view cable devices in the network topology in the following ways:

**Note**
Cisco EPN Manager supports RPD physical link discovery in IPv4 and IPv6 networks.

- Click **Maps > Topology Maps > Network Topology** in the left navigation panel.
- Click the Geographical Map icon.
- Click the **Network Topology** hyperlink from the RPD Association page.

For more information on the network topology features, see View Your Network on a Geographical Map (Geo Map), on page 183
RPD MIB and Supported Alarms

User can collect RPD-related statistics by configuring the following MIB files:

- DOCS-RPHY-CTRL
- DOCS-RPHY-PTP
- DOCS-RPHY-MIB

For more information on the MIB Polling policy, see Custom MIB Polling Monitoring Policy, on page 880

Troubleshooting Cable Devices

Problem:
Mismatch in the count of RPDs per service profile.

Cause:
Duplicate Cisco Smart PHY credentials. Cisco Smart PHY is registered with more than one Cisco EPN Manager server.

Workaround:
Ensure that Cisco Smart PHY is not integrated with more than one Cisco EPN Manager server. After you register Cisco Smart PHY credentials in the Client Credentials page, ensure that you do not update the client to any other instance of Cisco Smart PHY.

If you decide to use a different Cisco Smart PHY client, complete the following steps:

Note
Before you proceed, we recommend that you export and save a local copy of Cisco cBR-8 devices and RPD data.

1. Delete all cBR-8 and RPD data from Cisco EPN Manager.
2. Configure the new Cable Network Automation client credentials.
3. Import the cBR-8 to RPD association details again.

Problem:
Edit RPD operation failing.

Cause:
Editing the RPD Name may fail in Cisco EPN Manager if the RPD to be edited does not exist in the Smart PHY application.

Workaround:
Edit any of the RPD parameters except the RPD Name. This ensures that the RPD is first added to the Smart PHY application. Once it is successfully added, editing the RPD Name will be possible in Cisco EPN Manager.
**Problem:**
High CPU usage in cBR-8 device.

**Cause:**
If the CPU of the cBR-8 device is idle, the CPU spikes may be seen momentarily during Cisco EPN Manager inventory collection. However, if there are high priority items running on the device, the SNMP requests from Cisco EPN Manager will be automatically throttled by the device.

**Workaround:**
No workaround as of now. If high priority items are running on the cBR-8 device, SNMP requests are automatically throttled by the device.
Troubleshooting Cable Devices
PART VI

Manage Circuits

- Overview of Circuit/VC Discovery and Provisioning, on page 457
- Provision Circuits/VCs, on page 475
- View and Manage Discovered/Provisioned Circuits/VCs, on page 583
- Monitor and Troubleshoot Circuits/VCs, on page 619
Circuit/VCs Provisioning Overview

Cisco EPN Manager supports provisioning of circuits/VCs for various technologies such as Carrier Ethernet (CE), Optical/DWDM, L3VPN, Circuit Emulation, and MPLS Traffic Engineering. Mostly, a circuit spans across multiple devices. You must make configuration changes across multiple devices to provision a circuit. Cisco EPN Manager provides a Provisioning Wizard that allows you to make the required configuration changes across multiple devices that participate in a circuit.

The Provisioning Wizard collects all the required information in a step-by-step approach and generates the required configuration for all the devices. You can review the configurations generated for each device, and then choose to either make any changes in the service parameters or deploy the configurations to the devices.

The configuration changes are deployed to the participating devices as an 'atomic' transaction. Cisco EPN Manager does a best-effort attempt to either carry out all these operations together or does none at all. To implement the concept of 'atomic' transaction, Cisco EPN Manager has the rollback feature, which helps to recover from failures during provisioning.

When configuring multiple devices, if the configuration fails in any of the devices, Cisco EPN Manager does a best-effort to rollback the configuration changes made so far in all the participating devices. The device configuration states are restored to the same state, which was there before the provisioning operation was attempted.
Supported Carrier Ethernet VCs

In a Carrier Ethernet (CE) network, data is transported across point-to-point and multipoint-to-multipoint Ethernet Virtual Connections (EVCs) and Operator Virtual Connections (OVCs) according to the attributes and definitions of the various service types—that is, E-Line, E-LAN, E-Tree, E-Access, and EVPN Virtual Private Wire Service.

Each EVC type has a port-based service and a VLAN-based service. These are differentiated by the method for service identification used at the UNIs. EVCs using all to one bundling UNIs (port-based) are referred to as ‘Private’, while EVCs using UNIs that are service multiplexed (VLAN-based), are referred to as ‘Virtual Private’.

For E-Line, E-LAN, and E-Tree services, each EVC carries data in the form of CE service frames from UNI (User Network Interface) to UNI, where the UNI is the physical demarcation point between the responsibility of the Service Provider and the responsibility of the Subscriber. E-Access Operator Virtual Circuits (OVCs) allow service provider interconnections at the ENNI (External Network Network Interface), which is the physical demarcation point between the responsibility of two interconnecting Service Providers.

Each EVC can be configured with a rich set of attributes that include bandwidth profiles (Committed Information Rate - CIR, Excess Information Rate - EIR, Committed Burst Size - CBS, Excess Burst Size - EBS), multiple classes of service, application-oriented performance objectives, traffic management, forwarding rules, and so on.

Cisco EPN Manager supports the discovery and provisioning of the following EVC types, which are described in these topics:

- **E-Line, on page 459:**
  - MPLS to the edge
  - Single-segment pseudowire
  - Ethernet access—local, G.8032, ICCP-SM
- **E-LAN, on page 459**
  - MPLS to the edge
  - Single-segment pseudowire
  - VPLS/H-VPLS with redundant pseudowire
  - Ethernet access—VPLS-based
- **E-Tree, on page 460**—MPLS to the edge
- **E-Access, on page 460**—MPLS to the edge
- **EVPN Virtual Private Wire Service (VPWS), on page 461**—Provisioning is not supported in Cisco EPN Manager for this service type.

Core Technology for Multipoint EVCs

The core technology for the E-LAN or E-Tree EVC can be either VPLS (Virtual Private LAN Services) or H-VPLS (Hierarchical VPLS).

- **VPLS**—A Layer 2 VPN technology that provides Ethernet-based multipoint-to-multipoint communication over MPLS networks. VPLS allows geographically dispersed sites to share an Ethernet broadcast domain by connecting sites through pseudowires. The network emulates a LAN switch or bridge by connecting customer LAN segments to create a single bridged Ethernet LAN.
E-VPLS—Partitions the network into several edge domains that are interconnected using an MPLS core. The edge devices learn only of their local U-PE devices and therefore do not need large routing table support. The E-VPLS architecture provides a flexible architectural model that enables Ethernet multipoint and point-to-point Layer 2 VPN services, as well as Ethernet access to Layer 3 VPN services, enabling service providers to offer multiple services across a single high-speed architecture.

In E-TREE EVCs, E-VPLS supports redundancy. Two hubs operate as connectors through which all traffic passes. If the primary hub fails, traffic is switched to the backup hub. With E-VPLS as the core technology, there is no direct connection between the E-tree root and leaf. E-VPLS is used together with split-horizon capabilities to prevent leaf to leaf communication.

If VPLS is used as the core technology, redundancy is not supported and there is a direct connection between root and leaves. The hub is located in the root, meaning that the root assumes the role of the hub.

**E-Line**

E-Line refers to an Ethernet service that is based on a point-to-point EVC. There are two types of E-Line VCs:

- **Ethernet Private Line (EPL)**, which has the following characteristics:
  - Port-based
  - Uses a point-to-point EVC between two UNIs to provide a high degree of transparency such that service frames, headers, and most Layer 2 protocols are identical at both the source and destination UNI.
  - All to one bundling where all CE-VLAN IDs are bundled to one EVC. No service multiplexing.

- **Ethernet Virtual Private Line (EVPL)**, which has the following characteristics:
  - VLAN-based
  - Uses a point-to-point EVC between two UNIs, but does not provide full transparency as with the EPL, that is, all Layer 2 control protocols are discarded at the UNI.
  - Allows for service multiplexing, which means that more than one EVC can be supported at the UNI.

Following are the limitations of E-Line services:

- Assignment of a MEP group for E-line services after promotion may not match as seen during service creation.
- MEP group for an E-line service is assigned based on lexicographical order of the device name.

**E-LAN**

E-LAN refers to an Ethernet service that is based on a multipoint-to-multipoint EVC. There are two types of E-LAN VCs:

- **Ethernet Private LAN (EP-LAN)**, which has the following characteristics:
  - Port-based
  - All-to-one bundling at the UNI
  - Very transparent, no manipulation of CE-VLAN IDs and PCP bits
• EP-LAN multiport transparency is more complex than EPL

• Ethernet Virtual Private LAN (EVP-LAN), which has the following characteristics:
  • VLAN-based
  • Allows for service multiplexing and bundling

Following are the limitations of E-LAN services:
  • For XR devices, probe name should have unique probe id – PM2_<probeid>_*.
  • MEP group should be provided even if CFM is disabled for the services(ELAN/ETREE) during promotion.

E-Tree

An E-Tree VC is a rooted multipoint VC that connects a number of UNIs providing sites with hub and spoke multipoint connectivity. Each UNI is designated as either root or leaf. A root UNI can communicate with any leaf UNI. A leaf UNI can communicate only with a root UNI, not with another leaf UNI.

E-Tree VCs provide the separation between UNIs required to deliver a single service instance in which different customers (each having a leaf UNI) connect to an ISP which has one or more root UNIs. Having more than one root UNI is useful for load sharing and resiliency schemes.

There are two types of E-Tree VCs:
  • Ethernet Private TREE (EP-TREE), which has the following characteristics:
    • Rooted multipoint, port-based.
    • All-to-one bundling at the UNI.
    • Simpler than typical hub and spoke configuration using multiple EPLs. Hub function is performed by the root UNI.
    • Provides CE-VLAN tag preservation and tunneling of key Layer 2 Control Protocols.
    • Supports CE-VLAN CoS preservation.
  • Ethernet Virtual Private TREE (EVP-TREE), which has the following characteristics:
    • Rooted multipoint, VLAN-based.
    • Provides an alternative to multiple EVPLs multiplexed at the hub site.
    • Used in cases where one or more of the subscriber’s UNIs also supports other services, e.g., EVPL or EVP-LAN.

E-Access

An Ethernet Access service allows a service provider to construct an Operator Virtual Connection (OVC) between two customer sites where one of the sites is located outside of the service provider’s own network. In such cases a service provider uses an E-Access service offered by a local wholesale access provider to reach the out-of-franchise UNI. The service provider connects to the E-Access service at an ENNI, and traffic is forwarded between the ENNI and the out-of-franchise UNI across an Operator Virtual Connection (OVC).

E-Access definitions include attributes related to the external interfaces, in this case, the ENNI and the UNI, as well as attributes related to the virtual Ethernet connection associating these external interfaces. E-Access
services use a point-to-point OVC to associate one OVC endpoint at an ENNI and one OVC endpoint at a UNI.

There are two types of E-Access VCs:

- **Access EPL**, which has the following characteristics:
  - Private or port-based
  - One OVC per UNI
  - All CE-VLAN IDs are mapped to the OVC

- **Access EVPL**, which has the following characteristics:
  - VLAN-based
  - Can be multiple OVCs per UNI
  - Multiple but not all CE-VLAN IDs are bundled to one OVC

**EVPN Virtual Private Wire Service (VPWS)**

The EVPN-VPWS is a BGP control plane solution for point-to-point services. It implements the signaling and encapsulation techniques for establishing an EVPN instance between a pair of PEs. It has the ability to forward traffic from one network to another without MAC lookup. The use of EVPN for VPWS eliminates the need for signaling single-segment and multi-segment PWs for point-to-point Ethernet services. The EVPN-VPWS technology works on IP / MPLS core; IPcore to support BGP and MPLS core for switching packets between the endpoints.

---

**Note**

Cisco EPN Manager supports only the discovery of single-homing EVPN-VPWS services and does not support the provisioning for this type of services.

**Supported Network Structure for Provisioning EVCs**

Cisco EPN Manager can provision EVCs and OVCs over a mix of access networks. The endpoints can be configured directly on an MPLS router, an Ethernet Access switch, or an nV satellite attached to a Cisco ASR 9000 router. The EVCs may have endpoints in different Ethernet Access networks, in the same network, or on the same device. Cisco EPN Manager will configure as much as is needed to create the connectivity.

EVCs can be provisioned over the following networks:

- **MPLS Domain**—Cisco EPN Manager assumes that the managed network contains a single MPLS domain. Any router can communicate with any other router via a targeted LDP session. Alternatively, MPLS end-to-end connectivity can be achieved using MPLS Traffic Engineering or segment routing.

- **Ethernet Access Network**—Cisco EPN Manager supports EVC provisioning over Ethernet Access networks attached to a central MPLS domain. The networks are discovered by the system. EVCs can be provisioned over a G.8032 access ring or over ICCP-SM links. The access network can be:
  - A G.8032 ring. This should include a router to enable the creation of EVCs that cross the MPLS domain.
  - A G.8032 open ring, which means a sequence of links.
• Cisco ASR 9000 nV Satellite Topology—Cisco EPN Manager can configure EVCs on single-homed nV satellite devices attached to an Cisco ASR 9000 host.

To support service discovery and provisioning, Cisco EPN Manager must discover the topology in the access network. For successful discovery, the following prerequisites must be fulfilled:

• For ICCP-SM, LAG must be configured with LACP.
• For G.8032, CDP or LLDP must be configured on the ring ports.

**Supported Optical Circuits**

A circuit represents an end-to-end connection between two or more connection termination points (CTPs). A circuit consists of an alternating series of cross-connections and link connections. In its simplest form, a circuit consists of a single cross-connection (if the circuit is defined between two CTPs on the same NE). A circuit can be bidirectional or unidirectional, point-to-point or point-to-multipoint, and protected or unprotected.

Cisco EPN Manager supports the provisioning of Dense Wavelength Division Multiplexing (DWDM) optical channel (OCH) circuit types and Optical Transport Network (OTN) circuit types. The DWDM optical technology is used to increase bandwidth over existing fiber optic backbones. It combines and transmits multiple signals simultaneously at different wavelengths on the same fiber. In effect, one fiber is transformed into multiple virtual fibers.

Cisco EPN Manager supports the following optical circuits types:

- **Dense Wavelength Division Multiplexing (DWDM) Circuits**, on page 462
  - Optical Channel Network Connection (OCHNC) WSON, on page 462
  - Optical Channel Client Connection (OCHCC) WSON, on page 463
  - Optical Channel (OCH) Trail WSON, on page 463
  - Optical Channel (OCH) Trail Connecting NCS 1002, NCS 55xx, and ASR 9K Devices, on page 463
  - Optical Channel (OCH) Trail User-to-Network Interface (UNI), on page 464
  - Spectrum Switched Optical Network (SSON) Circuits, on page 465

- **Optical Transport Network (OTN) Circuit**, on page 465
  - Optical Channel Data Unit User-to-Network Interface (ODU UNI), on page 466
  - Optical Channel Data Unit (ODU) Tunnel, on page 467
  - Optical Channel Payload Unit (OPU) Over Optical Channel Data Unit (ODU), on page 467
  - Optical Channel Data Unit User-to-Network Interface (ODU UNI) Hairpin, on page 467
  - Optical Channel Data Unit (ODU), on page 467

**Dense Wavelength Division Multiplexing (DWDM) Circuits**

The following topics describe the different optical channel (OCH) and media channel (MCH) circuit types.

**Optical Channel Network Connection (OCHNC) WSON**

OCHNC WSON circuits establish connectivity between two optical nodes on a specified C-band wavelength. The connection is made through the ports present on the wavelength selective switches, multiplexers,
demultiplexer, and add/drop cards. In an OCHNC WSON circuit, the wavelength from a source OCH port ingresses to a DWDM system and then egresses from the DWDM system to the destination OCH port.

**Optical Channel Client Connection (OCHCC) WSON**

OCHCC WSON circuits extend the OCHNC WSON to create an optical connection from the source client port to the destination client port of the TXP/MXP cards. An OCHCC WSON circuit represents the actual end-to-end client service passing through the DWDM system. Each OCHCC WSON circuit is associated to a pair of client or trunk ports on the transponder (TXP), muxponder (MXP), GE_XP (in layer-1 DWDM mode), 10GE_XP (in layer-1 DWDM mode), or ITU-T line card. The OCHCC WSON circuits can manage splitter protection as a single protected circuit. However, for the Y-Cable protection, two OCHCC WSON circuits and two protection groups are required.

---

**Note**

Cisco EPN Manager can discover the LMP links between a Cisco NCS 2000 series device and a Cisco IOS-XR device.

---

**Optical Channel (OCH) Trail WSON**

OCH trail WSON circuits transport the OCHCC WSON circuits. The OCH trail WSON circuit creates an optical connection from the source trunk port to the destination trunk port of the Transponder (TXP), Muxponder (MXP), GE_XP, 10GE_XP, or ITU-T line card. The OCH trail WSON represents the common connection between the two cards, over which all the client OCHCC WSON circuits, SVLAN circuits or STS circuits are carried. Once an OCHCC WSON is created, a corresponding OCH Trail is automatically created. If the OCHCC WSON is created between two TXP, MXP, GE_XP, or 10GE_XP cards, two circuits are created in the CTC. These are:

- One OCHCC WSON (at client port endpoints)
- One OCH trail WSON (at trunk port endpoints)

If the OCHCC WSON is created between two TXP or two MXP cards, three circuits are created in the CTC. These are:

- One OCHCC WSON (at client port endpoints)
- Two OCH Trails WSON (at trunk port endpoints). One for the working and other for the protect trunk.

**Optical Channel (OCH) Trail Connecting NCS 1002, NCS 55xx, and ASR 9K Devices**

Cisco EPN Manager can discover an OCH Trail circuit from the following devices:

- Source trunk port of an NCS 1002 device to the destination trunk port of another NCS 1002 device.
- Source trunk port of an NCS 55xx device (trunk ports on NCS55-6X200-DWDM-S card) to the destination trunk port of another NCS 55xx device.
- Source trunk port of an ASR 9K device (trunk port on ASR9K-400G-DWDM-TR) to the destination trunk port of another ASR 9K device.

The trunk port of each of these devices must be connected via a manual link to the passive units of NCS 2K devices. Where the manual links are terminated, and OCH-NC circuit must be created as a pre-requisite between the ports of the passive units of NCS 2K network.
Optical Channel (OCH) Trail Hybrid Circuits

An OCH Trail hybrid circuit connects a Cisco IOS-XR device and a Cisco NCS 2000 series device. Cisco EPN Manager can discover such circuits whose trunk ports must be connected via either a manual link or an LMP link to the passive units of Cisco NCS 2000 series devices.

Note: Provisioning is not supported for this type of optical circuits.

Optical Channel (OCH) Trail User-to-Network Interface (UNI)

An OCH trail UNI circuit establishes connectivity between the following devices:

- Cisco NCS 2000 series devices and Cisco NCS 4000 series devices. It provides an end-to-end configuration of DWDM network that consists of Cisco NCS 2000 series devices and terminates on a Cisco NCS 4000 series device. When an OCH trail UNI circuit is created in a Cisco NCS 4016 network element, a corresponding OCHNC circuit is created in the Cisco NCS 2006 network element.

Note: You will not be able to modify or delete the OCHNC circuit.

- Cisco NCS 1000 series devices that act as UNI-C and Cisco NCS 2000 series devices that act as UNI-N. The OCH trail UNI circuit originates from an NCS 1002 trunk interface (UNI-C) on the source NCS 1002 node and terminates on the NCS 2000 series interface (UNI-N) on the destination NCS 2000 series node to create an optical connection. The prerequisite for the OCH trail UNI circuit is to create a Link Management Protocol (LMP) link between the optical channel Add/Drop NCS 2000 series interface on the NCS 2000 series node and the NCS 1002 interface on the NCS 1002 node. See Configure GMPLS and WSON Properties, on page 353.

Note: Cisco EPN Manager discovers the OCH Trail UNI circuits that originates from NCS 1002 device running on software version 6.3.2.

The LMP link can either be a numbered link or an unnumbered link. An unnumbered link does not have an IP address.

- For unnumbered links, Cisco EPN Manager creates the required explicit path object on the NCS 1000 series device, which is the source device. This device will contain two constraints, one for the source peer NCS 2000 series device and the other for the destination device. You can add more constraints as required.

- For numbered links, a default explicit path object is not required. If you want to add constraints, you must first specify the source NCS 2000 series node in the explicit path even if the node is selected as the source endpoint of the OCH Trail UNI circuit. If you do not add the source NCS
2000 series node as your first constraint, the corresponding OCHNC circuit on the NCS 2000 series node will not be created.

Note
You cannot use both numbered and unnumbered links for the same OCH Trail UNI circuit.

Spectrum Switched Optical Network (SSON) Circuits
SSON circuits allow you to provide more than 96 channels in a span. Using the SSON functionality, the circuits are placed closer to each other if they are created within a media channel group. The minimum spacing between circuits is 50 GHz.

SSON circuits can be created only if the source and destination nodes have the SSON package installed.

Note
The existing OCHNC, OCHCC, and OCH Trail circuits cannot be upgraded to SSON circuits.

Cisco EPN Manager supports the following SSON circuits:

- Media Channel Circuits—Media channel (MCH) works on any available frequency (flexible frequency) and establishes connection between two optical nodes. A continuous section of the spectrum is allocated between the source and destination nodes. The MCH contains information regarding the allocated optical bandwidth. A media channel can be of three modes:
  - Media Channel Trail—MCH trail SSON circuits transport the MCHCC SSON circuits. These circuits create optical connection between trunk ports of a co-located TXP (based on the carrier trails).
  - Media Channel Network Connection (MCHNC)—MCHNC SSON circuits create optical connection between filter ports (based on the carrier).
  - Media Channel Client Connection (MCHCC)—MCHCC circuits create optical connection between client ports of a co-located TXP.

- Media Channel Group (MCHG)—MCHG is a container that can include one or more media channels. Media channels are grouped together to increase the spectral efficiency. Circuits can be created at closer intervals, when compared to OCH circuits. Maximum number of media channels can be achieved on a single fiber, if the MCHG covers the entire C-band.

Optical Transport Network (OTN) Circuit
OTN specifies a digital wrapper, which is a method of encapsulating an existing frame of data, regardless of the native protocol, to create an optical data unit (ODU), similar to that used in SDH/SONET. OTN provides the network management functionality of SDH/SONET, but on a wavelength basis. A digital wrapper, however, is flexible in terms of frame size and allows multiple existing frames of data to be wrapped together into a single entity that can be more efficiently managed through a lesser amount of overhead in a multi-wavelength system.
The OTN specification includes framing conventions, non-intrusive performance monitoring, error correction (FEC), rate adaptation, multiplexing mechanisms, ring protection, and network restoration mechanisms operating on a wavelength basis.

A key element of a digital wrapper is the forward error correction (FEC) mechanism that provides performance gains for improved margins and extended optical reach.

The OTN architecture is compliant to ITU-T G.872. An OTN circuit can be established statically or dynamically between ingress and egress nodes using Resource Reservation Protocol (RSVP) signaling. An OTN circuit is established and maintained as a label switched path (LSP) between the ingress and egress Label Switched Routers (LSRs) switched through transit LSRs. An LSP can be established as a soft permanent connection (SPC) when the request comes from the user interface.

Following are the types of OTN circuits:

- Optical Channel Data Unit User-to-Network Interface (ODU UNI), on page 466
- Optical Channel Data Unit (ODU) Tunnel, on page 467
- Optical Channel Payload Unit (OPU) Over Optical Channel Data Unit (ODU), on page 467
- Optical Channel Data Unit User-to-Network Interface (ODU UNI) Hairpin, on page 467
- Optical Channel Data Unit (ODU), on page 467

**Optical Channel Data Unit User-to-Network Interface (ODU UNI)**

ODU is the transport container defined to carry client signals from network ingress to egress. The ODU provides a payload area for client data along with performance monitoring and fault management. The payload area of an ODU may contain a single non-OTN signal as a client or may contain multiple lower rate OUDs as clients. An ODU UNI circuit represents the actual end-to-end client service passing through the OTN architecture.

**Open Ended ODU UNI**

In an open-ended ODU UNI circuit, one or both end points may be connected to ODU subcontrollers, instead of client payload controllers.

Cisco EPN Manager supports three types of open-ended ODU UNIs:

- Only the source interface is an ODU subcontroller
- Only the destination interface is an ODU subcontroller
- Both source and destination interfaces are ODU subcontrollers

To create an open-ended ODU UNI circuit, you must configure ODU subcontrollers on devices before adding the devices to Cisco EPN Manager. Use the `controller oduk` command to configure ODU subcontrollers on devices.

**Example: Configure an ODU subcontroller on a Cisco NCS 4000 Device**

In this example, two ODU0 subcontrollers are configured to an ODU1 controller.

```
RP/0/RP0:router#config
RP/0/RP0:router(config)# controller ODU10/1/0/1
RP/0/RP0:router(config-odu1)# tsg 1.25G
RP/0/RP0:router(config-odu1)# ODU0 tpn 1 ts 1
RP/0/RP0:router(config-odu1)# ODU0 tpn 2 ts 2
RP/0/RP0:router(config-odu1)#commit
```

To verify that the ODU subcontrollers are configured correctly on the device:
After configuring the ODU subcontrollers on the device, you must add the device to Cisco EPN Manager. You can then verify that the ODU 0/1/0/1/10 and ODU 0/1/0/1/20 subcontrollers are available in the inventory.

### Optical Channel Data Unit (ODU) Tunnel

ODU tunnel circuits transport the ODU UNIs. The ODU tunnel represents the common connection between two Cisco NCS 4000 series devices that are connected with Traffic Engineering (TE) links. Once an ODU UNI circuit is created, a corresponding ODU tunnel is automatically created.

### Optical Channel Payload Unit (OPU) Over Optical Channel Data Unit (ODU)

OPU over ODU circuits provide a high-bandwidth point-to-point connection between two customer designated premises. Client signals are mapped over an OTN framing structure with in-band management through GCC0. These circuits use ODU UNI circuits to carry client signals through the network. You need to perform the following tasks to create and provision an OPU over ODU circuit:

- Using Cisco EPN Manager, create an ODU UNI circuit. For information about how to create ODU UNI circuits, see Create and Provision an OTN Circuit, on page 510.
- Using Cisco Transport Controller (CTC), create LMP links and enable the links on the devices that you want to use in the OPU over ODU circuits. For information about how to create LMP, see the “DLP-K27 Create an LMP Using CTC” section in the OTN and DWDM Configuration Guide for Cisco NCS 4000 Series.
- Using Cisco EPN Manager, create an OPU over ODU circuit with the LMP links enabled devices. For information about how to create OPU over ODU circuits, see Create and Provision an OTN Circuit, on page 510.

### Optical Channel Data Unit User-to-Network Interface (ODU UNI) Hairpin

An ODU UNI Hairpin circuit is similar to an ODU UNI circuit, but it is created in the management plane and it is an intra node circuit, that is, the source and destination is the same device but with different interfaces. In this type of circuit, the connection is established between two clients or two ODU subcontrollers.

Cisco EPN Manager supports the following types of ODU UNI Hairpin circuits:

- Circuits without open-ended cross-connect—In this type of circuits, the interfaces of both source and destination are not OTU interfaces.
- Circuits with open-ended cross-connect on one side—In this type of circuits, the interface of either source or destination is an OTU interface.
- Circuits with open-ended cross-connect on both sides—In this type of circuits, the interface of both source or destination are OTU interfaces.

### Optical Channel Data Unit (ODU)

The Optical Channel Data Unit (ODU) circuit represents the common connection between two Cisco NCS 2000 series devices that are connected with Traffic Engineering (TE) links. The ODU is created as a subcontroller of an OTU controller. ODU contains information for the maintenance and operational functions to
support optical channels. ODU Over Head (OH) information is added to the ODU payload to create the complete ODUk. The ODUk OH consists of portions dedicated to the end-to-end ODUk path and to six levels of tandem connection monitoring. The ODUk path OH is terminated where the ODUk is assembled and disassembled. The TCM OH is added and terminated at the source and sink to the corresponding tandem connections.

ODU cross connection is an end-to-end channel between two OTN or client ports in the OTN network. Cisco EPN Manager supports ODU cross connections with bidirectional SNC-N protection.

## Supported Circuit Emulation Services

Circuit Emulation (CEM) provides a protocol-independent transport over IP networks. It enables proprietary or legacy applications to be carried transparently to the destination, similar to a leased line. In traditional TDM networks, numerous physical circuits are maintained between geographically diverse locations to provide TDM transport. CEM allows TDM endpoints to connect across an IP/MPLS core. In CEM, endpoints are connected to the TDM circuits, but the circuits terminate at each local router that has the IP/MPLS connectivity available. The router then transports those TDM frames across the IP/MPLS core via Circuit Emulation (CEM) pseudowires (PWs) to the remote endpoint that also has the IP/MPLS connectivity available. Thus, the TDM endpoints can communicate as if they were directly connected by physical circuits. Cisco EPN Manager supports the following CEM modes:

- **Structure-Agnostic time-division multiplexing (TDM) over Packet (SAToP)**—This is the unstructured mode in which the incoming TDM data is considered as an arbitrary bit stream. It disregards any structure that may be imposed on the bit stream. SAToP encapsulates the TDM bit streams as pseudowire (PWs) over PSN.

- **Circuit Emulation over Packet (CEP)**—This mode is used to emulate Synchronous Optical Network/Synchronous Digital Hierarchy (SONET/SDH) circuits and services over MPLS. To transport SONET/SDH circuits through a packet-oriented network, the Synchronous Payload Envelope (SPE) or Virtual Tributary (VT) is broken into fragments. A CEP header and optionally an RTP header are prepended to each fragment.

- **Circuit Emulation Service over Packet Switched Network (CESoPSN)**—This is the structured mode in which the structured TDM signals are encapsulated as PWs and transmitted over PSN. It selects only valid timeslots and disregards the idle timeslots for transmission. Thus, CESoPSN can save utilized bandwidth.

Cisco EPN Manager supports the following CEM service types depending on the rate at which the circuits can transmit data:

- **DS0**—A basic digital signal with transmission data rate of up to 64 Kbps.

---

**Note**

Cisco NCS 42XX series devices does not support the DS0 service type.

- **T1 and E1**—Digital Signal (DS) is known as T-carrier in North America, South Korea, and Japan and as E-carrier in the rest of the world. The T1 circuit has a transmission data rate of up to 1.544 Mbps and the E1 circuit has a transmission data rate of up to 2.048 Mbps in framed mode and 2.048 Mbps in unframed mode.
• T3 and E3—The T3 circuit has a transmission data rate of up to 44.736 Mbps. The E3 circuit has a transmission data rate of up to 34.368 Mbps. The T3 or E3 circuit can transport 672 DS0 level channels and 28 DS1 level channels within its payload.

• VT 1.5—A virtual tributary network line with transmission data rate of up to 1.728 Mbps.

• STS1—A synchronous transport signal with transmission data rate of up to 51.84 Mbps.

• STS12—A synchronous transport signal with transmission data rate of up to 155.52 Mbps.

• STS48—A synchronous transport signal with transmission data rate of up to 2488.32 Mbps.

• STM1—A synchronous Transport Module with transmission data rate of up to 155.52 Mbps.

• STM4—A Synchronous Transport Module with transmission data rate of up to 622.08 Mbps.

• STM16—A Synchronous Transport Module with transmission data rate of up to 2488.32 Mbps.

• VC11—A Virtual Container line with transmission data rate of up to 1.7 Mbps.

• VC12—A Virtual Container line with transmission data rate of up to 2.2 Mbps.

• X.21—The X.21 interface supports the serial data speed that are multiples of 64 Kbps. The maximum limit of speed can be 2048 Kbps. The pseudowire utilizes Circuit Emulation Service over Packet-Switched Network (CESoPSN) in E1 mode to transport the X.21 traffic over the MPLS network.

• C37.94—The C37.94 is an IEEE standard that defines the communication of protection relays with communication equipment using optical fibers. This interface supports pseudowire that utilizes CESoPSN to transmit data. The frame format defined for the C37.94 interface is used to transmit data in packet format from the multiplexer to the tele-protection equipment and from the tele-protection equipment to the multiplexer equipment. The IEEE defines the C37.94 standard as N * 64 kbps optical fiber interface to provide transparent communications between tele-protection relays and multiplexers equipments. The C37.94 standard describes the interconnection details for the variable N, (where N = 1, 2…12), which describes a multiple of 64 kilobit per second connections at which the communication link is to operate.

• EM-Voice—The E&M interface supports pseudowire types that utilize CEM transport, CESoPSN in T1 and E1 modes to transport analog signals and voice traffic over MPLS. The voice port interfaces that connect the device to E & M lines pass voice data and signaling between the packet network and the analog-circuit-switched network. The devices in the packet network must be configured to convey signaling information in a way that the circuit-switched network can understand. The devices must also be able to understand signaling information received from the circuit-switched network. E&M signaling interface uses special signaling paths that are separate from the trunk circuit’s audio path to convey information about the calls.

**Supported L3VPN Services**

An MPLS Layer 3 VPN creates a private IP network. The customer connects to the network via customer edge (CE) routers, which act as IP peers of provider edge (PE) routers.

**Virtual Routing and Forwarding (VRFs)**
On the PE, Virtual Routing and Forwarding (VRF) instances act as virtual IP routers dedicated to forwarding traffic for the L3VPN service. The VRFs learn the routes to each other via the Multi-Protocol Border Gateway Protocol (MP-BGP), and then forward traffic using MPLS.

A VPN is comprised of at least one but typically several VRFs. Cisco EPN Manager uses the VPN ID to discover which VRFs together form a single VPN. If Cisco EPN Manager discovers an existing network where no VPN ID has been provisioned, it takes all VRFs with the same name and associates them into one VPN. For VPNs created using Cisco Prime Provisioning, which uses a naming convention with version number prefixes and different suffixes, Cisco EPN Manager will recognize the different VRFs as belonging to one VPN.

In general there is a regular expression which can be configured to allow for varying naming convention.

**Route Targets (RTs)**

The connections between VRFs are defined using Route Targets (RTs) that are imported and exported by the VRFs. Cisco EPN Manager makes it easy to set up a full mesh of connections, and automatically allocates the route target to be used. The route target consists of a prefix which is either an AS number or an IPv4 address, for example, a full mesh prefix, 100 [681682]. The prefix can be selected from the existing BGP autonomous system (AS) numbers in the network, or it can be entered manually. The second number following the prefix is allocated automatically by Cisco EPN Manager.

Alternatively or in addition to the full mesh, it is possible to manually select route targets. During VPN creation, there is an initial screen where you type in the route targets to be used within a VPN, and then for each VRF you can select which route targets you import and export. You also specify for which address family (IPv4 or IPv6) you will use the route target. This can be used for example to configure extranets, by importing route targets used in other VPNs.

**Route Redistribution**

The routes that are exchanged between the PE and the CE have to be redistributed into the MP-BGP routing protocol so that remote endpoints can know which prefixes can be reached at each VRF. To control route redistribution, Cisco EPN Manager allows you to define the required protocol (Static, Connected, or RIP), the protocol's metric value, and optionally the applicable route policy.

**Endpoints**

Cisco EPN Manager supports the creation of IP endpoints on Ethernet subinterfaces. It supports selecting untagged encapsulation, or specifying an outer and optionally an inner VLAN, with 802.1q or 802.1ad encapsulation. You can specify both IPv4 and Ipv6 addresses at an endpoint. You can also specify the BGP and OSPF neighbor details to provision BGP and OSPF neighbors between CE and PE.

For information on how to provision L3VPN service using Cisco EPN Manager, see, Provision L3VPN Services, on page 517.

**Supported MPLS Traffic Engineering Services**

In traditional IP networks, packets are forwarded on a per-hop basis where a route lookup is performed on each router from source to destination. The destination-based forwarding mechanism leads to suboptimal use of available bandwidth between a pair of routers in the network. Mostly, the suboptimal paths are under-utilized in IP networks. To avoid packet drops due to inefficient use of available bandwidth and to provide better performance, traffic engineering (TE) is implemented. TE directs the traffic that is destined to follow the optimal path to a suboptimal path, thus enabling better bandwidth utilization between a pair of routers.
Multiprotocol Label Switching (MPLS) is an integration of Layer 2 and Layer 3 technologies. In an MPLS domain, unique labels are assigned to data packets and the packets are forwarded based on these labels. It avoids the complex lookup in a routing table. MPLS creates a VC switching function to provide similar performance on the IP-based network services as compared to those delivered over traditional networks such as Frame Relay or Asynchronous Transfer Mode (ATM).

By making traditional Layer 2 features available to Layer 3, MPLS enables traffic engineering. MPLS TE enables an MPLS backbone to replicate and expand the TE capabilities of Layer 2 over Layer 3.

MPLS TE uses Resource Reservation Protocol (RSVP) to establish and maintain label-switched path (LSP) across the backbone. The path that an LSP uses is based on the LSP resource requirements and network resources, such as bandwidth and link attributes. Available resources are flooded by means of extensions to a link-state-based Interior Gateway Protocol (IGP). Cisco EPN Manager supports OSPF as the IGP to flood the available bandwidth and link status information across the network. Based on this information, the ingress (headend) router gathers information on all the available resources in the network along with the topology to define tunnels through the network between a set of MPLS-enabled routers. This is called as constraint-based routing. When a shortest path is over-utilized, the IGP automatically routes the traffic to these LSPs. You can also create and provision explicit paths for MPLS TE tunnels.

Cisco EPN Manager provides full path protection mechanism for MPLS TE tunnels against path, link, and node failures. A secondary LSP is established to provide failure protection for the protected LSP that is carrying a tunnel’s TE traffic. When there is a failure on the protected LSP, the source router immediately enables the secondary LSP to temporarily carry the tunnel's traffic. If there is a failure on the secondary LSP, the tunnel no longer has path protection until the failure along the secondary path is cleared.

Cisco EPN Manager supports the following MPLS TE service types:

- **Unidirectional TE Tunnel**, on page 471
- **Bidirectional TE Tunnel**, on page 471
- **Layer 3 Link**, on page 472

---

**Note**

Cisco EPN Manager does not support MPLS TE services over MPLS core with LAG.

---

### Unidirectional TE Tunnel

MPLS TE tunnels are unidirectional tunnels that connect a pair of LSRs. Once the unidirectional tunnel is created, a label is assigned for the tunnel that corresponds to a specific path in a MPLS network. The traffic is routed through the tunnel. You must create another unidirectional tunnel between the same routers to route the return traffic. For example, router A is the head end and router B is the tail end of tunnel 1, which is a unidirectional tunnel. You must create another unidirectional tunnel, say tunnel 2 with router B as the head end and router A as the tail end.

### Bidirectional TE Tunnel

Two unidirectional TE tunnels established between a pair of LSRs that are connected to each other, can be bound together to form a bidirectional co-routed TE tunnel. The binding of unidirectional tunnels is based on the source and destination addresses, global ID, association ID, and association address of the tunnels. For example, router A and router B that are connected by two unidirectional tunnels, tunnel C and tunnel D, can be bound together to form a bidirectional TE tunnel only if the following conditions are met:
• The source address of tunnel C is the destination address of tunnel D and vice versa.

• The global ID, association ID, and association address of tunnel C and D are the same. The association ID and association address for the tunnels are system-defined and you need to assign a global ID for the tunnels.

Bidirectional TE tunnels inherit the security features of RSVP-TE.

Layer 3 Link

To enable traffic engineering links between two devices, you need to configure the following on both ends of the devices:

• Loopback interface
• Ethernet interface
• BDI Interface
• OSPF, RSVP, and MPLS
• IS-IS and BGP

You can perform these configurations using the Layer 3 link provisioning feature in Cisco EPN Manager.

Supported Serial Services

In a serial communication, the serial port sends and receives bytes of information one bit at a time. The serial communication can be used over longer distances. The cabling between devices can extend up to 1200 meters. Serial communication is used to transmit ASCII data. Communication is completed using three transmission lines—ground, transmit, and receive. Since serial is asynchronous, the port is able to transmit data on one line while receiving data on another. Other lines are available for handshaking, but are not required.

Cisco EPN Manager supports the following serial service types:

• RS232—is a standard communication protocol that links devices in a network to allow serial data exchange. It defines the voltage for the path used for data exchange between the devices. It specifies common voltage, signal level, common pin wire configuration, and minimum amount of control signals. The RS232 interface is suitable for short-distance and low-speed requirements. RS232-RS422 point to point services can be configured by selecting corresponding media-types during configuration of RS232 and RS422 Services.

• RS485—is an EIA/TIA standard that defines a communication bus that is used to form simple networks of multiple devices. The RS485 interface can be used in simplex or half-duplex modes with a single-pair cable. Full-duplex or simultaneous transmit and receive operations can be implemented with a two-pair cable. This interface is used for high speed over long distances.

• RS422—is an EIA/TIA standard that was designed for greater distances and higher baud rates than RS232. To enable high speed data to be transmitted over serial data lines, RS422 accommodates data rates of up to 100kbps and distances up to 4000 ft. RS422 uses both differential transmitters and receivers to balance the transmission techniques. To enable the differential driver to be used, RS422 uses a four conductor cable. Additionally up to ten receivers can be placed on a single cable, providing a multi-point network or bus.
• Raw Socket—is a method for transporting serial data through an IP network. Raw Socket transports Supervisory Control and Data Acquisition (SCADA) data from Remote Terminal Units (RTUs). Raw Socket supports point-to-point and point-to-multipoint connections. Raw Socket supports point-to-multipoint connection over an asynchronous serial line and has a built-in auto TCP connection retry mechanism. You can choose Synch RS232, RS422 P2MP Options while configuring RawSocket by selecting Synch and media-type options.

Circuit/VC Discovery Overview

Cisco EPN Manager uses the Service Discovery feature to automatically discover circuits/VCs existing in the network. Ensure that the Service Discovery feature is enabled under Administration > System Settings. See Enable and Disable Service Discovery, on page 583.

Circuit/VC discovery depends on device-level inventory discovery, and consists of two parts:

• Resource facing service (RFS) discovery—The RFS represents the relations between resources on different devices. During RFS discovery, the system creates device-level objects and network-level objects. Device-level RFS objects represent the circuit/VC configuration parts of the device-level configuration. Network-level RFS objects aggregate device or other network-level objects to represent network-level entities.

• Customer facing service (CFS) matching—The CFS represents the customer facing data for a circuit/VC. The CFS is derived from discovered RFS and represents the endpoints of the circuit/VC in the network. During CFS discovery, the system creates CFS objects for the discovered RFS objects.

Discovery is an ongoing process in Cisco EPN Manager. When you first start using Cisco EPN Manager, the circuits/VCs that exist in the network are discovered. Later, when you start provisioning circuits/VCs using the Provisioning Wizard, Cisco EPN Manager will discover the provisioned circuits/VCs and will search for a match between the resources used in the circuit/VC and the resources discovered from the network. When a match is found between a discovered circuit/VC and a provisioned circuit/VC, information from the provisioned CFS is copied into the discovered CFS.

Cisco EPN Manager allows you to compare between the provisioned and discovered versions to identify changes that might have been made in the device configurations and you can do a reconciliation, if necessary. See Compare and Reconcile Provisioned and Discovered Versions of a Circuit/VC, on page 608.
Provision Circuits/VCs in Cisco EPN Manager

The process of creating and provisioning a circuit/VC is similar for all the supported technologies and involves:

- Specifying the endpoints of the circuit/VC.
- Defining the configuration parameters of the circuit/VC.

For a detailed overview of the provisioning support in Cisco EPN Manager, see Provision Circuits/VCs, on page 475.

To create and provision a new circuit/VC:

**Step 1**  From the left sidebar, choose **Maps > Topology Maps > Network Topology**.

**Step 2**  Click on the **Device Groups** button, select the required device group(s) and click **Load**.

**Step 3**  Close the **Device Groups** popup window.

**Step 4**  In the **Network Topology** window, click the **Circuits/VCs** tab.

**Step 5**  Click the '+' icon to open the Provisioning Wizard in a new pane to the right of the map.
You can also access the Provisioning wizard by choosing Configuration > Network > Service Provisioning.

Step 6
From the Technology drop-down list, choose the required technology. For example, if you are creating a circuit for Optical/DWDM network, choose Optical.

Step 7
In the Service Type area, choose the type of circuit/VC you want to create. For example, if you are creating a circuit/VC for Optical/DWDM network, the various circuit types include OCHNC WSON, OCHCC WSON, OCH-Trail WSON, OCH-Trail UNI, ODU UNI, ODU Tunnel and OPU over ODU.

Step 8
If you have defined profiles to set the attributes of the different services, select the required profile from the Select Profile drop-down list. See Create Circuit/VC Profiles, on page 572.

Step 9
Click Next to go to the Customer Service Details page.

Step 10
(Optional) Select the customer for whom the circuit/VC is being created. If there are no customers in the list, go to Inventory > Other > Customers to create the customer in the system, and then go to the Provisioning Wizard to start provisioning the circuit/VC.

Step 11
Enter the service name and its description.

Step 12
From the Deployment Action drop-down list, choose the action that you want to perform after defining the attributes for the circuit/VC. The options are:

- **Preview**—Displays the generated CLIs for each device. You can review the CLIs and decide if you want to edit any attributes or go ahead with the deployment.

- **Deploy**—Deploys the configuration to the relevant devices immediately after you click Submit in the last page of the Provisioning Wizard.

Click one of the following deployment options:

- **Deploy Now**—Directly deploys the provisioning order

- **Deploy Later**—Saves the created provisioning order. You can deploy the same order at later point of time. To redeploy the provisioning order click the circuit/VCs link at the bottom of the left pane.

- **Schedule Deployment**—Saves the order for future deployment at the designated time provided by you. Schedules the provisioning order and creates the Job order to be deployed at the scheduled time. If required, you can specify the date and time to provision the order in the Job Scheduler dialog box.

If you click this Schedule Deployment radio button, specify the following:

- **Deploy Schedule Time**—Specify a schedule time for deployment of provision order.

- **Server Time**—Displays the current server time.

To know more about how to schedule and save a provisioning order, see Save and Schedule a Provisioning Order, on page 545.

Step 13
Click Next to choose the endpoints and define the attributes based on the technology you have selected.

Step 14
Click Submit. Depending on the deployment action you have chosen, the relevant action will be performed. That is, if you have chosen to preview the configuration, the preview page will be displayed where you can view the configurations, and then click Deploy. If you have chosen to deploy, the configurations will be directly deployed to the relevant devices.

Step 15
(Optional) Click the Leave this View button to continue using Cisco EPN Manager and to enable the service deployment to continue in the background.
If the device is busy, the request from Cisco EPN Manager to deploy the service will wait up to a pre-configured period of time before the request times out. To change this setting, see Set the Service Deployment Timeout Value, on page 477.

Note

The circuit/VC should be added to the list in the Circuits/VCs pane in the Network Topology window. To check the provisioning state, click the i icon next to the circuit/VC name to see the Circuit/VC 360 view.

For information about how to create and provision circuit/VCs for various technologies, see:

- Provision EVCs in a Carrier Ethernet Network, on page 481
- Provision Circuits in an Optical/DWDM Network, on page 496
- Provision L3VPN Services, on page 517
- Provision Circuit Emulation Services, on page 538
- Provision MPLS Traffic Engineering Services, on page 548

You can view the saved provisioning order in the Planned Circuits/VCs tab from Administration > Dashboards > Job Dashboard > Provisioning.

Click the (I) icon at the Last run stat field and view the configuration and Device details.

Set the Service Deployment Timeout Value

When you deploy a service to devices, if the devices are pre-occupied or busy, the service request created waits for a pre-configured period of time to acquire a ‘device lock’ for deploying the service. By default, the timeout value is set to 60 minutes.

To change the default timeout value:

**Step 1**
From the left sidebar, choose Administration > Settings > System Settings.

**Step 2**
Expand the Circuits/VCs section and click Deployment Settings.

**Step 3**
Set the required timeout value in minutes.

Cisco EPN Manager will now wait up to the specified time period to acquire the device lock for deploying the service. If the lock is not acquired within this time, the service deploy operation will fail.

What Happens When a Deployment Fails

When you deploy a circuit/VC, Cisco EPN Manager performs configuration changes in the participating devices based on the type of circuit/VC. Only when the configuration changes are successfully deployed to the devices, the circuit/VC will be considered as successfully provisioned. If the deployment of configuration changes fails in any one of the participating device, Cisco EPN Manager rolls back the configuration changes made so far in all the devices.

Deployment action can result in any one of the following scenarios:

- Deployment succeeds in all the participating devices; roll back is not initiated—In this scenario, all devices are successfully configured and the circuit provisioning is successful.
• Deployment fails; roll back is initiated and succeeds—In this scenario, when configuring multiple devices, the configuration fails in one of the device. The failure could be due to various reasons, for example, the device has declined the configuration. Cisco EPN Manager identifies the failure and successfully rolls back all the configuration changes that were made on all the devices. In this scenario, all device configurations are restored to the states, which were there before the deployment was attempted.

Here is an example with three devices, A, B, and C, which are configured in a sequential order to provision a circuit. The configuration changes are deployed successfully in device A, but the deployment fails in device B. Cisco EPN Manager detects the failure and stops further configuration in devices B and C. It rolls back the configuration in the reverse order of provisioning, that is, it first rolls back the device B, followed by device A. Following are the actions that are performed sequentially in the three devices:

- Device C—Rollback is not required for device C because there were no changes deployed to the device. This is because the configuration failure was detected in device B before configurations changes were sent to device C.

- Device B—Cisco EPN Manager checks if there are any configuration changes made on this device before the deployment failed. If there are any changes, the partial configuration on this device is removed and the device is rolled back to the previous configuration.

- Device A—Cisco EPN Manager performs a complete roll back in device A, where all the configuration changes that were successfully deployed earlier are removed and the device is rolled back to the previous configuration.

• Deployment fails; roll back is initiated but fails—In this scenario, when the configuration deployment fails on any of the participating device(s), Cisco EPN Manager performs a roll back, but the roll back on one or more devices fail. Now, the device(s) on which the roll back had failed, has the partial configuration.

For example, the configuration changes are successfully deployed in devices A and B, the deployment fails in device C. Cisco EPN Manager identifies the failure and initiates the roll back in the reverse order of provisioning, that is, it first rolls back the device C, device B, and then device A. Following are the actions that are performed sequentially in the three devices:

- Device C—Cisco EPN Manager performs a successful roll back in device C.

- Device B—When attempting a rollback on device B, device connectivity is lost and there could be partial configurations left on the device.

- Device A—Cisco EPN Manager performs a rollback of Device A, even if the roll back fails in device B.

The roll back may fail due to various other reasons.

In the Provisioning Wizard, after previewing the configurations, click Deploy. When the deployment fails, the rollback configuration and the status for each participating device is displayed. From the Device(s) drop-down list, choose the device for which you want to view the rollback configuration and the status.

The following figure illustrates the rollback configuration and the rollback status for each device.
1 **Attempted Configuration** — Shows the configurations that were deployed to the device selected in the **Device(s)** drop-down list.

2 **Deployment Status** — Shows the deployment status of the selected device. If the deployment succeeds, it shows the status as "Success". If the deployment fails, it provides information about the failure.

3 **Rollback Configuration** — Shows the configurations for which rollback is automatically attempted.

4 **Rollback Status** — Shows the rollback status of the selected device. If the rollback succeeds, it shows the status as "Success". If the rollback fails, it provides information about the failure. You can use this information to manually clean up the partial configurations on the device.

You can also click the *i* icon next to the **Provisioning** column in the Circuits/VCs and Deleted Circuits/VCs tabs in the extended tables to view the details of configuration, configuration errors, rollback configuration, and rollback configuration errors for each device participating in the circuit/VC. The *i* icon is available for all provisioning states, except None. For information about how to access the extended tables, see **View Detailed Tables of Alarms, Network Interfaces, Circuits/VCs, and Links from a Network Topology Map**, on page 157.

For information about how to troubleshoot deployment and rollback failures, see **Troubleshoot Configuration Deployment Failures and Roll Back Failures**, on page 479.

## Troubleshoot Configuration Deployment Failures and Roll Back Failures

Following are the tips to troubleshoot the deployment or rollback failures:
• Deployment fails, but rollback succeeds—If the configuration deployment fails, rollback is automatically initiated and the results are displayed in the results page. Analyze the attempted configuration and error message shown in the results page for each device and identify the root cause of the deployment failure.

The deployment failure could be due to, but not limited to the following issues:

• Invalid values entered for the service parameters in the Provisioning Wizard. For example, the Service ID may already exist or there could be semantic errors in the CLI that is generated, and so on.

• Device issues such as, device is not reachable, device password has changed, and so on.

In this case, you must locate the circuit (by the name that you had given when creating it) for which deployment has failed, edit the circuit, and re-attempt the provisioning. If the service parameter for which the value to be changed is not editable, delete the circuit and create a new circuit.

Note Before deleting the circuit, ensure that it is not in use.

• Both, deployment and rollback fail—In this case, do the following:

1. Ensure that the device is reachable and perform a device re-synch.

2. If there were any device issues that were reported in the previous deployment, try to fix the issues.

3. Edit the circuit and update the attributes, if required, and then re-attempt the circuit deployment.

4. If the deployment fails, Cisco EPN Manager will initiate the rollback.

5. If the rollback fails again, identify the cause of the rollback failure.

6. To identify the cause of the failure, you can use the configuration and rollback transaction details, history of the service deployment attempts, and the rollback attempts that are displayed in the Circuit/VC 360 view. See Get Quick Information About a Circuit/VC: Circuit/VC 360 View, on page 593.

7. Manually remove the partial configurations that are stored on the device.

You can also contact the Cisco representative to analyze and identify the root cause of configuration deployment failure and rollback failure.

**WAN Automation Engine Integration**

**Cisco WAN Automation Engine Integration with Cisco EPN Manager**

The Cisco WAN Automation Engine (WAE) platform is an open, programmable framework that interconnects software modules, communicates with the network, and provides APIs to interface with external applications. Cisco WAE provides the tools to create and maintain a model of the current network through continuous monitoring and analysis of the network and based on traffic demands that are placed on it. This network model contains all relevant information about a network at a given time, including topology, configuration, and traffic information. You can use this information as a basis for analyzing the impact on the network due to changes in traffic demands, paths, node and link failures, network optimizations, or other changes.
For details, refer to the latest *Cisco WAN Automation Engine (WAE) Installation Guide* and *Cisco WAN Automation Engine (WAE) User Guide*.

In Cisco EPN Manager, when you create an unidirectional or a Bi-directional tunnel with an explicit path, the WAN Automation Engine (WAE) integration provides you the explicit path using a REST call from Cisco EPN Manager automatically. Thus, you can avoid manually entering the explicit paths. WAE provides you a list of possible network paths to review and allows you to select an appropriate path.

### Configure WAE Parameters

To specify the WAE path details:

**Before you begin**

Ensure to set the WAE parameters:

1. Choose **Administration > Settings > System Settings**
2. Expand Circuit VCs and then choose **WAE Server Settings**.
3. Enter the relevant WAE Details (version 7.1.1 and above) and field details such as **WAE Server IP**, **WAE Port Address**, **WAE Server UserName**, **WAE Server Password**, and **WAE Network Name**.
4. Click **Save** to save the WAE server settings or click **Reset to Defaults** to use the default values.

**Step 1** Create an Unidirectional or Bidirectional tunnel with necessary parameters. For more information, see **Create and Provision an MPLS TE Tunnel**, on page 549.

**Step 2** In the **Path Constraints Details** area, choose the path type either as **Working** or **Protected**. See **Field References for Path Constraint Details—MPLS TE Tunnel**, on page 557 for descriptions of the fields and attributes.

**Step 3** Check the **New Path** check box to enable the **Choose Path from WAE server** check box.

**Step 4** Check the **Choose Path from WAE server** checkbox. EPNM manager sends a REST request to WAE to obtain WAE networks.

WAE will return a list of possible networks.

**Step 5** From the **Select WAE Network** drop-down list, choose a network.

EPNM manager will send a REST request to WAE with all the required parameters such as Source, Destination, network; Max path returned default value = 2. WAE displays a list of possible paths satisfying the request.

**Step 6** From the **Select WAE Path** drop-down list, choose the appropriate paths returned.

EPNM shows the selected path overlay on the map.

**Step 7** Enter the name of the path in the **Path Name** field.

You can proceed with provisioning the order using the last selected path as explicit path.

### Provision EVCs in a Carrier Ethernet Network

- **Summary of Cisco EPN Manager Carrier Ethernet Provisioning Support**, on page 482
- **Prerequisites for EVC Provisioning**, on page 482
**Summary of Cisco EPN Manager Carrier Ethernet Provisioning Support**

This topic provides a summary of the Carrier Ethernet service provisioning support in Cisco EPN Manager 2.1. For a more detailed overview of the different types of EVCs and the supported underlying networks, see **Overview of Circuit/VC Discovery and Provisioning, on page 457**.

Cisco EPN Manager supports provisioning of both port-based and VLAN-based VCs of the following types:

- **E-line**—Ethernet Private Line (EPL) and Ethernet Virtual Private Line (EVPL). See **E-Line, on page 459**.
- **E-LAN**—EP-LAN and EVP-LAN. See **E-LAN, on page 459**.
- **E-Access**—Access EPL and Access EVPL. See **E-Access, on page 460**.
- **E-TREE**—EP-TREE and EVP-TREE. See **E-Tree, on page 460**.

Cisco EPN Manager supports the following supplementary provisioning functions that can be used during EVC creation:

- **Provision UNIs**—For each EVC, you must define the attributes of the participating UNIs. You can either do this during the EVC creation or you can provision a UNI independently of the EVC creation process. See **Configure a Device and Interface To Be a UNI, on page 492**.
- **Provision ENNI**—For E-Access circuits, you must define the attributes of the ENNI. You can either do this during the EVC creation or you can provision an ENNI independently of the EVC creation process. See **Configure a Device and Interface To Be an ENNI, on page 492**.
- **QoS Profiles**—You can create QoS profiles to apply to VCs. See **Create QoS Profiles, on page 573**.
- **EVC Attribute Profiles**—You can create profiles containing all the required attributes for an EVC. These profiles can be selected during EVC creation to define the attributes of the EVC, instead of having to define the attributes individually for each EVC. See **Create Circuit/VC Profiles, on page 572**.

**Prerequisites for EVC Provisioning**

The following prerequisites must be met before you can provision EVCs:

1. **Communication between devices must be set up before you can provision EVCs:**
   - In an MPLS end-to-end network, Label Distribution Protocol (LDP) must be set up across the network and each device must be provided with an LDP ID. This enables peer label switch routers (LSRs) in an MPLS network to exchange label binding information for supporting hop-by-hop forwarding. Alternatively, MPLS end-to-end connectivity can be achieved using MPLS Traffic Engineering or segment routing, and specifically, EVC provisioning over unidirectional or bidirectional TE tunnels is supported.
   - If there is Ethernet access, i.e., not all devices are MPLS-enabled, G.8032 rings or ICCP-SM must be configured to connect the Ethernet access switch to the MPLS switch.
   - CDP or LLDP must be configured on the links within the G.8032 ring to enable Ethernet link discovery.

2. **To provision EVCs over ICCP-SM and G.8032 networks, all VLANs (from 1 to 4095) should be configured either as primary or as secondary VLANs.**
3. Inventory collection status for the devices on which the EVCs will be provisioned must be Completed. To check this, go to Inventory > Network Devices, and look at the status in the Last Inventory Collection Status column.

4. Customers can be created in the system so that you can associate a circuit/VC to a customer during the circuit/VC creation and provisioning process. Choose Inventory > Other > Customers in the left sidebar to create and manage customers.

5. For interfaces to be used in EVCs, it is recommended to reset the default configuration on the interfaces. In global configuration mode, configure the following command on each interface:

   ```
   default interface 'interface-name'
   ```

6. For ME3600 and ME3800 devices, service instances can only be configured on trunk ports with no allowed VLANs. Configure the following commands on the interface and then re-sync the device in Cisco EPN Manager:

   ```
   interface GigabitEthernetXX/XX
   switchport trunk allowed vlan none
   switchport mode trunk
   ```

---

**Create and Provision a New Carrier Ethernet EVC**

EVCs are created in the context of the topology map. You can access the topology map and the Provisioning Wizard by choosing Configuration > Network > Service Provisioning in the left sidebar or you can open the Provisioning Wizard from the topology map, as described in the procedure below.

The process of creating and provisioning an EVC is similar for all supported EVC types and involves:

- Specifying the endpoints (UNIs and ENNIs) of the EVC.
- Defining the configuration parameters of the circuit/VC.

After a service is provisioned, you can edit the service and update or change the A-end or Z-end points.

Endpoint modification is supported with E-line services such as EPL and EVPL. You can modify only managed endpoints and full and partial services.

During modification of service, if existing UNI has different device or same device with different port, you can change to other existing UNI.

Some limitations are:

- You cannot modify the endpoints on both end in a single modification of services.
- Create an UNI using the standalone UNI wizard and use it in modification of EPL or EVPL services.
- During modification of service you cannot create a new UNI.

**Before you begin**

For information about the prerequisites that must be met before you can provision EVCs, see Prerequisites for EVC Provisioning, on page 482.

To create a new EVC:

---

**Step 1**

In the left sidebar, choose Maps > Topology Maps > Network Topology.
Step 2  Click the Device Groups button in the toolbar and select the group of devices you want to show on the map.

Step 3  In the Circuits/VCs tab, click the ‘+’ icon to open the Provisioning Wizard in a new pane to the right of the map.

Step 4  Select Carrier Ethernet in the Technology drop-down list. Cisco EPN Manager displays a list of relevant circuit/VC types in the Service Type area. For example, Carrier Ethernet service types include EPL, EVPL, EP-LAN, and so on.

Step 5  In the Service Type list, select the type of circuit/VC you want to create.

Step 6  If you have defined profiles to set the attributes of the different services, select the required profile from the Select Profile drop-down list. See Create Circuit/VC Profiles, on page 572.

Step 7  Click Next to go to the Service Details page.

Step 8  (Optional) Select the customer for whom the EVC is being created. If there are no customers in the list, go to Inventory > Other > Customers to create the customer in the system, and then restart the Provisioning Wizard.

Step 9  Enter the Service Details. See Service Details Reference, on page 487 for descriptions of the fields and attributes.

Step 10  For E-Line, E-Tree, and E-LAN EVCs: If required, configure the service OAM which enables fault and performance monitoring across the EVC. For E-Line EVCs, select the Enable CFM check box to enable the Service OAM options. You can then choose to either create a new CFM domain or select an existing domain for the E-Line EVC. See Service OAM, on page 491. Click the Plus icon to add a row to the Service OAM table and provide values in the relevant columns. For E-Tree EVCs, you must specify the direction, i.e., Leaf-to-Root, Root-to-Leaf, or Root-to-Root.

If you want to promote and reconcile point-to-point services or multipoint services, for example EVPL/EPL services, enable the CFM parameters such as CFM Domain name, CFM Domain level and Continuity check interval fields. CFM parameters will be read from the discovered version during service promotion. You can perform reconciliation with discovered or provisioned version.

Step 11  In the Deployment Action field, specify what you want to do when the EVC creation process is completed. You can either request a preview of the configurations that will be deployed to the relevant devices before the actual deployment or you can deploy the configurations immediately upon completion.

Step 12  Click Next to go to the page(s) in which you define the UNI(s). In the case of E-Access, there is an additional page for defining the ENNI.

Step 13  Identify the device and interface that will serve as the UNI:

  Note  If one of the endpoints is an interface on a device that is not managed by Cisco EPN Manager, select the Unmanaged check box and provide information for the unmanaged device. See Provision a Circuit/VC with an Unmanaged Endpoint, on page 575

  • If you have already configured the required interface on the device as a UNI, uncheck the Create New UNI check box and select the relevant UNI Name from the list.

  • To create a new UNI:

    • Make sure that the Create New UNI check box is checked.
    • In the UNI Name field, enter a name for the UNI that will enable easy identification of the UNI.
    • Select a device from the list in the Device field or click on a device in the map to select it and populate the Device field. A list of the selected device’s ports is displayed.
    • Select the required port from the Port table. If the port cannot be used for the UNI, there is an alert icon next to the UNI name in the Port table that displays the reason why the port cannot be selected.

  Note  The device you select during UNI creation is circled in orange in the map. The UNI name is displayed above the orange circle. If it is a point-to-point EVC, the orange circle is labeled to indicate whether it is an A-side or Z-side endpoint.

Step 14  If you are creating a new UNI, enter the New UNI Details. See New UNI Details Reference, on page 488 for descriptions of the fields and attributes.
Step 15  Enter the UNI Service Details. See UNI Service Details Reference, on page 489 for descriptions of the fields and attributes.

Step 16  For E-LAN and E-TREE EVCs with H-VPLS as the core technology, select the devices that will serve as the primary and secondary hubs.

Step 17  For E-Line EVCs: In the Pseudowire Settings page, you can select a TE tunnel over which the EVC will traverse, as follows:

1. Check the Static Preferred Path check box to assign a static route for the service.
2. Choose the Preferred Path Type as Bidirectional or Unidirectional or SR Policy.
3. Select the required bidirectional TE tunnel from the Preferred Path drop-down list. This list contains all existing bidirectional TE tunnels between the endpoints of the EVC.
   
   **Note**  This field is available only if you selected Bidirectional as the Preferred Path Type.

4. Select the required unidirectional TE tunnels from the Preferred Path (A-Z) and Preferred Path (Z-A) drop-down lists.
   
   **Note**  These fields are available only if you selected Unidirectional as the Preferred Path Type.

5. Select the Allow Fallback to LDP check box if you want the default path to be used if the preferred path is unavailable.
   
   **Note**  If no tunnel exists between the endpoints, the Preferred Path and the Fallback to LDP options will be disabled.

6. Select the Send Control Word check box if you want a control word to be used to identify the pseudowire payload on both sides of the connection.

7. Select the Interworking Option if you need to interconnect sites using either Ethernet, VLAN, or IP. This option must be enabled if one of the endpoints in the EVC is an unmanaged device.

8. Enter the required bandwidth for the pseudowire.

9. In the PW ID field, enter an identifier that is displayed in the Pseudowire settings for point-to-point services.
   
   **Note**  Pseudowire (PW) ID is automatically allocated from the resource pool of PW ID. You can modify the PW ID value only when you create a service. You cannot edit this value during modification of an EVC service. If the entered PW ID is already allocated to the service then an error message is displayed.

Step 18  (Optional) If you want to append a template with additional CLI commands that will be configured on the devices participating in the service, do so in the Service Template page. See Extend a Circuit/VC Using Templates, on page 575 for more information.

Step 19  When you have provided all the required information for the circuit/VC, click Submit. If you chose to see a preview of the CLI that will be deployed to the devices, it will be displayed now and you can click Edit Attributes to change the attributes. Otherwise, the configurations will be deployed to the devices immediately.

Step 20  The circuit/VC should be added to the list in the Circuits/VCs tab in the Network Topology window.

---

If the configuration deployment fails, see the What Happens When a Deployment Fails, on page 477 section.
Create and Provision an EVC with Multiple UNIs

Cisco EPN Manager supports creating/selecting multiple UNIs during the creation and provisioning of multipoint EVCs (E-LAN and E-Tree).

**Note**

You can have multiple UNIs on the same device for EVCs using VPLS as the core technology, but not for H-VPLS-based EVCs.

**Before you begin**

For information about the prerequisites that must be met before you can provision EVCs, see Prerequisites for EVC Provisioning, on page 482.

To create a new EVC:

1. From the left sidebar, choose **Maps > Topology Maps > Network Topology**. The network topology window opens.
2. From the toolbar, click **Device Groups** and then select the group of devices you want to show on the map.
3. Click the **Circuits/VCs** tab.
4. From the **Circuits/VCs** pane toolbar, click the + (Create) icon. The Provisioning Wizard opens in a new pane to the right of the map.
5. Select **Carrier Ethernet** in the Technology drop-down list.
6. In the Service Type list, select a multipoint EVC type.
7. If you have defined profiles to set the attributes of the different services, select the required profile from the Select Profile drop-down list. See Create Circuit/VC Profiles, on page 572.
8. Click Next to go to the Service Details page.
9. Select the customer for whom the EVC is being created. If there are no customers in the list, go to **Inventory > Other > Customers** to create the customer in the system, and then restart the Provisioning Wizard.
10. Enter the Service Details. See Service Details Reference, on page 487 for descriptions of the fields and attributes.
11. In the Deployment Action field, specify what you want to do when the EVC creation process is completed. You can either request a preview of the configurations that will be deployed to the relevant devices before the actual deployment or you can deploy the configurations immediately upon completion.
12. Click Next to go to the page(s) in which you define the UNI(s).
13. In the Multi UNI area, click the Plus icon to add the first UNI to the table. The UNI is given a default name and is automatically selected in the table. Each time you click the Plus icon, a new UNI is added to the table. Alternatively, you can click on devices in the map to add new UNIs to the table. In this case, the device name will be populated in the Device field under New UNI details.
14. Select a UNI in the table to define or edit its attributes.
15. Identify the device and interface that will serve as the UNI:
   - To use an existing UNI, uncheck the Create New UNI check box and select the relevant UNI Name from the list.
   - To define a new UNI:
• Make sure that the Create New UNI check box is checked.
• In the UNI Name field, enter a name for the UNI that will enable easy identification of the UNI.
• Select a device from the list in the Device field. A list of the selected device’s ports is displayed.
• Select the required port from the Port table. If the port cannot be used for the UNI, there is an alert icon next to the UNI name in the Port table that displays the reason why the port cannot be selected.

Step 16  If you are creating a new UNI, enter the New UNI Details. The New UNI details are relevant for the UNI that is currently selected in the Multi UNI table. See New UNI Details Reference, on page 488 for descriptions of the fields and attributes.

Step 17  Enter the UNI Service Details. See UNI Service Details Reference, on page 489 for descriptions of the fields and attributes. Click Next.

Step 18  If one of the endpoints is an interface on a device that is not managed by Cisco EPN Manager, provide information for the unmanaged device in the Unmanaged page. See Provision a Circuit/VC with an Unmanaged Endpoint, on page 575

Step 19  Optional. If you want to append a template with additional CLI commands that will be configured on the devices participating in the service, do so in the Service Template page. See Extend a Circuit/VC Using Templates, on page 575 for more information.

Step 20  When you have provided all the required information for the circuit/VC, click Submit. If you chose to see a preview of the CLI that will be deployed to the devices, it will be displayed now and you can click Edit Attributes to change the attributes. Otherwise, the configurations will be deployed to the devices immediately.

Step 21  The circuit/VC should be added to the list in the Circuits/VCs pane in the Network Topology window.

Service Details Reference

The following table lists and describes the attributes that define the EVC on the service level. Note that not all attributes are relevant for all the EVC types.

Table 36: Service Details

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Service Name</td>
<td>Unique name to identify the circuit/VC.</td>
</tr>
<tr>
<td>Service Description</td>
<td>Description of the VC that will help to identify the VC.</td>
</tr>
<tr>
<td>Service Type</td>
<td>Prepopulated based on the type of service you are creating—EPL, EVPL, EP-LAN, and so on.</td>
</tr>
<tr>
<td>Service MTU</td>
<td>The maximum size, in bytes, of any frame passing through the VC. Values can be between 64 to 65535. The service MTU must be lower than or equal to the MTU defined on all of the service’s UNIs.</td>
</tr>
<tr>
<td>Core Technology</td>
<td>VPLS or H-VPLS. See Core Technology for Multipoint EVCs, on page 458.  Note: For VPLS or H-VPLS, you can provision a maximum number of 20 devices using the Provisioning Wizard.</td>
</tr>
</tbody>
</table>
### Attribute | Description
--- | ---
VPN ID | Relevant for multipoint EVCs (both VPLS and H-VPLS). This field is automatically populated with the next available pseudowire ID. This ID can be changed during the EVC creation process (valid value range: 1-4294967295). The ID is not editable when modifying the EVC.
 | Note **VPN ID** is used uniquely across the network, meaning that two services will not use the same VPN ID. In addition, the VPN ID cannot use a pseudowire ID which is already configured in the network to avoid pseudowire ID collision. The VPN ID value is displayed in the PW ID field. You cannot modify the PW ID value for multipoint services during creation and modification of services.
PW ID | Relevant for multipoint EVCs and point-to-point EVCs. This field is automatically populated with the next available pseudowire ID. You can edit this ID to assign a value only in case of point-to-point EVCs (valid value range: 1-4294967295) during the EVC creation process. The ID is not editable when modifying the EVC.
 | Note **PW ID** is used uniquely across the network, meaning that two services will not use the same PW ID.
Bundling | Enables multiple VLANs on this VC. Multiple CE-VLAN IDs are bundled to one EVC.
CE-VLAN ID Preservation | Ensures that the CE-VLAN ID of an egress service frame is identical in value to the CE-VLAN ID of the corresponding ingress service frame. This must be enabled if bundling is enabled.
CE-VLAN ID CoS Preservation | Ensures that the CE-VLAN CoS of an egress service frame is identical in value to the CE-VLAN CoS of the corresponding ingress service frame. The CoS markings are unaltered.

## New UNI Details Reference

The following table lists and describes the attributes relating to the port that is specified as the UNI. Note that not all attributes are relevant for all the EVC types.

### Table 37: New UNI Details

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MTU</td>
<td>The Maximum Transmission Size, in bytes, of a packet passing through the interface. The MTU of the UNI must be greater than or equal to the MTU defined on the service level.</td>
</tr>
<tr>
<td>Auto Negotiation</td>
<td>Check this check box to automatically negotiate the speed and duplex mode.</td>
</tr>
<tr>
<td>Speed</td>
<td>Port speed. You can reduce the speed if this is supported on the port.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>This field is not available if you select the Auto Negotiation check box.</td>
</tr>
</tbody>
</table>
| Duplex Mode | • Full Duplex — Uses simultaneous communication in both directions between the UNI and the customer’s access switch, assuming that both sides support full duplex. If one side does not support full duplex, the port will be brought down.  
• Auto-Negotiation — Uses the mode that is agreed upon between the two devices, depending on what is supported. Full Duplex will be attempted but if one device does not support it, half duplex will be used. |
<p>| <strong>Note</strong> | This field is not available if you select the Auto Negotiation check box. |</p>
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Service Multiplexing</td>
<td>Allows the UNI to participate in more than one EVC instance.</td>
</tr>
<tr>
<td>UNI Allows Bundling</td>
<td>Allows the UNI to participate in VCs with Bundling enabled. See Bundling in Service Details Reference, on page 487</td>
</tr>
<tr>
<td>Untagged CE-VLAN ID</td>
<td>The ID of the CE-VLAN assigned to untagged traffic.</td>
</tr>
<tr>
<td>Ingress/Egress QoS Profile</td>
<td>Select the required QoS profile for ingress or egress traffic on the UNI. The list of profiles includes policy maps that were configured on the device and discovered by the system, as well as user-defined QoS profiles. Refer to Create QoS Profiles, on page 573 for information on how to create QoS profiles.</td>
</tr>
<tr>
<td>UNI QoS Profile</td>
<td>Applies a QoS profile on the UNI itself to define the bandwidth profile and other quality of service attributes of the UNI. If you apply a QoS profile on the UNI level, you should not apply a QoS profile on the service level.</td>
</tr>
<tr>
<td>Enable Link OAM</td>
<td>Enables IEEE 803.1ah link operation and maintenance. If Link OAM is enabled, you will see events relating to the state of the link between this UNI and the customer’s access switch.</td>
</tr>
<tr>
<td>Enable Link Management</td>
<td>Enables the customer access switch to get information about this UNI, VLAN IDs, services on the UNI, and so on.</td>
</tr>
</tbody>
</table>

**UNI Service Details Reference**

The following table lists and describes the attributes of the EVC in relation to the UNI, i.e., how the EVC operates on this UNI. Note that not all attributes are relevant for all the EVC types.

**Note**

For QinQ attributes, only the attributes that are supported on the selected device will appear in the wizard.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ingress/Egress Service QoS Profile</td>
<td>Select the required QoS profile for ingress or egress traffic on the UNI. The list of profiles includes policy maps that were configured on the device and discovered by the system, as well as user-defined QoS profiles. Refer to Create QoS Profiles, on page 573 for information on how to create QoS profiles.</td>
</tr>
<tr>
<td>Layer 2 Control Protocol Profile</td>
<td>Profile that determines how the various communication protocols are handled. Frames using the various protocols are either tunneled, dropped or peered. Refer to MEF 6.1 for details.</td>
</tr>
<tr>
<td>Designation</td>
<td>For E-Tree: Select the role of the UNI in the VC, either Leaf or Root.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Use point to point connection with Root</td>
<td>For E-Tree: If the UNI is designated as a leaf, you can select this check box to create an active pseudowire between root and leaf. The check box will not appear if there is more than one endpoint on a single device or if there is more than one root in the service.</td>
</tr>
</tbody>
</table>
| Match | Select the type of tagging the traffic should have in order to enter the UNI:  
• Dot1q—Mapping of 802.1q frames ingress on an interface to the service instance.  
• Dot1ad—Mapping of 802.1ad frames ingress on an interface to the service instance.  
• Default—Traffic that is not assigned to any other VC on this port.  
• Untagged—Frames that have no VLAN tag | Dot1AD is not supported on ME3600 devices running 15.3(3)software version. |
| Auto Allocate VLAN | Check this check box to automatically allocate a VLAN ID for the UNI. | This field is not available if you have checked the Auto Allocate VLAN check box. |
| VLAN(s) | VLAN identifier, an integer between 1 and 4094. You can enter a range of VLAN IDs using a hyphen or a comma-separated series of VLAN IDs. |  |
| Inner VLAN(s) | VLAN identifier for the second level of VLAN tagging, an integer between 1 and 4094. You can enter a range of VLAN IDs using a hyphen or a comma-separated series of VLAN IDs. |  |
| Untagged Bundled | Enables traffic with no VLAN tags to be bundled together with VLAN tagged frames. |  |
| Priority Tagged Bundled | Enables priority tagged traffic to be bundled together with VLAN tagged frames. |  |
| Exact | Prevents admittance of traffic with additional inner VLAN tags other than those that are matched to be carried by the service. | Applicable for IOS-XR devices only. |
| Outer VLAN CoS | The outer VLAN Class of Service identifier that should be associated with the frame. The CoS ID can be an integer between 0 and 7. | Applicable for IOS devices only. |
| Inner VLAN CoS | The inner VLAN Class of Service identifier that should be associated with the frame. The CoS ID can be an integer between 0 and 7. | Applicable for IOS devices only. |
| E-Type | Limits the service to only carry frames of the specified Ethertype:  
• IPv4  
• IPv6  
• PPPoE-All  
• PPPoE-Discovery  
• PPPoE-Session | Applicable for IOS devices only. |
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Additional Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rewrite Definition Action</td>
<td>The encapsulation adjustment to be performed when the frame enters the UNI:</td>
<td>The Translate action is applicable for IOS-XR devices only.</td>
</tr>
<tr>
<td></td>
<td>• None</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Pop—Removes one or two VLAN tags from the frame on ingress and adds them on egress.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Push—Adds one or two VLAN tags from the frame on ingress and removes them on egress., either Dot1q or Dot1ad tags.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Translate—Replaces VLAN tags with new VLAN tags, either Dot1q or Dot1ad tags The translation can be 1:1, 1:2, 2:1, or 2:2.</td>
<td></td>
</tr>
</tbody>
</table>

**Service OAM**

On the service level, you can define EOAM (Ethernet Operations, Administration and Management) parameters that will allow monitoring and troubleshooting of the EVC. Effectively, you will be configuring Connectivity Fault Management (CFM) components on the endpoints of the EVC.

For a point-to-point EVC, you can define OAM parameters in one direction, i.e., from UNI A to UNI Z or in both directions. For a multipoint EVC, you can define the source and destination MEP groups and then associate the EVC endpoints with a specific MEP group.

See *Configure EOAM Fault and Performance Monitoring, on page 386* for more information about CFM and for device-level CFM configuration.

Use the Service OAM section in the Customer Service Details page of the Provisioning Wizard to define the specifications of the service frame to be monitored and to define the OAM profile to apply to that frame, as follows:

- From—The source of the traffic flow across the EVC.
- To—The destination of the traffic flow across the EVC.
- Direction (E-Tree only) —The direction of traffic flow between leaf and root, or root to root.

**Note**

Your input in the From and To fields creates MEP groups, or ordered sets of UNIs. In the next page of the wizard, you will associate the UNI with one of these MEP groups.

- CoS—The Class of Service identifier that should be associated with the frame.
- OAM Profile—A set of OAM attributes that should be applied to the frame to enable performance monitoring. The following OAM profiles are available for selection:
  - Performance Monitoring 1: Enables continuity check and synthetic loss measurement. This profile supports both point-to-point and multipoint EVCs.
  - Performance Monitoring 2: Enables continuity check, synthetic loss measurement, and single-ended delay measurement. This profile supports both point-to-point and multipoint EVCs.
  - Performance Monitoring 3: Enables continuity check, synthetic loss measurement, and dual-ended delay measurement. This profile supports both point-to-point and multipoint EVCs.
  - Performance Monitoring 3: Enables continuity check, synthetic loss measurement, and dual-ended delay measurement. This profile supports frame size of 64 (loss & delay), history interval 2 (delay) and 5 (loss), aggregate interval 60.
- Performance Monitoring 4: Enables continuity check, synthetic loss measurement, and dual-ended delay measurement. This profile supports frame size of 152 (loss & delay), history interval 10, aggregate interval 300 (5 min samples).

- Continuity Check Interval—The interval between continuity check messages.

**Configure a Device and Interface To Be a UNI**

The User Network Interface (UNI) is the physical demarcation point between the responsibility of the Subscriber (the Customer Edge or CE) and the responsibility of the Service Provider (the Provider Edge or PE).

UNIs demarcate the endpoints of EVCs, so configuring device interfaces as UNIs is an essential part of VC provisioning. UNI configuration can be done during the VC creation process. Alternatively, you can configure UNIs independently of VC creation. These UNIs will be available for selection during VC creation.

To configure a UNI:

**Step 1** Follow the instructions in Create and Provision a New Carrier Ethernet EVC, on page 483 to access the Provisioning Wizard.

**Step 2** Select Carrier Ethernet from the Technology drop-down list.

**Step 3** Select UNI from the Service Types list.

**Step 4** Click Next to go to the Customer Service Details page.

**Step 5** Provide a unique name and description for the UNI, and associate it with a customer, if required.

**Step 6** Define the service attributes of the UNI, as follows:

- All to One Bundling—For port-based VCs where the UNI is dedicated to the VC. When enabled, all CE-VLAN IDs are bundled to one VC. When All to One Bundling is selected, Multiplexing and Bundling cannot be selected.

- Service Multiplexing—For VLAN-based VCS where the UNI is shared between multiple VCs. When enabled, allows the UNI to participate in more than one EVC instance.

- Bundling—Allows the use of multiple VLANs for this UNI. Multiple CE-VLAN IDs are bundled to one EVC.

**Step 7** Under Deploy, select whether you want to deploy the UNI immediately upon completion or first display a preview of the CLI that will be deployed to the device.

**Step 8** Click Next to go to the UNI Details definition page.

**Step 9** Select the device and port you want to configure as the UNI.

**Step 10** Configure the UNI attributes, as described in New UNI Details Reference, on page 488.

**Step 11** Click Submit. If you previously chose to deploy the circuit upon completion, a job is created and the required CLI is deployed to the devices. If you chose to see a preview of the CLI before actually deploying to the devices, the preview will be displayed now. Verify the CLI and if you want to change any of the attributes, click Edit Attributes. Else, click Deploy.

**Configure a Device and Interface To Be an ENNI**

The External Network to Network Interface (ENNI) specifies the reference point that is the interface between two Metro Ethernet Networks (MENs) where each operator network is under the control of a distinct
administration authority. The ENNI is intended to support the extension of Ethernet services across multiple operator MENs, while preserving the characteristics of the service.

When provisioning an E-Access VC, you need to define the ENNI that will carry traffic through to the adjacent network. ENNI configuration can be done during the VC creation process. Alternatively, you can configure ENNIs independently of VC creation. These ENNIs will be available for selection during VC creation.

To configure an ENNI:

Step 1 Follow the instructions in Create and Provision a New Carrier Ethernet EVC, on page 483 to access the Provisioning Wizard.

Step 2 Select Carrier Ethernet from the Technology drop-down list.

Step 3 Select ENNI from the Service Types list.

Step 4 Click Next to go to the Customer Service Details page.

Step 5 Provide a unique name and description for the ENNI, and associate it with a customer/operator, if required.

Step 6 Under Deploy, select whether you want to deploy the ENNI immediately upon completion or first display a preview of the CLI that will be deployed to the device.

Step 7 Click Next to go to the ENNI Details definition page.

Step 8 Select the device and port(s) you want to configure as the ENNI.

Step 9 Define the following parameters for the ENNI:

- MTU—The Maximum Transmission Size, in bytes, of a packet passing through the interface. The MTU of the ENNI must be greater than 1526.
- Speed—If required, you can reduce the speed of the port if this is supported.
- Protection Mechanism—This defines the resiliency scheme at the ENNI. If you have selected more than one port for this ENNI, you can specify whether to apply a protection mechanism, which could be Link Aggregation or another agreed upon protection mechanism. Selecting Link Aggregation creates a Link Aggregation Group (LAG) with two links. If one of the links fails, traffic is moved to the other link.

Step 10 Click Submit. If you previously chose to deploy the circuit upon completion, a job is created and the required CLI is deployed to the devices. If you chose to see a preview of the CLI before actually deploying to the devices, the preview will be displayed now. Verify the CLI and if you want to change any of the attributes, click Edit Attributes. Else, click Deploy.

Segment Routing

Configure Segment Routing

Segment Routing (SR) is a flexible, scalable way of doing source routing. The source router chooses a path, either explicit or Interior Gateway Protocol (IGP) shortest path and encodes the path in the packet header as an ordered list of segments. Segments represent subpaths that a router can combine to form a complete route to a network destination. Each segment is identified by a segment identifier (SID) that is distributed throughout the network using new IGP extensions.
Each router (node) and each link (adjacency) has an associated SID. Node segment identifiers are globally unique and represent the shortest path to a router as determined by the IGP. The network administrator allocates a node ID from a reserved block to each router. On the other hand, an adjacency segment ID is locally significant and represents a specific adjacency, such as egress interface, to a neighboring router. Routers automatically generate adjacency identifiers outside of the reserved block of node IDs. In an MPLS network, a segment identifier is encoded as an MPLS label stack entry. Segment IDs direct the data along a specified path. A node segment can be a multi-hop path while an adjacency segment is a one-hop path.

Cisco EPN Manager supports discovery of Segment Routing traffic engineering (SR-TE) policies through inventory. Discovered SR-TE policies can be used during CE provisioning. Promotion and reconciliation of CE services with SR-TE preferred path is supported.

### Create and Provision Carrier Ethernet Services with Segment Routing Policies

The Cisco EPN Manager supports provisioning of EPL, EVPL, Access EPL, Access EVPL carrier ethernet point-to-point services using Segment Routing traffic engineering (SR-TE) policy. You can perform promotion and reconcile of the CE services that uses SR-TE preferred path. You can modify SR-TE policy during modification of CE services. Related Circuits/VCs tab in Circuit/VCs 360* can be used to view the SR policies associated to this service.

To create and Provision an EVPL Service with SR Policies:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In the left plane, choose <strong>Maps &gt; Topology Maps &gt; Network Topology</strong>.</td>
</tr>
<tr>
<td>2</td>
<td>Click the Device Groups button in the toolbar and select the group of devices you want to show on the map.</td>
</tr>
<tr>
<td>3</td>
<td>In the Circuits/VCs tab, click the ‘+’ icon to open the Provisioning Wizard in a new pane to the right of the map.</td>
</tr>
<tr>
<td>4</td>
<td>Select <strong>Carrier Ethernet</strong> in the Technology drop-down list. Cisco EPN Manager displays a list of relevant circuit/VC types in the Service Type area. For example, Carrier Ethernet service types include EPL, EVPL, EP-LAN, and so on.</td>
</tr>
<tr>
<td>5</td>
<td>In the Service Type list, select the type of circuit/VC you want to create. For example, EVPL.</td>
</tr>
<tr>
<td>6</td>
<td>If you have defined profiles to set the attributes of the different services, select the required profile from the Select Profile drop-down list. See <strong>Create Circuit/VC Profiles</strong>, on page 572.</td>
</tr>
<tr>
<td>7</td>
<td>Click Next to go to the Service Details page.</td>
</tr>
<tr>
<td>8</td>
<td>(Optional) Select the customer for whom the EVPL is being created. If there are no customers in the list, go to <strong>Inventory &gt; Other &gt; Customers</strong> to create the customer in the system, and then restart the Provisioning Wizard.</td>
</tr>
<tr>
<td>9</td>
<td>Enter the Service Details. See <strong>Service Details Reference</strong>, on page 487 for descriptions of the fields and attributes.</td>
</tr>
<tr>
<td>10</td>
<td>Click Next.</td>
</tr>
<tr>
<td>11</td>
<td>In the <strong>Deployment Action</strong> field, specify what you want to do when the EVPL creation process is completed. You can either request a preview of the configurations that will be deployed to the relevant devices before the actual deployment or you can deploy the configurations immediately upon completion. For more information see, <strong>Save and Schedule a Provisioning Order</strong>, on page 545.</td>
</tr>
<tr>
<td>12</td>
<td>Click Next to go to the page(s) in which you define the UNI(s). In the case of E-Access, there is an additional page for defining the ENNI.</td>
</tr>
<tr>
<td>13</td>
<td>Identify the device and interface that will serve as the UNI:</td>
</tr>
</tbody>
</table>

**Note**: If one of the endpoints is an interface on a device that is not managed by Cisco EPN Manager, select the Unmanaged check box and provide information for the unmanaged device. See **Provision a Circuit/VC with an Unmanaged Endpoint**, on page 575.
Step 14: If you are creating a new UNI, enter the New UNI Details. See New UNI Details Reference, on page 488 for descriptions of the fields and attributes.

Step 15: Enter the UNI Service Details. See UNI Service Details Reference, on page 489 for descriptions of the fields and attributes.

Step 16: If one of the endpoints is an interface on a device that is not managed by Cisco EPN Manager, select the Unmanaged checkbox and provide information for the unmanaged device. See Provision a Circuit/VC with an Unmanaged Endpoint, on page 575 for more information.

Step 17: For E-LAN and E-TREE EVCs with H-VPLS as the core technology, select the devices that will serve as the primary and secondary hubs.

Step 18: For E-Line and E-Access EVCs: In the Pseudowire Settings page, you can select SR-TE policy for segment routing over which the EVC will traverse, as follows:

1. Check the Static Preferred Path checkbox to assign a static route for the service.
   
   **Note**  
   For E-access this check box is not applicable.

2. Click the SR Policy radio button.

3. Select the required SR-TE policy from the Preferred Path (A-Z) and Preferred Path (Z-A) drop-down lists.
   
   **Note**  
   Both Preferred Path(A-Z) and Preferred Path(Z-A) are optional fields.

4. Repeat steps 5 through 8 in Create and Provision a New Carrier Ethernet EVC, on page 483.

Step 19: Repeat steps 20 through 22 Create and Provision a New Carrier Ethernet EVC, on page 483.

---

**What to do next**

To receive free text routes names from technology providers, choose an SR services policy route and then choose Routes > Performance. When you point your cursor to the label you can view additional information coming from the provider, such as to which route a particular free text route name belong to and so on. Click the Multilayer Trace link to view the free route names of multilayer services either in 3D view or in Linear view mode. You can view only one route at a time in the 3D view. Click Routes > Placeholder to switch between routes to view switch between routes.

**View Segment Routing Policy Details**

Using Cisco EPN Manager, you can view the detailed information about an Segment Routing service in the following ways:

- **Using the Circuit/VC 360 View**: The Circuit/VC 360 view provides detailed information available for segment routing policies discovered using Cisco EPN Manager. The different parameters that are associated with the segment routing policy are displayed in two different tabs: Endpoint Details and Candidate Path. View the endpoint details of selected devices and in the Candidate Path tab, choose the path to view the segment list details. For example, for a selected path you can view the XTC address provisioning the path and the type of the path.
Figure 12: View EndPoints and Candidate Path Details

- Using the Network Topology and Service Details View: The Network Topology window presents a graphical, topological map view of devices and the links between them. It also enables you to visualize segment routing overlays within the displayed topology map.
  - To view a complete list of L3VPNs and its details, see View a Device Group's Circuits/VCs List in the Topology Window, on page 600. See, Get Quick Information About a Circuit/VC: Circuit/VC 360 View.
  - To view the L3VPN service details for a specific device, see View a Specific Device's Circuits/VCs

Provision Circuits in an Optical/DWDM Network

- Summary of Cisco EPN Manager Optical/DWDM Network Provisioning Support, on page 497
- Prerequisites for Provisioning Optical Circuits, on page 498
- Create and Provision an OCH Circuit, on page 498
- Create and Provision Two Mutually Diverse OCH-Trail UNI Circuits, on page 504
- Create and Provision a Media Channel Group SSON Circuit, on page 506
- Create and Provision a Media Channel SSON Circuit, on page 507
- Create and Provision an OTN Circuit, on page 510
- Create and Provision an ODU Circuit, on page 516
Summary of Cisco EPN Manager Optical/DWDM Network Provisioning Support

Cisco EPN Manager supports the provisioning of Dense Wavelength Division Multiplexing (DWDM) optical channel (OCH) circuit types. The DWDM optical technology is used to increase bandwidth over existing fiber optic backbones. It combines and transmits multiple signals simultaneously at different wavelengths on the same fiber. In effect, one fiber is transformed into multiple virtual fibers.

Cisco EPN Manager supports the following optical circuits:

- Dense Wavelength Division Multiplexing (DWDM) optical channel (OCH) circuit—Following are the different optical channel circuit types:
  - Optical Channel Network Connection (OCHNC) WSON—OCHNC WSON circuits establish connectivity between two optical nodes on a specified C-band wavelength. For more information, see Optical Channel Network Connection (OCHNC) WSON, on page 462.
  - Optical Channel Client Connection (OCHCC) WSON—OCHCC WSON circuits extend the OCHNC WSON to create an optical connection from the source client port to the destination client port of the TXP/MXP cards. For more information, see Optical Channel Client Connection (OCHCC) WSON, on page 463.
  - Optical Channel (OCH) Trail WSON—OCH trail WSON circuits transport the OCHCC WSON circuits. For more information, see Optical Channel (OCH) Trail WSON, on page 463.
  - Optical Channel (OCH) Trail connecting NCS 1002, NCS 55xx, and ASR 9K devices—This OCH trail circuit creates an optical connection from the source trunk port of an NCS 1002, NCS 55xx, or ASR 9K device to the destination trunk port of another similar device. For more information, see Optical Channel (OCH) Trail Connecting NCS 1002, NCS 55xx, and ASR 9K Devices, on page 463.
  - Optical Channel (OCH) Trail User-to-Network Interface (UNI)—An OCH trail UNI circuit establishes connectivity between Cisco NCS 2000 series devices and Cisco NCS 4000 series devices. For more information, see Optical Channel (OCH) Trail User-to-Network Interface (UNI), on page 464.
  - Spectrum Switched Optical Network (SSON)—SSON circuits allow you to provide more channels in a span. Using the SSON functionality, the circuits are placed closer to each other if they are created within a media channel group. For more information, see Spectrum Switched Optical Network (SSON) Circuits, on page 465.

- Optical Transport Network (OTN)—An OTN circuit can be established statically or dynamically between ingress and egress nodes using Resource Reservation Protocol (RSVP) signaling. For more information, see Optical Transport Network (OTN) Circuit, on page 465.
  - Optical Channel Data Unit User-to-Network Interface (ODU UNI)—An ODU UNI circuit represents the actual end-to-end client service passing through the OTN architecture. For more information, see Optical Channel Data Unit User-to-Network Interface (ODU UNI), on page 466.
  - Optical Channel Data Unit (ODU) Tunnel—ODU tunnel circuits transport the ODU UNIs. For more information, see Optical Channel Data Unit (ODU) Tunnel, on page 467.
  - Optical Channel Payload Unit (OPU) Over Optical Channel Data Unit (ODU)—OPU over ODU circuits provide a high-bandwidth point-to-point connection between two customer designated premises. These circuits use ODU UNI circuits to carry client signals through the network. For more information, see Optical Channel Payload Unit (OPU) Over Optical Channel Data Unit (ODU), on page 467.
Prerequisites for Provisioning Optical Circuits

Following are the prerequisites for provisioning an optical circuit:

- Cisco EPN Manager supports both, Wavelength Switched Optical Network (WSON) and non-WSON circuits. However, for non-WSON circuits, Cisco EPN Manager supports only circuit discovery, which includes circuit overlay, circuit 360 view, multilayer trace view, and circuit details. Cisco EPN Manager does not support the provisioning, activation, deactivation, protection switch actions, and modification of non-WSON circuits.
- Communication between devices must be set up before you can provision an optical circuit.
- Inventory collection status for the devices on which the optical circuits will be provisioned must be Completed. To check this, go to Inventory > Device Management > Network Devices, and look at the status in the Last Inventory Collection Status column.
- DWDM grid unit must be set to either, wavelength or frequency. To do this, go to Administration > Settings > System Settings > Circuits/VCs Display, and under the DWDM Grid Unit area, choose either Wavelength (Nanometer (nm)) or Frequency (Terahertz (THz)).
- Before you provision an OCHNC or a Media Channel NC circuit using NCS2000 series devices running on software version 10.7 or later, ensure that you create a UNI config, either in Cisco Transport Controller (CTC) or in Cisco EPN Manager.
- Optionally, customers must be created in the system so that you can associate a circuit/VC to a customer during the circuit/VC creation and provisioning process. From the left sidebar, choose Inventory > Other > Customers to create and manage customers.

Create and Provision an OCH Circuit

To provision an OCH circuit:

**Before you begin**

For information about the prerequisites that must be met before you can provision an optical circuit, see Prerequisites for Provisioning Optical Circuits, on page 498.

**Step 1** From the left sidebar, choose Maps > Topology Maps > Network Topology.
**Step 2** Click Device Groups, and then select the location in which you want to create the OCH circuit.
**Step 3** Close the Device Groups popup window.
**Step 4** In the Network Topology window, click Circuits/VCs.
Step 5 Click the Circuits/VCs tab, then click the + (Create) icon in the Circuits/VCs pane toolbar. The Provisioning Wizard opens in a new pane to the right of the map. You can also access the Provisioning wizard by choosing Configuration > Network > Service Provisioning.

Step 6 From the Technology drop-down list, choose Optical. Cisco EPN Manager displays a list of relevant circuit types in the Service Type area. For example, Optical service types for OCH circuits include OCHNC WSON, OCHCC WSON, OCH-Trail WSON, and OCH-Trail UNI.

Step 7 In the Service Type area, choose the type of OCH circuit you want to create.

Step 8 If you have defined profiles to set the attributes of the different services, select the required profile from the Select Profile drop-down list. See Create Circuit/VC Profiles, on page 572.

Step 9 Click Next to go to the Customer Section page.

Step 10 (Optional) Select the customer for whom the circuit is being created. If there are no customers in the list, go to Inventory > Other > Customers to create the customer in the system, and then restart the Provisioning Wizard.

Step 11 Enter the circuit name and its description in the Customer Section page.

Step 12 Click Next to go to the Circuit Section page.

Note If you select OCH-Trail UNI as the optical service type, the Endpoint Section page appears first followed by the Circuit Section page.

Step 13 Enter the circuit details. See Circuit Section Reference for OCH Circuit Types, on page 500 for descriptions of the fields and attributes.

Step 14 Click Next to go to the Endpoint Section page.

Step 15 Select a row in the Endpoint table, and then click a device in the map to populate the Device Name column with the selected device. Alternatively, you can click the row in the Endpoint table to edit the Device Name, Termination Point, Add/Drop Port, OCH-Trail, and Side columns. The Side column gets auto-populated based on the port selected. Only network elements that are available and compatible with the circuit type you chose will be displayed.

Note The Add Port and Drop Port columns are available only for OCHNC WSON circuit. Once you choose the port that needs to be added to the Add Port column, the values in the Drop Port and Side columns get auto-populated. Also, you can manually edit the values in the Drop Port column.

Step 16 Select a trail diversity for the OCH circuit. The OCH circuit that you are creating will be diverse from the trail that you choose.

Note You cannot modify or delete the trail diversity once it is created.

Step 17 Click Next to go to the Constraints Section page.

Step 18 Click a device node or a link in the map to add it to the Constraints table. Alternatively, you can click the ‘+’ button in the table toolbar to add a new row to the table and edit the Node/Link Name, Include/Exclude, and Route columns. Only network elements and links that are compatible with the circuit type you chose will be displayed.

Note When the row is in the edit mode, you cannot click a device or a link in the map to populate the columns in the Constraints table. The following route constraint conditions apply to the OCHCC Trail WSON circuit:

- The modified route constraints are not applied immediately to the circuit but might cause a reroute. However, the modification is applied at the next route operation or restoration.

- The Circuit Overlay shows only the constraints applicable to current route, while the Circuit Edit wizard will display the currently configured constraints.

- The Circuit Edit wizard contains the constraints table displaying the different constraints with respect to constraints icon displayed using circuit overlay.
Step 19 Click Next to go to the Alien Wavelength Section page. The current Alien Wavelength configurations such as the Card, Trunk mode, and Fec mode for the source and destination nodes are displayed. You can choose to create new configurations of the Alien Wavelength for the source and destination nodes.

Note The Alien Wavelength Section is available only when you create OCHNC WSON circuits.

Step 20 Click Create Now to create the circuit. If you chose to see a preview of the TL1 or CLI commands that will be deployed to the devices, it will be displayed on clicking Preview and now, you can either deploy the configurations to the device or cancel it but you cannot edit the attributes.

Step 21 The circuit should be added to the list in the Circuits/VCs pane in the Network Topology window. To check the provisioning state, click the i icon next to the circuit/VC name to see the Circuit/VC 360 view.

Circuit Section Reference for OCH Circuit Types

The following table lists and describes the attributes that define the OCH circuit types.

*Table 39: Circuit Section Reference—OCH Circuit Types*

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Circuit Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Label</td>
<td>Unique name to identify the circuit.</td>
<td></td>
</tr>
<tr>
<td>State</td>
<td>Administrative state for the circuit. Values are:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• In Service—The circuit is in service and able to carry traffic.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Out of Service—The circuit is out of service and unable to carry traffic.</td>
<td></td>
</tr>
<tr>
<td>Bi-directional</td>
<td>Check this check box to create a two-way circuit.</td>
<td></td>
</tr>
</tbody>
</table>

For OCHCC WSON and OCH Trail WSON circuit types.
### Protection
Protection mechanism for the circuit. Cisco EPN Manager supports the following protection mechanism based on the circuit type selected:

- **None**—For unprotected circuits. This value is available for all OCH circuit types.
- **PSM**—When a Protection Switch Module (PSM) card is connected to a TXP card. This value is available for OCHNC WSON and OCHCC WSON circuit types.
- **Y-Cable**—When a transponder or muxponder card protects the circuit. This value is available for OCHCC WSON circuit type.
- **Splitter**—When a MXPP/TXPP card is used. The circuit source and destination are on MXPP_MR_2.5G and TXPP_MR_2.5G cards. These cards provide splitter (line-level) protection (trunk protection typically on TXPP or MXPP transponder cards). This value is available only for OCHCC WSON circuit type.

| Enabled | For OCHNC WSON circuit type. |

### Route Properties

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diverse From Tunnel</td>
<td>Select a tunnel to ensure that it is not used by the circuit you are provisioning. This is to ensure that if there is a failure in a tunnel, the same tunnel is not used by another circuit.</td>
<td>For OCH-Trail UNI circuit types when the Mutual Diversity check box is unchecked.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Validation</td>
<td>Validation mode for the circuit. Values are:</td>
<td>For all OCH circuit types.</td>
</tr>
<tr>
<td></td>
<td>- Full—The circuit is created when the circuit validation result is greater than or equal to the acceptance threshold value.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- None—The circuit is created without considering the acceptance threshold value.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acceptance Threshold</td>
<td>Protection acceptance threshold value set for the OCH protected circuits. Values are:</td>
<td>For all OCH circuit types when the Validation field is set to Full.</td>
</tr>
<tr>
<td></td>
<td>- Green—Indicates that the restoration failure risk is 0%.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Yellow—Indicates that the restoration failure risk is between 0% and 16%.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Orange—Indicates that the restoration failure risk is between 16% and 50%.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Red—Indicates that the restoration failure risk is greater than 50%.</td>
<td></td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Enabled</td>
</tr>
<tr>
<td>---------------------------------------</td>
<td>----------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Protect Acceptance Threshold</td>
<td>Protection acceptance threshold value set for the OCH protected circuits. Values are:</td>
<td>For OCHNC WSON circuit type when:</td>
</tr>
<tr>
<td></td>
<td>• Green—Indicates that the restoration failure risk is 0%.</td>
<td>• Protection field is set to PSM, Y-Cable, or Splitter.</td>
</tr>
<tr>
<td></td>
<td>• Yellow—Indicates that the restoration failure risk is between 0% and 16%.</td>
<td>• Validation field is set to Full.</td>
</tr>
<tr>
<td></td>
<td>• Orange—Indicates that the restoration failure risk is between 16% and 50%.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Red—Indicates that the restoration failure risk is greater that 50%.</td>
<td></td>
</tr>
<tr>
<td>Ignore Path Alarms</td>
<td>Check the check box to ignore path alarms.</td>
<td>For OCHCC WSON, OCHNC WSON, and OCH-Trail WSON circuit types.</td>
</tr>
<tr>
<td>Allow Regeneration</td>
<td>Check the check box to allow the network elements to regenerate the signal.</td>
<td>For all OCH circuit types.</td>
</tr>
<tr>
<td>Restoration</td>
<td>Check this check box to restore the failed OCH circuit to a new route.</td>
<td>For all OCH circuit types.</td>
</tr>
<tr>
<td>Priority</td>
<td>Prioritize the restoration operation for the failed OCH circuit. Values are High, Priority 1, Priority 2, Priority 3, Priority 4, Priority 5, Priority 6, and Low.</td>
<td>For all OCH circuit types when the Restoration check box is checked.</td>
</tr>
<tr>
<td>Restoration Validation</td>
<td>Validation mode for the restoration operation. Values are:</td>
<td>For all OCH circuit types when the Restoration check box is checked.</td>
</tr>
<tr>
<td></td>
<td>• None—The circuit is restored without considering the restoration acceptance threshold value.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Inherited—The restoration circuit inherits the validation and acceptance threshold values from the primary circuit.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Full—The circuit is restored when the restoration validation result is greater than or equal to the restoration acceptance threshold value.</td>
<td></td>
</tr>
<tr>
<td>Restoration Acceptance Threshold</td>
<td>Acceptance threshold value set for the restoration operation for OCH circuits. Values are:</td>
<td>For all OCH circuit types when:</td>
</tr>
<tr>
<td></td>
<td>• Green—Indicates that the restoration failure risk is 0%.</td>
<td>• Restoration check box is checked.</td>
</tr>
<tr>
<td></td>
<td>• Yellow—Indicates that the restoration failure risk is between 0% and 16%.</td>
<td>• Restoration Validation field is set to Full.</td>
</tr>
<tr>
<td></td>
<td>• Orange—Indicates that the restoration failure risk is between 16% and 50%.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Red—Indicates that the restoration failure risk is greater that 50%.</td>
<td></td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Enabled</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Restoration Protect Acceptance</td>
<td>Protection acceptance threshold value set for the restoration operation for OCH protected circuits. Values are:</td>
<td>For OCHNC WSON circuit type when:</td>
</tr>
<tr>
<td>Threshold</td>
<td>• Green—Indicates that the restoration failure risk is 0%.</td>
<td>• Protection field is set to PSM, Y-Cable, or Splitter.</td>
</tr>
<tr>
<td></td>
<td>• Yellow—Indicates that the restoration failure risk is between 0% and 16%.</td>
<td>• Restoration check box is checked.</td>
</tr>
<tr>
<td></td>
<td>• Orange—Indicates that the restoration failure risk is between 16% and 50%.</td>
<td>• Restoration Validation field is set to Full.</td>
</tr>
<tr>
<td></td>
<td>• Red—Indicates that the restoration failure risk is greater than 50%.</td>
<td></td>
</tr>
<tr>
<td>Revert</td>
<td>Reverts the circuit from the restored path to the original path after a failure is fixed. Values are None, Manual, and Automatic.</td>
<td>For OCHCC WSON, OCHNC WSON, and OCH-Trail WSON circuit types when the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Restoration check box is checked.</td>
</tr>
<tr>
<td>Soak Time</td>
<td>Period that the circuit on the restored path waits before switching to the original path after a failure is fixed.</td>
<td>For OCHCC WSON, OCHNC WSON, and OCH-Trail WSON circuit types when Revert</td>
</tr>
<tr>
<td></td>
<td></td>
<td>is set to Manual or Automatic.</td>
</tr>
<tr>
<td>Admin State</td>
<td>Select the admin state of the circuit as <strong>Up</strong> or <strong>Down</strong>. This impacts the circuit’s operability and determines whether the circuit can be activated or deactivated.</td>
<td>For OCH-Trail UNI circuit type.</td>
</tr>
<tr>
<td>Preferred Wavelength Properties</td>
<td>Wavelength options for the circuit. Values are <strong>Do Not Set</strong>, <strong>Set To Default</strong>, and <strong>Set Preferred Wavelength</strong>.</td>
<td>For OCH-Trail UNI circuit type.</td>
</tr>
<tr>
<td>Work Port Properties</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Auto Provisioning</td>
<td>Check this check box to enable the Auto Provisioning feature.</td>
<td>For all OCH circuit types</td>
</tr>
</tbody>
</table>
### Create and Provision Two Mutually Diverse OCH-Trail UNI Circuits

Use this procedure to create two OCH-Trail UNI circuits that are mutually diverse from each other. Both the circuits must originate from the same device. You can create both the circuits quickly using the Provisioning wizard in a single workflow.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>C Band</td>
<td>Conventional wavelength window to provision the circuit. Values are:</td>
<td>• For all OCHCC WSON, OCHNC WSON, and OCH-Trail WSON circuit types when the Auto Provisioning check box is unchecked.</td>
</tr>
<tr>
<td></td>
<td>• Odd—The odd position in the ITU grid.</td>
<td>• For OCH-Trail UNI circuit type when the Wavelength Options is set to Set Preferred Wavelength.</td>
</tr>
<tr>
<td></td>
<td>• Even—The even position in the ITU grid.</td>
<td>For all OCH circuit types when the C Band field is set to Odd or Even.</td>
</tr>
<tr>
<td>Wavelength/Frequency</td>
<td>Wavelength or frequency of the circuit. This value is applicable for the C Band that you chose.</td>
<td>For all OCH circuit types when the C Band field is set to Odd or Even.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong></td>
<td>You must set the DWDM grid unit to either wavelength or frequency. To do this, go to Administration &gt; Settings &gt; System Settings &gt; Circuits/VCs Display, and under the DWDM Grid Unit area, choose either Wavelength (Nanometer (nm)) or Frequency (Terahertz (THz)).</td>
</tr>
<tr>
<td>Preferred/Required</td>
<td>Select to determine whether the values set in the C Band and Wavelength/Frequency fields are preferred or required to provision the circuit.</td>
<td>For all OCH circuit types when the Auto Provisioning check box is unchecked.</td>
</tr>
</tbody>
</table>

**Protect Port Properties**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy from Work Port</td>
<td>Check this check box to copy the values set in the Work Port Properties section.</td>
<td>For all OCH circuit types when the Protection field is set to PSM, Y-Cable, or Splitter.</td>
</tr>
</tbody>
</table>
Before you begin

For information about the prerequisites that must be met before you can provision an optical circuit, see **Prerequisites for Provisioning Optical Circuits**, on page 498.

---

**Step 1**
From the left sidebar, choose **Maps > Topology Maps > Network Topology**.

**Step 2**
Click **Device Groups**, and then select the location in which you want to create the OCH circuit.

**Step 3**
Close the **Device Groups** popup window.

**Step 4**
In the **Network Topology** window, click **Circuits/VCs**.

**Step 5**
Click the **Circuits/VCs** tab, then click the + (Create) icon in the Circuits/VCs pane toolbar. The Provisioning Wizard opens in a new pane to the right of the map.

You can also access the Provisioning wizard by choosing **Configuration > Network > Service Provisioning**.

**Step 6**
From the **Technology** drop-down list, choose **Optical**.

**Step 7**
In the **Service Type** area, choose **OCH-Trail UNI**.

**Step 8**
If you have defined profiles to set the attributes of the different services, select the required profile from the Select Profile drop-down list. See **Create Circuit/VC Profiles**, on page 572.

**Step 9**
Click **Next** to go to the **Customer Section** page.

**Step 10**
Check the **Mutual Diversity** check box to create two OCH-Trail UNI circuits that are mutually diverse from each other.

**Step 11**
Enter the circuit name and its description in the **Customer Section** page.

**Step 12**
Click **Next** to go to the **Endpoint Section** page.

**Step 13**
Select a row in the Endpoint table, and then click a device in the map to populate the Device Name column with the selected device. Alternatively, you can click the row in the Endpoint table to edit the Device Name and Interface.

**Note** When the row is in the edit mode, you cannot click a device in the map to populate the **Device Name** column.

**Step 14**
Click **Next** to go to the **Circuit Section** page.

**Step 15**
Enter the circuit details. See **Circuit Section Reference for OCH Circuit Types**, on page 500 for descriptions of the fields and attributes.

**Step 16**
Click **Next** to go to the **Constraints Section** page.

**Step 17**
Click a device node or a link in the map to add it to the Constraints table. Alternatively, you can click the '+' button in the table toolbar to add a new row to the table and edit the Node/Link Name, Include/Exclude, and Route columns. Only network elements and links that are compatible with the circuit type you chose will be displayed.

**Note** When the row is in the edit mode, you cannot click a device or a link in the map to populate the columns in the Constraints table.

**Step 18**
Click **Next**. The **Customer Section** page for the second circuit is displayed.

**Step 19**
Repeat Step 11 to Step 17 to create the second circuit.

**Step 20**
Click **Create Now** to create the circuit. If you chose to see a preview of the TL1 or CLI commands that will be deployed to the devices, it will be displayed on clicking **Preview** and now, you can either deploy the configurations to the device or cancel it but you cannot edit the attributes.

**Step 21**
The circuits should be added to the list in the Circuits/VCs pane in the Network Topology window. To check the provisioning state, click the i icon next to the circuit/VC names to see the Circuit/VC 360 view.

---
Create and Provision a Media Channel Group SSON Circuit

To create and provision a Media Channel Group SSON circuit:

**Before you begin**

For information about the prerequisites that must be met before you can provision an optical circuit, see *Prerequisites for Provisioning Optical Circuits, on page 498.*

---

**Step 1**
From the left sidebar, choose **Maps > Topology Maps > Network Topology.**

**Step 2**
Click **Device Groups,** and then select the location in which you want to create the Media Channel Group SSON circuit.

**Step 3**
Close the **Device Groups** popup window.

**Step 4**
In the **Network Topology** window, click **Circuits/VCs.**

**Step 5**
Click the **Circuits/VCs** tab, then click the + (Create) icon in the **Circuits/VCs** pane toolbar. The Provisioning Wizard opens in a new pane to the right of the map.

You can also access the Provisioning wizard by choosing **Configuration > Network > Service Provisioning.**

**Step 6**
From the **Technology** drop-down list, choose **Optical.** Cisco EPN Manager displays a list of relevant circuit types in the Service Type area.

**Step 7**
In the **Service Type** area, choose **Media Channel Group SSON.**

**Step 8**
If you have defined profiles to set the attributes of the different services, select the required profile from the **Select Profile** drop-down list. See *Create Circuit/VC Profiles,* on page 572.

**Step 9**
Click **Next** to go to the **Customer Section** page.

**Step 10**
(Optional) Select the customer for whom the circuit is being created. If there are no customers in the list, go to **Inventory > Other > Customers** to create the customer in the system, and then restart the Provisioning Wizard.

**Step 11**
Enter the circuit name and its description in the **Customer Section** page.

**Note**  
A maximum of only 80 characters are allowed for the Circuit Name field.

**Step 12**
Click **Next** to go to the **Endpoint Section** page.

**Step 13**
Select a row in the Endpoint table, and then click a device in the map to populate the Device Name column with the selected device. Alternatively, you can click the row in the Endpoint table to edit the Device Name, Termination Point, and Add/Drop Port columns. Only network elements that are available and compatible with the circuit type you chose will be displayed.

**Note**  
When the row is in the edit mode, you cannot click a device in the map to populate the Device Name column.

**Step 14**
Click **Next** to go to the **Circuit Section** page.

**Step 15**
Choose the required circuit width.

**Step 16**
To set the **Central Wavelength/Frequency Properties,** do one of the following:

- Check the **Auto Provisioning** check box.
- Choose the required **Wavelength** for the circuit and then choose either **Preferred** or **Required** option to determine whether the values set in the **Wavelength** field is preferred or required to provision the circuit.

**Step 17**
Click **Next** to go to the **Constraints Section** page.
Step 18
Click a device node or a link in the map to add it to the Constraints table. Alternatively, you can click the ‘+’ button in the table toolbar to add a new row to the table and edit the Node/Link Name, Include/Exclude, and Route columns. Only network elements and links that are compatible with the circuit type you chose will be displayed.

Note
When the row is in the edit mode, you cannot click a device or a link in the map to populate the columns in the Constraints table.

Step 19
Click Create Now to create the circuit. If you chose to see a preview of the TL1 or CLI commands that will be deployed to the devices, it will be displayed on clicking Preview and now, you can either deploy the configurations to the device or cancel it, but you cannot edit the attributes.

The circuit should be added to the list in the Circuits/VCs pane in the Network Topology window. To check the provisioning state, click the i icon next to the circuit/VC name to see the Circuit/VC 360 view.

Create and Provision a Media Channel SSON Circuit

To create and provision a Media Channel SSON circuit:

Before you begin

• Ensure that a Media channel group SSON is already created to associate the Media Channel SSON circuits with the Media channel group. See Create and Provision a Media Channel Group SSON Circuit, on page 506.

• For information about the prerequisites that must be met before you can provision an optical circuit, see Prerequisites for Provisioning Optical Circuits, on page 498.

Step 1
From the left sidebar, choose Maps > Topology Maps > Network Topology.

Step 2
Click Device Groups, and then select the location in which you want to create the Media Channel SSON circuit.

Step 3
Close the Device Groups popup window.

Step 4
In the Network Topology window, click Circuits/VCs.

Step 5
Click the Circuits/VCs tab, then click the + (Create) icon in the Circuits/VCs pane toolbar. The Provisioning Wizard opens in a new pane to the right of the map.

You can also access the Provisioning wizard by choosing Configuration > Network > Service Provisioning.

Step 6
From the Technology drop-down list, choose Optical. Cisco EPN Manager displays a list of relevant circuit types in the Service Type area. For example, optical service types for Media Channel SSON circuits include Media Channel NC SSON, Media Channel Trail SSON, and Media Channel CC SSON.

Step 7
In the Service Type area, choose the type of Media Channel SSON circuit you want to create.

Step 8
If you have defined profiles to set the attributes of the different services, select the required profile from the Select Profile drop-down list. See Create Circuit/VC Profiles, on page 572.

Step 9
Click Next to go to the Customer Section page.

Step 10
(Optional) Select the customer for whom the circuit is being created. If there are no customers in the list, go to Inventory > Other > Customers to create the customer in the system, and then restart the Provisioning Wizard.

Step 11
Enter the circuit name and its description in the Customer Section page.
For the Media Channel NC SSON and Media Channel Trail SSON circuits, a maximum of only 77 characters are allowed in the Circuit Name field. Of the 77 characters, three characters are reserved for carrier suffix.

For the Media Channel CC SSON circuits, a maximum of 71 characters are allowed in the Circuit Name field.

**Note**

For the Media Channel NC SSON and Media Channel Trail SSON circuits, a maximum of only 77 characters are allowed in the Circuit Name field. Of the 77 characters, three characters are reserved for carrier suffix.

For the Media Channel CC SSON circuits, a maximum of 71 characters are allowed in the Circuit Name field.

**Step 12**

Click Next to go to the Endpoint Section page.

**Step 13**

Select a row in the Endpoint table, and then click a device in the map to populate the Device Name column with the selected device. Alternatively, you can click the row in the Endpoint table to edit the Device Name and Termination Point columns. The Side column gets auto-populated based on the termination point selected. Only network elements that are available and compatible with the circuit type you chose will be displayed.

**Note**

The MCH-Trail Name column is available only when you create a Media Channel CC SSON circuit.

**Step 14**

Select a media channel diversity for the MCH circuit. The MCH circuit that you are creating will be diverse from the media channel that you choose.

**Note**

You cannot modify or delete the media channel diversity once it is created.

**Step 15**

Click Next to go to the Circuit Section page.

**Note**

For the Media Channel CC SSON circuits, the Circuit Section page is not available if you have entered an MCH-Trail Name in the Endpoint table.

**Step 16**

Choose the Media Channel Group to which you want to associate the Media Channel SSON circuit.

**Step 17**

Enter the circuit details. See Circuit Section Reference for Media Channel SSON Circuit Types, on page 508 for descriptions of the fields and attributes.

**Step 18**

Click Next to go to the Constraints Section page.

**Step 19**

Click a device node or a link in the map to add it to the Constraints table. Alternatively, you can click the '+ ' button in the table tool bar to add a new row to the table and edit the Node/Link Name, Include/Exclude, and Route columns. Only network elements and links that are compatible with the circuit type you chose will be displayed.

**Note**

When the row is in the edit mode, you cannot click a device or a link in the map to populate the columns in the Constraints table.

**Step 20**

Click Create Now to create the circuit. If you chose to see a preview of the TL1 or CLI commands that will be deployed to the devices, it will be displayed on clicking Preview and now, you can either deploy the configurations to the device or cancel it, but you cannot edit the attributes.

---

The circuit should be added to the list in the Circuits/VCs pane in the Network Topology window. To check the provisioning state, click the i icon next to the circuit/VC name to see the Circuit/VC 360 view.

### Circuit Section Reference for Media Channel SSON Circuit Types

The following table lists and describes the attributes that define the Media Channel SSON circuit types.

**Table 40: Circuit Section Reference—Media Channel SSON Circuit Types**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Central Wavelength/Frequency Properties</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Cisco Evolved Programmable Network Manager 3.0 User and Administrator Guide

508
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto Provisioning</td>
<td>Check this check box to automatically set the wavelength or frequency properties for the circuit.</td>
<td>For all Media Channel SSON circuit types.</td>
</tr>
<tr>
<td>Wavelength (nm)</td>
<td>Wavelength or frequency of the circuit.</td>
<td>For all Media Channel SSON circuit types.</td>
</tr>
<tr>
<td>Note</td>
<td>You must set the DWDM grid unit to either wavelength or frequency. To do this, go to Administration &gt; Settings &gt; System Settings &gt; Circuits/VCs Display, and under the DWDM Grid Unit area, choose either Wavelength (Nanometer (nm)) or Frequency (Terahertz (THz)).</td>
<td>For all Media Channel SSON circuit types when the Auto Provisioning check box is unchecked.</td>
</tr>
<tr>
<td>Preferred/Required</td>
<td>Select to determine whether the values set in the Wavelength field is preferred or required to provision the circuit.</td>
<td>For all Media Channel SSON circuit types when the Auto Provisioning check box is unchecked.</td>
</tr>
</tbody>
</table>

**Optical Properties**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Validation</td>
<td>Validation mode for the circuit. Values are:</td>
<td>For all Media Channel SSON circuit types.</td>
</tr>
<tr>
<td></td>
<td>• Full—The circuit is created when the circuit validation result is greater than or equal to the acceptance threshold value.</td>
<td>For all Media Channel SSON circuit types.</td>
</tr>
<tr>
<td></td>
<td>• None—The circuit is created without considering the acceptance threshold value.</td>
<td>For all Media Channel SSON circuit types.</td>
</tr>
<tr>
<td>Acceptance Threshold</td>
<td>Protection acceptance threshold value set for the circuit. Values are:</td>
<td>For all Media Channel SSON circuit types when the Validation field is set to Full.</td>
</tr>
<tr>
<td></td>
<td>• Green—Indicates that the restoration failure risk is 0%.</td>
<td>For all Media Channel SSON circuit types when the Validation field is set to Full.</td>
</tr>
<tr>
<td></td>
<td>• Yellow—Indicates that the restoration failure risk is between 0% and 16%.</td>
<td>For all Media Channel SSON circuit types when the Validation field is set to Full.</td>
</tr>
<tr>
<td></td>
<td>• Orange—Indicates that the restoration failure risk is between 16% and 50%.</td>
<td>For all Media Channel SSON circuit types when the Validation field is set to Full.</td>
</tr>
<tr>
<td></td>
<td>• Red—Indicates that the restoration failure risk is greater than 50%.</td>
<td>For all Media Channel SSON circuit types when the Validation field is set to Full.</td>
</tr>
<tr>
<td>Ignore Path Alarms</td>
<td>Check the check box to ignore path alarms.</td>
<td>For all Media Channel SSON circuit types.</td>
</tr>
<tr>
<td>Allow Regeneration</td>
<td>Check the check box to allow the network elements to regenerate the signal.</td>
<td>For all Media Channel SSON circuit types.</td>
</tr>
<tr>
<td>Restoration</td>
<td>Check this check box to restore the failed Media Channel SSON circuit to a new route.</td>
<td>For all Media Channel SSON circuit types.</td>
</tr>
<tr>
<td>Priority</td>
<td>Prioritize the restoration operation for the failed circuit. Values are High, Priority 1, Priority 2, Priority 3, Priority 4, Priority 5, Priority 6, and Low.</td>
<td>For all Media Channel SSON circuit types when the Restoration check box is checked.</td>
</tr>
</tbody>
</table>
### Create and Provision an OTN Circuit

To provision an OTN circuit:

#### Before you begin

For information about the prerequisites that must be met before you can provision an optical circuit, see Prerequisites for Provisioning Optical Circuits, on page 498.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Restoration Validation</strong></td>
<td>Validation mode for the restoration operation. Values are:</td>
<td>For all Media Channel SSON circuit types when the Restoration check box is checked.</td>
</tr>
<tr>
<td></td>
<td>• None—The circuit is restored without considering the restoration acceptance threshold value.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Inherited—The restored circuit inherits the validation and acceptance threshold values from the primary circuit.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Full—The circuit is restored when the restoration validation result is greater than or equal to the restoration acceptance threshold value.</td>
<td></td>
</tr>
<tr>
<td><strong>Restoration Acceptance Threshold</strong></td>
<td>Acceptance threshold value set for the restoration operation for the circuit. Values are:</td>
<td>For all Media Channel SSON circuit types when:</td>
</tr>
<tr>
<td></td>
<td>• Green—Indicates that the restoration failure risk is 0%.</td>
<td>• Restoration check box is checked.</td>
</tr>
<tr>
<td></td>
<td>• Yellow—Indicates that the restoration failure risk is between 0% and 16%.</td>
<td>• Restoration Validation field is set to Full.</td>
</tr>
<tr>
<td></td>
<td>• Orange—Indicates that the restoration failure risk is between 16% and 50%.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Red—Indicates that the restoration failure risk is greater than 50%.</td>
<td></td>
</tr>
<tr>
<td><strong>Revert</strong></td>
<td>Reverts the circuit from the restored path to the original path after a failure is fixed. Values are None, Manual, and Automatic.</td>
<td>For all Media Channel SSON circuit types when the Restoration check box is checked.</td>
</tr>
<tr>
<td><strong>Soak Time</strong></td>
<td>Period that the circuit on the restored path waits before switching to the original path after a failure is fixed.</td>
<td>For all Media Channel SSON circuit types when the Revert option is set to Manual or Automatic.</td>
</tr>
</tbody>
</table>

#### Step 1

From the left sidebar, choose Maps > Topology Maps > Network Topology.

#### Step 2

Click Device Groups, and then select the location in which you want to create the OTN circuit.

#### Step 3

In the Network Topology window, click Circuits/VCs.

#### Step 4

Click the Circuits/VCs tab, then click the + (Create) icon in the Circuits/VCs pane toolbar. The Provisioning Wizard opens in a new pane to the right of the map.

You can also access the Provisioning wizard by choosing Configuration > Network > Service Provisioning.
Step 5  From the Technology drop-down list, choose Optical. Cisco EPN Manager displays a list of relevant circuit types in the Service Type area. For example, service types for OTN circuits include ODU UNI, ODU Tunnel, OPU over ODU, and ODU UNI Hairpin.

Step 6  In the Service Type area, choose the type of OTN circuit you want to create.

Step 7  If you have defined profiles to set the attributes of the different services, select the required profile from the Select Profile drop-down list. See Create Circuit/VC Profiles, on page 572.

Step 8  Click Next to go to the Customer Details page.

Step 9  (Optional) Select the customer for whom the circuit is being created. If there are no customers in the list, go to Inventory > Other > Customers to create the customer in the system, and then restart the Provisioning Wizard.

Step 10  Enter the circuit name and its description in the Customer Details page.

Step 11  Click Next to go to the Circuit Details page.

Step 12  Enter the circuit details. See Circuit Section Reference for OTN Circuit Types, on page 511 for descriptions of the fields and attributes.

Step 13  Click Next to go to the Endpoint Section page.

Step 14  Select a row in the Endpoint table, and then click a device in the map to populate the Device Name column with the selected device. Alternatively, you can click the row in the Endpoint table to edit the Device Name and Interface/Termination Point columns. Only network elements that are available and compatible with the circuit type you chose will be displayed.

Note  When the row is in the edit mode, you cannot click a device in the map to populate the Device Name column.

Step 15  Enter the protection type and path options for the circuit. See Endpoint Section Reference for OTN Circuit Types, on page 513 for descriptions of the fields and attributes.

Step 16  Click Create Now to create the circuit. If you chose to see a preview of the TL1 or CLI commands that will be deployed to the devices, it will be displayed on clicking Preview. After seeing the preview of the TL1 or CLI commands, you can either deploy the configurations to the devices or cancel the provisioning operation.

The circuit should be added to the list in the Circuits/VCs tab in the Network Topology window. To check the provisioning state, click the / icon next to the circuit/VC name to see the Circuit/VC 360 view.

Circuit Section Reference for OTN Circuit Types

The following table lists and describes the attributes that define the OTN circuit types.

Table 41: Circuit Section Reference—OTN Circuit Types

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Circuit Properties</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bandwidth</td>
<td>Bandwidth required to provision the OTN circuit.</td>
<td>For all OTN circuit types.</td>
</tr>
<tr>
<td></td>
<td>See Table 43: Value Mapping—Bandwidth and Service Type for ODU UNI Circuits for the mapping of values in the Bandwidth, and Service Type fields.</td>
<td></td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Enabled</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
<td>---------</td>
</tr>
<tr>
<td>A-End Open Ended</td>
<td>Check this check box to create an open-ended circuit, in which the source end point is connected to an ODU subcontroller, instead of a client payload controller.</td>
<td>For ODU UNI circuit type when the Bandwidth field is set to ODU0, ODU1, ODU2, or ODU2E.</td>
</tr>
<tr>
<td>Z-End Open Ended</td>
<td>Check this check box to create an open-ended circuit, in which the destination end point is connected to an ODU subcontroller, instead of a client payload controller.</td>
<td>For ODU UNI circuit type when the Bandwidth field is set to ODU0, ODU1, ODU2, or ODU2E.</td>
</tr>
<tr>
<td>Service Type</td>
<td>Service types supported for the selected bandwidth. See Table 43: Value Mapping—Bandwidth and Service Type for ODU UNI Circuits for the mapping of values in the Bandwidth and Service Type fields.</td>
<td>For ODU UNI circuit type.</td>
</tr>
<tr>
<td>Route Properties</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bit Rate</td>
<td>Total number of bits per second.</td>
<td>For all OTN circuit types (except ODU UNI Hairpin) when the Bandwidth field is set to ODUFLEX.</td>
</tr>
</tbody>
</table>
| Framing Type | The elementary signal of the requested service. Values are:  
• CBR—Constant bit rate.  
• GFP-F-Fixed—Fixed and frame mapped generic framing procedure. | For all OTN circuit types (except ODU UNI Hairpin) when the Bandwidth field is set to ODUFLEX. |
### Endpoint Section Reference for OTN Circuit Types

The following table lists and describes the attributes that define the protection type and path options for OTN circuit types.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record Route</td>
<td>Check this check box to record the circuit route.</td>
<td>For all OTN circuit types (except ODU UNI Hairpin).</td>
</tr>
<tr>
<td><strong>Endpoints</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Device Name</td>
<td>A end and Z end devices of the circuit.</td>
<td>For all OTN circuit types.</td>
</tr>
<tr>
<td>Note</td>
<td>For ODU UNI Hairpin circuits, both A end and Z end will be the same device but with different termination points.</td>
<td></td>
</tr>
<tr>
<td>Interface</td>
<td>Interface names for the A end and Z end devices.</td>
<td>For ODU UNI circuits.</td>
</tr>
<tr>
<td>Termination Point</td>
<td>Termination point for the cards.</td>
<td>For OPU over ODU and ODU UNI Hairpin circuits.</td>
</tr>
<tr>
<td><strong>Protection Type</strong></td>
<td>Protection type for the OTN circuit. Values are:</td>
<td>For all OTN circuit types (except ODU UNI Hairpin).</td>
</tr>
<tr>
<td>• 1+0</td>
<td>Unprotected card. If a failure is detected in the working path, it results in loss of data.</td>
<td></td>
</tr>
<tr>
<td>• 1+1</td>
<td>Both primary and secondary path carry traffic end to end and the receiver receives and compares both the traffic. When the egress node detects failure in one path, it switches the traffic to the unaffected path.</td>
<td></td>
</tr>
<tr>
<td>• 1+R</td>
<td>When the primary path fails, the restored path is calculated and traffic is switched to the restored path. If the primary path is non-revertible, the restored path becomes the new primary path.</td>
<td></td>
</tr>
<tr>
<td>• 1+1+R</td>
<td>Both primary and secondary path carry traffic. When the egress node detects failure in one path, it switches the traffic to the unaffected path. The restored path is calculated and traffic is switched to the restored path. If the primary or secondary path is non-revertible, the restored path becomes the new primary or secondary path.</td>
<td></td>
</tr>
<tr>
<td>Note</td>
<td>This protection type is not supported for Cisco NCS 4000 series devices.</td>
<td></td>
</tr>
</tbody>
</table>
### Attribute

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diverse From Tunnel ID</td>
<td>Select a tunnel to ensure that it is not used by the circuit you are provisioning. This is to ensure that if there is a failure in a tunnel, the same tunnel is not used by another circuit.</td>
<td>For all OTN circuit types(except ODU UNI Hairpin).</td>
</tr>
</tbody>
</table>

### Working Path, Protected Path, and Restored Path

The Protected Path field group is available for all OTN circuit types (except ODU UNI Hairpin) only when the Protection Type field is set to 1+1 or 1+1+R.

The Restored Path field group is available for all OTN circuit types (except ODU UNI Hairpin) only when the Protection Type field is set to 1+R or 1+1+R.

<table>
<thead>
<tr>
<th>Type</th>
<th>Choose the type of working path or protected path for the circuit. Values are Dynamic and Explicit.</th>
<th>For all OTN circuit types (except ODU UNI Hairpin).</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Check this check box to create a new explicit working or protected path for the circuit.</td>
<td>For all OTN circuit types (except ODU UNI Hairpin) when the Type field is set to Explicit.</td>
</tr>
<tr>
<td>Select Existing EP</td>
<td>Choose an existing explicit working or protected path for the circuit.</td>
<td>For all OTN circuit types (except ODU UNI Hairpin) when the Type field is set to Explicit and the New check box is unchecked.</td>
</tr>
<tr>
<td>New Name</td>
<td>Enter a name for the explicit path that you are creating. In the table below the New Name field, click the ‘+’ button to add a new row to the table, and then select a device and an explicit path controller as the interface for the device.</td>
<td>For all OTN circuit types (except ODU UNI Hairpin) when the Type field is set to Explicit and the New check box is checked.</td>
</tr>
</tbody>
</table>

### Protection Profile

The Protection Profile field group is available for all OTN circuit types (except ODU UNI Hairpin) only when the Protection Type field is set to 1+1, 1+R, or 1+1+R and a valid A end device is selected.
The profile used to manage the protection of the circuit. This protection profile must be configured on the A end node of the circuit.

**Note** You can enter the protection profile that was configured on the device.

The details of the protection profile such as the protection type, SNC, hold off, wait to restore, and whether the circuit is revertive are displayed.

## Bandwidth and Service Type Value Mapping for ODU UNI Circuits.

The following table maps the values in the Bandwidth and Service Type fields for the ODU UNI circuits

<table>
<thead>
<tr>
<th>Bandwidth</th>
<th>Service Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>ODU0</td>
<td>• Ethernet OPU0 GMP</td>
</tr>
<tr>
<td>ODU1</td>
<td>• OTN OPU1</td>
</tr>
<tr>
<td></td>
<td>• Sonet OPU1 BMP</td>
</tr>
<tr>
<td></td>
<td>• SDH OPU1 BMP</td>
</tr>
<tr>
<td>ODU1E</td>
<td>• Ethernet OPU1e BMP</td>
</tr>
<tr>
<td></td>
<td>• OTN OPU1e</td>
</tr>
<tr>
<td>ODU1F</td>
<td>• OTN OPU1f</td>
</tr>
<tr>
<td>ODU2</td>
<td>• Ethernet OPU2 GFP_F</td>
</tr>
<tr>
<td></td>
<td>• Ethernet OPU2 GFP_F_EXT</td>
</tr>
<tr>
<td></td>
<td>• Ethernet OPU2 WIS</td>
</tr>
<tr>
<td></td>
<td>• OTN OPU2</td>
</tr>
<tr>
<td></td>
<td>• Sonet OPU2 AMP</td>
</tr>
<tr>
<td></td>
<td>• Sonet OPU2 BMP</td>
</tr>
<tr>
<td></td>
<td>• SDH OPU2 AMP</td>
</tr>
<tr>
<td></td>
<td>• SDH OPU2 BMP</td>
</tr>
<tr>
<td>ODU2E</td>
<td>• Ethernet OPU2e BMP</td>
</tr>
<tr>
<td></td>
<td>• OTN OPU2e</td>
</tr>
<tr>
<td>ODU2F</td>
<td>• OTN OPU2f</td>
</tr>
<tr>
<td>ODU4</td>
<td>• OTN OPU4</td>
</tr>
<tr>
<td></td>
<td>• Ethernet OPU4 GFP_F</td>
</tr>
<tr>
<td></td>
<td>• Ethernet OPU4 GMP</td>
</tr>
<tr>
<td>ODFLEX</td>
<td>• OTN OPUFlex</td>
</tr>
<tr>
<td></td>
<td>• Ethernet OPUFlex GFP_F</td>
</tr>
</tbody>
</table>
Create and Provision an ODU Circuit

To create and provision an ODU circuit:

**Before you begin**

For information about the prerequisites that must be met before you can provision an optical circuit, see Prerequisites for Provisioning Optical Circuits, on page 498.

---

**Step 1**
From the left sidebar, choose Maps > Topology Maps > Network Topology.

**Step 2**
Click Device Groups, and then select the location in which you want to create the ODU circuit.

**Step 3**
Close the Device Groups popup window.

**Step 4**
In the Network Topology window, click Circuits/VCs.

**Step 5**
Click the Circuits/VCs tab, then click the + (Create) icon in the Circuits/VCs pane toolbar. The Provisioning Wizard opens in a new pane to the right of the map.

You can also access the Provisioning wizard by choosing Configuration > Network > Service Provisioning.

**Step 6**
From the Technology drop-down list, choose Optical. Cisco EPN Manager displays a list of relevant circuit types in the Service Type area.

**Step 7**
In the Service Type area, choose ODU.

**Step 8**
If you have defined profiles to set the attributes of the different services, select the required profile from the Select Profile drop-down list. See Create Circuit/VC Profiles, on page 572.

**Step 9**
Click Next to go to the Customer Section page.

**Step 10**
(Optional) Select the customer for whom the circuit is being created. If there are no customers in the list, go to Inventory > Other > Customers to create the customer in the system, and then restart the Provisioning Wizard.

**Step 11**
Enter the circuit name and its description in the Customer Section page.

**Step 12**
Click Next to go to the Circuit Section page.

**Step 13**
Choose one of the following protection type for the circuit:

- None—No protection type for the circuit.
- 1+1—Both primary and secondary paths carry traffic end to end and. The receiver receives the traffic from both primary and secondary paths, and compares both the traffic. When the egress node detects failure in one path, it switches the traffic to the unaffected path.

**Note** If you have selected 1+1 as the protection type, the Connection Mode is set to SNC-N, by default.

**Step 14**
Choose the required Reversion Time and Hold off Timer for the circuit.

**Note** These fields are available only if you have selected 1+1 as the protection type.

**Step 15**
Click Next to go to the Endpoint Section page.

**Step 16**
Select a row in the Endpoint table, and then click a device in the map to populate the Device Name column with the selected device. Alternatively, you can click the row in the Endpoint table to edit the Device Name and Termination Point columns. Only network elements that are available and compatible with the circuit type you chose will be displayed.

**Note** When the row is in the edit mode, you cannot click a device in the map to populate the Device Name column.

**Step 17**
Click Next to go to the Constraints Section page.
Step 18  
Click a device node in the map to add it to the Constraints table. Alternatively, you can click the '+' button in the table toolbar to add a new row to the table and edit the Node/Link Name, Include/Exclude, and Route columns. Only network elements that are compatible with the ODU circuit type will be displayed.

Note  
You cannot provide links as constraints for ODU circuits.

Step 19  
(Optional) Click Calculate Path to verify if there is a valid working path between the selected endpoints. If a valid working path exists between the selected endpoints, the path appears with a 'W' label on the topology map. If a valid working path does not exist between the selected endpoints, a Path Calculation Result section appears that displays the reason why a working path cannot be established between the selected endpoints.

Step 20  
Click Create Now to create the circuit. If you chose to see a preview of the TL1 or CLI commands that will be deployed to the devices, it will be displayed on clicking Preview and now, you can either deploy the configurations to the device or cancel it, but you cannot edit the attributes.

---

The circuit should be added to the list in the Circuits/VCs pane in the Network Topology window. To check the provisioning state, click the i icon next to the circuit/VC name to see the Circuit/VC 360 view.

Provision L3VPN Services

- Supported L3VPN Services, on page 469
- L3VPN Provisioning Features and Limitations, on page 518
- Prerequisites for L3VPN Provisioning, on page 519
- L3VPN Service Discovery, on page 520
- Create and Provision a New L3VPN Service, on page 521
- View L3VPN Service Details, on page 534
- Modify L3VPN Services and VRFs, on page 536
- Add and Copy VRFs to an L3VPN Service, on page 537
- Example Configuration: Provisioning an L3VPN Service, on page 533

Supported L3VPN Services

An MPLS Layer 3 VPN creates a private IP network. The customer connects to the network via customer edge (CE) routers, which act as IP peers of provider edge (PE) routers.

Virtual Routing and Forwarding (VRFs)

On the PE, Virtual Routing and Forwarding (VRF) instances act as virtual IP routers dedicated to forwarding traffic for the L3VPN service. The VRFs learn the routes to each other via the Multi-Protocol Border Gateway Protocol (MP-BGP), and then forward traffic using MPLS.

A VPN is comprised of at least one but typically several VRFs. Cisco EPN Manager uses the VPN ID to discover which VRFs together form a single VPN. If Cisco EPN Manager discovers an existing network where no VPN ID has been provisioned, it takes all VRFs with the same name and associates them into one VPN. For VPNs created using Cisco Prime Provisioning, which uses a naming convention with version number.
prefixes and different suffixes, Cisco EPN Manager will recognize the different VRFs as belonging to one VPN.

In general there is a regular expression which can be configured to allow for varying naming convention.

**Route Targets (RTs)**

The connections between VRFs are defined using Route Targets (RTs) that are imported and exported by the VRFs. Cisco EPN Manager makes it easy to set up a full mesh of connections, and automatically allocates the route target to be used. The route target consists of a prefix which is either an AS number or an IPv4 address, for example, a full mesh prefix, 100 [681682]. The prefix can be selected from the existing BGP autonomous system (AS) numbers in the network, or it can be entered manually. The second number following the prefix is allocated automatically by Cisco EPN Manager.

Alternatively or in addition to the full mesh, it is possible to manually select route targets. During VPN creation, there is an initial screen where you type in the route targets to be used within a VPN, and then for each VRF you can select which route targets you import and export. You also specify for which address family (IPv4 or IPv6) you will use the route target. This can be used for example to configure extranets, by importing route targets used in other VPNs.

**Route Redistribution**

The routes that are exchanged between the PE and the CE have to be redistributed into the MP-BGP routing protocol so that remote endpoints can know which prefixes can be reached at each VRF. To control route redistribution, Cisco EPN Manager allows you to define the required protocol (Static, Connected, or RIP), the protocol's metric value, and optionally the applicable route policy.

**Endpoints**

Cisco EPN Manager supports the creation of IP endpoints on Ethernet subinterfaces. It supports selecting untagged encapsulation, or specifying an outer and optionally an inner VLAN, with 802.1q or 802.1ad encapsulation. You can specify both IPv4 and IPv6 addresses at an endpoint. You can also specify the BGP and OSPF neighbor details to provision BGP and OSPF neighbors between CE and PE.

For information on how to provision L3VPN service using Cisco EPN Manager, see, Provision L3VPN Services, on page 517.

**L3VPN Provisioning Features and Limitations**

Cisco EPN Manager supports the following L3VPN features:

- Creation of VRFs.
- Automatic allocation of VPN IDs and Route Target IDs.
- Automatic allocation of route distinguishers.
- Discovery of VPNs consisting of several VRFs, based on multiple criteria (VPN ID, common name, and Prime Provisioning naming conventions).
- You can select devices for L3VPN provisioning using the Point and Click method of provisioning.
- Definition of IP endpoints attached to a VRF. Associating Ethernet subinterfaces with VRFs.
- Provisioning of BGP and/or OSPF neighbors between CE and PE.
- Attaching QoS profiles to the endpoint interfaces.
- Adding new VRFs to existing VPNs.
• Modifying VPNs and associated VRFs created and deployed (or discovered and promoted) using Cisco EPN Manager.

• Overlays in the Network Topology for L3VPN services.

• Promotion of L3VPN services discovered directly from the device. This further helps in modifying and deleting discovered services.

• Using route targets with OSPF dual AS routing.

• Using integrated routing and bridging to provision L3VPN services using BDI/BVI interfaces (subinterfaces).

• Associating IP Service Level Agreements (SLAs) and CLI templates with L3VPN services.

• Route redistribution between the PE-CE link and the MP-BGP core using connected, static, RIP, or OSPF routes.

• Provisioning L3VPN services using LAG interfaces.

Cisco EPN Manager has the following L3VPN limitations:

• VRFs are supported only on Cisco ASR1000, Cisco ASR9000, Cisco ASR90X, Cisco ASR 920X, and Cisco ASR901S devices.

• You cannot provision multicast VPNs. Only unicast VPNs are supported.

• While creating the L3VPN service, you can add only up to five VRFs to the VPN. More VRFs can later be added to the VPN using the Modify VRF and Add VRF options.

• Only one VRF per device is supported. You can create multiple VRFs but on different devices either with the same VRF name or with different VRF names.

• Route policies can be selected but cannot be defined within the L3VPN service.

• Only BGP, OSPF, and OSPFv3 routing protocols are supported in PE-CE.

• There is no support for multiple attached PEs, and so there is no Site of Origin support.

• IP SLA operations can be associated with VRFs only during service creation and not during service modification.

• Deleting an L3VPN service deletes the IP SLA operations associated with the service from the device. And the associated operations that are deleted will not be available for future usage.

• The Integrated Routing and Bridging (IRB) is not supported for Cisco Catalyst 6500 series switches.

Prerequisites for L3VPN Provisioning

For more information about implementing L3VPNs, see Implementing MPLS Layer 3 VPNs.

Before you begin provisioning L3VPN services, ensure that the following pre-requisites are followed.

Following are the prerequisites for provisioning an L3VPN service:

• BGP must be set up on all devices. Typically all devices must communicate with each other via a pair of route reflectors.

• Pre-configuration changes required to set up BGP:
Configure the BGP router-id as shown in the example below:

```bash
router bgp 65300
    bgp router-id 1.1.1.1
```

Set Vpn4 and Vpn6 as the parent address family using these commands:

```bash
router bgp 100
    address-family vpnv4 unicast
    address-family vpnv6 unicast
```

- MPLS reachability must be set up between the devices. MPLS core network configuration must be set up.
- Inventory collection status for the devices on which the L3VPN services will be provisioned must be 'Completed'. To check the status of devices, go to Inventory > Network Devices, and look at the status in the Last Inventory Collection Status column.
- (Optional) Customers must be created in the system so that you can associate the L3VPN service to a customer during L3VPN service provisioning. To create and manage customers, choose Inventory > Other > Customers.

### L3VPN Service Discovery

Cisco EPN Manager associates multiple VRFs into a single VPN using multiple criteria:

- If VRFs were configured with a VPN ID: then the VPN service is discovered using the VPN ID to identify the VRFs that belong to the same VPN. If you have VPNs that you need to discover, where different VRF names are used within one VPN, then Cisco EPN Manager discovers the VRFs by the VRF names.

  In cases where no more than one VRF is created per device, it is common practice to simply use the same VRF name everywhere across the VPN. If Cisco EPN Manager sees multiple VRFs with the same name and no VPN ID, then it considers them as a single VPN, and the VPN name will be the name of the VRFs.

- If VPNs that were originally provisioned using Prime Provisioning: Cisco EPN Manager is also aware of the Prime Provisioning VRF naming convention. The naming convention used by Prime Provisioning is in the format:

  V<number>:<VPN name><optional suffix, one of -s -h -etc>

  VRFs with the same names and numbers will belong to the same VPN. For example these are VRFs belonging to a VPN called 'ABC':

  V1:ABC, V2:ABC, V4:ABC-s, V22:ABC-h, V001:ABC, etc.

- If the VRF has no VPN ID: and has a unique name that doesn't match other names according to the Prime Provisioning convention, it will be placed into a VPN on its own. The name of the VPN will be the name of the VRF.

The Prime Provisioning naming convention feature is driven by a regular expression that is embedded in the product. If configuring a VPN is not an option for you and you have a naming convention that could be matched with a regular expression, it is possible to change it. To change the regular expression, please contact your Cisco Advanced Services representative.
Create and Provision a New L3VPN Service

The process of creating and provisioning a unicast L3VPN involves:

- (Optional) Associating a customer to the VPN.
- Defining the attributes that influence how traffic that is delivered over the L3VPN and through its endpoints will be treated.
- Specifying the endpoints and route redistribution values of the L3VPN.
- (Optional) Configuring IP Service Level Agreements (SLAs) operation to monitor end-to-end response time between devices using IPv4 or IPv6.
- (Optional) Associating user defined CLI templates with the L3VPN service.

Note: Only Unicast L3VPN services are supported in this release.

To create a new L3VPN service:

Step 1
From the left pane, choose Maps > Topology Maps > Network Topology.
The network topology window opens.

Step 2
From the toolbar, click Device Groups and then select the group of devices you want to show on the map.

Step 3
Click the Circuits/VCs tab, then click the + (Create) icon in the Circuits/VCs pane toolbar.
The Provisioning Wizard opens in a new pane to the right of the map. You can also access the L3VPN Provisioning wizard by choosing Configuration > Network > Service Provisioning.

Step 4
From the Technology drop-down list, select L3VPN. A list of supported L3VPN service types is displayed.

Step 5
In the Service Type section, choose Unicast and click Next to enter the customer and service details. In this release, only service type Unicast L3VPN is supported.

Step 6
(Optional) Select the customer that you want to associate with the VPN. If there are no customers in the drop-down list, you can go to Inventory > Other > Customers to create the customer and return to this step.

Step 7
Specify the basic L3VPN parameters:

a) Use the Activate check box to specify whether the service must be in active (check box enabled) or inactive (check box disabled) state. The Active state enables traffic to pass through the circuit and automatically sets the Service State for all associated IP endpoints to True. In the Inactive state, you can choose to set the service state for IP endpoints to true or false.

b) Provide a unique name for the service and optionally enter a description

c) Enter a unique VPN ID for the service. The VPN ID must be in the format OUI:VPN Index. For example, 36B:3. Here, 36B is the Organization Unique Identifier (OUI) and 3 is the VPN Index.

d) In the IP MTU field, enter a value between 1522 (default) and 9216. The service MTU is the size in bytes of the largest IP packet that can be carried unfragmented across the L3VPN. It does not include layer 2 headers.
The configured interface MTU is the service MTU plus the size of any layer 2 headers. For Ethernet, this will add 14 bytes plus 4 bytes per VLAN header.
The value of the UNI MTU depends on the service MTU and outer and inner VLAN values:

- If both outer and inner VLANs are present, then the UNI MTU value is greater than the Service MTU + 14 + (4*2)
• If only the outer VLAN is present, then the UNI MTU value is greater than the Service MTU + 14 + (4 * 1)
• If no VLANs are present, then the UNI MTU value is greater than the Service MTU + 14

e) (Optional) To create a full mesh topology for this service, select the Create Full Mesh check box and enter the full mesh prefix manually in the New Prefix field or select a value from the Existing Prefix drop-down list. The available options depend on the full mesh prefix values discovered from the selected device.

f) Select the address family as IPv4, IPv6, or Both from the Full Mesh Address Family drop-down list.

Step 8 Use the Route Target Allocation section to manually specify the route target address families (IPv4, IPv6, or Both) and their associated route target values. You can create multiple route targets for the L3VPN service. These route targets can be associated with any VRF that you attach to this L3VPN service in the following steps.

Note The route targets associated with a VRF must also be associated with the L3VPN the VRFs belong to.

Step 9 In the Deployment Action drop-down menu, specify the task that must be taken up when the service creation process is completed. Your options are:
• Preview: allows you to review the configuration that is generated before it is deployed to the device.
• Deploy: allows you to deploy the configuration to the relevant devices immediately upon completion.

Step 10 Click Next to associate VRFs to the L3VPN service.

Step 11 Select the required VRFs from the VRFs drop-down list or add a new VRF as explained below, and then click Next. During L3VPN service creation, you can associate up to five VRFs with the VPN. To associate more VRFs to the VPN, see Add and Copy VRFs to an L3VPN Service, on page 537. To create a new VRF:

1. Click the ‘+’ icon to add the VRF details manually. To auto populate the VRF details, click the respective device on the map. The device details and a new name for the VRF are automatically populated on the Add VRFs page.

2. To manually specify the VRF details, select the required device from the Device drop-down list. You can then manually enter the VRF name and description, and check the RD Auto check box.

Note If multiple VRFs are created on the same device, you must name them differently to ensure that they are not part of the same VPN. You cannot create multiple VRFs with the same names on the same device.

Step 12 Specify the IPv4 and IPv6 route targets and route distribution details:

1. Route Targets: Select the route targets for this VRF from the Route Target drop-down menu. The options in this drop-down menu are available based on the route targets associated with this service in Step 7.

2. Select the direction in which the route targets must be applied. Depending on the device you select, choose Import, Export, Both, or None.

   Choose the directions depending on the type of device that is selected. For example, for Cisco IOS-XR devices, you cannot choose 'None' as the route target direction.

3. In the Route Policy section, select the import and export policy for the route targets.

4. In the Route Distribution section, specify the protocol that must be associated with the VRF, the protocol's metric value, the routing process ID, the relevant route policies and the route match type.

   • Protocol- Choose the source protocol from which routes must be redistributed. Your options are Static, Connected, RIP, and OSPF.

   • Metric- (Optional) Enter a numeric value for the metric which is used when redistributing from one routing process to another process on the same router.
• **Routing Process ID**- (applicable only to OSPF and RIP) Specify the unique numerical value that identifies the instance of the routing process on the device.

• **Route Policy**- (Optional) Select one of the route policies present on the selected device. You cannot create route policies using Cisco EPN Manager.

• **Route Match Type** (applicable only to OSPF)- Specify the match type that must be associated with the selected route policy. Your options are: Internal, External, External 1, External 2, NSSA External, NSSA External 1, NSSA External 2, NSSA, Level 1, Level 2, and Level Inter Area.

**Step 13** Specify the IP endpoints and UNIs values manually as follows:

- If the endpoint interface has already been configured as a UNI, uncheck the **New UNI** check box and select the required UNI from the **UNI Name** drop-down list.

- To create a new UNI:
  1. Select the **New UNI** check box.
  2. In the **UNI Name** field, enter a unique name for the UNI.
  3. In the **Device** drop-down, select the device, its required interface, and provide a description for the UNI.
  4. Check the **Service Multiplexing** check box to enable more than one L3VPN or Carrier Ethernet service to be supported at the UNI.
  5. Specify the IP Maximum Transmission Unit (MTU) for the UNI., the speed and duplex settings for the UNI.
  6. Either check the **Auto Negotiation** check box to automatically adjust the speed and duplex settings for the UNI or uncheck the **Auto Negotiation** check box and specify the speed and duplex settings manually.
  7. Choose the UNI QoS profiles for ingress or egress traffic on the UNI. The list of profiles includes policy maps that were configured on the device and discovered by the system, as well as user-defined QoS profiles. If you select a UNI QoS profile, you cannot add individual QoS policies to the service endpoint in the upcoming steps. If you want to add specific QoS policies to the endpoint, leave the UNI Ingress and Egress QoS Profile fields blank.

  **Note** You can choose two different discovered QoS profiles for the ingress and egress directions, however, in case of user defined QoS profiles, only a single QoS profile can be chosen for both directions.

  8. Select **Enable Link OAM** to enable IEEE 803.1ah link operation and maintenance. If Link OAM is enabled, you will see events relating to the state of the link between this UNI and the customer’s access switch.

  9. Select **Enable Link Management** to enable the customer access switch to get information about this UNI, VLAN IDs, services on the UNI, and so on.

For a detailed description of the fields and attributes in the UNI table, see **New UNI Details Reference, on page 488**.

**Step 14** Specify the service end point to be associated with the L3VPN by providing the following details, and then click **Next**:

- **VRF Name**: Choose one of the available VRFs that can be associated with this VPN.

- **IPv4 and IPv6 address**: Enter the IP addresses and network masks of the service end point. The masks can be entered simply as an integer that represents the length of the network mast (or in CIDR format).

- **VLAN and Inner VLAN**: Enter the inner and outer VLAN identifiers using integers between 1 and 4094. Inner VLAN is the identifier for the second level of VLAN tagging.
• **QoS Policy**: (Optional) Select the QoS policy that must be applied to the service endpoint. This field is disabled if you have associated UNI Ingress/Egress QoS profiles to the service in the above step. For information on creating QoS profiles, see *Configure Quality of Service (QoS)*, on page 394.

  * **Note** You can choose two different discovered QoS policies for the ingress and egress directions, however, in case of user defined QoS policies, only a single QoS policy can be chosen for both directions.

• **Service State**: Specify whether the service state for associated IP endpoints must be set to true or false. If the L3VPN is in Activate state (specified in Step 6 above), this check box is disabled and all service state values are automatically set to True.

• **Use Integrated Routing & Bridging**: Specify whether the VRF and IP addresses must be configured under the sub-interfaces or under the BVI (virtual) interfaces.

  * **Note** This check box is enabled only when you select devices such as, Cisco ASR 90XX devices, that support integrated routing and bridging. For Cisco ASR90xx and other IOS-XE devices you cannot uncheck the **Use Integrated Routing & Bridging** check box because configuration is taken care by the BDI interface.

• (Optional) Check the **Enable HSRP** check box to specify the HSRP details. See HSRP Details Reference, on page 528

**Step 15** Click Next to go to the **PE-CE Routing** page.

**Step 16** Click the ‘+’ icon to add the PE-CE routing details. See PE-CE Routing Details References, on page 529.

**Step 17** (Optional) Select existing IP SLA parameters from the list, or specify the IP SLA operation parameters described in the table below and then click **Next**.
### IP SLA Settings and Parameters

<table>
<thead>
<tr>
<th>Operation Settings</th>
<th>IP SLA Parameters</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name</td>
<td>Enter a unique name to identify the IP SLA operation for the selected L3VPN service.</td>
</tr>
<tr>
<td>Type</td>
<td>Type</td>
<td>Select the type of IP SLA operation that must be generated for the devices participating in this L3VPN service. Your options are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>UDP Echo</strong>: Configures an IP SLA User Datagram Protocol (UDP) Echo operation to measure response times and to test end-to-end connectivity between a Cisco device and devices using IPv4 or IPv6.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>ICMP Echo</strong>: Allows you to measure end-to-end network response time between a Cisco device and other devices (source and destination values, as described below) using IPv4 or IPv6. With an IP SLA operation of type ICMP Echo, you cannot associate the 'Connection Loss' action variable.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>ICMP Jitter</strong>: Configures the Internet Control Message Protocol (ICMP) Jitter operation which provides the capability to generate a stream of ICMP packets between a Cisco IOS device (source) and any other IP device (destination) to gather network performance-related statistics. Statistical measurements for the IP SLAs ICMP jitter operation include latency, round-trip time, jitter (interpacket delay variance), and packet loss.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>UDP Jitter</strong>: Configures the UDP jitter operation which analyzes round-trip delay, one-way delay, one-way jitter, one-way packet loss, and connectivity in networks that carry UDP traffic in IPv4 or IPv6 networks.</td>
</tr>
<tr>
<td>Source</td>
<td>Source</td>
<td>Specify the device which acts as the source point from which the IP SLA configuration is generated. The IP SLA responses are generated based on the connectivity between this source device and the target device. The VRF values for this operation are automatically selected based on your Source selection.</td>
</tr>
<tr>
<td>Source Port</td>
<td>Source Port</td>
<td>Enter a numeric value between 0 and 65535 to specify the source port value for which the IP SLA operation must be configured.</td>
</tr>
<tr>
<td>Destination</td>
<td>Destination</td>
<td>Specify the device which acts as the target point from which the IP SLA configuration is generated. The IP SLA responses are generated based on the connectivity between the source device and this target device.</td>
</tr>
<tr>
<td>Destination Port</td>
<td>Destination Port</td>
<td>Enter a numeric value between 0 and 65535 to specify the destination port value for which the IP SLA operation must be generated.</td>
</tr>
<tr>
<td>VRF</td>
<td>VRF</td>
<td>The VRF details are automatically selected based on the device you specify as the IP SLA operation Source.</td>
</tr>
</tbody>
</table>
### IP SLA Settings | IP SLA Parameters | Descriptions
---|---|---
Reaction Settings | Action Variable | Select the variable based on which the IP SLA reactions must be triggered. For example, when a monitored value exceeds or falls below a specified level, or when a monitored event (such as a timeout or connection loss) occurs.
  - **Connection Loss**: Indicates that an event must be triggered when a connection loss occurs. This value is not displayed if you select ICPMEcho as the type of operation.
  - **Round Trip Time**: If you choose this action variable, you need to enter the **Upper Threshold Value** and the **Lower Threshold Value** which indicates that an event must be triggered when a monitored value exceeds or falls below the upper and lower threshold values that you specify.
  - **Time Out**: Indicates that an event must be triggered after a given set of consecutive timeouts occur.
  - **Verify Error**: Indicates that an event must be triggered after an error of type 'VerifyError' occurs.

Action Type | Select one of the following actions that must be taken based on the conditions set in the Action Variable field:
  - **None**: No action is taken.
  - **Trap and Trigger**: Triggers both an SNMP trap and starts another IP SLA operation when the violation conditions are met, as defined in the Trap Only and Trigger Only options below.
  - **Trap Only**: Sends an SNMP logging trap when the specified violation type occurs for the monitored element.
  - **Trigger Only**: Changes the state of one or more target operation's Operational state from 'pending' to 'active' when the violation conditions are met. A target operation will continue until its life expires (as specified by the target operation's configured lifetime value). A triggered target operation must finish its life before it can be triggered again.

Threshold Type

---

Cisco Evolved Programmable Network Manager 3.0 User and Administrator Guide
### IP SLA Settings Parameters

Select the threshold type based on which the IP SLA events are generated.

- **Average**: If you choose this threshold type, enter the **N Value** which specifies that an event must be triggered when the averaged total value of N probes is reached either when specified upper-threshold value is exceeded, or when it falls below the lower-threshold value.

- **Consecutive**: If you choose this threshold type, enter the **Consecutive Values** as part of the reaction settings. This threshold type triggers an event only after a violation occurs a specified number of times consecutively. For example, if you enter 5 as the consecutive value, the consecutive violation type is used to configure an action to occur after a timeout occurs 5 times in a row, or when the round-trip-time exceeds the upper threshold value 5 times in a row.

- **Immediate**: Triggers an event immediately when the value for a reaction type (such as response time) exceeds the upper threshold value or falls below the lower threshold value, or when a timeout, connection loss, or verify error event occurs.

- **Never**: Never triggers an event.

- **X out of Y occurrences**: If you choose this threshold type, enter the **X Values** and **Y Values** to specify the number of occurrences. This triggers an event after some number (x) of violations within some other number (y) of probe operations (x of y).

| Simple Schedule | - | Enter the scheduling parameters for an individual IP SLAs operation by entering the following values:

- **Frequency**: Enter the elapsed time within which the operation must repeat, in seconds.

- **Life Time**: Enter the overall time until when the operation must be active, in seconds. A single operation repeats at the specified frequency for the lifetime of the operation.

- **Age Out**: Enter the length of time to keep an operation active, in seconds. For example, an age out value of 43200 will ensure that the operation will age out after 12 hours of inactivity.

- **Start Now** and **Start After**: Enable the Start Now check box to schedule the IP SLA operation to be executed immediately on Save. Or use the Start After field to specify the number of minutes after which the operation can be executed.

---

**Step 18** *(Optional)* Use the Service Template page to append a template with additional CLI commands that will be configured on the devices participating in the service. See Extend a Circuit/VC Using Templates, on page 575 for more information.

**Step 19** When you have provided all the required information for the service, click **Submit**. If you chose to see a preview of the CLI that will be deployed to the devices, it will be displayed now and you can click **Edit Attributes** to change the L3VPN attributes. Otherwise, the configurations will be deployed to the devices immediately.
In case of a deploy failure on even a single device that is part of the service, the configuration is rolled back on all devices participating in the service. To delete the endpoints associated with the service, see, Delete an L3VPN Service Endpoint, on page 615. To add more VRFs to this L3VPN service, see Add and Copy VRFs to an L3VPN Service, on page 537.

**HSRP Details Reference**

Hot Standby Router Protocol (HSRP) is Cisco’s standard method of providing high network availability by providing first-hop redundancy for IP hosts on an IEEE 802 LAN configured with a default gateway IP address. Hot Standby Router Protocol (HSRP) provides redundancy for IP networks, ensuring that user traffic immediately and transparently recovers from first hop router failures. HSRP allows multiple routers on a single LAN to share a virtual IP and MAC address which is configured as the default gateway on the hosts. From the group of routers configured in an HSRP group, there is one router elected as the active router and another as a standby router. The active router assumes the role of forwarding packets sent to the virtual IP address. If the active router fails, the standby router takes over as the new active router. In Cisco EPN Manager, HSRP for IPv4 is supported on switches running the IP base or IP services image and HSRP for IPv6 is supported on unicast routing. HSRP is not supported in IOS-XE devices for address family IPv6. The following table lists and describes the attributes of HSRP.

**Table 44: HSRP Settings**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group Number</td>
<td>Enter the standby group number of either IOS-XE or IOS-XR device. The recommended range values are:</td>
</tr>
<tr>
<td></td>
<td>• IOS-XE—Range value must be between 1-255.</td>
</tr>
<tr>
<td></td>
<td>• IOS-XR—Range value must be between 1-4095.</td>
</tr>
<tr>
<td>Virtual IP</td>
<td>Enter the IPv4/IPv6 address. Ensure that the Virtual IP address and SEP address should be entered within the same subnet.</td>
</tr>
<tr>
<td>Priority</td>
<td>Enter the priority to decide which router is to be the primary router.</td>
</tr>
<tr>
<td>Hello Timer</td>
<td>Enter the time between hello packets in seconds.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Hold Timer and Reload Delay values should be entered mandatorily for IOS-XR device for the specified Hello Timer and Minimum Delay values.</td>
</tr>
<tr>
<td>Minimum Delay</td>
<td>Enter the minimum delay time in seconds.</td>
</tr>
<tr>
<td>Preempt Minimum Delay</td>
<td>Specify the preempt delay on the router.</td>
</tr>
<tr>
<td>Authentication Key</td>
<td>Enter the authentication key if the group number is between 1 to 255. This will allow the authentication messages to be included in the HSRP multicast. This ensures that only authorized routers can become part of the HSRP group.</td>
</tr>
<tr>
<td>Hold Timer</td>
<td>Enter the hold time in seconds.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Hold down time should be more than hello timer for XE device.</td>
</tr>
<tr>
<td>Reload Delay</td>
<td>Enter the delay time to reload.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Preempt Reload Delay</td>
<td>Enter the preempt reload delay. This field is not supported for IOS-XR device.</td>
</tr>
</tbody>
</table>

**PE-CE Routing Details References**

The following table lists and describes the attributes that define the PE-CE details for provisioning a Layer 3 VPN service.

**Table 45: PE-CE Routing Reference**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Routing Protocol Settings</strong></td>
<td></td>
</tr>
<tr>
<td>PE Device</td>
<td>Name of the pseudowire device.</td>
</tr>
<tr>
<td>VRF</td>
<td>The VRF name that you specified in the VRF page of the wizard is populated.</td>
</tr>
<tr>
<td>Routing Protocol Type</td>
<td>Choose BGP, OSPF, or OSPFv3 as the routing protocol for the Layer 3 VPN service.</td>
</tr>
<tr>
<td>Note</td>
<td>Based on the routing protocol chosen, either the BGP Neighbor Information section or the OSPF Process Information section will be displayed. For XR and XE devices the PE-CE authentication is based on the Routing Protocol Type and Authentication Type selection. For more information see, PE-CE Authentication Table.</td>
</tr>
<tr>
<td>Address Family</td>
<td>Choose the address family as IPv4 or IPv6.</td>
</tr>
<tr>
<td>Note</td>
<td>IPv6 is not supported for the OSPF routing protocol.</td>
</tr>
<tr>
<td>Authentication Type</td>
<td>Choose the authentication type. Only the MD5 authentication type is supported.</td>
</tr>
<tr>
<td>Note</td>
<td>Authentication Type field is available only when you select OSPF or OSPFv3 as the routing protocol.</td>
</tr>
<tr>
<td><strong>BGP Neighbor Information</strong></td>
<td></td>
</tr>
<tr>
<td>Note</td>
<td>This section is available only when you select BGP as the routing protocol.</td>
</tr>
<tr>
<td>Neighbor Address</td>
<td>Enter the IP address of the neighbor.</td>
</tr>
<tr>
<td>Neighbor AS</td>
<td>Enter the autonomous system number of this neighbor, which is the unique identifier used to establish a peering session with a BGP neighbor.</td>
</tr>
<tr>
<td>Ingress Route Policy</td>
<td>Enter the route policy applied to any BGP routes received from this neighbor.</td>
</tr>
<tr>
<td>Egress Route Policy</td>
<td>Enter the route policy applied to any routes sent to this neighbor.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Local AS</td>
<td>Enter the unique local identifier used to establish a peering session with a BGP neighbor.</td>
</tr>
<tr>
<td>AS Action</td>
<td>Select one of the following action types that must be associated with the local autonomous-system (AS) number:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Prepend</strong>: Use this option to configure BGP such that it prepends the AS number to routes received from the neighbor.</td>
</tr>
<tr>
<td></td>
<td>• <strong>No Prepend</strong>: Use this option to configure BGP such that it does not prepend the AS number to routes received from the neighbor.</td>
</tr>
<tr>
<td></td>
<td>• <strong>No Prepend, Replace AS</strong>: Use Replace AS to prepend only the local AS number (as configured with the ip-address) to the AS_PATH attribute. The AS number from the local BGP routing process is not prepended.</td>
</tr>
<tr>
<td></td>
<td>• <strong>No Prepend, Replace AS, Dual AS</strong>: Use the Dual AS option to configure the eBGP neighbor to establish a peering session using the AS number (from the local BGP routing process) or by using the AS number configured with the ip-address argument (local-as).</td>
</tr>
</tbody>
</table>

### OSPF Process Information

**Note**: This section is available only when you select OSPF or OSPFv3 as the routing protocol.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Router ID</td>
<td>Specify an IPv4 address for the OSPF protocol.</td>
</tr>
<tr>
<td>Area ID</td>
<td>Define an area for the OSPF protocol. The valid range is 0 - 4294967295.</td>
</tr>
<tr>
<td>Domain Type</td>
<td>Select the required domain type.</td>
</tr>
<tr>
<td>Domain Value</td>
<td>Enter the domain value in the 6 Octet Hexadecimal format. For example, 00000000000F.</td>
</tr>
<tr>
<td>BFD Min Interval</td>
<td>Enter the minimum interval between which control packets are sent to the neighbor. The range is between 3 milliseconds and 30000 milliseconds.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong>: This field is available only for Cisco IOS-XR devices.</td>
</tr>
<tr>
<td>BFD Multiplier</td>
<td>The multiplier is the number of times a packet is missed before BFD declares the neighbor down. The range for the OSPF protocol is 2 to 50.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong>: This field is available only for Cisco IOS-XR devices.</td>
</tr>
<tr>
<td>BFD Fast Detect</td>
<td>Check this check box to quickly detect failures in the path between adjacent forwarding engines.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong>: This field is available only for Cisco IOS-XR devices.</td>
</tr>
</tbody>
</table>
## PE-CE Authentication

The following table lists the relevant combinations of Routing Protocol and authentication types for PE-CE authentication based on the XE and XR devices selection.

*Table 46: PE-CE Authentication Reference*

<table>
<thead>
<tr>
<th>Device</th>
<th>Routing Protocol</th>
<th>Authentication Type</th>
<th>Password Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>XE</td>
<td>BGP</td>
<td>—</td>
<td>Click either one of the following radio buttons</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Plain Text</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>— Enable to enter the password</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Encrypted</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>— Enable to enter an hexadecimal value as the password</td>
</tr>
<tr>
<td>OSPF</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>OSPFv3</td>
<td>—</td>
<td>Only Key chain</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td></td>
<td>authentication type is available.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>From the Key Chain drop-down list, choose the authentication key chain that is configured on the device.</td>
<td></td>
</tr>
<tr>
<td>Device</td>
<td>Routing Protocol</td>
<td>Authentication Type</td>
<td>Password Type</td>
</tr>
<tr>
<td>--------</td>
<td>------------------</td>
<td>---------------------</td>
<td>---------------</td>
</tr>
</tbody>
</table>
| XR     | BGP              | —                   | Click either one of the following radio buttons:  
- Plain Text — Enable to enter the password  
- Encrypted — Enable to enter an hexadecimal value as the password. |
|        |                  | Choose MD5 or Keychain | Click either one of the following radio buttons:  
- Plain Text — Enable to enter the password  
- Encrypted — Enable to enter an hexadecimal value as the password. |
| OSPFv3 |                  | Choose either IPSec - MD5 or IPSec-SHA1 as the authentication type. | Click either one of the following radio buttons:  
- Plain Text — Enable to enter the password  
- Encrypted — Enable to enter an hexadecimal value as the password. |
Example Configuration: Provisioning an L3VPN Service

The following are examples of the configuration deployed to a Cisco ASR 9000 device with the following parameters:

- Creation of VRF and IP addresses (both IPv4 and IPv6) under the BDI (virtual) interface.
- Redistribution of OSPF protocol to the BGP protocol.

Example: Provisioning an L3VPN service on a Cisco ASR 9000 device's BVI enabled interface (sub-interface).

```plaintext
vrf vfrbvbidi9k
vpn id aaaaaa:21
address-family ipv4 unicast
import route-target 6:55
address-family ipv6 unicast
import route-target 6:55
export route-target 6:55
interface GigabitEthernet0/0/0/17
no shutdown
exit
interface GigabitEthernet0/0/0/17.1
encapsulation dot1q 1198
shutdown
interface BVI 1
vrf vfrbvbidi9k
ipv4 address 88.7.6.4 255.224.0.0
l2vpn
bridge group BDI1
bridge-domain 1
routed interface BVI 1
interface GigabitEthernet0/0/0/17.1
exit
router bgp 140
vrf vfrbvbidi9k
rd auto
address-family ipv6 unicast
address-family ipv4 unicast
exit
exit
exit
```

Example: Using a BVI enabled interface for provisioning an L3VPN service with OSPF route distribution (using dual AS):

```plaintext
vrf definition VRF2-2
vpn id AAAAAA:2
rd 532533:2
address-family ipv4
 route-target import 6:5
 route-target export 6:5
address-family ipv6
 route-target import 6:5
 route-target export 6:5
interface GigabitEthernet0/0/0/0
duplex full
service instance 2 ethernet
encapsulation dot1q 761
bridge-domain 14
shutdown
exit
interface BDI14
```

Cisco Evolved Programmable Network Manager 3.0 User and Administrator Guide
View L3VPN Service Details

Using Cisco EPN Manager, you can view the detailed information about an L3VPN service in the following ways:

- **Using the Circuit/VC 360 View:** The Circuit/VC 360 view provides detailed information available for a specific L3VPN created using Cisco EPN Manager. See View Circuits/VCs. The different parameters associated with the L3VPN service are displayed in five different tabs: Summary, VRFs, Site Details, HSRP, and PE-CE Routing.

  **Note:** To view the extended details of HSRP during service discovery, click the Site Details tab and then choose a row from the IP endpoints. Also, to view the 6VPE authentication properties for the selected OSPFv3 routing protocol type and IPv6 address family, click the PE-CE Routing tab.

- **Using the Network Topology and Service Details View:** The Network Topology window presents a graphical, topological map view of devices, the links between them, and the active alarms on the devices or links. It also enables you to visualize L3VPNs within the displayed topology map.

  - To view a complete list of L3VPNs and its details, see View a Device Group's Circuits/VCs List in the Topology Window, on page 600. See, Get Quick Information About a Circuit/VC: Circuit/VC 360 View.

  - To view the L3VPN service details for a specific device, see View a Specific Device's Circuits/VCs

- **Using the Alarms Table:** The Alarms Table in Cisco EPN Manager provides several ways to see, at a glance, if there are any problems with your L3VPN services. See Check Circuits/VCs for Faults.

View HSRP Extended Details

After creating an L3VPN service with Hot Standby Routing Protocol (HSRP) details you can view HSRP properties in the Circuit 360/extended details view.

**Step 1** From the left pane, choose Maps > Topology Maps > Network Topology.
The network topology window opens.

**Step 2**  
From the toolbar, click **Device Groups** and then filter an L3VPN service to view.

**Step 3**  
Choose the L3VPN service to view the Overlay of HSRP as shown in the Figure.

*Figure 13: Overlay-HSRP*

**Step 4**  
To view extended details of HSRP:

- Click the View 360 hyperlink. The Circuit/VC 360* page appears.
- Choose View > Details.
- In the Circuit-VC Details window, click the Site Details tab.
- Choose an IP Endpoint and then click the HSRP tab to view the properties.
Modify L3VPNs and VRFs

You can modify L3VPN services that are created and deployed using Cisco EPN Manager. While the full mesh prefix, QoS profiles, Route Target values, and the OSPF configurations associated with the service can be modified, you cannot modify parameters such as the customer details, VPN name, and service MTU values associated with the service. To modify these parameters, delete the service, and re-create it with new values. You can also modify the VRFs associated with L3VPN services.

To modify L3VPN services and VRFs:

**Before you begin**

To modify L3VPN services that are discovered and promoted using Cisco EPN Manager, you must ensure that the route distinguisher for the L3VPN service is specified in the format `rd device_ip:number`. For example:

```plaintext
vrf definition vdvgfr420
  rd 10.104.120.133:420
  vpn id 36B:420
  !
  address-family...
```

If the route distinguisher is specified in any other format, you will not be able to edit the service.

**Step 1**

Navigate to Maps > Network Topology.
Step 2  Click the Circuits/VCs tab, and select the L3VPN service that you want to modify.

Step 3  Click the pencil (Modify) icon.

Step 4  To modify the selected L3VPN, choose Modify VPN and click Next.

The Provisioning wizard displays the VRFs, endpoints, and other details associated with the selected L3VPN.

Step 5  To modify the VRFs associated with the selected L3VPN, choose Modify VRF and click Next.

The Provisioning wizard displays the VRFs, endpoints, and other details associated with the selected L3VPN. Along with modifying existing VRF parameters, you can also associate new Route Target values to the VRF.

While modifying VRFs, you cannot modify the QoS profiles associated with the UNIs, however, you can modify the QoS policies associated with the service endpoints.

Note  You cannot modify the VRF name and device associated with the selected L3VPN.

Step 6  Make the required changes and click Submit to preview the configuration that will be deployed to the device.

Note  When you modify a VPN, you cannot change the VRFs associated with the VPN. To modify the VRFs, see Add and Copy VRFs to an L3VPN Service, on page 537.

Step 7  Review your changes and click Deploy to deploy your changes to the device.

In case of a deploy failure on even a single device that is part of the service, the configuration is rolled back on all devices participating in the service.

Step 8  To verify that your changes were saved, view the L3VPN service details. See View L3VPN Service Details, on page 534.

Add and Copy VRFs to an L3VPN Service

Using Cisco EPN Manager you can create and associate new VRFs to existing L3VPN services. You can also copy the route target and other details from existing VRFs to create new VRFs for the L3VPN service.

To associate new VRFs with an L3VPN service:

Step 1  Navigate to Maps > Network Topology.

Step 2  Click the Circuits/VCs tab and select the L3VPN service to which you want to associate new VRFs.

You can also access the L3VPN Provisioning wizard by choosing Configuration > Network > Service Provisioning.

Step 3  Click the pencil (Modify) icon.

The L3VPN Provisioning wizard is displayed.

Step 4  Select Add VRF and click Next.

Step 5  Click the + icon to add the new VRF details manually. To auto populate the VRF details, click the device on the map to select it. The device details and a new name for the VRF are automatically populated on the VRF's page.

Step 6  You can copy VRF details from an existing VRF by clicking the Copy From drop-down list and selecting the required VRF.

Only those VRFs that are associated with the selected L3VPN are displayed along with the VRFs route target, and route redistribution details.
Step 7 Otherwise, manually specify the details of the VRFs that you want to add to the selected VPN service. For more information about the different VRF parameters, see, Create and Provision a New L3VPN Service.

Step 8 Make any required changes such as adding endpoint and BGP neighbor details and click Submit.

Step 9 Preview the configuration that is to be deployed to the device, make the required changes, and click Deploy to deploy the changes to the device.

To verify that your changes were deployed, view the selected L3VPN service's details. See View L3VPN Service Details.

For more information on modifying and deleting L3VPN services, see Delete an L3VPN Service Endpoint, on page 615 and Modify L3VPNs and VRFs, on page 536.

---

Provision Circuit Emulation Services

- Summary of Cisco EPN Manager CEM Provisioning Support, on page 538
- Prerequisites for CEM Provisioning, on page 538
- Create and Provision a New CEM Service, on page 538
- Provision an EM-Voice CEM Service, on page 547

Summary of Cisco EPN Manager CEM Provisioning Support

Cisco EPN Manager supports the provisioning of Circuit Emulation (CEM) services. CEM provides a bridge between the traditional TDM network and the packet switched network (PSN). It encapsulates the TDM data into packets, provides appropriate header, and send the packets through PSN to the destination node. For more information, see Supported Circuit Emulation Services, on page 468.

You can also assign a MPLS TE tunnel to a CEM service to allow the CEM service to traverse through the network. Use the Preferred Path drop-down list in the Provisioning Wizard to assign a MPLS TE tunnel for a CEM service. For more information, see CEM Service Details References, on page 540.

Prerequisites for CEM Provisioning

The following prerequisites must be met before you can provision a CEM service:

- IP/MPLS connectivity must be enabled on the originating and terminating endpoints in a CEM service.
- CEM configurations such as loopback interface and ACR groups must be configured on the devices that will be used in the CEM service. For more information, see Configure Circuit Emulation, on page 292.
- Inventory collection status for the devices on which the CEM service will be provisioned must be Completed. To check this, go to Inventory > Device Management > Network Devices, and look at the status in the Last Inventory Collection Status column.
- Optionally, customers can be created in the system so that you can associate a CEM service to a customer during the service creation and provisioning process. From the left sidebar, choose Inventory > Other > Customers to create and manage customers.

Create and Provision a New CEM Service

The process of creating and provisioning a CEM service in Cisco EPN Manager involves:
• Specifying endpoints of the CEM service.
• Defining the attributes that influence how traffic that is delivered over the CEM service and through its endpoints will be treated.

Before you begin

For information about the prerequisites that must be met before you can provision a CEM service, see Prerequisites for CEM Provisioning, on page 538.

Step 1
In the left sidebar, choose Maps > Topology Maps > Network Topology.

Step 2
Click Device Groups, and then select the location in which you want to create the CEM service.

Step 3
Close the Device Groups popup window.

Step 4
In the Network Topology window, click Circuits/VCs.

Step 5
Click the ‘+’ icon to open the Provisioning Wizard in a new pane to the right of the map.

You can also access the Provisioning wizard by choosing Configuration > Network > Service Provisioning.

Step 6
From the Technology drop-down list, choose Circuit Emulation.

Step 7
From the Service Type drop-down list, choose the required CEM service type depending on the rate at which you want the circuit to transmit the data. For a list of CEM service types that Cisco EPN Manager supports, see Supported Circuit Emulation Services, on page 468.

Step 8
If you have defined profiles to set the attributes of the different services, select the required profile from the Select Profile drop-down list. See Create Circuit/VC Profiles, on page 572.

Step 9
Click Next to go to the Customer Service Details page.

Step 10
(Optional) Select the customer for whom the EVC is being created. If there are no customers in the list, go to Inventory > Other > Customers to create the customer in the system, and then go to the Provisioning Wizard to start provisioning the CEM service.

Step 11
Check the Activate check box to activate the interface associated with the service that you are provisioning.

Step 12
Enter the service name and its description.

Step 13
In the Deployment Action field, specify what you want to do when the CEM service creation process is completed. You can either request a preview of the configurations that will be deployed to the relevant devices before the actual deployment or you can deploy the configurations immediately upon completion.

If you choose Deploy, then click one of the following deployment options:

• Deploy Now—Directly deploys the provisioning order
• Deploy Later—Saves the created provisioning order and deploys the same order at later period of time.
• Schedule Deployment—Schedules the provisioning order and to be deployed at the scheduled time. If you click this Schedule Deployment radio button, specify the following:
  • Deploy Schedule Time—Specify a schedule time for deployment of provision order.
  • Server Time—Displays the current server time.

Step 14
Click Next, and then enter the A End and Z End configurations, and the transport settings for the CEM service. See CEM Service Details References, on page 540 for descriptions of the fields and attributes.
Step 15
If one of the endpoints is an interface on a device that is not managed by Cisco EPN Manager, check the **Unmanaged Device** check box and provide information for the unmanaged device. See *Provision a Circuit/VC with an Unmanaged Endpoint*, on page 575 for more information.

**Note**
The **Unmanaged Device** check box is available only in the Z End Configurations page.

Step 16
(Optional) If you want to append a template with additional CLI commands that will be configured on the devices participating in the service, do so in the **Template Details** page. See *Extend a Circuit/VC Using Templates*, on page 575 for more information.

Step 17
When you have provided all the required information for the service, click **Submit**. If you chose to see a preview of the CLI that will be deployed to the devices, it will be displayed now and you can click **Edit Attributes** to change the attributes. Otherwise, the configurations will be deployed to the devices immediately.

---

The CEM service should be added to the list in the Circuits/VCs pane in the **Network Topology** window. To check the provisioning state, click on the **i** icon next to the circuit/VC name to see the Circuit/VC 360 view. Also, you can view the saved provisioning job in the Planned Circuits/VCs tab from **Administration > Dashboards > Job Dashboard > Provisioning**.

---

### CEM Service Details References

The following table lists and describes the attributes that define the CEM service types.

<table>
<thead>
<tr>
<th><strong>Table 47: Circuit Section Reference—CEM Service Types</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Attribute</strong></td>
</tr>
<tr>
<td><strong>A End and Z End Configurations</strong></td>
</tr>
<tr>
<td>Device</td>
</tr>
<tr>
<td><strong>Working Path and Protecting Path</strong></td>
</tr>
<tr>
<td><strong>Note</strong> The <strong>Working Path and Protecting Path</strong> are not available for X.21, C37.94, and EM-Voice service types.</td>
</tr>
<tr>
<td>Port Name or Interface Name</td>
</tr>
<tr>
<td>When you choose the port name under the <strong>Protecting Path</strong> area, the unidirectional path switched ring (UPSR) protection mechanism is enabled.</td>
</tr>
<tr>
<td>When you choose the port group under the <strong>Protecting Path</strong> area, the Automatic Protection Switching (APS) protection mechanism is enabled. For more information about how to configure protection groups, see <em>Configure APS or MSP and UPSR or SNCP Protection Groups</em>, on page 298.</td>
</tr>
<tr>
<td>Higher Order Path</td>
</tr>
<tr>
<td>Select the path and path mode available for the CEM service.</td>
</tr>
</tbody>
</table>
### Attribute Description

**Lower Order Path**
LOPs or virtual tributary (VT) path is used to transport TDM data of lower bandwidth.

**DS0 Time Slot**
Choose one or more time slots available in the DS0 group.

**Note** This field is available only if you select **DS0** in the **Service Type** field.

### Clocking

The nodes in a network may be at different clock rates. Differences in timing at nodes may cause the receiving node to either drop or reread information sent to it. Clocking is essential to synchronize all nodes to the same clock rate. For more information about clocking, see *Configure Clocking for CEM, on page 300.*

**Clock Source**
Enables to recover the clock rate from single source so that all nodes can be synchronized at the same clock rate. Values are:

- **Internal** – Clock rate recovered from the host.
- **Line** – Clock rate recovered from the SONET/SDH line.
- **Adaptive Clock Recovery** – Clock rate is recovered based on the dejitter buffer fill level. Due to delay variations, the dejitter buffer fill levels keep varying continuously. The TDM service clock is recovered after filtering the variations. The accuracy of the recovered clock depends on the delay variations.
- **Differential Clock Recovery** – Clock rate is recovered from a master clock using Sync-E. For more information about how to setup the master clock for your network, see *Synchronize the Clock Using Sync-E, BITS, and PTP, on page 310.*

**Clock Rate**
Select the required clock rate in bits per second (bps). For example, if the clock rate is set to 64000, you can only send 64 kbps over the serial interface.

**Note** This field is available only for X.21 service type.

### QOS

The list of profiles available for selection includes policy maps that were configured on the device and discovered by the system, as well as user-defined QoS profiles. Refer to *Create QoS Profiles, on page 573* for information on how to create QoS profiles.

**Ingress QoS Profile**
Select the ingress QoS policies that are configured on the A end and Z end devices.

### Unmanaged Device Details

**Note** The below fields are available only for Z End Configurations.

**Unmanaged Device**
Check this check box to include a device that is not managed by Cisco EPN Manager and create partial service.

**New Device**
Check this check box to create a new unmanaged device.
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device</td>
<td>Choose an unmanaged device from the drop-down list. <strong>Note</strong> This field is available only when the New Device check box is unchecked.</td>
</tr>
<tr>
<td>Device Name</td>
<td>Enter a unique name for the new unmanaged device that you want to create. <strong>Note</strong> This field is available only when the New Device check box is checked. If the New Device check box is unchecked, the name of the unmanaged device that you chose in the Device drop-down list is populated in this field.</td>
</tr>
<tr>
<td>Device IP</td>
<td>Enter the IP address of the new unmanaged device that you want to create. <strong>Note</strong> This field is available only when the New Device check box is checked. If the New Device check box is unchecked, the IP address of the unmanaged device that you chose in the Device drop-down list is populated in this field.</td>
</tr>
<tr>
<td>LDP IP</td>
<td>Enter a valid LDP IP for the unmanaged device.</td>
</tr>
<tr>
<td>VC ID</td>
<td>Enter a unique Virtual Circuit (VC) ID for the unmanaged device.</td>
</tr>
<tr>
<td>Time Slot</td>
<td>Enter the time slot for the service. The valid range is 1 to 12. <strong>Note</strong> This field is available only for C37.94 service type.</td>
</tr>
<tr>
<td>Command Type</td>
<td>Select the PCM encoding configuration for voice port. The values are A Law and U Law. <strong>Note</strong> This field is available only for EM-Voice service type.</td>
</tr>
<tr>
<td>Operation</td>
<td>Select the number of wires used for voice transmission at this interface. The values are:</td>
</tr>
<tr>
<td></td>
<td>• Wire 2—The audio path is full duplex with one pair of wires.</td>
</tr>
<tr>
<td></td>
<td>• Wire 4—The audio path is full duplex with two pairs of wires.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This field is available only for EM-Voice service type.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>EM Signal</td>
<td>Select the options of signaling type configuration. The values are:</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Note This field is available only for EM-Voice service type.</td>
</tr>
<tr>
<td>EM Type</td>
<td>Select the type of E&amp;M interface to which the voice port is connecting. The values are Type 1, Type 2, Type 3, Type 5, and Type To.</td>
</tr>
<tr>
<td></td>
<td>Note This field is available only for EM-Voice service type.</td>
</tr>
<tr>
<td>Impedence</td>
<td>Select the impedance depending on the operation selected. If you selected the Operation as Wire 2, select the impedance as 600 R, Complex1, Complex2, or Complex3. If you selected the Operation as Wire 4, select the impedance as 600 R.</td>
</tr>
<tr>
<td></td>
<td>Note This field is available only for EM-Voice service type.</td>
</tr>
<tr>
<td>Transport Settings</td>
<td></td>
</tr>
<tr>
<td>Frame Type</td>
<td>This field is display-only and is auto-populated based on the CEM service type that you chose when creating the CEM service. The values are CESoPSN, SAToP, FRAMED_SAToP and CEP.</td>
</tr>
<tr>
<td></td>
<td>Note View the CLI changes for T1/T3 and E1/E3 services over SONET framed mode with SDH in the Device Preview Config after deployment of a CEM service. The FRAMED-SAToP frame type is supported on NCS42xx or ASR9xx device.</td>
</tr>
<tr>
<td>Payload Size</td>
<td>Number of bytes put into each IP packet. The valid range is 64 – 1312. The range will vary based on the device capability, level of support and the configured dejitter buffer size value.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Dejitter Buffer Size | Determines the ability of the emulated circuit to tolerate network jitter. The valid range is 1 - 32. The range will vary based on the device capability, level of support and the configured payload size value.  
Note For X.21 service type, the range will vary based on the clock rate. |
| Idle pattern       | Idle pattern to transmit the data when the service goes down. The valid range is 0x00 - 0xFF.                                                                                                                |
| Dummy Mode         | Enables you to set a bit pattern for filling in for lost or corrupted frames. The values are last-frame and user-defined.                                                                                       |
| Dummy Pattern      | The bit pattern used for filling in for lost or corrupted frames. The valid range is 0x00 - 0xFF. The default is 0xFF.  
Note This field is enabled only if you choose the Dummy Mode as user-defined.                                                                 |
| RTP Header Enabled | Check this check box to enable the Real-Time Transport Protocol (RTP) header for the CEM service.                                                                                                             |
| RTP Compression Enabled | Check this check box to compress the IP header in a packet before the packet is transmitted. It reduces network overhead and speeds up the transmission of RTP. |

**Pseudowire Settings**

<table>
<thead>
<tr>
<th>Preferred Path Type</th>
<th>Choose the Preferred Path Type as Bidirectional or Unidirectional.</th>
</tr>
</thead>
</table>
| Preferred Path      | Select the MPLS bidirectional TE tunnel through which you want the CEM service to pass through.  
Note This field is available only if you selected **Bidirectional** as the Preferred Path Type.                                                              |
| Preferred Path (A-Z) | Select the required unidirectional tunnel through which you want the CEM service to travel from the A endpoint to the Z endpoint.  
Note This field is available only if you selected **Unidirectional** as the Preferred Path Type.                                                            |
| Preferred Path (Z-A) | Select the required unidirectional tunnel through which you want the CEM service to travel from the Z endpoint to the A endpoint.  
Note This field is available only if you selected **Unidirectional** as the Preferred Path Type.                                                            |
| Allow Fallback to LDP | Check this check box to ensure that the CEM service falls back to the default MPLS Label Distribution Protocol (LDP) when the selected preferred path goes down.  
Note This check box is available only when you select a valid MPLS TE tunnel in the **Preferred Path** field.                                                |
| Send Control Word   | Check this check box if you want a control word to be used to identify the pseudowire payload on both sides of the connection.                                                                                  |
Save and Schedule a Provisioning Order

When you create, modify, or delete provisioning services such as Circuits/VCs, MPLS tunnels or L3VPN service technologies you can either preview or deploy services. You can choose deploy options such as Deploy Now, Deploy Later, and Schedule Deployment before you save or schedule a provisioning order.

View the saved provisioning orders in the Planned Circuits/VCs tab and if necessary you can modify the planned services or create succeeded services. Following are some of the limitations:

- If the planned version exists all modify and delete operations for live circuits are disabled. Also, you cannot amend services under Inventory > Circuits/VCs&Network Interfaces for planned order. For more information, see the What to do Next section.

- If you edit the order from Planned circuits, Cisco EPNM allows modification against planning.

- The delete action from Planned circuits deletes the planned service that is reverted to the last attempted provisioned version. For scheduled orders, if the time is updated from the Job dashboard then the same time will not reflect in the Planned Circuits.

To save and schedule deployment:

**Step 1**
Create a planned provisioning order through one of the following paths:

Choose **Maps > Topology Maps > Network Topology**

—Or—

**Inventory > Circuits/VCs&Network Interfaces**

**Step 2**
Repeat steps 2 through 12 from the Provision Circuits/VCs in Cisco EPN Manager topic.

**Step 3**
To save and schedule deployment:

a) Under the Deploy area, click the **Deploy Later** radio button to save the provisioning order.

b) Under the Deploy area, click the **Schedule Deployment** radio button to save the order for future deployment at the designated time provided by you. Specify the following values.

- **Deploy Schedule Time**—Specify a schedule time for deployment of a provisioning order.

- **Server Time**—Displays the current server time.

c) Click **Next** to choose the endpoints and define the attributes based on the technology you have selected.

d) Click **Submit** Depending on the deployment action you have chosen, the relevant action will be performed. That is, if you have chosen to preview the configuration, the preview page will be displayed where you can view the configurations, and then click **Deploy**. If you have chosen to deploy, the configurations will be directly deployed to the relevant devices. After you receive the Deployment Saved/Scheduled successful message, click **Close**.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Internetworking Options</td>
<td>Choose an option if one of the endpoints in the EVC is an unmanaged device</td>
</tr>
<tr>
<td>Bandwidth (Kbps)</td>
<td>Enter the required bandwidth for the pseudowire.</td>
</tr>
<tr>
<td>PWID</td>
<td>Enter a pseudowire identifier. This ID is displayed in the Pseudowire settings for point-to-point services.</td>
</tr>
</tbody>
</table>
Step 4 In the left pane, click the CircuitVCs hyperlink. The Locations/All Locations/Unassigned extended view window appears.

Step 5 Click the Planned Circuit VC tab to view the newly created provisioning service details. The status of the newly created provisioning service is displayed as "Create Planned". View the deployment schedule time, type and name of service to be provisioned, customer name and the last modified date and time. If required, you can modify the service again. For the planned service you can perform multiple amends until deployment. The status will be displayed as "Modify Planned".

Note The Planned Circuit /VCs tab will be available only when you click the CircuitVCs from the Maps > Topology > Network Topology. For Deploy Later option the deployment schedule time is not displayed.

During multiple amends the latest version is captured. In due course, if there is a scheduled order and the latest version is set to deploy later then all the previous scheduled order will be deleted from the Job dashboard.

Step 6 Click the create planned order and then choose Actions > Deploy to directly deploy the service.

Step 7 (Optional) You can perform other actions, if required:
    a) Click the + icon to create a new provisioning workflow.
    b) Click X icon to delete the planned service. A successful or failure message is displayed at the bottom right corner of the window after the service is deleted.

Step 8 To view the Scheduled provisioning job choose Administration > Dashboard > Job Dashboard. The status is displayed as Scheduled and you can view the next start time of deployment and so on.
    a) (Optional) Click the Edit Schedule to edit the schedule order.
       • In the Schedule window, modify the schedule time and other details, if required.
       • Click Save and return to the Job Dashboard window.
    b) (Optional) Click the X icon to delete the job.

After the job is successfully deployed, the entry is listed in the job dashboard. For Deploy Later option, a job will not be created as the time is not defined.

---

**What to do next**

Choose Inventory > Circuits/VCs&Network Interfaces to view the Planned Circuits/VCs. You can create a new provisioning workflow, deploy the existing service or amend the service for a given provisioning order. After the deployment is successful the provisioning order entry is cleared from the Planned Circuits/VCs tab.

---

**Note**

View the deployed Circuit /VCs in the Circuits/VCs tab and the Planned Circuits in the Planned Circuit /VCs tab.

You cannot perform modify or delete operation for live Circuits/VCs. This is because you have to first clear the planned version before making further amends to the deployed version. Click the Planned Circuits/VCs to make amends to the selected Circuits/VCs or deploy the planned version.

**Delete Operation**

When you delete the planned version, a successful message or failure message is displayed at the bottom right corner of the window. After the service is deleted in the Circuit/VCs tab the status is displayed as "Modify Plan Canceled," and "Delete Plan Canceled".
Preview Config

During creation of new provisioning Circuits/Vcs, if the **Deployment Action** is chosen as **Preview** then you have the option to choose either **Deploy Now** or **Deploy Later** or **Schedule Deployment** in the **Deploy** page.

View Network Interfaces

In the Circuits/VCs tab, click Network Interfaces to view network interface details for provisioning services. You can modify or delete an interface using a Wizard.

# Provision an EM-Voice CEM Service

On the EM IM, ports 0-3 form one group and ports 4 and 5 form another group, the applicable EM types for each of these groups will now be reflected in EPNM during service provisioning, and you can view the list of applicable type for every port.

To provision a CEM service for the selected service type EM-Voice:

---

**Step 1** In the left pane, choose **Maps > Topology Maps > Network Topology**.

**Step 2** Click **Device Groups**, and then select the location in which you want to create the CEM service.

**Step 3** Close the **Device Groups** popup window.

**Step 4** In the **Network Topology** window, click **Circuits/VCs**.

**Step 5** Click the ‘+’ icon to open the Provisioning Wizard in a new pane to the right of the map.

You can also access the Provisioning wizard by choosing **Configuration > Network > Service Provisioning**.

**Step 6** From the **Technology** drop-down list, choose **Circuit Emulation**.

**Step 7** From the **Service Type** drop-down list, choose **EM-Voice** to transmit the data. For a list of CEM service types that Cisco EPN Manager supports, see Supported Circuit Emulation Services, on page 468.

**Step 8** If you have defined profiles to set the attributes of the different services, select the required profile from the **Select Profile** drop-down list. See Create Circuit/VC Profiles, on page 572.

**Step 9** Click **Next** and then enter the service name and its description.

**Step 10** Click **Next** and then enter the A End configurations for the CEM service. See CEM Service Details References, on page 540 for descriptions of the fields and attributes.

a) From the **Port Name** drop-down list, choose the interface name. Based on the configurations on the device, the ports are listed and you can view the list of applicable type for every port.

b) From the **EM Type** drop-down list, choose the type that can be configured on a port.

**Note** The **Type** will be listed based on the Interface name and **Applicable Type** that you have chosen in the **Port Name** field.

**Step 11** Click **Next**, and then enter the Z End configurations for the CEM service.

**Note** EM Type must be same as A Endpoint EM Type.

**Step 12** Click **Submit** to push the configuration to the device. If you chose to see a preview of the CLI that will be deployed to the devices, it will be displayed now and you can click **Edit Attributes** to change the attributes. Otherwise, the configurations will be deployed to the devices immediately.
Provision MPLS Traffic Engineering Services

- Summary of Cisco EPN Manager MPLS TE Provisioning Support, on page 548
- MPLS TE Service Provisioning Features, on page 548
- Prerequisites for Provisioning an MPLS TE Service, on page 548
- Create and Provision an MPLS TE Tunnel, on page 549
- Create and Provision an MPLS Layer 3 Link, on page 559

Summary of Cisco EPN Manager MPLS TE Provisioning Support

Cisco EPN Manager supports the provisioning of MPLS Traffic Engineering services. MPLS TE enables an MPLS backbone to replicate and expand the TE capabilities of Layer 2 over Layer 3. MPLS TE uses Resource Reservation Protocol (RSVP) to establish and maintain label-switched path (LSP) across the backbone. For more information, see Supported MPLS Traffic Engineering Services, on page 470.

MPLS TE Service Provisioning Features

Cisco EPN Manager supports the following MPLS TE features:

- Support for explicit routing, constraint-based routing, and trunk admission control.
- Provision for path protection mechanism against link and node failures.
- Usage of Resource Reservation Protocol (RSVP) to establish and maintain label-switched path (LSP).
- Ability to advertise TE links using OSPF and ISIS.

Following are the MPLS TE limitations in Cisco EPN Manager:

- MPLS TE tunnel is supported only on NCS 4206, 4216 devices, NCS4K, NCS 5500, ASR9k, and ASR9XX. However, inventory support is provided for NCS 4201 and NCS 4202.
- OSPF and ISIS are supported as the IGP for implementing MPLS TE.
- Wrap protection, BFD and fault-oam are not supported in NCS5500 device.

For the list of devices that support the provisioning of MPLS TE tunnel, see Cisco Evolved Programmable Network Manager Supported Devices

Prerequisites for Provisioning an MPLS TE Service

The following prerequisites must be met before you can provision an MPLS TE service:

- OSPF or IS-IS must be configured on the devices that participate on the MPLS TE service.
- All links that will be used for MPLS TE service provisioning must be TE enabled.
Create and Provision an MPLS TE Tunnel

To provision an MPLS TE tunnel:

**Before you begin**

For information about the prerequisites that must be met before you can provision an MPLS TE tunnel, see Prerequisites for Provisioning an MPLS TE Service, on page 548

**Step 1**
From the left sidebar, choose Maps > Topology Maps > Network Topology.

**Step 2**
Click Device Groups, and then select the location in which you want to create the MPLS TE tunnel.

**Step 3**
Close the Device Groups popup window.

**Step 4**
In the Network Topology window, click Circuits/VCs.

**Step 5**
Click the '+’ icon to open the Provisioning Wizard in a new pane to the right of the map.

**Step 6**
From the Technology drop-down list, choose MPLS TE. Cisco EPN Manager displays a list of relevant service types in a Service Type area.

**Step 7**
In the Service Type area, choose Unidirectional TE Tunnel or Bidirectional TE Tunnel. You can set up WAE parameters REST call from EPN Manager automatically.

**Step 8**
If you have defined profiles to set the attributes of the different services, choose the required profile from the Select Profile drop-down list. See Create Circuit/VC Profiles, on page 572.

**Step 9**
Click Next to go to the Customer Service Details page.

**Step 10**
(Optional) Select the customer for whom the service is being provisioned. If there are no customers in the list, go to Inventory > Other > Customers to create the customer in the system, and then restart the Provisioning wizard.

**Step 11**
Enter the service name and its description, and then enter the service details. See Field References for Service Details—MPLS TE Tunnel, on page 550.

**Note**
If you do not provide a service name, Cisco EPN Manager assigns a service name in the following format:

- If the source and destination devices have a common tunnel ID, the service name is assigned in the `<SourceDeviceName>`_<TunnelId>_<DestinationDeviceName>` format.

- If the source and destination devices have unique tunnel IDs, the service name is assigned in the `<SourceDeviceName>`_<ATunnelId>_<ZTunnelId>_<DestinationDeviceName>` format.
Step 12 Click Next, and then enter the tunnel creation parameters. See Field References for Tunnel Creation—MPLS TE Tunnel, on page 551 for descriptions of the fields and attributes.

Step 13 Click Next, and then enter the path constraint details. See Field References for Path Constraint Details—MPLS TE Tunnel, on page 557 for descriptions of the fields and attributes.

Step 14 Click Submit. If you chose to see a preview of the CLI that will be deployed to the devices, it will be displayed now and you can click Edit Attributes to change the attributes. Otherwise, the configurations will be deployed to the devices immediately.

The service should be added to the list in the Circuits/VCs pane in the Network Topology window. To check the provisioning state, click the i icon next to the circuit/VC name to see the Circuit/VC 360 view.

Field References for Service Details—MPLS TE Tunnel

The following table lists and describes the attributes that define the service details for creating a MPLS TE tunnel.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable FRR</td>
<td>Check this check box to enable the fast reroute feature that provides link and node protection for your MPLS TE tunnel.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This check box is available only when you create a unidirectional TE tunnel.</td>
</tr>
<tr>
<td>Enable Auto Bandwidth</td>
<td>Check this check box to automatically assign maximum and minimum bandwidth to the TE tunnel based on the traffic.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This check box is available only when you create a unidirectional TE tunnel.</td>
</tr>
<tr>
<td>Wrap Protection</td>
<td>Check this check box to detect mid-link failure scenarios.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This check box is available only when you create a bidirectional TE tunnel.</td>
</tr>
<tr>
<td>Enable Fault OAM</td>
<td>Check this check box to enable the fault OAM protocols and messages that support the provisioning and maintenance of MPLS TE tunnels.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This check box is available only when you create a bidirectional TE tunnel.</td>
</tr>
<tr>
<td>Enable Autoroute</td>
<td>Check this check box to enable autoroute for the tunnel.</td>
</tr>
<tr>
<td>Enable LockDown</td>
<td>Check this check box if you do not want to reoptimize the working LSP.</td>
</tr>
<tr>
<td>Enable BFD Settings</td>
<td>Check this check box to enable the Bidirectional Forwarding Detection (BFD) protocol. BFD provides fast forwarding path failure detection time and a consistent failure detection method.</td>
</tr>
</tbody>
</table>
Choose one of the following protection mechanism for the TE tunnel:

- **Working**—The tunnel has only a working path.
- **Working+Protected**—The tunnel has a working and a protected path, wherein if the working path fails, the traffic flow is automatically routed to the protected path without the links going down.
- **Working+Restore**—The tunnel has a working and a restore path, wherein if the working path fails, the link goes down and then the traffic flow is routed to the restore path.
- **Working+Protected+Restore**—The tunnel has a working, protected, and restore path, wherein, if the working path fails, the traffic flow is routed to the protected path. If the protected path also fails, the link goes down and then the traffic flow is routed to the restore path.

Choose one of the following options to specify what you want to do when the MPLS TE tunnel creation process is completed:

- **Preview**—Previews the configurations that will be deployed to the relevant devices before the actual deployment.
- **Deploy**—Deploys the configurations immediately upon completion.

### Field References for Tunnel Creation—MPLS TE Tunnel

The following table lists and describes the attributes that define the MPLS TE tunnel creation.

**Table 49: Tunnel Creation Section Reference—MPLS TE Tunnel**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Create Tunnel</strong></td>
<td></td>
</tr>
<tr>
<td>Source</td>
<td>Source or A endpoint of the tunnel.</td>
</tr>
<tr>
<td>Source routing Process</td>
<td>OSPF or ISIS routing process that is TE enabled and configured on the source endpoint selected. You can determine the router ID and loopback address configured on the source endpoint based on the OSPF or ISIS routing process.</td>
</tr>
<tr>
<td>Destination</td>
<td>Destination or Z endpoint of the tunnel.</td>
</tr>
<tr>
<td>Destination Routing Process</td>
<td>OSPF or ISIS routing process that is TE enabled and configured on the destination endpoint selected. You can determine the router ID and loopback address configured on the destination endpoint based on the OSPF or ISIS routing process.</td>
</tr>
<tr>
<td><strong>Tunnel Setting</strong></td>
<td></td>
</tr>
<tr>
<td>Global ID</td>
<td>The global ID assigned to both, source and destination endpoints. This ID must be the same to bind two unidirectional tunnels into a bidirectional TE tunnel. The default value is 0.</td>
</tr>
<tr>
<td>Note</td>
<td>This attribute is available only when you create a bidirectional TE tunnel. EPNM supports a global id only within the range of 1 to 2147483647.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Affinity Bits</td>
<td>The affinity bit determines the link attribute that the bidirectional TE tunnel will use when configuring the dynamic backup paths.</td>
</tr>
<tr>
<td>Affinity Mask</td>
<td>The affinity mask determines which link attribute the router must check. You can use affinity bits and affinity mask to include or exclude link attributes when configuring the dynamic backup paths. If a bit in the mask is 0, the value of the associated link attribute for that bit is irrelevant. In this case, the link attribute is excluded when configuring the dynamic backup paths. If a bit in the mask is 1, the value of the associated link attribute must match the affinity of the tunnel for that bit. In this case, the link attribute is included when configuring the dynamic backup paths.</td>
</tr>
<tr>
<td>Setup Priority</td>
<td>Setup priority assigned to an LSP for the unidirectional or bidirectional TE tunnels. Based on this priority, the LSP can determine which existing tunnels or LSPs with low priority can be blocked. Valid values are from 0 to 7. A lower number indicates a higher priority. For example, an LSP with a setup priority of 0 can block any LSP with a setup priority between 1 and 7. Note Setup priority cannot be higher than the hold priority.</td>
</tr>
<tr>
<td>Hold Priority</td>
<td>Hold priority assigned to an LSP for the unidirectional or bidirectional TE tunnels. Based on this priority, the LSP can determine whether it must be blocked by another signaling LSP with a high setup priority. Valid values are from 0 to 7. A lower number indicates a higher priority. For example, an LSP with a hold priority of 0 cannot be blocked by another LSP.</td>
</tr>
<tr>
<td>Bandwidth Pool Type</td>
<td>Bandwidth pool used to manage the reservable bandwidth on each link for constraint-based routing (CBR) in MPLS TE. Values are: • Global – Regular TE tunnel bandwidth. • Subpool – A portion of the global pool. The subpool bandwidth is not reserved from the global pool if it is not in use. Subpool tunnels require a higher priority than global pool tunnels. Note This field is available only when you uncheck the Enable Auto Bandwidth check box.</td>
</tr>
<tr>
<td>Bandwidth</td>
<td>Bandwidth for the bidirectional TE tunnel. The value must be specified in the units of Kbps. For example, if you want to assign a bandwidth of 1000000 Kbps for the tunnel, enter the value as 1000000 Gbps. Note This field is available only when you uncheck the Enable Auto Bandwidth check box.</td>
</tr>
</tbody>
</table>

Cisco Evolved Programmable Network Manager 3.0 User and Administrator Guide
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto Bandwidth Max</td>
<td>Cisco EPN Manager automatically assigns the maximum bandwidth for the unidirectional TE tunnel based on the traffic. However, you can change the bandwidth, if required.                                                                                                     Note: This field is available only when you check the Enable Auto Bandwidth check box in the Customer Service Detail screen.</td>
</tr>
<tr>
<td>Auto Bandwidth Min</td>
<td>Cisco EPN Manager automatically assigns the minimum bandwidth for the unidirectional TE tunnel based on the traffic. However, you can change the bandwidth, if required.                                                                                                     Note: This field is available only when you check the Enable Auto Bandwidth check box in the Customer Service Detail screen.</td>
</tr>
<tr>
<td>Bandwidth Change Frequency (Sec)</td>
<td>Enter the bandwidth change frequency in seconds. The valid range is between 3600 to 604800.                                                                                          Note: This field is available only when you check the Enable Auto Bandwidth check box in the Customer Service Detail page when you create unidirectional tunnels.</td>
</tr>
<tr>
<td>Adjustment Threshold</td>
<td>Enter the bandwidth adjustment threshold in percentage to trigger an adjustment if the largest sample percentage is higher or lower than the current tunnel bandwidth. Adjustment threshold is the percentage of the current tunnel bandwidth and an absolute (minimum) bandwidth. Both the thresholds must be fulfilled for the automatic bandwidth to resignal the tunnel. The tunnel bandwidth is adjusted only if the difference between the largest sample output rate and the current tunnel bandwidth is larger than the adjustment thresholds. The valid range for the unidirectional tunnels that connect the Cisco IOS-XR devices is 1 to 100 and the range for the unidirectional tunnels that connect the Cisco IOS-XE devices is 1 to 99. Note: This field is available only when you check the Enable Auto Bandwidth check box in the Customer Service Detail page when you create unidirectional tunnels.</td>
</tr>
<tr>
<td>Overflow Threshold</td>
<td>Enter the overflow threshold in percentage to trigger the overflow detection. It is the percentage of the actual signaled tunnel bandwidth. When the difference between the measured bandwidth and the actual bandwidth is larger than the overflow threshold percentage for the N consecutive times (defined as the overflow limit), an overflow detection is triggered. The valid range for the unidirectional tunnels that connect the Cisco IOS-XR devices is 1 to 100 and the range for the unidirectional tunnels that connect the Cisco IOS-XE devices is 1 to 99. Note: This field is available only when you check the Enable Auto Bandwidth check box in the Customer Service Detail page when you create unidirectional tunnels.</td>
</tr>
</tbody>
</table>
### Attribute | Description
--- | ---
Overflow Limit | Enter the number of consecutive collection periods during which the difference between the measured bandwidth and the actual bandwidth of a tunnel can exceed the overflow threshold defined for the tunnel.
The valid range is 1 to 10.  
**Note** This field is available only when you check the **Enable Auto Bandwidth** check box in the **Customer Service Detail** page when you create unidirectional tunnels.

Collect Bandwidth | Check this check box to collect the bandwidth information for the unidirectional tunnel.  
**Note** This field is available only when you check the **Enable Auto Bandwidth** check box in the **Customer Service Detail** page when you create unidirectional tunnels.

### BFD Settings

**New BFD** | This checkbox is selected by default when you select the **Enable BFD Settings** checkbox. Allows you to create a new BFD template for both bidirectional (Flex LSP) and unidirectional tunnels during provisioning.

**BFD Template Name** | Enter the name for the new BFD template.

**BFD Template** | Displays the selected BFD template name by concatenating the device name. For example from A-End and/or Z-End devices. Choose an existing template from the existing template name and the related Min Interval and Multiplier range values are displayed by default.

Alphabets, digits and special characters _(underscore),-(hyphen),.(dot) are allowed, and BFD Template name should be less than 32 characters long.

The BFD template name should not have ,(dots) or digits or combination of digits and ,(dots).  
**Note** This field is available only when you clear the **New BFD** checkbox.

**Min Interval** | BFD uses intervals and multipliers to specify the periods at which control and echo packets are sent in asynchronous mode and their corresponding failure detection. A failure detection timer is started based on \((I x M)\), where \(I\) is the minimum interval, and \(M\) is the multiplier.  
**Note** These fields are available only when you check the **Enable BFD Settings** check box and **New BFD** check box.

Min Interval and Multiplier values are displayed for both new and existing BFD. For the existing BFD, you cannot edit the values.
Logic for BFD Template Usage

Use the BFD template configuration for unidirectional and FLEX LSP tunnels for XE devices. Use inline configuration for uni-directional and FLEX LSP tunnels for XR devices. EPNM provides an option either to create a new BFD template or to re-use an existing BFD template based on the following logic.

Note
FLEX LSP tunnels are referred as Bi-Directional Tunnels.

The following table lists the logic for using BFD template.

Table 50: Logic for BFD Template—MPLS TE Tunnel

<table>
<thead>
<tr>
<th>Uni-Directional</th>
<th>Device Name Combination</th>
<th>Configuration Logic Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>XE-XE</td>
<td>If you have chosen XE device as Source and destination (or XR device as destination), the logic works as a BFD Template configuration. To create a new BFD template: 1. EPNM displays <strong>New BFD</strong> checkbox selected by default. 2. Enter the name of BFD template. 3. Enter the Min interval range value between 4-1000. 4. Enter the Multiplier range value between 3-50. To re-use the existing BFD template: 1. Clear the <strong>New BFD</strong> checkbox. 2. From the <strong>BFD Template</strong> drop-down list, choose an existing BFD template. All existing BFD template names from A-End devices are listed. 3. The Min Interval and Multiplier range values are displayed. 4. Click <strong>Submit</strong>.</td>
</tr>
<tr>
<td></td>
<td>XE-XR</td>
<td></td>
</tr>
<tr>
<td></td>
<td>XR-XR</td>
<td>If you have chosen an XR device as a source and destination (or XE device as destination), the logic works as an inline configuration. EPNM displays only <strong>Min Interval</strong> and <strong>Multiplier</strong> fields.</td>
</tr>
<tr>
<td></td>
<td>XR-XE</td>
<td></td>
</tr>
<tr>
<td>Bi-Directional</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Logic for BFD Template Usage</td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>-----------------------------</td>
<td></td>
</tr>
</tbody>
</table>
| XE-XE | If you have chosen XE devices as source and destination, the logic works as a BFD Template configuration.  
      | To create a BFD template:  
      | 1. EPNM displays **New BFD** checkbox selected by default.  
      | 2. Enter the name of BFD template.  
      | 3. Enter the **Min interval** range value between 4-1000.  
      | 4. Enter the **Multiplier** range value between 3-50.  
      | To re-use the existing BFD template:  
      | 1. Clear the **New BFD** checkbox.  
      | 2. From the **BFD Template** drop-down list, choose an existing BFD template.  
      | All existing BFD template names from **A-End** and **Z-End** devices are listed.  
      | 3. The **Min Interval** and **Multiplier** range values are displayed.  
      | 4. Click **Submit**. |
| XE-XR | If you have chosen XE devices as Source and XR device as destination, the logic works as a BFD Template configuration.  
      | To create a new BFD Template:  
      | 1. EPNM displays **New BFD** checkbox selected by default.  
      | 2. Enter the BFD template name.  
      | 3. Enter the **Min interval** range value between 4-1000.  
      | 4. Enter the **Multiplier** range value between 3-10.  
      | To re-use the existing BFD template:  
      | 1. Clear the **New BFD** checkbox.  
      | 2. From the **BFD Template** drop-down list, choose an existing BFD template.  
      | This will list all existing BFD template names from A-End device.  
      | 3. The **Min Interval** and **Multiplier** range values are displayed.  
      | 4. Click **Submit**. |
| XR-XR | If you have chosen an XR device as a Source and destination, the logic works as an inline configuration. EPNM displays only **Min interval** and **Multiplier** fields. |
If you have chosen an XR device as a source and XE device as a destination the logic works as a BFD Template configuration.

To create a new BFD template:
1. EPNM displays **New BFD** checkbox selected by default.
2. Enter the name of BFD template.
3. Enter the Min interval range value between 4-1000.
4. Enter the Multiplier range value between 3-10.

To re-use the existing template:
1. Clear the **New BFD** checkbox.
2. From the **BFD Template** drop-down list, choose an existing BFD template. All existing BFD template names from **Z-End** device are listed.
3. The **Min Interval** and **Multiplier** range values are displayed.
4. Click **Submit**.

---

**Field References for Path Constraint Details—MPLS TE Tunnel**

The following table lists and describes the attributes that define the path constraint details for creating a MPLS TE tunnel.

**Table 51: Path Constraint Details Section Reference—MPLS TE Tunnel**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Path Type</strong></td>
<td>Choose the required path for the TE tunnel. The values are <strong>Working</strong>, <strong>Protected</strong>, and <strong>Restore</strong>.</td>
</tr>
<tr>
<td><strong>Working Path, Protection Path, and Restore Path</strong></td>
<td>Based on the value you choose in the <strong>Path Type</strong> field, the respective field group is available.</td>
</tr>
<tr>
<td><strong>Type</strong></td>
<td>Choose the type of working path or protected path for the tunnel. Values are <strong>Dynamic</strong> and <strong>Explicit</strong>.</td>
</tr>
<tr>
<td><strong>New Path</strong></td>
<td>Check this check box to create a new explicit working, protected, or restore path for the tunnel. <strong>Note</strong> All the below fields are available only when you select <strong>Explicit</strong> in the <strong>Type</strong> field.</td>
</tr>
<tr>
<td><strong>Select Existing Path</strong></td>
<td>Choose an existing explicit working, protected, or restore path for the tunnel. <strong>Note</strong> This field is available only when you uncheck the <strong>New Path</strong> check box.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Choose path from WAE server</td>
<td>Check this check box to specify the WAE networks and paths. For more information about WAE configurations.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This field is available only when you check the <strong>New Path</strong> check box. You can check or uncheck this check box if you have chosen <strong>Dynamic</strong> type and Path type as <strong>Working</strong>. However, if you have chosen <strong>Explicit</strong> type and path type as <strong>Protected</strong>, it is recommended to check this box to avoid entering of explicit paths manually.</td>
</tr>
<tr>
<td>Select WAE Network</td>
<td>Click the down arrow to choose a WAE network from the dialog box.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This field is available only when you check the <strong>Choose path from WAE server</strong> check box.</td>
</tr>
<tr>
<td>Select the WAE Path</td>
<td>Click the down arrow to choose an explicit path.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This field is available only when you check the <strong>Choose path from WAE server</strong> check box.</td>
</tr>
<tr>
<td>Path Name</td>
<td>Enter a name for the explicit path that you are creating. In the <strong>Working Path</strong>, <strong>Protection Path</strong>, or <strong>Restore Path</strong> table, click the ‘+’ button to add a new row to the table, and then select a MPLS-enabled device, an explicit path controller as the interface for the device, and a path constraint type.</td>
</tr>
<tr>
<td></td>
<td>In the path table, you can select any MPLS-enabled device except the source and destinations devices. Cisco EPN Manager supports only strict path constraint type.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This field is available only when you check the <strong>New</strong> check box.</td>
</tr>
</tbody>
</table>

**Working Path LSP Attribute List, Protection Path LSP Attribute List, and Restore Path LSP Attribute List**

Based on the value you choose in the **Path Type** field, the respective field group is available.

The LSP attributes that you define here are associated with the path option you selected in the **Path Type** field and these attributes are applicable for source and destination devices.

**Note** The values that are defined for a specific path option will override the values specified at the interface tunnel level. For example, if you have defined the LSP attributes for the working path, these values will override the values that you defined in the **Tunnel Settings** section at the interface tunnel level, which is common for all the path options.

<table>
<thead>
<tr>
<th>New LSP Attribute List</th>
<th>Check this check box to create a new LSP attribute list for the selected path type.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Existing LSP Attribute List</td>
<td>Choose an existing LSP attribute list for the selected path type.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This field is available only when you uncheck the <strong>New LSP Attribute List</strong> check box.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>LSP Attribute List Name</td>
<td>Enter a name for the LSP attribute list that you are creating.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> All the below fields including this field are displayed as read-only when the <strong>New LSP Attribute List</strong> check box in unchecked.</td>
</tr>
<tr>
<td>LSP Affinity Bits</td>
<td>Enter the LSP affinity bit that determines the link attribute that the bidirectional TE tunnel will use when configuring the backup paths (working, protected, or restore).</td>
</tr>
<tr>
<td>LSP Affinity Mask</td>
<td>Enter the LSP affinity mask that determines which link attribute the router must check when configuring the backup paths.</td>
</tr>
<tr>
<td>LSP Setup Priority</td>
<td>Enter the setup priority assigned to an LSP for the chosen path type. Based on this priority, the LSP can determine which existing tunnels or LSPs with low priority can be blocked.</td>
</tr>
<tr>
<td></td>
<td>Valid values are from 0 to 7. A lower number indicates a higher priority. For example, an LSP with a setup priority of 0 can block any LSP with a setup priority between 1 and 7.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> LSP setup priority cannot be higher than the LSP hold priority.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> For Cisco IOS-XR devices, the <strong>LSP Setup Priority</strong> and <strong>LSP Hold Priority</strong> fields are not applicable.</td>
</tr>
<tr>
<td>LSP Hold Priority</td>
<td>Enter the hold priority assigned to an LSP for the chosen path type. Based on this priority, the LSP can determine whether it must be blocked by another signaling LSP with a high setup priority.</td>
</tr>
<tr>
<td></td>
<td>Valid values are from 0 to 7. A lower number indicates a higher priority. For example, an LSP with a hold priority of 0 cannot be blocked by another LSP.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> For Cisco IOS devices, if you do not specify an LSP hold priority, Cisco EPN Manager takes the value specified in the <strong>LSP Setup Priority</strong> field.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> For Cisco IOS-XR devices, the <strong>LSP Setup Priority</strong> and <strong>LSP Hold Priority</strong> fields are not applicable.</td>
</tr>
<tr>
<td>LSP Record Route</td>
<td>Check the check box to record the route used by the LSP.</td>
</tr>
</tbody>
</table>

**Create and Provision an MPLS Layer 3 Link**

To provision an MPLS Layer 3 Link:

**Before you begin**

For information about the prerequisites that must be met before you can provision an MPLS Layer 3 Link, see Prerequisites for Provisioning an MPLS TE Service, on page 548.
Step 1 From the left sidebar, choose Maps > Topology Maps > Network Topology

Step 2 Click Device Groups, and then select the location in which you want to create the MPLS Layer 3 Link.

Step 3 Close the Device Groups popup window.

Step 4 In the Network Topology window, click Circuits/VCs.

Step 5 Click the ‘+’ icon to open the Provisioning Wizard in a new pane to the right of the map.

Step 6 From the Technology drop-down list, choose MPLS TE. Cisco EPN Manager displays a list of relevant service types in the Service Type area.

Step 7 In the Service Type area, choose Layer 3 Link.

Step 8 If you have defined profiles to set the attributes of the different services, choose the required profile from the Select Profile drop-down list. See Create Circuit/VC Profiles, on page 572.

Step 9 Click Next to go to the Link Settings page.

Step 10 Enter a name and description for the layer 3 link.

Step 11 Choose the A End Device, A End Interface, Z End Device, and Z End Interface fields using one of the following ways:

- Click a link on the map to automatically populate the A End Device, A End Interface, Z End Device, and Z End Interface fields.
- Click a device node on the map to automatically populate the A End Device field. If the A End Device is connected to only one device, the Z End Device field is populated automatically. If the A End Device is connected to more than one device, you must choose the Z End Device manually.

Step 12 Enter the IP address and mask for the A End and Z End devices.

Step 13 Choose an L2 Discovery Protocol from the following options:

- NONE—No L2 discovery protocol to be enabled for the layer 3 link.
- CDP—Cisco Discovery Protocol to be enabled for the layer 3 link to facilitate communication between Cisco devices connected to the network.
- LLDP—Link Layer Discovery Protocol to be enabled for the layer 3 link to support non-Cisco devices and to allow for interoperability between other devices that supports the IEEE 802.1AB LLDP.
- ALL—Both, CDP and LLDP to be enabled for the layer 3 link.

Step 14 Choose the required routing protocol for the layer 3 link. The values are BGP, ISIS, and OSPF. For information about how to configure the routing protocols, see Configure Routing Protocols and Security, on page 378.

Step 15 (Optional) Enter a Link VLAN ID for the layer 3 link.

Step 16 (Optional) Check the Enable MPLS TE check box to support MPLS TE on the layer 3 link that you are provisioning.

Note This check box is available only when you choose OSPF or ISIS as your routing protocol.

Step 17 Click Next, and then enter the A End and Z End details. See Field References for A End Details and Z End Details in MPLS Layer 3 Link, on page 561 for descriptions of the fields and attributes.

Step 18 In the Deployment Action field, specify what you want to do when the MPLS layer 3 link creation process is completed. You can either request a preview of the configurations that will be deployed to the relevant devices before the actual deployment or you can deploy the configurations immediately upon completion.

Step 19 Click Submit. If you chose to see a preview of the CLI that will be deployed to the devices, it will be displayed now and you can click Edit Attributes to change the attributes. Otherwise, the configurations will be deployed to the devices immediately.
The service should be added to the list in the **Circuits/VCs** tab in the Network **Topology** window. To check the provisioning state, click the icon next to the circuit/VC name to see the Circuit/VC 360 view.

### Field References for A End Details and Z End Details in MPLS Layer 3 Link

The following table lists and describes the attributes that define the MPLS Layer 3 Link.

**Table 52: Field References for A End and Z End Details—MPLS Layer 3 Link**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Available when the routing protocol is:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Same as A End</td>
<td>Check this check box if you want to have the same OSPF and MPLS-TE configurations for both A end and Z end devices. <strong>Note</strong> This check box is available only in the Z End Details page of the Provisioning Wizard.</td>
<td>BGP, ISIS, and OSPF</td>
</tr>
<tr>
<td>BGP AS Number</td>
<td>Choose the unique BGP autonomous system number assigned for your network.</td>
<td>BGP</td>
</tr>
<tr>
<td>Route Policy</td>
<td>Choose the routing policy to control which routes the BGP stores in and retrieves from the routing table.</td>
<td>BGP</td>
</tr>
<tr>
<td>Route Reflector Client</td>
<td>Check this check box to configure the BGP neighbor as the route reflector client for the local route reflector to advertise the available routes.</td>
<td>BGP</td>
</tr>
<tr>
<td>Use AIGP</td>
<td>Check this check box to use the Accumulated Interior Gateway Protocol (AIGP) metric attribute for the layer 3 link. The AIGP is the BGP attribute that carries the accumulated end-to-end metrics for the paths in the network.</td>
<td>BGP</td>
</tr>
<tr>
<td>Update Source</td>
<td>Choose the required source interface. <strong>Note</strong> This field is available only when the Use AIGP check box is unchecked.</td>
<td>BGP</td>
</tr>
<tr>
<td>ISIS Process ID</td>
<td>Choose an ISIS routing process ID that is available to both A end and Z end devices. For information about how to configure an ISIS process, see <strong>Configure an IS-IS, on page 381.</strong></td>
<td>ISIS</td>
</tr>
<tr>
<td>Network</td>
<td>The network ID is automatically populated based on the ISIS process ID selected.</td>
<td>ISIS</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Available when the routing protocol is:</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>----------------------------------------</td>
</tr>
<tr>
<td>Circuit Type</td>
<td>Choose the type of adjacency required for the layer 3 link from the following options:</td>
<td>ISIS</td>
</tr>
<tr>
<td></td>
<td>• NONE—No adjacency is established.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Level-1—Establishes a level 1 adjacency if there is at least one area address in common between the selected device and its neighbors.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Level-2-only—Establishes a level 2 adjacency on the circuit. If the neighboring device is a level 1 only device, no adjacency will be established.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Level-1-2—Establishes a level 1 and 2 adjacency if the neighbor is also configured as a level 1-2 device and there is at least one area in common. If there is no area in common, a level 2 adjacency is established.</td>
<td></td>
</tr>
<tr>
<td>Level 1 Metric</td>
<td>Enter the metric that must be used in the SPF calculation for Level 1 (intra-area) routing.</td>
<td>ISIS</td>
</tr>
<tr>
<td></td>
<td>Note This field is available only when you choose the Circuit Type as Level-1 or Level-1-2.</td>
<td></td>
</tr>
<tr>
<td>Level 2 Metric</td>
<td>Enter the metric that must be used in the SPF calculation for Level 2 (inter-area) routing.</td>
<td>ISIS</td>
</tr>
<tr>
<td></td>
<td>Note This field is available only when you choose the Circuit Type as Level-2 or Level-1-2.</td>
<td></td>
</tr>
<tr>
<td>OSPF Process ID</td>
<td>Choose an OSPF routing process ID. For information about how to configure an OSPF process, see Configure OSPF, on page 383.</td>
<td>OSPF</td>
</tr>
<tr>
<td></td>
<td>Note You cannot modify the OSPF routing process for the Z end device.</td>
<td></td>
</tr>
<tr>
<td>OSPF Area</td>
<td>Enter the area in which you want to deploy the OSPF routing process.</td>
<td>OSPF</td>
</tr>
<tr>
<td>Metric</td>
<td>Enter the routing metric used by the OSPF routing process.</td>
<td>OSPF</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Available when the routing protocol is:</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-----------------------------------------</td>
</tr>
<tr>
<td>BFD Template</td>
<td>Choose a BFD template for the layer 3 link. A BFD template defines the set of configurable parameters used by a BFD session. These include the transmit and receive timers used for BFD control and echo packets, the transmit timer interval used when the session is providing a CV function, the multiplier value, and the echo-receive interval.</td>
<td>BGP, ISIS, and OSPF</td>
</tr>
<tr>
<td>BFD Min Interval</td>
<td>Enter the minimum control packet interval for BFD sessions for the corresponding BFD configuration scope.</td>
<td>BGP, ISIS, and OSPF</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This field is available only if you have not chosen the BFD Template.</td>
<td></td>
</tr>
<tr>
<td>BFD Multiplier</td>
<td>Enter the BFD multiplier. This value along with the BFD minimum interval is used to determine the intervals and failure detection times for both control and echo packets in asynchronous mode on bundle member links.</td>
<td>BGP, ISIS, and OSPF</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This field is available only if you have not chosen the BFD Template.</td>
<td></td>
</tr>
<tr>
<td>BFD Fast Detect</td>
<td>Check this check box to quickly detect failures in the path between adjacent forwarding engines.</td>
<td>BGP, ISIS and OSPF</td>
</tr>
<tr>
<td>Authentication Mode</td>
<td>Choose the required authentication mode used to send and receive ISIS packets.</td>
<td>ISIS</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> The authentication fields are available only when you select Cisco IOS and Cisco IOS XE devices.</td>
<td></td>
</tr>
<tr>
<td>Authentication Key Chain</td>
<td>Choose the authentication key chain. This enables authentication for routing protocols and identifies a group of authentication keys.</td>
<td>ISIS</td>
</tr>
<tr>
<td>Authentication for Send Only</td>
<td>Check this check box to perform authentication only for ISIS packets that are being sent.</td>
<td>ISIS</td>
</tr>
<tr>
<td>Password Type</td>
<td>Choose the password type as <strong>Encrypted</strong> or <strong>Plain Text</strong>.</td>
<td>BGP</td>
</tr>
<tr>
<td>Password</td>
<td>Type the desired password. Password is required to establish connection between two peers.</td>
<td>BGP</td>
</tr>
</tbody>
</table>

**MPLS-TE**
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Available when the routing protocol is:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Loopback Interface</td>
<td>Choose a loopback interface address for the layer 3 link. For information about how to configure a loopback interface, see Configure Loopback Interfaces.</td>
<td>ISIS and OSPF</td>
</tr>
<tr>
<td>TE Metric</td>
<td>Enter the MPLS TE tunnel metric with mode absolute.</td>
<td>ISIS and OSPF</td>
</tr>
<tr>
<td>TE Attributes</td>
<td>Enter the MPLS TE Link attribute to be compared with a tunnel's affinity bits during path selection.</td>
<td>ISIS and OSPF</td>
</tr>
<tr>
<td>Is Percentage</td>
<td>Check this check box to assign the bandwidth in percentage for the layer 3 link.</td>
<td>ISIS and OSPF</td>
</tr>
<tr>
<td>Global Bandwidth</td>
<td>Enter the regular TE tunnel bandwidth that will be reserved for the layer 3 link for CBR. For example, if you want to assign 10% as the global bandwidth for the layer 3 link, select the Is Percentage check box and enter the value 10 in the Global Bandwidth field. Whereas, if you want to assign 50 Kbps as the global bandwidth, uncheck the Is Percentage check box, choose Kbps from the Bandwidth Unit drop-down list, and then enter the value 50 in the Global Bandwidth field.</td>
<td>ISIS and OSPF</td>
</tr>
<tr>
<td>Subpool Bandwidth</td>
<td>Enter the subpool bandwidth that is reserved from the global pool bandwidth. For example, if you want to assign 10% as the subpool bandwidth for the layer 3 link, select the Is Percentage check box and enter the value 10 in the Subpool Bandwidth field. Whereas, if you want to assign 50 Kbps as the subpool bandwidth, uncheck the Is Percentage check box, choose Kbps from the Bandwidth Unit drop-down list, and then enter the value 50 in the Subpool Bandwidth field.</td>
<td>ISIS and OSPF</td>
</tr>
<tr>
<td>QoS</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ingress Policy</td>
<td>Select the ingress QoS policies that are configured on the A end and Z end devices.</td>
<td>BGP, ISIS, and OSPF</td>
</tr>
<tr>
<td>Egress Policy</td>
<td>Select the egress QoS policies that are configured on the A end and Z end devices.</td>
<td>BGP, ISIS, and OSPF</td>
</tr>
<tr>
<td>Additional Settings</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Enable MPLS</td>
<td>Check this check box to support MPLS on the layer 3 link that you are provisioning.</td>
<td>BGP</td>
</tr>
</tbody>
</table>
Provision Serial Services

- Prerequisites for Serial Circuits/VCs Provisioning, on page 565
- Create and Provision a New Serial Circuit/VC (RS232, RS422 and RS485), on page 565
- Create and Provision a New Serial Circuit/VC (Raw Socket), on page 569

Prerequisites for Serial Circuits/VCs Provisioning

Following are the prerequisites to provision a serial circuit/VC:

- Communication between devices must be set up before you can provision a serial circuit/VC.
- Inventory collection status for the devices on which the Serial circuits/VCs will be provisioned must be "Completed". To check this, go to Inventory > Device Management > Network Devices, and look at the status in the Last Inventory Collection Status column.
- Optionally, customers must be created in the system so that you can associate a circuit/VC to a customer during the circuit/VC creation and provisioning process. From the left sidebar, choose Inventory > Other > Customers to create and manage customers.

Create and Provision a New Serial Circuit/VC (RS232, RS422 and RS485)

To create a new serial circuit/VC:

**Before you begin**

For information about the prerequisites that must be met before you can provision a serial circuit/VC, see Prerequisites for Serial Circuits/VCs Provisioning, on page 565.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Available when the routing protocol is:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable SyncE</td>
<td>Check this check box to enable Synchronous Ethernet at the interface level for the layer 3 link.</td>
<td>BGP, ISIS, and OSPF</td>
</tr>
</tbody>
</table>

Step 1  
From the left sidebar, choose Maps > Topology Maps > Network Topology. The network topology window opens.

Step 2  
From the toolbar, click Device Groups and then select the group of devices you want to show on the map.

Step 3  
Click the Circuits/VCs tab.

Step 4  
From the Circuits/VCs pane toolbar, click the + (Create) icon. The Provisioning Wizard opens in a new pane to the right of the map.

Step 5  
Select Serial in the Technology drop-down list.

Step 6  
In the Service Type list, select the type of serial service you want to create. For information about the serial service types that Cisco EPN Manager supports, see Supported Serial Services, on page 472.
Step 7 If you have defined profiles to set the attributes of the different services, select the required profile from the Select Profile drop-down list. See Create Circuit/VC Profiles, on page 572.

Step 8 Click Next to go to the Customer Service Details page.

Step 9 Select the customer for whom the circuit/VC is being created. If there are no customers in the list, go to Inventory > Other > Customers to create the customer in the system, and then restart the Provisioning Wizard.

Step 10 Check the Activate check box to specify whether the service must be in active state. The Active state enables traffic to pass through the circuit and automatically sets the service state of all the associated endpoints to True.

Step 11 Enter the service name and description.

Step 12 In the Deployment Action field, specify what you want to do when the circuit/VC creation process is completed. You can either request a preview of the configurations that will be deployed to the relevant devices before the actual deployment or you can deploy the configurations immediately upon completion.

Step 13 Click Next to go to the page in which you configure the endpoints. See Serial Service Details Reference, on page 566.

Step 14 If one of the endpoints is an interface on a device that is not managed by Cisco EPN Manager, provide information for the unmanaged device. See Provision a Circuit/VC with an Unmanaged Endpoint, on page 575.

Step 15 Click Next to go to the Line Settings and Pseudowire Settings page. See Serial Service Details Reference, on page 566.

Step 16 Optional. If you want to append a template with additional CLI commands that will be configured on the devices participating in the circuit/VC, do so in the Template Details page. See Extend a Circuit/VC Using Templates, on page 575 for more information.

Step 17 When you have provided all the required information for the circuit/VC, click Submit. If you chose to see a preview of the CLI that will be deployed to the devices, it will be displayed now and you can click Edit Attributes to change the attributes. Otherwise, the configurations will be deployed to the devices immediately.

The circuit/VC should be added to the list in the Circuits/VCs pane in the Network Topology window.

Serial Service Details Reference

The following table lists and describes the attributes that define the serial service type.

Table 53: Circuit Section Reference—Serial Service Type

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>A Endpoint and Z Endpoint Configurations</strong></td>
<td></td>
</tr>
<tr>
<td>Media Type</td>
<td>The media type selected for the serial interface service.</td>
</tr>
<tr>
<td>Device Name</td>
<td>Name of the source and destination devices in the serial service.</td>
</tr>
<tr>
<td>Port Name and Description</td>
<td>Name and description of the interface on the source and destination devices in the serial service.</td>
</tr>
<tr>
<td><strong>QOS</strong></td>
<td></td>
</tr>
<tr>
<td>The list of profiles available for selection includes policy maps that were configured on the device and discovered by the system, as well as user-defined QoS profiles. Refer to Create QoS Profiles, on page 573 for information on how to create QoS profiles.</td>
<td></td>
</tr>
<tr>
<td>Ingress QoS Profile</td>
<td>Select the ingress QoS policies that are configured on the A end and Z end devices.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Egress QoS Profile</td>
<td>Select the egress QoS policies that are configured on the A end and Z end devices.</td>
</tr>
</tbody>
</table>

**Unmanaged Device Details**

<table>
<thead>
<tr>
<th>Note</th>
<th>The below fields are available only for Z Endpoint Configurations.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unmanaged Device</td>
<td>Check this check box to include a device that is not managed by Cisco EPN Manager and create partial service.</td>
</tr>
<tr>
<td>New Device</td>
<td>Check this check box to create a new unmanaged device.</td>
</tr>
<tr>
<td>Media Type</td>
<td>Choose either RS232 or RS422 as media type for an existing RS232 or RS422 service to create point-to-point RS232 to RS422 service. For example, at the A-end if there is an existing media type RS232, you can choose either RS232 or RS422 as media type at the Z-end for the point-to-point service configuration.</td>
</tr>
<tr>
<td>Note</td>
<td>You cannot modify a media type after it is created.</td>
</tr>
<tr>
<td>Device Name</td>
<td>Enter a unique name for the new unmanaged device that you want to create.</td>
</tr>
<tr>
<td>Note</td>
<td>This field is available as a drop-down list if you have unchecked the <strong>New Device</strong> check box. You can choose an unmanaged device as your Z endpoint.</td>
</tr>
<tr>
<td>Device IP</td>
<td>Enter the IP address of the new unmanaged device that you want to create.</td>
</tr>
<tr>
<td>Note</td>
<td>This field is available only when the <strong>New Device</strong> check box is checked. If the <strong>New Device</strong> check box is unchecked, the IP address of the unmanaged device that you chose in the <strong>Device</strong> drop-down list is populated in this field.</td>
</tr>
<tr>
<td>LDP IP</td>
<td>Enter a valid LDP IP for the unmanaged device.</td>
</tr>
<tr>
<td>VC ID</td>
<td>Enter a unique Virtual Circuit (VC) ID for the unmanaged device.</td>
</tr>
</tbody>
</table>

**Line Settings**

<table>
<thead>
<tr>
<th>Speed</th>
<th>The speed of the serial link in kilo bits per second.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Bits</td>
<td>The measurement of actual data per packet that is transmitted through the serial circuit/VC. The values are 5, 6, 7, and 8.</td>
</tr>
<tr>
<td>Stop Bits</td>
<td>Indicates the end of communication for a single packet. The values are 1, 1.5, and 2 bits.</td>
</tr>
<tr>
<td>Note</td>
<td>Since the data is clocked across the lines and each device has its own clock, it is possible for the two devices to become slightly out of sync. Therefore, the stop bits not only indicate the end of transmission but also provides the network with some lenience to synchronize the different clocks. The more bits that are used for stop bits, the greater the lenience in synchronizing the different clocks, but slower the data transmission rate.</td>
</tr>
</tbody>
</table>
### Attribute Description

**Parity**

Used to check errors in serial communication. The values are:

- **None**—No parity defined for the circuit/VC.
- **Even**—The serial port will set the parity bit (the last bit after the data bits) to a value to ensure that the transmission has an even number of logic high bits. For example, if the data was 011, then for even parity, the parity bit would be 0 to keep the number of logic high bits even.
- **Odd**—The serial port will set the parity bit (the last bit after the data bits) to a value to ensure that the transmission has an odd number of logic high bits. For example, if the data was 011, then for odd parity, the parity bit would be 1, resulting in 3 logic high bits.
- **Mark**—Sets the parity bit high. This allows the receiving device to know the state of a bit which enables the device to determine if noise is corrupting the data or if the transmitting and receiving devices' clocks are out of sync.
- **Space**—Sets the parity bit low. This allows the receiving device to know the state of a bit which enables the device to determine if noise is corrupting the data or if the transmitting and receiving devices' clocks are out of sync.

**Duplex Mode**

Choose the required duplex mode for the serial service from the following options:

- **HalfDuplex**—Supports communication in both directions between the endpoints, but not simultaneously. The transmission of data happens at one direction at a time.
- **FullDuplex**—Supports simultaneous communication in both directions between the endpoints assuming that both endpoints support full duplex. If one side does not support full duplex, the port will be brought down.

**Note**

This field is available only for RS485 and RS422 service types. You can edit RS485 and RS422 service type details. This is because you can select Duplex mode between Half and Full for RS485 and RS422. However, you cannot edit RS232 service type details because for RS232 you can select only FULL Duplex mode.

### Pseudowire Settings

<table>
<thead>
<tr>
<th>Preferred Path Type</th>
<th>Choose the Preferred Path Type as Bidirectional or Unidirectional.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preferred Path</td>
<td>Select the MPLS bidirectional TE tunnel through which you want the serial service to pass through.</td>
</tr>
</tbody>
</table>

**Note**

This field is available only if you selected **Bidirectional** as the Preferred Path Type.

<table>
<thead>
<tr>
<th>Preferred Path (A-Z)</th>
<th>Select the required unidirectional tunnel through which you want the serial service to travel from the A endpoint to the Z endpoint.</th>
</tr>
</thead>
</table>

**Note**

This field is available only if you selected **Unidirectional** as the Preferred Path Type.
Apply the following configuration:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
</table>
| Preferred Path (Z-A)     | Select the required unidirectional tunnel through which you want the serial service to travel from the Z endpoint to the A endpoint.  
                        | **Note** This field is available only if you selected **Unidirectional** as the Preferred Path Type. |
| Send Control Word        | Check this check box if you want a control word to be used to identify the pseudowire payload on both sides of the connection. |

**Create and Provision a New Serial Circuit/VC (Raw Socket)**

To create a new serial circuit/VC with Raw Socket type:

**Before you begin**

For information about the prerequisites that must be met before you can provision a Raw Socket circuit/VC, see **Prerequisites for Serial Circuits/VCs Provisioning**, on page 565.

**Step 1**

From the left sidebar, choose Maps > Topology Maps > Network Topology.

The network topology window opens.

**Step 2**

From the toolbar, click Device Groups and then select the group of devices you want to show on the map.

**Step 3**

Click the Circuits/VCs tab.

**Step 4**

From the Circuits/VCs pane toolbar, click the + (Create) icon.

The Provisioning Wizard opens in a new pane to the right of the map.

**Step 5**

Select Serial in the Technology drop-down list.

**Step 6**

In the Service Type list, select Raw Socket. For information about the Raw Socket circuits/VCs, see **Supported Serial Services**, on page 472.

**Step 7**

If you have defined profiles to set the attributes of the different services, select the required profile from the Select Profile drop-down list. See **Create Circuit/VC Profiles**, on page 572.

**Step 8**

Click Next to go to the Customer Service Details page.

**Step 9**

Select the customer for whom the circuit/VC is being created. If there are no customers in the list, go to Inventory > Other > Customer to create the customer in the system, and then restart the Provisioning Wizard.

**Step 10**

Enter the service name and description.

**Step 11**

In the Deployment Action field, specify what you want to do when the circuit/VC creation process is completed. You can either request a preview of the configurations that will be deployed to the relevant devices before the actual deployment or you can deploy the configurations immediately upon completion.

**Step 12**

Click Next to go to the Server Side Configuration page. See **Raw Socket Service Details Reference**, on page 570 for descriptions of the fields and attributes.

**Step 13**

Click Next to go to the Client Side Configuration page. Click the ‘+’ icon in the Raw Socket Client table to add a new row for client side configuration. See **Raw Socket Service Details Reference**, on page 570 for descriptions of the fields and attributes.
Step 14 Optional. If you want to append a template with additional CLI commands that will be configured on the devices participating in the circuit/VC, do so in the Template Details page. See Extend a Circuit/VC Using Templates, on page 575 for more information.

Step 15 When you have provided all the required information for the circuit/VC, click **Submit**. If you chose to see a preview of the CLI that will be deployed to the devices, it will be displayed now and you can click **Edit Attributes** to change the attributes. Otherwise, the configurations will be deployed to the devices immediately.

The circuit/VC should be added to the list in the Circuits/VCs pane in the Network Topology window. From the Services tab, you can click the i icon that is present next to the newly created serial interface service and view the recently created endpoints on the server with both end points (that is server and its associated clients) in the Circuit/VCs 360° dialog box. Also, click the i icon next to the **Provisioning State** and view the configurations that are being pushed on to each end point.

### Raw Socket Service Details Reference

The following table lists and describes the attributes that define the Raw Socket service type.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Server Settings and Client Settings</strong></td>
<td></td>
</tr>
<tr>
<td>Media Type</td>
<td>From the Media Type drop-down list, choose one of the following to configure a multipoint RS422 or RS4232 service, as part of cross circuit services.</td>
</tr>
<tr>
<td>• RS232—If you choose RS232 option as media type, the SyncRS232 check box is available for Sync operation along with other configuration settings for serial interfaces.</td>
<td></td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>When you create a service (for example, Serial Raw Socket) with RS232, at the time of configuring the supported services both the end should have either RS232 or RS422, so that the corresponding server and its associated clients can be configured with only one media type at a time. You can configure these configuration settings on the Device and from the EPNM as well.</td>
</tr>
<tr>
<td>• RS422—Allows you to configure client, server and Packetization settings for RS 422 multipoint service.</td>
<td></td>
</tr>
<tr>
<td>Sync RS232</td>
<td>Check this check box to enable the synchronous mode of RS232 for the service.</td>
</tr>
<tr>
<td>Device Name</td>
<td>Name of the devices that act as a server and client in the Raw Socket service.</td>
</tr>
<tr>
<td>Port Name</td>
<td>Name of the interface on the server and client devices in the Raw Socket service.</td>
</tr>
<tr>
<td>Server Address and Server Port</td>
<td>The IP address and the port number of the server.</td>
</tr>
<tr>
<td>Client Address and Client Port</td>
<td>The IP address and the port number of the client.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Connection Idle Timeout</td>
<td>TCP session timeout setting for the Raw Socket service. If no data is transferred between the client and server over this interval, then the TCP session closes. The client then automatically attempts to reestablish the TCP session with the server.</td>
</tr>
<tr>
<td>VRF</td>
<td>Virtual Routing and Forwarding (VRF) interface through which the server and client are connected to transport the data.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Ensure that the VRF definition is common for both server and client.</td>
</tr>
<tr>
<td>Speed</td>
<td>The speed of the serial link in kilo bits per second. This line setting is optional for Sync service settings.</td>
</tr>
<tr>
<td>Data Bits</td>
<td>The measurement of actual data per packet that is transmitted through the serial circuit/VC. The values are 5, 6, 7, and 8. This line setting is optional for Sync service settings.</td>
</tr>
<tr>
<td>Stop Bits</td>
<td>Indicates the end of communication for a single packet. The values are 1, 1.5, and 2 bits. This line setting is optional for Sync service settings.</td>
</tr>
<tr>
<td>Parity</td>
<td>Checks errors in serial communication. This line setting is optional for Sync service settings.</td>
</tr>
<tr>
<td>Duplex Mode</td>
<td>The duplex mode for the selected serial service. This line setting is optional for Sync service settings.</td>
</tr>
<tr>
<td>DTR</td>
<td>Choose one of the following option:</td>
</tr>
<tr>
<td></td>
<td>• Used—Allows you to configure Data Terminal Ready (DTR) equipment from the customer end if there is no connected cables.</td>
</tr>
<tr>
<td></td>
<td>• Not Used—Allows you not to configure Data Terminal Ready (DTR) equipment from the customer end if there is no connected cables</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This option is available only if the SyncRS232 check box is selected.</td>
</tr>
<tr>
<td>Clock Rate</td>
<td>Choose the desired clock rate in bits per second (bps) for the service. The valid values are 48000 and 64000.</td>
</tr>
<tr>
<td>NRZI Encoding</td>
<td>Check this check box to enable the nonreturn-to-zero inverted (NRZI) encoding mechanism for the service.</td>
</tr>
<tr>
<td>Control Signal Transport</td>
<td>Check this check box to specify if the hardware control signals need to be sent to the remote PE.</td>
</tr>
<tr>
<td>Frequency</td>
<td>Enter the required frequency. The valid value is between 50 and 200.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> This field is available only when you check the Control Signal Transport check box.</td>
</tr>
</tbody>
</table>
Create Circuit/VC Profiles

Profiles contain sets of attributes specific to the different types of circuits/VCs. Once a profile is created, it will be available to all users for selection during circuit/VC creation. When a profile is selected, the Provisioning Wizard is populated with the profile attributes. Users only have to define the endpoints of the service and, if necessary, make small changes before provisioning the circuit/VC.

The types of profiles you can create mirror the types of circuits/VCs that can be provisioned.

Each profile is given a unique name, so you can create multiple profiles per circuit/VC type, depending on your needs.

To create a profile:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frame Pattern</td>
<td>Choose one of the required frame format from the following options that will be used for internal signal transport:</td>
</tr>
<tr>
<td></td>
<td>• BCN—Beacon</td>
</tr>
<tr>
<td></td>
<td>• CFGR—Configure for test</td>
</tr>
<tr>
<td></td>
<td>• NR0—Nonreserved 0</td>
</tr>
<tr>
<td></td>
<td>• NR1—Nonreserved 1</td>
</tr>
<tr>
<td></td>
<td>• NR2—Nonreserved 2</td>
</tr>
<tr>
<td></td>
<td>• NR3—Nonreserved 3</td>
</tr>
<tr>
<td>Connection Topology</td>
<td>The connection topology, either point-to-point or point-to-multipoint, for the service is displayed.</td>
</tr>
<tr>
<td>Packetization Settings</td>
<td></td>
</tr>
<tr>
<td>Packet Length</td>
<td>The packet length that triggers the routing device (either a server or a client) to transmit the serial data to the peer. When the device collects the specified bytes of data in its buffer, it packetizes the accumulated data and forwards it to the Raw Socket peer.</td>
</tr>
<tr>
<td>Fragment Off</td>
<td>Check this check box to disable the frame relay fragmentation for this service.</td>
</tr>
<tr>
<td>Packet Timer</td>
<td>Specifies the amount of time in milliseconds, the device (either server or client) waits to receive the next character in a stream. If a character is not received by the time the packet timer expires, the data the device has accumulated in its buffer is packetized and forwarded to the Raw Socket peer.</td>
</tr>
<tr>
<td>Special Char</td>
<td>A character that triggers the device (either server or client) to packetize the data accumulated in its buffer and send it to the Raw Socket peer. When the specified special character is received, the device packetizes the accumulated data and sends it to the Raw Socket peer.</td>
</tr>
</tbody>
</table>
Step 1 Choose **Inventory > Other > Profiles** in the left navigation pane. The **Profiles** window opens, showing a table of existing profiles (if any). You can select a profile in the table to edit or delete it.

Step 2 Click **Create Profile**.

Step 3 In the Create Profile wizard, provide a unique name for the profile and enter a description.

Step 4 Select **Carrier Ethernet** or **Optical** or **L3VPN** from the Technology list. The relevant service types for the selected technology are displayed.

Step 5 Select the required service type.

For L3VPN services, choose **Unicast** to create a profile that helps pre-populate values for most L3VPN service creation fields. And choose **IPSLA Operations** to create a profile with IPSLA specific options for the L3VPN service.

Step 6 Click **Next** to go to the attribute definition pages and define the attributes for the selected service type. The attributes in the profile are the same as the attributes in the Provisioning Wizard and they are described in the reference sections, as follows:

Information on Ethernet VCs attributes is provided in these topics:

- For attributes relating to the service itself, see **Service Details Reference**, on page 487
- For attributes specific to the UNI, see **New UNI Details Reference**, on page 488
- For attributes relating to the UNI as it operates within the service, see **UNI Service Details Reference**, on page 489.
- For QoS Profile attributes, see **Create QoS Profiles**, on page 573
- For UNI attributes, see **Configure a Device and Interface To Be a UNI**, on page 492
- For ENNI attributes, see **Configure a Device and Interface To Be an ENNI**, on page 492

Information on OCH and OTN attributes is provided in **Circuit Section Reference for OCH Circuit Types**, on page 500 and **Circuit Section Reference for OTN Circuit Types**, on page 511.

Information on L3VPN attributes is provided in **Create and Provision a New L3VPN Service**, on page 521 and **View L3VPN Service Details**, on page 534.

Step 7 Click **Create Profile** when you have defined the attributes. The profile will be added to the table in the Profiles window.

---

## Create QoS Profiles

You can create a library of QoS profiles that will be available for selection when creating and provisioning EVCs. The selected QoS profile determines the bandwidth profile for traffic of various classes on the UNI or the EVC level, and defines how the classified traffic is treated.

The QoS profile can define up to four levels of bandwidth profile: Extra High, High, Medium, and Low. For each bandwidth profile, you specify the matching criteria that must be met for the traffic to be classified as belonging to that bandwidth profile.

To create a QoS profile:

### Step 1
Follow the instructions in **Create and Provision a New Carrier Ethernet EVC**, on page 483 to access the Provisioning Wizard.

### Step 2
Select **Carrier Ethernet** from the Technology drop-down list.

### Step 3
Select **QoS Profile** from the Service Types drop-down list.
Step 4  Click **Next** to go to the QoS Profile definition page.

Step 5  Provide the QoS profile with a unique name and description.

Step 6  Check the required check boxes to define where the QoS profile will be available for selection (i.e., it will appear in the drop-down list of QoS profiles):

- Applicable for Interfaces—The QoS profile will be available for selection when provisioning UNIs or ENNIs.
- Applicable for Virtual Services—The QoS profile will be available for selection as a UNI service attribute when creating VLAN-based services, such as EVPL, EV-LAN, and so on.
- Applicable for Private Services—The QoS profile will only be available for selection as a UNI service attribute when creating private VCs, such as EPL, EP-LAN, and so on

Step 7  In the Classification field, indicate what method will be used to identify and classify the traffic, then enter the relevant values in the Match Criteria field for the required bandwidth profiles:

- DSCP—Differentiated service code point (DSCP) value will be used to classify the traffic. Valid values are from 0 to 63. Up to 8 comma-separated values can be entered.
- COS (Class of service)—Also known as PCP—IEEE 802.1Q bits in the header of the layer 2 frame from hosts supporting FCoE and other trunked devices. Valid values are from 0 to 7. Multiple comma-separated values or a range of values indicated by a hyphen (e.g., 0-2), can be entered.

Step 8  Select one or more classes of service that will apply to the service.

Step 9  For each class of service you selected, define a bandwidth profile to specify the match criteria and how the matching traffic will be handled. For each bandwidth profile, enter the match criteria, as described in **Step 7** above.

Step 10  For each bandwidth profile, create rules to specify how the matching traffic will be handled. You can create a separate rule for ingress and egress traffic or you can create a rule for traffic moving in both directions. In each rule, you can specify the following:

- Committed Information Rate (CIR)—The long-term average transmission rate, specified in bits per second (bps).
- Committed Burst Size (CBS)—How large traffic bursts can be (in bytes) before some traffic exceeds the CIR.
- Excess Information Rate (EIR)—The average rate up to which packets are admitted. The EIR is greater than or equal to the CIR. Packets that exceed the CIR are typically discarded.
- Excess Burst Size (EBS)—How large traffic bursts can be (in bytes) before traffic exceeds the EIR.
- Color Mode—Specify whether traffic coloring will be applied or not.

Step 11  Click **Submit** when you have defined all the required bandwidth profiles. Your QoS profile will be created and will be available for selection when you are creating VCs.

---

**Create Customers**

Customers must be created in the system so that they are available for selection during the circuit/VC provisioning process.

To create a customer:

---

**Step 1**  From the left sidebar, choose **Inventory > Other > Customers**.

**Step 2**  Click **Create Customer**.

**Step 3**  Enter the name of the customer and a description (optional).
Provision a Circuit/VC with an Unmanaged Endpoint

You can create and provision a circuit/VC even if one or more of the endpoints is a device that is not managed by Cisco EPN Manager. The Provisioning Wizard allows you to identify an endpoint device as "unmanaged" and to provide information about that device so that the system can create the circuit/VC. Once you identify the unmanaged device, it will be available in the system in the Unmanaged Devices group and can be used for other services.

Step 1
Start the circuit/VC creation process for the required technology, as described in Provision Circuits/VCs, on page 475.

Step 2
For a point-to-point EVC and a CEM service:

a) When defining the Z endpoint, select the Unmanaged Device check box. The Unmanaged Device Details panel opens.

b) If the unmanaged device has already been identified in the system, deselect the New Device check box and select the required device from the list. If you are identifying a new unmanaged device, provide the device name, IP address, and LDP IP. The LDP IP is used as the neighbor address of the pseudowire on the managed device.

Step 3
For a point-to multipoint or multipoint-to-multipoint EVC: In the Unmanaged UNI page, click the Plus icon in the table to add a row and then define the Unmanaged Device Details and Service Endpoint details for the selected row.

Step 4
Complete the circuit/VC creation and provisioning process for the required technology, as described in Provision Circuits/VCs, on page 475.

Extend a Circuit/VC Using Templates

When you create and provision a circuit/VC, Cisco EPN Manager configures a set of CLI commands on the participating devices. If you need to configure additional commands on the same devices, you can create a template containing these commands and you can include it during the circuit/VC creation process. This effectively extends the circuit/VC beyond what is configured by Cisco EPN Manager. This functionality is available in the provisioning wizard but it is dependent on the template being created prior to creating or modifying the circuit/VC.

Extending a circuit/VC using CLI templates involves the following steps:

1. Create the CLI template using blank templates or existing templates. See Create a New CLI Configuration Template Using a Blank Template, on page 410 and Create a New CLI Configuration Template Using An Existing Template, on page 411.

2. Create/modify a circuit/VC and append the CLI template. See Provision Circuits/VCs, on page 475.

Step 1
Create the CLI template:

a) In the left sidebar, choose Configuration > Templates > Features & Technologies.

b) In the Templates panel, choose CLI Templates > CLI.
Step 2

Create/modify a service that includes the template you created (or a different template if relevant):

a) From the left sidebar, choose Maps > Topology Maps > Network Topology.
   
   The network topology window opens.

b) Click the Circuits/VCs tab.

c) From the Circuits/VCs pane toolbar, either click the + (Create) icon or select a circuit and then click the pencil (Modify) icon.

   The Provisioning Wizard opens in a new pane to the right of the map.

d) Start creating or modifying the required circuit or VC. See Provision Circuits/VCs, on page 475 and Modify a Circuit/VC, on page 606.

e) In the Service Template page, use the Pre-Configuration section if you want the template to be a prefix to the service configuration or use the Post-Configuration section if you want the template to be a suffix to the service configuration.

f) In the Template drop-down menu, select the required CLI template.

   The same CLI template cannot be selected for both pre-configuration and post-configuration options.

g) In the Template Usage drop-down menu, select an option to indicate under what circumstances the CLI template should be configured on the devices. For example, if you select Service Create Only, the template CLI will only be configured on the devices when the service is created. It will not be configured when the service is modified.

h) Enter values for the template parameters. The parameters shown here depend on the variables that were defined for the template.

i) Click Submit.

   By default, the selected CLI templates are associated with all devices that take part in the service. You cannot specifically choose the devices to be associated with the CLI templates.

Example Configuration: Extend a Circuit/VC Using CLI Templates

Example Configuration 1: Extending an L3VPN service on a Cisco ASR 903 device using a CLI template with Global and Template (Local) variables:

```plaintext
vrf definition Testdoc1
exit
vrf Testdoc1
  vpn id 36B:3
  address-family ipv4 unicast
    import route-target 65:1
    export route-target 65:1
  address-family ipv6 unicast
    import route-target 65:1
    export route-target
```
Example Configuration 2: Extending a CEM service using a CLI template with a global variable and a template (local) variable:

```plaintext
#set($interfaceNameList = $gv.service-cem-cemInterfaceNameList.split("","))
#set($cemGroupNumberList = $gv.service-cem-cemGroupNumberList.split("","))
#set($count = 0)
#foreach($interfaceName in $interfaceNameList)
  interface $interfaceName
    service-policy input MainInterfacePolicy
    #if($count == 0)
      cem $cemGroupNumberList[0]
    #else
      cem $cemGroupNumberList[1]
    #end
    service-policy input servicePolicy
    #set($count = $count+1)
#end
```

Example Configuration 3: Extending a CEM service to configure QoS over CEM:

```plaintext
#set($count = 0)
#foreach($interfaceName in $gv.service-cem-cemInterfaceNameList)
  interface $interfaceName
  service-policy input MainInterfacePolicy
  #if($count == 0)
    cem $gv.service-cem-cemGroupNumberList[0]
  #else
    cem $gv.service-cem-cemGroupNumberList[1]
  #end
  service-policy input servicePolicy
  #set($count = $count+1)
#end
```

Example Configuration 4: Extending a CE service using a CLI template with global and template variables on a Cisco ME3800 device. The highlighted text represents the pre-config and post-config configuration changes that are appended and prepended to the CE service provisioning configuration.
Example Configuration: Extend a Circuit/VC Using CLI Templates

```
pseudowire-class PWClass_51_192-168-12-29
protocol ldp
exit
ethernet cfm domain EVC level 4
    service evplextnpseudowireclass_evc evplextnpseudowireclass_continuity-check
        continuity-check interval 1s
    ethernet evc evplextnpseudowireclass
interface GigabitEthernet0/11
    no shutdown
    no spanning-tree portfast
    mtu 1522
    ethernet uni id 3800x
    service instance 1 ethernet evplextnpseudowireclass
        encapsulation dot1q 88
        xconnect 192.168.12.29 51 encapsulation mpls pw-class PWClass_51_192-168-12-29
        mtu 1508
    service instance 1 ethernet evplextnpseudowireclass
        cfm mep domain EVC mpid 2
        ethernet lmi ce-vlan map 88
ip sla 17
    ethernet y1731 loss SLM domain EVC evc evplextnpseudowireclass_mpid 1 cos 5 source mpid 2
        history interval 5
        aggregate interval 60
ip sla schedule 17 life forever start-time after 00:02:00
interface GigabitEthernet0/11
desc postconfig
exit
```

Example Configuration 5: Extending a Layer 3 Link service using a CLI template with a global variable and a template (local) variable:

```csharp
#$CREATE AND MODIFY CASE
#if($gv.service-serviceOperationType == "CREATE" || $gv.service-serviceOperationType == "MODIFY")
###XE DEVICE
#if($variant=="IOS-XE")
#if($gv.service-l3Link-routingProtocolName=="BGP")
    router bgp $gv.service-l3Link-routerProcessId
        address-family ipv4
            neighbor $gv.service-l3Link-bgpNeighborName next-hop-self all
            if($gv.service-l3Link-isRouteReflectorClient=="TRUE" && $prefixListName!="" && $gv.service-l3Link-endPointDesignation=="AEND")
                neighbor $gv.service-l3Link-bgpNeighborName capability orf prefix-list send
            neighbor $gv.service-l3Link-bgpNeighborName prefix-list $prefixListName in
            #elseif($gv.service-l3Link-isRouteReflectorClient=="TRUE" && $prefixListName!="" && $gv.service-l3Link-endPointDesignation=="ZEND")
                neighbor $gv.service-l3Link-bgpNeighborName capability orf prefix-list receive
                #end
        exit
    exit
endif
#endif
#if($xeMTU!="" || $xeClnsMTU!="")
    interface $gv.service-l3Link-interfaceName
        if($xeMTU!="")
            mtu $xeMTU
        endif
        if($xeClnsMTU!="")
            clns mtu $xeClnsMTU
        endif
```
exit

#if($gv.service-l3Link-routingProtocolName=="BGP")
#if($addressFamily !="" && $addressFamily=="vpnv4")
router bgp $gv.service-l3Link-routerProcessId
    address-family $addressFamily
    neighbor $gv.service-l3Link-bgpNeighborName activate
    neighbor $gv.service-l3Link-bgpNeighborName send-community both
    #if($gv.service-l3Link-isRouteReflectorClient=="TRUE")
        neighbor $gv.service-l3Link-bgpNeighborName route-reflector-client
    #end
    bgp additional-paths install
    neighbor $gv.service-l3Link-bgpNeighborName next-hop-self all
exit
exit
#endif
#include DEVICE
#include XR DEVICE
#endif
#if($xrMTU!="")
#endif
#if($gv.service-l3Link-routingProtocolName=="BGP")
#if($addressFamily !="" && $addressFamily=="vpnv4")
router bgp $gv.service-l3Link-routerProcessId
    address-family $addressFamily unicast
    additional-paths receive
exit
    neighbor $gv.service-l3Link-bgpNeighborName
    address-family $addressFamily unicast
    #if($gv.service-l3Link-isRouteReflectorClient=="TRUE")
        route-reflector-client
    #end
    aigp
    #if( $routePolicyName!="")
        route-policy $routePolicyName in
    #end
exit
#endif
#endif
#endif

##DELETE USE CASE
#elseif($gv.service-serviceOperationType == "DELETE")
##XE DEVICE
#endif
#endif
#if($variant=="IOS-XE")
#endif
#if($xeMTU!="" || $xeClnsMTU!="")
interface $gv.service-l3Link-interfaceName
#endif
Cisco Evolved Programmable Network Manager 3.0 User and Administrator Guide
Example Configuration 6: Extending a Bidirectional TE tunnel using a CLI template with a global variable and a template (local) variable:

```plaintext
#CREATE AND MODIFY CASE
#if($gv.service-serviceOperationType == "CREATE" || $gv.service-serviceOperationType == "MODIFY")
  #if($variant && $variant=="IOS-XE")
    #if($gv.service-teTunnel-tunnelId && $gv.service-teTunnel-tunnelId!="")
      #if($xeBandWidth && $xeBandWidth !="")
        interface Tunnel$gv.service-teTunnel-tunnelId
        bandwidth $xeMaxBandWidth
        tunnel mpls traffic-eng auto-bw frequency $xeBandWidth max-bw $xeMaxBandWidth min-bw $xeMinBandWidth
        exit
      #end
    #end
  #else
    #if($gv.service-teTunnel-tunnelId && $gv.service-teTunnel-tunnelId!="")
      #if($xrBandWidth && $xrBandWidth!="")
        #if($gv.service-teTunnel-tunnelId && $gv.service-teTunnel-tunnelId=="vpnv4")
          router bgp $gv.service-teTunnel-routerProcessId
          address-family $addressFamily unicast
          no additional-paths receive
        exit
        neighbor $gv.service-teTunnel-bgpNeighborName
          no address-family $addressFamily unicast
        exit
      #end
    #end
  #end
#end
```

**Example Configuration 6:** Extending a Bidirectional TE tunnel using a CLI template with a global variable and a template (local) variable:
Example Configuration: Extend a Circuit/VC Using CLI Templates

interface tunnel-te$gv.service-teTunnel-tunnelId
  bandwidth $xrMaxBandWidth
  auto-bw
    bw-limit min $xrMinBandWidth max $xrMaxBandWidth
  application $xrBandWidth
exit
#end
#end
#end
#elseif($gv.service-serviceOperationType == "DELETE")
  #if($variant && $variant=="IOS-XE")
    #if($gv.service-teTunnel-tunnelId && $gv.service-teTunnel-tunnelId!='"")
      #if($xeBandWidth && $xeBandWidth!='"")
        interface Tunnel$gv.service-teTunnel-tunnelId
          no bandwidth
          no tunnel mpls traffic-eng auto-bw
        exit
      #end
    #end
  #else
    #else
      #if($gv.service-teTunnel-tunnelId && $gv.service-teTunnel-tunnelId!='"")
        #if($xrBandWidth && $xrBandWidth!='"")
          interface tunnel-te$gv.service-teTunnel-tunnelId
            no bandwidth
            no auto-bw
          exit
        #end
      #end
    #end
  #end
#end
### Enable and Disable Service Discovery

Cisco EPN Manager uses the service discovery feature to automatically discover the circuits/VCs existing in the network and the circuits/VCs that are provisioned using the Provisioning Wizard.

The service discovery feature is enabled by default. You can choose to disable this feature. If you disable service discovery, all the discovered services in Cisco EPN Manager will be removed. However, the services that were provisioned using Cisco EPN Manager will remain and their state will be 'Missing'. Use the **History Settings** option to configure the number of versions of service discovery changes that you would like to keep in store. You must restart the server to apply the changes.
The History Settings configuration is relevant only for service discovery changes in optical circuits.

To disable service discovery:

**Step 1**
From the left side bar, choose Administration > Settings > System Settings, then choose Circuits/VCs > Discovery Settings.

**Step 2**
Uncheck the Enable Service Discovery check box.

**Step 3**
Restart Cisco EPN Manager to apply your changes. See Stop and Restart Cisco EPN Manager, on page 719.

## Circuit or VC States

**Circuit or VC Primary States**— Conveys the most important state information for a circuit, in this order: Serviceability, Discovery, Alarm, Provisioning. It is normally shown in the first column of a circuit or VC table.

<table>
<thead>
<tr>
<th>Circuit or VC Primary State</th>
<th>Icon</th>
<th>Serviceability</th>
<th>Discovery</th>
<th>Alarm</th>
<th>Provisioning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Missing</td>
<td>📈</td>
<td>—</td>
<td>Missing</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Down</td>
<td>🔄</td>
<td>Down</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Critical</td>
<td>❌</td>
<td>—</td>
<td>—</td>
<td>Critical</td>
<td>—</td>
</tr>
<tr>
<td>Major</td>
<td>🔴</td>
<td>—</td>
<td>—</td>
<td>Major</td>
<td>—</td>
</tr>
<tr>
<td>Minor</td>
<td>🟢</td>
<td>—</td>
<td>—</td>
<td>Minor</td>
<td>—</td>
</tr>
<tr>
<td>Partially Down</td>
<td>🟡</td>
<td>Partial</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Admin Down</td>
<td>🟠</td>
<td>Admin Down</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Partially Discovered</td>
<td>🟡</td>
<td>—</td>
<td>Partial</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Failed</td>
<td>🟠</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>(Create, modify, or delete) failed</td>
</tr>
<tr>
<td>In progress</td>
<td>⌁</td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>(Create, modify, or delete) in progress</td>
</tr>
<tr>
<td>Warning</td>
<td>🟠</td>
<td>—</td>
<td>—</td>
<td>Warning</td>
<td>—</td>
</tr>
<tr>
<td>Up</td>
<td>🟠</td>
<td>Up</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
</tbody>
</table>
Circuit or VC Serviceability State— This value is a combination of the circuit or VC’s admin and operational states. The admin state is shown because it impacts service operability. For optical circuits, the admin state also determines whether the Activate and Deactivate actions are available. The operational state is shown to quickly identify whether a service is working or not.

<table>
<thead>
<tr>
<th>Circuit or VC Serviceability State</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Admin Down</td>
<td>x</td>
<td>Circuit or VC manually shut down by the administrator.</td>
</tr>
<tr>
<td>Down</td>
<td>x</td>
<td>Circuit or VC is operationally down and administratively up.</td>
</tr>
<tr>
<td>Up</td>
<td></td>
<td>Circuit or VC is operationally and administratively up.</td>
</tr>
<tr>
<td>Auto Up</td>
<td></td>
<td>Circuit or VC is operationally auto up and administratively up. Only certain devices support the Auto Up operational state.</td>
</tr>
<tr>
<td>Unavailable</td>
<td></td>
<td>Circuit or VC has not been discovered yet, or its operational status is unavailable.</td>
</tr>
<tr>
<td>Partial</td>
<td></td>
<td>Circuit/VC operational or administrative state is partial.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Partial admin state—The circuit or VC has a mixed administrative request (to activate some service resources and deactivate others), has a mix of resources that are administratively up and down, or has resources whose operational state is unavailable.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Partial operational state—The circuit or VC has a mix of some active and deactivated resources, or the operational state for some of its resources are unavailable.</td>
</tr>
</tbody>
</table>

Following table provides details of the serviceability states of Circuits/VCs under various scenarios:

<table>
<thead>
<tr>
<th>Technology</th>
<th>Service Type</th>
<th>Scenario</th>
<th>Serviceability State</th>
</tr>
</thead>
<tbody>
<tr>
<td>Carrier Ethernet</td>
<td>EPL, EVPL, Access EPL, and Access EVPL</td>
<td>If the operational state of the endpoints (service instance / sub-interface), cross connects, and pseudowire participating in the service is up</td>
<td>Up</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>----------------------------------------</td>
<td>-------------------------------------------------------------------------------</td>
<td>----</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If the admin state of both, the source and destination endpoints (service instance / sub-interface) participating in the service is down</td>
<td>Admin Down</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In all the other scenarios, when at least one endpoint (service instance / sub-interface), cross connect, or the pseudowire participating in the service is down</td>
<td>Down</td>
</tr>
<tr>
<td>EP-LAN, EVP-LAN, EP-Tree, and EVP-Tree</td>
<td>If all the endpoints (service instance / sub-interface), bridge domains, VFI, and pseudowires participating in the service are up</td>
<td>Up</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>If the operational state of at least two endpoints (service instance / sub-interface) participating in the service are up and the rest of the endpoints are down</td>
<td>Partial</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If the admin state of all the endpoints (service instance / sub-interface) participating in the service is down</td>
<td>Admin Down</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If the operational state of at least one endpoint (service instance / sub-interface) participating in the service is up and the rest of the endpoints are down</td>
<td>Down</td>
</tr>
<tr>
<td>Circuit Emulation</td>
<td>All service types</td>
<td>If the operational state of the endpoints (cemGroup), underlying TDM controller, cross connect, and pseudowire participating in the service are up</td>
<td>Up</td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-----</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If the admin state of both, the source and destination endpoints (cemGroup) participating in the service is down</td>
<td>Admin Down</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In all the other scenarios, when the operational state of one of the endpoint (cemGroup), underlying TDM controller, cross connect, and pseudowire participating in the service is down</td>
<td>Down</td>
</tr>
<tr>
<td>MPLS</td>
<td>Unidirectional TE Tunnel</td>
<td>If the operational state of the tunnel interface is up</td>
<td>Up</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If the admin state of the tunnel interface is down</td>
<td>Admin Down</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In all the other scenarios, when the operational state of the tunnel is down</td>
<td>Down</td>
</tr>
<tr>
<td>Bidirectional TE Tunnel</td>
<td></td>
<td>If the operational states of the interfaces on both ends of the tunnel is up</td>
<td>Up</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If the admin states of the interfaces on both ends of the tunnel is down</td>
<td>Admin Down</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In all the other cases, when the operational state of the tunnel interface is down</td>
<td>Down</td>
</tr>
<tr>
<td>Circuit or VC States</td>
<td>Manage Circuits</td>
<td></td>
<td></td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Serial</strong></td>
<td><strong>RS232, RS422, and RS485</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>If the operational state of the endpoints (channelGroup), underlying Serial interface, cross connect, and pseudowire participating in the service are up</td>
<td><strong>UP</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>If the admin state of both, the source and destination endpoints (channelGroup) participating in the service is down</td>
<td>Admin Down</td>
<td></td>
<td></td>
</tr>
<tr>
<td>If the admin state of either source or destination endpoint (channelGroup) is down</td>
<td>Down</td>
<td></td>
<td></td>
</tr>
<tr>
<td>In all the other scenarios, when the operational state of one of the endpoint (channelGroup), underlying Serial interface, cross connect, and pseudowire participating in the service is down</td>
<td>Down</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Raw Socket</strong></td>
<td><strong>Up</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>If server and all its associated client sessions are up</td>
<td>Up</td>
<td></td>
<td></td>
</tr>
<tr>
<td>If server is up and all its associated client sessions are down</td>
<td>Down</td>
<td></td>
<td></td>
</tr>
<tr>
<td>If the admin state of both, the source and destination endpoints (channelGroup) participating in the service is down</td>
<td>Admin Down</td>
<td></td>
<td></td>
</tr>
<tr>
<td>If the admin state of a server or admin state of all the participating clients are down</td>
<td>Down</td>
<td></td>
<td></td>
</tr>
<tr>
<td>If server and all its associated client sessions are down</td>
<td>Down</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Circuit or VC Discovery State—Represents the latest state and structure of a service and its components, as discovered from the network. Having a Discovered version means that the application is actually monitoring the service itself, e.g. it can define meaningful operational and performance data.

<table>
<thead>
<tr>
<th>Circuit or VC Discovery State</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Partial</td>
<td>🌡️</td>
<td>Circuit or VC partially discovered by Cisco EPN Manager; not all of its expected entities have been discovered.</td>
</tr>
<tr>
<td>Full</td>
<td>✅</td>
<td>Circuit or VC fully discovered by Cisco EPN Manager, so Cisco EPN Manager can monitor the service and provide meaningful operational and performance data.</td>
</tr>
<tr>
<td>Missing</td>
<td>🚭</td>
<td>Circuit or VC not yet discovered by Cisco EPN Manager (though it may have been provisioned).</td>
</tr>
</tbody>
</table>

Circuit or VC Provisioning State—Represents whether there is a provisioning intent for a circuit or VC and, if so, its status. If a reconciliation report has been generated, the state of the reconcile action is reflected.
Provisioning State | Icon | Description
--- | --- | ---
None | | Circuit or VC was discovered but has not yet been provisioned. The circuit/VC must be promoted in order to modify or delete it.
Failed | | Action has failed.
InProgress | | Action was initiated but not yet completed.
Planned | | Action is planned but not yet initiated.
Succeeded | | Action has completed successfully.

### View Circuits/VCs

Cisco EPN Manager provides a variety of ways that you can view circuits/VCs:

To view circuit/VC information for: | See the procedures in:
--- | ---
A specific circuit/VC in a topology map, in a Circuit/VC 360 view, or in a Circuit/VC Details page | • Get Quick Information About a Circuit/VC: Circuit/VC 360 View, on page 593
• Get Comprehensive Information About a Circuit/VC: Circuit/VC Details Window, on page 597
A device | View a Specific Device's Circuits/VCs, on page 600
A device group in a topology map or in an expanded table | View a Device Group's Circuits/VCs, on page 600
All of Cisco EPN Manager | View All Circuits/VCs in Cisco EPN Manager, on page 602

### View a Specific Circuit/VC's Details

Cisco EPN Manager provides different ways to view details about a specific circuit/VC, depending on how much detail you need:

• View a Specific Circuit/VC in the Topology Map, on page 590
• Get Quick Information About a Circuit/VC: Circuit/VC 360 View, on page 593
• Get Comprehensive Information About a Circuit/VC: Circuit/VC Details Window, on page 597
• View and Compare Versions of a Circuit (Optical), on page 599

### View a Specific Circuit/VC in the Topology Map

When working with circuits/VCs, it is very useful to see how a circuit/VC is deployed within the existing network topology. Cisco EPN Manager overlays the circuit/VC on an existing topology map, clearly indicating
the endpoints and midpoints of the circuit/VC, the role of the endpoint (where relevant), and relevant fault information for the circuit/VC. This overlay functionality is available in the geo map as well as the topology map.

For CE and CEM services that use the MPLS TE tunnels to traverse through the network, the underlying tunnel is also displayed in the topology map along with the service overlay. For information about how to assign a MPLS TE tunnel for a CE or CEM service, see Provision EVCs in a Carrier Ethernet Network, on page 481 and Provision Circuit Emulation Services, on page 538.

- The overlay cannot be displayed if the discovery state of the circuit is "Missing".
- A circuit/VC might contain endpoints that cross device groups, meaning that one endpoint might belong to one group and another might belong to a different group. In this case, the full overlay cannot be shown. If an endpoint is not currently shown in the map, a notification link will appear at the top left of the map. Click the link to expand the map to show all the device groups that contain endpoints of the selected circuit/VC.
- When the overlay is displayed, the Link Type filter is disabled.

To display an overlay of a circuit/VC on the network topology:

**Step 1** From the left sidebar, choose Maps > Topology Maps > Network Topology.

**Step 2** Click the Device Groups button and select the required group.

**Step 3** Go to the Circuits/VCs tab to see a list of the circuits/VCs associated with the selected group.
**Step 4**  Select the circuit/VC you want to see on the map.

The nodes and links that participate in the selected circuit are highlighted in the overlay and the rest of the devices in the map appear disabled. The name of the selected circuit is displayed just below the topology toolbar. To clear the overlay, click the ‘x’ button to the right of the circuit name. For a description of the overlay icons, see Circuit or VC Network Topology Overlay Icons.

### Circuit or VC Network Topology Overlay Icons

<table>
<thead>
<tr>
<th>Overlay Icon</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Source endpoint" /></td>
<td>Source endpoint</td>
</tr>
<tr>
<td><img src="image" alt="Destination endpoint" /></td>
<td>Destination endpoint</td>
</tr>
<tr>
<td><img src="image" alt="EVC or CEM service with local switching" /></td>
<td>EVC or CEM service with local switching</td>
</tr>
<tr>
<td><img src="image" alt="Endpoint included by the user during creation of the circuit." /></td>
<td>Endpoint included by the user during creation of the circuit.</td>
</tr>
<tr>
<td><img src="image" alt="Endpoint excluded by the user during the creation of the circuit." /></td>
<td>Endpoint excluded by the user during the creation of the circuit.</td>
</tr>
<tr>
<td><img src="image" alt="Endpoint with some ports that were either included or excluded during creation of the circuit. This endpoint contains multiple ports that are participating in various routes of the circuit." /></td>
<td>Endpoint with some ports that were either included or excluded during creation of the circuit. This endpoint contains multiple ports that are participating in various routes of the circuit.</td>
</tr>
<tr>
<td><img src="image" alt="E-TREE EVC endpoint that has been designated as a root." /></td>
<td>E-TREE EVC endpoint that has been designated as a root.</td>
</tr>
<tr>
<td><img src="image" alt="Selected endpoint." /></td>
<td>Selected endpoint.</td>
</tr>
<tr>
<td><img src="image" alt="Hub; If the hub and root are on the same device (VPLS scenario), the brown circle is combined with the root icon." /></td>
<td>Hub; If the hub and root are on the same device (VPLS scenario), the brown circle is combined with the root icon.</td>
</tr>
</tbody>
</table>
### Get Quick Information About a Circuit/VC: Circuit/VC 360 View

The Circuit/VC 360 view provides at-a-glance information about a specific circuit/VC. From the Circuit/VC 360 view, you can access detailed information about the circuit/VC and perform the actions described in \[\text{Actions You Can Perform from the Circuit/VC 360 View, on page 596.}\]

The Circuit/VC 360 view displays the circuit name, state, and general circuit/VC and performance information at the top of the view. More detailed information is provided in tabs in the lower part of the view.

<table>
<thead>
<tr>
<th>Information Provided in Circuit/VC 360 View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General information</td>
<td>Type of circuit/VC, its various states (discovery, serviceability, provisioning), the customer associated with the circuit/VC, and some audit information (when it was created, when it was last changed). For an explanation of circuit/VC states, see [\text{Circuit or VC States, on page 584.}]</td>
</tr>
<tr>
<td>Note</td>
<td>If the Provisioning state is \text{Create Failed}, click the associated (i) (information) icon to see the reason for the failure.</td>
</tr>
<tr>
<td>Performance data</td>
<td>Graphs reflecting various aspects of the circuit/VC performance.</td>
</tr>
<tr>
<td>Note</td>
<td>For data to be shown in the graphs, the required monitoring policy must be activated for the relevant devices. For example, to view graphs that chart the number of Explicit Pointer Adjustment Relay counters (such L-bits and P-bits) that have been generated and received, both the CEM and Pseudowire Emulation Edge to Edge monitoring policies must be enabled. See [\text{Monitoring Policies Reference, on page 879.}]</td>
</tr>
<tr>
<td>Alarms</td>
<td>Current alarms for the circuit/VC, including their severity, status, and the time they were generated.</td>
</tr>
<tr>
<td>Endpoints</td>
<td>Devices and interfaces that serve as endpoints for this circuit/VC.</td>
</tr>
</tbody>
</table>
The **History** tab lists all versions of the circuit, allowing you to view the changes that have occurred since the circuit/VC was discovered or first deployed. You can open the Circuit 360 view for any of the versions listed to see its endpoints, alarms, and so forth.

**Note** If you are looking at the Circuit 360 view for a historical circuit/VC, the **History** tab is not displayed.

You can also view the configuration details for the circuit/VC's endpoints by doing the following:

1. Locate the appropriate circuit/VC version and click its *information* icon in the **Provisioning State** column.

   The **Device Configuration Details** pop-up window opens.

2. Click the radio button for the endpoint whose configuration details you want to view.

   If the endpoint was successfully provisioned, its configuration is listed at the bottom of the pop-up window. If provisioning of the endpoint failed, a description of why provisioning failed is listed instead.

<table>
<thead>
<tr>
<th>Related Circuits/VCs</th>
<th>Additional circuits within the selected circuit.</th>
</tr>
</thead>
</table>

For EVCs, the following information is shown:

- **Incoming Traffic**—The sum of incoming traffic, in bits per second (bps), entering all the endpoint interfaces of the circuit/VC over time. The graph shows the last 24 samples of the total incoming traffic for all the endpoints in intervals of 1 minute. The pink bar shows the lowest level of incoming traffic while the blue bar shows the highest level of incoming traffic.

- **Port Availability**—Average availability of all the endpoints of the circuit/VC, expressed as a percentage, aggregated across all endpoints. Baseline is 100% unless any of the interfaces has been unavailable.

- **Outgoing Traffic**—The sum of traffic, in bits per second (bps), exiting all the endpoint interfaces of the circuit/VC over time.

- **Loss**—Average loss, expressed as a percentage, across all the endpoints of the circuit/VC.

- **Delay**—Average delay, in microseconds, across all the endpoints of the circuit/VC.

- **Jitter**—Average jitter, in milliseconds, across all the endpoints of the circuit/VC.

For optical circuits, the performance data is shown based on the following circuit types:

- **OCHCC WSON**—The total number of octets received on the interface, including frames, number of inbound packets with errors that prevented them from being delivered to a higher layer protocol, and number of severely errored seconds per line and multiplex sections.

- **OCHNC WSON**—The average, minimum, and maximum optical signal to noise ratio (OSNR) for this circuit type.

- **OCH-TRAIL WSON**—The total number of uncorrectable words and the total number of errors corrected, in bits per second (bps), for this circuit type.
• OCH-Trail UNI—The total number of uncorrectable words and the total number of errors corrected, in bits per second (bps), and the minimum, average, and maximum output power received and transmitted, in decibel referenced to 1 watt (dBW) by this circuit type.

• ODU UNI—The total number of background block errors, total number of severely errored seconds, and errored seconds ratio for path monitoring.

• ODU Tunnel—The total number of background block errors, total number of severely errored seconds, and errored seconds ratio for section monitoring.

In addition, the average, minimum, and maximum amount of output power received and transmitted from the circuit is shown for all optical circuit types.

For Circuit Emulation services, the following information is shown:

• The total number of jitter buffer overruns for each circuit endpoint.
• The total number of Explicit Pointer Adjustment Relay counters (such as L-bits and R-bits) that were generated and received for each circuit endpoint.

For services on a Cisco ME 1200 device, information such as incoming and outgoing traffic, jitter, and availability is displayed.

For MPLS bidirectional TE tunnels, ensure that you activate the Interface Health monitoring policy so that the performance data is shown. See Monitoring Policies Reference, on page 879 for more information. The following performance data is shown:

• Traffic—The sum of traffic in both directions of the tunnel, in bits per second (bps).
• Availability—Average availability of the endpoints in the tunnel.
• Bandwidth Utilization—The percentage of bandwidth configured on the tunnel against the sum of the percentage of bandwidth configured on all the pseudowires associated with the tunnel.
• Actual Bandwidth Utilization—The percentage of bandwidth configured on the tunnel against the sum of the percentage of bandwidth utilized for the incoming and outgoing traffic in all the pseudowires associated with the tunnel.

For Carrier Ethernet services that have Y.1731 probes enabled, view the extended details of Y.1731 probes in the Y.1731 tab.

Note
In the Endpoints tab, choose a relevant endpoint and then click the \( i \) icon to view the extended details.

To open the Circuit/VC 360 view for a particular circuit or VC:

**Step 1** Choose Maps > Topology Maps > Network Topology.

The network topology window opens. See Visualize the Network Topology, on page 155 for a description of the network topology window and its functionality.

**Step 2** From the Network Topology page toolbar, click Device Groups.

The Device Groups dialog box opens.

**Step 3** Locate and click the device group that the circuit or VC is associated with, then close the dialog box.

**Step 4** Click the Circuits/VCs tab.
Step 5  Locate the circuit or VC in the list and then click its \textit{(information)} icon.

### Actions You Can Perform from the Circuit/VC 360 View

The following is a list of the actions you can perform from the \textbf{View} and \textbf{Actions} menus for the selected circuit or VC. The actions that are available will vary, depending on the type of circuit or VC that is selected:

- Choose \textbf{View} > \textbf{Details} to display further details about the circuit/VC. See \textit{Get Comprehensive Information About a Circuit/VC: Circuit/VC Details Window}, on page 597.
- Choose \textbf{View} > \textbf{Service Trace} to trace the route of an optical circuit. See \textit{Trace and Visualize the Full Route of a Circuit}, on page 177.
- Choose \textbf{View} > \textbf{Dashboard} to view the service performance dashboard of the circuit/VC. See \textit{Set Up and Use the Dashboards}, on page 6.
- Choose \textbf{Actions} > \textbf{Add to Compare} to select the circuit or VC for a side-by-side comparison with another circuit or VC on the basis of information such as serviceability and provisioning state and raised alarms. See \textit{Compare Circuit/VC Information and Status}.
- Choose \textbf{Actions} > \textbf{Multilayer Trace} to visualize a circuit in a graphical manner. See \textit{Trace and Visualize the Full Route of Circuits/VCs}.
- Choose \textbf{Actions} > \textbf{Y.1564 Test} to test the performance of the CE circuit/VC end to end. See \textit{Running a Y.1564 Performance Test}, on page 628.
- Choose \textbf{Actions} > \textbf{Y.1731 Test} to test the performance of the CE circuit/VC end to end. See \textit{Performance Test Based on Y1731 for EVCs}, on page 629.
- Choose \textbf{Actions} > \textbf{BERT} to test the performance of the Circuit Emulation Services. See \textit{Performance Test for Circuit Emulation Services}, on page 632.
- Choose \textbf{Actions} > \textbf{Optical PM Parameters} to view the real-time performance monitoring data of the optical circuit/VC. See \textit{Optical Performance Monitoring Parameters}, on page 630.
- Choose \textbf{Actions} > \textbf{PRBS Test} to test the performance of the optical circuit/VC end to end. See \textit{Run PRBS Test on Circuits (ODU UNI)}, on page 631.
- Choose \textbf{Actions} > \textbf{Restoration Actions} > \textbf{Upgrade Restore} to upgrade the failed optical circuit to an active route and delete the old route where the failure occurred. See \textit{Restore a Circuit (Optical)}, on page 607.
- Choose \textbf{Actions} > \textbf{Restoration Actions} > \textbf{Manual Revert} to revert the optical circuit to its original route when the route is recovered from the failure. See \textit{Restore a Circuit (Optical)}, on page 607.
- Choose \textbf{Actions} > \textbf{Reroute Actions} > \textbf{Working Path} or \textbf{Protected Path} to reroute the traffic through the working path or protected path defined for the circuit. See \textit{Reroute a Circuit (Optical)}, on page 608.
- Choose \textbf{Actions} > \textbf{Activate} to allow the traffic to pass through the optical circuit. See \textit{Activate a Circuit (Optical)}, on page 607.
- Choose \textbf{Actions} > \textbf{Deactivate} to stop the traffic passing through the optical circuit. See \textit{Activate a Circuit (Optical)}, on page 607.
- Choose \textbf{Actions} > \textbf{PsedowireOAM} or \textbf{MPLS LSP OAM} or \textbf{CFM OAM} option to troubleshoot a service failure using OAM commands. See \textit{Troubleshoot a Service Failure Using OAM Commands}, on page 622.
- Choose \textbf{Actions} > \textbf{Show in Topology} to view the circuit/VC overlay in the topology map.
- Click the \textit{i} icon next to the Serviceability status to view additional information about a circuit failure. See \textit{Get More Information About a Circuit/VC Failure}, on page 621.
- Choose \textbf{Actions} > \textbf{Resync} > to perform the service discovery resync pertaining to a particular service. For more information, see \textit{Service Discovery Resync}.
**Compare Circuit/VC Information and Status**

From the **Comparison View**, you can perform a side-by-side comparison of multiple circuits or VCs, viewing information such as discovery and provisioning state, raised alarms, and associated endpoints. To compare circuits or VCs, do the following:

**Step 1**
For each circuit or VC you want to compare:

a) Open its **Circuit/VC 360** view, as described in Get Quick Information About a Circuit/VC: Circuit/VC 360 View.

b) Choose **Actions > Add to Compare**.

The circuit or VC you selected is displayed at the bottom of the page. You can select a maximum of 4 circuits and VCs.

**Step 2**
Click **Compare**.

The **Comparison View** opens.

**Step 3**
From the drop-down list at the top of the view, specify whether the view will show all available information or just the information that is unique to each device.

**Step 4**
Click **Comparison View**, check the check box for the categories you want the view to display, and then click **Save**.

By default, all of the categories are already selected.

**Step 5**
Scroll down the page to view the information provided for each category you selected.

Note the following:

- The **Comparison View** only displays information for two circuits or VCs at a time. If you selected more than two, you will need to toggle to the circuits or VCs that are not currently displayed.

- To reorder the circuits or VCs you have selected, click **Rearrange**.

- Each circuit or VC's **View** and **Actions** menu is identical to the ones provided in its **Circuit/VC 360** view. If you select an option, the corresponding page opens.

- You can minimize and maximize the categories displayed, as needed.

- The **Comparison View** is also available for devices, interfaces, and links. Whenever you select any of these elements from their respective 360 view for comparison, they are displayed in the corresponding tab. This allows you to switch between element types, as needed.

- When you are done comparing circuits or VCs, click **Back** at the top of the view and then click **Clear All Items** at bottom of the page. If tabs for other element types are still displayed, you will need to clear them as well.

**Get Comprehensive Information About a Circuit/VC: Circuit/VC Details Window**

The Circuit/VC Details window provides additional details about a specific circuit/VC, including the attributes defined for the circuit/VC. The information shown in the displayed page varies depending on the type of circuit/VC. You can also perform certain actions from the Circuit/VC Details Window, for example, modify/delete the circuit/VC, create a new circuit/VC, run a performance test.

To access the Circuit/VC Details window, click on the circuit/VC name hyperlink in any of the circuit/VC tables. Alternatively, you can access the Circuit/VC details window from the Circuit/VC 360 view, as follows:
Step 1  Access the Circuit/VC 360 view for the required circuit/VC. See Get Quick Information About a Circuit/VC: Circuit/VC 360 View, on page 593.

Step 2  Choose View > Details. See Provision EVCs in a Carrier Ethernet Network, on page 481 and Provision Circuits in an Optical/DWDM Network, on page 496 for description of the attributes in the Circuit/VC details page.

The details are displayed in two tabs:

- **Summary**: Displays circuit information such as the circuit discovery and provisioning states, acceptance threshold, WSON label, circuit type, wavelength associated with the circuit, protection status, and more.

- **Ports**: Displays ports information such as the ports associated with the circuit, their port roles, the IP addresses associated with the ports, and more.

---

**Actions You Can Perform from the Circuit/VC Details Page**

From the Circuit/VC Details window, you can do the following:

- **Modify the circuit/VC** (action available for circuits/VCs provisioned using Cisco EPN Manager, not for discovered circuits/VCs). See Modify a Circuit/VC, on page 606.

- **Delete the circuit/VC** (action available for circuits/VCs provisioned using Cisco EPN Manager, not for discovered circuits/VCs). See Delete a Circuit/VC, on page 612.

- **Create a new circuit/VC**. Clicking the Create button opens the Provisioning Wizard, enabling you to create a new circuit/VC. See Provision EVCs in a Carrier Ethernet Network, on page 481 and Provision Circuits in an Optical/DWDM Network, on page 496.

- **Choose Actions > Y.1564 Test** to test the performance of the CE circuit/VC end to end. See Running a Y.1564 Performance Test, on page 628.

- **Choose Actions > BERT** to test the performance of the Circuit Emulation Services. See Performance Test for Circuit Emulation Services, on page 632.

- **Choose Actions > Optical PM Parameters** to view the realtime performance monitoring data of the optical circuit/VC. See Optical Performance Monitoring Parameters, on page 630.

- **Choose Actions > PRBS Test** to test the performance of the optical circuit/VC end to end. See Run PRBS Test on Circuits (ODU UNI), on page 631.

- **Choose Actions > Restoration Actions > Upgrade Restore** to upgrade the failed optical circuit to an active route and delete the old route where the failure occurred. See Restore a Circuit (Optical), on page 607.

- **Choose Actions > Restoration Actions > Manual Revert** to revert the optical circuit to its original route when the route is recovered from the failure. See Restore a Circuit (Optical), on page 607.

- **Choose Actions > Activate** to allow the traffic to pass through the optical circuit. See Activate a Circuit (Optical), on page 607.

- **Choose Actions > Deactivate** to stop the traffic passing through the optical circuit. See Activate a Circuit (Optical), on page 607.
View and Compare Versions of a Circuit (Optical)

Use the Circuit History page to compare two versions of an optical circuit. From the Circuit History page, you can:

- Get a simple visualization and integrated view of the events that occurred in an optical circuit.
- View the alarms associated with an event.
- View information about a failure that occurred in an optical circuit.
- Compare the route changes in a circuit.

For example, consider that there is a restoration that has occurred in an optical circuit. Using the Circuit History page, you can:

1. View the list of changes that had occurred in the circuit.
2. If there is a protection switch action or a reroute that had occurred in the circuit, you can click the i icon in the Type column to see the details of the event that has caused the protection switch action or the reason for the failure occurred because of the reroute action.
3. Click the i icon in the Time Stamp column to see the alarms that are associated with the event.
4. You can further compare the route changes between the active path and the path at the time of protection switch.
5. You can also choose to compare the route changes between the active path and the original path or between the original path and the path at the time of protection switch to view the difference in the participating nodes and take action on the affected nodes.

To view the history of an optical circuit:

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>From the left side bar, choose Maps &gt; Topology Maps &gt; Network Topology.</td>
</tr>
</tbody>
</table>
| Step 2 | Click Device Groups, and then select the location in which the required circuit/VC was created.  
**Note** By default, All Location group is selected. |
| Step 3 | Close the Device Groups popup window. |
| Step 4 | In the Network Topology window, click Circuits/VCs. |
| Step 5 | Select the optical circuit for which you want to view the history. The overlay of the circuit is displayed on the map. |
| Step 6 | Click the Circuit History hyperlink that appears right below the topology toolbar.  
The Circuit History area is displayed next to the topology map and lists the various versions of the circuit. The active route of the circuit is selected by default and it is displayed on the map. |
| Step 7 | Select a history version from the list displayed in the Circuit History area to compare it with the current version.  
The overlay on the map changes based on your selection and displays both, the active route and the history version. You can select and compare only two versions at a time. |
View a Specific Device's Circuits/VCs

Use the Device 360 view to see a list of all the circuits/VCs in which a specific device participates. This is useful when a specific device is having a problem and you want to see which services it will affect.

To view a list of circuits/VCs in which a device participates:

**Step 1** Click the required device in the network topology (Maps > Topology Maps > Network Topology).

**Step 2** Click View 360 in the popup window.

**Step 3** Go to the Circuit/VC tab in the Device 360 view to see a table listing the relevant circuits for that device. The table lists the circuit/VC name, the circuit/VC type, when it was created/modified, and the current status of the circuit/VC.

View a Device Group's Circuits/VCs

- View a Device Group's Circuits/VCs List in the Topology Window, on page 600
- View a Device Group's Circuits/VCs in an Expanded Table, on page 601

View a Device Group's Circuits/VCs List in the Topology Window

Cisco EPN Manager displays discovered and provisioned circuits/VCs in the Circuits/VCs tab on the left side of the network topology window. The list of circuits/VCs is filtered according to the selected device group. You can get details about the circuit/VC by clicking on the circuit/VC name to launch the Circuit/VC Details window or by clicking the information icon and launching the Circuit/VC 360 view.

The Circuits/VCs tab lists discovered circuits/VCs and the latest version of circuits/VCs provisioned using Cisco EPN Manager. The circuits/VCs are sorted by primary state (default).

To view a list of circuits/VCs in the network topology window:

**Step 1** Choose Maps > Topology Maps > Network Topology in the left navigation pane. The network topology window opens.
Step 2  Click the **Device Groups** button and select the group of devices you want to show on the topology map.

Step 3  Go to the Circuits/VCs tab to see a list of circuits/VCs relevant to the selected device group.

Step 4  Select a circuit/VC to view an overlay of the circuit/VC in the network topology, meaning that the circuit/VC endpoints and path are shown on top of the physical topology. Click on the circuit name hyperlink to see circuit details or click on the information icon next to the circuit/VC name to open the Circuit/VC 360 view.

Step 5  To open a tabular view of the circuits/VCs in a separate window, click **Circuit/VCs** below the list of circuits/VCs.

---

**View a Device Group's Circuits/VCs in an Expanded Table**

From the network topology window, you can open a table of circuits/VCs associated with the selected device group in a separate browser window. The table provides more information about each circuit/VC and is also sortable and searchable, enabling you to find information easily. This table is particularly useful for identifying the provisioning status of circuits/VCs, as well as their management status within Cisco EPN Manager. For an explanation of circuit/VC states (and their icons, see Circuit or VC States, on page 584).

By default, the circuits/VCs table sorts the circuits/VCs by primary state. You can change how the table is sorted as required.

The expanded circuits/VCs table sorts the circuits/VCs by primary state. You can change how the table is sorted as required.

To open an expanded and more detailed tabular list of circuits in a separate window:

---

**Step 1**  Choose **Maps > Topology Maps > Network Topology** in the left navigation pane. The network topology window opens.

**Step 2**  Click the **Device Groups** button and select the group of devices you want to show on the topology map.

**Step 3**  Go to the Circuits/VCs tab to see a list of circuits/VCs relevant to the selected device group.

**Step 4**  Click the **Circuit/VCs** hyperlink below the list of circuits/VCs to open a separate window containing a list of circuits/VCs relevant to the selected device group.

---

- See more information about the circuit/VC by displaying the Circuit/VC 360 view. See View Circuits/VCs, on page 93.
- View the circuit/VC on the map, as an overlay on top of the displayed devices. See View a Specific Circuit/VC in the Topology Map, on page 590.
- Launch the Provisioning Wizard to provision circuits/VCs. See Create and Provision a New Carrier Ethernet EVC, on page 483 and Provision Circuits in an Optical/DWDM Network, on page 496.
- See more information about a circuit failure. See Get More Information About a Circuit/VC Failure, on page 621.
- Select a circuit/VC for modification, deletion, circuit trace, and performance test. See the following topics for more information:
  - Modify a Circuit/VC, on page 606
  - Delete a Circuit/VC, on page 612
  - Run a Performance Test on a Circuit/VC, on page 626
View All Circuits/VCs in Cisco EPN Manager

The Circuits/VCs & Network Interfaces page lists all of the circuits and VCs that Cisco EPN Manager is currently managing. From here, you can quickly locate a specific circuit or VC by filtering the list using basic criteria such as name, type, or customer. You can view the number of EFPs that Cisco EPN Manager has provisioned. If all the EFPs are provisioned, the number of EFPs will match the number of services. You can identify all of the circuits and VCs that have severe alarms or are in a specific state. (For a description of circuit and VC states (including primary states), see Circuit or VC States, on page 584.) You can also perform circuit and VC management tasks and run performance tests. To use this page, do the following:

---

**Note** After a device that is participating in a circuit or VC is removed from Cisco EPN Manager, the corresponding circuit or VC is still listed on the Circuits/VCs & Network Interfaces page.

---

**Step 1** Choose Inventory > Other > Circuits/VCs & Network Interfaces.

**Step 2** Perform any of the following actions:

- Find specific circuits or VCs by using one of the quick filter fields. For example, enter L3VPN in the Type field to list all circuits and VCs of that type or click the Serviceability quick filter field and then choose Down to view all circuits and VCs that are currently down.

- View a specific circuit or VC in the topology map by clicking its radio button and then choosing Actions > Show in Topology.

- With a circuit or VC selected, use the Actions menu to activate circuits or VCs and run performance tests.

- Create, modify, delete, or force delete circuits and VCs by clicking the appropriate button in the Circuits/VCs & Network Interfaces page toolbar, which opens the provisioning wizard.

---

Identify and Manage Discovered Circuits/VCs

Cisco EPN Manager discovers existing network circuits/VCs and displays them in the Circuit/VC list. Discovered circuits/VCs are automatically named by the system. The names for EVCs begin with EvcLink_ (for example, EvcLink_Vpls_Bridge_318#318#VFIVPLS2_541549_10.56.23.48#1).

---

**Note** When circuits/VCs are discovered, the system identifies whether they are optical, CE, or L3VPN circuits/VCs, but it cannot identify the exact type of CE circuit/VC. For example, CE circuits/VC will display EVC in the Type column but not the type of EVC, such as EPL, E-LAN, and so on. For optical, the exact type of circuit is displayed.

You can do the following with discovered circuits/VCs:

- Identify discovered circuits/VCs in the Circuit/VC list by name or in the table of circuits/VCs by state, Discovered.

- View details about the discovered circuits/VCs in the Circuit/VC 360 view, including the endpoints of the circuit/VC.
• View an overlay of the circuit/VC on the network topology.
• View fault information for the circuit/VC.
• Promote a discovered circuit/VC, after which you can edit or delete it (applies to optical circuits and selected EVCs. See Promote a Discovered Circuit/VC Before Modifying/Deleting, on page 604.
• Do a performance test.

Show/Hide Implicit Circuits

A circuit is classified as implicit if it is an underlying or "carrying" circuit of another circuit. For example, an OCHTRAIL circuit could be a carrying circuit (and implicit) for an OCHCC circuit. By default, all circuits are listed in the circuit lists. However, you can hide implicit circuits from the lists, if required. When implicit circuits are hidden, they will not be displayed in the circuit lists but you can see them in the Carrying Circuits tab of the Circuit 360 view.

To hide implicit circuits from the circuit lists:

Step 1 From the left sidebar, choose Administration > Settings > System Settings.
Step 2 From the System Settings menu, choose Circuits/VCs > Circuits/VCs Display.
Step 3 Uncheck the Show Implicit Circuits/VCs check box.

Filter and Export the Circuit/VC list Based on a User Defined Field

You can create a user defined field, assign a value to the field, and associate it to a circuit/VC. You can then sort, filter, and export the circuit/VC list based on the user defined field.

For example, if you want to filter the circuit/VC list based on the service impact, you need to:

• Create a user defined field, named Service Impact
• Select the circuit/VC to which you want to associate the user defined field, Service Impact
• Assign the value as Critical, Moderate, or Low for the Service Impact field
• Sort, filter, and export the circuit/VC list based on the service impact value

Note You can create a maximum of 10 user defined fields.

Step 1 To create a user defined field, do one of the following:

• Choose Administration > Settings > System Settings > Inventory > User Defined Fields, and then click the ‘+’ icon to create a new label and description. Click Save.

Note You cannot assign a value to the user defined field from the Administration menu.
• Choose Inventory > Other > Circuits/VCs & Network Interfaces, select a circuit/VC, and then choose Actions > Manage User Defined Fields. Click the ‘+’ icon to create a user defined field, its description, and value. Click Save.

• Choose Maps > Topology Maps > Network Topology, go to the Circuits/VCs tab, and then click the Circuits/VCs hyperlink below the list of circuits/VCs. An expanded table of circuits/VCs opens in a separate window. Select a circuit/VC, and then choose Actions > Manage User Defined Fields. Click the ‘+’ icon to create a user defined field, its description, and value. Click Save.

Step 2
In the Circuits/VCs & Network Interfaces page or in the expanded table of circuits/VCs, click the settings icon at the top right of the page, and then choose Columns.

Step 3
Choose the user defined field you have created, and then click Close. The user defined field with the assigned value is displayed as a column in the table of circuits/VCs.

Step 4
Click the Export icon next to the Settings icon at the top right of the table to export the data from the table to a file (either PDF or CSV format).

You can delete the user defined field only from Administration > Settings > System Settings > Inventory > User Defined Fields.

Display the Routes Associated With a Circuit

Use the network topology Routes drop-down menu to display specific routes associated for a circuit in the circuit overlay. Cisco EPN Manager calculates the routes from the links within a service. You can also filter the overlay based on the selected routes.

Note
This feature is supported only on point-to-point CE services, optical circuits, and CEM services.

Step 1
From the left sidebar, choose Maps > Topology Maps > Network Topology.

Step 2
From Device Groups list, select the required group. Cisco EPN Manager lists the circuits associated with the selected group in the Circuit/VCs tab.

Step 3
Click Circuit/VCs, and then select the circuit you want to display.

Step 4
From the Routes drop-down list, choose the required route type.

Note
The route types are based on the routes configured on the selected circuit.

Promote a Discovered Circuit/VC Before Modifying/Deleting

Discovered circuits need to be promoted before they can be modified or deleted. After being promoted, the circuit/VC’s provisioning state changes to Promote Successful.
Promotion is supported for Optical circuits, MPLS-TE and for basic EVCs that do not have additional configurations, such as CFM, LMI, QoS, OAM, G.8032, ICCP-SM. Promotion is supported if the underlying core is VPLS (for E-LAN and E-Tree EVCs). If a discovered circuit/VC cannot be promoted, it cannot be modified or deleted. Also, promotion is supported for Circuit Emulation' services, Unidirectional, Bidirectional, and L3VPN services.

To promote a discovered circuit/VC:

**Before you begin**

For successful promotion of L3VPN services, you must ensure that the route distinguisher for the L3VPN service is specified in the format `rd device_ip: number`.

For example:

```
vrf definition vdvvgfr420
    rd 10.104.120.133:420
    vpn id 36B:420
!  address-family...
```

**Step 1**

From the left sidebar, choose Maps > Topology Maps > Network Topology. The network topology window opens.

**Step 2**

Click the Device Groups button and select the required group.

**Step 3**

Go to the Circuits/VCs tab and click the Circuits/VCs link to open an extended table of circuits/VCs in the selected group.

**Step 4**

Select the discovered circuit/VC you want to promote.

To identify L3VPN services that are discovered from the device but not promoted, filter out L3VPN services that have the provisioning status 'None'. You can also identify discovered services using the Name field of the L3VPN service. The Name field for L3VPN services that are discovered are represented with the service's unique VLAN IDs.

To identify MPLS TE services that are discovered from the device but not promoted, filter out MPLS TE services that have the provisioning status 'None'. You can also identify discovered services using the Name field of the MPLS TE service.

**Step 5**

Click Modify. The Provisioning Wizard opens.

**Step 6**

For optical circuits, modify the circuit as required, then click Create.

**Step 7**

For EVCs, do the following:

a) In the Endpoints Details page, select an endpoint. Fields relevant to the selected endpoint are displayed below.

b) Specify the type of endpoint by selecting UNI or ENNI from the dropdown list, and enter a name for the endpoint. For UNIs, you can also set bundling and multiplexing attributes.

c) Select the next endpoint and define its type, name, and attributes.

d) Click Next.

e) In the Manage Discovered Service: Service Details page, select the Type of service. The available types in the list are derived from the types of endpoints and UNI options you defined. For example, if you defined a UNI with All to one Bundling option and an ENNI, only Access EPL will be available in the list. You can go back and redefine your endpoints if necessary.

f) Give the service a name. Provide a description and specify a customer, if required.
g) For E-Tree EVCs, specify the role of each endpoint (root or leaf) in the Endpoint Designation table. The role you specify here must match the role that is configured on the device.

h) Click Save. The EVC will appear with its new name in the Circuits/VCs list and its status will be Created and Deployed.

i) You can now select the promoted EVC in the list and modify or delete it.

Step 8
For L3VPN services, do the following:

a) Give the service a name. Provide a description and specify a customer, if required, and click Next.

b) In the Deployment Action drop-down menu, specify the task (Preview or Deploy) that must be taken up when the VPN service promotion process is completed, and click Next.

c) Specify the UNI name, the MTU value, and whether service multiplexing should be enabled.

d) Click Save. The L3VPN service will appear with its new name in the Circuits/VCs list and its status will be Promote Successful.

e) You can now select the promoted L3VPN service from the list and modify or delete it.

Step 9
For MPLS TE Tunnel services, do the following:

a) Give the service a name if required. Provide a description and specify a customer, if required, and click Next.

b) Click Save. The MPLS TE Tunnel service will appear in the Circuits/VCs list and its status will be Promote Successful.

c) You can now select the promoted MPLS TE Tunnel service from the list and modify or delete it.

Note
Default values for affinity and priority are re-configured in the modify flow after promotion of a tunnel.

MPLS TE tunnels discovered with lockdown on working path will lose the lockdown upon being modified and promoted.

Modify a Circuit/VC

You can modify circuits/VCs that are in the following provisioning states: Defined, Deployed, Failed, or Discovered. For more information about the provisioning states, see Circuit or VC States, on page 584.

Note
You cannot change the UNI or endpoint selections. However, you can change the name of the UNI. If you want a different device to be an endpoint, you must delete the circuit/VC and create a new one.

For E-LAN and E-TREE EVCs, you can add or delete endpoints (sites).

To modify a circuit/VC:

Step 1
From the left sidebar, choose Maps > Topology Maps > Network Topology.

The network topology window opens.

Step 2
From the toolbar, click Device Groups and then select the required group.

Step 3
Click the Circuits/VCs tab and then click the radio button for the circuit or VC you want to modify.

Step 4
From the Circuits/VCs pane toolbar, click the pencil (Modify) icon.

The Provisioning Wizard opens and displays information for the selected circuit or VC.
Step 5  Edit the circuit or VC as required, and then redeploy it. See Provision EVCs in a Carrier Ethernet Network, on page 481 and Provision Circuits in an Optical/DWDM Network, on page 496.

Activate a Circuit (Optical)

You can activate an optical circuit to determine if the traffic is passing through it. You can activate circuits that are discovered and deployed in the network. Also, the admin status of the circuit must be Down.

Step 1  From the left side bar, choose Maps > Topology Maps > Network Topology.

Step 2  Click the Device Groups button and select the device group within which the required circuit/VC was created.

Step 3  In the Circuits/VCs tab, locate the optical circuit that you want to activate and click the information icon to access its Circuit/VC 360 view.

Step 4  Choose Actions > Activate to enable the traffic to pass through the optical circuit.

Note  You can also activate the optical circuit from the Circuit/VC Details window and from the multilayer trace view. See View Circuits/VCs, on page 93 and Trace and Visualize the Full Route of Circuits/VCs, on page 635.

Step 5  Redeploy the optical circuit.

You can also choose to deactivate the optical circuit to stop the traffic passing through it. Ensure that the circuit is discovered and deployed in the network and the admin status of the circuit is Up. Click Actions > Deactivate.

Restore a Circuit (Optical)

You can restore an optical circuit when it encounters multiple successive failures and reroute the failed circuit over a new route.

You can restore or revert optical circuits that meet the following conditions:

- Circuit’s provisioning state is Deployed or Discovered.
- The Restoration attribute for the circuit is set to true.
- The Revert mode for the circuit is set to manual or automatic.

To restore an optical circuit:

Step 1  From the left side bar, choose Maps > Topology Maps > Network Topology.

Step 2  Click the Device Groups button and select the device group that contains the failed optical circuit.

Step 3  In the Circuits/VCs tab, locate the failed optical circuit and click the information icon to access its Circuit/VC 360 view.

Step 4  Choose Actions > Restoration Actions > Upgrade Restore to upgrade the failed optical circuit to an active route and delete the old route where the failure occurred.
You can also restore the failed optical circuit from the Circuit/VC Details window and from the multilayer trace view. See View Circuits/VCs, on page 93 and Trace and Visualize the Full Route of Circuits/VCs, on page 635.

You can also choose to revert the optical circuit to its original route when the route is recovered from the failure. Click Actions > Restoration Actions > Manual Revert.

Reroute a Circuit (Optical)

You can reroute a circuit to its working path or protected path so that you can perform network maintenance activities without interrupting the service. The reroute operation is available for all WSON circuits that are provisioned or discovered in Cisco EPN Manager.

Note

The reroute operation is not available for circuits that has the restoration status as "Restored" or "Revertible".

Step 1
From the left side bar, choose Maps > Topology Maps > Network Topology.

Step 2
Click the Device Groups button and select the device group within which the required circuit/VC was created.

Step 3
In the Circuits/VCs tab, locate the optical circuit that you want to reroute and click the information icon to access its Circuit/VC 360 view.

Step 4
Choose Actions > Reroute Actions > Working Path or Protected Path to reroute the traffic through the working path or protected path defined for the circuit.

Note
You can also reroute the optical circuit from the multilayer trace view. See Trace and Visualize the Full Route of Circuits/VCs, on page 635.

Compare and Reconcile Provisioned and Discovered Versions of a Circuit/VC

Note

This functionality is supported for Carrier Ethernet VCs, Circuit Emulation, and Serial services only.

When you provision a circuit/VC using Cisco EPN Manager, the relevant CLI commands are configured on the devices participating in the circuit/VC. After a circuit/VC is provisioned using Cisco EPN Manager, the system discovers the provisioned circuit/VC from the network. In some cases, there might be differences between the provisioned CLI and the discovered CLI, for example, if a configuration change was made on a device after provisioning. Cisco EPN Manager allows you to compare the provisioned and discovered versions of a circuit/VC and generate a reconciliation report showing the differences. Based on the report, you can
decide whether to keep the discovered version or revert back to the provisioned version. If you choose to keep the discovered version, the circuit/VC in the Cisco EPN Manager is synched with this version.

The comparison and reconciliation functionality is accessed from the circuit/VC tables.

The functionality is disabled if the circuit/VC discovery state is Missing or the provisioning state is None, In Progress, or Delete Succeeded.

To compare and reconcile a circuit/VC:

**Step 1** Open a table of circuits/VCs, either the full table of all circuits/VCs in the system (**Inventory > Other > Circuits/VCs and Network Interfaces**) or a list of circuits/VCs for a specific device group (**Maps > Network Topology > Circuits/VCs tab > Circuits/VCs link**).

**Step 2** In the circuits/VCs table, locate and select the required circuit/VC.

**Step 3** Choose **Actions > Reconciliation Report**.

A comparison report is displayed, showing the differences in provisioned and discovered attributes on specific devices in the circuit/VC. If there are no differences between the provisioned and discovered attributes, "No data available" is displayed in the report.

**Step 4** After you have reviewed the report, you can choose to save the discovered version to the database as the current version of the circuit/VC or to revert back to the provisioned version. At the top of the page, select the Provisioned or the Discovered radio button and click **Reconcile**.

If you chose Provisioned, the circuit/VC will be redeployed and the attribute values of the original provisioned circuit/VC will be configured on the devices. If you chose Discovered, the discovered circuit/VC will be stored in the database and this version will replace the original provisioned version. The provisioning status will indicate whether or not the reconcile action was successful.

**Step 5** If the system requires your input in order to complete the reconciliation, the Provisioning Wizard is launched. Fill in the required information and redeploy the circuit/VC.

---

**Initiate a Protection Switch Action on a Circuit (Optical)**

You can initiate a protection switch action on an optical circuit to switch over the traffic from one path to another path. For example, the traffic in an optical circuit is flowing through a working path and the working path is damaged. You can initiate a protection switch action on this circuit to switch over the traffic from the working path to the protected path.

---

**Note** You can initiate protection switch actions only on optical circuits in which the 1+1 or 1+1+R protection type is enabled. For more information about the protection types, see **Circuit Section Reference for OTN Circuit Types**, on page 511.

To initiate a protection switch action:

**Step 1** From the left sidebar, choose **Maps > Topology Maps > Network Topology**.

**Step 2** Click **Device Groups**, and then select the location in which the required circuit/VC was created.
Step 3 Close the Device Groups popup window.

Step 4 In the Network Topology window, click Circuits/VCs.

Step 5 On the Circuits/VCs tab, locate the required circuit/VC and click the icon next to the circuit/VC name. The Circuit/VC 360 view appears in a separate popup window.

Step 6 Choose Actions > Protection Actions, and then choose the required protection switch action.

The following table provides a detailed description of each of the protection switch actions.

<table>
<thead>
<tr>
<th>Protection Switch Action</th>
<th>Description</th>
<th>Applicable when:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Force On Working</td>
<td>Configures the working path to carry traffic over the network.</td>
<td>The current state of the protection switch action is 'Manual On Protect' or 'Manual On Working'.</td>
</tr>
<tr>
<td>Manual On Protect</td>
<td>Switches the traffic manually from the working to the protected path.</td>
<td>There is no protection switch action initiated on the circuit.</td>
</tr>
<tr>
<td>Clear</td>
<td>Clears the protection switch state on the circuit.</td>
<td>The current state of the protection switch action is not 'Lockout On Working'.</td>
</tr>
<tr>
<td>Exercise</td>
<td>Checks if an ODU subcontroller is ready for a protection switch.</td>
<td>There is no protection switch action initiated on the circuit.</td>
</tr>
<tr>
<td>Manual On Working</td>
<td>Switches the traffic manually from the protected path to the working path.</td>
<td>There is no protection switch action initiated on the circuit.</td>
</tr>
<tr>
<td>Action</td>
<td>Description</td>
<td>State Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Lockout On Working</td>
<td>Configures an ODUk subcontroller as a locked out resource in the ODU subcontroller group. Locks the circuit so that its traffic cannot be switched to the working path.</td>
<td>The current state of the protection switch action is not 'Lockout On Working'.</td>
</tr>
<tr>
<td>Clear Lock out</td>
<td>Clears the 'Lockout On Working' switch state for the circuit.</td>
<td>The current state of the protection switch action is 'Lockout On Working'.</td>
</tr>
<tr>
<td>Status</td>
<td>Displays the details of ODU subcontroller group and the protection switch state specified in the AID.</td>
<td>Available for all protected optical circuits.</td>
</tr>
<tr>
<td>Force On Protect</td>
<td>Configures the protected path to carry traffic over the network.</td>
<td>The current state of the protection switch action is 'Manual On Protect' or 'Manual On Working'.</td>
</tr>
</tbody>
</table>

**Resynchronize a Circuit/VC**

When there is any issue with circuit/VC, such as primary or discovery state is down, or the link between the participating devices is missing, you can resynchronize the circuit. Cisco EPN Manager synchronizes the circuit with the participating devices on a best-effort to resolve the issue.

To resynchronize the circuit/VC:

**Step 1**
Access one of the following pages:
- Circuit/VC 360 View. See Get Quick Information About a Circuit/VC: Circuit/VC 360 View, on page 593.
- Circuit/VC Details Window. See Get Comprehensive Information About a Circuit/VC: Circuit/VC Details Window, on page 597.

**Note**
You can resynchronize L3VPN, EVPL and EVC services only from Circuit/VC Details window.
- Multi-Layer Trace View. See Trace and Visualize the Full Route of a Circuit, on page 177

**Step 2**
Choose Actions > Resync.

The discovery state of the circuit will change to Resync when the resync action is in progress. Once the action is completed, the discovery state will change to Full or Partial.

**Service Discovery Resync**

You can resync the supported serial services, IOT CEM and IOT CEM variants X.21 C 3794, MPLS-TE, CE, L3VPN, CEM over T1/E1/E3/T3/SONET/SDH services, if there are any conflict changes on the devices.

In the service 360 view area, from the Action drop-down list, choose Resync to update the related entities. That is you can perform the service resync pertaining to a particular service.
Delete a Circuit/VC

You can choose to either delete or force delete a circuit/VC.

You can delete circuits/VCs that are in the following provisioning states: Create/Modify Succeeded or Create/Modify/Delete Failed.

As a network administrator you can force delete an MPLS TE tunnels and Layer 3 link for the selected services in the circuit VC's window. This option will be available when there is a failure in previous delete operation or a Service is in missing state. You can force delete circuits/VCs that are in the Delete Failed provisioning state. When you force delete a circuit/VC, it is removed from the Cisco EPN Manager database. The circuit/VC will not appear in the circuit/VC tables.

Caution

However, the force delete option may not remove the configurations from all the devices participating in the circuit/VC. You may need to manually clean up the devices.

Note

The force delete option is not available for optical circuits.

To delete or force delete a circuit/VC:

Step 1

From the left sidebar, choose Maps > Topology Maps > Network Topology. The network topology window opens.

Step 2

From the toolbar, click Device Groups and then select the required group.

Step 3

Click the Circuits/VCs tab and then click the radio button for the circuit or VC you want to delete.

Step 4

From the Circuits/VCs pane toolbar, do one of the following:

- From the X (Delete) icon drop-down list, choose Force Delete. A confirmation message is displayed. A corresponding job is created in the Jobs dashboard and you can monitor the progress. After the job is completed, the circuit/VC is removed from the Cisco EPN Manager database.
- Click the X (Delete) icon. The Provisioning Wizard opens and displays information for the selected circuit or VC.

Step 5

Click Next to go to the Service Details page.

Step 6

In the Deploy area, specify what you expect the delete operation to accomplish:

- Delete the circuit or VC from devices and Cisco EPN Manager — This will remove the configurations from all the devices participating in the circuit or VC and will also remove it from the database. The circuit or VC will not appear in the circuit and VC tables and no history will be available for it.
• Delete the circuit or VC from devices only—The circuit and VC history will remain in the database but all relevant configurations will be removed from the devices participating in the circuit or VC.

Note These options are only available in the wizard when deleting an EVC/OVC with "failed" status, for example, "Create failed," Modify failed," and so on.

**Step 7** In the **Deployment Action** field:

- Choose **Preview** to view the configurations that will be deployed to the relevant devices before the actual deployment.
- Choose **Deploy** to deploy the changes without previewing them.

**Step 8** Click **Submit**.

- If you selected **Preview** in the previous step, a Preview Config page is displayed. If you are satisfied with the changes, click **Deploy**.
- If you selected **Deploy** in the previous step, the configurations are deployed to the devices immediately.

A confirmation message is displayed when the deployment is complete.

To view the details of configuration, configuration errors, rollback configuration, and rollback configuration errors for each device participating in the circuit/VC, click the i icon next to the **Provisioning** column in the Deleted Circuits/VCs tab in the extended tables. The i icon is available for all provisioning states, except None. For information about how to access the extended tables, see View Detailed Tables of Alarms, Network Interfaces, Circuits/VCs, and Links from a Network Topology Map, on page 157.

---

**Delete or Force Delete an L3VPN Service**

You can delete or force delete L3VPN services that were originally created using Cisco EPN Manager. L3VPN services that were only discovered but not created using Cisco EPN Manager cannot be deleted.

To delete or force delete an L3VPN service:

**Step 1** In the left pane, choose **Maps > Network Topology**.

**Step 2** In the Circuits/VCs panel, click the **Circuit/VCs** link to display all services in Cisco EPN Manager.

**Step 3** Select the service that you want to delete or force delete. You can type the service's name in the **Name** filter to filter out the required L3VPN service and click the X (Delete) icon.

**Step 4** Alternately, from the Circuits/VCs pane toolbar, do one of the following:

a) Choose the service that you want to delete and click the X (Delete) icon.

The Provisioning Wizard opens and displays information for the selected circuit or VC.

Click Next to proceed to the Service details.

The L3VPN Provisioning wizard displays the VRFs, endpoints, and other details associated with the selected L3VPN.

b) From the X (Delete) icon drop-down list, choose **Force Delete**. A confirmation message is displayed. A corresponding job is created in the Jobs dashboard (Administration > Dashboard > Job Dashboard > User Jobs > Force Delete...
Circuit) and you can monitor the progress. After the job is completed, the Layer 3 link is removed from the Cisco EPN Manager database.

Also, use the Force Delete option when you are not able to proceed with the Service deletion from the GUI.

**Step 5** Select **Submit** to preview the configuration that is to be pushed on the device.

**Step 6** Review the configuration and click **Deploy** to confirm. A confirmation message is displayed when the deployment is complete.

The selected L3VPN service is deleted from the device.

**Note** If the selected L3VPN service uses integrated routing and switching (BVI/virtual interfaces), then deleting the L3VPN service automatically deletes the associated BVI/virtual interface from the device. The BGP and VRF settings associated with the L3VPN service are also deleted.

**Step 7** To verify that the selected L3VPN was deleted from the device, view the complete list of L3VPN services from the Circuits/VCs list.

**Step 8** To view the device configurations of the force deleted services, click the * icon next to the Provisioning column in the **History** tab in the **Deleted Circuit/VCs** tab. In the Circuit /VC 360* View window, click the * icon that is available for all provisioning states, except **None** to view the configuration details of the selected devices.
Delete an L3VPN Service Endpoint

You can delete L3VPN service endpoints for L3VPN services created using Cisco EPN Manager. Endpoints associated with L3VPN services that are discovered but not created using Cisco EPN Manager cannot be deleted.

To delete an L3VPN service endpoint:

Step 1 In the left sidebar, choose Maps > Network Topology.
Step 2  In the Circuits/VCs panel, click the Circuit/VCs link to display all services in Cisco EPN Manager.
Step 3  Select the service that you want to delete. You can type the service's name in the Name filter to filter out the required L3VPN service.
Step 4  Click the pencil Modify icon.
   The L3VPN Provisioning wizard displays the VRFs, endpoints, and other details associated with the selected L3VPN.
Step 5  Choose Delete Endpoint and click Next.
Step 6  Choose the IP endpoints that must be disassociated from the selected L3VPN service. For single endpoint VRFs, deleting the endpoints turns the VRF ineffective and the VRF then acts as a dangling VRF. To associate newer endpoints with this ineffective VRF, you need to further edit the VRF's attributes.
Step 7  Click Next to preview the configuration that will be pushed to the device.
Step 8  Review the configuration and click Deploy to confirm and deploy your changes to the device.

The selected L3VPN service endpoint is deleted from the device.

---

Delete or Force Delete an MPLS TE Service

You can delete or force delete MPLS TE services that are in the following provisioning states: Planned, Succeeded, Failed, or None. For more information about the provisioning states, see Circuit or VC States, on page 584.

---

You cannot delete an MPLS TE service if it is being used by a CEM service or a Carrier Ethernet circuit/VC.

---

Step 1  From the left pane, choose Maps > Topology Maps > Network Topology.
Step 2  Click Device Groups, and then select the location in which the required circuit/VC was created.
Step 3  Close the Device Groups popup window.
Step 4  In the Network Topology window, click Circuits/VCs.
Step 5  In the Circuits/VCs tab, click the Circuits/VCs hyperlink located below the list of circuits/VCs.
Step 6  In the displayed table of circuits/VCs, select the MPLS TE service that you want to delete.
Step 7  Click the delete icon or Force Delete to open the Provisioning Wizard and display information for the selected MPLS TE service.
Step 8  From the Deployment Action drop-down list, choose one of the following option:
   • Preview—View the configurations that will be deployed to the relevant devices before the actual deployment.
   • Deploy—Deploy the changes without previewing them.
Step 9  Click Submit.
   • If you selected Preview in the previous step, Cisco EPN Manager displays a Preview Config page. If you are satisfied with the changes, click Deploy.
   • If you selected Deploy in the previous step, Cisco EPN Manager deploys the configurations to the devices immediately.
To view the details of device configuration of the force deleted services, click the i icon next to the Provisioning column in the History tab in the Circuit/VC 360* window. The i icon is available for all provisioning states, except None.

Cisco EPN Manager displays a confirmation message when the deployment is complete.

Manage Provisioned Network Interfaces

Cisco EPN Manager provides a table of interfaces that have been provisioned as network interfaces (UNIs or ENNIs) so that you can view details for and manage network interfaces independently of provisioned circuits/VCs. The table provides information about each network interface, including its identifying information, the device it belongs to, the actual interface on the device, and the number of services in which the network interface is currently participating.

You can view:

• The network interfaces in a specific device group (from the Network Topology window).

• All network interfaces managed by Cisco EPN Manager (from the Inventory menu).

You can edit a network interface by clicking the Edit button. This launches the wizard where you can make changes to the network interfaces as required. Keep in mind that if the network interface is associated with multiple services, your edit operation will affect all of those services.

You can delete a network interface as long as it is not participating in any circuits.

---

Step 1 To view and manage the network interfaces that belong to a specific device group:

a) In the left sidebar menu, choose Maps > Topology Maps > Network Topology.

b) Click the Device Groups button and select the required group.

c) In the Circuits/VCs tab, click the Network Interfaces hyperlink (below the table).

Step 2 To view and manage all network interfaces managed by Cisco EPN Manager, choose Inventory > Other > Network Interfaces.

---

Delete Network Interfaces

From the Network Interfaces table, you can delete a UNI/ENNI if it is not currently participating in any circuits.

To delete a network interface:

---

Step 1 In the left sidebar, choose Maps > Topology Maps > Network Topology.

Step 2 Click the Device Groups button and select the required group.

Step 3 In the Circuits/VCs tab, click the Network Interfaces hyperlink to display the Network Interfaces table.
Step 4  Select the network interface you want to delete and click the **Delete** button. If the network interface is participating in one or more circuits/VCs, the Delete button will be disabled. In the No. of Circuits/VCs column, you can see the number of circuits/VCs in which the network interface is included.
Check Circuits/VCs for Faults

Cisco EPN Manager provides several ways to see, at a glance, if there are any problems with circuits/VCs:

- Circuit list—The colored icon to the left of each circuit/VC name indicates the primary state of the circuit/VC. If the primary state indicates a problem with the circuit/VC, you can access detailed alarm information for the circuit/VC, as described below.

- Circuit/VC 360 view—The Alarms tab in the Circuit/VC 360 view shows all alarms on all devices over which the circuit/VC is configured. Click the information icon next to the circuit/VC name to access the Circuit/VC 360 view.

- Alarm Table—The alarm table shows all alarms for all devices, for a specific device group, or for a specific device. Choose Monitor > Monitoring Tools > Alarms and Events to access the alarm table. If you have identified an alarm in the Circuit/VC 360 view, you can get more details about the alarm in the alarm table. You can search for the alarm or for the device/link that generated the alarm using the quick filter or the advanced filter. Each alarm in the table can be expanded to show detailed information about the alarm, including which circuits/VCs are affected by the alarm.

- Circuit/VC Overlay in the Network Topology—When a circuit/VC is selected in the Circuits/VCs list, it is represented on the network topology as an overlay on top of the existing topology. If the alarm is on a specific device, the alarm badge will appear on the device as usual. If the alarm is on the link between the circuit/VC endpoints, the alarm badge will appear on the link.

- Multi-layer trace for optical circuits—See Trace and Visualize the Full Route of Circuits/VCs, on page 635.
Identify Which Circuits/VCs are Affected by a Specific Fault

To identify which circuits/VCs are affected by a specific fault:

**Step 1** From the left side bar, choose Monitor > Monitoring Tools > Alarms and Events.

**Step 2** In the alarm table, locate the required alarm. You can use the simple or advanced filters to locate the alarm, if necessary.

**Step 3** Click on the arrow to the left of the row to expand the row and display the alarm details.

**Step 4** Locate the Impacted Circuits/VCs pane. All circuits/VCs that are affected by the selected alarm are listed in this pane, with basic information for each circuit/VC. You can access the Circuit/VC 360 view to get more details about the circuit/VC by clicking the *i* icon.

**Step 5** If necessary, you can modify or delete the circuit/VC from the Impacted Circuits/VCs pane by selecting a circuit/VC and clicking the Modify or Delete button. This opens the Provisioning Wizard. See Modify a Circuit/VC, on page 606 and Delete a Circuit/VC, on page 612 for more information.
Get More Information About a Circuit/VC Failure

Cisco EPN Manager provides information about why the provisioning operation of a circuit/VC has failed so that you can troubleshoot the issues. In the Circuits/VCs table, you can identify problems with a circuit/VC by looking at the Provisioning state and the Serviceability and Discoverystates. If there has been an error during the provisioning of a circuit/VC and the circuit/VC could not be created, the Provisioning state will be Create Failed. You can click the i icon in the Provisioning column to see the configuration of the devices involved in the failure, as well as details about the specific error(s) that occurred.

For optical circuits, the combination of Serviceability state Down and Discovery state Partial can indicate a problem with the circuit. In this case, you can click the i icon in the Serviceability column to see the reason that the Serviceability state is Down.
Information about a circuit/VC failure can also be accessed from the Circuit/VC 360 view. See Get Quick Information About a Circuit/VC: Circuit/VC 360 View, on page 593.

To view additional information about a circuit/VC provisioning failure from the Circuits/VCs table:

Step 1  From the left sidebar, choose Maps > Topology Maps > Network Topology.

Step 2  In the Network Topology window, click the Circuits/VCs tab, and then click the Circuits/VCs hyperlink. A table listing all the circuits is launched in a separate window.

Step 3  Locate the circuit for which the provisioning operation has failed. The Provisioning state will be Create Failed.

Step 4  Click the i icon next to the Provisioning column. A popup window is displayed and lists the devices on which the provisioning errors occurred.

Step 5  Select a device to see its configuration and error details.

Step 6  Click the i icon next to the Serviceability column to view the Serviceability Details data pop-up window that displays information about why the provisioning operation has failed for the circuit.

Note  The i icon is available only if the serviceability status is down and the discovery status is partial.

For optical circuits, if the Serviceability state is Down and the Discovery state is Partial, click the i icon next to the Serviceability column to view the Serviceability Details data pop-up window that displays information about why the circuit's serviceability state is Down. You can also view the Serviceability Details data pop-up window from the Circuit/VC 360 view. For information about how to access the Circuit/VC 360 view, see Get Quick Information About a Circuit/VC: Circuit/VC 360 View, on page 593.

Troubleshoot a Service Failure Using OAM Commands

Cisco EPN Manager provides the ping and traceroute features to troubleshoot service failures. You can use OAM commands to access these features and monitor the connectivity and path between two endpoints in a
service. You can then isolate and resolve the failure. The technologies that are supported for the different IOS devices are:

- MPLS LSP, Pseudowire and CFM: Cisco IOS-XE and Cisco IOS-XR
- MPLS Bidirectional TE Flex LSP and VRFs: Cisco IOS-XE

The launch points for the OAM command vary based on:

- Technology type—Launching from Network Devices Table, on page 623 (This launch point for OAM commands is supported only for the MPLS LSP technology.)
- Service type—Launching from Circuit 360, on page 623
- Event type—Launching from Alarm Browser, on page 624

You can perform ping or traceroute using the OAM commands to troubleshoot a service failure. See Perform a Ping or Traceroute Using OAM Command, on page 625

### Launching from Network Devices Table

To launch MPLS LSP technology OAM command from Network Devices table:

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Step 2</th>
<th>Step 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose <strong>Inventory &gt; Device Management &gt; Network Devices</strong>.</td>
<td>In the Network Devices table, select a MPLS enabled device.</td>
<td>Click the &gt;&gt; icon above the Network Devices table and select <strong>OAM Commands</strong>.</td>
</tr>
</tbody>
</table>

### Launching from Circuit 360

If you are launching OAM command from the Service/Circuit 360, the service type is the criteria that determines the technology that is supported. See Overview of Circuit/VC Discovery and Provisioning, on page 457 to know in detail about the different service types.

To launch OAM command from Circuit 360:

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Step 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose <strong>Maps &gt; Topology Maps &gt; Network Topology</strong>.</td>
<td>In the <strong>Network Topology</strong> window, click the <strong>Circuits/VCs</strong> tab and click the icon next to the circuit to view the Circuit 360. Based on the service type of the circuit you selected, the supported technology OAM commands as mentioned in this table are displayed.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Service Type for which you can launch the OAM command:</th>
<th>Technology supported</th>
</tr>
</thead>
<tbody>
<tr>
<td>Carrier Ethernet</td>
<td>• MPLS LSP</td>
</tr>
<tr>
<td></td>
<td>• Pseudowire</td>
</tr>
<tr>
<td></td>
<td>• CFM</td>
</tr>
<tr>
<td>Circuit Emulation (CEM)</td>
<td>• MPLS LSP</td>
</tr>
<tr>
<td></td>
<td>• Pseudowire</td>
</tr>
<tr>
<td></td>
<td>• Bidirectional TE (Flex LSP)</td>
</tr>
</tbody>
</table>
### Launching from Alarm Browser

If you are launching OAM command from the alarm browser, the event type is the criteria that determines the technology that is supported.

To launch OAM command from an alarm browser:

**Step 1** Choose **Monitor > Monitoring Tools > Alarms and Events**.

**Step 2** In the Alarms table, select an alarm with an event type listed in the "Event Type for which you can launch the OAM command" column in this table.

**Step 3** Click **Troubleshoot** above the Alarms table and select **OAM Commands**.
Perform a Ping or Traceroute Using OAM Command

To perform a ping or traceroute using OAM command:

Step 1
Launch the *Technology OAM Command* window. See *Troubleshoot a Service Failure Using OAM Commands*, on page 622 for the OAM command launch points for the supported technologies.

Step 2
Based on the launch point, select the required fields as displayed in this table for the selected technology type.

<table>
<thead>
<tr>
<th>Technology Type</th>
<th>Launched from Alarm Browser</th>
<th>Launched from Service/Circuit 360</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pseudowire</td>
<td>Details are auto-populated</td>
<td>From the <em>Pseudowire Endpoint</em> drop-down list, choose the endpoint participating in the service.</td>
</tr>
<tr>
<td>MPLS LSP</td>
<td>From the <em>Destination LDP ID</em> drop-down list, choose the LDP ID of the destination endpoint participating in the service.</td>
<td>From the <em>Source LDP ID</em> and <em>Destination LDP ID</em> drop-down lists, choose the LDP ID of the source and destination endpoints participating in the service.</td>
</tr>
<tr>
<td>MPLS Bidirectional TE Tunnel (Flex LSP)</td>
<td>Choose the tunnel's path as <em>Active</em>, <em>Working</em>, or <em>Path-Protect</em> for which you want to perform a ping or traceroute. Cisco EPN Manager performs the ping or traceroute on both directions, that is, from headend to tailend and vice versa.</td>
<td>Choose the tunnel's path as <em>Active</em>, <em>Working</em>, or <em>Path-Protect</em> for which you want to perform a ping or traceroute. Cisco EPN Manager performs the ping or traceroute on both directions, that is, from headend to tailend and vice versa.</td>
</tr>
<tr>
<td>VRF in L3VPN</td>
<td>From the <em>End Points</em> drop-down list, choose the endpoint of another VRF that belongs to the same VPN.</td>
<td>From the <em>Source End Points</em> and <em>Destination End Points</em> drop-down lists, choose the source and destination endpoints of another VRF that belongs to the same VPN.</td>
</tr>
<tr>
<td>CFM in Carrier Ethernet</td>
<td>From the <em>Destination MEP ID</em> drop-down list, choose the MEP ID of the destination endpoint participating in the service.</td>
<td>From the <em>Source MEP ID</em> and <em>Destination MEP ID</em> drop-down lists, choose the MEP IDs of the source and destination endpoints participating in the service.</td>
</tr>
</tbody>
</table>

Step 3
Choose *Actions > Ping* to perform a ping, and choose *Actions > Traceroute* to perform a traceroute.

The results of the ping and traceroute commands are displayed in the following formats:

- For MPLS bidirectional TE tunnels, the results are displayed for both directions, that is, from headend to tailend and vice versa.
- For Pseudowire, the results are displayed in visual and tabular formats and as raw data.
Use EOAM Templates to Troubleshoot EVCs

Cisco EPN Manager provides several predefined templates that can be used to monitor the connectivity and performance of virtual connections (VCs) in a Carrier Ethernet network. To use these templates, choose Configuration > Templates > Features & Technologies > CLI Templates > System Templates - CLI. See Perform EOAM Connectivity and Performance Checks, on page 390 for more information.

Run a Performance Test on a Circuit/VC

When you run a performance test, Cisco EPN Manager connects to the network elements to provide real-time data. To get historical information, see View Performance Metrics and Reports for Circuits/VCs, on page 634.

Performance Test Based on Y.1564 for EVCs

CE performance tests verify the correct configuration and performance of CE EVCs at the time of activation. You can also use the CE performance tests to troubleshoot an EVC that is already in operation.

The Y.1564 Ethernet service activation or performance test methodology allows turning up, installing, and troubleshooting Ethernet-based services. Using this test, you can verify the service configuration and
performance from UNI to UNI. This ensures that the SLA will be met according to the bandwidth profile purchased, and the promised class of service.

These tests provide complete validation of Ethernet service-level agreements (SLAs) in a single test. Using a traffic generator performance profile, you can create the traffic based on your requirements. The network performance, such as throughput, loss, and availability, are analyzed using Layer 2 traffic with various bandwidth profiles.

---

**Note**

You can only run performance tests on EVCs that are configured on the network and discovered by Cisco EPN Manager.

---

**Supported Devices**

The Y.1564 performance test is supported on the following devices running IOS 15.4(S) or IOS XE 3.12S and higher:

- List of devices that can be specified as either source or destination:
  - Cisco ASR 920
  - Cisco ASR907 with RSP3 as both source and destination (loopback)
  - Cisco ASR903 with RSP2, RSP3 as both source and destination (loopback)
  - Cisco ASR 901
  - Cisco ASR9K (as loopback)
  - Cisco NCS 4201
  - Cisco NCS 4202
  - Cisco NCS 4206
  - Cisco NCS 4216
  - NCS540 (as a loopback)
  - Cisco NCS55xx (as loopback)
  - Cisco ME 1200
  - Cisco ME 3600
  - Cisco ME3800 (loopback)

- List of devices that can be specified as destination (loopback) only:
  - Cisco ME3800X
  - Cisco NCS 4206
  - Cisco ASR 903 RSP/RSP1
Running a Y.1564 Performance Test

To run a Y.1564 performance test on an EVC, do the following:

Before you begin

If you want to run a Y.1564 performance test on an EVC that resides on a ME1200 device, enter the following QoS configuration on both the source and destination interfaces before you run the test:

```
Interface <interface-name>
qos map tag-cos pcp 0 dei 0 cos 0 dpl 0
qos map tag-cos pcp 0 dei 1 cos 0 dpl 1
qos map tag-cos pcp 1 dei 0 cos 1 dpl 0
qos map tag-cos pcp 1 dei 1 cos 1 dpl 1
qos map cos-tag cos 0 dpl 0 pcp 0 dei 0
qos map cos-tag cos 0 dpl 1 pcp 0 dei 1
qos map cos-tag cos 1 dpl 0 pcp 0 dei 0
qos map cos-tag cos 1 dpl 1 pcp 0 dei 1
```

Step 1 Choose Maps > Topology Maps > Network Topology to open the Network Topology page.

Step 2 From the toolbar, click Device Groups to open the Device Groups pop-up window.

Step 3 Locate and click the device group that contains the circuit/VC you want to test, then close the pop-up window.

Step 4 Click the Circuits/VCs tab, locate the relevant service, and then click its i (information) icon to open its Circuit/VC 360 view.

Step 5 From the top right corner of the view, choose Actions > Y.1564 Test to open the Y.1564 performance test settings page.

Note This test can also be initiated from the Circuit/VC tab in a device's Device 360 view and the Circuits/VCs & Network Interfaces page. See View a Device Group's Circuits/VCs, on page 600 and View Circuits/VCs, on page 93.

Step 6 Configure the settings for the performance test:

a) In the Test Mode field, specify whether this will be a one- or two-way test by clicking the appropriate radio button. Note that in the case of a two-way test, loopback will be created on the service instance of the destination device.

b) In the End Points area, choose the source and destination device, interface, and EFP ID from the drop-down lists.

  c) In the Service Configuration Test area, specify the duration of each iteration, the size of packets to be generated, and the rate at which traffic will be generated.

  - If you choose the CIR/EIR radio button, specify values (in kilobits per second) for the Committed Information Rate (CIR) and Excess Information Rate (EIR). The CIR is the long-term average transmission rate, whereas the EIR is the long-term average excess transmission rate.

  - If you select the Color Aware Test check-box, specify the Class of Service (CoS) values between 0 to 7 for the Conform Action and Exceed Action. The CoS values must be set different for Conform Action and Exceed Action to differentiate and prioritize the traffic. Also, you may specify the values (in kilobytes per second) for the Committed Burst Size (CBS) and Excess Burst Size (EBS) to define the committed or excess traffic that can be transmitted in bursts at temporary rates above the CIR.

Note The Color Aware Test check-box will be enabled only for FPGA enabled devices with 10G ports. “Color Aware” is used to describe the mode where the customer is marking each frame as green or yellow, and the network takes this marking into account at the bandwidth profiler and traffic policer.
• If you check the **Step Load CIR** check box, the test will generate traffic at four different levels: 25, 50, 75, and 100% of the CIR value you specify. Note that this option is not available if the CIR is set to a value lower than 8 kbps.

• If you choose the **Custom Rates** radio button, 1000 kbps is set by default. Change this value, if necessary.

• If you are running a one-way performance test, you can only specify a custom traffic rate.

d) In the **Service Acceptance Criteria** area, enter the highest acceptable frame loss ratio value (in percent) in the **FLR** field.

   • If you also want to set a frame transfer delay (FTD) and frame delay variation (FDV) value, check the corresponding check box and then enter the appropriate value (in milliseconds).

   • If any of the thresholds you set are exceeded during the performance test, the EVC will be deemed as having failed the test.

e) (Optional) In the **Frame Settings** area, specify values for the following parameters:

   • IP version—IPv4 or IPv6

   • Inner and outer VLAN ID—Identify the source and destination VLAN ID you want to test

**Step 7**  
Click **Run Test**.

When the test is completed, the results are displayed at the bottom of the Y.1564 performance test settings page.

---

**Performance Test Based on Y1731 for EVCs**

The Y.1731 Performance Monitoring (PM) provides a standard ethernet PM function that includes measurement of ethernet frame delay, frame delay variation, frame loss, and frame throughput measurements specified by the ITU-T Y-1731 standard and interpreted by the Metro Ethernet Forum (MEF) standards group. Using this test, you can verify the delay and loss measurements such as the delay and loss probe status, delay and loss probe availability, two-way delay, two-way jitter, loss forward, and loss backward for your circuit/VC.

**Note**  
This performance test is supported on Cisco IOS, IOS-XR and IOS-XE devices.

**Before you begin**

Following are the prerequisites that must be met before you run a performance test based on Y.1731 for a circuit/VC:

• The circuit/VC, along with the participating devices, on which you want to run the performance test, must be operationally up.

• Ensure that the MEP ID matches the domain name for all the devices participating in the circuit/VC.

**Step 1**  
From the left sidebar, choose **Maps > Topology Maps > Network Topology**.
**Performance Test for Optical Circuits**

Cisco EPN Manager performance test for optical circuits is based on the ITU-T recommendations as defined in G.709 and G.798.

Cisco EPN Manager supports the following performance tests for Optical Circuits:

- Optical Performance Monitoring Parameters, on page 630
- Run PRBS Test on Circuits (ODU UNI), on page 631

**Optical Performance Monitoring Parameters**

Optical Performance Monitoring Parameters monitor the quality of optical signals and are used to measure the average optical power transmitted and received between end points in optical circuits. From these
measurements, you can derive critical network performance parameters such as channel presence verification, channel wavelength, ASE noise, optical signal power, and optical signal to noise ratio (OSNR) per channel. You can then use these parameters to manage the network reliability and quality of service.

Follow the steps below to view the performance monitoring parameters for an optical circuit:

**Step 1**
From the left sidebar, choose **Maps > Topology Maps > Network Topology**.

**Step 2**
Select the device group that contains the circuit/VC you want to test.

**Step 3**
In the Circuits/VCs pane on the left, locate the required service and click the i icon to access its Circuit/VC 360 view.

**Step 4**
Choose **Actions > Optical PM Parameters**.

*Note*  
The performance test can also be initiated from the circuit/VC details window and from the expanded list of circuits/VCs. See View a Device Group's Circuits/VCs, on page 600 and View Circuits/VCs, on page 93.

**Step 5**
Select an optical monitoring type based on which the performance data will be displayed. For more information about the optical monitoring types and the associated performance counters, see Performance Counters for Optical Monitoring Policies, on page 888.

**Step 6**
Choose the performance monitoring time interval as 15 minutes or 24 hours to collect the performance data from the device.

**Step 7**
Specify the time interval to automatically refresh the performance data.

**Step 8**
Click **Auto Refresh**. The performance data for the circuit is displayed as a tabular representation. For the detailed descriptions of the performance data, see Performance Counters for Optical Monitoring Policies, on page 888.

Based on the time interval specified to refresh the performance data, the newly retrieved data is displayed at the beginning of the table. For example, if the time interval specified is 10 seconds, the performance data is automatically refreshed every 10 seconds and the newly retrieved data is displayed at the beginning of the table. The table displays the last 20 entries of the performance data retrieved.

---

**Run PRBS Test on Circuits (ODU UNI)**

PRBS test is supported for OTN Circuits of type ODU UNI. PRBS bit error count measures the reliability of the link between the endpoints. This test is supported for NCS4K-20T-O-S cards. When PRBS test is run between 2 endpoints (ODU Controller or sub-controller), the source device sends a bit pattern through one or more midpoints (intermediate controller or sub-controller) and the same bit pattern is received by the destination device, the test results can be viewed from both the endpoints. You can also run the PRBS test on a controller, configuring the other endpoint as a loopback, source, or source-sink.

For information on configuring PRBS on an ODU controller, see Configure PRBS on ODU Controllers, on page 326.

To run a PRBS performance test for an optical circuit:

**Step 1**
From the left sidebar, choose **Maps > Topology Maps > Network Topology**.

**Step 2**
Select the device group that contains the circuit/VC of type ODU UNI you want to test.

**Step 3**
In the Circuits/VCs pane on the left, locate the required service and click the i icon to access its Circuit/VC 360 view.

**Step 4**
Choose **Actions > PRBS Test**.
Step 5 To assign roles to the endpoints, in the Endpoint table, click the endpoint's role and select one of the following options from the drop-down list:

- SOURCE—To set this role to either A or Z side.
- SINK—To set this role to either A or Z side.
- SOURCESINK—To set this role either to A side, Z side, or both.
- INVALID—To disable PRBS on the endpoint.

Step 6 To assign patterns to the endpoints, in the Endpoint table, click the endpoint's pattern and select the desired pattern from the drop-down list.

Following patterns are supported for NCS4K-20T-O-S cards:

- PRBS 31
- PRBS 31 Inverted
- PRBS 11
- PRBS 11 Inverted

Step 7 To change the loopback mode, in the Loopbacks table, click the endpoint's or midpoint's loopback mode and select one of the following options from the drop-down:

- NO_LOOPBACK—For testing without loopback.
- INTERNAL—For testing within the same network.
- LINE—For testing across different network.

Step 8 In the Test Results area, select the endpoint from the Sink Controller drop-down list.

Step 9 Click one of the following Interval radio button, to set the time interval to collect the data from the device:

- Current (every 10 seconds)—Displays past 15 minutes results every 10 seconds.
- 15 Minutes—Displays past 15 minutes historic performance data.
- 1 Day—Displays past 1 day historic performance data.

Step 10 Click Go.

Step 11 Click Auto Refresh. The test result for the endpoints is displayed as a tabular representation which includes bit error count, packets lost and found timestamps and packet lost and found counts.

Based on the time interval specified to refresh the test, the newly retrieved data is displayed at the beginning of the table. For example, if the time interval specified is 10 seconds, the data is automatically refreshed every 10 seconds and the newly retrieved data is displayed at the beginning of the table.

Performance Test for Circuit Emulation Services

Bit error rate test (BERT) allows you to test cables and diagnose signal problems in the field. This testing mechanism is supported on the Cisco NCS 42xx Series(T1/E1 Ports). This test generates a specific pattern on to the outgoing data stream of a circuit controller and then analyzes the incoming data stream for the same pattern. The bits that do not match the expected pattern are counted as bit errors.
The bit error rate is determined by comparing the erroneous bits received with the total number of bits received. You can view and analyze the total number of error bits transmitted and the total number of bits received on the circuit. You can retrieve error statistics anytime during the test.

The following table lists the test patterns supported in Cisco NCS 42xx series (T1/E1 Ports) devices.

<table>
<thead>
<tr>
<th>BERT Pattern</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0s</td>
<td>Test pattern consisting of all 0's that is used to test line coding.</td>
</tr>
<tr>
<td>1s</td>
<td>Test pattern consisting of all 1's that is used to test alternating line volt and repeaters.</td>
</tr>
<tr>
<td>$2^{11}$</td>
<td>Pseudo-random repeating test pattern that consists of 2,048 bits.</td>
</tr>
<tr>
<td>$2^{15}$</td>
<td>Pseudo-random repeating test pattern that consists of 32,767 bits.</td>
</tr>
<tr>
<td>$2^{20}$-O153</td>
<td>Pseudo-random repeating test pattern that consists of 1,048,575 bits.</td>
</tr>
<tr>
<td>$2^{20}$-QRSS</td>
<td>Pseudo-random QRSS O.151 test pattern that is 1,048,575 bits in length.</td>
</tr>
<tr>
<td>$2^{23}$</td>
<td>Pseudo-random 0.151 test pattern that is 8,388,607 bits in length.</td>
</tr>
<tr>
<td>alt-0-1</td>
<td>Repeating alternating pattern of zeros and ones.</td>
</tr>
</tbody>
</table>

To run a BERT performance test for a CEM circuit:

**Step 1** From the left sidebar, choose **Inventory > Others > Circuits/VCs & Network Interfaces.**

**Step 2** In the **Circuits/VCs** tab, locate the required CEM service and click the i icon to access its Circuit/VC 360 view. In the Circuit/VC 360 view, choose **Actions > Performance Test > BERT.** Alternatively, you can reach this page through **Maps > Topology Maps > Network Topology** and from the **Circuits/VCs** pane, access the Circuit/VC 360 view of the required CEM circuit.

**Step 3** In the **Test** tab, select the test direction, source and destination. For easy understanding, the pictorial representation of the test in the circuit is displayed, once the source and destination are selected.

**Step 4** To refresh the test data automatically for a defined time interval, in the **Settings** area, enter the time interval in minutes.

**Step 5** Select the pattern from the **BERT Pattern** drop-down list.

**Step 6** You can deliberately inject errors in the frame by specifying the value in **Inject Errors** field and then click **Run Test.** The test result is displayed in the **Test Results** area. See View and Export the Results of the Performance Test on Circuit Emulation Services, on page 633.

**Step 7** To terminate the test, in the **Settings** area, click **Stop** and click **Clear Counters** to reset the values in the **Test Results** area.

**View and Export the Results of the Performance Test on Circuit Emulation Services**

At a time, BERT performance test can be performed on any number of CEM circuits but only one test can be performed on a single CEM circuit. The results of the BERT performance test on a CEM circuit is displayed in the **Test Results** area.
• At any point in time, the results of last run/currently running BERT performance test on a CEM circuit is displayed in the Test Results area in the Test tab.

• If the Auto-refresh is enabled (ON), then the test results are auto-refreshed at the specified time period.

• In the Test Results area:
  • No test results are displayed, when an Unmanaged Endpoint is chosen as destination for a test.
  • Two set of test results are displayed, each for an endpoint, when a Managed Endpoint is chosen as destination.

• Choose Monitor > Performance Tests > BERTs. Here, only a single entry for each CEM circuit is available and it shows either the last run/currently running test on that CEM circuit. Select the required CEM circuit to view its test results.

• To view the historical records of BERT performance results for a specific CEM circuit, in the History tab, select the required test from the Test drop-down list to view the configuration and its result.

You can export the results of a BERT performance test by clicking the Export icon at the top right corner of the Test and History tabs of the BERT page (from the Circuit/VC 360 view, choose Actions > Performance Test > BERT).

You can also export the list of BERT performance tests from the following pages:

• Select BERT Test pop-up window (from the BERT page, click the History tab, and then click the Test drop-down list to open the Select BERT Test pop-up window).

• BERT listing page (choose Monitor > Performance Tests > BERTs).

View Performance Metrics and Reports for Circuits/VCs

The Circuit/VC 360 view provides information about the circuit's recent history. Reports, on the other hand, can retrieve all historical data stored in the database. For real-time information, run a performance test (see Run a Performance Test on a Circuit/VC, on page 626).

• View Performance Graphs in the Circuit/VC 360 View, on page 634
• Use Performance Reports to Monitor and Troubleshoot Circuits/VCs, on page 635
• Use Service Performance Dashboard to Monitor Circuits/VCs, on page 635

View Performance Graphs in the Circuit/VC 360 View

The Circuit/VC 360 view contains graphs showing various aspects of the circuit/VC performance. This view is helpful if you want to see, at-a-glance, if there are any major issues with circuit/VC performance. For more information, see Get Quick Information About a Circuit/VC: Circuit/VC 360 View, on page 593.

To access the Circuit/VC 360 view:

**Step 1** From the left side bar, choose Maps > Topology Maps > Network Topology. The network topology window opens.

See Visualize the Network Topology, on page 155 for a description of the Network Topology window and its functionality.

**Step 2** In the Locations pane on the left, select the device group within which the required circuit/VC was created.
Step 3
In the Circuits/VCs pane, locate the required circuit/VC and click on the i icon next to the circuit/VC name. The Circuit/VC 360 view appears in a separate popup window.

Use Performance Reports to Monitor and Troubleshoot Circuits/VCs

Cisco EPN Manager provides extensive reporting capabilities that enable you to retrieve in-depth performance information for optical circuits and EVCs. The Report Launch Pad provides access to all Cisco EPN Manager reports. From the Report Launch Pad, you can create and save new reports, view current reports, open specific types of reports, schedule a report to run later, and customize the results of a report.

Choose Reports > Report Launch Pad in the left navigation pane to access the reports and the reporting functionality.

For information about Carrier Ethernet performance reports, see Carrier Ethernet Performance Reports, on page 260.

For information about Optical performance reports, see Optical Performance Reports, on page 267.

Use Service Performance Dashboard to Monitor Circuits/VCs

Service Performance dashboard provides a collection of graphical and tabular representation of Performance measurement for the selected circuit/VC over time. This information is available in the form of customized dashlets. The dashboard menu provides access to all the available Cisco EPN Manager dashboards.

From Service Performance Dashboard, you must select a circuit/VC from the Circuits/VCs drop-down list to view the following information (dashlets):

- Average availability of service endpoints over time.
- Incoming and outgoing traffic measured in bits per second, for services over a specified time period.
- Average delay between the service endpoints over time.
- Average packet loss ratio between the service endpoints over time.
- List of services with highest incoming and outgoing traffic.

To launch the dashboard for a specific service from its Circuit/VC 360 view, click View and then choose Dashboard.

For more information on the Service Performance dashboards and dashlets, see Service Performance Dashboard Overview, on page 7.

For more information on managing dashboards and dashlets, see Get Started With Cisco EPN Manager, on page 1.

Trace and Visualize the Full Route of Circuits/VCs

Use the Multilayer Trace view (MLT) to visualize a circuit in a graphical manner. This view displays the complete circuit span and service trace between two endpoints and can be used to trace the connectivity of a circuit by displaying the source node, the destination node, and any intermediate nodes in graphical format.

Note the following:
• Multilayer Trace view is not supported for Multipoint Carrier Ethernet circuits/VCs, Serial and L3VPN services.

• You can launch the Multilayer Trace view for optical circuits only when LMP is configured on the A end device and also between devices participating in the optical circuit.

• For MPLS-TE tunnels, physical topology is required for the Multilayer Trace view, meaning that the physical links must have been discovered using one of the supported protocols, for example, CDP or LLDP.

To trace and visualize the full route of a circuit:

**Step 1**
From the left sidebar, choose **Maps > Topology Maps > Network Topology**.

**Step 2**
Click **Device Groups** and then select the location in which the required circuit/VC was created.

**Step 3**
On the Network Topology page, click **Circuits/VCs**. The list of circuits/VCs associated with the selected device group is displayed.

**Step 4**
Select a circuit/VC for which you want to view the full route. The overlay of the circuit is displayed on the map.

**Step 5**
Use one of the following ways to switch to the Multilayer Trace view:

- Click the **Multilayer Trace** hyperlink on the notification that appears right below the topology toolbar.
  
  **Note**
  The **Multilayer Trace** hyperlink appears only if the Multilayer Trace view is supported for the selected circuit/VC and if the primary state of the circuit/VC is not 'Missing' or 'Down'.

  You can view the partial multilayer trace even when a full route of a circuit/VCs is not completely modeled or if the route is broken. You can identify the root cause and the suggestions to overcome the error.

- Click the information icon adjacent to the circuit/VC to open the Circuit/VC 360 view, and then click **View > Multilayer Trace**.

The simplified three-dimensional view of the selected circuit/VC is displayed. In the simplified view, only the source and destination endpoints of the participating devices are displayed. You can choose to either expand or collapse the different layers in the circuit/VC. The animation of the route direction between the endpoints is displayed for some circuit types. For more information, see **View Specific Information of a Circuit in a Multilayer Trace View**, on page 640.

**Note**
In the case of a device with a circuit being traversed more than once (more incoming and outgoing connections), the collapse option is disabled in both three-dimensional and linear views.

The following figure shows the simplified view of a circuit/VC with the expand and collapse options.
For more information about the details displayed in a three-dimensional view, see Three-Dimensional View of a Circuit V/C Trace, on page 638.

To switch to the linear view, click Linear View. For more information about the details displayed in a linear view, see Linear View of a Circuit/VC Trace, on page 639.

The Multilayer Trace view displays a graphical map that:

- Uses high-level span information such as NEs and links to display the circuit trace.
- Displays logical high-level view where the circuit is traced on the map using logical links. For example, OCHCC circuits use OCH trail links for the trace.
- Displays physical high-level view where the circuit is traced on the map using physical links. For example, OCHCC circuits use OTS links for the trace.
- Displays badges on the devices that represent the most severe alarm on the device, irrespective of the selected circuit. The alarm badges within the trace view show the alarms on each entity (for example the link, node, or point).
- Highlights links according to the high-level view that you select.
- Highlights the layers with different shades and displays border lines that delineate the different layers in the circuit. If a layer is not applicable for a device, that layer appears in gray color
- Displays a collapsible legend that lists the different icons and descriptions of each icon displayed in the Multilayer Trace view.
- For optical circuits, indicates whether the devices or links in the circuit have Shared Risk Resource Groups (SRRGs) assigned to them. Click on the SRRG label on the link or device to see a list of all the SRRGs on that link/device. The SRRGs are color-coded based on whether they are the default on the device, assigned, or yet to be assigned. Click on the question mark icon to see the legend.
- For OCHCC circuits, displays the LMP links between the source or destination node and the DWDM controller.
If one or more devices participating in the circuit/VC is not part of your virtual domain, the Multilayer Trace will be partial. Instead of the inaccessible device, you will see an inaccessible device icon in the Multilayer Trace view (as shown in the figure below).

Three-Dimensional View of a Circuit V/C Trace

This is the default view. It displays a three-dimensional view of the full route of a circuit/VC. For information about how to access this view, see Trace and Visualize the Full Route of Circuits/VCs, on page 635.

This view displays the different paths available for the selected circuit. For example, if an optical circuit has working path, protected path, and restoration path, the paths are color-coded and displayed in this view.
To know about the navigation controls in the three-dimensional view, click the help icon in the tool bar. The Navigation Controls data popup window shows the mouse, MAC Trackpad, and keyboard controls to pan, zoom, and rotate in this view.

Note

The MAC Trackpad controls are displayed only for MAC users.

Linear View of a Circuit/VC Trace

Using the linear view, you can trace and visualize the route of a circuit/VC in a two-dimensional view. For information about how to access this view, see Trace and Visualize the Full Route of Circuits/VCs, on page 635.
This view displays only one path of the circuit at a time. Choose Route, and then select Working, Protected, or Restored to view the required path in the circuit trace. The path options will vary depending on the type of circuit/VC you selected.

View Specific Information of a Circuit in a Multilayer Trace View

In the multilayer trace view of a circuit, you can choose what information you want to view by enabling the specific check box from the Show menu. You can choose to view the labels, physical flows, links, route directions, SRRG, port states, power levels, span loss, and faults in the circuit. The check boxes vary depending on the type of circuit/VC you selected.
You can view either the alarm status or the primary state of the ports. For a list of the port primary state icons and a description of the states, see Port or Interface States, on page 82.

The Route Direction check box to view the animation of the route direction in a circuit, will be enabled by default, only for those circuits which have non-symmetrical paths:

- Unidirectional circuits with path from A to Z. For example, Unidirectional TE Tunnels.
- Bidirectional non-symmetrical circuits with the paths from A to Z and Z to A not being the same. For example, a Carrier Ethernet or a CEM circuit traversing over a unidirectional TE Tunnel.

---

**Note**

The Route Direction check box will not appear in the Show menu for circuits that have exactly the same path from A to Z and Z to A i.e., bidirectional symmetrical circuits.

By default, the route direction from A to Z end will appear. To view the animation in the opposite direction, click the icon. But this icon will be enabled only for those circuits (bidirectional non-symmetrical circuit) that has different A to Z and Z to A paths. For example, a Carrier Ethernet or a CEM circuit traversing over two different unidirectional TE Tunnels. The switch icon does not appear for these circuits:

- Unidirectional circuits with path from A to Z. For example, Unidirectional TE Tunnels.
• Bidirectional symmetrical circuits with the paths from A to Z and Z to A being exactly the same. For example, Bidirectional Core Routed TE Tunnel (or Flex LSP).

When you apply filter to the layers, the Route Direction check box gets disabled depending on the chosen layer. Once disabled, it does not get auto-enabled and you have to manually enable the check box to view the route direction animation again.

In case of a partially discovered circuit or a problematic/unsupported circuit configuration, the default route direction from A to Z might not launch. But these circuits may have a potential Z to A direction, which traverses a different path. Click the Change Endpoints hyperlink to configure the endpoints to launch the multilayer trace view in the opposite direction.

## Actions You Can Perform from the Multilayer Trace View

You can do the following from the Multilayer Trace view:

• Choose Show, and then check the appropriate check boxes to view the labels, physical flows, links, port states, power levels, span loss, and faults in the circuit. For more information, see View Specific Information of a Circuit in a Multilayer Trace View, on page 640.

• Click the View 360 hyperlink that appears right below the toolbar in the Multilayer Trace to open the Circuit/VC 360 view. See Get Quick Information About a Circuit/VC: Circuit/VC 360 View, on page 593.

• Click the Port icon on the circuit trace to open the Interface 360 view. See Get a Quick Look at a Device Interface: Interface 360 View, on page 87.

• Click the device name or device IP address that appears at the top of the device to open the Device 360 view. See Get Basic Device Information: Device 360 View, on page 69.

• Click a link in the Multilayer Trace to open the Link 360 view. See Get a Quick Look at a Specific Link: Link 360 View, on page 167.

• Click the Cross Connection icon on the circuit trace to open the Link Details popup window.

---

**Note**

The Cross Connection icon appears on the links where internal ports are used by the circuit/VC. The internal ports are not displayed in the Multilayer Trace view.

The following figure shows the Link Details popup window that lists the affected internal ports, port status, layer, and power levels. These details are listed for all the affected internal ports in both directions, that is from A side to Z side and vice versa.
• Choose **Actions > Y.1564 Test** to test the performance of the CE circuit/VC end to end. See *Running a Y.1564 Performance Test*, on page 628.

• Choose **Actions > BERT** to test the performance of the Circuit Emulation Services. See *Performance Test for Circuit Emulation Services*, on page 632.

• Choose **Actions > Optical PM Parameters** to view the real time performance monitoring data of the optical circuit/VC. See *Optical Performance Monitoring Parameters*, on page 630.

• Choose **Actions > PRBS Test** to test the performance of the optical circuit/VC end to end. See *Run PRBS Test on Circuits (ODU UNI)*, on page 631.

• Choose **Actions > Service Details** to view further details about the circuit. See *Get Comprehensive Information About a Circuit/VC: Circuit/VC Details Window*, on page 597.

• Choose **Actions > Restoration Actions > Upgrade Restore** to upgrade the failed optical circuit to an active route and delete the old route where the failure occurred. See *Restore a Circuit (Optical)*, on page 607.

• Choose **Actions > Restoration Actions > Manual Revert** to revert the optical circuit to its original route when the route is recovered from the failure. See *Restore a Circuit (Optical)*, on page 607.

• Choose **Actions > Reroute Actions > Working Path or Protected Path** to reroute the traffic through the working path or protected path defined for the circuit. See *Reroute a Circuit (Optical)*, on page 608.

• Choose **Actions > Activate** to allow the traffic to pass through the optical circuit. See *Activate a Circuit (Optical)*, on page 607.

• Choose **Actions > Deactivate** to stop the traffic passing through the optical circuit. See *Activate a Circuit (Optical)*, on page 607.

• Choose **Actions > Protection Actions**, and then choose the required protection switch action to switch over the traffic from one path to another path in a protected optical circuit. See *Initiate a Protection Switch Action on a Circuit (Optical)*, on page 609.

• Click the filter icon in the Multilayer Trace view toolbar to view the various layers in the circuit. Choose the layers that you want to be displayed.
PART VII

Administer the Cisco EPN Manager System

• Set Up the Cisco EPN Manager Server, on page 647
• Licenses and Software Updates, on page 655
• Cisco EPN Manager Security, on page 669
• Backup and Restore, on page 685
• Server Health and Configuration, on page 703
• Data Collection and Purging, on page 729
• User Permissions and Device Access, on page 743
• Fault Management Administration Tasks, on page 781
• Audits and Logs, on page 799
• Configure and Manage High Availability, on page 809
Set Up the Cisco EPN Manager Server

These topics describe the tasks an administrator should perform after Cisco EPN Manager is installed. After these tasks are finished, users can log in and set up their working environment as described in Get Started With Cisco EPN Manager, on page 1.

For information on the various types of Cisco EPN Manager users (for example, CLI and web GUI users), see How to Transition Between the CLI User Interfaces in Cisco EPN Manager, on page 745.

Be sure to review the important information in Best Practices: Harden Your Cisco EPN Manager Security, on page 845.

- Server Setup Tasks, on page 647
- User Management Setup Tasks, on page 652
- Fault Management Setup Tasks, on page 653
- Web GUI Setup Tasks (Admin), on page 653

**Server Setup Tasks**

<table>
<thead>
<tr>
<th>Task</th>
<th>See</th>
</tr>
</thead>
<tbody>
<tr>
<td>Verify the backup settings</td>
<td>Set Up Automatic Application Backups, on page 695</td>
</tr>
<tr>
<td>Install any required product licenses and software updates</td>
<td>Licenses and Software Updates, on page 655</td>
</tr>
<tr>
<td>Modify the stored Cisco.com credentials (user name and password) used to log on to Cisco.com and:</td>
<td>Configure Stored Cisco.com Credentials, on page 718</td>
</tr>
<tr>
<td>• Check for product updates</td>
<td></td>
</tr>
<tr>
<td>• Check for device software image updates</td>
<td></td>
</tr>
<tr>
<td>• Open or review Cisco support cases</td>
<td></td>
</tr>
</tbody>
</table>
**Task** | **See**
---|---
For software updates:  
   • Enable notifications for product software updates (critical fixes, device support, add-ons)  
   • Specify whether you want credentials stored on Cisco.com when Cisco EPN Manager checks for software updates, and if yes, whether you want the user to be prompted for credentials when checking for updates | Enable or Disable Notifications About Software Updates, on page 667

Set up HTTPS on the server for secure interactions between the server and browser-based GUI client (you can use HTTP but HTTPS is recommended) | Secure the Connectivity of the Cisco EPN Manager Server, on page 705

Configure high availability | Configure and Manage High Availability, on page 809

Adjust data retention and purging | Data Collection and Purging, on page 729

For server-related traps that signal system problems, customize the threshold settings and severities, and forward the traps as SNMP trap notifications to configured receivers | Customize Server Internal SNMP Traps and Forward the Traps, on page 724  
Forward Alarms and Events as SNMP Trap Notifications, on page 783

Set up NTP (Network Time Protocol) so that time is synchronized between the server and network devices | Set Up NTP on the Server, on page 716

Configure FTP/TFTP on the server for file transfers between the server and network devices | Enable FTP/TFTP/SFTP Service on the Server, on page 718

Configure a proxy for the Cisco EPN Manager server | Set Up the Cisco EPN Manager Proxy Server, on page 717

Configure the email server | Set Up the SMTP E-Mail Server, on page 717

Set global SNMP polling parameters for managed network elements | Configure Global SNMP Settings for Communication with Network Elements, on page 719

Enable the Compliance feature if you plan to use it to identify device configuration deviations | Enable and Disable Compliance Auditing, on page 138

Enable the Service Discovery feature so that Cisco EPN Manager discovers the services that are existing in the network and the services that are provisioned using the Provisioning Wizard. | Enable and Disable Service Discovery, on page 583

Configure product feedback to help Cisco improve its products | Set Up Defaults for Cisco Support Requests, on page 726
See Task ConfigureCiscoProductFeedbackSettings, on page 726

Configure and Use LDAP Servers

Add an LDAP Server to Cisco EPN Manager

Provides authentication with users who are listed in the LDAP directory and not specified in EPNM.

To add an LDAP server:

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose Administration &gt; Users &gt; Users, Roles &amp; AAA and choose LDAP Servers.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Select the LDAP server and then in the right pane, click the + icon to create LDAP server details that you want to add.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Enter the required LDAP Server Details—Server Address, Server Port, Password, IP address, DNS Name, and so forth.</td>
</tr>
<tr>
<td>Step 4</td>
<td>If you want to use the SSL communication channel, then check the Use Secure Auth check box. For more information about Installing LDAP certificates, see how to Configure LDAP Servers on the Cisco EPN Manager.</td>
</tr>
<tr>
<td>Note</td>
<td>Set Up HTTPS to Secure the Connectivity of the Web Server. This is a prerequisite before you configure LDAP with SSL Administrator can configure the schema for each LDAP server.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Enter the Admin DN string.</td>
</tr>
<tr>
<td>Step 6</td>
<td>Enter the Password and the Confirmation Password details.</td>
</tr>
<tr>
<td>Note</td>
<td>The LDAP administrator knows the string and confirmation password.</td>
</tr>
<tr>
<td>Step 7</td>
<td>Enter the schemas in the following fields: typically every LDAP server has its own configuration of users and groups and concatenated certificate file:</td>
</tr>
<tr>
<td>a) Subject Name Attribute—This value represents the uid attribute in the LDAP server user profile under which a particular username is organized.</td>
<td></td>
</tr>
<tr>
<td>b) Group Name Attribute—This value represents the role permissions that are assigned to the group members (admin, monitor, configurator), and is denoted by the description attribute in the LDAP server group profile. Information about the user group name values can be found in Administration &gt; Users, Roles &amp; AAA &gt; User Groups page.</td>
<td></td>
</tr>
<tr>
<td>c) Group Map Attribute—This value represents the association between group and user, and is denoted by the memberUid attribute in the LDAP server group profile.</td>
<td></td>
</tr>
<tr>
<td>d) Virtual Domain Attribute—This value represents network sections that users can have access to, and is mentioned in the title attribute in the LDAP server user profile. This value is in relation with the Cisco EPN Manager virtual domain profiles configured in Administration &gt; Users &gt; Virtual Domains page. You can choose which elements should be included in a virtual domain and which users should have access to that virtual domain.</td>
<td></td>
</tr>
<tr>
<td>e) Subject Search Base—Specify the path to search where the users are located.</td>
<td></td>
</tr>
<tr>
<td>f) Group Search Base—Specify the path to search where the group are located.</td>
<td></td>
</tr>
<tr>
<td>Step 8</td>
<td>In the Retries field, enter the number of times that the LDAP authentication of source file can be run.</td>
</tr>
<tr>
<td>Step 9</td>
<td>Click Save.</td>
</tr>
</tbody>
</table>
Configure LDAP Servers on the Cisco EPN Manager

Cisco EPN Manager connects to the LDAP server using 1-way SSL. This means that you need to install the Certificate Authority (CA) root (and intermediate) certificates for the LDAP server in Cisco EPN Manager. You will get these certificates from the CA for the LDAP server. The procedure below explains the steps to install the root (and intermediate) CA certificates.

Before you begin

Make sure to install the LDAP certificate to Cisco EPN Manager:

1. Get the root and intermediate certificates for the SSL certificate for the LDAP server, which is owned by the customer.
2. Log in as CLI admin user using ssh as mentioned in Establish an SSH Session With the Cisco EPN Manager Server, on page 716.
3. Copy the CA root/intermediate certificate(s) for the LDAP server certificate to the local directory of Cisco EPN Manager. For example, copy your rootCA.pem to /localdisk/defaultRepo.
   1. Log in to the Cisco EPN Manager server as the Cisco EPN Manager CLI admin user.
   2. Log in as the Linux CLI root user. See Log In and Out as the Linux CLI root User, on page 746.
   3. Retrieve the CA root/intermediate certificate(s) for the LDAP server certificate from your local machine and copy it to the local directory of Cisco EPN Manager (defaultRepo):
      
      ```
      scp clientUserName@clientIP:/FullPathTo rootCA.pemFile /localdisk/defaultRepo
      ```
   4. Exit out of the Linux shell. This will take you back to the Cisco EPN Manager Admin CLI.
4. In the Cisco EPN Manager Admin CLI, run the command to import this CA root certificate in Cisco EPN Manager as -

   ```
   EPNMServer/admin# ncs key importcacert <alias-name> <certificate file> repository defaultRepo
   ```

   (for example, `EPNMServer/admin# ncs key importcacert ldapcacert rootCA.pem repository defaultRepo`). This imports the LDAP certificate in the Java import trust store.
5. Restart Cisco EPN Manager.

Note If you have two LDAP servers and two Cisco EPN Manager servers (HA mode), install the root/intermediate certificate for each LDAP server and restart each Cisco EPN Manager server based on HA guidelines.

| Step 1 | Choose Administration > Users > Users, Roles & AAA, then choose AAA Mode. |
| Step 2 | Choose the LDAP radio button. |
| Step 3 | Check the Enable Fallback to Local check box to enable the use of the local database when the external AAA server is down. |
| Step 4 | If you want to revert to local authentication if the external LDAP server goes down, perform the following steps:
   a) Select Enable Fallback to Local.
   b) Specify the fall back conditions—either Only on no server response or On authentication failure or no server response. |

Note You should be able to log in as root users as they are authenticated locally.
Click Save.

**Note** Use different browsers to log in to LDAP with the new user name and password. You can view the newly added device in the Inventory > Device Management > Network Devices > All Devices.

---

### Cisco WAN Automation Engine Integration with Cisco EPN Manager

The Cisco WAN Automation Engine (WAE) platform is an open, programmable framework that interconnects software modules, communicates with the network, and provides APIs to interface with external applications.

Cisco WAE provides the tools to create and maintain a model of the current network through continuous monitoring and analysis of the network and based on traffic demands that are placed on it. This network model contains all relevant information about a network at a given time, including topology, configuration, and traffic information. You can use this information as a basis for analyzing the impact on the network due to changes in traffic demands, paths, node and link failures, network optimizations, or other changes.

**Note**
For details, refer to the latest *Cisco WAN Automation Engine (WAE) Installation Guide* and *Cisco WAN Automation Engine (WAE) User Guide*.

In Cisco EPN Manager, when you create an unidirectional or a Bi-directional tunnel with an explicit path, the WAN Automation Engine (WAE) integration provides you the explicit path using a REST call from Cisco EPN Manager automatically. Thus, you can avoid manually entering the explicit paths. WAE provides you a list of possible network paths to review and allows you to select an appropriate path.

### Configure WAE Parameters

To specify the WAE path details:

**Before you begin**
Ensure to set the WAE parameters:

1. Choose Administration > Settings > System Settings
2. Expand Circuit VCs and then choose WAE Server Settings.
3. Enter the relevant WAE Details (version 7.1.1 and above) and field details such as WAE Server IP, WAE Port Address, WAE Server UserName, WAE ServerPassword, and WAE Network Name.
4. Click Save to save the WAE server settings or click Reset to Defaults to use the default values.

---

**Step 1** Create an Unidirectional or Bidirectional tunnel with necessary parameters. For more information, see *Create and Provision an MPLS TE Tunnel*, on page 549.

**Step 2** In the Path Constraints Details area, choose the path type either as Working or Protected. See *Field References for Path Constraint Details—MPLS TE Tunnel*, on page 557 for descriptions of the fields and attributes.

**Step 3** Check the New Path check box to enable the Choose Path from WAE server check box.
Step 4  
Check the **Choose Path from WAE server** checkbox. EPNM manager sends a REST request to WAE to obtain WAE networks. 
WAE will return a list of possible networks.

Step 5  
From the **Select WAE Network** drop-down list, choose a network. 
EPNM manager will send a REST request to WAE with all the required parameters such as Source, Destination, network; 
Max path returned default value = 2. WAE displays a list of possible paths satisfying the request.

Step 6  
From the **Select WAE Path** drop-down list, choose the appropriate paths returned. 
EPNM shows the selected path overlay on the map.

Step 7  
Enter the name of the path in the **Path Name** field. 
You can proceed with provisioning the order using the last selected path as explicit path.

---

### User Management Setup Tasks

<table>
<thead>
<tr>
<th>Task</th>
<th>See</th>
</tr>
</thead>
</table>
| Create web GUI users that have administration privileges, and disable the web GUI root account | Create Web GUI Users with Administrator Privileges, on page 754  
Disable and Enable the Web GUI root User, on page 747 |
| Set up user audits                                                   | Audit Configuration Archive and Software Management Changes (Network Audit), on page 799 |
| Set up user authentication and authorization                        | Configure External Authentication, on page 767  
Configure Local Authentication, on page 766 |
| Create user accounts and user groups                                 | Control the Tasks Users Can Perform (User Groups), on page 748 |
| Adjust user security settings (password rules for local authentication, idle time logout setting) | Configure Global Password Policies for Local Authentication, on page 757  
Configure the Global Timeout for Idle Users, on page 757 |
| Specify which users can approve jobs                                | Configure Job Approvers and Approve Jobs, on page 756 |
| Create virtual domains to control device access                     | Create Virtual Domains to Control User Access to Devices, on page 758 |
| Create a message that is displayed when users log in to the GUI client | Create a Login Banner (Login Disclaimer), on page 719 |
### Fault Management Setup Tasks

<table>
<thead>
<tr>
<th>Task</th>
<th>See</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forward alarms and events to other receivers in e-mail format</td>
<td>Forward Alarms and Events as Email Notifications (Administrator Procedure), on page 782</td>
</tr>
<tr>
<td>Forward alarms and events to other receivers in SNMP trap format</td>
<td>Forward Alarms and Events as SNMP Trap Notifications, on page 783</td>
</tr>
<tr>
<td>Configure global settings for alarm and event displays and searches:</td>
<td>Configure Global Display and Search Settings for Acknowledged, Cleared, and Assigned Alarms, on page 784</td>
</tr>
<tr>
<td>• Hide acknowledged, assigned, and cleared alarms in the Alarms and Events tables</td>
<td></td>
</tr>
<tr>
<td>• Include acknowledged and assigned alarms in search results</td>
<td></td>
</tr>
<tr>
<td>• Include device names in alarm messages</td>
<td></td>
</tr>
<tr>
<td>Customize the severity for specific events</td>
<td>Change Event Severity Levels, on page 785</td>
</tr>
<tr>
<td>Customize the auto-clear interval for specific alarms</td>
<td>Change Alarm Auto-Clear Intervals, on page 786</td>
</tr>
<tr>
<td>Make the text in the alarm <strong>Failure Source</strong> field more user-friendly</td>
<td>Change Event Severity Levels, on page 785</td>
</tr>
<tr>
<td>Customize the behavior of expedited events</td>
<td>Change the Behavior of Expedited Events, on page 787</td>
</tr>
<tr>
<td>Control generic event handling</td>
<td>Disable and Enable Generic Trap Processing, on page 794</td>
</tr>
<tr>
<td>Control if and how users can create Cisco Support Requests</td>
<td>Set Up Defaults for Cisco Support Requests, on page 726</td>
</tr>
</tbody>
</table>

### Web GUI Setup Tasks (Admin)

<table>
<thead>
<tr>
<th>Task</th>
<th>See</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable features or menu items that your deployment does not use</td>
<td>Customize the Web GUI Menus to Disable Cisco EPN Manager Features, on page 654</td>
</tr>
<tr>
<td>Set Up the System Monitoring Administration Dashboard</td>
<td>Check Cisco EPN Manager Server Health, Jobs, Performance, and API Statistics Using the System Monitoring Dashboard, on page 722</td>
</tr>
</tbody>
</table>
Customize the Web GUI Menus to Disable Cisco EPN Manager Features

If you belong to the root, Super Users, or Admin user group, you can customize Cisco EPN Manager so that specific menus are no longer displayed in the web GUI. See View User Groups and Their Members, on page 751. This is helpful if your deployment does not use all of the functions in Cisco EPN Manager. When you disable a menu, it is no longer displayed in the web GUI for any users, regardless of their user role.

Complete the following procedure to customize the web GUI by disabling entire features and specific menus. To re-enable the currently disabled features, use the same procedure, but toggle the feature's status to Enabled (or click Enable All).

**Step 1** Click the gear that is displayed above the left sidebar menu.

**Step 2** To disable an entire feature:
1. Locate the feature in the Feature Navigation Groups area.
2. In the feature's Status column, click the toggle so that it displays Disabled.
3. To check which menus will be disabled, scroll through the menus in the Menu Details area. All affected menus will be listed as Disabled.

**Step 3** To disable specific menus:
1. Locate the menu in the Menu Details area.
2. In the menu's Status column, click the toggle so that it displays Disabled. If you disable a menu that has sub-menus, the sub-menus are also disabled. For example:
   * If you disable Group Management, Cisco EPN Manager will disable all of the Group Management sub-menus: Network Device Groups, Compute Device Groups, and Port Groups.
   * If you disable only the Compute Device Groups sub-menu, Cisco EPN Manager will still display the Network Device Groups and Port Groups sub-menus under Group Management.
3. To check which menus will be disabled, scroll through the menus in the Menu Details area.

**Step 4** Click Save, then log out of the web GUI.

**Step 5** Log back into the web GUI and validate your changes.
CHAPTER 20

Licenses and Software Updates

- View and Manage Licenses, on page 655
- Manage Software Updates, on page 666

View and Manage Licenses

Licenses determine the features you can use and the type and number of devices that Cisco EPN Manager can manage. When you connect to Cisco EPN Manager (without logging in), the login page displays a banner that identifies the type of license the server is running (see Types of Cisco EPN Manager Licenses, on page 655). If Cisco EPN Manager is configured to use single sign-on (SSO), check the license type by viewing the banner contents.

Cisco EPN Manager supports Cisco Smart Licensing and traditional licensing. If you are currently using traditional licensing, Cisco recommends that you convert to Smart Licensing. For information on the differences between the two types of licensing, refer to the Cisco Smart Licensing Overview on Cisco.com.

You can upgrade Cisco EPN Manager to a new version using one of the following licensing methods:

- Cisco Smart Licensing - In this method, you must register the new instance of the Cisco EPN Manager with the Cisco Smart Software Manager. See Register Cisco EPN Manager with the Cisco Smart Software Manager, on page 659.

- Traditional Licensing - In this method, the files are copied from the previous version of the Cisco EPN Manager to the upgraded version. However, you must purchase the Base license for the upgraded version. To purchase a new traditional license, go to http://cisco.com/go/license.

How to use Cisco Smart Licensing and traditional licensing is explained in the following topics:

- Use Cisco Smart Licensing, on page 656
- Use Traditional Licensing, on page 663

Types of Cisco EPN Manager Licenses

The following topics describe the feature and time-based licenses supported by Cisco EPN Manager.

Base License

A base license enables all applications and all device drivers (without device count restrictions) on the server. It is displayed in the web GUI as Base License.
Device Right-to-Manage (RTM) License

Device RTM licenses allow the server to manage a specific number of devices of a specific device type. For RTM licenses, the device count is displayed next to the device type. These licenses come in two flavors:

- Extended RTM licenses for core, edge, aggregation, and access network devices. These licenses enable end-to-end network management: device lifecycle management, network provisioning, and network assurance.
- Foundation RTM licenses for service provider Wi-Fi networks that have Wi-Fi access points, WAN routers, core switches, and data center switches. Along with device lifecycle management, these licenses enable assurance visibility and troubleshooting capabilities.

Devices that are configured as satellites (for example, Cisco ASR 903 with a Cisco ASR 9000v host) are counted as independent devices.

Cisco EPN Manager will also discover third party network devices using its Open License "best effort" detection process. The collected information is displayed in the web GUI, but results can vary widely (depending entirely on the responses Cisco EPN Manager receives from the devices). You do not have to purchase any licenses to enable this mechanism.

RTM licenses are displayed in the GUI as follows:

- For Cisco devices—Device model, such as NCS 2002 or ASR 9001.
- For third party devices—Open License.

SBY License for High Availability

The Standby (SBY) license allows the setup of high availability deployments. In a high availability deployment, all the device and feature licenses must be installed on the primary server. No licenses are required on the secondary server.

NBI License

The NBI license enables all MTOSI- and RESTCONF-related APIs and administrative features on the server. If the NBI license is time-based, the remaining time is listed next to the license. This license is displayed in the GUI as NBI.

Time-Based, Lab, and Permanent Licenses

Most licenses can be purchased as a lab license or time-based license:

- Lab—For lab or staging environments.
- Time-Based (Evaluation)—For a 90-day trial period (the product is disabled when the trial period expires).

If you purchase a time-based license, the days remaining are listed next to the license name.

These licenses can be converted to Permanent licenses.

Use Cisco Smart Licensing

Cisco recommends that you use the simple and efficient Cisco Smart Licensing mechanism to manage your licenses. A comparison of Smart and traditional licensing is provided in the Cisco Smart Licensing Overview on Cisco.com. After enabling Smart Licensing in Cisco EPN Manager, you must register Cisco EPN Manager
with the Cisco Smart Software Manager (CSSM) on Cisco.com. After you are registered, all Cisco EPN Manager license types will be available to you from the Cisco EPN Manager web GUI.

If you are currently using traditional licensing, you can convert your existing Cisco EPN Manager licenses to Smart entitlements at any time, as described in Convert Traditional Licenses to Smart Entitlements, on page 660.

The following topics explain how to set up and manage Cisco EPN Manager licenses using Cisco Smart Licensing.

- Set Up Cisco Smart Licensing in Cisco EPN Manager, on page 657
- Choose Cisco EPN Manager Licenses Using Smart Licensing, on page 660
- Configure License Thresholds for the Smart License Dashboard, on page 661
- Check Cisco EPN Manager License Usage, on page 661
- Disable Smart Licensing, on page 661
- Reference: Smart Product Registration and License Authorization Statuses, on page 662

Set Up Cisco Smart Licensing in Cisco EPN Manager

Follow these steps to set up Cisco Smart Licensing so you can use it to manage your licenses. If you are currently using traditional licensing, use these same procedures to use Cisco Smart Licensing and, when convenient, convert your existing Cisco EPN Manager licenses as described in Convert Traditional Licenses to Smart Entitlements, on page 660.

<table>
<thead>
<tr>
<th>Step</th>
<th>See:</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Create a Smart Account with Cisco Systems.</td>
<td>Go to Smart Account Request and follow the instructions on the website.</td>
</tr>
<tr>
<td>2. Set up communication between Cisco EPN Manager and the CSSM on Cisco.com.</td>
<td>Set Up the Transport Mode Between Cisco EPN Manager and Cisco Smart Software Manager, on page 657</td>
</tr>
<tr>
<td>3. Enable Smart Licensing in Cisco EPN Manager.</td>
<td>Enable Smart Licensing in Cisco EPN Manager, on page 658</td>
</tr>
<tr>
<td>4. Register Cisco EPN Manager with the CSSM on Cisco.com by obtaining a token from the CSSM and entering it in the Cisco EPN Manager web GUI.</td>
<td>Register Cisco EPN Manager with the Cisco Smart Software Manager, on page 659</td>
</tr>
<tr>
<td>5. Choose the licenses you want to use in Cisco EPN Manager.</td>
<td>Choose Cisco EPN Manager Licenses Using Smart Licensing, on page 660</td>
</tr>
<tr>
<td>6. Set up the Smart License Dashboard so you can monitor your licensing usage.</td>
<td>Configure License Thresholds for the Smart License Dashboard, on page 661</td>
</tr>
</tbody>
</table>

Set Up the Transport Mode Between Cisco EPN Manager and Cisco Smart Software Manager

Step 1 Choose Administration > Settings > System Settings, then choose General > Account Settings.
Step 2  Click the **Smart Licensing Transport** tab and select a communication mode:

- **Direct mode**—Sends license information directly to the cloud. This is the default. You cannot edit this URL. Click **Test Connectivity** to check the connection status.
- **Transport Gateway**—Uses either a Cisco Smart Call Home transport gateway or a Cisco Smart Licensing Software satellite (which is installed at customer premises and provides a subset of CCSM functionality) for communication. (See Cisco.com for more details.) Enter the appropriate URL in the **Enter URL** field. Click **Test Connectivity** to check the connection status.
- **HTTP/HTTPS Proxy**—Uses either an HTTP or HTTPS proxy for communication between Cisco EPN Manager and the cloud. To enable this option, you must first configure the proxy settings. Click **HTTP/HTTPS Proxy** hyperlink or click the **Proxy** tab to add or edit the proxy settings. See Set Up the Cisco EPN Manager Proxy Server, on page 717.

Step 3  Click **Save** to save the transport settings.

Step 4  To revert to the default values, click **Reset**, and then click **Save**.

---

**What to do next**

If you have not already done so, enable Smart Licensing. See Enable Smart Licensing in Cisco EPN Manager, on page 658.

Enable Smart Licensing in Cisco EPN Manager

**Before you begin**

Make sure you have set up the transport mode. See Set Up the Transport Mode Between Cisco EPN Manager and Cisco Smart Software Manager, on page 657.

---

**Step 1**  Choose **Administration > Licenses and Software Updates > Smart Software Licensing**.

**Step 2**  Enable Cisco Smart Licensing in the Cisco EPN Manager web GUI.

a) Click the **Licensing Settings** tab.
b) In the **Licensing Mode** field, click **Smart Software Licensing** radio button.
c) Choose **Evolved Programmable Network Manager** from the Product Name drop-down list.
d) Click **Enable Smart Software Licensing**. Cisco EPN Manager may display a dialog box indicating that when you complete this procedure, you must restart the web GUI before you can proceed with the configuration step.
e) Click **OK** in the dialog box.
f) If necessary, log out of the web GUI and then log back in.

---

**What to do next**

Do one of the following:

- If you have not yet registered Cisco EPN Manager with the CSSM on Cisco.com, Cisco EPN Manager will run in evaluation mode (which has a limit of 90 days). Register the product as described in Register Cisco EPN Manager with the Cisco Smart Software Manager, on page 659.

- If you have registered Cisco EPN Manager with the CSSM, select the licenses you want to use. See Choose Cisco EPN Manager Licenses Using Smart Licensing, on page 660.
Register Cisco EPN Manager with the Cisco Smart Software Manager

To register Cisco EPN Manager with the CSSM, you must obtain a token from the CSSM and enter it into the Cisco EPN Manager web GUI. This is a one-time requirement. If for any reason you have to re-register your product instance, you can do that by following this procedure.

**Note**

Refer to the Cisco Smart Software Manager User Guide for information on how to use the CSSM and the other actions that you can perform from this application—for example, renewing license registration and license authorization, unregistering the product from Cisco Smart Licensing, and so forth.

**Before you begin**

If your organization does not have a Smart Account, go to software.cisco.com, choose Request a Smart Account in the Administration area, and follow the instructions to create an account.

**Step 1**

Go to the Cisco Software Central web site (software.cisco.com).

**Step 2**

Obtain your tokens. If you already have tokens (for example, you converted traditional licensing PAKs to Smart entitlements), proceed to the next step.

If you are re-registering your product instance, your token will be listed in the CSSM user interface. If your token is no longer valid, you can obtain a new token using this procedure.

1. On Cisco Software Central, choose License > Smart Software Licensing.
2. Select the appropriate virtual account.
3. Click the General tab, then click New Token.
4. Follow the instructions to provide a name, duration, and export compliance applicability before accepting the terms and responsibilities.
5. Click Create Token.
6. Copy the Token ID to your clipboard and proceed to the next step.

**Step 3**

Enter the Token ID into the Cisco EPN Manager web GUI to register the product instance.

1. Choose Administration > Licenses and Software Updates > Smart Software Licensing.
2. Click the Licensing Settings tab, then paste your token into the Registration Token field.
3. Click Register.

**Step 4**

Log out of the Cisco EPN Manager web GUI, then log back in.

**What to do next**

Choose the licenses you want to use. See Choose Cisco EPN Manager Licenses Using Smart Licensing, on page 660.
Choose Cisco EPN Manager Licenses Using Smart Licensing

After you have registered Cisco EPN Manager with the CSSM, all Cisco EPN Manager license types will be listed in the Cisco EPN Manager web GUI, and you can choose the ones you want to use.

Step 1  If this is the first time you are choosing Smart licenses:
   a) Choose Administration > Licenses and Software Updates > Licenses.
      After a few moments, Cisco EPN Manager displays a dialog box informing you that you cannot access the page because you are not using traditional licensing. This is normal.
   b) In the dialog box, click Smart License Settings.
   c) Click the Licensing Settings tab.

Step 2  If you are already using Smart Licensing:
   a) Choose Administration > Licenses and Software Updates > Smart Software Licensing.
   b) Click the Licensing Settings tab.

Step 3  Under Smart License Usage, click Choose Licenses.

Step 4  Select licenses from the Available Licenses dialog box, then click Save. Cisco EPN Manager immediately begins consuming the licenses.

What to do next

Configure the Smart License Dashboard thresholds for the new licenses. See Configure License Thresholds for the Smart License Dashboard, on page 661.

Convert Traditional Licenses to Smart Entitlements

If you have been managing Cisco EPN Manager licenses using traditional licensing, you can enable and configure Smart Licensing by following the setup tasks in Set Up Cisco Smart Licensing in Cisco EPN Manager, on page 657. When convenient, convert your existing traditional licenses to Smart entitlements described in this procedure. You will have to enter your Product Activation Key (PAK) numbers in the License Registration Portal on the Cisco Software Central site.

Before you begin

• You must have a Cisco.com account to access Cisco Software Central. If you do not have an account, go to the Cisco.com registration page.

• Make sure you have your existing traditional licensing PAK numbers.

Step 1  On Cisco Software Central, choose License > Traditional Licensing.

Step 2  Click Continue to Product License Registration to open the License Registration Portal.

Step 3  In the field under Get New Licenses, enter your PAK numbers. If you are entering multiple PAKs, separate them with a comma. You can enter a maximum of 10 PAKs.
Step 4 Under the **PAKs/Tokens** tab, select the PAKs you want to convert to Smart entitlements, then choose **Actions > Convert to Smart Entitlements**.

---

**Configure License Thresholds for the Smart License Dashboard**

To efficiently manage your licenses, configure the Smart License Dashboard to indicate when Cisco EPN Manager is approaching the point where its licenses will be depleted. The settings you configure here are system-wide.

**Step 1** Choose **Administration > Licenses and Software Updates > Smart Software Licensing**, then click the **License Dashboard Settings** tab.

**Step 2** Make a selection from the **License Type** drop-down list.

**Step 3** Enter a value in the **Threshold Value** field.

**Step 4** Click **Save**.

The threshold value is displayed as a straight line in the graphical representation of the **License Summary** and the **Device Distribution for License** dashlets.

---

**Check Cisco EPN Manager License Usage**

Check current license usage using the Smart Licensing Dashboard. To open the dashboard, choose **Administration > Dashboards > Smart Licensing Dashboard**. For an explanation of the basic license types, see **Types of Cisco EPN Manager Licenses**, on page 655.

<table>
<thead>
<tr>
<th>To view these license counts:</th>
<th>Check this part of the dashboard:</th>
</tr>
</thead>
<tbody>
<tr>
<td>For the current date</td>
<td>License Summary Count—Green indicates compliant license counts; red indicates non-compliant license counts.</td>
</tr>
<tr>
<td>For a specific week or month</td>
<td>License Summary—Hover over a bar chart to view more details.</td>
</tr>
<tr>
<td>For a specific license type</td>
<td>Device Distribution for License—Click one of the license links at the top of the License Summary dashlet. Hover your mouse cursor over the chart to view the details.</td>
</tr>
</tbody>
</table>

---

**Disable Smart Licensing**

**Step 1** Change the license setting in the Cisco EPN Manager web GUI.

a) Choose **Administration > Licenses and Software Updates > Smart Software Licensing**.

b) At the bottom of the page, click **Disable Smart Licensing**, then confirm your choice.

**Step 2** Log out of the Cisco EPN Manager web GUI, then log back in.

Because Cisco EPN Manager is not yet registered to use traditional licensing, when you log back in, all features are disabled. This is normal.

**Step 3** Enable traditional licensing in the Cisco EPN Manager web GUI. (This is done from the Smart License Settings page.)
a) Choose Administration > Licenses and Software Updates > Licenses.

After a few moments, Cisco EPN Manager displays a dialog box informing you that you cannot access the page because you are not using traditional licenses. This is normal.

b) In the dialog box, click Smart License Settings.

c) Click the License Settings tab.

d) For the Licensing Mode, select Traditional Licensing.

e) Click Register.

Step 4  Log out of Cisco EPN Manager, then log back in.

Reference: Smart Product Registration and License Authorization Statuses

Product Registration Status

The License Registration Status reflects whether the product is properly registered with Cisco Smart Software Licensing on Cisco.com.

<table>
<thead>
<tr>
<th>License Registration Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unregistered</td>
<td>Smart Software Licensing is enabled in Cisco EPN Manager but Cisco EPN Manager is not registered with the CSSM.</td>
</tr>
<tr>
<td>Registered</td>
<td>Cisco EPN Manager is registered with the CSSM. Cisco EPN Manager has received an ID certificate that will be used for future communication with the Cisco licensing authority.</td>
</tr>
<tr>
<td>Registration Expired</td>
<td>Cisco EPN Manager did not successfully renew its registration prior to the expiration date and has been removed from CSSM.</td>
</tr>
</tbody>
</table>

License Authorization Status

The License Authorization status reflects license usage against purchased licenses, and whether you are in compliance with Cisco Smart Licensing. If you exceed the number of purchased licenses, the product's status will be Out of Compliance.

<table>
<thead>
<tr>
<th>License Authorization Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Evaluation Mode</td>
<td>Cisco EPN Manager is running in evaluation mode (expires in 90 days).</td>
</tr>
<tr>
<td>Authorized</td>
<td>Cisco EPN Manager has a valid Smart Account and is registered. All licenses requested by the product are authorized for use.</td>
</tr>
<tr>
<td>Out of Compliance</td>
<td>Cisco EPN Manager has exceeded the number of licenses that were purchased. (Specifically, the virtual account for the product instance has a shortage of one or more licenses types.)</td>
</tr>
<tr>
<td>Evaluation Expired</td>
<td>The evaluation period has expired and Cisco EPN Manager is in the unlicensed state.</td>
</tr>
</tbody>
</table>
Use Traditional Licensing

Cisco recommends that you convert to Cisco Smart Licensing. See Set Up Cisco Smart Licensing in Cisco EPN Manager, on page 657. If you are using Smart Licensing and want to re-enable traditional licensing, see Disable Smart Licensing, on page 661.

Cisco EPN Manager checks traditional licenses every 4 hours and writes the status to the License log (/opt/CSCOlumos/logs/license.log). If a time-based license expires, any users that are in an active session will be redirected to the Licenses page, and new users are prevented from logging in. If an RTM license device count is exceeded, you should either:

- Delete some of the devices. After the daily inventory collection, the devices will be displayed as Managed.
- Obtain a license with a higher RTM count. See Add and Delete Traditional Licenses, on page 663.

See these topics for more information on traditional licenses:

- Types of Cisco EPN Manager Licenses, on page 655
- View Traditional Licenses, on page 663
- Add and Delete Traditional Licenses, on page 663
- Move a Traditional License to Another Server, on page 664

View Traditional Licenses

To view the traditional Cisco EPN Manager licenses that are currently installed, choose Administration > Licenses and Software Updates > Licenses. Cisco EPN Manager supports the licenses listed under Base License.

A separate license is used by each chassis in a multi shelf device. For example, if a Cisco NCS 2006 device houses 3 chassis, 3 licenses are used by that device.

Add and Delete Traditional Licenses

To install a new traditional license, the original license must already reside on the server. Do not create copies of licenses. To purchase new traditional licenses, go to www.cisco.com/go/license. Make sure you install licenses in the correct order. For example, you must always install the Base license first because it is required by the other licenses.

When you delete a license, all of that license’s information is removed from the server.
If you make a manual change to a license file, Cisco EPN Manager considers the file corrupted and will not install it. If this happens, obtain a new license file.

**Caution**

---

**Step 1** Choose **Administration > Licenses and Software Updates > Licenses.**

**Step 2** Choose **Files > License Files.**

- To add a license, click **Add**, click **Choose File**, browse to the location of the license file, and then click **OK**.
- To delete a license, select the license file, then click **Delete**.

---

### Move a Traditional License to Another Server

The only time you may have to move a license to another server is if you are using high availability, and a server fails. If you need to delete a license, see Add and Delete Traditional Licenses, on page 663. To move the license:

**Step 1** Delete the traditional licenses from the original server.

**Step 2** Send an e-mail to licensing@cisco.com requesting a **re-host** for your traditional licenses.

**Step 3** When you receive the traditional license, install it on the new server.

### Renewing an Expired License

If your Cisco EPN Manager license has expired, you can complete the following procedure to renew it:

**Step 1** Choose **Administration > Licenses and Software Updates > Licenses.**

The **Licenses** page opens.

**Step 2** Do one of the following:

- If you see the **Summary** and **Files** menus in the top left portion of the page, skip ahead to Step 4.
- If you do not see these menus, you will first need to register traditional licensing. Proceed to Step 3.

**Step 3** Register traditional licensing, then return to Step 1 of this procedure:

a) Choose **Administration > Licenses and Software Updates > Smart Software Licensing**.

b) With the **Licensing Settings** tab selected, click the **Traditional Licensing** radio button, then click **Register**.

c) Log out of Cisco EPN Manager, then log back in.

**Step 4** From the top left area of the page, choose **Files > License Files.**

The **License Files** page opens.

**Step 5** Choose the license file you want to renew:
a) Click Add.
   The Add A License File dialog box opens.

b) From the Select License File field, click Choose File.
c) Navigate to and click the appropriate license file, then click Open.
d) Click OK.

Step 6 Log out of Cisco EPN Manager, then log back in.

View the Licensing Dashboard

From the Licensing dashboard, you can determine whether traditional or smart software licensing is enabled (indicated in the Active Licensing Mode field at the top of the dashboard) and view the number of licenses that are currently in use. You can set the licensing mode from the Smart Software Licensing page (Administration > Licenses and Software Updates > Smart Software Licensing).

To open this dashboard, do one of the following:

- Choose Administration > Dashboards > Licensing Dashboard.
- Click the Licensing Dashboard link from the top-right corner of the Smart Software Licensing page.

The information displayed in the dashboard depends on the licensing mode that is enabled. If smart software licensing is currently enabled, the following dashlets are displayed:

- License Summary Count area—Displays the number of licenses consumed and the compliance status for each license type. The number of licenses displayed is based on the current date.

- License Summary dashlet—Displays a bar chart that graphs the number of licenses consumed for each license type during a particular time period. To view additional information, place your cursor over the chart.

- Device Distribution for License dashlet—To view the device distribution chart for a particular license, click its link from the top of the chart displayed in the License Summary dashlet. To view additional information, place your cursor over the chart.

The information displayed in the License Dashboard is refreshed daily after the SmartLicense job runs at 02:00 A.M. (its pre-configured run time). To view this job in the Job Dashboard, choose Administration > Dashboards > Job Dashboard.

If traditional licensing is currently enabled, the Licensing dashboard displays the Traditional Licensing dashlet. Specify whether you want to view information about Lifecycle or Assurance licenses by choosing the corresponding option from the License Type drop-down list. The dashlet updates, displaying information such as the device families with that license type, the number of tokens allocated to each device in those families, as well as the number of tokens that are not being used at the moment.

Related Topics
- Set Up Cisco Smart Licensing in Cisco EPN Manager, on page 657
- Enable Smart Licensing in Cisco EPN Manager, on page 658
- Register Cisco EPN Manager with the Cisco Smart Software Manager, on page 659
Manage Software Updates

- What Are Software Updates?, on page 666
- View the Installed Product Software Version, on page 666
- Enable or Disable Notifications About Software Updates, on page 667
- View Installed Software Updates, on page 667

What Are Software Updates?

Cisco provides updates to the Cisco EPN Manager software periodically. These updates fall into the following three categories:

- Critical Fixes—Provide critical fixes to the software. We strongly recommend that you download and apply all of these updates as soon as they are available.
- Device Support—Adds support for managing devices which Cisco EPN Manager did not support at release time.
- Add-ons—Provide new features, which can include GUI screens and functionality, to supplement the Cisco EPN Manager version you are using. This includes Cisco EPN Manager maintenance packs and maintenance pack point patches.

The update notifications that Cisco EPN Manager displays depend on the Notification Settings specified by your administrator. See Enable or Disable Notifications About Software Updates, on page 667. All software updates are packaged in .ubf files. A large update can contain individual smaller updates, from which you can choose what you want to install. When you install an update, Cisco EPN Manager does the following:

- Verifies that the file publisher is Cisco Systems and the file has not been tampered with
- Automatically installs any other updates that are required

If you have connectivity to http://www.cisco.com, you can download and install the updates directly from Cisco.com. If you do not have internet connectivity, copy the update from a server that has the necessary connectivity and install it from there.

See the Cisco EPN Manager Installation Guide for installation instructions for maintenance packs. For point patch installation instructions, see the readme file provided with the patch file on the Software Download page on Cisco.com.

View the Installed Product Software Version

Use one of these methods to check the Cisco EPN Manager product version:

- From the Web GUI, click the Settings icon at the top right of the page, and choose Help > About Cisco EPN Manager.
- From the CLI, view the contents of the file named
  
  #cat /opt/CSCOlumos/installedComponentsVersions.xml
To use the CLI, see Establish an SSH Session With the Cisco EPN Manager Server, on page 716.

View Installed Software Updates

If you are not logged in to the web GUI, you can view a pop-up window that lists the software updates by clicking View Installed Updates from the login page.

If you are logged in to the web GUI, you can view the software updates in two ways:

- From the About Cisco EPN Manager page, by clicking the settings icon at the top right of the page and clicking About Cisco EPN Manager, and then clicking View Installed Updates. (The View Installed Updates link is also available from the login page.)
- By choosing Administration > Licenses and Software Updates > Software Update (this method provides the most detail).

The Software Update page displays two tabs:

- **Installed Updates**—Updates that Cisco EPN Manager is currently using.
- **Uploaded Update Files**—Update files that have been uploaded to the server (including those that are not being used). The Corresponding Updates field lists any prerequisite updates that were also uploaded.

If an update file has not yet been installed, it can be deleted. Select the file and click the Delete button.

Enable or Disable Notifications About Software Updates

By default, Cisco EPN Manager displays information about all available updates in the Software Updates page. Because the list can be quite long, you may want to adjust what is displayed and the updates for which you are notified. You can also disable all notifications and re-enable them later.

**Step 1** Configure the default Cisco.com credentials so that Cisco EPN Manager can get information about available updates.

a) Choose Administration > Settings > System Settings, then choose General > Account Settings.
b) Click the Cisco.com Credentials tab, enter the credentials, then click Save.

**Step 2** Configure your software update notification settings.

a) Choose Administration > Settings > System Settings, then choose General > Software Update.
b) Under Notification Settings, select or deselect the update categories. To disable all notifications, make sure no categories are selected. For an explanation of the categories, see What Are Software Updates?, on page 666.
c) Click Save.
Enable or Disable Notifications About Software Updates
This chapter consists of the following topics:

- Security Overview, on page 669
- Secure Architecture, on page 669
- Secure Default Configurations, on page 673
- Harden Your Installation, on page 673
- CSDL Process, on page 682

**Security Overview**

Cisco EPN Manager requires a high level of security to ensure that your network and its data are not compromised. This is especially important because it has full management control over your network and stores device credentials. To this end, Cisco EPN Manager leverages the following security approaches:

- **Secure architecture**: The Cisco EPN Manager architecture is designed to limit access to any unknown software flaws that may be present so they cannot be used for a malicious purpose.

- **Secure default configurations**: Cisco EPN Manager is shipped with a default configuration that enhances the security of the product. For example, even though insecure FTP and TFTP services are supported, they are not activated in the default configuration.

- **Installation hardening**: Cisco’s Advanced Services team can evaluate the specifics of your Cisco EPN Manager installation and complete the additional security hardening tasks that may be needed.

- **Cisco Secure Development Lifecycle (CSDL) process**: From development to release, the CSDL process is followed to improve security of Cisco EPN Manager.

The following sections describe these approaches in more detail.

**Secure Architecture**

Cisco EPN Manager’s architecture design is based on the premise that 3 conditions must exist simultaneously in order for an attacker to breach a system:

- The system has a flaw.
- The attacker has access to that flaw.

On its own, a flaw is benign. It is only when an attacker can access the flaw and knows how to exploit it that the flaw becomes a vulnerability. This distinction between a flaw and a vulnerability is important to understand. Just because a flaw has gone public does not automatically mean it has become a vulnerability. And a flaw may only be a vulnerability under certain circumstances.

Limiting access to system flaws is key to the approach Cisco EPN Manager uses to manage security risks. We have designed the Cisco EPN Manager architecture so that any flaws that may be found should not be readily accessible to an attacker. This is a practical and reasonable approach because you cannot always eliminate flaws or prevent an attacker from exploiting them. What you can do is limit access to certain flaws that exist by putting multiple layers of security in place. Cisco EPN Manager uses three layers of perimeter security, as illustrated in Figure 1.

**Figure 16: Multilayer Secured Perimeter Architecture: A Closed System**

Of these three layers, one resides within and two reside outside of Cisco EPN Manager. The interior layer is preconfigured with Cisco EPN Manager and becomes operational after the installation is completed. The two exterior layers are not preconfigured and need to be implemented by creating an exterior network firewall and encrypted communication link layer. We recommend that your company's technical team works with Cisco Advanced Services to create these items.

**Note**

You may need to modify some configurations within Cisco EPN Manager in order to choose the right kind of encryption protocols to use for your network.
The interior layer is built into Cisco EPN Manager and consists of the following components:

- **Embedded firewall**—Provides the first protective layer around the interior components. This allows only a few ports to be open to incoming traffic. This decreases the attack surface by limiting access to multiple flaws (both known and unknown) in the Linux OS and Oracle databases.

- **CARS shell**—Provides a protective layer around Linux by enforcing a whitelist of allowed commands that can be run on Linux, thus restricting interaction with the OS.

- **Web server**—Provides a protective layer around Linux, the Java virtual machine, and the database. This layer has security filters in place for restricting access to Java as well as the database resources and methods.

This interior layer protects the system against many risks, such as the ones described in the following examples. While these flaws are deemed vulnerabilities in an unprotected system, there are not in Cisco EPN Manager. In these examples (identified by their National Vulnerability Database ID), we will assume that the external firewall and encrypted links layer have either been breached by an attacker or are non-existent:

- **CVE-2013-5211**: Flaw in NTP’s implementation of the Linux NTPD component—A DoS attack takes place after incoming NTP traffic is accessed from port 23. Since the embedded firewall disallows this traffic, this flaw is not accessible to an attacker and therefore not a risk in Cisco EPN Manager.

- **CVE-2016-0634**: Linux bash shell flaw—This attack can be made by an authenticated user that has targeted a bash shell through port 22. Cisco EPN Manager does not offer direct access to a bash shell via port 22. Instead, a CARS shell is accessible by regular authenticated users. As a result, this flaw is not a risk in Cisco EPN Manager.

- **CVE-2017-12617**: Apache Tomcat flaw—This attack can happen when a PUT request is made. Since Cisco EPN Manager’s webservice configuration does not allow this kind of access, this flaw is not a risk.

- **CVE-2015-4863**: Oracle database flaw—This attack can happen on a network via the Oracle Net protocol. This flaw is not a risk in Cisco EPN Manager since the Oracle database resides behind the built-in firewall and webservice. As a result, it is not possible to access the database over the network.

**Ports Used by Cisco EPN Manager**

Cisco EPN Manager ships with a built-in application firewall configuration to ensure that only legitimate traffic is allowed into the server. Table 1 lists the ports used to listen for connection requests from devices and accept incoming traffic. The opening and closing of these ports in the firewall is done automatically by Cisco EPN Manager when you enable or disable certain features. There is no need to enable or disable the ports within the firewall. If you try to specify any firewall configurations that circumvent Cisco EPN Manager, you may compromise its security and integrity.

Table 1 also provides information required to carry out post-installation security hardening (see Secure Default Configurations for more information).
### Table 55: Listening Ports That Are Open Through Built-in Firewall

<table>
<thead>
<tr>
<th>Port</th>
<th>Protocol</th>
<th>Usage</th>
<th>Safe to Disable?</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>21</td>
<td>TCP</td>
<td>To transfer files to and from devices using FTP.</td>
<td>Yes</td>
<td>Disable FTP from the web GUI under <strong>Administration &gt; Settings &gt; System Settings</strong>, then choose <strong>General &gt; Server</strong>. After disabling FTP, as the CLI admin user, stop and restart the server.</td>
</tr>
<tr>
<td>22</td>
<td>TCP</td>
<td>To initiate SSH connections with the Cisco EPN Manager server, and to copy files to the Cisco EPN Manager server using SCP or SFTP.</td>
<td>Depends</td>
<td>This might be still needed by older managed devices that only support TFTP and not SFTP or SCP.</td>
</tr>
<tr>
<td>69</td>
<td>UDP</td>
<td>To distribute images to devices using TFTP.</td>
<td>Depends</td>
<td>Only if alternative protocols like SCP or SFTP or HTTPS are used for image distribution, and if supported by the managed devices.</td>
</tr>
<tr>
<td>162</td>
<td>UDP</td>
<td>To receive SNMP traps from network devices.</td>
<td>No</td>
<td>—</td>
</tr>
<tr>
<td>443</td>
<td>TCP</td>
<td>For browser access to the Cisco EPN Manager server via HTTPS.</td>
<td>No</td>
<td>—</td>
</tr>
<tr>
<td>514</td>
<td>UDP</td>
<td>To receive syslog messages from network devices.</td>
<td>No</td>
<td>—</td>
</tr>
<tr>
<td>1522</td>
<td>TCP</td>
<td>For High Availability (HA) communication between active and standby Cisco EPN Manager servers. Used to allow Oracle JDBC traffic for Oracle database synchronization.</td>
<td>Yes</td>
<td>If at least one Cisco EPN Manager server is not configured for HA, this port is automatically disabled.</td>
</tr>
<tr>
<td>2021</td>
<td>TCP</td>
<td>To distribute images to devices using FTP.</td>
<td>No</td>
<td>—</td>
</tr>
<tr>
<td>8082</td>
<td>TCP</td>
<td>For the HA Health Monitor web interface (via HTTP). Used by primary and secondary servers to monitor their health status via HTTP.</td>
<td>No (If HA configured)</td>
<td>—</td>
</tr>
<tr>
<td>8087</td>
<td>TCP</td>
<td>To update software on the HA secondary backup server (uses HTTPS as transport).</td>
<td>No</td>
<td>—</td>
</tr>
<tr>
<td>Port</td>
<td>Protocol</td>
<td>Usage</td>
<td>Safe to Disable?</td>
<td>Notes</td>
</tr>
<tr>
<td>--------</td>
<td>----------</td>
<td>--------------------------------------------</td>
<td>------------------</td>
<td>-----------------------------------------------------------------------</td>
</tr>
<tr>
<td>9991</td>
<td>UDP</td>
<td>To receive Netflow data packets.</td>
<td>Yes</td>
<td>Cisco EPN Manager does not support Netflow. You should disable this traffic in the network firewall.</td>
</tr>
<tr>
<td>9992</td>
<td>TCP</td>
<td>To manage M-Lync using HTTP or HTTPS.</td>
<td>Yes</td>
<td>Cisco EPN Manager does not support M-Lync. You should disable this traffic in the network firewall.</td>
</tr>
<tr>
<td>11011 to 11014</td>
<td>TCP</td>
<td>For PnP operations for proprietary Cisco Network Service (CNS) protocol traffic.</td>
<td>Yes</td>
<td>Cisco EPN Manager does not support PnP. You should disable this traffic in the network firewall.</td>
</tr>
<tr>
<td>61617</td>
<td>TCP</td>
<td>For MTOSI NBI notification over Java Message Service (JMS) connections. Also used for PnP operations.</td>
<td>Yes</td>
<td>Cisco EPN Manager does not support MTOSI over JMS or PnP. You should disable this traffic in the network firewall.</td>
</tr>
</tbody>
</table>

**Secure Default Configurations**

Cisco EPN Manager ships with default application configurations that are as secure as possible. You should only modify them after you have analyzed the threat model and assessed the risks for your specific situation. With the default configurations, Cisco EPN Manager does its best to:

- Not use default passwords.
- Not make unnecessary OS and Oracle packages/services accessible.
- At the time of a Cisco EPN Manager release, the latest security patches are applied for the embedded OS and Oracle.
- Not allow the use of Oracle access passwords by human users. These passwords are machine-generated and used by internal components.

**Harden Your Installation**

To harden your Cisco EPN Manager installation, you need to complete the following tasks:

1. Configure the built-in interior and exterior network firewalls to allow only legitimate traffic.
2. Use encryption for all incoming and outgoing traffic.
3. Configure Cisco EPN Manager and its peer systems to allow the transmission of only legitimate transactions.
Before you proceed, you should first understand how Cisco EPN Manager interacts with peer systems. This, along with management traffic flows and the exterior network firewalls for a generic HA deployment, is illustrated in the following figure.

**Note**

Although we recommend that you implement these firewalls, you are not required to do so.

Depending on your installation, you may need to customize the firewall configuration to further improve security. As a general policy, any ports that are not needed and not secure (i.e. do not transmit encrypted traffic) should be disabled.

### Configure the Built-In Application Firewall

To configure the application firewall, you need to disable the Cisco EPN Manager features that your installation does not need to run. This will automatically shut down the corresponding listening ports in the firewall.

#### Step 1

Identify the ports that are currently enabled:

a) To view a list of the ports used in your deployment that are exposed externally, log in as a Cisco EPN Manager CLI admin user and then run the `show security-status` command.

b) To view a list of all open listening ports at the OS level, including those that are blocked by the built-in firewall, log in as the Linux CLI admin user and then run the `netstat -aln` command.
Step 2

Using Table 1 for guidance, determine which of these ports can be safely disabled without disrupting the normal functioning of Cisco EPN Manager.

Note the following:

- Cisco EPN Manager uses some of the listening ports for its internal operations. These ports are kept hidden behind the built-in firewall.
- You should only use the procedure provided in Table 1 to enable or disable ports.

Set Up Exterior Network Firewalls

In addition to the built-in firewall, you can also deploy network firewalls that only allow traffic targeted at the listening ports used by Cisco EPN Manager and its peer systems. The figure provided in the Harden Your Installation topic illustrates how the port information listed in Tables 1 and 2 are used to set up firewall rules. Use this figure to decide on the appropriate firewall configurations for your management network.

- To identify the traffic class, refer to the Usage column in Table 1. We recommend that you disable the ports used by the services that are not used by your Cisco EPN Manager installation.
- You should also enable the destination ports that Cisco EPN Manager uses for outgoing traffic (to connect to network devices or peer systems) in your network firewalls. Refer to Table 2 for a listing of these destination ports and their purpose.

Table 56: Destination Ports Used by Cisco EPN Manager

<table>
<thead>
<tr>
<th>Port</th>
<th>Protocol</th>
<th>Used to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>7</td>
<td>TCP/UDP</td>
<td>Discover endpoints using ICMP.</td>
</tr>
<tr>
<td>22</td>
<td>TCP</td>
<td>Initiate SSH connections with managed devices.</td>
</tr>
<tr>
<td>23</td>
<td>TCP</td>
<td>Communicate with managed devices using Telnet.</td>
</tr>
<tr>
<td>25</td>
<td>TCP</td>
<td>Send email using an SMTP server.</td>
</tr>
<tr>
<td>49</td>
<td>TCP/UDP</td>
<td>Authenticate Cisco EPN Manager users using TACACS.</td>
</tr>
<tr>
<td>53</td>
<td>TCP/UDP</td>
<td>Connect to DNS service.</td>
</tr>
<tr>
<td>161</td>
<td>UDP</td>
<td>Poll using SNMP.</td>
</tr>
<tr>
<td>443</td>
<td>TCP</td>
<td>Upload or download images and perform configuration backup-restore for Cisco NCS 2000 devices using HTTPS.</td>
</tr>
<tr>
<td>1522</td>
<td>TCP</td>
<td>Communicate between primary and secondary HA servers (allows Oracle JDBC traffic for Oracle database synchronization between primary and secondary servers).</td>
</tr>
<tr>
<td>1080</td>
<td>TCP</td>
<td>Communicate with Cisco Optical Networking System (ONS) and Cisco NCS 2000 series devices using Socket Secure (SOCKS) protocol.</td>
</tr>
</tbody>
</table>
### Set Up Traffic Encryption

You will need to encrypt the following traffic groups:

- **Northbound traffic**—This group consists of either client-server traffic from a human user’s browser or NBI traffic from a Business Support System/Operational Support System (BSS/OSS). This traffic is transmitted over HTTP, so you need to implement HTTPS (HTTP encrypted by TLS). For a description of how to set up HTTPS, see **Set Up HTTPS to Secure the Connectivity of the Web Server**.

- **Southbound traffic**—This group consists of management traffic that queries or configures managed devices using a wide range of protocols such as SNMP and HTTP. Protocols such as SSH and SNMPv3 may be used to secure this traffic. For a description of the configuration steps that need to be completed in order to encrypt this traffic, see **Use SNMPv3 to Harden Communication Between Cisco EPN Manager and Devices**.

- **East-West traffic between peer systems**—This group consists of traffic between Cisco EPN Manager and a variety of other supporting systems like an external authentication server (secured by TLS-EAP) or a SMTP mail server (secured by TLS). Different encryption protocols are used, depending on the application protocol that needs to be protected. Some of the application protocols may also have built-in encryption.

- **East-West traffic between a primary and secondary server in an HA deployment**—This group consists of traffic between two Cisco EPN Manager servers running in primary and secondary mode. Each server monitors the other’s health and keeps database and other file content synchronized over a connection secured by HTTPS.

<table>
<thead>
<tr>
<th>Port</th>
<th>Protocol</th>
<th>Used to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>1645, 1646, and 1812, 1813</td>
<td>UDP</td>
<td>Authenticate Cisco EPN Manager users using RADIUS.</td>
</tr>
<tr>
<td>3082</td>
<td>TCP</td>
<td>Communicate with Cisco ONS and Cisco NCS 2000 devices using TL1 protocol.</td>
</tr>
<tr>
<td>4083</td>
<td>TCP</td>
<td>Communicate with Cisco ONS and Cisco NCS 2000 series devices using TL1 protocol.</td>
</tr>
<tr>
<td>8082</td>
<td>TCP</td>
<td>Communicate between primary and secondary HA servers to monitor each other's health using HTTPS.</td>
</tr>
<tr>
<td>10022 to 10041</td>
<td>TCP</td>
<td>Passive FTP file transfers (for example, device configurations and report retrievals).</td>
</tr>
<tr>
<td><strong>MTOSI/RESTCONF TCP port number</strong></td>
<td>TCP</td>
<td>Listen at NBI client connected to the Cisco EPN Manager server (after this port is configured by NBI client system, a registration notification message containing the port number is sent to Cisco EPN Manager server); refer to the MTOSI or RESTCONF API guide for more information.</td>
</tr>
</tbody>
</table>
Use SNMPv3 to Harden Communication Between Cisco EPN Manager and Devices

SNMPv3 is a higher security protocol than SNMPv2. If your devices support SNMPv3, configure the devices to use SNMPv3 to communicate with the Cisco EPN Manager server. The following procedures explain how to specify SNMPv3 when adding new devices.

<table>
<thead>
<tr>
<th>Method for Adding Devices</th>
<th>How to Specify SNMPv3</th>
<th>For more information, see:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a single device</td>
<td>In the Add Device dialog box, go to the SNMP Properties page and choose v3 from the Versions drop-down list.</td>
<td>Add Devices Manually (New Device Type or Series), on page 41</td>
</tr>
</tbody>
</table>
| Add multiple devices (bulk import) | When you edit your CSV file, enter the following:  
• Enter 3 in the SNMP Version column.  
• Enter the appropriate values for these columns: snmpv3_user_name, snmpv3_auth_type, snmpv3_auth_password, snmpv3_privacy_type, and snmpv3_privacy_password | Import Devices Using a CSV File, on page 40 |
| Add multiple devices using discovery | In the Discovery Settings dialog box, go to the Credential Settings area and click SNMPv3 Credentials. Click the + sign to add the device credentials. | Run Discovery With Customized Discovery Settings, on page 38 |

Before you begin

Make sure SNMPv3 is enabled (with the appropriate security algorithm, such as HMAC-SHA-96) on the network devices that support it.

Set Up External Authentication Using the CLI

We recommend that you manage user accounts and passwords using a dedicated, remote authentication server running a secure authentication protocol such as RADIUS or TACACS+. In addition to setting up authentication using the following procedure, contact your external authentication vendor for additional security hardening suggestions.

Note

If you decide to use local user authentication, check the default password policies to determine whether you want to make them stronger. See Configure Global Password Policies for Local Authentication, on page 757.

Configure Cisco EPN Manager to authenticate users using an external AAA server. You can configure the server using the web GUI or by using the command line interface (CLI). To set up remote user authentication via the GUI, see Configure External Authentication, on page 767.

To configure external authentication using the CLI, follow these steps. EPNM supports configuring only TACACS+ via CLI.
Harden SSH Against Brute-Force Password Attacks

Since password-based SSH authentication is vulnerable to brute-force attacks, we recommend that you switch to one of the accepted Public Key types (PubkeyAcceptedKeyTypes) after installing Cisco EPN Manager. The list of accepted Public Key type (PubkeyAcceptedKeyTypes) in the Cisco EPN Manager 3.0 are:

- ecdsa-sha2-nistp256-cert-v01@openssh.com
- ecdsa-sha2-nistp384-cert-v01@openssh.com
- ecdsa-sha2-nistp521-cert-v01@openssh.com
- ssh-ed25519-cert-v01@openssh.com
- ssh-rsa-cert-v01@openssh.com
- ecdsa-sha2-nistp256
- ecdsa-sha2-nistp384
- ecdsa-sha2-nistp521
- ssh-ed25519

To make the switch, follow these steps:
Step 1  Log in as the Linux CLI admin user:
a) Start an SSH session with the Cisco EPN Manager server and log in as the Cisco EPN Manager CLI admin user.
b) Run the following command: `shell`
c) Enter the shell access password.

Step 2  Check who the current user is:

```
# whoami
```

The resulting output should indicate that you are the Linux admin user, not the Linux root user.

Step 3  For the Cisco EPN Manager admin user, use one of the accepted Public Key types (PubkeyAcceptedKeyTypes) to create key pairs and an SSH string using a tool (such as puTTYgen) with at least 2048-bit strength.

For example, generate a key using ed25519 like this:
```
$ ssh-keygen -t ed25519 -N ""
```

The SSH string should look something like this:

```
ssh-ed25519 AAAAC3Nza... ......root@localhost.localdomain
```

Tip  Save the private key in a file, preferably in encrypted form with a passphrase. Also keep the passphrase handy.

Step 4  Create the authorized_keys file and assign the appropriate access privileges to the Cisco EPN Manager admin user:
a) In the admin user's home directory, create the .ssh directory and assign read, write, and execute privileges for this directory to only the admin user:
```
# cd ~
# mkdir .ssh
# chmod 700 ~/.ssh
```
b) Create the authorized keys file:
```
# cd .ssh
# vi authorized_keys
```
c) Copy and paste the SSH string you created in Step 3 in to the authorized_keys file and then save the file.
d) Assign read, write, and execute privileges for the authorized_keys file to only the admin user:
```
# chmod go- ~/.ssh/authorized_keys
# chmod u=rwx ~/.ssh/authorized_keys
```
e) Confirm you assigned the appropriate access privileges to the authorized_keys file:
```
# ls -al
```

The resulting output should look something like this:

```
total 6
drwx------. 2 admin gadmin 1024 May 10 00:25 .
drwx------. 6 admin gadmin 1024 May 10 00:24 ..
-rwx------. 1 admin gadmin 398 May 10 00:25 authorized_keys
```

In this example, the Linux admin user is named `admin`.

Step 5  Switch to the root user in a bash shell:
```
# sudo -i
```

Step 6  Update the sshd_config file:
a) Copy the current and original versions of the `sshd_config` file, located in the `/etc/ssh` directory:

```
# cp /etc/ssh/sshd_config /etc/ssh/sshd_config.orig
```

b) Open the `sshd_config` file in a `vi` editor:

```
# vi /etc/ssh/sshd_config
```

c) Enter the following key-value pairs:

```
Protocol 2
MaxAuthTries 3
PasswordAuthentication no
PermitRootLogin no
AuthenticationMethods publickey
PubkeyAuthentication yes
```

**Important** The default `sshd_config` file may already specify some of these key-value pairs. If this is the case, either:

- Change any values that do not match the ones listed above.
- Comment out the existing key-value pairs and specify the required entries on new lines.

Doing so will prevent conflicting or duplicate key-value pairs.

d) Save the file.

**Step 7** Reload sshd:

```
# systemctl reload sshd.service
```

**Caution** Do not restart sshd. If any of the previous configuration steps are not completed correctly and you restart sshd, you will lose access to SSH. It is much safer to reload sshd because current SSH sessions are maintained (allowing you to make any necessary corrections).

The configuration of SSH authentication is complete. To confirm that configuration was successful, keep the existing SSH session open (in case you need to fix something) and try to open a new SSH session using the private key and passphrase you created in Step 3 of this procedure.

---

**Harden NTP**

Network Time Protocol (NTP) authenticates server date and time updates. We recommend you configure the Cisco EPN Manager server to perform time synchronization over NTP. Failure to manage NTP synchronization across your network can result in anomalous results. Management of network time accuracy is an extensive subject that involves your organization's network architecture and falls outside the scope of this guide. For more information on this topic, see (for example) the Cisco white paper *Network Time Protocol: Best Practices*.

Note the following:

- Because using NTP creates the possibility of security breach-related disruptions, you should also harden the NTP aspect of the Cisco EPN Manager server by using NTP version 4 (NTPv4). Cisco EPN Manager also supports NTPv3 because NTPv4 is backward compatible with NTPv3.
- You can configure a maximum of 3 NTP servers with Cisco EPN Manager.
Set Up NTP on the Cisco EPN Manager Server

To use the Network Time Protocol (NTP) to synchronize clocks on the server and network devices using an NTP server, NTP must first be set up on the Cisco EPN Manager server. For information on how to do this, see Set Up NTP on the Server, on page 716.

Enable Authenticated NTP Updates

Complete the following procedure to set up authenticated NTP updates:

**Step 1**
Log into Cisco EPN Manager using the command line, as explained in Establish an SSH Session With the Cisco EPN Manager Server, on page 716.

**Step 2**
Enter config mode.

**Step 3**
Enter the following command to setup an external NTPv4 server:

```
ntp server serverIP userID plain password
```

Where:
- **serverIP** is the IP address of the authenticating NTPv4 server you want to use.
- **userID** is the md5 key id of the NTPv4 server.
- **password** is the corresponding plain-text md5 password for the NTPv4 server.

For example:
```
ntp server 209.165.202.128 20 plain myPass123
```

**Step 4**
Perform these tests to ensure NTP authentication is working correctly:

a) Check the NTP update details:
```
show run
```

b) Check NTP sync details:
```
show ntp
```

Configure External NFS-Based Storage Servers

NFS servers may be used as external storage in a Cisco EPN Manager installation, especially for data backup. Since NFS does not have built-in security, you must implement as many of the following security measures as possible to secure the NFS server:

- Set up a firewall in front of the NFS server—To do this practically, tie down the ports that NFS will use in various configuration files and then specify those ports in the firewall configurations.
- Use a port mapper—On the NFS server, only allow NFS transactions that involve specific IP addresses.
To prevent attacks via a compromised DNS, only specify IP addresses (and not domain names) when configuring NFS.

When setting up the export of folders, use the `root_squash` option in the `/etc/exports` file.

When configuring the `/etc/exports` file, use the `secure` option.

When configuring the backup staging and storage folders, use the `nosuid` and `noexec mount` options.

---

**Note**

It is not mandatory to configure a staging folder.

---

For the storage folder (and optional staging folder), configure a file access permission value of 755 (which grants all users read and write privileges) and set userid **65534** (the user **nobody**, who does not have any system privileges) as the owner.

Tunnel NFS traffic either through SSH or SSL/TLS. For SSH, use RSA key-based authentication instead of user authentication.

Do not rely on just one of these measures to secure your NFS-based storage. Your best bet is to implement the combination of measures that best suits your situation. Also keep in mind that this list is not an exhaustive one. To achieve a higher level of confidence when hardening your storage, we recommend that you discuss your situation with a Linux system admin and a security expert beforehand.

---

**CSDL Process**

Cisco EPN Manager development adheres to the Cisco Secure Development Lifecycle (CSDL) process. This covers the entire development-to-deployment timespan to improve product and installation security. Cisco EPN Manager’s product design is reviewed from a security viewpoint against specific criteria and the product is tested using security tools and test methods. In addition, Cisco EPN Manager is reviewed by external security experts and penetration testers. See Cisco Security Issue Resolution Process for a description of how security fixes are deployed (as part of the Cisco EPN Manager update lifecycle).

---

**Cisco Security Issue Resolution Process**

There are 2 types of defects and vulnerabilities: customer-found and Cisco-found. Let's cover how Cisco addresses them for Cisco EPN Manager.

**Customer-Found Defects and Vulnerabilities**

1. After a customer raises a service request with the Cisco Technical Assistance Center (TAC), the Cisco TAC opens a case with the support team who (depending on the problem) may open a Cisco Defect and Enhancement Tracking System (CDETS) defect report.

2. Cisco evaluates the defect to determine whether that defect poses a security risk to Cisco EPN Manager. If the defect does pose a security risk, then Cisco categorizes it as a vulnerability. Otherwise, Cisco treats the defect as a regular software defect.

3. Cisco does one of the following:
• For security vulnerabilities, Cisco reports it to the Cisco Product Security Incident Response Team (PSIRT), develops a fix that adheres to Cisco PSIRT guidelines, and then allows Cisco PSIRT to handle both the disclosure of the vulnerability to the client and delivery of the patch.

• For defects, Cisco determines its severity and schedules the release of a fix.

**Cisco-Found Defects and Vulnerabilities**

For the first year following the end-of-sale date for a Cisco EPN Manager version, Cisco provides bug fixes, maintenance releases, workarounds, or patches for critical bugs and security vulnerabilities reported via the TACS or Cisco.com Web site.
CHAPTER 22

Backup and Restore

• Backup and Restore Concepts, on page 685
• Set Up and Manage Repositories, on page 690
• Set Up Automatic Application Backups, on page 695
• Perform a Manual Backup, on page 697
• Restore Cisco EPN Manager Data, on page 698
• Manage Disk Space Issues During Backup and Restore, on page 701
• Migrate to Another Virtual Appliance Using Backup and Restore, on page 701

Backup and Restore Concepts

• Backup Types: Application and Appliance, on page 685
• Backup Scheduling, on page 686
• Backup Repositories, on page 686
• Backup Filenames, on page 687
• Backup Validation Process, on page 688
• Information That Is Backed Up, on page 688
• Information That Is Not Backed Up, on page 690

Backup Types: Application and Appliance

Cisco EPN Manager supports two types of backups:

• Application backups—Contain Cisco EPN Manager application data but do not include platform data (host-specific settings, such as the server hostname and IP address). Application backup should be used during Cisco EPN Manager upgrade, when you want to move only application data and not the platform/host specific configurations.
• Appliance backups—Contain all application data and platform data (host-specific settings, including the hostname, IP address, subnet mask, default gateway, and so on). Appliance backup should be used for disaster recovery (or to recover from platform hardware or software failures). For example, to recover from any disk or filesystem failure, the standard recovery process would be to reinstall Cisco EPN Manager and then restore from the appliance backup in order to restore all data as well as platform-specific configurations. You would then need to manually reconstruct the HA configurations as they are not included in the appliance backup.
Note:

For details on what is considered application data and what is considered platform data, see Information That Is Backed Up, on page 688.

Note the following about application and appliance backups:

- Application and appliance backups can be restored to the same or a new host, as long as the new host has the same hardware and software configuration as the host from which the backup was taken.
- You can only restore an appliance backup to a host running the same version of the Cisco EPN Manager server software as the server from which the backup was taken.
- When upgrading to a later version of Cisco EPN Manager, application backup and restore can run across different releases, as long as the upgrade path is supported.
- You cannot restore an application backup using the appliance restore command, nor can you restore an appliance backup using the application restore command.

We recommend the following best practices:

- If you are evaluating Cisco EPN Manager, use the default automatic application backup to the local repository.
- If you are running Cisco EPN Manager in a production environment as a virtual appliance, take regular application backups to a remote backup server. You can use the application backups to restore your server for all failures except complete failure of the server hardware.

Backup Scheduling

Cisco EPN Manager performs automatic scheduled application backups. This feature is enabled by default and creates one application backup file every day in the default local backup repository.

You can change this schedule as needed. You can also take an automatic application backup at any time from the web GUI. Appliance backups can only be taken from the command line.

Automatic application backups can create storage space problems if the backup repository is local to the Cisco EPN Manager server. While this is usually acceptable in test implementations, it is not intended to substitute for routine scheduled backups to remote servers in a production environment.

We recommend the following for production environments:

- Set up remote repositories to store the backup files.
- Use the automatic schedule application backup to create backups on the remote repositories on a regular schedule.

Even if you are using scheduled backups, you can still use the command line to create application or appliance backups at any time.

Backup Repositories

By default, automatic application backup feature stores backup files in the local backup repository /localdisk/defaultRepo. You can use the web GUI to create a new local backup repository and then choose...
it when you set up automatic application backups. You can also specify a remote repository but you must create the repository first as described in Set Up and Manage Repositories, on page 690.

When taking application or appliance backups using the command line, you must specify the local or remote repository you want the backup to be stored in. In a production environment, this is normally a remote repository that is accessed via NFS, SFTP, or FTP. We recommend you use NFS because it is typically much faster and more reliable than other protocols.

There is no difference between performing an application backup from the command line or performing it from the web GUI. Both actions create the same backup file.

Whenever you use NFS to take backups or restore data from a remote backup, make sure the mounted NFS server remains active throughout the backup or restore operation. If the NFS server shuts down at any point in the process, the backup or restore operation will hang without warning or an error message.

### Backup Filenames

**Application backups launched from the web GUI**—either automatically or manually—are assigned a filename with the following format:

`host-yyyymm-ddhhmm_VERver_BKSZsize_CPUcpus_MEMtarget_RAMram_SWAPswap_APP_APP_CK_checksum.tar.gpg`

**Application backups launched from the CLI** use the same format, except that the file starts with the user-specified filename rather than the server name.

`filename-yyyymm-ddhhmm_VERver_BKSZsize_CPUcpus_MEMtarget_RAMram_SWAPswap_APP_APP_CK_checksum.tar.gpg`

**Appliance backups launched from the CLI** have files that also start with the user-specified filename, but the type is indicated as SYS, not APP.

`filename-yyyymm-ddhhmm_VERver_BKSZsize_CPUcpus_MEMtarget_RAMram_SWAPswap_SYS_SYS_CK_checksum.tar.gpg`

The following table describes the variables used by the backup files.

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>host</code></td>
<td>Host name of the server from which the backup was taken (for application backups launched from web GUI).</td>
</tr>
<tr>
<td><code>filename</code></td>
<td>Filename specified by user in command line (for application backups launched from CLI, and for appliance backups)</td>
</tr>
<tr>
<td><code>yyyymm-ddhhmm</code></td>
<td>Date and time the backup was taken</td>
</tr>
<tr>
<td><code>ver</code></td>
<td>Internal version.</td>
</tr>
<tr>
<td><code>size</code></td>
<td>Total size of the backup</td>
</tr>
<tr>
<td><code>cpus</code></td>
<td>Total number of CPUs in the server from which the backup was taken</td>
</tr>
<tr>
<td><code>target</code></td>
<td>Total amount of system memory in the server from which the backup was taken</td>
</tr>
<tr>
<td><code>ram</code></td>
<td>Total amount of RAM in the server from which the backup was taken</td>
</tr>
<tr>
<td><code>swap</code></td>
<td>Total size of the swap disk on the server from which the backup was taken</td>
</tr>
<tr>
<td><code>checksum</code></td>
<td>Backup file checksum</td>
</tr>
</tbody>
</table>
Backup Validation Process

Cisco EPN Manager performs the following steps to validate the backup files:

1. Before starting the backup process, validates disk size, fast-recovery area, and control files.
2. Validates the created backup database to ensure that it can be restored.
3. Validates the zipped application data against the files that were backed up.
4. Validates the TAR file to make sure it is correct and complete.
5. Validates the GPG file to ensure that it is correct.

If you manually transfer the backup file, or if you want to verify that the backup file transfer is completed, view the file's md5CheckSum and file size.

Another best practice for validating a backup is to restore it to a standalone "test" installation of Cisco EPN Manager.

Information That Is Backed Up

The following table describes the information that is contained in backup files. This information is restored to the server from backups.

See Information That Is Not Backed Up, on page 690 for details about data that is not saved by the backup mechanism.

---

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Feature</th>
<th>Information Saved and Restored</th>
</tr>
</thead>
</table>

Note: The /opt/CSCO/lumos/conf/Migration.xml file contains all configuration files and reports that are backed up. This file is included in the backup and is restored.
<table>
<thead>
<tr>
<th>Application Data</th>
<th>Background job settings</th>
<th>Data in the database</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration archive (device configuration files)</td>
<td>Data in the database</td>
<td></td>
</tr>
</tbody>
</table>
| Configuration templates | Files in /opt/CSCOlumos:  
  • /conf/ootb  
  • /xmp_inventory/dar/customized-feature-parts/CONFIGURATION  
  • Data in the database | |
| Credentials | Data in the database | |
| Device inventory data | Data in the database | |
|Licenses | Files in /opt/CSCOlumos/licenses | |
| Maps | Files in /opt/CSCOlumos/domainmaps  
  • Data in the database | |
| Reports | Files in /localdisk/ftp:  
  • /reports  
  • /reportsOnDemand  
  • Data in the database | |
| Managed device software image files | Data in the database | |
| System settings | Data in the database | |
| User preferences | Files in /opt/CSCOlumos/conf/wap/datastore/webacs/xml/prefs  
  • Data in the database | |
|CEPNMusers, groups, and roles | Data in the database | |
| Virtual domains | Data in the database | |
Information That Is Not Backed Up

Before performing a backup, make sure that you manually note the following information because it is not saved as part of the backup process. You will need to reconfigure these settings after the data has been restored.

- High availability configurations
- Local customization (for example, report heap size)

Patch history information is also not saved.

For a list of information that is backed up, see Information That Is Backed Up, on page 688.

Set Up and Manage Repositories

Cisco EPN Manager supports the following repository types:

- Local repositories—NFS
- Remote repositories—NFS, FTP, SFTP

See the following topics for information on how to set up and manage these different types of repositories.

Create a Local Backup Repository

Cisco EPN Manager stores automatic backup files in the default local backup repository /localdisk/defaultRepo. You can create a different local backup repository and use it if you prefer.

<table>
<thead>
<tr>
<th>Platform Data</th>
<th>CLI settings</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>All CLI information and settings are preserved. This includes the list of backup repositories, the FTP user name, users created using the CLI, AAA information specified via the CLI, and other CLI settings (such as the terminal timeout).</td>
</tr>
<tr>
<td>Credentials</td>
<td>Linux OS credentials file</td>
</tr>
<tr>
<td>Network settings</td>
<td>Files in /opt/CSCOlinux/conf/rfm/classes/com/cisco/packaging/PortResources.xml</td>
</tr>
<tr>
<td>Linux user preferences</td>
<td>Linux data structure</td>
</tr>
<tr>
<td>Linux users, groups, and roles</td>
<td>Linux data structure</td>
</tr>
</tbody>
</table>
1. Click Create. The Create Backup Repository dialog box opens.

2. Enter the name of the local repository you want to create.

3. If it is an FTP repository, check the FTP check box and enter the location and credentials.

4. Click Submit. The new repository is added to the Backup Repository drop-down list in the Edit Job Properties dialog box.

**Step 6** Click Save.

**Step 7** If you want to use the repository for future automatic application backups, specify it as described in Specify the Backup Repository for Automatic Backups, on page 696.

---

**Use a Remote Backup Repository**

In production environments, we recommend that you use remote repositories for backups so that your network management data is protected from hardware and site failures. In most cases, this means you will need to:

1. Create one or more remote repositories to hold Cisco EPN Manager backup files. You will need to set these up yourself if your organization does not already have remote backup servers.

2. Specify the remote repository as the destination for automatic application backups.

3. If needed, specify the interval between automatic application backups and time of day to take them. You will need to monitor and manually archive automatic application backups stored on remote repositories (because the Max backups to keep setting does not apply to remote repositories).

4. Specify the remote repository as the backup destination when taking an application or appliance backup using the CLI backup commands.

As with any resource that you plan to access remotely, specifying the correct server IP address and login credentials during setup are a requirement for successful use of remote backup repositories with Cisco EPN Manager.

**Use Remote NFS Backup Repositories**

To use NFS-based remote backup repositories, you need an NFS file server (which exports the designated folders in its file system to its client) and Cisco EPN Manager (which acts as the server’s client). The Cisco EPN Manager system mounts the exported folders and makes them, along with other local folders, available to the Cisco EPN Manager server. To set this up, complete the following three tasks:

1. Specify the paths for the two folders on the NFS server that will stage and store backups, then configure the NFS server to export these paths. Since this falls outside of the scope of Cisco EPN Manager setup, this task should be completed by the NFS server’s system admin.

2. Set up Cisco EPN Manager to use the staging and storing folders you specified. This should be completed by a Cisco EPN Manager admin.

3. Secure communication between the NFS server and Cisco EPN Manager, which is very important because NFS is not secure on its own. This should be completed by a Linux admin who has a solid understanding of the security issues that NFS and its installation entails. For tips on hardening NFS, see Harden NFS-Based Storage.
Before You Set Up the NFS Backup Configuration

Before you begin, make sure:

- You know the IP address of the NFS server on which you want to stage and store backups. The staging and storage folders can be on the same NFS server, or on separate NFS servers. If you plan to stage and store on separate NFS servers, you will need IP addresses for both servers.
- You know the path names of the staging and storage folders on the NFS server. If you choose to stage and store on the same NFS server, the staging and storage folders must have different names.
- You have an administrator user ID with root privileges on the Cisco EPN Manager server.
- You have selected a repository name on the Cisco EPN Manager server, which will point to the NFS server storage folder.

Set Up NFS-Based Remote Repositories

Complete the following procedure to set up the NFS-based remote repositories that Cisco EPN Manager will use for backups.

**Step 1**
Log into the server as the Cisco EPN Manager CLI admin user. See Establish an SSH Session With the Cisco EPN Manager Server, on page 716.

**Step 2**
Enter configuration mode:
```
configure terminal
config#
```

**Step 3**
Set up the NFS remote repositories that will stage the temporary files created during backup processing and store completed backup files:
```
config# backup-staging-url nfs://Staging_Server_IP_Address:/Staging_Server_Path
config# repository repositoryName
config-Repository# url nfs://Storage_Server_IP_Address:/Storage_Server_Path
```

Where:

- `Staging_Server_IP_Address` is the IP address of the NFS server on which the staging repository is located.
- `Staging_Server_Path` is the full path of the staging repository on its host NFS server.
- `repositoryName` is the name of the remote repository that will store completed backup files.
- `Storage_Server_IP_Address` is the IP address of the NFS server on which the storage repository is located.
- `Storage_Server_Path` is the full path of the storage repository on its host NFS server.

**Caution**
We recommend that you only enter an IP address for `Staging_Server_IP_Address` and `Storage_Server_IP_Address`. If the DNS service has been compromised and you enter a URL instead, this can result in the redirection of traffic to a malicious NFS server. That said, if you still prefer to specify a URL, we suggest you configure Cisco EPN Manager to use local name resolution (instead of relying on the DNS service). This can be done by entering the NFS server's name and IP address in the `/etc/hosts` file. Doing so can improve system security.

**Step 4**
Exit configuration mode:
Use Remote FTP Backup Repositories

We recommend using remote NFS repositories.

You can create backup repositories on a remote FTP server and configure the Cisco EPN Manager server to use them.

The FTP server hosting your backups can be set up anywhere in your network, as long as the server:

• Has an IP address accessible from the Cisco EPN Manager server.
• Has a user (FTP user) with write access to the FTP server disk.
• Has a local subdirectory that matches the repository name you specify on the Cisco EPN Manager server.
• Has a password of 16 characters or less.

Other than these requirements, no other configuration is needed on the FTP backup server.

For the SFTP server details to appear in the Backup Repository drop-down list in the web GUI, you should configure the FTP server using the CLI. You can configure the FTP server only using the CLI.

Step 1 Log into the server as the Cisco EPN Manager CLI admin user. See Establish an SSH Session With the Cisco EPN Manager Server, on page 716.

Step 2 Enter configuration mode:
```
configure terminal
config#
```

Step 3 Configure a symbolic link to the remote FTP server, then exit configuration mode:
```
config# repository repositoryName
config-Repository# url ftp://RemoteServerIP//sharedFolder
config-Repository# user userName password plain userPassword
config-Repository# exit
config# exit
```

Where:

• `repositoryName` is the name of the repository (for example, MyRepo or EPNManager).
• `RemoteServerIP` is the IP address of the FTP server hosting the shared backup folder.
• `sharedFolder` is the name of the shared backup folder on the FTP server.
• `userName` is the name of the user with write privileges to the repository on the FTP server.
• `userPassword` is the corresponding password for that user. The password must be 16 characters or less.

Step 4 Verify the creation of the symbolic link:
Use Remote SFTP Backup Repositories

Note
We recommend using remote NFS repositories.

You can create backup repositories on a remote SFTP server and configure the Cisco EPN Manager server to use them.

The SFTP server hosting your backups can be set up anywhere in your network, as long as the server:

- Has an IP address accessible from the Cisco EPN Manager server.
- Has a user with write access to the SFTP server disk.
- Has a local shared folder where the backups will be stored.

Other than these requirements, no other configuration is needed on the SFTP backup server.

For the SFTP server details to appear in the Backup Repository drop-down list in the web GUI, you should configure the SFTP server using the CLI. You can configure the SFTP server only using the CLI.

Step 1
Log into the server as the Cisco EPN Manager CLI admin user. See Establish an SSH Session With the Cisco EPN Manager Server, on page 716.

Step 2
Enter configuration mode:
```
configure terminal
config#
```

Step 3
Configure a symbolic link to the remote SFTP server, then exit configuration mode:
```
config# repository repositoryName
config-Repository# url sftp://RemoteServerIP//sharedFolder
config-Repository# user userName password plain userPassword
config-Repository# exit
config# exit
```

Where:

- `repositoryName` is the name of the repository (for example, MyRepo or EPNManager).
• RemoteServerIP is the IP address of the SFTP server hosting the shared backup folder. Note that the example above specifies an absolute path to the shared folder. To specify a relative path to the shared folder, use only one slash in the URL (for example, url sftp://RemoteServerIP/sharedfolder).

• sharedFolder is the name of the shared backup folder on the SFTP server.

• userName is the name of the user with write privileges to the repository on the SFTP server.

• userPassword is the corresponding password for that user.

Step 4 Verify the creation of the symbolic link:

```
show repository repositoryName
```

What to do next

When you perform a manual backup, specify the new repository as the repository name in the backup command. For example:

```
backup MyBackupFileName repository MyRepo application NCS
```

If you want to use this repository for automatic backups, see Specify the Backup Repository for Automatic Backups, on page 696.

Delete a Local Backup Repository

Use the following procedure to delete a local backup repository. This procedure ensures that the admin interface has the updated information.

Step 1 Log into the server as a Cisco EPN Manager CLI admin user (see Establish an SSH Session With the Cisco EPN Manager Server, on page 716).

Step 2 List the local application backup repositories and identify the one that you want to delete:

```
show running-config | begin repository
```

Step 3 Enter configuration mode and delete the repository:

```
configure terminal
(config)# no repository repositoryName
```

Step 4 Repeat step 2 to verify that the repository was deleted.

Set Up Automatic Application Backups

Automatic application backups are enabled by default after installation. You can customize the schedule, specify a different backup repository, or adjust the number of backups that are saved.

To check what data is saved by the backup mechanism (and verify whether you need to manually save any data that is not backed up), see these topics:
Schedule Automatic Application Backups

Automatic application backups are enabled by default but you can adjust the day and interval at which these backups are performed. Performing a backup is resource-intensive and affects Cisco EPN Manager server performance. Avoid scheduling automatic backups to occur at peak traffic times.

If an automatic application backup fails, Cisco EPN Manager generates a Backup Failure alarm (with major severity). You can view these alarms just as you do other alarms (see Find and View Alarms, on page 233). You can also get email notifications for these alarms if you include the System alarm category in your email notification settings (see Forward Alarms and Events as Email Notifications, on page 241).

Note

After an automatic application backup fails, a pop-up message is displayed before every subsequent login attempt. This message will continue to appear until you acknowledge the corresponding alarm.

Step 1
Choose Administration > Dashboards > Job Dashboard.
Step 2
Choose System Jobs > Infrastructure.
Step 3
In the Jobs list, check the Server Backup check box, then click Edit Schedule. The Schedule dialog box opens.
Step 4
In the Schedule dialog box, select a start date, recurrence interval, and optional end time.
Step 5
Click Submit. These settings will now be used for future automatic application backups.

Specify the Backup Repository for Automatic Backups

You can use the Cisco EPN Manager interface to specify a different backup repository for automatic application backups. The backup repository can be local or remote. You can also use the interface to create a new local backup repository if it does not already exist.

Before you begin

If you want to use a remote repository for automatic backups, you must create the repository first. Only local repositories can be created using this procedure. See Set Up and Manage Repositories, on page 690.

Step 1
Choose Administration > Dashboards > Job Dashboard.
Step 2
Choose System Jobs > Infrastructure.
Step 3
In the list of jobs, check the Server Backup check box.
Step 4
Click Edit (the pencil icon). The Edit Job Properties dialog box opens.
Step 5
Select a repository from the Backup Repository drop-down list, then click Save. Cisco EPN Manager will use the new repository when it performs the next automatic application backup.
Change the Number of Automatic Application Backups That Are Saved

Follow this procedure to adjust the number of automatic application backups that are saved on a local repository. When a backup exceeds the number you specify here, Cisco EPN Manager deletes the oldest backup from the repository.

The Max UI backups to keep setting does not apply if you are using remote repositories for automatic application backups. You must monitor and archive or delete old backups on remote repositories using your own methods.

**Step 1** Choose Administration > Dashboards > Job Dashboard.

**Step 2** Choose System Jobs > Infrastructure.

**Step 3** In the Jobs list, check the Server Backup check box.

**Step 4** Click Edit (the pencil icon) to open the Edit Job Properties dialog box.

**Step 5** Enter a value in the Max UI backups to keep field, then click Save. Cisco EPN Manager will enforce this setting at the next backup.

Perform a Manual Backup

The topics in this section explain how to perform manual application or appliance backups. To check what data is saved by the backup mechanism (and verify whether you need to manually save any data that is not backed up), see these topics:

- Information That Is Backed Up, on page 688
- Information That Is Not Backed Up, on page 690

Perform an Immediate Application Backup

Cisco EPN Manager performs automatic application backups as described in Backup Scheduling, on page 686. If needed, you can manually trigger an application backup as described in the following topics.

Perform an Immediate Application Backup Using the Web GUI

Use this procedure to trigger an immediate application backup using the web GUI.

**Step 1** Choose Administration > Dashboards > Job Dashboard.

**Step 2** Choose System Jobs > Infrastructure.

**Step 3** In the Jobs list, check the Server Backup check box, then click Run.

**Step 4** To view the backup status, scroll to the top of the table to locate the new job, then check its status and results.
Perform an Immediate Application Backup Using the CLI

Use this procedure to trigger an immediate application backup using the CLI.

Step 1 Log into the server as a Cisco EPN Manager CLI admin user (see Establish an SSH Session With the Cisco EPN Manager Server, on page 716).

Step 2 Display the list of backups, where repositoryName is the backup repository:

```
show repository repositoryName
```

Step 3 Start the remote backup:

```
backup filename repository repositoryName application NCS
```

where filename is the name that you want to give the appliance backup file (for example, myBackup). The character length of the file name is 26. Other information is appended to the filename automatically, as explained in Backup Filenames, on page 687.

Perform a Manual Appliance Backup

Use this procedure to perform an appliance backup to a remote repository. Be sure you have configured the remote repository as described in Set Up NFS-Based Remote Repositories, on page 692.

Step 1 Make sure the remote host is available.

Step 2 Log into the Cisco EPN Manager server as admin (see Establish an SSH Session With the Cisco EPN Manager Server, on page 716).

Step 3 Start the remote backup:

```
(admin)# backup filename repository repositoryName
```

Step 4 To verify that the backup transfer is complete, view the md5CheckSum and file size.

Restore Cisco EPN Manager Data

All restore operations are performed using the CLI. Data can be restored to the host where the backup is executed (local host), or to a remote host. Backups can only be restored in their entirety; you cannot restore only parts of a backup.

See these topics for more information:

- Restore an Application Backup, on page 699
- Restore an Appliance Backup, on page 699
Restore an Application Backup

To restore an appliance backup, use the procedure in Restore an Appliance Backup, on page 699.

Note

When you restore an application backup, make sure it is being restored to an OVA installation of the same size or larger. If the OVA installation is smaller, the restore will fail.

Before you begin

If you are using high availability, read the guidelines in Remove HA During Restore, on page 844 before restoring your data.

Step 1
Log into the server as a Cisco EPN Manager CLI admin user (see Establish an SSH Session With the Cisco EPN Manager Server, on page 716).

Step 2
If a previous restoration attempt failed, the database may have been corrupted. Run this command to recreate the database:

\texttt{ncs run reset db}

Step 3
List the saved application backups and identify the one that you want to restore. \texttt{repositoryName} is the repository that contains the backup files.

\texttt{show repository \textit{repositoryName}}

Step 4
From the VMware vSphere client (OVA) or the Cisco IMC server (Bare Metal), restore the data:

\texttt{restore backupFileName repository \textit{repositoryName} application NCS}

Step 5
If you are using Cisco Smart Licensing, re-register Cisco EPN Manager with the Cisco Smart Software Manager (CSSM) on Cisco.com. See Register Cisco EPN Manager with the Cisco Smart Software Manager, on page 659.

Restore an Appliance Backup

To restore an application backup, use the procedure in Restore an Application Backup, on page 699.

Note

When you restore an appliance backup, make sure it is being restored to an OVA installation of the same size or larger. If the OVA installation is smaller, the restore will fail.

Cisco recommends that you change the restored server’s IP address, subnet mask, and default gateway if:

\begin{itemize}
  \item The restored host is on the same subnet as the old host, and the old host is still active.
  \item The restored host is on a different subnet from the old host.
\end{itemize}

Before you begin

If you are using high availability, read the information in Remove HA During Restore, on page 844 before restoring your data.
**Step 1** Log into the server as a Cisco EPN Manager CLI admin user (see Establish an SSH Session With the Cisco EPN Manager Server, on page 716).

**Step 2** If a previous restoration attempt failed, the database may have been corrupted. With the backup stored in an external repository, reinstall the setup using the same release and then retry the restore.

**Step 3** List the saved appliance backups and identify the one that you want to restore. repositoryName is the repository that contains the backup files.

```
show repository repositoryName
```

**Step 4** From the vmWare vSphere client (OVA) or the Cisco IMC server (Bare Metal), restore the data:

```
restore backupFileName repository repositoryName
```

**Step 5** Determine whether you should change the IP address, subnet mask, and default gateway.

a) Check if your installation meets the following criteria:

- The restored host is on the same subnet as the old host, and the old host is still active.
- The restored host is on a different subnet from the old host.

If it does, perform the next step.

b) Change the IP address, subnet mask, default gateway and (optionally) the host name on the restored server.

c) Write the changes to the server’s running configuration and restart Cisco EPN Manager services. For example:

```
configure terminal
(config)# int GigabitEthernet 0
(config-GigabitEthernet)# ip address IPAddress subnetMask
(config-GigabitEthernet)# exit
(config)# ip default-gateway gatewayIP
(config)# hostname hostname
(config)# exit
(admin)# write mem
(admin)# ncs stop
(admin)# ncs start
(admin)# exit
```

**Step 6** If you are using Cisco Smart Licensing, re-register Cisco EPN Manager with the Cisco Smart Software Manager (CSSM) on Cisco.com. See Register Cisco EPN Manager with the Cisco Smart Software Manager, on page 659.

---

**Recover from Failed Restores**

You may sometimes find that a restore does not complete, or reports a failure. Whenever a restore fails, you run the risk of database corruption, which can prevent the further restoration or re-installation. Perform the following steps to restore a corrupted database before attempting another restore or re-installation.

**Step 1** Open a CLI session with the Cisco EPN Manager server (see Establish an SSH Session With the Cisco EPN Manager Server, on page 716).

**Step 2** Enter the following command to reset the corrupted database:

```
ncs run reset db
```
Manage Disk Space Issues During Backup and Restore

If you are experiencing disk issues during a backup or restore, move your installation to a server with adequate disk space by following the procedure in Migrating to Another Virtual Appliance Using Backup and Restore, on page 701.

If you are unable to create a backup after a restore of your existing system, follow the steps explained in Compact the Database, on page 723 to free disk space and create a successful backup. If you are still unable to create a backup after using the `ncs cleanup` command, set up and use a remote repository (using NFS, FTP, or SFTP) for your backups, as explained in Using a Remote Backup Repository, on page 691.

Migrate to Another Virtual Appliance Using Backup and Restore

You will need to migrate your Cisco EPN Manager data from an existing virtual appliance (OVA server installation) to a new one whenever you want to:

- Replace the old server entirely, such as after a catastrophic hardware failure. In this case, you can use your old installation media to re-create the new host on a replacement server, then migrate your application data from the old host to the new host.
- Migrate to a larger or more powerful server, so you can use Cisco EPN Manager to manage more of your network. In this case, you will want to ensure that you have the OVA installation file and install it on the new server using the larger installation option before retiring the older, smaller one. You can then migrate your application data from the old host.

In both cases, it is relatively easy to migrate your old data to the new virtual appliance by restoring to the new host an appliance or application backup taken from the old host.

| Step 1 | If you have not already done so, set up a remote backup repository for the old host, as explained in Use a Remote Backup Repository, on page 691. |
| Step 2 | Perform an application backup of the old host and save it to the remote repository (see Perform an Immediate Application Backup Using the CLI, on page 698). |
| Step 3 | Install the new host (installation steps are in the Cisco Evolved Programmable Network Manager Installation Guide). |
| Step 4 | Configure the new host to use the same remote backup repository as the old host (see Use a Remote Backup Repository, on page 691). |
| Step 5 | Restore the application backup on the remote repository to the new host (see Restore an Application Backup, on page 699). |
CHAPTER 23

Server Health and Configuration

- View the Cisco EPN Manager Server Configuration, on page 703
- Change the Cisco EPN Manager Hostname, on page 704
- Secure the Connectivity of the Cisco EPN Manager Server, on page 705
- Establish an SSH Session With the Cisco EPN Manager Server, on page 716
- Set Up NTP on the Server, on page 716
- Set Up the Cisco EPN Manager Proxy Server, on page 717
- Set Up the SMTP E-Mail Server, on page 717
- Enable FTP/TFTP/SFTP Service on the Server, on page 718
- Configure Stored Cisco.com Credentials, on page 718
- Create a Login Banner (Login Disclaimer), on page 719
- Stop and Restart Cisco EPN Manager, on page 719
- Configure Global SNMP Settings for Communication with Network Elements, on page 719
- Manage Administrative Passwords, on page 720
- Check Cisco EPN Manager Server Health, Jobs, Performance, and API Statistics Using the System Monitoring Dashboard, on page 722
- Improve the Cisco EPN Manager Server Performance, on page 723
- Work With Server Internal SNMP Traps That Indicate System Problems, on page 724
- Set Up Defaults for Cisco Support Requests, on page 726
- Configure Cisco Product Feedback Settings, on page 726
- Monitor Backups, on page 727

View the Cisco EPN Manager Server Configuration

Use this procedure to view Cisco EPN Manager server configuration information such as the current server time, kernel version, operating system, hardware information, and so forth.

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Choose Administration &gt; Dashboards &gt; System Monitoring Dashboard.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>Click the Overview tab.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Click System Information at the top left of the dashboard to expand the System Information field.</td>
</tr>
</tbody>
</table>
Change the Cisco EPN Manager Hostname

Cisco EPN Manager prompts you to enter a hostname when you install the server. For a variety of reasons, you may find a mismatch between the hostname configured on the Cisco EPN Manager server and the hostname configured elsewhere. You can resolve this issue without reinstalling Cisco EPN Manager by changing its hostname on the server. To do so:

**Step 1**
Open a CLI session with the Cisco EPN Manager server, making sure you enter `configure terminal` mode. See *Connect via CLI*.

**Step 2**
Enter the following command:

```
Cisco_EPN_Manager_Server/admin(config)#hostname newHostName
```

where `newHostName` is the hostname you want to assign to the Cisco EPN Manager server.

**Step 3**
Restart the Cisco EPN Manager server using the `ncs stop` and `ncs start` commands.

**Step 4**
Check the hostname configured for your SSL server certificate:

- If the hostname is the same as the one you specified in Step 2, you can stop here.
- If the hostname is different, you will need to create a new SSL server certificate configured with the hostname you specified in Step 2 and then install it. See *Set Up HTTPS to Secure the Connectivity of the Web Server*.

Connect via CLI

Administrators can connect to the Cisco EPN Manager server via its command-line interface (CLI). CLI access is required when you need to run commands and processes accessible only via the Cisco EPN Manager CLI. These include commands to start the server, stop it, check on its status, and so on.

**Before you begin**
Before you begin, make sure you:

- Know the user ID and password of an administrative user with CLI access to that server or appliance. Unless specifically barred from doing so, all administrative users have CLI access.
- Know the IP address or host name of the Cisco EPN Manager server.

**Step 1**
Start up your SSH client, start an SSH session via your local machine’s command line, or connect to the dedicated console on the Cisco EPN Manager physical or virtual appliance.

**Step 2**
Log in as appropriate: If you are using a GUI client: Enter the ID of an active administrator with CLI access and the IP address or host name of the Cisco EPN Manager server. Then initiate the connection. If you are using a command-line client or session: Log in with a command like the following:

```
[localhost]# ssh username@IPHost -Where username is the user ID of a Cisco EPN Manager administrator with CLI access to the server. IPHost is the IP address or host name of the Cisco EPN Manager server or appliance. If you are using the console: A prompt is shown for the administrator user name. Enter the user name.
```
Step 3 Enter the administrative ID password. Cisco EPN Manager will present a command prompt like the following:

```plaintext
Cisco_EPN_Manager_Server/admin#
```

Step 4 If the command you need to enter requires that you enter `configure terminal` mode, enter the following command at the prompt:

```plaintext
Cisco_EPN_Manager_Server/admin# configure terminal
```

The prompt will change from `Cisco_EPN_Manager_Server/admin#` to `Cisco_EPN_Manager_Server/admin/conf#`.

Secure the Connectivity of the Cisco EPN Manager Server

For data security, Cisco EPN Manager encrypts data in transit using standard public key cryptography methods and public key infrastructure (PKI). You can obtain more information about these technologies from the internet. Cisco EPN Manager encrypts the data that is exchanged between the following connections:

- Between the web server and the web client
- Between a CLI client and the Cisco EPN Manager CLI shell interface (handled by SSH)
- Between the Cisco EPN Manager and systems such as AAA and external storage

To secure communication between the web server and web client, use the public key cryptography services that are built in as part of the HTTPS mechanism. For that you need to generate a public key for the Cisco EPN Manager web server, store it on the server, and then share it with the web client. This can be done using the standard PKI certificate mechanism which not only shares the web server public key with the web client, but also guarantees that the public key belongs to the web server (URL) you are accessing. This prevents any third party from posing as the web server and collecting sensitive information that the web client is sending to the web server. Follow the procedure in Set Up HTTPS to Secure the Connectivity of the Web Server, on page 705

These topics provide additional steps you can take to secure the web server:

- Cisco recommends that the Cisco EPN Manager web server authenticate web clients using certificate-based authentication. This security hardening procedure is described in Set Up Certificate-Based Authentication for Web Clients, on page 848
- To secure connectivity between a CLI client and the Cisco EPN Manager CLI interface, refer to the security hardening procedures in Harden the Cisco EPN Manager Server, on page 851.
- To secure connectivity between the Cisco EPN Manager and systems such as AAA and external storage, refer to the recommendations in Harden Your Cisco EPN Manager Storage, on page 853.

Set Up HTTPS to Secure the Connectivity of the Web Server

HTTPS operations use a server key that is generated using public key cryptography algorithms, and trust chain certificates that are generated using the server key. These certificates are applied to the Cisco EPN Manager web server. Depending upon how you generated the certificates, you may have to request the client browsers to trust these certificates the first time the browser connects to the web server. The HTTPS mechanism ensures the security of the server machine (which in turn improves security of all other associated systems).
Use one of the following two methods to generate and install the web server certificate (do not use the methods together).

<table>
<thead>
<tr>
<th>Signing Entity</th>
<th>Description</th>
<th>See:</th>
</tr>
</thead>
</table>
| Self-signed certificates | You generate the self-signed certificates and then apply them to the web server. This method can be used on:  
  • Deployments that do not use HA  
  • HA deployments that do not use virtual IP addresses. | Generate and Apply Self-Signed Web Server Certificate, on page 706 |
| Certificate Authority (CA) signed certificates | A Certificate Authority (CA) generates and issues these certificates. The certificates bind a public key to the name of the entity (for example, a server or device) that is identified in the certificate. You must generate a Certificate Signing Request (CSR) file from the Cisco EPN Manager server, and submit the CSR file (which contains the server key) to the CA. When you receive the certificates, you apply them to the web server.  
  These certificates can be generated by an external CA or an internal CA.  
  • External CA—An external CA organization validates identities and issues the certificates, usually for a fee. (Popular browsers are usually pre-installed with Root and Intermediate certificates issued by the external CA organization).  
  • Internal CA—Uses a certificate-generating server within your organization (this avoids a fee). The internal CA functions exactly the same way as an external fee-based CA.  
  This method can be used on:  
  • Deployments that do not use HA  
  • HA deployments that do use virtual IP addresses (including SSL connections between browser-based clients) | Generate and Apply a CA-Signed Web Server Certificate, on page 707 |

**Generate and Apply Self-Signed Web Server Certificate**

The following procedure generates an RSA key and then applies a self-signed certificate with domain information.

**Before you begin**

Make sure you have the fully qualified domain name (FQDN) of the server. You will need it for this procedure.

**Note**

Depending on your deployment, you may need to instruct your users to install the CA-signed Root and Intermediate certificates to their browser or OS certificate store. Ask your organization’s IT administrator if this is required. Instructions are provided in Add the CA-Signed Root and Intermediate Certificates to a Browser/OS Trust Store, on page 714.
Step 1 Log in to the Cisco EPN Manager server as the Cisco EPN Manager CLI admin user.

Step 2 Enter the following command:

```
ncs key genkey -newdn
```

Step 3 To activate the certificate, restart Cisco EPN Manager. See Stop and Restart Cisco EPN Manager, on page 719.

---

### Generate and Apply a CA-Signed Web Server Certificate

The following topics explain how to generate and apply CA-signed certificates to the Cisco EPN Manager web server. The procedures are slightly different depending on whether or not your deployment is using HA, and if it is using HA, whether or not you are using HA with virtual IP addresses.

You may need to instruct your users to install the Root and Intermediate CA certificates to their browser or OS certificate store. Ask your organization's IT administrator if this is required. Instructions are provided in Add the CA-Signed Root and Intermediate Certificates to a Browser/OS Trust Store, on page 714.

<table>
<thead>
<tr>
<th>Deployment Type</th>
<th>Summary of Steps</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deployment without HA</td>
<td>For deployments without HA, you must request the certificate, import it into your web server, and restart the web server to apply it, as described in these topics:</td>
</tr>
<tr>
<td></td>
<td>1. Request a CA-Signed Web Server Certificate, on page 708</td>
</tr>
<tr>
<td></td>
<td>2. Import and Apply a CA-Signed Web Server Certificate—No HA, on page 709</td>
</tr>
<tr>
<td>High availability deployment not using virtual IP addresses</td>
<td>For HA deployments that do not use virtual IPs, you must request separate certificates for the primary and secondary servers and then import the appropriate certificate onto each server. When you restart the servers to apply the certificates, you must restart them in a specific order. The entire procedure is described in these topics:</td>
</tr>
<tr>
<td></td>
<td>1. Request a CA-Signed Web Server Certificate, on page 708</td>
</tr>
<tr>
<td></td>
<td>2. Import and Apply CA-Signed Web Server Certificates—HA Without Virtual IP Addresses, on page 710</td>
</tr>
<tr>
<td>High availability deployment using virtual IP addresses</td>
<td>For HA deployments that use virtual IPs, you only need to request a single certificate for both servers. You must remove HA on the servers, import the certificate on both servers, and then restart the servers to apply the certificate (you must restart the servers in a specific order). Finally, you reconfigure HA by registering the secondary server on the primary server. The entire procedure is described in these topics:</td>
</tr>
<tr>
<td></td>
<td>1. Request, Import, and Apply a CA-Signed Web Server Certificate—HA With Virtual IP Addresses, on page 712</td>
</tr>
<tr>
<td></td>
<td>2. How to Configure HA Between the Primary and Secondary Servers, on page 815</td>
</tr>
</tbody>
</table>
Request a CA-Signed Web Server Certificate

Use this procedure to request a CA-signed web server certificate for your deployment. You should use this procedure if:

- Your deployment does not use HA
- Your deployment uses HA but does not use virtual IP addressing (you will need to perform the following procedure on both servers)

---

**Note**

If your deployment uses HA with virtual IP addresses, use the procedure in Request, Import, and Apply a CA-Signed Web Server Certificate—HA With Virtual IP Addresses, on page 712.

---

**Before you begin**

Make sure SCP is enabled on your machine and all relevant ports are open. This is required so that you can copy files to and from the server.

---

**Step 1**

Generate a Certificate Signing Request (CSR) file for the Cisco EPN Manager server:

- a) Log in to the Cisco EPN Manager server as the Cisco EPN Manager CLI admin user.
- b) Enter the following command to generate the CSR file in the default backup repository (defaultRepo):

  ```
  ncs key genkey -newdn -csr CertName.csr repository defaultRepo
  ```

  where CertName is an arbitrary name of your choice.

---

**Step 2**

Copy the CSR file from the Cisco EPN Manager server to your local machine.

- a) Log in to the Cisco EPN Manager server as the Cisco EPN Manager CLI admin user.
- b) Log in as the Linux CLI root user. See Log In and Out as the Linux CLI root User, on page 746.
- c) Copy the file from the Cisco EPN Manager server to your local machine. For example:

  ```
  scp /localdisk/defaultRepo/CertName.csr clientUserName@clientIP:/destinationFolder
  ```

  d) Log out as the Linux CLI root user.

---

**Step 3**

Submit the CSR file to a Certificate Authority of your choice.

**Note**

Once you have generated and sent the CSR file for certification, do not use the `genkey` command to generate a new key on the same Cisco EPN Manager server. If you do, when you try to import the signed certificate file, you will receive an error due to a mismatch between keys in the file and on the Cisco EPN Manager server.

The CA will send you digitally-signed certificates either in a single file with the name `CertFilename.cer`, or as a set of multiple files.

---

**Step 4**

(HA deployments not using virtual IP addresses) Repeat these steps for the secondary server.

---

**What to do next**

When your receive the certificates from the CA, import and apply the certificates. Use one of the following procedures, depending on your deployment:
• Import and Apply a CA-Signed Web Server Certificate—No HA, on page 709
• Import and Apply CA-Signed Web Server Certificates—HA Without Virtual IP Addresses, on page 710

Import and Apply a CA-Signed Web Server Certificate—No HA

This topic explains how to import and apply CA-signed web server certificates to a deployment that does not use HA.

Before you begin

• You must have the CA-signed certificates you requested using Request a CA-Signed Web Server Certificate, on page 708. You cannot perform the following procedure until you have received the certificates.

• Make sure SCP is enabled on your local machine and all relevant ports are open. This is required so that you can copy files to and from the server.

---

**Step 1**

If you receive only one CER file from the CA, proceed to Step 2. If you receive multiple (chain) certificates, combine (concatenate) them into a single CER file. You will receive three files: the SSL server certificate file, the intermediate CA certificate file, and the root CA server certificate file.

a) Using a text editor, open the three certificate files that you received. Paste the contents of the certificates into a single new file, from top to bottom in this order: your SSL Server certificate, the Intermediate CA certificate, and the Root CA server certificate. Remove any blank lines. This will create a file that looks like the following (the certificate contents are omitted for brevity):  

```plaintext
-----BEGIN CERTIFICATE-----
Your_SSL_Server_Cert_Contents
-----END CERTIFICATE-----

-----BEGIN CERTIFICATE-----
Intermediate_CA_Cert_Contents
-----END CERTIFICATE-----

-----BEGIN CERTIFICATE-----
Root_CA_Cert_Contents
-----END CERTIFICATE-----
```

b) Save this new file with a new name in the format `CertFilename.cer`

**Step 2**

Copy the CER file from your local machine to the backup repository on the Cisco EPN Manager server.

a) Log in to the Cisco EPN Manager server as the Cisco EPN Manager CLI admin user.

b) Log in as the Linux CLI root user. See Log In and Out as the Linux CLI root User, on page 746.

c) Retrieve the file from your local machine and copy it to the Cisco EPN Manager server default backup repository (defaultRepo):

```
scp clientUserName@clientIP:/FullPathToCERfile /localdisk/defaultRepo
```

d) Log out as the Linux CLI root user.

**Step 3**

As the Cisco EPN Manager CLI admin user, import the CER file.

```
ncs key importsignedcert CertFilename.cer repository RepoName
```

**Step 4**

Restart Cisco EPN Manager to activate this certificate. See Stop and Restart Cisco EPN Manager, on page 719.
What to do next

Depending on your deployment, you may need to instruct your users to install the root and intermediate CA certificates to their browser or OS certificate store. See Add the CA-Signed Root and Intermediate Certificates to a Browser/OS Trust Store, on page 714 for more information.

Import and Apply CA-Signed Web Server Certificates—HA Without Virtual IP Addresses

This topic explains how to import and apply CA-signed web server certificates to an HA deployment that is not using virtual IP addresses. (If you have an HA deployment that does use virtual IPs, see Request, Import, and Apply a CA-Signed Web Server Certificate—HA With Virtual IP Addresses, on page 712.) This procedure is similar to the procedure for a deployment that does have HA, except that you have to perform the procedure on both the primary server and the secondary server.

Note
When you restart the servers, follow these steps carefully because the servers must be restarted in a specific sequence.

Before you begin

- You must have the CA-signed certificates you requested using Request a CA-Signed Web Server Certificate, on page 708. You cannot perform the following procedure until you have received the certificates for each server.
- Make sure SCP is enabled on your local machine and all relevant ports are open. This is required so that you can copy files to and from the server.

Step 1

Import the primary certificates onto the primary server.

a) If you received only one CER file from the CA, proceed to Step 1(b). If you received multiple (chain) certificates, combine (concatenate) them into a single CER file. You will receive three files: the SSL server certificate file, the intermediate CA certificate file, and the root CA server certificate file.

1. Using a text editor, open the three certificate files that you received. Paste the contents of the certificates into a single new file, from top to bottom in this order: your SSL Server certificate, the Intermediate CA certificate, and the Root CA server certificate. Remove any blank lines. This will create a file that looks like the following (the certificate contents are omitted for brevity):

   ```
   -----BEGIN CERTIFICATE-----
   Your_SSL_Server_Cert_Contents
   -----END CERTIFICATE-----
   -----BEGIN CERTIFICATE-----
   Intermediate_CA_Cert_Contents
   -----END CERTIFICATE-----
   -----BEGIN CERTIFICATE-----
   Root_CA_Cert_Contents
   -----END CERTIFICATE-----
   ```

2. Save this new file with a new name in the format CertFilename.cer.

b) Log in to the primary Cisco EPN Manager server as the Cisco EPN Manager CLI admin user.
c) Log in as the Linux CLI root user. See Log In and Out as the Linux CLI root User, on page 746.
d) Retrieve the CER file from your local machine and copy it to the Cisco EPN Manager server's default backup repository (defaultRepo):
Step 2 Perform the previous step on the secondary server.

Step 3 On the secondary server, import the CER file.
  a) Log in as the Cisco EPN Manager CLI admin user and stop the server:
     
     ncs stop
  
  b) Verify that the secondary server is stopped.
  
  c) Import the CER file:
     
     ncs key importsignedcert CertFilename.cer repository RepoName
  
     Note Do not restart the secondary server until you reach Step 5.

Step 4 On the primary server, import the CER file.
  a) Log in as the Cisco EPN Manager CLI admin user and stop the server:
     
     ncs stop
  
  b) Verify that the primary server is stopped.
  
  c) Import the CER file:
     
     ncs key importsignedcert CertFilename.cer repository RepoName
  
     Note Do not restart the primary server until you reach Step 6.

Step 5 On the secondary server, run the following commands:
  a) Run the ncs start command to restart the server.
  
  b) Verify that the secondary server has restarted.
  
  c) Run the ncs status command and verify that the HA status of the secondary server is Secondary Lost Primary.

Step 6 On the primary server, run the following commands:
  a) Run the ncs start command to restart the server.
  
  b) Verify that the primary server has restarted.
  
  c) Run the ncs status command and make sure that the Health Monitor process and other processes have restarted.

Once all the processes on the primary server are up and running, HA registration is automatically triggered between the secondary and primary servers (and an email is sent to the registered email addresses). This normally completes after a few minutes.

Step 7 Verify the HA status on the primary and secondary servers by running the ncs ha status command on both servers. You should see the following:

• The primary server state is Primary Active.

• The secondary server state is Secondary Syncing.
What to do next

Depending on your deployment, you may need to instruct your users to install the root and intermediate CA certificates to their browser or OS certificate store. See Add the CA-Signed Root and Intermediate Certificates to a Browser/OS Trust Store, on page 714 for more information.

Request, Import, and Apply a CA-Signed Web Server Certificate—HA With Virtual IP Addresses

If you have a high availability deployment that uses virtual IP addresses, you need to make only one certificate request. When you receive the certificate from the CA, you install the same certificate on both the primary and secondary servers. This is different from HA deployments that do not use IP addressing, where you make two certificate requests and install one certificate on the primary server and the other (different) certificate on the secondary server.

For more information on virtual IPs and HA, see Using Virtual IP Addressing With HA, on page 815

Before you begin

Make sure SCP is enabled on your machine and all relevant ports are open. This is required so that you can copy files to and from the server.

Step 1

Generate a CSR file and private key for the primary and secondary servers. You will install the private key on both servers, and submit the CSR file to a Certificate Authority of your choice. The following example shows how to create these files using openssl in Linux.

a) Generate the CSR file in the default backup repository.

```
openssl req -newkey rsa:2048 -nodes -keyout ServerKeyFileName -out CSRFileName -config opensslCSRconfigFileName
```

where:

- `ServerKeyFileName` is the name you want to use for the private key file.
- `CSRFileName` is the name that you want to use for the CSR request file, which will be submitted to the CA.
- `opensslCSRconfigFileName` is the name of the file that contains the openssl configurations used to generate the CSR file.

b) Using a text editor, edit the file with openssl configurations (opensslCSRconfigFileName in (a)) to have contents similar to the following.

```
[req]
distinguished_name = req_distinguished_name
req_extensions = v3_req

[req_distinguished_name]
countryName = Country
countryName_default = US
stateOrProvinceName = State
stateOrProvinceName_default = CA
localityName = City
localityName_default = San Jose
organizationName = Organization
organizationName_default = Cisco Systems
organizationalUnitName = Organizational Unit
organizationalUnitName_default = CSG
commonName = Common Name
commonName_default = example.cisco.com
commonName_max = 64
```
Extensions to add to a certificate request

```
[ v3_req ]
# Extensions to add to a certificate request
basicConstraints = CA:FALSE
keyUsage = nonRepudiation, digitalSignature, keyEncipherment
subjectAltName = @alt_names

[alt_names]
DNS.1 = example.cisco.com
DNS.2 = example-pri.cisco.com
DNS.3 = example-sec.cisco.com
IP.1 = 209.165.200.224
IP.2 = 209.165.200.225
IP.3 = 209.165.200.226
```

In this example:

- The virtual IP address is 209.165.200.224. The FQDN for is `example.cisco.com`. The FQDN is also used for the DNS server name.
- The primary server IP address is 209.165.200.225. Its hostname is `example-pri`. This hostname should be included in `/etc/hosts` and other hostname setting files.
- The secondary server IP address is 209.165.200.226. Its hostname is `example-sec`.

**Step 2**
Submit the CSR file to a Certificate Authority of your choice. The CA will send you digitally-signed certificates either in a single file with the name `CertFilename.cer`, or as a set of multiple files.

**Step 3**
If you receive only one CER file from the CA, proceed to Step 4. If you receive multiple (chain) certificates, combine (concatenate) them into a single CER file. You will receive three files: the SSL server certificate file, the intermediate CA certificate file, and the root CA server certificate file.

a) Using a text editor, open the three certificate files that you received. Paste the contents of the certificates into a single new file, from top to bottom in this order: your SSL Server certificate, the Intermediate CA certificate, and the Root CA server certificate. Remove any blank lines. This will create a file that looks like the following (the certificate contents are omitted for brevity):

```
-----BEGIN CERTIFICATE-----
Your_SSL_Server_Cert_Contents
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
Intermediate_CA_Cert_Contents
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
Root_CA_Cert_Contents
-----END CERTIFICATE-----
```

b) Save this new file with a new name in the format `CertFilename.cer`.

**Step 4**
On the primary server, copy the CER file to the backup repository on each server.

a) Log in to the Cisco EPN Manager server as the Cisco EPN Manager CLI admin user.

b) Log in as the Linux CLI root user. See Log In and Out as the Linux CLI root User, on page 746.

c) Retrieve the file from your local machine and copy it to the server's default backup repository (defaultRepo).

```
scp clientUserName@clientIP:/FullPathToCERfile /localdisk/defaultRepo
```

d) Log out as the Linux CLI root user.

**Step 5**
Repeat the previous step on the secondary server.

**Step 6**
On the primary server, as the Cisco EPN Manager CLI admin user, remove the HA settings:
ncs ha remove

Run the `ncs ha status` to verify if the HA settings is removed before proceeding with the next step.

**Step 7**

On both the primary and secondary server, import the CER file.

`ncs key importkey ServerKeyFileNameCertFilename.cer repository RepoName`

**Step 8**

Restart the primary and secondary servers. Because they are not yet paired for HA, the order does not matter. See Stop and Restart Cisco EPN Manager, on page 719.

*Note* If the server does not restart, it may indicate that you mistakenly imported an individual certificate file instead of a concatenated certificate file (even though the import operation appeared to be successful). To fix this, repeat the import operation using the (correct) concatenated certificate file.

**Step 9**

Verify the status of the primary and secondary servers by running the `ncs status` command on both servers.

**Step 10**

Register the secondary server on the primary server for HA. See How to Configure HA Between the Primary and Secondary Servers, on page 815.

---

**What to do next**

Depending on your deployment, you may need to instruct your users to install the root and intermediate CA certificates to their browser or OS certificate store. See Add the CA-Signed Root and Intermediate Certificates to a Browser/OS Trust Store, on page 714 for more information.

**Add the CA-Signed Root and Intermediate Certificates to a Browser/OS Trust Store**

Ask your organization's IT administrator if your users should install the CA Root and Intermediate CA certificates to their browser or OS certificate store. If not done in situations where it is required, users will see indications on their browsers that the browsers are not trusted.

Depending on your browser type and version, the exact steps for this procedure may be slightly different.

**Before you begin**

If you are adding the certificates to an Internet Explorer browser, you must have Administrator privileges on your client machine.

**Step 1**

For Firefox browsers, follow these steps to import the certificates.

a) Choose **Tools > Options**, then click **Advanced** from the options on the left.

b) Click **Certificates** from the list at the top of the window, then click **View Certificates**. This opens the browser's Certificate Manager dialog box.

c) In the Certificate Manager dialog box, click the **Authorities** tab, then click **Import** at the bottom of the dialog box.

d) In the **Select File...** dialog box, browse to the CA-signed Root certificate file, then click **Open**.

e) Import the file.

f) Repeat the import steps for the CA-signed Intermediate certificate file.

**Step 2**

For Internet Explorer browsers, use the Microsoft Certificate Manager tool to import the certificates. To use this tool, users must have Administrator privileges on their client machine.

a) In Windows 7, click **Start**.

b) Enter **certmgr.msc** in the Search text box, the hit Return.
c) Launch the Microsoft Certificate Manager by clicking the program's icon in the Search results.
d) In the left column of the Certificate Manager GUI, choose **Trusted Root Certification Authorities**.
e) Left-click **Certificates**, then choose **All Tasks > Import**.
f) Click **Next**, then browse to the CA-signed Root certificate file, and import it.
g) Repeat the import steps for the CA-signed Intermediate certificate file, but choose **Intermediate Certification Authorities** as the first step for importing the certificate.

---

**Change the HTTPS Server Port**

Because many devices use HTTPS to relay device configuration information, HTTPS is enabled by default in Cisco EPN Manager. (HTTP is not used by Cisco EPN Manager and is disabled by default.) If needed, you can change the port for the HTTPS server by following these steps.

**Step 1** Choose **Administration > Settings > System Settings**, then choose **General > Server**.

**Step 2** In the HTTPS area, enter the new port number, then click **Save**.

**Step 3** Restart Cisco EPN Manager to apply your changes. See **Stop and Restart Cisco EPN Manager**, on page 719.

---

**View Existing CA Certificates**

To view existing certificates for the Cisco EPN Manager server:

**Step 1** Log in to the Cisco EPN Manager Admin CLI as the admin user.

**Step 2** To view the list of CA certificates that exist in the Cisco EPN Manager trust store, enter the following command:

```
ncs key listcacerts
```

**Step 3** To see the complete trust chain for SSL/HTTPS operations, log in to the Cisco EPN Manager web GUI using Google Chrome, and use Chrome to view the CA-signed certificate that the server sent to the browser. Chrome will display all the linked certificates in the trust chain.

---

**Delete CA Certificates**

**Step 1** Log in to the Cisco EPN Manager server as the admin user.

**Step 2** Because you will need the certificate short names for the delete command, list the short names of all the CA certificates on the Cisco EPN Manager server:

```
ncs key listcacert
```

**Step 3** Locate the CA certificate you want to delete and enter the following command:

```
ncs key deletecacert aliasname
```
where aliasname is the short name of the CA certificate you want to delete.

Establish an SSH Session With the Cisco EPN Manager Server

When you connect to the server, use SSH and log in as the admin user. (See User Interfaces, User Types, and How To Transition Between Them, on page 743 for more information.)

Step 1
Start your SSH session and log in as the Cisco EPN Manager admin user.

- From the command line, enter the following, where server-ip is the Cisco EPN Manager:
  
  `ssh admin server-ip`

- Open an SSH client and log in as admin.

Step 2
Enter the admin password. The prompt will change to the following:

`(admin)`

To view a list of the operations the admin user can perform, enter `?` at the prompt.

To enter admin config mode, enter the following command (note the change in the prompt):

`(admin) configure terminal
(config)`

Set Up NTP on the Server

Network Time Protocol (NTP) must be properly synchronized on all devices in your network as well as on the Cisco EPN Manager server. Failure to manage NTP synchronizations across your network can result in anomalous results in Cisco EPN Manager. This includes all Cisco EPN Manager -related servers: Any remote FTP servers that you use for Cisco EPN Manager backups, secondary Cisco EPN Manager high-availability servers, and so on.

You specify the default and secondary NTP servers during Cisco EPN Manager server installation. You can also use Cisco EPN Manager’s `ntp server` command to add to or change the list of NTP servers after installation.

Note Cisco EPN Manager cannot be configured as an NTP server; it acts as an NTP client only. Up to three NTP servers are allowed.
Step 1 Log in to the Cisco EPN Manager server as the admin user and enter config mode. See Establish an SSH Session With the Cisco EPN Manager Server, on page 716.

Step 2 Set up the NTP server using one of the following commands.

\[ ntp server ntp-server-IP ntp-key-id ntp-key \]

Where:
- \( ntp-server-IP \) is the IP address or hostname of the server providing the clock synchronization to the Cisco EPN Manager server
- \( ntp-key-id ntp-key \) is the md5 key ID md5 key of the authenticated NTP server

## Set Up the Cisco EPN Manager Proxy Server

Use this procedure to configure proxies for the server and, if configured, its local authentication server. If you use a proxy server as a security barrier between your network and the Internet, you need to configure the proxy settings as shown in the following steps:

Step 1 Choose Administration > Settings > System Settings, then choose General > Account Settings.

Step 2 Click the Proxy tab.

Step 3 Select the Enable Proxy check box and enter the required information about the server that has connectivity to Cisco.com and will act as the proxy.

Step 4 Select the Authentication Proxy check box and enter the proxy server’s user name and password.

Step 5 Click Test Connectivity to check the connection to the proxy server.

Step 6 Click Save.

## Set Up the SMTP E-Mail Server

To enable Cisco EPN Manager to send email notifications (for alarms, jobs, reports, and so forth), the system administrator must configure a primary SMTP email server (and, preferably, a secondary email server).

Step 1 Choose Administration > Settings > System Settings, then choose Mail and Notification > Mail Server Configuration.

Step 2 Under Primary SMTP Server, complete the Hostname/IP, User Name, Password, and Confirm Password fields as appropriate for the email server you want Cisco EPN Manager to use. Enter the IP address of the physical server. and the Enter the hostname of the primary SMTP server.

Note You cannot enter a virtual IP address in the Hostname/IP field, and the IP address cannot be behind a load balancer.

Step 3 (Optional) Complete the same fields under Secondary SMTP Server. SMTP server username and password.

Step 4 Under Sender and Receivers, enter a legitimate email address for Cisco EPN Manager.
Step 5 When you are finished, click **Save**.

---

### Enable FTP/TFTP/SFTP Service on the Server

FTP/TFTP/SFTP is used to transfer files between the server and devices for device configuration and software image file management. These protocols are also used in high availability deployments to transfer files to a secondary server. These services are normally enabled by default. If you installed Cisco EPN Manager in FIPS mode, they are disabled by default. If you use this page to enable these services, Cisco EPN Manager will become non-compliant with FIPS.

SFTP is the secure version of the file transfer service and is used by default. FTP is the unsecured version of the file transfer service; TFTP is the simple, unsecured version of the service. If you want to use either FTP or TFTP, you must enable the service after adding the server.

To change the FTP/TFTP/SFTP password, see Change the FTP User Password, on page 720.

---

### Step 1

Configure Cisco EPN Manager to use the FTP, TFTP, or SFTP server.

a) Choose **Administration > Servers > TFTP/FTP/SFTP Servers**.

b) From the **Select a command** drop-down list, choose **Add TFTP/FTP/SFTP Server**, then click **Go**.

   • From the **Server Type** drop-down list, choose **FTP**, **TFTP**, **SFTP**, or **All**.
   • Enter a user-defined name for the server.
   • Enter the IP address of the server.

   c) Click **Save**.

### Step 2

If you want to use FTP or TFTP, enable it on the Cisco EPN Manager server.

a) Choose **Administration > Settings > System Settings**, then choose **General > Server**.

b) Go to the FTP or TFTP area.

c) Click **Enable**.

d) Click **Save**.

### Step 3

Restart Cisco EPN Manager to apply your changes. See Stop and Restart Cisco EPN Manager, on page 719.

---

### Configure Stored Cisco.com Credentials

Cisco EPN Manager stores only the username and not the password to log in to Cisco.com while performing the following tasks:

- Checks for product software updates
- Checks for device software image updates

To download the updates and open/review a support case, you are required to enter a password.

If these settings are not configured, Cisco EPN Manager will prompt users for their credentials when they perform these tasks. To configure a global Cisco.com user name and password:
Step 1: Choose **Administration > Settings > System Settings**, then choose **General > Account Settings**.

Step 2: Under the **Cisco.com Credentials** tab, enter a user name and password, and click **Save**.

---

**Create a Login Banner (Login Disclaimer)**

When you have a message that you want to display to all users before they log in, create a login disclaimer. The text will be displayed on the GUI client login page below the login and password fields.

**Step 1** Choose **Administration > Settings > System Settings**, then choose **General > Login Disclaimer**.

**Step 2** Enter (or edit) the login disclaimer text.

*Note:* Carriage returns are ignored.

Your changes will take effect immediately.

---

**Stop and Restart Cisco EPN Manager**

A Cisco EPN Manager restart is needed in rare cases, such as after a product software upgrade. When you stop the Cisco EPN Manager server, all user sessions are terminated.

To stop the server, open a CLI session with the server and enter:

```
ncs stop
```

To restart the server, open a CLI session with the server and enter:

```
ncs start
```

---

**Configure Global SNMP Settings for Communication with Network Elements**

The SNMP Settings page controls the how the server uses SNMP to reach and monitor devices. These settings will determine when a device is considered unreachable. Any changes you make on this page are applied globally and are saved across restarts, as well as across backups and restores.

*Note:* The default network address is 0.0.0.0, which indicates the entire network. An SNMP credential is defined per network, so only network addresses are allowed. 0.0.0.0 is the SNMP credential default and is used when no specific SNMP credential is defined. You should update the prepopulated SNMP credential with your own SNMP information.
**Manage Administrative Passwords**

### Change the FTP User Password

Cisco EPN Manager uses the ID `ftp-user` to access other servers using FTP. Users with Admin privileges can change the FTP password.

**Step 1** Log in to the Cisco EPN Manager server as the admin user. Establish an SSH Session With the Cisco EPN Manager Server, on page 716.

**Step 2** To change the Cisco EPN Manager server’s FTP password, enter:

```
ncs password ftpuser username password password
```

**Example**

```
(admin) ncs password ftpuser FTPUser password FTPUserPassword
Initializing...
Updating FTP password.
```
This may take a few minutes.
Successfully updated location ftpuser

Change the Web GUI Root User Password

Cisco EPN Manager uses the root ID to perform special tasks that require root access to the web GUI.

Before you begin

You must know the current web GUI root user password to change it.

Step 1
Log into the Cisco EPN Manager Admin CLI as the root user. (For information on the Admin CLI, see User Interfaces and User Types, on page 743.)

Step 2
Enter the following command, where newpassword is the new web GUI root password:

```
ncs password root password newpassword
```

Note  
The new password you enter must adhere to the current password policies. For more information, see Configure Global Password Policies for Local Authentication, on page 757.

Example

```
ncs password root password NewWebGUIRootPassword
Password updated for web root password
```

Recovering Administrator Passwords on Virtual Appliances

This topic explains how to recover and reset the admin password on Cisco EPN Manager virtual machines (also known as OVAs).

Before You Begin

Ensure that you have:

- Physical access to the Cisco EPN Manager server.
- A copy of the installation ISO image appropriate for your version of the software.
- Access to the VMware vSphere client, and to the vSphere inventory, Datastores and Objects functions. If you do not have such access, consult your VMware administrator. Avoid accessing ESX directly from the vSphere client.

Step 1
At the Cisco EPN Manager OVA server, launch the VMware vSphere client.

Step 2
Upload the installation ISO image to the data store on the OVA virtual machine, as follows:

- In the vSphere inventory, click Datastores.
- On the Objects tab, select the datastore to which you will upload the file.
- Click the Navigate to the datastore file browser icon.
- If needed, click the Create a new folder icon and create a new folder.
- Select the folder that you created or select an existing folder, and click the Upload a File icon.
If the Client Integration Access Control dialog box appears, click **Allow** to allow the plug-in to access your operating system and proceed with the file upload.

f) On the local computer, find the ISO file and upload it.

g) Refresh the datastore file browser to see the uploaded file in the list.

**Step 3**

With the ISO image uploaded to a datastore, make it the default boot image, as follows:

a) Using the VMware vSphere client, right-click the deployed OVA and choose **Power > Shut down guest**.

b) Select **Edit Settings > Hardware**, then select **CD/DVD drive 1**.

c) Under **Device Type**, select **Datastore ISO File**, then use the **Browse** button to select the ISO image file you uploaded to the datastore.

d) Under **Device Status**, select **Connect at power on**.

e) Click the **Options** tab and select **Boot Options**. Under **Force BIOS Setup**, select **Next time VM boots, force entry into BIOS setup Screen**. This will force a boot from the virtual machine BIOS when you restart the virtual machine.

f) Click **OK**.

g) In the VMware vSphere client, right-click the deployed OVA and choose **Power > Power On**.

h) In the BIOS setup menu, find the option that controls the boot order of devices and move **DVD/CDROM** to the top.

**Step 4**

Follow the steps below to reset a server administrator password:

a) Save your BIOS settings and exit the BIOS setup menu. The virtual machine will boot from the ISO image and display a list of boot options.

b) Enter **3** if you are using the keyboard and monitor to access the OVA, or **4** if you are accessing via command line or console. The vSphere client displays a list of administrator user names.

c) Enter the number shown next to the administrator username for which you want to reset the password.

d) Enter the new password and verify it with a second entry.

e) Enter **Y** to save your changes and reboot.

f) Once the virtual machine has rebooted: Using the vSphere client, click on the CD icon and select **Disconnect ISO image**.

**Step 5**

Log in with the new admin password.

---

**Check Cisco EPN Manager Server Health, Jobs, Performance, and API Statistics Using the System Monitoring Dashboard**

The System Monitoring Dashboard provides information about the configuration and performance of the Cisco EPN Manager server. To access the dashboard, choose **Administration > Dashboards > System Monitoring Dashboard** (your User ID must have administrator privileges to access this dashboard). If you want to customize the dashlets that are displayed in the Overview or Performance tabs, follow the instructions in **Add a Predefined Dashlet To a Dashboard**, on page 22.

<table>
<thead>
<tr>
<th>Dashboard Tab</th>
<th>Description</th>
</tr>
</thead>
</table>
Backup and data purging jobs, Cisco EPN Manager system alarms, and utilization statistics for server CPU, disk, and memory. You can specify different time frames to check this information.

To view the server time, kernel version, operating system, hardware information, and so forth, click **System Information** at the top left of the dashboard to open a field with that information.

You can add and delete dashlets from the Overview dashboard.

<table>
<thead>
<tr>
<th>Overview</th>
<th>Server syslogs and traps, and input/output. You can specify different time frames for this data, and add and remove dashlets from the Performance dashboard.</th>
</tr>
</thead>
</table>
| Performance | • Health—System alarms, number of jobs running, number of users logged in, and database usage distribution. You can specify different time frames for historical information.  
• API Health—Lists all API services with their response time statistics.  
• Service Details—Statistics for a specific service (response count and time trend, calls per client (clients are identified by their IP address). You can pick the service you want to check. |
| Admin | Improve the Cisco EPN Manager Server Performance  
• Check the OVA Size, on page 723  
• Compact the Database, on page 723  
• Manage Server Disk Space Issues, on page 724 |

### Improve the Cisco EPN Manager Server Performance

- Check the OVA Size, on page 723
- Compact the Database, on page 723
- Manage Server Disk Space Issues, on page 724

### Check the OVA Size

If Cisco EPN Manager is using 80 percent or more of your system resources or the device/interface/flow counts recommended for the size of OVA you have installed, this can negatively impact performance. Make sure the OVA is not exceeding the device, interface, and flow record recommendations given in the installation documentation. They are the maximums for each given OVA size. You can check these from the Admin Dashboard (see Check Cisco EPN Manager Server Health, Jobs, Performance, and API Statistics Using the System Monitoring Dashboard, on page 722). To respond to space issues, see Manage Server Disk Space Issues, on page 724.

### Compact the Database

**Step 1**  
Log in to the server as the admin user. Establish an SSH Session With the Cisco EPN Manager Server, on page 716.

**Step 2**  
Enter the following command to compact the application database:

```bash
(admin)# ncs cleanup
```

**Step 3**  
When prompted, answer **Yes** to the deep cleanup option.
Manage Server Disk Space Issues

Cisco EPN Manager will trigger alarms indicating that the server is low on disk space at the following thresholds:

- 60% usage triggers a Major alarm
- 65% usage triggers a Critical alarm

If you receive an alert, consider performing the following actions:

- Free up existing database space as explained in Compact the Database, on page 723.
- If you are saving backups to a local repository, consider using a remote backup repository. See Set Up NFS-Based Remote Repositories, on page 692.
- Reduce the retention period for network inventory, performance, reports, and other classes of data as explained in Data Collection and Purging, on page 729.
- Add more disk space. VMware OVA technology enables you to easily add disk space to an existing server. You will need to shut down the Cisco EPN Manager server and then follow the instructions provided by VMware to expand the physical disk space. Once you restart the virtual appliance, Cisco EPN Manager automatically makes use of the additional disk space (see Data Collection and Purging, on page 729).
- Set up a new server that meets at least the minimum RAM, disk space, and processor requirements of the next higher level of OVA. Back up your existing system, then restore it to a virtual machine on the higher-rated server.

Work With Server Internal SNMP Traps That Indicate System Problems

Cisco EPN Manager generates internal SNMP traps that indicate potential problems with system components. This includes hardware component failures, high availability state changes, backup status, and so forth. The failure trap is generated as soon as the failure or state change is detected, and a clearing trap is generated if the failure corrects itself. For TCAs (high CPU, memory and disk utilization traps, and so forth), the trap is generated when the threshold is exceeded.

A complete list of server internal SNMP traps is provided in Cisco Evolved Programmable Network Manager Supported Alarms. Cisco EPN Manager sends traps to notification destination on port 162. This port cannot be customized at present.

You can customize and manage these traps as described in the following topics:

- Customize Server Internal SNMP Traps and Forward the Traps, on page 724
- Troubleshoot Server Internal SNMP Traps, on page 725

Customize Server Internal SNMP Traps and Forward the Traps

You can customize server internal SNMP traps by adjusting their severity or (for TCAs) thresholds. You can also disable and enable the traps. Server internal SNMP traps are listed in Cisco Evolved Programmable Network Manager Supported Alarms.
Cisco Evolved Programmable Network Manager does not send SNMPv2 Inform or SNMPv3 notifications.

Step 1
Choose Administration > Settings > System Settings, then choose Alarms and Events > System Event Configuration.

Step 2
For each SNMP event you want to configure:
   a) Click on the row for that event.
   b) Set the Event Severity to Critical, Major, or Minor, as needed.
   c) For the CPU, disk, memory utilization, and other hardware traps, Enter the Threshold percentage (from 1–99). These events will send the associated SNMP traps when the utilization exceeds the threshold limit. (You cannot set thresholds for events for which the threshold setting is shown as NE.) These events send traps whenever the associated failure is detected.
   d) For backup threshold and certificate expiry (critical), enter the Threshold in days (from \(x\)–\(y\), where \(x\) is the minimum number of days and \(y\) is the maximum number of days).
   e) To control whether a trap is or is not generated, set the Event Status.

Step 3
To save all of your trap changes, click Save (below the table).

Step 4
If you want to configure receivers for the server internal SNMP traps, refer to the procedures in the following topics, depending on whether you want to send the information as an email or trap notification.

   • Forward Alarms and Events as Email Notifications (Administrator Procedure), on page 782
   • Forward Alarms and Events as SNMP Trap Notifications, on page 783

Troubleshoot Server Internal SNMP Traps

Cisco Evolved Programmable Network Manager Supported Alarms provides a complete list of server internal SNMP traps, their probable cause, and recommended actions to remedy the problem. If that document does not provide the information you need, follow this procedure to troubleshoot and get more information about Cisco EPN Manager server issues.

Step 1
Ping the notification receiver from the Cisco EPN Manager server to ensure that there is connectivity between Cisco EPN Manager and your management application.

Step 2
Check if any firewall ACL settings are blocking port 162, and open communications on that port if needed.

Step 3
Log in to Cisco EPN Manager with a user ID that has Administrator privileges. Select Administration > Logging and download the log files. Then compare the activity recorded in these log files with the activity you are seeing in your management application:

   • ncs_nbi.log: This is the log of all the northbound SNMP trap messages Cisco EPN Manager has sent. Check for messages you have not received.
   • ncs-#-#.log: This is the log of most other recent Cisco EPN Manager activity. Check for hardware trap messages you have not received.
   • hm-#-#.log: This is the log of all Health Monitor activity. Check for recent messages about High Availability state-changes and application-process failures that you have not received.
The messages you see in these logs should match the activity you see in your management application. If you find major differences, open a support case with Cisco Technical Assistance Center (TAC) and attach the suspect log files with your case. See Open a Cisco Support Case, on page 796.

## Set Up Defaults for Cisco Support Requests

By default, users can create Cisco support requests from different parts of the Cisco EPN Manager GUI. If desired, you can configure the sender e-mail address and other e-mail characteristics. If you do not configure them, users can supply the information when they open a case.

If you do not want to allow users to create requests from the GUI client, you can disable that feature.

### Step 1
Choose **Administration > Settings > System Settings**, then choose **General > Account Settings**.

### Step 2
Click the **Support Request** tab.

### Step 3
Select the type of interaction you prefer:

- **Enable interactions directly from the server**—Specify this option to create the support case directly from the Cisco EPN Manager server. E-Mails to the support provider are sent from the e-mail address associated with the Cisco EPN Manager server or the e-mail address you specify.

- **Interactions via client system only**—Specify this option to download the information required for your support case to a client machine. You must then e-mail the downloaded support case details and information to the support provider.

### Step 4
Select your technical support provider:

- **Click Cisco** to open a support case with Cisco Technical Support, enter your Cisco.com credentials, then click **Test Connectivity** to check the connectivity to the following servers:
  - Cisco EPN Manager mail server
  - Cisco support server
  - Forum server

- **Click Third-party Support Provider** to create a service request with a third-party support provider. Enter the provider’s e-mail address, the subject line, and the website URL.

## Configure Cisco Product Feedback Settings

To help Cisco improve its products, Cisco EPN Manager collects the following data and sends it to Cisco:

- **Product information**—Product type, software version, and installed licenses.
- **System information**—Server operating system and available memory.
- **Network information**—Number and type of devices on your network.
This feature is enabled by default. Data is collected on a daily, weekly, and monthly basis and is posted to a REST URL in the Cisco cloud using HTTPS. Choose Administration > Settings > System Settings, then choose General > Help Us Improve, and:

- To view the types of data Cisco collects, click What data is Cisco collecting?
- To disable this feature, select Not at this time, thank you, then click Save.

**Monitor Backups**

Use this procedure to view Cisco EPN Manager backup information such as file name, size, available size, and data.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Choose Administration &gt; Dashboards &gt; System Monitoring Dashboard.</td>
</tr>
<tr>
<td>Step 2</td>
<td>Click the Overview tab. The Backup Information dashlet is displayed here.</td>
</tr>
</tbody>
</table>

**Note** Information in the backup dashlet is available only when the backup repository is local.
Monitor Backups
Data Collection and Purging

- Control Data Collection Jobs, on page 729
- How Data Retention Settings Affect Web GUI Data, on page 737
- Performance and System Health Data Retention, on page 738
- Specifying Data Retention By Database Table, on page 738
- Alarm, Event, and Syslog Purging, on page 739
- Log Purging, on page 740
- Report Purging, on page 740
- Backup Purging, on page 740
- Device Configuration File Purging, on page 740
- Software Image File Purging, on page 741

Control Data Collection Jobs

All data collection tasks (and data purging tasks) are controlled from the Jobs Dashboard. See Manage Jobs Using the Jobs Dashboard, on page 26. Data collection jobs are listed under System Jobs.

About System Jobs

The following table describes the background data collection jobs Cisco EPN Manager performs.

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Default Schedule</th>
<th>Description</th>
<th>Editable options</th>
</tr>
</thead>
<tbody>
<tr>
<td>APIC EM Integration Jobs</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>APIC-EM Site Sync</td>
<td>6 hours</td>
<td>Schedules synchronization of sites and devices between APIC-EM and Cisco EPN Manager</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>APIC Server Status Periodic</td>
<td>5 minutes</td>
<td>Schedules checks on APIC-EM server reachability.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Task Name</td>
<td>Default Schedule</td>
<td>Description</td>
<td>Editable options</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>PnP Status Polling</td>
<td>5 minutes</td>
<td>Tracks the status of the PnP devices created on APIC-EM and adds them to Prime Inventory when successful.</td>
<td>Select <strong>Edit Schedule</strong> &gt; <strong>Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td><strong>Infrastructure jobs</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mobility Service Status</td>
<td>5 minutes</td>
<td>Schedules mobility services status polling.</td>
<td>Select <strong>Edit Schedule</strong> &gt; <strong>Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Autonomous Client Status</td>
<td>5 minutes</td>
<td>Lets you schedule status polling of autonomous AP clients.</td>
<td>Select <strong>Edit Schedule</strong> &gt; <strong>Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Bulk Recompute RF Prediction</td>
<td>15 days</td>
<td>Schedules status polling of Bulk Recompute RF Prediction.</td>
<td>Select <strong>Edit Schedule</strong> &gt; <strong>Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Controller Configuration Backup</td>
<td>1 day</td>
<td>Displays the controller configuration backup activities.</td>
<td>Select <strong>Edit Schedule</strong> &gt; <strong>Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Data Cleanup</td>
<td>2 hours</td>
<td>Schedules daily data file cleanup.</td>
<td>Select <strong>Edit Schedule</strong> &gt; <strong>Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Device Config Backup-External</td>
<td>15 minutes</td>
<td>Transfers device configuration periodically to external repository. You can configure or create the repository using CLI commands and the supported repositories are FTP, SSH FTP (SFTP) and Network File System (NFS).</td>
<td>Select <strong>Edit Schedule</strong> &gt; <strong>Recurrence</strong> and select the appropriate settings to schedule the job. Click the edit icon, and check the <strong>Export only Latest Configuration</strong> check box, to transfer only the latest configuration. You can edit the job properties based on the user permission set in Role Based Access Control (RBAC).</td>
</tr>
<tr>
<td>Guest Accounts Sync</td>
<td>1 day</td>
<td>Schedules guest account polling and synchronization.</td>
<td>Select <strong>Edit Schedule</strong> &gt; <strong>Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Task Name</td>
<td>Default Schedule</td>
<td>Description</td>
<td>Editable options</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>------------------</td>
<td>--------------------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Index search Entities</td>
<td>3 hours</td>
<td>Schedules the Index Search Entities job.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Mobility Service Backup</td>
<td>7 days</td>
<td>Schedules automatic mobility services backups.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Mobility Service Synchronization</td>
<td>1 hour</td>
<td>Schedules mobility services synchronization.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>On Demand Reports Cleanup</td>
<td>6 hours</td>
<td>Schedules reports cleanup.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Server Backup</td>
<td>1 day</td>
<td>Schedules automatic Cisco EPN Manager server backups. The backups created are application backups.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Smart License Compliance Status</td>
<td>Disabled</td>
<td>Runs for Smart License for the default schedule.</td>
<td>Non Editable.</td>
</tr>
<tr>
<td>wIPS Alarm Sync</td>
<td>2 hours</td>
<td>Schedules wIPS alarm synchronization.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
</tbody>
</table>

**Inventory and Discovery Jobs**

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Default Schedule</th>
<th>Description</th>
<th>Editable options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autonomous AP Inventory</td>
<td>1 day</td>
<td>Collects inventory information for autonomous APs.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Switch Inventory</td>
<td>1 day</td>
<td>Collects inventory information for Switches.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Wireless Controller Inventory</td>
<td>1 day</td>
<td>Collects inventory information for Wireless Controllers.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
</tbody>
</table>

**Status Jobs**
### About System Jobs

#### Task Name | Default Schedule | Description | Editable options
--- | --- | --- | ---
Appliance Status | 5 minutes | Schedules appliance polling. This task populates the appliance polling details from the Administration > Appliance > Appliance Status page. It also populates information like the performance and fault checking capabilities of the appliance. | Select Edit Schedule > Recurrence and select the appropriate settings to schedule the job.
Autonomous AP Operational Status | 5 minutes | Schedules status polling of autonomous wireless access points. | Select Edit Schedule > Recurrence and select the appropriate settings to schedule the job.
Controller Operational Status | 5 minutes | Schedules controller operational status polling. | Select Edit Schedule > Recurrence and select the appropriate settings to schedule the job.
Device Data Collector | 30 minutes | Schedules data collection based on specified command-line interface (CLI) commands at a configured time interval. | Select Edit Schedule > Recurrence and select the appropriate settings to schedule the job.
Identity Services Engine Status | 15 minutes | Schedules Identity Services Engine polling. | Select Edit Schedule > Recurrence and select the appropriate settings to schedule the job.
Interferers | 15 minutes | Schedules interferer information collection. | Select Edit Schedule > Recurrence and select the appropriate settings to schedule the job.
License Status | 4 hours | Schedules the license-status information collection. | Select Edit Schedule > Recurrence and select the appropriate settings to schedule the job.
Lightweight AP Ethernet Interface Status | 1 minute | Schedules Lightweight AP Ethernet Interface Status information collection. | Select Edit Schedule > Recurrence and select the appropriate settings to schedule the job.
Lightweight AP Operational Status | 5 minutes | Schedules Lightweight AP Operational Status information collection. | Select Edit Schedule > Recurrence and select the appropriate settings to schedule the job.
<table>
<thead>
<tr>
<th>Task Name</th>
<th>Default Schedule</th>
<th>Description</th>
<th>Editable options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lightweight Client Status</td>
<td>5 minutes</td>
<td>Schedules information collection for Lightweight AP Clients from Network.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Mobility Service Performance</td>
<td>15 minutes</td>
<td>Schedules status polling of mobility services performance.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Mobility Status Task</td>
<td>15 minutes</td>
<td>Schedules status polling of mobility services engines.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>OSS Server Status</td>
<td>5 minutes</td>
<td>Schedules status polling of OSS Servers.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Redundancy Status</td>
<td>1 hour</td>
<td>Schedules redundancy status polling of primary and secondary controllers.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Switch NMSP and Location Status</td>
<td>4 hours</td>
<td>Schedules Switch Network Mobility Services Protocol (NMSP) and Civic Location status polling.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Switch Operational Status</td>
<td>5 minutes</td>
<td>Schedules switch operational status polling.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Third Party Access Point</td>
<td>3 hours</td>
<td>Schedules operational status polling of third party APs.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Operational Status</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Third Party Controller</td>
<td>3 hours</td>
<td>Schedules operational status polling of third party Controllers.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Operational Status</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unmanaged APs</td>
<td>15 minutes</td>
<td>Collects poll information for unmanaged access points.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Task Name</td>
<td>Default Schedule</td>
<td>Description</td>
<td>Editable options</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------------</td>
<td>--------------------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Wired Client Status</td>
<td>2 hours</td>
<td>Schedules Wireless Client status polling</td>
<td>Select <strong>Edit Schedule &gt; Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Wireless AP Discovery</td>
<td>5 minutes</td>
<td>Schedules Wireless AP discovery.</td>
<td>Select <strong>Edit Schedule &gt; Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Wireless Configuration Audit</td>
<td>1 day</td>
<td>Schedules Wireless Configuration Agent audit collection.</td>
<td>Select <strong>Edit Schedule &gt; Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td><strong>Utilization Collection Jobs</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>UtilizationCollector_15Min</td>
<td>15 minutes</td>
<td>Schedules physical interface utilization.</td>
<td>Select <strong>Edit Schedule &gt; Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>UtilizationProvider_15Min</td>
<td>15 minutes</td>
<td>Schedules physical links utilization.</td>
<td>Select <strong>Edit Schedule &gt; Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>UtilizationCollector_1Hour</td>
<td>1 hour</td>
<td>Schedules physical interface utilization.</td>
<td>Select <strong>Edit Schedule &gt; Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>UtilizationProvider_1h</td>
<td>1 hour</td>
<td>Schedules physical links utilization.</td>
<td>Select <strong>Edit Schedule &gt; Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>UtilizationCollector_6Hour</td>
<td>6 hours</td>
<td>Schedules physical interface utilization.</td>
<td>Select <strong>Edit Schedule &gt; Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>UtilizationProvider_6h</td>
<td>6 hours</td>
<td>Schedules physical links utilization.</td>
<td>Select <strong>Edit Schedule &gt; Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>UtilizationCollector_24Hour</td>
<td>24 hours</td>
<td>Schedules physical interface utilization.</td>
<td>Select <strong>Edit Schedule &gt; Recurrence</strong> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Task Name</td>
<td>Default Schedule</td>
<td>Description</td>
<td>Editable options</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>UtilizationProvider_1d</td>
<td>24 hours</td>
<td>Schedules physical links utilization.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td><strong>Wireless Monitoring Jobs</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AP Ethernet Statistics</td>
<td>15 minutes</td>
<td>Schedules AP Ethernet statistics collection.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>AP Image Pre-Download Status</td>
<td>15 minutes</td>
<td>Allows you to see the Image Predownload status of the associated APs in the controllers. To see the status of the access points, the “Pre-download software to APs” checkbox should be selected while downloading software to the controller.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Autonomous AP CPU and Memory Utilization</td>
<td>15 minutes</td>
<td>Schedules collection of information on memory and CPU utilization of Autonomous APs.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Autonomous AP Radio Performance</td>
<td>15 minutes</td>
<td>Schedules collection of information about radio performance information as well as radio up or down status for autonomous APs.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Autonomous AP Tx Power and Channel Utilization</td>
<td>15 minutes</td>
<td>Schedules collection of information about radio performance of Autonomous APs.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>CCX Client Statistics</td>
<td>1 hour</td>
<td>Schedules collection of the Dot11 and security statistics for CCX Version 5 and Version 6 clients.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>CleanAir Air Quality</td>
<td>15 minutes</td>
<td>Schedules collection of information about CleanAir air quality.</td>
<td>Select Edit Schedule &gt; Recurrence and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Task Name</td>
<td>Default Schedule</td>
<td>Description</td>
<td>Editable options</td>
</tr>
<tr>
<td>-----------------------</td>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Client Statistics</td>
<td>15 minutes</td>
<td>Schedules retrieval of statistical information for autonomous and lightweight clients.</td>
<td>Select <a href="#">Edit Schedule &gt; Recurrence</a> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Map Info Polling Job</td>
<td>1 minute</td>
<td></td>
<td>Select <a href="#">Edit Schedule &gt; Recurrence</a> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Media Stream Clients</td>
<td>15 minutes</td>
<td>Schedules collection of information about media stream clients.</td>
<td>Select <a href="#">Edit Schedule &gt; Recurrence</a> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Mesh Link Status</td>
<td>5 minutes</td>
<td>Schedules collection of status of mesh links.</td>
<td>Select <a href="#">Edit Schedule &gt; Recurrence</a> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Mesh link Performance</td>
<td>10 minutes</td>
<td>Schedules collection of information about the performance of mesh links.</td>
<td>Select <a href="#">Edit Schedule &gt; Recurrence</a> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Radio Performance</td>
<td>15 minutes</td>
<td>Schedules collection of statistics from wireless radios.</td>
<td>Select <a href="#">Edit Schedule &gt; Recurrence</a> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Radio Voice Performance</td>
<td>15 minutes</td>
<td>Schedules collection of voice statistics from wireless radios.</td>
<td>Select <a href="#">Edit Schedule &gt; Recurrence</a> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Rogue AP</td>
<td>2 hours</td>
<td>Schedules collection of information about rogue access points.</td>
<td>Select <a href="#">Edit Schedule &gt; Recurrence</a> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Switch CPU and Memory Poll</td>
<td>30 minutes</td>
<td>Schedules polling of switch CPU and memory information.</td>
<td>Select <a href="#">Edit Schedule &gt; Recurrence</a> and select the appropriate settings to schedule the job.</td>
</tr>
<tr>
<td>Traffic Stream Metrics</td>
<td>8 minutes</td>
<td>Retrieves traffic stream metrics for the clients.</td>
<td>Select <a href="#">Edit Schedule &gt; Recurrence</a> and select the appropriate settings to schedule the job.</td>
</tr>
</tbody>
</table>
How Data Retention Settings Affect Web GUI Data

Changes you make on the Data Retention page determine the information that is displayed in the web GUI. You can open the data retention page by choosing Administration > Settings > System Settings, then choosing General > Data Retention.

For example, if you do not need any historical performance data older than 7 days, you can modify the performance data retention values as follows:

- Short-term Data Retention Period—1 day
- Medium-term Data Retention Period—3 days
- Long-term Data Retention Period—7 days

If you specify these settings, all data displayed in performance reports and on performance dashboards will be for the previous 7 days only. When you generate a performance report, even if you select a reporting period longer than the last 7 days, the report will contain data from the last 7 days only (because that is all of the data you selected to retain).

Similarly, if you view a performance dashboard and select a time frame longer than one week, the dashboard will contain data from the last 7 days only.

When you create the monitoring policy for interfaces, you can define the polling interval for every 15 minutes or every 5 minutes or every 1 minute. According to the selected polling interval, the device data is polled and stored in Oracle Data base. The data is aggregated every 1 hour into the AHxxx table; once a day into the ADxxx table irrespective of the polling interval is set to 1/5/15 minutes.

In the Interface Health Policy tab, if the frequency is set at 5 mins, you can view 12 samples for each hour. Every hour the data moves to the aggregated table and an average or mean interface statistics is calculated, and there will be one entry in the hourly aggregated table. The aggregation is the same for all the policies no matter what the polling interval is.

You can view data retention details and the age of the data storage, the event time in milliseconds and for each data base the entity ID and the event time. View the performance data and aggregate data in the Performance Dashlet, > Interfaces > Traffic Utilization tab.
Performance and System Health Data Retention

Note

Cisco recommends you do not change the retention periods for trend, device health, system health, and performance data because the default settings are optimized to get the most helpful information from interactive graphs.

The following table describes the information shown on the Data Retention page.

<table>
<thead>
<tr>
<th>Type of Data</th>
<th>Description</th>
<th>Default Retention Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trend Data Retain Periods</td>
<td>Device-related historical information. Trend data is gathered as a whole and summarized as minimums, maximums, or averages.</td>
<td>Hourly data retain period: 15 (days)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Daily data retain period: 90 (days)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Weekly data retain period: 54 (weeks)</td>
</tr>
<tr>
<td>Device Health Data Retain Periods</td>
<td>SNMP-pooled device data such as device reachability, and utilization for CPU, memory, and interfaces.</td>
<td>Hourly data retain period: 15 (days)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Daily data retain period: 90 (days)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Weekly data retain period: 54 (weeks)</td>
</tr>
<tr>
<td>Performance Data Retain Periods</td>
<td>Assurance data such as traffic statistics.                                                                                           • Short-term data is aggregated every 5 minutes.</td>
<td>Short term data retain period: 7 (days)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Medium-term data is aggregated every hour.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Long-term is aggregated daily.</td>
</tr>
<tr>
<td>Network Audit Data Retain Period</td>
<td>Audit records for configurations triggered by users, and so on.</td>
<td>Audit data retain period: 90 (days)</td>
</tr>
<tr>
<td>System Health Data Retain Periods</td>
<td>Includes most data shown on the Admin dashboards</td>
<td>Hourly data retain period: 1 (days)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Weekly data retain period: 54 (weeks)</td>
</tr>
</tbody>
</table>

For example, these are the retention settings for optical performance data:

• Optical 15-minute performance data (short-term) is saved for 7 days.
• Optical 1-day performance data (medium-term) is saved for 31 days.

Specifying Data Retention By Database Table

Administrators can use the “Other Data Retention Criteria” section of the Data Retention page to configure retention periods for specific Cisco EPN Manager database tables. You specify the retention period using the following attributes:
Alarm, Event, and Syslog Purging

These default purging settings are provided to ensure optimal performance. Use care when adjusting these settings, especially if Cisco EPN Manager is managing a very large network (where increasing these settings may have an adverse impact).

Cisco EPN Manager stores a maximum of 8000000 events and 2000000 syslogs in the database.

To protect system performance, Cisco EPN Manager purges alarms, events, and syslogs according to the settings in the following table. All of these settings are enabled by default. Data is deleted on a daily basis. Alarm tables are checked hourly, and if the alarm table exceeds the 300,000 limit, Cisco EPN Manager deletes the oldest cleared alarms until the alarms table size is within the limit.

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Deleted after:</th>
<th>Default Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarms—Cleared security alarms</td>
<td>30 days</td>
<td>Enabled</td>
</tr>
<tr>
<td>Alarms—Cleared non-security alarms</td>
<td>7 days</td>
<td>Enabled</td>
</tr>
<tr>
<td>Events</td>
<td>60 days</td>
<td>Enabled</td>
</tr>
<tr>
<td>Syslogs</td>
<td>30 days</td>
<td>Enabled</td>
</tr>
<tr>
<td>Alarms</td>
<td>30 days</td>
<td>Disabled</td>
</tr>
</tbody>
</table>

To change the settings, choose Administration > Settings > System Settings, then choose Alarms and Events > Alarms and Events and modify the settings in the Alarm and Event Cleanup Options area.
Log Purging

You can adjust the purging settings for logs by choosing Administration > Settings > Logging. Logs are saved until they reach the maximum size. At that point, a number is appended to the log file and a new log is started. When the number of logs exceeds the maximum, the oldest log is deleted.

The following table lists the default purging values for General and SNMP logs.

<table>
<thead>
<tr>
<th>Log Type</th>
<th>Size of Logs</th>
<th>Number of Logs</th>
<th>To change the setting, see:</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>10 MB</td>
<td>10</td>
<td>Adjust General Log File Settings and Default Sizes, on page 802</td>
</tr>
<tr>
<td>SNMP</td>
<td>10 MB</td>
<td>5</td>
<td>View and Manage General System Logs, on page 802</td>
</tr>
</tbody>
</table>

Report Purging

By default, reports are stored in a repository named /localdisk/ftp/reports and are deleted after 31 days from that directory. Reports filters that you set from the filters page are saved in the database and are not purged.

- **Step 1** Choose Administration > Settings > System Settings, then choose General > Reports.
- **Step 2** If required, adjust the location for the reports repository on the server. The repository must reside under the FTP root partition.
- **Step 3** If you want to change the default purging age, enter a new value in the File Retain Period field.
- **Step 4** Click Save.

Backup Purging

By default, 2 backups are saved for backups in local repositories. If you are using remote repositories, there is no automatic backup purging mechanism; you must manually delete old backups. See Change the Number of Automatic Application Backups That Are Saved, on page 697.

Device Configuration File Purging

For each device, 5 configuration files are saved in the configuration archive. Any file that is older than 30 days is purged. Device configuration files cannot be manually deleted. For more information on device configuration files, see Manage Device Configuration Files, on page 95.
Software Image File Purging

Device software image files are not automatically purged from the database. They must be manually removed using the GUI client. For more information, see Delete Software Image Files from the Image Repository, on page 135.
Software Image File Purging
User Permissions and Device Access

- User Interfaces, User Types, and How To Transition Between Them, on page 743
- Enable and Disable root Access for the Linux CLI and the Cisco EPN Manager Web GUI, on page 747
- Control the Tasks Users Can Perform (User Groups), on page 748
- Add Users and Manage User Accounts, on page 753
- Find Out Which Users Are Currently Logged In, on page 755
- View the Tasks Performed By Users (Audit Trail), on page 756
- Configure Job Approvers and Approve Jobs, on page 756
- Configure Global Password Policies for Local Authentication, on page 757
- Configure the Global Timeout for Idle Users, on page 757
- Create Virtual Domains to Control User Access to Devices, on page 758
- Configure Local Authentication, on page 766
- Configure External Authentication, on page 767

User Interfaces, User Types, and How To Transition Between Them

These topics describe the GUI and CLI interfaces used by Cisco EPN Manager, and how to transition between the Cisco EPN Manager and Linux CLI interfaces.

- User Interfaces and User Types, on page 743
- How to Transition Between the CLI User Interfaces in Cisco EPN Manager, on page 745

User Interfaces and User Types

The following table describes the user interfaces employed by Cisco EPN Manager (CEPNM), and the types of users that can access each interface.
<table>
<thead>
<tr>
<th>CEPNM User Interface</th>
<th>Interface Description</th>
<th>CEPNM User Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>CEPNM web GUI</td>
<td>Web interface that facilitates day-to-day and administration operations using the web GUI. These users can have varying degrees of privileges and are classified into role-based access control (RBAC) classes and subclasses. This interface provides a subset of operations that are provided by the Cisco EPN Manager CLI admin and CLI config users.</td>
<td><strong>Cisco EPN Manager web GUI everyday users</strong>—Created by web GUI root user. These users have varying degrees of privileges and are classified into role-based access control (RBAC) classes and subclasses called user groups (Admin, Super Users, Config Managers, and so forth). For information on the user groups, see <em>Types of User Groups</em>, on page 748.</td>
</tr>
<tr>
<td>CEPNM Admin CLI</td>
<td>Cisco proprietary shell which provides secure and restricted access to the system (as compared with the Linux shell). This Admin shell and CLI provide commands for advanced Cisco EPN Manager administration tasks. These commands are explained throughout this guide. To use this CLI, you must have Cisco EPN Manager CLI admin user access. You can access this shell from a remote computer using SSH.</td>
<td><strong>Cisco EPN Manager web GUI root user</strong>—Created at installation and intended for first-time login to the web GUI, and for creating other user accounts. This account should be disabled after creating at least one web GUI user that has Admin privileges—that is, a web GUI user that belongs to the Admin or Super Users user group. See <em>Disable and Enable the Web GUI root User</em>, on page 747.</td>
</tr>
</tbody>
</table>
| CEPNM Config CLI     | Cisco proprietary shell which is restricted and more secure than the Linux shell. This Config shell and CLI provide commands for Cisco EPN Manager system configuration tasks. These commands are explained throughout this guide. To use this CLI, you must have admin-level user access (see the information in the User Types column of this table). You can access this shell from the Admin CLI shell. | **Cisco EPN Manager CLI Admin user**—Created at installation time and used for administration operations such as stopping and restarting the application and creating remote backup repositories. (A subset of these administration operations are available from the web GUI). To display a list of operations this user can perform, enter `?` at the prompt. Some tasks must be performed in config mode. To transition to config mode, use the procedure in *Transition Between the Cisco EPN Manager admin CLI and Cisco EPN Manager config CLI*, on page 745. The admin CLI user can create other CLI users for a variety of reasons, using the following command: 

```
(config) username username password role {admin|user} password
```

These users may have admin-like privilege/roles or lower level privileges as defined during creation time. To create a Cisco EPN Manager CLI user with admin privileges, run the `username` command with the `admin` keyword; otherwise, use the `user` keyword. |
### CEPNM User Interface Description

<table>
<thead>
<tr>
<th>CEPNM User Interface</th>
<th>Interface Description</th>
<th>CEPNM User Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linux CLI</td>
<td>Linux shell which provides all Linux commands. The Linux shell should only be used by Cisco technical support representatives. Regular system administrators should not use the Linux shell. You cannot reach this shell from a remote computer using SSH; you can only reach it through the Cisco EPN Manager admin shell and CLI.</td>
<td>Linux CLI admin user—Created at installation time and used for Linux-level administration purposes. This admin user can get root-level privileges by following the procedure in Log In and Out as the Linux CLI root User, on page 746. Tasks that require root-level permissions should only be performed by Cisco Support teams to debug product-related operational issues. For security purposes, the Linux CLI admin and root users should be disabled; see Disable and Enable the Linux CLI Users in Cisco EPN Manager 2.x, on page 747.</td>
</tr>
</tbody>
</table>

### How to Transition Between the CLI User Interfaces in Cisco EPN Manager

The following figure illustrates how to transition between the Cisco EPN Manager and Linux CLI user interfaces on deployments running Cisco EPN Manager.

#### Transition Between the Cisco EPN Manager admin CLI and Cisco EPN Manager config CLI

To move from the Cisco EPN Manager admin CLI to the Cisco EPN Manager config CLI, enter `config` at the admin prompt.

```
(admin)# config
(config)#
```

To move from the config CLI back to the admin CLI, enter `exit` or `end` at the config prompt:

```
(config)# exit
(admin)#
```
Log In and Out as the Linux CLI root User

The Linux CLI has two shell users: One with administrative access (Linux CLI admin user), and another with root access (Linux CLI root user). The diagram in How to Transition Between the CLI User Interfaces in Cisco EPN Manager, on page 745 illustrates the flow for logging in and out as the various CLI users.

To log in as the Linux CLI root user, you will have to transition from being the Cisco EPN Manager CLI admin user to the Linux CLI admin user to the Linux CLI root user. The following procedure gives you the exact steps you must follow.

Before you begin

If the Linux CLI user is disabled, re-enable it. See Disable and Enable the Linux CLI Users in Cisco EPN Manager 2.x, on page 747.

---

**Step 1**

To log in as the Linux CLI root user:

a) Start an SSH session with the Cisco EPN Manager server and log in as the Cisco EPN Manager CLI admin user.

b) As the Cisco EPN Manager CLI admin user, log in as the Linux CLI admin user:

```bash
shell
Enter shell access password: password
```

c) Log in as the Linux CLI root user.

```bash
sudo -i
```

By default, the Linux CLI shell prompt is the same for the Linux CLI admin and root user. You can use the `whoami` command to check the current user.

---

**Step 2**

To exit:

a) Log out as the Linux CLI root user.

```bash
exit
```

b) Log out as the Linux CLI admin user.

```bash
exit
```

You are now logged in as the Cisco EPN Manager CLI admin user.

---

What to do next

For security purposes, disable the Linux CLI root user. See Disable and Enable the Linux CLI Users in Cisco EPN Manager 2.x, on page 747.
Enable and Disable root Access for the Linux CLI and the Cisco EPN Manager Web GUI

As described in How to Transition Between the CLI User Interfaces in Cisco EPN Manager, on page 745, after installation, you should disable the Cisco EPN Manager web GUI root user after creating at least one other web GUI user that has Admin or Super Users privileges. See Disable and Enable the Web GUI root User, on page 747.

The Linux CLI root user is disabled after installation time. If you need to re-enable it, follow the procedure in Disable and Enable the Linux CLI Users in Cisco EPN Manager 2.x, on page 747.

Disable and Enable the Linux CLI Users in Cisco EPN Manager 2.x

This procedure shows you how to disable and enable the Linux CLI admin shell in deployments running Cisco EPN Manager 2.x. When you disable the shell, you will no longer be able to log in as the Linux CLI admin or root users. When the shell is enabled, users can log in by following the procedure in How to Transition Between the CLI User Interfaces in Cisco EPN Manager, on page 745.

Before you begin

Make sure you have the password for the Linux CLI admin user.

Step 1

Log into Cisco EPN Manager as the Cisco EPN Manager CLI admin user. See Establish an SSH Session With the Cisco EPN Manager Server, on page 716.

Step 2

Disable the Linux CLI admin shell (which disables the Linux CLI admin and root users):

```
sHELL disable
Enter shell access password: passwd
shell access is disabled
```

Step 3

To re-enable the Linux CLI admin shell (you must run this command as the Cisco EPN Manager CLI admin user):

```
sHELL
Shell access password is not set
Configure password for shell access
Password: passwd
Password again: passwd
Shell access password is set
Run the command again to enter shell
```

Disable and Enable the Web GUI root User

Step 1

Log into the Cisco EPN Manager web GUI as root, and create another web GUI user that has root privileges—that is, a web GUI user that belongs to the Admin or Super Users user group. See Add Users and Manage User Accounts, on page 753. Once this is done, you can disable the web GUI root account.
Step 2  Disable the Cisco EPN Manager web GUI root user account. (The web GUI admin account, which remains active, can perform all required CLI functions.)
  ncs webroot disable

Step 3  To re-enable the account:
  ncs webroot enable

Control the Tasks Users Can Perform (User Groups)

Cisco EPN Manager user authorization is implemented through user groups. A user group contains a list of tasks that control which parts of Cisco EPN Manager a user can access and the tasks the user can perform in those parts.

While user groups control what the user can do, virtual domains control the devices on which a user can perform those tasks. Virtual domains are described in Create Virtual Domains to Control User Access to Devices, on page 758.

Cisco EPN Manager provides several predefined user groups. If a user belongs to a user group, the user inherits all of the authorization settings for that group. A user is normally added to user groups when their account is created.

These topics explain how to manage user authorization:

• Types of User Groups, on page 748
• View and Change the Tasks a User Can Perform, on page 750
• View and Change the Groups a User Belongs To, on page 750
• View User Groups and Their Members, on page 751
• Create a Customized User Group, on page 751
• View and Change the Tasks a Group Can Perform, on page 752
• Use Cisco EPN Manager User Groups with RADIUS and TACACS+, on page 752

Types of User Groups

Cisco EPN Manager provides the following predefined user groups:

• User Groups—Web UI, on page 748
• User Groups—NBI, on page 749

For information about CLI users, see User Interfaces and User Types, on page 743.

User Groups—Web UI

Cisco EPN Manager provides the default web GUI user groups listed in the following table. You can assign users to multiple groups, except for users that belong to the Monitor Lite user group (because Monitor Lite is meant for users who should have very limited permissions).

See View and Change the Tasks a Group Can Perform, on page 752 for information on the tasks that pertain to each user group and the default settings.
### User Groups

<table>
<thead>
<tr>
<th>User Group</th>
<th>Group Task Focus</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Root</strong></td>
<td>All operations. The group permissions are not editable. The root web UI user is available after installation and is described in User Interfaces and User Types, on page 743. A best practice is to create other users with Admin or Super Users privileges, and then disable the root web UI user as described in Disable and Enable the Web GUI root User, on page 747.</td>
</tr>
<tr>
<td><strong>Super Users</strong></td>
<td>All operations (similar to root). The group permissions are editable.</td>
</tr>
<tr>
<td><strong>Admin</strong></td>
<td>Administer the system and server. Can also perform monitoring and configuration operations. The group permissions are editable.</td>
</tr>
<tr>
<td><strong>Config Managers</strong></td>
<td>Configure and monitor the network (no administration tasks). The permissions assigned to this group are editable.</td>
</tr>
<tr>
<td><strong>System Monitoring</strong></td>
<td>Monitor the network (no configuration tasks). The group permissions are editable.</td>
</tr>
<tr>
<td><strong>Help Desk Admin</strong></td>
<td>Only has access to the help desk and user preferences related pages. Members of this user group cannot be members of any other user group. This is a special group which lacks access to the user interface.</td>
</tr>
<tr>
<td><strong>Lobby Ambassador</strong></td>
<td>User administration for Guest users only. Members of this user group cannot be members of any other user group.</td>
</tr>
<tr>
<td><strong>User-Defined 1–4</strong></td>
<td>N/A; these are blank groups and can be edited and customized as needed.</td>
</tr>
<tr>
<td><strong>Monitor Lite</strong></td>
<td>View network topology and use tags. The group permissions are not editable. Members of this user group cannot be members of any other user group.</td>
</tr>
<tr>
<td><strong>North Bound API</strong></td>
<td>Access to the SOAP APIs.</td>
</tr>
<tr>
<td><strong>User Assistant</strong></td>
<td>Local Net user administration only. Members of this user group cannot be members of any other user group.</td>
</tr>
<tr>
<td><strong>mDNS Policy Admin</strong></td>
<td>mDNS policy administration functions.</td>
</tr>
</tbody>
</table>

### User Groups—NBI

Cisco EPN Manager provides the default NBI user groups listed in the following table. The permissions in these groups are not editable.

See View and Change the Tasks a Group Can Perform, on page 752 for information on the tasks that pertain to each user group and the default settings.

<table>
<thead>
<tr>
<th>User Group</th>
<th>Provides access to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>NBI Credential</td>
<td>Credential management using MTOSI NBI. Can also belong to other NBI and web UI user groups.</td>
</tr>
<tr>
<td>NBI Read</td>
<td>MTOSI and RESTCONF NBI read operations (HTTP GET). Can also belong to other NBI and web UI user groups.</td>
</tr>
</tbody>
</table>
Provides access to: User Group
| Provides access to: | MTOSI and RESTCONF NBI write operations (HTTP PUT, POST, DELETE). Can also belong to other NBI and web UI user groups. |

**View and Change the Tasks a User Can Perform**

The tasks a user can perform is controlled by the user groups the user belongs to. Follow these steps to find out which groups a user belongs to and which tasks a user is authorized to perform.

**Note** If you want to check the *devices* a user can access, see **Assign Virtual Domains to Users, on page 763**.

**Step 1** Choose **Administration** > **Users** > **Users, Roles & AAA** and locate the username.

**Step 2** Locate the username and check the **Member of** column to find out which user groups the user belongs to.

**Step 3** Click a user group hyperlink. The **Group Detail** window lists the tasks that group members can and cannot perform.

- A checked check box means group members have permission to perform that task. If a checked box is greyed-out, it means you cannot disable the task. For example, Cisco EPN Manager does not allow you to remove the "View tags" task for the Monitor Lite user group because it is an integral task for that user group.

- A blank check box means group members cannot perform that task. If a blank check box is greyed out, it means you cannot enable the task for the user group.

The web GUI root and Monitor Lite groups, and the NBI groups, are not editable.

**Step 4** If you want to change permissions, you have these choices:

**Note** Be careful. Selecting and deselecting tasks in the Group Detail window will apply your changes to *all group members*.

- Change permissions for all user group members. See **View and Change the Tasks a Group Can Perform, on page 752**.

- Add the user to a different user group. The predefined user groups are described in **User Groups—Web UI, on page 748** and **User Groups—NBI, on page 749**. Those topics also describe any group restrictions; for example, if a user belongs to the predefined Monitor Lite user group, the user cannot belong to any other groups.

- Remove the user from this group. See **View and Change the Groups a User Belongs To, on page 750**.

- Use a customized user group and add the user to that group. To find out which customized groups already exist, see **View and Change the Tasks a Group Can Perform, on page 752**. To create a new customized group, see **Create a Customized User Group, on page 751**.

**View and Change the Groups a User Belongs To**

The tasks users can perform is determined by the user groups they belong to. This is normally configured when a user account is created (see **Add and Delete Users, on page 754**). User groups are described in **Types of User Groups, on page 748**.
This procedure explains how to view the groups a user belongs to and, if necessary, change the user's group membership.

**Step 1** Choose > Administration > Users, Roles & AAA Users, then choose Users.

**Step 2** In the User Name, column, locate and click the user name hyperlink to open the User Details window. All user groups are listed under the General tab.

- A checked check box means the user belongs to that group. If a checked box is greyed-out, it means you cannot remove the user from that group. For example, Cisco EPN Manager will not allow you to remove the user named **root** from the root user group.
- A blank check box means the user does not belong to that group. If a blank check box is greyed-out, it means you cannot add the user to that group.

(To check the tasks that a group can perform, choose User Groups from the left sidebar menu and click a group name.)

**Step 3** To change the groups the user belongs to, select and unselect the appropriate groups in the User Details window, then click Save.

---

**View User Groups and Their Members**

Users can belong to multiple groups, unless they belong to a very restricted group such as Monitoring Lite. This procedure explains how to view existing user groups and their members.

**Step 1** Choose Administration > Users > Users, Roles & AAA, then choose User Groups.

The User Groups page lists all existing user groups and a short list of their members. For a description of these groups, see Types of User Groups, on page 748.

**Step 2** To view all members of a group, click a group hyperlink to open the Group Details window, then click the Members tab.

**Step 3** If you want to make changes to these groups, see:

- View and Change the Tasks a Group Can Perform, on page 752
- View and Change the Groups a User Belongs To, on page 750

---

**Create a Customized User Group**

Cisco EPN Manager provides a set of predefined user groups that help you control user authorization. These groups are described in Types of User Groups, on page 748 and include four User Defined groups which you can customize to create a user group that is specific to your deployment. The following procedure explains how to create a customized group using one of the four predefined User Defined group templates.

**Step 1** Choose Administration > Users > Users, Roles & AAA, then choose User Groups.

**Step 2** Locate a User Defined group that has no members, then click its group name hyperlink.
View and Change the Tasks a Group Can Perform

Follow these steps to get information about existing user groups and the tasks group members can perform. The predefined user groups are described in View User Groups and Their Members, on page 751.

### Note
If you want to change device access, see Assign Virtual Domains to Users, on page 763.

#### Step 1
Choose Administration > Users > Users, Roles & AAA, then choose User Groups.

The User Groups page lists all existing user groups.

#### Step 2
Click a user group hyperlink. The Group Detail window lists the group permissions.

- A checked task means group members have permission to perform that task. If a checked box is greyed-out, it means you cannot disable the task.
- A blank check box means group members cannot perform that task. If a blank check box is greyed out, it means you cannot enable the task for the user group.

The web GUI root and Monitor Lite groups, and the NBI groups, are not editable.

#### Step 3
If you want to change the group permissions—which will affect all group members—check and uncheck tasks, then click Save.

**Note**
Be careful. Selecting and deselecting tasks in the Group Detail window will apply your changes to all group members. An alternative is to create a new group using one of the User Defined group templates; see Create a Customized User Group, on page 751.

Use Cisco EPN Manager User Groups with RADIUS and TACACS+

Your RADIUS or TACACS+ servers must be configured to recognize the user groups that exist in Cisco EPN Manager. You can do this using the procedure in Export the Cisco EPN Manager User Group and Role Attributes for RADIUS and TACACS+, on page 752.

Export the Cisco EPN Manager User Group and Role Attributes for RADIUS and TACACS+

If you are using RADIUS or TACACS+, you must copy all Cisco EPN Manager user group and role information into your Cisco Access Control Server (ACS) or Cisco Identity Services Engine (ISE) server. You can do this using the Task List dialog box provided in the Cisco EPN Manager web GUI. If you do not
export the data into your Cisco ACS or Cisco ISE server, Cisco EPN Manager will not allow users to perform their assigned tasks.

The following information must be exported:

• TACACS+—Requires virtual domain and role information (tasks are automatically added).
• RADIUS—Requires virtual domain and role information (tasks are automatically added).

Information in the Task List dialog is preformatted for use with the Cisco ACS server.

**Note**
When you add tasks to the external server, be sure to add the **Home Menu Access** task. It is mandatory for all users.

**Before you begin**
Make sure you have added the AAA server and configured the AAA mode as explained in Configure External Authentication, on page 767.

---

**Step 1**
In Cisco EPN Manager:

a) Choose **Administration > Users > User Groups**.

b) From the User Groups table, copy the role for each user group by clicking the **Task List** hyperlink (at the end of a user group row).
   - If you are using RADIUS, right-click the **role0 line** in the RADIUS Custom Attributes field and choose **Copy**.
   - If you are using TACACS+, right-click the **role0 line** in the TACACS+ Custom Attributes field and choose **Copy**.

**Step 2**
Paste the information into your Cisco ACS or Cisco ISE server. These steps show how to add the information to an existing user group in Cisco ACS. If you have not yet added this information to Cisco ACS or Cisco ISE, see:

• Use Cisco ACS With RADIUS or TACACS+ for External Authentication, on page 773
• Use Cisco ISE With RADIUS or TACACS+ for External Authentication, on page 768

a) Navigate to **User or Group Setup**.
b) For the applicable user or group, click **Edit Settings**.
c) Paste the attributes list into the appropriate text box.
d) Select the check boxes to enable these attributes, then click **Submit + Restart**.

---

**Add Users and Manage User Accounts**

• Create Web GUI Users with Administrator Privileges, on page 754
• Add and Delete Users, on page 754
• Disable (Lock) a User Account, on page 755
• Change a User’s Password, on page 755
Create Web GUI Users with Administrator Privileges

After installation, Cisco EPN Manager has a web GUI root account named root. This account is used for first-time login to the server to create:

- Web GUI users with Administrator privileges who will manage the product and features
- All other user accounts

You should not use the web GUI root account for normal operations. For security purposes, create a new web GUI user with Administrator privileges (and access to all devices), and then disable the web GUI root account.

---

**Step 1**
Choose Administration > Users > Users, Roles & AAA, then choose Users.

**Step 2**
From the Select a command drop-down list, choose Add User, then click Go.

**Step 3**

**Step 4**
Complete the required fields.

**Step 5**
In the General tab under Groups Assigned to This User, click Admin.

**Step 6**
Click the Virtual Domains tab to specify which devices the user can access. You should have at least one Admin web GUI user that has access to all devices (ROOT-DOMAIN). For more information on virtual domains, see Create Virtual Domains to Control User Access to Devices, on page 758.

**Step 7**
Click Save.

---

**What to do next**

If you have not done so already, for security purposes, disable the web GUI root account as described in Disable and Enable the Web GUI root User, on page 747.

---

Add and Delete Users

Before you create user accounts, create virtual domains to control device access so you can apply them during account creation. Otherwise you will have to edit the user account to add the domain access. See Create Virtual Domains to Control User Access to Devices, on page 758.

If you want to temporarily disable an account (rather than delete it), see Disable (Lock) a User Account, on page 755.

---

**Step 1**
Choose Administration > Users > Users, Roles & AAA, then choose Users.

**Step 2**
From the Select a command drop-down list, choose Add User, then click Go.

**Step 3**
Configure the user account.

a) Enter a username and password.

b) Enter the first name, last name, and a description for the user.

c) Control the actions the user can perform by selecting one or more user groups. For descriptions of user groups, see View User Groups and Their Members, on page 751.

d) Control the devices a user can access by clicking the Virtual Domains tab and assigning domains to the user. (see Create Virtual Domains to Control User Access to Devices, on page 758).

**Step 4**
Click Save.
Step 5 To delete a user account, select a user, choose Delete User from the Select a command drop-down list, then click Go.

Disable (Lock) a User Account

Disable a user account when you temporarily want to disallow a user from logging into the Cisco EPN Manager GUI. You might want to do this if a user is temporarily changing job functions. If the user tries to log in, Cisco EPN Manager displays a message saying the login failed because the account is locked. You can unlock the account later without having to re-create the user. If you want to delete a user account, see Add and Delete Users, on page 754.

User accounts may be disabled automatically if the password is not changed before expiration. Only an administrator can reset the password in this case. See Change a User’s Password, on page 755 and Configure Global Password Policies for Local Authentication, on page 757.

Step 1 Choose Administration > Users > Users, Roles & AAA, then click Users.
Step 2 Select the user whose access you want to disable or enable.
Step 3 From the Select a command drop-down list, select Lock User(s) (or Unlock User(s)), then click Go.

Change a User’s Password

You can force users to change their passwords on a regular basis using password rules (see Configure Global Password Policies for Local Authentication, on page 757). Users can change their own passwords as described in Change Your Password, on page 3. If you need to make an immediate change to a user's password, use this procedure.

Step 1 Choose Administration > Users > Users, Roles & AAA, then click Users.
Step 2 Click the username hyperlink.
Step 3 Enter the new password in the password fields, then click Save.

Find Out Which Users Are Currently Logged In

Use this procedure to find out who is currently logged into the Cisco EPN Manager server. You can also view a historical list of the actions performed by the user in the current web GUI session and past sessions.

Step 1 Choose Administration > Users > Users, Roles & AAA, then choose Active Sessions. Cisco EPN Manager lists all users that are currently logged in to the Cisco EPN Manager server, including their client machine IP address. If the user performed any actions on managed devices (for example, the user added new devices to Cisco EPN Manager), the device IP addresses are listed in the Device IPAddress column.
Step 2 To view a historical list of all actions performed by this user, click the Audit Trail icon that corresponds to the user name.
View the Tasks Performed By Users (Audit Trail)

Cisco EPN Manager maintains a history of all actions performed by users in active and past web GUI sessions. Follow these steps to view a historical list of tasks performed by a specific user or by all members of a specific user group. The audit information includes a description of the task, the IP address of the client from which the user performed the task, and the time at which the task was performed. If a task affects a managed device (for example, a user adds a new device), the affected device's IP address is listed in the Device IPAddress column. If a change is made to multiple devices (for example, a user deploys a configuration template to 10 switches), Cisco EPN Manager displays an audit entry for each switch.

To find out which users are currently logged into the Cisco EPN Manager web GUI, see Find Out Which Users Are Currently Logged In, on page 755.

To view audits that are not user-specific, see these topics:
- Audit Actions Executed from the GUI (System Audit), on page 801
- Audit Configuration Archive and Software Management Changes (Network Audit), on page 799
- Audit Changes Made By Users (Change Audit), on page 799

---

**Step 1**
Choose Administration > Users > Users, Roles & AAA.

**Step 2**
To view the tasks performed by a specific user:
1. Choose Users.
2. Locate the user name, then click the Audit Trail icon corresponding to that user.

**Step 3**
To view a historical list of the tasks performed by all members of a user group:
2. Locate the user group name, then click the Audit Trail icon corresponding to that group.

---

Configure Job Approvers and Approve Jobs

Use job approval when you want to control jobs that could significantly impact the network. If a job requires approval, Cisco EPN Manager sends an e-mail to all users with Admin privileges and does not run the job until one of them approves it. If a job is rejected by an approver, the job is removed from the database. By default, all jobs do not require approval.

If job approval is already enabled and you want to view jobs that need approval, approve a job, or reject a job, choose Administration > Dashboards > Job Dashboard, then click the Job Approval link.

To enable job approval and configure the jobs that require approval before running:

**Step 1**
Choose Administration > Settings > System Settings, then choose General > Job Approval.
Configure Global Password Policies for Local Authentication

If you are using local authentication (Cisco EPN Manager’s authentication mechanism), you control the global password policies from the web GUI. If you are authenticating Cisco EPN Manager users using external authentication, the policies are controlled by an external application (see Set Up External Authentication Using the CLI, on page 677).

By default, users are not forced to change passwords after any period of time. To enforce password changes and configure other password rules, choose Administration > Users > Users, Roles & AAA, then choose Local Password Policy.

Configure the Global Timeout for Idle Users

Cisco EPN Manager provides two settings that control when and how idle users are automatically logged out:

- User Idle Timeout—You can disable or configure this setting, which ends your user session automatically when you exceed the timeout. It is enabled by default and is set to 15 minutes.

- Global Idle Timeout—The Global Idle Timeout setting overrides the User Idle Timeout setting. The Global Idle Timeout is enabled by default and is set to 15 minutes. Only users with administrative privileges can disable the Global Idle Timeout setting or change its time limit.

By default, client sessions are disabled and users are automatically logged out after 15 minutes of inactivity. This is a global setting that applies to all users. For security purposes, you should not disable this mechanism, but you can adjust the timeout value using the following procedure. To disable/change the timeout for an idle user, see Disable Idle User Timeout, on page 758.

Step 1  Choose Administration > Settings > System Settings, then choose General > Server.
Step 2  In the Global Idle Timeout area, make sure the Logout all idle users check box is selected (this means the mechanism is enabled).
Step 3  Configure the timeout by choosing a value from the Logout all idle users after drop-down list.
Step 4  Click Save. You will need to log out and log back in for this change to take effect.
Disable Idle User Timeout

By default, client sessions are disabled and users are automatically logged out after certain period of inactivity. This is a global setting that applies to all users. To avoid being logged out during the installation, it is recommended to disable automatic logout of idle users in the system settings using the following procedure.

Note

The Global Idle Timeout setting overrides the User Idle Timeout setting. To configure Global Idle Timeout settings, see Configure the Global Timeout for Idle Users, on page 757.

Step 1
Choose Administration > Settings > System Settings, then choose General > Server.

Step 2
In the Global Idle Timeout area, uncheck the Logout all idle users check box and click Save.

Step 3
Click at the top right of web GUI window and choose My Preferences.

Step 4
In the User Idle Timeout area, uncheck the Logout idle user check box and click Save.

If you need to change the idle timeout value, then select Logout idle user check box and from the Logout idle user after drop-down list, choose one of the idle timeout limits. (But this cannot exceed the value set in the Global Idle Timeout settings.)

Step 5
Click Save. You will need to log out and log back in for this change to take effect.

Create Virtual Domains to Control User Access to Devices

- What Are Virtual Domains?, on page 758
- How Virtual Domains Affect Cisco EPN Manager Features, on page 759
- Create New Virtual Domains, on page 760
- Import a List of Virtual Domains, on page 763
- Add Network Devices to Virtual Domains, on page 763
- Assign Virtual Domains to Users, on page 763
- Export the Cisco EPN Manager Virtual Domain Attributes for RADIUS and TACACS+, on page 765
- Edit a Virtual Domain, on page 764
- Delete a Virtual Domain, on page 764

What Are Virtual Domains?

Virtual domains are logical groupings of devices, sites, and other NEs, and are used to control who has access to those NEs. You choose which elements are included in a virtual domain and which users have access to that virtual domain. Virtual domains can be based on physical sites, device types, user communities, or any
other designation you choose. All devices belong to ROOT-DOMAIN, which is the parent domain for all new virtual domains.

Virtual domains work in conjunction with user groups. Virtual domains control the devices a user can access, while user groups determine the actions a user can perform on those devices. Users with access to a virtual domain (depending on their privileges) can configure devices, view alarms, and generate reports for the NEs in their virtual domain.

You can create virtual domains after you have added devices to Cisco EPN Manager. Each virtual domain must have a name and can have an optional description, email address, and time zone. Cisco EPN Manager uses the email address and time zone that you specify to schedule and email domain-specific reports.

Users work in one virtual domain at a time. Users can change the current virtual domain by choosing a different one from the Virtual Domain drop-down list (see Work In a Different Virtual Domain, on page 25).

Before you set up virtual domains, determine which users are responsible for managing particular areas of the network. Then organize your virtual domains according to those needs—for example, by geography, by device type, or by the user community served by the network.

How Virtual Domains Affect Cisco EPN Manager Features

Virtual domains are organized hierarchically. The ROOT-DOMAIN domain includes all virtual domains.

Because network elements are managed hierarchically, user views of devices—as well as some associated features and components—are affected by the user's virtual domain. The following topics describe the effects of virtual domains on these features.

- Reports and Virtual Domains, on page 759
- Search and Virtual Domains, on page 759
- Alarms and Virtual Domains, on page 760
- Maps and Virtual Domains, on page 760
- Configuration Templates and Virtual Domains, on page 760
- Config Groups and Virtual Domains, on page 760
- Email Notifications and Virtual Domains, on page 760

Reports and Virtual Domains

Reports only include components that belong to the active virtual domain. A parent virtual domain cannot view reports from its child domains. New components are only reflected in reports that are generated after the components were added.

Search and Virtual Domains

Search results only include components that belong to the active domain. You can only view saved search results if you are in the same domain from which the search was performed and saved. When working in a parent domain, you cannot view the results of searches performed in child domains.
Alarms and Virtual Domains

When a component is added to a virtual domain, no previous alarms for that component are visible to that virtual domain. Only new alarms are visible. For example, if a network element is added to Cisco EPN Manager, and that network element generated alarms before and after it was added, its alarm history would only include alarms generated after it was added.

**Note**
For alarm email notifications, only the ROOT-DOMAIN virtual domain can enable Location Notifications, Location Servers, and Cisco EPN Manager email notifications.

Maps and Virtual Domains

Maps only display network elements that are members of the active virtual domain.

Configuration Templates and Virtual Domains

When you create or discover a configuration template in a virtual domain, it can only be applied to network elements in that virtual domain. If you apply a template to a device and then add that device to a child domain, the template is also available to the same device in the child domain.

**Note**
If you create a child domain and then apply a configuration template to both network elements in the virtual domain, Cisco EPN Manager might incorrectly reflect the number of partitions to which the template was applied.

Config Groups and Virtual Domains

A parent domain can view the network elements in a child domain's configuration groups. The parent domain can also edit the child domain's configuration groups.

Email Notifications and Virtual Domains

Email notifications can be configured per virtual domain.

For alarm email notifications, only the ROOT-DOMAIN can enable Location Notifications, Location Servers, and email notifications.

Create New Virtual Domains

To create a new virtual domain, use one of the following procedures depending on the desired hierarchy of the virtual domain.

<table>
<thead>
<tr>
<th>To create a new virtual domain (new-domain) here:</th>
<th>See this procedure:</th>
</tr>
</thead>
<tbody>
<tr>
<td>ROOT-DOMAIN &gt; new-domain</td>
<td>Create Virtual Domains Directly Under ROOT-DOMAIN, on page 761</td>
</tr>
</tbody>
</table>
Create Virtual Domains Directly Under ROOT-DOMAIN

The following procedure creates an empty virtual domain under ROOT-DOMAIN. You can also create multiple virtual domains at one time by using the procedure in Import a List of Virtual Domains, on page 763.

If a virtual domain already exists under ROOT-DOMAIN, and you want to create a new domain under it (a child domain), see Create Child Virtual Domains (Subdomains), on page 761.

Step 1 Choose Administration > Users > Virtual Domains.
Step 2 In the Virtual Domains sidebar menu, click the + icon (Add New Domain).
Step 3 Enter a name in the Name text box. This is required.
Step 4 (Optional) Enter the new domain's time zone, email address and description.
Step 5 Click Submit to view a summary of the newly-created virtual domain.

What to do next
Add devices to the virtual domain as described in Add Network Devices to Virtual Domains, on page 763.

Create Child Virtual Domains (Subdomains)

The following procedure creates a child virtual domain (also called a subdomain). A child virtual domain is a domain that is not directly under ROOT-DOMAIN; it is under a domain that is under ROOT-DOMAIN.

Do not use this procedure if you want the new virtual domain to appear directly under ROOT-DOMAIN. In that case, see Create Virtual Domains Directly Under ROOT-DOMAIN, on page 761.

Step 1 Choose Administration > Users > Virtual Domains.
Step 2 In the Virtual Domains sidebar menu:
   a) Locate the domain under which you want to create a new child domain. (This is called the parent domain.) In this example, the parent domain is California.
   b) Click the information (i) icon next to the domain name. This opens a data popup window.
   c) In the popup window, click Create Sub Domain. The navigation pane switches to the list view, with the parent domain California displayed above Untitled.
Step 3 Enter a name in the Name text box. This is required. In this example, the new child domain is named Los Angeles. (The name in the navigation pane will not change from Untitled to Los Angeles until you save the new child domain.)
Step 4  (Optional) Enter the new domain's time zone, email address and description.

Step 5  Click Submit and confirm the creation of the new child domain. To revert back to the hierarchical view, click the view toggle button at the top of the navigation pane.

The view reverts to the hierarchical view.

What to do next

Add devices to the virtual domain as described in Add Network Devices to Virtual Domains, on page 763.
Import a List of Virtual Domains

If you plan to create many virtual domains, or give them a complex hierarchy, you will find it easier to specify them in a properly formatted CSV file, and then import it. The CSV format allows you to specify a name, description, time zone, and email address for each virtual domain you create, as well as each domain's parent domain. Adding network elements to the virtual domains must be performed separately.

**Step 1** Choose Administration > Users > Virtual Domains.

**Step 2** Click the Import Domain(s) icon, download a sample CSV file from the link provided in the popup, and prepare the CSV file.

**Step 3** Click Choose File and navigate to your CSV file.

**Step 4** Click Import to import the CSV and create the virtual domains you specified.

**What to do next**

Add devices to the virtual domains as explained in Add Network Devices to Virtual Domains, on page 763.

Add Network Devices to Virtual Domains

Use this procedure to add network devices to a virtual domain. When you add a new network device to an existing virtual domain, the device becomes immediately accessible to users with access to that domain (users do not have to restart the web GUI).

**Step 1** Choose Administration > Users > Virtual Domains.

**Step 2** From the Virtual Domains sidebar menu, click the virtual domain to which you want to add network devices.

**Step 3** Click the Network Devices tab, then click Add.

**Step 4** Select the network devices you want to add to the domain. Note that the Select Network Devices dialog lists all managed devices, not only those that are in the parent domain. If you add a device that is not included in the parent domain, Cisco EPN Manager adds it to both the child and parent domain.

a) Select the devices you want to add to the domain. You can use the Filter By drop-down list to locate the devices you want to add.

b) Click Select.

**Step 5** Click Submit to view the summary of the virtual domain contents.

**Step 6** Click Save to confirm your changes.

**What to do next**

Give users access to the virtual domain as described in Assign Virtual Domains to Users, on page 763.

Assign Virtual Domains to Users

Once a virtual domain is assigned to a user account, the user is restricted to viewing and performing operations on the devices in their assigned domain(s).
When using external AAA, be sure to add the custom attributes for virtual domains to the appropriate user or group configuration on the external AAA server. See Use Cisco EPN Manager Virtual Domains with RADIUS and TACACS+, on page 765.

---

**Step 1** Choose **Administration > Users, Roles & AAA > Users**.

**Step 2** Select the user to whom you want to grant device access.

**Step 3** Click the **Virtual Domains** tab.

**Step 4** Use the **Add** and **Remove** buttons to make your assignment changes, then click **Save**.

---

**Edit a Virtual Domain**

To adjust a virtual domain, choose it from the Virtual Domain Hierarchy on the left sidebar menu to view or edit its assigned network devices. You cannot edit any of the settings for ROOT-DOMAIN.

**Step 1** Choose **Administration > Users > Virtual Domains**.

**Step 2** Click the virtual domain you want to edit in the Virtual Domains sidebar menu.

**Step 3** To adjust the name, email address, time zone, or description, enter your changes in the text boxes.

**Step 4** To adjust device members:
  - To add devices, click **Add** and follow the instructions in Add Network Devices to Virtual Domains, on page 763.
  - To delete devices, select the devices using their check boxes, then click **Delete**.

**Step 5** Click **Submit**, then check the summary of your changes.

**Step 6** Click **Save** to apply and save your edits.

---

**Delete a Virtual Domain**

Use this procedure to delete a virtual domain from Cisco EPN Manager. This procedure only deletes the virtual domain; it does not delete the network elements from Cisco EPN Manager (the network elements will continue to be managed by Cisco EPN Manager).

**Before you begin**

You can only delete a virtual domain if:

- The virtual domain does not contain any network elements and does not have any child domains.
- It is not the only domain a user can access. In other words, if a Cisco EPN Manager user has access to only that domain, you cannot delete it.
- No users are logged into the domain.
**Step 1** Choose Administration > Users > Virtual Domains.

**Step 2** In the Virtual Domains sidebar menu, click the information (i) icon next to the virtual domain name. This opens a data popup window.

**Step 3** In the popup window, click **Delete**.

**Step 4** Click **OK** to confirm deleting the virtual domain.

---

**Use Cisco EPN Manager Virtual Domains with RADIUS and TACACS+**

Your RADIUS or TACACS+ servers must be configured to recognize the virtual domains that exist in Cisco EPN Manager. You can do this using the procedure in Export the Cisco EPN Manager Virtual Domain Attributes for RADIUS and TACACS+, on page 765.

If your RADIUS or TACACS+ server does not have any virtual domain information for a user, the following occurs, depending on the number of virtual domains that are configured in Cisco EPN Manager:

- If Cisco EPN Manager has only one virtual domain (ROOT-DOMAIN), the user is assigned the ROOT-DOMAIN by default.
- If Cisco EPN Manager has multiple virtual domains, the user is prevented from logging in.

**Export the Cisco EPN Manager Virtual Domain Attributes for RADIUS and TACACS+**

If you are using RADIUS or TACACS+, you must copy all Cisco EPN Manager virtual domain information into your Cisco ACS or Cisco ISE server. You can do this using the Virtual Domains Custom Attributes dialog box provided in the Cisco EPN Manager web GUI. If you do not export the data into your Cisco ACS or Cisco ISE server, Cisco EPN Manager will not allow users to log in.

The following information must be exported, depending on the protocol you are using:

- **TACACS+**—Requires virtual domain, role, and task information.
- **RADIUS**—Requires virtual domain and role information (tasks are automatically added).

When you create a child domain for an existing virtual domain, the sequence numbers for the RADIUS/TACACS+ custom attributes are also updated in the parent virtual domain. These sequence numbers are for representation only and do not impact AAA integration.

Information in the Virtual Domains Custom Attributes dialog is preformatted for use with Cisco ACS server.

---

**Note**

When you add tasks to the external server, be sure to add the **Home Menu Access** task. It is mandatory for all users.

---

**Before you begin**

Make sure you have added the AAA server and configured the AAA mode as explained in Configure External Authentication, on page 767.
**Configure Local Authentication**

Cisco EPN Manager uses local authentication by default, which means that user passwords are stored and verified from the Cisco EPN Manager database. To check the authentication mode that is being used, choose **Administration > Users > Users, Roles & AAA**, then choose **AAA Mode Settings**. The selection is displayed on the AAA Mode Settings page. If you are using local authentication, be sure to configure strong password policies. See **Configure Global Password Policies for Local Authentication**, on page 757.

If you want to use SSO with local authentication, see **Use SSO With Local Authentication**, on page 766.

For information on external authentication, see **Configure External Authentication**, on page 767.

**Use SSO With Local Authentication**

To use SSO with local authentication, you must add the SSO server and then configure Cisco EPN Manager to use SSO in local mode.

If you have deployed Cisco EPN Manager in a high availability environment where you have a primary and backup server, refer to the instructions in **Configure an SSO Server in an HA Environment**, on page 817.

Cisco EPN Manager does not support localization on the SSO sign-in page.

The following topics describe how to configure SSO for external authentication, but you can use the same procedures to configure SSO for local authentication. The only difference is that when you configure the SSO mode on the Cisco EPN Manager server, choose **Local** mode (not RADIUS or TACACS+).
Configure External Authentication

Users with web GUI root user or SuperUser privileges can configure Cisco EPN Manager to communicate with external RADIUS, TACACS+, and SSO servers for external authentication, authorization, and accounting (AAA). If you choose to configure external authentication, the user groups, users, authorization profiles, authentication policies, and policy rules must be created in the external server through which all access requests to Cisco EPN Manager will be routed.

You can use a maximum of three AAA servers. Users are authenticated on the second server only if the first server is not reachable or has network problems.

If you want to configure external authentication from the CLI, see Set Up External Authentication Using the CLI, on page 677.

See the following topics for more information.

• Use RADIUS or TACACS+ for External Authentication, on page 767
• Use Cisco ISE With RADIUS or TACACS+ for External Authentication, on page 768
• Use Cisco ACS With RADIUS or TACACS+ for External Authentication, on page 773
• Use SSO with External Authentication, on page 778

Use RADIUS or TACACS+ for External Authentication

These topics explain how to configure Cisco EPN Manager to use RADIUS or TACACS+ servers.

• Add a RADIUS or TACACS+ Server to Cisco EPN Manager, on page 767
• Configure RADIUS or TACACS+ Mode on the Cisco EPN Manager Server, on page 768

Add a RADIUS or TACACS+ Server to Cisco EPN Manager

To add a RADIUS or TACACS+ server to Cisco EPN Manager:

Step 1 Choose Administration > Users > Users, Roles & AAA, then choose RADIUS Servers.

Step 2 Select the type of server you want to add.

• For RADIUS, choose RADIUS Servers. From the Select a command drop-down list, choose Add RADIUS Server, then click Go.
• For TACACS+, choose TACACS+ Servers. From the Select a command drop-down list, choose Add TACACS+ Server, then click Go.

Note You can use Move Up and Move Down arrow to reorder the available IP address.

Step 3 Enter the required information—IP address, DNS Name, and so forth. For Cisco EPN Manager to communicate with the external authentication server, the shared secret you enter on this page must match the shared secret configured on the RADIUS or TACACS+ server. You can use alphabets, numbers, and special characters except ’ (single quote) and “ (double quote) while entering the shared secret key for a third-party TACACS+ or RADIUS server.
Configure RADIUS or TACACS+ Mode on the Cisco EPN Manager Server

Step 4  Select the authentication type.

- PAP—Password-based authentication is the protocol where two entities share a password in advance and use the password as the basis of authentication.
- CHAP—Challenge-Handshake Authentication Protocol requires that both the client and server know the plain text of the secret, although it is never sent over the network. CHAP provides greater security than Password Authentication Protocol (PAP).

Step 5  If you have enabled the High Availability feature and configured a virtual IP address for the Local Interface IP, choose either the virtual IP address or the physical IP address of the primary server. (See the information on setting up and installing high availability on a secondary server in the Cisco Evolved Programmable Network Manager Installation Guide.)

Note  The IP address configured in the external authentication server must match the Local Interface IP.

Step 6  Click Save.

Use Cisco ISE With RADIUS or TACACS+ for External Authentication

Cisco Identity Services Engine (ISE) uses the RADIUS or TACACS+ protocols for authentication, authorization, and accounting (AAA). You can integrate Cisco EPN Manager with Cisco ISE to authenticate the Cisco EPN Manager users using the RADIUS or TACACS+ protocols. When you use external authentication, the details such as users, user groups, passwords, authorization profiles, authorization policies, and policy rules that are required for AAA must be stored and verified from the Cisco ISE database.

Complete the following tasks to use Cisco ISE with the RADIUS or TACACS+ protocol for external authentication:

<table>
<thead>
<tr>
<th>Tasks to be completed to use Cisco ISE for external authentication</th>
<th>For information, see:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make sure you are using a supported version of Cisco ISE</td>
<td>Supported Versions of Cisco ISE in Cisco EPN Manager, on page 769</td>
</tr>
<tr>
<td>Task</td>
<td>Page Reference</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Add Cisco EPN Manager as an AAA client in Cisco ISE</td>
<td>769</td>
</tr>
<tr>
<td>Create a user group in Cisco ISE</td>
<td>770</td>
</tr>
<tr>
<td>Create a user in Cisco ISE and add the user to the user group that is created in Cisco ISE</td>
<td>770</td>
</tr>
<tr>
<td>(If using RADIUS) Create an authorization profile for network access in Cisco ISE, and add the RADIUS custom attributes with user roles and virtual domains created in Cisco EPN Manager</td>
<td>770</td>
</tr>
<tr>
<td><strong>Note</strong> For RADIUS, you do not need to add the attributes for user tasks. They are automatically added based on the user roles.</td>
<td></td>
</tr>
<tr>
<td>(If using TACACS+) Create an authorization profile for network access in Cisco ISE, and add the TACACS+ custom attributes with user roles and virtual domains created in Cisco EPN Manager</td>
<td>771</td>
</tr>
<tr>
<td><strong>Note</strong> For TACACS+, you need not add the attributes for user tasks. They are automatically added based on the user roles.</td>
<td></td>
</tr>
<tr>
<td>Create an authorization policy in Cisco ISE and associate the policy with the user groups and authorization profile created in Cisco ISE</td>
<td>772</td>
</tr>
<tr>
<td>Create an authentication policy to define the protocols that Cisco ISE must use to communicate with Cisco EPN Manager, and the identity sources that it uses for authenticating users to Cisco EPN Manager</td>
<td>773</td>
</tr>
<tr>
<td>Add Cisco ISE as a RADIUS or TACACS+ server in Cisco EPN Manager</td>
<td>767</td>
</tr>
<tr>
<td>Configure the RADIUS or TACACS+ mode on the Cisco EPN Manager server</td>
<td>768</td>
</tr>
</tbody>
</table>

**Supported Versions of Cisco ISE in Cisco EPN Manager**
Cisco EPN Manager supports Cisco ISE 1.x and 2.x releases.

**Add Cisco EPN Manager as a Client in Cisco ISE**

**Step 1** Log in to Cisco ISE as the admin user.

**Step 2** Choose **Administration > Network Resources > Network Devices**.

**Step 3** In the **Network Devices** page, click **Add**.

**Step 4** Enter the device name and IP address of the Cisco EPN Manager server.

**Step 5** Check the **Authentication Settings** check box, and then enter the shared secret.
Ensure that this shared secret matches the shared secret you enter when adding the Cisco ISE server as the RADIUS server in Cisco EPN Manager.

Step 6  
Click Submit.

---

Create a User Group in Cisco ISE

1. Log in to Cisco ISE as the admin user.
2. Choose Administration > Identity Management > Groups.
3. In the User Identity Groups page, click Add.
4. In the Identity Group page, enter the name and description of the user group.
5. Click Submit.

Create a User and Add the User to a User Group in Cisco ISE

1. Log in to Cisco ISE as the admin user.
2. Choose Administration > Identity Management > Identities.
3. In the Network Access Users page, click Add.
4. From the Select an item drop-down list, choose a user group to assign the user to.
5. Click Submit.

Create an Authorization Profile for RADIUS in Cisco ISE

You create authorization profiles to define how different types of users are authorized to access the network. For example, you can define that a user attempting to access the network over a VPN connection is treated more strictly than a user attempting to access the network through a wired connection.

When you create an authorization profile for device administration, you must add the RADIUS custom attributes that are associated with user roles, tasks, and virtual domains created in Cisco EPN Manager.

Note

For RADIUS, you can add the user role attributes without adding the task attributes. The tasks are automatically added with the user roles.

For more information about Cisco ISE authorization profiles, see the information on managing authorization policies and profiles in the Cisco Identity Services Engine Administrator Guide.

To create an authorization profile for RADIUS in Cisco ISE:
Before you begin

Make sure you have the complete list of the following Cisco EPN Manager custom attributes for RADIUS. You will need to add this information to Cisco ISE in this procedure.

- Cisco EPN Manager user roles and tasks—see Export the Cisco EPN Manager User Group and Role Attributes for RADIUS and TACACS+, on page 752
- Cisco EPN Manager virtual domains—see Export the Cisco EPN Manager Virtual Domain Attributes for RADIUS and TACACS+, on page 765

Step 1 Log in to Cisco ISE as the admin user.
Step 2 Choose Policy > Policy Elements > Results.
Step 3 From the left sidebar, choose Authorization > Authorization Profiles.
Step 4 In the Standard Authorization Profiles page, click Add.
Step 5 In the Authorization Profile page, enter the name and description of the authorization profile.
Step 6 From the Access Type drop-down list, choose ACCESS_ACCEPT.
Step 7 In the Advanced Attributes Settings area, paste in the complete list of RADIUS custom attributes for:
  - User roles
  - Virtual domains

Note If you do add user tasks, be sure to add the Home Menu Access task. It is mandatory.

Step 8 Click Submit.

Create an Authorization Profile for TACACS+ in Cisco ISE

You create authorization profiles to define how different types of users are authorized to access the network. For example, you can define that a user attempting to access the network over a VPN connection is treated more strictly than a user attempting to access the network through a wired connection.

When you create an authorization profile for device administration, you must add the TACACS+ custom attributes that are associated with user roles, tasks, and virtual domains created in Cisco EPN Manager.

For more information about Cisco ISE authorization profiles, see the information on managing authorization policies and profiles in the Cisco Identity Services Engine Administrator Guide.

To create an authorization profile for TACACS+ in Cisco ISE:

Before you begin

Make sure you have the complete list of the following Cisco EPN Manager custom attributes for TACACS+. You will need to add this information to Cisco ISE in this procedure.

- Cisco EPN Manager user roles and tasks—see Export the Cisco EPN Manager User Group and Role Attributes for RADIUS and TACACS+, on page 752
- Cisco EPN Manager virtual domains—see Export the Cisco EPN Manager Virtual Domain Attributes for RADIUS and TACACS+, on page 765
Configure an Authorization Policy in Cisco ISE

An authorization policy consists of a rule or a set of rules that are user-defined and produce a specific set of permissions, which are defined in an authorization profile. Based on the authorization profile, access requests to Cisco EPN Manager are processed.

There are two types of authorization policies that you can configure:

- **Standard**—Standard policies are intended to be stable and are created to remain in effect for long periods of time, to apply to a larger group of users, devices, or groups that share a common set of privileges.

- **Exception**—Exception policies are created to meet an immediate or short-term need, such as authorizing a limited number of users, devices, or groups to access network resources. An exception policy lets you create a specific set of customized values for an identity group, condition, or permission that are tailored for one user or a subset of users.

For more information about authorization policies, see the “Manage Authorization Policies and Profiles” chapter in the Cisco Identity Services Engine Administrator Guide.

To create an authorization policy in Cisco ISE:

**Step 1** Log in to Cisco ISE as the admin user.

**Step 2** Choose **Policy > Authorization**.

**Step 3** In the **Standard** area, click the down arrow on the far right and select either **Insert New Rule Above** or **Insert New Rule Below**.

**Step 4** Enter the rule name and choose identity group, condition, attribute, and permission for the authorization policy.

For example, you can define a user group as Cisco EPN Manager -SystemMonitoring-Group and choose this group from the Identity Groups drop-down list. Similarly, define an authorization profile as Cisco EPN Manager -SystemMonitoring-authorization profile and choose this profile from the Permissions drop-down list. Now, you have defined a rule where all users belonging to the Cisco EPN Manager System Monitoring identity group receive an appropriate authorization policy with system monitoring custom attributes defined.
Create an Authentication Policy in Cisco ISE

Authentication policies define the protocols that Cisco ISE uses to communicate with Cisco EPN Manager, and the identity sources that it uses for authenticating users to Cisco EPN Manager. An identity source is an internal or external database where the user information is stored.

You can create two types of authentication policies in Cisco ISE:

- Simple authentication policy - In this policy, you can choose the allowed protocols and identity sources to authenticate users.
- Rule-based authentication policy - In this policy, you can define conditions that allow Cisco ISE to dynamically choose the allowed protocols and identity sources.

For more information about authentication policies, see the "Manage Authentication Policies" chapter in the Cisco Identity Services Engine Administrator Guide.

To create an authentication policy in Cisco ISE:

Step 1 Log in to Cisco ISE as the Super Admin or System Admin user.
Step 2 Choose Policy > Authentication.
Step 3 Choose the Policy Type as Simple or Rule-Based to create the required authentication policy.
Step 4 Enter the required details based on the policy type selected.
Step 5 Click Save.

Use Cisco ACS With RADIUS or TACACS+ for External Authentication

Cisco Secure Access Control System (ACS) uses RADIUS and TACACS+ protocol for authentication, authorization, and accounting (AAA). You can integrate Cisco EPN Manager with Cisco ACS to authenticate the Cisco EPN Manager users using the RADIUS or TACACS+ protocol. When you use an external authentication, the details such as users, user roles, passwords, authorization profiles, authorization policies, and policy rules that are required for AAA must be stored and verified from the Cisco ACS database.

Complete the following tasks to use Cisco ACS with the RADIUS or TACACS+ protocol for external authentication:

<table>
<thead>
<tr>
<th>Tasks to be completed to use Cisco ACS for external authentication</th>
<th>For information, see:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make sure you are using a supported version of Cisco ACS</td>
<td>Supported Versions of Cisco ACS in Cisco EPN Manager, on page 774</td>
</tr>
<tr>
<td>Add Cisco EPN Manager as an AAA client in Cisco ACS</td>
<td>Add Cisco EPN Manager as a Client in Cisco ACS, on page 774</td>
</tr>
<tr>
<td>Create a user group in Cisco ACS</td>
<td>Create a User Group in Cisco ACS, on page 775</td>
</tr>
</tbody>
</table>
Create a user in Cisco ACS and add the user to the Cisco ACS user group

Create an Authorization Profile for RADIUS in Cisco ACS, on page 775

**Note** For RADIUS, you do not need to add the attributes for user tasks. They are automatically added based on the user roles.

Create an Authorization Profile for TACACS+ in Cisco ACS, on page 776

**Note** For TACACS+, you need not add the attributes for user tasks. They are automatically added based on the user roles.

Create an Access Service for Cisco EPN Manager in Cisco ACS, on page 777

Create an Authorization Policy Rule in Cisco ACS, on page 777

Configure a Service Selection Policy in Cisco ACS, on page 778

Add Cisco ACS as a RADIUS or TACACS+ server in Cisco EPN Manager.

Add a RADIUS or TACACS+ Server to Cisco EPN Manager, on page 767

Configure the RADIUS or TACACS+ mode on the Cisco EPN Manager server.

Configure RADIUS or TACACS+ Mode on the Cisco EPN Manager Server, on page 768

### Supported Versions of Cisco ACS in Cisco EPN Manager

Cisco EPN Manager supports Cisco ACS 5.x releases.

### Add Cisco EPN Manager as a Client in Cisco ACS

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Log in to Cisco ACS as the admin user.</td>
</tr>
<tr>
<td>Step 2</td>
<td>From the left sidebar, choose <strong>Network Resources</strong> &gt; <strong>Network Devices</strong> &gt; <strong>Network Devices and AAA Clients</strong>.</td>
</tr>
<tr>
<td>Step 3</td>
<td>In the <strong>Network Devices</strong> page, click <strong>Create</strong>.</td>
</tr>
<tr>
<td>Step 4</td>
<td>Enter the device name and IP address of the Cisco EPN Manager server.</td>
</tr>
<tr>
<td>Step 5</td>
<td>Choose the authentication option as <strong>RADIUS</strong> or <strong>TACACS+</strong>, and enter the shared secret.</td>
</tr>
</tbody>
</table>

**Note** Ensure that this shared secret matches the shared secret you enter when adding the Cisco ACS server as the RADIUS or TACACS+ server in Cisco EPN Manager.
Create a User Group in Cisco ACS

Step 1  Log in to Cisco ACS as the admin user.
Step 2  From the left sidebar, Choose Users and Identity Stores > Identity Groups.
Step 3  In the Identity Groups page, click Create.
Step 4  Enter the name and description of the user group.
Step 5  Select a network device group parent for the user group.
Step 6  Click Submit.

Create a User and Add the User to a User Group in Cisco ACS

Step 1  Log in to Cisco ACS as the admin user.
Step 2  From the left sidebar, Choose Users and Identity Stores > Internal Identity Stores > Users.
Step 3  In the Internal Users page, click Create.
Step 4  Enter the required details.
Step 5  In the Identity Group field, click Select to choose a user group to assign the user to.
Step 6  Click Submit.

Create an Authorization Profile for RADIUS in Cisco ACS

You create authorization profiles to define how different types of users are authorized to access the network. For example, you can define that a user attempting to access the network over a VPN connection is treated more strictly than a user attempting to access the network through a wired connection.

When you create an authorization profile for device administration, you must add the RADIUS custom attributes that are associated with user roles, tasks, and virtual domains created in Cisco EPN Manager.

For RADIUS, you can add the user role attributes without adding the task attributes. The tasks are automatically added with the user roles.

For more information about Cisco ACS authorization profiles and policies, see chapters on managing policy elements and access policies in the User Guide for Cisco Secure Access Control System.

To create an authorization profile for RADIUS in Cisco ACS:

Before you begin

Make sure you have the complete list of the following Cisco EPN Manager custom attributes for RADIUS. You will need to add this information to Cisco ACS in this procedure.
Create an Authorization Profile for TACACS+ in Cisco ACS

When you create an authorization profile for device administration, you must add the TACACS+ custom attributes that are associated with user roles and virtual domains created in Cisco EPN Manager.

For TACACS+, you need not add the attributes for user tasks. They are automatically added based on the user roles.

For more information about Cisco ACS authorization profiles and policies, see chapters on managing policy elements and access policies in the User Guide for Cisco Secure Access Control System.

To create an authorization profile for TACACS+ in Cisco ACS:

**Before you begin**

Make sure you have the complete list of the following Cisco EPN Manager custom attributes. You will need to add this information to Cisco ACS in this procedure.

- Cisco EPN Manager user roles and tasks—see Export the Cisco EPN Manager User Group and Role Attributes for RADIUS and TACACS+, on page 752
- Cisco EPN Manager virtual domains—see Export the Cisco EPN Manager Virtual Domain Attributes for RADIUS and TACACS+, on page 765.

**Step 1** Log in to Cisco ACS as the admin user.

**Step 2** From the left sidebar, choose Policy Elements > Authorizations and Permissions > Device Administration > Shell Profiles.
Step 3  Click Create.
Step 4  On the General tab, enter the name and description of the authorization profile.
Step 5  Click the Custom Attributes tab, and paste in the complete list of TACACS+ custom attributes for:
   - User roles, including the tasks
   - Virtual domains
Step 6  Click Submit.

Create an Access Service for Cisco EPN Manager in Cisco ACS

Access services contain the authentication and authorization policies for access requests. You can create separate access services for different use cases; for example, device administration (TACACS+), network access (RADIUS), and so on.

When you create an access service in Cisco ACS, you define the type of policies and policy structures that it contains; for example, policies for device administration, network access, and so on.

Note
You must create access services before you define service selection rules, although you do not need to define the policies in the services.

To create an access service for Cisco EPN Manager requests:

Step 1  Log in to Cisco ACS as the admin user.
Step 2  From the left sidebar, choose Access Policies > Access Services.
Step 3  Click Create.
Step 4  Enter the name and description of the access service.
Step 5  Choose one of the following options to define a policy structure for the access service:
   - Based on service template—Creates an access service containing policies based on a predefined template.
   - Based on existing service—Creates an access service containing policies based on an existing access service. However, the new access service does not include the existing service's policy rules.
   - User selected service type—Provides you the option to select the access service type. The available options are Network Access (RADIUS), Device Administration (TACACS+), and External Proxy (External RADIUS or TACACS+ servers).
Step 6  Click Next.
Step 7  Choose the authentication protocols that are allowed for the access service.
Step 8  Click Finish.

Create an Authorization Policy Rule in Cisco ACS

Step 1  Log in to Cisco ACS as the admin user.
configure a service selection policy in cisco acs

a service selection policy determines which access service applies to an incoming request. for example, you can configure a service selection policy to apply the device administration access service to any access request that uses the tacacs+ protocol.

you can configure two types of service selection policy:

- simple service selection policy—applies the same access service to all requests.
- rule-based service selection policy—contains one or more conditions and a result, which is the access service that will be applied to an incoming request.

To configure a service selection policy:

step 1 log in to cisco acs as the admin user.
step 2 from the left sidebar, choose access policies > access services > service selection rules.
step 3 if you want to configure a simple service selection policy, click the single result selection radio button, and then choose an access service to apply to all requests.

alternatively, if you want to configure a rule-based service selection policy, click the rule based result selection radio button, and then click create.
step 4 enter the name of the rule and then choose the rule status.
step 5 choose either radius or tacacs+ as the protocol for the service selection policy.
step 6 configure the required compound condition, and then choose an access service to apply to an incoming request.
step 7 click ok, and then click save changes.

use sso with external authentication

to set up and use sso (with or without a radius or tacacs+ server), see these topics:

- add the sso server, on page 779
Configure SSO Mode on the Cisco EPN Manager Server, on page 779

Cisco EPN Manager does not support localization on the SSO sign-in page.

Add the SSO Server

If you have deployed Cisco EPN Manager in a high availability environment where you have a primary and backup server, refer to the instructions in Configure an SSO Server in an HA Environment, on page 817.

Cisco EPN Manager can be configured with a maximum of three AAA servers.

**Step 1** Choose Administration > Users > Users, Roles & AAA, then choose SSO Servers.

**Step 2** From the Select a command drop-down list, choose Add SSO Servers, then click Go.

**Step 3** Enter the SSO information. The maximum number of server retries for an SSO server authentication request is 3.

**Step 4** Click Save.

Configure SSO Mode on the Cisco EPN Manager Server

The SSO functionality distributes CA and self-signed certificate when the SSO server is added to the SSO client.

Cisco EPN Manager supports CA and self-signed certificates as long as the Common Name (CN) field of the certificate contains the Fully Qualified Domain Name (FQDN) of the server on both the SSO client and the SSO server. The server must be capable of name resolution from the IP address to the FQDN. In addition, the hostname must match the left-most component of the FQDN. SSO requires accurate DNS configuration. You must define the DNS with fully qualified domain name (FQDN). For example, the nslookup command and expected data when configuring DNS with FQDN is:

```
hostname CUSTOMER_HOSTNAME
nslookup CUSTOMER_HOSTNAME
Server:...
Address:...
Name: CUSTOMER_HOSTNAME.example.com
Address:....
```

For SSO operation, Cisco EPN Manager requires that the SSL/TLS certificate hold the FQDN in the CN field. To verify that the certificate used by your Cisco EPN Manager server has the FQDN in the CN field, use your browser to view the certificate. If the certificate does not contain the FQDN in the CN field, you must regenerate the certificate and redistribute it to all users that have the old certificate.

**Note** If you are using this procedure to configure SSO but are using local authentication, choose Local in Step 2.

**Step 1** Choose Administration > Users > Users, Roles & AAA, then choose SSO Server Settings.

**Step 2** Choose which SSO Server AAA Mode you want to use. You can select only one at a time.

**Step 3** Click OK.
Configure SSO Mode on the Cisco EPN Manager Server
CHAPTER 26

Fault Management Administration Tasks

Advanced users can also use the Cisco EPN Manager Representational State Transfer (REST) API to access device fault information. For information on the API, click at the at the top right of the Cisco EPN Manager window, then choose Help > API Help.

- Event Receiving, Forwarding, and Notifications, on page 781
- Configure Global Display and Search Settings for Acknowledged, Cleared, and Assigned Alarms, on page 784
- Change Event Severity Levels, on page 785
- Customize the Troubleshooting Text for an Alarm, on page 786
- Change Alarm Auto-Clear Intervals, on page 786
- Change the Information Displayed in the Failure Source for Alarms, on page 787
- Change the Behavior of Expedited Events, on page 787
- Customize Generic Events That Are Displayed in the Web GUI, on page 794
- Troubleshoot Fault Processing Errors, on page 795
- Get Help from the Cisco Support Community and Technical Assistance Center (TAC), on page 796

Event Receiving, Forwarding, and Notifications

Cisco EPN Manager processes syslogs and SNMPv1, v2, and v3 traps that it receives from devices. The server automatically listens for these events on UDP port 162. You do not have to perform any event listening configuration on the server, but you do have to configure devices to forward traps and syslogs to Cisco EPN Manager on the appropriate port.

Notifications are forwarded in SNMPv2 or SNMPv3 format. They are also forwarded to email recipients when you setup corresponding Notification Policies. If you are adding a notification receiver with the notification type UDP, the receiver you add should be listening to UDP on the same port on which it is configured. Only INFO level events are processed for the selected category and alarms are processed with critical, major, minor and warning levels.

Cisco EPN Manager can forward alarms and events that are generated by the processing of received syslogs, traps, and TL/1 alarms to northbound notification receiver. Alarms of any severity can be forwarded, but only events with INFO severity can be forwarded. Information can be forwarded in:

- E-Mail format. See Configure Default Settings for E-Mail Notifications, on page 783
• SNMP trap format. See Forward Alarms and Events as SNMP Trap Notifications, on page 783

You can also use the SNMP trap notification mechanism to forward SNMP traps that indicate server problems. Alerts and events are sent as SNMPv2.

Forward Alarms and Events as Email Notifications (Administrator Procedure)

When you configure an e-mail notification, e-mail is sent to the configured receivers when an alarm matching the criteria is created or updated. By default, the subject line includes the alarm severity and category. These settings, along with the message mode, are controlled from the system settings page for alarms and events. For more information, see Configure Default Settings for E-Mail Notifications, on page 783.

If you want to forward generic (unsupported) events, make sure generic event handling is enabled. (To check the setting, see Disable and Enable Generic Trap and Syslog Handling, on page 794.)

You can also forward alarms and events as SNMP trap notifications. For more information, see Forward Alarms and Events as SNMP Trap Notifications, on page 783.

Users can also configure email notifications from the Alarms and Events page. Users are allowed to pick the event and severity, and specify a receiver's email address.

Before you begin

If you have not configured the mail server, perform the instructions in Set Up the SMTP E-Mail Server, on page 717. Otherwise notifications will not be sent.

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Choose Administration &gt; Settings &gt; System Settings, then choose Mail and Notification &gt; Mail Server Configuration.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>In the Sender and Receivers area, add the receivers. You can specify multiple recipients as a comma-separated list.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>To forward alarms from specific categories to:</th>
<th>Do the following:</th>
</tr>
</thead>
<tbody>
<tr>
<td>The same receivers</td>
<td>1. Enter the receiver(s) in the To field. Specify multiple receivers in a comma-separated list.</td>
</tr>
<tr>
<td></td>
<td>2. Click the Configure email notification for individual alarm categories hyperlink and specify the data for the notification:</td>
</tr>
<tr>
<td></td>
<td>• Choose the alarms you want to include.</td>
</tr>
<tr>
<td></td>
<td>Note If you are forwarding server internal SNMP traps, choose the System category.</td>
</tr>
<tr>
<td></td>
<td>• To specify alarms of specific severities, click the alarm name hyperlink, then choose the severities.</td>
</tr>
<tr>
<td></td>
<td>Note Do not enter any receiver e-mail addresses when you specify the alarm severities.</td>
</tr>
<tr>
<td></td>
<td>3. Click Save to save the alarm categories and their settings.</td>
</tr>
</tbody>
</table>
To different receivers

1. Do not enter any e-mail addresses in the To field.
2. Click the Configure email notification for individual alarm categories hyperlink.
   
   Note If you are forwarding server internal SNMP traps, choose the System category.
3. Select the alarms in which you are interested. You can specify the severities by clicking the alarm link and choosing Critical, Major, Minor, or Warning.
   
   Note If you are forwarding server internal SNMP traps, choose the System category.
4. Click Save to save the alarm categories and their settings.

Step 3 Click Test to send a test email using the parameters you configured. The results of the test operation appear on the same page. The test feature checks connectivity to both primary and secondary mail servers by sending an email with a "Cisco EPN Manager test email" subject line.

Step 4 Click Save to save the new notifications.

Configure Default Settings for E-Mail Notifications

If you have not configured the mail server, perform the instructions in Set Up the SMTP E-Mail Server, on page 717. Otherwise notifications will not be sent.

You can configure certain default settings that are applied across all alarm and event e-mail notifications. These settings can be overwritten when users configure individual notifications and receivers.

By default, the email subject line will include the alarm severity and category. The following settings are also available but are disabled by default.

- Subject line—Include the prior alarm severity or add custom text. Alternatively you can replace all of the subject line with custom text.
- Body of the email—Include custom text, the alarm condition, and a link to the alarm detail page.
- Secure message mode—Enabling this mode masks the IP address and controller name.

To enable, disable, or adjust these settings, choose Administration > Settings > System Settings, then Alarms and Events > Alarms and Events. Make your changes in the Alarm Email Options area.

For information on configuring an e-mail notification, see Forward Alarms and Events as Email Notifications (Administrator Procedure), on page 782.

Forward Alarms and Events as SNMP Trap Notifications

Cisco EPN Manager can forward alarms and events in EPM-NOTIFICATION-MIB format as an SNMPv2c and SNMPv3 trap notifications. You can specify:

- A specific alarm or event category, such as System for internal server SNMP traps.
- Alarms of a specific severity. Only INFO events are forwarded; you cannot specify other severities for events.

Before a notification is sent, Cisco EPN Manager pings the receiver to ensure it can be reached. If it does not respond, an alarm is generated to notify that the device is unreachable.
Configure Global Display and Search Settings for Acknowledged, Cleared, and Assigned Alarms

The following table lists some display options for acknowledged, cleared, and assigned alarms. These settings cannot be adjusted by individual users (in their display preferences) because, for very large systems, a user could make a change that will impact system performance.

---

Note: Cisco EPN Manager sends traps to notification receivers on port 162.

You can also forward alarms and events as email notifications. For more information, see Forward Alarms and Events as Email Notifications (Administrator Procedure), on page 782.

**Step 1**  As a user with Admin privileges, choose **Administration > Settings > System Settings**, then choose **Alarms and Events > Notification Receivers**.

**Step 2**  Select **Add Notification Receiver** from the **Select a command** drop-down list, then click **Go**.

**Step 3**  Configure the new notification receiver.

a)  Provide the IP address and server name.

   - **IP Address**—Enter the IPv4 or IPv6 address of the server on which the receiver will run.
   - **Server Name**—Enter the host name of the server on which the receiver will run.

b)  Click the **North Bound** radio button. The notification type defaults to UDP.

c)  Enter the port number and SNMP version. The receiver that you configure should be listening to UDP on the same port that is configured.

   **Note**  Do not change the port number.

   - For SNMPv2c, enter the community string.
   - For SNMPv3, enter the username and password (the Engine ID is auto-populated), then select a mode from the Mode drop-down list (depending on the security level).

**Step 4**  Specify the category and (for alarms) severity of the alarms and events you want to forward.

   **Note**  Generic events will only be forwarded if generic event handling is enabled. To check the setting, see Disable and Enable Generic Trap and Syslog Handling, on page 794.

   - Under **Category**, check all alarm types to be forwarded. If you are forwarding server internal SNMP traps, choose System.
   - Under **Severity**, select the highest Severity Level that you set when you configured the trap notifications themselves.

**Step 5**  When you are finished, click **Save**.
Other settings shown on the Alarms and Events page can be adjusted by users, but you can set the global defaults here. For information on those settings, see these topics:

- **Configure Default Settings for E-Mail Notifications**, on page 783
- **Alarm, Event, and Syslog Purging**, on page 739

---

**Step 1**
Choose **Administration > Settings > System Settings**, then choose **Alarms and Events > Alarms and Events**.

**Step 2**
Under the Alarm Display Options area, enable or disable these settings, as desired:

<table>
<thead>
<tr>
<th>Alarm Display Options</th>
<th>Description</th>
<th>Does setting also affect search results?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide acknowledged alarms</td>
<td>Do not display Acknowledged alarms in the Alarms list or include them in search results</td>
<td>Yes</td>
</tr>
<tr>
<td>Hide assigned alarms</td>
<td>Do not display assigned alarms in the Alarms list or in search results</td>
<td>Yes</td>
</tr>
<tr>
<td>Hide cleared alarms in alarm browser</td>
<td>Do not display cleared alarms in the Alarms list or in search results</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Cleared alarms remain viewable under the <strong>Cleared Alarms</strong> tab.</td>
<td></td>
</tr>
<tr>
<td>Add device name to alarm messages</td>
<td>Include device name in e-mail notifications</td>
<td>No</td>
</tr>
</tbody>
</table>

**Step 3**
To apply your changes, click **Save** at the bottom of the Alarms and Events window.

---

**Change Event Severity Levels**

Each alarm in Cisco EPN Manager has a severity. The alarm severity is determined by the most severe event associated to the alarm. You can adjust the severity for alarms by changing the severity for newly-generated events.

**Note**
For alarms that are related to Cisco EPN Manager system administration, such as high availability, refer to **Customize Server Internal SNMP Traps and Forward the Traps**, on page 724.

You can change the severity level for network- and device-level alarms in two ways:

- Threshold-crossing alarms generated by optical, Carrier Ethernet, device health, or interface health monitoring policies—Change the settings in the relevant monitoring policy. See **Change Thresholds and Alarm Behavior for a Monitoring Policy**, on page 215.
- Specific alarms—Use the procedure in this section.

**Step 1**
Choose **Administration > System Settings**, then choose **Alarms and Events > Alarm Severity and Auto Clear**.
Customize the Troubleshooting Text for an Alarm

You can associate troubleshooting and explanatory information with an alarm so that users with access to the Alarms and Events tables will be able to see it. Use this procedure to add or change the information that is displayed in the popup window.

Step 1 Choose Administration > Settings > System Settings, then choose Alarms and Events > Alarm Severity and Auto Clear.
Step 2 Select an alarm, then click Recommended Action.
Step 3 Add or change the content in the Explanation and Recommended Actions fields, then click Save. To revert to the default text, click Reset and Save.

Change Alarm Auto-Clear Intervals

You can configure an alarm to auto-clear after a specific period of time. This is helpful in cases, for example, where there is no clearing event. Auto-clearing an alarm will not change the severity of the alarm's correlated events.

Step 1 Choose Administration > Settings > System Settings, then choose Alarms and Events > Alarm Severity and Auto Clear.
Step 2 Expand the categories available under the Event Types column, or search for the event type you want by entering all or part of the event text in the Event Types search field just below the column heading.
Step 3 To change the auto-clear duration for an event or group of events:
   • For a single event, check the event's check box, click in the Auto Clear Duration field, enter the new duration, then click Save.
   • For multiple events, select the events, then click Alarm Auto Clear, enter the new duration in the dialog box, then click OK.
Step 4 Change the Auto Clear Interval by performing one of the following tasks:
   • Click on the Auto Clear Duration field, enter the new interval, and click Save.
   • Select the check box of the event type, click Alarm Auto Clear, enter the new interval, and click OK.
The **Alarm Auto Clear** button is enabled only for the events that do not have an auto-clear event configured.

---

**Change the Information Displayed in the Failure Source for Alarms**

When an alarm is generated, it includes information about the source of the failure. Information is presented using a specific format. For example, performance failures use the format `MACAddress:SlotID`. Failure sources for other alarms may include the host name, IP address, or other properties. Adjust the properties and separators (a colon, dash, or number sign) that are displayed in the alarm's failure source using the following procedure.

**Step 1** Choose Administration > Settings > System Settings, then choose Alarms and Events > Alarms and Events.

**Step 2** In the Failure Source Pattern area, select the alarm category you want to customize.

**Step 3** Adjust the failure source format as follows:

- To customize the properties that are displayed, click **Edit**, select the properties, then click **OK**. If a property is greyed-out, you cannot remove it.

- To customize the separators that are displayed between the properties, click **Edit Separator**.

**Step 4** To apply your changes, click **Save** at the bottom of the Alarms and Events settings window.

---

**Change the Behavior of Expedited Events**

When Cisco EPN Manager receives a configuration change event from a device, it waits for a certain time interval before starting inventory collection, in case other related events are sent. This prevents multiple collection processes from running at the same time. This is called the **inventory collection hold off time** and is set to 10 minutes by default. This setting is controlled from the Inventory system settings page (Administration > Settings > System Settings > Inventory).

The following events are processed by Cisco EPN Manager within the default time interval of 10 minutes:

<table>
<thead>
<tr>
<th>Type</th>
<th>Supported Events</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link</td>
<td>LINK-3-UPDOWN</td>
</tr>
<tr>
<td>Card Protection</td>
<td>CARD_PROTECTION-4-PROTECTION</td>
</tr>
<tr>
<td></td>
<td>CARD_PROTECTION-4-ACTIVE</td>
</tr>
<tr>
<td>VLAN</td>
<td>PORT_SECURITY-6-VLAN_REMOVED</td>
</tr>
<tr>
<td></td>
<td>PORT_SECURITY-6-VLAN_FULL</td>
</tr>
<tr>
<td>Type</td>
<td>Supported Events</td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ICCP SM</td>
<td>L2-L2VPN_ICCP_SM-4-REMOTE_CORE_ISOLATION</td>
</tr>
<tr>
<td></td>
<td>L2-L2VPN_ICCP_SM-4-REMOTE_CORE_ISOLATION_CLEAR</td>
</tr>
<tr>
<td></td>
<td>L2-L2VPN_ICCP_SM-3-CONFIG_LOCAL_ERROR</td>
</tr>
<tr>
<td></td>
<td>L2-L2VPN_ICCP_SM-3-CONFIG_REMOTE_ERROR</td>
</tr>
<tr>
<td></td>
<td>L2-L2VPN_ICCP_SM-4-LOCAL_CORE_ISOLATION</td>
</tr>
<tr>
<td></td>
<td>L2-L2VPN_ICCP_SM-4-LOCAL_CORE_ISOLATION_CLEAR</td>
</tr>
<tr>
<td></td>
<td>L2-L2VPN_ICCP_SM-4-PEER_REACHABILITY_FAILURE</td>
</tr>
<tr>
<td></td>
<td>L2-L2VPN_ICCP_SM-4-PEER_REACHABILITY_CLEAR</td>
</tr>
<tr>
<td></td>
<td>L2-L2VPN_ICCP_SM-4-REMOTE_ACCESS_MAIN_PORT_FAILURE</td>
</tr>
<tr>
<td></td>
<td>L2-L2VPN_ICCP_SM-4-REMOTE_ACCESS_MAIN_PORT_FAILURE_CLEAR</td>
</tr>
<tr>
<td></td>
<td>INFRA-ICCP-5-ISOLATION</td>
</tr>
<tr>
<td></td>
<td>INFRA-ICCP-5-ISOLATION_CLR</td>
</tr>
<tr>
<td></td>
<td>INFRA-ICCP-5-NEIGHBOR_STATE_UP</td>
</tr>
<tr>
<td></td>
<td>INFRA-ICCP-5-NEIGHBOR_STATE_DOWN</td>
</tr>
<tr>
<td></td>
<td>INFRA-ICCP-6-BACKBONE_INTERFACE_STATE_UP</td>
</tr>
<tr>
<td></td>
<td>INFRA-ICCP-6-BACKBONE_INTERFACE_STATE_DOWN</td>
</tr>
<tr>
<td></td>
<td>L2-BM-6-ACTIVE_CLEAR</td>
</tr>
<tr>
<td></td>
<td>L2-BM-6-ACTIVE_PROBLEM</td>
</tr>
<tr>
<td></td>
<td>L2-L2VPN_ICCP_SM-3-CONFIG_INVALID_NODEID</td>
</tr>
<tr>
<td></td>
<td>L2-L2VPN_ICCP_SM-3-CONFIG_INVALID_NODEID_CLEAR</td>
</tr>
<tr>
<td>Satellite</td>
<td>PKT_INFRA-ICPE_GCO-5-SATELLITE_STATUS_PROBLEM</td>
</tr>
<tr>
<td></td>
<td>PKT_INFRA-ICPE_GCO-5-SATELLITE_STATUS_CLEAR</td>
</tr>
<tr>
<td>Cluster</td>
<td>PLATFORM-REDDRV-7-ROLE_CHANGE</td>
</tr>
<tr>
<td></td>
<td>PLATFORM-CE_SWITCH-6-UPDN</td>
</tr>
<tr>
<td></td>
<td>PLATFORM-CLUSTER_CLM-6-UPDN</td>
</tr>
<tr>
<td></td>
<td>LINK_UP</td>
</tr>
<tr>
<td></td>
<td>LINK_DOWN</td>
</tr>
<tr>
<td>Celeborn cards</td>
<td>UEA_SPA_MODE-6-UEA_SPA_MODE_CHG</td>
</tr>
<tr>
<td>Configuration Commit</td>
<td>MGBL-CONFIG-6-DB_COMMIT</td>
</tr>
<tr>
<td>sylogs</td>
<td>SYS-5-CONFIG_I</td>
</tr>
</tbody>
</table>

However, in case of the following critical events, Cisco EPN Manager performs a full discovery of the device immediately when the event occurs:

SYS-5-RELOAD
SYS-5-RESTART
OIR-6-INSCARD
OIR-SP-6-INSCARD
SWT_CEF_C_STATUS_CHANGE
cfcFURRemoved
cfcFURIInserted

**Granular Inventory Event Rate Flow Controller**

Granular inventory identifies the events generated, and processes only the changes made in the devices. To avoid continuous syncing of devices due to event inflow, granular inventory uses the Burst Event rate flow controller.

When there are 100 or more instances of the same event, Cisco EPN Manager considers it as a Burst event. In this scenario, the inventory sync of the events breaching the threshold is held for a certain time period, and the threshold is recalculated again at intervals. After the permitted number of recalculations, if the threshold is still breached, Cisco EPN Manager stops all the processing to the device, and this can be resolved only when the user performs the relevant action to resolve the issue causing the Burst event.
Cisco EPN Manager has multiple rules file that are stored in /opt/CSCOlumos/conf/fault/correlationEngine. Event settings are controlled by the files that end in the string EventBasedInventoryRules.xml.

The following Burst event action properties can be configured:

**Table 58: Burst Event Action**

<table>
<thead>
<tr>
<th>Property Name</th>
<th>Description</th>
<th>Default value</th>
</tr>
</thead>
<tbody>
<tr>
<td>BurstThreshold</td>
<td>The number of events of a given type at a particular time, which is considered as the ‘burst’ of that event.</td>
<td>100</td>
</tr>
<tr>
<td>BurstHoldOffTimer</td>
<td>The time period for which the inventory sync is withheld</td>
<td>300000 ms</td>
</tr>
<tr>
<td>BurstCheckRetryCount</td>
<td>The permitted number of recalculations</td>
<td>3</td>
</tr>
</tbody>
</table>

System alarms (in Monitor > Monitoring Tools > Alarms and Events page) will notify users about the burst mode, and user can take the appropriate action. Once the event inflow issue is resolved, the alarm is cleared and can be viewed in the ‘Cleared Alarms’ tab. The active alarm information is also available in the device 360 page.

Here is the list of events that are monitored for burst mode:

**Table 59: Burst mode - supported events**

<table>
<thead>
<tr>
<th>Technology</th>
<th>Supported Events</th>
</tr>
</thead>
<tbody>
<tr>
<td>MPLS</td>
<td>MPLS_TE-5-LSP_Down&lt;br&gt;mplsLdpSessionDown&lt;br&gt;mplsLdpSessionUp&lt;br&gt;MPLS_TE-5-LSP_Active_StandBy&lt;br&gt;MPLS_TE-5-LSP_CLEAR&lt;br&gt;ROUTING-MPLS_TE-5-LSP_UPDOWN&lt;br&gt;ROUTING-MPLS_TE-5-S2L_SIGNALLING_STATE</td>
</tr>
<tr>
<td>Pseudowire</td>
<td>cpwVcUp&lt;br&gt;cpwVcDown&lt;br&gt;L2-L2VPN_PW-3-UPDOWN&lt;br&gt;L2-L2VPN_PW-3-UPDOWN_Clear&lt;br&gt;XCONNECT-5-PW_STATUS&lt;br&gt;XCONNECT-5-PW_STATUS_Clear&lt;br&gt;EVPN-5-VC_STATUS&lt;br&gt;EVPN-5-VC_STATUS_Clear</td>
</tr>
<tr>
<td>LDP</td>
<td>mplsLdpSessionDown&lt;br&gt;mplsLdpSessionUp</td>
</tr>
<tr>
<td>Technology</td>
<td>Supported Events</td>
</tr>
<tr>
<td>------------</td>
<td>------------------</td>
</tr>
</tbody>
</table>
| BGP        | cbgpBackwardTransition  
             | cbgpFsmStateChange  
             | cbgpPrefixThresholdExceeded  
             | cbgpPrefixThresholdClear  
             | bgpBackwardTransition  
             | bgpEstablished  
             | cbgpPeer2BackwardTransition  
             | cbgpPeer2FsmStateChange  
             | cbgpPeer2PrefixThresholdClear  
             | cbgpPeer2PrefixThresholdExceeded  
             | BGP-5-ADJCHANGE  
             | BGP-5-ADJCHANGE_DOWN  
             | BGP-5-ADJCHANGE_UP  
             | BGP-3-NOTIFICATION  
             | ROUTING-BGP-5-ADJCHANGE  
             | ROUTING-BGP-5-UPDATEFILTERED |
| ISIS       | CLNS-5-ADJCHANGE  
             | CLNS-5-ADJCHANGE_UP  
             | CLNS-5-ADJCHANGE_DOWN  
             | ROUTING-ISIS-5-ADJCHANGE  
             | ROUTING-ISIS-5-ADJCHANGE_UP  
             | ROUTING-ISIS-5-ADJCHANGE_DOWN  
             | ROUTING-ISIS-4-ADJCHANGE  
             | ROUTING-ISIS-4-ADJCHANGE_UP  
             | ROUTING-ISIS-4-ADJCHANGE_DOWN  
             | isisAdjacencyChange  
             | isisAdjacencyChangeDown  
             | isisAdjacencyChangeUp  
             | isisAdjacencyChangeInit |
| OSPF       | OSPF-5-ADJCHG  
             | OSPF-5-ADJCHG_DOWN  
             | OSPF-5-ADJCHG_UP  
             | OSPFv3-5-ADJCHG  
             | OSPFv3-5-ADJCHG_DOWN  
             | OSPFv3-5-ADJCHG_UP  
             | ROUTING-OSPF-5-ADJCHG  
             | ROUTING-OSPFv3-5-ADJCHG  
             | ROUTING-OSPFv3-5-ADJCHG_DOWN  
             | ROUTING-OSPFv3-5-ADJCHG_UP |

You do not have to restart Cisco EPN Manager after editing the rules file. The change takes effect from when you save the rules file.

The following events are not monitored for Burst mode and are processed normally by the granular inventory:

G8032:  
G8032-STATE_IDLE  
G8032-STATE_PENDING  
G8032-STATE_PROTECTION  
G8032-STATE_FORCED_SWITCH  
G8032-STATE_MANUAL_SWITCH  
L2-G8032-3-APSCHANNEL_INACTIVE  
L2-G8032-6-APSCHANNEL_ACTIVE  
CEM:  
SONET-4-ALARM_SLOS
Administer the Cisco EPN Manager System

Granular Inventory Event Rate Flow Controller

SONET-4-ALARM_SLOS_Clear
SONET-4-ALARM_SLOF
SONET-4-ALARM_SLOF_Clear
SONET-4-ALARM_LAIS
SONET-4-ALARM_LAIS_Clear
SONET-4-ALARM_LBDI
SONET-4-ALARM_LBDI_Clear
SONET-4-ALARM_PAIS
SONET-4-ALARM_PAIS_Clear
SONET-4-ALARM_PLOF
SONET-4-ALARM_PLOF_Clear
SONET-4-ALARM_PUNEQ
SONET-4-ALARM_PUNEQ_Clear
SONET-4-ALARM_PPLM
SONET-4-ALARM_PPLM_Clear
SONET-4-ALARM_PDI
SONET-4-ALARM_PDI_Clear
SONET-4-ALARM_LOM
SONET-4-ALARM_LOM_Clear
SONET-4-ALARM_B1-TCA
SONET-4-ALARM_B1-TCA_Clear
SONET-4-ALARM_B2-TCA
SONET-4-ALARM_B2-TCA_Clear
SONET-4-ALARM_B3-TCA
SONET-4-ALARM_B3-TCA_Clear
SONET-4-ALARM_APS
SONET-4-ALARM_APS_Clear
SONET-4-UPSR_Working
SONET-4-UPSR_Working_Clear
SONET-4-UPSR_Protect
SONET-4-UPSR_Protect_Clear
CONTROLLER-5-UPDOWN_Clear
CONTROLLER-5-UPDOWN
dsx1LoopbackState
dsx1LoopbackState_CLEAR
dsx1RcvAIS
dsx1RcvAIS_CLEAR
dsx3RcvAIS
dsx3RcvAIS_CLEAR
dsx3LOS
dsx3LOS_CLEAR
dsx3LoopbackState
dsx3LoopbackState_CLEAR
dsx1LossOfSignal
dsx1LossOfSignal_CLEAR
SONET-4-ALARM_VT_TRACE_MISMATCH
SONET-4-ALARM_VT_TRACE_MISMATCH_Clear
SONET-4-ALARM_VT_PATH_LOP
SONET-4-ALARM_VT_PATH_LOP_Clear
SONET-4-ALARM_VT_UNEQUIPPED
SONET-4-ALARM_VT_UNEQUIPPED_Clear
SONET-4-ALARM_VT_PATH_RDI
SONET-4-ALARM_VT_PATH_RDI_Clear
CONTROLLER-5-UPDOWN_VT_PATHAIS
CONTROLLER-5-UPDOWN_VT_PATHAIS_Clear
CONTROLLER-5-UPDOWN_VT_PATHL0P
CONTROLLER-5-UPDOWN_VT_PATHL0P_Clear
CONTROLLER-5-UPDOWN_VT_UNEQUIPPED
CONTROLLER-5-UPDOWN_VT_UNEQUIPPED_Clear
CONTROLLER-4-ACR_DCR_CLOCK_DS1
CONTROLLER-4-ACR_DCR_CLOCK_DS3
CONTROLLER-4-ACR_DCR_CLOCK_DS3_CHANNEL
CONTROLLER-4-ACR_DCR_CLOCK_OCN_VT
CONTROLLER-4-ACR_DCR_CLOCK_OCN_CT3
CONTROLLER-4-ACR_DCR_CLOCK_OCN_T3
CONTROLLER-4-ACR_DCR_CLOCK_DS3_CHANNEL_FREERUN
CONTROLLER-4-ACR_DCR_CLOCK_DS3_CHANNEL_ACQUIRING
CONTROLLER-4-ACR_DCR_CLOCK_OCN_VT_FREERUN
CONTROLLER-4-ACR_DCR_CLOCK_OCN_VT_ACQUIRING
CONTROLLER-4-ACR_DCR_CLOCK_OCN_T3_FREERUN
CONTROLLER-4-ACR_DCR_CLOCK_OCN_T3_ACQUIRING
CONTROLLER-4-ACR_DCR_CLOCK_OCN_T3_ACQUIRED
CONTROLLER-4-ACR_DCR_CLOCK_OCN_T3_HOLDOVER
SONET-4-UPSR
DSX-ALARM_DS1_LOS
DSX-ALARM_DS1_LINK_DOWN
DSX-ALARM_DS1_AIS
DSX-ALARM_DS1_RAI
DSX-ALARM_DS1_LOF
DSX-ALARM_DS1_RX_LOMF
DSX-ALARM_DS3_RX_RAI
DSX-ALARM_DS3_TX_RAI
DSX-ALARM_DS3_RX_AIS
DSX-ALARM_DS3_TX_AIS
DSX-ALARM_DS3_RX_LOF
DSX-ALARM_DS3_RX_LOS
DSX-ALARM_DS3_RX_IDLE
DSX-ALARM_DS3_CHANNEL_FREERUN
DSX-ALARM_DS3_CHANNEL_ACQUIRING
DSX-ALARM_DS3_CHANNEL_HOLDOVER
DSX-ALARM_DS1_OOF
SDH-ALARM_DS3_RX_AIS
SDH-ALARM_DS3_RX_AIS_Clear
SDH-ALARM_DS3_RX_LOF
SDH-ALARM_DS3_RX_LOF_Clear
SDH-ALARM_DS3_RX_LOS
SDH-ALARM_DS3_RX_LOS_Clear
SDH-ALARM_DS3_RX_IDLE
SDH-ALARM_DS3_RX_IDLE_Clear
SDH-ALARM_LO_PAIS
SDH-ALARM_LO_PAIS_Clear
SDH-ALARM_LO_PLOP
SDH-ALARM_LO_PLOP_Clear
SDH-ALARM_LO_PTIM
SDH-ALARM_LO_PTIM_Clear
SDH-ALARM_LO_PUNEQ
SDH-ALARM_LO_PUNEQ_Clear
SDH-ALARM_LO_PPLM
SDH-ALARM_LO_PPLM_Clear
SDH-ALARM_LO_PRDI
SDH-ALARM_LO_PRDI_Clear
Customize Generic Events That Are Displayed in the Web GUI

You can customize the description and severity for generic events generated by SNMP traps and syslogs. Your customization will be displayed in the Events tab for SNMP trap events. If a MIB module is not loaded, you can load it manually and then customize the notifications provided in that MIB.

See Customize Generic Events Based on SNMP Traps, on page 795, for information on how to customize these generic events.

Disable and Enable Generic Trap and Syslog Handling

By default Cisco EPN Manager does not drop any received syslog or traps. As mentioned in How are Alarms and Events Created and Updated?, on page 226, Cisco EPN Manager maintains an event catalog that determines whether Cisco EPN Manager should create a new event for incoming syslog or traps (and if it creates a new event, whether it should also create an alarm). If Cisco EPN Manager does not create an event, the trap or syslog is considered a generic event.

By default, Cisco EPN Manager does the following:

- Displays the generic events in the Events list.
- Forwards generic events in e-mail or SNMP trap notifications, after normalizing them using CISCO-EPM-NOTIFICATION-MIB. For more information, refer to the CISCO-EPM-NOTIFICATION-MIB section in the guide.

All of these events are assigned the MINOR severity, regardless of the trap contents, and fall under the alarm category Generic.

Disable and Enable Generic Trap Processing

Use the genericTrap.sh command to manage generic syslogs.

<table>
<thead>
<tr>
<th>To do the following:</th>
<th>Use this command:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Turn off generic trap processing</td>
<td>/opt/CSCOlumos/bin/genericTrap.sh -l</td>
</tr>
</tbody>
</table>
Customize Generic Events Based on SNMP Traps

Cisco EPN Manager supports the customized representation of generic events in the GUI. Managed objects normally generate SNMP traps and notifications that contain an SNMP trap object identifier (SnmpTrapOID) and a variable bind object identifier (VarBindOIDs) in numerical format. Cisco EPN Manager translates the numeric SnmpTrapOIDs and VarBindOIDs into meaningful names using customized MIB modules, then displays the generic events in the web GUI (in the event tables, Device 360 view, and so forth). For more details on Generic Events see How are Alarms and Events Created and Updated?, on page 226.

Using the SNMP MIB files that are packaged with Cisco EPN Manager, you can customize the defined MIBs for your deployment's technology requirement.

The following table illustrates how ObjectIDs are decoded and displayed in the GUI.

### Table 60: Example: ObjectID Representation

<table>
<thead>
<tr>
<th>OIDs before Decoding</th>
<th>OIDs after Decoding</th>
</tr>
</thead>
<tbody>
<tr>
<td>snmpTrapOID = 1.3.6.1.4.1.9.10.120.0.1, Values: 1.3.6.1.4.1.9.10.119.1.1.2.1.11.7.1 = 1</td>
<td>mplsL3VpnVrfDown, values: mplsL3VpnVrfOperStatus(&quot;vrf1&quot;).(1) = 1</td>
</tr>
</tbody>
</table>

Follow the steps below to create customized generic events.

**Step 1**  Select **Monitor > Monitoring Tools > Alarms and Events**.

**Step 2**  Click the **Events** tab.

**Step 3**  Click **Custom Trap Events** and then click **Upload New Mibs**.

**Step 4**  In the **Upload Mib** window, click **Upload New MIB** to upload a MIB file.

**Step 5**  If you upload a new MIB file, wait until the file upload is complete, and then click **Refresh MIBs** to have the newly added MIB included in the **MIB** drop-down list.

**Step 6**  Click **OK**.

ciscoEPNManager creates a new event type and alarm condition for the specified trap.

Troubleshoot Fault Processing Errors

If your deployment is having fault processing problems, follow this procedure to check the fault logs.

**Step 1**  Log in to Cisco EPN Manager with a user ID that has Administrator privileges.

**Step 2**  Select **Administration > Settings > Logging**, then choose **General Logging Options**.

**Step 3**  In the **Download Log File** area, click **Download**.
Step 4  
Compare the activity recorded in these log files with the activity you are seeing in your management application:

- console.log
- ncs-x-x.log
- decap.core.java.log
- xmp_correlation.log
- decap.processor.log

What to do next

You can also get help from the Cisco support community. If you do need to open a support case, attach the suspect log files with your case. See Get Help from the Cisco Support Community and Technical Assistance Center (TAC), on page 796.

Get Help from the Cisco Support Community and Technical Assistance Center (TAC)

- Open a Cisco Support Case, on page 796
- Join the Cisco Support Community, on page 797

Open a Cisco Support Case

When you open a support case from the web GUI, Cisco EPN Manager automatically populates the case form with information it can retrieve from a device. This includes technical details about the device, configuration changes on the device, and all device events that occurred in the last 24 hours. You can also attach your own files to the case.

Before you begin

You can open a support case from the web GUI if:

- Your administrator has configured Cisco EPN Manager to allow you to do so. See Set Up Defaults for Cisco Support Requests, on page 726.
- The Cisco EPN Manager server has a direct connection to the internet, or a connection by way of a proxy server.
- You have a Cisco.com username and password.

Step 1  
Choose one of the following:

- From Monitor > Monitoring Tools > Alarms and Events. Click a single alarm, then choose Troubleshoot > Support Case. If you do not see the Troubleshoot button, widen your browser window.
- From the Device 360 view. Hover your mouse over a device IP address, then click the information icon. Choose Support Request from the Actions drop-down menu.
### Administer the Cisco EPN Manager System

#### Step 2
Enter your Cisco.com username and password.

#### Step 3
Click **Create**. Cisco EPN Manager populates the form with data it retrieves from the device.

#### Step 4
(Optional) Enter a Tracking Number that corresponds to your own organization’s trouble ticket system.

#### Step 5
Click **Next** and enter a description of the problem.

Cisco EPN Manager populates the form with data it retrieves from the device and automatically generates the necessary supporting documents.

If desired, upload files from your local machine.

#### Step 6
Click **Create Service Request**.

---

### Join the Cisco Support Community

You can access and participate in discussion forums in the online Cisco Support Community. You will need a Cisco.com username and password.

#### Step 1
Choose one of the following:

- From **Monitor > Monitoring Tools > Alarms and Events**. Click a single alarm, then choose **Troubleshoot > Support Forum**. If you do not see the **Troubleshoot** button, widen your browser window.

- From the Device 360 view. Hover your mouse over a device IP address, then click the information icon. Choose **Support Community** from the **Actions** drop-down menu.

#### Step 2
In the Cisco Support Community Forum page, enter your search parameters to find what you need.
CHAPTER 27

Audits and Logs

- Audit Configuration Archive and Software Management Changes (Network Audit), on page 799
- Audit Changes Made By Users (Change Audit), on page 799
- Audit Actions Executed from the GUI (System Audit), on page 801
- System Logs, on page 801
- Synchronize System logs to an External Location, on page 804
- Security Log, on page 805

Audit Configuration Archive and Software Management Changes (Network Audit)

The Network Audit window displays changes made to devices using the Configuration Archive and Software Management features. To view these changes, choose Inventory > Device Management > Network Audit. Cisco EPN Manager lists the most recent devices changes including the type of change (Configuration Archive, Software Image Management). For examples, see:

- Check the Network Audit for Configuration Archive Operations, on page 108
- Check the Network Audit for Software Image Operations, on page 134

You can also view the most recent changes for a device in the Recent Changes tab of its Device 360 view. See Get Basic Device Information: Device 360 View, on page 69.

Audit Changes Made By Users (Change Audit)

Cisco EPN Manager supports managing change audit data in the following ways:

Generate a Change Audit Report

The Change Audit report lists the actions that users have performed using the Cisco EPN Manager features. The following table provides examples of what may appear in a Change Audit report.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device management</td>
<td>Device '209.165.202.159' Added</td>
</tr>
</tbody>
</table>
### Enable Change Audit Notifications and Configure Syslog Receivers

If desired, you can configure Cisco EPN Manager to send a change audit notification when changes are made to the system. These changes include device inventory and configuration changes, configuration template and monitoring template operations, and user operations such as logins and logouts and user account changes.

You can configure Cisco EPN Manager to:

- Forward changes as change audit notifications to a Java Message Server (JMS).
- Send these messages to specific syslog receivers.

If you configure syslog receivers but do not receive syslog settings on the destination syslog receiver to permit reception of syslog messages.

#### Step 1
Select **Administration > Settings > System Settings**, then choose **Mail and Notification > Change Audit Notification**.
Step 2  Select the Enable Change Audit Notification check box to enable notifications.

Step 3  If you want to send the messages to specific syslog receivers:
   a) Click the Add button (+) to specify a syslog receiver.
   b) In the Syslog Receivers area, enter the IP address, protocol, and port number of the syslog receiver.

You can repeat these steps as needed to specify additional syslog receivers.

Step 4  Click Save.

Note  It is recommended to restart the Cisco EPN Manager server for the records to be reflected in secure tls log.

### Audit Actions Executed from the GUI (System Audit)

Cisco EPN Manager sends all change audit notifications in XML format to the topic ChangeAudit.All. You must be subscribed to ChangeAudit.All to receive the notifications.

The System Audit window lists all Cisco EPN Manager GUI pages that users have accessed. To view a System Audit, choose Administration > Settings > System Audit.

The following table shows some of the information you can find from the System Audit page using the quick filter. To enable the quick filter, choose Quick Filter from the Show drop-down list.

<table>
<thead>
<tr>
<th>Find actions performed:</th>
<th>Do the following:</th>
</tr>
</thead>
<tbody>
<tr>
<td>By a specific user</td>
<td>Enter the username in the Username quick filter field</td>
</tr>
<tr>
<td>By all users in a user group</td>
<td>Enter the group name in the User Group quick filter field</td>
</tr>
<tr>
<td>On devices in a specific virtual domain</td>
<td>Enter the virtual domain name in the Active Virtual Domain quick filter field</td>
</tr>
<tr>
<td>By the web GUI root user</td>
<td>Select Root User Logs from the Show drop-down list</td>
</tr>
<tr>
<td>On a specific device</td>
<td>Enter the IP address in the IP Address quick filter field</td>
</tr>
<tr>
<td>On a specific day</td>
<td>Enter the day in the Audit Time quick filter filed (in the format yyyy–mmm–dd)</td>
</tr>
</tbody>
</table>

### System Logs

Cisco EPN Manager provides three classes of logs which are controlled by choosing Administration > Settings > Logging.
**View and Manage General System Logs**

You can view system logs after downloading them to your local server.

**View the Logs for a Specific Job**

**Step 1** Choose Administration > Dashboards > Job Dashboard.

**Step 2** Choose a job type from the Jobs pane, then select a job instance from the Jobs window.

**Step 3** At the top left of the Job instance window, locate the Logs field, then click Download.

**Step 4** Open or save the file as needed.

**Adjust General Log File Settings and Default Sizes**

By default, Cisco EPN Manager logs all error, informational, and trace messages generated by all managed devices. It also logs all SNMP messages and Syslogs that it receives. You can adjust these settings, changing logging levels for debugging purposes.

<table>
<thead>
<tr>
<th>To do the following:</th>
<th>From Administration &gt; Settings &gt; Logging:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the size of logs and the number of logs saved</td>
<td>Adjust the Log File Settings.</td>
</tr>
<tr>
<td></td>
<td>Note Change these settings with caution to avoid impacting the system.</td>
</tr>
<tr>
<td>Change the logging level for specific modules</td>
<td>In the General Log Settings, select the files and the desired level, and click Save. For example, from the Message Level drop-down list, choose one of the following as current logging level:</td>
</tr>
<tr>
<td></td>
<td>• Error—Captures error logs on the system.</td>
</tr>
<tr>
<td></td>
<td>• Information—Captures informational logs on the system.</td>
</tr>
<tr>
<td></td>
<td>• Trace—Reproduces problems of managed devices on the system so the details can be captured in the logs.</td>
</tr>
<tr>
<td></td>
<td>You will have to restart Cisco EPN Manager for the changes to take effect.</td>
</tr>
</tbody>
</table>
Download and E-Mail Log Files for Troubleshooting Purposes

<table>
<thead>
<tr>
<th>To do the following:</th>
<th>From Administration &gt; Settings &gt; Logging:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Download log files for troubleshooting purposes</td>
<td>In the Download Log File area, click <strong>Download</strong>.</td>
</tr>
<tr>
<td>E-mail log files (for example, to the Cisco Technical Center)</td>
<td>Enter a comma-separated list of e-mail IDs and click <strong>Send</strong>.</td>
</tr>
</tbody>
</table>

This procedure sets and log message levels to Trace. Be sure to return the log message levels to their original setting so system performance is not impacted.

**Step 1** Choose **Administration > Settings > Logging**, then choose **General Logging Options**.

**Step 2** Note the setting in the **Message Level** drop-down list because you will need to reset it later.

**Step 3** In the **Enable Log Modules** area, select the **Log Modules** check box to select all modules.

**Step 4** Select **Trace** from the **Message Level** drop-down list.

**Step 5** Click **Save**.

**Step 6** Reproduce the problem on the system so the details can be captured in the logs.

**Step 7** In the **Download Log File** area, click **Download**. The download zip file will have the name:

NCS-hostname-logs-yy-mm-dd-hh-mm-ss.

The file includes an HTML file that lists all files included in the zip file.

The information captured in the `ifm_da.log` and `ifm_sam.log` files are now split-up into the accompanying classes:

- `assurance_wirelessuser.log`
- `assurance_pfr.log`
- `assurance_netflow.log`
- `assurance_appclassifier.log`

The `ifm_da.log` file logs the information related to the Netflow devices and their respective pcaps, post device inclusion on Cisco EPN Manager. The `assurance_wirelessuser.log` file logs the information that is captured when the WirelessUser job runs to read the user data and populate in the memory caches that are added by WIRELESS_ASSURANCE. The `assurance_pfr.log` file stores the PfR monitoring related information. The `assurance_netflow.log` file logs the processing of incoming Netflow data being sent from various Netflow devices to Cisco EPN Manager. The `assurance_appclassifier.log` file stores the logs for NBAR classification on incoming AVC/Wireless Netflow data.

**Step 8** In the E-Mail Log File area, enter a comma-separated list of e-mail IDs.

**Step 9** Revert to the original setting in the **Message Level** drop-down list.
Forward System Audit Logs As Syslogs

**Before you begin**

To work with Forward System Audit Logs as Syslogs, the user must configure Enable Change Audit Notifications and Configure Syslog Receivers.

---

**Step 1** Choose Administration > Settings > Logging, then choose Syslog Logging Options.

**Step 2** Select the Enable Syslog check box to enable collecting and processing system logs.

**Step 3** In the Syslog Host field, enter the IP address of the interface from which the message is to be transmitted.

**Step 4** From the Syslog Facility drop-down list, choose any of the eight local use facilities for sending syslog messages. The local use facilities are not reserved and are available for general use.

**Step 5** Click Save.

---

Enable SNMP Traces and Adjust SNMP Log Settings (Levels, Size)

Enable SNMP tracing to access more detailed information about the packets sent and received through SNMP. You may want to do this when troubleshooting, such as when a trap is dropped.

To make the following changes, choose Administration > Settings > Logging, then choose SNMP Logging Options.

<table>
<thead>
<tr>
<th>If you want to:</th>
<th>Do the following:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable SNMP tracing on specific devices</td>
<td>In the SNMP Log Settings area:</td>
</tr>
<tr>
<td></td>
<td>1. Select the Enable SNMP Trace check box and the Display Values check boxes.</td>
</tr>
<tr>
<td></td>
<td>2. Enter the IP addresses of the devices you want to trace and click Save.</td>
</tr>
<tr>
<td>Change the size of logs and number of logs saved</td>
<td>In the SNMP Log File Settings area:</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Be careful when you change these settings so that you do not impact system performance (by saving too much data).</td>
</tr>
<tr>
<td></td>
<td>1. Adjust the maximum number of files and file size.</td>
</tr>
<tr>
<td></td>
<td>2. Restart Cisco EPNM Manager for your changes to take effect. See Stop and Restart Cisco EPNM Manager, on page 719.</td>
</tr>
</tbody>
</table>

---

Synchronize System logs to an External Location

You can configure to synchronize the ncs (Cisco EPNM Manger logs) and os logs to a local or NFS based repository.

---

Synchronize System Logs to an External Location

To synchronize the logs to a repository:
Before you begin

Create a local or NFS based repository to which you want to synchronize the logs. For more information on how to do this, see Set Up and Manage Repositories, on page 690.

Step 1
Open a CLI session with the Cisco EPN Manager server. See Connect via CLI, on page 704.

Step 2
Enter the following commands in the configuration mode to synchronize the system logs.

• To synchronize the ncs logs:
  logging sync-logs ncs repository repository-name

• To synchronize the os logs:
  logging sync-logs os repository repository-name

Where repository-name refers to the repository you configured.

Note
To disable the synchronization, enter these commands instead in the configure terminal mode.

• To disable synchronizing the ncs logs:
  no logging sync-logs ncs repository repository-name

• To disable synchronizing the os logs:
  no logging sync-logs os repository repository-name

Step 3
Exit configuration mode:
exit

Example

Example 1
(config)# logging sync-logs ncs repository myrepository
(config)# logging sync-logs os repository myrepository
config# exit

Example 2
(config)# no logging sync-logs ncs repository myrepository
(config)# no logging sync-logs os repository myrepository
config# exit

Security Log

Cisco EPN Manager maintains a log of security-related actions performed by a root user and members of the admin and super-user user group in active and past web GUI or CLI sessions.
The logged information includes a description of the event, the IP address of the client from which the user performed the task, and the time at which the task was performed. The following events are logged:

- User login
- User logout
- User creation
- User added
- User deleted
- Lock user
- Unlock user
- Linux shell entering
- User modifications (mail, password)

Cisco EPN Manager always maintains a log of security-related actions locally. To view details of this log, enter the following command. You must be logged in as an admin CLI user to use this command. For more information, see Establish an SSH Session With the Cisco EPN Manager Server, on page 716.

```
show logging security
```

Event entries from the CLI have the prefix “SYSTEM-CLI:” and entries from the web interface have the prefix “SYSTEM-WEB:” The structure of each event entry is based on a JSON format and is JSON valid.

<table>
<thead>
<tr>
<th>Events CLI</th>
<th>Event Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SYSTEM-CLI:SSH:LOGIN:FAILED:WRONG_PASSWORD</td>
<td>User login failed due to wrong password</td>
</tr>
<tr>
<td>SYSTEM-CLI:SSH:LOGIN:FAILED:MAXIMUM_ATTEMPTS_REACHED</td>
<td>User login failed due to maximum attempts reached</td>
</tr>
<tr>
<td>SYSTEM-CLI:SSH:LOGIN:SUCCESSFUL</td>
<td>User login successful</td>
</tr>
<tr>
<td>SYSTEM-CLI:SSH:LOGOUT:SUCCESSFUL</td>
<td>User logout successful</td>
</tr>
<tr>
<td>SYSTEM-CLI:CONSOLE:LOGIN:WRONG_PASSWORD</td>
<td>Console login failed due to wrong password</td>
</tr>
<tr>
<td>SYSTEM-CLI:CONSOLE:LOGIN:SUCCESSFUL</td>
<td>Console login successful</td>
</tr>
<tr>
<td>SYSTEM-CLI:CONSOLE:LOGOUT:SUCCESSFUL</td>
<td>Console logout successful</td>
</tr>
<tr>
<td>SYSTEM-CLI:USER:ADD</td>
<td>User added</td>
</tr>
<tr>
<td>SYSTEM-CLI:USER:DELETE</td>
<td>User deleted</td>
</tr>
<tr>
<td>SYSTEM-CLI:USER:GROUP</td>
<td>User group modified</td>
</tr>
<tr>
<td>SYSTEM-CLI:USER:PASSWORD</td>
<td>User password modified</td>
</tr>
<tr>
<td>SYSTEM-CLI:USER:PASSWORD:POLICY</td>
<td>User password policy modified</td>
</tr>
<tr>
<td>SYSTEM-CLI:USER:ROLE</td>
<td>User role modified</td>
</tr>
<tr>
<td>SYSTEM-CLI:USER:STATE:LOCK</td>
<td>User state locked</td>
</tr>
<tr>
<td>SYSTEM-CLI:USER:STATE:UNLOCK</td>
<td>User state unlocked</td>
</tr>
<tr>
<td>SYSTEM-CLI:USER:MAIL</td>
<td>User mail modified</td>
</tr>
</tbody>
</table>
### Send Security Log to an External location

Remote logging is supported and you can configure to forward security-related events to a remote syslog server.

| Events UI | • SYSTEM-CLI:USER:OS:SHELL:ENTERED  
| • SYSTEM-CLI:OS:SHELL:ENABLED  
| • SYSTEM-CLI:OS:SHELL:DISABLED  
| • SYSTEM-WEB:UI:NCS:BODEGE:LOGIN:SUCCESSFUL  
| • SYSTEM-WEB:UI:LOGOUT  
| • SYSTEM-WEB:UI:LOGIN:SUCCESSFUL  
| • SYSTEM-WEB:UI:LOGIN:AUTHENTICATION_FAILED  
| • SYSTEM-WEB:UI:USER:DELETE  
| • SYSTEM-WEB:UI:USER:ADD  
| • SYSTEM-WEB:UI:USER:STATE:UNLOCK  
| • SYSTEM-WEB:UI:USER:STATE:LOCK  
| • SYSTEM-WEB:UI:USER:UPDATE |

| **Step 1** | Open a CLI session with the Cisco EPN Manager server, making sure you enter configure terminal mode. See Connect via CLI, on page 704. |
| **Step 2** | Enter the following command:  
`logging security hostname[:port]`  
Where *hostname* is the name or IP address of the remote logging host server.  
**Note** This command sends the log to UDP port 514 by default, if the port is not specified. |
| **Step 3** | Exit the configuration mode:  
`exit` |

**Example**

/admin(config)# logging security 10.56.22.33  
/admin(config)# exit
Send Security Log to an External location
CHAPTER 28

Configure and Manage High Availability

- How High Availability Works, on page 809
- Planning HA Deployments, on page 811
- Set Up High Availability, on page 814
- How to Patch HA Servers, on page 819
- Monitor HA Status and Events, on page 825
- Trigger Failover, on page 828
- Trigger Failback, on page 829
- Respond to Other HA Events, on page 830
- High Availability Reference Information, on page 839

How High Availability Works

The Cisco EPN Manager high availability (HA) framework ensures continued system operation in case of failure. HA uses a pair of linked, synchronized Cisco EPN Manager servers to minimize or eliminate the impact of application or hardware failures that may take place on either server. Servers can fail due to issues in one or more of the following areas:

- Application processes—Server, TFTP, FTP, and other process failures. You can view the status of these processes using the CLI `ncs status` command.

- Database server—Database-related process failures (the database server runs as a service on Cisco EPN Manager).

- Network—Problems with network access or reachability.

- System—Problems with the server's physical hardware or operating system.

- Virtual machine (if HA is running in a VM environment)—Problems with the VM environment on which the primary and secondary servers are installed.

The following figure shows the main components and process flows for an HA setup.
An HA deployment consists of a primary and a secondary server with Health Monitor (HM) instances (running as an application process) on both servers. When the primary server fails (either automatically or because it is manually stopped), the secondary server takes over and manages the network while you restore access to the primary server. If the deployment is configured for automatic failover, the secondary server takes over the active role within two to three minutes after the failover. This HA is based on the active/passive or cold standby model of operation. Because it is not a clustered system, when the primary server fails, the sessions are not preserved in the secondary server.

When issues on the primary server are resolved and the server is in a running state, it remains in standby mode during which it begins syncing its data with the active secondary server. When the primary is available again, you can initiate a failback operation. When a failback is triggered, the primary server again takes over the active role. This role switching between the primary and secondary servers happens within two to three minutes.

Whenever the HA configuration determines that the primary server has changed, it synchronizes this change with the secondary server. These changes are of two types:

- File changes, which are synchronized using the HTTPS protocol. This includes items such as report configurations, configuration templates, TFTP-root directory, administration settings, licensing files, and the key store. File synchronization is done:
  - In batches, for files that are not updated frequently (such as license files). These files are synchronized once every 500 seconds.
  - Near real-time, for files that are updated frequently. These files are synchronized once every 11 seconds.

- Database changes, such as updates related to configuration, performance and monitoring data. Oracle Recovery Manager (RMAN) creates the initial standby database and Oracle Active Data Guard synchronizes the databases when there is any change.

The primary and secondary HA servers exchange the following messages to maintain synchronization between the two servers:

- Database Sync—Includes all the information necessary to ensure that the databases on the primary and secondary servers are running and synchronized.
• File Sync—Includes frequently updated configuration files. These are synchronized every 11 seconds, while other infrequently updated configuration files are synchronized every 500 seconds.

Note
Configuration files that are updated manually on the primary are not synced to the secondary. When you update a configuration file manually on the primary, you must update the file on the secondary as well.

• Process Sync—Ensures that application- and database-related processes are running. These messages fall under the Heartbeat category.

• Health Monitor Sync—These messages check for the network, system, and health monitor failure conditions.

Planning HA Deployments

The HA feature supports the following deployment models:

- **Local**: Both of the HA servers are located on the same subnet (giving them Layer 2 proximity), usually in the same data center.

- **Campus**: Both HA servers are located in different subnets connected via LAN. Typically, they will be deployed on a single campus, but at different locations within the campus.

- **Remote**: Each HA server is located in a separate, remote subnet connected via WAN. Each server is in a different facility. The facilities are geographically dispersed across countries or continents.

The following sections explain the advantages and disadvantage of each model, and discusses underlying restrictions that affect all deployment models.

HA will function using any of the supported deployment models. The main restriction is on HA’s performance and reliability, which depends on the bandwidth and latency criteria discussed in “Network Throughput Restrictions on HA”. As long as you are able to successfully manage these parameters, it is a business decision (based on business parameters, such as cost, enterprise size, geography, compliance standards, and so on) as to which of the available deployment models you choose to implement.

Network Throughput Restrictions on HA

Cisco EPN Manager HA performance is always subject to the following limiting factors:

- The net bandwidth available to Cisco EPN Manager for handling all operations. These operations include (but are not restricted to) HA configuration, database and file synchronization, and triggering failback.

- The net latency of the network across the links between the primary and secondary servers. Irrespective of the physical proximity of these two servers, high latency on these links can affect how Cisco EPN Manager maintains sessions between the primary and secondary servers.

- The net throughput that can be delivered by the network that connects the primary and secondary servers. Net throughput varies with the net bandwidth and latency, and can be considered a function of these two factors.
Using the Local Model

These limits apply to at least some degree in every possible deployment model, although some models are more prone to problems than others. For example: Because of the high level of geographic dispersal, the Remote deployment model is more likely to have problems with both bandwidth and latency. But both the Local and Campus models, if not properly configured, are also highly susceptible to problems with throughput, as they can be saddled by low bandwidth and high latency on networks with high usage.

You will rarely see throughput problems affecting a failback or failover, as the two HA servers are in more or less constant communication and the database changes are replicated quickly. Most failovers and failbacks take approximately two to three minutes.

The main exception to this rule is the delay for a full database copy operation. This kind of operation is triggered when the primary server has been down for more than the data retention period and you then bring it back up. The data retention period for the express, express-plus and standard configurations server is six hours and for professional and Gen 2 appliance server it is 12 hours.

Cisco EPN Manager will trigger a full database copy operation from the secondary to the primary. No failback is possible during this period, although the Health Monitor page will display any events encountered while the database copy is going on. As soon as the copy is complete, the primary server will go to the “Primary Syncing” state, and you can then trigger failback. Be sure not to restart the primary server or disconnect it from the network while the full database copy is in progress.

Variations in net throughput during a full database copy operation, irrespective of database size or other factors, can mean the difference between a database copy operation that completes successfully in under an hour and one that does not complete at all. Cisco recommends for the following:

- Network throughput – minimum 500 Mbps (Mega bit per second), preferably higher.
- Network latency – maximum 100 ms, preferably under 70 ms.

Running at a lower performance may risk system stability and result in a failure to complete high availability scenarios (mainly registration & failback).

Using the Local Model

The main advantage of the Local deployment model is that it permits use of a virtual IP address as the single management address for the system. Users can use this virtual IP to connect to Cisco EPN Manager, and devices can use it as the destination for their SNMP trap and other notifications.

The only restriction on assigning a virtual IP address is to have that IP address in the same subnet as the IP address assignment for the primary and secondary servers. For example: If the primary and secondary servers have the following IP address assignments within the given subnet, the virtual IP address for both servers can be assigned as follows:

- Subnet mask: 255.255.255.224 (/27)
- Primary server IP address: 10.10.101.2
- Secondary server IP address: 10.10.101.3
- Virtual IP address: 10.10.101.[4-30] e.g., 10.10.101.4. Note that the virtual IP address can be any of a range of addresses that are valid and unused for the given subnet mask.

In addition to this main advantage, the Local model also has the following advantages:

- Usually provides the highest bandwidth and lowest latency.
- Simplified administration.
Device configuration for forwarding syslogs and SNMP notifications is much easier.

The Local model has the following disadvantages:

- Being co-located in the same data center exposes them to site-wide failures, including power outages and natural disasters.
- Increased exposure to catastrophic site impacts will complicate business continuity planning and may increase disaster-recovery insurance costs.

Using the Campus Model

The Campus model assumes that the deploying organization is located at one or more geographical sites within a city, state or province, so that it has more than one location forming a “campus”. This model has the following advantages:

- Usually provides bandwidth and latency comparable to the Local model, and better than the Remote model.
- Is simpler to administer than the Remote model.

The Campus model has the following disadvantages:

- More complicated to administer than the Local model.
- Does not permit use of a virtual IP address as the single management address for the system, so it requires more device configuration (see What If I Cannot Use Virtual IP Addressing?, on page 815).
- May provide lower bandwidth and higher latency than the Local model. This can affect HA reliability and may require administrative intervention to remedy (see Network Throughput Restrictions on HA, on page 811).
- While not located at the same site, it will still be exposed to city, state, or province-wide disasters. This may complicate business continuity planning and increase disaster-recovery costs.

Using the Remote Model

The Remote model assumes that the deploying organization has more than one site or campus, and that these locations communicate across geographical boundaries by WAN links. It has the following advantages:

- Least likely to be affected by natural disasters. This is usually the least complex and costly model with respect to business continuity and disaster recovery.
- May reduce business insurance costs.

The Remote model has the following disadvantages:

- More complicated to administer than the Local or Campus models.
- Does not permit use of a virtual IP address as the single management address for the system, so it requires more device configuration (see What If I Cannot Use Virtual IP Addressing?, on page 815).
- Usually provides lower bandwidth and higher latency than the other two models. This can affect HA reliability and may require administrative intervention to remedy (see Network Throughput Restrictions on HA, on page 811).
Automatic Versus Manual Failover

Configuring HA for automatic failover reduces the need for network administrators to manage HA. It also reduces the time taken to respond to the conditions that provoked the failover, since it brings up the secondary server automatically.

However, we recommend that the system be configured for Manual failover under most conditions. Following this recommendation ensures that Cisco EPN Manager does not go into a state where it keeps failing over to the secondary server due to intermittent network outages. This scenario is most likely when deploying HA using the Remote model. This model is often especially susceptible to extreme variations in bandwidth and latency (see Planning HA Deployments, on page 811 and Network Throughput Restrictions on HA, on page 811).

If the failover type is set to Automatic and the network connection goes down or the network link between the primary and secondary servers becomes unreachable, there is also a small possibility that both the primary and secondary servers will become active at the same time. We refer to this as the “split brain scenario”.

To prevent this, the primary server always checks to see if the secondary server is Active. As soon as the network connection or link is restored and the primary is able to reach the secondary again, the primary server checks the secondary server's state. If the secondary state is Active, then the primary server goes down on its own. Users can then trigger a normal, manual failback to the primary server.

Note that this scenario only occurs when the primary HA server is configured for Automatic failover. Configuring the primary server for Manual failover eliminates the possibility of this scenario. This is another reason why we recommend Manual failover configuration.

Automatic failover is especially ill-advised for larger enterprises. If a particular HA deployment chooses to go with Automatic failover anyway, an administrator may be forced to choose between the data that was newly added to the primary or to the secondary. This means, essentially, that there is a possibility of data loss whenever a split-brain scenario occurs. For help dealing with this issue, see How to Recover From Split-Brain Scenario, on page 838.

To ensure that HA is managed correctly, Cisco recommends that Cisco EPN Manager administrators always confirm the overall health of the HA deployment before initiating failover or failback, including:

- The current state of the primary.
- The current state of the secondary.
- The current state of connectivity between the two servers.

Set Up High Availability

The Cisco Evolved Programmable Network Manager Installation Guide describes how to install the primary and secondary servers in your high availability deployment. As part of the installation, your administrator configures your HA deployment to use manual or automatic failover. You can check the current failover setting using the ncs ha status command or by checking the Health Monitor web page (see Use the Health Monitor Web Page, on page 825).

After the primary and secondary servers are installed, you must perform the HA configuration steps described in How to Configure HA Between the Primary and Secondary Servers, on page 815.

The following topics provide additional information about the HA deployment:

- Using Virtual IP Addressing With HA, on page 815
Using Virtual IP Addressing With HA

A virtual IP address represents the management IP address of the active HA server. During failover or failback, the virtual IP address automatically switches between the two HA servers. This provides two benefits:

- You do not need to know which server is active in order to connect to the Cisco EPN Manager web GUI. Using a virtual IP, your requests are automatically forwarded to the HA server that is active.

- You do not need to configure managed devices to forward notifications to both the primary server and the secondary server. Notifications only need to be forwarded to the virtual IP address.

Virtual IP addressing can be enabled when you configure the secondary server with the primary server. You will need to provide the virtual address (IPv4 or IPv6) that you want both servers to share. See How to Configure HA Between the Primary and Secondary Servers, on page 815.

Using virtual IP addresses does not change the fact that active client-server sessions are terminated when a failover or failback occurs. Even though the virtual IP address will remain available, active client-server sessions (web GUI or NBI) are terminated as the new server begins servicing new requests. Web GUI users will have to log out and back in. For information on handling broken NBI sessions, see the Cisco Evolved Programmable Network Manager MTOSI API Guide for OSS Integration.

Note

To use a virtual IP, the IP addresses of the primary and secondary servers must be on the same subnet.

What If I Cannot Use Virtual IP Addressing?

Depending on the deployment model you choose, not configuring a virtual IP address may result in the administrator having to perform additional steps in order to ensure that syslogs and SNMP notifications are forwarded to the secondary server in case of a failover. The usual method is to configure the devices to forward all syslogs and traps to both servers, usually via forwarding them to a given subnet or range of IP addresses that includes both the primary and secondary server.

This configuration work should be done at the same time HA is being set up: that is, after the secondary server is installed but before HA registration is done on the primary server. It must be completed before a failover so that the chance of losing data is eliminated or reduced. Not using a virtual IP address entails no change to the secondary server install procedure. The primary and secondary servers still need to be provisioned with their individual IP addresses, as normal.

How to Configure HA Between the Primary and Secondary Servers

To enable HA, you must configure HA on the primary server. The primary server needs no configuration during installation in order to participate in the HA configuration. The primary needs to have only the following information:
• The IP address or host name of the secondary HA server you have already installed and configured (Installing the secondary server is described in the Cisco Evolved Programmable Network Manager Installation Guide.)

• The authentication key you set during installation of the secondary server.

• (Optional) One or more email addresses, to which notifications will be sent.

• The Failover Type (see Automatic Versus Manual Failover, on page 814).

If you plan to use virtual IP addressing (see Using Virtual IP Addressing With HA, on page 815), you will also need to:

• Select the Enable Virtual IP checkbox.

• Specify the IPv4 virtual IP address to be shared by the primary and secondary HA servers. You may also specify an IPv6 virtual IP address, although this is not required.

The following steps explain how to configure HA on the primary server. Follow the same steps when re-configuring HA.

**Step 1**
Log into Cisco EPN Manager with a user ID and password that has administrator privileges.

**Step 2**
From the menu, select Administration > Settings > High Availability. Cisco EPN Manager displays the HA status page.

**Step 3**
Select HA Configuration and then complete the fields as follows:

1. **Secondary Server**: Enter the IP address or the host name of the secondary server.
   
   **Note**: We always recommend to use DNS server for resolving the host name to IP address. If you are using the "/etc/hosts" file instead of DNS server, you should enter the secondary IP address instead of host name.

2. **Authentication Key**: Enter the authentication key password you set during the secondary server installation.

3. **Email Address** (Optional): Enter the address (or comma-separated list of addresses) to which notification about HA state changes should be mailed. If you have already configured email notifications using the Mail Server Configuration page (see Forward Alarms and Events as Email Notifications (Administrator Procedure), on page 782), the email addresses you enter here will be appended to the list of addresses already configured for the mail server.

4. **Failover Type**: Select either Manual or Automatic. We recommend that you select Manual.

**Step 4**
If you are using the virtual IP feature: Select the Enable Virtual IP checkbox, then complete the additional fields as follows:

1. **IPV4 Virtual IP**: Enter the virtual IPv4 address you want both HA servers to use.

2. **IPV6 Virtual IP**: (Optional) Enter the IPv6 address you want both HA servers to use.

Note that virtual IP addressing will not work unless both servers are on the same subnet.

**Step 5**
Click Check Readiness to ensure if the HA related environmental parameters are ready for the configuration.

For more details, see Check Readiness for HA Configuration, on page 817.

**Note**: The readiness check does not block the HA configuration. You can configure HA even if some of the tests do not pass.
Step 6  
Click **Save** to save your changes. Cisco EPN Manager initiates the HA configuration process. When configuration completes successfully, **Configuration Mode** will display the value **HA Enabled**.

### Configure an SSO Server in an HA Environment

Single Sign-On (SSO) authentication is used to authenticate and manage users in a multi-user, multi-repository environment. SSO is responsible for storing and retrieving the credentials that are used for logging into different systems. You can set up a Cisco EPN Manager as the SSO server for other instances of Cisco EPN Manager.

To configure an SSO server in the high-availability environment, choose one of the procedures listed in the Table 61: SSO Configuration in a HA Deployment. See these topics for more information:

- To configure the SSO server, see Add a RADIUS or TACACS+ Server to Cisco EPN Manager, on page 767.
- To configure the HA servers, see the Cisco Evolved Programmable Network Manager Installation Guide.

**Table 61: SSO Configuration in a HA Deployment**

<table>
<thead>
<tr>
<th>SSO Configuration</th>
<th>Setup SSO Server</th>
<th>Sever Failover Scenario</th>
<th>SSO Server Failure Scenario</th>
</tr>
</thead>
<tbody>
<tr>
<td>SSO as a standalone server</td>
<td>1. Configure the standalone SSO server.</td>
<td>When the primary server fails, the secondary server is activated. All machines that</td>
<td>When the SSO server fails, SSO functionality is disabled. Cisco EPN Manager will use local</td>
</tr>
<tr>
<td></td>
<td>2. Configure the primary and secondary HA servers.</td>
<td>are connected to the primary server will be redirected to the secondary server.</td>
<td>authentication.</td>
</tr>
<tr>
<td>SSO on the secondary Server</td>
<td>1. Configure one server to be the SSO server and the</td>
<td>When the primary server fails, the secondary server is activated. All machines that</td>
<td>When the SSO (primary) server fails, the secondary server can be set as the failback option</td>
</tr>
<tr>
<td></td>
<td>primary server (in other words, the primary server</td>
<td>are connected to primary server will not be redirected to the secondary server (because</td>
<td>for SSO. This enables all instances to connect to the secondary server. If the secondary</td>
</tr>
<tr>
<td></td>
<td>will also be the SSO server).</td>
<td>SSO is configured on the primary server).</td>
<td>server is not set as the SSO server failback option, Cisco EPN Manager will use local</td>
</tr>
<tr>
<td></td>
<td>2. Configure the secondary HA server.</td>
<td></td>
<td>authentication.</td>
</tr>
</tbody>
</table>

### Check Readiness for HA Configuration

During the HA configuration, other environmental parameters related to HA like system specification, network configuration and bandwidth between the servers determine the HA configuration.

15 checks are run in the system to ensure the HA configuration completion without any error or failure. The checklist name and the corresponding status with recommendations if any, will be displayed when you run the Check Readiness feature.
The Check Readiness does not block the HA configuration. You can configure HA even if some of the checks do not pass.

To check readiness for HA configuration, follow these steps:

**Step 1** Log in to Cisco EPN Manager with a user ID and password that has administrator privileges.

**Step 2** From the menu, select Administration > Settings > High Availability. Cisco EPN Manager displays the HA status page.

**Step 3** Select HA Configuration.

**Step 4** Provide the secondary server IP address in the Secondary Server field and secondary Authentication Key Authentication Key field.

**Step 5** Click Check Readiness.

A pop up window with the system specifications and other parameters will be displayed. The screen will show the Checklist Item name, Status, Impact and Recommendation details.

Below, is the list of checklist test name and the description displayed for Check Readiness:

<table>
<thead>
<tr>
<th>Checklist Test Name</th>
<th>Test Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SYSTEM - CHECK CPU COUNT</td>
<td>Checks the CPU count in both the primary and secondary servers. The CPU count in both servers must meet the requirements.</td>
</tr>
<tr>
<td>SYSTEM - CHECK DISK IOPS</td>
<td>Checks the disk speed in both the primary and secondary servers. The minimum expected disk speed is 200 MBps.</td>
</tr>
<tr>
<td>SYSTEM - CHECK RAM SIZE</td>
<td>Checks the RAM size of both the primary and secondary servers. The RAM size of both servers must meet the requirements.</td>
</tr>
<tr>
<td>SYSTEM - CHECK DISK SIZE</td>
<td>Checks the disk size of both the primary and secondary servers. The disk size of both servers must meet the requirements.</td>
</tr>
<tr>
<td>SYSTEM - CHECK SERVER PING REACHABILITY</td>
<td>Checks that the primary server can reach the secondary server through ping.</td>
</tr>
<tr>
<td>SYSTEM - CHECK OS COMPATABILITY</td>
<td>Checks that the primary server and secondary servers have the same OS version.</td>
</tr>
<tr>
<td>SYSTEM - HEALTH MONITOR STATUS</td>
<td>Checks whether the health monitor process is running in both the primary and secondary servers.</td>
</tr>
</tbody>
</table>
Step 6

Once the check is completed for all the parameters, check their status and click **Clear** to close the window.

**Note**  
Failback and failover events during **Check Readiness** are forwarded to the Alarms and Events page. Configuration failure events are not present in the Alarms and Events list.

### How to Patch HA Servers

You can download and install UBF patches for your HA servers in one of the following ways:

- Install the patch on HA servers that are not currently paired. Cisco recommends this method if you have not set up HA for Cisco EPN Manager.
- Install the patch on existing paired HA servers using manual failover. This is the method Cisco recommends if you already have HA set up.
- Install the patch on existing paired HA servers using automatic failover.
For information on each method, see:

How to Patch New HA Servers

If you are setting up a new Cisco EPN Manager High Availability (HA) implementation and your new servers are not at the same patch level, follow the steps below to install patches on both servers and bring them to the same patch level.

Step 1 Download the patch and install it on the primary server:
   a) Point your browser to the software patches listing for Cisco EPN Manager. (see Software patches listing for Cisco Evolved Programmable Network Manager)
   b) Click the Download button for the patch file you need to install (the file name ends with a UBF file extension), and save the file locally.
   c) Log in to the primary server using an ID with administrator privileges and choose Administration > Licenses and Software Updates > Software Update.
   d) Click the Upload link at the top of the page and browse to the location where you saved the patch file.
   e) Select the UBF file and click OK to upload the file.
   f) When the upload is complete: On the Software Upload page, verify that the Name, Published Date and Description of the patch file are correct.
   g) Select the patch file and click Install.
   h) Click Yes in the warning pop-up. When the installation is complete, the server will restart automatically. The restart typically takes 15 to 20 minutes.
   i) After the installation is complete on the primary server, verify that the Status of Updates table on the Software Update page shows “Installed” for the patch.

Step 2 Install the same patch on the secondary server:
   a) Access the secondary server’s Health Monitor (HM) web page by pointing your browser to the following URL:
      https://ServerIP:8082
      where ServerIP is the IP address or host name of the secondary server.
   b) You will be prompted for the secondary server authentication key. Enter it and click Login.
   c) Click the HM web page’s Software Update link. You will be prompted for the authentication key a second time. Enter it and click Login again.
   d) Click Upload Update File and browse to the location where you saved the patch file.
   e) Select the UBF file and click OK to upload the file.
   f) When the upload is complete: On the Software Upload page, confirm that the Name, Published Date and Description of the patch file are correct.
   g) Select the patch file and click Install.
   h) Click Yes in the warning pop-up. When the installation is complete, the server will restart automatically. The restart typically takes 15 to 20 minutes.
   i) After the installation is complete on the secondary server, verify that the Status of Updates table on the Software Update page shows “Installed” for the patch.

Step 3 Verify that the patch status is the same on both servers, as follows:
   a) Log in to the primary server and access its Software Update page as you did in step 1, above. The “Status” column should show “Installed” for the installed patch.
b) Access the secondary server’s Health Monitor page as you did in step 2, above. The “Status” column should show “Installed” for the installed patch.

**Step 4**

Register the servers.

For more information, see "Software patches listing for Cisco Evolved Programmable Network Manager" and "Stop and Restart Cisco EPN Manager, on page 719".

---

### How to Patch Paired HA Servers

If your current Cisco EPN Manager implementation has High Availability servers that are not at the same patch level, or you have a new patch you must install on both your HA servers, follow the steps below.

Patching paired HA servers is not supported. You will receive a popup error message indicating that you cannot perform an update on Cisco EPN Manager servers while HA is configured. So, you must first disconnect the primary and secondary servers before attempting to apply the patch.

1. Follow the steps in **Remove HA Via the GUI, on page 843** to disconnect the primary and secondary servers.

2. Follow the steps in **How to Patch New HA Servers, on page 820** to apply the patch.

3. Follow the steps in **Set Up High Availability, on page 814** to restore your HA configuration.

### How to Patch Paired HA Servers Set for Manual Failover

If your current Cisco EPN Manager implementation has High Availability servers that are not at the same patch level, or you have a new patch you must install on both your HA servers, follow the steps below.

You must start the patch install with the primary server in “Primary Active” state and the secondary server in “Secondary Syncing” state.

Patching of primary and secondary HA servers set for manual failover takes approximately 30 minutes, and does not require failover or failback. Patching of the primary and secondary HA servers takes approximately 30 minutes. Downtime during the primary patch installation restart takes 15 to 20 minutes.

In some cases, you may receive a popup error message indicating that you cannot perform an update on Cisco EPN Manager servers while HA is configured. If so, you must first disconnect the primary and secondary servers before attempting to apply the patch. In this case, you cannot use the steps in this procedure. Instead, be sure to:

1. Follow the steps in **Remove HA Via the GUI, on page 843** to disconnect the primary and secondary servers.

2. Follow the steps in **How to Patch New HA Servers, on page 820** to apply the patch.

3. Follow the steps in **Set Up High Availability, on page 814** to restore your HA configuration.

---

**Step 1**

Ensure that your HA implementation is enabled and ready for update:

a) Log in to the primary server using an ID with Administrator privileges.

b) Select **Administration > Settings > High Availability**, The primary server state displayed on the HA Status page should be “Primary Active”.

---

Cisco Evolved Programmable Network Manager 3.0 User and Administrator Guide
c) Select **HA Configuration**. The current Configuration Mode should show “HA Enabled”. We recommend that you set the Failover Type to “manual” during the patch installation.

d) Access the secondary server’s Health Monitor (HM) web page by pointing your browser to the following URL:

   https://ServerIP:8082

   where **ServerIP** is the IP address or host name of the secondary server.

e) Verify that the secondary server state displayed on the HM web page is in the “Secondary Syncing” state.

### Step 2
You will be prompted for the authentication key entered when HA was enabled. Enter it and click **Login**.

### Step 3
Download the UBF patch and install it on the primary server:

a) Point your browser to the software patches listing for Cisco EPN Manager (see **Software patches listing for Cisco Evolved Programmable Network Manager**).

b) Click the **Download** button for the patch file you need to install (the file name ends with a UBF file extension), and save the file locally.

c) Log in to the primary server using an ID with administrator privileges and choose **Administration > Licenses and Software Updates > Software Update**.

d) Click the **Upload** link at the top of the page and browse to the location where you saved the patch file.

e) Select the UBF file and click **OK** to upload the file.

f) When the upload is complete: On the Software Upload page, verify that the Name, Published Date and Description of the patch file are correct.

g) Select the patch file and click **Install**.

h) Click **Yes** in the warning pop-up. When the installation is complete, the server will restart automatically. The restart typically takes 15 to 20 minutes.

i) After the server restart is complete on the primary server, select **Administration > Settings > High Availability**.

   The primary server state displayed on the HA Status page should be “Primary Active”.

j) Verify that the Status of Updates table on the Software Update page shows “Installed” for the patch.

### Step 4
Install the same patch on the secondary server once patching is complete on the primary server:

a) Access the secondary server’s HM web page and login if needed.

b) Click the HM web page’s **Software Update** link. You will be prompted for the authentication key a second time. Enter it and click **Login** again.

c) Click **Upload Update File** and browse to the location where you saved the patch file.

d) Select the UBF file and click **OK** to upload the file.

e) When the upload is complete: On the Software Upload page, confirm that the Name, Published Date and Description of the patch file are correct.

f) Select the patch file and click **Install**.

h) Click **Yes** in the warning pop-up. When the installation is complete, the server will restart automatically. The restart typically takes 15 to 20 minutes.

i) After the server restart is complete on the secondary server, log in to the secondary HM page (https://serverIP:8082) and verify that the secondary server state displayed on the HM web page is “Secondary Syncing”.

j) Verify that the Status of Updates table on the Software Update page shows “Installed” for the patch.

### Step 5
Once the server restart is complete, verify the patch installation as follows:

a) Log in to the primary server and access its Software Update page as you did in step 2, above. The “Status” column on the Status of Updates > Update tab should show “Installed” for the patch.

b) Access the secondary server’s Software Update page as you did in step 3, above. The “Status” column on the Status of Updates > Updates tab should show “Installed” for the patch.
How to Patch Paired HA Servers Set for Automatic Failover

If your current Cisco EPN Manager implementation has High Availability servers that are not at the same patch level, or you have a new patch you must install on both your HA servers, follow the steps below.

You must start the patch install with the primary server in “Primary Active” state and the secondary server in “Secondary Syncing” state.

Patching of primary and secondary HA servers set for automatic failover takes approximately one hour, and requires both failover and failback. Downtime during the failover and failback lasts 10 to 15 minutes.

In some cases, you may receive a popup error message indicating that you cannot perform an update on Cisco EPN Manager servers while HA is configured. If so, you must first disconnect the primary and secondary servers before attempting to apply the patch. In this case, you cannot use the steps in this procedure. Instead, be sure to:

1. Follow the steps in Remove HA Via the GUI, on page 843 to disconnect the primary and secondary servers.
2. Follow the steps in How to Patch New HA Servers, on page 820 to apply the patch.
3. Follow the steps in Set Up High Availability, on page 814 to restore your HA configuration.

Step 1

Ensure that your HA implementation is enabled and ready for update:

a) Log in to the primary server using an ID with Administrator privileges.
b) Select Administration > Settings > High Availability. The primary server state displayed on the HA Status page should be “Primary Active”.
c) Select HA Configuration. The current Configuration Mode should show “HA Enabled”.
d) Access the secondary server’s Health Monitor (HM) web page by pointing your browser to the following URL:
   https://ServerIP:8082
   where ServerIP is the IP address or host name of the secondary server.
e) You will be prompted for the authentication key entered when HA was enabled. Enter it and click Login.
f) Verify that the secondary server state displayed on the HM web page is in the “Secondary Syncing” state.

Step 2

Download the UBF patch and install it on the primary server:

a) Point your browser to the software patches listing for Cisco EPN Manager (see Software patches listing for Cisco Evolved Programmable Network Manager).
b) Click the Download button for the patch file you need to install (the file name ends with a UBF file extension), and save the file locally.
c) Log in to the primary server using an ID with administrator privileges and choose Administration > Licenses and Software Updates > Software Update.
d) Click the upload link at the top of the page and browse to the location where you saved the patch file.
e) Select the UBF file and then click OK to upload the file.
f) When the upload is complete: On the Software Upload page, verify that the Name, Published Date and Description of the patch file are correct.
g) Select the patch file and click **Install**.

h) Click **Yes** in the warning pop-up. Failover will be triggered and the primary server will restart automatically. Failover will take 2 to 4 minutes to complete. After the failover is complete, the secondary server will be in “Secondary Active” state.

i) After the primary server is restarted, run the **ncs status** command to verify that the primary’s processes have re-started. Before you continue, access the primary server’s HM web page and verify that the primary server state displayed is “Primary Syncing”.

**Step 3**

Failback to the primary using the secondary server’s HM web page:

a) Access the secondary server’s HM web page and login if needed.

b) Click **Failback** to initiate a failback from the secondary to the primary server. It will take 2 to 3 minutes for the operation to complete. As soon as failback completes, the secondary server will be automatically restarted in the standby mode. It will take a maximum of 15 minutes for the restart to complete, and it will be synched with the primary server.

You can verify the restart by logging into the secondary server’s HM web page and looking for the message “Cisco EPN Manager stopped successfully” followed by “Cisco EPN Manager started successfully.”

After failback is complete, the primary server state will change to “Primary Active”.

c) Before continuing: Run the **ncs ha status** command on both the primary and secondary servers. Verify that the primary server state changes to “Primary Active” and the secondary server state is “Secondary Syncing”.

**Step 4**

Once failback completes, verify the patch installation by logging in to the primary server and accessing its Software Update page (as you did in step 2, above). The “Status” column on the Status of Updates > Update tab should show “Installed” for the patch.

**Step 5**

Install the same patch on the secondary server once patching is complete on the primary server:

a) Access the secondary server’s HM web page and login if needed.

b) Click the HM web page’s **Software Update** link. You will be prompted for the authentication key a second time. Enter it and click **Login** again.

c) Click **Upload Update File** and browse to the location where you saved the patch file.

d) Select the UBF file and then click **OK** to upload the file.

e) When the upload is complete: On the Software Upload page, confirm that the Name, Published Date and Description of the patch file are correct.

f) Select the patch file and click **Install**.

g) Click **Yes** in the warning pop-up. The server will restart automatically. The restart typically takes 15 to 20 minutes.

h) After the installation is complete on the secondary server, verify that the Status of Updates table on the Software Update page shows “Installed” for the patch.

i) After the server restart is complete on the secondary server, log in to the secondary HM page and verify that the secondary server state displayed on the HM web page is “Secondary Syncing”.

**Step 6**

Once server restart is complete, verify the patch installation as follows:

a) Log in to the primary server and access its Software Update page as you did in step 2, above. The “Status” column on the Status of Updates > Update tab should show “Installed” for the patch.

b) Access the secondary server’s Software Update page as you did in step 5, above. The “Status” column on the Status of Updates > Updates tab should show “Installed” for the patch.

For more information, see Software patches listing for Cisco Evolved Programmable Network Manager, Stop and Restart Cisco EPN Manager, on page 719.
Monitor HA Status and Events

These topics describe how to monitor the overall health of the HA environment:

- Use the Health Monitor Web Page, on page 825
- HA Configuration Modes, on page 839
- HA States and Transitions, on page 840
- Check HA Status and Overall Health, on page 827
- View and Customize HA Events, on page 827
- Use HA Error Logging, on page 828

Use the Health Monitor Web Page

The Health Monitor is one of the main components that manage the HA operations. Health Monitor instances run on both servers as an application process, with its own web page on each server. It performs the following functions:

- Synchronizes database and configuration data related to HA (this excludes databases that synchronize separately using Oracle Data Guard).

- Exchanges heartbeat messages between the primary and secondary servers every 5 seconds, to ensure communications are maintained between the servers. If the healthy server does not receive 3 consecutive heartbeats from the other redundant server, it waits for 10 seconds. The healthy server then attempts to open a web URL in the redundant server. If this attempt fails, the healthy server becomes the active server.

- Checks the available disk space on both servers at regular intervals and generates events when storage space runs low.

- Manages, controls, and monitors the overall health of the linked HA servers. If there is a failure on the primary server, the Health Monitor activates the secondary server.

After you have completed HA configuration successfully, you can access the Health Monitor web page from the primary or secondary server by entering the following URL on your browser:

https://ServerIP:8082

where ServerIP is the primary or secondary server’s IP address or host name.

The following example shows a Health Monitor web page for a secondary server in the Secondary Syncing state.
# Use the Health Monitor Web Page

## Administer the Cisco EPN Manager System

### Evolved Programmable Network Manager Health Monitor

#### Health Monitor Details

<table>
<thead>
<tr>
<th>Status</th>
<th>Primary IP Address</th>
<th>State</th>
<th>Failover Type</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>10.0.0.201</td>
<td>Secondary Syncing</td>
<td>Manual</td>
<td>Manual Failover</td>
</tr>
</tbody>
</table>

#### Settings

- **Status:** Indicates the current functional status of the HA setup (a green check mark indicates HA is enabled and working).
- **2 Settings:** Displays the Health Monitor state and configuration detail in five separate sections.
- **1 Primary/Secondary IP address:** Displays the IP address of the paired servers. Because this Health Monitor instance is running on the secondary server, it shows the IP address of the primary server.
- **4 Events:** Displays the current HA-related events in chronological order, with the most recent events at the top.
- **3 State:** Shows the current state of the server on which this Health Monitor instance is running (in this case, the secondary server).
- **5 Download:** Lets you download the Health Monitor log files.
- **7 Message Level:** Indicates the current logging level, which you can change (Error, Informational, or Trace). You must click `Save` to change the logging level.
- **9 Failover Type:** Shows whether you have Manual or Automatic failover configured.
- **11 Check Failover Readiness:** Shows the outcome of the disk speed, network interface bandwidth and DB sync status checks after the HA configuration is enabled.

#### Checklist Item

<table>
<thead>
<tr>
<th>Item</th>
<th>Status</th>
<th>Impact</th>
<th>Recommendation</th>
</tr>
</thead>
<tbody>
<tr>
<td>SYSTEM - CHECK DISK IOPS</td>
<td></td>
<td></td>
<td>None</td>
</tr>
<tr>
<td>NETWORK - CHECK NETWORK INTERFACE BANDWIDTH</td>
<td></td>
<td></td>
<td>None</td>
</tr>
<tr>
<td>DATABASE - SYNC STATUS</td>
<td></td>
<td></td>
<td>None</td>
</tr>
</tbody>
</table>

#### Events

- **Feb 10, 2019 04:50 PM IST**
  - **Status:** Secondary Syncing
  - **Description:** New Primary Evolved Programmable Network Manager server has team-based [10.0.0.201] registered.
- **Feb 10, 2019 04:54 PM IST**
  - **Status:** HA Initializing
  - **Description:** Primary Evolved Programmable Network Manager [team-based [10.0.0.201]] is attempting to register.
- **Feb 10, 2019 04:54 PM IST**
  - **Status:** HA not Configured
  - **Description:** Secondary EPN Manager Server started successfully as standby.
- **Feb 10, 2019 04:54 PM IST**
  - **Status:** Health Monitor Available
  - **Description:** Health Monitor Started.

#### Note

The **Check Readiness** does not block failover to the secondary (either automatic or manual).
Check HA Status and Overall Health

You can use the Cisco EPN Manager web GUI or CLI to check HA status. Either of these approaches will list the state of the server. States are described in HA States and Transitions, on page 840.

To check the HA status from the web GUI, do one of the following:

• From the Cisco EPN Manager web GUI—Choose Administration > Settings > High Availability, then choose HA Status. The current HA status and the event states are displayed.
• From the Health Monitor. See Use the Health Monitor Web Page, on page 825.

To check HA status from the CLI, log into either server as a CLI admin user (see Establish an SSH Session With the Cisco EPN Manager Server, on page 716). The `ncs ha status` command provides a HA-specific output similar to the below example:

```
ncs ha status
```

Use the `ncs status` command to check the Health Monitor and other server processes. You will see an output similar to the following example:

```
ncs status
Health Monitor Server is running. ( [Role] Primary [State] Primary Active )
Database server is running
FTP Service is disabled
TFTP Service is disabled
NMS Server is running...
SAM Daemon is running ...
DA Daemon is running ...
```

View and Customize HA Events

HA-related alarms are listed in the Alarms and Events table. A list of these alarms is provided in Cisco Evolved Programmable Network Manager Supported Alarms. The following procedure explains how to view these alarms in the web GUI.

If desired, you can also:

• Adjust the severity for these alarms
• Configure notifications for these alarms

For more information, see Work With Server Internal SNMP Traps That Indicate System Problems, on page 724.

To view HA-related alarms:

**Step 1** Choose Monitor > Monitoring Tools > Alarms and Events, then click the Alarms tab.

**Step 2** Choose Quick Filter from the Show drop-down list at the top right of the table.

**Step 3** In the Message field, enter High Availability.
Use HA Error Logging

To save disk space and maximize performance, HA error logging is disabled by default. If you are having trouble with HA, complete the following procedure to enable error logging and examine the log files.

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Launch the Health Monitor on the server that is having trouble (see Use the Health Monitor Web Page, on page 825).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 2</td>
<td>In the <strong>Logging</strong> area, select the error-logging level from the <strong>Message Level</strong> drop-down list and then click <strong>Save</strong>.</td>
</tr>
<tr>
<td>Step 3</td>
<td>Download the log files you want to examine:</td>
</tr>
<tr>
<td></td>
<td>1. Click <strong>Download</strong>. A .zip file is copied to your default download location.</td>
</tr>
<tr>
<td></td>
<td>2. Extract the log files and use any ASCII text editor to view them.</td>
</tr>
</tbody>
</table>

Trigger Failover

Failover activates the secondary server in response to a failure detected on the primary server.

The Health Monitor detects failure conditions using the heartbeat messages exchanged between the two HA servers. The heartbeat messages are sent every 5 seconds, and if the primary server is not responsive to three consecutive heartbeat messages from the secondary server, the Health Monitor deems the primary server to have failed. During the health check, the Health Monitor also checks the application process status and database health. If there is no proper response to these checks, these are also treated as having failed.

The HA system in the secondary server takes about 15 seconds to detect a process failure on the primary server. If the secondary server is unable to reach the primary server due to a network issue, it might take more time to discover the failure and initiate a failover. In addition, it may take additional time for the application processes on the secondary server to be fully operational.

As soon as the Health Monitor detects a failure, it sends an e-mail notification. The e-mail includes the failure status along with a link to the secondary server's Health Monitor web page. If HA is configured for automatic failover, the secondary server will activate automatically.

To perform a manual failover:

**Before you begin**

- Check the state of the primary and secondary servers.
- Validate the connectivity between the two servers.
- If you are not using virtual IP addresses, make sure all devices are configured to forward traps and syslogs to both servers.

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Access the secondary server's Health Monitor web page using the web link given in the email notification, or by entering the following URL on your browser:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><a href="https://ServerIP:8082">https://ServerIP:8082</a></td>
</tr>
</tbody>
</table>
Step 2   Click Failover.

### Trigger Failback

Failback is the process of re-activating the primary server once it is back online. It also transfers Active status from the secondary server to the primary server, and stops active network monitoring processes on the secondary server.

When a failback is triggered, the secondary server replicates its current database information and updated files to the primary server. The time it takes to complete the failback from the secondary server to the primary server will depend on the amount of data that needs to be replicated and the available network bandwidth.

After the data is replicated successfully, HA changes the state of the primary server to **Primary Active** and the state of the secondary server to **Secondary Syncing**.

During failback, the availability of the secondary server depends on whether the Cisco EPN Manager was reinstalled on the primary server after the failover, as follows:

- If Cisco EPN Manager was reinstalled on the primary server after the failover, a full database copy will be required and the secondary server will not be available during the failback process.
- If Cisco EPN Manager was not reinstalled with primary server, the secondary server is available, except during the period when processes are started on the primary server and stopped on the secondary server. Both servers’ Health Monitor web pages are accessible for monitoring the progress of the failback. Additionally, users can also connect to the secondary server to access all normal functionalities.

You must always trigger failback manually, as described in the procedure below. Note:

- Do not initiate configuration or provisioning activity while the failback is in progress.
- After a successful failback, the secondary server will go down and control will switch over to the primary server. During this process, Cisco EPN Manager will be inaccessible to the users for a few moments.

### Before you begin

- Check the state of the primary and secondary servers.
- Validate the connectivity between the two servers.
- If you are not using virtual IP addresses, make sure all devices are configured to forward traps and syslogs to both servers.
- If you have reinstalled Cisco EPN Manager on the primary server and you are using offline geo maps, you must reinstall the geo maps resources on the primary server before triggering failback. See the Cisco Evolved Programmable Network Manager Installation Guide.

### Step 1

Access the secondary server's Health Monitor web page using the link given in the e-mail notification, or by entering the following URL on your browser:

**https://ServerIP:8082**

### Step 2

Click Failback.
Respond to Other HA Events

All the HA related events are displayed on the HA Status page, the Health Monitor web pages, and under the Cisco EPN Manager Alarms and Events page. Most events require no response from you other than triggering failover and failback. A few events are more complex, as explained in the following topics:

- HA Registration Fails, on page 830
- Network is Down (Automatic Failover), on page 831
- Network is Down (Manual Failover), on page 831
- Process Restart Fails (Automatic Failover), on page 833
- Process Restart Fails (Manual Failover), on page 834
- Primary Server Restarts During Synchronization (Manual Failover), on page 835
- Secondary Server Restarts During Synchronization, on page 835
- Both HA Servers Are Down, on page 835
- Both HA Servers Are Powered Down, on page 836
- Both HA Servers Are Down and Secondary Server Will Not Restart, on page 836
- How to Replace the Primary Server, on page 837
- How to Recover From Split-Brain Scenario, on page 838
- Secondary Server Goes Down, on page 838
- How to Resolve Database Synchronization Issues, on page 839

HA Registration Fails

If HA registration fails, you will see the following HA state-change transitions for each server:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: HA Initializing</td>
<td>From: HA Initializing</td>
</tr>
<tr>
<td>To: HA Not Configured</td>
<td>To: HA Not Configured</td>
</tr>
</tbody>
</table>

To recover from failed HA registration, follow the steps below.

---

**Step 1**  
Use ping and other tools to check the network connection between the two Cisco EPN Manager servers. Confirm that the secondary server is reachable from the primary, and vice versa.

**Step 2**  
Check that the gateway, subnet mask, virtual IP address (if configured), server hostname, DNS, NTP settings are all correct.

**Step 3**  
Check that the configured DNS and NTP servers are reachable from the primary and secondary servers, and that both are responding without latency or other network-specific issues.

**Step 4**  
Check that all Cisco EPN Manager licenses are correctly configured.

**Step 5**  
Once you have remedied any connectivity or setting issues, retry the steps in How to Configure HA Between the Primary and Secondary Servers, on page 815.
Network is Down (Automatic Failover)

If there is a loss of network connectivity between the two Cisco EPN Manager servers, you will see the following HA state-change transitions for each server, assuming that the Failover Type is set to “Automatic”:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Active</td>
<td>From: Secondary Syncing</td>
</tr>
<tr>
<td>To: Primary Lost Secondary</td>
<td>To: Secondary Lost Primary</td>
</tr>
<tr>
<td>To: Primary Lost Secondary</td>
<td>To: Secondary Failover</td>
</tr>
<tr>
<td>To: Primary Lost Secondary</td>
<td>To: Secondary Active</td>
</tr>
</tbody>
</table>

You will get an email notification that the secondary is active.

Step 1

Check on and restore network connectivity between the two servers. Once network connectivity is restored and the primary server can detect that the secondary is active, all services on the primary will be restarted and made passive automatically. You will see the following state changes:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Lost Secondary</td>
<td>From: Secondary Active</td>
</tr>
<tr>
<td>To: Primary Failover</td>
<td>To: Secondary Active</td>
</tr>
<tr>
<td>To: Primary Syncing</td>
<td>To: Secondary Active</td>
</tr>
</tbody>
</table>

Step 2

Trigger a failback from the secondary to the primary. You will then see the following state transitions:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Syncing</td>
<td>From: Secondary Active</td>
</tr>
<tr>
<td>To: Primary Failback</td>
<td>To: Secondary Failback</td>
</tr>
<tr>
<td>To: Primary Failback</td>
<td>To: Secondary Post Failback</td>
</tr>
<tr>
<td>To: Primary Active</td>
<td>To: Secondary Syncing</td>
</tr>
</tbody>
</table>

Network is Down (Manual Failover)

If there is a loss of network connectivity between the two Cisco EPN Manager servers, you will see the following HA state-change transitions for each server, assuming that the Failover Type is set to “Manual”:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Active</td>
<td>From: Secondary Syncing</td>
</tr>
</tbody>
</table>
You will get email notifications that each server has lost the other.

### Step 1
Check on and, if needed, restore the network connectivity between the two servers.

You will see the following state changes once network connectivity is restored:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Lost Secondary</td>
<td>From: Secondary Lost Primary</td>
</tr>
<tr>
<td>To: Primary Active</td>
<td>To: Secondary Syncing</td>
</tr>
</tbody>
</table>

No administrator response is required.

### Step 2
If network connection cannot be restored for any reason, use the HM web page for the secondary server to trigger a failover from the primary to the secondary server. You will see the following state changes:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Lost Secondary</td>
<td>From: Secondary Lost Primary</td>
</tr>
<tr>
<td>To: Primary Lost Secondary</td>
<td>To: Secondary Failover</td>
</tr>
<tr>
<td>To: Primary Failover</td>
<td>To: Secondary Active</td>
</tr>
</tbody>
</table>

You will get an email notification that the secondary server is now active.

### Step 3
Check and restore network connectivity between the two servers. Once network connectivity is restored and the primary server detects that the secondary server is active, all services on the primary server will be restarted and made passive. You will see the following state changes:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Lost Secondary</td>
<td>From: Secondary Active</td>
</tr>
<tr>
<td>To: Primary Failover</td>
<td>To: Secondary Active</td>
</tr>
<tr>
<td>To: Primary Syncing</td>
<td>To: Secondary Active</td>
</tr>
</tbody>
</table>

### Step 4
Trigger a failback from the secondary to the primary.

You will then see the following state transitions:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Syncing</td>
<td>From: Secondary Active</td>
</tr>
<tr>
<td>To: Primary Failback</td>
<td>To: Secondary Failback</td>
</tr>
<tr>
<td>To: Primary Failback</td>
<td>To: Secondary Post Failback</td>
</tr>
</tbody>
</table>
The Cisco EPN Manager Health Monitor process is responsible for attempting to restart any Cisco EPN Manager server processes that have failed. Generally speaking, the current state of the primary and secondary servers should be “Primary Active” and “Secondary Syncing” at the time any such failures occur.

If HM cannot restart a critical process on the primary server, then the primary server is considered to have failed. If your currently configured Failover Type is “automatic”, you will see the following state transitions:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Active</td>
<td>From: Secondary Syncing</td>
</tr>
<tr>
<td>To: Primary Uncertain</td>
<td>To: Secondary Lost Primary</td>
</tr>
<tr>
<td>To: Primary Failover</td>
<td>To: Secondary Failover</td>
</tr>
<tr>
<td>To: Primary Failover</td>
<td>To: Secondary Active</td>
</tr>
</tbody>
</table>

When this process is complete, you will get an email notification that the secondary server is now active.

**Step 1**

Restart the primary server and ensure that it is running. Once the primary is restarted, it will be in the state “Primary Syncing”. You will see the following state transitions:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Failover</td>
<td>From: Secondary Active</td>
</tr>
<tr>
<td>To: Primary Preparing for Failback</td>
<td>To: Secondary Active</td>
</tr>
<tr>
<td>To: Primary Syncing</td>
<td>To: Secondary Active</td>
</tr>
</tbody>
</table>

**Step 2**

Trigger a failback from the secondary to the primary. You will then see the following state transitions:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Syncing</td>
<td>From: Secondary Active</td>
</tr>
<tr>
<td>To: Primary Failback</td>
<td>To: Secondary Failback</td>
</tr>
<tr>
<td>To: Primary Failback</td>
<td>To: Secondary Post Failback</td>
</tr>
<tr>
<td>To: Primary Active</td>
<td>To: Secondary Syncing</td>
</tr>
</tbody>
</table>
Process Restart Fails (Manual Failover)

The Cisco EPN Manager Health Monitor process is responsible for attempting to restart any Cisco EPN Manager server processes that have failed. Generally speaking, the current state of the primary and secondary servers should be “Primary Active” and “Secondary Syncing” at the time any such failures occur. If HM cannot restart a critical process on the primary server, then the primary server is considered to have failed. You will receive an email notification of this failure. If your currently configured Failover Type is “Manual”, you will see the following state transitions:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Active</td>
<td>From: Secondary Syncing</td>
</tr>
<tr>
<td>To: Primary Uncertain</td>
<td>To: Secondary Lost Primary</td>
</tr>
</tbody>
</table>

**Step 1**
Trigger on the secondary server a failover from the primary to the secondary. You will then see the following state transitions:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Uncertain</td>
<td>From: Secondary Syncing</td>
</tr>
<tr>
<td>To: Primary Failover</td>
<td>To: Secondary Failover</td>
</tr>
<tr>
<td>To: Primary Failover</td>
<td>To: Secondary Active</td>
</tr>
</tbody>
</table>

**Step 2**
Restart the primary server and ensure that it is running. Once the primary server is restarted, the primary’s HA state will be “Primary Syncing”. You will see the following state transitions:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Failover</td>
<td>From: Secondary Active</td>
</tr>
<tr>
<td>To: Primary Preparing for Failback</td>
<td>To: Secondary Active</td>
</tr>
<tr>
<td>To: Primary Syncing</td>
<td>To: Secondary Active</td>
</tr>
</tbody>
</table>

**Step 3**
Trigger a failback from the secondary to the primary. You will then see the following state transitions:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Syncing</td>
<td>From: Secondary Active</td>
</tr>
<tr>
<td>To: Primary Failback</td>
<td>To: Secondary Failback</td>
</tr>
<tr>
<td>To: Primary Failback</td>
<td>To: Secondary Post Failback</td>
</tr>
<tr>
<td>To: Primary Active</td>
<td>To: Secondary Syncing</td>
</tr>
</tbody>
</table>
Primary Server Restarts During Synchronization (Manual Failover)

If the primary Cisco EPN Manager server is restarted while the secondary server is syncing, you will see the following state transitions:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Active</td>
<td>From: Secondary Syncing</td>
</tr>
<tr>
<td>To: Primary Alone</td>
<td>To: Secondary Lost Primary</td>
</tr>
<tr>
<td>To: Primary Active</td>
<td>To: Secondary Syncing</td>
</tr>
</tbody>
</table>

The “Primary Alone” and “Primary Active” states occur immediately after the primary comes back online. No administrator response should be required.

Secondary Server Restarts During Synchronization

If the secondary Cisco EPN Manager server is restarted while syncing with the primary server, you will see the following state transitions:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Primary Active</td>
<td>From: Secondary Syncing</td>
</tr>
<tr>
<td>From: Secondary Lost Primary</td>
<td>From: Secondary Lost Primary</td>
</tr>
<tr>
<td>To: Primary Active</td>
<td>To: Secondary Syncing</td>
</tr>
</tbody>
</table>

No administrator response should be required.

Both HA Servers Are Down

If both the primary and secondary servers are down at the same time, you can recover by bringing them back up in the correct order, as explained in the steps below.

---

**Step 1**  
Restart the secondary server and the instance of Cisco EPN Manager running on it. If for some reason you cannot restart the secondary server, see Both HA Servers Are Down and Secondary Server Will Not Restart, on page 836.

**Step 2**  
When Cisco EPN Manager is running on the secondary, access the secondary server’s Health Monitor web page. You will see the secondary server transition to the state “Secondary Lost Primary”.

**Step 3**  
Restart the primary server and the instance of Cisco EPN Manager running on it. When Cisco EPN Manager is running on the primary, the primary will automatically sync with the secondary. To verify this, access the primary server’s Health Monitor web page. You will see the two servers transition through the following series of HA states:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>To: Primary Lost Secondary</td>
<td>To: Secondary Lost Primary</td>
</tr>
</tbody>
</table>
Both HA Servers Are Powered Down

If both the primary and secondary servers are powered down at the same time, you can recover by bringing them back up in the correct order, as explained in the steps below.

### Step 1
Power on the secondary server and the Cisco EPN Manager instance running on it. The secondary HA restart will fail at this state because the primary server is not reachable. However, the secondary server's HM process will be running (with an error).

### Step 2
When Cisco EPN Manager is running on the secondary server, access the secondary server's HM web page (see Use the Health Monitor Web Page, on page 825). You will see the secondary server transition to the Secondary Lost Primary state.

### Step 3
Power on the primary server and the Cisco EPN Manager instance running on it.

### Step 4
When Cisco EPN Manager is running on the primary server, the primary server will automatically begin syncing with the secondary server. To verify this, access the primary server's HM web page. You will see the two servers transition through the following series of HA states:

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>To: Primary Lost Secondary</td>
<td>To: Secondary Lost Primary</td>
</tr>
<tr>
<td>To: Primary Active</td>
<td>To: Secondary Syncing</td>
</tr>
</tbody>
</table>

### Step 5
Restart the secondary server and the Cisco EPN Manager instance running on it. This is required because not all processes will be running on the secondary server at this point.

If for some reason you cannot restart the secondary server, see Both HA Servers Are Down and Secondary Server Will Not Restart, on page 836.

### Step 6
When Cisco EPN Manager finishes restarting on the secondary server, all processes should be running. Verify this by running the `ncs ha status` command.

---

Both HA Servers Are Down and Secondary Server Will Not Restart

If both HA servers are down at the same time and the secondary server will not restart, you will need to remove the HA configuration from the primary server in order to use it as a standalone server until you can replace or restore the secondary server.

The following steps assume that you have already tried and failed to restart the secondary server.

### Step 1
Attempt to restart the primary instance of Cisco EPN Manager. If the primary server is able to restart at all, the restart will abort with an error message indicating that you must remove the HA configuration.
Step 2  Open a CLI session with the primary server (see Establish an SSH Session With the Cisco EPN Manager Server, on page 716).

Step 3  Enter the following command to remove the HA configuration on the primary server:

```
ncs ha remove
```

Step 4  Confirm that you want to remove the HA configuration.

You should now be able to restart the primary instance of Cisco EPN Manager without receiving an error message, and use it as a standalone server. When you are able to restore or replace the secondary server, proceed as explained in How to Configure HA Between the Primary and Secondary Servers, on page 815.

How to Replace the Primary Server

Under normal circumstances, the state of your primary server will be **Primary Active** and your secondary server will be **Secondary Syncing**. If the primary server fails for any reason, a failover to the secondary will take place (automatically or manually).

You may find that restoring full HA access requires you to reinstall the primary server using new hardware. If this happens, you can follow the steps below to bring up the new primary server without losing any data.

**Before you begin**

Make sure you have the password (authentication key) that was set when HA was configured on the secondary server. You will need it for this procedure.

---

<table>
<thead>
<tr>
<th>Primary HA State Transitions...</th>
<th>Secondary HA State Transitions...</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: HA not configured</td>
<td>From: Secondary Active</td>
</tr>
<tr>
<td>To: Primary Failback</td>
<td>To: Secondary Failback</td>
</tr>
<tr>
<td>To: Primary Failback</td>
<td>To: Secondary Post Failback</td>
</tr>
<tr>
<td>To: Primary Active</td>
<td>To: Secondary Syncing</td>
</tr>
</tbody>
</table>
How to Recover From Split-Brain Scenario

In a split-brain scenario, both the primary and secondary servers become active at the same time, perhaps due to a network outage or a link that temporarily goes down. However, because the primary server constantly checks the secondary server, when the connection is reestablished, the primary server will go down due to the secondary server being active.

The possibility of data loss always exists on the rare occasions when a “split-brain scenario” occurs. In this case, you can choose to save the newly added data on the secondary and forget the data that was added on the primary, as explained in the following steps.

Step 1 Once the network is up, and the secondary server is up, the primary will restart itself automatically, using its standby database. The HA status of the primary server will be, first, “Primary Failover” transitioning to “Primary Syncing”. You can verify this by logging on to the primary server’s Health Monitor web page.

Step 2 Once the primary server’s status is “Primary Syncing, confirm that a user can log into the secondary server’s Cisco EPN Manager page using the web browser (for example, https://server-ip-address:443). Do not proceed until you have verified this.

Step 3 Once access to the secondary is verified, initiate a failback from the secondary server's Health Monitor web page (see Trigger Failback, on page 829 ). You can continue to perform monitoring activities on the secondary server until the switchover to the primary is completed.

Secondary Server Goes Down

In this scenario, the secondary server is acting as a standby server and it goes down.

To get the secondary server up and running again:

Step 1 Power on the secondary server.

Step 2 Start Cisco EPN Manager on the secondary server.

Step 3 On the primary server, verify that the primary server's HA status changes from "Primary Lost Secondary" to "Primary Active." Go to Administration > Settings > High Availability > HA Configuration.

Step 4 Log into the secondary server's Health Monitor page by entering the following URL in your browser: https://serverIP:8082.

Step 5 Verify that the secondary server's HA status changes from "Secondary Lost Primary" to "Secondary Syncing." No further action is required once the above statuses are displayed. However, if the HA status does not change, the secondary server cannot be recovered automatically. In this case, continue with the following steps.

Step 6 Remove the HA configuration on the primary server. Go to Administration > Settings > High Availability > HA Configuration and click Remove.

Step 7 Register the secondary server with the primary server. See How to Configure HA Between the Primary and Secondary Servers, on page 815.

If HA registration is successful, no further action is required. However, if HA registration is unsuccessful, it indicates that the secondary server might have suffered hardware/software loss. In this case, continue with the following steps.

Step 8 Remove the HA configuration on the primary server.

Step 9 Reinstall the secondary server with the same release and patches (if any) as the primary server.
Step 10
Register the secondary server with the primary server. See How to Configure HA Between the Primary and Secondary Servers, on page 815.

---

How to Resolve Database Synchronization Issues

To resolve the database synchronization issue, when the primary server is in "Primary Active" state and the secondary server is in "Secondary Syncing" state, do the following:

**Step 1**
Remove HA, see Remove HA Via the CLI, on page 843 and Remove HA Via the GUI, on page 843.

**Step 2**
After both the primary and secondary servers reaches "HA not configured" state, perform the HA configuration. See Set Up High Availability, on page 814.

---

High Availability Reference Information

The following topics provide reference information on HA:

- HA Configuration Modes, on page 839
- HA States and Transitions, on page 840
- High Availability CLI Command Reference, on page 842
- Reset the HA Authentication Key, on page 842
- Remove HA Via the CLI, on page 843
- Remove HA Via the GUI, on page 843
- Remove HA During Upgrade, on page 843
- Remove HA During Restore, on page 844
- Use HA Error Logging, on page 828
- Reset the Server IP Address or Host Name, on page 844

---

HA Configuration Modes

HA configuration modes represent the overall status of the complete HA configuration (as opposed to HA states, which are specific to a server).

<table>
<thead>
<tr>
<th>Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HA Not Configured</td>
<td>HA is not configured on this server.</td>
</tr>
<tr>
<td>HA Initializing</td>
<td>HA configuration process between the primary and secondary servers has started.</td>
</tr>
<tr>
<td>HA Enabled</td>
<td>HA is enabled between the primary and secondary servers.</td>
</tr>
</tbody>
</table>
HA States and Transitions

The following table lists the HA states, including those that require no response from you. You can view these states from the HA Status page (Administration > Settings > High Availability > HA Status) or from the Health Monitor. For a list of HA events and instructions for enabling, disabling, and adjusting them, see Customize Server Internal SNMP Traps and Forward the Traps, on page 724.

<table>
<thead>
<tr>
<th>State</th>
<th>Server</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stand Alone</td>
<td>Both</td>
<td>HA is not configured on this server.</td>
</tr>
<tr>
<td>Primary Alone</td>
<td>Primary</td>
<td>Primary server has restarted after it lost the secondary server (only Health Monitor is running in this state).</td>
</tr>
<tr>
<td>HA Initializing</td>
<td>Both</td>
<td>HA configuration process between the primary and secondary server has started.</td>
</tr>
<tr>
<td>Primary Active</td>
<td>Primary</td>
<td>Primary server is now active and is synchronizing with the secondary server.</td>
</tr>
<tr>
<td>Primary Database Copy Failed</td>
<td>Primary</td>
<td>Restarted primary server detected a data gap, triggered a data copy from the active secondary server, and the database copy failed. When a primary server is restarted, it always checks to see if a data gap has occurred due to the primary server being down for 24 hours or more. This copy rarely fails but if it occurs, all attempts to failback to the primary are blocked until the database copy completes successfully. As soon as it does, the primary state is set to Primary Syncing.</td>
</tr>
<tr>
<td>Primary Failover</td>
<td>Primary</td>
<td>Primary server detected a failure.</td>
</tr>
<tr>
<td>Primary Failback</td>
<td>Primary</td>
<td>User-triggered failback is currently in progress.</td>
</tr>
<tr>
<td>Primary Lost Secondary</td>
<td>Primary</td>
<td>Primary server is unable to communicate with the secondary server.</td>
</tr>
<tr>
<td>Primary Preparing for Failback</td>
<td>Primary</td>
<td>Primary server has started up in standby mode after a failover (because the secondary server is still active). When the primary server is ready for failback, its state will be set to Primary Syncing.</td>
</tr>
<tr>
<td>Primary Syncing</td>
<td>Primary</td>
<td>Primary server is synchronizing the database and configuration files from the active secondary server. This occurs after a failover, when primary processes are brought up (and the secondary server is playing the active role).</td>
</tr>
<tr>
<td>Primary Uncertain</td>
<td>Primary</td>
<td>Primary server's application processes are not able to connect to its database.</td>
</tr>
<tr>
<td>Secondary Alone</td>
<td>Secondary</td>
<td>Primary server is not reachable from secondary server after a primary server restart.</td>
</tr>
</tbody>
</table>
Secondary Syncing  | Secondary  | Secondary server is synchronizing the database and configuration files from the primary server.
Secondary Active  | Secondary  | Failover from the primary server to the secondary server has completed successfully.
Secondary Lost Primary  | Secondary  | Secondary server is not able to connect to the primary server (occurs when the primary fails or network connectivity is lost).
For automatic failover, the secondary server will automatically move to the Secondary Active state. For Manual failover, you must trigger the failover to make the secondary server active (see Trigger Failover, on page 828).
Secondary Failover  | Secondary  | Failover triggered and is in progress.
Secondary Failback  | Secondary  | Failback triggered and database and file replication is in progress.
Secondary Post Failback  | Secondary  | Failback triggered; associated process stops and restarts are in progress. Database and configuration files have been replicated from the secondary server to the primary server. The primary server status will change to Primary Active, and the secondary server HA status will change to Secondary Syncing.
Secondary Uncertain  | Secondary  | Secondary server's application processes cannot connect to the server's database.

The following figure illustrates the primary server HA state changes.

This figure illustrates the secondary server HA state changes.
High Availability CLI Command Reference

The following table lists the CLI commands available for HA management. You must be logged in as the admin CLI user to use these commands. The output reflects the status of the server you are using. In other words, if you run `ncsha status` from the primary server, Cisco EPN Manager reports the status of the primary server.

**Table 63: High Availability Commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ncs ha ?</td>
<td>Displays the command usage message.</td>
</tr>
<tr>
<td>ncs ha authkey newAuthkey</td>
<td>Updates the authentication key to newAuthKey.</td>
</tr>
<tr>
<td>ncs ha remove</td>
<td>Removes the HA configuration.</td>
</tr>
<tr>
<td>ncs ha status</td>
<td>Displays the current status for HA.</td>
</tr>
</tbody>
</table>

**Reset the HA Authentication Key**

Users with administrator privileges can change the HA authentication key using the `ha authkey` command. You will need to ensure that the new authorization key meets the password standards.

**Step 1**
Log in to the primary server as a Cisco EPN Manager CLI admin user (see Establish an SSH Session With the Cisco EPN Manager Server, on page 716).

**Step 2**
Enter the following at the command line:

```
ha authkey newAuthKey
```
Where newAuthKey is the new authorization key.

Remove HA Via the GUI

The simplest method for removing an existing HA implementation is via the GUI, as shown in the following steps. You can also remove the HA setup via the command line.

Note that, to use this method, you must ensure that the primary Cisco EPN Manager server is currently in the “Primary Active” state. If for any reason the secondary server is currently active, perform a failback and then try to remove the HA configuration after the failback is complete and the secondary’s automatic restart has finished.

Step 1 Log in to the primary Cisco EPN Manager server with a user ID that has administrator privileges.
Step 2 Select Administration > Settings > High Availability > HA Configuration.
Step 3 Select Remove. Removing the HA configuration takes from 3 to 4 minutes.

Once the removal is complete, ensure that the HA configuration mode displayed on the page now reads “HA Not Configured”.

Remove HA Via the CLI

If for any reason you cannot access the Cisco EPN Manager GUI on the primary server, administrators can remove the HA setup via the command line, using the steps below.

Note that, to use this method, you must ensure that the primary Cisco EPN Manager server is currently in the “Primary Active” state. If for any reason the secondary server is currently active, perform a failback and then try to remove the HA configuration after the failback is complete and the secondary’s automatic restart has finished.

Step 1 Connect to the primary server via CLI. Do not enter “configure terminal” mode.
Step 2 Enter the following at the command line:

    admin# ncs ha remove.

Remove HA During Upgrade

To upgrade a Cisco EPN Manager implementation that uses HA, follow the steps below.

Step 1 Use the GUI to remove the HA settings from the primary server. See Remove HA Via the GUI, on page 843.
Step 2 Upgrade the primary server as needed.
Step 3 Re-install the secondary server using the current image.
Note that upgrading the secondary server from the previous version or a beta version is not supported. The secondary server must always be a fresh installation.

**Step 4** Once the upgrade is complete, perform the HA configuration process again.

---

### Remove HA During Restore

Cisco EPN Manager does not back up configuration settings related to high availability. If you are restoring an implementation that is using HA, you should only restore data to the primary server. The restored primary server will automatically replicate its data to the secondary server. If you try to run a restore on a secondary server, Cisco EPN Manager will generate an error message.

Follow these steps when restoring an implementation that uses HA:

1. Use the GUI to remove the HA settings from the primary server. See Remove HA Via the GUI, on page 843.
2. Restore data on the primary server. See Restore Cisco EPN Manager Data, on page 698.
3. When the restore process is complete, perform the HA configuration process again. See How to Configure HA Between the Primary and Secondary Servers, on page 815.

### Reset the Server IP Address or Host Name

Avoid changing the IP address or hostname of the primary or secondary server, if possible. If you must change the IP address or hostname, remove the HA configuration from the primary server before making the change. When finished, re-register HA.
Best Practices: Harden Your Cisco EPN Manager Security

Security hardening entails making adjustments to ensure that the following components optimize their security mechanisms:

- Cisco EPN Manager web server
- Cisco EPN Manager server
- Cisco EPN Manager storage system (local or external)
- Communication between Cisco EPN Manager and devices
- User authentication system (local or external)
- Time synchronizing system that use Network Time Protocol (NTP)

This appendix will first cover a few core security concepts that administrators should know about. It will then cover the specific tasks that need to be completed in order to optimize Cisco EPN Manager security.

- Core Security Concepts, on page 845
- Cisco EPN Manager Security Hardening Overview, on page 847
- Harden the Cisco EPN Manager Web Server, on page 848
- Harden the Cisco EPN Manager Server, on page 851
- Harden Your Cisco EPN Manager Storage, on page 853

Core Security Concepts

If you are an administrator and are looking to optimize the security of your Cisco EPN Manager product, you should have a good understanding of the following security concepts.

HTTPS

Hypertext Transfer Protocol Secure (HTTPS) uses Secure Sockets Layer (SSL) or its subsequent standardization, Transport Layer Security (TLS), to encrypt the data transmitted over a channel. Several vulnerabilities have been found in SSL, so Cisco EPN Manager now supports TLS only.
TLS is loosely referred to as SSL often, so we will also follow this convention.

SSL employs a mix of privacy, authentication, and data integrity to secure the transmission of data between a client and a server. To enable these security mechanisms, SSL relies upon certificates, private-public key exchange pairs, and Diffie-Hellman key agreement parameters.

SSL Certificates

SSL certificates and private-public key pairs are a form of digital identification for user authentication and the verification of a communication partner’s identity. Certificate Authorities (CAs), such as VeriSign and Thawte, issue certificates to identify an entity (either a server or a client). A client or server certificate includes the name of the issuing authority and digital signature, the serial number, the name of the client or server that the certificate was issued for, the public key, and the certificate's expiration date. A CA uses one or more signing certificates to create SSL certificates. Each signing certificate has a matching private key that is used to create the CA signature. The CA makes signed certificates (with the public key embedded) readily available, enabling anyone to use them to verify that an SSL certificate was actually signed by a specific CA.

In general, setting up certificates in both High Availability (HA) and non-HA environments involves the following steps:

1. Generating an identity certificate for a server.
2. Installing the identity certificate on the server.
3. Installing the corresponding root certificate on your client or browser.

The specific tasks you need to complete will vary depending on your environment.

Note the following:

- The start-stop sequencing of servers needs to be done carefully in HA environments.
- Non-HA environments, where a virtual IP address is configured, require the completion of a more complicated certificate request process.

1-Way SSL Authentication

This authentication method is used when a client needs assurance that it is connecting to the right server (and not an intermediary server), making it suitable for public resources like online banking websites. Authentication begins when a client requests access to a resource on a server. The server on which the resource resides then sends its server certificate (also known as an SSL certificate) to the client in order to verify its identity. The client then verifies the server certificate against another trusted object: a server root certificate, which must be installed on the client or browser. After the server has been verified, an encrypted (and therefore secure) communication channel is established. At this point, the Cisco EPN Manager server prompts for the entry of a valid username and password in an HTML form. Entering user credentials after an SSL connection is established protects them from being intercepted by an unauthorized party. Finally, after the username and password have been accepted, access is granted to the resource residing on the server.
A client might need to store multiple server certificates to enable interaction with multiple servers.

To determine whether you need to install a root certificate on your client, look for a lock icon in your browser’s URL field. If you see this icon, this generally indicates that the necessary root certificate has already been installed. This is usually the case for server certificates signed by one of the bigger Certifying Authorities (CAs), because root certificates from these CAs are included with popular browsers.

If your client does not recognize the CA that signed a server certificate, it will indicate that the connection is not secure. This is not necessarily a bad thing. It just indicates that the identity of the server you want to connect has not been verified. At this point, you can do one of two things: First, you can install the necessary root certificate on your client or browser. A lock icon in your browser’s URL field will indicate the certificate was installed successfully. And second, you can install a self-signed certificate on your client. Unlike a root certificate, which is signed by a trusted CA, a self-signed certificate is signed by the person or entity that created it. While you can use a self-signed certificate to create an encrypted channel, understand that it carries an inherent amount of risk because the identity of the server you are connected with has not been verified.

**Cisco EPN Manager Security Hardening Overview**

Hardening Cisco EPN Manager security requires completion of the following tasks:

(During installation)

- Configuring HTTPS and setting up 1-way SSL authentication for standalone servers and HA environments
- Shutting down insecure and unused ports
- Configuring network firewalls
- Configuring external authentication

(Post installation)

- Updating certificates in response to changes (like setting a new hostname or IP address)
- Hardening the Cisco EPN Manager server, as needed
Although your primary source of information is your Cisco representative, who can provide server hardening guidance specific to your deployment, you can also follow the steps listed below to secure Cisco EPN Manager.

<table>
<thead>
<tr>
<th>Hardening Procedure</th>
<th>The procedure hardens:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make Web Server Connectivity Secure By Using HTTPS, on page 848</td>
<td>Cisco EPN Manager web server</td>
</tr>
<tr>
<td>Set Up Certificate-Based Authentication for Web Clients, on page 848</td>
<td></td>
</tr>
<tr>
<td>Configure and Manage OCSP on the Server, on page 851</td>
<td></td>
</tr>
<tr>
<td>Disable Insecure Ports and Services, on page 852</td>
<td>Cisco EPN Manager server</td>
</tr>
<tr>
<td>Use SNMPv3 to Harden Communication Between Cisco EPN Manager and Devices, on page 677</td>
<td></td>
</tr>
<tr>
<td>Set Up External Authentication Using the CLI, on page 677</td>
<td></td>
</tr>
<tr>
<td>Disable Accounts Not Needed for Day-to-Day Operations, on page 853</td>
<td></td>
</tr>
<tr>
<td>Harden NTP, on page 680</td>
<td></td>
</tr>
<tr>
<td>Harden Your Cisco EPN Manager Storage, on page 853</td>
<td>Cisco EPN Manager storage system (local or external)</td>
</tr>
</tbody>
</table>

**Harden the Cisco EPN Manager Web Server**

To harden the Cisco EPN Manager web server, do the following:

1. Make Web Server Connectivity Secure By Using HTTPS, on page 848
2. Set Up Certificate-Based Authentication for Web Clients, on page 848
3. Configure a Custom OCSP Responder on the Server, on page 851

**Make Web Server Connectivity Secure By Using HTTPS**

The Cisco EPN Manager web server should be configured to use HTTPS instead of HTTP. This protects the systems that connect to the Cisco EPN Manager web server and also avoids the possibility of any client indirectly intruding into the web server and other participating systems. HTTPS requires using a Certificate Authority (CA) certificate in the web server and appropriate SSL mechanisms. For information on how to set this up, see Set Up HTTPS to Secure the Connectivity of the Web Server, on page 705.

**Set Up Certificate-Based Authentication for Web Clients**

For higher-level security, the Cisco EPN Manager server should authenticate clients by using certificate-based authentication. With this form of authentication, Cisco EPN Manager first validates the client’s associated certificate to ensure that the client is authentic and then it validates the username and password. This mechanism prevents unauthorized machines (that is, machines for which no certificate exists) to connect with the web server. Cisco EPN Manager implements this feature using the Online Certificate Status Protocol (OCSP).
The certificate(s) discussed in this topic uniquely identify the clients. This is different from the certificate for the web server, which was used to set up HTTPS operation. While this procedure is similar to the procedure for generating CER files for web server certificates, it is not exactly the same. You might need to use other tools (such as OpenSSL). In addition, there are different methods for generating CA certificate files. If you need assistance, contact your Cisco representative.

To configure certificate-based authentication:

**Step 1** Generate the client certificate files using a CA, which normally involves the following steps:

a) Generate the public key.
b) Generate the CSR file containing the public key.
c) Submit the CSR file to a CA to get the certificate file(s).
d) If you receive multiple files, do not concatenate the files to make a single CER/PEM file. Instead:
   • Give the Client certificate file to the application user to keep in the client machine.
   • Keep the Root and all Intermediate CA certificates. You will import them into the server in Step 4.

**Note** You should get these certificates from the root and intermediate CA servers. Do not use any files received from a non-trusted source.

**Note** Do not import the Client CA certificate into the web server. Keep that file with the client machine—for example, on an insertable card, a hardware or software token device, and so forth. When the client browser tries to connect to the Cisco EPN Manager web server, the web server instructs the client browser to ask for the Client certificate. The user must provide the Client certificate, and then enter their username and password.

**Step 2** Log in to the Cisco EPN Manager server using the command line, as explained in Establish an SSH Session With the Cisco EPN Manager Server, on page 716. Do not enter config mode.

**Step 3** Import the Root CA and Intermediate CA certificate files, one at a time, into the Cisco EPN Manager web server.

a) Import the Root CA certificate file with this command:

```
ncs key importcacert aliasName rootCACertFile repository repoName
```

Where:

• `aliasName` is the short name supplied for the CA certificate.
• `rootCACertFile` is the Root CA certificate filename.
• `repoName` is the location of the Cisco EPN Manager repository where the certificate file is hosted.

**Note** Note that this command is very different from the command used to apply the server certificate.

b) Import the Intermediate CA certificate file with this command:

```
ncs key importcacert aliasName intermediateCACertFile repository repoName
```

Where:

• `intermediateCACertFile` is the Intermediate CA certificate filename.
Step 4

Restart the server(s). The procedure you should follow depends on whether your deployment is configured for high availability.

**For deployments without high availability**, restart the Cisco EPN Manager server to apply the changes.

`ncs stop
ncs start`

**For deployments with high availability**, follow these steps, being sure to restart the servers in the correct order.

a) On the secondary server, log in as the Cisco EPN Manager CLI admin user and stop the server:

```
n cs stop
```

*Note* Do not restart the secondary server until you reach Step 5(e).

b) Verify that the secondary server is stopped.

c) On the primary server, log in as the Cisco EPN Manager CLI admin user and stop the server:

```
n cs stop
```

*Note* Do not restart the primary server until you reach Step 5(f).

d) Verify that the primary server is stopped.

e) On the secondary server, run the following commands:

1. Run the `ncs start` command to restart the server.
2. Verify that the secondary server has restarted.
3. Run the `ncs status` command and verify that the Health Monitor process is running.
4. Run the `ncs ha status` command and verify that the HA status of the secondary server is `Secondary Lost Primary`.

f) On the primary server, run the following commands:

1. Run the `ncs start` command to restart the server.
2. Verify that the primary server has restarted.
3. Run the `ncs status` command and make sure that the Health Monitor process and other processes have restarted.

Once all the processes on the primary server are up and running, HA registration is automatically triggered between the secondary and primary servers (and an email is sent to the registered email addresses). This normally completes after a few minutes.

g) Verify the HA status on the primary and secondary servers by running the `ncs ha status` command on both servers. You should see the following:

- The primary server state is **Primary Active**.
- The secondary server state is **Secondary Syncing**.
Configure and Manage OCSP on the Server

Online Certificate Status Protocol (OCSP) enables certificate-based authentication for web clients using OCSP responders. Typically, the OCSP responder URL is read from the certificate's Authority Information Access (AIA). As a failover mechanism, configure the OCSP responder URL on the Cisco EPN Manager server.

Configure a Custom OCSP Responder on the Server

To configure a custom OCSP responder URL on the Cisco EPN Manager server:

**Step 1**
Log in to the Cisco EPN Manager server using the command line, as explained in Establish an SSH Session With the Cisco EPN Manager Server, on page 716. Do not enter config mode.

**Step 2**
Enter the following command to enable client certificate authentication:
```
ocsp responder custom enable
```

**Step 3**
Enter the following command to set the custom OCSP responder URL:
```
ocsp responder set url responderNumber responderURL
```
Where:
- `responderNumber` is the number of the OCSP responder you want to define (for example, 1 or 2).
- `responderURL` is the URL of the OCSP responder, as taken from the client CA certificate.

Delete a Custom OCSP Responder from the Server

To delete an existing custom OCSP responder defined on the Cisco EPN Manager server:

**Step 1**
Execute the `show security-status` command to view the custom OCSP responders that are currently configured on the server, and identify the number of the responder you want to delete.

**Step 2**
Delete the OCSP responder from the server:
```
ocsp responder clear url responderNumber
```

Harden the Cisco EPN Manager Server

Follow these steps to harden the Cisco EPN Manager server.

1. Disable Insecure Ports and Services, on page 852
2. Use SNMPv3 to Harden Communication Between Cisco EPN Manager and Devices, on page 677
3. Set Up External Authentication Using the CLI, on page 677
4. Disable Accounts Not Needed for Day-to-Day Operations, on page 853
5. Harden NTP, on page 680
Disable Insecure Ports and Services

As a general policy, any ports that are not needed and are not secure should be disabled. You need to first know which ports are enabled, and then decide which of these ports can be safely disabled without disrupting the normal functioning of Cisco EPN Manager for your deployment. You can do this by listing the ports that are open and comparing it with a list of ports that are safe to disable.

You can get this list of ports which are safe to disable from Cisco Evolved Programmable Network Manager Installation Guide, which lists the ports and services used by Cisco EPN Manager.

Follow the procedure below to find out which ports are enabled.

---

**Step 1**
Log into Cisco EPN Manager using the command line, as explained in Establish an SSH Session With the Cisco EPN Manager Server, on page 716. Do not enter config mode.

**Step 2**
The show security-status command displays the server's currently open (enabled) TCP/UDP ports, the status of other services the system is using, and other security-related configuration information. You will see output similar to the following:

```
show security-status
Open TCP Ports 22 443 1522 8082
Open UDP Ports 162 514 9991
FIPS Mode enabled
TFTP Service disabled
FTP Service disabled
JMS port (61617) disabled
Root Access disabled
Client Auth enabled
OCSP Responder1 http://209.165.200.224/ocsp
```

**Step 3**
Check the Cisco Evolved Programmable Network Manager Installation Guide for the table of ports used by Cisco EPN Manager, and see if your ports are listed in that table. That table will help you understand which services are using the ports, and which services you do not need—and thus can be safely disabled. In this case, safe means you can safely disable the port without any adverse effects to the product.

*Note* If you are not sure whether you should disable a port or service, contact your Cisco representative.

**Step 4**
Disable the insecure ports using the Cisco EPN Manager GUI.

This example disables FTP and TFTP, which are not secure protocols and should be disabled (use SFTP or SCP instead). TFTP and FTP are typically used to transfer firmware or software images to and from network devices and Cisco EPN Manager.

a) Log in to Cisco EPN Manager with a user ID that has Administrator privileges.
b) Choose **Administration > Settings > System Settings**, then choose **General > Server**.
c) Under **FTP** and **TFTP**, select **Disable**, then click **Save**.
d) Restart Cisco EPN Manager. See Stop and Restart Cisco EPN Manager, on page 719.

**Step 5**
If you have firewalls in your network, configure the firewalls to only allow traffic that is needed for Cisco EPN Manager to operate. For more information, refer to the Cisco Evolved Programmable Network Manager Installation Guide (specifically, the information about ports that are used by Cisco EPN Manager and suggested firewall configurations). If you need further help, contact your Cisco representative.
Disable Accounts Not Needed for Day-to-Day Operations

The Cisco EPN Manager web GUI root user should be disabled after creating at least one other web GUI user that has root privileges. See Disable and Enable the Web GUI root User, on page 747.

Harden Your Cisco EPN Manager Storage

We recommend that you secure all storage elements that will participate in your Cisco EPN Manager installation, such as the database, backup servers, and so on.

Contact your Cisco representative for more information about hardening your internal or external storage. In the case of external storage, also contact your storage vendor.

If you ever uninstall or remove Cisco EPN Manager, make sure that all VM-related files that might contain sensitive data are digitally shredded (as opposed to simply deleted).

Harden NFS-Based Storage

Since NFS does not have built-in security, you must implement as many of the following security measures as possible to secure the NFS server:

• Set up a firewall in front of the NFS server—To do this practically, tie down the ports that NFS will use in various configuration files and then specify those ports in the firewall configurations.

• Use a port mapper—On the NFS server, only allow NFS transactions that involve specific IP addresses.

• To prevent attacks via a compromised DNS, only specify IP addresses (and not domain names) when configuring NFS.

• When setting up the export of folders, use the root_squash option in the /etc/exports file.

• When configuring the /etc/exports file, use the secure option.

• When configuring the backup staging and storage folders, use the nosuid and noexec mount options.

Note: It is not mandatory to configure a staging folder.

• For the storage folder (and optional staging folder), configure a file access permission value of 755 (which grants all users read and write privileges) and set user id 65534 (the user nobody, who does not have any system privileges) as the owner.

• Tunnel NFS traffic either through SSH or SSL/TLS. For SSH, use RSA key-based authentication instead of user authentication.

Do not rely on just one of these measures to secure your NFS-based storage. Your best bet is to implement the combination of measures that best suits your situation. Also keep in mind that this list is not an exhaustive one. To achieve a higher level of confidence when hardening your storage, we recommend that you discuss your situation with a Linux system admin and a security expert beforehand.
Best Practices: Harden Your Cisco EPN Manager Security

Harden NFS-Based Storage
Icon and State Reference

- Device Reachability and Admin States, on page 855
- Port or Interface States, on page 857
- Circuit or VC States, on page 858
- Link Serviceability States, on page 864
- Link Characteristics, on page 864
- Equipment Operational States (Chassis View), on page 865
- Alarm Severity Icons, on page 865
- Device Type Icons, on page 866
- Circuit or VC Network Topology Overlay Icons, on page 868

Device Reachability and Admin States

Device Reachability State—Indicates whether Cisco EPN Manager can communicate with the device using all configured protocols.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Device Reachability State</th>
<th>Description</th>
<th>Troubleshooting</th>
</tr>
</thead>
<tbody>
<tr>
<td>✔</td>
<td>Reachable</td>
<td>Cisco EPN Manager can reach the device using SNMP, or the NCS 2K device using ICMP.</td>
<td>—</td>
</tr>
<tr>
<td>🚨</td>
<td>Ping reachable</td>
<td>Cisco EPN Manager can reach the device using Ping, but not via SNMP.</td>
<td>Although ICMP ping is successful, check for all possible reasons why SNMP communication is failing. Check that device SNMP credentials are the same in both the device and in Cisco EPN Manager, whether SNMP is enabled on the device, or whether the transport network is dropping SNMP packets due to reasons such as mis-configuration, etc. See Change Basic Device Properties, on page 287.</td>
</tr>
</tbody>
</table>
Verify that the physical device is operational and connected to the network.

Cisco EPN Manager cannot reach the device using Ping.

Unreachable

Table 65: Device Admin State

<table>
<thead>
<tr>
<th>Icon</th>
<th>Device Admin State</th>
<th>Description</th>
<th>Troubleshooting</th>
</tr>
</thead>
<tbody>
<tr>
<td>![x]</td>
<td>Managed</td>
<td>Cisco EPN Manager is actively monitoring the device.</td>
<td>Not Applicable.</td>
</tr>
<tr>
<td>![x]</td>
<td>Maintenance</td>
<td>Cisco EPN Manager is checking the device for reachability but is not processing traps, sylogs, or TL1 messages.</td>
<td>To move a device back to Managed state, see Move a Device To and From Maintenance State, on page 57.</td>
</tr>
</tbody>
</table>
| ![x] | Unmanaged         | Cisco EPN Manager is not monitoring the device. | In the Network Devices table, locate the device and click the "i" icon next to the data in the Last Inventory Collection Status column. The popup window will provide details and troubleshooting tips. Typical reasons for collection problems are:  
  • Device SNMP credentials are incorrect.  
  • The Cisco EPN Manager deployment has exceeded the number of devices allowed by its license.  
  • A device is enabled for switch path tracing only.  
If a device type is not supported, its Device Type will be Unknown. You can check if support for that device type is available from Cisco.com by choosing Administration > Licenses and Software Updates > Software Update and then clicking Check for Updates. |
| ![?] | Unknown           | Cisco EPN Manager cannot connect to the device. | Check the device. |

Device Admin State—Indicates the configured state of the device (for example, if an administrator has manually shut down a device, as opposed to a device being down because it is not reachable by Ping).

Unknown

Check the device.
Port or Interface States

**Port or Interface Primary States**—Conveys the most important state information for a port or interface by combining the admin and operational states. The Multilayer Trace displays either a port's primary state or alarm status. For the Chassis View, if an element does not support the changing of color to indicate a state change, you can still get the state change information from the alarm that is generated.

<table>
<thead>
<tr>
<th>Port or Interface Primary State</th>
<th>Icon</th>
<th>Admin Status</th>
<th>Operational State</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unknown</td>
<td><img src="image" alt="Unknown Icon" /></td>
<td>Unknown</td>
<td>Unknown</td>
</tr>
<tr>
<td>Down</td>
<td><img src="image" alt="Down Icon" /></td>
<td>Up</td>
<td>Down</td>
</tr>
<tr>
<td>Test</td>
<td><img src="image" alt="Test Icon" /></td>
<td>Test</td>
<td>—</td>
</tr>
<tr>
<td>Admin Down</td>
<td><img src="image" alt="Admin Down Icon" /></td>
<td>Admin Down</td>
<td>—</td>
</tr>
<tr>
<td>Up</td>
<td><img src="image" alt="Up Icon" /></td>
<td>Up</td>
<td>Up</td>
</tr>
<tr>
<td>Auto Up</td>
<td><img src="image" alt="Auto Up Icon" /></td>
<td>Up</td>
<td>Auto Up</td>
</tr>
</tbody>
</table>

**Note**

If there is an alarm associated with a port/interface, alarm icon will show up, port icon will not show.

<table>
<thead>
<tr>
<th>Port or Interface Admin Status</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unknown</td>
<td><img src="image" alt="Unknown Icon" /></td>
<td>Port or interface admin status is unknown. There is no response (or insufficient response) from the device.</td>
</tr>
<tr>
<td>Admin Down</td>
<td><img src="image" alt="Admin Down Icon" /></td>
<td>Port or interface was manually shut down by the administrator.</td>
</tr>
<tr>
<td>Up</td>
<td><img src="image" alt="Up Icon" /></td>
<td>Port or interface is enabled by the administrator.</td>
</tr>
<tr>
<td>Test</td>
<td><img src="image" alt="Test Icon" /></td>
<td>Port or interface is being tested by the administrator.</td>
</tr>
</tbody>
</table>

**Port or Interface Operational State**—Conveys the port or interface's running state and whether it is working properly.

<table>
<thead>
<tr>
<th>Port or Interface Operational State</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
</table>

Circuit or VC States

**Circuit or VC Primary States**—Conveys the most important state information for a circuit, in this order: Serviceability, Discovery, Alarm, Provisioning. It is normally shown in the first column of a circuit or VC table.

<table>
<thead>
<tr>
<th>Circuit or VC Primary State</th>
<th>Icon</th>
<th>Serviceability</th>
<th>Discovery</th>
<th>Alarm</th>
<th>Provisioning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Missing</td>
<td></td>
<td>—</td>
<td>Missing</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Down</td>
<td></td>
<td>Down</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Critical</td>
<td></td>
<td>—</td>
<td>—</td>
<td>Critical</td>
<td>—</td>
</tr>
<tr>
<td>Major</td>
<td></td>
<td>—</td>
<td>—</td>
<td>Major</td>
<td>—</td>
</tr>
<tr>
<td>Minor</td>
<td></td>
<td>—</td>
<td>—</td>
<td>Minor</td>
<td>—</td>
</tr>
<tr>
<td>Partially Down</td>
<td></td>
<td>Partial</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Admin Down</td>
<td></td>
<td>Admin Down</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Partially Discovered</td>
<td></td>
<td>—</td>
<td>Partial</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Failed</td>
<td></td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>(Create, modify, or delete) failed</td>
</tr>
<tr>
<td>In progress</td>
<td></td>
<td>—</td>
<td>—</td>
<td>—</td>
<td>(Create, modify, or delete) in progress</td>
</tr>
<tr>
<td>Warning</td>
<td></td>
<td>—</td>
<td>Warning</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Up</td>
<td></td>
<td>Up</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Auto Up</td>
<td></td>
<td>Auto Up</td>
<td>—</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Info</td>
<td></td>
<td>—</td>
<td>—</td>
<td>Info</td>
<td>—</td>
</tr>
</tbody>
</table>
Circuit or VC Serviceability State— This value is a combination of the circuit or VC's admin and operational states. The admin state is shown because it impacts service operability. For optical circuits, the admin state also determines whether the Activate and Deactivate actions are available. The operational state is shown to quickly identify whether a service is working or not.

<table>
<thead>
<tr>
<th>Circuit or VC Serviceability State</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Admin Down</td>
<td>✗</td>
<td>Circuit or VC manually shut down by the administrator.</td>
</tr>
<tr>
<td>Down</td>
<td>✗</td>
<td>Circuit or VC is operationally down and administratively up.</td>
</tr>
<tr>
<td>Up</td>
<td>🔄</td>
<td>Circuit or VC is operationally and administratively up.</td>
</tr>
<tr>
<td>Auto Up</td>
<td>🔄</td>
<td>Circuit or VC is operationally auto up and administratively up. Only certain devices support the Auto Up operational state.</td>
</tr>
<tr>
<td>Unavailable</td>
<td>🗑</td>
<td>Circuit or VC has not been discovered yet, or its operational status is unavailable.</td>
</tr>
<tr>
<td>Partial</td>
<td>🏷</td>
<td>Circuit/VC operational or administrative state is partial.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Partial admin state—The circuit or VC has a mixed administrative request (to activate some service resources and deactivate others), has a mix of resources that are administratively up and down, or has resources whose operational state is unavailable.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Partial operational state—The circuit or VC has a mix of some active and deactivated resources, or the operational state for some of its resources are unavailable.</td>
</tr>
</tbody>
</table>

Following table provides details of the serviceability states of Circuits/VCs under various scenarios:

<table>
<thead>
<tr>
<th>Technology</th>
<th>Service Type</th>
<th>Scenario</th>
<th>Serviceability State</th>
</tr>
</thead>
<tbody>
<tr>
<td>Service Type</td>
<td>Description</td>
<td>State</td>
<td></td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>---------</td>
<td></td>
</tr>
<tr>
<td>Carrier Ethernet</td>
<td>EPL, EVPL, Access EPL, and Access EVPL</td>
<td>Up</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If the operational state of the endpoints (service instance / sub-interface), cross connects, and pseudowire participating in the service is up</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>If the admin state of both, the source and destination endpoints (service instance / sub-interface) participating in the service is down</td>
<td>Admin Down</td>
<td></td>
</tr>
<tr>
<td></td>
<td>In all the other scenarios, when at least one endpoint (service instance / sub-interface), cross connect, or the pseudowire participating in the service is down</td>
<td>Down</td>
<td></td>
</tr>
<tr>
<td>EP-LAN, EVP-LAN, EP-Tree, and EVP-Tree</td>
<td>If all the endpoints (service instance / sub-interface), bridge domains, VFLs, and pseudowires participating in the service are up</td>
<td>Up</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If the operational state of at least two endpoints (service instance / sub-interface) participating in the service are up and the rest of the endpoints are down</td>
<td>Partial</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If the admin state of all the endpoints (service instance / sub-interface) participating in the service is down</td>
<td>Admin Down</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If the operational state of at least one endpoint (service instance / sub-interface) participating in the service is up and the rest of the endpoints are down</td>
<td>Down</td>
<td></td>
</tr>
<tr>
<td>Service Type</td>
<td>Interface Type</td>
<td>State Conditions and Actions</td>
<td></td>
</tr>
<tr>
<td>----------------------</td>
<td>--------------------------</td>
<td>-----------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
</tbody>
</table>
| Circuit Emulation    | All service types        | If the operational state of the endpoints (cemGroup), underlying TDM controller, cross connect, and pseudowire participating in the service are up:  
  If the admin state of both, the source and destination endpoints (cemGroup) participating in the service is down:  
  In all other scenarios, when the operational state of one of the endpoints (cemGroup), underlying TDM controller, cross connect, and pseudowire participating in the service is down:  
  Up
| MPLS                 | Unidirectional TE Tunnel | If the operational state of the tunnel interface is up:  
  If the admin state of the tunnel interface is down:  
  In all other scenarios, when the operational state of the tunnel is down:  
  Up
| Bidirectional TE Tunnel | If the operational states of the interfaces on both ends of the tunnel are up:  
  If the admin states of the interfaces on both ends of the tunnel is down:  
  In all other cases, when the operational state of the tunnel interface is down:  
  Up
<table>
<thead>
<tr>
<th>Icon and State Reference</th>
<th>Icon and State Reference</th>
</tr>
</thead>
</table>

| Serial | RS232, RS422, and RS485 | If the operational state of the endpoints (channelGroup), underlying Serial interface, cross connect, and pseudowire participating in the service are up | UP |
|        |                         | If the admin state of both, the source and destination endpoints (channelGroup) participating in the service is down | Admin Down |
|        |                         | If the admin state of either source or destination endpoint (channelGroup) is down | |
|        |                         | In all the other scenarios, when the operational state of one of the endpoint (channelGroup), underlying Serial interface, cross connect, and pseudowire participating in the service is down | Down |

| Raw Socket | If server and all its associated client sessions are up | Up |
|            | If server is up and all its associated client sessions are down | Down |
|            | If the admin state of both, the source and destination endpoints (channelGroup) participating in the service is down | Admin Down |
|            | If the admin state of a server or admin state of all the participating clients are down | |
|            | If server and all its associated client sessions are down | Down |
If server is up and if any one of its associated clients is up | Partial
---|---
Layer 3 VPN | If the operational state of all the endpoints (sub-interface, BDI, and BVI) participating in the service is up | Up
| If the operational state of at least two endpoints (sub-interface, BDI, and BVI) participating in the service are up and the rest of the endpoints are down | Partial
| If the admin state of all the endpoints (sub-interface, BDI, and BVI) participating in the service is down | Admin Down
| If the operational state of at least one endpoint (sub-interface, BDI, and BVI) participating in the service is up and the rest of the endpoints are down. | Down

**Circuit or VC Discovery State**—Represents the latest state and structure of a service and its components, as discovered from the network. Having a Discovered version means that the application is actually monitoring the service itself, e.g. it can define meaningful operational and performance data.

<table>
<thead>
<tr>
<th><strong>Circuit or VC Discovery State</strong></th>
<th><strong>Icon</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Partial</td>
<td><img src="image" alt="Icon" /></td>
<td>Circuit or VC partially discovered by Cisco EPN Manager; not all of its expected entities have been discovered.</td>
</tr>
<tr>
<td>Full</td>
<td><img src="image" alt="Icon" /></td>
<td>Circuit or VC fully discovered by Cisco EPN Manager, so Cisco EPN Manager can monitor the service and provide meaningful operational and performance data.</td>
</tr>
<tr>
<td>Missing</td>
<td><img src="image" alt="Icon" /></td>
<td>Circuit or VC not yet discovered by Cisco EPN Manager (though it may have been provisioned).</td>
</tr>
</tbody>
</table>

**Circuit or VC Provisioning State**—Represents whether there is a provisioning intent for a circuit or VC and, if so, its status. If a reconciliation report has been generated, the state of the reconcile action is reflected.
### Link Serviceability States

<table>
<thead>
<tr>
<th>Serviceability State</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Admin Down</td>
<td>![Admin Down Icon]</td>
<td>Link was purposefully shut down by the administrator.</td>
</tr>
<tr>
<td>Down</td>
<td>![Down Icon]</td>
<td>Link is down (but it should not be).</td>
</tr>
<tr>
<td>Up</td>
<td>![Up Icon]</td>
<td>Link is up and traffic is passing through the link.</td>
</tr>
<tr>
<td>Auto Up</td>
<td>![Auto Up Icon]</td>
<td>Link is up because it detected a signal (this state is only supported by optical devices).</td>
</tr>
<tr>
<td>Unavailable</td>
<td>![Unavailable Icon]</td>
<td>Link is not discovered yet or its status is unavailable.</td>
</tr>
</tbody>
</table>
| Partial              | ![Partial Icon] | Link has a mismatch between requests, resources, or resource states. Examples:  
  - Link is processing a request to activate some service resources and deactivate others.  
  - Link has some active and some deactivated resources.  
  - Some link resources are up and others are down.  
  - The state for one of the link's resources is not known. |

### Link Characteristics

The following table describes the different types of links used to represent the connection between devices in the Topology Map view of Cisco EPN Manager:

<table>
<thead>
<tr>
<th>Link Type</th>
<th>Description</th>
</tr>
</thead>
</table>

---

Cisco Evolved Programmable Network Manager 3.0 User and Administrator Guide
**Equipment Operational States (Chassis View)**

The equipment operational states represent the running state of the network element.

<table>
<thead>
<tr>
<th>Equipment Operational State</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>In Service</td>
<td>(none)</td>
<td>Equipment is operating properly.</td>
</tr>
<tr>
<td>Pre-provisioned</td>
<td>![Image]</td>
<td>(Cisco NCS 2000 and Cisco ONS devices only) Equipment has been configured but is not physical present in the chassis.</td>
</tr>
<tr>
<td>Failed/Disabled/Down/Out of Service/Out of Service Maintenance</td>
<td>![Image]</td>
<td>Equipment is not operating properly.</td>
</tr>
<tr>
<td>Unknown</td>
<td>![Image]</td>
<td>Equipment operational state is unknown. No response (or insufficient response) from the device.</td>
</tr>
</tbody>
</table>

**Alarm Severity Icons**

The table below lists the alarm colors and their respective severity levels for the icons displayed in various parts of the web GUI.

<table>
<thead>
<tr>
<th>Severity Icon</th>
<th>Description</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Image]</td>
<td>Critical alarm</td>
<td>Red</td>
</tr>
</tbody>
</table>
### Device Type Icons

Table below defines the icons used to represent different device types in the Topology and the Multi-layer Trace views in Cisco EPN Manager.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Switch Icon" /></td>
<td>Switch</td>
</tr>
<tr>
<td><img src="image" alt="Router Icon" /></td>
<td>Router</td>
</tr>
<tr>
<td><img src="image" alt="Router Aggregated Icon" /></td>
<td>Router Aggregated</td>
</tr>
<tr>
<td><img src="image" alt="Cisco NCS 6000 Device Icon" /></td>
<td>Cisco NCS 6000 device on which a Secure Domain Router (SDR) resides. The SDR's name is listed directly above the device's icon. <strong>Note</strong> There may be cases where the SDR label for a device that belongs to a cluster or user-defined group is not displayed (since auto-clustering is applied to devices based on their proximity).</td>
</tr>
</tbody>
</table>

### Severity Icon

<table>
<thead>
<tr>
<th>Severity Icon</th>
<th>Description</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Major Alarm Icon" /></td>
<td>Major alarm</td>
<td>Orange</td>
</tr>
<tr>
<td><img src="image" alt="Minor Alarm Icon" /></td>
<td>Minor alarm</td>
<td>Yellow</td>
</tr>
<tr>
<td><img src="image" alt="Warning Alarm Icon" /></td>
<td>Warning alarm</td>
<td>Light Blue</td>
</tr>
<tr>
<td><img src="image" alt="Alarm Cleared Icon" /></td>
<td>Alarm cleared; normal, OK</td>
<td>Green</td>
</tr>
<tr>
<td><img src="image" alt="Informational Alarm Icon" /></td>
<td>Informational alarm</td>
<td>Medium Blue</td>
</tr>
<tr>
<td><img src="image" alt="Indeterminate Alarm Icon" /></td>
<td>Indeterminate alarm</td>
<td>Dark Blue</td>
</tr>
<tr>
<td>Icon</td>
<td>Definition</td>
<td></td>
</tr>
<tr>
<td>------</td>
<td>------------</td>
<td></td>
</tr>
<tr>
<td><img src="router.png" alt="Router Icon" /></td>
<td>Router configured with an L3VPN service.</td>
<td></td>
</tr>
<tr>
<td><img src="switch.png" alt="Switch Aggregated Icon" /></td>
<td>Switch Aggregated</td>
<td></td>
</tr>
<tr>
<td><img src="access_point.png" alt="Access Point Icon" /></td>
<td>Access Point</td>
<td></td>
</tr>
<tr>
<td><img src="service_module.png" alt="Service Module Icon" /></td>
<td>Service Module</td>
<td></td>
</tr>
<tr>
<td><img src="ucsc.png" alt="UCS C-Series Icon" /></td>
<td>UCS C-Series</td>
<td></td>
</tr>
<tr>
<td><img src="nam.png" alt="NAM Blade Icon" /></td>
<td>NAM Blade</td>
<td></td>
</tr>
<tr>
<td><img src="group.png" alt="Group Icon" /></td>
<td>Group</td>
<td></td>
</tr>
<tr>
<td><img src="generic_device.png" alt="Generic Device Icon" /></td>
<td>Generic Device</td>
<td></td>
</tr>
<tr>
<td><img src="virtual_server.png" alt="Virtual Server Icon" /></td>
<td>Virtual Server</td>
<td></td>
</tr>
<tr>
<td><img src="wireless.png" alt="Wireless LAN Controller Icon" /></td>
<td>Wireless LAN Controller</td>
<td></td>
</tr>
</tbody>
</table>
### Circuit or VC Network Topology Overlay Icons

<table>
<thead>
<tr>
<th>Overlay Icon</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Source endpoint" /></td>
<td>Source endpoint</td>
</tr>
<tr>
<td><img src="image" alt="Destination endpoint" /></td>
<td>Destination endpoint</td>
</tr>
<tr>
<td><img src="image" alt="EVC or CEM service with local switching" /></td>
<td>EVC or CEM service with local switching</td>
</tr>
<tr>
<td><img src="image" alt="Endpoint included by the user during creation of the circuit." /></td>
<td>Endpoint included by the user during creation of the circuit.</td>
</tr>
<tr>
<td><img src="image" alt="Endpoint excluded by the user during the creation of the circuit." /></td>
<td>Endpoint excluded by the user during the creation of the circuit.</td>
</tr>
<tr>
<td><img src="image" alt="Endpoint with some ports that were either included or excluded during creation of the circuit. This endpoint contains multiple ports that are participating in various routes of the circuit." /></td>
<td>Endpoint with some ports that were either included or excluded during creation of the circuit. This endpoint contains multiple ports that are participating in various routes of the circuit.</td>
</tr>
<tr>
<td><img src="image" alt="E-TREE EVC endpoint that has been designated as a root." /></td>
<td>E-TREE EVC endpoint that has been designated as a root.</td>
</tr>
<tr>
<td><img src="image" alt="Selected endpoint." /></td>
<td>Selected endpoint.</td>
</tr>
<tr>
<td>Overlay Icon</td>
<td>Definition</td>
</tr>
<tr>
<td>--------------</td>
<td>------------</td>
</tr>
<tr>
<td><img src="image" alt="Hub Icon" /></td>
<td>Hub; If the hub and root are on the same device (VPLS scenario), the brown circle is combined with the root icon.</td>
</tr>
<tr>
<td><img src="image" alt="Link Included Icon" /></td>
<td>Link included during creation of the circuit.</td>
</tr>
<tr>
<td><img src="image" alt="Link Excluded Icon" /></td>
<td>Link excluded during creation of the circuit.</td>
</tr>
<tr>
<td><img src="image" alt="Endpoint Icon" /></td>
<td>Endpoint with some ports that were either included or excluded during creation of the circuit. This represents the aggregated link that contains multiple ports participating in various routes of the same circuit.</td>
</tr>
</tbody>
</table>
Cisco EPM Notification MIB

This appendix contains the CISCO-EPM-NOTIFICATION-MIB.

<table>
<thead>
<tr>
<th>SNMP Varbind</th>
<th>Data Type</th>
<th>Varbind OID</th>
<th>SNMP Varbind Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>cenAlarmVersion</td>
<td>SnmpAdminString</td>
<td>.1.36.1.499311.1.12.12</td>
<td>The release version of this MIB.</td>
<td>1.0</td>
</tr>
<tr>
<td>cenAlarmTimestamp</td>
<td>Timestamp</td>
<td>.1.36.1.499311.1.12.13</td>
<td>The time when the alarm was raised. Note: This is the number of seconds since Jan 1st 1970 (since epoch) in UTC.</td>
<td>1523608787</td>
</tr>
<tr>
<td>cenAlarmUpdatedTimestamp</td>
<td>Timestamp</td>
<td>.1.36.1.499311.1.12.14</td>
<td>Alarms persist over time and its value is updated automatically when field(s) changed. The updated time denotes a time. Each alarm is identified by the unique alarm instance ID, Foreexample, cenAlarmInstanceID.</td>
<td>1523608788</td>
</tr>
<tr>
<td>cenAlarmInstanceID</td>
<td>SnmpAdminString</td>
<td>.1.36.1.499311.1.12.15</td>
<td>The Unique Alarm Instance ID.</td>
<td>118509814</td>
</tr>
<tr>
<td>cenAlarmStatus</td>
<td>Integer</td>
<td>.1.36.1.499311.1.12.16</td>
<td>The alarm status indicates the status of the alarm in integer value.</td>
<td>Active=2, Cleared=3</td>
</tr>
<tr>
<td>cenAlarmStatusDefinition</td>
<td>SnmpAdminString</td>
<td>.1.36.1.499311.1.12.17</td>
<td>The short description of the status of the alarm. The string is formatted in ', ' tuples. The value is the same value that the 'cenAlarmStatus' attribute holds. Contains one line description of the alarm status generated.</td>
<td>2, ACTIVE3,CLEARED</td>
</tr>
</tbody>
</table>
## SNMP Varbind Description

<table>
<thead>
<tr>
<th>SNMP Varbind</th>
<th>Data Type</th>
<th>Varbind OID</th>
<th>SNMP Varbind Description</th>
<th>Example</th>
</tr>
</thead>
</table>
| cenAlarmType     | Integer   | .1.3.6.1.4.9.9311.1.1218 | • unknown(1) — When the value for this attribute could not be determined.  
• direct(2) — Denotes an alarm generated by a set of events where all events are reported by an observation(s) of a managed object.  
• indirect(3) — Denotes an alarm generated by a set of events where all events were deduced or inferred by the status of managed objects as determined by the network management system.  
• mixed(4) — Denotes an alarm generated by a set of events which were either direct or indirect. | 2       |
| cenAlarmCategory | Integer   | .1.3.6.1.4.9.9311.1.1219 | The category of the alarm generated represented in integer value.  
**Note** This integer field is not used in EPN Manager. Use cenAlarmCategoryDefinition instead, which is a string. | —       |
| cenAlarmCategoryDefinition | SnmpAdminString | .1.3.6.1.4.9.9311.1.12110 | The short description of the category of the alarm generated.  
The String is formatted in ',' tuples. The value is the same value that the 'cenAlarmCategory' attribute holds. contains one line description of the alarm category generated.  
For a list of alarm types, see the 'Alarm Name column in the following documents. These are for 2.1 (Derecho). For other versions, use cisco.com published documentation for the version that you need.  
Cisco Evolved Programmable Network Manager Supported SNMP Traps  
Cisco Evolved Programmable Network Manager Supported Syslogs  
Cisco Evolved Programmable Network Manager Supported TL1 Messages  
Cisco Evolved Programmable Network Manager Supported Alarms | "LINK_DOWN", "SWT_AUTH_FAIL", "LINK_UP" |
<table>
<thead>
<tr>
<th>SNMP Varbind</th>
<th>Data Type</th>
<th>Varbind OID</th>
<th>SNMP Varbing Description</th>
<th>Example</th>
</tr>
</thead>
</table>
| snmpAlarmServerType  | InetAddressType | .1.3.6.1.4.9.9.311.1.1.2.1.11 | The type of Internet address by which the server is reachable. The server is the server that is generating this trap.                                                                                                   | 0: unknown 
1: ipv4 
2: ipv6 |
| snmpAlarmServerAddress | InetAddress   | .1.3.6.1.4.9.9.311.1.1.2.1.12 | The IP Address or the DNS name of the Management Server that raised this alarm will be notified.                                                                                                                          | 10.127.101.145 |
| snmpMgmtObjectClass  | SnmpAdminString | .1.3.6.1.4.9.9.311.1.1.2.1.13 | The class of the managed object for which this alarm was generated. For example, Router, Switch, GateKeeper and VoicePort. For a list of categories, see the 'Category' column in the following documents. These are for 2.1 (Derecho). For other versions, use cisco.com published documentation for the version that you need. Cisco Evolved Programmable Network Manager Supported SNMP Traps Cisco Evolved Programmable Network Manager Supported Syslogs Cisco Evolved Programmable Network Manager Supported TL1 Messages Cisco Evolved Programmable Network Manager Supported Alarms | "Optical", "Carrier Ethernet" |
| snmpMgmtObjectId     | InetAddressType | .1.3.6.1.4.9.9.311.1.1.2.1.14 | The type of Internet address by which the managed object is reachable.                                                                                                                                                     | 0 : unknown 
1 : ipv4 
2 : ipv6 |
<p>| snmpMgmtObjectId     | InetAddress    | .1.3.6.1.4.9.9.311.1.1.2.1.15 | The IP Address or the DNS name of the Managed Object.                                                                                                                                                                      | 2465000204138172309121 |</p>
<table>
<thead>
<tr>
<th>SNMP Varbind</th>
<th>Data Type</th>
<th>Varbind OID</th>
<th>SNMP Varbing Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>cenAlarmDescription</td>
<td>OctetString</td>
<td>.1.3.6.1.4.9.9311.1.121.1.6</td>
<td>A detailed description of the alarm. For a list of alarm descriptions, see the 'Description/Probable Cause' column in the following documents. These are for 2.1 (Derecho). For other versions, use cisco.com published documentation for the version that you need. Cisco Evolved Programmable Network Manager Supported SNMP Traps Cisco Evolved Programmable Network Manager Supported Syslogs Cisco Evolved Programmable Network Manager Supported TL1 Messages Cisco Evolved Programmable Network Manager Supported Alarms</td>
<td>Port 'GigabitEthernet0/0/6' (Description: '# TO GigabitEthernet0/0/7 #') is down on device 2405:200:204:138:172:30:9:121. Carrier</td>
</tr>
<tr>
<td>cenAlarmSeverity</td>
<td>Integer</td>
<td>.1.3.6.1.4.9.9311.1.121.1.7</td>
<td>The alarm severity indicates the severity of the alarm in integer value. • 1—Critical • 2—Major • 3—Minor • 4—Warning • 5—Clear • 6—Info</td>
<td>4</td>
</tr>
<tr>
<td>SNMP Varbind</td>
<td>Data Type</td>
<td>Varbind OID</td>
<td>SNMP Varbing Description</td>
<td>Example</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------</td>
<td>--------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>---------</td>
</tr>
</tbody>
</table>
| cenAlarmSeverityDefn| SnmpAdminString | .1.3.6.1.4.9.9311.1.121.18 | The short description of the severity of the alarm generated. The String is formatted in ',' tuples. The value is the same value that the 'cenAlarmSeverity' attribute holds. contains one line description of the alarm severity generated.  
  • 1—Critical  
  • 2—Major  
  • 3—Minor  
  • 4—Warning  
  • 5—Clear  
  • 6—Info | 4.CLEARED |
| cenAlarmTriageValue | Integer         | .1.3.6.1.4.9.9311.1.121.19 | The triage value of an alarm is a hierarchical weighting value (applied by the application, and more importantly customizable by the end user) to allow an artificial form of evaluating impact, interest, or other user-determined functions between alarms. The value is a positive number or zero where denotes an undetermined or uncomputable value.  
  **Note** EPN manager does not support this field. | — |
| cenEventIDList      | OctetString     | .1.3.6.1.4.9.9311.1.121.20 | Comma separated list of the Unique Event identifiers that led to the generation of this Alarm.  
  **Note** EPN manager does not support this field. | — |
<table>
<thead>
<tr>
<th>SNMP Varbind</th>
<th>Data Type</th>
<th>Varbind OID</th>
<th>SNMP Varbing Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>cenUserMessage1</td>
<td>SnmpAdminString</td>
<td>.136.1.499311.1.12121</td>
<td>User input message. This value can be configured.</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>srcObjectClassName=ProtocolEndpoint, srcObjectDisplayName=GigabitEthernet0/1/2/3, srcObjectBusinessKey=172.20.127.100:GigabitEthernet0/1/2/3, chassisId=SAT101</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>srcObjectDisplayName=GigabitEthernet0/3/1, rootCauseId=0, hostName=ASR903-101.110.cisco, chassisId=, correlationType=UNKNOWN, srcObjectBusinessKey=82a</td>
<td></td>
</tr>
<tr>
<td>cenUserMessage2</td>
<td>SnmpAdminString</td>
<td>.136.1.499311.1.12122</td>
<td>User input message. This value can be configured.</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Note EPN manager does not support this field.</td>
<td></td>
</tr>
<tr>
<td>cenUserMessage3</td>
<td>SnmpAdminString</td>
<td>.136.1.499311.1.12123</td>
<td>User input message. This value can be configured.</td>
<td>—</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Note EPN manager does not support this field.</td>
<td></td>
</tr>
</tbody>
</table>
| cenAlarmMode      | Integer       | .136.1.499311.1.12124 | • unknown(1) — When the value for this attribute could not be determined.  
• alert(2) — Denotes an alarm generated by a set of events where all events are reported by polling of managed objects and/or listening to SNMP notifications.  
• event(3) — Denotes an event generated by polling of managed objects and/or listening to SNMP notifications. |
|                   |               |                      | 2                                                                                                                                                                                                                       |         |
| cenPartitionNumber | Integer       | .136.1.499311.1.12124 | In traps generated by the management application that support multiple partitions, the attribute will carry the integer value assigned to identify the logical group where the managed device resides.  
Note EPN manager does not support this field.                                                                                       | 0       |
<table>
<thead>
<tr>
<th>SNMP Varbind</th>
<th>Data Type</th>
<th>Varbind OID</th>
<th>SNMP Varbing Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>cenPartitionName</td>
<td>SnmpAdminString</td>
<td>.1.3.6.1.4.9.931.1.1.2.1.26</td>
<td>In traps generated by the management application that support multiple partitions, the attribute will carry the name assigned to identify the logical group where the managed device resides.</td>
<td></td>
</tr>
<tr>
<td>cenCustomerIdentification</td>
<td>SnmpAdminString</td>
<td>.1.3.6.1.4.9.931.1.1.2.1.27</td>
<td>User input message. The attribute takes in a free format text. This attribute can be used by advanced management applications to sort responses from the fault management server.</td>
<td></td>
</tr>
<tr>
<td>cenCustomerRevision</td>
<td>SnmpAdminString</td>
<td>.1.3.6.1.4.9.931.1.1.2.1.28</td>
<td>User input message. The attribute takes in a free format text. This attribute can be used by advanced management applications to sort responses from the fault management server.</td>
<td></td>
</tr>
<tr>
<td>cenAlertID</td>
<td>SnmpAdminString</td>
<td>.1.3.6.1.4.9.931.1.1.2.1.29</td>
<td>In event based notification, this attribute will contain the alert id to which the generated event has been rolled upto. In alert based notification, the cenAlarmInstanceId and cenAlertID will be identical.</td>
<td>1185098114</td>
</tr>
</tbody>
</table>
Monitoring Policies Reference

The following topics describe the monitoring policies used by Cisco EPN Manager. For information on the supported MIBs and MIB objects, see Cisco Evolved Programmable Network Manager Supported Devices.

- Device Health Monitoring Policy, on page 879
- Interface Health Monitoring Policy, on page 880
- Custom MIB Polling Monitoring Policy, on page 880
- IP SLA Y.1731 Monitoring Policy, on page 881
- Pseudowire Emulation Edge to Edge Monitoring Policy, on page 881
- Quality of Service Monitoring Policy, on page 882
- Cable Policy, on page 882
- IP SLA Monitoring Policy, on page 883
- ME1200 EVC QoS Monitoring Policy, on page 883
- MPLS Link Performance Monitoring Policy, on page 884
- BNG Sessions and IP Pools Monitoring Policy, on page 885
- TDM/SONET Ports Monitoring Policy, on page 885
- Optical SFP Monitoring Policy, on page 885
- Cable Utilization, on page 886
- Optical 1 Day and Optical 15 Mins Monitoring Policies, on page 886
- CEM Monitoring Policy, on page 887
- Device Sensor Monitoring Policy, on page 887
- Performance Counters for Optical Monitoring Policies, on page 888

Device Health Monitoring Policy

The Device Health Monitoring Policy monitors device CPU utilization, memory pool utilization, environmental temperature, and device availability for all devices in the network. By default, the policy polls devices for this information every 5 minutes, and an alarm is generated if CPU utilization, memory pool utilization, or environmental temperature thresholds are surpassed.

This monitoring policy is activated by default after installation.
This policy does not monitor the device CPU utilization and memory pool utilization for supported Cisco ONS or Cisco NCS 2000 devices, but it does monitor memory utilization and device availability.

For information on how to manage this policy, see Set Up Basic Device Health Monitoring, on page 204.

---

**Interface Health Monitoring Policy**

An Interface Health Monitoring Policy monitors over 30 attributes to check interface operational status and performance. It polls device interfaces every 5 minutes and generates an alarm when interface discard, error, utilization, or byte rate thresholds are exceeded.

To protect the performance of large deployments, this policy is not activated by default.

---

**Note**

This policy does not monitor optical interfaces. Use an optical policy to monitor that information. See Optical 1 Day and Optical 15 Mins Monitoring Policies, on page 886.

See these topics for information on how to manage this policy:

- To check whether an Interface Health policy is actively monitoring interfaces, see Check What Cisco EPN Manager Is Monitoring, on page 208.
- To set up interface monitoring, see Set Up Basic Interface Monitoring, on page 205.
- To adjust an interface monitoring policy, see Adjust What Is Being Monitored, on page 211.

---

**Custom MIB Polling Monitoring Policy**

The Custom MIB Polling monitoring policy is a customizable policy you can use to monitor unsupported parameters—that is, parameters that are not polled by any of the existing monitoring policy types. When you create a Custom MIB Polling policy, you can choose from an extensive list of Cisco and other MIBs, or import new MIBs into the policy. If a Custom MIB Polling policy is collecting device performance information, you can display that data in the Performance dashboard by creating a generic dashlet (see Add a Customized Dashlet to the Device Trends Dashboard, on page 23). For more information on managing Custom MIB Polling monitoring policies, see the following topics:

- To check if a Custom MIB Polling policy is being used to monitoring information, see Check What Cisco EPN Manager Is Monitoring, on page 208.
- To create a new Custom MIB Polling policy, see Create a Monitoring Policy for Unsupported Parameters and Third-Party Devices, on page 213.
- To adjust an existing Custom MIB Polling policy, see Adjust What Is Being Monitored, on page 211.
**IP SLA Y.1731 Monitoring Policy**

An IP SLA Y.1731 monitoring policy uses the Y.1731 ITU-T recommendation to monitor over 70 fault and performance attributes in Metro Ethernet networks. When you create an IP SLA Y.1731 monitoring policy, it polls the parameters every 15 minutes and generates an alarm when delay, jitter, frame loss, and other thresholds are exceeded.

The jitter and delay measurements during intervals are collected separately under Bins statistics section. For each measurement, the forward, backward and two way data is collected. Bins statistics data is not polled by default. To enable the collection of this data, choose a polling frequency, for details see Change the Polling for a Monitoring Policy.

---

**Note**

The Bins statistics data is collected only on ME1200 devices.

For more information on how to configure and manage an IP SLA Y.1731 monitoring policy, see these topics:

- To check if IP SLA Y.1731 parameters are being monitored, see Check What Cisco EPN Manager Is Monitoring, on page 208.
- To create a new IP SLA Y.1731 monitoring policy, see Create a New Monitoring Policy Using Out-of-the-Box Policy Types, on page 213.
- To adjust an existing IP SLA Y.1731 monitoring policy, see Adjust What Is Being Monitored, on page 211.

**Pseudowire Emulation Edge to Edge Monitoring Policy**

A Pseudowire Emulation Edge to Edge (PWE3) monitoring policy polls approximately 20 attributes that emulate edge-to-edge services over a Packet Switched Network (PSN). When you create and enable a monitoring policy that uses this policy type, attributes are polled every 15 minutes by default. In addition, Cisco EPN Manager generates a minor alarm when the thresholds for the following attributes are surpassed on pseudowire virtual circuits (PW VCs):

- HC packets and bytes—Total in and total out rates
- Operational status up, inbound and outbound operational status up

For more information on how to configure and manage a PWE3 monitoring policy, see these topics:

- To check if PWE3 parameters are being monitored, see Check What Cisco EPN Manager Is Monitoring, on page 208.
- To create a new PWE3 monitoring policy, see Create a New Monitoring Policy Using Out-of-the-Box Policy Types, on page 213.
- To adjust an existing PWE3 monitoring policy, see Adjust What Is Being Monitored, on page 211.
Quality of Service Monitoring Policy

A Quality of Service monitoring policy polls over 60 service parameters to validate the quality of services running on network devices. When you create a Quality of Service monitoring policy, it polls the parameters every 15 minutes and generates an alarm when certain thresholds are exceeded. The following is a partial list of parameters that can cause an alarm:

- Dropped/discard bytes and packets rates
- Pre-policy bytes and packets rates, utilization, percent of Committed Information Rate (CIR), Peak Information Rate (PIR)
- Post-policy bytes rates, utilization, percent of Committed Information Rate (CIR), Peak Information Rate (PIR)

To view all Quality of Service parameters that can cause TCAs, see Check Which Parameters and Counters Are Polled By a Monitoring Policy, on page 210.

For more information on how to configure and manage a Quality of Service monitoring policy, see these topics:

- To check if Quality of Service parameters are being monitored, see Check What Cisco EPN Manager Is Monitoring, on page 208.
- To create a new Quality of Service monitoring policy, see Create a New Monitoring Policy Using Out-of-the-Box Policy Types, on page 213.
- To adjust an existing Quality of Service monitoring policy, see Adjust What Is Being Monitored, on page 211.

Cable Policy

Note
The default polling frequency value is 5 minutes.

The dashboard or metrics in the description column require this policy to be enabled.

Table 66:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modem States</td>
<td>Chassis View &gt; Performance &gt; Modem History</td>
</tr>
<tr>
<td></td>
<td>Dashboard &gt; Cable &gt; Cable Modem &gt; Cable Modem</td>
</tr>
<tr>
<td>IPv6 Neighbour States</td>
<td>Chassis View &gt; Configuration &gt; IPv4 and IPv6 Statistics &gt; IPv6 Neighbour Statistics</td>
</tr>
<tr>
<td>Voice Calls States</td>
<td>Chassis View &gt; Configuration &gt; Voice Calls</td>
</tr>
<tr>
<td></td>
<td>Chassis View &gt; Performance &gt; Voice Calls</td>
</tr>
</tbody>
</table>
In a data backup and restore scenario, if a policy activated in an earlier release is restored on to a new release, the parameters introduced in new release will have the polling frequency set as **No Polling**. Once the data restore is completed, user has to explicitly set the polling frequency to poll these parameters.

### IP SLA Monitoring Policy

An IP SLA monitoring policy monitors approximately 20 parameters to provide real-time performance information. When you create an IP SLA monitoring policy, it polls the parameters every 15 minutes. This monitoring policy does not generate any alarms; if you want to generate IP SLA-based alarms, use the IP SLA Y.1731 monitoring policy.

For more information on how to configure and manage an IP SLA monitoring policy, see these topics:

- To check if IP SLA parameters are being monitored, see [Check What Cisco EPN Manager Is Monitoring](#), on page 208.
- To create a new IP SLA monitoring policy, see [Create a New Monitoring Policy Using Out-of-the-Box Policy Types](#), on page 213.
- To adjust an existing IP SLA monitoring policy, see [Adjust What Is Being Monitored](#), on page 211.

### ME1200 EVC QoS Monitoring Policy

A ME1200 QoS monitoring policy polls over 20 service parameters to validate the quality of selected services running on ME1200 devices. When you create a ME1200 Quality of Service monitoring policy, it polls the parameters every 15 minutes but does not generate an alarm when certain thresholds are exceeded.

The following is a partial list of parameters that are polled by ME1200 QoS monitoring policy:

- Transmitted and discarded bytes and packets rates.
- Average bit and frame rates for green (conforming), yellow (exceeding), red (violating), and discard traffic (both inbound and outbound)
To ensure that you are viewing accurate ME1200 QoS data, when you enable the ME1200 EVC Quality of Service monitoring policy, first disable the EVC performance monitoring session on the ME1200 devices.

To view all ME1200 QoS parameters that are polled, see Check Which Parameters and Counters Are Polled By a Monitoring Policy, on page 210.

For more information on how to configure and manage a ME1200 QoS monitoring policy, see these topics:

- To check if ME1200 QoS parameters are being monitored, see Check What Cisco EPN Manager Is Monitoring, on page 208.
- To create a new ME1200 QoS monitoring policy, see Create a New Monitoring Policy Using Out-of-the-Box Policy Types, on page 213.
- To adjust an existing ME1200 QoS monitoring policy, see Adjust What Is Being Monitored, on page 211.

**MPLS Link Performance Monitoring Policy**

The MPLS Link Performance monitoring policy measures link delay in MPLS. When you create a MPLS link performance Monitoring policy, it polls the parameters every 15 minutes by default. The polling interval can also be set to 1, 5 or 60 minutes.

This policy collects data only on NCS5500 and ASR9000 devices

This policy polls the following parameters:

- Average Delay
- Min Delay
- Max Delay
- RX packets
- TX packets

For more information on how to configure and manage a MPLS Link Performance monitoring policy, see these topics:

- To check what the MPLS Link Performance monitoring policy is monitoring, see Check What Cisco EPN Manager Is Monitoring, on page 208.
- To create a new MPLS Link Performance monitoring policy, see Create a New Monitoring Policy Using Out-of-the-Box Policy Types, on page 213.
- To adjust an existing MPLS Link Performance monitoring policy, see Adjust What Is Being Monitored, on page 211.
BNG Sessions and IP Pools Monitoring Policy

This monitoring policy polls over 5 parameters to monitor the BNG sessions as well as the IP addresses leased from the IP pools. When you create a BNG Sessions and IP Pools monitoring policy, it polls the parameters every 15 minutes and generates an alarm when certain thresholds are exceeded. The following is a partial list of parameters that can cause an alarm:

- Number of used or free IP addresses in the IP pools.
- Number of sessions for authenticated and up subscribers.

To view all BNG Sessions and IP Pools parameters that can cause TCAs, see Check Which Parameters and Counters Are Polled By a Monitoring Policy, on page 210.

For more information on how to configure and manage a BNG Sessions and IP Pools monitoring policy, see these topics:

- To check if BNG Sessions and IP Pools parameters are being monitored, see Check What Cisco EPN Manager Is Monitoring, on page 208.
- To create a new BNG Sessions and IP Pools monitoring policy, see Create a New Monitoring Policy Using Out-of-the-Box Policy Types, on page 213.
- To adjust an existing BNG Sessions and IP Pools monitoring policy, see Adjust What Is Being Monitored, on page 211.

TDM/SONET Ports Monitoring Policy

The TDM/Sonet Ports monitoring policy monitors approximately 20 circuit emulation (CEM) parameters. When you create a TDM/SONET Ports monitoring policy, it polls the CEM parameters every 15 minutes and generates an alarm when errored seconds (ES), unavailable sessions (UAS), and code violation (CV) thresholds are exceeded.

For more information on how to configure and manage a TDM/SONET Ports monitoring policy, see these topics:

- To check if TDM/SONET Ports parameters are being monitored, see Check What Cisco EPN Manager Is Monitoring, on page 208.
- To create a new TDM/SONET Ports monitoring policy, see Create a New Monitoring Policy Using Out-of-the-Box Policy Types, on page 213.
- To adjust an existing TDM/SONET Ports monitoring policy, see Adjust What Is Being Monitored, on page 211.

Optical SFP Monitoring Policy

An Optical SFP monitoring policy polls health and performance information for optical Small Form-Factor Pluggable (SFP) interfaces. This policy polls temperature, voltage, current, and optical TX/RX power. When you create an Optical SFP monitoring policy, it polls the parameters every 1 minute.
For more information on how to configure and manage an Optical SFP monitoring policy, see these topics:

- To check if Optical SFP parameters are being monitored, see Check What Cisco EPN Manager Is Monitoring, on page 208.
- To create a new Optical SFP monitoring policy, see Create a New Monitoring Policy Using Out-of-the-Box Policy Types, on page 213.
- To adjust an existing Optical SFP monitoring policy, see Adjust What Is Being Monitored, on page 211.

**Cable Utilization**

As this policy uses SNMP, this is a device CPU intensive operation. It is always recommended to have a polling frequency of 60 minutes (default value) or more.

The metrics in the description column require this policy to be enabled.

**Table 67:**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line Card and Channel Utilization</td>
<td>Chassis view &gt; Configuration &gt; Fiber Node Utilization</td>
</tr>
<tr>
<td></td>
<td>Chassis view &gt; Configuration &gt; Mac Domain Utilization</td>
</tr>
<tr>
<td></td>
<td>Chassis view &gt; Card &gt; Configuration &gt; Controller Utilization</td>
</tr>
<tr>
<td></td>
<td>Chassis View &gt; Performance &gt; Fiber Node Upstream Utilization</td>
</tr>
<tr>
<td></td>
<td>Chassis View &gt; Performance &gt; Fiber Node Downstream Utilization</td>
</tr>
<tr>
<td></td>
<td>Chassis View &gt; Performance &gt; Mac Domain Upstream Utilization</td>
</tr>
<tr>
<td></td>
<td>Chassis View &gt; Performance &gt; Mac Domain Downstream Utilization</td>
</tr>
<tr>
<td></td>
<td>Chassis View &gt; Performance &gt; Upstream Channel Utilization</td>
</tr>
<tr>
<td></td>
<td>Chassis View &gt; Performance &gt; Downstream Channel Utilization</td>
</tr>
<tr>
<td></td>
<td>Chassis View &gt; Performance &gt; Line Cards Upstream Utilization</td>
</tr>
<tr>
<td></td>
<td>Chassis View &gt; Performance &gt; Line Cards Downstream Utilization</td>
</tr>
<tr>
<td>Fiber Node Utilization</td>
<td>Device (hyperlink) &gt; Utilization (Next to Chassis View tab)</td>
</tr>
</tbody>
</table>

**Optical 1 Day and Optical 15 Mins Monitoring Policies**

The Optical 1 Day and Optical 15 Mins monitoring policies poll the following optical interfaces:

- Physical, OTN, Ethernet, and SONET/SDH interfaces on Cisco NCS 4000 devices
- DWDM interfaces on Cisco NCS 2000 and Cisco ONS devices
Device availability and environmental temperature is monitored by the Device Health monitoring policy. See Device Health Monitoring Policy, on page 879 for more information.

See Performance Counters for Optical Monitoring Policies, on page 888 for a list of the parameters that these policies poll.

For more information on how to configure and manage an Optical 1 Day and Optical 15 Mins monitoring policy, see these topics:

- To check if Optical 1 Day and Optical 15 Mins parameters are being monitored, see Check What Cisco EPN Manager Is Monitoring, on page 208.
- To create a new Optical 1 Day and Optical 15 Mins monitoring policy, see Create a New Monitoring Policy Using Out-of-the-Box Policy Types, on page 213.
- To adjust an existing Optical 1 Day and Optical 15 Mins monitoring policy, see Adjust What Is Being Monitored, on page 211.

**CEM Monitoring Policy**

Use the CEM Monitoring Policy to poll the following CEM parameters:

- Jitter Buffer Overruns
- Generated Lbits
- Received Lbits
- Generated Rbits
- Received Rbits
- Generated Nbits
- Received Nbits
- Generated Pbits
- Received Pbits

The polling happens through the CLI and the delta of the current and last collection is taken as the current entry.

**Note**

This polling data is not displayed in the dashboard.

**Device Sensor Monitoring Policy**

Use the Device Sensor monitoring policy to poll the sensor information through SNMP to the devices that are added to this policy. The sensor details such as voltage, power, and current temperature are polled to the device.
There are no calculations involved in the device sensor data.

Performance Counters for Optical Monitoring Policies

The following topics list the performance counters used by the optical monitoring policies. This information is provided here because it is not available from the web GUI.

- Reference—Performance Counters for Physical Interfaces, on page 888
- Reference—Performance Counters for OTN-FEC Interfaces, on page 890
- Reference—Performance Counters for OTN-ODU Interfaces, on page 890
- Reference—Performance Counters for OTN-OTU Interfaces, on page 891
- Reference—Performance Counters for Ethernet Interfaces, on page 892
- Reference—Performance Counters for SONET Interfaces, on page 893
- Reference—Performance Counters for SDH Interfaces, on page 894

Reference—Performance Counters for Physical Interfaces

The following table lists the performance counters used by the optical policy types to monitor physical interfaces.

Performance counters marked with an asterisk (*) are applicable for all Cisco Optical Networking Services (ONS) and Cisco Network Convergence System (NCS) 2000 series devices. Performance counters marked with a double asterisk (**) are applicable for Cisco Network Convergence System (NCS) 4000 series devices.

<table>
<thead>
<tr>
<th>Physical Interface Performance Counter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OPR-MIN</td>
<td>Minimum output power received by the optical circuit.</td>
</tr>
<tr>
<td>OPR-AVG</td>
<td>Average output power received by the optical circuit.</td>
</tr>
<tr>
<td>OPR-MAX</td>
<td>Maximum output power received by the optical circuit.</td>
</tr>
<tr>
<td>OPT-MIN</td>
<td>Minimum output power transmitted from the optical circuit.</td>
</tr>
<tr>
<td>OPT-AVG</td>
<td>Average output power transmitted from the optical circuit.</td>
</tr>
<tr>
<td>OPT-MAX</td>
<td>Maximum output power transmitted from the optical circuit.</td>
</tr>
<tr>
<td>LBC-MIN*</td>
<td>Minimum laser bias current for the optical circuit.</td>
</tr>
<tr>
<td>LBCL-MIN</td>
<td></td>
</tr>
<tr>
<td>LBC-AVG*</td>
<td>Average laser bias current for the optical circuit.</td>
</tr>
<tr>
<td>LBCL-AVG</td>
<td></td>
</tr>
<tr>
<td>Metric</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>LBC-MAX*</td>
<td>Maximum laser bias current for the optical circuit.</td>
</tr>
<tr>
<td>LBCL-MAX</td>
<td></td>
</tr>
<tr>
<td>DGD-MIN**</td>
<td>Minimum differential group delay for the optical circuit.</td>
</tr>
<tr>
<td>DGD-AVG**</td>
<td>Average differential group delay for the optical circuit.</td>
</tr>
<tr>
<td>DGD-MAX**</td>
<td>Maximum differential group delay for the optical circuit.</td>
</tr>
<tr>
<td>SOPMD-MIN**</td>
<td>Minimum second order polarization mode dispersion for the optical circuit.</td>
</tr>
<tr>
<td>SOPMD-AVG**</td>
<td>Average second order polarization mode dispersion for the optical circuit.</td>
</tr>
<tr>
<td>SOPMD_MAX**</td>
<td>Maximum second order polarization mode dispersion for the optical circuit.</td>
</tr>
<tr>
<td>OSNR-MIN**</td>
<td>Minimum optical signal to noise ratio for the optical circuit.</td>
</tr>
<tr>
<td>OSNR-AVG**</td>
<td>Average optical signal to noise ratio for the optical circuit.</td>
</tr>
<tr>
<td>OSNR-MAX**</td>
<td>Maximum optical signal to noise ratio for the optical circuit.</td>
</tr>
<tr>
<td>PDL-MIN**</td>
<td>Minimum polarization dependent loss for the optical circuit.</td>
</tr>
<tr>
<td>PDL-AVG**</td>
<td>Average polarization dependent loss for the optical circuit.</td>
</tr>
<tr>
<td>PDL-MAX**</td>
<td>Maximum polarization dependent loss for the optical circuit.</td>
</tr>
<tr>
<td>PCR-MIN**</td>
<td>Minimum polarization change rate for the optical circuit.</td>
</tr>
<tr>
<td>PCR-AVG**</td>
<td>Average polarization change rate for the optical circuit.</td>
</tr>
<tr>
<td>PCR-MAX**</td>
<td>Maximum polarization change rate for the optical circuit.</td>
</tr>
<tr>
<td>PMD-AVG**,</td>
<td>Average polarization mode dispersion for the optical circuit.</td>
</tr>
<tr>
<td>PMD-MIN**,</td>
<td>Minimum polarization mode dispersion for the optical circuit.</td>
</tr>
<tr>
<td>PN-MIN**</td>
<td>Minimum phase noise for the optical circuit.</td>
</tr>
<tr>
<td>PN-AVG**</td>
<td>Average phase noise for the optical circuit.</td>
</tr>
<tr>
<td>PN-MAX**</td>
<td>Maximum phase noise for the optical circuit.</td>
</tr>
<tr>
<td>PREFEC-BER*</td>
<td>Pre-forward error correction bit error rate for the optical circuit.</td>
</tr>
<tr>
<td>CD-MIN**</td>
<td>Minimum chromatic dispersion for the optical circuit.</td>
</tr>
<tr>
<td>CD-AVG**</td>
<td>Average chromatic dispersion for the optical circuit.</td>
</tr>
<tr>
<td>CD-MAX**</td>
<td>Maximum chromatic dispersion for the optical circuit.</td>
</tr>
</tbody>
</table>
Reference—Performance Counters for OTN-FEC Interfaces

The following table lists the performance counters used by the optical policy types to monitor OTN-FEC interfaces.

Performance counters marked with an asterisk (*) are applicable for all Cisco Optical Networking Services (ONS) and Cisco Network Convergence System (NCS) 2000 series devices.

<table>
<thead>
<tr>
<th>OTN-FEC Interface Performance Counter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BIT-EC*</td>
<td>Number of bit errors corrected.</td>
</tr>
<tr>
<td>BIEC</td>
<td></td>
</tr>
<tr>
<td>UNC-WORDS*</td>
<td>Number of uncorrectable words.</td>
</tr>
<tr>
<td>UCW</td>
<td></td>
</tr>
</tbody>
</table>

Reference—Performance Counters for OTN-ODU Interfaces

The following table lists the performance counters used by the optical policy types to monitor OTN-ODU interfaces.

<table>
<thead>
<tr>
<th>OTN-ODU Interface Performance Counter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BBE-PM</td>
<td>Number of background block errors in path monitoring.</td>
</tr>
<tr>
<td>BBER-PM</td>
<td>Background block errors ratio in path monitoring.</td>
</tr>
<tr>
<td>ES-PM</td>
<td>Number of errored seconds in path monitoring.</td>
</tr>
<tr>
<td>ESR-PM</td>
<td>Errored seconds ratio in path monitoring.</td>
</tr>
<tr>
<td>SES-PM</td>
<td>Number of severely errored seconds in path monitoring.</td>
</tr>
<tr>
<td>SESR-PM</td>
<td>Severely errored seconds ratio in path monitoring.</td>
</tr>
<tr>
<td>UAS-PM</td>
<td>Number of unavailable seconds in path monitoring.</td>
</tr>
<tr>
<td>FC-PM</td>
<td>Number of failure counts (AIS/RFI detected) in path monitoring.</td>
</tr>
<tr>
<td>gfpStatsRxFrames</td>
<td>Number of generic framing procedure (GFP) frames received.</td>
</tr>
<tr>
<td>gfpStatsTxFrames</td>
<td>Number of GFP frames transmitted.</td>
</tr>
<tr>
<td>gfpStatsRxOctets</td>
<td>Number of GFP bytes received.</td>
</tr>
<tr>
<td>gfpStatsTxOctets</td>
<td>Number of GFP bytes transmitted.</td>
</tr>
<tr>
<td>gfpStatsRxCRCErrors</td>
<td>Number of packets received with a payload frame check sequence (FCS) error.</td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>gfpStatsRxMBitErrors</td>
<td>Number of multiple bit errors. In the GFP core header at the GFP-transparent (GFP-T) receiver, these are uncorrectable.</td>
</tr>
<tr>
<td>gfpStatsRxSBitErrors</td>
<td>Number of single bit errors. In the GFP core header at the GFP-T receiver, these are correctable.</td>
</tr>
<tr>
<td>gfpStatsRxTypeInvalid</td>
<td>Number of packets received with invalid GFP type. This includes unexpected user payload identifier (UPI) type and errors in core header error check (CHEC).</td>
</tr>
<tr>
<td>gfpStatsRxCIDInvalid</td>
<td>Number of packets received with invalid CID.</td>
</tr>
<tr>
<td>gfpStatsRoundTripLatencyUSec</td>
<td>Round trip delay for the end-to-end Fibre Channel transport in milliseconds.</td>
</tr>
<tr>
<td>gfpStatsTxDistanceExtBuffers</td>
<td>Number of buffer credit transmitted for GFP-T transmitter (valid only if distance extension is enabled).</td>
</tr>
<tr>
<td>gfpStatsRxSblkCRCErrors</td>
<td>Number of super block cyclic redundancy check (CRC) errors.</td>
</tr>
<tr>
<td>gfpStatsCSFRaised</td>
<td>Number of GFP client signal fail (CSF) frames detected at the GFP-T receiver.</td>
</tr>
<tr>
<td>gfpStatsLFDRaised</td>
<td>Number of GFP loss of frame delineation (LFD) detected.</td>
</tr>
<tr>
<td>gfpRxCmffFrame</td>
<td>Number of client management frames (CMF) received.</td>
</tr>
<tr>
<td>gfpTxCmffFrame</td>
<td>Number of client management frames (CMF) transmitted.</td>
</tr>
<tr>
<td>gfpStatsCHEcRxMBitErrors</td>
<td>Number of core header error control (cHEC) CRC multiple bit errors.</td>
</tr>
<tr>
<td>gfpStatsTHecRxMBitErrors</td>
<td>Number of type header error control (tHEC) CRC multiple bit errors.</td>
</tr>
</tbody>
</table>

**Reference—Performance Counters for OTN-OTU Interfaces**

The following table lists the performance counters used by the optical policy types to monitor OTN-OTU interfaces.

<table>
<thead>
<tr>
<th>OTN-OTU Interface Performance Counter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BBE-SM</td>
<td>Number of background block errors in section monitoring.</td>
</tr>
<tr>
<td>BBER-SM</td>
<td>Background block error ratio in section monitoring.</td>
</tr>
<tr>
<td>ES-SM</td>
<td>Number of errored seconds in section monitoring.</td>
</tr>
<tr>
<td>ESR-SM</td>
<td>Errored seconds ratio in section monitoring.</td>
</tr>
<tr>
<td>SES-SM</td>
<td>Number of severely errored seconds in section monitoring.</td>
</tr>
<tr>
<td>SESR-SM</td>
<td>Severely errored seconds ratio in section monitoring.</td>
</tr>
</tbody>
</table>
### Reference—Performance Counters for Ethernet Interfaces

The following table lists the performance counters used by the optical policy types to monitor Ethernet interfaces.

<table>
<thead>
<tr>
<th>Ethernet Interface Performance Counter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ifInOctets</td>
<td>The total number of octets received on the interface, including framing octets.</td>
</tr>
<tr>
<td>ifInErrors</td>
<td>The total number of received packets that were discarded because of errors.</td>
</tr>
<tr>
<td>ifOutOctets</td>
<td>The total number of transmitted octets, including framing packets.</td>
</tr>
<tr>
<td>ifInUcastPkts</td>
<td>The total number of unicast packets received since the last counter reset.</td>
</tr>
<tr>
<td>ifOutUcastPkts</td>
<td>The total number of packets requested by the higher-level protocols to be transmitted, and which were not addressed to a multicast or broadcast address at this sub-layer, including those that were discarded or not sent.</td>
</tr>
<tr>
<td>ifInMulticastPkts</td>
<td>The total number of multicast packets received since the last counter reset.</td>
</tr>
<tr>
<td>ifOutMulticastPkts</td>
<td>The total number of multicast frames transmitted error free.</td>
</tr>
<tr>
<td>ifInBroadcastPkts</td>
<td>The total number of broadcast packets received since the last counter reset.</td>
</tr>
<tr>
<td>ifOutBroadcastPkts</td>
<td>The total number of packets requested by higher-level protocols and addressed to a broadcast address at this sub-layer, including those that were not transmitted.</td>
</tr>
<tr>
<td>txTotalPkts</td>
<td>The total number of packets transmitted.</td>
</tr>
<tr>
<td>rxTotalPkts</td>
<td>The total number of packets received.</td>
</tr>
<tr>
<td>etherStatsOctets</td>
<td>The total number of octets of data (including those in bad packets) received on the network (excluding framing bits but including FCS octets).</td>
</tr>
<tr>
<td>etherStatsOversizePkts</td>
<td>The total number of packets received that were longer than 1518 octets (excluding framing bits but including FCS octets) and were otherwise well formed. Note that for tagged interfaces, this number becomes 1522 bytes.</td>
</tr>
<tr>
<td>dot3StatsFCSErrors</td>
<td>A count of frames received on a particular interface that are an integral number of octets in length but do not pass the FCS check.</td>
</tr>
<tr>
<td>dot3StatsFrameTooLongs</td>
<td>A count of frames received on a particular interface that exceed the maximum permitted frame size.</td>
</tr>
</tbody>
</table>
etherStatsJabbers | The total number of packets received that were longer than 1518 octets (excluding framing bits but including FCS octets), and had either a bad FCS with an integral number of octets (FCS Error) or a bad FCS with a non-integral number of octets (Alignment Error).

etherStatsPkts64Octets | The total number of packets (including bad packets) received that were 64 octets in length (excluding framing bits but including FCS octets).

etherStatsPkts65to127Octets | The total number of packets (including bad packets) received that were between 65 and 127 octets in length inclusive (excluding framing bits but including FCS octets).

etherStatsPkts128to255Octets | The total number of packets (including bad packets) received that were between 128 and 255 octets in length inclusive (excluding framing bits but including FCS octets).

etherStatsPkts256to511Octets | The total number of packets (including bad packets) received that were between 256 and 511 octets in length inclusive (excluding framing bits but including FCS octets).

etherStatsPkts512to1023Octets | The total number of packets (including bad packets) received that were between 512 and 1023 octets in length inclusive (excluding framing bits but including FCS octets).

etherStatsPkts1024to1518Octets | The total number of packets (including bad packets) received that were between 1024 and 1518 octets in length inclusive (excluding framing bits but including FCS octets).

etherStatsMulticastPkts | The total number of good packets received that were directed to a multicast address.

etherStatsBroadcastPkts | The total number of good packets received that were directed to the broadcast address.

etherStatsUndersizePkts | The total number of packets received that were less than 64 octets long (excluding framing bits, but including FCS octets) and were otherwise well formed.

Reference—Performance Counters for SONET Interfaces

The following table lists the performance counters used by the optical policy types to monitor SONET interfaces.

Performance counters marked with an asterisk (*) are applicable for all Cisco Optical Networking Services (ONS) and Cisco Network Convergence System (NCS) 2000 series devices.

<table>
<thead>
<tr>
<th>SONET Interface Performance Counter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CV-S*</td>
<td>Number of coding violations per section.</td>
</tr>
</tbody>
</table>
### Reference—Performance Counters for SDH Interfaces

The following table lists the performance counters used by the optical policy types to monitor SDH interfaces.

<table>
<thead>
<tr>
<th>SDH Interface Performance Counter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MS-ES</td>
<td>Number of errored seconds per multiplex section for near end and far end devices.</td>
</tr>
<tr>
<td>MS-ESR</td>
<td>Error seconds ratio per multiplex section for near end and far end devices.</td>
</tr>
<tr>
<td>MS-SES</td>
<td>Number of severely errored seconds per multiplex section for near end and far end devices.</td>
</tr>
<tr>
<td>MS-SESR</td>
<td>Severely errored seconds ratio per multiplex section for near end and far end devices.</td>
</tr>
<tr>
<td>MS-BBE</td>
<td>Number of background block errors per multiplex section for near end and far end devices.</td>
</tr>
<tr>
<td>MS-BBER</td>
<td>Background block error ratio per multiplex section for near end and far end devices.</td>
</tr>
<tr>
<td>MS-UAS</td>
<td>Number of unavailable seconds per multiplex section for near end and far end devices.</td>
</tr>
<tr>
<td>MS-EB</td>
<td>Number of errored block per multiplex section for near end and far end devices.</td>
</tr>
<tr>
<td><strong>MS-FC</strong></td>
<td>Number of failure counts per multiplex section for near end and far end devices.</td>
</tr>
<tr>
<td>-----------</td>
<td>---------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>MS-PSC</strong></td>
<td>Protection switching count per multiplex section. PSC is the number of times the service switches from a working card to a protection card and back.</td>
</tr>
<tr>
<td><strong>MS-PSC-R</strong></td>
<td>Protection switching count ring per multiplex section. This count is incremented only if ring switching is used.</td>
</tr>
<tr>
<td><strong>MS-PSC-S</strong></td>
<td>Protection switching count span per multiplex section. This count is incremented only if span switching is used.</td>
</tr>
<tr>
<td><strong>MS-PSC-W</strong></td>
<td>Protection switching count working per multiplex section. It is the count of the number of times traffic switches away from the working capacity in the failed line and back to the working capacity after the failure is cleared. PSC-W increments on the failed working line.</td>
</tr>
<tr>
<td><strong>MS-PSD</strong></td>
<td>Protection switching duration applies to the length of time, in seconds, that service is carried on another line.</td>
</tr>
<tr>
<td><strong>MS-PSD-R</strong></td>
<td>Protection switching duration ring is a count of the seconds that the protection line was used to carry service. This count is incremented only if ring switching is used.</td>
</tr>
<tr>
<td><strong>MS-PSD-S</strong></td>
<td>Protection switching duration span is a count of the seconds that the protection line was used to carry service. This count is incremented only if span switching is used.</td>
</tr>
<tr>
<td><strong>MS-PSD-W</strong></td>
<td>Protection switching duration working per multiplex section.</td>
</tr>
<tr>
<td><strong>RS-ES</strong></td>
<td>Number of errored seconds per regenerator section.</td>
</tr>
<tr>
<td><strong>RS-ESR</strong></td>
<td>Errored seconds ratio per regenerator section.</td>
</tr>
<tr>
<td><strong>RS-SES</strong></td>
<td>Number of severely errored seconds per regenerator section.</td>
</tr>
<tr>
<td><strong>RS-SESR</strong></td>
<td>Severely errored seconds ratio per regenerator section.</td>
</tr>
<tr>
<td><strong>RS-BBE</strong></td>
<td>Number of background block errors per regenerator section.</td>
</tr>
<tr>
<td><strong>RS-BBER</strong></td>
<td>Background block errors ratio per regenerator section.</td>
</tr>
<tr>
<td><strong>RS-UAS</strong></td>
<td>Number of unavailable seconds per regenerator section.</td>
</tr>
<tr>
<td><strong>RS-EB</strong></td>
<td>Number of errored block per regenerator section.</td>
</tr>
<tr>
<td><strong>RS-OFS</strong></td>
<td>Number of out-of-frame seconds per regenerator section.</td>
</tr>
</tbody>
</table>
Cisco Evolved Programmable Network Manager
RESTful API

- Cisco EPN Manager SDK, on page 897
- Cisco EPN Manager APIs, on page 897
- When to Use Cisco EPN Manager RESTful API, on page 899
- How to Use Cisco EPN Manager RESTful API, on page 899
- RESTConf API-An Overview, on page 900
- RESTConf API Functional Areas, on page 903
- Authentication and Authorization, on page 904
- Getting Started with Cisco EPN Manager REST API, on page 904
- Statistics, on page 907

Cisco EPN Manager SDK

The Cisco EPN Manager SDK is a collection of technologies that enables you to extend the capabilities of Cisco EPN Manager, access data, and invoke the automation operations from any application. The Cisco EPN Manager SDK includes the RESTful APIs and Open Automation. It is possible to use the RESTful API with scripting languages such as "bash with wget and cURL utilities", "Python", "Ruby", Java and so on.

With Cisco EPN Manager SDK technologies, you can:

- Access Cisco EPN Manager programmatically—Use the Cisco EPN Manager RESTful API to invoke workflows and obtain reports.
- Customize Cisco EPN Manager —Create custom workflow tasks, Customize Cisco EPN Manager by deploying your own jar files and script libraries in script modules. Use custom tasks from script bundles.

Cisco EPN Manager APIs

Cisco EPN Manager provides easy to use and comprehensive APIs that allow integration with any standards-based OSS system north bound. These APIs extend its core functionalities using three of the most commonly used standards - MTOSI and RESTConf, and RESTful APIs.

To provide rapid development design for automation, it's important for developers to develop APIs consistently thus paving way for a smoothest and easy to use design guidelines. Consistency allows teams to leverage
common code, patterns, documentation and design decisions. In Cisco EPN Manager, RESTful APIs are easily made available within the application with simple and extensive examples. The following diagram is an example illustrates the general behavior found in Cisco EPN Manager across *all* its APIs.

*Figure 17: EPNM RESTful API General Behavior*

This chapter is intended for the following technical professionals interested in using the Cisco EPN Manager Development Kit (SDK) and related technologies. Such users might be:

- System administrators and REST API developers who use Cisco EPN Manager and want to extend their ability to automation resources using it.
- Anyone else who wants to compare Cisco EPN Manager SDK or API technologies and determine which would be most appropriate for their application.

Cisco EPN Manager provides three northbound API interface types, MTOSI, REST and RESTConf. The functionality provided by these three APIs are fairly similar but not all APIs provide the same functions.

The MTOSI API is the most different of the APIs in terms of behaviour. It provides a SOAP interface over HTTPS that provides basic provisioning of optical and carrier ethernet functionality. Use the MTOSI interface if you need to provision optical services such as DWDM or OTN, and cannot use the RESTConf API.

The REST API provides system information and most statistics and assurance information besides other functions that handle configuration files, group management and device import capabilities.

The RESTConf API, like the above REST API, adheres to a RESTful interface. It provides all provisioning for carrier ethernet, L2/L3 VPNs, circuit emulation, OTN and DWDM technologies as well as core routing and switching.

For more information see the individual Cisco EPNM integration guides available on cisco.com.
When to Use Cisco EPN Manager RESTful API

Cisco EPN Manager RESTful API is a language-independent interface that can be used by any program or script capable of making HTTP requests. Use the REST API when you want to invoke operations on Cisco EPN Manager from a separate program or process.

Applications can use the RESTful API to do the following:

- Retrieve Cisco EPN Manager reports on physical and virtual devices, networks, appliances, groups and users, policies, and other monitored entities within your Cisco EPN Manager domains.
- Invoke additional operations specific to Cisco EPN Manager.

How to Use Cisco EPN Manager RESTful API

Because a RESTful API client interacts with Cisco EPN Manager using standard HTTP requests and responses, the RESTful API responses are compatible with any web browser. Many programming languages have libraries devoted to creating and sending HTTP requests and handling HTTP responses.

Most of the REST API calls send and return data in the request or the response, respectively. These data payloads may be formatted in one of two ways depending on the RESTful API call. Some of the RESTful API calls use a JavaScript Object Notation (JSON) payload, while others use an XML payload. You probably have to use both for any reasonably complex application.

A JSON-based RESTful API call is a plain HTTP request and response with a JSON payload. JSON is a lightweight text-based open standard designed for human-readable data interchange. JSON represents simple data structures and associative arrays. Your application directly invokes the JSON-based API without using any specialized RESTful API libraries, and parses JSON data using any means native to your application.

All requests to the Cisco EPN Manager API require user authentication. For more information about Authentication see Authentication and Authorization.

Authorization in the RESTful API is enforced by requiring that only registered users of Cisco EPN Manager are able to make API requests. For Cisco EPN Manager, access to the API is controlled by three user groups such as NBI Read, NBI Write and NBI Credentials. Each of these groups controls access to a different set of APIs. You can assign a user to multiple groups if you wish. You can check the documentation page of an API resource to determine which user group is required to access it. When a user is created and registered on Cisco EPN Manager, the user is assigned a unique RESTful API access key.

To obtain the RESTConf topological link retrieval resources, you can use RESTful topological link resources to get these values and perform the required correlation.

To access Cisco EPN Manager RESTful API documentation:

- Launch Cisco EPN Manager, and then in the top right corner, click the window settings menu opens.
RESTConf API-An Overview

In Cisco EPN Manager, the implementation conforms to the RESTConf/Yang specification information model and operational APIs protocols. Where required, the information model and operations APIs are extended in a standard way to support Cisco’s vendor extensions to the RESTConf/Yang interface. These extensions are added as a set of xml and yang schema definitions for the information model extensions.

RESTCONF—Uses structured data (XML or JSON) and YANG to provide a REST-like APIs, enabling you to programmatically access different network devices. RESTCONF APIs use HTTP methods.

YANG—A data modelling language that is used to model configuration and operational features. YANG determines the scope and the kind of functions that can be performed by NETCONF and RESTCONF APIs.

Following are the essential structure of RESTConf API:

• HTTP Headers: HTTP headers are used to describe the content sent or requested within an HTTP request. HTTP headers include:
  • Content-Type: At server side, an incoming request may have an entity attached to it. To determine its type, server uses the HTTP request header Content-Type.
  • Accept: Similarly, to determine what type of representation is desired at client side, HTTP header ACCEPT is used. Generally, if no Accept header is present in the request, the server can send pre-configured default representation type.
• **HTTP Methods**: The following methods are used to call an API:
  • Get-The GET method is sent by the client to retrieve data and metadata for a resource.
  • Post-It is used to create a new entity, but it can also be used to update an entity. The POST method is sent by the client to create a data resource or invoke an operation resource.
  • Put-A PUT request is idempotent. The PUT method is sent by the client to create or replace the target data resource.
  • Delete-Request that a resource be removed. The DELETE method is used to delete the target resource.

• **Messages**: The RESTCONF protocol uses HTTP messages. A single HTTP message corresponds to a single protocol method.

• **Media Types**: XML and JSON.

• **Query Parameters**:
  • Content
  • Depth
  • Fields
  • Filter
  • Insert
  • Point
  • Start-time
  • Stop-time
  • With-defaults

**Standard usage - Get Method**
The “GET All RESTConf API calls” returns the existing endpoint schema sections.

**GET /restconf/data/ietf-yang-library:modules-state**
Retrieves all RESTConf API endpoints

The schema URLs provide the details for many of the enumeration variables as well as the structural components of the module.

**Example for schema retrieval:**

**GET /restconf/schema/v1/cisco-resource-optical**

Returns the YANG schema for the module as plain text.

Several URL parameters are often available in RESTConf API calls. These are not implemented in all calls.

• .maxCount
• .startIndex
• .depth
GET /restconf/data/v1/module:resource
The general format for a RESTConf GET call.

Table 68: Query Parameters

<table>
<thead>
<tr>
<th>Query Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.depth (integer)</td>
<td>The number of detail levels to retrieve.</td>
</tr>
<tr>
<td>.maxCount (integer)</td>
<td>The limit of the number of rows retrieved.</td>
</tr>
<tr>
<td>.startIndex (integer)</td>
<td>The initial row to retrieve.</td>
</tr>
</tbody>
</table>

GET /restconf/data/v1/module:resource HTTP/1.1

RESTful API Utility

- Fully Distinguishable Name: Inventory objects in this interface has attributes representing FDN (Fully Distinguished Name). These attributes are used as identifiers of the object or as a reference to the object in query parameters or in the returns data wherever a reference to the object is needed. This FDN is a formatted string that consists of a set of type/value pairs with the following syntax, Sequence of <type>=<value> pairs separated by “!” where:
  - <type> is a constant value defined in the data model to represent the inventory object in the hierarchy, e.g. MD,ND,EQ,PTP,FTP, CTP, TL, VC, CFS, etc.
  - <value> is any text or sequence of <attrName>=<attrValue> pair separated by “;” that represents the attribute/value pairs of the inventory object constitutes a unique value within the local scope of the object represented by the type.

For more information, refer to the Cisco EPNM RESTConf guide.

RESTConf API Functional Areas

- Alarms—The alarms module provides mechanisms to retrieve and acknowledge alarms and events. The preferred method of managing alarms is to listen via the Notification API where a service can collect events of differing types or criticality and then handle them via this API.

- Performance Test—The Service Performance Test can be conducted standalone as well as part of service provisioning. Restconf NBI supports standalone performance test execution.

- Quality of Service (QoS)—QoS is a set of capabilities that allow the delivery of differentiated services for network traffic. Using Cisco EPN Manager you can configure QoS on Carrier Ethernet interfaces.

- OAM—The OAM tests in the EPNM RESTConf API fall into two general categories. The service and the network resource OAM configurations. For Y.1731, Y.1564 and BERT tests, the service-oam-config endpoint is used. For OTDR, the network-resource-oam-config endpoint is used. EPNM RESTConf OAM calls provide a POST command to initiate the test. That request yields a test ID and a test request ID. One usually then uses the test ID in a subsequent call to retrieve the results. There are URLs for most specific test types.

- Service Profiles—Service Profiles contain pre-defined provisioning request (order data) that can be used in provisioning each circuit/VC type. In NBI Provisioning request, a service profile reference can be used to get provisioning request data to be used in the provisioning. If the provisioning data is provided in the request along with the service profile reference, but the user provided data and the data stored in
the service profile gets merged with user provided data overriding the profile data before the request is sent to execute provisioning. Service profile can be created using EPNM Service Profile wizard GUI.

- Customer Facing Services (CFS)—The CFS represents the customer facing data for a circuit/VC. The CFS is derived from discovered RFS and represents the endpoints of the circuit/VC in the network. During CFS discovery, the system creates CFS objects for the discovered RFS objects.

- Resource Facing Services (RFS)—The RFS represents the relations between resources on different devices. During RFS discovery, the system creates device-level objects and network-level objects. Device-level RFS objects represent the circuit/VC configuration parts of the device-level configuration. Network-level RFS objects aggregate device or other network-level objects to represent network-level entities.

**RESTConf API Functional Areas**

- Alarms—The alarms module provides mechanisms to retrieve and acknowledge alarms and events. The preferred method of managing alarms is to listen via the Notification API where a service can collect events of differing types or criticality and then handle them via this API.

- Performance Test—The Service Performance Test can be conducted standalone as well as part of service provisioning. Restconf NBI supports standalone performance test execution.

- Quality of Service (QoS)—QoS is a set of capabilities that allow the delivery of differentiated services for network traffic. Using Cisco EPN Manager you can configure QoS on Carrier Ethernet interfaces.

- OAM—The OAM tests in the EPNM RESTConf API fall into two general categories. The service and the network resource OAM configurations. For Y.1731, Y.1564 and BERT tests, the service-oam-config endpoint is used. For OTDR, the network-resource-oam-config endpoint is used. EPNM RESTConf OAM calls provide a POST command to initiate the test. That request yields a test ID and a test request ID. One usually then uses the test ID in a subsequent call to retrieve the results. There are URLs for most specific test types.

- Service Profiles—Service Profiles contain pre-defined provisioning request (order data) that can be used in provisioning each circuit/VC type. In NBI Provisioning request, a service profile reference can be used to get provisioning request data to be used in the provisioning. If the provisioning data is provided in the request along with the service profile reference, but the user provided data and the data stored in the service profile gets merged with user provided data overriding the profile data before the request is sent to execute provisioning. Service profile can be created using EPNM Service Profile wizard GUI.

- Customer Facing Services (CFS)—The CFS represents the customer facing data for a circuit/VC. The CFS is derived from discovered RFS and represents the endpoints of the circuit/VC in the network. During CFS discovery, the system creates CFS objects for the discovered RFS objects.

- Resource Facing Services (RFS)—The RFS represents the relations between resources on different devices. During RFS discovery, the system creates device-level objects and network-level objects. Device-level RFS objects represent the circuit/VC configuration parts of the device-level configuration. Network-level RFS objects aggregate device or other network-level objects to represent network-level entities.
Authentication and Authorization

All requests to the Cisco EPN Manager API require user authentication. If no authentication details are provided in the request, the request is redirected to the login page. Authentication details may be passed through the HTTP header of the request. For more information see Authentication, Authorization, and Security topic (Home > Authentication, Authorization, and Security) in the Cisco EPN Manager API documentation.

For Cisco EPN Manager, access to the API is controlled by the user groups such as NBI Read, NBI Write, and NBI credential. Each of these groups controls access to a different set of APIs. You can assign a user to multiple groups if you wish. You can check the documentation page of an API resource to determine which user group is required to access it.

Note

It is recommended to use JSESSIONID during the production environment.

Getting Started with Cisco EPN Manager REST API

The Cisco EPNM REST API allows an application to interact with Cisco EPNM, programmatically. These requests provide access to resources in Cisco EPNM. With an API call, you can execute Cisco EPNM workflows and Monitor Alarms and Events, Collect device inventory, monitor network clients and usage, configure devices, Device Inventory and so on. For more information see the Getting Started topic (Home > Getting Started) in the Cisco Evolved Programmable Network Manager API documentation.

REST API Basics and Functional Areas

EPNM’s REST implementation uses multiple calls and filters. For example, when retrieving statistics, the first call provides URLs for the subsequent calls. Those then can be used for retrieving finer detail. In general, the URL parameters become more complicated with each call as more detail is added.

REST API Basics

• HTTPS Headers: The following HTTP Headers are used to control the way in which data is returned to a client.
  • Accept
  • Accept-Language
  • Content-Type
  • Accept-Encoding
  • Content-Encoding

• Query Parameters:

The API supports query parameters for almost all requests. The following table describes the General REST Query Parameters:
### Table 69: General REST Query Parameters

<table>
<thead>
<tr>
<th>Query Parameter</th>
<th>Applicability</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>.json</code></td>
<td>/api/*</td>
<td>When present indicates that the response should be returned in json format.</td>
</tr>
<tr>
<td><code>.xml</code></td>
<td>/api/*</td>
<td>When present indicates that the response should be returned in xml format. This is the default in the absence of the <code>.json</code> parameter.</td>
</tr>
<tr>
<td><code>_docs</code></td>
<td>/api/*</td>
<td>Displays the documentation page.</td>
</tr>
<tr>
<td><code>.full</code></td>
<td>/api/v1/data/T</td>
<td>When ‘true’ indicates that whole objects be returned rather than just IDs of the entities.</td>
</tr>
<tr>
<td><code>.group</code></td>
<td>api/v1/data/T</td>
<td>Filters the response based on content of the group specified by the string value, and the result of any applied operator.</td>
</tr>
<tr>
<td><code>.transform</code></td>
<td>GET/POST</td>
<td>Supplies the logical-name of a transform to be applied immediately before rendering to XML or JSON.</td>
</tr>
<tr>
<td><code>.maxresults</code></td>
<td>GET Paged</td>
<td>The greatest number of results in terms of the heads of instance trees returned.</td>
</tr>
<tr>
<td><code>.firstResult</code></td>
<td>GET Paged</td>
<td>The first result in terms of the heads of instance trees.</td>
</tr>
<tr>
<td><code>.strict</code></td>
<td>/api/v1/data/T</td>
<td>When ‘true’, the property names used in queries are validated, and an error thrown if appropriate. (The default - ie when strict=false - is to ignore invalid property names with a simple log message).</td>
</tr>
<tr>
<td><code>.case_sensitive</code></td>
<td>/api/v1/data/T</td>
<td>When ‘true’, the string values used in filter queries are case sensitive. (The default - ie when .case_sensitive=false - is to treat comparisons as case insensitive).</td>
</tr>
</tbody>
</table>
### Query Parameter

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Applicability</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>.nocount</td>
<td>/api/v1/data/T</td>
<td>When ‘true’, the “count”, “first”, and “last” attributes are not included in the response. Getting the values of these attributes requires additional time, therefore setting this to ‘true’ will improve performance. Defaults to ‘false’.</td>
</tr>
<tr>
<td>_ctx.domain</td>
<td>GET</td>
<td>Sets the active domain to be that named in the query parameter value - this is, by default, “sticky” in the sense that once set, the active-domain remains set. The “stickiness” is not RESTful, and so it can be switched off in configuration.</td>
</tr>
</tbody>
</table>

### REST API Functional Areas

- **Statistics**: The Statistics services provide summary, pre-defined statistical information about the system. Some of the resources of statistics are listed below.
  - GET All Border Routers
  - GET All IMEs
  - GET All RCs
  - GET All TCAs
  - GET All WAN Interfaces

- **Report Service**: The Report service provides operations to discover and run reports. Reports need to be defined in the system prior to access through the API. The following APIs are supported:
  - GET Get Available Report Templates
  - GET Get a Report
  - GET Run a Report
  - GET Run a ZIP Report

- **CLI Template Configuration**: The CLI Template Configuration service allows a CLI configuration template to be applied to one or more target devices. It also provides a way to upload, delete, and get the CLI templates in the system. The following APIs are supported:
  - GET CLI Configuration Templates
  - DELETE Delete Configuration Template
  - DELETE Delete Configuration Template Folder
  - GET Download Configuration Template
Statistics

From EPNM you can acquire statistics data in a simple step by step process. This is a fairly consistent general pattern of usage across several REST statistics endpoints. In general, a high-level first call is made that returns a list of available metrics. From that call, a second list of finer statistics for a given metric is returned from which the actual data series is returned.

Following is an example for Statistics - endpoint call succession: ESR PM data for a given circuit:

GET /webacs/api/v1/op/statisticsService/circuits?circuitName=VSO5_TO_HUB2
GET /webacs/api/v1/op/statisticsService/circuits/metrics?circuitType=ODUUNI&circuitId=161374613
GET /webacs/api/v1/op/statisticsService/circuits/metrics/ESR_PM?maxResults=24&timeInterval=6&endpointName=ODU20/4/0/0/1&location=FEND&circuitType=ODUUNI&deviceId=124606492_10.201.1.174&circuitId=161374613

The URLs for the last two calls were provided in the body of the previous call.