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Job Activity

Overview
The Job Activity pane displays information about jobs presently in the production schedule. To see jobs 
that have been defined but that are not currently scheduled, you need to open the Jobs pane. For more 
information about the Jobs pane, see <Jumps>“Jobs” on page 139. 

Note Remember that the security rights of a user will always affect what they are allowed to see in Scheduler. 
The Job Activity pane may show all jobs currently scheduled or only the jobs owned by the user and the 
user’s workgroup, depending on the user’s security policy.

The messages that display information about each job and group use different colored text to indicate 
their status, with a row background color of white. For example, carry over job rows display a 
background color of light gray. 

Job groups are presented in bold with an expand or collapse button in the first column. All jobs in a job 
group are slightly indented and can be collapsed into and expanded from the group.

Use the scroll bars to view all the columns in the Job Activity pane. The Job Activity pane makes a large 
amount of important job information easily accessible. In the case of estimated start times and durations, 
the values displayed are periodically updated as new data becomes available. You can also press the F5 
key for an instant refresh.

The Job Activity pane displays can be customized through the Preferences dialog. For more information 
on how to customize the Job Activity pane, see “Job Activity Preferences Dialog” section on page 4-114.

If the schedule in the Job Activity pane is a “forecast” for a future date (Forecast Only option selected 
when creating a schedule), then the word “Forecast” displays after the date in the pane title bar.

Job Activity Pane Interface
From the Navigator pane, select Operations > Job Activity to display the Job Activity pane.

You can double-click a job in the Job Activity pane to open its Job Details dialog.
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Note When you view a particular day in the production schedule, all jobs that have not been launched on 
previous days will also appear (unless you have filtered them out). This includes jobs in Active, Waiting 
On Resources, Waiting On Operator, Waiting On Dependencies, Stopped, Held, Agent Unavailable and 
Agent Inactive states.

Buttons
The Job Activity pane contains the following buttons:

 • Refresh – Refreshes the Job Activity pane.

 • Filter – Displays the Job Filter dialog to customize the data that displays in the Job Activity pane.

 • View Time By – Displays the View Time By dialog. Allows you to view jobs according to the time 
zone of the master doing the scheduling, the Tidal Web client you are using or an agent that you 
select.

 • Prior Day – Displays the production schedule for the day before the one currently displayed.

 • Next Day – Displays the production schedule for the day after the one currently displayed.

 • Select Day – Displays the production schedule for “today” or any other day.

 • Print – Displays the Reports pane to view and print the contents of the Job Activity pane. For more 
information, see <Jumps>“Monitoring Production” on page 361.

 • Graphical View – Displays a graphical view of the Job Activity pane.

Search Field
Enter text that you want to search for within the columns displayed into this field.

Note This field at the top right of the grids will only search text columns that are not grayed out and are 
string-based. See “Searchable Columns” on page 44.

Columns
The order of the columns listed in the Job Activity pane can be rearranged from the Job Activity 
Preferences dialog.

The Job Activity pane contains the following columns:

 • Job No. – The job number is the instance identification number of the job or group occurrence. Each 
occurrence or instance of a job is assigned a unique tracking number when it is added to the schedule 
to distinguish it from any other occurrences of the job. It is possible that the same job may run 
several times during a day.

 • Name – The name of the job.

 • Status – The present status of the job. The color of text used for each job and Job Group is based on 
its status. You can customize the status colors and sort order using the Preferences dialog.

 • Current Est Start – The estimated start time as of the current moment in time. This start time value 
is updated every minute. 
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 • Est Duration – The estimated duration for the command or executable as specified in the job 
definition. If the job has run more than once with the same command or executable, the estimated 
duration is the historical average of the job’s previous run times. You can also manually set the 
estimated duration time of a job in its definition.

 • Reruns – Tracks the number of times that a job has run. 

 • Est Start – The estimated job time calculated using the estimated launch times and estimated 
durations of preceding jobs. This value is created at the time the production schedule is compiled. 

 • Time Zone – The assigned job timezone. The time value adjusts the timezone offset into Master 
time.

 • Job Time Zone – The timezone the job was run in.

 • Act Start – The job’s actual start time after it has launched. 

 • Act End – The actual ending time and date for the job occurrence.

 • Act Duration – The actual time that it took for the command or executable to run. The actual 
duration is used to calculate the historical average of the Est Duration field in the job’s definition. 
The actual duration value is 0 until after the job completes. 

Note The displayed value for the Actual Duration value of a job is updated every 90 seconds.

 • Date – The production date of the job. If the job does not execute until the next day, this date stays 
the same, since it represents when the job was scheduled to run based on its calendar or when the 
job was inserted as an unscheduled job.

 • Time window – The time window during which the job can run as defined in the job’s definition. 
The default, 12:00 AM to 11:59 PM, effectively means the job is eligible to run anytime during the 
day.

 • Agent – The name of the agent or agent list associated with the job, as specified in the job definition. 
This field displays the agent list name prior to the job running and then displays the chosen agent 
from the list after it is launched.

 • Queue – The queue that the queue manager assigns to the job. The queue to which the job is assigned 
depends upon the job’s properties, and the way that the queues are configured to assign jobs using 
queue filters. 

 • Priority – The job priority as defined in the job’s definition. Job priorities are only relative to the 
job priorities of other jobs within its queue before running. 

 • Runtime User – The user account that the job runs under when it executes.

 • Scheduled By – How the job entered the schedule. There are three options:

 – Event – The job was inserted by an action that was initiated by an event.

 – Calendar – The job was compiled into the schedule according to its calendar.

 – On Demand – The job was an ad hoc insertion through either operator action or the command 
line.

 • Owner – The user who owns the job. If the job is owned by a workgroup, the owner of the 
workgroup. Note that this column does not display the workgroup name itself, but the owner of the 
workgroup.

 • Parent Group(s) – All of the parent job groups that the job or job group belongs to. If the job or job 
group belongs to several job groups, the group path is shown.
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 • Command – The command, program or script that the job will execute, as specified in the job’s 
definition. The command path is relative to the agent machine on which the job runs. The command 
data includes any command parameters. 

 • Exit Code – The exit code that the command returns when the job is complete. The exit code is one 
way of determining whether the completion status of the job is Completed Normally (the exit code 
equals 0) or Completed Abnormally (the exit code does not equal 0). The exit code value can range 
from 0 to 30,000.

 • Job Full Name – The full directory path to the job and its job group name.

 • Job Type – The type of job.

 • Parent Group – The immediate parent job group that the job or job group belongs to.

 • Job Class – The job class the job is assigned to, if any.

 • Alias – An alternate name for the job, as set in its job definition. The job alias is limited to eight 
characters and due to this limitation is often used in the command line mode to refer to a job.

 • Predecessors – The job dependencies that have to be fulfilled before this job can run. This job will 
not run until the Predecessors have fulfilled the conditions set in this job’s definition.

 • Successors – Jobs that use this job as a job dependence. This job must fulfill a certain condition 
before Successors can run.

 • Group Instance – The group instance number applies only to jobs and groups with a parent group. 
As opposed to the day instance number (also known as the job ID) which is unique, the Group 
Instance is relative to other jobs in the parent group.

 • Agent Instance – The agent instance number applies only to broadcast jobs. For more information 
on broadcast jobs, see Controlling Production. The Agent Instance is relative to other jobs run by 
the same agent.

 • Ext ID – This number corresponds to the External ID field in a job’s Job Detail dialog. This 
number is the process ID number that the Windows operating system assigns to the highest level 
process within the job. If this is a SAP or PeopleSoft job, the Ext ID is the same as the SAP or 
PeopleSoft job ID.

 • WaitOp – Indicates if a job is waiting for the operator to release it.

 • Calendar – Displays the name of the calendar associated with the job instance.

Each column can be sorted in either ascending or descending order. Click any column name to change 
the column sort. For example, click Name on top of the Name column. The items in the column 
alphabetize from z to a. Click Name again and the items alphabetize from a to z. For a column that is 
numerical, the sort changes from earliest to latest time, or latest to earliest time.

Job Activity Preferences Dialog
Select View>Preferences from the main menu bar while viewing the Job Activity pane to display the Job 
Activity Preferences dialog.

Columns Tab

From the Columns tab, you can select which columns are displayed in the Job Activity pane and in what 
order they appear.

 • A checkmark to the left of a column title indicates that it will be displayed in the pane. No 
checkmark indicates that it will not be displayed.
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 • To rearrange the order in which the columns are displayed, select the column and click the up or 
down arrow.

Status Color Tab

The Status Colors tab lists every possible status a job can have. From the drop-down menu to the right 
of each field, you can select the color to represent that status in the Job Activity pane.

Grid Background Color Tab

On the Grid Background Color tab select an option from the drop-down menus to the right of each field. 
You can select the color to represent the grid background color in the Job Activity pane.

Navigator Context Menu
When you right-click in the Navigator pane while viewing the Job Activity pane, the Navigator context 
menu displays. 

This context menu contains the following options:

 • Statistics – Displays the Job Statistics dialog showing the number of scheduled and unscheduled 
jobs in the present day’s production schedule.

 • Filter – Displays the Job Filter dialog to filter the job occurrences that are displayed in the Jobs 
pane according to criteria you select. Has the same function as the Filter button on the toolbar. You 
can also custom-sort job occurrences. For more information about the Job Filter dialog, see 
<Jumps>“Job Filter Dialog” on page 126.

 • Group Display – Selecting Group Display brings up the Group Display submenu with the 
following menu options:

 – Expand Selected – Expands one level on the selected job group, displaying its child jobs. If 
multiple groups are selected, only the first group selected is expanded.

 – Collapse Selected – Collapses one level on the selected job group, hiding its child jobs. If 
multiple groups are selected, only the last job group selected is collapsed.

 – Expand All – Expands all levels on the currently selected group, respectively. 

 – Collapse All – Collapses all levels on the currently selected job groups to hide all child jobs.

 • Prior Day – Displays the production schedule for the day before the one currently displayed. Has 
the same function as the Prior Day button on the toolbar.

 • Next Day – Displays the production schedule for the day after the one currently displayed. Has the 
same function as the Next Day button on the toolbar.

 • Select Day – Displays a calendar from which you can select the date whose production schedule you 
want to view. Has the same function as the Select Day button on the toolbar.

 • Save View As – Displays the Save View dialog to name the view that you would like to save.

 • New Root Folder – Displays the New Root Folder dialog to name the new root folder that you 
would like to create in the Navigator pane.

 • New Sub Folder – Displays the New Sub Folder dialog to name the new sub folder that you would 
like to create in the Navigator pane.

 • Preferences – Displays the Preferences dialog for the Job Activity pane.
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 • Print – Displays the Reports pane to view and print your connection definitions. Has the same 
function as the Print button on the toolbar. For more information, see <Jumps>“Monitoring 
Production” on page 361.

 • Export – Saves the data in the current pane as an ASCII text file. You can then use the file data in 
other applications. 

 • Refresh – Updates the data in the current pane.

Job Activity Pane Context Menu
When you right-click in the Job Activity pane, the Job Activity context menu displays. 

The Job Activity context menu contains the following options:

 • Refresh – Updates the data in the Job Activity pane.

 • Filter – Displays the Job Filter dialog to filter the job occurrences that are displayed in the Jobs 
pane according to criteria you select. You can also custom-sort job occurrences. For more 
information about the Job Filter dialog, see <Jumps>“Job Filter Dialog” on page 126.

 • Print – Displays the Reports pane to view and print your jobs. Has the same function as the Print 
button on the toolbar. For more information, see <Jumps>“Monitoring Production” on page 361.

 • Print Selected – Displays the Reports pane to view and print your job selections. 

 • View Time By – Selecting View Time By displays the View Time by Agent dialog. From here, you 
can choose to view job times according to the time zone of your master, current Tidal Web client or 
an agent that you specify.

 • Group Display – Selecting Group Display brings up the Group Display submenu. The menu 
options are as follows:

 – Expand Selected – Expands one level on the selected job group, displaying its child jobs. If 
multiple groups are selected, only the first group selected is expanded.

 – Collapse Selected – Collapses one level on the selected job group, hiding its child jobs. If 
multiple groups are selected, only the last job group selected is collapsed.

 – Expand All – Expands all levels on the currently selected group, respectively. 

 – Collapse All – Collapses all levels on the currently selected job groups to hide all child jobs.

 • Prior Day – Displays the production schedule for the day before the one currently displayed.

 • Next Day – Displays the production schedule for the day after the one currently displayed.

 • Select Day – Displays a calendar to select the date whose production schedule you want to view.

 • Graphical View – If you selected the Use New Graphical View Layout Manager option on the 
Other tab of the System Configuration dialog, this option displays instead of the View option. 
Select this option again to return to the original view. (Refer to <Jumps>“Business Views Pane 
Interface” on page 263 for more information.) If this option is selected (a check mark is beside the 
option), the following menu options also are available. 

 • Details – When in the Jobs pane, displays the Job Detail dialog for the selected job occurrence. 
Alternately, you can display these dialogs by double-clicking the individual job record.

 • Statistics – Displays the Job Statistics dialog showing the number of scheduled and unscheduled 
jobs in the present day’s production schedule.

 • Goto Now – Sets the job pane’s date to the current date. 
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 • Job Control – Displays a submenu with options for manipulating jobs. For more information on job 
control menu options, see <Jumps>“Job Control Submenu” on page 117.

 • Insert Job into Schedule – Adds one new occurrence of the selected job into the production 
schedule regardless of the job’s (or job group’s) calendar setting or number of times the job is 
scheduled to repeat during the day. When a job or a job group is added, and the job or job group 
already resides in the production schedule, an incremented occurrence number appears next to the 
job occurrence in parentheses, i.e., Job A (2).

 • Remove Job(s) from Schedule – Removes the selected job occurrence from the production 
schedule. If you wish to remove all future occurrences of the job within the schedule, select the All 
option in the Confirmation dialog. The job occurrence cannot be removed unless it has a pre-launch 
status.

 • Require Operator Release – Holds the job until an operator releases it. The job will not run until 
it is released. When all the job’s dependencies are met, and it is ready to run, its status is Waiting 
On Operator. The information in the Operator Instructions field (Description tab) can inform the 
operator of any external requirements that need to be met before the job is released.

 • List Instances – Lists all job instances 

 • Successors – Advises which jobs, if any, are dependent on the currently selected job.

Job Control Submenu
When you select Job Control from the Job Activity context menu, a submenu displays.

Note After selecting a job control action from the menu, a context dialog confirms the success or failure of 
the action.

This submenu contains the following options:

 • Override – Overrides all unmet dependencies and changes the selected job status from Waiting On 
Dependencies to Waiting on Resource or Waiting On Operator. The job must have the status of 
Waiting On Dependencies for this job control function to be available. (For information on 
overriding individual dependencies, refer to <Jumps>“Dependencies Tab” on page 121.)

 • Hold/Stop – When a job is in the Held or Stopped state, the execution of the job will not begin or 
continue until it is manually released. Because Windows does not support the pausing and resuming 
of a process, the Hold/Stop option is not available for Windows jobs.

 • Hold – Changes the selected job status from Waiting On Dependencies, Waiting On Resource, 
Agent Inactive, or Agent Unavailable to Held. When a job group’s occurrence is selected, places 
all waiting jobs in Held status, and all active jobs in Stopped status.

 • Stop – Changes the selected job status from Active to Stopped. 

 • Release/Resume – This command recommences the execution of a job at the point at which it was 
stopped (suspended). On non-Windows agents, the Release/Resume command can also take a job 
in the Held state and release it so that it will launch once all of its dependencies have been met. 
Because Windows does not support the pausing and resuming of a process, the Release/Resume 
option is not available for Windows jobs.

 – Release – Changes the selected job status from Waiting On Operator or Held, to Active (with 
an intermediate Scheduled state). When a job group’s occurrence is selected, Release changes 
the job group’s status from Waiting On Operator to Active (with an intermediate Scheduled 
state), and changes all child job statuses from Waiting On Group to Scheduled.
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 – Resume – Changes the selected job status from Stopped to Active. Also changes the selected 
job status from Held to Waiting On Dependencies (with an intermediate Scheduled state). 
When a job group’s occurrence is selected, changes its status from Held to Active (with an 
intermediate Scheduled state). All child jobs that were Stopped become Active, and all that 
were Held become Waiting On Dependencies.

 • Cancel/Abort – Prevents or stops a job from running in the production schedule. TES agents react 
differently when a job with child jobs is aborted, depending upon the agent type and operating 
system.

Table 4-1 Agent Cancel/Abort Behavior

Type of Agent Abort Behavior of Jobs

 – Cancel – Changes the selected job status from Agent Inactive, Agent Unavailable, Deferred, 
Held, Waiting On Dependencies, Waiting On Operator, or Waiting On Resource to 
Canceled. Canceled jobs do not run in the production schedule.

 – Abort – Changes the selected job status from Active or Stopped to Aborted, and kills the active 
job process on the system.

Caution Avoid excessive aborting of job processes as this may lead to system instability. Instability may appear 
after more than 10 job aborts. Restore system stability by rebooting the agent machine.

When selecting Cancel/Abort you can choose to release the selected job’s dependents. If you 
choose to release, the dependent job will no longer be dependent on the job you are canceling or 
aborting.

 • Cancel Pending – Stops or prevents a job instance from running but overrides the dependencies in 
the job stream so that children of the job will consider the parent to have completed normally. In a 
job group, all of the children also go to Cancel Pending status. Once all of the dependencies of the 
jobs in Cancel Pending status complete, the jobs end in a Cancel Normally status which is 
considered the same as Completed Normally.

 • Cancel/Abort All – Prevents all occurrences of a job that are not complete from running in the 
production schedule. When you select Cancel/Abort All, you can choose whether to release the 
selected job’s dependents. If you choose to release, the dependent job will no longer be dependent 
on the jobs you are canceling or aborting.

Agent for Windows When TES launches a job, a Windows Job Object 
is created that spawns the actual job process. 
Aborting the job in TES, destroys the job object 
and kills the job process. If you abort a job on 
Windows, all of its child processes are aborted 
also.

Agent for Unix Aborting a job sends a SIGTERM (request to 
terminate) message to the job and its child 
processes before sending a SIGKILL message 
that actually kills all of its child processes. The 
interval between the SIGTERM and SIGKILL 
signals can be configured. More information on 
configuring agent parameters is available in 
Installing the Unix Agent chapter of the 
Installation and Configuration Guide.
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 • Rerun – Changes the selected job status from Aborted, Completed Normally, Completed 
Abnormally or Error Occurred to Active (with an intermediate Scheduled state). A new instance 
ID of the job is not created. You cannot rerun a job with the status of Externally Defined, Orphaned 
or Skipped.

 • Set – Changes the selected job or job group completion status. The selected status can affect all other 
jobs dependent on that job or job group. When a status is changed with this command, an asterisk 
appears after the new status. For example, Completed Normally*. You can choose from the 
following: Completed Normally, Completed Abnormally, Externally Defined, Error Occurred, 
Orphaned or Skipped. 

View Time By Dialog
The View Time by Agent dialog displays by clicking the View Time By button on the TES toolbar while 
in the Job Activity pane.

This dialog configures the times displayed in the schedule according to the time zone of one of the 
system components. TES may be managing a production schedule that includes components that are 
spread out over a wide geographic area. This geographic area may encompass several time zones. When 
you are scheduling jobs over diverse timezones you have to account for the fact that the master, agent 
and Tidal Web client may be in different time zones.

Note You can configure the jobs to run according to the timezone used by the master or by the agent from the 
Timezone tab of the System Configuration dialog. Master and Job Based Timezone offset will be applied 
into all time value for that job.

You can configure the Tidal Web client to display the estimated and actual times of jobs from the 
viewpoint of one of the following components:

 • Master – The master controlling the production schedule

 • Client – The Tidal Web client being used

 • Job – The job being run

 • Agent – The agent running the job

Job Detail Dialog
The Job Detail dialog displays when you double-click a job occurrence record in the Job Activity pane 
or right-click and select Details from the context menu.The details shown for a job differ from the details 
for a job group, thus while the Job Details dialog for a job group is very similar, it does not have the 
same tabs as a job does.

Common To All Tabs
 • Job Name – The name of the job as defined in its job definition.

 • Job No. – The job’s instance number.
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 • Print – Clicking this button displays a report that lists the same fields of information contained 
within on the various tabs of this Job Detail dialog. This report can be saved or printed. You can 
elect to display the report with or without the job output if the job has run.

 • Defaults – This button becomes available whenever you make a change to the job’s parameters from 
the Override tab. Clicking the Defaults button after a change returns all the fields on the Override 
tab to their original values. The Defaults button is then unavailable until the next override change. 
This button is unavailable from the other tabs of the dialog.

Status Tab
This tab contains the following elements:

 • Status – The job’s current status. 

 • Est. Start Time – Estimated job launch time based on its time dependencies and the launch times 
and estimated durations of preceding jobs. You can view all the dependent jobs on the Dependencies 
tab.

 • Act. Start Time – The time the job became active. Until the job is active, this field is empty.

 • Est. Duration – The estimated time it will take for the job to run. If the job has never run before, it 
contains the value in the Estimated Duration field in the job’s definition. Otherwise, it contains a 
historical average of the Actual Duration.

 • Act. Duration – The actual time the job took to run. 

 • Job Owner – The user that owns the job.

 • Scheduled By – Indicates how the job entered the production schedule. Three possible values may 
be displayed here:

 – Calendar – Compiled into the schedule based on an assigned calendar. 

 – Event – Inserted by a job action based on an event trigger. 

 – On Demand – Inserted by an operator via the Tidal Web client, command-line, API or Web 
Service.

 • Exit Code – The exit code of the completed job (if the job has not completed, this field is blank). 
This field is not displayed for a job group. Exit code values mean:

 – if the value equals 0, the job has completed normally

 – if the value does not equal 0, the job has completed abnormally

 • External ID – By default, this is the ID number assigned to the job process by the operating system. 
Certain job types have an External ID assigned by third party software, such as SAP or PeopleSoft.

 • Reruns – The number of times the job has rerun for the day.

 • Disable Carryover – Selecting this option prevents the job from being carried forward to the next 
day’s schedule if the job does not run on its scheduled day. If the Try again tomorrow option in 
the If not ready by end of day field on the Schedule tab of a job definition is selected, it will 
override the Disable Carryover option and the job will run on the next day.
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Audit Log Tab
Displays both user-initiated job interaction and production schedule audit trail messages for the job 
including job control actions, job occurrence status changes and errors. 
Double-click a record to display its details more clearly.

This tab displays the following information:

 • Time – The date and time the audit was recorded.

 • Description – The job audit or error message describing the change/error to the job. Audit 
information is retained according to the audit retention setting in the System Configuration dialog. 

 • User – The user that submitted the job.

Output Tab
Displays the standard output of the job. TES can be configured to save or discard job output by default 
from the Defaults tab of the System Configuration dialog. Regardless of the system default, any 
individual job instance can be configured from its job definition to override the system default. 

 • If the Append option in the Save Output field on the Options tab of the job definition is selected 
in the job’s definition, the job’s standard output file is transferred to the master and displayed on this 
tab. Each time a job is rerun that run’s output is separated by a block of number signs (#). 

 • If the Replace option in the Save Output field is selected, then only the output from the last job 
instance that ran is saved. The output from the previous time that the job ran is overwritten. 

 • If the Discard option of the Save Output field is selected than this tab will not have any job output 
displayed here. 

If a job is canceled before it can complete, any partial output that was generated during the processing 
of the job displays on the Output tab. Note that a job group does not have an Output tab in its Job Details 
dialog.

Note Scheduler’s default is to discard job output. To save or append job output or to specify that the output be 
produced in summary format, change the system default on the Defaults tab of the System Configuration 
dialog. This can be adjusted for individual jobs from the Options tab of that job’s Job Definition dialog.

You can refresh the output if parameters have been changed after runtime by clicking Refresh output.

Dependencies Tab
Shows all predecessors (job, file, time and variable dependencies) needed before a job can run. It also 
displays all successors occurring after the job runs.

From the Dependencies tab, you can override individual job dependencies for a job instance (but not for 
a job group). (To override all of a job instance’s dependencies, refer to the override section of the 
<Jumps>“Job Control Submenu” on page 117.) Other instances of the job are not affected when you 
override a dependency. 

There are three ways to override a dependency:

 • Select the dependency in the Predecessors field and click the Override button.
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 • Select the dependency in the Predecessors field, right-click to display the context menu and choose 
the Override option.

 • Select the dependency in the Predecessors field and use the keyboard shortcut, Ctrl+O.

This tab contains the following elements:

 • Include dependencies already satisfied option – When not checked, only dependencies that have 
not been met are displayed. Otherwise, met dependencies are displayed with a green box outlining 
the dependency’s icon. The default is checked to show all predecessors and successors.

 • Predecessors – Displays files, times that must be met and hierarchical trees of earlier jobs that must 
reach a particular status before this job can run. Jobs on higher levels of the hierarchies depend upon 
jobs in lower levels.

 • Override Button – Select a specific dependency and click the Override button to override the 
dependency for a job instance. 

 • Successors – Displays a hierarchical tree of jobs that are dependent on the job in question. Jobs on 
lower levels of the hierarchies depend on the jobs above.

File Dependencies

File dependencies are defined in the job’s definition dialog, and are displayed with a file icon, the file’s 
path name and the dependency expression (Exist, Not Exist, etc…).

Job Dependencies

Job dependencies are defined in the job’s definition dialog and are displayed with a job icon, the job’s 
name, the selected logical operator (=, <>, etc…), its target status, and the present status. If the job is 
not currently in the production schedule, the icon changes to the not-in-schedule icon.

Note To have a job ignore a job dependency when the dependency is not in the schedule, select the Ignore 
dependency if job not in schedule option in the Job Dependency Definition dialog.

Time Dependencies

Time dependencies are displayed with a time icon, and indicate the time when the time dependency will 
be met.

Variable Dependencies

Variable dependencies are defined in the job’s definition dialog and are displayed with a variable icon, 
the variable’s name, its dependency expression and its present value in parentheses.

Resources Tab
The Resources tab of the Job Detail dialog displays information about any resources assigned to a job. 
The current and required system resource values, with a column showing the status of the resource, 
displays on this tab. In the case of a job that uses an agent list and has not yet been assigned an agent 
from the list, the current and status columns are grayed out.
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The possible statuses for the resource are:

 • Available – The resource is available. The job cannot use the resource until all of its needed 
resources are available at the same time.

 • Unavailable – The resource is unavailable. 

 • Waiting – The resource is not available because another job is using the resource. 

 • Locked – The job is running. All of the listed resources will display the Locked status. A job cannot 
run until all of its assigned resources are simultaneously available. When the resources do become 
available to the job, the job locks up its share of each resource until the job completes and the 
resource is released for use by other jobs.

A resource in a Locked status cannot be overridden to release it but a user could modify the 
resource's definition to temporarily increase its limit and make more of the resource available to 
other jobs. 

Note Resources cannot be assigned to a job group. If this is a job group definition, then the Resources 
tab is not displayed.

The Resources tab contains the following elements:. 

 • Resource Consumption

 – Type – The kind of resource that is being used, Virtual or Agent. 

 – Resource Name – Displays the name of the resource associated with the job. 

 – Amount Used – The amount of the resource's specified limit that the job uses. This number 
cannot exceed the number shown in the Amount Available column. 

 – Amount Available – The amount of the resource that is available to be used. This number is 
derived by subtracting the amount of the resource currently in use from the limit specified in the 
resource’s definition.

 – Status – Denotes the status of a resource assigned to the job. There are three possible statuses:

Available – The resource is available for the job.

Waiting – The resource is not currently available. The job is unable to run until the specified 
amount (shown in the Amount Needed column) of the resource is available.

Locked – The resource is being used by job. The amount of the resource being used by the job 
(shown in the Amount Used column) is unavailable to any other job until this job completes. If 
multiple resources are required for the job, then an all or nothing approach is used. No resource 
is locked up until all of the required resources are available and can be locked simultaneously. 

Note A resource in a locked status cannot be overridden to release it but a user could modify the 
resource's definition to temporarily increase its limit and make more of the resource 
available to other jobs.

 • Resource conditions

 – Type – The kind of resource that is being used, Published or Custom. 

 – Resource Name – Displays the name of the resource associated with the job.

 – Current – Displays the current value.

 – Condition – Contains the conditional operators depending on the data type of the resource.
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 – Required – Displays the amount of the resource needed by the job. This amount is defined in 
the Resource Requirement Definition dialog.

 – Status – Denotes the status of a resource assigned to the job. There are three possible statuses:

Available – The resource is available for the job.

Waiting – The resource is not currently available. The job is unable to run until the specified 
amount (shown in the Amount Needed column) of the resource is available.

Locked – The resource is being used by job. The amount of the resource being used by the job 
(shown in the Amount Used column) is unavailable to any other job until this job completes. If 
multiple resources are required for the job, then an all or nothing approach is used. No resource 
is locked up until all of the required resources are available and can be locked simultaneously.

Variables Tab
Displays the variables used by the job group. These variables are isolated from any changes to their 
values that occur outside of this job group and its parent or child groups. The Job Details dialog for a 
job does not have a Variables tab.

Override Tab
Displays job properties that can be changed for this occurrence at any time while the job is waiting to 
run. After a job runs, it is only useful to change these values if you rerun the job. Changes made only 
affect the instance and not the rule as defined in the Job Definition dialog. The Job Details dialog for a 
job group does not have an Override tab.

Note After changing any of these values and clicking OK, you are prompted to confirm the changes, and you 
are given the choice to apply the changes to all occurrences of the job in today’s schedule if this is a 
repeating job. This applies to all repeating jobs that have not run yet, and all additions of this job that 
were inserted manually.

This tab contains the following elements:

 • Agent – The agent that the job runs on. This is useful if the job failed on one agent and you want to 
rerun it on another. You can select from a list of active agents only. Be sure to choose an agent 
platform that will support the command in the command field.

 • Agent List – The list of available agents that can run the job. The master assigns an agent to the job 
only when the job's dependencies are met and the job is ready to run. The master assigns an agent 
according to demands of the production schedule and the agent's job limit at the time that the job is 
ready to run.

Note Since the agent is not assigned to a job until the last minute, if a user looks at a Job Details dialog before 
the job runs (e.g., the job is in a Waiting on Dependencies state), the Agent field on the Override tab is 
empty. The master does not select an agent from the agent list displayed in the Agent List field until the 
job’s dependencies are met and the job is ready to run. Only then is the agent selected and the name of 
the agent displayed in the Agent field. If the job reruns, the master may assign a different agent from the 
agent list according to the demands of the production schedule.
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 • Queue – Normally, jobs are automatically assigned to queues. You can use this field to override the 
automatic assignment. You may want to do this if the present queue is too full to run the job any time 
soon.

 • Runtime User – The runtime user, if any, assigned to the job. If that user account is currently 
experiencing problems, you can select another runtime user in this field.

 • Priority – The job priority. This value ranges from low (0) to high (100). This value is used to 
prioritize job execution by comparing with other jobs within the job’s destination queue.

 • From Time – The start of a job instance’s time dependency pane. By modifying the time within this 
field, you can override the time dependency.

 • Until Time – The end of a job instance’s time dependency pane. Modifying the time in this field 
overrides the jobs’s time dependency. 

 • Remove Time Dependency – This button clears the values entered in the From Time and Until 
Time fields, removing the time dependency for this job instance.

 • Defaults – This button becomes available whenever you make a change to the job’s parameters from 
the Override tab. Clicking the Defaults button after a change returns all the fields on the Override 
tab to their original values. The Defaults button is then unavailable until the next override change.

Runbook Tab
The Runbook tab is intended to supply any instructions for the user relative to the execution of this job. 
This field can be used effectively with the Require operator release option in the job’s definition. 

Notes Tab
Use this field to enter other notes concerning the job.

This tab contains the following elements:

 • Other Notes – A free text field where you can type any instructions for the operator, up to 255 
characters long or enter a web address that provides relevant information about the job. If you 
selected the Require operator release option on the Options tab, you could use this field for 
detailed reminders about the circumstances under which to run this job with the Require operator 
release option selected.

A web address or network directory address can be entered here and if the Load URL option is 
selected, the specified directory or web page from an internet site or a company intranet site 
displays. The web page or directory pane that displays here is an active pane that can be refreshed 
and whose links and folders can be accessed by clicking. You can right-click a web page in this field 
to display a context menu of the same options available in the web browser.

 • Load URL – If a web URL is entered in the text field and this option is selected then that web page 
displays in the text field. This web address can be for an internet site or a company intranet site. This 
can be very useful if information pertaining to a job is stored on a company intranet.
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History Tab
Details the job run history of every occurrence of this job in the production schedule sorted by Start 
Time and then by job number in descending order. The history includes jobs that have completed and 
jobs currently waiting to run either as repeated jobs and/or in future days of the production schedule. 
The history is retained according to the retention history setting in the job’s definition.

Note Columns in the History tab can be resized by clicking the right border bar and dragging left or right.

This tab contains the following elements:

 • Job No. – The unique number assigned to the job occurrence (day instance).

 • Date – The date on which the occurrence was scheduled to run.

 • Status – The present or final status of the occurrence. For a description of job statuses, see 
<Jumps>“Jobs” on page 139.

 • Act Start Time – For past or present jobs, the actual time the job occurrence started. For future jobs, 
this field is blank.

 • Act End Time – For past jobs, the actual time the job occurrence ended. For jobs currently running 
or future jobs, this field is blank.

 • Act Duration – The actual duration of the job.

 • Est Start Time – For past or present jobs, the time the job was estimated to start. For future jobs, 
the estimated time the job occurrence is expected to start. The start time may vary due to system 
resource utilization, and job dependencies.

 • Reruns – The number of times the job has been rerun.

 • Command – The command path, name and parameters that were executed for the occurrence of the 
job.

 • Priority – The priority of the job when the job ran.

Job Filter Dialog
The Job Filter dialog displays by right-clicking in the Job Activity pane and selecting the Filter option 
from the context menu.

The Job Filter dialog allows you to perform the following tasks:

 • View only the jobs that have the statuses that you want to see.

 • View jobs using wildcards to specify the job name.

 • View jobs that are running or ran on a specific agent.

 • View jobs that are owned by a specific user.

 • View jobs that are run as a specific user.

 • View jobs that belong to a specific job class.

 • View jobs that will run in a certain queue.

 • View jobs that run a certain command

 • View only jobs, only job groups, or both.
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Note Filters only apply to jobs within groups, not to groups themselves. Groups are only displayed if at least 
one child within the group passes the filter criteria. If, according to the criteria, the group would be 
empty, the group is not displayed. If the Show Groups option is not selected, groups are ignored 
completely, and filters apply to the individual jobs which are now displayed outside of their group.

Status Filter
Use this filter to view only jobs with the statuses you are interested in. The default is all statuses (all 
selected). 

The Job Filter dialog contains the following status viewing options:

 • Aborted – Shows all jobs that were actively running and were aborted by the operator.

 • Active – Shows all jobs that are currently running in the production schedule. Jobs that run longer 
than a day are shown on the day it started.

 • Agent Disabled – Shows all jobs that could not launch because their assigned agent is inactive.

 • Agent Unavailable – Shows all jobs that cannot run because their assigned agent is either not online 
or not presently connected. 

 • Canceled – Shows all jobs that were canceled by the operator.

 • Completed Abnormally – Displays all jobs that completed with an exit code outside the designated 
normal range of values.

 • Completed Normally – Displays all jobs that completed with an exit code within the designated 
normal range of values. This is configured on the Run tab of the job definition. The default exit code 
is 0 if a range of values is not specified.

 • Deferred – Shows all jobs that were deferred because another occurrence of the job was running 
when the job was launched. These jobs have their concurrency option set to Deferred in their job 
definition.

 • Error Occurred – Shows all jobs where an error occurred that prevented the job from running. Error 
messages can be examined in the Job Details dialog.

 • Externally Defined – Shows all jobs that have a completion status defined by an external program.

 • Held – Shows all jobs that were put on hold by an operator.

 • Launched – Shows all jobs that are being launched by the Queue Manager.

 • Orphaned – Shows all jobs where the connection between the agent and master failed while the job 
was running, and thus the job’s status is unknown.

 • Scheduled – Shows all jobs that have been scheduled to run on future days, and jobs running today 
where the status has not yet been determined.

 • Skipped – Shows all jobs that were skipped because another occurrence of the job was running 
when the job was launched. These jobs have the Skip option set in the If job is currently running 
field on the Options tab of their job definition.

 • Stopped – Shows all active jobs that were stopped by an operator. Jobs can be resumed by using the 
Release job control menu item.

 • Timed Out – Shows all jobs that could not launch during their date and time window and will never 
run because Timeout is selected in the If not ready by end of day field on the Schedule tab of the 
Job Definition dialog.
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 • Timed Out for Day – Shows all jobs that missed or could not launch during their time window and 
cannot run for the rest of the day. These jobs will be carried forward to the next day because the Try 
again tomorrow option is selected in the Schedule tab of the Job Definition dialog.

 • Waiting on Children – Shows all parent job groups that are waiting for their children to reach the 
necessary status. 

 • Waiting on Dependencies – Shows all jobs that are waiting on time, variable, file or job 
dependencies. You can view all the job dependency information from the Job Details dialog by 
double-clicking the job in the Jobs pane. 

 • Waiting On Group – Shows all jobs that are waiting on their job group’s dependencies to be 
satisfied. You can view the job group dependencies information from the Job Details dialog by 
double-clicking the group in question in the Jobs pane. 

 • Waiting on Operator – Shows all jobs that have passed their dependency tests, and are waiting for 
an operator to release it. The job can be released using the Release/Resume job control command.

 • Waiting on Resource – Shows all jobs that are waiting for an agent to free resources so that the job 
can run. 

Note When the Status column is sorted, the sort order is defined by the sort order listed in the System 
Configuration dialog. For more information about the System Configuration dialog, see, “System 
Configuration” on page 68.

Hours
Use this section to filter for jobs that run only during certain hours. Select the check box for each hour 
you wish to filter for. 

Other Filters
 • Job – Shows all the job occurrences matching the wildcard string specified. You can use the 

following wildcard characters.

 – * (Asterisk) The asterisk character masks any number of characters on and to the right of the 
location it is placed. For example, A* will match (allow in) AB, ABB, and ABBB.

 – ? (Question Mark) The question mark masks one character in the location it is placed. For 
example, A?A will match ABA and ACA, but not ABB or ABBA.

 – [x, y, z] The brackets with commas let you specify a set of characters to filter in to that location 
in the string. For example, A[X,Y]B accepts AXB and AYB but not AAB.

 – [a-z] You can also specify ranges within brackets. For example, A[X-Z]B filters in AXB, AYB, 
and AZB but not AWB.

 • Group – In this text field, type the name of a group filter. The groups configured with this filter are 
displayed as well as their children.

 • Agent – Shows all job occurrences that run under the selected agent. When no agent is selected, all 
agents are assumed.

 • Owner – Shows all job occurrences that belong to the selected user or workgroup.

 • Runtime User – Shows jobs assigned to the selected runtime user.
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 • Job Class – Shows jobs belonging to the selected job class.

 • Queue – Shows all job occurrences that run in the selected queue.

 • Command – Shows all jobs that execute the selected command.

 • Calendar – Displays all jobs that use the selected calendar.

 • Show Jobs – Displays all jobs meeting the defined filtering criteria. No jobs display if this is not 
selected, though job groups display if the Show Groups option is selected.

 • Show Groups – Displays a job group if it meets the defined criteria. No job groups are displayed if 
this option is not selected. 

 • Show Carryover – Displays any jobs that carried over from previous production dates.

 • Show Scheduled Only – Displays jobs that were compiled as part of the original production 
schedule. The Show Ad Hoc Only option cannot be selected if this option is selected. 

 • Show Ad Hoc Only – Displays jobs that were not part of the original production schedule but were 
manually inserted into the schedule by an operator.The Show Scheduled Only option cannot be 
selected if this option is selected. 

Note Jobs that did not finish on their production dates carry over only if the Carry Over Unfinished Schedule 
option was selected on the Master tab of the System Configuration dialog.

 • Server Side Filter – Select this option if the job filter criteria does not change very often. This 
option improves performance by reducing network traffic. With this option selected, only jobs 
meeting the defined criteria are downloaded to the Tidal Web client when the Job Activity pane is 
selected. Once the filter criteria is changed, jobs are filtered again according to the new criteria and 
downloaded again. 

If the option is not selected, all jobs are downloaded first and then filtered by the Tidal Web client 
to meet the defined criteria. After the initial download it is quicker to refilter the jobs from the Tidal 
Web client since they do not have to be downloaded again.

 • Defaults – Resets the job filter criteria to the default options. The defaults include all statuses, all 
hours, and the Show Jobs, Show Groups and Show Carryover options. The criteria in the Other 
Filters section is cleared.

Job Statistics Dialog
The Job Statistics dialog displays by right-clicking in the Job Activity pane and selecting Statistics from 
the context menu. The Job Statistics dialog shows statistics regarding job occurrences for the day 
currently displayed in the Job Activity pane. You can view statistics for All Jobs, Production jobs and 
Unscheduled jobs on the respective tab.

All Jobs, Production and Unscheduled Tabs
These tabs contain the following elements:

 • Completed Normally – Shows the number of jobs that completed normally.

 • Completed Abnormally – Shows the number of jobs that completed abnormally.

 • Launch Errors – Shows the number of jobs that have a status of Error Occurred.
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 • Total Reruns – Shows the number of jobs that have been rerun manually.

 • Number of Filtered Jobs – Shows the number of jobs that have been filtered into the Job Activity 
pane using the job filter. 

Job Activity Pane Procedures

Adding or Removing Columns in the Job Activity Pane
To add or remove columns:

Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 Select View>Preferences from the main menu bar or right-click the Navigator pane and select 
Preferences from the context menu to display the Preferences dialog.

Step 3 Click the Columns tab. By default, all columns are used.

 • To remove columns, clear the check box to the left of the column name. 

 • To include columns, click the check box so that a black checkmark appears.

Adding a New Job or Group Occurrence to the Schedule
To add a new job or group occurrence:

Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 Right-click the job or job group occurrence to add to the production schedule and select Insert Job Into 
Schedule from the context menu or click the job or job group, and from the Activities main menu, select 
Insert Job Into Schedule. 

Step 3 Click Yes at the confirmation prompt. 

Another occurrence of the selected job or job group is added to today’s production schedule regardless 
of its calendar dates (if any). If the job is defined to repeat, only one occurrence of the job enters the 
schedule. Note that a job must have the Unscheduled Allowed option selected in its Job Definition to 
be added in this manner. 

Adjusting Column Widths in the Job Activity Pane
To adjust a column’s width:

Step 1 Place the cursor on the right vertical border of the column heading. The mouse pointer turns into the 
separator icon.
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Step 2 Hold down the left mouse button and resize the width.

Deleting Jobs or Groups from the Production Schedule
To remove jobs that have not yet launched from the production schedule:

Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 Right-click the job or job group occurrence to remove, and from the context menu select Remove Job(s) 
from Schedule. In the resulting confirmation dialog, select Yes if you only want to delete the selected 
job occurrence. If you wish to delete all future scheduled occurrences of the job, select the All option.

You can select multiple jobs or job groups simultaneously.

 • To select more than one job or job group that are adjacent to each other, hold down the Shift key and 
select the first and last jobs.

 • To select more than one job or job group that are not adjacent to each other, hold down the Control 
key while selecting the desired job occurrences.

Step 3 Click Yes at the confirmation prompt.

Remove Job(s) from Schedule will remove any pre-launch job occurrence from the schedule, for any 
date. Only the job occurrence you select is removed. If a job group occurrence is selected, all of the 
group’s child jobs are removed.

Filtering Jobs in the Job Activity Pane Based on Job Status
To filter a job:

Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 Click the Filter button on the TES toolbar or right-click the Navigator pane and select Filter from the 
context menu to display the Job Filter dialog.

The statuses that are presently displayed are the ones with a check mark.

Step 3 Select the agent, owner and job statuses to view.

Moving to Different Dates and Times in the Job Activity Pane
You can view job occurrences for past, present or future days. Each job’s retention history value in its 
job definition determines how far back you can see its job occurrences. The Future Days value in the 
System Configuration dialog determines how far you can see into the future.

Note When you are viewing the current day in the Job Activity pane, you may also see jobs from previous 
dates if those jobs have not yet completed.
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To move to different dates and times:

From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

 • To move backward one day in the production schedule, right-click in the Job Activity pane and 
select Prior Day from the context menu.

 • To move forward one day in the production schedule, right-click in the Job Activity pane and select 
Next Day from the context menu.

 • To move to today’s date and time, right-click the Job Activity pane and select Goto Now from the 
context menu.

 • To move to a job’s graphical start location, right-click the job’s record and select Goto Job Time 
from the context menu to display the job’s start time.

Pausing the Production Schedule
You can pause and then resume the production schedule at any time. You can also pause and resume job 
launching without having any affect on scheduling. 

When you pause a production schedule, the master service is stopped and waiting jobs are prevented 
from running, even if their dependencies are met. Jobs that are already in Active status will continue to 
run on their respective agents; however, their updated status (for example, Completed Normally) will 
not be displayed in the Job Activity pane until the master service is restarted.

When you pause job launching, jobs can still be scheduled and calendars compiled, but jobs will not 
actually launch until job launching is resumed.

To pause the production schedule or job launching:

Step 1 From the Navigator pane, select Operations>Job Activity> to display the Job Activity pane.

Step 2 From the Activities main menu, select Pause Scheduler or Pause Job Launching.

Rearranging Columns in the Job Activity Pane
To rearrange columns:

Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 From the View main menu, select Preferences or right-click the Navigator pane and select Preferences 
from the context menu to display the Preferences dialog. 

Step 3 Click the Columns tab. 

Step 4 Select the column and click the up or down arrows to arrange the titles into the desired order.

Recreating the Production Schedule
To recreate the production schedule:
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Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 From the Activities menu, select Create Schedule to display the Create Schedule dialog.

Step 3 Select the date range for which to create the schedule.

Step 4 If you want repeating jobs with no time window to start immediately, rather than after midnight, select 
the For today’s repeating jobs with no time window, start repeating ASAP option.

Step 5 TES searches for all qualified jobs to add to the production schedule for the selected dates.

Warning All job occurrences that were added manually and all records of jobs that ran will be lost. 
Furthermore, the Create Schedule recreates the schedule at the time you issue the command. This 
means that jobs whose dependencies have not been met can qualify to run immediately. Use this 
command with caution.

Refreshing the Job Activity Pane
To refresh:

Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 From the View main menu, select Refresh Data or Refresh All Data.

Resuming the Production Schedule or Job Launching
To resume the production schedule or job launching:

Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 From the Activities main menu, select Resume Scheduler or Resume Job Launching.

Saving a Job’s Output on the Master
You can view the output of a job after the job finishes running. In order to view the output of a job from 
the Job Activity pane, you must save the output for the job on the master (this is the default).

To save a job’s output on the master:

Step 1 From the Navigator pane, select Definitions>Jobs to display the Jobs pane.

Step 2 Select the job for which to save output.

Step 3 Click the Edit button to display the Job Definition dialog.

Step 4 Click the Options tab. 
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Step 5 In the Save Output option, select Append or Replace.

Step 6 Click OK. The next time the job completes, you can view its output from the Job Detail dialog.

Selecting or Removing All Job Filters in the Job Activity Pane
To select or remove all job filters:

Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 Click the Filter button on the TES toolbar or right-click the Navigator pane and select Filter from the 
context menu to display the Job Filter dialog.

Step 3 Right-click in the Statuses section and select Check All or Uncheck All from the context menu.

Setting the Completion Status of a Job

Note You should only set the completion status of jobs that have already finished running. Setting completion 
status of a job that is still active, may adversely affect job activity.

To set the completion status:

Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 Select the job on which to perform job control.

Step 3 Right-click the job to open the Job Activity context menu.

Step 4 From the Job Control submenu, select Set and from the Set submenu, select the desired job completion 
status.

Note When job completion statuses are changed in this way, an asterisk appears to the right of it, for 
example, Completed Normally*.

Sorting Jobs in the Job Activity Pane Using Column Headers
You can sort the job occurrences displayed in the Job Activity pane by two different sorting criteria. You 
can sort on a primary criteria and in turn, organize the primary sort by secondary criteria. The sorts are 
done by column header in either alphabetical or numerical order depending on the type of data contained 
in the column.

To sort a job using a column header:
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Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 Click the column header to select it for a primary sort. The jobs sort alphabetically (in text data) or 
numerically (if numerical data). A single arrow displays beside the column header to denote the primary 
sort.

If you click the header more than once, the sort order toggles back and forth from ascending to 
descending order.

Step 3 To perform a secondary sort, hold down the ALT key while clicking the column header. The secondary 
sort displays a double arrow in the column header.

For example, click the Name column heading. The items in the column are alphabetized from a to z 
(because the column contains alphabetical data). Clicking again reverses the order z to a. Click the Time 
column header while holding down the ALT key and the jobs remain in alphabetical order but are now 
organized also by numerical order (since this column contains numerical data). Now the jobs are 
arranged in alphabetical order and each numerical segment is organized from earliest time to latest time. 
Clicking again on the secondary sort column while holding down the ALT key reverses the secondary 
sort to latest time to earliest time.

If you click the header more than once, the sort order toggles back and forth from ascending to 
descending order.

Sorting Jobs Using the Job Filter Dialog
To sort jobs using the Job Filter dialog:

Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 Click the Filter button on the TES toolbar or right-click the Navigator pane and select Filter from the 
context menu to display the Job Filter dialog.

Step 3 Checking or clearing the options for status or hours enables you to sort jobs using those criteria. You can 
also sort using other criteria listed including by job name, by agent, by queue, by command, etc.

Note The Job Filter dialog includes filter options that affect sorting. For example, if you want to sort 
by the status column, and some statuses have been filtered out, those statuses will not be used 
for sorting.

Note When a Status column is clicked for sorting within the Job Activity pane, the order is defined by 
the settings on the Job Status Order tab in the System Configuration dialog.

Stopping or Starting Jobs in the Job Activity Pane
To stop or start a job:
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Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 Select the job on which to perform job control.

Step 3 Right-click the job to display the Job Activity context menu.

Step 4 From the Job Control submenu, select one of the following job control options:

 • Select Override to override a job’s dependencies. The job enters a queue and becomes active. 
Override ignores all dependencies and launches the job immediately.

 • Select Hold/Stop to stop a job from running or to keep a job from launching. The job enters the Held 
or Stopped status. If the job cannot be held or stopped, you cannot select this menu item. 

Note Windows jobs cannot be suspended, therefore this menu item is unavailable for active Windows 
jobs.

 • Select Release/Resume to release a held job, or a job waiting for operator release or to start a 
stopped job. The job enters the Active or Waiting On Dependencies status. If the job can’t be 
released or resumed, you won’t be able to select this menu item.

 • Select Cancel/Abort to cancel a job before running or to abort a job while running (Canceled jobs 
cannot be rerun). The job enters the Canceled or Aborted status. If the job can’t be canceled or 
aborted, you won’t be able to select this menu item.

 • Select Cancel/Abort All to cancel all occurrences of a job before running or to abort all occurrences 
of a job while running. All occurrences of the same job enter the Canceled or Aborted status.

 • Select Rerun to rerun a job. The job re-enters the schedule and is re-executed with the same job ID 
number. A new occurrence ID is not created. If the job can’t be rerun, you won’t be able to select 
this menu item. 

Viewing a Job’s Output
You can view the output of a job after the job finishes running. In order to view the output of a job from 
the Job Activity pane, you must first have the Save Output option selected in the job’s or job group’s 
definition.

Note Scheduler’s default is to discard job output.

To view a job’s output:

Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 Double-click the completed job to display the Job Detail dialog.

Step 3 Click the Output tab to view job output.
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Viewing Other Dates in the Production Schedule
To view other dates:

Step 1 From the Navigator pane, select Operations>Job Activity to display the Job Activity pane.

Step 2 Click the Select Day button or right-click in the Job Activity pane and select the Select Day option to 
display a Calendar tab. 

Step 3 Click the date to go to. You can use the arrow controls in the title bar to move to different months.
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