
 

 

C H A P T E R 2

Getting Started

Connecting to Your First Server/Environment
This section contains instructions for connecting the console to your first Process Orchestrator server.

Before You Begin

There are several user groups assigned to Process Orchestrator’s built-in security roles. Before 
attempting to access the console, you must be a member of one of these user groups or another group to 
which your administrator has assigned custom role privileges. If you do not have access or the 
appropriate rights, please contact your local IT administrator. 

Step 1 Choose Start > Programs > Cisco > Cisco Process Orchestrator > Cisco Process Orchestrator 
Console. 

Step 2 In the Select Server dialog, select a server name and click Connect to Server. 

Step 3 To configure the console server connection, choose Tools > Options, and update the parameters as 
necessary.

Understanding the User Interface

Process Orchestrator Console Components
The following topics describe the main components of the Process Orchestrator console:

• Console Menus

• Toolbars

• Workspaces

• Results Pane

• Details Pane

• Process Viewer

• Process Editor Menus
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Console Overview
The Cisco Process Orchestrator Console is the interface used to access and operate the application. The 
Console displays after completing the license check or updating your license. The default view is the 
Operations workspace.

After the initial access, the view on the Console is determined by the last item accessed before exiting 
the Console.

The Console consists of the following areas:

• Menu Bar

Contains options used to access the tasks associated with the current item selected in the Navigation 
pane.

• Toolbars

Provides shortcuts to general tasks within Cisco Process Orchestrator as well as specific tasks 
associated with the item currently selected in the Navigation pane.

• Navigation Pane

The Navigation pane, located on the left side of the Console, displays several navigation 
workspaces, each containing a group of items that enable you to perform specific actions within the 
application. When a navigation view is selected, the available contents are displayed.

The following is a list of the available views in the Navigation pane. 

– Operations Workspace

– Definitions Workspace

– Administration Workspace

– Favorites Workspace

• Results Pane

• Details Pane
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Console Menus
The Process Orchestrator console menus provide general task items, such as feature customization 
options. These menus are displayed on the Console menu bar. 

The following topics describe the contents of each of the Process Orchestrator Console menus.

Using the File Menu

The File menu contains general actions related to the configuration of Process Orchestrator. The File 
menu contains the following items: 

Using the Edit Menu

The Edit menu contains the following items for modifying the configuration. 

Note The items enabled under the Edit menu depend on the objects selected in the navigation and detail panes 
of the Console.

Menu Option Description

Connect to Server Opens the Select Server dialog box where you can specify the server to 
which to connect.

The Server drop-down list displays the list of previously connected 
servers to the Console. You can also enter the specific server address to 
be connected.

Recent Servers Displays the most recent servers that have been connected to the 
Console. 

Environment Properties Displays the Environment Properties dialog box for the connected 
Process Orchestrator server.

Update License Launches the Update License Wizard (see Updating the Product 
License) to enter your product license information. 

Exit Closes the Console

Menu Option Description

Undo Reverses the last action by the user

Redo Reinstates the previously reversed action

Copy Copies the selected text or object to the clipboard

Paste Pastes the previously copied item from the clipboard

Delete Deletes the selected item

Select All Selects all items on the dialog box or text field

Find Launches the Find dialog box to locate specific text on a dialog box.
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Using the View Menu

The View menu contains items that determines how the information displays in the results pane. Select 
one of the following items to adjust the Console display:

Using the Go Menu

The Go menu contains the following shortcuts that allow you to navigate from one view to another on 
the Console:

Menu Option Description

Large Icons Displays large icons with the associated item

Small Icons Displays small icons with the associated name

List Displays icons with the associated name in list format

Details Displays icons with the associated name and details in list format

Choose Columns Opens the Choose Columns dialog box, which is used to customize the 
displayed columns and the order in which they display (see Configuring 
Columns).

Refresh Updates the current view

Navigation Pane Enables/disables the Navigation pane on the Console. When disabled, the 
Results pane and the detail pane, if selected, expand the width of the entire 
window

Detail Pane Toggles the Details pane On or Off

Toolbars Determines the toolbars (Standard Toolbar, Advanced Toolbar, 
Configuring the Appearance of the Console) to display on the Console. 
The check mark to the left of the toolbar name indicates the toolbar is 
selected.

Status Bar Enables/disables the status bar that appears at the bottom of the Console

Menu Option Description

Back Returns to the previously selected view

Forward Option is active if you have clicked Back to access a previous view. Use 
this option to navigate to the next navigation item in the list.

Go To Displays all previously selected views to which you can return

Operations Opens the Operations workspace

Definitions Opens the Definitions workspace

Administration Opens the Administration workspace

Folder List Opens the Folder List workspace

Favorites Opens the Favorites workspace
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Using the Tools Menu

The Tools menu contains the following items that configure the appearance of the Console:

Using the Actions Menu

The Actions menu contains items that perform specific actions associated with the selected item in the 
navigation pane. 

The items that are available on the menu depend on the selected item on the Navigation pane. For 
example, the options available when the Processes view is selected are different from those that are 
available when Global Variables view is selected.

Understanding the Help Menu

The Help menu contains the following items: 

Menu Option Description

Customize Launches the Customize dialog box. Use this dialog to change the fonts 
and colors that display in the Console (see Customizing the Fonts and 
Colors).

Options Displays the Options dialog box. Use this dialog to modify basic server 
interface functions.

Menu Option Description

Help Displays dialog box-specific information in a separate pane 
to the left. 

On the toolbar, click the Help  tool to display and 
remove the Help pane.

Contents Displays the Table of Contents tab used to navigate and 
view the comprehensive help information. 

Index Displays the Index tab used to navigate and view the 
indexed help information.

Search Displays the Search tab used to enter search criteria and 
locate specific information in the comprehensive help.

About Cisco Process Orchestrator Displays the About Cisco Process Orchestrator dialog box, 
which contains the product version and license 
information.
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Toolbars
The Console has three toolbars (Standard Toolbar, Advanced Toolbar, Configuring the Appearance of 
the Console), which can be used to configure the selected navigation view, provide quick navigation 
between views, and perform item-specific actions.

Figure 2-1 Console Toolbars

To enable or disable a toolbar, choose View > Toolbars, then click the appropriate toolbar.

Standard Toolbar

The Standard toolbar displays shortcuts to general actions and functions. The following icons appear on 
every view on the Console. 

Advanced Toolbar

The Advanced toolbar displays shortcuts to general navigation and Console configuration icons.

Action Toolbar

Standard Toolbar
Advanced Toolbar

Icon Name/Action

Connect to Server—Connects to the server to which you were last connected

Server Properties—Displays the properties for the connected server

Refresh—Updates the current view with the latest information from the server

Properties—Displays defined properties for the selected object. This icon is 
unavailable if the current selection does not support property pages.

Cut—Cuts the selected text to the clipboard

Copy—Copies the selected text to the clipboard

Paste—Pastes the selected items to the location identified by the cursor

Delete—Deletes the selected object

Help—Displays or hides the Help pane

Icon Name/Task

Back—Permits you to select the page to be displayed from a drop-down list of 
the most recent history pages.

Forward—Permits you to select the page to be displayed from a drop-down list 
of the most recent forward-history pages. 
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Configuring the Appearance of the Console

You can configure options that modify the basic interface behavior of the console.

Step 1 From the Advanced toolbar, select Options to display the Options dialog box provides configuration 
options that modifies the basic interface behavior.

Step 2 Click the General tab to configure the server connection startup behavior.

• Automatically select the group and item you most recently selected—At console startup, the group 
and item that are selected are the group and item that were last selected.

• Always select the following group and item—Specify the starting group and item:

– Group—The navigation group that is selected at console startup

– Item—The navigation item that is selected at console startup

• Remember the most recently used servers—Specify the number of recently accessed servers to 
display

Step 3 Click the Windows and Layout tab to specify how the user is to be prompted when a process is launched 
and what is to be displayed after the process is launched.

• When starting a process—Select one of the following options to determine what action occurs when 
a process is launched:

– Always Launch Immediately with Default Input Value—Launches the process immediately 
when the process has specified or default values without confirmation

– Always Prompt to Confirm— Default option launches the Confirm Start Process dialog box to 
allow you to confirm whether the selected process should be launched or override the process 
start option

– Only Prompt when Process has Inputs— Launches the Confirm Start Process dialog box if the 
process has input variables. If the process does not have input variables, starts the process 
immediately without confirmation.

• After process is started—Choose one of the following options to determine what is displayed after 
a process begins:

– None—Option does not display any process instances after the process has started

– Show Instances—Displays the processes initiated in the Activities view on the Console

• Reset User Preferences—Click this button to reset the saved settings (size and location of dialog 
boxes, selected property pages, visibility of toolbars and menu items, etc.) to the system default.

Clicking this button automatically closes the Console and requires the application to restart.

Navigation Pane—Displays or hides the Navigation pane.

Detail Pane—Displays or hides the Details pane.

Status Bar—Displays or hides the Status Bar.

Options—Displays the Options dialog box.

Icon Name/Task
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Step 4 Click the Security tab to configure the default owner when creating objects in Cisco Process 
Orchestrator.

• The current user—Select this radio button to use the user account that is currently logged in to assign 
the owner on any new objects created.

• The specified user—Select this radio button and then click the browse button to launch the Select 
User or Group dialog box and specify the default user for objects.

Step 5 Click OK.

Actions Toolbar

The Actions toolbar displays options that are associated with the selected item in the Navigation pane or 
Results pane. The available items on the Action toolbar depend on the item selected. 

For example, the options available when the Processes item is selected are different from those that are 
available when Global Variables is selected.

Menu Option Description

Start Process Click to manually start any enabled process displayed in 
the Process View.

Enable If a process is manually disabled, click Enable before 
executing.

Disable Click to disable a selected process instance on the process 
view from executing.

Unlock—If a process is manually locked, click to unlock it.

Lock—If a process is manually unlocked, click to lock it.

Advanced Click this button and select Break Lock if a process is 
locked by another user and you have Break Lock 
permissions.
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Workspaces
The Console contains the following workspaces. Each workspace contains a group of objects that 
perform specific actions within the application.

Workspace Description

Operations The Operations workspace displays:

• The status of processes that are scheduled to execute, view processes that 
are currently running, and verify that processes have successfully 
completed. 

• Alerts, incidents, and approvals relating to system event history for actions 
that have occurred within Cisco Process Orchestrator. 

• System messages about status and errors within the Process Orchestrator 
server or adapters.

For more information, see Chapter 8, “Monitoring Operations.”

Definitions The Definitions workspace displays all of the components that are used in 
defining and executing processes. The options provided by this workspace 
include:

• View Current Processes—Displays the Definitions > Processes view where 
you can view and manage defined processes. This view has two panes that 
display the execution progress of the process and activity instances.

From this view, you can view process properties, execute a process ad hoc, 
edit existing processes, and define new processes. From the Processes View, 
you can also execute processes and view the status of the process as it in 
progress.

For additional information about monitor and manage processes, see 
Chapter 8, “Monitoring Operations.”

• Create a New Process—Launches the Process Editor, which you can use to 
view and define the properties for a new process as well as construct the 
process workflow. 

For additional information about the Process Editor, see Accessing the 
Process Editor

• View Operations—Displays the Operations workspace that shows what 
processes are in progress, scheduled or have been completed. 

For additional information about managing operations, see Chapter 8, 
“Monitoring Operations.”

Administration The Administration workspace displays all of the components that are used to 
manage administrative activities (such as security or database administration 
tasks).

For more information, see Performing Administrative Actions.

Folder List The Folder List view displays a list of all the navigation items available from the 
Console. The items are sorted according to the view displayed on the Console. 
The Results pane displays the view associated with the selected item.
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Results Pane
When a navigation item is selected on the Navigation pane, the information associated with that item 
displays in the Results pane. By default, the information is presented in a details list view format. The 
columns that display depend on the selected navigation item.

Details Pane
The Details pane provides additional information for a selected item in the Results pane. The links on 
each of the detail pages launch the property pages for the selected item.

Process Viewer
The Process Viewer displays a graphical view of the process workflow after a process has been launched. 
The information displayed on this viewer is read-only.

The Process Viewer contains this information:

Process Editor Menus

Process Editor File Menu

The File menu contains the following items:

Favorites The Favorites workspace displays shortcuts to user-selected navigation items. 
This view is used for quickly accessing navigation items that are frequently 
used. Any item in the Navigation pane can be added to the Favorites view.

Click Set Favorites to display the Set Favorites dialog box. Check the 
appropriate items, then click OK.

Workspace Description

Pane Description

Status Pane Displays a flat list of all activity instances that were executed by the process 
instance.

Workflow Pane Displays the graphical workflow of the selected process and its activities.

Properties Pane Displays the properties for the process and activity instances. 

To view the activity instance properties, select the activity instance in the 
Workflow pane. To return to viewing the process instance properties, click 
in the white space or use the menu.

Menu Option Description

Save Saves the process workflow

Save Copy As Saves a copy of the process workflow under a different name

Verifies that the process follows the best practices
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Process Editor Edit Menu

The Edit menu contains items to be used for modifying the process in the workflow pane. For 
information about using this menu, refer to Using the Edit Menu.

Process Editor View Menu

The View menu contains the following items:

Process Editor Tools Menu

The Tools menu contains the following items that allow you to configure the appearance and behavior 
of the editor.

Revert Returns the workflow to the previous saved version

Print Prints the contents of the workflow pane

Process Properties If an activity properties pane is displayed, the option toggles to the 
process properties pane

Exit Closes the editor

Menu Option Description

Menu Option Description

Collapse All Collapses all the activities in the workflow pane

Expand All Expands all the activities in the workflow pane

Zoom In Increases the size of the contents of the workflow pane

Zoom Out Decreases the size of the contents of the workflow pane

Zoom Default Resizes the contents of the workflow pane according to the default 
zoom value

Zoom Fit Resizes the workflow to fit the size of the pane

Zoom Fit Selection Resizes the selected item in the workflow pane to the size of the 
pane

Toolbar Displays the Editor toolbar

Status Bar Displays the status bar at the bottom of the Editor

Toolbox Displays the toolbox pane

Properties Displays the process properties pane

Menu Option Description

Customize Launches the Customize dialog box where users can change the fonts and colors 
that display in the editor. 

For information about using this dialog box, refer to Customizing the Fonts and 
Colors.
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Process Editor Actions Menu

The Actions menu contains the following items that apply to a selected item in the workflow pane: 

Process Editor Help Menu

The Help menu contains information that provides documentation assistance to work in Process 
Orchestrator. For information about using this menu, refer to Understanding the Help Menu.

Process Editor Toolbar

The toolbar displays icons to be used as shortcuts for performing actions in the workflow pane. To 
display the toolbar, choose Toolbar from the View menu. 

Options Launches the Options dialog box which is used to configure basic Process 
Orchestrator console behavior. 

Regex Matcher Launches the Match dialog box where users can match the specified source text 
against a specified regular expression.

Menu Option Description

Menu Option Description

Move Back Moves the position of an activity in the workflow back one position 
at a time.

Move Forward Moves the position of an activity in the workflow forward one 
position at a time.

Add Result Handler Inserts a Condition Branch into the workflow. A Condition Branch 
is executed only if the specified condition is met.

Expand Expands the selected activity

Collapse Collapses the selected activity

Icon Description

Saves the process

Starts the process

Prints the contents of the Workflow pane

Copies the selected information to the clipboard

Pastes the selected information to the location identified by the cursor

Deletes the selected item

Collapses the contents of the workflow pane
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Field Reference Icons

Defining a Target
Targets specify where certain processes, activities, or triggers will run. You can define a target once and 
then reuse it in multiple processes. 

Note Not all targets can be created manually. Some targets are discovered automatically based on the 
information specified by other targets.

The Definitions > Targets view displays all the existing defined targets. You can also use this view to 
create new targets, modify the properties of a target, and delete targets. 

Step 1 Choose Definitions, right-click Targets, choose New > [Target], and select a target type from the 
drop-down list.

Step 2 Run through the wizard, then click Finish.

Expands the contents of the workflow pane

Resizes the contents of the workflow pane according to the default zoom value

Increases the size of the contents of the workflow pane

Decreases the size of the contents of the workflow pane

Resizes the workflow to fit the size of the pane

Resizes the selected item in the workflow pane to the size of the pane

Displays or hides the Help pane

Icon Description

The Reference icon displayed next to a text field indicates that you can select a 
defined variable or reference an object within the process from the Insert Variable 
Reference dialog box.

The Required Value icon displayed on a tab or page indicates that the field is required 
and is either missing a value or contains an invalid value.

Icon Description
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Defining Runtime Users
Runtime users hold the security credentials that are assigned to processes and activities. For more 
information about runtime users.

Use the Definitions > Runtime Users view to display the configured runtime users, add new runtime 
users to define new connection credentials, update runtime users such as to update a password, or delete 
runtime users.

Step 1 Choose Definitions > Runtime Users, right-click and choose New > [Runtime User] for the 
appropriate runtime user account.

Step 2 Click the General tab and enter the appropriate runtime user-specific information. The property pages 
displayed depend on the type of runtime user selected. 

In the Owner field, you can click the browse button to display the Select Identity dialog box.

From the User Identity tab, click Add to display the Select Identity dialog box.

• Type—From this list, select either User or Group to define the user assignments.

• Location—Specify the user or group location. Click the browse button to display the Select Location 
dialog box.

• Filter—Filter on the search results

• Search—Click to search for the identity

• Results—Displays search results

Step 3 Search for the identity, select it, then click OK.

The Used By tab displays objects that reference the runtime user. This tab will remain blank until the 
runtime user is used by an object. 

The History tab displays the history of actions taken against the runtime user. This tab remains blank 
until after the initial creation.

Step 4 To view information about an object, highlight the object, right-click and choose Properties. 

Step 5 Click OK to close the property sheet.

Defining a Repository User
Use the following instructions define the user credentials required to access a repository. Use the 
Repository User dialog box to specify the credentials for a runtime user record to be used for configuring 
the repository.

Use the Definitions > Runtime Users view to display the configured runtime users, add new runtime 
users to define new connection credentials, update runtime users such as to update a password, or delete 
runtime users.

Step 1 Choose Definitions > Runtime Users, right-click and choose New > [Repository User] for the 
appropriate runtime user account.

Step 2 Click the General tab and enter the appropriate runtime user-specific information, includes:

• Display Name—Enter the display name for the repository user.
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• Owner—The owner of the object. This is typically the creator of the object.

• User name—The user name assigned to the user account.

• Password—Check the check box and then enter the password to be assigned to the user account.

• Email—Enter the valid email Id for the repository user.

In the Owner field, you can click the browse button to display the Select Identity dialog box.

• Type—From this list, select either User or Group or All to define the user assignments.

• Location—Specify the user or group location. Click the browse button to display the Select Location 
dialog box.

• Filter—Filter on the search results

• Search—Click to search for the identity

• Results—Displays search results

Step 3 Search for the identity, select it, then click OK.

The Used By tab displays objects that reference the runtime user. This tab will remain blank until the 
runtime user is used by an object. 

The History tab displays the history of actions taken against the runtime user. This tab remains blank 
until after the initial creation.

Step 4 To view information about an object, highlight the object, right-click and choose Properties. 

Step 5 Click OK to close the property sheet.

Selecting a Client Certificate

Use the Select Client Certificate dialog box to select certificate you want to assign to a runtime user.

To select a certificate:

Step 1 On the Certificate property page, click Browse.

The Select Client Certificate dialog box displays.

Step 2 Click the Certificate tab and specify the following properties about the selected Certificate.

• Issued to—User name or the owner of the certificate

• Issued by—User name of the certificate issuer

• Start date—The date and time the certificate became valid.

• Expiration date—The date and time the certificate will expire.

• Thumbprint—Specified parameters containing the client certificate thumbprint

• Has private key—Select to indicate the certificate is assigned a private key.

Step 3 Browse to the appropriate certificate.

Step 4 Enter the password for the certificate.

Step 5 Click OK to close the dialog box.
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Configuring Security

Creating a New Security Role
A security role is a list of permissions that enhances product use through logical groupings of powers 
and objects for reuse in multiple places. A security permission is a pairing of a scope that defines the 
objects and powers over those objects. 

After a security role has been defined, it is available in a list of available security roles on the 
Administration > Security view. 

Step 1 Choose Administration > Security, right-click and choose New > Role. 

Step 2 On the New Role property pages, define the properties.

Step 3 Click the Permissions tab and add permissions as necessary.

Step 4 On the Permissions tab, click Add to display the Permission "All" Over "All" Properties dialog box.

• Operations—Select the appropriate operations

• Objects—Give permissions to act upon a specific object

The property pages included in the Power are determined by the specific permission to be created.

Step 5 Click the User Assignments tab and add user assignments as necessary. 

Step 6 Click OK. The new security role is displayed on the Administration > Security view.

Assigning Users Or Groups to Security Roles

Step 1 Choose Administration > Security, highlight the appropriate security role (see Predefined Security 
Roles), right-click and choose Assign.

Step 2 On the Select User or Group dialog box, in the Enter the object name to select text field, enter the user 
name (domain\user name) or group, then click Check Names. 

Note If there is a matching user name or group, it is displayed in the field. If there is not a match, an 
error message displays. 

Step 3 On the Search Results pane, choose the appropriate user or group, then click OK.
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