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C H A P T E R 1

Introduction

Understanding Service-Oriented Orchestration
Cisco Process Orchestrator 3.3 introduces a new set of features providing Service-Oriented 
Orchestration that enable a paradigm shift vs. traditional run-book automation and IT process 
automation. This shift enables automation to align to the high-level services provided by IT, and models 
how a high level service is supported by a topology of lower level services, systems, and devices.

Planning for services and their desired state are the initial focus of automation design. Focus then moves 
to defining process actions against these services, with implementation of specific process workflows 
that traverse these services to act on lower level elements as a final implementation step.This enables a 
declarative approach to automation, focusing primarily on what is desired instead of how it is achieved. 

Note The capabilities are additive and complimentary to traditional orchestration definitions and approaches, 
so Cisco Process Orchestrator provides both service-oriented and process-based orchestration. This 
means that you can still program Process Orchestrator as usual, so you can ease into the new concepts 
or not use them at all. This guide, however, will demonstrate the service-oriented orchestration approach.

Cisco Process Orchestrator is an advanced orchestration engine belonging to the Run-Book Automation 
(RBA) or IT Process Automation (ITPA) class of products. Traditionally, tools in this category focus on 
a sequence of IT processes that achieve automation. The process is the focal point of automation. 
Processes act on lower-level IT elements such as devices, servers, or specific tools. The set of elements 
on which automation acts are typically delivered in the product and through adapters connecting to 
various layers of the IT technology stack. IT, on the other hand, is focused on services providing value 
to the business, which are much higher up the stack. The inability of RBA/ITPA tools to act on the 
business-level services in the environment becomes an inhibitor to delivery and creates a poor 
abstraction for users. 

Service-Oriented Orchestration provides the agility to model and act on IT services. These features make 
creating orchestration active and dynamic, and allow for:

• Defining new, higher-level services in the system, and deploy new services quickly. 

• In real-time, after these new types of services have been defined, creating real-time instances of 
those new services. 

• Using events to watch for patterns in these services, enabling policy-driven automation.

Service-Oriented Orchestration combines several industry trends to synthesize a fresh approach to 
orchestration:
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• Service modeling capabilities of a service catalog are now available in the orchestrator layer. 
Process Orchestrator provides fluid mechanisms to exchange service information with the Cisco 
Prime Service Catalog, advancing the integration of these systems. 

• The feature delivers many of the capabilities of object-oriented design and programming into the 
RBA / ITPA world. The shift from traditional orchestration to Service-Oriented Orchestration is 
similar to the shift from procedural to object-oriented programming. Today, virtually all 
programming is done with object-oriented languages, and object-oriented design has transformed 
the industry to higher levels of productivity and quality. Service-Oriented Orchestration holds the 
same promise. 

• The IT Infrastructure Library (ITIL) prescribes a service-centric approach for IT. Configuration 
Management Databases (CMDBs) model IT services and their relationship to other IT assets. 
Service-Oriented Automation allows automation to be driven through a model of current and 
potential IT services, aware of their relationships and interdependencies. In this aspect, the 
principles of service modeling in Process Orchestrator are essentially the same as modeling services 
within ITIL and CMDBs. While Process Orchestrator can integrate with an available CMDB, there 
is no requirement to have a CMDB to enable orchestration. 

• The feature aligns to industry standards like the DMTF Common Information Model (CIM) and the 
Topology and Orchestration Specification for Cloud Applications (TOSCA).

• Model-based automation is becoming popular via script-based tools, especially in the configuration 
management space. Process Orchestrator combines the capability to model services with the 
openness to integrate with these tools to leverage their strengths. Moreover, the feature allows 
model-driven orchestration atop legacy tools to bring the full power of model-driven approaches to 
integrate with other IT tools.

Key Benefits
Service-Oriented Orchestration allows automation to focus on higher level IT services, possibly specific 
to the customer’s business and unknown by Cisco when the product is built. User interaction shifts to 
services on which to act and what you can do to them. The approach to defining automation shifts from 
having to first decompose automation into a sequence of processes, to decomposing high-level services 
into their components, and then defining actions that are possible on each of the component services. 

This inversion in approach is simple, yet powerful. Cisco Services, partners, and customers can model 
services and extend others’ services without coding. Extensions and automation can be packaged, 
shipped to customers or moved from development to test to production, versioned, and upgraded. 

The approach delivers several key benefits:

• Greater ease of use in combining Process Orchestrator with Prime Service Catalog. 

The Prime Service Catalog adapter simplifies the exchange of service requests and service items to 
and from the orchestrator. It is easy to create targets from incoming service requests. Process 
Orchestrator helps push service items back to the catalog as needed by allowing users to pick the 
right moments in a flow to synchronize data. Using active catalog connection in the Prime Service 
Catalog adapters optimize user experience. The Prime Service Catalog adapter easily reads, writes, 
or creates service items, and is CP schema-aware. When a service item definition is created in the 
catalog, the desire is to set up integration rapidly. The property browser exposes the catalog 
definition to enhance ease of use. Get Service Item properties can be followed by Update Target to 
save properties in a single step. One can write directly through the Create Service Item or Update 
Service Item activities using property references.

• It allows simpler, more readable workflows.
1-2
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• Data defines desired services, and the service instance drives automation to achieve the desired state. 
This separates the desired state from the implementation (the “what” from the “how”).

• It acts on the higher-level service rather than its technology elements. Services can span tools, and 
workflows can navigate service topologies to lower-level elements on which they act.

• It provides operational views of automation by service.

• It lets you monitor the environment vs. the service definition and bring them in line with policy.

• It provides federated storage, including push objects and relationships to and from Service Catalog, 
CMDB, and Service Assurance tools when needed.

• Automation becomes easier to extend and customize.

Process Orchestrator Supports Service-Oriented Orchestration
Several features in Process Orchestrator combine to bring these capabilities: 

• Service instances are targets. A target type allows you to define a new service; all new targets are 
created based on a target type. Target types can be based on the DMTF Common Information Model, 
but this is not required.

Target types are service definitions that allow Process Orchestrator to deliver service-oriented 
automation, where the service, not the process, is the focal point. In service-oriented automation, 
the content, not the Process Orchestrator platform, defines the solution models; the platform is open 
to any model you want to produce. 

Some target types can be ‘abstract’, meaning they cannot be directly instantiated into targets but are 
only available for inheritance by other target types. In Process Orchestrator, these target types are 
marked as either ‘creatable’ or ‘not creatable’.

Target types support inheritance, which allows you to extend a general type for a specialized need. 
In Process Orchestrator, you can select a ‘base target type’ for a target type that specifies that the 
target type inherits from the base target type.

Target types have an extensible list of properties including field-customizable default values.

In these properties, data can be stored that might come from Process Orchestrator in terms of 
defining an order or a desired state, or might include data that is collected from the environment. 
For example, periodic network device discovery can store information such as the operating system, 
version, which line cards are installed, and so on. Network automation can use that information in 
its workflows.

• Relationships allow modeling of topologies of lower level services assembled to offer higher-level 
services; that is, relationships allow lower-level objects to be bound together to achieve a larger 
whole. Automation can navigate from a higher-level object, such as a service, to lower-level objects 
against which they can perform automation.

– Relationships allow you to navigate from one object to another in a workflow.

– Target types define the property that models the relationship.

– Target instances provide the link to a specific instance.

– Relationships support inheritance.

– Relationships can be set in the northbound web service like any property.

• Processes provide actions that can be executed against targets. Process Orchestrator allows you to 
view a target to see what actions are possible, or what automation is being done against those targets.

The target types that a process can accept define the services on which a process can act.
1-3
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• Targets and target types have events. These can be internal process events or the open Advanced 
Message Queuing Protocol (AMQP) protocol. Triggering processes in response to patterns in 
underlying processes provides policy.

• Extensible by services, partners, customers. The content, not the platform, defines service 
models. The platform is open to model any IT service topology within automation content. For 
example, some types, actions, properties, etc. may come from the packaged product, some from 
team 1, some from team 2, some from a partner, and some from a customer. Using this capability 
you can assemble a complex solution from parts. Each author controls the version control and 
lifecycle of the elements they deliver so they can deliver upgrades.

• A consistent API, even if elements come from different authors. Users and automation pack authors 
(see Automation Packs) can control which target types are published to the NorthBound Web 
Service (NBWS; see the Northbound Web Services Guide). For published objects, Process 
Orchestrator exposes the type uniquely in the NBWS. As content teams, services, partners, or 
customers extend types, these APIs are maintained to provide a consistent format for APIs across 
all types of objects. However, each type of object is uniquely supported. 

• Authors can also configure which properties are exposed in the NBWS as optional parameters in the 
per-type WSDL.

Aligned to IT Standards
While Service-Oriented Automation is open, allowing any model, it aligns to IT best practices such as 
the IT Infrastructure Library (ITIL). ITIL prescribes a configuration management database (CMDB) as 
a central tenet which allows high level services to be decomposed into their supporting lower level 
services and ultimately to the lower level systems and devices. In ITIL, each element in the model is 
called a Configuration Item since it is a unit of configuration. This provides a mapping of how lower 
level elements support business services. Service-Oriented Orchestration allows automation to be driven 
through a model of current and desired IT services, aware of their relationships and interdependencies. 
In this aspect, the principles of service modeling are substantially the same as modeling services within 
ITIL and CMDBs. 

However, the implementation bypasses many of the negatives and weight of typical CMDB 
implementations. Process Orchestrator can integrate with a CMDB if it is there. Targets provide a natural 
synchronization point to exchange data with a CMDB, and target events allow that synchronization to 
be externalized from other processes. However, Service-Oriented Orchestration does not require a 
CMDB; one does not have to have a CMDB to enable orchestration to function. Often orchestration 
needs a reduced model vs. what is in the CMDB, and it is therefore much easier to keep the smaller data 
set current. For example, resource management can be more efficient when externalized. Moreover, a 
CMDB typically represents actual elements and not potential elements, and since orchestration is often 
responsible for provisioning, the orchestrator may have data prior to its life in the CMDB, which it might 
write to the CMDB as it is instantiated. Even if Process Orchestrator service models leverage data in 
CMDBs, performance is improved by keeping this data in Process Orchestrator target properties to 
optimize queries. Process Orchestrator allows a local representation of only those services that relate to 
what you want to automate, so that the implementation is right-sized and lighter than complete CMDBs. 
Updates are more real time and targeted to the need of automation. A conceptual alignment to ITIL and 
CMDB principles creates the flexibility to right size the implementation and unify with CMDBs when 
needed.

Also, ITIL prescribes key process records such as alerts, incidents, and change requests that drive the IT 
operations process. Process Orchestrator provides a native representation for these concepts. This allows 
content to be abstracted from how these concepts are provided in a company. For example, content that 
detects an IT incident does not have to encode the specific service desk used by a particular customer.
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Content that enriches incidents with further diagnostic data can also do so independent of tool selection. 
Process Orchestrator alerts, incidents, and change request records allow reusable content independent of 
tool selection and company-specific ITIL extensions. A separate body of content can integrate 
orchestrator incidents with a specific service desk like BMC Remedy. Processes can trigger when 
incidents are created or changed in general automation and push those changes to Remedy. Updates 
within Remedy such as incident closure trigger synchronization processes which update the Process 
Orchestrator incident. Processes in general automation can then proceed from incident resolution. For 
example, the incident can be verified to prove that the problematic behavior no longer manifests. 
Moreover, ITIL prescribes that these records have a relationship to the element which failed so one 
knows what services may be impacted. Process Orchestrator incidents provide a link to:

• The target defined by the target type for the service

• A secondary configuration item field to link arbitrary external CMDB references when a CMDB is 
present

Related Service-Oriented Orchestration Terms and Concepts
The following table summarizes how Service-Oriented Automation blends aspects of these industry 
standards as well as common best practices like object-oriented programming. Users who are familiar 
with one of these domains might find it easiest to map the concepts with which they are familiar to 
Service-Oriented Orchestration features. As you can see, the feature synthesizes similar concepts that 
have very disparate terms across the industry. Process Orchestrator attempts to provide the most intuitive 
terms within orchestration, and especially with prior Process Orchestrator users.

 
Table 1-1 Service-Oriented Orchestration Terms and Concepts Comparison 

Object-Oriented 
Programming

IT Infrastructure 
Library (ITIL)

Cisco Process 
Orchestrator

Cisco Prime 
Service Catalog

Common 
Information Model 
(CIM)

Topology and 
Orchestration 
Specification for 
Cloud Applications 
(TOSCA)

Object Model Service

Configuration Item 
Hierarchy

Collection of 
related targets

Model Service, Service 
Template, 
Topology Template

Class Configuration Item 
type, or more 
loosely asset 
classes

Target Type Service Item 
Definition, Service 
Standard 
Definition

Class Node Type

Instance, object Configuration 
Item, Service

Target Service Item, 
Service Standard

Object derived 
from Managed 
Element

Node

Inheritance, 
Parent / child / 
ancestor / 
descendant
Subclass / 
superclass, subtype 
/ super-type

(loosely) 
Configuration Item 
categories and 
classification

Inheritance Inheritance, 
Parent / child / 
ancestor / 
descendant

Inheritance 
(subclassing)

Inheritance, 
Parent / child / 
ancestor / 
descendant
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Attribute, field Configuration Item 
attribute

Property Attribute Property Property

Relationship type Future: 
Relationship Type 
(achievable 
through Target 
Types - see above)

Relationship type

Links and 
associations
Pointers

Configuration Item 
relationship

Relationship Relationship Relationship, 
association

Relationship

Method, operation Process
From Target Type: 
Process Action

Action, Associated 
Services, Tasks

Method Plan

Event or Message Event
From Process: 
Trigger from Event

Event
Rules for “On 
Event”
Some use of the 
term “Trigger”

Indication (stop, 
Alert, Threshold, 
and others)

Selection by 
Configuration Item 
Category

Target Group, 
Target Selection

... Rule

Event (related to 
Configuration 
Item)

Alert (Related to 
Target)

Incident (related to 
configuration item)

Incident (Related 
to Target)

Change Request 
(related to 
configuration item)

Change Request 
(Related to Target)

Automation Pack Cloud Service 
Archive (CSAR)

Files in an 
Automation Pack

Artifact

Class Interface No explicit term 
The collection of 
all processes that 
act on a Target 
Type, including 
their input and 
output parameters

Class Interface Interface

Table 1-1 Service-Oriented Orchestration Terms and Concepts Comparison  (continued)

Object-Oriented 
Programming

IT Infrastructure 
Library (ITIL)

Cisco Process 
Orchestrator

Cisco Prime 
Service Catalog

Common 
Information Model 
(CIM)

Topology and 
Orchestration 
Specification for 
Cloud Applications 
(TOSCA)
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Service Definition Examples
The following sections provide some service definition examples.

A Distributed Application and Product as a Service

An example of the usefulness of Service-Oriented Orchestration is the ability to model a distributed 
application and provide its provisioning and ongoing operations. To the business, an application and its 
elements are not important by themselves; the application is important for the service it provides to the 
business. For example, an application may provide customer support, order entry, or partner billing. Let's 
pick one of these, say customer support. The customer support service in this example is provided by a 
distributed application that consists of a number of web servers behind a load balancer, a database, a 
cluster of application servers, and an LDAP repository for user credentials. Each application server 
ultimately runs on a UCS blade, which is in turn related to a UCS Manager. Moreover, each of these 
topology nodes fit within some network, with each tier separated by firewalls, and these nodes require 
specific firewall configuration, so the application topology has relationships to a network topology. All 
of this combines to form the service topology.

In a Platform as a Service solution, the customer must enable not only provisioning but ongoing 
operations and eventually deprovisioning of services or applications, as opposed to IaaS where 
individual virtual machines are provisioned. The leap involves treating a service or a collection of virtual 
machines and their networks as a package. Applications or other services are provisioned and configured 
on these VMs and networks. It involves an ordering experience that allows customers to deploy and use 
those services.

To this end, there is a need to define service or application blueprints so they can model their services 
and make them orderable and support provisioning, operations, and de-provisioning of those services. 
These blueprints capture what the customer needs to deploy some application. Customers want to receive 
these blueprints from Cisco, or possibly from partners or a community. They also need to be able to build 
these blueprints themselves and move them from development to test to production.

“This” reference in 
a method

Process Target

Abstract class “Targets of this 
type can be 
created” check box 
on a Target Type

Abstract type

Dynamic binding, 
overriding, 
polymorphism

Achievable in 
processes

Table 1-1 Service-Oriented Orchestration Terms and Concepts Comparison  (continued)

Object-Oriented 
Programming

IT Infrastructure 
Library (ITIL)

Cisco Process 
Orchestrator

Cisco Prime 
Service Catalog

Common 
Information Model 
(CIM)

Topology and 
Orchestration 
Specification for 
Cloud Applications 
(TOSCA)
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Service-Oriented Orchestration allows one to define, package, ship, and receive these models, as well as 
to create instances of the service from that model. In this way, the company can drive a standardized 
deployment of the service across development, test, and production systems. For example, a target type 
could be created for a web server, while the specific web server target is an instance created from that 
web server target type. This might have a relationship to the Linux server that hosts the web server.

A level 1 help desk operator might not know or care what specific database or LDAP instance supports 
the customer support service, or what UCS blade actually runs a certain instance of the web server. They 
want to do things against the customer support service. Say they want to authorize a new user to access 
the customer support service and provision whatever they need. They would generally run an add-user 
process, acting on the customer support service. 

A Build process that acts on the customer support service is responsible for provisioning of the whole 
of the service. This process might call the Build process for each target type in the topology, building 
the service up an element at a time. This process might use files, like an OVF for a server, to stand up 
the specific service element, or might invoke a tool such as Puppet or Chef.

Other examples of processes that act on the service or its elements are things like site disaster recovery, 
that may need to make changes to many parts of the customer support distributed application to move it 
to another site. These processes need to act on the customer support service as a whole, but leverage the 
topology and relationships to traverse to other actions, possibly calling similar processes that act on 
those elements. For example, a request to back up the overall service might invoke a backup of each 
server in the topology as well as the database.

Through Service-Oriented Orchestration, processes can act on the customer support service. As 
necessary, the process can traverse relationships to lower level infrastructure and tool elements on which 
it takes action. For example, a process that queries capacity might traverse to the database target, and 
perform Process Orchestrator activities against that database.

A Cisco TelePresence Service

A TelePresence system has a number of components that automation can act on through SSH, stop, or a 
web service. Prior to Process Orchestrator 3.0, to act on a service, one was required to browse through 
all of the processes, filter by category or automation pack (see Automation Packs), then run a process 
and specify the terminal, stop, or web service target. One had to understand the underlying 
implementation to know what target to provide.

Now, using Service-Oriented Orchestration:

1. An external team provides an automation pack that defines a TelePresence target type, with:

– Relationships defined for terminal, stop, and web service target types

– Properties such as a phone number or escort name

– Process actions for TelePresence systems

2. The automation pack can add properties such as a location property to the built-in network device 
target type.

3. The customer installs the automation pack and configures TelePresence service instances by calling 
a constructor process called Create. 

4. The process not only creates the TelePresence target, but also creates the terminal, stop, and web 
service targets as well as the relationships that unify them into the model. 

5. The end user can browse the target views or operations views and filter for targets with the 
TelePresence type. When they select a type, they can see:

– All of the available user-startable actions (processes).
1-8
Cisco Process Orchestrator 3.3 User Guide



 

Chapter 1      Introduction
  Process Orchestrator System Components
– All automation running against the TelePresence system. These results are filterable by a time 
range or by a specific process.

6. When the end user runs a process action, internally the workflow traverses the relationship to find 
the SSH, etc. target required by the action. The user sees this and other automation running against 
the TelePresence system.

Process Orchestrator System Components
The topics in the following sections describe the major architectural elements of the Process 
Orchestrator.

Process Orchestrator Console
The Process Orchestrator console is a Windows form-based UI that is intended for advanced users that 
will be defining processes, target types, activities, and so on.

The console contains the following workspaces, each of which contains a group of objects that perform 
specific actions within the application.

• Operations—Use the Operations workspace to monitor the orchestration that is executing or is 
scheduled to execute on various targets. You can also use this workspace to monitor the processes 
that are scheduled to execute, view processes that are currently running, and verify that processes 
have successfully completed.

• Definitions—Use the Definitions workspace to view and modify processes and other related 
configurations that are used in executing automation. 

• Administration—Use the Administration workspace to perform administrative actions such as 
editing system-wide settings, managing security roles, configuring adapters and automation packs, 
and tuning database grooming and other settings.

Web Console
The Process Orchestrator Web Console provides a web-based UI that is intended for occasional users. 
The vision is that while a broad set of users may be defining processes, pervasively everyone in IT and 
even non-IT individuals may need to interact with those processes. The web console focuses on this 
second group. It does not allow users to define processes but does allow them to start processes, monitor 
processes they started, or interact with human steps in processes called tasks (such as approvals). This 
interface is purposefully simplified to minimize the learning curve of occasional users.

Note The Web Console is typically not used when Process Orchestrator is used in conjunction with Cisco 
Prime Service Catalog. In these cases, end-user interaction occurs through the catalog rather than 
Process Orchestrator interfaces. The Web Console is typically only used in cases when Process 
Orchestrator is used independently.

The web console runs on a Microsoft IIS web server. Process Orchestrator environments can span 
Process Orchestrator servers, so if a deployment scenario requires breaking up automation for security, 
organizational, geographic, or purpose (such as development or test), the Web Console can provide a 
single point of access for occasional users.
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Related Topics

Chapter 9, “Performing Basic Console Tasks”

Process Orchestrator Server (Process Engine)
At the core is the Process Orchestrator Server, which executes automated processes. This component is 
responsible for:

• Creating instances of running processes

• Orchestrating the execution of these processes

• Configuring multiple servers to work together for load balancing and in an active-active 
configuration to achieve high availability.

Northbound Web Service Interface
Process Orchestrator provides a web service interface that allows external systems to invoke Process 
Orchestrator processes, check their results, and so on. Use the northbound web service interface when 
you: 

• Have a need to integrate with or communicate between multiple Process Orchestrator environments

• Have your own support portal

• Use a service catalog

• Leverage Process Orchestrator underneath some other master orchestrator

For more information about the northbound web service interface, see the Cisco Process Orchestrator 
Northbound Web Services Guide.

REST Services Guide
Process Orchestrator provides a web service interface that allows external systems to invoke Process 
Orchestrator processes, check their results, and so on. Use the REST services guide when you:

• Have a need to integrate with or communicate between multiple Process Orchestrator environments

• Have your own support portal

• Use a service catalog

• Leverage Process Orchestrator underneath some other master orchestrator

For more information about the REST services guide, see the Cisco Process Orchestrator REST Services 
Guide.

Command Line Interface
The Process Orchestrator command line interface is based on Windows PowerShell. PowerShell is the 
emerging standard for CLI interfaces on the Microsoft platform. The CLI provides basic operations that 
are needed for integration, including the ability to:

• Export or import automation packs
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• Start a process with input variables

• Check the status of a process

• Enable and disable processes and targets

• Import automation pack patches

• Export/Import automation pack customizations

Databases

Process Database (Configuration & Audit)

This database is closely associated with a Process Orchestrator high availability environment (that 
includes one or more servers) and stores process definitions and other configuration information. In this 
environment, the Process Orchestrator Server (Process Engine):

1. Loads process definitions and other configuration information at startup. Then, as appropriate, it 
starts instances of processes. 

2. Stores the state of running process instances into the Process Database. This persistence allows 
resiliency across server restarts and supports load balancing and high availability in an multi-server 
environment.

3. Stores auditing data in the Process Database to record change as users interact with the system, (such 
as to make a configuration change or invoke a process manually). 

Reporting Database (Data Warehouse)

This second database stores data needed for longer-term retention and storage. This can include a copy 
of auditing data that can groom more slowly than the Process database, as well as summary information 
for each process that ran. This data is organized for reporting, with flat relational tables, and can be 
summarized. Automation content can also add data, such as performance measurements, to the reporting 
database.

Related Topics

Reporting

Reporting
Process Orchestrator supports two reporting technologies:

• SAP BusinessObjects 

• SQL Server Reporting Services

Report definitions are provided in the Process Orchestrator product and in some Cisco automation packs, 
and are imported into the chosen reporting platform.

Related Topics

Managing the Report Database
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Role-Based Access Control (RBAC)
Windows performs authentication of the user connecting to Process Orchestrator against Active 
Directory. The authentication is done prior to connection to the Process Orchestrator server, and the 
Process Orchestrator server simply relies on the results of that authentication. No special end-user 
account management is necessary for Process Orchestrator.

In Process Orchestrator, authorization is performed using a Role-Based Access Control System. Roles 
are a collection of permissions. Users are assigned to roles that give them the ability to perform the 
actions allowed by the role. 

Typically, roles are defined according to a standardized job function within IT. Examples might include 
Level 1 Helpdesk, Level 2 Helpdesk, Cloud Technical Administrator, Network Configuration, SAP Basis 
Expert, and so on. Security groups already in the directory for the users in these job functions are then 
typically assigned to the roles.

Adapters
Adapters are one of the extensibility mechanisms in the Process Orchestrator platform, and are only 
written by members of the Process Orchestrator product development team. The development team uses 
adapters to extend Process Orchestrator functionality to integrate with devices, environments, 
applications, or tools without undergoing core modification. 

Related Topics

• Configuring Security

Automation Packs
Automation packs are the primary means of extending integrations in the field. Automation packs are 
prepackaged collections of process definitions, target types, variables, categories, targets, target groups, 
and other configurations needed to define a set of automated IT processes. Automation packs allow:

• Cisco or its partners to ship best practice automation to customers. 

• Customers to get productive quickly, and to shift automation across systems, such as from a 
development system to a test system to production. 

• Customers to export their own processes and share with each other in the community.

• The backup of process definitions and other product configuration.

Automation packs:

• Can be exported from one Process Orchestrator system and imported into another. 

• Can ship separately from product releases.

• Are versioned and dependencies are recorded. Versions and dependencies are checked during import 
to ensure that the system will work after the import. For example, if your personal automation pack 
calls a process in “Sample Document A” automation pack v1.3, then you cannot import your 
automation pack into a system that has installed “Sample Document A” v1.2.

The Core automation pack is provided by Cisco Process Orchestrator and is a required prerequisite for 
all other automation packs included in the Cisco Process Orchestrator installation.
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Related Topics

• Managing Automation Packs

Advanced Message Queuing Protocol (AMQP)
The Advanced Message Queuing Protocol (AMQP) is an open standard application layer protocol for 
message-oriented middleware. It delivers message orientation, queuing, routing (including 
point-to-point and publish-and-subscribe), reliability and security. AMQP came out of the financial 
industry, and is proven highly scalable in demanding environments (see http://www.amqp.org/).

AMQP is the emerging standard for messaging and events in the cloud. For example:

• vCloud Director can publish vCloud Messages, also known as “blocking tasks,” “notifications,” or 
“call-outs,” related to different provisioning. An orchestrator can not only receive these events, but 
can also respond to them to delay execution. 

• AMQP is supported with vCloud Orchestrator. 

• OpenStack selected AMQP as the messaging technology for OpenStack.

AMQP is integrated with more than 70 developer platforms, providing a nice framework for 
event-oriented integrations.

AMQP enables event-driven capabilities of Enterprise Service Bus-style designs. It enables queuing, so 
automation can fetch messages when there is capacity. You can use asynchronous methods servicing 
requests as capacity allows when possible, and reserve real-time, synchronous methods only when 
absolutely needed. AMQP’s open platform is a natural choice for event and message design patterns

Process Orchestrator can trigger processes in response to messages placed on AMQP queues/exchanges. 
Processes can also read messages from queues/exchanges one at a time if they want to respond to 
messages one at a time rather than in parallel, to operate more as a queue. Processes can submit messages 
to queues/exchanges.

JMS is another possible integration enabled through AMQP. AMQP has providers to place JMS 
messages on queues/exchanges.

Related Topics

Integrating Using the Advanced Message Queuing Protocol (AMQP)
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AMQP Exchange Types 

The exchange type determines how AMQP processes and routes messages. There are several types of 
exchanges. 

Exchange Type Description

Default The default exchange is a direct exchange with no name (empty string) pre-declared 
by the broker. It has one special property that makes it very useful for simple 
applications: every queue that is created is automatically bound to it with a routing 
key which is the same as the queue name.

For example, when you declare a queue with the name of "search-indexing-online", 
the AMQP broker will bind it to the default exchange using 
"search-indexing-online" as the routing key. Therefore, a message published to the 
default exchange with the routing key "search-indexing-online" will be routed to 
the queue "search-indexing-online". In other words, the default exchange makes it 
seem like it is possible to deliver messages directly to queues, even though that is 
not technically what is happening.

Direct Delivers messages to queues based on the message routing key. A direct exchange 
is ideal for the unicast routing of messages (although they can be used for multicast 
routing as well).

Fanout Routes messages to all of the queues that are bound to it and the routing key is 
ignored. If N queues are bound to a fanout exchange, when a new message is 
published to that exchange a copy of the message is delivered to all N queues. 
Fanout exchanges are ideal for the broadcast routing of messages.

Topic Routes messages to one or many queues based on matching between a message 
routing key and the pattern that was used to bind a queue to an exchange. The topic 
exchange type is often used to implement various publish/subscribe pattern 
variations. Topic exchanges are commonly used for the multicast routing of 
messages.

Headers Routes messages based on multiple attributes that are more easily expressed as 
message headers than a routing key. Headers exchanges ignore the routing key 
attribute. Instead, the attributes used for routing are taken from the headers 
attribute. A message is considered matching if the value of the header equals the 
value specified upon binding.
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Process Orchestrator System Elements
The following diagram shows the major functional elements of the Process Orchestrator system. These 
elements are discussed in the sections that follow.

Figure 1-1 Process Orchestrator Functional Model 

Activities
Activities are the steps in a process. They are customized to perform integration with some environment. 
For example, an stop trap send activity would have a very different UI and set of properties from an SAP 
ABAP call, and would have very different runtime characteristics as well.

Activities can be provided by adapters (binary components in Cisco Process Orchestrator) or by 
automation packs. Therefore both adapters and automation packs can contribute to a particular 
integration. 

Workflow activities provide the logic or flow aspects of the process workflow. Workflow activities are 
exposed in the Logic tab of the toolbox in the Process Editor. 

Related Topics

• Advanced Authoring Concepts

• Adapters

• Automation Packs

• Adding Logic Components to a Process

Automation Summaries
Technically, automation summaries are XML files that are published on a share or web server. The path 
or URL is then available to be linked from anywhere. This architecture makes them available for 
integration into virtually any context.
1-15
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 1      Introduction
  Process Orchestrator System Elements
Automation Summaries are a key integration tool. For example, they can be placed in incidents in the 
Service Desk to reveal the analysis of the automation that was performed, or they can show how an 
incident was resolved.

Conditions
Many workflow logic elements perform tests to control execution. Conditions implement these tests. For 
example, a Condition Branch can split execution to take one path if a condition exists, and another if it 
does not. A While Block can iterate execution while a condition exists.

Conditions can also be placed on a process trigger, allowing control of situations in which the process 
can run. For example, a scenario might require the process to run during two different time ranges, which 
would require two triggers: one trigger with an 8am-5pm condition and a totally different trigger with a 
5pm-8am condition.

There are two basic types of conditions:

• State conditions

State conditions evaluate some state. The Process Orchestrator provides a number of state conditions 
that can be perceived as a part of the base product, but technically are part of the adapter. For 
example, it provides a test to see if a variable has some value.

• Composite conditions

A composite condition builds a compound condition from individual conditions. It allows 
combining conditions with AND logic, where all of the conditions must be TRUE for the composite 
condition to be TRUE, or OR logic, where any of the conditions can be TRUE for the composite 
condition to return TRUE.

Compound conditions can be used in other compound conditions to produce complex logic, such as 
((X AND Y) OR (A AND B)).

Processes
Use Process Orchestrator to automate an IT processes by defining a process, then running instances of 
the defined process. 

An element of the process is the process workflow. The workflow defines the automation steps 
(activities), the logic or flow between these steps, and how to flow data from one step to the next.

The engine manages the state and lifecycle of a process, bringing it into existence, running its steps, and 
finally terminating it. During and (by default) after process execution, the engine retains information so 
that operators can view the status of their running processes.

Related Topics

Creating a Basic Process

Runtime Users
A runtime user record stores information about the user security context and passes this information to 
the adapters for activity execution, event monitoring, and some target operations (such as availability 
monitoring and discovery). Runtime user instances can be shared across targets and processes. For 
example, if a single set of credentials can be used to access a set of network devices, only one runtime 
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user instance must be created. When it is time to change the credentials, users can go to the runtime users 
list and edit the single instance to change the credentials. This greatly reduces the configuration load 
when credentials tend to change often in some environments.

Note Runtime user credentials can be used in a process, but no process can retrieve credentials. If your process 
must access credentials, use hidden string variables.

The runtime user concept allows the product to implement delegation. For example:

1. An IT help desk operator comes to Process Orchestrator to run a process. 

2. This operator is presented with a list of processes that Process Orchestrator’s role-based access 
control allows them to run. These processes might include activities that require a level of security 
permission that the operator does not natively have. 

3. The operator can perform actions as a part of the established process that are not possible for them 
to perform manually.

This concept can also be leveraged to reveal where operators make changes outside of a process. By 
examining auditing logs such as Windows logs for things being done under the operator’s credentials 
rather than the Process Orchestrator runtime user credentials, it is possible to determine how the operator 
is doing things outside of process and determine how to close things down. So a side effect of Process 
Orchestrator automation is that customers might be able to tighten security in their environment.

Targets
Targets are instances created from a target type. For example:

• A terminal target allows SSH or telnet to some specific network device.

• A UCS Manager target allows connection to a specific UCS Manager in charge of a UCS system.

• A database target allows connection to specific supported databases.

A process or activity executes an action within some environment. The specifics of the definition of the 
connection to the environment are encompassed in the target. For example, a target for:

• An SSH command might be a specific UNIX system or network device.

• A database query might be a specific database

• An SAP ABAP activity might be a specific SAP system. 

Processes can restrict the type of target which they can accept. For example, it is not appropriate to run 
a process to change a network device’s configuration against a Windows computer.

A process workflow acts on a target. This allows the process workflow to perform actions against an 
external tool or environment. Although a default target instance can be specified directly by a process, 
more commonly it is associated to the process at run time.

Activities, which are the steps in a process (see Activities), can also specify a target. Typically, activities 
default to use the process target, but a step in a workflow might need to happen against a different system 
than the process target. For example, a process overall might deal with a network device, but a step in 
the process might need to update a database. Often workflows can determine the target on which an 
activity may act by using a relationship to the target for the process, or doing a query on some data such 
as a name to find a matching target instance.
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Related Topics

• Defining a Target

• Creating Triggers

Target Groups
Target groups are collections of targets. Often automation might need to run against all machines in a 
collection, or against one of the machines in a collection. Target groups provide this functionality. 

Adapters can provide target groups to leverage grouping definitions where they exist. For example:

• Active Directory OU—Customers are frustrated when they must recode their grouping information 
into yet another product. The Active Directory adapter seeks grouping information where it is 
defined. For example, an Active Directory target group looks up computers in some organizational 
unit (OU) in the directory.

• Target Type group—Using queries of their attributes, the Process Orchestrator provides type-based 
groupings of targets. For example, use a target group to group all targets of a given type, or to 
perform additional filtering to pattern match against a field in the target definition.

• Virtual group—A target group can be a virtual group. Use a virtual group to specify an explicit list 
of targets, providing the capability to manually select targets and establish group membership. A 
virtual group can also allow the inclusion of other target groups so that group membership can be 
defined hierarchically. For example, a virtual group called “Production switches” might include all 
members of the “Houston data center switches” group as well as all members of the “London data 
center switches” group, but not members of the “Engineering lab switches.”

A default target for a process can specify a target group along with a target selection algorithm:

• Typically, a target selection algorithm chooses one or more members of a target group to specify the 
target instances on which the process will act.

• At runtime the target selection algorithm resolves the then-present members of the target group and 
selects a target. 

• When a user, CLI, or northbound API call interactively runs a process ad-hoc (on demand), the user 
can accept the default target specified in the process or override it with a specific target.

• Where a target selection algorithm resolves to multiple target instances, the engine spins up separate 
process instances for each target. Thus at runtime, a process instance has a specific target on which 
it will act, against which the process workflow encodes actions.

Related Topics

Defining a Target

Target Types
Target types provide a way to define a service or other IT element that is not represented by any target 
type provided by an adapter. A target type can:

• Extend an existing adapter-provided target type

• Extend another target type

• Define a completely new target type
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All new targets are created based upon a target type. Some target types are ‘abstract’, meaning they 
cannot be directly instantiated into targets but are only available for inheritance by other target types. In 
Process Orchestrator, these target types are marked as either ‘creatable’ or ‘not creatable’.

A target type:

• Exposes (and inherits from its ancestor target types) properties and inter-target named relationships 
that can be read and set either manually or by an Update Target activity. 

• Defines property default values.

Tasks
Tasks allow a process to create an IT record or perform human interaction, and provide ownership and 
lifecycle. Process Orchestrator provides a list of tasks in the operator console. Managers can then set or 
change assignments to those on their staff. Assignment changes, state changes, and all other changes are 
audited, so one can definitively tell exactly who did what in the system. 

There are two types of tasks: IT process records and human interaction.

IT Process Records

IT process records tasks include the alerts, incidents, and change requests. These records represent the 
core records within IT; they are the core ITIL (IT Infrastructure Library) records. While Process 
Orchestrator does provide a list of these records so that one can, for example, look at a list of alerts which 
automation created and manage their lifecycle, more often these records are used to synchronize the 
records out of Process Orchestrator to a separate tool. 

For example, alerts typically need to be pushed to an enterprise event manager so that the alerts can be 
combined with others to present a view of IT system health. Incidents and change requests are typically 
the domain of service desks. Rather than managing these records in Process Orchestrator, many 
customers prefer to manage these records elsewhere. 

This construct allows processes to be independent of the event manager or service desk. For example:

1. A process such as one in a network best practice automation pack simply creates an alert, incident, 
or change request. 

2. Optionally, this process can block waiting on the task to enter a completed state. 

3. Separately, a Remedy automation pack includes a process that triggers when a new incident task is 
created, and creates the corresponding entry in the Remedy system. 
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4. The Remedy automation pack can synchronize data between the systems and when the incident 
reaches a terminating state in the Remedy system, the incident in Process Orchestrator is then 
automatically synchronized. 

5. When the incident in Process Orchestrator is closed, if the process in the network best practice 
automation pack blocked, it can continue. For example, the process might go on to prove that the 
problem that generated the incident in fact no longer manifests, closing the loop to prove that the 
remediation did in fact fix the problem. 

With this abstraction, the network best practice automation pack does not need to be dependent on the 
specifics of which service desk is involved, and no dependency exists between the automation packs.

Human Interactions

Human interaction tasks are steps in a workflow where a human needs to take action. They include the 
following types of tasks:

• Approval tasks consist of steps where the workflow needs someone’s indication of what route to 
take. They may be simple yes or no questions, or they might give any arbitrary set of choices.

• Guided Operation tasks consist of steps in a workflow that someone must perform manually. For 
example, a step in a network automation workflow might be to replace a cable. While this step 
cannot be automated, it might be a small part of an overall workflow that can be automated.

• Review tasks allow the assignment of a document or automation summary review. When someone 
indicates the review is complete, the workflow can continue. Moreover, the person who indicated 
they completed the review is recorded in auditing. Many systems might send a notification to let 
someone know that they need to, for example, look at a report, but do not close the loop to see that 
the review actually occurred. Process Orchestrator allows closing the loop.

• Input Request tasks allow gathering data as the workflow executes.

Task Rules
Task rules provide a list of rules that act on new tasks or task changes to handle cases such as 
assignments, changing alert or incident severities, or setting customer-specific categories on tasks. By 
defining a task rule, you can tune the content you receive to your specific company without having to 
edit processes in the automation pack. By performing these actions by rule, one change can affect tasks 
created by multiple processes. For example, you can assign all SAP Incidents to a single person with a 
single rule.
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You can view default assignments, notifications, and properties to be updated according to the following 
defined rule types:

Whenever a task is created, Process Orchestrator goes through the settings and conditions of each task 
rule that is listed and enabled. If the conditions and settings in the rule are satisfied, the task rule is 
executed. 

Note Task rules are executed according to the order in which they are displayed in the list.

When Task Rules Execute

Task rules can not be manually run by the user. Task rules can only execute when a task is created within 
Process Orchestrator processes and rule conditions are met. If the task-created trigger (for any task type) 
and rule conditions are met, the action of the task rule is executed in the order in which it is listed in the 
Definitions > Task Rules view. 

Any processes that are triggered based on a Task Created trigger will only execute after the appropriate 
task rules have executed.

Task Rules Example

Assign a task A new user installs and runs the SAP Automation Packs. Automation 
Pack processes create alerts and incidents. The user needs to assign the 
alerts and incidents to individuals who own that specific area of SAP. It 
is difficult to anticipate every way the customer may have broken up 
their SAP management responsibilities within the team. Virtually every 
customer who uses Process Orchestrator for SAP customizes the product 
for assignments. The user can go to a list of Task Rules and create a rule 
to make the assignment. In this list, they can see what other assignments 
have been made.

Send a task notification Beyond notifications, when an owner is assigned, often the same or 
separate people must be notified in response to incidents. For example, 
if a job fails that is a financial job, perhaps both the technical owner of 
SAP job management and someone in the financial team should be 
notified; ownership of the incident should not be assigned just to the 
financial team. Note that Cisco’s implementation task rules set a “people 
to notify” property on the task. The Task Rule identifies who to notify 
and a process would send the actual email.

Change alert or incident 
severity

Cisco’s SAP automation pack assigns the severity of each detected 
condition when it creates the alerts and incidents. However, customer 
environments and requirements are unpredictable. It is very common for 
customers to change the severity of their alerts and incidents to match 
the business importance of that issue relative to others in their systems.

Add a custom category to a 
task

If you need to see a certain type of review, alert, or incident within a 
restricted view, categories are a natural way to group these alerts. 
Default alert categories are established in the automation pack, but users 
might want to add their customized categories to Tasks generated by 
automation packs.
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Notifications

In addition to notifications that occur when a user is assigned, often the same or other people must be 
notified in response to a task. The task rule notification identifies which person or group to notify and a 
process emails the notice.

Each task contains a list of notification recipients in addition to task assignees. The notification task rule 
adds to this list of notification recipients. A process can react to a task create event or task change event 
and then appropriately notify the notification recipients by email or any other mechanism.

Automation Pack Rule Management

Task rules can be included in automation packs to easily transfer default task rules from one system to 
another, such as transferring task rules from a development system into a test or production system. 

Some Cisco automation packs include not only processes that generate tasks, but also separate processes 
that handle notifications. You can create task rules to manage these objects without editing the process 
or task so that your customization to the tasks occurs before these notification processes run.

Triggers
Process instances can come into existence in the following ways:

• A process can be invoked manually. 

• A process can be invoked by another process. 

• A trigger can fire, which initiates the process.

• A process can be invoked using the northbound web service.

Triggers are events and conditions in the system that determine how or when the process will be 
executed. Multiple triggers can be added that can be initiated when certain conditions are met. 

Process Orchestrator supports two types of rule-based triggers: events and schedules.

Events

The Process Orchestrator can monitor for events from the environment, and you can specify triggers that 
initiate processes when the subscribed event occurs. For example, an event might be an incoming stop 
trap or a fault on a UCS system.

Schedules

Schedules allow triggering processes at some time by leveraging another object called a calendar. 
Calendars define which days something can occur. Calendars can be selected days or sequences of dates 
such as weekly or monthly, they can represent dates like fiscal quarter end, or they can be combined 
hierarchically. Schedules then associate a time with a calendar. When the day is in the calendar, the time 
is evaluated. Times can be explicit or repeating (for example, hourly).
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Variables
The variables feature provides a storage area for information that is used on a regular basis to avoid 
having to specify the same information in several places. Data stored in a variable can be altered to affect 
process execution behavior. 

Activity Configuration

One of the most common uses of variables is to define activity configuration. Any field in an activity can 
refer to a variable value rather than an explicit value. For example, you can use a variable to:

• Specify the target as the machine where an event occurred

• Specify the start date of the process’ operations window as a parameter to an operating system 
command

• Specify a condition, such as a file that should not exist after a job is initially triggered by the arrival 
of that file where a prior activity should have deleted the file

Process Control Components

Processes can use variables to define the control components. For example, you can use a variable to 
define:

• A Conditional activity to look at the exit code of a prior activity

• A While Loop activity to loop until a query fails or loop for a number of times corresponding to a 
number of objects pulled from a query

Process Parameters

Variables can be parameterized so that a process definition can be vague enough to be reused in multiple 
places and the specifics can remain undefined so that they can be defined by the person or process that 
invokes the process or activity.

For example, a process called notify server owner might use a variable server for the name of the server 
that has a problem. The process retrieves the email address of the owner of the server and sends an email.

This process might be called from multiple places; a step in a server maintenance job fails, so the 
maintenance job populates the Server variable and invokes the notify server owner process. Another 
process might notify the server owner when a backup completes.

Formulas as Variable Values

You can specify a formula anywhere a variable value is used. For example, an operating system 
command's parameter might be formed from concatenating two variables' values or from parsing the 
output of a prior command.

Adapters No Longer Supported as of Cisco Process Orchestrator 
3.3

The following adapters are no longer supported and therefore instructions on how to implement them 
has been removed from the Online help and the user guide.

• SAP ABAP Adapter

• SAP Java Adapter

• SAP Solution Manager Adapter
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• IBM DB2 Database Adapter

• JMX Adapter

• OLAP Database Adapter
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C H A P T E R 2

Getting Started

Connecting to Your First Server/Environment
This section contains instructions for connecting the console to your first Process Orchestrator server.

Before You Begin

There are several user groups assigned to Process Orchestrator’s built-in security roles. Before 
attempting to access the console, you must be a member of one of these user groups or another group to 
which your administrator has assigned custom role privileges. If you do not have access or the 
appropriate rights, please contact your local IT administrator. 

Step 1 Choose Start > Programs > Cisco > Cisco Process Orchestrator > Cisco Process Orchestrator 
Console. 

Step 2 In the Select Server dialog, select a server name and click Connect to Server. 

Step 3 To configure the console server connection, choose Tools > Options, and update the parameters as 
necessary.

Understanding the User Interface

Process Orchestrator Console Components
The following topics describe the main components of the Process Orchestrator console:

• Console Menus

• Toolbars

• Workspaces

• Results Pane

• Details Pane

• Process Viewer

• Process Editor Menus
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Console Overview
The Cisco Process Orchestrator Console is the interface used to access and operate the application. The 
Console displays after completing the license check or updating your license. The default view is the 
Operations workspace.

After the initial access, the view on the Console is determined by the last item accessed before exiting 
the Console.

The Console consists of the following areas:

• Menu Bar

Contains options used to access the tasks associated with the current item selected in the Navigation 
pane.

• Toolbars

Provides shortcuts to general tasks within Cisco Process Orchestrator as well as specific tasks 
associated with the item currently selected in the Navigation pane.

• Navigation Pane

The Navigation pane, located on the left side of the Console, displays several navigation 
workspaces, each containing a group of items that enable you to perform specific actions within the 
application. When a navigation view is selected, the available contents are displayed.

The following is a list of the available views in the Navigation pane. 

– Operations Workspace

– Definitions Workspace

– Administration Workspace

– Favorites Workspace

• Results Pane

• Details Pane
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Console Menus
The Process Orchestrator console menus provide general task items, such as feature customization 
options. These menus are displayed on the Console menu bar. 

The following topics describe the contents of each of the Process Orchestrator Console menus.

Using the File Menu

The File menu contains general actions related to the configuration of Process Orchestrator. The File 
menu contains the following items: 

Using the Edit Menu

The Edit menu contains the following items for modifying the configuration. 

Note The items enabled under the Edit menu depend on the objects selected in the navigation and detail panes 
of the Console.

Menu Option Description

Connect to Server Opens the Select Server dialog box where you can specify the server to 
which to connect.

The Server drop-down list displays the list of previously connected 
servers to the Console. You can also enter the specific server address to 
be connected.

Recent Servers Displays the most recent servers that have been connected to the 
Console. 

Environment Properties Displays the Environment Properties dialog box for the connected 
Process Orchestrator server.

Update License Launches the Update License Wizard (see Updating the Product 
License) to enter your product license information. 

Exit Closes the Console

Menu Option Description

Undo Reverses the last action by the user

Redo Reinstates the previously reversed action

Copy Copies the selected text or object to the clipboard

Paste Pastes the previously copied item from the clipboard

Delete Deletes the selected item

Select All Selects all items on the dialog box or text field

Find Launches the Find dialog box to locate specific text on a dialog box.
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Using the View Menu

The View menu contains items that determines how the information displays in the results pane. Select 
one of the following items to adjust the Console display:

Using the Go Menu

The Go menu contains the following shortcuts that allow you to navigate from one view to another on 
the Console:

Menu Option Description

Large Icons Displays large icons with the associated item

Small Icons Displays small icons with the associated name

List Displays icons with the associated name in list format

Details Displays icons with the associated name and details in list format

Choose Columns Opens the Choose Columns dialog box, which is used to customize the 
displayed columns and the order in which they display (see Configuring 
Columns).

Refresh Updates the current view

Navigation Pane Enables/disables the Navigation pane on the Console. When disabled, the 
Results pane and the detail pane, if selected, expand the width of the entire 
window

Detail Pane Toggles the Details pane On or Off

Toolbars Determines the toolbars (Standard Toolbar, Advanced Toolbar, 
Configuring the Appearance of the Console) to display on the Console. 
The check mark to the left of the toolbar name indicates the toolbar is 
selected.

Status Bar Enables/disables the status bar that appears at the bottom of the Console

Menu Option Description

Back Returns to the previously selected view

Forward Option is active if you have clicked Back to access a previous view. Use 
this option to navigate to the next navigation item in the list.

Go To Displays all previously selected views to which you can return

Operations Opens the Operations workspace

Definitions Opens the Definitions workspace

Administration Opens the Administration workspace

Folder List Opens the Folder List workspace

Favorites Opens the Favorites workspace
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Using the Tools Menu

The Tools menu contains the following items that configure the appearance of the Console:

Using the Actions Menu

The Actions menu contains items that perform specific actions associated with the selected item in the 
navigation pane. 

The items that are available on the menu depend on the selected item on the Navigation pane. For 
example, the options available when the Processes view is selected are different from those that are 
available when Global Variables view is selected.

Understanding the Help Menu

The Help menu contains the following items: 

Menu Option Description

Customize Launches the Customize dialog box. Use this dialog to change the fonts 
and colors that display in the Console (see Customizing the Fonts and 
Colors).

Options Displays the Options dialog box. Use this dialog to modify basic server 
interface functions.

Menu Option Description

Help Displays dialog box-specific information in a separate pane 
to the left. 

On the toolbar, click the Help  tool to display and 
remove the Help pane.

Contents Displays the Table of Contents tab used to navigate and 
view the comprehensive help information. 

Index Displays the Index tab used to navigate and view the 
indexed help information.

Search Displays the Search tab used to enter search criteria and 
locate specific information in the comprehensive help.

About Cisco Process Orchestrator Displays the About Cisco Process Orchestrator dialog box, 
which contains the product version and license 
information.
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Toolbars
The Console has three toolbars (Standard Toolbar, Advanced Toolbar, Configuring the Appearance of 
the Console), which can be used to configure the selected navigation view, provide quick navigation 
between views, and perform item-specific actions.

Figure 2-1 Console Toolbars

To enable or disable a toolbar, choose View > Toolbars, then click the appropriate toolbar.

Standard Toolbar

The Standard toolbar displays shortcuts to general actions and functions. The following icons appear on 
every view on the Console. 

Advanced Toolbar

The Advanced toolbar displays shortcuts to general navigation and Console configuration icons.

Action Toolbar

Standard Toolbar
Advanced Toolbar

Icon Name/Action

Connect to Server—Connects to the server to which you were last connected

Server Properties—Displays the properties for the connected server

Refresh—Updates the current view with the latest information from the server

Properties—Displays defined properties for the selected object. This icon is 
unavailable if the current selection does not support property pages.

Cut—Cuts the selected text to the clipboard

Copy—Copies the selected text to the clipboard

Paste—Pastes the selected items to the location identified by the cursor

Delete—Deletes the selected object

Help—Displays or hides the Help pane

Icon Name/Task

Back—Permits you to select the page to be displayed from a drop-down list of 
the most recent history pages.

Forward—Permits you to select the page to be displayed from a drop-down list 
of the most recent forward-history pages. 
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Configuring the Appearance of the Console

You can configure options that modify the basic interface behavior of the console.

Step 1 From the Advanced toolbar, select Options to display the Options dialog box provides configuration 
options that modifies the basic interface behavior.

Step 2 Click the General tab to configure the server connection startup behavior.

• Automatically select the group and item you most recently selected—At console startup, the group 
and item that are selected are the group and item that were last selected.

• Always select the following group and item—Specify the starting group and item:

– Group—The navigation group that is selected at console startup

– Item—The navigation item that is selected at console startup

• Remember the most recently used servers—Specify the number of recently accessed servers to 
display

Step 3 Click the Windows and Layout tab to specify how the user is to be prompted when a process is launched 
and what is to be displayed after the process is launched.

• When starting a process—Select one of the following options to determine what action occurs when 
a process is launched:

– Always Launch Immediately with Default Input Value—Launches the process immediately 
when the process has specified or default values without confirmation

– Always Prompt to Confirm— Default option launches the Confirm Start Process dialog box to 
allow you to confirm whether the selected process should be launched or override the process 
start option

– Only Prompt when Process has Inputs— Launches the Confirm Start Process dialog box if the 
process has input variables. If the process does not have input variables, starts the process 
immediately without confirmation.

• After process is started—Choose one of the following options to determine what is displayed after 
a process begins:

– None—Option does not display any process instances after the process has started

– Show Instances—Displays the processes initiated in the Activities view on the Console

• Reset User Preferences—Click this button to reset the saved settings (size and location of dialog 
boxes, selected property pages, visibility of toolbars and menu items, etc.) to the system default.

Clicking this button automatically closes the Console and requires the application to restart.

Navigation Pane—Displays or hides the Navigation pane.

Detail Pane—Displays or hides the Details pane.

Status Bar—Displays or hides the Status Bar.

Options—Displays the Options dialog box.

Icon Name/Task
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Step 4 Click the Security tab to configure the default owner when creating objects in Cisco Process 
Orchestrator.

• The current user—Select this radio button to use the user account that is currently logged in to assign 
the owner on any new objects created.

• The specified user—Select this radio button and then click the browse button to launch the Select 
User or Group dialog box and specify the default user for objects.

Step 5 Click OK.

Actions Toolbar

The Actions toolbar displays options that are associated with the selected item in the Navigation pane or 
Results pane. The available items on the Action toolbar depend on the item selected. 

For example, the options available when the Processes item is selected are different from those that are 
available when Global Variables is selected.

Menu Option Description

Start Process Click to manually start any enabled process displayed in 
the Process View.

Enable If a process is manually disabled, click Enable before 
executing.

Disable Click to disable a selected process instance on the process 
view from executing.

Unlock—If a process is manually locked, click to unlock it.

Lock—If a process is manually unlocked, click to lock it.

Advanced Click this button and select Break Lock if a process is 
locked by another user and you have Break Lock 
permissions.
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Workspaces
The Console contains the following workspaces. Each workspace contains a group of objects that 
perform specific actions within the application.

Workspace Description

Operations The Operations workspace displays:

• The status of processes that are scheduled to execute, view processes that 
are currently running, and verify that processes have successfully 
completed. 

• Alerts, incidents, and approvals relating to system event history for actions 
that have occurred within Cisco Process Orchestrator. 

• System messages about status and errors within the Process Orchestrator 
server or adapters.

For more information, see Chapter 8, “Monitoring Operations.”

Definitions The Definitions workspace displays all of the components that are used in 
defining and executing processes. The options provided by this workspace 
include:

• View Current Processes—Displays the Definitions > Processes view where 
you can view and manage defined processes. This view has two panes that 
display the execution progress of the process and activity instances.

From this view, you can view process properties, execute a process ad hoc, 
edit existing processes, and define new processes. From the Processes View, 
you can also execute processes and view the status of the process as it in 
progress.

For additional information about monitor and manage processes, see 
Chapter 8, “Monitoring Operations.”

• Create a New Process—Launches the Process Editor, which you can use to 
view and define the properties for a new process as well as construct the 
process workflow. 

For additional information about the Process Editor, see Accessing the 
Process Editor

• View Operations—Displays the Operations workspace that shows what 
processes are in progress, scheduled or have been completed. 

For additional information about managing operations, see Chapter 8, 
“Monitoring Operations.”

Administration The Administration workspace displays all of the components that are used to 
manage administrative activities (such as security or database administration 
tasks).

For more information, see Performing Administrative Actions.

Folder List The Folder List view displays a list of all the navigation items available from the 
Console. The items are sorted according to the view displayed on the Console. 
The Results pane displays the view associated with the selected item.
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Results Pane
When a navigation item is selected on the Navigation pane, the information associated with that item 
displays in the Results pane. By default, the information is presented in a details list view format. The 
columns that display depend on the selected navigation item.

Details Pane
The Details pane provides additional information for a selected item in the Results pane. The links on 
each of the detail pages launch the property pages for the selected item.

Process Viewer
The Process Viewer displays a graphical view of the process workflow after a process has been launched. 
The information displayed on this viewer is read-only.

The Process Viewer contains this information:

Process Editor Menus

Process Editor File Menu

The File menu contains the following items:

Favorites The Favorites workspace displays shortcuts to user-selected navigation items. 
This view is used for quickly accessing navigation items that are frequently 
used. Any item in the Navigation pane can be added to the Favorites view.

Click Set Favorites to display the Set Favorites dialog box. Check the 
appropriate items, then click OK.

Workspace Description

Pane Description

Status Pane Displays a flat list of all activity instances that were executed by the process 
instance.

Workflow Pane Displays the graphical workflow of the selected process and its activities.

Properties Pane Displays the properties for the process and activity instances. 

To view the activity instance properties, select the activity instance in the 
Workflow pane. To return to viewing the process instance properties, click 
in the white space or use the menu.

Menu Option Description

Save Saves the process workflow

Save Copy As Saves a copy of the process workflow under a different name

Verifies that the process follows the best practices
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Process Editor Edit Menu

The Edit menu contains items to be used for modifying the process in the workflow pane. For 
information about using this menu, refer to Using the Edit Menu.

Process Editor View Menu

The View menu contains the following items:

Process Editor Tools Menu

The Tools menu contains the following items that allow you to configure the appearance and behavior 
of the editor.

Revert Returns the workflow to the previous saved version

Print Prints the contents of the workflow pane

Process Properties If an activity properties pane is displayed, the option toggles to the 
process properties pane

Exit Closes the editor

Menu Option Description

Menu Option Description

Collapse All Collapses all the activities in the workflow pane

Expand All Expands all the activities in the workflow pane

Zoom In Increases the size of the contents of the workflow pane

Zoom Out Decreases the size of the contents of the workflow pane

Zoom Default Resizes the contents of the workflow pane according to the default 
zoom value

Zoom Fit Resizes the workflow to fit the size of the pane

Zoom Fit Selection Resizes the selected item in the workflow pane to the size of the 
pane

Toolbar Displays the Editor toolbar

Status Bar Displays the status bar at the bottom of the Editor

Toolbox Displays the toolbox pane

Properties Displays the process properties pane

Menu Option Description

Customize Launches the Customize dialog box where users can change the fonts and colors 
that display in the editor. 

For information about using this dialog box, refer to Customizing the Fonts and 
Colors.
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Process Editor Actions Menu

The Actions menu contains the following items that apply to a selected item in the workflow pane: 

Process Editor Help Menu

The Help menu contains information that provides documentation assistance to work in Process 
Orchestrator. For information about using this menu, refer to Understanding the Help Menu.

Process Editor Toolbar

The toolbar displays icons to be used as shortcuts for performing actions in the workflow pane. To 
display the toolbar, choose Toolbar from the View menu. 

Options Launches the Options dialog box which is used to configure basic Process 
Orchestrator console behavior. 

Regex Matcher Launches the Match dialog box where users can match the specified source text 
against a specified regular expression.

Menu Option Description

Menu Option Description

Move Back Moves the position of an activity in the workflow back one position 
at a time.

Move Forward Moves the position of an activity in the workflow forward one 
position at a time.

Add Result Handler Inserts a Condition Branch into the workflow. A Condition Branch 
is executed only if the specified condition is met.

Expand Expands the selected activity

Collapse Collapses the selected activity

Icon Description

Saves the process

Starts the process

Prints the contents of the Workflow pane

Copies the selected information to the clipboard

Pastes the selected information to the location identified by the cursor

Deletes the selected item

Collapses the contents of the workflow pane
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Field Reference Icons

Defining a Target
Targets specify where certain processes, activities, or triggers will run. You can define a target once and 
then reuse it in multiple processes. 

Note Not all targets can be created manually. Some targets are discovered automatically based on the 
information specified by other targets.

The Definitions > Targets view displays all the existing defined targets. You can also use this view to 
create new targets, modify the properties of a target, and delete targets. 

Step 1 Choose Definitions, right-click Targets, choose New > [Target], and select a target type from the 
drop-down list.

Step 2 Run through the wizard, then click Finish.

Expands the contents of the workflow pane

Resizes the contents of the workflow pane according to the default zoom value

Increases the size of the contents of the workflow pane

Decreases the size of the contents of the workflow pane

Resizes the workflow to fit the size of the pane

Resizes the selected item in the workflow pane to the size of the pane

Displays or hides the Help pane

Icon Description

The Reference icon displayed next to a text field indicates that you can select a 
defined variable or reference an object within the process from the Insert Variable 
Reference dialog box.

The Required Value icon displayed on a tab or page indicates that the field is required 
and is either missing a value or contains an invalid value.

Icon Description
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Defining Runtime Users
Runtime users hold the security credentials that are assigned to processes and activities. For more 
information about runtime users.

Use the Definitions > Runtime Users view to display the configured runtime users, add new runtime 
users to define new connection credentials, update runtime users such as to update a password, or delete 
runtime users.

Step 1 Choose Definitions > Runtime Users, right-click and choose New > [Runtime User] for the 
appropriate runtime user account.

Step 2 Click the General tab and enter the appropriate runtime user-specific information. The property pages 
displayed depend on the type of runtime user selected. 

In the Owner field, you can click the browse button to display the Select Identity dialog box.

From the User Identity tab, click Add to display the Select Identity dialog box.

• Type—From this list, select either User or Group to define the user assignments.

• Location—Specify the user or group location. Click the browse button to display the Select Location 
dialog box.

• Filter—Filter on the search results

• Search—Click to search for the identity

• Results—Displays search results

Step 3 Search for the identity, select it, then click OK.

The Used By tab displays objects that reference the runtime user. This tab will remain blank until the 
runtime user is used by an object. 

The History tab displays the history of actions taken against the runtime user. This tab remains blank 
until after the initial creation.

Step 4 To view information about an object, highlight the object, right-click and choose Properties. 

Step 5 Click OK to close the property sheet.

Selecting a Client Certificate

Use the Select Client Certificate dialog box to select certificate you want to assign to a runtime user.

To select a certificate:

Step 1 On the Certificate property page, click Browse.

The Select Client Certificate dialog box displays.

Step 2 Click the Certificate tab and specify the following properties about the selected Certificate.

• Issued to—User name or the owner of the certificate

• Issued by—User name of the certificate issuer

• Start date—The date and time the certificate became valid.

• Expiration date—The date and time the certificate will expire.
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• Thumbprint—Specified parameters containing the client certificate thumbprint

• Has private key—Select to indicate the certificate is assigned a private key.

Step 3 Browse to the appropriate certificate.

Step 4 Enter the password for the certificate.

Step 5 Click OK to close the dialog box.

Configuring Security

Creating a New Security Role
A security role is a list of permissions that enhances product use through logical groupings of powers 
and objects for reuse in multiple places. A security permission is a pairing of a scope that defines the 
objects and powers over those objects. 

After a security role has been defined, it is available in a list of available security roles on the 
Administration > Security view. 

Step 1 Choose Administration > Security, right-click and choose New > Role. 

Step 2 On the New Role property pages, define the properties.

Step 3 Click the Permissions tab and add permissions as necessary.

Step 4 On the Permissions tab, click Add to display the Permission "All" Over "All" Properties dialog box.

• Operations—Select the appropriate operations

• Objects—Give permissions to act upon a specific object

The property pages included in the Power are determined by the specific permission to be created.

Step 5 Click the User Assignments tab and add user assignments as necessary. 

Step 6 Click OK. The new security role is displayed on the Administration > Security view.

Assigning Users Or Groups to Security Roles

Step 1 Choose Administration > Security, highlight the appropriate security role (see Predefined Security 
Roles), right-click and choose Assign.

Step 2 On the Select User or Group dialog box, in the Enter the object name to select text field, enter the user 
name (domain\user name) or group, then click Check Names. 

Note If there is a matching user name or group, it is displayed in the field. If there is not a match, an 
error message displays. 
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Step 3 On the Search Results pane, choose the appropriate user or group, then click OK.
2-16
Cisco Process Orchestrator 3.3 User Guide

 



 

 

C H A P T E R 3

Managing Automation Packs

Automation packs are collections of configuration definitions of process definitions, target types, 
variables, categories, target groups, and other system elements needed to define a set of automated IT 
processes. The out-of-the-box automation definitions in automation packs allow customers to get 
productive quickly. 

Automation packs allow users with the appropriate rights to export their own processes and share them 
with other customers in the community. Users can customize third-party automation packs and move 
them from one environment to another. Automation pack authors have control over how end users can 
override their automation definitions. The purpose of this control is to improve the ease of:

• Consuming future upgrades. Customers naturally expect that some amount of work is involved in 
upgrades. During an upgrade, all properties customized by users will be preserved. If a workflow is 
customized, it will be preserved. Process Orchestrator does not merge workflows. If any part of the 
workflow has been customized, all of the workflow will be left intact (no updates will be made to a 
customized workflow).

• Consuming patches and hotfixes for content. Customers do not expect these to be difficult or 
dangerous to consume. 

An automation pack is a single file (package) that contains:

• Configuration (processes, categories, knowledge base articles, and so on)

• An optional custom configuration user interface that presents a wizard used to configure essential 
elements of the automation pack. For example, a configuration UI for SAP performance 
management might ask the user importing the automation pack to define the SAP systems that 
Process Orchestrator will manage and provide credentials to reach those systems.

• Report Definition files. These files are extracted into a directory during automation pack import, and 
can then be imported by the customer into their chosen reporting system

• External management system configuration files such as those to define alerts in a health monitoring 
application such as Microsoft System Center Operations Manager or HP OpenView SPI Modules.

• Binaries that the customer installs in an external system that the automation pack might require. For 
example, in Cisco Intelligent Automation for Cloud, Process Orchestrator provides the elements that 
can be imported into Cloud Portal to order cloud services. 

The Administration workspace includes an Automation Pack view that displays the list of automation 
packs that have been imported. From this view, automation pack authors can create and export their own 
automation packs and share them with others in the community. Users can also export the customizations 
that they have made to third-party automation packs.

This is the typical process you will want to follow when you create an automation pack:

1. Create the basic automation pack—See Creating an Automation Pack
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– Adding Automation Pack Objects

– Creating an Automation Pack Patch

– Applying an Automation Pack Patch

– Removing Automation Pack Objects

– Refreshing References in an Automation Pack

– Viewing Automation Pack Properties

– Archiving Process Instances in an Automation Pack

2. Verify it—See Validating Automation Packs

3. Modify its settings as necessary—See Controlling the Customization of Automation Pack Elements

4. Review its dependencies—See:

– Executing a Circular Dependency Check

– Reviewing Automation Pack Validation Rules

– Selecting Automation Pack Dependencies

5. Export it—See Exporting an Automation Pack

6. Customize it— See:

– Exporting Customization Packs

– Importing Customization Packs

Creating an Automation Pack
Process Orchestrator Automation Package files include processes and other objects for Process 
Orchestrator. The defined automation packs included with the product are located in the install directory 
on the machine where the product was installed. Individual-created automation packs and 
customizations made to the third-party automation packs can be exported and reimported from one 
environment to another on an as-needed basis.

Each exportable object in Process Orchestrator supports at least two customization settings; you can tune 
these settings to control what customers can edit (see Controlling the Customization of Automation Pack 
Elements). 

• No—The object is not customizable.

• Limited—Some object properties can be customized. The extent to which properties are 
customizable varies by object type; the controls for any non-customizable (immutable) property will 
be read-only. Most objects default to Limited.

Processes have three customization settings:

• No—Users have no process editing capabilities.

• Limited—This is the default setting, under which users can make the following changes:

– Change the execution and archival option.

– Change the default target and default runtime user.

– Change the process input variable value. Users cannot add or create process variables (input or 
output), only the value of the input variables.

– Add new triggers to the process.
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– Enable/disable existing triggers. Users can remove only those triggers that they created from the 
process.

– Add category (assuming the category customization setting is set to limited).

– Remove category that is added by users (assuming the category customization setting is set to 
limited).

• Workflow—Users have near full control to edit processes with this setting. Under the Workflow 
setting, in addition to the above, users can make the following changes:

– Edit the process workflow. If the process is shipped with some workflow, defined users can 
delete the existing workflow (activities).

– Create process local or definition variables.

– Delete process variables they have created.

Users cannot:

– Delete the process

– Change the input or output variables. Input and output variables are the API or the contract 
between parent and child process.

– Change the name, description, target type, or runtime user that the process can run against.

The best practice for authors, then, is to plan extension points. Most processes that an author ships in an 
automation pack would be locked down. Authors design specific points of extension, and embed calls to 
processes with workflow customization enabled for these extension points. The workflow for these 
extension point processes would be empty.

Note You cannot export a process from an automation pack you do not own. Therefore, instead of creating 
your extension in the extension point itself, call a child process where you code the logic. In other words, 
the contents of an extension point should simply be an invocation of child processes, not activities within 
the extension point workflow. In this way, you can ship an automation pack with your extension. 
However, the call to this process must be coded into the extension point in each development, test, and 
production system.

Recommendations

• The functionality authored to extend the solution should be defined in terms of child processes, not 
activities within the workflow of the extension point.

• It should be exported separately from solution-packaged automation packs

• The functionality authored to extend the solution should be imported separately from 
solution-packaged content and stitched into the solution extension points.

• By passing target objects rather than specific parameters in to extension points, your automation 
becomes more extensible from a data perspective as well. For example, someone can come along 
and add more properties to some target type, and if the target is passed through to the extension 
point, this data is available. 

• If XML is passed into a process request, it is a good idea to make this XML available to extension 
points as well, so that they are open to extension. Moreover, the child processes in the extension 
point can modify the target properties.

Before You Begin

You must have Process Orchestrator Administrator privileges to create an automation pack.
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To create an automation pack:

Step 1 Choose Administration > Automation Pack, right-click and choose New > Automation Pack.

Step 2 If the automation pack file is a community automation pack, click the About tab, then check 
Community Automation Pack. This lets anyone modify and export this automation pack.

Note The Community Automation Pack check box is available only during automation pack creation, 
and cannot be turned on or off later. Use this feature with caution; it is mostly suitable if the 
author has no plans for maintaining and releasing new versions, and wants to post this 
automation pack as an “open source”.

Step 3 On the General tab, enter the required information.

Step 4 Click the Objects tab to add objects to the automation pack.

Step 5 Click the Dependencies tab to review the list of automation packs and adapter information referenced 
and required by the objects in the automation pack.

The Referenced Objects dialog box displays the list of objects in an automation pack that depends on an 
object in different automation pack. This dialog box is launched when an entry on the Dependencies tab 
is right-clicked and the View Referenced Objects option is chosen.

Note The dependent automation pack and required adapter lists will be updated when the automation 
pack properties is first opened or when there is a change to the Objects page, such as adding or 
removing an object.

Step 6 Click the Style Checker Selection tab to select the rules you want to validate against an automation 
pack.

Step 7 Click the Patches tab to view the list of patches that are applied to the automation pack.

Step 8 Click OK to save your changes.

Viewing Automation Pack Properties
Use the Automation Packs Properties property sheet to view or modify the processes and objects in an 
automation pack. 

To view automation pack properties:

Step 1 Choose Administration > Automation Pack, highlight the appropriate automation pack, right-click and 
choose Properties.

Step 2 On the Automation Pack Properties property sheet, click the appropriate tab to review the properties. 
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Importing Automation Packs
Use the Automation Pack Import Wizard to import product objects that are required to create and manage 
processes. The wizard automatically launches after the installation is complete and the automation pack 
initialization is completed. The wizard does not fully launch until after the automation server has started.

Note Using the Automation Pack Import Wizard, you can only import an automation pack (.TAP). You cannot 
import a customization pack (.apc).

After the automation pack initialization is complete, the Select Automation Packs dialog box displays.

Step 1 Check the check box to the left of each appropriate automation pack to be imported and click OK.

The available automation packs for import are dependent upon the product license. The Core automation 
pack will be imported first.

The Welcome to the Automation Pack Import Wizard panel displays.

Note If you do not want to display the Welcome panel the next time the wizard is launched, check the Do not 
show this page next time check box.

Step 2 Click Next to continue to the General Information Panel.

Step 3 Check the Disable all imported processes check box if you want all processes to be disabled after being 
imported.

Step 4 On the Email Keystore Password panel, specify password for Keystore file containing email digital 
signatures.

Step 5 On the Email Configuration panel, specify the default SMTP server and sender’s email address to be 
used for email activities, then click Next.

• Default SMTP server—The name of the SMTP server that is used as the default server for sending 
emails. This server name can be changed when configuring email activities that require a different 
server.

• Default SMTP port—The port number for the SMTP server. This field is automatically populated 
with port number 25 but can be changed if necessary.

• Default sender—The email address of the sender that is designated as the default sender for email 
activities.

Note The settings in this panel can be manually changed when configuring a specific email activity that 
requires a different SMTP server or sender email address.

Step 6 On the Automation Summary Configuration panel, specify where the automation summary reports that 
are generated by activities are to be saved and how long the reports are to be retained, and click Next.

• Automation summary file share—Verify the default file path that the Cisco Process Orchestrator 
server will use when creating automation summary reports.

Click Browse to determine the file share location on the network where all the automation summary 
reports are stored or click the Create a share on the current Orchestrator Server link.
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Note Verify that the UNC share file path is on a network where the Cisco Process Orchestrator service account 
has write permissions.

• Credentials—Enter the credentials for Cisco Process Orchestrator Server to access the file share.

• Virtual directory mapping—Select the Enable Virtual Directory mapping check box if you want to 
map the automation summary to an IIS Virtual Directory. This allows end-users easier access to 
automation summaries using email or the Cisco Process Orchestrator Web Console.

In the Virtual directory path box, enter the name of the virtual directory or click the Create a virtual 
directory on the current Orchestrator Server link to manually create a virtual directory on the 
local machine.

Note The file paths specified indicate the path that will be used when viewing the automation summary 
reports.

• Archiving Automation Summary Reports—Delete automation summary reports older than—Check 
this check box to limit the number of automation summary reports that are retained.

a. Enter the number of days that the reports should be retained in the text field.

b. Reports that have been retained for a period past the specified number of days will be deleted.

Step 7 On the Data Extraction panel, under Specify the destination for the extracted data, verify the default 
location for where the Cisco Process Orchestrator-provided data files should be copied.

Step 8 Under Select data to extract, check the appropriate check boxes to indicate which data files should be 
extracted.

Note Reports should be imported after the Automation Pack Import Wizard is completed.

The Review Prerequisites panel displays.

• Name—Name of the prerequisite

• Status—Status shows whether the prerequisite was located on the computer

– Passed—Correct item or version of item was on the computer

– Failed—Correct item or version of item was not on the computer

• Complete—Percentage of computer checked when verifying prerequisite

• Description—Displays description of the prerequisite information or instructions to further 
requirements for the prerequisites to be installed.

The green check mark verifies that the prerequisite was located on the computer.

The red X determines that the prerequisite is not available on the computer. When this occurs, the import 
progress is stopped and cannot continue until all prerequisites have been met.

If you click Cancel during the import, the wizard will close and the automation pack will not be 
imported.

Note If all prerequisites are passed, the wizard automatically continues to the next panel which displays the 
status of the automation pack objects being imported.
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After the objects have been imported, the importing of the Core automation pack is complete.

Step 9 If other automation packs were selected to be imported, the wizard will relaunch for the next automation 
pack, otherwise click Close.

Note If there is an existing object on the Cisco Process Orchestrator server, the Overwrite Objects dialog box 
displays. Click Yes or Yes to All to continue.

Related Topics

Importing from the Console

Importing from the Console
To use the Automation Pack Import Wizard from the Process Orchestrator console to import automation 
packs:

Step 1 Choose Administration > Automation Packs, right-click and choose Import.

Step 2 Select the automation packs to be imported and click OK.

You can import multiple Cisco automation packs from multiple directories. The Automation Pack Import 
Wizard will verify that all of the dependent automation packs already exist in the database, or in the list 
of automation packs to import, before allowing the import to continue.

The automation packs that are available for import depend on the product license.

Step 3 When the Welcome to the Automation Pack Import Wizard panel displays, click Next.

Step 4 On the General Information Panel, you can optionally check Disable all imported processes to indicate 
that all processes from this tab should be disabled by default after being imported.

Step 5 Review the information about the automation pack, then click Next.

Step 6 Some automation packs might include additional steps in the wizard to configure elements of that 
automation pack. Follow the instructions to perform each configuration.

A Warning dialog box indicates that the listed objects within the automation pack may be incompatible 
with the current release of the product.

Step 7 Some automation packs might include supplemental files that ship in the automation pack. These files 
are typically used to configure external systems, such as report definitions, that can be imported into 
your chosen reporting technology. If the automation pack includes these elements, you will see a Data 
Extraction panel. On this panel:

a. Verify the default location for where the Process Orchestrator-provided data files should be copied. 

b. Under Select data to extract, check the appropriate check boxes to indicate which data files should 
be copied, then click Next.

Step 8 The Review Prerequisites panel displays the status of each prerequisite:

• The green check mark verifies that the prerequisite was met on the computer.

• The red X determines that the prerequisite is not met on the computer. When this occurs, the import 
progress is stopped and cannot continue until all prerequisites have been met.
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Note If all prerequisites are passed, the wizard automatically continues to the next panel which 
displays the status of the automation pack objects being imported. After the objects have been 
imported, the importing of the automation pack is complete.

Step 9 If other automation packs were selected to be imported, the wizard will relaunch for the next automation 
pack. Otherwise, a Finish page will display the information about the automation packs that were 
imported. Click Close.

Related Topics

• Creating an Automation Pack

• Exporting an Automation Pack

• Cisco Process Orchestrator Installation Guide

Extracting Data Files
Data files are embedded in some Process Orchestrator-provided automation packs. By default, you can 
extract these data files during the automation pack import process. However, if you decide not to extract 
the files at that time, use the following steps to extract the files in the automation pack to a location on 
the computer.

Step 1 Choose Administration > Automation Packs, right-click and choose Extract.

Step 2 Highlight the appropriate automation pack, then click Open.

Step 3 In the Data Extraction dialog box, verify the default location for where the selected files are to be copied.

Step 4 Check the check box to the left of the appropriate data file to indicate that the data file should be 
extracted, then click OK.

Overwriting Existing Objects
Use the Overwrite Objects dialog box to confirm whether to overwrite existing objects that currently 
reside in Process Orchestrator. The Overwrite Objects dialog box displays only if both the following are 
true:

• The Cisco Process Orchestrator server contains existing objects with the same unique ID. 

• The current user is the author of the object. 

To overwrite the existing version of the object, check the check box to the left of the object, then click 
OK.

If the object belongs to a third-party automation pack, the object will be updated automatically. Any 
changed value of the object will be preserved.
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Deleting Automation Packs
If you import the wrong automation pack, use the following steps to delete it from Process Orchestrator. 

Note Automation packs that have objects with dependencies cannot be deleted. First delete the dependent 
objects, then return to try deleting the automation pack again.

Step 1 Choose Administration > Automation Pack, highlight the appropriate automation pack, right-click and 
choose Delete.

Step 2 On the Delete Confirmation dialog box, uncheck the Select the checkbox to delete all member objects 
check box to keep all member objects in the product. 

Note This check box is available only to the automation pack’s authors. If this check box remains 
checked, all objects in the automation pack will also be deleted. 

Step 3 Click OK to delete the automation pack.

Working with Automation Pack Objects

Adding Automation Pack Objects
Use this option to add more objects to an automation pack.

Step 1 Choose Administration > Automation Pack, highlight the appropriate automation pack, right-click and 
choose Properties.

Step 2 Click the Objects tab, then click Add to add objects to the automation pack.

Step 3 In the Select Object dialog box, click the Filter by Object Type drop-down list and choose the 
appropriate object type to filter the list of objects. 

Note Objects that already belong to an automation pack will be filtered from this dialog box.

Step 4 Under Select Object, highlight the appropriate objects and click OK. Or click New to create an object 
to add to the automation pack.

Step 5 Click OK. 
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Creating an Automation Pack Patch
After shipping the automation pack to the customers, you might sometimes want to add or modify an 
object in the automation pack and then ship the modified object to another environment.

Using the Create Automation Pack Patch Wizard, you can easily create a patch by adding the objects that 
exists in the current automation pack to a .pat file and then export this patch file to another environment.

You can create and manage multiple patches for a single automation pack.

The Create Patch option displays only if the current user is the author of the automation pack. The user 
must also have Process Orchestrator Administration Privileges. 

Step 1 Choose Administration > Automation Pack, highlight the appropriate automation pack, right-click and 
choose Create a Patch.

Note You need to be the author of the automation pack, otherwise the command will be grayed out 
(disabled). 

Step 2 On the Create Automation Pack Patch Wizard panel, click Next.

Step 3 On the Add Objects to the Patch panel, click Add.

Step 4 Under Select Object, highlight the appropriate objects and click OK.

Step 5 On the Select a Location panel, verify the default location for where the patch file is to be saved or click 
Browse...to select the location.

Note The patch file is saved as a .pat file.

Step 6 Verify the default version or specify the new version of the patch that is being created for the automation 
pack and then click Next.

Step 7 Click Close to complete the create automation pack patch process.

Applying an Automation Pack Patch
Patches can sometimes have a dependency on another automation pack or objects. They might also have 
dependency on another patch created for the same automation pack. Before applying the patch, verify 
that all the dependent automation packs, objects, and patches exists in the environment.

Note You can apply a patch on the same version of the automation pack on another environment.

Step 1 Choose Administration > Automation Pack.

Step 2 Highlight the appropriate automation pack, right-click and choose Apply a Patch.

Note You need to be an administrator in order to apply a patch, otherwise the command will be grayed 
out (disabled). 
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Step 3 Select the patch file that you want to apply and click Open.

Step 4 On the Apply Automation Patch Wizard, click Close to apply the automation pack patch.

Viewing Patch Details
Using the View Patch Details wizard, you can view the version of the patch, the time when it was created, 
and the objects included in the patch.

Step 1 Choose Administration > Automation Pack, highlight the appropriate automation pack, right-click and 
choose Properties.

Step 2 Click the Patches tab, highlight the appropriate automation pack, and then click View.

Removing Automation Pack Objects
Use this option to remove objects from an automation pack. Removing objects from the list of objects 
in the automation pack does not delete the object from the system.

Step 1 Choose Administration > Automation Pack, highlight the appropriate automation pack, right-click and 
choose Properties.

Step 2 Click the Objects tab, highlight the appropriate object and click Remove.

Step 3 Click OK. 

Refreshing References in an Automation Pack
Use the following instructions to update list of objects in the Objects tab. 

Step 1 Choose Administration > Automation Pack, highlight the appropriate automation pack, right-click and 
choose Properties.

Step 2 Click the Objects tab, then click Refresh References to update the list of references associated with the 
object, then click OK. 

Archiving Process Instances in an Automation Pack
Use the Automation Packs Properties property sheet to archive instances of all processes in an 
automation pack. When this option is checked, it will override and force an archive, regardless of the 
individual process archival setting.
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Step 1 Choose Administration > Automation Pack, highlight the appropriate automation pack, right-click and 
choose Properties.

Step 2 In the General tab, click Always archive all process instances in this automation pack, then click 
OK.

Validating Automation Packs
Automation pack authors are not always aware of best practices for creating content. In fact, the 
challenge is that the further removed one is from the product team, the less awareness there is of best 
practices.

Style checkers are sets of validation rules that run against an automation pack and its member objects to 
ensure that the automaton pack follows best practices. Some of the style checkers can be run against a 
process under development in the Process Editor. Some of the benefits that style checkers provide 
include:

• Automating best practice checks that QA performs on packaged content, including:

– Ensuring that the content follows best practice guidelines.

– Identifying issues with automation pack objects (broken references, missing required values).

• Raising the quality of packaged automation and automation created by Cisco Services, delivery 
partners, or customers.

• Tuning preferred checks per automation pack. Style checkers can be turned on or off based on need. 
For example, automation packs developed for in-house use might want to turn off some style 
checkers (such as target, or users included in automation pack).

• Embedded help for identified issues. Help topics notify users why a style check is added, and what 
the consequences might be if the warning is not resolved.

To run a style checker against an automation pack:

Step 1 Choose Administration > Automation Pack, highlight the appropriate automation pack, right-click and 
choose Properties.

Step 2 Click the Style Checker Selection tab to select the rules you want to validate against an automation pack 
(see Controlling the Customization of Automation Pack Elements), then click OK.

Step 3 To start the validation process, you can either:

• Right-click on the automation pack and choose Validate from the context menu. 

• On the Process Editor, choose File > Validate to display the Style Checkers Selection dialog box.

Note that:

• The automation pack validation action can be run on-demand or at export.

• This menu item is disabled if you click an automation pack that you did not create.

• Validation of an automation pack could take several minutes. 

Step 4 Click OK. The process validator will start processing the selected validation rules against the current 
process. 
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Controlling the Customization of Automation Pack Elements
Use the Settings dialog box to define the customization settings for the objects included in an automation 
pack. These settings can only be modified by the automation pack author. 

Note This functionality (the Settings dialog box and Customization settings) is not available on “Community” 
automation packs; anyone can modify objects in those types of automation packs. For more information, 
see Creating an Automation Pack.

When the automation pack author imports a newer version of the automation pack, the objects in the 
automation pack will replace the objects in the database.

When a third-party user imports a newer version of the automation pack, the customization setting of an 
object will determine whether user-customized values will be preserved.

The following are instances where an object customization will be lost:

• The author of the object no longer allows users to customize the object. Any customization of the 
object will be lost on upgrade. 

For example, the global variable customization level is set to Limited. Users change the variable 
value. However, in the updated automation pack, the author no longer allows users to change the 
variable value, because the automation pack must have a particular value. Therefore, the 
customization level is now set to No. 

• The object customization level is unchanged, but the schema of the object is changed. The old object 
is now obsolete and needs to be replaced.

To change the customization of an object:

Step 1 Choose Administration > Automation Pack, highlight the appropriate automation pack, right-click and 
choose Properties.

Step 2 Click the Objects tab, highlight the appropriate object, then click Settings.

Step 3 In the Settings dialog box, click the Customizable drop-down list and choose the appropriate option, 
then click OK. 

Executing a Circular Dependency Check
Use the Circular Dependency Check command to perform an automation pack circular dependency 
check on the selected automation pack.

Before You Begin

• You can only run this test if you are the “author”.

• This command relies on the automation pack dependencies and their dependent automation packs 
dependencies (recursively) to be accurate. The command will not continue if it detects the 
automation pack or its dependent automation pack is not up to date. 

To run this check, choose Administration > Automation Packs, highlight the appropriate automation 
pack (you must be the author), and choose Circular Dependency Check.
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Reviewing Automation Pack Validation Rules
Before you export an automation (see Controlling the Customization of Automation Pack Elements), you 
should review the adapter and automation pack dependencies.

To review automation pack dependencies:

Step 1 Choose Administration > Automation Pack, highlight the appropriate automation pack, right-click and 
choose Properties.

Step 2 Click the Dependencies tab to view the dependent automation pack and required adapter lists for the 
automation pack. 

The dependencies will be updated when the automation pack properties is first opened or when there is 
a change to the Objects tab, such as adding or removing an object.

Step 3 Review the list of automation packs and adapter information referenced and required by the objects in 
the automation pack (see the Automation Pack Details and Required Adapters tables in Controlling the 
Customization of Automation Pack Elements), then click OK. 

Selecting Automation Pack Dependencies

Step 1 Choose Administration > Automation Pack, highlight the appropriate automation pack, right-click and 
choose Properties.

Step 2 Click the Style Checker Selection tab to select the rules you want to validate against an automation pack 
(see Controlling the Customization of Automation Pack Elements).

Step 3 Click OK to save your changes.

Exporting an Automation Pack
The automation definitions included in Process Orchestrator Automation Packs can be exported. 
Exporting automation definitions allows them to be moved from one environment to another, creates a 
backup of the automation definition, and allows automation to be shared with another organization.

Use the Automation Pack Export Wizard to export an automation pack file to a designated file path on 
your computer.

Step 1 Choose Administration > Automation Packs, highlight the appropriate automation pack, right-click 
and choose Export.

Step 2 On the Welcome to the Automation Pack Export Wizard panel, click Next.

Step 3 On the Objects to Export panel, review the list of objects associated with the process being exported, 
then click Next. 

Step 4 On the Dependencies panel, review the list of automation packs and adapter information referenced and 
required by the objects in the automation pack, then click Next.
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Step 5 On the Prerequisite Selection panel, review the additional prerequisite information used to export the 
automation pack. Click Select All to select all the objects to be included when this automation pack is 
imported. Click Unselect All to clear the objects from selection.

Step 6 On the General Information panel, modify the version number for the automation pack, as necessary, and 
click Next.

Step 7 On the Export Location panel, in the File name text box, specify the name of the file and where the 
automation pack will be exported onto the computer, then click Next.

The Validate Objects panel displays progress of the object validation.

Step 8 On the Validate Objects panel, review the following information about the objects being validated, then 
click Next.

Step 9 Click Close to complete the automation pack export process.

Automating Automation Pack Exports and Imports
You can use the automation pack export and import CLI to automate moving the self-authored or 
customization packs from development to test to production. 

Use the PowerShell interface on the Process Orchestrator server (see Using the PowerShell Snap-in CLI) 
to get the syntax help for a command.

Step 1 Enter the following command to list all of the available commands:

Get-Command *-Orchestrator*

Step 2 Enter the Get-Help command to view the syntax help for the automation pack export and import 
commands.

• To view the syntax for exporting self-authored automation packs, enter:

Get-Help Export-OrchestratorAutomationPack –full

• To view the syntax for importing self-authored automation packs, enter:

Get-Help Import-OrchestratorAutomationPackFile –full

• To view the syntax for exporting customization packs, enter:

Get-Help Export-OrchestratorCustomizationPack –full

• To view the syntax for importing customization packs, enter:

Get-Help Import-OrchestratorCustomizationPackFile –full

Exporting Customization Packs
Automation Packs allow users to customize third-party processes and share them with other customers 
in the community. When you export a customized automation pack, the customized objects are exported 
to a customization pack and are saved with the extension .apc.

Use the Automation Pack Customization Export wizard to export the customized objects to a 
customization pack.
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Step 1 Choose Administration > Automation Packs, highlight the appropriate automation pack that is 
customized, right-click and choose Export Customized Objects.

Step 2 On the Welcome to the Automation Pack Customization Export Wizard panel, click Next.

Step 3 On the Objects to Export panel, review the list of objects associated with the process being exported, 
then click Next.

Note Not all customized values are exported to the customization pack. For example, if you customize the 
target value of a target that doesn’t exist in the automation pack, such referenced target value is not 
exported to the customization pack.

Step 4 On the Customization Export Location panel, specify the location of the file and the password to encrypt 
data in the data file, then click Next.

• File name—Specify the name of the file and where the automation pack will be exported onto the 
computer.

• Password to encrypt data in data file—Password used for encrypting data such as the password of 
the runtime user, target properties with the type secure string, and so on.

• Confirm the Password—Re-enter the password

Step 5 Click Close to complete the customized automation pack export process.

Importing Customization Packs
Before importing the customization pack, make sure that the same version of the automation pack that 
you used to customize already exists in the environment. Also, verify that all the dependent automation 
packs already exist in Process Orchestrator.

The customizations made to the automation pack can be imported on the same version of the automation 
pack that you customized.

Use the Automation Pack Customization Import wizard to import the customization pack.

Step 1 Choose Administration > Automation Packs, highlight the appropriate customization pack, right-click 
and choose Import Customized Objects.

Step 2 Select the customization pack that you want to import and click Open.

Step 3 On the Welcome to the Automation Pack Customization Import Wizard panel, click Next.

Step 4 On the Decryption Password panel, enter the decryption password to decrypt the encrypted data.

The decryption password is the same as the encryption password entered while exporting the 
customization pack.

Step 5 Click Close to complete the customized automation pack import process.
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Using the Wizard

Launching the Import Wizard
Launch the Wizard and follow the steps as instructed.

Launching the Export Wizard
Launch the Wizard and follow the steps as instructed.
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C H A P T E R 4

Advanced Process Orchestrator Actions

The topics in the following sections provide information about managing the server connections for 
Process Orchestrator. You can launch multiple consoles, change your server connections, and modify the 
behavior of the server connection upon startup. 

• Launching Multiple Consoles with the Same Server

• Launching Multiple Consoles with Different Servers

• Connecting to a Different Server from the Current Console

• Managing Cisco Process Orchestrator Server Connections

• Configuring the Console Global Settings

• Collecting Process Orchestrator Diagnostics

Related Tasks

• Updating the Product License

Launching Multiple Consoles with the Same Server
To launch multiple Consoles using the same server:

Step 1 Choose Start > Programs > Cisco > Cisco Process Orchestrator> Cisco Process Orchestrator 
Console. 

Step 2 In the Select Server dialog, enter the server and authentication credentials, then click OK. 

Note For additional information about connecting to a server, see Connecting to a Different Server 
from the Current Console.

Step 3 Repeat as necessary to open additional consoles connected to the same server.
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Launching Multiple Consoles with Different Servers 
To launch multiple Process Orchestrator Consoles with a different server:

Step 1 After the first console is launched, choose Start > Programs > Cisco > Cisco Process Orchestrator> 
Cisco Process Orchestrator Console to launch an additional Console.

Step 2 In the Select Server dialog, enter the server and authentication credentials, then click OK. 

Step 3 Choose File > Connect to Server. 

Step 4 In the Select Server dialog, enter the server and authentication credentials for the new server, then click 
OK.

Note If the Console was recently connected to the server, click the arrow to select the server from the 
drop-down list.

The Console display changes and retrieves the Console configuration for the selected server.

Step 5 Repeat, as necessary, to open additional Consoles.

Connecting to a Different Server from the Current Console
Use this process when connecting to a different server while working in an open Console. This option 
may be useful when wanting to connect to a different server used for process monitoring. 

To connect to a server:

Step 1 Choose File > Connect to Server.

Step 2 In the Select Server dialog, enter the server and authentication credentials for the new server, then click 
OK.

Note If the Console was recently connected to the server, click the arrow to choose the server from 
the drop-down list.

If the server is properly connected, the Cisco Process Orchestrator License Check dialog box displays. 
If the server does not properly connect, the Connect to Server error dialog box displays.
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Managing Cisco Process Orchestrator Server Connections
The following instructions provide information about managing the server connections for Process 
Orchestrator. You can launch multiple consoles, change your server connections, and modify the 
behavior of the server connection upon startup. 

Configuring Server Connection Behavior
When you connect to a server and open the Process Orchestrator Console, you can choose to open the 
last group and item you were using before you closed the Console, or you can open a specific group and 
item every time you start the Process Orchestrator Console. 

To determine the behavior of the server connection:

Step 1 Choose Tools > Options, then click the General tab.

Step 2 Under Startup behavior, choose one of the following functions to occur when connecting to a server, then 
click OK:

• Automatically select the group and item most recently selected to open the last group and item 
selected before the Console was closed.

• Always select the following group and item from the dropdown list to specify the group and item 
to open upon startup.

Modifying the List of Recent Servers
To adjust the number of recent servers displayed:

Step 1 Choose Tools > Options, then click the General tab.

Step 2 Under Most recently used servers, enter the number of servers to display on the Recent Servers list on 
the File menu, then click OK.

Configuring the Console Global Settings
Use the following sections to configure the global display settings for the Console.

Configuring Process Orchestrator Objects Default Owner
By default, the objects that are created in Process Orchestrator use the currently logged in Windows user 
as the default owner. Use Security tab to specify the currently logged in Windows user as the default user 
or to specify a different default owner.

Step 1 Choose Tools > Options, then click the Security tab. 
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Step 2 Under Default Owner, select the appropriate option to indicate the default ownership setting for objects, 
then click OK.

Modifying Process Launch Settings
Use the Windows and Layout tab to determine the action required when launching a process.

To set the Console behavior when starting a process:

Step 1 Choose Tools > Options, then click the Windows and Layout tab. 

Step 2 Under Process Launching, from the When starting a process drop-down list, choose one of the following:

Step 3 From the After a process is started drop-down list, choose one of the following options to determine 
what is displayed after a process begins:

Step 4 Click OK.

Field Description

The current user Select this radio button to use the user account that is currently logged in 
to assign the owner on any new objects created.

The specified user Select this radio button, then click “...” to launch the Select User or Group 
dialog box and specify the default user for objects.

Field Description

Always Launch Immediately with 
Default Input Value

Launches the process immediately when the process has 
specified or default values without confirmation.

Always Prompt to Confirm Default option launches Confirm Start Process dialog box 
to confirm whether the selected process should be 
launched.

Only Prompt when Process has 
Inputs

Launches the Confirm Start Process dialog box if the 
process has input variables. If the process does not have 
input variables, starts the process immediately without 
confirmation.

Field Description

Show Instances Displays the processes initiated in the Start Process Results popup 
window.

None Does not display the Start Process Results popup window.
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Restoring Console Default Settings
The Reset User Preferences button on the Windows and Layout tab restores the Console configuration 
to the default value.

If the window position and size, columns and column sizes, and other configurations in the Console have 
been modified, this option restores the settings to the Console default settings. The product will 
automatically close when you reset user preferences.

To restore the default Console configuration:

Step 1 Choose Tools > Options, then click the Windows and Layout tab. 

Step 2 Under Saved user preferences, click Reset User Preferences, then click OK. 

After confirming the action, the Console will close automatically.

Collecting Process Orchestrator Diagnostics
The Cisco Process Orchestrator Diagnostic Utility collects various information about the server 
environment, installation, as well as any errors or exceptions. The information is compiled into a zip file 
and saved according to the user preference. The user can then send the information to Cisco Process 
Orchestrator Technical Support to help diagnose the problem with the Process Orchestrator installation.

Note Run this utility only when directed to do so by Customer Support.

The following data is collected by the Utility:

• Diagnostic logs written by the Cisco Process Orchestrator Service, console and other components 
(*.log files)

• Information about the computer: including memory, processors, OS versions, installed hotfixes and 
applications (ComputerInfo.txt)

• Information about files installed in the Process Orchestrator installation folder (FileInfo.txt)

• Snapshots of the Windows Event logs (Application, System, as well as Process Orchestrator-specific 
logs) (.evt files)

• Snapshots of the Process Orchestrator registry key (.reg files)

• Process Orchestrator component configuration files (.config files)

To generate diagnostic logs:

Step 1 Choose Start > All Programs > Cisco > Cisco Process Orchestrator > Diagnostic Utility.

Step 2 To collect diagnostic information:

a. Click Collect diagnostic information about Cisco Process Orchestrator, then click Next.
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b. On the Information to Collect panel, check the check box of the appropriate logs.

c. Click Next to continue. 

d. In the Full path to the diagnostics archive file, verify the default file path, then click Next.

e. After the information is collected and saved to the appropriate directory, click Close.

Step 3 To review logging settings and manage debug log files:

a. Click Review logging setting and manage debug log files, then click Next.

b. In the Logging Settings panel, select the log files for the component you want to view (such as client, 
server, or Java adapter debug logs).

c. To open the folder of log files for a component, click Open. Use an ASCII editor to view the contents 
of a specific log file.

d. Click Finish.

Field Description

General information Generates log information from the Process Orchestrator server 

• Process Orchestrator registry key

• Process Orchestrator configuration files

• Installed file information

Server Information • Application event log—Log information of application events

• Process Orchestrator event log(s)—Log information of the Process 
Orchestrator server

• Server debug logs—Server log information containing debug logs 
produced by the Process Orchestrator server

• System event log—Event information of system logs

• Web Console debug logs—Event information of Web Console logs

Client Information • Client debug logs—Contains debug logs produced by the Automation 
Pack Import Wizard. 

• Cached client file information—These log files are collected on 
client-only computers. These files contain information about files that 
were downloaded by the Console Loader from the server. The 
information also includes time stamps and version numbers for all 
files in the loader cache.

• Console settings file—Contains debug logs produced by the Process 
Orchestrator console 
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Authoring Processes

A process is basically a constructed workflow that consists of activities, invocations of child processes, 
and logic components that can be included to complete the process. Cisco Process Orchestrator allows 
you to automate IT processes based on your organizational requirements using a workflow format. The 
Process Orchestrator also includes many predefined processes in its packaged automation packs.

Processes can be viewed from both the Operations and Definitions workspaces:

• The Operations workspace displays scheduled and running processes. This workspace displays the 
Activity Views, Process Views, and Target Views. These views display the execution progress of the 
process instances.

• The Definitions workspace displays the defined processes and provides options to edit existing 
processes and define new processes. From the Processes View, you can also execute processes and 
view the status of a process in progress.

The following sections provide information about creating and managing processes:

• Accessing the Process Editor

• Creating a Basic Process

• Selecting the Target Type on Which a Process Acts

• Adding an Invocation of an Existing Child Process

• Authoring Task Activities

• Publishing Automation Summaries

• Adding Logic Components to a Process

• Adding Process and Global Variables

• Adding Targets and Target Groups

• Adding Conditions

• Adding Target Types

• Managing Processes

• Creating Processes as a Team
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Working with the Definitions Workspace
The Getting Started > Definitions view displays all the components that are used in defining and 
executing processes. This view contains items that are used to define the various components that are 
included in processes.

The Results pane displays task shortcuts information in the Results pane that guides you through using 
the features in the Definitions workspace.

The following tasks can be performed from this view:

• View Current Processes—Displays the Processes view where users can view and manage the defined 
processes

• Create a New Process—Launches the Process Editor dialog box which is used to view define the 
properties for a new process and construct the process workflow

• View Operations—Displays the Operations workspace that shows what processes are in progress, 
scheduled or have been completed.

Accessing the Process Editor
Cisco Process Orchestrator simplifies process creation using a drag and drop workflow designer. The 
Process Editor allows you to drag activities, workflow activities (logic), or processes you want to invoke 
into a process definition where you want it to occur. The Process Editor dynamically accepts the new 
addition and shows the resulting logic.

Unlike drag-and-wire approaches common to other Process Orchestrators, the logic of the process is 
always clear, without having to constantly modify the layout as the process definition evolves. This 
makes it easier for other operators to view or edit processes that have previously been created. You can 
also collapse sections of the workflow that are not currently of interest.

Use the Process Editor to:

• View and modify the properties of an existing process

• Define properties

• Construct a workflow for a new process

Note The procedure to access the editor depends on the task to be performed.

To access the Process Editor:

• If you are creating a new process, choose Definitions > Processes, right-click and choose New > 
Process. 

Note The New button on the Actions toolbar is not available if a process is highlighted in the 
Processes Results pane.

• If you are modifying an existing process, on the Processes Results pane, right-click the appropriate 
process, then choose Edit.

The Process Editor opens.
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Toolbox Pane

The toolbox pane on the left side of the editor includes these views. The navigation items displayed in 
the toolbox depend on the view that is selected. 

Workflow Pane

The Workflow pane is a canvas located in the center portion of the Process Editor (see ). Use this area 
to create processes by dragging and dropping activities, other processes, and components from the 
toolbox onto the canvas. 

Process Orchestrator ships with automation packs that contain built-in process definitions that cannot be 
modified. If you select one of the shipped processes, a limited version of the Process Editor displays only 
the workflow pane and properties pane; the Toolbox pane in the Process Editor is not displayed. 

Process Pane

The Process pane is located on the right side of the editor and displays the properties for the selected 
process, as well as selected activity, child process, or workflow logic element properties. 

Toggling the Process Editor View
In the Process Editor view, you can toggle the view between the process property pages and the activity 
view pages. To switch to the process properties, use one of the following options:

• Choose File > Process Properties.

• In the Workflow pane, click anywhere outside of the activities in the workflow.

View or Tab Description

Activities The Activities view displays the list of activities that are used to construct the 
process workflow. 

The activities that display depend on the adapters that are installed.

Processes The Processes view displays the list of defined processes that can be included 
in other processes. 

To add an existing process to a new process, drag and drop the appropriate 
process onto the workflow pane and define the criteria for execution of the 
process.

Logic The Logic view displays the list of workflow components that support or define 
the workflow logic and provide control over the execution of the workflow 
logic.

For information about configuring the logic components, see Adding Logic 
Components to a Process

Favorites The Favorites view allows you to choose commonly used items from all the 
other tabs. For example, if you often use AMQP activities and some of the core 
activities, you can add them all to your Favorites tab. Then, instead of having to 
locate the activities in the activities tab, they can be quickly located in Favorites 
tab. Similarly, if you have favorite processes or logic items, these can also be 
added to the Favorites.
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Expanding the Workflow View
To expand the workflow, use one of the following options:

• Choose View > Expand OR on the toolbar, click the Expand  tool.

Collapsing the Workflow View
To collapse the activities in the Workflow pane, use one of the following options:

• Choose View > Collapse OR on the toolbar, click the Collapse  tool.

Creating a Basic Process
Before You Begin

Identify any drag-and-drop objects in the toolbox that will be required by your new process.

Step 1 Choose Definitions > Processes, right-click and choose New > Process. 

Step 2 On the Process Properties pane, define the process properties.

Note Because Process Orchestrator no longer enforces uniqueness of object names, two content 
authors can create and ship automation packs or processes with identical names. As a result, a 
customer importing both automation packs will have two seemingly identical processes. To 
avoid confusion to the customer, use a namespace (a unique prefix) when naming objects. 
However, there are no technical issues with having duplicate process names.

Step 3 On the Toolbox pane, drag and drop the appropriate items onto the workflow pane (see Toolbox Pane).

Step 4 On the Properties pane, define the properties for each object selected on the workflow pane. The 
available property pages are determined by the selected objects.

Step 5 When all of the property pages are complete, click Save to save the process. 

Exiting a Process Without Saving

If you exit a process without saving first, the Save Changes confirmation dialog displays, asking you “Do 
you want to save the changes to this process?”

• If the process is already locked, the Save Changes dialog will ask you if you want to unlock.

• If it is not locked, it will prompt you to lock it.

Understanding the LOCK Mechanism

There may be multiple users using different consoles connected to the same Cisco Process Orchestrator 
environment. Therefore, it’s possible that you can edit the same process that someone else is working on 
it. In such a case, either one of you could overwrite the other person’s changes. To avoid situation like 
that, we provide the “LOCK” feature so you can lock the process and work on it. Others won’t be able 
to change the process until it is unlocked.
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Reverting Process Changes
This option is used when changes have been made to the process definition, but are no longer necessary. 
It deletes all changes made since you last saved the process. If you have saved the process and have not 
made any additional changes, no action will be taken.

To reverse process changes, choose File > Revert.

The process reverts back to the last saved version of the process. All new activities, components, and 
other changes are removed from the process definition.

Selecting the Target Type on Which a Process Acts
Process definitions control the target types on which they act. This selection supports inheritance. 

Step 1 Open the process in the Process Editor (see Accessing the Process Editor).

Step 2 Click the Target tab, then click the target types on which this process can run.

For example, assume that an SQL Server 2008 type provides a more specific implementations of an SQL 
Server Database through inheritance. All process that can run on an SQL Server Database run against a 
SQL Server 2008; a SQL Server 2008 “is a” SQL Server Database.

To view the processes that run on a given target type or target instance:

Step 1 Choose Definitions > Target Types, highlight a target type, right click and choose Properties.

Step 2 Click the Processes tab. The list shows the processes that can be executed against this target type.

Adding an Invocation of an Existing Child Process
Before an existing process is available in the Processes pane of the Process Editor and can be used in 
another process' workflow, the Started by Parent Process trigger must be defined in that existing process.

Before You Begin

• Confirm that the process you want to invoke includes the trigger, Started by Parent Process.

Step 1 Choose Toolbox > Processes, then highlight and drag the appropriate process to the Workflow pane. 

Step 2 On the [Child Process Name] Properties property sheet, click the General tab and modify the general 
property information.

Step 3 Click the Target and Credentials tabs and modify those properties as needed.

Step 4 Click the Inputs tab in the [Variable Name] field and modify the parameters for executing the child 
process. If the process does not have any input variables, the page will be blank.

Step 5 Click Save  to save the child process definition.
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Adding Variables to a Process
You can assign variables to the process when you use something multiple times. For example, if there is 
a person who must always be first approver, you can create a variable with the details of the person so 
you don’t have to re-enter the email address in the activity properties; you simply reference the variable.

Step 1 On the Process Properties pane, click the Variable tab.

Step 2 Click New > [Variable Name] to create a variable for the process and specify the appropriate information 
to create the variable.

Step 3 Click OK to close the dialog box.

Working with Target Reference Variables
A target reference variable is, simply, a variable that references a target. For example, assume you have 
a Windows target. If you then want a variable to point to that Windows target, you would create a target 
reference variable.

Here’s an sample scenario: You might use a Target Reference Variable for a process that has activities 
(such as, “Select From SQL Server”) that need run in a different target other than the one included in the 
process. For example, you might create a process that runs in a “VM target” or an “Open Stack Sever 
Target.” But at some point in the work flow, an activity will call the “SQL Server Database Target.”

So, could run a process against a target reference variable, or an activity within the process, or optionally, 
you don’t have to run any process against it at all. 

To create a Target Reference Variable, follow the steps below:

Step 1 Select Definitions.

Step 2 Right-click Global Variable.

Step 3 Select New > Target Reference Variable.

Step 4 Create or modify a Target Reference Variable, as needed.

Step 5 Save the variable.

Note You can now use this variable when creating a new process. See Creating a Basic Process for 
more information.
5-6
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 5      Authoring Processes
  Authoring Task Activities
About the References Dialog

The References dialog is where you can view the references for the selected variable. This allows you 
to find all references to a particular process variable in a workflow. It locates all the references to the 
variable within the workflow and provides the paths to those nodes.

To access this dialog, you follow this path:

Step 1 Go to Process Properties.

Step 2 Select the Variables tab.

Step 3 Right-click on the variable you are interested in.

Step 4 Select Find References.

Step 5 Review the list of nodes that reference the associated variable, as needed.

Step 6 Click OK or Close to close this dialog.

Note To see additional information on the associated references for a particular variable, select the 
reference and then click the Properties button before closing this dialog.

About the References Properties Form

When you click the Properties button on the References dialog, this Reference Info dialog displays, 
showing you the following information for the selected variable:

– Name

– Type

– Path

To close the Reference Info dialog, click OK or Close.

Authoring Task Activities
Task activities allow the creation, manipulation, and deletion of tasks within process workflows. They 
allow processes to interact with task records.

There are two primary types of tasks: 

• IT process records tasks include the alerts, incidents, and change requests. For more information, 
see IT Process Records.

• Human interaction tasks are steps in a workflow where a human needs to take action. For more 
information, see Human Interactions.

Authoring Task Activities
A process workflow consists of one or more activities that can be executed by the product. An activity 
definition contains actions and any other information required for the product to execute it.

To add an activity that creates a new task or acts on an existing task within a process workflow:
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Step 1 In the Process Editor, choose Toolbox > Tasks, choose the appropriate activity, then drag and drop the 
activity onto the Workflow pane.

• Use IT Records activities to create workflows that handle basic IT functions. To access these 
activities, choose Toolbox > Tasks - IT Records > [Activity Name].

• Use user interaction activities to create workflows that handle functions that require human 
interaction. To access these activities, choose Toolbox > Tasks - User Interactions > [Activity 
Name].

Step 2 Click the General tab and enter the required information.

Step 3 Click the Automation Summary tab to define the properties specific to the activity, including:

• Automation summary style sheet—Select the type of template to be used for the automation 
summary. 

– Table of Configuration Properties

– Situation Analysis Report (default)

• Include the following items—Select the activity or trigger/event, since events and triggers can be 
included into the automation summary as well, and specify the section of the automation summary 
to include the reporting details and whether the activity is the root cause of any issues that are 
detected.

– Name—Name of the activities that are included in the process

– Section—Name of the section of the automation summary where the data will be stored

– Root cause—Yes indicates the Is the root cause check box is checked

• Section—Specify the section of the automation summary template in which to export the data:

– SituationAnalysis—After a situation that requires action is identified, the state and diagnostic 
information is displayed in the Situation Analysis section of the automation summary.

– ContextAnalysis—After a situation is analyzed in context with other situations, the symptom 
and cause is displayed in the Context Analysis section of the automation summary.

• Is the root cause—List the activity or event at the top of the automation summary, or identified as 
the root cause of the problem.

• Last instance information only—Indicate that the automation summary must include only 
information for the latest execution of the activity instance.

This setting is only for activities that are inside the loop of a workflow component (While or For 
Each). If this setting is not selected, the automation summary will include information about all 
instances of activity, for all iterations of the loop.

Step 4 Click the Affects tab to specify the elements that trigger the selected target:

• This alert applies to the following target— Specify the affected target to be used in the activity.

• Process target—Use the process target as the affected target in the activity.

• Activity target—specify the affected target for a specific task activity.

– Activity target—Select the activity containing the target that will be used. Only task activities 
will display in the list.

– Target reference—Reference to a target of a specific type.

– Specific target group—Specify the affected target group that will be used.

To view the properties for the selected target group, click the Properties  tool. To create a 
new target group, click New > [Target Group].
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From the Choose a target using this algorithm drop-down list, specify which target will be 
chosen from the eligible target group members. 

Target Algorithms

Choose all targets that satisfy the specified criteria—Executes the process on all targets defined 
by the criteria specified in the Target Selection dialog box.

Choose any target that satisfies  the specified criteria—Executes the process on any targets 
defined by the criteria specified in the Target Selection dialog box.

Choose the target with the specified name—Executes the process on the member of the group 
specified in the Name to match text field.

Select SAP target with the specified System ID—SAP System runs target against the SAP 
System database connection

– Choose the target with the specified name—Runs the process on the member of the group whose 
name is specified in Name to match.

• This alert applies to the following configuration item—Specify the configuration item to be used in 
the activity

• Name—Name of the configuration item (IT component) to which the alert pertains. For example, 
the name of a database server that failed or the name of a specific job that failed.

• Type—Enter the appropriate configuration item type or select the type of ITIL configuration item 
(IT component) from the list which the alert describes. For example, the type of the specific 
application element that failed (Application Server, Database, Host, or User).

• This is a CMDB reference—Indicate that the true source of the CI is in the CMDB, so the 
configuration item properties reference a CMDB entry.

• Object key—ID for the specific record in the CMDB that contains the configuration item

• Object source—Name for the specific record in the CMDB that contains the target configuration 
item

• Affected services—IT Service affected by the alert or incident

• Affected organizations—Organizations that consume the IT service affected by the alert or incident

Step 5 Click the Assignment tab to modify individuals or groups of individuals assigned to the task and other 
assignment properties.

• Alert assigned to—User names assigned to the task

– Add—Click Add to launch the Select Identity dialog box to add a user name to the list.

Type the name of the assignee or to search for the assignee, click Browse to launch the Select 
User or Group dialog box to select the name of the person.

– Remove—Select the user name and click this button to remove the user from list.

• Alert priority—Indicates the priority of the task

• Set alert resolution due time period —Check the check box and select appropriate date the task 
should be completed from the drop-down calendar.

• Set alert expiration time period—Select the appropriate date the alert should expire from the 
drop-down calendar.

• Do not complete this activity until alert resolved—Check the check box if you do not want this 
activity to be complete until the alert is resolved.

Step 6 Click the Parameters tab to define parameters for a specific task.
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Step 7 Click the Duplicate tab and enter the time period the alert should be resolved if the alert properties match 
another alert.

Step 8 Click the Categories tab to:

– Assign a category to the task or change existing category assignments. 

– Check the Task should inherit process categories check box to inherit the categories assigned 
to the process.

Step 9 Click the External tab to specify the external incident management system information to support the 
synchronization between Process Orchestrator and the system that the customer is using. 

Step 10 Click the Web Form tab to apply a specific XSL transformation to the task XML. XSLT transformation 
is used to convert XML text to the HTML web pages used by the Web Console (see Chapter 9, 
“Performing Basic Console Tasks.”)

Step 11 Enter the information in the remaining tabs as necessary, then click OK to complete the task definition.

Step 12 Click Save  to save the activity definition.

The following table summarizes the available task activities.

Table 5-1 Summary of Task Activities

Task Activity Name Purpose

Assign Task Modify the list of assignees for a task. On this activity, tasks can be 
assigned to a user or group of users. Users can also remove current 
assignees from tasks.

Correlate Alert Watch for alerts raised before or after a process starts and that are 
related to data from the process, such as its trigger, input parameters, 
activity outputs, or other elements referenced from the process 
workflow.

See Defining the Correlate Alert Activity.

Create Alert Create alerts to reflect potential problems that a user may want to 
investigate and possibly diagnose the problem.

Find [Task] Find tasks that were created in the product and that match the specified 
criteria. See Viewing Find [Activity] Results.

Publish Task to Event Log Retrieve task information and publish it to the Cisco Process 
Orchestrator Tasks event log on the Process Orchestrator server.

Update [Task] Update the properties for a specific task. The properties for the tasks can 
be updated using their respective activities in the Toolbox pane.

To update the properties for a specific task, specify the task ID and 
select the property to update within the task.

Wait for Task to Enter State Wait for a task to match a specific state before the activity continues. 

If the task reaches a completed state without matching, or if the duration 
expires without matching a specified status, then the activity succeeds 
without matching.

See Viewing Wait for Task to Enter State Results.
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Defining the Correlate Alert Activity
Use the Correlate Alerts activity to check whether an alert occurred within a certain amount of time.

Step 1 In the Process Editor Toolbox, choose Tasks - IT records > Correlate Alerts and drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Alerts Criteria tab and enter the following information:

• Correlate alerts that occur within—Enter a value and select the time unit to indicate the length of 
time to wait before or after the process start time.

– Time unit – Enter the start time value in minutes or seconds

– Event occurrence – Determine whether the process start time is before or after the alert occurs

• Number of alerts to correlate—Select one of the following options to specify which alerts to wait 
for before the process continues:

– All alerts in the above time frame – Select this option to wait for all alerts that match the 
specified criteria before the process continues.

– Number of alerts – Select this option to wait for the specified number of alerts to occur before 
the process continues. Enter the number of alerts to wait for in the text field.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Task Properties That Task Activities Manipulate
The following table summarizes the types of changes you can make to task properties within a task 
activity in your process workflow.

Table 5-2 Summary of Common Actions Against Tasks That Can be Defined in a Process

Use Case Description

Modifying automation 
summary properties

Define the properties used to capture relevant diagnostic and state information about the process 
execution. 

On the activity property page, click the Automation Summary tab.

This tab is available only in these activities:

• Create Alert

• Update Alert

• Create Change Request 

• Update Change Request

• Create Incident

• Update Incident

Adding an assignee to a 
task

Change the assignee or other assignment properties for the activity.

On the activity property page, click the Assignment tab.
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Debugging Task Activities
The actions in this section demonstrate things you can do when viewing an activity that created a task 
or that manages tasks. For example, you might do them when you want to view a process workflow that 
actually ran and look at a specific task-related activity in the workflow. 

Viewing Correlated Alert Results

When the Correlate Alerts activity is launched, the alerts that were found by the activity are displayed 
from the Operations Workspace activity instance view. 

Step 1 Choose Operations > Activity Views. 

Step 2 Highlight the Correlate Alerts activity instance, right-click and choose Properties.

Step 3 Click the Correlated Alerts display-only tab to view the alerts collected by the Correlate Alerts activity.

Viewing Find [Activity] Results

Use the following steps to review the results of the query generated by the Find Alerts, Find Change 
Requests, and Find Incidents activities.

Step 1 On the Operations workspace, click the Activity Views folder. 

Step 2 Highlight the Find [Activity] activity instance, right-click and choose Properties.

Assigning duplicate 
criteria for a task

Define the criteria to indicate that the alert is a duplicate. If the alert is a duplicate, the new alert 
is automatically resolved as a duplicate and linked to the original alert as a related task. 

On the activity property page, click the Duplicate tab.

This tab is available only in these activities:

• Create Alert

• Update Alert

Removing an assigned 
duplicate property

Remove a task property from the duplicate criteria.

On the activity property page, click the Duplicate tab, then click Remove. One field will always 
remain. 

The Remove button removes the last property added to the list. For example, you cannot remove 
Parameter 4 without removing Parameter 5 from the list.

To keep Parameter 5, update Parameter 4 with the information from Parameter 5, then click 
Remove to remove Parameter 5 from the list. 

Adding a related alert Assign alerts that the incident originated from.

On the activity property page, click the Related tab, click Add then, enter the Alert ID or click 
the Reference tool to search for the alert property to add to the list.

Table 5-2 Summary of Common Actions Against Tasks That Can be Defined in a Process (continued)

Use Case Description
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Step 3 Click the Results display-only tab to view the list of alerts, change requests, and incidents queried by 
the Find activity. 

Viewing Wait for Task to Enter State Results

When the Wait for Task to Enter State activity is launched, the matching tasks that were found by the 
activity are displayed from the Operations Workspace activity instance view. 

Step 1 On the Operations workspace, click the Activity Views folder. 

Step 2 Highlight the Wait for Task to Enter State activity instance, right-click and choose Properties.

Step 3 Click the Result display-only tab to view the status values matched by the Wait for Task to Enter State 
activity.

The following information is displayed: 

Publishing Automation Summaries
An automation summary is a collection of data that summarizes the actions taken and data retrieved 
during the execution of the process. To publish an automation summary:

Step 1 Add a Create Automation Summary activity to the process workflow.

Step 2 Configure which activities from earlier in the workflow to publish in which sections of the document.

Technically, automation summaries are XML files that are published on a share or web server. The path 
or URL is then available to be linked from anywhere. This architecture makes them available for 
integration into virtually any context.

Automation Summaries are a key integration tool. For example, they can be placed in incidents in the 
Service Desk to reveal the analysis of the automation that was performed, or they can show how an 
incident was resolved.

Field Description

Result Values for the task state

• Unknown—Indicates activity is running or has failed to complete

• Timed Out—Activity timed out without matching

• Task Completed Without Matching—Task has reached a completing 
state that was not a state that was not included we were attempting to 
match on.

• Matched—Status was matched by the task

Matching Status Indicates the status that was matched
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Adding Logic Components to a Process
Insert process logic components into a process to support or configure the process logic and provide 
control over the process execution. 

The following table summarizes the types of logic components and when to use them.

To add logic components to a process:

Step 1 In the Process Editor, choose Toolbox > Logic, then highlight and drag the appropriate logic component 
to the Workflow pane. 

Step 2 On the component property pages, define the properties.

Step 3 Click Save .

Table 5-3 Summary of Logic Components

Activity Type Purpose

Completed Signal the completion of an activity and terminate the process. The 
component ends the workflow and sets the state of the workflow to 
Succeeded, Failed (Completed), or Failed (Not Completed).

Condition Execute one of the defined Condition Branches in a process. It checks 
conditions for each of the branches, in order from left to right, and 
executes the first Condition Branch whose condition is true.

Condition Branch Create a branch in the process and execute the branch only if the specified 
condition is met.

For Each Add the activities to the process that should be executed one time for each 
item in the target source.

Parallel Run two or more branches of a process simultaneously. The component 
consists of two or more sequential block components that execute their 
activities in parallel. 

Queue Create queues, which are like the lines going through Customs at an 
international airport. You can set the maximum allowed entries and 
maximum allowed in queue independently for each queue you set up. See 
Queue Resources for additional information.

Sequence Run activities in a block in a sequential order. 

Start Point Indicate points within a process workflow (in addition to the top of the 
process workflow) at which you can start the process. 

You will always be able to start the process from the beginning. However, 
if a process contains a Start Point component, then you can start the 
process from the location of the Start Point within the process.

To do so, from the Confirm Start Process dialog and check Start from 
start point. Then select your start point from drop down list. 

While Execute a sequence of child activities (contained in the While Block) that 
repeats as long as the specified condition is true.
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Adding Process and Global Variables
The variables feature provides a storage area for information that is used on a regular basis to avoid 
having to specify the same information in several places. Data stored in a variable can be altered to affect 
process execution behavior. 

The following sections describe how you can use variables in Process Orchestrator for a variety of 
purposes.

Activity Configuration
One of the most common uses of variables is to define activity configurations. Any field in an activity 
can refer to a variable value rather than an explicit value. For example, you can use a variable to:

• Specify the target as the machine where an event occurred

• Specify the start date of the process’ operations window as a parameter to an operating system 
command

• Specify a condition, such as a file that should not exist after a job is initially triggered by the arrival 
of that file where a prior activity should have deleted the file

Process Control Components
Processes can use variables to define the control components. For example, you can use a variable to 
define:

• A Conditional activity to look at the exit code of a prior activity

• A While Loop activity to loop until a query fails or loop for a number of times corresponding to a 
number of objects pulled from a query

Process Parameters
Variables can be parameterized so that a process definition can be vague enough to be reused in multiple 
places and the specifics can remain undefined so that they can be defined by the person or process that 
invokes the process or activity.

For example, a process called notify server owner might use a variable server for the name of the server 
that has a problem. The process retrieves the email address of the owner of the server and sends an email.

This process might be called from multiple places; a step in a server maintenance job fails, so the 
maintenance job populates the Server variable and invokes the notify server owner process. Another 
process might notify the server owner when a backup completes.

Formulas as Variable Values
You can specify a formula anywhere a variable value is used. For example, an operating system 
command's parameter might be formed from concatenating two variables' values or from parsing the 
output of a prior command.

Variables are used to store or pass a value between executions of a process or between steps within a 
single process.
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Common Use of Variables
The most common types of variables in Cisco Process Orchestrator are name variables and process or 
activity property variables.

Named Variables 

The most common use of variables is a name that has a changeable value. For example, you can use a 
global variable to store information used in processes such as:

• Locations of files and directories

• Email addresses

• Order numbers

• User names

Process or Activity Property Variables

• In a process or activity definition, you can refer to the process properties or the properties of a prior 
activity in the process. In this scenario, the properties of the process or activity may also refer to 
associated objects.

• One of the most common uses of variables is to define activity configuration. Any field in an activity 
with a Reference tool can refer to a variable value rather than an explicit value.

Status Tracking

Another common use of variables is to track state. For instance, you can use variables as a loop counters 
to store the number of times a loop has executed and know the current loop iteration running.

Summary Variables

You can also use a variable to build up a 'summary' message. For each thing event happens, you can 
append 'what just happened' to the variable. At the end of a process, the result will be the contents of this 
variable as an entire summary of the process.

Creating a Boolean Global Variable
Use the Boolean global variable to indicate the set of elements that should be true or false. The variable 
information is stored as a reference value that is used for multiple objects.

Variables are used to store or pass a value between executions of a process or between steps within a 
single process.

Step 1 Choose Definitions > Global Variables, right-click and choose New > Boolean Variable.

Step 2 On the General Information panel, specify the appropriate information, and click Next.

Step 3 On the Variable Value panel, specify whether the value should be interpreted as true or false and click 
Next.
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Step 4 Click Finish to complete the procedure.

Creating a Hidden String Global Variable
Hidden variables are used to specify protected secrets (such as HR information or security information, 
such as a password) when they are outside of the use cases of runtime users. For example, you might 
need to pass a password to a script. Runtime users in Process Orchestrator are fully protected, so no 
process can retrieve the password from any runtime user. Hidden strings provide an alternative for these 
use cases. Another example is a password that must be passed to a web service invocation.

When values for hidden variables are entered or displayed, their values are obscured. When they are 
stored, their values are encrypted so that they cannot be compromised by UI or database access.

A common use case is when a password is required to access some service. Typically there will be a 
target that is associated with the connection, such as a web service. Using service-oriented orchestration 
principles, you can either:

• Extend the existing target type to add a “password” property of a hidden text type.

• Create a new specialized target type that inherits from the target type and create a “password” 
property on the new target type. 

For example, say that you use a web target to connect to a Cisco Prime Network Services Controller 
REST API, and that the API requires a password. You could create a new “Cisco Prime Network Services 
Controller” target type which inherits from web target, then add a hidden text target property “password” 
on that type. You can then securely store passwords only for Prime Network Services Controller 
connections and not for all web services in general.

Caution In some cases, hidden strings can be passed outside Process Orchestrator. For example, a hidden text 
variable might be passed to a Windows script or a web service invocation. The variable value is passed 
in clear text outside the tool. Care must be taken in this regard. For example, if someone put a network 
sniffer on the web service call and you used HTTP rather than HTTPS for the call, the sniffer would be 
able to see the value. Process Orchestrator protects the value of the variable within the product itself and 
its logs, but it is the responsibility of the author and their IT department to protect these secrets outside 
of the product.

Step 1 Choose Definitions > Global Variables, right-click and choose New > Hidden String Variable.

Step 2 On the General Information panel, specify the appropriate information, and click Next.

Step 3 On the Variable Value panel, specify the security-sensitive string text for the value, and click Next.

Step 4 Click Finish to complete the procedure.

Creating a Numeric Global Variable
Use the Numeric global variable to define a variable containing a single whole or decimal number 
(positive and negative).

Variables can be used as a reference value used for multiple objects. They can also be used to store or 
pass a value between executions of a process or between steps within a single process.
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Step 1 Choose Definitions > Global Variables, right-click and choose New > Numeric Variable.

Step 2 On the General Information panel, specify the appropriate information, and click Next.

Step 3 On the Variable Value panel, specify the numeric value, and click Next.

Step 4 Click Finish to complete the procedure.

Creating a String Global Variable
Use the String global variable to define a variable containing a string of text.

Variables can be used as a reference value used for multiple objects. They can also be used to store or 
pass a value between executions of a process or between steps within a single process.

Step 1 Choose Definitions > Global Variables, right-click and choose New > String Variable.

Step 2 On the General Information panel, specify the appropriate information, and click Next.

Step 3 On the Variable Value panel, specify the string value, and click Next.

Note Check the Multiline check box to expand the text box and add more lines to the string.

Step 4 Click Finish to complete the procedure.

Creating a Table Global Variable
Use the Table global variable to define a table format that is used to store a set of records. Use the Table 
tab to define the table columns and rows.

The variable information is stored as a reference value that can be used for multiple objects. Variables 
are used to store or pass a value between executions of a process or between steps within a single process.

Step 1 Choose Definitions > Global Variables, right-click and choose New > Table Variable.

Step 2 On the General Information panel, specify the appropriate information, and click Next.

Step 3 On the Variable Value tab, define the values to be included in the cells of a table as well as add new rows 
and columns for the table, and click Next.

Note The table must contain at least one column before a row can be added.

• Rows—Click to modify the number of rows to be included in the table.

• Add—Adds a new row to the table

• Remove—Removes selected rows from table. The Remove option is enabled when the user selects 
one or more rows within the data table.

• Columns—Click to modify the columns to be included in the table.
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– Add—Launches the Table Columns Properties dialog box to allow the user to define the name 
and data type for the new column.

– Edit—Allows the user to modify the name for the new column. The Edit option is enabled when 
the user has one column or one cell in the table selected.

– Remove—Removes the selected columns from the table. The Remove option is enabled when 
the user selects one or more columns within the table.

Step 4 Click Finish to complete the procedure.

Creating an Identity Global Variable
Use the Identity global variable to store the value of a user identity.

Variables can be used as a reference value used for multiple objects. They can also be used to store or 
pass a value between executions of a process or between steps within a single process.

Step 1 Choose Definitions > Global Variables, right-click and choose New > Identity Variable.

Step 2 On the General Information panel, specify the appropriate information, and click Next.

Step 3 On the Variable Value panel, specify the user or group identity for the value, and click Next.

Step 4 Click Finish to complete the procedure.

Creating a Copy of a Global Variable
The copy option is used when the user wants to leverage an existing global variable to define a new 
global variable using existing properties. If the original global variable allows overrides, then the copied 
variable will all also allow global variables.

Step 1 Choose Definitions > Global Variables, highlight the appropriate global variable, right-click and 
choose Copy.

Step 2 On the Results pane, right-click and choose Paste.

A copy of the global variable is pasted into the Results pane.

Step 3 To rename the copied global variable or other properties, right-click and choose Properties.

Step 4 Modify the global variable name, as appropriate, and click OK to close the dialog box.
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Adding Targets and Target Groups
When you create a process, you must specify where you want the process to run. You can also specify 
that the process runs on a specific target or target group. 

Note When you move process definitions from environment to environment using automation packs, the 
specific targets will be different in the new environment. Therefore, if you plan to export your process 
in an automation pack, you will want to avoid references to specific targets. Instead, use a target group 
in your process definition, and place the environment-specific targets in that target group. Use direct 
target references only in environment-specific processes.

The target group can be defined once and reused in several processes. For example, you might have a 
database maintenance process that is scheduled to run every month on all database servers. Instead of 
scheduling the process multiple times to run on each database server, you can create a target group that 
includes all the database servers and schedule the process to run on all the servers at the same time.

If you choose to execute the process on a target group, you can further specify to run the process on all 
objects that are included in the target group, or run the process on a specific object within the target 
group.

Use Definitions > Target Groups to view the defined target groups. From this view, you can create new 
target groups, modify the properties of a target group, and delete target groups.

Viewing Members of a Target Group
Viewing members of a target group is important when debugging processes and environments.

Step 1 Choose Definitions > Target Groups, select the target group, right click and display properties for that 
group.

Step 2 Click the Members tab.

Step 3 Examine or view the targets considered to be part of the group by Process Orchestrator.

.

Creating a Target Group
You can create several types of target groups:

• A target type group specifies the type of target to be included in a target group as well as additional 
property-based criteria for a selecting target. 

• A virtual target group contains a collection of any type of target or target group that has been 
defined. 

• The Active Directory group types, Active Directory Group and Active Directory Organizational 
Unit (OU), are supplied by the Active Directory adapter. Membership in these group types is 
determined dynamically.

Step 1 Choose Definitions > Target Groups, right-click and choose New > [Target Group Type].

Step 2 In the New [Target Group Type] Properties dialog, enter the appropriate information for that group type.
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Step 3 Click OK to create the new target group.

Using a Target Group in Your Process
To use a target group in your process, define the target selection criteria.

Step 1 In the Process Editor, click the Target tab, click Execute on this target group, then click “...”.

Step 2 From the Select Target Group dialog, select one or more target groups, then click OK.

Step 3 You can choose to run the process on:

• All targets in this group

• All targets that satisfy the specified criteria

• Any target that satisfies the specified criteria

• A target with a specified name

Step 4 Enter the criteria as necessary.

Adding Conditions
The conditions assigned to an object within a process specify when an action is to be taken based on an 
evaluation of conditions that have been defined. 

You can access condition property pages from many places, including the Process Editor and the Task 
Rules dialog box. Using these property pages, you can add basic or compound conditions to an object:

• A basic condition is a simple variable condition that uses a variable to match against a value using 
a defined criteria operator. To add a basic condition, see Adding Basic Conditions to an Object.

• A compound condition combines conditions with AND and OR logic. To create a complex 
condition, see Adding Advanced Conditions to an Object.

Adding Basic Conditions to an Object
Use the Basic panel to create simple conditions using variables to match to operator criteria. When you 
edit a condition using the Basic panel, you are actually creating a compound condition where every 
subcondition is ANDed together. If there are no conditions, the condition will either be 'TRUE' or 
'FALSE' based on the user selection. If there are conditions, the condition is evaluated to either TRUE 
or FALSE.

Step 1 In the Process Editor, choose Toolbox > Logic, then drag a Condition or a Condition Branch into the 
workflow panel.

Step 2 On the [Object] property page or dialog box, click the Conditions tab.

Step 3 Under Conditions, click the True/False link to determine when the object should execute against the 
specified conditions.
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• Click True to indicate the conditions should always be satisfied before the object executes.

A single condition is listed by default and is set to True. If no other conditions are specified, this 
condition will remain and cannot be deleted by the user.

• Click False to indicate the object can execute if the conditions are never satisfied.

Step 4 Click the appropriate button to modify the condition properties used to execute the object.

• Click New to add a Properties pane to the condition. 

• Click Delete to remove the last Properties section in the list of properties.

Step 5 Update the following properties for each condition:

• Text field—Data for this field cannot be manually entered. Click the Reference tool to select a 
property variable to use as a condition.

• Operator—Select the operator to be used to evaluate the variable expression. The displayed 
operators depend on the selected property. 

• Value—Enter value for the property.

Step 6 Click OK to save the object.

Creating a Time Condition
The Time Condition is used to used to define conditions that evaluates to true on the days in the specified 
calendar and between the specified start and end time. Time conditions can be assigned to a calendar, 
process, activity, and a process trigger.

Use the following steps to create a time condition based on a defined calendar.

Step 1 On the Conditions tab, click New > Time Condition.

Step 2 In the Time Condition properties, modify the following properties.

• Start Time—Time the condition should begin. Enter or click the scroll button to modify the time.

• End Time—Time the condition should end. Enter or click the scroll button to modify the time.

Step 3 To modify the properties in the Time Condition dialog box, click anywhere on the line of properties.

Step 4 In the Time Condition dialog box, complete the following information, as necessary:

• Calendar—Name of the calendar that should trigger the process.

• Time Zone—Select the time zone that should be used for the condition

• Start Time—Time the condition should begin. Enter or click the scroll button to modify the time.

• End Time—Time the condition should end. Enter or click the scroll button to modify the time.

• Condition—Display-only. Properties used to define the time condition

Step 5 Click OK to add the condition to the Conditions tab.
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Creating a Component Licensed Condition
Use the Component Licensed Condition to be used to verify whether a product component is licensed. 
This condition can then determine the next step in the execution of the process. to be used as the 
condition under which the variable should evaluate as true.

Use the following steps to create a time condition based on a defined calendar.

Step 1 On the Conditions tab, click New > Component Licensed Condition.

Step 2 In the Component Licensed Condition properties, modify the following properties.

• Text field—Enter the license ID for the appropriate component.

• Value—Click the option to be used to evaluate the licensing expression.

Step 3 Complete the following information, as necessary:

• Component Id—Enter the license ID for the component to be evaluated in the condition.

• Comparison—From the drop-down list, choose the option to be used to evaluate the licensing 
expression.

– is licensed

– is not licensed

 

Creating a Variable Condition
The Variable Condition is used to specify a variable based on a variable expression to be used as the 
condition under which the variable should evaluate as true.

Step 1 On the Conditions tab, click New > Variable Condition.

Step 2 In the Variable Condition properties, modify the following properties.

• Text field—Data for this field cannot be manually entered.

• Operator—Select the operator to be used to evaluate the variable expression. The displayed 
operators depend on the selected property.

• Value—Enter value for the property.

The Variable Condition dialog box displays.

Step 3 Complete the following information, as necessary:

• Comparison Operator—From the drop-down list, choose the comparison operator to use for 
comparing the value of the selected variable and the expression.

Comparison Operators

– contains—Iterates through the contents of the collection and determines if the specified item 
exists (if this is a string collection, this is case-insensitive)

– contains (case-sensitive)—Iterates through the contents of the collection and determines if the 
specified item exists (same as above, but a case-insensitive version)
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– contains only—Iterates through the contents of the collection and determines if the only item in 
the collection is the specified item (if this is a string collection, this is case-insensitive)

– contains only (case-sensitive)—Iterates through the contents of the collection and determines if 
the only item in the collection is the specified item (same as above, but a case-insensitive 
version)

– does not match wildcard—Determines if the item does not match all items in the wildcard 
example

– is empty—Determines if there are items in the collection or not

– equals—Determines if the left side equals the right side (if this is a string comparison, this is 
case-insensitive)

– not equals—Determines if the left side does not equal the right side

– matches regular expression—Determines if the left side matches the regular expression 
specified on the right side. 

– matches wildcard—Determines if the left side matches the wildcard specified on the right side

– equals (case-sensitive)—Determines if the left side equals the right (this is the case-sensitive 
version of Equals for string)

– less than [<]—Determines if a value is less than another value

– more than [>]—Determines if a value is greater than another value

– equal [=]—Determines if a value is equal to another value

– not equal [>]—Determines if a value is not equal to another value

– greater than or equal [>=]—Determines if a value is greater than or equal to another value

– less than or equal [<=]—Determines if a value is less than or equal to another value

• Expression—Enter the expression to be evaluated against the boolean type variable to determine 
whether the condition is true.

The information in this field is case-sensitive and must be lowercase.

Adding Advanced Conditions to an Object
Use the Advanced panel to create a Cisco Process Orchestrator-based condition. You can define the 
properties of the conditions within the Advanced panel, or within the Properties dialog box.

When you edit a condition using the Advanced panel, the compound conditions are explicitly shown. 
This allows you to create complex conditional logic with the ability to nest any type of condition inside 
of a compound condition. To add a child compound condition in the advanced editor, choose New > 
Compound Condition.

The conditions specified on the Basic panel can also be configured on the Advanced panel because they 
transition to simple Process Orchestrator-level variable conditions. 

Step 1 In the Process Editor, choose Toolbox > Logic, then drag a Condition or a Condition Branch into the 
workflow panel.

Step 2 On the [Object] property page or dialog box, click the Conditions tab, then click Advanced. 
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If there are no conditions, the condition will either be 'TRUE' or 'FALSE' based on the user selection. If 
there are conditions, the condition is evaluated to either TRUE or FALSE.

Step 3 Click the appropriate button to modify the condition properties used to execute the object.

• Click New to add a Properties pane to the condition. 

• Click Properties, then click anywhere around the appropriate condition. After the area around the 
condition is highlighted, click Properties to launch the condition properties dialog box.

Condition properties can be modified on the tab or within the conditions properties dialog box.

• Click Delete to remove the last Properties section in the list of properties.

Step 4 After the first condition is added, choose the appropriate operator (AND or OR). The operator is set to 
AND by default.

Step 5 Click OK to save the object.

Deleting a Condition
A condition can have subconditions, and anywhere there is a condition you can delete a subcondition. 
Multiple condition equations can be included in a condition. Conditions are deleted only from the object 
upon which they reside. 

Deleting Conditions from Task Rules

Use the following steps when deleting a condition from a task rule. If you delete the task rule, that 
automatically deletes the condition.

Step 1 Choose Definitions > Task Rule, highlight an existing task rule, right-click and click Properties.

Step 2 Click the Conditions tab, highlight the appropriate condition, then click Delete.

Step 3 Click OK to save your changes.

Deleting Conditions from Triggers

Use the following steps when deleting a condition from a trigger. Delete the trigger from the process 
properties automatically deletes the condition.

Step 1 In the Process Editor, choose Toolbox > Processes, highlight the process, and choose Process > Edit.

Step 2 In the Process Properties pane, click the Triggers tab, highlight the appropriate the trigger, and click 
Properties.

Step 3 Click the Conditions tab, highlight the appropriate condition, then click Delete.

Step 4 Click OK to save the changes made to the trigger.

Step 5 Click Save  to save your changes.
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Deleting Conditions from a Logic Component

Use the following steps to delete a condition from a logic component such as a Condition Branch or a 
While Block. If you delete the logic component from the Workflow pane, that automatically deletes the 
condition. 

Step 1 In the Process Editor, choose Workflow, then the relevant logic component.

Step 2 Choose one of the following:

• Right-click and choose Delete to remove the logic component and all associated conditions. 

• Click the logic component’s, highlight the appropriate condition, then click Delete.

Step 3 Click Save  to save your changes.

Deleting Archive Conditions

Use the following steps when deleting a condition from an archive. If you choose another archive option 
from the process properties, that automatically deletes the condition.

Step 1 In the Process Editor, choose Toolbox > Processes, highlight the process, and choose Process > Edit.

Step 2 In the Process Properties pane, click the Options tab.

Step 3 In the Archival section, choose one of the following:

• Click Archive based on condition, click “...”, then use the Archive Condition dialog to delete the 
appropriate condition or subcondition.

• Check another Archival option and the condition will not be used; you do not need to “delete” it.

Step 4 Click Save  to save your changes.

Adding Target Types
Target types provide a way to define a service or other IT element that is not represented by any target 
type provided by an adapter. All new targets are created based upon an existing target type. 

Step 1 Choose Definitions > Target Types, right-click and choose New > Type.

Step 2 In the General panel, enter the basic properties for the new type, then click Next.

Step 3 On the Properties pane, specify the new properties for this type, then click Next.

Step 4 On the Relationships pane, specify the new relationships for this type, then click Next.

Step 5 On the Processes tab, specify the processes that are in the application, then click Next.

Step 6 Click Finish to create the new type.
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Related Topics

Target Types

Managing Processes
The following topics describe how to manage processes:

• Modifying Process Properties

• Modifying Activity Definition Properties

• Managing Process Workflow Revisions

• Starting a Process

• Canceling a Process

• Executing and Archiving Process Instances

Modifying Process Properties
Process definitions are modified in the Process Editor. With the appropriate rights from the Definitions 
view, the Process Editor is launched when accessing the process properties. Users with the appropriate 
rights can also modify processes in the top panel of any of the Process Views in the Operations View. 

When user rights are restricted, the Process Viewer is launched with the properties displaying a 
display-only view. 

Step 1 Choose Definitions > Processes, highlight the appropriate process, right-click and choose Edit.

Even when a process comes from an automation pack, some aspects of that process can still be updated. 
For example, you can:

• Disable/enable existing triggers

• Add additional triggers

• Disable/enable the process

• Change options (such as archive/resume options)

Note If you have been adding activities while editing a process, your focus will often be on an activity, 
so you will actually be seeing properties of the activity. To return to editing process properties, 
click in the white space outside of any activity. 

Step 2 Select the appropriate process property tab and modify the fields as necessary.

Step 3 Click Save  to save your changes. 
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Modifying Activity Definition Properties
Activities can only be modified in the Process Editor; modifying a process does not automatically 
modify an activity. Activity definitions are included in the workflow of a process definition, so the 
activity properties must be modified separately from the process properties. 

Step 1 Choose Definitions > Process, highlight the appropriate process, right-click and choose Edit. 

Step 2 On the Process Editor Workflow pane, choose the appropriate activity and modify the activity properties 
as necessary.

Step 3 Click Save, then click Exit to close the Process Editor.

Managing Process Workflow Revisions
Whenever you modify the workflow of a process definition in the Process Editor, a new revision is 
created for the process so that the historical versions are preserved. This allows users to easily restore a 
previous version or simply refer to the process definitions that were displayed at a certain point in the 
past. Using the Manage Workflow Revisions dialog box, you can:

• View the number of revisions made for the selected workflow during the specified created time

• Open a single or multiple read-only editors to view the changes made to the revisions; Opening 
multiple read-only editors at the same time helps you to compare the changes made to different 
versions

• Restore previous versions

Invalid references are checked before restoring the previous versions. For example, if you have a variable 
referenced in revision “A” and then deleted in revision “C”, an error message is displayed when you try 
to revert to revision “A”.

Note If you are not the author of the automation pack, all the revisions made prior to importing or applying a 
patch on the automation pack are displayed in Grey. You cannot restore these versions. However, you 
can view the changes by opening the ready-only editors. If you are the author, however, you can restore 
to any earlier revision, even ones made before the patch import or patch apply.

Viewing Workflow Revisions

Step 1 Choose Definitions > Process.

Step 2 Highlight the appropriate process, then right-click and choose Workflow Revisions.

Step 3 To view changes made to a specific version, select the version and click View.

Note You can view more than one version at the same time.
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Restoring a Workflow Revision

Step 1 Choose Definitions > Process.

Step 2 Highlight the appropriate process.

Step 3 Right-click and choose Workflow Revisions.

Step 4 To restore a previous version, select the version and click Restore.

Note Process properties are not restored. Process properties include process name, any defined 
variables, and triggers, and so on. Only the workflow itself is restored.

Starting a Process
You can manually start a process displayed on a Process View or the Process Editor under these 
conditions:

• You have the appropriate privileges.

• The process includes the Started by User trigger.

• The process is enabled (see Enabling and Disabling an Object).

Only one process can be manually started at a time. 

Note When a process is started manually, all conditions and triggers included in the process definition will be 
overridden.

Step 1 Choose one of the following:

• From a process view, highlight the appropriate process, right-click and choose Start Process.

• From the Process Editor, highlight the appropriate process, then choose File > Start or click Start 
 in the toolbar.

Step 2 The Confirm Start Process dialog box displays.

• If the process has any input variables, verify the variables associated with the process in the 
Parameters table. To update the variable, highlight the variable and click Edit to modify the value.

• To start a process from a specific starting point, check the Start from start point check box and 
then select the appropriate starting point from the drop-down list. The first activity after the 
specified starting point will run first.

• To specify a target that is different from the default process target, check the Override target 
(Target name) check box and select a target from the drop-down list.

• To create a new target for this process, click New. For additional information on targets, see 
Defining a Target.

Step 3 Click OK to confirm.

Step 4 The Start Process Results dialog box displays the progress of the process. To view the process workflow, 
double-click the process instance.
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Step 5 Click Close to return to the console.

Canceling a Process
If you have the appropriate rights, you can manually cancel any process that is currently running. To 
cancel a process, choose the Activity View Results, highlight the appropriate process, right-click and 
choose Cancel.

Executing and Archiving Process Instances
The Process Orchestrator provides settings that control:

• Whether the server saves the process state after the process completes. 

• Whether the process is restartable in case of a server restart or failover. 

Both the archival and resume options affect performance (how much data is saved into the database and 
how often). However, only the resume option controls whether the process is restartable. If the process 
is set to “archive” but “not resume”, it will save the data to the database but will not restart when the 
server restarts.

To specify the archival and resume settings for an existing process:

Step 1 In the Process Editor, choose Toolbox > Processes, highlight the process, and choose Process > Edit.

Step 2 In the process properties dialog, click the Options tab.

Step 3 In the Execution section, if you want the server to resume the process that is running when server restarts 
or fails over, click Resume execution if interrupted.

Step 4 In the Archival section, choose one of the archival options:

• Never archive any instances—The process instance is not stored upon completion

• Only archive failed instances—Only the failed process instances are stored upon completion

• Archive all completed instances—The process is stored upon completion

• Archive process instances (skip activity instances) only—Removes the activity instances from 
archival and stores the process instance upon completion

• Archive based on condition—The process instance is stored upon completion based on the selected 
condition. For example, ([Global Variables.Archive All Processes] = true)

• Cascade the setting to child process instances - The archival setting of a parent process is cascaded 
to the child processes

For example, if you have Run Antivirus Checks as the parent process, and then Check for Weekly 
Antivirus scan as the child process, the archival setting applied for the Run Antivirus Checks process 
is passed to the Check for Weekly Antivirus child process irrespective of the archival setting selected 
for this child process. Assume that Check for Weekly Antivirus scan process has a child process 
which in turn has another child process, the archival setting is applied to all the child processes 
irrespective of their respective archival settings.

Step 5 Click Save  to save your changes.
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Related Topics

• Adding Conditions

• Archiving Process Instances in an Automation Pack

• Chapter 15, “Managing High Availability and Resiliency”

Creating Processes as a Team
Multiple users might be working together to develop processes that they plan to group into an automation 
pack. The Process Locking feature is designed to enforce limits on access to a process. You can lock one 
or more processes from the Process Orchestrator console. Process Locking also includes these features:

• The UI provides a filter for the process definition view to view processes locked by me, or processes 
locked by someone else.

The columns for these views show whether a process is locked, who has the lock, and since what 
date / time the lock has been held.

• Locked processes:

– Are read-only to other users.

– Cannot be enabled or disabled by other users.

– Can be added or removed from automation packs by other users because this action does not 
modify the configuration of the process itself.

– That are locked by another user can be unlocked if you have Break Lock permissions (see 
Editing Locked Processes).

During the editing process:

• If User A attempts to edit a process that is currently locked by User B, User A receives a warning 
message and the process displays in Read-only mode.

• If User A is editing a process, which is then locked by User B, User A receives an error message 
when attempting to save the process.

• User A cannot delete a process that is currently locked by User B.

• A confirmation dialog displays if you close the Process Orchestrator and there are still locked 
processes remaining.

• The category membership of a locked process cannot be edited by other users.

Team content development is:

• A way for users to lock processes when they are developing content along with other process authors

• A new environment-wide setting which forces users to lock processes when editing them

Team content development is not:

• Locking other object types

• Source control or versioning support

• Being notified in real-time that someone has locked a process that the user is editing
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Enabling Team Process Authoring
The Environment Properties dialog box contains an option to enable/disable team process authoring on 
a server. If enabled, it:

• Locks and unlocks processes for editing

• Provides a server-wide setting that causes Edit process to become equivalent to Locking a process 
for editing

• Warns users when they attempt to close the console and still have processes locked for editing

Step 1 Choose File > Environment Properties.

Step 2 Check the Enable team development check box to enable team process authoring on this server, then 
click OK.

Viewing Process Views by Lock Status
To view locked processes, choose Definitions > Processes, choose Filter by Lock, then choose one of 
the options from the drop-down list.

Editing Locked Processes 
Use the Process Locking feature to edit locked processes:

Task Purpose

Lock a process Enforce limits on access to a process. Locked processes are read-only to 
other users.

Choose Definitions > Processes, highlight the appropriate process, 
right-click and choose Lock.

Unlock a process If you have locked a process, you can unlock that process from the Process 
Orchestrator console. 

Choose Definitions > Processes, highlight the appropriate process, 
right-click and choose Unlock.

If the process is locked by someone else, a message displays indicating that 
the process is locked by another user.

Break a lock If a process is locked by another user, and if you have Break Lock 
permissions, you can unlock that process. 

Choose Definitions > Processes, highlight the appropriate process, 
right-click and choose Advanced > Break Lock.
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Scheduling Processes
When defining a process, you can specify when the process will execute. You can execute a process 
based on a schedule. A schedule specifies one or more times of day, and is combined with a calendar that 
specifies which days the schedule should initiate the process.

The following topics include how to define a calendar, how to use calendars to define a schedule for a 
process, and how to use calendars in a condition:

• Authoring a Calendar

• Scheduling a Process Based on a Calendar

• Scheduling a Process to Run Only Under Certain Conditions

• Using a Calendar in a Condition

Authoring a Calendar
Calendars are reusable for schedules within many processes. For example, you can define a calendar for 
Saturdays. When defining a process that you want to run on Saturdays, you reference the Saturday 
calendar. Other examples include a calendar that includes weekends and company holidays when IT 
might perform scheduled maintenance, or the last week of a fiscal quarter when IT might exclude 
non-essential automation or deny change requests.

The calendars feature defines the calendar to be associated with a schedule, time, or condition. This 
feature simplifies:

• Reusing calendar definitions across processes

• Building complex calendars from other calendars

• Viewing the processes that run based on a specific calendar

Creating a New Calendar

Cisco Process Orchestrator ships with some predefined calendars for the most commonly-used 
scenarios. However, you can create your own calendar or copy and modify the predefined calendars 
based on your organizational requirements. 

Use the Definitions > Calendars view to display the defined calendars.

• Date List—Specify an explicit list of dates. The processes to which this calendar definition is 
assigned will execute on the specified dates in the calendar. You might want to use this type of 
calendar for processes that run on specific days of a specific month.

• Group—Specify a collection of other defined calendar types, such as inclusion of date list or a 
recurring calendar within the group calendar definition. The group calendar can contain defined 
recurring calendars, other group calendars, and date list calendars. You select the calendars to 
include or exclude in the group calendar definition. 

You can also add dates to or exclude dates from a group calendar.

• Recurring—Specify a starting date for the subsequent dates and recurrence frequency. You can 
specify the calendar to repeat on a daily, weekly, monthly, or yearly basis. 

Step 1 Choose Definitions > Calendars, right-click and choose New > [Calendar Type].

Step 2 On the [Calendar Type] property pages, define the properties.
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For example, if you want to define a recurring process that runs on the fifth day of each month, enter 
these values:

• Recurrence Pattern: Monthly

• Start date: (select a day of the month)

• Monthly Recurrence: Every 1 months

• On the following day(s): 5

Step 3 Click the Preview tab to display the list of dates that are included in the calendar. The calendar 
highlighting the dates displays on the right side of the page. 

Step 4 Click OK to close the dialog box.

Creating a Recurring Calendar

A recurring calendar has a specified start date, time period, and duration for when the process repeats 
execution.

Use the Daily Recurrence calendar to specify the start and end date for a recurring calendar and the 
number of days.

You can specify the calendar to repeat on a daily, weekly, monthly, or yearly basis.

Note Use commas to separate multiple dates.

Related Topics

• Creating a Daily Calendar

• Creating a Weekly Calendar

• Creating a Monthly Calendar

• Creating a Yearly Calendar

Creating a Daily Calendar

The Daily Recurring calendar specifies the start and end date for a daily recurring calendar and the 
number of days in the daily recurrence cycle.

Step 1 Choose Definitions > Calendars, right-click and choose New > Recurring Calendar.

Step 2 Click the General tab and enter the required information.

Step 3 Choose Recurrence > Recurrence Pattern > Daily.

Step 4 Select one of the following options to indicate how often the recurrence repeats:

• Every [ ] day(s)—Enter the number of days the recurrence is to repeat. 

For example, to have the recurrence repeat every other day, enter 2 in the text field.

• For every [ ] day period, on the day(s)—Enter the number of days the recurrence cycle is to repeat 
or click Select to select the specific days within the day period from the Select Days dialog box.
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For example, to have the recurrence to repeat every 7 days on the first and last day of this time 
period, enter 7 in the text field and then click Select to select Day 1 and Day 7 on the Select Days 
dialog box.

Creating a Weekly Calendar

Use the Weekly Recurrence calendar to specify the start and end date for a weekly recurring calendar 
and the number of weeks in the recurrence cycle.

Step 1 Choose Definitions > Calendars, right-click and choose New > Recurring Calendar.

Step 2 Click the General tab and enter the required information.

Step 3 Choose Recurrence > Recurrence Pattern > Weekly.

Step 4 Enter the number of weeks of the recurrence cycle.

Step 5 Check the check boxes for the day(s) of the week the recurrence should occur. 

For example, to have the recurrence repeat every week on Monday and Friday, enter 1 in the text field 
and check the Monday and Friday check boxes.

Creating a Monthly Calendar

Use the Monthly Recurrence calendar to specify the start and end date for a monthly recurring calendar, 
and how often it repeats.

Step 1 Choose Definitions > Calendars, right-click and choose New > Recurring Calendar.

Step 2 Click the General tab and enter the required information.

Step 3 Choose Recurrence > Recurrence Pattern > Monthly.

Step 4 Enter the number of months in the recurrence cycle.

Step 5 Use one of the following methods:

• On the following day(s)—Select this option to specify which day(s) the recurrence is to repeat. 

– In the text field, enter the appropriate numeric date(s) of the month. 

– Click Select to select the days from the Select Days dialog box. 

For example, to have the recurrence repeat every day within the month, enter 1-31 or on the Select 
Days dialog box, select Day 1 through Day 31.

• For the specified week(s)—Select this option to specify which week(s) and day(s) of the week the 
recurrence is to repeat. 

– In the text field, enter which weeks the recurrence is to repeat. 

– Click Select to select the days from the Select Days dialog box. 

– Under On the following day(s), check the check boxes for the days of the week the recurrence 
should occur. 
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For example, to have the recurrence repeat every week within the month, enter 1-4 or on the Select 
Weeks dialog box, select Week 1 through Week 4.

Creating a Yearly Calendar

Use the Yearly Recurrence calendar to specify the start and end date for a yearly recurring calendar and 
how often it repeats.

Step 1 Choose Definitions > Calendars, right-click and choose New > Recurring Calendar.

Step 2 Click the General tab and enter the required information.

Step 3 Choose Recurrence > Recurrence Pattern > Yearly.

Step 4 Click Select to select the months from the Select Months dialog box. 

For example, to have the recurrence repeat every month within the year, enter 1-12 or in the Select 
Months dialog box, select Month 1 through Month 12. 

Step 5 Use one of the following methods to specify the days within the selected months the recurrence should 
repeat:

• On the following day(s)—Select this option to specify which days of the months the recurrence is 
to repeat.

– In the text field, enter the appropriate numeric dates.

– Click Select to select the days from the Select Days dialog box. 

For example, to have the recurrence repeat every day within the month, enter 1-31 or in the Select 
Days dialog box, select Day 1 through Day 31.

• On the following month(s)—Select this option to specify which weeks and days of the month the 
recurrence is to repeat. 

– From the first drop-down list, select the appropriate week of the month (First, Second, Third, 
Fourth, Fifth, Last).

– From the second drop-down list, select the appropriate day of the week. 

For example, to have the recurrence repeat the first Monday of every month that is specified, select 
First and Monday.

Scheduling a Process Based on a Calendar

Step 1 In the Process Editor, choose Toolbox > Processes, highlight the name of the process you want to 
schedule, then choose Process > Edit.

Step 2 In the Process Properties pane, click the Triggers tab, then choose New > Schedule from the drop-down 
list.

Step 3 In the Schedule Properties dialog, choose an existing calendar from the Calendar drop-down list, or 
click New to create a new calendar (see Authoring a Calendar).

Step 4 Define any additional required properties. For example:
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• To define a recurring process that runs every 5 minutes, enter the Start Time (when the process 
should run on the days included in the selected calendar), the Number of times to run the process, 
and the Time Interval.

• To schedule a process to run based on an equation evaluated at run time, see Scheduling a Process 
to Run Only Under Certain Conditions.

Step 5 Click OK, then click Save  to save your changes.

Scheduling a Process to Run Only Under Certain Conditions
Using the Conditions tab in the Properties dialog, you can schedule a process to run based on an equation 
evaluated at run time. The process will be run only if the specified conditions are met.

Step 1 In the Process Editor, choose Toolbox > Processes, highlight the name of the process you want to 
schedule, then choose Process > Edit.

Step 2 In the Process Properties pane, click the Triggers tab, then choose New > Schedule from the drop-down 
list.

Step 3 Click the Conditions tab. 

• Use the Basic panel to create a simple variable condition using a variable to match to operator 
criteria. For example, you can insert a variable reference based on a schedule value such as the 
schedule name or the local time. Or click Show advanced properties to see addition variable 
references.

• Use the Advanced panel to create a more complex condition. You can define the properties of the 
conditions within the Advanced panel, as well as within the Properties dialog box.

For more information about using conditions, see Adding Conditions.

Step 4 Define any additional required properties, then click OK.

Step 5 Click Save  to save your changes.

Using a Calendar in a Condition
Calendars are “time” conditions that evaluate to true on the days in the specified calendar and between 
the specified start and end time. For more information about conditions, see Adding Conditions.

Step 1 In the Process Editor, you can:

• Add a condition to a process by choosing Toolbox > Logic, then drag a Condition or a Condition 
Branch into the workflow panel.

• Edit an existing process by choosing Toolbox > Processes, highlight the name of the process, then 
choose Process > Edit.

Step 2 In the Properties panel, click Advanced > New > Time Condition.

Step 3 Choose one of the calendars from the drop down list and adjust the start and end times as needed.
5-37
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 5      Authoring Processes
  Scheduling Processes
Step 4 Click Save  to save your changes.
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C H A P T E R 6

Authoring Categories

Process Orchestrator processes, tasks and several other elements of the functional model can be placed 
into categories. Categories in Process Orchestrator work just like Microsoft Outlook categories with 
respect to tagging objects for grouping in the UI. Objects such as processes can be in multiple categories. 
For example, a process can be both a network best practice and a security best practice.

The Categories feature provides a way to organize your processes based on your organizational or 
functional requirements. Cisco Process Orchestrator ships with predefined categories but provides the 
functionality for you to create your own business-specific categories. When creating a process, you can 
assign the process to a category. You can also add other categories to a category to create a hierarchy.

The following sections provide information about working with categories:

• Creating Categories

• Adding Objects to a Category

• Viewing Process Properties from the Members Tab

Creating Categories
Categories can be used to organize your processes based on your business-specific requirements. Use 
the Definitions > Categories view to create a new category and add members to the category. You can 
also add members to a category when defining a process.

For additional information about defining a process, see Chapter 5, “Authoring Processes.”

Step 1 Choose Definitions > Categories, right-click and choose New > Category. 

Step 2 In the New Category Properties property sheet, update the properties for this category, then click OK.

See also

Adding Objects to a Category

Viewing Process Properties from the Members Tab
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Adding Objects to a Category
You can choose the objects (or create new objects) to be included as members of a category. Both 
processes and categories can be included as members of a category.

Note The category membership of a locked process cannot be edited by other users. For more information 
about locked processes, see Creating Processes as a Team.

Step 1 Choose Definitions > Categories, select a category, right-click and choose Properties.

Step 2 Click the Members tab, then click Add.

Step 3 In the Objects available for category membership dialog box, use one of the following methods to select 
objects:

• If the appropriate objects are listed under Select Category Members, choose the appropriate 
categories or processes to be included in the category, and click OK.

• If the appropriate objects are not listed, click one of the following to create a new object, and click 
OK: 

– New > Categories—Define the properties of a new category 

– New > Processes—Define the properties of a new process. 

The new object displays in the Select Category Members list. Highlight the new object and any other 
objects, as necessary. The selected items display on the Members tab. 

Step 4 Click OK to close the dialog box and complete the procedure.

Viewing Process Properties from the Members Tab

Step 1 Choose Definitions > Categories, select a category, right-click and choose Properties.

Step 2 Click the Members tab. The processes and categories in the selected category are displayed.

Step 3 To view the properties for a process or category in that list, select the object, right-click, and choose 
Properties. 
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Advanced Authoring Concepts

Cisco Process Orchestrator provides integrations with various technologies. Although it supports 
numerous types of integrations, at the core Process Orchestrator provides the individual steps that make 
up the workflows in processes; these are called activities. For example, Process Orchestrator provides:

• A set of String activities that you can use to manipulate string text and characters. 

• A set of Table activities that you can use to modify the format for existing defined table variables. 
The available table variables can be defined as either a global or process variable. 

• A Set Variable activity that you can use to place a collection of bits in a Process Orchestrator 
number.

• Knowledge base articles provide information to help understand the results of an activity, including 
a summary of what has occurred, the possible cause of the result, and suggested actions to take to 
resolve issues with an activity. 

Note that:

• Modifying a process does not automatically modify an activity. Activity definitions are included in 
a process workflow and the activity properties must be modified separately from the process 
properties. 

• Activities can only be modified in the Process Editor. With the appropriate rights from the 
Operations view, the Process Editor is launched when accessing the process properties. 

• When user rights are restricted, the Process Viewer is launched with the properties displaying a 
display-only view after determining that the user cannot edit the activity.

The following topics describe these activities:

• Using String Activities

• Using Table Activities

• Using Core Activities

• Authoring Knowledge Base Articles

Related Topics

For instructions about inserting a variable in an activity, see Inserting Reference Variables.
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Using String Activities
You can use String activities to search, replace, and modify string content in the objects within Process 
Orchestrator. For example, you can:

Activity Type Purpose

Find String Search for specific content in a string. 

Replace String Replace specific content substrings in a string. 

Split String Split a string into multiple parts around matches of the given delimiter or 
delimiters.

String Escape Specify characters that must be escaped within a string so that the string 
can be inserted into messages or file names.

String Lowercase Lower the text case in a string

String Uppercase Capitalize the text case in a string

Substring Return part of a string starting with the characters in the start position and 
ending with the character in the specified end position. For example:

Input string = dictionary

Start position = 4

End position = 6

Dictionary

0123456 <- using 0 as the starting point

Positions 4 through 6 yield ‘ion’

Trim String Trim characters from the content in a string. When no character is 
specified, the activity will trim all leading and trailing whitespace 
characters, including empty lines at the beginning and at the end.
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Using Table Activities
You can use Table activities to modify the format for existing defined table variables.

Note Any boolean and numeric values that are used by the Table activities in the product are not localized. 
Numbers use [ . ] for the decimal format regardless of the regional and language options. Boolean values 
for substitutable boolean must be true or false regardless of the installed language.

For example, you can:

Table 7-1 Sample Table Activities 

Activity Type Purpose

Add Row to Table Append new rows to a table variable. The row is added to the end of the 
table. 

This activity will not work on tables that are outputs of other activities. 

Analyze Table Summarize and analyze data in a table variable or property using basic 
aggregation functions. 

Highlight Row Highlight selected rows of a table variable. Highlighted rows can only 
be displayed in an automation summary. Therefore you will not see the 
highlighted rows in Process Orchestrator unless you are viewing the 
automation summary.

Read Table from Text Read a comma-separated value (CSV) string variable and convert the 
text into a table with a specified set of columns. 

Read Table from XML Read an XML snippet and convert it into a table with a specified set of 
columns. For example:

Row XML Element Name:

MyRow

Columns to read:

Name String
Age Integer

Source XML:

<MyData>
<MyRow>

<Name>Jeff</Name>
<Age>32</Age>

</MyRow>
<MyRow>

<Name>Mark</Name>
<Age>31</Age>

</MyRow>
<MyRow>

<Name>Jay</Name>
<Age>30</Age>

</MyRow>
</MyData>

This produces a table with two columns (name, age), with three rows.
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Using Core Activities
Core activities are a set of items that span applications. For example, use the following activities to:

Remove Row from Table Remove one or more rows from a table variable based on specified 
criteria. 

This activity will not work on tables that are outputs of other activities.

Select From Table Query and select rows from a source table using specified criteria. The 
user can also determine the order of the rows selected as well as limit 
the number of rows displayed.

Set Table Variable Modify the value of a defined table variable. You must specify a name 
for the activity, choose the defined variable that you want to modify, and 
enter a new value for the table variable using a different table variable 
property.

The table variables used must match in their entirety, including the 
name of columns, number of columns, and the type of columns or the 
activity will fail.

Update Row in Table Update the selected rows of a table variable. The new rows become part 
of the variable being modified. You will not see the modified rows in the 
automation summary, but you can see the rows in the variable property 
pages in Process Orchestrator. 

This activity will not work on tables that are outputs of other activities.

Table 7-1 Sample Table Activities  (continued)

Activity Type Purpose

Table 7-2 Sample Core Activities

Activity Type Purpose

Calculate Date Calculate a new date/time value based on a specified base date/time and 
adjustments.

Format Date Convert the date and time into a string text format. For example:

Format string

yyyyMMdd hh:mm:ss tt

Original Date/Time

10/23/2009 10:23:00 PM

Result

20091023 10:23:00 PM

Correlate Process Event Check whether a process event occurred within a certain amount of time 
of another problem (see Creating Correlate Event Activities).
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Adding an XPath Namespace Definition
An XML namespace provides a way to avoid element and attribute name conflicts within an XML 
document. An XML namespace is uniquely identified by a Uniform Resource Identifier (URI) and is 
assigned a prefix (unique to the XML document) used for its element and attribute names.

To add an XPath namespace:

Step 1 In the Process Editor, choose Toolbox > Core Activities > XPath Query, then drag and drop the activity 
onto the Workflow pane.

Step 2 Choose the XPath Query tab, then choose Namespaces > New.

Step 3 In the XPath Namespace Definition dialog, enter the prefix and URI for the new namespace, then click 
OK.

Create Automation 
Summary

Generate an automation summary including data selected activities in a 
process. To generate the data output, choose the activity, then specify the 
section in the automation summary in which to output the data.

An automation summary is a collection of data summarizing the objects 
included in the process and the data retrieved by the processing of the of 
the objects. 

The share path specified in the Core Functions Adapter properties will be 
used when viewing the automation summary reports. 

Find Targets Among other use cases supported by this activity, you can find targets 
whose properties have certain values.

Insert Event Define the configuration properties to be used to insert one event into 
Process Orchestrator Reporting Database. 

Publish Metric Define the performance metric properties to be published into the Process 
Orchestrator Reporting Database and the Windows Management 
Instrumentation (WMI) provider.

The metrics are published under the root\TEO name space through the 
WMI class, TEO_PerformanceMetric.

XPath Query XPath queries navigate through XML documents and search through the 
document nodes. Use the XPath Query dialog box to enter the XPath 
properties to query from the source XML code. 

For additional information, see:

• Adding an XPath Namespace Definition

• XPath Query Example

XSL Transform Apply an XSLT transformation to a specific XML text. XSLT 
transformation can transform XML into plain text, HTML, or other XML.

Table 7-2 Sample Core Activities

Activity Type Purpose
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XPath Example Syntax

The following expressions can be used when selecting nodes in a path expression.

XPath Query Example

The following is an example of source XML.

The following example path expressions and related results are based on the preceding source XML. 

For additional examples, see http://www.w3schools.com/xpath/xpath_syntax.asp.

Path Expression Description

nodename Selects all child nodes of the named node

/ Selects from the root node

// Selects nodes in the document from the current node that match the selection 
no matter where they are

. Selects the current node

.. Selects the parent of the current node

@ Selects attributes

Example XML

<?xml version=”1.0” encoding=”ISO-8859-1”?>
<bookstore>
<book>
  <title lang=”eng”>Harry Potter</title>
  <price>29.99</price>
</book>
<book>
  <title lang=”eng”>Learning XML</title>
  <price>39.95</price>
</book>
</bookstore>

Path Expression Description

bookstore Selects all child nodes of the bookstore element 

/bookstore Selects the root element bookstore

Note If the path starts with a slash ( / ) it always 
represents an absolute path to an element.

bookstore/book Selects all book elements that are children of bookstore

//book Selects all book elements no matter where they are in the 
document 

bookstore//book Selects all book elements that are descendant of the 
bookstore element, no matter where they are under the 
bookstore element 

//@lang Selects all attributes that are named lang
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XPath Query Example 2

In the following example, the elements prefixed with xdc are associated with a namespace whose name 
is http://www.xml.com/books, while those prefixed with h are associated with a namespace whose name 
is http://msdn.microsoft.com/en-us/library/ms950779.aspx. 

For additional examples, see http://msdn.microsoft.com/en-us/library/ms950779.aspx.

Authoring Knowledge Base Articles
Knowledge base articles provide information to help understand the results of an activity, including a 
summary of what has occurred, the possible cause of the result, and suggested actions to take to resolve 
issues with an activity. Knowledge base articles can make automation summaries more usable, 
explaining how to use the information that is surfaced.

Knowledge base articles are referenced by specific activities and can be viewed in the following 
locations in Process Orchestrator: 

• Operations Workspace—When viewing activity instance properties, you can view the display-only 
properties of the associated knowledge base articles by selecting the Knowledge Base tab.

• Process Editor—You can reference a knowledge base article to an activity when defining the activity 
properties in the Process Editor.

• Automation Summary—All referenced knowledge base articles will display on the automation 
summary. 

The Definitions > Knowledge Base view displays the available knowledge base articles that can be 
assigned to a process activity or to a trigger. When Knowledge Base Articles is selected in the Navigation 
pane, the defined knowledge base articles display in the Results pane. 

Process Orchestrator ships with predefined knowledge base articles, or you can create your own 
knowledge base articles to associate with activities in the process. 

Example XML

<h:html xmlns:xdc=”http://www.xml.com/books”
        xmlns:h=”http://www.w3.org/HTML/1998/html4”>
 <h:head><h:title>Book Review</h:title></h:head>
 <h:body>
  <xdc:bookreview>
   <xdc:title>XML: A Primer</xdc:title>
   <h:table>
    <h:tr align=”center”>
     <h:td>Author</h:td><h:td>Price</h:td>
     <h:td>Pages</h:td><h:td>Date</h:td></h:tr>
    <h:tr alignment”>
     <h:td><xdc:author>Simon St. Laurent</xdc:author></h:td>
     <h:td><xdc:price>31.98</xdc:price></h:td>
     <h:td><xdc:pages>352</xdc:pages></h:td>
     <h:td><xdc:date>1998/01</xdc:date></h:td>
    </h:tr>
   </h:table>
  </xdc:bookreview>
 </h:body>
</h:html>
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To create a knowledge base article:

Step 1 Choose Definitions > Knowledge Base, right-click and choose New > Knowledge Base.

Step 2 On the Knowledge Base property pages, define the properties, including:

• Summary—A concise description of the issue.

• Possible cause—An explanation of the condition that may be causing the issue. If necessary, enter 
multiple possible causes so that all possibilities are investigated.

• Possible resolution—List of actions that can be performed to attempt to resolve the issue.

• Related information—Additional information that may be relevant to the issue.

Step 3 Click OK to close the dialog box.
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Monitoring Operations

The Operations workspace is used to monitor the processes that are scheduled to execute, view processes 
that are currently running, and verify that processes have successfully completed. The view also provides 
auditing information relating to system event history for actions that have occurred within Cisco Process 
Orchestrator and process information generated when the defined processes are executed.

The Getting Started > Operations view displays task shortcuts to view process instances, process 
instance activities, and the other system activity in the results pane. The following tasks can be 
performed from this view:

• Monitor Operations—Launches the Activity Views folder which includes the options to display 
information about the activities that are in progress, scheduled or have been completed.See 
Operations—Activity Views for more information. 

• View Auditing—Launches the Auditing view which displays the system event history for actions 
that have occurred within Cisco Process Orchestrator. See Operations > Auditing View for more 
information. 

• Define New Objects—Launches the Getting Started > Definitions view which displays the options 
for creating a new process and defining new objects to be associated with a process. See Getting 
Started > Definitions for more information.

• Launch Web Console—Launches the Cisco Process Orchestrator Web console to provide users with 
a web-based view of the scaled-back Operations workspace on the expert Cisco Process Orchestrator 
console.

The Operations workspace displays:

• The status of processes and activities executing, scheduled, or recently executed by the application. 

• Alerts, incidents, and approvals in the product.

• System messages about status and errors within the Process Orchestrator server or adapters.

The options provided by this workspace include:

Navigation Item Function

Getting Started Displays task shortcuts to view process instances, process instance 
activities, and the other system activity in the results pane.

For more information, see Filtering Views.

Search Work Displays the results of the query for processes and activities based on the 
specified filter options.

For more information, see Searching Tasks.
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The Process Views folder includes all the defined processes and their associated activity instances that 
are in progress, scheduled or have been completed. From this view, you can see detailed information 
about all processes that have been triggered, executed adhoc, or are scheduled for execution. 

You can review both process and activity instances in the Process Views folders when querying the 
properties and status of process instances. Each Process View has two separate results panes:

• The top results pane displays the process definitions for the selected view. This view also allows 
you, if you have the appropriate rights, to access the Process Editor to modify the configuration of 
the process, to start the process, and enable or disable the process.

• The bottom results pane is automatically filtered to show only the instances of the process whose 
definition is selected in the top panel.

The Definitions > Processes view displays all defined processes that are in the application. This includes 
all processes that have been authored in the Process Editor and the processes that have been imported in 
automation packs. 

Target Views Displays the defined targets and their associated process instances that 
are in progress, scheduled or have been completed.

For more information, see Monitoring Target Views.

Process Views Includes all the defined processes and their associated activity instances 
that are in progress, scheduled or have been completed.

For more information, see Monitoring Process Views.

Activity Views Includes a set of predefined views that displays information about 
processes, including the status of activities within the processes.

For more information, see Monitoring Activity Views.

Search Tasks Displays the results of queried tasks based on the specified filter option.

For more information, see Searching Tasks.

Search IT Records Displays only the alerts, incidents, and change requests created in 
Process Orchestrator. 

For more information, see Searching IT Records.

Task Views Displays all task activities and tasks that have been assigned to a specific 
user or group. Only users with administrative rights can create tasks 
from this view in Process Orchestrator.

For more information, see Monitoring Task Views.

Auditing Displays the system logs for system events that have occurred within 
Cisco Process Orchestrator.

For more information, see Monitoring Auditing Information.
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Monitoring Target Views
Target views allow you to view ongoing automation in the context of the targets or services on which it 
acts. You can filter the list of all targets to focus in on a specific type, or by the name of a target such as 
an Cisco Intelligent Automation for Cloud service request. After selecting a target, you can see the 
processes that act on that target type and all process activity related to that target. 

The Operations > Target Views folder displays the defined targets and their associated activity instances 
that are in progress, scheduled or have been completed.

Monitoring Target Information

Step 1 Choose Operations > Target Views > View All. 

From this view, you can see detailed information about all targets, regardless of whether processes have 
or have not been executed against these targets. This view contains the following information:

• The Target Process Actions pane (top right) contains items that perform specific actions associated 
with the target selected in the Targets pane. 

• The Target Activity pane (bottom) displays the processes that ran or are scheduled to run against the 
target selected in the Targets pane.

Step 2 Select a target (in the top pane) for which you are interested in viewing the target activity. The list of 
processes appears in the Target Activity pane.

Step 3 You can filter the results by process name, a range of dates, by a start or end period, by days to offset, 
by a specific time period, and so on.

Step 4 To view additional (read-only) information about a process, highlight it and use one of the following 
methods to launch the Process Viewer:

• From the Target Activity pane, double-click the appropriate process instance.

• From the Details pane, click any hyperlink (see Details Pane, page 2-10).

Monitoring Process Views
The Operations > Process View folders display all processes that have been started, scheduled to start, 
started by a trigger, or started ad hoc. Each Process view display can be filtered to display by the name, 
category, or column view. 

Use the Definitions > Processes View to display the defined processes.

Note To add, remove, or sort column headings on the display, see Configuring Columns.
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Monitoring Process Information
The Process View displays all the defined processes and their associated activity instances that are in 
progress, scheduled or have been completed. From this view you can view detailed information about all 
the processes that have been triggered, executed ad hoc, or are scheduled for execution.

Step 1 Choose Operations > Process Views, then choose one of the following options. 

Step 2 Select a process definition (in the top panel) for which you are interested in viewing the instances. The 
process information appears in the View Results pane. 

Step 3 Filter the results as necessary (see Monitoring Process Views, page 8-3).

Step 4 To view additional information about an instance, highlight it and use one of the following methods to 
launch the Process Viewer:

• From the View Results pane, double-click the appropriate process instance.

• From the Details pane, click any hyperlink (see Details Pane, page 2-10).

Viewing Process Instance Workflows
A graphical view of a process workflow can be viewed from the Process Views area after a process has 
been launched. The information displayed on the Process Workflow Viewer is display-only.

Step 1 Choose any of the four process views to display the process and activity instances in the Results pane.

Step 2 From the Process Instance results pane, use one of the following methods to launch the Process Viewer:

• Double-click the appropriate process instance.

• Highlight the appropriate process instance on the Process Views Details pane, then click any link in 
the General or Run Options tabs.

Process View Description

View Adhoc Displays all process or activity instances that were executed manually 
and are in progress, have successfully completed, or failed 

View All Displays all process, activity, and scheduled process and activity 
instances that are in progress, have successfully completed, or failed

View Scheduled Displays all process or activity instances that are in progress, have 
successfully completed, or failed and are also scheduled to execute 

View Started Displays all process or activity instances that were executed (manually 
or automatically) and are in progress, have successfully completed, or 
failed 

View Triggered Displays only processes that were “triggered” (not processes that were 
manually executed or scheduled).
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Step 3 From the Activity Instance results pane, highlight the appropriate process instance, right-click and 
choose Observe.

Canceling Running Process Instances
You can only cancel running process instances from the bottom View Results pane on any of the Process 
Views. You cannot cancel processes from the top Process results pane. 

Monitoring Activity Views
The Operations > Activity Views folders display processes and their associated activities that have been 
started, scheduled to start, started by a trigger, or started ad hoc. Each Activity view display can be 
filtered to display by the date/time of execution, category, or column view. 

From this view, detailed information is provided about all the activity instances that are started, running 
and scheduled to run. If you have the appropriate security rights, you can create and modify tasks from 
this view. 

Activity Views include a set of predefined views that display information about the status of activities 
within the processes. From this view, you can view activities that have been triggered, executed ad hoc, 
view all activities, and view all scheduled activities.

Certain activities display additional activity instance information. For example, there will be certain 
activities that generate information based on the defined properties of the activities. In those situations, 
the activity instance properties displayed from the Operations > Activity View will show the read-only 
configuration properties as well as the generated results of the configuration properties. 

Step 1 Choose Operations > Activity Views, then choose one of the following options:

The selected view displays in the Results pane.

Step 2 Use the Filter by [Object] drop-down list to display processes or activities according to its assigned 
category in the Results pane.

The default selection is <No Filter>. After the initial change to the selection, the last selected item 
displays.

Views Descriptions

View Adhoc Displays all process or activity instances that were executed manually 
and are in progress, have successfully completed, or failed during the 
selected time period 

View Scheduled Displays all process or activity instances that are scheduled to execute 
during the selected time period

View Started Displays all process or activity instances that are in progress, have 
successfully completed, or failed during the selected display time period

View Triggered Displays all process or activity instances that were triggered for execution 
(manually or automatically) and are in progress, have successfully 
completed, or failed during the selected time period 
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Step 3 Filter the results as necessary (see Monitoring Process Views, page 8-3).

Step 4 To view additional information about an instance, highlight it and use one of the following methods to 
launch the Process Viewer:

• From the View Results pane, double-click the appropriate process instance.

• From the Details pane, click any hyperlink (see Details Pane, page 2-10).

Modifying Activity View Format
To change an Activity View format, highlight an activity instance, right-click, and choose View > 
[Format]. Each of the activity views can display in one of these formats:.

Understanding Activity View Indicators
The process and activity views have certain indicators that provide status information.

Status Indicators

The State column displays the status of the individual process and activity. The following indicators 
definitions display in the Results pane.

Color Indicators

The colors associated with the individual activities determine the status of the process and activity 
instances. 

Activity View Description

Flat Displays all process instances and activity instances on the top-level 
with no expandable tree view.

Workflow Displays the process instances and only one workflow instance (even 
if it has run multiple times) in an expandable tree-view format.

Activity (Default view) Displays the process instances and all related activity instances (no 
matter how many times it has run) in an expandable tree-view format.

Status Description

Succeeded Process has completed successfully

Running Process is in progress

Failed (Not Completed) The process has failed and did not complete the process 
execution

Failed (Canceled) The process has been canceled manually

Indicator Description

Blue Process is in progress

Green Process has completed successfully

Red Process has failed and did not complete the process execution

Orange Process has stopped
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To customize these colors, choose Tools > Customize. For more information about customizing the 
color indicators, see Customizing the Fonts and Colors.

Filtering Views
You can filter the results by a range of dates, by a start or end period, by days to offset, by a specific time 
period, and so on.

Step 1 Choose Operations > [Operation] > [Views option]. 

Step 2 Use the Filter by [Object] drop-down list to display processes or activities according to its assigned 
category in the Results pane.

The default selection is <No Filter>. After the initial change to the selection, the last selected item 
displays.

Step 3 On the [Views option] subheader, choose the appropriate category and time period to display.

For example, you can filter the results by:

• Object (category, name, description, automation pack, trigger name or type, or lock option)

• Date range (from and to)

• Start time or end time period

Note To use the current time as the Start Time or End Time period in which the activities are 
displayed, do not make any changes to Time menu options.

To modify the start and end times, choose:

– Start—Default option uses the current time on the Console

– Back—Adjusts the number of hours that precede the current Console time

– Forward—Adjusts the number of hours ahead of the current Console time

• Current time period

The navigation arrows located on each side of the Calendar icon select the next day on the Back and 
Forward options on the Start Date and End Date submenu.

– The Back arrow chooses the previous day prior to the currently selected day on the Back 
submenu for the starting and ending dates. For example, if Yesterday is currently selected, then 
clicking the Back arrow changes the display selection to 2 days before today.

– The Forward arrow chooses the day after the currently selected day. For example, if Tomorrow 
is currently selected, then clicking the Forward arrow changes the display selection to 2 days 
after today.

• Calendar date

• A specific date

• Days to offset—Use the More option on the Before today and After today submenus to enter a 
specific number of days for the start date. Use Select Day Offset when the appropriate number of 
days to offset is not on the predefined list.

To specify days before the displayed value, select or enter a negative number.
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• Time period to offset—Use the More option on the Back and Forward submenus to enter the specific 
hours and minutes for the end and start time. Click Select Time Offset when the number of hours 
and minutes to offset is not on the predefined list.

To specify hours or minutes before the displayed value, select or enter a negative number.

Searching Work
The Operations > Search Work view displays the results of the query for processes and activities based 
on the specified filter options. The Search Work view displays all processes and activities that are 
scheduled to be performed during the selected display time period. 

On the Operations workspace, choose Search Work. 

Monitoring Scheduled Work

Step 1 Choose Operations > Search Work.

Step 2 To customize the information to be displayed in the Search Results table:

a. Click Customize Options. 

b. In the Select Search Filters dialog box, click the check boxes to the left of the appropriate options. 
If a check box remains unchecked, the results for that filter option will not display in the Search 
Results table. Click OK. 

Step 3 Filter the results as necessary (see Monitoring Process Views).

Step 4 To view additional information about an instance, highlight it and use one of the following methods to 
launch the Process Viewer:

• From the View Results pane, double-click the appropriate process instance.

• From the Details pane, click any hyperlink (see Details Pane, page 2-10).

Monitoring Task Views
Tasks allow a process to create an IT record or perform human interaction, and provide ownership and 
a lifecycle. Process Orchestrator enables the user to act on tasks within the operator console, which 
managers can use to set or change assignments to those on their staff. Assignment changes, state 
changes, and all other changes are audited, so you can keep track of exactly who did what in the system. 

The Operations > Tasks view displays all tasks or all tasks that have been assigned to a specific user or 
group. 

The Tasks display can be filtered to display by category, task type, and status. You can also decide which 
task view to display.
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From this view, detailed information is provided about all the alerts, incidents, and other tasks that are 
assigned, in progress, or have been completed. If you have the appropriate security rights, you can create 
and modify tasks from this view. 

Step 1 Choose Operations > Task Views.

Step 2 To access detailed information about a task view, click the Task Views folder and choose one of the 
following options. 

Step 3 On the Task Views Header, choose the appropriate filtering options to display.

Acting on Tasks
The following table summarizes some of the types of changes you can make to a task.

Task View Description

View Alerts Displays all alerts

View All Displays all tasks that are assigned, in progress, or 
have successfully completed

View Change Requests Displays all change requests 

View Incidents Displays all incidents

View User Interactions Displays all tasks that require user action

Table 8-1 Summary of Actions

Action Purpose

Changing a task state See Resolving a Task.

Adding a related task Related tasks could be duplicates of one another or the resolution of the 
task that depends on the solution of the existing task.

Choose Operations > Task Views, highlight the appropriate task, 
right-click and choose Properties > Related > Add.

Adding a option to the 
input request select 
question

Create options for the input request select question.

Assigning a category to a 
task

Choose Operations > Task Views, highlight the appropriate task, 
right-click and choose Properties > Categories.

For information about managing categories, see Authoring Categories

Assign a duplicate alert Indicate that the task is a duplicate of an existing task.

Choose Operations > Task Views, highlight the appropriate task, 
right-click and choose Properties > Related.
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Resolving a Task
Most users cannot resolve a task from the Process Orchestrator console because they do not have the 
rights to modify the task. In general, the user will launch the web console (see Resolving a Task) when 
attempting to resolve a task.

Step 1 Choose Operations > Task Views, highlight the appropriate task, right-click and choose one of the 
following: 

• Resolve 

• Select a choice 

Step 2 Review the details of the task.

Step 3 From the Status drop-down list, choose the appropriate status for the task resolution.

Step 4 In the Add Notes text box, enter any notes related to the task resolution or status update.

Step 5 Click Submit to resolve the task.

The Task details page is updated and displays the user name of who resolved or updated the task.

Searching Tasks
The Operations > Search Tasks view displays all tasks created or defined in Process Orchestrator. The 
results of the query are based on the specified filter options. The following topics describe the available 
search options:

• Customizing the Search Tasks Header

• Filtering Search Results

• Filtering Display by [Objects]

Modifying the assignment 
properties for a task

Change the assignee or other assignment properties for the task. This 
includes taking ownership of the task, if necessary.

Choose Operations > Task Views, highlight the appropriate task, 
right-click and choose Properties > Assignment > Assigned to

Adding parameters for a 
task

Adding parameters for a task. A single task can include up to ten 
parameters.

Choose Operations > Task Views, highlight the appropriate task, 
right-click and choose Properties > Parameters > Add.

Table 8-1 Summary of Actions (continued)

Action Purpose
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Customizing the Search Tasks Header
Use the Select Search Filters dialog box to customize the query header options. If the check box to the 
left of the option remains unchecked, then the filter option will not display on the designated Search 
header.

Step 1 Choose Operations > Search Tasks > Customize Options. 

Step 2 In the Select Search Filters dialog box, choose one of the following options, then click OK.

• Task Assignee—Displays the list of task assignee options

• Created Time—Displays the time options to determine the time period for which item to display

• Modified Time—Displays the time options to determine the time frame for which tasks to display

• Task Status—Displays the available status values to filter

Filtering Search Results
Use the Filter pane in the Task Views header to display selected tasks in the results pane. 

Step 1 Choose Operations > Search Tasks.

Step 2 The Filter by drop-down list in the Task Views header contains several options that can be used to filter 
the results. Enter the search query information, then click Search to query the tasks. 

Filtering Display by [Objects]
Use the Filter by [Object] drop-down list to display processes or activities according to its assigned 
category in the Results pane.

The default selection is <No Filter>. After the initial change to the selection, the last selected item 
displays.

To filter the display, choose the appropriate object from the Filter by drop-down list:

• Category—Choose the appropriate category from the list

• Name—Enter the names of process or activity

• Description—Enter description of process or activity

• Automation Pack—Enter the name of the automation pack for the process

• Trigger Name—Enter the name of a trigger

• Trigger Type—Choose a trigger type from the list

• Lock—Choose one of the following Lock options:

– Locked by me

– Locked by another user

– Locked by anyone
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– Unlocked

The results display in the Results pane. 

Defining Task Rules
Task rules provide a list of rules that act on new tasks or task changes to handle cases such as 
assignments, changing alert or incident severities, or setting customer-specific categories on tasks. 

Whenever a task is created, Process Orchestrator goes through the settings and conditions of each task 
rule that is listed and enabled. If the conditions and settings in the rule are satisfied, the task rule is 
executed. Task rules are executed according to the order in which they are displayed in the list.

Before You Begin

By default, only users with administrative rights can create and update task rules from the Definitions > 
Task Rules view. However, the security settings can be changed, if necessary, by the Process Orchestrator 
administrator.

Step 1 Choose Definitions > Task Rules, then on the toolbar, choose New > [Task Rule].

Step 2 On the [Task Rule] property pages, define the properties.

Note The property pages might display as display-only if the task rule definition is shipped as part of 
the product or you do not have the appropriate rights.

• Click the General tab and enter the required information.

• Click the Task Types tab to select the task types to be executed by the rule. 

• Click the Conditions tab and click the appropriate panel to indicate the type of condition equation 
to be used to trigger the task rule. 

• Click the Assign tab and specify the assignees for task rule. 

Step 3 Click OK to close the property sheet.

You can create the following task rules: 

Table 8-2 Summary of Available Task Rules

Task Rule Purpose

Assign Task Rule Specify the users to be assigned to the task after the task rule has 
executed.

To modify this rule, click the Assign tab on the [Task Rule] Properties 
property sheet.
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Adding Conditions to a Task Rule
Use the following steps to add a condition to a task rule.

Step 1 Choose Definitions > Task Rules, highlight the appropriate task, right-click and choose Properties. 

Step 2 On the [Task Rule] Properties property sheet, click the Conditions tab, then click the appropriate panel 
to indicate the type of condition equation to be used to trigger the task rule (see Defining Task Rules). 

Step 3 Click OK to close the property sheet.

Modifying Task Types in a Task Rule
Use the following steps to modify the list of task types affected by the task rule.

Step 1 Choose Definitions > Task Rules, highlight the appropriate task rule, right-click, and choose 
Properties. 

Step 2 On the [Task Rule] Properties property sheet, click the Task Type tab, then use one of the following 
methods:

• To add a task type to the list, check the check box to the left of the appropriate task type. 

• To remove a task type from the list, uncheck the check box to the left of the appropriate task type.

• To include all the task types into the task rule, click Select All. 

• To exclude all the task types, click Unselect All. 

Notify Task Rule Specify the recipients to be notified after the task rule is executed. 

To modify this rule, click the Notify tab on the [Task Rule] Properties 
property sheet.

Update Task Rule Specify the properties to be updated on the task after the task rule has 
executed. 

To add task properties to update after the task rule is executed:

1. Click the Update tab, click Add to add a new Property drop-down 
list to the Properties to Update section.

2. From the Property drop-down list, select the item to update in the 
task.

To remove this rule, the Remove button removes the last property added 
to the list. For example, you cannot remove Property 4 without 
removing Property 5 from the list. To keep Property 5:

1. Update Property 4 with the information from Property 5.

2. Click Remove to remove Property 5 from the list. 

Table 8-2 Summary of Available Task Rules

Task Rule Purpose
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Step 3 Click OK to close the property sheet.

Searching IT Records
The Operations > Search IT Records view displays only the alerts, incidents, and change requests created 
in Process Orchestrator. The results of the query are based on the specified filter options. You can search 
by the assignee, category, task type, and status. 

Monitoring Auditing Information
The Auditing View displays the system auditing logs for system events that have occurred within Cisco 
Process Orchestrator for each Process Orchestrator server in the environment.Use this view to:

• Display detailed information regarding system events that have occurred within Process 
Orchestrator, such as start and shut down time and error occurrences. 

• Filter the results by Orchestration Server name.

Step 1 Choose Operations > Auditing > System.

Step 2 To view the audit logs for a specific server in your environment, enter the server name in the 
Orchestration Server filter text box.

Step 3 From the Auditing Log Results pane, highlight the appropriate log entry, right-click and choose 
Properties.

Step 4 To add, remove, or sort column headings on the display, see Configuring Columns.
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C H A P T E R 9

Performing Basic Console Tasks

The Process Orchestrator Web Console provides a simplified web-based view to allow end users to 
interact with automation. The web console does not allow users to define processes but does allow them 
to start processes, monitor processes they started, or interact with human steps in processes called tasks 
(such as approvals). This interface is purposefully simplified to minimize the learning curve of the 
occasional user.

Note The Web Console is typically not used when Process Orchestrator is used in conjunction with Cisco 
Prime Service Catalog. In these cases, end-user interaction occurs through the catalog rather than 
Process Orchestrator interfaces. The Web Console is typically only used in cases when Process 
Orchestrator is used independently.

Figure 9-1 Cisco Process Orchestrator Web Console

For the Web Console to work properly, Internet Information Services must be installed on the computer 
on which the Web Console is installed. For information about installing and configuring IIS, refer to the 
Cisco Process Orchestrator Installation Guide.
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You cannot create or modify processes on the Web Console. To modify a process, you must have the 
appropriate security rights and must access the Process Orchestrator console. If you think you should 
have access to the expert Process Orchestrator console, contact your manager to authorize your access. 

Use the following sections for instructions on navigating and performing actions in the Web Console:

• Launching the Web Console, page 9-2

• Performing Web Console Actions, page 9-2

Launching the Web Console
To use the Process Orchestrator Web Console, you must log in using your Windows credentials. If you 
have Windows integrated authentication configured, then logging in might not be required. 

To access the Web Console, choose one of the following:

• Open the Cisco Process Orchestrator console and choose File > Environment Properties to see the 
web console location.

• Choose Operations > Getting Started > Launch Web Console. 

• Choose Start > All Programs > Cisco > Cisco Process Orchestrator > Cisco Process 
Orchestrator Web Console.

Performing Web Console Actions
The following sections describe some of the typical actions you can perform using the Web Console.

Refreshing the Display
The Refresh option updates the information on the current web page.

To refresh the current view, use one of the following methods:

• Press F5.

• Click the Refresh tool.

• On the navigation bar, click Refresh.

The display refreshes with the latest information generated from the Process Orchestrator server.

Viewing the My Tasks Page
Use the My Tasks page to navigate and manage Process Orchestrator tasks in the Web Console.

Before You Begin

To make sure the default search criteria is available after the initial search on the Process Orchestrator 
Web Console, enable the cookies in your browser.

Step 1 Launch the Web Console and click My Tasks.

Step 2 Enter the search criteria, then click Search. Tasks can be filtered to display:
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• Tasks created within a selected time period. 

Note Press Alt E to highlight the Tasks created within the past option.

• Tasks assigned to the currently logged in user or user group

• Tasks filtered according to the state of the task

• Tasks filtered according to the type of task 

• The affected target (for example, the default SMTP server, automation service, or Process 
Orchestrator server) that the alert or incident describes

• Tasks filtered according to the category assigned to the task

The <No Filter> option allows the page to display all tasks regardless of the assigned state.

Step 3 To view the task details, highlight the appropriate task, then click View Details.

Resolving Tasks in the Web Console

Step 1 Launch the Web Console, click My Tasks, then enter the search criteria to filter the display. 

Step 2 Highlight the appropriate task, then click View Details or press Alt V.

Step 3 From the Status drop-down list, choose the appropriate status for the task resolution.

Step 4 In the Add Notes text box, if available, enter any notes related to the task resolution or status update. 

Step 5 Click Submit to resolve the task.

Taking Ownership of a Task
These steps are used when deciding to take ownership of a task that is unassigned or assigned to an entire 
group of which the current logged in user is also included.

Step 1 Launch the Web Console, click My Tasks, then enter the search criteria to filter the display. 

Step 2 Highlight the appropriate task, then click View Details.

Step 3 In the Add Note text box, add notes to the task, as necessary. 

Step 4 Check the Take sole ownership of this task check box, then click Submit. 

Starting Processes in the Web Console
The Run Processes page displays the processes that the user has access to run, are enabled, and have the 
Started by User trigger. 
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Step 1 Launch the Web Console and click Run Processes, then enter the search criteria to filter the display. 

To filter the display by category, choose the appropriate category and click Search.

Step 2 On the appropriate process, click Start. 

Step 3 If process has input variables, under Start the process with the following parameters, verify or modify 
the values:

Step 4 If the process has multiple start points and you want to start a process from a specific point, check the 
Start from start point check box, then select the appropriate starting point. The first activity after the 
specified starting point will run first.

Step 5 Under This process will execute against [Target Name]. Would you like to override?, choose one of 
the following options:

• Yes—To specify a target or target group different from the defined process target

• No—To continue with the process execution

Step 6 Click Start to start the process; click Observe to review the process execution details.

Overriding the Process Target
With the appropriate rights, you can override the target of any manually-started process before process 
execution begins. To override the current process target, see Starting Processes in the Web Console, 
page 9-3, Step 5.

Note Targets cannot be modified from the Web Console.

Column Description

Name Name of the input variable

Value Value assigned to the variable

Description Brief description of the variable

Data Type Type of variable 

• Boolean—Indicates whether the set of elements is true 
or false

• Hidden String—Holds data that must be protected 
from other Process Orchestrator users 

• Identity—Represents the value of a user identity

• Numeric—A single whole or decimal number assigned 
(positive and negative)

• String—Sequence of characters, such as letters, 
numbers, and punctuation marks displayed in a string 
of text

• Table—Used to store a set of records in a table format
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Viewing My Process History
The My Process History page displays the processes that you have run in Process Orchestrator. You can 
filter the display of the processes you have launched and the details of the processes. 

Step 1 Launch the Web Console, click My Process History, then enter the search criteria to filter the display. 
You can filter by:

• Processes that were started in a specified time period.

• Process state—Display all processes in all states (same as <No Filter>), only the processes that have 
succeeded, or only the process that have failed.

• Category—Filter by the category associated with the processes in the list. The <No Filter> option 
displays all processes regardless of the assigned category.

Step 2 Click Search to modify the process list display. 

Step 3 On the appropriate process, click View Details. The Process Details page displays the summary 
information for the process. 

Viewing an Automation Summary 
An automation summary is a collection of data summarizing the objects included in the process and the 
data retrieved by the processing of the objects. On the web console, an automation summary can be 
launched from the following locations:

• Task detail page—Displays the task details of the task

• Process history page—Displays the details of the process activity

Step 1 Launch the Web Console. 

Step 2 Use one of the following methods:

• Choose My Tasks, highlight the appropriate task, then click View Details. After the task opens, 
choose Automation Summary > View.

• Choose My Process History, highlight the appropriate process, click View Details, then click View 
Automation Summary.

The Automation Summary page displays the following information. 

Field Description

Situation Analysis After Process Orchestrator requires action, it performs deep analysis based on 
the type of situation identified.

During situation analysis, Process Orchestrator captures volatile state and 
diagnostic information that may otherwise be difficult or impossible to capture 
manually. 

The Situation Analysis section displays below the overview information. 

Click the link in the upper portion of the summary to navigate directly to the 
Situation Analysis section or simply scroll to the section.
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The topics in the following sections describe some of the more typical actions you can perform from the 
Process Orchestrator console:

Basic Actions

• Refreshing the View, page 9-7

• Viewing and Modifying Object Properties, page 9-7

• Configuring the Navigation Pane, page 9-8

• Customizing the Fonts and Colors, page 9-8

• Changing the Process Display Icon, page 9-9

• Configuring the Display Refresh Rate, page 9-10

• Configuring Columns, page 9-10

• Searching for an Object, page 9-11

• Modifying the Console Time Zones, page 9-11

• Enabling and Disabling an Object, page 9-12

• Deleting an Object, page 9-12

Setup Actions

• Connecting to a Server, page 9-12

• Specifying Server Credentials, page 9-13

• Assigning Credentials to Processes and Activities, page 9-13

• Displaying Recent Servers, page 9-13

• Suspending Server Automation, page 9-14

Properties

• Viewing the Properties of an Object

• Viewing Activity Instance Properties, page 9-14

• Viewing Runtime Usage Properties, page 9-15

• Viewing the Used By Properties of an Object, page 9-15

• Viewing the History of an Object, page 9-15

Creating Tasks

• Creating an Alert Task, page 9-16

• Creating an Approval Request Task, page 9-18

• Creating a Change Request Task, page 9-18

Context Analysis Process Orchestrator analyzes all data points in context with each other to 
identify a situation that may require action. 

This information can be viewed in the Context Analysis section of the 
summary. The Context Analysis displays the symptom and possible causes.

Field Description
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• Creating a Guided Operation Task, page 9-19

• Creating an Incident Task, page 9-19

• Creating an Input Request Task, page 9-20

• Creating a Review Task, page 9-21

• Adding a Related Task, page 9-21

• Adding an Option to the Input Request Select Question, page 9-22

• Assigning a Category to a Task, page 9-22

• Assigning a Duplicate Alert, page 9-23

• Creating a Check Box Question, page 9-23

• Creating a Hidden Text Question, page 9-23

• Creating a Select Question, page 9-24

• Creating a Text Question, page 9-24

Miscellaneous Tasks

• Manually Changing the Status, page 9-25

• Modifying the Assignment Properties for a Task, page 9-25

• Specifying Parameters for a Task, page 9-25

• Resolving a Task, page 9-26

• Viewing Task History, page 9-26

• Reversing Process Changes, page 9-26

• Viewing the History of an Object, page 9-15

Refreshing the View
The Refresh option updates the information on the current view.

To refresh the current view, choose View > Refresh, or click F5.

Viewing and Modifying Object Properties

Step 1 Click Definitions > [Object], highlight the appropriate object, right-click and choose Properties.

Step 2 On the [Object] Properties property sheet, click the tabs to view and update the various properties for 
that object. 

Step 3 Click OK to close the dialog.
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Configuring the Navigation Pane
The Navigation pane includes views that you use to perform specific functions in the product. You can 
customize the views that display in the Navigation pane and the order in which they display.

Step 1 In the bottom right corner of the Navigation pane, click the >> icon.

Step 2 Select the option for the appropriate action to be performed:

Customizing the Fonts and Colors
The default formatting for the Console display can be updated through the Customize dialog box. The 
available items to update depend on the category selected.

Step 1 Choose Tools > Customize.

Step 2 From the Category drop-down list in the Customize dialog box (see Using the Actions Menu, page 2-5), 
select any of the following items, as necessary:

Step 3 Under Display items, select the item to be modified. The available items to update depend on the 
category selected.

Field Description

Show More Buttons Select this menu item to add buttons (views) to the Navigation pane. This 
option is available only if all of the available views are not currently 
displayed.

Show Fewer Buttons Select this menu item to remove buttons (views) from the Navigation 
pane. This option is available when there are navigation views that can be 
removed from the Navigation pane.

Button Configuration Select this menu item to display the Button Configuration dialog box, 
where you can arrange the order of the navigation views.

Add or Remove Buttons Select this menu item to display the list of views that can be displayed or 
hidden in the Navigation pane.

Field Description

Console Updates the display of the Console panel caption

Navigator Updates the display of the Navigation pane

Activity Updates the displayed processes on the Operations—Activity view

Calendar Updates the display of the Calendar dialog box

Target Updates the display of the color status on targets in the Operations 
workspace.

Definition Updates the color status of the processes in the Definitions workspace

Task Updates the color status of tasks in the Operations—Task view
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Step 4 Modify the following items as necessary, then click OK.

Matching a Regular Expression
The Match dialog box provides the ability to easily check the specified string text against a specified 
regular expression.

Step 1 In the Process Editor, choose Tools > Regex Matcher.

Step 2 In the Match dialog box, specify the following information to the regular expression:.

Changing the Process Display Icon
The following steps provide instructions on how to change the icon for the process that displays in the 
Process Views.

Step 1 On the Process Properties pane, click the Options tab.

Step 2 Under Display, check the Use custom icon check box and click Select Icon.

Field Description

Font Provides font and font size display options

Foreground Provides a list of colors to appear on different items in the foreground.

Click Custom to define a color not displayed in the list.

Background Provides a list of colors to appear on different items in the background.

Click Custom to define a color not displayed in the list.

Gradient Start Provides a list of colors to appear graded from top the bottom.

Click Custom to define a color not displayed in the list.

Gradient End Provides list of colors to appear graded from bottom to top.

Click Custom to define a color not displayed in the list.

Field Description

Source text Enter the text to be validated against the specified regular expression.

Regular Expression Specify a fixed string to represent the regular expression to be used in 
matching.

Match case Check the check box to specify whether regular expression matching 
should be case-sensitive.

Matches found Displays the matching regular expression.
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Step 3 In the Select Images dialog box, the currently selected icons display to the right of the of the fields. To 
the right of both Image fields (Small or Large), click “...” to change the icon, then click OK.

Step 4 In the Select Image dialog box, use one of the following options:

• To choose from the display of default icons, on the Common tab, click the appropriate icon and then 
click OK. 

• To choose an icon from a different location, click the Custom tab.

– To the right of the Image path field, click “...” to insert the file path to the appropriate icon.

– In the Display Name field, enter the name of the icon and click OK.

Step 5 Click OK.

Configuring the Display Refresh Rate
Use the Refresh tab to specify the refresh rate for the Activity and Process Views.

Note Use the scroll buttons to the right of the text fields to change the numeric display one second at 
a time.

Step 1 Choose Tools > Options, then click the Refresh tab.

Step 2 Under Refresh, select the appropriate process and activity instance refresh rate (see Using the Actions 
Menu, page 2-5), then click OK.

Configuring Columns
The Choose Columns dialog box determines which columns display for a selected navigation item and 
the order in which the columns display. The available column headings vary depending on the selected 
item.

Step 1 In the Navigation pane, select the appropriate item.

Step 2 In the Results pane, right-click and choose Choose Columns.

Step 3 Under Columns, use one of the following options to select the appropriate column heading to display:

• Check the check box for the column heading.

• Highlight the column heading and click Show.

Step 4 Choose any of the following options:

a. To remove a column heading from the display, use one of the following options:

– Uncheck the check box.

– Highlight the column heading and click Hide.
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b. To change the order in which a column appears in the results pane, select the column heading and 
click Move Up or Move Down.

c. To determine the width of a column, select the column heading and specify a value in the Width of 
selected column field.

d. To reset the column settings to the default, click Reset.

Step 5 Click OK to save the settings and close the dialog box.

Searching for an Object
The Find dialog box locates an item with specific text in the current view.

Step 1 Choose Edit > Find.

Step 2 In the Find what text field, enter specific terms for the search query.

Step 3 Check the following check boxes, as necessary:

• Match case—Selected when searching for term using the specific case in the Find what text field

• Use regular expressions—Select this item to query items that can contain special characters.

Step 4 Click one of the following buttons to begin the search:

• Find Previous—Locates previous match in the search query

• Find Next—Locates next match in the search query

Modifying the Console Time Zones
Use the Date & Times tab to specify the time zone that will be used to display date and time values 
throughout the application. 

Step 1 Choose Tools > Options, then click the Date & Times tab.

Step 2 Under Show dates and times using, choose one of the following options to specify the time zone to be 
used, then click OK.

Field Description

The current time zone of my 
computer

Select this radio button to display the date and time zone 
settings of the computer on which the application is 
installed.

The specified time zone Select this radio button to select the time zone to be 
displayed throughout the application.
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Enabling and Disabling an Object
Most objects are enabled by default. If an object is manually disabled, it must be enabled before it is 
available. The disabled object is not removed from the list of objects in the Definitions > [Objects] 
Results pane.

Step 1 Choose Definitions > [Objects].

Step 2 Highlight the object, then in the Results pane, right-click and choose one of the following:

• Enable—The Enabled column on the Results pane changes to True. 

• Disable—The Enabled column on the Results pane changes to False.

Step 3 If necessary, click the Refresh  tool to update the view. 

Deleting an Object

Note If the object definition is shipped as a part of product or you do not have the appropriate rights, the Delete 
option will be disabled.

Use the Definitions > [Object] view to delete an object. 

Before deleting an object, access the object’s properties and click the Used By tab to view where this 
object is being referenced. This ensures that deleting the object does not affect any processes or 
activities. 

Notes

• The deletion process will fail if the object is referenced by other objects. 

• A process variable is not completely deleted from a process until after the process has been saved. 

Connecting to a Server
Use this option when you want to connect to a different server used for process monitoring.

Step 1 Choose File> Connect to Server.

Step 2 Choose a previously connected server from the Server drop-down list or enter the server’s name, then 
click OK.

If the server is properly connected, the Cisco Process Orchestrator License Check dialog box displays. 
If the server does not properly connect, the Connect to Server dialog box displays.
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Specifying Server Credentials
The Specify Credentials check box on the Select Server dialog box displays the login pane used for 
entering the information to authenticate the server connection.

Step 1 Choose File > Connect to Server.

Step 2 In the Select Server dialog box, enter the server URL into the Server field or choose the server from the 
list.

Step 3 Check the Specify Credentials check box.

Step 4 Enter the user name required to access the server, the domain where the server resides, and the user 
password. Then click OK.

Displaying Recent Servers
The Recent Servers option displays all the servers recently accessed during the current session.

Step 1 Choose File > Recent Servers. 

Step 2 To adjust the number of recent servers displayed:

a. Choose Tools > Options > General > Most recently used servers.

b. Enter the number of servers to display on the Recent Servers list on the File menu, then click OK.

Assigning Credentials to Processes and Activities

Step 1 Choose Definitions > Processes, right-click and choose Edit, or right-click Processes in the navigation 
pane and choose New Process.

Step 2 On the Process Editor properties, click the Credentials tab.

Step 3 Check the check box for the appropriate runtime user types to be included with the process.

Step 4 Click Select All to select all the available runtime users. Click the Unselect All to clear the selected 
runtime users availability for the process.

Step 5 In the Default runtime user section, select the appropriate runtime user that the process will run on by 
default.

Modifying the Condition Branches
Use the Result Handlers tab to modify the list of condition branches on the process. You can add 
condition branches, specify the order of the condition branches, or remove condition branches from the 
process.
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Assigning a Category

Step 1 Choose Definitions > Processes, right-click and choose Edit, or right-click Processes in the navigation 
pane and choose New Process.

Step 2 On the Process Editor properties, click the Category tab.

Step 3 Click Add to launch the Select Categories dialog box and select the category to which the process is to 
be assigned.

Suspending Server Automation
Use the Suspend Automation check box to suspend the execution of processes on the server. The enabled 
check box suspends any new process from being created and the server will no longer create instances 
of activities or processes.

Step 1 Choose File > Environment Properties.

Step 2 In the Environment Properties dialog box, check the Suspend automation check box.

Viewing the Properties of an Object
To view information about an object, highlight the object, right-click and choose Properties. 

Properties are organized by tabs. For example, the General tab can include information such as the object 
name of the object and type, its status, a brief description, and whether the object is enabled or disabled. 
The properties that are displayed depend on the object type.

Viewing Activity Instance Properties

Step 1 Select any of the activity views to display the process and activity instances in the Results pane (for 
example, Operations > Activity Views > View Triggered).

Step 2 In the Results pane, expand the appropriate instance to display the related activities.

Step 3 Highlight the appropriate activity, and use one of the following methods:

• Double-click the appropriate activity instance.

• Right-click and choose Observe.

• From the Details pane, click any hyperlink (see Details Pane, page 2-10).

Step 4 To view activity instance properties, in the Results pane, expand the appropriate instance to display the 
related activities.
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Viewing Environment Properties
The Environment Properties option provides a view of the properties for the entire high availability 
Process Orchestrator environment.

To view the environment properties, choose File > Environment Properties.

Viewing Runtime Usage Properties
The Runtime Usage tab shows the list of running processes that is currently using that specific queue 
resource.

Viewing the Used By Properties of an Object
Use the Used By tab to display the objects that directly reference the selected object in their 
configuration. Because the Used By tab displays objects in a tree view, you can also display the objects 
that directly reference the top level objects for the selected object. 

The objects at the top level are the objects that reference the selected object directly, but you can expand 
the listed objects and see their referenced objects. For example, if object A is used by objects X and Y 
and object X is used by object Q, then on the property pages of object A, you will see X and Y listed. If 
you expand the (+) object X, then object Q will display. 

Step 1 Click Definitions > [Object], highlight the appropriate object, right-click and choose Properties.

Step 2 On the [Object] Properties property sheet, click the Used By tab to view the objects that use that object. 

Step 3 Click OK to close the dialog.

Viewing the History of an Object
Use the History tab to view a history of changes that have been made to an object. This is a display-only 
tab that does not require any user interaction.

Step 1 Click the History tab to view the changes made to the object. 

Field Description

Display Name Displays the queue resource name.

Process Name Displays the processes that uses the queue resource.

Process Instance ID Displays the process IDs of the running processes.

Priority Displays the priority set on the queue block.

Description Displays how many seconds the queue resource has been in 
allocated state for the process.
9-15
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 9      Performing Basic Console Tasks
  Creating an Alert Task
The following information about the history of the object is displayed:

Step 2 To view the audit history for a specific action, highlight the appropriate time, right-click and choose 
Properties. 

Step 3 Click OK to close the property sheet.

Creating an Alert Task
Use the Alert task to create an alert regarding any potential problems. An alert reflects potential 
problems that a user might want to investigate and possibly diagnose the problem.

Step 1 Choose Operations > Task Views > New > IT Record > Alert.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Alert tab to enter the following criteria for the alert:

• Alert class—String or numeric value indicating the class of the alert.

• Severity—Severity of the alert:

– High—Interruption to critical business processes.

– Normal—Interruption to the work of individual employees.

– Low—Hindrance to the work of individual employees, continuation of work possible by means 
of a circumvented solution.

• Automation Summary—Enter the file path for the related automation summary that was performed 
on the alert.

Step 4 Click the Affects tab to specify the elements that trigger the selected target:

• This alert applies to the following target— Specify the affected target to be used in the activity.

• Process target—Use the process target as the affected target in the activity.

• Activity target—specify the affected target for a specific task activity.

– Activity target—Select the activity containing the target that will be used. Only task activities 
will display in the list.

– Specific target—Specify the affected target that will be used.

To view the properties for the selected target, click the Properties  tool. To create a new 
target, click New > [Target].

Column  Description

Created by The user name of the person who created the object

Created time The date and time the object was created

Time The date and time the action occurred 

User The user name of the person that performed the action

Type The action that occurred

Description Information about the action that was performed
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– Specific target group—Specify the affected target group that will be used.

To view the properties for the selected target group, click the Properties  tool. To create a 
new target group, click New > [Target Group].

From the Choose a target using this algorithm drop-down list, specify which target will be 
chosen from the eligible target group members. 

Target Algorithms

Choose all targets that satisfy the specified criteria—Executes the process on all targets defined 
by the criteria specified in the Target Selection dialog box.

Choose any target that satisfies  the specified criteria—Executes the process on any targets 
defined by the criteria specified in the Target Selection dialog box.

Choose the target with the specified name—Executes the process on the member of the group 
specified in the Name to match text field.

Select SAP target with the specified System ID—SAP System runs target against the SAP 
System database connection

– Choose the target with the specified name—Runs the process on the member of the group whose 
name is specified in Name to match.

• This applies to the following configuration item—Specify the configuration item to be used in the 
activity

• Name—Name of the configuration item (IT component) to which the alert pertains. For example, 
the name of a database server that failed or the name of a specific job that failed.

• Type—Enter the appropriate configuration item type or select the type of ITIL configuration item 
(IT component) from the list which the alert describes. For example, the type of the specific 
application element that failed (Application Server, Database, Host, or User).

• This is a CMDB reference—Indicate that the true source of the CI is in the CMDB, so the 
configuration item properties reference a CMDB entry.

• Object key—ID for the specific record in the CMDB that contains the configuration item

• Object source—Name for the specific record in the CMDB that contains the target configuration 
item

• Affected services—IT Service affected by the alert or incident

• Affected organizations—Organizations that consume the IT service affected by the alert or incident

Step 5 Click the Assignment tab to manage the general task properties for the alert.

• Assigned to—User names assigned to the task

– Add—Click Add to launch the Select Identity dialog box to add a user name to the list.

Type the name of the assignee or to search for the assignee, click Browse to launch the Select 
User or Group dialog box to select the name of the person.

– Remove—Select the user name and click this button to remove the user from list.

• Priority—Indicates the priority of the task

• Due date—Check the check box and select appropriate date the task should be completed from the 
drop-down calendar.

• Expiration date—Select the appropriate date the alert should expire from the drop-down calendar.

Step 6 Click the Notification tab to specify the recipients to be notified when the task rule is executed.

Step 7 Click the Parameters tab to define parameters for a specific task.
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Step 8 Click the Notes tab to enter any notes related to the task.

Click Add to launch the Add Note Dialog Box to add a specific set of notes to the task.

Step 9 Click the Categories tab to assign an alert to a category or modify an existing assigned category for the 
task.

Step 10 Click the Related tab to assign or modify an existing related task. The fields displayed depend on the 
task selected.

Step 11 Click the External tab to specify the external incident information to support the synchronization 
between Cisco Process Orchestrator and the system that the customer is using.

Step 12 Enter the information in the remaining tabs as necessary, then click OK to complete the task definition.

Creating an Approval Request Task
Use the Approval Request task to specify the user or group required to approve a task including the 
message associated for the approver.

Step 1 Choose Operations > Task Views > New > User Interaction > Approval Request.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Approval tab and enter the following criteria:

• Message—Message that informs the approver what is being requested

• Approval Choices—The approval choices available (Add, Remove)

• Choice—Enter the appropriate approval choice

Step 4 Enter the information in the remaining tabs as necessary, then click OK to complete the task definition.

Creating a Change Request Task
Use the Change Request task to request a modification to the configuration of an object or system. 
Change requests are used to request system enhancements, report problems with a system, or report 
changes from one system which affects another system.

Step 1 Choose Operations > Task Views > New > IT Record > Change Request.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Change Request tab to enter the following criteria for the task:

• Change request identifier—Cisco Process Orchestrator generated ID number for the change request 
task

• Change request class—Numeric value indicating the class of the change request

• Reason for change—Describes the business justification for the request

• Change timing—Enter the deadline date or time for the change

• Severity—Severity of the change request (High, Normal, Low)
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• Automation Summary—Enter the file path for the related automation summary that was performed 
on the change request.

Step 4 Enter the information in the remaining tabs as necessary, then click OK to complete the task definition.

Creating a Guided Operation Task
Use the Guided Operations activity to detail the steps a user makes when handling an assigned task.

Step 1 Choose Operations > Task Views > New > User Interaction > Guided Operation.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Guided Operation tab and enter the step-by-step process for handling the task.

• Alert—Alerts reflect potential problems that a user may want to investigate and possibly diagnose 
the problem

• Approval Request—Specifies the message and choices for the assignee who is approving the task

• Guided Operation—Details the steps a user takes to complete an assigned task

• Incident—Task requires an operator to take action in order to resolve an issue

• Input Request—Task requires input from an individual or group

• Review—Task assigns a document for review

Step 4 Enter the information in the remaining tabs as necessary, then click OK to complete the task definition.

Creating an Incident Task
Use the Incident task to create a create a task that requires an operator to take action in order to resolve 
an issue.

Click the hyperlink to display field descriptions for the appropriate tab. Click the hyperlink again to 
remove the displayed field descriptions.

Step 1 Choose Operations > Task Views > New > IT Record > Incident.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Incident tab to enter the criteria for the incident.

• Incident Identifier—ID of the incident

• Reporting user—User name of the individual who reported the incident and contact information of 
the user who called IT to report the problem

• Reporting user details—Contact information of the individual who reported the incident

• Severity—Severity of the incident (High, Normal, Low)

• Automation Summary—Enter the file path for the related automation summary that was performed 
on the alert
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Step 4 Click the Affects tab to specify the elements that trigger the selected target:

• This alert applies to the following target— Specify the affected target to be used in the activity.

• Process target—Use the process target as the affected target in the activity.

• Activity target—specify the affected target for a specific task activity.

– Activity target—Select the activity containing the target that will be used. Only task activities 
will display in the list.

– Specific target—Specify the affected target that will be used.

To view the properties for the selected target, click the Properties  tool. To create a new 
target, click New > [Target].

– Specific target group—Specify the affected target group that will be used.

To view the properties for the selected target group, click the Properties  tool. To create a 
new target group, click New > [Target Group].

From the Choose a target using this algorithm drop-down list, specify which target will be 
chosen from the eligible target group members. 

– Choose the target with the specified name—Runs the process on the member of the group whose 
name is specified in Name to match.

• This applies to the following configuration item—Specify the configuration item to be used in the 
activity

• Name—Name of the configuration item (IT component) to which the alert pertains. For example, 
the name of a database server that failed or the name of a specific job that failed.

• Type—Enter the appropriate configuration item type or select the type of ITIL configuration item 
(IT component) from the list which the alert describes. For example, the type of the specific 
application element that failed (Application Server, Database, Host, or User).

• This is a CMDB reference—Indicate that the true source of the CI is in the CMDB, so the 
configuration item properties reference a CMDB entry.

• Object key—ID for the specific record in the CMDB that contains the configuration item

• Object source—Name for the specific record in the CMDB that contains the target configuration 
item

• Affected services—IT Service affected by the alert or incident

• Affected organizations—Organizations that consume the IT service affected by the alert or incident

Step 5 Click the Related tab to assign or modify alerts that originated the incident.

Step 6 Enter the information in the remaining tabs as necessary, then click OK to complete the task definition.

Creating an Input Request Task
Use the Input Request task to create a set of questions requiring a user or group response in order to 
gather a large set of information. 

Step 1 Choose Operations > Task Views > New > User Interaction > Input Request.

Step 2 Click the General tab and enter the required information.
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Step 3 Click the Questions tab and enter the following criteria for the input request:

• Input request message—Introductory message for the input request

• Questions presented on the input request—Displays the input request question properties

– Question—Input request question

– Type—Type of question (text, select, check box)

– Default Value—Default answer for the question

• New—Use this option to create a specific type of input request question. Click New each time to 
create additional questions for the input request.

– Text—Launches the Text Question Properties dialog box to allow the user to define a text 
question.

– Hidden value text—Launches the New Hidden Text Properties dialog box to allow the user to 
define a question requiring an encrypted value as a response.

– Check box—Launches the Check box Question Properties dialog box to allow the user to define 
a question utilizing a check box.

– Select—Launches the Select Question Properties dialog box to allow the user to define a text 
question.

• Properties—Modifies the properties for the question.

Step 4 Enter the information in the remaining tabs as necessary, then click OK to complete the task definition.

Creating a Review Task
Use the Review task to submit a document for review as well as provide a message for the reviewer. 

Step 1 Choose Operations > Task Views > New > User Interaction > Review.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Review tab to enter the following criteria for the review request:

• Message—Read-only display of message that informs the reviewer what is being requested

• Document to review—Click Browse to locate document or automation summary to be reviewed. 
The following example is the display for the file path for the document.

C:/Documents and Settings/user name/My Documents/

Step 4 Enter the information in the remaining tabs as necessary, then click OK to complete the task definition.

Adding a Related Task
Related tasks could be duplicates of one another or the resolution of the task is dependent on the solution 
of the existing task.

Step 1 Choose Operations > Tasks Views, highlight the appropriate task, right-click and choose Properties.
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Step 2 Click the Related tab to modify the list of tasks related to the opened task.

Step 3 Click Add to launch the Select Task dialog box.

Step 4 Use one of the methods to choose a category:

• To choose a single category, highlight the appropriate category.

• To choose multiple categories, press CTRL and hold the key while making the appropriate 
selections.

• Click New to create a new related task.

Step 5 Click OK to close the dialog box.

Note On the Related tab, you can click Remove to remove the task from the list. This action does not 
delete the task from the system.

Adding an Option to the Input Request Select Question
Use the following steps to create options for the Select question. Repeat the steps for each additional 
option.

Step 1 On the New Select Properties dialog box, click New.

Step 2 Enter the label name and value for the selection, then click OK.

The new selection displays on the New Select Properties dialog box under the Selections area. 

Assigning a Category to a Task

Step 1 Choose Operations > Tasks Views, highlight the appropriate task, right-click and choose Properties.

Step 2 Click the Categories tab to modify the list of categories assigned to the task.

Step 3 Click Add to launch the Select Categories dialog box.

Step 4 Use one of the methods to choose a category, then click OK.

• To select a single category, highlight the appropriate category.

• To select multiple categories, press CTRL and hold the key while making the appropriate selections.

Note On the Related tab, you can click Remove to remove the category from the list. This action does 
not delete the category from the system.
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Assigning a Duplicate Alert
This task can be auto-populated if the duplicate task criteria defined in the Create Alert activity has been 
met.

Step 1 Choose Operations > Tasks Views, highlight the appropriate task, right-click and choose Properties.

Step 2 Click the Related tab to indicate the task is a duplicate of another task.

Step 3 Click Browse to launch the Select Tasks dialog box.

Step 4 Use one of the following to choose a duplicate task, then click OK.

• To choose a single task, highlight the appropriate task.

• To choose multiple tasks, press CTRL and hold the key while making the appropriate selections.

• Click New to create a new task.

Note On the Related tab, you can click Remove to remove the selected task from the field. This action 
does not delete the task from the system.

Creating a Check Box Question
Use a Check Box question in an Input Request task to check a specific selection to a defined question. 
For example, create this task type to allow assignees to respond with an answer such as True/False or 
Yes/No to the question.

Step 1 Choose the Input Request > Questions tab, click New > Check Box.

Step 2 Enter the following information to create or modify questions that contain a check box: 

• ID—Unique ID for the input request question (Default: Q1)

• Question—The question for the input request

• Default value—Default value to be used for the question

Step 3 Click OK to create the new question.

The new question displays on Input Request > Questions tab under the Questions presented on the input 
request area.

Creating a Hidden Text Question
Use the Hidden Text Properties dialog to create or modify Hidden text questions for an input request. An 
example of an encrypted value includes values such as passwords.

An encrypted value will be available from the Insert Variable Reference dialog and can be used in 
providing a response to the Hidden text question. The encrypted value is only to be used when the 
question type is a Hidden text question.
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Step 1 Choose Input Request > Questions, then click New > Hidden Text.

Step 2 Enter the following information for the question: 

• ID—Unique ID for the input request question (Default: Q1)

• Question—The question for the input request

Step 3 Click OK to create the new question.

Creating a Select Question
A Select question in an Input Request task allows the user to choose a single option from a list of answers 
to a defined question.

Step 1 Choose Input Request > Questions, then click New > Select.

Step 2 Enter the following information to create or modify questions that contain a check box:

• ID—Unique ID for the input request question (Default: Q1)

• Question—Enter the question for the input request

• Selections—Displays the input request question properties:

– Label—Input request question

– Value—Default answer for the question

– New—Use this option to launch the Select Choice dialog box to create a selection for the input 
request question. For additional information, see Adding an Option to the Input Request Select 
Question, page 9-22.

• Properties—Modifies the properties for the selected option

• Delete—Removes the selected option from the list

Step 3 Click OK to create the new question.

The new question displays on Input Request > Questions tab under the Questions presented on the input 
request section.

Creating a Text Question
A Text question in an Input Request task allows the user to enter a text or numeric value to the question.

Step 1 Choose Input Request > Questions, then click New > Text.

Step 2 Enter the following information for the text question: 

• ID—Unique ID for the input request question (Default: Q1)

• Question—The question for the input request

• Default value—Default value to be used for the question
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Step 3 Click OK to create the new question.

The new question displays on Input Request > Questions tab under the Questions presented on the input 
request area.

Manually Changing the Status

Step 1 Choose Operations > Tasks Views, then highlight the appropriate task, right-click and choose 
Properties.

Step 2 Click the General tab and enter the following information, then click OK.

• Display name—Name of the task

• Status—Choose the appropriate status of the task. The statuses displayed depend on the currently 
open task.

• Description—Brief description of the task

Modifying the Assignment Properties for a Task
Use the following steps to change the assignee or other assignment properties for the task. This includes 
taking ownership of the task, if necessary.

Step 1 Choose Operations > Tasks Views, highlight the appropriate task, right-click and choose Properties.

Step 2 Click the Assignment tab to modify the assignment properties for the task.

Step 3 Under Assigned to, change the list owners for the task.

Step 4 Modify the task priority, the date the task should be completed, and the expiration date, then click OK.

Specifying Parameters for a Task
A single task can include up to 10 parameters. 

Step 1 Choose Operations > Tasks Views, highlight the appropriate task, right-click and choose Properties.

Step 2 Click the Parameters tab, then click Add.

Step 3 Enter the appropriate information for the task, then click OK.
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Resolving a Task
Before You Begin

Only users with administrative rights can update tasks from the Operations > Task view in Cisco Process 
Orchestrator.

Step 1 Choose Operations > Tasks Views, highlight the appropriate task, right-click and choose one of the 
following:

• Resolve

• Select a choice

Step 2 From the Status drop-down list, choose the appropriate status for the task resolution, then click Submit.

Viewing Task History
Use the History tab to view a history of changes that have been made to the task.

Step 1 Choose Operations > Task, highlight the appropriate task, right-click and choose Properties.

Step 2 Click the History tab to view the changes made to the task.

Step 3 To view the audit history for a specific action, highlight the appropriate item, right-click and choose 
Properties to display the Audit Properties dialog box.

Step 4 Click OK to close the dialog box. 

Reversing Process Changes
This item is used when changes have been made to the process definition, but are no longer necessary. 
This option deletes all changes made since you last saved the process. If you have saved the process and 
have not made any additional changes, then no action will be taken.

To reverse process changes, choose File > Revert. 

The process reverts back to the last saved version of the process. All activities, components, and other 
changes are removed from the process definition.

Deleting a Calendar
Choose Definitions > Calendars to delete calendars that are no longer used. Before deleting a calendar, 
access the properties, then select the Used By tab to view where objects are being used by the calendar. 
The calendar deletion process fails if the calendar is used by another object.

If the calendar definition is a core product or the user does not have the appropriate rights, the Delete 
option will be disabled.
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Removing Dates from a Calendar List

Step 1 Choose Definitions > Calendars, highlight the appropriate calendar, right-click, and choose 
Properties.

To remove a calendar from either list, highlight the appropriate calendar and click Remove.

Certain features of the property pages may display as display-only if the calendar definition is shipped 
as part of an automation pack or the user does not have the appropriate rights.

Step 2 Click the Dates tab, highlight the appropriate date, and drag it onto the calendar displayed to the right.

Step 3 Click the Preview tab to review the schedule, then click OK.

Applying a Value to a Target-Specific Target Property
Use the Target Values tab to specify a target property value for a specific target. This values overrides 
the default target property value.

Step 1 Choose Definitions > Target Properties, highlight the appropriate target property, right-click and 
choose Properties.

Step 2 Click the Target Values tab to specify a target property value for a specific target.

Step 3 Click New to launch the Target Properties dialog box.

Step 4 To add a specific target to the target property, click Add to launch the Select Targets dialog box.

Step 5 On the Select Targets dialog box, select the targets to be added to the target property.

Step 6 Use the Value field to modify the value assigned to the targets assigned to the target property. The fields 
displayed depend on the type of extended target property.

Step 7 Click OK to close the dialog box.

Viewing Target Properties
Use the Definitions—Target Properties view to access the properties of the target property.

Step 1 Choose Definitions > Target Properties, highlight the appropriate target property, right-click and 
choose Properties.

Step 2 Click the General tab to view information such as Target name, owner, data type, and description.

Step 3 Click the Group tab to view information about the primary property group name, secondary property 
group name, and the grouping index.

Step 4 Click the Target Types tab to view the information about the Target types that are chosen.
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Inserting Reference Variables
The Reference  icon displayed next to a text field indicates that the field can be populated by 
referencing a defined variable or the property of another activity or process. Use the Insert Variable 
Reference dialog box to select a defined variable or reference an object to populate a field. The OK button 
does not activate until a valid property or variable is selected.

Depending on the object type, some of these variables might not be available.

Reference Variable Description

Notes Description for the virtual machine

Name Display name of the object

Created by / Owner User name or the owner of the object

Creation Time The date and time the object was created

Modified by User name of the individual who modified the object

Modification Time The date and time the object was modified

Type Type of object

Is Normal Status Status is normal and indicates that there are no known problems 
with this object

Is Unreachable Status Status is unreachable which indicates that there are no known 
problems with this object

Status Information Detailed information regarding the target status and the reasons for 
object being unreachable

Target ID ID number assigned to the object 

Authentication String used by the client for authentication

Polling interval Interval to query the system

Port Port number used to access the server port

Server Host name or the IP address of object server

Description Description of the activity

Audit Starts Date and time the process audit starts

Audit Successes Indicates the number of successful audits

End Time Date and time the activity stopped

Error Information Description of the error that has occurred

Group Name Name of toolbox activity group

Instance Canceled Indicates the process was canceled manually

Instance Failed Indicates the process has failed

Instance Failed (Completed) Indicates the process has failed but the process execution was 
completed

Instance Failed (Not 
Completed)

Indicates the process has failed and did not complete the 
process execution

Start Time Date and time the activity was started

Process Id ID number of the Process Orchestrator process
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Process Instance Id ID number of the Process Orchestrator process instance

Entry ID ID number assigned to the object entry

Incident Id Incident ID of the object property

Back Link Id ID number assigned to the first item in the item relationship

Forward Link Id ID number assigned to the second item in the item relationship

Work Info Id ID number of the work info entry

Results Results of the activity

Field Values Value of the property
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C H A P T E R 10

Performing Administrative Actions

Use the Administration workspace to perform administrative actions within the product, including:

• Managing Process Orchestrator servers in a high availability environment

• Determining what Process Orchestrator objects users are allowed to view, create, or modify

• Enabling time zones to be used when configuring processes

• Configuring adapters

• Creating and managing the report database, and running reports

The Administration > Getting Started view provides the initial access to the Administration pane.

In this view, the following administrative actions are available: 

The following topics guide you through accessing the Administration workspace and using the features 
in this view.

• Managing Properties

• Managing Database Settings

• Configuring Security

The Administration workspace contains navigation items that define the various administrative 
components that are used to manage Cisco Process Orchestrator.

• Security—View the security groups to which users can be added and the objects to which privileges 
are granted

• Time Zones—View the available time zones that can be used in processes

• Adapters—View and configure the adapters that are installed. You can also view what objects the 
adapter provides in the product.

• Database Settings—Create a new report database or modify the properties of an existing report 
database

• Automation Packs—Displays the automation pack that is associated with the security role in the 
product

Options Description

View Security Launches the Administration > Security view to display the 
rules that ship with the product

Create or Modify Cisco Process 
Orchestrator Reporting Database

Launches the Administration > Database Settings view 
where you can view reports, create or modify the report 
database
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Managing Properties

Viewing Process Orchestrator Server Properties

Step 1 Choose Administration > Orchestration Servers, and double-click the server name.

Step 2 In the Properties dialog, click the General tab to view the properties for the Orchestration server. 

Step 3 Click the Prerequisites tab to view the status of the server.

Step 4 Click the Responsibilities tab to view the current responsibilities assigned to the server.

Step 5 Click the Ports tab to view the following information:

• Port Number—Port number for connecting to the Orchestration Server.

• Protocol—Displays the protocol for connection.

• Listener—Listening port for the protocol

• Enabled—Indicates the port is opened

Setting Process Orchestrator Console Environment Properties

Step 1 From the File menu, select Environmental Properties to display the Environment Properties panel.

Step 2 Click the General tab to enter or modify general information about the server connected to the Console.

• Name—Name of the environment of the Orchestrator server

• Id—Display-only. ID number of the orchestrator server

• Description—Enter a brief description to associate with the connected server

• Enable Team Development—Check this check box to enable team process authoring on this server. 
Uncheck the check box to disable team process authoring on this server.

• Suspend Automation—Check this check box to suspend the execution of processes on the server.

• Audit target property value changes made by processes—Check this check box if you want a 
property value change made to a process to be audited.

• Web Console location—Displays the URL to the Web console

Step 3 Click the Web Service tab to modify Cisco Process Orchestrator Web Service configuration settings.

• Enable secure Web Service (HTTPS) —Check this check box to configure the authentication for the 
HTTP endpoints.

– HTTPS port—Enter or verify the Hidden value HTTPS port for the Cisco Process Orchestrator 
Web Service. (Default: 61526)

– HTTPS authentication mechanism—Choose the appropriate authentication for the Web service

– Override default certificate—Select to override the default certificate

• Enable non-secure Web Service (HTTP)—Check this check box to unencrypt the HTTP endpoints.

– HTTP port—Enter or verify the Hidden value HTTP port for the Cisco Process Orchestrator 
Web Service. (Default: 61527) 
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– HTTPS authentication mechanism—Choose the appropriate authentication for the Web service

Basic—Sends a username and password as the method of authentication. It's the simplest 
method of authentication, but the least Hidden value.

Digest—Sends cryptographic representation of the password rather than the password itself. 
This authentication method is more Hidden value than basic authentication.

Ntlm—Authentication protocol used on networks that include systems running on the Windows 
operating system. This option can be used to return to the normal mode of operation.

• Refresh Web Services—Click this button to regenerate the dynamic Web service methods in the 
North Bound Web service. This affects the Web service methods which start processes and retrieve 
process instance output variables.

For example, if you create a new process called My Process. Click the Refresh Web Services button 
to regenerate the NBWS so that the Process service has a new StartMyProcess() call.

Step 4 Click the Execution Limits tab to set the limits for the server. 

Each limit has two settings. One that will warn and generate a warning event log in the Cisco Process 
Orchestrator system audit and the other will generate an error entry in the system audit. If the error level 
is reached the process will halt.

• Warning Level—Set the limit before sending a warning. If this is reached, a warning message is 
returned.

• Error Level—Set the limit before sending an error. If this is reached, a error message is returned.

• Activity Instances in Process Instance—Set the number of activity instances within a process 
instance.

• String Variable Size—Set the size limit for the string variable

• Event Instance Size—Set the size limit for the event instance

Step 5 Click the Encryption tab to view a Uuencoded public key that can be used for external encryption of 
Hidden value strings. 

• External encryption public key (uuencoded)—Contains the default key or the imported key.

• Import—Imports a public/private key pair file into the Process Orchestrator. You must have 
“Update” permission over the “Environment Settings” object in order to import new public/private 
key pair. When you click this button, a standard File Open dialog box displays, allowing you to point 
the console to an existing file. PFX file format is supported. It supports password protection on the 
file. Therefore, when importing a PFX file, a dialog box displays requesting the password of the file.

• Reset to default key—Click to reset the current key to the default key.

Step 6 Click the History tab to view the history of changes made to an object.

• Created by—The user name of the person who created the object

• Created time—The date and time the object was created

• Time—The date and time the action occurred

• Change Type—The action that occurred

• User—The user name of the person that performed the action

• Orchestration Server—The name of the Orchestration server associated with the object

Step 7 Click OK.
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Updating the Product License
Cisco Process Orchestrator is packaged with a trial license that is valid for a specified number of days. 
The trial license can be used until the license expires or is updated with a permanent license.

After the trial license expires, you must enter the appropriate license information (the license must be 
updated to a permanent license) to continue using the product.

Step 1 From the File menu, select Update License to display the License Information panel.

Step 2 Enter the appropriate information, including:

• Customer Name— Name of the individual client or department. This field is customer-specified and 
is not case-sensitive.

• Company Name— Name of the organization as provided by Cisco. The company name must be 
entered exactly as provided by Cisco. This field is case-sensitive.

• License code—Product license code as provided by Cisco. The license code must be entered exactly 
as provided by Cisco. This field is not case-sensitive. 

Step 3 Click Next.

Step 4 Select the I agree radio button, then click Next.

Step 5 When the Completing the Update License Wizard panel displays, click Finish.

Step 6 When the License was successfully updated dialog box displays, click OK.

Managing Time Zone Properties
Use the Administration > Time Zones view to display the time zones that ship with the product. The time 
zones are used when specifying a schedule trigger for a process. The time zones cannot be modified. 
However, you can add a description to the time zone properties and enable or disable the time zones. If 
a time zone is disabled, it will not be available for selection when defining schedule properties.

You can update the properties of a specific time zone using the Time Zone Properties property sheet. 
From this property sheet, you can enter a description for the time zone and enable or disable the time 
zone. Click the Used By tab to display the processes or schedule definitions that reference the time zone.

Step 1 Choose Administration > Time Zones, right-click a time zone, then choose Properties.

Step 2 In the [time zone] Properties dialog, enter the appropriate information, including: 

• Name—The Greenwich Mean Time (GMT) name for the time zone and the location where the time 
zone is in effect

Step 3 Click Next.
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Managing Database Settings
Use the Administration > Database Settings view to create and manage the database connections 
included in the product.

For example, you can:

• Choose Database Settings > Process Database to set the database grooming settings properties for 
the processes database. This dialog also contains the Groom Now option that allows you to manually 
start the database grooming process.

• Choose Database Settings > Report Database to import reports, view database properties, and 
delete the database from the product.

To view database properties, highlight the appropriate database, right-click and choose Properties.

To manage the database connections:

Step 1 Choose Administration > Database Settings. 

Step 2 Choose one of these database options: 

Managing the Process Database
The Process Database is created during the installation process, but only the default size of the data files 
is determined. Use the Process Database Properties property sheet to determine the amount of data that 
is archived in the database files before being deleted from the system. 

To configure the database settings:

Step 1 Choose Administration > Database Settings.

Step 2 Highlight Process Database, right-click and choose Properties.

Step 3 In the Process Database Properties property sheet, click the Configuration tab.

Step 4 Choose one of the following options:

Database Description

Process Database The process database displays the properties for the Process Orchestrator 
performance database. For information about configuring the grooming 
settings of the process database, see Managing the Process Database.

Report Database The report database generates reports for viewing process execution 
history and to audit process changes. 

Note You must be logged in with an account that has administrator 
privileges on the machine where the report database is being 
created, whether it is the local machine or a remote machine. Your 
user account must also have Reporting Services privileges to 
create or modify the reports.

For information about managing reports, see Managing the Report 
Database.
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• To start the grooming process immediately, click Groom Now.

• To modify the database grooming settings for the automation database server, specify a value for the 
grooming fields, then click OK. 

Managing the Report Database
Process Orchestrator supports two reporting technologies:

• SQL Server Reporting Services. Customers who install Microsoft SQL Server as their chosen 
database platform can add the Reporting Services technology for free by simply specifying the 
component during SQL Server installation. SQL Server Reporting Services is only supported for 
Process Orchestrator databases hosted on an SQL Server.

SQL Server Reporting Services reports are XML based report definitions that include report data 
and report layout elements. On a client file system, report definitions have the file extension .rdl. 
After a report is published, it is a report item stored on the report server or SharePoint site. Reports 
are one part of the server-based reporting platform provided by Reporting Services. 

With Reporting Services, you can create interactive, tabular, graphical, or free-form reports from 
relational, multidimensional, or XML-based data sources. You can publish reports, schedule report 
processing, or access reports on-demand. Reporting Services also enables you to create ad hoc 
reports based on predefined models, and to interactively explore data within the model. You can 
select from a variety of viewing formats, export reports to other applications, and subscribe to 
published reports. The reports that you create can be viewed over a Web-based connection or as part 
of a Microsoft Windows application or SharePoint site. Reporting Services provides the key to your 
business data. 

• SAP BusinessObjects. BusinessObjects is the only solution that supports reporting against an Oracle 
Process Orchestrator database. 

The reporting technology is installed separately from the product. Typically a reporting installation 
spans Process Orchestrator servers.

Field Description

Configuration Audit 
Grooming

Groom configuration audit data older than

Enter the number of days before configuration audit data is deleted from 
the database.

Process Instances 
Grooming

Groom completed process instances older than

Enter the number of days before completed process instance data is 
deleted from the database.

Task Grooming Groom completed tasks older than

Enter the number of days before completed task data is deleted from the 
database.

Groom task audit data older than

Enter the number of days before the task audit data is deleted from the 
database.
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To configure the database settings:

Step 1 Choose Administration > Database Settings.

Step 2 Highlight Report Database, right-click and choose Properties.

Step 3 Click the Connection tab to view the properties of the database server.

Step 4 In the Report Database Properties property sheet, click the Configuration tab and view or modify the 
database grooming settings that determine when specific data is deleted from the database after specific 
amount of months.

Viewing the SQL Server Connection Properties

Step 1 Choose Administration > Database Settings.

Step 2 Highlight Report Database, right-click and choose Properties.

Step 3 Click the Connection tab and choose the appropriate SQL Server database type.

Viewing the Oracle (Oracle Authentication) Connection Properties

Step 1 Choose Administration > Database Settings.

Step 2 Highlight Report Database, right-click and choose Properties.

Field Description

Server name Display-only. Name of the reporting server.

Database name Display-only. Name of the reporting database

User User name assigned to the account for logging on to the SQL server.

Password Password assigned to the user account for logging on to the SQL server. 
Check the check box to enable the Password field.

Domain Name of the domain for the user account

Reports URL URL of the reporting database report
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Step 3 Click the Connection tab and choose the Oracle (Oracle Authentication) database type.

Viewing the Oracle via TNS (Oracle Authentication) Connection Properties

Step 1 Choose Administration > Database Settings.

Step 2 Highlight Report Database, right-click and choose Properties.

Step 3 Click the Connection tab and choose the Oracle (Oracle Authentication) database type.

Viewing the Oracle via Service name (Oracle Authentication) Connection 
Properties

Step 1 Choose Administration > Database Settings.

Step 2 Highlight Report Database, right-click and choose Properties.

Field Description

Host Display-only. Name of the Oracle server where the database resides.

SID Display-only. Oracle system ID used to identify the Oracle database.

Port Display-only. Port number used to access Oracle database.

User/Schema Display-only. Name of the reporting database.

Password Password assigned to the user account for logging on to the Oracle 
database server.

Field Description

Host Display-only. Name of the Oracle server where the database resides.

TNS Alias Display-only. Service name alias used for the TNS connection.

User/Schema Display-only. Name of the reporting database.

Password Password assigned to the user account for logging on to the Oracle 
database server.
10-8
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 10      Performing Administrative Actions
  Managing Database Settings
Step 3 Click the Connection tab and choose the Oracle (Oracle Authentication) database type.

Creating a Reporting Database Connection
The Process Orchestrator Reporting database is initially created during the installation process. There 
are occasions when the report database connection may need to be removed and then re-connected. 

Before You Begin

• You must be logged in with an account that has Administrator rights on the machine where the report 
database is being created, whether it is the local machine or a remote machine. 

• You must also have Reporting Services permission to create or modify the reports as create or 
modify permission over the Report Database object within Cisco Process Orchestrator.

To create the report database connection:

Step 1 Choose Administration > Database Settings, right-click Report Database and choose Create Process 
Orchestrator Reporting Database.

The Welcome to the Report Database Configuration Wizard panel displays. Click Next.

Step 2 The fields on the New Process Orchestrator Reporting Database panel (excluding the Password field) are 
automatically populated with the name of the local server and the credentials of the currently logged in 
user. Use one of the following methods:

• To use the credentials that are auto-populated for the default user, enter the password in the 
Password field.

• Specify the credentials for a different user, then click Next.

Step 3 The fields on the Database Settings panel are automatically populated with the default locations and data 
grooming settings for the database. Use one of the following methods:

• To use the information that is auto-populated, click Next.

• To modify the data and transaction log file settings for the new database, specify the appropriate 
information, then click Next.

Step 4 When the dialog box indicates that the database has been successfully created, click Next.

Step 5 Verify the information and click Finish to complete the procedure and close the wizard.

Field Description

Service name Display-only. Service name alias used for the Oracle Single Client Access 
Name (SCAN)

Host Display-only. Name of the Oracle server where the database resides.

Port Display-only. Port number used to access Oracle database.

User/Schema Display-only. Name of the reporting database.

Password Password assigned to the user account for logging on to the Oracle 
database server.
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Importing Reports into SQL Reporting Services
During the Core Automation Pack import process, SQL Server Reporting Services report definition files 
are copied to the file path determined on the Core Report panel. To view the reports in SQL Server 
Reporting Services Report Manager, the report definition files must be imported into the Report 
Manager using the Report Database Import Report wizard.

Use the Import Reports process to import new reports into the report database. 

Before You Begin

• To import reports, you must be logged in with an account that has Administrator rights on the 
machine where the report database is being created, whether it is the local machine or a remote 
machine. 

• Your account must also have Reporting Services permission to create or modify the reports as create 
or modify permission over the Report Database object within Process Orchestrator.

To import reports:

Step 1 Choose Administration > Database Settings, right-click Report Database and choose Import 
Reports.

The Report Settings panel displays.

Step 2 On the Report Settings panel, specify the following information to define the server and credentials for 
importing reports:

• Reports Server URL

• Enter the address for the SQL Server Reporting Services report server.

• Access Report Server via Hidden value Socket Layer (SSL)

• Check this check box if SSL protocol is used to access the report server.

• Database Type

– Select the type of database based on the authentication method that is used to log on to the 
database. The following options are available:

– SQL Server (Integrated Windows Authentication)

• SQL Server (SQL Authentication)

• User

• Enter the name assigned to the user account that is used to connect to the report database.

Step 3 After the reports have been imported, click Next.

Step 4 Verify the URL of the report server, then click Finish.
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Importing Reports into BusinessObjects
During the Core Automation Pack import process, Business Intelligence Archive Resource (BIAR) files 
are copied to the file path determined on the Core Report panel. To view the reports in BusinessObjects 
InfoView, the BIAR file must be imported onto the BusinessObjects server using the BusinessObjects 
Import Wizard.

Before You Begin

To import BIAR files, you must be logged in with an account that has the appropriate permissions on the 
Business Object server, whether it is the local machine or a remote machine.

Use the following steps to import reports into BusinessObjects. 

Step 1 Choose Start > All Programs > BusinessObjects XI.3.1 > BusinessObjects Enterprise > Import 
Wizard.

Step 2 From the Welcome to the Import Wizard panel language drop-down list, choose the appropriate language 
to use to import the reports (English is the default), then click Next.

Step 3 On the Source environment panel, specify the environment to where the wizard will import the 
appropriate user and object information, then click Next.

The fields in the lower pane changes based on the selection.

Step 4 On the Destination environment panel, specify the appropriate information for Business Object 
Enterprise XI 3.1, then click Next.

Step 5 On the Select objects to import panel, choose the appropriate items to import into your Business Object 
Enterprise XI 3.1 server, then click Next.

Step 6 On the Import Scenarios panel, select the appropriate radio button for handling scenarios where the 
objects already exist in the destination environment, then click Next.

Field Description 

Source From the drop-down list, choose Business Intelligence Archive Resource 
(BIAR) File.

BIAR file Enter the appropriate file path or click “...” to locate the BIAR file on the 
computer.

Field Description 

CMS Name Enter the name of the Business Object Enterprise XI 3.1 destination CMS

If the CMS is running a particular port, add a colon and the port number to the end 
of the CMS name.

User Name Enter the name of a user with import permissions. The default is typically an 
administrator.

Password Enter the password of the associated user name

Authentication Select the type of authentication appropriate for the CMS and the user who will be 
used to import the reports. The default is Enterprise.
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Step 7 On the Incremental import panel, uncheck the check boxes next to options that perform the following 
imports as appropriate, then click Next.

• To import report objects without overwriting dependent objects that already exist in the destination 
environment.

• To import report objects without importing a universe or connection that would overwrite a universe 
or connection in the destination environment.

Step 8 Review the summary information on the Import Wizard panel, then click Next.

Step 9 On the Users and groups panel, check the check boxes to import the appropriate specific users and 
groups, then click Next.

Step 10 On the Custom Access Levels panel, check the appropriate check boxes to import custom access level, 
then click Next.

Note If you import a user and an object, the Import Wizard imports the rights of that imported and 
does not exist in the destination environment, the Import Wizard gives the individual rights 
specified in the level on the object for the user.

Step 11 On the Categories panel, choose the appropriate categories to be imported, then click Next.

• For large document domains, you can import incrementally and import documents one category at 
a time.

• To import all the objects associated with the category, check the Import all objects that belong to 
the selected categories check box.

Step 12 On the Folders and objects panel, select the folders and objects to import, then click Next.

• Click Select All to check all check boxes of the folders and objects displayed.

• To import all instances of each selected object, check the Import all instances of each selected 
object check box.

Step 13 On the Select application folders and objects panel, select the application folders and objects to import, 
then click Next.

Import Scenario Description 

Update the destination object. 
In case of name conflict, 
rename it.

If the Import Wizard finds an object in the destination environment 
with the same source objects unique identifier (CUID), it updates the 
destination object.

If the Import Wizard does not find an object in the destination 
environment with the same CUID but it finds an object with the same 
name, the Import Wizard imports the object from the source 
environment and then renames the object.

Update the destination object. 
In case of name conflict, do 
not import it.

If the Import Wizard finds an object in the destination environment 
with the same CUID, it updates the destination object.

If the Import Wizard finds an object in the destination environment 
with the same name but different CUID, the Import Wizard does not 
import the object from the source environment.

Do not import the object. If the Import Wizard finds an object in the destination environment 
with the same CUID, the Import Wizard does not import the object.
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Note If the selected folders and objects exist on the destination system, they will be updated using the 
source system as a reference.

Step 14 In the Import options for universes and connections panel:

a. Select one of the following import radio buttons for universe objects:

– Import all universes and connection objects (Default) 

– Import all universes and only connection objects used by these universes

– Import the universes and connections that the selected Web Intelligence and Desktop 
Intelligence documents use directly. In the next dialog box, you can select additional universes 
that are not used by any imported document.

b. To import universe overloads, check the Keep universe overloads for imported users and groups 
check box.

If you are importing universe overloads, you must also choose the users, groups, and universes 
during previous steps in the Import Wizard. You must also choose to overwrite existing objects in 
the Incremental import panel. If you did not choose these options, click Back until you get to the 
appropriate panel.

c. If you choose to import users and groups, universe overloads, and other objects and do not want to 
overwrite all of the object rights for the users and groups and objects that you’ve selected, use one 
of the following methods:

– Ensure that you choose only the universes that you want to import and then import the other 
objects in another import process.

– Delete the universe overload in the destination environment and then uncheck the Overwrite 
existing objects and Overwrite object rights check boxes in the Incremental import panel. In 
this case, the Import Wizard imports only the universe overloads that do not already exist in the 
destination environment.

d. Click Next.

e. If you selected either of the first two options, the Import options for publications panel displays. 
Skip to Step 15 to continue.

f. If you selected the third option, the Universe folder and universes panel displays. Choose the 
appropriate universes and universe folders.

– If the selected source environment is other than BusinessObjects 5.x or 6.x, the universes that 
are linked to specific documents cannot be cleared from the list. You can choose additional 
universes that are not used by any imported document. 

– If no universe is found, the associated documents will not be imported and a warning message 
appears. If this occurs, link the documents to a universe, republish the documents to the 
repository, and retry the import. 

g. Click Next.
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Step 15 On the Import Options for Universes panel, choose the appropriate profile and publication recipient 
radio buttons, then click Next. 

Step 16 On the Remote Connections and Replication Jobs panel, choose the appropriate remote connections and 
replication jobs to import, then click Next.

Step 17 On the Ready to import panel, click Finish.

Configuring the BusinessObjects Connection for the Process Orchestrator 
Report Database

BusinessObjects can support a Process Orchestrator Report Database running on either an SQL server 
or Oracle. Use the following steps to configure the BusinessObjects reporting connection to the Process 
Orchestrator reporting database. 

Before You Begin 

• If you are running on an SQL server:

– Verify that the Microsoft SQL native client or the Oracle client is installed.

– On the reporting database, verify that the named pipes are enabled. To enable the named pipes, 
use MS SQL Configuration Manager. 

– For additional information on the prerequisites, refer to the SQL server information on the 
Microsoft Developer Network.

To configure the BO reports connection:

Step 1 Choose Start > All Programs > BusinessObjects XI.3.1 > BusinessObjects Enterprise > Designer.

Step 2 On the User ID dialog box, enter the appropriate credentials, then click OK.

Step 3 On the Universe Designer dialog box, choose Tools > Connections.

Step 4 From the Connections List, highlight Process OrchestratorReporting, then click Edit. 

Step 5 On the Edit Process Orchestrator Reporting Connection dialog box, in the Authentication Mode list, 
verify that Use specified username and password is selected.

Step 6 Specify the reporting database information, then click Next.

Step 7 Verify the information on the Configuration Parameters and the Custom Parameters panels, then 
click Finish.

Option Description

Select import option for importing 
profiles

• Import all profiles

• Import profiles used by selected publications

Select import option for importing 
publication recipients

• Import recipients used by selected publications

• Do not import recipients
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Accessing SQL Server Reporting Service Reports
Process Orchestrator provides SQL Server Reporting Services reports required by managers and auditors 
as well as reports required by developers of process automation. In general, the data that is provided for 
these diverse audiences is the same. What differs is the granularity and level of aggregation of this data 
and the specific data that is the focus of a given report.

Before You Begin

• Access to any report is controlled and available only to authorized users. 

To access reports from your web browser:

Step 1 In the Address bar of your web browser, enter the following URL:

http://<ReportServer>/Reports

where <ReportServer> is the name of the server hosting the reports. 

If you use SQL server named instances, the URL and Report folder include the instance name. For 
example, if you enter <SQLserver>\NamedInstance:

• The URL will be http://<ReportServer>/Reports_NamedInstance.

• The report folder will be located at Cisco Process Orchestrator Reporting > <ReportServer> 
> NamedInstance > <ReportDBName>.

Step 2 Click Cisco Process Orchestrator Reporting > [Report Server] > [Report DB Name].

Step 3 On the Process Orchestrator Reporting Database Report Manager home page, click Core to view the 
Core Process Orchestrator report folders.

The available reports and a brief description of the information that is generated by each report is 
displayed. 

Step 4 Click the report name to enter the search criteria and generate the report.

Accessing Reports in BusinessObjects InfoView
Process Orchestrator provides reports required by managers and auditors as well as reports required by 
developers of process automation. In general, the data that is provided for these diverse audiences is the 
same. What differs is the granularity and level of aggregation of this data and the specific data that is the 
focus of a given report.

Before You Begin

• Access to any report is controlled and available only to authorized users. 

To access Process Orchestrator Core reports in Java Infoview:

Step 1 On the BusinessObjects client machine, choose Start > All Programs > BusinessObjects XI 3.1 > 
BusinessObjects Enterprise > BusinessObjects Enterprise Java InfoView.

Step 2 In the SAP BusinessObjects application, enter your user credentials to log on to InfoView.

Step 3 Choose Documents List > Public Folders > Cisco Process Orchestrator > Core > Auditing (or) 
Operations.
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Step 4 To view a report, double-click on the report name.

Modifying the Report Database
In some cases, you might need to move the SQL Server Reporting Services server to another location. 
You must remove the current Report Database connection and connect to the new server using the Report 
Database Import Report wizard.

To modify the report database:

Step 1 Choose Administration > Database Settings.

Step 2 Highlight Report Database, right-click and choose Remove Cisco Process Orchestrator Reporting 
Database Connection.

Step 3 To connect to the new server, see Creating a Reporting Database Connection.

Configuring Security
As a Process Orchestrator administrator, you can limit users access to only a subset of Process 
Orchestrator processes or limit a whole group to read-only access for specific objects. For example, the 
Process Orchestrator administrator can configure members of the Accounting Process Authors group 
with the ability to only create, delete, modify or schedule processes in the Accounting category and can 
only act on targets that represent the accounting services. However, those members of that group will not 
be allowed to view or modify any other processes or targets in Process Orchestrator.

Using the Security view, you can determine what Process Orchestrator objects users are allowed to view, 
create, or modify. 

If the user has permissions to view (or edit) only a subset of Process Orchestrator objects, when the 
Process Orchestrator user interfaces (Console, CLI, or Web Service) display Process Orchestrator 
objects to the user, the display will only show those objects that the user has permissions to view or 
modify.

When the user does not have sufficient permissions in Process Orchestrator to perform an operation and 
attempts to perform that operation, Process Orchestrator will generate an error, as well as log an audit 
failure event to the event log.
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Role-Based Access Control (RBAC)
In Process Orchestrator, authorization is performed using a Role-Based Access Control System. Roles 
are a collection of permissions. Each permission pairs a set of operations that can be performed over 
some set of objects. A user assignment gives end users the ability to perform the role.

Typically, roles are defined according to a standardized job function within IT. Examples might include 
“Level 1 Helpdesk,” “Level 2 Helpdesk,” “Human Resources,” “Network Configuration,” “SAP Basis 
Expert,” and so on. Security groups already in the directory for the users in these job functions are then 
typically assigned to the roles.

Figure 10-1 Process Orchestrator Role-Based Access Control

Permissions define what operations can be performed over what objects. This defines the rights and 
associates them with set of Process Orchestrator objects. This is similar to file permissions (such as read 
or update). 

• Operations are things such as Cancel, Change Owner, Create, Delete, Read, Start, Update, and Use. 
Most other Operations automatically allow Read. Change Owner automatically allows Update and 
Read. 

• Objects specify rules that match elements from the functional model, such as Processes, Targets, and 
Runtime Users. Specifically, several types of object rules are supported:

– Object List—Allows rights only to specified objects in the list.

– Object Type—Allows rights to all objects of that type (for example, all targets or all processes).

– Owner Security—Allows rights to all objects of a specified type that are owned by a specific 
principal (user or group in Active Directory).

A User Assignment is a link to a security principal. The user assignment is the thing that is defined in 
Process Orchestrator, since it defines the rule for who is in the Role. The Principal is actually in an 
external directory, so the user assignment is a reference to the directory. 
10-17
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 10      Performing Administrative Actions
  Configuring Security
Predefined Security Roles

Cisco Process Orchestrator provides predefined security roles that ship with the product and cannot be 
modified. Custom user roles can be created using the Administration view, but the following roles are 
defined by default:

Predefined Security Permissions

In the Security Role Properties property sheet, the Operations tab displays the list of permissions 
included and/or available for inclusion into the security role. Check the check boxes for the appropriate 
powers for the security role. 

Role Description

Administrators Role These users have access to all functionality in the product. Users can view 
or modify any definition, process or setting. Only a small number of users 
are assigned this role. These users have permissions to modify adapter 
settings, import automation packs, and configure databases.

Auditors Role The user can view any definition or instances, such as running processes, 
but are not allowed to modify any of the objects.

Create Ownership Role All users are assigned to this group. It provides full control over any 
objects the user owns.

Definition Role This is a user who can define processes. The user can:

• View all Operations information (Activity Views, Process Views and 
Auditing) 

• Start adhoc processes

• Cancel running processes

• View/update definitions

The user cannot update administration settings.

Operators Role This is a classic role for a level 1 Service Desk employee, executing 
workflows. The user can:

• View all Operations information (Activity Views, Process Views and 
Auditing) 

• Start ad-hoc processes

• Cancel running processes

The user cannot:

• Update definitions

• Update administration settings
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Object Owners

Process Orchestrator objects have an owner. For example, Process Orchestrator targets, processes, 
calendar, target group, global variables, etc. all have an owner field. Owners are security principals; by 
default, they reflect the user who created an object. However, they can be set to any Active Directory 
security principal. In addition, in the preferences section of the UI, users can specify a security principal 
such as a group name to use for all objects they create. This concept is useful in team development.

One type of RBAC object definition within an RBAC permission is an Owner security permission. This 
has two possible settings:

• The connected user matches objects the user owns, either directly or indirectly. For example, if the 
user running the Process Orchestrator console is a member of a group specified in an owner field, 
the permission would match that object.

• Exactly the specified user matches objects where the user is an explicit match.

This feature can be used to give a simple yet powerful way to say users can act on objects they create. It 
can also be used to specify access to objects according to the security principal of the connecting user. 
If groups are used for owner fields rather than the ID of the user who created the object, users of that 
group will have access. This is very useful in team development scenarios.

Object views have an optional column that can be used to manage object ownership. 

Changing the Owner of a Security Role
With the appropriate rights, ownership of a security role can be changed using the Process Orchestrator 
security feature.

Step 1 Choose Administration > Security, highlight an existing security role, right-click and choose 
Properties.

Step 2 Click the General tab, scroll to the Owner field, and to the right of each field, click Browse.

Step 3 To change the default object type in the Select this object type field:

a. Click Object Types.

b. In the Object Types dialog box, check the check box to the left of the appropriate object types, and 
click OK.

Step 4 To change the server location for querying a user or group:

a. Click Locations on the Select User or Group dialog box.

b. Expand the appropriate server name, choose the user or group, and click OK.

Step 5 In the Enter the object name to select text field, enter the user name (domain\user name) or group and 
click Check Names.

Note If there is a matching user name or group, it is displayed in the field. If there is not a match, a 
warning message displays.

Step 6 Click Advanced to enter additional query information.

Step 7 In the Name field, enter the appropriate terms, and click Find Now.
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Note To generate more search results, leave the Name field blank and then click Find Now.

Step 8 In the Search Results pane, choose the appropriate user or group, and click OK.

Step 9 Click OK to return to the Security Role Properties dialog box.

The selected user name or group is displayed in the appropriate Owner field.

Removing Users from Security Roles

Step 1 Choose Administration > Security, highlight the appropriate security role, right-click and choose 
Properties.

Step 2 Click the User Assignment tab. 

Step 3 Highlight the principal to be removed and click Remove, then click OK.

Modifying Security Permissions
With the appropriate rights, operations, objects, and owners can be added or removed from a security 
permission. There are three types of security permissions:

• Operations—The Operations tab displays all the operations in Cisco Process Orchestrator, such as 
Break Lock, Delete, Change Owner, and so on. Use this tab to add or remove an operation from the 
security permission.

• Object Types—The Object Types tab displays the top-level object types in Cisco Process 
Orchestrator, such as adapters, processes, targets, and global variables. Use this tab to add or remove 
an object type from the security permission.

• Owner—Use the Owner tab to modify the Windows security principal (either a user or a group) 
associated with the object and the permission. The permission is enforced upon the specified owner 
of the object.

For information about predefined security permissions, see Predefined Security Permissions.

Step 1 Choose Administrations > Security.

Step 2 Highlight the appropriate security role, right-click and choose Properties.

Step 3 On the [Security Role] Properties property sheet, click the Permissions tab, highlight the appropriate 
security permission, then click Edit.

Step 4 Click the following tabs:

• Operations—Use the Operations tab to modify the list of permissions to be included in the security 
role.

Check the check box to the left of the appropriate permission to define what actions a user assigned 
to the security role can have over the selected object types.

– Cancel— Allows the user to cancel process or activity instances
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– Change Owner— Allows the user to change the owner of the object. Change ownership 
permission includes the Read permission and requires the Modify permission to change 
ownership on an object.

– Create—Allows the user to create new objects and specify all properties of the object.

– Create permission includes Change Owner and Read permissions. This permission is required 
to perform Copy or Import functions.

– Delete—Allows the user to delete objects

– Update—Allows the user to modify all properties of the object, except the owner.

– Change Owner is the permission required to change the owner of an object.

– Read—Allows the user to view all properties of an object.

The Read permission along with the Create permission is the minimum level of permissions 
required to copy an object.

– Break Lock—Allows the user to break the lock on a process held by another user. 

– Start—Allows the user to start process ad-hoc

– Use—Allows the user to reference objects. This permission is not available to all objects, but 
only for those that can be referenced.

For example, this permission on a target or target group would allow the user to run activities 
and processes against the target group.

• Object Types—Click to add or remove permissions from a specific object type.

• Owner tab—Click to modify the Windows security principal (either a user or a group) associated 
with the object and the permission. The permission is enforced upon the specified owner of the 
object.

– Label—Assigns the permission to the currently connected Windows user

– Exactly the specified user—Click the browse button to launch the Select User or Group dialog 
box and change the security principal for the object.

Step 5 Click OK.

Note Removing an operation or object from the list is permanent. Click Add to add a new operation 
or object to the security permission.

Deleting a Security Role
Deleting the role deletes all associated permissions.

Note Removing the security role from the list is permanent. Choose Administrations > Security.

Step 1 Highlight the appropriate security role, right-click and choose Delete.

Note The default security role cannot be deleted.
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Step 2 On the Confirm Security Role Delete dialog box, click Yes to delete the security role. 
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Working with Events and Triggers

Triggers are events and conditions in the system that can fire off processes. The attributes of the trigger 
that fires off a process instance can be referenced in the process workflow. Processes often use this data 
to control execution. If a process contains a trigger, you can view its properties in the process instance 
views and in the Process Editor. The Trigger tab displays all triggers associated with the process, and 
allows you to create new triggers, modify the properties of a trigger, and delete triggers.

Process Orchestrator supports two types of rule-based triggers: 

• Events—The Process Orchestrator can monitor for events from the environment, and you can 
specify triggers that initiate processes when the subscribed event occurs. For example, an event 
might be an incoming SNMP trap or a fault on a UCS system.events and schedules.

• Schedules—Schedules allow triggering processes at some time by leveraging calendars that define 
which days something can occur. Calendars can be selected days or sequences of dates such as 
weekly or monthly, they can represent dates like fiscal quarter end, or they can be combined 
hierarchically. Schedules then associate a time with a calendar. When the day is in the calendar, the 
time is evaluated. Times can be explicit or repeating (for example, hourly).

The following sections provide information about working with triggers and events:

• Creating Triggers, page 11-1

• Correlating Events, page 11-5

• Integrating Using the Advanced Message Queuing Protocol (AMQP), page 11-7

• Debugging Process Trigger Instances, page 11-8

Creating Triggers
The following table summarizes some of the more commonly-used types of triggers and when to use 
them.

Table 11-1 Commonly-Used Trigger Types

Trigger Type Purpose

AMQP (Advanced Message 
Queuing Protocol)

Use AMQP to create Process Orchestrator triggers for events that occur 
out on the IT landscape for which Cisco does not have adapters, but that 
can generate AMQP messages. 
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Process Event Process events allow one process to pass an event to other processes. For 
example:

• A Raise Process Event activity can post a process event, and a 
trigger can monitor for a specific event. 

• A Correlate Process Events activity allows monitoring for an event 
within a process workflow. 

Process events include elements of the Process Orchestrator functional 
model so that they are aware of internal schema elements. For example, 
you can include a target type in your subscription criteria.

Process events are exposed in the northbound web service, so an external 
system can programmatically submit an event to Process Orchestrator. 
However, the use cases for process events generally center more around 
Process Orchestrator-internal use cases; Advanced Message Queuing 
Protocol (AMQP) is preferred for external message passing.

For internal use cases, process events have the advantage because they 
are native and lightweight within Process Orchestrator. It is easy to 
create message driven architectures within Process Orchestrator using 
process events. Since these events are not persisted to the database, they 
are very lightweight. Process events have the advantage that they do not 
require external setup and installation, as would be the case with AMQP.

Started by Parent Process Indicates that a process can be used by a parent process. If this trigger is 
not set in the child process, the parent process will fail.

The information used to start the child process can also be included in 
the automation summary. 

Started by User Indicates that the process can be started manually by a user. This trigger 
is added by default to a process, but can be removed. 

If a user attempts to manually start a process that does not have the 
ad-hoc trigger (or the user is restricted from starting the process in the 
ad-hoc trigger), an error message will be displayed and the process will 
not be launched.

This trigger will expose all the typical trigger properties, as well as some 
additional properties that allow you to determine exactly how the 
process was manually started.

Started by Web Service Indicates that the process can be started using the Northbound Web 
Services. For more information, see the Cisco Process Orchestrator 
Northbound Web Services Guide.

Task Event All task events are monitored by the Process Orchestrator environment. 
A user can create a trigger that can watch for any task event (task 
created, task deleted, task updated) that matches the user-specified 
criteria. 

Table 11-1 Commonly-Used Trigger Types

Trigger Type Purpose
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Creating a New Trigger
To create a new trigger for an existing process:

Step 1 On the Process Properties pane, click the Triggers tab, then choose New > [Trigger Type] from the 
drop-down list.

Step 2 On the [Trigger Type] property pages, define the properties.

Step 3 Click the General tab and enter the required information.

Step 4 Optional: To specify that the event should be monitored on targets that match specific criteria:

a. On the Trigger Target property page, click Monitor on this target group and the appropriate target 
group.

b. Under Monitor for Events on, click Choose a target using this algorithm, then click Choose the 
target that satisfies the specified criteria. 

c. Click “...” to launch the Target Selection Criteria dialog box. 

d. On the Properties pane, specify the required information, then click OK to return to the Trigger > 
Target property page.

Step 5 Optional: Complete the following tabs, then click OK.

• Condition—Specify when an action is to be taken based on an evaluation of the defined conditions. 
See Adding Conditions, page 5-21.

• Knowledge Base—Choose the appropriate knowledge base article to associate with the trigger. 

Step 6 Click OK to add the trigger to the process.

Step 7 Click Save to save the process with the new trigger.

Target Event Target events complement target types to allow event-driven automation 
for each type of service. When used as triggers, target events enable 
policy, which allows you to invoke automation as data is created or 
changed, according to patterns in the data. Available target events 
include:

• Target Created Event—Target properties are available in reference 
control.

• Target Changed Event—Current values for target properties are 
available in reference control. Names of “changed” properties are 
also available in reference control.

• Target Deleted Event—Deleted target properties available in 
reference control.

For more information about targets, see Defining a Target, page 2-13.

Table 11-1 Commonly-Used Trigger Types

Trigger Type Purpose
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Creating a Schedule Trigger
Use the Schedule trigger to specify the criteria on a defined calendar that must be met before the process 
executes. This criteria determines the values that must be met before the process executes.

Step 1 Click the Triggers tab, then click New > Schedule.

Step 2 Click the General tab and enter the general information for the trigger.

Step 3 Click the Schedule tab and specify the schedule information.

Step 4 Select the Conditions tab to include any special conditions for when the event log trigger will be 
applied.

Step 5 Click OK to complete the procedure.

Creating a Task Trigger
Use the CCMS Alert trigger to specify the properties of the monitoring tree element (MTE) that must be 
monitored before an alert is generated. This criteria must be met before the process executes.

Step 1 Click the Triggers tab, then click New > CCMS Alert.

Step 2 Click the General tab and enter the general information for the trigger.

Step 3 Click the CCMS Alert tab to enter the trigger information, including:

• Monitoring Tree Element—Click Browse to launch the SAP Destination dialog box to locate the 
monitoring tree element for the SAP system.

• Context—The CCMS MTE context for the SAP system that will be monitored by this workflow. 
Enter a wildcard (*) to monitor all servers.

• Object name—The object in SAP that will be monitored by this workflow (for example, the CPU in 
your host system, the database, and SAP services, such as background processing).

• Short name—Short text that is assigned to the MTE class.

• MTE class—The MTE class in SAP for the monitoring tree element.

• Alert Color—CCMS alerts are assigned a color based on the severity of the alert (Red, Yellow, 
Green, Unknown).

Step 4 Click the Target tab to specify the target on which to monitor for changes that will trigger the process.

Step 5 Click the Conditions tab to include special conditions for when the event log trigger will be applied.

Step 6 Click the Knowledge Base Article tab to add a knowledge base article.

Step 7 Click OK to complete the procedure.
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Creating a Variable Updated Trigger
Use the Variable Updated Properties trigger to specify the changed variable value to use as a trigger to 
execute a process. This criteria determines the values that must be met before the process executes.

Step 1 Click the Triggers tab, then click New > Variable Updated.

Step 2 Click the General tab and enter the general information for the trigger.

Step 3 Click the Conditions tab to include special conditions for when the event log trigger will be applied.

Step 4 Click OK to complete the procedure.

Adding Trigger Logic to Process Workflows
You can check the attributes of a trigger in a process, so that if one process has multiple triggers (such 
as started by user, started by parent process, and a trigger from an AMQP message), you can check which 
of these events occurred and branch the execution accordingly. The properties of the event that triggered 
the process are available in the process workflow using reference control.

Correlating Events
Process Orchestrator contains a technology called Correlex that allows events that match data in the 
workflow (such as a trigger) to be correlated. Process Orchestrator’s event correlation capabilities are 
real time, in memory, geared towards typical IT staff, not programmers, and can be combined with active 
probing and action activities to leverage correlated data. 

Process Orchestrator’s correlation activities can be placed anywhere in a workflow and reference any 
data from prior workflow steps. It is common for workflows to capture diagnostic data to perform 
decision tree branching before they correlate other events. A workflow might:

• Probe the system to see if a service is up. 

• Test system performance. 

• Look up configuration to find a relationship that is not evident in events themselves and then use 
that new information to capture events. 

Process Orchestrator's process workflows can include activities other than correlations to capture 
supplemental non-event data in real time that might be gone before the end of a classic event correlation 
time window. 

For example, assume there are two events, A and B, and there is a need to handle things one way when 
only A occurs, and another when A and B happen together. In correlation, a time window is required; if 
A occurs, it will not be clear whether A and B both occur until the end of the time window. So the results 
of the correlation might not be able to publish the results until sometime after A occurs. But with 
complex enterprise systems, often issues can be fleeting. There is a need to capture data right when a 
condition occurs or it might be gone; in other words, the tool might miss event A while looking for event 
B. Too often for difficult issues, troubleshooting data is not available at the time the operator is notified 
or some correlation response script occurs. 
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In Process Orchestrator, when event A triggers the workflow, the workflow can first focus on data 
capture, then move on to correlation. In this way Process Orchestrator has at its disposal data that is more 
real-time, and more complete, than correlation has previously allowed, which means that analysis in 
Process Orchestrator workflows can be more sophisticated. The workflow can solve a superset of cases 
compared to traditional correlation, and the data presented to operators is more complete and accurate.

This capability is exposed through Correlate activities. For example, the Correlate Windows Events 
activity allows the correlation of related events from the Windows Event Logs. 

Process Orchestrator provides Correlate activities that correspond to many types of supported triggers. 
Typically, if Process Orchestrator provides a trigger, it will also provide a correlation activity, though 
this is not explicitly required.

Figure 11-1 A Correlate Activity

Correlate activities have several key pieces of data that specify the events to find:

• The time window in which the event can occur

• The number of events to match. If a number is specified, and when the process workflow execution 
gets to the correlate activity that number of events has already occurred within the time window, the 
Correlate activity will immediately match. If not, the activity will block waiting for those events to 
occur. If all is specified, the activity will wait until the end of the window and then return the results.

• The event criteria. This presents fields for filtering that type of event and is specific to the event type 
and adapter.

Events that match a Correlate activity are available to the later steps in the workflow and are published 
in the automation summary.

From a technology perspective, the server implementation:

• Allows activities to complete in real time. If you wait for one event and a matching event arrives, 
the activity will complete immediately rather than waiting until the end of the time window.
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• Handles cases where event arrival might precede process execution of the correlation node. A 
process might not even be executing when an event arrives; it could be triggered later and look 
retrospectively for matching events. The server must cache data given its knowledge of Correlate 
activities in process definitions so it is ready to provide matched events should a Correlate activity 
execute later.

• Allows that correlation activities may never run due to untriggered workflows or workflow logic 
taking a different flow.

• Performs intelligent event caching and garbage collection based on process definitions.

Creating Correlate Event Activities
Use a Correlate activity to check whether an event occurred.

Step 1 In the Process Editor, choose Toolbox > Activities, enter correlate in the Filter by Name text box, 
then select the correlate activity for the specific event you want to collect.

Step 2 On the Correlate activity property page, click the General tab and enter the appropriate information. 

Step 3 Click the Event Criteria tab and specify the required event properties for the activity.

Step 4 Click Additional properties to match and specify the appropriate information.

The Expression arrow displayed to the right of the Reference tool indicates that a wildcard expression 
is available.

Step 5 Click Save  to complete the activity definition.

Step 6 To view the correlated event results:

a. Choose Operations > Activity Views, highlight the correlate activity instance, right-click and 
choose Properties.

b. Click the Correlated Events tab to view the alerts collected by the correlate activity.

Integrating Using the Advanced Message Queuing Protocol 
(AMQP)

Use AMQP to create Process Orchestrator triggers for events that occur out on the IT landscape for 
which Cisco does not have adapters. For example, to trigger a Process Orchestrator process in response 
to a syslog event:

Step 1 Set up an AMQP queue/exchange with a feed from an off-the-shelf component such as this: 
https://github.com/bkjones/bevis. 

Step 2 Set up the IT landscape elements (application) to post messages to the newly created queue.

Step 3 Set up a Process Orchestrator trigger from the queue/exchange.
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Related Topics

• Advance Message Queuing Protocol (AMQP) Adapter, page 12-4

Debugging Process Trigger Instances
Use the Process Editor to view the process triggers. The Triggers tab in the Properties panel displays the 
triggers associated with the process and each trigger’s target.

To debug process trigger instances:

• Review the product's auditing log (choose Operations > Auditing > System) for any errors that the 
server or adapters might have experienced while monitoring for an event.

• If a process contains a trigger, use the Process Editor to view the trigger criteria that the adapter will 
be monitoring. In the Process Instance view, you can see the specific occurrence of the trigger that 
caused the specific process instance to execute.

One debugging technique is to create a new separate process that triggers from the same event as the 
process you are trying to debug, and set the trigger criteria to include all events with no filters. You can 
then monitor the operations views to see instances of the process which launch, and look at their trigger 
attributes to see all events. Be sure to delete these debugging processes when you are done diagnosing 
your problem.

Queue Resources
Think of queues as the same thing as Customs waiting area when you travel internationally. Like 
Customs, there is both a maximum number for going through queue and a maximum number waiting to 
go through the queue, or the “waiting area.” A “queue block” is the equivalent of a person going through 
Customs.

There are two types of Queue Resources:

• Default System Queue Resource:

– Maximum concurrent executions is 1

– Maximum entries in the queue is 1000

The two values and the resource name or display name are read–only. There is only one Default 
System Queue Resource in a Process Orchestrator system.

• User Defined Queue Resource:

– Maximum concurrent executions is 1 or more

– Maximum entries in queue is 1 or more.

– You can modify the two values and the resource name or display name. 

– You can create any number of User Defined Queue Resources with any maximum concurrent 
executions and maximum entry values.

Note You can have different maximum allowed entries and maximum allowed in queue for different Queue 
Resources.
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The Process Editor Toolbox uses an object called Queue for creating or adding queues. For more 
information on using the Process Orchestrator Toolbox and creating processes, see Authoring Task 
Activities, page 5-7.

Creating a Queue Block
Think of a “queue block” as the equivalent of a person going through the line in Customs.

Step 1 Access the Queue Block Properties page.

Step 2 Enter a Queue Block Name.

Step 3 Select a Queue Resource:

– Select either a Queue Block Resource Name, or

– Select a Queue Resource Name (User defined or default).

Note The Queue Block searches for a user defined queue resource that matches the given name. 
If the name does not exist, the default system queue resource is used.

Step 4 Select a Priority level.

Step 5 Enter any optional Notes as needed.

Step 6 Click OK to save your work and close this page.

For more information on Queue Resources, see Queue Resources, page 11-8

Creating a Queue Resource
You can create one or many, as well as parallel queues and sequential queues in the same queue block.

Step 1 Go to Definitions > Queue Resources.

Step 2 On the Properties screen, enter a Display Name.

Step 3 Enter a Resource Name.

Step 4 Select the Maximum Allowed Entries.

Step 5 Select the Maximum Allowed Entries Waiting on Queue.

Step 6 Enter an optional Description.

Step 7 Click OK.
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Using Adapters

The topics in this chapter describe the adapters available for Cisco Process Orchestrator, any special 
information about installing and configuring the adapters, and the activities provided by each adapter. 
You can use these adapters in a workflow.

Many of the Process Orchestrator tasks that are required to run an activity are common to all or most 
adapters. For example:

Configuring Adapters

For specific information about installing and configuring an adapter, see the topics in this chapter. For 
general information about adapters, see Configuring Security, page 10-16.

Creating Targets

Before you can create or run processes in your Process Orchestrator environment, you must create the 
targets on which the processes will run. Targets define specific environments where certain processes, 
activities, or triggers will run.

You can define a target once and then reuse it in multiple processes. To define a target, see Defining a 
Target, page 2-13.

Creating Runtime User Accounts

When creating targets, a runtime user account must be specified to be used to connect to the target. The 
runtime user account stores the information about the user security context for the target. 

You can create the runtime user accounts during the process of creating the targets or prior to creating 
the targets. To create a runtime user account, see Defining Runtime Users, page 2-14.

Creating Triggers

Triggers are events and conditions in the system that determine how or when the process will be 
executed. Using a trigger, for example, you can subscribe to an existing queue and fire an event trigger 
based on the message that is generated. See Creating Triggers, page 11-1.

Target General Tab

Use the General tab to enter general information about a target. The information displayed depends on 
the configured target.
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Target Configuration Tab

Use the Configuration tab to specify the character restrictions for a database identifier. A distinction is 
made between simple identifiers and special identifiers.

Target Permission Tab

Use the Permission page to define the permissions for SQL commands that can run on the target.

Target General Information

Use the New [Object] Wizard General Information panel to specify the display name and description for 
the new target.

Completing the New Object Wizard Panel

The Completing the New [Object] Property Wizard panel displays name of the new object.

Review the information to verify that it is correct and click the appropriate button to complete wizard 
process.

User Assignments tab

Use the User Assignments tab to add and modify security role information between the security principal 
and the permissions.

The User Assignment tab binds the security principal (either a user or group) and defined security 
permissions for the security role.

Add

Click this to launch the select User or Group dialog box and change the owner.

Remove

Removes the selected principal from the list of the owners assigned to the security role.
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Configuring Adapters
Adapters are one of the extensibility mechanisms used to extend Process Orchestrator functionality to 
integrate with devices, environments, applications, or tools without undergoing core modification. 
Examples of adapters include:

• The primary adapter for Cisco Process Orchestrator is the Core Functions Adapter. This adapter 
provides the core features and objects to be used to manage IT processes.

• Microsoft Windows Adapter provides Windows objects, such as the Windows computer target, 
Windows runtime user, and Windows-related activities.

Use the Administration > Adapters view to display the adapters that are installed with the product and 
their associated objects.

Viewing Adapter Prerequisites
Each adapter can have prerequisites that must be satisfied before the adapter can be fully functional. For 
example, the Core Functions Adapter has no prerequisites, but the SAP ABAP Adapter requires the SAP 
.NET 3.0 connector; without this connector, the SAP ABAP adapter will not function correctly.

Prerequisites apply to particular Process Orchestrator servers, so prerequisites can be satisfied on one 
server but not on another. This means that sometimes an adapter might be functional on one server and 
not on another if the prerequisites are not met on that other server. If you are running in a high availability 
environment, it is important that all required adapter’s prerequisites are satisfied on all Process 
Orchestrator servers.

To check the status of the prerequisites for each adapter:

Step 1 Choose Administration > Adapters, then double-click an adapter name.

Step 2 In the [adapter name] Adapter Properties dialog, click the Prerequisites tab.

Step 3 If your environment contains more than one server, you can view the prerequisites for each server. 
Choose Administration > Orchestration Servers > PO Server properties > Prerequisites.

Viewing Adapter Properties
To view general information related to the adapter, the specific functions that the adapter provides, and 
a history of changes that have been made to the adapter, choose Administration > Adapters > Adapter 
Properties. The information on the property dialog for each adapter varies. 

Viewing Objects Provided by the Adapter
Each adapter provides specific functionality within Process Orchestrator. Use the Provides tab in the 
Administration > Adapters > Adapter Properties dialog to view the functionality that is provided by an 
adapter.
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Advance Message Queuing Protocol (AMQP) Adapter
The Cisco Advanced Message Queuing Protocol (AMQP) software adapter allows you to automate 
messaging activities on Cisco AMQP instances. 

The following table displays activities that are provided by the AMQP adapter. For more information 
about using these activities, see Getting Started Using the AMQP Adapter, page 12-4. 

Getting Started Using the AMQP Adapter
Use the following process to monitor and manage Cisco AMQP instances. 

Step 1 Create a Cisco AMQP target (see Defining an AMQP Broker Target, page 12-5).

Step 2 Define a Cisco AMQP command activity (see Automating Cisco AMQP Tasks, page 12-6). 

Step 3 View the activity results (see Monitoring Operations, page 8-1).

Activity Action

Declare Exchange Declare an exchange on the AMQP broker.

See Declaring an AMQP Exchange, page 12-6.

Declare Queue Declare a queue on the AMQP broker.

See Declaring an AMQP Queue, page 12-6.

Bind Queue Bind a queue to an exchange on the AMQP broker.

See Binding an AMQP Queue to an Exchange, page 12-7.

Publish Message Publish a text message to a an existing exchange on the AMQP broker.

See Advance Message Queuing Protocol (AMQP) Adapter, page 12-4.

Get Message Get a message from a given queue on the AMQP broker.

See Getting a Message, page 12-8.

Purge Queue Purge a queue.

See Purging an AMQP Queue, page 12-8.

Unbind Queue Unbind a queue from an exchange. 

See Unbinding an AMQP Queue, page 12-8.

Delete Queue Delete a queue. 

See Deleting an AMQP Queue, page 12-9.
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Managing AMQP Messages

Receiving Messages Based on a Pattern

You can define policies that automatically trigger specific workflows based on certain AMQP messages. 
 A message-based event starts only when the message matches all of the criteria on both the Content 
Header and Message pages.

To create the message-based event:

Step 1 Choose AMQP Message Event Properties.

Step 2 Choose an existing queue.

Step 3 Add the message criteria and message body to the message event.

Step 4 Use an AMQP Message Event trigger to fire an event trigger based on the message that is generated.

Defining an AMQP Broker Target
Use the AMQP Broker target to configure the connection information to a vCloud Directory server to be 
used for process and activities to run against.

Step 1 Choose Definitions > Targets > New > AMQP Broker.

Step 2 On the General panel, enter the required information.

Step 3 On the Connection panel, specify the connection information for the AMQP broker, including:

• Host—The host name or IP address for the AMQP Broker.

• Port—The AMQP protocol port number; the default port is 5672.

• Virtual Host—The virtual host name or IP address for the AMQP Broker.

• Default runtime user—The runtime user required to execute a process or activity against this target.

• SSL enabled—Indicates if SSL is enabled on the AMQP Broker.

• Ignore certificate error— Ignore the certificate error messages when attempting to connect to the 
service portal.

Step 4 On the Finish panel, click Finish to complete the target definition.
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Automating Cisco AMQP Tasks

Declaring an AMQP Exchange

Use the Declare Exchange activity to create or check an AMQP broker exchange.

Step 1 In the Process Editor Toolbox, choose AMQP > Declare AMQP Exchange, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Note Exchange names must be unique within a virtual host.

Step 3 Click the Declare Exchange tab and specify the information that describes the exchange, including:

• Type— type of exchange you want to declare (see Managing AMQP Messages, page 12-5).

• Durable—Durable exchanges last until they are deleted. Temporary exchanges last until the server 
shuts-down. Not all scenarios and use cases require durable exchanges.

• Auto delete—Auto-deleted exchanges last until they are no longer used.

• Arguments—Enter the name and value pair arguments for the queue

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Declaring an AMQP Queue

Use the Declare Queue activity to create or check a queue on the AMQP broker. This activity will create 
a queue if the queue does not already exist. 

When you declare a new queue, you can specify various properties that control the durability of the 
queue and its contents and the level of sharing for the queue.

Step 1 In the Process Editor Toolbox, choose AMQP > Declare AMQP Queue, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Note Message queue names must be unique within a virtual host.

Step 3 Click the Declare Queue tab and specify the information that describes the queue, including:

• Durable—Whether the queue is durable or transient. Durable queues survive broker restart whereas 
transient queues do not (they must be redeclared when the broker comes back online). Not all 
scenarios and use cases require durable queues.

• Auto delete—Delete the queue when it is empty.

• Exclusive—The queue belongs to the current connection only, and is deleted when the connection 
closes.
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• Arguments—Enter the name and value pair arguments for the queue

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Binding an AMQP Queue to an Exchange

Use the Bind Queue activity to bind a queue to an AMQP broker exchange. 

Step 1 In the Process Editor Toolbox, choose AMQP > Bind AMQP Queue, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Bind Queue tab and specify the information that describes the queue binding, including:

• Queue Name—Name of the queue you want to bind to an exchange.

• Exchange Name—Name of the exchange you want to bind to a queue.

• Routing Key—The key to be sent with the message.

• Arguments—Enter the name and value pair arguments for the queue

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Publishing a Message

Use the Publish Message activity to publish a text message to an existing exchange on the AMQP broker. 
The message will be routed to queues as defined by the exchange configuration and distributed when the 
transaction, if any, is committed.

For example, VMWare vCloud Director can publish vCloud AMQP Messages (also known as blocking 
tasks, notifications, or call-outs) related to different provisioning tasks. A Process Orchestrator can not 
only receive these events, but can respond to them to delay execution.

Step 1 In the Process Editor Toolbox, choose AMQP > Publish AMQP Message, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Publish Message tab and specify the information that describes the message to be published.

Step 4 To define the content header for the message, click Add to display the Content Header dialog box.

Step 5 Click the Message tab to define the header and body of the message. Click Add to display the Message 
Header dialog box.

Step 6 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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Getting a Message

Use the Get Message activity to retrieve the next available message from a given queue on the AMQP 
broker. 

Note This activity will open and close the channel to get one message; it is not designed to put it into 
a tight loop. This activity is considered to be a destructive way to get a message from an AMQP 
queue. The typical way is to subscribe to an AMQP queue. 

Step 1 In the Process Editor Toolbox, choose AMQP > Get AMQP Message, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Get Message tab and specify the information that describes the message to be retrieved, 
including:

• No Acknowledgment Mode—If this option is checked, no acknowledgment is sent after retrieving 
the message. The server will auto-acknowledge the message.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Purging an AMQP Queue

Use the Purge Queue activity to remove all messages from a queue that are not awaiting acknowledgment 
on the AMQP broker. In the Process Editor Toolbox on the [AMQP Activity] property page, click the 
Purge Queue tab, then choose the queue to be purged.

Unbinding an AMQP Queue

Use the Unbind Queue activity to remove the binding between the queue and the exchange. After the 
binding has been removed, the queue will not receive any more messages until it is bound to another 
exchange. 

Step 1 In the Process Editor Toolbox, choose AMQP > Unbind AMQP Queue, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Unbind Queue tab and specify the information that describes the queue you want to unbind, 
including:

• Name—Name of the queue you want to unbind from an exchange.

• Exchange Name—Name of the exchange you want to unbind from a queue.

• Routing Key—The key the messages will be sent with.

• Arguments—Enter the name and value pair arguments for the queue
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Deleting an AMQP Queue

Use the Delete Queue activity to delete a queue from the AMQP broker. When a queue is deleted, any 
pending messages are sent to a dead-letter queue if this is defined in the server configuration, and all 
consumers on the queue are canceled.

Step 1 In the Process Editor Toolbox, choose AMQP > Delete AMQP Queue, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Delete Queue tab and specify the information that describes the queue you want to unbind, 
including:

• Name—Name of the queue you want to delete

• Delete only if queue is not used—Indicates if queue will only be deleted if it is not used.

• Delete only if queue is empty—Indicates if queue will only be deleted if it is empty.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

AMQP Activities Instance Properties

Argument Instance Dialog
The Argument display-only dialog box displays additional arguments given on queue declaration, 
including the name and value for the given key.

AMQP Message Event Instance Properties Message Tab
The Message display-only tab displays the attributes used for routing Header exchanges route messages 
based on message header matching. 

AMQP Message Event Instance Properties, Advanced Tab
The Advanced display-only tab displays the advanced attributes used for the AMQP event.
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Bind Queue
The Bind Queue display-only tab displays the defined parameters used for binding a queue to an 
exchange on the AMQP broker. 

Content Header
The Content Header display-only tab displays the properties defined for how the AMQP message 
displays in the header of the message.

Declare Exchange
The Declare Exchange display-only tab displays the properties used to declare an exchange on the 
AMQP broker.

Declare Queue
The Delete Queue display-only tab displays the properties used to declare a queue on the AMQP broker.

Delete Queue
The Delete Queue display-only tab displays the properties used to delete a queue on the AMQP broker.

Exchange
The Exchange display-only tab displays the selected objects properties.

Get Message
The Get Message display-only tab displays the properties used to subscribe to an existing queue and fire 
an event trigger based on the message criteria.

Message Tab
The Message display-only tab displays the properties used to define the header and body of a message.

Publish Message
The Publish Message display-only tab displays the properties used to define the text message to an 
existing exchange on the AMQP broker with a routing key.
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Purged Messages
The Purged Messages display-only tab displays the properties used to purge messages in a queue on the 
AMQP broker.

Purge Queue
The Purge Queue display-only tab displays the properties defined to purge messages in a queue on the 
AMQP broker.

Unbind Queue
The Unbind AMQP Queue display-only tab displays the properties used to unbind a queue from an 
exchange on the AMQP broker. 

Microsoft Service Bus Adapter
The Microsoft Service Bus Adapter integrates Microsoft Service Bus API into Cisco Process 
Orchestrator and allows you to automate messaging activities. You can use Microsoft Service Bus 
implementation for Windows Server 1.1 on premises. For more details see, Getting Started with Service 
Bus for Windows Server 1.1.

Note You must export certificate to client machine (Process Orchestrator Server) to enable remote clients to 
connect to a Service Bus for Windows Server.

The following table displays activities that are provided by the Microsoft Service Bus adapter.

Getting Started Using the Microsoft Service Bus Adapter
Use the following process to monitor and manage Service Bus instances. 

Step 1 Create a Microsoft Service Bus target (see Defining an Microsoft Service Bus Target, page 12-12).

Step 2 Define a Microsoft Service Bus activity (see Automating Microsoft Service Bus Tasks, page 12-13). 

Step 3 View the activity results (see Monitoring Operations, page 8-1).

Activity Action

Send Message Send a message to a given queue.

See Sending a Message, page 12-13.

Get Message Get a message from a given queue.

See Getting a Message, page 12-13
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Managing Service Bus Messages

Receiving Messages Based on a Pattern

You can define policies that automatically triggers specific workflows based on certain Service Bus 
messages.  A message-based event starts only when the message matches all criteria on both the Content 
Header and Message pages.

To create the message-based event:

Step 1 Choose Service Bus Message Event Properties.

Step 2 Choose an existing queue.

Step 3 Add the message criteria and message body to the message event.

Step 4 Use an Service Bus Message Event trigger to fire an event trigger based on the message that is generated.

Defining an Microsoft Service Bus Target
Use the Microsoft Service Bus Broker target to configure the connection information to a vCloud 
Directory server to be used for process and activities to run against.

Step 1 Choose Definitions > Targets > New > Microsoft Service Bus.

Step 2 On the General panel, enter the required information.

Step 3 On the Connection panel, specify the connection information for the Microsoft Service Bus broker, 
including:

• Namespace—The container of queues, topics with subscriptions for the Service Bus.

Note You can create 1 or more namespace, when you register in the Microsoft Service Bus portal.

• Service Bus Windows Server — Enter the following information:

– Server — Enter the host name or IP address.

– Runtime Port — Enter the Runtime port number. By default it is 9354.

– Management Port — Enter the Management Port number. By default it is 9355.

• Shared access key—Enter the access key of the account.

• Connection String — Displays the string information about the data source.

Step 4 Click Ok to complete the target definition.

New Shared Access Key Properties

Use the New Shared access key properties to create an access key for the service bus.
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Step 1 Choose Definitions > Targets > New > Microsoft Service Bus.

Step 2 On the Connection panel, choose New > Shared Access Key.

Step 3 Enter the Shared access key name and Shared access key for the Service Bus.

Step 4 Click Ok to complete the key properties definition.

Automating Microsoft Service Bus Tasks

Sending a Message

Use the Send Message activity to publish a text message to an existing exchange on the Service Bus 
broker. The message is routed to queues as defined by the exchange configuration and distributed when 
the transaction, if any, is committed.

Step 1 In the Process Editor Toolbox, choose Microsoft Service Bus > Send Message, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Publish Message tab and specify the information that describes the message to be published.

You can either use the Queue name or Topic name.

Step 4 To define the content header for the message, click Add to display the Content Header dialog box.

Step 5 Click the Message tab to define the header and body of the message. Click Add to display the Message 
Header dialog box.

Step 6 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

For more detail on Microsoft Service Bus, see Microsoft Service Bus Adapter

Getting a Message

Use the Get Message activity to retrieve the next available message from a given queue. 

Step 1 In the Process Editor Toolbox, choose Microsoft Service Bus > Get Message, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Get Message tab and specify the information that describes the message to be received.

You can either use the Queue name or Subscription name.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

For more detail on Microsoft Service Bus, see Microsoft Service Bus Adapter
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Cloud Center Adapter
The Cloud Center adapter integrates Cloud Center API into Cisco Process Orchestrator, so you can 
automate cloud deployments and control various aspects of cloud infrastructure provided by Cloud 
Center.

Defining a Cloud Center Target
Use the Cloud Center Target to configure the connection information to the Cloud Center server.

Step 1 Choose Definitions > Targets > New > Cloud Center Server.

Step 2 On the General panel, enter the required information.

Step 3 On the Connection panel, specify the following connection information:

• Server name — Enter the Server name for the cloud center.

Note The server name is the property of the target which contains the host part of the URI - a 
registered name or an IP address.

For more information, see https://en.wikipedia.org/wiki/Uniform_Resource_Identifier

• Port — Enter the port number (default is 443). You can enter values from 1 to 65535.

• Ignore Secure Socket Layer (SSL) certificate error — Check the check box to ignore the SSL 
certificate error.

Note You can ignore certificate chain errors only, which is useful to test against the servers with 
self-generated certificates, without importing the certificates on the client machine.

• Runtime user — Select the Runtime user from the drop–down list or choose New to create a New 
Cloud Center Manage API Access Key.

Step 4 Click OK, to create the connection.

New Cloud Center API Access Credentials Properties

Use the New Cloud Center API Access Credentials properties to create an access credentials for the 
Cloud Center.

Step 1 Choose Definitions > Targets > New > Cloud Center Server.

Step 2 On the Connection panel, choose New > Cloud Center API Access Credentials.

Step 3 Enter the User name for the Cloud Center.

Step 4 Check the API Key check box, and enter the API key.

Step 5 Click OK to complete the key properties definition.
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Execute Cloud Center Command
Use the Execute Cloud Center Command activity to execute Cloud Center API command against a Cloud 
Center server. The Cloud Center activity provides a flexible way to perform the desired action using the 
request methods. Responses for common information are scanned and displayed as activity results in the 
Operations Workspace activity instance view.

Step 1 In the Process Editor Toolbox, choose CloudCenter > Execute Cloud Center Command, then drag and 
drop the activity onto the workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Request tab and specify the following information:

• Path — Enter the Relative URI part of the request. 

For example:

v1/users
v1/users/userId
v1/users/userId?detail=true

For more information, see http://docs.cliqr.com/display/40API/Base+URI+Format.

• Method — Select the required Method from drop–down list:

– GET — To query or view the server information based on a CloudCenter deployment.

– PUT — To replace the entire object for update operations.

– POST — To perform a CloudCenter platform task or creating the resource.

– DELETE — To remove specific aspects of the CloudCenter deployment.

Note The CloudCenter APIs use HTTPS Version 1 to support these request methods.

For more information on HTTPS request methods see, 
http://docs.cliqr.com/display/40API/HTTPS+Request+Methods

• Content Type — Select the required Content type from the drop–down list. Values are:

– JSON

– XML

• HTTP Message Body — You can send a message body with following methods. Values are: 

– PUT

– POST

– DELETE

Note GET request is not sent as part of the request and hence cannot have an HTTP message body.

• Timeout — Check the check box and then enter the time period the activity should wait before 
failing.

Note Click the time unit link to change the time interval.
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Cloud Center Response

The Response tab displays the properties of the HTTP Response received from the API call.

• HTTP Status Code — Displays the Status code of the response. This may indicate whether a request 
is success or failure.

The Cloud Center API can only return a limited set of HTTP status codes. For more information on 
HTTP Status codes, see 
http://docs.cliqr.com/display/40API/CloudCenter+API+Overview#CloudCenterAPIOverview-HT
TPStatusCodes.

• HTTP Reason Phrase — Displays the HTTP reason phrase for the process activity.

• HTTP Message Body — Displays the HTTP message body in JSON or XML.

For more information on HTTP response message see, 
https://en.wikipedia.org/wiki/Hypertext_Transfer_Protocol#Response_message

BMC Remedy Adapter
The Cisco Remedy Adapter provides activities for automating tasks on Cisco Remedy instances. Typical 
Remedy command activities include:

• Creating an entry in any Remedy form.

• Initiating an incident request review. These reviews can be performed periodically to analyze 
incident request information and identify potential problems.

Remedy defines an incident as an event that is not part of the standard operation of a service and 
that causes an interruption to or a reduction in the quality of that service.

Incident management is typically initiated in response to a customer call or automated event, such 
as an alert from a monitoring system. The primary goal of the incident management process is to 
restore normal service operation as quickly as possible with minimum disruption.

• Creating a relationship between an incident request and a problem (Remedy does this automatically 
when a problem investigation is created from an incident request).

• Adding a new Work Info entry, such as files and customer email messages, to an existing Remedy 
property. Use this activity to add general notes about the current record, such as the date a particular 
configuration item was deployed, or vendor-related notes, such as a bulletin sent from a vendor.

Note All Cisco Process Orchestrator Remedy activities are based on forms that can be customized by the user. 
This can cause a misunderstanding as to whether the fields on the forms are required or optional.

The following table displays activities that are provided by the BMC Remedy adapter. For more 
information about using these activities, see Getting Started Using the Remedy Adapter, page 12-18. 
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Prerequisites

Installing Remedy client C API Library Files

The Remedy adapter requires the Remedy client C API libraries to be installed in order to communicate 
with Remedy servers. Before you can create a Remedy Server target, the dll files must be installed on 
the Cisco Process Orchestrator server. 

Activity Comments

Create Remedy Entry Create an entry in any Remedy form.

See Selecting an Association Type, page 12-26.

Create Remedy Incident Create an incident on a Remedy server using selected properties.

See Initiating an Incident Request Review, page 12-19.

Create Remedy Relationship Configure a relationship between incidents and configuration items.

See Creating a Relationship Between an Incident Request and a 
Problem, page 12-20

Create Remedy Work Info Add a new Work Info entry to an existing Remedy property. 

See Adding a New Work Info Entry to an Existing Remedy Property, 
page 12-22

Delete Remedy Entry Remove entries, such as relationships, work log entries, or custom 
entries from a Remedy item.

See Deleting a Remedy Entry, page 12-22

Find Remedy Objects Query objects, configuration items, and other assets to create 
relationships. It can also be used to find any entry on a Remedy server.

See Finding Remedy Objects, page 12-23

Get Remedy Entry Property 
Values

Retrieve property values for a specific entry on a Remedy server. If the 
entry ID is known, this activity can be a better alternative than the Find 
Remedy Objects activity, which allows a broader set of parameters.

See Get Remedy Entry Property Values, page 12-23

Get Remedy Incident 
Property Values

Retrieve property values for a specific incident on a Remedy server. If 
the incident ID is known, this activity can be a better alternative than 
the Find Remedy Objects activity, which allows a broader set of 
parameters.

See Get Remedy Incident Property Values, page 12-24

Update Remedy Entry Update the entries in a specific Remedy form. This activity can also be 
used to update the properties in a Work Info or Relationship entries.

See Defining an Update Remedy Entry Activity, page 12-24

Update Remedy Incident Update the properties for a specific Remedy incident. 

See Defining an Update Remedy Incident Activity, page 12-25
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Step 1 Download the API zip file from the BMC community site (see 
https://communities.bmc.com/docs/DOC-33310). 

Step 2 From the folder where the dll files are extracted, locate the following files:

• arapi81_build001_win64.dll

• arrpc81_build001_win64.dll

• arutl81_build001_win64.dll

• arxmlutil81_build001_win64.dll

• icudt32.dll, icuinbmc32_win64.dll

• icuucbmc32_win64.dll

Step 3 Copy the files to the following folder on the Orchestrator server:

<Install drive>:\Program Files\Cisco\Process Orchestrator\Adapters\Remedy

Step 4 Verify the properties of the dll files and unlock them, if necessary.

Getting Started Using the Remedy Adapter
Use the following process to monitor and manage Cisco BMC Remedy instances. 

Step 1 Create a Cisco Remedy target (see Defining a Remedy Server Target, page 12-18).

Step 2 Define BMC Remedy activities: 

a. In the Process Editor Toolbox, choose BMC Remedy > [BMC Remedy Activity], then drag and 
drop the activity onto the Workflow pane.

b. Click the General tab and enter the required information.

c. Click the [Activity-Specific] tabs to define the properties specific to the activity. 

d. Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

For details about a specific activity, see Managing Remedy Tasks, page 12-19.

Step 3 View the activity results (see Monitoring Operations, page 8-1).

Defining a Remedy Server Target
Use the Remedy Server target to specify the connection information to a Remedy server which is used 
for processes to run against. Define the Remedy target before attempting to define any Remedy 
activities. The Remedy target accesses the list of properties on the Remedy server.

Step 1 Choose Definitions > Targets, right-click, and choose New > Remedy Server.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Connection tab to specify the connection information to a Remedy server, including:

• Remedy Server Name—Host name or the IP address of Remedy server
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• Port—Port number used to access the Remedy server (Default: 0)

Step 4 Click the Polling tab to configure the frequency in which Process Orchestrator queries a Remedy system.

Step 5 Click OK to close the dialog box and complete the procedure.

Managing Remedy Tasks

Creating a Remedy Entry

Use the Create Remedy Entry activity to create an entry in any Remedy form.

Before You Begin

A Remedy server must be installed and accessible. For installation information, see the BMC Remedy 
documentation.

Step 1 In the Process Editor Toolbox, choose BMC Remedy > Create Remedy Entry, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 On the Entry tab, specify the form properties and associated values to be used to create a Remedy entry, 
then click Add.

• Form Name—Enter the name of the form containing the entry properties.

Step 4 In the Select Properties box, choose the Remedy server from which the properties will be added to the 
entry.

Step 5 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Initiating an Incident Request Review

Before You Begin

A Remedy server must be installed and accessible. For installation information, see the BMC Remedy 
documentation.

Step 1 In the Process Editor Toolbox, choose BMC Remedy > Create Remedy Incident, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Incident tab, then specify the properties and associated values to be used to create a Remedy 
incident.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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Creating a Relationship Between an Incident Request and a Problem

Use the Create Remedy Relationship activity to create a relationship between an incident request and a 
problem (Remedy does this automatically when a problem investigation is created from an incident 
request). You can use this activity to create the following types of relationships:

• Incident -> Configuration item

• Incident -> Incident

• Configuration -> Incident

• Configuration -> Configuration

Note Because of operations outside of Process Orchestrator control, such as power failure or network outage, 
only one side of the relationship can be created by the Create Remedy Relationship activity.

Before You Begin

A Remedy server must be installed and accessible. For installation information, see the BMC Remedy 
documentation.

Step 1 In the Process Editor Toolbox, choose BMC Remedy > Create Remedy Relationship, then drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Item 1 or Item 2 tab to continue and select the appropriate item to configure the relationship 
properties.

• Item Type—From the drop-down list, select the appropriate item to configure the relationship 
properties.

– Incident—See Configuring Relationship Incident Properties, page 12-25.

– Configuration—See Selecting an Association Type, page 12-26.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Adding Properties to a Remedy Activity

When configuring the activity properties, you might be required to add properties to the activity. Sort 
the properties list by the column Type so that all of the required fields for your system are displayed at 
the top of the list.

The Select Properties dialog box is launched when the Add button on the activity-specific property page 
is clicked. Use the Select Properties dialog box to specify the incident properties for the activity.

Step 1 On the activity-specific property page tab, click Add.

Step 2 From the Add properties from the following server drop-down list, select the appropriate server from 
the drop down list.

Step 3 Highlight the appropriate incident properties, then click OK.

Step 4 On the Edit Property dialog box, assign a value to the incident property.
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Step 5 Repeat Step 2 through Step 4 to add additional incident properties to the activity.

Configuring Relationship Configuration Item Properties

Use the following steps to define the configuration item properties on the Create Remedy Relationship 
activity.

Step 1 Click the appropriate Item tab, then choose Item Type > Configuration Items.

Step 2 Complete the following configuration item fields, then click Save:

• Reconciliation ID—Enter the reconciliation ID of the Remedy configuration item.

• Configuration item form name—Enter the name of the form containing the configuration properties.

• Association type—Enter the type of incident property to associate with the Remedy item (see 
Selecting an Association Type, page 12-26).

• Request description—Enter a description to associate with the incident or configuration item. For 
example, this could be the name of the item or the name of the related item.

Viewing Results

Click the Item display-only tabs to view the properties of the activity.

• Reconciliation ID—reconciliation ID of the Remedy configuration item

• Configuration item form name—name of the form containing the configuration properties

• Association type—type of incident property to associate with the Remedy item

• Request description—description associated with the incident or configuration item.

Adding Incident Properties to a Remedy Trigger

When configuring a Remedy trigger, you can add incident properties to the trigger which can then be 
used as additional criteria to monitor for incidents. Sort the properties list by the column Type so that all 
of the required fields for your system are displayed at the top of the list.

The Select Properties dialog box is launched when the Add button on the Incident Update Criteria tab is 
clicked. Use the Select Properties dialog box to specify the incident properties for the trigger.

Before You Begin

A Remedy server must be installed and accessible. For installation information, see the BMC Remedy 
documentation.

Step 1 Choose the Incident Update Criteria tab, click Add, then choose Wildcard match or Exact match.

Step 2 On the Remedy Incident Updated Properties dialog box, select the incident update type, click Add, then 
select the appropriate server from the drop down list. The Remedy server incident properties display in 
the columns.
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Step 3 Highlight the appropriate incident properties, then click OK.

Step 4 Assign a value to the incident property, then click OK.

Adding a New Work Info Entry to an Existing Remedy Property

Use the Create Remedy Work Info activity to add general notes about the current record, such as the date a 
particular configuration item was deployed, or vendor-related notes, such as a bulletin sent from a vendor.

This activity can be used to add attachments, such as files and customer emails to the work info property. 
For information on adding attachments to the activity, see Attaching a File to a Remedy Activity.

Before You Begin

A Remedy server must be installed and accessible. For installation information, see the BMC Remedy 
documentation.

Step 1 In the Process Editor Toolbox, choose BMC Remedy > Create Remedy Work Info, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Work Info tab and modify the list of Remedy work info properties. For information about 
adding attachments to the activity, see Configuring Relationship Incident Properties, page 12-25.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Deleting a Remedy Entry

Use the Delete Remedy Entry activity to remove entries, such as relationships, work log entries, or 
custom entries from a Remedy item.

Step 1 In the Process Editor Toolbox, choose BMC Remedy > Delete Remedy Entry, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Entry tab and enter:

Field Description

Name Name of the incident property

ID ID number of the Remedy incident

Type Type of Remedy property

• Display

• Optional

• Read-only

• Required
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• Form Name—Enter the name of the form containing the entry properties.

Click Browse to launch the Select a Form dialog box to select the form containing the entry 
properties to be removed by the activity.

• Entry ID—ID number of the Remedy 

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Finding Remedy Objects

Use the Find Remedy Objects activity to query objects, configuration items, and other assets in order to 
create relationships. It can also be used to find any entry on a Remedy server.

All Cisco Process Orchestrator Remedy activities are based on forms which can be customized by the 
user. This may cause user misunderstanding as to whether the fields on the forms are required or 
optional.

Step 1 In the Process Editor Toolbox, choose BMC Remedy > Find Remedy Entry, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Criteria tab and enter:

• Form Name—Enter the name of the form containing the entry properties.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Get Remedy Entry Property Values

Use the Get Remedy Entry Property Values activity to retrieve property values for a specific entry on a 
Remedy server. If the entry ID is known, then this activity may be a better alternative than the Find 
Remedy Objects activity which allows a broader set of parameters.

All Cisco Process Orchestrator Remedy activities are based on forms which can be customized by the 
user. This may cause user misunderstanding as to whether the fields on the forms are required or 
optional.

Step 1 In the Process Editor Toolbox, choose BMC Remedy > Get Remedy Entry Property Values, then drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Entry tab and enter:

• Form Name—Enter the name of the form containing the entry properties.

Click Browse to launch the Select a Form dialog box to select the form containing the entry 
properties to be removed by the activity.

• Entry ID—Enter the Remedy entry ID number or click the Reference tool to select the appropriate 
Remedy entry value to be retrieved.
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

The Properties to Get box displays the list of Remedy properties to be retrieved by the activity.

Get Remedy Incident Property Values

Use the Get Remedy Incident Property Values activity to retrieve property values for a specific incident 
on a Remedy server. If the incident ID is known, then this activity may be a better alternative than the 
Find Remedy Objects activity which allows a broader set of parameters.

All Cisco Process Orchestrator Remedy activities are based on forms which can be customized by the 
user. This may cause user misunderstanding as to whether the fields on the forms are required or 
optional.

Step 1 In the Process Editor Toolbox, choose BMC Remedy > Get Remedy Incident Property Values, then 
drag and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Incident Property Values tab and enter:

• Incident ID—Enter the Remedy incident number or click the Reference tool to select the appropriate 
Remedy incident values to be retrieved

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

The Properties to Get box displays the list of Remedy properties to be retrieved by the activity.

Defining an Update Remedy Entry Activity

Use this activity to update the entries in a specific Remedy form, or to update the properties in a Work 
Info or Relationship entry.

Step 1 In the Process Editor Toolbox, choose BMC Remedy > Update Remedy Entry, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Entry tab and enter:

• Form Name—Enter the name of the form containing the entry properties.

• Entry ID—Enter the Remedy entry ID number or click the Reference tool to select the appropriate 
Remedy entry value to be retrieved.

• Properties to update—See Adding Properties to a Remedy Activity, page 12-20

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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Defining an Update Remedy Incident Activity

Use this activity to update the properties for a specific Remedy incident. 

Step 1 In the Process Editor Toolbox, choose BMC Remedy > Update Remedy Incident, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Incident tab and enter:

• Incident ID—Enter the Remedy incident number or click the Reference tool to select the appropriate 
Remedy incident values to be retrieved

• Properties to update—See Adding Properties to a Remedy Activity, page 12-20

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Selecting a Remedy Form

Use the Select a Form dialog box to select the form containing the properties to be added to a Remedy 
activity. Activities requiring entry IDs will contain the option to locate the appropriate form on the 
Remedy server.

Step 1 On the Remedy entry activity tab, click Browse.

Step 2 From the Add a form from the following Remedy Server drop-down list, select the appropriate 
Remedy server target defined in Process Orchestrator. The displayed forms depend on the server that is 
selected.

Step 3 From the Selected form list, select the appropriate form containing the available properties to add to the 
Remedy entry. Only one form can be selected at a time.

Step 4 Click OK to select the Remedy form.

Configuring Relationship Incident Properties

Use the following steps to configure the incident properties on the Create Remedy Relationship activity. 

Step 1 Click the appropriate Item tab, then choose Item Type > Incident.

Step 2 Complete the following incident fields, then click Save:

• Incident ID—Enter the Incident ID number of the Remedy incident.

• Association type—Enter the type of incident property to associate with the Remedy item (see 
Selecting an Association Type, page 12-26).

• Request description—Enter a description to associate with the incident or configuration item. For 
example, this could be the name of the item or the name of the related item.
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Selecting an Association Type

Use the Select a Property Value dialog box to select the appropriate values to associate the relationship 
with the Remedy item.

Step 1 On the Remedy activity tab, click Browse.

Step 2 From the Select the property value using the Remedy Server drop-down list, select the appropriate 
Remedy server target defined in Process Orchestrator. The displayed fields depend on the selected 
Remedy server.

Step 3 From the Selected field value list, select the appropriate fields containing the available properties to add 
to the Remedy relationship.

Step 4 Click OK to select the Remedy field.

Attaching a File to a Remedy Activity

Use the following steps to attach a file to a Remedy activity. When attaching a file to a Remedy activity, 
the file path should be a local path accessible on the Process Orchestrator server machine or a network 
share path.

Note If an attachment is present in the activity, a Windows user must be specified. 

Step 1 On the appropriate Remedy activity property page, click the Credentials tab to specify the Windows 
runtime user for the remedy activity.

Step 2 Check the Use the following credentials for Remedy attachments check box, then specify the 
credentials to be used to access the attachment.

To view the properties for the selected runtime user, click the Properties icon. To create a runtime user 
record for the process, click New > [Runtime User].

Step 3 Click the Remedy activity-specific tab, then click Add.

Step 4 From the Add properties from the following server drop-down list, select the appropriate server.

Step 5 Scroll to the property labeled Attachment, or sort by the Data Type Attachment, and click OK.

When attaching multiple files, use the Attachment property labeled by number (for example, Attachment 
1, Attachment 2).

Step 6 In the Attachment field, enter the path to the appropriate file.

Step 7 Click OK to save the attachment to the Remedy activity property and return to the Remedy object tab.
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Instance Properties

Create Remedy Entry

The Entry display-only tab displays the properties used to add an entry on a Remedy incident.

• Form Name—Name of Remedy form containing the entry properties used for selection by the Create 
Remedy Entry activity.

The following columns display the list of properties added to the Create Remedy Entry activity.

• Name—Name of the property

• ID—ID number of the Remedy property

• Label—Label of the property

• Data Type—Type of Remedy property

– Display

– Optional

– Read-Only

– Required

Create Remedy Entry Results

The Results display-only tab displays the number created by the remedy entry activity.

• Entry ID— New ID number of the newly created Remedy entry

Create Remedy Incident

The Incident display-only tab displays the list of properties added to the Create Remedy Incident 
activity.

• Name—Name of the Remedy property

• Label—Label of the Remedy property

• Value—Value assigned to the Remedy property

• ID—Incident ID of the property

• Data Type—Type of Remedy property

– Display

– Optional

– Read-Only

– Required

Create Remedy Incident Results

The Results display-only tab displays the incident number created by the remedy incident activity

• Incident ID—New ID number of the newly created Remedy incident
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Create Remedy Relationship, Configuration

The Item display-only tab displays the properties used to configure relationships between incidents and 
configuration items.

• Item Type—Selected item used to configure the relationship properties

• Reconciliation ID—ID of the Remedy configuration item

• Configuration item form name—Name of the form containing the configuration properties 
associated with the activity

• Association type—Type of configuration property to associate with the Remedy item

• Request description—Description associated with the incident or configuration item

The following columns display the list of Remedy properties added to the item.

• Name—Name of the Remedy property

• Label—Label of the Remedy property

• Value—Value assigned to the Remedy property

• ID—ID number of the Remedy item

• Data Type—Type of Remedy property

– Display

– Optional

– Read-Only

– Required

Create Remedy Relationship, Incident

The Item display-only tab displays the properties used to configure relationships between incidents and 
configuration items.

• Item Type—From the drop-down list, select the appropriate item to configure the relationship 
properties.

• Incident ID—Incident ID number of the Remedy incident

• Association type—Type of incident property to associate with the Remedy item

• Request description—Description associated with the incident or configuration item

The following columns display the list of Remedy properties added to the incident.

• Name—Name of the Remedy property

• Label—Description of the Remedy property

• Value—Value assigned to the Remedy property

• ID—ID number of the Remedy property

• Data Type—Type of Remedy property

– Display

– Optional

– Read-Only

– Required
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Create Remedy Relationship, Item

The Item display-only tab displays the properties used to configure relationships between incidents and 
configuration items.

• Item Type—Selected item assigned to the relationship properties

– Incident

– Configuration

Create Remedy Relationship Results

The Results display-only tab displays the ID numbers assigned to the newly-linked items.

• Forward link ID—ID number assigned to the first item in the Remedy item relationship

• Back link ID—ID number assigned to the second item in the Remedy item relationship

Create Remedy Work Info

The Work Info display-only tab displays the list of properties added to the Create Work Info activity.

• Name—Name of the property

• ID—ID number of the Remedy work info property

• Label—Value assigned to the work info property

• Data Type—Type of Remedy property

– Display

– Optional

– Read-Only

– Required

Create Remedy Work Info Results

The Results display-only tab displays the number created by the Create Remedy Work Info activity.

• Work Info ID—New ID number of the newly created Remedy work info entry

Delete Remedy Entry

The Entry display-only tab displays the properties used to remove an entry from a Remedy item.

• Form Name—Name of the form containing the entry properties

• Entry ID—ID number of the Remedy entry

Find Remedy Objects

The Criteria display-only tab displays the properties and entries used to query Remedy objects on a 
Remedy server.

• Name—Name of the Remedy property

• Label—Description of the Remedy entry
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• Value—Value assigned to the Remedy entry

• ID—ID number of the Remedy property

Find Remedy Objects, Results

The Results display-only tab displays the matching properties and entries retrieved by the activity.

• Results—Displays the list of matching Remedy properties

Get Remedy Entry Property Values

The Entry display-only tab displays the properties used to retrieve property values of a Remedy entry.

• Form Name—Name of the form containing the entry properties

• Entry ID—Remedy entry ID number

The following columns display the list of properties queried by the activity.

• Name—Name of the Remedy property

• Label—Description of the Remedy property

• ID—Entry ID of the Remedy property

Get Remedy Entry Property Values, Results

The Results display-only tab displays the list of values for the properties retrieved by the activity.

• Name—Name of the Remedy entry

• Id—ID number for the Remedy property

• Value—User-modified property values

• Raw Value—Raw value for the entry retrieved by the activity

Get Remedy Incident Property Values

The Incident Property Values display-only tab displays the properties used to retrieve property values of 
a Remedy incident.

• Incident ID—Remedy incident number used to retrieve the incident properties

The following columns display the list of properties queried by the activity.

• Name—Name of the Remedy incident property

• Label—Description of the Remedy incident

• ID—Incident ID of the incident property

• Data Type—Type of Remedy property

– Display

– Optional

– Read-Only

– Required
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Get Remedy Incident Property Values, Results

The Results display-only tab displays the list of values for the properties retrieved by the activity.

• Name—Name of the Remedy incident

• Id—ID number for the Remedy property

• Value—User-modified property values

• Raw Value—Raw value for the incident (case) state retrieved by the activity

Update Remedy Entry

The Entry display-only tab displays the properties used to update the properties of a Remedy entry.

• Form Name—Name of the form containing the entry properties

• Entry ID—Remedy entry ID number

The following columns display the list of properties updated by the activity.

• Name—Name of the Remedy property

• Label—Description of the Remedy property

• ID—Entry ID of the Remedy property

• Data Type—Type of Remedy property

– Display

– Optional

– Read-Only

– Required

Update Remedy Incident

The Incident Property Values display-only tab displays the properties used to retrieve property values of 
a Remedy incident.

• Incident ID—Remedy incident number used to retrieve the incident properties

The following columns display the list of properties updated by the activity.

• Name—Name of the Remedy incident property

• Label—Description of the Remedy incident

• ID—Incident ID of the incident property

• Data Type—Type of Remedy property

– Display

– Optional

– Read-Only

– Required
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Element Descriptions

Select Remedy Properties Dialog Box

Use the Select Properties dialog box to select the properties from a Remedy server target defined in Cisco 
Process Orchestrator to add to the list. The displayed properties depend on the server selected.

To select multiple properties, press CTRL and hold the key while making the appropriate selections. 
When completed selecting properties, click OK.
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Cisco Prime Service Catalog Adapter
The Cisco Prime Service Catalog adapter establishes a relationship between Cisco Process Orchestrator 
and the Cisco Prime Service Catalog. In Process Orchestrator, you can:

• Manage services items and service requests in Cisco Prime Service Catalog. 

• Create, delete, and update service items using attributes of the service item. 

• Submit and update service requests by manually creating dictionaries or browsing for dictionaries 
in a Cisco Prime Service Catalog Server target. 

The following table displays activities that are provided by the Cisco Prime Service Catalog adapter. For 
more information about using these activities, see Getting Started Using the Prime Service Catalog 
Adapter, page 12-34.

Activity Comments

Create Service Item Creates a service item to be delivered in response to a service request.

See Defining the Create Service Item Activity, page 12-35.

Create Service Items 
from Table

Creates multiple service items using a table variable to be delivered in 
response to a service request in the Cisco Prime Service Catalog.

See Defining the Create Service Item from Table Activity, page 12-36.

Delete Service Item Deletes an existing service item in the Cisco Prime Service Catalog.

See Defining the Delete Service Item Activity, page 12-37.

Delete Service Items 
from Table

Deletes multiple service items using a table variable in the Cisco Prime 
Service Catalog.

See Defining the Delete Service Item from Table Activity, page 12-37.

Submit Service 
Request

Submits a request for a service order on the Cisco Prime Service Catalog.

See Defining the Submit Service Request Activity, page 12-40.

Update Service Item Updates the attributes for an existing service item on the Cisco Prime Service 
Catalog.

See Defining the Update Service Item Activity, page 12-41.

Update Service Item 
from Table

Updates multiple service items using a table variable in the Cisco Prime 
Service Catalog.

See Defining the Update Service Item from Table Activity, page 12-41.

Update Service 
Request

Updates an existing service request that currently resides on the Cisco Prime 
Service Catalog server.

See Defining the Update Service Item Activity, page 12-41.

Cancel Service 
Request

Cancels a service request.

See Defining the Cancel Service Request Activity, page 12-42.
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Getting Started Using the Prime Service Catalog Adapter
Use the following process to monitor and manage Cisco Prime Service Catalog instances. 

Step 1 Create a Cisco Prime Service Catalog target (see Defining a Cisco Prime Service Catalog Server Target, 
page 12-34).

Step 2 Define a Cisco Prime Service Catalog command activity (see Automating Cisco Prime Service Catalog 
Adapter Activities, page 12-35). 

Step 3 View the activity results (see Monitoring Operations, page 8-1).

Configuring the Service Catalog Server Adapter Reconnection Properties
Use the Retry tab to enter the default time period for all Cisco Prime Service Catalog activities to retry 
to connect to the Service Catalog whenever there are connection failures. This allows the activity to 
resume running if the Cisco Prime Service Catalog is temporarily unavailable and the running activity 
was terminated.  

To configure the default reconnection time frame:

Step 1 Choose Administration > Adapters > Cisco Prime Service Catalog Adapter, right-click and choose 
Properties.

Step 2 Click the Retry tab and complete the following reconnection fields:

• Retry time period (minutes)—Enter the number of minutes Process Orchestrator should attempt to 
connect to the Cisco Prime Service Catalog. (Default: 15 minutes)

• Retry frequency (seconds)—Enter the number of seconds to determine the frequency Process 
Orchestrator should retry connecting to the Cisco Prime Service Catalog. (Default: 30 seconds)

Defining a Cisco Prime Service Catalog Server Target
Use the Cisco Prime Service Catalog Server (PSC) target to connect to the Cisco Prime Service Catalog 
and Request Center services. Process Orchestrator will connect the target to the appropriate service 
based on the activity that attempts to execute.

Step 1 Choose Definitions > Targets, right-click, and choose New > Cisco Prime Service Catalog Server.

Step 2 On the General panel, enter the appropriate information.

Step 3 On the Connection panel, enter the appropriate information, including:

• Service Link port—Port number used to access the service link port server (Default: 6080)

• Request Center port—Port number used to access the request center port (Default: 6080)

• Access Cisco Prime Catalog via Secure Socket Layer (SSL)—If checked, the connection to the 
Cisco Prime Catalog server will run on the SSL port.
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• Ignore Secure Socket Layer (SSL) certificate error—Check this check box to indicate the target 
should ignore certificate errors when attempting to connect to the service portal.

• Public key GUID—Optional. The GUID of the external encryption key that is used to encrypt the 
data sent from Cisco Prime Service Catalog to Process Orchestrator via AMQP. This GUID is 
generated in the Prime Service Catalog server when user configures external encryption keys for 
AMQP.

Note The Public key GUID information is configured in Cisco Prime Service Catalog Server. This 
information is entered only when you use Cisco Prime Service Catalog and AMQP features. It 
is also used to fetch the broker information via PSC nsAPI. 

Step 4 Verify the information on the Completing the New Cisco Prime Service Catalog Server Wizard panel and 
click Finish to close the wizard.

Automating Cisco Prime Service Catalog Adapter Activities

Defining the Create Service Item Activity

Use the Create Service Item activity to create a service item to be delivered in response to a service 
request. A service item may be a virtual machine type or a user-defined type in the Cisco Prime Service 
Catalog.

Step 1 In the Process Editor Toolbox, choose Cisco Prime Service Catalog > Create Service Item and drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Service Item tab and enter the following information:

• Channel id—Enter the identifier that uniquely identifies each Service Link task (for example, 
82fdbbaf-3310-4156-a4ae-173b9f15e07c).

• Service item type—Enter the type of physical or virtual asset for the service item. The service item 
can be a virtual machine or a user-defined item.

• Service item name—Enter the unique name for the service item.

Step 4 To add attributes to the service item, click Attributes and complete the following fields. 

• Attribute name—Enter the attribute name to be added to the service item. Click the Reference tool 
to browse for the correct variable reference property for the service item.

• Data type—From the drop-down list, select the data type for the service item (such as Boolean, 
String, Numeric, Date and Time).

• Value—Enter the value for the associated attribute.

For example:

Property name: CreatedTime

Type: Date and Time

Value: 12/21/2010
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Step 5 Click the Subscription tab to specify the service item owner's login information to be used when 
connecting to the Cisco Prime Service Catalog. The login ID and organizational unit information must 
match.

Step 6 Click the Retry tab to enter the default time period for the activity to retry to connect to the Service 
Catalog if there is a connection failure. This allows the activity to resume running if the Cisco Prime 
Service Catalog is temporarily unavailable and the running activity was terminated.  

The properties entered on this tab override the time period configured on the adapter level.

• Retry on connection failures—Check this check box to indicate the activity should retry to connect 
to the service portal if there is a connection failure.

If the check box remains unchecked, then activity will fail if there is a connection failure.

• These fields are automatically populated with the default settings defined in the Cisco Prime Service 
Catalog adapter.

– Time period (minutes)—Clear the field to manually update the time period for when the activity 
should retry to connect to the Cisco Prime Service Catalog. (Default: 15 minutes)

– Frequency (seconds)—Clear the field to manually to determine the frequency in which Process 
Orchestrator should retry connecting to the Cisco Prime Service Catalog. (Default: 30 seconds)

Step 7 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Defining the Complete Service Request Activity

Use the Complete Service Request activity to notify Service Catalog that the process is complete. The 
required Task ID is provided in the AMQP message that initiated the process.

Step 1 On the Toolbox, choose Cisco Prime Service Catalog > Complete Service Request and drag and drop 
the activity onto the Workflow pane.

Step 2 Click the Service Request tab to specify the following properties:

• Task ID—provided in the AMQP message that initiated the process 

• Timeout—Check the check box and then enter the time period the activity should wait before failing.

Note Click the time unit link to change the time interval.

• Action—action that can be used with this nsAPI call 

Step 3 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Defining the Create Service Item from Table Activity

Use the Create Service Items from Table activity to create multiple service items using a table variable 
to be delivered in response to a service request in the Cisco Prime Service Catalog.

The table variable should include the service names and values that correspond to the attribute names in 
the Cisco Prime Service Catalog.
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Step 1 In the Process Editor Toolbox, choose Cisco Prime Service Catalog > Create Service Items from 
Table and drag and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Service Item tab and enter the following information:

• Channel id—Enter the identifier that uniquely identifies each Service Link task.

• Service item type—Enter the type of physical or virtual asset for the service item.

• Table variable— Click the Reference tool to query a table variable to be used for the service item. 
The table must contain a column type for each property being created on the corresponding service 
item.

For example, the table might contain the following columns for a virtual machine:

Name / IP Address / Host / Memory / DiskSpace

To create multiple VMs from the table, add several rows for the table with the above column values 
defined.

Step 4 Click the Subscription tab to specify the service item owner's login information to be used when 
connecting to the Cisco Prime Service Catalog. The login ID and organizational unit information must 
match.

Step 5 Click the Retry tab to enter the default time period for the activity to retry to connect to the Service 
Catalog if there is a connection failure. This allows the activity to resume running if the Cisco Prime 
Service Catalog is temporarily unavailable and the running activity was terminated.  

Step 6 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Defining the Delete Service Item Activity

Use the Delete Service Item activity to delete an existing service item in the Cisco Prime Service 
Catalog.

Step 1 On the Toolbox, choose Cisco Prime Service Catalog > Delete Service Item and drag and drop the 
activity onto the Workflow pane.

Step 2 Enter the service item properties (see Defining the Create Service Item Activity, page 12-35). Enter the 
unique name for the service item.

Step 3 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Defining the Delete Service Item from Table Activity

Use the Delete Service Items from Table activity to delete multiple service items using a table variable 
in the Cisco Prime Service Catalog.

The table variable should include the service names and values that correspond to the attribute names in 
the Cisco Prime Service Catalog.
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Step 1 In the Process Editor Toolbox, choose Cisco Prime Service Catalog > Delete Service Items from Table 
and drag and drop the activity onto the Workflow pane.

Step 2 Enter the service item properties (see Defining the Create Service Item from Table Activity, page 12-36).

The table must contain a “Name” column. This column must contain the uniquely named items that are 
to be deleted.

Step 3 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Defining the Find Service Item Activity

Use the Find Service Item activity to search for attribute properties for the service item.

Step 1 In the Process Editor Toolbox, choose Cisco Prime Service Catalog > Find Service Item and drag and 
drop the activity onto the Workflow pane.

Step 2 Click the Advanced tab to define the service items you want to retrieve.

• Get all matching items—Select this option to retrieve all matching service items

• Get specified row— Start row—enter the row properties you want to retrieve the service item from

• Maximum items to return—enter the number of service items to retrieve

Step 3 Click the Service Item tab to search for attribute properties for the service item.

• Service item type—Enter the type of physical or virtual asset for the service item. The service item 
can be a virtual machine or a user-defined type.

• Timeout—Check the check box and then enter the time period the activity should wait before failing.

Note Click the time unit link to change the time interval.

• Search criteria—Enter the search criteria for the service item type you want to find

– Attribute—Enter the attribute name to be added to the service item

– Data Type—From the drop-down list, select the data type for the service item.

Boolean

String

Numeric

Date and Time

– Value—Enter the attribute value to be added to the service item

• Attributes to get—The list of associated attributes for the selected type

Step 4 Click the Subscription tab to define the subscriber, or current owner of the service item, properties.

• Subscriber login id—The unique ID assigned to the current owner of the service item

• Subscriber OU—The organizational unit to which the subscriber belongs

• Include subscriber information in results—Indicates the subscriber information is included in the 
results retrieved.
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Step 5 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Defining the Get Service Item Activity

Use the Get Service Item activity to retrieve attribute properties for the service item.

Step 1 In the Process Editor Toolbox, choose Cisco Prime Service Catalog > Get Service Item and drag and 
drop the activity onto the Workflow pane.

Step 2 On the Service Item tab, enter the service item properties.

• Service item type—Enter the type of physical or virtual asset for the service item. The service item 
can be a virtual machine or a user-defined type.

• Service item name—Enter the name of the service to be ordered.

For example:

Order a Virtual Machine

-or-

Start User Provisioning Process

• Timeout—Check the check box and then enter the time period the activity should wait before failing.

Note Click the time unit link to change the time interval.

• Attributes to get—The list of associated attributes for the selected type

Step 3 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Defining the Delete Service Item from Table Activity

Use the Delete Service Items from Table activity to delete multiple service items using a table variable 
in the Cisco Prime Service Catalog.

The table variable should include the service names and values that correspond to the attribute names in 
the Cisco Prime Service Catalog.

Step 1 In the Process Editor Toolbox, choose Cisco Prime Service Catalog > Delete Service Items from Table 
and drag and drop the activity onto the Workflow pane.

Step 2 Enter the service item properties (see Defining the Create Service Item from Table Activity, page 12-36).

The table must contain a “Name” column. This column must contain the uniquely named items that are 
to be deleted.

Step 3 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.
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Defining the Get User Information Activity

Use the Get User Information activity to retrieve the properties of a specified user.

Step 1 In the Process Editor Toolbox, choose Cisco Prime Service Catalog > Get User Information and drag 
and drop the activity onto the Workflow pane.

Step 2 Click the User tab to enter the user properties.

• User name—Enter the user name for the user account properties to be retrieved.

• Timeout—Check the check box and then enter the time period the activity should wait before failing.

Note Click the time unit link to change the time interval.

Step 3 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Defining the Submit Service Request Activity

Use the Submit Service Request activity to submit a request for a service order on the Cisco Prime 
Service Catalog. In this activity, users can add multiple dictionaries to the service request manually or 
by browsing for an existing dictionary on a target.

Step 1 In the Process Editor Toolbox, choose Cisco Prime Service Catalog > Submit Service Request and 
drag and drop the activity onto the Workflow pane.

Step 2 Click the Service Request tab to specify the name of the service to be ordered. For example:

• Order a Virtual Machine

• Start User Provisioning Process

Step 3 Modify the list of dictionaries to be used to support the service request. The dictionary properties provide 
additional data used to request a service and/or fulfill the service request.

• Add—Click this button to add a dictionary properties pane to the service request. Select one of the 
following options for adding a dictionary.

– Manual dictionary—Click this button to add a Properties pane to the Service Request tab. After 
the pane displays on the tab, click the appropriate to modify the list of properties for the 
dictionary. See Manually Adding a Dictionary, page 12-44.

– Browse for dictionary—Click this button to launch the Add Dictionaries dialog box to search 
for a dictionary on a Cisco Prime Service Catalog server.

• Remove—Click the area around the appropriate dictionary properties, then click this button to 
remove the last set of dictionary properties from the service request.

Step 4 Click the Advanced tab to provide default customer login information for the requestor. The information 
defined on this tab will override the runtime user selected on the Credentials tab.

• Customer login name—Enter the log in name for the customer of the service being requested.

• Initiator login name—Enter the log in name of the person initiating the request for the service.

• Quantity—Enter the quantity needed for the service request. (Default: 1)
12-40
Cisco Process Orchestrator 3.3 User Guide

#managing_portal_adapter_defining_2682


 

Appendix 12      Using Adapters
  Cisco Prime Service Catalog Adapter
• Bill to OU—Enter the organizational unit to be billed for the service request.

Step 5 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Defining the Update Service Item Activity

Use the Update Service Item activity to update the attributes for an existing service item on the Cisco 
Prime Service Catalog.

Step 1 In the Process Editor Toolbox, choose Cisco Prime Service Catalog > Update Service Item and drag 
and drop the activity onto the Workflow pane.

Step 2 Click the appropriate tabs and update the service item properties as necessary. For details, see Defining 
the Create Service Item Activity, page 12-35.

Step 3 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Defining the Update Service Item from Table Activity

Use the Update Service Items from Table activity to update multiple service items using a table variable 
in the Cisco Prime Service Catalog. The table variable should include the service names and values that 
correspond to the attribute names in the Cisco Prime Service Catalog.

Step 1 In the Process Editor Toolbox, choose Cisco Prime Service Catalog > Update Service Items from 
Table and drag and drop the activity onto the Workflow pane.

Step 2 Click the appropriate tabs and update the service item properties as necessary. For details, see Defining 
the Create Service Item from Table Activity, page 12-36.

Step 3 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Defining the Update Service Request Activity

Use the Update Service Request activity to update an existing service request that currently resides on 
the Cisco Prime Service Catalog server.

Step 1 In the Process Editor Toolbox, choose Cisco Prime Service Catalog > Update Service Request and 
drag and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Service Request tab and enter the required information, including:

• Channel Id—Enter the identifier for the Service Link task in the service request to be updated.

Note: The identifier for the activity must be retrieved directly from the Cisco Prime Service Catalog. 
Do not reference an output property of the Submit Service Request activity.
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• Take action—Check this check box to indicate that a specific action should be taken when updating 
the service request. From the enabled drop-down list, select the appropriate option.

• Comments—Enter any comments related to the service task or service request.

Step 4 Click the Parameters tab to specify the parameters needed by the Service Link to update data on the 
service request to coordinate the completion of a task.

• Do not send parameters—Select this radio button to indicate that no parameters are required in order 
to update the task in the service request.

• Send the following parameters—Select this radio button to enable the Parameters pane.

• Send parameters from table variable—Select this radio button to enable the text field.

Step 5 Click the Reference icon to query a table variable to be used for the service request. The table must 
contain both a "Name" and a "Value" column. The name column must correspond to an attribute name 
in the service portal.

Defining the Cancel Service Request Activity

Use the Cancel Service Request activity to cancel a request for a service order on the Cisco Prime 
Service Catalog. 

Step 1 In the Process Editor Toolbox, choose Cisco Prime Service Catalog > Cancel Service Request and 
drag and drop the activity onto the Workflow pane.

Step 2 Click the Service Request tab and select the Requisition ID of the service to be canceled.

Step 3 Enter the time period the activity should wait before failing.

Step 4 Check the Force Monitor Plan Cancellation check box to force the cancellation, if the service request 
is configured not to allow cancellation after the task has started.

Defining the Execute Python Script

Use the following procedure to execute python script.

Step 1 In the Process Editor Toolbox, choose Execute Python Script and drag and drop the activity onto the 
Workflow pane.

Step 2 Click the Execute Python Script tab.

Step 3 Enter the Script Name of the Python Program.

Step 4 Enter the Local Windows runtime Credentials that python code will run on behalf. 

Note The Windows users must have access to the machine, where the Process Orchestrator server is located at.

Step 5 Enter the Script Arguments users can pass to sys module in Python code. For example:

In windows command line, if to run python script, underlined arguments are set in sys 
module in python code
example.py arg1 arg2
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The Script argument block here is to provide users capability to pass arguments like arg1, 
arg2 set in sys module and you can access them via sys.argv[1], sys.argv[2] and so on.

Step 6 Enter the Import Module Path of any custom python code files or any third party python library.

Note The path must exist in Process Orchestrator server machine.

Step 7 Enter the Script of the python code.

Step 8 Enter the time period the activity should wait before failing.

Execute Python Code Properties

The Execute Python Script tab displays the properties used to execute the python script in the Process 
Orchestrator.

• Script name—Displays the script name of the python program

• Local windows runtime user that the python script will run on behalf—Displays the name of local 
Windows user

• Script argument—Displays the arguments users can pass to the sys module in python code

• Import module path—Displays the path of the python files

• Script—Displays the python code script

• Wait for command to complete or time out in—Displays the time period the activity should wait 
before failing

Python Code Results

The Results tab displays the result from the python code execution.

Typical Cisco Prime Service Catalog Tasks

Adding a Service Item Attribute

Use the following steps to add attribute properties to the service item.

Step 1 On the Service Item tab, click Add.

Step 2 Complete the following fields to enter the attributes for the service item.

• Attribute name—Enter the attribute name to be added to the service item.

• Data type—Select the data type for the service item.

• Value—Enter the value for the associated attribute.

Step 3 Click the Save tool to complete the activity definition
12-43
Cisco Process Orchestrator 3.3 User Guide

 



 

Appendix 12      Using Adapters
  Cisco Prime Service Catalog Adapter
Manually Adding a Dictionary

Use the following options to add a Dictionary properties pane for manually adding a dictionary to the 
service request.

Step 1 On the Service Request tab, click Add > Manual Dictionary.

Step 2 Under Properties, enter the name of the dictionary to included with the service request.

Step 3 Click Add > [Name] Property to launch the Add Property dialog box to add a property to the dictionary.

• Property name—Enter the name of the dictionary property.

• Native data type—Data type that may not be used by Process Orchestrator, but was retrieved from 
the Cisco Prime Service Catalog as part of an existing item within a dictionary property. (Ex. 
Number, Text, Double)

• Data type—Data type assigned to the item

• Required—Check this check box to indicate the property is required.

• Property is multi-valued—Check this check box to indicate more than one value should be assigned 
to the item.

• Value—Enter the value(s) for the associated property. If the Property is multi-valued check box is 
checked, complete each Value field, as necessary.

Step 4 Click OK to close the Add Property dialog box and return to the Service Request tab.

Step 5 Click the Save tool to complete the activity definition.

Browsing for Dictionaries

Use the Add Dictionaries dialog box to add dictionaries and their related properties to a service request 
from a defined Cisco Prime Service Catalog server target. Use the following steps to browse for a 
dictionary to be included in the service request.

The queried dictionary completes all the fields required for service request.

Step 1 On the Service Request tab, click Add > Browse for Dictionaries.

Step 2 From the Add Dictionaries from the following Cisco Prime Service Catalog server drop-down list, select 
the appropriate server containing the dictionaries from which you want to query.

Step 3 In the Service name field, enter the service name for the product containing the dictionaries to be used 
with the service request.

Step 4 Click Refresh to display the dictionaries from the service in the list.

Step 5 Under the Names list, select the appropriate dictionary to be included in the service request, then click 
OK.
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Specifying the Owner for the Service Item

Use the Subscription tab to provide the service item owner's login information to be used when 
connecting to the Cisco Prime Service Catalog. The login ID and organizational unit information must 
match the information in the portal.

Step 1 Click the Subscription tab on the service item activity.

Step 2 Complete the fields, as necessary.

Specifying Requestor Credentials for the Service Request

Use the Advanced tab on the Submit Service Request activity to provide login information for the 
requestor which can be used to override the runtime user credentials configured in the process properties. 
The login ID and organizational unit information must match the information in the portal.

Step 1 Click the Advanced tab on the Submit Service Request activity.

Step 2 Complete the login and organizational information needed for this activity, as necessary.

• Customer login name—Enter the log in name for the customer of the service being requested.

• Initiator login name—Enter the log in name of the person initiating the request for the service.

• Quantity—Enter the quantity needed for the service request. (Default: 1)

• Bill to OU—Enter the organizational unit to be billed for the service request.

Step 3 Click the Save tool to complete the activity definition.

Instance Properties

Cancel Service Request

The Service Request display-only tab displays the properties defined to cancel a service item to be 
delivered in response to a service request. A service item may be a Virtual Machine type or a 
user-defined type in the Cisco Prime Service Catalog.

• Requisition ID—Click the Insert Variable Definition button to select the variable reference.

Complete Service Request

The Complete Service Request display-only tab displays the existing service request that completed on 
the Cisco Prime Service Catalog server.

• Task Id—the identifier that uniquely identifies each Service Link task.

• Action—indicates that a specific action should be taken when updating the service request. From 
the enabled drop-down list, select the appropriate option. 

– Done—Indicates task should be noted as completed

• Timeout—indicates the time period the activity waits before failing.
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Create Service Item

The Service Item display only page displays the properties used to create a service item to be delivered 
in response to a service request in the Cloud Service Portal.

• Service item type—the type of physical or virtual asset for the service item. The service item can be 
a virtual machine or a user-defined type.

• Service item name—the name of the service to be ordered.

For example:

Order a Virtual Machine

-or-

Start User Provisioning Process

• Channel Id (Service Link only)—the identifier that uniquely identifies each Service Link task. If 
provided, the current SOAP based interface to Service Catalog will be utilized. If not provided, the 
nsAPI will be used for the implementation of the activity.

• Timeout— the time period the activity should wait before failing.

Note Click the time unit link to change the time interval.

• Attributes—The following options display the properties used to configure the attributes to add to 
the service item.

– Attribute name—Attribute name to be added to the service item. 

• Data type—Displays the selected data type for the service item. 

– Boolean

– String

– Numeric

– Date and Time

• Value—Value for the associated attribute. 

Create Service Items from Table

The Service Item display-only page displays the properties used to create multiple service items using a 
table variable to be delivered in response to a service request in the Cisco Prime Service Catalog. 

• Service item type—the type of physical or virtual asset for the service item. The service item can be 
a virtual machine or a user-defined type.

• Table variable—the table variable data containing the information needed to create the service 
items.

• Channel Id (Service Link only)—the identifier that uniquely identifies each Service Link task. If 
provided, the current SOAP based interface to Service Catalog will be utilized. If not provided, the 
nsAPI will be used for the implementation of the activity.

• Timeout—the time period the activity should wait before failing.

Note Click the time unit link to change the time interval.
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Delete Service Item

The Service Item tab displays the properties used to delete an existing service item in the Cisco Prime 
Service Catalog.

• Channel id—Displays Identifier that uniquely identifies each Service Link task

• Service item type—Type of physical or virtual asset for the service item

• Service item name—Name or IP address of the service item

Delete Service Items from Table

The Service Item tab displays the properties used to delete multiple service items using a table variable 
in the Cisco Prime Service Catalog. 

• Channel ID—Displays the identifier that uniquely identifies each Service Link task

• Service item type—Type of physical or virtual asset for the service item

• Table variable—Displays the table variable data containing the information needed to delete the 
service items

Find Service Items, Advanced

The Advanced read only tab displays the service items that were defined for retrieval.

• Get all matching items—Retrieves all matching service items

• Get specified row

– Start row—the row properties you want to retrieve the service item from

– Maximum items to return—the number of service items to retrieve

Find Service Items, Results

The Results display-only tab displays the matching service items results.

• Matching service items—Displays the matching service items

Find Service Items, Service Item

The Service Item display-only tab displays the attribute properties for the service item.

• Service item type—Enter the type of physical or virtual asset for the service item. The service item 
can be a virtual machine or a user-defined type.

• Search criteria—Enter the search criteria for the service item type you want to find

– Attribute—Enter the attribute name to be added to the service item

– Data Type—From the drop-down list, select the data type for the service item.

Boolean

String

Numeric

Date and Time
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– Value—Enter the attribute value to be added to the service item

• Attributes to get—The list of associated attributes for the selected type

Find Service Item, Subscription

The Subscription display-only tab displays the subscriber, or current owner of the service item, 
properties.

• Subscriber login id—The unique ID assigned to the current owner of the service item

• Subscriber OU—The organizational unit to which the subscriber belongs

• Include subscriber information in results—Indicates the subscriber information is included in the 
results retrieved.

Get Service Item

Display-only. Use the Get Service Item activity to retrieve attribute properties for the service item.

• Service item type—Enter the type of physical or virtual asset for the service item. The service item 
can be a virtual machine or a user-defined type.

• Service item name—Enter the name of the service to be ordered.

Example

Order a Virtual Machine

-or-

Start User Provisioning Process

• Timeout—Check the check box and then enter the time period the activity should wait before failing.

Note Click the time unit link to change the time interval.

• Attributes to get—The list of associated attributes for the selected type

Get User Information

Display-only.Use the Get User Information activity to retrieve the properties of a specified user.

• User name—Enter the user name for the user account properties to be retrieved.

• Timeout—Check the check box and then enter the time period the activity should wait before failing.

Note Click the time unit link to change the time interval.

Get User Information Results

Use the Results tab to view the response output in the selected format.

• XML—Click this option to display the XML output results if the page is available in XML format.

• Text—Click this option to display the results in a text format.
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Submit Service Request

Display-only. Use the Submit Service Request activity to submit a request for a service order on the 
Cisco Prime Service Catalog. In this activity, users can add multiple dictionaries to the service request 
manually or by browsing for an existing dictionary on a target. 

• Service name—Name or IP address of the service item. 

The following displays the dictionary and its related properties that were included in the service request.

• Dictionary name—Name of the dictionary included with the service request. 

The following table displays the properties associated with the dictionary assigned to the service request.

• Name—Name of the dictionary property

• Values—Value assigned to the dictionary property

• Native data type—Data type originally assigned to the property

• Data Type—Data type assigned to the property

– Boolean

– Date

– Numeric

– String

• Required—Indicates the property is required 

• Multivalued—Indicates the property has multiple values assigned (True, False)

Submit Service Request, Advanced

The Advanced display-only tab displays the default customer login information for the requestor used 
by the service request.

• Customer login name—Log in name for the customer of the service being requested

• Initiator login name—Log in name of the person who initiated the service request

• Quantity—Quantity needed for the service request (Default: 1)

• Bill to OU—Organizational unit to be billed for the service request. 

Submit Service Request, Results

The Results tab displays the details of the service request submitted. 

• Service Name—Name of the service request submitted

• Requisition ID—Identifier for the service that has been ordered as part of a service request

• Status—Status of the service request

• Started date—Date the service request was started

• Due date—Date the service request should be completed

• Customer login date—Login name of the customer who submitted the request for the service

• Initiator login name—Login name of the person initiating a request for the service
12-49
Cisco Process Orchestrator 3.3 User Guide

 



 

Appendix 12      Using Adapters
  Cisco Prime Service Catalog Adapter
Update Service Item

The Service Item tab displays the attributes used to update an existing service item on the Cisco Prime 
Service Catalog.

• Channel Id (Service Link only)—Enter the identifier that uniquely identifies each Service Link task. 
If provided, the current SOAP based interface to Service Catalog will be utilized. If not provided, 
the nsAPI will be used for the implementation of the activity.

• Service item type—Type of physical or virtual asset for the service item.

• Service item name—Name or IP address of the service item. 

This section displays the attributes updated on the service item.

• Attribute name—Attribute name to be updated on the service item. 

• Data type—Selected data type for the service item. 

– Boolean

– String

– Numeric

– Date and Time

• Value—Value for the associated attribute.

Update Service Items from Table

The Service Item tab displays the properties used to update multiple service items using a table variable 
in the Cisco Prime Service Catalog. 

• Channel Id (Service Link only)—Displays the identifier that uniquely identifies each Service Link 
task. If provided, the current SOAP based interface to Service Catalog was utilized. If not provided, 
the nsAPI was used for the implementation of the activity.

• Service item type—Type of physical or virtual asset for the service item

• Table variable—Displays the table variable data containing the information needed to update the 
service items

Update Service Request

The Service Request display-only tab displays the properties used to update an existing service request 
that currently resides on the Cisco Service Catalog server.

• Channel Id—Identifier for the Service Link task in the service request to be updated

• Take action—Checked box and completed text field indicates the specific action that should be taken 
when the service request is updated. 

– Approval—Indicates task should be sent for approval

– Cancel—Indicates task should be canceled

– Done—Indicates task should be noted as completed

– Reject—Indicates task should be rejected

– Skip—Indicates task should skipped

• Comments—Comments related to the service task or service request
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Update Service Request, Parameters

The Parameters display-only tab provides the properties used on whether to send parameters with the 
service request and any parameters needed by the Service Link to update the data on the service request. 

• Do not send parameters—Selected option indicate that no parameters were required to update the 
task in the service request.

• Send the following parameters—Selected option indicates that the displayed parameters in the 
Parameters Column were used to update the service request. 

• Send parameters from table variable—Selected option indicates a table variable was used for 
updating the service request. 

The following table displays the parameters that are included in the Update Service Request activity.

• Name—Displays the name of the agent parameter.

• Values—Displays the value assigned to the agent parameter

• Data Type—Data type assigned to the parameter

– Boolean

– Date

– Numeric

– String

• Multivalued—Indicates the parameters has multiple values assigned (True, False)
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OpenStack Adapter
The OpenStack adapter establishes a relationship between Cisco Process Orchestrator and OpenStack. 
In Process Orchestrator, you can perform IT process automation tasks such as provisioning OpenStack 
resources, monitoring OpenStack installations, troubleshooting operational problems, and so on.

Getting Started Using the OpenStack Adapter
Use the following process to monitor and manage OpenStack instances. 

Step 1 Create an OpenStack target (see Defining an OpenStack Server Target, page 12-52).

Step 2 Define an OpenStack user (see Defining an OpenStack User, page 12-52).

Step 3 Define an OpenStack command activity (see Automating OpenStack Adapter Activity, page 12-53). 

Step 4 View the activity results (see Monitoring Operations, page 8-1).

Defining an OpenStack User
Use the following instructions to define the user credentials required to access OpenStack. The level of 
access for the network device is dependent upon the type of user logging in.

Step 1 Choose Definitions > Runtime Users, right-click and choose New > OpenStack User.

Step 2 Click the General tab to specify the required information, including:

• Display name—Enter the display name for the runtime user. This field is populated with the 
information specified in the User name text field, but can be overwritten by the user.

• Type—Display only. Type of object.

• Owner—User name of the owner of the object. This is typically the person who created the object.

• User name—The user name assigned to access the OpenStack server.

• Password—Check the Password check box and then enter the password assigned to access the 
OpenStack server.

Step 3 Click OK to close the dialog box.

Defining an OpenStack Server Target
Use the OpenStack Server target to connect to the OpenStack server.

Step 1 Choose Definitions > Targets, right-click, and choose New > OpenStack Server.

Step 2 On the General panel, enter the appropriate information.

Step 3 On the Connection panel, enter the appropriate information, including:
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• OpenStack server name—Enter the host name or the IP address of the OpenStack server.

• Override default URL—Select this option to enter an appropriate URL to use to override the default 
URL.

• API Version—Select the appropriate API version to which your automation content is associated.

• Ignore Secure Socket Layer (SSL) certificate error—Check this check box to indicate the target 
should ignore certificate errors when attempting to connect to the service portal.

• Runtime user—Select this radio button to specify the runtime user required to execute a process or 
activity against this target.

• Project—The project or an organizational unit in the cloud that is used to scope the command. It is 
also known as tenant.

Step 4 Verify the information on the Completing the New OpenStack Server Wizard panel and click Finish to 
close the wizard.

Automating OpenStack Adapter Activity

Defining the Execute OpenStack Command Activity

Use the Execute OpenStack Command activity to execute OpenStack RESTful API command against an 
OpenStack server. The Execute OpenStack Command activity provides a flexible way to automatically 
track authentication tokens and renew them as needed. Responses for common information are scanned 
and displayed as activity results in the Operations Workspace activity instance view.

Step 1 In the Process Editor Toolbox, choose OpenStack > Execute OpenStack Command and drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Request tab and enter the following information:

• Project—The project or an organizational unit in the cloud that is used to scope the command. It is 
also known as tenant. 

• Base URL—Select the appropriate service and the endpoints through which you can access the 
resources and perform operations.

– Service—The OpenStack services supported by the OpenStack server. 

– Endpoint—The endpoint to access the OpenStack service. 

• Relative URL—Enter the URL to be requested. The Relative URL is case-sensitive.

From the Insert Variable Reference dialog box, select the reference variable and then enter the rest 
of the URL to be requested. For example, if you want to request for all the tenants available in the 
OpenStack service, you can enter [Process.Target.IDentity Endpoints 
FirstRowAdminURL]/tenants.

• Method—The method to be performed on the resource identified by the Request-URI. For a list of 
common header methods, see HTTP Header Methods.

• Request Content Type—The value for the content type used to define the structure of the request.

• Request—Enter any additional HTTP request details using JSON or XML format.
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• Response Content Type—The value for the content type used to define the structure of the response. 

• When request creates a task, wait for its completion (in seconds)—Check the check box to indicate 
that when a task request is sent using methods, PUT, POST, DELETE, the activity should wait for 
the specified time period for the completion of the task before continuing.

In the enabled text box, enter the time period the activity should wait for the task. Click the time unit 
link to change the time interval.

• Rate limit wait time—Enter the number of seconds that the web service call must wait to prevent the 
call from exceeding the limits.

• Archive request text upon successful activity completion—Check the check box to indicate whether 
to archive the data request after the successful completion of the activity. 

• If the check box remains unchecked, the data generated by the activity is removed from the database 
upon successful completion of the activity.

• Restart activity if interrupted —Check this check box to indicate the activity should resume after an 
interruption in the execution. 

If the check box remains unchecked, then the activity remains paused if there is an interruption in 
the execution.

Step 4 Click the Paging tab and enter the following information:

• Limit—Enter the number of items to be displayed on each page. By default, the limit is set to 0 and 
the search returns all the items.

• Marker—Set the marker to the last item returned in the previous list and then request for subsequent 
items.

• Page reverse—Check this check box to indicate that the list can be reversed.

Step 5 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Cisco Process Orchestrator Adapter Help for Email

Overview
The Email adapter provides the ability to execute email objects and send email messages to a specified 
user. This guide provides instructions for viewing Email adapter properties, defining Email targets, 
triggers, and activities, instructions for completing the property pages for each specific activity, and 
instructions on viewing the activity results.

The Email adapter properties dialog box displays general information about the functionality provided 
by the adapter, version number, release date and install date, any prerequisites, and the history of changes 
made to the adapter.
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Managing Email Objects

Email Targets Overview

Users can define an email target to run a process or activity against an Internet Message Access Protocol 
(IMAP) email server, a Post Office Protocol (POP3) email server, or an SMTP Server.

The IMAP email server allows an email client, such as Microsoft Outlook, to retrieve email on a remote 
mail server. The POP3 email server allows an email client to retrieve e-mail from a remote server over 
a TCP/IP connection.

An Email (IMAP) target must be connected to an Exchange 2007 Server with Service Pack 3. An 
authentication failure will occur when attempting to create an Email (IMAP) target against an Exchange 
2007 Server that does not have service pack 3.

The following table provides a listing of the targets that are associated with the adapter.

• Email Account (IMAP)—Specify the connection information to the IMAP email server

• Email Account (POP3)—Specify the connection information to the POP3 email server

• Email SMTP Server—Specify the connection information to the SMTP email server

Defining the Email Account Target
Use the following steps to define an Email Account (IMAP) target. This target allows a process or 
activity to execute against an email account on an IMAP mail server.

An Email (IMAP) target must be connected to an Exchange 2007 Server with Service Pack 3. An 
authentication failure will occur when attempting to create an Email (IMAP) target against an Exchange 
2007 Server that does not have service pack 3.

To define the target:

Step 1 On the Definitions > Targets view, right-click and choose New > Email Account (IMAP).

The New Email Account (IMAP) Properties dialog box displays.

Step 2 On the General Information panel, specify the name and description of the new object, then click Next.

Step 3 On the Email Account settings panel, specify the email server, email user name and port for the email 
account. 

• Email server—Name of the email server that relays email to the mailbox

• Protocol—Display-only field of the type of email protocol being used by the email server

• Email user—Select the default runtime user account used to connect to the target. Select the default 
runtime user from the drop-down list.

• Port Override—Check the check box and enter the port number in the adjacent field to override the 
default port used by the protocol if the port is being used by another application.

• Enable TLS authentication—If checked, the authorization of the Email server will use TLS.

• Enable SSL—If checked, the connection to the Email server will run on the SSL port. 

Note You may also need to override the default IMAP port (143) to the SSL port.
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• Ignore Certificate Error—If checked, any errors regarding the certificate will be ignored. 

• Enable server push notifications—If checked, Email Simple or Advanced Events will be monitored 
through email server push notifications.

Step 4 Click the Keystore tab and enter the key file password that provides access to the file.

Step 5 Click the Advanced tab to specify the reconnection settings to the appropriate email server (IMAP, 
POP3) after a connection failure.

• Reconnect to email server on connection failure—Check this check box to enable the reconnection 
settings for the target.

• Reconnect every ____seconds—Select this option and in the text field, enter the number of seconds 
the target should take to reconnect to the server.

• Reconnect up to—In the text field, enter the maximum number of times the target should attempt to 
reconnect to the server.

• Attempt to reconnect at the following intervals (in seconds)—Select this option and in the text field, 
enter the number of seconds the target should wait before attempting to reconnect to the server.

Step 6 Click OK to close the dialog box and complete the procedure.

The new target displays in the list of targets on the Definitions > Targets view.

Viewing Email Properties

Step 1 On the Administration > Adapters view, double-click Email Adapter.

The Properties dialog box displays.

Step 2 Click the Advanced tab to specify the maximum size of a text file attachment which will be returned in 
the output table in the Get Email Attachments activity.

• Maximum allowed text file size (KB—Choose the maximum number of kilobytes allowed for the 
text file. 

Step 3 Click the Keystore tab and enter the key file password that provides access to the file.

Step 4 Click Ok.

Managing Email Activities

Defining the Email Activity
Use the Email activity to specify the information required for sending an email as part of the process.

To define the Email activity

Step 1 On the Toolbox pane, under Email Activities, select the Email activity, then drag and drop the activity 
onto the Workflow pane.
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The Email property pages display.

Step 2 On the General tab, enter the appropriate information.

Step 3 Click the Email tab to specify the properties used to generate the email. Use commas to separate 
multiple email addresses.

• To—Enter the email address of the primary recipient(s) of the email.

• Cc—Enter the email address of the recipient(s) who are to be carbon-copied on the email.

• Bcc—Enter the email address of the recipient(s) who are to blind carbon-copied on the email.

• Subject—Enter the subject heading of the email.

• Message—Enter the content of the message in the body of the email.

Note HTML code can be used for formatting if the email is saved in HTML format.

• Save as HTML—Check this check box to send the email contents as an HTML file.

For example, if the content is <B> Cisco Process Orchestrator </B>, then the contents in the email 
will be shown in bold text.

Step 4 Click the Attachments tab to specify the file paths for the attachments to be sent as part of the email.

• User with access to attachments—From the drop-down list, select the runtime user account to attach 
files to the email.

• Attachment Paths—Displays the list of file paths for attachments

Step 5 Click OK to complete the activity definition.

Define a Get Email Attachments Activity
Use the Get Email Attachments activity to specify the parameters for the attachments to be sent as part 
of the email.

To define the activity

Step 1 On the Toolbox pane, under Email Activities, select the Get Email Attachments activity, then drag and 
drop the activity onto the Workflow pane.

The Get Attachments tab display.

Step 2 On the Get Attachments tab, specify the properties used for the attachments.

• Mail folder—[Required] mail folder name that contains the message

• Message ID—[Required] the unique message ID.

• Select attachments—Include all the attachments in the message; (b) specify the attachment file table 
with a “File Name” column, containing attachment file names Usually, user may user the variable 
reference to the attachment output table from the trigger Email Advanced Event; or (c) Specify the 
attachment file name, user may use “*” wild card to specify the attachment file name pattern. The 
default choice is to include all the attachments.
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• What to do with the attachments—(a) Download the attachments; or (b) return the text attachment 
in the output table. Download is the default. If choose to return the text attachment in the output 
table, the text of the attachment can be referenced in the exposed attachment table. The size of the 
text attachment file needs to be no larger than the max allowed size specified in the Email Adapter 
Advanced settings. If oversized, the activity will fail. 

• [Optional] If choose to download—Window Runtime User to access file systems for downloading 
attachments. The default user is “Orchestrator   Server User” that was created during product 
installation.

• [Optional] If choose to download—Directory to save the downloaded files. In high availability 
environment server setup, the directory should be a network share accessible to all the servers.

• [Optional] Mutually exclusive choices—If you choose to download, what to do if the file exists. The 
default is ‘Always replace’. The other two choices are ‘Do not replace’ and ‘Replace only if newer’.

Step 3 Click OK to close the dialog box and complete the procedure.

Element Descriptions

Service Request Parsing Rules Page
Use the Service Request Parsing Rule page to set up the predefined XPath query based parsing rule for 
a given type of the service request payloads. 

• Display Name—Name of the parsing rule

• Description—Description of the parsing rule

• Automation Pack—Name of the automation pack associated with the parsing rule

Add/Edit Property Dialog
Use this dialog to add or edit dictionary properties to/for a service request. Select one of the following 
data types to the request and enter a value for the associated attribute:

• Boolean

• String

• Numeric

• Date and Time

Add Value Dialog Box
Use this dialog box to add or modify the properties and parameters to be included in the service request. 

Note The displayed fields depend on the dialog box that is opened.

• Property/Parameter name—Enter the name of the agent parameter or dictionary property.
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• Native data type—Display-only. Data type that may not be used by Process Orchestrator, but was 
retrieved from the Cisco Prime Service Catalog as part of an existing item within a dictionary 
property. (Ex. Number, Text, Double)

• Data type—Display-only. Data type assigned to the item

– Boolean

– Date

– Numeric

– String

• Required—Check this check box to indicate the item is required.

• Property/Parameters is multi-valued—Check this check box to indicate more than one value should 
be assigned to the item.

• Value—Enter the value(s) to be associated with the item.

XPath Query Page
Use the XPath Query page to fill in the XPath namespaces defined in the service request XML payload.

• Prefix—Enter the prefix element associated with the namespace URI reference in the attribute value

• Uri—Enter the Uniform resource identifier (URI) used to identify the attribute value of the 
namespace name or resource on the Internet

• Property Name—Enter the property name

• Property Type—Select the data type associated with the path expression to query.

– String

– Numeric

– Boolean

– DateTime
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Core Adapter
The following table displays activities that are provided by the Core Functions adapter. For more 
information about using these activities, see Getting Started Using the Core Adapter, page 12-61.

Activity Description

Calculate Date Manipulates the values of a date/time variable

See Defining the Calculate Date Activity, page 12-64

Calculate Date Time Difference Calculates the time difference between two different dates.

See Defining the Calculate Date Time Difference Activity, 
page 12-64

Cast Target Type Defines the target type to cast to

See Defining the Cast Target Type Activity, page 12-65

Convert JSON to XML Converts JavaScript Object Notation text to XML. 

See Defining the Convert JSON to XML Activity, page 12-65

Convert XML to JSON Converts XML to JavaScript Object Notation text.

See Defining the Convert XML to JSON Activity, page 12-66

Correlate Process Events Check whether a process occurred within a certain amount of time 
of another problem

See Defining the Correlate Process Event Activity, page 12-66

Create Automation Summary Generates an automation summary for selected activities

See Defining the Create Automation Summary Activity, 
page 12-68

Delete Target Delete a specific target

See Deleting an Object, page 9-12

Find Targets Queries all defined targets

See Defining the Find Target Activity, page 12-69

Format Date Converts date time into a string text format

See Defining the Format Date Activity, page 12-69

Insert Event Inserts one event into Cisco Process Orchestrator Reporting 
Database

See Defining the Insert Event Activity, page 12-70

Match Regular Expression Matches specified string against a specified regular expression

See Defining the Match Regular Expression Activity, page 12-72

Parse Date Converts string text into a date/time format

See Defining the Parse Date Activity, page 12-72

Publish Metric Publishes a single performance metric into the Cisco Process 
Orchestrator Reporting Database

See Defining the Publish Metric Activity, page 12-74
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Getting Started Using the Core Adapter
Use the following process to monitor and manage Core activity instances. 

Step 1 Define a Core command activity (see Defining Core Adapter Activities, page 12-64). 

Step 2 View the activity results (see Monitoring Operations, page 8-1).

Configuring the Core Function Adapter
The Core Function Adapter provides the basic functionality in Cisco Process Orchestrator. Use the Core 
Function Adapter Properties dialog box to configure default email settings, diagnostic report location, 
and Return on Investment calculations.

Raise Process Event Raise an internal event to the Cisco Process Orchestrator server 
based on specific data

See Defining the Raise Process Event, page 12-74

Set Multiple Variables Updates multiple variables in a single activity

See Defining the Set Multiple Variables Activity, page 12-75

Set Variable Modifies the values of a variable.

See Modifying the Value of a Defined Variable, page 12-75

Sleep Specifies the time period to pause between activities in the 
workflow.

See Defining the Sleep Activity, page 12-76

Test FTP Destination Tests the validity of a FTP file path

See Defining the Test FTP Destination Activity, page 12-76

Update Target Update the properties of a specific target

See Defining the Update Target Activity, page 12-76

XPath Query Queries information based on XML path expressions, nodes, as 
well as namespace definitions

See Defining the XPath Query Activity, page 12-77

XSL Transform Applies XSLT transformation to specific XML text. XSLT 
transformation can transform XML into plain text, HTML, or other 
XML

See Defining the XSL Transform Activity, page 12-77

Activity Description
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Configuring Automation Summary Settings

Automation summary reports are generated by activities to provide information about the activity and 
assist in resolving any issues that may need attention. Use the following steps to specify how the 
automation summary reports are to be saved and how long the reports are to be retained. The file paths 
specified indicate the path that will be used when viewing the automation summary reports.

To view automation summary reports, it is recommended that Automation summary reports are saved on 
a UNC share path.

If the automation summary is set to be saved only on the local computer, then only local users will have 
access to the automation summary report. The automation summary will not display for users with 
remote access, such as those accessing Process Orchestrator from the web console or the remote client.

Step 1 Choose Administration > Adapters, right-click Core Functions Adapter and choose Properties.

Step 2 Click the Automation Summary tab to specify where the automation summary reports that are 
generated by activities are to be saved and how long the reports are to be retained.

The file paths specified indicate the path that will be used when viewing the automation summary 
reports.

Step 3 Verify or enter the appropriate default file path for the automation summary directory.

• Share path—Enter the UNC path to a share directory. This path will be used when viewing the 
automation summary reports.

Example:

(\\servername\sharename\path\filename)

Note Verify that the UNC share file path is on a network where the Cisco Process Orchestrator service 
account has write permissions.

Use the following buttons to modify the share path:

• Browse—Launches the Browse for Share dialog box to query the file path to store the automation 
summary reports.

• Create share—Launches the Create Share dialog box to create the directory on the Process 
Orchestrator server where the automation summary reports should be created and stored.

Step 4 Specify the default credentials to be used to access the Orchestrator server on the network share.

• Enable virtual directory mapping—Check this check box to map the file path to an IIS Virtual 
Directory. If the check box is unchecked, then the automation summary will not be saved to a shared 
or IIS virtual directory and will not be available for view from the Web Console.

• Virtual directory path—Enter the http://host:(port)/sharefolder that corresponds to a virtual 
directory in IIS. If necessary, go to IIS Manager to create your Web Sites and your Virtual Directory 
for the share folder. Use the default settings or change the settings, as necessary.

Click Create to launch the Create Virtual Directory dialog box to update the Virtual Directory name.

The file path to the network share where automations may be created and stored.

– Site name—Name of the IIS virtual directory

– Physical path—Display only. File path that corresponds to the virtual directory

\\host\sharefolder
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– Virtual Directory name—Name of the new shared folder

Select the appropriate directory mapping option from the drop-down list to map the automation summary 
to a shared directory or IIS Virtual Directory to allow end-users easier access to automation summaries 
using email or the Process Orchestrator Web Console.

Step 5 Configure the automation summary reports grooming settings.

• Delete automation summary reports older than—Check this check box to limit the number of 
automation summary reports that are retained. Enter the number of days that the reports should be 
retained in the text field. Reports that have been retained for a period past the specified number of 
days will be deleted.

Configuring Return on Investment

Process Orchestrator provides the ability to calculate the Return on Investment (ROI) that is achieved by 
automating your processes. When you create a process, you have the option to enter the equivalent time 
it would take to run the process manually. This value is calculated against the hourly rate specified on 
this page to determine your ROI.

Step 1 Choose Administration > Adapters, right-click Core Functions Adapter and choose Properties.

Step 2 Click the ROI tab and specify the hourly rate (in dollars) that it would cost to execute a process 
manually.

Getting Task XSL Transforms

Each task type has a specific XSL transform that converts the XML into HTML web pages for display 
in the Web Console. Use the Task tab to display the default XSLT transform file names. The files are 
located in the Process Orchestrator program Web Console folder under the following file path:

C://Install Directory/Web Console/Task XSL Transforms

You can change the XSL file name for a specific task when modifying the task properties in the Process 
Editor dialog box.

Step 1 Choose Administration > Adapters, right-click Core Functions Adapter and choose Properties.

Step 2 Click the Task tab, highlight the appropriate task, and right-click and choose Properties.

The Task XSL Transform dialog box displays the default XSL transform file name for the specific task.

Step 3 To view the converted code, use a web browser to launch the appropriate XSLT file that resides in the 
Process Orchestrator install directory/WebConsole folder.
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Publishing Metrics to the Window Management Instrumentation Provider

Use the WMI tab to configure the default settings for publishing metrics into the Windows Management 
Instrumentation (WMI) provider.

Step 1 Choose Administration > Adapters, right-click Core Functions Adapter and choose Properties.

Step 2 Click the WMI tab.

Step 3 Click Publish Metrics to enable the settings to configure the publishing time frame, then set these 
values:

• Poll metrics to publish every—Enter the default number of minutes in the text field to indicate when 
a poll is taken to publish metrics.

• Unpublish metrics older than—Enter the default number of days in the text field to indicate that 
metrics should be unpublished after a certain number of days.

Defining Core Adapter Activities

Defining the Calculate Date Activity

Use the Calculate Date activity to manipulate the values of a date/time variable.

Step 1 In the Process Editor Toolbox, choose Core Activities > Calculate Date, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Calculate Date tab to specify the properties to be used to adjust the date and time frame.

• Original date—Enter the original date/time of the variable.

Format must be according to the regional settings. (mm/dd/yyyy hh:mm:ss)

• Adjustment—Enter the number of units to increase or decrease the time frame. Enter minus (-) prior 
to the value to decrease or enter plus (+) prior to the value to increase. (ex. -5)

Step 4 Click the time unit link to change the modified date/time (from seconds up to days).

Step 5 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Calculate Date Time Difference Activity

Use the Calculate Date Time Difference activity to manipulate the values of a date/time variable.

Step 1 In the Process Editor Toolbox, choose Core Activities > Calculate Date Time Difference, then drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Date Difference tab to specify the properties to be used to adjust the date and time frame.
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• Original date—Enter the original date/time of the variable.

Format must be according to the regional settings. (mm/dd/yyyy hh:mm:ss)

• Adjustment—Enter the number of units to increase or decrease the time frame. Enter minus (-) prior 
to the value in order to decrease or enter plus (+) prior to the value to increase. (ex. -5)

Step 4 Click the time unit link to change the modified date/time (from seconds up to days).

Step 5 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Cast Target Type Activity

Use the Cast Target Type activity to define the target type to cast to.

Step 1 In the Process Editor Toolbox, choose Core Activities > Cast Target Type, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Cast Target Type tab to define the properties specific to the activity. 

• Target—Selected target to cast

• Cast to Type—Selected target type for the target to cast to

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Viewing Results

Click the Cast Target Type display-only tab to view the properties used to cast the target type.

• Target—Selected target to cast

• Target Type—Selected target type to cast

• Cast to Type—Selected target type for the target to cast to

Defining the Convert JSON to XML Activity

Use the Convert JSON to XML activity convert JavaScript Object Notation text to XML which makes it 
easier for users to parse and manipulate XML configuration.

JSON is a text-based open standard designed for human-readable data interchange and is often used for 
serializing and transmitting structured data over a network connection.

Step 1 In the Process Editor Toolbox, choose Core Activities > Convert JSON to XML, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the JSON Source tab to define the properties specific to the activity. 

• Input JSON—Enter the JSON text to be converted to XML. For example:

{"menu": {
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"id": "file",
"value": "File",
"popup": {
"menuitem": [
{"value": "New", "onclick": "CreateNewDoc()"},
{"value": "Open", "onclick": "OpenDoc()"},
{"value": "Close", "onclick": "CloseDoc()"}
]
}
}}

• Specify the root element name for XML—Check the check box to enter the name of the XML root 
element that is generated and recognized in an XML document instance in the enabled text field.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Convert XML to JSON Activity

Use the Convert XML to JSON activity convert XML to JavaScript Object Notation text which makes it 
easier for users to parse and manipulate JSON configuration.

Step 1 In the Process Editor Toolbox, choose Core Activities > Convert XML to JSON, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the XML Source tab to define the properties specific to the activity. 

• Input XML—Enter the XML text to be converted to JSON. For example:

<menu id="file" value="File">
<popup>
<menuitem value="New" onclick="CreateNewDoc()" />
<menuitem value="Open" onclick="OpenDoc()" />
<menuitem value="Close" onclick="CloseDoc()" />
</popup>
</menu>

• Omit XML root element—Check this check box to indicate XML root element should not be 
included in the conversion.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Correlate Process Event Activity

Use the Correlate Process Event activity to check whether a process occurred within a certain amount of 
time of another problem.

Step 1 In the Process Editor Toolbox, choose Core Activities > Correlate Process Event, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.
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Step 3 Click the Event Criteria tab to define the properties specific to the activity, including:

• Correlate events that occur within—Enter a value and select the time unit to indicate the time period 
in which the events should correlate before or after the process start time. The process start time is 
the default object used to correlate events.

– Time unit—Enter the start time value to specify the time period to correlate. Click the time unit 
link to change the time interval.

– Event occurrence—Click the link to determine whether the process start time is before or after 
the event occurs.

• Number of events to correlate—Select one of the following radio buttons to specify which events to 
correlate during the specified time period:

– All events in the above time frame—Select this radio button to correlate all events that occur 
within the specified time frame.

– Number of events—Select this radio button and then enter the number of events to correlate in 
the text field.

• Event Severities—The severity level of the event in that must be matched before the process 
executes (such as Information, Warning, Error, Success audit, or Failure audit).

• Property—Click the Reference tool to launch the Insert Variable Reference dialog box and select the 
event data to correlate

• Comparison—Select the operator to be used to evaluate the expression.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Viewing Results

The Event Criteria display-only tab specifies the event criteria that must occur before or after the process 
starts.

• Correlate events that occur within—Value and time unit indicates the time period in which the events 
should correlate before or after the process start time.

• Number of events to correlate—The selected radio button specifies which events should correlate 
according to the specified start time.

– All events in the above time frame—Correlates all events during the specified time frame.

– Number of events—Correlates the specified number of events to occur during the specified time 
frame

• Event Severities—The severity level of the event in that must be matched before the process 
executes.

– Information

– Warning

– Error

– Success audit

– Failure audit

• Additional Properties to match

– Property—Select event data property to correlate
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– Comparison—Selected operator used to evaluate the expression

– Expression—Expression associated with the selected operator

Defining the Create Automation Summary Activity

An automation summary is a record of process execution. The automation summary includes 
information about the events that trigger processes, activities that were executed, and the data retrieved 
by the executed activities.

Use the Create Automation Summary activity to specify the activities in the process for which an 
automation summary should be generated. To generate the data output, select the activity and then 
specify the section in the automation summary in which to output the data.

The share path specified in the Core Functions Adapter properties will be used when viewing the 
automation summary reports.

If the automation summary is set to not be shared, then only local users on the Process Orchestrator 
server computer will have access to the automation summary report. The automation summary will not 
display for users with remote access, such as those accessing Process Orchestrator from the Web Console 
or the remote client, unless a UNC share or IIS Virtual directory sharing options have been selected.

Step 1 In the Process Editor Toolbox, choose Core Activities > Create Automation Summary, then drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Automation Summary tab to define the properties specific to the activity, including:

• Automation summary style sheet—Select the type of template to be used for the automation 
summary. 

– Table of Configuration Properties

– Situation Analysis Report (default)

• Include the following items—Select the activity or trigger/event, since events and triggers can be 
included into the automation summary as well, and specify the section of the automation summary 
to include the reporting details and whether the activity is the root cause of any issues that are 
detected.

– Name—Name of the activities that are included in the process

– Section—Name of the section of the automation summary where the data will be stored

– Root cause—Yes indicates the Is the root cause check box is checked

• Section—Specify the section of the automation summary template in which to export the data:

– SituationAnalysis—After a situation that requires action is identified, the state and diagnostic 
information is displayed in the Situation Analysis section of the automation summary.

– ContextAnalysis—After a situation is analyzed in context with other situations, the symptom 
and cause is displayed in the Context Analysis section of the automation summary.

• Is the root cause—List the activity or event at the top of the automation summary, or identified as 
the root cause of the problem.

• Last instance information only—Indicate that the automation summary must include only 
information for the latest execution of the activity instance.
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This setting is only for activities that are inside the loop of a workflow component (While or For 
Each). If this setting is not selected, the automation summary will include information about all 
instances of activity, for all iterations of the loop.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Find Target Activity

Use the Find Target activity to query a list of defined targets matching specific target attribute criteria. 

Step 1 In the Process Editor Toolbox, choose Core Activities > Find Target, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Find Targets tab to define the properties specific to the activity, including:

• Target type—Select the appropriate target type to be queried.

• Choose a target group—Select the appropriate target group to be queried. Only target groups defined 
in Process Orchestrator in which the user has Use permission will be available.

• Properties to Match—Select the appropriate exposed target criteria to use to query a list of defined 
targets in Process Orchestrator:

– Property—select the appropriate exposed target property to query.

– Operator—Select the appropriate operator to include to match to the criteria. The displayed 
operators depend on the selected property. For additional information, see Common Operators

– Expression—Select the appropriate wildcard expression to associate with the selected operator. 

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Format Date Activity

Use the Format Date activity to convert date and time into a string text format.

Step 1 In the Process Editor Toolbox, choose Core Activities > Format Date, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Format Date tab to define the properties specific to the activity, including:

• Original Date—Click the Reference tool to select the appropriate date/time variable reference, such 
as the Process > Start Time reference variable, to be used to format the string.

To customize the specific date/time of the variable reference, add the Parse activity to the process 
and use that activity to modify the selected date/time.
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Insert Event Activity

Use the Insert Event activity to view or specify the properties that display depending on the selected 
event.

Step 1 In the Process Editor Toolbox, choose Core Activities > Insert Event, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Event tab to define the properties specific to the activity, including:

• ID—Unique identifier for the process event

• Subject—The subject line of the event message

• Category—The category assigned to the event

• Severity—The severity level of the event (Information, Warning, Error, Success audit, Failure audit)

• Automation Summary (URL)—URL for the related automation summary

Step 4 Click the Parameters tab to define parameters for a specific task.

Step 5 Click the Affects tab to specify the elements that trigger the selected target.

• This event applies to the following target— Specify the affected target to be used in the activity.

• Process target—Use the process target as the affected target in the activity.

• Activity target—specify the affected target for a specific task activity.

– Activity target—Select the activity containing the target that will be used. Only task activities 
will display in the list.

– Target Reference—Specify the affected target that will be used.

To view the properties for the selected target, click the Properties  tool. To create a new 
target, click New > [Target].

– Specific target group—Specify the affected target group that will be used.

To view the properties for the selected target group, click the Properties  tool. To create a 
new target group, click New > [Target Group].

From the Choose a target using this algorithm drop-down list, specify which target will be 
chosen from the eligible target group members. 

Target Algorithms

– Choose any target that satisfies  the specified criteria—Executes the process on any targets 
defined by the criteria specified in the Target Selection dialog box.

– Choose the target with the specified name—Executes the process on the member of the group 
specified in the Name to match text field.

• This event applies to the following configuration item—Specify the configuration item to be used 
in the activity

• Name—Name of the configuration item (IT component) to which the alert pertains. For example, 
the name of a database server that failed or the name of a specific job that failed.
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• Type—Enter the appropriate configuration item type or select the type of ITIL configuration item 
(IT component) from the list which the alert describes. For example, the type of the specific 
application element that failed (Application Server, Database, Host, or User).

• This is a CMDB reference—Indicate that the true source of the CI is in the CMDB, so the 
configuration item properties reference a CMDB entry.

• Object key—ID for the specific record in the CMDB that contains the configuration item

• Object source—Name for the specific record in the CMDB that contains the target configuration 
item

Step 6 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Viewing Results

Click the Events display-only tab to view the batch of events generated by the activity in the Reporting 
database.

• Event ID—Identifier used for the event

• Subject—Name of the event

• Affected Target Configuration Item Type—Type of ITIL configuration item (IT component) or 
application element which failed such as a server, database, host, or user

• Affected Target Configuration Item Source—Name for the specific record in the CMDB which 
contains the target configuration item

• Affected Target Configuration Item Object Name—Name of the configuration item (IT component) 
which failed or the name of a specific job which failed.

• Affected Target Configuration Object Key—ID for the specific record in the CMDB which contains 
the configuration item

• Configuration Item Type— Type of ITIL configuration item (IT component) which the alert 
describes.

Example—The type of the specific application element which failed:

– Application Server

– Database

– Host

– User

• Source—Name for the specific record in the CMDB which contains the target configuration item

• Category—Category for the event

• Severity—Severity of the event

– Error 

– Warning

– Information

– Success Audit

– Failure Audit

• Automation Summary—File path for the automation summary report
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• Description—Brief description of the event

• Parameter [1-10]—Values of the parameter

• Time Generated—Date and time the event was generated

Defining the Match Regular Expression Activity

Use the Match Regular Expression activity to match specified string text against a specified regular 
expression.

Step 1 In the Process Editor Toolbox, choose Core Activities > Match Regular Expression, then drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Regular Expression tab to define the properties specific to the activity, including:

• Regular Expression—Specify a fixed string to represent the regular expression to be used in 
matching

Click the Expression arrow to view frequently used symbols.

• Match case—Check the check box to specify whether regular expression matching should be 
case-sensitive

• Input string—Enter the input string for text to be parsed and matched against the specified regular 
expression.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Parse Date Activity

Use the Parse Date activity to convert string text into a date/time format.

Step 1 In the Process Editor Toolbox, choose Core Activities > Parse Date, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Parse Date tab to define the properties specific to the activity, including:

• Input String—Enter the date or time string to be parsed.

• For details about other date properties, see Defining the Insert Event Activity, page 12-70

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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Defining the Ping Hosts Activity

Use the Ping Hosts activity to ping IP address.

Step 1 In the Process Editor Toolbox, choose Core Activities > Ping Hosts, then drag and drop the activity onto 
the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Ping tab to define the properties specific to the activity, including:

• Hosts—Enter 1 or more IP addresses or name of the servers.

Note For a single entry, you can enter multiple hosts separated by commas.

• Number of echo requests to send—Enter the number of echo request (default is 4).

• Timeout—Enter the time period the activity should wait before failing. Click the time unit link to 
change the time interval.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Ping Hosts Results

The Results tab displays the Ping results of the Hosts entered in the activity.

Note The activity will stop, when it’s timeout. It will not continue to ping the rest of the hosts.

Note The activity doesn’t stop just because it is not able to reach some of the hosts.

Column Description

Host The host name or IP address.

Package Sent Displays the number of Packets sent.

Package Received Displays the number of Packets received.

Package Lost Displays the number of Packets lost.

Minimum Round Trip (in 
milliseconds)

Displays the minimum time taken for packets to travel from 
a specific source to a specific host destination and back again.

Maximum Round Trip (in 
milliseconds)

Displays the maximum time taken for packets to travel from 
a specific source to a specific host destination and back again.

Average Round Trip (in 
milliseconds)

Displays the average time taken for packets to travel from a 
specific source to a specific host destination and back again.
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Defining the Publish Metric Activity

Use the Publish Metric activity to define the performance metric properties to be published into the 
Reporting Database and the Windows Management Instrumentation (WMI) provider.

The metrics are published under the root\Process Orchestrator name space using the WMI class, 
CPO_PerformanceMetric. Use the Metrics page to define the performance metric properties to be 
published into the Process Orchestrator Reporting Database and the Windows Management 
Instrumentation (WMI) provider.

Step 1 In the Process Editor Toolbox, choose Core Activities > Publish Metric, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Metrics tab to define the properties specific to the activity, including:

• Object name—Object name of the metric

• Counter name—Counter name of the metric

• Instance name—Name of the instance

• Value—Performance metric value

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Raise Process Event

Use the Raise Process Event activity to raise an internal event to the Cisco Process Orchestrator server 
based on specific data.

Step 1 In the Process Editor Toolbox, choose Core Activities > Raise Process Event, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Event tab to define the properties specific to the activity, including:

• ID—The identifier to be used for the event

• Subject—The name of the event

• Category—The category for the event

• Severity—The severity of the event (Error, Warning, Information, Success Audit, Failure Audit)

• Source—Source of the event. For Cisco Process Orchestrator-generated events through Raise 
Process Event, the source is the Cisco Process Orchestrator: process name that raised the event.

• Description—A brief description of the event.

Response Displays the results of the Ping.

Status Code Status code indicates whether a request is successful or 
unsuccessful.

Column Description
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Set Multiple Variables Activity

Use the Set Multiple Variables activity to update multiple variables in a single activity. This activity will 
update each defined variable in the activity, one by one, as well as perform the necessary auditing for 
each updated variable.

If updating a single variable, use the Set Variable activity (see Modifying the Value of a Defined 
Variable, page 12-75).

Step 1 In the Process Editor Toolbox, choose Core Activities > Set Multiple Variables, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Variable tabs to define the properties specific to the activity, including:

• Variable—Click the Reference tool to select the variable reference property to be updated.

• New Value—Enter the new value of the variable. You can also click the Reference tool to select a 
variable reference property to be used to update the variable.

For a Boolean variable, the text entered in this field (true or false) is case-sensitive and must be 
entered all lowercase.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Modifying the Value of a Defined Variable

Step 1 In the Process Editor Toolbox, choose Core Activities > Set Variable, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Variable tab to define the properties specific to the activity, including:

• Variable to update—Select the appropriate variable to be modified.

• Variable data type—Data type associated with the selected variable.

• Current value—The current value of the selected variable.

• New value—Enter or select a new value of the variable.

For a Boolean variable, the text entered in this field (true or false) is case-sensitive and must be 
entered all lowercase.

Formulas can also be included to modify variable values. For example:

– 5+10

– [Activity.Reference1] / [Activity.Reference2] * 100) + [Activity.Reference3]

– [Activity.PropertyName1] [Activity.PropertyName2]
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Sleep Activity

Use the Sleep activity to specify the time period to pause between activities in the workflow.

Step 1 In the Process Editor Toolbox, choose Core Activities > Sleep, then drag and drop the activity onto the 
Workflow pane.

Step 2 Click the General tab and enter the appropriate information. 

Step 3 Click the Result Handlers tab to modify the list of condition branches on the process.

Defining the Test FTP Destination Activity

Use the Credentials tab to specify the runtime user that should be used for execution.

Step 1 In the Process Editor Toolbox, choose Core Activities > Set Variable, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the FTP tab to define the properties specific to the activity, including:

• Use process runtime user—Use the credentials for the runtime user that was specified for the process

• Override process runtime user—Specify different credentials than what are used for the process. The 
selected runtime user overrides the runtime user that was specified for the process.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Update Target Activity

Use the Update Target activity to update the properties of a specific target.

Step 1 In the Process Editor Toolbox, choose Core Activities > Update Target, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Target tab to define the properties specific to the activity, including:

• Target—Name of the target

• Target Type—Type of target

•  Target—Indicates the target will be d

• Properties to update—The target properties available for update
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the XPath Query Activity

Use the XPath Query activity to query information based on XML path expressions, nodes, as well as 
namespace definitions. If the query matches more than one node in the XML document, an error will be 
generated.

Step 1 In the Process Editor Toolbox, choose Core Activities > XMPath Query, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the XPath Query tab to define the properties specific to the activity, including the source XML 
text to be queried.

Step 4 Modify the list of namespace definitions.

Step 5 Click Namespace to display the namespace column descriptions.

Step 6 Click XPath Queries to display the XPath queries column descriptions, including:

• XPath Query—Enter the path expression to query.

• Property Name—Enter the property name to display on the Results tab after the activity has run.

• Property Type—Select the data type associated with the path expression to query (String, Numeric, 
Boolean, or DateTime).

Step 7 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the XSL Transform Activity

Use the XSL Transform activity to apply XSLT transformation to specific XML text. XSLT 
transformation can transform XML into plain text, HTML, or other XML.

Step 1 In the Process Editor Toolbox, choose Core Activities > XMPath Query, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the XSL Transform tab to define the properties specific to the activity, including:

• Specify XSL document—Select this radio button to transform a specific XSL document, then enter 
the XSLT style sheet for the XSL document. 

• XSL transform—Select this radio button to transform XSL text from a specific file path, then enter 
the appropriate file path of the XSL file. 

• Source XML to transform—Source XML text to be transformed.

• Output Format—Select the radio button to determine the appropriate output in the automation 
summary and activity instance (HTML, XML).
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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Database Adapter—Microsoft SQL Server
Use the Cisco Process Orchestrator SQL Server Database Adapter to automate common SQL queries in 
the SQL Server database.

The following table displays activities that are provided by the Microsoft SQL Server database adapter. 
For more information about using these activities, see Getting Started Using the Microsoft SQL Server 
Database Adapter, page 12-80.

Activity Comments

Bulk Insert SQL Server Enter the source table that will be used to insert data into an SQL Server 
database. 

For more information, see Performing Bulk Database Insertions, 
page 12-94.

Check SQL Server Buffer 
HitRate

Query the percentage of pages that were found in the buffer pool without 
having to incur a read from disk.

Check SQL Server 
Database Space

Query the total amount of database space the server is currently 
consuming. 

Check SQL Server Disk 
Space

Query the total amount of disk space the database is currently consuming. 

The result of the query is the amount of available database memory.

Check SQL Server Locks Display the results of the query for the locks performed in the SQL server 
database.

For more information, see Configuring Database Adapters, page 12-97.

Check SQL Server 
Memory

Query the total amount of dynamic memory the server is currently 
consuming. 

Check SQL Server Page 
Life Expectancy

Query the number of seconds a page will stay in the buffer pool without 
references.

Delete from SQL Server Delete data from the SQL server database using SQL command lines.

Enter the command text for the selected database. For example, this is a 
simple DELETE statement:

DELETE from mytable where mycolumn = 'zzz'

Execute SQL Server SQL 
Script

Execute an SQL script against an SQL server database.

For more information, see Executing a Generic (OLEDB) SQL Script, 
page 12-84

Insert into SQL Server Insert one database activity into an SQL server database. 

Enter the command text for the selected database. For example, to insert 
values into a table:

INSERT into mytable (column1,column2) VALUES ('val1','val2')
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Getting Started Using the Microsoft SQL Server Database Adapter
Use the following process to monitor and manage Microsoft SQL Server database instances. 

Step 1 Create a Microsoft SQL Server database target (see Defining an SQL Server Database Target, 
page 12-81).

Step 2 Define a Microsoft SQL Server database activity. 

a. In the Process Editor Toolbox, choose Database > Microsoft SQL Server > [Microsoft SQL 
Server Database Activity], then drag and drop the activity onto the Workflow pane.

b. Click the General tab and enter the required information.

c. Click the [Activity-Specific] tabs to define the properties specific to the activity. 

d. Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

For details about a specific activity, see Automating SQL Queries in the Microsoft SQL Server Database, 
page 12-81.

Step 3 View the activity results (see Monitoring Operations, page 8-1).

List SQL Server Running 
SQL Queries

Display the results of the running SQL queries performed in the SQL 
server database.

Specify the information that describes the query results, including:

• Row Limit—The appropriate number rows to limit for the query and 
returned data (default=50).

Select from SQL Server Query data from an SQL server database. 

For more information, see Configuring Database Adapters, page 12-97.

Select From Report 
Database

Query data from a report database. 

For more information, see Configuring Database Adapters, page 12-97.

Note Use a different Select activity when switching between databases.

SQL Server Lock 
Information 

Use this activity to display a list of all client processes that have locks. 

For more information, see Configuring Database Adapters, page 12-97.

Update SQL Server Use this activity to update column information in the SQL Server database 
using SQL command lines.

Enter the command text for the selected database. For example, this 
sample query updates the columns in a table:

Update mytable set column1 = 'newvalue' where column2 = 'zzz'

Activity Comments
12-80
Cisco Process Orchestrator 3.3 User Guide



 

Appendix 12      Using Adapters
  Database Adapter—Microsoft SQL Server
Defining an SQL Server Database Target
Use the SQL Server Database target to specify the connection information for a SQL server target.

Step 1 Choose Definitions > Targets, right-click and choose New > SQL Server Database.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Connection tab and enter the required information, including:

• Server—Host name or IP address of the database server

• Default runtime user—The default runtime user account that contains the credentials to connect to 
the target. 

• Connection string—The information needed to establish a connection to the database. To connect to 
a non-default instance, use the (server\instance) format. If your SQL server has a non-default port 
number, the correct format is to enter the server\instance, then a comma, then the port number. For 
example:

servername,portnumber

Step 4 Click the Permission tab to define the type of SQL commands that can run on the target.

Step 5 Click OK to close the dialog box and complete the procedure.

Automating SQL Queries in the Microsoft SQL Server Database

Executing a Microsoft SQL Server SQL Script

Use this activity to execute SQL script against a Microsoft SQL Server database.

Step 1 In the Process Editor Toolbox, choose the [Microsoft SQL Server Database Activity] property page, 
then click the Execute SQL Server SQL Script tab.

Step 2 Specify the information that describes the script you want to run, including the script text for the selected 
database. For example:

• To truncate a sample table Employees:

TRUNCATE TABLE Employees

• To execute a stored procedure:

exec master..xp_logininfo

.
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Database Adapter—Generic (OLEDB)
Use the Generic (OLEDB) Adapter to automate common SQL queries in a generic Microsoft Object 
Linking and Embedding Database (OLEDB) database.

The following table displays activities that are provided by the generic Microsoft OLEDB database 
adapter. For more information about using these activities, see Getting Started Using the Generic 
(Microsoft OLEDB) Database Adapter, page 12-83.1

Activity Comments

Bulk Insert into Generic 
Database

Provides source table for data inserted into a generic database. 

For more information, see Performing Bulk Database Insertions, 
page 12-94.

Generic Database Locks Queries the locks performed in the generic database. 

For more information, see Configuring Database Adapters, page 12-97.

Generic Database Table 
Space

Queries the table space in a generic database. 

Delete from Generic 
Database

Deletes data from the generic database using SQL command lines. 

Enter the command text for the selected database. For example, this is a 
simple DELETE statement:

DELETE from mytable where mycolumn = 'zzz'

For more information, see Deleting Data from a Database, page 12-96.

Execute Generic Database 
SQL Script

Use the Execute Generic Database SQL Script activity to execute SQL 
script against the specified database.

New support in release 3.0 allows retrieval of data tables from SAP HANA 
databases. The activity can retrieve the data table directly or through the 
mechanism HANA uses.

For more information, see Executing a Generic (OLEDB) SQL Script, 
page 12-84.

Insert Into Generic 
Database

Executes SQL command used to insert data into a generic database. 

Enter the command text for the selected database. For example, this query 
inserts values into a table:

INSERT into mytable (column1,column2) VALUES ('val1','val2')

List Generic Database 
Running SQL Queries

Queries the running SQL queries performed. 

Specify the information that describes the query results, including:

• Row Limit—The appropriate number rows to limit for the query and 
returned data (default=50).
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Getting Started Using the Generic (Microsoft OLEDB) Database Adapter
Use the following process to monitor and manage generic Microsoft OLEDB database instances. 

Step 1 Create a generic Microsoft OLEDB database target (see Defining a Generic Data Source (OLEDB) 
Target, page 12-83).

Step 2 Define a generic Microsoft OLEDB database activity. 

a. In the Process Editor Toolbox, choose Database > Generic (OLEDB) > [Generic (OLEDB) 
Database Activity], then drag and drop the activity onto the Workflow pane.

b. Click the General tab and enter the required information.

c. Click the [Activity-Specific] tabs to define the properties specific to the activity. 

d. Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

For details about a specific activity, see Automating SQL Queries in the Generic (Microsoft OLEDB) 
Database, page 12-84.

Step 3 View the activity results (see Monitoring Operations, page 8-1).

Defining a Generic Data Source (OLEDB) Target
Use the Generic Data Source (OLEDB) Database target to specify the connection information for a 
generic database.

Step 1 Choose Definitions > Targets, right-click and choose New > Generic Data Source OLEDB Database.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Connection tab and enter the required information, including:

• Database Source—Database server name and database name

• Database Owner—Principal owner of the database

• Default runtime user—The default runtime user account that contains the credentials to connect to 
the target. 

• Connection string—Check the check box and enter the information needed to establish a connection 
to the database. 

Select from Generic 
Database

Queries data from generic database. 

For more information, see Configuring Database Adapters, page 12-97.

Update Generic Database Updates column information in the generic database using SQL command 
lines. 

Enter the command text for the selected database. For example, this query 
updates columns in a table:

Update mytable set column1 = 'newvalue' where column2 = 'zzz'

Activity Comments
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Step 4 Click the Configuration tab to specify the character restrictions for a database identifier. A distinction 
is made between simple identifiers and special identifiers.

Step 5 Click the Permission tab to define the type of SQL commands that can run on the target.

Step 6 Click OK to close the dialog box and complete the procedure.

Automating SQL Queries in the Generic (Microsoft OLEDB) Database

Executing a Generic (OLEDB) SQL Script

This script executes an SQL script against a Generic (OLEDB) database.

Step 1 In the Process Editor Toolbox, choose the [Generic (OLEDB) SQL Database Activity] property page, 
then click the Execute Generic Database SQL Script tab.

Step 2 Specify the information that describes the script you want to run, including the SQL script text for the 
selected database. For example, to encrypt data using the ODBC ENCRYPT function:

create proc #tfn

as

select { fn USER() } , { fn CURRENT_DATE() },

{ fn CURRENT_TIME() }, { fn CURRENT_TIMESTAMP() }

go

exec #tfn

go

drop proc #tfn

Step 3 In the Columns panel, click Add to display the Table Column properties dialog box and define the table 
column and data type to be displayed.

Step 4 Enter the other criteria as necessary.
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Database Adapter—Oracle
Use the Oracle Database Adapter to automate common SQL queries in the Oracle database.

The following table displays activities that are provided by the Oracle database adapter. For more 
information about using these activities, see Getting Started Using the Oracle Database Adapter, 
page 12-86.

Activity Comments

Bulk Insert Oracle Use this activity to enter the source table that will be used to insert data 
into an Oracle database. 

For more information, see Performing Bulk Database Insertions, 
page 12-94.

Check Oracle Library 
Cache

Use this activity to query the library cache for an Oracle database.

Check Oracle Row Cache 
Hit Ratio

Use this activity to query the rows of the library cache shared by the hits 
and misses due to the overlap of when a large number of users are entering 
and exchanging data.

Check Oracle Table Scan Use this activity to query the table activity on the Oracle database.

Delete from Oracle Use this activity to delete data from the Oracle database using SQL 
command lines.

Enter the command text for the selected database. For example, this is a 
simple DELETE statement:

DELETE from mytable where mycolumn = 'zzz'

Display Oracle Free 
Memory

Use this activity to query the available memory in the shared pool of the 
Oracle database.

Execute Oracle SQL 
Script

Use this activity to execute SQL script against the specified database.

For more information, see Defining an SQL Server Database Target, 
page 12-81.

Insert Into Oracle Use this activity to enter the SQL command that will be used to insert data 
into an Oracle database.

Enter the command text for the selected database. For example, this query 
inserts values into a table:

INSERT into mytable (column1,column2) VALUES ('val1','val2')

List Oracle Heavy Queries Use this activity to query the statistics on SQL statements that are in 
memory, parsed, and ready for execution.

For more information, see Listing the Oracle Heavy Queries.
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Getting Started Using the Oracle Database Adapter
Use the following process to monitor and manage Oracle database instances. 

Step 1 Create an Oracle database target (see Defining an Oracle Database Target, page 12-87).

Step 2 Define an Oracle database activity. 

a. In the Process Editor Toolbox, choose Database > Oracle > [Oracle Database Activity], then drag 
and drop the activity onto the Workflow pane.

b. Click the General tab and enter the required information.

c. Click the [Activity-Specific] tabs to define the properties specific to the activity. 

d. Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

For details about a specific activity, see Automating Oracle Database Activities, page 12-87.

Step 3 View the activity results (see Monitoring Operations, page 8-1).

List Oracle Running SQL 
Queries

Use this activity to query the running SQL queries performed in the Oracle 
database.

Specify the information that describes the query results, including:

• Row Limit—The appropriate number rows to limit for the query and 
returned data (default=50).

Oracle Database Lock Use this activity to query the locks performed in the Oracle database.

For more information, see Editing Locked Processes, page 5-32.

Oracle Table Space Use this activity to query the amount of table space for an Oracle database.

For more information, see Viewing the Oracle Table Space.

Select from Oracle Use this activity to query data from the Oracle database using SQL 
command lines. 

For more information, see Configuring Database Adapters, page 12-97.

Select from Oracle 
Reporting Database

Use this activity to query data from a report database.

For more information, see Configuring Database Adapters, page 12-97.

Update Oracle Use this activity to update column information in the Oracle database 
using SQL command lines.

Enter the command text for the selected database. For example, this query 
updates columns in a table:

Update mytable set column1 = 'newvalue' where column2 = 'zzz'

Activity Comments
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Defining an Oracle Database Target
Use the Oracle Database target to specify the connection information for an Oracle database. The 
connection properties allows customers to connect to a standard Oracle Database target or an Oracle 
Database target via RAC support. An Oracle client is required when connecting to a target requiring RAC 
support.

Step 1 Choose Definitions > Targets, right-click and choose New > Oracle Database.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Connection tab and enter the required information.

Under the Connect to radio buttons, indicate the database connection type for the target and determine 
whether to connect to a target requiring RAC support.

• Hostname—Select this radio button and enter the local network service name, hosting system, or IP 
address and other relevant source information for the database. 

– Port Number—Port number used to access Oracle database

– SID—Oracle system ID used to identify the Oracle database

• RAC via TNS—Select this radio button and enter the TNS connection string to indicate the RAC 
target connection.

Oracle 11g R2 64bit client is required for this connection and the tnsnames.ora is configured with 
the TNS RAC target connection. For example, to specify the RAC via TNS connection, enter:

TNS RAC target connection name

Step 4 Click Connection Credentials and enter the necessary connection credentials to access the database, 
including:

• Database Owner—Principal owner of the database

• Default runtime user—The default runtime user account that contains the credentials to connect to 
the target.

• Connection string—The information needed to establish a connection to the database. For example, 
this establishes a direct connection:

Data Source=testserver;SID=oracle;port=1521;Unicode=true;

Step 5 Click the Permission tab to define the type of SQL commands that can run on the target.

Step 6 Click OK to close the dialog box and complete the procedure.

Automating Oracle Database Activities

Modifying Oracle DB Instance Case-Sensitive Settings

Use the following script to change the case-sensitive settings in the Oracle database.

Before You Begin

You must have database administrative rights to execute this script.
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Step 1 Run this script:

ALTER SYSTEM SET NLS_COMP=LINGUISTIC scope=spfile;

ALTER SYSTEM SET NLS_SORT=BINARY_CI scope=spfile;

Step 2 Reset the database server.

Executing an Oracle SQL Script

This script executes an SQL script against the Oracle database.

Step 1 In the Process Editor Toolbox on the [Oracle SQL Database Activity] property page, click the Execute 
Oracle Database SQL Script tab.

Step 2 Specify the information that describes the script you want to run, including the script text for the selected 
database. For example:

exec dbms_lock.sleep(5);;

Example 2

DECLARE 

DEPARTMENT_ID NUMBER;

BEGIN 

DEPARTMENT_ID := NULL;

SYSTEM.EMPTEST300 ( DEPARTMENT_ID );

DBMS_OUTPUT.PUT_LINE(DEPARTMENT_ID);

COMMIT;

END;

Reviewing the SQL Script

Use the Info tab to review the SQL command used when executing the activity.

Viewing the Oracle Table Space

Use this activity to query the total amount of space the Oracle database is currently consuming. 

Step 1 In the Process Editor Toolbox, choose the [Database Activity] property page, then click the Oracle 
Table Space tab.

Step 2 Specify the information that describes the data you want to insert, including:

• Autoextensible (only Oracle 9i and below)—Check this check box to indicate that the table space 
should automatically grow in size when necessary.
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Note This option is not available for Oracle 10G and above.

Listing the Oracle Heavy Queries

Use this activity to query the statistics on SQL statements that are in memory, parsed, and ready for 
execution.

Step 1 In the Process Editor Toolbox, choose the [Database Activity] property page, then click the List Oracle 
Heavy Queries tab.

Step 2 Specify the information that describes the data you want to insert, including:

• Use database target query timeout—Use the timeout value indicated in the database target as the 
length of time to wait before a command is complete.

• Override database target query timeout—Override the timeout value indicated in the database target.

Note Click the time unit link to change the timed out interval (such as seconds, minutes, hours, days)

• Row Limit—The appropriate number rows to query and return (default=30).

• Process list—Comma-delimited list of processes IDs.

• CPU Time—The CPU time (in microseconds) used by this cursor for parsing, executing, and 
fetching (default=60000000).

• Disk Reads—The default number of disk reads over all child cursors (default=1000).

• Buffer Gets—The default number of buffer gets over all child cursors (default=10000).

• Executions—The total number of executions, totaled over all the child cursors (default=100).

• Time—Enter the maximum amount of time that should be used to query the database (default=60 
minutes).

Note Click the time unit link to change the timed out interval.
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Database Adapter—JDBC
Use the Java Database Connectivity (JDBC) adapter to connect to a generic database via JDBC driver.

The following table displays activities that are provided by the JDBC adapter. For more information 
about using these activities, see Getting Started Using the JDBC Adapter, page 12-90.

Getting Started Using the JDBC Adapter
Use the following process to monitor and manage JDBC adapter instances.

Step 1 Configure a JDBC Driver Type (see Configuring the JDBC Driver Type, page 12-91).

Step 2 Create a JDBC Server target (see Defining a JDBC Server Target, page 12-91).

Step 3 Define a JDBC command activity (see Automating SQL Queries in the Database Via JDBC, page 12-92).

Step 4 View the activity results (see Monitoring Operations, page 8-1).

Prerequisites

Downloading the JDBC Driver Type (JAR File)

The JDBC adapter requires the JDBC driver to be downloaded from the database provider and the JAR 
file of the JDBC driver to be copied into the Cisco Process Orchestrator server before you begin the 
configuration.

On the Cisco Process Orchestrator install directory, copy the JAR file in the following location:

<Install drive>:\Program Files\Cisco\Process Orchestrator\Adapters\JdbcDrivers

Activity Name Description

Select From via JDBC Queries data from the database. For more information, see Selecting 
Data from a Database, page 12-94.

Update via JDBC Updates column information in the database using SQL command 
lines. For more information, see Updating Data from a Database, 
page 12-95.

Bulk Insert via JDBC Provides source table for data inserted into a database. For more 
information, see Performing Bulk Database Insertions, page 12-94.

Inset via JDBC Executes SQL command used to insert data into a database. For 
more information, see Inserting Data from a Database, page 12-95.

Execute SQL via JDBC Use this activity to execute SQL script against the specified 
database.

For more information, see Executing SQL Script via JDBC, 
page 12-92.

Delete via JDBC Deletes data from a database using SQL command lines. For more 
information, see Deleting Data from a Database, page 12-96.
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For installation information, see the documentation provided for the applicable database platform.

Before You Begin

• Choose the right JAR file

• Setup the Classpath

Configuring the JDBC Driver Type

Step 1 Choose Administration > Adapters, and then double-click the JDBC Adapter.

Step 2 On the JDBC Adapter Properties dialog box, click the JDBC Drivers tab.

If you have JDBC drivers already configured, they are displayed in this tab.

Step 3 To configure a new JDBC Driver type, click New > JDBC Driver Type.

Step 4 Click the General tab and enter the required information.

Step 5 Click the JDBC Driver tab and enter the required information, including:

• Jar file name—Select the available jar file name from the drop-down list.

Note For the jar file names to appear in the drop-down list, you must have installed the JDBC driver 
and copied the jar files in the Cisco Process Orchestrator server location.

• Driver class full name—Enter the name of JDBC driver classpath.

• Provider name—Enter the JDBC provider name.

• Default port—Enter the JDBC protocol port number.

• Connection URL—Check the check box and enter the information needed to establish a connection 
to the database. Refer to the following format as an example to enter the connection string using 
IPV4 and IPV6:

IPV4
jdbc:<DatabaseName>://[TargetServerName]:[TargetPost]/TargetDatabaseName

IPV6
jdbc:<DatabaseName>://address=(Protocol=tcp)[host=TargetServerName]:[port=TargetPos
t]/TargetDatabaseName

Step 6 Enter the information in the remaining tabs as necessary, then click OK to complete the process of 
configuring the JDBC driver type.

Defining a JDBC Server Target
Use the Java Database Connectivity (JDBC) server target to specify the connection information for a 
generic database.
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Step 1 On the Definitions workspace, right-click Targets and choose New > JDBC Database to open the JDBC 
Database Properties.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Connection tab and enter the required information, including:

• JDBC Driver—Select the available JDBC driver from the drop-down list.

If you have not yet configured the JDBC driver type, click New. For more information about 
configuring a new JDBC driver, see Configuring the JDBC Driver Type, page 12-91.

• Server—Host address or the IP address of the database server.

• Port Number—Port number used to access the SQL database.

• Database Name—Enter the name of the database.

• Default Runtime User—Choose the user account that contains the credentials to connect to the 
database from the drop-down list.

• Connection String—Check the check box and enter the information needed to establish a connection 
to the database. Refer to the following format as an example to enter the connection string using 
IPV4 and IPV6:

IPV4
jdbc:<DatabaseName>://[TargetServerName]:[TargetPost]/TargetDatabaseName

IPV6
jdbc:<DatabaseName>://address=(Protocol=tcp)[host=TargetServerName]:[port=TargetPos
t]/TargetDatabaseName

• Default Timeout For Activities—Enter the number of seconds before the activity times out. The 
default timeout period is 120 seconds.

Step 4 Click the Configuration tab to specify the character restrictions for a database identifier. A distinction 
is made between simple identifiers and special identifiers.

Step 5 Click the Permission tab to define the type of SQL commands that can run on the target.

Step 6 Click OK to close the dialog box and complete the procedure.

Automating SQL Queries in the Database Via JDBC

Executing SQL Script via JDBC 

This script executes an SQL script against a Generic (JDBC) database.

Step 1 In the Process Editor Toolbox, choose the [Execute SQL via JDBC] property page, then click the SQL 
tab.

Step 2 Specify the information that describes the script you want to run, including the SQL script text for the 
selected database.

Step 3 In the Columns panel, click Add to display the Table Column properties dialog box and define the table 
column and data type to be displayed.
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Step 4 Enter the other criteria as necessary.

Errors

You may receive error messages at any time. Please go back and review your query setup to troubleshoot.
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Database Adapter—Common Database Tasks
The following sections describe some of the tasks that are common to most or all supported databases.

Performing Bulk Database Insertions

Step 1 In the Process Editor Toolbox, choose the [Database Activity] property page, then click the Bulk Insert 
into [Database] tab.

Step 2 Specify the information that describes the data you want to insert, including:

• Data source—Source table variable. If necessary, click the Reference tool to locate a global table 
variable.

• Target table name—The table name targeted in the database.

• Populate columns from data source—List the columns from the data source directly into the 
Columns section.

• Column Map List—Display the columns generated by the data source.

• Use database target query timeout—Use the timeout value indicated in the database target as the 
length of time to wait before a command is complete.

• Override database target query timeout—Select this button and enter the appropriate value to use to 
override the timeout value indicated in the database target.

Selecting Data from a Database

Step 1 In the Process Editor Toolbox, choose the [Database Activity] property page, then click the Select 
From [Database] tab.

Step 2 Specify the information that describes the data you want to select, including:

• SQL command text—The command text for the selected database. Verify that the SQL command is 
entered correctly. The data in the database is case-sensitive. 

For example, this is a sample query that selects specific columns from a table:

SELECT column1,column2 from mytable

This is a sample query that selects the country code and the name of the country:

SELECT code, name from country

• Populate columns from query—List the columns from the SQL query directly into the Columns 
section.

• Columns—Displays the columns generated by the SQL query.

• Return all columns of Select statement—Return all columns of a Select statement, regardless of 
whether a column type is defined in the activity.

The returned data will be stored in a data table and will be available for use in an automation 
summary.

• Row number per page—The number of rows to display per page (default=100).
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• Maximum number of rows—The maximum number of rows to display (default=200).

Updating Data from a Database

Step 1 In the Process Editor Toolbox, choose the [Database Activity] property page, then click the Update 
[Database] tab.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the SQL tab to specify the SQL command and target query information.

Step 4 Complete the appropriate information in the following tabs, as necessary, and then click the Save tool to 
complete the activity definition.

• Target—Specify whether the process target should be used or overridden with a different target.

• Credentials—Specify the runtime user whose credentials should be used for process execution.

• Knowledge Base—Choose the appropriate knowledge base article to associate with the process.

• Result Handlers—Click the appropriate buttons to manage the condition branches on the workflow.

Inserting Data from a Database

Step 1 In the Process Editor Toolbox, choose the [Database Activity] property page, then click the Insert 
[Database] tab.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the SQL tab to specify the SQL command and target query information.

Activity Comments

SQL command text Enter the command text for the selected database.

For example, this query updates columns in a table:

Update mytable set column1 = 'newvalue' where column2 = 'zzz'

Use database target query 
timeout

Select this radio button to use the timeout value indicated in the database 
target as the length of time to wait before a command is complete.

Override database target 
query timeout

Select this radio button and in the text field enter the appropriate value to 
use to override the timeout value indicated in the database target.

Note Click the time unit link to change the timed out interval (e.g., 
seconds, minutes, hours, days)
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Step 4 Complete the appropriate information in the following tabs, as necessary, and then click the Save tool to 
complete the activity definition.

• Target—Specify whether the process target should be used or overridden with a different target.

• Credentials—Specify the runtime user whose credentials should be used for process execution.

• Knowledge Base—Choose the appropriate knowledge base article to associate with the process.

• Result Handlers—Click the appropriate buttons to manage the condition branches on the workflow.

Deleting Data from a Database

Step 1 In the Process Editor Toolbox, choose the [Database Activity] property page, then click the Delete 
From [Database] tab.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the SQL tab to specify the SQL command and target query information

Activity Comments

SQL command text Enter the command text for the selected database.

For example, this query inserts values into a table:

into mytable (column1,column2) VALUES ('val1','val2')

Use database target query 
timeout

Select this radio button to use the timeout value indicated in the database 
target as the length of time to wait before a command is complete.

Override database target 
query timeout

Select this radio button and in the text field enter the appropriate value to 
use to override the timeout value indicated in the database target.

Note Click the time unit link to change the timed out interval (e.g., 
seconds, minutes, hours, days)

Activity Comments

SQL command text Enter the command text for the selected database.

Examples:

Sample query to delete a column

Simple DELETE statement

DELETE from mytable where mycolumn = 'zzz'

Use database target query 
timeout

Select this radio button to use the timeout value indicated in the database 
target as the length of time to wait before a command is complete.

Override database target 
query timeout

Select this radio button and in the text field enter the appropriate value to 
use to override the timeout value indicated in the database target.

Note Click the time unit link to change the timed out interval (e.g., 
seconds, minutes, hours, days)
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Step 4 Complete the appropriate information in the following tabs, as necessary, and then click the Save tool to 
complete the activity definition.

• Target—Specify whether the process target should be used or overridden with a different target.

• Credentials—Specify the runtime user whose credentials should be used for process execution.

• Knowledge Base—Choose the appropriate knowledge base article to associate with the process.

• Result Handlers—Click the appropriate buttons to manage the condition branches on the workflow.

Configuring Database Adapters
The database adapters provide the activities to access database objects and execute SQL queries in 
Process Orchestrator.

Step 1 Choose Administration > Adapters, right-click [Database Adapter] and choose Properties.

Step 2 On the properties dialog box, click the SQL tab.

Step 3 Enter:

• The maximum number of rows to return in a Select SQL query (default=10000). 

• The termination character string with default values. Termination characters can be configured; 
common termination characters are forward slash [ / ] and the semi-colon [ ; ].

Adding a Column to an SQL Command Line
Use the Column Definitions dialog box to map the properties for a source column or modify the name 
of an existing column.

Step 1 On the SQL tab, under Column List, click Add.

Step 2 In the Column Definition dialog box, enter the column properties.

Adding a Column to Table Source
Use the Column map dialog box to add a column to the queried table source or modify the name of an 
existing column.

Step 1 On the SQL tab, under Column Map List, click Add.

Step 2 In the Column Map dialog box, enter the column properties. 
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Email Adapter
The Email adapter provides the ability to execute email objects and send email messages to a specified 
user. 

Users can define an email target to run a process or activity against an Internet Message Access Protocol 
(IMAP) email server or a Post Office Protocol (POP3) email server:

• The IMAP email server allows an email client, such as Microsoft Outlook, to retrieve email on a 
remote mail server. The POP3 email server allows an email client to retrieve e-mail from a remote 
server over a TCP/IP connection.

• An Email (IMAP) target must be connected to an Exchange 2007 Server with Service Pack 3. An 
authentication failure will occur when attempting to create an Email (IMAP) target against an 
Exchange 2007 Server that does not have service pack 3.

The following table provides a listing of the targets that are associated with the adapter. For more 
information about using these activities, see Getting Started Using the Email Adapter, page 12-98.

Related Topics

Getting Started Using the Email Adapter, page 12-98

Getting Started Using the Email Adapter
Use the following process to monitor and manage email instances. 

Step 1 Create an email target (see Defining an Email Account Target, page 12-99).

Step 2 Define the fault criteria you want to monitor (see Defining Email Triggers, page 12-101).

Step 3 Define an email command activity (see Defining the Email Activity, page 12-103). 

Step 4 View the activity results (see Monitoring Operations, page 8-1).

Configuring Default Email Settings 

The Email adapter allows the user to configure default email settings to be used in processes and 
activities. Use the Mail tab to specify the default email server, port, and sender to be used in email 
activities. The values in the fields on this page can be overridden by each activity configuration.

Step 1 Choose Administration > Adapters, highlight Email Adapter, right-click and choose Properties.

Step 2 Click the Mail tab to specify the following information:

Field Description

Email Account (IMAP) Specify the connection information to the IMAP email server

See Defining the Email Account IMAP Target, page 12-99

Email Account (POP3) Specify the connection information to the POP3 email server

See Defining the Email Account POP3 Target, page 12-100
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Step 3 Click OK to close the dialog box.

Defining an Email Account Target
You can define the following types of email account targets:

• Defining the Email Account IMAP Target, page 12-99

• Defining the Email Account POP3 Target, page 12-100

Defining the Email Account IMAP Target

Use the following steps to define an Email Account (IMAP) target. This target will allow a process or 
activity to execute against the an email account on an IMAP mail server.

An Email (IMAP) target must be connected to an Exchange 2007 Server with Service Pack 3. An 
authentication failure will occur when attempting to create an Email (IMAP) target against an Exchange 
2007 Server that does not have service pack 3.

Step 1 Choose Definitions > Targets, right-click and choose New > Email Account (IMAP).

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Connection tab to specify the following information:

Field Description

Default SMTP server Name of the email server to be used as the default server for sending email

Default SMTP port Port number for the default SMTP port (typically 25)

Default sender Email address of the person designated as the default sender in email 
activities

Field Description

Email server Name of the email server that relays email to the mailbox

Protocol Display-only field of the type of email protocol being used by the email 
server (IMAP, POP3)

Email user Select the default runtime user account used to connect to the target. Select 
the default runtime user from the drop-down list.

Port Override Check the check box and enter the port number in the adjacent field to 
override the default port used by the protocol if the port is being used by 
another application.

Enable TLS 
authentication

Email Account (IMAP) and Email Account (POP3) targets support TLS 
protocol and do not support SSL connection. TLS protocol is more secure 
than SSL. The Microsoft Exchange Server setup is plain and SSL connection 
running on port 143 while TLS connection running on port 993. If you  have 
an email server on a Linux platform and configure the email server running 
plain on port 143 while both SSL and TLS connections running on port 99r. 
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Step 4 Click the Advanced tab to specify the reconnection settings to the appropriate email server (IMAP, 
POP3) after a connection failure.

Step 5 Complete the appropriate information in the remaining tabs as necessary, then click OK.

Defining the Email Account POP3 Target

Use the following steps to define an Email Account (POP3) target. This target will allow a process or 
activity to execute against the an email account on an POP3 mail server.

Step 1 Choose Definitions > Targets, right-click and choose New > Email Account (POP3).

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Connection tab to specify the following information:

Enable SSL If checked, the connection to the Email server will run on the SSL port. 

Note You might also need to override the default IMAP port (143) to the 
SSL port.

Enable server push 
notifications

If checked, the email server will push the emails to the recipient’s email 
address.

Polling Interval If there is an Email trigger running against this target, the Email adapter will 
check the email account on the email server using this polling interval. Since 
polling may take some time, the polling interval is defined as the time period 
between the start point of next polling and the end point of the previous 
polling. The default value is 10 seconds. To prevent busy polling, the 
minimum polling interval is set to 5 seconds. 

Field Description

Reconnect to email server on 
connection failure

Check this check box to enable the reconnection settings for the target.

Reconnect every 
____seconds

Select this option and in the text field, enter the number of seconds the 
target should take to reconnect to the server.

Reconnect up to In the text field, enter the maximum number of times the target should 
attempt to reconnect to the server.

Attempt to reconnect at the 
following intervals (in 
seconds)

Select this option and in the text field, enter the number of seconds the 
target should wait before attempting to reconnect to the server.

Field Description

Field Description

Email server Name of the email server that relays email to the mailbox

Protocol Display-only field of the type of email protocol being used by the email 
server (IMAP, POP3)
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Step 4 Click the Advanced tab to specify the reconnection settings to the appropriate email server (IMAP, 
POP3) after a connection failure.

Step 5 Complete the appropriate information in the remaining tabs, as necessary, and then click OK.

Defining Email Triggers

Defining an Email Event (Simple) Trigger

Use the Email Event (Simple) trigger to specify the basic criteria for the mail server to be monitored and 
the email conditions that will trigger the process.

Step 1 On the Triggers tab, click New > Email Event (Simple).

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Email Event (Simple) tab and enter the appropriate information.

Email user Select the default runtime user account used to connect to the target. Select 
the default runtime user from the drop-down list.

To view the properties for the selected runtime user, click the Properties 
tool.

To create a new runtime user, click New > Runtime User to create a new 
Runtime User account.

Port Override Check the check box and enter the port number in the adjacent field to 
override the default port used by the protocol if the port is being used by 
another application.

Field Description

Reconnect to email server on 
connection failure

Check this check box to enable the reconnection settings for the target.

Reconnect every 
____seconds

Select this option and in the text field, enter the number of seconds the 
target should take to reconnect to the server.

Reconnect up to In the text field, enter the maximum number of times the target should 
attempt to reconnect to the server.

Attempt to reconnect at the 
following intervals (in 
seconds)

Select this option and in the text field, enter the number of seconds the 
target should wait before attempting to reconnect to the server.

Field Description
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Step 4 Modify the items to indicate what action is to be taken with the email message.

Step 5 Enter the information in the remaining tabs as necessary, then click OK to complete the trigger 
definition.

Adding Email Criteria for a Trigger

When defining a trigger on an email event, you can specify the criteria on which the email event should 
be triggered when specific criteria is matched.

The Email Criteria dialog box is launched from the Add button on the Email Criteria tab on the Email 
Event trigger. Use the Email Criteria dialog box to specify the matching criteria for the email event.

Step 1 Click the Email Criteria tab, then click Add.

Step 2 Click the Email Criteria dialog box and specify the following information:

Field Description

Action Select the option to specify the action to be taken after the criteria has been met 
on the Exchange server.

• Mark message read—The message will be marked as read. This option is 
not available for POP3 email systems.

• Move message to folder—The message will be moved to a designated 
folder. Do not move email to a folder to be deleted, such as specifying the 
Deleted Items folder in Microsoft Outlook. Use the Delete message option 
to delete email.

• Delete message—The email will be deleted. This is the only option 
available for a POP3 type of email connection.

Target folder This field is enabled after the Move message to folder option is selected.

Enter the name of the folder where the message is to be moved. If the folder is 
a subfolder, then enter the file path for the folder location (for example, 
project/issues/connections).

Return message 
body as output

Select this option to indicate that the body of the email message should be 
included in the output.

Field Description

Scan for text Specifies the text that should be matched in the email

In Indicates what section in the email should be searched:

• Sender—The name of the sender of the email will be scanned for the 
specified text.

• Subject—The subject line of the email will be scanned for the specified 
text.

• Message—The message body of the email will be scanned for the 
specified text.

Case sensitive Indicates whether the text match should be case-sensitive (Yes, No)
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Step 3 Click OK to add the criteria to the Email Criteria tab.

Defining the Email Activity
Use the Email activity to specify the information required for sending an email as part of the process.

Step 1 In the Process Editor Toolbox, choose Email Activities, select the Email activity, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Email tab to specify the properties used to generate the email. 

Step 4 Click the Attachments tab to specify the file paths for the attachments to be sent as part of the email.

Step 5 On the Target tab, click the browse button to display the Select Target dialog box. 

Step 6 Click New > Email Account (POP3) or (IMAP) to display the Email Account Wizard.

Step 7 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Field Description

To Enter the email address of the primary recipient(s) of the email. Use commas 
to separate multiple email addresses.

Cc Enter the email address of the recipient(s) who are to be carbon-copied on 
the email. Use commas to separate multiple email addresses.

Bcc Enter the email address of the recipient(s) who are to blind carbon-copied on 
the email. Use commas to separate multiple email addresses.

Subject Enter the subject heading of the email.

Message Enter the content of the message in the body of the email.

HTML code can be used for formatting if the email is saved in HTML 
format.

Save as HTML Check this check box to send the email contents as an HTML file.

For example, if the content is <B> Cisco Process Orchestrator </B>, then the 
contents in the email will be shown in bold text.

Field Description

User with access to 
attachments

From the drop-down list, select the runtime user account to attach files to the 
email.

Attachment Paths Displays the list of file paths for attachments
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Microsoft Active Directory Adapter
Cisco Process Orchestrator is designed to enhance the management and administration of several objects 
in the Microsoft Active Directory. The Microsoft Active Directory Adapter provides the ability to 
automate common administrative tasks, such as adding users and groups, managing printers, and setting 
permissions for network resources.

The following Microsoft Active Directory activities are available in the product. For more information 
about using these activities, see Getting Started Using the Microsoft Active Directory Adapter, 
page 12-104.

Getting Started Using the Microsoft Active Directory Adapter
Use the following process to monitor and manage Microsoft Active Directory adapter instances. 

Step 1 Create an Active Directory Domain target (see Creating an Active Directory Domain Target, 
page 12-104).

Step 2 Define an Active Directory Domain activity (see Automating Active Directory Domain Activities, 
page 12-105).

Step 3 View the activity results (see Monitoring Operations, page 8-1).

Creating an Active Directory Domain Target

Step 1 Choose Definitions > Targets, right-click and choose New > Active Directory Domain.

Step 2 Click the General tab and enter the appropriate information.

Activity Name Description

Create User Account Create a new active directory user account.

See Defining a Create User Account Activity, page 12-105

NetDiag Launch tests using the Network Connectivity Tester tool.

See Defining the NetDiag Activity, page 12-105

Resolve Email Address Resolve an email address conflict for a user or group.

See Defining the Resolve Email Address Activity, page 12-107

Resolve Identity Find the user or group based on the identity or distinguished name 
of the Active Directory object.

See Defining the Resolve Identity Activity, page 12-107

Set User Password Identify and set the password for a user.

See Defining the Set User Password Activity, page 12-107
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Step 3 Click the Domain tab and enter the domain name and runtime user account that contains the credentials 
to connect to the target, then click OK.

Automating Active Directory Domain Activities

Defining a Create User Account Activity

Before You Begin

To launch this activity, the runtime user must have local administrative rights to the target.

Step 1 On the Toolbox pane, select the Microsoft Active Directory > Create User Account and drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the User tab and enter the required information, including:

• Canonical Path—Full or partial canonical path of the Organizational Unit object excluding the 
domain name. For example:

mydomain.local/LocationOU/DeptOU or LocationOU/DeptOU

• Object class—The type of location where new user information will reside

– Container—Group of objects held within a domain

– Organizational Unit—Group of containers of objects held within a domain

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the NetDiag Activity

Use the NetDiag activity to launch tests using the Network Connectivity Tester tool (Netdiag.exe) to help 
isolate networking and connectivity problems to determine the state of your network client.

The Network Connectivity Tester tool (Netdiag.exe) is installed as part of the deployment and resource 
kits and may not be installed on all targets. If you execute the activity against a target (Windows or 
Exchange) that does not have the tool installed, then the following message will be displayed:

Netdiag.exe is not recognized as an internal or external command, operable program or batch file.

Step 1 In the Process Editor Toolbox, choose Microsoft Active Directory > NetDiag, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Targets tab to specify whether the process target should be used for activity execution or 
overridden with a different target.

Step 4 Click the Inputs tab to continue and specify the following information:

• NetDiag Switches—Network Connectivity diagnostic switch options. The default switches is /v.
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Step 5 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

NetDiag Switches

Use the following switches to generate the Network Connectivity Tester automation summary.

• Usage: z:\Tools\Bin\NETdiag.exe [/Options]>

Switch Description

/q Quiet output (errors only)

/v Verbose output

/l Log output to NetDiag.log

/debug Even more verbose

/d:<DomainName> Find a DC in the specified domain

/fix Fix trivial problems

/DcAccountEnum Enumerate DC machine accounts

/skip:<TestName> Skip the named test. Click this link to display valid tests for this switch.

/test:<test name> Tests only this test. Non-skippable tests will still be run. Click this link 
to display valid tests for this switch.

Autonet Autonet address Test

Bindings Bindings Test

Browser Redir and Browser Test

DcList DC list Test

DefGw Default gateway Test

DNS DNS Test

DsGetDc DC discovery Test

IpConfig IP config Test

IpLoopBk IP loopback ping Test

Kerberos Kerberos Test

Ldap LDAP Test

Member Domain membership Test

Modem Modem diagnostics Test

NbtNm NetBT name Test

Ndis Netcard queries Test

NetBTTransports NetBT transports Test

Netstat Netstat information Test

Netware Netware Test

IPSec IP Security Test

IPX IPX Test
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Defining the Resolve Email Address Activity

Use the Resolve Email Address activity to resolve an email address conflict for a user or group.

Step 1 In the Process Editor Toolbox, choose Microsoft Active Directory > Resolve Email Address, then drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the User or Group to Resolve tab to continue and specify the following information:

• Identity—The user name or group to search for the email address

• Distinguished Name—The Active Directory distinguished name for a user object

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Resolve Identity Activity

Use the Resolve Identity activity to define the properties that find the user or group based on the identity 
or distinguished name of the Active Directory object.

Step 1 In the Process Editor Toolbox, choose Microsoft Active Directory > Resolve Identity and drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the User Identity tab to continue and specify the following information:

• User Name—Specifies the user or distinguished name of the user or group

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Set User Password Activity

Step 1 In the Process Editor Toolbox, choose Microsoft Active Directory > Set User Password and drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the User tab and enter the user LDAP path and password.

Route Routing table Test

Trust Trust relationship Test

WAN WAN configuration Test

WINS WINS service Test

Winsock Winsock Test

Switch Description
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

AD Instance Properties

Create User Account Instance Properties

The Create User Account page displays the properties used to create a new active directory user.

Note If the activity fails, verify that the runtime has local administrative rights to the Process Orchestrator 
server. If the runtime user does not have these rights, the activity will fail and display a message that the 
process has encountered a failed node.

• User name—User name assigned to the user

• Last Name—Last name of the user

• First Name—First name of the user

• Distinguished Name—Active Directory distinguished name for a user

Resolve Email Address Instance Properties

The Resolve Email Address display-only page displays the properties used to find for a user or group.

• Identity—User name or group to search for the email address

• Distinguished Name—Active Directory distinguished name for a user object

Resolve Email Address Results

The Email Address display-only page displays the generated results of the email addresses associated 
with the user or group.

• Email Address—Email address of the user or group

• Proxy Address—Proxy address associated with the email address on the exchange server

User Properties

The User page displays the properties used to identify and set the password for user.

Note If the activity fails, verify that the runtime has local administrative rights to the Process Orchestrator 
server. If the runtime user does not have these rights, the activity will fail and display a message that the 
process has encountered a failed node.

• User LDAP Path—Complete LDAP Path for the user

• Password—New user password
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User Identity Properties

The User Identity tab displays the defined properties that find the email addresses for the user or group 
based on the identity or distinguished name of the Active Directory object.

User or Group to Decide Instance Properties

The User or Group to Decide tab displays the properties defined that find the email addresses for the user 
or group based on the identity or distinguished name of the Active Directory object.

• Identity—The value of the user identity

• Distinguished Name—The distinguished name of the user or group
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Microsoft System Center Operations Manager (SCOM) Adapter
The Microsoft System Center Operations Manager (SCOM) 2007 is designed to monitor the entire data 
center environment. The Microsoft System Center Operations Manager 2007 adapter provides the ability 
to detect a wide variety of problems and to automatically take corrective actions or alert administrators 
when necessary. The data that is collected, stored, and analyzed automatically can help administrators 
determine which servers have additional capacity and which servers might soon suffer a stress-induced 
heart attack.

The following SCOM activities are available in the product. For more information about using these 
activities, see Getting Started Using the SCOM Adapter, page 12-110.

Getting Started Using the SCOM Adapter
Use the following process to monitor and manage SCOM adapter instances. 

Step 1 Create an SCOM target (see Defining a SCOM Management Server Target, page 12-110).

Step 2 Define an SCOM command activity (see Automating SCOM Activities, page 12-111). 

Step 3 View the activity results (see Monitoring Operations, page 8-1).

Defining a SCOM Management Server Target
Use the SCOM Management Server target to specify information about the SCOM management server. 
When an SCOM management server is configured as a target, you can run activities against the target 
and subscribe to SCOM alerts.

Before You Begin

The Microsoft System Center Operations Manager must be installed in your environment and you must 
have the credentials to connect to the SCOM management server to use this activity in a process.

Step 1 Choose Definitions > Targets, right-click and choose New > SCOM Management Server.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Connection tab to specify the following information:

Activity Description

Collect SCOM 
Performance Counter

Use the Collect SCOM Performance Counter activity to specify information 
about your SCOM environment to obtain performance data.

To define the property page for this activity, see Defining the Collect SCOM 
Performance Counter Activity, page 12-111.

Update SCOM Alert Use the Update SCOM Alert activity to specify the alert ID in SCOM that 
is to be used to update/resolve and any comments to add to the alert history.

To define the property page for this activity, see Defining the Update SCOM 
Alert Activity, page 12-112
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• Management server name—The name of the SCOM management server. This is the name that is 
configured in SCOM.

• Default runtime user—The default runtime user account that contains the credentials to connect to 
the target. Select the default runtime user from the drop-down list.

Step 4 Click OK to close the dialog box and complete the procedure.

Automating SCOM Activities

Defining the Collect SCOM Performance Counter Activity

SCOM creates a performance database that can track resource usage statistics for all of the systems in 
the environment. Use the Collect SCOM Performance Counter activity to specify information about your 
SCOM environment to obtain performance data.

Before You Begin

The Microsoft System Center Operations Manager must be installed in your environment and have the 
credentials to connect to the SCOM management server to use this activity in a process.

Step 1 In the Process Editor Toolbox, choose Microsoft SCOM > Collect SCOM Performance Counter and 
drag and drop the activity onto the Workflow pane

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Counter tab to specify the appropriate information about your SCOM environment to obtain 
performance data, including:

• Object name—Name of the object that contains the performance counter

• Counter name—Name of the performance counter

• Instance name—Name of the instance from which to collect the performance data

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Viewing Results

Click the Values display-only tab to view the SCOM environment information that made up the 
performance data.

• Object name—Name of the object that contains the performance counter

• Counter name—Name of the performance counter

• Instance name—Name of the instance from which to collect the performance data
12-111
Cisco Process Orchestrator 3.3 User Guide

 



 

Appendix 12      Using Adapters
  Microsoft System Center Operations Manager (SCOM) Adapter
Defining the Update SCOM Alert Activity

Use the Update SCOM Alert activity to specify the alert ID in SCOM that is to be used to update/resolve 
and any comments to add to the alert history.

Before You Begin

The Microsoft System Center Operations Manager must be installed in your environment and you must 
have the credentials to connect to the SCOM management server to use this activity in a process.

Step 1 In the Process Editor Toolbox, choose Microsoft SCOM > Update SCOM Alert, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the SCOM alert tab and specify the alert ID information, including:

• Alert ID—The ID in SCOM that is assigned to the alert that you want to resolve or update.

• Alert comment—Enter the comments about the alert that should be displayed on the alert history 
property page in SCOM.

• Resolve the SCOM alert—Set the alert status in SCOM to Resolved.

Step 4 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tab to view the specified alert ID information.

• Alert ID—ID in SCOM that is assigned to the alert 

• Alert comment—comments about the alert that should be displayed on the alert history property 
page in SCOM

• Resolve the SCOM alert—the alert status in SCOM is set to Resolved.

Searching for SCOM Performance Monitoring Options

If you do not have the appropriate information to define the activity on the Collect SCOM Performance 
Counter activity, click Browse. This option launches the Select SCOM Performance Counter dialog box, 
which allows you to search for the appropriate information to populate the fields on the activity property 
page.

To search for the monitoring information, enter the credentials for connecting to the SCOM management 
server to display the performance counter options.

Step 1 On the Collect SCOM Performance Counter property page, click Browse.

Step 2 Under SCOM Connection, specify the appropriate information to connect to the SCOM Management 
Server.

Step 3 Click Connect to connect to the server.

The drop-down lists populate with options. These drop-down lists remain empty until connected to the 
SCOM management server.

Step 4 Select the appropriate options in the drop-down lists, including:
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• Monitor class name—Name of the monitor class in SCOM to which the monitor object belongs.

• Monitor object full name—The full name of the monitor object in SCOM. This is typically the 
computer name of the machine being monitored.

• Object name—The name of the object in SCOM from which you want to obtain performance data.

• Counter name—The name of the performance counter in SCOM.

• Instance name—The name of the instance in SCOM from which to obtain data.

Click Browse to launch the Select SCOM Performance Counter dialog box and connect to the 
SCOM management server. For additional information about connecting to the SCOM management 
server, see Searching for SCOM Performance Monitoring Options.

• Performance values generated within the last—Time frame (in seconds, minutes, or hours) of 
collected performance data to be gathered by Process Orchestrator. Enter a numeric value in the text 
box or select the value using the scroll buttons.

• Only return the latest performance counter—Check this check box to collect only the latest 
performance counter.

• Fail if no values are found—Check this check box to fail the activity if no values match.

Step 5 Click OK. The fields on the Collect SCOM Performance Counter property page populates with the 
selected information.

Searching for an Alert Source

Use the following steps to search for the appropriate alert source details for the SCOM alert.

Step 1 On the SCOM Alert Properties dialog, click Browse to launch the Select Monitor Class and Object 
dialog box to enter the credentials for connecting to the SCOM management server.

Step 2 Choose SCOM Connection and specify the appropriate information to connect to the SCOM 
Management Server.

Step 3 Click Connect to connect to the server.

The Alert source class and Alert source name drop-down lists populate with options after the connection 
to the SCOM Management server is d.

Step 4 Select the appropriate Alert source options, including:

• Alert source class—The name of the monitor class in SCOM to which the monitor object belongs.

• Alert source name—The fully-qualified name of the monitor object.

• Browse—To search for the appropriate alert source, click this button to launch the Select Monitor 
Class and Object dialog box to connect to the SCOM management server and select the monitor 
class name and monitor class object. 

• Alert severity level—The severity level of the alert in SCOM that must be matched before the 
process executes. Check one or more of the following check boxes to indicate the severity level of 
alerts that are to be matched:

– Information

– Critical

– Warning
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• Alert name—The name of the alert in SCOM that must be matched before the process executes.

• Description—A description of the alert in SCOM that must be matched before the process executes.

Step 5 Click OK. The fields on the SCOM Alert property page populate with the selected information.
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SNMP Adapter
Cisco Process Orchestrator is designed to enhance the management and administration of Simple 
Network Management Protocol (SNMP), which is used in network management systems to monitor 
network devices for conditions that require administrative attention. The SNMP adapter allows a level 
of support for different platforms and applications to send and receive data through SNMP. 

The SNMP activities gather and publish data that pass through the SNMP agents. The agents return 
information contained in a MIB (Management Information Base), which is a data structure that defines 
what is obtainable from the device and what can be controlled (for example, turned off or on).

There are two different types of SNMP targets:

• When Process Orchestrator is acting as a manager, it uses an SNMP Device (Agent) target to 
communicate with network devices and all of the other endpoints out in the environment, sending 
and receiving data from those devices.

• When Process Orchestrator is acting as an SNMP endpoint, it uses an SNMP Server (Manager) 
target to send traps to an event manager, typically to publish Process Orchestrator tasks (such as 
alerts or incidents) to report automation health concerns.  

Each activity and trigger only works against a certain type of target.  For example, the SNMP trap 
received trigger requires an  SNMP Device (Agent)  target.

The following table displays activities that are provided by the SNMP adapter. For more information 
about using these activities, see Getting Started Using the SNMP Adapter, page 12-116.

Related Topics

Getting Started Using the SNMP Adapter, page 12-116

Activity Comments

Correlate SNMP Trap 
Received

Detect incoming traps that match the specified criteria. 

See Defining the Correlate SNMP Trap Received Activity, page 12-120

Generate SNMP Trap Publish a generic trap to the specified SNMP Manager target or target 
group.

See Defining the Generate SNMP Trap Activity, page 12-121

Generate SNMP Trap 
from Task 

Publish Cisco Process Orchestrator process alerts and incident traps to the 
specified SNMP Manager target or target group.

See Defining the Generate SNMP Trap from Task Activity, page 12-121

SNMP Get Request Request a set of variable values from the SNMP agents. SNMP agents are 
hardware and/or software processes reporting activity in a network device. 
Data passes through SNMP agents and the requested information is 
returned in a MIB.

See Defining the SNMP Get Request Activity, page 12-121

SNMP Set Request Modify the variables used to request the information that is returned in a 
MIB from the SNMP agent.

See Defining the SNMP Set Request Activity, page 12-122
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Getting Started Using the SNMP Adapter
Use the following process to monitor and manage SNMP adapter instances. 

Step 1 Create the SNMP targets (see Defining an SNMP Device (Agent) Target, page 12-117and Defining an 
SNMP Device (Manager) Target, page 12-118).

Step 2 Specify the credentials for an SNMP runtime user (see Defining a SNMP Credentials Account, 
page 12-118).

Step 3 Define an SNMP message event trigger (see Defining a SNMP Trap Received Trigger, page 12-119).

Step 4 Define an SNMP command activity (see Automating SNMP Device (Agent) Command Activities, 
page 12-120). 

Step 5 View the activity results (see Monitoring Operations, page 8-1).

Configuring the SNMP Adapter
Use the Settings tab to configure the security settings required for an SNMP agent and the port to use 
when receiving a trap.

Step 1 Confirm that the prerequisites have been installed. To view the adapter prerequisites:

a. Choose Administration > Adapters, highlight the SNMP Adapter, right-click and choose 
Properties.

b. On the SNMP Adapter Properties dialog box, click the Prerequisites tab to view the prerequisites 
that are required by the adapter, then click OK. 

For the latest prerequisites, see the Cisco Process Orchestrator Compatibility Matrix.

Step 2 Configure the security settings required for an SNMP agent and the port to use when receiving a trap:

a. Choose Administration > Adapters, highlight the SNMP Adapter, right-click and choose 
Properties.

b. On the SNMP Adapter Properties dialog box and click the Settings tab.

c. Enter the following information:

– Local Engine ID—ID number of the SNMP engine

The SNMP engine ID number can be automatically discovered by the SNMP adapter or 
specified by the SNMP Agent Device target.

– Trap listening port—Port number that the event or the activity used to listen for incoming traps 
(default port number=162).
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Configuring Listening Port Settings
Use the Settings tab to configure the security settings required for a SNMP Agent and the port to use 
when receiving a trap.

Step 1 Choose Administration > Adapters, highlight the SNMP Adapter, right-click and choose Properties.

Step 2 Click the Settings tab to specify the following listening port for the incoming traps:

• Local Engine ID—ID number of the SNMP engine

The SNMP engine ID number can be automatically discovered by the SNMP adapter or specified by 
the SNMP Agent Device target.

• Trap listening port—Port number that the event or the activity used to listen for incoming traps. The 
default port number is 162.

Step 3 Click OK to close the dialog box.

Defining an SNMP Device (Agent) Target
Use the SNMP (Device) Agent target to configure the host and operation and notification settings for 
accessing an SNMP agent.

Step 1 Choose Definitions > Targets, right-click, and choose New > SNMP Device (Agent).

Step 2 On the General tab, enter the appropriate information and click Next.

Step 3 On the SNMP Device (Agent) panel, enter the appropriate target information to configure the host and 
operation and notification settings, and click Next.

• Host (Name or IP address)—Enter the host name or IP address of the SNMP agent

• Port number—Enter the listening SNMP port to be used by Cisco Process Orchestrator to execute 
SNMP GET/SNMP SET activities against the device. This is the port number that the activities use 
for Get/Set Requests. The default port number is 161.

• Enable reading only from device (SNMP Get Request)—Select this radio button and then select the 
appropriate SNMP credentials with Read rights from the drop-down list.

To view the properties of the SNMP credentials, click the Properties  tool.

If the drop-down list does not contain the appropriate credentials, click New > SNMP Credentials 
to create new credentials.

• Let me choose SNMP operations to enable—Select this radio button to define the specific 
credentials for the SNMP agent.

Step 4 On the SNMP Credentials panel, specify different credentials to be used for Get or Set operations or 
receiving SNMP traps, and click Next.

• Enable reading only from device (SNMP Get Request)—Check this check box and then select the 
appropriate SNMP credentials with Read rights from the drop-down list

If the drop-down list does not contain the appropriate credentials, click New > SNMP Credentials 
to create new credentials.

• Enable writing to device (SNMP Set Request)—Write rights from the drop-down list
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When verifying the write credentials, the SNMP adapter will only perform the Get Request for 
confirmation.

If the drop-down list does not contain the appropriate credentials, click New > SNMP Credentials 
to create new credentials.

• Enable traps from the device—Check this check box and then select the appropriate SNMP 
credentials to enable traps from the device from the drop-down list.

If the drop-down list does not contain the appropriate credentials, click New > SNMP Credentials 
to create new credentials.

Note Cisco Process Orchestrator does not verify SNMP trap credentials.

Step 5 Verify the information on the panel and click Finish to close the wizard.

Defining an SNMP Device (Manager) Target
Use the SNMP (Server) Manager target to configure the host and security settings for sending traps to a 
SNMP server.

Step 1 Choose Definitions > Targets, right-click, and choose New > SNMP Device (Manager).

Step 2 On the General panel, enter the appropriate information and click Next.

Step 3 On the SNMP Device (Manager) panel, specify the connection information to the appropriate server, 
then click Next.

• Host (Name or IP address)—Enter the host name or IP address of the SNMP server

• Port number—Enter the listening SNMP port to be used by Cisco Process Orchestrator to send traps 
to the SNMP server. The default port number is 162.

• Credentials used to generate traps to send to the SNMP server—Select the appropriate SNMP 
credentials with the appropriate rights to enable traps from the device from the drop-down list.

If the drop-down list does not contain the appropriate credentials, click New > SNMP Credentials 
to create new credentials.

Step 4 Verify the information on the panel and click Finish to close the wizard.

Defining a SNMP Credentials Account
Use the SNMP Credentials dialog box to specify the credentials for a SNMP runtime user. The 
information is used to assign run options for SNMP processes or activities.

Step 1 Choose Definitions > Runtime Users, right-click and choose New > SNMP Credentials.

Step 2 On the General panel, enter the appropriate information and click Next.

Step 3 Click the Credentials tab to specify the following information:

• Version—Select the appropriate SNMP version (SNMPv1, SNMPv2c, or SNMPv3).
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• Community String—This field is displayed when the SNMPv1 or SNMPv2c versions is selected.

Specify the community string to be used for publishing traps. The default community string is 
public.

• User name—Enter the user name assigned to the SNMP Credentials account.

• Security level—The security level assigned to the user:

– noAuthNoPriv—Communication without authentication and privacy

– authNoPriv—Communication with authentication and without privacy. The protocols used for 
Authentication are MD5 (Message Digest 5 Algorithm) and SHA (Secure Hash Algorithm).

– authPriv—Communication with authentication and privacy.  

• Authentical protocol—The protocol used for authentication. This field is enabled when the security 
level is set to authNoPriv or authPriv.

– SHA

– MD5

• Authentication Key—Password used for authentication

• Privacy Protocol—Format for transmitting encrypting data between the two devices

This option is available when security level is set to authPriv.

– DES—Data Encryption Standard uses a 56-bit key and uses the block cipher method, which 
breaks text into 64-bit blocks and then encrypts the text.

– 3DES—Non-standard convention of the DES encryption algorithm in which three 64-bit keys 
are used, instead of one, for an overall key length of 192 bits. The first encryption is encrypted 
with second key, and the resulting cipher text is again encrypted with a third key.

– AES128—Specifies the Advanced Encryption Standard which uses a symmetric 128-bit block 
data encryption technique

– AES256—Specifies 256-bit AES as the encryption algorithm

Note You must update your policy with JCE to use the AES256 encryption. To update the JCE 
provider, click Oracle JCE provider to download the correct local_policy.jar file and 
US_export_policy.jar file to the local Java security folder. Before downloading, rename the 
original security files in the Java installation folder. After downloading the files, restart Cisco 
Process Orchestrator to apply the changes.

• Privacy Key—Password used for encrypting data

Step 4 Click OK to close the dialog box and complete the procedure.

Defining a SNMP Trap Received Trigger
Use the SNMP Trap Received trigger to specify the criteria for the incoming traps from all SNMP agents 
through the port specified in the SNMP adapter. This criteria must be met before the process executes.

Step 1 Choose Definitions > Triggers > New > SNMP Trap Received.

Step 2 Click the General tab and enter the required information.
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Step 3 Click the Trap Criteria tab and enter the OID for the trap.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Automating SNMP Device (Agent) Command Activities

Defining the Correlate SNMP Trap Received Activity

Use the Correlate SNMP Trap Received activity to detect incoming traps that match the specified 
criteria.

Step 1 In the Process Editor Toolbox, choose SNMP Activities > Correlate SNMP Trap Received, then drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Event Criteria tab to specify the event properties for the activity, including:

• Correlate events that occur within—Enter a value and select the time unit to indicate the length of 
time to wait before or after the process start time.

– Time unit—Enter the start time value in minutes or seconds

– Event occurrence—Determine whether the process start time is before or after the event occurs

• Number of events to correlate—Select one of the following options to specify which events to wait 
for before the process continues:

– All events in the above time frame—Select this option to wait for all events that match the 
specified criteria before the process continues.

– Number of events—Select this option to wait for the specified number of events to occur before 
the process continues. Enter the number of events to wait for in the text field.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Viewing Results

Click the instance tab to view the event properties for the completed activity.

• Correlate events that occur within—Enter a value and select the time unit to indicate the length of 
time to wait before or after the process start time.

– Time unit—Enter the start time value in minutes or seconds

– Event occurrence—Determine whether the process start time is before or after the event occurs

• Number of events to correlate—Select one of the following options to specify which events to wait 
for before the process continues:

– All events in the above time frame—Select this option to wait for all events that match the 
specified criteria before the process continues.

– Number of events—Select this option to wait for the specified number of events to occur before 
the process continues. Enter the number of events to wait for in the text field.
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Defining the Generate SNMP Trap Activity 

Use the Generate SNMP Trap activity to publish a generic trap to the specified SNMP Manager target 
or target group.

Step 1 In the Process Editor Toolbox, choose SNMP Activities > Generate SNMP Trap, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Trap tab and enter the object identifier of the trap to publish.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Viewing Results

Click the instance tabs to view the published trap. See also, Defining the Generate SNMP Trap Activity. 

Defining the Generate SNMP Trap from Task Activity

Use the Generate SNMP Trap from Task activity to publish Cisco Process Orchestrator process alerts 
and incident traps to the specified SNMP Manager target or target group.

Step 1 In the Process Editor Toolbox, choose SNMP Activities > Generate SNMP Trap from Task, then drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Trap from Task tab and enter the ID of the alert or incident task to publish. The task GUID 
should contain 32-digits with four dashes placed in the following format:

xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Viewing Results

Click the instance tabs to view the published process alerts and incident traps. See also, Defining the 
Generate SNMP Trap from Task Activity. 

Defining the SNMP Get Request Activity

Use the SNMP Get Request activity to request a set of variable values from the SNMP agents. SNMP 
agents are hardware and/or software processes reporting activity in a network device. Data passes 
through SNMP agents and the requested information is returned in a MIB.

Step 1 In the Process Editor Toolbox, choose SNMP Activities > SNMP Get Request, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.
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Step 3 Click the Variables tab and enter the context name to be used during SNMP V3 operation.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Viewing Results

Click the instance tabs to view the set of variable values. See also, Defining the SNMP Get Request 
Activity. 

Defining the SNMP Set Request Activity

Use the SNMP Set Request activity to update a set of variable values on the SNMP agents. SNMP agents 
are hardware and/or software processes reporting activity in a network device. The SNMP Set Request 
activity modifies the variables used to request the information that is returned in a MIB from the SNMP 
agent.

Step 1 In the Process Editor Toolbox, choose SNMP Activities > SNMP Set Request, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Variables tab and enter the context name to be used during SNMP V3 operation.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Viewing Results

Click the instance tabs to view the set of variable values updated on the SNMP agents. See also, Defining 
the SNMP Set Request Activity. 

Adding a Variable to an SNMP Activity
Trap variables are a required property for the SNMP Request Set and Generate SNMP Trap activities. 
The Add button on these activities launches the Variable dialog box for users to specify the variable 
properties to be added to the list on the specified SNMP activity.

Step 1 On the SNMP activity property page, click Add.

Step 2 On the Variable dialog box, specify the required information, then click OK.

Note If the Add button is launched from the SNMP Get Request activity, the dialog box will only have 
an OID field.

Step 3 Specify the information that describes the variable, including:

• OID—Object identifier of the trap to publish (default =1.3.6).
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• Type—The list of variable bindings for the specified trap. The third-party SNMP library supports 
these data types:

– Integer—Signed integer-valued information in the range of -231 to 231-1. This data type 
redefines the integer data type, which has arbitrary precision in ASN.1 but bounded precision 
in the SMI

– IP Address—represent addresses from a particular protocol family. SMIv1 supports only 32-bit 
(IPv4) addresses (SMIv2 uses Octet Strings to represent addresses generically, and thus are 
usable in SMIv1 too. SMIv1 had an explicit IPv4 address datatype.)

– OctetString—Ordered sequences of 0 to 65,535 octets

– OID—Comes from the set of all object identifiers allocated according to the rules specified in 
ASN.1

– TimeTicks—Time since an event, measured in hundredths of a second

– UInteger—Unsigned integer-valued information, which is useful when values are always 
non-negative. This data type redefines the integer data type, which has arbitrary precision in 
ASN.1 but bounded precision in the SMI

• Value—Instance value of the variable

Defining an SNMP Credentials Account
Use the SNMP Credentials dialog box to specify the credentials for an SNMP runtime user. The 
information is used to assign run options for SNMP processes or activities.

Step 1 Choose Definitions > Runtime Users, right-click and choose New > SNMP Credentials.

Step 2 Click the General tab and specify the appropriate information.

Step 3 Click the Credentials tab to specify the SNMP information.

Step 4 Click OK to close the dialog box and complete the procedure.

Automating SNMP Device (Manager) Command Activities
Use the following steps to define an SNMP Device (Manager) activity. 

Step 1 In the Process Editor Toolbox, choose SNMP > [SNMP Activity], then drag and drop the activity onto 
the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the [Activity-Specific] tabs to define the properties specific to the activity. 
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Activity Comments

Publish a generic trap Select Generate SNMP Trap to publish a generic trap to the specified 
SNMP Manager target or target group. 

Click the Trap tab and enter the object identifier of the trap to publish

Generate an SNMP trap 
from a task activity

Select Generate SNMP Trap from Task to publish Process Orchestrator 
process alerts and incident traps to the specified SNMP Manager target or 
target group.

Specify the ID of the alert or incident task to publish. The task GUID 
should contain 32-digits with four dashes placed in the following format:

xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
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Terminal Adapter
The Terminal adapter provides the functionality to execute commands, scripts and session-based 
activities against a system or network device using SSH or Telnet. While SSH is more secure than telnet, 
many environments use a telnet connection and using a SSH connection against such devices will not be 
possible. The Terminal adapter allows you the flexibility to execute against those devices.

The Terminal adapter allows Cisco Process Orchestrator to run commands and script activities on a 
system or network device that has Secure Shell (SSH) enabled. The Terminal adapter also contains three 
session-based activities that allow you to open new SSH/Telnet sessions and interact with the previously 
opened sessions.

SSH and Telnet leverage the same command execution activities differentiated by the target type they 
are deployed against.  For example, an IOS target can have SSH or telnet optionally configured.

Cisco Process Orchestrator requires SFTP to be configured on the Unix/Linux system to execute SSH 
activities. SFTP is not needed for the SSH/Telnet Terminal Session activities.

The Terminal Adapter for Cisco Process Orchestrator:

• Provides host-based and public key authentication and improves upon the existing expects 
functionality. The authentication enhancement allows users to apply host-based authentication from 
the adapter level. Users can also apply public key authentication on the device target level.

• Allows you to create expect templates for their login expects. Expect templates allow you to 
leverage existing login expect sequences when applying expects to a device target or activity.

• Is now FIPS-compliant and allows you to enable FIPS-compliant algorithms.

The following table displays activities that are provided by the Terminal adapter. For more information 
about using these activities, see Getting Started Using the Terminal Adapter, page 12-126.

Activity Description

Close Terminal Session Closes a Terminal session opened by a previous Open Terminal Session 
activity

See Defining a Close Terminal Session Activity, page 12-136

Execute Terminal 
Command(s)

Sends commands to a terminal command session started by a previous Open 
Terminal Session activity

See Defining an Execute Unix/Linux SSH Command Activity, page 12-139

Execute Unix/Linux 
SSH Command

Specifies a Unix/Linux SSH command to execute

See Defining an Execute Unix/Linux SSH Command Activity, page 12-139

Execute Unix/Linux 
SSH Script

Specifies a Unix/Linux SSH script to execute

See Defining an Execute Unix/Linux SSH Script Activity, page 12-141

Get File Retrieves files from a Unix/Linux system target to transfer to a specified local 
directory

See Defining a Get File Activity, page 12-137

Open Terminal Session Starts an SSH session on a selected Terminal target

See Defining an Open Terminal Session Activity, page 12-143

Put File Pushes local files to a Unix/Linux system target

See Defining a Put File Activity, page 12-138
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Getting Started Using the Terminal Adapter
Use the following process to monitor and manage Terminal adapter instances. 

Step 1 Create the Terminal targets (see Defining Terminal Adapter Targets, page 12-130).

Step 2 Define a Terminal message runtime users (see Defining Terminal Adapter Targets, page 12-130).

Step 3 Define a Terminal command activity (see Automating Terminal and Secure Shell (SSH) Activities, 
page 12-136). 

Step 4 View the activity results (see Monitoring Operations, page 8-1).

Configuring the Terminal Adapter

Configuring SSH Version 2.0 Support for Cisco IOS Devices

To properly execute Cisco IOS processes and activities against the Terminal adapter, the IOS device 
cannot run using SSH v1.0. The IOS devices should be configured to run SSH v2.0. The Secure Shell 
Version 2 Support feature allows users to configure Secure Shell (SSH) Version 2.

Before configuring SSH, download the k9 (Triple Data Encryption Standard [3DES]) software image 
from Cisco IOS Release 12.3(4)T, 12.2(25)S, or 12.3(7)JA onto your router.

For additional information on configuring IOS devices for SSH v2.0 support, see Secure Shell Version 
2 Support on the Cisco web site.

Configuring an Expect Template

Because creating Terminal targets can be complex, the expect template provides users with limited 
knowledge of expects a simpler method to complete the target configuration properties. Expect templates 
contain default configuration sequence of expects and elevated privilege command expects.

The Expect Template tab on the Terminal Adapter dialog box displays the list of default expect template 
configurations that have been created using the Expect Templates dialog box. From this tab, users can 
create, modify, and delete expect templates.

Expect templates can be imported and exported just like other objects in an automation pack. Imported 
expect templates from an automation pack can only be modified by the author of that automation pack. 
A Process Orchestrator content-author can only export those expect templates created by that content 
author.

Step 1 Choose Administration > Adapters, highlight Terminal Adapter, right-click and choose Properties.

Step 2 Click the Expect Templates tab, then click New > Expect Template.

Step 3 Click the General tab and enter the required information.

Step 4 Click the Expect Template tab to configure the default expect values.

Step 5 Complete the following information for the connection patterns.

• Prompt—Enter the system prompt pattern in regular expression

• Error—Enter the error message pattern in regular expression
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• Admin Prompt—Enter the admin prompt pattern in regular expression

Step 6 To elevate the privilege command for login expects:

• Elevating Privilege command—Check this check box and enter the command or select the reference 
variable containing the command to elevate the privilege for the expect.

• Elevating Privilege expects—Use this section to view and/or define the login expect sequence for 
the elevating privilege command expects.

Step 7 Click OK to close the dialog box.

Enabling the FIPS-Compliance JCE Provider

The Terminal Adapter ships with a FIPS-compliant Java Crypto Extension (JCE) provider to connect to 
FIPS-compliant network devices, such as the ACS 5.2 server. This provider includes encryption 
algorithms that may not be supported by Java that are also useful in high-security scenarios.

Step 1 Choose Administration > Adapters, highlight Terminal Adapter, right-click and choose Properties.

Step 2 Click the Advanced tab, then under FIPS-Compliance, check the Only use FIPS-compliant encryption 
algorithm check box to indicate that only FIPS-compliant encryption algorithms should be used by the 
Terminal adapter.

If this check box is checked, then any SSH targets that uses an unsupported algorithm will not be 
accessible in Process Orchestrator.

Step 3 Click OK to close the dialog box.

 

Configuring Default Host-Based Authentication Keys

Users can define default host public and private keys on the Advanced tab of the Terminal Adapter dialog 
box. This tab allows users to select a specific private key for the target. The private key will be used for 
host-based authentication if a target does not specify its own keys.

The Authentication tab on a Target dialog box indicates whether the target should allow authentication 
based on the host system of the user and the user name on the remote host system.

Step 1 Choose Administration > Adapters, highlight Terminal Adapter, right-click and choose Properties.

Step 2 Click the Advanced tab to configure the authentication keys.

• Private key—To the right of the display-only field, click Browse to launch the Load Private Key 
dialog box to select a private key.

• Public key—To the right of the display-only field, click Browse to launch the Load Public Key 
dialog box to select a public key.

• Public key file content—Enter the SSH public key request message to the remote SSH server that 
will authenticate the request against the stored public key.

Step 3 Click OK to close the dialog box.
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Selecting a Private Key

Use the Load Private Key dialog box to select the private key file to be used to provide authentication of 
a public key. If OpenSSH is installed, the key pair is generated by the command line tool "ssh-keygen."

Copy the file to a location where it is accessible from the Process Orchestrator server, then follow the 
steps to load the private key.

The private key file should reside on the same machine as the Process Orchestrator server.

Step 1 Choose Administration > Adapters, highlight Terminal Adapter, right-click and choose Properties.

Step 2 Click the Advanced tab to select the private key to authenticate the public key.

Step 3 On the Private Key field, click Browse. 

Step 4 In the Load Private Key dialog box, enter the following information:

• Passphrase to the private key file—Check this check box and in the text field, enter the passphrase 
to be used to the private key file.

The passphrase is used to protect the private key file when the private key is generated.

• Select a private key file—The most commonly used private key file format is "RSA PRIVATE KEY." 
The private key file should reside on the same machine as the Process Orchestrator server. The 
default location of the file is under the unix user's home directory:

~/.ssh/id_rsa

The content of the private key file will be displayed after the passphrase is d against the private key 
file content.

Step 5 Click OK to close the dialog box.

The private key displays on the Private key field on the Advanced tab. The content of the private key file 
will be displayed except in the Load Private File dialog box in order for the user to verify the content.

Selecting a Public Key

A public key is a value provided by some designated authority as an encryption key that, combined with 
a private key derived from the public key, can be used to effectively encrypt messages and digital 
signatures.

Use the Load Public Key dialog box to select a public key to be used by the Terminal adapter.

Step 1 Choose Administration > Adapters, highlight Terminal Adapter, right-click and choose Properties.

Step 2 Click the Advanced tab to select the private key to authenticate the public key.

Step 3 On the Public Key field, click Browse.

Step 4 On the Load Private Key dialog box, select the public key file.

Step 5 Click OK to close the dialog box.

The public key displays on the Public key field on the Advanced tab.
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Configuring Total Concurrent Sessions

Users can specify the limits on how many concurrent sessions can be run against a target. When the total 
live sessions reach limits, the activity that needs to open a new session will wait until a live session is 
closed. The waiting Open Terminal Session activities will be displayed in the target’s Open Sessions 
property page.

The Network Device Module inherits the max allowed sessions from its chassis system by default. Users 
cannot adjust the value on the network device module more than value set by the chassis system. 
Therefore users can only modify the amount concurrent sessions against the network device module 
through its chassis system.

Due to the nature of network device management, Process Orchestrator may have a very large number 
of Process Orchestrator Terminal Adapter targets and concurrent running Process Orchestrator 
processes. Users can specify the total sessions allowed against the Terminal Adapter in the configuration 
file to minimize the negative impact on performance and resource usage.

To configure the maximum sessions against a target:

Step 1 Choose Definitions > Targets, highlight the appropriate target, right-click and choose Properties.

Step 2 Click the Connection tab to modify the maximum allowed sessions.

Step 3 In the Maximum allowed concurrent sessions field, enter the maximum allowed open sessions to run 
concurrently. (Default: Terminal target: 3, Unix/Linux target: 1)

Step 4 Click OK to close the dialog box.

Adding an Expect Parameter

Use the Expect dialog box to configure the expect parameters to manage the Terminal target command 
output. The Add button on the device activities and targets launch the Expect dialog box for users to 
configure the expect parameters to be added to the list of expects and matched in the output.

Step 1 On the Execute Terminal property page, click Add.

Step 2 Complete the following fields, as necessary.

• Name—Enter the name of the case defining what to expect

• Regular Expression—Enter characters to match in the terminal output. 

• Match Case—Check the check box to indicate whether the regular expression is case-sensitive

• Operation Type—Displays what operation takes place if an expected regular expression match is 
encountered in the terminal output:

– User Response—Provides input to the terminal and continue execution of the activity

– Runtime User's User name—Allows user to respond with the user name of the runtime user for 
the session

– Runtime User's Password—Allows user to respond with the password of the runtime user for 
the session

– Runtime User's Admin Password—Allows user to respond with the admin password of the 
runtime user. If the runtime user doesn’t have the admin password, the regular password will be 
used.
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– Succeeded—Complete activity and set its status to Completed

– Failed (Completed)—Complete activity and set its status to Failed (Completed)

– Failed (Not Completed)—Complete activity and set its status to Failed (Not Completed)

• User Response—Field is enabled when User Response is selected from the Operation Type 
drop-down list. This field can also remain empty.

When User Response is selected, enter the appropriate string text for the user.

• Hidden—This check box is enabled when User Response or Set Expect Result is selected from the 
Operation Type drop-down list.

Check this check box and enter the string text into the Operation Parameter field, which will be used 
as security-sensitive content for the expect.

Step 3 Click OK.

The expect parameters is added to the list of login expects.

Defining Terminal Adapter Targets

Defining a Network Device Module Target

Some Cisco network devices are chassis systems that can hold other network devices such as ACE, 
FWSM, on boards that plug into the chassis.

Use the Network Device Module to create a network device module target which can be used as a 
dependent of a terminal target as well as an independent network device target that can be used by 
network processes for execution.

Step 1 Choose Definitions > Targets, right-click, and choose New > Network Device Module.

Step 2 On the General Information panel, enter the appropriate information, then click Next.

Step 3 On the Terminal Connection panel, enter the appropriate target information to specify the connection 
information to the appropriate server, then click Next.

• Chassis system—From the drop-down list, select the appropriate terminal target on which the 
network module resides.

• Switch number—Check the check box and in the text field, enter the appropriate switch number for 
the chassis system.

• Slot number—Enter the slot number on which the network device module resides.

• Process Id—Enter the processor Id on which the network device module resides.

• Command to access—Enter the session command to access the network device module.The default 
command is session slot [Slot Number] processor [Processor Id].

• Prompt prefix—Enter the command prompt prefix that will be used by the device type 
configurations and expects when issuing commands and connecting to the device.

Adding a regex character, such as $, >, and #, at the end of a prompt in the Prompt Prefix field ins 
the command prompt prefix.

Regular expressions should be placed in the appropriate Terminal Interaction Pattern fields. See the 
Connections Patterns panel to customize the interaction patterns.
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For example, if you connect to the terminal, and the prompt is Cisco_7606#, enter the regular 
expression that will match the entire prefix (before #) using any of the following expressions:

– CISCO.*

– .*7606

– CISCO_7606

• Default runtime user—Select the default runtime user account that contains the credentials to 
connect to the target.

Step 4 On the Terminal Interaction Patterns panel, configure the terminal interaction patterns for the target, and 
click Next.

• Use patterns common for the following device—Select this radio button to choose one of the 
pre-defined expect templates from the drop-down list.

– Cisco IOS Device—Select this option to use the default pattern values used by the device during 
the completion of a session command.

– Unix—Select this option to use the default pattern values indicated for a Unix device during the 
completion of a session command.

• Customize patterns for this connection—Check this check box to customize the default values for 
the selected expect template. On the Connection Patterns panel, configure the terminal interaction 
patterns for the target, then click Next.

– Prompt pattern—Enter the system prompt pattern in regular expression.

– Error pattern—Enter the error message pattern in regular expression.

– Admin prompt pattern—Enter the admin prompt pattern in regular expression.

Step 5 Modify the list of expects:

• Elevating Privilege command—Check this check box and enter the command or select the reference 
variable containing the command to elevate the privilege for the expect.

• Elevating Privilege expects—Use this section to view and/or define the login expect sequence for 
the elevating privilege command expects.

To view details about the expect columns, view Login Expect columns.

Step 6 Verify the information on the panel and click Finish to close the wizard.

Defining a Terminal Target

Use the Terminal target to specify the connection information used to access the device used for 
processes to run against. The connection information includes IP address or host name, protocol type, 
port and the runtime user credentials to access the device.

Step 1 Choose Definitions > Targets, right-click, and choose New > Terminal.

Step 2 On the General Information panel, enter the appropriate information, and click Next.

Step 3 On the Terminal Connection panel, enter the target information to specify the connection information 
to the appropriate server, including: 

• Protocol—Select the appropriate protocol from the drop-down list.

• Host name—Host name or IP address of the network device
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• Port—Port number used to access the appropriate terminal target port (Default: SSH server: 22, 
Telnet server: 23)

• Prompt prefix—Enter the command prompt prefix that will be used by the device type 
configurations and expects when issuing commands and connecting to the device.

Adding a regex character, such as $, >, and #, at the end of a prompt in the Prompt Prefix field ins 
the command prompt prefix.

Regular expressions should be placed in the appropriate Terminal Interaction Pattern fields. See the 
Connections Patterns panel to customize the interaction patterns.

For example, if you connect to the terminal, and the prompt is Cisco_7606#, enter the regular 
expression that will match the entire prefix (before #) using any of the following expressions:

– CISCO.*

– .*7606

– CISCO_7606

• Use credentials of the following runtime user—Select the default runtime user account that contains 
the credentials to connect to the target.

• Use patterns common for the following device—Select this radio button to choose one of the 
pre-defined expect templates from the drop-down list.

– Cisco IOS Device—Select this option to use the default pattern values used by the device during 
the completion of a session command.

– Unix—Select this option to use the default pattern values indicated for a Unix device during the 
completion of a session command.

• Customize patterns for this connection—Check this check box to customize the default values for 
the selected expect template. On the Connection Patterns panel, configure the terminal interaction 
patterns for the target, then click Next.

– Prompt pattern—Enter the system prompt pattern in regular expression.

– Error pattern—Enter the error message pattern in regular expression.

– Admin prompt pattern—Enter the admin prompt pattern in regular expression.

Step 4 Modify the list of expects:

• Elevating Privilege command—Check this check box and enter the command or select the reference 
variable containing the command to elevate the privilege for the expect.

• Elevating Privilege expects—Use this section to view and/or define the login expect sequence for 
the elevating privilege command expects.

Step 5 On the Host-Based Authentication panel, specify whether the target should allow authentication based 
on the host system of the user and the user name on the remote host system, and click Next.

Users can define default host public and private keys on the Terminal Adapter settings. This panel allows 
users to select a specific private key for the target. The private key will be used for host-based 
authentication if a target does not specify its own keys.

• Use host-based authentication—Check this check box to indicate that host-based authentication will 
be used with this target.

• Use the default host keys—Check this check box to indicate the host keys defined on the Terminal 
Adapter property page will be used for this target.

• Private key—Click Browse to launch the Load Private Key dialog box to select a private key.
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Step 6 On the Network Modules panel, review the list of network modules assigned to the terminal target. These 
network device modules are considered dependents of the terminal target.

If the appropriate network device module is not displayed, users can create a network device module 
target from within this wizard to be used as a dependent of the terminal target.

Step 7 Verify the information on the panel and click Finish to close the wizard.

Defining a Unix Linux System Target

Use the Unix/Linux Connection tab to specify the connection information for the SSH server used for 
processes to run against. The Unix/Linux System target also supports Telnet protocol and session based 
activities.

To properly run script and command activities against Unix/Linux system targets, Process Orchestrator 
requires the Secured File Transfer Protocol (SFTP) to be enabled on the Unix/Linux system. It is not 
needed for the SSH/Telnet Terminal Session activities.

Step 1 Choose Definitions > Targets, right-click, and choose New > Unix/Linux System.

Step 2 On the General tab, enter the appropriate information.

Step 3 Click the Connection tab to enter the appropriate target information to specify the connection 
information to the appropriate SSH server, including:

• Prompt prefix—Enter the command prompt prefix that will be used by the device type 
configurations and expects when issuing commands and connecting to the device.

Adding a regex character, such as $, >, and #, at the end of a prompt in the Prompt Prefix field ins 
the command prompt prefix.

Regular expressions should be placed in the appropriate Terminal Interaction Pattern fields. See the 
Advanced tab to customize the interaction patterns.

For example, the Unix system prompt prefix is defined by the user default login script. it usually 
contains user name, node name or current directory name. If the user does not define anything, the 
prompt prefix is empty.

If you connect to the terminal, and the prompt is jsmith@TBD-SH03-IT ~$, enter the regular 
expression that will match the entire prefix (before #) using any of the following expressions:

– .*TBD-SH03-IT.*

– \[\w+@TBD-SH03-IT.*\]

• Select the default runtime user account that contains the credentials to connect to the target. 

– To view the properties for the selected runtime user, click the Properties tool.

– To create a new runtime user, click New > [Runtime User] to create a new Runtime User 
account.

• Override Default Korn Shell path—This checkbox needs to be checked out when:

– Using a public key authenicated Admin runtime user 

– The target UNIX server does not have the "ksh" file under /usr/bin

Note When using this option, override the default path as "/bin/ksh".
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• Maximum allowed concurrent sessions—Enter the maximum allowed open sessions to run 
concurrently. (Default: 3)

If the user tries to open new session via Open Session activity, it will wait in a queue until there is 
a session available to open

Step 4 Click the Authentication tab and specify whether the target should allow authentication based on the 
host system of the user and the user name on the remote host system.

Users can define default host public and private keys on the Terminal Adapter settings. This tab allows 
users to select a specific private key for the target. The private key will be used for host-based 
authentication if a target does not specify its own keys.

• Use host-based authentication—Check this check box to indicate that host-based authentication will 
be used with this target.

• Use the default host keys—Check this check box to indicate the host keys defined on the Terminal 
Adapter property page will be used for this target. If this check box is unchecked, then the user will 
need to load the appropriate private key to be used to this target.

• Private key—To the right of the display-only field, click Browse to launch the Load Private Key 
dialog box to select a private key.

Step 5 Click the Advanced tab to configure the interaction patterns for the target.

• Use patterns common for the following device—device targets from the drop-down list.

– Cisco IOS Device—Select this option to use the default pattern values used by the device during 
the completion of a session command.

– Unix—Select this option to use the default pattern values indicated for a Unix device during the 
completion of a session command

• Customize patterns for this target—Select this radio button to enable the following sections to 
customize the default values for the selected device type. Configure the terminal interaction patterns 
for the target, then click Next.

– Prompt pattern—Enter the system prompt pattern in regular expression.

– Error pattern—Enter the error message pattern in regular expression.

– Admin prompt pattern—Enter the admin prompt pattern in regular expression.

• Login expects:

– Name—Name of the case defining what to expect

– Regular Expression—Characters in terminal output

– Operation Type—Displays what operation takes place if an expected regular expression match 
is encountered in the terminal output

- User Response—Provides input to the terminal and continue execution of the activity

- Runtime User's User name—Allows user to respond with the user name of the runtime user 
for the session

- Runtime User's Password—Allows user to respond with the password of the runtime user for 
the session

- Runtime User's Admin Password—Allows user to respond with the admin password of the 
runtime user. If the runtime user doesn’t have the admin password, the regular password will be 
used.

- Succeeded—Complete activity and set its status to Completed

- Failed (Completed)—Complete activity and set its status to Failed (Completed)
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- Failed (Not Completed)—Complete activity and set its status to Failed (Not Completed)

– User Response—Displays the defined user input string text or format to be used to perform the 
substring operation  

• To modify the list of expects, use the following buttons:

– Elevating Privilege command—Check this check box and in the text field, enter the command 
or select the reference variable containing the command to elevate the privilege for the expect.

– Elevating Privilege expects—Use this section to view and/or define the login expect sequence 
for the elevating privilege command expects.

Step 6 Click the Open Sessions tab to display the information about sessions currently opened on the target and 
sessions waiting to be opened.

To avoid the negative impacts on performance and manage resource usage, the Terminal Adapter has a 
limit on the maximum total live sessions. When the total live sessions reaches the maximum limits, the 
activity that needs to open a new session will wait until a live session is closed.

The network device module, by default, inherits the maximum allowed sessions from its chassis system. 
Users cannot adjust the value on the network device module more than value set by the chassis system. 
Any terminal activities executed against a network device module target will also count towards its 
chassis system session statistics.

Each displayed list will contain one entry for each opened session.

Defining Terminal Adapter Runtime Users

Defining a Public-key Authenticated Admin Runtime User

Use the Public-key Authenticated Admin Runtime User dialog box to define the user credentials required 
to allow public key authentication and an administrative password is required to perform privileged 
operations.

If a target has set up public key authentication on the remote SSH server, the private key of the 
Public-key Authenticated Admin Runtime User will be used to form the SSH authentication request. The 
request is then authenticated against the stored public key on the remote server.

If the target does not allow public key authentication, the SSH authentication will fail.

Step 1 Choose Definitions > Runtime Users, right-click and choose New > Public-key Authenticated Admin 
Runtime User.

Step 2 Click the General tab and enter the required information, including:

• Owner—User name of the owner of the object. This is typically the person who created the object.

• User name—The user name assigned to access the device

• Private key—Use the Load Private Key dialog box to select the private key file to be used to provide 
authentication of a public key. The private key file should reside on the same machine as the Process 
Orchestrator server.

• Admin password—Check the Admin password check box and then enter the password assigned to 
access Privileged EXEC mode on the device. The Privileged EXEC mode provides the highest level 
of commands to users.
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Step 3 Click OK to close the dialog box.

Defining a Runtime Admin User

Use the following instructions define the user credentials required to access a network device. The level 
of access for the network device is dependent upon the type of password used.

Step 1 Choose Definitions > Runtime Users, right-click and choose New > Runtime Admin User.

Step 2 Click the General tab to specify the required information, including:

• Display name—Enter the display name for the runtime user. This field is populated with the 
information specified in the User name text field, but can be overwritten by the user.

• Owner—User name of the owner of the object. This is typically the person who created the object.

• User name—The user name assigned to access the device

• Password—Check the Password check box and then enter the password assigned to access USER 
mode on the device. This password provides very limited commands to execute.

• Admin password—Check the Admin password check box and then enter the password assigned to 
access Privileged EXEC mode on the device. The Privileged EXEC mode provides the highest level 
of commands to users.

Step 3 Click OK to close the dialog box.

Automating Terminal and Secure Shell (SSH) Activities

Defining a Close Terminal Session Activity

Use the Close Terminal Session activity to close a SSH or Telnet session opened by a previous Open 
Session activity. The user should always specify a paired Open Terminal Session and Close Terminal 
Session activity within a process.

If a corresponding Close Terminal Session activity for an Open Terminal Session activity is not 
specified, the SSH session opened by the Open Terminal Session activity will be closed by the Terminal 
adapter when the process completes. The SSH session also may terminated earlier by the SSH server if 
the SSH server configuration specified a shorter user idle time.

When the Close Terminal Session activity is launched, the results of the matched expect configurations 
are displayed from the Operations Workspace activity instance view.

Step 1 In the Process Editor Toolbox, choose Terminal > Close Terminal Session, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Close Session tab to specify the appropriate device command or inputs. Enter the appropriate 
device command before ending the SSH session. For example: Quit.

Step 4 Click the Session tab and select the appropriate Open Terminal Session activity to close or send 
commands.
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The Open Terminal Session activity provides the target upon which the SSH session was opened. The 
Execute Terminal Command(s) and Close Terminal Session activities will run against the same target 
and runtime user specified in the Open Session activity.

Step 5 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Viewing Results

Click the instance tabs to view the sessions closed and opened. See also, Defining a Close Terminal 
Session Activity.

Defining a Get File Activity

Use the Get File activity to retrieve files from a Unix/Linux system target to transfer to a specified local 
directory using either the Secured File Transfer Protocol (SFTP) or Secure Copy Protocol (SCP) if SFTP 
or SCP is available on the given target. If both protocols are available, SFTP will be used.

The wildcard * is allowed. 

When the Get File activity is launched, the file transfer results of the Get File activity are displayed from 
the Operations Workspace activity instance view.

Step 1 In the Process Editor Toolbox, choose Secure Shell (SSH) > Get File and drag and drop the activity onto 
the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Get File tab and specify the remote files and file path to the local directory to where the files 
will be copied:

• Remote files on the target to copy from—The list of files on the Unix/Linux system the user wants 
to retrieve. If a relative path is specified, it will be relative to the product local application data 
directory.

• Local windows runtime user for accessing local file systems—From the drop-down list, select the 
windows runtime user account that contains the credentials to access local files.

The user must have the Log on as batch job and Allow log on locally User Rights Assignment. To 
adjust the user right assignments (choose Administrative Tools/Local Security Policy/Security 
Settings/Local Policies/User Rights Assignment).

• Local directory to copy files to—Specify the file path to the local directory to where the files will 
be copied. The default file path is relative to the product local application data directory. For 
example:

C:\Documents and Settings\test\Local Settings\Application Data

• Overwrite—Select the appropriate option to determine the circumstances in which the copied file 
should overwrite any existing file in the local directory.

– Do not overwrite—The copied file should never overwrite the existing file

– Always overwrite—The copied file should always overwrite the existing file

– Pull only if newer—Retrieves the file only if the file on the Unix/Linux system is more recent 
than the local copy.

This setting might not apply when the SCP protocol is used or a directory copy takes place.
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• Time out if not completed within—Enter a value to specify the time frame to wait for the file transfer 
to complete before timing out. Large files may cause the file transfer to take longer.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Viewing Results

Click the instance tabs to view the retrieve files from a Unix/Linux system target. See also, Defining a 
Get File Activity.

Adding a Remote File to a Get File Activity

The Get File activity copies files from remote target systems to a local directory. The Add button on this 
activity launches the Enter Remote File to Add dialog box for users to specify the file name to be added 
to the list on the Get File activity.

Step 1 On the Get File property page, click Add.

Step 2 Enter or select the file name to be added to the list and click OK.

The file is added to the list of remote files to be retrieved by the Get File activity.

Viewing Results

Click the instance tabs to view the retrieve files from a Unix/Linux system target. See also, Adding a 
Remote File to a Get File Activity.

Defining a Put File Activity

Use the Put File activity to push local files to a Unix/Linux system target if SFTP or SCP is available on 
the given target.

If both protocols are available, SFTP will be used. If one file in the list fails while uploading, the activity 
will fail.

The file transfer results of the Put File activity are displayed from the Operations Workspace activity 
instance view.

Step 1 In the Process Editor Toolbox, choose Secure Shell (SSH) > Put File and drag and drop the activity onto 
the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Put File tab and specify the local files and file path to the remote directory to where the files 
will be copied:

• Local windows runtime user for accessing local file systems—From the drop-down list, select the 
windows runtime user account that contains the credentials to access local files.

The user must have the Log on as batch job and Allow log on locally User Rights Assignment. To 
adjust the user right assignments (see Administrative Tools/Local Security Policy/Security 
Settings/Local Policies/User Rights Assignment).
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• Local files on the target to copy from—The list of files on the local computer to put on remote target 
systems. If a relative path is specified, it will be a relative to the product local application data 
directory.

• Remote directory on the target to copy files to—the file path to the local directory on the target 
systems where the files will be transferred.

An absolute path is recommended. The default file path is relative to the product local application 
data directory. For example:

C:\Documents and Settings\test\Local Settings\Application Data

• Overwrite—Select the appropriate option to determine the circumstances in which the copied file 
should overwrite any existing file in the local directory.

– Do not overwrite—The copied file should never overwrite the existing file

– Always overwrite—The copied file should always overwrite the existing file

– Pull only if newer—Retrieves the file only if the file on the Unix/Linux system is more recent 
than the local copy.

This setting might not apply when the SCP protocol is used or a directory copy takes place.

• Time out if not completed within—Enter a value to specify the time frame to wait for the file transfer 
to complete before timing out. Large files may cause the file transfer to take longer.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Viewing Results

Click the instance tabs to view the pushed local files to a Unix/Linux system target. See also, Defining 
a Put File Activity.

Adding a Local File to a Put File Activity

The Put File activity copies files from a local directory onto a remote target system. The Add button on 
this activity launches the Enter Local File to Add dialog for users to specify the file name to be added to 
the list on the Put File activity.

Step 1 On the Put File property page, click Add.

Step 2 In the Local File field, enter or select the file name to be added to the list and click OK.

The file is added to the list of local files to be retrieved by the Put File activity

Defining an Execute Unix/Linux SSH Command Activity

Use the Execute Unix/Linux SSH Command activity to specify a SSH command to execute. To properly 
run this activity, Process Orchestrator requires SFTP to be configured on the SSH server. This activity 
is only supported against the Unix/Linux system target. Korn Shell is also required.

Pipe is not supported by the Execute Unix/Linux SSH Command activity. If the user needs to execute 
pipe in an activity, it is recommended that the user places the pipe in the Execute Unix/Linux SSH Script 
activity.
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For example, you can enter “ps -ef “ in the Execute Unix/Linux SSH Command activity, but if you need 
to execute “ps -ef | grep myusename” then, that information should be placed in the Execute Unix/Linux 
SSH Script activity.

When the Execute Unix/Linux SSH Command activity is launched, the results of the executed SSH 
command are displayed from the Operations Workspace activity instance view.

Step 1 In the Process Editor Toolbox, choose Secure Shell (SSH) > Execute Unix/Linux SSH Command and 
drag and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Command tab to specify the command line properties used to execute an activity on a local 
working directory on the SSH server.

• Command to execute on target—Enter the actual command to execute an activity on the SSH server. 
See Command Line Examples, page 12-140.

• Local working directory on target—Enter the path to the local working directory on the SSH server 
where the command will be executed.

If the path is left blank, the default directory will be user login directory on the SSH server

• Command line arguments—Enter the collection of argument values for the command. See Web 
Console Help Adapter, page 12-213.

• Time out if not completed within—Enter a value or use the scroll buttons to specify the time frame 
to wait for the action to complete before timing out.

• Time out if no available session within—Enter a value or use the scroll buttons to specify the time 
frame to wait for the activity to complete if there is no available session.

The cause for no available session might be that the setting “max allowed concurrent sessions” on 
the target has been reached.

• Fail on non-zero return code—Selected check box indicates that the activity should fail when a 
return code having a non-zero value is received.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Command Line Examples

The following are Terminal adapter command line examples.

Example

If your local working directory is:

/home/myusername/myappdata

and the command is

/myAppPath/myShellScript.sh

the full path is:

/home/myusername/myappdata/myAppPath/myShellScript.sh.

Example

on Unix systems:
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ls

/usr/bin/ls

If your command is located at the directory of:

/myCommandPath

and the command is

myCommand

the full path is:

/myCommandPath/myCommand

Defining an Execute Unix/Linux SSH Script Activity

Use the Execute Unix/Linux SSH Script activity to specify a SSH script argument to execute. 

When the Execute Unix/Linux SSH Script activity is launched, the results of the executed SSH script 
argument are displayed from the Operations Workspace activity instance view.

Before You Begin

To properly run this activity, SFTP must be configured on the SSH server.

Step 1 In the Process Editor Toolbox, choose Secure Shell (SSH) > Execute Unix/Linux SSH Script and drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Script tab and specify a SSH script argument to execute:

• Local working directory on target—Enter the path to the local working directory on the SSH server 
where the script will be executed.

• Script arguments—Enter the collection of argument values for the script. See Web Console Help 
Adapter, page 12-213.

• Script to execute on target—Enter the actual script code to use to execute in the specified local 
working directory.

• Time out if not completed within—Enter a value or use the scroll buttons to specify the time frame 
to wait for the action to complete before timing out.

• Time out if no available session within—Enter a value or use the scroll buttons to specify the time 
frame to wait for the activity to complete if there is no available session.

The cause for no available session might be that the setting “max allowed concurrent sessions” on 
the target has been reached.

• Fail on non-zero return code—Selected check box indicates that the activity should fail when a 
return code having a non-zero value is received.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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Adding a Script Argument

Script arguments are a property for SSH activities. The Add button on these activities launches the Select 
Argument to Add dialog box for users to specify the script arguments to be added to the list on the 
specified SSH activity.

Step 1 On the appropriate SSH activity property page, click Add.

Step 2 Specify the script argument value for the script and click OK.

The script argument is added to the command line argument list on the activity property page.

Script Argument Example

The following is an example of a script containing four arguments. 

Script to Execute

#! /bin/csh

     echo ${0}

     echo “Number of arguments is $#argv”

     echo $2

     echo $argv[2-3]

     echo $argv[$]

     exit

Script Arguments

% argex.csh “hello world” 42 3.14159 “(300:400,~100)”

     argex.csh

     Number of arguments is 4

     42

     42 3.14159

     (300:400,~100)

Script Argument Syntax

Any command-line arguments can be accessed as shell variables inside a script. The following table 
contains script arguments which can be used inside a script.

Syntax Description

${0} The name of the script being run

$?name Returns 1 if the variable name is defined, or 0 if it is not defined

$n The value of the n argument passed to the script

$argv[n] The value of the n argument passed to the script

$#argv The number of arguments passed to the script
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Defining an Open Terminal Session Activity

Use the Open Terminal Session activity to start a SSH session on a given terminal target via a SSH 
protocol client. The subsequent Execute Terminal Command(s) and Close Terminal Session activities 
will run against an SSH session.

The expects configuration used during this operation are defined in the selected target.

When the Open Terminal Session activity is launched, the results of the matched expect configurations 
are displayed from the Operations Workspace activity instance view.

Step 1 In the Process Editor Toolbox, choose Terminal > Open Terminal Session, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Open Terminal Session tab and modify the time constraints for the activity or command:

• Activity Timeout—Check this check box and then enter a value to specify the time frame to wait for 
the Open Terminal Session activity to complete before timing out. (Default: 5 minutes)

• Time out if no available session within—Enter a value or use the scroll buttons to specify the time 
frame to wait for the activity to complete if there is no available session.

The cause for no available session might be that the setting “max allowed concurrent sessions” on 
the target has been reached.

To the right of the timeout fields, select the time unit link to adjust the time unit 

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Troubleshooting the Terminal Adapter

Activity Output Does Not Match Expect Prompts

Error

This activity has failed, please check the output or the expect results table.

If the output does not match the expect prompts, the activity will timeout.

To review the expect result properties:

Step 1 Choose Operations > Processes, highlight the appropriate process, right-click and choose Observe.

Step 2 On the Workflow pane, locate the appropriate Execute Terminal Command activity.

Step 3 On the activity Properties pane, click the Output tab.

Step 4 Under Expect result table, click Properties. The Expect properties dialog box displays.

$* All the arguments supplied to the script

$$ Process identification number (useful for making temporary files with unique 
names)
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Step 5 Review the Match before field to review the expect properties to verify whether the activity contains 
valid expects.

Solution

This is not an easily determined problem, because the output doesn’t clearly explain the error. After 
verifying the expects in the Expect Result Properties dialog box, modify the expects and then re-run the 
process.

To modify the expects:

Step 1 Highlight the process, right-click and choose Edit.

Step 2 On the Workflow pane, locate the appropriate Execute Terminal Command activity.

Step 3 On the activity Properties pane, click the Expect tab.

Step 4 Highlight the appropriate expect, click Edit and then modify the information in the Regular Expression 
field.

Step 5 Click OK to close the dialog box and then click the Save tool to save the process.

Step 6 Click the Start tool to run the saved process.

Step 7 Close the Process Editor and return to the Operations workspace to observe the process status.

Correcting Open Session Activity Timeout Error

Error

This activity has failed because the session activity has timed out.

Solution

This is a basic issue that occurs when the user did not enter enough time when defining the properties of 
the Open Session activity.

To modify the Open Session activity properties:

Step 1 Highlight the process, right-click and choose Edit.

Step 2 On the Workflow pane, locate the appropriate Open Session activity.

Step 3 On the activity Properties pane, click the Open Sessions tab.

Step 4 In the Activity timeout field, increase the amount of time necessary to run the process before the activity 
times out.

Step 5 Click the Save tool to save and the Start tool to run the saved process.

Step 6 Close the Process Editor and return to the Operations workspace to observe the process status.
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Execute Terminal Command Activity Timed Out

Error

This activity has timed out while waiting for expected output.

Step 1 Choose Operations > Processes, highlight the appropriate process, right-click and choose Observe.

Step 2 On the Workflow pane, locate the appropriate Execute Terminal Command activity.

Step 3 On the activity Properties pane, click the Output tab.

Step 4 Under Expect result table, click Properties.

Step 5 Review all the expects with the Succeeded operation type to make sure that there is an expect that will 
match the output somewhere. There must be at least one expect with a Succeeded operation type for the 
activity to succeed.

Solution

After verifying the expects in the Expect Result Properties dialog box, modify the expects and then 
re-run the process.

To modify the expects:

Step 1 Double-click the process.

Step 2 On the Workflow pane, locate the appropriate Execute Terminal Command activity.

Step 3 On the activity Properties pane, click the Expect tab.

Step 4 Highlight the appropriate expect, click Edit and then modify the information in the Regular Expression 
field.

Step 5 Click OK to close the dialog box and then click the Save tool to save the process.

Step 6 Click the Start tool to run the saved process.

Step 7 Close the Process Editor and return to the Operations workspace to observe the process status.

Expect Prompt Command Error

Error

This activity has failed, please check the output or the expect result table to see the error details.

Solution

For this particular error, the user should not concentrate on the match results, but the expect command 
in the Expect Result Properties dialog box. The information in the dialog is Cisco IOS data and the user 
must be familiar with Cisco IOS, otherwise he or she will not understand the error.

To review the expect result properties:

Step 1 Choose Operations > Processes, highlight the appropriate process, right-click and choose Observe.

Step 2 On the Workflow pane, locate the appropriate Execute Terminal Command activity.
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Step 3 On the activity Properties pane, click the Output tab.

Step 4 Under Expect result table, click Properties to review the detailed error message for the prompt 
command.

Step 5 Review the expect properties to determine the next course of action based on the Cisco IOS data.

Target Connection Pattern Prompt Prefix Error

Error

This activity has timed out while waiting for expected output.

This error is generated because the activity was waiting for data before successfully completing the 
activity.

Solution

Before continuing, verify that the activity simply isn’t timing out too quickly. If so, then modify the time 
entry in the Activity timeout field on the activity property page in the Process Editor. If the amount of 
time in the activity is sufficient, then compare the information on the Output tab to the regular expression 
and the operation type on the Expect tab. If the expects do no match, then it will be necessary to modify 
the appropriate prompt prefixes.

In the following examples, the regular expressions in both Prompt expects are different than what was 
generated on the output.

Example—Output Tab 1
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Example—Expect Tab 2

To modify the prompt prefix:

Step 1 Double-click the process.

Step 2 On the Workflow pane, locate the appropriate Execute Terminal Command activity.

Step 3 On the activity Properties pane, click the Expect tab.

Step 4 Highlight the appropriate expect, click Edit and then modify the information in the Regular Expression 
field.

Step 5 Click OK to close the dialog box and then click the Save tool to save the process.

Step 6 Click the Start tool to run the saved process.

Step 7 Close the Process Editor and return to the Operations workspace to observe the process status.
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UCS Director Adapter
The Cisco Process Orchestrator Software Adapter for Cisco UCS Director supports task automation on 
Cisco Unified Computing System (UCS) Manager instances. It provides activities for service profile 
management and the collection of Cisco UCS Director statistics and the Cisco UCS Director target.

The Cisco UCS Director Adapter uses real-time available capacity, internal policies, and application 
workload requirements to optimize availability of the most beneficial or best-suited resources. 

The following table displays activities that are provided by the UCS Director adapter. For more 
information about using these activities, see Getting Started Using the Cisco UCS Director Adapter, 
page 12-148.

Getting Started Using the Cisco UCS Director Adapter
Use the following process to monitor and manage Cisco Unified Computing System (UCS) Director 
instances. 

Step 1 Create a Cisco UCS Director target (see Defining a Cisco UCS Director Operation Activity, 
page 12-150).

Step 2 Define a Cisco UCS Director command activity (see Automating Cisco UCS Director Task and 
Workflow Activities, page 12-149). 

Step 3 View the activity results (see Monitoring Operations, page 8-1).

Activity Comments

Define an operation 
activity

Select Execute Cisco UCS Director Operation to support any of the 
other Version 1 JSON-based APIs. These operations accept JSON 
parameter inputs and produce JSON output.

See Defining a Cisco UCS Director Operation Activity.

Define a task activity Select Execute Cisco UCS Director Task to support any of the other 
Version 2 XML task APIs supported by Cisco UCS Director.

See Defining a Cisco UCS Director Task Activity.

Define a workflow 
activity

Select Execute Cisco UCS Director Workflow to start a Cisco UCS 
Director workflow.

See Defining a Cisco UCS Director Workflow.

Define a get workflow 
status activity

Select Get Cisco UCS Director Workflow Status to get the status for a 
specified Service Request Id.

See Defining a Get Workflow Status Activity.
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Defining a Cisco UCS Director Server Target

Step 1 Use the Cisco UCS Director Server target to configure the connection information for the UCS Director 
Directory server that processes and activities will be run against. 

Step 1 Choose Definitions > Targets, right-click, and choose New > Cisco UCS Director Server.

Step 2 Enter the required General information.

Step 3 Enter the Cisco UCS Director server Connection information, including:

• Access Cisco UCS Director via Secure Socket Layer (SSL)—Use this option to make your 
environment secure.

Step 4 Verify the information on the panel and click Finish to close the wizard.

Generating the REST XML for a Task Invocation

Before You Begin

You must be logged in as “admin”.

Step 1 In the Cloupia UI, click on your username in the upper right corner. 

Step 2 In the User Information panel, click the Advanced tab, then click Enable Developer Menu (for this 
session).

Step 3 There is no OK button, so just close the window. If you are already looking at Policies > Orchestration, 
you will need to navigate away and then back to the page.

Step 4 Choose Policies > Orchestration > Rest API Browser.  You should get a list of all available tasks for 
this session.  

Step 5 Browse to a task, then copy and paste the XML into the Process Orchestrator Execute Cisco UCS 
Director Task activity.

• In some cases, such as for GET calls, all you need is the relative URL and the Method (GET).  

• In other cases where there are a lot of inputs, build those inputs in the REST API Browser and then 
click Generate XML to see what the contents of the POST should look like. 

Step 6 Replace items as needed with the Process Orchestrator reference control

Automating Cisco UCS Director Task and Workflow Activities
Calling a Cisco UCS Director tasks is different from calling a workflow. Calling a task is similar to using 
a Process Orchestrator activity. There are several advantages:

• Ease of installation and distribution—The customer can use Cisco automation pack files, which 
contain Cisco Process Orchestrator workflows

• Use upgrade, customization, licensing, and other capabilities of Cisco automation packs

• Write workflows using Process Orchestrator logical conditions, and so on.
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The one disadvantage of calling a Task is that you must know the XML for all of the called tasks. 
However, there is a relatively easy way to do this using Cisco UCS Director (see Generating the REST 
XML for a Task Invocation, page 12-149).

There are advantages to calling a Workflow in Cisco UCS Director as well:

• A workflow allows Process Orchestrator to be used at a customer site where the customer might have 
already created several Cisco UCS Director workflows.

• There might be some other cases in which a Cisco UCS Director workflow is preferred.

The disadvantages of calling a workflow are that a workflow is not as easy to distribute using the Cisco 
automation pack files, and it might be more difficult to express certain workflows.

Defining a Cisco UCS Director Operation Activity

Use the Execute Cisco UCS Director Operation activity to support any of the other Version 1 
JSON-based APIs. These operations accept JSON parameter inputs and produce JSON output.

Step 1 In the Process Editor Toolbox, choose AMQP > Execute Cisco UCS Director Operation, then drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Operation tab and enter the API name, the operation data (JSON), and whether to restart the 
operation if it is interrupted.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining a Cisco UCS Director Task Activity

This activity supports any of the other Version 2 XML task APIs supported by Cisco UCS Director.

Step 1 In the Process Editor Toolbox, choose AMQP > Execute Cisco UCS Director Task, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Operation tab and enter:

• The URL to be requested (relative or absolute).

– Relative Url—For example, admin

If the API leads the relative URL (api/admin), the activity will fail and cause a Resource not 
found error.

– Absolute URL—For example, https://172.25.4.131/api/admin/orgs

• HTTP Method—The HTTP method to be performed on the resource identified by the Request-URI. 
The method is case-sensitive.

• Request XML—The request XML. For example:

<cuicOperationRequest>

<operationType>EXECUTE_VM_COMMAND</operationType>

<payload>
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<![CDATA[

<ExecuteVMCommand>

<!-- Accepts value from the list: vm-->

<vmId>17</vmId>

<userName>test</userName>

<password>test</password>

<commdPath>test</commdPath>

<commdArgs>test</commdArgs>

</ExecuteVMCommand>

]]>

</payload>

</cuicOperationRequest> 

• Timeout—The timeout time in seconds, minutes, hours, or days.

• Restart when interrupted—Whether to restart the operation if it is interrupted.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining a Cisco UCS Director Workflow

This activity starts a Cisco UCS Director workflow with optional specified inputs, and optionally waits 
for a period of time for the workflow to complete.

Step 1 In the Process Editor Toolbox, choose AMQP > Execute Cisco UCS Director Workflow, then drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Workflow tab and enter:

• The workflow name.

• A list of workflow properties, which consist of substitutable string / type / substitutable encrypted 
string (can reference encrypted strings like HTTP Request).

• Whether to restart the operation if it is interrupted.

• Whether to wait for completion. If configured to wait for completion, this activity will fail if the 
workflow times out, fails, or is canceled on the Cisco UCS Director side.

Step 4 Click the Advanced tab and enter the required information.

Step 5 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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Defining a Get Workflow Status Activity

Use the Get Cisco UCS Director Workflow Status activity to get the status for a specified Service 
Request Id.

Step 1 In the Process Editor Toolbox, choose AMQP > Get Cisco UCS Director Workflow Status, then drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Workflow tab and enter the Service Request Id for the workflow on which you want to receive 
a status.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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UCS Software Adapter
The Cisco UCS Adapter provides activities for automating tasks on Cisco Unified Computing System 
(UCS) Manager instances. It provides activities for service profile management and the collection of 
Cisco UCS statistics, and the Cisco UCS Manager target and Cisco UCS Fault event.

The following table displays activities that are provided by the Cisco UCS adapter. For more information 
about using these activities, see Getting Started Using the Cisco UCS Software Adapter, page 12-155.

Activity Comments

Associate UCS Service Profile to 
Server

Associate a service profile to a server. You can associate the service 
profile to a server using the server distinguished name, chassis ID 
and slot ID (for blade servers), rack ID (for C-Series servers), or 
server pool.

See Defining the Associate UCS Service Profile to Server Activity, 
page 12-157.

Associate UCS VLAN To vNIC Assign a UCS VLAN to a vNIC of a service profile.

See Defining the Associate UCS VLAN To vNIC Activity, 
page 12-159

Bind UCS Service Profile to 
Template

Bind a service profile to a service profile template. 

When you bind the service profile to a template, Cisco UCS 
Manager configures the service profile with the values defined in 
the service profile template. If the existing service profile 
configuration does not match the template, Cisco UCS Manager 
reconfigures the service profile. 

You can only change the configuration of a bound service profile 
through the associated template.

Boot UCS Server Boot a UCS blade server or rack-mount server using the service 
profile associated with it.

Collect UCS Statistics Collect performance counters from UCS blade servers or 
rack-mount servers, chassis, fabric interconnects and other 
components.

See Defining the Associate UCS VLAN To vNIC Activity, 
page 12-159

Correlate UCS Faults Correlate UCS faults for the specified fault criteria on the specified 
UCS Manager target.

Create UCS Configuration 
Backup

Create a backup copy of the UCS configuration prior to a firmware 
upgrade.

See Defining the Create UCS Configuration Backup Activity, 
page 12-160

Create UCS Service Profile from 
Template

Create a service profile from an existing template.

Defining the Create UCS Service Profile From Template, 
page 12-158
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Delete UCS Service Profile Delete a service profile.

Note The distinguished name should be in the format 
root/org-Sales/ls-ServiceProfiler1.

Disassociate UCS Service Profile Disassociate a service profile from a UCS server or blade.

Note The distinguished name should be in the format 
root/org-Sales/ls-ServiceProfiler1.

Disassociate UCS VLAN From 
vNIC

Disassociate a UCS VLAN from a vNIC of a service profile.

Note The distinguished name should be in the format 
org-root/org-TEO_Test/ls-srvprofz1/ether-1-host-eth-2.

Note The VLAN name should be in the format 123.45.67-Test.

Execute UCS Manager Command Execute an XML-style request on a UCS Manager target and return 
its output as response text. Example XML command:

<configResolveDn dn="sys/chassis-2/blade-1" 
inHierarchical="false"></configResolveDn>

Defining the Execute UCS Manager Command Activity, 
page 12-161

Get UCS Blade Server 
Configuration

Retrieve configuration information on a UCS blade server.

Note The distinguished name should be in the format 
sys/chassis-1/blade-1.

Get UCS C-Series Server 
Configuration

Retrieve configuration information on a UCS rack-mounted server 
(C-Series).

Note The distinguished name should be in the format 
sys/rack-unit-1.

Get UCS Fabric Interconnect 
Configuration

Retrieve the fabric interconnect configuration properties and 
whether the fabric interconnect components are ready for firmware 
upgrade.

Note The distinguished name should be in the format 
sys/mgmt-entity-A.

Get UCS Interface Card 
Configuration

Retrieve interface card configuration properties and whether the 
interface card components are ready for firmware upgrade.

Note The distinguished name should be in the format 
sys/chassis-1/blade-1/adaptor-1.

Get UCS IO Module 
Configuration

Retrieve IO module configuration information and whether the IO 
module components are ready for firmware upgrade.

Note The distinguished name should be in the format 
sys/chassis-1/slot-1.

Get UCS Service Profile Fibre 
Channel and VSAN 
Configuration

Retrieve configuration information on a UCS service profile fabric 
channel and VSAN.

Note The distinguished name should be in the format 
org-root/org-TEO_Test/ls-srvprofz1.

Modify UCS Service Profile Modify a service profile. 

See Defining the Modify UCS Service Profile Activity, 
page 12-162
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Getting Started Using the Cisco UCS Software Adapter
Use the following process to monitor and manage Cisco UCS Software instances. 

Step 1 Create a Cisco UCS target (see Creating a Cisco UCS Manager Target, page 12-155).

Step 2 Define the fault criteria you want to monitor in Cisco UCS Manager (see Creating a Cisco UCS Fault 
Trigger, page 12-156).

Step 3 Define a Cisco UCS command activity. 

a. In the Process Editor Toolbox, choose Cisco UCS > [Cisco UCS Activity], then drag and drop the 
activity onto the Workflow pane.

b. Click the General tab and enter the required information.

c. Click the [Activity-Specific] tabs to define the properties specific to the activity. 

d. Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

For details about a specific activity, see Automating a Cisco UCS Activity, page 12-157.

Step 4 View the activity results (see Monitoring Operations, page 8-1).

Creating a Cisco UCS Manager Target

Step 1 Choose Definitions > Targets > New > Cisco UCS Manager.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Connection tab to specify the connection information for the Cisco UCS Manager target, 
including:

• UCS Manager host name—Enter the IP address or name of the server that hosts the UCS Manager.

• UCS Manager port number—Port number for connecting to the Cisco UCS Manager target. By 
default, port 443 is used for SSL protocol and port 80 is used for http connection.

Step 4 Click the Options tab to specify polling information for the UCS Manager target:

Modify UCS VLAN Settings Modify the VLAN settings on a service profile vNIC.

See Defining the Modify UCS VLAN Settings Activity, 
page 12-164

Reset UCS Server Reboot a UCS server blade using its service profile. The activity 
polls the server state until its power state is up.

See Defining the Reset UCS Server Activity, page 12-164

Shutdown UCS Server Power down a server or blade using its service profile.

See Defining the Shutdown UCS Server Activity, page 12-165

Unbind UCS Service Profile from 
Template

Unbind a UCS service profile from a template.

Note The distinguished name should be in the format 
root/org-Sales/ls-ServiceProfiler1.
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• Default timeout for activities—Enter the number of seconds to wait for a UCS activity to fail 
because it timed out. The default timeout value is 120 seconds.

Note In some cases, the timeout will not actually cancel at 120 seconds, but at 1800 seconds. The 
UI on screen might still say 120 seconds and may be ignored.

• UCS faults polling interval—Enter the number of seconds to represent how often the UCS Manager 
target should be polled for faults. The default value is 60 seconds.

• Wait time for asynchronous UCS commands—Enter the number of seconds to wait for an 
asynchronous command to fail because it timed out. The default timeout value is 900 seconds.

Step 5 Enter the information in the remaining tabs as necessary, then click OK.

Specifying Cisco UCS Default Assignment
Perform the following steps to specify the person or group who will be assigned tasks related to Cisco 
UCS incidents.

Step 1 Choose Definitions > Task Rules.

Step 2 Click the Filter by link and choose Automation Pack, and then choose Cisco UCS from the drop-down 
list to display the task rules that ship with the automation pack.

Step 3 Right-click the Cisco UCS Default Assignment task rule and choose Properties to open the Cisco UCS 
Default Assignment Properties dialog box.

Step 4 Click the Assign tab to specify the user or group that should receive assignments for incidents and alerts 
generated by the processes, then click Add to open the Select Assignee to Add dialog box.

Step 5 On the Select Assignee to Add dialog box, click the Reference tool to select the appropriate variable 
reference containing the assignee or list of assignees from the Insert Variable Reference dialog box.

Step 6 Click OK to add the assignee to the task rule, then click OK to close the dialog box.

Creating a Cisco UCS Fault Trigger
In Cisco UCS Manager, a fault represents a failure in the Cisco UCS Manager or an alarm threshold that 
has been raised. During the lifecycle of a fault, it can change from one state or severity to another. Each 
fault includes information about the operational state of the affected object at the time the fault was 
raised. If the fault is transitional and the failure is resolved, the object transitions to a functional stated.

Note With the high availability feature, every process definition that is executed based on the Cisco UCS Fault 
trigger, has an associated owning server responsible for monitoring it. To view the server that is assigned 
the responsibility for the Cisco UCS Manager Fault Monitor, open the Orchestrator Server properties 
and click the Responsibilities tab.

To define the fault criteria for which to monitor in Cisco UCS Manager:
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Step 1 Choose Definitions > Processes, select an existing process, right-click and choose Edit, or right-click 
Processes in the navigation pane and choose New Process.

Step 2 On the Process Editor properties, click the Triggers tab, then click New > Cisco UCS Fault.

Step 3 Click the General tab and enter the required information.

Step 4 Click the Faults tab and enter the required information.

Step 5 Enter the information in the remaining tabs as necessary, then click OK.

Automating a Cisco UCS Activity

Defining the Associate UCS Service Profile to Server Activity

Step 1 In the Process Editor Toolbox, choose Cisco UCS > Associate UCS Service Profile to Server, click the 
activity and drag it onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Service Profile tab to define the properties specific to the activity, including:

• Service profile distinguished name—The distinguished name should be in the format 
root/org-Sales/ls-ServiceProfiler1.

• Server assignment—Choose the method to be used to associate the service profile to the server. The 
fields that display depend on the selected method:

– Server—Choose this option to specify the server name to which to associate the service profile 
and then specify the following information:

– Chassis ID—Click this radio button for blade servers; specify the chassis that contains the 
server to be assigned to the service profile. This option is used to blade servers.

– Slot ID—Specify the slot ID that contains the server to be assigned to the service profile.

– Rack ID—Click this radio button for C-Series servers; specify the rack ID that contains the 
server to be assigned to the service profile. Use the format sys/rack-unit-{0} to specify the server 
distinguished name.

– Server distinguished name—Choose this option to specify the distinguished name of the server 
to which to associate the service profile and then specify the following information:

– Server distinguished name—Specify the distinguished name of the server. For example: 
fabric/server/chassis-2/slot-5

– Server pool—Choose this option to specify an existing server pool that contains the server to 
which to associate the service profile and then specify the following information:

– Server pool—Specify the name of the server pool to which the server is assigned. For example, 
CIAC-UCS-Blades.

– Server pool qualification—Optional. Specify the server pool qualification that is assigned to the 
servers in the server pool.

• Restrict migration—Check this check box if you want UCS Manager to perform compatibility 
checks on the new server before migrating the existing service profile.
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• Collect XML output—Check this check box if you want the raw XML output to display on the XML 
Output instance property page.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Create UCS Service Profile From Template

Step 1 In the Process Editor Toolbox, choose Cisco UCS > Create UCS Service Profile From Template, click 
the activity and drag it onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Service Profile tab to define the properties specific to the activity, including:

• Template distinguished name—Choose this option to specify the distinguished name from the 
template that you want to use to create the UCS service profile.

• Template Organization—Choose this option to specify the Organization name for the service 
profile.

• Service profile name—Choose the name for the service profile that will be created.

• Number of service profiles—Specify the number of service profiles to be created.

• Expose All Properties—Check this check box if you want all the properties in the template to be 
used to create the service profile.

• Collect XML output—Check this check box if you want the raw XML output to display on the XML 
Output tab.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Correlate UCS Faults Activity

Step 1 In the Process Editor Toolbox, choose Cisco UCS > Correlate UCS Faults, click the activity and drag 
it onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the UCS Fault Criteria tab to correlate UCS faults for the specified fault criteria on the UCS 
Manager target, including:

• Correlate UCS faults that occur within—Time interval for which to correlate faults. Choose the 
number and click the time value (seconds or minutes). Indicate when the correlation should occur 
(after, before, or before or after) in relation to the process start time.

• Number of UCS faults to correlate—Specify the number of faults to correlate:

– All UCS faults in the above time frame—Click this radio button to indicate that all UCS faults 
that occur within the specified time frame should be correlated.

– Number of UCS faults—Click this radio button to enter a specific number of faults to correlate.

• UCS Fault criteria—Check the check box for fault severity level of faults that should be correlated:

– Critical
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– Major

– Minor

– Warning

– Condition

– Info

– Cleared

• Match only UCS faults within the following properties—Check the check box for the properties 
within the fault that should be matched and then specify the criteria.

– Affected object—Check this check box to match a specific object.

– Code—Check this check box to match a specific unique identifier assigned to the fault.

– Description—Check this check box to match a text description of the fault.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Associate UCS VLAN To vNIC Activity

Step 1 In the Process Editor Toolbox, choose Cisco UCS > Associate UCS VLAN To vNIC, click the activity 
and drag it onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Associate VLAN tab and enter:

• vNIC distinguished name—Specify the distinguished name for the vNIC to which the VLAN will 
be assigned.

• VLAN name—Specify the name of the VLAN to be assigned to the vNIC.

• Native VLAN—Enter True or False to indicate whether the selected VLAN is a native VLAN. You 
can also use the reference tool to reference the value of another variable.

• Collect XML output—Check this check box if you want the raw XML output to display on the XML 
Output instance property page.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Collect UCS Statistics Activity

Step 1 In the Process Editor Toolbox, choose Cisco UCS > Collect UCS Statistics, click the activity and drag 
it onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Managed Object tab and enter:

• Distinguished name contains (* for all)—Specify the distinguished name of a UCS statistics (for 
example, sys/switch-A/sysstats). Enter * to collect all statistics of the server component class.

The distinguished name format is related to the class name selected. For example, 
sys/switch-A/systats.
12-159
Cisco Process Orchestrator 3.3 User Guide

 



 

Appendix 12      Using Adapters
  UCS Software Adapter
• Class name—The server component for which to retrieve performance data.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Create UCS Configuration Backup Activity

Step 1 In the Process Editor Toolbox, choose Cisco UCS >Create UCS Configuration Backup, click the 
activity and drag it onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Configuration Backup tab to define the properties specific to the activity, including:

• Type—Choose the type of configuration to be backed up from the drop-down list. The following 
configuration types are available:

– Full state—Includes a snapshot of the entire system. You can use this file for disaster recovery 
if you need to recreate every configuration on a fabric interconnect or rebuild a fabric 
interconnect.

– All configuration—Includes all system and logical configuration information.

– System configuration—Includes all system configuration settings such as user names, roles, and 
locales.

– Logical configuration— Includes all logical configuration settings such as service profiles, 
LAN configuration settings, SAN configuration settings, pools, and policies.

• Preserve identities—Preserve all identities derived from pools, including the MAC addresses, 
WWPN, WWNN, and UUIDs.

• Protocol—The protocol to be used when communicating with the remote server. The following 
protocols can be used:

– FTP

– TFTP

– SCP

– SFTP

• Remote file—The full path to the backup configuration file. This field can contain the filename as 
well as the path. If you omit the filename, the backup procedure assigns a name to the file.

Note You can insert the timestamp into the file name by referencing the output from the Format 
Date activity. This activity will format the process start time into a data time string and 
expose a Formatted Date property that can be referenced in the Create UCS Configuration 
Backup activity (Remote File field)

• User—The runtime user that should be used to log into the remote server. This field does not apply 
if the protocol is TFTP.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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Defining the Disassociate UCS Service Profile Activity

Step 1 In the Process Editor Toolbox, choose Cisco UCS >Disassociate UCS Service Profile, click the activity 
and drag it onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Service Profile tab to disassociate a service profile from a server or server pool.

• Distinguished name—Click the Browse tool to specify the distinguished name for the service 
profile. 

Note The distinguished name should be in the format root/org-Sales/ls-ServiceProfiler1.

• Collect XML output—Check this check box if you want the raw XML output to display on the XML 
Output instance property page.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Execute UCS Manager Command Activity

Step 1 In the Process Editor Toolbox, choose Cisco UCS >Execute UCS Manager Command, click the 
activity and drag it onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Command tab to execute an XML-style request on a UCS Manager target and return its output 
as response text.

• UCS XML API command—Enter the UCS Manager XML command request to be executed on the 
UCS Manager target. 

Step 4 Click the XML Transform tab to transform the XML output to a table.

• Row XML element name—The element name of the row to be transformed

• Columns to read—Specify the columns in the XML output to read. Click Add to specify the column 
and type of data, and then click OK to add the information to the table.

Step 5 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Inserting Formatted Date Into Activity

You can insert a timestamp into the UCS Configuration Backup file using the Format Date activity in the 
process. This activity will format the process start time into a data time string and expose a Formatted 
Date property that can be referenced in the Create UCS Configuration Backup activity (Remote File 
field).

Step 1 Create a new process that includes the following activities:
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• Format Date 

• Create UCS Configuration Backup

Step 2 In the Process Editor toolkit, choose Core Activities > Format Date.

Step 3 Click the Format Date tab, then click Original date > Reference.

Step 4 On the Insert Variable Reference dialog box, expand the Process node and select Start Time.

Step 5 Click OK to close the dialog box and insert the variable reference into the Original date field on the 
Format Date activity properties.

Step 6 In the Process Editor toolkit, choose Cisco UCS > Create UCS Configuration Backup.

Step 7 Click the Configuration Backup tab, then in the Remote file field, enter a name for the backup file.

Step 8 Click Reference to reference the formatted date exposed from the Format Date activity in the workflow.

Step 9 On the Insert Variable Reference dialog box, expand the Workflow > Format Date nodes and select 
Formatted Date, then click OK.

Step 10 Complete the remaining fields on the Configuration Backup Properties dialog box and click Save to 
complete the process definition.

Defining the Modify UCS Service Profile Activity

Before You Begin

If the service profile is associated with a template, you must first disassociate the service profile from 
the template.

Step 1 In the Process Editor Toolbox, choose Cisco UCS > Modify UCS Service Profile, click the activity and 
drag it onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Service Profile tab to define the properties specific to the activity, including:

• Service profile distinguished name—Choose the type of profile to be modified (Service Profile or 
Service Profile Template). The distinguished name should be in the format 
root/org-Sales/ls-ServiceProfiler1.

• Profile Properties—List of profile properties and property values to be updated. 

• From the Property name drop-down list, choose the property name and enter the new value in the 
Property value field. Click Add to List. The following selections are available:

– Agent Policy—The Agent policy that should be included in this service profile.

– Bios Profile—The BIOS policy that should be included in this service profile.

– Boot Policy—The type of boot policy that should be included in this service profile. This can 
be one of the following:

- Primary—The first address defined for the associated boot device class. A boot policy can only 
have one primary LAN, SAN, or iSCSI boot location.

- Secondary—The second address defined for the associated boot device class. Each boot policy 
can have only one secondary LAN or SAN boot location.
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The use of the terms primary or secondary boot devices does not imply a boot order. The 
effective order of boot devices within the same device class is determined by PCIe bus scan 
order.

– Description—The user-defined description for this service profile. Enter up to 256 characters. 
You can use any characters or spaces except ^ (carat), \ (backslash), > (greater than), < (less 
than), ' (single quote), " (double quote), ` (accent mark), or = (equal sign).

– Dynamic vNIC Connection Policy—Global or Private vNIC connection policy.

– Host Firmware Policy—The name of the host firmware package associated with this profile, if 
any.

– UUID Pool—The name of the UUID pool that this service profile uses to create a UUID for any 
server to which it is assigned.

– Local Disk Configuration Policy Name—The name of the associated global local disk policy.

– Mgmt Access Policy Name—The name of the IPMI access profile associated with this service 
profile, if any.

– Management Firmware Policy—The name of the management firmware package associated 
with this profile, if any.

– Scrub Policy—The scrub policy that should be included in this service profile.

– Serial over LAN Policy—Name of the selected Serial over LAN policy.

– Stats Policy—The name of the threshold policy associated with service profiles created from 
this template.

– Status—A brief description of the overall status of the component.

– UUID—The UUID associated with this service profile.

– Vcon Profile Name—Name of the Vcon profile.

If you want to remove a property from the list of Profile properties to be modified, select it and click 
Remove.

For information on the profile properties, refer to the Cisco UCS Manager online help available at:

http://sjc-ucs-200.tidalsoft.local/ucsm/help/content/Centrale.Introduction.html

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Disassociate UCS VLAN from VNC Activity

Step 1 In the Process Editor Toolbox, choose Cisco UCS > Disassociate UCS VLAN from VNC, click the 
activity and drag it onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Disassociate VLAN tab to specify the criteria to be used to disassociate a UCS VLAN from a 
vNIC of a service profile.

• vNIC distinguished name—Click the Browse   button to specify the distinguished name for the vNIC 
from which to disassociate the VLAN. 
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Note The distinguished name should be in the format 
org-root/org-TEO_Test/ls-srvprofz1/ether-1-host-eth-2.

• VLAN name—Click the Browse button to specify the name of the VLAN to be disassociated from 
the vNIC. 

Note The VLAN name should be in the format 123.45.67-Test.

• Collect XML output—Check this check box if you want the raw XML output to display on the XML 
Output instance property page.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Modify UCS VLAN Settings Activity

Step 1 In the Process Editor Toolbox, choose Cisco UCS > Modify UCS VLAN Settings, click the activity and 
drag it onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the VLAN Settings tab to define the properties specific to the activity, including:

• Service profile distinguished name—Specify the distinguished name for the network card. The 
distinguished name should be in the format org-root/ls-C1B1/ether-eth1.

• Fabric Id—Choose the fabric interconnect associated with the component (A or B) from the 
drop-down list.

• Enable failover—Check this check box if you want the vNIC to be able to access the second fabric 
interconnect if the default fabric interconnect is unavailable.

• VLAN trunking—Check this check box if you want to use VLAN trunking. If this check box is 
checked, you can select more than one VLAN.

• VLANS—List of selected VLANs to be modified.

• Native VLAN—Indicates whether the selected VLAN is a native VLAN. Select the VLAN in the 
list and check this check box to indicate that it is a native VLAN.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Reset UCS Server Activity

Step 1 In the Process Editor Toolbox, choose Cisco UCS > Reset UCS Server, click the activity and drag it 
onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Server tab to define the properties specific to the activity, including:
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• Service profile distinguished name—Specify the distinguished name for the service profile that is 
associated with the server that is to be rebooted. The distinguished name should be in the format 
root/org-Sales/ls-ServiceProfiler1.

• Power cycle—Click this radio button if you want to reset the server by brute force power cycle.

• Gracefully restart OS—Click this radio button if you want to reset the server by gracefully restarting 
the operating system. If the Graceful OS Restart is not supported by the OS or it does not occur 
within a reasonable amount of time, the system will perform a power cycle.

• Wait for completion of outstanding UCS tasks on the server—Check this check box if you want the 
operation to wait until any outstanding tasks being performed on the server are completed before 
restarting the server.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining the Shutdown UCS Server Activity

Step 1 In the Process Editor Toolbox, choose Cisco UCS > Shutdown UCS Server, click the activity and drag 
it onto the Workflow pane.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Server tab to define the properties specific to the activity, including:

• Service profile distinguished name—Specify the distinguished name for the service profile that is 
associated with the server that is to be shut down. The distinguished name should be in the format 
root/org-Sales/ls-ServiceProfiler1.

• Gracefully shutdown OS—Use a graceful shutdown of the OS to shut down the server. A command 
is issued with soft-shut-down state.

• Hard shutdown in case of graceful shutdown failure—If a graceful shutdown of the OS fails, turn 
off the server using a hard shutdown. If this check box is not checked, the operating system will first 
be shut down completely, and then the server will be shut down.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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VMware vCloud Director Adapter
VMware® vCloud Director provides role-based access to a Web console that allows the members of an 
organization to interact with the organization's resources to create and work with vApps and virtual 
machines. Cisco Process Orchestrator VMware vCloud Director adapter allows you to retrieve data from 
vCloud data centers. 

The vCloud adapter supports vCloud Director 1.5. For users who are on vCloud Director 1.0, use the 
existing vCloud automation pack. 

The following table displays activities that are provided by the VMware vCloud adapter. For more 
information about using these activities, see Getting Started Using the VMware vCloud Director 
Adapter.

Getting Started Using the VMware vCloud Director Adapter
Use the following process to monitor and manage VMware vCloud instances. 

Step 1 Create a VMware vCloud user (see Defining a VMware vCloud User).

Step 2 Define a VMware vCloud target (see Defining a VMware vCloud Director Server Target).

Step 3 Define a VMware vCloud activity (see Automating VMware vCloud Command Activities, 
page 12-168). 

Step 4 View the activity results (see Filtering Views, page 8-7).

Viewing Adapter Properties
To view Target properties:

Step 1 On the Definitions > Targets view, highlight the target, and right-click and choose Properties.

The Properties dialog box displays. 

Step 2 Click the Settings tab to specify the maximum number of rows retrieved when querying the vCloud 
Director server

Step 3 Click OK.

Activity Comments

Execute vCloud 
Command

Sends an HTTP request against a VMware vCloud Director REST API 
based on a URL and HTTP headers data. 

See Defining an Execute vCloud Command Activity

Execute vCloud Query Specifies information about the vCloud queries that you want to find on 
the target.

See Defining an Execute vCloud Query Activity
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Defining a VMware vCloud User
Use the following instructions define the user credentials required to access a vCloud Director server. 
Use the vCloud User dialog box to specify the credentials for a runtime user record to be used for the 
configuration and execution of vCloud activities.

Step 1 Choose Definitions > Runtime Users, right-click and choose New > vCloud User.

Step 2 Click the General tab and enter the appropriate information, including:

• Display Name—Enter the display name for the vCloud user. If left blank, this field will populate 
with the information specified in the User name text field, but can be overwritten by the user.

• Owner—The owner of the object. This is typically the creator of the object.

• User name—The user name assigned to the user account

• Password—Check the check box and then enter the password to be assigned to the user account.

For existing runtime user records, check the check box to enter the new password assigned to the 
user account. 

• User type—Select the appropriate radio button to indicate what level in which to authenticate the 
user.

– System—System administrators create and provision organizations, while organization 
administrators manage organization users, groups, and catalogs. If the user type is designated 
as a System user, then the name will be appended with “@System” when used to authenticate 
with a vCloud server. 

– Organization—Users authenticate at the organization level, supplying credentials established 
by an organization administrator when the user was created or imported. If the user type is 
designated as organization, then the specified organization will be appended to the user name 
(for example, @Cisco”).

Step 3 Click OK to close the dialog box.

Defining a VMware vCloud Director Server Target
Use the VMware vCloud Director Server target to configure the connection information to a vCloud 
Directory server to be used for process and activities to run against. 

Step 1 Choose Definitions > Runtime Users, right-click and choose New > VMware vCloud Director Server.

Step 2 Click the General tab and enter the appropriate information.

Step 3 On the Connection panel, enter the appropriate target information to specify the connection information 
to the appropriate vCloud server, and click Next.

• vCloud Directory server name—Enter the host name or IP address or the public REST API address 
(as configured in vCloud Director) for the vCloud Director server target.

• Override URL—Enter the appropriate URL to use to override the base URL for execution. For 
example:

http://172.21.45.210

The format is:
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http://<servername>

• Ignore Secure Socket Layer(SSL) certificate error—Check this check box to indicate the target 
should ignore certificate errors when attempting to connect to the service portal. 

• Default runtime user—Select this radio button to specify the runtime user required to execute a 
process or activity against this target.

Step 4 Verify the information on the panel and click Finish to close the wizard.

Automating VMware vCloud Command Activities

Defining an Execute vCloud Command Activity

Use the Execute vCloud Command activity to send a HTTP request against a VMware vCloud Director 
REST API based on a URL and HTTP headers data. 

This activity supports generic HTTP operations, such as POST and GET, and is used to retrieve a web 
page and then examine the results to ensure there are no errors. 

Step 1 In the Process Editor Toolbox, choose VMware vCloud Director > Execute vCloud Command and 
drag and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Request tab and specify the appropriate information, including:

• Relative URL—Enter the URL to be requested. This URL can be a relative URL or absolute URL. 
For example:

– Relative URL:

admin

If API leads the relative URL (api/admin), then the activity will fail and cause a Resource not 
found error.

– Absolute URL:

https://172.25.4.131/api/admin/orgs

• Method—The method to be performed on the resource identified by the Request-URI. The method 
is case-sensitive. For a list of common header methods, see HTTP Header Methods.

• Content type—The value for the content type used to define the structure of the output. 

• Request—Enter any additional HTTP request details using XML format.

• When request creates a task, wait for its completion (in seconds)—Check the check box to indicate 
that when a task request using methods, PUT, POST, DELETE, the time period the activity should 
wait for the completion of the task before continuing. 

In the enabled text box, enter the time period the activity should wait for the task. Click the time unit 
link to change the time interval.

• Archive request upon successful completion—Check the check box to indicate whether to archive 
the data request after the successful completion of the activity. 

If the check box remains unchecked, the data generated by the activity is removed from the database 
upon successful completion of the activity. 
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• Restart activity if interrupted—Check this check box to indicate the activity should resume after an 
interruption in the execution. 

If the check box remains unchecked, then the activity remains paused if there is an interruption in 
the execution.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Defining an Execute vCloud Query Activity

Use the Execute vCloud Query activity to execute vCloud Director API queries against a vCloud 
Director Server. The query activity provides a flexible way to retrieve information from the vCloud 
Director Server and allows for more efficient access to the vCloud Director database. Additional key 
benefits include:

• Paginated results

• Filtering criteria

• Multiple output formats

• Typed and packaged queries

Step 1 In the Process Editor Toolbox, choose VMware vCloud Director > Execute vCloud Query, then drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the ExecuteQuery tab and enter the appropriate information, including:

• Relative Url—The URL against which the HTTP request is made. It can be relative or absolute. If 
it is relative, the “api” url for the target is prepended to the configured value. Relative URLs are more 
flexible because they are not tied to a particular environment

• Columns—The list of columns included in the results. If this field is blank, all columns are included. 
Naming columns explicitly has two key benefits:

– Scalability—The data is restricted to only what you need

– Convenience—The columns (their names) are identified to any following activities in the 
process

• Fetch all results—Indicates that all results will be fetched, even if they span multiple pages. If this 
field is not selected, only the page defined by the query will be returned.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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VMware vCenter, ESX, and ESXi Adapter
The Cisco Process Orchestrator VMware vSphere adapter connects a virtual infrastructure (VMware 
vCenter and ESX server) and automates the process of managing virtual machines and their hosts based 
on specific criteria. Using the VMware vSphere adapter, you can set up a HTTP/HTTPS connection to 
the ESX/ESXi Server and vCenter Server.

For the VMware vSphere adapter prerequisites, see the Cisco Process Orchestrator Compatibility 
Matrix.

Although the VMware vSphere Adapter software is already installed as part of a normal installation of 
Cisco Process Orchestrator, you should perform the configuration steps in this topic before attempting 
to execute any VMware objects in Process Orchestrator (see Configuring the VMware vSphere Adapter).

The following table displays the configuration activities provided by the VMware vSphere adapter. For 
more information about using these activities, see Getting Started Using the VMware vSphere Adapter.

Activity Description

Add Optical Drive To 
VM 

Add an optical drive to a specified virtual machine.

See Adding an Optical Drive to a Virtual Machine

Add Physical Adapter Add hosts and physical adapters to a vNetwork Distributed Switch at the vDS 
level after the vDS has been created.

See Adding a Physical Adapter to a vSphere Distributed Switch

Add VM Hard Disk Add a hard disk to a specified virtual machine

See Adding a Hard Disk to a Virtual Machine.

Add VM Network 
Adapter

Add a network adapter to a specified virtual machine.

See Adding a Network Adapter to a Virtual Machine

Clone VM Clone a specified virtual machine

See Cloning a Virtual Machine

Create Folder Create a new folder within the VMware infrastructure inventory

See Creating a Folder

Create New VM Create a new virtual machine

See Creating a New Virtual Machine

Customize Linux VM Customize the Linux operation system of a specified virtual machine

See Customizing the Linux OS of a Virtual Machine

Customize Windows 
VM

Customize a Windows operating system of a specified virtual machine

See Customizing the Windows OS of a Virtual Machine

Delete VM Remove a virtual machine from the inventory or deletes a virtual machine:

See Deleting a Virtual Machine

Enumerate Datastores Retrieves all datastores configured within the specified VMware 
infrastructure

See Retrieving the Datastores in a Virtual Machine

Enumerate Networks Retrieves all networks configured within the specified VMware infrastructure

See Retrieving the Networks in a Virtual Machine
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Getting Started Using the VMware vSphere Adapter
Use the following process to monitor and manage VMware vSphere adapter instances. 

Step 1 Create the VMware vSphere Adapter targets (see Managing VMware vSphere Targets).

Step 2 Define a VMware vSphere Adapter message triggers (see Managing VMware Triggers).

Step 3 Define a VMware vSphere Adapter command activity (see Automating VMware vSphere Activities). 

Step 4 View the activity results (see Filtering Views, page 8-7).

Enumerate Resource 
Pools

Retrieves all resource pools configured within the VMware infrastructure.

See Retrieving the Resource Pools in a Virtual Machine

Migrate VM Migrates a specified virtual machine from one server to another server

See Migrating a Virtual Machine

Query VM Devices Queries the list of devices on a specified virtual machine

See Querying the List of VM Devices on a Virtual Machine

Query VM Network 
Adapters

Queries information about network adapters configured for a specified virtual 
machine

See Querying the Network Adapters on a Virtual Machine

Query VM Properties Queries the properties of a specified virtual machine

See Querying the Properties of a Virtual Machine

Query VMs Queries the virtual machines on a given ESX server or vCenter server

See Querying the Virtual Machines on an ESX or vCenter Server

Reconfigure VM Reconfigures the memory, number of CPUs allocated, and other settings

See Reconfiguring the Virtual Machine on an ESX or vCenter Server

Relocate VM Relocates a specified virtual machine from one server to another server

See Relocating a Virtual Machine

Remove VM Removes a device from a specified virtual machine

See Removing a Virtual Machine from a vCenter Server

Update VM Hard Disk Updates configuration of a specified hard disk on a specified virtual machine.

See Updating a Hard Disk on a Virtual Machine

Update VM Network 
Adapter

Updates network adapter properties on a virtual machine

See Updating a Network Adapter on a Virtual Machine

Upgrade VM 
Hardware

 Upgrades the virtual machine's virtual hardware to the latest revision that is 
supported

See Upgrading the Hardware on a Virtual Machine

Upgrade VM Tools Upgrades the VMware Tools on a Windows virtual machine using the 
VMware Tools installer

See Upgrading the VM Tools on a Windows Virtual Machine
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Configuring the VMware vSphere Adapter

Configuring the ESX HTTPS Protocol

Configure the VMware vCenter and ESX Servers using the HTTPS protocol. The default configuration 
is HTTPS. If your environment is configured to use HTTP, these steps can be ignored.

Step 1 In My Computer, use the following file path to open the config.xml file.

/etc/vmware/host/config.xml

Step 2 Under the <proxyDatabase> tag, modify the /sdk namespace in the <http> and <https> sections to 
switch the redirect from HTTP to HTTPS.

Step 3 Save the configuration.

Step 4 To restart the service, enter:

service mgmt.vmware restart

Configuring the Keystore Password

The VMware vSphere Adapter requires security certificates for all target servers that use HTTPS 
protocol for connection. Use the Keystore tab to enter the password that protects the Java Keystore file 
used to keep SSL certificates for all configured VMware targets.

For new installations, this password can be set to a keytool password, which must be six characters or 
more. For installation upgrades, this password must be set to the password that is already used to protect 
the previously configured keystore file.

Step 1 Choose Administration > Adapters, highlight VMware vSphere Adapter, right-click and choose 
Properties.

Step 2 Click the Keystore tab > Keystore password, then enter the key file password that provides access to 
the file.

Step 3 Click OK to close the dialog box.

After the Keystore password is set, the VMware vSphere Adapter will automatically import the required 
certificates into a Java Keystore.

Configuring VMware vCenter HTTPS Protocol

The VMware vCenter and ESX Servers should be configured to use HTTPS protocol. The default 
configuration is HTTPS. If your environment is configured to use HTTP, these steps can be ignored.

Step 1 In My Computer, use the following file path to open the vpxd.cfg file.

C:\Documents and Settings\All Users\Application Data\VMware\VMware VirtualCenter

Step 2 Under the <proxyDatabase> tag, modify the /sdk namespace in the <http> and <https> sections to 
switch the redirect from HTTP to HTTPS.

Step 3 Save the configuration.
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Step 4 To restart the VirtualCenter service, choose Start > All Programs > Administration > Services.

Configuring IP Address Settings

Use the IP Address dialog box to configure the IP address settings for the network.

Step 1 Choose the Network tab, then click New.

Step 2 Select one of the following options:

• Use DHCP to obtain an IP address automatically—Use the DHCP server to obtain the IP address for 
the computer.

• Use an application configured on vCenter to generate the IP address—Enter the following 
information:

– The argument to the application that can generate the IP address automatically

• Use the following IP setting—Enter the following information:

– IP Address—IP address assigned to the network

– Subnet mask—The numeric mask used to determine the subnet that an IP address belongs to on 
the network

– Default gateway—Gateway in the network that a computer will use to access another network 
if a gateway is not specified for use

– Alternate gateway—Alternate gateway in the network that a computer will use to access another 
network if the default gateway is not available

Configuring Network Properties

Use the Network Properties dialog box to configure the IP address and DNS Server settings for the 
network.

Step 1 Choose the Network tab, then click New.

Step 2 In the IP Address section, select one of the following options:

• Use DHCP to obtain an IP address automatically—Use the DHCP server to obtain the IP address for 
the computer.

• Use the following IP setting—Enter the following information:

– IP Address—IP address assigned to the network

– Subnet mask—The numeric mask used to determine the subnet that an IP address belongs to on 
the network

– Default gateway—Gateway in the network that a computer will use to access another network 
if a gateway is not specified for use

– Alternate gateway—Alternate gateway in the network that a computer will use to access another 
network if the default gateway is not available

Step 3 In the DNS Server section, select one of the following options:
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• Use DHCP to obtain an IP address automatically—Use DHCP to obtain the IP address for the 
queried VM network.

• Select this radio button and then enter the appropriate information in the following text fields:

– Preferred DNS server—Preferred IP address of a DNS server

– Alternate DNS server—Alternate IP address of a DNS server that is used when the preferred IP 
address is not available

Selecting a Managed Object

Use the Select Managed Objects dialog box to retrieve the inventory path of an object residing on a 
specified VMware target.

To select an object from a defined target:

Step 1 To the right of the field on the VMware activity field, click Browse to launch the Select Managed Objects 
dialog box to query the appropriate managed object on a specified target.

Step 2 From the drop-down list, select the appropriate target from the drop down list to display the managed 
objects.

Step 3 To the left of a folder, click Expand (+) to view additional objects for selection.

Step 4 Select a valid object from the list, and click OK. The OK button remains disabled until a valid object is 
selected.

Managing VMware vSphere Targets
The VMware virtual infrastructure targets (such as a VMware vCenter or ESX server) represent a 
connection to a given VMware virtual infrastructure.

The following table provides a list of the targets that are associated with the adapter.

Defining a VMware vSphere Hypervisor Target

VMware ESX and VMware ESXi are "bare-metal" hypervisors, and are installed directly on top of the 
physical server and partitioned into multiple virtual machines that can run simultaneously, sharing the 
physical resources of the underlying server.

The ESX/ESXi Server and host have a one-to-one correspondence. Use the VMware vSphere Hypervisor 
target to specify the connection information to an ESX/ESXi server.

Target Description

VMware vSphere Hypervisor  Establishes connection to a standalone ESX server.

See Defining a VMware vSphere Hypervisor Target, page 12-174

VMware vCenter Server Establishes connection to vCenter server

See Defining a VMware vCenter Server Target, page 12-175
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Step 1 Choose Definitions > Targets, right-click and choose New > VMware vSphere Hypervisor, then enter 
the required information.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Connection tab and enter the appropriate information, including:

• ESX server name—Fully-qualified domain name (FQDN) or IP address of the ESX/ESXi server

The Power Up Host and Power Down Host activities can only be performed against the ESX/ESXi 
Server.

• ESX service port—Port number used to access the ESX/ESXi server (Default: 443)

Step 4 Click OK to close the dialog box and complete the procedure.

Defining a VMware vCenter Server Target

vCenter Server provides unified management of all the hosts and VMs in your datacenter from a single 
console with an aggregate performance monitoring of clusters, hosts and VMs.

Use the VMware vCenter Server target to specify the connection information to the VMware server.

Step 1 Choose Definitions > Targets, then right-click and choose New > VMware vCenter Server.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Connection tab and enter the appropriate information, including:

• vCenter server name—Fully-qualified domain name (FQDN) or IP address of the virtual server

• vCenter service port—Port number used to access the virtual server (Default: 443)

Step 4 Click OK to close the dialog box and complete the procedure.

Managing VMware Triggers
The following table provides a list of the triggers that are associated with the VMware vSphere Adapter. 
The triggers that are available depend on what adapters are installed.

Trigger Description

VMware Host Performance 
Event

Monitors the performance for a ESX host

See Defining a VMware Host Performance Event Trigger

VMware Virtual Machine 
Performance Event

Monitors the performance for a ESX virtual machine

See Defining a VMware Virtual Machine Performance Event Trigger

VMware Virtual Machine 
Power Event

Monitors the power state changes of a virtual machine

See “Defining a VMware Virtual Machine Power Event Trigger” 
section on page 12-177
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Defining a VMware Host Performance Event Trigger

Use the VMware Host Performance Event trigger to specify the performance criteria for the ESXi  server 
to be monitored and used to trigger an event that must be matched to trigger the process.

Step 1 On the Triggers tab, click New > VMware > VMware Host Performance Event.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Host Performance Event tab and enter the appropriate trigger information, including:

• ESX host—Inventory path to the performance monitored host server or host server where the 
monitored virtual machine resides. The information in this field is case-sensitive.

Wildcards can be used in this field. 

• Performance counter—Click Browse to launch the Performance Event dialog box to select the 
appropriate counter to monitor for the virtual machine.

For example, the counter with the name "usage" for the "cpu" group of performance counters is 
CPU_Usage.

• Statistic—The type of statistical values that are returned for the counter.

– Latest—Most recent value of the performance counter over the summarization period

– Minimum—Minimum value of the performance counter value over the summarization period

– Maximum—The maximum value of the performance counter value over the summarization 
period

– Average—The actual value collected or the average of all values collected during the summary 
period

• Comparison—Select the performance calculation operator to use for matching.

For information on the displayed operators, see Comparison Operators.

• Expression—Expression associated with the selected operator

• Unit—The unit for the values of the performance counter (such asKBps or MHz)

• Sample size—Enter the number of samples to be returned by the trigger

• Interval (in seconds)—Enter the interval, in seconds, for the performance statistics

Step 4 Enter the information in the remaining tabs as necessary, then click OK.

Defining a VMware Virtual Machine Performance Event Trigger

Use the VMware Virtual Machine Performance Event trigger to specify the performance counter criteria 
for the virtual machine of the ESXi server to be monitored and used to trigger an event that must be 
matched to trigger the process.

Step 1 On the Triggers tab, click New > VMware > VMware Virtual Machine Performance Event.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the VMware Virtual Machine Performance Event  tab to enter the appropriate trigger 
information, including wildcard expressions.
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• Virtual Machine—Inventory path to the virtual machine to be monitored for the event. The 
information in this field is case-sensitive.

Wildcards can be used in this field. .

For information about other fields in this tab, see Defining a VMware Host Performance Event Trigger

Step 4 Enter the information in the remaining tabs as necessary, then click OK.

Defining a VMware Virtual Machine Power Event Trigger

Use the VMware Virtual Machine Power Event trigger to specify the criteria for the vCenter to monitor 
the power state of a virtual machine changes to that specified in the event.

Step 1 On the Triggers tab, click New > VMware > VMware Virtual Machine Power Event.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the VMware Virtual Machine Power Event  tab to enter the appropriate trigger information, 
including:

• Power state—Select the power state that will trigger the event:

– Powered On—When the virtual machine and the guest operating system that automatically 
starts up on system boot is Powers up.

– Tools Running—Triggered when the VMware tools state is running.

– Powered Off—Powers down the virtual machine. The virtual machine does not attempt to 
gracefully shut down the guest operating system.

– Suspended—Pauses the virtual machine activity. All transactions are frozen until the Resume 
command is executed.

– Any State Change—Process is triggered when power changes to any state.

• Check trigger connect—Check this check box to trigger the condition is detected upon connection 
to the VMware infrastructure server.

If the Power State is Powered On, the event based upon connection to the VMware infrastructure 
server.

For information about other fields in this tab, see Defining a VMware Host Performance Event Trigger

Step 4 Enter the information in the remaining tabs as necessary, then click OK.

Selecting Performance Counters to Monitor

When configuring a VMware performance event trigger, you must select performance counters to 
monitor the trigger. Click Browse on the VMware performance event triggers to specify the performance 
counters for the trigger.

Step 1 Choose the Performance Event tab, then to the right of the Performance Counter field, click Browse.

Step 2 From Use the following VMware vCenter or ESXi server, select the appropriate server.

To create a new VMware target containing the appropriate counters, click New [Target].
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Step 3 Highlight the appropriate performance counter, and click OK to select the performance counter to 
display in the Performance Counter field on the trigger.

Automating VMware vSphere Activities

Adding an Optical Drive to a Virtual Machine

Use the Add Optical Drive to a VM activity to add an optical drive to a specified virtual machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Add Optical Drive to VM, then drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Optical Drive tab and specify the inventory path to the virtual machine. The information in 
this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Adding a Physical Adapter to a vSphere Distributed Switch

You can add hosts and physical adapters to a vNetwork Distributed Switch at the vDS level after the vDS 
is created.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Adding a Physical Adapter to a vSphere 
Distributed Switch, then drag and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Add Physical Adapter tab and enter the inventory path to the physical adapter and to the host 
(for example, TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02). The information in this field is 
case-sensitive.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Adding a Hard Disk to a Virtual Machine

Use the Add VM Hard Disk activity to add a hard disk to a specified virtual machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Add VM Hard Disk, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.
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Step 3 Click the Hard Disk Settings tab and enter the inventory path to the virtual machine. The information 
in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Choose the appropriate type of virtual hard disk to be added and enter the appropriate information:

• To create a new virtual disk from original settings, choose Type > Create a new virtual disk and 
specify the following properties:

– Provisioned Size—Enter the size of the new virtual disk. From the Unit drop-down list, select 
the appropriate unit size for the disk.

- MB—Megabyte (1024 KB)

- GB—Gigabyte (1024 MB)

- TB—Terabyte (1024 GB)

– Disk Provisioning—Indicates that the disk space should be provisioned and how the resources 
should be allocated or supported.

- Allocate and commit space on demand (Thin provisioning)—Indicates that a certain amount 
of storage space on a datastore should be allocated to the virtual disk files

- Supporting clustering features such as Fault Tolerance— Indicates the virtual disk can support 
a cluster of hosts in the virtual environment.

• To add an existing virtual disk file, choose Type > Use an a existing virtual disk and specify the 
following properties:

– Disk file path—Enter the virtual disk datastore path to the existing disk file.

– Virtual device node—Enter the device node of the cluster.

• To create a file that points the data to the raw LUN, choose Type > Raw Device Mappings and 
specify the following properties:

– Target LUN—Enter the inventory path to the target LUN mapping file.

– Location—Select the appropriate location for the hard disk.

– Compatibility—Select the appropriate virtual disk compatibility mode.

- Physical—Allows the guest operating system to access the hardware directly. Physical 
compatibility is useful if you are using SANaware applications in the virtual machine. LUNs 
attached to powered-on virtual machines and configured for physical compatibility cannot be 
migrated if the migration involves copying the disk. Such LUNs cannot be cloned or cloned to 
a template. You can migrate the mapping file.

- Virtual—Allows the virtual machine to use VMware snapshots and other advanced functions. 
Virtual compatibility allows the LUN to behave as if it were a virtual disk, so that you can use 
features like disk modes. When you clone the disk or make a template out of it, the contents of 
the LUN are copied into a .vmdk virtual disk file. When you migrate a virtual compatibility 
mode RDM, you can migrate the mapping file or copy the contents of the LUN into a virtual 
disk.

– Virtual device node—Enter the device node of the cluster.

• For all virtual hard disks, specify the following information:

– Mode:

- Independent_nonpersistent—The disk appears to operate normally, but whenever the virtual 
machine is powered off or reverted to a snapshot, the contents of the disk return to their original 
state. All later changes are discarded.
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- independent_persistent—The disk operates normally except that changes to the disk are 
permanent even if the virtual machine is reverted to a snapshot.

- persistent—All disk writes issued by software running inside a virtual machine are 
immediately and permanently written to a virtual disk that is configured as an independent disk.

– Time out if not completed within—Check the check box and enter the time period the activity 
should wait for completion before failing. Click the time unit link to change the time interval

Step 5 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Adding a Network Adapter to a Virtual Machine

Use the Add VM Network Adapter activity to add a network adapter to a specified virtual machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Add VM Network Adapter, then drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Network Adapter Settings tab and specify the following properties:

• Virtual machine—Enter the inventory path to the virtual machine. The information in this field is 
case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Adapter type—select the appropriate network adapter type.

– E1000—Emulates the functioning of an E1000 network card. It is the default adapter type for 
virtual machines that run 64-bit guest operating systems.

– Flexible—Supported on virtual machines that were created on ESX Server 3.0 or greater and 
that run 32-bit guest operating systems.

– Vlance—An emulated version of the AMD 79C970 PCnet32- LANCE NIC, an older 10Mbps 
NIC with drivers available in most 32-bit guest operating systems except Windows Vista and 
later.

– VMXNET—This virtual network adapter has no physical counterpart and is optimized for 
performance in a virtual machine. Because operating system vendors do not provide built-in 
drivers for this card, VMware Tools must be installed to have a driver for the VMXNET network 
adapter available.

– VMXNET 2—The VMXNET 2 adapter is based on the VMXNET adapter but provides some 
high-performance features commonly used on modern networks, such as jumbo frames and 
hardware offloads. This virtual network adapter is available only for some guest operating 
systems on ESX/ESXi 3.5 and later. VMXNET 2 is supported only for a limited set of guest 
operating systems

– VMXNET 3—The VMXNET 3 adapter offers all the features available in VMXNET 2, and 
adds several new features like multiqueue support, IPv6 offloads, and MSI/MSI-X interrupt 
delivery. VMXNET 3 is supported only for virtual machines version 7 and later, with a limited 
set of guest operating systems

• Network—Enter the inventory path of the virtual network to use for this adapter.

• Connect on power on—Check this check box to indicate that the host should be connected when it 
was started.
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• Time out if not completed within—Check the check box and enter the time period the activity should 
wait for completion before failing.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Cloning a Virtual Machine

Use the Clone VM activity to clone a virtual machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Clone VM, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Clone Virtual Machine tab to specify the appropriate information, including:

• Virtual machine—Enter the inventory path to the virtual machine. The information in this field is 
case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Computer name—Name address of the Linux computer

• Domain—Fully-qualified domain name for Linux computer

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Creating a Folder

Use the Create Folder activity to create a new folder within the VMware infrastructure inventory so that 
objects can be created or moved into the new folder.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Create Folder, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Folder tab and enter the appropriate information, including:

• Parent folder—Inventory path to the parent folder in the VMware infrastructure. The information in 
this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• New folder name—Enter the name of the new folder to be created on the virtual machine.

• Folder type—select the appropriate type of folder.

– Hosts and Clusters—Identifies a folder containing clusters and hosts

– Virtual Machines and Templates—Identifies a virtual machine folder. A virtual machine folder 
may contain child virtual machine folders. It also can contain VirtualMachine managed objects, 
templates, and VirtualApp managed objects
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– Datastores—Identifies a datastore folder. Datastore folders can contain child datastore folders 
and Datastore managed objects. A collection of references to the subset of datastore objects in 
the datacenter that is used by this virtual machine

– Networking—Identifies a network entity folder. Network entity folders can contain Network, 
DistributedVirtualSwitch, and DistributedVirtualPort managed objects.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Creating a New Virtual Machine

Use the Create New VM activity to create a new virtual machine on a specified vCenter server or ESX 
host.

Step 1 In the Process Editor Toolbox, choose VMware vSphere Adapter > Create New VM, then drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Settings tab and enter the appropriate information, including:

• Virtual machine—Inventory path to the virtual machine to be created. The information in this field 
is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Inventory location—Inventory file path to the virtual machine folder

• Host—Inventory path of the host on which the new virtual machine will run. The information in this 
field is case-sensitive.

• Resource pool—Inventory path of the target resource pool for the virtual machine. The information 
in this field is case-sensitive.

If the default  resource pool for the server is used, the virtual machine’s current pool is used as the 
target pool.

• Datastore—Inventory path to the storage location for the virtual machine files, such as a physical 
disk, a RAID, or a SAN.

• Guest operating system—The appropriate operating system on which the virtual machine will run.

• Virtual disk size (GB)—Disk space allocated for the virtual disk.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Customizing the Linux OS of a Virtual Machine

Use the Customize Linux VM activity to customize the Linux operation system of a specified virtual 
machine.
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Before You Begin

The Customize Linux VM activity has several activity-specific tabs included with the default Process 
Orchestrator activity configuration tabs. Please ensure that all tabs are configured properly before 
attempting to execute the process.

Step 1 In the Process Editor Toolbox, choose VMware vSphere >Customize Linux VM, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Computer Name tab and enter the appropriate information, including:

• Virtual machine—Inventory path to the virtual machine to be created. The information in this field 
is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Inventory location—Inventory file path to the virtual machine folder

• Host—Inventory path of the host on which the new virtual machine will run. The information in this 
field is case-sensitive.

• Resource pool—Inventory path of the target resource pool for the virtual machine. The information 
in this field is case-sensitive.

If the default  resource pool for the server is used, the virtual machine’s current pool is used as the 
target pool.

• Datastore—Inventory path to the storage location for the virtual machine files, such as a physical 
disk, a RAID, or a SAN.

• Guest operating system—The appropriate operating system on which the virtual machine will run.

• Virtual disk size (GB)—Disk space allocated for the virtual disk.

Step 4 Click the Network tab to specify the type of network settings to apply to the guest operating system:

• Typical settings—Allow the vCenter Server to configure all network interfaces from a DHCP server.

• Custom settings—Enable manual configuration of the network interface settings.

Step 5 Click the DNS and Domain tab to configure the domain name server properties for the specified Linux 
virtual machine:

• Primary DNS—The primary name server computer for where the record of the domain name is 
stored.

• Secondary DNS—The name server computer that will be used if the primary DNS server is not 
available.

• Tertiary DNS—The name server to manage the DNS independently from the domain registrar.

• DNS search path—The domain name(s) to try when trying to translate a machine name into an IP 
address. Click Add after each domain name to add to the list in the Domain Name column.

Step 6 Click the Time Zone tab to configure the time zone for the network for the specified Linux virtual 
machine.

Step 7 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
12-183
Cisco Process Orchestrator 3.3 User Guide

 



 

Appendix 12      Using Adapters
  VMware vCenter, ESX, and ESXi Adapter
Customizing the Windows OS of a Virtual Machine

Use the Customize Windows VM activity to customize a Windows operating system of a specified 
virtual machine.

According to VMware's KB 1005593 article, Sysprep file locations and versions, users must install 
Microsoft Sysprep files on the vCenter server before customizing certain versions of Windows.

Before You Begin

The Customize Windows VM activity has several activity-specific tabs included with the default Process 
Orchestrator activity configuration tabs. Please ensure that all tabs are configured properly before 
attempting to execute the process.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Customize Windows VM, then drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Computer Name tab and enter the appropriate information, including:

• Virtual machine—The inventory path to the virtual machine. The information in this field is 
case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Computer name—The full computer name.

• Enter the registration information:

– Name—Name of the owner to whom this OS should be registered

– Organization—Organization to which this OS should be registered

• Enter the password information, including the new password that VMware will use to set the 
Administrator's password.

• Enter the time zone information.

Step 4 Click the Domain tab and enter the appropriate information, including:

Note For security reasons, you might want to choose a runtime user with the appropriate credentials 
rather than entering a password.

• Add computer to a workgroup—Select this radio button and in the text field, enter the workgroup 
name.

• Add computer to a windows domain—Select this radio button and in the text field, enter the full 
domain name. Select the appropriate radio button to determine the credentials for the user account 
used to join computer to the domain.

• Use credentials of the following runtime user—Select the appropriate runtime user account. Select 
the default runtime user from the drop-down list.

Step 5 Click the License tab to enter the product key and pertinent licensing information for the Windows 
operating system for the specified virtual machine:

• Product Key—Enter the product key for the Windows operating system.

• Include Server License Information (Required for customizing a server guest OS)—Check this 
check box to indicate server information is required and to enable the server license mode fields and 
select the appropriate license mode.
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• Server License Mode—Select the appropriate software license mode for the Windows server.

– Per seat—Software license mode based on the number of individual users who have access to 
the software

– Per server—Software license mode based on the number of connections using the Windows 
server

When choosing Per server, enter the number of maximum number of connections allowed to the 
Windows server in the Maximum Connections field

Step 6 Click the Run Once tab to enter the commands to run in the specified virtual machine at the end of the 
customization process:.

Step 7 Click the Network tab to use the typical settings, which allow the vCenter Server to configure all 
network interfaces from a DHCP server, or to enable manual configuration of the network interface 
settings.

Step 8 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Deleting a Virtual Machine

Use the Delete VM activity to:

• Remove from inventory (VM can be restored)—This option removes the virtual machine from the 
inventory but leaves all files and snapshots and allows the VM to be restored.

• Permanently delete all VM files (including snapshot)—This option deletes all VM files including 
any snapshots, and the virtual machine cannot be restored.

Retrieving the Datastores in a Virtual Machine

Use the Enumerate Datastores activity to retrieve all datastores configured within the specified VMware 
infrastructure.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Enumerate Datastores, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Datacenter tab and enter the appropriate information, including the inventory path to the 
datacenter name containing the datastores. The information in this field is case-sensitive.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Retrieving the Networks in a Virtual Machine

Use the Enumerate Networks activity to retrieve all networks configured within the specified VMware 
infrastructure.
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Step 1 In the Process Editor Toolbox, choose VMware vSphere > Enumerate Networks, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Datacenter tab and enter the appropriate information, including the inventory path to the 
datacenter name containing the datastores. The information in this field is case-sensitive.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Retrieving the Resource Pools in a Virtual Machine

Use the Enumerate Resource Pools activity to retrieve all resource pools configured within the VMware 
infrastructure.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Enumerate Resource Pools, then drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Datacenter tab and enter the appropriate information, including the inventory path to the 
datacenter name containing the datastores. The information in this field is case-sensitive.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Finding the Managed Object Reference

Use the Find Managed Object Reference activity to identify an object within the VMware infrastructure 
inventory.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Find Managed Object Reference, then drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Find Managed Object Reference tab and enter the appropriate information, including:

• Parent—Inventory path to the parent folder in the VMware infrastructure. The information in this 
field is case-sensitive. 

• Search folder name—Enter the name of the folder to be identified on the virtual machine.

• Folder Type—select the appropriate type of folder.

– Hosts and Clusters—Identifies a folder containing clusters and hosts

– Virtual Machines and Templates—Identifies a virtual machine folder. A virtual machine folder 
may contain child virtual machine folders. It also can contain VirtualMachine managed objects, 
templates, and VirtualApp managed objects

– Datastores—Identifies a datastore folder. Datastore folders can contain child datastore folders 
and Datastore managed objects. A collection of references to the subset of datastore objects in 
the datacenter that is used by this virtual machine
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– Networking—Identifies a network entity folder. Network entity folders can contain Network, 
DistributedVirtualSwitch, and DistributedVirtualPort managed objects.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Migrating a Virtual Machine

Use the Migrate VM activity to migrate a specified virtual machine from one server to a specific resource 
pool or host.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Migrate VM, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Migrate tab and enter the appropriate information, including:

• Virtual machine—Inventory path to the virtual machine targeted for migration. The information in 
this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Target host—Inventory path to the host server to migrate the virtual machine. The information in 
this field is case-sensitive.

• Target resource pool—Inventory path of the target resource pool for the virtual machine. The 
information in this field is case-sensitive.

• Priority—Select a priority for the migration to ensure that sufficient CPU resources are available on 
both the source and target hosts to perform the migration:

– Default—Default priority for the operations

– High—Reserve resources on both the source and destination hosts to maintain virtual machine 
availability during the migration. High priority operations will not proceed if the resources are 
unavailable.

– Low—Low priority operations will always proceed, but the virtual machine may become briefly 
unavailable if sufficient host resources are unavailable.

• Power state—Select the option to migrate the virtual machine only if it matches the specified power 
state:

– Powered On—Virtual machine and the guest operating system that automatically starts up on 
system boot is Powers up.

– Powered Off—Virtual machine is Powered down

– Suspended—All activities on the virtual machine are paused

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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Querying the List of VM Devices on a Virtual Machine

Use the Query VM Devices activity to query the list of virtual machine devices on a given virtual 
machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Query VM Devices, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Virtual Machine tab and enter the appropriate information, including the inventory path to the 
virtual machine to be queried. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Querying the Network Adapters on a Virtual Machine

Use the Query VM Network Adapters activity to query information about network adapters configured 
for a specified virtual machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Query VM Network Adapters, then drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Query VM Network Adapters tab and enter the appropriate information, including the 
inventory path to the virtual machine to be queried. The information in this field is case-sensitive. For 
example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Querying the Properties of a Virtual Machine

Use the Query VM Properties activity to query the properties of a specified virtual machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere> Query VM Properties, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Query VM Properties tab and enter the appropriate information, including the inventory path 
to the virtual machine to be queried. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
12-188
Cisco Process Orchestrator 3.3 User Guide



 

Appendix 12      Using Adapters
  VMware vCenter, ESX, and ESXi Adapter
Querying the Virtual Machines on an ESX or vCenter Server

Use the Query VMs activity to query the list of virtual machines on a given ESX server or vCenter server.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Query VMs, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Query VMs tab and enter the appropriate information, including:

• Virtual machine—The name of the virtual machine. Wildcards can be used in this field. 

• Host—The name of the ESX host server to be queried

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Reconfiguring the Virtual Machine on an ESX or vCenter Server

Use the Reconfigure VM activity to modify the memory and number of CPUs allocated to the virtual 
machine on a given ESX server or vCenter server.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Reconfigure VMs, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Reconfigure VMs tab enter the appropriate information, including:

• Virtual machine—Inventory path to the virtual machine to be reconfigured. The information in this 
field is case-sensitive.  For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Memory (MB)—Size of the virtual machine’s memory in MB. This field can remain blank if the 
activity should leave the memory size unchanged.

• Number of CPUs—The number of virtual processors to allocate to the virtual machine. This field 
can remain blank if the activity should leave the number of CPUs unchanged.

• Config File (.vmx)—File path to the configuration file for the virtual machine (.vmx file). This also 
implicitly defines the configuration directory

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Relocating a Virtual Machine

Use the Relocate VM activity to relocate a specified virtual machine from one server to another server.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Relocate VM, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.
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Step 3 Click the Relocate VM tab and enter the required information, including:

• Virtual machine—Inventory path to the virtual machine to be relocated. The information in this field 
is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Host—Inventory path to the target server where the virtual machine is to be relocated. The 
information in this field is case-sensitive.

• Resource pool—Inventory path of the target resource pool for the virtual machine. The information 
in this field is case-sensitive.

• Datastore—Inventory path to the storage device attached to the host to be used as the main disk 
storage for the virtual machine you are relocating. The information in this field is case-sensitive.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Removing a Virtual Machine from a vCenter Server

Use the Remove VM Device activity to remove a virtual device from a specified vCenter server.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Remove VM Device, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Remove VM Device tab and enter the required information, including:

• Virtual machine—Inventory path to the virtual machine to be relocated. The information in this field 
is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Device name—The name of the device to be removed from the virtual machine (for example, Hard 
disk 22).

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Mounting an ISO Image

The Mount ISO Image activity allows an ISO image already on the VMware server datastore to be 
mounted to an existing optical drive device of a VM.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Mount ISO Image, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the ISO Image tab and enter the inventory path to the image and host server. The information in 
this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Removing a Folder

Use the Remove folder activity to remove a folder from a VMware infrastructure. 

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Remove a Folder, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Remove Folder tab and enter the inventory path to the parent folder in the VMware 
infrastructure. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Unmounting an ISO Image

Use the Unmount ISO Image activity to unmount an ISO image from an existing optical drive of a VM.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Unmount ISO Image, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Virtual Machine tab and enter the inventory path to the image and host server. The information 
in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Updating a Hard Disk on a Virtual Machine

Use the Update VM Hard Disk activity to update configuration of a specified hard disk on a specified 
virtual machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Update VM Hard Disk, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Update VM Hard Disk tab and enter the required information, including:

• Virtual machine—The inventory path to the virtual machine of the hard disk that should be updated. 
The information in this field is case-sensitive. For example:
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TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Hard disk name—Enter the name of the hard disk to be updated.

• Provisioned Size—The size of the new virtual disk.

• Virtual device node—The device node of the cluster.

• Mode—The mode for the property of a virtual disk.

– do not change current settings—Indicates that the current settings of the hard disk are not 
changed

– append—Changes are stored in a temporary .REDO file. If a system administrator deletes the 
redo-log file, the virtual machine returns to the state it was in the last time it was used in 
persistent mode.

– independent_nonpersistent—The disk appears to operate normally, but whenever the virtual 
machine is powered off or reverted to a snapshot, the contents of the disk return to their original 
state. All later changes are discarded.

– independent_persistent—The disk operates normally except that changes to the disk are 
permanent even if the virtual machine is reverted to a snapshot.

– nonpersistent—All disk writes issued by software running inside a virtual machine appear to be 
written to the independent disk. In fact, they are discarded after the virtual machine is powered 
off. As a result, a virtual disk or physical disk in independent-nonpersistent mode is not 
modified by activity in the virtual machine.

– persistent—All disk writes issued by software running inside a virtual machine are immediately 
and permanently written to a virtual disk that is configured as an independent disk.

– undoable—The file that stores changes made to a disk in all modes except the persistent and 
independent-persistent modes. For a disk in nonpersistent mode, the redo-log file is deleted 
when you power off or reset the virtual machine without writing any changes to the disk. You 
can permanently apply the changes saved in the redo-log file to a disk in undoable mode so that 
they become part of the main disk files.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Updating a Network Adapter on a Virtual Machine

Use the Update VM Network Adapter activity to modify the configuration of a specified network adapter 
on a specified virtual machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Update VM Network Adapter, then drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Network Adapter Settings tab and enter the required information, including:

• Virtual machine—The inventory path to the virtual machine containing the network adapter to be 
updated. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Name—The display name of the network adapter.
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• Connected—Select the option to determine whether to modify connection state of the network 
adapter.

• Connect on Power On—Select the appropriate option to indicate whether the host should be 
connected when it was started.

• MAC Address Type—Select the appropriate option to indicate how the MAC Address was assigned 
to the network adapter.

• MAC Address—Modify the MAC Address assigned to the network adapter in the virtual machine.

• Network—Modify the name or IP address of the virtual network in the VMware environment.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Upgrading the Hardware on a Virtual Machine

Use the Upgrade VM Hardware activity to upgrade the virtual machine’s virtual hardware to the latest 
revision that is supported by the virtual machine’s current host.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Upgrade VM Hardware, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Virtual Hardware tab and enter the required information, including:

• Virtual machine—The inventory path to the virtual machine containing the hardware to be upgraded. 
The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Version—Enter the appropriate version to specify which version to upgrade the virtual hardware. 
For example, vmx-04 or vmx-07. The versions supported will depend on the VMware infrastructure.

If the version is not specified, the virtual hardware is upgraded to the most current virtual hardware 
supported on the host.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Upgrading the VM Tools on a Windows Virtual Machine

Use the Upgrade VM Tools activity to upgrade the VMware tools on a Windows virtual machine using 
the VMware Tools installer.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Upgrade VM Tools, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Upgrade Tools tab and enter the required information, including:

• Virtual machine—The inventory path to the virtual machine on which to install or upgrade the 
VMware tools. The information in this field is case-sensitive. For example:
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TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Options—Enter the command line options to pass to the installer to modify the installation 
procedure for tools. For example, this is the basic command line syntax:

vmrun <host authentication flags> <guest authentication flags> <command> <parameters>

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Retrieving Resource Pools

Use the Resource Pools activity to retrieve all resource pools configured within the VMware 
infrastructure.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Resource Pools, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the Resource Pool tab and specify the following properties:

• Parent—Name of the direct parent resource pool

• Resource pool name—Name of the new resource pool

• Time out if not completed within—The time period the activity should wait for completion before 
failing

Step 3 Click the CPU Resources tab and specify the following properties:

• CPU Shares—Resource allocation for CPU

• CPU Reservation (Mhz)—Amount of CPU resources that are guaranteed available to the resource 
pool (in Mhz)

• CPU Expandable Reservation—The amount of resources the CPU reservation can expand in a 
resource pool beyond the specified value if the resource pool has unreserved resources

• CPU Limit (Mhz)—Determines the limit on the CPU Mhz the resource pool cannot exceed 
regardless of available of resources

Step 4 Click the Memory Resources tab and specify the following properties:

• Memory Shares Level—The memory allocation level for the resource pool (Custom, Low, Normal, 
High)

• Memory Shares—Resource allocation for memory

• Memory Reservation (MB)—Amount of memory that is guaranteed available to the resource pool 
(in MB)

• Memory Expandable Reservation—The amount of memory the reservation can expand in a resource 
pool beyond the specified value if the resource pool has unreserved resources

• Memory Limit (MB)—Determines the limit on the amount of memory the resource pool cannot 
exceed regardless of available of resources

Step 5 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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Managing VMware vSphere Host Activities
The following table displays the activities used to perform basic management of the host using a VI 
connection.

Activity Description

Add Host Adds a new ESX/ESXi to a VMware environment

See Adding a New Host, page 12-196

Add Host Port Group Create a new network port group for a specified ESX server.

See Adding a New Host Port Group, page 12-196

Enter VM Host 
Maintenance Mode

Moves a host server offline so that maintenance can be performed

See Moving a VM Host Server to Maintenance Mode, page 12-197.

Exit VM Host 
Maintenance Mode

Brings a host server back online after maintenance has been performed

See Moving a VM Host Server from Maintenance Mode to Online, 
page 12-198

Power Down Host to 
Standby

Powers down the host to standby mode, a state from which the host can be 
powered up remotely

See Powering Down an ESX Host Server to Standby State, page 12-198

Power Up Host from 
Standby

Powers up the host out of standby mode

See Powering Up a Host Server from Standby State, page 12-199

Query Host Properties Queries the properties of a specified ESX/ESXi host

See Querying the Properties of a Host Server, page 12-199

Query Hosts Retrieves the hosts within a VMware infrastructure

See Querying the List of Hosts, page 12-200

Query Host Network 
Adapter

Enumerates the network adapters configured on a specified ESX server

See Querying the Network Adapters on an ESX Server, page 12-199

Query Host Storage 
Adapters

Retrieves information about storage adapters configured for a specified 
host

See Querying the Storage Adapters for a Host Server, page 12-200

Reboot VM Host Restart an ESX host

See Rebooting a VM Host Server, page 12-200

Remove Adapter from 
vSphere Distributed 
Switch

Removes an adapter from a vSphere Distributed Switch

See Removing a Host from a vSphere Distributed Switch, page 12-201

Remove ESX Host Removes a host from the VMware infrastructure

See Removing an ESX Host, page 12-201

Shut Down Host Powers off a host server

See Shutting Down a Host, page 12-202

Update Host Port Group Modifies VLAN ID of the specified port group.

See Updating a Host Port Group, page 12-202
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Adding a New Host

Use the Add Host activity to add a new host to the VMware infrastructure. There are two types of hosts 
that can be added to the VMware infrastructure: standalone hosts, which can be added to any data center 
or folder, and hosts that are intended to be part of a VMware cluster. This activity may not be able to add 
hosts if the hosts contains invalid SSL certificates.

While this activity is running and when the host is in maintenance mode, no virtual machines can be 
powered on and no provisioning operations can be performed on the host.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Add Host, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Add Host tab and enter the required information, including:

• Location—The inventory path to the location in the VMware infrastructure where the host server is 
to be added. This could be a folder, data center, other cluster. The information in this field is 
case-sensitive.

• The connection settings

• The SSL certificate settings

• Connect after adding—Check the check box to indicate that the newly added host should be 
connected after being added to VMware. 

If the check box remains unchecked, the host will remain disconnected after being added.

Step 4 Click the Advanced tab and enter the required information, including:

• Resource pool—Name of the resource pool for the root resource pool from the host.

• Inventory location for virtual machines—Enter the inventory path in which to store the existing 
virtual machines on the host.

• Add even if connected to another virtual center—Check this check box to add host even if it is 
already being managed by another virtual center server. The host connection to the original virtual 
center is severed.

If the check box is unchecked, the host cannot be added to the new virtual center server.

Step 5 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Adding a New Host Port Group

Use the Add Host Port Group activity to create a new network port group for a specified ESX server.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Add Host Port Group, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Port Group tab and enter the required information, including:

• Host—The inventory path of the host. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02
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• Port group—The name of the port group to add.

• VLAN ID—The integer number that corresponds to the VLAN ID. The valid values are integers 
between 0 and 4095.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Adding a Host to a vSphere Distributed Switch

You can add hosts and physical adapters to a vNetwork Distributed Switch at the vDS level after the vDS 
is created.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Adding a Host to a Vsphere Distributed 
Switch, then drag and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Host and DV Switches tab and enter the inventory path of the host. The information in this 
field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Moving a VM Host Server to Maintenance Mode

Use the Enter VM Host Maintenance Mode activity to move a host server offline so that maintenance 
can be performed.

While this activity is running and when the host is in maintenance mode, no virtual machines can be 
powered on and no provisioning operations can be performed on the host.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Enter VM Host Maintenance Mode, then 
drag and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Enter Maintenance tab and enter the appropriate information, including:

• Host—The inventory path of the host. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Skip if already in expected power state—Check this check box to complete the activity normally if 
the power state is in maintenance mode.

If the check box is not checked and the ESX host is already in entering maintenance mode, the 
activity will complete with an error message stating the operation is not allowed in the current state 
or could not connect the host.

• Evacuate guests—Check this check box to migrate all virtual machines currently associated with the 
host server to other available hosts in the computer resource pool before entering maintenance mode.
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Moving a VM Host Server from Maintenance Mode to Online

Use the Exit VM Host Maintenance Mode activity to bring a host server back online after the 
maintenance on the server has been completed. Using this activity, blocks any concurrent running 
maintenance-only host configurations operations are being performed (for example, when VMFS 
(Virtual Machine File System) volumes are being upgraded).

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Exit VM Host Maintenance Mode, then 
drag and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Exit Maintenance tab and enter the appropriate information, including:

• Host—The inventory path of the host. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Skip if already in expected power state—Check this check box to complete the activity normally if 
the power state is exiting maintenance mode.

If the check box is not checked and the ESX host is already exiting maintenance mode, the activity 
will complete with an error message stating the operation is not allowed in the current state or could 
not connect the host.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Powering Down an ESX Host Server to Standby State

Use the Power Down Host to Standby activity to power down an ESX host server to standby state.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Power Down Host to Standby, then drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Power Down tab and enter the appropriate information, including:

• Host—The inventory path of the host. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Skip if already in expected power state—Check this check box to complete the activity normally if 
the power state is powered down to standby state.

If the check box is not checked and the ESX host is already in a standby state, the activity will 
complete with an error message stating the operation is not allowed in the current state or could not 
connect the host.

• Evacuate guests—Check this check box to migrate all virtual machines currently associated with the 
host server to other available hosts in the computer resource pool before powering down to a standby 
state.
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Powering Up a Host Server from Standby State

Use the Power Up Host from Standby activity to power up an ESX host server from standby state.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Power Up Host from Standby, then drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Power Up tab and enter the appropriate information, including:

• Host—The inventory path of the host. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Skip if already in expected power state—Check this check box to complete the activity normally if 
the power state is Powered Up.

If the check box is not checked and the ESX host is already powered up, the activity will complete 
with an error message stating the operation is not allowed in the current state or could not connect 
the host

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Querying the Network Adapters on an ESX Server

Use the Query Host Network Adapters activity to enumerate the network adapters configured on a 
specified ESX server.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Query Host Network Adapter, then drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Host tab and enter the appropriate information, including the inventory path of the host. The 
information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Querying the Properties of a Host Server

Use the Query Host Properties activity to query the properties of an ESX server.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Query Host Properties, then drag and drop 
the activity onto the Workflow pane.
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Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Query Host Properties tab and enter the appropriate information, including the inventory path 
of the host. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Querying the Storage Adapters for a Host Server

Use the Query Host Storage Adapters activity to query information about storage adapters configured 
for a specified host.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Query Host Storage Adapters, then drag 
and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Host tab and enter the appropriate information, including the inventory path of the host. The 
information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Querying the List of Hosts

Use the Query Hosts activity to query the list of hosts within the virtual infrastructure target.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Query Hosts, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Query Hosts tab and enter the appropriate information, including the inventory path of the 
host. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Rebooting a VM Host Server

Use the Reboot VM Host activity to restart an ESX server.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Reboot VM Host, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.
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Step 3 Click the Reboot tab and enter the appropriate information, including the inventory path of the host. The 
information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Removing an ESX Host

Use the Remove ESX Host activity to remove a host from the virtual environment (vCenter).

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Remove ESX Host, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Host tab and enter the appropriate information, including the inventory path of the host. The 
information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Removing a Host from a vSphere Distributed Switch

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Remove Host from vSphere Distributed 
Switch, then drag and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Remove Host tab and enter the appropriate information, including the inventory path of the 
host. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Removing an Adapter from a vSphere Distributed Switch

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Remove Adapter from vSphere 
Distributed Switch, then drag and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Remove Adapter tab and enter the appropriate information, including the inventory path of 
the host. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Shutting Down a Host

Use the Shutdown Host activity to power off an ESX host in a vCenter.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Shutdown Host, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Host tab and enter the appropriate information, including:

• Host—The inventory path of the host. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Skip if already in expected power state—Check this check box to complete the activity normally if 
the power state is shut down.

If the check box is not checked and the host is already shut down, the activity will complete with an 
error message stating the operation is not allowed in the current state or could not connect the host.

• Force shutdown if not in maintenance mode—Check this check box to indicate that the host should 
be shut down even if it is not in maintenance mode.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Updating a Host Port Group

Use the Update Host Port Group activity to modify the VLAN ID of the specified port group.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Update Host Port Group, then drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Port Group tab and enter the appropriate information, including:

• Host—The inventory path to the host server (for example, 
TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02)

• Port group—The name of the port group to update

• VLAN ID—The integer that corresponds to a VLAN ID. The valid values are integers between 0 
and 4095.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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Managing VMware vSphere Power Activities
The following table displays the activities that perform basic power management to the virtual machines 
running on the ESX Server via the VI connection.

Executing a PowerCLI Script

Use the Execute PowerCLI Script activity to specify a script command to execute using the VMware 
vSphere PowerCLI module.

Step 1 On the appropriate activity property page, click Add.

Step 2 Specify the script argument value for the script, then click OK.

The script argument is added to the command line argument list on the activity property page.

Activity Description

Execute PowerCLI 
Script

Specifies a script command to execute using the VMware vSphere PowerCLI 
module.

See Executing a PowerCLI Script, page 12-203

Power Off VM Powers off a virtual machine.

See Powering Off a Virtual Machine, page 12-204

Power On VM Powers on a virtual machine

See Powering On Virtual Machine, page 12-204

Reboot Guest Restarts a guest operating system on a virtual machine

See Rebooting a Guest Operating System on a Virtual Machine, page 12-205

Reset VM Resets the power on a virtual machine

See Resetting the Power on a Virtual Machine, page 12-205

Shutdown Guest Powers off a guest operating system on a virtual machine and performs a 
clean shutdown of all services

See Shutting Down a Guest Operating System on a Virtual Machine, 
page 12-206

Standby Guest Powers down a guest operating system on a virtual machine to standby mode

See Moving a Guest Operating System on a Virtual Machine to Standby 
Mode, page 12-206

Suspend VM Suspends execution in the virtual machine

See Suspending a Virtual Machine, page 12-207
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Powering Off a Virtual Machine

Use the Power Off VM activity to power off a specified virtual machine on a given ESX server or vCenter 
server.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Power Off VM, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Power Off tab and enter the appropriate information, including:

• Virtual machine—The inventory path to the virtual machine to be powered off. The information in 
this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Skip if already in expected power state—Check this check box to complete the activity normally if 
the power state is Powered Off.

If the check box is not checked and the ESX host is already powered off, the activity will complete 
with an error message stating the operation is not allowed in the current state or could not connect 
the host.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Powering On Virtual Machine

Use the Power On VM activity to power on a specified virtual machine on a given ESX server or vCenter 
server.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Power On VM, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Power On tab and enter the appropriate information, including:

• Virtual machine—The inventory path to the virtual machine to be powered off. The information in 
this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Host—Inventory path to the ESX host server to be powered on. The information in this field is 
case-sensitive.

• Skip if already in expected power state—Check this check box to complete the activity normally if 
the power state is Powered On.

If the check box is not checked and the ESX host is already powered on, the activity will complete 
with an error message stating the operation is not allowed in the current state or could not connect 
the host.

• Wait for VMware tools—Check this check box to wait for the VM tools service to start before 
completing the activity.

You can configure the VMware Tools service to depend on other required application services, to 
ensure that the required application services are available when the activity completes.
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Rebooting a Guest Operating System on a Virtual Machine

Use the Reboot Guest activity to restart a guest operating system on a virtual machine on a given ESX 
server or vCenter server. This activity shuts the machine down gracefully prior to powering the machine 
back up.

Use the Power On VM activity to power on a specified virtual machine on a given ESX server or vCenter 
server.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Reboot Guest, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Reboot Guest tab and enter the appropriate information, including:

• Virtual machine—The inventory path to the virtual machine to be rebooted. The information in this 
field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Wait for VMware tools—Check this check box to wait for the VM tools service to start before 
completing the activity.

You can configure the VMware Tools service to depend on other required application services, to 
ensure that the required application services are available when the activity completes.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Resetting the Power on a Virtual Machine

Use the Reset VM activity to reset the power on a virtual machine on a given ESX server or vCenter 
server.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Reset VM, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Reset tab and enter the appropriate information, including:

• Virtual machine—The inventory path to the virtual machine to be reset. The information in this field 
is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Wait for VMware tools—Check this check box to wait for the VM tools service to start before 
completing the activity.

You can configure the VMware Tools service to depend on other required application services, to 
ensure that the required application services are available when the activity completes.
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Shutting Down a Guest Operating System on a Virtual Machine

Use the Shutdown Guest activity to power off a guest operating system on a virtual machine gracefully.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Shutdown Guest, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Shutdown Guest tab and enter the appropriate information, including:

• Virtual machine—The inventory path to the virtual machine to be reset. The information in this field 
is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Skip if already in expected power state—Check this check box to complete the activity normally if 
the power state is shut down.

If the check box is not checked and the ESX host is already shut down, the activity will complete 
with an error message stating the operation is not allowed in the current state or could not connect 
the host.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Moving a Guest Operating System on a Virtual Machine to Standby Mode

Use the Standby Guest activity to put a guest operating system on a virtual machine in standby mode on 
a given ESX server or vCenter server.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Standby Guest, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Standby Guest tab and enter the appropriate information, including:

• Virtual machine—The inventory path to the virtual machine to be put in stand by mode. The 
information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Skip if already in expected power state—Check this check box to complete the activity normally if 
the power state is in standby.

If the check box is not checked and the ESX host is already in standby, the activity will complete 
with an error message stating the operation is not allowed in the current state or could not connect 
the host.
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Suspending a Virtual Machine

Use the Suspend VM activity to suspend a virtual machine on a given ESX server or vCenter server.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Suspend VM, then drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Suspend VM tab and enter the appropriate information, including:

• Virtual machine—The inventory path to the virtual machine to be put in stand by mode. The 
information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Skip if already in expected power state—Check this check box to complete the activity normally if 
the power state is suspended.

If the check box is not checked and the ESX host is already suspended, the activity will complete 
with an error message stating the operation is not allowed in the current state or could not connect 
the host.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Managing VMware vSphere Snapshot Activities
The following table displays the activities which perform the basic snapshot management of the virtual 
machines running on the ESX Server or vCenter.

Activity Description

Create Snapshot Creates a snapshot of a specified virtual machine

See Creating a Snapshot of a Virtual Machine, page 12-208

Query VM Snapshots Queries the properties of a snapshot of a selected virtual machine

See Querying the Properties of a Virtual Machine Snapshot, page 12-208

Remove all Snapshot Removes all snapshots that have been taken of the virtual machine

See Removing All Snapshots of a Virtual Machine, page 12-209

Remove Snapshot Removes a specific snapshot from the virtual machine and deletes any 
associated storage

See Removing a Specific Snapshot of a Virtual Machine, page 12-210

Rename Snapshot Changes the name or description of a snapshot of the virtual machine

See Renaming a Snapshot of a Virtual Machine, page 12-210
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Creating a Snapshot of a Virtual Machine

Use the Create Snapshot activity to capture a snapshot of a specified virtual machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Create Snapshot, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Snapshot tab and enter the appropriate information, including:

• Virtual machine—The inventory path to the virtual machine on which the snapshot will be taken. 
The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Snapshot the virtual machine memory—Check this check box to include the memory of the virtual 
machine in the snapshot.

A dump of the internal state of the virtual machine is included in the snap shot. If the check box is 
not checked, then the power state of the snapshot is set to Powered Off.

• Quiesce virtual memory during snapshot—Check this check box to quiesce file system writes before 
the snapshot is taken.

If the virtual machine is Powered On when the snapshot is taken, this ensures that the disk snapshot 
represents a consistent state of the guest file system.

If the virtual machine is Powered Off or VMware Tools are not available, the quiesce flag is ignored.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Querying the Properties of a Virtual Machine Snapshot

Use the Query VM Snapshots activity to query the properties of a snapshot of a selected virtual machine 
on a given ESX server or vCenter server. The Query VM Snapshots activity should generate a list with 
the name and description of each snapshot of the virtual machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Query VM Snapshots, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Virtual Machine tab and enter the inventory path to the virtual machine to query for snapshots. 
The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Revert to Current 
Snapshot

Restore the most recent snapshot

See Restoring a Virtual Machine to the Most Current Snapshot, page 12-210

Revert to Snapshot Restore the specified virtual machine to a specific snapshot

See Reverting a Virtual Machine to a Specific Snapshot, page 12-211

Take Snapshot Captures a snapshot of a specified virtual machine

See Taking a Snapshot of a Virtual Machine, page 12-211
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Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Managing the Virtual Machine Snapshots

Use the Manage Snapshot activity to manage the available snapshots.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Manage Snapshot, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Snapshot tab and enter the appropriate information, including:

• Virtual machine—The inventory path to the virtual machine on which the snapshot will be taken. 
The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Snapshot the virtual machine memory—Check this check box to include the memory of the virtual 
machine in the snapshot.

A dump of the internal state of the virtual machine is included in the snap shot. If the check box is 
not checked, then the power state of the snapshot is set to Powered Off.

• Quiesce virtual memory during snapshot—Check this check box to quiesce file system writes before 
the snapshot is taken.

If the virtual machine is Powered On when the snapshot is taken, this ensures that the disk snapshot 
represents a consistent state of the guest file system.

If the virtual machine is Powered Off or VMware Tools are not available, the quiesce flag is ignored.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Removing All Snapshots of a Virtual Machine

Use the Remove All Snapshots activity to delete all snapshots that have been taken of a specified virtual 
machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Remove All Snapshots, then drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Virtual Machine tab and enter the inventory path to the virtual machine on which the 
snapshots will be deleted. The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
12-209
Cisco Process Orchestrator 3.3 User Guide

 



 

Appendix 12      Using Adapters
  VMware vCenter, ESX, and ESXi Adapter
Removing a Specific Snapshot of a Virtual Machine

Use the Remove Snapshot activity to delete a specific snapshot that was taken of a specified virtual 
machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Remove Snapshot, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Snapshot tab and enter the appropriate information, including:

• Virtual machine—The inventory path to the virtual machine on which the snapshot was taken. The 
information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Snapshot name—The name of the snapshot to be deleted.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Renaming a Snapshot of a Virtual Machine

Use the Rename Snapshot activity to update the name or description of an existing snapshot of a 
specified virtual machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Rename Snapshot, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Snapshot tab and enter the appropriate information, including:

• Virtual machine—The inventory path to the virtual machine containing the snapshot to be updated. 
The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Snapshot name—Current name of the snapshot whose properties are to be updated.

• New snapshot name—New name for the snapshot.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Restoring a Virtual Machine to the Most Current Snapshot

Use the Revert to Current Snapshot activity to restore the virtual machine to the most recent snapshot.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Revert to Current Snapshot, then drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.
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Step 3 Click the Snapshot tab and enter the inventory path to the virtual machine with the current state that the 
VM is to be reverted to the most current snapshot. The information in this field is case-sensitive. For 
example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Reverting a Virtual Machine to a Specific Snapshot

Use the Revert to Snapshot activity to restore the specified virtual machine to a specific snapshot.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Revert to Snapshot, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Snapshot tab and enter the appropriate information, including:

• Virtual machine—The inventory path to the virtual machine on which the snapshot was taken. The 
information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Snapshot name—Name of the snapshot to which the virtual machine should be restored.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

Taking a Snapshot of a Virtual Machine

Use the Take Snapshot activity to capture a snapshot of a specified virtual machine.

Step 1 In the Process Editor Toolbox, choose VMware vSphere > Take Snapshot, then drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Snapshot tab and enter the appropriate information, including:

• Virtual machine—The inventory path to the virtual machine on which the snapshot will be taken. 
The information in this field is case-sensitive. For example:

TEST-ENV/UCS/vm/TESTDEV-W2K8-64-02

• Snapshot the virtual machine memory—Check this check box to include the memory of the virtual 
machine in the snapshot.

A dump of the internal state of the virtual machine is included in the snap shot. If the check box is 
not checked, then the power state of the snapshot is set to Powered Off.

• Quiesce virtual memory during snapshot—Check this check box to quiesce file system writes before 
the snapshot is taken.

If the virtual machine is Powered On when the snapshot is taken, this ensures that the disk snapshot 
represents a consistent state of the guest file system.
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If the virtual machine is Powered Off or VMware Tools are not available, the quiesce flag is ignored.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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Web Console Help Adapter
The Cisco Process Orchestrator Web Console provides a web-based view of the scaled-back Operations 
workspace on the Process Orchestrator Console. On the Web Console, you can view tasks that have been 
assigned to the individual or the group, processes they are able to run, and track the processes they have 
started from any web browser. 

For the Web Console to work properly, Internet Information Services must be installed on the computer 
on which the Web Console is installed. For information on installing and configuring IIS, see the Cisco 
Process Orchestrator Installation and Administration Guide. 

You cannot create or modify processes on the Web Console. To modify a process, you must have the 
appropriate security rights and you must access the Process Orchestrator console. If you think you 
should have access to the Process Orchestrator console, contact your manager to authorize your access.

Managing Tasks
The My Tasks page displays the tasks that have been assigned to you or your group. Use this page to:

• Display the details about a task that you have run

• Filter the display of the tasks

• Resolve an assigned task

• Take ownership of a task

• View an automation summary

Displaying Details About a Task You Have Run

To view information about a task you have run, choose My Tasks, highlight the appropriate task, then 
click View Details. 

Filtering the Tasks Display

Use the Search Criteria pane to modify the display of the tasks in the My Tasks page. The display options 
consist of filtering the tasks according the assignee, the group of the assignee, or by task type.

Step 1 Choose My Tasks, then use the Search Criteria pane to modify the display of the processes on the page. 

Step 2 Set the following properties:

• Task Assignments: 

– Me

– Me and My Groups

– View All Tasks

• Task State—The status associated with the tasks in the list. 

The <No Filter> option allows the page to display all tasks regardless of the assigned state. 

• Filter by Type —The appropriate task type to display. 
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Step 3 Click Search to filter the display. 

Resolving an Assigned Task

Step 1 Choose My Tasks, then use the search criteria to filter the tasks to the appropriate display. 

Step 2 Choose Actions > View Details. 

Step 3 Set the following properties:

• Status—Select the appropriate status for the task resolution. 

• Add Notes—If available, enter any notes related to the task resolution or status update. 

Step 4 Click Submit to resolve the task.  The Task details page is updated and displays the user name of who 
resolved the task. 

Taking Ownership of a Task

These steps are used when deciding to take ownership of a task that is unassigned or assigned to an entire 
group of which the current logged in user is also included. 

Step 1 Choose My Tasks, highlight the appropriate task, then click View Details. 

Step 2 Set the following properties:

• Add Notes—If available, enter any notes related to the task. 

• Click Take sole ownership of this task. 

Step 3 Click Submit. The Task details page is updated and displays the user name of who resolved the task. 

Viewing an Automation Summary

An automation summary is a collection of data summarizing the objects included in the process and the 
data retrieved by the processing of the of the objects. Process Orchestrator analyzes all data points in 
context with each other to identify a situation that may require action, then displays this information in 
an automation summary. 

Step 1 Choose My Tasks, highlight the appropriate task, then click View Details. 

The Summary page displays summary of a specific task, including:

• Report Location—The file path for the automation summary.

• Situation Analysis—After Process Orchestrator puts all data points in context to identify a situation 
that requires action, it performs deep analysis based on the type of situation identified. During 
situation analysis, Process Orchestrator captures volatile state and diagnostic information that may 
otherwise be difficult or impossible to capture manually.
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The Situation Analysis section displays below the overview information. You can click the link in 
the upper portion of the summary to navigate directly to the Situation Analysis section or scroll to 
the section.

• Context Analysis— Displays the symptom and possible causes.

Running Processes
The Run Processes page displays the processes that an authenticated user can run in Process 
Orchestrator. The available processes are determined by the security role of the user. Use this page to:

• Filter the display of the available processes according to process category

• Start a process

• Override a process target

Filtering the Display by Category

Step 1 Choose My Process History, then use the Search Criteria pane to modify the display of the processes 
on the page.

Step 2 Choose Category, select the appropriate category, and click Search.

Starting a Process

All processes that display on the Run Processes page are enabled and can be started by an authenticated 
user. Only one process can be started at a time. When a process is started manually, all conditions and 
triggers included in the process definition are overridden.

Step 1 Choose the appropriate process and click Start.

Step 2 The name of the selected process displayed under Are you sure you want to launch the process? If No, 
skip to Step 4.

Step 3 If the process has input variables, click Start the process with the following parameters and verify or 
modify the input variable values as necessary.

Step 4 Under This Process will execute against [Target Name]. Would you like to override?, select one of 
the following options:

• Yes—To specify a target or target group different from the defined process target

• No—To continue with the process execution

Step 5 Click Start to begin. The Process Results page displays and the process begins executing. 
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Overriding a Process Target

With the appropriate rights, a user can override the target of any manually started process before process 
execution has begun. The Start Process page displays after the process is launched and is used to confirm 
the process to be started, associated input variables, and the target against which the process is launched.

Targets cannot be modified from the web console.

Step 1 After the process has been started from the Run Processes page, the Start Process page displays.

Step 2 Under This Process will execute against [Target Name]. Would you like to override?, select one of 
the following options:

• Yes—To specify a target or target group different from the defined process target.

– On the Targets drop-down list, select the appropriate target.

– On the Target Group drop-down list, select the appropriate target group.

• No—To continue with the process execution

Step 3 Click Start to begin. The Start Process Results page displays.

Process History
The My Process History page displays the processes that the authenticated user has run in Process 
Orchestrator. The user is able to filter the display of the processes the user has launched as well view the 
details of the processes. Use this page to:

• Filter the processes displayed on the history page

• View the processes that the authenticated user has run in Process Orchestrator. 

• View additional information about the activities in the processe

Filtering My Process History

Step 1 Choose My Process History, then use the Search Criteria pane to modify the display of the processes. 

Step 2 Set the following properties:

• Processes started within the past—Enter the appropriate number and select a time unit to filter the 
display by a specific time frame. (ex. dd:hh:mm)

• Process State—Select one of the options to filter the display according to the state of the process:

– View All

– View Completed

– View Incomplete

• Category—Select the appropriate category associated with the processes in the list.

The <No Filter> option allows the page to display all processes regardless of the assigned category.

Step 3 Click Search to modify the process list display.
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Viewing My Process History

The My Process History page displays the processes that the authenticated user has run in Process 
Orchestrator. The user is able to filter the display of the processes the user has launched as well view the 
details of the processes.

Step 1 Choose My Process History and filter the process list for the appropriate processes to display.

Step 2 Click View Details.

Viewing Process Activity Information

The My Process History page displays the processes that the authenticated user has run in Process 
Orchestrator. Use the following steps to view additional information about the activities in the processes.

To view activity information

Step 1 Choose My Process History, highlight the appropriate process and click View Details.

Step 2 To access detailed information about a task, click Viewing Task Information.

Step 3 To access the automation summary for a task, click View Automation Summary.
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Web Services Adapter
Web services are components on a Web server that a client application can call by making HTTP requests 
across the Web. The Cisco Process Orchestrator Web Service adapter is designed to support general web 
service calls. The adapter allows users to send requests using web service methods and other parameters 
to generate an XML output. Web Targets allow activities to execute against a web site or web service 
that is hosted by several machines.

The following table displays the activities that are provided by the Web Services adapter. For more 
information about using these activities, see Getting Started Using the Web Services Adapter, 
page 12-218.

Getting Started Using the Web Services Adapter
Use the following process to monitor and manage Web Services instances. 

Step 1 Create a Web Services target (see Defining a Web Target, page 12-220).

Step 2 Specify the credentials for a Web Services runtime user (see Automating Web Services Adapter 
Activities, page 12-221).

Step 3 Define a Web Services activity (see Automating Web Services Adapter Activities, page 12-221). 

Step 4 View the activity results (see Monitoring Operations, page 8-1).

Configuring the Web Services Adapter

Configuring HTTP Endpoints for Process Orchestrator Web Service

The HTTP Endpoints are encrypted by default. This is the most compatible endpoint that Process 
Orchestrator can offer for accessing the web service, but it is not necessary for normal Process 
Orchestrator operations.

Step 1 Stop the Process Orchestrator service.

Activity Description

URL Ping Pings a web address

See the Defining a URL Ping Activity, page 12-221.

Web HTTP Request Sends a HTTP request for a file based on a URL

See the Defining a Web HTTP Request Activity, page 12-222.

Web HTTP Save File Saves a specific HTTP file to the local machine or network drive

See the  Defining a Web HTTP Save File Activity, page 12-222.

Web Service Execute Groups a WSDL URL used by the server, a web service method, and input 
parameters to generate an XML output

See Defining a Web Service Execute Activity, page 12-223.
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Step 2 In the Process Orchestrator install directory, open the Tidal.Automation.Server.Exe.Config file in a text 
editor, such as Notepad.exe.

Step 3 Scroll to NonsecuredHttpAllowed and change the value tag to True.

Step 4 Scroll to NonsecuredHttpPort and verify the value tag is 61527.

The NonsecuredHttpPort indicates the port at which Process Orchestrator's unencrypted HTTP endpoint 
can be accessed.

Step 5 Press Ctrl+S to save and then close the text editor.

Step 6 Start the Process Orchestrator service and wait for the startup to fully complete.

All transmissions by the web service are now unencrypted.

Configuring Authentication for HTTP Endpoints for Process Orchestrator Web Service

The default authentication for the HTTP Endpoints is NTLM. Process Orchestrator allows users the 
ability to modify the authentication for the HTTP Endpoints. The following steps are to be used when 
trying to integrate with Process Orchestrator using the web service from a third-party product that does 
not support NTLM authentication.

Step 1 Stop the Process Orchestrator service.

Step 2 In the Process Orchestrator install directory, open the Tidal.Automation.Server.Exe.Config file in a text 
editor, such as Notepad.exe.

Step 3 Scroll to HttpAuthenticationMechanism and change the value tag to one of the following:

• NTLM (recommended)

• Basic

• Digest

Step 4 Press Ctrl+S to save and then close the text editor.

Step 5 Start the Process Orchestrator service and wait for the startup to fully complete.

Selecting a Client Certificate

Use the Select Client Certificate dialog box to select certificate you want to assign to a runtime user.

To select a certificate:

Step 1 On the Certificate property page, click Browse.

The Select Client Certificate dialog box displays.

Step 2 Browse to the appropriate certificate.

Step 3 Enter the password for the certificate.

Step 4 Click OK to close the dialog box.
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Configuring URL Prefixes to Ignore Certificate Errors

A certificate error occurs when a https-secured site is being opened and the certificate has become 
invalid.  Use the Ignore Certificate Error tab to add the URL prefixes to ignore when a certificate error 
occurs. If the URL prefix is not listed, then any site with that URL prefix will be inaccessible.

This tab allows invalid/expired SSL certificates in HTTPS-based activities in the Web Service adapter. 
For example, a user may have a web service or web site configured using a temporary/test or otherwise 
invalid SSL certificate. If the prefix is not included in the list, then the activity would fail against the web 
site with an invalid certificate error.

Step 1 Choose Administration > Adapters, highlight Web Service Adapter, right-click and choose 
Properties.

Step 2 Click the Ignore Certificate Errors tab to modify the list of prefixes to ignore.

Step 3 To add a URL prefix to the URL Prefixes to ignore certificate errors for text box, click Add.

Step 4 In the URL prefix to ignore field, enter the appropriate prefix, and click OK. For example:

https://myserver:myport/site1

The URL prefix is added to the URL Prefixes to ignore certificate errors for text box.

Step 5 To modify the list of URL prefixes, click the appropriate button.

Step 6 Click OK to close the dialog box.

Defining a Web Target
Use the Web target to configure a target for execution by a web service activity on which a web site may 
be hosted on several machines. The target allows an activity to execute against the specified URL 
address.

Step 1 Choose Definitions > Targets, right-click, and choose New > Web Target.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Connection tab to specify the connection information to a web service.

Step 4 Enter the information in the remaining tabs as necessary, then click OK to close the dialog box.

Defining an OAuth Credential Account
The OAuth Credential account simplifies the task of making authenticated RESTful web service calls. 
Use the OAuth Credential Properties dialog box to specify the credentials for a OAuth runtime user. The 
information is used to assign run options for Web HTTP Request and Web HTTP Save File processes or 
activities.

Step 1 Choose Definitions > Runtime Users, right-click and choose New > OAuth Credential.

Step 2 On the General panel, enter the appropriate information and click Next.

Step 3 Click the Credentials tab to specify the following information:
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• 1.0 OAuth Version

– OAuth Version—Select 1.0 version of OAuth, from the drop–down list.

– Consumer Key—Enter the key that was received after registering with the resource providers.

– Consumer Key Secret—Enter the consumer secret that is associated with the consumer key.

– Access Token—Enter the access token which provides the consumer access to resources from 
resource providers.

– Access Token Secret—Enter the secret associated with the access token.

Note Depending on the resource providers, you might not need Access Token and Access Token 
Secret to make some RESTful web service calls. However, if a RESTful web service call does 
require access token and access token secrets, you need to obtain it from resource providers

– Signature Method—Specify the method that you want to use for signing.

• 2.0 OAuth Version

– OAuth Version—Select 2.0 version of OAuth, from the drop–down list.

– Url—Enter the Url of the OAuth token.

– Refresh Token—Enter the refresh token which provides the consumer access to resources from 
resource providers.

– Client ID—Enter the Client ID.

– Client Secret—Enter the secret associated with the access token.

Note The Client ID and Client Secret is generated when you register with the developer concern.

Step 4 Click OK to close the dialog box and complete the procedure.

Automating Web Services Adapter Activities

Defining a URL Ping Activity

Use the URL Ping activity to ping a web address.

Step 1 In the Process Editor Toolbox, choose Web Service > URL Ping, then drag and drop the activity onto 
the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the URL tab to specify the available properties.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

When the URL Ping activity is launched, the summary information from the activity results is displayed 
from the Operations Workspace activity instance view.
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Defining a Web HTTP Request Activity

Use the Web HTTP Request activity to send a request for a file based on a URL, HTTP headers, or 
Cookies data. This request generates a response in an output file provided by the web server.

This activity supports generic HTTP operations, such as POST and GET, and is used to retrieve a web 
page and then examine the results to ensure there are no errors.  The activity can be used to perform 
synthetic transactions against portals or other web sites.

Step 1 In the Process Editor Toolbox, choose Web Service > Web HTTP Request and drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the HTTP Request tab to specify the required properties, including:

• Relative URL—Enter the relative URL to be requested. The base URL will be determined by the 
web target combined with the relative Url during the activity execution.

• Method—Enter the method to be performed on the resource identified by the Request-URI. The 
method is case-sensitive. 

• HTTP Version—Select the appropriate HTTP version for the request. (Default: 1.1)

• Request—Enter any additional HTTP request details.

Step 4 Click the Output Format tab to select the appropriate format for the output of the header request.

Step 5 Click the HTTP Headers tab to customize the content header requests for the activity (see Defining the 
HTTP Headers, page 12-224).

Step 6 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

When the Web HTTP Request activity is launched, results are displayed from the Operations Workspace 
activity instance view.

Defining a Web HTTP Save File Activity

Use the Web HTTP Save File activity tab to save a specific HTTP file to the local machine or network 
drive which hosts the Process Orchestrator server.

Step 1 In the Process Editor Toolbox, choose Web Service > Web HTTP Save File and drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Save File tab and enter the required information.

Step 4 Click the HTTP Headers tab to customize the content header requests for the activity. For a list of 
common HTTP headers, see Defining the HTTP Headers, page 12-224.

Step 5 Click the Cookies tab to configure the current activity to accept cookies and/ or use a cookies data table 
retrieved from a previous HTTP request.

Step 6 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.
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When the Web HTTP Save File activity is launched, the summary information from the activity results 
is displayed from the Operations Workspace activity instance view.

Defining a Web Service Execute Activity

Use this Web Service activity to call web service parameters to generate an XML output.

Step 1 In the Process Editor Toolbox, choose Web Service > Web Service Execute and drag and drop the 
activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Web Service tab and specify the following properties:

• Method—See Selecting a Web Service Method, page 12-223.

The information populates the Method field and the parameters for the selected method display 
under the Parameters box.

The Build button is not available until a valid web service method is selected. Click Build to launch 
the Build Array dialog box to define the array and class properties for the activity.

• WSDL Location:

– Relative WSDL Url—Use the relative URL.

– Use WSDL file path—Use an alternate WSDL file path.

• Endpoint:

– Use endpoint specified in WSDL file

– Relative endpoint URL

• SOAP Headers—Displays the SOAP header class associated with the web service method. SOAP 
headers passes data to and from an XML Web service method if the data is not directly related to 
the XML Web service method's primary functionality.

• Parameters—See Defining the Web Service Parameters, page 12-224.

Step 4 Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

When the Web Service Execute activity is launched, results are displayed from the Operations 
Workspace activity instance view.

Selecting a Web Service Method

Use the Select Method dialog box to select a web service method for the URL.

To select a web service method:

Step 1 On the Web Service property page, click Select.

The Select Method dialog box displays all the web service methods for the URL.

Step 2 Enter the appropriate URL containing the web service methods in the URL field, and click Verify to 
connect to the web service specified in the Url field and verify the service connection.
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If the connection is successful, a confirmation dialog box displays confirming the URL connection.

The Methods list box displays the following information for all the web service methods discovered by 
the console for the web service of the specified URL.

• Binding Name—User name for the binding in the metadata of the service

Step 3 In the Method Details box, review the information and click OK.

The information populates the Method field and the parameters for the selected method display under 
the Parameters box on the Web Service Execute property page.

Defining the Web Service Parameters

The Web Service parameters dialog box includes these parameters:

• Parameters—Modify the input parameters when making the web service call.

• Secure—Check the check box to indicate that security-sensitive string text is required

• Synchronize—Click this button to synchronize the parameters in the Parameters box and the list of 
parameters for the specified method.

Clicking this button will remove the existing parameter information if any web method parameters 
are added or removed. If the parameters are the same type and are listed in the same order, then no 
change is made.

Defining the HTTP Headers

Click the HTTP Headers tab to customize the content header requests for the activity, including:

• Content type—Enter or modify the value for the content type used to define the structure of the 
output. (Default: application/xml;charset=utf-8). 

• Accept—Enter the value of the Accept HTTP header.

• User-Agent—Enter the value of the User-agent HTTP header.

• Timeout—Check the check box and then enter the time period the activity should wait before failing. 
Click the time unit link to change the time interval.

• Allow auto redirect—Check this check box to allow the header request to be redirected 
automatically.

Adding Customized Header Requests

Use the Add Header dialog box to create and modify customized content header requests.

Step 1 On the Web HTTP Request property page, click the HTTP Headers tab. 

Step 2 Scroll to the bottom of the tab, and click Add.

Step 3 Enter the appropriate information as necessary, and click OK.

Step 4 Enter the web service parameters. 

The Build Array dialog box is launched when the SelectByActivityViewIdExpanded method is selected. 
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Step 5 To specify the build array:

a. On the Web Service property page, under Parameters, click Build.

b. To create an array, click Add to launch the Build Primitive dialog box and specify the primitive value 
for the array.

c. On the Build Primitive dialog box, specify the required information, then click OK.

d. Click OK again to close the dialog box.

Defining the Build Class Properties

Use the Build Class dialog box to specify the class for the build instanceID. The web services class 
defines the optional base class for XML Web services.

The Build Class dialog box is launched when a valid web services method is selected.

Step 1 On the Web Service property page, click Build.

Step 2 Select the appropriate radio button to specify the appropriate class option.

Step 3 Under Set properties of the created objects to the values, enter the object values for the listed build 
properties, as necessary.

The displayed objects in the section are dependent upon the selected object type.

Step 4 To the right of the name of the property, check the Hidden check box to indicate that the string text in 
the field is security-sensitive.

Step 5 Click OK to close the dialog box.

The information populates the appropriate parameter field on the Web Service Execute property page.

Modifying the List of Headers

Step 1 Click the appropriate button to modify the list of specific header requests.

Step 2 Click the Cookies tab to configure the current activity to accept cookies and/ or use a cookies data table 
retrieved from a previous HTTP request.

Step 3 Complete the appropriate information in the remaining tabs, as necessary, and then click the Save tool 
to complete the activity definition.

Defining Cookie Properties for Web Service Activity

Use the Cookies tab to configure the current activity to accept cookies and/ or use a cookies data table 
retrieved from a previous HTTP request. The data table can be user-defined, as long as the properties of 
the table matches the default cookies data table.

When working with cookies, it is recommended that users verify that the status code for the activity is 
satisfactory at 200 (OK). For example, if the following is configured:

• First HTTP Request activity - Login to web site - accept cookies check box checked
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• Second HTTP Request activity - Download a file - use the cookies from the previous request 
completed

However, if the Accept cookies check box is not checked on the first HTTP Request activity, the second 
HTTP request will still attempt to download the file specified in the activity. If the user isn't logged in, 
then the web page will require the user to log in and the 200 (OK) status code will not display.

To ensure that the 200 OK status code is displayed, add result handlers to the activity to ensure the 
expected status code.

Step 1 On the appropriate activity property page, click the Cookies tab.

Step 2 Complete the fields as necessary, then click the Save icon.

Inserting a Web Service Cookie Data Table Reference Property

Use the Insert Variable Reference dialog box to select a cookie reference variable to populate the Use 
cookies from previous request field on the web service activity. You can select the entire Cookie data 
table or a Cookie reference property. The OK button does not activate until a valid property or variable 
is selected.

Step 1 To the right of a field on a property page, click the Reference tool.

Check the Show Advanced check box to display all items that are available for referencing.

If the check box is not checked, then only the most commonly-used items are displayed for activities, 
processes or events.

Step 2 Click the Save icon to save the changes.

Step 3 Click the appropriate Workflow Activity Expand (+) > Cookies to display the reference columns for the 
cookie.

Step 4 From the list of displayed objects, select the appropriate cookie property.

Step 5 Click OK to add the selected Cookie reference variable to the related text field.

Viewing Web Service Activity Results

Viewing the URL Ping Response Time

When the URL Ping activity is launched, the summary information from the activity results are displayed 
from the Operations Workspace activity instance view.

To view the URL Ping results:

Step 1 On the Operations workspace, click the Activity Views folder.

Step 2 Expand the appropriate process and then double-click the appropriate activity instance.

The URL Ping Properties dialog box displays.
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Step 3 Click the Results display-only tab to view the results of the response time for the URL specified in the 
activity properties.

• Destination—File path or URL for the web address pinged

• Response time (in milliseconds)—Time taken for web site to respond to the ping

Viewing the Web HTTP Request Activity Results

When the Web HTTP Request activity is launched, results are displayed from the Operations Workspace 
activity instance view.

To view Web HTTP Request output results:

Step 1 In the Operations workspace, click the Activity Views folder.

Step 2 Highlight the Web HTTP Request activity instance, right-click and choose Properties.

The Web HTTP Request Properties dialog box displays.

Step 3 Click the Output display-only tab to view the header request results.

• Response URL—Displays the URL requested by the activity

• Status Code—HTTP status code may indicate whether a request is successful or unsuccessful

• Status Description—Description of the HTTP status

Step 4 Click the appropriate to indicate which format the output should be displayed.

Viewing the Web HTTP Save File Results

When the Web HTTP Save File activity is launched, the summary information from the activity results 
are displayed from the Operations Workspace activity instance view.

To view the Web HTTP Save File results:

Step 1 On the Operations workspace, click the Activity Views folder.

Step 2 Expand the appropriate process and then highlight the Web HTTP Save File activity instance, right-click 
and choose Properties.

The Web HTTP Save File Properties dialog box displays.

Step 3 Click the Save File display-only tab to view the file properties of the newly saved file.

• Saved File Path—File path to the local computer or network share which hosts the Cisco Process 
Orchestrator server where the file was saved

• File Size—Size of the file saved (in Kilobytes)

• Response URL—Displays the URL requested by the activity

• Status Code—HTTP status code may indicate whether a request is successful or unsuccessful

• Status Description—Description of the HTTP status
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Viewing the Web Service Execute Activity Results

When the Web Service Execute activity is launched, results are displayed from the Operations 
Workspace activity instance view.

To view Web Service Execute output results:

Step 1 In the Operations workspace, click the Activity Views folder.

Step 2 Highlight the activity instance, right-click and choose Properties.

The Web Service Execute Properties dialog box displays.

Step 3 Click the Output tab to view the web service results.

Step 4 Click the appropriate button to indicate which format the output should be displayed.
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Windows Adapter
Cisco Process Orchestrator’s process automation engine provides the logical constructs necessary to 
support even the most complex requirements to automate Microsoft Windows server operating systems 
tasks. Windows Server 2003 or later is required for use in Process Orchestrator.

The Windows Adapter provides the ability to easily query Windows performance data and execute 
Windows commands and scripts. 

The Windows Adapter provides the following activities for querying specific Windows performance 
information. Additional activities can display in the Process Editor toolbox if you have imported the 
Windows automation pack.  For more information about using these activities, see Getting Started Using 
the Microsoft Windows Adapter, page 12-230.

Activity Description

Control Windows Service Specifies the Windows service to which an action should be performed.

See Defining the Control Windows Service Activity, page 12-232

Copy Folder Copies file folders from one location to another.

See Defining Copy Folders Activity, page 12-237

Correlate Windows Event Specifies the event log information that is to be located on the target.

See Defining a Correlate Windows Event Activity, page 12-233

Create Folder Creates a file path.

Execute Windows 
Command

Specifies the Windows command and the target directory on which to 
execute.

See Defining the Execute Windows Command Activity, page 12-235

Execute Windows 
PowerShell Script

Specifies a Windows command and the target directory on which to 
execute.

See:

• Defining the Execute Windows PowerShell Script Activity, 
page 12-236

• Adding a Script Argument, page 12-238

Execute Windows Script Specifies the Windows script and target directory on which to execute.

See:

• Defining the Execute Windows Script Activity, page 12-238.

• Adding a Script Argument, page 12-238

Get Folder Properties Retrieves folder properties.

Query Windows Events Specifies the criteria for an event that must be matched to trigger the 
process.

See Defining the Query Windows Events Activity, page 12-239
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Getting Started Using the Microsoft Windows Adapter
Use the following process to monitor and manage Microsoft Windows adapter instances. 

Step 1 Create a Microsoft Windows target (see Defining a Microsoft Windows Target, page 12-231).

Step 2 Create a Windows user (see Defining a Windows User, page 12-232).

Step 3 Define a Windows message event trigger (see Creating a Microsoft Windows Event Trigger, 
page 12-232).

Step 4 Define a Microsoft Windows command activity. 

Query Windows 
Performance Counter

Specifies the information used to collect performance data for your 
monitoring system components.

See:

• Defining the Query Windows Performance Counter Activity, 
page 12-241

• Selecting a Performance Counter, page 12-241

Query Windows Registry Specifies the information necessary to read information from the registry 
keys.

See: 

• Defining the Query Windows Registry Activity, page 12-242

• Selecting a Registry Key, page 12-244

Query Windows Service Produces the current state of the service, the startup type of the service, 
and specifies the Windows service to be queried.

See Defining the Query Windows Service Activity, page 12-243.

Restart Server Use the Restart Server activity to indicate the time to delay before 
restarting a server and the server restart notification message.

See Defining Restart Server Activity, page 12-242

Stop Windows Process Use this activity to stop a currently-running Windows process.

Define a Stop a Windows Process Properties Activity, page 12-239

Uninstall Application Use this activity to uninstall a specific application.

Update Windows Registry Specifies the information required to update the existing information 
from the registry keys.

See:

• Defining the Update Windows Registry Activity, page 12-244

• Selecting a Registry Key, page 12-244

Update Windows Service Specifies the Windows service to configure with a new startup mode.

See Defining the Update Windows Service Activity, page 12-245

Write File Writes content into a file that resides on a remote machine.

See Defining the Write File Activity, page 12-245.

Activity Description
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Note To ensure these Windows activities execute properly, verify that the Remote Registry service is 
enabled on your machine. 

a. In the Process Editor Toolbox, choose Microsoft Windows > [Microsoft Windows Activity], then 
drag and drop the activity onto the Workflow pane.

b. Click the General tab and enter the required information.

c. Click the [Activity-Specific] tabs to define the properties specific to the activity. 

d. Enter the information in the remaining tabs as necessary, then click Save to complete the activity 
definition.

For details about a specific activity, see Automating Microsoft Windows Adapter Activities, 
page 12-232.

Step 5 View the activity results (see Monitoring Operations, page 8-1).

Defining a Microsoft Windows Target
Use the Windows Computer target to specify the connection information for the Windows computer used 
for processes to run against. The Windows computer target must be added to the domain in which the 
Cisco Process Orchestrator server has a trust relationship, before it can be used as a target on the Cisco 
Process Orchestrator server.

Windows firewall settings must be adjusted to allow Windows Management Instrumentation (WMI) to 
pass through.

Step 1 Choose Definitions > Targets, right-click and choose New > Windows Computer.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Connection tab to specify the following information:

• Computer name (NetBIOS)—The name of the computer (local computer name)

– Local computer name

– .DNS name

– NetBIOS name

– IP address

• Default runtime user—Select the default runtime user account that contains the credentials to 
connect to the target.

Step 4 Click OK to close the dialog box and complete the procedure.
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Defining a Windows User
The credentials specified for a runtime user stores the information about the user security context and to 
pass this information to the adapters. Use the credentials specified for the Windows user to assign run 
options for processes or activities.

Step 1 Choose Definitions > Runtime Users, right-click and choose New > Windows User.

Step 2 Click the General tab and enter the required information.

Step 3 Click OK to close the dialog box and complete the procedure.

Creating a Microsoft Windows Event Trigger
Use the Windows Event trigger to specify the criteria for an event that must be matched execute a 
process. This criteria must be met before the process executes.

Step 1 Choose Definitions > Processes, right-click and choose Edit.

Step 2 Click the Triggers tab and choose New > Windows Event.

For details about creating a trigger, see Creating Triggers, page 11-1.

Automating Microsoft Windows Adapter Activities

Defining the Control Windows Service Activity

Use the Control Windows Service activity to specify the Windows service to which an action should be 
performed.

Note To ensure this Windows activity executes properly, verify that the Remote Registry service is enabled on 
your machine. 

Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Control Windows Service and drag and 
drop the activity onto the Workflow pane

Step 2 Click the Service tab to specify the Windows service and the action that should be performed against the 
service and the amount of time to wait before completion:

Step 3 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.
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Viewing Results

Click the Service tab to view the Windows service name the action was performed on. See also, Defining 
the Control Windows Service Activity.

Defining a Windows Ping Activity

Use the Ping activity to determine whether a specific IP address is accessible during network 
troubleshooting.

Step 1 In the Process Editor Toolbox, choose Networking > Ping and drag and drop the activity onto the 
Workflow pane.

Step 2 Click the Inputs tab and enter the host name or IP address of the server to be pinged.

Step 3 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Defining a Correlate Windows Event Activity

Use the Correlate Windows Events activity to specify the event log information that is to be located on 
the target.

Note To ensure this Windows activity executes properly, verify that the Remote Registry service is enabled on 
your machine. 

Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Correlate Windows Events and drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Event Criteria tab and specify the following event properties for the activity:

• Correlate events that occur within—Enter a value and select the time unit to indicate the time period 
in which the events should correlate before or after the process start time. The process start time is 
the default object used to correlate events.

– Time unit—Enter the start time value to specify the time period to correlate. Click the time unit 
link to change the time interval.

– Event occurrence—Click the link to determine whether the process start time is before or after 
the event occurs.

• Number of events to correlate—Select one of the following radio buttons to specify which events to 
correlate during the specified time period:

– All events in the above time frame—Select this radio button to correlate all events that occur 
within the specified time frame.

– Number of events—Select this radio button and then enter the number of events to correlate in 
the text field.

• Event criteria—Specify the following information as necessary:
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– Event log name—The name of the event log to be matched. Enter a name or expression in the 
text field.

– Event types—Check the check boxes for the types of events that must be matched. 

– Event source—Check the check box and then enter the source or click the Reference tool to 
select a variable to find event log entries by where they occurred.

– Event number—Check the check box and then enter the event ID or click the Reference tool to 
select a variable to find an event log entry by the event ID.

– Event description—Check the check box and then enter the description or click the Reference 
tool to select a variable to find an event log entry matching a description.

– Event computer—Check this check box to find an event log entry by matching a specific 
computer.  Enter the computer name in the text field that should be matched or click the 
Reference tool to select a variable for the field value.

Step 4 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the Event Criteria display-only tab to view the event log information that located on the target. 
See also, Defining a Correlate Windows Event Activity.

Defining the Copy Folders Activity

Use the Copy Folders activity to copy file folders from one location to another.

Step 1 On the Toolbox, select Copy Folders and drag and drop the activity onto the Workflow pane.

The Copy Folders property page displays.

Step 2 Click the Inputs tab to continue and specify the following information:

• Source – Files or folders to be copied

• Destination – Location to where the files or folders will be copied

Step 3 Click Save on the toolbar to save the activity properties.

Viewing Results

Click the instance display-only tab to view the source and destination of the files and to view the inputs 
and outputs of the activity. See also, Defining the Copy Folders Activity.

Defining the NSLookup Activity

Use the NSLookup activity for testing and troubleshooting DNS servers.

Step 1 On the Toolbox, select NSLookup and drag and drop the activity onto the Workflow pane.

The NSLookup property page displays.
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Step 2 Click the Inputs tab to continue and in the Destination field, enter the host name.

Step 3 Click Save on the toolbar to save the activity properties.

Viewing Results

Click the instance display-only tab to view the results of the DNS server test and troubleshoot for the 
activity. See also, Defining the NSLookup Activity.

Defining the Execute Windows Command Activity

Use the Execute Windows Command activity to specify a Windows command and the target directory 
on which to execute that command.

Note To ensure this Windows activity executes properly, verify that the Remote Registry service is enabled on 
your machine. 

Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Execute Windows Command and drag 
and drop the activity onto the Workflow pane.

Step 2 Click the Command tab to define the properties specific to the activity, including:

• Command line to execute on target—The actual command line to use to execute an activity on the 
specified local working directory on the Windows target computer. For example:

If the local working directory is C:\program files and the command is myapppath\app.exe, then the 
full path is:

C:\program files\myapppath\app.exe

• Local working directory on target—Enter the path to the local working directory on the Windows 
target where the command will be executed.

• Wait for command to complete or time out in—Enter a value or use the scroll buttons to specify the 
time frame to wait for the action to complete.

Note Select the time unit link to adjust the time unit (seconds, minutes, or hours).

• Fail on non-zero return code—Check this check box to configure the activity to fail when a return 
code having a non-zero value is received.

Step 3 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tab to view the Windows command and the target directory on which the 
command was executed. See also, Defining the Execute Windows Command Activity.
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Defining Uninstall Application Activity

Use the Uninstall Application activity to uninstall a specific application.

To define the Uninstall Application activity:

Step 1 On the Toolbox, select Uninstall Application and drag and drop the activity onto the Workflow pane.

The Uninstall Application property page displays.

Step 2 Click the Inputs tab to continue and in the Application Name field, enter the display name as it is shown 
in the Add/Remove Programs list.

Step 3 Click Save on the toolbar to save the activity properties.

Viewing Results

Click the instance display-only tabs to view the application that was uninstalled. See also, Defining 
Uninstall Application Activity.

Defining Trace Route Activity

Use the Trace Route activity to assist during network troubleshooting.

To define the Trace Route activity:

Step 1 On the Toolbox, select Trace Route and drag and drop the activity onto the Workflow pane.

The Trace Route property page displays.

Step 2 On the General tab, enter a Name and Description for the activity.

Step 3 Click the Inputs tab to continue and in the Destination field, enter the enter the address to be used as the 
trace route. Valid entries include: ipaddress, netbiosname, fully qualified domain name.

Step 4 Click the link to modify the option for the condition equation that is to be evaluated for a specific 
condition type (Time, Variable, Prior Process Instance or Compound).

Step 5 Click Save on the toolbar to save the activity properties.

Viewing Results

Click the instance display-only tabs to view the traced route. See also, Defining Trace Route Activity.

Defining the Execute Windows PowerShell Script Activity

Use this activity to specify a Windows command and the target directory on which to execute.

Note To ensure this Windows activity executes properly, verify that the Remote Registry service is enabled on 
your machine. 
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Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Execute Windows PowerShell Script and 
drag and drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the PowerShell Script tab to specify the command used to execute an activity on a local working 
directory on the Windows target:

• Local working directory on target—Enter the path to the local working directory on the Windows 
target where the script will be executed.

• Script arguments—Enter the collection of argument values for the script. Multi-line script 
arguments are not supported.

• Script to execute on target—Enter the actual script code to use to execute an activity on the specified 
local working directory on the Windows target computer.

• Use 32-bit version of PowerShell on 64-bit Windows target—Check this check box to indicate that 
the 32-bit PowerShell will be used to work against a 64-bit Windows target.

• Select this check box if script accesses remote resources—Check this check box to indicate that the 
script will access remote resources

• Fail on non-zero return code—Check this check box configure the activity to fail when a return code 
having a non-zero value is received.  

Step 4 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tabs to view the Windows command and the target directory on which 
the activity was executed. See also, Defining the Execute Windows PowerShell Script Activity.

Defining Copy Folders Activity

Use the Copy Folders activity to copy file folders from one location to another.

To define the Copy Folders activity:

Step 1 On the Toolbox, select Copy Folders and drag and drop the activity onto the Workflow pane.

The Copy Folders property page displays.

Step 2 Click the Inputs tab to continue and specify the following information:

• Source – Files or folders to be copied

• Destination – Location to where the files or folders will be copied

Step 3 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tabs to view the source and location of the copied folder. See also, 
Defining Copy Folders Activity
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Defining the Execute Windows Script Activity

Use the Execute Windows Script activity to specify a Windows script and the target directory on which 
to execute.

Note To ensure this Windows activity executes properly, verify that the Remote Registry service is enabled on 
your machine. 

Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Execute Windows Script and drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Script tab to define the properties specific to the activity, including:

• Local working directory on target—Enter the path to the local working directory on the Windows 
target where the script will be executed.

• Script arguments—Enter the collection of argument values for the script. Multi-line script 
arguments are not supported.

• Script to execute on target—Enter the actual script code to use to execute an activity on the specified 
local working directory on the Windows target computer.

• Wait for script to complete or time out in—Enter a value or use the scroll buttons to specify the time 
frame to wait for the action to complete.

Select the time unit link to adjust the time unit (seconds, minutes, or hours).

• Select this check box if script accesses remote resources—Check this check box to indicate that the 
script will access remote resources

• Fail on non-zero return code—Check this check box configure the activity to fail when a return code 
having a non-zero value is received. 

Step 4 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tabs to view the Windows script and the target directory on which the 
script was executed. See also, Defining the Execute Windows Script Activity

Adding a Script Argument

Script arguments are a property for Windows script and command activities. The Add button on these 
activities launches the Select Argument to Add dialog box for users to specify the script arguments to be 
added to the list on the specified Windows activity.

Step 1 On the appropriate Windows activity property page, click Add.

Step 2 Enter the appropriate script argument value for the script in the text field or click the Reference tool to 
select from the list.

• String Dialog box can contain standard string text
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• Secure String Dialog box can contain hidden string text or query encrypted value variables in the 
Insert Reference Variable dialog box

Step 3 Click OK.

The script argument is added to the command line argument list on the Windows activity property page.

Define a Stop a Windows Process Properties Activity

Use the Stop a Windows Process activity to stop a running Windows process.

To launch this activity, the runtime user should have local administrative rights to the target.

If the runtime user does not have these rights, the activity will fail and display a message that the process 
has encountered a failed node.

Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Stop Windows Process drag and drop the 
activity onto the Workflow pane.

Step 2 Click the Inputs tab and enter the Windows process ID for the appropriate running process to be stopped

Step 3 Click OK.

Viewing Results

Click the instance display-only tabs to view the process that was stopped. See also, Define a Stop a 
Windows Process Properties Activity.

Defining the Query Windows Events Activity

Use the Query Windows Events activity to specify information about the event logs that you want to find 
on the target. The activity searches the event log on the specified target and returns all matching events 
in the activity instance.

Note To ensure this Windows activity executes properly, verify that the Remote Registry service is enabled on 
your machine. 

Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Query Windows Events and drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Event Log tab to define the properties specific to the activity, including:

• Event types—The types of events that must be matched (Information, Warning, Error, Success 
Audit, Failure Audit).

• Event log name—The name in the text field of the event log to be matched.

• Event source—Check the check box and enter the source or click the Reference tool to select a 
variable to find event log entries by where they occurred.
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• Event number—Check the check box and enter the event ID or click the Reference tool to select a 
variable to find an event log entry by the event ID.

Note Use a comma to separate multiple event IDs in the field.

• Event description—Check this check box and enter the description in the field to find an event log 
entry to match the description.

• Event computer—Check this check box and enter the computer name in the text field to find an event 
log entry to match to a specific computer.

• Events generated within the last—Specify a time period in which the event occurred. Enter that 
value or scroll to the value and then select the time unit (minutes, hours, or days).

• Return the newest (latest) event only—Check this check box if you want only the most recent event 
to be returned.

Step 4 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tabs to view the event logs found on the target selected. See also, 
Defining the Query Windows Events Activity.

Defining the Read File Activity

Use the Read File activity to read the content a file that resides on a remote machine.

Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Read File and drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Read File tab and specify the following information:

• Local file name—Name of file as it was saved on the local computer.

Defining Get Folder Properties Activity

Use the Get Folder Properties activity to retrieve folder properties.

To retrieve folder properties:

Step 1 On the Toolbox, select Get Folder Properties and drag and drop the activity onto the Workflow pane.

The Get Folder Properties property page displays.

Step 2 Click the Inputs tab to continue, in the Folder field, specify the file path for the appropriate folder.

For example:

c:\

d:\program files
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h:\temp\

Step 3 Click Save on the toolbar to save the activity properties.

Viewing Results

Click the instance display-only tabs to view the properties of the selected folder. See also, Defining the 
Read File Activity.

Defining the Query Windows Performance Counter Activity

Note To ensure this Windows activity executes properly, verify that the Remote Registry service is enabled on 
your machine. 

Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Query Windows Performance Counter 
and drag and drop the activity onto the Workflow pane.

Step 2 Click the Counter tab to define the properties specific to the activity. You can either:

• Manually enter the following fields:

– Object name—A name of the category that contains the performance counter

– Counter name—The name of the performance counter

– Instance Name—The name of the instance specific to the selected counter

For instance names containing common wildcard expressions, add an escape value “\” to the 
expression. For example, the instance name java#1, should be java\#1.

• Click Browse to select the performance counter and the instance to be used in the Query Windows 
Performance Counter activity (see Selecting Performance Counters to Monitor).

Step 3 Click OK to return to the Query Windows Performance Counter property page.

Step 4 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tabs to view the properties specific to the Performance Counter activity. 
See also, Defining the Query Windows Performance Counter Activity.

Selecting a Performance Counter

Use the Select Performance Counter dialog box to select the performance counter and the instance to be 
used in the Query Windows Performance Counter activity.

Step 1 On the Query Windows Performance Counter property page, click Browse.

Step 2 Choose one of the following:
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• Use local computer counters—Select this option to use the performance counters available on your 
local computer.

• Select counters from computer—Select this option to use the performance counters available on the 
specified computer.

Step 3 From the Category name drop-down list, select the name of the category that contains the performance 
counter. 

Step 4 From the Counter list, select the counter that you want to use to collect data. 

Step 5 From the Instance list, select the instance from which you want to collect data.

Defining Restart Server Activity

Use the Restart Server activity to indicate the time to delay before restarting a server and the server 
restart notification message.

To define the Restart Server activity:

Step 1 On the Toolbox, select Restart Server and drag and drop the activity onto the Workflow pane.

The Restart Server property page displays.

Step 2 On the General tab, enter a Name and Description for the activity.

Step 3 Click the Inputs tab to continue and specify the following information:

• Delay – Time to wait before forcing the restart

• Note – Reason to restart server

Step 4 Click the link to modify the option for the condition equation that is to be evaluated for a specific 
condition type (Time, Variable, Prior Process Instance or Compound).

• TRUE/FALSE

Step 5 Click Save on the toolbar to save the activity properties.

Viewing Results

Click the instance display-only tabs to view the time delayed before restarting a server and the server 
restart notification message. See also, Defining Restart Server Activity.

Defining the Query Windows Registry Activity

Note To ensure this Windows activity executes properly, verify that the Remote Registry service is enabled on 
your machine. 

Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Query Windows Registry and drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.
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Step 3 Click the Registry tab to define the properties specific to the activity, including:

• Registry hive—The name of the registry hive where the registry key and value are located

• Registry key—Enter the registry key. You can either:

– Enter the key manually or select a defined variable that represents the registry key to be used to 
read data. For example:

software\microsoft\windows nt\currentversion

– Click Browse to select the registry key (see Selecting a Registry Key, page 12-244).

• Check for key existence only—Query the registry to determine whether the key exists

• Read from value name—Read the value associated with the specified registry key

• Options for 64-bits Windows targets—Select one of the following options to query the windows 
registry:

– Query on 32-bit registry section

– Query on 64-bit registry sections

– Query on both 32-bit and 64-bit registry sections

Step 4 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tabs to view the results of the register query. See also, Defining the Query 
Windows Registry Activity.

Defining the Query Windows Service Activity

Use the Query Windows Service activity to produce the current state of the service, the startup type of 
the service, and specifies the Windows service to be queried.

Note To ensure this Windows activity executes properly, verify that the Remote Registry service is enabled on 
your machine. 

Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Query Windows Service and drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Service tab to specify the name of the Windows service to be queried.

Step 4 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tabs to view the current state of the service, the startup type of the 
service, and the Windows service queried. See also, Defining the Query Windows Service Activity.
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Defining the Create Folder Activity

Use the Create Folder activity to create a file path for the folder.

To launch this activity, the runtime user must have local administrative rights to the target.

Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Create Folder and drag and drop the 
activity In the Workflow pane.

Step 2 Click the Registry tab to define the properties specific to the activity, including:

• Registry hive—The name of the registry hive where the registry key and value are located

• Registry key—Enter the registry key. You can either:

Step 3 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tabs to view the file path for the folder created. See also, Defining the 
Create Folder Activity.

Selecting a Registry Key

Use the Select Registry Key dialog box to select the registry key to be used in the Query Windows 
Registry and the Update Windows Registry activities.

Step 1 On the Query Windows Registry property page, click Browse.

Step 2 Choose one of the following:

• Use local computer registry—Select this option to use the available registry keys on your local 
computer.

• Select registry key from computer—Select this option to use the registry keys available on the 
specified computer.

Step 3 Under Registry key, select the registry key from the current registry hive.

Defining the Update Windows Registry Activity

Use the Update Windows Registry activity to specify the information required to update the existing 
information from the registry keys.

Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Update Windows Registry and drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Registry tab to specify the registry information (see Defining the Query Windows Registry 
Activity, page 12-242).
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Step 4 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tabs to view the information used to update the existing information from 
the registry keys. See also, Defining the Update Windows Registry Activity.

Defining the Update Windows Service Activity

Use the Update Windows Service activity to specify the Windows service to configure with a new startup 
mode.

Note To ensure this Windows activity executes properly, verify that the Remote Registry service is enabled on 
your machine. 

Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Update Windows Service and drag and 
drop the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Service tab to specify the name of the Windows service and the new startup mode (see Defining 
the Query Windows Service Activity, page 12-243).

Step 4 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tabs to view the Windows service configured with a new startup mode. 
See also, Defining the Update Windows Service Activity.

Defining the Write File Activity

Use the Write File activity to write content into a file that resides on a remote machine.

Note To ensure this Windows activity executes properly, verify that the Remote Registry service is enabled on 
your machine. 

Step 1 In the Process Editor Toolbox, choose Microsoft Windows > Write File and drag and drop the activity 
onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Write File tab and specify the following information:

• Local file name—File path including the name of the file in which the contents are written. For 
example:
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C:\Documents and Settings\user name\My Documents\file name

• Content—Enter the appropriate contents to include in the file.

• Encoding—Select the appropriate encoding class for the file, as necessary:

– ASCII—An encoding for the ASCII (7-bit) character set

– Unicode—An encoding for the UTF-16 format using the little endian byte order

– UTF-7—An encoding for the UTF-7 format and is less robust and secure than UTF-8, UTF-16, 
or UTF-32

– UTF-8—An encoding for the UTF-8 format

– UTF-32—An encoding object for the UTF-32 format using the little endian byte order

• Options—Select the appropriate action to take when saving the file.

Step 4 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tabs to view the content written into a file that resides on a remote 
machine. See also, Defining the Write File Activity.

Networking Adapter

Defining the Convert Integer to IP Address Activity 

Use the Convert Integer to IP Address activity to change an integer to an IP address.

Step 1 In the Process Editor Toolbox, choose Networking > Convert Integer to IP Address and drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Inputs tab to specify the integer value to be returned as an IP address.

• Integer Representation—Integer value to be returned as an IP address.

Example

0 returns an IP address of 0.0.0.0

3232271626 returns and IP address of 192.168.141.10

Step 4 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tabs to view the integer changed to an IP address. See also, Defining the 
Convert Integer to IP Address Activity.
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Defining the Convert IP Address to Integer Activity 

Use the Convert IP Address to Integer activity to change an IP address to an integer.

Step 1 In the Process Editor Toolbox, choose Networking > Convert IP Address to Integer and drag and drop 
the activity onto the Workflow pane.

Step 2 Click the General tab and enter the appropriate information.

Step 3 Click the Inputs tab to specify the IP address that to be returned as an integer.

• IP Address—IP address to be returned as an integer

Step 4 Complete the appropriate information in the remaining tabs as necessary, then click Save to complete 
the activity definition.

Viewing Results

Click the instance display-only tabs to view the IP address that changed to an integer. See also, Defining 
the Convert IP Address to Integer Activity.

Cisco Process Orchestrator Adapter Help for Terminal Adapter

Overview
The Terminal adapter provides the functionality to execute commands, scripts and session-based 
activities against a system or network device using SSH or Telnet. While SSH is more secure than telnet, 
many environments use a telnet connection and using a SSH connection against such devices will not be 
possible. The Terminal adapter was improved to allow users the flexibility to execute against those 
devices.

The Terminal adapter allows Cisco Process Orchestrator to run commands and script activities on a 
system or network device that has Secure Shell (SSH) enabled. The Terminal adapter also contains three 
session-based activities which allow users to open new SSH/Telnet sessions and interact with the 
previously opened sessions.

SSH and Telnet leverage the same command execution activities differentiated by the target type they 
are deployed against.  For example, an IOS target can have SSH or telnet optionally configured.

Cisco Process Orchestrator requires SFTP to be configured on the Unix/Linux system in order to execute 
SSH activities. SFTP is not needed for the SSH/Telnet Terminal Session activities.

The information in this online help is intended to provide information on using the objects provided by 
the Terminal adapter including instructions for viewing Terminal adapter properties, defining device 
targets and activities, completing the property pages for each specific activity, and viewing the activity 
results.
12-247
Cisco Process Orchestrator 3.3 User Guide

 



 

Appendix 12      Using Adapters
  Cisco Process Orchestrator Adapter Help for Terminal Adapter
Configuring Terminal Adapter

Configuring SSH Version 2.0 Support for Cisco IOS Devices

To properly execute Cisco IOS processes and activities against the Terminal adapter, the IOS device 
cannot run using SSH v1.0. The IOS devices should be configured to run SSH v2.0. The Secure Shell 
Version 2 Support feature allows users to configure Secure Shell (SSH) Version 2.

Before configuring SSH, download the k9 (Triple Data Encryption Standard [3DES]) software image 
from Cisco IOS Release 12.3(4)T, 12.2(25)S, or 12.3(7)JA onto your router.

Configuring an Expect Template

Because creating Terminal targets can be complex, the expect template provides users with limited 
knowledge of expects a simpler method to complete the target configuration properties. Expect templates 
contain default configuration sequence of expects and elevated privilege command expects.

The Expect Template tab on the Terminal Adapter dialog box displays the list of default expect template 
configurations that have been created using the Expect Templates dialog box. From this tab, users can 
create, modify, and delete expect templates.

Expect templates can be imported and exported just like other objects in an automation pack. Imported 
expect templates from an automation pack can only be modified by the author of that automation pack. 
A Process Orchestrator content-author can only export those expect templates created by that content 
author.

To configure an expect template:

Step 1 On the Administration > Adapters view, highlight Terminal Adapter, right-click and choose 
Properties.

The Terminal Adapter Properties dialog box displays.

Step 2 Click the Expect Templates tab to continue.

Step 3 Click New > Expect Template.

The New Expect Template Properties dialog box displays.

Step 4 Click the Expect Template tab to configure the default expect values.

Step 5 Complete the following information for the connection patterns.

• Prompt—Enter the system prompt pattern in regular expression

• Error—Enter the error message pattern in regular expression

• Admin Prompt—Enter the admin prompt pattern in regular expression

Step 6 To elevate the privilege command for login expects:

• Elevating Privilege command—Check this check box and in the text field, enter the command or 
select the reference variable containing the command to elevate the privilege for the expect.

• Elevating Privilege expects—Use this section to view and/or define the login expect sequence for 
the elevating privilege command expects.

Step 7 Click OK to close the dialog box.
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Enabling the FIPS-Compliance JCE Provider

The Terminal Adapter ships with a FIPS-compliant Java Crypto Extension (JCE) provider to connect to 
FIPS-compliant network devices, such as the ACS 5.2 server. This provider includes encryption 
algorithms that may not be supported by Java that are also useful in high-security scenarios.

To enable the FIPS-compliance algorithm:

Step 1 On the Administration > Adapters view, highlight Terminal Adapter, right-click and choose 
Properties.

The Terminal Adapter Properties dialog box displays.

Step 2 Click the Advanced tab to continue.

Step 3 Under FIPS-Compliance, check the Only use FIPS-compliant encryption algorithm check box to 
indicate that only FIPS-compliant encryption algorithms should be used by the Terminal adapter.

If this check box is checked, then any SSH targets that uses an unsupported algorithm will not be 
accessible in Process Orchestrator.

Step 4 Click OK to close the dialog box.

 

Configuring Default Host-Based Authentication Keys

Users can define default host public and private keys on the Advanced tab of the Terminal Adapter dialog 
box. This tab allows users to select a specific private key for the target. The private key will be used for 
host-based authentication if a target does not specify its own keys.

The Authentication tab on a Target dialog box indicates whether the target should allow authentication 
based on the host system of the user and the user name on the remote host system.

To configure default host-based authentication keys:

Step 1 On the Administration > Adapters view, highlight Terminal Adapter, right-click and choose 
Properties.

The Terminal Adapter Properties dialog box displays.

Step 2 Click the Advanced tab to configure the authentication keys.

• Private key—To the right of the display-only field, click Browse to launch the Load Private Key 
dialog box to select a private key

• Public key—To the right of the display-only field, click Browse to launch the Load Public Key 
dialog box to select a public key.

• Public key file content—Enter the SSH public key request message to the remote SSH server that 
will authenticate the request against the stored public key.

Step 3 Click OK to close the dialog box.

See Also

Selecting a Private Key

Selecting a Public Key
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Selecting a Private Key

Use the Load Private Key dialog box to select the private key file to be used to provide authentication of 
a public key. If OpenSSH is installed, the key pair is generated by the command line tool "ssh-keygen."

Copy the file to a location where it is accessible from the Process Orchestrator server, then follow the 
steps to load the private key.

The private key file should reside on the same machine as the Process Orchestrator server.

To configure a private key

Step 1 On the Administration > Adapters view, highlight Terminal Adapter, right-click and choose 
Properties.

The Terminal Adapter Properties dialog box displays.

Step 2 Click the Advanced tab to select the private key to authenticate the public key.

Step 3 On the Private Key field, click Browse.

The Load Private Key dialog box displays.

• Passphrase to the private key file—Check this check box and in the text field, enter the passphrase 
to be used to  the private key file.

The passphrase is used to protect the private key file when the private key is generated.

• Select a private key file—To the right of the display-only field, click Browse to launch the Open 
dialog box to locate the private key file.

The most commonly used private key file format is "RSA PRIVATE KEY." The private key file 
should reside on the same machine as the Process Orchestrator server. The default location of the 
file is under the unix user's home directory:

~/.ssh/id_rsa

The content of the private key file will be displayed after the passphrase is d against the private key 
file content.

Step 4 Click OK to close the dialog box.

The private key displays on the Private key field on the Advanced tab. The content of the private key file 
will be displayed except in the Load Private File dialog box in order for the user to verify the content.

Selecting a Public Key

A public key is a value provided by some designated authority as an encryption key that, combined with 
a private key derived from the public key, can be used to effectively encrypt messages and digital 
signatures.

Use the Load Public Key dialog box to select a public key to be used by the Terminal adapter.

To configure a public key

Step 1 On the Administration > Adapters view, highlight Terminal Adapter, right-click and choose 
Properties.

The Terminal Adapter Properties dialog box displays.

Step 2 Click the Advanced tab to select the private key to authenticate the public key.
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Step 3 On the Public Key field, click Browse.

The Load Public Key dialog box displays.

Step 4 On the Load Private Key dialog box, select the public key file.

• Select a public key file—To the right of the display-only field, click Browse to launch the Open 
dialog box to locate the public key file.

Step 5 Click OK to close the dialog box.

The public key displays on the Public key field on the Advanced tab.

Supported Cisco Appliances

The following table contains the list of Cisco appliances supported by the content provided by Process 
Orchestrator 3.3 to provide cloud and network support automation functionality. While specific Process 
Orchestrator content only works with the following devices, Process Orchestrator can work against any 
TELNET or SSH 2.0 device.  

• Cisco ACE Application Control Engine Module—a next-generation load-balancing and 
application-delivery solution

Learn more on the Cisco ACE Application Control Engine Module Data Sheet.

• Cisco ASA 5580 Adaptive Security Appliances—Delivers multigigabit security services for large 
enterprise, data center, and service-provider networks in a robust, 4-rack-unit form factor

Learn more on the Cisco ASA 5500 Series Adaptive Security Appliances Data Sheet.

• Cisco Catalyst 6500 Series Network Analysis Module—Offers unparalleled visibility into network 
performance, and helps you simplify the application delivery challenges of today's dynamic, 
evolving global organizations

Learn more on the Cisco Catalyst 6500 Series Network Analysis Module

• Cisco Catalyst 6500 Series Firewall Services Module—A high-speed, integrated firewall module 
which provides the fastest firewall data rates in the industry

Learn more on the Cisco Catalyst 6500 Series Firewall Services Module Data Sheet.

See Also

Supported Cisco Routers

Supported Cisco Switches

Supported Cisco Routers

The following table contains the list of Cisco routers supported by the content provided by Cisco Process 
Orchestrator 3.3 to provide cloud and network support automation functionality. While specific Cisco 
Process Orchestrator content only works with the following devices, Cisco Process Orchestrator can 
work against any TELNET or SSH 2.0 device.

• Cisco 2800 Series Integrated Services Routers—Designed for wire-speed delivery of highly secure 
concurrent services and can accommodate multiple T1/E1 connections.

Learn more on the Cisco 2800 Series Integrated Services Router Data Sheet.

• Cisco 7200 Series Routers—Universal services aggregation router for enterprise and service 
provider edge applications
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Learn more on the Cisco 7200 Series Routers Overview Data Sheet.

• Cisco 7600 Series Routers—Offers integrated, high-density Ethernet switching, carrier-class 
IP/MPLS routing, and 10-Gbps interfaces

Learn more on the Cisco 7600 Series Data Sheet.

• Cisco PIX 515E Security Appliance—Provides robust user and application policy enforcement, 
multi-vector attack protection, and secure connectivity services through a wide range of rich 
security and networking services

Learn more on the Cisco PIX 515E Security Appliance Data Sheet.

See Also

Supported Cisco Appliances

Supported Cisco Switches

Supported Cisco Switches

The following table is a breakdown of the Cisco series switches supported by the content provided by 
Cisco Process Orchestrator 3.3 to provide cloud and network support automation functionality. While 
specific Cisco Process Orchestrator content only works with the following devices, Cisco Process 
Orchestrator can work against any TELNET or SSH 2.0 device.

• Cisco Catalyst 2950 Series Switches—Fixed-configuration, stackable standalone switch that 
provides wire-speed Fast Ethernet and Gigabit Ethernet connectivity

Learn more on the Cisco Catalyst 2950 Series Switches Data Sheet.

• Cisco Catalyst 3750 Series Switches—Eases deployment of converged applications and adapts to 
changing business needs by providing configuration flexibility, support for converged network 
patterns, and automation of intelligent network services configurations

Learn more on the Cisco Catalyst 3750 Series Switches Data Sheet.

• Cisco Catalyst 4500 Series Switches—Delivers a high-performance, highly secure, and mobile user 
experience for enterprise wiring closets, access and core layers through innovations in collaboration, 
security, resiliency, and EnergyWise

Learn more on the Cisco Catalyst 4500 Series Switches Data Sheet.

• Cisco Catalyst 6500 Series Switches—Delivers secure, converged, end-to-end services, from the 
wiring closet to the core network, the data center, and the WAN edge

Learn more on the Cisco Catalyst 6500 Series Switches Data Sheet.

• Nexus 1000V Series Switches—Ensures consistent, policy-based network and security services to 
all virtual machines (VMs) in your data center

Learn more on the Cisco Nexus 1000V Series Switches Data Sheet.

• Nexus 2000 Series Fabric Extenders—Simplifies data center architecture and operations to meet 
customers' business and application needs

Learn more on the Cisco Nexus 2000 Series Fabric Extenders Data Sheet.

• Nexus 5000 Series Switches—Helps transform the data center with innovative, standards-based, 
multilayer, multiprotocol, and multipurpose Ethernet-based fabric

Learn more on the Cisco Nexus 5000 Series Switches Data Sheet.

• Nexus 7000 Series Switches—Modular switching system designed to deliver 10 Gigabit Ethernet 
and unified fabric in the data center
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Learn more on the Cisco Nexus 7000 Series Switches Data Sheet.

See Also

Supported Cisco Routers

Supported Cisco Switches

Managing Terminal Objects

Defining a Public-key Authenticated Admin Runtime User

Use the Public-key Authenticated Admin Runtime User dialog box to define the user credentials required 
to allow public key authentication and an administrative password is required to perform privileged 
operations.

If a target has set up public key authentication on the remote SSH server, the private key of the 
Public-key Authenticated Admin Runtime User will be used to form the SSH authentication request. The 
request is then authenticated against the stored public key on the remote server.

If the target does not allow public key authentication, the SSH authentication will fail.

To create a Public-key Authenticated Admin Runtime User:

Step 1 On the Definitions > Runtime Users view, right-click and choose New > Public-key Authenticated 
Admin Runtime User.

The New Public-key Authenticated Admin Runtime User Properties dialog box displays.

Step 2 Click the General tab to specify the requested information.

• Display name—Enter the display name for the runtime user.

This field is populated with the information specified in the User name text field, but can be 
overwritten by the user.

• Type—Display only. Type of object

• Owner—User name of the owner of the object. This is typically the person who created the object.

• User name—The user name assigned to access the device

• Private key—To the right of the display-only field, click Browse to launch the Load Private Key 
dialog box to select a private key.

Use the Load Private Key dialog box to select the private key file to be used to provide authentication 
of a public key. The private key file should reside on the same machine as the Process Orchestrator 
server.

• Admin password—Check the Admin password check box and then enter the password assigned to 
access Privileged EXEC mode on the device.

The Privileged EXEC mode provides the highest level of commands to users.

• Description—Brief description of the runtime user

Step 3 Click OK to close the dialog box.
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Defining a Public-key Authenticated Admin Runtime User

Use the Public-key Authenticated Admin Runtime User dialog box to define the user credentials required 
to allow public key authentication and an administrative password is required to perform privileged 
operations.

If a target has set up public key authentication on the remote SSH server, the private key of the 
Public-key Authenticated Admin Runtime User will be used to form the SSH authentication request. The 
request is then authenticated against the stored public key on the remote server.

If the target does not allow public key authentication, the SSH authentication will fail.

To create a Public-key Authenticated Admin Runtime User:

Step 1 On the Definitions > Runtime Users view, right-click and choose New > Public-key Authenticated 
Admin Runtime User.

The New Public-key Authenticated Admin Runtime User Properties dialog box displays.

Step 2 Click the General tab to specify the following information.

Step 3 Click OK to close the dialog box.

Defining a Network Device Module Target
Some Cisco network devices are chassis systems that can hold other network devices such as ACE, 
FWSM, on boards that plug into the chassis.

Use the Network Device Module to create a network device module target which can be used as a 
dependent of a terminal target as well as an independent network device target that can be used by 
network processes for execution.

To create a Network Device Module:

Step 1 On the Definitions > Targets view, right-click, and choose New > Network Device Module.

The New Network Device Module Wizard displays.

Step 2 On the General Information panel, enter the appropriate information, and click Next.

Step 3 On the Terminal Connection panel, enter the appropriate target information to specify the connection 
information to the appropriate server, and click Next.

• Chassis system—From the drop-down list, select the appropriate terminal target on which the 
network Switch numberCheck the check box and in the text field, enter the appropriate switch 
number for the chassis system.

• Slot number—Enter the slot number on which the network device module resides.

• Process Id—Enter the processor Id on which the network device module resides.

• Command to access—Enter the session command to access the network device module.

The default command is session slot [Slot Number] processor [Processor Id].

• Prompt prefix—Enter the command prompt prefix that will be used by the device type 
configurations and expects when issuing commands and connecting to the device.
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Adding a regex character, such as $, >, and #, at the end of a prompt in the Prompt Prefix field ins 
the command prompt prefix.

Regular expressions should be placed in the appropriate Terminal Interaction Pattern fields. See the 
Connections Patterns panel to customize the interaction patterns.

Example

If you connect to the terminal, and the prompt is Cisco_7606#, enter the regular expression that will 
match the entire prefix (before #) using any of the following expressions:

– CISCO.*

– .*7606

– CISCO_7606

• Default runtime user—Select the default runtime user account that contains the credentials to 
connect to the target.

Step 4 On the Terminal Interaction Patterns panel, configure the terminal interaction patterns for the target, and 
click Next.

• Use patterns common for the following device—Select this radio button to choose one of the 
pre-defined expect templates from the drop-down list.

– Cisco IOS Device—Select this option to use the default pattern values used by the device during 
the completion of a session command.

– Unix—Select this option to use the default pattern values indicated for a Unix device during the 
completion of a session command.

• Customize patterns for this connection—Check this check box to customize the default values for 
the selected expect template. Click Next to continue to the Connection Patterns panel.

If the check box is unchecked, then clicking Next will navigate to the Completion panel.

You can specify terminal interaction patterns on this panel.  If user does not choose to customize 
patterns from a selected expect template, the user will be taken to the Completion panel directly after 
the target is verified. If user chooses to customize patterns, the next panel will be Connection 
Patterns panel.

Step 5 On the Connection Patterns panel, configure the terminal interaction patterns for the target, and click 
Next.

• Prompt pattern—Enter the system prompt pattern in regular expression.

• Error pattern—Enter the error message pattern in regular expression.

• Admin prompt pattern—Enter the admin prompt pattern in regular expression.

Step 6 On the Login Expects panel, modify the list of sequence expects for the target connection, as necessary, 
and click Next.

• Add—Click Add to launch the Expect Dialog Box to configure the expect parameters to be added 
to the list.

• Remove—Highlight the appropriate item and click Remove to remove the item from the list.

• Edit—Highlight the appropriate item and click Edit to launch the Expect Dialog Box to modify the 
expect parameters in the list.

• Move Up—Highlight the appropriate item and then click this button to move the item up list.

• Move Down—Highlight the appropriate item and then click this button to move the item down list.

Elevating Privilege command
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To modify the list of expects, use the following buttons:

• Elevating Privilege command—Check this check box and in the text field, enter the command or 
select the reference variable containing the command to elevate the privilege for the expect.

• Elevating Privilege expects—Use this section to view and/or define the login expect sequence for 
the elevating privilege command expects.

The Completing the New [Network Device Module] Wizard panel displays the connection information 
about the device target added to Process Orchestrator.

Step 7 Verify the information on the panel and click Finish to close the wizard.

Defining a Terminal Target
Use the Terminal target to specify the connection information used to access the device used for 
processes to run against. The connection information includes IP address or host name, protocol type, 
port and the runtime user credentials to access the device.

To create a terminal target:

Step 1 On the Definitions > Targets view, right-click, and choose New > Terminal.

The New Terminal Wizard displays.

Step 2 On the General Information panel, enter the appropriate information, and click Next.

Step 3 On the Terminal Connection panel, enter the appropriate target information to specify the connection 
information to the appropriate server, and click Next.

• Protocol—Select the appropriate protocol from the drop-down list.

– SSH

– Telnet

• Host name—Host name or IP address of the network device

• Port—Port number used to access the appropriate terminal target port (Default: SSH server: 22, 
Telnet server: 23)

• Prompt prefix—Enter the command prompt prefix that will be used by the device type 
configurations and expects when issuing commands and connecting to the device.

Adding a regex character, such as $, >, and #, at the end of a prompt in the Prompt Prefix field ins 
the command prompt prefix.

Regular expressions should be placed in the appropriate Terminal Interaction Pattern fields. See the 
Connections Patterns panel to customize the interaction patterns.

For example:

If you connect to the terminal, and the prompt is Cisco_7606#, enter the regular expression that will 
match the entire prefix (before #) using any of the following expressions:

– CISCO.*

– .*7606

– CISCO_7606
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• Use credentials of the following runtime user—Select the default runtime user account that contains 
the credentials to connect to the target.

• Use patterns common for the following device—Select this radio button to choose one of the 
pre-defined device targets from the drop-down list.

– Cisco IOS Device—Select this option to use the default pattern values used by the device during 
the completion of a session command.

– Unix—Select this option to use the default pattern values indicated for a Unix device during the 
completion of a session command.

• Customize patterns for this connection—Check this check box to customize the default values for 
the selected device type.

If this check box is unchecked, then clicking Next will navigate to the Host-Based Authentication 
panel.

Step 4 On the Terminal Interaction Patterns panel, configure the terminal interaction patterns for the target, and 
click Next.

You can specify terminal interaction patterns on this panel.  If user does not choose to customize patterns 
from a selected expect template, the user will be taken to the Completion panel directly after the target 
is verified. If user chooses to customize patterns, the next panel will be Connection Patterns panel. If the 
Customize patterns for this connection check box is unchecked, skip to Step 11 for Host-Based 
Authentication instructions.

Step 5 On the Connection Patterns panel, configure the terminal interaction patterns for the target, and click 
Next.

Step 6 On the Login Expects panel, modify the list of sequence expects for the target connection, as necessary, 
and click Next.

Elevating Privilege command

To modify the list of expects, use the following buttons:

• Elevating Privilege command—Check this check box and in the text field, enter the command or 
select the reference variable containing the command to elevate the privilege for the expect.

• Elevating Privilege expects—Use this section to view and/or define the login expect sequence for 
the elevating privilege command expects.

Step 7 On the Host-Based Authentication panel, specify whether the target should allow authentication based 
on the host system of the user and the user name on the remote host system, and click Next.

You can define default host public and private keys on the Terminal Adapter settings. This panel allows 
users to select a specific private key for the target. The private key will be used for host-based 
authentication if a target does not specify its own keys.

• Use host-based authentication—Check this check box to indicate that host-based authentication will 
be used with this target.

If this check box is unchecked, then host-based authentication will not be used.

• Use the default host keys—This check box becomes enabled after the Use host-based authentication 
check box is checked.

Check this check box to indicate the host keys defined on the Terminal Adapter property page will 
be used for this target.

If this check box is unchecked, then the user will need to load the appropriate private key to be used 
to  this target.
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• Private key—This box becomes enabled only if the Use the default host keys check box is 
unchecked.

To the right of the display-only field, click Browse to launch the Load Private Key dialog box to 
select a private key.

Step 8 On the Network Modules panel, review the list of network modules assigned to the terminal target. These 
network device modules are considered dependents of the terminal target.

• Display name—Name of the network device

• Enabled—Indicates whether the network device module is enabled (True) or disabled (False). A 
disabled network device module is unavailable for execution.

• Switch number—Switch number for the chassis system

• Slot number—Slot number on which the network device module resides

• Process Id—Processor Id on which the network device module resides

If the appropriate network device module is not displayed, users can create a network device module 
target from within this wizard to be used as a dependent of the terminal target.

The Completing the New [Terminal] Wizard panel displays the connection information about the device 
target added to Process Orchestrator.

Step 9 Verify the information on the panel and click Finish to close the wizard.

Defining a Unix Linux System Target
Use the Unix/Linux Connection tab to specify the connection information for the SSH server used for 
processes to run against. The Unix/Linux System target also supports Telnet protocol and session based 
activities.

To properly run script and command activities against Unix/Linux system targets, Process Orchestrator 
requires the Secured File Transfer Protocol (SFTP) to be enabled on the Unix/Linux system. It is not 
needed for the SSH/Telnet Terminal Session activities.

To define:

Step 1 On the Definitions > Targets view, right-click, and choose New > Unix/Linux System.

The New Unix/Linux System Properties dialog box displays.

Step 2 On the General tab, enter the appropriate information.

Step 3 Click the Connection tab to enter the appropriate target information to specify the connection 
information to the appropriate SSH server.

• Host name—Host name or IP address of the selected server

• Port—Port number used to access the selected protocol

• Prompt prefix—Enter the command prompt prefix that will be used by the device type 
configurations and expects when issuing commands and connecting to the device.

Adding a regex character, such as $, >, and #, at the end of a prompt in the Prompt Prefix field ins 
the command prompt prefix.

Regular expressions should be placed in the appropriate Terminal Interaction Pattern fields. See the 
Advanced tab to customize the interaction patterns.
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For example:

Unix system prompt prefix is defined by the user default login script. it usually contains username, 
node name or current directory name. If the user does not define anything, the prompt prefix is 
empty.

If you connect to the terminal, and the prompt is jsmith@TBD-SH03-IT ~$, enter the regular 
expression that will match the entire prefix (before #) using any of the following expressions:

.*TBD-SH03-IT.*

\[\w+@TBD-SH03-IT.*\]

• Default runtime user—Select the default runtime user account that contains the credentials to 
connect to the target.

• Enable code injection prevention—Check this check box to enable the protection which prevents 
code that is injected to exploit the security vulnerability.

• Maximum allowed concurrent sessions—Enter the maximum allowed open sessions to run 
concurrently. (Default: 3)

Step 4 Click the Authentication tab to specify whether the target should allow authentication based on the host 
system of the user and the user name on the remote host system.

You can define default host public and private keys on the Terminal Adapter settings. This tab allows 
you to select a specific private key for the target. The private key will be used for host-based 
authentication if a target does not specify its own keys.

Step 5 Click the Advanced tab to configure the interaction patterns for the target.

Step 6 Click the Open Sessions tab to display the information about sessions currently opened on the target and 
sessions waiting to be opened.

To avoid the negative impacts on performance and manage resource usage, the Terminal Adapter has a 
limit on the maximum total live sessions. When the total live sessions reaches the maximum limits, the 
activity that needs to open a new session will wait until a live session is closed.

The network device module, by default, inherits the maximum allowed sessions from its chassis system. 
Users cannot adjust the value on the network device module more than value set by the chassis system. 
Any terminal activities executed against a network device module target will also count towards its 
chassis system session statistics.

Each displayed list will contain one entry for each opened session.

• Process Name—Name of the process that opened the session

• Process Executor—Target against which the process is executing

• Process Start Time—Time when the process was started

• Activity Name—Name of the Open Terminal Session activity that opened the session

• Activity Start Time—Time when Open Terminal Session activity started running

Step 7 Click OK.
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Configuring Total Concurrent Sessions
You can specify the limits on how many concurrent sessions can be run against a target. When the total 
live sessions reach limits, the activity that needs to open a new session will wait until a live session is 
closed. The waiting Open Terminal Session activities will be display in the target’s Open Sessions 
property page.

The Network Device Module inherits the max allowed sessions from its chassis system by default. Users 
cannot adjust the value on the network device module more than value set by the chassis system. 
Therefore users can only modify the amount concurrent sessions against the network device module 
through its chassis system.

Due to the nature of network device management, Process Orchestrator may have a very large number 
of Process Orchestrator Terminal Adapter targets and concurrent running Process Orchestrator 
processes. Users can specify the total sessions allowed against the Terminal Adapter in the configuration 
file to minimize the negative impact on performance and resource usage.

To configure the maximum sessions against a target

Step 1 On the Definitions > Targets view, highlight the appropriate target, right-click and choose Properties.

The [Target] Properties dialog box displays.

Step 2 Click the Connection tab to modify the maximum allowed sessions.

Step 3 In the Maximum allowed concurrent session field, enter the maximum allowed open sessions to run 
concurrently. (Default: Terminal target: 3, Unix/Linux target: 1)

Step 4 Click OK.

Adding an Expect Parameter

Use the Expect dialog box to configure the expect parameters to manage the Terminal target command 
output. The Add button on the device activities and targets launch the Expect dialog box for users to 
configure the expect parameters to be added to the list of expects and matched in the output.

To add a expect parameter:

Step 1 On the Execute Terminal property page, click Add.

The Expect dialog box displays.

Step 2 Complete the following fields, as necessary.

• Name—Enter the name of the case defining what to expect

• Regular Expression—Enter characters to match in the terminal output

• Match Case—Check the check box to indicate whether the regular expression is case-sensitive

Step 3 Click OK.
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Removing an Expect Parameter

To remove a configured expect parameter, highlight the appropriate item, and then click Remove. The 
selected parameter is removed from the list of expect parameters on the tab.

Viewing Terminal Target Properties

The property pages may display as display-only if the target definition is shipped as part of the product 
or the user does not have the appropriate rights.

To view Target properties:

Step 1 On the Definitions > Targets view, highlight the appropriate target, and right-click and choose 
Properties.

The Properties dialog box displays. The tabs displayed depend on the selected target.

Step 2 Click the following tabs to view the target properties:

• Connection—Displays the connection properties for the defined target

• Authentication—Displays properties used to indicate the target uses host-based authentication and 
the private/public key for host-based authentication provided by the user.

• Advanced—Displays the settings for the interaction patterns

• Network Modules—Displays the list of network modules assigned to the terminal target

• Open sessions—Displays information about sessions currently opened on the target and sessions 
waiting to be opened

• Extended Properties—Displays the list of all target properties defined for this target type

Step 3 Click OK.

See Also

Configuring an Expect Template

Configuring Default Host-Based Authentication Keys

Viewing Network Device Modules

Use the Network Device Module tab to view the list of network modules assigned to the target. These 
network device modules are considered dependents of the chassis system. Therefore, network device 
modules can only be removed from within the chassis system.

If the appropriate network device module is not displayed, users can create a network device module 
target from within this wizard to be used as a dependent of the chassis system.

To view the target network modules

Step 1 On the Definitions > Targets view, highlight the appropriate target, right-click and choose Properties.

The Properties dialog box displays.

Step 2 Click the Network Modules tab to review the list of network device modules dependent on the target.

• Display name—Name of the network device
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• Enabled—Indicates whether the network device module is enabled (True) or disabled (False). A 
disabled network device module is unavailable for execution.

• Switch number—Switch number for the chassis system

• Slot number—Slot number on which the network device module resides

• Process Id—Processor Id on which the network device module resides

Step 3 Click OK.

See Also

Defining a Network Device Module Target

Viewing Target Open Sessions

Use the Open Sessions tab to review the information about sessions currently opened on the target and 
sessions waiting to be opened.

To configure the amount of total open sessions, see Configuring Total Concurrent Sessions.

To view the target open sessions

Step 1 On the Definitions > Targets view, highlight the appropriate target, right-click and choose Properties.

The Properties dialog box displays.

Step 2 Click the Open Sessions tab to review the information about sessions currently opened on the target and 
sessions waiting to be opened.

• Process Name—Name of the process that opened the session

• Process Executor—Target against which the process is executing

• Process Start Time—Time when the process was started

• Activity Name—Name of the Open Terminal Session activity that opened the session

• Activity Start Time—Time when Open Terminal Session activity started running

Step 3 Click OK.

See Also

Configuring Total Concurrent Sessions

Defining Terminal Activities

Overview

When defining an activity in the process workflow, the properties pane contains property pages that are 
specific to the selected activity. The following table displays the activities that are provided by the 
Terminal adapter.
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Defining a Close Terminal Session Activity

Use the Close Terminal Session activity to close a SSH or Telnet session opened by a previous Open 
Session activity. The user should always specify a paired Open Terminal Session and Close Terminal 
Session activity within a process.

If a corresponding Close Terminal Session activity for an Open Terminal Session activity is not 
specified, the SSH session opened by the Open Terminal Session activity will be closed by the Terminal 
adapter when the process completes. The SSH session also may terminated earlier by the SSH server if 
the SSH server configuration specified a shorter user idle time.

To define the Close Terminal Session activity:

Step 1 On the Toolbox pane, under Terminal, select the Close Terminal Session activity, then drag and drop 
the activity onto the Workflow pane.

The Close Terminal Session property page displays.

Step 2 Click the Close Session tab to specify the appropriate device command or inputs.

• Input—Enter the appropriate device command before ending the SSH session. (Example: Quit)

Step 3 Click the Session tab to select the appropriate Open Terminal Session activity to close or send 
commands.

The Open Terminal Session activity provides the target upon which the SSH session was opened. The 
Execute Terminal Command(s) and Close Terminal Session activities will run against the same target 
and runtime user specified in the Open Session activity.

• Session opened by—Select the appropriate open session from the drop-down list.

Activity Description

Close Terminal Session Closes a Terminal session opened by a previous Open Terminal Session 
activity

See Defining a Close Terminal Session Activity.

Execute Terminal 
Command(s)

Sends commands to a terminal command session started by a previous 
Open Terminal Session activity

See Defining an Execute Terminal Command Activity.

Execute Unix/Linux SSH 
Command

Specifies a Unix/Linux SSH command to execute

See Defining an Execute Unix/Linux SSH Command Activity.

Execute Unix/Linux SSH 
Script

Specifies a Unix/Linux SSH script to execute

See Defining an Execute Unix/Linux SSH Script Activity.

Get File Retrieves files from a Unix/Linux system target to transfer to a specified 
local directory

See Defining a Get File Activity.

Open Terminal Session Starts an SSH session on a selected Terminal target

See Defining an Open Terminal Session Activity.

Put File Pushes local files to a Unix/Linux system target

See Defining a Put File Activity.
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Step 4 Click OK.

See Also

Viewing Close Terminal Session Output

Defining a Get File Activity

Use the Get File activity to retrieve files from a Unix/Linux system target to transfer to a specified local 
directory using either the Secured File Transfer Protocol (SFTP) or Secure Copy Protocol (SCP) if SFTP 
or SCP is available on the given target. If both protocols are available, SFTP will be used.

To define the To define the Get File activity:

Step 1 On the Toolbox pane, under Secure Shell (SSH), select Get File and drag and drop the activity onto the 
Workflow pane.

The Get File property page displays.

Step 2 Click the Get File tab to specify the remote files and file path to the local directory to where the files 
will be copied.

• Remote files on the target to copy from—The list of files on the Unix/Linux system the user wants 
to retrieve. If a relative path is specified, it will be relative to the product local application data 
directory.

– Add—Click to launch the Enter Remote File to Add dialog box to type the file name to be added 
to the list.

– Edit—Highlight the appropriate file name and click Edit to launch the Enter Remote File to Add 
dialog box to modify the file name in the list.

– Remove—Highlight the appropriate file name and click Remove to remove the file name from 
the list.

– Remove All—Click Remove All to remove all the files in the list.

• Local windows runtime user for accessing local file systems—From the drop-down list, select the 
windows runtime user account that contains the credentials to access local files.

– The user must have the Log on as batch job and Allow log on locally User Rights Assignment. 
To adjust the user right assignments, go to: Administrative Tools/Local Security Policy/Security 
Settings/Local Policies/User Rights Assignment.

• Local directory to copy files to—Specify the file path to the local directory to where the files will 
be copied. The default file path is relative to the product local application data directory.

For example:

C:\Documents and Settings\test\Local Settings\Application Data

• Overwrite—Select the appropriate option to determine the circumstances in which the copied file 
should overwrite any existing file in the local directory.

– Do not overwrite—Indicates the copied file should never overwrite the existing file

– Always overwrite—Indicates the copied file should always overwrite the existing file

– Pull only if newer—Retrieves the file only if the file on the Unix/Linux system is more recent 
than the local copy.
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Note This setting may not apply when the SCP protocol is used or a directory copy takes place.

• Time out if not completed within—Enter a value to specify the time frame to wait for the file transfer 
to complete before timing out. Large files may cause the file transfer to take longer.

Note Select the time unit link to adjust the time unit (seconds, minutes, or hours).

Step 3 Click OK.

See Also

Viewing Get File Activity Results

Defining a Put File Activity

Use the Put File activity to push local files to a Unix/Linux system target if SFTP or SCP is available on 
the given target.

If both protocols are available, SFTP will be used. If one file in the list fails while uploading, the activity 
will fail.

To define the Put File activity:

Step 1 On the Toolbox pane, under Secure Shell (SSH), select Put File and drag and drop the activity onto the 
Workflow pane.

The Put File property page displays.

Step 2 Click the Put File tab to specify the local files and file path to the remote directory to where the files 
will be copied.

• Local windows runtime user for accessing local file systems—From the drop-down list, select the 
windows runtime user account that contains the credentials to access local files.

Note The user must have the Log on as batch job and Allow log on locally User Rights Assignment. 
To adjust the user right assignments, go to: Administrative Tools/Local Security Policy/Security 
Settings/Local Policies/User Rights Assignment.

• Local files on the target to copy from—The list of files on the local computer to put on remote target 
systems. If a relative path is specified, it will be a relative to the product local application data 
directory.

– Add—Click Add to launch the Enter Remote File to Add dialog box to type the file name to be 
added to the list.

– Edit—Highlight the appropriate file name and click Edit to launch the Enter Remote File to Add 
dialog box to modify the file name in the list.

– Remove—Highlight the appropriate file name and click Remove to remove the file name from 
the list.

– Remove All—Click Remove All to remove all the files in the list.
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• Remote directory on the target to copy files to—Specify the file path to the local directory on the 
target systems where the files will be transferred.

An absolute path is recommended. The default file path is relative to the product local application 
data directory.

For example:

C:\Documents and Settings\test\Local Settings\Application Data

• Overwrite—Select the appropriate option to determine the circumstances in which the copied file 
should overwrite any existing file in the remote target system.

– Do not overwrite—Indicates the copied file should never overwrite the existing file

– Always overwrite—Indicates the copied file should always overwrite the existing file

– Push only if newer—Retrieves the file only if the file on the local directory is more recent than 
the remote target system.

Note This setting may not apply when the SCP protocol is used or a directory copy takes place.

• Time out if not completed within—Enter a value to specify the time frame to wait for the file transfer 
to complete before timing out. Large files may cause the file transfer to take longer.

Note Select the time unit link to adjust the time unit (seconds, minutes, or hours).

Step 3 Click OK.

See Also

Adding a Local File to Put File Activity

Removing Files from Activity

Viewing Put File Activity Results

Defining an Execute Terminal Command Activity

Use the Execute Terminal Command(s) activity to send commands to a session started by a previous 
Open Terminal Session activity.

To define the Execute Terminal Command(s) activity:

Step 1 On the Toolbox pane, under Terminal, select the Execute Terminal Command(s) activity, then drag and 
drop the activity onto the Workflow pane.

The Execute Terminal Command(s) property page displays.

Step 2 Click the Command tab to Specify the following options for the command or input to be sent during an 
open session.

To generate a long output, it is recommended that users include 'terminal length 0' in one of the 
commands that uses the session before any command that will return a lot of output. If not, then the 
command will timeout and the generated output will not display in its entirety.

• Input—Enter the appropriate commands and inputs that a user can send to an open session.
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• Ends with special character—Check this check box and then select the appropriate option to place 
at the end of the lines that is sent with the input.

Use options CTRL_A through CTRL_Z.

• Multiple lines option

– Send all lines as one input—Select this radio button to send all lines in the plain text as one 
input.

– Send next line only if previous line succeeded—Select this radio button to send a line as an input 
if there is a previous line before the input.

• Activity Timeout—Enter a value to specify the time frame to wait for the Execute Terminal 
Command(s) activity to complete before timing out.

• Individual Command Timeout—Enter a value to specify the time frame to wait for an individual user 
input to be completed before timing out.

• Preserve activity output—Check the check box to indicate that the output from the activity should 
be preserved.

If the check box remains unchecked, then the output will not be preserved and cannot be referenced 
by the user nor the expect results.

Step 3 Click the Expect tab to view or modify the configuration used to manage the target command output 
during the terminal session.

• Name—Name of the case defining what to expect

• Regular Expression—Matches the characters in terminal output

• Operation Type—Displays what operation takes place if an expected regular expression match is 
encountered in the terminal output

– User Response—Provides input to the terminal and continue execution of the activity

– Runtime User's Username—Allows user to respond with the username of the runtime user for 
the session

– Runtime User's Password—Allows user to respond with the password of the runtime user for 
the session

– Runtime User's Admin Password—Allows user to respond with the admin password of the 
runtime user. If the runtime user doesn’t have the admin password, the regular password will be 
used.

– Succeeded—Complete activity and set its status to Completed

– Failed (Completed)—Complete activity and set its status to Failed (Completed)

– Failed (Not Completed)—Complete activity and set its status to Failed (Not Completed)

• User Response—Displays the defined user input string text or format to be used to perform the 
substring operation on the match results.

• Hidden—This check box is enabled when User Response is selected from the Operation Type 
drop-down list.

Check this check box and enter the string text into the User Response field, which will be used as 
security-sensitive content for the expect.

Step 4 Click the Session tab to specify the appropriate Open Terminal Session activity to execute terminal 
commands.
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Due to the nature of network device management, Process Orchestrator may have a very large number 
of Process Orchestrator Terminal Adapter targets and concurrent running Process Orchestrator 
processes. To avoid the negative impacts on performance and manage resource usage, the Terminal 
Adapter has a limit on the maximum total live sessions. When the total live sessions reaches the 
maximum limits, the activity that needs to open a new session will wait until a live session is closed.

• Session opened by—Select the appropriate open session from the drop-down list.

Step 5 Click OK.

Viewing Results

Defining an Execute Unix/Linux SSH Command Activity

Use the Execute Unix/Linux SSH Command activity to specify a SSH command to execute. To properly 
run this activity, Process Orchestrator requires SFTP to be configured on the SSH server. This activity 
is only supported against the Unix/Linux system target. Korn Shell is also required.

Pipe is not supported by the Execute Unix/Linux SSH Command activity. If the user needs to execute 
pipe in an activity, it is recommended that the user places the pipe in the Execute Unix/Linux SSH Script 
activity.

For example, the user can enter "ps -ef " in the Execute Unix/Linux SSH Command activity, but if the 
user needs to execute "ps -ef | grep myusename" then, that information should be placed in the Execute 
Unix/Linux SSH Script activity.

To define the Execute Unix/Linux SSH Command activity:

Step 1 On the Toolbox, under Secure Shell (SSH), select Execute Unix/Linux SSH Command and drag and 
drop the activity onto the Workflow pane.

The Execute Unix/Linux SSH Command property page displays.

Step 2 Click the Command tab to specify the command line properties used to execute an activity on a local 
working directory on the SSH server.

• Command to execute on target—Actual command line used to execute an activity on the SSH server

Enter the actual command to execute an activity on the SSH server.

See Command Line Examples.

• Local working directory on target—Enter the path to the local working directory on the SSH server 
where the command will be executed.

If the path is left blank, the default directory will be user login directory on the SSH server

• Command line arguments—Enter the collection of argument values for the command.

– Add—Click this button to enter or select the appropriate argument to add to the command line. 
See Adding a Script Argument.

– Edit—Click this button to modify the command argument. See Modifying a Script Argument.

– Remove—Click this button to remove a command argument from the list. See Removing a 
Script Argument.
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Note For an example of a script argument, see Script Argument Example.

• Time out if not completed within—Enter a value or use the scroll buttons to specify the time frame 
to wait for the action to complete before timing out.

Note Select the time unit link to adjust the time unit (seconds, minutes, or hours).

• Time out if no available session within—Enter a value or use the scroll buttons to specify the time 
frame to wait for the activity to complete if there is no available session.

The cause for no available session may be the setting "max allowed concurrent sessions" on the 
target has been reached.

• Fail on non-zero return code—Selected check box indicates that the activity should fail when a 
return code having a non-zero value is received

Step 3 Click OK.

See Also

Viewing Executed Unix/Linux SSH Command Output

Defining an Execute Unix/Linux SSH Script Activity

Use the Execute Unix/Linux SSH Script activity to specify a SSH script argument to execute. To 
properly run this activity, Process Orchestrator requires SFTP to be configured on the SSH server.

To define the Execute Unix/Linux SSH Script activity

Step 1 On the Toolbox, under Secure Shell (SSH), select Execute Unix/Linux SSH Script and drag and drop 
the activity onto the Workflow pane.

The Execute Unix/Linux SSH Script property page displays.

Step 2 Click the Script tab to specify a SSH script argument to execute:

• Local working directory on target—Enter the path to the local working directory on the SSH server 
where the script will be executed.

• Script arguments—Enter the collection of argument values for the script.

– Add—Click this button and choose one of the following to launch the Select Argument to Add 
dialog box. Enter the appropriate script in the text field or click Reference icon to select from 
the list.

String—Dialog box can contain standard string text

Hidden String—Dialog box can contain Hidden string text or query encrypted value variables 
in the Insert Reference Variable dialog box

– Edit—Select a script argument from the list and click this button to modify the script argument 
in the Select Argument to Add dialog box.

– Remove—Select a script argument from the list and click this button to remove the script 
argument from the list.
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For an example of a script argument, see Script Argument Example.

• Script to execute on target—Enter the actual script code to use to execute in the specified local 
working directory.

• Time out if not completed within—Enter a value or use the scroll buttons to specify the time frame 
to wait for the action to complete before timing out.

Select the time unit link to adjust the time unit (seconds, minutes, or hours).

• Time out if no available session within—Enter a value or use the scroll buttons to specify the time 
frame to wait for the activity to complete if there is no available session.

The cause for no available session may be the setting "max allowed concurrent sessions" on the 
target has been reached.

• Fail on non-zero return code—Select this check box configure the activity to fail when a return code 
having a non-zero value is received.  

Step 3 Click OK.

See Also

Adding a Script Argument

Modifying a Script Argument

Removing a Script Argument

Viewing Executed Unix/Linux SSH Script Output

Defining a Stop a Unix Process via SSH Properties

Use the Stop a Unix Process via SSH activity to stop a running Unix process.

• PID—Enter the Unix process ID for the appropriate running process to be stopped.

Defining an Open Terminal Session Activity

Use the Open Terminal Session activity to start a SSH session on a given terminal target via a SSH 
protocol client. The subsequent Execute Terminal Command(s) and Close Terminal Session activities 
will run against a SSH session.

The expects configuration used during this operation are defined in the selected target.

To define the Open Terminal Session activity:

Step 1 On the Toolbox pane, under Terminal, select the Open Terminal Session activity, then drag and drop 
the activity onto the Workflow pane.

The Open Terminal Session property page displays.

Step 2 Click the Open Terminal Session tab to modify the time constraints for the activity or command.

• Activity Timeout—Check this check box and then enter a value to specify the time frame to wait for 
the Open Terminal Session activity to complete before timing out. (Default: 5 minutes)

• Time out if no available session within—Enter a value or use the scroll buttons to specify the time 
frame to wait for the activity to complete if there is no available session.
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The cause for no available session may be the setting "max allowed concurrent sessions" on the 
target has been reached.

Note To the right of the timeout fields, select the time unit link to adjust the time unit (seconds, 
minutes, or hours).

Step 3 Click OK.

Modifying Terminal Activities

Adding a Local File to Put File Activity

The Put File activity copies files from a local directory onto a remote target system. The Add button on 
this activity launches the Enter Local File to Add dialog for users to specify the file name to be added to 
the list on the Put File activity.

To add a file:

Step 1 On the Put File property page, click Add.

The Enter Local File to Add dialog box displays.

Step 2 In the Local File field, enter or select the file name to be added to the list.

Step 3 Click OK.

The file is added to the list of local files to be retrieved by the Put File activity.

See Also

Defining a Put File Activity

Adding a Remote File to Get File Activity

The Get File activity copies files from remote target systems to a local directory. The Add button on this 
activity launches the Enter Remote File to Add dialog box for users to specify the file name to be added 
to the list on the Get File activity.

To add a file:

Step 1 On the Get File property page, click Add.

The Enter Remote File to Add dialog box displays.

Step 2 In the Remote File field, enter or select the file name to be added to the list.

Step 3 Click OK.

The file is added to the list of remote files to be retrieved by the Get File activity.

See Also
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Defining a Get File Activity

Adding a Script Argument

Script arguments are a property for SSH activities. The Add button on these activities launches the Select 
Argument to Add dialog box for users to specify the script arguments to be added to the list on the 
specified SSH activity.

To add a script argument:

Step 1 On the appropriate SSH activity property page, click Add.

The Select Arguments to Add dialog box displays.

Step 2 Specify the script argument value for the script.

Step 3 Click OK.

The script argument is added to the command line argument list on the activity property page.

See Also

Script Argument Example

Script Argument Syntax

Modifying a Script Argument

Use the Select Argument to Add dialog box to modify existing script arguments added to the SSH script 
or command activities.

To modify a script argument:

Step 1 On the appropriate SSH activity property page, under the Arguments section, highlight the appropriate 
the script argument, and click Edit.

The Select Argument to Add dialog box displays.

Step 2 Modify the information on the variable, as necessary, and click OK.

The modified script argument displays in the activity tab.

See Also

Script Argument Example

Script Argument Syntax

Removing a Script Argument

Removing a script argument from an activity does not delete the object from the Process Orchestrator 
server. To delete the object, refer to the appropriate object definition section.

To remove a script argument:

On the activity property page tab, highlight the appropriate the argument, and click Remove.

See Also
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Adding a Script Argument

Modifying a Script Argument

Removing Files from Activity

Use the following steps to remove files specified on the Get File and Put file activities to be copied.

To remove a single file

Under one of the following, highlight the appropriate file, and then click Remove.

• Remote files on the target to copy

• Local files on the target to get

The selected file is removed from the Get File or Put File tab.

To remove all files

Under one of the following, click Remove All.

• Remote files on the target to copy

• Local files on the target to get

All the files under the appropriate section are removed from the list.

Command Line Examples

The following are command line examples.

If your local working directory is:

/home/myusername/myappdata

and the command is

/myAppPath/myShellScript.sh

the full path is:

/home/myusername/myappdata/myAppPath/myShellScript.sh.

On Unix systems:

ls

/usr/bin/ls

If your command is located at the directory of:

/myCommandPath

and the command is

myCommand

the full path is:

/myCommandPath/myCommand

Script Argument Example

The following is an example of a script containing four arguments. For additional examples and 
information, see Script Argument Example.
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Script to execute:

 #! /bin/csh

     echo ${0}

     echo "Number of arguments is $#argv"

     echo $2

     echo $argv[2-3]

     echo $argv[$]

     exit

Script argument:

% argex.csh "hello world" 42 3.14159 "(300:400,~100)"

     argex.csh

     Number of arguments is 4

     42

     42 3.14159

     (300:400,~100)

See Also

Script Argument Syntax

Adding a Script Argument

Script Argument Syntax

Any command-line arguments can be accessed as shell variables inside a script. The following table 
contains script arguments which can be used inside a script.

${0}—The name of the script being run

$?name—Returns 1 if the variable name is defined, or 0 if it is not defined

$n—The value of the n argument passed to the script

$argv[n]—The value of the n argument passed to the script

$#argv—The number of arguments passed to the script

$*—All the arguments supplied to the script

$$—Process identification number (useful for making temporary files with unique names)

Viewing Terminal Activity Results

Viewing Execute Terminal Command(s) Results

The Execute Terminal Command(s) display-only tab displays the properties used to send commands to 
a SSH session started by a previous Open Terminal Session activity.

Step 1 In the Operations workspace, click the Activity Views folder.
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Step 2 Highlight the Execute Terminal Command(s) activity instance, right-click and choose Properties.

The Execute Terminal Command(s) dialog box displays.

• secure—Checked box indicates that security-sensitive string text is required

• Input—Commands and inputs that a user can send to an open SSH session.

Security-sensitive string text may be used to send to an open SSH session when the secure check 
box is checked.

• Send all lines as one input—Sends all lines in the Plain text as one input

• Send next line only if previous line—Sends a line as an input if there is a previous line before the 
input

• Activity Timeout—Value indicates the time frame to wait for the Open Session activity to complete 
before timing out.

• Individual Command Timeout—Value indicates the time frame to wait for an individual user input 
to be completed before timing out.

• Preserve activity output—Checked box indicate that the output from the activity has been preserved 
and can be referenced by the user and expect results.

Viewing Close Terminal Session Output

When the Close Terminal Session activity is launched, the results of the matched expect configurations 
are displayed from the Operations Workspace activity instance view.

To view the Close Terminal Session results:

Step 1 In the Operations workspace, click the Activity Views folder.

Step 2 Highlight the Close Terminal Session activity instance, right-click and choose Properties.

The Close Terminal Session dialog box displays.

Step 3 Click the Output tab to display the results of the matched expect configurations.

• Expect Name—The name of an expect configuration

• Match Result—The match result of an Expect configuration

The Output box displays the terminal output during the opening session period.

Step 4 Click OK.

See Also

Defining a Close Terminal Session Activity

Viewing Executed Unix/Linux SSH Command Output

When the Execute Unix/Linux SSH Command activity is launched, the results of the executed SSH 
command are displayed from the Operations Workspace activity instance view.

To view the Unix/Linux SSH Command results:
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Step 1 In the Operations workspace, click the Activity Views folder.

Step 2 Highlight the Execute Unix/Linux SSH Command activity instance, right-click and choose Properties.

The Execute Unix/Linux SSH Command dialog box displays.

Step 3 Click the Command Output tab to display the executed SSH command line and the display-only 
activity properties used to generate the results.

• Command return status code—Exit status return code of the command execution

• Command output—String property that captures the output from command execution

Step 4 Click OK.

See Also

Defining an Execute Unix/Linux SSH Command Activity

Viewing Executed Unix/Linux SSH Script Output

When the Execute Unix/Linux SSH Script activity is launched, the results of the executed SSH script 
argument are displayed from the Operations Workspace activity instance view.

To view the Unix/Linux SSH Script results:

Step 1 In the Operations workspace, click the Activity Views folder.

Step 2 Highlight the Execute Unix/Linux SSH Script activity instance, right-click and choose Properties.

The Execute Unix/Linux SSH Script dialog box displays.

Step 3 Click the Script Output tab to display the executed SSH script argument and the display-only activity 
properties used to generate the results.

• Script exit status code—Exit status return code of the script execution

• Script output—String property that captures the output from script execution

Step 4 Click OK.

See Also

Defining an Execute Unix/Linux SSH Script Activity

Viewing Get File Activity Results

When the Get File activity is launched, the file transfer results of the Get File activity are displayed from 
the Operations Workspace activity instance view.

To view the Get File results:

Step 1 In the Operations workspace, click the Activity Views folder.

Step 2 Highlight the Get File activity instance, right-click and choose Properties.

The Get File dialog box displays.
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Step 3 Click the Result tab to display the Get File output properties from the file transfer and the display-only 
activity properties used to generate the results.

• File Transfer Protocol—The SFTP or SCP protocol used to transfer the files

• Local File Name—Name of file as it was saved on the local computer

• Remote File Name—Name of file as it was saved on the remote host computer

• Transferred—Indicates the status of the file transfer from a remote host computer onto the local 
computer

• Comment—Any comments about the transferred file

Step 4 Click OK.

See Also

Defining a Get File Activity

Viewing Open Terminal Session Output

When the Open Terminal Session activity is launched, the results of the matched expect configurations 
are displayed from the Operations Workspace activity instance view.

To view the Open Terminal Session  results:

Step 1 In the Operations workspace, click the Activity Views folder.

Step 2 Highlight the Open Terminal Session  activity instance, right-click and choose Properties.

The Open Terminal Session dialog box displays.

Step 3 Click the Output tab to display the results of the matched expect configurations

Step 4 Highlight the appropriate expect and click this button to view the display-only expect result properties.

The Output box displays the terminal output during the opening session period.

Step 5 Click OK.

See Also

Defining an Open Terminal Session Activity

Viewing Expect Instance Tab Results

The Expect display-only tab displays the expect configurations used to interact with the terminal in order 
to determine when an activity completes during the session.

• Name—Name of the case defining what to expect

• Regular Expression—Matches the characters in terminal output

• Operation Type—Displays what operation takes place if an expected regular expression match is 
encountered in the terminal output

– Succeeded

– Failed (Completed)
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– Failed (Not Completed)

– User encrypted response

– User response

– Set Expect Result

• User Response—Displays the defined user input string text or format to be used to perform the 
substring operation on the match results.

Viewing Put File Activity Results

When the Put File activity is launched, the file transfer results of the Put File activity are displayed from 
the Operations Workspace activity instance view.

To view the Put File results:

Step 1 In the Operations workspace, click the Activity Views folder.

Step 2 Highlight the Put File activity instance, right-click and choose Properties.

The Put File dialog box displays.

Step 3 Click the Result tab to display the Put File output properties from the file transfer and the display-only 
activity properties used to generate the results.

• File Transfer Protocol—The SFTP or SCP protocol used to transfer the files)

• Local File Name—Name of file as it was saved on the local computer

• Remote File Name—Name of file as it was saved on the remote host computer

• Transferred—Indicates the status of the file transfer from the local computer into the remote host 
computer

• Comment—Any comments about the transferred file

Step 4 Click OK.

See Also

Defining a Put File Activity

Viewing Get Interface Inputs

The Inputs display-only tab displays the device configuration output from an Execute Terminal 
Command(s) activity that executes the IOS command "show running-config".

Viewing Get Interface Outputs

The Outputs display-only tab displays the name of the Interface Table that contains the list of interfaces 
returned for the device.

Get Interface List Instance Properties - Inputs

The Inputs display-only tab displays the device configuration output from an Execute Terminal 
Command(s) activity that executes the IOS command "show running-config".
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Get Interface List Instance Properties - Outputs

The Outputs display-only tab displays the name of the Interface Table that contains the list of interfaces 
returned for the device.

Troubleshooting Terminal Adapter

Activity Output does not match Expect Prompts

Error

This activity has failed, please check the output or the expect results table.

If the output does not match the expect prompts, the activity will timeout.

To review the expect result properties:

Step 1 On the Operations > Processes view, highlight the appropriate process, right-click and choose Observe.

Step 2 On the Workflow pane, locate the appropriate Execute Terminal Command activity.

Step 3 On the activity Properties pane, click the Output tab.

Step 4 Under Expect result table, click Properties.

The Expect properties dialog box displays.

Step 5 Review the Match before field to review the expect properties to verify whether the activity contains 
valid expects.

Solution

This is not an easily determined problem, because the output doesn’t clearly explain the error. After 
verifying the expects in the Expect Result Properties dialog box, modify the expects and then re-run the 
process.

To modify the expects:

Step 1 Double-click the process.

The selected process opens in the Process Editor.

Step 2 On the Workflow pane, locate the appropriate Execute Terminal Command activity.

Step 3 On the activity Properties pane, click the Expect tab.

Step 4 Highlight the appropriate expect, click Edit and then modify the information in the Regular Expression 
field.

Step 5 Click OK to close the dialog box and then click the Save tool to save the process.

Step 6 Click the Start tool to run the saved process.

Step 7 Close the Process Editor and return to the Operations workspace to observe the process status.
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Correcting Open Session Activity Timeout Error

Error

This activity has failed because the session activity has timed out.

Solution

This is a basic issue that occurs when the user did not enter enough time when defining the properties of 
the Open Session activity.

To modify the Open Session activity properties:

Step 1 Double-click the process.

The selected process opens in the Process Editor.

Step 2 On the Workflow pane, locate the appropriate Open Session activity.

Step 3 On the activity Properties pane, click the Open Sessions tab.

Step 4 In the Activity timeout field, increase the amount of time necessary to run the process before the activity 
times out.

Step 5 Click the Save tool to save and the Start tool to run the saved process.

Step 6 Close the Process Editor and return to the Operations workspace to observe the process status.

 

Execute Terminal Command Activity Timed Out

Error

This activity has timed out while waiting for expected output.

Step 1 On the Operations—Processes view, highlight the appropriate process, right-click and choose Observe.

Step 2 On the Workflow pane, locate the appropriate Execute Terminal Command activity.

Step 3 On the activity Properties pane, click the Output tab.

Step 4 Under Expect result table, click Properties.

Step 5 Review all the expects with the Succeeded operation type to make sure that there is an expect that will 
match the output somewhere. There must be at least one expect with a Succeeded operation type for the 
activity to succeed.

Solution

After verifying the expects in the Expect Result Properties dialog box, modify the expects and then 
re-run the process.

To modify the expects:

Step 1 Double-click the process.
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The selected process opens in the Process Editor.

Step 2 On the Workflow pane, locate the appropriate Execute Terminal Command activity.

Step 3 On the activity Properties pane, click the Expect tab.

Step 4 Highlight the appropriate expect, click Edit and then modify the information in the Regular Expression 
field.

Step 5 Click OK to close the dialog box and then click the Save tool to save the process.

Step 6 Click the Start tool to run the saved process.

Step 7 Close the Process Editor and return to the Operations workspace to observe the process status.

Expect Prompt Command Error

Error

This activity has failed, please check the output or the expect result table to see the error details.

Solution

For this particular error, the user should not concentrate on the match results, but the expect command 
in the Expect Result Properties dialog box. The information in the dialog is Cisco IOS data and the user 
must be familiar with Cisco IOS, otherwise he or she will not understand the error.

To review the expect result properties:

Step 1 On the Operations—Processes view, highlight the appropriate process, right-click and choose Observe.

Step 2 On the Workflow pane, locate the appropriate Execute Terminal Command activity.

Step 3 On the activity Properties pane, click the Output tab.

Step 4 Under Expect result table, click Properties to review the detailed error message for the prompt 
command.

Step 5 Review the expect properties to determine the next course of action based on the Cisco IOS data.

Target Connection Pattern Prompt Prefix Error

Error

This activity has timed out while waiting for expected output.

This error is generated because the activity was waiting for data before successfully completing the 
activity.
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Solution

Before continuing, verify that the activity simply isn’t timing out too quickly. If so, then modify the time 
entry in the Activity timeout field on the activity property page in the Process Editor. If the amount of 
time in the activity is sufficient, then compare the information on the Output tab to the regular expression 
and the operation type on the Expect tab. If the expects do no match, then it will be necessary to modify 
the appropriate prompt prefixes.

Please note in the following examples that the regular expressions in both the Prompt expects are 
different than what was generated on the output.

Example—Output Tab 1

Example—Expect Tab 2

To modify the prompt prefix:

Step 1 Double-click the process.

The selected process opens in the Process Editor.

Step 2 On the Workflow pane, locate the appropriate Execute Terminal Command activity.
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Step 3 On the activity Properties pane, click the Expect tab.

Step 4 Highlight the appropriate expect, click Edit and then modify the information in the Regular Expression 
field.

Step 5 Click OK to close the dialog box and then click the Save tool to save the process.

Step 6 Click the Start tool to run the saved process.

Step 7 Close the Process Editor and return to the Operations workspace to observe the process status.

Cisco Network Services Manager

Overview
The Cisco Network Services Manager adapter manages network services which allows users to create, 
revise, review, update physical and virtual networks in a cloud computing infrastructure. Cloud 
computing provides IT services in a self-service and highly automated manner.

The Cisco Network Services Manager adapter properties dialog box displays general information about 
the functionality provided by the adapter, version number, release date and install date, any prerequisites, 
and the history of changes made to the adapter.
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C H A P T E R 13

Using SAP Adapters

The Cisco Intelligent Automation for SAP solution consists of core features provided by Cisco Process 
Orchestrator and the Automation Packs for SAP. The solution standardizes, unifies, and automates best 
practices for IT processes in complex, heterogeneous environments. It helps companies shift from siloed 
and manual management to operational performance analysis and process automation across the data 
center.

While the Cisco Process Orchestrator platform provides users the enterprise context for IT process 
automation, the SAP automation packs are specifically designed to integrate with SAP Solution 
Manager, CCMS, and SAP HANA to automate SAP functions around incident response, task 
management, corrective actions and system copy activities.

The automation packs for SAP interface with SAP environments and include pre-configured SAP 
content, enabling users to automate incident response activities and orchestrate complex operational 
processes for SAP applications.

The Intelligent Automation for SAP solution includes the following automation packs:

Table 13-1 Automation Packs: 

Automation Pack Name Description

Core Automation for SAP Contains content shared by other SAP dependent automation packs.

Core Automation for SAP 
BW, BOBJ and In-Memory 
Computing

Contains content share by the SAP BW, BOBJ and In-Memory 
computing automation packs.

Assessment for SAP BWA Contains the content used to generate an assessment report to automate 
query evaluation and hardware sizing necessary for implementing SAP 
BWA.

Automation for SAP BW 
and BWA

Contains the content used to automate best practices for monitoring SAP 
BW and BWA availability, operations and performance.

Automation for SAP HANA Contains the content used to provide intelligent automation, analysis, 
and corrective actions to support the operations, management, and 
maintenance of the SAP HANA database and its related technologies.

Automation for SAP 
Solution Manager E2E 
Response

Contains the content used to automate analysis and problem resolution 
for incidents triggered by SAP Solution Manager alerts.
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Configuring SAP Targets
Before you can create or run processes in your SAP environment, you must create the targets on which 
the processes will run. Targets are used to define specific environments where activities, triggers and 
processes will be executed. Use the Definitions—Targets view to define the targets. 

When creating targets, a runtime user account must be specified to be used to connect to the target. The 
runtime user account stores the information about the user security context for the target. You can create 
the runtime user accounts during the process of creating the targets or prior to creating the targets using 
the Runtime Users workspace in the Console.

The type of target that is required depends on the adapter that supports the automation pack. For the 
SAP-related automation packs, the following targets and corresponding runtime user account types are 
used.

Table 13-2 Targets and corresponding runtime user account type for SAP-related automation packs. 

Incident Response for SAP Contains the content used to automate best practices for identifying and 
analyzing availability and performance problems within your SAP 
environment. This includes event correlation and root cause analysis, 
and management of incoming incidents based on an analysis in the 
context of other incidents, events and metrics.

IT Task Automation for 
SAP

Contains the content to resolve incidents that are raised from the 
Incident Response for SAP processes.

Automation for SAP BOBJ 
Accelerator

Contains the content used to automate monitoring Business Objects XI 
Data Services content.

Automation for SAP BOBJ 
Enterprise

Contains the content used to automate system monitoring and corrective 
actions for Business Objects XI Data Services content.

Target Description Runtime User Type

SAP System SAP system SAP User

SAP ABAP connection SAP User

SAP Java application server Runtime User

SAP database Runtime User

SAP Solution Manager Connects to an SAP Solution Manager system SAP User

SAP HANA (Service target) Use the HANA target to reference all the targets 
in the SAP HANA environment. The following 
targets are referenced in the HANA System 
target:

• Generic Data Source (OLEDB)—database 
target

• Web Target

• Unix/Linux System Target

Runtime User
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Creating SAP System Targets

SAP HANA Target

The Automation for SAP HANA automation pack includes a SAP HANA target that can be used to create 
a service target for the HANA environment. The service target will hold the reference to all of the 
connections to HANA that are needed for automation.

Before You Begin 

Before you can create or run processes, you must create the SAP HANA target on which the processes 
will run:

• SAP HANA Database Target

• SAP HANA Web Targets

• SAP HANA Linux/Unix Targets

• SAP System (ABAP) Target

Step 1 On the Definitions workspace, right-click Targets and choose New > SAP HANA to open the SAP 
HANA Properties dialog box.

Step 2 In the Display name text field, enter a name for the SAP HANA target, then click OK to save the target 
and close the dialog box.

Step 3 In the Targets pane, right-click the newly created SAP HANA target and choose Enable to enable the 
target.

SAP HANA Database Targets

You must create a database target for the SAP HANA database using the Generic Data Source (OLEDB) 
target type. Use the New Generic Data Source (OLEDB) Properties dialog box to create the database 
target.

SAP BOBJ DS (Service 
target)

Use the service target type for the BOBJ DS 
environment. The following targets must also 
be created and referenced in the BOBJ DS 
Service target:

• Web Target

• BOBJ DS Database Target

• BWA Unix/Linux target

Runtime User

SAP BOBJ XI (Service target) Use the service target type for the BOBJ XI 
environment. The following targets must also 
be created and referenced in the BOBJ XI 
Service target:

•  Server Target

• Web Target

Runtime User
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Step 1 On the Definitions workspace, right-click Targets and choose New > Generic Data Source (OLEDB) 
to open the New Generic Data Source (OLEDB) Properties dialog box.

Step 2 Click the General tab and enter the required information.

Step 3 Click the Connection tab and specify the required connection information for the target, including:

• Hostname or Datasource—Name of the server or data source where the HANA database resides. 
Enter the information in the following format:

<server name>:port

Port number will be 3XX15, where XX is the HANA System Number.

• Runtime User—The HANA User account created for Cisco Process Orchestrator should have 
SYSTEM level authorizations.

• Connection string—Check the check box and enter the DSN connection string to the data source. 
For example:

DSN=DH1;

Step 4 Click the Permission tab, then click the Execute SQL command radio button.

Step 5 Click OK to close the dialog box and complete the procedure.

SAP HANA Web Targets

If you want to configure Cisco Process Orchestrator to monitor the Web targets in your HANA 
environment, you must create a Web target using the using the New Web Target Properties dialog box.

Step 1 On the Definitions workspace, right-click Targets and choose New > Web Target to open the New Web 
Target Properties dialog box.

Step 2 Click the General tab and enter the required information:

Step 3 Click the Connection tab and specify the following connection information for the target:

• Base Url—Enter the appropriate target URL to use as a base for the execution. For example:

http://<hanahostname>:5XX13/?wsdl

where XX=HANA System Number

• Runtime User—Click one of the following radio buttons to indicate which runtime user account to 
use to connect to the target:

– No runtime user—Click this radio button to indicate that no runtime user is required to execute 
a process or activity against the target.

– Default runtime user—Click this radio button and then choose the default runtime user account 
that contains the credentials to connect to the target.

Note The runtime user for this target should be the HANA OS SIDADM user.

• Ignore certificate errors—Check or uncheck the check box to indicate whether the target should 
ignore any certificate errors on the specified web site. If the check box is checked, all errors will be 
ignored.
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Step 4 Click OK to close the dialog box and complete the procedure.

SAP Unix/Linux Targets

If you want to monitor the SAP HANA Linux systems in your environment, you must create the 
Unix/Linux System targets. Create a Unix/Linux Web target using the New Unix/Linux System 
Properties dialog box.

Step 1 On the Definitions workspace, right-click Targets and choose New > Unix/Linux System to open the 
New Unix/Linux System Properties dialog box.

Step 2 Click the General tab and enter the required information:

Step 3 Click the Connection tab, then specify the required information, including:

• Prompt prefix—Enter the command prompt prefix that will be used by the device type 
configurations and expects when issuing commands and connecting to the device.

Adding a regex character, such as $, >, and #, at the end of a prompt in the Prompt Prefix field 
invalidates the command prompt prefix. 

Regular expressions should be placed in the appropriate Terminal Interaction Pattern fields. 

Unix system prompt prefix is defined by the user default login script. it usually contains username, 
node name or current directory name. If the user does not define anything, the prompt prefix is 
empty.

If you connect to the terminal, and the prompt is jsmith@TBD-SH03-IT ~$, enter the regular 
expression that will match the entire prefix (before #) using any of the following expressions:

.*TBD-SH03-IT.*

\[\w+@TBD-SH03-IT.*\]

• Default runtime user—Choose the default runtime user account that contains the credentials to 
connect to the target from the drop-down list. 

– HANA.SAP Administration Unix Target—Select the HANA OS SIDADM runtime user 
account.

– HANA.Linux Administration Unix Target—Select the Linux user with OS administration 
permissions runtime user account.

• Enable code injection prevention—Check this check box to enable the protection that prevents code 
that is injected from exploiting the security vulnerability.

• Maximum allowed concurrent sessions—Enter the maximum allowed open sessions to run 
concurrently (default value is 3).

If the user tries to open new session via Open Session activity, it will wait in a queue until there is 
a session available to open.

Step 4 Click the Authentication tab and specify the following information to indicate whether the target should 
allow authentication based on the host system:

• Use host-based authentication—Check this check box to indicate that host-based authentication will 
be used with this target.

• Use the default host keys—This check box becomes enabled after the Use host-based authentication 
check box is checked. 
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Check this check box to indicate the host keys defined on the Terminal Adapter property page will 
be used for this target. 

If this check box is unchecked, then the user will need to load the appropriate private key to be used 
to validate this target.

• Private key—This box becomes enabled only if the Use the default host keys check box is 
unchecked.Click Browse to launch the Load Private Key dialog box and select a private key.

Step 5 Click the Advanced tab and specify the interaction patterns for the target:

• Use patterns common for the following device—Click the radio button one of the predefined device 
targets from the drop-down list.

– Cisco IOS Device—Select this option to use the default pattern values used by the device during 
the completion of a session command.

– Unix/Linux System—Select this option to use the default pattern values indicated for a Unix or 
Linux system during the completion of a session command

• Customize patterns for this target—Select this radio button to enable the display-only sections in 
order to customize the default values for the selected device type.

Step 6 Click OK to close the dialog box and complete the procedure.

SAP Reference Information

SAP AP

SAP System Setup Properties

You can only create one target for each SAP system. However, for multi-tenant environments, you can 
create targets for different SAP systems with the same system ID (SID).

• Display name—Enter a name for the SAP system. This is the name that will be displayed in the 
Targets view.

• System Components—Specify the system components to be configured:

– ABAP application servers—Check this check box if the SAP system uses an ABAP connection 
to the application server.

– Java application servers—Check this check box if the SAP system uses a Java connection to the 
application server. Not applicable for ABAP only connection. 

– SAP database—Check this check box if you want to configure the SAP database that is 
associated with the SAP system.

• Monitor as production system—Certain processes will run only on production systems. If you want 
to monitor the system as a non-production system (development or sandbox), uncheck the check 
box.

• Organization—Enter the group or organization within the company that owns the target.

When using the same SID for different SAP systems, you must enter the organization for each SAP 
system so Cisco Process Orchestrator can differentiate the alerts and incidents for each system.
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SAP Connection Properties

• Connect Using—Choose the connection method from the drop-down list. The fields that display on 
the panel depend on the connection method selected.

– Application server—Choose this option to connect to the SAP or SAP Solution Manager system 
using the SAP application server connection information. Specify the information in the 
following fields:

- Server name—Enter the name of the SAP application server.

- System number—Enter the SAP system number.

– Logon group—Choose this option to establish a connection using a logon group, which contains 
a group of SAP or SAP Solution Manager system instances. When a user logs on to a logon 
group, the message server directs the users to the server of this group that currently has the 
lightest load. Specify the information in the following fields:

- System ID—Enter the SAP system ID (SID).

- Message server—Enter the name of the server a user logs on to and that handles the 
communication between the application servers. For example, transport of update requests and 
lock requests.

- Group name—Enter the name of the Logon Group to be accessed. The name entered in this 
field is case-sensitive.

• Router string (optional)—Enter the router string for accessing the SAP or SAP Solution Manager 
systems via SAP Router. If you do not specify a router string, Cisco Process Orchestrator accesses 
the SAP system directly. The router string must be formatted as:

/H/host01/H/host02/H/

where host01 and host02 are the SAP systems that you want to access through the SAP Router.

• Default runtime user—Choose the user account that contains the credentials to connect to the target 
from the drop-down list.

SAP  Connection Properties

• Application server—Enter the IP address or name of the SAP Java application server.

•  ports—Enter the  port number used to connect to the Java application server.

• Use credentials of the following runtime user—Choose the default runtime user that contains the 
credentials to connect to the target from the drop-down list.

The runtime user must be a J2EE Admin account.

• Monitor as Portal—Run processes designed for portals on this Java server.

• Central Instance—Run processes designed for central instances on this Java server.

• Enable Telnet connection—Specify the Telnet connection information to connect to the Java 
application server.

SAP Telnet Connection Properties

• Telnet port—Enter the Telnet port number used to connect to the Java application server.

• Use credentials of the following runtime user—Choose the default runtime user that contains the 
credentials to connect to the target from the drop-down list.
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The runtime user must be a J2EE Admin account.

Browse for MBean Dialog

Use this dialog to navigate to the MBean that the activity will sample. Once you select the MBean and 
click OK, the information is automatically populated into the fields on the SAP Java Attribute Properties 
dialog.

SAP RFC Adapter

SAP RFC Function Methods

AL08 – Logged On Users Method Properties

The SAP RFC Analysis Function activity is used to define the properties of any remote-enabled function 
within the monitored SAP system.

Use the AL08 - Logged on Users method to retrieve the users who are logged onto the system.

AL11 – Change Custom Directory Method Properties

Use the AL11 - Change Custom Directory method to change an existing custom directory defined via 
the SAP transaction AL11.

• Directory Name—Specify a unique directory name. This field is case-sensitive.

• New Directory Name—Specify a unique for the new directory. This field is case-sensitive.

• New Alias Name—Specify an alias name of the directory. This field is case-sensitive.

• New Server Name—Specify a server name or enter All for all servers. This field is case-sensitive.

AL11 – Read Custom Directory Method Properties

Use the AL11 - Read Custom Directory method to retrieve current customer directories that are defined 
via the SAP transaction AL11.

Note This method requires the ABAP Add-On.

AL11 – Remove Custom Directory Method Properties

Use the AL11 - Remove Custom Directory method to remove an existing custom directory defined via 
the SAP transaction AL11.

• Directory—Specify a unique directory name. This field is case-sensitive.

AL15 – Add SAPOSCOL Destination Method Properties

Use the AL15 - Add SAPOSCOL Destination method to add an SAPOSCOL destination.

• Save Last 30 Days—Choose Yes or No to indicate whether to set a Save Alert flag.

• DB Server—Choose Yes or No to indicate whether the database server should be displayed.
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Note This method requires the ABAP Add-On.

AL15 – Delete SAPOSCOL Destination Method Properties

Use the AL15 - Delete SAPOSCOL Destination method to delete an SAPOSCOL destination.

Note This method requires the ABAP Add-On.

BD97 – Assign RFC Special Method Destination Method Properties

Use the BD97 - Assign RFC Special Method Destination method to modify the RFC assignments defined 
in BD97. This method modifies the RFC destinations based on Business Object name and method used 
in the interface.

• RFC Destination—RFC destination to be defined (validated against SAP RFC Destination table).

• Business Object Type—Business Object type technical name (validated against SAP Business 
Objects; viewable via SAP Transaction BAPI).

• Business Object Method—Business Object method technical Name for the Business Object type 
name.

Note This method requires the ABAP Add-On.

BD97 – Assign RFC Standard BAPI Destination Method Properties

Use the BD97 - Assign RFC Standard BAPI Destination method to modify the RFC assignments defined 
in BD97 for BAPI destinations.

• RFC Destination—RFC destination to be defined (validated against SAP RFC Destination table).

Note This method requires the ABAP Add-On.

BD97 – Assign RFC Standard Dialog Destination Method Properties

Use the BD97 - Assign RFC Standard Dialog Destination method to modify the RFC assignments 
defined in BD97 for dialog destinations.

• RFC Destination—RFC destination to be defined (validated against SAP RFC Destination table).

Note This method requires the ABAP Add-On.

BD97 – Delete All RFC Assignments Method Properties

Use the BD97 - Delete All RFC Assignments method to delete all the RFC assignments defined in BD97.

Note This method requires the ABAP Add-On.
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BD97 – Read RFC Assignments Special Method Destinations Method Properties

Use the BD97 - Read RFC Assignments Special Method Destinations method to retrieve the RFC 
assignments that are defined in BD97. This method retrieves the RFC destinations based on Business 
Object name and method used in the interface.

Note This method requires the ABAP Add-On.

BD97 – Read RFC Assignments Special Method Destinations Method Properties

Use the BD97 - Read RFC Assignments Special Method Destinations method to retrieve the RFC 
assignments that are defined in BD97. This method retrieves the RFC destinations based on Business 
Object name and method used in the interface.

Note This method requires the ABAP Add-On.

BD97 – Read RFC Destinations Standard Destinations Method Properties

Use the BD97 - Read RFC Assignments Standard Destinations method to retrieve the RFC assignments 
that are defined in BD97 for standard destinations.

Note This method requires the ABAP Add-On.

BDC – Data Loader Method Properties

Use the BDC Data Loader method to pass pre-recorded BDC (Batch Data Communication) data into a 
function that either executes the transaction directly (Synchronous) or records the session, returning the 
Session ID that can be found using SAP Transaction SM35 for processing.

• SAP Transaction—SAP transaction code to be called.

• Transaction BDC Data—BDC Data pre-recorded and formatted per SAP requirements. Transaction 
recordings can be created using the SAP BDC Recorder transaction, accessible via SM35.

The BDC data consists of five columns that should be populated with the following information:

– Program – Enter SAP Program name (for example, SAPMV45A)

– Dynpro – Enter SAP Screen number (for example, 0100)

– DynBegin – Enter X if the screen (Dynpro) is a new screen in the screen sequence

– Field Name – Enter SAP Field name that data is to be supplied for, or the BDC reserved name 
such as BDC_OKCODE or BDC_CURSOR.

– Field Value – Enter the value for the screen field specified in FIELDNAME.

Note This method requires the ABAP Add-On.
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BDLS – Convert Logical Systems Background Job Method Properties

Use the BDLS - Convert Logical Systems Background Job method to convert logical system (LOGSYS) 
names using transaction code BDLS.

• Old Logical System Name—Logical system name that was copied over from the production system. 
The old logical system is copied over in the database copy activity and must be converted to the new 
logical system.

• New Logical System Name—New logical system name of the target system. This may be the old 
logical system name of the QA system that was refreshed from production.

Note The new logical system name must already be defined.

• Client Dependent Only—Choose Yes or No to indicate whether to convert only client dependent 
tables.

• Test Run—Choose Yes or No to indicate whether to execute a test run.

• Number of Entries per Commit—Enter numeric value to indicate the number of entries to include 
per Commit. The default is 100000 but you may increment this based on recommendations from 
your Database Administrator.  This number affects the amount of records changed per database 
commit.

• Job Name—Job name of the scheduled job in SAP. A relevant job name should be selected so that 
it can be easily found in the SM37 (Job overview) transaction, or subsequent methods to check the 
job status.

• Job Variant Name—Name of the job variant that will either be updated or created depending on 
whether it exists yet. This is required as the job variant will be created and will be used in scheduling 
the job.  This also provides some information that can be viewed later for auditing purposes.

• Tables to be Converted—If this field is left blank, the program will convert all pertinent tables.  If 
you want to run the job for a specific set of tables, or exclude certain tables, then reference a data 
table that contains a Table Name [String] column that contains the names of the tables to be 
converted.

Note This method requires the ABAP Add-On.

BDLS – Get Tables Method Properties

Use the BDLS - Get Tables method to retrieve a list of relevant BDLS tables for conversion. The list of 
tables includes the number of entries greater than the defined threshold.

Note This method requires the ABAP Add-On.

BW – BWA Reorganize Landscape Method Properties

Use the BW - BWA Reorganize Landscape method to reorganize the BWA landscape.

• RFC Destination—RFC destination to TREX engine.

• Force—Choose Yes or No to indicate whether to force the reorganization if the summary is no.
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Note This method requires the ABAP Add-On. This method is not supported on SAP BW systems running on 
HANA.

BW – Change Index Global Parameters Method Properties

Use the BW - Change Index Global Parameters method to modify the BWA index global parameters.

• Parameter Type—Type of global parameter to be changed. Choose the type from the drop-down list.

• Parameter Value—New value of the global parameter.

Note • This method requires the ABAP Add-On.

• This method is not supported on SAP BW systems running on HANA.

BW – Check DTP Status Method Properties

Use the BW - Check DTP Status method to determine Data Transfer Process (DTP) status in the BW 
system.

• Request ID — A numeric value or variable that represents the DTP request

Note This method can be used on only SAP BW 7.0 systems.

BW – Check OLAP Connection Method Properties

Use the BW - Check OLAP Connection method to verify connection to the OLAP interface in the BW 
system.

Note This method can be used on only SAP BW 7.0 systems.

BW – Get BW InfoCube Dimensions Method Properties

Use the BW - Get BW InfoCube Dimensions method to retrieve the list of InfoCubes in the BW system 
and their associated layout.

• Infocube — Name of the Infocube(s)

Note This method can be used on only SAP BW 7.0 systems.

BW – Get BWA Index Reorg Plan Data Method Properties

Use the BW - Get BWA Index Reorg Plan Data method to reorganize BWA landscape for performance.

• RFC Destination — RFC destination to TREX engine.

Note • This method requires the ABAP Add-On.

• This method can be used on SAP BW 7.0 and higher.

• This method is not supported on SAP BW systems running on HANA.
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BW – Get InfoCube Size Method Properties

Use the BW - Get InfoCube Size method to retrieve the row sizing information for all InfoCube tables.

Note This method can be used on only SAP BW 7.0 systems.

BW – Get Infocube List Method Properties

Use the BW - Get InfoCube List method to retrieve a list of InfoCubes in the BW system.

Note • This method requires the ABAP Add-On.

• This method can be used on both SAP BW 3.5 and 7.0 systems.

BW – Get Infopackage Source System Method Properties

Use the BW - Get Infopackage Source System method to determine the source system for a specified 
Infopackage.

Note • This method requires the ABAP Add-On.

• This method can be used on only SAP BW 7.0 systems.

BW – Get Last BWA Index Reorg Status Method Properties

Use the BW - Get Last BWA Index Reorg Status method to retrieve the state of the last executed 
reorganization plan.

• RFC Destination — RFC destination to TREX engine.

Note • This method requires the ABAP Add-On.

• This method can be used on SAP BW 7.0 and higher.

• This method is not supported on SAP BW systems running on HANA.

BW – Get Process Chain Jobs Method Properties

Use the BW - Get Process Chain Jobs method to retrieve a list of SM37 jobs.

• Process Chain — Name of the process chain

• Process Variant — Name of the process variant within the process chain

Note • This method requires the ABAP Add-On.

• This method can be used on only SAP BW 7.0 systems.

BW – Get Process Chain Log Method Properties

Use the BW - Get Process Chain Log method to retrieve the process chain status messages recorded in 
the process chain log.
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Note This method can be used on only SAP BW 7.0 systems.

BW – Get Process Chain Parent Method Properties

Use the BW - Get Process Chain Parent method to determine if a process chain is a meta-chain, and if 
so, its parent chain.

Note This method can be used on only SAP BW 7.0 systems.

BW – Get Process Chain Processes Method Properties

Use the BW - Get Process Chain Processes method to retrieve a list of the process variants in the process 
chain.

Note This method can be used on only SAP BW 7.0 systems.

BW – Get Process Variant Job Log Method Properties

Use the BW - Get Process Variant Job Log method to retrieve the status of process chain variant job logs, 
which contain detailed status messages and job status for process variant steps.

• Process Variant(s) — A variable that represents the name or ID of the process variant

Note This method can be used on only SAP BW 7.0 systems.

BW – Get Process Variant Log Method Properties

Use the BW - Get Process Variant Log method to retrieve the status of process chain variant logs, which 
contain detailed status messages and status for process variant steps.

• Process Variant(s) — A variable that represents the name or ID of the process variant

Note This method can be used on only SAP BW 7.0 systems.

BW – Get Queries for InfoCube Method Properties

Use the BW - Get Queries for InfoCube method to retrieve a list of the queries for an infocube.

• Infocube — Name of the infocube for which to retrieve queries

Note • This method requires the ABAP Add-On.

• This method can be used on both SAP BW 3.5 and 7.0 systems.

BW – Get Query Top Executions Method Properties

Use the BW - Get Query Top Executions method to retrieve the top queries by number of executions.

• Executions Threshold — Threshold for the number of executions.
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• Get Executions in the Last X Minutes — Start time to return results. The default value is 60 minutes.

Note • This method requires the ABAP Add-On.

• This method can be used on both SAP BW 3.5 and 7.0 systems.

BW – Get Source System Delta Queue Status (RSA7) Method Properties

Use the BW - Get Source System Delta Queue Status (RSA7) method to retrieve a list of the data sources 
and their status in RSA7.

• Source System Client — The client of the source system or a variable that represents the client

Note This method can be used on only SAP BW 7.0 systems.

BW – Infocube Memory Consumption – Grand Totals Method Properties

Use the BW - Infocube Memory Consumption - Grand Totals method to retrieve sizing data to estimate 
memory requirements of BW infocubes for indexing in BW Accelerator.

• Infocubes — List of infocubes for which to obtain sizing data.

• Run as Job — Choose Yes or No to indicate whether a job should be created for each infocube

Note When this field is set to Yes, the results will only return the Job ID. Information about the 
memory will be in the Background Job that is created; use SM37 - Simple Job Selection custom 
method to read memory information from job.

Note • This method requires the ABAP Add-On.

• This method can be used on SAP BW 3.5 and higher.

• This method is not supported on SAP BW systems running on HANA.

BW – Infocube Memory Consumption – Table Totals Method Properties

Use the BW - Infocube Memory Consumption - Table Totals method to retrieve sizing data for tables to 
estimate memory requirements of BW infocubes for indexing in BW Accelerator.

• Infocubes — List of infocubes for which to obtain sizing data.

Note • This method requires the ABAP Add-On.

• This method can be used on SAP BW 7.0 and higher.

• This method is not supported on SAP BW systems running on HANA.

BW – Infocube Memory Consumption Grand Totals From Job Method Properties

Use the BW - Infocube Memory Consumption - Grand Totals From Job method to retrieve sizing data 
per job to estimate memory requirements of BW infocubes for indexing in BW Accelerator.

• Job ID — Identification number of the job for which to retrieve sizing data.
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Note • This method requires the ABAP Add-On.

• This method can be used on SAP BW 7.0 and higher.

• This method is not supported on SAP BW systems running on HANA.   

BW – Infocube Table Sizes Method Properties

Use the BW - InfoCube Table Sizes method to retrieve infocube table sizes.

• Infocube — Infocube for which to obtains table size

Note • This method requires the ABAP Add-On.

• This method can be used on both SAP BW 3.5 and 7.0 systems.

BW – RSDDAGGRDIR List Aggregates Method Properties

Use the BW - RSDDAGGRDIR - List Aggregates method to retrieve a list of BW aggregates in BW 
Accelerator.

Note This method can be used on only SAP BW 7.0 systems.

BW – RSDDBIAMON2 Get Infocube Indexes for Query Method Properties

Use the BW - RSDDBIAMON2 Get Infocube Indexes for Query method to retrieve a list of the infocube 
indexes for a BW query.

Note • This method requires the ABAP add-on.

• This method can be used on SAP BW 7.0 and higher.

• This method is not supported on SAP BW systems running on HANA.

BW – RSDDSTAT Get BW 3.5 DM Statistics Method Properties

Use the BW - RSDDSTAT Get BW 3.5 DM Statistics method to retrieve a list of query statistics on BW 
3.5 systems.

Note This method can be used on only SAP BW 3.5 systems.

BW – RSDDSTAT Get BW 3.5 OLAP Statistics Method Properties

Use the BW - RSDDSTAT Get BW 3.5 OLAP Statistics method to retrieve a list of query statistics on 
BW 3.5 systems.

Note This method can be used on only SAP BW 3.5 systems.
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BW – RSDDSTAT Get BW 3.5 Header Statistics Method Properties

Use the BW - RSDDSTAT Get BW 3.5 Header Statistics method to retrieve a list of query statistics on 
BW 3.5 systems.

Note This method can be used on only SAP BW 3.5 systems.

BW – RSDDSTAT_DM List Queries with High DM Time Method Properties

Use the BW - RSDDSTAT_DM - List Queries with High DM Time method to retrieve a list of query 
statistics for all queries with high Data Manager read time.

• Read time in seconds — Minimum number of seconds for Data Manager read time for which to 
retrieve statistics

• Start Date (yyyyMMddHHmmss) — Start date and time to begin retrieving statistics

• Last X minutes prior to the specified date — Time period, in minutes, for selecting statistics based 
on the date

Note This method can be used on only SAP BW 7.0 systems.

BW – RSDDSTAT_OLAP List Queries with High OLAP Time Method Properties

Use the BW - RSDDSTAT_OLAP - List Queries with High OLAP Time method to retrieve a list of query 
statistics for all queries with high OLAP runtime.

• Run time in seconds — Minimum number of seconds for OLAP runtime for which to retrieve 
statistics

• Start Date (yyyyMMddHHmmss) — Start date and time to begin retrieving statistics

• Last X minutes prior to the specified date — Time period, in minutes, for selecting statistics based 
on the date

Note This method can be used on only SAP BW 7.0 systems.

BW – RSDDTPS Index Maintenance for Business Objects Polestar Method Properties

Use the BW - RSDDTPS Index Maintenance for Business Objects Polestar method to create indexes or 
convert existing indexes for infocubes that are used by Business Objects Explorer Accelerated.

Note This method requires the ABAP Add-On.

BW – RSDDV Create Index Method Properties

Use the BW - RSDDV Create Index method to create an index in BWA.

Note • This method requires the ABAP Add-On.

• This method is not supported on SAP BW systems running on HANA.
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BW – RSDDV Delete Index Method Properties

Use the BW - RSDDV Delete Index method to delete an index in BWA.

Note • This method requires the ABAP Add-On.

• This method is not supported on SAP BW systems running on HANA.

BW – RSDDV Fill Index Method Properties

Use the BW - RSDDV Fill Index method to fill an index in BWA.

Note This method requires the ABAP Add-On.

BW – RSPC Finish Process Chain Method Properties

Use the BW - RSPC Finish Process Chain method to reset the status of a failed process chain step and 
restart the chain to run to the end of the completion from the point of failure.

• Variant — Name of the process chain variant

• Instance — ID of a runtime instance of a process chain

• State — Choose the status of the process chain to run from the drop-down list:

Note This method requires the ABAP Add-On.

BW – RSPC Stop Process Chain Method Properties

Use the BW - RSPC Stop Process Chain method to stop execution of a process chain run, and to 
optionally kill any running process instance.

• Process Chain—Name of the process chain

• Kill Running Processes—Choose Yes or No to indicate whether to kill any running process instance.

Note This method requires the ABAP Add-On.

BW – RSRCACHE Get Cache Monitor Buffer Objects Method Properties

Use the BW - RSRCACHE Get Cache Monitor Buffer Objects method to retrieve the information of the 
BW cache monitor buffer objects.

Note This method can be used on only SAP BW 7.0 systems.

BW – RSRCACHE Get Cache Monitor Buffer Objects (SAP 7.40 and above) Method Properties

Use the BW - RSRCACHE Get Cache Monitor Buffer Objects (SAP 7.40 and above) method to retrieve 
the information of the BW cache monitor buffer objects. 
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Note This method can be used on only SAP BW 7.40 and above.

BW – RSRCACHE Get OLAP Cache Parameters Method Properties

Use the BW - RSRCACHE Get OLAP Cache Parameters method to retrieve the BW OLAP cache 
parameters. 

Note This method can be used on only SAP BW 7.0 systems.

BW – RSRT Analyze Query Method Properties

Use the BW - RSRT Analyze Query method to execute a BW query and provide performance statistics 
on the query runtime.

• Use Cache—Choose Yes or No to indicate whether to use OLAP cache during the query execution

• Use Aggregates—Choose Yes or No to indicate whether to use aggregates during the query 
execution

• Use BWA Index—Choose Yes or No to indicate whether to use BWA index (if it exists) during the 
query execution

• Use Parallel Processing—Choose Yes or No to indicate whether to use parallel processing during 
the query execution

• Query List—List of queries

Note • This method requires the ABAP Add-On.

• This method can be used on only SAP BW 7.0 systems.

BW – RSRT Analyze Single Query Method Properties

Use the BW - RSRT - Analyze Single Query method to execute a BW query and provide performance 
statistics on the query runtime.

• Query Technical Name—Name of the query to execute

• Use Cache—Choose Yes or No to indicate whether to use OLAP cache during the query execution

• Use Aggregates—Choose Yes or No to indicate whether to use aggregates during the query 
execution

• Use BWA Index—Choose Yes or No to indicate whether to use BWA index (if it exists) during the 
query execution

• Use Parallel Processing—Choose Yes or No to indicate whether to use parallel processing during 
the query execution

• Query Variables—Query input variant values

Note • This method requires the ABAP Add-On.

• This method can be used on only SAP BW 7.0 systems.
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BW – RSRT Check Query Mandatory Variables Method Properties

Use the BW - RSRT Check Query Mandatory Variables method to check the entry requirements for the 
variables of an SAP BW query (optional, mandatory, or mandatory but initial value not allowed).

Note • This method requires the ABAP Add-On.

• This method can be used on only SAP BW 7.0 systems.

BW – RSRV Data Consistency Check Method Properties

Use the BW - RSRV Data Consistency Check method to check for data discrepancies on BW infocubes 
and their BWA indexes.

Note • This method requires the ABAP Add-On.

• This method can be used on SAP BW 7.0 and higher.

• This method is not supported on SAP BW systems running on HANA.

BW – Read Info Provider Data Method Properties

Use the BW - Read Info Provider Data method to read data from InfoProvider objects in SAP BW.

Table 13-3 Provides description of data from InfoProvider objects in SAP BW

Note This method can be used on only SAP BW 7.0 systems.

BW – Read Info Provider Vertical Data Method Properties 

Use the BW - Read Info Provider Vertical Data method to read data from InfoProvider objects in SAP 
BW. The data is returned in a vertical data table.

Field Description

Info provider Technical name of the InfoCube, DataStore object or 
MultiProvider.

RFC mode ID RFC mode logical identifier.
RFC mode receiver Received RFC-capable ABAP function name.
SFC Table List of characteristics.
SFK Table List of key figures.
Table Selection List of table selections.
RTime Table Table of intervals for non-cumulatives.
Requid Table Ranges for REQUID table.
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Note This method can be used on only SAP BW 7.0 systems.

BW – SE38 Create Variant Method Properties

Use the BW - SM38 Create Variant method to create a variant for an SAP ABAP program.

Field Description

Info provider Technical name of the InfoCube, DataStore object or 
MultiProvider.

RFC mode ID RFC mode logical identifier.

RFC mode receiver Received RFC-capable ABAP function name.

Info provider Technical name of the InfoCube, DataStore object or 
MultiProvider.

SFC Table List of characters.

SFK Table List of key figures.

RTime Table Table of intervals for non-cumulatives.
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Table 13-4 Describes data in a SAP ABAP program

BW – TREX Get Alert Details Method Properties

Use the BW - TREX Get Alert Details method to retrieve the alert details in the TREX index.

Field Description

Variant Values Values to be assigned to the variant.

Note This requires a table variable with the following parameters:

• Program Parameter - Enter parameter or select option name defined on the ABAP program's 
selection screen. Use the screen field value that is displayed when you press F1 and then 
select Technical Information on the selection screen field.

• Type of Selection - Enter P (Parameter) or S (Select-Option).

• Include/Exclude -- Enter I (Inclusive of defined values/range) or E (Exclusive of defined 
values/range).

• Selection Option - Enter one of the following valid values:

EQ - Equal To (= Low)

NE - Not equal to (<> Low)

BT - Between lower and upper value (Low <= x <= High)

NB - Outside lower and upper value (x < Low and High < x )

CP - Contains the pattern (low value contains a wildcard (*). For instance, enter the value 
"test*" for all values beginning with "test")

NP - Does not contain the pattern (negative relationship as described in CP)

LT - Less Than (< Low)

LE - Less than or equal to (<= Low)

GT - Greater Than (> Low)

GE - Greater than or equal to  (>=Low)

• Low Value - Enter the lower limit value, or for single value.

• High value - Enter the upper limit value, for ranges.
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Table 13-5 Describes the fields in an TREX index

Note • This method requires the ABAP Add-On.

• This method can be used on SAP BW 7.0 and higher.

• This method is not supported on SAP BW systems running on HANA.

BW – TREX Get Alerts Method Properties

Use the BW - TREX Get Alerts method to retrieve the alerts in the TREX index.

Note • This method requires the ABAP Add-On.

• This method can be used on SAP BW 7.0 and higher.

• This method is not supported on SAP BW systems running on HANA.

BW – TREX Get Index Status Method Properties

Use the BW - TREX Get Index Status method to retrieve the status of the TREX index.

Note • This method requires the ABAP Add-On.

• This method can be used on SAP BW 7.0 and higher.

• This method is not supported on SAP BW systems running on HANA.

BW – TREX Get Landscape Status Summary Method Properties

Use the BW - TREX Get Landscape Status Summary method to retrieve the TREX BWA blade status 
summary information.

Field Description

RFC Destination Name of the TREX server RFC destination.

Field Description

RFC Destination Name of the TREX server RFC destination.

Field Description

Infocube Name of the index infocube.

Field Description

RFC Destination Name of the TREX server for RFC destination.
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Note • This method requires the ABAP Add-On.

• This method can be used on SAP BW 7.0 and higher.

• This method is not supported on SAP BW systems running on HANA.

BW – TREX Kill Server Processes Method Properties

Use the BW - TREX Kill Server Processes method to kill processes running on the TREX server.

Note • This method requires the ABAP Add-On.

• This method is not supported on SAP BW systems running on HANA.

BW – TREX List Indexes Method Properties

Use the BW - TREX List Indexes method to retrieve a list of indexes on the BWA blade and memory 
usage per index.

Note • This method requires the ABAP Add-On.

• This method can be used on SAP BW 7.0 and higher.

• This method is not supported on SAP BW systems running on HANA.

BW – TREX Reconfigure Server Method Properties

Use the BW - TREX Reconfigure Server method to reconfigure the TREX server.

Field Description

RFC Destination Name of the TREX server RFC destination.

Server Host name of the TREX server where the processes are 
running.

Process IDs Process IDs, separated by a comma, for those processes to be 
killed.

Field Description

RFC Destination TREX server RFC destination.

Index Server Index server host/port.

Namespace Index namespace.
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Note • This method requires the ABAP Add-On.

• This method is not supported on SAP BW systems running on HANA.

BW – TREX Restart Server Method Properties

Use the BW - TREX Restart Server method to restart the TREX server.

Note • This method requires the ABAP Add-On.

• This method is not supported on SAP BW systems running on HANA.

BW – TREX Service Statistics Method Properties

Use the BW - TREX Service Statistics method to retrieve blade TREX service statistics.

Note • This method requires the ABAP Add-On.

• This method can be used on SAP BW 7.0 and higher.

• This method is not supported on SAP BW systems running on HANA.

CRMRFCPAR – Modify Method Properties

Use the CRMRFCPAR - Modify method to change an existing entry in the CRMRFCPAR configuration 
table for a consumer and object combination.

Field Description

RFC Destination Name of the TREX server RFC destination.

Server Host name of the TREX server.

Process IDs Process IDs, separated by a comma.

Field Description

RFC Destination Name of the TREX server RFC destination.
Server Host name of the TREX server.
Process IDs Process IDs, separated by a comma.

Field Description

RFC Destination TREX server RFC destination.
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Note This method requires the ABAP Add-On.

CRMRFCPAR – Read Method Properties

Use the CRMRFCPAR - Read method to retrieve information from the CRMRFCPAR table.

Note This method requires the ABAP Add-On.

CRMRFCPAR – Remove Method Properties

Use the CRMRFCPAR - Remove method to remove a specific entry in the CRMRFCPAR configuration 
table for a consumer and object combination.

Note This method requires the ABAP Add-On.

CRMRFCPAR – Create Method Properties

Use the CRMRFCPAR - Create method to create a new entry in the CRMRFCPAR configuration table 
for a consumer and object combination.

Field Description

Consumer CRM partner name. This is a key field used to look for entries 
in CRMRFCPAR.

Object Name Data object/table name. This is a key field used to look for 
entries in CRMRFCPAR.

Download Type Choose the type of download. This is a key field used to look 
for entries in CRMRFCPAR.

RFC Destination RFC destination of partner. This is a key field used to look for 
entries in CRMRFCPAR.

Field Description

Consumer Partner system name, such as CRM or IPC.

Object Name Name of the data object. Enter asterisk (*) to retrieve all 
objects.

Field Description

Consumer CRM partner name. This is a key field used to look for entries 
in CRMRFCPAR.

Object Name Data object/table name. This is a key field used to look for 
entries in CRMRFCPAR.
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Note This method requires the ABAP Add-On.

DB02 – Get DB6 Tablespace Method Properties

Use the DB02 - Get DB6 Tablespace method to retrieve DB6 (DB2 UDB) tablespace usage data.

Note This method requires the ABAP Add-On.

DB02 – Reset Statistics Method Properties

Use the DB02 - Reset Statistics method to launch the SAP program to reset the DB2 database statistics.

Note This method requires the ABAP Add-On.

DBACOCKPIT – Read DB6 UDF Configuration Method Properties

Use the DBACOCKPIT - Read DB6 UDF Configuration method to read the path for the User Defined 
Function library. This is defined for DB6 databases via DBACockpit transaction.

 DBACOCKPIT – Update DB6 UDF Configuration Method Properties

Use the DBACOCKPIT - Update DB6 UDF Configuration method to update the path for the User Defined Function 
library.Execute ABAP Function – XML Method Properties

Use the Execute ABAP Function - XML method to call function methods through an SAP generic proxy.

Field Description

Consumer CRM partner name. This is a key field used to look for entries 
in CRMRFCPAR.

Object Name Data object/table name. This is a key field used to look for 
entries in CRMRFCPAR.

RFC Destination RFC destination of partner.

Field Description

Percentage Used Value for the percentage of used tablespace. Data will be 
retrieved for tablespaces with a percentage of usage equal to 
or greater than the value specified. The default value is 0.
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Execute ABAP Program – String Method Properties

Use the Execute ABAP Program - String method to run SAP programs through execution of the function 
inst_execute_report. The results are returned in a string.

Execute ABAP Program – Table Method Properties

Use the Execute ABAP Program - Table method to run SAP programs through execution of the function 
inst_execute_report. The results are returned in a data table.

Get SAP Server Info Method Properties

Use the Get SAP Server Info method to retrieve the SAP server host name and IP address and other 
information for all instances in an SAP system.

ICM – Clear HTTP Cache Method Properties

Use the ICM - Clear HTTP Cache method to clear the HTTP cache on the ABAP server.

Field Description

Program name Name of the SAP program to be run.

Parameters If the program has input parameters, you must specify a data table 
with the columns Name and Value. For example, for the program 
RSRFCPIN, the data table would contain the columns:

Name = DEST

Value = <destination to test>

Field Description

Program name Name of the SAP program to be run.

Parameters If the program has input parameters, you must specify a data table 
with the columns Name and Value. For example, for the program 
RSRFCPIN, the data table would contain the columns:

Name = DEST

Value = <destination to test>

Field Description

Server 
(ServerHost_SID_SysNo)

Name of the SAP application server for which information should 
be retrieved. Use the wildcard (*) to retrieve information from all 
servers.
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Note This method requires the ABAP Add-On.

ICM – Restart J2EE Server Method Properties

Use the ICM - Restart J2EE Server method to restart the J2EE server that is associated with an ABAP 
system (ABAP+Java solution) after a system copy operation or if the J2EE server has been manually shut 
down.

Note This method requires the ABAP Add-On.

ICM – Stop J2EE Server Method Properties

Note Use the ICM - Stop J2EE Server method to shut down the J2EE server that is associated with an ABAP 
system (ABAP+Java solution).This method requires the ABAP Add-On.

PFCG – Update Composite Role Method Properties

Use the PFCG - Update Composite Role method to update a composite role.

Note This method requires the ABAP Add-On.

PI – Get Message List Method Properties

Use the PI - Get Message List method to monitor individual XML message processing for a specified 
group of messages from an SAP server.

RBDMONI5 – Get Open Change Pointers Method Properties

Use the RBDMONI5 - Get Open Change Pointers method to retrieve the number of outstanding change 
pointers to be processed for a selected message type.

Field Description

Global Choose Yes or No to indicate whether to clear the cache on all 
application servers. If No is selected, only the cache on the 
application server on which this method is executed will be cleared.

Fields Description

Message status group Select the type of messages to retrieve from the drop-down list:

All Errors – Retrieves all error messages

Get messages in the last X 
minutes

Time period, in days, for selecting messages to retrieve based on the date
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RSMO – Get InfoPackage Requests Method Properties

Use the RSMO - Get InfoPackage Requests method to retrieve the InfoPackage processing requests that 
have not completed processing or are in failed status.

RSMO – InfoPackage Request Error Message Method Properties

Use the RSMO - InfoPackage Request Error Message method to retrieve the InfoPackage request 
processing log with detailed information about InfoPackage failures.

RSRDA End Daemons Method Properties

Use the RSRDA End Daemons method to stop all BW daemon processes on the BW system. This method 
is used post system copy to ensure that there are no data transmissions to satellite systems until the 
reconfiguration is completed.

Note This method requires the ABAP Add-On.

RZ03 – Swap OP Modes Method Properties

Use the RZ03 - Swap OP Modes method to switch to another operation mode for a specific server. For 
example, when alerts report not enough dial work processes, this method is used to trigger a temporary 
increase in dialog work processes.

RZ04 – List Operation Modes Instances Method Properties

Use the RZ04 - List Operation Modes Instances method to list all instance information and the operation 
modes assigned to the instance to verify that changes have been made after performing a system copy.

Fields Description

Message Type Enter the message type to retrieve the number of outstanding change 
pointers. Leave this field blank to retrieve open change pointers for 
all message types.

Fields Description

Date (yyyyMMddHHmmss) Specify the date from which to retrieve the data. If you leave this field 
blank, data from the current date will be retrieved.

Last X minutes prior to the 
specified date

Time period, in minutes, for selecting InfoPackage processing 
requests based on the date

Fields Description

Operation Mode Name of the operation mode, as defined in RZ04, to switch the server. 
This field is case-sensitive.

Application Server 
(ServerHost_SID_SysNo)

Full name of the application server (instance) to be switched. This 
field is case-sensitive.
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Note This method requires the ABAP Add-On.

RZ04 – List Operation Modes Method Properties

Use the RZ04 - List Operation Modes method to list all operation modes.

Note This method requires the ABAP Add-On.

RZ04 – Update All Operation Modes Method Properties

Use the RZ04 - Update All Operation Modes method to automatically remove all incorrect productive 
instances and to create new instances.

Note This method requires the ABAP Add-On.

RZ10 – Delete Profiles Method Properties

Use the RZ10 - Delete Profiles method to delete the profiles of all active servers.

RZ10 – Import Profiles Method Properties

Use the RZ10 - Import Profiles method to import the start and instance profiles of all active servers.

RZ10 – Modify Profile Parameter Value Method Properties

Use the RZ10 - Modify Profile Parameter Value method to verify the system profile parameter value and 
modify the value if it is incorrect.

Note This method requires the ABAP Add-On.

RZ10 – Read Profile Parameters Method Properties

Use the RZ10 - Read Profile Parameters method to verify system profile parameter values.

ProfileType of system profile (Default, Start, or Instance). This field is case-sensitive.

ParameterName of the parameter whose values need to be verified. This field is case-sensitive. If left 
blank or the asterisk (*) is used, all parameters will be returned.

Note This method requires the ABAP Add-On.

Fields Description

Parameter Name Name of the profile parameter to be verified. Refer to SAP 
transaction RZ11 for a complete set of profile parameter definitions 
and allowable values.

Parameter Value New value to be assigned to the profile parameter
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RZ11 – Change Dynamic Parameter Method Properties

Use the RZ11 - Change Dynamic Parameter method to change a dynamically switchable profile 
parameter. The Dynamically Switchable flag must be switched to ON in RZ11 to be able to use this 
method.

RZ12 – Create Logon Group Method Properties

Note Use the RZ12 - Create Logon Group method to create a new SAP logon group.This method requires the 
ABAP Add-On.

RZ12 – Delete All Logon Groups Method Properties

Use the RZ12 - Delete All Logon Groups method to delete all SAP logon groups.

Note This method requires the ABAP Add-On.

RZ12 – Delete Logon Group Method Properties

Note Use the RZ12 - Delete Logon Group method to delete a specific SAP logon group.This method requires 
the ABAP Add-On.

RZ12 – List Logon Groups Method Properties

Use the RZ12 - List Logon Groups method to retrieve a list of all logon groups on an SAP system.

Note This method requires the ABAP Add-On.

RZ20 – Change CCMS Thresholds Method Properties

Use the RZ20 - Change CCMS Thresholds method to change the performance threshold values of CCMS 
monitoring classes.

Note This method requires the ABAP Add-On.

RZ70 – Get Status Info Method Properties

Use the RZ70 - Get Status Info method to retrieve the host name and gateway service configured on the 
target system. If the target system is not configured or is configured incorrectly, an error is returned. If 
the target system is configured, the method returns the SAP host name and SAP gateway service.

Fields Description

Parameter value New value to assign to the dynamically switchable profile parameter.
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Note This method requires the ABAP Add-On.

RZ70 – Set SLD Supplier Method Properties

Use the RZ70 - Set SLD Supplier method to reset the System Landscape Directory (SLD) supplier 
configuration.

Read Single Column From SAP Table Method Properties

Use the Read Single Column From SAP Table method to read a single column from a specific SAP table.

SAP RFC Function Properties

You can use this activity to execute commonly used transactions that will be run against an SAP system 
or application server.

SCC4 – Modify Client Method Properties

Use the SCC4 - Modify Client method to maintain the attributes of clients.

Note This method requires the ABAP Add-On.

SCC4 – Read Client Method Properties

Use the SCC4 - Read Client method to read the client details configured on the SAP system. This method 
retrieves the details of the SAP Table T000 that is viewed and maintained using the SAP transaction 
SCC4. This method can be used to verify changes (Change date/user) or the current client configuration, 
such as a client that is open for modification.

In a corrective action scenario, clients can be monitored on QA and Production systems to check if any 
client is currently open for modifications, and then use the custom method SCC4 Modify Client to close 
or protect the client for modifications.

In a system copy scenario, this method allows you to verify the current client settings, and to restore 
them to the original settings as a final step in the system copy activities.

Fields Description

SAP Host Name Host name of server with SLD (for example, sapqaxi.cisco.com).

SAP Gateway Service SAP Gateway on SLD server (for example, sapgw01).

Fields Description

Client SAP client number to be maintained.

Logical System SAP logical system ID, validated based on SAP table TBDLS. This is 
normally a combination of the system ID and the client number (for 
example, QUACLNT800). A blank value results in no changes being 
made.
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Note This method requires the ABAP Add-On.

SCC7 – Client Import Method Properties

Use the SCC7 - Client Import method to import data from a client export (client copy job) into SAP.

Note This method is dependent on the export transports being in the import queue. See examples for using 
SSH script if the transport requests are not in the import queue.

Note • This method requires the ABAP Add-On.

• If the transport requests are not yet in the import queue in the target system, use the following 
commands using an SSH script:

./tp pf=TPPARAM addtobuffer <commfile name> <target sys id> u18

Example:

cd /usr/sap/trans/bin

./tp pf=TPPARAM addtobuffer "DEVKT00005"  P11 u18

You can also still import the transport requests directly with the tp. Do so in the 
sequence "DEVKO00005", "DEVKT00005",  "DEVKX00005". Where DEV = System ID and KO, KT, 
KX are the Cross-Client, Client Data, Client Text transports, respectively.

Example:

./tp pf=TPPARAM import "DEVKT00005" P11 client005 u18

SCC8 – Client Export Method Properties

Use the SCC8 - Client Export method to export data (SAP users and their profiles) from SAP.

Note This method requires the ABAP Add-On.

SCOT – Clear Node Address Method Properties

Use the SCOT - Clear Node Address method to clear specific recipient filters for existing nodes defined 
in the SA Connect application in an SAP ABAP system. This method is called during the post-system 
copy functions to clear specific outbound mail routing settings to prevent emails from being sent out to 
partner systems.

Note This method requires the ABAP Add-On.

Fields Description

Export Profile Specify the name of the profile to be exported. This is the named 
profile created via SAP transaction SCC8.

Target System ID System ID for the target system. Typically, this is the same system ID 
as the export system in a client-copy scenario.
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SCOT – Get Transaction SCOT Data Method Properties

Use the SCOT - Get Transaction SCOT Data method to retrieve data from SAPConnect that is related to 
external communications from an SAP system such as fax and email.  

SCOT – Set Node Address Method Properties

Use the SCOT - Set Node Address method to set specific recipient filters for existing nodes defined in 
the SAPConnect application in an SAP ABAP system. This method is called to set specific outbound 
mail routing settings to prevent emails from being sent out to partner systems.

Note This method requires the ABAP Add-On.

SCOT – Set SMTP Host Method Properties

Use the SCOT - Set SMTP Host method to reset the host name and port number for an existing SMTP 
node.

Note This method requires the ABAP Add-On.

SDCCN – Clear Tasks Method Properties

Use the SDCCN - Clear Tasks method to clear all SDCCN (Service Data Control Center) tasks.

Note This method requires the ABAP Add-On.

SDCCN – Read Tasks Method Properties

Use the SDCCN - Read Tasks method to retrieve a list of scheduled SDCCN (Service Data Control 
Center) tasks.  

Note This method requires the ABAP Add-On.

SDCCN – Schedule Tasks Method Properties

Use the SDCCN - Schedule Tasks method to schedule SDCCN (Service Data Control Center) tasks.

Note This method requires the ABAP Add-On.

SE06 – Perform Post-Installation Actions Method Properties

Use the SE06 - Perform Post-Installation Actions method to reset the TMS configuration.

Note This method requires the ABAP Add-On.
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SE06 – Set System Change Options Method Properties

Use the SE06 - Set System Change Options method to modify the setting of system change options in 
the SAP system.

Note This method requires the ABAP Add-On.

SE06 – System Change Method Properties

Use the SE06 - System Change Options method to retrieve a specified number of system changes.

SE10 – Export Tables Method Properties

Use the SE10 - Export Table method to create an SAP transport that contains SAP table data that is to 
be exported from the target system during a system copy and then re-imported after a system copy. This 
method can be used in instances where database scripts are not allowed to be run against the SAP 
database.

Note This method requires the ABAP Add-On.

SE38 – Change Variant Method Properties

Use the SM38 - Change Variant method to modify an existing variant of an SAP program.

Note This method requires the ABAP Add-On.

SE38 – Create Variant Method Properties

Use the SM38 - Create Variant method to create a variant for an SAP ABAP program.

Fields Description

Export Table List List of ABAP tables to be exported in a single transport (Change 
Request). Tables must be transparent as defined in the SAP ABAP 
Data Dictionary.
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Note This method requires the ABAP Add-On.

Fields Description

Variant Description Description of the variant.

Variant Values Values to be assigned to the variant.

Note This requires a table variable with the 
following parameters:

• Program Parameter - Enter parameter or select option 
name defined on the ABAP program's selection screen. 
Use the screen field value that is displayed when you 
press F1 and then select Technical Information on the 
selection screen field.

• Type of Selection - Enter P (Parameter) or S 
(Select-Option).

• Include/Exclude -- Enter I (Inclusive of defined 
values/range) or E (Exclusive of defined values/range).

• Selection Option - Enter one of the following valid 
values:

– EQ - Equal To (= Low)

– NE - Not equal to (<> Low)

– BT - Between lower and upper value (Low <= x <= 
High)

– NB - Outside lower and upper value (x < Low and 
High < x )

– CP - Contains the pattern (low value contains a 
wildcard (*). For instance, enter the value "test*" for 
all values beginning with "test")

– NP - Does not contain the pattern (negative 
relationship as described in CP)

– LT - Less Than (< Low)

– LE - Less than or equal to (<= Low)

– GT - Greater Than (> Low)

– GE - Greater than or equal to  (>=Low)

• Low Value - Enter the lower limit value, or for single 
value.

• High value - Enter the upper limit value, for ranges.
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SE38 – Display Variant Values Method Properties

Use the SE38 - Display Variant Values method to retrieve a list variant parameters for a program.

Note This method requires the ABAP Add-On.

SE61 – Display Document Method Properties

Use the SE61 - Display Document method to display the content of a document on the SAP system (for 
example, ZLOGIN_SCREEN_INFO).

Note This method requires the ABAP Add-On.

SE61 – Modify Document Method Properties

Use the SE61 - Modify Document method to change the content of a document on the SAP system (for 
example, ZLOGIN_SCREEN_INFO).

Note This method requires the ABAP Add-On.

Fields Description

Program Name Report or program name for which to retrieve the list of variant 
parameters.

Variant Variant name of the program. This field is case sensitive.

Fields Description

Document Language Language of the document to be modified or displayed (for example, 
EN=English, DE=German)

Fields Description

Document Language Language of the document to be modified or displayed (for example, 
EN=English, DE=German)

Document Lines Table of text lines that make up the content of the document.  The 
table should contain the following columns:

• Line Number - Line number to be updated. Each line number 
equals one row in the document. The current content of the 
document will be overwritten.

• Text Line - Text line to be updated. Each text line equals one row 
in the document. The current content of the document will be 
overwritten.
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SECSTORE – Check Status Method Properties

Use the SECSTORE - Check Status method to check the status of the secure storage on the ABAP stack.

Note This method requires the ABAP Add-On.

SECSTORE – Set Migration Key Method Properties

Use the SECSTORE - Set Migration Key method to set the migration key in the event the system ID or 
installation number has changed in a production system. Changes to the installation number can occur 
in the context of reorganizations and are dependent on the import of a new license. This function converts 
the table copied from the production system.

Note This method requires the ABAP Add-On.

SICF – Activate Service Method Properties

Use the SICF - Activate Service method to activate service nodes and their direct sub-nodes defined in 
the Internet Connection Framework Tree (HTTP Service Tree) via SAP transaction SICF.

Note This method requires the ABAP Add-On.

SICF – Clear Service Anonymous User Login Data Method Properties

Use the SICF - Clear Service Anonymous User Login Data method to clear the anonymous logon user 
for a service defined in the Internet Connection Framework Tree (HTTP Service Tree) via SAP 
Transaction SICF.

Fields Description

Old System ID System number of the source system.

Old Installation Number Installation number of the source system.

New Migration Key Migration key (Hex values) downloaded from the SAP Service 
Marketplace.

Fields Description

Service Name SAP service name (for example, SAP/PUBLIC/PING).

Test Only Choose Yes or No to indicate whether changes are to be made; if set 
to No, only the verification of the service name is performed.

Apply to Direct 
Subordinate(s)

Choose Yes or No to indicate whether to apply the activation activity 
to the direct sub-nodes of the specified service name (direct children 
of the service name in the HTTP tree).  
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Note This method requires the ABAP Add-On.

SICF – Deactivate Service Method Properties

Use the SICF - Deactivate Service method to deactivate service nodes and their direct sub-nodes defined 
in the Internet Connection Framework Tree (HTTP Service Tree) via SAP transaction SICF.

Note This method requires the ABAP Add-On.

SICF – Get Service Anonymous User Login Data Method Properties

Use the SICF - Get Service Anonymous User Login Data method to retrieve the user login data for the 
service.

Note This method requires the ABAP Add-On.

SICF – Update Service Anonymous User Method Properties

Use the SICF - Update Service Anonymous User method to update the anonymous logon user for a 
service defined in the Internet Connection Framework Tree (HTTP Service Tree) via SAP transaction 
SICF.

Note This method requires the ABAP Add-On.

SICK – Basic Installation Check Method Properties

Use the SICK - Basic Installation Check method to run the SAP basic installation check report to check 
system consistency.

SLDCHECK – PI Check Method Properties

Use the SLDCHECK - PI Check method to run the SLDCheck transaction and report on the connection 
status for a system to the SAP System Landscape Directory. 

Fields Description

Test Only Choose Yes or No to indicate whether changes are to be made; if set 
to No, only the verification of the service name is performed.

Apply to Direct 
Subordinate(s)

Choose Yes or No to indicate whether to apply the activation activity 
to the direct sub-nodes of the specified service name (direct children 
of the service name in the HTTP tree).  

Method Parameter
No parameters are required for this RFC method. 
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SLG1 – Read Application Log Method Properties

Use the SLG1 - Read Application Log method to retrieve log messages from the SAP application log, 
accessible via transaction SLG1.

Note This method requires the ABAP Add-On.

SLT - Get Connection Parameters Properties

Use the SLT - Get Connection Parameters method to retrieve the data of SLT connection parameters.

SLT - Get Connection Status Method Properties

Use the SLT - Get Connection Status method to obtain the source and target connection status of the SLT 
data replication server.

SLT - Get Job Status Method Properties

Use the SLT - Get Job Status method to obtain the status of SLT data replication background jobs.

SLT - Get Mass Transfer ID Mapping Method Properties

Use the SLT - Get Mass Transfer ID mapping method to retrieve the schema configuration ID to which 
an SLT mass transfer ID maps.

Note This method requires the ABAP Add-On.

SLT - Get Replication Runtime Statistics Method Properties

Use the SLT - Get Replication Runtime Statistics method to retrieve the replication runtime statistics of 
an SLT data replication schema.

Note This method requires the ABAP Add-On.

Fields Description

Date From (yyyyMMdd) Enter lowest date for searching the log table.

Date To (yyyyMMdd) Enter highest date for searching the log table.

Time To (hhmmss) Enter highest time for searching the log table.

Program Name Name of the program that generated the log message.

Transaction Code Transaction code that generated the log message.

User SAP user running the program that caused the log message.

Fields Description

Mass Transfer ID SLT mass transfer ID
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SLT - Get Schema Header Data Method Properties

Use the SLT - Get Schema Header Data method to retrieve the SLT schema header data.

Note This method requires the ABAP Add-On.

SLT - Get Schema Trigger Status Method Properties

Use the SLT - Get Schema Trigger Status method to retrieve the schema triggers status of an SLT data 
replication schema.

Note This method requires the ABAP Add-On.

SLT - Get Table Status Method Properties

Use the SLT - Get Table Status method to obtain the status of SLT data replication related to a database 
table.

Note This method requires the ABAP Add-On.

SLT - Start Jobs Method Properties

Use the SLT - Start Jobs method to start the SLT data replication background jobs.

Note This method requires the ABAP Add-On.

SLT - Stop Jobs Method Properties

Use the SLT - Stop Jobs method to stop the SLT data replication background jobs.

Note This method requires the ABAP Add-On.

SM01 – Lock Transaction Method Properties

Use the SM01 - Lock Transaction method to lock a specific SAP transaction to prevent users from 
unknowingly starting the transaction during a technical operation.

Note This method requires the ABAP Add-On.

SM01 – Unlock Transaction Method Properties

Use the SM01 - Unlock Transaction method to unlock a specific SAP transaction that was temporarily 
locked.

Note This method requires the ABAP Add-On.
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SM02 – Create System Message Method Properties

Use the SM02 - Create System Message method to create system-wide messages to alert SAP users of 
any system maintenance or any activity that may affect all users.

SM02 – Delete System Message Method Properties

Use the SM02 - Delete System Message method to manually delete a SAP system message that was 
create using RFC SM02 - Create System Message. After this method is executed, users will no loner see 
the system message when they log into the SAP system and viewing messages via SAP transaction 
SM02.

Note This method requires the ABAP Add-On.

SM04 – Logoff User Method Properties

Use the SM04 - Logoff User method to log off a user that is currently logged on to an SAP application 
server.

Field Description

Message Line 1 System message text line 1. For example:

System will be shut down on Friday, 7:00 PM PST

Message Line 2 System message text line 2. For example:

Estimated restart is Monday, 8:00 AM EST

Message Line 3 System message text line 3. For example:

Please complete work and log off prior to the shutdown time 
otherwise unsaved data may be lost.

Delete Date (yyyyMMdd) Date the message is to be deleted automatically from database 
(optional).

Delete Time (hhmmss) Time the message is to be deleted automatically from database 
(optional).

Client Specific client ID (optional).

Language Language of message (optional).

Field Description

Message ID Unique message ID of the SAP system message to be deleted.

Note The Message ID is returned from the SM02 
Create System Message method. It can also be 
viewed in the table TEMSG.
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SM12 – Age Enqueue Entries Method Properties

Use the SM12 - Age Enqueue Entries method to retrieve all SAP document locks older than the specified 
time period.

SM12 – Enqueue Size Method Properties

Use the SM12 - Enqueue Size method to retrieve the number of Enqueue entries (locks) that exceed a 
defined maximum number.

SM12 – Select Lock Entries Method Properties

Use the SM12 - Select Lock Entries method displays the specified enqueue lock entries on the specified 
SAP system.

Field Description

Only Pooled User Choose Yes to reset the session pool or select No to log off the user.

Note The SAP runtime environment stores user 
context data in a session pool. Resetting the 
session pool is pertinent to RFC or plug-in 
type user sessions. The session pool allows for 
a quick reconnect of a user context for a RFC 
or plug-in type of user connection. Resetting 
the session pool (Only Pooled User = Yes) 
does not affect a user currently connected to 
the system.

Method Parameter

Displays the parameters for the selected method. Complete the appropriate fields, as necessary.

Field Description

Maximum number of locks in 
the tables

Number of locks to use as a threshold to indicate that a problem may 
exist.

Field Description

Lock argument Key field of the rows in the SAP tables.

Date (yyyyMMddHHmmss) Specify the end date for retrieving lock entries. If you leave this field 
blank, data for the current date/time will be retrieved.

Last X minutes prior to the 
specified date

Time period, in minutes, for selecting data based on the date.
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SM13 – Check Update System Status Method Properties

Use the SM13 - Check Update System Status method to verify whether the update system is active or 
inactive.

Note This method requires the ABAP Add-On.

SM13 – Delete Update Record Method Properties

Use the SM13 - Delete Update Record method to delete a single update record that is stored in the 
VBLOG (Update Log) table.

Note This method requires the ABAP Add-On.

SM13 – Delete Update Records Method Properties

Use the SM13 - Delete Update Records method to delete all update records currently found in the 
VBLOG (Update log) table.

Note This method requires the ABAP Add-On.

SM13 – Get Update Error Message Method Properties

Use the SM13 - Get Update Error Message method to displays the properties used to retrieve the error 
message for a specific update record.

Field Description

Update Key Unique key of the update record to be deleted. This field is 
case-sensitive.

Field Description

Update Keys Unique keys of the update records to be deleted. This field is 
case-sensitive.

Method Parameters 

Displays the parameter for the selected method. Complete the appropriate fields, as necessary.

Field Description

Key Update record key currently in error status.
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SM13 – Get Update Error Message Method Properties

Use the SM13 - Get Update Error Message method to retrieve the error message for a specific update 
record.

SM13 – Get Update Queue Method Properties

Use the SM13 - Get Update Queue method to retrieve entries in the SAP update queue, optionally 
filtering entries in queued or error status.

SM14 – Activate and Deactivate Update System Method Properties

Use the SM14 - Activate or Deactivate Update System method to activate or deactivate the update 
system.

Note This method requires the ABAP Add-On.

SM21 – Read System Log Method Properties

Use the SM21 - Read System Log method to retrieve the data from the SAP system log for a defined 
server and defined time period. SAP servers record events and problems in the system logs.

Field Description

Key Update record key currently in error status.

Field Description

Status Status by which to filter results.

Date (yyyyMMddHHmmss) Specify the end date for retrieving entries in the SAP update queue. 
If you leave this field blank, data for the current date/time will be 
retrieved.

Last X minutes prior to the 
specified date

Time period for displaying update records.

Update server Name of the server for the SAP update queue.

Field Description

Server 
(ServerHost_SID_SysNo)

SAP application server to read the system log (server name should be 
in the format host_sysid_sysnum).

User User name assigned to the SAP account on the SAP application 
server. Wildcards are accepted in this field.

Date (yyyyMMddHHmmss) Specify the date from which to retrieve the data from the system log. 
If you leave this field blank, data from the current date will be 
retrieved.

Last X minutes prior to the 
specified date

Time period, in minutes, for selecting data based on the date.
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SM35 – Session Overview Method Properties

Use the SM35 - Session Overview method to retrieve information about the sessions that are running.

SM36 – Create Background Job Method Properties

Use the SM36 - Create Background Job method to schedule simple jobs without spool output. This 
method creates a background job in scheduled status.  It must be released in a subsequent step based on 
the Job ID return parameter provided.

Note This method requires the ABAP Add-On.

SM36 – End Standard Jobs Method Properties

Use the SM36 - End Standard Jobs method to delete all currently scheduled or released standard jobs 
defined in SAP.

Note This method requires the ABAP Add-On.

SM36 - Job Scheduler Method Properties

Use the SM36 - Job Scheduler method to schedule and release jobs in the SAP system. This method 
provides the capability to schedule jobs based on complex job scheduling requirements, including 
setting up recurring jobs with multiple job steps.  

Field Description

Client(s) Specify a variable that lists the SAP clients on which to retrieve the 
session information (parameter should be a Data Table with a single 
column named Client).

Session name Name of the session to be retrieved. Enter a wildcard (*) to retrieve 
all sessions.

Sessions created in the last X 
minutes

Time period, in minutes, for selecting data based on the time the 
session was created.

Field Description

Job name Name of the SAP background job to be scheduled.

Target Server SAP application server on which to execute the job.
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Note This method requires the ABAP Add-On.

Field Description

Job Name Name of the SAP background job to be scheduled.

Predecessor Job ID Job ID of the job to follow; the scheduled job will start after this job has 
completed. If only the job name is known, leave this field blank.

Predecessor Job Name Name of the job to follow; the scheduled job will start after this job has 
completed.

Event ID Background job event ID that triggers the scheduled job.

Event Parameters Background job event parameters that trigger the scheduled job.

Operation Mode Name Operation mode name if you have selected Operation Mode as the Start 
Type (for example, enter Normal).

Periodic Minutes If the Periodic field is set to Yes, enter how often to reschedule the job in 
minutes (x minutes).

Periodic Hours If the Periodic field is set to Yes, enter how often to reschedule the job in 
hours (x hours).

Periodic Days If the Periodic field is set to Yes, enter how often to reschedule the job in 
days (x days).

Periodic Weeks If the Periodic field is set to Yes, enter how often to reschedule the job in 
weeks (x weeks).

Periodic Minutes If the Periodic field is set to Yes, enter how often to reschedule the job in 
minutes (x minutes).

Periodic Months If the Periodic field is set to Yes, enter how often to reschedule the job in 
months (x months).

Target Host Target system on which to run background job.

Target Server Group Server group name for background processing.

Job Steps Array of the ABAP or external programs to be executed. A table 
parameter with the following columns must be referenced:

• ABAP Program/Command -  ABAP program name or command.

• Step Type - Valid values include ABAP,Command, External Program

• Parameter - ABAP program variant or external program parameters

• Background User ID - Authorization user whose privileges are used 
to run the background program.

• External Command Operating System - Operating system for which 
the ABAP command is defined. For example, ANYOS, UNIX, etc.

• External Program ID - External program ID.

• External Program Target Server - Target server, if applicable, of the 
external program.

• External Program RFC Destination - RFC destination, if applicable, 
 where the external program is to run.
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SM36 – Schedule Standard Jobs Method Properties

The SAP RFC Function activity is used to define the properties of any remote-enabled function within 
the monitored SAP system.

Use the SM36 - Schedule Standard Jobs method to schedule all standard jobs in SAP.

SM37 – Cancel a Background Job Method Properties

Use the SM37 - Cancel a Background Job method to retrieve all background jobs that have been canceled 
because they were running too long or were consuming too many resources.

SM37 – Delete Background Job Method Properties

Use the SM37 - Delete Background Job method to delete each job that is returned in the list of all 
scheduled jobs.

SM37 – Get Active Job Duration Method Properties

Use the SM37 - Get Active Job Duration method to retrieve the jobs specified in the input table that are 
currently running along with their current duration.

SM37 – Get Job Instance Information Method Properties

Use the SM37 - Get Job Instance Information method to retrieve all data associated with a specific 
instance of an SAP job execution.

SM37 – Get Job Step Information Method Properties

Use the SM37 - Get Job Step Information method to retrieve the job steps for a SAP job.

Method Parameters

Displays the parameters for the selected method. Complete the appropriate fields, as necessary.

Field Description

Job name Name of the SAP job (this field is case-sensitive and should be 
entered all uppercase).

Job ID Job ID assigned by SAP to this instance of job execution.

Field Description

Job name Name of the table variable that contains a list of the SAP jobs to be 
retrieved. The table must contain a column named "Job Name" with 
the jobs listed in that column.

Field Description

Job ID Job ID assigned by SAP to this instance of job execution.
13-49
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 13      Using SAP Adapters
  SAP RFC Adapter
SM37 – Jobs Waiting Method Properties

Use the SM37 - Jobs Waiting method to display all SAP jobs currently waiting for execution for a 
specified date.

SM37 – Read Job Log Method Properties

Use the SM37 - Read Jobs Log method to collect the job log for an SAP job identified by a job name 
and job ID.

SM37 – Resume Jobs Method Properties

Use the SM37 - Resume Jobs method to restart jobs that were temporarily suspended.

Note This method requires the ABAP Add-On.

SM37 – Simple Job Selection Method Properties

Use the SM37 - Simple Job Selection method to retrieve all SAP jobs for a defined time period that match 
the defined criteria.

Field Description

Job user SAP user that created the job. Enter the wildcard * to search all users.

Field Description

Job name (wildcard) Name of the SAP job to filter (enter the wildcard * to display all 
jobs).

User name (wildcard) Name of the SAP user that executed the job to filter (enter the 
wildcard * to display all SAP users).

Start date (wildcard or 
yyyymmdd)

Date the SAP job is scheduled to execute (enter the wildcard * to 
display all dates).

Field Description

Job ID Job instance ID assigned to the job by SAP.

Field Description

Job name (wildcard) Name of the SAP job.

User name (wildcard) SAP user that created the SAP job.
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Note If you select Yes in any of the fields that have a Yes/No selectable option, the value specified in the Last 
X minutes prior to the specified date field will be ignored.

SM37 – Start or Restart a Background Job Method Properties

Use the SM37 - Start or Restart a Background Job method to start or restart a released or scheduled job.

SM37 – Suspend Jobs Method Properties

Use the SM37 - Suspend Jobs method to temporarily suspend jobs. Only released jobs can be suspended.

Note This method requires the ABAP Add-On.

SM37 – Complex Job Selection Method Properties

Use the SM37 - Complex Job Selection method to retrieve the current SAP SLD connectivity details.

Date (yyyMMddHHmmss) Status date for the job

Notes:

To get the results in the last X minutes from the current time, this field 
should remain blank and specify the number of minutes in the Last X 
minutes prior to specified date field.

To get the results within a specified date range (To/From), you must 
enter the value for the ending date in this field and specify the amount 
of minutes in the Last X minutes prior to specified date field.

Last X minutes prior to the 
specified date

Time period, in minutes, for selecting jobs based on the date.

After event (wildcard) Specify the job scheduling event to scheduled job so that it can only 
be released via a SAP Background Processing Event.  The job will 
not execute until this event has been triggered by the SAP runtime 
system. Job scheduling events are configured in SAP Background 
Processing configuration, accessed via SAP Transaction SM62.

Field Description

Field Description

Job Name (wildcard) Name of the job. Leave blank for wildcard search or enter partial 
search with wildcard (for example, MYJOB*).

User Name (wildcard) SAP user that scheduled the SAP job.
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Note This method requires the ABAP Add-On.

SM50 – Analyze Long Running Processes Method Properties

Use the SM50 - Analyze Long Running Processes method to determines if any SAP work processes of 
a specified type have been executing longer than the specified time.

Date (yyyMMddHHmmss) Status date for the job

Note To get the results in the last X minutes from the current time, 
this field should remain blank and specify the number of 
minutes in the Last X minutes prior to specified date field.

Note To get the results within a specified date range (To/From), 
you must enter the value for the ending date in this field and 
specify the amount of minutes in the Last X minutes prior to 
specified date field.

Last X minutes prior to the 
specified date

Time period, in minutes, for selecting jobs based on the date.

After Event (wildcard) Specify the job scheduling event to scheduled job so that it can only 
be released via a SAP Background Processing Event.  The job will 
not execute until this event has been triggered by the SAP runtime 
system. Job scheduling events are configured in SAP Background 
Processing configuration, accessed via SAP Transaction SM62.

Duration For jobs that have completed, the amount of time job took between 
start and end. For example, set to 1000 for any jobs that executed for 
longer than 100 seconds.

Delay For jobs that have started, the minimum amount of time job was on 
hold between its scheduled start time and the time that it was able to 
start. For example, set to 100 to select any jobs that were delayed by 
100 seconds or more.

Field Description
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SM50 – Work Process Overview Method Properties

Use the SM50 - Work Process Overview method to display the current state of the SAP work processes 
on the selected application server.

SM51 – Dispatcher Queue Method Properties

Use the SM51 - Dispatcher Queue method to display statistics related to dispatching requests to SAP 
work processes.

SM51 – Server List Method Properties

Use the SM51 - Server List method to display the current status of the application servers on an SAP 
system.

SM58 – Delete All tRFC Messages Method Properties

Use the SM58 - Delete All tRFC Messages method delete transactional RFC message found in queue 
(SM58 log).

Field Description

Execution time in seconds Amount of time, measured in seconds, to determine whether a work 
process is running long.

Work process type Type of work process to be analyzed. The following values are 
possible:

• DIA – Work process for executing dialog steps in user 
transactions

• UPD – Update process for making time critical database updates

• UP2 – Update process for making not time critical database 
updates

• ENQ – Work process for locking and releasing SAP objects and 
documents

• BGD – Work process for executing background processes

• SPO – Work process for executing print spool requests

Server name SAP application server on which to analyze work processes (server 
name should be in the format host_sysid_sysnum). Enter the 
wildcard (*) to collect all work processes from all application 
servers.

Field Description

Server name SAP application server to take the work process snapshot (server 
name should be in the format host_sysid_sysnum). You can enter the 
wildcard (*) to collect all work processes from all application servers.
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Note This method requires the ABAP Add-On.

SM58 – Execute LUW Method Properties

Use the SM58 - Execute LUW method repeats the transmission of a tRFC LUW (Logical Unit of Work)

.

SM58 – RFC Transaction Call Status Method Properties

Use the SM58 - RFC Transaction Call Status method to display RFC calls for a selected time period.

SM59 – Delete RFC ABAP Connection Method Properties

Use the SM59 - Delete RFC ABAP Connection method to delete an ABAP destination.

Field Description

Transaction ID tRFC unique transaction ID.

Forced Choose Yes or No from the drop-down list to indicate whether to 
force a restart regardless of whether the queues were stopped before 
by a queue stop function module (parameter FORCE) or by statuses 
CPICERR or SYSSFAIL.

QOut Scheduler Activated Choose Yes or No to indicate whether to activate the qRFC outbound 
scheduler if the destination is registered as a qRFC Outbound 
destination.

Field Description

User name (wildcard) User name for the SAP user that executed RFC transactions (displays 
only the RFC transactions for the specified SAP user). This field is 
case-sensitive.

Function module (wildcard) SAP function module where RFC transactions were executed 
(displays only the RFC transactions for the specified SAP function 
module). This field is case-sensitive.

Target system (wildcard) SAP system ID (SID) for the system that is targeted by RFC 
transactions (displays only the RFC transactions that are targeted for 
the specified system ID). This field is case-sensitive.

Status (wildcard) Specify the status for the RFC calls to be retrieved. This field is 
case-sensitive.

Date (yyyyMMddHHmmss) Specify the date for the RFC calls to be retrieved.

Last X minutes prior to the 
specified date

Time period, in minutes, in which the RFC transactions were 
executed based on the date (displays only the RFC transactions that 
were executed in this time period).
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Note This method requires the ABAP Add-On.

SM59 – Delete RFC HTTP Connection to ABAP System Method Properties

Use the SM59 - Delete RFC HTTP Connection to ABAP System method to delete an HTTP connection 
to an ABAP system.

Note This method requires the ABAP Add-On.

SM59 – Delete RFC HTTP Connection to External Server Method Properties

Use the SM59 - Delete RFC HTTP Connection to External Server method to delete an HTTP connection 
to an external server.

Note This method requires the ABAP Add-On.

SM59 – Delete RFC TCP/IP Connection Method Properties

Use the SM59 - Delete RFC TCP/IP Connection method to delete an TCP/IP connection.

Note This method requires the ABAP Add-On.

Field Description

Destination Name of the ABAP destination to be deleted. This field is 
case-sensitive.

Field Description

Destination Name of the HTTP connection to be deleted. This field is 
case-sensitive.

Field Description

Destination Name of the HTTP connection to be deleted. This field is 
case-sensitive.

Field Description

Destination Name of the TCP/IP connection to be deleted. This field is 
case-sensitive.
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SM59 – Get RFC Connection Info Method Properties

Use the SM59 - Get RFC Connection Info method to retrieve data from a specific RFC destination.

SM59 – HTTP Connection Test Method Properties

Use the SM59 - HTTP Connect Test method to tests a list of HTTP destinations from a selected SAP 
application server.

SM59 – List ABAP Connections Method Properties

Use the SM59 - List ABAP Connections method to retrieve a list of ABAP RFC destinations.

Note This method requires the ABAP Add-On.

SM59 – List HTTP Connections to ABAP System Method Properties

Use the SM59 - List HTTP Connections to ABAP System method to retrieve a list of HTTP connections 
to an ABAP system.

Field Description

Destination Name of the RFC destination for which to retrieve data. This field is 
case-sensitive.

Field Description

HTTP server 
(ServerHost_SID_SysNo)

Name of the server where the destination check tests are executed.

HTTP destination Global variable containing a table with the list of destinations to be 
monitored. The table should include the following columns:

• Host - Hostname of the destination.

• Destination - Name of the destination. This field is optional and 
does not affect the result of the execution.

• Service - Service used for the destination (Example: 80).

• Path - Path of the destination, starting with '/'.

• Pattern - Pattern returned from the HTTP connection. Valid 
values for pattern are OK, Unavailable, FAILED, etc. The 
pattern entry is case-sensitive and should match exactly what is 
returned in the SAP message. For the OK pattern, uppercase is 
always required.
To check whether the HTTP connection is successful or for 
correct results, enter OK in the pattern field. If the connection is 
established, the returned status will be success. If the connection 
is not established, the returned status will be failed.

Note The table must include Host, Pattern, and either Service or 
Path.
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Note This method requires the ABAP Add-On.

SM59 – List HTTP Connections to External Server Method Properties

Use the SM59 - List HTTP Connections to External Server method to retrieve a list of HTTP connections 
to external servers.

Note This method requires the ABAP Add-On.

SM59 – List TCP/IP Connections Method Properties

Use the SM59 - List TCP/IP Connections method to retrieve a list of all TCP/IP destinations.

Note This method requires the ABAP Add-On.

SM59 – Modify RFC ABAP Connection Method Properties

Use the SM59 - Modify RFC ABAP Connection method to update an ABAP connection.

Note This method requires the ABAP Add-On.

SM59 – Modify RFC HTTP Connection to ABAP System Method Properties

Use the SM59 - Modify RFC HTTP Connection to ABAP System method to update an HTTP connection 
to an ABAP system.

Field Description

Destination Name of the ABAP destination to be updated. This field is 
case-sensitive.

Client New logon client number.

Description Description of the new ABAP destination.

Group Name of the new logon group for the ABAP destination.

Gateway Host Name of the new gateway host for the ABAP destination.

Gateway Service Name of the new gateway service for the ABAP destination.

Language New logon language.

User New logon user.

Password New logon password.

Server New target host of the ABAP destination.

System ID New SAP system ID.

System Number New SAP system number.
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Note This method requires the ABAP Add-On.

SM59 – Modify RFC HTTP Connection to External Server Method Properties

Use the SM59 - Modify RFC HTTP Connection to External Server method to update an HTTP 
connection to an external server.

Note This method requires the ABAP Add-On.

Field Description

Destination Name of the HTTP connection to ABAP system that needs to be 
updated. This field is case-sensitive.

Description Description of the new HTTP connection.

Client Logon client for new HTTP connection.

Language Language for new HTTP connection.

Path Prefix New HTTP service path prefix.

Server New target host of HTTP connection.

Service Number New HTTP service port.

User New logon user.

Password New logon password.

Proxy Host New proxy host.

Proxy Service New proxy service.

Proxy User New proxy user.

Proxy Password New proxy password.

Field Description

Destination Name of the HTTP connection that needs to be updated. This field is 
case-sensitive.

Description Description of the new HTTP connection.

Server New target host of HTTP connection.

Service Number New HTTP service port.

Path Prefix New HTTP service path prefix.

User New logon user.

Password New logon password.

Proxy Host New proxy host.

Proxy Service New proxy service.

Proxy User New proxy user.
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SM59 – Modify RFC TCP/IP Connection Method Properties

Use the SM59 - Modify RFC TCP/IP Connection method to update a TCP/IP connection.

Note This method requires the ABAP Add-On.

SM59 – RFC Connection Test Method Properties

Use the SM59 - RFC Connection Test method to test a list of RFC destinations from a selected SAP 
application server.

SM61 – Assign Server Method Properties

Use the SM61 - Assign Server method to add a target system server.

Field Description

Destination Name of the TCP/IP destination to be updated. This field is 
case-sensitive.

Description Description of the new TCP/IP destination.

Gateway Host Name of the gateway host for the new TCP/IP destination.

Gateway Service Name of the gateway service for the new TCP/IP destination

Method Choose one of the following methods to indicate the new TCP/IP 
communication method that should be used:

• Registered Server Program

• Start on Application Server

• Start on Explicit Host

• Start on Front-End Workstation

Program New program ID to execute TCP/IP communication method.

Server New target host of TCP/IP destination.

RFC Unicode Choose Unicode or Non-Unicode from the drop-down list to indicate 
whether the target system for the RFC connection is a Unicode-based 
system.

Field Description

RFC server 
(ServerHost_SID_SysNo)

SAP application server on which to test the RFC destinations.

RFC destination(s) Table variable with a "Destination" column that contains the list of 
RFC destinations to be tested.

Note This field is case-sensitive.
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Note This method requires the ABAP Add-On.

SM61 – Get Server List Method Properties

Use the SM61 - Get Server List method to retrieve a list of system background servers that are included 
in a specific server group.

Note This method requires the ABAP Add-On.

SM61 – List Active Background Servers Method Properties

Use the SM61 - List Active Background Servers method to retrieve a list of all active servers that are 
running background work processes.

SM61 – Remove Server Method Properties

Use the SM61 - Remove Server method to remove a background server from an SAP system.

Note This method requires the ABAP Add-On.

Field Description

Application Server The server name should be entered using the following format:

ServerHost_SID_SysNo

This field is case-sensitive.

Server Group Name of the group that includes the source system background 
servers.This field is case-sensitive.

Field Description

Server Group Name of the group that includes the source system background 
servers. This field is case-sensitive.

Field Description

Application Server The server name should be entered using the following format:

ServerHost_SID_SysNo

This field is case-sensitive.

Server Group Name of the group that includes the source system background 
servers. This field is case-sensitive.
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SM66 – Global Work Process Overview Method Properties

Use the SM66 - Global Work Process method to display SAP work processes that are currently 
processing user requests across all SAP application servers.

SM66 – Global Work Process Activity Detail Method Properties

Use the SM66 - Global Work Process Activity Detail method to take a snapshot of the current activity 
in the available work processes on all servers of a single SAP ABAP system.

In a corrective action scenario, this method can be used to:

• Identify long running jobs in the work process and all the associated details.

• Retrieve the PID of a work process and its associated server to cancel the process.

• Identify all the current application servers for a single SID and confirm their availability.

In a system copy scenario, this method can be used to confirm the current ABAP work process count (for 
example, dialog) based on changes to the system profile parameters in a post-processing step. This 
method can also be used to confirm server connectivity, work process availability, and identify any long 
running jobs during the system copy process.

Note This method requires the ABAP Add-On.

SMGW – Gateway Monitor Method Properties

Use the SMGW - Gateway Monitor method to display the current status of SAP gateway 
communications.

SMICM – ICM Monitor Method Properties

Use the SMICM - ICM Monitor method to display the current status of the SAP Internet Communication 
Manager, which sends and receives requests to and from the Internet.

SMLG – Change Assignments Method Properties

Use the SMLG - Change Assignments method to change a specified list of servers to logon group 
assignments.

SMLG – Create Assignments Method Properties

Use the SMLG - Create Assignments method to create a specified list of servers for logon group 
assignments.

SMLG – Delete All Assignments Method Properties

Use the SMLG - Delete All Assignments method to delete all logon group assignments.

SMLG – Delete Assignment Method Properties

Use the SMLG - Delete Assignment method to delete a specific logon group assignment.
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SMLG – Delete Assignments Method Properties

Use the SMLG - Delete Assignments method to delete one or more logon group assignments.

SMLG – Get Assignments-Setup Method Properties

Use the SMLG - Get Assignments-Setup method to return a list of logon group assignments currently 
configured. This method returns data from the Setup table.

SMLG – Get Assignments-eRFC Setup Method Properties

Use the SMLG - Get Assignments-eRFC Setup method to return a list of logon group assignments 
currently configured. This method returns data from the eRFC Setup table.

SMLG – Remove Lock Method Properties

Use the SMLG - Remove Lock method to remove an enqueue lock from the server group table.

SMLG – Set Lock Method Properties

Use the SMLG - Set Lock method to set an enqueue lock on the server group table.

SMQ1 – Activate qRFC Outbound Queue Method Properties

Use the SMQ1 - Activate qRFC Outbound Queue method to retrieve the list of stopped outbound queues 
to be activated. This function is necessary only if the queue is blocked due to a communication, network 
error, or if a system or application exception has occurred and the problem has been solved.

Note A queue that has been stopped cannot be processed using this function.

SMQ1 – Delete All qRFC Outbound Queues Method Properties

Use the SMQ1 - Delete All qRFC Outbound Queues method to delete all qRFC outbound queues.

Note This method requires the ABAP Add-On.

SMQ1 – Delete qRFC Outbound Queue Method Properties

Use the SMQ1 - Delete qRFC Outbound Queue method to delete a specific qRFC outbound queue.

Field Description

Queue Name Name of the RFC queue (this field is case sensitive).

Destination RFC destination specified in the function call.
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Note This method requires the ABAP Add-On.

SMQ1 – Lock qRFC Outbound Queue Method Properties

Use the SMQ1 - Lock qRFC Outbound Queue method to retrieve the outbound queues with the Lock 
status.

SMQ1 – Unlock qRFC Outbound Queue Method Properties

Use the SMQ1 - Unlock qRFC Outbound Queue method to retrieve the outbound queues with the Unlock 
status.

SMQ1 – qRFC Monitor Outbound Queue Method Properties

Use the SMQ1 - qRFC Monitor Outbound Queue method to display the list of all queued remote function 
calls (RFCs) that could not be successfully completed, or that had to be scheduled as background jobs.

Field Description

Queue Name Name of the qRFC outbound queue to be deleted.

Destination Name of the system where the current client resides.

Field Description

Queue Name Name of the tRFC queue (this field is case sensitive).

Stop immediately Determines whether to retrieve the queues that were immediately 
stopped.

No commit Indicates whether to retrieve the queues that were not committed.

Field Description

Queue Name Name of the tRFC queue (this field is case sensitive),

Queue destination RFC destination specified in the function call.

Activate immediately Determines whether to retrieve queues that are to be activated 
immediately.

Only unlock Determines whether to retrieve queues that are to be unlocked, but not 
activated.

No commit Determines whether to retrieve the queues that were not committed,

Lock key Lock key returned from the TRFC_QOUT_STOP RFC.

Till lock key Lock acquired till end of transaction.
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SMQ2 – Delete All qRFC Inbound Queues Method Properties

Use the SMQ2 - Delete All qRFC Inbound Queue method to delete all qRFC inbound queues.

Note This method requires the ABAP Add-On.

SMQ2 – Delete qRFC Inbound Queue Method Properties

Use the SMQ2 - Delete qRFC Inbound Queue method to delete a specific qRFC inbound queue.

Note This method requires the ABAP Add-On.

SMQ2 – Lock qRFC Inbound Queue Method Properties

Use the SMQ2 - Lock qRFC Inbound Queue method to retrieve the inbound queues with the Lock status.

SMQ2 – Unlock qRFC Inbound Queue Method Properties

Use the SMQ2 - Unlock qRFC Outbound Queue method to retrieve the inbound queues with the Unlock 
status.

Field Description

Client SAP client to which the queue is assigned.

Queue Name Name of the tRFC queue (this field is case sensitive).

Queue Type Option to show only RFC transactions in Error or Hanging state.

Queue destination RFC destination specified in the function call (this field is case 
sensitive).

Field Description

Queue Name Name of the tRFC queue (this field is case sensitive).

Stop immediately Determines whether to retrieve the queues that were immediately 
stopped.

No commit Determines whether to retrieve the queues that were not committed.

Field Description

Queue Name Name of the tRFC queue (this field is case sensitive).

Activate immediately Determines whether to retrieve queues that are to be activated 
immediately.

Activate all LUWs Activates all LUWs in the inbound queue.

Mode Processes all qRFC LUWs in a queue in the context of the caller.
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SMQ2 – qRFC Monitor Inbound Queue Method Properties

Use the SMQ2 - qRFC Monitor Inbound Queue method to display list of all queued remote function calls 
(RFCs) that could not be successfully completed, or that had to be scheduled as background jobs.

SMQ3 – qRFC Monitor Saved Inbound Queue Method Properties

Use the SMQ3- qRFC Monitor Saved Inbound Queue method to display a list of inbound qRFC (with 
saved queues) calls in Error state.

SMQR – Reorganize qRFC Inbound Monitor Method Properties

Use the SMQR - Reorganize qRFC Inbound Monitor method to reorganize the qRFC inbound monitor. 
It first deletes all entries in the monitor and then changes the SAP logon group.

Only unlock Determines whether to retrieve queues that are to be unlocked, but 
not activated.

Queue Name Name of the tRFC queue (this field is case sensitive).

Activate immediately Determines whether to retrieve queues that are to be activated 
immediately.

Max time Activates the queue within a specified time. If the time runs out while 
the last LUW is being processed, this call is returned after the last 
LUW is processed.

User destination Retrieves all qRFC LUWs in a queue under the user who is currently 
logged on.

No commit Determines whether to retrieve the queues that were not committed.

Lock key Lock key returned from the TRFC_QOUT_STOP RFC.

Till lock key Lock acquired till end of transaction.

Field Description

Field Description

Client SAP client to which the queue is assigned.

Queue name Name of the tRFC queue (this field is case sensitive).

Queue type Option to show only RFC transactions in Error or Hanging state.

Field Description

Client SAP client to which the queue is assigned.

Queue name Name of the RFC queue. Use an asterisk (*) for all queues or a 
specific queue name. Wildcards are not supported.

Field Description

Logon Group Name of the existing SAP logon group.
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Note This method requires the ABAP Add-On.

SMQR – qRFC Monitor (QIN Scheduler) Method Properties

Use the SMQR - qRFC Monitor (QIN Scheduler) method to display the management properties of the 
qRFC inbound scheduler, including scheduler status and inbound queues processed.

SMQR – Register Inbound Queue Method Properties

Use the SMQR - Register Inbound Queue method to register an inbound queue (QIN Scheduler). This 
function is used to manage inbound queues.

Note This method requires the ABAP Add-On.

SMQR – Unregister Inbound Queue Method Properties

Use the SMQR - Unregister Inbound Queue method to unregister an inbound queue (QIN Scheduler). 
This function is used to manage inbound queues.

Note This method requires the ABAP Add-On.

SMQS – Register Destination Method Properties

Use the SMQS - Register Destination method to register an outbound destination (QOUT Scheduler). 
This function is used to manage outbound queues.

Field Description

Execution Mode Choose Dialog or Batch to indicate the type of execution mode.

Max Time Maximum runtime (timeout) in seconds; default value is 60 seconds.

User Destination Local RFC destination with logon details.

Number of Retry Attempts Number of retry attempts; default value is 30.

Delay Interval Delay between retry attempts in seconds; default value is 300 
seconds.

Monitoring Interval Monitoring interval time by scheduler in seconds.

Field Description

Max Connections Maximum number of connections; default value is 1.

Max Runtime Maximum runtime (timeout) in seconds; default value is 60 seconds.

QRFC Only Choose Yes or No to indicate whether to pass tRFCs (transactional 
RFCs) to the destination.

Monitoring Interval Monitoring interval for scheduler; default value is 0.
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Note This method requires the ABAP Add-On.

SMQS – Reorganize qRFC Outbound Monitor Method Properties

Use the SMQS - Reorganize qRFC Outbound Monitor method to reorganize the qRFC outbound monitor. 
It first deletes all entries in the monitor and then changes the SAP logon group.

Note This method requires the ABAP Add-On.

SMQS – Unregister Destination Method Properties

Use the SMQS - Unregister Destination method to unregister an outbound destination (QOUT 
Scheduler). This function is used to manage outbound queues.

Note This method requires the ABAP Add-On.

SMQS – qRFC Monitor (QOUT Scheduler) Method Properties

Use the SMQS - qRFC Monitor (QOUT Scheduler) method to display the management properties of the 
qRFC outbound scheduler, including scheduler status and outbound queues processed.

SMT1 – Add Trusted System Method Properties

Use the SMT1 - Add Trusted System method to add the trusted system and its details.

Note This method requires the ABAP Add-On.

SMT1 – Get Trusted Systems Method Properties

Use the SMT1 - Get Trusted Systems method to retrieve a list of all or specific permitted trusted systems 
that are stored in SAP database table RFCSYSACL

Note This method requires the ABAP Add-On.

Field Description

RFC Destination RFC destination created to connect to the system that will be trusted.

Security Key Security key/logon ticket for target system.

Field Description

Trusted System ID Enter the system ID (SID) to retrieve specific systems. Leave blank 
or enter * to retrieve all trusted systems.
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SMT1 – Modify Trusted System Method Properties

Use the SMT1 - Modify Trusted System method to update a trusted system in the SAP database table 
RFCSYSACL.

Note This method requires the ABAP Add-On.

SMT1 – Remove Trusted System Method Properties

Use the SMT1 - Remove Trusted System method to remove a trusted system in the SAP database table 
RFCSYSACL.

Note This method requires the ABAP Add-On.

SMT2 – Add Trusting System Method Properties

Use the SMT2 - Add Trusting System method to set the trusting system, system ID and RFC destination.

Note This method requires the ABAP Add-On.

SMT2 - Get Trusting Systems Method Properties

Use the SMT2 - Get Trusting Systems method to retrieve a list of all or specific trusting systems that are 
stored in SAP database table RFCTRUST.

Note This method requires the ABAP Add-On.

SMT2 – Modify Trusting System Method Properties

Use the SMT2 - Modify Trusting System method to update the trusting system in the SAP database table 
RFCTRUST.

Field Description

RFC Destination Prefix Prefix to append to the RFC destination (TRUSTING_SYSTEM@).

Field Description

Trusting System ID Enter the system ID (SID) to retrieve specific systems. Leave blank 
or enter * to retrieve all trusting systems.

Field Description

RFC Destination Prefix Prefix to append to the RFC destination (TRUSTING_SYSTEM@).
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Note This method requires the ABAP Add-On.

SMT2 – Remove Trusting System Method Properties

Use the SMT2 - Remove Trusting System method to remove the trusting system in the SAP database 
table RFCTRUST.

Note This method requires the ABAP Add-On.

SOA Manager – Read J2EE Admin Server Data Method Properties

Use the SOA Manager - Read J2EE Admin Server Data method to retrieve configuration data from the 
J2EE administration server.

Note This method requires the ABAP Add-On.

SOA Manager – Set J2EE Admin Server Method Properties

Use the SOA Manager - Set J2EE Admin Server method to set the J2EE administration server 
configuration details used by the SAP ABAP environment.

Note This method requires the ABAP Add-On.

SOST – Delete Mail Method Properties

Use the SOST - Delete Mail method to delete emails from a specific date, regardless of their status. This 
method removes all pending and processed emails from the SOST queue. All emails are deleted 
internally, similar to deleting an email via the SAP administrator transaction SOST.

Field Description

Protocol Choose http, https, or Do Not Modify to indicate the type of protocol 
to be set.

Host Name Enter the full host name to be set. If the host name is to remain 
unchanged, leave this field blank.

Port Number Enter the J2EE engine port number to be set. If the port number is to 
remain unchanged, leave this field blank.  

Access Path Enter the access path to J2EE service, if applicable. If the access path 
is to remain unchanged, leave this field blank.

J2EE User Enter the J2EE user name to be set. If the user name is to remain 
unchanged, leave this field blank.

J2EE Password Enter the J2EE password for the user account. If the password is to 
remain unchanged, leave this field blank.
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Note This method requires the ABAP Add-On.

SOST – Repeat Send Method Properties

Use the SOST - Repeat Send method to resend any unsuccessfully sent SAP Office transmission requests 
to the request queue.

Note This method requires the ABAP Add-On.

SP01 – Spool Requests Method Properties

Use the SP01 - Spool Requests method to send pages to be printed are sent to the SAP spool system.

SP12 – TemSe Data Consistency Check – Delete All Method Properties

Use the SP12 - TemSe Data Consistency Check - Delete All method to check the consistency of the 
Temporary Sequential Objects (TemSe) and to delete inconsistent TemSe data files.

Field Description

From the Last X Days A value to indicate the date from which to delete emails (number of 
days before the current date).

Job Name Name of the job in the queue.

Field Description

Date (yyyyMMdd) Start date of the date range for selecting requests (optional). When 
this field is blank, the start date is set to the previous day.

From the Last X Days A value to indicate the date from which to resend SAP Office 
transmission requests (number of days before the current date). If this 
field is 0 (default value), the date is set to the current day.

Note This field cannot be blank. Enter 0 if the date is to be set to 
the current day.

Sender List A list of SAP logon user IDs to be used as request senders for 
selecting requests (optional). If this field is blank, all senders will be 
selected.

Field Description

Date (yyyyMMddHHmmss) Date for which to check for spool requests.

Last X minutes prior to the 
specified date

Time period, in minutes, in which the spool requests were executed 
based on the date (displays only the spool requests that were executed 
in this time period).
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Note This method requires the ABAP Add-On.

SPAD – Assign Server Method Properties

Use the SPAD - Assign Server method to reassign output devices to a new spool server.

Note This method requires the ABAP Add-On.

SPAD – Check Consistency Delete All Method Properties

Use the SPAD - Check Consistency Delete All method to purge job spool files and other temporary files 
that are stored in TEMSE content.

Note This method requires the ABAP Add-On.

SPAD – Create Output Device Method Properties

Use the SPAD - Create Output Device method to create a new spool device (printer) or change the 
attributes of an existing spool device (printer).

Field Description

Output Device Name of the output device(s) to reassign.

Old Spool Server Source system for the old spool server.

New Spool Server Source system for the new spool server.

Field Description

Job Name The name of the schedule job (released immediately).le

Delete Choose the objects to be deleted from the drop-down list (All Objects 
or Only Obsolete Objects).

Days Old Number of days old for TEMSE document to be considered for 
deletion.

Field Description

Output Device Name Name of the output device(s) to be created or modified.

Output Device Short 
Name

ID of the spool device used by the system to access it.

Output Device Type Type of the output device(s) to be created or modified.

Destination Host Name of the remote host on which SAP LPD is running.
13-71
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 13      Using SAP Adapters
  SAP RFC Adapter
Note This method requires the ABAP Add-On.

SPAD – Delete Output Device Method Properties

Use the SPAD - Delete Output Device method to delete a spool device found via SP01. This method can 
be used when production printers must be deleted instead of reassigning to a different printer server.

Note This method requires the ABAP Add-On.

SPAD – Display Output Devices Method Properties

Use the SPAD - Display Output Devices method to retrieve a list of output devices listed in transaction 
code SPAD.

Note This method requires the ABAP Add-On.

SPAD – Export Command Set Method Properties

Use the SPAD - Export Command Set method to create an SAP transport that contains the command sets 
that are defined for printers.

Note This method requires the ABAP Add-On.

SPAD – Export Device Method Properties

Use the SPAD - Export Device method to export a list of devices to a backup file. The file is created in 
the directory \usr\sap\SID\DVEBMGS01\work.

Note This method requires the ABAP Add-On.

SPAD – Get Device Descriptions Method Properties

Use the SPAD - Get Device Descriptions method to retrieve descriptions for a list of devices.

Field Description

File Name Name of the file to be created for the exported devices.

Device List List of devices to be exported.
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Note This method requires the ABAP Add-On.

SPAD – Import Device Method Properties

Use the SPAD - Import Device method to import devices from a file.

Note • This method requires the ABAP Add-On.

• This method is not supported on SAP v7.3 systems.

ST02 – Get Buffer Tune Summary Method Properties

Use the ST02 - Get Buffer Tune Summary method to display statistics for the selected SAP application 
buffer.

Field Description

Device List List of devices for which to retrieve descriptions. The table should 
have the following columns:

• Low - Used for single selection, such as LP01.

• High - Used in combination with Low Value for a range 
selection, such as Low Value = LP* and High Value = LZ*, 
returning all devices between LPOO and LZZZ.
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ST02 – Get Memory Usage Method Properties

Use the ST02 - Get Memory Usage method to display details about SAP memory management.

ST03 – Get Data for WebAS 7.0 Method Properties

Use the ST03 - Get Data for WebAS 7.0 method to display summarized workload statistics for all SAP 
application servers.

ST03 – Get Hourly Snapshot Data for WebAS 7.0 Method Properties

Use the ST03 - Get Hourly Snapshot Data for WebAS 7.0 method to display workload statistics for a 
selected SAP application server.

ST03 – Workload Analysis Method Properties

Use the ST03 - Workload Analysis method to display workload statistics for an SAP system.

Field Description

Buffer Name of the SAP application server buffer to display metrics. If you want to 
retrieve data for all buffers, leave this field blank. The following input parameters 
are valid:

• TTAB – Table definition

• FTAB – Field description

• SNTAB – Short nametab

• IRBD – Initial record contains the record layout initialized depending on the 
field type

• TABL – Generic key (resident) buffer stores a range of table entries, that is, a 
range of records with their field values.

• TABLP – Single key (partial) buffer stores single table entries, that is, one 
record with its field values.

• PXA – Program Execution Area stores the compiled executable versions of 
ABAP programs

• CUA – Defines the total size of the buffer in KB

• PRES – Screen buffer defines the size of the directory

• CALE – Calendar

• EIBUF – Export/Import buffers

• OTR – Online Text Repository

• ESM – Export/Import shared memory

Field Description

Task type Specify the type of SAP work processes to include in the report or enter the 
asterisk * to include all types.
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ST04 – Get DB6 Log Space Method Properties

Use the ST04 - Get DB6 Log Space method to retrieve DB2 log space usage data.

Note This method requires the ABAP Add-On.

STAD – Workload Statistical Records Method Properties

Use the STAD - Workload Statistical Records method to retrieve workload details for SAP transactions 
matching selected criteria.

STATTRACE—Global Statistics Method Properties

Use the STATTRACE - Global Statics method to retrieve raw statistical data from the SAP Java stack. 
The raw statistics data originates from Distributed Statistics Records (DSRs).

Field Description

Read time (hhmmss) Amount of time to retrieve records beginning with values entered in the 
Start date and Start time fields.

User (wildcard) Specify the SAP user for which to retrieve records that were executed or 
enter the asterisk * to retrieve records executed by all SAP users.

Transaction (wildcard) Specify a SAP transaction code for which to retrieve records (for 
example, VA01) or enter the asterisk * to retrieve records for all 
transaction codes.

Program (wildcard) Specify a SAP program for which to retrieve records or enter the asterisk 
* to retrieve records for all SAP programs.

Task type (wildcard) Specify a work process type for which to retrieve records (for example, 
Dialog) or enter the asterisk * to retrieve records for all task types.

Server name (wildcard) Specify an SAP application server on which records were executed or 
enter the asterisk * to retrieve records executed on all SAP application 
servers.

Response time threshold 
(>=ms)

Enter a threshold value for retrieving records whose response time 
exceeds the defined threshold.

DB request time threshold 
(>=ms)

Enter a threshold value for retrieving records whose database request 
time exceeds the defined threshold.

CPU time threshold 
(>=ms)

Enter a threshold value for retrieving records whose CPU time exceeds 
the defined threshold.

Bytes requested threshold Enter a threshold value for retrieving records whose bytes requested 
exceeds the defined threshold.

Start date Specify the start date to begin retrieving records (used in conjunction 
with Start time and Read time).

Start time Specify the start time to begin retrieving records (used in conjunction 
with Start date and Read time).
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STMS – Activate System Method Properties

Use the STMS - Activate System method to approve (activate) a system that has been added or changed 
in the domain controller and redistribute the changes to the transport domain.

Note This method requires the ABAP Add-On.

STMS – Add Transport Request to Import Queue Method Properties

Use the STMS - Add Transport Request to Import Queue method to add a specific transport request to 
the TMS import queue. This method will verify that the transport has been added to the queue; if it hasn't 
been added, it will add the request to the queue.

Note This method requires the ABAP Add-On.

Method Parameters

Displays the parameters for the selected method. Complete the appropriate fields, as 
necessary.

Field Description

Date 
(yyyyMMddHHmmss)

Local date time on the SAP server.

Last X minutes prior to 
the specified date

Specify the number of minutes prior to the date time specified in the Date 
field for which to retrieve data.

System (wildcard) SAP system ID; or enter a wildcard to retrieve data from all SAP 
systems.

User (wildcard) SAP user name of the user who is logged onto a component; or enter a 
wildcard to retrieve data from all users logged onto a component.

Action (wildcard) SAP action name; or enter a wildcard to retrieve all executed 
transactions.

Transaction ID (wildcard) SAP transaction ID; or enter a wildcard to retrieve all transaction IDs.

Field Description

Transport Request Transport request ID.

Import Again Choose Yes or No to indicate whether to re-import a transport request if 
it is already imported in the import queue. If you choose No, the RFC fails 
with a message stating that the transport request is already in the import 
queue.
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STMS – Configure Transport Domain Controller Method Properties

Use the STMS - Configure Transport Domain Controller method to set up the domain controller system 
in the Transport Management System (TMS) domain landscape. This method will return status and 
landscape validation information about the procedure.

Note This method requires the ABAP Add-On.

STMS – Delete System from Domain Method Properties

Use the STMS - Delete System from Domain method to delete the system from the transport domain so 
that the configuration activity can function correctly. This method must be run before running the 
domain setup custom method (STMS - Configure Domain Controller).

Note This custom method can only be used to delete a system on the domain controller.

Note This method requires the ABAP Add-On.

STMS – Distribute Configuration Method Properties

Use the STMS - Distribute Configuration method to distribute a TMS configuration.

Note This method requires the ABAP Add-On.

STMS – Get TMS Configuration Method Properties

Use the STMS - Get TMS Configuration method to determine the system's landscape configuration. This 
method will return information about the Transport Management System (TMS) configuration, 
including whether the system is the domain controller or a landscape client system.

Field Description

Domain Controller Host Target system host where domain is being configured.

Domain Controller 
System Number

Target system instance system number.

Domain Controller 
System Description

Description of target system instance hosting domain controller.

Transport Group Name Name of the target system TMS transport group.

Transport Group Text Description of the target system TMS transport group.

Field Description

System Name Name of the SAP target system (system copy target).
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Note This method requires the ABAP Add-On.

STMS – Import Transport Request Method Properties

Use the STMS - Import Transport Request method to start the import of a specific transport request to 
the TMS import queue.

Note Client-copy transports with the following formats are not supported:

• <SID>KT<numbers>

• <SID>KX<numbers>

• <SID>KO<numbers>

(Examples: QW2KT00001, PW1KX05140, D21KO78925)

If you have a client-copy transport with one of these formats, you must perform the import via the 
command line using the following command:

Command line: /usr/sap/trans/bin/tp import <transport> <SID> client=<client> 
pf=TP_DOMAIND_<sid>.PFL

Note This method requires the ABAP Add-On.

STMS – Include System in Transport Domain Method Properties

Use the STMS - Include System in Transport Domain method to set up the client system in the Transport 
Management System (TMS) domain landscape. This method will return status and landscape validation 
information about the procedure.

Note This method requires the ABAP Add-On.

STMS – Transport Routes Configuration Adjust with Controller Method Properties

Use the STMS - Transport Routes Configuration Adjust with Controller method to copy the transport 
routes from the specified domain controller.

Note This method requires the ABAP Add-On.

Field Description

Controller System Name Specify the name of the SAP system where the domain controller 
resides.
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STRUST – Export Own PSE Certificate Method Properties

Use the STRUST - Export Own PSE Certificate method to export an own certificate in the Personal 
Security Environment (PSE) to a binary file on the SAP application server filesystem directory.

Note This method requires the ABAP Add-On.

STRUST – Export System PSE Certificate Method Properties

Use the STRUST - Export System PSE Certificate method to export a system certificate in the Personal 
Security Environment (PSE).

Note This method requires the ABAP Add-On.

STRUST – Get Own PSE Certificate Details Method Properties

Use the STRUST - Get Own PSE Certificate Details method to retrieve the certificate details for the 
current Personal Security Environment (PSE) for an SAP ABAP system.

Note This method requires the ABAP Add-On.

STRUST – Get PSE ACL List Method Properties

Use the STRUST - Get PSE ACL List method to retrieve the ACL List of the current Personal Security 
Environment (PSE) for an SAP ABAP system.

Note • This method requires the ABAP Add-On.

• This method only runs successfully in SAP Client 000.

Field Description

File Name File name (<name>.crt) of the certificate file to be exported. The file is 
automatically exported to DIR_TEMP only (path can be found using 
transaction AL11), per SAP requirements.

Note The following characters are not allowed: `;<>|&%*~'-

Field Description

File Name File name (<name>.crt) of the certificate file to be exported.

File Path Location of the certificate file to be exported. This path must be 
accessible by the SAP application server and have the necessary 
Read/Insert credentials granted for the SAP user.

Note The file path must end with \. For example: 
E:\USR\SAP\PW2\DVEBMGS01\SEC\
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STRUST – Get PSE Certificate List Method Properties

Use the STRUST - Get Own PSE Certificate Details method to retrieve a list of assigned certificates for 
the current Personal Security Environment (PSE) for an SAP ABAP system.

Note This method requires the ABAP Add-On.

STRUST – Get System PSE Details Method Properties

Use the STRUST - Get System PSE Details method to retrieve system details for the current Personal 
Security Environment (PSE) for an SAP ABAP system.

Note This method requires the ABAP Add-On.

STRUST – Import Own PSE Certificate Method Properties

Use the STRUST - Import Own PSE Certificate method to import an own certificate in the Personal 
Security Environment (PSE).

Note This method requires the ABAP Add-On.

STRUST – Remove Own PSE Certificate Method Properties

Use the STRUST - Remove Own PSE Certificate method to delete own certificate from certificate list 
of system Personal Security Environment (PSE).

Note This method requires the ABAP Add-On.

STRUST – Remove System PSE Certificate Method Properties

Use the STRUST - Remove System PSE Certificate method to delete a system certificate in the Personal 
Security Environment (PSE).

Note This method requires the ABAP Add-On.

STRUST – Set Own PSE Method Properties

Use the STRUST - Set Own PSE method to reset the Personal Security Environment (PSE) for an SAP 
ABAP system. This method rebuilds the system PSE file in the secure directory, and removes any 
certificates and access control lists that may have been copied from the production environment.

Note This method requires the ABAP Add-On.
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STRUSTSSO2 – Add System ACL Method Properties

Use the STRUSTSSO2 - Add System ACL method to add an Access Control List (ACL) entry in the 
Personal Security Environment (PSE) for an SAP ABAP system.  

Note This method only runs successfully in SAP Client 000.

STRUSTSSO2 – Remove System ACL Method Properties

Use the STRUSTSSO2 - Remove System ACL method to delete an Access Control List (ACL) entry in 
the Personal Security Environment (PSE) for an SAP ABAP system.  

Note • This method requires the ABAP Add-On.

• This method only runs successfully in SAP Client 000.

Field Description

Method name Click the browse  button to open the Select SAP RFC Function 
dialog and select the custom method to be used for execution

Time out if not completed 
within

Check the check box to specify a time out interval within which the RFC 
call must complete. If the RFC call does not complete within the 
specified time out interval, the activity will fail with Failed (Not 
Completed) status.

Click the time unit link to change the timed out interval from seconds to 
minutes.

Field Description

Method Parameters

Displays the parameters for the selected method. Complete the appropriate fields, as 
necessary.

Field Description

System ID SAP system ID.

System Client SAP system client number. This method can only run in Client 000.

Field Description

System ID SAP system ID. This field is case-sensitive.

System Client SAP system client number. This method can only run in Client 000.
13-81
Cisco Process Orchestrator 3.3 User Guide

 

#sap_rfc_function_methods_select__9820


 

Chapter 13      Using SAP Adapters
  SAP RFC Adapter
STRUST – Import System PSE Certificate Method Properties

Use the STRUST - Import System PSE Certificate method to import a certificate to the system Personal 
Security Environment (PSE).

Note This method requires the ABAP Add-On.

SU01 – Reset User Password Method Properties

Use the SU01 - Reset User Password method to reset an SAP user password.

Note This method requires the ABAP Add-On.

SUIM – Complex User Selection Method Properties

Use the SUIM - Complex User Selection method to retrieve a list of all unlocked user accounts.  

SWU3 – Update Workflow RFC Destination Method Properties

Use the SWU3 - Update Workflow RFC Destination method to update the password for the workflow 
agent WF-BATCH in the SAP system.

Field Description

File Name File name (<name>.crt) of the certificate file to be imported.

File Path Location of the certificate file to be imported. This path must be 
accessible by the SAP application server and have the necessary 
Read/Insert credentials granted for the SAP user.

Note The file path must end with \. For example: 
E:\USR\SAP\PW2\DVEBMGS01\SEC\. The following 
characters are not allowed ` ; < > | & % * ~ ' -

Field Description

User Name SAP user name. The entry in this field must be all uppercase.

Password New password.

Prompt Choose Yes or No to indicate whether to prompt the user to reset the 
password during the next logon attempt.

Field Description

Password New password to be assigned to the workflow agent WF-BATCH in the 
target system.
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Note This method requires the ABAP Add-On.

Select SAP RFC Function

Use this dialog to select the RFC function you want to use in the activity. You can filter the list by name 
or category. If you want to filter by category, click the Filter by link to toggle to Category and then select 
the category name from the drop-down list.

Select the RFC function in the list to populate the Selected method field and then click OK.

Note After selecting an RFC function in the list, you can click Help to display information about the selected 
method.

AL08 – Logged On Users Method Instance Properties

The AL08 - Logged on Users method display-only page displays the properties used to retrieve the 
number of users logged into the system.

AL11 – Change Custom Directory Method Instance Properties

The AL11 - Change Custom Directory display-only page displays the properties used to change an 
existing custom directory defined via the SAP transaction AL11.

AL11 – Create Custom Directory Method Instance Properties

The AL11 - Create Custom Directory display-only page displays the properties used to create a new 
custom directory via the SAP transaction AL11.

AL11 – Read Custom Directory Method Instance Properties

The AL11 - Read Custom Directory method display-only page displays the properties used to retrieve 
current customer directories that are defined via the SAP transaction AL11.

Field Description

  Directory Name   Unique directory name

Field Description

Directory Name Unique directory name.

Alias Name Alias name of the directory.

Field Description

Directory Name Unique directory name.
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 AL11 – Remove Custom Directory Method Instance Properties

The AL11 - Remove Custom Directory display-only page displays the properties used to remove an 
existing custom directory defined via the SAP transaction AL11.

The AL15 - Add SAPOSCOL Destination display-only page displays the properties used to add an 
SAPOSCOL destination.

AL15 – Delete SAPOSCOL Destination Method Instance Properties

The AL15 - Delete SAPOSCOL Destination display-only page displays the properties used to delete an 
SAPOSCOL destination.

BD97 – Assign RFC Special Method Destination Method Instance Properties

The BD97 - Assign RFC Special Method Destination display-only page displays the properties used to 
modify the RFC assignments defined in BD97 based on Business Object name and method used in the 
interface.

Field Description

Directory Name Unique directory name.

Alias Name Alias name of the directory.

Field Description

Destination Name of the destination to be added

Description Description of the destination

Save Last 30 Days Indicates whether to set a Save Alert flag

DB Server Indicates whether the database server should be displayed

Field Description

Destination Name of the SAPOSCOL destination to be deleted

Field Description

Logical System SAP logical system to be modified (validated against the SAP Logical 
System Configuration table TBDLS ).

RFC Destination RFC destination to be defined (validated against SAP RFC Destination 
table).

Business Object Type Business Object type technical name (validated against SAP Business 
Objects; viewable via SAP Transaction BAPI).

Business Object Method Business Object method technical Name for the Business Object type 
name.
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BD97 – Assign RFC Standard BAPI Destination Method Instance Properties

The BD97 - Assign RFC Standard BAPI Destination display-only page displays the properties used to 
modify the RFC assignments defined in BD97 for BAPI destinations.

BD97 – Assign RFC Standard Dialog Destination Method Instance Properties

The BD97 - Assign RFC Standard Dialog Destination display-only page displays the properties used to 
modify the RFC assignments defined in BD97 for dialog destinations.

BD97 – Delete All RFC Assignments Method Instance Properties

The BD97 - Delete All RFC Assignments display-only page displays the properties used to delete all the 
RFC assignments defined in BD97.

BD97 – Read RFC Assignments Special Method Destinations Method Instance Properties

The BD97 - Read RFC Assignments Special Method Destinations method display-only page displays 
the properties used to retrieve RFC assignments that are defined in BD97. This method retrieves the RFC 
destinations based on Business Object name and method used in the interface.

Field Description

Logical System SAP logical system to be modified (validated against the SAP Logical 
System Configuration table TBDLS).

RFC Destination RFC destination to be defined (validated against SAP RFC Destination 
table).

Field Description

Logical System SAP logical system to be modified (validated against the SAP Logical 
System Configuration table TBDLS ).

RFC Destination RFC destination to be defined (validated against SAP RFC Destination 
table).

Field Description

Logical System SAP logical system to be modified (validated against the SAP 
Logical System Configuration table TBDLS).

Field Description

Logical system Name of the SAP logical system from which to retrieve the RFC 
assignments. You can enter the full system name, use a wildcard (T*), 
or leave this field blank to retrieve all RFC assignments for all logical 
systems.
13-85
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 13      Using SAP Adapters
  SAP RFC Adapter
BD97 – Read RFC Destinations Standard Destinations Method Instance Properties

The BD97 - Read RFC Assignments Standard Destinations method display-only page displays the 
properties used to retrieve RFC assignments that are defined in BD97 for standard destinations.

BDC – Data Loader Method Instance Properties

The BDC Data Loader display-only page displays the properties used to pass pre-recorded BDC (Batch 
Data Communication) data into a function that either executes the transaction directly (Synchronous) or 
records the session, returning the Session ID that can be found using SAP Transaction SM35 for 
processing.

BDLS – Convert Logical Systems Background Job Method Instance Properties

The BDLS - Convert Logical Systems Background Job display-only page displays the properties used to 
convert logical system (LOGSYS) names using transaction code BDLS.

Field Description

Logical system Name of the SAP logical system from which to retrieve the RFC 
assignments. You can enter the full system name, use a wildcard 
(T*), or leave this field blank to retrieve all RFC assignments for all 
logical systems.

Field Description

SAP Transaction SAP transaction code to be called

Transaction BDC Data BDC Data pre-recorded and formatted per SAP requirements. 
Transaction recordings can be created using the SAP BDC Recorder 
transaction, accessible via SM35.

The BDC data consists of five columns that should be populated with the 
following information:

• Program – SAP Program name (for example, SAPMV45A)

• Dynpro – SAP Screen number (for example, 0100)

• DynBegin – X if the screen (Dynpro) is a new screen in the screen 
sequence

• Field Name – SAP Field name that data is to be supplied for, or the 
BDC reserved name such as BDC_OKCODE or BDC_CURSOR.

• Field Value – Value for the screen field specified in FIELDNAME.

Field Description

Old Logical System Name Name of the logical system name to be converted.
New Logical System Name New name to be assigned to the logical system.
Client Dependent Only Indicates whether to convert only client dependent tables.
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BDLS – Get Tables Method Instance Properties

The BDLS - Get Tables method display-only page display the properties to retrieve a list of relevant 
BDLS tables for conversion. The list of tables includes the number of entries greater than the defined 
threshold.

BW – BWA Reorganize Landscape Method Instance Properties

The BW - BWA Reorganize Landscape method display-only page displays the properties used to 
reorganize the BWA landscape.

BW – Change Index Global Parameters Method Instance Properties

The BW - Change Index Global Parameters method display-only page displays the properties used to 
modify the index global parameters.

BW – Check DTP Status Method Instance Properties

The BW - Check DTP Status method display-only page displays the properties used to retrieve the list 
DTP status in the BW system.

Number of Entries per 
Commit

Numeric value to indicate the number of entries to include per 
Commit.

Job Name Job name of the scheduled job in SAP.

Field Description

Field Description

Threshold The maximum number of rows to exceed before returning the table. 
All tables that have a number of rows greater than this threshold 
value will be returned. The default value is 10000.

Field Description

RFC Destination RFC destination to TREX engine.

Field Description

Parameter Type Type of global parameter to be changed.

Parameter Value New value of the global parameter.

Field Description

Request ID A numeric value or variable that represents the DTP request
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BW – Check OLAP Connection Method Instance Properties

The BW - Check OLAP Connection method display-only page displays the properties used to verify 
connection to the OLAP interface in the BW system.

BW – Get BW InfoCube Dimensions Method Instance Properties

The BW - Get BW InfoCube Dimensions method display-only page displays the properties used to 
retrieve the list of InfoCubes in the BW system and their associated layout.

BW – Get BWA Index Reorg Plan Data Method Instance Properties

The BW - Get BWA Index Reorg Plan Data method display-only page displays the properties used to 
reorganize BWA landscape for performance.

BW – Get InfoCube Size Method Instance Properties

The BW - Get InfoCube Size display-only page displays the properties used to retrieve the row sizing 
information for all InfoCube tables.

BW – Get Infocube List Method Instance Properties

The BW - Get InfoCube List method display-only page displays the properties used to retrieve the list 
of InfoCubes in the BW system.

BW – Get Infopackage Source System Instance Properties

The BW - Get Infopackage Source System method display-only page displays the properties used to 
retrieve the source system for the specified Infopackage.

BW – Get Last BWA Index Reorg Status Method Instance Properties

The BW - Get Last BWA Index Reorg Status method display-only page displays the properties used to 
retrieve the state of the last executed reorganization plan.

Field Description

RFC Destination RFC destination to TREX engine.

Field Description

Infopackage ID Infopackage identifier

Field Description

RFC Destination RFC destination to TREX engine.
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BW – Get Monitored Process Chains Method Instance Properties

The BW - Get Monitored Process Chains method display-only page displays the properties used to 
retrieve a list of process chains that are being monitored manually via transaction RSPCM (monitor 
process chains).

BW – Get Process Chain Jobs Method Instance Properties

The BW - Get Process Chain Job method display-only page displays the properties used to retrieve a list 
of SM37 jobs.

BW – Get Process Chain Log Method Instance Properties

The BW - Get Process Chain Log method display-only page displays the properties used to retrieve the 
process chain status messages recorded in the process chain log.

BW – Get Process Chain Parent Method Instance Properties

The BW - Get Process Chain Parent method display-only page displays the properties used to determine 
the process chain parent of a meta-chain.

BW – Get Process Chain Processes Method Instance Properties

The BW - Get Process Chain Processes method display-only page displays the properties used to 
determine the process chain variants.

BW – Get Process Variant Job Log Method Instance Properties

The BW - Get Process Variant Job Log method display-only page displays the properties used to retrieve 
the status of process chain variant job logs, which contain detailed status messages and job status for 
process variant steps.

BW – Get Process Variant Log Method Instance Properties

The BW - Get Process Variant Log method display-only page displays the properties used to retrieve 
status of process chain variant logs, which contain detailed status messages and status for process variant 
steps.

Field Description

Process Chain ID of the process chain

Field Description

Process Chain ID of the process chain

Field Description

Process Variant(s) A variable that represents the name or ID of the process variant.
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BW – Get Queries for InfoCube Method Instance Properties

The BW - Get Queries for InfoCube method display-only page displays the properties used to retrieve a 
list of queries for an infocube.  

BW – Get Query Top Executions Method Instance Properties

The BW - Get Query Top Executions method display-only page displays the properties used to retrieve 
the top queries by number of executions.

BW – Get Source System Delta Queue Status (RSA7) Method Instance Properties

The BW - Get Source System Delta Queue Status (RSA7) method display-only page displays the 
properties used to retrieve a list of the data sources and their status in RSA7.  

BW – Infocube Memory Consumption – Grand Totals Method Instance Properties

The BW - Infocube Memory Consumption - Grand Totals method display-only page displays the 
properties used to retrieve sizing data to estimate memory requirements of BW infocubes for indexing 
in BW Accelerator.

Field Description

Process Variant(s) A variable that represents the name or ID of the process variant.

Field Description

Infocube Name of the infocube for which to retrieve queries.

Field Description

Get Executions in the Last X 
Minutes

Start time to return results. The default value is 60 minutes.

Field Description

Source System Client The client of the source system or a variable that represents the 
client

Field Description

Infocubes List of infocubes for which to obtain sizing data.

Run as Job Indicates whether a job should be created for each infocube.
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BW – Infocube Memory Consumption – Table Totals Method Instance Properties

The BW - Infocube Memory Consumption - Table Totals method display-only page displays the 
properties used to retrieve sizing data for tables to estimate memory requirements of BW infocubes for 
indexing in BW Accelerator.

BW – Infocube Memory Consumption Grand Totals From Job Method Instance Properties

The BW - Infocube Memory Consumption - Grand Totals From Job method display-only page displays 
the properties used to retrieve sizing data for a specific job to estimate memory requirements of BW 
infocubes for indexing in BW Accelerator.

BW – Infocube Table Sizes Method Instance Properties

The BW - Infocube Table Sizes method display-only page displays the properties used to retrieve table 
size for the specified Infocube.

BW – RSDDAGGRDIR – List Aggregates Method Instance Properties

The BW - RSDDAGGRDIR method display-only page displays the properties used to retrieve BW 
aggregates in BW Accelerator per the BWA Assessment Pulse Check requirements.

BW – RSDDBIAMON2 Get Infocube Indexes for Query Method Instance Properties

The BW - RSDDBIAMON2 Get Infocube Indexes for Query method display-only page displays the 
properties used to retrieve a list of the infocube indexes for a BW query.

BW – RSDDSTAT Get BW 3.5 DM Statistics Method Instance Properties

The BW - RSDDSTAT Get BW 3.5 DM Statistics method display-only page displays the properties used 
to retrieve query statistics on BW 3.5 systems.

Field Description

Infocubes List of infocubes for which to obtain sizing data.

Field Description

Job ID Identification number of the job for which to retrieve sizing data.

Field Description

Infocube Infocube for which to obtain table size.

Field Description

Query Name Name of a BW query (for example, 0SD_C03/0SD_C03_Q007).
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BW – RSDDSTAT Get BW 3.5 Header Statistics Method Instance Properties

The BW - RSDDSTAT Get BW 3.5 Header Statistics method display-only page displays the properties 
used to retrieve query statistics on BW 3.5 systems.

BW – RSDDSTAT Get BW 3.5 OLAP Statistics Method Instance Properties

The BW - RSDDSTAT Get BW 3.5 OLAP Statistics method display-only page displays the properties 
used to retrieve query statistics on BW 3.5 systems.

BW – RSDDSTAT OLAP – List Queries with High OLAP Time Method Instance Properties

The BW - RSDDSTAT_OLAP - List Queries with High OLAP Time display-only page displays the 
properties to retrieve a list of query statistics for all queries with high OLAP runtime.

BW – RSDDSTAT_DM – List Queries with High DM Time Method Instance Properties

The BW - RSDDSTAT_DM - List Queries with High DM Time display-only page displays the properties 
to retrieve a list of query statistics for all queries with high Data Manager read time.

Field Description

Date (yyyyMMddHHmmss) Start date and time from which to retrieve statistics.

Last X minutes prior to the 
specified date

Number of minutes prior to the specified date for which to retrieve 
statistics.

Field Description

Date (yyyyMMddHHmmss) Start date and time from which to retrieve statistics.

Last X minutes prior to the 
specified date

Number of minutes prior to the specified date for which to retrieve 
statistics.

Field Description

Date (yyyyMMddHHmmss) Start date and time from which to retrieve statistics.

Last X minutes prior to the 
specified date

Number of minutes prior to the specified date for which to retrieve 
statistics.

Field Description

Run time in seconds Minimum number of seconds for OLAP runtime for which to retrieve 
statistics.

Start Date Start date and time to begin retrieving statistics.

Last X minutes prior to the 
specified date

Time period, in minutes, for selecting statistics based on the date.
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BW – RSDDTPS Index Maintenance for Business Objects Polestar Method Instance Properties

The BW - RSDDTPS Index Maintenance for Business Objects Polestar display-only page displays the 
properties to create indexes or convert existing indexes for infocubes that are used by Business Objects 
Explorer Accelerated

BW – RSDDV Create Index Method Instance Properties

The BW - RSDDV Create Index display-only page displays the properties used to create an index in 
BWA.

BW – RSDDV Delete Index Method Instance Properties

The BW - RSDDV Delete Index display-only page displays the properties used to delete an index in 
BWA.

BW – RSDDV Fill Index Method Instance Properties

The BW - RSDDV Fill Index display-only page displays the properties used to fill an index in BWA.

Field Description

Read time in seconds Minimum number of seconds for Data Manager read time for which 
to retrieve statistics.

Start Date Start date and time to begin retrieving statistics.

Last X minutes prior to the 
specified date

Time period, in minutes, for selecting statistics based on the date.

Field Description

Infocube Name of the BW infocube.

User Authorization The table that contains the users and BI authorizations for accessing 
the infocube.

Field Description

Infocube Infocube for which to create index.

Field Description

Infocube Infocube for which to delete index.

Field Description

Infocube Infocube for which to fill index.
13-93
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 13      Using SAP Adapters
  SAP RFC Adapter
BW – RSPC Finish Process Chain Method Instance Properties

The BW - RSPC Finish Process Chain display-only page displays the properties used to reset the status 
of a failed process chain step and restart the chain to run to the end of the completion from the point of 
failure.

BW – RSPC Stop Process Chain Method Instance Properties

The BW - RSPC Stop Process Chain display-only page displays the properties used to stop the process 
chain.

BW – RSRCACHE Get Cache Monitor Buffer Objects Method Instance Properties

The BW - RSRCACHE Get Cache Monitor Buffer Objects display-only page displays the properties to 
retrieve the information of the BW cache monitor buffer objects.

BW – RSRCACHE Get OLAP Cache Parameters Method Instance Properties

The BW - RSRCACHE Get OLAP Cache display-only page displays the properties to retrieve the BW 
OLAP cache parameters.

BW – RSRT Analyze Query Method Instance Properties

The BW - RSRT Analyze Query Method display-only page displays the properties used to execute a BW 
query and provide performance statistics on the query runtime.

BW – RSRT Analyze Single Query Method Instance Properties

The BW - RSRT Analyze Single Query Method display-only page displays the properties used to execute 
a BW query and provide performance statistics on the query runtime.

Field Description

Variant Name of the process chain variant.

Instance ID of a runtime instance of a process chain.

State Status of the process chain to run.

Field Description

Use Cache Indicates whether to use OLAP cache during the query execution.

Use Aggregates Indicates whether to use aggregates during the query execution.

Use BWA Index Indicates whether to use BWA index (if it exists) during the query 
execution.

Use Parallel Processing Indicates whether to use parallel processing during the query 
execution.
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BW – RSRT Check Query Mandatory Variables Method Instance Properties

The BW - RSRT Check Query Mandatory Variables Method display-only page displays the properties 
used to check the entry requirements for the variables of an SAP BW query (optional, mandatory, or 
mandatory but initial value not allowed).

BW – RSRV Data Consistency Check Method Instance Properties

The BW - RSRV Data Consistency Check display-only page displays the properties used to check for 
data discrepancies on BW infocubes and their BWA indexes.

BW – Read Info Provider Data Method Instance Properties

The BW - Read Info Provider Data method display-only page displays the properties used to read data 
from InfoProvider objects in SAP BW.

Field Description

Query Technical Name Name of the query to execute.

Use Cache Indicates whether to use OLAP cache during the query execution.

Use Aggregates Indicates whether to use aggregates during the query execution.

Use BWA Index Indicates whether to use BWA index (if it exists) during the query 
execution.

Use Parallel Processing Indicates whether to use parallel processing during the query 
execution.

Query Variables Query input variant values.

Field Description

Test Case Name of the data consistency check (Consistency-Checks (fast) or 
Consistency Check with Random Queries).

Test Object Type Type of object (Infocube) to be checked for data consistency.

Test Object Name of the object to be checked for data consistency (IFC).

Field Description

Info provider Technical name of the InfoCube, DataStore object or MultiProvider

RFC mode ID RFC mode logical identifier

RFC mode receiver Received RFC-capable ABAP function name

SFC Table List of characteristics

SFK Table List of key figures

Range Table Range list

Table Selection List of table selections
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BW – Read Info Provider Vertical Data Method Instance Properties

The BW - Read Info Provider Data method display-only page displays the properties used to read data 
from InfoProvider objects in SAP BW. The data is returned in a vertical data table.

BW – SE38 Create Variant Method Instance Properties

The SE38 - Create Variant display-only page displays the properties used to create a variant for an SAP 
ABAP program.

BW – TREX Get Alert Details Method Instance Properties

The BW - TREX Get Alert Details display-only page displays the properties used to retrieve the alert 
details of the TREX index.

RTime Table Table of intervals for non-cumulatives

Requid Table Ranges for REQUID table

Field Description

Field Description

Info provider Technical name of the InfoCube, DataStore object or MultiProvider

RFC mode ID RFC mode logical identifier

RFC mode receiver Received RFC-capable ABAP function name

RFC mode ID RFC mode logical identifier

SFC Table List of characteristics

SFK Table List of key figures

Range Table Range list

Table Selection List of table selections

RTime Table Table of intervals for non-cumulatives

Requid Table Ranges for REQUID table

Field Description

Program Name Name of the ABAP program or report.

Variant Name Name of the ABAP variant.

Variant Values Values to be assigned to the variant.

Field Description

RFC Destination Name of the TREX server RFC destination.

Alert Check Name Name of the type of alert to be checked.

Alert Execution Time 
(yyyyMMddHHmmss)

Date and time from which to begin retrieving alerts.
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BW – TREX Get Alerts Method Instance Properties

The BW - TREX Get Alerts display-only page displays the properties used to retrieve the alerts in the 
TREX index.

BW – TREX Get Index Status Method Instance Properties

The BW - TREX Get Index Status display-only page displays the properties used to retrieve the status 
of the TREX index.

BW – TREX Get Landscape Status Summary Method Instance Properties

The BW - TREX Get Landscape Status Summary display-only page displays the properties used to 
retrieve the TREX BWA blade status summary information..

BW – TREX Kill Server Processes Method Instance Properties

The BW - TREX Kill Server Processes display-only page displays the properties used to kill processes 
running on the TREX server.

BW – TREX List Indexes Method Instance Properties

The BW - TREX List Indexes display-only page displays the properties used to retrieve a list of indexes 
on the BWA blade and memory usage per index.

Field Description

RFC Destination Name of the TREX server RFC destination.

Date (yyyyMMddHHmmss) Date and time from which to start retrieving the alerts.

Last X minutes prior to the 
specified date

Number of minutes prior to the specified date to start retrieving the 
alerts.

Field Description

Infocube Name of the index infocube.

Field Description

RFC Destination Name of the TREX server for RFC destination.

Field Description

RFC Destination Name of the TREX server RFC destination.

Server Host name of the TREX server where the processes are running.

Process IDs Process IDs, separated by a comma, for those processes to be killed.
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BW – TREX Reconfigure Server Method Instance Properties

The BW - TREX Reconfigure Server display-only page displays the properties used to reconfigure the 
TREX server.

BW – TREX Restart Service Method Instance Properties

The BW - TREX Restart Service display-only page displays the properties used to restart the TREX 
server.

BW – TREX Service Statistics Method Instance Properties

The BW - TREX Service Statistics display-only page displays the properties used to retrieve blade 
TREX service statistics.

CRMRFCPAR – Create Method Instance Properties

The CRMRFCPAR - Create display-only page displays the properties used to create a new entry in the 
CRMRFCPAR configuration table for a consumer and object combination.

Field Description

RFC Destination Name of the TREX server RFC destination.

Index Server Index server host/port.

Namespace Index namespace.

Field Description

RFC Destination Name of the TREX server RFC destination.

Server Host name of the TREX server.

Process IDs Process IDs, separated by a comma.

Field Description

RFC Destination Name of the TREX server RFC destination.

Server Host name of the TREX server.

Process IDs Process IDs, separated by a comma.

Field Description

RFC Destination TREX server RFC destination.

Show History Indicates whether to return history.
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CRMRFCPAR – Modify Method Instance Properties

The CRMRFCPAR - Modify display-only page displays the properties used to change an existing entry 
in the CRMRFCPAR configuration table for a consumer and object combination.

CRMRFCPAR – Read Method Instance Properties

The CRMRFCPAR - Read method display-only page displays the properties used to retrieve information 
from the CRMRFCPAR table.

CRMRFCPAR – Remove Method Instance Properties

The CRMRFCPAR - Remove display-only page displays the properties used to remove a specific entry 
in the CRMRFCPAR configuration table for a consumer and object combination.

Field Description

Consumer CRM partner name.

Object Name Data object/table name.

RFC Destination RFC destination of partner.

RFC Queue Name of the RFC outbound queue.

RFC Inbound Queue Name of the RFC inbound queue.

Inbound Queue Used Indicates whether the inbound queue was used.

Send XML Indicates whether to send the message in XML format.

Hold Data Indicates whether the data should be held instead of sending to partner.

Field Description

Consumer CRM partner name.

Object Name Data object/table name.

RFC Destination RFC destination of partner.

RFC Queue Name of the RFC outbound queue.

RFC Inbound Queue Name of the RFC inbound queue.

Inbound Queue Used Indicates whether the inbound queue was used.

Send XML Indicates whether to send the message in XML format.

Hold Data Indicates whether the data should be held instead of sending to 
partner.

Field Description

Consumer Partner system name, such as CRM or IPC.

Object Name Name of the data object. The asterisk (*) indicate that all objects are 
to be retrieved.
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DB02 – Get DB6 Tablespace Method Instance Properties

The DB02 - Get DB6 Tablespace display-only page displays the properties used to retrieve DB6 (DB2 
UDB) tablespace usage data.

DB02 – Reset Statistics Method Instance Properties

The DB02 - Reset Statistics display-only page displays the properties used to launch the SAP program 
to reset the DB2 database statistics.

DBACOCKPIT – Read DB6 UDF Configuration Method Instance Properties

The DBACOCKPIT - Read DB6 UDF Configuration method display-only page displays the properties 
used to read the path for the User Defined Function library. This is defined for DB6 databases via 
DBACockpit transaction.

DBACOCKPIT – Update DB6 UDF Configuration Method Instance Properties

The DBACOCKPIT - Update DB6 UDF Configuration method display-only page displays the properties 
used to update the path for the User Defined Function library.  

Execute ABAP Function – XML Method Instance Properties

The Execute ABAP Function - XML method display-only page displays the properties used to call 
function methods through an SAP generic proxy.

Field Description

Consumer CRM partner name.

Object Name Data object/table name.

Field Description

Percentage Used Value for the percentage of used tablespace. Data will be retrieved 
for tables paces with a percentage of usage equal to or greater than 
the value specified. The default value is 0.

Field Description

Path New path to the User Defined Function library.

Field Description

Function Module Name Name of the SAP function module to call

Import Parameters Parameters and values to be retrieved

Import Structures Structures and values to be retrieved

Import Tables Tables to be retrieved
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Execute ABAP Program – String Method Instance Properties

The Execute ABAP Program - String method display-only page displays the properties used to run SAP 
programs through execution of the function inst_execute_report. The results are returned in a string.

Execute ABAP Program – Table Method Instance Properties

The Execute ABAP Program - Table method display-only page displays the properties used to run SAP 
programs through execution of the function inst_execute_report. The results are returned in a data table.

Get SAP Server Info Method Instance Properties

The Get SAP Server Info display-only page displays the properties used to retrieve information about 
the specified SAP server.

ICM – Clear HTTP Cache Method Instance Properties

The ICM - Clear HTTP Cache display-only page displays the properties used to clear the HTTP cache 
on the ABAP server.

Field Description

Program Name Name of the SAP program to be run.

Parameters If the program has input parameters, you must specify a data table 
with the columns Name and Value. For example, for the program 
RSRFCPIN, the data table would contain the columns:

Name = DEST

Value = <destination to test>

Field Description

Program Name Name of the SAP program to be run.

Parameters If the program has input parameters, you must specify a data table 
with the columns Name and Value. For example, for the program 
RSRFCPIN, the data table would contain the columns:

Name = DEST

Value = <destination to test>

Field Description

Server 
(ServerHost_SID_SysNo)

Name of the SAP application server for which information 
should be retrieved

Field Description

Global Indicates whether to clear the cache on all application servers or only 
the application server on which this method is executed.
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ICM – Restart J2EE Server Method Instance Properties

The ICM - Restart J2EE Server display-only page displays the properties used to restart the J2EE server 
associated with an ABAP system.

ICM – Stop J2EE Server Method Instance Properties

The ICM - Stop J2EE Server display-only page displays the properties used to shut down the J2EE server 
that is associated with an ABAP system.

PFCG – Update Composite Role Method Instance Properties

The PFCG - Update Composite Role display-only page displays the properties used to update a 
composite role.

PI – Get Message List Method Instance Properties

The PI - Get Message List method display-only page displays the properties used to retrieve the 
messages.

RBDMONI5 – Get Open Change Pointers Method Instance Properties

The RBDMONI5 - Get Open Change Pointers method display-only page displays the properties used to 
retrieve the number of outstanding change pointers to be processed for a selected message type.

Field Description

Request Soft Shutdown Indicates whether to send a soft shutdown.

Field Description

Composite Role Name of the existing composite role

Single Roles Table variable that contains the name of the new role.

Field Description

Message status group Type of messages retrieved:

All Errors – Retrieves all error messages

Get messages in the last x 
minutes

Time period, in days, for selecting messages to retrieve based on the 
date

Field Description

Message type Message type used to retrieve the number of outstanding change 
pointers. Leave this field blank to retrieve open change pointers for 
all message types.
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RSMO – Get InfoPackage Requests Method Instance Properties

The RSMO - Get InfoPackage Requests method display-only page displays the properties to retrieve the 
InfoPackage processing requests that have not completed processing or are in failed status.

RSMO – InfoPackage Request Error Message Method Instance Properties

Use the RSMO - InfoPackage Request Error Message method to retrieve the InfoPackage request 
processing log with detailed information about InfoPackage failures.

RSRDA End Daemons Method Instance Properties

The RSRDA End Daemons display-only page displays the properties used to stop all daemon processes 
on the BW system.

RZ03 – Swap OP Modes Instance Properties

The RZ03 - Swap OP Modes display-only page displays the properties used to switch to another 
operation mode for a specific server.

RZ04 – List Operation Modes Instances Method Instance Properties

The RZ04 - List Operation Modes display-only page displays the properties used to retrieve a list all 
instance information and the operation modes assigned to the instance to verify that changes have been 
made.

Field Description

Date (yyyyMMddHHmmss) Date from which to retrieve the data. If you leave this field blank, data 
from the current date will be retrieved.

Last X minutes prior to the 
specified date

Time period, in minutes, for selecting InfoPackage processing 
requests based on the date

Method Parameters

Displays the parameters for the selected method.

Field Description

InfoPackage request ID SAP ID of the InfoPackage request.

Field Description

Operation Mode Name of the operation mode, as defined in RZ04, to switch the 
server. 

Application Server 
(ServerHost_SID_SysNo)

Full name of the application server (instance) to be switched. 
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RZ04 – List Operation Modes Method Instance Properties

The RZ04 - List Operation Modes display-only page displays the properties used to retrieve a list of 
operation modes.

RZ04 – Update All Operation Modes Method Instance Properties

The RZ04 - Update All Operation Modes display-only page displays the properties used to automatically 
remove all incorrect productive instances and to create new instances.

RZ10 – Change Dynamic Parameter Method Instance Properties

The RZ10 - Change Dynamic Parameter method display-only page displays the properties used to 
change the value of dynamic switchable parameters.

RZ10 – Delete Profiles Method Instance Properties

The RZ10 - Delete Profiles display-only page displays the properties used to delete the profiles of all 
active servers.

Method Parameters

No parameters are required for this method.

Field Description

Assembly Path name to the .NET assembly that contains the remote-enabled 
function

Class name Class within the assembly that contains the custom method

Method name Custom method name

Time out if not completed 
within

Specified time out interval within which the RFC call must complete. 
If the RFC call does not complete within the specified time out 
interval, the activity will fail with Failed (Not Completed) status.

Field Description

Displays the parameters for the selected method. Complete the appropriate fields, as 
necessary.

Field Description

Parameter name Name of the parameter to be changed

Parameter value New value to assign to the parameter
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RZ10 – Import Profiles Method Instance Properties

The RZ10 - Import Profiles display-only page displays the properties used to import the start and 
instance profiles of all active servers.

RZ10 – Modify Profile Parameter Value Method Instance Properties

The RZ10 - Modify Profile Parameter Value display-only page displays the properties used to verify the 
system profile parameter value and modify the value if it is incorrect.

RZ10 – Read Profile Parameters Method Instance Properties

The RZ10 - Read Profile Parameters display-only page displays the properties used to verify system 
profile parameter values.

RZ11 – Change Dynamic Parameter Method Instance Properties

The RZ11 - Change Dynamic Parameter method display-only page displays the properties used to 
change a dynamically switchable profile parameter.

RZ12 – Create Logon Group Method Instance Properties

The RZ10 - Create Logon Group display-only page displays the properties used to create a new SAP 
logon group.

Field Description

Parameter Name Name of the profile parameter to be verified. Refer to SAP 
transaction RZ11 for a complete set of profile parameter 
definitions and allowable values.

Parameter Value New value to be assigned to the profile parameter

Ignore Errors and 
Warnings

Indicates whether errors and warnings should be ignored.

Field Description

Parameter Name Name of the parameter whose values need to be verified

Field Description

Parameter name Name of the parameter to be changed

Parameter value New value to assign to the parameter

Field Description

Logon Group Name of the SAP logon group to be created

Instance Instance in the target system where the SAP logon group will be 
created
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RZ12 – Delete All Logon Groups Method Instance Properties

The RZ12 - Delete All Logon Groups display-only page displays the properties used to delete all SAP 
logon groups.

RZ12 – Delete Logon Group Method Instance Properties

The RZ12 - Delete Logon Group display-only page displays the properties used to delete a specific SAP 
logon group.

RZ12 – List Logon Groups Method Instance Properties

The RZ12 - List Logon Groups display-only page displays the properties used to retrieve a list of all 
logon groups.

RZ20 – Change CCMS Thresholds Method Instance Properties

The RZ20 - Change CCMS Thresholds display-only page displays the properties used to change the 
performance threshold values of CCMS monitoring classes.

RZ70 – Get Status Info Method Instance Properties

The RZ70 - Get Status Info display-only page displays the properties used to retrieve the host name and 
gateway service configured on the target system.

RZ70 – Set SLD Supplier Method Instance Properties

The RZ70 - Set SLD Supplier display-only page displays the properties used to reset the System 
Landscape Directory (SLD) supplier configuration.

Field Description

Logon Group Name of the SAP logon group to be deleted

Field Description

Monitor Set Name Name of the CCMS monitor set.

Monitor Name Name of the CCMS monitor.

Field Description

SAP Host Name Host name of server with SLD (for example, sapqaxi.cisco.com).

SAP Gateway Service SAP Gateway on SLD server (for example, sapgw01).

Start Data Collector Indicates whether to immediately start the data collector.

Start Synchronous Indicates whether to execute data collector in synchronous mode.
13-106
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 13      Using SAP Adapters
  SAP RFC Adapter
Read Single Column From SAP Table Method Instance Properties

The Read Single Column From SAP Table display-only page displays the properties used to read a single 
column from a specific SAP table.

SAP RFC Function Instance Properties

The SAP RFC Function page displays the properties of the remote-enabled function activity used to run 
against an SAP system or application server.

SCC4 – Modify Client Method Instance Properties

The SCC4 - Modify Client display-only page displays the properties used to maintain the attributes of 
clients in the SAP system.

SCC4 – Read Client Method Instance Properties

The SCC4 - Read Client display-only page displays the properties used to read the client details 
configured on the SAP system. This method retrieves the details of the SAP Table T000 that is viewed 
and maintained using the SAP transaction SCC4. This method can be used to verify changes (Change 
date/user) or the current client configuration, such as a client that is open for modification.

SCC7 – Client Import Method Instance Properties

The SCC7 - Client Import method display-only page displays the properties to import data a from a client 
export (client copy job) into SAP.

Field Description

Table Name Name of the table that contains the column to be read

Column Name Name of the column from which to retrieve information

Field Description

Client SAP client number to be maintained.

Logical System SAP logical system ID, validated based on SAP table 
TBDLS. This is normally a combination of the system ID and 
the client number (for example, QUACLNT800). A blank 
value results in no changes being made.

Changes and Transports 
for Client Dependent 
Entries

Changes and transports that are allowed for client-specific 
objects:

• Don’t change this field

• No automatic recording of changes for transport

• Changes are recorded in transport request

• Customizing in this client cannot be changed

• Customizing can be changed as requested, but cannot be 
transported
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SCC8 – Client Export Method Instance Properties

The SCC8 - Client Export display-only page displays the properties used to export data (SAP users and 
their profiles) from SAP.

SCOT – Clear Node Address Method Instance Properties

The SCOT - Clear Node Address method display-only page displays the properties used to clear specific 
recipient filters for existing nodes defined in the SA Connect application in an SAP ABAP system.

SCOT – Get Transaction SCOT Data Method Instance Properties

The SCOT - Get Transaction SCOT Data method display-only page displays the properties used to 
retrieve data from SAPConnect that is related to external communications from an SAP system such as 
fax and email.  

SCOT – Set Node Address Method Instance Properties

The SCOT - Set Node Address display-only page displays the properties used to set specific recipient 
filters for existing nodes defined in the SAPConnect application in an SAP ABAP system. This method 
is called to set specific outbound mail routing settings to prevent emails from being sent out to partner 
systems.

Field Description

Export Profile Name of the profile to be exported. This is the named profile created 
via SAP transaction SCC8.

Target System ID System ID for the target system. Typically, this is the same system ID 
as the export system in a client-copy scenario.

Field Description

Node Name Name of the defined node in SAPConnect.

Address Type Message routing address type. 

Field Description

Error Specify whether to only retrieve items in error status

Inconsistency Specify whether to only retrieve items that have inconsistency issues

Time Period (in minutes) Time range for selecting records

Field Description

Node Name Name of the defined node in SAPConnect.

Address Type Message routing address type.

Address Address name/restriction for routing.
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SCOT – Set SMTP Host Method Instance Properties

The SCOT - Set SMTP Host display-only page displays the properties used to reset the host name and 
port number for an existing SMTP node.

SDCCN – Clear Tasks Method Instance Properties

The SDCCN - Clear Tasks display-only page displays the properties used to clear SDCCN tasks.

SDCCN – Read Tasks Method Instance Properties

The SDCCN - Read Tasks display-only page displays the properties used to retrieve a list of scheduled 
SDCCN tasks.

SDCCN – Schedule Tasks Method Instance Properties

The SDCCN - Schedule Tasks display-only page displays the properties used to schedule an SDCCN 
task.

SE06 – Perform Post-Installation Actions Method Instance Properties

The SE06 - Perform Post-Installation Actions display-only page displays the properties used to reset the 
TMS configuration.

SE06 – Set System Change Options Method Instance Properties

Use the SE06 - Set System Change Options display-only page displays the properties used to modify the 
setting of system change options in the SAP system.

Field Description

Node Name Name of the defined node in SAPConnect.

Host Name Name of the SMTP host.

Port Number Port number of the SMTP host.

Field Description

Task Technical Name Technical task name from database table 
/BDL/TASK_ATTR.

Periodic Indicates whether the scheduled task should run on a periodic 
schedule.

Field Description

Post-Installation Type Type of post-installation action to be performed (database 
copy/database migration).

Source System ID System ID (SID) for the source copy system
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SE10 – Export Tables Method Instance Properties

The SE10 - Export Tables display-only page displays the properties used to create an SAP transport that 
contains SAP table data that is to be exported from the target system during a system copy and then 
re-imported after a system copy.

SE38 – Change Variant Method Instance Properties

The SE38 - Change Variant display-only page displays the properties used to modify an existing variant 
of an SAP program.

Field Description

Global Setting System-wide change option—either Modifiable or Not modifiable.

Software Components Table of individual software components and their change options. 

Namespaces Table of individual namespaces and their change option.

Field Description

Description Description of the transport.

Release Indicates whether to automatically release the transport to the 
transport directory.

Export Table List List of ABAP tables to be exported in a single transport (Change 
Request).

Field Description

Program Name Name of the ABAP program or report.
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Variant Name Name of the ABAP variant that needs to be modified.

Variant Values New values to be assigned to the variant

Note This requires a table variable with the following parameters:

Program Parameter

Enter parameter or select option name defined on the ABAP program 
selection screen. Use the screen field value that is displayed when 
you press F1 and then select Technical Information on the selection 
screen field.

Type of Selection

P (Parameter)

• "I" can be specified in the Include/Exclude column

• "EQ" can be specified in the Select-option column

• Field value can be specified in the Low column

S (Select-Option)

Include/Exclude

I (Inclusive of defined values/range)

E (Exclusive of defined values/range)

Selection Option

EQ - Equal To (= Low)

NE - Not equal to (<> Low)

BT - Between lower and upper value (Low <= x <= High)

NB - Outside lower and upper value (x < Low and High < x )

CP - Contains the pattern

NP - Does not contain the pattern

LT - Less Than (< Low)

LE - Less than or equal to (<= Low)

GT - Greater Than (> Low)

GE - Greater than or equal to  (>=Low)

Note For Variant values containing a CP in the Option column, the 
values of (+) for a single field wildcard or (*) for a multiple 
field wildcard must be specified in the value provided for the 
Low or High column.

Low Value

Lower limit value, or for single value

High Value

Upper limit value, for ranges

Field Description
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 SE38 – Create Variant Method Instance Properties

The SE38 - Create Variant display-only page displays the properties used to create a variant for an SAP 
ABAP program.

SE38 – Display Variant Values Method Instance Properties

The SE38 - Display Variant Values display-only page displays the properties used to retrieve a list of 
variant parameters for a program.

SE61 – Display Document Method Instance Properties

The SE61 - Display Document display-only page displays the properties used to display the content of 
a document on the SAP system (for example, ZLOGIN_SCREEN_INFO).

SE61 – Modify Document Method Instance Properties

The SE61 - Modify Document display-only page displays the properties used to modify a document on 
the SAP system.

SECSTORE – Check Status Method Instance Properties

The SECSTORE - Check Status method display-only page displays the properties used to check the 
status of the secure storage on the ABAP stack.

SECSTORE – Set Migration Key Method Instance Properties

The SECSTORE - Set Migration Key method display-only page displays the properties used to set the 
migration key in the event the system ID or installation number has changed in a production system.

Field Description

Document Language Language of the document to be modified or displayed (for 
example, EN=English, DE=German).

Field Description

Document Language Language of the document to be modified or displayed (for example, 
EN=English, DE=German).

Document Lines Table of text lines that make up the content of the document. The 
table contains the following columns:

• Line Number - Line number to be updated. Each line number 
equals one row in the document. The current content of the 
document will be overwritten.

• Text Line - Text line to be updated. Each text line equals one row 
in the document. The current content of the document will be 
overwritten.
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SICF – Activate Service Method Instance Properties

The SICF - Activate Service display-only page displays the properties used to activate service nodes and 
their direct sub-nodes defined in the Internet Connection Framework Tree (HTTP Service Tree) via SAP 
transaction SICF.

SICF – Clear Service Anonymous User Login Data Method Instance Properties

The SICF - Clear Service Anonymous User Login Data display-only page displays the properties used 
to clear the anonymous logon user for a service defined in the Internet Connection Framework Tree 
(HTTP Service Tree) via SAP Transaction SICF.

SICF – Deactivate Service Method Instance Properties

The SICF - Deactivate Service display-only page displays the properties used to deactivate service nodes 
and their direct sub-nodes defined in the Internet Connection Framework Tree (HTTP Service Tree) via 
SAP transaction SICF.

Field Description

Old System ID System number of the source system.

Old Installation Number Installation number of the source system.

New Migration Key Migration key (Hex values) downloaded from the SAP Service 
Marketplace.

Field Description

Service Name SAP service name (for example, SAP/PUBLIC/PING).

Test Only Indicates whether changes are to be made; if set to No, only the 
verification of the service name is performed.

Apply to Direct 
Subordinate(s)

Indicates whether to apply the activation activity to the direct 
sub-nodes of the specified service name (direct children of the 
service name in the HTTP tree).  

Field Description

Service Name SAP service name (for example, SAP/PUBLIC/PING).

Field Description

Service Name SAP service name (for example, SAP/PUBLIC/PING).

Test Only Indicates whether changes are to be made; if set to No, only the 
verification of the service name is performed.

Apply to Direct 
Subordinate(s)

Indicates whether to apply the activation activity to the direct 
sub-nodes of the specified service name (direct children of the 
service name in the HTTP tree).  
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SICF – Get Service Anonymous User Login Data Method Instance Properties

The SICF - Get Service Anonymous User Login Data method display-only page displays the properties 
used to retrieve the user login data from the specified service.

SICF – Update Service Anonymous User Method Instance Properties

The SICF - Update Service Anonymous User display-only page displays the properties used to update 
the anonymous logon user for a service defined in the Internet Connection Framework Tree (HTTP 
Service Tree) via SAP transaction SICF.

SLDCHECK – PI Check Method Instance Properties

The SLDCHECK - PI Check display-only page displays the properties used to run the SLDCheck 
transaction and report on the connection status for a system to the SAP System Landscape Directory. 

SLG1 – Read Application Log Method Instance Properties

The SLG1 - Read Application Log display-only page displays the properties used to retrieve a list of 
SAP application log messages.

SE61 – Display Document Method Instance Properties

The SE61 - Display Document display-only page displays the properties used to display the content of 
a document on the SAP system (for example, ZLOGIN_SCREEN_INFO).

Field Description

Application Object SAP application log object.

Application Sub Object SAP application log sub object

Date From (yyyyMMdd) Lowest date for searching the log table.

Date To (yyyyMMdd) Highest date for searching the log table.

Time To (hhmmss) Highest time for searching the log table.

Lowest Message Severity Lowest level severity to search for in the log table:

• 1 =  Critical only

• 4 = All message levels

Program Name Name of the program that generated the log message.

Transaction Code Transaction code that generated the log message.

User SAP user running the program that caused the log message.

Field Description

Document Language Language of the document to be modified or displayed (for example, 
EN=English, DE=German).
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SM01 – Lock Transaction Method Instance Properties

The SM01 - Lock Transaction display-only page displays the properties used to lock a specific SAP 
transaction to prevent users from unknowingly starting the transaction during a technical operation.

SM01 – Unlock Transaction Method Instance Properties

The SM01 - Unlock Transaction display-only page displays the properties used to unlock a specific SAP 
transaction that has been temporarily locked.

SM02 – Create System Message Method Instance Properties

The SM02 - Create System Message display-only page displays the properties used to create a 
system-wide message to alert SAP users of any system maintenance or any activity that may affect all 
users.

SM02 – Delete System Message Method Instance Properties

The SM02 - Delete System Message display-only page displays the properties used to manually delete 
a SAP system message.

Field Description

SAP Transaction Code SAP transaction code to be locked.

Field Description

SAP Transaction Code SAP transaction code to be unlocked.

Field Description

Message Line 1 System message text line 1. For example:

System will be shut down on Friday, 7:00 PM PST

Message Line 2 System message text line 2. For example:

Estimated restart is Monday, 8:00 AM EST

Message Line 3 System message text line 3. For example:

Please complete work and log off prior to the shutdown time 
otherwise unsaved data may be lost.

Expiration Date 
(yyyyMMdd)

Date the message expires.

Expiration Time (hhmmss) Time the message expires (optional).

Delete Date (yyyyMMdd) Date the message is to be deleted automatically from database 
(optional).

Delete Time (hhmmss) Time the message is to be deleted automatically from database 
(optional).

Client Specific client ID (optional).

Language Language of message (optional).
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SM04 – Logoff User Method Instance Properties

The SM04 - Logoff User method display-only page displays the properties used to log off a user who is 
currently logged onto an SAP application server.

SM12 – Age Enqueue Entries Method Instance Properties

The SM12 - Age Enqueue Entries method display-only page displays the properties used to retrieve all 
SAP document locks older than the specified time period.

• Lock age in minutes — Amount of time, in minutes, to display Enqueue entries (locks)

SM12 - Enqueue Size Method Instance Properties

The SM12 - Enqueue Size display-only page displays the number of Enqueue entries (locks) retrieved 
that exceed a defined maximum number.

• Maximum number of locks in the tables—Number of locks to use as a threshold to indicate that a 
problem may exist.

SM12 – Select Lock Entries Method Instance Properties

The SM12 - Select Lock Entries method display-only page displays the properties used to retrieve the 
lock entries.

Field Description

Message ID Unique message ID of the SAP system message to be deleted.

Field Description

User SAP user name

Client SAP client number

Only Pooled User Yes indicates the session pool is be to reset;  No indicates to 
log off the user.

TID Transaction ID

Field Description

Table name SAP table name

Lock argument Locked fields in a database table

Client SAP client number

User name SAP user name

Date (yyyyMMddHHmmss) Specified date from which data was retrieved. If this field is blank, 
data from the current date was retrieved.

Last X minutes prior to the 
specified date

Time period, in minutes, for selecting data based on the date
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SM13 – Check Update System Status Method Instance Properties

The SM13 - Check Update System Status display-only page displays the properties used to verify 
whether the update system is active or inactive.

SM13 – Delete Update Records Method Instance Properties

The SM13 - Delete Update Records display-only page displays the properties used to delete all update 
records currently found in the VBLOG (Update log) table.

SM13 – Get Update Queue Method Instance Properties

The SM13 - Get Update Queue display-only page displays the properties used to retrieve the entries in 
the SAP update queue, optionally filtering entries in queued or error status.

 SM14 – Activate and Deactivate Update System Method Instance Properties

The SM14 - Activate and Deactivate Update System display-only page displays the properties used to 
activate or deactivate update system.

SM35 – Session Overview Method Instance Properties

The SM37 - Session Overview method display-only page displays the properties used to retrieve the data 
associated with a session on the SAP server.

Field Description

Update Keys Unique keys of the update records to be deleted

Field Description

Client SAP client number.

User SAP user name.

Status Status by which to filter results (Canceled, To be updated, V1 
executed, V2 executed or All).

Date (yyyyMMddHHmmss) Specified end date for retrieving entries in the SAP update queue.

Last X minutes prior to the 
specified date

Time period for displaying update records.

Update server Name of the server for the SAP update queue.

Field Description

Client(s) Variable that represents the SAP client.

Sessions created in the last X 
minutes

Time period, in minutes, for selecting data based on the time the 
session was created
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SM36 – Create Background Job Method Instance Properties

The SM36 - Create Background Job display-only page displays the properties used to schedule a simple 
job without spool output. This method creates a background job in scheduled status.  It must be released 
in a subsequent step based on the Job ID return parameter provided.

SM36 – End Standard Jobs Method Instance Properties

The SM36 - End Standard Jobs display-only page displays the properties used to delete all currently 
scheduled or released standard jobs defined in SAP.  

SM36 – Job Scheduler Method Instance Properties

The SM36 - Job Scheduler method display-only page displays the properties used to schedule and release 
jobs in the SAP system.

Field Description

Job name Name of the SAP background job to be scheduled

ABAP Program Name Name of the SAP ABAP program

ABAP Variant Name Name of the SAP ABAP variant

SAP User Name Name of the user account to use to execute the program

Target Server SAP application server on which to execute the job

Field Description

Job Name Name of the SAP background job to be scheduled.

Start Type Indicates how to start the job.

Immediate Start Possible Indicates whether the job can be started immediately for a start time 
in the past.

Start Time (HHmmss) Time the scheduled job should start (00:00:00 – 23:59:59).

Periodic Indicates whether the job should be scheduled repeatedly. By 
default, this field is set to No.

Predecessor Job ID Job ID of the job to follow; the scheduled job will start after this job 
has completed.

Predecessor Job Name Name of the job to follow; the scheduled job will start after this job 
has completed.

Event ID Background job event ID that triggers the scheduled job.

Event Parameters Background job event parameters that trigger the scheduled job.

Operation Mode Name Operation mode name if you have selected Operation Mode as the 
Start Type (for example, enter Normal).

Periodic Minutes If the Periodic field is set to Yes, how often to reschedule the job in 
minutes (x minutes).

Periodic Hours If the Periodic field is set to Yes, how often to reschedule the job in 
hours (x hours).
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SM36 – Schedule Standard Jobs Method Instance Properties

The SM36 - Schedule Standard Jobs display-only page displays the properties used to schedule all 
currently standard jobs in SAP.  

SM37 - Cancel a Background Job Method Instance Properties

The SM37 - Cancel a Background Job read only page displays the properties used to retrieve all 
background jobs that have been canceled because they were running too long or were consuming too 
many resources.

SM37 – Complex Job Selection Method Instance Properties

The SM37 - Complex Job Selection method display-only page displays the properties used to list all SAP 
jobs for a defined time period that match the defined criteria.

Periodic Days If the Periodic field is set to Yes, how often to reschedule the job in 
days (x days).

Periodic Weeks If the Periodic field is set to Yes, how often to reschedule the job in 
weeks (x weeks).

Periodic Months If the Periodic field is set to Yes, how often to reschedule the job in 
months (x months).

Target Host Target system on which to run background job.

Target Server Group Server group name for background processing.

Job Steps Array of the ABAP or external programs to be executed.

Field Description

Field Description

Job Name (wildcard) Name of the job. Leave blank for wildcard search or enter partial 
search with wildcard (for example, MYJOB*).

User Name (wildcard) SAP user that scheduled the SAP job.

Date (yyyMMddHHmmss) Status date for the job.

Last X minutes prior to the 
specified date

Time period, in minutes, for selecting jobs based on the date.

After Event (wildcard) Specify the job scheduling event to scheduled job so that it can only 
be released via a SAP Background Processing Event.  The job will 
not execute until this event has been triggered by the SAP runtime 
system. Job scheduling events are configured in SAP Background 
Processing configuration, accessed via SAP Transaction SM62.

Program Name Program name in a job step.

Variant (wildcard) Variant of a program name in a job step.

Target Server Target server specified for the job.
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SM37 – Delete Background Job Method Instance Properties

The SM37 - Delete Background Job display-only page displays the properties used to delete scheduled 
SAP background jobs.

SM37 – Get Active Job Duration Method Instance Properties

The SM37 - Get Active Job Duration method display-only page displays the properties used to retrieve 
the jobs specified in the input table that are currently running along with their current duration.

SM37 – Get Job Instance Information Method Properties

The SM37 - Get Job Instance Information page displays all retrieved data associated with a specific 
instance of an SAP job execution.

SM37 – Jobs Waiting Method Instance Properties

The SM37 - Jobs Waiting method display-only page displays the properties used to generate all SAP jobs 
currently waiting for execution for a specified date.

Duration For jobs that have completed, the amount of time job took between 
start and end. For example, set to 1000 for any jobs that executed for 
longer than 100 seconds.

Delay For jobs that have started, the minimum amount of time job was on 
hold between its scheduled start time and the time that it was able to 
start. For example, set to 100 to select any jobs that were delayed by 
100 seconds or more.

Field Description

Field Description

Job name Name of the SAP background job to be deleted

Job ID ID assigned to the SAP background job

Field Description

Job name Name of the table variable that contains a list of the SAP jobs to 
be retrieved. The table must contain a column named "Job 
Name" with the jobs listed in that column.

Field Description

Job name (wildcard) Name of the SAP job to filter

User name (wildcard) Name of the SAP user that executed the job to filter

Start date (wildcard or 
yyyymmdd)

Date the SAP job is scheduled to execute
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SM37 – Resume Jobs Method Instance Properties

The SM37 - Resume Jobs display-only page displays the properties used to restart jobs that were 
temporarily suspended.

SM37 – Simple Job Selection Method Instance Properties

The SM37 - Simple Job Selection display-only page displays the properties used to retrieve all SAP jobs 
for a defined time period that match the defined criteria.

 SM37 – Start or Restart a Background Job Method Instance Properties

The SM37 - Start or Restart a Background Job method display-only page displays the properties used to 
start or restart a released or scheduled job.

SM37 – Suspend Jobs Method Instance Properties

The SM37 - Suspend Jobs display-only page displays the properties used to temporarily suspend jobs.

Field Description

Method name Custom method to be used for execution

Time out if not completed 
within

Specified time out interval within which the RFC call must 
complete. If the RFC call does not complete within the specified 
time out interval, the activity will fail with Failed (Not Completed) 
status.

Method Parameters

Displays the parameters for the selected method. Complete the appropriate fields, as necessary.

Field Description

Job name (wildcard) Name of the SAP job.

User name (wildcard) SAP user that created the SAP job.

Date (yyyMMddHHmmss) Status date for the job

Last X minutes prior to the 
specified date

Time period, in minutes, for selecting jobs based on the date.

After event (wildcard) The job scheduling event that is specified to scheduled job so that 
it is released via a SAP Background Processing Event.

Field Description

Job name Name of the SAP job

Job ID Job ID assigned by SAP to this instance of job execution

Target server Target server for the job
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SM50 – Analyze Long Running Processes Instance Properties

The SM50 - Analyze Long Running Processes method display-only page displays the properties used to 
retrieve the long running processes on the specified SAP application server.

SM50 – Work Process Overview Method Instance Properties

The SM50 - Work Process Overview ready-only page displays the properties used to retrieve the current 
state of the SAP work processes on the selected application server.

SM51 – Dispatcher Queue Method Instance Properties

The SM51 Table - Dispatcher Queue method display-only page displays the properties used to retrieve 
statistics related to dispatching requests to SAP work processes.

SM51 - Server List Method Instance Properties

The SM51 - Server List display-only page displays the current status of the application servers on an 
SAP system.

SM58 – Delete All tRFC Messages Method Instance Properties

The SM58 - Delete All tRFC Messages display-only page displays the properties used to delete all 
transactional RFC messages in queue.

SM58 – Execute LUW Method Instance Properties

The SM58 - Execute LUW method display-only page displays the properties used to execute a Logical 
Unit of Work.

Field Description

Execution time in seconds Amount of time, measured in seconds, to determine whether a work 
process was running long

Work process type Type of work process that was analyzed.

Server name SAP application server on which to analyze work processes (server 
name should be in the format host_sysid_sysnum). The wildcard (*) 
indicates that all application servers were analyzed.

Field Description

Server name SAP application server to take the work process snapshot (server 
name should be in the format host_sysid_sysnum)

CPU time  CPU time that the work processes are using
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SM59 – Delete RFC ABAP Connection Method Instance Properties

The SM59 - Delete RFC ABAP Connection display-only page displays the properties used to delete an 
ABAP destination.

SM59 – Delete RFC HTTP Connection to ABAP System Method Instance Properties

The SM59 - Delete RFC HTTP Connection to ABAP System display-only page displays the properties 
used to delete an HTTP connection to an ABAP system.

SM59 – Delete RFC HTTP Connection to External Server Method Instance Properties

The SM59 - Delete RFC HTTP Connection to External Server display-only page displays the properties 
used to delete an HTTP connection to an external server.

SM59 – Delete RFC TCP/IP Connection Method Instance Properties

The SM59 - Delete RFC TCP/IP Connection display-only page displays the properties used to delete a 
TCP/IP connection.

Field Description

Transaction ID tRFC unique transaction ID

Forced Restart regardless of whether the queues were stopped before by a 
queue stop function module (parameter FORCE) or by statuses 
CPICERR or SYSSFAIL

QOut Scheduler Activated If the destination is registered as a qRFC Outbound destination, 
activate the qRFC Outbound Scheduler.

Field Description

Destination Name of the ABAP destination to be deleted

Field Description

Destination Name of the HTTP connection to be deleted

Field Description

Destination Name of the HTTP connection to be deleted

Field Description

Destination Name of the TCP/IP connection to be deleted
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 SM59 – Get RFC Connection Info Method Instance Properties

The SM59 - Get RFC Connection Info display-only page displays the properties used to retrieve 
information about a specific RFC destination.

SM59 – HTTP Connection Test Method Instance Properties

The SM59 - RFC Connection Test method display-only page is used to display the HTTP destinations 
on a specified SAP application server.

SM59 - List ABAP Connections Method Instance Properties

The SM59 - List ABAP Connections display-only page displays a list of retrieved ABAP RFC 
destinations.

SM59 – List HTTP Connections to ABAP System Method Instance Properties

The SM59 - List HTTP Connections to ABAP System display-only page displays the properties used to 
retrieve a list of HTTP connections to the ABAP system.

SM59 – List HTTP Connections to External Server Method Instance Properties

The SM59 - List HTTP Connections to External Server display-only page displays the properties used 
to retrieve a list of HTTP connections to external servers.

SM59 – List TCP/IP Connections Method Instance Properties

The SM59 - List TCP/IP Connections display-only page displays the properties used to retrieve a list of 
all TCP/IP destinations.

SM59 – Modify RFC ABAP Connection Method Instance Properties

The SM59 - Modify RFC ABAP Connection display-only page displays the properties used to update an 
ABAP destination.

Field Description

Destination Name of the RFC destination for which to retrieve data

Field Description

HTTP server 
(ServerHost_SID_SysNo)

Name of the server where the destination checks are executed

HTTP destination Global variable containing a list of destinations to be monitored

Host Server for the HTTP connection to be tested

Service Port number that the SAP system uses to connect to the destination

Path Path prefix in SAP for the destination

Pattern Pattern in SAP for the destination
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SM59 – Modify RFC HTTP Connection to ABAP System Method Instance Properties

The SM59 - Modify RFC HTTP Connection to ABAP System display-only page displays the properties 
used to update an HTTP connection to an ABAP system.

SM59 – Modify RFC HTTP Connection to External Server Method Instance Properties

The SM59 - Modify RFC HTTP Connection to External Server display-only page displays the properties 
used to update an HTTP connection to an external server.

Field Description

Destination Name of the ABAP destination to be updated

Client New logon client number

Description Description of the new ABAP destination

Group Name of the new logon group for the ABAP destination

Gateway Host Name of the new gateway host for the ABAP destination

Gateway Service Name of the new gateway service for the ABAP destination

Language New logon language

User New logon user

Password New logon password

Server New target host of the ABAP destination

System ID New SAP system ID

System Number New SAP system number

Field Description

Destination Name of the HTTP connection to ABAP system that needs to be 
updated

Description Description of the new HTTP connection

Client Logon client for new HTTP connection

Language Language for new HTTP connection

Path Prefix New HTTP service path prefix

Server New target host of HTTP connection

Service Number New HTTP service port

User New logon user

Password New logon password

Proxy Host New proxy host

Proxy Service New proxy service

Proxy User New proxy user

Proxy Password New proxy password
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SM59 – Modify RFC TCP/IP Connection Method Instance Properties

The SM59 - Modify RFC TCP/IP Connection display-only page displays the properties used to update 
a TCP/IP connection.

SM59 – RFC Connection Test Method Instance Properties

The SM59 - RFC Connection Test method display-only page is used to display RFC destinations on a 
specified application server.

Field Description

Destination Name of the HTTP connection that needs to be updated

Description Description of the new HTTP connection

Server New target host of HTTP connection

Service Number New HTTP service port

Path Prefix New HTTP service path prefix

User New logon user

Password New logon password

Proxy Host New proxy host

Proxy Service New proxy service

Proxy User New proxy user

Proxy Password New proxy password

Field Description

Destination Name of the TCP/IP destination to be updated

Description Description of the new TCP/IP destination

Gateway Host Name of the gateway host for the new TCP/IP destination

Gateway Service Name of the gateway service for the new TCP/IP destination

Program New program ID to execute TCP/IP communication method

Server New target host of TCP/IP destination

RFC Unicode Indicates whether the target system for the RFC connection is a 
Unicode or Non-Unicode based system.

Field Description

RFC server 
(ServerHost_SID_SysNo)

SAP application server from which the RFC destinations 
were tested

RFC destination(s) Table variable with a "Destination" column that contains the 
list of RFC destinations to be tested.

Note This field is case-sensitive
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SM61 – Assign Server Method Instance Properties

The SM61 - Assign Server display-only page displays the properties used to add a target system server.

SM61 – Get Server List Method Instance Properties

The SM61 - Get Server List display-only page displays the properties used to retrieve a list of source 
system background servers that are included in a specific server group.

SM61 – List Active Background Servers Method Instance Properties

The SM61 - List Active Background Servers display-only page displays the properties used to retrieve 
a list of all active servers that are running background work processes.

SM66 – Global Work Process Activity Detail Method Instance Properties

The SM66 - Global Work Process Activity Detail method display-only page displays the properties used 
to take a snapshot of the current activity in the available work processes on all servers of a single SAP 
ABAP system.

SM66 – Global Work Process Overview Method Instance Properties

The SM66 - Global Work Process Overview display-only page displays the properties used to retrieve 
the SAP work processes that are currently processing user requests across all SAP application servers.

SMGW – Gateway Monitor Method Instance Properties

The SMGW - Gateway Monitor page displays the current status of SAP gateway communications.

SMICM – ICM Monitor Method Instance Properties

The SMICM - ICM Monitor method display-only page displays the properties used to retrieve the current 
status of  the SAP Internet Communication Manager, which sends and receives requests to and from the 
Internet.

Repetition factor Number of times the test was executed

Number of blocks sent Number of data blocks sent during the test

Field Description

Field

Application Server Name of the application server to be added

Server Group Name of the group to which the server belongs

Field Description

Server Group Name of the group that includes the source system background 
servers
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SMLG – Change Assignment Method Instance Properties

The SMLG - Change Assignment display-only page displays the properties used change a specific server 
to a specific logon group.

SMLG – Create Assignment Method Instance Properties

The SMLG - Change Assignment display-only page displays the properties used to create a specific 
logon group assignment.

SMLG – Delete All Assignments Method Instance Properties

The SMLG - Delete Assignments display-only page displays the properties used to delete all logon group 
assignments.

SMLG – Delete Assignment Method Instance Properties

The SMLG - Delete Assignment display-only page displays the properties used to delete a specific logon 
group assignment.

Field Description

Logon Group Name Name of the SAP logon group

Instance Name Name of the SAP instance

IP Address IP address of the SAP instance

Option Mode Miscellaneous text for login/server group

Max Number of WPs Maximum number of work processes that can be used

Set Lock Indicates whether the record should be locked.

Field Description

Logon Group Name Name of the SAP logon group

Instance Name Name of the SAP instance

IP Address IP address of the SAP instance

Number of Users Number of logged-in users

Option Mode Miscellaneous text for logon/server group (optional)

Max Number of WPs Maximum number of work processes that can be used

Set Lock Indicates whether the record should be locked.

Field Description

Logon Group Name Name of the SAP logon group from which to delete the 
server

Instance Name Name of the SAP application server to be deleted from the 
logon group
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SMLG – Delete Assignments Method Instance Properties

The SMLG - Delete Assignments display-only page displays the properties used to delete one or more 
logon group assignments.

SMLG – Get Assignments-Setup Method Instance Properties

The SMLG - Get Assignments display-only page displays the properties used to retrieve a list of logon 
group assignments currently configured. When you run this method, a list of assigned servers is returned.

SMLG – Get Assignments-eRFC Setup Method Instance Properties

The SMLG - Get Assignments-eRFC Setup display-only page displays the properties used to retrieve a 
list of logon group assignments currently configured. When you run this method, a list of assigned 
servers is returned.

SMLG – Set Lock Method Instance Properties

The SMLG - Set Lock page displays the properties used to set an enqueue lock on the server group table.

 SMQ1 – Activate qRFC Outbound Queue Method Instance Properties

The SMQ1 - qRFC Monitor Outbound Queue method display-only page displays the properties used to 
retrieve the list of stopped outbound queues to be activated.

This function is necessary only if the queue is blocked due to a communication, network error, or if a 
system or application exception has occurred and the problem has been solved.

SMQ1 – Delete qRFC Outbound Queue Method Instance Properties

The SMQ1 - Delete qRFC Outbound Queue display-only page displays the properties used to delete a 
specific qRFC outbound queue.

Field Description

Modifications Variable that contains the modifications table

ERFC Modifications Variable that contains the eRFC modifications table

Field Description

Queue Name Name of the RFC queue

Destination RFC destination specified in the function call

Resend the luw forcibly Determines whether to force the luw to resend

Field Description

Queue Name Name of the qRFC outbound queue to be deleted

Destination Name of the system where the current client resides
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SMQ1 – Delete All qRFC Outbound Queues Method Properties

The SMQ1 - Delete All qRFC Outbound Queues page displays all deleted qRFC outbound queues.

SMQ1 – Lock qRFC Outbound Queue Method Instance Properties

The SMQ1 - Lock qRFC Outbound Queue method display-only page displays the properties used to 
retrieve with the Lock status.

SMQ1 – Unlock qRFC Outbound Queue Method Instance Properties

The SMQ1 -Unlock qRFC Outbound Queue method display-only page displays the properties used to 
retrieve the outbound queues with the Unlock status.

SMQ2 – Activate qRFC Inbound Queue Method Instance Properties

The SMQ2 -Activate qRFC Inbound Queue method display-only page displays the properties used to 
retrieve the list of stopped inbound queues to be activated.

SMQ2 – Delete All qRFC Inbound Queues Method Instance Properties

The SMQ1 - Delete All qRFC Inbound Queues display-only page displays the properties used to delete 
all qRFC inbound queues.

SMQ2 – Delete qRFC Inbound Queue Method Instance Properties

The SMQ2 - Delete qRFC Inbound Queue method display-only page displays the properties used to 
delete a specific qRFC inbound queue.

Field Description

Queue Name Name of the tRFC queue

Destination RFC destination specified in the function call

Stop immediately Retrieve the queues that were immediately stopped

No commit Retrieve the queues that were not committed

Field Description

Queue Name Name of the tRFC queue

Queue destination RFC destination specified in the function call

Activate immediately Retrieves the queues that are to be activated immediately

Only unlock Retrieves the queues that are to be unlocked, but not activated

No commit Retrieve the queues that were not committed

Lock key Lock key returned from the TRFC_QOUT_STOP RFC

Till lock key Lock acquired till end of transaction
13-130
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 13      Using SAP Adapters
  SAP RFC Adapter
SMQ2 – Lock qRFC Inbound Queue Method Instance Properties

The SMQ2 - Lock qRFC Outbound Queue method display-only page displays the properties used to 
retrieve the inbound queues with the Lock status.

SMQ2 – Unlock qRFC Inbound Queue Method Instance Properties

The SMQ2 - Unlock qRFC Inbound Queue method display-only page displays the properties used to 
retrieve the inbound queues with the Unlock status.

SMQ3 – qRFC Monitor Saved Inbound Queue Method Instance Properties

The SMQ3- qRFC Monitor Saved Inbound Queue page displays a list of inbound qRFC (with saved 
queues) calls in Error state.

Field Description

Queue Name Name of the tRFC queue

Destination RFC destination specified in the function call

Stop immediately Retrieves the queues that were immediately stopped

No commit Retrieves the queues that were not committed

Field Description

Queue Name Name of the tRFC queue

Activate immediately Determines whether to retrieve queues that are to be 
activated immediately

Activate all LUWs Activates all LUWs in the inbound queue

Mode Processes all qRFC LUWs in a queue in the context of the 
caller

Only unlock Determines whether to retrieve queues that are to be 
unlocked, but not activated

Max time Activates the queue within a specified time. If the time runs 
out while the last LUW is being processed, this call is 
returned after the last LUW is processed.

User destination Retrieves all qRFC LUWs in a queue under the user who is 
currently logged on

No commit Determines whether to retrieve the queues that were not 
committed

Lock key Lock key returned from the TRFC_QOUT_STOP RFC

Till lock key Lock acquired till end of transaction
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SMQR – Reorganize qRFC Inbound Monitor Method Instance Properties

The SMQR - Reorganize qRFC Inbound Monitor display-only page displays the properties used to 
reorganize the qRFC inbound monitor. It first deletes all entries in the monitor and then changes the SAP 
logon group.

SMQR – Register Inbound Queue Method Instance Properties

The SMQR - Register Inbound Queue display-only page displays the properties used to register an 
inbound queue.

SMQR – Unregister Inbound Queue Method Instance Properties

The SMQR - Unregister Inbound Queue display-only page displays the properties used to unregister an 
inbound queue.

SMQS – Reorganize qRFC Outbound Monitor Method Instance Properties

The SMQS - Reorganize qRFC Outbound Monitor display-only page displays the properties used to 
reorganize the qRFC outbound monitor. It first deletes all entries in the monitor and then changes the 
SAP logon group.

SMQS – Unregister Destination Method Instance Properties

The SMQS - Unregister Destination display-only page displays the properties used to unregister an 
outbound destination (QOUT Scheduler). This function is used to manage outbound queues.

Field Description

Client SAP client to which the queue is assigned.

Queue name Name of the RFC queue. Use an asterisk (*) for all queues or a 
specific queue name. Wildcards are not supported.

Field Description

Max Time Maximum runtime (timeout) in seconds; default value is 60 
seconds.

User Destination Local RFC destination with logon details.

Activate Indicates whether to activate the queue immediately.

Number of Retry Attempts Number of retry attempts; default value is 30.

Delay Interval Delay between retry attempts in seconds; default value is 300 
seconds.

Monitoring Interval Monitoring interval time by scheduler in seconds.
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SMQS – qRFC Monitor QOUT Scheduler Method Instance Properties

The SMQS - qRFC Monitor (QOUT Scheduler) method display-only page displays the properties used 
retrieve the management properties of the qRFC outbound scheduler, including scheduler status and 
outbound queues processed.

SMQS – qRFC Monitor (QOUT Scheduler) Method Instance Properties

The SMQS - qRFC Monitor (QOUT Scheduler) method display-only page displays the properties used 
retrieve the management properties of the qRFC outbound scheduler, including scheduler status and 
outbound queues processed.

SMQS – Register Destination Method Instance Properties

The SMQS - Register Destination display-only page displays the properties used to register an outbound 
destination (QOUT Scheduler). This function is used to manage outbound queues.

SMT1 – Add Trusted System Method Instance Properties

The SMT1 - Add Trusted System display-only page displays the properties used to add a trusted system 
and its details.

SMT1 – Get Trusted Systems Method Instance Properties

The SMT1 - Get Trusted Systems display-only page displays the properties used to retrieve a list of all 
or specific permitted trusted systems that are stored in SAP database table RFCSYSACL

Field Description

Max Connections Maximum number of connections; default value is 1.

Max Runtime Maximum runtime (timeout) in seconds; default value is 60 
seconds.

QRFC Only Indicates whether to pass tRFCs (transactional RFCs) to the 
destination.

Activate Indicates whether to automation activate the destination.

Monitoring Interval Monitoring interval for scheduler; default value is 0.

Field Description

RFC Destination RFC destination created to connect to the system that will be 
trusted.

Security Key Security key/logon ticket for target system.

Field Description

Trusted System ID System ID (SID) for the system to retrieve; blank or * indicates to 
retrieve all trusted systems.
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SMT1 – Modify Trusted System Method Instance Properties

The SMT1 - Add Trusted System display-only page displays the properties used to update a trusted 
system in the SAP database table RFCSYSACL.

SMT1 – Remove Trusted System Method Instance Properties

The SMT1 - Remove Trusted System display-only page displays the properties used to remove a trusted 
system in the SAP database table RFCSYSACL.

SMT2 – Add Trusting System Method Instance Properties

The SMT2 - Add Trusting System display-only page displays the properties used to set the trusting 
system ID, system name, and RFC destination.

SMT2 – Get Trusting Systems Method Instance Properties

The SMT2 - Get Trusting Systems display-only page displays the properties used to retrieve a list of all 
or specific trusting systems that are stored in SAP database table RFCTRUST.

SMT2 – Modify Trusting System Method Instance Properties

The SMT2 - Modify Trusting System display-only page displays the properties used to update a trusting 
system in the SAP database table RFCTRUST.

Field Description

Enable Login Popup Indicates whether to use login popup for password.

Enable RFC User Check Indicates whether to validate RFC user.

Security Key Security key/logon ticket for target system.

Field Description

RFC Destination Prefix Prefix to append to the RFC destination (TRUSTING_SYSTEM@).

Field Description

Trusting System ID System ID (SID) for the system to retrieve; blank or * indicates to 
retrieve all trusting systems.

Field Description

RFC Destination Prefix Prefix to append to the RFC destination (TRUSTING_SYSTEM@).
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SMT2 – Remove Trusting System Method Instance Properties

The SMT2 - Remove Trusting System display-only page displays the properties used to remove a 
trusting system in the SAP database table RFCTRUST.

SOA Manager – Read J2EE Admin Server Data Method Instance Properties

The SOA Manager - Read J2EE Admin Server Data method display-only page displays the properties 
used to retrieve the configuration data on the J2EE administration server.

SOA Manager – Set J2EE Admin Server Method Instance Properties

The SOA Manager - Set J2EE Admin Server display-only page displays the properties used to set the 
J2EE administration server configuration details used by the SAP ABAP environment.

SOST – Delete Mail Method Instance Properties

The SOST - Delete Mail display-only page displays the properties used to delete emails from a specific 
date, regardless of their status.

SOST – Repeat Send Method Instance Properties

The SOST - Repeat Send display-only page displays the properties used to resend any unsuccessfully 
sent SAP Office transmission requests to the request queue.

Field Description

Trusting System ID System ID (SID) for the trusting system.

Field Description

Protocol Indicates the type of protocol to be set.

Host Name Full host name to be set. If the host name is to remain unchanged, 
this field is blank.

Port Number J2EE engine port number to be set. If the port number is to remain 
unchanged, this field is blank.  

Access Path Access path to J2EE service, if applicable. If the access path is to 
remain unchanged, this field is blank.

J2EE User J2EE user name to be set. If the user name is to remain unchanged, 
this field is blank.

J2EE Password J2EE password for the user account. If the password is to remain 
unchanged, this field is blank.

Field Description

From the Last X Days Indicates the date from which to delete emails (number of days 
before the current date).

Job Name Name of the job in the queue.
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SP12 – TemSe Data Consistency Check – Delete All Method Instance Properties

The SP12 - TemSe Data Consistency Check - Delete All display-only page displays the properties used 
to check the consistency of the Temporary Sequential Objects (TemSe) and to delete inconsistent TemSe 
data files.

SPAD – Assign Server Method Instance Properties

The SPAD - Assign Server display-only page displays the properties used to reassign output devices to 
a new spool server.

SPAD – Check Consistency Delete All Method Instance Properties

The SPAD - Check Consistency Delete All display-only page displays the properties used to purge job 
spool files and other temporary files that are stored in TEMSE content.

SPAD – Create Output Device Method Instance Properties

The SPAD - Create Output display-only page displays the properties used to create a new spool device 
(printer) or modify and existing spool device (printer).

Field Description

Date (yyyyMMdd) Start date of the date range for selecting requests (optional). When 
this field is set to blank, the start date is set to the previous day.

From the Last X Days A value to indicate the date from which to resend SAP Office 
transmission requests (number of days before the current date). If 
this field is set to 0, the date is set to the current day.

Sender List A list of SAP logon user IDs to be used as request senders for 
selecting requests (optional). If this field is blank, all senders will 
be selected.

Field Description

Output Device Name of the output device(s) to reassign

Old Spool Server Source system for the old spool server

New Spool Server Source system for the new spool server

Field Description

Job Name Name of the schedule job (released immediately).

Delete Indicates the objects to be deleted (All Objects or Only Obsolete Objects).

Days Old Number of days old for TEMSE document to be considered for deletion.
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SPAD – Delete Output Device Method Instance Properties

The SPAD - Delete Output Device display-only page displays the properties used to delete a spool device 
found via SP01. This method can be used when production printers must be deleted instead of 
reassigning to a different printer server.

SPAD – Display Output Devices Method Instance Properties

The SPAD - Display Output Devices display-only page displays the properties used to retrieve a list of 
output devices listed in transaction code SPAD.

SPAD – Export Command Set Method Instance Properties

The SPAD - Export Command Set display-only page displays the properties used to create an SAP 
transport that contains the command sets that are defined for printers.

SPAD – Export Device Method Instance Properties

The SPAD - Export Device display-only page displays the properties used to export the device.

Field Description

Output Device Name Name of the output device(s) to be created or modified.

Output Device Short Name ID of the spool device used by the system to access it.

Output Device Type Type of output device(s) to be created or modified.

Spool Server Name Name of the SAP spool server.

Access Method Method used to connect to the spool device.

Host Printer Name of the printer as specified in the operating system.

Output Management System Name of an external output management system.

Destination Host Name of the remote host on which SAP LPD is running.

Field Description

Output Device Name Name of the output device(s) to deleted.

Field Description

Release Indicates whether to automatically release the transport to the 
transport directory.

Field Description

File Name Name of the back up file
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SPAD – Get Device Descriptions Method Instance Properties

The SPAD - Get Device Descriptions display-only page displays the properties used to retrieve 
descriptions for a list of devices.

SPAD – Import Device Method Instance Properties

The SPAD - Import Device display-only page displays the properties used to import the device.

SP01 – Spool Requests Method Instance Properties

The SP01 - Spool Requests display-only page displays the printed pages sent to the SAP spool system.

ST02 – Get Memory Usage Method Instance Properties

The ST02 - Get Memory Usage method display-only page displays the properties used to generate details 
about SAP memory management.

ST03 – Get Hourly Snapshot Data for WebAS 7.0 Method Instance Properties

The ST03 - Get Hourly Snapshot Data for WebAS 7.0 page displays the workload statistics for a selected 
SAP application server.

• Server (ServerHost_SID_SysNo) — SAP application server (ServerHost_SID_SysNo).

ST04 – Get DB6 Log Space Method Instance Properties

The ST04 - Get DB6 Log Space display-only page displays the properties used to retrieve DB2 log space 
usage data.

Field Description

Device List List of devices for which to retrieve descriptions.

Field Description

File Name Name of the file to be used to import the devices.

Field Description

Method name Custom method used for execution

Time out if not completed within Time out interval (seconds, minutes) with which the RFC call must 
complete. If the RFC call does not complete within the specified 
time out interval, the activity will fail with Failed (Not Completed) 
status.

Maximum number of rows to 
include in output table

Maximum number of rows to be displayed in the results table

No parameters are required for this RFC method.
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STAD – Workload Statistical Records Method Instance Properties

The STAD - Workload Statistical Records method display-only page displays the properties workload 
used to retrieve details for SAP transactions matching selected criteria.

STATTRACE—Global Statistics Method Instance Properties

The STATTRACE—Global Statics display-only page displays the properties used to retrieve raw 
statistical data from the SAP Java stack. The raw statistics data originates from Distributed Statistics 
Records (DSRs).

Field Description

Read time (hhmmss) Amount of time to retrieve records beginning with values entered in 
the Start date and Start time fields

User (wildcard) SAP user for which to retrieve records that were executed. The 
wildcard [*] can be used to retrieve records executed by all SAP 
users.

Transaction (wildcard) SAP transaction code for which to retrieve records (for example, 
VA01).  The wildcard [*] can be used to retrieve records for all 
transaction codes

Program (wildcard) SAP program for which to retrieve records. The wildcard [*] can be 
used to retrieve records for all SAP programs.

Task type (wildcard) Work process type for which records are retrieved (for example, 
Dialog). The wildcard [*] can be used to retrieve records for all task 
types.

Server name (wildcard) SAP application server on which records were executed. The 
wildcard [*] can be used to retrieve records executed on all SAP 
application servers.

Response time threshold (>=ms) Threshold value for retrieving records whose response time exceeds 
the defined threshold

DB request time threshold 
(>=ms)

Threshold value for retrieving records whose database request time 
exceeds the defined threshold

CPU time threshold (>=ms) Threshold value for retrieving records whose CPU time exceeds the 
defined threshold

Bytes requested threshold Threshold value for retrieving records whose bytes requested 
exceeds the defined threshold

Start date Start date to begin retrieving records (used in conjunction with Start 
time and Read time)

Start time Start time to begin retrieving records (used in conjunction with 
Start date and Read time)
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STMS – Activate System Method Instance Properties

The STMS - Activate System display-only page displays the properties used to approve (activate) a 
system that has been added or changed in the domain controller and redistribute the changes to the 
transport domain.

STMS – Add Transport Request to Import Queue Method Instance Properties

The STMS - Add Transport Request to Import Queue display-only page displays the properties used to 
add a specific transport request to the TMS import queue. This method will verify that the transport has 
been added to the queue; if it hasn't been added, it will add the request to the queue.

STMS – Configure Transport Domain Controller Method Instance Properties

The STMS - Configure Transport Domain Controller display-only page displays the properties used to 
set up the domain controller system in the Transport Management System (TMS) domain landscape.  

Field Description

Date 
(yyyyMMddHHmmss)

Local date time on the SAP server.

Last X minutes prior to the 
specified date

Number of minutes prior to the date time specified in the Date field 
for which to retrieve data.

System (wildcard) SAP system ID; or a wildcard to retrieve data from all SAP systems.

User (wildcard) SAP user name of the user who is logged onto a component; or a 
wildcard to retrieve data from all users logged onto a component.

Action (wildcard) SAP action name; or a wildcard to retrieve all executed 
transactions.

Transaction ID (wildcard) SAP transaction ID; or a wildcard to retrieve all transaction IDs.

Field Description

System ID SAP system ID for the SAP system that was added or changed.

Domain Name of the STMS domain where the SAP system resides.

Field Description

Transport Request Transport request ID.

Import Again Indicates whether to re-import a transport request if it is already 
imported in the import queue.

Field Description

Domain Name Transport domain name to be configured.

Domain Description Text description of domain to be configured.
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 STMS – Delete System from Domain Method Instance Properties

The STMS - Delete System from Domain display-only page displays the properties used to delete the 
system from the transport domain (if the system target is a TMS domain controller) so that the 
configuration activity can function correctly. This method must be run before running the domain setup 
custom method (STMS - Configure Domain Controller).

STMS – Distribute Configuration Method Instance Properties

The STMS - Distribute Configuration display-only page displays the properties used to distribute a TMS 
configuration.

STMS – Get TMS Configuration Method Instance Properties

The STMS - Get TMS Configuration display-only page displays the properties used to determine the 
system's landscape configuration. This method will return information about the Transport Management 
System (TMS) configuration, including whether the system is the domain controller or a landscape client 
system.

STMS – Import Transport Request Method Instance Properties

The STMS - Import Transport Request display-only page displays the properties used to start the import 
of a specific transport request to the TMS import queue.

STMS – Transport Routes Configuration Adjust with Controller Method Instance Properties

The STMS - Transport Routes Configuration Adjust with Controller display-only page displays the 
properties used to copy the transport routes from the specified domain controller.

Domain Controller Host Target system host where domain is being configured.

Domain Controller System 
Number

Target system instance system number.

Domain Controller System 
Description

Description of target system instance hosting domain controller.

Transport Group Name Name of the target system TMS transport group.

Transport Group Text Description of the target system TMS transport group.

TMS User Target system TMS user name that is used by TMS.

TMS Password Target system TMS password that is used by TMS.

Field Description

Field Description

System Name Name of the SAP target system (system copy target).

Force Indicates whether the complete TMS configuration will be deleted.

Inactive Indicates whether the distribution of the changed configuration to 
all clients will be suppressed.

No access Indicates whether the system will be deleted without sending the 
delete request to the client.
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STRUST – Export Own PSE Certificate Method Instance Properties

The STRUST - Export Own PSE Certificate display-only page displays the properties used to export an 
own certificate in the Personal Security Environment (PSE) to a binary file on the SAP application server 
file system directory.

STRUST – Export System PSE Certificate Method Instance Properties

The STRUST - Export System PSE Certificate display-only page displays the properties used to export 
a system certificate in the Personal Security Environment (PSE).

STRUST – Get Own PSE Certificate Details Method Instance Properties

The STRUST - Get Own PSE Certificate Details display-only page displays the properties used to 
retrieve the certificate details for the current Personal Security Environment (PSE) for an SAP ABAP 
system.

STRUST – Get PSE ACL List Method Instance Properties

The STRUST - Get Own PSE Certificate Details display-only page displays the properties used to 
retrieve the certificate details of the current Personal Security Environment (PSE) for an SAP ABAP 
system.

STRUST – Get PSE Certificate List Method Instance Properties

The STRUST - Get PSE Certificate List display-only page displays the properties used to retrieve a list 
of assigned certificates for the current Personal Security Environment (PSE) for an SAP ABAP system.

STRUST – Get System PSE Details Method Instance Properties

The STRUST - Get System PSE Details display-only page displays the properties used to retrieve system 
details for the current Personal Security Environment (PSE) for an SAP ABAP system.

Field Description

Controller System Name Name of the SAP system where the domain controller resides

Field Description

File Name File name (<name>.crt) of the certificate file to be exported. The 
file is automatically exported to DIR_TEMP only (path can be 
found using transaction AL11), per SAP requirements.

Field Description

File Name File name of the certificate file to be exported.

File Path Location of the certificate file to be exported.  
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STRUST – Import Own PSE Certificate Method Instance Properties

The STRUST - Import Own PSE Certificate display-only page displays the properties used to import an 
own certificate in the Personal Security Environment (PSE).

STRUST – Import System PSE Certificate Method Instance Properties

The STRUST - Import System PSE Certificate display-only page displays the properties used to import 
a certificate in the system Personal Security Environment (PSE).

STRUST – Remove Own PSE Certificate Method Instance Properties

The STRUST - Remove Own PSE Certificate display-only page displays the properties used to delete 
own certificate from certificate list of system Personal Security Environment (PSE).

STRUST – Remove System PSE Certificate Method Instance Properties

The STRUST - Remove System PSE Certificate display-only page displays the properties used to delete 
a system certificate in the Personal Security Environment (PSE).

STRUST – Set Own PSE Method Instance Properties

The STRUST - Set Own PSE display-only page displays the properties used to reset the Personal 
Security Environment (PSE) for an SAP ABAP system. This method rebuilds the system PSE file in the 
secure directory, and removes any certificates and access control lists that may have been copied from 
the production environment.

STRUSTSSO2 – Add System ACL Method Instance Properties

The STRUSTSSO2 - Add System ACL display-only page displays the properties used to add an Access 
Control List (ACL) entry in the Personal Security Environment (PSE) for an SAP ABAP system.

Field Description

File Name File name of the certificate file to be imported.

File Path Location of the certificate file to be imported.  

Field Description

Transaction Transaction to run:

• STRUST - for standard PSE functions

• STRUSTSSO2 - for PSE functions that include Single Sign On Access 
Control List Management.
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STRUSTSSO2 – Remove System ACL Method Instance Properties

The STRUSTSSO2 - Remove System ACL display-only page displays the properties used to delete an 
Access Control List (ACL) entry in the Personal Security Environment (PSE) for an SAP ABAP system.

SU01 – Reset User Password Method Instance Properties

The SU01 - Reset User Password display-only page displays the properties used to reset an SAP user 
password.

SUIM – Complex User Selection Method Instance Properties

The SUIM - Complex User Selection display-only page displays the properties used to retrieve a list of 
all unlocked user accounts.

SWU3 – Update Workflow RFC Destination Method Instance Properties

The SWU3 - Update Workflow RFC Destination display-only page displays the properties used to update 
the password for the workflow agent WF-BATCH in the target system after performing a system copy.

Field Description

System ID SAP system ID.

System Client SAP system client number. This method only runs in Client 000.

Field Description

System ID SAP system ID.

System Client SAP system client number. This method only runs in Client 000.

Field Description

User Name SAP user name.

Password New password

Prompt Indicates whether to prompt the user to reset the password during 
the next logon attempt.

Field Description

Selection Criteria A global variable that contains a table with the selection criteria for 
retrieving the unlocked user accounts

Field Description

Password New password to be assigned to the workflow agent WF-BATCH in 
the target system
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SAP RFC Function Methods Results

AL08 – Logged On Users Method Results

The AL08 - Logged on Users method results page displays the number of users logged in the system. 
The RFC method retrieves the following information:

AL11 – Change Custom Directory Method Results

The AL11 - Change Custom Directory method results page indicates whether the directory was 
successfully changed. The Results text box displays either Success or Failed.

AL11 – Create Custom Directory Method Results

The AL11 - Create Custom Directory method results page indicates whether the directory was 
successfully created. The Results text box displays either Success or Failed.

AL11 – Read Custom Directory Method Results

The AL11 - Read Custom Directory method results page displays the directory information that was 
retrieved.

AL11 – Remove Custom Directory Method Results

The AL11 - Remove Custom Directory method results page indicates whether the directory was 
successfully removed. The Results text box displays either Success or Failed.

AL15 – Add SAPOSCOL Destination Method Results

The AL15 - Add SAPOSCOL Destination method results page indicates whether the destination was 
successfully added. The Results text box displays either Success or Failed.

AL15 – Delete SAPOSCOL Destination Method Results

The AL15 - Delete SAPOSCOL Destination method results page indicates whether the destination was 
successfully deleted. The Results text box displays either Success or Failed.

BD97 – Assign RFC Special Method Destination Method Results

The BD97 - Assign RFC Special Method Destination method results page indicates whether the 
destination was successfully modified. The Results text box displays either Success or Failed.

Column Description

Server Name of the server that was used to retrieve the logged on users.

Client SAP client number for the user account.

User User name assigned to the account.

Terminal Name or the IP address of the computer being used by the user.

Transaction Code SAP transaction code executed.

Time Time user logged onto the system.
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BD97 – Assign RFC Standard BAPI Destination Method Results

The BD97 - Assign RFC Standard BAPI Destination method results page indicates whether the 
destination was successfully modified. The Results text box displays either Success or Failed.

BD97 – Assign RFC Standard Dialog Destination Method Results

The BD97 - Assign RFC Standard Dialog Destination method results page indicates whether the 
destination was successfully modified. The Results text box displays either Success or Failed.

BD97 – Delete All RFC Assignments Method Results

The BD97 - Delete All RFC Assignments method results page indicates whether the destinations were 
successfully deleted. The Results text box displays either Success or Failed.

BD97 – Read RFC Assignments Special Method Destinations Method Results

The BD97 - Read RFC Assignments Special Method Destinations method results page displays the RFC 
assignments for the specified logical system.

BD97 – Read RFC Destinations Standard Destinations Method Results

The BD97 - Read RFC Assignments Standard Destinations method results page displays the RFC 
assignments for the specified logical system.

BDC – Data Loader Method Results

The BDC - Data Loader method results page indicates whether the pre-recorded BDC data was passed 
successfully into a function.

Column Description

Business Object Name Business Object type technical name.

Logical System SAP logical system name.

Method Method of the Business Object type.

RFC Destination RFC destination to be called.

Column Description

Recorded Queue ID The SAP Internal Queue ID that can be used to reference the recorded 
session

Direct Call Failed A direct call using the CALL TRANSACTION technique failed.  Refer to 
the error log for further details pertaining to the failure. If the Create 
Session if Fails parameter was set to Yes, then a recording would have 
been made for manual processing.

Session Recorded Yes or No is provided if a session was recorded in the SAP target system. 
A recorded session is actionable by either scheduling a job to release the 
recording, or processed manually via the SAP GUI using SAP 
Transaction SM35.
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BDLS – Convert Logical Systems Background Job Method Results

The BDLS - Convert Logical Systems method results page indicates whether the logical system names 
were successfully converted. The Results text box displays either Success or Failed.

BDLS – Get Tables Method Results

The BDLS - Get Tables method results page returns a list of BDLS tables with rows that exceed the 
specified threshold.

BW – BWA Reorganize Landscape Method Results

The BW - BWA Reorganize Landscape method results page displays details from the landscape 
reorganization.

BW – Change Index Global Parameters Method Results

The BW - Change Index Global Parameters method results page indicates whether the global parameters 
were successfully modified. The Results text box displays either Success or Failed.

BW – Check DTP Status Method Results

The BW – Check DTP Status method results page displays the status of the specified DTP request. The 
RFC method retrieves the following information:

Column Description

DTP Request ID assigned to the DTP request

Data Packet Number ID of the data packet

TP Status of Data Package The status of the data package. The following values may be 
returned:

• 0 = New

• 1 = Executable

• 2 = Processed Successfully

• 3 = Process with Errors

• 4 = Deleted

• 5 = Active

• 6 = Processed with Warnings

• 7 = Further Processing Started

• 8 = Processed Further

• 9 = Deletion Started

• A = Further Processing Terminated

Batch ID ID assigned to the batch job

Start Time Time DTP was started

Finish Time Time DTP completed
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BW – Check OLAP Connection Method Results

The BW – Check OLAP Connection method results page displays the OLAP connection test results.

OLAP Test Results

Displays the results of the OLAP connection test (Success or Failed)

BW - Get BW InfoCube Dimensions Method Results

The BW - Get BW InfoCube Dimensions method results page displays the list of InfoCubes in the BW 
system and their layout. The RFC method retrieves the following information:

BW – Get BWA Index Reorg Plan Data Method Results

The BW - Get BWA Index Reorg Plan Data method results page displays information about the 
reorganization plan.

BW – Get InfoCube Size Method Results

The BW - Get InfoCube Size method results page displays the retrieved row sizing information for all 
InfoCube tables.

Column Description

InfoCube InfoCube name.

Table InfoCube dimension table.

Rows Number of rows in the dimension table.

Ratio Number of records in each dimension as percentage of the number 
of records in the fact tables.

Column Description

Reorganization Required Hint if a TREX index reorg run is recommended or not 
recommended.

Reorganization Target State Target state (improvement forecast) of a TREX index reorg.

Reorganization Plan Status of a TREX index reorg plan.

Column Description

Infocube Name of the Infocube.

Table Name of the Infocube table from which data was retrieved.

Rows Number of rows from which data was retrieved.

Ratio Ratio of dimension to fact table size.

Density Number of rows in the table.
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BW – Get Infocube List Method Results

The BW - Get InfoCube List method results page displays the list of InfoCubes in the BW system.

BW – Get Infopackage Source System Method Results

The BW – Get Infopackage Source System method results page displays the source system information 
for the specified Infopackage. The RFC method retrieves the following information:

BW – Get Last BWA Index Reorg Status Method Results

The BW – Get Last BWA Index Reorg Status method results page displays information about the last 
reorganization plan.

BW – Get Monitored Process Chains Method Results

The BW – Get Monitored Process Chains method results page displays a list of the process chains that 
are being monitored manually. The RFC method retrieves the following information:

Monitored Chain

Name of the process chain that is being monitored manually using transaction RSPCM (monitor process 
chains)

BW – Get Process Chain Jobs Method Results

The BW – Get Process Chain Jobs method results page displays a list of SM37 process chain jobs that 
have been executed and relevant information about the jobs. The RFC method retrieves the following 
information:

Column Description

Logical Infopackage InfoPackage ID that is created in the system (the request ID of an 
InfoPackage)

Infosource InfoSource loaded by the Infopackage

Source System Source system from which data is loaded

Column Description

Reorganization Plan state Status of a step in a TREX index reorganization 
plan.

Reorganization Plan Data table

Column Description

Job Step Scheduling Date Date of job/step scheduling

Job Step Scheduling Time Time of a scheduled job/step

Job Step Scheduling Initiator Initiator of job/step scheduling
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BW – Get Process Chain Log Method Results

The BW – Get Process Chain Log method results page displays the process chain process status 
messages recorded in the process chain log. The RFC method retrieves the following information:

BW – Get Process Chain Parent Method Results

The BW - Get Process Chain Parent method results page displays whether the process chain has a parent 
and the ID of the parent chain.

BW – Get Process Chain Processes Method Results

The BW - Get Process Chain Processes method results page displays a list of the process variants within 
the process chain.

Job Log Temse object name

Target System Target system to run background job

Job Status Check Job status check indicator for subsequent job start

Calendar ID Factory calendar ID for background processing

Job Behavior on Non-Workdays Period behavior of jobs on non-workdays

Server Name Name of the first server.

Connection Field 1 Correction field for calc. job execution (end-of-month)

Connection Field 2 Correction field for calc. job execution (end-of-month)

Server Name 2 Name of the second server.

Server Group Name Server group name background processing

Column Description

Column Description

Message Class Process chain message class

Message Number Process chain message number

Message Variable 1 Process chain message variable

Message Variable 2 Process chain message variable

Message Variable 3 Process chain message variable

Column Description

Background Processing 
Event Start

Background processing event name

Background Event 
Parameters

Background processing event parameter

Event Number Background processing event

Back-Link Event Start Link event indicator

Process Instance Process characteristic value
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BW – Get Process Variant Job Log Method Results

The BW - Get Process Variant Job Log method results page displays a list of the process variant jobs 
within the process chain.

BW – Get Process Variant Log Method Results

The BW - Get Process Variant Log method results page displays a list of the process variants within the 
process chain.

BW – Get Queries for InfoCube Method Results

The BW - Get Queries for InfoCube method results page displays a list of queries for the infocube.

• Query Name—List of queries returned for the infocube.

BW – Get Query Top Executions Method Results

The BW - Get Query Top Executions method results page displays a list of the top queries that have been 
executed.

BW – Get Source System Delta Queue Status (RSA7) Method Results

The BW - Get Source System Delta Queue Status (RSA7) method results page displays a list of the 
datasources and their status in RSA7.

BW – Infocube Memory Consumption – Grand Totals Method Results

The BW - Infocube Memory Consumption – Grand Totals method results page displays the sizing data 
for the specified infocubes.

Column Description

Job Log Entry Date Date the job was logged

Job Log Entry Time Time the job was logged

Message Class ABAP message class

Message Number ABAP message number

Message Type ABAP message type

Message Text ABAP message text

DB Key of RABAX Message Database key

DB Key Length Database key length

Message Variable ABAP message variable

Column Description

Receiver Source System BW logical system

Total Number of LUWs that were written in the delta queue and that have 
not yet been confirmed
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• Grand Totals—Memory sizing grand totals for the specified infocubes.

BW – Infocube Memory Consumption – Table Totals Results

The BW - Infocube Memory Consumption – Table Totals method results page displays the sizing data 
for the specified infocubes.

• Table Totals—Memory sizing table totals for the specified infocubes.

BW – Infocube Memory Consumption Grand Totals From Job Method Results

The BW - Infocube Memory Consumption Grand Totals From Job method results page displays the 
sizing data for the specified infocubes.

• Grand Totals—Memory sizing grand totals for the specified infocubes.

BW – Infocube Table Sizes Method Results

The BW - Infocube Table Sizes method results displays the following information about the table:

BW – RSDDAGGRDIR – List Aggregates Method Results

The BW - RSDDAGGRDIR - List Aggregates method results page displays the retrieved BW aggregates. 
The following information displays:

BW – RSDDBIAMON2 Get Infocube Indexes for Query Method Results

The BW - RSDDBIAMON2 Get Infocube Indexes for Query method results page displays the list of 
indexes for a BW query. The following information displays:

Column Description

AGGRUID Technical UID for aggregates.

OBJVERS Object version.

INFOCUBE InfoCube.

AGGRCUBE Aggregate of the InfoCube.

PARTITIONING Aggregate: Partitioning property.

RNSID_TO SID of a request.

CNSID_TO SID of the change.

MODFL Flag: Aggregate has been modified.

MODNEWFL Flag: Change by reconstructing.

MODCNSID Change Run ID, That Made Change.

NEXT_BETTERUID Next aggregate that is more suitable for the query.

NEXTUID Next aggregate.

PARENTUID Parent aggregate.
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BW – RSDDSTAT Get BW 3.5 DM Statistics Method Results

The BW - RSDDSTAT Get BW 3.5 DM Statistics method results page displays whether the information 
that was retrieved from the BW 3.5 systems.

BW – RSDDSTAT Get BW 3.5 Header Statistics Method Results

The BW - RSDDSTAT Get BW 3.5 Header Statistics method results page displays whether the 
information that was retrieved from the BW 3.5 systems.

BW – RSDDSTAT Get BW 3.5 OLAP Statistics Method Results

The BW - RSDDSTAT Get BW 3.5 OLAP Statistics method results page displays whether the 
information that was retrieved from the BW 3.5 systems.

BW – RSDDSTAT OLAP – List Queries with High OLAP Time Method Results

The BW - RSDDSTAT OLAP - List Queries with High OLAP Time method results page displays the 
query statistics for all queries with high OLAP runtime.

Column Description

Index Status Status of the index:

• C = Created

• F = Filled

• U = Unknown

• I = Incomplete

Infocube Name of the InfoCube, for example, 0SD_C03.

Infocube Object Version Version of the InfoCube object:

• A= Active

• M = Modified

• B = Backup

• D = Delivery

• N = New

• T = Transport

• H = Historic

Last Change Time Time that the last change was made to the index.

Last Change User Name of the user who made the last changes to the index.

Multiple Usage Indicates whether the index is shared.

With Delta Indicates if index is with delta.
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BW – RSDDSTAT_DM – List of Queries with High DM Time Method Results

The BW - RSDDSTAT_DM - List Queries with High DM Time method results page displays the query 
statistics for all queries with high Data Manager read time.

Column Description

CALDAY BW statistics: Day.

EVENTID OLAP statistics event (Type NUMC9).

HANDLEID Internal ID of a query runtime object.

HANDLETP Internal Type of query runtime object.

INFOPROV InfoProvider.

OBJNAME OLAP statistic object name (QueryID, TemplateID, etc.).

OBJPROP Properties of the statistic object (Query, Template, etc.).

RUNTIME Validity period.

SESSIONUID UUID in compressed form.

STATLEVEL Detail level of the OLAP statistics label.

STEPCNT Counter of the (Navigation) step during query execution.

STEPTP OLAP statistics: Step type (ODBO, BEX, etc.)

STEPUID UUID in compressed form.

UNAME User name.

UTIME BW statistics: Time.

Column Description

STEPUID UUID in compressed form.

HANDLEID Internal ID of a query runtime object.

HANDLETP Internal Type of query runtime object.

UNAME User name.

UTIME BW statistic: Time.

CALDAY BW statistic: Day.

OBJNAME OLAP statistic object name (QueryID, TemplateID, etc.).

DMUID UUID in compressed form.

ACCESSCNT DM statistics: DM access counter.

ACCESSTP Type of data rad access (Non-Cumulative or Delta)

INFOPROV InfoCube

PARTPROV InfoCube

AGGREGATE InfoCube

TABLTP Single-Character flag.

TIMEDMPREP Validity period.
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BW – RSDDTPS Index Maintenance for Business Objects Polestar Method Results

The BW - RSDDTPS Index Maintenance for Business Objects Polestar method results page indicates 
whether the index was successfully created or updated. The Results text box displays either Success or 
Failed.

BW – RSDDV Create Index Method Results

The BW - RSDDV Create Index method results page indicates whether the index was successfully 
created. The Results text box displays either Success or Failed.

BW – RSDDV Delete Index Method Results

The BW - RSDDV Delete Index method results page indicates whether the index was successfully 
deleted. The Results text box displays either Success or Failed.

BW – RSDDV Fill Index Method Results

The BW - RSDDV Fill Index method results page indicates whether the index was successfully filled. 
The Results text box displays either Success or Failed.

BW – RSPC Finish Process Chain Method Results

The BW - RSPC Finish Process Chain method results page indicates whether the process chain step 
status was successfully reset and restarted. The Results text box displays either Success or Failed.

BW – RSPC Stop Process Chain Method Results

The BW - RSPC Stop Process Chain method results page indicates whether the process chain step status 
was successfully stopped. The Results text box displays either Success or Failed.

BW – RSRCACHE Get Cache Monitor Buffer Objects Method Results

The BW - RSRCACHE Get Cache Monitor Buffer Objects method results page displays the BW cache 
monitor buffer objects.

TIMEDMPOST Validity period.

TIMEREAD Validity period.

TIMESID Validity period.

TIMENAVATTR Validity period.

TIMEHIERARCHY Validity period.

DBSEL Number of selected records.

DBTRANS Number of transported records.

WP_ID Work process ID.

PROCESSCNT Process counter.

SLOTNR Slot number for parallel processing.

Column Description
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BW – RSRCACHE Get OLAP Cache Parameters Method Results

The BW - RSRCACHE Get OLAP Cache Parameters method results page displays the BW OLAP cache 
parameters.

BW – RSRT – Analyze Query Method Results

The BW - RSRT - Analyze Query method results page displays the performance statistics on the query 
runtime.

Column Description

Aggregate Size Total size of a cache object and its child cache objects.

Cache Directory Indicates whether it is a cache directory that contains other cache 
objects.

Column Description

ACCESSCNT Access counter.

ACCESSTP Type of data read access (Non-Cumulative).

AGGREGATE Aggregate.

CALDAY BW statistics: Day

DBSEL Selected records.

DBTRANS Transported records.

DMUID Data manager UID.

EVCOUNT Event counter.

EVENTID Event ID.

EVENTIDCNT Event ID counter.

EVTIME Event duration.

HANDLEID Handle ID.

HANDLETP Handle type.

INFOPROV Infoprovider.

OBJNAME Object name.

OBJPROP Object properties.

PARTPROV Basis provider.

PROCESSCNT Process number.

RESULTNAME Result name.

RUNTIME Validity period.

SESSIONUID Session UID.

SLOTNR Slot number.

STARTTIME Start time.

STATLEVEL OLAP statistics level.
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BW – RSRT Analyze Single Query Method Results

The BW - RSRT - Analyze Query method results page displays the performance statistics on the query 
runtime.

STEPCNT Step counter.

STEPTP Step type.

STEPUID Step UID.

TABLTP Table type.

TIMEDMPOST DM postprocessing.

TIMEDMPREP DM preparation.

TIMEHEIRARCHY Hierarchy.

TIMENAVATTR Attribute processing.

TIMEREAD Viewed at this time.

TIMESID SID processing.

UNAME User name.

UTIME BW statistics: Time

WP_ID Work process ID.

Column Description

Column Description

Access Counter Data manager access counter.

Attribute Processing Validity period.

Basis Provider Basic Infoprovider.

BW Statistics Day Day.

BW Statistics Time Time.

Counter Statistics counter.

DM Processing Data manager post processing time.

Duration Frontend/calculation layer execution time.

Event Counter Statistics event counter.

Event ID OLAP event statistics type.

Handle ID Internal ID of a query runtime object.

Handle Type Internal ID of a query runtime object.

Infoprovider BW data provider.

Object Name Query ID.

Object Properties Query properties.

OLAP Statistics Level Detail level of the OLAP statistics label

Process Number Process counter.

Slot Number Slot for parallel processing.
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BW – RSRT Check Query Mandatory Variables Method Results

The BW - RSRT Check Query Mandatory Variables results page displays a table that contains the entry 
requirements for the variables of the query.

BW – RSRV Data Consistency Check Method Results

The BW - RSRV Data Consistency Check results page displays a table that contains one or more log 
messages.

BW – Read Info Provider Data Method Results

The BW – Read Info Provider Data method results page displays the data extracted from the specified 
InfoProvider object in SAP BW. The RFC method retrieves the following information:

SID Processing Master data table processing time.

SQL Statement Database SQL issued.

Start Time Query start time

Step Counter Counter of the (Navigation) step during query execution.

Step Type OLAP statistics event (Navigation) step type.

Step UID Navigation unique ID

Table Type Infocube table type called.

User Name Calling user name.

Validity Period Validity period.

Viewed at Data manager time read.

Column Description

Column Description

Message Type A = Abort

E = Error

W = Warning

I = Information

S = Success

Message Text Log message text.

Column Description

ID Identification assigned to the entry

IOBJNIM Selected characteristic

Value Value returned for the characteristic
13-158
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 13      Using SAP Adapters
  SAP RFC Adapter
BW – Read Info Provider Vertical Data Method Results

The BW – Read Info Provider Vertical Data method results page displays the data that was read in the 
InfoProvider objects in BW. The RFC method retrieves the following information:

BW – SE38 Create Variant Method Results

The BW - SE38 Create Variant method results page indicates whether the program variant was 
successfully created. The Results text box displays either Success or Failed.

BW – TREX Get Alert Details Method Results

The BW - TREX Get Alert Details method results page displays the alert details of the TREX index.

BW – TREX Get Alerts Method Results

The BW - TREX Get Alerts method results page displays the alerts in the TREX index.

BW – TREX Get Index Status Method Results

The BW - TREX Get Index Status method results page displays the status of the TREX index.

BW – TREX Get Landscape Status Summary Method Results

The BW - TREX Get Landscape Status Summary method results page displays the TREX BWA blade 
status summary information.

BW – TREX Kill Server Processes Method Results

The BW - TREX Kill Server Processes method results page indicates whether the processes were 
successfully killed. The Results text box displays either Success or Failed.

BW – TREX List Indexes Method Results

The BW - TREX List Indexes method results page displays the list of indexes on the BWA blade and 
memory usage per index.

Column Description

ID Identification assigned to the entry

IOBJNIM Selected characteristic

Value Value returned for the characteristic

Column Description

Index ID ID assigned to the index.

Description Text description of the index.
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BW – TREX Reconfigure Server Method Results

The BW - TREX Reconfigure Server method results page indicates whether the server was successfully 
reconfigured. The Results text box displays either Success or Failed.

BW – TREX Restart Server Method Results

The BW - TREX Restart Server method results page indicates whether the server was successfully 
restarted. The Results text box displays either Success or Failed.

BW – TREX Service Statistics Method Results

The BW - TREX Service Statistics method results page displays blade TREX service statistics.

CRMRFCPAR – Create Method Results

The CRMRFCPAR - Create method results page indicates whether the entry in the CRMRFCPAR table 
was successfully created. The Results text box displays either Success or Failed.

CRMRFCPAR – Modify Method Results

The CRMRFCPAR - Modify method results page indicates whether the entry in the CRMRFCPAR table 
was successfully changed. The Results text box displays either Success or Failed.

CRMRFCPAR – Read Method Results

The CRMRFCPAR - Read method results page displays the entries in the CRMRFCPAR table.

Column Description

Location TREX service resource location.

Total Memory Total memory usage of all processes (%).

Column Description

Client Client number.

Consumer CRM partner name.

Object Name Data object/table name.

RFC Destination RFC destination of partner.

RFC Queue Name of the RFC outbound queue.

RFC Inbound Queue Name of the RFC inbound queue.

BAPI Name Name of the BAPI, if used.

Inactive Indicates whether the data record is inactive.

Discard Data Indicates whether the data was discarded.

Send XML Indicates whether the message was sent in XML format.

Hold Data Indicates whether the data was held instead of sending to partner.

CRM Release SAP CRM release number.
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CRMRFCPAR – Remove Method Results

The CRMRFCPAR - Remove method results page indicates whether the entry in the CRMRFCPAR table 
was successfully removed. The Results text box displays either Success or Failed.

DB02 – Get DB6 Tablespace Method Results

The DB02 - Get DB6 Tablespace results page displays data about the tablespace usage.

DB02 – Reset Statistics Method Results

The DB02 - Reset Statistics method results page indicates whether the database statistics were 
successfully reset. The Results text box displays either Success or Failed.

DBACOCKPIT – Read DB6 UDF Configuration Method Results

The DBACOCKPIT - Read DB6 UDF Configuration results page displays the configuration information.

DBACOCKPIT – Update DB6 UDF Configuration Method Results

The DBACOCKPIT - Update DB6 UDF Configuration method results page indicates whether the path 
was successfully updated. The Results text box displays either Success or Failed.

Execute ABAP Function – XML Method Results

The Execute ABAP Function - XML method results page displays the data that was retrieved from the 
function call. The RFC method retrieves the following information:

Last Update Date Last update date of interface.

Change User Last user that changed the record.

Change Date Last change date of record.

CRM Logical System Name Partner logical system ID.

Column Description

Column Description

Computation Time Date and time of computation.

Database Start Time Database start date and time.

High Water Mark High water mark of used page numbers.

Partition Partition number.

Tablespace ID ID of tablespace.

Column Description

Schema Database schema name.

Function Function definition.

Path Directory path.
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Execute ABAP Program – String Method Results

The Execute ABAP Program - String method results page displays the data that was retrieved from 
running SAP programs through function inst_execute_report in a string.

Execute ABAP Program – Table Method Results

The Execute ABAP Program - Table method results page displays the data that was retrieved from 
running SAP programs through function inst_execute_report. A data table is returned with each 
command output line in a table row.

Get SAP Server Info Method Results

The Get SAP Server Info method results page displays the retrieved information about the specified SAP 
server.

ICM – Clear HTTP Cache Method Results

The ICM - Clear HTTP Cache method results page indicates whether the HTTP cache was successfully 
cleared. The Results text box displays either Success or Failed.

ICM – Restart J2EE Server Method Results

The ICM - Restart J2EE Server method results page indicates whether the J2EE server was successfully 
started. The Results text box displays either Success or Failed.

ICM – Stop J2EE Server Method Results

The ICM - Stop J2EE Server method results page indicates whether the J2EE server was successfully 
shut down. The Results text box displays either Success or Failed.

PFCG – Update Composite Role Method Results

The PFCG - Update Composite Role method results page indicates whether the composite role was 
successfully updated. The Results text box displays either Success or Failed.

Column Description

Parameter Parameter that was retrieved from the SAP function module

Value Parameter value that was retrieved

Content XML content that was retrieved

Column Description

Server Name Name of the SAP server for which information was retrieved

Host Name Host name for the SAP server

IP Address IP address for the server
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PI – Get Message List Method Results

The PI - Get Message List method results page displays the messages retrieved from the specified SAP 
application server. The RFC method retrieves the following information:

RBDMONI5 – Get Open Change Pointers Method Results

The RBDMONI5 – Get Open Change Pointers method results page displays the number of outstanding 
change pointers to be processed for a selected message type. The RFC method retrieves the following 
information:

Column Description

Executed From Time that the message was sent to XI

End time Execution time

Sender Component Outbond business system

Sender Namespace Outbound interface namespace

Sender Interface Outbound interface name

Receiver Component Inbound business system

Receiver Namespace Inbound interface namespace

Receiver Interface Inbound interface name

 Pipeline Pipeline ID

Type Message type

QoS QoS mode

Inbound Incoming pipeline name

Outbound Outgoing pipeline name

Outbound Status Adapter status

Queue ID tRFC queue name

Q. Status Queue status

Original Message ID ID of reference message

Request Message ID ID of reference recorded message

Message Status Type Message status type

Client SAP Client

User Name SAP User name

Column Description

Description Description of the message type

Open Change Pointers Number of outstanding open change pointers to be processed

Note: If the RFC returns all 0 change pointers, no data will display 
in Process Orchestrator, whereas, in SAP, a list of 0 change pointers 
does display.
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RSMO – Get InfoPackage Requests Method Results

The RSMO – Get InfoPackage Requests method results page displays the InfoPackage processing 
requests that have not completed processing or are in failed status. The RFC method returns a table with 
the following columns:

RSMO – InfoPackage Request Error Message Method Results

The RSMO – InfoPackage Request Error Message method results page displays the InfoPackage request 
processing log with detailed information about InfoPackage failures. The RFC method returns a table 
with the following columns:

RSRDA End Daemons Method Results

The RSRDA End Daemons method results page indicates whether the daemon processes were 
successfully stopped. The Results text box displays either Success or Failed.

RZ03 – Swap OP Modes Method Results

The RZ03 - Swap OP Modes method results page indicates whether the operation mode was successfully 
switched on the specified server. The Results text box displays either Success or Failed.

RZ04 – List Operation Modes Instances Method Results

The RZ04 - List Operation Modes Instances method results page displays a list of operation modes.

Column Description

InfoPackage Name of the InfoPackage

InfoPackage ID SAP ID assigned to the InfoPackage

Request Number Request number assigned to the InfoPackage (same as the instance 
number)

Time (UTC) Time that the InfoPackage was processed

Column Description

Header Error message header text.

Type Error message type.

ID Error message ID.

Number Error message number ID.

Column Description

Instance Profile File system path of instance profile

Startup Profile File system path of startup profile

Home Directory Home directory of SAP instance

User Name User name of the instance owner (N/A)
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RZ04 – List Operation Modes Method Results

The RZ04 - List Operation Modes method results page displays a list of operation modes.

RZ04 – Update All Operation Modes Method Results

The RZ04 - Update All Operation Modes method results page indicates whether the all operation modes 
were successfully updated. The Results text box displays either Success or Failed.

RZ10 – Delete Profiles Method Results

The RZ10 - Delete Profiles method results page displays the profiles that were deleted.

RZ10 – Import Profiles Method Results

The RZ10 - Import Profiles method results page displays the profiles that were imported.

Password Password of the instance owner (N/A)

Reserved Background Processes Number of work processes reserved for background processing

Online Service Dialog instance service

Update Service Update instance service

Background Processing Service Background processing service

Locking Service Lock management

Spool Service Spool instance service

Operating System Type of operating system

V2 Update Work Processes Number of V2 update work processes

Work Process Variant 1, 2 N/A

V2 Update Service V2 update instance service

Variant 1, 2 Service N/A

Column Description

Column Description

Operation Mode Name Name of the operation mode

System Name SAP system name

Operation Mode Type Type of operation mode:

• M = Maintenance

• P = Productive

T = Test

Instance Allocation Allocation of instances:

• A = All

• E = Explicit
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RZ10 – Modify Profile Parameter Value Method Results

The RZ10 - Modify Profile Parameter Value method results page indicates whether the profile parameter 
value was verified and/or successfully modified. The Results text box displays either Success or Failed.

RZ10 – Read Profile Parameter Value Method Results

The RZ10 - Read Profile Parameter Value method results page displays the assigned parameter value.

RZ11 – Change Dynamic Parameter Method Results

The RZ11 - Change Dynamic Parameter method results page displays whether the parameter change was 
successful or if it failed. The Results text box displays Success or Failed .

RZ12 – Create Logon Group Method Results

The RZ12 - Create Logon Group method results page indicates whether the logon group was successfully 
create. The Results text box displays either Success or Failed.

RZ12 – Delete All Logon Groups Method Results

The RZ12 - Delete All Logon Groups method results page indicates whether all of the logon groups were 
successfully deleted. The Results text box displays either Success or Failed.

RZ12 – Delete Logon Group Method Results

The RZ12 - Delete Logon Group method results page indicates whether the logon group was successfully 
deleted. The Results text box displays either Success or Failed.

RZ12 – List Logon Groups Method Results

The RZ12 - List Logon Groups method results page displays the logon groups that are found on the target 
system.

Column Description

Log Line Log file information about the profiles that were imported

Column Description

Parameter Value Value assigned to the profile parameter

Column Description

Instance SAP instance to which the logon group is assigned

IP Address IP address of target system

Response Time Response time of target system

Users Number of users in logon group
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RZ20 – Change CCMS Thresholds Method Results

The RZ20 - Change CCMS Thresholds method results page indicates whether the threshold values 
successfully changed. The Results text box displays either Success or Failed.

RZ70 – Get Status Info Method Results

The RZ70 - Get Status Info method results page displays the retrieved configuration information from 
the target system.

RZ70 – Set SLD Supplier Method Results

The RZ70 - Set SLD Supplier method results page indicates whether the SLD supplier was successfully 
reconfigured. The Results text box displays either Success or Failed.

Read Single Column From SAP Table Method Results

The Read Single Column From SAP Table results page displays the information retrieved from the 
specified column in the SAP table.

SCC4 – Modify Client Method Results

The SCC4 - Modify Client method results page indicates whether all of the specified attributes of the 
client in the target system were successfully changed. The Results text box displays either Success or 
Failed.

SCC4 – Read Client Method Results

The SCC4 - Read Client method results page displays the client details (SAP Table T000) configured on 
the SAP system.

Column Description

SAP Host Name Name of the SAP SLD host. (For example, sapxisys.cisco.com)

SAP Gateway Service Name of the SAP SLD host gateway service.( For example, 
SAPGW01)

Scheduled Data collector job is scheduled.

Schedule Interval Interval of data collector schedule job.

Column Description

Values The data retrieved from the specified column in the SAP 
table.

Column Description

Client Default Currency Standard currency throughout client.

Client Role Description Short text for fixed values.

Change Object Value Changes and transports for client-specific objects.
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 SCC7 – Client Import Method Results

The SCC7 - Client Import method results page displays the jobs that have been submitted.

• Job ID—Identification number assigned to the submitted job.

SCC8 – Client Export Method Results

The SCC8 - Client Export method results page displays the client data that was exported.

SCOT – Clear Node Address Method Results

The SCOT - Clear Node Address method results page indicates whether the node addresses were 
successfully cleared. The Results text box displays either Success or Failed.

SCOT – Get Transaction SCOT Data Method Results

The SCOT – Get Transaction SCOT Data method results page displays the data from SAPConnect that 
is related to external communications from an SAP system such as fax and email. The RFC method 
returns a table with the following columns:

Change Object Description Short text for fixed values.

Change Client Independent 
Value

Maintenance authorization for objects in all clients.

Change Client Independent 
Description

Short text for fixed values.

Client Copy Protect Value Protection value for client copy program and comparison tools.

Client Copy Protect 
Description

Short text for fixed values.

Lock Against Upgrade Client control; no client cascade for upgrade import.

Client Recording Value Client control; CATT and eCATT authorization

Client Recording Description Short text for fixed values.

Client Locked for Client 
Copy Value

Client control; Indicator that client is temporarily locked.

Column Description

Column Description

Job ID Job ID of the submitted job.

Transport ID for Client 
Data

Transport ID found in /usr/sap/tras directory for client data.

Transport ID for Client 
Texts

Transport ID found in /usr/sap/tras directory for client texts.

Transport ID for Cross 
Client Data

Transport ID found in /usr/sap/tras directory for cross client 
data.
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SCOT – Set Node Address Method Results

The SCOT - Set Node Address method results page indicates whether the specific recipient filters for 
existing nodes were successfully set. The Results text box displays either Success or Failed.

SCOT – Set SMTP Host Method Results

The SCOT - Set SMTP Host method results page indicates whether the sMTP host was successfully 
reset. The Results text box displays either Success or Failed.

SDCCN – Clear Tasks Method Results

The SDCCN - Clear Tasks method results page indicates whether all of the specified SDCCN tasks were 
successfully deleted. The Results text box displays either Success or Failed.

SDCCN – Read Tasks Method Results

The SDCCN - Read Tasks method results page displays the scheduled SDCCN tasks that were retrieved. 
The RFC method returns a table with the following columns:

Column Description

Object Number Internal number assigned to the SAPOffice object by SAP

Object Type SAPOffice code for document class

Sender Username SAP user that sent the object

Recipient Type Recipient address type (Fax, internet, etc.)

Address Type SAPConnect address format

Sender Type Senders address type (Fax, internet, etc.)

Sender Number Sender fax number

GUID Sender request globally unique ID

Message Class Delivery status message class

Message Type Delivery status message type

Message 1 Delivery status message text

Message 2 Delivery status message text

Message 3 Delivery status message text

Message 4 Delivery status message text

Status Status of the transaction

Column Description

Task ID Task ID for the SDCCN task.
Task Name Name of the SDCCN task.
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SDCCN – Schedule Tasks Method Results

The SDCCN - Schedule Tasks method results page indicates whether the specified SDCCN task was 
successfully scheduled. The Results text box displays either Success or Failed.

SE06 – Perform Post-Installation Actions Method Results

The SE06 - Perform Post-Installation Actions method results page indicates whether the TMS 
configuration was successfully reset. The Results text box displays either Success or Failed.

SE06 – Set System Change Options Method Results

The SE06 - Set System Change Options method results page indicates whether the system change option 
settings were successfully modified. The Results text box displays either Success or Failed.

SE06 – System Change Method Results

The SE06 - System Change method results page displays the specified number of changes in the system. 
The RFC method retrieves the following information:

SE10 – Export Tables Method Results

The SE10 - Export Tables method results page displays information about the tables that were exported.

SE38 – Change Variant Method Results

The SE38 - Change Variant method results page indicates whether the program variant was successfully 
changed. The Results text box displays either Success or Failed.

SE38 – Create Variant Method Results

The SE38 - Create Variant method results page indicates whether the program variant was successfully 
created. The Results text box displays either Success or Failed.

Column Description

Description Brief description of the system change

Changed by User name of the person initiating the change

Column Description

Transport Number SAP Transport (Change Request) that contains the tables to 
be exported.

Result Exceptions returned; if no exceptions return is success.

Job ID Job ID of export job (only if release option was chosen).

Job Name Name of the submitted job (only if release option was 
chosen).
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SE38 – Display Variant Values Method Results

The SE38 - Display Variant Values method results page displays the retrieved information about the 
specified program.

SE61 – Display Document Method Results

The SE61 - Display Document method results page displays the information about the action performed 
on the specified document.

SE61 – Modify Document Method Results

The SE61 - Modify Document method results page indicates whether the modifications were 
successfully implemented. The Results text box displays either Success or Failed.

SECSTORE – Check Status Method Results

The SECSTORE - Check Status method results page indicates whether the secure storage was 
successfully read by the SAP System. The Results text box displays either Success or Failed.

SECSTORE – Set Migration Key Method Results

The SECSTORE - Set Migration Key method results page indicates whether the migration key was 
successfully set. The Results text box displays either Success or Failed.

SICF – Activate Service Method Results

The SICF - Activate Service method results page indicates whether the service was successfully 
activated. The Results text box displays either Success or Failed.

SICF – Clear Service Anonymous User Login Data Method Results

The SICF - Clear Service Anonymous User Login Data method results page indicates whether the 
service anonymous user login data was successfully cleared. The Results text box displays either 
Success or Failed.

Column Description

Parameter Name Name of the parameter for which values were retrieved

Column Description

Return Message Message returned from the RFC call

Document Lines Table of text lines that contains the context of the document. Each 
text line corresponds to one row in the document.

Line Number Sequence number of a text line

Text Line Content of text line
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SICF – Deactivate Service Method Results

The SICF - Deactivate Service method results page indicates whether the service was successfully 
deactivated. The Results text box displays either Success or Failed.

SICF – Get Service Anonymous User Login Data Method Results

The SICF - Get Service Anonymous User Login Data method results page displays the user data 
retrieved for the specified service.

SICF – Update Service Anonymous User Method Results

The SICF - Update Service Anonymous User method results page indicates whether the service user 
account was successfully updated. The Results text box displays either Success or Failed.

SICK – Basic Installation Check Method Results

The SICK - Basic Installation Check method results page displays the results of the SAP basic 
installation check results. The Results text field displays a text message indicating the results of the SAP 
basic installation check report (for example, if there are no system inconsistencies, the results column 
will display no errors reported.

SLDCHECK – PI Check Method Results

The SLDCHECK - PI Check method results page displays the highlights and errors for connecting the 
ABAP system to the assigned SLD. It also displays whether the ABAP system is represented as a 
Business System on the System Landscape Directory (SLD). 

SLG1 – Read Application Log Method Results

The SLG1 - Read Application Log method results page displays the retrieved log messages from the SAP 
application log.

Column Description

Client SAP client.

Password SAP password for the user account.

User Name SAP user name.

Column Description

Appl. Log Number Application log internal message number.

Message Type Message type(S=Success, I=Information, W=Warning, E=Error, 
A=Program Abort).

Message ID SAP-related message ID.

Message Number SAP-related message number.

Message V1 Message parameter 1, included in the final message text.

Message V2 Message parameter 2, included in the final message text.
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SLT - Get Connection Parameters Method Results

The SLT - Get Connection Parameters method results page displays the data retrieved of SLT connection 
parameters.

SLT - Get Connection Status Method Results

The SLT - Get Connection Status method results page displays the source and target connection status 
of the SLT data replication server.

SLT - Get Job Status Method Results

The SLT - Get Job Status method results page displays the status of SLT data replication background 
jobs.

SLT - Get Mass Transfer ID Mapping Method Results

The SLT - Get Mass Transfer ID Mapping results page displays the schema configuration ID to which 
an SLT mass transfer ID is mapped.

Message V3 Message parameter 3, included in the final message text.

Message V4 Message parameter 4, included in the final message text.

Determination Level Application log level of detail.

Problem Class Application log problem class.

Appl Log Sort Application log sort criteria/grouping.

Message Count Application log cumulated message count (if multiple messaged 
occurred).

Message Message text is the complete message with parameters included.

Column Description

Column Description

Configuration ID Configuration ID of an SLT data replication schema

Sender/Receiver Indicator Sender or receiver indicator

Parameter Name Name of the SLT connection parameter

Parameter Value Value of the SLT connection  parameter

Column Description

Source Connection Status Source connection status of the SLT data replication server

Target Connection Status Target connection status of the SLT data replication server

Column Description

Load Job Status Status of the data transfer jobs
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SLT - Get Replication Runtime Statistics Method Results

The SLT - Get Replication Runtime Statistics method results page displays the replication runtime 
statistics of an SLT data replication schema.

SLT - Get Schema Header Data Method Results

The SLT - Get Schema Header Data Method Results page displays the SLT schema header data.

SLT - Get Schema Trigger Status Method Results

The SLT - Get Job Status method results page displays the schema triggers status of an SLT data 
replication schema.

SLT - Get Table Status Method Results

The SLT - Get Table Status method results page displays the status of SLT data replication related to a 
database table.

SLT - Start Jobs Method Results

The SLT - Start Jobs method results page displays whether the SLT data replication background jobs was 
successfully started.

Column Description

Configuration ID Configuration ID of an SLT data replication schema

Mass Transfer ID SLT mass transfer ID

Column Description

Status Description Description of the status

Table Name Name of the table that contains the runtime statistics

Current Data Replication Action Action of the current data replication

Current Data Replication Status Status of the current data replication

Column Description

Table Name Name of the table that contains the schema trigger status

Column Description

Process Time Status of the replication process
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SLT - Stop Jobs Method Results

The SLT - Stop Jobs method results page displays whether the SLT data replication background jobs was 
successfully stopped.

SM01 – Lock Transaction Method Results

The SM01 - Lock Transaction method results page indicates whether the transaction was successfully 
locked. The Results text box displays either Success or Failed.

SM01 – Unlock Transaction Method Results

The SM01 - Unlock Transaction method results page indicates whether the transaction was successfully 
unlocked. The Results text box displays either Success or Failed.

SM02 – Create System Message Method Results

The SM02 - Create System Message results page displays a unique message ID of the SAP system 
message that was created and stored in the database.

Note This message ID must be retained as an input parameter for the delete message functionality in RFC 
SM02 - Delete System Message Method.

SM02 – Delete System Message Method Results

The SM02 - Delete System Message method results page indicates whether the system message was 
successfully deleted. The Results text box displays either Success or Failed.

SM04 – Logoff User Method Results

The SM04 - Logoff User method results page displays the specified number of changes in the system. 
The Results text box displays either Success or Failed.

SM12 – Age Enqueue Entries Method Results

The SM12 – Age Enqueue Entries method results page displays all SAP document locks older than the 
specified time period. The RFC method returns a table with the following columns:

Column Description

Date Date the lock was created.

Time Time the lock was created.

Object SAP tables to be locked.

Key Key field of the rows in the SAP tables to be locked.

User SAP user that created the lock.

Transaction Code SAP transaction code the user executed that created the lock.

Client SAP client in which the lock was created.

Host SAP application server that created the lock.
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SM12 – Enqueue Size Method Results

The SM12 – Enqueue Size method results page displays the number of Enqueue entries (locks) exceed 
a defined maximum number. The RFC method returns a table with the following columns:

SM12 – Select Lock Entries Method Results

The SM12 - Select Lock Entries method results page displays the lock entries on the specified SAP 
system. The RFC method retrieves the following information:

SM13 – Check Update System Status Method Results

The SM13 - Check Update System Status method results page indicates whether the update system is 
active or inactive. The Update System Status displays Active or Deactivated.

SM13 – Delete Update Record Method Results

The SM13 - Delete Update Record method results page displays the number of deleted update records 
with Error status. The RFC method returns a table with the following columns:

Column Description

Date Date the lock was created.

Time Time the lock was created.

Object SAP tables to be locked.

Key Key field of the rows in the SAP tables to be locked.

User SAP user that created the lock.

Transaction Code SAP transaction code the user executed that created the lock.

Client SAP client in which the lock was created.

Host SAP application server that created the lock.

Column Description

Date Date the lock was created

Time Time the lock was created

Table SAP tables locked

Lock Argument Locked fields in a database table

User SAP user that created the lock

Transaction code SAP transaction code that was executed to create the lock

Client SAP client in which the lock was created

Host SAP application server that created the lock
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SM13 – Delete Update Records Method Results

The SM13 - Delete Update Records method results page indicates whether the records were successfully 
deleted. The Results text box displays either Success or Failed.

SM13 – Get Update Error Message Method Results

The SM13 – Get Update Error Message method results page displays the error message for a specific 
update record. The RFC method returns a table with the following columns:

Column Description

Update Key Key under which an update request is stored as a data record 
in the database. The key writes messages in the system log if 
update processing terminates abnormally. The express mail 
that informs you of the canceled update also contains this key.

Client Client to which the user is logged on

User User who triggered the update

Language Language in which the user is logged on

Account The Account field is currently not used

Report ABAP report with which the update was created

Transaction Transaction that called up the ABAP program

Enqueue key Key of the lock entries created by the transaction that created 
the update.

The update task holds the locks until the V1 update has been 
successfully completed. The locks are canceled if an update 
error occurs.

Context Language that the update server has to support for this update 
request.

You can display the contexts of the update server(s) in your 
system by choosing Display Server.

Information Bit mask that contains further information on the update 
request. The default value is 1 (standard update request). 2 
means that this request is from the batch input, and must not 
be restarted manually.

UD ret. code Update return code (for error analysis)

Status Detailed description of status

Update server Update server on which the update request was processed

UD Client Update server on which the update request was created

Time Offset Difference between local time and system time
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SM13 – Get Update Queue Method Results

The SM13 – Get Update Queue method results page displays entries in the SAP update queue, optionally 
filtering entries in queued or error status. The RFC method returns a table with the following columns:

SM14 – Activate and Deactivate Update System Method Results

The SM14 - Activate and Deactivate Update System method results page indicates whether the update 
system was activated or deactivated. The Results text box displays either Success or Failed.

SM21 – Read System Log Method Results

The SM21 – Read System Log method results page displays the SAP system log for a defined server and 
defined time period. SAP servers record events and problems in the system logs. The RFC method 
returns a table with the following columns:

Column Description

Application Area Area of an application that created the update record 
(assigned by the application developer).

Message Number SAP message number of the error message (used for 
localization).

Message Text Text of the error message.

Column Description

Client SAP client that the user was logged into that created the update 
record

User SAP user that created the update record

Transaction SAP transaction the user executed that created the update record

Program SAP application the user executed that created the update record

Date Date the update record was created

Time Time the update record was created

Update Key Key that uniquely identifies the update record

Enqueue Key Key that links this update record to a record lock (Enqueue lock)

Update Return Code Code returned when the update was processed

Column Description

Date Date the system log entry was written

Time Time the system log entry was written

Instance SAP application server where the log entry was written

User SAP user executing the program that created the log entry

Program SAP program executing that create the log entry
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SM35 – Session Overview Method Results

The SM35 - Session Overview method results page displays information about the sessions that have run 
on the specified client. The RFC method returns a table with the following columns:

SM36 – Create Background Job Method Results

The SM36 - Create Background Job method results page indicates whether the job was successfully 
executed. The Results text box displays either Success or Failed.

SM36 – End Standard Jobs Method Results

The SM36 - End Standard Jobs method results page indicates whether the job was successfully deleted. 
The Results text box displays either Success or Failed.

SM36 – Job Scheduler Method Results

The SM36 - Job Scheduler method results page indicates whether the job was successfully scheduled. 
The Results page displays either Success or Failed.

MNo SAP message number of the message written to the log (used 
for localization)

Text Message written to the system log

Column Description

Column Description

Client SAP client

Date Date session was created

Time Time session was created

Creation Program SAP program that created the session

Lock Date Date the session was locked

Authorization Authorization User for permissions during session execution

Total Number of 
Transactions

Total number of transactions executed during the session

Transactions with Errors Number of transactions with errors

Transaction Processed Number of transactions processed

Screens Number of screens (Dynpros) in session

Deletion Indicator Deletion indicator for processed sessions

Queue ID Queue identification number Unique number of session

Status Session status

Created By SAP user who created the session
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SM36 – Schedule Standard Jobs Method Results

The SM36 - Schedule Standard Jobs method results page indicates whether the job was successfully 
scheduled. The Results text box displays either Success or Failed.

SM37 – Cancel a Background Job Method Results

The SM37 - Cancel a Background Job method results page displays all data associated with a specific 
instance of an SAP job execution. The RFC method returns a table with the following columns:

SM37 – Complex Job Selection Method Results

The SM37 – Complex Job Selection method results page displays the list of all SAP jobs for a defined 
time period that match the defined criteria. The method returns a table with the following columns:

Column Description

Job ID Job ID assigned by SAP to this instance of job execution.

Column Description

Check Status Job status check indicator for subsequent job start.

Duration (sec.) Amount of time the job executed or has been executing if still 
Active.

End Time Batch job end time.

Event ID SAP event that triggered the job to execute.

Executing Server Server name.

Job ID Job ID assigned by SAP to this instance of job execution.

Job Name Name of the SAP job.

Scheduled Start Time Time the job is scheduled to start.

Start Time Batch job start time.

Status Current state of the job:

• R – Running or Active

• Y – Ready

• P – Scheduled

• S – Released

• A – Aborted or Canceled

• F – Finished or Completed

• Z – Put Active

• X – Unknown State

Step Count Number of steps in the job.

Target Server The SAP application server where the job executed.

Target Server Group Server group name background processing.
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SM37 – Delete Background Job Method Results

The SM37 - Delete Background Job method results page indicates whether the job was successfully 
deleted. The Results text box displays either Success or Failed.

SM37 – Get Active Job Duration Method Results

The SM37 – Get Active Job Duration method results page displays the jobs specified in the input table 
that are currently running along with their current duration. The RFC method returns a table with the 
following columns:

SM37 – Get Job Instance Information Method Results

The SM37 – Get Job Instance Information method results page displays all data associated with a 
specific instance of an SAP job execution. The RFC method returns a table with the following columns

:

Target System Target system to run background job.

User Authority Name Background user name for authorization check.

Work Process ID Operating system PID of the SAP work process that executed 
the job.

Work Process Number Number of SAP work processes that executed the job on the 
application server.

Column Description

Column Description

Duration Seconds Amount of time, measured in seconds, that the job has been 
in the active state

Server SAP application server where the job is executing

Work Process Number Number of the work process on the SAP application server 
where the job is executing

Work Process ID Operating system PID of the SAP work process executing the 
job

User SAP user that executed the job

Column Description

Job ID Job ID assigned by SAP to this instance of job execution

Last Change User User that last modified the job

Scheduled Start Date Date the SAP job is scheduled to execute

Scheduled Start Time Time the SAP job is scheduled to execute

Work Process Number SAP application server work process number that executed 
the job

Work Process ID SAP application server operating system process ID (PID) 
that executed the job.
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SM37 – Get Job Step Info Method Results

The SM37 – Get Job Step Info method results page displays the job steps for an SAP job. The RFC 
method returns a table with the following columns:

SM37 – Jobs Waiting Method Results

The SM37 – Jobs Waiting method results page displays all SAP jobs currently waiting for execution for 
a specified date. The RFC method returns a table with the following columns:

Target Server Server that is scheduled to execute the SAP job

Status Status of the job

Event ID SAP event that is associated with this job

Step Count Number of job steps in this SAP job

Job Group SAP job group to which this job belongs

Column Description

Column Description

Date/Time Date and time the job step executed

StartDate Date the job step executed

StartTime Time the job step executed

JobRunTime Time the SAP job to which this job step belongs ran

Program Program name executed by this job step

JobStep Step number for this job step

JobName Name of the SAP job

JobID Job ID assigned by SAP to this instance of job execution

JobUser SAP user that created the job

Duration Amount of time, measured in seconds, it took for this job step 
to execute

Column Description

Job Name Name of the SAP job

Job ID Job ID assigned by SAP to this instance of job execution

Release Date Date the job was released for execution

Release Time Time the job was released for execution

Release User User that released the job for execution

Work Process Number Number of SAP work processes that executed the job on the 
application server

Work Process ID Operating system PID of the SAP work process that executed 
the job

Target Server SAP application server where the job executed
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SM37 – Read Job Log Method Results

The SM37 – Read Job Log method results page displays the job log for an SAP job identified by a job 
name and job ID. The RFC method returns a table with the following columns:

SM37 – Resume Jobs Method Results

The SM37 - Resume Jobs method results page displays indicates whether the suspended jobs were 
successfully restarted. The Results text box displays either Success or Failed.

SM37 – Simple Job Selection Method Results

The SM37 – Simple Job Selection method results page displays the list of all SAP jobs for a defined time 
period that match the defined criteria. The RFC method returns a table with the following columns:

Status Current state of the job:

• R – Running or Active

• Y – Ready

• P – Scheduled

• S – Released

• A – Aborted or Canceled

• F – Finished or Completed

• Z – Put Active

• X – Unknown State

Event ID SAP event that triggered the job to execute

Column Description

Column Description

Date Date and time the entry was written to the log

Program Name of the SAP program that wrote the log entry

Type Type of message written to the log

Message The ID of the message written to the log (used for 
localization)

Text The actual text of the message written to the log

Column Description

Job Name Name of the SAP job

Job ID Job ID assigned by SAP to this instance of job execution

Schedule Job Date Date the job was created

Schedule Job Time Time the job was created

Schedule Job User User that created the job
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SM37 – Start or Restart a Background Job Method Results

The SM37 – Start or Restart a Background Job method lists all SAP jobs that have started or restarted 
as part of a maintenance or administrative process such as a system refresh The RFC method returns a 
table with the following columns:

Last Change Date Date the job was last modified

Last Change Time Time the job was last modified

Last Change User User that last modified the job

Start Date Date the job started execution

Start Time Time the job started execution

Duration (sec.) Amount of time the job executed or has been executing if still 
Active

Release Date Date the job was released for execution

Release Time Time the job was released for execution

Release User User that released the job for execution

Scheduled Start Date Date the job is scheduled to start

Scheduled Start Time Time the job is scheduled to start

Work Process Number Number of SAP work processes that executed the job on the 
application server

Work Process ID Operating system PID of the SAP work process that executed 
the job

Target Server The SAP application server where the job executed

Status Current state of the job:

• R – Running or Active

• Y – Ready

• P – Scheduled

• S – Released

• A – Aborted or Canceled

• F – Finished or Completed

• Z – Put Active

• X – Unknown State

Event ID SAP event that triggered the job to execute

Step Count Number of steps in the job

Column Description

Column Description

Job name Name of the SAP job

Job ID Job ID assigned by SAP to this instance of job execution

Target server Target server for the job
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SM37 – Suspend Jobs Method Results

The SM37 - Suspend Jobs method results page displays indicates whether the jobs were successfully 
suspended. The Results text box displays either Success or Failed.

SM50 – Analyze Long Running Processes Method Results

The SM50 – Analyze Long Running Processes method results page displays the results for long running 
processes on the specified SAP application server. The RFC method returns True if one or more work 
processes of the specified type have been executing longer than the time period specified.  Otherwise, 
the RFC method returns False.

SM50 – Work Process Overview Method Results

The SM50 – Work Process Overview method results page displays the current state of the SAP work 
processes on the selected application server. The RFC method returns a table with the following 
columns:

Column Description

Server The SAP application server where the work process is 
executing

Number The internal ID number of the work process (used to identify 
messages belonging to this work process in the system log)

Type The type of work process. The following values are possible:

• DIA – Work process for executing dialog steps in user 
transactions

• UPD – Update process for making time critical database 
updates

• ENQ – Work process for locking and releasing SAP 
objects and documents

• BGD – Work process for executing background 
processes

• SPO – Work process for executing print spool requests

PID Operating system process ID of the work process

Restart Indicates whether the process will automatically restart if a 
process ends prematurely. You can change the restart status of 
a process by selecting Process>Restart after error>Yes/No. 
You should normally leave Restart set to Yes.

Errors The number of times the work process has aborted
13-185
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 13      Using SAP Adapters
  SAP RFC Adapter
SM51 – Dispatcher Queue Method Results

The SM51 – Dispatcher Queue method results page displays statistics related to dispatching requests to 
SAP work processes. The RFC method returns a table with the following columns:

Status Current status of the work process. The following values are 
possible:

• Running – The work process is currently executing a 
request

• Waiting – The work process is idle and waiting for a 
work request

• Hold – The work process is being held for a single user. 
This is not an abnormal state. However, if too many work 
processes are in the hold state, system performance 
suffers. Refer to the Waiting column to determine why 
the work process is being held.

• Stopped – Work process aborted with Restart set to No

Waiting Indicates the reason the work process is in a Hold status

User User ID currently executing a request on the work process

Client SAP client number where the user is logged in

CPU Time Cumulative CPU time since the start of a work process (time 
units are seconds and hundredths of seconds)

Elapsed Time Indicates the elapsed time used by a work process for the 
dialog step that it is currently processing

Program ABAP program or report that is currently being executed

Action Action that is being executed by the current program. The 
actions displayed are recorded by the SAP Performance 
Monitor. The Performance Monitor must be active.

Table If the database is being accessed, this column shows the name 
of the table being accessed

Column Description

Column Description

Request Type Type of SAP work process requested

Waiting Requests Number requests waiting to be dispatched to a work process

Maximum Number Requests 
Since Instance Started

Maximum number of requests in queue since the instance started

Maximum Number Requests 
Possible for Each Queue

Maximum capacity of requests configured for the queue

Requests Written Number of requests written to queue since the instance started

Requests Read Number of requests read from queue since the instance started
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SM51 – Server List Method Results

The SM51 – Server List method results page displays the current status of the application servers on an 
SAP system. The RFC method returns a table with the following columns:

SM58 – Delete All tRFC Messages Method Results

The SM58 - Delete All tRFC Messages method results page indicates whether the messages were 
successfully deleted. The Results text box displays either Success or Failed.

SM58 – Execute LUW Method Results

The SM58 - Execute LUW method results page displays whether the LUW was executed. The RFC 
method returns Success or Fail in the Result text box.

SM58 – RFC Transaction Call Status Method Results

The SM58 – Status of RFC Transactional Calls method results page displays RFC calls for a selected 
time period. The RFC method returns a table with the following columns:

SM59 – Delete RFC ABAP Connection Method Results

The SM59 - Delete RFC ABAP Connection method results page indicates whether the ABAP destination 
was successfully deleted. The Results text box displays either Success or Failed.

Column Description

Server Name SAP application server name (hostname_SID_SYSNO)

Host Name Machine host name

Status Current status of the SAP application server

Column Description

Caller SAP user that initiated the RFC call

Function Module SAP function module called

Target System SAP system ID (SID) that was called

Date Date the RFC call was made

Time Time the RFC call was made

Error Text Text describing any error that occurred

Transaction ID Internal transaction ID assigned by SAP

Host Host name of application server making the RFC call

TCode SAP transaction code making the RFC call

Program SAP program making the RFC call

Client SAP client that the user is logged into that is making the RFC 
call
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SM59 – Delete RFC HTTP Connection to ABAP System Method Results

The SM59 - Delete RFC HTTP Connection to ABAP System method results page indicates whether the 
HTTP connection was successfully deleted. The Results text box displays either Success or Failed.

SM59 – Delete RFC HTTP Connection to External Server Method Results

The SM59 - Delete RFC HTTP Connection to External Server method results page indicates whether the 
HTTP connection was successfully deleted. The Results text box displays either Success or Failed.

SM59 – Delete RFC TCP/IP Connection Method Results

The SM59 - Delete RFC TCP/IP Connection method results page indicates whether the TCP/IP 
connection was successfully deleted. The Results text box displays either Success or Failed.

SM59 – Get RFC Connection Info Method Results

The SM59 - Get RFC Connection Info method results page displays data retrieved from the specified 
RFC destination.

SM59 – HTTP Connection Test Method Results

The SM59 – HTTP Connection Test method results page displays HTTP destinations tested on a 
specified server. The RFC method returns a table with the following columns:

SM59 – List ABAP Connections Method Results

The SM59 - List ABAP Connections method results page displays the ABAP RFC destinations.

Column Description

Client Logon client number for the destination

Description Description of the destination

Group Name of the logon group for the destination

GW Host Name of the gateway host for the destination

GW Service Name of the gateway service for the destination

Path Prefix Service path prefix

Column Description

Source SAP application server where the test originated

Destination Name of the HTTP destination tested

Host Host name of the destination

Service Service used for the destination

Path Path prefix in SAP for the destination

Status Status of HTTP connection test (Succeeded or Failed)
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SM59 – List HTTP Connections to ABAP System Method Results

The SM59 - List HTTP Connections to ABAP System method results page displays the HTTP 
connections to the ABAP System.

Column Description

Destination Name Name of the ABAP destination

Description Description of the ABAP destination

System ID SAP System ID

System Number SAP System Number

Target Host Target host of the ABAP destination

Logon Group Logon group

Language Logon language

Client Logon client

User Logon user

MDMP Settings Target system uses Multiple Display Multiple Processing (MDMP) 
to dynamically use the necessary code-page based on the login 
language.

RFC Unicode Target system for the RFC connection is a Unicode-based system.

Same User Logon user to be used is the current logon user that is invoking the 
RFC call from the ABAP runtime environment.

Trusted System Target system is a trusted system.

Column Description

Destination Name Name of the HTTP connection to the ABAP system

Description Description of the new HTTP connection

Service Number HTTP service port number

Target Host Target host of the HTTP connection

Path Prefix HTTP service path prefix

Language Logon language

Client Logon client

User Logon user

Proxy Host New proxy host

Proxy Service New proxy service

Proxy User New proxy user

SSL Indicates SSL protocol (HTTPS)

Logon Method Method used to logon
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SM59 – List HTTP Connections to External Server Method Results

The SM59 - List HTTP Connections to External Server method results page displays the HTTP 
connections to external servers.

SM59 – List TCP/IP Connections Method Results

The SM59 - List TCP/IP Connections method results page displays all the TCP/IP destinations.

Column Description

Destination Name Name of the HTTP connection to the external server

Description Description of the new HTTP connection

Service Number HTTP service port number

Target Host Target host of the HTTP connection

Path Prefix HTTP service path prefix

Language Logon language

Client Logon client

User Logon user

Proxy Host New proxy host

Proxy Service New proxy service

Proxy User New proxy user

SSL Indicates SSL protocol (HTTPS)

Logon Method Method used to logon

Column Description

Destination Name Name of the TCP/IP destination

Description Description of the TCP/IP destination

Method TCP/IP communication method:

• A = Start on Application Server

• E = Start on Explicit Host

• F = Start on Front-End Workstation

• R = Registered Server Program

Program ID Program ID used to execute TCP/IP communication method

Target Host Target host of the TCP/IP destination

Gateway Host Gateway host

Gateway Service Gateway service
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SM59 – Modify RFC ABAP Connection Method Results

The SM59 - Modify RFC ABAP Connection method results page indicates whether the ABAP 
connection was successfully updated. The Results text box displays either Success or Failed.

SM59 – Modify RFC HTTP Connection to ABAP System Method Results

The SM59 - Delete RFC HTTP Connection to ABAP System method results page indicates whether the 
HTTP connection was successfully deleted. The Results text box displays either Success or Failed.

SM59 – Modify RFC HTTP Connection to External Server Method Results

The SM59 - Modify RFC HTTP Connection to External Server method results page indicates whether 
the HTTP connection was successfully updated. The Results text box displays either Success or Failed.

SM59 – Modify RFC TCP/IP Connection Method Results

The SM59 - Modify RFC TCP/IP Connection method results page indicates whether the TCP/IP 
connection was successfully updated. The Results text box displays either Success or Failed.

SM59 – RFC Connection Test Method Results

The SM59 – RFC Connection Test method results page displays RFC destinations on a specified server. 
The RFC method returns a table with the following columns:

SM61 – Assign Server Method Results

The SM61 - Assign Server method results page indicates whether the server was successfully assigned. 
The Results text box displays either Success or Failed.

Start Type Start type:

• 0 = Default Gateway Value

• 1 = Remote Shell

• 2 = Remote Execution

• 4 = Secure Shell

Return Message Message returned from the RFC call

RFC Unicode Target system for the RFC connection is a Unicode-based 
system.

Column Description

Column Description

Source SAP application server where the test originated

Destination Name of the RFC destination tested

Connection Type Status of RFC connection

Source SAP application server where the test originated

Internal Connection Response time of connection test
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SM61 – Get Server List Method Results

The SM61 - Get Server List method results page displays a list of source system background servers that 
were retrieved as part of a system refresh.

SM61 – List Active Background Servers Method Results

The SM61 - List Active Background Servers method results page displays a list of all active application 
servers that are running background work processes.

SM61 – Remove Server Method Results

The SM61 - Remove Server results page indicates whether the source system background server was 
successfully removed. The Results text box displays either Success or Failed.

SM66 – Global Work Process Activity Detail Method Results

The SM66 – Global Work Process Activity Detail method results page displays the current activity in 
the available work processes on all servers of a single SAP ABAP system.

Column Description

Application Server Name of the SAP application server that is included in the specified server 
group

Column Description

Server Name Name of the SAP application server that is active and running 
background work processes

Column Description

Action Action that is being executed by the current program. The actions 
displayed are recorded by the SAP Performance Monitor 
(Performance Monitor must be active)

Client SAP client number where the user is logged in

CPU Cumulative CPU time since the start of a work process (time units 
are seconds and hundredths of seconds)

Current Memory Extended memory.

Dialog Step Screen Number Screen number or transaction name.

Dialog Step Start Date Start date for dialog step.

Err Number of times the work process has aborted

Number Unique work process number on the server.

PID Operating system process ID of the work process

Private Memory Heap (private) memory.

Reason Reason the work process is in a Hold status

Report ABAP program or report that is currently being executed
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SM66 – Global Work Process Overview Method Results

The SM66 – Global Work Process Overview method results page displays SAP work processes that are 
currently processing user requests across all SAP application servers. The RFC method returns a table 
with the following columns:

Se Indicates the number of the semaphore for which a work process is 
waiting

Server SAP application server host name where the work process is 
executing.

Start Indicates whether the process will automatically restart if a process 
ends prematurely. You can change the restart status of a process by 
selecting Process>Restart after error>Yes/No. You should normally 
leave Restart set to Yes.

Status Current status of the work process. The following values are 
possible:

• Running – The work process is currently executing a request

• Waiting – The work process is idle and waiting for a work 
request

• Hold – The work process is being held for a single user. This is 
not an abnormal state. However, if too many work processes are 
in the hold state, system performance suffers. Refer to the 
Waiting column to determine why the work process is being 
held.

• Ended – Work process aborted with Restart set to No

Table Database table last accessed by the work process.

Time Indicates the elapsed time used by a work process for the dialog step 
that it is currently processing

Type The type of work process. The following values are possible:

• DIA – Dialog

• BTC – Batch

• ENQ – Enqueue

• SPO – Spool

• UPD – Update

• UP2 – Delayed update

User User ID currently executing a request on the work process

Wait Time Time when waiting started.

Column Description

Column Description

Server The SAP application server where the work process is executing

Number The internal ID number of the work process (used to identify messages 
belonging to this work process in the system log)
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SMGW – Gateway Monitor Method Results

The SMGW – Gateway Monitor method results page displays the current status of SAP gateway 
communications. The RFC method returns a table with the following columns:

Type The type of work process. The following values are possible:

• DIA – Work process for executing dialog steps in user transactions

• UPD – Update process for making time critical database updates

• UP2 – Update process for making non-time critical database 
updates

• ENQ – Work process for locking and releasing SAP objects and 
documents

• BGD – Work process for executing background processes

• SPO – Work process for executing print spool requests

PID Operating system process ID of the work process

Status Current status of the work process. The following values are possible:

• Running – The work process is currently executing a request

• Waiting – The work process is idle and waiting for a work request

• Hold – The work process is being held for a single user. This is not 
an abnormal state. However, if too many work processes are in the 
hold state, system performance suffers. Refer to the Waiting column 
to determine why the work process is being held.

• Ended – Work process aborted with Restart set to No

Reason Reason the work process is in a Hold status

Se Indicates the number of the semaphore for which a work process is 
waiting

Start Indicates whether the process will automatically restart if a process ends 
prematurely. You can change the restart status of a process by selecting 
Process>Restart after error>Yes/No. You should normally leave Restart 
set to Yes.

Err Number of times the work process has aborted

CPU Cumulative CPU time since the start of a work process (time units are 
seconds and hundredths of seconds)

Time Indicates the elapsed time used by a work process for the dialog step that 
it is currently processing

Client SAP client number where the user is logged in

User User ID currently executing a request on the work process

Report ABAP program or report that is currently being executed

Action Action that is being executed by the current program. The actions 
displayed are recorded by the SAP Performance Monitor (Performance 
Monitor must be active).

Table Name of the table being accessed, if the database is being accessed

Column Description
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SMICM – ICM Monitor Method Results

The SMICM – ICM Monitor method results page displays the current status of the SAP Internet 
Communication Manager, which sends and receives requests to and from the Internet. The RFC method 
returns a table with the following columns:

SMLG – Change Assignments Method Results

The SMLG - Change Assignments method results page indicates whether the servers were successfully 
changed to logon group assignments. The Results text box displays either Success or Failed.

SMLG – Create Assignment Method Results

The SMLG - Create Assignment method results page indicates whether the server logon group 
assignment was successfully created. The Results text box displays either Success or Failed.

Column Description

Number Connection ID number

LU Name Logical Unit name

TP Name Name of the transaction program started by the gateway

User SAP user that is using the connection

Symbolic Destination Name that identifies a CPIC connection

Conversation ID Unique number to identify a connection instance

Protocol Protocol agreed to be used with the client:

• R2PR – R/2 presentation

• INT – Internal communication

• EXT – External communication

• REG – External communication with registered program

• CPIC – CPI-C communication

• NE – External communication gateway not used for start

Last Request Time of last request activity

SAP Error SAP program error

CPIC Error Communication error

Column Description

No. Connection thread number

Thread ID Operating system process ID (PID) of the connection thread

Number Number of request made on the connection thread

Status Current status of the thread (Available or Running)

Processed Request Number of requests processed by this thread
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SMLG – Create Assignments Method Results

The SMLG - Create Assignments method results page indicates whether the server logon group 
assignments were successfully created. The Results text box displays either Success or Failed.

SMLG – Delete All Assignments Method Results

The SMLG - Delete All Assignments results page indicates whether all logon group assignments were 
successfully deleted. The Results text box displays either Success or Failed.

SMLG – Delete Assignment Method Results

The SMLG - Delete Assignment results page indicates whether the specified logon group assignment 
was successfully deleted. The Results text box displays either Success or Failed.

SMLG – Get Assignments-Setup Method Results

The SMLG - Get Assignments-Setup results page displays a data table of servers with group 
assignments.

SMLG – Get Assignments - eRFC Setup Method Results

The SMLG - Get Assignments - eRFC Setup results page displays a data table of servers with group 
assignments.

SMLG – Remove Lock Method Results

The SMLG - Remove Lock results page indicates whether an enqueue lock was successfully removed 
from the server group table. The Results text box displays either Success or Failed.

Column Description

Logon/Server Group 
Name

Name of the group

Instance Name Name of the SAP server instance

Group Type Type of group (Logon or Server)

IP Address IP address for the SAP server

Response Time Response time for the server

Number of Users Number of users within the logon or server group

Max Number of WPs Maximum number of work processes

Option Mode Multi-purpose logon or server group

Column Description

Group ID Identification value assigned to the group

Logon Group Time Interval Logon group time interval in minutes

Favorite Method of 
Determination of Servers

Method used to determine the servers (Best Performance, Round 
Robin, According to Probability or Weighted Round Robin)
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SMLG – Set Lock Method Results

The SMLG - Set Lock results page indicates whether an enqueue lock was successfully set on the server 
group table. The Results text box displays either Success or Failed.

SMQ1 – Activate qRFC Outbound Queue Method Results

The SMQ1 - Activate qRFC Outbound Queue method results page displays the queues that were 
activated.

SMQ1 – Delete All qRFC Outbound Queues Method Results

The SMQ1 - Delete All qRFC Outbound Queues method results page indicates whether the qRFC 
outbound queues were successfully deleted. The Results text box displays either Success or Failed.

SMQ1 – Delete qRFC Outbound Queue Method Results

The SMQ1 - Delete qRFC Outbound Queue method results page indicates whether the qRFC outbound 
queues were successfully deleted. The Results text box displays either Success or Failed.

SMQ1 – Lock qRFC Outbound Queue Method Results

The SMQ1 - Lock qRFC Outbound Queue method results page displays the list of keys with the Lock 
status in the Lock Key field.

SMQ1 – Unlock qRFC Outbound Queue Method Results

The SMQ1 - Unlock qRFC Outbound Queue method results page displays the list of keys with the Lock 
status.

SMQ1 – qRFC Monitor Outbound Queue Method Results

The SMQ1 – qRFC Monitor Outbound Queue method results page displays a list of all queued remote 
function calls (RFCs) that could not be successfully completed, or that had to be scheduled as 
background jobs. The RFC method returns a table with the following columns:

Column Description

EXELUW Executed logical unit of work

ASTATE State of the key

Column Description

EXELUW Executed logical unit of work

ASTATE State of the key

Column Description

Client SAP client to which the queue is assigned

Queue Name Name of the tRFC queue
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Destination RFC destination specified in the function call

Date Date the RFC call was executed

Time Time the RFC call was executed

Status Status of the RFC call

The following statuses are immediately identified as blocking:

• CPICERROR – During transmission or processing of the first 
LUW in the target system, a network or communication error 
occurred. For more information on this error, see the syslog 
(SM21), the trace files dev_rd or dev_rfc*. Depending on the 
definition in transaction SM59 for the destination used, a batch 
job is scheduled for subsequent sending.

• SYSFAIL – A serious error occurred in the target system while 
the first LUW of this queue was executed. For more information 
on this error, see the corresponding short dump in the target 
system (ST22).

• STOP – On this queue or a generic queue (for example BASIS_*) 
a lock was set explicitly (SMQ1 or programs). Note that the 
processing of qRFC never locks a queue. After having informed 
the corresponding application, you can unlock and activate this 
queue using transaction SMQ1.

• EXECUTED – The first LUW of this queue has been processed. 
The system waits for a qRFC-internal confirmation from the 
target system before processing further LUWs. If a queue in this 
status hangs for more than 30 minutes, this may mean that the 
work process responsible for sending this LUW has been 
terminated. In contrast to status RUNNING, this current LUW 
has definitely been executed successfully. You can reactivate this 
queue without any problems. The qRFC Manager will 
automatically delete the LUW already executed and send the next 
LUW.

• NOSEND – LUWs of this queue are retrieved by a special 
application. NOSEND queues are only used internally at SAP for 
communication between components BW or CRM with Mobile 
Clients. Even if an LUW has been read by the corresponding 
application (BW, CRM), the NOSEND status does not change. 
The LUW is only deleted from the queue once the application 
confirms collection (collective confirmation possible). Under no 
circumstances should the NOSEND status be reset using 
transaction SMQ1 and the queue activated.

• NOEXEC – This status is set if the queue is waiting for 
debugging.

Status Text Descriptive error text if error occurred

User SAP user that made the RFC call

Function SAP function module called by the RFC

Transaction ID Internal transaction ID assigned by SAP to this RFC transaction

Column Description
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SMQ2 – Activate qRFC Inbound Queue Method Results

The SMQ2 -Activate qRFC Inbound Queue method results page displays the list of stopped inbound 
queues to be activated.

SMQ2 – Delete All qRFC Inbound Queues Method Results

The SMQ2 - Delete qRFC Inbound Queues method results page indicates whether the qRFC inbound 
queues were successfully deleted. The Results text box displays either Success or Failed.

SMQ2 – Delete qRFC Inbound Queue Method Results

The SMQ2 - Delete  qRFC Inbound Queue method results page displays the list of stopped inbound 
queues to be deleted.

SMQ2 – Lock qRFC Inbound Queue Method Results

The SMQ2 - Lock qRFC Inbound Queue method results page displays the list of keys with the Lock 
status in the Lock Key field.

SMQ2 – Unlock qRFC Inbound Queue Method Results

The SMQ2 -Unlock qRFC Outbound Queue method results page displays the inbound queues with the 
Lock status.

SMQ2 – qRFC Monitor Inbound Queue Method Results

The SMQ2 – qRFC Monitor Inbound Queue method results page displays a list of all queued remote 
function calls (RFCs) that could not be successfully completed, or that had to be scheduled as 
background jobs. The RFC method returns a table with the following columns:

Host Host name of SAP application server making the RFC call 
(applicable only to calls in an Error state)

TCode SAP transaction code making the RFC call. Applicable only to calls 
in an Error state

Program SAP program making the RFC call. Applicable only to calls in an 
Error state

Column Description

Column Description

EXELUW Executed logical unit of work

ASTATE State of the key

Column Description

EXELUW Executed logical unit of work

ASTATE State of the key
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Column Description

Client SAP client to which the queue is assigned

Queue Name Name of the tRFC queue

Destination RFC destination specified in the function call

Date Date the RFC call was executed

Time Time the RFC call was executed

Status Status of the RFC call

The following statuses are immediately identified as blocking:

• CPICERROR – During transmission or processing of the first 
LUW in the target system, a network or communication error 
occurred. For more information on this error, see the syslog 
(SM21), the trace files dev_rd or dev_rfc*. Depending on the 
definition in transaction SM59 for the destination used, a batch job 
is scheduled for subsequent sending.

• SYSFAIL – A serious error occurred in the target system while the 
first LUW of this queue was executed. For more information on 
this error, see the corresponding short dump in the target system 
(ST22).

• STOP – On this queue or a generic queue (for example BASIS_*) 
a lock was set explicitly (SMQ1 or programs). Note that the 
processing of qRFC never locks a queue. After having informed 
the corresponding application, you can unlock and activate this 
queue using transaction SMQ1.

• ANORETRY – During the LUW execution, the application has 
found a serious error and prompted the qRFC Manager via a 
specific qRFC call to cancel processing of this LUW.

• WAITSTOP – The first LUW of this queue has dependencies to 
other queues, and at least one of these queues is currently still 
locked.

• ARETRY – During LUW execution the application has diagnosed 
a temporary problem and has prompted the qRFC Manager in the 
sending system via a specific qRFC call to schedule a batch job for 
a repetition based on the definition in transaction SM59.

The following statuses are identified as blocking if they remain 
unchanged for more than 30 minutes:

• READY – The queue is ready for transmission. This status should 
only be a temporary status. However, in the following case this 
status can also be permanent: A queue has been locked manually 
via transaction SMQ1 or via a program, and then unlocked without 
being activated at the same time. This queue must be activated 
explicitly.
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• RUNNING – The first LUW of this queue is currently being 
processed. If a queue in this status hangs for more than 30 minutes, 
this may mean that the work process responsible for sending this 
LUW has been terminated. In this case you can activate this queue 
again.  Note that activating a queue in status RUNNING may 
cause a LUW to be executed several times if this LUW is still 
being processed in the target system at that time. A waiting time 
of at least 30 minutes before reactivating the queue is 
recommended.

• WAITUPDA – This status is set if qRFC is called within a 
transaction that also contains one or more update functions. As a 
result of this status, the LUW and thus the queue is blocked until 
the update has been completed successfully. If this status takes 
longer than a few minutes, check the status of the update or the 
update requests using transaction SM13. After a successful 
retroactive update, the blocked LUW is sent automatically. You 
can reset this status in the qRFC Monitor SMQ1, and reactivate the 
queue. Note that this can lead to possible inconsistencies in the 
application data between the two systems.

• EXECUTED – The first LUW of this queue has been processed. 
The system waits for a qRFC-internal confirmation from the target 
system before processing further LUWs. If a queue in this status 
hangs for more than 30 minutes, this may mean that the work 
process responsible for sending this LUW has been terminated. In 
contrast to status RUNNING, this current LUW has definitely 
been executed successfully. You can reactivate this queue without 
any problems. The qRFC Manager will automatically delete the 
LUW already executed and send the next LUW.

• NOSEND – LUWs of this queue are retrieved by a special 
application. NOSEND queues are only used internally at SAP for 
communication between components BW or CRM with Mobile 
Clients. Even if an LUW has been read by the corresponding 
application (BW, CRM), the NOSEND status does not change. 
The LUW is only deleted from the queue once the application 
confirms collection (collective confirmation possible). Under no 
circumstances should the NOSEND status be reset using 
transaction SMQ1 and the queue activated.

Status Text Descriptive error text if error occurred

User SAP user that made the RFC call

Function SAP function module called by the RFC

Transaction ID Internal transaction ID assigned by SAP to this RFC transaction

Original TID SAP transaction ID of the original transaction

Host Host name of SAP application server making the RFC call (applicable 
only to calls in an Error state)

Column Description
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SMQ3 – qRFC Monitor Saved Inbound Queue Method Results

The SMQ3 – qRFC Monitor Saved Inbound Queue method results page displays a list of inbound qRFC 
(with saved queues) calls in error state. The RFC method returns a table with the following columns:

SMQR – Register Inbound Queue Method Results

The SMQR - Register Inbound Queue method results page indicates whether the inbound queue was 
successfully registered. The Results text box displays either Success or Failed.

SMQR – Reorganize qRFC Inbound Monitor Method Results

The SMQR - Reorganize qRFC Inbound Monitor method results page indicates whether the qRFC 
inbound monitor was successfully reorganized. The Results text box displays either Success or Failed.

SMQR – Unregister Inbound Queue Method Results

The SMQR - Unregister Inbound Queue method results page indicates whether the inbound queue was 
successfully unregistered. The Results text box displays either Success or Failed.

SMQR – qRFC Monitor (QIN Scheduler) Method Results

The SMQR – qRFC Monitor (QIN Scheduler) method results page displays the management properties 
of the qRFC inbound scheduler, including scheduler status and inbound queues processed. The RFC 
method returns a table with the following columns:

TCode SAP transaction code making the RFC call. Applicable only to calls in 
an Error state

Program SAP program making the RFC call. Applicable only to calls in an Error 
state.

Column Description

Column Description

Client SAP client to which the queue is assigned

Queue Name Name of the RFC queue

Destination RFC destination

Current Loop Logical destination specified in function call

Status Transactional RFC queue condition (see Remarks)

Status Text Transaction RFC error message

First Count Counter for serialized tRFC

Column Description

Client SAP client to which the queue is assigned

Queue Name Name of the RFC queue

Type RFC Destination Registered or Unregistered Queue (R, U)
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SMQS – Register Destination Method Results

The SMQS - Register Destination method results page indicates whether the outbound destination was 
successfully registered. The Results text box displays either Success or Failed.

SMQS – Reorganize qRFC Outbound Monitor Method Results

The SMQS - Reorganize qRFC Outbound Monitor method results page indicates whether the qRFC 
outbound monitor was successfully reorganized. The Results text box displays either Success or Failed.

SMQS – Unregister Destination Method Results

The SMQS - Unregister Destination method results page indicates whether the outbound destination was 
successfully unregistered. The Results text box displays either Success or Failed.

SMQS – qRFC Monitor (QOUT Scheduler) Method Results

The SMQS – qRFC Monitor (QOUT Scheduler) method results page displays the management 
properties of the qRFC outbound scheduler, including scheduler status and outbound queues processed. 
The RFC method returns a table with the following columns:

Mode Executable mode (D = Dialog, B = Batch)

Max. Runtime Maximum runtime of queue

Attempts Retry counter

Pause Delay between two retries

Destination Logical RFC Destination in SM59 to run the LUWs under a specific 
user

Column Description

Column Description

Client SAP client to which the queue is assigned

Destination Logical RFC Destination

Type RFC Destination Registered or Unregistered Queue (R, U)

W/o RFC Indicates if queue is preventing tRFC LUWs from being processed 
by the outbound scheduler

Max. Runtime Maximum scheduler processing time for a destination in seconds 
(default is 60 seconds)
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Status Status of RFC call

The following statuses are immediately identified as blocking:

• CPICERROR – During transmission or processing of the first 
LUW in the target system, a network or communication error 
occurred. For more information on this error, see the syslog 
(SM21), the trace files dev_rd or dev_rfc*. Depending on the 
definition in transaction SM59 for the destination used, a batch 
job is scheduled for subsequent sending.

• SYSFAIL – A serious error occurred in the target system while 
the first LUW of this queue was executed. For more information 
on this error, see the corresponding short dump in the target 
system (ST22).

• STOP – On this queue or a generic queue (for example 
BASIS_*) a lock was set explicitly (SMQ1 or programs). Note 
that the processing of qRFC never locks a queue. After having 
informed the corresponding application, you can unlock and 
activate this queue using transaction SMQ1.

• ANORETRY – During the LUW execution, the application has 
found a serious error and prompted the qRFC Manager via a 
specific qRFC call to cancel processing of this LUW.

• WAITSTOP – The first LUW of this queue has dependencies to 
other queues, and at least one of these queues is currently still 
locked.

• ARETRY – During LUW execution the application has 
diagnosed a temporary problem and has prompted the qRFC 
Manager in the sending system via a specific qRFC call to 
schedule a batch job for a repetition based on the definition in 
transaction SM59.

The following statuses are identified as blocking if they remain 
unchanged for longer than 30 minutes:

• READY – The queue is ready for transmission. This status 
should only be a temporary status. However, in the following 
case this status can also be permanent: A queue has been locked 
manually via transaction SMQ1 or via a program, and then 
unlocked without being activated at the same time. This queue 
must be activated explicitly. 

• RUNNING – The first LUW of this queue is currently being 
processed. If a queue in this status hangs for more than 30 
minutes, this may mean that the work process responsible for 
sending this LUW has been terminated. In this case you can 
activate this queue again.  Note that activating a queue in status 
RUNNING may cause a LUW to be executed several times if 
this LUW is still being processed in the target system at that 
time. A waiting time of at least 30 minutes before reactivating 
the queue is recommended.

Column Description
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SMT1 – Add Trusted System Method Results

The SMT1 - Add Trusted System method results page displays whether the trusted system was 
successfully added. The Results page displays Success or Failed.

SMT1 – Get Trusted Systems Method Results

The SMT1 - Get Trusted Systems method results page displays the permitted trusted systems that are 
stored in SAP database table RFCSYSACL

• WAITUPDA – This status is set if qRFC is called within a 
transaction that also contains one or more update functions. As 
a result of this status, the LUW and thus the queue is blocked 
until the update has been completed successfully. If this status 
takes longer than a few minutes, check the status of the update 
or the update requests using transaction SM13. After a 
successful retroactive update, the blocked LUW is sent 
automatically. You can reset this status in the qRFC Monitor 
SMQ1, and reactivate the queue. Note that this can lead to 
possible inconsistencies in the application data between the two 
systems.

• EXECUTED – The first LUW of this queue has been processed. 
The system waits for a qRFC-internal confirmation from the 
target system before processing further LUWs. If a queue in 
this status hangs for more than 30 minutes, this may mean that 
the work process responsible for sending this LUW has been 
terminated. In contrast to status RUNNING, this current LUW 
has definitely been executed successfully. You can reactivate 
this queue without any problems. The qRFC Manager will 
automatically delete the LUW already executed and send the 
next LUW.

Connection Unused

Host ID SAP system name of logical destination specified in function call

Column Description

Column Description

Check RFC User Indicates whether user was validated.

Check Transaction Code Indicates whether to transaction code was checked.

HTTP SSL Indicates whether SSL communication is enabled.

Logon Group Logon group for load balancing mode.

No Display in Server List Indicates whether to display in the trusted system list.

Password Check Indicates whether the password check for RFC single login is 
enabled.

RFC Credentials Destination Logical destination for credentials check.

RFC Destination Logical destination for the system.

RFC Registration Destination Logical destination for registration.
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SMT1 – Modify Trusted System Method Results

The SMT1 - Modify Trusted System method results page displays whether the trusted system was 
successfully updated. The Results page displays Success or Failed.

SMT1 – Remove Trusted System Method Results

The SMT1 - Remove Trusted System method results page displays whether the trusted system was 
successfully removed. The Results page displays Success or Failed.

SMT2 – Add Trusting System Method Results

The SMT2 - Add Trusting System method results page displays whether the trusting system was 
successfully set. The Results page displays Success or Failed.

SMT2 – Get Trusting Systems Method Results

The SMT2 - Get Trusting Systems method results page displays the trusting systems that are stored in 
SAP database table RFCTRUST.

SMT2 – Modify Trusting System Method Results

The SMT2 - Modify Trusting System method results page displays whether the trusting system was 
successfully updated. The Results page displays Success or Failed.

SMT2 – Remove Trusting System Method Results

The SMT2 - Remove Trusting System method results page displays whether the trusting system was 
successfully removed. The Results page displays Success or Failed.

Security Key Security key lLogon ticket to trusted system)

Trusted System ID Trusted system (for R/3 and external systems).

Trusted System Name Trusted system name (for R/3 and external systems).

Column Description

Column Description

Hidden Flag Indicates whether system displays in trusting system list.

HTTP SSL Indicates whether SSL communication is enabled.

Logon Group Logon group for load balancing mode.

Message Server Host Name of target host.

RFC Credentials Destination Logical destination for credentials check.

RFC Registration Destination Logical destination for registration.

RFC Trusting System Trusting system name.

Version Version ID for table entry.
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SOA Manager – Read J2EE Admin Server Data Method Results

The SOA Manager - Read J2EE Admin Server Data method results page displays the configuration data 
retrieved from the J2EE administration server.

SOA Manager – Set J2EE Admin Server Method Results

The SOA Manager - Set J2EE Admin Server method results page indicates whether the server 
configuration was successfully updated. The Results text box displays either Success or Failed.

SOST – Delete Mail Method Results

The SOST - Delete Mail method results page indicates whether the emails were successfully deleted 
from the SOST queue. The Results text box displays either Success or Failed.

SOST – Repeat Send Method Results

The SOST - Repeat Send method results page indicates whether the SAP Office transmission requests 
were successfully resent to the queue. The Results text box displays either Success or Failed.

SP01 – Spool Requests Method Results

The SP01 - Spool Requests method results page displays the list of pages sent to be printed are sent to 
the SAP spool system.  The RFC method retrieves the following information:

SP12 – TemSe Data Consistency Check - Delete All Method Results

The SP12 - TemSe Data Consistency Check - Delete All method results page displays the objects that 
were deleted.

Column Description

Host Name Current host name of the J2EE server.

J2EE Password Current user password to access the J2EE server.

J2EE User Current user name to access the J2EE server.

Port Number Current port number to the J2EE server.

Protocol Current protocol being used on the J2EE server.

Column Description

User User who launched the spool

Output Device Device to where spool request was sent

Column Description

Object Name The temporary sequential object name

Client SAP client to which the inconsistent temporary sequential object 
belongs
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SPAD – Assign Server Method Results

The SPAD - Assign Server results page indicates whether the output devices were successfully 
reassigned to a new spool server. The Results text box displays either Success or Failed.

SPAD – Check Consistency Delete All Method Results

The SPAD - Check Consistency Delete All method results page indicates whether the objects were 
successfully deleted. The Results text box displays either Success or Failed.

SPAD – Create Output Device Method Results

The SPAD - Create Output Device results page indicates whether the output device was successfully 
created or modified. The Results text box displays either Success or Failed.

SPAD – Delete Output Device Method Results

The SPAD - Delete Output Device results page indicates whether the output devices were successfully 
deleted. The Results text box displays either Success or Failed.

SPAD – Display Output Devices Method Results

The SPAD - Display Output Devices method results page displays a list of output devices.

SPAD – Export Command Set Method Results

The SPAD - Export Command Set results page displays information about the transport.

Part Sequence Number The part sequence number of the temporary sequential object

Comments Error message (for example: Length = 0, which means that the object 
is inconsistent because of the length being 0)

Column Description

Column Description

Device Long device name

Access Method Method used access host spool system

Message Status message

Column Description

Job ID Job ID of export job (only displays if release option was selected).

Job Name Name of the submitted job (only displays if release option was 
selected).

Transport Number SAP transport (change request) that contains the tables to be 
exported.
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SPAD – Export Device Method Results

The SPAD - Export Device results page indicates whether the devices were successfully exported. The 
Results text box displays either Success or Failed.

SPAD – Get Device Descriptions Method Results

The SPAD - Get Device Descriptions results page displays a list of devices and their descriptions.

SPAD – Import Device Method Results

The SPAD - Import Device results page displays whether the devices were successfully imported. The 
Results text box displays either Success or Failed.

ST02 – Get Buffer Tune Summary Method Results

The ST02 – Get Buffer Tune Summary method results page displays the statistics for the selected SAP 
application buffer. The RFC method retrieves the following information:

ST02 – Get Memory Usage Method Results

The ST02 – Get Memory Usage method results page displays details about SAP memory management. 
The RFC method returns a table with the following columns:

Column Description

Buffer Name of the buffer

Hit Ratio % Percentage of time data is retrieved from the buffer instead of the 
database

Allocated KB Allocates size of the buffer

Database Accesses Number of times the database has been accessed

Freespace KB Free space in the buffer expressed in kilobytes

Freespace % Free space in the buffer expressed as a percentage of the allocated 
size

Directory Size Portion of the buffer allocated for directory

Server Name Name of the SAP application server

Swap Number of swaps occurring between the buffer and the database

Column Description

Current Use [%] Amount of memory used expressed as a percent of total 
memory

Current Use [KB] Amount of memory used expressed in kilobytes

Max Use [KB] Maximum utilization of memory since system start
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ST03 – Get Data WebAS 7.0 Method Results

The ST03 – Get Data for WebAS 7.0 method results page displays summarized workload statistics for 
all SAP application servers. The RFC method returns a table with the following columns:

ST03 – Get Hourly Snapshot Data WebAS 7.0 Method Results

The ST03 – Get Hourly Snapshot Data for WebAS 7.0 method results page displays workload statistics 
for a selected SAP application server. The RFC method returns a table with the following columns:

In Memory [KB] How much memory is allocated in shared memory

On Disk [KB] Size of roll or paging file

Column Description

Column Description

Task Type Name Type of SAP work process

# of Steps Number of dialog steps processed during time range

Response Time Average dialog response time during time range

Avg. Proc Time Average time to process ABAP program code during time range

Avg. CPU Time Average CPU time during time range

Avg. DB Time Average database request time during time range

Avg. Wait Time Average time a unit of work had to wait for a work process during 
time range

Avg. Roll In Time Average time to switch a user context into memory

Avg. Roll Wait Time Average wait time until dialog step can continue

Avg. Load + Gen Time Average time to load and compile program source code and GUI 
objects

Avg. Lock Time Average time in Enqueue

Avg. CPIC/RFC Time Average time spent in function calls

Avg. GUI Time Average time to render GUI

# of Roundtrips Number of trips between SAP GUI and application server during 
dialog step

Avg. KB Amount of data requested from database

Column Description

Task Type Name Type of SAP work process

Time Range Hourly period reported

# of Steps Number of dialog steps processed during time range

Response Time Average dialog response time during time range

Avg. Proc Time Average time to process ABAP program code during time range

Avg. CPU Time Average CPU time during time range
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ST03 – Workload Analysis Method Results

The ST03 – Workload Analysis method results page displays workload statistics for an SAP system. The 
RFC method returns a table with the following columns:

ST04 – Get DB6 Log Space Method Results

The ST04 – Get DB6 Log Space method results page displays information about the DB6 log space 
usage.

STAD – Workload Statistical Records Method Results

The STAD – Workload Statistical Records method results page displays the workload details for SAP 
transactions matching selected criteria. The RFC method returns a table with the following columns:

Avg. DB Time Average database request time during time range

Avg. DB Procedure Time Average time to process database procedures during time range

Avg. Wait Time Average time a unit of work had to wait for a work process during 
time range

Avg. Roll Wait Time Average time to bring user context into memory during time range

Avg. GUI Time Average time to render GUI during time range

Avg. Frontend Network Time Average network time from SAP GUI to application server (one 
way)

# of Round Trips Number of trips between SAP GUI and application server during 
dialog step

Column Description

Column Description

Instance SAP application server

Dialog steps Number of dialog steps processed

Avg. response time (ms) Average dialog response time

Avg. wait time (ms) Average time a unit of work had to wait for a work process

Avg. load time (ms) Average time to load and generate programs

Avg. DB request time (ms) Average database request

Avg. physical DB calls Average number of physical database requests

Avg. Kbyte requested Average data size requested from database

Column Description

Log Percentage Used Percentage of log space used by database.

Log Space Available Log space available for usage by database.

Log Space Used Log spaced used by database.
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STATTRACE—Global Statistics Method Results

The STATTRACE - Global Statistics method results page displays the data that was retrieved from the 
SAP Java stack.

Column Description

Started Me the transaction started

Server SAP application server that executed the transaction

Transaction SAP transaction code associated with the transaction

Program SAP program that was executed by the transaction

T Work process task type that executed the transaction

Scr SAP screen associated with the transaction

Wp SAP work process number that executed the transaction

User SAP user that executed the transaction

Response time (ms) Overall response time of the transaction

Time in WPs (ms) Time the transaction consumed the SAP work process

Wait time (ms) Time the transaction had to wait to be dispatched to a SAP work 
process

CPU time (ms) CPU time consumed by the transaction

DB req. time (ms) Amount of time the transaction waited for the database

Load + Gen time (ms) Amount of time required to load and compile the application 
executed by the transaction

Memory used (kb) Amount of memory used by the transaction

kBytes transferred Amount of data transferred over the network

Column Description

Action Executed transaction.

Component Name Name of the component from which data was retrieved.

CPU Time Step CPU time (ms).

End Time Step end time.

Gen Time Time for generation process (ms).

Load Time Time for load process of step (ms).

Memory Maximum occupied memory during process request (KB).

Net Time Step net time (ms).

Process Id ID of process processing request.

Queue Time Step queue time (ms).

Response Time Step response time (ms).

Start Time Step start time.

System System ID.
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STMS – Activate System Method Results

The STMS - Activate System results page indicates whether the system was successfully activated 
redistributed to the transport domain.. The Results text box displays either Success or Failed.

STMS – Add Transport Request to Import Queue Method Results

The STMS - Add Transport Request to Import Queue results page displays a data table that includes 
information about the transport request and whether it  was successfully added to the TMS import queue.

STMS – Configure Transport Domain Controller Method Results

The STMS - Configure Transport Domain Controller results page indicates whether the transport domain 
controller was successfully configured. The Results text box displays either Success or Failed.

STMS – Delete System from Domain Method Results

The STMS - Delete System from Domain results page indicates whether the system was successfully 
deleted from the domain. The Results text box displays either Success or Failed.

STMS – Distribute Configuration Method Results

The STMS - Distribute Configuration results page indicates whether the TMS configuration was 
successfully distributed. The Results text box displays either Success or Failed.

STMS – Get TMS Configuration Method Results

The STMS - Get TMS Configuration results page displays information about the system's landscape 
configuration after performing a system copy. This method returns information about the Transport 
Management System (TMS) configuration, including whether the system is the domain controller or a 
landscape client system.

Transaction ID SAP transaction ID.

User User name of user logged onto a component.

Wait Time Step wait time (ms).

Column Description

Column Description

System Text Description of the system

Domain Name Name of the TMS domain

Domain Text Description of the TMS domain

Status TMS system status:

• A - Active

• I - Inactive

• D - Deleted

• R - Refused

Domain Controller Text Description of the domain controller system
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STMS – Import Transport Request Method Results

The STMS - Import Transport Request results page indicates whether the transport request to the TMS 
import queue were was successfully imported. The Results text box displays either Success or Failed.

STMS – Include System in Transport Domain Method Results

The STMS - Include System in Transport Domain results page indicates whether the client system in the 
TMS domain landscape was successfully configured. The Results text box displays either Success or 
Failed.

STMS – Transport Routes Configuration Adjust with Controller Method Results

The STMS - Transport Routes Configuration Adjust with Controller results page indicates whether the 
transport routes were was successfully copied from the domain controller. The Results text box displays 
either Success or Failed.

STRUST – Export Own PSE Certificate Method Results

The STRUST - Export Own PSE Certificate method results page displays whether the own certificate 
was successfully exported. The Results page displays Success or Failed.

STRUST – Export System PSE Certificate Method Results

The STRUST - Export System PSE Certificate method results page displays whether the system 
certificate was successfully exported. The Results page displays Success or Failed.

STRUST – Get Own PSE Certificate Details Method Results

The STRUST - Get Own PSE Certificate Details method results page displays the details of the current 
Personal Security Environment (PSE) for an SAP ABAP system.

STRUST – Get PSE ACL List Method Results

The STRUST - Get PSE ACL List method results page displays the details of the current Personal 
Security Environment (PSE) for an SAP ABAP system.

STRUST – Get PSE Certificate List Method Results

The STRUST - Get PSE Certificate List method results page displays the details of the current Personal 
Security Environment (PSE) for an SAP ABAP system.

Column Description

Certificate Issuer Associated certificate issuer.

Certificate Owner Associated certificate owner.

Certificate Serial Number Associated certificate serial number.

SAP Client Number Client number from which data was retrieved.

System Client System client number for ACL.

System ID System ID for ACL.
13-214
Cisco Process Orchestrator 3.3 User Guide

 



 

Chapter 13      Using SAP Adapters
  SAP RFC Adapter
STRUST – Get System PSE Details Method Results

The STRUST - Get System PSE Details method results page displays the system details of the current 
Personal Security Environment (PSE) for an SAP ABAP system.

STRUST – Import Own PSE Certificate Method Results

The STRUST - Import Own PSE Certificate method results page displays whether the own certificate 
was successfully imported. The Results page displays Success or Failed.

STRUST – Import System PSE Certificate Method Results

The STRUST - Import System PSE Certificate method results page displays whether the system 
certificate was successfully imported. The Results page displays Success or Failed.

STRUST – Remove Own PSE Certificate Method Results

The STRUST - Remove Own PSE Certificate method results page displays whether the own certificate 
was successfully deleted. The Results page displays Success or Failed.

STRUST – Remove System PSE Certificate Method Results

The STRUST - Remove System PSE Certificate method results page displays whether the system 
certificate was successfully deleted. The Results page displays Success or Failed.

STRUST – Set Own PSE Method Results

The STRUST - Set Own PSE method results page displays whether the own PSE was successfully reset. 
The Results page displays Success or Failed.

Column Description

Created By Name of user who created system PSE.

Created Date Date the system PSE was created.

Data Format Format of PSE file.

Data Length Data length of PSE file.

File Name File name of the system PSE on the application server.

Modified By Name of user who modified system PSE.

Modified Date Date system PSE was modified.

PSE Host Name Name of the current application server.

PSE Instance ID Instance ID of the current application server.

PSE Name Key field for SSF_PSE storage.

Signed Indicates whether PSE is signed.

SSF Name SSF name of signatory.
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STRUSTSSO2 – Add System ACL Method Results

The STRUSTSSO2 - Add System ACL method results page displays whether the system ACL entry in 
the PSE was successfully added. The Results page displays Success or Failed.

STRUSTSSO2 – Remove System ACL Method Results

The STRUSTSSO2 - Remove System ACL method results page displays whether the system ACL entry 
in the PSE was successfully deleted. The Results page displays Success or Failed.

SU01 – Reset User Password Method Results

The SU01 - Reset User Password method results page indicates whether the password was successfully 
changed. The Results text box displays either Success or Failed.

SUIM – Complex User Selection Method Results

The SUIM - Complex User Selection method results page displays a list of user accounts that are 
currently unlocked.

SWU3 – Update Workflow RFC Destination Method Results

The SWU3 - Update Workflow RFC Destination method results page indicates whether the password for 
the workflow agent WF-BATCH in the target system was successfully updated. The Results text box 
displays either Success or Failed.

Select Monitoring Tree Element Dialog

Use the Select Monitoring Tree Element dialog to select the appropriate element from the folder list of 
monitoring tree elements.

Managing SAP Solution Manager Targets

Creating an SAP Solution Manager Target
Before you can create or run processes in your SAP Solution Manager environment, you must create the 
targets on which the processes will run. You use the New SAP Solution Manager wizard to create SAP 
Solution Manager targets.

Note When you create an SAP Solution Manager target, you must map the SAP systems that are monitored in 
Solution Manager to the SAP System targets configured in Process Orchestrator. Therefore, you must 
create SAP System targets in Process Orchestrator for the systems that are monitored in Solution 
Manager prior to creating an SAP Solution Manager target.

To create an SAP Solution Manager Target

Step 1 On the Definitions workspace, right-click Targets and choose New > SAP Solution Manager to launch 
the New SAP Solution Manager Wizard.
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Step 2 Click Next on the Welcome panel.

Step 3 On the System Setup panel, complete the following information:

• Display name—Enter a name for the SAP Solution Manager system. This is the name that will be 
displayed in the Targets view.

• Organization—Enter the group or organization within the company that owns the target.

Step 4 Click Next.

Step 5 On the Connection panel, enter the connection information for the SAP Solution Manager system. The 
system information entered on this panel must be unique. Otherwise, an error message displays 
informing you that the wizard detected another system already registered with the same information.

• Connect using—Choose the connection method from the drop-down list. The fields that display on 
the panel depend on the connection method selected.

• Application server—Choose this option to connect to the SAP Solution Manager target using the 
SAP application server connection information. Specify the information in the following fields:

– Server name—Enter the name of the SAP application server.

– System number—Enter the SAP system number.

– Logon group—Choose this option to establish a connection using a logon group, which contains 
a group of SAP Solution Manager system instances. When a user logs on to a logon group, the 
message server directs the users to the server of this group that currently has the lightest load. 
Specify the information in the following fields:

– System ID—Enter the SAP system ID (SID).

– Message server—Enter the name of the server a user logs on to and that handles the 
communication between the application servers. For example, transport of update requests and 
lock requests.

– Group name—Enter the name of the Logon Group to be accessed. The name entered in this field 
is case-sensitive.

• Router string (optional)—Enter the router string for accessing the SAP Solution Manager systems 
via SAPRouter. If you do not specify a router string, Process Orchestrator accesses the SAP system 
directly.

The router string must be formatted as:

/H/host01/H/host02/H/

where host01 and host02 are the SAP systems that you want to access through the SAPRouter.

• Default runtime user—Choose the user account that contains the credentials to connect to the target 
from the drop-down list.

Step 6 Click Next.

Step 7 On the Options panel, map the systems that are being monitored by the Solution Manager target to the 
SAP System targets configured in Cisco Process Orchestrator. The list box displays the systems that are 
mapped.

Note The matching SAP system targets must already be created in Process Orchestrator.

• Poll Solution Manager alert not older than—Specify the value (in minutes, hours or days) to indicate 
which SAP Solution Manager alerts to retrieve. Any alerts older than the specified value will be 
ignored.
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• Select a system monitored by Solution Manager—Choose the SAP system that is monitored by 
Solution Manager from the drop-down list.

• Select a matching system monitored by Process Orchestrator—Choose the SAP system target that 
is configured in Process Orchestrator from the drop-down list. This target must already be defined 
in Process Orchestrator.

• Add to List—Click this button to add the mapped configuration to the list of systems to be 
monitored.

• Refresh—Click this button to refresh the list of systems to be monitored.

Step 8 Click Next.

Step 9 On the Completing the New SAP Solution Wizard panel, verify that the information is correct and click 
Finish to complete the procedure.

 SAP Solution Manager Wizard

Welcome to the SAP Solution Manager Wizard

The New SAP Solution Manager Wizard is used to add SAP Solution Manager systems in Cisco Process 
Orchestrator. You use this wizard to specify the connection and logon information for the system.

Check the Do not show this page next time check box if you do not want the Welcome panel to be 
displayed the next time the wizard is launched. The check box is checked by default.

SAP Solution Manager Wizard—System Setup

You use the System Setup panel to specify the information about your SAP Solution Manager system.

SAP Solution Manager Wizard—Connection

You use the Connection panel to enter the connection information for connecting to SAP Solution 
Manager.

Fields Description

Display name Display name for the SAP Solution Manager system. This is 
the name that displays in the Targets view.

Organization Group or organization within the company that owns the 
target.
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SAP Solution Manager Wizard—Options

Use the Options panel to specify polling intervals and to map the systems that are being monitored by 
the Solution Manager target to the SAP System targets configured in Cisco Process Orchestrator. 

Note The matching SAP System targets must already be created in Cisco Process Orchestrator.

Field Description

Connect using Choose the connection method from the drop-down list. The fields that 
display on the panel depend on the connection method selected.

• Application server—Choose this option to connect to the SAP 
Solution Manager system using the SAP application server 
connection information. Specify the information in the following 
fields:

– Server name—Enter the name of the SAP application server.

– System number—Enter the SAP system number.

• Logon group—Choose this option to establish a connection using a 
logon group, which contains a group of SAP Solution Manager 
system instances. When a user logs on to a logon group, the message 
server directs the users to the server of this group that currently has 
the lightest load. Specify the information in the following fields:

– System ID—Enter the SAP system ID (SID).

– Message server—Enter the name of the server a user logs on to 
and that handles the communication between the application 
servers. For example, transport of update requests and lock 
requests.

– Group name—Enter the name of the Logon Group to be 
accessed. The name entered in this field is case-sensitive.

Router string (optional) Enter the router string for accessing the SAP Solution Manager systems 
via SAPRouter. If you do not specify a router string, Process Orchestrator 
accesses the SAP system directly.

The router string must be formatted as:

/H/host01/H/host02/H/

where host01 and host02 are the SAP systems that you want to access 
through the SAPRouter.

Default runtime user Choose the user account that contains the credentials to connect to the 
target from the drop-down list.
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Completing the SAP Solution Manager Wizard

Verify that the information is correct and click Finish to add the SAP Solution Manager system to the 
configuration. If you want to modify the configuration, click Back.

Managing SAP Solution Manager Triggers

Creating an SAP Solution Manager Trigger

Use the Solution Manager Alert trigger to specify the properties in the monitoring tree element (MTE) 
that must be matched before an alert is generated. When the specified alert is generated, the process is 
executed.

To create an SAP solution manager trigger:

Step 1 On the Definitions—Processes view, right-click Processes in the navigation pane and choose New > 
Process.

Step 2 On the Process Editor properties, click the Triggers tab.

Step 3 On the Triggers tab, click New > Solution Manager Alert.

Step 4 On the General tab, enter the general information about the trigger.

Step 5 Click the Alert tab to specify the alert criteria.

Column Description

Poll Solution Manager alert 
not older than

Specify the value (in minutes, hours or days) to indicate which SAP 
Solution Manager alerts to retrieve. Any alerts older than the 
specified value will be ignored.

Select a system monitored by 
Solution Manager

Choose the SAP system that is monitored by Solution Manager from 
the drop-down list.

Select a matching system 
monitored by Process 
Orchestrator

Choose the SAP system target that is configured in Cisco Process 
Orchestrator from the drop-down list. This target must already be 
defined in Cisco Process Orchestrator.

Add to List Click this button to add the mapped configuration to the list of 
systems to be monitored.

Refresh Click this button to refresh the list of systems to be monitored.

Column Description

Category Name of the category in Solution Manager to be matched.

Managed object name Name of the managed object in Solution Manager to be 
matched.

Managed object type Type of managed object in Solution Manager to be matched.

System ID SAP system ID for the system that generated the alert.

Alert name Name of the alert in Solution Manager to be matched.
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Step 6 Click the Targets tab and specify the target on which to monitor for faults that will trigger the process.

Step 7 Click the Conditions tab to specify when the trigger is to execute the process:

• True—Click this link to indicate that all conditions must be satisfied (true) when the trigger occurs 
before the process is executed.

• False—Click this link to indicate that any conditions may occur for the trigger to execute the 
process.

• To create a specific condition, click New.

Step 8 Click OK to complete the trigger definition and close the dialog box.

SAP Solution Manager Activities

Correlate Solution Manager Alerts Activity Properties—Solution Manager Alert Criteria

Use the Correlate Solution Manager Alerts activity to specify the properties of SAP Solution Manager 
alerts that must be matched before an alert is correlated. Specify the following information on the 
Solution Manager Alert Criteria page:

Alert technical name Technical name of the alert in Solution Manager to be 
matched.

Description Description for the alert to be matched.

Alert Rating Severity level of the alerts to be monitored (Red, Yellow, 
Green, Unknown).

Column Description

Field Description

Correlate Solution 
Manager alerts that occur 
within

Enter a value and select the time unit to indicate the length of time to wait 
before or after the process start time.

• Time unit—Enter the start time value in minutes or seconds.

• Event occurrence—Determine whether the process start time is before 
or after the alert occurs.
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Get Solution Manager Alert Metrics – Alert Metrics

Use the Get Solution Manager Alert Metrics activity to retrieve metrics associated with an SAP Solution 
Manager alert. Specify the following information on the Alert Metrics page:

Get Solution Manager Managed Object Metrics – Managed Object Metrics

Use the Get Solution Manager Managed Object Metrics activity to retrieve metrics in SAP Solution 
Manager. Specify the following information on the Connection page:

Number of Solution 
Manager alerts to 
correlate

Click one of the following options to specify which alerts to wait for 
before the process continues:

• All Solution Manager alerts in the above time frame—Click this radio 
button to wait for all alerts that match the specified criteria before the 
process continues.

• Number of Solution Manager alerts— Click this radio button to wait 
for the specified number of alerts to occur before the process 
continues. Enter the number of alerts to wait for in the text field 
(maximum value in this field is 2147483647).

Solution Manager Alert 
criteria

Check the check box for the properties to be matched for Solution 
Manager alerts and then enter the relevant property in the text field.

• Category—Application server for the Solution Manager system that 
will be monitored by this process. Enter the (*) wildcard to monitor 
all servers.

• Alert name—Name of the alert in Solution Manager.

• Alert technical name—Technical name of the alert in Solution 
Manager.

• Managed object name—Object in Solution Manager that will be 
managed by this process. Enter the (*) wildcard to monitor all objects.

• Managed object type—Object type in Solution Manager that will be 
managed by this process. Enter the (*) wildcard to monitor all objects.

• System Id—Solution Manager system ID for the system that 
generated the alert.

• Description—Text that describes the alert in Solution Manager.

Field Description

Field Description

Alert ID Unique number of the alert within the SAP system to retrieve 
the metrics.

Managed Object name The name of the object associated with the alert.

Field Description

Category The category associated with the alert

Managed object type The type of object associated with the alert
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Update Solution Manager Alert Activity Properties—Update Alert

Use the Update Solution Manager Alert activity to acknowledge a Solution Manager alert. On the Update 
Alert page, specify the unique alert number and other SAP properties.

Activity Results

Correlate Solution Manager Alerts Instance Properties—Correlated Alerts

The Correlated Alerts display-only page displays the alerts that were found when the Correlate Solution 
Manager Alerts activity was run. The following information displays for each alert:

Managed object name The name of the object associated with the alert

Select time window Click one of the following radio buttons and then specify the 
corresponding information:

• State date (wildcard or yyyyMMdd)—Enter a wildcard 
to search all dates or specify the date from which to begin 
retrieving metrics.

• Last X minutes—Enter the timeframe (in minutes) from 
which to retrieve metrics (for example, enter 30 to 
retrieve metrics within the last 30 minutes).

Field Description

Field Description

Alert ID Unique number of the alert within the SAP system.

Complete alert Check box to indicate whether the alert should be acknowledged and 
completed. Check the check box to acknowledge and complete the 
alert.

Comment Text information about the alert and acknowledgment.

Column Description

Name Name of the Solution Manager alert.

Occurred Time the alert occurred.
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Using the PowerShell Snap-in CLI

The Cisco Process Orchestrator Command Line Interface (CLI) Snap-In leverages the Windows 
PowerShell console to execute scripts using Cisco Process Orchestrator commandlets. If you have the 
appropriate privileges, you can use the CLI commands to more easily control system administration and 
accelerate automation. The CLI is included in the standard Process Orchestrator installation and will 
only execute against the local Process Orchestrator server under the credentials of the current user 
running the CLI command.

Process Orchestrator PowerShell CLI Snap-in consists the of commandlets that allow you to view details 
of the existing processes and targets in the Process Orchestrator server. Using the PowerShell CLI 
Snap-in, you can generate a list of processes and targets, as well as enable and disable specific processes 
and targets.

Step 1 To see a list of all the Process Orchestrator commands, run the following command in the PowerShell 
console:

Get-Command *-Orchestrator*

This will reveal commands such as Export-OrchestratorAutomationPack and 
Import-OrchestratorAutomationPack.

Step 2 Use the Get-Help command to view the syntax help for a command. For example:

• To view the syntax for exporting automation packs, enter:

Get-Help Export-OrchestratorAutomationPack –full

• To view the syntax for importing automation packs, enter:

Get-Help Import-OrchestratorAutomationPackFile –full

Related Topics

• For additional information about Microsoft Windows PowerShell, refer to the Windows PowerShell 
Owner’s Manual.

• If PowerShell is not installed, see Install Windows PowerShell 2.0 on the Microsoft web site to 
access the free Windows PowerShell download. Note that you only need to install Powershell 2.0 on 
Windows 2008 because Powershell 2.0 is installed and integrated in Windows 2008R2 and later.
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Managing High Availability and Resiliency

This topic documents the basic approach used to support operational continuity, the ability to maintain 
availability during routine maintenance, and disaster recovery requirements for a Cisco Process 
Orchestrator. Using the production-level planning and operations described in the following topics, 
implementing these features should result in as much as 99.95% up time for your site:

• Understanding High Availability and Resiliency

• Advance Planning

• Ensuring Operational Continuity

• Maintaining Availability During Routine Maintenance

• Performing Disaster Recovery

Related Topics

• Handling Restarts and Failures

• Windows Performance Counters

Understanding High Availability and Resiliency
The Cisco Process Orchestrator active-active server provides a highly available and scalable solution, 
the goal of which is to virtually eliminate down time due to hardware application failures. This solution, 
which protects critical pieces of the system from failure and excessive loads, includes these features:

• Rather than a single server performing all of the work (running processes, monitoring triggers, and 
so on), a Process Orchestrator environment can contain many servers. If one server fails, as long as 
another is available to take its place, useful work can continue. 

• In a Process Orchestrator environment, all servers connected to the system share the workload, 
which helps increase scalability and performance. The more servers that are available in the system, 
the less work each of them must perform. 

• A Process Orchestrator environment is available during routine maintenance, such as rebooting the 
operating system, applying OS security patches, and performing minor upgrades (even to the 
Process Orchestrator itself).
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The following figure illustrates the recommended Process Orchestrator high availability environment:

Figure 1 High Availability Environment

The Process Orchestrator environment consists of:

• A reporting database. Although the environment requires a reporting database to enable reporting 
features, the reporting database can span environments and therefore can be thought of as external 
to the environment.

• A configuration database. The configuration database is specific to one environment, and therefore 
requires a high availability-appropriate solution. 

• Multiple Process Orchestrator servers

• Optional: Multiple web servers 

• A load balancer in front of the northbound web service and/or web servers (optional). For 
information about installing a load balancer, see the Cisco Process Orchestrator Installation Guide.

Because the Process Orchestrator environment supports high availability, the installation process:

• Requires an environment name (defaults to PRODUCTION).

• Differs for “subsequent” servers that are added to an existing high availability environment. During 
the installation of a secondary server, the installation process does not create the databases, 
configure security, import automation packs, or configure Windows accounts. 

However, the secondary server does require connectivity to an existing server in the environment. 
In addition, a security check is performed to ensure that the person installing the new server has the 
permissions to:

– Add the server to an existing environment

– Access the processes database

• Configures a default Process Orchestrator Windows Runtime User for Orchestration Server targets.
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• Recommended: Assign security principals to default roles (typically Active Directory groups). The 
install process prompts you to specify the groups to be assigned to default security roles, but allows 
this step to be skipped. However, you will need to do this eventually or the environment will only 
work for the account that installed it.

Note Do not use local security groups and users in a high availability environment. By their 
nature, local security groups and users are accessible to one Process Orchestrator server, but 
are not accessible to another server. This means that they will be very confusing to configure 
and work with because server A will have a different “view” of permissions than server B.

In addition, because the Process Orchestrator environment supports high availability:

• The license key is tied to a computer name. This association is checked only when the license is 
applied. Therefore, if you have a high availability environment with three servers, for example, you 
can obtain a license key tied to one of the servers and then apply that license using the UI connected 
to that server. After the license has been applied, the license loses its association with the first 
server’s name and becomes available to all servers in the environment.

• Process execution and event monitoring are automatically “equally” divided between all Process 
Orchestrator servers, with the following exceptions:

– Only the current load is taken into account.

– CPU, disk space, and other performance factors are not taken into account.

– Due to the technical constraints of adapter connections, some work must be performed on a 
specific node.

• There are several constructs in Process Orchestrator that relate to files that exist on the servers. 
These constructs must now store files on some network share, which is available to all servers, so 
that if one server writes the file and fails, or if work is shifted for load balancing, other servers can 
access it to continue the automation. Ideally the network share would not be a directory on some 
specific Windows server, but a highly available location with redundancy and fault tolerance, such 
as an HA NAS system. Examples of such elements that should now use a share in a multi-server 
Process Orchestrator environment are:

– Automation summaries, which are stored as XML files. The server must log in to write 
automation summaries from multiple servers.

– Files that are written by some process and later read by the same or another process such as 
email attachments or FTP files. Although Process Orchestrator provides backward 
compatibility so that processes that rely on the well-known Windows Computer target can run 
after the upgrade, processes that rely on file locations local to a Process Orchestrator server will 
not be high availability-ready.

• Windows Computer targets are created for each Process Orchestrator server. However, the singleton 
(well-known) Windows Computer target from prior Process Orchestrator versions still exists and 
represents the first server in the environment. Processes that rely on the well-known Windows 
computer target will not be high-availability ready. 

• The Core Automation Pack contains a well-known target group that includes all Process 
Orchestration server targets. 

Note When writing high-availability processes, use this group instead of the well-known 
Windows computer target ID.
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Advance Planning
Ensuring both operational continuity and disaster recovery preparedness requires:

1. Creating a support team (see Creating the Cisco Process Orchestrator Support Team).

2. Planning for high availability by installing multiple Process Orchestrators on virtual machines (see 
Planning for High Availability).

3. Using one of the recommended databases (see Storing the Information).

4. Considering the dependencies Process Orchestrator has on other services (see Considering 
Dependencies on Other Services).

5. Develop a strategy for performing regular database and system backups.

Creating the Cisco Process Orchestrator Support Team
To maintain operational continuity and ensure that the people on your site are prepared for any 
emergency:

Step 1 Create your Cisco Process Orchestrator Support team well in advance of any disaster. 

When a disaster occurs, the first step of any recovery process should be to contact this team. The 
members of this team should know the prescribed (and latest) list of procedures, and each member 
should have a pre-defined role in the recovery process.

This team should consist of:

• The team assigned to day-to-day administration and operations. 

Note Although Process Orchestrator can be useful across a broad span of IT users, it needs an 
administrator/operator. This person will use the Operations Workspace (see Monitoring 
Processes) to monitor the health of processes and receive operational alerts, and will 
typically serve as the primary contact for customer support issues.

• The database administrator (DBA) responsible for the database if the disaster is related to the 
Process Orchestrator database.

• The manager of the VM farm on which the Process Orchestrator servers run.

• Personnel who can run the software that restores the Process Orchestrator server. This can be the 
VM farm operator.

Step 2 Because outages in individual upstream systems can affect processes that span technologies and 
services, maintain the contact information for the owners of any upstream systems (see Considering 
Dependencies on Other Services). This information should include current names and phone numbers.

Planning for High Availability
A single-server environment does not provide high availability, so you should plan to implement 
multiple Process Orchestrator active-active servers. When you are planning your Process Orchestrator 
environment, consider these recommendations:
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• Be sure that all Process Orchestrator servers have similar hardware and software configurations; that 
is, the same (or similar) amounts of memory, number of CPUs, OS levels, and so on.

Cisco Process Orchestrator’s high availability solution does not take hardware or operating system 
differences into account when distributing load. When new work arrives to be executed by Cisco 
Process Orchestrator, only the current load (the number of process instances and monitored triggers) 
is considered. Over time, more work will be assigned to less loaded or more capable Process 
Orchestrator servers, but the amount of memory, CPUs, or storage is not directly taken into account 
when assigning work. 

• Install the Process Orchestrator servers on virtual machines backed by networked storage. Using this 
approach, if a host fails, the VM can be migrated to a new host using a tool such as vCenter. Many 
customers find this method of fault tolerance preferable because the host can change to another site 
in disaster recovery situations. 

• VM farms tend to be sets of machines connected to the same storage, and might be in the same data 
center. Consider replicating your snapshots to a secondary data center.

Moving to High Availability

Customers running multiple database and Process Orchestrator 2.x server installations running the same 
content against many targets should consider going to a single database and a multiple high availability 
server installation. To migrate to this environment:

Step 1 Upgrade one of the servers directly.

Step 2 Add additional high availability servers (on separate hardware, unrelated to the old 2.x servers).

Step 3 Create automation packs to include your targets from the non-upgraded 2.x environments.

Step 4 One by one, shutdown your old 2.x servers and at the same time, import the automation packs with 
targets from those servers into the new high availability environment.

Customers running multiple database and Process Orchestrator 2.x server installations running different 
content against many targets might not want to use high availability, but it can be accomplished. In this 
case, to migrate to this environment:

Step 1 Perform same steps listed above.

Step 2 Export whatever content you need from each 2.x server (in addition to the targets), then import the 
content back into the new high availability environment.

Storing the Information
Virtually all Process Orchestrator state information is stored in the database. Although there are two 
databases, only the configuration database is a hard upstream dependency (see Considering 
Dependencies on Other Services) and must be made highly available to prevent a database-based Process 
Orchestrator outage. The reporting database is used for auditing and reporting purposes, but Process 
Orchestrator does not depend on its presence or on it being up and running.

Process Orchestrator supports the following high availability databases:

• SQL Server Failover Cluster
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• Oracle Real Application Clusters (see the Oracle RAC configuration steps in the Cisco Process 
Orchestrator Installation Guide)

Although the bulk of the Process Orchestrator server's state is stored in the database, the following 
important pieces of data are stored in the Process Orchestrator server system:

Considering Dependencies on Other Services
Process Orchestrator interacts with many different IT technologies and processes (see Considering 
Dependencies on Other Services). It is critically dependent on some technologies, such as its backend 
database on an Oracle or SQL Server (a hard upstream dependency), and on other technologies such as 
a DB2 database or VMware vCenter connection (soft upstream dependencies), only to the extent that 
processes interact with those technologies. 

Similarly, other IT services might rely on Process Orchestrator. For example, an IaaS private cloud 
service built on Cisco Intelligent Automation for Cloud (that includes Process Orchestrator) will be 
non-operational or will have to revert to all-manual workarounds without a functioning Process 
Orchestrator. 

Other IT services could operate in various degraded states without Process Orchestrator. For example, 
Incident Management in Remedy will still function as IT's Incident Management without a functional 
Process Orchestrator, but capabilities such as automated troubleshooting (a hard downstream 
dependency) and ticket enrichment (a soft downstream dependency) will not be available. 

Table 15-1 Information Held in the Process Orchestrator Server System

Type of Information Description

The keys used to encrypt security 
credentials

This key is stored in a controlled space in the Windows security subsystem of the 
Windows server hosting the Process Orchestrator server. 

Process Orchestrator stores runtime user names, passwords, and other credentials in 
the database so that it can connect using those credentials when running an activity 
against a target. Credentials are encrypted with a key specific to the Process 
Orchestrator environment before being stored in the database. 

This environment-specific key, which is stored in the Windows security system of each 
Process Orchestrator server, can be exported as a file, retained for disaster recovery 
purposes, and moved to a standby/backup server for recovery (see Saving the Process 
Orchestrator Server Data in Preparation for a Disaster). In a disaster recovery 
situation, the Process Orchestrator database is useless without the corresponding and 
separately stored encryption keys.

The Process Orchestrator server 
installation

This is core software that can be recreated from the installation media.

The server configuration file This file configures certain properties of the Process Orchestrator server. For example, 
it tells the Process Orchestrator server which ports to open to talk to the client. It also 
tells the server where the database is and which credentials to use to access it.

Persistent queue files for data to be 
written to the reporting database

These files store reporting data so that it is not lost across server restarts (see Handling 
Restarts and Failures).
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To summarize, when you are planning your Process Orchestrator environment, take into consideration 
all of these types of dependencies:

For more information about the dependencies on Process Orchestrator and Process Orchestrator's 
dependencies on other services, see the Cisco Process Orchestrator Compatibility Matrix. 

Ensuring Operational Continuity
Ensuring operational continuity of your Process Orchestrator environment includes these actions:

• Backing Up Your Data

• Monitoring Processes and Events

• Handling Errors, Exceptions, and Diagnostics

Backing Up Your Data
In a disaster recovery situation, you will need copies of the following information, so be sure to 
regularly: 

• Back up your database. Follow the standard database backup procedures for data recovery and the 
best practice database resiliency strategies of your database vendors, which should be provided in 
the documentation for the applicable database platform.

• Save the Windows security credentials encryption key for the Process Orchestrator environment. 
This only needs to be done once; this key is shared by all servers in a single Process Orchestrator 
environment. For information about how to save the key, see Saving the Process Orchestrator Server 
Data in Preparation for a Disaster. 

• Save the Process Orchestrator server configuration file. For more information about this file, see 
Storing the Information.

• Take snapshots of the Process Orchestrator server VMs and save them at an alternate site (see 
Planning for High Availability).

• Save any customizations to the Web.config file in the Web Console server.

Table 15-2 Dependency Types 

Dependency Description

Hard A component or service is required by the dependent service to be fully operational.

Soft A component or service is not required by the dependent service to be fully 
operational, but functionality directly involving the component might be degraded 
or broken.

Upstream The IT services that Process Orchestrator relies on.

Downstream The IT services that rely on Process Orchestrator.
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Saving the Process Orchestrator Server Data in Preparation for a Disaster

When making preparations for a disaster, the most important piece of information to save is the security 
key that a Process Orchestrator server uses to encrypt sensitive data before storing it to the database. This 
environment-specific key is stored in the Windows security system of each Process Orchestrator server.

Note In a disaster recovery situation, the Process Orchestrator database is useless without the 
corresponding and separately stored encryption key for the Process Orchestrator environment.

Another important piece of data is the Process Orchestrator server configuration file. For more 
information about this file, see Storing the Information.

To save this information:

Step 1 Once for the Process Orchestrator environment:

a. Export the security credentials encryption key to a file:

aspnet_regiis –px “Tidal Intelligent Automation Server” Keys.xml -pri

Aspnet_regiis.exe is a Microsoft.NET framework utility that resides in the .Net Framework folder. 
This folder is typically located at this location:

C:\Windows\Microsoft.Net\Framework64\{Version}\aspnet_regiis.exe

You might need to specify the full path to this utility if you have not defined the path in your Path 
environment variable

b. Save the Keys.xml file, then move it to a secure location (typically a standby or backup server) 
separate from the Process Orchestrator server.

Step 2 For each Process Orchestrator server, copy the server configuration file to a standby or backup server. 
You can find this file in the installation folder.

%INSTALLDIR%\Tidal.Automation.Server.exe.config

Monitoring Processes and Events
Each server in a Process Orchestrator environment publishes performance and events. A Process 
Orchestrator server can also provide data about its own health to operational support systems, and can 
interact with operational support systems with regard to the health of services for which it provides 
automation.

If you want to monitor the entire high availability environment, however, you must monitor all of the 
servers. Most application management systems include the ability to monitor the data that Process 
Orchestrator publishes, such as Windows event logs and performance counters. 

Process Orchestrator can integrate with IT management or network management tools such as the Cisco 
Prime products. Process Orchestrator also provides direct out-of-the box integrations with other 
management tools, including:

• Microsoft System Center Operations Manager

• SAP CCMS and Solution Manager

• Remedy Service Desk
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Process Orchestrator also provides numerous features to integrate in a generic manner with other 
management systems. For example, the triggered Process Orchestrator process can invoke a web service 
or run a script and pass in the incident, so the information can be published to another service assurance 
system.

Monitoring Processes

Process Orchestrator provides full visibility into the processes running on the system, including the 
status of all running processes, which activities have executed, succeeded, failed, and so on.

Use the Operations view to monitor the processes that are scheduled to execute, view processes that are 
currently running, and verify that processes have successfully completed. You can also start processes 
or interact with human steps in processes called Tasks. For more information about monitoring 
processes, see Monitoring Operations.

Managing Events

Process Orchestrator provides IT process records such as alerts and incidents, and uses these records to:

• Supply incidents and events for external tools it might be monitoring or managing.

• Manage the Process Orchestrator itself. For example, the Process Orchestrator Core automation 
pack performs some self-monitoring of the Process Orchestrator, and can raise an alert or incident 
if there is something that requires the Process Orchestrator administrator's attention. 

Use the Operations > Auditing > System view to review the list of internal Process Orchestrator events, 
including notifications of warnings and errors, and information events about the general functioning of 
the system. 

Note Events from all Process Orchestrator servers in a high availability environment appear in this 
view. 

For more information about managing events, see Working with Events and Triggers.

Handling Errors, Exceptions, and Diagnostics
Use Windows event logs and Windows performance counters to monitor the Process Orchestrator 
platform, either of which can be monitored through Microsoft Windows directly or fed into the service 
assurance platform of choice. Because event logs and performance counters are the standard for 
monitoring Windows-based applications, most service assurance tools include the ability to monitor 
these elements.

• System event logs 

The Process Orchestrator server logs errors that can be useful when you need to diagnose failures to 
the Windows Event Logs. For example, if there is an error connecting to a database, this will be 
logged as an event. 

These logs can also be picked up by most enterprise systems management tools if you want a view 
of Process Orchestrator health within your systems or application management console.

For more information about viewing system events, see Working with Events and Triggers.
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• Windows performance counters

The Process Orchestrator server publishes a number of Windows performance counters concerning 
its operations. For a list of Windows performance counters, see Windows Performance Counters.

Note Be sure to monitor the system event logs and Windows performance counters from all 
Process Orchestrator servers in an environment. Monitoring one server is not sufficient to 
monitor the health of all servers.

Maintaining Availability During Routine Maintenance
This section discusses how to maintain the availability of the servers in the Process Orchestrator 
environment during routine maintenance:

• Handling Routine Maintenance Outages

• Adding More Capacity

• Relocating a Process Orchestrator Server

• Maintaining the Database

Handling Routine Maintenance Outages
To maintain availability of the overall high availability environment during routine outages, such as 
Microsoft security patches and minor Process Orchestrator upgrades that do not affect the database 
schema:

Step 1 Shut down one Process Orchestrator service (while keeping the others running). Wait for the Process 
Orchestrator service to completely stop via a friendly shutdown.

Step 2 Install the Microsoft patches or Process Orchestrator patches on that server.

Step 3 Reboot as necessary, then restart the Process Orchestrator service.

Step 4 Repeat steps 1-3 on all Process Orchestrator servers, one at a time, to maintain availability of the overall 
high availability environment.

For more information about shutting down and restarting Process Orchestrator, see the Cisco Process 
Orchestrator Installation Guide.

Adding More Capacity
To add more capacity to your Process Orchestrator environment, just add another Process Orchestrator 
server. Before you can do that, you must:

• Be able to connect to an existing Process Orchestrator server

• Have permission to add a new server

• Acquire the credentials for connecting to the Process Orchestrator process database

For information about how to add a new server, see the Cisco Process Orchestrator Installation Guide.
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Relocating a Process Orchestrator Server
To relocate a Process Orchestrator server:

Step 1 Add a new server to the environment (see Adding More Capacity).

Step 2 Uninstall Process Orchestrator from the old server (see the Cisco Process Orchestrator Installation 
Guide).

Maintaining the Database
The following sections describe how to maintain the Process Orchestrator database:

• Grooming the Database

• Database Performance Best Practices

 Grooming the Database

Process Orchestrator provides settings to control grooming of the following types of objects:

• Various sections of its Process and Reporting databases. 

– The Process database instances are primarily useful for viewing prior instances in the main 
expert UI, understanding the specific activities which were executed, querying the activity 
instance inputs, outputs, and other execution details typically useful in troubleshooting and 
development scenarios. 

Grooming the Process database can help optimize performance. Reducing the database size can 
improve database insert speeds, but at a cost of being able to view older process instances in the 
UI. If you perform complex views including large numbers of historic processes, the database 
and UI must deal with the larger data volumes. Larger views might also mean larger data 
payloads coming through the server to the UI. This factor therefore not only affects the database 
layer, but also the server and UI performance.

Grooming the Process database as tightly as business scenarios allow optimizes performance of 
both the Process Orchestrator Server and UIs. For example, if no business requirement exists to 
monitor and troubleshoot failed processes past the end of a shift, setting grooming for one day 
might be appropriate.

– Data about completed process instances is available on a long-term basis in the Process 
Orchestrator Reporting database. The Reporting database provides information on which 
processes have run, when they started and ended, whether they were successful or failed, how 
they were started, and who started the processes in long term storage. The Reporting database 
has information about processes only, not activities within the process.

• Task instances, such as alerts, incidents, and change requests. These objects are groomed only upon 
their completion, which means that an open or active task can remain in the database forever. By 
default, the tasks can stay in the database for a long time.

• Audit data, which is groomed less aggressively because it is more important to keep around longer.

Using the default settings, grooming is automatic, but you can tune these settings to your needs. For 
example, there are options to:

• Control how much data is retained for completed instances. 
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• Mark expired tasks as completed.

• Configure a process to archive on failure. This allows low data and performance load during 
normal/successful executions of the process, while archiving failures so that they can be debugged 
and diagnosed.

• Start grooming immediately (rather than to wait for the scheduled time).

To change the grooming settings for the Process database, see Managing the Process Database.

Database Performance Best Practices

Proper database server hardware and routine database maintenance can have substantial effects on 
performance. Although the Process Orchestrator ships with performance-optimized schemas, including 
the relevant indices, you must install and operate these databases. 

Ideally, to optimize performance, a database administrator (DBA) familiar with best practices should 
prescribe and configure the server hosting the database platform containing the Process Orchestrator 
databases. The DBA should also be involved in the installation of the database and should perform 
routine maintenance.

In high performance scenarios, the following best practices can dramatically affect performance:

• Run regular backups of the Process Orchestrator database. Without backups, the transactional logs 
of the database will grow fairly substantially, resulting in large files and poor database performance, 
and ultimately affecting Process Orchestrator’s performance.

• Always run the database server on physical hardware, not on a VM. 

• Use a separate host server for the database instead of running the database server on a Process 
Orchestrator server.

• Disk throughput (I/O) is also an important metric for large scale deployments. Use a separate high 
speed disk for the database, operating system, program files, and swap files.

• Provide sufficient memory to avoid paging. In very large installations, Process Orchestrator has 
benefited from databases running 16 or even 32GB of RAM.

• Use a high-speed network connection. Typically this means the database is “close” to the Process 
Orchestrator server, and certainly in same data center.

For best practices, refer to the documentation associated with your chosen database platform. 
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Performing Disaster Recovery
This section discusses the following topics:

• Recovering from a Server Failure

• Recovering from a Reporting Database Failure

• Recovering from an Entire Environment Failure

Recovering from a Server Failure
In a multi-server high availability environment, there is very little you need to do to recover from a single 
server failure. When a Process Orchestrator server fails (due to, for example, a network outage, disk 
failure, or software failure), the remaining Process Orchestrator servers within the environment will:

1. Recognize the failure (within a few seconds).

2. Report the failure in event logs.

3. Redistribute the work that was performed by the failed Process Orchestrator server among the 
remaining healthy servers.

If the server failure is recoverable, simply bringing the server or service back up will put it back into the 
high availability environment and operations will resume.

If the server failure is not recoverable (for example, a hardware failure), you can add a new Process 
Orchestrator server to the environment. There is very little need to recover the failed server; it will not 
be considered healthy, and no work will be assigned to it. To delete the old server from the environment, 
choose Administration > Orchestration Servers > Remove.

Recovering from a Reporting Database Failure
If only your Reporting database has failed, there are several options:

• If possible, recover the database server. Operations will resume as before, and no changes are 
needed.

• If the database server is not recoverable but the database is (because there is a backup), restore the 
database to a new database server (see Restoring the Database to a New Database Server).

• If both the database server and the database are not recoverable, recreate the database on a new 
database server (see Recreating a New Database on a New Database Server).

Restoring the Database to a New Database Server

To restore the database to a new database server:

Step 1 Open a console connecting to any Process Orchestrator server in the environment.

Step 2 Remove the existing Reporting Database connection and connect to the new database server (see 
Managing the Report Database).

The changes will propagate throughout the entire high availability environment.
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Recreating a New Database on a New Database Server

To create a new database on a new database server:

Step 1 Open a console connecting to any Process Orchestrator server in the environment.

Step 2 Choose Administration > Database Settings, right-click Report Database and choose Remove Cisco 
Process Orchestrator Reporting Database Connection.

Step 3 Create a new Reporting database on the new database server (see Creating a Reporting Database 
Connection).

The changes will propagate throughout the entire high availability environment.

Recovering from a Total Database Failure
If your entire database has failed:

Step 1 Contact your Cisco Process Orchestrator Support team (see Creating the Cisco Process Orchestrator 
Support Team). To ensure that the latest procedures are followed and to minimize downtime, the support 
team should be contacted as early as possible and involved throughout the process. Do not wait to call 
them until the disaster recovery process goes astray.

Step 2 Stop the Process Orchestrator service on all of the server machines.

Step 3 Restore the database from the latest backup to a new database server (or new database schema). The 
restore will depend on the database version; follow the manufacturer’s instructions for your database 
server.

Note If you do not have a backup, you cannot recover the database. In that case, you must reinstall the 
entire environment.

Step 4 Log in to the first Process Orchestrator server, then use the Database User utility 
(Tidal.Automation.Server.DatabaseUserConfigurationUtility.exe) to point the server to the new database 
and/or new credentials.

Step 5 Start the Process Orchestrator service on this server. 

Step 6 Launch the Process Orchestrator console, then verify and correct Reporting database configuration if 
needed. This step is required if the Reporting database connection or the reporting credentials have 
changed.

Step 7 Log in, reconfigure, and restart (Step 4 and Step 5) all other Process Orchestrator servers in the 
environment.
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Recovering from an Entire Environment Failure
If your environment fails but you have snapshots of the Process Orchestrator server VMs saved at an 
alternate site, use the procedure described in Recovering from a Total Database Failure instead.

Follow these steps when your environment fails and you do not have snapshots of the Process 
Orchestrator server VMs saved at an alternate site:

Step 1 Contact your Cisco Process Orchestrator Support team (see Creating the Cisco Process Orchestrator 
Support Team). To ensure that the latest procedures are followed and to minimize downtime, contact the 
support team as early as possible and involve them throughout the process. Do not wait to call them until 
the disaster recovery process goes astray.

Step 2 Restore the database from the latest backup to a new database server (or new database schema). The 
restore will depend on the database version; follow the manufacturer's instructions for your database 
server.

Note If you do not have a backup, you cannot recover the database. In that case, you must reinstall the 
entire environment.

Step 3 To import the Windows security credentials encryption key from the Keys.xml file created in Saving the 
Process Orchestrator Server Data in Preparation for a Disaster to the new (first) Process Orchestrator 
server in the environment, enter the following command (do not cut and paste):

aspnet_regiis -pi “Tidal Intelligent Automation Server” Keys.xml -exp

Aspnet_regiis.exe is a Microsoft.NET framework utility that resides in the .Net Framework folder. For 
example, this folder is typically located at this location:

C:\Windows\Microsoft.Net\Framework64\{Version}\aspnet_regiis.exe

You might need to specify the full path to this utility if you have not defined the path in your Path 
environment variable.

Note It is not enough to just bring the Process Orchestrator environment up; you also need the security 
credentials encryption key to apply to the server at the new site to make this database copy 
usable. If you do not have a backup of this key, you cannot recover the database. In that case, 
you must reinstall the entire environment.

Step 4 Reinstall the core Process Orchestrator software from the installation media. Be sure to reinstall the same 
version and all of the updates/hotfixes.

Step 5 Replace the server configuration file on the new machine with the file copied in Saving the Process 
Orchestrator Server Data in Preparation for a Disaster.

Note If the file contents contain any path (such as the log file path), make sure that the path is still 
valid in the new server machine.

Step 6 Use the Database User utility (Tidal.Automation.Server.DatabaseUserConfigurationUtility.exe) to point 
the server to the restored database and/or credentials.

Step 7 Start the Process Orchestrator service on this server.
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Step 8 Launch the Process Orchestrator console, then verify and correct the Reporting database configuration 
if needed. This step is required if the Reporting database connection or the Reporting credentials have 
changed.

Step 9 Install any additional Process Orchestrator servers as new High Availability servers (see the Cisco 
Process Orchestrator Installation Guide). The additional servers will receive the database settings and 
encryption keys from the first server.

Step 10 Because the Process Orchestrator server is now installed on a different server:

a. Review the list of Windows targets in the Process Orchestrator, remove the Windows computer 
targets that point to “old” Process Orchestrator servers that are no longer available, and disable the 
old server target in the target definition.

b. If the Web Server is on a different computer or virtual machine from the Process Orchestrator server 
computer, and if the Web Server survived the outage but the Process Orchestrator servers did not, 
choose File > Environment Properties to verify and update the Web Console configuration file 
location.

c. Use the Core Functions Adapter properties to review and update the Automation Summary 
configuration.

Step 11 Choose Administration > Orchestration Servers and remove the old servers.

Handling Restarts and Failures
This section discusses the following topics:

• Handling Running Processes During Restarts and Failures

• Handling Reporting Data Queues During Restarts and Failures

• Handling Scheduled Triggers During Restarts and Failures

• Handling Events During Restarts and Failures

Handling Running Processes During Restarts and Failures
The rules described in this section apply to moving a process from one Process Orchestrator server to 
another server when a single server fails. If server A goes down, then if the process hasn’t stopped on a 
non-restartable activity, it will move to another active server. 

By default, Process Orchestrator persists all data about running processes so that state is preserved 
across service restarts; whether the restarts are planned or unexpected, process and activity states are 
persisted to the Process Orchestrator database. When the Process Orchestrator server shuts down in a 
friendly manner, it allows in-flight activities time to complete, but blocks new activities from running. 
This typically allows activities that might not be marked as restartable to complete so that processes do 
not fail during friendly shutdowns. 

Generally, processes will pick up and start running again after a restart or failure; in some activities, this 
is configurable by the user. Many activities, if they were running when the server shut down, can be 
restarted without any side effects. Some examples:

• If an activity is passive (such a configuration query), Process Orchestrator can simply run the query 
again. 
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• Other activities can have side effects and cannot be rerun without consequence. For example, if a 
CLI adds some entry for a device to a file, running the CLI again will cause two entries for the 
device. In these cases, Process Orchestrator shows these processes as failed after the restart; the 
operator must examine the failures, then rerun the failed processes. 

• The Web HTTP Request has a “Restart when interrupted” check box. Click this option if the HTTP 
Request is performing a read operation, in which case it should be restartable, but do not click it 
when performing a write operation because you could accidentally create multiple entries.

Process Orchestrator offers process Start Points that process authors can use to give operators restart 
points when a process needs to be restarted. If a volatile activity is run in Process Orchestrator and has 
not returned a status and Process Orchestrator shuts down, when Process Orchestrator restarts, this 
activity will not resume and the results of what the activity was supposed to do are lost.

Adapters determine whether to declare activities as restartable. The Process Orchestrator server also 
allows activities to save their state as they run, which allows long-running activities to be restarted. For 
example, a Create Approval activity might save a state that the approval request task has been created 
but the activity is blocked waiting on an approval. 

Process Orchestrator's writing of state is transactional. Process Orchestrator will not proceed to the next 
step until the state change is committed to the database. There should be no time gap where process state 
can be lost. This persistence has a cost. With every step in every process, Process Orchestrator writes to 
the database to update states such as when the activity starts, stops, etc. Where this performance hit is 
inappropriate, Process Orchestrator provides a setting to turn restartability off for a process. Many 
processes do not need to restart after a shutdown or failure; it might often be acceptable to rerun the 
process at the next scheduled interval or on the next instance of the trigger. For example, many SAP 
diagnostic processes fall into this category. In the case of SAP diagnostics, Process Orchestrator's SAP 
automation pack process definitions have restartability turned off on analysis processes. If the server 
fails, the state of the SAP server with respect to alerts might not be the same after restart anyway. It is 
often best to not restart these processes but to instead to relearn the state of the SAP system. Also, by 
disabling restartability, the performance impact of maintaining state is reduced.

Handling Reporting Data Queues During Restarts and Failures
To improve performance, reporting data is held in queues and is occasionally written to the database in 
bulk rather than an item at a time. During a friendly shutdown, the queue is flushed so that the reporting 
data is fully synchronized to the reporting database. In the event of a failure, the data in the queue will 
be present on restart and will be sent whenever the Process Orchestrator Server starts up; no data will be 
lost. However, if an unexpected failure occurs for which there is a need to reinstall the Process 
Orchestrator server on a different computer or restore the computer hosting the Process Orchestrator 
server from a backup, reporting data from these queues is lost. 

Handling Scheduled Triggers During Restarts and Failures
In a Process Orchestrator high availability environment, schedules that are monitored on server A will 
move to Server B when server A fails. There is a small window (of a few seconds) during which a 
schedule could be missed while server B is detecting server A’s failure.
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Handling Events During Restarts and Failures
Process Orchestrator adapters resume sending events after the Process Orchestrator server restarts. 
While the adapter is still responsible for the implementation in this area, existing Process Orchestrator 
adapter implementations attempt to be consistent with this guaranteed delivery design. For example, 
when the SAP adapter reads CCMS alerts or the Remedy adapter polls for Incident state, the adapter 
stores the last-read record so that it can resume reading records starting with the next entry when the 
Process Orchestrator server resumes. For non guaranteed-delivery, network-initiated event technologies 
such as stop traps, the Process Orchestrator server cannot know about events that occurred while it was 
down. If required, many of these technologies can use highly-available intermediaries to persist the 
transient events. For example, there are tools to listen for stop traps and convert them to persistent stores 
such as log files or Windows events. 

There are two types of event systems in the Process Orchestrator server: 

• Event-based triggers. Because of the adapter implementations (see Handling Running Processes 
During Restarts and Failures), event-based triggers are not lost across server restarts or failures. Like 
state management in other areas of the product, trigger submissions are transactional. When Process 
Orchestrator adapters send a trigger to the Process Orchestrator server, processes depending on that 
trigger are initiated as a part of the submission. As with any other processes, these process instances 
are persisted to the database so that after a restart, the triggered processes are running. With the 
exception of transient, non-persisted events, such as stop traps or performance thresholds, there 
should be no time gap where events should be lost such that triggers fail to launch.

• Correlation. The Correlation feature allows a server to tie together a related series of events. This is 
achieved through a caching mechanism to ensure that the event data is available to the Correlate 
activities in processes when needed. This cache of events is not retained across server restarts, which 
can cause issues with some Correlate activities. Correlate activities can be used to make a process 
wait for a certain condition, or branch based on how many events with particular properties have 
been received in a particular time frame. Because the cache is not persisted across server restarts, 
events received before the restart will not be matched by Correlate activities. These effects can affect 
accuracy of a process “decision” made based on the data from a Correlate activity.

In practice this has been found to not be an issue for the following reasons:

– First, correlation is a fairly advanced feature in the product and is very rarely used in a majority 
of scenarios. 

– Second, best practices also dictate that a correlation time frame is configured to be fairly small, 
which will minimize both the likelihood and impact of this compound condition. The time 
required to restart a server will take up some or all of this time frame if the correlation time 
frame coincides with a server restart. 

– Third, these correlations are typically used in diagnostic situations, and often the events repeat 
if the problem recurs. Where a problem is still occurring, Process Orchestrator will typically 
pick up the condition the next time the diagnostic process launches. 

– Finally, Process Orchestrator automation packs tend to set these processes as non-persistent 
anyway so they are not restarted. If the Process Orchestrator server is down, it is usually best to 
get a fresh view of the health of the component being monitored rather than depend on the status 
before the Process Orchestrator server restart. In many cases, the failure is resolved and it just 
creates noise to record the old diagnosis.
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Windows Performance Counters
A Cisco Process Orchestrator server publishes performance counters that can be used to monitor its 
health and diagnose performance issues. These counters are grouped into several performance objects, 
which are discussed in the following sections.

The following standard Windows performance counters are also of interest:

• Memory—Pages/sec

• Processor—% Processor Time

• Process—Private Bytes

• Process—Handle Counts

• Physical Disk

Cisco Process Orchestrator Object
 

Table 15-3 Windows Performance Counters - Cisco Process Orchestrator

Counter Description

Running Process 
Instances

The number of running process instances

Running Activity 
Instances

The number of running activity instances

In-Memory Activity 
Instances

The number of in-memory activity instances.

An in-memory activity instance might be running now or have run 
within a process that is running now. For example, if you have a single 
10-step sequential process, there will always be only one active activity 
instance. But as the workflow continues to run, the number of 
“in-memory” activities will grow as the execution progresses. When the 
process stops running, the number drops to zero.

In-Memory Process 
Instances

The number of in-memory process instances.

In-memory activity instance might be running now, or have run within 
a process which is running now. For example, if you have a single 
10-step sequential process, there will always be only one active activity 
instance. But as workflow continues to run the number of “in-memory” 
activities will grow as the execution progresses. When the process stops 
running, the number drops to zero.

Schedules Monitored The number of schedules being monitored in Process Orchestrator.

Schedules Met The number of monitored schedules met in Process Orchestrator. 

If there is only one process definition that has an “Every day, every 5 
minutes” schedule trigger, then “Schedules Monitored” will be 1 for as 
long as the server runs. “Schedules Met” will grow by one every five 
minutes as the schedule fires process instances.

Events Monitored The number of events being monitored in Process Orchestrator.
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Cisco Process Orchestrator Adapter Object
There are separate instances for each adapter.

Events Fired The number of monitored events fired in Process Orchestrator.

If there is only one process definition that has an “Every day, every 5 
minutes” schedule trigger, then “Events Monitored” will be 1 for as 
long as the server runs. “Events Fired” will grow by one every five 
minutes as the schedule fires process instances.

Web Service Calls The number of calls to the Process Orchestrator Northbound Web 
Service.

Completed Activity 
Instances /sec

The rate (per second) at which activities are being completed (with 
success or failure).

Completed Process 
Instances /sec

The rate (per second) at which running process instances are being 
completed (with success or failure).

Started Activity Instances 
/sec

The rate (per second) at which activity instances are being started.

Started Process Instances 
/sec

The rate (per second) at which process instances are being started.

Table 15-3 Windows Performance Counters - Cisco Process Orchestrator

Counter Description

Table 15-4 Windows Performance Counters - Cisco Process Orchestrator Adapters Object

Counter Description

Running Activities The number of activities running under this adapter.

Activities Run The number of activities this adapter has run

Disappearances The number of times this adapter has disappeared unexpectedly.

Event Fired The number of monitored events fired by this adapter.

Events Monitored The number of events being monitored by this adapter.

Excessive Memory 
Restarts

The number of times this adapter has been restarted due to excessive 
memory usage.

Host Process ID The ID of the process that hosts this adapter.

Idleness Shutdowns The number of times this adapter has shut down due to idleness.

Requested Restarts The number of times this adapter has requested to be restarted.

Starts The number of times this adapter has started

Targets Managed The number of targets this adapter is managing.
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Cisco Process Orchestrator Persistent Queue Object
There are separate instances for each queue.

Cisco Process Orchestrator Data Access Layer Operations Object
There are separate instances for each type of DAL (Data Access Layer) operation.

Cisco Process Orchestrator SAP Connections
There are separate SAP requests in each queue.

Table 15-5 Windows Performance Counters - Cisco Process Orchestrator Persistent Queue Object

Counter Description

%Used Space The maximum space for the queue is preallocated; this counter 
measures how much of the queue is used.

Queue Item Submits/Sec Number of items submitted to the persistent queue per second.

Queue Items This is the current number of items in the queue. This number will vary 
as new items are added by the process execution and removed as the 
engine records them into the reporting database.

Table 15-6 Windows Performance Counters - Cisco Process Orchestrator Data Access Layer 

Operations Object

Counter Description

# of Data Access Layer 
Calls

Number of times a particular DAL (Data Access Layer) call was made.

# of Errors in Data 
Access Layer Calls

Number of times a DAL call completed with an error.

Average Data Access 
Layer Call Duration 
(milliseconds)

Average time it took to complete this type of DAL operation.

Cumulative Data Access 
Layer Call Duration 
(milliseconds)

Total time spent in all DAL operations of this type.

Longest Data Access 
Layer Call Duration 
(milliseconds)

The time it took for the longest of DAL operations of this type to 
complete.

Table 15-7 Windows Performance Counters - Cisco Process Orchestrator SAP Connections

Counter Description

RFC calls in waiting The number of RFC calls waiting in the queue.

The maximum number of concurrent calls allowed is 1 by default.

RFC calls in working The maximum number of RFC calls that are concurrently working.
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Total RFC Calls The total number of RFC calls made in the SAP connection

SAP alerts The total number of SAP alerts monitored on the SAP or SAP solution 
manager connection.

Total SAP Requests The total number of SAP requests made on the SAP or SAP solution 
manager connection.

Queued SAP Requests The total number of SAP requests waiting in the queue. Each SAP or 
SAP solution manager connection processes one SAP request at a time.

Table 15-7 Windows Performance Counters - Cisco Process Orchestrator SAP Connections

Counter Description
15-22
Cisco Process Orchestrator 3.3 User Guide

 


	Cisco Process Orchestrator 3.3 User Guide
	Introduction
	Understanding Service-Oriented Orchestration
	Key Benefits
	Process Orchestrator Supports Service-Oriented Orchestration
	Aligned to IT Standards
	Related Service-Oriented Orchestration Terms and Concepts
	Service Definition Examples
	A Distributed Application and Product as a Service
	A Cisco TelePresence Service


	Process Orchestrator System Components
	Process Orchestrator Console
	Web Console
	Process Orchestrator Server (Process Engine)
	Northbound Web Service Interface
	REST Services Guide
	Command Line Interface
	Databases
	Process Database (Configuration & Audit)
	Reporting Database (Data Warehouse)

	Reporting
	Role-Based Access Control (RBAC)
	Adapters
	Automation Packs
	Advanced Message Queuing Protocol (AMQP)
	AMQP Exchange Types


	Process Orchestrator System Elements
	Activities
	Automation Summaries
	Conditions
	Processes
	Runtime Users
	Targets
	Target Groups
	Target Types
	Tasks
	Task Rules
	Triggers
	Variables

	Adapters No Longer Supported as of Cisco Process Orchestrator 3.3

	Getting Started
	Connecting to Your First Server/Environment
	Understanding the User Interface
	Process Orchestrator Console Components
	Console Overview
	Console Menus
	Using the File Menu
	Using the Edit Menu
	Using the View Menu
	Using the Go Menu
	Using the Tools Menu
	Using the Actions Menu
	Understanding the Help Menu

	Toolbars
	Standard Toolbar
	Advanced Toolbar
	Actions Toolbar

	Workspaces
	Results Pane
	Details Pane
	Process Viewer
	Process Editor Menus
	Process Editor File Menu
	Process Editor Edit Menu
	Process Editor View Menu
	Process Editor Tools Menu
	Process Editor Actions Menu
	Process Editor Help Menu
	Process Editor Toolbar
	Field Reference Icons


	Defining a Target
	Defining Runtime Users
	Selecting a Client Certificate

	Configuring Security
	Creating a New Security Role
	Assigning Users Or Groups to Security Roles


	Managing Automation Packs
	Creating an Automation Pack
	Viewing Automation Pack Properties
	Importing Automation Packs
	Importing from the Console

	Extracting Data Files
	Overwriting Existing Objects
	Deleting Automation Packs
	Working with Automation Pack Objects
	Adding Automation Pack Objects
	Creating an Automation Pack Patch
	Applying an Automation Pack Patch
	Viewing Patch Details
	Removing Automation Pack Objects

	Refreshing References in an Automation Pack
	Archiving Process Instances in an Automation Pack
	Validating Automation Packs
	Controlling the Customization of Automation Pack Elements
	Executing a Circular Dependency Check
	Reviewing Automation Pack Validation Rules
	Selecting Automation Pack Dependencies
	Exporting an Automation Pack
	Automating Automation Pack Exports and Imports
	Exporting Customization Packs
	Importing Customization Packs
	Using the Wizard
	Launching the Import Wizard
	Launching the Export Wizard

	Launching Multiple Consoles with the Same Server
	Launching Multiple Consoles with Different Servers
	Connecting to a Different Server from the Current Console
	Managing Cisco Process Orchestrator Server Connections
	Configuring Server Connection Behavior
	Modifying the List of Recent Servers

	Configuring the Console Global Settings
	Configuring Process Orchestrator Objects Default Owner
	Modifying Process Launch Settings
	Restoring Console Default Settings

	Collecting Process Orchestrator Diagnostics

	Authoring Processes
	Working with the Definitions Workspace
	Accessing the Process Editor
	Toggling the Process Editor View
	Expanding the Workflow View
	Collapsing the Workflow View

	Creating a Basic Process
	Reverting Process Changes

	Selecting the Target Type on Which a Process Acts
	Adding an Invocation of an Existing Child Process
	Adding Variables to a Process
	Working with Target Reference Variables
	About the References Dialog


	Authoring Task Activities
	Authoring Task Activities
	Defining the Correlate Alert Activity
	Task Properties That Task Activities Manipulate
	Debugging Task Activities
	Viewing Correlated Alert Results
	Viewing Find [Activity] Results
	Viewing Wait for Task to Enter State Results


	Publishing Automation Summaries
	Adding Logic Components to a Process
	Adding Process and Global Variables
	Activity Configuration
	Process Control Components
	Process Parameters
	Formulas as Variable Values
	Common Use of Variables
	Named Variables
	Process or Activity Property Variables
	Status Tracking
	Summary Variables

	Creating a Boolean Global Variable
	Creating a Hidden String Global Variable
	Creating a Numeric Global Variable
	Creating a String Global Variable
	Creating a Table Global Variable
	Creating an Identity Global Variable
	Creating a Copy of a Global Variable

	Adding Targets and Target Groups
	Viewing Members of a Target Group
	Creating a Target Group
	Using a Target Group in Your Process

	Adding Conditions
	Adding Basic Conditions to an Object
	Creating a Time Condition
	Creating a Component Licensed Condition
	Creating a Variable Condition
	Adding Advanced Conditions to an Object
	Deleting a Condition
	Deleting Conditions from Task Rules
	Deleting Conditions from Triggers
	Deleting Conditions from a Logic Component
	Deleting Archive Conditions


	Adding Target Types
	Managing Processes
	Modifying Process Properties
	Modifying Activity Definition Properties
	Managing Process Workflow Revisions
	Viewing Workflow Revisions
	Restoring a Workflow Revision

	Starting a Process
	Canceling a Process
	Executing and Archiving Process Instances

	Creating Processes as a Team
	Enabling Team Process Authoring
	Viewing Process Views by Lock Status
	Editing Locked Processes

	Scheduling Processes
	Authoring a Calendar
	Creating a New Calendar
	Creating a Recurring Calendar

	Scheduling a Process Based on a Calendar
	Scheduling a Process to Run Only Under Certain Conditions
	Using a Calendar in a Condition


	Authoring Categories
	Creating Categories
	Adding Objects to a Category
	Viewing Process Properties from the Members Tab

	Advanced Authoring Concepts
	Using String Activities
	Using Table Activities
	Using Core Activities
	Adding an XPath Namespace Definition
	XPath Example Syntax
	XPath Query Example
	XPath Query Example 2


	Authoring Knowledge Base Articles

	Monitoring Operations
	Monitoring Target Views
	Monitoring Target Information

	Monitoring Process Views
	Monitoring Process Information
	Viewing Process Instance Workflows
	Canceling Running Process Instances

	Monitoring Activity Views
	Modifying Activity View Format
	Understanding Activity View Indicators
	Filtering Views

	Searching Work
	Monitoring Scheduled Work

	Monitoring Task Views
	Acting on Tasks
	Resolving a Task

	Searching Tasks
	Customizing the Search Tasks Header
	Filtering Search Results
	Filtering Display by [Objects]

	Defining Task Rules
	Adding Conditions to a Task Rule
	Modifying Task Types in a Task Rule

	Searching IT Records
	Monitoring Auditing Information

	Performing Basic Console Tasks
	Launching the Web Console
	Performing Web Console Actions
	Refreshing the Display
	Viewing the My Tasks Page
	Resolving Tasks in the Web Console
	Taking Ownership of a Task
	Starting Processes in the Web Console
	Overriding the Process Target
	Viewing My Process History
	Viewing an Automation Summary

	Refreshing the View
	Viewing and Modifying Object Properties
	Configuring the Navigation Pane
	Customizing the Fonts and Colors
	Matching a Regular Expression
	Changing the Process Display Icon
	Configuring the Display Refresh Rate
	Configuring Columns
	Searching for an Object
	Modifying the Console Time Zones
	Enabling and Disabling an Object
	Deleting an Object
	Connecting to a Server
	Specifying Server Credentials
	Displaying Recent Servers
	Assigning Credentials to Processes and Activities
	Modifying the Condition Branches
	Assigning a Category
	Suspending Server Automation
	Viewing the Properties of an Object
	Viewing Activity Instance Properties
	Viewing Environment Properties
	Viewing Runtime Usage Properties
	Viewing the Used By Properties of an Object
	Viewing the History of an Object
	Creating an Alert Task
	Creating an Approval Request Task
	Creating a Change Request Task
	Creating a Guided Operation Task
	Creating an Incident Task
	Creating an Input Request Task
	Creating a Review Task
	Adding a Related Task
	Adding an Option to the Input Request Select Question
	Assigning a Category to a Task
	Assigning a Duplicate Alert
	Creating a Check Box Question
	Creating a Hidden Text Question
	Creating a Select Question
	Creating a Text Question
	Manually Changing the Status
	Modifying the Assignment Properties for a Task
	Specifying Parameters for a Task
	Resolving a Task
	Viewing Task History
	Reversing Process Changes
	Deleting a Calendar
	Removing Dates from a Calendar List
	Applying a Value to a Target-Specific Target Property
	Viewing Target Properties
	Inserting Reference Variables

	Performing Administrative Actions
	Managing Properties
	Viewing Process Orchestrator Server Properties
	Setting Process Orchestrator Console Environment Properties
	Updating the Product License
	Managing Time Zone Properties

	Managing Database Settings
	Managing the Process Database
	Managing the Report Database
	Viewing the SQL Server Connection Properties
	Viewing the Oracle (Oracle Authentication) Connection Properties
	Viewing the Oracle via TNS (Oracle Authentication) Connection Properties
	Viewing the Oracle via Service name (Oracle Authentication) Connection Properties
	Creating a Reporting Database Connection
	Importing Reports into SQL Reporting Services
	Importing Reports into BusinessObjects
	Configuring the BusinessObjects Connection for the Process Orchestrator Report Database
	Accessing SQL Server Reporting Service Reports
	Accessing Reports in BusinessObjects InfoView
	Modifying the Report Database

	Configuring Security
	Role-Based Access Control (RBAC)
	Predefined Security Roles
	Predefined Security Permissions
	Object Owners

	Changing the Owner of a Security Role
	Removing Users from Security Roles
	Modifying Security Permissions
	Deleting a Security Role


	Working with Events and Triggers
	Creating Triggers
	Creating a New Trigger
	Creating a Schedule Trigger
	Creating a Task Trigger
	Creating a Variable Updated Trigger
	Adding Trigger Logic to Process Workflows

	Correlating Events
	Creating Correlate Event Activities

	Integrating Using the Advanced Message Queuing Protocol (AMQP)
	Debugging Process Trigger Instances
	Queue Resources
	Creating a Queue Block
	Creating a Queue Resource


	Using Adapters
	Target General Tab
	Target Configuration Tab
	Target Permission Tab
	Target General Information
	Completing the New Object Wizard Panel
	User Assignments tab
	Configuring Adapters
	Viewing Adapter Prerequisites
	Viewing Adapter Properties
	Viewing Objects Provided by the Adapter

	Advance Message Queuing Protocol (AMQP) Adapter
	Getting Started Using the AMQP Adapter
	Managing AMQP Messages
	Receiving Messages Based on a Pattern

	Defining an AMQP Broker Target
	Automating Cisco AMQP Tasks
	Declaring an AMQP Exchange
	Declaring an AMQP Queue
	Binding an AMQP Queue to an Exchange
	Publishing a Message
	Getting a Message
	Purging an AMQP Queue
	Unbinding an AMQP Queue
	Deleting an AMQP Queue


	AMQP Activities Instance Properties
	Argument Instance Dialog
	AMQP Message Event Instance Properties Message Tab
	AMQP Message Event Instance Properties, Advanced Tab
	Bind Queue
	Content Header
	Declare Exchange
	Declare Queue
	Delete Queue
	Exchange
	Get Message
	Message Tab
	Publish Message
	Purged Messages
	Purge Queue
	Unbind Queue

	Microsoft Service Bus Adapter
	Getting Started Using the Microsoft Service Bus Adapter
	Managing Service Bus Messages
	Receiving Messages Based on a Pattern

	Defining an Microsoft Service Bus Target
	New Shared Access Key Properties

	Automating Microsoft Service Bus Tasks
	Sending a Message
	Getting a Message


	Cloud Center Adapter
	Defining a Cloud Center Target
	New Cloud Center API Access Credentials Properties

	Execute Cloud Center Command
	Cloud Center Response


	BMC Remedy Adapter
	Prerequisites
	Installing Remedy client C API Library Files

	Getting Started Using the Remedy Adapter
	Defining a Remedy Server Target
	Managing Remedy Tasks
	Creating a Remedy Entry
	Initiating an Incident Request Review
	Creating a Relationship Between an Incident Request and a Problem
	Adding Properties to a Remedy Activity
	Configuring Relationship Configuration Item Properties
	Adding Incident Properties to a Remedy Trigger
	Adding a New Work Info Entry to an Existing Remedy Property
	Deleting a Remedy Entry
	Finding Remedy Objects
	Get Remedy Entry Property Values
	Get Remedy Incident Property Values
	Defining an Update Remedy Entry Activity
	Defining an Update Remedy Incident Activity
	Selecting a Remedy Form
	Configuring Relationship Incident Properties
	Selecting an Association Type
	Attaching a File to a Remedy Activity

	Instance Properties
	Create Remedy Entry
	Create Remedy Entry Results
	Create Remedy Incident
	Create Remedy Incident Results
	Create Remedy Relationship, Configuration
	Create Remedy Relationship, Incident
	Create Remedy Relationship, Item
	Create Remedy Relationship Results
	Create Remedy Work Info
	Create Remedy Work Info Results
	Delete Remedy Entry
	Find Remedy Objects
	Find Remedy Objects, Results
	Get Remedy Entry Property Values
	Get Remedy Entry Property Values, Results
	Get Remedy Incident Property Values
	Get Remedy Incident Property Values, Results
	Update Remedy Entry
	Update Remedy Incident

	Element Descriptions
	Select Remedy Properties Dialog Box


	Cisco Prime Service Catalog Adapter
	Getting Started Using the Prime Service Catalog Adapter
	Configuring the Service Catalog Server Adapter Reconnection Properties
	Defining a Cisco Prime Service Catalog Server Target
	Automating Cisco Prime Service Catalog Adapter Activities
	Defining the Create Service Item Activity
	Defining the Complete Service Request Activity
	Defining the Create Service Item from Table Activity
	Defining the Delete Service Item Activity
	Defining the Delete Service Item from Table Activity
	Defining the Find Service Item Activity
	Defining the Get Service Item Activity
	Defining the Delete Service Item from Table Activity
	Defining the Get User Information Activity
	Defining the Submit Service Request Activity
	Defining the Update Service Item Activity
	Defining the Update Service Item from Table Activity
	Defining the Update Service Request Activity
	Defining the Cancel Service Request Activity
	Defining the Execute Python Script
	Execute Python Code Properties
	Python Code Results

	Typical Cisco Prime Service Catalog Tasks
	Adding a Service Item Attribute
	Manually Adding a Dictionary
	Browsing for Dictionaries
	Specifying the Owner for the Service Item
	Specifying Requestor Credentials for the Service Request

	Instance Properties
	Cancel Service Request
	Complete Service Request
	Create Service Item
	Create Service Items from Table
	Delete Service Item
	Delete Service Items from Table
	Find Service Items, Advanced
	Find Service Items, Results
	Find Service Items, Service Item
	Find Service Item, Subscription
	Get Service Item
	Get User Information
	Get User Information Results
	Submit Service Request
	Submit Service Request, Advanced
	Submit Service Request, Results
	Update Service Item
	Update Service Items from Table
	Update Service Request
	Update Service Request, Parameters


	OpenStack Adapter
	Getting Started Using the OpenStack Adapter
	Defining an OpenStack User
	Defining an OpenStack Server Target
	Automating OpenStack Adapter Activity
	Defining the Execute OpenStack Command Activity


	Cisco Process Orchestrator Adapter Help for Email
	Overview
	Managing Email Objects
	Email Targets Overview

	Defining the Email Account Target

	Viewing Email Properties
	Managing Email Activities
	Defining the Email Activity
	Define a Get Email Attachments Activity

	Element Descriptions
	Service Request Parsing Rules Page
	Add/Edit Property Dialog
	Add Value Dialog Box
	XPath Query Page

	Core Adapter
	Getting Started Using the Core Adapter
	Configuring the Core Function Adapter
	Configuring Automation Summary Settings
	Configuring Return on Investment
	Getting Task XSL Transforms
	Publishing Metrics to the Window Management Instrumentation Provider

	Defining Core Adapter Activities
	Defining the Calculate Date Activity
	Defining the Calculate Date Time Difference Activity
	Defining the Cast Target Type Activity
	Defining the Convert JSON to XML Activity
	Defining the Convert XML to JSON Activity
	Defining the Correlate Process Event Activity
	Defining the Create Automation Summary Activity
	Defining the Find Target Activity
	Defining the Format Date Activity
	Defining the Insert Event Activity
	Defining the Match Regular Expression Activity
	Defining the Parse Date Activity
	Defining the Ping Hosts Activity
	Ping Hosts Results
	Defining the Publish Metric Activity
	Defining the Raise Process Event
	Defining the Set Multiple Variables Activity
	Modifying the Value of a Defined Variable
	Defining the Sleep Activity
	Defining the Test FTP Destination Activity
	Defining the Update Target Activity
	Defining the XPath Query Activity
	Defining the XSL Transform Activity


	Database Adapter—Microsoft SQL Server
	Getting Started Using the Microsoft SQL Server Database Adapter
	Defining an SQL Server Database Target
	Automating SQL Queries in the Microsoft SQL Server Database
	Executing a Microsoft SQL Server SQL Script


	Database Adapter—Generic (OLEDB)
	Getting Started Using the Generic (Microsoft OLEDB) Database Adapter
	Defining a Generic Data Source (OLEDB) Target
	Automating SQL Queries in the Generic (Microsoft OLEDB) Database
	Executing a Generic (OLEDB) SQL Script


	Database Adapter—Oracle
	Getting Started Using the Oracle Database Adapter
	Defining an Oracle Database Target
	Automating Oracle Database Activities
	Modifying Oracle DB Instance Case-Sensitive Settings
	Executing an Oracle SQL Script
	Reviewing the SQL Script
	Viewing the Oracle Table Space
	Listing the Oracle Heavy Queries


	Database Adapter—JDBC
	Getting Started Using the JDBC Adapter
	Prerequisites
	Downloading the JDBC Driver Type (JAR File)

	Configuring the JDBC Driver Type
	Defining a JDBC Server Target
	Automating SQL Queries in the Database Via JDBC
	Executing SQL Script via JDBC
	Errors


	Database Adapter—Common Database Tasks
	Performing Bulk Database Insertions
	Selecting Data from a Database
	Updating Data from a Database
	Inserting Data from a Database
	Deleting Data from a Database
	Configuring Database Adapters
	Adding a Column to an SQL Command Line
	Adding a Column to Table Source

	Email Adapter
	Getting Started Using the Email Adapter
	Configuring Default Email Settings
	Defining an Email Account Target
	Defining the Email Account IMAP Target
	Defining the Email Account POP3 Target

	Defining Email Triggers
	Defining an Email Event (Simple) Trigger
	Adding Email Criteria for a Trigger

	Defining the Email Activity

	Microsoft Active Directory Adapter
	Getting Started Using the Microsoft Active Directory Adapter
	Creating an Active Directory Domain Target
	Automating Active Directory Domain Activities
	Defining a Create User Account Activity
	Defining the NetDiag Activity
	Defining the Resolve Email Address Activity
	Defining the Resolve Identity Activity
	Defining the Set User Password Activity

	AD Instance Properties
	Create User Account Instance Properties
	Resolve Email Address Instance Properties
	Resolve Email Address Results
	User Properties
	User Identity Properties
	User or Group to Decide Instance Properties


	Microsoft System Center Operations Manager (SCOM) Adapter
	Getting Started Using the SCOM Adapter
	Defining a SCOM Management Server Target
	Automating SCOM Activities
	Defining the Collect SCOM Performance Counter Activity
	Defining the Update SCOM Alert Activity
	Searching for SCOM Performance Monitoring Options
	Searching for an Alert Source


	SNMP Adapter
	Getting Started Using the SNMP Adapter
	Configuring the SNMP Adapter
	Configuring Listening Port Settings
	Defining an SNMP Device (Agent) Target
	Defining an SNMP Device (Manager) Target
	Defining a SNMP Credentials Account
	Defining a SNMP Trap Received Trigger
	Automating SNMP Device (Agent) Command Activities
	Defining the Correlate SNMP Trap Received Activity
	Defining the Generate SNMP Trap Activity
	Defining the Generate SNMP Trap from Task Activity
	Defining the SNMP Get Request Activity
	Defining the SNMP Set Request Activity

	Adding a Variable to an SNMP Activity
	Defining an SNMP Credentials Account
	Automating SNMP Device (Manager) Command Activities

	Terminal Adapter
	Getting Started Using the Terminal Adapter
	Configuring the Terminal Adapter
	Configuring SSH Version 2.0 Support for Cisco IOS Devices
	Configuring an Expect Template
	Enabling the FIPS-Compliance JCE Provider
	Configuring Default Host-Based Authentication Keys
	Selecting a Private Key
	Selecting a Public Key
	Configuring Total Concurrent Sessions
	Adding an Expect Parameter

	Defining Terminal Adapter Targets
	Defining a Network Device Module Target
	Defining a Terminal Target
	Defining a Unix Linux System Target

	Defining Terminal Adapter Runtime Users
	Defining a Public-key Authenticated Admin Runtime User
	Defining a Runtime Admin User

	Automating Terminal and Secure Shell (SSH) Activities
	Defining a Close Terminal Session Activity
	Defining a Get File Activity
	Adding a Remote File to a Get File Activity
	Defining a Put File Activity
	Adding a Local File to a Put File Activity
	Defining an Execute Unix/Linux SSH Command Activity
	Defining an Execute Unix/Linux SSH Script Activity
	Defining an Open Terminal Session Activity

	Troubleshooting the Terminal Adapter
	Activity Output Does Not Match Expect Prompts
	Correcting Open Session Activity Timeout Error
	Execute Terminal Command Activity Timed Out
	Expect Prompt Command Error
	Target Connection Pattern Prompt Prefix Error


	UCS Director Adapter
	Getting Started Using the Cisco UCS Director Adapter
	Defining a Cisco UCS Director Server Target
	Generating the REST XML for a Task Invocation
	Automating Cisco UCS Director Task and Workflow Activities
	Defining a Cisco UCS Director Operation Activity
	Defining a Cisco UCS Director Task Activity
	Defining a Cisco UCS Director Workflow
	Defining a Get Workflow Status Activity


	UCS Software Adapter
	Getting Started Using the Cisco UCS Software Adapter
	Creating a Cisco UCS Manager Target
	Specifying Cisco UCS Default Assignment
	Creating a Cisco UCS Fault Trigger
	Automating a Cisco UCS Activity
	Defining the Associate UCS Service Profile to Server Activity
	Defining the Create UCS Service Profile From Template
	Defining the Correlate UCS Faults Activity
	Defining the Associate UCS VLAN To vNIC Activity
	Defining the Collect UCS Statistics Activity
	Defining the Create UCS Configuration Backup Activity
	Defining the Disassociate UCS Service Profile Activity
	Defining the Execute UCS Manager Command Activity
	Inserting Formatted Date Into Activity
	Defining the Modify UCS Service Profile Activity
	Defining the Disassociate UCS VLAN from VNC Activity
	Defining the Modify UCS VLAN Settings Activity
	Defining the Reset UCS Server Activity
	Defining the Shutdown UCS Server Activity


	VMware vCloud Director Adapter
	Getting Started Using the VMware vCloud Director Adapter
	Viewing Adapter Properties
	Defining a VMware vCloud User
	Defining a VMware vCloud Director Server Target
	Automating VMware vCloud Command Activities
	Defining an Execute vCloud Command Activity
	Defining an Execute vCloud Query Activity


	VMware vCenter, ESX, and ESXi Adapter
	Getting Started Using the VMware vSphere Adapter
	Configuring the VMware vSphere Adapter
	Configuring the ESX HTTPS Protocol
	Configuring the Keystore Password
	Configuring VMware vCenter HTTPS Protocol
	Configuring IP Address Settings
	Configuring Network Properties
	Selecting a Managed Object

	Managing VMware vSphere Targets
	Defining a VMware vSphere Hypervisor Target
	Defining a VMware vCenter Server Target

	Managing VMware Triggers
	Defining a VMware Host Performance Event Trigger
	Defining a VMware Virtual Machine Performance Event Trigger
	Defining a VMware Virtual Machine Power Event Trigger
	Selecting Performance Counters to Monitor

	Automating VMware vSphere Activities
	Adding an Optical Drive to a Virtual Machine
	Adding a Physical Adapter to a vSphere Distributed Switch
	Adding a Hard Disk to a Virtual Machine
	Adding a Network Adapter to a Virtual Machine
	Cloning a Virtual Machine
	Creating a Folder
	Creating a New Virtual Machine
	Customizing the Linux OS of a Virtual Machine
	Customizing the Windows OS of a Virtual Machine
	Deleting a Virtual Machine
	Retrieving the Datastores in a Virtual Machine
	Retrieving the Networks in a Virtual Machine
	Retrieving the Resource Pools in a Virtual Machine
	Finding the Managed Object Reference
	Migrating a Virtual Machine
	Querying the List of VM Devices on a Virtual Machine
	Querying the Network Adapters on a Virtual Machine
	Querying the Properties of a Virtual Machine
	Querying the Virtual Machines on an ESX or vCenter Server
	Reconfiguring the Virtual Machine on an ESX or vCenter Server
	Relocating a Virtual Machine
	Removing a Virtual Machine from a vCenter Server
	Mounting an ISO Image
	Removing a Folder
	Unmounting an ISO Image
	Updating a Hard Disk on a Virtual Machine
	Updating a Network Adapter on a Virtual Machine
	Upgrading the Hardware on a Virtual Machine
	Upgrading the VM Tools on a Windows Virtual Machine
	Retrieving Resource Pools

	Managing VMware vSphere Host Activities
	Adding a New Host
	Adding a New Host Port Group
	Adding a Host to a vSphere Distributed Switch
	Moving a VM Host Server to Maintenance Mode
	Moving a VM Host Server from Maintenance Mode to Online
	Powering Down an ESX Host Server to Standby State
	Powering Up a Host Server from Standby State
	Querying the Network Adapters on an ESX Server
	Querying the Properties of a Host Server
	Querying the Storage Adapters for a Host Server
	Querying the List of Hosts
	Rebooting a VM Host Server
	Removing an ESX Host
	Removing a Host from a vSphere Distributed Switch
	Removing an Adapter from a vSphere Distributed Switch
	Shutting Down a Host
	Updating a Host Port Group

	Managing VMware vSphere Power Activities
	Executing a PowerCLI Script
	Powering Off a Virtual Machine
	Powering On Virtual Machine
	Rebooting a Guest Operating System on a Virtual Machine
	Resetting the Power on a Virtual Machine
	Shutting Down a Guest Operating System on a Virtual Machine
	Moving a Guest Operating System on a Virtual Machine to Standby Mode
	Suspending a Virtual Machine

	Managing VMware vSphere Snapshot Activities
	Creating a Snapshot of a Virtual Machine
	Querying the Properties of a Virtual Machine Snapshot
	Managing the Virtual Machine Snapshots
	Removing All Snapshots of a Virtual Machine
	Removing a Specific Snapshot of a Virtual Machine
	Renaming a Snapshot of a Virtual Machine
	Restoring a Virtual Machine to the Most Current Snapshot
	Reverting a Virtual Machine to a Specific Snapshot
	Taking a Snapshot of a Virtual Machine


	Web Console Help Adapter
	Managing Tasks
	Displaying Details About a Task You Have Run
	Filtering the Tasks Display
	Resolving an Assigned Task
	Taking Ownership of a Task
	Viewing an Automation Summary

	Running Processes
	Filtering the Display by Category
	Starting a Process
	Overriding a Process Target

	Process History
	Filtering My Process History
	Viewing My Process History
	Viewing Process Activity Information


	Web Services Adapter
	Getting Started Using the Web Services Adapter
	Configuring the Web Services Adapter
	Configuring HTTP Endpoints for Process Orchestrator Web Service
	Configuring Authentication for HTTP Endpoints for Process Orchestrator Web Service
	Selecting a Client Certificate
	Configuring URL Prefixes to Ignore Certificate Errors

	Defining a Web Target
	Defining an OAuth Credential Account
	Automating Web Services Adapter Activities
	Defining a URL Ping Activity
	Defining a Web HTTP Request Activity
	Defining a Web HTTP Save File Activity
	Defining a Web Service Execute Activity
	Selecting a Web Service Method
	Defining the Web Service Parameters
	Defining the HTTP Headers
	Adding Customized Header Requests
	Defining the Build Class Properties
	Modifying the List of Headers
	Defining Cookie Properties for Web Service Activity
	Inserting a Web Service Cookie Data Table Reference Property

	Viewing Web Service Activity Results
	Viewing the URL Ping Response Time
	Viewing the Web HTTP Request Activity Results
	Viewing the Web HTTP Save File Results
	Viewing the Web Service Execute Activity Results


	Windows Adapter
	Getting Started Using the Microsoft Windows Adapter
	Defining a Microsoft Windows Target
	Defining a Windows User
	Creating a Microsoft Windows Event Trigger
	Automating Microsoft Windows Adapter Activities
	Defining the Control Windows Service Activity
	Defining a Windows Ping Activity
	Defining a Correlate Windows Event Activity
	Defining the Copy Folders Activity
	Defining the NSLookup Activity
	Defining the Execute Windows Command Activity
	Defining Uninstall Application Activity
	Defining Trace Route Activity
	Defining the Execute Windows PowerShell Script Activity
	Defining Copy Folders Activity
	Defining the Execute Windows Script Activity
	Adding a Script Argument
	Define a Stop a Windows Process Properties Activity
	Defining the Query Windows Events Activity
	Defining the Read File Activity
	Defining Get Folder Properties Activity
	Defining the Query Windows Performance Counter Activity
	Defining Restart Server Activity
	Defining the Query Windows Registry Activity
	Defining the Query Windows Service Activity
	Defining the Create Folder Activity
	Selecting a Registry Key
	Defining the Update Windows Registry Activity
	Defining the Update Windows Service Activity
	Defining the Write File Activity


	Networking Adapter
	Defining the Convert Integer to IP Address Activity
	Defining the Convert IP Address to Integer Activity

	Cisco Process Orchestrator Adapter Help for Terminal Adapter
	Overview
	Configuring Terminal Adapter
	Configuring SSH Version 2.0 Support for Cisco IOS Devices
	Configuring an Expect Template
	Enabling the FIPS-Compliance JCE Provider
	Configuring Default Host-Based Authentication Keys
	Supported Cisco Appliances
	Supported Cisco Routers
	Supported Cisco Switches

	Managing Terminal Objects
	Defining a Public-key Authenticated Admin Runtime User
	Defining a Public-key Authenticated Admin Runtime User

	Defining a Network Device Module Target
	Defining a Terminal Target
	Defining a Unix Linux System Target
	Configuring Total Concurrent Sessions
	Adding an Expect Parameter
	Removing an Expect Parameter
	Viewing Terminal Target Properties
	Viewing Network Device Modules
	Viewing Target Open Sessions

	Defining Terminal Activities
	Overview
	Defining a Close Terminal Session Activity
	Defining a Get File Activity
	Defining a Put File Activity
	Defining an Execute Terminal Command Activity
	Defining an Execute Unix/Linux SSH Command Activity
	Defining an Execute Unix/Linux SSH Script Activity
	Defining a Stop a Unix Process via SSH Properties
	Defining an Open Terminal Session Activity
	Modifying Terminal Activities
	Adding a Script Argument
	Command Line Examples
	Script Argument Example
	Script Argument Syntax

	Viewing Terminal Activity Results
	Viewing Execute Terminal Command(s) Results
	Viewing Close Terminal Session Output
	Viewing Executed Unix/Linux SSH Command Output
	Viewing Executed Unix/Linux SSH Script Output
	Viewing Get File Activity Results
	Viewing Open Terminal Session Output
	Viewing Expect Instance Tab Results
	Viewing Put File Activity Results
	Viewing Get Interface Inputs
	Viewing Get Interface Outputs
	Get Interface List Instance Properties - Inputs
	Get Interface List Instance Properties - Outputs

	Troubleshooting Terminal Adapter
	Activity Output does not match Expect Prompts
	Correcting Open Session Activity Timeout Error
	Execute Terminal Command Activity Timed Out
	Expect Prompt Command Error
	Target Connection Pattern Prompt Prefix Error


	Cisco Network Services Manager
	Overview


	Using SAP Adapters
	Configuring SAP Targets
	Creating SAP System Targets

	SAP Reference Information
	SAP AP
	SAP Connection Properties
	SAP Telnet Connection Properties
	Browse for MBean Dialog

	SAP RFC Adapter
	SAP RFC Function Methods
	SAP RFC Function Methods Results

	Managing SAP Solution Manager Targets
	Creating an SAP Solution Manager Target
	 SAP Solution Manager Wizard
	SAP Solution Manager Wizard—Options

	Managing SAP Solution Manager Triggers
	Creating an SAP Solution Manager Trigger

	SAP Solution Manager Activities
	Correlate Solution Manager Alerts Activity Properties—Solution Manager Alert Criteria
	Get Solution Manager Alert Metrics – Alert Metrics
	Get Solution Manager Managed Object Metrics – Managed Object Metrics
	Update Solution Manager Alert Activity Properties—Update Alert

	Activity Results
	Correlate Solution Manager Alerts Instance Properties—Correlated Alerts



	Using the PowerShell Snap-in CLI
	Managing High Availability and Resiliency
	Understanding High Availability and Resiliency
	Advance Planning
	Creating the Cisco Process Orchestrator Support Team
	Planning for High Availability
	Storing the Information
	Considering Dependencies on Other Services

	Ensuring Operational Continuity
	Backing Up Your Data
	Saving the Process Orchestrator Server Data in Preparation for a Disaster

	Monitoring Processes and Events
	Monitoring Processes
	Managing Events

	Handling Errors, Exceptions, and Diagnostics

	Maintaining Availability During Routine Maintenance
	Handling Routine Maintenance Outages
	Adding More Capacity
	Relocating a Process Orchestrator Server
	Maintaining the Database
	Grooming the Database
	Database Performance Best Practices


	Performing Disaster Recovery
	Recovering from a Server Failure
	Recovering from a Reporting Database Failure
	Restoring the Database to a New Database Server
	Recreating a New Database on a New Database Server

	Recovering from a Total Database Failure
	Recovering from an Entire Environment Failure

	Handling Restarts and Failures
	Handling Running Processes During Restarts and Failures
	Handling Reporting Data Queues During Restarts and Failures
	Handling Scheduled Triggers During Restarts and Failures
	Handling Events During Restarts and Failures

	Windows Performance Counters
	Cisco Process Orchestrator Object
	Cisco Process Orchestrator Adapter Object
	Cisco Process Orchestrator Persistent Queue Object
	Cisco Process Orchestrator Data Access Layer Operations Object
	Cisco Process Orchestrator SAP Connections



