CHAPTER
4

Setting Up Cisco Prime LMS in High Availability and Disaster Recovery Environment

This chapter explains setting up LMS in a High Availability (HA) and Disaster Recovery (DR) environment on Windows and Solaris systems. The High Availability solution is based on Symantec’s Veritas Storage Foundation products.

This section explains:
- High Availability and Disaster Recovery- An Overview
- Veritas Components for Setting Up High Availability
- System Requirements for High Availability Implementation
- Setting up LMS High Availability Environment on Windows
- Setting up LMS High Availability Environment on Solaris
- Moving LMS from non-HA to HA Environment

High Availability and Disaster Recovery- An Overview

High Availability refers to a state where data and applications are available always because software or hardware has been installed to maintain the continued functioning in spite of computer or processes failure.

High availability is a configuration of hardware and software that allows you to:
- Monitor the services provided by a system
- Transfer of those services to another system when there is a catastrophic system failure

Disaster Recovery refers to the ability to recover from the catastrophic failure of the complete primary site because of a disaster or disruption. Disaster Recovery configuration involves the duplication of hardware and software at a remote site, with data replication occurring on a regular basis. Only then, the remote site can take over the responsibilities of providing the services with little or no loss of data.

The High Availability solution has the following benefits:
- Reduces planned and unplanned downtime.
- Allows you to enable failover between clusters in a local redundancy configuration and between sites in a geographic redundancy configuration.
- Manages applications and allows you to bring the processes online or take them offline.
- Consolidates hardware in clusters.
The implementation of Symantec Veritas High Availability solution in LMS Server supports local redundancy (HA), geographic redundancy (DR) and Replication without clustering configurations. The following configurations that are implemented by Symantec Veritas High Availability solution in LMS Server, are supported through the local hard disks only:

- **Local redundancy (dual-node within a single site)**
  The local redundancy configuration provides an automatic failover solution in the event of software or hardware failures without the need to reconfigure IP Addresses or DNS entries on the switched or routed network.

- **Geographic redundancy (single-node across two sites)**
  The geographic redundancy configuration provides disaster recovery by replicating application data between two sites. Switch over between sites (redundant server) can be initiated manually or performed automatically when there is a network failure or during abnormal conditions.

- **Replication without clustering**
  This refers to the replication of data across servers without creating a cluster configuration.

---

**Note**

The local redundancy (HA), geographic redundancy (DR) and Replication without clustering configurations are not supported in a Storage Area Network (SAN) environment.

Figure 4-1 displays local redundancy (high availability) configuration.

*Figure 4-1  Local Redundancy Configuration*
Veritas Components for Setting Up High Availability

The following Symantec Veritas components are used in the LMS high availability solution:

- **Veritas Storage Foundation**
  Provides volume management technology, quick recovery, and fault tolerant capabilities to enterprise computing environments. Veritas Storage provides the foundation for Veritas Cluster Server and Veritas Volume Replicator.

- **Veritas Volume Replicator**
  Provides a foundation for continuous data replication over IP networks, enabling rapid and reliable recovery of critical applications at remote recovery sites.

- **Veritas Cluster Server (VCS)**
  Clustering solution to reduce application downtime. A cluster connects multiple independent systems to provide fault tolerance and failover capability, thus reducing the downtime. VCS supports both local and global clusters.

- **Global Cluster Option (GCO)**
VCS add-on that allows managing multiple clusters, as in a Disaster Recovery environment.

The following Symantec Veritas GUI applications are used in LMS high availability solution:

- **Veritas Enterprise Administrator (VEA) Console**
  Provides a graphical view of storage and allows you to monitor or manage storage objects such as disk groups and disk volumes.

- **Cluster Management Console**
  Allows you to monitor, manage, and report on multiple VCS clusters from a single web-based console. This console provides enhanced visualization of the managed clusters, and centralized control for global applications. It also provides reports on the status of the availability of each application.

- **Cluster Manager (Java Console)**
  Provides complete administration capabilities for clusters and different views to monitor the clusters, systems, service groups, and resources.

### Licensing Information

In a high availability or a geographic redundancy option, the LMS is active on only one server at any given point in time. Hence only a single license of LMS needs to be procured to be shared between the two servers (Primary and Secondary servers) running in Active-Standby mode respectively.

### System Requirements for High Availability Implementation

This section explains the Operating system and hardware requirements for Veritas implementation:

**Operating Systems**

- Solaris 10 systems
- Windows 2008 64 bit Enterprise Edition

**Hardware Requirements**

- Each server should have at least two hard disks for Windows implementation and three hard disks for Solaris implementation. The additional hard disk should be chosen for disk group and volume creation.
- Each server should have two Network Interface Cards (NICs) assigned to it. One of the IP Addresses can be assigned with a private IP address on both Primary and Secondary servers and they should be connected as a direct link. This requirement is not mandatory for a geographic redundancy configuration.
- You should install Storage Foundation on servers under the Domain Controller.
- You should configure name resolution for all the nodes.

**General Requirements**

- Veritas Volume Replicator requires a static IP for replication. Make sure the system has atleast one IP address configured which is resolved by DNS.
• VCS Cluster Manager (Java Console) requires an 8-bit display and a graphics card that can render 2D images.
• We recommend that all servers must run the same Operating System, service pack level and system architecture.

Setting up LMS High Availability Environment on Windows

This section explains setting up Veritas implementation on a Windows system.

• Installing Storage Foundation HA 5.1 on Windows
• Creating Disk Groups and Volumes
• Installing LMS on Primary and Secondary Servers
• Setting Up Veritas Volume Replication
• Setting Up Veritas Volume Replication Without Clustering
• Veritas Cluster Server Setup Tasks

Installing Storage Foundation HA 5.1 on Windows

To install the product:

Step 1 Start the Veritas Storage and High Availability Solutions setup.
Step 2 Click Storage Foundation HA 5.1 for Windows.
Step 3 Click Complete/Custom to begin the installation.
Step 4 Review the Welcome message and click Next.
Step 5 Accept the license agreement and click Next.
Step 6 Enter the product license key for Veritas Storage Foundation HA 5.1 for Windows and click Add.
Step 7 Click Next to select the product options.
   a. Ensure that the following products are selected:
      – Veritas Storage Foundation HA 5.1 for Windows (Server components)
      – Veritas Storage Foundation HA 5.1 for Windows (Client components)
   b. Ensure that the following product options are selected:
      – Veritas Volume Replicator—Replicates data across multiple sites for disaster recovery.
      – FlashSnap—Allows you to create and maintain persistent snapshot of volumes
      – VxCache—Uses a portion of system memory to improve I/O performance.
      – Global Cluster Option—Enables you to link clusters to provide wide-area failover and disaster recovery.
      – Product Documentation—Documentation of Veritas Storage Foundation HA 5.1 for Windows
Step 8 Select the domain and the computer for the installation, and click Next.

You can select the domain from the auto-populated list. Depending on domain and network size, speed, and activity, the domain and computer lists can take some time to populate.
You can choose the computer name from the list of servers.
When the domain controller and the computer that runs the installation program are on different subnets, the installer may not be able to locate the target computers.
You must manually enter the host names or the IP Addresses of the missing computer names.

**Step 9**
Review the installation settings information and click Next.
The Installation Status screen displays the status messages and the progress of the installation.

**Step 10**
Review the installation summary information and click Next after the installation has completed.

**Step 11**
Click Finish.

**Step 12**
Click Yes to reboot the local node.

---

**Creating Disk Groups and Volumes**

A disk group is a collection of disks that is ported as a single unit. Veritas Storage Foundation uses disk groups to organize disks for management purposes.

Volumes are logical entities that comprises of portions of one or more physical disks and are accessed by a drive letter or mount point. Volumes can be configured for performance and high availability.

This section explains:
- Prerequisites for Configuring Disk Groups and Volumes
- Creating Disk Groups on Primary Server
- Creating Volumes on Primary Server
- Creating Disk Groups and Volumes on Secondary Server

**Prerequisites for Configuring Disk Groups and Volumes**

Complete the following tasks before you configure the disk groups and volumes:
- Determine the configuration of each volume and the total number of disks needed.
- Determine the initial size necessary for the volumes. You may increase the volume size at a later time but you cannot decrease the size.
- Verify that the disks you plan to include in the disk groups are available from all nodes.
- Verify that the drive letters that will be assigned to the volumes are available on all nodes so that the volumes can be accessed from any node.

**Creating Disk Groups on Primary Server**

You must create the disk group on the first node where the product instance is being installed. Repeat the procedure if you want to create additional disk groups.

To create a disk group:

**Step 1**
Click Start > All Programs > Symantec > Veritas Storage Foundation > Veritas Enterprise Administrator to launch the Veritas Enterprise Administrator (VEA) console.

**Step 2**
Select a profile if prompted. You can also select the default profile.
Chapter 4  Setting Up Cisco Prime LMS in High Availability and Disaster Recovery Environment

Setting up LMS High Availability Environment on Windows

Step 3  Click Connect to a Host or Domain.

Step 4  Enter the host name of the server which you want to connect in the Host Name field or select a host name from the drop-down list box.

To connect to the local system, enter localhost.

Step 5  Click Connect.

You must provide the user name, password, and domain name if prompted.

You can see the host name of the server added on to the VEA console.

Step 6  Expand the tree view under the host node to configure a disk group under the StorageAgent tree node.

Step 7  Locate the StorageAgent tree node and right-click the Disk Groups icon under the StorageAgent tree node.

Step 8  Select New Dynamic Disk Group from the shortcut context menu.

The New Dynamic Disk Group wizard appears with the welcome page.

Step 9  Click Next to go to next page in the wizard.

Step 10  Provide the information about the disk group:

a. Enter a name for the disk group in the Group Name field.

You should enter datadg as group name.

b. Select the Create Cluster Group checkbox.

While creating datadg disk group, if the system bus error appears, you must run this command:

Vxclus UseSystemBus ON

c. Select the appropriate hard disks in the Available disks list, and use the Add button to move them to the Selected disks list.

You should not select the boot disks from the Available disks list.

d. Click Next.

Step 11  Click Next to accept the confirmation screen with the selected tasks.

Step 12  Click Finish to create the new disk group.

---

Creating Volumes on Primary Server

This section will guide you through the process of creating a volume on a cluster disk group. Repeat the procedure below if you want to create the following volumes on the first node of the cluster.

To create a volume:

Step 1  Click Start > All Programs > Symantec > Veritas Storage Foundation > Veritas Enterprise Administrator to launch the Veritas Enterprise Administrator (VEA) console.

Step 2  Select a profile if prompted.

You can also select the default profile.

Step 3  Click Connect to a Host or Domain.

Step 4  Enter the host name of the server which you want to connect in the Host Name field or select a host name from the drop-down list box.
To connect to the local system, enter `localhost`.

**Step 5** Click **Connect**.

You must provide the user name, password, and domain name if prompted. You can see the host name of the server added on to the VEA console.

**Step 6** Expand the tree view under the host node to configure a disk group under the StorageAgent tree node. See *Creating Disk Groups on Primary Server* for details on how to create a disk group.

**Step 7** Locate the StorageAgent tree node and right-click the Volumes icon under the StorageAgent tree node.

**Step 8** Select **New Volume** from the shortcut context menu.

The New Volume wizard appears with a welcome message.

**Step 9** Click **Next** to go to the next page in the wizard.

**Step 10** Click **Manually select disks** and select the available disks (datadg) for the volume.

Ensure that the appropriate disk group name appears in the Group name drop-down list.

**Step 11** Click **Next**.

**Step 12** Specify the parameters of the volume:

- a. Enter a name for the volume in the Volume Name field.
  
  You should enter `cscopx` as volume name.

- b. Select the volume type as concatenated volume.

- c. Provide a size for the volume.
  
  For example, you can enter as 10 GB. Ensure that the disk has sufficient space before providing a size for the volume.

- d. Click **Next**.

  The Add Drive Letter and Path dialog box appears.

**Step 13** Select **Assign a Drive Letter**, and choose a drive letter.

We recommend that you do not assign D: for this volume. This is because, the CD-ROM drive when installed on the system, may be allocated with D: by default.

**Step 14** Click **Next**.

The Create File System dialog box appears.

**Step 15** Select the **Format this volume** checkbox.

**Step 16** Select the file system as **NTFS**.

**Step 17** Click **Next** to review the settings summary.

**Step 18** Click **Finish** to create the new volume.

**Step 19** Repeat the above procedure to create a volume in the datadg disk group with the following characteristics:

- Volume Name: data_srl
- Volume Type: Concatenated Volume
- Volume Size: 30 GB
- Assigned Drive Letter: None
This volume will not be mounted and is used only by Veritas Volume Replicator.

Creating Disk Groups and Volumes on Secondary Server

You should launch the Veritas Enterprise Administration console on the Secondary server.

Create the identical disk group and volume as you have created on Primary server. See Creating Disk Groups on Primary Server and Creating Volumes on Primary Server for detailed explanation.

You should create the data_srl and cscopx volumes with the same size, type and drive letter.

Installing LMS on Primary and Secondary Servers

To make the LMS application highly available, install LMS on newly created cscopx volume on both the Primary and Secondary servers.

Ensure that:

- LMS is installed
- Admin password, Database password, and HTTP ports are the same on both the Primary and Secondary servers.
- Name of the LMS volume is the same on both the servers.
- Casuser settings configured should be the same on both the servers.

Note

After installing LMS on Secondary server under cscopx volume, unmount the cscopx volume.

If you are using Veritas 5.0 and 5.1 storage foundations for setting up High Availability on a 64-bit environment and if the set up is not functioning properly, do the following soon after the LMS installation:

1. Back up the existing LMS.dll file from the location \NMSROOT\HA\LMS and \VCSHOME\bin\LMS to some other location and save it with different names.
2. Copy VCSdefault.dll /defaultagent50.dll for Veritas 5.0 or 5.1, respectively from VCSHOME location to \NMSROOT\HA\LMS and \VCSHOME\bin\LMS, and change the name to LMS.dll.

By default the VCSHOME is located at:

- On Windows, C:\Program Files\Veritas\Cluster Server\bin
- On Solaris, /var/VRTSvcs/bin

Note

To find out the VCSHOME location, give the echo %vcs_home% command in run prompt or console.
Setting Up Veritas Volume Replication

Veritas Volume Replicator is a fully integrated component of Veritas Volume Manager that replicates data to remote locations over any standard IP network to provide continuous data availability.

This section explains:

- **Modes of Replication**
- **Setting Up RDS, RVG and RLINK**
- **Setting Casuser Permissions on cscopx Volume**

**Modes of Replication**

The Veritas Volume Replicator replicates data in one of the following modes:

- **Synchronous**
  
  Ensures that an update has been acknowledged by the Secondary host, before completing the update at the Primary. If there is a network failure, it ensures that the update fails at the Primary server.

- **Asynchronous**
  
  The application updates are immediately reflected at the Primary server and sent to the Secondary server, later. The updates are stored on the Replicator Log until they are sent to the Secondary server.

- **Synchronous Override**
  
  In this mode, the replication is synchronous, as long as the network is available. If the network is unavailable, the replication is continued in the asynchronous mode. The pending updates are sent to the Secondary server when the network becomes available.

  This method is chosen by default for best support.

**Setting Up RDS, RVG and RLINK**

This section explains how to set up an Replication Data Set (RDS), which is the most important step to get replication started. Data is replicated from a Primary node where the application is running to one or more Secondary nodes.

An RDS consists of a Replication Volume Group (RVG) on the Primary node, and the corresponding RVG on the Secondary nodes.

A Replication Link (RLINK) is associated with an RVG and it establishes the link between the Primary and a Secondary RVG. The RLINKs associated with the Primary RVG control the replication settings.

To create the Replicated Data Set, Replicated Volume Groups and Replication Links:

**Step 1**

Click **Start > All Programs > Symantec > Veritas Storage Foundation > Veritas Enterprise Administrator** to launch the Veritas Enterprise Administrator (VEA) console.

**Step 2**

Click **View > Connection > Replication Network**.

**Step 3**

Click **Action > Setup Replicated Data Set** to launch the Setup Replicated Data Set wizard.

**Step 4**

Enter a name for **Replicated Data Set name**.

**Step 5**

Enter a name for **Replicated Volume Group name**.

**Step 6**

Select a Primary host from the drop-down list box.

**Step 7**

Click **Next**.
Step 8 Select cscopx as the volume to be replicated and click Next.

Step 9 Select data_srl as the volume to be used for replicator log and click Next.

Step 10 Review the information on the summary page and click Create Primary RVG to create the RVG.

A message appears.

Step 11 Click Yes to add the Secondary host to the Primary RDS.

The Specify Secondary host for replication page appears.

Step 12 Specify the Secondary host details for replication:
   a. Enter the name of the Secondary host.
   b. Click Next.
   c. Enter the credentials (User name and Password) to connect to the Secondary server.
   d. Click OK to edit the replication settings.

Step 13 Edit the replication settings as required:

   • Verify the Primary side IP address or edit the IP Address if required.
   • Verify the Secondary side IP address or edit the IP Address if required.
   • Select the Replication Mode as Synchronous Override.
   • Enter a Primary RLINK Name and a Secondary RLINK Name.
     If you do not specify any name, Veritas Volume Replicator assigns a default name.

Step 14 Click Next to start Replication with the default settings.

The Secondary server will be in inconsistent state. It takes some time to become consistent depending on the network bandwidth.

---

**Setting Casuser Permissions on cscopx Volume**

To run the protected instance of LMS on Secondary servers, you must add the local casusers groups permissions to the cscopx volume.

Before you set the casusers permissions on cscopx volume:

---

Step 1 Stop the Replication Network by right-clicking on the Primary server, in the Replication Network view.

Step 2 Mount the cscopx volume with the drive letter as same as in the Primary server.

---

To add the local casusers group permissions for a Secondary server:

---

Step 1 Right-click Selected Drive Letter\Program Files\CSCOpx from the Windows Explorer.

Step 2 Select the Sharing and Storage menu item.

The folder properties dialog box appears.

Step 3 Select the Security tab and click Add.

Step 4 Click the Location button in the Select Users or Groups dialog box, and select the local server from the selection tree.
Setting up LMS High Availability Environment on Windows

Step 5  Enter casusers in the enter object names text box and click Check Names. The text box displays Server Name\casusers.

Step 6  Click OK.

Step 7  Click the Full Control checkbox under Allow to grant the casusers group full control.

Step 8  Click the Advanced button.

Step 9  Select Replace permission entries on all child objects shown here that apply to child objects.

Step 10  Click Apply and wait for the permissions to propagate to all child objects under the CSCOpx directory.

Step 11  Click OK after the propagation is complete.

Note  After the casusers group permissions have been set, unmount the volume and start the replication.

Setting Up Veritas Volume Replication Without Clustering

To set up volume replication on the Primary server:

Step 1  Stop the Daemon Manager on the LMS server.

Step 2  Launch the VEA Console and select View Connection > Replication Network.

Step 3  Right-click on the blue arrow displayed for the volume group to be replicated. For example, LMS_RVG.

Step 4  Click Migrate.

Step 5  Verify the Secondary Server name to which data is to be replicated.

Step 6  Click OK.

Do the following tasks on the Secondary Server:

Step 1  Mount the cscopx volume with the drive letter as the same as mount drive that is mentioned for cscopx volume on Primary server drive.

Step 2  Run the following perl script from the directory:

```
NMSRoot\bin\perl NMSRoot\bin\hostnamechange.pl -host oldhostname -nhost newhostname -domain DomainName
```

Here,

- **oldhostname**—Hostname of the Primary server.
- **newhostname**—Hostname of the Secondary server
- **Domain**—Domain name of the LMS Server. Entering domain name is optional.

Step 3  Remove the following files after running the hostnamechange.pl script:
- NMSROOT\lib\csorb\NS_Ref
- NMSROOT\campus\www\classpath\NS_Ref
Setting up LMS High Availability Environment on Windows

Veritas Cluster Server Setup Tasks

Clustering is used while monitoring of resources or automatic failover of the resources is required. This section covers the steps required to setup and configure the Veritas clusters. There are two specific scenarios described:

- Cluster Configuration for High Availability
- Cluster Configuration for Disaster Recovery

Cluster Configuration for High Availability

This section specifically covers the setup and configuration of the Veritas cluster for the local redundancy configuration.

Before you start configuring the clusters, ensure that:

- You create a cluster with both the Primary and Secondary servers.
- NICs on both the servers are assigned with IP Address.
- Virtual IP Address will be assigned to the cluster.
- You configure the cluster with the Notifier manager option for mail alerts.
- You create service groups to control and administer the cluster such as Cluster service groups, Replication service group, and Application service group.

This section covers the following procedures:

- Creating the Cluster
- Creating the Cluster Service Group
- Creating the datadg Service Group (For HA Setup)
- Creating the Replication Service Group
- Creating the Application Service Group

Creating the Cluster

To create the cluster:

Step 1 Click Start > All Programs > Symantec > Veritas Cluster Server > Configuration Wizards > Cluster Configuration Wizard.
Chapter 4 Setting Up Cisco Prime LMS in High Availability and Disaster Recovery Environment

Setting up LMS High Availability Environment on Windows

Step 2 Select **Cluster Operation** and click **Next**.

The domain name is displayed.

By default, the list of systems and the list of users in the domain is enabled. You can edit, if required.

Step 3 Click **Next**.

Step 4 Include the Primary and Secondary servers that should be part of the cluster.

Step 5 Select **Create New Cluster Option** and click **Next**.

Step 6 Create a new cluster using the VCS Configuration wizard, where:

- Cluster Name = LMS_HA_Cluster
- Cluster ID = 0

Part of the cluster definition in the wizard is to specify the NICs for the private network. VCS uses a private network for communications between cluster nodes for cluster maintenance.

You should set the Public NICs with Low Priority on both the servers.

Step 7 Click **Next** to go to the next page in the wizard.

Step 8 Select the existing user account and the password for VCS helper service.

The username and password are the credentials with domain name which are used to log into the server.

Step 9 Click **Ok**.

Step 10 Click **Next** to go to the next page in the wizard.

Step 11 Select the Use VCS User Privileges checkbox.

Step 12 Enter the VCS User privileges with user name and password.

This is used to log into the cluster.

**Note** Use the Authentication Broker option instead of VCS user privileges option, if you want the communication between the Primary and Secondary servers to be more secured.

Step 13 Review the summary page and click **Configure** to configure the clusters.

Creating the Cluster Service Group

You can configure a Cluster Service group to run the following optional components:

- Cluster Manager (Web Console)—Configure this resource if you want to access the Cluster Management Console (CMC) through the web browser.
- Notification—Configure this component to receive notifications of events occurring in the cluster through e-mail.

You can use the VCS Configuration wizard to configure these components.

To configure these components:

Step 1 Launch the VCS Configuration wizard.

Step 2 Click **Next**.

Step 3 Click **Cluster Operations > Domain name**.
Setting up LMS High Availability Environment on Windows

Step 4 Select the server to configure the cluster groups.
Step 5 Select Edit existing cluster option and click Next.
Step 6 Select Configure Cluster Service options and configure the notifier and web console options for local redundancy configuration (HA Setup).
Step 7 Enter the virtual IP Address of the cluster.
   You can assign a real IP Address which is not used in the network and is not assigned DHCP, as a virtual IP Address.
Step 8 Click OK.
Step 9 Start the Cluster Manager using Start > All Programs > Symantec > Veritas Cluster Manager - Java Console.
Step 10 Click File > New Cluster.
Step 11 Enter the virtual IP Address of the cluster that is configured, in the Hostname field.
Step 12 Click OK.

Creating the datadg Service Group (For HA Setup)

To create the datadg Service Group:

Step 1 Log in to the cluster using the credentials that you have configured in the VCS Configuration wizard.
   Use the VCS Configuration wizard to see the Cluster Service group created.
Step 2 Go to Tools > Add/Modify Service Group in the console and do the following:
   • Give the name of the service group as App_datadg.
   • Select the Parallel option.
   • Select the servers (Primary and Secondary servers) on which the service group can come online.
Step 3 Click OK.
Step 4 Add the VMDg resource with the following configuration:
   • Resource Name = datadg
   • Resource Type = VMDg
   • DiskGroupName = datadg
   You must select the Critical and Enabled checkboxes for this resource. You should add this resource only for local redundancy configuration.
   Now the service group is online on both Primary and Secondary servers.

Creating the Replication Service Group

To create the Replication Service group, do the following on the Primary and Secondary clusters:

Step 1 Start the Cluster Manager using Start > All Programs > Symantec > Veritas Cluster Manager - Java Console.
Step 2 Login to the cluster using the credentials that you have configured in the VCS Configuration wizard.
Use the VCS Configuration wizard to see the Cluster Service group created.

**Step 3** Go to **Tools > Add/Modify Service Group** in the console and do the following:
- Enter the name of the service group as **App_Rep**.
- Select the Failover Option.
- Select the servers (Primary and Secondary servers) on which the service group can come online.
- Enable the Auto Start option.

**Step 4** Click **OK**.

**Step 5** Add the Proxy resource with the following configuration:
- Resource Name = **VVR_NIC_Proxy**
- Resource Type = **Proxy**
- TargetResName = **csg_nic**
  
  This name should be the same as the name of the resource of resource type NIC.

You must select the Critical and Enabled checkboxes for this resource.

**Step 6** Add the IP resource with the following configuration:
- Resource Name = **VVR_IP**
- Resource Type = **IP**
- Address = **Virtual IP address**
- SubNetMask = **subnet mask**
- MACAddress = **MAC Address of the corresponding NIC card**

You must select the Critical and Enabled checkboxes for this resource.

**Step 7** Add the VvrRvg resource with the following configuration:
- Resource Name = **APP_RVG**
- Resource Type = **VvrRvg**
- RVG = **Name of the Replicated Volume Group**
  
  For example, LMS_RVG.
- VMDg Resource Name = **Name of the Resource Configured under the App_Rep Service group**
  
  For example, datadg.
- IPResName = **VVR_IP**

You must select the Critical and Enabled checkboxes for this resource.

**Step 8** Add the VMDg resource with the following configuration:
- Resource Name = **datadg**
- Resource Type = **VMDg**
- DiskGroupName = **datadg**

You must select the Critical and Enabled checkboxes for this resource.

This is required only for geographic redundancy setup (DR setup).
Step 9 Right-click on the respective resources and do the following:

- Link VVR_IP as the parent of VVR_NIC_Proxy.
- Link APP_RVG as the parent of VVR_IP.
- Link APP_RVG as the parent of datadg.

This is required only for geographic redundancy setup (DR setup).

Step 10 Right-click on the App_Rep service group and select Online on Primary Server.

Creating the Application Service Group

To create the Application Service Group:

Step 1 Start the Cluster Manager using Start > All Programs > Symantec > Veritas Cluster Manager - Java Console.

Step 2 Log in to the cluster using the credentials that you have configured in the VCS Configuration wizard.

Step 3 Go to Tools > Add/Modify Service Group in the console and do the following:

- Enter the name of the service group as App_Service_GP.
- Select the Failover option.
- Select the servers (Primary and Secondary servers) on which the service group can come online.
- Enable the Auto Start option.

Step 4 Click OK.

Step 5 Add the RVG Primary resource with the following configuration:

- Resource Name = App_RVGPrimary
- Resource Type = RVGPrimary
- RvgResourceName = Name of the Resource Configured under the App_Rep Service group

For example, App_Rvg.

You must select the Critical and Enabled checkboxes for this resource.

Step 6 Add the MountV Resource with the following configuration:

- Resource Name = APP_MountV
- Resource Type = MountV
- Mount Path = Selected Drive Letter:
- Volume Name = cscopx
- VMDg Resource Name = Name of the Resource Configured under the App_Rep Service group

For example, datadg.

You must select the Critical and Enabled checkboxes for this resource.
Setting up LMS High Availability Environment on Windows

Step 7 Add the Proxy resource with the following configuration:
- Resource Name = `APP_NIC_Proxy`
- Resource Type = `Proxy`
- TargetResName = `NIC`
You must select the Critical and Enabled checkboxes for this resource.

Step 8 Add the IP resource with the following configuration.
- Resource Name = `APP_IP`
- Resource Type = `IP`
- Address = `Virtual IP address allocated for this cluster and used by LMS application`
- SubNetMask = `subnet mask`
- MACAddress = `MAC Address of the corresponding NIC card`.
You must select the Critical and Enabled checkboxes for this resource.

Step 9 Import the Agent file from the location C:\Program Files\Veritas\cluster server\conf\config, into the cluster.

Step 10 Add the Agent resource with the following configuration.
- Resource Name = `LMSAgent`
- Resource Type = `LMS`
You must select the Critical and Enabled checkboxes for this resource.

Step 11 Enter the pathname as `NMSROOT`.

Step 12 Enter the Virtual IP as `EventIPAddress`.

Step 13 Enter the Certificate Dir as `NMSROOT/MDC/Apache/conf/ssl`.

Step 14 Link `APP_MountV` as the parent of `APP_RVGPrimary`.

Step 15 Link `APP_IP` as the parent of `APP_NIC_PROXY`.

Step 16 Link Agent as the parent of `APP_MountV`.

Step 17 Link Agent as the parent of `APP_IP`.

Step 18 Right-click on the App_Service_Gp service group and select **Online on Primary Server**.

Cluster Configuration for Disaster Recovery

This section specifically covers the setup and configuration of the Veritas cluster for the case of two clusters geographically separated with a single node in each cluster. It contains:

- Creating the Primary and Secondary Clusters
- Creating the Cluster Service Group for Disaster Recovery Setup
- Disaster Recovery Setup Between Primary and Secondary Clusters
Chapter 4  Setting Up Cisco Prime LMS in High Availability and Disaster Recovery Environment

Setting up LMS High Availability Environment on Windows

Creating the Primary and Secondary Clusters

For a Disaster Recovery Cluster setup, you should:

**Step 1** Create a Primary cluster with the server in Site 1 and make all the service groups online.
See Cluster Configuration for High Availability for instructions to configure a cluster and various service groups.

**Step 2** Create a Secondary cluster with the server in Site 2 and make all the service groups online except Application Service Group.
See Cluster Configuration for High Availability for instructions to configure a cluster and various service groups.

*Note* The names of the service groups, resources and their configuration should be identical on both the Primary cluster at Site 1 and the Secondary cluster at Site 2.

Creating the Cluster Service Group for Disaster Recovery Setup

Configure a Cluster Service group in the servers at both sites to run the following optional components:

- Cluster Manager (Web Console)—Configure this resource if you want to access the Cluster Management Console (CMC) through web browser.
- Notification—Configure this component if you want to receive notification of events happening in the cluster through e-mail.
- Global Cluster Option—Allows you to manage multiple clusters.

To create a Cluster Service Group:

**Step 1** Perform the steps explained in Creating the Cluster Service Group on both the Primary and Secondary clusters to create the Cluster Service Group.

**Step 2** Add a wac resource with the following configuration to the Cluster Service Group:
- Resource Name = wac
- Resource Type = Process
You must select the Critical and Enabled checkboxes for this resource.

**Step 3** Link wac as the parent of VCS_IP.

**Step 4** Link VCS_IP as the parent of NIC.

**Step 5** Link the other resources as explained in Creating the Cluster Service Group.
Chapter 4  Setting Up Cisco Prime LMS in High Availability and Disaster Recovery Environment

**Step 6** Right-click on the App_Rep service group and select **Online on Primary Server**.
You should not bring the resources to online in the Secondary cluster.

**Step 7** Configure the Online Local Firm link between the App_Service_Gp and App_Rep service groups. To do so:
- a. Select the App_Service_Gp in the Cluster Administrator Console.
- b. Right-click on the App_Rep service group.
- c. Select the Online Local Firm link option and select the name of the service group to be linked as App_Rep.

---

**Disaster Recovery Setup Between Primary and Secondary Clusters**

Steps to follow on a Primary cluster to establish the Disaster Recovery setup between the clusters:

**Step 1** Start the Cluster Manager using **Start > All Programs > Symantec > Veritas Cluster Manager - Java Console**.

**Step 2** Click **Edit > Add/Delete Remote Cluster**.
A wizard appears.

**Step 3** Click **Next**.

**Step 4** Select the Add Cluster option and click **Next**.

**Step 5** Enter the IP Address of the Secondary cluster.

**Step 6** Enter the Username and password which is used to log into that cluster.
A confirmation message appears stating the cluster has been successfully added.

**Step 7** Click **File > User Manager option** to edit the default user using Java Console and give the following permissions for App_Rep and App_Service_Gp groups:
- Cluster Operator
- Group Operator
- Group Administrator

**Note** The permissions has to be provided in both Primary and Secondary clusters.

**Step 8** Right-click on App Service Group and select **Configure as a Global Option**.
The Global Cluster Details window appears.

**Step 9** Select the cluster to be used in remote site from the Global Cluster details window and select the Cluster failover policy as Auto.
You can select the failover policy as Manual, if you want to bring the App_Service_Gp online in the remote cluster only after getting the approval from the Cluster Administrator.

**Step 10** Enter the Cluster IP address, Username and password.
Step 11 Click **Configure**.

A summary page shows that global group has been configured successfully.
The Remote Cluster status of the App service group shows the status of the service group in both the clusters.

Step 12 Set the attributes for Administrator manually, if they are set already. To do so:

a. Select the App Service Group.
b. Click **Show All attributes** from the properties tab for Administrator.
c. Click **Set Administrators/Operators**.

---

### Setting up LMS High Availability Environment on Solaris

This section explains setting up Veritas implementation on a Solaris system.

- Installing Storage Foundation HA 5.1 on Solaris
- Creating Disk Groups and Volumes on Solaris Servers
- Installing LMS on Primary and Secondary Servers
- Setting Up Veritas Volume Replication on Solaris Server
- Setting Up Veritas Volume Replication Without Clustering On Solaris
- Veritas Cluster Server Setup Tasks on Solaris

### Installing Storage Foundation HA 5.1 on Solaris

To install the product:

Step 1 Go to Veritas installer location.
For example, `/Veritas/VSF_HA_5.1/installer`.

Step 2 Run the installer file:
`. /installer`
The Task menu appears.

Step 3 Enter `1` to install or upgrade Veritas Storage Foundation HA 5.1 package.
The component list appears.

Step 4 Enter `5` to install all Veritas Storage Foundation components and press `Enter`.

Step 5 The installer prompts for a system name.

Step 6 Enter the system hostnames and press `Enter`. 
**Chapter 4  Setting Up Cisco Prime LMS in High Availability and Disaster Recovery Environment**

**Setting up LMS High Availability Environment on Solaris**

**Step 7** Enter the required Veritas Storage Foundation license that includes the following components:
- Veritas Storage Foundation High Availability
- Veritas Volume Replicator
- Veritas Cluster Server with the Global Cluster Option support

**Step 8** Enter 2 to install Veritas Storage Foundation and press Enter.

**Step 9** Enter y to configure Storage Foundation.

**Step 10** Enter n to configure VCS.

**Step 11** Enter n to configure Enclosure based naming schemes.

**Step 12** Enter y to set up the default disk group.

**Step 13** Enter the disk group name as datadg.

**Step 14** Enter n for all VVR questions.

**Step 15** Enter y for Fully qualified host name confirmation.

**Step 16** Enter n to enable the Storage Foundation Management server.

**Step 17** Enter y to start the Veritas Storage Foundation Process.

**Step 18** Enter `shutdown -y -i6 -g0` to reboot the Solaris server.

**Step 19** Enter `ps -ef | grep vx` on the command prompt after reboot to verify whether all Veritas processes are brought up successfully.

---

**Creating Disk Groups and Volumes on Solaris Servers**

A disk group is a collection of disks that is ported as a single unit. Veritas Storage Foundation uses disk groups to organize disks for management purposes.

Volumes are logical entities that are comprised of portions of one or more physical disks and are accessed by a drive letter or mount point. Volumes can be configured for performance and high availability.

This section explains:
- Prerequisites for Configuring Disk Groups and Volumes on Solaris
- Creating Disk Groups on Primary Solaris Server
- Creating Volumes on Primary Solaris Server
- Creating Disk Groups and Volumes on Secondary Solaris Server

**Prerequisites for Configuring Disk Groups and Volumes on Solaris**

See Prerequisites for Configuring Disk Groups and Volumes for details.
Creating Disk Groups on Primary Solaris Server

You must create the disk group on the first node where the product instance is being installed. Repeat the procedure if you want to create additional disk groups.

To create a disk group:

**Step 1** Enter `/opt/VRTS/bin/vea` on the Solaris system command prompt to launch the Veritas Enterprise Administrator (VEA) console.

**Step 2** Select a profile if prompted.

You can also select the default profile.

**Step 3** Click **Connect to a Host or Domain**.

**Step 4** Enter the host name of the server which you want to connect in the Host Name field or select a host name from the drop-down list box.

To connect to the local system, enter **localhost**.

**Step 5** Click **Connect**.

You must enter the user name, password, and domain name if prompted. You can see the host name of the server added on to the VEA console.

**Step 6** Expand the tree view under the host node to configure a disk group under the StorageAgent tree node.

**Step 7** Locate the StorageAgent tree node and right-click the Disk Groups icon under the StorageAgent tree node.

**Step 8** Select **New Dynamic Disk Group** from the shortcut context menu.

The New Dynamic Disk Group wizard appears with the welcome message.

**Step 9** Click **Next** to go to next page in the wizard.

**Step 10** Enter the information about the disk group:

a. Enter a name for the disk group in the Group Name field.

   You should enter **datadg** as group name.

b. Select the appropriate hard disks in the Available disks list, and use the Add button to move them to the Selected disks list.

   You should select two hard disks that are not the boot disks, from the Available disks list.

c. Click **Next**.

**Step 11** Click **Next** to accept the confirmation screen with the selected tasks.

**Step 12** Click **Finish** to create the new disk group.

Creating Volumes on Primary Solaris Server

This section explains how to create a volume on a cluster disk group. Repeat the procedure below if you want to create the volumes on the first node of the cluster.

To create a volume:

**Step 1** Enter `/opt/VRTS/bin/vea` on the Solaris system command prompt to launch the Veritas Enterprise Administrator (VEA) console.
Step 2  Select a profile if prompted.
        You can also select the default profile.

Step 3  Click **Connect to a Host or Domain**.

Step 4  Enter the host name of the server that you want to connect in the Host Name field.
        or
        Select a host name from the drop-down list box.
        To connect to the local system, enter **localhost**.

Step 5  Click **Connect**.
        You must enter the user name, password, and domain name if prompted. You can see the host name of
        the server added on to the VEA console.

Step 6  Expand the tree view under the host node to configure a disk group under the StorageAgent tree node.

Step 7  Locate the StorageAgent tree node and right-click the Volumes icon under the StorageAgent tree node.

Step 8  Select **New Volume** from the shortcut context menu.
        The New Volume wizard appears with the welcome message.

Step 9  Click **Next** to go to the next page in the wizard.

Step 10 Click **Let volume manager decide what disks to use for this volume**.

Step 11 Click **Next**.

Step 12 Specify the parameters of the volume:
        a. Enter a name for the volume in the Volume Name field.
           You should enter **cscopx** as volume name.
        b. Select the volume type as concatenated volume.
        c. Enter a size for the volume.
           For example, you can enter as 10 GB.
        d. Click **Next**.
           The Create File System dialog box appears.

Step 13 Select the file system as **vxfs**.

Step 14 Mount the cscopx volume using the mount point as */opt/CSCOpx*

Step 15 Click **Next** to review the settings summary.

Step 16 Click **Finish** to create the new volume.

Step 17 Repeat the above procedure to create a volume in the datadg disk group with the following
        characteristics:
        • Volume Name: varcscopx
        • Volume Type: Concatenated Volume
        • Volume Size: 10 GB
        • File System: **vxfs**
        This volume will be mounted using the mount point */var/adm/CSCOpx* and is used only by LMS
        application.

Step 18 Repeat the above procedure to create a volume in the datadg disk group with the following
        characteristics:
• Volume Name: data_srl
• Volume Type: Concatenated Volume
• Volume Size: 10 GB
This volume will not be mounted and is used only by Veritas Volume Replicator.

Creating Disk Groups and Volumes on Secondary Solaris Server

You should launch the Veritas Enterprise Administration console on the Secondary server.
Create the identical disk group and volume as you have created on Primary server. See Creating Disk Groups on Primary Solaris Server and Creating Volumes on Primary Solaris Server for detailed explanation.
You should create the csco px and varcsco px volume with the same size, type and mount point.

Installing LMS on Primary and Secondary Servers

To make the LMS application highly available, install LMS on the newly created csco px or varcsco px volumes on both the Primary and Secondary servers.
Ensure that:
• LMS is installed
• Admin password, Database password, and HTTP ports are same on both the Primary and Secondary servers.
• Name of the LMS volume is same on both the servers.
• Casuser settings configured should be same on both the servers.

Note After installing LMS on Secondary server under csco px volume, unmount the csco px and varcsco px volumes.

Setting Up Veritas Volume Replication on Solaris Server

Veritas Volume Replicator is a fully integrated component of Veritas Volume Manager that replicates data to remote locations over any standard IP network to provide continuous data availability.
See the following sections for information:
• Modes of Replication
• Setting Up RDS, RVG and RLINK
  You must select both the csco px and varcsco px as the volumes to be replicated.
This section explains:
• Setting Casuser Permissions on csco px Volume on Solaris (If Required)
• Setting Up Veritas Volume Replication Without Clustering On Solaris
### Setting Casuser Permissions on cscopx Volume on Solaris (If Required)

You must set the casuser permissions on cscopx volume only if required on a Solaris system. Otherwise, you can skip this section.

To run the protected instance of LMS on Secondary servers, you must add the local casusers group permissions to the cscopx and varcscopx volumes.

Before you set the casusers permissions on cscopx volume:

**Step 1** Stop the Replication Network by right-clicking on the Primary server, in the Replication Network view.

**Step 2** Mount the cscopx and varcscopx volumes with the mount point as the same as in the Primary server.

To add the local casusers group permissions for a Secondary server, run the following commands:

- `chown -R casuser:casusers /opt/CSCOpx`
- `chown -R casuser:casusers /var/adm/CSCOpx`

After the casusers group permissions have been set, unmount the cscopx and varcscopx volumes and start the replication.

### Setting Up Veritas Volume Replication Without Clustering On Solaris

To set up volume replication on the Primary server:

**Step 1** Stop the Daemon Manager on LMS server.

**Step 2** Launch the VEA Console and select View Connection > Replication Network.

**Step 3** Right-click on the blue arrow displayed for the volume group to be replicated. For example, LMS_RVG.

**Step 4** Click Migrate.

**Step 5** Verify the Secondary Server name to data is to be replicated.

**Step 6** Click OK.

Do the following tasks on the Secondary Server:

**Step 1** Mount the cscopx volume with the /opt/CSCOpx directory.

**Step 2** Mount the varcscopx volume with the /var/adm/CSCOpx directory.

**Step 3** Run the following perl script from the directory.

```
NMSRoot/bin/perl NMSRoot/bin/hostnamechange.pl -ohost oldhostname -nhost newhostname -domain DomainName
```

Here,

- `oldhostname`—Hostname of the Primary server.
- `newhostname`—Hostname of the Secondary server
- `Domain`—Domain name of the LMS Server. Entering domain name is optional.
Step 4  Remove the following files after running the hostnamechange.pl script:

- NMSROOT/lib/corb/NS_Ref
- NMSROOT/campus/www/classpath/NS_Ref
- NMSROOT/_nsdb_root

Step 5  Run the following command in the Secondary Server:

```
```

You must run this command only if there are any backup jobs scheduled in the Primary Server.

Step 6  Restart the Daemon Manager.

Step 7  Launch the LMS Server by entering the following on the web browser:

```
http://Secondary_Server_IP_Address:1741
```

Veritas Cluster Server Setup Tasks on Solaris

Clustering is used while monitoring of resources or automatic failover of the resources is required. This section covers the steps required to setup and configure the Veritas clusters. There are two specific scenarios described:

- Cluster Configuration for High Availability on Solaris
- Cluster Configuration for Disaster Recovery on Solaris

Cluster Configuration for High Availability on Solaris

This section specifically covers the setup and configuration of the Veritas cluster for the case of a single, local cluster with two nodes in the cluster (Primary and Secondary).

You must do the following tasks before you start configuring the clusters:

- Create a cluster with both the Primary and Secondary servers.
- NICs on both the servers are assigned with IP Address.
- Virtual IP Address will be assigned to the cluster.
- Configure the cluster with Notifier manager option for mail alerts.
- Create service groups to control and administer the cluster such as Cluster service groups, Replication service group, and Application service group.

This section covers the following procedures:

- Creating the Cluster on Solaris
- Creating the datadg Service Group on Solaris (For HA Setup)
- Creating the Replication Service Group on Solaris
- Creating the Application Service Group on Solaris

Creating the Cluster on Solaris

To create the cluster on Solaris:

Step 1  Run the Veritas installer from the VSF_HA_5.1 CD.
Chapter 4 Setting Up Cisco Prime LMS in High Availability and Disaster Recovery Environment

Setting up LMS High Availability Environment on Solaris

Step 2 Enter `c` followed by `1` to configure the clusters.

The installer prompts you for a system name.

Step 3 Enter the system hostnames of the Primary and Secondary server.

Step 4 Press `Enter` after the system resumes back after stopping the VCS process.

Step 5 Enter the name of the cluster when system prompts for the cluster name.

Step 6 Enter `n` to configure Symantec Security Services and press `Enter`.

Step 7 Enter `y` to create a new user for that cluster and press `Enter`.

Step 8 Enter `n` for Cluster Management configuration.

Step 9 Enter `y` for Cluster Management Console configuration and press `Enter`.

Step 10 Select the public NICs among the list of NICs and press `Enter`.

Step 11 Enter the virtual IP Address assigned for that cluster and press `Enter`.

Step 12 Enter the correct netmask and press `Enter`.

Step 13 Configure the SMTP notification for that server.

Step 14 Start the Cluster Manager by entering `/opt/VRTSvcs/bin/hagui` on the command prompt.

Step 15 Log in to the cluster using the credentials that you have configured during the Veritas Cluster Server configuration.

Step 16 Select the Cluster Service group and set the following attributes:

a. Select the Show All Attributes option from the pane displayed at the right.

b. Set the value of Onlineretrylimit attribute as 0.

Step 17 Make all the resources including the Notifier Manager and Cluster Management Console online.

Creating the datadg Service Group on Solaris (For HA Setup)

To create the datadg Service Group:

Step 1 Log in to the cluster using the credentials that you have configured in the VCS Configuration wizard.

Use the VCS Configuration wizard to see the Cluster Service group created.

Step 2 Go to Tools > Add/Modify Service Group in the console and do the following:

- Give the name of the service group as `App_datadg`.
- Select the Parallel option.
- Select the servers (Primary and Secondary servers) on which the service group can come online.

Step 3 Click OK.

Step 4 Add the Disk Group resource with the following configuration:

- Resource Name = `datadg`
- Resource Type = `Disk Group`
- DiskGroupName = `datadg`

You must select the Critical and Enabled checkboxes for this resource. You should add this resource only for local redundancy configuration.
Now the service group is online on both Primary and Secondary servers.

Creating the Replication Service Group on Solaris

To create the Replication Service group on Solaris, do the following on the Primary and Secondary clusters:

**Step 1**
Start the Cluster Manager by entering `/opt/VRTSvcs/bin/hagui` at the command prompt.

**Step 2**
Log in to the cluster using the credentials that you have configured during the Veritas Cluster Server configuration.

You can see the Cluster Service group that is created during the Veritas Cluster Server configuration.

**Step 3**
Go to **Tools > Add/Modify Service Group** in the console and do the following:
- Enter the name of the service group as `App_Rep`.
- Select the Failover option.
- Select the servers (Primary and Secondary servers) on which the service group can come online.
- Enable the Auto Start option.

**Step 4**
Click **OK**.

**Step 5**
Add the Proxy resource with the following configuration:
- Resource Name = `App_Rep_NIC`
- Resource Type = `Proxy`
- TargetResName = `csg_nic`

This name should be the same as the name of the resource of resource type NIC.

You must select the Critical and Enabled checkboxes for this resource.

**Step 6**
Add the RVG resource with the following configuration:
- Resource Name = `APP_RVG`
- Resource Type = `RVG`
- RVG = `LMS_DR_RVG`
- Disk Group= `datadg`

You must select the Critical and Enabled checkboxes for this resource.

**Step 7**
Add the IP resource with the following configuration:
- Resource Name = `AppRep_IP`
- Resource Type = `IP`
- Address = `Virtual IP address`
- Device = `Public NIC name`

You must select the Critical and Enabled checkboxes for this resource.

**Step 8**
Add the Disk Group resource with the following configuration:
- Resource Name = `datadg`
- Resource Type = `Disk Group`
Chapter 4  Setting Up Cisco Prime LMS in High Availability and Disaster Recovery Environment

Setting up LMS High Availability Environment on Solaris

- DiskGroupName = datadg
  You must select the Critical and Enabled checkboxes for this resource.
  This is required only for geographic redundancy setup (DR setup).

**Step 9**
Right-click on the respective resources and do the following:
- Link APPRep_IP as the parent of App_Rep_NIC.
- Link APP_RVG as the parent of AppRep_IP.
- Link APP_RVG as the parent of datadg.
  This is required only for geographic redundancy setup (DR setup).

**Step 10**
Right-click on the App_Rep service group and select **Online on Primary Server.**

Creating the Application Service Group on Solaris

To create the Application Service group on Solaris:

**Step 1**
Start the Cluster Manager by entering `/opt/VRTSvcs/bin/hagui` at the command prompt.

**Step 2**
Log in to the cluster using the credentials that you have configured in the VCS Configuration wizard.
You can see the Cluster Service group that is created.

**Step 3**
Go to **Tools > Add/Modify Service Group** in the console and do the following:
- Give the name of the service group as `App_Service_GP`.
- Select the Parallel Option.
- Select the servers in which the service group to act upon.

**Step 4**
Click **OK**.

**Step 5**
Add the RVG Primary resource with the following configuration:
- Resource Name = `App_RVGPrimary`
- Resource Type = `RVGPrimary`
- RvgResourceName = `Name of the Resource Configured under the App_Rep Service group` (For example, App_Rvg).
  You must select the Critical and Enabled checkboxes for this resource.

**Step 6**
Add the Proxy resource with the following configuration:
- Resource Name = `APP_NIC_Proxy`
- Resource Type = `Proxy`
- TargetResName = `NIC`
  You must select the Critical and Enabled checkboxes for this resource.

**Step 7**
Add the IP resource with the following configuration.
- Resource Name = `APP_IP`
- Resource Type = `IP`
- Address = `Virtual IP address allocated for this cluster and used by LMS application`
- SubNetMask = `subnet mask`
• MACAddress = MAC Address of the corresponding NIC card.

You must select the Critical and Enabled checkboxes for this resource.

**Step 8** Add the Volume resource for cscopx volume with the following configuration.

- Resource Name = Volume
- Resource Type = cscopx
- Disk Group = datadg

You must select the Critical and Enabled checkboxes for this resource.

**Step 9** Add the Volume resource for varcscopx volume with the following configuration.

- Resource Name = Volume
- Resource Type = varcscopx
- Disk Group = datadg

You must select the Critical and Enabled checkboxes for this resource.

**Step 10** Add the Mount resource for cscopx volume with the following configuration:

- Resource Name = cscopx_Mount
- Resource Type = Mount
- Mount Point = Mount_point
- Block Device = Exact Path of cscopx volume
- FSType = vxfs

You must select the Critical and Enabled checkboxes for this resource.

**Step 11** Add the Mount resource for varcscopx volume with the following configuration:

- Resource Name = varcscopx_Mount
- Resource Type = Mount
- Mount Point = Mount_point
- Block Device = Exact Path of cscopx volume
- FSType = vxfs
- FSopt = -y

You must select the Critical and Enabled checkboxes for this resource.

**Step 12** Import the Agent file from the location /etc/VRTSvcs/conf/config/LMSTypes.cf, into the cluster.

**Step 13** Add the Agent resource with the following configuration.

- Resource Name = LMSAgent
- Resource Type = LMS

You must select the Critical and Enabled checkboxes for this resource.

**Step 14** Click the LMS Resource Type and do the following:

a. Select the Show All Attributes option from the pane displayed at the right.

b. Set the value of OnlineTimeout attribute as 1300.

c. Set the value of OfflineTimeout attribute as 1000.

**Step 15** Enter the Virtual IP as EventIPAddress.

**Step 16** Link cscopx_Mount as the parent of cscopx.
Chapter 4      Setting Up Cisco Prime LMS in High Availability and Disaster Recovery Environment

Setting up LMS High Availability Environment on Solaris

**Step 17** Link varcscopx_Mount as the parent of varcscopx.

**Step 18** Link cscopx as the parent of App_RVGPrimary.

**Step 19** Link varcscopx as the parent of App_RVGPrimary.

**Step 20** Link APP_IP as the parent of APP_NIC_PROXY.

**Step 21** Link Agent as the parent of cscopx_Mount, varcscopx_Mount and APP_IP.

---

**Cluster Configuration for Disaster Recovery on Solaris**

This section specifically covers the setup and configuration of the Veritas cluster for the case of two clusters geographically separated with a single node in each cluster.

For a Disaster Recovery Cluster setup, you should:

**Step 1** Create a Primary cluster with the server in Site 1 and make all the service groups online.

See [Cluster Configuration for High Availability](#) for instructions to configure a cluster and various service groups.

**Step 2** Create a Secondary cluster with the server in Site 2 and make all the service groups online except Application Service Group.

See [Cluster Configuration for High Availability](#) for instructions to configure a cluster and various service groups.

**Note** The names of the service groups, resources and their configuration should be identical on both the Primary cluster at Site 1 and the Secondary cluster at Site 2.

---

This section explains:

- Creating the Cluster Service Group on Solaris
- Disaster Recovery Setup Between Primary and Secondary Clusters on Solaris

### Creating the Cluster Service Group on Solaris

Configure a Cluster Service group in the servers at both sites to run the following optional components:

- Cluster Manager (Web Console)—Configure this resource if you want to access the Cluster Management Console (CMC) through web browser.
- Notification—Configure this component to receive e-mail notifications about the events occurring in the cluster.
- Global Cluster Option—Allows you to manage multiple clusters.

To create the Cluster Service Group, you must:

**Step 1** Perform the steps explained in Creating the Cluster Service Group on both the Primary and Secondary clusters to create the Cluster Service Group.
Chapter 4  Setting Up Cisco Prime LMS in High Availability and Disaster Recovery Environment

Setting up LMS High Availability Environment on Solaris

Step 2 In addition to these steps, you must add a wac resource with the following configuration to the Cluster Service Group:
  - Resource Name = wac
  - Resource Type = Process

You must select the Critical and Enabled checkboxes for this resource.

Step 3 Link wac as the parent of APP_IP.

Step 4 Link APP_IP as the parent of NIC.

Step 5 Configure the Online Local Firm link between the App_Service_Gp and App_Rep service groups. To do so:
  - a. Select the App_Service_Gp in the Cluster Administrator Console.
  - b. Right-click on the App_Rep service group.
  - c. Select the Online Local Firm link option and select the name of the service group to be linked as App_Rep.

Disaster Recovery Setup Between Primary and Secondary Clusters on Solaris

To establish the Disaster Recovery setup between the clusters, do the following configuration on a Primary cluster:

Step 1 Start the Cluster Manager by entering `/opt/VRTSvcs/bin/hagui` at the command prompt.

Step 2 Click Edit > Add/Delete Remote Cluster.

A wizard appears.

Step 3 Click Next.

Step 4 Select the Add Cluster option and click Next.

Step 5 Enter the IP Address of the Secondary cluster.

Step 6 Enter the Username and password which is used to log into that cluster.

A confirmation message appears stating the cluster has been successfully added.

Step 7 Click File > User Manager option to edit the default user using Java Console and give the following permissions for App_Rep and App_Service_Gp groups:
  - Cluster Operator
  - Group Operator
  - Group Administrator

Note The permissions has to be provided in both Primary and Secondary clusters.

Step 8 Right-click on App Service Group and select Configure as a Global Option.

The Global Cluster Details window appears.
**Step 9** Select the cluster to be used in remote site from the Global Cluster details window and select the Cluster failover policy as **Auto**.

You can select the failover policy as **Manual**, if you want to bring the App_Service_Gp online in the remote cluster only after getting the approval from the Cluster Administrator.

**Step 10** Enter the Cluster IP address, Username and password.

**Step 11** Click **Configure**.

A summary page shows that global group has been successfully configured.

The Remote Cluster status of the App service group shows the status of the service group in both the clusters.

**Step 12** Set the attributes for Administrator manually, if they are set already. To do so:

a. Select the App Service Group.

b. Click **Show All attributes** from the properties tab for Administrator.

c. Click **Set Administrators/Operators**.

---

**Moving LMS from non-HA to HA Environment**

You can create the HA or DR deployment environment only for a fresh installation of LMS.

We recommend you to:

1. Uninstall LMS from the server if you want to migrate from non-HA to HA environment.
2. Install the Symantec Veritas products.
3. Install LMS 4.2 after the Veritas Setup is complete.

**Remote Migration of LMS 3.2 SP1, LMS 4.0.1 or LMS 4.1 Data to Cisco Prime LMS 4.2 Server with HA Setup**

You can do a remote migration of Cisco Prime LMS 3.2 SP1, MS 4.0.1 or LMS 4.1 data to the Cisco Prime LMS 4.2 server with Symantec Veritas implementation.

We recommend you to:

1. Uninstall LMS from the server if you want migrate from non-HA to HA environment.
2. Install the Symantec Veritas products.
3. Install LMS 4.2 after the Veritas Setup is complete.
4. Migrate the Cisco Prime LMS 3.2 SP1, LMS 4.0.1, or LMS 4.1 data to the remote LMS 4.2 server (Remote Migration).

For more information on data migration, see

- *Data Migration Guide for CiscoWorks LAN Management Solution 3.2* for instructions to do a remote migration of data to LMS 3.2.

- *Migrating Data to CiscoWorks LAN Management Solution 4.0* in the *Installing and Migrating to CiscoWorks LAN Management Solution 4.0* Guide for instructions to do a remote migration of data to LMS 4.0.

- *Migrating Data to Cisco Prime LAN Management Solution 4.2* for instructions to do a remote migration of data to LMS 4.2.
Caution

Ensure that the passwords, HTTPS port and SMTP server details are the same in both the servers (LMS 3.2 SP1, LMS 4.0.1, or LMS 4.1 and LMS 4.2 server). This is applicable only for Windows Operating System.