CiscoView 4.1 CD Installation
Instructions for AIX

This instruction book provides information about installing and running CiscoView on your network management station. You can install CiscoView on an AIX workstation, either as a standalone application or on top of the network management platform NetView for AIX. You should be familiar with Motif window management system and (optionally) NetView for AIX.

CiscoView is a GUI-based device management software application that enables you to access dynamic status, statistics, and comprehensive configuration information for Cisco internetworking products.

CiscoView lets you display a graphical representation of each network device, display configuration and performance information, perform minor troubleshooting tasks, and control and configure specific devices. There are also device-specific applications that further enhance your network management capabilities.

Table 1 explains where to find the procedures described in this booklet and when you should perform them.
Installing or upgrading CiscoView installs only the CiscoView engine. You also need to configure CiscoView and install device packages before it is ready to use. This booklet includes procedures for installing and configuring CiscoView. It also includes limited information about ongoing tasks that you might perform with CiscoView, including

### Table 1 Upgrading CiscoView on AIX

<table>
<thead>
<tr>
<th>If you have this product installed</th>
<th>You need to</th>
</tr>
</thead>
<tbody>
<tr>
<td>CiscoView 3.x, 4.0(^1)</td>
<td>Upgrade to CiscoView 4.1</td>
</tr>
<tr>
<td>CiscoWorks 3.2 or later</td>
<td>Upgrade to or install CiscoView 4.1</td>
</tr>
<tr>
<td>CiscoWorks for Switched Internetworks (CWSI) 1.1.1</td>
<td>Upgrade to CWSI 1.3 and then upgrade to CiscoView 4.1</td>
</tr>
<tr>
<td>CWSI 1.3</td>
<td>Upgrade to CiscoView 4.1</td>
</tr>
</tbody>
</table>

1. If you are upgrading CiscoView 4.0.1 to CiscoView 4.1 and /usr/nms or /usr/nms/CVapp is a symbolic link, the link is removed by SMIT (an install utility). To prevent the removal of the symbolic link, remove the link and mount the directory to /usr/nms/CVapp to perform the upgrade. You can also remove the previous version of CiscoView and do a fresh install of the latest version of CiscoView. Refer to the CiscoView 4.1 Release Notes for more information.
incrementally installing device packages, using and maintaining the software, and getting product support.

**System Requirements for CiscoView**

Before you install CiscoView, make sure your workstation meets the requirements shown in Table 2 and the hardware and software recommendations shown in Table 3.

**Table 2  CiscoView Typical System Requirements**

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Available Disk Space</th>
<th>RAM</th>
</tr>
</thead>
<tbody>
<tr>
<td>AIX 4.1.5, 4.2¹</td>
<td>1 MB in the / directory, 5 MB in /tmp directory, and 100 MB in the /usr directory²</td>
<td>32 MB³</td>
</tr>
</tbody>
</table>

1. See the “Verifying AIX Version” section for details about verifying the operating system level.
2. See the “Verifying Hard Disk Space” section for instructions on determining the amount of disk space available on your workstation.
3. See the “Verifying RAM Size” section for details on determining the amount of available RAM on your workstation.
Table 3  CiscoView Hardware and Software Recommendations

<table>
<thead>
<tr>
<th>Hardware</th>
<th>Software</th>
</tr>
</thead>
<tbody>
<tr>
<td>with Power architecture</td>
<td>Netview for AIX 4.1 or 5.0 (optional)¹</td>
</tr>
<tr>
<td>Color monitor</td>
<td>Cisco IOS—Managed Cisco devices must be running specific versions of the</td>
</tr>
<tr>
<td>PostScript-compatible printer (for printing</td>
<td>Cisco IOS software. See the CiscoView 4.1(1) Release Note.</td>
</tr>
<tr>
<td>window images)</td>
<td></td>
</tr>
<tr>
<td>CD-ROM drive on the host workstation, or</td>
<td></td>
</tr>
<tr>
<td>CD-ROM drive on an accessible remote host</td>
<td></td>
</tr>
</tbody>
</table>

¹ CiscoView can operate without NetView for AIX as described under “Starting CiscoView from the Command Line,” so NetView for AIX is optional. Without NetView for AIX, however, you cannot graph information. (See the “Verifying System Software” section for instructions.)
Verifying AIX Version

To verify that you are running a supported version of AIX, perform the following steps:

1. Log in as root by entering su and the root password at the prompt, or log in as root. The prompt changes to the pound sign (#).

2. Enter the following command:

   # oslevel

Output similar to the following appears:

   4.2.0.0

This output shows that AIX Version 4, Release 2 is installed.

Verifying System Software

If you use CiscoView with NetView for AIX, you need to verify that you are running a supported version of NetView.

To determine which version of NetView is installed, log in as root and enter the following command:

   # lslpp -l nv6000.base.obj
Output similar to the following appears:

<table>
<thead>
<tr>
<th>Fileset</th>
<th>Level</th>
<th>State</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Path: /usr/lib/objrepos</td>
<td>4.1.2.0</td>
<td>COMMITTED</td>
<td>NetView for AIX Server-Base</td>
</tr>
</tbody>
</table>

This output shows that NetView 4.1 is installed and committed on the AIX workstation.

**Verifying RAM Size**

CiscoView requires a minimum of 32 MB of RAM. To verify that you have enough RAM available on your workstation, log in as root and enter the following command at the AIX prompt:

```
# lscfg | grep mem
```

Output similar to the following appears:

```
+ mem0        00-0B        32 MB Memory Card
+ mem1        00-0C        32 MB Memory Card
```

If your workstation does not have at least 32 MB of RAM, upgrade its memory.
Verifying Hard Disk Space

CiscoView requires 1 MB of disk space in the root directory, 100 MB of disk space in the /usr directory, and 5 MB of disk space in the /tmp directory.

To verify that you have enough disk space on your workstation, enter the following command at the prompt:

```bash
% df -Ik
```

Output similar to the following appears:

<table>
<thead>
<tr>
<th>Filesystem</th>
<th>Total KB</th>
<th>used</th>
<th>free</th>
<th>%used</th>
<th>Mounted on</th>
</tr>
</thead>
<tbody>
<tr>
<td>/dev/hd4</td>
<td>16384</td>
<td>10008</td>
<td>6376</td>
<td>61%</td>
<td>/</td>
</tr>
<tr>
<td>/dev/hd2</td>
<td>1003520</td>
<td>871324</td>
<td>132196</td>
<td>86%</td>
<td>/usr</td>
</tr>
<tr>
<td>/dev/hd3</td>
<td>16384</td>
<td>732</td>
<td>15652</td>
<td>4%</td>
<td>/tmp</td>
</tr>
</tbody>
</table>

The amount of disk space available in each filesystem appears in the free column. Note that 1,000 KB is approximately 1 MB. If you do not have sufficient space in the filesystem mounted on the /usr directory, you must create a filesystem mounted on the /usr/nms/CVapp directory.

**Caution** CiscoView can be installed only in the /usr/nms/CVapp directory. If you create a filesystem, its mount point must be either /usr/nms or usr/nms/CVapp. If /usr/nms/CVapp already exists on your
workstation, *back up all data in that directory* before installing CiscoView. Installation of CiscoView overwrites existing data.

To create a filesystem, we recommend that you contact a knowledgeable system administrator and use the System Management Interface Tool (SMIT).

**Mounting the CD-ROM**

This section describes how to mount the CiscoView CD-ROM on the local filesystem from a local or remote CD-ROM drive.

You can install CiscoView from a CD-ROM drive attached to your workstation or from a drive connected to a remote host. You must first use SMIT to mount the local or remote device on the local AIX workstation.

**Note**  SMIT and this booklet refer to the software product as CiscoView 4.1(1).
Mounting from a Local CD-ROM Drive

To mount the CD-ROM on the filesystem from a local CD-ROM drive, use SMIT to perform the following steps on the local host:

1. Place the CD-ROM into its caddy and insert it into the CD-ROM drive.

2. Log in as the root user.

3. Start SMIT by entering the following command:
   
   ```
   # smit
   ```

4. From the SMIT System Management menu, select System Storage Management (Physical & Logical Storage).

5. Select File Systems.


7. Select CDROM File Systems.

8. Select Add a CDROM File System.

9. Click the “DEVICE name” List button, and select the device name (such as /dev/cd0) from the list that appears.
10 Enter the name of a mount point directory (such as /cdrom) in the Mount point field.

11 Click **OK** and read the output.

   If you have already performed this procedure, or if another device is already mounted on the mount point, the process fails.

12 Click **Done**.

13 Terminate SMIT by pressing **F12** or clicking **Exit SMIT** on the Exit menu.

14 Enter the following at the command prompt:

   ```
   # smit mountfs
   ```

15 Click the FILE SYSTEM name **List** button, and select a device name (such as /dev/cd0) from the list that appears.

16 In the DIRECTORY over which to mount field, enter the name of a mount point directory (for example, /cdrom).

17 Click the TYPE of file system **List** button, and select **cdrfs** as the filesystem type.

18 Set the Mount as Read-Only System field to **yes**.
19 Click OK, read the output, and then click Done.

20 Click Cancel to exit SMIT.

The CD-ROM is ready to be installed. Continue with the “Installing CiscoView” section.

**Mounting from a Remote CD-ROM Drive**

To mount the CD-ROM on the local filesystem from a remote CD-ROM drive, first perform the following steps on the *remote* workstation:

1. Perform all steps exactly as described in “Mounting from a Local CD-ROM Drive” on the *remote* workstation.

2. Enter the following command:

   ```
   # smit mknfsexp
   ```

3. Enter the PATHNAME of directory to export (such as `/cdrom`).

4. Use the arrow keys to change the Mode to Export Directory field to *read-only*.

5. Enter the appropriate information, if necessary, into the other fields.

6. Click OK, read the output, and then click Done.
7 Click **Cancel** to exit SMIT.

After working on the *remote* workstation, perform the following steps on the *local* workstation:

1 Log in as root.

2 Enter the following command:

```bash
# mount \
remote_hostname:remote_exported_filesystem_name \ 
local_mount_point
```

For example, to mount the `/cdrom` remote filesystem from the workstation `zen` to the local `/cdrom` directory, enter

```bash
# mount zen:/cdrom /cdrom
```

The CD-ROM is ready to install the software.
Installing CiscoView

To install CiscoView from a mounted CD-ROM drive, perform the following steps.

**Caution**  CiscoView can be installed only in the `/usr/nms/CVapp` directory. If `/usr/nms/CVapp` already exists, *back up all data in the directory* because the installation process overwrites existing files.

1. Log in as root.

2. Mount the CD-ROM as described in the previous section.

3. Set the `I_CDROM_PATH` environment variable to the path where the CD-ROM is mounted. For example, if you are using Bourne shell or Korn shell, enter

   ```
   # I_CDROM_PATH=/cdrom; export I_CDROM_PATH
   ```

   Or, if you are using C shell, enter

   ```
   # setenv I_CDROM_PATH /cdrom
   ```

4. Start SMIT by entering the following command:

   ```
   # smit
5 From the System Management menu, select **Software Installation and Maintenance**.

6 Click **Install and Update Software**.

7 If you have AIX 4.1.5, select **Install and Update Selectable Software (Custom Install)**, then select **Install Software Products at Latest Level**, then select **Install New Products at Latest Level**. The Install New Products at Latest Level dialog box is displayed.

If you have AIX 4.2, select **Install and Update from LATEST Available Software**. The Install and Update from Latest Available Software dialog box is displayed.

8 In the dialog box, enter the name of the directory where the CD-ROM is mounted (for example, `/cdrom`), or click **List** to see the local devices.

9 Click **OK**.

The Install Software Products at Latest Available Level dialog box displays additional fields.

10 Click **List** next to the SOFTWARE to install field. After a brief delay, the Multi-Select List dialog box appears.
11 In the Multi-Select List dialog box, click the CiscoView module named **CiscoView.base.obj**.

12 Click **OK**.

13 In response to the ARE YOU SURE? prompt, click **OK** to install the module you just highlighted.

While the animated man is running, SMIT installs CiscoView in the `/usr/nms/CVapp` directory, and CiscoView modifies SMIT to allow subsequent configuration and uninstallation of CiscoView.

If the animated man raises his hands and SMIT displays **OK**, the installation has succeeded. If the man falls down, installation has failed. If the reason for failure is not apparent, read the installation log file `$HOME/smit.log`, then contact the Cisco Technical Assistance Center (TAC), if necessary.

14 Click **Done**, then **Cancel**.

15 If the installation in Step 13 was successful, select **Return To> System Management** and go to the section “Configuring CiscoView.”

If the installation failed, terminate SMIT by pressing **F12** or selecting **Exit>Exit SMIT**.
Configuring CiscoView

After installing CiscoView, follow these steps to configure the product.

1. Start SMIT if you have not already done so by entering the following command:

   # smit

2. On the initial SMIT menu, click Communications Applications and Services.

3. Click Cisco Network Management Applications for AIX.

4. Click CiscoView.

5. From the CiscoView dialog box, select Product Configuration.

6. From the Product Configuration dialog box, accept the defaults, or type values into each of the following fields.

   Product Group Name—Name of the AIX group that owns the CiscoView files. The default is bin. Click List to select one or more names from a list.

   Product User Name—AIX username of the individual assigned to the CiscoView files. The default is bin.
Integrate with Netview—The default is No. If you want to integrate CiscoView with NetView, click List.

Load MIBs Into NetView—The default is No. If you want to monitor MIBs through NetView, click List to select Yes. This option applies only when CiscoView is integrated with NetView.

Loading MIBs takes a significant amount of time, depending on the number of MIBs being loaded.

7 Click OK, wait for the process to complete, and read the output.

If the animated man raises his hands and SMIT displays OK, the process has succeeded. If the man falls down, the configuration has failed. If the configuration fails, contact the TAC.

8 Click Done, then click Cancel.

9 Terminate SMIT by pressing F12 or selecting Exit>Exit SMIT.

Now you need to install the device packages using the procedures in the sections “Installing Device Packages Incrementally” and “Performing CiscoView Maintenance Functions.” If you are installing packages from CD-ROM, unmount the CD-ROM after you have installed the necessary device packages.
Incremental Device Package Installation

To install device packages incrementally, you can use either of the following methods:

- Install device packages from the CiscoView CD-ROM, as explained in the “Installing CiscoView” section.

  or

- Install device packages from Cisco Connection Online (CCO). Refer to the section “Downloading Device Packages” for a quick reference to downloading device packages from CCO.

Setting Up Incremental Device Package Installation

To install device packages incrementally, you first need to set up the incremental installation by following these steps:

1. Start SMIT if you have not already done so by entering the following command:

   # smit

2. On the initial SMIT menu, click Communications Applications and Services.
3  Click **Cisco Network Management Applications for AIX**.

4  Click **CiscoView**.

5  On the CiscoView menu, click **Device Package Install Setup**.

6  In the Directory Containing Device Packages field, enter the path where the device packages reside.

7  In the Load MIBs into NetView field, the default is **No**. If you want to load MIBs, click **List**.

8  If you checked **List** in Step 8, click **Yes** in the Single Select List dialog box to load MIBs into NetView.

**Note**  Loading MIBs can take a significant amount of time depending on the number of MIBs being loaded.

9  Click **OK**, wait for the process to complete, and read the output.

   If the animated man raises his hands and SMIT displays **OK**, the process has succeeded. If the man falls down, incremental installation of the device packages has failed. If the incremental installation fails, contact a TAC representative.

10 Click **Done**, then click **Cancel**.
This procedure registers the directory containing the device packages and the options to load MIBs into NetView.

**Installing Device Packages Incrementally**

To install device package files from a directory on a workstation, follow these steps:

1. Start SMIT if you have not already done so by entering the following command:

   ```
   # smit
   ```

2. On the initial SMIT menu, click **Communications Applications and Services**.

3. Click **Cisco Network Management Applications for AIX**.

4. Click **CiscoView**.

5. In the CiscoView dialog box, click **Device Package Installation**.

6. In the Select Device Packages to Install field, click **List**. Wait for the process to complete, and read the output.
If the animated man raises his hands and SMIT displays OK, the process has succeeded. If the man falls down, the device package installation has failed. If the installation fails, contact the TAC.

8 Click **Done**, then **Cancel**.

**Device Package Deinstallation**

To deinstall device packages from CiscoView on AIX, perform the following steps:

1 If you haven’t already done so, start SMIT by entering the following command:

   ```
   # smit
   ```

2 On the initial SMIT menu, click **Communications Applications and Services**.

3 Click **Network Management Applications for AIX**.

4 Click **CiscoView**.

5 In the CiscoView dialog box, click **Device Package Deinstallation**.

6 Click **List** next to the Select Device Packages to Deinstall field. The Multi-Select List dialog box appears.

7 In the dialog box, click the package you want to deinstall.
8 Click **OK**.

While the animated man is running, SMIT deinstalls the device package you selected. If the man falls down, the deinstallation failed. If the device package deinstallation fails, contact the Cisco Technical Assistance Center (TAC).

9 Click **Done**, then **Cancel**.

10 Terminate SMIT by pressing **F12** or by selecting **Exit SMIT** on the Exit menu.

**Unmounting the CD-ROM Drive**

To unmount the CD-ROM drive, log in as root and perform the following steps:

1 At the local or remote workstation where the CD-ROM is mounted, enter the following command:

```
# cd /
# umount /cdrom
```

AIX unmounts the CD-ROM device from the `/cdrom` directory.

2 Remove the CD-ROM caddy from the drive.
Performing CiscoView Maintenance Functions

You can perform the following routine maintenance functions:

- Loading MIBs into NetView
- Rebuilding All CiscoView Files
- Uninstalling CiscoView

Loading MIBs into NetView

If you experience any corruption of your MIB database or the MIBs are not usable, you might want to consider reloading MIBs into NetView. The amount of time it takes to load MIBs into NetView depends on the number of MIBs being loaded.

To load MIBs into NetView, perform the following steps:

1. Start SMIT by performing steps 1 through 4 in the “Configuring CiscoView” section.

2. In the CiscoView dialog box, click Maintenance.

3. In the Maintenance dialog box, click Load all MIBs into NetView.

4. In response to the confirmation dialog box, click OK.
While the animated man is running, the MIB files are being loaded. If the man raises his hands and SMIT displays OK, the MIB files are loaded. If the man falls down, loading of the MIB files has failed. If loading fails, contact the TAC.

5 Terminate SMIT by pressing **F12** or by clicking **Exit SMIT** on the Exit menu.

**Rebuilding All CiscoView Files**

You can rebuild all CiscoView on AIX configuration files if

- You are not sure which device packages or files reside on your workstation.
- You want to troubleshoot and rebuild existing CiscoView files because of suspected corruption or deletion of CiscoView configuration files.

To rebuild all CiscoView files, perform the following steps:

1 Start SMIT by performing steps 1 through 4 in the “Configuring CiscoView” section.

2 In the CiscoView dialog box, click **Maintenance**.
3 In the Maintenance dialog box, click Rebuild all CiscoView config files.

4 In response to the confirmation dialog box, click OK.

While the animated man is running, the CiscoView device package files are rebuilt. If the man raises his hands and SMIT displays OK, the rebuilding of configuration files has succeeded. If the man falls down, rebuilding has failed, and you should contact the TAC.

5 Terminate SMIT by pressing F12 or clicking Exit SMIT on the Exit menu.

Uninstalling CiscoView

To uninstall CiscoView, perform these steps:

1 Log in as the root user.

2 Start SMIT by entering the following command:

   # smit

3 On the System Management menu, select Communications Applications and Services.

4 Select Cisco Network-Management Applications for AIX.
5 Select CiscoView.

6 Select Maintenance.

7 Select Remove CiscoView for AIX program.

8 In response to the ARE YOU SURE? prompt, click OK.

   While the animated man is running, SMIT uninstalls the CiscoView product. If the man raises his hands and SMIT displays OK, the uninstallation process has succeeded. If the man falls down, uninstallation has failed, and you should contact the TAC.

9 Terminate SMIT by pressing F12 or selecting Exit>Exit SMIT.

Getting Started with CiscoView

This section contains two startup methods for the first-time CiscoView user.

For details on CiscoView features, refer to the online help.
Starting CiscoView from the Command Line

To start CiscoView from the AIX command line and monitor a Cisco device, follow these steps:

1. For C shell, enter the following command
   
   ```
   $ source /usr/nms/CVapp/etc/CVinstall.cshrc
   ```

   For Bourne shell or Korn shell, enter the following command:
   
   ```
   % . /usr/nms/CVapp/etc/CVinstall.kshrc
   ```

2. Start CiscoView by entering the following at the command line:
   
   ```
   % nmcview
   ```

   To view the usage of the nmcview command, enter
   
   ```
   % nmcview -help
   ```

3. Specify a Cisco device to monitor.

   Select **File>Open Device** and enter a host name or IP address in the Host field, then click **OK**. The default password for the Read and Write community strings is **public**.

   A graphical image of the device’s back panel appears.
Starting CiscoView from NetView for AIX

To start CiscoView from NetView for AIX, follow these steps:

1. Start NetView for AIX by entering the following command:
   
   `nv6000`

2. Click the IP Internet symbol on NetView’s root map. NetView displays all devices running IP, including Cisco devices.

3. To see an image of a device’s control panels, highlight a Cisco device on the network map and select **Monitor>CiscoView**.

   If the CiscoView application is not visible on the NetView Monitor menu (and the configuration steps were successful), look for the `ciscoview.reg` file in the `/usr/OV/registration/C` directory. If the file is missing, contact the TAC.

Discovering New or Changed IP Devices

The default IP Internet map includes all IP devices connected to NetView when NetView is started. To discover newly added or modified IP devices, use the NetView **Options>Manage Objects** command as follows:

1. Click a device symbol on the default IP Internet map.
2  Select **Options>Manage Objects**. NetView displays a submap of the selected device’s children that are reachable in one hop. Newly appearing children could have been added to the network or explicitly unmanaged by a previous user. All newly appearing children devices are now accessible by CiscoView.

3  Select **File>Save Map As** to save the database of devices you created.

**Displaying a Device with CiscoView**

After you start CiscoView, you see the CiscoView main window. To display a device, perform the following steps:

1  Select **File>Open Device**.

   The File - Open Device window is displayed.

2  Complete the fields in the File - Open Device window as follows:

   In the Host field, enter the host name or IP address of the device you want to display.

   In the Read Community field, enter the read community string specified by your network administrator (*public* is the default).

   In the Write Community field, enter the write community string specified by your network administrator (*public* is the default). The
correct write community string allows you to change certain device settings.

3 Click OK to display the panel of the specified device.

**Downloading Device Packages**

This section provides a quick reference to downloading device packages from CCO.

If you do not have Internet access, skip this section. To receive updated packages, you can order the Cisco Network Management Support CD-ROM.

For the detailed description of downloading from CCO or additional information about the Cisco Network Management Support CD-ROM, see the “Downloading Device Packages” chapter in the *Overview for CiscoView*.

**Note** You need to be root or the owner (as specified in the installation), to perform the download.
To download device packages from CCO, perform the following steps:

1. Verify that you are running CiscoView Version 4.1(1) or later by entering `nmcview` from any directory on your workstation.

2. Select **Help>About CiscoView**.

3. Close CiscoView by selecting **File>Exit**.

4. Create a directory to store the `cv_pkgs` by entering the following commands:

   ```bash
   # mkdir /usr/nms/cv_pkgs
   # cd /usr/nms/cv_pkgs
   ```

5. Access CCO.

   You can access CCO as a registered user or as a guest.

   To access as a registered user, do the following:

   (a) Access the Software Center by entering the following URL in your Web browser: http://www.cisco.com/kobayashi/sw-center/

   (b) At the prompts, enter your CCO user ID and password.

   To be granted special file access as a guest do the following:
(a) Call the Technical Assistance Center (TAC) at 1-800-553-2447 or 1-408-526-7209, state the name of the product you are downloading, and you are transferred to the appropriate person to obtain your special access code.

(b) Enter the following URL in your Web browser:

(c) Enter your special access code in the Other Software Products/Special Files section.

(d) Select the device tar file and a download option.

6 Download the device tar file into the cv_pkgs directory.

There are two methods for downloading: from CCO and by FTP. For information on downloading by FTP, see the Software Library Web page or the Overview for CiscoView.

(a) In the Network Management Products section, select the CiscoView Upgrade Planner pointer to the CiscoView packages. To review the package README, click on the README filename and select a download option. To select a device tar file, click on the device filename and select a download option.

(b) Reenter your password, if required.
(c) If required, click **Save File** or **File>Save As**, depending on the browser you are using.

(d) If a filter window appears, enter the complete destination pathname in the Selection section of the filter window for the downloaded device, for example, 
/\textit{usr/nms/cv\_pkgs/device\_name}.

(e) Close the Web browser.

7 Unzip the device tar file.

CiscoView packages are saved on CCO as tar files. You can open the tar files using WinZip, which is also available on CCO.

(a) Enter \texttt{tar -xvf file\_name} in the \textit{cv\_pkgs} directory, where \textit{file\_name} is the name of your device package.

(b) Add the package file to CiscoView.

(c) Check the environment variable by entering \texttt{env}. It should include NMSROOT.

(d) If NMSROOT does not appear, set it by entering

\begin{verbatim}
setenv NMSROOT install_directory
\end{verbatim}
where install_directory is the name of the directory where CiscoView is installed, /usr/nms/CVapp.

Enter su root to log in as root and enter the following command to add the package file to CiscoView in the cv_pkgs directory:

$NMSROOT/bin/cvinstall /usr/nms/cv_pkgs/device_name.pkg

The downloading is complete. If there are any problems, check the cvinstall.log file in your install directory for an explanation of errors or see the Overview for CiscoView for more detail.

**Troubleshooting**

If you cannot open the specified device in CiscoView, you receive a message that the device is unmanageable. This message indicates one of the following conditions:

- The SNMP server is not set in the device. You can still ping the device from the management station.
- You have entered an incorrect community string in the File - Open Device window.
- The management station cannot reach the device and cannot successfully ping the device.
• The timeout value is too low. To change the timeout value, select **Options > Properties** and enter a new timeout value. Doubling the existing timeout value is a good starting point.

• The device package is not up to date. Check your device package and compare the date to the CCO device package version. Upgrade your device package to the latest version, if required.

**Service and Support**

This section describes how to contact Cisco Systems to order documentation products and receive service and support.

**Cisco Connection Documentation**

Cisco documentation and additional literature are available in a CD-ROM package, which ships with your product. The Documentation CD-ROM, a member of the Cisco Connection Family, is updated monthly. Therefore, it might be more up to date than printed documentation. To order additional copies of the Documentation CD-ROM, contact your local sales representative or call customer service. The CD-ROM package is available as a single package or as an annual subscription. You can also access Cisco documentation on the

If you are reading Cisco product documentation on the World Wide Web, you can submit comments electronically. Click Feedback in the toolbar, select Documentation, and click Enter the feedback form. After you complete the form, click Submit to send it to Cisco. We appreciate your comments.

Cisco Connection Online

Cisco Connection Online (CCO) is Cisco Systems’ primary, real-time support channel. Maintenance customers and partners can self-register on CCO to obtain additional information and services.

Available 24 hours a day, 7 days a week, CCO provides a wealth of standard and value-added services to Cisco’s customers and business partners. CCO services include product information, product documentation, software updates, release notes, technical tips, the Bug Navigator, configuration notes, brochures, descriptions of service offerings, and download access to public and authorized files.

CCO serves a wide variety of users through two interfaces that are updated and enhanced simultaneously: a character-based version and a multimedia version that resides on the World Wide Web (WWW). The
character-based CCO supports Zmodem, Kermit, Xmodem, FTP, and Internet e-mail, and it is excellent for quick access to information over lower bandwidths. The WWW version of CCO provides richly formatted documents with photographs, figures, graphics, and video, as well as hyperlinks to related information.

You can access CCO in the following ways:

- WWW: http://www.cisco.com
- WWW: http://www-europe.cisco.com
- WWW: http://www-china.cisco.com
- Telnet: cco.cisco.com
- Modem: From North America, 408 526-8070; from Europe, 33 1 64 46 40 82. Use the following terminal settings: VT100 emulation; databits: 8; parity: none; stop bits: 1; and connection rates up to 28.8 kbps.

For a copy of CCO’s Frequently Asked Questions (FAQ), contact cco-help@cisco.com. For additional information, contact cco-team@cisco.com.
Note  If you are a network administrator and need personal technical assistance with a Cisco product that is under warranty or covered by a maintenance contract, contact Cisco’s Technical Assistance Center (TAC) at 800 553-2447, 408 526-7209, or tac@cisco.com. To obtain general information about Cisco Systems, Cisco products, or upgrades, contact 800 553-6387, 408 526-7208, or cs-rep@cisco.com.