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Using the Spectrum Management Tools

CBT 3.5 interfaces with the Cisco CMTS to provide return path spectrum analysis. The following tasks 
allow you to use the spectrum management tool effectively:

• Trace Window—Monitors power and noise levels for a selected modem or upstream port.

• Spectrogram—Monitors power and noise levels over time for a selected modem or upstream port.

• CNR Analysis—Retrieves the carrier-to-noise ratio (CNR) for selected modems or upstream ports.

• CNR Trending—Retrieves CNR trending data for selected modems or upstream ports.

• Data Playback—Reviews a saved Trace Window or CNR Analysis. 

• Polling Status—Displays the spectrum analysis in progress on a client machine and to view the 
scheduled spectrum polling events.

Each task is covered in the following sections:

• Using the Trace Window, page 4-1

• Sorting Support in the CBT 3.5 Graphical User Interface, page 4-5

• Using Auto-Select in the Trace Window, page 4-6

• Using the Spectrogram, page 4-6

• Analyzing the Carrier-to-Noise Ratio, page 4-9

• Retrieving CNR Trending Data, page 4-11

• Playing Back Data, page 4-12

• Displaying Polling Status, page 4-19

• Enabling Instantaneous CPU Assessment for Spectrum Polling, page 4-20

Using the Trace Window

To monitor power and noise levels for a selected modem or upstream port, use the Trace Window. As 
shown in Figure 4-1, the Trace Window shows the output that you would see in a spectrum analyzer. 
This output displays in the plot line of the Trace Window.
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Figure 4-1 Trace Window Display

In the Trace Window, you can:

• Monitor the power and noise levels two ways:

– Single sweep—Provides a snapshot view of levels at one point in time, as shown in Figure 4-1

– Continuous sweep—Provides a real-time view of data as it changes

• Check two types of power levels and display the data in the results block, which is in the lower right 
corner as shown in Figure 4-1:

– Burst power analysis—Acquires the upstream channel power

– Band power analysis—Acquires the band power measurement for a start and stop frequency 
that you select

• View the Modulation profile information as shown in Figure 4-1:

– Modulation profile—Displays the modulation profile number, usage code, and the channel 
type of an upstream.

• Show additional plot lines:

– Minimum hold—Display the plot line that shows the minimum power level

– Maximum hold—Display the plot line that shows the maximum power level

– Average—Displays the plot line that shows the average power level

– Smoothing—Displays the plot line that shows power on a frequency based on its own value and 
neighboring power values

– Stacking—Displays the plot line that shows multiple upstreams or modems are being 
monitored

• Indicate a variety of lines and points in the plot line and display the data in the annotations block, 
which is in the upper right corner, as shown in Figure 4-1

– Amplitude and frequency lines—Display a line marker in the plot line, as shown by the 
horizontal amplitude line at 0 dBmV and the vertical frequency line just before 14000 kilohertz 
(kHz) in Figure 4-1
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– Reference marker—Is a unique marker in the plot line and is indicated by r, as shown in 
Figure 4-1

– Point markers—Is a way to indicate one or more points in the plot line; each point marker is 
numbered consecutively beginning with p1, as shown in Figure 4-1

• Num Sample—Display number of samples stored to calculate the average.

• Weight—Toggle the smoothing algorithm between exponential weight and even weight smoothing.

• Zoom Out—Return to a normal view from a zoomed in view.

• Clear All Markers—Clear all the markers including the reference and point markers and the 
amplitude and frequency lines.

• Customize the placement and position of point markers:

– Delta—You can enable this to indicate that the power level for all point markers in the 
annotation window is the delta between the point markers power level and the reference marker 
power level.

– Frequency (kHz)—You can specify a frequency in kilohertz for the point marker by entering a 
number in the Frequency text box. For example, you could enter 20200 instead of clicking on 
the plot line near 20000.

– Text—You can customize a point marker’s label by entering a name in the Text box. For 
example, you could change p1 to Test Point 1 and p2 to Test Point 2, as shown in Figure 4-1.

• On Trace—Add a cable modem or upstream to the marker.

• Clear Spectrum—Clear the spectrum requests from the CMTS.

• Move a marker that you created to peaks in the plot line:

– Peak

– Next peak

– Left peak

– Right peak

Starting the Trace Window

To use the Trace Window to monitor power and noise levels for a selected modem or upstream port:

Step 1 From the Spectrum Tools menu, choose Trace Window. The Trace Window Criteria dialog box appears, 
as shown in Figure 4-2.

Step 2 Select an upstream or cable modem for which you want to monitor power and noise levels.

Note To update the cable modem information on the selected CMTS instead of getting data from the cache, 
click Update CM Info. This real-time update varies according to how many modems are attached to the 
CMTS. The update depends on the number of modems attached to the Cisco CMTS; the update takes 
longer if more number of modems are attached to the Cisco CMTS.
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Tip When you select the resolution bandwidth (RBW), keep in mind that the smaller the RBW, the less 
variance and the more accurate the frequency is in the Trace Window is. Specifically, when a single-tone 
signal that resembles a noise burst appears in the Trace Window, the frequency of the signal gets shifted. 
This causes the frequency in the Trace Window to be different from the spectrum analyzer output. The 
variance in frequency increases as the resolution bandwidth increases. 

Step 3 Click Start. The Trace Window appears, as shown in Figure 4-1.

Step 4 To view the return path data and activate all options in the Trace Window, click one of the following 
buttons:

• Single Sweep—Provides a single snapshot of power and noise levels

• Continuous Sweep Start— Starts to monitor for real-time measurements of power and noise levels

Step 5 For a complete description of each field in these dialog boxes, click Help.

Figure 4-2 Trace Window Criteria Dialog Box
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Working with the Trace Window

Table 4-1 shows several ways to work with data in the Trace Window.

Viewing Trace Windows

Some browsers give the user the ability to stop windows from being launched by the browser. CBT 3.5 
normally launches a new window to display the trace pop-up spectrum data charts. If the data chart 
window does not appear and the browser is configured to stop new windows from launching, you can 
configure CBT 3.5 to display data charts within the browser window.

To display data charts within the browser window:

Step 1 From the Configuration menu, choose System.

Step 2 In the System Configuration screen, uncheck the Use Popup check box.

Sorting Support in the CBT 3.5 Graphical User Interface

CBT 3.5 supports sorting for the List fields in the following GUI pages:

• Spectrum Data Scheduler

• Trace Window Criteria

• Spectrogram Criteria

• CNR Analysis Criteria

• CNR Trending Criteria

To change the order of sorting:

Step 1 Select the desired desired page:

• Configuration > Scheduler > Spectrum Data > Spectrum Data Scheduler

• Spectrum Tools > Trace Window > Trace Window Criteria

Table 4-1 Keyboard Actions for Working with the Trace Window

Task Keyboard Sequence

To move a line marker Press Shift, click and drag the line to the desired 
location.

To zoom in on a selected frequency Move your cursor to the area you want to enlarge 
and press Ctrl, left-click.

or

Press Ctrl, left-click and drag your cursor to 
create a box that indicates the area you want to 
enlarge.

To return to a full view from a zoom view Press r.
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• Spectrum Tools > Spectrogram > Spectrogram Criteria

• Spectrum Tools > CNR Analysis > CNR Analysis Criteria

• Spectrum Tools > CNR Trending > CNR Trending Criteria

Step 2 Click on the label of the desired field, and data is sorted in ascending or descending order. Each click of 
the label reverses the current order displayed.

Using Auto-Select in the Trace Window

CBT 3.3 and later do not support auto-select of any given field in the Trace Window by default. To 
retrieve and display information for any given field in the Trace Window display, select the desired field. 

Using the Spectrogram

To monitor power and noise levels, as you do in the Trace Window, while viewing the added dimension 
of time, use the Spectrogram. As shown in Figure 4-3, the Spectrogram shows the output that you would 
see in a spectrum analyzer.

Figure 4-3 Spectrogram

In the Spectrogram, you see the following variables in one easy, 3-D view:

• Power level—Measured in decibels millivolt (dBmV) and depicted according to the color key at the 
bottom. As shown in Figure 4-3, the power level is cyan, which the color key indicates is in the 
-30 to -10 dBmV range.

• Frequency—Measured in kilohertz and shown on the X axis. In Figure 4-3, the power level is 
between 30867 and 34563 kHz.

• Time—Measured in hours, minutes, and seconds (HH:MM:SS) and shown on the Y axis. Figure 4-3 
shows the latest time that data was captured is 15:18:39.
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When you move your cursor over the Spectrogram, the status bar at the bottom of the window displays 
the time, frequency, and power level for the current location. In the Spectrogram, you can click Pause 
or Print at anytime.

Starting the Spectrogram

To use the Spectrogram to monitor power and noise levels for a selected modem or upstream port over 
time:

Step 1 From the Spectrum Tools menu, choose Spectrogram. The Spectrogram Criteria dialog box appears, as 
shown in Figure 4-4.

Step 2 Select the Cisco CMTS, the interface, and an upstream or cable modem for which you want to monitor 
power and noise levels over time.

Note To update the cable modem information on the selected CMTS instead of getting data from the cache, 
click Update CM Info. This real-time update varies according to how many modems are attached to the 
CMTS. The update depends on the number of modems attached to the Cisco CMTS; the update takes 
longer if more number of modems are attached to the Cisco CMTS.

Step 3 Click Start. The Spectrogram appears, as shown in Figure 4-3.

Step 4 After completion of criteria selections, click Start, and the Spectrogram Criteria Confirmation dialog 
box appears. Click Yes to apply the changes. 

Step 5 For a complete description of each field in these dialog boxes, click Help.
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Figure 4-4 Spectrogram Criteria Dialog Box
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Figure 4-5 Spectrogram Criteria Confirmation Dialog Box

Analyzing the Carrier-to-Noise Ratio

To show the carrier-to-noise ratio for selected cable modems or upstream ports, use the CNR Analysis 
task. As shown in Figure 4-6, this information displays in the CNR Analysis dialog box, which lets you:

• View the following information:

– CMTS and interface/upstream

– CM MAC address

– Carrier-to-noise ratio

– Collected time

• Save the results to play back later.
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Figure 4-6 CNR Analysis Dialog Box

You can set the following SPECTRUM.INI file parameters:

• Set thresholds for acceptable carrier-to-noise ratios

• Specify colors for CNRs that are below two thresholds, floor and ceiling

In Figure 4-6, the CNRs for the selected modems fall into three categories:

• Yellow—The CNR is below the ceiling threshold.

• Red—The CNR is below the floor threshold.

• White—The CNR is above the ceiling threshold.

For more information on the SPECTRUM.INI file, see the “Parameters in the SPECTRUM.INI File” 
section on page 3-20.

Getting the CNR Analysis

To show the carrier-to-noise ratio for selected cable modems or upstream ports:

Step 1 From the Spectrum Tools menu, choose CNR Analysis. The CNR Analysis Criteria dialog box appears, 
as shown in Figure 4-7.

Step 2 Select one or more upstreams or cable modems for which you want to see the carrier-to-noise ratio.
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Note To update the cable modem information on the selected CMTS instead of getting data from the cache, 
click Update CM Info. This real-time update varies according to how many modems are attached to the 
CMTS. The update depends on the number of modems attached to the Cisco CMTS; the update takes 
longer if more number of modems are attached to the Cisco CMTS.

Tip You specify an upper and lower threshold for carrier-to-noise ratios in the CNRCeiling and CNRFloor 
parameters of the SPECTRUM.INI file. If you want to specify different thresholds on an 
analysis-by-analysis basis, you can do that in the Upper Threshold and Lower Threshold fields. For more 
information on thresholds, see the “Parameters in the SPECTRUM.INI File” section on page 3-20.

Step 3 Click Start. The CNR Analysis dialog box appears, as shown in Figure 4-7.

Step 4 For a complete description of each field in these dialog boxes, click Help.

Figure 4-7 CNR Analysis Criteria Dialog Box

Retrieving CNR Trending Data

To retrieve the CNR trending data for selected cable modems or upstream ports:

Step 1 From the Spectrum Tools menu, choose CNR Trending. The CNR Trending Criteria dialog box appears 
as shown in Figure 4-8.

Step 2 Select one or more upstreams or cable modems for which you want to see the CNR trending data.
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Note To update the cable modem information on the selected CMTS instead of getting data from the cache, 
click Update CM Info. This real-time update varies according to how many modems are attached to the 
CMTS. The update depends on the number of modems attached to the Cisco CMTS; the update takes 
longer if more number of modems are attached to the Cisco CMTS.

Step 3 Click Add to add the upstream or cable modem to the Selected US/CM list.

Step 4 Click Start. The CNR Trending graph is displayed.

Step 5 For a complete description of each field in these dialog boxes, click Help.

Figure 4-8 CNR Trending Criteria Dialog Box

Playing Back Data

You can play back a saved Trace Window or CNR Analysis. This allows you to capture and preserve 
troubleshooting information and use it later.
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Playing Back Trace Window

To play back Trace window:

Step 1 From the Spectrum Tools menu, choose Data Playback > Trace Window. The 
Trace Window Playback Criteria dialog box appears, as shown in Figure 4-9. Otherwise, Figure 4-10 
shows an alternate view of this dialog box, with additional information displayed for illustrative 
purpose.

Step 2 Select one or more MAC addresses for which you want to see a list of saved traces and click Start. The 
Trace Window Playback List dialog box appears, as shown in Figure 4-11.

Step 3 From the list of saved traces, select the one you want to play back and click Show. The Trace Window 
for the saved trace, as shown in Figure 4-1, appears.

Note To remove a saved Trace Window from the database, from the Utilities menu, choose Purge Saved Data, 
Spectrum Data.

Step 4 For a complete description of each field in these dialog boxes, click Help.

Figure 4-9 Trace Window Playback Criteria Dialog Box
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Figure 4-10 Trace Window Playback Criteria Dialog Box, Alternate View
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Figure 4-11 Trace Window Playback List Dialog Box

Playing Back CNR Analysis

To play back CNR analysis:

Step 1 From the Spectrum Tools menu, choose Data Playback > CNR Analysis. The 
CNR Analysis Playback Criteria dialog box appears, as shown in Figure 4-12.

Step 2 To select one or more MAC addresses for which you want to see a saved CNR Analysis, click Start. The 
CNR Analysis Playback Result dialog box appears, as shown in Figure 4-13. 

Note To remove a saved CNR Analysis from the database, from the Utilities menu, choose Purge Saved Data, 
Spectrum Data.

Step 3 For a complete description of each field in these dialog boxes, click Help.
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Figure 4-12 CNR Analysis Playback Criteria Dialog Box
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Figure 4-13 CNR Analysis Playback Result Dialog Box

Playing Back CNR Trending Data

To play back CNR trending data:

Step 1 From the Spectrum Tools menu, choose Data Playback > CNR Trending. The 
CNR Trending Playback Criteria dialog box appears, as shown in Figure 4-14.

Step 2 Select the MAC addresses for which you want to see the saved CNR trending data and then click Add.

Step 3 Click Start to view the CNR Trending Playback result dialog box. (See Figure 4-15.) 

Step 4 Click Print to create a printer-friendly version of the chart and print it at your local printer.

Step 5 For a complete description of each field in these dialog boxes, click Help.
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Figure 4-14 CNR Trending Playback Criteria Dialog Box

Figure 4-15 CNR Trending Playback Result Dialog Box
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Displaying Polling Status

To get a list of each spectrum analysis in process on a client machine and to view the details of the 
scheduled spectrum polling events, use the Polling Status tool.

Real Time Polling Status

To see a list of clients currently using CBT's spectrum management tools:

Step 1 From the Spectrum Tools menu, choose Polling Status > Real Time. The Spectrum Data Clients dialog 
box appears, as shown in Figure 4-16.

Step 2 Perform one of the following:

1. Refresh - Refreshes the screen.

2. Launch Trace Window - Launches the trace window.

3. Launch Spectrogram - Launches the spectrogram.

4. Generate HTML - Generates the HTML file that can be printed and saved.

Step 3 For a complete description of each field in these dialog boxes, click Help.

Figure 4-16 Spectrum Data Clients Dialog Box

Scheduled Polling Status

To view the details of the scheduled spectrum polling events:

Step 1 From the Spectrum Tools menu, choose Polling Status > Scheduled. The Spectrum Event Status dialog 
box appears, as shown in Figure 4-17.
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Step 2 Perform one of the following:

1. Refresh - Polls the database for the latest events.

2. Details - Displays a pop-up window with the details for the scheduled collection.

3. Stop - Cancels the scheduled collection.

4. Remove - Cancels the scheduled collection.

5. Show - Displays the data collection.

6. Play - Shows the actual trace.

7. Generate HTML - Generates the HTML file that can be printed and saved.

Step 3 For a complete description of each field in these dialog boxes, click Help.

Figure 4-17 Spectrum Event Status Dialog Box

Enabling Instantaneous CPU Assessment for Spectrum Polling 

CBT 3.5 enables the option of preventing excessive CPU consumption, in circumstances in which the 
Trace Window, Spectrogram functions, or Scheduled Polling features might otherwise exceed CPU 
bandwidth.

CBT has provisions to instantaneously check the CPU utilization and prevents the spectrum operation if 
the CPU utilization exceeds the CPU thresholds (value of SpecDataMaxCPU parameter). 

Perform these steps to enable or disable CPU assessment in the Trace Window Criteria dialog box, the 
Spectrogram Criteria dialog box, or the Spectrum Data Scheduler dialog box before launching the 
spectrum event.
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Step 1 Launch CBT 3.5.

Step 2 Log in to CBT as admin.

Step 3 Launch the desired window in which to configure this change. 

• For Trace Window changes, from the Spectrum Tools menu, choose Trace Window. The 
Trace Window Criteria dialog box appears. Proceed to the next step.

• For Spectrogram changes, from the Spectrum Tools menu, choose Spectrogram. The 
Spectrogram Criteria dialog box appears. Proceed to the next step.

Step 4 Select the checkbox Check CPU Util. This setting defines the number of sweeps for every CPU 
utilization check. Only when the check box is selected is the text box enabled to enter the number of 
spectrum sweeps that should be done for every CPU utilization check. If periodic check of CPU 
utilization is not necessary, then deselect this option and proceed. If not selected, the CPU utilization is 
checked only once before the launch of the spectrum operation. Refer to Figure 4-18. 

Figure 4-18 Check CPU Util Dialog Box

Step 5 When the Check CPU Util check box is selected, enter the number of sweeps in which CPU utilization 
should be checked. The default value is 10.

This setting means that the CPU utilization is checked and compared with the SpecDataMaxCPU 
parameter. Upon positive results, the spectrum operation gets started. The spectrum data is collected 
continuously with the specified poll interval. 

One sweep corresponds to a single polling of spectrum data. After 10 such polling events, CBT again 
checks the CPU Utilization and compares it with the SpecDataMaxCPU parameter. If the results are 
positive, the spectrum operation continues; otherwise, the continuous query is stopped. If the number of 
sweeps is 1, then the CPU utilization is checked before every polling of spectrum data.

Step 6 Continue with the launch of the spectrum operation.
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