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Managing with the Configuration Desktop
These sections describe how to manage with the Configuration Desktop:
•

Overview of the Configuration Desktop, page 2-79

•

Launching the CWI Configuration Desktop, page 2-81

•

Closing the Configuration Desktop, page 2-82

•

Navigating the Configuration Desktop, page 2-82

•

Managing with Text Editor, page 2-101

•

Common Activities in Configuration Desktop Applications, page 2-107

Overview of the Configuration Desktop
The Configuration Desktop applications allow you to configure the Cisco routers within your network.
The Configuration Desktop is opened for one logical router (LR) chosen in the Craft Works Interface
(CWI) Desktop, and multiple Configuration Desktops for different LRs can be opened concurrently. For
detailed information on the Configuration Desktop applications, see the Cisco Craft Works Interface
Configuration Applications Reference Guide.
Table 2-1 lists the different options to configure an LR using the Configuration Desktop.
Table 2-1

Options to Configure a Logical Router

Type
1

GUI applications

Description
Configures specific components of an LR using a user-friendly interface.
See the “Managing with Text Editor” section on page 2-101 and the
“Common Activities in Configuration Desktop Applications” section on
page 2-107 for information on the GUI applications in the Configuration
Desktop.
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Table 2-1

Options to Configure a Logical Router (continued)

Type

Description

Configuration Editor

Configures an LR using CLI2 commands, functions, and features. When
the Configuration Editor is opened, it contains a copy of the running
configuration on the LR. This copy of the running configuration becomes
the target configuration, which you can edit using CLI commands and
functions. See Chapter 3, “Configuring with the Configuration Editor,”
for information on the Configuration Editor.
Note

Replace Configuration
Editor

You must launch the Configuration Editor from the CWI
Desktop.

Loads or creates a configuration using CLI commands, functions, and
features. The content of the Replace Configuration Editor must either be
committed (become the running configuration) or be saved locally. See
Chapter 4, “Configuring with the Replace Configuration Editor,” for
information on the Replace Configuration Editor.

1. GUI = graphical user interface
2. CLI = command-line interface

Table 2-2 lists the GUI applications for the Configuration Desktop. You can concurrently access multiple
applications within the Configuration Desktop.
Table 2-2

Configuration Desktop Applications

Name

Description

Administration Configuration
AAA1

Manages TACAC servers.

Alarm Administration

Specifies event (alarm) log and correlation rule parameters.

User Administration

Manages users, user groups, and task groups.

Applications Configuration
IEP2

Creates and configures an IEP.

MPLS-TE

3

Configures MPLS-TE on the router.

Interfaces Configuration
Common

Displays and sets attributes common to all available interfaces.

Ethernet

Displays and sets the attributes specific to the available Ethernet interfaces.

PoS

4

Display and set the attributes specific to the available PoS interfaces.

Controllers Configuration
SONET

Displays and sets the attributes specific to SONET on a router port using Layer 1
SONET transport technology.

Policy Configuration
Access Control Lists

Displays, creates, and edits ACLs5 and ACEs6.

Packet Filter

Displays and chooses the inbound and outbound ACLs that apply to each interface.

QoS

7

Displays and edits class maps, policy maps, and service policies.
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Table 2-2

Configuration Desktop Applications (continued)

Name

Description

Routing Policy

Displays, creates, and edits prefix lists and redistributes route information from one
routing protocol to another.

Protocols Configuration
BGP8
IS-IS

Displays, edits, and configures BGP parameters.

9

Displays, edits, and configures an IS-IS routing protocol on process, address, family
(topology), and interface levels.

LDP10

Displays, edits, and configures LDP globally and enables or disables LDP for each
interface or neighbor.

OSPF11

Displays, edits, and configures OSPF processes, areas, and interfaces.

RSVP

12

Displays, edits, and configures RSVP configurations for available interfaces.

1. AAA = authentication, authorization, and accounting
2. IEP = IP explicit path
3. MPLS-TE = Multiprotocol Label Switching traffic engineering
4. PoS = Packet-over- SONET
5. ACL = access control list
6. ACE = access control entries
7. QoS = quality of service
8. BGP = Border Gateway Protocol
9. IS-IS = Intermediate System-to-Intermediate System
10. LDP = Label Distribution Protocol
11. OSPF = Open Shortest Path First
12. RSVP = Resource Reservation Protocol

Launching the CWI Configuration Desktop
You can use the CWI Configuration Desktop to interactively display and manage the configuration. The
Configuration Desktop is the main point of access to all configuration applications.
To launch the Configuration Desktop from the main CWI desktop, perform the following steps:
Step 1

Choose the logical router in the root node in the Physical View. Or press Ctrl and click the desired
objects in the Inventory Tree to choose random multiple objects.

Step 2

Invoke the Configuration Desktop. Choose one of the following options:
a.

Choose Tools > Configuration Desktop.

b.

Right-click the logical router node in the Physical View and choose Configuration Desktop.

The Configuration Desktop window is displayed (see Figure 2-2). You can select one of the
configuration applications.
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Closing the Configuration Desktop
To close the Configuration Desktop, perform the following steps:
Step 1

Choose File > Exit. Or click the Close button on the application title bar. A CWI dialog box appears
(see Figure 2-1).
Figure 2-1

Step 2

CWI Dialog Box

Click Yes to close the Configuration Desktop. The Configuration Desktop closes.

Navigating the Configuration Desktop
The Configuration Desktop is designed with common features in all Configuration Desktop applications.
These features provide an easy to use and consistent user interface.
The Configuration Desktop provides various applications that allow you to monitor and configure a
router. All configuration activities originate from the Configuration Desktop. One Configuration
Desktop can be opened for one LR.
The line card type and interface selected in the Inventory Tree when the Configuration Desktop is opened
determines which configuration applications are available.
These sections describe how to navigate the Configuration Desktop:
•

Configuration Desktop Window, page 2-83

•

Configuration Applications Tree, page 2-84

•

Configuration Applications Pane, page 2-88

•

Launch Context Pane, page 2-89

•

Configuration Desktop Menu Bar, page 2-90

•

Configuration Desktop Toolbar, page 2-92

•

Application Toolbar, page 2-94

•

Configuration Desktop Application Buttons, page 2-96

•

Configuration Desktop Status Bar, page 2-96

•

Configuration Change Handling, page 2-96

•

Validating the Required Fields, page 2-98

•

Error Handling, page 2-99
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Configuration Desktop Window
The Configuration Desktop window (see Figure 2-2) is used to start all the configuration applications.
You can also perform all configuration activities on the router network.
Table 2-3 lists the primary panes in the Configuration Desktop.
Table 2-3

Primary Panes

Pane

Description

Configuration Applications tree

Displays all applications available in the Configuration Desktop.
See the “Configuration Applications Tree” section on page 2-84
for more information.

Configuration Applications pane

Displays all active configuration applications. See the
“Configuration Applications Pane” section on page 2-88 for more
information.

Launch Context pane

Displays the objects that were chosen when the Configuration
Desktop was opened from the CWI Desktop. For interfaces, only
the objects listed in the Launch Context pane are available for
configuration. See the “Launch Context Pane” section on
page 2-89 for more information.

Cisco Craft Works Interface User Interface Guide
OL-4457-05

2-83

Chapter 2

Managing with the Configuration Desktop

Navigating the Configuration Desktop

Figure 2-2

Configuration Desktop

1

Configuration Applications Tree

5

Configuration Desktop status bar

2

Configuration Desktop menu bar

6

Configuration Applications pane

3

Configuration Desktop toolbar (Standard toolbar icons)

7

Launch Context pane

4

Configuration Desktop toolbar (Configuration Controls toolbar icons) — —

Configuration Applications Tree
The Configuration Applications Tree is the primary interface to all configuration applications in the
CWI. You can navigate the configuration applications and dynamically display the status of the
applications. The icon for each application in the tree indicates the state of the application
(see Figure 2-3).
Right-click an application icon in the Applications Tree. A popup menu allows you to start the chosen
application or double-click the application to open it.
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Figure 2-3

Configuration Applications Tree Symbols

1

Not Permitted

4

Disabled

2

Unchanged Configuration

5

Incompatible Version

3

Uncommitted Configuration

— —

When there is an uncommitted configuration on the router, right-click the Configuration Applications
icon in the Configuration Applications Tree. A popup menu allows you to display uncommitted
configuration (also known as the target configuration) settings in a window in CLI format. The
Configuration Applications icon changes from a folder to a folder with paper and a pencil when there is
an uncommitted configuration in the Configuration Desktop.
Table 2-4 describes the Configuration Applications tree symbols.
Table 2-4

Symbols for the Configuration Applications Tree

Name

Description

Not Permitted symbol
(no entry symbol on a page)

Indicates that the application is not available. This symbol
indicates that you do not have permission to start the
application.

Unchanged Configuration symbol
(blank page)

Indicates that the application is available and there is no
uncommitted configuration for the application.

Disabled symbol
(dimmed page or not available)

Indicates that the application has already been disabled.
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Table 2-4

Symbols for the Configuration Applications Tree (continued)

Name

Description

Uncommitted Configuration symbol
(paper and pencil)

Indicates that the application contains configuration changes
that have not been committed and are in the target
configuration.

Incompatible Version symbol
(a large red V)

Indicates that the application is not available and there is a
version mismatch between the software on the router and the
CWI graphical configuration (mismatches are not relevant to
the Configuration Editor or CWI Telnet Plus configurations).

User Permissions
User permissions for each configuration application are displayed in tooltips. Permissions are based on
assigned task IDs. Task IDs are assigned to users by associating each user with one or more user groups.
Every user group is associated with one or more task groups; in turn, every task group is defined by a set
of task IDs and a set of permissions associated with each task ID. Consequently, a user's association with
a particular user group links that user to a particular set of task IDs and permissions associated with each
of those task IDs. The permissions associated with a task ID that a user is linked to dictate what kind of
operation the user can perform on a particular command that requires the same task ID. For example, if
a user has only ready permissions for a particular task ID, then the user can only view the commands and
output and not change any configuration.

Note

Task IDs grant permission to perform certain tasks; task IDs do not deny permission to perform tasks.
When the pointer is placed on an application icon in the Configuration Applications tree, the tooltip
containing the task ID permissions appears (see Figure 2-4).
Each line after the Privilege Status line represents an AAA task ID that is required for complete read and
write access to the selected configuration application. For information on task IDs, see the
Cisco IOS XR Getting Started Guide.
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Figure 2-4

Configuration Applications Permissions

The task ID permissions are read, write, execute, and notify. When you launch an application, you can
configure all parameters in the application that are associated with the task IDs for which you are
assigned read and write permissions. If there are task IDs for which you are not assigned write
permissions, you will not be able to configure any parameters that are associated with those task IDs
(you have read-only access). An error message is displayed when you attempt to apply configuration
changes to a parameter that you do not have write permissions assigned.

Note

If you do not have write permissions for all the task IDs for a configuration application, you can still
launch the application with read-only access.
Table 2-5 provides descriptions of the permission syntax used in the tooltips.
Table 2-5

Task ID Permission in Tooltips

Syntax

Description

Privilege Status [ () = Missing]:

Any permission key listed inside the ‘()’ is a permission that is
required to have complete access to the selected configuration
application.
For example, bgp [ R (W) ] indicates that the bgp taskID with read
and write permissions is required for full (read and write) access to
the application. The example indicates only read permissions for
bgp taskID.

[ (R) (W) ]

Read and write permissions are required, but you do not have either
of the permissions.

[RW]

Read and write permissions are required, and you have both
permissions.
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Table 2-5

Task ID Permission in Tooltips (continued)

Syntax

Description

[ (R) W ]

Read and write permissions are required, and you have write
permissions.

[ R (W) ]

Read and write permissions are required, and you have read
permissions.

Configuration Applications Pane
The Configuration Applications pane is the area of the Configuration Desktop that contains the active
configuration applications used to configure the router. Multiple applications can be opened
concurrently in the Configuration Applications pane.
An example of an application in the Configuration Applications pane is displayed (see Figure 2-5).
Figure 2-5

Example of an Application Window

1

Application title bar

4

Application pane

2

Application tool bar

5

Application status bar

3

Application table

— —
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Several components in the applications are similar. The similarities in the applications provide a
consistent user interface, as listed in Table 2-6.
See the “Managing with Text Editor” section on page 2-101 for detailed information on similar
components in the configuration applications.
Table 2-6

Components for the Applications Pane

Component

Description

Application title bar

Contains the name of the application. The application title bar also provides
Minimize, Maximum, and Close buttons to control the application window.

Application toolbar

Provides quick access to commonly used functions. Several of the
applications do not contain all the tools shown (see Figure 2-6). The following
applications contain all the tools except Add, Clone, Clone Special, and
Delete:
•

Common

•

Ethernet

•

PoS

•

SONET

•

Packet Filter

See the “Validating the Required Fields” section on page 2-98.
Application status bar Displays the status of the application.
Application pane

Displays the details for the record selected in the application table.
The Application pane contains attributes for one or more records. When one
or more records is chosen in the Application table, the attributes are displayed
in the Application pane. The Application pane can contain multiple tabs,
which allows the application to combine multiple functions within a single
configuration application.
Tooltips provide information such as default value, accepted range, and a
description of the field for each input field in the Application pane.
See the “Managing with Text Editor” section on page 2-101 for information
on validating fields in the Application pane.

Application table

Displays all the records for the application in table format. When a record in
the Application table is chosen, the record details appear in the Application
pane.
See the “Managing with Text Editor” section on page 2-101 for information
on validating cells in the application table.

Launch Context Pane
The Launch Context pane displays the objects that were chosen when the Configuration Desktop was
opened from the CWI Desktop. When you have multiple Configuration Desktop windows open, you can
view the objects that can be configured in that instance of the Configuration Desktop. Only the objects
listed in the Launch Context pane are available for configuration in the active Configuration Desktop.
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Configuration Desktop Menu Bar
The Configuration Desktop menu bar (see Table 2-7) provides a list of options (see Table 2-8) available
based on the chosen object and active application.The options are administrative, editing, and viewing
tasks; starting applications; and arranging windows. The Configuration Desktop menu bar is located
under the CWI Desktop title bar (see Figure 2-2).
Table 2-7

Table 2-8

Configuration Desktop Menu

Menu Bar

Task

File

Prints and exports configuration application data or text, and exits the Configuration
Desktop.

Edit

Cuts, copies, and pastes CWI application data or text, searches for data or text in a
configuration application, and specifies configuration application preferences.

View

Shows and hides the CWI Desktop toolbar and status bar.

Tools

Opens the configuration applications used to configure a router.

Window

Closes configuration applications, cascades or minimizes open configuration
applications in the Application pane, and chooses the active configuration application.

Help

Displays the online help.

Configuration Desktop Menu Bar Options

Menu-Bar Options

Task

File
Print

Prints data from the currently active application in tabular format. See the “Setting
Preferences” section on page 1-71.

Export

Exports the chosen report to a text (comma-separated or tab-separated) or HTML file. See
the “Exporting Table Data” section on page 1-69.

Exit

Closes the Configuration Desktop. See the “Closing the Configuration Desktop” section
on page 2-82.

Cut

Removes the currently chosen data or text and moves it to the Clipboard (supported in the
Configuration Editor, Replace Configuration Editor, and Text Editor applications). See the
“Cutting, Copying, and Pasting Text in the Configuration Editor” section on page 3-133,
the “Cutting, Copying, and Pasting Text in the Replace Configuration Editor” section on
page 4-142, and the “Cutting, Copying, and Pasting Text in the Text Editor” section on
page 2-106.

Copy

Copies the currently chosen data or text and moves it to the Clipboard (supported in the
Configuration Editor, Replace Configuration Editor, and Text Editor applications). See the
“Cutting, Copying, and Pasting Text in the Configuration Editor” section on page 3-133,
the “Cutting, Copying, and Pasting Text in the Replace Configuration Editor” section on
page 4-142, and the “Cutting, Copying, and Pasting Text in the Text Editor” section on
page 2-106.

Edit
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Table 2-8

Configuration Desktop Menu Bar Options (continued)

Menu-Bar Options

Task

Paste

Pastes the data or text from the Clipboard into the currently chosen field (supported in the
Configuration Editor, Replace Configuration Editor, and Text Editor applications). See the
“Cutting, Copying, and Pasting Text in the Configuration Editor” section on page 3-133,
the “Cutting, Copying, and Pasting Text in the Replace Configuration Editor” section on
page 4-142, and the “Cutting, Copying, and Pasting Text in the Text Editor” section on
page 2-106.

Find

Opens the Find dialog box allowing you to search the active window for specific text. See
the “Setting Preferences” section on page 1-71.

Find Next

Finds the next instance of the specific text in the active window. See the “Setting
Preferences” section on page 1-71.

Preferences

Opens the Table Preferences dialog box allowing you to choose the columns to be
displayed in the active application table. See the “Setting Preferences” section on
page 1-71.

View
Show Tool Bar

Displays and hides the Configuration Desktop toolbar by activating and deactivating the
Show Tool Bar check box.

Show Status Bar

Displays and hides the Configuration Desktop status bar by activating and deactivating the
Show Status Bar check box.

Tools
Administration

Applications

Interfaces

Controllers

Displays, configures, and manages user access, permissions, and alarms for the following
administration applications:
•

AAA

•

Alarm Administration

•

User Administration

Displays, configures, and manages traffic tunnels and explicit IP paths for the following
applications:
•

IEP

•

MPLS-TE

Displays, configures, and manages Ethernet, PoS, and common interfaces for the
following Interfaces applications:
•

Common

•

Ethernet

•

PoS

Displays, configures, and manages SONET interfaces. The Controllers application is
SONET.
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Table 2-8

Configuration Desktop Menu Bar Options (continued)

Menu-Bar Options

Task

Policy

Displays, configures, and manages system-wide policy-related rules for the following
Policy applications:

Protocols

•

Access Control Lists

•

Packet Filter

•

QoS

•

Routing Policy

Manages, creates, displays, and edits protocol data and settings on the router for the
following Protocol applications:
•

BGP

•

IS-IS

•

LDP

•

OSPF

•

RSVP

Window
Close

Closes the active application in the Configuration Applications pane.

Close All

Closes all the applications in the Configuration Applications pane.

Cascade

Arranges all the applications in the Configuration Application pane in an overlapping
pattern in which each application title bar is visible.

Minimize All

Minimizes all the application windows in the Configuration Applications pane.
Double-click the minimized application in the Configuration Applications pane to
maximize the applications.

List of Open Windows

Displays up to ten open application windows. The windows are displayed in the
chronological order in which they were opened. Choosing a window from the menu makes
it the active window in the Configuration Applications pane.

Windows

Opens a CWI Windows List dialog box that displays a list of open application windows.
Choosing a window from the dialog box makes it the active window in the Configuration
Applications pane.

Help
Help Desktop

Opens the CWI Online Help. For information on online help, see the Cisco Craft Works
Interface Quick Start Guide.

Configuration Desktop Toolbar
The Configuration Desktop toolbar contains icons, referred to as tools, that provide quick access to
common tasks used in all the configuration applications, allows you to open the Replace Configuration
Editor, and controls the committing of a target configuration to the running configuration.
You can click the tool to choose the task. When the pointer is positioned over the tool, a tooltip appears
describing the function of the tool.
A tool can be enabled or disabled, depending on where you are in the Configuration Desktop window.
A tool appears dimmed when it is not available.

Cisco Craft Works Interface User Interface Guide

2-92

OL-4457-05

Chapter 2

Managing with the Configuration Desktop
Navigating the Configuration Desktop

The Configuration Desktop toolbar contains standard tools and Configuration Controls tools
(see Figure 2-2). All standard tools except Refresh are also available in the Configuration Desktop menu.
The Configuration Controls tools are available only in the toolbar.
Table 2-9 describes the Configuration Desktop toolbar icons.
Table 2-9

Configuration Desktop Toolbar Icons

Icon

Description

Print

Prints data from the currently active application in tabular format. See the
“Setting Preferences” section on page 1-71.

Export

Exports the chosen report to a text (comma-separated or tab-separated) or
HTML file. See the “Exporting Table Data” section on page 1-69.

Find

Opens the Find dialog box allowing you to search the active window for
specific text. See the “Setting Preferences” section on page 1-71.

Find Next

Finds the next instance of the specific text in the active window. See the
“Setting Preferences” section on page 1-71.

Cut

Removes the currently chosen data or text and moves it to the Clipboard
(supported in the Configuration Editor, Replace Configuration Editor, and Text
Editor applications). See the “Cutting, Copying, and Pasting Text in the
Configuration Editor” section on page 3-133, the “Cutting, Copying, and
Pasting Text in the Replace Configuration Editor” section on page 4-142, and
the “Cutting, Copying, and Pasting Text in the Text Editor” section on
page 2-106.

Copy

Copies the currently chosen data or text and moves it to the Clipboard
(supported in the Configuration Editor, Replace Configuration Editor, and Text
Editor applications). See the “Cutting, Copying, and Pasting Text in the
Configuration Editor” section on page 3-133, the “Cutting, Copying, and
Pasting Text in the Replace Configuration Editor” section on page 4-142, and
the “Cutting, Copying, and Pasting Text in the Text Editor” section on
page 2-106.

Paste

Pastes the data or text from the Clipboard into the currently chosen field
(supported in the Configuration Editor, Replace Configuration Editor, and Text
Editor applications). See the “Cutting, Copying, and Pasting Text in the
Configuration Editor” section on page 3-133, the “Cutting, Copying, and
Pasting Text in the Replace Configuration Editor” section on page 4-142, and
the “Cutting, Copying, and Pasting Text in the Text Editor” section on
page 2-106.

Refresh

Refreshes the content in the active window in the Configuration Applications
pane. See the “Refreshing Content” section on page 1-77.

Preferences

Opens the Table Preferences dialog box allowing you to choose the columns
to be displayed in the active application table. See the “Setting Preferences”
section on page 1-71.

Help Contents

Opens the CWI Online Help for the currently active application. For
information on online help, see the Cisco Craft Works Interface Quick Start
Guide.
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Table 2-9

Configuration Desktop Toolbar Icons (continued)

Icon

Description

Replace
Configuration Editor

Opens the Replace Configuration Editor. See Chapter 4, “Configuring with the
Replace Configuration Editor,” for information on the Replace Configuration
Editor.

View Uncommitted
Configuration

Displays all the configuration changes that still need to be committed in CLI1
format. For a procedure on how to display an uncommitted configuration, see
the Cisco Craft Works Interface Configuration Guide.

1. CLI = command-line interface

Configuration Controls Toolbar Icons
The configuration control tools are used to manage the configuration on the router. You can lock and
unlock the running configuration on the router, load, save, clear, commit, or roll back a configuration.
See the “Common Activities in Configuration Desktop Applications” section on page 2-107 for
procedures.
The Configuration Desktop toolbar contains the configuration control tools as described in Table 2-10.
Table 2-10 Definitions for the Configuration Controls

Icon

Definition

Lock/Unlock

Locks the running configuration on the router to prevent other users from committing
a configuration while you are making changes. The status of the Lock/Unlock button
indicates the current status.

Load

Allows you to enter the path and name of a configuration file to load. The Load
button allows you to load a target configuration buffer that was previously saved on
the router into the current target configuration. The loaded configuration merges with
the current target configuration, with the items in the saved target buffer taking
precedence over any items already in the target configuration. All active
configuration applications are closed.

Save

Saves uncommitted configuration changes to a specified location on the router.

Commit

Commits the target configuration to the running configuration running on the router.
The Commit button is enabled only after the parameters set in the configuration
applications have been applied. Any errors resulting from a commit command are
displayed in a read-only text window in CLI format.

Clear

Clears the target configuration and closes all active configuration applications.

Rollback

Contains a list of available rollback checkpoints saved on the router. A checkpoint is
a previous commit operation. You can choose the checkpoint to which to roll back
the running configuration. The checkpoints provide the usernames, date, and time of
the commit operation.

Application Toolbar
The Application toolbar contains icons, referred to as tools, which represent commonly used tasks in the
configuration application. You can click a tool to choose a task. When the pointer is positioned over the
tool, a tooltip appears describing the function of the tool.
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Figure 2-6

Application Toolbar

1

Add Record

7

Row Paste

2

Clone Record

8

Row Paste Special

3

Clone Special

9

Undo Copy

4

Delete Record

10 Redo Copy

5

Set Defaults

11 Filter Table

6

Row Copy

— —

Table 2-11 describes the tools for the Application toolbar.
Table 2-11 Application Toolbar Definitions

Icon

Description

Add

Adds a blank record to the Application table. See the “Adding Records” section on
page 2-109.

Clone Record

Creates a new row (object) using the attributes of the chosen row. At a minimum, the
key fields must be modified. See the “Cloning Records” section on page 2-110.

Clone Special
Record

Creates a specified number of new rows (objects) using the attributes of the chosen
row. The key field values can be copied, initialized to empty, or automatically
generated, according to the selected algorithm. See the “Cloning Records” section on
page 2-110.

Delete Record

Deletes the chosen record in the Application table. Multiple record selection is
supported. See the “Deleting Records” section on page 2-111.

Set Default

Sets default values for either a chosen field in a record or for a complete record.

Row Copy

Copies the chosen record in the Application table to the Clipboard. Only one record
can be copied to the Clipboard at a time. See the “Copying a Row” section on
page 2-113.

Row Paste

Copies the record in the Clipboard into the chosen row of the Application table. See
the “Pasting a Row” section on page 2-113.

Row Paste
Special

Copies chosen fields from the record in the Clipboard into the chosen row of the
Application table. See the “Pasting a Row” section on page 2-113.

Undo Copy

Undoes the last task in the Configuration Desktop. The tool is available only when
the last task can be undone. See the “Undoing and Redoing the Last Task” section on
page 2-114.

Redo Copy

Redoes a task that was undone using the Undo tool. See the “Undoing and Redoing
the Last Task” section on page 2-114.

Filter Table

Opens the Filter dialog box, which allows you to filter the records in the Application
table. See the “Filtering Records” section on page 1-68.
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Configuration Desktop Application Buttons
The Configuration Desktop application buttons allow you to control the applying or canceling of changes
in the active application. You can apply configuration information to the target configuration and keep
the application open or close the application, or close the application without applying any changes or
additions made to the configuration.
Table 2-12 describes the Configuration Desktop application buttons that are used in all Application
panes.
Table 2-12 Configuration Desktop Application Buttons

Button

Description

OK

Validates the fields in the application, then applies the changes to the target configuration.
When the changes have been applied to the router, the application closes. An error is
displayed if the changes cannot be applied, and the application does not close.

Cancel

Closes the application without applying any changes or additions made since the
application was opened or since the Apply button was last clicked. A Proceed dialog box
(see Figure 2-17) is displayed to ensure that you want to close the application without
saving changes.

Apply

Validates the fields in the application, then applies the changes to the target configuration.
The application remains open when Apply is chosen, which allows you to continue using
the application.

Configuration Desktop Status Bar
The Configuration Desktop status bar provides information on the status of the Configuration Desktop.
The NE Connectivity Status icon is on the right side of the status bar (see Figure 2-2). The left side of
the status bar may contain a progress message when the application is processing a task.
The NE Connectivity Status icon shows the connection status between the CWI and the management
agent on the router. The icon shows a green connection line if the CWI is connected to the management
agent and a red connection line if the CWI has a broken connection with the management agent.

Configuration Change Handling
Configuration change handling allows you to be notified of a change to the configuration of a router and
allows you to view the new configuration. See the “Managing with Text Editor” section on page 2-101
for information on Text Editor features and procedures.
If another user commits a configuration on the router you are logged in to, a dialog box informs you of
the change (see Figure 2-7).
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Figure 2-7

Configuration Change Dialog Box

If you click Yes, the Text Editor displays the configuration committed by the user (see Figure 2-8).
Figure 2-8

Configuration Changes from Commit Text Editor

The committed configuration is displayed in a new window (see Figure 2-9).
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Figure 2-9

Configuration Changes from Commit Text Editor

Note

The managed router must be configured to send notifications to a specified client for configuration
change notifications be enabled. See the “Setting the Minimum Router Configuration” section in the
Cisco Craft Works Interface Quick Start Guide for information on configuring the router to send
notifications to a specified client.

Note

The Telnet/SSH server must be enabled before you can manage a router using certain CWI features.
These features include the Telnet/SSH application, the Troubleshooter application, setting character
displays in the Rack View application, and viewing committed configuration changes using the
Configuration Change dialog box. See the Cisco IOS XR Getting Started Guide for information on
enabling the Telnet/SSH server.

Validating the Required Fields
All required fields in the application pane or table contain data. In the Application pane, required fields
are indicated with an asterisk (*) in front of the field name. These fields must have values entered before
the OK or Apply button is clicked in the application; otherwise, a dialog box is displayed indicating that
the required fields need values entered.
Field validation ensures that the data entered into the fields in the application pane or table is valid.
Table 2-13 lists the types of field validation in the configuration applications.
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Table 2-13 Types of Field Validation

Type

Description

Field value

If the value entered in the Application pane or Application table is invalid, when Tab
is pressed or the pointer is moved to another field (the field loses focus), an error
dialog box appears indicating that the field contains invalid data.

Required value

If a required value is missing from an Application pane or Application table and OK
or Apply is clicked in the configuration application, a Client Side Error List dialog
box appears listing the errors in the application. See the “Error Handling” section
on page 2-99 for information on the Client Side Error List dialog box.

Default value

If a value is entered that is within the allowed range but is not the default value, the
field is highlighted green.

Value range

If a value is entered that is not within the allowed range, an Error dialog box
appears.

Entry format

If an entry does not conform to the required format, an Error dialog box appears.

Error Handling
Error handling checks that the data entered into fields in the configuration application is valid. The data
is first checked on the client side and, if there are no errors, the data is checked on the server side.
These sections describe the types of error handling provided by the CWI and router:
•

Client-Side Error Handling, page 2-99

•

Server-Side Error Handling, page 2-100

Client-Side Error Handling
Client-side error handling validates user input before sending the new input to the target configuration.
Client-side error handling is initiated when you click the OK or Apply button in the Application pane.
The validation includes checks for missing required fields, duplicate keys, field validation, and value
validation.
Any errors detected during validation appear in a Client Side Error List dialog box (see Figure 2-10).
When an item in the Client Side List dialog box is chosen, the item changes to italicized and the
appropriate row in the Application table becomes active, allowing you to make the required changes.
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Figure 2-10 Client Side Error List Dialog Box

Server-Side Error Handling
Server-side error handling checks the target configuration sent to the router. Error handling includes
checks for connection and configuration errors. You can initiate server-side error handling from the
following methods:
•

After the client-side error handling is completed, you can click the OK or Apply button in the
Application pane. See the “Configuration Desktop Application Buttons” section on page 2-96 for
information on the OK and Apply buttons. If there are errors, they appear in a Server-Side Error List
dialog box with recommendations on how to resolve the errors (see Figure 2-11).

Figure 2-11 Server Side Error List Dialog Box

Cisco Craft Works Interface User Interface Guide

2-100

OL-4457-05

Chapter 2

Managing with the Configuration Desktop
Managing with Text Editor

•

When a configuration commit is requested, you can click the Commit icon on the Configuration
Desktop toolbar (see Figure 2-2).
– If the configuration was set using the configuration applications and there are errors, a Commit

Error List dialog box appears with a list of the errors and recommendations on how to resolve
the errors (see Figure 2-9). The commit has failed.
– If the configuration was set using the Configuration Editor and there are errors, the errors appear

in a Commit Errors text editor in CLI format (see Figure 2-12). See the “Managing with Text
Editor” section on page 2-101 for information on the Text Editor. The commit has failed.

Note

If a commit fails, the target configuration is not affected (the target configuration buffer is
not cleared), allowing you to modify the target configuration then recommit it.

Figure 2-12 Commit Errors in CLI Format

Managing with Text Editor
A general Text Editor application is available in the Configuration Desktop and displays configuration
information in CLI format (see Figure 2-13).
These sections describe how to manage the Text Editor:
•

Text Editor Overview, page 2-102

•

Text Editor Menu Bar Options, page 2-103

•

Launching the Text Editor, page 2-103

•

Loading a Configuration in the Text Editor, page 2-104

•

Undoing and Redoing the Last Task in the Text Editor, page 2-105
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•

Printing the Contents of the Text Editor, page 2-105

•

Saving the Content of the Text Editor, page 2-106

•

Cutting, Copying, and Pasting Text in the Text Editor, page 2-106

Text Editor Overview
The general Text Editor application (see Figure 2-13) provides features that are common in all text
editors in the CWI. You can perform the following common functions:
•

Use CLI keyword highlighting

•

Load the saved text

•

Save the contents of the Text Editor

•

Print the contents of the Text Editor

•

Cut, copy, and paste in the Text Editor

•

Copy text into the Text Editor

•

Undo and redo the last task

The Configuration Editor and Replace Configuration Editor are similar to the general Text Editor
application.
Figure 2-13 Text Editor
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Related Topics
•

Chapter 3, “Configuring with the Configuration Editor”

•

Chapter 4, “Configuring with the Replace Configuration Editor”

Text Editor Menu Bar Options
The Text Editor menu bar provides a list of options available in the Text Editor as listed in Table 2-14.
Table 2-14 Text Editor Menu Bar Options

Menu-Bar Option

Task

File
Load

Loads a chosen configuration into the Text Editor (available when the Text Editor
is opened using the Configuration Applications icon in the Configuration
Applications Tree). See the “Loading a Configuration in the Text Editor” section
on page 2-104.

Save

Saves the contents of the Text Editor to a text file (*.txt). The first time the Save
option is chosen, a filename and location must be entered. For each subsequent
time, the content is automatically saved to the file and location provided the first
time the Save option was used.
For a procedure, see the “Saving the Content of the Text Editor” section on
page 2-106.

Save As

Saves the contents of the Text Editor to a text file (*.txt). You can enter a new
filename and location each time the Save As option is chosen.
For a procedure, see the “Saving the Content of the Text Editor” section on
page 2-106.

Edit
Undo

Undoes the last task in the Text Editor. See the “Undoing and Redoing the Last
Task in the Text Editor” section on page 2-105.

Redo

Allows you to redo a task that was undone using the Undo tool. See the “Undoing
and Redoing the Last Task in the Text Editor” section on page 2-105.

Launching the Text Editor
To launch the Text Editor, choose one of the following options:
•

Click the Configuration Applications icon in the Configuration Applications Tree. The Text Editor
opens and displays the uncommitted target configuration. For a procedure on how to display an
uncommitted configuration using the Text Editor, see the Cisco Craft Works Interface Configuration
Guide, Chapter 2, Managing Router Configuration with CWI.

•

When there is an automatic configuration change notification from another user logged in to the
same router, see the “Configuration Change Handling” section on page 2-96.

•

When the Configuration Editor or Replace Configuration Editor is used to configure the router and
there is a commit failure, a Commit Errors text editor appears with the errored target configuration
displayed (see Figure 2-14). See Chapter 3, “Configuring with the Configuration Editor,” for
information on configuring the router using the Configuration Editor.

Cisco Craft Works Interface User Interface Guide
OL-4457-05

2-103

Chapter 2

Managing with the Configuration Desktop

Managing with Text Editor

Figure 2-14 Commit Errors Text Editor

Loading a Configuration in the Text Editor
To load a file in the Text Editor from a previously saved text file to load into the Text Editor, perform the
following steps:
Step 1

Choose the Text Editor in the Configuration Applications pane.

Step 2

Choose File > Load. The Open dialog box appears (see Figure 2-15).
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Figure 2-15 Open Dialog Box (Text Editor)

Step 3

Enter a filename in the File Name field.

Step 4

Click Open. The chosen file is loaded into the Text Editor.

Undoing and Redoing the Last Task in the Text Editor
To undo or redo the last task in the Text Editor, perform the following steps:
Step 1

Choose the Text Editor in the Configuration Applications pane.

Step 2

Choose Edit > Undo. Or press Ctrl-Z. If the last task in the Text Editor is undone, the Redo menu option
can be chosen.

Step 3

Choose Edit > Redo. Or press Ctrl-Shift-Z to redo the task removed from the Text Editor using the
Undo menu option. The task is redone into the Text Editor.

Printing the Contents of the Text Editor
To print the contents of the Text Editor, perform the following steps:
Step 1

Choose the Text Editor in the Configuration Applications pane.

Step 2

To open the Print dialog box, choose one of the following options:

Step 3

•

Click the Print icon (see Figure 2-2) in the Configuration Desktop.

•

Choose File > Print.

Click OK. The Text Editor content is printed.
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Saving the Content of the Text Editor
To save the content of the Text Editor, perform the following steps:
Step 1

Choose the Text Editor in the Configuration Applications pane.

Step 2

Choose File > Save or File > Save As. For a definition of the Save option and the Save As option,
see Table 2-14. The Save dialog box is displayed (see Figure 2-16).
Figure 2-16 Save Dialog Box (Text Editor)

Step 3

Enter a filename in the File Name field.

Step 4

Choose a location from the Save In drop-down arrow.

Step 5

Click Save. The content is saved.

Cutting, Copying, and Pasting Text in the Text Editor
You can copy or cut text from the Text Editor to the Clipboard, and paste Clipboard contents into the
Text Editor.
To cut text in the Text Editor, perform the following steps:
Step 1

Choose the Text Editor in the Configuration Applications pane.

Step 2

Select the text to cut in the Text Editor application.
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Step 3

Choose one of the following options:
•

Click the Cut icon (see Figure 2-2).

•

Press Ctrl-X.

The text is copied to the Clipboard and is removed from the Text Editor.

Procedure

To copy text, perform the following steps:
Step 1

Choose the Text Editor in the Configuration Applications pane.

Step 2

Select the text to copy in the Text Editor application.

Step 3

Choose one of the following options:
•

Click the Copy icon (see Figure 2-2).

•

Press Ctrl-C.

The text is copied to the Clipboard.

Procedure

To paste text, perform the following steps:
Step 1

Choose the Text Editor in the Configuration Applications pane.

Step 2

Select the location where you want the copied text in the Text Editor application.

Step 3

Choose one of the following options:
•

Click the Paste icon (see Figure 2-2).

•

Press Ctrl-V.

The text is copied in to the specified location in the Text Editor application.

Common Activities in Configuration Desktop Applications
These sections provide procedures common in the Configuration Desktop:
•

Starting Applications, page 2-108

•

Closing Applications, page 2-108

•

Managing Records, page 2-109

•

Loading Tables (by Request), page 2-116

•

Choosing Tabs, page 2-117

•

Configuration Controls Tasks, page 2-118

Procedures that are specific to an application are provided with the application descriptions. See the
Cisco Craft Works Interface Configuration Applications Reference Guide for application descriptions.
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See the “Common Activities in the CWI Desktop Applications” section on page 1-64 for activities that
are common in the CWI Desktop and the Configuration Desktop.
Related Topics
•

Sorting Columns, page 1-67

•

Moving Columns, page 1-67

•

Filtering Records, page 1-68

•

Removing Record Filtering, page 1-68

•

Finding Text in the Application Table, page 1-69

•

Exporting Table Data, page 1-69

•

Printing Data, page 1-71

•

Setting Preferences, page 1-71

•

Cascading Applications, page 1-74

•

Minimizing Applications, page 1-74

•

Maximizing Applications, page 1-74

•

Choosing Applications in the CWI Application Pane, page 1-74

Starting Applications
To start applications in the Configuration Desktop, choose one of the following options:

Note

All applications, with the exception of the Replace Configuration Editor, can be opened from the
Configuration Desktop menu and the Configuration Applications tree.
•

Choose an application to start from the Configuration Desktop menu. The chosen application is
opened in the Configuration Applications pane (see Figure 2-5).

•

Double-click an object from the Configuration Applications tree. The chosen application is opened
in the Configuration Applications pane (see Figure 2-5).

•

Click the Replace Configuration Editor icon to start the application from the Configuration
Desktop toolbar. Click the View Uncommitted Config icon to display an uncommitted
configuration from the Configuration Desktop toolbar. For more information, see the
Cisco Craft Works Interface Configuration Guide.

Closing Applications
To close applications in the Configuration Applications pane, choose one of the following options:
•

Choose Window > Close to close an application.

•

Click the Close button on the application title bar to close the active application.

•

Choose Window > Close All to open the Proceed dialog box (see Figure 2-17). Click Yes to close
all applications.
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Figure 2-17 Proceed Dialog Box

For definitions of the Close option and Close All option, see Table 2-8.

Managing Records
All configuration applications contain tables with records specific to the application.
These sections describe how to manage records in a table:
•

Adding Records, page 2-109

•

Cloning Records, page 2-110

•

Deleting Records, page 2-111

•

Setting Defaults, page 2-112

•

Copying a Row, page 2-113

•

Pasting a Row, page 2-113

•

Undoing and Redoing the Last Task, page 2-114

•

Moving Records, page 2-114

•

Editing Records, page 2-115

Adding Records
When adding records, the new record is added after the chosen record in the table, or, if no record is
chosen, the new record is added at the end of the table.
To add records in an Application table, perform the following steps:
Step 1

Step 2

Choose an application that supports adding records in the Configuration Applications tree. Choose one
of the following options:
•

Double-click an application from the folder.

•

Right-click an application from the folder and choose Launch.

•

Choose the application from the Tools menu.

Click the Add Record tool (see Figure 2-6). An empty record is added to the Application table.
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Cloning Records
Records can be cloned in an Application table. There are two types of cloning: Clone and Clone Special.
There must be at least one record in the application table to enable the Clone Record.
The Clone Record feature duplicates a record and adds the record after the cloned record in the
Application table.
To clone a record using Clone Record, perform the following steps:
Step 1

Choose an application that supports cloning records in the Configuration Applications tree. Choose one
of the following options:
•

Double-click an application from the folder.

•

Right-click an application from the folder and choose Launch.

•

Choose the application from the Tools menu.

Step 2

Choose a record to clone in the Application table.

Step 3

Click the Clone Record icon (see Figure 2-6). A cloned record is added to the Application table below
the record chosen in Step 2.

Procedure

The Clone Special Record allows you to choose the number of records and the fields to clone. The new
records are added after the cloned record in the table.
To clone a record using Clone Special Record, perform the following steps:
Step 1

Choose an application that supports cloning records in the Configuration Applications tree. Choose one
of the following options:
•

Double-click an application from the folder.

•

Right-click an application from the folder and choose Launch.

•

Choose the application from the Tools menu.

Step 2

Choose a row to clone in the Application table.

Step 3

Click the Clone Special Record icon (see Figure 2-6) to open the Clone Special dialog box
(see Figure 2-18).
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Figure 2-18 Clone Special Dialog Box

Step 4

Enter the number of records to clone in the Number of Cloned Records field. The maximum number of
cloned records is the current application size subtracted from the maximum number of records in the
table.

Step 5

Choose one of the following options:
a.

Click the Copy Key Fields radio button to copy the key fields.

b.

Click the Leave Key Fields Empty radio button to leave the key fields empty.

c.

Click the Generate Key Fields radio button to modify the key fields. For each Key Field, it is
optional to modify any of the following fields:
– From the Selected Algorithms column, click the drop-down arrow and choose an algorithm.
– Double-click the Base Value field and enter a new base value.
– Double-click the Increment Value and enter an increment value.

Step 6

Click OK. The cloned records are added to the Application table below the record chosen in Step 2.

Deleting Records
You can delete the chosen record or multiple records in the Application table. There must be at least one
record in the application table to enable the Delete Record icon.
To delete records, perform the following steps:
Step 1

Step 2

Choose an application that supports deleting records in the Configuration Applications tree. Choose one
of the following options:
•

Double-click an application from the folder.

•

Right-click an application from the folder and choose Launch.

•

Choose the application from the Tools menu.

Choose the records to delete in the Application table from the following options:
•

Click a record to choose one record in the Application table.

•

Press Ctrl and click the desired records to choose random multiple records in the Application table.
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•
Step 3

Press Shift and click the first desired record in the Application table. For serial multiple records,
choose the last desired record.

Click the Delete Record icon.The chosen record or multiple records are deleted from the Application
table.

Setting Defaults
You can set the defaults values for the chosen record in the Application pane. Setting defaults applies to
fields that have default values. Fields with default values are highlighted in green when the value is
changed to a value that is not the default.
To set defaults, perform the following steps:
Step 1

Choose an application that supports setting defaults in the Configuration Applications tree. Choose one
of the following options:
•

Double-click an application from the folder.

•

Right-click an application from the folder and choose Launch.

•

Choose the application from the Tools menu.

Step 2

Choose a record from the Application table.

Step 3

Select the field you want to reset to the default value in the Application pane. If you want to reset all
fields in the record, select any field.

Step 4

Click the Set Default(s) icon (see Figure 2-6) to open the Default dialog box (see Figure 2-19).
Figure 2-19 Default Dialog Box

Step 5

Choose one of the following options to set the defaults:
•

Click All to reset all fields in the active record to the default values.

•

Click Field with focus to reset only the chosen field to the default value.

The default is applied to the records or the chosen field in the record.
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Copying a Row
You can copy the chosen row to the Clipboard. Only one record can be copied at a time. There must be
at least one record in the application table to enable the Copy Record icon.
To copy a row, perform the following steps:
Step 1

Choose an application that supports copying records in the Configuration Applications tree. Choose one
of the following options:
•

Double-click an application from the folder.

•

Right-click an application from the folder and choose Launch.

•

Choose the application from the Tools menu.

Step 2

Choose a record in the Application table.

Step 3

Click the Row Copy icon (see Figure 2-6). The record is copied to the Clipboard, and the Row Paste and
Row Paste Special icons become available.

Pasting a Row
You can paste a copied row into the Application table. There are two types of pasting: Row Paste and
Row Paste Special. There must be a record on the Clipboard for the Clone Record feature to be enabled.
See the “Copying a Row” section on page 2-113 for information on copying a record to the Clipboard.
See the Application Toolbar, page 2-94 for definitions.

Note

Row Paste and Row Paste Special tools do not overwrite key fields. Both tools are available only after
the Row Copy tool has been clicked.
To paste a row using Row Paste, perform the following steps:

Step 1

Ensure that the Row Paste tool is available.

Step 2

Choose a row with values entered in the fields or a new empty row in the Application table.

Step 3

Click the Row Paste icon (see Figure 2-6). The record is copied in the Application table.

Procedure

To paste a row using Row Paste Special, perform the following steps:
Step 1

Ensure that the Row Paste Special tool is available.

Step 2

Choose a row with values entered in the fields or a new empty row in the Application table.

Step 3

Click the Row Paste Special icon (see Figure 2-6) to open the Paste Special dialog box
(see Figure 2-20).
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Figure 2-20 Paste Special Dialog Box

The Pastable Fields pane contains all the fields that can be copied into a new record in the Application
table.
Step 4

Select the fields to paste in a new record in the application table from the following options:
•

Select an item to choose one field in the Pastable Fields pane.

•

Press Ctrl and click the desired items to choose random multiple fields in the Pastable Fields pane.

•

Press Shift and click the first desired item, then choose the last desired item to choose serial multiple
fields in the Pastable Fields pane.

The chosen fields in the Pastable Fields pane are highlighted.
Step 5

Click Add. The chosen fields are moved to the Paste Selected Fields pane.

Step 6

Click OK. The chosen fields are pasted into a new record in the Application table.

Undoing and Redoing the Last Task
You can undo the last task performed in the active application. Click the Undo Copy icon
(see Figure 2-6) to undo the last task. Once the undo task has been performed, the Redo Copy icon
becomes available allowing you to redo the task. Click the Redo icon (see Figure 2-6) to redo the task.

Moving Records
You can move records up or down and in sequence in the Application table. The following applications
support moving records because these applications run matching operations sequentially through the
records:
•

ACL

•

Routing Policy

•

QoS

•

AAA
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To move records, perform the following steps:
Step 1

Choose an application that supports moving records in the Configuration Applications tree. Choose one
of the following options:
•

Double-click an application from the folder.

•

Right-click an application from the folder and choose Launch.

•

Choose the application from the Tools menu.

Step 2

Choose a record in the Application table.

Step 3

Click the blue scroll arrows on the left side of the Application table.
Each time you click the blue scroll arrow, the chosen record moves up or down one row in the
Application table. If the record contains a sequence number, the sequence number is automatically
modified based on location in the table relative to other records in the same list.

Editing Records
You can edit rows in an Application table along with editing single and multiple records.
To edit a single record, perform the following steps:
Step 1

Choose an application that supports editing records in the Configuration Applications tree.Choose one
of the following options:
•

Double-click an application from the folder.

•

Right-click an application from the folder and choose Launch.

•

Choose the application from the Tools menu.

Step 2

Choose a record in the Application table. The Application pane displays the data for the chosen record.

Step 3

Edit the desired fields in the Application pane. Each field is updated in the Application table when you
press Tab or the pointer is moved to another field (the field loses focus).
To edit the table records in the Application table:
a.

Double-click the table cell. Enter the new value.

b.

Press Tab or use the pointer to move between table cells.
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Procedure

Multiple record editing allows you to edit multiple records when the selected fields allow identical
values.

Note

Multiple record editing cannot be done in the Application table but can done in the Application pane.
To edit multiple records, perform the following steps:

Step 1

Step 2

Choose an application that supports editing records in the Configuration Applications tree. Choose one
of the following options:
•

Double-click an application from the folder.

•

Right-click an application from the folder and choose Launch.

•

Choose the application from the Tools menu.

Choose the records to edit in the Application table. Choose one of the following options:
•

Choose one record.

•

Press Ctrl and click the desired records to choose random multiple records.

•

Press Shift and click the first desired record. Select the last desired record to choose serial multiple
records.

The selected records are highlighted, and the Application pane displays the data for the first chosen
record.
Step 3

Edit the desired fields in the Application pane. Each field is updated in the Application table when you
press Tab or the pointer is moved to another field (the field loses focus).

Loading Tables (by Request)
When a configuration application is opened, the existing records (if any) for the application are
displayed in the Application table. For some cases, the loading of data into tables must be triggered
manually. Loading tables by request keeps you from having to wait for data to load if a large amount of
information exists for the table.
To load tables, perform the following steps:
Step 1

Choose an application that supports table loading in the Configuration Applications tree. Choose one of
the following options:
•

Double-click an application from the folder.

•

Right-click an application from the folder and choose Launch.

•

Choose the application from the Tools menu.

An example of an application with the loading tables feature is displayed (see Figure 2-21).
Step 2

Ensure that the application is the active application in the Configuration Applications pane.
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Figure 2-21 Loading Tables Example

Step 3

Click the click here button in the Application table. The records are loaded into the Application table.

Choosing Tabs
Multiple functions are often combined within a single configuration application, and are accessible
through multiple tabs in the Application pane. To display the information in a tab, click the tab. Some
applications also contain subtabs, which are within a tab and contain a subset of functions related to the
tab. An example of a configuration application with tabs and subtabs is displayed in Figure 2-22.
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Figure 2-22 Multiple Tabs in a Configuration Application

1

Tabs

2

Subtabs

Configuration Controls Tasks
The configuration controls provide configuration functionality that is implemented on the router. These
controls are located on the Configuration Desktop toolbar. See the “Configuration Controls Toolbar
Icons” section on page 2-94 for descriptions of the configuration controls.
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These sections describe how to use the configuration controls:
•

Locking and Unlocking a Router, page 2-119

•

Loading a Configuration from the Configuration Desktop, page 2-120

•

Saving a Configuration from the Configuration Desktop, page 2-121

•

Committing a Configuration, page 2-121

•

Clearing a Configuration, page 2-122

•

Rolling Back a Configuration, page 2-123

Locking and Unlocking a Router
A router can be locked or unlocked. Locking the router allows you to commit a configuration to the
router while preventing other users from committing a configuration. Unlocking a router allows all users
to commit a configuration. Locking prevents multiple users from trying to commit a configuration to the
router at the same time.
To lock a router, perform the following steps:
Step 1

Ensure that the router is unlocked. The Lock/Unlock tool indicates an open padlock if the router is
unlocked.

Step 2

Click the Lock icon (see Figure 2-2) in the Configuration Desktop. An Operation Succeeded dialog box
(see Figure 2-23) appears and the router is locked. The Lock/Unlock tool indicates a closed padlock.
Figure 2-23 Operation Succeeded Dialog Box

Step 3

Click OK.

Procedure

Only the user that locked the router can unlock the router.
To unlock a router, perform the following steps:
Step 1

Ensure that the router is locked. The Lock/Unlock tool indicates a closed padlock if a user has locked
the router.

Step 2

Click the Unlock icon (see Figure 2-2) in the Configuration Desktop.

Step 3

An Operation Succeeded dialog box (see Figure 2-24) appears and the router is unlocked. The
Lock/Unlock tool indicates an open padlock.
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Figure 2-24 Operation Succeeded Dialog Box

Step 4

Click OK.

Loading a Configuration from the Configuration Desktop
You can load a configuration file saved on the router. The loaded configuration merges with the target
configuration, with the contents from the loaded configuration file replacing any conflicting information
in the target configuration.

Caution

This procedure automatically closes all open applications in the Configuration Applications pane before
the file is loaded. The loaded configuration file overwrites all current uncommitted configuration
changes.
To load a configuration, perform the following steps:

Step 1

Click the Load icon (see Figure 2-2) in the Configuration Desktop to open the Select file to load dialog
box (see Figure 2-25).
Figure 2-25 Select File to Load Dialog Box

Step 2

Enter the name and location for the file to be loaded in the Filename field.

Step 3

Click OK. The file is loaded.
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Saving a Configuration from the Configuration Desktop
To save a target configuration to the router, perform the following steps:
Step 1

Click the Save icon (see Figure 2-2) in the Configuration Desktop to open the Select file to save dialog
box (see Figure 2-26).
Figure 2-26 Select File to Save Dialog Box

Step 2

Enter the name and location for the file to be saved on the router in the Filename field.

Step 3

Click OK. The target configuration is saved to the router.

Committing a Configuration
You can commit the target configuration to the running configuration on the router.
The Commit tool is available only when some configuration application changes have been applied.
When the configuration applications are used to configure the router, the application icons in the
Configuration Applications tree indicate which applications have uncommitted changes. See the
“Configuration Applications Tree” section on page 2-84 for information on the Configuration
Applications Tree icons.

Note

Uncommitted changes to the target configuration using the configuration applications, Text Editor, or
Replace Configuration Editor are indicated by the Configuration Applications icon in the Configuration
Applications Tree. The icon indicates that there is an uncommitted target configuration.

Note

If the target configuration was created or modified using the Text Editor or the Replace Configuration
Editor, the application icons in the Configuration Applications Tree do not indicate that changes were
made. For example, if alarm administration parameters were modified using the Text Editor application,
the Alarm Administration application icon in the Configuration Application Tree would not indicate that
the application contained an uncommitted configuration, but the Configuration Application icon would
indicate that there is an uncommitted configuration.
To commit a configuration, perform the following steps:

Step 1

Click the Commit icon (see Figure 2-2) in the Configuration Desktop. A commit command is sent to
the router.

Step 2

If the commit is successful, an Operation Succeeded dialog box (see Figure 2-27) is displayed.
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Figure 2-27 Operation Succeeded Dialog Box

If the commit fails, errors are displayed. Any errors resulting from a commit command are displayed in
following formats:
•

If the Configuration Editor was used to configure the router, the errors are displayed in a Commit
Errors text editor in command-line interface (CLI) format (see Figure 2-12). To fix any commit
errors, use the Configuration Editor to modify the configuration accordingly.

•

If the Configuration Applications were used to configure the router, the errors are displayed in a
Commit Error List dialog box (see Figure 2-9). To fix any commit errors, use the Configuration
Applications to modify the configuration accordingly.

See the “Server-Side Error Handling” section on page 2-100 for details on error handling.
Step 3

Click OK. The configuration has been committed.

Clearing a Configuration
To clear the target configuration, perform the following steps:

Caution

Step 1

This procedure automatically closes all open applications in the Configuration Applications pane.
Click the Clear icon (see Figure 2-2) in the Configuration Desktop to open the Continue dialog box
(see Figure 2-28).
Figure 2-28 Continue Dialog Box

Step 2

Click Yes to open the Operation Succeeded dialog box (see Figure 2-29).
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Figure 2-29 Continue Dialog Box

Step 3

Click OK. The target configuration is deleted, and the configuration applications close.

Rolling Back a Configuration
You can roll back the current configuration to a configuration, that was used in a previous commit
operation. Each previous commit operation creates a checkpoint that is stored on the router. You can
choose from the list of checkpoints, which provide the username, date, and time of the commit operation.
To roll back a configuration, perform the following steps:
Step 1

Click the Rollback icon (see Figure 2-2) in the Configuration Desktop.
When the Rollback tool is chosen, a query is done of the list of rollback checkpoints. The available
rollback checkpoints appear in a Select Rollback Point dialog box (see Figure 2-30).
Figure 2-30 Select Rollback Point Dialog Box

Step 2

Choose a rollback checkpoint from the Select Rollback Point dialog box.

Step 3

Click OK. The Operation Succeeded dialog box (see Figure 2-31) appears.
Figure 2-31 Operation Succeeded Dialog Box

Step 4

Click OK. The current configuration is replaced with the checkpoint configuration, and all applications
in the Configuration Applications pane close.
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