Multichassis Link Aggregation Group for L3VPN

TheMultichassis Link Aggregation Group for L3VPN feature provides a solution to prevent the static routes from being advertised on the standby Point of Attachments (PoA) . When a PoA becomes inactive, the static routes are blocked on all Layer 3 port channel subinterfaces. When a PoA becomes active, static routes are allowed on all Layer 3 port channel subinterfaces.

Information about Multichassis Link Aggregation Group for L3VPN

mLACP and L3VPN Static Routes Overview

In a network where L3VPN and Cisco multichassis Link Aggregation Control Protocol (mLACP) features are enabled, and logical port channels have subinterfaces that are not configured with Link Aggregation Group (LAG) or Multichassis-LAG (MC-LAG), the subinterfaces associated with both active and standby PoAs can be in the active (UP) state.

Currently, the static routes are advertised through both active and standby PoAs to the core MPLS, because all port channel subinterfaces are active on both PoAs.

To prevent the static routes being advertised on a standby PoA, when a PoA moves to an inactive state, the static routes are blocked on all Layer 3 port-channel subinterfaces. When a PoA moves to an active state, static routes are allowed on all Layer 3 port-channel subinterfaces.

To block the standby PoA from advertising static routes to MPLS, MC-LAG notifies the platform manager about the change in the PoA state. The platform manager shuts down all subinterfaces associated with the standby PoA.

To allow the static routes on subinterfaces, when a PoA moves to active state, the platform manager activates all subinterfaces associated with the active PoA.

mLACP Redundancy

The mLACP feature provides network resiliency by protecting the network against port, link, and node failures. These failures can be categorized into five types.

  • Failure of the uplink port on the dual-homed device (DHD)

  • Failure of the ethernet link

  • Failure of the downlink port on the active PoA

  • Failure of the active PoA

  • Failure of active PoA when isolated from the core network

When a PoA moves to active or standby redundancy mode, the mLACP triggers a registered call from the platform manager to block or unblock the static routes on subinterfaces that are associated with the port channel of PoA.

How to Configure Multichassis Link Aggregation Group for L3VPN

Enabling MC-LAG for L3VPN

Perform the following task to enable MC-LAG for L3VPN.

configure terminal
  port-channel mc-lag

Configuration Examples for Multichassis Link Aggregation Group for L3VPN

Example: Configuring mLACP VPWS

Provider Edge1 (PE1) configuration


mpls ldp graceful-restart
mpls label protocol ldp
!
redundancy
 mode sso
 interchassis group 1
  member ip 10.0.0.1
  backbone interface Ethernet0/2
  backbone interface Ethernet1/2
  backbone interface Ethernet1/3
  monitor peer bfd
  mlacp node-id 0
!
pseudowire-class mpls-dhd
 encapsulation mpls
 status peer topology dual-homed
!
interface Loopback0
 ip address 192.168.0.1 255.255.0.0
!
interface Port-channel1
 no ip address
 lacp fast-switchover
 lacp max-bundle 1
 mlacp interchassis group 1
 hold-queue 300 in
 service instance 1 ethernet
  encapsulation dot1q 100
  xconnect 172.16.0.1 10 pw-class mpls-dhd
   backup peer 209.165.200.225 10 pw-class mpls-dhd
!
interface Ethernet0/0
 no ip address
 channel-group 1 mode active
!
interface Ethernet1/3
 ip address 10.0.0.200 255.255.255.0
 mpls ip
 bfd interval 50 min_rx 150 multiplier 3

Provider Edge2 (PE2) configuration

mpls ldp graceful-restart
mpls label protocol ldp
!
Redundancy
 mode sso
 interchassis group 1
  member ip 192.168.0.1
  backbone interface Ethernet0/2
  backbone interface Ethernet1/2
  backbone interface Ethernet1/3
  monitor peer bfd
  mlacp node-id 1
!
pseudowire-class mpls-dhd
 encapsulation mpls
 status peer topology dual-homed
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Port-channel1
 no ip address
 lacp fast-switchover
 lacp max-bundle 1
 mlacp lag-priority 40000
 mlacp interchassis group 1
 hold-queue 300 in
 service instance 1 ethernet
  encapsulation dot1q 100
  xconnect 172.16.0.1 10 pw-class mpls-dhd
   backup peer 209.165.200.225 10 pw-class mpls-dhd
!
interface Ethernet1/0
 no ip address
 channel-group 1 mode active
!
interface Ethernet1/3
 ip address 10.0.0.201 255.255.255.0
 mpls ip
 bfd interval 50 min_rx 150 multiplier 3

Example: Configuring mLACP VPLS

PE1 Configuration



mpls ldp graceful-restart
mpls label protocol ldp
!
redundancy
 mode sso
 interchassis group 1
  member ip 10.0.0.1
  backbone interface Ethernet0/2
  monitor peer bfd
  mlacp node-id 0
!
l2 vfi VPLS_200 manual
 vpn id 10
 neighbor 172.16.0.1 encapsulation mpls
 neighbor 209.165.200.225 encapsulation mpls
 neighbor 10.0.0.1
 encapsulation mpls
!
interface Loopback0
 ip address 192.168.0.1 255.255.0.0
!
interface Port-channel1
 no ip address
 lacp fast-switchover
 lacp max-bundle 1
 mlacp interchassis group 1
 service instance 1 ethernet
  encapsulation dot1q 100
  bridge-domain 200
!
interface Ethernet0/0
 no ip address
 channel-group 1 mode active
!
interface Ethernet1/3
 ip address 10.0.0.200 255.255.255.0
 mpls ip
 bfd interval 50 min_rx 150 multiplier 3
!
interface Vlan200
 no ip address
 xconnect vfi VPLS_200

PE2 Configuration


mpls ldp graceful-restart
mpls label protocol ldp
!
redundancy
 interchassis group 1
  member ip 192.168.0.1
  backbone interface Ethernet0/2
  monitor peer bfd
  mlacp node-id 1
!
l2 vfi VPLS1 manual
 vpn id 10
 neighbor 172.16.0.1 encapsulation mpls
 neighbor 209.165.200.225 encapsulation mpls
 neighbor 192.168.0.1 encapsulation mpls
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
port-channel mc-lag 
interface Port-channel1
 no ip address
 lacp fast-switchover
 lacp max-bundle 1
 mlacp lag-priority 40000
 mlacp interchassis group 1
 service instance 1 ethernet
  encapsulation dot1q 100
  bridge-domain 200
!
interface Ethernet1/0
 no ip address
 channel-group 1 mode active
!
interface Ethernet1/3
 ip address 10.0.0.201 255.255.255.0
 mpls ip
 bfd interval 50 min_rx 150 multiplier 3
!
interface Vlan200
 no ip address
 xconnect vfi VPLS_200

Verifying MC-LAG for L3VPN

Verifying Active and Standby POAs

Device# show lacp multichassis port-channel 5
Interface Port-channel5
        Local Configuration:
                Address: 0011.1111.1111
                Channel Group: 5
                State: Active
                LAG State: Up
                Priority: 40033
                Inactive Links: 0
                Total Active Links: 1  
                           Bundled: 1  
                          Selected: 1  
                           Standby: 0  
                        Unselected: 0  

Device# show etherchannel summary
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
5       Po5(RU)         LACP     Gi0/1/0(bndl-sby)
!

Device# show ip route vrf esp11 static
Interface: Port-channel5
                Address: 0011.1111.1111
                Channel Group: 5
                State: Standby
                LAG State: Up
                Priority: 40034
                Inactive Links: 0
                  Total Active Links: 1  
                             Bundled: 0  
                             Selected: 0  
                           Standby: 1  
                           Unselected: 0Info

Feature Information for MC-LAG for L3VPN

Table 1. Feature Information for IPv6 VPN over MPLS

Feature Name

Releases

Feature Information

MC-LAG for L3VPN

Cisco IOS XE Fuji 16.7.1

The MC-LAG for L3VPN feature provides a solution to prevent the static routes being advertised on inactive PoAs.

The following commands were introduced: port-channel mc-lag