
Preinstallation

• Preinstallation Task Flow, on page 1
• Preinstallation Tasks, on page 1

Preinstallation Task Flow
Before you can install Unified CCE and the associated components, set up the network, create virtual machines,
and install and configure third-party software.

The length of the hostname of any Unified CCE server must not exceed 15 characters.Important

SeeTask

Set up Active Directory, on page 1If you are integrating Unified CCE into an
existing corporate network, verify Domain
Controller health. If you are installing into
a new Active Directory domain, install and
configure Active Directory and DNS server.

Set Up Virtual Machines, on page 5Download Open Virtualization Format
(OVA) templates and create virtual
machines.

Set Up Third-Party Software, on page 10Install and configure third-party software.

Preinstallation Tasks

Set up Active Directory
Ensure that you have a completed plan for your domain structure and Active Directory implementation before
you set up your network. For more information, see the Staging Guide for Cisco Unified ICM/Contact Center
Enterprise at
http://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/products-installation-guides-list.html.
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Verify Domain Controller Health
Before you set up the Unified CCEDNS and Active Directory (AD) structure, ensure that your existing domain
controller environment is stable. Install and run the following tools, available from the Microsoft Windows
Server 2012 R2 installation media, in the Tools subfolder:

• dcdiag.exe—Generates a report on AD health, including connectivity, replication, topology integrity,
intersite health, and trust verification. Checks Network Card (NC) head security descriptors, net logon
rights, and roles. Locates the domain controller.

• repadmin.exe—Retrieves the replication status of all /csv >showrepl.csv domain controllers in a
spreadsheet, verifies DNS infrastructure, Kerberos, Windows time service (W32time), remote procedure
call (RPC), and network connectivity.

Ask your network administrator or qualified AD expert (for example, Microsoft Support Services) to evaluate
the resulting reports from these tools.

Run dcdiag.exe

Procedure

Step 1 Choose Start > Run.
Step 2 Type cmd.
Step 3 Press Enter.

A command console opens.

Step 4 At the prompt, enter dcdiag.exe /e /v /f:dcdiag.txt.

If you use the /e option, run dcdiag.exe at the root level. If you do not use the “/e” option, run
dcdiag.exe on each individual domain controller.

Note

The application creates the text file dcdiag.txt in the folder containing dcdiag.exe.

Step 5 Open the text file and note any items that are prefaced with “Warning” or “Error.”
Step 6 Correct all the issues, then rerun dcdiag.exe to ensure that no issues remain.

Run repadmin.exe

Procedure

Step 1 Choose Start > Run.
Step 2 Type cmd.
Step 3 Press Enter.

A command console opens.

Step 4 At the prompt, enter repadmin.exe /showrepl * /csv >showrepl.csv.
Step 5 Open Excel and choose File > Open.
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Depending on your version of Excel, the menu cascades may be slightly different.Note

Step 6 In the “Files of type” section, click Text Files (*.prn;*.txt;*.csv).
Step 7 In the “Look in” section, navigate to showrepl.csv, then click Open.
Step 8 In the Excel spreadsheet, right-click the column heading for showrepl_COLUMNS (column A), then click

Hide.
Step 9 In the Excel spreadsheet, right-click the column heading for Transport Type, then click Hide.
Step 10 Select the row just under the column headings, then choose Windows > Freeze Pane.
Step 11 Click the upper-left corner of the spreadsheet to highlight the entire spreadsheet. Choose Data > Filter >

AutoFilter.
Step 12 In the heading of the Last Success column, click the down arrow, then click Sort Ascending.
Step 13 In the heading of the Source DC column, click the down arrow, then click Custom.

In the Custom AutoFilter dialog box, complete the custom filter as follows:

a. Under Source DC, click does not contain.

b. In the corresponding text box, enter del to filter deleted domain controllers from the spreadsheet.

Step 14 In the heading of the Last Failure column, click the down arrow, then click Custom.

In the Custom AutoFilter dialog box, complete the custom filter as follows:

a. Under Last Failure, click does not equal.

b. In the corresponding text box, enter 0 to filter for only domain controllers that are experiencing failures.

For every domain controller in the forest, the spreadsheet shows the following:

• Source replication partner

• The time that replication last occurred

• The time that the last replication failure occurred for each naming context (directory partition)

Step 15 Use Autofilter in Excel to view the replication health for the following:

• Working domain controllers only

• Failing domain controllers only

• Domain controllers that are the least, or most recent

You can observe the replication partners that replicate successfully.

Step 16 Locate and resolve all errors.
Step 17 Rerun repadmin.exe to ensure that no issues remain.

Add DNS Server to Local Domain Controller
Ensure that the local Active Directory domain controllers have Domain Name Servers installed.
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See the Microsoft documentation at https://docs.microsoft.com/en-us/windows-server/identity/ad-ds/plan/
creating-a-dns-infrastructure-design for adding DNS role to Active Directory servers.

If the local domain controllers serve as Forest Root for the domain, see DNS requirement in Staging Guide
for Cisco Unified ICM/Contact Center Enterprise at
http://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/products-installation-guides-list.html
for additional requirements on Forest Root DNS configuration.

Note

Configure Active Directory Sites
Perform the following procedure on the Unified CCE root domain controller:

Procedure

Step 1 Start > Programs > Administrative Tools > AD Sites and Services.
Step 2 Rename the default first site name in accordance with your AD site plan.

a) For a geographically separated Domain Controller, right-click Sites.
b) Select New Site.
c) Enter the site name of the additional domain controller based on your AD site plan.

Step 3 Create subnets for each Domain Controller site:
a) Right-click the Subnets folder and select New Subnet.
b) Enter the subnet address and mask associated with the LAN at the Domain Controller Site.
c) Highlight the Site Name that is associated with that subnet.

Step 4 Expand the Servers folder from the original first site folder.
Step 5 For each server that you must move to a different site, right-click the server name, select Move, and highlight

the Site to which you want to move it.
Step 6 Expand Inter-Site Transport under Sites.

a) Open the IP folder and select DEFAULTIPSITELINK from the right pane.
b) Right-click and select Properties. Ensure that both sites appear as entries in the Sites in this Site Link

window.
c) Change the Replicate Every value to 15 minutes.

Assign Global Catalog and Set Time Source

Before you begin

Use the Administrator account and open command prompt to connect to the Domain Controller with the
PDC (Primary Domain Controller) role. If you have multiple Domain Controllers, use the following command
to determine which one contains the PDC role:
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Procedure

Step 1 Locate your PDC Server. Open the command prompt and enter the following command:netdom/query
fsmo

Step 2 Log in to your PDC Server and open the command prompt as Administrator. Configure the PDC to synchronise
to external sources. Type the following command at the command prompt: w32tm /config
/manualpeerlist:"<NTPServer 1> <NTP Server 2>”

Step 3 Make the Domain Controller a reliable time source for the clients: w32tm /config /reliable:yes.
Step 4 Start the w32time service: net stop w32time && net start w32time. The windows time service

begins synchronizing with the time.

If the Domain Controller does not synchronize time with the external NTP server, check the event
logs (Event Viewer >> System).

Note

Step 5 Check the source Time-Service in Event Viewer for any errors.

Set Up Virtual Machines

Verify Datastores
Before you install the VMs, verify that the datastore is in place. The type of datastore depends on the type of
server on which you deploy the VMs. For example, UCS-B servers use a SAN datastore and UCS-C servers
use DAS datastores.

For more information, see the VMware documentation at https://www.vmware.com/support/pubs/.

For more information, see Virtualization for Unified Contact Center Enterprise at https://www.cisco.com/c/
dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/
virtualization-unified-contact-center-enterprise.html.

Configure RAID for C240 M4SX
The disk array configuration for the C240 M4SX is already set up to match what is required for Unified CCE.
Verify the settings as follows.

Procedure

Using Cisco Integrated Management Controller, check that the following settings are configured correctly:

• Virtual Drive Info: RAID 5 with 5 (Physical Disks) * 4 (Virtual Drives/Datastores)

• Stripe Size: 128KB

• Write Policy: Write Back with BBU

• Read Policy: Read Ahead Always
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For more information regarding RAID configuration for C240 M4SX in Configure RAID with GUI (UCS
C-Series M4 Servers) section, see Cisco Collaboration on Virtual Servers Guide at:
https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/virtual/CHCS_BK_C7C7ED05_00_cisco-collaboration-on-virtual-servers.html.

Configure RAID for C240 M5SX
The disk array configuration for the UCS C240 M5SX is already set up to match the requirements. Verify the
settings as follows:

Procedure

Using Cisco Integrated Management Controller, check that the following settings are configured correctly:

• Virtual Drive Info: RAID 5 with 6 (Physical Disks) * 4 (Virtual Drives or Datastores)

• Stripe Size: 128KB

• Write Policy: Write Back with BBU

• Read Policy: Read Ahead Always

For more information regarding RAID configuration for C240 M5SX, see the Installation and Configuration
section of the Cisco Collaboration on Virtual Servers Guide at:

https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/virtual/chcs_b_
cisco-collaboration-on-virtual-servers.html

Download Unified CCE OVA Files
The Unified CCE Open Virtualization Format (OVA) files define the basic structure of the corresponding
VMs that are created. The structure definition includes the CPU, RAM, disk space, reservation for CPU, and
reservation for memory.

Before you begin

You must have a valid service contract associated with your Cisco.com profile.

Procedure

Step 1 Go to the Unified CCE Download Software page on Cisco.com.
Step 2 Click Download to download and save the appropriate OVA file to your local hard drive. When you create

VMs, you select the OVA required for the application.

Create a Virtual Machine from the OVA
To create virtual machines (VMs) from the OVA files, complete the following procedure.
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ECE requires a second virtual hard drive on its VM. The OVA creates one virtual hard drive. Create a second
hard drive of an appropriate size for your solution requirements.

Note

Procedure

Step 1 Select the Host in the vSphere client.
Step 2 Choose File > Deploy OVF Template.
Step 3 Browse to the location on your local drive where you stored the OVA. Click Open to select the file. Click

Next.

Step 4 Click Next at the OVF Template Details page.
Step 5 Enter the virtual machine name. It cannot contain spaces or special characters. Enter a maximum of 32

characters. Click Next.
Step 6 On the Name and Location page, enter a name of your choice in the Name field. Click Next.

After the VM is created, you cannot rename it.Important

Step 7 On the Deployment Configuration page, select the applicable configuration from the drop-down list. Click
Next.

Step 8 Choose a data store on which to deploy the new virtual machine. Click Next.

For each datastore, the following tables describe the RAID group, the ESXi Host, and the virtual machines
for the C240 M4SX and the C240 M5SX servers.

RAID configuration for the C240 M4SX and C240 M5SX

Virtual MachinesESXi HostVM DatastoreRAID Group

ESXi operating system

Unified CCE Rogger, Side A

Unified Communications Manager
Publisher

Cisco Finesse Primary

Adatastore 1VD0

Unified CCE AW-HDS-DDS, Side AAdatastore 2VD1

Unified Communications Manager
Subscriber 1

Unified CVP OAMP Server

Unified CVP Server, Side A

Adatastore 3VD2

Unified Intelligence Center Server
Publisher

Unified CCE PG, Side A

Adatastore 4VD3
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Virtual MachinesESXi HostVM DatastoreRAID Group

ESXi operating system

Unified CCE Rogger, Side B

Unified Communications Manager
Subscriber 2

Cisco Finesse Secondary

Bdatastore 1VD0

Unified CCE AW-HDS-DDS, Side BBdatastore 2VD1

Unified Customer Voice Portal
Reporting Server (optional)

Unified CVP Server, Side B

Bdatastore 3VD2

Unified Intelligence Center Server
Subscriber

Unified CCE PG, Side B

Enterprise Chat and Email Server
(optional)

Bdatastore 4VD3

Step 9 On the Disk Format page, choose Thick provisioned Eager Zeroed format for the virtual disk format.
Click Next.

Thick provisioned Lazy Zero is also supported, but Thin provisioned is not supported.Note

Step 10 Confirm that the Network Mapping page is correct:
a) Public network adapter to Public network
b) Private network adapter to Private network

Certain VMs do not require a private network connection. The OVAs for those VMs do not create
a second network adapter.

Note

Step 11 Click Finish.

Step 12 At the Successfully Completed message, click Close.

For more information, see Virtualization for Unified Contact Center Enterprise at
http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/
virtualization-unified-contact-center-enterprise.html.

Note

Allocate a Second Virtual Hard Drive
After deploying the OVA files, the second hard drive is no longer automatically created. To create a second
hard drive:
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Procedure

Step 1 Right-click the virtual machine and click Edit Settings.
Step 2 In the Hardware tab, click on Add.

The Add Hardware window appears.

Step 3 You can select the type of device you wish to add. Select Hard Disk, and then click Next.
Step 4 Select the Create a new virtual disk option, and then click Next.
Step 5 In the Capacity section, use the Disk Size box to assign the desired disk space, and then click Next.

Virtual machine templates for Logger, Rogger, AW, and HDS servers do not have a SQL database
drive preprovisioned. The following reference table can be used to assign disk space to the virtual
machine based on the type:

Default Second Disk SizeVirtual Machine Template

500 GBLogger

150 GBRogger

500 GBAW-HDS-DDS

500 GBAW-HDS

500 GBHDS-DDS

You can custom size the SQL database disk space to meet data retention requirements, as calculated
by the Database Estimator tool.

Note

Step 6 On the Disk Provisioning section choose Thick provision Lazy Zeroed format. Click Next.
Step 7 In the VM Options > Advanced Options section, retain the default options and then click Next.
Step 8 In the Ready to Complete section, click Finish to create the hard disk.
Step 9 Click OK to confirm the changes.

The Recent Tasks window at the bottom of the screen displays the progress.

Mount ISO Files
Upload ISO image to data store:

1. Select the host in the vSphere client and click Configuration. Then click Storage in the left panel.

2. Select the datastore that will hold the ISO file.

3. Right click and select Browse datastore.

4. Click the Upload icon and select Upload file.

Preinstallation
9

Preinstallation
Mount ISO Files



5. Browse to the location on your local drive where you saved the ISO file, and upload the ISO to the
datastore.

Mount the ISO image:

1. Right-click the VM in the vSphere client and select Edit virtual machine settings.

2. Click Hardware and select CD|DVD Drive 1.

3. Check Connect at power on (Device status panel upper right).

4. Click the Datastore ISO File radio button and then click Browse.

5. Navigate to the data store where you uploaded the file.

6. Select the ISO file and click OK.

Initialize and Format Secondary Disk
After the second hard disk is created, allocate memory to the hard disk.

Procedure

Step 1 Open the command prompt, and type diskmgmt.msc.
Step 2 Right-click Disk 1, and click Online.
Step 3 After the disk goes online, right-click the disk, and then click Initialize Disk.
Step 4 Select Master Boot Record (MBR) radio button.
Step 5 After the disk is initialized, right-click the disk, and then click Convert to Dynamic Disk.
Step 6 In the Convert to Dynamic Disk window, check the Disk 1 check box to select it, and then click OK.
Step 7 Right click on the unallocated disk space, and click New Simple Volume. The New Simple Volume Wizard

window appears.
Step 8 Click Next and follow the on-screen instructions to create a simple volume on the disk.
Step 9 Click Finish to complete the process of allocating memory to the hard drive.

Set Up Third-Party Software

Install Microsoft Windows Server
Complete the following procedure to install Microsoft Windows Server on the virtual machines deployed.

For information about supported editions, see the Unified CCE Solution Compatibility Matrix at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html

Note
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Procedure

Step 1 Mount the Microsoft Windows Server ISO image to the virtual machine.

Check the Connect at power on check box when mounting the ISO.

For more information, see Mount and Unmount ISO File.

Step 2 Power on the VM.
Step 3 Enter the Language, Time and Currency Format, and Keyboard settings. Click Next.
Step 4 Click Install Now.
Step 5 If prompted, enter the product key for Windows Server and click Next.
Step 6 Select the Desktop Experience option for the Windows Server and click Next.
Step 7 Accept the license terms and click Next.
Step 8 Select Custom: Install Windows only (advanced), select Drive 0 to install Microsoft Windows Server, and

then click Next.

The installation begins. After the installation is complete, the system restarts without prompting.

Step 9 Enter and confirm the password for the administrator account, and then click Finish.
Step 10 Enable Remote Desktop connections as follows:

a) Navigate to Control Panel > System and Security > System.
b) Click Remote Settings.
c) Click the Remote tab.
d) Select the Allow remote connections to this computer radio button. The Remote Desktop Connection

dialog displays a notification that the Remote Desktop Firewall exception is enabled. Click OK.

Step 11 Install VMWare tools. See Install Vmware Tools, on page 12
Step 12 Open the Network and Sharing Center, and in the View your basic network info and set up connections

section, click Ethernet.
Step 13 In the Ethernet Status window, click Properties.
Step 14 In the Ethernet Properties dialog box, configure the network settings and the Domain Name System (DNS)

data:
a) Uncheck Internet Protocol Version 6 (TCP/IPv6).
b) Select Internet Protocol Version 4 (TCP/IPv4) and click Properties.
c) Select Use the following IP Address.
d) Enter the IP address, subnet mask, and default gateway.
e) Select Use the following DNS Server Address.
f) Enter the preferred DNS server address, and click OK.

Step 15 Navigate to Control Panel > System and Security > System. Follow the instructions:
a) ClickChange Settings.
b) In Computer name tab, click Change.
c) Change the name of the computer from the name randomly generated during Microsoft Windows Server

installation. The name does not contain underscores or spaces.
d) Select Domain radio button to change the member from Workgroup to Domain.
e) Enter qualified domain name and click OK.
f) In the Windows security dialog, validate the domain credentials and click OK.
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g) On successful authentication, click OK.
h) Reboot the server and sign in with domain credentials.
Restart your system for the change to take effect.

Step 16 Go to Settings > Update & Security and run Microsoft Windows Update. .

After the update is complete, click Do not enable automatic updates.

Microsoft Windows Server is installed. In addition, Internet Explorer 11 is installed automatically.

If you want to install Unified CCE on a multilingual version of Windows Server, run the Multilingual User
Interface (MUI) language pack. See https://software.cisco.com/download/
release.html?mdfid=268439622&flowid=46046&softwareid=280840583.

If Unified CCE language pack is applied on Chinese Windows OS machine, set the screen resolution to 1600
x 1200.

Note

Set Windows Locale
If theWindows system locale differs from the display language (and therefore also the SQL collation setting),
some characters appear incorrectly in the user interface and are saved incorrectly to the database. For example,
if the system locale is English and an agent works in Spanish, characters such as the acute a do not appear
correctly.

If you use a multilingual version of Microsoft Windows Server, complete this procedure to set the Windows
locale.

Procedure

Step 1 Open Control Panel > Clock, Region and Language.
Step 2 In the Region section, click Change date, time, or number formats.
Step 3 Click the Administrative tab.
Step 4 In the Language for non-Unicode programs section, click Change system locale.
Step 5 In the Region Settings window, select the language that matches the display language.
Step 6 Restart the virtual machine.

Install Vmware Tools
VMware Tools is a suite of utilities that enhance the performance of the virtual machine guest operating
system. It also aids virtual machine management.
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Install VMware Tools for Windows

Procedure

Step 1 From the vSphere Client, right-click the virtual machine, select Power, and click Power On.
Step 2 Click the Summary tab.

In the General section, the VMware Tools field indicates whether VMware Tools are:

• installed and current

• installed and not current

• not installed

Step 3 Click the Console tab to make sure that the guest operating system starts successfully. Log in if prompted.
Step 4 Right-click the virtual machine, select Guest OS, and then click Install/Upgrade VMware Tools. The

Install/Upgrade VMware Tools window appears with the option - Interactive Tools Upgrade and Automatic
Tools Upgrade.
a) To install/upgrade the VMware tools manually, select the Interactive Tools Upgrade option, and click

OK. Follow the on-screen instructions to install/upgrade the VMware tools, and restart the virtual machine
when prompted.

b) To install/upgrade the VMware tools automatically, select the Automatic Tools Upgrade option, and
click OK. This process takes a few minutes to complete, and restart the virtual machine when prompted.

Install VMware Tools for VOS

To install or upgrade VMware Tools using VOS, perform the following steps:

Procedure

Step 1 Ensure that your virtual machine is powered on.
Step 2 Right-click the VM menu. Select Guest > Install / Upgrade VMware tools .
Step 3 Choose the interactive tools update and press OK.
Step 4 Open the console and log in at the command prompt.
Step 5 Enter the command utils vmtools refresh and confirm.

The server automatically reboots twice.
Step 6 After reboot, check the Summary tab for the VM to verify that the VMware Tools version is current. If it is

not current, reboot the VM and check the version again.

The process takes a few minutes. After the process completes, the tools are listed as Running (Current) on
the VM's Summary tab in vSphere.
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Install Microsoft SQL Server
To use the default (two) vDisk design, install Microsoft SQL Server 2014, and store the SQL Server log and
temporary files on the same vDisk as the operating system. If you choose to use more than two virtual disks,
then the tempDB cannot be on the same vDisk as the solution database.

For further information about the database placement and performance tuning the SQL installation, see the
Microsoft documentation.

For information about supported editions, see the Unified CCE Solution Compatibility Matrix at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html.

Note

Before you begin

EnableMicrosoft .NET Framework 3.5 SP1 before installing SQL Server 2014. In theWindows Server, Server
Manager, use the Add Roles and Features Wizard to enable the .NET Framework 3.5 SP1. See the Microsoft
documentation at https://technet.microsoft.com/en-au/library/dn482071.aspx for detailed instructions.

If your computer is not connected to the internet to get the updates, download and install Microsoft .NET
Framework 3.5 SP1 manually.

Note

Procedure

Step 1 Mount the Microsoft SQL Server ISO image to the virtual machine. For more information, see Mount ISO
Files, on page 9.

Step 2 Select Installation in the left pane and then clickNew SQL Server stand-alone installation or add features
to an existing installation. Click OK.

Step 3 On the Product Key page, enter the product key and then click Next.
Step 4 Accept the License Terms and then click Next.
Step 5 Optional: On theMicrosoft Update page, check theUse Microsoft Update to check for updates check box,

and then click Next.

If you do not check the Use Microsoft Update to check for updates option, click Next on the
Product Updates page.

Note

Step 6 On the Install Rules page, click Next.

In this step, the installation program checks to see that your system meets the hardware and software
requirements. If there are any issues, warnings or errors appear in the Status column. Click the links for more
information about the issues.

Step 7 On the Setup Role page, select SQL Server Feature Installation and click Next.
Step 8 On the Feature Selection page, select only the following, and click Next:
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If you intend to use Outbound Option High Availability two-way replication, be sure to select the Replication
feature on this page. For more information about replication, see the Outbound Option Guide for Unified
Contact Center Enterprise.

Step 9 On the Instance Configuration page, select Default Instance and click Next.

Step 10 On the Server Configuration page, click the Services Account tab.
a) Associate the SQL services with the virtual account.

• For the SQL Server Agent service, in the Account Name field, select NT
Service\SQLSERVERAGENT. If you have enabled Outbound Option High Availability, this
account must have the system administrator privilege.

• For the SQL Server Database Engine, in the Account Name field, select NT
Service\MSSQLSERVER.

While you can use the Network or Local Services account instead of the Virtual account, using
the Virtual account provides security.

Note

b) For the remaining services, accept the default values.
c) In the Start Up Type column, for the SQL Server Agent service account, select Automatic from the

list.
d) EnableGrant Perform Volume Maintenance Task privilege to SQL Server Database Engine Service.

ICM Installer automatically enables the Grant Perform Volume Maintenance Task for the
NT service account.If it is not enabled automatically then you must enable Grant Perform
Volume Maintenance Task privilege to SQL Server Database Engine Service manually on
the SQL server.

Note

Step 11 On the Server Configuration page, click the Collation tab.
a) In the Database Engine section, click Customize.
b) Select the Windows Collation designator and sort order radio button.
c) Select the appropriate collation. Typically, you choose the SQL Server collation that supports theWindows

system locale most commonly used by your organization; for example, "Latin1_General" for English.

See the Unified CCE Solution Compatibility Matrix at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/products-device-support-tables-list.html
for details about collations used for other languages.

Note

The database entry is related to the collation that you select. For example, if you set the collation for
Latin1_General, but you select Chinese language at sign-in. When you enter field values in Chinese, the
application displays the unsupported character error, because the database does not support the
characters.

It is critical to select the correct collation setting for the language display on your system. If
you do not select the correct collation during installation, you must uninstall and reinstall
Microsoft SQL Server.

Important

d) Check the Binary check box.
e) Click OK, and then click Next.

Step 12 On the Database Engine Configuration page:
a) On the Server Configuration tab, click the Mixed Mode radio button.
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b) Enter the password for the SQL Server system administrator account, and confirm by reentering it.
c) Click Add Current User to add the user who is installing the SQL Server as an administrator.
d) On theTempDB tab, set the Initial size andAutogrowth for Rogger, Logger, AW-HDS-DDS, AW-HDS,

and HDS-DDS. For information about values for respective components .

For more information about the SQL Server TempDBDatabase and its use, see the Microsoft SQL Server
documentation.

e) Click Next.

Step 13 On the Ready to Install page, click Install.
Step 14 On the Complete page, click Close.
Step 15 Enable Named Pipes and set the sort order as follows:

a) Open the SQL Server Configuration Manager.
b) In the left pane, navigate to SQL Native Client 11.0 Configuration (32bit) > Client Protocols.
c) In the right pane, confirm that Named Pipes is Enabled.
d) Right-click Client Protocols and select Properties.
e) In the Enabled Protocols section of the Client Protocols Properties window, use the arrow buttons to

arrange the protocols in the following order:

1. Named Pipes

2. TCP/IP

f) Check the Enable Shared Memory Protocol and then click OK.
g) In the left pane, navigate to SQL Server Network Configuration > Protocols for MSSQLSERVER.
h) In the right pane, right-click Named Pipes and select Enable.

By default, Microsoft SQL Server dynamically resizes its memory. The SQL Server reserves the
memory based on process demand. The SQL Server frees its memory when other processes request
it, and it raises alerts about the memory monitoring tool.

Cisco supports the Microsoft validation to dynamically manage the SQL Server memory. If your
solution raises too many memory alerts, you can manually limit SQL Server’s memory usage. Set
the maximum and minimum limit of the SQLmemory using themaximum memory usage settings
in the SQL Server Properties menu.

For more information about the SQL Server memory settings and its use, see the Microsoft SQL
Server documentation.

Note

Step 16 Set the SQL Server's default language to English as follows:
a) Launch SQL Server Management Studio.
b) In the left pane, right-click the server and select Properties.
c) Click Advanced.
d) In the Miscellaneous section, set the Default Language to English.
e) Click OK.

Set the SQL Server default language to English because Cisco Unified Contact Center Enterprise
requires a US date format (MDY). Many European languages use the European date format (DMY)
instead. This mismatch causes queries such as select * from table where date = '2012-04-08

00:00:00' to return data for the wrong date. Handle localization in the client application, such as
Cisco Unified Intelligence Center.

Important
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Step 17 Restart the SQL Server service as follows:
a) Navigate to the Windows Services tool.
b) Right-click SQL Server (MSSQLSERVER) and click Stop.
c) Right-click SQL Server (MSSQLSERVER) and click Start.

Step 18 Ensure that the SQL Server Browser is started, as follows:
a) Navigate to the Windows Services tool.
b) Navigate to the SQL Server Browser.
c) Right-click to open the Properties window.
d) Enable the service, change the startup type to Automatic, and click Apply.
e) To start the service, click Start, and then click OK.

What to do next

Do not change the SQL port number. Retain the default port numbers as 1433 for TCP and 1434 for UDP
connections. In case you change the port numbers, the applications like CCEAdmin will not work.

Caution

Set Users as System Administrators

Any users who are involved in installing or upgrading a Unified ICM/CCE solution must be added as part of
SQL Server Security login and associated with the System Administrator role. Complete the following steps
to set a user as a System Administrator:

Procedure

Step 1 Open the Microsoft SQL Server Management Studio using the System Administrator login credentials.
Step 2 In the Object Explorer pane, click the Security folder.

The Security folder expands.

Step 3 Right-click the Logins folder, and then click New Login.

The Login-New view appears.

Step 4 In theLogin name field, enter the Domain login name of the user whom you want to associate with the System
Administrator role.

Use the following format:

<domain>\<username>

Step 5 In the Object Explorer pane, click the Server Roles folder.

The Server Roles view appears.

Step 6 Check the sysadmin check box.

This step is mandatory.Note
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System administrator is a predefined fixed server-level role in the Microsoft SQL Server. The system
administrator performs operations on a site-level. System administrators manage jobs, role definitions, and
shared schedules that are used to run reports.

You must be a system administrator to create, modify, and delete individual records in the Configuration
Manager tool.

For details about the sysadmin role, see the Microsoft SQL documentation.

Step 7 Click OK.

The user is now a part of the SQL Security login and is also associated with the System Administrator role.

Increase Database and Log File Size
Use the Microsoft SQL Server Management Studio to increase the database and log sizes.

For more information, see the corresponding Microsoft documentation.

For the Tempdb, follow these guidelines:

• For Data Files:

• Set the Space Allocated to 1400 MB.

• Set Automatically grow files to 100MB.

• Set Unlimited file size.

• For Transaction Log Files, follow these guidelines:

• Set the Space Allocated to 400 MB.

• Set Automatically grow files to 10%.

• Set Unlimited file size.

• In the Options page, ensure that the following options are set to False: ANSI NULL Enabled,
Recursive triggers Enabled, Auto close, Auto shrink and Quoted identifiers Enabled.

Install Antivirus Software
For details about supported anitvirus softwares, see Unified CCE Solution Compatibility Matrix, see
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html

Use your antivirus vendor's product documentation for installation instructions, and adhere to the following:

• Update antivirus software manually. Do not enable automatic updates.

• To allow required access to installation program files or folders, perform file-blocking exclusions in the
antivirus product file-and-folder protection rules. For example, to create the exclusions in McAfee
VirusScan:

1. Open the VirusScan console.

2. Right-click Access Protection and select Properties.
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3. In the Anti-virus Standard Protection category, make sure that the rule Prevent IRC communication
is unchecked in the Block column.

• Be aware that in the firewall component of Symantec Endpoint Protection 12.1, the Network Threat
Protection feature must be disabled. The feature is enabled by default. When the feature is enabled, both
sides of a redundant router come up in stand-alone mode which blocks communication between each
side of the router pair. This blocking affects all deployment types.

If you retain the default (enabled) and start serviceson side A and B of the router, the following Symantec
message appears in the system tray: “The client will block traffic from IP address [side A router address]
for the next 600 seconds.” The same message is also written to the security login client management.
The Symantec Network Threat Protection traffic log indicates that a default firewall rule called “Block_all”
was dynamically enabled. The router logs show that both sides of the router came up in stand-alone
mode.

• The firewall component of Trend Micro Deep Security blocks communication between each side of the
Router/PG.

If you retain the default (enabled) and start service on side A and B you can see a new deny event logged
in Trend Micro Manager > Events> Firewall Events.

To resolve the issue, disable the Trend Micro firewall policy or add a new firewall exception for that
particular policy.

To resolve the issue, disable the Symantec firewall on all Unifed CCE boxes and restart the services.

If you are using a managed client, perform the following steps:

1. Launch Symantec Endpoint Protection Manager.

2. Click Policies.

3. Right-click the firewall policy that you want to disable, and then select Edit.

4. Uncheck the check mark next to the policy to disable it.

5. Click OK to confirm.

If you are using an unmanaged client, perform the following steps:

1. Double-click the Symantec icon in the system tray and select Change Settings.

2. Configure settings for Network Threat Protection and uncheck the Enable Firewall check box at
the top of the Firewall tab.

Install .NET Framework 4.5.2
The Unified CCE installation or upgrade runs faster if .NET Framework 4.5.2 or later version is pre-installed.

If the appropriate version of the .NET Framework is not installed, the Unified CCE installer installs it.
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