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Using the Cisco Modeling Labs Client Overview
The Cisco Modeling Labs client is a cross-platform, point-and-click GUI that simplifies topology creation
and initial device configurations and permits access to the Cisco Modeling Labs server. You can interact
directly with your running simulations from this GUI. Additionally, the Cisco Modeling Labs client provides
the functionality to generate default router configurations before simulating your topology.

This chapter introduces the main areas and capabilities of the Cisco Modeling Labs client.

Navigating Within the Cisco Modeling Labs Client
This section describes the functionality of the Cisco Modeling Labs client, which comprises a workbench
containing a menu bar, a toolbar, multiple editors, multiple perspectives, and multiple views.

• Menu Bar: References all the actions that can be performed when using the CiscoModeling Labs client.
Figure 1: Menu Bar

• Cisco Modeling Labs Client Perspectives: Identifies the Design and Simulation perspectives, each of
which is associated with an initial set of views and editors in your workbench.
Figure 2: Perspectives

• From theDesign perspective, you can design your network topology, build the node configurations,
and check routing protocols. The Design perspective is the default perspective if you are launching
the Cisco Modeling Labs client for the first time.
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• From the Simulation perspective, you can enable devices and modify configurations to run the
simulations. When the nodes in your topology are fully initialized, you can connect to the consoles
as you would connect to a router console.

• Cisco Modeling Labs Client Views: Provides alternative presentations of your topology and methods
for navigating the information in your workbench.
Figure 3: Views

• Cisco Modeling Labs Client Layout: Enables you to personalize your workbench, allowing you to
rearrange, resize, reset, and move between views.

Menu Bar
The menu bar provides access to the complete list of actions that are possible in the Cisco Modeling Labs
client.

Importing a Topology File

Step 1 From the menu bar, choose File > Import.
The Import dialog box appears.

Step 2 From the drop-down list, choose Topology > Import Topology file from File System, and click Next.
Step 3 Click Browse to locate the applicable .virl file.
Step 4 In the right pane, check the check box for the applicable .virl file.
Step 5 Click Finish to import the topology file.

Using the Cisco Modeling Labs Client
2

Using the Cisco Modeling Labs Client
Menu Bar



Exporting a Topology File

Step 1 From the menu bar, choose File > Export.

To export a topology file, it must be open on the canvas of the Topology Editor.Note

The Export dialog box appears.
Step 2 From the drop-down list, choose Topology > Export Topology file to File System, and click Next.
Step 3 Click Browse to select the directory to export the topology file to.
Step 4 Click Finish to export the topology file.

Generate Problem Reports
The Cisco Modeling Labs client provides functionality that allows you to generate problem reports for any
problems encountered in your topology. It is accessible from the menu bar under Help > Generate Problem
Report.

While all options are preselected, you can individually select the information you want to include in the report.

When generating a problem report for your topology, you must have the topology containing the problem
open on the canvas.

Note

DescriptionOption

User interface .log file from the user's workspace.Log File

Current content from the Console view messages. These are messages
from the server in response to AutoNetkit and simulation launch actions.

Consoles' Content

Contents of the currently open topology file in theTopology Editor canvas.Topology Editor Contents

Screenshot showing the state of the user interface when the problem
occurred.

Screenshot of the User Interface

Report of the web services details and errors.Web Services Setting

Any additional information that users can provide to describe the problem.Additional Information

The generated problem report is saved to a .zip file, where you can check the contents before sending it to
Cisco TAC for investigation.

Toolbar
The toolbar is a compilation of icons representing commonly used actions. The toolbar is arranged below the
menu bar and offers the same actions as the menu bar in a single click. The following table outlines the actions
that can be performed using the Cisco Modeling Labs client toolbar.
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Cisco Modeling Labs Client Components
The three main components of the Cisco Modeling Labs client are described in the following sections:

• Cisco Modeling Labs Client Perspectives, on page 5

•

Cisco Modeling Labs Client Topology Editor
The Topology Editor is a visual component within the Cisco Modeling Labs client. The Topology Editor
shows the entire topology (or sites) and it comprises the Topology Palette view and the canvas.

The Topology Editor allows you to:

• Add, move, group, rename, delete nodes, and sites on the canvas, or change the properties.
• Create or remove connections between nodes.

Cisco Modeling Labs Client Node Icons
The node icons used in the Cisco Modeling Labs client have been updated, as shown in the following figure:
Figure 4: Updated Node Icons

Cisco Modeling Labs Client Unified Editor
This release of the Cisco Modeling Labs client provides the ability to see the interfaces associated with a
node, directly in the Design or Simulation perspectives without needing to open a new perspective.

The Node Editor available in previous versions of the Cisco Modeling Labs client has been retired.Note

Double-clicking a node expands its presentation to show the interfaces and connection mappings.
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Figure 5: Expanded Nodes with Interfaces Displayed

Double-clicking again hides the node interfaces. The View/Expand All/Collapse All menu option can be
used to expand and collapse all nodes in your topology.
Figure 6: View All Menu Option

Cisco Modeling Labs Client Perspectives
A perspective defines the initial set and layout of views and editors in the workbench. The Cisco Modeling
Labs client provides two perspectives. However, you can customize your own user-defined perspectives for
use, which can be saved or deleted as needed.

The two perspectives provided in the Cisco Modeling Labs client are Design and Simulation.

• Design: Allows you to create and design your topologies, for example, adding devices and defining
interfaces and adding connections to devices within your network. If you are using the Cisco Modeling
Labs client for the first time, the Design perspective opens by default.

• Simulation: Shows running project simulation(s). The simulation’s nodes are listed with their operational
state. The Simulation perspective will also present the live-canvas display of the running topology.
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TheDesign and Simulation perspectives that are built into the Cisco Modeling Labs client cannot be deleted.Note

One or more perspectives can exist in a single workspace. If multiple perspectives are opened at the same
time, you can choose whether to layer them or open them in a separate workspace.

Working with Perspectives
You can manage the various perspectives defined in the workbench by choosing File > Preferences >
General > Perspectives.

The following table describes the Perspectives options:

Table 1: Perspectives Options

DescriptionOption

Defines whether a new perspective opens in the current workbench or opens in
a new window. By default, a new perspective opens in the current workbench.

Open a new perspective

Defines whether a new view opens within the current perspective or opens
docked beside the current perspective (fast view). By default, a new view opens
within the current perspective.

Open a new view

Defines perspective behavior when a new project is created. By default, a new
project opens the perspective in the same workbench.

New project options

The following table describes the Available perspectives options:

Table 2: Available Perspectives Options

DescriptionOption

Sets the selected perspective as the default perspective.Make Default

Resets the definition of the selected perspective to the default configuration. This option
is only applicable to system-defined perspectives.

Revert

Deletes the selected perspective. This option is only applicable to user-defined
perspectives. (System-defined perspectives cannot be deleted.)

Delete

Customize Perspectives
Cisco Modeling Labs provides two perspectives for use in the workspace: the Design perspective and the
Simulation perspective. These perspectives display various views and settings that cannot be changed, nor
can they be deleted from the Cisco Modeling Labs client. You can, however, customize additional Design
and Simulation perspectives for your specific needs.

From the View menu, you can open additional views and arrange them in your perspective. The views can
be arranged by dragging them around the workspace. When finished, you can save the perspective.

Right-click the applicable perspective tab to open the context menu, and then click Show Text. The Design
perspective and the Simulation perspective buttons will be displayed as text labels instead of icons only.

Note
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Step 1 Open the Design perspective or Simulation perspective in your workspace.

Use this as an initial template from which to create a customized perspective.

Step 2 To add new views, chooseWindow > Show View > Other and the Show View dialog box is displayed listing all views
for use.
Views already in use are shown as dimmed in the list.

Step 3 When you are finished arranging the workspace, right-click the applicable perspective button, and then click Save As.
You are prompted to name the new perspective.

Step 4 Enter a name for the perspective and click OK.

Design Perspective
The Design perspective allows you to create and design your topologies. By default, the Design perspective
incorporates the components listed here because they are the most widely used. However, you can customize
a Design perspective to include a different set of components.

• Palette view: Provides the node types, connection types, and sites used to design a topology.

• Projects view: Lists topology projects, subfolders, and files defined from the workbench.

• History view: Lists changes made to a file based on date and time stamp.

• Properties view: Identifies node and interface properties.

• Topology Editor: Develops a network topology.

• Graph Overview: Provides methods for viewing a network topology.

To customize a new Design perspective, choose the desired components from the View menu (for example,
View > Other > Cisco Terminal), and then drag that component view to the desired location within the
workbench. When you are done adding components to the workbench and the component views are laid out
as desired, right-click the Design perspective button, select Save As, and enter a name for the new Design
perspective.

From the Design perspective, right-click the Design icon. This displays the following menu options:

Table 3: Design Perspective Context Menu Options

DescriptionOperation

Saves the customized workbench layout, views, and editors as a new Design
perspective.

Save As
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DescriptionOperation

Resets the current perspective to display the workbench design that was used when
the workbench was first opened.

The Topology Editor is not closed when a perspective is reset. You must
close it manually.

Note

Reset

Closes the current perspective. You can reopen it using the Open Perspective tool,
which is located at the upper right corner of the window.

Close

When selected, shows perspective names in the toolbar instead of icons.

When deselected, shows perspective icons in the toolbar instead of names.

Show Text

Simulation Perspective
The Simulation perspective opens after you launch a simulation; you are prompted to switch to the Simulation
perspective. Switching to the Simulation perspective means that you can now connect to your running nodes
in the Simulations view. By default, it incorporates the canvas, Projects view, Simulations view, Console
view, and Terminal view.

From the Simulation perspective, right-click the Simulation icon. This displays the following menu options:

Table 4: Simulation Perspective Context Menu Options

DescriptionOperation

Saves the current perspective.Save As

Resets the current perspective to its original configuration (when the workbench opened
initially).

Reset

Closes the current perspective. (Reopen it using the Open Perspective tool.)Close

When selected, shows perspective names in the toolbar instead of icons.

When deselected, shows perspective icons in the toolbar instead of names.

Show Text

Cisco Modeling Labs Client Views
Views provide alternativemethods for presenting topology information and navigating within your workbench.
You can drag the view windows and position them anywhere within the workbench. Some views have their
own toolbars, and some of the tools on these toolbars are specific to the views being presented.

The most commonly used views within the Cisco Modeling Labs client are listed in the following table:

Console View
The Console view displays message streams from the Cisco Modeling Labs server after a simulation is
launched. It also displays messages from AutoNetkit when it is used to generate router configurations.

Using the Cisco Modeling Labs Client
8

Using the Cisco Modeling Labs Client
Simulation Perspective



Figure 7: Console View

The Console view toolbar contains the following tools:
Figure 8: Console View Toolbar

Table 5: Available Tools

DescriptionFunctionIcon

Removes all the information from the Console view.Clear Console

Switches scrolling on and off.Scroll Lock

Pins the Console view to the workbench so that
subsequent message streams are shown in another
Console view. The pinned view remains unchanged.

Pin Console

Displays theConsole view for the selected simulation.Display Selected Console

Opens a new Console view.Open Console

Reduces the size of the Console view.Minimize

Increases the size of the Console view.Maximize

When several simulations are running, use the toolbar button Display Selected Console to toggle between
the Console views for the different simulations.

Note

Graph Overview
Graph Overview enables you to view a scaled-down version of your entire topology. A blue rectangle
(representing an overlay) is used to indicate a portion of the topology that is currently being displayed in the
Topology Editor. Using this overlay, you can easily see where the displayed portion sits in relation to the
entire topology.
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The Graph Overview also allows you to navigate around a large topology when it is either too large to fit
into the canvas or is zoomed in and not fully displayed on the canvas.
Figure 9: Graph Overview

From theGraph Overview, click and drag the overlay to pan around your topology. As you drag the overlay,
the corresponding content is reflected in the Topology Editor.

History View
When you create or modify a file, a history of record is maintained and a copy of the modified file is stored
locally. This allows you to replace the current file with a previous version or restore a file that has been deleted.
You can also use theHistory view to compare the changes that were made to the local files. Each file's history,
which is stored locally, is uniquely represented by the date and time at which the file was saved.

Only changes made to topology files (.virl) are retained locally; changes made to projects and folders are not.Note

Figure 10: History View

To view the changed history of a file, in the Projects view, right-click the applicable file and choose Team >
Show Local History.

The History view displays a list of revision times; the most recent revision time is highlighted at the top of
the list.
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If you have a .virl file opened in the workbench, click the History tab to view the list of changes made to the
file.

Note

The History view toolbar contains the following tools:
Figure 11: History View Toolbar

Table 6: Available Tools

DescriptionFunctionIcon

Refreshes the contents of the view, retrieving the latest history
information for a file from the system.

Refresh

Toggles when the History view selection is linked to the
active editor. When this option is selected, changing the active
editor automatically updates the History view selection to
the project, folder, and file being edited.

Link with Editor
and Selection

Pins the view to the workbench and captures a snapshot of
the file history information. New requests for file history are
opened in a new instance of the History view.

Pin this History
View

Sorts all history items by date. Options are:

• Today

• Yesterday

• This Month

• Previous

GroupRevisions by
Date

Collapses all the history items listed in the hierarchical view.Collapse All

Opens the compare editor for file comparison.Compare Mode

Topology Palette View
The Topology Palette view allows you to add devices and interface connections to your topology. Using the
Topology Palette view, you can:
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Figure 12: Topology Palette View

The Topology Palette view is divided into the following categories:

• Tools: Contains the Select andConnect tools. The Select tool allows you to select nodes, Layer 3 external
(SNAT) connections, and Layer 2 external (FLAT) connections on the Topology Editor canvas. The
Connect tool creates connections between node interfaces.

The File > Preferences > Topology Editor setting affects how the nodes and
connections are placed on the canvas. If you check the Revert back to the
palette's default tool check box, you must click a node, connection, or other
object each time you place an object on the canvas. If the Revert back to the
palette's default tool check box is not checked, each time you click the canvas,
an object is placed until you click the Select tool (the default palette tool).

Note
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• Nodes: Contains the node types available for use in topologies. Currently, CiscoModeling Labs, Release
1.5 includes the following:

• Cisco IOSv Software Release 15.6(3)T

• Cisco IOSv Layer 2 Switch Software Release 15.2 (03.2017)

• Cisco IOS XRv Software Release 6.1.3 CCO

• Linux server (Ubuntu 16.04.3 Cloud-init)

• Cisco ASAv Software Release 9.8.2

• Unmanaged Switch

Additional node subtypes can be installed separately. See Release Notes for Cisco
Modeling Labs Release 1.5 for themost up-to-date list of supported virtual images.

Note

• General: Contains the different types of connection functions that are supported for nodes. Options are:

• Layer 3 external connections

• Layer 2 external connections

• External routers

• Annotations: Contains four types of annotations that you can add to your topologies to provide further
information and clarification. These are:

• Rectangle

• Ellipse

• Line

• Text

The Topology Palette view toolbar contains the following tools:
Figure 13: Topology Palette View Toolbar

Table 7: Available Tools

DescriptionToolIcon

Reduces size of Palette view.Minimize

Increases size of Palette view.Maximize
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Problems View
Figure 14: Problems View

The Problems view groups errors and warnings by severity, with the most critical issues listed first.

Double-click the problem marker in the Problems view, which opens the appropriate editor in the Cisco
Modeling Labs client. If the problem relates to an XML file, the XML file opens in a text editor. The problem
is highlighted, allowing you to quickly identify the issue and correct it.
Figure 15: Problem Example

The Problems view toolbar contains the following tools:
Figure 16: Problems View Toolbar
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Table 8: Available Tools

DescriptionFunctionIcon

The View menu has the following options:

• Show: Displays errors and warnings.

• Group By: Groups problems under the headings Type,
Severity, and None. The default is Severity.

• Sort By: Sorts problems under the following headings:

• Description: Details the problem encountered.

• Resource: Displays the name of the .virl file where the
problem has occurred.

• Path: Displays the applicable project folder.

• Location: Displays the location in the .virl file where
the problem has occurred.

• Type: Displays the type of problem, for example, XML
problem.

• New Problems View: Opens a new Problems view on the
workbench.

• Configure Contents: Opens theConfigure Contents dialog
box, where you can addmultiple filters to the Problems view
and enable or disable them. Filters can either be additive or
exclusive. The All Errors/Warnings on Selection filter is
provided by default.

• Configure Columns: Opens theConfigure Columns dialog
box, where you can choose to hide or show specific
information about the problem encountered, as shown in the
Sort By option. Options are:

• Creation Time: Displays the time when the problem
occurred.

• Description, ID: Displays the system-generated ID for
the problem, location, path, resource, and type.

View Menu

Reduces the size of the Problems view.Minimize

Increases the size of the Problems view.Maximize

The Quick Fix Option

Problems displayed in the Problems view are provided with a Quick Fix option if available. A quick fix is
indicated by a light bulb icon that is visible on the marker. When this option is selected, you are presented
with one or more possible fixes.
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We recommend that you useQuick Fix to resolve the errors discovered unless the errors have been deliberately
created for testing purposes.
Figure 17: Quick Fix

To fix a problem:

1. Right-click the line containing the problem, and select Quick Fix.

The Quick Fix dialog box displays a list of possible solutions.
Figure 18: Quick Fix Dialog Box
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2. Select a fix from the list, and then check the check box of any of the resources listed in the Problems
area. You can click Select All to apply the quick fix to all the resources listed. Alternatively, you can click
Deselect All to clear all selections.

3. Click Finish.

Once a problem has been fixed using the Quick Fix option, the action cannot be undone.Note

Projects View
The Projects view provides a hierarchical view of topology projects, folders, and topologies in the workbench.
From here, you can open topologies for editing or select resources for operations, such as exporting.
Figure 19: Projects View

Right-click any topology in the Projects view to open a context menu. In this context menu, you can copy,
move, and create new topology files, view comparison files, and so on.

The Projects view toolbar contains the following tools:
Figure 20: Projects View Toolbar

Table 9: Available Tools

DescriptionFunctionIcon

Collapses the hierarchy of all the resources in the Projects view.Collapse All

Links the Projects view with an active editor. A change to an
active editor automatically updates the Projects view and allows
you to toggle between the two views.

Link with
Editor

Provides options for customizing the content displayed in the
Projects view. Options are:

• Sort by filters

• Sort by content

View Menu

Reduces the size of the Projects view.Minimize

Increases the size of the Projects view.Maximize
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The Projects view displays several icons on the toolbar:

Table 10: Projects View Icons

DescriptionNameIcon

Indicates an open topology project.Topology Project

Indicates an open folder. Folders are created within a
topology project so that topology files can be organized
into separate areas for greater accessibility.

Folder

Indicates a topology file.Topology

Properties View
The Properties view displays the names and properties of nodes and interfaces. If no specific node or interface
is selected, the Properties settings apply globally to all the nodes and interfaces within a topology. If a specific
node or interface is selected, the Properties settings apply to only that node or interface.

The Properties view toolbar contains the following tools:
Figure 21: Properties View Toolbar

Table 11: Available Tools

DescriptionFunctionIcon

Shows the available properties categories.Show Categories

Shows all advanced properties.ShowAdvanced Properties

Restores the default value for the property.Restore Default Value

Pins this properties view to the current selection.Pin to Selection

Displays menu items that allow you to:

• Open a new properties view.

• Pin the properties view to the current selection.

View Menu

Reduces the size of the Properties view.Minimize

Increases the size of the Properties view.Maximize

The properties in the Properties view are discussed in the following sections:

• Node Properties, on page 19
• Topology Properties, on page 27
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Node Properties

When you select a node on the canvas, the properties for that node are displayed in the Properties view.
Figure 22: Node Properties

Under the Node tab, you can perform the following tasks:

Table 12: Node Properties

DescriptionProperty

Specify a name for the node.

Use only alphanumeric and special characters for node names. Node names
must be unique across the entire topology. Duplicate node names cause the build
to fail when the configuration is autogenerated. If a duplicate node name is
defined, a marker is shown in the Problems view. Unicode is not supported for
node names. The use of a period in a node name may cause the node name to
wrap when viewing the hierarchy from the Cisco Modeling Labs server.

Note

Name
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DescriptionProperty

Specify a subtype from the list. Cisco Modeling Labs 1.5 includes the following images
built into the Cisco Modeling Labs client:

• Cisco IOSv Software Release 15.6(3)T

• Cisco IOSv Layer 2 Switch Software Release 15.2 (03.2017)

• Cisco IOS XRv Software Release 6.1.3 CCO

• Linux server (Ubuntu 16.04.3 Cloud-init)

• Cisco ASAv Software Release 9.8.2

• Unmanaged Switch

Additional Cisco virtual images are available for use. However, they must be installed
separately. For a list of supported subtypes, see Release Notes for Cisco Modeling Labs
1.5.

When changing a node subtype after it is initially configured using AutoNetkit,
for example, changing a Cisco IOSv subtype to a Cisco IOS XRv subtype, you
need to revalidate the AutoNetkit properties for the new node subtype.

Note

Subtype

Specify an IPv4 loopback address. The loopback address is added to the router as interface
loopback0. Enter a valid IP address in the correct format.

IPv4

Specify an IPv6 loopback address. The loopback address is added to the router as interface
loopback0. Enter a valid IP address in the correct format.

IPv6

Lists the following ports:

• (C)onsole Port: An optional static TCP port number assigned to the node's console
port. The number must be unique and in the range 4000..32767.

• (A)uxillary Port:An optional static TCP port number assigned to the node's auxillary
port. The number must be unique and in the range 4000..32767.

• (M)onitor Port: An optional static TCP port number assigned to the node's monitor
port. The number must be unique and in the range 4000..32767.

• (E)xtra Port: An optional static TCP port number assigned to the node's extra port.
The number must be unique and in the range 4000..32767.

Static Serial
Ports

Specify a VM image other than the default. Click Browse to choose a valid VM image
from the Select VM Image dialog box.

VM Image

Specify a VM flavor other than the default. Click Browse to choose a valid VM flavor
from the Select VM Flavor dialog box.

VM Flavor

Specify the IPv4 address to be assigned to the management interface of the node. The
address must be in the IPv4 subnet assigned to the Flat or Flat1 network.

Other |
Management
Interface Static
IPv4 Address
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The property Exclude Node from Simulation Launch is set on a per-node basis. When it is enabled for a
node, the node is not launched when the simulation is launched. However, the node can later be started and
configured and automatically join a running simulation.

Under theAutoNetkit tab, when you check theAuto-generate the configuration based on these attributes
check box, the AutoNetkit generates the configuration for your topology when you click Build Initial
Configurations.

Any preexisting configuration for a node is overwritten when you choose Build Initial Configurations from
the toolbar. Uncheck this Auto-generate the configuration based on these attributes check box if you do
not want the router configuration for a node updated by AutoNetkit.

Note

Using the properties listed, you can perform the following tasks:

Table 13: AutoNetkit Properties

DescriptionFieldsProperty

Specify the autonomous system number, which is used to infer IGP and BGP.
This can be any valid integer.

ASNGeneral

Configure an internal routing protocol. Options are:

• Not specified

• OSPF

• ISIS

• EIGRP

• RIP-V2

The default value is Not specified.

IGPIGP

Configure an OSPF area. The default value is 0.OSPF Area

Configure an iBGP role from the list and use it to create an iBGP topology.
Options are:

• Not specified

• Disabled

• Peer

• RR (route reflector)

• HRR(hierarchical route reflector)

• RRC(route reflector client)

The default value is Peer.

iBGP RoleiBGP

Specify the RRC as a name or number. Should be an alphanumeric string.RR Cluster
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DescriptionFieldsProperty

Specify the HRR cluster. Should be an alphanumeric string.HRR Cluster

In this section, users can specify their own configuration text for inclusion
in the appropriate section of the node configuration.

The following fields do not apply to external routers. Note too
that text entered is not syntactically checked, so ensure that the
text is valid.

Note

GlobalCustom
Configuration

Specify a custom configuration for the physical interfaces.Physical
Interfaces

Specify a custom configuration for loopback zero.LoopbackZero

Specify a custom configuration for OSPF.OSPF

Specify a custom configuration for IS-IS.IS-IS

Specify a custom configuration for EIGRP.EIGRP

Specify a custom configuration for RIPv2.RIP-V2

Specify a custom configuration for BGP.BGP

Specify an MPLS VPN name for VRF MPLS VPNs.VRF NameMPLS

Enable Cisco MPLS Label Distribution Protocol. Options are:

• Not specified

• True

• False

The default value is False.

LDP

Enable Cisco MPLS Traffic Engineering. Options are:

• Not specified

• True

• False

The default value is False.

Enable MPLS
TE

This property only applies to external routers.Note

Specify the IPv4 address of the remote router. Enter a valid IP address in the
correct format.

IPv4 AddressExternal
BGP

Specify an IPv6 address of the remote router. Enter a valid IP address in the
correct format.

IPv6 Address

Specify the AS number of the remote router. This is used when trying to
establish a BGP connection to a remote device. The value range is 1 to 65535.

Remote ASN

Using the Cisco Modeling Labs Client
22

Using the Cisco Modeling Labs Client
Node Properties



DescriptionFieldsProperty

Specify the MD5 password to use to secure the BGP session to the remote
router.

MD5Password

Enable BGP multihop. When the remote router is directly adjacent (Layer
3 adjacent), this field is set to False; otherwise it is set to True.

Options are:

• Not specified

• True

• False

The default value is True.

Multihop

Specify a remote loopback IPv4 address.Remote
Loopback IPv4
Address

External
L2TPv3

Specify a local endpoint IPv4 address.Local Endpoint
IPv4 Address

Specify a local endpoint IPv4 netmask.Local Endpoint
IPv4 Netmask

Specify a pseudowire ID.PseudoWire ID

Enable IPv4 GRE tunneling. Options are:

• Not specified

• True

• False

The default value is False.

IPv4 Tunnel
Enabled

GRE
Tunnel

Specify a tunnel IPv4 address to use, which is the IP address of the far-end
node terminating the GRE tunnel itself.

Tunnel IPv4
Address

Specify a tunnel IPv4 netmask to use.Tunnel IPv4
Netmask

Enable IPv6 GRE tunneling. Options are:

• Not specified

• True

• False

The default value is False.

IPv6 Tunnel
Enabled
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DescriptionFieldsProperty

Specify a tunnel IPv6 address to use, which is the IP address of the far-end
node terminating the GRE tunnel itself.

Tunnel IPv6
Address

Specify a tunnel IPv6 netmask to use.Tunnel IPv6
Netmask

Cisco IOS XRv devices set with the ODL Management Group attribute
must be paired with an External Router entity which is configured with the
matching ODL Management Group attribute along with an ODL External
Server IP address. The ODL server may be running on your Cisco Modeling
Labs server or another location and does not need to part of the Cisco
Modeling Labs simulation itself. Connectivity between the simulation and
server must be provided.

OpenDayLight
(ODL)
Management
Group

OpenDayLight
(ODL)

Information displayed under theConfiguration tab depends on whether theAuto-generate the configuration
based on these attributes check box under the AutoNetkit tab is checked.

• When checked, AutoNetkit generates the configuration and displays it under the node's Configuration
tab.

• When unchecked, no configuration information is created for the node. You must configure the node
manually or cut and paste the existing configuration information into this area.

Under theExtensions tab, all the extensions used to generate the configuration are listed with theKey,Value,
and Type attributes.

Cisco Modeling Labs Client Node Menu Options

Cisco Modeling Labs has previously provided users with a series of extensions that could be applied to Cisco
Modeling Labs topologies in order to control aspects such as the Mgmt-IP address assigned to a node or the
static_ip address to be applied to a data interface.

The Cisco Modeling Labs client provides node type appropriate menu options, allowing users to easily set
these values, without the need to the use the extensions function.
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Figure 23: IOSv Node Menu Options

Figure 24: Flat Node Menu Options
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Figure 25: SNAT Node Menu Options

The following table provides an expanded list of the various extensions.

NoteApplies toExampleUseExtension Name

If undefined, 'flat'
is used.

Topology or Flat
connector

host_network=flat1Defines which
Flat network to
use.

host_network

(string)

Single IP for flat
networks, IP
address pair for
SNAT mappings.
Admin rights
required.

Flat and SNAT
objects and nodes
for OOB
management IP

static_ip=172.16.1.200

static_ip=10.254.0.222

Defines a static
IP assignment of
an object.

static_ip

(string)

Ports must be
defined via the
User Workspace
Management
interface.

Flat /SNAT
connector or
virtual machine
instance

bound_port=my_static_portReferences a
pre-configured
Neutron port to
use.

bound_port

(string)

Inserts 'Float IP'
into interface that
has VLAN 100.

Flat/SNAT
attached to Cisco
OS node instance

vlan=100VLAN number
for IP insertion.

vlan

(integer)

Inserts 'Float IP'
into interface that
ends with .100.

Flat/SNAT
attached to Cisco
OS node instance

subinterface=.100Subinterface
name for IP
insertion.

subinterface

(string)

File name is part
of key, which in
the example used
is script.txt.

Cisco
IOSv/IOSvL2
node instance

initial config

script.txt=line 1

line 2

line 3

Create file on
node disk.

initial config

(string)

If undefined, a
pool IP is used.

Topology with
the 'Use an LXC
Management
node' parameter
set to True.
(management_lxc=true)

lxc.host.static_ip=172.16.1.254Defines which IP
the LXC
jumphost should
use.

lxc.host.static_ip

(string)
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NoteApplies toExampleUseExtension Name

The Neutron port
must be on a Flat
network.

Topology with
the 'Use an LXC
Management
node' parameter
set to True.
(management_lxc=true)

lxc.host.bound_port=lxcportReferences a
pre-configured
Neutron port to
be used by the
LXC jumphost.

lxc.host.bound_port

(string)

Topology with
the 'Use an LXC
Management
node' parameter
set to True.
(management_lxc=true)

lxc.host.tcp_port=12345Defines the TCP
port on the Cisco
Modeling Labs
host that the LXC
jumphost is
available on.

lxc.host.tcp_port

(string)

Topology Properties

Under the Topology tab, you can perform the following tasks:

Under the AutoNetkit tab, you can perform the following tasks:

The following table shows the default IP address values used by Cisco Modeling Labs. You can update these
values as required.

The following table shows the default routing protocols used by Cisco Modeling Labs. You can update these
values as required.

Under theExtensions tab, all the extensions used to generate the configuration are listed with theKey,Value,
and Type attributes.

Interface Properties

Under the Interface tab, you can perform the following tasks:

Under theExtensions tab, all the extensions used to generate the configuration are listed with theKey,Value,
and Type attributes.

Connection Properties

When you select a connection on the canvas, the properties of that connection are displayed in the Properties
view.

From the Connection tab, you can associate a line style design with a connection between nodes. Line styles
are visual aids that help you identify the connections used in your topology design.

Search View
To search for text string and files, from the toolbar chooseEdit > Search. The Search dialog box is displayed.
Enter criteria for your search and click Search. The Search view displays the results of the search. A file
search can be based on text strings, regular expressions, and patterns, in addition to whole words and
case-sensitive characters. The scope of a file search can encompass a workspace, selected resources, or projects.
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Text searches are only performed on expressions contained in files with the extension .virl.Note

The Search view also displays the results of a Git search, which can be based on the same criteria as noted
in a file search. However, the scope of a Git search, can encompass a particular message, resource, or
identification number in the code.

Search criteria can be based on either a file or Git. The scope of a search can be general to all the topologies
that are defined on Cisco Modeling Labs client or specific to a particular project or file.
Figure 26: Search View

To use the search functionality, perform the following tasks:

1. From the Cisco Modeling Labs client toolbar, click Search > File.

The Search dialog box appears.

2. In the Containing text field, enter the text string to search for. The Containing text field displays a list
of recently performed searches to select from. Leave this field empty if you want to search for files only.
Check or uncheck the Case sensitive check box depending on whether a case-sensitive search is to be
performed. You can also check the Regular expression check box to enable more powerful searching
capabilities. Check theWhole word check box if you want to search for whole words that are identical
to the text string. Specify the types of files to include in the search in the File name patterns field.

3. Click Choose to open the Select Types dialog box. This dialog box provides a quick way to select from
a list of valid extensions.

4. In the Scope area, specify the files and folders to include in the search. Valid options are:

• The entire workspace.
• The currently selected resources in the workspace.
• A named working set.
• A customized group of files and folders. Use the Customize option to define the type of available
searches from the Search Page Selection dialog box.

5. Click Search to begin your search.

The Search view appears with the results of the search listed. You can click theCancel tool in the Search
view to cancel your search while it is still in progress.

The Search view toolbar contains the following tools:
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Figure 27: Search View Toolbar

Table 14: Available Tools

DescriptionFunctionIcon

Deletes all the highlighted matches from the search results.Remove Selected
Matches

Deletes all the matches from the search results.Remove All
Matches

Expands each item in the Search view.Expand All

Collapses each item in the Search view.Collapse All

Reruns the current search to retrieve previous search results or
to reflect recent changes.

Run the Current
Search Again

Cancels the search currently running.Cancel Current
Search

Browses previously conducted searches and selects a previous
search from the drop-down menu to repeat a previous search.
You can also clear the search history.

Show Previous
Searches

Pins the Search view so that subsequent search results are
displayed in a separate Search view while the pinned view
remains unchanged. This allows for a comparison of results.

Pin the Search
View

Displays the search results as a tree or a list, filters the results
using the Filters option, and sets the overall preferences for
searches using the Preferences option.

View Menu

Reduces the size of the Search view.Minimize

Increases the size of the Search view.Maximize

Simulations View
The Simulations view displays information about all the running simulations, including:

• Name of the user running the simulation
• Name of the topology
• Number of nodes in the running simulation
• Current state of each node

Possible simulation states are:

Table 15: Simulation States

Possible node states are:
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Table 16: Node States

The Simulations view toolbar contains the following tools:
Figure 28: Simulations View Toolbar

Table 17: Available Tools

DescriptionFunctionIcon

Refreshes the list of simulations displayed in the Simulations
view.

Refresh the List

Reduces the size of the Simulations view.Minimize

Increases the size of the Simulations view.Maximize

Topology Options

Node Options

Terminal View
The Terminal view is displayed when you connect via Telnet to a node. Using the Terminal view, you can
communicate with and control the operating system running on the node.
Figure 29: Terminal View

The Terminal view toolbar contains the following tools:
Figure 30: Terminal View Toolbar

Table 18: Available Tools

DescriptionFunctionIcon

Disconnects the terminal connection to the node.Disconnect
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DescriptionFunctionIcon

Sets scrolling on and off.Scroll Lock

Allows you to select a connection from the list of
active terminal connections.

Display SelectedConnections

Closes the Terminal view.Remove Terminal

Allows you to set the font to be used in the terminal,
from the Colors and Fonts dialog box.

You can also access the Colors and
Fonts dialog box by choosing File >
Preferences > General >
Appearance > Colors and Fonts.

Note

Set Terminal Font

Setting Preferences for the Cisco Modeling Labs Client
For the Cisco Modeling Labs client to operate, you must first identify certain setting preferences. These
preferences are available from the menu bar under File > Preferences:

• Node Subtypes Setting, on page 33
• Terminal Setting, on page 34
• Topology Editor Setting, on page 37
• Web Services Setting, on page 37
• AutoNetkit Visualization Setting, on page 37
• Web Browser Setting, on page 31
• Secure Storage Setting, on page 31

These are discussed in the following sections.

Web Browser Setting
This setting allows you to add, remove, or edit installed browsers. The selected browser is used by default
when web pages are opened in the Cisco Modeling Labs client for AutoNetkit visualization.

The available operations for this setting are:

Secure Storage Setting
This setting configures security preferences and encryption requirements for storing system passwords.

The Password tab pools functionality related to the master password life cycle and password providers.

The available options are:
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Table 19: Password Tab Options

DescriptionOption

Clears cached master passwords from memory.Clear Passwords

Lists the currently available password providers. By default, the enabled
provider with the highest priority is used to encrypt the data added to secure
storage. The priority range is from 0 to 10, with 10 being the highest priority.

Data can only be decrypted by the same provider that encrypted
the data. By default, all password providers are enabled. Each
password provider that has been used at least once will have a
master password associated with it. The Details text box provides
information on the master password providers.

Note

Master Password Providers

Changes the master password of the selected password provider.Change Password

Opens the Password Recovery dialog box. Use this option if you have
forgotten the master password and have configured password recovery
questions. The button is disabled if the password recovery setup was cancelled
when the master password was created.

The answers for the password recovery questions must be entered
exactly as they were during the password recovery setup. Answers
are case sensitive, and white space inside answers are relevant.

Note

Recover Password

Restores to the initial default state.Restore Defaults

Applies changes.Apply

The Contents tab displays contents of the default secure storage. Secure storage is organized as a tree, where
nodes represent the context of information and values associated with each node. Selecting a node in the tree
displays a table of values associated with that node. Values stored in a nonencrypted form will be displayed;
the encrypted values will be shown as *********. At the bottom of this tab, you will find the actual file
location used to persist secure storage data. To force the changes to the contents of secure storage to be saved,
click Save.

To delete stored data in order to recover from an error or to reflect a change in the setup, click Delete. This
deletes the contents of secure storage. In some cases, other parts of the applicationmay depend on the contents
of secure storage that you deleted.

To avoid unexpected errors, we recommend that you restart the application after secure storage has been
deleted.

Caution

TheAdvanced tab provides a list of algorithms to further configure secure storage. Changes in the encryption
algorithm are applied only to the data stored after a change. If you have already created a secure storage, you
must first delete it and then recreate it to use the newly selected encryption algorithm.

Resetting the Secure Storage Password
When the Secure Storage feature is used for the first time, it generates a master password that is used to encrypt
the data. In the future, this same master password will be required to retrieve the data from secure storage. If
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the master password becomes unavailable, the Secure Storage feature provides optional support for password
recovery.

Two methods are used to reset the password for the secure storage feature.

Method 1

1. From within Cisco Modeling Labs client, choose File > Preferences > General > Security > Secure
Storage.

2. Click Change Password. The Secure Storage dialog box appears.
3. Click Yes. The Password Recovery dialog box appears.
4. Enter details in both Question fields and provide answers for both questions. Take note of the answers

you provide, as these are treated as secondary passwords.
5. Click OK.

Method 2

If you are unable to access the Cisco Modeling Labs client due to a lost or forgotten password for the secure
storage feature, complete the following steps:

1. Move to the <user-home>/.eclipse/org.eclipse.equinox.security folder.
2. Delete the file secure_storage.
3. Open Cisco Modeling Labs client to provide details for the password for the secure storage feature when

prompted.

Node Subtypes Setting
The available operations for this setting are:

Fetch Node Subtypes from the Cisco Modeling Labs Server
To fetch new node subtypes from the Cisco Modeling Labs server, perform the following tasks:

Step 1 Click File > Preferences > Node Subtypes.
Step 2 Click the Fetch from Server button.

The Confirm dialog box is displayed.
Step 3 Click OK to finish.

The updated list of node subtypes is available for use in the Topology Palette view.

Contact your system administrator if a specific node subtype is missing from the list, as the system administrator
is responsible for adding new node subtypes to the Cisco Modeling Labs server.

Packet Capture Setting
This setting allows you to check for suitable applications that can open .pcap files when you have downloaded
packet captures. The .pcap files can be set to either open automatically or after receiving a prompt.

The available operations for this setting are:
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Table 20: Packet Capture Setting Operations

DescriptionOperation

Check the checkbox box to have the system automatically check for a suitable
application to open the .pcap files.

Check for Applications
Capable of Opening
*.pcap Files

Select the applicable option: Always, Never or Prompt for opening downloaded
.pcap files.

Open Downloaded
*.pcap Files

Restore the settings to their initial default state.Restore Defaults

Apply any changes made.Apply

Simulation Launch Setting
This setting allows you to include the file's path in the system-generated Simulation IDs. You can set the
system to either open the Simulation perspective automatically or after receiving a prompt.

The available operations for this setting are:

Table 21: Simulation Launch Setting Operations

DescriptionOperation

Check this box if you want to include the file's path in the system-generated
Simulation IDs.

Include the File's Path
in Sytem generated
Simulation IDs.

Select the applicable option: Always, Never or Prompt for switching to the
Simulation perspective after a simulation is launched.

Switch to the
Simulation Perspective
after a Simulation is
Launched.

Restore the settings to their initial default state.Restore Defaults

Apply any changes made.Apply

Terminal Setting
This setting allows you to launch an external terminal application, such as SecureCRT or PuTTY, or use the
internal Cisco Modeling Labs client Terminal view in a separate window.
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• If you are using the internal Cisco Modeling Labs Terminal view, the views are visible from both the
Design and Simulation perspectives. However, a detached view is only visible from the perspective in
which it was detached.

• If you are using an external terminal application, you must specify both Telnet and SSH run commands.
You must also ensure that the title format includes the percentage (%) character. Omission of either of
these requirements will impede your ability to save your setting preferences.

• When you specify to use an external terminal via File > Preferences > Terminal > Cisco Terminal and
then Telnet over WebSocket to a VM, the terminal opens internally, not externally as specified.

Note

The available operations for this setting are:

Setting Up an External Terminal

This section outlines the steps involved in setting up an external terminal on Windows and OS X.

Windows

Under File > Preferences > Terminal > Cisco Terminal, update the terminal settings for connection to an
external program. For example, for a PuTTY installation, configure the putty.exe binary file as the terminal
program.

The complete PATH must be specified.Note

Table 22: PuTTY Command-Line Options

DescriptionCommand-Line Option

Opens an SSH connectionssh

Opens a Telnet connectiontelnet

Specifies the host to connect to (the Cisco Modeling Labs client will not allow an
external program to be set without having%h in the command line)

%h

Specifies the host to connect to (the Cisco Modeling Labs client will not allow an
external program to be set without having%p in the command line)

%p

For an external terminal on Windows, the commands to enter are:

• Telnet command: "C:\Program Files (x86)\PuTTY\putty.exe" -telnet %h %p

• SSH command: "C:\Program Files (x86)\PuTTY\putty.exe" -ssh %h %p

The double quotes (" ") must enclose the PATH to allow the use of spaces within the PATH. Select the Use
external terminal application (specified below) radio button to use an external terminal.

Note
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The following table lists other terminal programs that can be used.

Table 23: Additional Terminal Programs

Command to UseConnection TypeTerminal
Program

"C:\Program Files (x86)\NetSarang\Xshell 4\xshell.exe" -url

telnet://%h:%p -newtab %t

TelnetXshell

"C:\Program Files\VanDyke Software\SecureCRT\SecureCRT.exe"

/T /TELNET %h %p

The /T option ensures SecureCRT creates a tab for new
sessions instead of opening a new window. Ensure to
validate the path of the binary.

Note

TelnetSecureCRT

OS X

The procedure is more complex on OSX since command-line parameters are not as easy to use on this platform.
Two additional components are required. These are:

• AppleScript: A program used to start applications and interact with them; some examples are open
windows, start new sessions, paste keyboard input into a session, and so on.

• /usr/bin/osascript: A built-in OS X command-line utility used to execute AppleScript and other OSA
language scripts. This is configured in the Cisco Modeling Labs client; it is essentially the glue between
the Cisco Modeling Labs client and the terminal application.

The following table lists iTerm and the built-in Terminal.app programs that can be used on OS X.

Table 24: Additional Terminal Programs for OS X

Command to UseConnection TypeTerminal
Program

/usr/bin/osascript /Users/your-user-id/iterm.scpt telnet

%h %p %t

TelnetiTerm

/usr/bin/osascript /Users/your-user-id/iterm.scpt telnet

%h %p %t

SSH

/usr/bin/osascript /Users/your-user-id/iterm.scpt ssh %h

%p %t

TelnetTerminal.app

/usr/bin/osascript /Users/your-user-id/terminal.scpt ssh

%h %p %t

SSH

The following are AppleScript scripts that are used to set up an external terminal.

iTerm
on run argv

tell application "iTerm"
activate
if current terminal exists then

set t to current terminal
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else
set t to (make new terminal)

end if

tell t
launch session "Default Session"
tell the current session

write text "/usr/bin/" & item 1 of argv & " " & item 2 of argv & " " & item
3 of argv

set name to item 4 of argv
end tell

end tell
end tell

end run

Terminal.app
on run argv

tell application "Terminal"
activate
-- open a new Tab - there is no method
tell application "System Events"

keystroke "t" using {command down}
end tell
repeat with win in windows

try
if get frontmost of win is true then

set cmd to "/usr/bin/" & item 1 of argv & " " & item 2 of argv & " " &
item 3 of argv

do script cmd in (selected tab of win)
set custom title of (selected tab of win) to item 4 of argv

end if
end try

end repeat
end tell

end run

Topology Editor Setting
This setting allows you to customize the Topology Editor in the Cisco Modeling Labs client.

The available operations for this setting are:

Web Services Setting
This setting allows you to configure the CiscoModeling Labs client to communicate with the CiscoModeling
Labs server. When you first launch the Cisco Modeling Labs client, the Active profile is not specified and
the web services that are listed displayUnauthorized in red. This message relates to theMaster Credentials
field, which must be set before the Cisco Modeling Labs client can communicate with the Cisco Modeling
Labs server.

The available operations for this setting are:

AutoNetkit Visualization Setting
The AutoNetkit visualization feature is available only when node configurations are built using the parameters
defined in AutoNetkit. If AutoNetkit visualization is turned off, you cannot get a true representation of your
topology.
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AutoNetkit visualization is used to determine how AutoNetkit presents graphical representations of
topology-specific attributes, such as nodes, links, and interfaces, during the build phase. The graphical
representations can be presented as a physical perspective of a network topology or based on a protocol
perspective.

For AutoNetkit visualization to operate, the Cisco Modeling Labs client must be connected to the Cisco
Modeling Labs server. The nodes in the network topology must be set to open AutoNetkit visualization either
automatically or after receiving a prompt.

To access this setting, choose File > Preferences >Web Services > AutoNetkit Visualization.

The available operations for this setting are:
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