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Preface

• Document Conventions, page v

• Related Documentation, page vii

• Obtaining Documentation and Submitting a Service Request, page vii

Document Conventions
This document uses the following conventions:

DescriptionConvention

Both the ^ symbol and Ctrl represent the Control (Ctrl) key on a keyboard. For
example, the key combination^D orCtrl-Dmeans that you hold down the Control
key while you press the D key. (Keys are indicated in capital letters but are not
case sensitive.)

^ or Ctrl

Commands and keywords and user-entered text appear in bold font.bold font

Document titles, new or emphasized terms, and arguments for which you supply
values are in italic font.

Italic font

Terminal sessions and information the system displays appear in courier font.Courier font

Bold Courier font indicates text that the user must enter.Bold Courier font

Elements in square brackets are optional.[x]

An ellipsis (three consecutive nonbolded periods without spaces) after a syntax
element indicates that the element can be repeated.

...

A vertical line, called a pipe, indicates a choice within a set of keywords or
arguments.

|

Optional alternative keywords are grouped in brackets and separated by vertical
bars.

[x | y]
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DescriptionConvention

Required alternative keywords are grouped in braces and separated by vertical
bars.

{x | y}

Nested set of square brackets or braces indicate optional or required choices
within optional or required elements. Braces and a vertical bar within square
brackets indicate a required choice within an optional element.

[x {y | z}]

A nonquoted set of characters. Do not use quotation marks around the string or
the string will include the quotation marks.

string

Nonprinting characters such as passwords are in angle brackets.< >

Default responses to system prompts are in square brackets.[ ]

An exclamation point (!) or a pound sign (#) at the beginning of a line of code
indicates a comment line.

!, #

Reader Alert Conventions

This document may use the following conventions for reader alerts:

Means reader take note. Notes contain helpful suggestions or references to material not covered in the
manual.

Note

Means the following information will help you solve a problem.Tip

Means reader be careful. In this situation, you might do something that could result in equipment damage
or loss of data.

Caution

Means the described action saves time. You can save time by performing the action described in the
paragraph.

Timesaver

IMPORTANT SAFETY INSTRUCTIONS

This warning symbol means danger. You are in a situation that could cause bodily injury. Before you
work on any equipment, be aware of the hazards involved with electrical circuitry and be familiar with
standard practices for preventing accidents. Use the statement number provided at the end of each warning
to locate its translation in the translated safety warnings that accompanied this device. Statement 1071

SAVE THESE INSTRUCTIONS

Warning
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Related Documentation

Before installing Cisco Modeling Labs, refer to the Cisco Modeling Labs release notes.Note

Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional information,
see the monthlyWhat's New in Cisco Product Documentation, which also lists all new and revised Cisco
technical documentation, at:

http://www.cisco.com/c/en/us/td/docs/general/whatsnew/whatsnew.html

Subscribe to theWhat's New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free
service and Cisco currently supports RSS version 2.0.
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C H A P T E R  1
Troubleshooting Cisco Modeling Labs

• Guidelines for Troubleshooting, page 1

• Troubleshooting Issues, page 1

Guidelines for Troubleshooting
When troubleshooting issues in Cisco Modeling Labs, you should follow the guidelines described in the
following table.

DescriptionGuideline

The latest release notes are available at Release Notes
for Cisco Modeling Labs 1.2.

Check the release notes to see if the issue is a known
problem.

The Cisco Modeling Labs client provides
functionality that allows you to generate problem
reports for any problems encountered in your
topology. It is accessible from the menu under Help
> Generate Problem Report. See the Cisco
Modeling Labs Corporate Edition User Guide,
Release 1.2 for more information.

Generate a problem report.

Troubleshooting Issues
Table 1: Troubleshooting Issues

SolutionProbable CauseProblem

Re-apply the licenses in the correct
order. See Applying Licenses, on
page 2 for more information.

Licenses have been applied in the
incorrect order.

Error returned when applying
multiple Cisco Modeling Labs
licenses.
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SolutionProbable CauseProblem

Fetch available node subtypes from
the Cisco Modeling Labs server.
See Fetch Node Subtypes from the
Cisco Modeling Labs Server, on
page 2 for more information.

Fetch from server option not run.Missing node subtypes (images)
under the Nodes tab in the
Topology Palette view.

Ensure that the ESXi host has the
correct date and time set. See ESXi
Host Time Configuration Issue, on
page 3 for more information.

The date and time set on the ESXi
host is incorrect.

During installation, the Cisco
Modeling Labs virtual machine
does not launch and the Ubuntu
splash screen is displayed
indefinitely.

Applying Licenses
The order in which you apply your Cisco Modeling Labs license is important.

• You must apply your base license (R-PID) first and then apply any remaining expansion license(s)
(L-PID).

• Applying an expansion license before a base license will result in an error.

To resolve this issue, remove all licenses and then re-apply them starting with your base license (R-PID).

Fetch Node Subtypes from the Cisco Modeling Labs Server
To fetch new node subtypes from the Cisco Modeling Labs server, perform the following tasks:

Step 1 Click File > Preferences > Node Subtypes.
Step 2 Click the Fetch from Server button.
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The Confirm dialog box is displayed.
Step 3 Click OK to update the list of node subtypes.

Figure 1: Fetch Node Subtypes from Server

Step 4 Click OK to finish.

The updated list of node subtypes is available for use in the Topology Palette view.
Contact your system administrator if a specific node subtype is missing from the list, as the system administrator
is responsible for adding new node subtypes to the Cisco Modeling Labs server.

ESXi Host Time Configuration Issue
When the date and time on the ESXi host are not set correctly during the installation process, the virtual
machine does not launch and the Ubuntu splash screen is displayed indefinitely.

To resolve this issue, ensure that the ESXi host has the correct date and time set as follows:

• On the ESXi host, select Configuration > Time Configuration.

• Update the Date & Time field as necessary.
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C H A P T E R  2
Cisco Modeling Labs FAQ

• Frequently Asked Questions, page 5

Frequently Asked Questions
This Cisco Modeling Labs FAQ provides answers to questions concerning the use of the Cisco Modeling
Labs server and client.

AnswerQuestion

See Supported VMware ESXi Versions, on page 6
for more information.

What is the minimum version of VMWare ESXi?

See Recommended Hardware for Cisco Modeling
Labs Version 1.2, on page 6 for more information.

What is the recommended hardware for Cisco
Modeling Labs Release 1.1?

See Map Network Interfaces, on page 6 for more
information.

Why does my installation fail with a 'No valid host
was found' error?

See Resource Issue in CiscoModeling Labs, on page
7 for more information.

Why do someVMs showACTIVE state while others
show ERROR state in my running simulation?

See Configuration Extraction Fails, on page 7 for
more information.

Why does my configuration extraction fail?

See Problem Running Simulations, on page 7 for
more information.

Why am I getting an error when I try to launch my
simulation?

See Resetting the Secure Storage Password, on page
8 for more information.

How do I reset my secure storage password?

See Topology File Information, on page 8 for more
information.

How do I know which topology is currently open?

See User Profile Information, on page 9 for more
information.

How do I know what active profile I am using?

Cisco Modeling Labs Corporate Edition Troubleshooting Guide, Release 1.2    
5



AnswerQuestion

See Caveat When Using AutoNetkit , on page 9
for more information.

Why did my updated configuration get overwritten?

See Storing Updated Node Configurations, on page
9 for more information.

Where are updated node configurations stored?

See Packet Tracing in a Simulated Network, on page
10 for more information.

Is packet tracing in a simulated network supported?

Supported VMware ESXi Versions
The versions of VMware ESXi supported in Cisco Modeling Labs version 1.2 are:

• VMware ESXi 5.5U1 (Build 1623387)

• VMware ESXi 6.0 (Build 2494585)

Youmust verify that you are using vSphere Client v5.5 Update 2 (Build 1993072) or later before deploying
Cisco Modeling Labs. Failure to use the minimum version will result in a failed deployment and will
return an error stating that nested virtualization is not supported.

Important

Recommended Hardware for Cisco Modeling Labs Version 1.2
The recommended servers for use with Cisco Modeling Labs version 1.2 are the Cisco UCS C220 M4 and
Cisco UCS C240 M4 servers. These are the latest dual-socket, rack-mounted servers based on Intel's Haswell
CPU that support up to a maximum of 18 cores per socket. Large installations may require a 4-socket server
such as the Cisco UCS C460 M4. See the following specification sheet for more information on supported
rack servers http://www.cisco.com/c/dam/en/us/products/collateral/servers-unified-computing/
ucs-c-series-rack-servers/c220m4-sff-spec-sheet.pdf.

Map Network Interfaces
Cisco Modeling Labs requires connections to five unique virtual network port groups, the first of which is
for management and is site unique. It is, by default, VM Network. The other four port groups are Flat, Flat1,
SNAT, and INT. These are used by Cisco Modeling Labs for external Layer-2 and Layer-3 connectivity.

For a fresh Cisco Modeling Labs installation, if you neglect to map these five network interfaces, a No valid
host was found error is returned.

You must map all five network interfaces, regardless if you plan to use all of them or not.Note

This is required for correct system operation. See Cisco Modeling Labs Corporate Edition System
Administration Installation Guide, Release 1.2 for more information.
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Resource Issue in Cisco Modeling Labs
In Cisco Modeling Labs, each configured virtual machine in a topology has an associated operating system,
such as Cisco IOSv, Cisco CSR1000v, and so on. Additionally, each virtual machine is also configured with
a memory size value which is allocated when the VM starts up. For example, Cisco IOSv requests 512mb,
while Cisco CSR1000v requests 3072mb.When you send a request to start a simulation, the VMmanagement
function, Openstack Icehouse, evaluates the virtual machine start request and confirms if there is sufficient
memory available to support the VM.

If there is enough memory, the VM boots up and is reported as ACTIVE.

Where there is insufficient memory, the VM is reported as being in the ERROR state.

Since the requested launch is evaluated in the sequence in which the VM receives the request, you may see
situations where some VMs in your topology go ACTIVE, while others go into the ERROR state.

Configuration Extraction Fails
During the configuration extraction process, the system attempts to log in using a set of default usernames
and passwords. For example, the Cisco IOSv cisco default password is enable. Therefore, if you have changed
this password, the configuration extraction will fail.

For virtual machines configured using AutoNetkit, the basic configuration created ensures that the configuration
extraction process will succeed.

Where AutoNetkit is not used to generate configurations, you will need to collect such configuration data
manually or create the required password.

The enable password is only required for virtual machines running in Cisco ASAv, Cisco IOSv, Cisco
IOSvl2 and Cisco CSR100v. For Cisco IOS XRv and Linux server the username cisco and corresponding
password cisco must be used.

Note

Problem Running Simulations
This section describes common errors encountered when launching your simulation.

After you have designed a topology on the Topology Editor canvas, you click Launch Simulations, and an
error is returned. Possible errors are:

• java.net.ConnectException: Connection refused: connect

• URI is not absolute

• Unauthorized User

These errors occur when a Web Services profile has not been correctly configured for the Cisco Modeling
Labs client to communicate with the CiscoModeling Labs server, or when you try to log in as an unrecognized
user or with an incorrect password.
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To resolves these issues:

Step 1 From File > Preferences > Web Services, click the green arrow next to Active Profile to open the Create a new web
services profile dialog box.

Step 2 In the dialog box, enter a name for your profile.

Resetting the Secure Storage Password
When the Secure Storage feature is used for the first time, it generates a master password that is used to encrypt
the data. In the future, this same master password will be required to retrieve the data from secure storage. If
the master password becomes unavailable, the Secure Storage feature provides optional support for password
recovery.

Two methods are used to reset the password for the secure storage feature.

Method 1

1 From within Cisco Modeling Labs client, choose File > Preferences > General > Security > Secure
Storage.

2 Click Change Password. The Secure Storage dialog box appears.
3 Click Yes. The Password Recovery dialog box appears.
4 Enter details in both Question fields and provide answers for both questions. Take note of the answers

you provide, as these are treated as secondary passwords.
5 Click OK.

Method 2

If you are unable to access the Cisco Modeling Labs client due to a lost or forgotten password for the secure
storage feature, complete the following steps:

1 Move to the <user-home>/.eclipse/org.eclipse.equinox.security folder.
2 Delete the file secure_storage.
3 Open Cisco Modeling Labs client to provide details for the password for the secure storage feature when

prompted.

Topology File Information
On the Cisco Modeling Labs client Topology Editor canvas, hover your mouse over the topology tab of the
open topology to view the project name and file name.

Figure 2: Topology Project Name and File Name
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User Profile Information
In the CiscoModeling Labs client, hover your mouse over the credentials button in the status bar at the bottom
of the screen.

Figure 3: Web Services Profile Details

The tool tip shows a summary of the current Web Services Profile settings.

Caveat When Using AutoNetkit
AutoNetkit is included with Cisco Modeling Labs to allow users to quickly generate configuration files for
topologies.

Be aware of the following caveat when using AutoNetkit.

AutoNetkit is enabled by default. You must disable AutoNetkit under the following conditions:

• You do not want AutoNetkit to update the configuration for a node.

• You want to preserve modifications made to a running configuration.

To disable the AutoNetkit settings, select a node in the topology, then choose Properties > AutoNetkit.
Uncheck the Auto-generate the configuration based on these attributes check box.

Storing Updated Node Configurations
Node configurations are stored in the topology .virl file. If you are extracting configurations from a topology
that is open and launched in the current UI session, the topology .virl file is modified in place and automatically
saved.

In cases where the original topology file has been updated since its last launch, a dialog box is displayed
asking to overwrite the file or ignore changes made.
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Packet Tracing in a Simulated Network
You can capture traffic from an interface by using tcpdump to attach to a port in a simulated network created
with Cisco Modeling Labs. The procedure is done on the Cisco Modeling Labs server. You can export the
packet-trace capture file to another server for examination and analysis with a tool, such asWireshark. If VNC
is enabled on the Cisco Modeling Labs server and sufficient resources are available, you can perform the
capture and analysis tasks within the VNC session.

Every link and every connection in Cisco Modeling Labs is a collection of ports represented in the Neutron
networking services component of OpenStack. Neutronmaintains a database of the ports. The database contains
the interfaces, MAC addresses, IP addresses, and so on, associated with those ports. Use the database to
identify the MAC address of the interface being investigated as the starting point, to identify the correct port,
and then to identify the Linux interface that the port belongs to.

To enable packet tracing, complete the tasks in this section:

Before You Begin

• Ensure that you have access to the Cisco Modeling Labs server.

• Ensure that you understand the basics of packet tracing and analysis.

• Ensure that you can use Wireshark or a similar tool for packet tracing and analysis.

• Ensure that you have an understanding of OpenStack and its basic architecture.

• Ensure that you are running a simulation in the Cisco Modeling Labs client.

Step 1 Identify the MAC address of the interface where packets are captured. Connect to the console on a router node or server
(or any Cisco Modeling Labs virtual device) and display the MAC address of the interface.

Example:
Router#show interface gigabitethernet0/1
GigabitEthernet0/1 is up, line protocol is up
Hardware is iGbE, address is fa16.3ea8.9b66 (bia fa16.3ea8.9b66)
Description: to core-1
Internet address is 10.1.0.21/30

The command used above will differ depending on the virtual device running.Note

Step 2 In a terminal window on the Cisco Modeling Labs server, use the MAC address as the input to the neutron port-list
command.

The command expects the MAC address delimiter to be a colon (:) in the format AA:BB:CC:DD:EE:FF. In
this example, the MAC address is entered as 9B:66. Usually, the last two bytes are sufficient.

Note

Example:
virl@guest:~$ neutron port-list | grep 9b:66
| 5eea1895-013f-4c1a-920e-d517d97304fc |
</guest/endpoint>-<mdns-hub-KbfrvU>-<mdns-hub>-<core-1-to-mdns-hub>| fa:16:3e:a8:9b:66 | {"subnet_id":
"71591779-4c42-4fc4-a880-6b2736b8a919", "ip_address": "10.255.0.2"} |
virl@guest:~$
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The command output is a table separated by bars (|). The information in the first column of output is the port ID. From
that ID, the first 11 characters are used. In this example, that value is 5eea1895-01. This string is then used to name the
server network interface.

Step 3 Use the ifconfig command on the Cisco Modeling Labs server to verify that the interface exists. You must prefix the
port ID with the word tap, as shown in the following example:

Example:
virl@guest:~$ ifconfig tap5eea1895-01
tap5eea1895-01 Link encap:Ethernet HWaddr 6e:be:73:63:d4:47

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:161487 errors:0 dropped:0 overruns:0 frame:0
TX packets:116419 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:500
RX bytes:16909609 (16.9 MB) TX bytes:13922881 (13.9 MB)

virl@guest:~$

The correct host network interface is identified.
Step 4 Capture traffic on the identified interface by using the command line, and capture the output in a file for examination.

The following example shows how to use tcpdump to capture traffic into a file in the /tmp directory:

Example:
virl@guest:~$ sudo tcpdump -ni tap5eea1895-01 -s0 -v -w /tmp/mgre.pcap
The command captures all the traffic on the interface into the file /tmp/mgre.pcap. The command option -s0 means no
restriction on packet size. Refer to the man page for tcpdump for details on writing capture filters.

Step 5 Press Ctrl-C to stop the capture.
Step 6 (Optional) If you are using VNC to connect to the Cisco Modeling Labs server, you can use Wireshark directly on the

server. However, the server must have sufficient resources to support VNC and Wireshark.
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