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Design a Topology Overview
The design phase is the initial step in creating a network topology. During the design phase, you will perform
the tasks described in the following sections.

Topology Nodes and Connections
The topology you design consists of nodes and connection functions. See NavigatingWithin the CiscoModeling
Labs Client for additional information about how to select and edit nodes and connection functions.

Topology Nodes

Table 1: Node Subtypes

Node TypeNode Name

Router node. Runs a Cisco IOS operating system.Cisco IOSv

Router node. Runs a Cisco IOS Layer 2 operating
system.

Cisco IOSvL2
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Node TypeNode Name

Server node. Runs a Linux operating system.Server

Router node. Runs a Cisco IOSXR operating system.Cisco IOS XRv

Router node. Runs a Cisco CSR 1000 operating
system.

Cisco CSR1000v

Router node. Runs a Cisco NX-OS operating system.
(Available separately.)

Cisco NX-OSv

A node subtype is a virtual machine that runs on top of OpenStack, which itself is running in a Linux virtual
machine that is running on top of VMware software. Because the node is virtual, specific hardware is not
emulated. For example, there are no power supplies, no fans, no ASICs, and no physical interfaces. For all
router nodes, the interface type is a Gigabit Ethernet network interface. A server node has an Ethernet network
interface.

You can choose an image and image flavor for each node type. See theUserWorkspaceManagement chapter
in the Cisco Modeling Labs Corporate Edition System Administrator Installation Guide, Release 1.1 for
information on how to access the VM Image and the VM Flavor choices. In most cases, you need not select
an image and flavor. By default, the node subtype is associated with an image and flavor that runs with the
topology.

Table 2: Node VM Images

Used ForVM Image Name

Server nodeserver

Cisco CSR1000 nodeCSR1000v

Cisco IOS nodeIOSv

Cisco IOS Layer 2 nodeIOSvL2

Cisco IOS XR nodeIOS XRv

Cisco NX-OS nodeNX-OSv

Table 3: Node VM Flavors

Used ForVM Flavor Name

Linux serverm1_tiny

Linux serverm1_small

Linux serverm1_medium
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Used ForVM Flavor Name

Linux serverm1_large

Linux serverm1_xlarge

Linux serverserver

Cisco CSR 1000 nodeCSR1000v

Cisco IOS XR nodeIOS XRv

Cisco IOS nodeIOSv

Cisco IOS Layer 2 nodeIOSvL2

Cisco NX-OS nodeNX-OSv

Each Linux flavor provides a different amount of memory and CPU allocated to the server.

Connection Functions

Cisco Modeling Labs provides the connection functions shown in the following table.

Table 4: Connection Functions

DescriptionConnection Type

Creates a connection between two interfaces.
Interfaces are created in the node to support a
connection. Any unused interfaces present are
automatically assigned. All the interfaces in router
nodes are represented as Gigabit Ethernet interfaces.
Multiple parallel connections are supported.

Connection

Creates an external router connection point.
When the external router is used in conjunction with
a Layer 2 External (Flat) network and IOSv instances,
AutoNetkit is able to configure an L2TPv3 tunnel to
connect simulations to remote devices in a transparent
manner.

External Router

Creates a Layer 3 external connection point using
static network address translation (SNAT). This
external connection point allows connections outside
of Cisco Modeling Labs to connect to the topology.

Layer 3 External (SNAT)

Creates a Layer 2 external connection point using
FLAT. This external connection point allows
connections outside of Cisco Modeling Labs to
connect to the topology.

Layer 2 External (Flat)
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DescriptionConnection Type

Creates a Layer 2 external connection point using
FLAT1. This second external connection point allows
connections outside of Cisco Modeling Labs to
connect to the topology.

Layer 2 External (Flat1)

Table 5: Site Groups

DescriptionType

Creates a site that uses levels of hierarchy in a Cisco
Modeling Labs topology. Sites can be added to a
topology, objects can be created within a site, and
objects can be linked between sites and parent sites.

Site

Create a Topology
Before You Begin

A topology project folder must exist.

There are several methods for creating a topology. These are discussed in the following sections.

Method 1: Create a Topology from the Menu Bar

Step 1 From the menu bar, choose File > New > Topology File.
Step 2 Select a topology project folder.
Step 3 Enter a filename, ensuring that it ends with the extension .virl.
Step 4 Click Finish.

A filename .virl topology file is created in the selected project folder.
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Method 2: Create a Topology from the Projects View

Step 1 Right-click Projects view.
Step 2 Choose New > Topology.
Step 3 Select a topology project folder.
Step 4 Enter a filename, ensuring that it ends with the extension .virl.
Step 5 Click Finish.

A filename .virl topology file is created in the selected project folder.

Method 3: Create a Topology from the Toolbar

Step 1 Click the New Topology File icon in the toolbar.
Step 2 Select a topology project folder.
Step 3 Enter a filename, ensuring that it ends with the extension .virl.
Step 4 Click Finish.

A filename .virl file is created in the selected project folder.

What to Do Next

Place the nodes.

Place the Nodes on the Canvas
Before You Begin

• A topology file must exist.

• The topology file must be open and the canvas visible in the Topology Editor.

Step 1 Click a node type, which is under the Nodes heading in the Palette view.
Step 2 Click the canvas at each point where you want to place a node. You can also drag the nodes on the canvas to position

them. You can then arrange the nodes using several methods:

• Use Shift-click to select two or more nodes. Alternatively, click and drag a selection box around two or more
nodes. You can also use Ctrl-click (Windows) or Cmd-click (OS X) to toggle between node selections.
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• From the menu bar, use Edit > Distribute Nodes to arrange the selected nodes vertically, horizontally, or to
distribute them on a grid.

The grid is determined dynamically, based on the selected
nodes.

Note

• Use Edit > Alignment from the menu bar to arrange the selected nodes in a variety of alignments, namely, Left,
Center, Right, Top, Middle, and Bottom.

The use ofDistributeNodes andAlignment is mutually exclusive.Note

•When no nodes are selected, use the Edit > Layout Nodes from the menu bar to arrange the nodes in a Tree Layout
or a Fruchterman-Reingold (F-R) Layout.

◦A basic tree layout is to choose a node as the root of the tree, and the nodes connected to the root become
children of the root node.

◦A F-R layout has connected nodes close to each other, while unconnected nodes are further apart from each
other.

See the section Toolbar for information on using these tools.

What to Do Next

Create connections and interfaces.

Create Connections and Interfaces
Before You Begin

Nodes must be in place on the canvas of the Topology Editor.

Step 1 Click Connection in the Tools view.
Step 2 Click the first node.
Step 3 Click the next node to create the connection.

When you connect two nodes, the interfaces are created and named automatically when you choose File >
Preferences > Topology Editor > Associate new connection with interfaces silently check box. You can
view the node interfaces when you click the connection and the two end points of the connection appear in the
Node Editor.

Note

Step 4 Repeat Step 2 and Step 3 until all the connections are in place.
You can create multiple parallel connections between two nodes. When a connection is selected, the Topology
Editor shows the connection end points and the Node Editor shows the two nodes involved in the connection,
all of the interfaces on those nodes, and all the connections between those two nodes.

Tip

Choose File > Export > Export Topology Diagram to Image to capture an image of the current topology on
the canvas.

Note
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Use Unmanaged Switches
Users have the choice to use either an unmanaged switch or Cisco IOSv layer 2 to provide a switching service.
Unmanaged switches are used in place of the multipoint connection which was available in previous versions
of Cisco Modeling Labs. For example, in the following figure there are 3 IOSv instances connected to an
unmanaged switch. Each of the interfaces on iosv-1, iosv-2, and iosv-3 appear to be on the same subnet for
point to point communication through the unmanaged switch.

Figure 1: Using an Unmanaged Switch in a Simple Topology

Unmanaged switch instances use the underlying Linux bridge process running under OpenStack control to
provide this connectivity between the various virtual machines. It is a transparent switch.

Before You Begin

A topology file with the extension .virl must exist. Router nodes or server nodes are placed on the canvas.
Optionally, connections may exist between nodes.

Step 1 In the Nodes view, click Unmanaged Switch.
Step 2 Click the area on the canvas where you want the unmanaged switch to appear.
Step 3 In the Tool view, click Connect.
Step 4 On the canvas, click the unmanaged switch node then click an end node. A connection appears.
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Continue clicking unmanaged switch-node combinations until all connections are made.

Figure 2: Using an Unmanaged Switch

The Cisco IOSvL2 Switch Image
The Cisco IOSvL2 switch image is available in Cisco Modeling Labs, Release 1.1. The Cisco IOSvL2 switch
image is a virtual machine like Cisco IOSv, Cisco IOS XRv, and so on. It runs and is configured in the same
way as all other virtual machines. It runs an Cisco IOSv 15.2 switch image.

All Cisco IOSvL2 switch images in a topology are counted against the node limit.Note

A Cisco IOSvL2 switch image provides sixteen Gigabit Ethernet interfaces, reserving Gi0/0 for OOB
management. It can be configured manually or using AutoNetkit.

Cisco IOSvL2 switch instances can operate in:

• Layer 2 mode

• Layer 3 mode

By default the instances operate in layer 3 mode. However, the primary use of the Cisco IOSvL2 switch image
is for switching purposes.

Any routers set up to connect to the Cisco IOSvL2 switch will be in switchport access mode. By default, all
routers are placed in VLAN 2. You can specify which VLAN to place a port in by setting a VLAN attribute
on the router interface. See Assign VLANs for details on how to do this.
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When using a switch to switch connection, it defaults to a 802.1q trunk port between the switches when
configured using AutoNetkit.

Use the Cisco IOSvL2 Switch Image

Step 1 In the Nodes view, click IOSvL2.
Step 2 Click the canvas at each point where you want to place an IOSvL2 node. You can also drag the nodes on the canvas to

position them.
Step 3 Add additional node types as required.
Step 4 Use the Connect tool to create connections between the nodes.
Step 5 To specify which VLAN to place a port in, select the interface for the host or router in the Node Editor.
Step 6 Under Properties > AutoNetkit, enter a value for the VLAN field, as shown.

Figure 3: Setting the VLAN Attribute

Step 7 From the toolbar, click Build Initial Configurations to generate a configuration for the topology using AutoNetkit.
When prompted to open AutoNetkit visualization, click Yes.
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AutoNetkit visualization for the topology opens in a browser window.

Figure 4: AutoNetkit Visualization

Step 8 To view all broadcast domains that are enabled, select layer2_conn from the phy drop-down list. For example, hovering
over server-2 in this example shows the routers and servers that are in the same VLAN. All other devices are greyed out.

Figure 5: Layer 2 Connectivity
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Selecting layer2 from the phy drop-down list shows the switches representing the VLANs in place.

Figure 6: Layer 2 Switches
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Step 9 In the Cisco Modeling Labs client, click Launch Simulation to start the simulation.
The simulation starts and is visible in the Simulations view.

Figure 7: Simulation with Cisco IOSvL2 Switch Image

Create a Site
A site is a container that can hold one or more nodes. It is used to group multiple nodes within the same site,
which provides a degree of hierarchy and simplifies the topology view.

A node interface within a site can connect to another node interface in the same site or to a node interface
located in a different site. A connection cannot start on a node and terminate on a site. Sites can be nested,
forming a hierarchical structure.

Before You Begin

One or more nodes should be on the canvas.

Step 1 In the General view, click Site.

Step 2 Click an area on the canvas to place the site.

Step 3 Shift-Click the nodes that you want in the site, or click and drag a selection window around the nodes.
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• From the Edit menu, choose Group to Site.

• Alternatively, you can drag the selected nodes to the site icon that you placed on the canvas.

Step 4 To view the site, select the site name from the drop-down list under the Topology tab.
A topology site tab opens and displays the site view.

The drop-down list under the Topology tab displays the site hierarchy as a navigation trail.

To open a site view, double-click on the site. The following figure shows the navigation trail selections for Site 1 and
Site 2.

Figure 8: Site Selection

Step 5 To ungroup the site, click the site icon and choose Edit > Ungroup Site.
Step 6 To connect node interfaces between Site 1 and Site 2:

a) Select Site 1.
b) Click Connect.
c) Click the node that is the starting point of the connection, Site 1.
d) Move the cursor to the breadcrumbs and click Site 2.

Site 2 is displayed.
e) Click the node that is the endpoint of the connection.

A connection now exists between the interfaces in the two sites.

Step 7 To delete a node from a site:
a) Select the applicable node.
b) Right-click the node and select Delete from the list.

The node is deleted.

Step 8 To delete a site from a topology:
a) Select the applicable site.
b) Right-click the site and select Delete from the list.

The site is deleted including all associated interfaces and connections.
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