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Design a Topology Overview
The design phase is the initial step in creating a network topology. During the design phase, you will perform
the tasks described in the following sections.

Topology Nodes and Connections
The topology you design consists of nodes and connection functions. Refer to the section Navigating Within
the Cisco Modeling Labs Client for additional information about how to select and edit nodes and connection
functions.

Topology Nodes

Cisco Modeling Labs provides the Cisco IOSv node subtype. Additional node types are available and can be
installed by the system administrator via the User WorkspaceManagement interface. See the UserWorkspace
Management chapter in theCiscoModeling Labs Corporate Edition System Administrator Installation Guide.
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Table 1: Node Subtypes

Node TypeNode Name

Router node. Runs a Cisco IOS operating system.Cisco IOSv

Server node. Runs a Linux operating system.Server

Router node. Runs a Cisco IOSXR operating system.
(Available separately.)

Cisco IOS XRv

Router node. Runs a Cisco CSR 1000 operating
system. (Available separately.)

Cisco CSR1000v

A node subtype is a virtual machine that runs on top of OpenStack, which itself is running in a Linux virtual
machine that is running on top of VMware software. Because the node is virtual, specific hardware is not
emulated. For example, there are no power supplies, no fans, no ASICs, and no physical interfaces. For all
router nodes, the interface type is a Gigabit Ethernet network interface. A server node has an Ethernet network
interface.

You can choose an image and image flavor for each node type. Refer to the User Workspace Management
chapter in theCiscoModeling Labs Corporate Edition System Administrator Installation Guide for information
on how to access the VM Image and the VM Flavor choices. In most cases, you need not select an image and
flavor. By default, the node subtype is associated with an image and flavor that runs with the topology.

Table 2: Node VM Images

Used ForVM Image Name

Server nodeserver

Cisco CSR1000v nodeCSR1000v

Cisco IOS nodeIOSv

Cisco IOS XR nodeIOS XRv

Table 3: Node VM Flavors

Used ForVM Flavor Name

Linux serverm1_tiny

Linux serverm1_small

Linux serverm1_medium

Linux serverm1_large

Linux serverm1_xlarge

Linux serverserver

Cisco CSR 1000v nodeCSR1000v
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Used ForVM Flavor Name

Cisco IOS XR nodeIOS XRv

Cisco IOS nodeIOSv

Each Linux flavor provides a different amount of memory and CPU allocated to the server.

Connection Functions

Cisco Modeling Labs provides the connection functions shown in the following table.

Table 4: Connection Functions

DescriptionConnection Type

Creates a connection between two interfaces.
Interfaces are created in the node to support a
connection. Any unused interfaces present are
automatically assigned. All the interfaces in router
nodes are represented as Gigabit Ethernet interfaces.
Multiple parallel connections are supported.

Connection

Creates a multipoint connection point. Multiple nodes
can connect to a multipoint connection.

Multipoint Connection

Creates a Layer 3 external connection point using
static network address translation (SNAT). This
external connection point allows connections outside
of Cisco Modeling Labs to connect to the topology.

Layer 3 External (SNAT)

Creates a Layer 2 external connection point using
FLAT. This external connection point allows
connections outside of Cisco Modeling Labs to
connect to the topology.

Layer 2 External (Flat)

Table 5: Site Groups

DescriptionType

Creates a site that can contain one or more nodes, and
additional groups of nodes. A site is a group of nodes
and you can create multiple site layers.

Site

Create a Topology Project
CiscoModeling Labs client provides a project folder and a sample topology that you can work with in addition
to creating your own project and topology.
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A topology project is a folder in which multiple topology files are stored. If you create many different
topologies, you can set up different projects for the topologies you create.

The three methods available for creating a topology project are discussed in the following sections.

Before You Begin

Before you begin the task of creating a topology project, you must complete the installation steps for your
system and set up the web services profile for the Cisco Modeling Labs client. Refer to the Cisco Modeling
Labs Corporate Edition System Administrator Installation Guide. See NavigatingWithin the Cisco Modeling
Labs Client for information on how to navigate the perspectives and views, and information about the menu
bars, toolbars, and editors. The navigation information is also available in the online help.

In addition, understand how:

• To navigate Cisco Modeling Labs client.

Method 1: Create a Topology Project from the Menu Bar

Step 1 From the menu bar, choose File > New > Other > Topology Project.
Step 2 Enter a Project Name and select the location in which to save the folder. A project folder is created in the default location

if you check the use default location check box. Alternatively, you can choose to save the project folder in another
location.

Step 3 Click Finish.

Method 2: Create a Topology Project from the Projects View

Step 1 Right-click Projects view.
Step 2 Choose New > Topology Project.
Step 3 Enter a Project Name and select the location in which to save the folder. A project folder is created in the default location

if you check the use default location check box. Alternatively, you can choose to save the project folder in another
location.

Step 4 Click Finish.
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Method 3: Create a Topology Project from the Toolbar

Step 1 Click the New Topology Project icon in the toolbar.
Step 2 Enter a Project Name and select the location in which to save the folder. A project folder is created in the default location

if you check the use default location check box. Alternatively, you can choose to save the project folder in another
location.

Step 3 Click Finish.

What to Do Next

Create a new topology file.

Create a Topology
Before You Begin

A topology project folder must exist.

There are several methods for creating a topology. These are discussed in the following sections.

Method 1: Create a Topology from the Menu Bar

Step 1 From the menu bar, choose File > New > Other > Topology.
Step 2 Select a topology project folder.
Step 3 Enter a filename, ensuring that it ends with the extension .virl.
Step 4 Click Finish.

A filename.virl topology file is created in the selected project folder.
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Method 2: Create a Topology from the Projects View

Step 1 Right-click Projects view.
Step 2 Choose New > Topology.
Step 3 Select a topology project folder.
Step 4 Enter a filename, ensuring that it ends with the extension .virl.
Step 5 Click Finish.

A filename.virl topology file is created in the selected project folder.

Method 3: Create a Topology from the Toolbar

Step 1 Click the New Topology File icon in the toolbar.
Step 2 Choose New > Topology.
Step 3 Select a topology project folder.
Step 4 Enter a filename, ensuring that it ends with the extension .virl.
Step 5 Click Finish.

A filename.virl topology file is created in the selected project folder.
filename.virl is a placeholder for example purposes only.Note

What to Do Next

Place the nodes.

Place the Nodes on the Canvas
Before You Begin

• A topology file must exist.

• The topology file must be open and the canvas visible in the Topology Editor.

Step 1 Click a node type, which is under the Nodes heading in the Palette view.
Step 2 Click the canvas at each point where you want a node. You can also drag the nodes on the canvas to position them. You

can then arrange the nodes using several methods:
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• Use Shift-click to select two or more nodes. Alternatively, click and drag a selection box around two or more nodes.
You can also use Ctrl+click (Windows) or Cmd+click (Mac OS X) to toggle between node selections.

• Use the Distribute Nodes tool on the toolbar to arrange the selected nodes vertically, horizontally, or to distribute
them on a grid.

The grid is determined dynamically, based on the selected
nodes.

Note

• Use the Align Nodes tool on the toolbar to arrange the selected nodes in a variety of alignments that you choose
from the Alignment drop-down list.

The use ofDistribute Nodes andAlignNodes is mutually exclusive.Note

•When no nodes are selected, use the Layout Nodes tool on the toolbar to arrange the nodes in a Tree Layout or a
Fruchterman-Reingold (F-R) Layout.

◦A basic tree layout is to choose a node as the root of the tree, and the nodes connected to the root become
children of the root node.

◦A F-R layout has connected nodes close to each other, while unconnected nodes are further apart from each
other.

See the section Toolbar for information on using these tools.

What to Do Next

Create connections and interfaces.

Create Connections and Interfaces
Before You Begin

Nodes must be in place on the canvas of the Topology Editor.

Step 1 Click Connection in the Tools view.
Step 2 Click the first node.
Step 3 Click the next node to create the connection.

When you connect two nodes, the interfaces are created and named automatically when you choose File >
Preferences > Topology Editor > Associate new connection with interfaces silently check box. You can
view the node interfaces when you click the connection and the two end points of the connection appear in the
Node Editor.

Note

Step 4 Repeat Step 2 and Step 3 until all the connections are in place.
You can create multiple parallel connections between two nodes. When a connection is selected, the Topology
Editor shows the connection end points and the Node Editor shows the two nodes involved in the connection,
all of the interfaces on those nodes, and all the connections between those two nodes.

Tip

Choose Export > Export Topology Diagram to Image to capture an image of the current topology on the
canvas.

Note
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What to Do Next

Create multipoint connections (optional).

Create Multipoint Connections
Multipoint connections are used in BUS topologies where all the nodes are connected to a single transmission
medium. This acts as the backbone of the connection and links all the nodes in the network. For example, for
four nodes to be directly connected to one another, 12 separate interface connections are needed, three in each
router, to fully connect each router to the other. By using a multipoint connection, each router has one
connection to the multipoint node.

Before You Begin

A topology file with the extension .virl must exist. Router nodes or server nodes are placed on the canvas.
Optionally, connections may exist between nodes.

Step 1 In the General view, clickMultipoint Connection.
Step 2 Click the area on the canvas where you want the multipoint connection node to appear.
Step 3 In the Tool view, click Connect.
Step 4 On the canvas, click the multipoint connection node then click an end node. A connection appears.

Continue clicking multipoint-node combinations until all connections are made.
You can have a connection between twomultipoint connection nodes as shown in the following figure.Note

Figure 1: Creating a Multipoint Connection

When performing alignment operations for multipoint connections on the canvas of the Topology Editor,
occasionally, these do not work as expected.

Note
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What to Do Next

• Create sites (optional).

• Show map background (optional).

Create a Site
A site is a container that can hold one or more nodes. It is used to group multiple nodes within the same site,
which provides a degree of hierarchy and simplifies the topology view.

A node interface within a site can connect to another node interface in the same site or to a node interface
located in a different site. A connection cannot start on a node and terminate on a site. Sites can be nested,
forming a hierarchical structure.

Before You Begin

One or more nodes should be on the canvas.

Step 1 In the General view, click Site.

Step 2 Click an area on the canvas to place the site.

Step 3 Shift-click the nodes that you want in the site, or click and drag a selection window around the nodes.

• From the Edit menu, choose Group to Site.

• Alternatively, you can drag the selected nodes to the site icon that you placed on the canvas.

Step 4 To view the site, select the site name from the drop-down list under the Topology tab.
A topology site tab opens and displays the site view.

The drop-down list under the Topology tab displays the site hierarchy as a navigation trail.

To open a site view, double-click on the site. The following figure shows the navigation trail selections for Site 1 and
Site 2.

Figure 2: Site Selection
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Step 5 To ungroup the site, click the site icon and choose Edit > Ungroup Site.
Step 6 To connect node interfaces between Site 1 and Site 2:

a) Select Site 1.
b) Click Connect.
c) Click the node that is the starting point of the connection, Site 1.
d) Move the cursor to the breadcrumbs and click Site 2.

Site 2 is displayed.
e) Click the node that is the endpoint of the connection.

A connection now exists between the interfaces in the two sites.

Step 7 To delete a node from a site:
a) Select the applicable node.
b) Right-click the node and select Delete from the list.

The node is deleted.

Step 8 To delete a site from a topology:
a) Select the applicable site.
b) Right-click the site and select Delete from the list.

The site is deleted including all associated interfaces and connections.

What to Do Next

Continue designing the topology.

View the Topology on a Map
The topology view is a schematic diagram. It shows the nodes and connections arranged in a logical fashion,
or represents a design that is easy to view. When you create a map view, you can move the nodes such that
they represent a physical location, for example, the locations of all router nodes in a city. Moving nodes on
a map view does not change their location in the topology view.

Within a topology file, each node is represented by two sets of coordinates. The location coordinates define
the node placement in the topology view. The map coordinates define node placement on the map view, by
latitude and longitude.

The map view uses the MapQuest database for map display.

Before You Begin

• A topology must exist with nodes and connections in place.
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• You must be connected to the Internet to use the mapping function, since it uses the map service from
MapQuest to retrieve the latest map images.

Step 1 With the topology view active, select Edit > Show map Background. Alternatively, you can click the Show Map
Background tool in the toolbar.

Step 2 Before you move a node, select the desired map location.
a) In theMap view, click the Go To Location icon, located under the pan and zoom controls.

• Type in the first few characters of a location.

• On a Windows platform, press Ctrl-Space and a list of matching locations appears.

• You can enter an airport code.

We recommend that you enter all upper-case or initial cap words when searching for locations, as these
provide more reliable results. For example, enter MEL or Mel to search for Melbourne airport.

Note

b) Select and click a location from the list.
c) Click OK.

The map location is displayed.
d) Use the pan and zoom controls on the map to determine an exact location. You can double-click the coordinates in

the Status bar, which opens the Go To Location dialog box.

Step 3 Click and drag the nodes into position on the map.
When you click and drag a node, the map coordinates are added to the .virl file and the node becomes a part of the map
view. When you open the map view again, the map location with the nodes is displayed.

Step 4 Continue to click and drag the nodes into position on the map view.
Step 5 Click the ShowMap Background tool in the toolbar to revert to the topology view. Note that the nodes in the topology

view are in their original layout.
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