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Using the Cisco Modeling Labs Client Overview
The Cisco Modeling Labs client is a cross-platform, point-and-click GUI that simplifies topology creation,
initial-device configurations, and permits access to the Cisco Modeling Labs server. You can interact directly
with your running simulations from this GUI. Additionally, the Cisco Modeling Labs client provides the
functionality to generate default router configurations before simulating your topology.

This chapter introduces the main areas and capabilities of the Cisco Modeling Labs client in the following
section.
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Navigating Within the Cisco Modeling Labs Client
This section describes the functionality of the Cisco Modeling Labs client, which comprises of a workbench
containing a menu bar, a toolbar, multiple editors, multiple perspectives, and multiple views.

Figure 1: Workbench Components

DescriptionCalloutDescriptionCallout

Canvas5Menu Bar1

Palette6Toolbar2

Views7Perspectives3

Topology Editor5+6
combined

Node Editor4

•Workbench—Refers to the CiscoModeling Labs client desktop environment. Each time the workbench
is exited, it is automatically saved, including all the open perspectives, views, and editors. When the
workbench is reopened, it appears exactly as it was when last closed.

•Menu Bar—References all the actions that can be performed when using the Cisco Modeling Labs
client.

• Toolbar—Contains a set of icons representing commands. The Toolbar provides shortcuts to actions
that are used most often from the Menu bar.

• Cisco Modeling Labs Client Perspectives—Identifies the Design and Simulate perspectives, each of
which is associated with an initial set of views and editors in your workbench.
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From theDesign perspective, you can design your network topology, build the node configurations,
and check routing protocols. TheDesign perspective is the default perspective if you are launching
the Cisco Modeling Labs client for the first time.

◦

◦From the Simulate perspective, you can enable devices and modify configurations to run the
simulations. When the nodes in your topology are fully initialized, you can connect to the consoles
as you would connect to a router console.

• Cisco Modeling Labs Client Editors—Provides alternative components within the Cisco Modeling
Labs client from which you can create and edit topologies. Two editors are provided: Node Editor and
Topology Editor.

◦The Node Editor shows the interface details for selected elements in the Topology Editor.

◦The Topology Editor is comprised of the Palette view and the canvas.

• CiscoModeling Labs Client Views—Provides alternative presentations of your topology, and methods
for navigating the information in your workbench.

• Cisco Modeling Labs Client Layout—Enables you to personalize your workbench, allowing you to
rearrange, resize, reset, and move between views.

Menu Bar
The menu bar provides access to the complete list of actions that are possible in the Cisco Modeling Labs
client.
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Table 1: Menu Bar Items

Action(s)Menu

Enables you to perform actions to a topology project, sub topology, or topology .virl file; set
preferences for resources; and exit the Cisco Modeling Labs client.

• New—Creates a new topology project folder, topology project, or topology .virl file.
See Design a Topology Overview for more information.

• Save—Saves the current Topology Editor contents.

• Save As—Saves the current Topology Editor contents to a new file.

• Print—Prints the current Topology Editor design.

• Import—Imports a resource type (for example, a topology.virl file) into the Cisco
Modeling Labs client. See Importing a Topology File, on page 6 for more information.

• Export—Exports a resource type (for example, a topology.virl file) from the Cisco
Modeling Labs client. See Exporting a Topology File, on page 6 for more information.

• Close—Closes the current editor.

• Close All—Closes all open editors.

• Preferences—Opens the Preferences dialog box where you can update the settings for
the Cisco Modeling Labs client. See Setting Preferences for the Cisco Modeling Labs
Client, on page 46 for more information.

• Switch Workspace—Allows you to select a workspace folder to use for your session.

• Exit—Exits the Cisco Modeling Labs client.

File
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Action(s)Menu

Enables you to manipulate resources on the canvas.

• Undo—Cancels the most recent change.

• Redo—Applies the most recent change that was removed.

• Copy—Places a copy of the topology on the clipboard.

• Paste—Pastes the topology from the clipboard to the canvas at the current cursor location.

• Delete—Deletes the current topology.

• Select All—Selects all objects in the current topology canvas.

• Show Map Background—Displays a map background for the topology. (You must
have Internet access to use this feature.)

• Reset Note Subtype—Enables you to redefine a virtual node on the canvas. The node
subtype installed with Cisco Modeling Labs is Cisco IOS. When Reset all interface
names is selected, the interface IDs are reset sequentially, starting from the Minimum
range.

• Highlight Connection—Highlights all connections to and from the selected node.

• Distribute Nodes—Aligns the nodes on the canvas evenly, either vertically or
horizontally, or places them in a grid layout. (This feature is disabled when Show Map
Background is chosen.)

• Layout Nodes—Places nodes on the canvas in a tree layout or an F-R layout. (This
feature is disabled when Show Map Background is selected.)

• Alignment—Aligns the nodes on the canvas. Options are: left, center, right, top, middle,
or bottom. (This feature is disabled when Show Map Background is selected.)

• Group to Site—Groups two or more nodes within a site.
Sites are created within Cariden
imports.

Note

• Ungroup to Site—Ungroups nodes from within a site, removing one layer of nesting.

Edit

Enables you to see numerous perspectives within the Cisco Modeling Labs client.

• Lists the view options for the selected perspective within the CiscoModeling Labs client.

• Allows you to filter your view results.

View

Provides zoom in and zoom out functionality from within the canvas.Zoom

Enables you to start and stop simulations, and to generate node configurations.Run

Enables you to perform topology searches and text searches within workspaces, topology
projects, files, and working sets.

Search
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Action(s)Menu

Displays the help topics for using the CiscoModeling Labs client in a separate browser window.

• Help Contents—Opens the Cisco Modeling Labs client support documentation.

• Cheat Sheets—Helps you complete a task.

• Generate Problem Report—Generates a detailed report of a problem, which can be
submitted to Cisco Technical Assistance Center (Cisco TAC) for further investigation.
See Generating Problem Reports, on page 7 for more information.

• About Cisco Modeling Labs—Identifies version information and displays details
pertaining to software installations.

Help

Importing a Topology File

Step 1 From the menu bar, choose File > Import.
The Import dialog box appears.

Step 2 From the drop-down list, choose Topology > Import Topology file from File System, and click Next.
Step 3 Click Browse to locate the applicable .virl file.
Step 4 In the right pane, check the check box for the applicable .virl file.
Step 5 Click Finish to import the topology file.

Exporting a Topology File

Step 1 From the menu bar, choose File > Export.

To export a topology file, it must be open on the canvas of theTopology Editor.Note

The Export dialog box appears.
Step 2 From the drop-down list, choose Topology > Export Topology file to File System, and click Next.
Step 3 Click Browse to select the directory to export the topology file to.
Step 4 Click Finish to export the topology file.
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Generating Problem Reports
The Cisco Modeling Labs client provides functionality that allows you to generate problem reports for any
problems encountered in your topology. It is accessible from the menu bar under Help > Generate Problem
Report.

While all options are pre-selected, you can individually select the information you want to include in the
report.

When generating a problem report for your topology, you must have the topology containing the problem
open on the canvas.

Note

DescriptionOption

User interface .log file from the user's workspace.Log File

Current content from the Console view messages. These are messages
from the server in response to AutoNetkit and simulation launch actions.

Consoles Content

Contents of the currently open topology file in theTopology Editor canvas.Topology Editor Contents

Screenshot showing the state of the user interface when the problem
occurred.

Screenshot of the User Interface

Report of the Web Services details and errors.Web Services Setting

Any additional information that users can provide to describe the problem.Additional Information

The generated problem report is saved to a .zip file where you can check the contents before sending it to the
Cisco Technical Assistance Center (Cisco TAC) for investigation.

Toolbar
The toolbar is a compilation of icons representing commonly used actions. The toolbar is arranged below the
menu bar and offers the same actions as the menu bar, in a single click. The following table outlines the actions
that can be performed using the Cisco Modeling Labs client toolbar.

DescriptionFunctionIcon

Creates a new topology project. A topology project is
a folder in which multiple topology files are stored. If
you create many different topologies, you can set up
different projects for the topologies you create.

New Topology
Project

Creates a new topology file. A topology file is a .virl
file where the network arrangement is designed.

New Topology File
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DescriptionFunctionIcon

Saves the current topology.Save

Prints the current topology.Print

Uses Global Positioning Satellite (GPS) coordinates
to map a topology to precise geographic locations.

You must have Internet access to use this
feature since it uses the map service from
MapQuest to retrieve the latest map images.

Note

Show Map
Background

Resets the node subtypes. A node subtype defines the
virtual machine running a particular operating system,
for example, Cisco IOSv virtual software. You can also
choose to reset all interface names.

Reset Node Subtype

Deletes the currently selected element within the
topology.

Delete

Undoes the most recent action.Undo

Redoes the most recent undone action.Redo

Enlarges the topology view on the canvas.Zoom In

Decreases the topology view on the canvas.Zoom Out

Aligns the nodes on the canvas either vertically or
horizontally. Alternatively, arranges the nodes in a grid.

Distribute Nodes
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DescriptionFunctionIcon

Places the nodes on the canvas in a tree layout or an
Fruchterman-Reingold (F-R) layout.

• A basic tree layout allows you to choose a node
as the root of the tree, and the nodes connected
to the root become the children of that root node.

• An F-R layout has connected nodes close to each
other, while unconnected nodes are further apart
from each other.

Layout Nodes

Aligns the nodes on the canvas either horizontally or
vertically, and allows you to position them at various
points on the canvas.

Alignment

Groups two or more nodes within a site. Sites can be
nested, forming a hierarchical structure.

Group to Site

Ungroups nodes fromwithin a site, removing one layer
of nesting.

Ungroup Site

Launches a simulation.Launch Simulation

Stops a running simulation.Stop Simulations

Generates configurations for the topology.Update Router
Configurations

Cisco Modeling Labs Client Components
The three main components of the Cisco Modeling Labs client are described in the following sections:

• Cisco Modeling Labs Client Editors, on page 10

• Cisco Modeling Labs Client Perspectives, on page 11

• Cisco Modeling Labs Client Views, on page 15
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Cisco Modeling Labs Client Editors
Editors are visual components within the Cisco Modeling Labs client. Currently, two editors are available:

• Topology Editor—Shows the entire topology (or sites). The Topology Editor comprises the canvas and
the Palette.

• Node Editor—Shows the interface details for the currently selected elements in the Topology Editor.

Selecting a connection in the Topology Editor shows the details of both the endpoints in the Node Editor.Note

Topology Editor
The Topology Editor allows you to:

• Add, move, group, rename, and delete nodes and sites on the canvas, or change the properties.

• Create or remove connections between nodes.

• Use GPS coordinates to map your topology to precise geographic locations.

Figure 2: Topology Editor

Node Editor
The Node Editor allows you to:

• Add interfaces to a node.

• Add connections to the interfaces on a node.

• View nodes, their connections, and all the interfaces on the nodes.

• Specify which interface the connection connects to on each node.
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• Update properties for interfaces.

Figure 3: Node Editor

Cisco Modeling Labs Client Perspectives
A perspective defines the initial set and layout of views and editors in the workbench. The Cisco Modeling
Labs client provides two perspectives. However, you can customize your own user-defined perspectives for
use, which can be saved or deleted, as needed.

The two perspectives provided in the Cisco Modeling Labs client are: Design and Simulation:

• Design—Allows you to create and design your topologies, for example, adding devices and defining
interfaces, and adding connections to devices within your network. If you are using the Cisco Modeling
Labs client for the first time, the Design perspective opens by default.

• Simulation—Allows you to simulate running configurations that are generated from virtual Cisco IOS
versions.

The Design and Simulation perspectives that are built into the Cisco Modeling Labs client cannot be
deleted.

Note

One or more perspectives can exist in a single workspace. If multiple perspectives are opened at the same
time, you can choose whether to layer them, or open them in a separate workspace.
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Working with Perspectives
You can manage the various perspectives defined in the workbench under Perspectives preferences, choosing
File > Preferences > General > Perspectives.

Figure 4: Perspective Preferences

The following table describes the Perspectives options:

Table 2: Perspectives Options

DescriptionOption

Defines whether a new perspective opens in the current workbench, or opens
in a newwindow. By default, a new perspective opens in the current workbench.

Open a new perspective

Defines whether a new view opens within the current perspective, or opens
docked beside the current perspective (fast view). By default, a new view opens
within the current perspective.

Open a new view

Defines perspective behavior when a new project is created. By default, a new
project opens the perspective in the same workbench.

New project options

The following table describes the Available Perspectives options:
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Table 3: Available Perspectives Options

DescriptionOption

Sets the selected perspective as the default perspective.Make Default

Resets the definition of the selected perspective to the default configuration. This
option is only applicable to system-defined perspectives.

Revert

Deletes the selected perspective. This option is only applicable to user-defined
perspectives. (System-defined perspectives cannot be deleted.)

Delete

Customizing Perspectives
Cisco Modeling Labs 1.0 provides two perspectives for use in the workspace: the Design perspective and the
Simulation perspective. These perspectives display various views and settings that cannot be changed, nor
can they be deleted from the Cisco Modeling Labs 1.0 client. You can, however, customize additionalDesign
and Simulation perspectives for your specific needs.

From the View menu, you can open additional views and arrange them in your perspective. The views can
be arranged by dragging them around the workspace. When finished, you can save the perspective.

Right-click the applicable perspective tab to open the context menu, and then click ShowText. TheDesign
perspective and the Simulation perspective buttons will be displayed as text labels instead of icons only.

Note

Step 1 Open the Design perspective or Simulation perspective in your workspace.

Use this as an initial template from which to create a customized perspective.

Step 2 To add new views, open the View menu to display the various views for use.
Views already in use are shown as dimmed in the list.

Step 3 To add node information, double-click a node to add a Node Editor in the perspective.
Step 4 Click and drag the views and Node Editors to different positions within the workspace. For example, you can move

each node's Console view so they are either side-by-side, or stacked in tabs.
Step 5 When you are finished arranging the workspace, right-click the applicable perspective button, and then click Save As.

You are prompted to name the new perspective.
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Step 6 Enter a name for the perspective and click OK.

Design Perspective
The Design perspective allows you to create and design your topologies. By default, the Design perspective
incorporates the components listed here because they are the most widely used. However, you can customize
a Design perspective to include a different set of components.

• Palette view—Provides the node types, connection types, and sites used to design a topology.

• Projects view—Lists topology projects, subfolders, and files defined from the workbench.

• History view—Lists changes made to a file based on date and time stamp.

• Properties view—Identifies node and interface properties.

• Outline view—Lists structural elements of a topology.

• Node Editor—Identifies nodes, node connections, and node interfaces.

• Topology Editor—Develops a network topology.

• Graph Overview—Provides methods for viewing a network topology.

To customize a new Design perspective, choose the desired components from the View menu (for example,
View > Other > Cisco Terminal), and then drag that component view to the desired location within the
workbench. When you are done adding components to the workbench and the component views are laid out
as desired, select Save As from the Design toolbar and enter a name for the new Design perspective.

From the Design perspective, right-click the Design icon. This displays the following menu options:

Table 4: Design Perspective Context Menu Options

DescriptionOperation

Saves the customized workbench layout, views, and editors as a new Design
perspective.

Save As

Resets the current perspective to display the workbench design that was used when
the workbench was first opened.

Any open editors, for example, Node Editor, are not closed when a perspective
is reset. You must close them manually.

Note

Reset

Closes the current perspective. You can reopen it using the Open Perspective tool,
which is located at the upper right corner of the window.

Close

Shows perspective names in the toolbar instead of icons, when selected.
When deselected, shows perspective icons in the toolbar instead of names.

Show Text
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Simulation Perspective
The Simulation perspective opens after you launch a simulation; you are prompted to switch to the Simulation
perspective. Switching to the Simulation perspective means that you can now connect to your running nodes
in the Simulations view. By default, it incorporates the Topology Editor, Projects view, Simulations view,
Console view, and Terminal view.

From the Simulation perspective, right-click the Simulation icon. This, displays the following menu options:

Table 5: Simulation Perspective Context Menu Options

DescriptionOperation

Saves the current perspective.Save As

Resets the current perspective to its original configuration (when the workbench
opened initially).

Any open editors, for example, Topology Editor, are not closed when a
perspective gets reset to its original configuration. They are stacked as tabs
in the default editor area for that perspective.

Note

Reset

Closes the current perspective. (Reopen it using the Open Perspective tool.)Close

Displays perspective icons only. (No text is displayed in the toolbar.)Show Text

Cisco Modeling Labs Client Views
Views provide alternativemethods for presenting topology information and navigating within your workbench.
You can drag the view windows and position them anywhere within the workbench. Some views have their
own toolbars, and some of the tools on these toolbars are specific to the views being presented.

The most commonly used views within the Cisco Modeling Labs client are listed in the following table:

Table 6: Commonly Used Views in the Cisco Modeling Labs Client

DescriptionPerspective Where
Used

View Name

Design—Displays messages from AutoNetkit when it
is used to generate router configurations.
Simulation—Displaysmessage streams from the Cisco
Modeling Labs server after a simulation is launched.

For more information, see Console View, on page 17

Design and SimulationConsole view

Provides you with the ability to view a scaled-down
version of your entire topology.
For more information, see Graph Overview, on page
18

DesignGraph Overview
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DescriptionPerspective Where
Used

View Name

Provides a history of changes made to a file and enables
you to select a previous file version from the list. For
more information, see History View, on page 18

DesignHistory view

Shows a list of the nodes in the topology and their
interface connections.
For more information, see Outline View, on page 20

DesignOutline view

Allows you to add devices and interface connections
to your topology.
For more information, see Palette View, on page 21

DesignPalette view

Displays errors, warnings, and other information that
was detected within the Topology Editor.
For more information, see Problems View, on page
23

DesignProblems view

Provides a hierarchical view of topology projects,
folders, and topologies in the workbench.
For more information, see Projects View, on page 28

Design and SimulationProjects view

Displays names and properties of nodes and interfaces.
For more information, see Properties View, on page
29

DesignProperties view

Displays the results of a search, which can be based on
text strings, regular expressions, and patterns, whole
words and case-sensitive characters.

For more information, see Search View, on page 38

DesignSearch view

Displays information on all running simulations.
For more information, see Simulations View, on page
40

SimulationSimulations view

Displays console information when you connect to a
node using Telnet.
For more information, see Terminal View, on page 45

SimulationTerminal view
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Console View
The Console view displays message streams from the Cisco Modeling Labs server after a simulation is
launched. It also displays messages from AutoNetkit when it is used to generate router configurations.

Figure 5: Console View

The Console view toolbar contains the following tools:

Figure 6: Console View Toolbar

Table 7: Available Tools

DescriptionFunctionIcon

Removes all the information from the Console view.Clear Console

Switches scrolling on and off.Scroll Lock

Pins the Console view to the workbench so that
subsequent message streams are shown in another
Console view. The pinned view remains unchanged.

Pin Console

Displays theConsole view for the selected simulation.Display Selected Console

Opens a new Console view.Open New Console

Cisco Modeling Labs 1.0 User Guide    
   OL-32056-01 17

Using the Cisco Modeling Labs Client
Cisco Modeling Labs Client Views



DescriptionFunctionIcon

Reduces the size of the Console view.Minimize

Increases the size of the Console view.Maximize

When several simulations are running, use the toolbar buttonDisplay Selected Console to toggle between
the Console views for the different simulations.

Note

Graph Overview
Graph Overview enables you to view a scaled-down version of your entire topology. A blue rectangle
(representing an overlay) is used to indicate a portion of the topology that is currently being displayed in the
Topology Editor. Using this overlay, you can easily see where the displayed portion sits in relation to the
entire topology.

The Graph Overview also allows you to navigate around a large topology when it is either too large to fit
into the canvas, or is zoomed in and not fully displayed on the canvas.

Figure 7: Graph Overview

From theGraph Overview, click and drag the overlay to pan around your topology. As you drag the overlay,
the corresponding content is reflected in the Topology Editor.

History View
When you create or modify a file, a history of record is maintained and a copy of the modified file is stored
locally. This allows you to replace the current file with a previous version, or restore a file that has been
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deleted. You can also use the History view to compare the changes that were made to the local files. Each
file's history, which is stored locally, is uniquely represented by the date and time at which the file was saved.

Only changes made to topology files (.virl) are retained locally, changes made to projects and folders are
not.

Note

Figure 8: History View

To view the change history of a file, in the Projects view, right-click the applicable file and choose Team >
Show Local History.

The History view displays a list of revision times, with the most recent one highlighted at the top of the list.

If you have a .virl file opened in the workbench, click theHistory tab to view the list of changes made to
the file.

Note

The History view toolbar contains the following tools:

Figure 9: History View Toolbar

Table 8: Available Tools

DescriptionFunctionIcon

Refreshes the contents of the view, retrieving the latest history
information for a file from the system.

Refresh

Toggles when the History view selection is linked to the
active editor.When this option is selected, changing the active
editor automatically updates the History view selection to
the project, folder, and file being edited.

Link with Editor
and Selection
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DescriptionFunctionIcon

Pins the view to the workbench and captures a snapshot of
the file history information. New requests for file history are
opened in a new instance of the History view.

Pin this History
View

Sorts all history items by date. Options are:

• Today

• Yesterday

• This Month

• Previous

GroupRevisions by
Date

Collapses all the history items listed in the hierarchical view.Collapse All

Opens the compare editor for file comparison.Compare Mode

Outline View
TheOutline view shows a list of the nodes in the topology and their interface connections. Node connectivity
is shown through their interface connections.

Figure 10: Outline View
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The Outline view toolbar contains the following tools:

Figure 11: Outline View Toolbar

Table 9: Available Tools

DescriptionFunctionIcon

Allows you to choose various options when displaying
connections:

• Hide Connections—No connections are shown.

Show Selected Connections—Displays only the
connections that are selected in theTopology Editor.

• Show Intra-Topology Connections—Displays only
the connections between the sites in the topology.

• Show Inter-Topology Connections—Displays only
the connections that are within a site.

• ShowAll Connections—Displays all the connections
for all the nodes in the topology.

ChangeDisplayMode
of Connection

Sorts and lists the node names in alphabetical order.Sort Alphabetically

Sorts and lists the node types in alphabetical order.Sort By Node Type

Expands nodes, interfaces, and connections in the
hierarchical view.

Expand All

Collapses all of the items in the hierarchical view.Collapse All

Palette View
The Palette view allows you to add devices and interface connections to your topology. Using the Palette
view, you can:
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• Add nodes, multipoint connections, L3 external Secure NetworkAddress Translation (SNAT) connections,
and L2 external (Flat) connections to your topologies.

• Select nodes and connections for repositioning on the canvas.

• Create connections between node interfaces.

• Group nodes into sites.

Figure 12: Palette View

The Palette view is divided into the following categories:

• Tools—Contains the Select and Connect tools. The Select tool allows you to select nodes, multipoint
connections, L3 external (SNAT) connections, and L2 external (Flat) connections on the Topology
Editor canvas. The Connect tool creates connections between node interfaces.

TheFile >Preferences >Topology Editor setting affects how the nodes and connections
are placed on the canvas. If you check the Revert back to the palette's default tool,
check box, you must click a node, connection, or other object each time you place an
object on the canvas. If the Revert back to the palette's default tool, check box is not
checked, each time you click the canvas, an object is placed until you click the Select
tool (the default palette tool).

Note

• Nodes—Contains the node types available for use in topologies. Currently, Cisco Modeling Labs 1.0
includes the Cisco IOSv virtual image.
An Ubuntu 14.04 server has been tested with Cisco Modeling Labs 1.0. The Ubuntu server must be
downloaded separately. To access the server, go to:

http://cloud-images.ubuntu.com/trusty/current.

From this page, download the clouding-amd64 RAW (img) image
trusty-server-cloudimg-amd64-disk1.img.
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Additional node subtypes can be installed separately. See the Release Notes for Cisco
Modeling Labs 1.0 for the most up-to-date list of supported virtual images.

Note

• General—Contains the different types of connection functions that are supported for nodes. Options
are:

◦Multipoint connections

◦Layer 3 (L3) external connections

◦Layer 2 (L2) external connections

You can also create sites.

The Palette view toolbar contains the following tools:

Figure 13: Palette View Toolbar

Table 10: Available Tools

DescriptionToolIcon

Reduces size of Palette view.Minimize

Increases size of Palette view.Maximize

Problems View
The Topology Editor automatically detects errors, warnings, or other information that are displayed on the
topology elements in the Topology Editor and Node Editor. These markers can be viewed in the Problems
view.
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By default, the Problems view displays all the errors and warnings for all the topologies in the Projects
view, not just the currently open topology. From the Problems view toolbar, choose ViewMenu > Show
> Errors/Warnings on Project to filter only those errors and warnings that are applicable to the current
project. Alternatively, you can also use the Configure Contents dialog box, which is accessible from the
ViewMenu option, to filter warnings and errors associated with a particular topology or topology project.
See Problems View Toolbar for more information.

Note

Figure 14: Problems View

The Problems view groups errors and warnings by severity, with the most critical issues listed first.

Double-click the problem marker in the Problems view, which opens the appropriate editor in the Cisco
Modeling Labs client. If the problem relates to an XML file, the XML file opens in a text editor. The problem
is highlighted, allowing you to quickly identify the issue and correct it.

Figure 15: Problem Example

The Problems view toolbar contains the following tools:

Figure 16: Problems View Toolbar
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Table 11: Available Tools

DescriptionFunctionIcon

The Problems view tool has the following options:

• Show—Displays errors and warnings.

• Group By—Groups problems under the headings Type,
Severity, and None. The default is Severity.

• Sort By—Sorts problems under the following headings:

◦Description—Details the problem encountered.

◦Resource—Displays the name of the .virl file where
the problem has occurred.

◦Path—Displays the applicable project folder.

◦Location—Displays the location in the .virl file where
the problem has occurred.

◦Type—Displays the type of problem, for example,
XML problem.

• New Problem View—Opens a new Problems view on the
workbench.

• Configure Contents—Opens the Configure Contents
dialog box where you can add multiple filters to the
Problems view and enable or disable them, as required.
Filters can either be additive or exclusive. The All
Errors/Warnings on Selection filter is provided by default.

• Configure Columns—Opens the Configure Columns
dialog box where you can choose to hide or show specific
information about the problem encountered, as shown in the
Sort By option. Options are:

◦Creation Time—Displays the timewhen the problem
occurred.

◦Description, ID—Displays the system-generated ID
for the problem, location, path, resource, and type.

View Menu

Reduces the size of the Problems view.Minimize

Increases the size of the Problems view.Maximize
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The Quick Fix Option

Problems displayed in the Problems view are provided with aQuick Fix option, if available. A Quick Fix is
indicated by a light-bulb icon that is visible on the marker. When this option is selected, you are presented
with one or more possible fixes.

We recommend that you use Quick Fix to resolve the errors discovered, unless the errors have been deliberately
created for testing purposes.

Figure 17: Quick Fix

To fix a problem:

1 Right-click the line containing the problem, and select Quick Fix.
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The Quick Fix dialog box displays a list of possible solutions.

Figure 18: Quick Fix Dialog Box

2 Select a fix from the list, and then check the check box of any of the Resources listed in the Problems
area. You can click Select All to apply the Quick Fix to all the Resources listed. Alternatively, you can
click Deselect All to clear all selections.

3 Click Finish.

Once a problem has been fixed using the Quick Fix option, the action cannot be undone.Note
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Projects View
TheProjects view provides an hierarchical view of topology projects, folders, and topologies in the workbench.
From here, you can open topologies for editing, or select resources for operations, such as exporting.

Figure 19: Projects View

Right-click any topology in the Projects view to open a context menu using which you can copy, move, and
create new topology files, view comparison files, and so on.

The Projects view toolbar contains the following tools:

Figure 20: Projects View Toolbar

Table 12: Available Tools

DescriptionFunctionIcon

Collapses the hierarchy of all the resources in the Projects view.Collapse All

Links the Projects view with an active editor. A change to an
active editor automatically updates the Projects view and allows
you to toggle between the two views.

Link with
Editor

Provides options for customizing the content displayed in the
Projects view. Options are:

• Sort by filters

• Sort by content

View

Reduces the size of the Projects view.Minimize
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DescriptionFunctionIcon

Increases the size of the Projects view.Maximize

The Projects view displays several icons on the toolbar:

Table 13: Project View Icons

DescriptionNameIcon

Indicates an open topology project.Topology Project

Indicates an open folder. Folders are created within a
Topology Project so that topology files can be organized
into separate areas for greater accessibility.

Folder

Indicates a topology file.Topology

Properties View
The Properties view displays the names and properties of nodes and interfaces. If no specific node or interface
is selected, the Properties settings apply globally to all the nodes and interfaces within a topology. If a specific
node or interface is selected, the Properties settings apply to only that node or interface.

Figure 21: Properties View
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The Properties view toolbar contains the following tools:

Figure 22: Properties View Toolbar

Table 14: Available Tools

DescriptionFunctionIcon

Shows the available property categories.Show Categories

Shows all advanced properties.ShowAdvancedProperties

Restores the default value for the property.Restore Default Value

Pins this property view to the current selection.Pin to Selection

Displays menu items that allow you to:

• Open a new property view.

• Pin the property view to the current selection.

View Menu

Reduces the size of the Properties view.Minimize

Increases the size of the Properties view.Maximize

The properties in the Properties view are discussed in the following sections:

• Node Properties, on page 31

• Topology Properties, on page 33
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Node Properties

When you select a node on the canvas, the properties for that node are displayed in the Properties view.

Figure 23: Node Properties

Under the Node tab, you can perform the following tasks:

Table 15: Node Properties

DescriptionProperty

Specify a name for the node.
Use only alphanumeric characters for node names. Node names must be unique
across the entire topology. Duplicate node names cause the build to fail when the
configuration is autogenerated. If a duplicate node name is defined, a marker is
shown in the Problems view. Unicode is not supported for node names. The use
of a period in a node name may cause the node name to wrap when viewing the
hierarchy from the Cisco Modeling Labs server. When you update a node name
in the Node Properties view, the node name is not updated in the Node Editor.

Note
Name

Specify a subtype from the list. Cisco Modeling Labs 1.0 includes a Cisco IOSv virtual
image. Additional Cisco virtual images are available for use. However, they must be
installed separately. For a list of supported subtypes, see the Release Notes for Cisco
Modeling Labs 1.0.
An Ubuntu 14.04 server has been tested with CiscoModeling Labs 1.0. The Ubuntu server
must be downloaded separately. To access the server, go to:

http://cloud-images.ubuntu.com/trusty/current.

From this page, download the clouding-amd64 RAW (img) image
trusty-server-cloudimg-amd64-disk1.img.

Use theManage Subtypes tool to add or remove node subtypes from the list.

When changing a node subtype after it is initially configured using AutoNetkit,
for example, changing it from Cisco IOSv to Cisco IOS XRv, you need to
re-validate the AutoNetkit properties for the new node subtype.

Note

Subtype

Specify an IPv4 loopback address. The loopback address is added to the router as interface
loopback0. Enter a valid IP address in the correct format.

IPv4

Specify an IPv6 loopback address. The loopback address is added to the router as interface
loopback0. Enter a valid IP address in the correct format.

IPv6
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DescriptionProperty

Specify a virtual machine (VM) image other than the default. Click Browse to choose a
valid VM image from the Select VM Image dialog box.

VM Image

Specify a VM flavor other than the default. Click Browse to choose a valid VM flavor
from the Select VM Flavor dialog box.

VM Flavor

Under theAutoNetkit tab, when you check theAuto-generate the configuration based on these attributes
check box, the AutoNetkit generates the configuration for your topology when you click the Update Router
Configurations icon on the toolbar.

Any pre-existing configuration for a node is overwritten when you chooseUpdate Router Configurations
from the toolbar. Uncheck this Auto-generate check box if you do not want router configuration for a
node updated by AutoNetkit.

Note

Using the properties listed, you can perform the following tasks:

Table 16: AutoNetkit Properties

DescriptionFieldsProperty

Specify the autonomous system number, which is used to infer IGP and BGP
and should be any valid integer.

ASNGeneral

Configure an OSPF area. The default value is 0.OSPFIGP

Specify an iBGP role from the list and use it to create an iBGP topology. Options
are:

• Not specified

• Disabled

• Peer

• Route Reflector (RR)

• Hierarchical Route Reflector (HRR)

• Route Reflector Client (RRC)

The default value is Peer.

iBGP RoleiBGP

Specify the RRC as a name or number. Should be an alphanumeric string.RR Cluster

Specify the HRR Cluster. Should be an alphanumeric string.HRR Cluster

Specify an MPLS VPN name for VRF Lite.VRF NameMPLS
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DescriptionFieldsProperty

Configure MPLS Traffic Engineering. Options are:

• Unspecified

• True

• False

The default value is False.

Enable MPLS
TE

Specify a username for the server.Server
Username

Server

Specify a secure shell key for the server.
An SSH key is required only if you want to connect to the VM server
within the topology using an external application. Using the VNC
option does not require an SSH key to be specified.

Note
SSH Key

Information displayed under the Configuration tab, depends on whether or not the Auto-generate the
configuration based on these attributes check box under the AutoNetkit tab is checked.

•When checked, AutoNetkit generates the configuration and displays it under the node's Configuration
tab.

•When unchecked, no configuration information is created for the node. You must configure the node
manually, or cut and paste the existing configuration information into this area.

Under the Extensions tab, all the extensions used to generate the configuration are listed along with Key,
Value, and Type attributes.

Topology Properties

When you select an area on the canvas other than a node, the properties for that topology are displayed in the
Properties view.

Figure 24: Topology Properties

Under the Topology tab, you can perform the following tasks:
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Table 17: Topology Properties

DescriptionProperty

Specify the rule type with which the topology is validated. Options are:

• Not specified

• VXR

• VIRL

For CiscoModeling Labs 1.0, we recommend you accept the default value,Not specified.

Validation
Rules

Specify the type of Out of Band (OOB) external network access. Options are:

• Not specified—No OOB external network access

• Shared Flat Network—Enables OOB external network access to all the devices in
the topology

• Private User Network—Enables OOB external network access using Network
Address Translation (NAT)

Management
Networks

TheNodes,Multipoint Connections, and Simple Connections properties are for information purposes only
and are useful when monitoring the size of the topology to your current user quotas or licensing limits or both.

Nodes in this instance includes node subtypes, Flat, and SNAT port groups.Note

Under the AutoNetkit tab, you can perform the following tasks:

Table 18: AutoNetkit Properties

DescriptionFieldsProperty

Configure the Cisco Discovery Protocol (CDP). Options are:

• True

• False

The default value is False.

Enable CDPGeneral

Configure the Cisco One Platform Kit (onePK). Options are:

• True

• False

The default value is False.

Enable onePK
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DescriptionFieldsProperty

Configure a routing session to use IPv4 address prefixes, IPv6
address prefixes, dual stack (includes both native IPv4 and IPv6),
or none. Options are:

• Not specified

• None

• v4

• v6

• dual_stack

IP Address FamilyAddressing

Specify the address to use for IPv4 infrastructure address allocations.
This is the address assigned to the interface created on the router.
The default value is 10.0.0.0. Enter a valid IP address in the correct
format.

IPv4 Infrastructure
Subnet

Specify the prefix to use for IPv4 infrastructure address allocations.
The default value is 8. Enter a valid IP address in the correct format.

IPv4 Infrastructure
Prefix

Specify the address to use for IPv4 loopback address allocations.
The default value is 192.168.0.0. Enter a valid IP address in the
correct format.

IPv4Loopback Subnet

Specify the prefix size to use for IPv4 loopback address allocations.
The default value is 22. Enter a valid IP address in the correct format.

IPv4 Loopback Pool

Specify the address to use for IPv4 VRF address allocations, when
specifying the address range for MPLS VRF. The default value is
172.16.0.0. Enter a valid IP address in the correct format.

IPv4 VRF Subnet

Specify the prefix to use for IPv4 VRF address allocations. The
default value is 24.

IPv4 VRF Prefix

Configure routing protocols (BGP and IGP). Options are:

• Not specified

• True

• False

The default value is True. If you specify False, there will be no
router configuration for any of the routing protocols.

Enable Routing
Protocols

Routing

Configure the Interior Gateway Protocol (IGP). Options are:

• OSPF

• ISIS

• EIGRP

IGP
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DescriptionFieldsProperty

Configure MPLS OAM for all routes on the topology. Options are:

• Not specified

• True

• False

The default value is False.

Enable MPLS OAMMPLS

The following table shows the default IP Address values used by Cisco Modeling Labs. You can update these
values as required.

Table 19: IP Address Default Values

Optional Value(s)Default ValueOptionViewed from

None, v6, dual_stackv4IP Address FamilyTopology > AutoNetkit
> Addressing

10.0.0.0IPv4 Infrastructure Subnet

8IPv4 Infrastructure Prefix

192.168.0.0IPv4 Loopback Subnet

22IPv4 Loopback Pool Prefix

172.16.0.0IPv4 VRF Subnet

24IPv4 VRF Prefix

In Cisco Modeling Labs 1.0, AutoNetkit IPv6 handling code does not support the following:

• The ability to manually specify IPs.

• The ability for users to specify the IPv6 range in the Cisco Modeling Labs client.

• The ability to divide out the allocation logic to permit both infrastructure and loopback to be automatically
or manually created for either combination.

The following table shows the default routing protocols used by Cisco Modeling Labs. You can update these
values as required.

Table 20: Routing Protocols Default Values

Optional Value(s)Default ValueOptionViewed from

truefalseEnable CDPTopology >AutoNetkit
> General

truefalseEnable OnePK
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Optional Value(s)Default ValueOptionViewed from

falsetrueEnable Routing ProtocolsTopology >AutoNetkit
> Routing

isis, eigrpospfIGP

truefalseEnable MPLS OAMTopology >AutoNetkit
> MPLS

None or any valid integer1ASNNode > AutoNetkit >
General

None or valid OSPF area
number

0OSPF AreaNode > AutoNetkit >
IGP

Disabled, RRC, HRR, RRPeeriBGP RoleNode > AutoNetkit >
iBGP

None or alphanumeric string(none)RR Cluster

None or alphanumeric string(none)HRR Cluster

None or alphanumeric string(none)VRF NameNode > AutoNetkit >
MPLS

truefalseEnable MPLS TE

Valid username(none)Server UsernameNode > AutoNetkit >
Server

(none)(none)Server SSH Key

Only one IGP protocol is supported per simulation. Even though you can create multiple BGP ASs, the
choice of IGP applies to all router devices in the simulation.

Note

Under the Extensions tab, all the extensions used to generate the configuration are listed, along with theKey,
Value, and Type attributes.

Interface Properties

In theNode Editor, selecting an interface on the canvas displays properties for the interface in the Properties
view.

Under the Interface tab, you can perform the following tasks:

Table 21: Interface Properties

DescriptionProperty

Specify a name for the interface.Name

Specify an IPv4 interface address and an IPv4 subnet prefix length.IPv4
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DescriptionProperty

Specify an IPv6 interface address and an IPv6 subnet prefix length.IPv6

To delete an interface from the Node Editor canvas, select the interface, right-click and choose Delete
from the context menu.

Note

Under the Extensions tab, all the extensions used to generate the configuration are listed, along with theKey,
Value, and Type attributes.

Connection Properties

When you select a connection on the canvas, the properties of that connection are displayed in the Properties
view.

From Connection properties, you can associate a line style design with a connection between nodes. Line
styles are visual aids that help you identify the connections used in your topology design.

Search View
To search for text string and files, click Search on the toolbar. The Search view displays the results of a
search. A file search can be based on text strings, regular expressions, and patterns, in addition to whole words
and case-sensitive characters. The scope of a file search can encompass a workspace, selected resources, or
projects.

Text searches are only performed on expressions contained in files with the extension .virl.Note

The Search view also displays the results of a Git search that can be based on the same criteria as noted in a
File search. However, the scope of a Git search can encompass a particular message, resource, or identification
number in the code.

Search criteria can be based on either a file or Git. The scope of a search can be general to all the topologies
that are defined on Cisco Modeling Labs client, or specific to a particular project or file.

Figure 25: Search View
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To use the search functionality, perform the following tasks:

1 From the Cisco Modeling Labs client toolbar, click Search > File.
The Search dialog box appears.

2 In the Containing text field, enter the text string to search for. The Containing text field displays a list of
recently performed searches to select from. Leave this field empty if you want to search for files only.
Check or uncheck the Case sensitive check box depending on whether or not a case-sensitive search is to
be performed. You can also check the Regular expression check box to enable more powerful searching
capabilities. Check theWhole word check box if you want to search for whole words that are identical
to the text string. Specify the types of files to include in the search in the File name patterns field.

3 Click Choose to open the Select Types dialog box. This dialog box provides a quick way to select from
a list of valid extensions.

4 In the Scope area, specify the files and folders to include in the search. Valid options are:

• The entire workspace

• The currently selected resources in the workspace

• A named working set

• A customized group of files and folders. Use the Customize option to define the type of available
searches from the Search Page Selection dialog box.

5 Click Search to begin your search.
The Search view appears with the results of the search listed. You can click theCancel tool in the Search
view to cancel your search while it is still in progress.

The Search view toolbar contains the following tools:

Figure 26: Search View Toolbar

Table 22: Available Tools

DescriptionFunctionIcon

Deletes all the highlighted matches from the search results.Remove Selected
Matches

Deletes all the matches from the search results.Remove All
Matches

Expands each item in the Search view.Expand All
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DescriptionFunctionIcon

Collapses each item in the Search view.Collapse All

Reruns the current search to retrieve previous search results or
to reflect recent changes.

Run the Current
Search Again

Cancels the search currently running.Cancel Current
Search

Browses previously conducted searches to repeat a previous
search, by selecting a previous search from the drop-down
menu. You can also clear the search history.

Show Previous
Searches

Pins the Search view so that subsequent search results are
displayed in a separate Search view with the pinned view
unchanged, in order to compare results.

Pin the Search
View

Displays the search results as a tree or a list, filters the results
using the Filters option, and sets the overall preferences for
search using the Preferences option.

View Menu

Reduces the size of the Search view.Minimize

Increases the size of the Search view.Maximize

Simulations View
The Simulations view displays information about all the running simulations, including:

• Name of the user running the simulation

• Name of the topology

• Number of nodes in the running simulation
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• Current state of each node

Figure 27: Simulations View

Possible simulation states are:

Table 23: Simulation States

DescriptionState

Indicates that the launchworker process has successfullymade all requests
to OpenStack to deploy all simulation nodes.

ACTIVE

Indicates that a simulation has been successfully stopped and no longer
exists in the STD database.

DONE

Indicates that the launch worker process failed.FAIL

Indicates that the simulation has just been created and is being launched.INIT

This is a two-phase state: i) Necessary DB entries are created in the
middleware and ii) Required networks are deployed.
Failure in this phase results in the removal of the simulation; success
results in the start of a launch worker process.

LAUNCHING

Indicates that a stop simulation request has been received.STOP

Possible node states are:

Table 24: Node States

DescriptionState

Indicates that the virtual machine process is successful. It may take a few
minutes for the node to boot up and configure.

ACTIVE

Indicates that the virtual machine is starting, but the router image has not
yet loaded.

BUILD

Indicates that the node has been requested for BUILD, but OpenStack
has no information on the node at this time. Possibly, it was deleted. The
node can be started when the simulation itself is ACTIVE.

DELETED

Indicates that the virtual machine process failed.ERROR
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DescriptionState

Indicates that the virtual machine is in an unused state.IDLE

These two states can occur when:

• The host environment is rebooted.

• The node itself shuts down.

• The operating system of the node crashes .

• The virtualization process running the node crashes.

In such instances, the appropriate action is to stop the nodes and then
start the nodes again.

All configuration changes to the nodes are
lost .

Note

PAUSED and SUSPENDED

Indicates that the virtual machine is deployed but not actually running.
This state can occur when:

• The host environment is rebooted.

• The node itself shuts down.

• The operating system of the node crashes .

• The virtualization process running the node crashes.

In such instances, the appropriate action is to stop the nodes and then
start the nodes again.

All configuration changes to the nodes are
lost.

Note

SHUTOFF

Indicates that the node has never requested to be deployed in OpenStack
(started) or the request failed. This only occurs when the launch worker
process is active but has not reached that specific node yet, or if the
simulation is in the FAIL state.

UNDEPLOYED

The Simulations view toolbar contains the following tools:

Figure 28: Simulations View Toolbar

Table 25: Available Tools

DescriptionFunctionIcon

Refreshes the list of simulations displayed in theSimulations
view.

Refresh the List
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DescriptionFunctionIcon

Reduces the size of the Simulations view.Minimize

Increases the size of the Simulations view.Maximize

Topology Options

The following operations are available, when you right-click the topology name in the Simulations view:

Figure 29: Topology Options

Table 26: Topology Options

DescriptionOperation

Opens the Console view, showing the message stream from Cisco Modeling
Labs server for the selected topology. Message streams contain information
on the topology launch, such as, the name of the launched topology, the date
and time of the launch, and the current status of each node in the topology.

Open messages console

Extracts router configurations for all the routers to a file saved locally.
All active console connections are automatically disconnected by
Cisco Modeling Labs. All external Telnet connections to the console
ports must be closedmanually. The Stop simulation operation cannot
be selected prior to the Extract configurations operation.

Note
Extract configurations

Stops the running simulation. See the chapter Simulate the Topology Overview
for more information on stopping and starting simulations.

Stop simulation
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Node Options

The following operations are available, when you right-click the node name in the Simulations view:

Figure 30: Node Options

Table 27: Node Options

DescriptionOperation

Allows you to connect using Telnet to ports on a node.Telnet

Allows you to connect using Telnet over a web socket to ports on a node.Web sockets
provide full-duplex communications channels over a single connection.

Telnet over Web
Socket

Displays a server Virtual Network Computing (VNC) login page.
This operation applies to the server
only.

Note
Attach to its VNC

Stops the selected node.Stop this node

Starts the selected node. See the section Start a Single Node for more information.Start this node
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Terminal View
The Terminal view is displayed when you connect via Telnet to a node. Using the Terminal view, you can
communicate with and control the operating system running on the node.

Figure 31: Terminal View

The Terminal view toolbar contains the following tools:

Figure 32: Terminal View Toolbar

Table 28: Available Tools

DescriptionFunctionIcon

Disconnects the terminal connection to the node.Disconnect

Sets scrolling on and off.Scroll Lock

Allows you to select a connection from the list of
active terminal connections.

Display SelectedConnections

Closes the Terminal view.Remove Terminal
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DescriptionFunctionIcon

Allows you to set the font to be used in the
terminal, from the Colors and Fonts dialog box.

You can also access theColors and Fonts
dialog box by choosing File >
Preferences >General > Appearance >
Colors and Fonts.

Note

Set Terminal Font

Setting Preferences for the Cisco Modeling Labs Client
For the Cisco Modeling Labs client to operate, you must first identify certain setting preferences. These
preferences are available from the menu bar under File > Preferences:

• Node Subtypes Setting, on page 46

• Terminal Setting, on page 50

• Topology Editor Setting, on page 52

•Web Services Setting, on page 53

• AutoNetkit Visualization Setting, on page 55

•Web Browser Setting, on page 58

• Secure Storage Setting, on page 59

These are discussed in the following sections.

Node Subtypes Setting
A node subtype defines a virtual machine running a particular operating system. For example, Cisco IOSv is
installed with CiscoModeling Labs, while others such as Cisco IOSXRv and Cisco CSR1000v can be installed
separately. This setting allows you to add and remove node subtypes for use with the Cisco Modeling Labs
client.
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Refer to the chapter User Workspace Management in the Cisco Modeling Labs Corporate Edition System
Administrator Installation Guide for information on installing virtual machine images on the Cisco Modeling
Labs server.

Figure 33: Node Subtypes Setting

The available operations for this setting are:

Table 29: Node Subtypes Setting Operations

DescriptionOperationIcon

Adds a new subtype to the list. To ensure that the new
subtype is visible in the Palette view, set the value in the
Show in Palette column to true. See Adding a New Node
Subtype to the List, on page 48.

Add new Subtype

Removes a subtype from the list.Remove Subtype
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DescriptionOperationIcon

Updates the local subtypes based on the currently configured
Cisco Modeling Labs server. All the subtypes supported on
Cisco Modeling Labs server are available with this
operation. See Fetching Node Subtypes from the Cisco
Modeling Labs Server, on page 49.

Fetch from Server

Reverts to the original list of subtypes.Restore Defaults

Applies changes.Apply

Adding a New Node Subtype to the List
To add a new node subtype to the node subtype list, perform the following tasks:

Step 1 Click File > Preferences > Node Subtypes.
Step 2 Click the Add new subtype button.

a) In the Name column, enter a name for the new node subtype, for example, Server_Block1.
b) In the Icon column, select an icon type from the drop-down list, for example app_server.
c) In the Show in Palette column, click to select True to display the node subtype in the Palette view, else select False.
d) In the Interface name format column, enter a name for the interface format, for example eth{0}.
e) In theMin interface column, enter the minimum number of interfaces permissible for the node subtype, for example,

1.
f) In theMax interface column, enter the maximum number of interfaces permissible for the node subtype, for example,

25.

Figure 34: New Node Subtype Added
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Step 3 Click Apply and OK to save the updates.

The newly added node subtype is available for use in the Palette view.

Figure 35: New Node Subtype Visible in the Palette View

Fetching Node Subtypes from the Cisco Modeling Labs Server
To fetch new node subtypes from the Cisco Modeling Labs server, perform the following tasks:

Step 1 Click File > Preferences > Node Subtypes.
Step 2 Click the Fetch from Server button.

The Confirm dialog box is displayed.
Step 3 Click OK to update the list of node subtypes.

Figure 36: Fetch Nodes Subtypes from Server

Step 4 Click OK to finish.
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The updated list of node subtypes is available for use in the Palette view.

Figure 37: Updated List of Node Subtypes Visible in the Palette View

Contact your system administrator if a specific node subtype is missing from the list, as the system administrator
is responsible for adding new node subtypes to the Cisco Modeling Labs server.

Terminal Setting
This setting allows you to launch an external terminal application, such as, SecureCRT or PuTTY, or use the
internal Cisco Modeling Labs client Terminal view in a separate window.
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Note • If you are using the internal Cisco Modeling Labs Terminal view, the views are visible from both
theDesign or Simulation perspective. However, a detached view is only visible from the perspective
in which it was detached.

• If you are using an external terminal application, you must specify both Telnet and SSH run
commands. Youmust also ensure that the title format includes the percentage (%) character. Omission
of either of these requirements will impede your ability to save your setting preferences.

•When you specify to use an external terminal via File > Preferences > Terminal > Cisco Terminal
and then Telnet over Web Socket to a virtual machine, the terminal opens internally, not externally
as specified.

Figure 38: Terminal Setting

The available operations for this setting are:

Table 30: Terminal Setting Operations

DescriptionOperation

Launches the Terminal view in a separate window.Detached internal Terminal view

Allows you to add a Terminal view title using the required formatting
characters.

Title format

Uses the Cisco Modeling Labs internal Terminal view.Use internal Terminal view
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DescriptionOperation

Uses an external terminal application, such as SSH or PuTTY.Use external terminal application

Specifies the Telnet command to run if you are using an external
terminal application.

Telnet command

Specifies the SSH command to run if you are using an external terminal
application.

SSH command

Removes settings specified for an external terminal application and
restores terminal settings to the CiscoModeling Labs internalTerminal
view.

Restore Defaults

Applies changes.Apply

Topology Editor Setting
This setting allows you to customize the Topology Editor in the Cisco Modeling Labs client.

Figure 39: Topology Editor Setting

The available operations for this setting are:

Table 31: Topology Editor Setting Operations

DescriptionOperation

Resets the definition of the Palette view tools, Select andConnect
to their default configuration. This option is disabled by default.

Revert back to the palette's default
tool
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DescriptionOperation

Enables the following:

•When selected, interfaces are automatically assigned to
connections between nodes.

•When deselected, you are presented with a list of available
interfaces.

Associate new connection with
interfaces silently

Enables the following:

•When the number of connections in the topology exceeds
the value set in this field, the internal algorithm used to
connect nodes will not be the shortest path algorithm.

Disable shortest path algorithm if
connection amount > (greater than)

Restores settings to the initial default state.Restore Defaults

Applies changes.Apply

Web Services Setting
This setting allows you to configure the CiscoModeling Labs client to communicate with the CiscoModeling
Labs server. When you first launch the Cisco Modeling Labs client, the Active profile is not specified and
the Web Services that are listed display an Unauthorized message in red. This message relates to the Master
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Credentials, which must be still be set before the CiscoModeling Labs client can communicate with the Cisco
Modeling Labs server.

Figure 40: Web Services Setting

The available operations for this setting are:

Table 32: Web Services Setting Operations

DescriptionOperation

Identifies an active profile that has been defined on the Cisco Modeling Labs
client. You can define a new active profile, and edit or delete an existing active
profile.

Active profile

Specifies a username and password for accessing the CiscoModeling Labs server.
These credentials are provided by the system administrator.

Master Credentials
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DescriptionOperation

Lists the Web Services needed for the Cisco Modeling Labs server and the Cisco
Modeling Labs client to communicate with each other. The Web Services listed
are:

• Roster

• Simulation Engine

• OpenStack

• AutoNetkit

After you have set up your profile with the correct Base URI, each of the
Web Services will display a Compatible message in green, indicating that
the CiscoModeling Labs client can communicate with the CiscoModeling
Labs server.

Note

Web Services

Encrypts passwords and stores them locally on the Cisco Modeling Labs client.
To change the settings for managing the encrypted passwords, choose File >
Preferences > General > Security > Secure Storage. See the Secure Storage
Setting, on page 59 for more information.

Store encrypted
passwords in system's
secure storage

Restores settings to the initial default state.Restore Defaults

Applies changes.Apply

AutoNetkit Visualization Setting
The AutoNetkit Visualization feature is available only when node configurations are built using the parameters
defined in AutoNetkit. If AutoNetkit Visualization is turned off, you cannot get a true representation of your
topology.

AutoNetkit Visualization is used to determine how AutoNetkit presents graphical representations of
topology-specific attributes, such as nodes, links, and interfaces, during the build phase. The graphical
representations can be presented as a physical perspective of a network topology or based on a protocol
perspective.

For AutoNetkit Visualization to operate, the Cisco Modeling Labs client must be connected to the Cisco
Modeling Labs server. The nodes in the network topology must be set to open AutoNetkit Visualization either
automatically, or after receiving a prompt.
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To access this setting, choose File > Preferences >Web Services > AutoNetkit Visualization.

Figure 41: AutoNetkit Visualization Setting

The available operations for this setting are:

Table 33: AutoNetkit Visualization Setting Operations

DescriptionOperation

Specifies the external web browser to use when displaying AutoNetkit
Visualization results. Options are:

• Default—the default system browser

•WebKit—based on the Safari web browser

•Mozilla Firefox

You are required to useMozilla Firefox, Google Chrome, or Apple
Safari as your default web browser. Internet Explorer is not
supported for AutoNetkit Visualization or for the UserWorkspace
Management interface.

Note

Preferred Web browser
engine

Tests the supported browsers that are available.Test all browser engines
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DescriptionOperation

Specifies whether to view configuration changes after a new build is
generated. Options are:

• Always

• Never

• Prompt

The default value is Prompt.

View configuration changes

Specifies when to open a browser window to display AutoNetkit
Visualization. Options are:

• Always

• Never

• Prompt

The default value is Prompt.

Open AutoNetkit
Visualization

Assigns a port value to the Web Service supporting AutoNetkit
Visualization. The default port is 8000. However, the port might need to
be changed depending on your network, for example, if a firewall is blocking
that port. The port value should be provided by the system administrator.

If an incorrect port value is entered, you will be prompted with an
error during the build stage.

Note

Visualization port

Restores the default state for the preferred web browser engine and restores
the default port value assigned to AutoNetkit Visualization.

Restore Defaults

Applies changes .Apply
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Web Browser Setting
This setting allows you to add, remove, or edit installed browsers. The selected browser is used by default
when web pages are opened in the Cisco Modeling Labs client for AutoNetkit Visualization.

Figure 42: Web Browser Setting

The available operations for this setting are:

Table 34: Web Browser Setting Operations

DescriptionOperation

Allows you to use an internal web browser built into the Cisco Modeling
Labs client to view AutoNetkit Visualization.

Use internal web browser

Allows you to use an external web browser. You can add new browsers,
delete or edit existing browsers, or search for new browsers to use.

You are required to use Mozilla Firefox, Google Chrome, or Apple
Safari as your default web browser. Internet Explorer is not supported
for AutoNetkit Visualization or for the UserWorkspaceManagement
interface.

Note

Use external web browser

Restores settings to the initial default state.Restore Defaults

Applies changes.Apply
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Secure Storage Setting
This setting configures security preferences and encryption requirements for storing system passwords.

Figure 43: Secure Storage Setting

The Password tab pools functionality related to the master password life-cycle and password providers.

The available options are:

Table 35: Password Tab Options

DescriptionOption

Clears cached master passwords from memory.Clear Passwords
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DescriptionOption

Lists the currently available password providers. By default, the enabled
provider with the highest priority is used to encrypt the data added to secure
storage. The priority range is from 0 to 10, with 10 being the highest priority.

Data can only be decrypted by the same provider that encrypted the
data. By default, all password providers are enabled. Each password
provider that has been used at least once will have a master password
associated with it. The Details text box provides information on the
master password providers.

Note

Master password providers

Changes the master password of the selected password provider.Change Password

Opens the password recovery dialog box. Use this option if you have forgotten
the master password and have configured password recovery questions. The
button is disabled if the password recovery setup was cancelled when the
master password was created.

The answers for the password recovery questions must be entered
exactly as they were during the password recovery setup. Answers
are case-sensitive, and white space inside answers are relevant.

Note

Recover Password

Restores to the initial default state.Restore Defaults

Applies changes.Apply

The Contents tab displays contents of the default secure storage. Secure storage is organized as a tree, where
nodes represent the context of information and values associated with each node. Selecting a node in the tree
displays a table of values associated with that node. Values stored in a nonencrypted form will be displayed;
the encrypted values will be shown as *********. At the bottom of this tab, you will find the actual file
location used to persist secure storage data. To force the changes to the contents of secure storage to be saved,
click Save.

To delete stored data in order to recover from an error or to reflect a change in the setup, click Delete. This
deletes the contents of secure storage. In some cases, other parts of the applicationmay depend on the contents
of secure storage that you deleted.

To avoid unexpected errors, we recommend that you restart the application after secure storage has been
deleted.

Caution

TheAdvanced tab provides a list of algorithms to further configure secure storage. Changes in the encryption
algorithm are applied only to the data stored after a change. If you have already created a secure storage, you
must first delete it and then re-create it to use the newly selected encryption algorithm.

Resetting the Secure Storage Password
When the Secure Storage feature is used for the first time, it generates a master password that is used to encrypt
the data. In the future, this same master password will be required to retrieve the data from secure storage. If
the master password becomes unavailable, the Secure Storage feature provides optional support for password
recovery.

Two methods are used to reset the secure storage password.

Method 1
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1 From within Cisco Modeling Labs client, choose File > Preferences > General > Security > Secure
Storage.

2 Click Change Password. The Secure Storage dialog box appears.
3 Click Yes. The Password Recovery dialog box appears.
4 Enter details for Question 1 and Question 2, along with answers for both. Take note of the answers you

provide, as these are treated as secondary passwords.
5 Click OK.

Method 2

If you are unable to access the Cisco Modeling Labs client due to a lost or forgotten secure storage password,
complete the following steps:

1 Move to the <user-home>/.eclipse/org.eclipse.equinox.security folder.
2 Delete the file secure_storage.
3 Open Cisco Modeling Labs client and provide details for the secure storage password, when prompted.
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