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Preface

• Document Conventions, page vii

• Related Documentation, page ix

• Obtaining Documentation and Submitting a Service Request, page ix

Document Conventions
This document uses the following conventions:

DescriptionConvention

Both the ^ symbol and Ctrl represent the Control (Ctrl) key on a keyboard. For
example, the key combination^D orCtrl-Dmeans that you hold down the Control
key while you press the D key. (Keys are indicated in capital letters but are not
case sensitive.)

^ or Ctrl

Commands and keywords and user-entered text appear in bold font.bold font

Document titles, new or emphasized terms, and arguments for which you supply
values are in italic font.

Italic font

Terminal sessions and information the system displays appear in courier font.Courier font

Bold Courier font indicates text that the user must enter.Bold Courier font

Elements in square brackets are optional.[x]

An ellipsis (three consecutive nonbolded periods without spaces) after a syntax
element indicates that the element can be repeated.

...

A vertical line, called a pipe, indicates a choice within a set of keywords or
arguments.

|

Optional alternative keywords are grouped in brackets and separated by vertical
bars.

[x | y]
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DescriptionConvention

Required alternative keywords are grouped in braces and separated by vertical
bars.

{x | y}

Nested set of square brackets or braces indicate optional or required choices
within optional or required elements. Braces and a vertical bar within square
brackets indicate a required choice within an optional element.

[x {y | z}]

A nonquoted set of characters. Do not use quotation marks around the string or
the string will include the quotation marks.

string

Nonprinting characters such as passwords are in angle brackets.< >

Default responses to system prompts are in square brackets.[ ]

An exclamation point (!) or a pound sign (#) at the beginning of a line of code
indicates a comment line.

!, #

Reader Alert Conventions

This document may use the following conventions for reader alerts:

Means reader take note. Notes contain helpful suggestions or references to material not covered in the
manual.

Note

Means the following information will help you solve a problem.Tip

Means reader be careful. In this situation, you might do something that could result in equipment damage
or loss of data.

Caution

Means the described action saves time. You can save time by performing the action described in the
paragraph.

Timesaver

IMPORTANT SAFETY INSTRUCTIONS

This warning symbol means danger. You are in a situation that could cause bodily injury. Before you
work on any equipment, be aware of the hazards involved with electrical circuitry and be familiar with
standard practices for preventing accidents. Use the statement number provided at the end of each warning
to locate its translation in the translated safety warnings that accompanied this device. Statement 1071

SAVE THESE INSTRUCTIONS

Warning
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Related Documentation

Before installing Cisco Modeling Labs 1.0, refer to the Cisco Modeling Labs release notes.Note

These documents provide complete information on Cisco Modeling Labs 1.0:

• Cisco Modeling Labs 1.0 Corporate Edition System Administrator Installation Guide

• Cisco Modeling Labs 1.0 Corporate Edition Client Installation Guide

• Cisco Modeling Labs 1.0 User Guide

• Release Notes for Cisco Modeling Labs 1.0

Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional information,
see the monthlyWhat's New in Cisco Product Documentation, which also lists all new and revised Cisco
technical documentation, at:

http://www.cisco.com/c/en/us/td/docs/general/whatsnew/whatsnew.html

Subscribe to theWhat's New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free
service and Cisco currently supports RSS version 2.0.
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C H A P T E R  1
Overview of Cisco Modeling Labs

• Cisco Modeling Labs, page 1

• Cisco Modeling Labs Server Components, page 2

• Cisco Modeling Labs Client, page 2

• Virtual Images, page 2

• Cisco Modeling Labs Component Requirements, page 3

• Cisco Modeling Labs Framework, page 5

Cisco Modeling Labs
Cisco Modeling Labs 1.0 is a scalable and extensible software platform that enables operators, engineers,
network designers, and architects to design Cisco-based networks and run simulations using virtual versions
of selected Cisco operating systems. Cisco Modeling Labs comprises the Cisco Modeling Labs server and
the Cisco Modeling Labs client. Together, they provide a sandbox environment that facilitates the design,
configuration, visualization, and simulation of network topologies quickly and efficiently.

• Cisco Modeling Labs server—A shared resource containing the capability to initiate topologies using
installed virtual images.

• CiscoModeling Labs client—A point-and-click GUI that simplifies topology creation and initial device
configurations along with continuous updates, and permits access to the Cisco Modeling Labs server
functionality.

• Virtual Images—Cisco Modeling Labs 1.0 includes a Cisco IOSv virtual image. Additional Cisco
virtual images are available for use. However, they must be installed separately. See the Release Notes
for Cisco Modeling Labs 1.0 for the most up-to-date list of supported virtual images.

An Ubuntu 14.04 server has been tested with Cisco Modeling Labs. The Ubuntu server must be
downloaded separately. To access the server, go to:

http://cloud-images.ubuntu.com/trusty/current.

From this page, download the clouding-amd64 RAW (img) image
trusty-server-cloudimg-amd64-disk1.img.
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Together, the virtual images and Ubuntu server provide a powerful platform for creating, modifying,
and testing the virtual network scenarios.

Cisco Modeling Labs Server Components
The Cisco Modeling Labs server is a Linux distribution that is bundled within the VMware Open Virtual
Appliance (OVA) file for VMware ESXi. The bundle includes all the supporting files. The Cisco Modeling
Labs server is a shared resource used by end users to run backend functions, such as router bootstrap
configurations, spinning up routers to operate with designated operating systems, and modifying and testing
configurations.

Cisco Modeling Labs 1.0 comprises a framework of components. The main components are:

• OpenStack—An open-source platform for creating and managing large groups of virtual servers in a
cloud-computing configuration. It is used for node control, management, and networking.

• AutoNetkit—An automated configuration engine that uses templates to provide working router
configurations based on user-supplied and default parameters for each virtual machine.

• Services Topology Director—Generates OpenStack calls for the creation of virtual machines and links
based on the XML topology definition created by the Cisco Modeling Labs client. Additionally, it
provides the bootstrap configuration, which can be auto-generated, generated manually, or imported.

Cisco Modeling Labs Client
The Cisco Modeling Labs client is a cross-platform user interface for creating and editing network designs,
and simulating those network topologies on the Cisco Modeling Labs server. The Cisco Modeling Labs client
offers the following benefits:

• The ability to quickly create and edit complex network topologies in a sandbox, using a graphical
point-and-click editor.

• Access to the build, visualization, and launch functions available in the Cisco Modeling Labs server.

The Cisco Modeling Labs client enables you to interact directly with your running simulations from the user
interface. The Cisco Modeling Labs client also provides the functionality to generate default router
configurations before launching the topology simulation.

For further information on the Cisco Modeling Labs client, see Using the Cisco Modeling Labs Client
Overview, on page 7.

Virtual Images
Cisco Modeling Labs 1.0 includes the Cisco IOSv 15.4(2)T virtual image. The operation and syntax used
with the virtual images are the same as a physical platform running the same software.

See the Release Notes for the Cisco Modeling Labs 1.0 for more information on Cisco IOSv virtual software
supported features.
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Cisco Modeling Labs Component Requirements
The following tables identify the minimum requirements for installing and operating the CiscoModeling Labs
1.0 Corporate Edition. For additional information, see the Cisco Modeling Labs 1.0 Corporate Edition Client
Installation Guide and the Cisco Modeling Labs 1.0 Corporate Edition System Administrator Installation
Guide. These guides provide detailed information on platform requirements for installing and operating Cisco
Modeling Labs 1.0 Corporate Edition for system administrators and end users.

Table 1: Server Hardware Requirements

DescriptionRequirement

Server with a capacity to run 30-40 nodesSmall to Medium

128 GBMemory (RAM)

1 TB minimumDisk Space

16 CPU coresProcessors

Server with a capacity to run 40-100 nodesLarge

256 GBMemory (RAM)

1 TB minimumDisk Space

40 CPU coresProcessors

Table 2: Server Software Requirements

DescriptionRequirement

One of the following:

• Release 5.0 with VMware ESXi

• Release 5.1 with VMware ESXi

• Release 5.5 with VMware ESXi

VMware vSphere

One of the following:

• Google Chrome Version 33.0 or later

• Internet Explorer 10.0 or later

• Mozilla Firefox 28.0 or later

• Safari 7.0 or later

Internet Explorer is not supported for use with the AutoNetkit
Visualization functionality and the User Workspace
Management interface.

Note

Browser
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Table 3: Client Hardware Requirements

DescriptionRequirement

Either of the following:

• Microsoft Windows

◦Windows 7 or

◦Windows 8

• Apple Mac OS X

◦Mac OS X 10.8 or later

Operating System

500 MBMemory (RAM)

150 MBDisk Space

Table 4: Client Software Requirements

DescriptionRequirement

For Windows and Mac OS X, either of the following:

• Version 6

• Version 7

Java Runtime Environment (JRE)

One of the following:

• Google Chrome Version 33.0 or later

• Internet Explorer 10.0 or later

• Mozilla Firefox 28.0 or later

• Apple Safari 7.0 or later

Internet Explorer is not supported for use with the AutoNetkit
Visualization functionality and the User Workspace
Management interface.

Note

Browser
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Cisco Modeling Labs Framework
Figure 1: Cisco Modeling Labs Framework

Cisco Modeling Labs 1.0 includes numerous features that enable you to create and simulate small and large
network designs. This user guide is organized in a task-based format where the main features are grouped
into four sections referred to as phases.

The following items describe each phase which should help you determine which section to refer to when
using this guide:

1 Design—This phase includes the tasks for creating a network topology. You use a blank canvas to create
topologies from scratch or import existing network topologies. You can also view your topologies on a
geographic map and adjust where and how interfaces are used on each device.

2 Build—This phase includes the tasks associated with configuring routers, external connections, and servers,
creating the required configurations, setting up interfaces, IP addressing, and routing protocols for the
virtual routers. There are several ways to create these configurations. You can use the AutoNetKit
functionality to set up the initial configuration or you can input your own configuration details. Whatever
configurations you create in this phase will be the configurations that the Cisco Modeling Labs server will
use when it initiates the node simulations.

3 Visualization—This phase is optional and operates only if you use AutoNetKit to create your configurations
during the Build phase. It includes the tasks related to running visualization scenarios of your network
design and configuration. It provides visual views of your topology whereby you can see how the nodes
will interact with each other in specific circumstances including physical set up as well as with specific
routing protocols such as ISIS and OSPF. It also supports MPLS and BGP.

4 Simulation—This phase includes the tasks for initiating the nodes and making them active. Once the
nodes are operational, you can connect to the consoles using Telnet or SSH, as you would connect to a
router console. You can run connectivity tests and modify configurations. This is where the power of the
product is realized since you can modify and test configurations as if you were on actual physical devices.
In this phase, you can also save your configurations and extract them for sharing with others or saving
them and using them as reference when configuring the production network.
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C H A P T E R  2
Using the Cisco Modeling Labs Client

• Using the Cisco Modeling Labs Client Overview, page 7

• Navigating Within the Cisco Modeling Labs Client, page 8

• Cisco Modeling Labs Client Components, page 15

• Setting Preferences for the Cisco Modeling Labs Client, page 52

Using the Cisco Modeling Labs Client Overview
The Cisco Modeling Labs client is a cross-platform, point-and-click GUI that simplifies topology creation,
initial-device configurations, and permits access to the Cisco Modeling Labs server. You can interact directly
with your running simulations from this GUI. Additionally, the Cisco Modeling Labs client provides the
functionality to generate default router configurations before simulating your topology.

This chapter introduces the main areas and capabilities of the Cisco Modeling Labs client in the following
section.
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Navigating Within the Cisco Modeling Labs Client
This section describes the functionality of the Cisco Modeling Labs client, which comprises of a workbench
containing a menu bar, a toolbar, multiple editors, multiple perspectives, and multiple views.

Figure 2: Workbench Components

DescriptionCalloutDescriptionCallout

Canvas5Menu Bar1

Palette6Toolbar2

Views7Perspectives3

Topology Editor5+6
combined

Node Editor4

•Workbench—Refers to the CiscoModeling Labs client desktop environment. Each time the workbench
is exited, it is automatically saved, including all the open perspectives, views, and editors. When the
workbench is reopened, it appears exactly as it was when last closed.

•Menu Bar—References all the actions that can be performed when using the Cisco Modeling Labs
client.

• Toolbar—Contains a set of icons representing commands. The Toolbar provides shortcuts to actions
that are used most often from the Menu bar.

• Cisco Modeling Labs Client Perspectives—Identifies the Design and Simulate perspectives, each of
which is associated with an initial set of views and editors in your workbench.
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From theDesign perspective, you can design your network topology, build the node configurations,
and check routing protocols. TheDesign perspective is the default perspective if you are launching
the Cisco Modeling Labs client for the first time.

◦

◦From the Simulate perspective, you can enable devices and modify configurations to run the
simulations. When the nodes in your topology are fully initialized, you can connect to the consoles
as you would connect to a router console.

• Cisco Modeling Labs Client Editors—Provides alternative components within the Cisco Modeling
Labs client from which you can create and edit topologies. Two editors are provided: Node Editor and
Topology Editor.

◦The Node Editor shows the interface details for selected elements in the Topology Editor.

◦The Topology Editor is comprised of the Palette view and the canvas.

• CiscoModeling Labs Client Views—Provides alternative presentations of your topology, and methods
for navigating the information in your workbench.

• Cisco Modeling Labs Client Layout—Enables you to personalize your workbench, allowing you to
rearrange, resize, reset, and move between views.

Menu Bar
The menu bar provides access to the complete list of actions that are possible in the Cisco Modeling Labs
client.

Cisco Modeling Labs 1.0 User Guide    
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Table 5: Menu Bar Items

Action(s)Menu

Enables you to perform actions to a topology project, sub topology, or topology .virl file; set
preferences for resources; and exit the Cisco Modeling Labs client.

• New—Creates a new topology project folder, topology project, or topology .virl file.
See Design a Topology Overview, on page 69 for more information.

• Save—Saves the current Topology Editor contents.

• Save As—Saves the current Topology Editor contents to a new file.

• Print—Prints the current Topology Editor design.

• Import—Imports a resource type (for example, a topology.virl file) into the Cisco
Modeling Labs client. See Importing a Topology File, on page 12 for more information.

• Export—Exports a resource type (for example, a topology.virl file) from the Cisco
Modeling Labs client. See Exporting a Topology File, on page 12 for more information.

• Close—Closes the current editor.

• Close All—Closes all open editors.

• Preferences—Opens the Preferences dialog box where you can update the settings for
the Cisco Modeling Labs client. See Setting Preferences for the Cisco Modeling Labs
Client, on page 52 for more information.

• Switch Workspace—Allows you to select a workspace folder to use for your session.

• Exit—Exits the Cisco Modeling Labs client.

File
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Action(s)Menu

Enables you to manipulate resources on the canvas.

• Undo—Cancels the most recent change.

• Redo—Applies the most recent change that was removed.

• Copy—Places a copy of the topology on the clipboard.

• Paste—Pastes the topology from the clipboard to the canvas at the current cursor location.

• Delete—Deletes the current topology.

• Select All—Selects all objects in the current topology canvas.

• Show Map Background—Displays a map background for the topology. (You must
have Internet access to use this feature.)

• Reset Note Subtype—Enables you to redefine a virtual node on the canvas. The node
subtype installed with Cisco Modeling Labs is Cisco IOS. When Reset all interface
names is selected, the interface IDs are reset sequentially, starting from the Minimum
range.

• Highlight Connection—Highlights all connections to and from the selected node.

• Distribute Nodes—Aligns the nodes on the canvas evenly, either vertically or
horizontally, or places them in a grid layout. (This feature is disabled when Show Map
Background is chosen.)

• Layout Nodes—Places nodes on the canvas in a tree layout or an F-R layout. (This
feature is disabled when Show Map Background is selected.)

• Alignment—Aligns the nodes on the canvas. Options are: left, center, right, top, middle,
or bottom. (This feature is disabled when Show Map Background is selected.)

• Group to Site—Groups two or more nodes within a site.
Sites are created within Cariden
imports.

Note

• Ungroup to Site—Ungroups nodes from within a site, removing one layer of nesting.

Edit

Enables you to see numerous perspectives within the Cisco Modeling Labs client.

• Lists the view options for the selected perspective within the CiscoModeling Labs client.

• Allows you to filter your view results.

View

Provides zoom in and zoom out functionality from within the canvas.Zoom

Enables you to start and stop simulations, and to generate node configurations.Run

Enables you to perform topology searches and text searches within workspaces, topology
projects, files, and working sets.

Search

Cisco Modeling Labs 1.0 User Guide    
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Action(s)Menu

Displays the help topics for using the CiscoModeling Labs client in a separate browser window.

• Help Contents—Opens the Cisco Modeling Labs client support documentation.

• Cheat Sheets—Helps you complete a task.

• Generate Problem Report—Generates a detailed report of a problem, which can be
submitted to Cisco Technical Assistance Center (Cisco TAC) for further investigation.
See Generating Problem Reports, on page 13 for more information.

• About Cisco Modeling Labs—Identifies version information and displays details
pertaining to software installations.

Help

Importing a Topology File

Step 1 From the menu bar, choose File > Import.
The Import dialog box appears.

Step 2 From the drop-down list, choose Topology > Import Topology file from File System, and click Next.
Step 3 Click Browse to locate the applicable .virl file.
Step 4 In the right pane, check the check box for the applicable .virl file.
Step 5 Click Finish to import the topology file.

Exporting a Topology File

Step 1 From the menu bar, choose File > Export.

To export a topology file, it must be open on the canvas of theTopology Editor.Note

The Export dialog box appears.
Step 2 From the drop-down list, choose Topology > Export Topology file to File System, and click Next.
Step 3 Click Browse to select the directory to export the topology file to.
Step 4 Click Finish to export the topology file.
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Generating Problem Reports
The Cisco Modeling Labs client provides functionality that allows you to generate problem reports for any
problems encountered in your topology. It is accessible from the menu bar under Help > Generate Problem
Report.

While all options are pre-selected, you can individually select the information you want to include in the
report.

When generating a problem report for your topology, you must have the topology containing the problem
open on the canvas.

Note

DescriptionOption

User interface .log file from the user's workspace.Log File

Current content from the Console view messages. These are messages
from the server in response to AutoNetkit and simulation launch actions.

Consoles Content

Contents of the currently open topology file in theTopology Editor canvas.Topology Editor Contents

Screenshot showing the state of the user interface when the problem
occurred.

Screenshot of the User Interface

Report of the Web Services details and errors.Web Services Setting

Any additional information that users can provide to describe the problem.Additional Information

The generated problem report is saved to a .zip file where you can check the contents before sending it to the
Cisco Technical Assistance Center (Cisco TAC) for investigation.

Toolbar
The toolbar is a compilation of icons representing commonly used actions. The toolbar is arranged below the
menu bar and offers the same actions as the menu bar, in a single click. The following table outlines the actions
that can be performed using the Cisco Modeling Labs client toolbar.

DescriptionFunctionIcon

Creates a new topology project. A topology project is
a folder in which multiple topology files are stored. If
you create many different topologies, you can set up
different projects for the topologies you create.

New Topology
Project

Creates a new topology file. A topology file is a .virl
file where the network arrangement is designed.

New Topology File
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DescriptionFunctionIcon

Saves the current topology.Save

Prints the current topology.Print

Uses Global Positioning Satellite (GPS) coordinates
to map a topology to precise geographic locations.

You must have Internet access to use this
feature since it uses the map service from
MapQuest to retrieve the latest map images.

Note

Show Map
Background

Resets the node subtypes. A node subtype defines the
virtual machine running a particular operating system,
for example, Cisco IOSv virtual software. You can also
choose to reset all interface names.

Reset Node Subtype

Deletes the currently selected element within the
topology.

Delete

Undoes the most recent action.Undo

Redoes the most recent undone action.Redo

Enlarges the topology view on the canvas.Zoom In

Decreases the topology view on the canvas.Zoom Out

Aligns the nodes on the canvas either vertically or
horizontally. Alternatively, arranges the nodes in a grid.

Distribute Nodes
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DescriptionFunctionIcon

Places the nodes on the canvas in a tree layout or an
Fruchterman-Reingold (F-R) layout.

• A basic tree layout allows you to choose a node
as the root of the tree, and the nodes connected
to the root become the children of that root node.

• An F-R layout has connected nodes close to each
other, while unconnected nodes are further apart
from each other.

Layout Nodes

Aligns the nodes on the canvas either horizontally or
vertically, and allows you to position them at various
points on the canvas.

Alignment

Groups two or more nodes within a site. Sites can be
nested, forming a hierarchical structure.

Group to Site

Ungroups nodes fromwithin a site, removing one layer
of nesting.

Ungroup Site

Launches a simulation.Launch Simulation

Stops a running simulation.Stop Simulations

Generates configurations for the topology.Update Router
Configurations

Cisco Modeling Labs Client Components
The three main components of the Cisco Modeling Labs client are described in the following sections:

• Cisco Modeling Labs Client Editors, on page 16

• Cisco Modeling Labs Client Perspectives, on page 17

• Cisco Modeling Labs Client Views, on page 21
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Cisco Modeling Labs Client Editors
Editors are visual components within the Cisco Modeling Labs client. Currently, two editors are available:

• Topology Editor—Shows the entire topology (or sites). The Topology Editor comprises the canvas and
the Palette.

• Node Editor—Shows the interface details for the currently selected elements in the Topology Editor.

Selecting a connection in the Topology Editor shows the details of both the endpoints in the Node Editor.Note

Topology Editor
The Topology Editor allows you to:

• Add, move, group, rename, and delete nodes and sites on the canvas, or change the properties.

• Create or remove connections between nodes.

• Use GPS coordinates to map your topology to precise geographic locations.

Figure 3: Topology Editor

Node Editor
The Node Editor allows you to:

• Add interfaces to a node.

• Add connections to the interfaces on a node.

• View nodes, their connections, and all the interfaces on the nodes.

• Specify which interface the connection connects to on each node.
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• Update properties for interfaces.

Figure 4: Node Editor

Cisco Modeling Labs Client Perspectives
A perspective defines the initial set and layout of views and editors in the workbench. The Cisco Modeling
Labs client provides two perspectives. However, you can customize your own user-defined perspectives for
use, which can be saved or deleted, as needed.

The two perspectives provided in the Cisco Modeling Labs client are: Design and Simulation:

• Design—Allows you to create and design your topologies, for example, adding devices and defining
interfaces, and adding connections to devices within your network. If you are using the Cisco Modeling
Labs client for the first time, the Design perspective opens by default.

• Simulation—Allows you to simulate running configurations that are generated from virtual Cisco IOS
versions.

The Design and Simulation perspectives that are built into the Cisco Modeling Labs client cannot be
deleted.

Note

One or more perspectives can exist in a single workspace. If multiple perspectives are opened at the same
time, you can choose whether to layer them, or open them in a separate workspace.
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Working with Perspectives
You can manage the various perspectives defined in the workbench under Perspectives preferences, choosing
File > Preferences > General > Perspectives.

Figure 5: Perspective Preferences

The following table describes the Perspectives options:

Table 6: Perspectives Options

DescriptionOption

Defines whether a new perspective opens in the current workbench, or opens
in a newwindow. By default, a new perspective opens in the current workbench.

Open a new perspective

Defines whether a new view opens within the current perspective, or opens
docked beside the current perspective (fast view). By default, a new view opens
within the current perspective.

Open a new view

Defines perspective behavior when a new project is created. By default, a new
project opens the perspective in the same workbench.

New project options

The following table describes the Available Perspectives options:
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Table 7: Available Perspectives Options

DescriptionOption

Sets the selected perspective as the default perspective.Make Default

Resets the definition of the selected perspective to the default configuration. This
option is only applicable to system-defined perspectives.

Revert

Deletes the selected perspective. This option is only applicable to user-defined
perspectives. (System-defined perspectives cannot be deleted.)

Delete

Customizing Perspectives
Cisco Modeling Labs 1.0 provides two perspectives for use in the workspace: the Design perspective and the
Simulation perspective. These perspectives display various views and settings that cannot be changed, nor
can they be deleted from the Cisco Modeling Labs 1.0 client. You can, however, customize additionalDesign
and Simulation perspectives for your specific needs.

From the View menu, you can open additional views and arrange them in your perspective. The views can
be arranged by dragging them around the workspace. When finished, you can save the perspective.

Right-click the applicable perspective tab to open the context menu, and then click ShowText. TheDesign
perspective and the Simulation perspective buttons will be displayed as text labels instead of icons only.

Note

Step 1 Open the Design perspective or Simulation perspective in your workspace.

Use this as an initial template from which to create a customized perspective.

Step 2 To add new views, open the View menu to display the various views for use.
Views already in use are shown as dimmed in the list.

Step 3 To add node information, double-click a node to add a Node Editor in the perspective.
Step 4 Click and drag the views and Node Editors to different positions within the workspace. For example, you can move

each node's Console view so they are either side-by-side, or stacked in tabs.
Step 5 When you are finished arranging the workspace, right-click the applicable perspective button, and then click Save As.

You are prompted to name the new perspective.
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Step 6 Enter a name for the perspective and click OK.

Design Perspective
The Design perspective allows you to create and design your topologies. By default, the Design perspective
incorporates the components listed here because they are the most widely used. However, you can customize
a Design perspective to include a different set of components.

• Palette view—Provides the node types, connection types, and sites used to design a topology.

• Projects view—Lists topology projects, subfolders, and files defined from the workbench.

• History view—Lists changes made to a file based on date and time stamp.

• Properties view—Identifies node and interface properties.

• Outline view—Lists structural elements of a topology.

• Node Editor—Identifies nodes, node connections, and node interfaces.

• Topology Editor—Develops a network topology.

• Graph Overview—Provides methods for viewing a network topology.

To customize a new Design perspective, choose the desired components from the View menu (for example,
View > Other > Cisco Terminal), and then drag that component view to the desired location within the
workbench. When you are done adding components to the workbench and the component views are laid out
as desired, select Save As from the Design toolbar and enter a name for the new Design perspective.

From the Design perspective, right-click the Design icon. This displays the following menu options:

Table 8: Design Perspective Context Menu Options

DescriptionOperation

Saves the customized workbench layout, views, and editors as a new Design
perspective.

Save As

Resets the current perspective to display the workbench design that was used when
the workbench was first opened.

Any open editors, for example, Node Editor, are not closed when a perspective
is reset. You must close them manually.

Note

Reset

Closes the current perspective. You can reopen it using the Open Perspective tool,
which is located at the upper right corner of the window.

Close

Shows perspective names in the toolbar instead of icons, when selected.
When deselected, shows perspective icons in the toolbar instead of names.

Show Text
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Simulation Perspective
The Simulation perspective opens after you launch a simulation; you are prompted to switch to the Simulation
perspective. Switching to the Simulation perspective means that you can now connect to your running nodes
in the Simulations view. By default, it incorporates the Topology Editor, Projects view, Simulations view,
Console view, and Terminal view.

From the Simulation perspective, right-click the Simulation icon. This, displays the following menu options:

Table 9: Simulation Perspective Context Menu Options

DescriptionOperation

Saves the current perspective.Save As

Resets the current perspective to its original configuration (when the workbench
opened initially).

Any open editors, for example, Topology Editor, are not closed when a
perspective gets reset to its original configuration. They are stacked as tabs
in the default editor area for that perspective.

Note

Reset

Closes the current perspective. (Reopen it using the Open Perspective tool.)Close

Displays perspective icons only. (No text is displayed in the toolbar.)Show Text

Cisco Modeling Labs Client Views
Views provide alternativemethods for presenting topology information and navigating within your workbench.
You can drag the view windows and position them anywhere within the workbench. Some views have their
own toolbars, and some of the tools on these toolbars are specific to the views being presented.

The most commonly used views within the Cisco Modeling Labs client are listed in the following table:

Table 10: Commonly Used Views in the Cisco Modeling Labs Client

DescriptionPerspective Where
Used

View Name

Design—Displays messages from AutoNetkit when it
is used to generate router configurations.
Simulation—Displaysmessage streams from the Cisco
Modeling Labs server after a simulation is launched.

For more information, see Console View, on page 23

Design and SimulationConsole view

Provides you with the ability to view a scaled-down
version of your entire topology.
For more information, see Graph Overview, on page
24

DesignGraph Overview
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DescriptionPerspective Where
Used

View Name

Provides a history of changes made to a file and enables
you to select a previous file version from the list. For
more information, see History View, on page 24

DesignHistory view

Shows a list of the nodes in the topology and their
interface connections.
For more information, see Outline View, on page 26

DesignOutline view

Allows you to add devices and interface connections
to your topology.
For more information, see Palette View, on page 27

DesignPalette view

Displays errors, warnings, and other information that
was detected within the Topology Editor.
For more information, see Problems View, on page
29

DesignProblems view

Provides a hierarchical view of topology projects,
folders, and topologies in the workbench.
For more information, see Projects View, on page 34

Design and SimulationProjects view

Displays names and properties of nodes and interfaces.
For more information, see Properties View, on page
35

DesignProperties view

Displays the results of a search, which can be based on
text strings, regular expressions, and patterns, whole
words and case-sensitive characters.

For more information, see Search View, on page 44

DesignSearch view

Displays information on all running simulations.
For more information, see Simulations View, on page
46

SimulationSimulations view

Displays console information when you connect to a
node using Telnet.
For more information, see Terminal View, on page 51

SimulationTerminal view

   Cisco Modeling Labs 1.0 User Guide
22 OL-32056-01   

Using the Cisco Modeling Labs Client
Cisco Modeling Labs Client Views



Console View
The Console view displays message streams from the Cisco Modeling Labs server after a simulation is
launched. It also displays messages from AutoNetkit when it is used to generate router configurations.

Figure 6: Console View

The Console view toolbar contains the following tools:

Figure 7: Console View Toolbar

Table 11: Available Tools

DescriptionFunctionIcon

Removes all the information from the Console view.Clear Console

Switches scrolling on and off.Scroll Lock

Pins the Console view to the workbench so that
subsequent message streams are shown in another
Console view. The pinned view remains unchanged.

Pin Console

Displays theConsole view for the selected simulation.Display Selected Console

Opens a new Console view.Open New Console
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DescriptionFunctionIcon

Reduces the size of the Console view.Minimize

Increases the size of the Console view.Maximize

When several simulations are running, use the toolbar buttonDisplay Selected Console to toggle between
the Console views for the different simulations.

Note

Graph Overview
Graph Overview enables you to view a scaled-down version of your entire topology. A blue rectangle
(representing an overlay) is used to indicate a portion of the topology that is currently being displayed in the
Topology Editor. Using this overlay, you can easily see where the displayed portion sits in relation to the
entire topology.

The Graph Overview also allows you to navigate around a large topology when it is either too large to fit
into the canvas, or is zoomed in and not fully displayed on the canvas.

Figure 8: Graph Overview

From theGraph Overview, click and drag the overlay to pan around your topology. As you drag the overlay,
the corresponding content is reflected in the Topology Editor.

History View
When you create or modify a file, a history of record is maintained and a copy of the modified file is stored
locally. This allows you to replace the current file with a previous version, or restore a file that has been
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deleted. You can also use the History view to compare the changes that were made to the local files. Each
file's history, which is stored locally, is uniquely represented by the date and time at which the file was saved.

Only changes made to topology files (.virl) are retained locally, changes made to projects and folders are
not.

Note

Figure 9: History View

To view the change history of a file, in the Projects view, right-click the applicable file and choose Team >
Show Local History.

The History view displays a list of revision times, with the most recent one highlighted at the top of the list.

If you have a .virl file opened in the workbench, click theHistory tab to view the list of changes made to
the file.

Note

The History view toolbar contains the following tools:

Figure 10: History View Toolbar

Table 12: Available Tools

DescriptionFunctionIcon

Refreshes the contents of the view, retrieving the latest history
information for a file from the system.

Refresh

Toggles when the History view selection is linked to the
active editor.When this option is selected, changing the active
editor automatically updates the History view selection to
the project, folder, and file being edited.

Link with Editor
and Selection
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DescriptionFunctionIcon

Pins the view to the workbench and captures a snapshot of
the file history information. New requests for file history are
opened in a new instance of the History view.

Pin this History
View

Sorts all history items by date. Options are:

• Today

• Yesterday

• This Month

• Previous

GroupRevisions by
Date

Collapses all the history items listed in the hierarchical view.Collapse All

Opens the compare editor for file comparison.Compare Mode

Outline View
TheOutline view shows a list of the nodes in the topology and their interface connections. Node connectivity
is shown through their interface connections.

Figure 11: Outline View
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The Outline view toolbar contains the following tools:

Figure 12: Outline View Toolbar

Table 13: Available Tools

DescriptionFunctionIcon

Allows you to choose various options when displaying
connections:

• Hide Connections—No connections are shown.

Show Selected Connections—Displays only the
connections that are selected in theTopology Editor.

• Show Intra-Topology Connections—Displays only
the connections between the sites in the topology.

• Show Inter-Topology Connections—Displays only
the connections that are within a site.

• ShowAll Connections—Displays all the connections
for all the nodes in the topology.

ChangeDisplayMode
of Connection

Sorts and lists the node names in alphabetical order.Sort Alphabetically

Sorts and lists the node types in alphabetical order.Sort By Node Type

Expands nodes, interfaces, and connections in the
hierarchical view.

Expand All

Collapses all of the items in the hierarchical view.Collapse All

Palette View
The Palette view allows you to add devices and interface connections to your topology. Using the Palette
view, you can:
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• Add nodes, multipoint connections, L3 external Secure NetworkAddress Translation (SNAT) connections,
and L2 external (Flat) connections to your topologies.

• Select nodes and connections for repositioning on the canvas.

• Create connections between node interfaces.

• Group nodes into sites.

Figure 13: Palette View

The Palette view is divided into the following categories:

• Tools—Contains the Select and Connect tools. The Select tool allows you to select nodes, multipoint
connections, L3 external (SNAT) connections, and L2 external (Flat) connections on the Topology
Editor canvas. The Connect tool creates connections between node interfaces.

TheFile >Preferences >Topology Editor setting affects how the nodes and connections
are placed on the canvas. If you check the Revert back to the palette's default tool,
check box, you must click a node, connection, or other object each time you place an
object on the canvas. If the Revert back to the palette's default tool, check box is not
checked, each time you click the canvas, an object is placed until you click the Select
tool (the default palette tool).

Note

• Nodes—Contains the node types available for use in topologies. Currently, Cisco Modeling Labs 1.0
includes the Cisco IOSv virtual image.
An Ubuntu 14.04 server has been tested with Cisco Modeling Labs 1.0. The Ubuntu server must be
downloaded separately. To access the server, go to:

http://cloud-images.ubuntu.com/trusty/current.

From this page, download the clouding-amd64 RAW (img) image
trusty-server-cloudimg-amd64-disk1.img.
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Additional node subtypes can be installed separately. See the Release Notes for Cisco
Modeling Labs 1.0 for the most up-to-date list of supported virtual images.

Note

• General—Contains the different types of connection functions that are supported for nodes. Options
are:

◦Multipoint connections

◦Layer 3 (L3) external connections

◦Layer 2 (L2) external connections

You can also create sites.

The Palette view toolbar contains the following tools:

Figure 14: Palette View Toolbar

Table 14: Available Tools

DescriptionToolIcon

Reduces size of Palette view.Minimize

Increases size of Palette view.Maximize

Problems View
The Topology Editor automatically detects errors, warnings, or other information that are displayed on the
topology elements in the Topology Editor and Node Editor. These markers can be viewed in the Problems
view.
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By default, the Problems view displays all the errors and warnings for all the topologies in the Projects
view, not just the currently open topology. From the Problems view toolbar, choose ViewMenu > Show
> Errors/Warnings on Project to filter only those errors and warnings that are applicable to the current
project. Alternatively, you can also use the Configure Contents dialog box, which is accessible from the
ViewMenu option, to filter warnings and errors associated with a particular topology or topology project.
See Problems View Toolbar for more information.

Note

Figure 15: Problems View

The Problems view groups errors and warnings by severity, with the most critical issues listed first.

Double-click the problem marker in the Problems view, which opens the appropriate editor in the Cisco
Modeling Labs client. If the problem relates to an XML file, the XML file opens in a text editor. The problem
is highlighted, allowing you to quickly identify the issue and correct it.

Figure 16: Problem Example

The Problems view toolbar contains the following tools:

Figure 17: Problems View Toolbar
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Table 15: Available Tools

DescriptionFunctionIcon

The Problems view tool has the following options:

• Show—Displays errors and warnings.

• Group By—Groups problems under the headings Type,
Severity, and None. The default is Severity.

• Sort By—Sorts problems under the following headings:

◦Description—Details the problem encountered.

◦Resource—Displays the name of the .virl file where
the problem has occurred.

◦Path—Displays the applicable project folder.

◦Location—Displays the location in the .virl file where
the problem has occurred.

◦Type—Displays the type of problem, for example,
XML problem.

• New Problem View—Opens a new Problems view on the
workbench.

• Configure Contents—Opens the Configure Contents
dialog box where you can add multiple filters to the
Problems view and enable or disable them, as required.
Filters can either be additive or exclusive. The All
Errors/Warnings on Selection filter is provided by default.

• Configure Columns—Opens the Configure Columns
dialog box where you can choose to hide or show specific
information about the problem encountered, as shown in the
Sort By option. Options are:

◦Creation Time—Displays the timewhen the problem
occurred.

◦Description, ID—Displays the system-generated ID
for the problem, location, path, resource, and type.

View Menu

Reduces the size of the Problems view.Minimize

Increases the size of the Problems view.Maximize
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The Quick Fix Option

Problems displayed in the Problems view are provided with aQuick Fix option, if available. A Quick Fix is
indicated by a light-bulb icon that is visible on the marker. When this option is selected, you are presented
with one or more possible fixes.

We recommend that you use Quick Fix to resolve the errors discovered, unless the errors have been deliberately
created for testing purposes.

Figure 18: Quick Fix

To fix a problem:

1 Right-click the line containing the problem, and select Quick Fix.
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The Quick Fix dialog box displays a list of possible solutions.

Figure 19: Quick Fix Dialog Box

2 Select a fix from the list, and then check the check box of any of the Resources listed in the Problems
area. You can click Select All to apply the Quick Fix to all the Resources listed. Alternatively, you can
click Deselect All to clear all selections.

3 Click Finish.

Once a problem has been fixed using the Quick Fix option, the action cannot be undone.Note
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Projects View
TheProjects view provides an hierarchical view of topology projects, folders, and topologies in the workbench.
From here, you can open topologies for editing, or select resources for operations, such as exporting.

Figure 20: Projects View

Right-click any topology in the Projects view to open a context menu using which you can copy, move, and
create new topology files, view comparison files, and so on.

The Projects view toolbar contains the following tools:

Figure 21: Projects View Toolbar

Table 16: Available Tools

DescriptionFunctionIcon

Collapses the hierarchy of all the resources in the Projects view.Collapse All

Links the Projects view with an active editor. A change to an
active editor automatically updates the Projects view and allows
you to toggle between the two views.

Link with
Editor

Provides options for customizing the content displayed in the
Projects view. Options are:

• Sort by filters

• Sort by content

View

Reduces the size of the Projects view.Minimize
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DescriptionFunctionIcon

Increases the size of the Projects view.Maximize

The Projects view displays several icons on the toolbar:

Table 17: Project View Icons

DescriptionNameIcon

Indicates an open topology project.Topology Project

Indicates an open folder. Folders are created within a
Topology Project so that topology files can be organized
into separate areas for greater accessibility.

Folder

Indicates a topology file.Topology

Properties View
The Properties view displays the names and properties of nodes and interfaces. If no specific node or interface
is selected, the Properties settings apply globally to all the nodes and interfaces within a topology. If a specific
node or interface is selected, the Properties settings apply to only that node or interface.

Figure 22: Properties View
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The Properties view toolbar contains the following tools:

Figure 23: Properties View Toolbar

Table 18: Available Tools

DescriptionFunctionIcon

Shows the available property categories.Show Categories

Shows all advanced properties.ShowAdvancedProperties

Restores the default value for the property.Restore Default Value

Pins this property view to the current selection.Pin to Selection

Displays menu items that allow you to:

• Open a new property view.

• Pin the property view to the current selection.

View Menu

Reduces the size of the Properties view.Minimize

Increases the size of the Properties view.Maximize

The properties in the Properties view are discussed in the following sections:

• Node Properties, on page 37

• Topology Properties, on page 39

   Cisco Modeling Labs 1.0 User Guide
36 OL-32056-01   

Using the Cisco Modeling Labs Client
Cisco Modeling Labs Client Views



Node Properties

When you select a node on the canvas, the properties for that node are displayed in the Properties view.

Figure 24: Node Properties

Under the Node tab, you can perform the following tasks:

Table 19: Node Properties

DescriptionProperty

Specify a name for the node.
Use only alphanumeric characters for node names. Node names must be unique
across the entire topology. Duplicate node names cause the build to fail when the
configuration is autogenerated. If a duplicate node name is defined, a marker is
shown in the Problems view. Unicode is not supported for node names. The use
of a period in a node name may cause the node name to wrap when viewing the
hierarchy from the Cisco Modeling Labs server. When you update a node name
in the Node Properties view, the node name is not updated in the Node Editor.

Note
Name

Specify a subtype from the list. Cisco Modeling Labs 1.0 includes a Cisco IOSv virtual
image. Additional Cisco virtual images are available for use. However, they must be
installed separately. For a list of supported subtypes, see the Release Notes for Cisco
Modeling Labs 1.0.
An Ubuntu 14.04 server has been tested with CiscoModeling Labs 1.0. The Ubuntu server
must be downloaded separately. To access the server, go to:

http://cloud-images.ubuntu.com/trusty/current.

From this page, download the clouding-amd64 RAW (img) image
trusty-server-cloudimg-amd64-disk1.img.

Use theManage Subtypes tool to add or remove node subtypes from the list.

When changing a node subtype after it is initially configured using AutoNetkit,
for example, changing it from Cisco IOSv to Cisco IOS XRv, you need to
re-validate the AutoNetkit properties for the new node subtype.

Note

Subtype

Specify an IPv4 loopback address. The loopback address is added to the router as interface
loopback0. Enter a valid IP address in the correct format.

IPv4

Specify an IPv6 loopback address. The loopback address is added to the router as interface
loopback0. Enter a valid IP address in the correct format.

IPv6
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DescriptionProperty

Specify a virtual machine (VM) image other than the default. Click Browse to choose a
valid VM image from the Select VM Image dialog box.

VM Image

Specify a VM flavor other than the default. Click Browse to choose a valid VM flavor
from the Select VM Flavor dialog box.

VM Flavor

Under theAutoNetkit tab, when you check theAuto-generate the configuration based on these attributes
check box, the AutoNetkit generates the configuration for your topology when you click the Update Router
Configurations icon on the toolbar.

Any pre-existing configuration for a node is overwritten when you chooseUpdate Router Configurations
from the toolbar. Uncheck this Auto-generate check box if you do not want router configuration for a
node updated by AutoNetkit.

Note

Using the properties listed, you can perform the following tasks:

Table 20: AutoNetkit Properties

DescriptionFieldsProperty

Specify the autonomous system number, which is used to infer IGP and BGP
and should be any valid integer.

ASNGeneral

Configure an OSPF area. The default value is 0.OSPFIGP

Specify an iBGP role from the list and use it to create an iBGP topology. Options
are:

• Not specified

• Disabled

• Peer

• Route Reflector (RR)

• Hierarchical Route Reflector (HRR)

• Route Reflector Client (RRC)

The default value is Peer.

iBGP RoleiBGP

Specify the RRC as a name or number. Should be an alphanumeric string.RR Cluster

Specify the HRR Cluster. Should be an alphanumeric string.HRR Cluster

Specify an MPLS VPN name for VRF Lite.VRF NameMPLS
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DescriptionFieldsProperty

Configure MPLS Traffic Engineering. Options are:

• Unspecified

• True

• False

The default value is False.

Enable MPLS
TE

Specify a username for the server.Server
Username

Server

Specify a secure shell key for the server.
An SSH key is required only if you want to connect to the VM server
within the topology using an external application. Using the VNC
option does not require an SSH key to be specified.

Note
SSH Key

Information displayed under the Configuration tab, depends on whether or not the Auto-generate the
configuration based on these attributes check box under the AutoNetkit tab is checked.

• When checked, AutoNetkit generates the configuration and displays it under the node's Configuration
tab.

• When unchecked, no configuration information is created for the node. You must configure the node
manually, or cut and paste the existing configuration information into this area.

Under the Extensions tab, all the extensions used to generate the configuration are listed along with Key,
Value, and Type attributes.

Topology Properties

When you select an area on the canvas other than a node, the properties for that topology are displayed in the
Properties view.

Figure 25: Topology Properties

Under the Topology tab, you can perform the following tasks:
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Table 21: Topology Properties

DescriptionProperty

Specify the rule type with which the topology is validated. Options are:

• Not specified

• VXR

• VIRL

For CiscoModeling Labs 1.0, we recommend you accept the default value,Not specified.

Validation
Rules

Specify the type of Out of Band (OOB) external network access. Options are:

• Not specified—No OOB external network access

• Shared Flat Network—Enables OOB external network access to all the devices in
the topology

• Private User Network—Enables OOB external network access using Network
Address Translation (NAT)

Management
Networks

TheNodes,Multipoint Connections, and Simple Connections properties are for information purposes only
and are useful when monitoring the size of the topology to your current user quotas or licensing limits or both.

Nodes in this instance includes node subtypes, Flat, and SNAT port groups.Note

Under the AutoNetkit tab, you can perform the following tasks:

Table 22: AutoNetkit Properties

DescriptionFieldsProperty

Configure the Cisco Discovery Protocol (CDP). Options are:

• True

• False

The default value is False.

Enable CDPGeneral

Configure the Cisco One Platform Kit (onePK). Options are:

• True

• False

The default value is False.

Enable onePK
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DescriptionFieldsProperty

Configure a routing session to use IPv4 address prefixes, IPv6
address prefixes, dual stack (includes both native IPv4 and IPv6),
or none. Options are:

• Not specified

• None

• v4

• v6

• dual_stack

IP Address FamilyAddressing

Specify the address to use for IPv4 infrastructure address allocations.
This is the address assigned to the interface created on the router.
The default value is 10.0.0.0. Enter a valid IP address in the correct
format.

IPv4 Infrastructure
Subnet

Specify the prefix to use for IPv4 infrastructure address allocations.
The default value is 8. Enter a valid IP address in the correct format.

IPv4 Infrastructure
Prefix

Specify the address to use for IPv4 loopback address allocations.
The default value is 192.168.0.0. Enter a valid IP address in the
correct format.

IPv4Loopback Subnet

Specify the prefix size to use for IPv4 loopback address allocations.
The default value is 22. Enter a valid IP address in the correct format.

IPv4 Loopback Pool

Specify the address to use for IPv4 VRF address allocations, when
specifying the address range for MPLS VRF. The default value is
172.16.0.0. Enter a valid IP address in the correct format.

IPv4 VRF Subnet

Specify the prefix to use for IPv4 VRF address allocations. The
default value is 24.

IPv4 VRF Prefix

Configure routing protocols (BGP and IGP). Options are:

• Not specified

• True

• False

The default value is True. If you specify False, there will be no
router configuration for any of the routing protocols.

Enable Routing
Protocols

Routing

Configure the Interior Gateway Protocol (IGP). Options are:

• OSPF

• ISIS

• EIGRP

IGP
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DescriptionFieldsProperty

Configure MPLS OAM for all routes on the topology. Options are:

• Not specified

• True

• False

The default value is False.

Enable MPLS OAMMPLS

The following table shows the default IP Address values used by Cisco Modeling Labs. You can update these
values as required.

Table 23: IP Address Default Values

Optional Value(s)Default ValueOptionViewed from

None, v6, dual_stackv4IP Address FamilyTopology > AutoNetkit
> Addressing

10.0.0.0IPv4 Infrastructure Subnet

8IPv4 Infrastructure Prefix

192.168.0.0IPv4 Loopback Subnet

22IPv4 Loopback Pool Prefix

172.16.0.0IPv4 VRF Subnet

24IPv4 VRF Prefix

In Cisco Modeling Labs 1.0, AutoNetkit IPv6 handling code does not support the following:

• The ability to manually specify IPs.

• The ability for users to specify the IPv6 range in the Cisco Modeling Labs client.

• The ability to divide out the allocation logic to permit both infrastructure and loopback to be automatically
or manually created for either combination.

The following table shows the default routing protocols used by Cisco Modeling Labs. You can update these
values as required.

Table 24: Routing Protocols Default Values

Optional Value(s)Default ValueOptionViewed from

truefalseEnable CDPTopology >AutoNetkit
> General

truefalseEnable OnePK
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Optional Value(s)Default ValueOptionViewed from

falsetrueEnable Routing ProtocolsTopology >AutoNetkit
> Routing

isis, eigrpospfIGP

truefalseEnable MPLS OAMTopology >AutoNetkit
> MPLS

None or any valid integer1ASNNode > AutoNetkit >
General

None or valid OSPF area
number

0OSPF AreaNode > AutoNetkit >
IGP

Disabled, RRC, HRR, RRPeeriBGP RoleNode > AutoNetkit >
iBGP

None or alphanumeric string(none)RR Cluster

None or alphanumeric string(none)HRR Cluster

None or alphanumeric string(none)VRF NameNode > AutoNetkit >
MPLS

truefalseEnable MPLS TE

Valid username(none)Server UsernameNode > AutoNetkit >
Server

(none)(none)Server SSH Key

Only one IGP protocol is supported per simulation. Even though you can create multiple BGP ASs, the
choice of IGP applies to all router devices in the simulation.

Note

Under the Extensions tab, all the extensions used to generate the configuration are listed, along with theKey,
Value, and Type attributes.

Interface Properties

In theNode Editor, selecting an interface on the canvas displays properties for the interface in the Properties
view.

Under the Interface tab, you can perform the following tasks:

Table 25: Interface Properties

DescriptionProperty

Specify a name for the interface.Name

Specify an IPv4 interface address and an IPv4 subnet prefix length.IPv4
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DescriptionProperty

Specify an IPv6 interface address and an IPv6 subnet prefix length.IPv6

To delete an interface from the Node Editor canvas, select the interface, right-click and choose Delete
from the context menu.

Note

Under the Extensions tab, all the extensions used to generate the configuration are listed, along with theKey,
Value, and Type attributes.

Connection Properties

When you select a connection on the canvas, the properties of that connection are displayed in the Properties
view.

From Connection properties, you can associate a line style design with a connection between nodes. Line
styles are visual aids that help you identify the connections used in your topology design.

Search View
To search for text string and files, click Search on the toolbar. The Search view displays the results of a
search. A file search can be based on text strings, regular expressions, and patterns, in addition to whole words
and case-sensitive characters. The scope of a file search can encompass a workspace, selected resources, or
projects.

Text searches are only performed on expressions contained in files with the extension .virl.Note

The Search view also displays the results of a Git search that can be based on the same criteria as noted in a
File search. However, the scope of a Git search can encompass a particular message, resource, or identification
number in the code.

Search criteria can be based on either a file or Git. The scope of a search can be general to all the topologies
that are defined on Cisco Modeling Labs client, or specific to a particular project or file.

Figure 26: Search View
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To use the search functionality, perform the following tasks:

1 From the Cisco Modeling Labs client toolbar, click Search > File.
The Search dialog box appears.

2 In the Containing text field, enter the text string to search for. The Containing text field displays a list of
recently performed searches to select from. Leave this field empty if you want to search for files only.
Check or uncheck the Case sensitive check box depending on whether or not a case-sensitive search is to
be performed. You can also check the Regular expression check box to enable more powerful searching
capabilities. Check theWhole word check box if you want to search for whole words that are identical
to the text string. Specify the types of files to include in the search in the File name patterns field.

3 Click Choose to open the Select Types dialog box. This dialog box provides a quick way to select from
a list of valid extensions.

4 In the Scope area, specify the files and folders to include in the search. Valid options are:

• The entire workspace

• The currently selected resources in the workspace

• A named working set

• A customized group of files and folders. Use the Customize option to define the type of available
searches from the Search Page Selection dialog box.

5 Click Search to begin your search.
The Search view appears with the results of the search listed. You can click theCancel tool in the Search
view to cancel your search while it is still in progress.

The Search view toolbar contains the following tools:

Figure 27: Search View Toolbar

Table 26: Available Tools

DescriptionFunctionIcon

Deletes all the highlighted matches from the search results.Remove Selected
Matches

Deletes all the matches from the search results.Remove All
Matches

Expands each item in the Search view.Expand All
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DescriptionFunctionIcon

Collapses each item in the Search view.Collapse All

Reruns the current search to retrieve previous search results or
to reflect recent changes.

Run the Current
Search Again

Cancels the search currently running.Cancel Current
Search

Browses previously conducted searches to repeat a previous
search, by selecting a previous search from the drop-down
menu. You can also clear the search history.

Show Previous
Searches

Pins the Search view so that subsequent search results are
displayed in a separate Search view with the pinned view
unchanged, in order to compare results.

Pin the Search
View

Displays the search results as a tree or a list, filters the results
using the Filters option, and sets the overall preferences for
search using the Preferences option.

View Menu

Reduces the size of the Search view.Minimize

Increases the size of the Search view.Maximize

Simulations View
The Simulations view displays information about all the running simulations, including:

• Name of the user running the simulation

• Name of the topology

• Number of nodes in the running simulation
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• Current state of each node

Figure 28: Simulations View

Possible simulation states are:

Table 27: Simulation States

DescriptionState

Indicates that the launchworker process has successfullymade all requests
to OpenStack to deploy all simulation nodes.

ACTIVE

Indicates that a simulation has been successfully stopped and no longer
exists in the STD database.

DONE

Indicates that the launch worker process failed.FAIL

Indicates that the simulation has just been created and is being launched.INIT

This is a two-phase state: i) Necessary DB entries are created in the
middleware and ii) Required networks are deployed.
Failure in this phase results in the removal of the simulation; success
results in the start of a launch worker process.

LAUNCHING

Indicates that a stop simulation request has been received.STOP

Possible node states are:

Table 28: Node States

DescriptionState

Indicates that the virtual machine process is successful. It may take a few
minutes for the node to boot up and configure.

ACTIVE

Indicates that the virtual machine is starting, but the router image has not
yet loaded.

BUILD

Indicates that the node has been requested for BUILD, but OpenStack
has no information on the node at this time. Possibly, it was deleted. The
node can be started when the simulation itself is ACTIVE.

DELETED

Indicates that the virtual machine process failed.ERROR
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DescriptionState

Indicates that the virtual machine is in an unused state.IDLE

These two states can occur when:

• The host environment is rebooted.

• The node itself shuts down.

• The operating system of the node crashes .

• The virtualization process running the node crashes.

In such instances, the appropriate action is to stop the nodes and then
start the nodes again.

All configuration changes to the nodes are
lost .

Note

PAUSED and SUSPENDED

Indicates that the virtual machine is deployed but not actually running.
This state can occur when:

• The host environment is rebooted.

• The node itself shuts down.

• The operating system of the node crashes .

• The virtualization process running the node crashes.

In such instances, the appropriate action is to stop the nodes and then
start the nodes again.

All configuration changes to the nodes are
lost.

Note

SHUTOFF

Indicates that the node has never requested to be deployed in OpenStack
(started) or the request failed. This only occurs when the launch worker
process is active but has not reached that specific node yet, or if the
simulation is in the FAIL state.

UNDEPLOYED

The Simulations view toolbar contains the following tools:

Figure 29: Simulations View Toolbar

Table 29: Available Tools

DescriptionFunctionIcon

Refreshes the list of simulations displayed in theSimulations
view.

Refresh the List
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DescriptionFunctionIcon

Reduces the size of the Simulations view.Minimize

Increases the size of the Simulations view.Maximize

Topology Options

The following operations are available, when you right-click the topology name in the Simulations view:

Figure 30: Topology Options

Table 30: Topology Options

DescriptionOperation

Opens the Console view, showing the message stream from Cisco Modeling
Labs server for the selected topology. Message streams contain information
on the topology launch, such as, the name of the launched topology, the date
and time of the launch, and the current status of each node in the topology.

Open messages console

Extracts router configurations for all the routers to a file saved locally.
All active console connections are automatically disconnected by
Cisco Modeling Labs. All external Telnet connections to the console
ports must be closedmanually. The Stop simulation operation cannot
be selected prior to the Extract configurations operation.

Note
Extract configurations

Stops the running simulation. See the chapter Simulate the Topology
Overview, on page 101 for more information on stopping and starting
simulations.

Stop simulation
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Node Options

The following operations are available, when you right-click the node name in the Simulations view:

Figure 31: Node Options

Table 31: Node Options

DescriptionOperation

Allows you to connect using Telnet to ports on a node.Telnet

Allows you to connect using Telnet over a web socket to ports on a node.Web sockets
provide full-duplex communications channels over a single connection.

Telnet over Web
Socket

Displays a server Virtual Network Computing (VNC) login page.
This operation applies to the server
only.

Note
Attach to its VNC

Stops the selected node.Stop this node

Starts the selected node. See the section Start a Single Node, on page 109 for more
information.

Start this node

   Cisco Modeling Labs 1.0 User Guide
50 OL-32056-01   

Using the Cisco Modeling Labs Client
Cisco Modeling Labs Client Views



Terminal View
The Terminal view is displayed when you connect via Telnet to a node. Using the Terminal view, you can
communicate with and control the operating system running on the node.

Figure 32: Terminal View

The Terminal view toolbar contains the following tools:

Figure 33: Terminal View Toolbar

Table 32: Available Tools

DescriptionFunctionIcon

Disconnects the terminal connection to the node.Disconnect

Sets scrolling on and off.Scroll Lock

Allows you to select a connection from the list of
active terminal connections.

Display SelectedConnections

Closes the Terminal view.Remove Terminal
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DescriptionFunctionIcon

Allows you to set the font to be used in the
terminal, from the Colors and Fonts dialog box.

You can also access theColors and Fonts
dialog box by choosing File >
Preferences >General > Appearance >
Colors and Fonts.

Note

Set Terminal Font

Setting Preferences for the Cisco Modeling Labs Client
For the Cisco Modeling Labs client to operate, you must first identify certain setting preferences. These
preferences are available from the menu bar under File > Preferences:

• Node Subtypes Setting, on page 52

• Terminal Setting, on page 56

• Topology Editor Setting, on page 58

• Web Services Setting, on page 59

• AutoNetkit Visualization Setting, on page 61

• Web Browser Setting, on page 64

• Secure Storage Setting, on page 65

These are discussed in the following sections.

Node Subtypes Setting
A node subtype defines a virtual machine running a particular operating system. For example, Cisco IOSv is
installed with CiscoModeling Labs, while others such as Cisco IOSXRv and Cisco CSR1000v can be installed
separately. This setting allows you to add and remove node subtypes for use with the Cisco Modeling Labs
client.
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Refer to the chapter User Workspace Management in the Cisco Modeling Labs Corporate Edition System
Administrator Installation Guide for information on installing virtual machine images on the Cisco Modeling
Labs server.

Figure 34: Node Subtypes Setting

The available operations for this setting are:

Table 33: Node Subtypes Setting Operations

DescriptionOperationIcon

Adds a new subtype to the list. To ensure that the new
subtype is visible in the Palette view, set the value in the
Show in Palette column to true. See Adding a New Node
Subtype to the List, on page 54.

Add new Subtype

Removes a subtype from the list.Remove Subtype
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DescriptionOperationIcon

Updates the local subtypes based on the currently configured
Cisco Modeling Labs server. All the subtypes supported on
Cisco Modeling Labs server are available with this
operation. See Fetching Node Subtypes from the Cisco
Modeling Labs Server, on page 55.

Fetch from Server

Reverts to the original list of subtypes.Restore Defaults

Applies changes.Apply

Adding a New Node Subtype to the List
To add a new node subtype to the node subtype list, perform the following tasks:

Step 1 Click File > Preferences > Node Subtypes.
Step 2 Click the Add new subtype button.

a) In the Name column, enter a name for the new node subtype, for example, Server_Block1.
b) In the Icon column, select an icon type from the drop-down list, for example app_server.
c) In the Show in Palette column, click to select True to display the node subtype in the Palette view, else select False.
d) In the Interface name format column, enter a name for the interface format, for example eth{0}.
e) In theMin interface column, enter the minimum number of interfaces permissible for the node subtype, for example,

1.
f) In theMax interface column, enter the maximum number of interfaces permissible for the node subtype, for example,

25.

Figure 35: New Node Subtype Added
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Step 3 Click Apply and OK to save the updates.

The newly added node subtype is available for use in the Palette view.

Figure 36: New Node Subtype Visible in the Palette View

Fetching Node Subtypes from the Cisco Modeling Labs Server
To fetch new node subtypes from the Cisco Modeling Labs server, perform the following tasks:

Step 1 Click File > Preferences > Node Subtypes.
Step 2 Click the Fetch from Server button.

The Confirm dialog box is displayed.
Step 3 Click OK to update the list of node subtypes.

Figure 37: Fetch Nodes Subtypes from Server

Step 4 Click OK to finish.
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The updated list of node subtypes is available for use in the Palette view.

Figure 38: Updated List of Node Subtypes Visible in the Palette View

Contact your system administrator if a specific node subtype is missing from the list, as the system administrator
is responsible for adding new node subtypes to the Cisco Modeling Labs server.

Terminal Setting
This setting allows you to launch an external terminal application, such as, SecureCRT or PuTTY, or use the
internal Cisco Modeling Labs client Terminal view in a separate window.
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Note • If you are using the internal Cisco Modeling Labs Terminal view, the views are visible from both
theDesign or Simulation perspective. However, a detached view is only visible from the perspective
in which it was detached.

• If you are using an external terminal application, you must specify both Telnet and SSH run
commands. Youmust also ensure that the title format includes the percentage (%) character. Omission
of either of these requirements will impede your ability to save your setting preferences.

• When you specify to use an external terminal via File > Preferences > Terminal > Cisco Terminal
and then Telnet over Web Socket to a virtual machine, the terminal opens internally, not externally
as specified.

Figure 39: Terminal Setting

The available operations for this setting are:

Table 34: Terminal Setting Operations

DescriptionOperation

Launches the Terminal view in a separate window.Detached internal Terminal view

Allows you to add a Terminal view title using the required formatting
characters.

Title format

Uses the Cisco Modeling Labs internal Terminal view.Use internal Terminal view
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DescriptionOperation

Uses an external terminal application, such as SSH or PuTTY.Use external terminal application

Specifies the Telnet command to run if you are using an external
terminal application.

Telnet command

Specifies the SSH command to run if you are using an external terminal
application.

SSH command

Removes settings specified for an external terminal application and
restores terminal settings to the CiscoModeling Labs internalTerminal
view.

Restore Defaults

Applies changes.Apply

Topology Editor Setting
This setting allows you to customize the Topology Editor in the Cisco Modeling Labs client.

Figure 40: Topology Editor Setting

The available operations for this setting are:

Table 35: Topology Editor Setting Operations

DescriptionOperation

Resets the definition of the Palette view tools, Select andConnect
to their default configuration. This option is disabled by default.

Revert back to the palette's default
tool
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DescriptionOperation

Enables the following:

• When selected, interfaces are automatically assigned to
connections between nodes.

• When deselected, you are presented with a list of available
interfaces.

Associate new connection with
interfaces silently

Enables the following:

• When the number of connections in the topology exceeds
the value set in this field, the internal algorithm used to
connect nodes will not be the shortest path algorithm.

Disable shortest path algorithm if
connection amount > (greater than)

Restores settings to the initial default state.Restore Defaults

Applies changes.Apply

Web Services Setting
This setting allows you to configure the CiscoModeling Labs client to communicate with the CiscoModeling
Labs server. When you first launch the Cisco Modeling Labs client, the Active profile is not specified and
the Web Services that are listed display an Unauthorized message in red. This message relates to the Master
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Credentials, which must be still be set before the CiscoModeling Labs client can communicate with the Cisco
Modeling Labs server.

Figure 41: Web Services Setting

The available operations for this setting are:

Table 36: Web Services Setting Operations

DescriptionOperation

Identifies an active profile that has been defined on the Cisco Modeling Labs
client. You can define a new active profile, and edit or delete an existing active
profile.

Active profile

Specifies a username and password for accessing the CiscoModeling Labs server.
These credentials are provided by the system administrator.

Master Credentials
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DescriptionOperation

Lists the Web Services needed for the Cisco Modeling Labs server and the Cisco
Modeling Labs client to communicate with each other. The Web Services listed
are:

• Roster

• Simulation Engine

• OpenStack

• AutoNetkit

After you have set up your profile with the correct Base URI, each of the
Web Services will display a Compatible message in green, indicating that
the CiscoModeling Labs client can communicate with the CiscoModeling
Labs server.

Note

Web Services

Encrypts passwords and stores them locally on the Cisco Modeling Labs client.
To change the settings for managing the encrypted passwords, choose File >
Preferences > General > Security > Secure Storage. See the Secure Storage
Setting, on page 65 for more information.

Store encrypted
passwords in system's
secure storage

Restores settings to the initial default state.Restore Defaults

Applies changes.Apply

AutoNetkit Visualization Setting
The AutoNetkit Visualization feature is available only when node configurations are built using the parameters
defined in AutoNetkit. If AutoNetkit Visualization is turned off, you cannot get a true representation of your
topology.

AutoNetkit Visualization is used to determine how AutoNetkit presents graphical representations of
topology-specific attributes, such as nodes, links, and interfaces, during the build phase. The graphical
representations can be presented as a physical perspective of a network topology or based on a protocol
perspective.

For AutoNetkit Visualization to operate, the Cisco Modeling Labs client must be connected to the Cisco
Modeling Labs server. The nodes in the network topology must be set to open AutoNetkit Visualization either
automatically, or after receiving a prompt.
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To access this setting, choose File > Preferences >Web Services > AutoNetkit Visualization.

Figure 42: AutoNetkit Visualization Setting

The available operations for this setting are:

Table 37: AutoNetkit Visualization Setting Operations

DescriptionOperation

Specifies the external web browser to use when displaying AutoNetkit
Visualization results. Options are:

• Default—the default system browser

•WebKit—based on the Safari web browser

•Mozilla Firefox

You are required to useMozilla Firefox, Google Chrome, or Apple
Safari as your default web browser. Internet Explorer is not
supported for AutoNetkit Visualization or for the UserWorkspace
Management interface.

Note

Preferred Web browser
engine

Tests the supported browsers that are available.Test all browser engines
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DescriptionOperation

Specifies whether to view configuration changes after a new build is
generated. Options are:

• Always

• Never

• Prompt

The default value is Prompt.

View configuration changes

Specifies when to open a browser window to display AutoNetkit
Visualization. Options are:

• Always

• Never

• Prompt

The default value is Prompt.

Open AutoNetkit
Visualization

Assigns a port value to the Web Service supporting AutoNetkit
Visualization. The default port is 8000. However, the port might need to
be changed depending on your network, for example, if a firewall is blocking
that port. The port value should be provided by the system administrator.

If an incorrect port value is entered, you will be prompted with an
error during the build stage.

Note

Visualization port

Restores the default state for the preferred web browser engine and restores
the default port value assigned to AutoNetkit Visualization.

Restore Defaults

Applies changes .Apply
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Web Browser Setting
This setting allows you to add, remove, or edit installed browsers. The selected browser is used by default
when web pages are opened in the Cisco Modeling Labs client for AutoNetkit Visualization.

Figure 43: Web Browser Setting

The available operations for this setting are:

Table 38: Web Browser Setting Operations

DescriptionOperation

Allows you to use an internal web browser built into the Cisco Modeling
Labs client to view AutoNetkit Visualization.

Use internal web browser

Allows you to use an external web browser. You can add new browsers,
delete or edit existing browsers, or search for new browsers to use.

You are required to use Mozilla Firefox, Google Chrome, or Apple
Safari as your default web browser. Internet Explorer is not supported
for AutoNetkit Visualization or for the UserWorkspaceManagement
interface.

Note

Use external web browser

Restores settings to the initial default state.Restore Defaults

Applies changes.Apply
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Secure Storage Setting
This setting configures security preferences and encryption requirements for storing system passwords.

Figure 44: Secure Storage Setting

The Password tab pools functionality related to the master password life-cycle and password providers.

The available options are:

Table 39: Password Tab Options

DescriptionOption

Clears cached master passwords from memory.Clear Passwords
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DescriptionOption

Lists the currently available password providers. By default, the enabled
provider with the highest priority is used to encrypt the data added to secure
storage. The priority range is from 0 to 10, with 10 being the highest priority.

Data can only be decrypted by the same provider that encrypted the
data. By default, all password providers are enabled. Each password
provider that has been used at least once will have a master password
associated with it. The Details text box provides information on the
master password providers.

Note

Master password providers

Changes the master password of the selected password provider.Change Password

Opens the password recovery dialog box. Use this option if you have forgotten
the master password and have configured password recovery questions. The
button is disabled if the password recovery setup was cancelled when the
master password was created.

The answers for the password recovery questions must be entered
exactly as they were during the password recovery setup. Answers
are case-sensitive, and white space inside answers are relevant.

Note

Recover Password

Restores to the initial default state.Restore Defaults

Applies changes.Apply

The Contents tab displays contents of the default secure storage. Secure storage is organized as a tree, where
nodes represent the context of information and values associated with each node. Selecting a node in the tree
displays a table of values associated with that node. Values stored in a nonencrypted form will be displayed;
the encrypted values will be shown as *********. At the bottom of this tab, you will find the actual file
location used to persist secure storage data. To force the changes to the contents of secure storage to be saved,
click Save.

To delete stored data in order to recover from an error or to reflect a change in the setup, click Delete. This
deletes the contents of secure storage. In some cases, other parts of the applicationmay depend on the contents
of secure storage that you deleted.

To avoid unexpected errors, we recommend that you restart the application after secure storage has been
deleted.

Caution

TheAdvanced tab provides a list of algorithms to further configure secure storage. Changes in the encryption
algorithm are applied only to the data stored after a change. If you have already created a secure storage, you
must first delete it and then re-create it to use the newly selected encryption algorithm.

Resetting the Secure Storage Password
When the Secure Storage feature is used for the first time, it generates a master password that is used to encrypt
the data. In the future, this same master password will be required to retrieve the data from secure storage. If
the master password becomes unavailable, the Secure Storage feature provides optional support for password
recovery.

Two methods are used to reset the secure storage password.

Method 1
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1 From within Cisco Modeling Labs client, choose File > Preferences > General > Security > Secure
Storage.

2 Click Change Password. The Secure Storage dialog box appears.
3 Click Yes. The Password Recovery dialog box appears.
4 Enter details for Question 1 and Question 2, along with answers for both. Take note of the answers you

provide, as these are treated as secondary passwords.
5 Click OK.

Method 2

If you are unable to access the Cisco Modeling Labs client due to a lost or forgotten secure storage password,
complete the following steps:

1 Move to the <user-home>/.eclipse/org.eclipse.equinox.security folder.
2 Delete the file secure_storage.
3 Open Cisco Modeling Labs client and provide details for the secure storage password, when prompted.
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C H A P T E R  3
Design a Topology

• Design a Topology Overview, page 69

• Topology Nodes and Connections, page 69

• Create a Topology Project, page 71

• Create a Topology, page 73

• Place the Nodes on the Canvas, page 74

• Create Connections and Interfaces, page 75

• Create Multipoint Connections, page 76

• Create a Site, page 77

• View the Topology on a Map, page 78

Design a Topology Overview
The design phase is the initial step in creating a network topology. During the design phase, you will perform
the tasks described in the following sections.

Topology Nodes and Connections
The topology you design consists of nodes and connection functions. Refer to the section Navigating Within
the Cisco Modeling Labs Client, on page 8 for additional information about how to select and edit nodes
and connection functions.

Topology Nodes

Cisco Modeling Labs provides the Cisco IOSv node subtype. Additional node types are available and can be
installed by the system administrator via the User WorkspaceManagement interface. See the UserWorkspace
Management chapter in theCiscoModeling Labs Corporate Edition System Administrator Installation Guide.
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Table 40: Node Subtypes

Node TypeNode Name

Router node. Runs a Cisco IOS operating system.Cisco IOSv

Server node. Runs a Linux operating system.Server

Router node. Runs a Cisco IOSXR operating system.
(Available separately.)

Cisco IOS XRv

Router node. Runs a Cisco CSR 1000 operating
system. (Available separately.)

Cisco CSR1000v

A node subtype is a virtual machine that runs on top of OpenStack, which itself is running in a Linux virtual
machine that is running on top of VMware software. Because the node is virtual, specific hardware is not
emulated. For example, there are no power supplies, no fans, no ASICs, and no physical interfaces. For all
router nodes, the interface type is a Gigabit Ethernet network interface. A server node has an Ethernet network
interface.

You can choose an image and image flavor for each node type. Refer to the User Workspace Management
chapter in theCiscoModeling Labs Corporate Edition System Administrator Installation Guide for information
on how to access the VM Image and the VM Flavor choices. In most cases, you need not select an image and
flavor. By default, the node subtype is associated with an image and flavor that runs with the topology.

Table 41: Node VM Images

Used ForVM Image Name

Server nodeserver

Cisco CSR1000v nodeCSR1000v

Cisco IOS nodeIOSv

Cisco IOS XR nodeIOS XRv

Table 42: Node VM Flavors

Used ForVM Flavor Name

Linux serverm1_tiny

Linux serverm1_small

Linux serverm1_medium

Linux serverm1_large

Linux serverm1_xlarge

Linux serverserver

Cisco CSR 1000v nodeCSR1000v
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Used ForVM Flavor Name

Cisco IOS XR nodeIOS XRv

Cisco IOS nodeIOSv

Each Linux flavor provides a different amount of memory and CPU allocated to the server.

Connection Functions

Cisco Modeling Labs provides the connection functions shown in the following table.

Table 43: Connection Functions

DescriptionConnection Type

Creates a connection between two interfaces.
Interfaces are created in the node to support a
connection. Any unused interfaces present are
automatically assigned. All the interfaces in router
nodes are represented as Gigabit Ethernet interfaces.
Multiple parallel connections are supported.

Connection

Creates a multipoint connection point. Multiple nodes
can connect to a multipoint connection.

Multipoint Connection

Creates a Layer 3 external connection point using
static network address translation (SNAT). This
external connection point allows connections outside
of Cisco Modeling Labs to connect to the topology.

Layer 3 External (SNAT)

Creates a Layer 2 external connection point using
FLAT. This external connection point allows
connections outside of Cisco Modeling Labs to
connect to the topology.

Layer 2 External (Flat)

Table 44: Site Groups

DescriptionType

Creates a site that can contain one or more nodes, and
additional groups of nodes. A site is a group of nodes
and you can create multiple site layers.

Site

Create a Topology Project
CiscoModeling Labs client provides a project folder and a sample topology that you can work with in addition
to creating your own project and topology.
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A topology project is a folder in which multiple topology files are stored. If you create many different
topologies, you can set up different projects for the topologies you create.

The three methods available for creating a topology project are discussed in the following sections.

Before You Begin

Before you begin the task of creating a topology project, you must complete the installation steps for your
system and set up the web services profile for the Cisco Modeling Labs client. Refer to the Cisco Modeling
Labs Corporate Edition System Administrator Installation Guide. See NavigatingWithin the Cisco Modeling
Labs Client, on page 8 for information on how to navigate the perspectives and views, and information
about the menu bars, toolbars, and editors. The navigation information is also available in the online help.

In addition, understand how:

• To navigate Cisco Modeling Labs client.

Method 1: Create a Topology Project from the Menu Bar

Step 1 From the menu bar, choose File > New > Other > Topology Project.
Step 2 Enter a Project Name and select the location in which to save the folder. A project folder is created in the default location

if you check the use default location check box. Alternatively, you can choose to save the project folder in another
location.

Step 3 Click Finish.

Method 2: Create a Topology Project from the Projects View

Step 1 Right-click Projects view.
Step 2 Choose New > Topology Project.
Step 3 Enter a Project Name and select the location in which to save the folder. A project folder is created in the default location

if you check the use default location check box. Alternatively, you can choose to save the project folder in another
location.

Step 4 Click Finish.
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Method 3: Create a Topology Project from the Toolbar

Step 1 Click the New Topology Project icon in the toolbar.
Step 2 Enter a Project Name and select the location in which to save the folder. A project folder is created in the default location

if you check the use default location check box. Alternatively, you can choose to save the project folder in another
location.

Step 3 Click Finish.

What to Do Next

Create a new topology file.

Create a Topology
Before You Begin

A topology project folder must exist.

There are several methods for creating a topology. These are discussed in the following sections.

Method 1: Create a Topology from the Menu Bar

Step 1 From the menu bar, choose File > New > Other > Topology.
Step 2 Select a topology project folder.
Step 3 Enter a filename, ensuring that it ends with the extension .virl.
Step 4 Click Finish.

A filename.virl topology file is created in the selected project folder.
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Method 2: Create a Topology from the Projects View

Step 1 Right-click Projects view.
Step 2 Choose New > Topology.
Step 3 Select a topology project folder.
Step 4 Enter a filename, ensuring that it ends with the extension .virl.
Step 5 Click Finish.

A filename.virl topology file is created in the selected project folder.

Method 3: Create a Topology from the Toolbar

Step 1 Click the New Topology File icon in the toolbar.
Step 2 Choose New > Topology.
Step 3 Select a topology project folder.
Step 4 Enter a filename, ensuring that it ends with the extension .virl.
Step 5 Click Finish.

A filename.virl topology file is created in the selected project folder.
filename.virl is a placeholder for example purposes only.Note

What to Do Next

Place the nodes.

Place the Nodes on the Canvas
Before You Begin

• A topology file must exist.

• The topology file must be open and the canvas visible in the Topology Editor.

Step 1 Click a node type, which is under the Nodes heading in the Palette view.
Step 2 Click the canvas at each point where you want a node. You can also drag the nodes on the canvas to position them. You

can then arrange the nodes using several methods:
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• Use Shift-click to select two or more nodes. Alternatively, click and drag a selection box around two or more nodes.
You can also use Ctrl+click (Windows) or Cmd+click (Mac OS X) to toggle between node selections.

• Use the Distribute Nodes tool on the toolbar to arrange the selected nodes vertically, horizontally, or to distribute
them on a grid.

The grid is determined dynamically, based on the selected
nodes.

Note

• Use the Align Nodes tool on the toolbar to arrange the selected nodes in a variety of alignments that you choose
from the Alignment drop-down list.

The use ofDistribute Nodes andAlignNodes is mutually exclusive.Note

• When no nodes are selected, use the Layout Nodes tool on the toolbar to arrange the nodes in a Tree Layout or a
Fruchterman-Reingold (F-R) Layout.

◦A basic tree layout is to choose a node as the root of the tree, and the nodes connected to the root become
children of the root node.

◦A F-R layout has connected nodes close to each other, while unconnected nodes are further apart from each
other.

See the section Toolbar, on page 13 for information on using these tools.

What to Do Next

Create connections and interfaces.

Create Connections and Interfaces
Before You Begin

Nodes must be in place on the canvas of the Topology Editor.

Step 1 Click Connection in the Tools view.
Step 2 Click the first node.
Step 3 Click the next node to create the connection.

When you connect two nodes, the interfaces are created and named automatically when you choose File >
Preferences > Topology Editor > Associate new connection with interfaces silently check box. You can
view the node interfaces when you click the connection and the two end points of the connection appear in the
Node Editor.

Note

Step 4 Repeat Step 2 and Step 3 until all the connections are in place.
You can create multiple parallel connections between two nodes. When a connection is selected, the Topology
Editor shows the connection end points and the Node Editor shows the two nodes involved in the connection,
all of the interfaces on those nodes, and all the connections between those two nodes.

Tip

Choose Export > Export Topology Diagram to Image to capture an image of the current topology on the
canvas.

Note
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What to Do Next

Create multipoint connections (optional).

Create Multipoint Connections
Multipoint connections are used in BUS topologies where all the nodes are connected to a single transmission
medium. This acts as the backbone of the connection and links all the nodes in the network. For example, for
four nodes to be directly connected to one another, 12 separate interface connections are needed, three in each
router, to fully connect each router to the other. By using a multipoint connection, each router has one
connection to the multipoint node.

Before You Begin

A topology file with the extension .virl must exist. Router nodes or server nodes are placed on the canvas.
Optionally, connections may exist between nodes.

Step 1 In the General view, clickMultipoint Connection.
Step 2 Click the area on the canvas where you want the multipoint connection node to appear.
Step 3 In the Tool view, click Connect.
Step 4 On the canvas, click the multipoint connection node then click an end node. A connection appears.

Continue clicking multipoint-node combinations until all connections are made.
You can have a connection between twomultipoint connection nodes as shown in the following figure.Note

Figure 45: Creating a Multipoint Connection

When performing alignment operations for multipoint connections on the canvas of the Topology Editor,
occasionally, these do not work as expected.

Note
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What to Do Next

• Create sites (optional).

• Show map background (optional).

Create a Site
A site is a container that can hold one or more nodes. It is used to group multiple nodes within the same site,
which provides a degree of hierarchy and simplifies the topology view.

A node interface within a site can connect to another node interface in the same site or to a node interface
located in a different site. A connection cannot start on a node and terminate on a site. Sites can be nested,
forming a hierarchical structure.

Before You Begin

One or more nodes should be on the canvas.

Step 1 In the General view, click Site.

Step 2 Click an area on the canvas to place the site.

Step 3 Shift-click the nodes that you want in the site, or click and drag a selection window around the nodes.

• From the Edit menu, choose Group to Site.

• Alternatively, you can drag the selected nodes to the site icon that you placed on the canvas.

Step 4 To view the site, select the site name from the drop-down list under the Topology tab.
A topology site tab opens and displays the site view.

The drop-down list under the Topology tab displays the site hierarchy as a navigation trail.

To open a site view, double-click on the site. The following figure shows the navigation trail selections for Site 1 and
Site 2.

Figure 46: Site Selection
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Step 5 To ungroup the site, click the site icon and choose Edit > Ungroup Site.
Step 6 To connect node interfaces between Site 1 and Site 2:

a) Select Site 1.
b) Click Connect.
c) Click the node that is the starting point of the connection, Site 1.
d) Move the cursor to the breadcrumbs and click Site 2.

Site 2 is displayed.
e) Click the node that is the endpoint of the connection.

A connection now exists between the interfaces in the two sites.

Step 7 To delete a node from a site:
a) Select the applicable node.
b) Right-click the node and select Delete from the list.

The node is deleted.

Step 8 To delete a site from a topology:
a) Select the applicable site.
b) Right-click the site and select Delete from the list.

The site is deleted including all associated interfaces and connections.

What to Do Next

Continue designing the topology.

View the Topology on a Map
The topology view is a schematic diagram. It shows the nodes and connections arranged in a logical fashion,
or represents a design that is easy to view. When you create a map view, you can move the nodes such that
they represent a physical location, for example, the locations of all router nodes in a city. Moving nodes on
a map view does not change their location in the topology view.

Within a topology file, each node is represented by two sets of coordinates. The location coordinates define
the node placement in the topology view. The map coordinates define node placement on the map view, by
latitude and longitude.

The map view uses the MapQuest database for map display.

Before You Begin

• A topology must exist with nodes and connections in place.
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• You must be connected to the Internet to use the mapping function, since it uses the map service from
MapQuest to retrieve the latest map images.

Step 1 With the topology view active, select Edit > Show map Background. Alternatively, you can click the Show Map
Background tool in the toolbar.

Step 2 Before you move a node, select the desired map location.
a) In theMap view, click the Go To Location icon, located under the pan and zoom controls.

• Type in the first few characters of a location.

• On a Windows platform, press Ctrl-Space and a list of matching locations appears.

• You can enter an airport code.

We recommend that you enter all upper-case or initial cap words when searching for locations, as these
provide more reliable results. For example, enter MEL or Mel to search for Melbourne airport.

Note

b) Select and click a location from the list.
c) Click OK.

The map location is displayed.
d) Use the pan and zoom controls on the map to determine an exact location. You can double-click the coordinates in

the Status bar, which opens the Go To Location dialog box.

Step 3 Click and drag the nodes into position on the map.
When you click and drag a node, the map coordinates are added to the .virl file and the node becomes a part of the map
view. When you open the map view again, the map location with the nodes is displayed.

Step 4 Continue to click and drag the nodes into position on the map view.
Step 5 Click the ShowMap Background tool in the toolbar to revert to the topology view. Note that the nodes in the topology

view are in their original layout.
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C H A P T E R  4
Build a Configuration

• Build a Configuration Overview, page 81

• Create and Modify a Node Configuration, page 81

• Create a Node Configuration Manually, page 82

• Use an Existing Node Configuration, page 83

• Import the Configuration from a Cariden MATE File, page 83

• Create Node and Interface Configurations Using AutoNetkit, page 84

Build a Configuration Overview
In the build phase, you build the configurations for each node. After selecting the options for the overall
topology and each node, you create the configuration files. Alternatively, you can use AutoNetkit to create
the configuration files.

You can modify and save configuration files for the topology and for each node in your topology.

Create and Modify a Node Configuration
While AutoNetkit is useful for generating configuration files for all the nodes in the topology, you can bypass
AutoNetkit and enter node configuration information directly.

You can enter configuration information in either of the following ways:

• During the design phase, copy and paste configuration commands for each node.

• During the simulation phase, connect to a node console and change its configuration when the topology
is running. See the chapter Simulate the Topology Overview for more information on how to modify,
extract, and save a running configuration.
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When you create your configuration files:Note

• Changes that are manually entered are not visible in the topology design. If you create a new interface
by entering configuration commands, the interface is not created in OpenStack nor does the interface
show up in any of the node views.

• Depending on how the AutoNetkit Auto-generate feature is set, you may overwrite the changes you
enter.

While in the Design perspective, any changes you manually make to a node configuration are saved in the
current filename.virl file. Before you launch a simulation from the Design perspective, a notification window
advises you to save the changes or cancel the simulation launch.

Figure 47: Save Changes Before Launch

Create a Node Configuration Manually
Before You Begin

The topology design should be complete.

Step 1 In the Topology Editor, click a node.
Step 2 In the Properties view, clickAutoNetkit and uncheck theAuto-generate the configuration based on these attributes

check box.

Figure 48: Uncheck Auto-generate Check Box

Step 3 Click Configuration.
Step 4 Enter the configuration commands in the Configuration view.
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All changes are automatically saved to the filename.virl file. However, the changes made do not appear in the
topology on the canvas.

Note

What to Do Next

Launch a simulation to observe the changes.

Use an Existing Node Configuration
You can use an existing configuration file to create a node configuration in Cisco Modeling Labs.

Before You Begin

The topology design should be complete.

Step 1 In the Topology Editor, click a node.
Step 2 In the Properties view, clickAutoNetkit and uncheck theAuto-generate the configuration based on these attributes

check box.
Step 3 Click Configuration.

a) Open the configuration file you want to use and copy the configuration commands.
b) In the Configuration view, paste the configuration commands.

All changes are automatically saved to the filename.virl file. However, the changes made do not appear in
the topology on the canvas.

Note

What to Do Next

Launch a simulation to observe the changes.

Import the Configuration from a Cariden MATE File
You can import a topology from an existing Cariden MATE file, version 5.2.0 or later. Cisco Modeling Labs
client will accept site imports up to two layers deep. Any Cariden MATE file that has a topology with more
than two layers of sites will not import correctly.

Before You Begin

A valid Cariden MATE file is available on your file system.

Cisco Modeling Labs client is running.

Your license allows Cariden MATE file import.

Step 1 Choose File > Import
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A window appears, prompting you to Import topology from the Cariden MATE file.
Step 2 Choose Import Cariden MATE File then click Next.

The license is checked. When confirmed, click Next.
Step 3 Choose the From data fileCariden MATE file to import. Use Browse to select the directory and file to import.
Step 4 Choose the location Into target folder for the Cariden MATE file. Use Browse to select the target Project folder.
Step 5 Enter a filename for the imported Cariden MATE file.

The filename you enter must have the extension .virl. For example, Lab_import.virl is a valid filename.
Otherwise, you cannot open the file in the topology editor.

Important

The Cariden MATE file converts to a Cisco Modeling Labs .virl file.
Step 6 In the Projects view, expand the project folder where you saved the imported file.
Step 7 Right click on the imported file, for example Lab_import.virl and choose Open With > Topology Editor.

A topology canvas opens and displays the topology.

What to Do Next

Visualize the configuration.

Run the simulation.

Create Node and Interface Configurations Using AutoNetkit
Before You Begin

The topology design should be complete.

Step 1 Verify the configuration for each node in the topology.
a) In the Topology Editor, click a node.
b) In the Properties view, click AutoNetkit. Verify Auto-Generate is checked or unchecked, depending on whether

AutoNetkit will generate a configuration for that node.
Any pre-existing configuration for this node is overwritten when you chooseUpdate Router Configurations
from the toolbar. Uncheck the Auto-generate check box if you do not want the router configuration for this
node updated by AutoNetkit.

Note

Step 2 Generate a configuration for the topology. Click Update Router Configurations from the toolbar. Alternatively, from
the menu bar, choose Run > Update Router Configurations. You are prompted to save any changes made since the
previous configuration update.
If the Auto-generate check box is checked for a node, the configuration updates are generated by AutoNetkit.

Step 3 AutoNetkit displays a notification after it generates the configuration. Click No to skip a comparison of configuration
changes. Click Yes to open a comparison view of the configuration changes.
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Figure 49: View Configuration Changes? Notification

Selecting the Remember my decision check box will always display configuration changes for subsequent
invocations. You can later change this behavior by choosing File > Preferences >Web Services >AutoNetkit.

Note

The .virl file opens and displays previous and current configurations side-by-side, with the changes highlighted. You
can scroll through the contents and see the differences. However, you cannot edit the configurations.

Figure 50: Show Configuration Comparison Side-by-Side

Click OK to close the comparison view.
Step 4 When you close the comparison view, a notification is displayed, and you can choose whether or not to open AutoNetkit

visualization.

• Click No to skip the visualization. You return to the Design perspective.

• ClickYes to display the visualization. TheAutoNetkit visualization opens in a browser window. For more information
about this feature, see Visualization Overview, on page 87.
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Figure 51: Open AutoNetkit Visualization? Notification

Selecting the Remember my decision check box will always open AutoNetkit visualization for subsequent
invocations. You can later change this behavior by choosing File > Preferences >Web Services >AutoNetkit.

Note
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C H A P T E R  5
Visualizing the Topology

• Visualization Overview, page 87

• Enabling AutoNetkit Visualization (for Windows Users), page 89

• Opening AutoNetkit Visualization, page 91

• Using Layers, page 92

• Changing the Settings, page 95

• Using Search, page 97

• Using Filters, page 98

Visualization Overview
The visualization phase allows you to see how the nodes interact in terms of routing protocol connectivity,
autonomous system (AS) numbers, Open Shortest Path First (OSPF) area, and so on. Before entering the
visualization phase, you must have designed the topology and built the node configurations.

Visualization is only available where node configurations are generated using parameters defined in
AutoNetkit.

Note

The AutoNetkit visualization runs in a browser window, either within the Cisco Modeling Labs client or in
a separate browser window. Ensure that you use a compatible browser, as described in the Cisco Modeling
Labs Installation Guides for the version of Cisco Modeling Labs that you are using.
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The following figure shows an overview of the visualization phase as it appears in a browser window.

Figure 52: Visualization Overview

Table 45: Visualization Overview

DescriptionIdentifier

Layers view selection. The layers shown correspond to the values selected when generating the
configuration. For example, if IGP is chosen as OSPF, an OSPF layer will be shown. If MPLS
is not used in the configuration, no MPLS layer will be shown.

1

Pan and zoom controls. Use the controls to pan the topology, zoom in and out on the topology,
adjust the display so that all the nodes are shown, and switch to a full-screen view.

2

Settings, search, and filter controls. Use the settings control to change the appearance of the
display. Use the search and filter controls to highlight specific nodes and connections.

3
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The following figure shows how the visualization compares to the topology design.

Figure 53: Topology Design

During the visualization phase, you perform the tasks described in the following sections.

Enabling AutoNetkit Visualization (for Windows Users)
To enable visualization for the Cisco Modeling Labs client on Windows, complete the tasks described in this
section.

Before You Begin

• Ensure that you have access to the Cisco Modeling Labs client.

Step 1 From the Cisco Modeling Labs client toolbar, choose File > Preferences > General >Web Browser.
The Web Browser Preferences dialog box appears.
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Figure 54: Web Browser Preferences

Step 2 Click the Use external web browser radio button.

On Windows, only Mozilla Firefox, Google Chrome, or Apple Safari are supported as default web browsers.
Internet Explorer is not supported for AutoNetkit Visualization.

Note

Step 3 In the External web browsers pane, check the Firefox check box.
Step 4 Click Apply and OK.
Step 5 Choose Preferences >Web Services > AutoNetkit Visualization.
Step 6 Under Open AutoNetkit Visualization, select the Always option.
Step 7 Click Apply and OK.

If the Firefox executable cannot be found, you will need to edit the path to find it (firefox.exe).
a) To do this, in the External web browsers pane (Step 3), select Firefox and click Edit.
b) Click Browse to navigate to the corresponding location and choose the Firefox executable.
c) Click OK to save the changes.
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Opening AutoNetkit Visualization
Before You Begin

Complete the task of building nodes and interfaces.

Step 1 Generate a configuration for the topology.
ClickUpdate Router Configurations from the toolbar. Alternatively, from the menu bar, chooseRun >Update Router
Configurations.

Step 2 View the configuration changes.
AutoNetkit displays a notification after it generates the configuration.

Figure 55: View Configuration Change Notification

• Click No to skip this step.

• Click Yes to open a comparison view of the configuration changes.

Step 3 Display the AutoNetkit Visualization view of the topology.
When you close the comparison view, a notification prompts you whether or not to open the AutoNetkit Visualization.

Figure 56: Open AutoNetkit Visualization

• Click No to skip this step.

• Click Yes to display the visualization.
The AutoNetkit Visualization opens in a browser window.

Choose File > Preferences >Web Services >AutoNetkit Visualization to control the prompts for visualization.Note
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Figure 57: AutoNetkit Visualization Window

What to Do Next

Explore the features in AutoNetkit Visualization.

Using Layers

Step 1 Verify if visualization is open in a browser window.
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The initial layer that is displayed in the browser window is the physical model of the topology, as shown in the following
figure. The physical model shows the nodes and interface connections between the nodes. It is similar to the Cisco
Modeling Labs topology view.

Figure 58: Physical Layer View

The options change depending on the router protocols configured. For example, if IPv6 is configured, you will
also see ebgp_v6

Note

Step 2 To select another view, place the cursor over the Layers view selection in the browser window. See Visualization
Overview, on page 87 for information on the Layers view selection.
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When you place the cursor over the layers view, several choices appear. For example, selecting ebgp_v4 will show the
IPv4 eBGP topology. This is constructed based on the AS property and node connections created in theTopology Editor,
as shown in the following figure.

Figure 59: ebgp_v4 Layers View

Step 3 Place the cursor over one of the nodes.
This action displays a pop-up view of information about that node. The type of information displayed depends on the
selected layer and node configuration.
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You can also hover over the connections to see connection details.Note

Figure 60: Node Pop-Up Information

Step 4 Continue selecting layer views and observe how the protocol-centric view changes. In a complex topology, you can use
the Layers views to verify that the protocols, nodes, and connections meet the design requirements.

What to Do Next

• (Optional) Change settings, use the Search feature, or use the Filter feature.

• (Optional) Return to the design and build phases to modify the topology and generate new configurations
and AutoNetkit Visualizations.

• (Optional) Run the topology simulation when you are satisfied with your configuration.

Changing the Settings

Step 1 In the AutoNetkit Visualization browser window, click Settings.
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The Settings window opens, as shown in the following figure.

Figure 61: AutoNetkit Visualization Settings Window

The following table lists the main settings.

Table 46: Main Settings

DescriptionSetting

Select ON to display the interface connection points. The default value is OFF.Interface

Select OFF to not resize the visualization automatically. The default value is ON.Auto Resize

Select a value from the drop-down list. The default value is label, which is the node name.
This node name is configured in Cisco Modeling Labs for each node.

Node Label

Select a value from the drop-down list. The default value is none.Link Label

Select ON to change the visualization display to a high-contract color scheme. The default
value is OFF.

High Contrast

Step 2 Observe the changes in the display when you select different settings.
Step 3 To close the Settings view, click the Settings tab.

What to Do Next

• (Optional) Change settings, use the Search feature, or use the Filter feature.

• (Optional) Return to the design and build phases to modify the topology and generate new configurations
and AutoNetkit Visualizations.

• (Optional) Run the topology simulation.
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Using Search

Step 1 In the AutoNetkit Visualization browser window, click Search.
The Search window opens.

Figure 62: AutoNetkit Visualization Search Window

The Search window contains the main options that are listed in the following table.

Table 47: Search Window Main Options

DescriptionOption

Selects a search attribute from the drop-down list. The default value is label.Search nodes using

Identifies keywords based on the attribute selected in the Search nodes using drop-down list.
Keywords are case-sensitive.
Wildcard selections are not supported. For example, searching asnwith the keyword 65* does
not modify the display, even if ASN values of 65000 and 65001 exist in the topology
configuration. Partial matches are not supported for numeric node values.

Partial matches are supported in alphanumeric fields. For example, selecting label and entering
the keyword P matches all the node labels that begin with a capital P or have a capital P
anywhere in the label.

Enter keywords here

Clears the keywords.Clear
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The following figure shows the values you can select from the Search nodes using drop-down list.

Figure 63: Search Window Drop-Down List

Step 2 Observe the visualization and how the different items are highlighted when they match the combination of Search nodes
using and keywords that you enter.

Step 3 To close the Search window, click the Search tab.

What to Do Next

• (Optional) Change settings, use the Search feature, or use the Filter feature.

• (Optional) Return to the design and build phases to modify the topology and generate new configurations
and AutoNetkit Visualizations.

• (Optional) Run the topology simulation.

Using Filters

Step 1 In the AutoNetkit Visualization browser window, click Filter.
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The Search window opens.

Figure 64: AutoNetkit Visualization Filter Window

The Filter window contains the main options that are listed in the following table.

Table 48: Filter Window Main Options

DescriptionOption

Clears all the checked selections.Clear

The selections that are available for filtering depend on the topology configuration. Values
that do not exist in the topology configuration do not appear in the selection window.

You can further drill down or expand your search using the parameters OR within a
keyword and AND between keywords.

Note

Selections
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For example, if your configuration contains multiple AS values, you can filter the display to show only AS values that
match 65000.

Figure 65: Filter AS Value 65000

Step 2 To close the Filter window, click the Filter tab.

What to Do Next

• (Optional) Change settings, use the Search feature, or use the Filter feature.

• (Optional) Return to the design and build phases to modify the topology and generate new configurations
and AutoNetkit Visualizations.

• (Optional) Run the topology simulation.
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C H A P T E R  6
Simulate the Topology

• Simulate the Topology Overview, page 101

• Launch a Simulation, page 103

• Connect to a Simulation Node Console, page 105

• Stop an Entire Simulation, page 107

• Stop a Single Node, page 108

• Start a Single Node, page 109

• Modify a Node Configuration in the Simulation, page 110

• Extract and Save Modified Configurations, page 111

Simulate the Topology Overview
The simulation phase is when you run the simulation of your topology design. The Simulation perspective
provides a set of views that support the simulation phase. By comparison, the design and build activities occur
in the Design perspective, which provides a set of views that support the design activity. Some views in the
Simulation perspective can also be viewed in the Design perspective.
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Simulation Perspectives and Views

The main areas of focus within the Simulation perspective are the Simulations view and the Console view.
The following figure highlights the Simulation and Console views for a running simulation.

Figure 66: Simulation Perspective Initial Display

From theViewmenu, you can open additional views in the perspective and arrange the open views by dragging
them within the perspective workspace. See the online help and the section Customizing Perspectives, on
page 19 for more information.

To reset your current perspective to its original configuration when the workbench was first opened,
right-click the perspective button and select Reset.

Note

Node Limits

In Cisco Modeling Labs 1.0 Corporate Edition, the number of nodes you can run is limited by the resources
available on the server and the number of licenses available. In Cisco Modeling Labs 1.0 Corporate Edition,
the design limit is 1,000 nodes.

During the simulation phase, you can perform the tasks described in the following sections.
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Launch a Simulation
Before You Begin

• Complete the topology design.

• Complete the task of building the nodes and interfaces.

• (Optional) Generate the configuration using AutoNetkit.

When you manually make changes to a node configuration and bypass AutoNetkit
auto-generation, those changes do not appear in the topology view of the Design
perspective or Simulation perspective. For example, if you use the hostname command
to change the host name from iosv-1 to Router-1 in the configuration, the node name
in the topology view and in other related views remains as iosv-1.

Caution

• Open the desired topology.

The topology should be open and visible in the Topology Editor. If you have multiple
topologies open in the Topology Editor, simulation will launch for the currently active
view.

Note

Step 1 From the toolbar, click the Launch Simulation button.
The simulation launches and provides a unique identifier, which means that multiple instances of the topology can be
launched and each will have a unique name.

Step 2 In the Launching Simulation dialog box, select any of the following actions:

a) Check the Always run in the background check box. All future node start requests, stop requests, and simulation
launch requests run in the background and do not display dialog boxes.

To control the background setting, chooseFile >Preferences >General.Note

b) Click Run in background. The dialog box closes when the node simulation starts.
c) Click Cancel to return to the Design view.
d) Take no action, and the node simulation launches momentarily.

When you click Run in background, the status bar displays a progress icon. Click the icon to display a
compact view of the activity progress. If the background activity encounters an error, the icon shows a red
X. Click the error icon to display the error dialog.

Tip
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Step 3 In the Simulation launched dialog box, click OK.

Step 4 When prompted to switch to the Simulation perspective, click Yes.

We recommend that you switch to the Simulation perspective to view the running simulation and to connect
to node consoles.

Note

The Cisco Modeling Labs client tracks the state of the simulations. All launched simulations appear in the Simulations
view. Status messages are displayed in theConsole view. After the CiscoModeling Labs server has started the simulation
launch, a confirmation dialog box appears with an identifier assigned to the simulation by the Cisco Modeling Labs
server.
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When the nodes are running on the Cisco Modeling Labs server, they are displayed in the Simulations view with the
status as [ACTIVE], as shown in the following figure.

Figure 67: Simulation Launched in Simulation View

Connect to a Simulation Node Console
Before You Begin

• Launch a simulation.

• Ensure that the Simulation perspective is active.
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• Ensure that the Simulations view and Console view are displayed.

Step 1 To connect to a console for a specific node, right-click the node in the Simulations view and choose Telnet > to its
Console port.

Figure 68: Connecting to a Node Console

A new Terminal view opens.

Figure 69: Terminal View

Step 2 To disconnect a terminal from the simulation, click Disconnect in the Terminal view toolbar or click the Close icon in
the Terminal view.

When you disconnect or close a terminal view, all text in the view is discarded.Note

After you disconnect a terminal, but do not close the terminal window, you can press Enter to reconnect the
terminal.

Tip
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Stop an Entire Simulation
There are several methods for stopping an entire simulation. These are discussed in the following sections.

Method 1: Stop an Entire Simulation from the Toolbar

Step 1 In the toolbar, click the Stop Simulations button.
A Stop Simulation(s) dialog box appears.

Step 2 In the Simulation column, click once to highlight the simulation to stop.
Step 3 (Optional) To save the configurations, click the adjacent setting in theExtract Configurations? column until the prompt

changes to Yes.
Configurations for server nodes are not
extracted.

Note

Step 4 (Optional) To close the internal terminals associated with the simulation, click the adjacent setting in theClose Terminals?
column until the prompt changes to Yes.

External terminal connections are not stopped as part of this operation and must be closed manually.Note

Step 5 To stop the simulation, click the adjacent setting in the Stop Simulation? column until the prompt changes to Yes.
Step 6 Click OK to confirm stopping the simulation, or click Cancel to leave the simulation running.

Figure 70: Stop Simulation(s) Dialog Box

On Mac OS X, you update the values for Extract Configurations?, Stop Simulation? and Close Terminals? in the
columns directly. You do not need to select the name of the simulation.

When stopping a simulation, you cannot attempt to stop individual nodes running in the simulation at the same
time. This behavior is not supported.

Note
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Method 2: Stop an Entire Simulation from the Simulations View

Step 1 In the Simulations view, right-click the Simulation name and select Stop Simulation. The Stop simulation confirmation
dialog box appears.

• (Optional) Check the Extract configurations before stopping simulation check box to save the current
configurations.

• (Optional) Check theClose associated terminal views check box to close all the open internal terminals associated
with the specific simulation. External terminals are not closed.

Step 2 Click OK to stop the simulation.
Once selected, all nodes in the simulation start shutting down. It may take a few minutes for the simulation to shut down
completely and to disappear from the Simulations view.

When stopping a simulation, you cannot attempt to stop individual nodes running in the simulation at the same
time. This behavior is not supported. Note too for instances where a user account expires, any running simulations
for that user continue to run. Since the user account can no longer log into stop them, they will remain active
until the next system reboot or until the system administrator explicitly stops them.

Note

Stop a Single Node

Step 1 In the Simulations view, right-click the node to stop and select Stop this node.

The Are you sure dialog box appears.

Step 2 Click OK to stop the simulation. Alternatively, click Cancel to abandon the operation and return to the simulation.
When you clickOK, the node stops without saving any changes to the configuration.Note

When a node is stopped, its status changes to [DELETED].
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What to Do Next

• (Optional) Start a node.

• (Optional) Stop the simulation.

Start a Single Node

Step 1 Right-click a stopped node.
When a node is stopped, its status changes to [DELETED].

Step 2 Click Start this node.

The Requesting start dialog box appears.

Step 3 Choose one or more of the following actions:
a) Check the Always run in the background check box. All future node start requests, stop requests, and simulation

launch requests run in the background and do not display dialog boxes.
To control the background setting, chooseFile >Preferences >General.Note

b) Click Run in background.
The dialog box closes while the node simulation stops.

c) Click Cancel to return to the Simulations view.
d) Take no action and the node simulation restarts momentarily.
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When you click Run in background, the status bar displays a progress icon. Click the icon to display a compact
view of the progress. If an error is encountered, the icon shows a red X. Click the error icon to display the error
dialog box.

Tip

What to Do Next

• (Optional) Stop the simulation.

Modify a Node Configuration in the Simulation

Step 1 Connect to a console on a router node. Right-click the node in the Simulations view and choose Telnet > to its Console
port.

Figure 71: Connecting to a Node Console

A new Terminal view opens.

Figure 72: Terminal View

Step 2 If no banner or router prompt is visible, press Enter.
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You are now working with the operating system running on the node, for example, Cisco IOS software.
Step 3 Use the operating system commands to view or modify the node configuration.

Changes you make to the configuration do not appear in the canvas of theTopology Editor.Note

Extract and Save Modified Configurations
Before You Begin

• You have modified a configuration within one or more nodes running within the simulation and want
to save the changes.

• Ensure that all routers in the simulation are operational before attempting to extract their configurations.

Step 1 In the Simulations view, right-click the topology name, making sure not to click the node name, and select Extract
Configurations.

Figure 73: Simulations View Context Menu

A confirmation dialog box appears.
Step 2 Ensure that all external Telnet connections to the simulation are closed before proceeding.

Youmust close all external Telnet connections to the simulation before you can proceed.Note

Figure 74: Extract Configurations Dialog Box

Step 3 Click OK.
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A dialog box appears.

Step 4 Click Run in Backgroud.
When the extraction is complete, a message is displayed.

Figure 75: Extraction Complete Message

The configuration information is extracted and saved in the filename.virl file that corresponds to the topology.
For example, the file New_Topology that is running as a New_Topology-dkIFaW simulation has its configuration
extracted to the file New_Topology.virl.

Note

Step 5 Click OK.

What to Do Next

• (Optional) Stop the simulation.

• (Optional) Stop a single node in the simulation.
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C H A P T E R  7
External Connectivity in Cisco Modeling Labs

• External Connectivity to a Node, page 113

• Set Up a FLAT Network for Out of Band (OOB) Management Access, page 114

• Set Up a FLAT Network for Inband Access, page 117

• Set Up a SNAT Network for Inband Access, page 119

External Connectivity to a Node
Depending on how the Cisco Modeling Labs environment has been set up by the system administrator, you
may have several ways to externally connect to the nodes in a running simulation.

1 Bypass the Cisco Modeling Labs client and connect directly to nodes via Out of Band Management IP
access using FLAT

If enabled by the system administrator, when designing your virtual network, you can specify that you
want all nodes to be configured on a reserved management network. All management interfaces are
connected to a shared management network segment known as FLAT. This set up will allow you to bypass
the Cisco Modeling Labs client and connect directly via Telnet to the nodes.

2 Connecting to external devices using FLAT Inband access

When enabled, you can configure your virtual topologies to connect and pass data-plane and control-plane
packets to one or more external devices such as routers or traffic generators during a simulation. Since
FLAT is a Layer 2 solution, the IP addresses in your topology are reachable externally. The L2 External
FLAT tool in the Cisco Modeling Labs client GUI is used to enable this option.

Your simulation continues to be driven through the Cisco Modeling Labs client GUI by communicating
with the Cisco Modeling Labs server at its IP address that is bound to the relevant management port.

Note

3 Connecting to external devices using SNAT Inband access

As an alternative to Inband access using FLAT, you can set up the Static NAT (SNAT) approach. SNAT
is a Layer 3 solution that leverages the use of an internal SNAT router to hide the IP addresses in your
topology. This router, internal to the Cisco Modeling Labs server, translates IP addresses inbound and
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outbound which means that the addressing schemes used on the virtual topology are not propagated outside
the virtual network.

When configured, an internal and an external address are assigned to the SNAT-assigned interface on the
nodes. For example, configuring 10.11.12.1 as the internal address, andmapping it to 172.16.2.51 externally.
Traffic sent to 172.16.2.51 will be translated to the correct internal address and presented to the appropriate
node.

The L3 External SNAT tool in the Cisco Modeling Labs client GUI is used to enable this option.

Your simulation continues to be driven through the Cisco Modeling Labs client GUI by communicating
with the Cisco Modeling Labs server at its IP address that is bound to the relevant management port.

Note

Set Up a FLAT Network for Out of Band (OOB) Management
Access

By using an out-of-band (OOB) network connection to the Cisco Modeling Labs simulation, you can connect
an external application to the Management port of any router node in the simulated network. All management
ports will have an IP address on the OOB network, which is a separate network from the other interface IP
addresses.

Before You Begin

• Ensure that you have installed a third-party application for Telnet connections, such as PuTTY.

• Ensure that FLAT connectivity has been enabled by the system administrator.

Step 1 Log in to the Cisco Modeling Labs client.
Step 2 Verify you have connectivity to the Cisco Modeling Labs server.
Step 3 Open the Design perspective, if it is not already open.
Step 4 Open an existing topology or create your network topology. See the section "Create a Topology" for information on how

to do this.
Step 5 Configure the OOB management network.

a) Click on the Topology Editor canvas.
b) Choose Properties > Topology.
c) LocateManagement Network and select Shared flat network from the drop-down list.
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The Shared flat network option is what enables the OOB connectivity.
Step 6 From the toolbar, click the Update Router Configurations tool.

For the purpose of this task, you may retain the default
settings.

Note

Step 7 After the build phase is completed, initiate the simulation by clicking the Launch Simulation tool in the toolbar, and
then change to the Simulation perspective.

Step 8 (Optional) Enter the ping command on the PC to confirm that the management port on a running node can be reached.
a) In the Cisco Modeling Labs client simulation, select a router node and display the IP address for its management

port. In this example, the IP address for the node management port is 172.16.1.51.

b) In the PC command window, enter the ping command to target the node management port identified in Step 8a.

Step 9 (Optional) In the CiscoModeling Labs client simulation, connect to a console port on a node and confirm the management
network IP address exists. Enter the show ip interface brief command to display the IP addresses. For this example,
use the IP address 172.16.1.51.
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Step 10 Launch and configure a terminal emulator for a Telnet connection to the node management port. In this example, the
PuTTY application is used.
a) Launch the PuTTY application.
b) In the PuTTY Configuration window, enter the IP address for a Telnet connection to the management port. In this

example, the IP address for the node management port is 172.16.1.51.

c) When successful, a Telnet window opens and the router console information is displayed.
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Set Up a FLAT Network for Inband Access
The following procedure describes how to connect your virtual network topology to physical devices that are
external to the Cisco Modeling Labs server environment. In this procedure, you will be configuring a FLAT
network. A FLAT network uses Layer 2 connectivity in which the IP address information about your virtual
network can be viewed externally.

Before You Begin

• Ensure that the system administrator has configured the Cisco Modeling Labs server to allow FLAT
connections.

• Ensure that you obtain the IP address of the default gateway from the system administrator.

• Ensure that you have the IP address of the external device to which the nodes will connect.
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We recommend that you first draw your intended design, and then label the devices with the appropriate
IP addresses.

Note

Step 1 Log in to the Cisco Modeling Labs client.
Step 2 Verify you have connectivity to the Cisco Modeling Labs server.
Step 3 Open the Design perspective, if it is not already open.
Step 4 Open an existing topology or create your network topology. See the section "Create a Topology" for information on how

to do this.
Step 5 Click on the canvas to open the Topology tab in the Properties view and ensure thatManagement Network displays

<not specified>.
Step 6 From the Palette view, under General, click the L2 External FLAT tool, and then click the canvas to add one FLAT

cloud network icon to each corresponding node icon on the canvas.
Step 7 From the Palette view, under Tools, click the Connect tool and connect the L2 External FLAT to the desired nodes.

L2 External FLAT connections can only be assigned to one interface on one
node.

Note

Step 8 From the toolbar, click the Update Router Configurations tool.

For the purpose of this task, you may retain the default
settings.

Note

The system automatically assigns an IP address to the node interface that is connected to the FLAT cloud during the
Simulation phase, not the Build phase.

Step 9 After the build phase is completed, start the simulation by clicking the Launch Simulation tool in the toolbar, and then
change to the Simulation perspective.

Step 10 Log in to the node that is connected to the FLAT network when its state has changed to ACTIVE.
Step 11 View the IP address assigned to the FLAT network and determine if it is on the same subnet as the gateway IP address

provided by your system administrator. The L2 external address for each node can be viewed from the Simulations view
or from each individual node.

• If yes, continue to Step 12.

• If no, advise your system administrator and request the correct gateway IP address.

Step 12 If the external device is on a different subnet, define a default gateway or a broadcast domain that points to the IP address
of the gateway that the system administrator supplies.

Prior to completing this step, if you do a show route, you will see that no default gateway is defined in the node. This
is the default set up. This step allows you to inform the node what path to take in order to reach the external environment
via the gateway. An alternative to defining a gateway or static route, with IOSv devices, is to enable DHCP on the
interface used for external connectivity.

Not all virtual images support DHCP. Check the supported features for the virtual images to determine which
ones do support DHCP.

Note

Step 13 Test the connection by pinging from the node to the external (physical) device. If required, turn on debug ip icmp or
use the tracert command to see the progress through the network.

Youmust repeat steps 10-13 for each node that is connected to the FLAT network.Note
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If the ping does not work, confirm with your system administrator that the Cisco Modeling Labs server is configured to
support FLAT connectivity and that the gateway IP address you have been provided is correct.

If these items are correct, ping to each of the key devices in the path to determine where the failure occurs and notify
your system administrator of the failure source if it is outside your Cisco Modeling Labs environment.

Set Up a SNAT Network for Inband Access
SNAT functionality also allows connected nodes to connect to external devices. Using SNAT, the connectivity
occurs at Layer 3 and allows you to hide the simulated virtual network behind a Static NAT address block.
The Cisco Modeling Labs server will do a static IP address translation (hence SNAT), translating the private
address range allocated to the SNAT ‘inside’ network into the IP network configured for the SNAT ‘outside'
network. By default, Cisco Modeling Labs uses an internal gateway function that acts as a SNAT router.

In the example used here, the iosv-1 GE 0/2 interface has two IP addresses. The addresses on the 172.16.22.0
subnet are reachable from the external devices and will be translated to the internal addresses which are on
the 10.11.58.0 network.

Figure 76: SNAT Functionality

Using SNAT, the iosv-1 host will have an internal IP address from the 10.11.58.0 infrastructure network on
its interface facing the SNAT cloud (10.11.58.2). This will be mapped by the SNAT router for that segment
into 172.16.22.53. Assuming that the SNAT interface is connected and there is another host on that segment,
such as a gateway, you can now connect to the iosv-1 router via the 172.16.22.53 address.

No default gateway is created on the IOSv router. A static route must be added to the iosv-1 router
configuration similar to the following example:
ip route 0.0.0.0 0.0.0.0 10.11.58.1

where 0.0.0.0 0.0.0.0 refers to all destination IP addresses not found in the routing table and 10.11.58.1
refers to the SNAT router.

Note
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Before You Begin

• Ensure that the system administrator has configured the Cisco Modeling Labs server to allow SNAT
connections.

• Ensure that the system administrator provides you with the internal and external IP addresses of the
SNAT router.

• Ensure that you have the IP address to the default gateway.

• Ensure that you have the IP address of the external device to which the nodes will connect.

Step 1 Log in to the Cisco Modeling Labs client.
Step 2 Verify you have connectivity to the Cisco Modeling Labs server.
Step 3 Open the Design perspective, if it is not already open.
Step 4 Open an existing topology or create your network topology. See the section "Create a Topology" for information on how

to do this.
Step 5 Click on the canvas to open the Topology tab in the Properties view and ensure thatManagement Network displays

<not specified>.
Step 6 From the Palette view, under General, click the L3 External SNAT tool, and then click the canvas to add one SNAT

cloud network icon to each corresponding node icon on the canvas.
Step 7 From the Palette view, under Tools, click the Connect tool and connect the L3 External SNAT to the desired nodes.

L3 External SNAT connections can only be assigned to one interface on one
node.

Note

Step 8 From the toolbar, click the Update Router Configurations tool.

For the purpose of this task, you may retain the default
settings.

Note

The system automatically assigns the internal and external IP addresses to the node interface that is connected to the
SNAT cloud during the Simulation phase, not theBuild phase. Therefore, no assigned addresses are visible at this point.

Step 9 After the build phase is completed, start the simulation by clicking the Launch Simulation tool in the toolbar, and then
change to the Simulation perspective.

Step 10 Log in to the node that is connected to the SNAT network when the status of the device has changed to ACTIVE.
Step 11 Create a static route or define a default gateway for the external connection IP addresses that point to the SNAT router’s

internal IP address. For example, if the external connections are part of the subnet 172.16.2.0/24, and the SNAT router’s
internal IP address is 10.11.11.1, then the route statement would be:
ip route 172.16.2.0 255.255.255.0 10.11.11.1

An alternative to defining a gateway or static route, with IOSv devices, is to enable DHCP on the interface used for
external connectivity.

Not all virtual images support DHCP. Check the supported features for the virtual images to determine which
ones do support DHCP.

Note

Step 12 Test the connection by pinging from the node to the external (physical) device. If required, turn on debug ip icmp or
use the tracert command to see the connectivity between the end points.

If the ping does not work, confirm with your system administrator that the Cisco Modeling Labs server is configured to
support SNAT connectivity and that the gateway IP address you have been provided is correct.
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If these items are correct, ping to each of the key devices in the path to determine where the failure occurs and notify
your system administrator of the failure source if it is outside your Cisco Modeling Labs environment.
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