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Applications
The following sections provide information about applications.

About Application Visibility
The Application Visibility service lets you manage your built-in and custom applications and application sets.

The Application Visibility service, hosted as an application stack within Cisco DNA Center, lets you enable
the Controller-Based Application Recognition (CBAR) function on a specific device to classify thousands of
network and home-grown applications and network traffic.

You can install the following packages:

• Application Policy: Lets you automate QOS policies across LAN, WAN, and wireless within your
campus and branch.

• Application Registry: Lets you view, manage, and create applications and application sets.

• Application Visibility Service: Provides application classification using Network-Based Application
Recognition (NBAR) and CBAR techniques.

NBAR supports provisioning of up to 450 interfaces on Cisco Catalyst 9000 devices. Cisco DNA Center
Application Visibility does not exceed this 450-interface limit.

To ensure compatibility, the preceding packages must have the same package version.Note
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If you install Application Registry or both Application Registry and Application Policy, you can see the
Applications and Application Sets tabs when you click the menu icon and choose Provision > Application
Visibility Setup.

If you install Application Registry and Application Visibility Service or Application Registry, Application
Policy, and Application Visibility Service, you can see theApplications,Application Sets,Network Devices
Enablement, andCBAR Extensions tabs when you click the menu icon and chooseProvision >Application
Visibility Setup.

Application Visibility Setup View
The following table describes the dashlets and charts that are available in the Overview tab in Provision >
Services > Application Visibility Setup.

DescriptionItem

This chart displays the number of applications available in the Cisco DNA
Center application that can be used in Application Policy. The applications
are classified as follows:

• Custom: Applications added by a user

• Built-in: Preinstalled applications in Cisco DNA Center

• Discovered: Applications discovered by different recognition methods
and imported into the application registry

The chart shows that the applications observed only on
CBAR-enabled devices.

Note

Applications
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DescriptionItem

Shows the total number of devices, devices with warning, and devices with
error.

Devices

This widget displays the service health and the average health score for all
CBAR-enabled devices. The device is healthy if there are no outstanding
errors or warnings on that device.

The CBAR health score is calculated across all CBAR-enabled devices.

You can view the CBAR health of each CBAR-enabled device. A 0%CBAR
health score indicates that the device has at least one error (P1). A 50%
CBAR health score indicates that the device has no errors but has at least
one warning (P2). A 100% CBAR health score indicates a healthy device.

CBAR

All issues are classified by priority:

• Errors (P1)

• Warnings (P2)

• Others (P3)

Click the P1, P2, and P3 tabs to view the device issues and remedy details.

Issues

This chart displays the number of devices classified by each of the
application recognition methods:

• CBAR: CBAR-enabled devices such as routers and switches

• NBAR: NBAR-based devices such as routers, switches, CiscoWireless
Controllers, and Cisco Catalyst 9800 Series Wireless Controller

• IP/port: IP/port-based devices such as switches

• Not supported: Devices that aren’t supported by any of the preceding
methods

Network Devices by
Application Recognition
Method

This chart displays the device count in each CBAR readiness status.

• Enabled: Devices that are CBAR-enabled

• Ready: Devices that are ready for enabling CBAR

The info icon next to Ready status shows that the
respective device is wireless enabled.

Note

• Not Ready: Devices that support CBAR but aren’t ready for enabling
CBAR due to some issues

• Not Supported: Devices that don’t support CBAR

Network Devices by CBAR
Enablement Status
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DescriptionItem

This chart displays the device application telemetry enablement status.

• Enabled: Devices that are application telemetry-enabled

• Ready: Devices that are ready for enabling application telemetry

• Not Ready: Devices that support application telemetry but aren’t ready
for enabling application telemetry due to some issues

• Not Supported: Devices that don’t support application telemetry

Network Devices by
Application Telemetry
Enablement Status

The following table describes the device information and statuses that are available in Site Devices table,
under Network Devices Enablement tab:

DescriptionColumn

Name of the device. Click the device name to view the CBAR Service
Status.

Device Name

IP address of the device.Management IP

Group of related devices, such as routers, switches and hubs, or wireless
controllers.

Device Type

The site to which the device is assigned.Site

The fabric domain to which the device is assigned.Fabric

Role assigned to each discovered device during the scan process. The device
role is used to identify and group devices according to their responsibilities
and placement within the network. If Cisco DNA Center cannot determine
a device role, it sets the device role to Unknown.

Role

Shows the device recognition method (CBAR, NBAR, IP/Port, or Not
Supported).

Active Recognition Method

Cisco IOS software that is currently running on the device.OS Version

Hover over the status displayed in the CBAR Readiness Status column to
view the Remedy message.

CBAR Readiness Status

Shows the current version of the protocol pack installed on the device and
the protocol pack update status.

Protocol Pack Version

Shows the synchronization status of the device with the application registry.
Hover over the info icon or the error icon to view more details about the
synchronization status.

Device Registry Status

Shows the CBAR deployment status.

For more information, see Reconfigure CBAR on Network Devices, on
page 9.

CBAR Deployment Status
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DescriptionColumn

Click the issues in the Service Health Status column to open the CBAR
Service status page, which displays a complete list of issues and the service
status information of a device. If you click the Cisco Catalyst 9K device
name, you can view the footprint (service load, CPU, and flows) of the
CBAR service.

Service Health Status

Shows the device readiness for Application Telemetry.Application Telemetry
Readiness Status

Shows Application Telemetry deployment status for the device. If the
deployment fails, click the link to view the details of failure.

Application Telemetry
Deployment Status

The application policy applied to the device. For CiscoWireless Controllers
with more than one application policy, the number of application policies
applied and the name of all the applied application policies are displayed.

Application QoS Policy

Shows the number of WAN interfaces. Click the WAN interface details to
view the WAN connectivity settings for the device.

WAN Interfaces

Shows the number of Trunk interfaces. Click the Trunk interface details to
view the Trunk connectivity settings for the device.

Trunk Interfaces

Configure CBAR Cloud
The Application Visibility service uses the CBAR cloud to enrich the protocol pack and enhance visibility
for unknown applications by sending and receiving data from the cloud.

Step 1 From the top-left corner, click the menu icon and choose Provision > Application Visibility Setup.
Step 2 Click CBAR Extensions > CBAR Cloud tab.
Step 3 Click the cloud authentication link to connect with Cisco DNA - Cloud, to enable CBAR and to gain access to CBAR

Application Intelligence data.

You will be redirected to System > Settings > Cloud Authentication window.

Step 4 You should generate a token in Cisco DNA - Cloud and enter it in Cloud Authentication window. Click Where did
I get my token Encryption Key link to generate a token.

If you do not have a Cisco DNA - Cloud account, click dna.cisco.com link.

Step 5 In the Cisco DNA - Cloud GUI, click the menu icon, click Applications, and choose Products.
Step 6 From the Region drop-down list, choose the appropriate region and click Register.
Step 7 In the Register Product pane, enter the required details, such as Host Name/IP, Name, and Description (if any).

Choose the appropriate type of product being registered from the Type drop-down list, such as Cisco DNA Center.
Click Register.

Check the Enable Cloud Access Login check box to enable automatic login from your Cisco DNA –
Cloud to Cisco DNA Center.

Note

The OTP redemption occurs automatically, and Cisco DNA Center opens in a new window.
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Step 8 If you want to connect manually, the OTP Generated dialog box appears after successful registration of Cisco DNA
Center. To copy the OTP, click Copy, and click Close.

Step 9 Navigate back to the Cloud Authentication window to establish the connection:
a) In the Cisco DNA Center GUI, click the menu icon and choose System > Settings > Cloud Authentication.
b) Click Add OTP Key.
c) In the OTP Code field, paste the OTP that you generated and copied in the Cisco DNA - Cloud application, and

click Done.

On successful establishment of the connection, CBAR Cloud is enabled by default.

Step 10 You can view the list of available CBAR Dynamic Application Feeds under CBAR Cloud tab. To enable all the
application feeds, click All radio button.

The newly introduced application feed is automatically enabled for your network, if you select all feeds.Note

To enable the required application feeds, do the following:

a. Click Selected only radio button.

b. Check the check box next to the application feed that you want to select.

c. Click Apply.

In Selected only mode, the newly introduced application feeds are not imported to the network until you
manually select it.

Note

Enable/Disable CBAR Cloud

Before you begin

Ensure to establish connection between Cisco DNA Center and Cisco DNA-Cloud. For more information,
see Configure CBAR Cloud, on page 5.

Step 1 From the top-left corner, click the menu icon and choose Provision > Application Visibility Setup.
Step 2 Click CBAR Extensions > CBAR Cloud tab.
Step 3 To enable CBAR Cloud, click the Enable toggle button.
Step 4 To disable CBAR Cloud, disable the Enable toggle button and click Yes in the subsequent dialog box.

Enable/Disable CBAR on Network Devices

Before you begin

• The devices must be assigned to a site.

• It is recommended to configure CBAR Cloud before enabling CBAR on the network devices. For more
information, see Configure CBAR Cloud, on page 5.
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Step 1 From the top-left corner, click the menu icon and choose Provision > Application Visibility Setup > Network Devices
Enablement tab.

The Site Devices table is displayed. Click the vertical ellipsis and click All to view all the columns.

Step 2 Do the following to enable CBAR on selected devices or all devices:

a. To enable CBAR on all devices, from the CBAR drop-down list choose Enable CBAR on all ready devices and
click Yes on the subsequent warning dialog box.

b. To enable CBAR on selected devices, check the check box next to the device name to select the device, from the
CBAR drop-down list choose Enable CBAR on selected devices and click Yes on the subsequent warning dialog
box.

Step 3 Do the following to disable CBAR on selected devices or all devices:

a. To disable CBAR on all devices, from the CBAR drop-down list choose Disable CBAR on all devices and click
Yes on the subsequent warning dialog box.

b. To disable CBAR on selected devices, check the check box next to the device name to select the device, from the
CBAR drop-down list choose Disable CBAR on selected devices and click Yes on the subsequent warning dialog
box.

Enable/Disable Application Telemetry

Before you begin

We recommend that you configure CBARCloud before enabling Application Telemetry. For more information,
see Configure CBAR Cloud, on page 5.

Step 1 From the top-left corner, click the menu icon and choose Provision > Application Visibility Setup.
Step 2 Click the Network Devices Enablement tab.
Step 3 In the Site Devices table, do the following to enable Application Telemetry:

a. Choose the devices.

b. From the Application Telemetry drop-down list, choose Enable Application Telemetry.

c. Click Enable in the Enable Application Telemetry slide-in pane.

If Application Telemetry deployment fails for a device, click the link under Application Telemetry
Deployment Status column to view the failure reason.

Note

A Success message at the bottom of the window indicates that Application Telemetry is enabled.

Step 4 To disable Application Telemetry, do the following:

a. Choose the devices in the Site Devices table.
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b. From the Application Telemetry drop-down list, choose Disable Application Telemetry and click Yes in the
subsequent warning dialog box.

Update the Protocol Pack on a CBAR-Enabled Device
You can upgrade the protocol pack on any device that supports CBAR to the latest or any specific protocol
pack. You can update protocol pack manually or enable automatic protocol pack update.

• Automatic Protocol Pack update menu is disabled when CBAR cloud connector is disabled.

• Manual Protocol Pack update menu is disabled when Automatic Protocol Pack is enabled.

Note

Before you begin

• Configure Cisco credentials on System Settings. Formore information about configuring Cisco credentials,
see the Cisco DNA Center Administrator Guide.

• Devices must support CBAR.

• CBAR must be enabled on the device.

• Protocol packs for the device must be available on cisco.com.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > Application Visibility Setup.
Step 2 Click the Network Devices Enablement tab.
Step 3 In Site Devices table, check the status shown in the Protocol Pack Version column.

You can click the Outdated status to view the list of applicable protocols packs in the Update Protocol Pack window.

Step 4 Click Update corresponding to the required protocol pack version in the Update Protocol Pack window.

The Protocol Pack Version column shows In progress status. Click the info icon to view the current updating version.
If the Protocol Pack Version column shows Update failed status, click the error icon to view the failure reason.

Step 5 If you want to manually update all the devices or selected devices to the latest protocol pack, do the following:

To update the protocol pack on all applicable CBAR-enabled devices:

• From theUpdate Protocol Pack drop-down list, chooseUpdate All Devices and clickYes in the subsequent warning
dialog box.

To update the protocol pack on the selected devices:

• Choose the devices in the Site Devices table.

• From the Update Protocol Pack drop-down list, choose Update Selected Devices and click Yes in the subsequent
warning dialog box.
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To update the protocol pack on the selected devices from the file:

• Choose the devices in the Site Devices table.

• From the Update Protocol Pack drop-down list, choose Update Selected Devices From File.

• In the Update Protocol Pack From File slide-in pane you can either drag and drop the file into the drag-and-drop
area or click Choose a file, browse to the location of the file, and click Open.

• Click Import.

Step 6 If you want to automatically update protocol pack for all the devices, do the following:

• From the Update Protocol Pack drop-down list, enable Auto Update toggle button and click Yes in the subsequent
warning dialog box.

By default, all ready devices are included for Auto Update.Note

To exclude selected devices from automatic protocol pack update, do the following:

• Choose the devices in the Site Devices table.

• From the Update Protocol Pack drop-down list, choose Exclude Selected Devices and click Yes in the subsequent
warning dialog box.

To include selected devices for automatic protocol pack update, do the following:

• Choose the devices in the Site Devices table.

• From the Update Protocol Pack drop-down list, choose Include Selected Devices and click Yes in the subsequent
warning dialog box.

Reconfigure CBAR on Network Devices
You can include or exclude interfaces from Site Devices table in theApplication Visibility Setup >Network
Devices Enablement window.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > Application Visibility Setup.
Step 2 Click the Network Devices Enablement tab.
Step 3 In the Site Devices table, click Re-Configure in the CBAR Deployment status column for the device that you want to

configure and do the following:
a) In the Enable CBAR slide-in pane, search for the device name or locate the device and click View Interfaces.
b) Locate the interface that you want to exclude.
c) In the Status column, click the toggle button to disable the interface and click Save.

Step 4 To include interfaces, choose Excluded Interfaces and enable the toggle button next to the desired interfaces, and click
Save.

Step 5 Click Enable.
Step 6 Based on the Visibility of Configurations settings, choose an available option. For more information, see Visibility and

Control of Configurations Workflow.
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• To immediately enable CBAR, click the Now radio button.

• To schedule the task for a later date and time, click the Later radio button and define the date and time of the
deployment.

• Cisco DNA Center allows you to review the configurations before deploying them on Cisco network devices. The
configuration can be reviewed from the Preview Configuration window.

To preview the CLI configuration, click the Generate configuration preview radio button.

Step 7 If you choose to Generate configuration preview in the preceding step, enter the task name in the Task Name field
and click Apply.

Step 8 (Optional) Click Deploy or Discard. If you're not ready to deploy the configurations, click Exit and Preview Later.
Step 9 If you choose to deploy the configurations in the preceding step, do the following:

a. Click Now to deploy the configuration immediately or click Later to schedule the deployment for a later time.

b. Edit the default Task Name, if required.

c. Click Submit.

When the configurations are successfully submitted, a success message is displayed.

You can view the status of the task on the Work Items window. To navigate to the Work Items window, click the menu
icon and choose Activities > Work Items.

Applications and Application Sets
Applications are the software programs or network signaling protocols that are used in your network. Cisco
DNA Center supports all of the applications in the Cisco Next Generation Network-Based Application
Recognition (NBAR2) library of approximately 1400 distinct applications.

Applications are grouped into logical groups called application sets. An application set can be assigned a
business relevance within a policy.

Applications are mapped into industry standard-based traffic classes, as defined in RFC 4594, that have similar
traffic treatment requirements. The traffic classes define the treatments (such as Differentiated Services Code
Point [DSCP] marking, queuing, and dropping) that will be applied to the application traffic, based on the
business relevance group that is assigned.

If you have additional applications that are not included in Cisco DNA Center, you can add them as custom
applications and assign them to application sets.

Unidirectional and Bidirectional Application Traffic
Some applications are completely symmetrical and require identical bandwidth provisioning on both ends of
the connection. Traffic for such applications is described as bidirectional. For example, if 100 kbps of
Low-Latency Queueing (LLQ) is assigned to voice traffic in one direction, 100 kbps of LLQ must also be
provisioned for voice traffic in the opposite direction. This scenario assumes that the same Voice over IP
(VoIP) coder-decoders (codecs) are being used in both directions and do not account for multicast
Music-on-Hold (MoH) provisioning. However, certain applications, such as streaming video and multicast
MoH, are most often unidirectional. Therefore, it might be unnecessary, and even inefficient, to provision
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any bandwidth guarantees for such traffic on a branch router for the branch-to-campus direction of traffic
flow.

Cisco DNA Center lets you specify whether an application is unidirectional or bidirectional for a particular
policy.

On switches and wireless controllers, NBAR2 and custom applications are unidirectional by default. However,
on routers, NBAR2 applications are bidirectional by default.

Custom Applications
Custom applications are applications that you add to Cisco DNA Center. You can view the number of custom
applications available in the Overviewwindow. For wired devices, you can define applications based on server
name, IP address and port, or URL. You can define custom applications for Cisco Catalyst 9800 SeriesWireless
Controllers and not for Cisco AireOS controllers.

When you define an application according to its IP address and port, you can also define a DSCP value and
port classification.

To simplify the configuration process, you can define an application based on another application that has
similar traffic and service-level requirements. Cisco DNA Center copies the other application's traffic class
settings to the application that you are defining.

Cisco DNA Center does not configure ACLs for port numbers 80, 443, 53, 5353, and 8080, even if they are
defined as part of a custom application. If the custom application has a transport IP defined, Cisco DNACenter
configures the application on the devices.

For a custom application to be programmed on devices when a policy is deployed, you must assign the custom
application to one of the application sets defined in the policy.

Note

Discovered Applications
Discovered applications are applications that are discovered by importing from the recommended customization,
such as an Infoblox DNS server, or by importing from the recommended unclassified applications flow.

The unclassified traffic can come from any flow that the CBAR-enabled device identifies, but that is not
recognized by the NBAR engine. In such cases, the applications that have a meaningful bit rate are reported
as unclassified and can be imported and used as applications in Cisco DNA Center.

The Application Visibility service lets Cisco DNACenter connect with external authoritative sources through
the CBAR cloud to help classify the unclassified traffic or help generate improved signatures.

The available external authoritative sources are Google Meet, Service Now, Sugarcrm, Telegram, SAP,
Microsoft Office 365 Cloud Connector, Box, RingCentral, Github, Crashplan, Intuit, Workday, Zscaler,
Atlassian, Amazon Chime, Zoom, Dropbox, Webex, Whatsapp, Cisco Meraki, and Salesforce. This list is
dynamic. As new sources are added to the cloud, the list is updated. To view the list, choose Application
Visibility Setup > CBAR Extensions > CBAR Cloud.

You must configure a CBAR cloud connector before configuring the applications.Note
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The discovered applications are imported to the application registry.

Favorite Applications
Cisco DNACenter lets you flag applications that you want to configure on devices before all other applications.
Flagging an application as a favorite helps to ensure that the QoS policies for your favorite applications get
configured on devices. For more information, see Processing Order for Devices with Limited Resources.

When custom applications are created they are marked as favorite applications.

Although there is no limit to the number of applications that you can mark as favorites, designating only a
small number of favorite applications (for example, fewer than 25) helps to ensure that these applications are
treated correctly from a business-relevance perspective in deployments with network devices that have limited
ternary content addressable memory (TCAM).

Favorite applications can belong to any business-relevance group or traffic class and are configured
system-wide, not on a per-policy basis. For example, if you flag the Cisco Jabber video application as a
favorite, the application is flagged as a favorite in all policies.

Keep in mind that not only can business-relevant applications be flagged as favorites, even business-irrelevant
applications can be flagged as such. For example, if administrators notice a lot of unwanted Netflix traffic on
the network, they might chose to flag Netflix as a favorite application (despite it being assigned as
business-irrelevant). In this case, Netflix is programmed into the device policies before other business-irrelevant
applications, ensuring that the business intent of controlling this application is realized.

Configure Applications and Application Sets
The following subsections describe the various tasks that you can perform in the context of applications and
application sets.

You can edit or delete only custom and discovered applications. You can edit or delete a maximum of 100
custom and discovered applications at one instance. If you choose applications for editing or deleting, a
notification message indicates the number of applications that can be edited or deleted, excluding the number
of chosen applications.

Note

Change an Application's Settings
You can change the application set or traffic class of an existing CBAR, custom, or discovered application.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > Application Visibility Setup.
Step 2 Click Applications tab.
Step 3 Use the Search, Show, or View By fields to locate the application that you want to change.

You can search applications based on their name, port number, and traffic class.

Step 4 Click the application name.
Step 5 In the dialog box, change one or both settings:

• Traffic Class: Choose a traffic class from the drop-down list. Valid traffic classes are BROADCAST_VIDEO,
BULK_DATA, MULTIMEDIA_CONFERENCING, MULTIMEDIA_STREAMING, NETWORK_CONTROL,
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OPS_ADMIN_MGMT, REAL_TIME_INTERACTIVE, SIGNALING, TRANSACTIONAL_DATA,
VOIP_TELEPHONY.

• Application Set: Choose an application set from the drop-down list. Valid application sets are authentication-services,
backup-and-storage, collaboration-apps, consumer-browsing, consumer-file-sharing, consumer-gaming,
consumer-media, consumer-misc, consumer-social-networking, database-apps, desktop-virtualization, email,
enterprise-ipc, file-sharing, generic-browsing, generic-media, generic-misc, tunneling, local-services, naming-services,
network-control, network-management, remote-access, saas-apps, signaling, software-development-tools,
software-updates, streaming-media.

Step 6 Click Save.

Create a Server Name-Based Custom Application
If you have applications that are not in Cisco DNA Center, you can add them as custom applications.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > Application Visibility Setup.
Step 2 Click the Application tab.
Step 3 Click Add Application at the top-right corner of the window.
Step 4 In the slide-in pane, provide the necessary information in the following fields:

• Application name: Name of the custom application. The name can contain up to 24 alphanumeric characters,
including underscores and hyphens. The underscore and hyphen are the only special characters allowed in the
application name.

• Type: Method by which users access the application. Choose Server Name for applications that are accessible
through a server.

• Server name: Name of the server that hosts the application.

• Similar to: Application with similar traffic-handling requirements. Click the radio button to select this option, and
then select an application from the drop-down list. Cisco DNA Center copies the other application's traffic class to
the application that you are defining.

• Traffic class: Traffic class to which the application belongs. Valid values are BULK_DATA,
TRANSACTIONAL_DATA, OPS_ADMIN_MGMT, NETWORK_CONTROL, VOIP_TELEPHONY,
MULTIMEDIA_CONFERENCING, MULTIMEDIA_STREAMING, BROADCAST_VIDEO,
REAL_TIME_INTERACTIVE, and SIGNALING.

• Application set: Application set is where you want the application to reside. Valid application sets are
authentication-services, backup-and-storage, collaboration-apps, consumer-browsing, consumer-file-sharing,
consumer-gaming, consumer-media, consumer-misc, consumer-social-networking, custom applications, database-apps,
desktop-virtualization, email, enterprise-ipc, file-sharing, generic-browsing, generic-media, generic-misc, tunneling,
local-services, naming-services, network-control, network-management, remote-access, saas-apps, signaling,
software-development-tools, software-updates, streaming-media.

Step 5 Click Save.
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Create an IP Address and Port-Based Custom Application
If you have applications that are not in Cisco DNA Center, you can add them as custom applications.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > Application Visibility Setup.
Step 2 Click the Application tab.
Step 3 Click Add Application.
Step 4 In the Application name field, enter a name for the custom application. The name can contain up to 24 alphanumeric

characters, including underscores and hyphens. The underscore and hyphen are the only special characters allowed in
the application name.

Step 5 In the Type area, click the Server IP/Port radio button to indicate that the application is accessible through an IP
address and port.

Step 6 Check the DSCP check box and define a DSCP value. If you do not define a value, the default value is Best Effort.
Best-effort service is essentially the default behavior of the network device without any QoS.

Step 7 Check the IP/Port Classifiers check box to define the IP address and subnet, protocol, and port or port range for an
application. Valid protocols are IP, TCP, UDP, and TCP/UDP. If you select the IP protocol, you do not define a port
number or range. Click to add more classifiers.

Step 8 Define your application traffic-handling requirements using one of the following methods:

• Similar To: If your application has similar traffic-handling requirements as an existing application, click the
Similar To radio-button and choose the application from the drop-down list. Cisco DNA Center copies the traffic
class of the other application to the application that you are defining.

• Traffic Class: If you know the traffic class that you want to define for your application, click the Traffic Class
radio button and choose the traffic class from the drop-down list. Valid values are BULK_DATA,
TRANSACTIONAL_DATA, OPS_ADMIN_MGMT, NETWORK_CONTROL, VOIP_TELEPHONY,
MULTIMEDIA_CONFERENCING, MULTIMEDIA_STREAMING, BROADCAST_VIDEO,
REAL_TIME_INTERACTIVE, and SIGNALING.

Step 9 From the Application Set drop-down list, choose the application set to which the application will belong. Valid
application sets are authentication-services, backup-and-storage, collaboration-apps, consumer-browsing,
consumer-file-sharing, consumer-gaming, consumer-media, consumer-misc, consumer-social-networking, custom
applications, database-apps, desktop-virtualization, email, enterprise-ipc, file-sharing, generic-browsing, generic-media,
generic-misc, tunneling, local-services, naming-services, network-control, network-management, remote-access,
saas-apps, signaling, software-development-tools, software-updates, streaming-media.

Step 10 Click Save.

Create a URL-Based Custom Application
If you have applications that are not in Cisco DNA Center, you can add them as custom applications.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > Application Visibility Setup.
Step 2 Click the Application tab.
Step 3 Click Add Application.

The Add Application dialog box appears.
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Step 4 In the Application name field, enter the name of the custom application. The name can contain up to 24 alphanumeric
characters, including underscores and hyphens. (Underscores and hyphens are the only special characters allowed in the
application name.)

Step 5 For Type, click the URL radio button.
Step 6 In the URL field, enter the URL used to reach the application.
Step 7 Configure the traffic class:

• To use the same traffic class as another application with similar traffic-handling requirements, click the Similar To
radio button and choose an application from the drop-down list.

• To specify the traffic class, click the Traffic Class radio button and choose a traffic class from the drop-down list.
Valid values are BULK_DATA, TRANSACTIONAL_DATA, OPS_ADMIN_MGMT, NETWORK_CONTROL,
VOIP_TELEPHONY,MULTIMEDIA_CONFERENCING,MULTIMEDIA_STREAMING,BROADCAST_VIDEO,
REAL_TIME_INTERACTIVE, and SIGNALING.

Step 8 From the Application Set drop-down list, choose an application set in which you want the application to reside.
Step 9 Click Save.

Edit or Delete a Custom Application
If required, you can change or delete a custom application.

You cannot delete a custom application that is directly referenced by an application policy. Application policies
typically reference application sets and not individual applications. However, if a policy has special definitions
for an application (such as a consumer or producer assignment or bidirectional bandwidth provisioning), the
policy has a direct reference to the application. As such, you must remove the special definitions or remove
the reference to the application entirely before you can delete the application.

Note

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > Application Visibility Setup.
Step 2 Click the Application tab.
Step 3 Use the Search, Show, or View By fields to locate the application that you want to change.

You can search applications based on their name, port number, and traffic class.

Step 4 To edit the application:
a) Click the application name and make the required changes. For information about the fields, see Create a Server

Name-Based Custom Application, on page 13, Create an IP Address and Port-Based Custom Application, on page
14, or Create a URL-Based Custom Application, on page 14.

b) Click Save.

Alternatively, choose the application and from the Actions drop-down list, click Edit to edit an application.

When policy is redeployed, the edited custom applications are not reconfigured on Cisco Catalyst 9800 Series
Wireless Controller.

Note

Step 5 To delete the application, click in the application box, and then click OK to confirm.

Alternatively, you can follow the steps below to delete the application:
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a) Check the check box next to an application name. You can also choose multiple applications.
b) From the Actions drop-down list, click Delete option.
c) Click OK to confirm.

Mark an Application as Favorite
You can mark an application as a favorite to designate that the application's QoS configuration must be
deployed to devices before other applications' QoS configuration. An application marked as favorite has a
yellow star next to it.

When you add or edit a policy, applications marked as a favorites are listed at the top of the application set.

Applications are configured system-wide, not on a per-policy basis. For more information, see Favorite
Applications, on page 12.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > Application Visibility Setup.
Step 2 Click the Application tab.
Step 3 Locate the application that you want to mark as a favorite.
Step 4 Click the star icon.

Create a Custom Application Set
If none of the application sets fits your needs, you can create a custom application set.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > Application Visibility Setup.
Step 2 Click the Application Sets tab.
Step 3 Click Add Application Set.
Step 4 In the slide-in pane, enter a name for the new application set.

Cisco DNA Center creates the new application set; however, it contains no applications.

Step 5 Choose a Default Business Relevance from the drop-down list. Default Business Relevance is the business relevance
level in the absence of a concreate application QoS, this level will appear in Assurance for sites that are not assigned
to a policy.

Step 6 Click Save.
Step 7 Use the Search, Show, or View By fields to locate the application set.

You can search applications based on their name, port number, and traffic class.

Step 8 Locate the applications that you want to move into the new application set.
Step 9 Check the check box next to the applications that you want to move.
Step 10 Drag and drop the applications into the new application set.
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Edit or Delete a Custom Application Set
If required, you can change or delete a custom application set.

You cannot delete a custom application set that is referenced by an application policy. You must remove the
application set from the policy before you delete the application set.

Note

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > Application Visibility Setup.
Step 2 Click the Application Sets tab.
Step 3 Use the Search, Show, or View By fields to locate the application set that you want to change.

You can search applications based on their name, port number, and traffic class.

Step 4 Do one of the following:

• To edit the application set, drag and drop applications into or out of the application set. Click OK to confirm each
change.

• To delete the application set, click in the application set box, and then click OK to confirm.

Discover Unclassified Applications
The Application Visibility service in Cisco DNA Center obtains information on classified and unclassified
domains and sockets from devices and displays that information in the Observed Traffic chart. The number
of unclassified server names and IP/ports that are discovered by the Application Visibility service is shown
under Recommendations.

You can add the unclassified server names and IP/ports to the Application Registry.

You can add a maximum of 1100 discovered applications in the Application Registry.Note

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > Application Visibility Setup.
Step 2 Click the CBAR Extensions > Discovered Applications tab.
Step 3 The table lists the discovered servers or IP/ports that are not classified. Choose the server and check the Hide Ignored

Applications check box if you want to hide the selected server or IP/ports in the table.
Step 4 Choose the server or IP/ports that you want to import as an application in the Application Registry.
Step 5 Choose the required Application, Application Set, and Traffic Class from the drop-down list.
Step 6 Click Import.
Step 7 Click the Applications tab and from Show drop-down list choose Discovered to view the imported application.
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Application Visibility Service Support for the Cisco DNA Traffic Telemetry
Appliance

The Cisco DNA Traffic Telemetry Appliance generates endpoint telemetry from mirrored IP network traffic
and shares the telemetry data with Cisco DNA Center for endpoint visibility and segmentation.

The prerequisites for enabling CBAR on the Cisco DNA Traffic Telemetry Appliance include:

• The device must be assigned to a site.

• The device role must be set to Distribution mode.

You can configure custom applications with attribute sets and maps on the Cisco DNA Traffic Telemetry
Appliance without configuring a QoS policy. For more information, see Create an Application Policy and
Deploy an Application Policy.

Discover Infoblox Applications
You can integrate Cisco DNA Center with an organizational Infoblox DNS server to resolve unclassified
traffic based on server names.

Before you begin

• The Infoblox WAPI version must be 1.5 or later. To check the Infoblox WAPI version, log in to the
Infoblox server and choose Help > Documentation > WAPI Documentation.

• Create a role with at least Read Only permissions and assign the role to the Infoblox user. For more
information, see Manage Users in the Cisco DNA Center Administrator Guide.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > Application Visibility Setup.
Step 2 Click the CBAR Extensions > Infoblox tab.
Step 3 Under Infoblox, click Here link to configure IPAM/DNS server credentials in Cisco DNA Center.
Step 4 Complete the IPAM settings. For more information, see Configure an IP Address Manager in the Cisco DNA Center

Administrator Guide.

Step 5 Go back to Infoblox and click the icon to complete the following settings:

• Check theAll DNS Zones check box, or choose the required DNS zones from theDNS Zones to Inspect drop-down
list. The drop-down list shows the DNS zones defined in the Infoblox server.

• From the Inspect drop-down list, choose the required inspection record.

• Check the Read Application name from check box and click the Extensible Attribute or AVC RRTYPE format
radio button. If you click the Extensible Attribute radio button, enter the extensible attribute name that contains
descriptive application names.

• From Default Traffic Class, choose the default traffic class for classifying the Infoblox applications.

• From Default Application Set, choose the default application set for classifying the Infoblox applications.

Step 6 Click Save.
Step 7 Choose the application that you want to import and complete the following:
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• If the application does not have a name defined in the Infoblox server, edit the application name.

• Choose the required application set and traffic class from the drop-down list if you want to change the default
application set and traffic class defined in the Infoblox.

Step 8 Click Import.
Step 9 Click the Applications tab and choose Discovered in the Show drop-down list to view or edit the imported Infoblox

applications.

If you change the server name of an application after importing the application, the Application Status column in the
Infoblox window shows the status of the application as Updated. The application name that you see in the Application
Status column is the new server name of the application. Click the info icon to view the old server names of the application.

Edit or Delete a Discovered Application
If required, you can edit or delete a discovered application.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > Application Visibility Setup.
Step 2 Click the Applications tab.
Step 3 Use the Search, Show, or View By fields to locate the discovered application that you want to change.

You can search for applications based on their name, port number, and traffic class.

Step 4 To edit the application:
a) Click the application name and make the required changes.

For discovered applications, you can edit only the Attribute Set and Traffic Class.

b) Click Save.

Step 5 To delete the application, select the application and choose Delete option from the Action drop-down list at the top of
the window, and then click OK in the subsequent warning dialog box that appears on the window.

Application Hosting
The following sections provide information about application hosting.

About Application Hosting
Application hosting lets you manage the lifecycle of third-party applications on devices managed by Cisco
DNA Center. You can host third-party docker applications on Cisco Catalyst 9300 Series switches running
Cisco IOS-XE software version 16.12.1s or later, Cisco Catalyst 9100 Series Access Points running Cisco
IOS-XE software version 17.3.1 or later, and Cisco Catalyst 9400 Series switches running Cisco IOS-XE
software version 17.1 or later.
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The disk space allocated in Cisco DNA Center for the hosted applications is limited to 5 GB.Note

Install or Update the Application Hosting Service Package

Before you begin

Only a user with SUPER-ADMIN-ROLE permissions can perform this procedure.

Step 1 From the top-left corner, click the menu icon and choose System > Software Updates. Alternatively, click the cloud
icon and click the Go to Software Updates link.

Step 2 In the Software Updates window, review the following tabs:

• Updates: Shows the system and application updates. System Update shows the system version that is installed and
the system updates that are available and have been downloaded from the Cisco cloud. Application Updates shows
the available applications that can be downloaded and installed from the Cisco cloud, the size of the application,
and the appropriate action (Download, Install, orUpdate). Hover your cursor over the package to view the available
version and a basic description.

• Installed Apps: Shows the application packages that are currently installed.

Step 3 To download the Application Hosting package, click Install next to the Application Hosting name under Updates >
Application Updates.

Step 4 To update the Application Hosting package, click Update next to the Application Hosting name under Updates >
Application Updates.

Step 5 Ensure that the application has been updated by reviewing the version on the Installed Apps tab.

After installing the Application Hosting service package, you must log out of Cisco DNA Center, clear your
browser cache, and log in to Cisco DNA Center again.

Note

Prerequisites for Application Hosting
To enable application hosting on a Cisco Catalyst 9000 device, the following prerequisites must be fulfilled:

• Configure NETCONF port on the device before discovery.

• Configure a secure HTTP server on the switch where the applications will be hosted.

• Configure local or AAA authentication server for HTTPS user authentication on the switch. You must
configure the username and password with privilege level 15.

• Ensure Cisco Catalyst 9300 Series switches are running Cisco IOS XE 16.12.x or later version and Cisco
Catalyst 9400 Series switches are running Cisco IOS XE 17.1.x or later version.

• Ensure that the device has an external USB SSD pluggable storage (only for the switches of 9300 family).
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• Verify that the configuration on the switch is correct. Open the WebUI on the switch and log in as the
HTTPS user.

The following example shows a working configuration on a switch:
prompt# sh run | sec http
ip http server
ip http authentication local
ip http secure-server
ip http max-connections 16
ip http client source-interface Loopback0

Additional configuration for switches with a Cisco IOS XE release that is earlier than 17.3.3:
ip http secure-active-session-modules dnac
ip http session-module-list dnac NG_WEBUI
ip http active-session-modules none

Additional configuration for switches with Cisco IOS XE 17.3.3 or later:
ip http secure-active-session-modules webui
ip http session-module-list webui NG_WEBUI
ip http session-module-list pki OPENRESTY_PKI
ip http active-session-modules pki

• On Cisco DNA Center, configure the HTTPS credentials while manually adding the device. The HTTPS
username, password, and port number are mandatory for application hosting. The default port number
is 443. You can also edit the device credentials; see Update Network Device Credentials. If you edit a
device that is already managed, resynchronize that device in the inventory before it is used for application
hosting-related actions.

Application hosting HA is not supported on three-node Cisco DNA Center clusters.Note

View Device Readiness to Host an Application
You must check the readiness of the Cisco Catalyst 9300 Series switch to host the application before you can
install an application on the switch.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > App Hosting for Switches.
Step 2 Click All Devices.
Step 3 View the list of devices that are capable of hosting applications. The App Hosting Status indicates the readiness of the

device to host an application. Click See Details to view the list of readiness checks performed on the device.

Add an Application
You can add a Cisco package or a docker application.
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Before you begin

• Cisco Package: You must package the application using IOS SDK tools so that the application is
compatible with IOS XE operating systems.

• Docker: You must save the docker image as a tar file. Enter the following command to store the docker
image as a tar file:
docker save -o <path for generated tar file> <image name:tag>
Example: docker save -o alpine-tcpdump.tar itsthenetwork/alpine-tcpdump:latest

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > App Hosting for Switches.
Step 2 Click New Application.
Step 3 Choose the application and category from the drop-down list.
Step 4 Click Select and choose the application to upload.
Step 5 Click Upload.

You can view the newly added application in the App Hosting page.

Automatic Download of ThousandEyes Enterprise Agent Application
The ThousandEyes Enterprise Agent application lets you monitor your network and oversee the network
traffic paths across internal, external, carrier, and internet networks in real time. The advantage of the
ThousandEyes Enterprise Agent application is that you do not have to import this application manually in
your Cisco DNACenter Application Hosting Service.When the switches and hubs in the network are enabled,
the ThousandEyes Enterprise Agent application is downloaded automatically within 10 minutes of starting
the Application Hosting Service. To manually download the application, click the following link to the
ThousandEyes Enterprise Agent .tar file:

thousandeyes-enterprise-agent.cat9k.tar

If there is no internet connection, you can set a proxy connection from the console using the following
command:
magctl service setenv app-hosting http_proxy <proxy-value>

Set the proxy value to connect to the ThousandEyes Enterprise Agent application.

Update an Application
You can update the application added in Cisco DNA Center.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > App Hosting for Switches.

You can view the available applications in the App Hosting window.

Step 2 Choose the application that you want to update.
Step 3 Click Update App.
Step 4 Choose a new version of the application to be uploaded.
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Step 5 Click Upload.

Start an Application
You can start an application in Cisco DNA Center.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > App Hosting for Switches.
Step 2 Choose the application and click Manage to view the devices that use the application.
Step 3 Choose the device that has the application that you want to start.
Step 4 From the Actions drop-down list, choose Start App.

Stop an Application
You can stop an application in Cisco DNA Center.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > App Hosting for Switches.
Step 2 Choose the application and click Manage to view the devices that use the application.
Step 3 Choose the device that has the application that you want to stop.
Step 4 From the Actions drop-down list, choose Stop App.

View Applications Hosted on a Device

Before you begin

Complete the prerequisites in Prerequisites for Application Hosting.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > App Hosting for Switches.
Step 2 To view all devices, click All Devices at the top-right corner, or to view only the devices that use a particular application,

choose the application and click Manage.

If you chose to view all devices, the All Devices window shows the following information about the devices that are
capable of hosting applications: Hostname, IP Address, Image Version, App Hosting Status, and Last Updated.

If you chose to view a list of devices for a particular application, the Devices window shows the following information
about the devices that are capable of hosting applications:Hostname,Device IP,App Version,App Status,Last Heard,
Platform Version, and Action Status.

Step 3 In the Devices window, click Summary to view a summary of failed, stopped, and running applications on a device.
Step 4 To take an action on an application, click theAction drop-down list and choose Start, Stop,Edit,Upgrade, orUninstall.
Step 5 Click the device link in which you want to view the installed hosting applications.
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The Applications window shows the Name, Version, App Status, Monitor App, Health, and Details of the installed
applications.

Monitor App contains a link to the Application Monitoring dashboard. This link is provided in the Cisco
DNA Center application package controller .yaml file. If the file does not contain the application dashboard
URL, the Monitor App column isn't applicable.

Note

Step 6 In the Details column, click View to get more information about an application status on the device.
Step 7 To download the log for a particular application, select the application and click Application Logs.
Step 8 To download tech support logs from the device, click Tech Support Logs.

Install an Application on a Cisco Catalyst 9300 Device
Cisco DNA Center allows you to install an application on a Cisco Catalyst 9300 Series switch.

Before you begin

• Complete the prerequisites. For more information, see Prerequisites for Application Hosting, on page
20.

• Add the application to Cisco DNA Center. For more information, see Add an Application, on page 21.

• Check the readiness of the switch to host the application. For more information, see ViewDevice Readiness
to Host an Application, on page 21.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > App Hosting for Switches.
Step 2 Choose the application and click Install.
Step 3 In the Get Started window, enter a unique name for your workflow in the Task Name field and click Next.
Step 4 In the Select Site window, choose the site where you want to enable the application, and click Next.
Step 5 In the Select Switches window, choose the devices on which you want to install the application and click Next.

You can choose the devices that are inReady and Partially Ready status. Click See Details to view the list of readiness
checks performed on the device.

For devices that are in Partially Ready status, click the Check Now link in the Readiness Check window to validate
the HTTPS credentials.

If you don't find your device in the Devices Table, click Import to add devices from a CSV file.

Step 6 In the Configuration App window, complete the following settings:

• Network Settings:

• From the Select Network drop-down list, choose a VLAN to configure the application.

• From theAddress Type drop-down list, choose Static orDynamic. If you choose Static, click the thumbnail
icon and enter the IP Address, Gateway, Prefix/Mask, and DNS for the application.

• App Resources: Check the Allocate all resources available on a device or the Customize resource allocation
check box. You can check theCustomize resource allocation check box andmodify themaximumCPU,Memory,
and Persistent Storage values to a lower value.

Provision Services
24

Provision Services
Install an Application on a Cisco Catalyst 9300 Device



• Custom Settings: Applicable only for Cisco package applications. Enter the configuration details for the attributes
that are specified by the application.

• App Data: Browse and upload the application-specific files. For information about how to identify the required
application-specific files, see the relevant application document.

• Docker Runtime Options: Enter the docker runtime options required by the application.

Step 7 In the Summary window, review the application configuration settings.
Step 8 (Optional) Click Configuration Preview to view the configuration template used to push the configuration settings

on the selected devices.
Step 9 Click Provision.
Step 10 In the confirmation window, click Yes to complete the application installation on the selected devices.

The installation of the application also modifies the Cisco IOS-XE configuration on the device. This change
in the running configuration must be copied to the startup configuration to ensure applications function as
expected after a router reload. After the application installation is complete, use the Template Hub to
copy the running configuration to the startup configuration.

Note

Uninstall an Application from a Cisco Catalyst 9300 Device
You can uninstall an application from a Cisco Catalyst 9300 Series switch.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > App Hosting for Switches.
Step 2 Choose the application and click Manage to view the devices that use the application.
Step 3 Choose the devices that have the application that you want to uninstall.
Step 4 From the Actions drop-down list, choose Uninstall App.

Edit an Application Configuration in a Cisco Catalyst 9300 Device
You can edit an application configuration if the application requires a configuration to be up and running in
a Cisco Catalyst 9300 Series switch.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > App Hosting for Switches.
Step 2 Choose the application and click Manage to view the devices that use the application.
Step 3 Choose the device that has the application that you want to edit.
Step 4 From the Actions drop-down list, choose Edit App Config.

Delete an Application
You can delete an application from Cisco DNA Center.
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Before you begin

You must uninstall the application from all devices that are using it. For more information, see Uninstall an
Application from a Cisco Catalyst 9300 Device, on page 25.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > App Hosting for Switches.

You can view the available hosted applications in the App Hosting window.

Step 2 Choose the application that you want to delete.
Step 3 Click Delete Application.
Step 4 In the confirmation dialog box, click OK.

The application is deleted only if it is not used by any of the devices managed by Cisco DNA Center.

Otherwise, an error message shows the number of devices that are using the application. ClickCancel in the confirmation
dialog box and uninstall the application. For more information, see Uninstall an Application from a Cisco Catalyst 9300
Device, on page 25.

Download App Logs
You can download application logs from Cisco DNA Center.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > IoT Services.
Step 2 Click All Devices.

You can view the list of devices that are capable of hosting applications.

Step 3 Click App logs to download the application logs from Cisco DNA Center.
Step 4 In the App Logs pop-up window, choose the application logs file that you want to download and click Download.

Download Device Tech Support Logs
You can download the device tech support logs from Cisco DNA Center for troubleshooting purposes.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > IoT Services.
Step 2 Click All Devices.

A list of devices that are capable of hosting applications is displayed.

Step 3 Click Tech Support logs to download the device tech support logs.
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Application Hosting on Cisco Catalyst 9100 Series Access Points
The following sections provide information about application hosting on Cisco Catalyst 9100 Series Access
Points.

About Application Hosting on Cisco Catalyst Access Points
The move to virtual environments has prompted the need to build applications that are reusable, portable, and
scalable. Application hosting gives administrators a platform for leveraging their own tools and utilities. An
application, hosted on a network device, can serve a variety of purposes. This ranges from automation,
configuration management monitoring, and integration with existing tool chains.

Application hosting lets you manage the lifecycle of third-party applications on devices managed by Cisco
DNA Center. This release lets you bring in the third-party SES-imagotag IoT Connector application on Cisco
Catalyst 9100 Series Access Points with Cisco IOS-XE software version 17.3 or later.

The SES-imagotag IoT Connector on Cisco Catalyst 9100 Series Access Points can handle all Electronic Shelf
Label (ESL) communication.

Application Hosting Workflow to Install and Manage USB on Cisco Catalyst
9100 Series Access Points

Before you begin

To enable application hosting on a device, the following prerequisites must be completed:

• Enable NETCONF and set the port to 830 to discover Cisco Catalyst 9100 Series Access Points.

• Make sure that the Cisco Catalyst 9100 Series Access Points have direct IP reachability to Cisco DNA
Center.

• Make sure that the Cisco Catalyst 9800 Series Wireless Controller is running Cisco IOS XE 17.3.x or
later software.

• Make sure that the Cisco DNA Center appliance is running the latest Cisco DNA Center ISO.

• Make sure that the USB dongle is inserted in the AP. This is required for the SES-imagotag Connector
application to run.

Step 1 Check the readiness of the Cisco Catalyst 9800 Series Wireless Controller and Cisco Catalyst 9100 Series Access Points
to host the application before you install it.

For more information, see View Device Readiness to Host an Application, on page 21.

Step 2 Install the Application Hosting service on Cisco DNA Center.

For more information, see Install or Update the Application Hosting Service Package, on page 20.

Step 3 Add the Cisco Catalyst 9800 Series Wireless Controller to Cisco DNA Center.

For more information, see Add a Network Device.
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Make sure that you enable NETCONF and set the port to 830.

You must wait for the Cisco Catalyst 9800 Series Wireless Controller to move to a Managed state.

Note

Step 4 Assign APs to a floor on the Network Hierarchy window.

For more information, see Work with APs on a Floor Map.

Step 5 Upload the USB application (the SES-imagotag Connector) to Cisco DNA Center.

For more information, see Add an Application, on page 21.

Step 6 Enable the IoT services.

For more information, see Enable IoT Services on Cisco Catalyst 9100 Series Access Points.

Step 7 Configure the container as described in the Application Hosting on Catalyst APs Deployment Guide.

View Installed Hosting Applications on Cisco Catalyst 9100 Series Access
Points

Before you begin

Make sure the prerequisites have been met. For more information, see Prerequisites for Application Hosting.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > IoT Services.
Step 2 To view all devices, click All Devices at the top-right corner, or to view only the devices that use a particular application,

choose the application and click Manage.

If you chose to view all devices, the All Devices page shows the following information about the devices that are capable
of hosting applications: Hostname, IP Address, Image Version, App Hosting Status, and Last Updated.

When the App Hosting Status of an AP is Ready, to configure the updates on the AP, check the check box
next to the required hostname and click Resync.

Note

If you chose to view a list of devices for a particular application, the Devices page shows the following information about
the devices that are capable of hosting applications: Hostname, Device IP, App Version, App Status, Last Heard,
Platform Version, and Action Status.

Step 3 In the Devices page, click Summary to view the summary of failed, stopped, and running applications on a device.
Step 4 Click the Action drop-down list to start, stop, edit, upgrade, and uninstall an application.
Step 5 Click the device link in which you want to view the installed hosting applications.

The Applications page shows the Name, Version, App Status, IP Address, Health, and Details of the installed
applications.

Step 6 In the Details column, click View to get more information about an application status on the device.

App details window shows the REOURCES and NETWORK information of an application.

Step 7 To download the application log, select an application for which you want to download the application log and click
Application Logs.
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Step 8 To download the tech support log, select an application for which you want to download the tech support log and click
Tech Support Logs.

Uninstall an Application from a Cisco Catalyst 9100 Device
You can uninstall an application from a Cisco Catalyst 9100 Series AP.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > IoT Services.
Step 2 Choose the application and click Manage to view the devices that use it.
Step 3 Choose the devices that have the application that you want to uninstall.
Step 4 From the Actions drop-down list, choose Uninstall App.

Delete an Application from a Cisco Catalyst 9100 Device
You can delete an application from a Cisco Catalyst 9100 Series AP.

Before you begin

You must uninstall the application from all devices that are using it. For more information, see Uninstall an
Application from a Cisco Catalyst 9100 Device.

Step 1 From the top-left corner, click the menu icon and choose Provision > Services > IoT Services.

You can view the available hosted applications in the IoT Services page.

Step 2 Choose the application that you want to delete.
Step 3 Click Delete Application.
Step 4 In the confirmation dialog box, click OK.

The application is deleted only if it is not used by any of the devices managed by Cisco DNA Center.

Otherwise, an error message shows the number of devices using the application. ClickCancel and uninstall the application.
For more information, see Uninstall an Application from a Cisco Catalyst 9100 Device.

Configure a Site-to-Site VPN
You can create a site-to-site VPN and edit or delete existing site-to-site VPNs.

• Create a Site-to-Site VPN, on page 30

• Edit a Site-to-Site VPN, on page 30

• Delete a Site-to-Site VPN, on page 31
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Create a Site-to-Site VPN
This procedure shows how to create a site-to-site VPN.

Before you begin

• Define the sites within the network hierarchy. See Network Hierarchy Overview.

• Configure IP address pools to be used for the VPN tunnels. The IP address pools must have a minimum
of six free IP addresses. See Configure IP Address Pools.

Step 1 From the top-left corner, click the menu icon and choose Provision > Site to Site VPN.

Alternatively, you can create a site-to-site VPN from the Workflows > Site to Site VPN window.

Step 2 To create a VPN, click Add.
The Choose Your Sites workflow is displayed.

Step 3 In the Choose Your Sites workflow, do the following:
a) Enter a VPN name in the first field.
b) Select the first site, a device in that site, and a WAN interface on that device from the Site 1 drop-down lists. The

WAN interface is set by default if the device is provisioned.
c) Select the second site, a device in that site, and a WAN interface on that device from the Site 2 drop-down lists. The

WAN interface is set by default if the device is provisioned.

Step 4 In the Select Networks window, do the following:
a) From the Tunnel IP Pool drop-down list, choose an IP address pool.
b) Check the boxes next to the subnets that you want to use for each site.
c) (Optional) If you want to add a custom network for a site, click the Add Custom Networks link at the bottom and

complete the required fields.

Step 5 In the Configure VPN window, do the following:
a) Enter a preshared key for encryption.
b) Set the encryption and integrity algorithms as desired. We recommend that you use the default settings. If you change

any settings, you can go back to the default choices by checking the Use Cisco recommended IKEV2 & Transform
Set Values check box.

Step 6 In the Summary window, review the VPN settings. To make any changes, click Edit.
Step 7 To proceed, click Create VPN.

In the status screen that follows, a check mark is shown next to each step as it is completed. Click Services to return to
the Site to Site VPN window, which shows the newly created VPN.

Edit a Site-to-Site VPN

Step 1 From the top-left corner, click the menu icon and choose Provision > Site to Site VPN.
Step 2 Check the check box next to the VPN that you want to edit.
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Step 3 Click Edit in the menu bar above the list.
Step 4 In the Summary window, review the VPN settings. To make any changes, click Edit.
Step 5 Click Edit VPN to submit the changes.

In the status screen that follows, a check mark is shown next to each step as it is completed. Click Services to return to
the Site to Site VPN screen.

Delete a Site-to-Site VPN

Step 1 From the top-left corner, click the menu icon and choose Provision > Site to Site VPN.
Step 2 Check the check box next to the VPN that you want to delete.
Step 3 Click Delete in the menu bar above the list.

A confirmation dialog box is displayed.

Step 4 Click Yes to confirm that you want to delete the VPN.

Create a User-Defined Network Service
Cisco DNA Center allows you to configure Cisco User Defined Network services from Provision > Service
Catalog > Cisco User Defined Network page. Alternatively, you can create Cisco User Defined Network
service from Workflows > Configure Cisco UDN page. For more information, see Configure Cisco User
Defined Network.

View the User-Defined Network Service Provisioning Status
This procedure shows you how to view the Cisco User-Defined Network service provisioning status from the
Provision > All Services window. You can also click the View Provisioning Status button in the Configure
Cisco User Defined Network screen after configuring a Cisco User-Defined Network successfully.

Before you begin

Configure and provision the Cisco User-Defined Network service from the Workflows > Configure Cisco
User Defined Network window.

Step 1 From the top-left corner, click the menu icon and choose Provision > All Services > Cisco User Defined Network.

The Site Provisioning Status window displays the site name, device name, number of SSIDs used, and status of site
provisioning.

Step 2 Click Refresh to see the latest provisioning status.
Step 3 Click the site name to view additional details for the provisioned device, such as SSID name, User-Defined Network

(UDN) status, and Unicast Traffic Containment.
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Step 4 Click Activities to track the scheduled task status in the Scheduled Tasks window.

Configure Cisco Umbrella
The following sections provide information about integrating Cisco Umbrella with Cisco DNA Center.

About Cisco Umbrella
The DNS-layer security in Cisco Umbrella provides the fastest and easiest way to improve your network
security. It helps improve security visibility, detect compromised systems, and protect your users on and off
the network by stopping threats over any port or protocol before they reach your network or endpoints.

Cisco DNA Center supports Cisco Umbrella configuration on the following devices:

• Cisco Catalyst 9800 Series Wireless Controllers with Cisco IOS-XE software version 16.12 or later

• Cisco Catalyst 9100 Series APs

• Cisco Catalyst 9200 Access Switch with Cisco IOS-XE software version 17.3.1 or later

• Cisco Catalyst 9300 Access Switch with Cisco IOS-XE software version 17.3.1 or later

Role-Based Access Control Settings for Cisco Umbrella
To configure Cisco Umbrella with Cisco DNA Center and to provision Cisco Umbrella on network devices,
you must create a user role with the necessary RBAC permission for Cisco Umbrella. For more information,
see "Manage Users" in the Cisco DNA Center Administrator Guide.

Table 1: RBAC Permission Matrix for Cisco Umbrella

PermissionAccessFunction

WriteNetwork Design > Advanced Network
Settings

Configure Cisco Umbrella with Cisco
DNA Center

WriteNetwork Design > Advanced Network
Settings

Add Umbrella dashlet in System 360

WriteNetwork Provision > ProvisionProvision Cisco Umbrella on network
devices

ReadNetwork Design > Network Hierarchy

ReadNetwork Provision > Inventory
Management

ReadSystem

WriteNetwork Provision > Scheduler

WriteNetwork Services > Umbrella
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Configure Cisco Umbrella with Cisco DNA Center

Before you begin

• Create a Cisco Umbrella account.

• Log in to login.umbrella.com and create the necessary keys, such as the API key, legacy token,
management key, and secret.

• Note down the organization ID from the Cisco Umbrella login URL.

• Create the local bypass domains in Cisco Umbrella.

• If Cisco DNA Center has a proxy server configured as an intermediary between itself and the network
devices it manages or the Cisco cloud from which it downloads software updates, you must configure
access to the proxy server. For more information, see the Configure the Proxy section in the Cisco DNA
Center Administrator Guide.

• Install the Cisco Umbrella package in Cisco DNA Center. See the Download and Install Packages and
Updates section in the Cisco DNA Center Administrator Guide.

• Create a user role with necessary RBAC permission for Cisco Umbrella. See Role-Based Access Control
Settings for Cisco Umbrella, on page 32.

You cannot install Cisco Umbrella package on a Cisco DNA Center cluster configured with IPv6.Note

Step 1 From the top-left corner, click the menu icon and choose System > Settings > External Services > Umbrella.
Step 2 Enter the following details that you retrieved manually from Cisco Umbrella:

• Organization ID

• Network Device Registration API Key

• Network Device Registration Secret

• Management API Key

• Management Secret

• Legacy Device Registration Token

Step 3 Click Save.

Add the Umbrella Dashlet
You can add the Umbrella dashlet in the System 360 page. The Umbrella dashlet shows the configuration
status of Cisco Umbrella with Cisco DNA Center.
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Before you begin

You must install the Cisco Umbrella package.

Step 1 From the top-left corner, click the menu icon and choose System > System 360.
Step 2 From the Actions menu, choose Edit Dashboard and click Add Dashlet.
Step 3 Choose Umbrella Dashlet and click Add.

The Umbrella dashlet appears under Externally Connected Systems in the System 360 page. The Umbrella dashlet
shows the status as Available and displays the organization ID, if Cisco Umbrella is configured with Cisco DNA Center.

If Cisco Umbrella is not configured with Cisco DNA Center, you can click the Configure link and complete the fields
in System > Settings > External Services > Umbrella. See Configure Cisco Umbrella with Cisco DNA Center, on page
33.

If the keys are changed in Cisco Umbrella, you can click the Update link and update the keys in System > Settings >
External Services > Umbrella. See Configure Cisco Umbrella with Cisco DNA Center, on page 33.

View the Umbrella Service Statistics Dashboard
From the top-left corner, click the menu icon and choose Provision > Services > Umbrella to view the
Umbrella Service Stats dashboard.

The dashboard displays the following dashlets:

• Total Umbrella DNS Queries: Shows the number of blocked DNS queries and allowed DNS queries
for the selected site.

• Blocked Umbrella DNS Queries: Shows the number of DNS queries blocked by security policy and
content policy for the selected site.

By default, the dashlet shows statistics for the last 3 hours. You can view statistics for the last 24 hours or 7
days by choosing the required time from the drop-down list in the top-left corner of the Umbrella Service
Stats page.

Prerequisites for Provisioning Cisco Umbrella on Network Devices
Before provisioning Cisco Umbrella on network devices, ensure that:

• Cisco Umbrella is configured with Cisco DNA Center.

• Wireless provisioning is complete for the devices on which you want to provision Cisco Umbrella.

• The SSID configuration is nonfabric.

• The AP is provisioned, if the device is configured with a nonfabric SSID in FlexConnect mode.

• The device has direct internet access to establish connection with Cisco Umbrella.

• The Cisco Umbrella root certificate is available in the Cisco DNA Center trusted certificates bundle. See
the "Configure Trusted Certificates" topic in the Cisco DNA Center Administrator Guide.
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• If the device has a Cisco Umbrella configuration that is not set from Cisco DNA Center, remove the
Cisco Umbrella configuration from the device and resync the device with Cisco DNA Center.

Provision Cisco Umbrella on Network Devices

Before you begin

Make sure the prerequisites have been met. For information, see Prerequisites for Provisioning Cisco Umbrella
on Network Devices, on page 34.

Cisco umbrella deployment on your organization's network can be monitored only from login.umbrella.com.Note

Step 1 From the top-left corner, click the menu icon and choose Workflows > Umbrella Deployment.
Alternatively, do the following:

• From the top-left corner, click the menu icon and choose Provision > Umbrella.

• Choose a site from the network hierarchy for which you want to deploy Cisco Umbrella.

• The Select Devices window appears. Go to Step 4 to continue the deployment workflow.

Step 2 If a task overview window appears, click Let's Start to go directly to the workflow.
Step 3 The Choose Site window appears.

a) You can view the device readiness status in each site, as follows:

• Eligible Devices: Devices that are eligible for Cisco Umbrella configuration. See Prerequisites for Provisioning
Cisco Umbrella on Network Devices, on page 34.

• Enabled Devices: Devices that are already configured from Cisco DNA Center.

b) Choose a site to deploy and click Next.

You can choose only one site at a time. If you choose a parent site, Cisco Umbrella can be deployed
on all child sites at the same time.

Note

Step 4 In the Select Device Type window, choose Switches or Wireless Controllers.
Step 5 If you have chosen Switches in the Select Device Type window, do the following:

a) In the Select Devices window, choose the wired device.
b) In the Configure Interface window, do the following:

1. Choose the ports you want to configure and click Define Umbrella Interfaces.

2. In the Select Configuration dialog box, click the Define Umbrella Interfaces drop-down list and choose
IN(LAN), OUT(WAN) or Disable Umbrella and click Save.

You must choose at lease one IN and one OUT interface to proceed further.Note

c) In the Define Umbrella Policy Mapping (Wired) window, choose Umbrella policies at a global or interface level.
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d) In the Configure Policies for Your Devices window, choose the IN(LAN) interface and click Define Umbrella
Policies.

e) In the Select Policy dialog box, choose the policy for the selected interfaces and click Save.

Step 6 If you have chosen Wireless Controllers in the Select Device Type window, do the following:
a) In the Select Devices window, choose the wireless device.
b) Choose the SSIDs and select the required Cisco Umbrella policy for each SSID.

• Only nonfabric SSIDs are listed on this page.

• If you choose an SSID and don't select the Cisco Umbrella policy, the default policy is mapped
with the SSID.

• If you choose multiple policies, the order of enforcement of policies is defined in the Cisco
Umbrella cloud portal.

Note

c) In the Umbrella Policy Association (Wireless) window, view the default policies applied to the SSIDs.

If you want to change the policies associated with the SSIDs, click the Cisco Umbrella link. In the Cisco Umbrella
console, you can see the network identity after you have completed the deployment of Cisco Umbrella from Cisco
DNA Center. For devices with Cisco IOS-XE software version 16.xx, the network identity is shown as global. For
devices with a Cisco IOS-XE software version later than 16.xx, the network identity is shown as a custom name
created based on the site and SSID name.

Step 7 In the Review Internal Domains window, add or delete the list of internal domains. The DNS queries that match a
domain in the Internal Domain list are forwarded to the local DNS server instead of Cisco Umbrella.

Step 8 The DNS Crypt window appears. The Enable DNS Packet Encryption option is selected by default.
a) In the DNS Crypt window, click Next.
b) If you don't want DNS packet encryption, uncheck the Enable DNS Packet Encryption check box.

Step 9 In the Summary window, review the details. To make any changes, click Edit.
Step 10 To proceed, click Deploy.
Step 11 In the Schedule window, choose whether you want to deploy the configuration now or schedule it later.
Step 12 To proceed, click Apply.
Step 13 In the Deployment window, click View Status to view the deployment status in the Scheduled Tasks window.

You can view the Cisco Umbrella deployment status of the device and the device configuration status in Cisco Umbrella.
You can also view the Cisco Umbrella deployment logs in the Audit Logs window.

Disable Cisco Umbrella on Network Devices

Step 1 From the top-left corner, click the menu icon and choose Workflows > Umbrella Deployment.
Alternately, do the following:

• From the top-left corner, click the menu icon and choose Provision > Services > Umbrella.

• Choose a site from the network hierarchy from which you want to disable Cisco Umbrella.

• The Select Devices window appears. Go to Step 4 to continue the disable workflow.
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Step 2 If a task overview window appears, click Let's Start to go directly to the workflow.
Step 3 The Choose Site window appears.

a) You can view the device readiness status in each site, as follows:

• Ready Devices: Devices that meet the prerequisites for Cisco Umbrella configuration. See Prerequisites for
Provisioning Cisco Umbrella on Network Devices, on page 34.

• Not Ready Devices: Devices that do not meet the prerequisites.

• Enabled Devices: Devices that are already configured from Cisco DNA Center.

b) Choose the site that you want to disable, and click Next.

You can choose only one site at a time. If you choose a parent site, Cisco Umbrella is disabled on all
the child sites at the same time.

Note

Step 4 In the Select Device Type window, choose Switches or Wireless Controllers.
Step 5 In the Select Devices window, click the Enabled tab and choose the devices.
Step 6 Click the Disable radio button and choose the devices.
Step 7 In the Summary window, review the details. To make any changes, click Edit.
Step 8 To proceed, click Deploy.
Step 9 In the Schedule window, choose whether you want to deploy the configuration now or schedule it later.
Step 10 To proceed, click Apply.
Step 11 In the Deployment window, click View Status to view the deployment status in the Scheduled Tasks window.

You can view the Cisco Umbrella deployment logs in the Audit Logs window.

Update the Cisco Umbrella Configuration on Network Devices

Step 1 From the top-left corner, click the menu icon and choose Workflows > Umbrella Deployment.
Alternately, do the following:

• From the top-left corner, click the menu icon and choose Provision > Services > Umbrella.

• Choose a site from the network hierarchy for which you want to update the Cisco Umbrella configuration.

• The Select Devices window appears. Go to Step 4 to continue the update workflow.

Step 2 If a task overview window appears, click Let's Start to go directly to the workflow.
Step 3 The Choose Site window appears.

a) You can view the device readiness status in each site, as follows:

• Ready Devices: Devices that meet the prerequisites for Cisco Umbrella configuration. See Prerequisites for
Provisioning Cisco Umbrella on Network Devices, on page 34.

• Not Ready Devices: Devices that do not meet the prerequisites.

• Enabled Devices: Devices that are already configured from Cisco DNA Center.
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b) Choose the site that you want to update and click Next.

You can choose only one site at a time. If you choose a parent site, Cisco Umbrella is updated on all
child sites at the same time.

Note

Step 4 In the Select Device Type window, choose Switches or Wireless Controllers.
Step 5 If you have chosen Switches in the Select Device Type window, do the following:

a) In the Select Devices window, choose the wired device and click the Update radio button.
b) In the Configure Interface window, do the following:

1. Choose the ports and click Define Umbrella Interfaces.

2. In the Select Configuration dialog box, click the Define Umbrella Interfaces drop-down list and choose
IN(LAN), OUT(WAN) or Disable Umbrella and click Save.

You must choose at lease one IN and one OUT interface to proceed further.Note

c) In the Define Umbrella Policy Mapping (Wired) window, choose Umbrella policies at a global or interface level
and click Next.

d) In the Configure Policies for Your Devices window, choose the IN(LAN) interface and click Define Umbrella
Policies.

e) In the Select Policy dialog box, choose the policy for the selected interfaces and click Save.

Step 6 If you have chosen Wireless Controllers in the Select Device Type window, do the following:
a) In the Select Devices window, choose the wireless device and click the Update radio button.
b) In the Define Umbrella Policy Map (Wireless) window, choose the SSIDs and select the desired Cisco Umbrella

policies to map, or unselect SSIDs to disable Cisco Umbrella.

Step 7 In the Review Internal Domains window, add or delete the list of internal domains. The DNS queries that match a
domain in the Internal Domain list are forwarded to the local DNS server instead of Cisco Umbrella.

Step 8 The DNS Crypt window appears. The Enable DNS Packet Encryption option is selected by default.

If you don't want DNS packet encryption, uncheck the Enable DNS Packet Encryption check box.

Step 9 In the Summary window, review the details. To make any changes, click Edit.
Step 10 To proceed, click Deploy.
Step 11 In the Schedule window, choose whether you want to deploy the configuration now or schedule it later.
Step 12 To proceed, click Apply.
Step 13 In the Deployment window, click View Status to view the deployment status in the Scheduled Tasks window.

You can view the Cisco Umbrella deployment logs in the Audit Logs window.

Create Secure Tunnel
Cisco DNA Center allows the user to plan and deploy VPN Tunnels, which establishes secure connection
between enterprise and branch location.
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This feature is currently supported only on the Cisco Catalyst 9300X Series Switches.Note

Configure Secure Tunnel
You can use this procedure to plan and deploy secure tunnels on day n.

Step 1 From the top-left corner, click the menu icon and choose Provision > Secure Tunnels.

Alternatively, you can create a secure tunnel from the Workflows > Create Secure Tunnel window.

Step 2 In the Secure Tunnel window, click Create Secure Tunnel.
Step 3 If the task overview window opens, click Let’s Do it to go directly to the workflow.
Step 4 In the Select Tunnel Type window, choose the type of secure tunnel to create by clicking the Site To Secure Access

Service Edge (SIG/SASE) tile.

This action creates a secure tunnel between the Cisco Catalyst 9300X Series switch and the Secure Internet Gateway.

Step 5 In the Select Secure Internet Gateway window, click the drop-down list to choose the Secure Internet Gateway.

Do one of the following for the chosen Secure Internet Gateway:

• Umbrella: Ensure that you created a tunnel in Cisco Umbrella. You will need the tunnel ID and preshared key in
the subsequent steps. For more information, see Configure Cisco Umbrella with Cisco DNA Center, on page 33.
If the tunnel is created in the Cisco Umbrella portal, check the confirmation check box.

• Zscaler: Ensure that the tunnel is already created on the Zscaler portal. After you create the tunnel in Zscaler, the
preshared key and the FQDN defined there are required to configure the tunnel parameters on the selected Cisco
Catalyst 9300X Series switch. If the tunnel is created in the Zscaler portal, check the confirmation check box.

Step 6 In the Choose Site and Device window, do the following for site and tunnel mapping:

a. Choose the Site from the drop-down list.

b. Choose the Device from the drop-down list.

c. Choose the Number of Tunnels to create from the drop-down list.

d. For Zscaler, choose the Tunnel Type from the drop-down list.

e. Enter the Tunnel Name.

f. Choose the Tunnel Source Interface.

g. Check the check box if you want to use the same interface for the tunnel IP. If you do not want to use the same
interface, uncheck the check box and choose the Interface.

h. Enter the Data Center Location.

Step 7 In Define Tunnel Settings window, do the following:

a. For Umbrella, enter the Pre-Shared Key (PSK) for authentication.

b. If the Secure Internet Gateway integration is not complete, do the following:
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1. Enter the Tunnel ID and choose one of the following:

a. Fully Qualified Domain Name (FQDN): Use the Tunnel ID generated in Cisco Umbrella or the User ID
generated in Zscaler.

b. IP Address: Use the IP address to which you want to connect.

c. Check the check box to use the Cisco-recommended settings. To customize the values, uncheck the check box.

Step 8 In the Configure Tunnel Traffic window, choose from the following options to route the traffic:

• Send all traffic: To send all traffic through the IPsec tunnel to Umbrella.

• Send Selected Traffic: Enter the subnet and ingress interface for the subnet. You can add more subnets by clicking
.

Step 9 In the Schedule Task window, choose whether you want to create the tunnel now or schedule it for later. Also, you
can choose to Generate CLI Preview.

Step 10 In the Summary window, review the configuration settings. To make any changes, click Edit.
Step 11 Click Create Secure Tunnel.

The Done! window appears.

Step 12 Click the View all Tunnels tab to view the status of the tunnel creation.

This process might take some time. Click Refresh. When the tunnel is up, the status changes from Provision to Up.
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