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Provisioning
After you have configured the policies for your network in Cisco DNACenter, you can provision your devices.
In this stage, you onboard devices and deploy the policies across them.

Provisioning devices includes the following aspects:

• Onboarding devices with Plug and Play, which adds them to the inventory.

• Deploying the required settings and policies to devices in the inventory.

• Adding devices to sites.

• Creating fabric domains and adding devices to the fabric.

Cisco DNACenter provisioning supports only IBNS 2.0, which changes the AAA configuration and converts
all relevant authentication commands to their Class-Based Policy Language (CPL) control policy equivalents.
Because the CPL conversion disables the conversion CLI authentication display [legacy|new-style], we
recommend that you back up your current configuration. Also, plan your change management windows to
support AAA configuration updates (aligned with IBNS 2.0).

Onboard Devices with Plug and Play Provisioning
Plug and Play provisioning provides a way to automatically and remotely provision and onboard new network
devices with minimal network administrator and field personnel involvement.
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Using Plug and Play provisioning, you can do the following:

• Provision devices by assigning a site, deploying site settings, installing a device software image, and
applying a custom onboarding configuration.

• Plan devices before their installation by entering device information and choosing provisioning operations.
When the device comes online, it contacts Cisco DNACenter and Plug and Play provisions and onboards
the device automatically.

• Provision unclaimed network devices, which are new devices that appear on the network, without prior
planning.

• Synchronize the device inventory from the Cisco Plug and Play Connect cloud portal in a Cisco Smart
Account to Plug and Play, so that all the devices appear in Cisco DNA Center.

• Display the detailed onboarding status of network devices.

Prerequisites

Before using Plug and Play provisioning, do the following:

• Set your Cisco credentials in the main Cisco DNA Center settings by using System Settings > Settings
> Cisco Credentials. For more information, see "Configure Cisco Credentials" in the Cisco Digital
Network Architecture Center Administrator Guide.

• Accept the End User License Agreement (EULA) in the main Cisco DNA Center settings by using
System Settings > Settings > Device EULA Acceptance. For more information, see "Accept the License
Agreement" in the Cisco Digital Network Architecture Center Administrator Guide.

• Ensure that Cisco network devices to be provisioned have a supported software release and are in a
factory default state. If you are using a network device that was previously configured or is in an unknown
state, see the device clean-up and reset details in the Network Plug and Play Troubleshooting Guide for
Cisco Digital Network Architecture Center.

The following sections describe typical use cases and workflows for Plug and Play provisioning.

Planned Provisioning

An administrator can plan the provisioning of a new site or other group of network devices as follows:

1. Define the site within the network hierarchy. See About Network Hierarchy.

2. Optionally, define Onboarding Configuration templates to be applied to devices. Such templates contain
basic network configuration commands to onboard a device so that it can be managed on the network. In
many cases, such templates are not necessary unless you need to customize the Day 0 configuration. See
Create Templates to Automate Device Configuration Changes.

3. Define network profiles for the types of devices you are deploying. See Create Network Profiles.

4. Define the device credentials (CLI and SNMP) for the devices you are deploying. See About Device
Credentials.

5. Optionally, ensure that software images for the devices to be provisioned are uploaded and marked as
golden in the Image Repository. See Import a Software Image.

6. Add details about planned devices one at a time or in bulk with a CSV file. See Add or Edit a Device, on
page 8 or Add Devices in Bulk, on page 9.
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7. Devices boot up and are automatically provisioned.

Unclaimed Provisioning

If a new network device is added to the network before it can be planned, it is labeled as an unclaimed device.
An unclaimed device can be addedmanually by an administrator, or automatically through one of the discovery
methods described in Controller Discovery Prerequisites, on page 3. An administrator can provision the
device as follows:

1. Find the device on the devices list by filtering on unclaimed devices or searching for it by name. See View
Devices, on page 7.

2. Claim the device by assigning a site, image, configuration template, or profile. See Provision a Device
with Plug and Play, on page 12.

Cisco Smart Account Synchronization and Provisioning

Network devices can be automatically registered through a Cisco Smart Account with the Cisco Plug and
Play Connect cloud service. An administrator can synchronize the device inventory from Cisco Plug and Play
Connect to Cisco DNA Center Plug and Play, so that all the devices appear in Cisco DNA Center. These
devices can then be claimed and provisioned.

1. Register a Smart Account and virtual account with which to synchronize. See Register or Edit a Virtual
Account Profile, on page 10.

2. Synchronize the device inventory from the Smart Account. See Add Devices from a Smart Account, on
page 11.

3. Find the device on the devices list by filtering on unclaimed devices or searching for it by name. See View
Devices, on page 7.

4. Claim the device by assigning a site, image, configuration template, or profile. See Provision a Device
with Plug and Play, on page 12.

5. Devices boot up and are automatically provisioned.

Controller Discovery Prerequisites
Plug and Play automates device onboarding and requires that devices must be able to discover and contact
the Cisco DNA Center controller. Devices must be able to automatically discover the controller in one of the
following ways:

• DHCP—See DHCP Controller Discovery, on page 3.

• DNS—See DNS Controller Discovery, on page 5.

• Cisco Plug and Play Connect cloud service—See Plug and Play Connect Controller Discovery, on page
5.

DHCP Controller Discovery
When a Cisco network device first starts up with no startup configuration, it attempts to discover the Cisco
DNA Center controller by using DHCP Option 43.
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The prerequisites for the DHCP discovery method are as follows:

• New devices can reach the DHCP server.

• The DHCP server is configured with Option 43 for Cisco Plug and Play. This option informs the network
device of the IP address of the Cisco DNA Center controller.

When the DHCP server receives a DHCP discover message from the device, with option 60 containing
the string “ciscopnp”, it responds to the device by returning a response that contains the Option 43
information. The Cisco Plug and Play IOS Agent in the device extracts the Cisco DNA Center controller
IP address from the response and uses this address to communicate with the controller.

DHCP Option 43 consists of a string value that is configured as follows on a Cisco router CLI that is acting
as a DHCP server:

ip dhcp pool pnp_device_pool <-- Name of DHCP pool
network 192.168.1.0 255.255.255.0 <-- Range of IP addresses assigned to clients
default-router 192.168.1.1 <-- Gateway address
option 43 ascii "5A1N;B2;K4;I172.19.45.222;J80" <-- Option 43 string

The Option 43 string has the following components, delimited by semicolons:

• 5A1N;—Specifies the DHCP suboption for Plug and Play, active operation, version 1, no debug
information. It is not necessary to change this part of the string.

• B2;—IP address type:

• B1 = hostname

• B2 = IPv4 (default)

• Ixxx.xxx.xxx.xxx;—IP address or hostname of the Cisco DNACenter controller (following a capital letter
i). In this example, the IP address is 172.19.45.222.

• Jxxxx—Port number to use to connect to the Cisco DNA Center controller. In this example, the port
number is 80. The default is port 80 for HTTP and port 443 for HTTPS.

• K4;—Transport protocol to be used between the device and the controller:

• K4 = HTTP (default)

• K5 = HTTPS

• TtrustpoolBundleURL;—Optional parameter that specifies the external URL of the trustpool bundle if
it is to be retrieved from a different location than the default, which is the Cisco DNA Center controller,
which gets the bundle from the Cisco InfoSec cloud (http://www.cisco.com/security/pki/). For example,
to download the bundle from a TFTP server at 10.30.30.10, you would specify the parameter like this:
Ttftp://10.30.30.10/ios.p7b

If you are using trustpool security and you do not specify the T parameter, the device retrieves the trustpool
bundle from the Cisco DNA Center controller.

• Zxxx.xxx.xxx.xxx;—IP address of the NTP server. This parameter is mandatory when using trustpool
security to ensure that all devices are synchronized.

See the Cisco IOS Command Reference for additional details on DHCP configuration.
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If DHCP Option 43 is not configured, the device cannot contact the DHCP server, or this method fails for
another reason, the network device attempts discovery using using DNS. For more information, see DNS
Controller Discovery, on page 5.

DNS Controller Discovery
If DHCP discovery fails to get the IP address of the Cisco DNA Center controller, the network device falls
back on the DNS lookup method. Based on the network domain name returned by the DHCP server, it
constructs a fully qualified domain name (FQDN) for the controller, using the preset hostname pnpserver.
The NTP server name is based on the preset hostname pnpntpserver.

For example, if the DHCP server returns the domain name “customer.com”, the network device constructs
the controller FQDN of pnpserver.customer.com. It then uses the local name server to resolve the IP address
for this FQDN. The NTP server name FQDN would be pnpntpserver.customer.com.

The prerequisites for the DNS discovery method are as follows:

• New devices can reach the DHCP server.

• The Cisco DNA Center controller is deployed with the hostname “pnpserver”.

• The NTP server is deployed with the hostname pnpntpserver.

Plug and Play Connect Controller Discovery
In situations where using the DHCP or DNS discovery methods is not an option, the Cisco Plug and Play
Connect cloud service allows devices to discover the IP address of the Cisco DNA Center controller. When
the network device boots up, if it cannot locate the controller through DHCP or DNS, then it tries Plug and
Play Connect by contacting devicehelper.cisco.com to obtain the IP address of the appropriate controller that
is defined for your organization. To secure the communications, the first thing that the device does when
contacting Plug and Play Connect is to download and install the Cisco trustpool bundle.

The following steps summarize how to use Cisco Plug and Play to deploy a Cisco network device by using
Plug and Play Connect for discovery.

Before you begin

Cisco network devices are running Cisco IOS images that support Cisco Plug and Play and have connectivity
to the Cisco Plug and Play Connect cloud service.

Step 1 The network administrator configures the controller profile for the appropriate Cisco DNA Center controller for your
organization by using Plug and Play Connect in the Cisco Smart Account web portal. For more information, see the Smart
Account documentation in the web portal.

Step 2 If you order plug and play network devices through Cisco Commerce Workspace (CCW), these network devices are
automatically registered with Plug and Play Connect as long as a Cisco Smart Account is assigned to the order and you
include the NETWORK-PNP-LIC option for each device that you want to use with Cisco Plug and Play.

This option causes the device serial number and PID to be automatically registered in your Smart Account for plug and
play. If you have specified a default controller, then the devices are automatically assigned to that controller when the
order is processed.

Step 3 Alternatively, you can manually add devices in the Plug and Play Connect web portal.
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Step 4 Register the Cisco DNA Center controller as a controller for Cisco Plug and Play Connect in a Cisco Smart Account, for
redirection services. See Register or Edit a Virtual Account Profile, on page 10.

This step is required if you order plug and play network devices through CCW and these network devices are automatically
registered with Plug and Play Connect through your Smart Account.

Step 5 Synchronize the device inventory from the Smart Account in the Cisco Plug and Play Connect cloud portal to Cisco DNA
Center Plug and Play.

Devices registered in the Plug and Play Connect web portal are synced to the controller and appear in the plug and play
device list with a source of SmartAccount.

Step 6 Claim the newly synced devices. See Provision a Device with Plug and Play, on page 12.
Step 7 The device installer installs and powers up the Cisco network device.
Step 8 The device discovers the Cisco DNA Center controller by querying the Plug and Play Connect service, identifies itself

by serial number to Plug and Play in Cisco DNA Center, then is provisioned according to what was planned for it during
the claim process.

The device will fail to contact Plug and Play Connect if the device cannot synchronize with the predefined
NTP servers time-pnp.cisco.com or pool.ntp.org. To resolve this problem, either unblock NTP traffic to
these two host names, or map these two NTP host names to local NTP server addresses on the DNS server.

Note

Plug and Play Deployment Guidelines
Follow these recommendations when using Plug and Play:

• Device bring up order—In general, routing and upstream devices should be brought up first. Once the
router and all upstream devices are up and provisioned, switches and downstream devices can be brought
up. The Plug and Play agent in a device attempts to auto-discover the Cisco DNA Center controller only
during initial device startup. If at this time, the device cannot contact the controller, device provisioning
fails, so upstream devices should be provisioned first.

• Cisco Router Trunk/Access Port Configuration—Typical branch networks include routers and switches.
One or more switches are connected to the WAN router and other endpoints like IP phones and access
points connect to the switches. When a switch connects to an upstream router, the following deployment
models are supported for Plug and Play:

• Downstream switch is connected to the router using a switched port on the router. In this type of
connection, the switched port on the router can be configured as a trunk or access port.

• Downstream switch is connected to the router using a routed port on the router. In this case, the
routed port can support multiple VLANs using sub-interfaces. During the Plug and Play process,
the switch would automatically configure its port as a trunk port. In a large branch scenario, it
becomes necessary to carry multiple VLANs between the router and the downstream switch. To
support this use case, the switch must be connected to a routed port.

• Non-VLAN 1 configuration—Plug and Play supports devices using VLAN 1 by default. If you want to
use a VLAN other than 1, adjacent upstream devices must use supported releases and you must configure
the following global CLI command on the upstream device to push this CLI to the upcoming Plug and
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Play device: pnp startup-vlan x . When you execute this command on an adjacent upstream device, the
VLAN membership change does not happen on that device. However, the active interfaces on the
upcoming Plug and Play device that are connected to the upstream device are changed to the specified
VLAN. This guideline applies to both routers and switches and should be used only for trunk mode
scenarios and not access mode.

View Devices
This procedure shows how to view Plug and Play devices, how to perform actions on them, and how to add
new devices.

Step 1 From the Cisco DNA Center home page, choose Provision > Devices > Plug and Play.
Step 2 View the devices in the table.

You can use the Filter option to find specific devices. Click Refresh to refresh the device list.

Step 3 Click the name of a device.

A window with the device details is displayed.

Step 4 Click the Details, History, and Configuration or Stack tabs to view the different types of information for the device.
Some tabs have additional links that you can click for more information.

The Stack tab appears only for a switch stack device.

Step 5 Click the following actions at the top of the dialog box to perform specific tasks on the device. Available actions depend
on the device state.

• Refresh: Refreshes the device state information.
• Claim: Claims and provisions the device. See Provision a Device with Plug and Play, on page 12.
• Edit: Edits the device. See Add or Edit a Device, on page 8.
• Reset: Resets the device if it is in an error state. See Reset a Device, on page 19.
• Delete: Deletes the device. See Delete a Device, on page 19.

Step 6 To perform an action on multiple devices, click the check box next to each device in the table view and choose an action
from the Actions drop-down menu.

Step 7 Click Add Device to add a new device.
See the following for more information about adding devices in different ways: Add or Edit a Device, on page 8, Add
Devices in Bulk, on page 9, or Add Devices from a Smart Account, on page 11.

The Device table displays the information shown in the following table for each device. All of the columns
support sorting. Click the column header to sort the rows in ascending order. Click the column header again
to sort the rows in descending order.

Some of the columns are hidden in the default column view setting, which can be customized by clicking the

three dots ( ) at the right end of the column headings.

Note
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Table 1: Device Information

DescriptionColumn

Row number.#

Hostname of the device. Click this link to open the device details window.
A stack icon indicates a switch stack.

Device Name

Device serial number.Serial Number

Device product ID.Product ID

Source of the device entry:

• User: User added the device through the GUI or API.

• Network: Unclaimed device that has contacted the controller.

• SmartAccount: Device was synced from a Smart Account.

Source

• Unclaimed: Device has not been provisioned.

• Planned: Device has been claimed but has not yet contacted the server.

• Onboarding: Device onboarding is in progress.

• Provisioned: Device is successfully onboarded and added to inventory.

• Error: Device had an error and could not be provisioned.

State

Onboarding state of the device.Onboarding State

Site with which the device is associated.Site

Last date and time the device contacted Plug and Play.Last Contact

Cisco Smart Account with which the device is associated.Smart Acct

Virtual Account (within the Cisco Smart Account) with which the device
is associated.

Virtual Acct

Date and time when the device was added to Plug and Play.Created

Add or Edit a Device
This procedure shows how to add or edit a device from the Plug and Play Devices list. Alternatively, you can
edit a device from the device details window by clicking Edit.

Table 2: Device Fields

DescriptionField

Device serial number (read only if you are editing a device).Serial Number
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DescriptionField

Device product ID (read only if you are editing a device).Product ID

Device name.Device Name

Enables secure unique device identifier (SUDI) authorization on devices
that support it.

Enable SUDI Authorization

Devices that support SUDI have two serial numbers: the chassis serial
number and the SUDI serial number (called the License SN on the device
label). Enter one or more comma-separated SUDI serial numbers in this
field when adding a device that uses SUDI authorization. This field appears
only if Enable SUDI Authorization is checked.

SUDI Serial Numbers

Device represents a stack (this item is read only if you are editing a device).
Applicable only for supported stackable switches.

This Device Represents a
Stack

Before you begin

If the device requires credentials, be sure that the global device credentials are set in the Design > Network
Settings > Device Credentials page. For more information, see Configure Global CLI Credentials.

Step 1 From the Cisco DNA Center home page, choose Provision > Devices > Plug and Play.
Step 2 View the devices in the table.

You can use the Filter option to find specific devices. Click Refresh to refresh the device list.

Step 3 Add or edit a device as follows:

• To add a device, click Add Device and the Add Devices dialog is displayed.
• To edit a device, check the check box next to the name of the device you want to edit and click Actions > Edit in
the menu bar above the device table. The Edit Device dialog is displayed.

Step 4 Set the fields as needed, referring to the preceding table for more information.
Step 5 Save the settings by doing one of the following:

• If you are adding a device and will claim it later, click Add Device.
• If you are adding a device and want to claim it immediately, click Add + Claim. For more information on claiming
a device, see Provision a Device with Plug and Play, on page 12.

• If you are editing a device, click Edit Device.

Add Devices in Bulk
This procedure shows how to add devices in bulk from a CSV file.

If you add a device that already exists in Plug and Play, there is no change to the existing device.Note
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Step 1 From the Cisco DNA Center home page, choose Provision > Devices > Plug and Play.
Step 2 Click Add Device.

The Add Devices dialog is displayed.

Step 3 Click the Bulk Devices tab.
Step 4 Click Download File Template to download the sample file.
Step 5 Add the information for each device to the file and save the file. Note that certain fields are required, depending on the

device type.
Step 6 Upload the CSV file by doing one of the following actions:

• Drag and drop the file to the drag and drop area.
• Click where it says "click to select" and select the file.

Step 7 Click Import Devices.

The devices in the CSV file are listed in a table.

Step 8 Check the box next to each device to import, or click the check box at the top to select all devices.
Step 9 Add the devices by doing one of the following:

• To add the devices and claim them later, click Add Devices.
• To add the devices and claim them immediately, click Add + Claim. For more information on claiming a device,
see Provision a Device with Plug and Play, on page 12.

Register or Edit a Virtual Account Profile
This procedure lets you register the Cisco DNA Center controller as the default controller for Cisco Plug and
Play Connect in a Cisco Smart Account, for redirection services. Also, this lets you synchronize the device
inventory from the Cisco Plug and Play Connect cloud portal to Cisco DNA Center Plug and Play.

Table 3: Virtual Account Fields

DescriptionField

Cisco Smart Account name.Select Smart Account

Virtual account name. Virtual accounts are subaccounts within a Cisco
Smart Account.

Select Virtual Account

Check this check box to register this Cisco DNA Center controller as the
default controller in the Cisco Plug and Play Connect cloud portal.

Use as Default Controller
Profile

IP address or fully qualified domain name of this Cisco DNA Center
controller.

Controller IP or FQDN

Controller profile name.Profile Name
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Before you begin

Set the Cisco Smart Account credentials in the main Cisco DNA Center settings by using System > Settings
> Smart Account. For more information, see "Configure Smart Account" in the Cisco Digital Network
Architecture Center Administrator Guide.

Step 1 From the Cisco DNA Center home page, choose System Settings > Settings > Cisco Credentials.
Step 2 Click the PnP Connect tab.

The table lists all of the registered Plug and Play Connect virtual account profiles.

Step 3 Either add or edit a virtual account profile, as follows:

• To register a virtual account, click Add. The register virtual account dialog is displayed.
• To edit a registered virtual account profile, click the radio button next to the name of the profile that you want to
edit and click Edit Profile in the menu bar above the table. The edit virtual account dialog is displayed.

Step 4 Set the fields as needed by referring to the preceding Virtual Account Fields table.
Step 5 Save the settings by doing one of the following:

• If you are registering a new virtual account profile, click Register.
• If you are editing a virtual account profile, click Change.

What to do next

Synchronize the device inventory from the Cisco Plug and Play Connect cloud portal to Cisco DNA Center
Plug and Play. For more information, see Add Devices from a Smart Account, on page 11.

Add Devices from a Smart Account
This task allows you to synchronize the device inventory from a Smart Account in the Cisco Plug and Play
Connect cloud portal to Cisco DNA Center Plug and Play.

The Virtual Accounts table displays the following information for each profile.

Table 4: Virtual Accounts Information

DescriptionColumn

Virtual account name.Virtual Accounts

Smart account that the virtual account is associated with.Smart Accounts

Status of the last synchronization processSync Status

Before you begin

Before you can synchronize the device inventory from the Cisco Plug and Play Connect cloud portal, you
must register a virtual account. See Register or Edit a Virtual Account Profile, on page 10.
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Step 1 From the Cisco DNA Center home page, choose Provision > Devices > Plug and Play.
Step 2 Click Add Device.

The Add Devices dialog is displayed.

Step 3 Click the Smart Account Devices tab.
Step 4 Click the radio button next to the name of the Plug and Play Connect virtual account profile from which you want to add

devices.
Step 5 Click Sync to synchronize the device inventory from Cisco Plug and Play Connect in this virtual account to Cisco DNA

Center Plug and Play.
Added devices appear in the Plug and Play Devices table with the source set to SmartAccount.

What to do next

Claim the newly synchronized devices. For more information on claiming a device, see Provision a Device
with Plug and Play, on page 12.

Provision a Device with Plug and Play
Provisioning or claiming a device provisions it by deploying an image and an onboarding configuration to it,
or a network profile for wireless devices, and adding it to the inventory. If you claim a device that has not yet
booted for the first time, you are planning the device so that it is automatically provisioned when it boots up.

The workflow for provisioning a device varies depending on the type of device, as follows:

• Switches and routers: See Provision a Switch or Router Device, on page 12

• Wireless LAN controllers, access points, and sensors: See Provision a Wireless or Sensor Device, on
page 16

Provision a Switch or Router Device
Claiming a device provisions it by assigning it to a site, installing an image, deploying the site settings and
onboarding configuration to it, and adding it to the inventory. If you claim a device that has not yet booted
for the first time, then you are planning the device so that it is automatically provisioned when it boots up.

When a device is claimed, some system configuration CLI commands from Cisco DNA Center are pushed
to the device first, before the Onboarding Configuration (Day-0) template that you have defined. If your
Onboarding Configuration template has any of the same CLI commands, these will override the system
configuration, since they are applied last. The CLI commands pushed by the system include the following:

• Device credentials (CLI and SNMP)

• Enable SSH v2 and SCP server

• Disable HTTP and HTTPS servers

• For switches, vtp mode transparent is enabled
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When Device Controllability is enabled for a device (it is enabled by default), the following configurations
are added when the device is added into inventory:

• SNMP, NETCONF, and Cisco TrustSec (CTS) credentials

• IPDT enablement

• Controller certificates

• SNMP trap server definitions

• Syslog server definitions

• Netflow collector definitions

• Wireless network assurance

Note

This procedure shows how to claim a device from the Plug and Play Devices list. Alternatively, you can claim
a device from the device details window by clicking Claim.

Before you begin

• Ensure that Cisco network devices to be provisioned have a supported software release and are in a
factory default state. If you are using a network device that was previously configured or is in an unknown
state, see the device clean-up and reset details in the Network Plug and Play Troubleshooting Guide for
Cisco Digital Network Architecture Center.

• Ensure that the devices being provisioned can discover and contact Cisco DNA Center. For more
information, see Controller Discovery Prerequisites, on page 3.

• Define the site within the network hierarchy. See About Network Hierarchy.

• Define the CLI and SNMP credentials for the devices. If you are using SNMPv2c, both Read and Write
credentials must be provided. See About Device Credentials.

• Optionally, ensure that software images for the devices to be provisioned are uploaded and marked as
golden in the Image Repository, if you want to deploy images. See Import a Software Image.

The image deployment process used by Plug and Play during Day-0 provisioning
is not the same as that used when updating a device image later, which is described
in Provision a Software Image. During Plug and Play provisioning, there are no
device prechecks, auto flash cleanup, or post-checks done, as it is expected that
devices are in the factory default state.

Note

• Optionally, define Onboarding Configuration templates to be applied to devices. Such templates contain
basic network configuration commands to onboard a device so that it can be managed on the network.
In most cases, such templates are not necessary, unless you need to customize the Day-0 configuration.
See Create Templates to Automate Device Configuration Changes.
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You can use the ip http client source-interface CLI command in the
Onboarding Configuration template, which makes Cisco DNA Center use that
IP address as the management IP address for device, especially for the scenario
of multiple IPs or VRFs.

Note

• Define network profiles for the devices. See Create Network Profiles.

Step 1 From the Cisco DNA Center home page, choose Provision > Devices > Plug and Play.
Step 2 View the devices in the table.

You can use the Filter or Find option to find specific devices.

Step 3 Check the check box next to one or more devices that you want to claim.
Step 4 Click Actions > Claim in the menu bar above the device table.

The Claim Devices window opens, showing the first step, Assign Site.

Step 5 (Optional) Change the device hostname, if needed, in the first column.
Step 6 From the Select a Site drop-down list, choose a site to assign to each device.

To apply the same site as the first device to all other devices, click the Apply Site to All check box. To assign the site
from any device to some other devices, click Assign this Site to Other Devices, choose the devices, and click Assign.

Step 7 Click Next.
The Assign Configuration window appears.

Step 8 (Optional) Make global changes to the device table as follows:
a) Change which columns are displayed in the table by clicking the 3 dots at the right end of the table headings and

choosing the desired columns. Click Apply to save the changes.
b) Click Clear Images to clear the default images configured for devices. Click the check box for each device you

want to clear the image from and click Clear.
c) Click Clear Templates to clear the default templates configured for devices. Click the check box for each device

you want to clear the template from and click Clear.
d) Click Clear License Levels to clear the license levels configured for devices. Click the check box for each device

you want to clear the license level from and click Clear.
e) You can apply an image or template from one device to other devices by clicking the 3 dots in the Actions column

next to a device and choosing Apply Image to Other Devices or Apply Template to Other Devices. For stacked
devices, you can apply the device license level to other devices by clickingApply License Level to Other Devices.

Step 9 In the Configuration column, click on Assign for the device that you want to configure and follow these steps:
a) View the device configuration summary and click Cancel if no changes are needed.
b) (Optional) In the Device Name field, change the device hostname, if needed.
c) (Optional) In the Image drop-down list, choose a golden software image to apply to the device. If there is only one

golden image for this device type in the image repository, it is chosen by default.
d) (Optional) In the Template drop-down list, choose an onboarding configuration template to apply to the device.

If there is only one onboarding configuration template for this device type defined, it is chosen by default.

Click Preview next to a selected template to view the template.
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e) (Optional) In the Select a Cabling Scheme drop-down list, choose the stack cabling scheme, if you want to renumber
the stack.

This item appears only for switches that support stacking, and only if they are connected as shown in one of the
following cabling schemes.

Figure 1: Cabling Schemes

f) (Optional) In the Select a Top of Stack serial Number drop-down list, choose the serial number of the top of stack
switch, if you want to renumber the stack.

This item appears only for switches that support stacking, and only if they are connected as shown in the image.

g) (Optional) In the Select a License Level drop-down list, choose the stack license level.

This item appears only for switches that support stacking.

h) If you made any changes, click Save, otherwise, click Cancel to return to the list and configure other devices.

Step 10 If you selected multiple devices to provision, click Assign for the next device in the list and repeat the configuration
steps, until you have done this for all devices.

Step 11 Click Next.

The Provision Templates window appears, where you can specify the values for parameters that were defined in the
template.

Step 12 Click on the name of a device that you want to configure and follow these steps:
a) Specify the values for the parameters that were defined in the template, if the device was assigned a configuration

template.

Enter the values for each parameter in the fields for each device. A red asterisk indicates required fields.

b) If you want to copy the running configuration to the startup configuration on the selected device, check the box
Copy running config to startup config.

c) If you selected multiple devices to provision, click the next device in the list at the left side of the window and enter
the parameter values, until you have done this for all devices.

Step 13 To specify parameter values for all devices in bulk, do the following:
a) Click Export to save the CSV template file.
b) Add the values for each of the parameters to the file and save the file.
c) Click Import.
d) Drag and drop the file to the drag and drop area, or click where it says "click to select" and select the file.
e) Click Import.

Step 14 Click Next.
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The Summary window appears, where you can view details about the devices and their configuration preview status.

Step 15 Check the Day-0 Config column for each device to see if the configuration preview was successful.

If the preview shows an error, you should resolve any issues before claiming the device, to avoid provisioning errors.
You may need to go back to the Provision Templates step and change parameter values, change the template, revisit
the Design area to update network design settings, or resolve any network connectivity issues.

Step 16 You can click the link in the Day-0 Config column to see more information about the device, its configuration, and
any configuration preview errors.

Step 17 Click Claim.

A confirmation dialog box is displayed.

Step 18 Click Yes to claim the devices.

What to do next

To complete the provisioning process, after the device is added to the inventory, go to the Inventory tab,
select the device and click Actions > Provision > Provision Device. Proceed through all the steps and click
Deploy in the Summary step. In the Summary, you can see the remaining network settings that will be
pushed to the device. For more information, see Provisioning Devices, on page 23. This process is required
if you intend to push the network settings that you may have configured in the Design area. During Plug and
Play provisioning, only the device credentials and the Onboarding Configuration are pushed to the device;
no other network settings are pushed until provisioning is completed from Inventory. Additionally, the device
is added to ISE by Cisco DNA Center as a AAA client for RADIUS and TACACS, if these are configured.

Provision a Wireless or Sensor Device
Claiming a device provisions it by assigning a network profile to the device and adding it to the inventory. If
you claim a device that has not yet booted for the first time, you are planning the device so that it is
automatically provisioned when it boots up.

When a device is claimed, some system configuration CLI commands from Cisco DNA Center are pushed
to the device first, before the Onboarding Configuration (Day-0) template that you have defined. If your
Onboarding Configuration template has any of the same CLI commands, these will override the system
configuration, since they are applied last. The CLI commands pushed by the system include the following:

• Device credentials (CLI and SNMP)

• Enable SSH v2 and SCP server

• Disable HTTP and HTTPS servers
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When Device Controllability is enabled for a device (it is enabled by default), the following configurations
are added when the device is added into inventory:

• SNMP, NETCONF, and Cisco TrustSec (CTS) credentials

• IPDT enablement

• Controller certificates

• SNMP trap server definitions

• Syslog server definitions

• Netflow collector definitions

• Wireless network assurance

Note

This procedure explains how to claim a device from the main Plug and Play tab. Alternatively, you can claim
a device from the device details window by clicking Claim.

Before you begin

• Ensure that Cisco network devices to be provisioned have a supported software release and are in a
factory default state. If you are using a network device that was previously configured or is in an unknown
state, see the device clean-up and reset details in the Network Plug and Play Troubleshooting Guide for
Cisco Digital Network Architecture Center.

• Ensure that the devices being provisioned can discover and contact Cisco DNA Center. For more
information, see Controller Discovery Prerequisites, on page 3.

• Define the site within the network hierarchy. See About Network Hierarchy.

• Define the CLI and SNMP credentials for the devices. See About Device Credentials.

• For provisioning a wireless access point device, ensure that the wireless LAN controller that is managing
the wireless access point has been added to the inventory and assigned to the site where the wireless
device is to be assigned. This is not needed for a Mobility Express access point.

• For provisioning a sensor device, ensure that the sensor is reachable through the Cisco DNA Center
enterprise IP address (private/enp9s0). A DHCP option 43 string makes the device reachable in unclaimed
mode in Cisco DNACenter, however, to claim the device, it must be reachable from the interface enp9s0
IP address. In the DHCP server, configure the NTP server (DHCP option 42) and the vendor-specific
DHCP option 43 with ACSII value "5A1D;B2;K4;I172.16.x.x;J80", where 172.16.x.x is the virtual IP
address of Cisco DNA Center associated with the enp9s0 interface.

• Define wireless radio frequency profiles for wireless access point devices, except for Mobility Express
access points. See Create a Wireless Radio Frequency Profile.

• Configure the backhaul settings for wireless sensor devices. See Manage Backhaul Settings.

• ForMobility Express access points, define an IP address pool and a management interface. See Configure
IP Address Pools.

Provision Your Network
17

Provision Your Network
Provision a Wireless or Sensor Device

https://www.cisco.com/c/en/us/td/docs/cloud-systems-management/network-automation-and-management/dna-center/tech_notes/pnp-troubleshooting.html#_Toc6240375
https://www.cisco.com/c/en/us/td/docs/cloud-systems-management/network-automation-and-management/dna-center/tech_notes/pnp-troubleshooting.html#_Toc6240375
b_cisco_dna_center_ug_1_3_3_0_chapter7.pdf#nameddest=unique_44
b_cisco_dna_center_ug_1_3_3_0_chapter7.pdf#nameddest=unique_156
b_cisco_dna_center_ug_1_3_3_0_chapter7.pdf#nameddest=unique_140
b_cisco_dna_center_ug_1_3_3_0_chapter7.pdf#nameddest=unique_141
b_cisco_dna_center_ug_1_3_3_0_chapter7.pdf#nameddest=unique_155
b_cisco_dna_center_ug_1_3_3_0_chapter7.pdf#nameddest=unique_155


Step 1 From the Cisco DNA Center home page, choose Provision > Devices > Plug and Play.
Step 2 View the devices in the table.

You can use the Filter or Find option to find specific devices.

Step 3 Check the check box next to one or more wireless devices that you want to claim.
Step 4 Choose Actions > Claim in the menu bar above the device table.

The Claim Devices window opens, showing the first step, Site Assignment.

Step 5 (Optional) Change the device name, if needed, in the first column.
Step 6 (Optional) Change the device type, if needed, in the second column. You can choose AP (Access Point) or ME (Mobility

Express), depending on which mode the device is using.

Choosing the wrong mode causes an error provisioning the device. This item does not appear for sensor devices.

Step 7 From the Select a Site drop-down list, choose a site and floor to assign to each device. Access point devices must be
assigned to a floor with a wireless controller.

To apply the same site as the first device to all other devices, click the Apply Site to All check box. To assign the site
from any device to some other devices, click Assign this Site to Other Devices, choose the devices, and click Assign.
Wireless devices can be assigned only to floors within a building, not to the building itself.

Step 8 Click Next.
The Configuration window appears.

Step 9 (Optional) You can change which columns are displayed in the table by clicking the 3 dots at the right end of the table
headings and choosing the desired columns. Click Apply to save the changes.

Step 10 Click on the name of the device that you want to configure and follow these steps:
a) View the device configuration summary and click Cancel if no changes are needed.
b) (Optional) In the Device Name field, change the device name, if needed.
c) For an access point device, in the RF Profile drop-down list, choose an RF profile to apply to the device. This may

be set if you designated one profile as a default.
d) For aMobility Express device, enter values in the following fields:Management IP, Subnet Mask, andGateway.
e) For a wireless sensor device, in the Sensor Settings drop-down list, choose the sensor device profile to apply to

the device.
f) If you made any changes, click Save, otherwise, click Cancel to return to the list and configure other devices.
g) You can apply a configuration that you assigned to one device to other devices of the same type by clicking Apply

… to Other Devices in the Actions column.

Step 11 If you selected multiple devices to provision, click the next device in the list and repeat the configuration, until you
have done this for all devices.

Step 12 Click Next.
The Summary window appears, where you can view details about the devices and configuration.

Step 13 Check the Day-0 Config Preview Status column for each device to see if the configuration preview was successful.

If the preview shows an error, you should resolve any issues before claiming the device, to avoid provisioning errors.
You may need to go back to the Configuration step and change the configuration, revisit the Design area to update
network design settings, or resolve any network connectivity issues. Ensure that the wireless LAN controller that is
managing a device has been added to the inventory and assigned to the site where the wireless device is assigned.

Step 14 Click Claim.
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A confirmation dialog box is displayed.
Step 15 Click Yes to claim the devices and start the provisioning process.

What to do next

To complete the provisioning process, after the device is added to the inventory, go to the Inventory tab,
select the device and click Actions > Provision > Provision Device. Proceed through all the steps and click
Deploy in the Summary step. In the Summary, you can see the remaining network settings that will be
pushed to the device. For more information, see Provisioning Devices, on page 23. This process is required
if you intend to push the network settings that you may have configured in the Design area. During Plug and
Play provisioning, only the device credentials and the Onboarding Configuration are pushed to the device;
no other network settings are pushed until provisioning is completed from Inventory. Additionally, the device
is added to ISE by Cisco DNA Center as a AAA client for RADIUS and TACACS, if these are configured.

Delete a Device
Deleting a device removes it from the Plug and Play database but does not reset the device. Use Reset if you
want to reset a device that is in the Error state.

This procedure shows how to delete a device from the Plug and Play tab. Alternatively, you can delete a
device from the device details window by clicking Delete.

If a device is in the Provisioned state, it can be deleted only from the Inventory tab.Note

Step 1 From the Cisco DNA Center home page, choose Provision > Devices > Plug and Play.
Step 2 View the devices in the table.

You can use the Filter option to find specific devices. Click Refresh to refresh the device list.

Step 3 Check the check box next to one or more devices that you want to delete.
Step 4 Click Actions > Delete in the menu bar above the device table.

A confirmation dialog box is displayed.

Step 5 Click Yes to confirm that you want to delete the devices.

Reset a Device
Resetting a device applies only to devices in the Error state and resets its state to Unclaimed and reloads the
device, but does not remove it from the Plug and Play database. Use Delete if you want to delete a device.
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If the saved configuration on the device is the factory default or a similar minimal configuration, then this
option causes the device to restart the provisioning process. However, if the device has a previously saved
startup configuration, then this could prevent the device from restarting the provisioning process and it will
need to be reset to factory defaults. On wireless and sensor devices, only the device state is reset and the device
is not reloaded.

Note

This procedure shows how to reset a device from the Plug and Play tab. Alternatively, you can reset it from
the device details window by clicking Reset.

Step 1 From the Cisco DNA Center home page, choose Provision > Devices > Plug and Play.
Step 2 View the devices in the table.

You can use the Filter option to find specific devices. Click Refresh to refresh the device list.

Step 3 Check the check box next to one or more devices that you want to reset.
Step 4 Click Actions > Reset in the menu bar above the device table.

A confirmation dialog box is displayed.

Step 5 Choose one of the following options:

• Reset and keep current claim parameters—Keep the current claim parameters and the device goes to the Planned
state.

• Reset and remove all claim parameters—Remove the current claim parameters and the device goes to the Unclaimed
state.

Step 6 Click Reset.

Managing Devices in Inventory
The following sections provide information about how to assign devices to sites and manage device tags by
using the Device Inventory window.

For more information about using the Device Inventory page to manage devices, see Manage Your Inventory.

Add a Device to a Site

Step 1 From the Cisco DNA Center home page, click Provision.
The Inventory window displays the device information gathered during the Discovery process.

Step 2 Check the check box for the devices that you want to assign to a site.
Step 3 From the Actions menu, choose Provision > Assign Device to Site.

The Assign Device to Site slide-in pane appears.
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Step 4 In the Assign Device to Site slide-in pane, click the link next to the icon for the device.
The Choose a floor slide-in pane appears.

Step 5 In the Choose a floor slide-in pane, select the floor to assign to the device.
Step 6 Click Save.
Step 7 (Optional) If you selected multiple devices to add to the same location, you can check the Apply to All check box for

the first device to assign its location to the rest of the devices.
Step 8 Click Assign.

Tag Devices
A device tag allows you to group devices based on an attribute or a rule. A single device can have multiple
tags; similarly, a single tag can be applied to multiple devices.

You can add tags to or remove tags from devices in the Provision window.

Step 1 From the Cisco DNACenter home page, click Provision. The Device Inventory page displays device information gathered
during the discovery process.

Step 2 Check the check box next to the device(s) for which you want to apply a tag, and then click Tag Device.
Step 3 Enter a tag name in the Tag Name field.

• If you are creating a new tag, click Create New Tag. You also can create a new tag with a rule. See Tag Devices
Using Rules, on page 21 for more information.

• If you are using an existing tag, select the tag from the list, and then click Apply.

A tag icon and the tag name(s) appear under the device name(s) for which you applied the tag(s).

Step 4 To remove a tag from a device, do one of the following:

• Click Create New Tag, unselect all tags, and then click Apply.

• Hover the cursor over the tag icon or tag name, and then click X to disassociate the tag from the device.

Tag Devices Using Rules
You can group devices based on tags in which you define a rule. When you define a rule, Cisco DNA Center
automatically applies the tag to all devices that match the specified rule. Rules can be based on device name,
device family, device series, IP address, location, or version.

Step 1 From the Cisco DNACenter home page, click Provision. The Device Inventory page displays device information gathered
during the discovery process.

Step 2 Check the check box next to the device(s) for which you want to apply a tag, then click Tag Device.
Step 3 Enter a tag name in the Tag Name field, then click Create New Tag with Rule.

Provision Your Network
21

Provision Your Network
Tag Devices



The Create New Tag window appears.

The Manually Added field under Total Devices Tagged Count indicates the number of devices you selected in Step 2.

Step 4 Click Add Condition, then complete the required fields for the rule.

The Matching Devices number automatically changes to indicate how many devices match this condition.

You can have two options to create additional conditions:

• And conditions—Click the Add Condition link. And appears above the condition.

• Or conditions—Click the add icon (+) next to an existing condition. Or appears next to the condition.

You can add as many conditions as needed. As you make changes to the rule, the Matching Devices count changes to
reflect how many devices in the inventory match the rule you specified. You can click on the device number to view the
devices that match the rule.

Step 5 Click Save to save your tag with the defined rule.

A tag icon and the tag name(s) appear under the device name(s) for which you applied the tag(s).

As devices are added to the inventory, if they match the rules you defined, the tag is automatically applied to the devices.

Edit Device Tags
You can edit device tags that you previously created.

Step 1 From the Cisco DNACenter home page, click Provision. The Device Inventory page displays device information gathered
during the discovery process.

In the Device Name column, you can see any previously created device tags listed under the device names.

Step 2 Without selecting any devices, click Tag Device.

The previously created tags are listed.

Step 3 Hover your cursor over the tag you want to edit, then click the pencil icon next to the tag name.

Altenatively, you can select Tag Device > View All Tags, then click the pencil icon next to the tag you want to edit.

Step 4 Make changes to the tag, then click Save to save your changes.

Delete Tags
You can delete a device tag or template tag only if it is not associated with a device or template.

Before you begin

Remove the tag that is associated statically or dynamically (using rules) with the device.

Remove the tag that is assocated with a template.
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Step 1 From the Cisco DNA Center home page, click Provision.

The Device Inventory page displays device information gathered during the discovery process.

Step 2 Without selecting any devices, click Tag Device > Manage Tags.
Step 3 Hover your cursor over the tag you want to delete, then click the delete icon next to the tag name.
Step 4 Click Yes in the delete tag warning message.

An error message is thrown, if the tag is associated with a device or template. Remove the tag associated with the device
or template and delete the tag.

Provisioning Devices
The following sections provide information about how to provision various Cisco devices.

Provision a Cisco AireOS Controller

Before you begin

• Make sure that you have defined the following global network settings before provisioning a Cisco
Wireless Controller:

• Network servers, such as AAA, DHCP, and DNS.

For more information, see Configure Global Network Servers.

• Device credentials, such as CLI, SNMP, HTTP, and HTTPS.

For more information, see Configure Global CLI Credentials, Configure Global SNMPv2c
Credentials, Configure Global SNMPv3 Credentials, and Configure Global HTTPS Credentials.

• IP address pools.

For more information, see Configure IP Address Pools.

• Wireless settings, such as SSIDs, wireless interfaces, and wireless radio frequency profiles.

For more information, see Configure Global Wireless Settings.

• Make sure that you have CiscoWireless Controller in your inventory. If not, discover wireless controller
using the Discovery feature.

• Make sure that Cisco Wireless Controller is added to a site. For more information, see Add a Device to
a Site, on page 20.

• You cannot reuse any pre-existing VLANs on devices. Provisioning fails if Cisco DNA Center pushes
the same VLAN that already exists on the device.

• You cannot make any configuration changes to the wireless controller that is being managed by the Cisco
DNA Center manually. You must perform all configurations from the Cisco DNA Center GUI.
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Step 1 From the Cisco DNA Center home page, choose Provision.

The Devices > Inventory window appears, with the discovered devices listed.

Step 2 Expand the Global site in the left pane, and select the site, building, or floor that you are interested in.

The available devices in the selected site is displayed in the Inventory window.

Step 3 From the DEVICE TYPE list, click the WLCs tab, and from the Reachability list, click the Reachable tab to get the
list of wireless controllers that are discovered and reachable.

Step 4 Check the check box next to the device name that you want to provision.
Step 5 From the Actions drop-down list, choose Provision > Provision Device.

The Assign Site window appears.

Step 6 Click Choose a site to assign a site for the wireless controller.
Step 7 In the Add Sites window, check the check box adjacent the site name to associate the wireless controller, and click

Save.
Step 8 Click Apply.
Step 9 Click Next.

The Configuration window appears.

Step 10 Select a role for the wireless controller: Active Main WLC or Guest Anchor WLC.
Step 11 Click Select Primary Managed AP Locations to select the managed AP location for the wireless controller.
Step 12 In the Managed AP Location window, check the check box adjacent the site name. You can either select a parent site

or the individual sites. If you select a parent site, the children under that parent site automatically gets selected.

Inheritance of managed AP locations allows you to automatically choose a site along with the buildings and
floors under that site. One wireless controller can manage only one site.

Note

Step 13 Click Save.
Step 14 Under Interface and VLAN Configuration, click + Add and configure the interface and VLAN details for an active

main wireless controller.

Interface and VLAN configuration is applicable for nonfabric wireless controller provisioning only.

The Configure Interface and VLAN window appears.

Step 15 From the Interface Name drop-down list, choose the interface name.
Step 16 In the VLAN ID field, enter a value for the VLAN.
Step 17 In the Interface IP Address field, enter a value for the interface IP address.
Step 18 In the Interface Net Mask (in bits) field, enter the subnet mask for the interface.
Step 19 In the Gateway IP Address field, enter the gateway IP address.
Step 20 From the LAG/Port Number drop-down list, choose the link aggregation or the port number.
Step 21 Click OK.
Step 22 For a guest anchor wireless controller, you can change the VLAN ID configuration by changing the VLAN ID under

Assign Guest SSIDs to DMZ site.
Step 23 Under Mobility Group, click Configure to configure wireless controller as the mobility peer.

For more information, see Mobility Configuration Overview, on page 48.
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The Configure Mobility Group side panel appears.

Step 24 From the Mobility Group Name drop-down list, you can either add a new mobility group by clicking , or choose
a mobility group from the existing mobility groups.

The existing mobility peers information is loaded from the intent available in the Cisco DNA Center.

Step 25 In the RF Group Name text box, enter a name for the RF group.

Step 26 Under Mobility Peers, click Add to configure wireless controller as a mobility peer.
Step 27 From the Device Name drop-down list, choose the controller.

After the device is provisioned, the Cisco DNA Center creates a mobility group in device, assigns the RF group, and
configures all ends of peers. The mobility group configuration is deployed automatically to all the selected peer devices.

Step 28 Click Save.
Step 29 To reset the mobility group name and the RF group name, you can do one of the following:

• In the Configure Mobility Group side panel, choose default from the Mobility Group Name drop-down list.

• On the Provision > Configuration page, under Mobility Group, click Reset.

This automatically sets the RF Group Name to default and removes all peers. Once you provision, the mobility on
the device is set and the device is removed from all other peers.

Step 30 Click Next.

The Advanced Configuration window appears, where you can enter values for predefined template variables.

Step 31 Search for the device or the template in the Devices panel.
Step 32 Enter a value for the predefined template variable in the wlanid field.
Step 33 Click Next.

The Summary window displays the following information:

• Device Details

• Network Settings

• SSID

• Managed Sites

• Interfaces

• Advanced Configuration

• Mobility Group Configuration

Step 34 Click Deploy to provision the controller.

• To immediately deploy the device, click the Now radio button, and click Apply.

• To schedule the device deployment for a later date and time, click the Later radio button and define the date and
time of the deployment.

Step 35 Provision the secondary controller.
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For more information, see Configure N+1 High Availability from Cisco DNA Center, on page 46.

Step 36 The Status column in the Device Inventory window shows SUCCESS after a successful deployment.

After provisioning, if you want to make any changes, click Design, change the site profile, and provision the wireless
controller again.

Step 37 After the devices are deployed successfully, the Provision Status changes from Configuring to Success.
Step 38 In the Device Inventory window, click See Details in the Provision Status column to get more information about the

network intent or to view a list of actions that you need to further take.
Step 39 Click See Details under Device Provisioning.
Step 40 Click View Details under Deployment of network intent, and click the device name.
Step 41 Expand theConfiguration Summary area to view the operation details, feature name, and the management capability.

The configuration summary also displays any error that occurred while provisioning the device.

Step 42 Expand the Provision Summary area to view details of the exact configuration that is sent to the device.

Configure Cisco WLC High Availability from Cisco DNA Center
Cisco Wireless Controller High Availability (HA) can be configured through Cisco DNA Center. Currently,
the formation of wireless controller HA is supported; the breaking of HA and switchover options is not
supported.

Prerequisites for Configuring Cisco Wireless Controller High Availability

• The discovery and inventory features of wireless controller 1 and wireless controller 2 must be successful.
The devices must be in Managed state.

• The service ports and the management ports of wireless controller 1 and wireless controller 2 must be
configured.

• The redundancy ports of wireless controller 1 and wireless controller 2 must be physically connected.

• The management address of wireless controller 1 and wireless controller 2 must be in the same subnet.
The redundancy management address of wireless controller 1 and wireless controller 2 must also be in
the same subnet.

• Manually configure the following boot variables on the wireless controller:
config t
boot system bootflash::<device_iosxe_image_filename>
config-register 0x2102

show boot. (IOSXE cli)

BOOT variable = bootflash:<device_iosxe_image_filename>,12;
Configuration register is 0x2102

Configure Cisco Wireless Controller HA

Step 1 From the Cisco DNA Center home page, choose Provision > Devices.

The Devices > Inventory window appears, with the discovered devices listed.
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Step 2 Check the check box adjacent the controller name that you want to configure as the primary controller.
Step 3 From the Actions drop-down list, choose Provision > Configure WLC HA.

The High Availability page appears.

Step 4 Enter the Redundancy Management IP and the Peer Redundancy Management IP address in the respective text
boxes.

The IP addresses used for redundancy management IP and peer redundancy management IP should be configured in the
same subnet as the management interface of the Cisco Wireless Controller. Ensure that these IP addresses are unused IP
addresses within that subnet range.

Step 5 From the Select Secondary WLC drop-down list, choose the secondary controller.
Step 6 Click Configure HA.

The HA configuration is initiated in the background using the CLI commands. First, the primary wireless controller is
configured. On success, the secondary wireless controller is configured. After the configuration is complete, both wireless
controllers reboot. This process may take up to 2.5 minutes to complete.

Step 7 To verify the HA configuration, on the Devices > Inventory page, click the device that you configured as a HA device.
Step 8 Click the Wireless Info tab.

The Redundancy Summary displays the Sync Status as In Progress. When Cisco DNA Center finds that HA pairing
succeeded, the Sync Status changes to Complete.

This is triggered by the inventory poller or by manual resynchronization. By now, the secondary wireless controller
(wireless controller 2) is deleted from Cisco DNACenter. This flow indicates successful HA configuration on the wireless
controller.

What Happens During or After the High Availability Process is Complete

1. Cisco wireless controller 1 and wireless controller 2 are configured with redundancy management,
redundancy units, and SSO. The wireless controllers reboot in order to negotiate their role as active or
stand by. Configuration is synced from active to stand by.

2. On the Show Redundancy Summary window, you can see these configurations:

• SSO is Enabled

• Wireless Controller is in Active state

• Wireless Controller is in Hot Stand By state

3. Themanagement port of the active wireless controller is shared by both the controllers and will be pointing
to active controller. The user interface, Telnet, and SSH on the stand by wireless controller will not work.
You can use the console and service port interface to control the stand by wireless controller.

Commands to Configure and Verify High Availability

Cisco DNA Center sends the following commands to configure Cisco Wireless Controller HA.

Cisco DNA Center sends the following commands to wireless controller 1:

• config interface address redundancy-management 198.51.100.xx peer-redundancy-management
198.51.100.yy
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• config redundancy unit primary

• config redundancy mode sso

Cisco DNA Center sends the following commands to wireless controller 2:

• config interface address redundancy-management 198.51.100.yy peer-redundancy-management
198.51.100.xx

• config redundancy unit secondary

• config port adminmode all enable

• config redundancy mode sso

Enter the following commands to verify the HA configuration from the wireless controller:

• To check HA-related details: config redundancy mode sso

• To check the configured interfaces: show redundancy summary

Provision Routing and NFV Profiles

Before you begin

Make sure that you have defined the following global network settings before provisioning Routing and NFV
profiles:

• Network servers, such as AAA, DHCP, and DNS. For more information, see Configure Global Network
Servers.

• Device credentials, such as CLI, SNMP, HTTP, and HTTPS. For more information, see Configure Global
CLI Credentials, Configure Global SNMPv2c Credentials, Configure Global SNMPv3 Credentials, and
Configure Global HTTPS Credentials.

• IP address pools. For more information, see Configure IP Address Pools.

• SP profiles. For more information, see Configure Service Provider Profiles.

When provisioning Cisco Firepower Threat Defense Virtual through the NFV provisioning flow, the default
credential username is retained and the password is updated based on the settings in the credential profile
assigned to the site in Network Settings.

Note

Step 1 From the Cisco DNA Center home page, choose Provision.

The Device > Inventory window appears, and all the discovered devices are listed in this window.

Step 2 To view devices available in a particular site, expand the Global site in the left pane, and select the site, building, or floor
that you are interested in.

All the devices available in that selected site is displayed in the Inventory window.
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Step 3 From the Device Type list, click the Routers tab, and from the Reachability list, click the Reachable tab to get the list
of devices that are discovered and reachable.

Step 4 Check the check box next to the device name that you want to provision.
Step 5 Click Assign under the site and Assign Device to Site window appears. Click Choose a Site to assign a site.
Step 6 From the Actions drop-down list, choose Provision > Provision Device.

To provision a NFVIS device, do the following:

• Review the details in the Confirm Profile window, and click Next.

• Review the details in the Router WAN Configuration window. Click on O and enter the WAN IP address. Review
the details in the +Edit Services window. Click Next.

You have to configure vManage settings in system setting page, before provisioning vEDGE related
service. For more information see the section Configure vManage Properties in Cisco Digital Network
Architecture Center Administrator Guide.

Note

• Review the details in the ENCS Integrated Switch Configuration window, and click Next.

• Review the details in the Custom Configuration window, and click Next.

• Review the details in the Summary page.

To provision a router, do the following:

• Review the details in the Confirm Profile window, and click Next.

• Review the details in the Router WAN Configuration window.

• If you have selected Gigabit ethernet as the line interface, click O and enter the WAN IP address if you select
static IP address. If you select DHCP, enter IP address from the DHCP server. If the primary WAN is already
configured using PnP, you can selectDo not Change and select the interface which is configured as the primary
WAN from the dropdown list.

• If you have selected cellular as the line interface, clickO, choose IP Negotiated and select the Interface Name
from the drop down list and enter the Access Point Name (APN). Check the check box next to PAP or CHAP
depending on your service provider.

• Enter IP SLA Address for the backup WAN interface when you have multiple service providers.

This window will not appear if you are provisioning a virtual router.

• Review the details in the Router LAN Configuration window, and click Next.

You can now select one L3 interface or one or multiple L2 interfaces from Interface(s) drop down list.

• Review the details in the Integrated Switch Configuration window, and click Next.

• Review the details in the Summary page.

Step 7 Click Deploy to provision the device.

The Provision Status column in the Device Inventory window shows SUCCESS after a successful deployment.
Click SUCCESS to see detailed Provisional log status.
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VPC Inventory Collection
After successful cloud inventory collection, the Cloud tab in the Provision section provides a view of the
collected AWS VPC Inventory. The navigation on the left can be expanded to show the cloud regions for a
cloud profile or access key. You can filter the left navigation items by keyword and click to see the VPCs just
for the selected region or access key.

In the VPC Inventory view you can also click on a VPC to see more details about it, like the subnets and
virtual instances in that VPC and some more details about them. AWS VPC inventory collection is scheduled
to occur at the default interval for all inventory collection and can also be triggered on demand by using the
Sync action from the gear menu for a cloud access key. The status of the inventory collection can be viewed
by clicking on Show Sync Status in the VPC Inventory view.

Provision a Cisco AP—Day 1 AP Provisioning

Before you begin

Make sure that you have Cisco AP in your inventory. If you do not, discover APs using the Discovery feature.
For more information, see Discover Your Network.

Step 1 From the Cisco DNA Center home page, choose Provision.

The Devices > Inventory window appears, and all the discovered devices are listed in this window.

Step 2 To view devices available in a particular site, expand the Global site in the left pane, and select the site, building, or
floor that you are interested in.

All the devices available in that selected site is displayed in the Inventory window.

Step 3 From the Device Type list, click the APs tab, and from the Reachability list, click the Reachable tab to get the list of
APs that are discovered and reachable.

Step 4 Check the check box adjacent the AP device name that you want to provision.
Step 5 From the Action drop-down list, choose Provision > Provision.

The Assign Site window appears.

Step 6 Click Choose a floor, and assign an AP to the site.
Step 7 In the Choose a floor window, select the floor to which you want to associate the AP, and click Save.
Step 8 Click Next.

The Configuration window appears.

Step 9 By default, the custom RF profile that you marked as default underDesign >Network Settings >Wireless >Wireless
Radio Frequency Profile is chosen in the RF Profile drop-down list.

You can change the default RF Profile value for an AP by selecting a value from the RF Profile drop-down list. The
options are: High, Typical, and Low.

The AP group is created based on the selected RF profile.

Step 10 Click Next.
Step 11 In the Summary window, review the device details, and click Deploy to provision the AP.
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• To deploy the AP immediately, click the Now radio button, and click Apply.

• To schedule the AP deployment for a later date and time, click the Later radio button and define the date and time
of the deployment.

Step 12 You are prompted with a message that creation or modification of an AP group in progress.

You are prompted with a message stating After provisioning AP(s) will reboot. Do you want
to continue?.

Step 13 Click OK.

The Last Sync Status column in the Inventory window shows SUCCESS if the deployment is successful.

Day 0 Workflow for Cisco AireOS Mobility Express APs

Before you begin

The Cisco Mobility Express wireless network solution comprises of at least one 802.11ac Wave 2 Cisco
Aironet Series access point with an in-built software-based wireless controller managing other APs in the
network. The AP acting as the wireless controller is referred to as the primary AP, while the other APs in the
Cisco Mobility Express network, which are managed by this primary AP, are referred to as subordinate APs.

• Design your network hierarchy, with sites, buildings, floors, and so on. For more information, see Create
a Site in a Network Hierarchy, Add Buildings, and Add a Floor to a Building.

• Define the device credentials, such as CLI, SNMP, HTTP, and HTTPS at the global level. The credentials
that are defined at the global level are inherited by the sites. For more information, see Configure Global
CLI Credentials, Configure Global SNMPv2c Credentials, and Configure Global SNMPv3 Credentials.

• Create WLANs, interfaces, RF profiles.

• Configure the DHCP server with Option #43 or Option #60. This is IP address of the Cisco DNA Center
Plug and Play server. Using this, the APs contact the PnP server and downloads the configuration.

• Make sure that you have Mobility Express APs in the inventory. If not, discover using the Discovery
feature. For more information, see Discover Your Network Using CDP, Discover Your Network Using
an IP Address Range, and About Inventory.

• The APs should be in the factory reset state without any Cisco Wireless Controller configurations.

Step 1 The Cisco Mobility Express contacts the DHCP server and connects to the Cisco DNA Center Plug and Play server.
Step 2 The DHCP server allocates the IP address with Option #43. Option #43 is the IP address of the Cisco DNA Center Plug

and Play server.
Step 3 The Mobility Express AP starts the PnP agent and contacts the PnP server.

If you have a set of Mobility Express APs in the network, they go through an internal protocol. The protocol
selects one Mobility Express AP, which will be configured on the Cisco Wireless Controller as the primary
AP to reach the PnP server.

Note
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Step 4 Find the unclaimed AP in the Provision > Devices > Plug and Play tab.

The table lists all the unclaimed devices. The State column shows asUnclaimed. Use the Filter or Find option to find
specific devices.

You must wait for the Onboarding Status to become Initialized.

Step 5 To claim the AP, check the check box adjacent the AP device name.
Step 6 Choose Actions > Claim in the menu bar above the device table.

The Claim Devices window appears.

Step 7 In the Site Assignment window, choose a site from the Site drop-down list.

Claiming the selected AP to this particular site also applies the associated configurations.

Step 8 Click Next.
Step 9 To configure a device, click the device name in the Configuration window.
Step 10 In the Configuration for device name page, assign the static IP details for the device:

• Management IP

• Subnet Mask

• Gateway

Step 11 Click Save.
Step 12 Click Next.

The Summary page appears.

Step 13 Click Claim in the Summary page.

Once the Mobility Express AP is claimed, the IP address configured is assigned to the Mobility Express AP.

Step 14 The claimed device, which is an AP and the wireless controller is now available under Provision >Device Inventory >
Inventory window.

Step 15 You can also add devices in bulk from a CSV file.

For more information, see Add Devices in Bulk, on page 9.

When you bulk import Mobility Express APs through CSV, all the Mobility Express APs appear on Devices > Plug
and Play page. Based on the VRRP protocol, only one Mobility Express AP among the imported ME APs becomes
the primary AP, which come up for claim and the rest of them become subordinate APs. After claiming the primary
AP, you need not claim the subordinate APs. Cisco DNA Center does not clear the subordinate APs from the Plug and
Play page. You must delete those subordinate APs manually from the Devices > Plug and Play page.

Step 16 To provision the Cisco Wireless Controller, see Provision a Cisco AireOS Controller, on page 23.
Step 17 To provision the AP, see Provision a Cisco AP—Day 1 AP Provisioning, on page 30.
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Brownfield Support for Cisco AireOS Controllers

Before you begin

Brownfield support is available for Cisco AireOSWireless Controller devices and not for Cisco Catalyst 9800
Series Wireless Controller devices.

Note

This procedure shows how to provision a brownfield Cisco AireOS Controller with the Cisco DNA Center.

• Start by running a Discovery job on the device. All your devices are displayed on the Inventorywindow.
For more information, see Discover Your Network and About Inventory.

• The wireless controller should be reachable and in Managed state on the Inventory window. For more
information, see About Inventory.

Step 1 From the Cisco DNA Center home page, choose Provision.

The Device > Inventory window appears, which lists the discovered devices available in the network.

Step 2 Click Filter and enter the appropriate values in the selected filter field. For example, for the Device Name filter, enter
the name of the device.

The data that is displayed in the Devices table is automatically updated according to your filter selection.

Step 3 Check the check box adjacent the wireless controller device name that you want to provision.
Step 4 From the Action drop-down list, choose Provision > Learn Device Config.

The Assign Site window appears.

Step 5 Click Choose a site to assign a site for the controller.
Step 6 In the Choose a site window, select a site to which you want to associate the wireless controller, and click Save.
Step 7 Click Next.
Step 8 The Resolve Conflict window shows any conflicting configurations in Cisco DNA Center that you need to resolve.
Step 9 Click Next.

The Design Object window lists all the learned configurations.

Step 10 Click Network in the left pane.

The right pane displays network configurations that were learned as part of device configuration learning, and shows
the following information:

• AAA Server details.

• Systems Settings, with details about the IP address and protocol of the AAA server.

• DHCP Server details.

Step 11 Enter the Shared Secret for the AAA server.
Step 12 Click Wireless in the left pane.
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The right pane lists the enterprise SSIDs, guest SSIDs, and wireless interface details.

Step 13 For an SSID with a preshared key (PSK), enter the passphrase key.
Step 14 Click Discarded Config in the left pane.

The right pane lists the conflicting or the existing configurations on Cisco DNA Center. The discarded configuration
entries are categorized as:

• Duplicate design entity

• Unknown device configuration for Radio Policy

Step 15 Click Next.

The Network Profile window lists the network profile or site profile that is created based on the AP and WLAN
combination.

Step 16 Click Save.

A message saying Brownfield Configuration is Successful is displayed.

Step 17 Choose Design > Network Profiles to assign a site to the network profile.
Step 18 In the Network Profiles window, click Assign Site to add sites to the selected profile.
Step 19 In the Add Sites to Profile window, choose a site from the drop-down list, and click Save.
Step 20 Click the Provision tab.
Step 21 Click Filter and enter the appropriate values in the selected filter field.

The data that is displayed in the Devices table is automatically updated according to your filter selection.

Step 22 Check the check box adjacent to the controller device name that you want to provision.
Step 23 From the Action drop-down list, choose Provision.
Step 24 Review the details in the Assign Site window, and click Next.

The Configurations window appears.

Step 25 Under Interface and VLAN Configuration, click +Add to configure interface and VLAN details.
Step 26 In the Configure Interface and VLAN window, configure the required fields, and click OK.
Step 27 Click Next.
Step 28 The Summary window displays the following information:

• Device Details

• Network Settings

• SSID

• Managed Sites

• Interfaces

Step 29 Click Deploy to provision the device.
The Provision Status column in the Device Inventory window shows SUCCESS after a successful deployment.
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Configure and Provision a Cisco Catalyst 9800 Series Wireless Controller

Cisco Catalyst 9800 Series Wireless Controller Overview
The Cisco Catalyst 9800 Series Wireless Controller is the next generation of wireless controllers built for
intent-based networking. The Cisco Catalyst 9800 Series Wireless Controller is Cisco IOS XE based and
integrates the RF excellence from Aironet with the intent-based networking capabilities of Cisco IOS XE to
create the best-in-class wireless experience for your organization.

The Cisco Catalyst 9800 Series Wireless Controller is built on a modular operating system and uses open,
programmable APIs that enable automation of day-0 and day-N network operations.

The Cisco Catalyst 9800 Series Wireless Controller is available in multiple form factors:

• Catalyst 9800-40 Wireless Controller

• Catalyst 9800-80 Wireless Controller

• Catalyst 9800-CL Cloud Wireless Controller: Deployable on private cloud (ESXi, KVM, Cisco ENCS,
and Hyper-V) and manageable by Cisco DNA Center

• Catalyst 9800 Embedded Wireless Controller for Catalyst 9300 Series Switches, Catalyst 9400 Series
Switches, and Catalyst 9500H Series Switches

• Cisco Catalyst 9800-L Wireless Controller: Provides seamless software updates for small- to mid-size
enterprises. The Cisco Catalyst 9800-LWireless Controller is available in two variations. You can choose
between copper and fiber uplinks, which gives you flexibility in your network.

The following table lists the supported virtual and hardware platforms for the Cisco Catalyst 9800 Series
Wireless Controller:

DescriptionPlatform

Supports up to 6000 access points and 64,000 clients.

Supports up to 80 Gbps throughput and occupies a 2 - rack unit space.

Modular wireless controller with up to 100-GE uplinks and seamless
software updates.

Cisco Catalyst 9800-80 Wireless Controller

A fixed wireless controller with seamless software updates for mid-sized
organizations and campus deployments.

Supports up to 2000 access points and 32,000 clients.

Supports up to 40 Gbps throughput and occupies a 1- rack unit space.

Provides four 1-GE or 10-GE uplink ports.

Cisco Catalyst 9800-40 Wireless Controller
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DescriptionPlatform

Cisco Catalyst 9800-CL Cloud Wireless Controller can be deployed in a
private cloud or a public cloud as Infrastructure as a Service (IaaS).

Cisco Catalyst 9800-CL Cloud Wireless Controller is the next generation
of enterprise-class virtual wireless controllers built for high availability
and security.

A virtual form factor of Cisco Catalyst 9800-CLCloudWireless Controller
for private cloud supports ESXi, KVM, Cisco ENCS, and Hyper-V
hypervisors.

Cisco Catalyst 9800-CL Cloud Wireless Controller

Cisco Catalyst 9800 Embedded Wireless Controller for Catalyst 9000
Series Switches bring the wired and wireless infrastructure together with
consistent policy and management.

This deployment model supports only Cisco SD-Access, which is a highly
secure solution for small campuses and distributed branches. The embedded
controller supports access points (APs) only in Fabric mode.

Cisco Catalyst 9800 Embedded Wireless Controller for
Catalyst 9000 Series Switches

Cisco Catalyst 9800-L Wireless Controller provides seamless software
updates for small to mid-size enterprises. The Cisco Catalyst 9800-L
Wireless Controller is available in two variations. You can choose between
copper and fiber uplinks, which gives you flexibility in your network.

• Cisco Catalyst 9800-L Copper SeriesWireless Controller (9800-L-C
RJ45)

• Cisco Catalyst 9800-L Fiber Series Wireless Controller 9800-L-F
SFP)

Cisco Catalyst 9800-L Wireless Controller

The following table lists the host environments supported by the Cisco Catalyst 9800 SeriesWireless Controller:

Software VersionHost Environment

• VMware ESXi vSphere 6.0

• VMware ESXi vSphere 6.51

• VMware ESXi vCenter 6.0

• VMware ESXi VCenter 6.5

VMware ESXi

• Linux KVM based on Red Hat Enterprise Linux 7.1 and 7.2

• Ubuntu 14.04.5 LTS, Ubuntu 16.04.5 LTS

KVM

Cisco ENCS 3.8.1 and 3.9.1NFVIS

1 Installing the .ova file of C9800-CL using ESXi vSphere does not work. This is not limited to the C9800 ova but affects other
products. Cisco and VMware are actively working to fix the issue. Contact your Cisco account representative to see if the
problem is fixed. There are issues specific to VMware 6.5 and C9800-CL OVA file deployment in which deployment fails with
the warning "A required disk image was missing" and the error "Failed to deploy VM: postNFCData failed: Cannot POST to
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non-disk files.” To install C9800-CL on VMware ESXi 6.5, do one of the following: 1) Install the .iso file of C9800-CL using
the ESXi embedded GUI (ESXI 6.5 client version 1.29.0 is tested and required). 2) Install the .ova file of C9800-CL using the
OVF tool.

The following table lists the Cisco Enterprise Network Function Virtualization Infrastructure Software (NFVIS)
versions supported in Cisco DNA Center:

Cisco Enterprise NFVIS devices support the N-1 to N upgrade path only. For example, upgrade from Cisco
Enterprise NFVIS 3.10.x to Cisco Enterprise NFVIS 3.11.x only is supported. Upgrade from Cisco Enterprise
NFVIS 3.10.x to Cisco Enterprise NFVIS 3.12.x is not supported.

Note

NotesEnterprise Network Compute System
(ENCS) Device Platform

Cisco Enterprise NFVIS Version

Cisco Enterprise NFVIS 3.12.1 is not supported on
any versions of Cisco DNA Center.

• Cisco Enterprise NFVIS 3.12.1 is not supported
on any versions of Cisco DNA Center because
the fix for caveat CSCvq66963 is not available
in Cisco Enterprise NFVIS 3.12.1.

• Upgrade to Cisco Enterprise NFVIS 3.12.1 from
Cisco Enterprise NFVIS 3.11.x using CiscoDNA
Center 1.3.3 is not supported.

• Upgrade to Cisco Enterprise NFVIS 3.12.2 from
Cisco Enterprise NFVIS 3.12.1 using CiscoDNA
Center 1.3.3 is not supported.

Cisco Enterprise NFVIS 3.12.2 is supported on Cisco
DNA Center 1.3.3.

• Upgrade to Cisco Enterprise NFVIS 3.12.2 from
3.11.2 is supported using Cisco DNA Center
1.3.3.

• Cisco Enterprise NFVIS 3.12.2 is supported on
Cisco DNA Center 1.3.3.

• ENCS 5400

• UCS-E

• UCS-C

• 3.10.1

• 3.10.2

• 3.10.3

• 3.11.1

• 3.11.2

• 3.11.3

• 3.12.2

Cisco 5100 Enterprise Network Compute System
(ENCS) does not support Cisco Enterprise NFVIS
3.10.x.

ENCS 5100• 3.11.1

• 3.11.2

• 3.11.3

• 3.12.2

Workflow to Configure a Cisco Catalyst 9800 Series Wireless Controller in Cisco DNA Center
1. Install Cisco DNA Center.
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For more information, see the Cisco Digital Network Architecture Center Installation Guide.

2. For information on software image upgrade, see Software Image Upgrade Support for Cisco Catalyst
9800 Series Wireless Controller, on page 40.

3. Log in to the Cisco DNACenter GUI and verify that the applications you need are in theRunning state.

To verify, from the Cisco DNA Center home page, click the gear icon , and then choose System
Settings > Software Updates > Installed Apps.

4. Integrate Cisco Identity Services Engine with Cisco DNA Center. After integration, any devices that
Cisco DNA Center discovers along with relevant configurations and data are pushed to Cisco ISE.

5. Discover the Cisco Catalyst 9800 Series Wireless Controller.

You must enable NETCONF and set the port to 830 to discover the Cisco Catalyst 9800 Series Wireless
Controller. NETCONF provides a mechanism to install, manipulate, and delete configurations of network
devices.

For more information, see Discover Your Network Using CDP or Discover Your Network Using an IP
Address Range.

You must add the wireless management IP address manually.

While performing discovery using the Cisco Discovery Protocol (CDP) or an IP address range in the
Discovery window, choose Use Loopback from the Preferred Management IP drop-down list to
specify the device's loopback interface IP address.

6. Make sure that the discovered devices appear in the Device Inventory page and are in Managed state.

For more information, see About Inventory and Display Information About Your Inventory.

You must wait for the devices to move to a Managed state.

7. To verify the assurance connection with the Cisco Catalyst 9800 Series Wireless Controller, use the
following commands:

• #show crypto pki trustpoints | sec DNAC-CA

Trustpoint DNAC-CA
Subject Name:
cn=kube-ca

Serial Number (hex): 00E***************
Certificate configured.

• #show crypto pki trustpoints | sec sdn-network

Trustpoint sdn-network-infra-iwan:
Subject Name:
cn=sdn-network-infra-ca

Serial Number (hex): 378***************
Certificate configured.

• #show telemetry ietf subscription all

Telemetry subscription brief

ID Type State Filter type
-----------------------------------------------------
1011 Configured Valid tdl-uri
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1012 Configured Valid tdl-uri
1013 Configured Valid tdl-uri

• #show telemetry internal connection

Telemetry connection

Address Port Transport State Profile
---------------------------------------------------------
IP address 25103 tls-native Active sdn-network-infra-iwan

• #show network-assurance summary

Network-Assurance : True
Server Url : https://10.***.***.***
ICap Server Port Number : 3***
Sensor Backhaul SSID :
Authentication : Unknown

8. Configure a TACACS server while configuring authentication and policy servers.

Configuring TACACS is not mandatory if you have configured the username locally on the Cisco
Catalyst 9800 Series Wireless Controller.

9. Design your network hierarchy by adding sites, buildings, and floors so that later you can easily identify
where to apply design settings or configurations.

You can either create a new network hierarchy, or if you have an existing network hierarchy on Cisco
Prime Infrastructure, you can import it into Cisco DNA Center.

To import and upload an existing network hierarchy, see Upload an Existing Site Hierarchy.

To create a new network hierarchy, see Create a Site in a Network Hierarchy, Add Buildings, and Add
a Floor to a Building.

10. Add the location information of APs, and position them on the floor map to visualize the heatmap
coverage.

For more information, see Add, Position, and Delete APs.

11. Define network settings, such as AAA (Cisco ISE is configured for Network and Client Endpoint),
Netflow Collector, NTP, DHCP, DNS, syslog, and SNMP traps. These network servers become the
default for your entire network. You can add a TACACS server while adding a AAA server.

For more information, see About Global Network Settings, Configure Global Network Servers, and
Add AAA server.

12. Create a wireless radio frequency profile with the parent profile as custom.

For more information, see Create a Wireless Radio Frequency Profile.

13. Create IP address pools at the global level.

Cisco DNA Center uses IP address pools to automate the configuration and deployment of SD-Access
networks.

To create an IP address pool, see Configure IP Address Pools.

You must reserve an IP address pool for the building that you are provisioning. For more information,
see Provision a LAN Underlay.

14. Create enterprise and guest wireless networks. Define the global wireless settings once; Cisco DNA
Center then pushes the configurations to various devices across geographical locations.
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Designing a wireless network is a two-step process. First, you must create SSIDs, and then associate
the created SSID to a wireless network profile. This profile helps you to construct a topology, which is
used to deploy devices on a site.

For more information, see Create SSIDs for an Enterprise Wireless Network and Create SSIDs for a
Guest Wireless Network.

15. Configure the backhaul settings. For more information, see Manage Backhaul Settings.

16. Configure the following in the Policy window for the Cisco Catalyst 9800 Series Wireless Controller:

• Create a virtual network. The virtual network segments your physical network into multiple logical
networks. For more information, see Virtual Networks and Create a Virtual Network.

• Create a group-based access control policy and add a contract. For more information, see Create
Group-Based Access Control Policy.

17. Configure high availability.

For more information, see Configure High Availability for the Cisco Catalyst 9800 Series Wireless
Controller, on page 41.

18. Provision the Cisco Catalyst 9800 Series Wireless Controller with the configurations added during the
design phase.

For more information, see Provision a Cisco Catalyst 9800 Series Wireless Controller, on page 52.

19. Configure and deploy application policies on the Cisco Catalyst 9800 Series Wireless Controller.

For more information, see Create an Application Policy, Deploy an Application Policy, and Edit an
Application Policy.

You must provision Cisco Catalyst 9800 Series Wireless Controller devices before deploying an application
policy.

Note

For Cisco Catalyst 9800 SeriesWireless Controller devices, two different policies with different business
relevance for two different SSIDs do not work. The last deployed policy always takes precedence when
you are setting up relevance.

For Cisco Catalyst 9800 Series Wireless Controller devices, changing the default business relevance
for an application does not work in FlexConnect mode.

You can apply an application policy only on a nonfabric SSID.

Software Image Upgrade Support for Cisco Catalyst 9800 Series Wireless Controller

Before you begin

• Discover the Cisco Catalyst 9800 Series Wireless Controller.

Enable NETCONF and set the port to 830 to discover Cisco Catalyst 9800 Series Wireless Controller.
NETCONF enables wireless services on the controller and provides a mechanism to install, manipulate,
and delete the configuration of network devices.

Provision Your Network
40

Provision Your Network
Software Image Upgrade Support for Cisco Catalyst 9800 Series Wireless Controller

b_cisco_dna_center_ug_1_3_3_0_chapter7.pdf#nameddest=unique_135
b_cisco_dna_center_ug_1_3_3_0_chapter7.pdf#nameddest=unique_137
b_cisco_dna_center_ug_1_3_3_0_chapter7.pdf#nameddest=unique_137
b_cisco_dna_center_ug_1_3_3_0_chapter7.pdf#nameddest=unique_141
b_cisco_dna_center_ug_1_3_3_0_chapter12.pdf#nameddest=unique_265
b_cisco_dna_center_ug_1_3_3_0_chapter12.pdf#nameddest=unique_268
b_cisco_dna_center_ug_1_3_3_0_chapter12.pdf#nameddest=unique_203
b_cisco_dna_center_ug_1_3_3_0_chapter12.pdf#nameddest=unique_203
b_cisco_dna_center_ug_1_3_3_0_chapter12.pdf#nameddest=unique_233
b_cisco_dna_center_ug_1_3_3_0_chapter12.pdf#nameddest=unique_243
b_cisco_dna_center_ug_1_3_3_0_chapter12.pdf#nameddest=unique_240
b_cisco_dna_center_ug_1_3_3_0_chapter12.pdf#nameddest=unique_240


For more information, see Discover Your Network Using CDP, or Discover Your Network Using an IP
Address Range.

• Make sure that the devices appear in the device inventory and are in the Managed state.

For more information, see About Inventory and Display Information About Your Inventory.

Step 1 From Cisco DNA Center home page, chooseDesign > Image Repository, or click Image Repository in the Cisco DNA
Center home page.

Step 2 Import Cisco Catalyst 9800 Series Wireless Controller software image from your local computer or from a URL.

For more information, see Import a Software Image.

Step 3 Assign the software image to a device family.

For more information, see Assign a Software Image to a Device Family.

Step 4 You can mark a software image as golden by clicking star for a device family or for a particular device role.

For more information, see Specify a Golden Software Image.

Step 5 To provision the software image, click Provision in the Cisco DNA Center home page.

The Devices > Inventory window appears.

Step 6 In the Inventory window, check the check box adjacent the Cisco Catalyst 9800 Series Wireless Controller whose image
you want to upgrade.

Step 7 From the Actions drop-down, choose Software Image > Update Image.

For more information, see the Provision a Software Image.

Configure High Availability for the Cisco Catalyst 9800 Series Wireless Controller

Before you begin

Here are the prerequisite tasks for configuring High Availability (HA) on Cisco Catalyst 9800 SeriesWireless
Controller:

• Both the Cisco Catalyst 9800 Series Wireless Controller devices are running the same software version
and have active software image on the primary Catalyst 9800 Series Wireless Controller.

• The service port and the management port of Catalyst 9800 Series Wireless Controller 1 and Catalyst
9800 Series Wireless Controller 2 are configured.

• The redundancy port of Catalyst 9800 Series Wireless Controller 1 and Catalyst 9800 Series Wireless
Controller 2 are physically connected.

• Preconfigurations such as interface configurations, route addition, ssh line configurations, netconf-yang
configurations are completed on the Catalyst 9800 Series Wireless Controller appliance.

• Themanagement interface of Catalyst 9800 SeriesWireless Controller 1 and Catalyst 9800 SeriesWireless
Controller 2 are in the same subnet.
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• The discovery and inventory of Catalyst 9800 Series Wireless Controller 1 and Catalyst 9800 Series
Wireless Controller 2 devices are successful from Cisco DNA Center.

• The devices are reachable and are in Managed state.

Step 1 From the Cisco DNA Center home page, choose Provision.
Step 2 The Devices > Inventorywindow appears, and all the discovered devices are listed in this window.
Step 3 To view devices available in a particular site, expand the Global site in the left pane, and select the site, building, or

floor that you are interested in.

All the devices available in that selected site is displayed in the Inventory window.

Step 4 From the Device Type list, click the WLCs tab, and from the Reachability list, click the Reachable tab to get the list
of wireless controllers that are discovered and reachable.

Step 5 In the Inventory window, click the desired Cisco Catalyst 9800 Series Wireless Controller name to configure as a
primary controller.

Step 6 Click the High Availability tab.

The selected Catalyst 9800 Series Wireless Controller by default becomes the primary controller and the Primary
C9800 field is grayed out.

Step 7 From the Select Primary Interface and Secondary Interface drop-down lists, choose the interface that is used for
HA connectivity.

The HA interface serves the following purposes:

• Enables communication between the controller pair before the IOSd boots up.

• Provides transport for IPC across the controller pair.

• Enables redundancy across control messages exchanged between the controller pair. The control messages can be
HA role resolution, keepalives, notifications, HA statistics, and so on.

Step 8 From the Select Secondary C9800 drop-down list, choose the secondary controller to create a HA pair.
Step 9 Enter the Redundancy Management IP and Peer Redundancy Management IP addresses in the respective fields.

The IP addresses used for redundancy management IP and peer redundancy management IP should be
configured in the same subnet as the management interface of the Catalyst 9800 Series Wireless Controller.
Ensure that these IP addresses are unused IP addresses within the subnet range.

For the Catalyst 9800 Series Wireless Controller with 16.12 or earlier, there is no redundancy management
IP to configure, because it does not exist on the controller. You can enter any nonroutable IP that will be used
for the redundancy port keepalives.

Note

Step 10 In the Netmask field, enter the netmask address.
Step 11 Click Configure HA.

The HA configuration is initiated at the background using the CLI commands. First, the primary controller is configured.
On success, the secondary controller is configured. Both the devices reboot once the HA is enabled. This process may
take up to 2.5 minutes to complete.
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Step 12 After the HA is initiated, the Redundancy Summary under High Availability tab displays the Sync Status as HA
Pairing is in Progress. When Cisco DNA Center finds that the HA pairing is successful, the SyncStatus becomes
Complete.

This is triggered by the inventory poller or by manual resynchronization. By now, the secondary controller (Catalyst
9800 SeriesWireless Controller 2) is deleted from Cisco DNACenter. This flow indicates successful HA configuration
in the Catalyst 9800 Series Wireless Controller.

Step 13 To manually resynchronize the controller, on the Provision > Inventory window, select the controller that you want
to synchronize manually.

Step 14 From the Actions drop-down list, choose Resync.
Step 15 The following is the list of actions that occur after the process is complete:

• Catalyst 9800 Series Wireless Controller 1 and Catalyst 9800 Series Wireless Controller 2 are configured with
redundancy management, redundancy units, and Single sign-on (SSO). The devices reboot in order to negotiate
their role as an active controller or a standby controller. Configuration is synchronized from active to standby.

• On the Show Redundancy Summary window, you can see these configurations:

• SSO is enabled

• Catalyst 9800 Series Wireless Controller 1 is in active state

• Catalyst 9800 Series Wireless Controller 2 is in standby state

Information About High Availability

High Availability (HA) allows you to reduce the downtime of wireless networks that occurs because of the
failover of controllers. You can configure high availability of Cisco Catalyst 9800 Series Wireless Controller
through Cisco DNA Center.

Commands to Configure High Availability on Cisco Catalyst 9800 Series Wireless Controllers

Step 1 Use the following commands to configure HA on primary for Cisco Catalyst 9800 Series Wireless Controller:

• Run the chassis ha-interface GigabitEthernet <redundancy interface num> local-ip <redundancy ip> <netmask>
remote-ip <peer redundancy ip> command to configure the HA chassis interface.

This example shows how to configure a HA chassis interface:

chassis ha-interface GigabitEthernet 3 local-ip 1.1.1.2 255.255.255.0 remote-ip
1.1.1.3

• Run the reload command to reload devices for the changes to become effective.

Step 2 Use the following commands to configure HA on secondary for Catalyst 9800 Series Wireless Controller:

• Run the chassis ha-interface GigabitEthernet <redundancy interface num> local-ip <redundancy ip> <netmask>
remote-ip <peer redundancy ip> command to configure the HA chassis interface.

This example shows how to configure a HA chassis interface:

chassis ha-interface GigabitEthernet 2 local-ip 1.1.1.3 255.255.255.0 remote-ip
1.1.1.2
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Step 3 Run the chassis clear command to clear or delete all the HA-related parameters, such as local IP, remote IP, HA interface,
mask, timeout, and priority.

Reload the devices for changes to take effect by running the reload command.Note

Step 4 Use the following commands to configure HA on primary for Cisco Catalyst 9800-40 Wireless Controller and Cisco
Catalyst 9800-80 Wireless Controller devices:

• Run the chassis ha-interface local-ip <redundancy ip> <netmask> remote-ip <peer redundancy ip> command
to configure the HA chassis interface.

This example shows how to configure a HA chassis interface:

chassis ha-interface local-ip 1.1.1.2 255.255.255.0 remote-ip 1.1.1.3

• Run the reload command to reload devices for the changes to become effective.

Step 5 Use the following commands to configure HA on secondary for Cisco Catalyst 9800-40 Wireless Controller and Cisco
Catalyst 9800-80 Wireless Controller devices:

• Run the chassis ha-interface local-ip <redundancy ip> <netmask> remote-ip <peer redundancy ip> command
to configure the HA chassis interface.

This example shows how to configure a HA chassis interface:

chassis ha-interface local-ip 1.1.1.3 255.255.255.0 remote-ip 1.1.1.2

Step 6 Run the chassis clear command to clear or delete all the HA-related parameters, such as local IP, remote IP, HA interface,
mask, timeout, and priority.

Reload the devices for changes to take effect by running the reload command.Note

Commands to Verify Cisco Catalyst 9800 Series Wireless Controllers High Availability

Use the following commands to verify the high availability configurations from Cisco Catalyst 9800 Series
Wireless Controller:

• Run the config redundancy mode sso command to check the HA-related details.

• Run the show chassis command to view chassis configurations about the HA pair, including the MAC
address, role, switch priority, and current state of each controller device in the redundant HA pair.

• Run the show ip interface brief command to view the actual operating redundancy mode running on
the device, and not the configured mode as set by the platform.

• Run the show redundancy states command to view the redundancy states of the active and standby
controllers.

• Run the show redundancy summary command to check the configured interfaces.

• Run the show romvar command to verify high availability configuration details.
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N+1 High Availability

Overview of N+1 High Availability

Cisco DNA Center supports N+1 High Availability (HA) on Cisco Wireless Controller and Cisco Catalyst
9800 Series Wireless Controller platforms.

N+1 HA with HA-SKU is supported on the Cisco 2504, 5500, 7500, and 8500 Series of standalone wireless
controllers and WiSM2 controllers.

The N+1 HA architecture provides redundancy for controllers across geographically separated data centers
with low-cost deployments.

N+1 HA allows a single Cisco Wireless Controller to be used as a backup controller for multiple primary
controllers. These wireless controllers are independent of each other and do not share configuration or IP
addresses on any of their interfaces.

Cisco DNA Center supports primary and secondary controller configurations for N+1 HA.

The N+1 HA configuration is done at the AP level, not at the global level. Configurations are pushed directly
to the AP.

When a primary wireless controller resumes operation, the APs fall back automatically from the backup
wireless controller to the primary wireless controller if the AP fallback option is enabled.

The primary and secondary controllers must be of the same device type. For example, if the primary device
is a Catalyst 9800 SeriesWireless Controller, the secondary device must also be a Catalyst 9800 SeriesWireless
Controller.

Note

APs with higher priority on the primary controller always connect first to the backup controller, even if they
have to push out the lower priority APs.

The N+1 HA configuration has the following limitations:

• The N+1 HA configuration is supported only in a nonfabric deployment.

• Auto provisioning of a secondary controller is not supported because of the VLAN ID configuration.

• You must reprovision the secondary controller manually with the latest design configuration if you have
made any changes to the primary controller.

• Cisco DNA Center does not support fault tolerance.

• Access Point Stateful Switch Over (AP SSO) functionality is not supported for N+1 HA. The AP Control
and Provisioning of Wireless Access Points (CAPWAP) state machine is restarted when the primary
controller fails.

Prerequisites for Configuring N+1 High Availability from Cisco DNA Center

• Discover primary and the secondary controller by running the Discovery feature.

For more information, see Discover Your Network Using CDP, or Discover Your Network Using an IP
Address Range.

• Make sure that the wireless controllers are reachable and in the managed state.
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For more information, see About Inventory and Display Information About Your Inventory.

• Verify the network connectivity between devices. If the primary controller goes down, the AP should
be able to join the secondary controller as per N+1 configuration.

• Create two buildings to manage the primary and secondary locations for both the devices. For example,
if you have created two buildings such as Building A and Building B, where Building A is the primary
managed location for controller-1 and also the secondary managed location for controller-2, and Building
B is configured only as a primary managed location for controller-2.

For more information, see Create a Site in a Network Hierarchy, Add Buildings, and Add a Floor to a
Building.

• Add and position APs on a floor map to get a coverage heatmap visualization during the design phase.

For more information, see Add, Position, and Delete APs.

• Create two SSIDs and associate them as the backhaul SSIDs.

For more information, see Create SSIDs for an Enterprise Wireless Network, Create SSIDs for a Guest
Wireless Network and Manage Backhaul Settings.

Configure N+1 High Availability from Cisco DNA Center

This procedure shows how to configure N+1 High Availability (HA) on Cisco Wireless Controller and Cisco
Catalyst 9800 Series Wireless Controller platforms in a nonfabric deployment.

Step 1 From the Cisco DNA Center home page, choose Provision.

The Devices > Inventory page appears, and all the discovered devices are listed in this page.

Step 2 Check the check box next to the desired controller to provision it as a primary controller.
Step 3 From the Actions drop-down list, choose Provision > Provision.

The Assign Site window appears.

Step 4 Click Choose a site to assign a primary managed AP location for the primary controller.
Step 5 In the Choose a site window, select a site and click Save.
Step 6 Click Next.

The Configuration window appears, which displays the primary AP managed location for the primary device.

Step 7 Add or update the managedAP locations for the primary controller by clicking Select Primary Managed AP Locations.
Step 8 In the Managed AP Location window, check the check box next to the site name, and click Save.

You can either select a parent site or the individual sites.

Step 9 Configure the interface and VLAN details.
Step 10 Under Configure Interface and VLAN area, configure the IP address and subnet mask details, and click Next.
Step 11 In the Advanced Configuration window, configure values for the predefined template variables, and click Next.
Step 12 In the Summary window, verify the managed AP locations for the primary controller and other configuration details,

and click Deploy.

• To deploy the device immediately, click the Now radio button and click Apply.
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• To schedule the device deployment for a later date and time, click the Later radio button and define the date and
time of the deployment.

Step 13 Next, provision the secondary controller.
Step 14 On the Inventory window, check the check box next to the desired controller to provision it as a secondary controller.
Step 15 From the Actions drop-down list, choose Provision > Provision.

The Assign Site window appears.

Step 16 Click Choose a site to assign the managed AP location for the secondary controller.

The managed AP location for the secondary controller should be same as the managed AP location of the primary
controller.

Step 17 In the Choose a site window, check the check box next to the site name to associate the secondary controller, and click
Save.

Step 18 Click Next.

The Configuration window appears, which displays the primary AP managed and secondary AP managed locations
for the secondary device.

Step 19 Add or update the managed AP locations for the secondary controller by clicking Select Secondary Managed AP
Locations.

Step 20 In the Managed AP Location window, check the check box next to the site name, and click Save.

You can either select a parent site or the individual sites.

Step 21 Configure the interface and VLAN details for the secondary controller.
Step 22 Under the Configure Interface and VLAN area, configure the IP address and subnet mask details for the secondary

controller, and click Next.
Step 23 In the Advanced Configuration window, configure values for the predefined template variables, and click Next.
Step 24 In the Summary window, verify the managed AP locations for the secondary controller and other configuration details

and click Deploy.

• To deploy the device immediately, click the Now radio button and click Apply.

• To schedule the device deployment for a later date and time, click the Later radio button and define the date and
time of the deployment.

Step 25 To verify the managed locations of the primary and secondary controllers, click the device name of the controllers that
you provisioned on the Provision > Devices > Inventory window.

Step 26 In theDevice detailswindow, click theManaged ap locations tab to view the primary and secondarymanaged location
details.

Step 27 Provision the AP for the primary controller.
Step 28 On the Devices > Inventory window, check the check box next to the AP that you want to provision.
Step 29 From the Action drop-down list, choose Provision > Provision.
Step 30 In the Assign Site window, click Choose a Floor to select the floor from the primary managed location.
Step 31 Click Next.

The Configuration window appears.
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Step 32 By default, the custom RF profile that you marked as the default under Design > Network Settings > Wireless >
Wireless Radio Frequency Profile is chosen in the RF Profile drop-down list.

You can change the default RF Profile value for an AP by selecting a value from the RF Profile drop-down list.

Step 33 Click Next.
Step 34 In the Summary window, review the details.
Step 35 Click Deploy to provision the primary AP.
Step 36 You are prompted with a message that creation or modification of an AP group is in progress.

You are prompted with a message stating After provisioning AP(s) will reboot. Do you want
to continue?.

Step 37 Click OK.

When deployment succeeds, the Last Sync Status column in the Device Inventory window shows SUCCESS.

Mobility Configuration Overview
The mobility configuration in Cisco DNA Center allows you to group a set of CiscoWireless Controllers into
a mobility group for a seamless roaming experience of wireless clients.

By creating a mobility group, you can enable multiple wireless controllers in a network to dynamically share
information and forward traffic when inter-controller or inter-subnet roaming occurs. Mobility groups enable
you to limit roaming between different floors, buildings, or campuses in the same enterprise by assigning
different mobility group names to different wireless controllers within the same wireless network.

The Cisco DNACenter allows you to create mobility groups between various platforms such as Cisco Catalyst
9800 Series Wireless Controller and Cisco AireOS Controllers.

Here are the guidelines and limitations for mobility configuration:

• You cannot select multiple controllers for configuring mobility on the Provision page.

• You cannot create mobility groups with the group name as default. This resets the mobility and RF group
names as default and deletes all the peers.

• You cannot configure a mobility group name on the anchor controller.

• You must reboot the wireless controller manually if there is change to the Virtual IP address when
configuring mobility groups on Cisco AireOS Controllers.

• The wireless controllers with the same mobility group name are automatically grouped into a single
mobility group and are added as peers to each other.

• When configuring mobility groups on Cisco AireOS Controllers, if the wireless controllers do not have
the IP address 192.0.2.1, then Cisco DNA Center pushes the virtual IP address which is 192.0.2.1 to all
the wireless controllers.

• Do not explicitly add guest anchor controllers to the mobility group. The provisioned guest anchor
controllers will not show in the drop-down list while adding peers in the mobility configuration page.

• If you provision a wireless controller as a guest anchor, ensure that it is not added to the mobility group.
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Mobility Configuration Workflow

Here is the workflow that you can follow to configure mobility on Cisco Wireless Controller:

• The mobility configuration is available in the Configuration window of the Provision page.

• To configure mobility, you must provision a wireless controller with mobility group name, RF group
name, and mobility peers.

• The configuration that is applied during the wireless controller provisioning is automatically replicated
to all the mobility peers configured in that group.

• Resynchronize the wireless controllers to get the latest tunnel status.

Mobility Configuration Use Cases

The following use cases explain the steps to configure mobility between controllers.

Use Case 1

Cisco Wireless Controller 1, wireless controller 2, and wireless controller 3 are newly added to Cisco DNA
Center with the mobility group name as Default and is not provisioned yet.

1. Provision the wireless controller 1 by configuring mobility group name, RF group name, and adding
wireless controller 2 and wireless controller 3 as peers.

2. Provision the wireless controller 2.

In the Provision window, the mobility configuration is automatically populated for wireless controller 2
with the group name and peers.

3. Provision the wireless controller 3.

4. After provisioning all wireless controllers, resynchronize the wireless controllers to receive the latest
tunnel status.

Use Case 2

Cisco Wireless Controller 1, wireless controller 2, and wireless controller 3 with different mobility group
names are already added to Cisco DNA Center and are provisioned.

1. Provision the wireless controller 1 by configuring mobility group name, RF group name, and adding
wireless controller 2 and wireless controller 3 as peers.

2. The mobility configuration is automatically replicated across other peers, such as wireless controller 2
and wireless controller 3.

• After the successful provisioning of wireless controller 1, the wireless controller 2 and wireless
controller 3 are added as peers on the wireless controller1.

• The wireless controller 1 and wireless controller 3 are added as peers on wireless controller 2.

• The wireless controller 1 and wireless controller 2 are added as peers on wireless controller 3.
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About N+1 Rolling AP Upgrade
The rolling AP upgrade feature is supported only on the Cisco Catalyst 9800 Series Wireless Controllers in
an N+1 High Availability setup. This feature helps you upgrade software images on the APs associated with
a Cisco Catalyst 9800 SeriesWireless Controller in your wireless LAN network. To achieve the zero downtime,
it is possible to upgrade APs in a staggered way using the N+1 Rolling AP upgrade feature.

The primary controller identifies the candidate APs through the radio resource management neighbor AP
map. The upgrade process starts with the software image downloading to the primary controller while the
image is predownloaded to the candidate APs. After the candidate APs have been upgraded and rebooted,
they join the secondary controller in a staggered manner. After all the APs have joined the secondary controller,
the primary controller reboots. The APs rejoin the primary controller in a staggered manner after it is rebooted.

Here are the prerequisites for configuring Rolling AP Upgrade on Cisco Catalyst 9800 Series Wireless
Controller:

• An N+1 High Availability setup with two Cisco Catalyst 9800 Series Wireless Controllers, one as the
primary controller and the other one as the secondary.

• The primary and the N+1 controllers have the same configuration and managing the same location in
the network.

• The N+1 controller is already running the Golden image so that rolling AP upgrade works with zero
downtime.

Golden images are standardized images for network devices and Cisco DNA Center automatically
downloads the images fromCisco.com. Image standardization helps in device security and optimal device
performance.

• The N+1 controller is reachable and in Managed state in Cisco DNA Center.

• Both the controllers are part of the same mobility group and a mobility tunnel is established between the
primary and N+1 controller. The upgrade information between the primary and N+1 controllers are
exchanged through the mobility tunnel.

Workflow to Configure Rolling AP Upgrade on Cisco Catalyst 9800 Series Wireless Controller

Before you begin

N+1 Rolling AP upgrade is supported only for nonfabric deployments.Note

Step 1 Install the Cisco DNA Center.

For more information, see the Cisco Digital Network Architecture Center Installation Guide.

Step 2 Log in to the Cisco DNA Center GUI and verify that the applications you need are in the Running state.

To verify, from the Cisco DNA Center home page, click the gear icon , and then choose System Settings > Software
Updates > Installed Apps.

To verify, from the Cisco DNA Center home page, click the gear icon , and then choose System Settings > Software
Updates > Installed Apps.
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Step 3 Discover the Cisco Catalyst 9800 Series Wireless Controller using the Discovery feature.

Youmust enable NETCONF and set the port to 830 to discover the Catalyst 9800 SeriesWireless Controller. NETCONF
provides a mechanism to install, manipulate, and delete configurations of network devices.

For more information, see Discover Your Network Using CDP or Discover Your Network Using an IP Address Range.

Step 4 Make sure that the discovered devices appear in the Device Inventory window and are in the Managed state.

For more information, see About Inventory and Display Information About Your Inventory.

You must wait for devices to move to a Managed state.

Step 5 Design your network hierarchy by adding sites, buildings, and floors so that later you can easily identify where to apply
design settings or configurations.

You can either create a new network hierarchy, or if you have an existing network hierarchy on Cisco Prime Infrastructure,
you can import it into Cisco DNA Center.

To import and upload an existing network hierarchy, see Upload an Existing Site Hierarchy.

To create a new network hierarchy, see Create a Site in a Network Hierarchy, Add Buildings, and Add a Floor to a
Building.

Step 6 Add the location information of APs, and position them on the floor map to visualize the heatmap coverage.

For more information, see Add, Position, and Delete APs.

Step 7 Provision the primary controller with primary managed AP location, Rolling AP upgrade enabled and mobility group
configured with secondary controller as its peer.

To do this, choose Provision > Devices > Inventory, and check the check box adjacent the primary controller name.

Step 8 Configure the N+1 controller as the mobility peer in the Mobility Group configuration.

For more information, see Mobility Configuration Overview, on page 48.

Step 9 Provision the N+1HA controller by configuring primary controllers primarymanaged AP location as the N+1 controllers
secondary managed AP location. This configures the secondary controller as N+1 controller.

For more information, see Provision a Cisco Catalyst 9800 Series Wireless Controller, on page 52.

Step 10 Provision the APs that are associated with the primary controller.

For more information, see Provision a Cisco AP—Day 1 AP Provisioning, on page 30.

Step 11 Import the software images to repository.

For more information, see Import a Software Image.

Step 12 Assign the software image to a device family.

For more information, see Assign a Software Image to a Device Family.

Step 13 Mark the software image as Golden by clicking star for a device family or a device role.

For more information, see Specify a Golden Software Image.

Step 14 Before upgrading the image, make sure that the image readiness checks are successful for both the devices.

Also make sure that the status of N+1 Device Check and the Mobility Tunnel Check has a green tick mark.
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• To do the image update readiness check, choose Provision > Devices > Software Images.

• Select the device whose image you want to upgrade.

• If the pre-checks are successful for a device, the Status link in the Image Precheck Status column has a green
tick mark. If any of the upgrade readiness pre-checks fail for a device, the Image Precheck Status link has a red
into mark, and you cannot update the OS image for that device. Click the Status link and correct any errors before
proceeding further.

Step 15 Intitiate the upgrade on primary controller.
Step 16 On the Provision > Devices > Software Images page, check the check box adjacent the primary controller.
Step 17 From the Actions drop-down list, choose Software Image > Update Image.

For more information, see Provision a Software Image.

Step 18 To monitor the progress of the image upgrade, click In Progress in the Software Image column.

The Device Status page displays the following information:

• Distribution Operation—Provides information about the image distribution process. The image gets copied from
the Cisco DNACenter to the primary device. The activate operation starts once the distribution process is complete.

• Activate Operation—Provides the activate operation details. The rolling AP upgrade starts during this process.

• Rolling AP Upgrade Operation—Provides summary of the rolling AP upgrade such as, whether the rolling AP
upgrade task is completed or not, number of APs pending, number of rebooting APs, and number of APs that have
joined N+1 controller.

Click the View AP Status to view details about the primary controller, N+1 controller, device names, current
status, and iterations.

Provision a Cisco Catalyst 9800 Series Wireless Controller

Before you begin

Before provisioning a Cisco Catalyst 9800 Series Wireless Controller make sure that you have completed the
steps in Workflow to Configure a Cisco Catalyst 9800 Series Wireless Controller in Cisco DNA Center, on
page 37.

Step 1 From the Cisco DNA Center home page, choose Provision.

The Devices > Inventory window appears with a list of discovered devices.

Step 2 Check the check box next to the Catalyst 9800 Series Wireless Controller name that you want to associate with a site.
Step 3 From the Actions drop-down list, choose Provision > Assign Device to Site.
Step 4 In the Assign Device to Site window, click Choose a Site to which you want to associate the Catalyst 9800 Series

Wireless Controller.
Step 5 In the Add Sites window, check the check box next to the site name to associate a Catalyst 9800 Series Wireless

Controller.
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You can either select a parent site or the individual sites. If you select a parent site, all the children under the parent
site are also selected. You can uncheck the check box to deselect an individual site.

Step 6 Click Save.
Step 7 Click Apply.
Step 8 Provision the device with configurations that were added during the design phase.
Step 9 Choose Provision > Devices > Inventory.
Step 10 Check the check box next to the Catalyst 9800 Series Wireless Controller name that you want to provision.
Step 11 From the Actions drop-down list, choose Provision > Provision.
Step 12 In the Assign Site window, click Next.

The Configuration window appears.

Step 13 Select a wireless controller role for the Catalyst 9800 SeriesWireless Controller:Active Main WLC orGuest Anchor.
Step 14 Click Select Primary Managed AP Locations to configure a managed AP location for the primary controller.
Step 15 Click Select Secondary Managed AP Locations to configure the secondary controller with secondary managed AP

location as the primary controllers primary managed location.
Step 16 You can either select a parent site or the individual sites. If you select a parent site, all the children under the parent

site are also selected. You can uncheck the check box to deselect a particular site.

Inheritance of managed AP location allows you to automatically choose a site along with the buildings and
floors under that particular site. One site is managed by only one wireless controller.

Note

Step 17 Under the Rolling AP Upgrade area, check the Enable check box to enable the rolling AP upgrade status.

For more information on Rolling AP upgrade, see Workflow to Configure Rolling AP Upgrade on Cisco Catalyst 9800
Series Wireless Controller, on page 50.

Rolling AP upgrade operation is not supported on fabric enabled and guest anchored devices.Note

Step 18 From the AP Reboot Percentage drop-down list, select the percentage of APs that will be rebooted in an iteration.
Because the upgrade must be staggered, select only a subset of APs to go through the reboot process, so that all the
clients connected to these APs can be safely steered to the other APs in the region.

Step 19 Under Mobility Group, click Configure to configure the mobility peer.

The Configure Mobility Group panel appears.

For more information, see Mobility Configuration Overview, on page 48.

Step 20 From the Mobility Group Name drop-down list, you can either add a new mobility group by clicking , or choose
from the existing mobility groups.

The existing mobility peers information is loaded from the intent available in the Cisco DNA Center.

Step 21 In the RF Group Name text box, enter a name for the RF group.

Step 22 Under Mobility Peers, click Add to configure a mobility peer.
Step 23 From the Device Name drop-down list, choose the controller.

After the device is provisioned, the Cisco DNA Center creates a mobility group in device, assigns the RF group, and
configures all ends of peers. The mobility group configuration is deployed automatically to all the selected peer devices.

Step 24 Click Save.
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Step 25 You can reset the mobility group name and the RF group name using one of the following methods:

• In the Configure Mobility Group panel, choose default from the Mobility Group Name drop-down list.

• On the Provision > Configuration page, under Mobility Group, click Reset.

This automatically sets the RF Group Name to default and removes all peers. Once you provision, the mobility on
the device is set and the device is removed from all other peers.

Step 26 For an active main wireless controller, you need to configure interface and VLAN details.
Step 27 Under the Assign Interface area, do the following:

• VLAN ID: Enter a value for the VLAN ID.

• IP Address: Enter the interface IP address.

• Gateway IP Address: Enter the gateway IP address.

• Subnet Mask (in bits): Enter the interface net mask details.

Assigning an IP address, gateway IP address, and subnet mask is not required for the Catalyst 9800 Series
Wireless Controller.

Note

Step 28 Click Next.

The Advanced Configuration window appears, where you can enter values for the predefined template variables.

Step 29 Search for the device or the template in the Devices panel.
Step 30 Enter a value for the predefined template variable in the wlanid text field.
Step 31 Click Next.
Step 32 On the Summary window, review the following configurations:

• Device Details

• Network Setting

• SSID

• Managed Sites

• Interfaces

• Advanced Configuration

Step 33 Click Deploy to provision the Catalyst 9800 Series Wireless Controller.

• To deploy the device immediately, click the Now radio button and click Apply.

• To schedule the device deployment for a later date and time, click the Later radio button and define the date and
time of the deployment.

Step 34 To verify configurations that are pushed from the Cisco DNA Center to the device, use the following commands on
the Catalyst 9800 Series Wireless Controller:

• #show wlan summary

• #show run | sec line
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• #show running-configuration

Step 35 After the devices are deployed successfully, the Provision Status changes from Configuring to Success.
Step 36 In the Inventory window, click See Details in the Provision Status column against a device to get more information

about network intent or to view a list of actions.
Step 37 Click See Details under Device Provisioning.
Step 38 Click View Details under Deployment of network intent, and click the device name.
Step 39 Click and expand the device name.
Step 40 Expand theConfiguration Summary area to view the operation details, feature name, and the management capability.

The configuration summary also displays any error that occurred while provisioning device with reasons for failure.
Step 41 Expand the Provision Summary area to view details of the exact configuration that is sent to the device.
Step 42 Provision the AP.

For more information, see Provision a Cisco AP—Day 1 AP Provisioning, on page 30.

Day 0 Workflow for Cisco Embedded Wireless Controller on Catalyst Access Points
The Cisco Embedded Wireless Controller on Catalyst Access Points (EWC-AP) is the next generation Wi-Fi
solution, which combines Cisco Catalyst 9800 Series Wireless Controller with Cisco Catalyst 9100 Series
Access Points, creating the best-in-class wireless experience for the evolving and growing organization.

Before you begin

• Design your network hierarchy, with sites, buildings, floors, and so on.

For more information, see Create a Site in a Network Hierarchy, Add Buildings, and Add a Floor to a
Building.

• Define the device credentials, such as CLI, SNMP, HTTP, and HTTPS at the global level. The credentials
that are defined at the global level are inherited by the sites.

For more information, see Configure Global CLI Credentials, Configure Global SNMPv2c Credentials,
and Configure Global SNMPv3 Credentials.

• Create wireless SSIDs, wireless interfaces, and wireless Radio Frequency profiles.

For more information, see Create SSIDs for an Enterprise Wireless Network, Create SSIDs for a Guest
Wireless Network, Create a Wireless Interface, and Create a Wireless Radio Frequency Profile.

For Cisco Embedded Wireless Controller on Catalyst Access Points, only
Flex-based SSID creation is supported.

Note

• Configure the DHCP server with Option #43 on the switch where the Cisco EmbeddedWireless Controller
on Catalyst Access Points is connected.. This is IP address of the Cisco DNACenter Plug and Play server.
Using this, the APs contact the PnP server and downloads the configuration.

• Make sure that you have Cisco EmbeddedWireless Controller on Catalyst Access Points in the inventory.
If not, discover using the Discovery feature. For more information, see Discover Your Network Using
CDP, Discover Your Network Using an IP Address Range , and About Inventory.
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• The APs should be in the factory reset state without any Cisco Wireless Controller configurations.

The Cisco Embedded Wireless Controller on Catalyst Access Points is available in multiple form factors:

• Cisco Embedded Wireless Controller on Catalyst 9115AX Access Points

• Cisco Embedded Wireless Controller on Catalyst 9117AX Access Points

• Cisco Embedded Wireless Controller on Catalyst 9120AX Access Points

• Cisco Embedded Wireless Controller on Catalyst 9130AX Access Points

Step 1 The Cisco Embedded Wireless Controller on Catalyst Access Points contacts the DHCP server.

The DHCP server in response provides the IP address along with Option #43. The option #43 contains the IP address
of the Cisco Plug and Play server.

Step 2 Based on Option #43, the Cisco Embedded Wireless Controller on Catalyst Access Points turns on the Plug and Play
agent and contacts the Cisco DNA Center Plug and Play server.

If you have a set of Cisco Embedded Wireless Controller on Catalyst Access Points in the network, they go
through an internal protocol. The protocol selects one Cisco Embedded Wireless Controller on Catalyst
Access Points, which is configured on the Cisco Wireless Controller as the primary AP to reach the PnP
server.

Note

Step 3 Find the unclaimed Cisco Embedded Wireless Controller on Catalyst Access Points in the Provision > Devices > Plug
and Play tab.

The table lists all the unclaimed devices. The State column shows asUnclaimed. Use the Filter or Find option to find
specific devices.

You must wait for the onboarding status to become Initialized under the Onboarding State column.

Step 4 To claim the Cisco Embedded Wireless Controller on Catalyst Access Points, check the check box adjacent the AP
device name.

Step 5 Choose Actions > Claim in the menu bar above the device table.

The Claim Devices window appears.

Step 6 In the Site Assignment window, choose a site from the Site drop-down list.

Claiming the selected AP to this particular site also applies the associated configurations.

Step 7 Click Next.
Step 8 To configure a device, click the device name in the Configuration window.
Step 9 In the Configuration for device name page, assign the static IP details for the device:

• Management IP

• Subnet Mask

• Gateway

Step 10 Click Save.
Step 11 Click Next.
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The Summary page appears.

Step 12 Click Claim in the Summary page.

Once the Cisco Embedded Wireless Controller on Catalyst Access Points is claimed, the IP address configured is
assigned to the Cisco Embedded Wireless Controller.

Step 13 The claimed device, which is an Cisco EmbeddedWireless Controller with internal AP is now available underProvision >
Devices > Inventory window.

Step 14 To provision the AP, see Provision a Cisco AP—Day 1 AP Provisioning, on page 30.
Step 15 To provision the additional Cisco Embedded Wireless Controller on Catalyst Access Points, see Provision a Cisco

AireOS Controller, on page 23.
Step 16 To bulk import devices from a CSV file, see Add Devices in Bulk, on page 9.
Step 17 To add devices manually, see Add or Edit a Device.

Configure and Provision a Cisco Catalyst 9800 Embedded Wireless Controller
for Catalyst 9000 Series Switches

Supported Hardware Platforms

PlatformsDevice Role

Cisco Catalyst 9300 Series SwitchesEmbedded Wireless Controller

Cisco Catalyst 9400 Series Switches

Cisco Catalyst 9500H Series Switches

Cisco Catalyst 9300 Series SwitchesFabric Edge

Cisco Catalyst 9400 Series Switches

Cisco Catalyst 9500H Series Switches

Cisco Catalyst 3600 Series Switches

Cisco Catalyst 3850 Series Switches

Cisco 802.11ac Wave 2 APs:APs

• Cisco Aironet 1810 Series OfficeExtend Access Points

• Cisco Aironet 1810W Series Access Points

• Cisco Aironet 1815i Access Point

• Cisco Aironet 1815w Access Point

• Cisco Aironet 1815m Access Point

• Cisco 1830 Aironet Series Access Points

• Cisco Aironet 1850 Series Access Points

Provision Your Network
57

Provision Your Network
Configure and Provision a Cisco Catalyst 9800 Embedded Wireless Controller for Catalyst 9000 Series Switches

https://www.cisco.com/c/en/us/td/docs/cloud-systems-management/network-automation-and-management/dna-center/1-3-1-0/user_guide/b_cisco_dna_center_ug_1_3_1_0/b_cisco_dna_center_ug_1_3_1_0_chapter_01100.html#id_89511


PlatformsDevice Role

• Cisco Aironet 2800 Series Access Points

• Cisco Aironet 3800 Series Access Points

• Cisco Aironet 4800 Series Access Points

Cisco 802.11ac Wave 1 APs

• Cisco Aironet 1700 Series Access Points

• Cisco Aironet 2700 Series Access Points

• Cisco Aironet 3700 Series Access Points

Preconfiguration
On Cisco Catalyst 9800 Embedded Wireless Controller for Catalyst 9300 Series Switches, make sure that the
following commands are present if the switch is already configured with aaa new-model:
aaa new-model

aaa authentication login default local

aaa authorization exec default local

aaa session-id common

This is required for NETCONF configuration. These configurations are not required if you are using automated
underlay for provisioning.

WorkflowtoConfigureCiscoCatalyst9800EmbeddedWirelessControllerforCatalyst9000Switches
1. Install Cisco DNA Center.

For more information, see the Cisco DNA Center Installation Guide.

2. Log in to the Cisco DNACenter GUI and verify that the applications you need are in theRunning state.

To verify, from the Cisco DNA Center home page, click the gear icon , and then choose System
Settings > Software Updates > Installed Apps.

3. Integrate Cisco Identity Services Engine with Cisco DNA Center. After Cisco ISE is registered with
Cisco DNA Center, any device that Cisco DNA Center discovers, along with relevant configurations
and other data, is pushed to Cisco ISE.

4. Discover Cisco Catalyst 9000 Series Switches and the edge switches.

Youmust enable NETCONF and set the port to 830 to discover Cisco Catalyst 9800 EmbeddedWireless
Controller for Catalyst 9000 Series Switches.

Do not enable NETCONF to discover the edge switches.

For more information, see Discover Your Network Using CDP and Discover Your Network Using an
IP Address Range.

Change the Preferred Management IP to Use Loopback.

5. Make sure that the devices appear in the device inventory and are in Managed state.
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For more information, see About Inventory and Display Information About Your Inventory.

Ensure that the devices are in the Managed state.

6. Design your network hierarchy, which represents your network's geographical location. You create
sites, buildings, and floors so that later you can easily identify where to apply design settings or
configurations.

You can either create a new network hierarchy, or if you have an existing network hierarchy on Cisco
Prime Infrastructure, you can import it into Cisco DNA Center.

To import and upload an existing network hierarchy, see the Upload an Existing Site Hierarchy.

To create a new network hierarchy, see the Create a Site in a Network Hierarchy, Add Buildings, and
Add a Floor to a Building.

7. For a nonfabric network, add and position APs on a floor map to get heatmap visualization during the
design phase.

For a fabric network, you cannot place APs on a floor map during the design time. The APs are onboarded
after adding devices to a fabric network.

For more information, see Add, Position, and Delete APs.

8. Define network settings, such as AAA (Cisco ISE is configured for Network and Client Endpoint),
NetFlow Collector, NTP, DHCP, DNS, syslog, and SNMP traps. These network servers become the
default for your entire network.

For more information, see About Global Network Settings, Configure Global Network Servers, and
Add AAA server.

9. Configure device credentials such as CLI, SNMP, and HTTPs.

Formore information, seeAbout Global Device Credentials, ConfigureGlobal CLI Credentials, Configure
Global SNMPv2c Credentials, Configure Global SNMPv3 Credentials, and Configure Global HTTPS
Credentials.

10. Configure IP address pools at the global level.

To configure an IP address pool, see Configure IP Address Pools.

To reserve an IP address pool for the building that you are provisioning, see Provision a LANUnderlay.

11. Create enterprise and guest wireless networks. Define global wireless settings once and Cisco DNA
Center then pushes configurations to various devices across geographical locations.

Designing a wireless network is a two-step process. First, you must create SSIDs on the Wireless page.
Then, associate the created SSID to a wireless network profile. This profile helps you to construct a
topology, which is used to deploy devices on a site.

For more information, see Create SSIDs for an Enterprise Wireless Network and Create SSIDs for a
Guest Wireless Network.

12. Configure backhaul settings. For more information, see Manage Backhaul Settings.

13. Configure the following on the Policy page:

• Create a virtual network. The virtual network segments your physical network into multiple logical
networks. For more information, see Virtual Networks and Create a Virtual Network.
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• Create a group-based access control policy, and add a contract. For more information, see Create
Group-Based Access Control Policy.

14. Provision Cisco Catalyst 9000 Series Switches and the edge node switches with the configurations
added during the design phase.

• Create a fabric domain.

• Add devices to the fabric network by creating a CP+Border+Edge or CP+Border.

• Enable embedded wireless capabilities on the Cisco Catalyst 9800 Embedded Wireless Controller
for Catalyst 9000 Series Switches.

• Onboard APs in the fabric domain.

After the devices are deployed successfully, the deploy status changes from Configuring to Success.

Provision Embedded Wireless on Cisco Catalyst 9000 Series Switches

Before you begin

Before provisioning a Cisco Catalyst 9800 Embedded Wireless Controller on Catalyst 9000 Series Switches,
ensure that you have completed the steps in Workflow to Configure Cisco Catalyst 9800 Embedded Wireless
Controller for Catalyst 9000 Switches, on page 58.

This procedure explains how to provision embedded wireless on Cisco Catalyst 9300 Series Switches, Cisco
Catalyst 9400 Series Switches, and Cisco Catalyst 9500H Series Switches.

Step 1 From the Cisco DNA Center home page, choose Provision.

The Devices > Inventory window appears with a list of discovered devices.

Step 2 Check the check box next to the Catalyst 9000 Series Switch device and an edge switch that you want to associate to
a site.

Step 3 From the Actions drop-down list, choose Provision > Assign Device to Site.
Step 4 In the Assign Device to Site window, click Choose a site.
Step 5 In the Choose a site window, check the check box next to the site to associate the device.
Step 6 Click Save.
Step 7 Click Apply.

The next step is to provision the Catalyst 9000 Series Switch and the edge node with the configurations that were added
during the design phase.

Step 8 In the Devices > Inventorywindow, check the check box next to the device name that you want to provision.
Step 9 From the Actions drop-down list, choose Provision.
Step 10 Click Next.
Step 11 In the Summary window, verify the configurations, and click Deploy.
Step 12 To provision the edge switch, check the check box next to the edge switch that you want to provision.
Step 13 From the Actions drop-down list, choose Provision.
Step 14 Click Next.
Step 15 In the Summary window, verify the configurations, and click Deploy.
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After the devices are deployed successfully, the Provision Status changes from Configuring to Success.

Step 16 To add devices to a fabric domain, from the Cisco DNA Center home page, choose Provision > Fabric.
Step 17 Create a fabric LAN.
Step 18 Add an IP transit network.

An IP transit network is used in a regular IP network to connect externally or to connect two or more fabric sites.

Step 19 Add devices and associate virtual networks to a fabric domain.
Step 20 Add the Cisco Catalyst 9000 Series Switch as a control plane, a border node, and an edge node or a control plane and

a border node.

Click the device and choose Add as CP+Border+Edge or Add as CP+Border.

Step 21 Click the edge node and choose Add to Fabric.
Step 22 Click Save.
Step 23 If you have not installed the wireless package on Cisco Catalyst 9000 Series Switches before enabling the wireless

functionality, Cisco DNA Center displays a warning message saying 9800-SW image is necessary for
turning on the capability. Click "OK" to import the 9800-SW image manually.

Step 24 Click OK to install the image manually.
Step 25 On the Download Image window, click Choose File to navigate to a software image stored locally or Enter image

URL to specify an HTTP or FTP source from which to import the software image.
Step 26 Click Import.

The progress of the import is displayed.

Step 27 Click Activate image on device.

A warning message saying Activate image on device will reboot the device. Are you sure
you want to reboot the device? appears.

Step 28 Click Yes.

The device reboots and comes online after the device package upgrade is complete.

Step 29 In the dialog box that appears, the AP locations that are managed by the controllers are displayed. You can change,
remove, or reassign the site here.

Step 30 Click Next.
Step 31 Review the details on the Summary window, and click Save.
Step 32 On theModify Fabric Domainwindow, clickNow to commit the changes, and clickApply to apply the configurations.

The next step is to onboard APs in a fabric domain.
Step 33 From the Cisco DNA Center home page, click the Provision tab.
Step 34 Click the Fabric tab.

A list of fabric domains is displayed.

Step 35 Select the fabric domain that was created, and click the Host Onboarding tab to enable IP pool for APs.
Step 36 Select the authentication template that is applied for devices in the fabric domain. These templates are predefined

configurations that are retrieved from Cisco ISE. After selecting the authentication template, click Save.
Step 37 Under Virtual Networks, click INFRA_VN to associate one or more IP pools with the selected virtual network.
Step 38 Under Virtual Network, click the guest virtual networks to associate IP pools for the selected guest virtual network.
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Step 39 Check the IP Pool Name check box that was created for APs during the design phase.
Step 40 Click Update to save the setting.

The AP gets the IP address from the specified pool, which is associated with the AP VLAN and registers with the Cisco
wireless controller through one of the discovery methods.

Step 41 Specify wireless SSIDs within the network that hosts can access. Under the Wireless SSID section, select the guest or
enterprise SSIDs and assign address pools, and click Save.

Step 42 Manually trigger resynchronization by performing an Inventory > Resync to see the APs on Cisco DNA Center for
embedded wireless.
The discovered APs are now displayed under Inventory in the Provision page and the Status is displayed as Not
Provisioned.

Step 43 Provision the AP.
Step 44 Configure and deploy application policies.

Provision the Catalyst 9300 Series Switches and Cisco Catalyst 9500H Series Switches before deploying an application
policy.

Two different policies with different business relevance for two different SSIDs do not work. Always the last deployed
policy takes precedence when you are setting up the relevance.

Changing the default business relevance for an application does not work in FlexConnect mode.

You can apply an application policy only on a nonfabric SSID.

Fabric in a Box with Catalyst 9800 Embedded Wireless on Cisco Catalyst 9000
Series Switches

Information About Fabric in a Box
Cisco Catalyst 9000 Series Switches have the capability to host fabric edge, control plane, border, and embedded
wireless functionalities on a single switch, which you can configure using Cisco DNA Center.

With this feature, configurations at the small site locations are simplified and the cost to deploy Cisco SD-Access
is reduced.

For information on how to add CP+Border+Edge nodes on Cisco Catalyst 9000 Series Switches, see Provision
a Cisco Catalyst 9800 Series Wireless Controller, on page 52.

Scale Information
This table shows the device scalability information.

Cisco Catalyst
9500-H Series
Switches

Cisco Catalyst 9500
Series Switches

Cisco Catalyst 9400
Series Switches

Cisco Catalyst 9300
Series Switches

Fabric
Constructs

256256256256Virtual
Networks
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Cisco Catalyst
9500-H Series
Switches

Cisco Catalyst 9500
Series Switches

Cisco Catalyst 9400
Series Switches

Cisco Catalyst 9300
Series Switches

Fabric
Constructs

4K4K4K4KLocal End
Points/Hosts

8K8K8K8KSGT/DGT
Table

18K18K18K5KSGACLs
(SecurityACEs)

Inter-Release Controller Mobility Introduction
Inter-Release Controller Mobility (IRCM) supports seamless mobility and wireless services across different
Cisco Wireless Controllers with different software versions.

Cisco DNA Center supports guest anchor feature for the following device combinations:

• Configuration of a Cisco AireOS controller as a foreign controller with a Cisco AireOS controller as an
anchor controller.

• Configuration of a Cisco AireOS controller as a guest anchor controller with a Cisco Catalyst 9800 Series
Wireless Controller as a foreign controller.

• Configuration of a Cisco Catalyst 9800 Series Wireless Controller as a foreign controller with a Cisco
Catalyst 9800 Series Wireless Controller as an anchor controller.

Here are the limitations for configuring IRCM on the controller devices in this release:

• Configuration of Cisco AireOS controller as a foreign and Cisco Catalyst 9800 SeriesWireless Controller
as an anchor controller is not supported.

• Configuration of a fabric guest anchor is not supported.

• Configuration of multiple anchor controllers and one foreign controller scenario is not supported.

• Only guest SSID is supported.

• Broadcast of a non-guest anchor SSID in a guest anchor node is not supported.

• Mobility tunnel is not encrypted.

Guest Anchor Configuration and Provisioning

Configuration of Cisco AireOS controller as a foreign controller and Cisco Catalyst 9800 Series Wireless
Controller as a guest anchor controller is not supported while using Inter-Release Controller Mobility (IRCM).

Note

Follow these steps to configure a guest anchor Cisco Wireless Controller.
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Step 1 Design a network hierarchy, with sites, buildings, floors, and so on. For more information, see Create a Site in a Network
Hierarchy, Add Buildings, and Add a Floor to a Building.

Step 2 Configure network servers, such as AAA, DHCP, and DNS servers. For more information, see Configure Global Network
Servers and Add Cisco ISE or Other AAA Servers.

Step 3 Create SSIDs for a guest wireless network with external web authentication and central web authentication along with
configuring Cisco Identity Services Engine. For more information, see Create SSIDs for a Guest Wireless Network.

Step 4 Discover the wireless controller using the Cisco Discovery Protocol (CDP) or an IP address range and that the devices
are in the Inventory window and are in the Managed state. For more information, see About Discovery.

Step 5 Provision a foreign wireless controller as the active main wireless controller. See Provision a Cisco AireOS Controller,
on page 23.

Step 6 Choose the role for the wireless controller as guest anchor and provision the guest anchor controllers. For more information,
see Provision a Cisco AireOS Controller, on page 23.

Step 7 Configure device credentials, such as CLI, SNMP, HTTP, and HTTPS. For more information, see Configure Global CLI
Credentials, Configure Global SNMPv2c Credentials, Configure Global SNMPv3 Credentials, and Configure Global
HTTPS Credentials.

IRCM: Cisco AireOS Controller and Cisco Catalyst 9800 Series Wireless Controller

Before you begin

• Discover the Cisco Catalyst 9800 Series Wireless Controller and Cisco AireOS Controllers.

You must enable NETCONF and set the port to 830 to discover the Catalyst 9800 Series Wireless
Controller. NETCONF provides a mechanism to install, manipulate, and delete configurations of network
devices.

For more information, see Discover Your Network Using CDP or Discover Your Network Using an IP
Address Range.

• Design your network hierarchy by adding sites, buildings, and floors so that later you can easily identify
where to apply design settings or configurations.

To create a new network hierarchy, see Create a Site in a Network Hierarchy, Add Buildings, and Add
a Floor to a Building.

• Add the location information of APs, and position them on the floor map to visualize the heatmap
coverage.

For more information, see Add, Position, and Delete APs.

• Define network settings, such as AAA (Cisco ISE is configured for Network and Client Endpoint),
NetFlow Collector, NTP, DHCP, DNS, syslog, and SNMP traps. These network servers become the
default for your entire network. You can add a TACACS server while adding a AAA server.

For more information, see About Global Network Settings, Configure Global Network Servers, and Add
AAA server.

• Create SSIDs for a guest wireless network.

For more information, see Create SSIDs for a Guest Wireless Network.

• TheWLAN profile name of the foreign controller and anchor controller should be the same for mobility.
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Step 1 From the Cisco DNA Center home page, choose Provision.

The Devices > Inventory window appears with a list of discovered devices.

Step 2 Check the check box adjacent the Catalyst 9800 Series Wireless Controller that you want to provision as a foreign
controller.

Step 3 From the Actions drop-down list, choose Provision > Provision.
Step 4 In the Assign Site window, clickChoose a Site to assign a site for the Catalyst 9800 Series Wireless Controller device.
Step 5 In the Add Sites window, check the check box next to the site name to associate a Catalyst 9800 Series Wireless

Controller.
Step 6 Click Save.
Step 7 Click Apply.
Step 8 Click Next.
Step 9 Select a role for the Catalyst 9800 Series Wireless Controller as Active Main WLC.
Step 10 For an active main wireless controller, you need to configure interface and VLAN details.
Step 11 Under the Assign Interface area, do the following:

• VLAN ID: Enter a value for the VLAN ID.

• IP Address: Enter the interface IP address.

• Gateway IP Address: Enter the gateway IP address.

• Subnet Mask (in bits): Enter the interface net mask details.

Assigning an IP address, gateway IP address, and subnet mask is not required for the Catalyst 9800 Series
Wireless Controller.

Note

Step 12 Click Next.
Step 13 In the Summary window, review the configurations details.
Step 14 Click Deploy to provision the Catalyst 9800 Series Wireless Controller as a foreign controller.
Step 15 On the Devices > Inventorywindow, check the check box adjacent the Cisco AireOS Controller that you want to

provision as a guest anchor controller.
Step 16 Repeat Step 3 through Step 8.
Step 17 Select a role for the Cisco AireOS Controller as Guest Anchor.
Step 18 For a guest anchor wireless controller, you need to configure interface and VLAN details.
Step 19 Repeat Step 11 through Step 14.

Provision a Meraki Device
This procedure explains how to provision SSIDs to Cisco Meraki devices managed by a Meraki dashboard.

Before you begin

• Integrate the Meraki dashboard with Cisco DNA Center. See Integrate Meraki Dashboard.
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• Create the SSID. See Create SSIDs for an Enterprise Wireless Network.

The Meraki dashboard supports the following types of SSIDs:

• Open: This SSID corresponds to Open in the Meraki dashboard.

• WPA2 Personal: This SSID corresponds to the preshared key with WAP2
in the Meraki dashboard.

• WPA2 Enterprise: This SSID corresponds toWAP-2 encryption withMeraki
authentication or My Radius server in the Meraki dashboard. If you have
defined AAA or Cisco ISE servers for client and endpoint authentication at
the building level in Cisco DNA Center, the configuration is provisioned to
my Radius server in the Meraki dashboard. Otherwise, Meraki Radius is
used for authentication by the Meraki devices.

Note

• Create the network profile and assign it to the sites that the SSID will be provisioned for. See Create
Network Profiles for Wireless.

The Network Hierarchy Sites > Buildings in Cisco DNA Center corresponds to
Organization > Network in the Meraki dashboard. We recommend that you
choose Buildings in the Add Sites to Profile window in the Create Network
Profiles for Wireless workflow.

Note

Cisco DNACenter creates theMeraki network and provisions the SSIDs to the network. TheMeraki dashboard
provisions the Meraki network configuration to the Meraki devices.

Note

Step 1 From the Cisco DNA Center home page, choose Provision.

The Devices > Inventory window appears, listing all discovered devices.

Step 2 To view the Meraki dashboard, expand the Global site in the left pane, and select a building.

All Meraki dashboards available in the selected building are displayed.

Step 3 Check the check box next to the Meraki dashboard name that you want to provision.
Step 4 From the Actions drop-down list, choose Provision > Provision Device.

The Assign Site window appears, where you can view the Meraki dashboard and the associated building.

Step 5 If you want to change the associated building, click Choose a site.
Step 6 In the Choose a site window, select a building and click Save.
Step 7 Click Next.

The Configuration window appears. You can view the managed building in the Primary location.
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Step 8 Click Select Secondary Managed AP Locations to select the secondary managed location for the Meraki dashboard.
Step 9 In the Managed AP Location window, check the check box next to the building name.
Step 10 Click Save.
Step 11 Click Next.

The Summary window displays the following information:

• Device Details

• Network Settings

• SSID

Meraki deployment supports a maximum of 15 SSIDs in each network.Note

• Managed Sites

Step 12 Click Deploy.

• To immediately deploy the Meraki dashboard, click the Now radio button, and click Apply.

• To schedule the Meraki dashboard deployment for a later date and time, click the Later radio button and define
the date and time of the deployment.

Delete a Device After Provisioning
• If you are deleting a device that is already been added to the fabric domain, remove it from the fabric
domain and then delete it from the Provision menu.

• You cannot delete a provisioned device from the Inventorywindow. Instead, you must delete provisioned
devices from the Provision menu.

Step 1 From the Cisco DNA Center home page, choose Provision > Devices.

The Device Inventory window appears.

Step 2 Click the Inventory tab, which lists all discovered and provisioned devices.
Step 3 Check the check box next to the device that you want to delete.

APs are deleted only when the controller to which they are connected is deleted.Note

Step 4 From the Action drop-down list, choose Delete Device.
Step 5 At the confirmation prompt, click OK.

Provision a LAN Underlay
Use LAN automation to provision a LAN underlay.
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Before you begin

• Configure your network hierarchy. (See Add a Device to a Site, on page 20.)

• Make sure you have defined the following global network settings:

• Network servers, such as AAA, DHCP, and DNS servers. (See Configure Global Network Servers.)

• Device credentials, such as CLI, SNMP, HTTP, and HTTPS credentials. (See Configure Global
CLI Credentials, Configure Global SNMPv2c Credentials, Configure Global SNMPv3 Credentials,
and Configure Global HTTPS Credentials.)

• IP address pools. (See Configure IP Address Pools.)

• Make sure that you have at least one device in your inventory. If not, discover devices using the Discovery
feature.

LAN automation is blocked if the discovered site is configured with CLI
credentials that has a username "cisco".

Note

• If you have a Cisco Catalyst 9400 Switch configured in the network, ensure the following operations are
done on the switch for LAN automation to automatically enable the 40G port:

• Day-0 Configuration is performed on the switch.

• A 40G Quad Small Form-Factor Pluggable (QSFP) transceiver is inserted in either port 9 or port
10 of the Supervisor, and the ports numbered 1 to 8 on the Supervisor do not have a 10G or 1G
Small Form-Factor Pluggable (SFP) transceiver inserted in them. If there are dual supervisor engines,
ensure the 40G QSFP is inserted in port 9.

For more information on the Catalyst 9400 Series Supervisor, see the Cisco Catalyst 9400 Series
Supervisor Installation Note.

Step 1 Reserve an IP address pool for the site that you will be provisioning.

The size of the LAN automation IP address pool must be at least 25 bits of netmask in size or larger.Note

a) From the Cisco DNA Center home page, choose Design > Network Settings > IP Address Pools.
b) From the Network Hierarchy pane, choose a site.
c) Click Reserve IP Pool and complete the following fields to reserve all or part of an available global IP address pool

for the specific site:

• IP Pool Name: Unique name for the reserved IP address pool.

• Type: Type of IP address pool. For LAN automation, choose LAN.

• Global IP Pool: IPv4 address pool from which you want to reserve all or part of the IP addresses.

LAN automation uses only the IPv4 subnet.Note

• CIDR Prefix/No. of IP Addresses: IP subnet and mask address used to reserve all or part of the global IP
address pool or the number of IP addresses you want to reserve.
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• Gateway IP Address: Gateway IP address.

• DHCP Servers: DHCP server(s) IP address(es).

d) Click Reserve.

Step 2 Discover and provision devices.
a) From the Cisco DNA Center home page, choose Provision > Devices > Inventory.

All the discovered devices are displayed.

b) From the LAN Automation drop-down list, choose LAN Automation.
c) In the LAN Automation dialog box, complete the following fields:

• Primary Site: Select your Primary Device from this site.

• Peer Site: This site is used for selection of Peer Device. Note that this site can be different from the Primary
Site.

• Primary Device: Select the primary device that Cisco DNA Center uses as the starting point to discover and
provision new devices.

• Peer Device: Select the peer device.

• Choose Primary Device Ports: Ports to be used to discover and provision new devices.

• Discovered Device Site: All newly discovered devices are assigned to this site. This site can be different from
Primary and Peer Sites.

• IP Pool: IP address pool that was reserved for LAN automation. (See Step 1.)

• ISIS Domain Password: A user-provided IS-IS password when LAN automation starts. If the password already
exists on the seed device, it is reused and is not overwritten. If no user-provided password is entered and there
is no existing IS-IS password on the device, the default domain password is used. If both primary and secondary
seeds have domain passwords, ensure that they match.

• Enable Multicast: LAN automation creates a multicast tree from seed devices as RPs and discovered devices
as subscribers.

• Device Name Prefix: Name prefix for the devices being provisioned. As Cisco DNA Center provisions each
device, it prefixes the device with the text that you provide and adds a unique number at the end. For example,
if you enter Access as the name prefix, as each device is provisioned, it is named Access-1, Access-2, Access-3,
and so on.

• Hostname Map File: Configures user-provided names for discovered devices using a CSV file that contains a
mapping between serial numbers and hostnames. If the discovered device is a stack, all serial numbers of the
stack are provided in the CSV file.

Here is a sample CSV file:
standalone-switch,FCW2212L0NF
stack-switch,"FCW2212E00Y,FCW2212L0GV"

d) Click Start.

Cisco DNA Center begins to discover and provision the new devices.
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LAN automation configures an IP address on the seed device of VLAN 1. If this VLAN 1 IP address of the seed
device is not reachable fromCisco DNACenter, an error message is displayed on the LANAutomation Status window.
Hover your cursor over the See Details link on this window to see the error details and possible remedial actions.

Step 3 Monitor and review the progress of the devices being provisioned.
a) From the Provision > Devices > Inventory tab, click LAN Automation > LAN Auto Status.

The LAN Automation Status dialog box displays the progress of the devices being provisioned.

The provisioning process might take several minutes for the new devices to be provisioned.Note

b) After all devices have been discovered, added to Inventory, and are in Managed state, click Stop in the LAN
Automation Status dialog box.

The LAN automation process is complete, and the new devices are added to the Inventory.

Peer Device in LAN Automation Use Case

Provision a Dual-Homed Switch

You must always select a peer device to provision the dual-homed switch.

Cisco DNACenter configures the DHCP server on the primary device. Because Cisco DNACenter understands
that the discovered device is connected to both the primary and peer devices, it configures two Layer 3
point-to-point connections when the LAN automation task is stopped. One connection is established between
the discovered device and the primary device; the other connection is established between the discovered
device and the peer device.

If the link between the primary and the peer device is not configured before the LAN automation job is
executed, you must select the interface of the primary device that connects to the peer device as part of the
LAN automation configuration in Cisco DNA Center.

Note
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LAN Automation's Two-Hop Limitation

For the preceding topology, Cisco DNA Center configures the following links:

• A point-to-point Layer 3 routed connection from Discovered device 1 to Primary device

• A point-to-point Layer 3 routed connection from Discovered device 1 to Peer device

• A point-to-point Layer 3 routed connection from Discovered device 1 to Discovered device 2

Consider the scenario where a device—named Discovered device 3—is directly connected below Discovered
device 2. The connection between Discovered device 2 and Discovered device 3 is not configured as part of
the LAN automation job, because it is more than two hops away from Primary device.

Check the LAN Automation Status
You can view the status of in-progress LAN automation jobs.

Before you begin

You must have created and started a LAN automation job.

Step 1 From the Cisco DNA Center home page, choose Provision > Devices.
Step 2 Click the Inventory tab.

All discovered devices are displayed.
Step 3 Click LAN Auto Status.

The status of any running or completed LAN automation jobs is displayed.
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Fabric Overview
A fabric is a logical group of devices that is managed as a single entity in one or multiple locations. Having
a fabric in place enables several capabilities, such as the creation of virtual networks and user and device
groups, and advanced reporting. Other capabilities include intelligent services for application recognition,
traffic analytics, traffic prioritization, and steering for optimum performance and operational effectiveness.

The Cisco DNA Center allows you to add devices to a fabric network. These devices can be configured to act
as control plane, border or edge devices within the fabric network.

Fabric Sites and Fabric Domains
A fabric site is an independent fabric area with a unique set of network devices: control plane, border node,
edge node, wireless controller, ISE PSN. Different levels of redundancy and scale can be designed per site
by including local resources: DHCP, AAA, DNS, Internet, and so on.

A fabric site can cover a single physical location, multiple locations, or only a subset of a location:

• Single location: branch, campus, or metro campus

• Multiple locations: metro campus + multiple branches

• Subset of a location: building or area within a campus

A fabric domain can consist of one or more fabric sites and transit site. Multiple fabric sites are connected to
each other using a transit site.

There are two types of transit sites:

• SD-Access transit: Enables a native SD-Access (LISP, VXLAN, CTS) fabric, with a domain-wide control
plane node for intersite communication.

• IP-based transit: Leverages a traditional IP-based (VRF-LITE,MPLS) network, which requires remapping
of VRFs and SGTs between sites.

Multi-Site Fabric Domain
A multi-site fabric domain is a collection of fabric sites interconnected via a transit site. A fabric site is a
portion of the fabric that has its own set of control plane nodes, border nodes, and edge nodes. A given fabric
site can also include fabricWLC and APs, and a related site-specific ISE PSN. Multiple fabric sites in a single
fabric domain are interconnected using a transit site.

A Software-Defined Access (SDA) fabric may comprise multiple sites. Each site has the benefits of scale,
resiliency, survivability, and mobility. The overall aggregation of sites (that is, the fabric domain) must also
be able to accommodate a very large number of endpoints and scale modularly or horizontally by aggregating
sites contained within each site.

Transit Sites
A transit site is a site that connects two or more fabric sites with each other or connects the fabric site with
external networks (Internet, data center, and so on). There are two types of transit networks:
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• IP transit: Uses a regular IP network to connect to an external network or to connect two or more fabric
sites.

• SDA transit: Uses LISP/VxLAN encapsulation to connect two fabric sites. The SDA transit area may be
defined as a portion of the fabric that has its own Control Plane Nodes, but does not have Edge or Border
Nodes. However, it can work with a fabric that has an external border. Using SDA transit, an end-to-end
policy plane is maintained using SGT group tags.

Create an IP Transit Network
To add a new IP transit network:

Step 1 From the Cisco DNA Center home page, click Provision.
Step 2 Click the Fabric tab.
Step 3 Click the Add Fabric Domain or Transit tab.
Step 4 Choose Add Transit from the pop-up.
Step 5 Enter a transit name for the network.
Step 6 Choose IP-Based as the transit type.

The routing protocol is set to BGP by default.
Step 7 Enter the Autonomous System Number (ASN) for the transit network in the correct ASN format that you choose from

the three radio buttons: ASPLAIN, ASDOT, ASDOT+.
Step 8 Click Save.

Create an SDA Transit Network
To add a new SDA transit network:

Step 1 From the Cisco DNA Center home page, click Provision.
Step 2 Click the Fabric tab.
Step 3 Click the Add Fabric Domain or Transit tab.
Step 4 Choose Add Transit from the pop-up.
Step 5 Enter a transit name for the network.
Step 6 Choose SD-Access as the transit type.
Step 7 Enter the Site for the Transit Control Plane for the transit network. Choose at least one transit map

server.
Step 8 Enter the Transit Control Plane for the transit network.
Step 9 Repeat Step 7 and Step 8 for all map servers that you want to add.
Step 10 Click Save.
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What to do next

After you create an SDA transit, go to the fabric site and connect the sites to which you want to connect the
SDA transit. Go to Provision > Fabric > Fabric Site. Choose the fabric site that you created. Click Fabric
Site > Border > Edit Border > Transit. From the drop-down, point to your SDA transit site and click Add.

Create a Fabric Domain
Cisco DNA Center creates a default fabric domain called Default LAN Fabric.

Before you begin

Ensure that your network has been designed, the policies have been retrieved from the Cisco Integrated
Services Engine (ISE) or created in the Cisco DNA Center, and the devices have been inventoried and added
to the sites.

Step 1 From the Cisco DNA Center home page, click Provision.
Step 2 Click the Fabric tab.
Step 3 Click the Add Fabric Domain or Transit tab.
Step 4 Choose Add Fabric from the pop-up.
Step 5 Enter a fabric name.
Step 6 Choose one fabric site.
Step 7 Click Add.

Fabric Readiness and Compliance Checks
Fabric Readiness Checks

Fabric readiness checks are a set of preprovisioning checks done on a device to ensure that the device is ready
to be added to the fabric. Fabric readiness checks are now done automatically when the device is provisioned.
Interface VLAN and Multi VRF configuration checks are not done as part of fabric readiness checks.

Fabric readiness checks include the following:

• Software version—checks if the device is running with an appropriate software image.

• Software license—checks if the device is running with an appropriate software license.

• Hardware version—checks if the hardware version of the device is supported.

• Image type—checks if the device is running with a supported image type (IOS-XE, IOS, NXOS, Cisco
Controller).

• Loopback interface—checks for the loopback interface configuration on the device. A device must have
a loopback interface configured on it to work with the SDA application.

• Connectivity checks—checks for the necessary connectivity between devices; for example, connectivity
from the edge node to map server, from edge node to border, and so on.

• Existing configuration check (brownfield check)—checks for any configuration on the device that conflicts
with the configuration that is pushed through SD-Access and can result in a failure later.
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For more information on the software versions supported, see Cisco SD-Access Hardware and Software
Compatibility Matrix.

If an error is detected during any of the fabric readiness checks, an error notification is displayed on the
topology area. You can correct the problem and continue with the provisioning workflow for the device.

Fabric Compliance Checks

Fabric compliance is a state of a device to operate according to the user intent configured during the fabric
provisioning. Fabric compliance checks are triggered based on the following:

• Every 24 hours for wired devices and every six hours for wireless devices.

• When there is a configuration change on the wired device.

A configuration change on the wired device triggers an SNMP trap, which in turn triggers the compliance
check. Ensure that you have configured the Cisco DNA Center server as an SNMP server.

The following compliance checks are done to ensure that the device is fabric compliant:

• Virtual Network—checks whether the necessary VRFs are configured on the device to comply with
current state of user intent for Virtual Network on Cisco DNA Center.

• Fabric Role—checks whether the configuration on the device is compliant with the user intent for a fabric
role on Cisco DNA Center.

• Segment—checks the VLAN and SVI configuration for segments.

• Port Assignment—checks the interface configuration for VLAN and Authentication profile.

Configure a Fabric Domain
You can add devices to sites and assign roles to these devices—border, control plane, or edge. You can also
configure IP address pools to enable communication between hosts.

Add a Device to a Fabric
After you have created a fabric domain, you can add fabric sites, and then add devices to the fabric site. You
can also specify whether the devices should act as a control plane node, an edge node or a border node.

It is optional to designate the devices in a fabric domain as control plane nodes or border nodes. You might
have devices that do not play these roles. However, every fabric domain must have at least one control plane
node device and one border node device. In the current release for wired fabric, you can add up to six control
plane nodes for redundancy.

Note

Currently, Cisco Wireless Controller communicates only with two control plane nodes.Note
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Before you begin

Provision the device. To provision a device, click the Provision tab and chooseDevices. The topology displays
a device in gray color if it has passed the fabric readiness checks and is ready to be provisioned.

If an error is detected during any of the fabric readiness checks, an error notification is displayed on the
topology area. Click See more details to check the problem area listed in the resulting window. Correct the
problem and click Re-check to ensure that the problem is resolved. If you update the device configuration as
part of problem resolution, ensure that you resynchronize the device information by performing an Inventory >
Resync for the device.

You can continue to provision a device that has failed the fabric readiness checks.Note

Step 1 From the Cisco DNA Center home page, choose Provision > Fabric.
The window displays all the provisioned fabric domains.

Step 2 From the list of fabric domains, choose a fabric.
The resulting screen displays all the Sites in that fabric domain.

Step 3 Choose a Site.

All devices in the network that have been inventoried are displayed in the topology view. In the topology view, any device
that is added to the fabric is shown in blue.

Step 4 Click a device; the device details window slides in with the following options:
DescriptionOption

Click the toggle button next to this option to enable the selected device as an edge node.Edge Node

Click the toggle the button next to this option to enable the selected device as a border node.
For more information, see the Add Device as a Border Node section.

Border Node

Click the toggle the button next to this option to enable the selected device as a control
plane node.

Control Plane

Allows the following options:Guest Border / Control
Plane • Control Plane: Check this check box if you want the device to act as a control plane.

• Border: Check this check box if you want the device to act as a border node.

• Select One Guest Virtual Network: All guest virtual networks created are listed. Check
the check box of the guest virtual network and click Enable.

Ensure that you have created a guest virtual network in the Policy
application. See Create a Virtual Network.

Note

Click this toggle button to configure Rendezvous Point on device.Rendezvous Point

For more information, see the Add a Device as a Rendezvous Point section.

To configure a device as a fabric-in-a-box, select the Control Plane, Border Node and Edge Node options.

To configure the device as a control plane and a border node, select both Control Plane and Border Node.
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Step 5 Click Save.

What to do next

Once a device is added to the fabric, fabric compliance checks are automatically performed to ensure that the
device is fabric compliant. The topology displays a device that has failed the fabric compliance check in blue
color with a cross-mark beside it. Click See more details on the error notification to identify the problem
area and correct it.

Add a Device as a Border Node
When you are adding a device to a fabric, you can add it in various combinations to act as a control plane,
border node, or edge node as explained in Add a Device to a Fabric, on page 75.

To add a device as a border node:

Step 1 From the Cisco DNA Center home page, click Provision > Fabric.
A list of all provisioned fabric domains is shown.

Step 2 From the list of fabric domains, choose a fabric.
A list of all fabric-enabled sites is shown.

Step 3 From the list of fabric sites, choose a site. The resulting topology view displays all devices in the network that have been
inventoried. In the topology view, any device that is added to the fabric is shown in blue.

Step 4 Click a device and choose Border Node.
Step 5 A slide-in window appears with the name of the device that you want to add.

a) Expand Layer 3 Handoff.
b) Click one of the radio buttons:

• ASPLAIN: Accepts the Autonomous System Number (ASN) in ASPLAIN format.

• ASDOT: Accepts the ASN in ASDOT format.

• ASDOT+: Accepts the ASN in ASDOT+ format.

c) Enter the Local Autonomous Number for the device.
d) From the Select drop-down list, choose an IP address pool.
e) Choose a transit network that is enabled on the border device:

• To enable SDA transit on the border, choose a user-created SDA transit domain from the Select Transit drop-down
list. Click Add.

• To enable IP transit on the border, choose a user-created IP transit domain from the Select Transit drop-down
list. Click Add.

Choose an IP pool from Design Hierarchy. The selected pool will be used to automate IP routing between the
border node and IP peer. Click Add Interface to enter interface details on the next screen.

ChooseExternal Interface from the drop-down list. Enter theRemote AS Number. Check theVirtual Network
from the list. This virtual network should be advertised by the border to the remote peer. You can select one,
multiple, or all virtual networks. Click Save.
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f) By default, a border node is designated as an internal border, wherein it acts as a gateway to known traffic and imports
specific external routes. A border node can be configured to be an external border wherein it acts as a gateway to all
unknown traffic, without importing any external routes. A border node can also have a combined role of internal and
external borders.

• Check both Default to all Virtual Networks and Do not Import External Routes check boxes to designate
the border node as an external border, providing connectivity to unknown networks..

• Do not check both Default to all Virtual Networks and Do not Import External Routes check boxes, to
designate the border as an internal border, operating as a gateway for specific network addresses.

• Check the Default to all Virtual Networks check box to designate this border node as an internal and external
border. It acts as a gateway to all known and unknown traffic sent from the edge nodes. (Do not check the Do
not Import External Routes check box.)

Step 6 (Optional) Perform this step only if you are connecting a non-fabric network to the fabric network or you are migrating
from a traditional network to a Software-Defined Access network. Click Layer 2 Handoff. Click one of the virtual
networks.

All the virtual networks and the number of pools in each virtual network are displayed.

If a check box in the virtual network list is not clickable, it indicates that the segments under the virtual network have
been handed off to an external VLAN.

After you select a virtual network, the list of IP address pools present in the virtual network appears. A list of interfaces
through which you can connect nonfabric devices is displayed.

Enter the External VLAN number into which the fabric must be extended. A virtual network can only be handed off on
a single interface. The same virtual network cannot be handed off through multiple interfaces.

Click Save.

Step 7 Click Add.

Configure Host Onboarding
TheHost Onboarding tab lets you configure settings for the various kinds of devices or hosts that can access
the fabric domain.

In this tab, you can:

• Select an authentication template to apply to the fabric. These templates are predefined configurations
that are retrieved from Cisco ISE. After selecting the authentication template, click Save.

• Associate IP address pools to virtual networks (default, guest, or user defined), and click Update. The
IP address pools displayed are site-specific pools only.

• Specify wireless SSIDs within the network that hosts can access. You can select the guest or enterprise
SSIDs and assign address pools, and click Save.

• Apply specific configurations for each port for the specific type of device that is connecting to the fabric
domain. To do this, select the ports that need a specific assignment, click Assign, and choose the port
type from the drop-down list.

Note the following constraints:
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• Cisco SD-Access deployments support only APs, extended nodes, user devices (such as a single
computer or a single computer plus phone), and single servers.

• Each port can learn up to a maximum of 10 MAC addresses.

• Servers with internal switches or virtual switches are not supported.

• Other networking equipment (such as hubs, routers, and switches) is not supported.

Select Authentication Template
You can select the authentication template that will apply to all the devices in the fabric domain.

Step 1 From the Authentication Template section, choose an authentication template for the Site:

• Closed Authentication: Any traffic prior to authentication is dropped, including DHCP, DNS, and ARP.
• Low Impact: Security is added by applying an ACL to the switch port, to allow very limited network access prior
to authentication. After a host has been successfully authenticated, additional network access is granted.

• No Authentication
• Open Authentication: A host is allowed network access without having to go through 802.1X authentication.

Starting with Cisco DNA Center Release 1.3.3.0, you can edit the settings of the selected authentication template to
address Site-specific authentication requirements.

Step 2 (Optional) To edit the settings of the chosen authentication method, click Edit.

A window slides in, displaying the parameters of the selected authenticationmethod: First Authentication Order, 802.1x
to MAB Fallback, Wake on LAN, and Number of hosts.

Number of hosts specifies the number of data hosts that can be connected to a port. With Single selected, you
can have only one data client on the port. With Unlimited selected, you can have multiple data clients and one
voice client on the port.

Note

Do the required changes and click Save.

The edit window closes.

The saved modifications apply only to the Site for which the authentication template is edited.Note

Step 3 Click Set as Default.

Starting from Cisco DNA Center Release 1.3.3.0, the Hitless Authentication Change feature lets you switch
from one authentication method to another without removing the devices from the fabric.

Note

Associate Virtual Networks to the Fabric Domain
IP address pools enable host devices to communicate within the fabric domain.
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When an IP address pool is configured, Cisco DNA Center immediately connects to each node to create the
appropriate switch virtual interface (SVI) to allow the hosts to communicate.

You cannot add an IP address pool, but you can configure a pool from the ones that are listed. The IP address
pools listed here were created when the network is designed.

Step 1 From the Virtual Networks section on the Host Onboarding tab, click a virtual network (VN).
Step 2 Review the following fields in the Edit Virtual Network window:

DescriptionField

Displays IP address pools.IP Pool Name

From the list of IP address pools, choose the ones that should be a part of the virtual
network.

Displays the authentication policy for the virtual network.Authentication Policy

Displays the type of traffic enabled on the virtual network.Traffic Type

Choose to send voice or data traffic through the virtual network.

Displays which group the IP pool belongs to.Groups

Enables or disables the selected IP Pool as a Wireless Pool.Wireless Pool

If enabled, you can choose from only the defined Wireless Pool while configuring
Wireless SSID for the fabric.

Displays whether Layer 2 flooding has been enabled or disabled.Layer-2 Extension

Enables Layer 2 MAC address registration for the IP pool and Layer 2 VNI. Layer 2
Extension is enabled by default and cannot be disabled.

Displays whether Layer 2 flooding has been enabled or disabled.Layer-2 Flooding

Layer 2 flooding is disabled by default.

Step 3 Click Add to associate one or more IP address pool to the selected virtual network.

Fill in the required fields in the resulting window:

• Choose the IP pool, Traffic type, and Groups from the corresponding drop-down list.

• Check the Layer-2 Flooding check box to enable Layer 2 flooding.

• Check the Critical Pool check box to include this IP pool in the critical IP address pool.

• Check the Common Pool check box to enable this IP pool to be shared across multiple sites in a fabric.

Cisco DNA Center Release 1.3.3.0 introduces the Intersite Layer 2 Handoff feature, which supports sharing an IP
pool among multiple sites in a fabric.

Step 4 Click Update to save the settings. The settings you specify here are deployed to all devices on the virtual network.
Step 5 After associating IP pools to all virtual networks, click Save.
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Configure Wireless SSIDs for the Fabric Domain

Step 1 From the Wireless SSID section, specify the wireless SSIDs within the network that the hosts can access.
Step 2 Click Choose Pool and select an IP pool reserve for the SSID.
Step 3 From the Assign SGT drop-down list, choose a scalable group for the SSID.
Step 4 Check the Enable Wireless Multicast check box to enable wireless multicast on the SSIDs.

Configure Ports Within the Fabric Domain
The Select Port Assignment section lets you configure each access device on the fabric domain. You can
specify network behavior settings for each port on each device.

The settings you make here for the ports override the general settings you made for the device in the Virtual
Networks section.

Note

Step 1 From the Select Fabric Device section, choose the access device that you want to configure.
The ports available on the device are displayed.

Step 2 Choose the ports on the device and specify the allowed IP address pool, the groups that have been provisioned, the voice
or data pool, and the authentication type for the port.

Step 3 Click Save.

Configure an Extended Node Device
Extended nodes are those devices that run in Layer 2 switch mode and do not support fabric technology
natively. An extended node is configured by an automated workflow. After configuration, the extended node
device is displayed on the fabric topology view. Port Assignment on the extended nodes is done on the Host
Onboarding window.

Extended node devices support multicast traffic.

Starting with Cisco DNACenter 1.3.3.0, policy extended nodes are supported. You can select aGroup during
port assignment for the policy extended node.

Cisco Catalyst Industrial Ethernet 3400 and IE 3400 Heavy Duty series switches that run Cisco IOS XE
17.1.1s or later versions of the software are policy extended node devices.

Cisco Digital Building series switches, Cisco Catalyst 3560-CX switches, and Cisco Industrial Ethernet 4000,
4010, and 5000 series switches are not policy extended node devices. They do not support Cisco TrustSec
and Group selection during port assignment.
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Steps to Configure an Extended Node
When configured as a fabric edge, Cisco Catalyst 9300, Cisco Catalyst 9400, and Cisco Catalyst 9500 series
switches support extended nodes.

The minimum supported software version on the edge nodes that support policy extended nodes is Cisco IOS
XE 17.1.1s.

Cisco Catalyst 9200 series switches that are configured as fabric edge nodes do not support extended node
devices.

Note

The following are the minimum supported software versions on the extended nodes:

• Cisco Industrial Ethernet 4000, 4010, 5000 series switches: 15.2(7)E0s

• Cisco Catalyst IE 3400, 3400 Heavy Duty (X-coded and D-coded) series switches: IOS XE 17.1.1s

• Cisco Catalyst IE 3300 series switches: IOS XE 16.12.1s

• Cisco Digital Building series switches, Cisco Catalyst 3560-CX switches: 15.2(7)E0s

Ensure the following before configuring a policy extended node:

• The minimum software version required on a policy extended node device and on the edge device
supporting the policy extended node is Cisco IOS XE 17.1.1s.

• Both the policy extended node and the edge node supporting it must have the Network Advantage and
DNA Advantage license levels enabled.

Step 1 Configure a network range for the extended node. See Configure IP Address Pools. This comprises adding an IP address
pool and reserving the IP pool at the site level. Ensure that the CLI and SNMP credentials are configured.

Step 2 Assign the extended IP address pool to INFRA_VN under the Fabric > Host Onboarding tab. Choose extended node
as the pool type.

Cisco DNA Center configures the extended IP address pool and VLAN on the supported fabric edge device. This enables
the onboarding of extended nodes.

Step 3 Configure the DHCP server with the extended IP address pool and Option 43. Ensure that the extended IP address pool
is reachable from Cisco DNA Center.

For a detailed description of Option 43, see DHCP Controller Discovery, on page 3.Note

Step 4 Connect the extended node device to the fabric edge device. You can have multiple links from the extended node device
to the fabric edge.

Step 5 (Optional) Create a port channel.

Complete this step only if the global authentication mode for the fabric is not No Authentication. Authentication modes
can be Open, Low Impact, or Closed.

Create a port channel on the fabric edge node connected to the extended node. To create a port channel, complete the
following steps:
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a) Go to Provision > Fabric > Fabric Infrastructure and select the fabric edge node. A window with the device name
as the title slides in.

b) Click Create Port Channel.
c) Fill in all the fields in the window. Note that LACP does not work for extended node onboarding.

• Do not select LACP.

• Select PAGP for all devices.

Starting with Cisco IOS XE Release 17.1.1s, IE 3300 and IE 3400 devices support PAGP.

• Select Static mode for IE 3300 and IE 3400 devices if they are running versions earlier than Cisco IOS XE
17.1.1s.

d) Go to Provision > Fabric > Host Onboarding and select the port channel that is created. In the resulting window,
select Extended Node as the Connected Device Type.

This creates a port channel on the fabric edge node to onboard an extended device.

Step 6 Power up the extended node device if it has no previous configuration. If the extended node device has configurations,
write-erase the previous configurations and reload the extended node device.

Cisco DNA Center adds the extended node device to the Inventory and assigns the same site as the fabric edge. The
extended node device is then added to the fabric. Now the extended node device is onboarded and ready to be managed.

After the configuration is complete, the extended node appears in the fabric topology with a tag (X) to indicate that it is
an extended node.

If there are errors in the workflow while configuring an extended node, an error notification is displayed as
a banner on the topology window.

Click See more details to see the error.

A Task Monitor window slides in, displaying the status of the extended node configuration task.

Click See Details to see the cause of error and possible solution.

Configure a Port Channel
A group of ports bundled together to act as a single entity is called a port channel. Port channels between a
fabric edge and its remotely connected devices like extended nodes or servers increase the connection resiliency
and bandwidth.
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Create a Port Channel
Do the following steps only when authentication is Closed Authentication. Note that the following steps are
automated for other authentiation modes.

Step 1 Go to Provision > Fabric > Fabric Infrastructure tab and select the fabric edge node.

A window with the device name as the title slides in.

Step 2 Select the Port Channel tab and click Create Port Channel.
Step 3 From the list of ports displayed, select the ports to be bundled and an appropriate protocol.

For IE 3300 or IE 3400 extended nodes, select On as the protocol.

For other extended nodes, select PAGP as the protocol.

Step 4 Click Done.

A new port channel is created and is displayed on the window.

Step 5 Navigate to Provision > Fabric > Host Onboarding page. Select the port channel that is created.

In the resulting window, selectExtended Node as theConnected Device Type if you are creating a port channel between
a fabric edge node and an extended node.

Select Server as the Connected Device Type if you are creating a port channel between a fabric edge node and a server.

Step 6 Click Update.

Update a Port Channel

Before you begin

Ensure that at least one member interface exists before you update a port channel.

Step 1 Go to Provision > Fabric > Fabric Infrastructure tab and select the fabric edge node.

A window with the device name as the title slides in.

Step 2 Select the Port Channel tab.
Step 3 From the list of port channels displayed, select the port channel to be updated.

The resulting window displays all the interfaces and the status of the selected port channel.

Step 4 You can either add interfaces to or delete existing interfaces on the port channel. Do the desired update on the port channel.
Step 5 Click Done.

Delete a Port Channel

Step 1 From the Home Page, navigate to Provision > Fabric > Fabric Infrastructure topology view.
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Step 2 Click on the device whose port channel is to be deleted.

A window with the device name slides-in.

Step 3 Select the Port Channel tab.

The resulting Port Channel view lists all the existing Port Channels.

Step 4 Select the Port Channel to be deleted and click Delete.
Step 5 Click Yes on the delete confirmation message that appears.

This deletes the Port Channel.

Multicast Overview
Multicast traffic is forwarded in different ways:

• Through shared trees by using a rendezvous point. PIM SM is used in this case.

• Through shortest path trees (SPT). PIM source-specific multicast (SSM) uses only SPT. PIM SM switches
to SPT after the source is known on the edge router that the receiver is connected to.

See IP Multicast Technology Overview.

Configure Multicast
Starting Release 1.3.3.0, Cisco DNA Center provides a workflow that helps enable group communication or
multicast traffic in the virtual networks. The workflow also allows you to choose multicast implementation
in the network: Native Multicast or Headend Replication.

Step 1 From the Cisco DNA Center home page, click Provision. The window displays all provisioned fabric domains.
Step 2 From the list of fabric domains, choose a fabric. You can view all the Sites configured for the fabric . Select the Site

for which you want to configure multicast.
Step 3 Click the gear icon next to the selected Site, on the Fabric-Enabled Sites pane.
Step 4 Select Configure Multicast from the drop-down list.

The resulting window starts a work flow for multicast configuration.

Step 5 Choose the method of mulitcast implementation for the network: Native Multicast or Head-end replication and click
Next.

Step 6 From the list of virtual networks available, select the virtual network on which you want multicast to be setup. Click
Next.

Step 7 Select an IP address pool from the IP Pools drop-down list. The selected IP address pool is associated with the chosen
Virtual Network. Click Next.

Step 8 Select the type of multicast to be implemented:

• SSM (Source Specific Multicast)

• ASM (Any Specific Multicast)
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Click Next.

Step 9 On selecting SSM, configure the SSM list by adding an IP group range for each Virtual Network. You can add
multiple IP group ranges for a virtual network.

a)

Choose an IP group range between 225.0.0.0 to 239.255.255.255.

Click Next.

b) On selecting ASM, choose the type of Rendezvous Point (RP):

• Internal RP

• External RP

Click Next.

If you choose Internal RP, do the following:

a. Select the devices that you need configured as internal rendezvous point. The second rendezvous point that you
select will be the redundant rendezvous point. Click Next.

b. Assign internal rendezvous points to each of the listed Virtual Networks. Click Next.

If you choose External RP, do the following:

a. Enter the IP address of the external rendezvous point.

b. Click Next.

Step 10 Review themulticast settings displayed on the Summary page andmodify, if required, before submitting the configuration.

Click Finish to complete the multicast configuration.

Intersite Layer 2 Handoff
The intersite Layer 2 handoff feature lets you extend an IP subnet across multiple sites in a fabric. The same
IP subnet coexists across sites in a fabric.

Note the following restrictions:

• A device that is configured as fabric-in-a-box or as a border and an edge cannot be used for intersite
Layer 2 handoff.

• Intersite Layer 2 handoff and SDA transit together are not supported.

Before you begin

• Ensure that all the devices are discovered and provisioned and that IP pools are reserved on the site from
which the IP pools will be shared.

• Ensure that the sites that share an IP pool are underlay connected. Without this connection between the
borders, DHCP might not work on the hosts that try to get IP addresses on the common subnet.

• Ensure that underlay multicast is configured, which is required for Layer 2 flooding to work. Underlay
multicast gets configured during the LAN automation workflow.
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Step 1 Associate Virtual Networks to the Fabric Domain. Ensure that you check the Layer-2 Flooding and Common Pool
check boxes.

With Layer-2 Flooding and Common Pool enabled, the IP pool becomes eligible to be extended to other sites.

Step 2 Configure Layer 2 handoff on the border.

From the Provision > Fabric > Fabric Infrastructure tab, select the border device on which the intersite Layer 2
handoff is to be configured.

From the L2 Handoff section, select the virtual network to which the common IP pool is associated.

Configure the external interface of the border that connects it to other borders across sites.

Check the Extend the subnet to other site check box and assign an external VLAN number to the common IP pool.

Step 3 Repeat the preceding steps for the other sites that share the IP pool.

Ensure that you specify the same external VLAN number on all the interconnected borders.

Applications

Applications and Application Sets
Applications are the software programs or network signaling protocols that are used in your network. Cisco
DNA Center supports all of the applications in the Cisco Next Generation Network-Based Application
Recognition (NBAR2) library of approximately 1400 distinct applications.

Applications are grouped into logical groups called application sets. An application set can be assigned a
business relevance within a policy.

Applications are also mapped into industry standard-based traffic classes, as defined in RFC 4594, that have
similar traffic treatment requirements. The traffic classes define the treatments (such as Differentiated Services
Code Point [DSCP] marking, queuing, and dropping) that will be applied to the application traffic, based on
the business relevance group that is assigned.

If you have additional applications that are not included in Cisco DNA Center, you can add them as custom
applications and assign them to application sets. For more information, see Custom Applications, on page
88. You can also create custom application sets to contain any applications that you want.

For more information about NBAR2, see https://www.cisco.com/c/en/us/products/ios-nx-os-software/
network-based-application-recognition-nbar/index.html.

Unidirectional and Bidirectional Application Traffic
Some applications are completely symmetrical and require identical bandwidth provisioning on both ends of
the connection. Traffic for such applications is described as bidirectional. For example, if 100 kbps of
Low-Latency Queueing (LLQ) is assigned to voice traffic in one direction, 100 kbps of LLQ must also be
provisioned for voice traffic in the opposite direction. This scenario assumes that the same Voice over IP
(VoIP) coder-decoders (codecs) are being used in both directions and do not account for multicast
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Music-on-Hold (MoH) provisioning. However, certain applications, such as Streaming Video and multicast
MoH, are most often unidirectional. Therefore, it might be unnecessary, and even inefficient, to provision
any bandwidth guarantees for such traffic on a branch router for the branch-to-campus direction of traffic
flow.

Cisco DNACenter allows you to specify whether an application is unidirectional or bidirectional for a particular
policy.

On switches and wireless controllers, NBAR2 and custom applications are unidirectional by default. However,
on routers, NBAR2 applications are bidirectional by default.

Custom Applications
Custom applications are applications that you add to Cisco DNA Center. An orange bar is displayed next to
custom applications to distinguish them from the standard NBAR2 applications and application sets. For wired
devices, you can define applications based on server name, IP address and port, or URL. You cannot define
custom applications for wireless devices.

When you define an application according to its IP address and port, you can also define a DSCP value and
port classification.

To simplify the configuration process, you can define an application based on another application that has
similar traffic and service-level requirements. Cisco DNA Center copies the other application's traffic class
settings to the application that you are defining.

Cisco DNA Center does not configure ACLs for port numbers 80, 443, and 8080 even if they are defined as
part of a custom application. If the custom application has a transport IP defined, Cisco DNACenter configures
the application on the devices.

For a custom application to be programmed on devices when a policy is deployed, you must assign the custom
application to one of the application sets defined in the policy.

Note

Favorite Applications
Cisco DNA Center allows you to flag applications that you want to configure on devices before all other
applications, except custom applications. Flagging an application as a favorite helps to ensure that the QoS
policies for your favorite applications get configured on devices. For more information, see Processing Order
for Devices with Limited Resources.

Although there is no limit to the number of applications that you can mark as favorite, designating only a
small number of favorite applications (for example, less than 25) helps to ensure that these applications are
treated correctly from a business-relevance perspective in deployments with network devices that have limited
ternary content addressable memory (TCAM).

Favorite applications can belong to any business-relevance group or traffic class and are configured
system-wide, not on a per-policy basis. For example, if you flag the Cisco Jabber video application as a
favorite, the application is flagged as a favorite in all policies.

Keep in mind that not only can business-relevant applications be flagged as favorites, even business irrelevant
applications can be flagged as such. For example, if an administrator notices a lot of unwanted Netflix traffic
on his network, the administrator might chose to flag Netflix as a favorite application (despite it being assigned
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as business-irrelevant). In this case, Netflix will be programmed into the device policies before other
business-irrelevant applications, ensuring that the business intent of controlling this application is realized.

Configure Applications and Application Sets
The following subsections describe the various tasks that you can perform in the context of applications and
application sets.

Change an Application's Settings
You can change the application set or traffic class of an existing NBAR or custom application.

Step 1 From the Cisco DNA Center home page, click Provision > Services > Application Visibility > Application.
Step 2 Use the Search, Show, or View By fields to locate the application that you want to change.
Step 3 Click the application name.
Step 4 In the dialog box, change one or both settings:

• Traffic Class: Choose a traffic class from the drop-down list. Valid traffic classes are BROADCAST_VIDEO,
BULK_DATA, MULTIMEDIA_CONFERENCING, MULTIMEDIA_STREAMING, NETWORK_CONTROL,
OPS_ADMIN_MGMT, REAL_TIME_INTERACTIVE, SIGNALING, TRANSACTIONAL_DATA,
VOIP_TELEPHONY.

• Application Set: Choose an application set from the drop-down list. Valid application sets are authentication-services,
backup-and-storage, collaboration-apps, consumer-browsing, consumer-file-sharing, consumer-gaming,
consumer-media, consumer-misc, consumer-social-networking, database-apps, desktop-virtualization, email,
enterprise-ipc, file-sharing, generic-browsing, generic-media, generic-misc, tunneling, local-services, naming-services,
network-control, network-management, remote-access, saas-apps, signaling, software-development-tools,
software-updates, streaming-media.

Step 5 Click Save.

Create a Server Name-Based Custom Application
If you have applications that are not in Cisco DNA Center, you can add them as custom applications.

Step 1 From the Cisco DNA Center home page, click Provision > Services > Application Visibility.
Step 2 Click the Application tab.
Step 3 Click Add Application.
Step 4 In the dialog box, provide the necessary information in the following fields:

DescriptionField

Name of the custom application. The name can contain up to 24 alphanumeric characters,
including underscores and hyphens. The underscore and hyphen are the only special
characters allowed in the application name.

Application name

Method by which users access the application. Choose Server Name for applications that
are accessible through a server.

Type
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DescriptionField

Name of the server that hosts the applicationServer name

Application with similar traffic-handling requirements. Click the radio button to select
this option, and then select an application from the drop-down list. Cisco DNA Center
copies the other application's traffic class to the application that you are defining.

Similar to

Traffic class to which the application belongs. Valid values are BULK_DATA,
TRANSACTIONAL_DATA, OPS_ADMIN_MGMT, NETWORK_CONTROL,
VOIP_TELEPHONY, MULTIMEDIA_CONFERENCING,
MULTIMEDIA_STREAMING,BROADCAST_VIDEO,REAL_TIME_INTERACTIVE,
and SIGNALING.

Traffic class

Application set where you want the application to reside. Valid application sets are
authentication-services, backup-and-storage, collaboration-apps, consumer-browsing,
consumer-file-sharing, consumer-gaming, consumer-media, consumer-misc,
consumer-social-networking, database-apps, desktop-virtualization, email, enterprise-ipc,
file-sharing, generic-browsing, generic-media, generic-misc, tunneling, local-services,
naming-services, network-control, network-management, remote-access, saas-apps,
signaling, software-development-tools, software-updates, streaming-media.

Application set

Step 5 Click OK.

Create an IP Address and Port-Based Custom Application
If you have applications that are not in Cisco DNA Center, you can add them as custom applications.

Step 1 From the Cisco DNA Center home page, click Provision > Services > Application Visibility.
Step 2 Click the Application tab.
Step 3 Click Add Application.
Step 4 In the Application name field, enter a name for the custom application. The name can contain up to 24 alphanumeric

characters, including underscores and hyphens. The underscore and hyphen are the only special characters allowed in
the application name.

Step 5 In the Type area, click the Server IP/Port radio button to indicate that the application is accessible through an IP
address and port.

Step 6 Check the DSCP check box and define a DSCP value. If you do not define a value, the default value is Best Effort.
Best-effort service is essentially the default behavior of the network device without any QoS.

Step 7 Check the IP/Port Classifiers check box to define the IP address and subnet, protocol, and port or port range for an
application. Valid protocols are IP, TCP, UDP, and TCP/UDP. If you select the IP protocol, you do not define a port
number or range. Click to add more classifiers.

Step 8 Define your application traffic-handling requirements using one of the following methods:

• Similar To: If your application has similar traffic-handling requirements as an existing application, click the
Similar To radio-button and choose the application from the drop-down list. Cisco DNA Center copies the traffic
class of the other application to the application that you are defining.

• Traffic Class: If you know the traffic class that you want to define for your application, click the Traffic Class
radio button and choose the traffic class from the drop-down list. Valid values are BULK_DATA,
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TRANSACTIONAL_DATA, OPS_ADMIN_MGMT, NETWORK_CONTROL, VOIP_TELEPHONY,
MULTIMEDIA_CONFERENCING, MULTIMEDIA_STREAMING, BROADCAST_VIDEO,
REAL_TIME_INTERACTIVE, and SIGNALING.

Step 9 From the Application Set drop-down list, choose the application set to which the application will belong. Valid
application sets are authentication-services, backup-and-storage, collaboration-apps, consumer-browsing,
consumer-file-sharing, consumer-gaming, consumer-media, consumer-misc, consumer-social-networking, database-apps,
desktop-virtualization, email, enterprise-ipc, file-sharing, generic-browsing, generic-media, generic-misc, tunneling,
local-services, naming-services, network-control, network-management, remote-access, saas-apps, signaling,
software-development-tools, software-updates, streaming-media.

Step 10 Click OK.

Create a URL-Based Custom Application
If you have applications that are not in Cisco DNA Center, you can add them as custom applications.

Step 1 From the Cisco DNA Center home page, click Provision > Services > Application Visibility.
Step 2 Click the Application tab.
Step 3 Click Add Application.

The Add Application dialog box appears.

Step 4 In the Application name field, enter the name of the custom application. The name can contain up to 24 alphanumeric
characters, including underscores and hyphens. The underscore and hyphen are the only special characters allowed in
the application name.

Step 5 For Type, click the URL radio button.
Step 6 In the URL field, enter the URL used to reach the application.
Step 7 Configure the traffic class:

• To use the same traffic class as another application with similar traffic-handling requirements, click the Similar To
radio button and choose an application from the drop-down list.

• To specify the traffic class, click the Traffic Class radio button and choose a traffic class from the drop-down list.
Valid values are BULK_DATA, TRANSACTIONAL_DATA, OPS_ADMIN_MGMT, NETWORK_CONTROL,
VOIP_TELEPHONY,MULTIMEDIA_CONFERENCING,MULTIMEDIA_STREAMING,BROADCAST_VIDEO,
REAL_TIME_INTERACTIVE, and SIGNALING.

Step 8 From the Application Set drop-down list, choose an application set in which you want the application to reside.
Step 9 Click OK.

Edit or Delete a Custom Application
If required, you can change or delete a custom application.
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You cannot delete a custom application that is directly referenced by an application policy. Application policies
typically reference application sets and not individual applications. However, if a policy has special definitions
for an application (such as a consumer or producer assignment or bidirectional bandwidth provisioning), the
policy has a direct reference to the application. As such, you must remove the special definitions or remove
the reference to the application entirely before you can delete the application.

Note

Step 1 From the Cisco DNA Center home page, click Provision > Services > Application Visibility.
Step 2 Click the Application tab.
Step 3 Use the Search, Show, or View By fields to locate the application that you want to change.
Step 4 To edit the application:

a) Click the application name and make the required changes. For information about the fields, see Create a Server
Name-Based Custom Application, on page 89, Create an IP Address and Port-Based Custom Application, on page
90, or Create a URL-Based Custom Application, on page 91.

b) Click OK

Step 5 To delete the application: Click in the application box, and then click OK to confirm.

Mark an Application as Favorite
You can mark an application as a favorite to designate that the application's QoS configuration must be
deployed to devices before other applications' QoS configuration. An application marked as favorite has a
yellow star next to it.

When you add or edit a policy, applications marked as a favorites are listed at the top of the application set.

Applications are configured system-wide, not on a per-policy basis. For more information, see Favorite
Applications, on page 88.

Step 1 From the Cisco DNA Center home page, click Provision > Services > Application Visibility.
Step 2 Click the Application tab.
Step 3 Locate the application that you want to mark as a favorite.
Step 4 Click .

Create a Custom Application Set
If none of the application sets fits your needs, you can create a custom application set.

Step 1 From the Cisco DNA Center home page, click Provision > Services > Application Visibility.
Step 2 Click the Application Sets tab.
Step 3 Click Add Application Set.
Step 4 In the dialog box, enter a name for the new application set.
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Cisco DNA Center creates the new application set; however, it will have no applications in it.

Step 5 Click OK.
Step 6 Use the Search, Show, or View By fields to locate the application set.
Step 7 Locate the applications that you want to move into the new application set.
Step 8 Check the check box next to the applications that you want to move.
Step 9 Drag and drop the applications into the new application set.

Edit or Delete a Custom Application Set
If required, you can change or delete a custom application set.

You cannot delete a custom application set that is referenced by an application policy. You must remove the
application set from the policy before you delete the application set.

Note

Step 1 From the Cisco DNA Center Home page, click Provision > Services > Application Visibility.
Step 2 Click the Application Sets tab.
Step 3 Use the Search, Show, or View By fields to locate the application set that you want to change.
Step 4 Do one of the following:

• To edit the application set, drag and drop applications into or out of the application set. Click OK to confirm each
change.

• To delete the application set, click in the application set box, and then click OK to confirm.

Application Hosting

About Application Hosting
Application Hosting lets you manage the lifecycle of third-party applications on devices managed by Cisco
DNACenter. This release allows customers to bring in third-party docker applications on Catalyst 9300 Series
switches with Cisco IOS-XE software version 16.12.1s.

Prerequisites for Application Hosting
To enable application hosting on a device, the following prerequisites must be completed:

• Configure HTTPS credentials on the device. You can configure the HTTPS credentials while manually
adding the device to Cisco DNA Center, or you can edit the device credentials. For more information,
see Update Network Device Credentials.
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• Configure the local authentication or AAA server for user authentication. Youmust configure the username
and password with privileged EXECmode (level 15). For more information, see Configure Authentication
and Policy Servers in the Cisco Digital Network Architecture Center Administrator Guide.

• Ensure the device has an external USB SSD pluggable storage support.

Three-node Cisco DNA Center clusters do not support application hosting high
availability (HA). Only standalone appliances support this feature.

Note

View Device Readiness to Host an Application
You must check the readiness of the Cisco Catalyst 9300 Series switch to host the application before you can
install an application on the switch.

Step 1 From the Cisco DNA Center home page, choose Provision > Services > App Hosting.
Step 2 Click All Devices.
Step 3 View the list of devices that are capable of hosting applications. The App Hosting Status indicates the readiness of the

device to host application. If the status shows Not Ready, click the status to view the reason.

Add an Application
You can add a Cisco package or a docker application.

Before you begin

• Cisco PackageApplication: Youmust package the application using IOS SDK tools so that the application
is compatible with IOS XE operating system.

• Docker Application: You must save the docker image as a tar file. Use the following command to store
the docker image as a tar file:
docker save -o <path for generated tar file> <image name:tag>
Example: docker save -o alpine-tcpdump.tar itsthenetwork/alpine-tcpdump:latest

Step 1 From the Cisco DNA Center home page, choose Provision > Services > App Hosting.
Step 2 Click New Application.
Step 3 Choose the application Type and Category from the drop-down list.
Step 4 Click Select and choose the application to be uploaded.
Step 5 Click Upload.

You can view the newly added application in the App Hosting page.
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Install an Application on a Cisco Catalyst 9300 Device
Cisco DNA Center allows you to install an application on a Cisco Catalyst 9300 Series switch.

Before you begin

• Complete the prerequisites. For more information, see Prerequisites for Application Hosting, on page
93.

• Add the application to Cisco DNA Center. For more information, see Add an Application, on page 94.

• Check the readiness of the switch to host the application. For more information, see ViewDevice Readiness
to Host an Application, on page 94.

Step 1 From the Cisco DNA Center home page, choose Provision > Services > App Hosting.
Step 2 Choose the application and click Install.
Step 3 Choose the devices on which you want to install the application and click Next.
Step 4 Complete the following settings in the Configuration App tab:

• App Networking

• Device Network: Click the Select Network drop-down list and choose a VLAN to configure the application.

• App IP address: Choose Static or Dynamic from the Address Type drop-down list. If you choose Static,
click the thumbnail icon and enter the IP Address, Gateway, Prefix/Mask, and DNS for the application.

• Resource Allocation: Click the Allocate all resources available on a device or Customize resource allocation
check box. You can check theCustomize resource allocation check box, andmodify the maximumCPU,Memory,
and Persistent Storage values to a lower value.

• (Optional)Custom Settings: Applicable only for Cisco package applications. Enter the configuration details for the
attributes that are specified by the application.

• (Optional) App Data: Browse and upload the application specific files. To identify the required application specific
files, see the relevant application document.

• Docker Runtime Options: Enter the docker runtime options required by the application.

Step 5 Click Next and review the application configuration settings in the Confirm screen.
Step 6 Click Finish.
Step 7 ClickYes in the installationConfirmationwindow to complete the application installation on the selected Cisco Catalyst

9300 devices.

What to do next

The installation of the application also modifies the IOS-XE configuration on the device. This change in the
running configuration must be copied to the startup configuration to ensure applications function as expected
post a router reload. After the application installation is completed successfully, use the Template Editor to
copy the running configuration to the startup configuration.
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Update an Application
You can update the application added in Cisco DNA Center.

Step 1 From the Cisco DNA Center home page, choose Provision > Services > App Hosting.

You can view the available applications in the App Hosting page.

Step 2 Choose the application that you want to update.
Step 3 Click Update Application.
Step 4 Choose the application Type and Category from the drop-down list.
Step 5 Click Select and choose a new version of the application to be uploaded.
Step 6 Click Upload.

Uninstall an Application from a Cisco Catalyst 9300 Device
You can uninstall an application from a Cisco Catalyst 9300 Series switch.

Step 1 From the Cisco DNA Center home page, choose Provision > Services > App Hosting.
Step 2 Choose the application and click Manage to view the devices that use the application.
Step 3 Choose the devices from which you want to uninstall the application.
Step 4 From the Actions drop-down list, choose Uninstall App.

Delete an Application
You can delete an application from Cisco DNA Center.

Before you begin

You must uninstall the application from all the devices using the application. For more information, see
Uninstall an Application from a Cisco Catalyst 9300 Device, on page 96

Step 1 From the Cisco DNA Center home page, choose Provision > Services > App Hosting.

You can view the available hosted applications in the App Hosting page.

Step 2 Choose the application that you want to delete.
Step 3 Click Delete Applicaiton.
Step 4 Click OK in the confirmation dialog box.

The application will be deleted only if it is not used by any of the devices managed by Cisco DNA Center. Otherwise,
an error message shows the number of devices using the application.
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Click Cancel in the confirmation dialog box and uninstall the application. For more information, see Uninstall an
Application from a Cisco Catalyst 9300 Device, on page 96

Download App Logs
You can download app logs from Cisco DNA Center.

Step 1 From the Cisco DNA Center home page, choose Provision > Services > App Hosting.
Step 2 Click All Devices.

You can view the list of devices that are capable of hosting applications.

Step 3 Click App logs to download the application logs from Cisco DNA Center.
Step 4 In the App Logs popup window, choose the App logs file that you want to download from the drop-down list and click

Download.

Download Device Tech Support Logs
You can download the device tech support logs from Cisco DNA Center for troubleshooting purposes.

Step 1 From the Cisco DNA Center home page, choose Provision > Services > App Hosting.
Step 2 Click All Devices.

You can view the list of devices that are capable of hosting applications.

Step 3 Click Tech Support logs to download the device tech support logs from Cisco DNA Center.
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