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Limitations and Restrictions of Assurance
Assurance does not support devices that are connected through Network Address Translation (NAT).

Basic Setup Workflow
Before you begin using the Assurance application, you must set up Cisco DNA Center to use Assurance.

This chapter provides the basic tasks you must do to set up Assurance. Use this chapter in conjunction with
the Cisco DNA Center User Guide.

See the following illustration and the procedure that follows to understand the basic workflow.
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Figure 1: Basic Workflow for Setting Up Cisco DNA Center to Use Assurance
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Before you begin

See Limitations and Restrictions of Assurance, on page 1.

Step 1 Install Cisco DNA Center.

See the Cisco DNA Center Installation Guide.

Step 2 Do the following in any order:

• Discover devices (routers, switches, wireless controllers, and access points).

See Discover Your Network Using an IP Address Range, on page 12, Discover Your Network Using CDP, on
page 6 and Discover Your Network Using LLDP, on page 19.

CiscoWireless Controllers must be discovered using the management IP address instead of the service
port IP address. If not, the related wireless controller 360 and AP 360 windows will not display any
data.

Note

• Design a new network hierarchy or use an existing one.

See Design a New Network Hierarchy, on page 27 or Use an Existing Cisco Network Hierarchy, on page 27.

If sites are already created, you can skip this step and run Discovery.Note

Step 3 Make sure that the devices appear in the device Inventory.

See Display Information About Your Inventory, on page 46.

Before you add devices to sites, you must wait for all the devices to get into a Managed state.Note

Step 4 Add devices to sites.
See Add a Device to a Site, on page 55.

Step 5 If you have APs, we recommend that you add them to a floor map.
Step 6 If your network uses Cisco Identity Services Engine (ISE) for user authentication, you can configure Assurance for

Cisco ISE integration. This enables you to see more information about wired clients, such as the username and operating
system, in Assurance.

See About Cisco ISE Configuration for Cisco DNA Center, on page 56.

Step 7 Configure the syslog, SNMP traps, and NetFlow Collector servers using Telemetry.

See Configure Syslog, SNMP Traps, NetFlow Collector Servers, and Wired Client Data Collection Using Telemetry,
on page 60.

Step 8 (Recommended) To view AI-driven issues and gain network insights, configure Cisco AI Network Analytics data
collection.

See Configure Cisco AI Network Analytics Data Collection, on page 61.

Step 9 (Recommended) To have access to the latestMachine Reasoning workflows, update theMachine Reasoning Knowledge
Base.

See Update the Machine Reasoning Knowledge Base, on page 64.
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Step 10 Start using the Assurance application.

Discover Devices
Use the Cisco DNA Center Discovery feature to scan the devices in your network.

Discovery Overview
The Discovery feature scans the devices in your network and sends the list of discovered devices to inventory.

The Discovery feature also works with the Device Controllability feature to configure the required network
settings on devices, if these settings are not already present on the devices.

There are three ways for you to discover devices:

• Use Cisco Discovery Protocol (CDP) and provide a seed IP address.

• Specify a range of IP addresses. (A maximum range of 4096 devices is supported.)

• Use Link Layer Discovery Protocol (LLDP) and provide a seed IP address.

When configuring the Discovery criteria, remember that there are settings that you can use to help reduce the
amount of time it takes to discover your network:

• CDP Level and LLDP Level: If you use CDP or LLDP as the Discovery method, you can set the CDP
or LLDP level to indicate the number of hops from the seed device that you want to scan. The default,
level 16, might take a long time on a large network. So, if fewer devices have to be discovered, you can
set the level to a lower value.

• Subnet Filters: If you use an IP address range, you can specify devices in specific IP subnets for Discovery
to ignore.

• Preferred Management IP: Whether you use CDP, LLDP, or an IP address range, you can specify
whether you want Cisco DNA Center to add any of the device's IP addresses or only the device loopback
address.

For Cisco SD-Access Fabric and Cisco DNAAssurance, we recommend that you
specify the device loopback address.

Note

Regardless of the method you use, youmust be able to reach the device fromCisco DNACenter and configure
specific credentials and protocols in Cisco DNA Center to discover your devices. These credentials can be
configured and saved in the Design > Network Settings > Device Credentials window or on a per-job basis
in the Discovery window.
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If a device uses a first hop resolution protocol, such as Hot Standby Router Protocol (HSRP) or Virtual Router
Redundancy Protocol (VRRP), the device might be discovered and added to the inventory along with its
floating IP address. Later, if HSRP or VRRP fails, the IP address might be reassigned to a different device.
This situation can cause issues with the data that Cisco DNA Center retrieves for analysis.

Note

Discovery Prerequisites
Before you run Discovery, complete the following minimum prerequisites:

• Understand what devices will be discovered by Cisco DNA Center by viewing the Cisco DNA Center
Compatibility Matrix.

• Understand that the preferred network latency between CiscoDNACenter and devices is 100ms round-trip
time (RTT). (The maximum latency is 200 ms RTT.)

• Ensure that at least one SNMP credential is configured on your devices for use by Cisco DNA Center.
At a minimum, this can be an SNMPv2C read credential.

• Configure SSH credentials on the devices you want Cisco DNA Center to discover and manage. Cisco
DNA Center discovers and adds a device to its inventory if at least one of the following criteria is met:

• The account that is being used by Cisco DNACenter to SSH into your devices has privileged EXEC
mode (level 15).

• You configure the device’s enable password as part of the CLI credentials configured in the Discovery
job. For more information, see Discovery Configuration Guidelines and Limitations, on page 6.

Preferred Management IP Address
When Cisco DNA Center discovers a device, it uses one of the device's IP addresses as the preferred
management IP address. The IP address can be that of a built-in management interface of the device, another
physical interface, or a logical interface such as Loopback0. You can configure Cisco DNA Center to use the
device's loopback IP address as the preferred management IP address, provided the IP address is reachable
from Cisco DNA Center.

When you choose Use Loopback IP as the preferred management IP address, Cisco DNA Center determines
the preferred management IP address as follows:

• If the device has one loopback interface, Cisco DNA Center uses that loopback interface IP address.

• If the device has multiple loopback interfaces, Cisco DNA Center uses the loopback interface with the
highest IP address.

• If there are no loopback interfaces, Cisco DNA Center uses the Ethernet interface with the highest IP
address. (Subinterface IP addresses are not considered.)

• If there are no Ethernet interfaces, Cisco DNACenter uses the serial interface with the highest IP address.

After a device is discovered, you can update the management IP address from the Inventory window.
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Discovery Configuration Guidelines and Limitations
The following are the guidelines and limitations for Cisco DNA Center to discover your Cisco Catalyst 3000
Series Switches and Catalyst 6000 Series Switches:

• Configure the CLI username and password with privileged EXEC mode (level 15). These credentials
are the same CLI username and password that you configure in Cisco DNA Center for the Discovery
function. Cisco DNA Center requires the highest access level to the device.

• Explicitly specify the transport protocols allowed on individual interfaces for both incoming and outgoing
connections. Use the transport input and transport output commands for this configuration. For
information about these commands, see the command reference document for the specific device type.

• Do not change the default login method for a device's console port and the VTY lines. If a device is
already configured with a AAA (TACACS) login, make sure that the CLI credential defined in the Cisco
DNA Center is the same as the TACACS credential defined in the TACACS server.

• Cisco wireless controllers must be discovered using the management IP address instead of the service
port IP address. If not, the related wireless controller 360 and AP 360 windows will not display any data.

Discover Your Network Using CDP
You can discover devices using Cisco Discovery Protocol (CDP), an IP address range, or LLDP. This procedure
shows you how to discover devices and hosts using CDP.

• The Discovery function requires the correct SNMP read-only community string. If an SNMP read-only
community string is not provided, as a best effort, the Discovery function uses the default SNMP read-only
community string, public.

• CLI credentials are not required to discover hosts; hosts are discovered through the network devices to
which they are connected.

Note

Before you begin

• Enable CDP on your network devices.

• Configure your network devices, as described in Discovery Prerequisites, on page 5.

• Configure your network device host IP address as the client IP address. (A host is an end-user device,
such as a laptop computer or mobile device.)

Step 1 Click the menu icon ( ) and choose Tools > Discovery.
Step 2 In the Discovery window, click Add Discovery.
Step 3 In the New Discovery window, enter a name in the Discovery Name field.
Step 4 If the IP Address/Range area is not already visible, expand it and configure the following fields:

• Discovery Type: Enable CDP by clicking the CDP radio button.

• IP Address: Enter a seed IP address for Cisco DNA Center to start the Discovery scan.
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• Subnet Filters: Exclude an IP address or subnet from the Discovery scan. To exclude an IP address, enter an
individual IP address (x.x.x.x). To exclude a subnet, enter a classless inter-domain routing (CIDR) address (x.x.x.x/y),
where x.x.x.x is the IP address and y is the subnet mask. The subnet mask can be a value from 0 to 32.

To exclude more IP addresses and subnets, click the add icon ( ).

• CDP Level: Enter the number of hops from the seed device that you want to scan.

Valid values are from 1 to 16. The default value is 16. For example, CDP level 3 means that CDP will scan up to
three hops from the seed device.

• Preferred Management IP Address: Click one of the following radio buttons:

• None: Allow the device to use any of its IP addresses.

• Use Loopback IP: Specify the device loopback interface IP address.

If you choose Use Loopback IP and the device does not have a loopback interface, Cisco DNA
Center chooses a management IP address using the logic described in Preferred Management IP
Address, on page 5.

Note

To use the loopback interface IP address as the preferred management IP address, make sure that
the IP address of the CDP neighbor is reachable from Cisco DNA Center.

Note

Step 5 Expand the Credentials area and choose the credentials that you want to use.

Choose any of the global credentials that have already been created or configure your own Discovery credentials.

Step 6 To use existing credentials, select the global credentials that you want to use and proceed to Step 14. If you do not want
to use a credential, deselect it.

Step 7 To configure new credentials, click Add Credentials.

If you configure your own credentials, you can save them future Discovery jobs by checking the Save as
global settings check box.

Note

Step 8 For CLI credentials, do the following:
a) Configure the following fields:

Table 1: CLI Credentials

DescriptionField

Name or phrase that describes the CLI credentials.Name/Description

Name that is used to log in to the CLI of the devices in your network.Username

Password that is used to log in to the CLI of the devices in your network.

For security reasons, re-enter the password as confirmation.

Passwords are encrypted for security reasons and are not displayed
in the configuration.

Note

Password
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DescriptionField

Password used to move to a higher privilege level in the CLI. Configure this
password only if your network devices require it.

For security reasons, re-enter the enable password.

Passwords are encrypted for security reasons and are not displayed
in the configuration.

Note

Enable Password

b) If you want to save these credentials for future use, click the Save as global settings check box. If you don't check
this check box, the credentials can be used only for the current Discovery job.

c) Click Save.

Step 9 For SNMP v2c credentials, click SNMP v2c and do the following:
a) Configure the following fields:

Table 2: SNMPv2c Credentials

DescriptionField

• Name/Description: Name or description of the SNMPv2c settings that you are adding.

• Read Community: Read-only community string password used only to view SNMP
information on the device.

Passwords are encrypted for security reasons and are not displayed in the
configuration.

Note

Read

• Name/Description: Name or description of the SNMPv2c settings that you are adding.

• Write Community: Write community string used to make changes to the SNMP
information on the device.

Passwords are encrypted for security reasons and are not displayed in the
configuration.

Note

Write

b) If you want to save these credentials for future use, click the Save as global settings check box. If you don't check
this check box, the credentials can be used only for the current Discovery job.

c) Click Save.

Step 10 (Optional) For SNMP v3 credentials, click SNMP v3 and do the following:
a) Configure the following fields:

Table 3: SNMPv3 Credentials

DescriptionField

Name or description of the SNMPv3 settings that you are adding.Name/Description

Name associated with the SNMPv3 settings.Username
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DescriptionField

Security level that an SNMP message requires. Choose one of the following modes:

• noAuthNoPriv: Does not provide authentication or encryption.

• AuthNoPriv: Provides authentication, but does not provide encryption.

• AuthPriv: Provides both authentication and encryption.

Mode

Authentication type to be used. (Enabled if you selectAuthPriv or AuthNoPriv asMode.)
Choose one of the following authentication types:

• SHA: Authentication based on HMAC-SHA.

• MD5: Authentication based on HMAC-MD5.

Auth Type

SNMPv3 password used for gaining access to information from devices that use SNMPv3.
These passwords (or passphrases) must be at least eight characters in length.

Note • Some wireless controllers require that passwords (or passphrases) be at
least 12 characters long. Be sure to check the minimum password
requirements for your wireless controllers. Failure to ensure these required
minimum character lengths for passwords results in devices not being
discovered, monitored, or managed by Cisco DNA Center.

• Passwords are encrypted for security reasons and are not displayed in
the configuration.

Auth Password

Privacy type. (Enabled if you select AuthPriv as Mode.) Choose one of the following
privacy types:

• AES128: 128-bit CBC mode AES for encryption.

• CISCOAES192: 192-bit CBC mode AES for encryption on Cisco devices.

• CISCOAES256: 256-bit CBC mode AES for encryption on Cisco devices.

Note • Discovery and Inventory features support only CISCOAES192 and
CICSOAES256 privacy types.

• Cisco DNA Assurance does not support any of these privacy types.

Privacy Type

SNMPv3 privacy password that is used to generate the secret key for encrypting messages
that are exchanged with devices that support encryption standards. Passwords (or
passphrases) must be at least eight characters long.

Note • Some wireless controllers require that passwords (or passphrases) be at
least 12 characters long. Be sure to check the minimum password
requirements for your wireless controllers. Failure to ensure these required
minimum character lengths for passwords results in devices not being
discovered, monitored, or managed by Cisco DNA Center.

• Passwords are encrypted for security reasons and are not displayed in
the configuration.

Privacy Password
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b) If you want to save these credentials for future use, click the Save as global settings check box. If you don't check
this check box, the credentials can be used only for the current Discovery job.

c) Click Save.

Step 11 (Optional) To configure SNMP properties, click SNMP PROPERTIES and do the following:
a) Configure the following fields:

Table 4: SNMP Properties

DescriptionField

Number of times Cisco DNA Center tries to communicate with network devices
using SNMP.

Retries

Amount of time, in seconds, between retries.Timeout

b) If you want to save these credentials for future use, click the Save as global settings check box. If you don't check
this check box, the credentials can be used only for the current Discovery job.

c) Click Save.

Step 12 (Optional) To configure HTTP(s) credentials, click HTTP(S) and do the following:
a) Configure the following fields:

Table 5: HTTP(S) Credentials

DescriptionField

Specifies the kind of HTTPS credentials you are configuring. Valid types are Read or
Write.

Type

You can configure up to 10 HTTPS read credentials:

• Name/Description: Name or description of the HTTPS credentials that you are adding.

• Username: Name used to authenticate the HTTPS connection.

• Password: Password used to authenticate the HTTPS connection. Passwords are
encrypted for security and are not displayed in the configuration.

• Port: Number of the TCP/UDP port used for HTTPS traffic. The default is port number
443 (the well-known port for HTTPS).

The password must contain between 7 and 128 characters, including at least one of the
following:

• Lowercase letter (a to z)

• Uppercase letter (A to Z)

• Number (0 to 9)

• Special character: # _ * ? –

The password cannot contain spaces or angle brackets (< >). Note that some Cisco IOS XE
devices do not allow a question mark (?).

Read
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DescriptionField

You can configure up to 10 HTTPS write credentials:

• Name/Description: Name or description of the HTTPS credentials that you are adding.

• Username: Name used to authenticate the HTTPS connection.

• Password: Password used to authenticate the HTTPS connection. Passwords are
encrypted for security and are not displayed in the configuration.

• Port: Number of the TCP/UDP port used for HTTPS traffic. The default is port number
443 (the well-known port for HTTPS).

The password must contain between 7 and 128 characters, including at least one of the
following:

• Lowercase letter (a to z)

• Uppercase letter (A to Z)

• Number (0 to 9)

• Special character: # _ * ? –

The password cannot contain spaces or angle brackets (< >). Note that some Cisco IOS XE
devices do not allow a question mark (?).

Write

b) (Optional) If you want to save these credentials for future use, click the Save as global settings check box. If you
don't check this check box, the credentials can be used only for the current Discovery job.

c) Click Save.

Step 13 (Optional) If you have network devices with NETCONF enabled and want Cisco DNA Center to use NETCONF to
install, manipulate, and delete the configurations of these devices, click NETCONF and do the following:
a) In the Port field, enter a port number. You can use one of the following ports:

• Port 830 (default).

• Any other port that is available on the device.

• A custom port that Cisco DNA Center configures. (You can use a custom port only if Device Controllability
is enabled. For more information, see the Device Controllability section in theCisco DNA Center Administrator
Guide.)

NETCONF is disabled if you choose the Telnet protocol in the Advanced area of the Add Discovery
window.

Note

To discover Cisco Catalyst 9800 Series Wireless Controller devices, you must enable NETCONF.Note

b) If you want to save these credentials for future use, click the Save as global settings check box. If you don't check
this check box, the credentials can be used only for the current Discovery job.

c) Click Save.

Step 14 (Optional) To configure the protocols that are used to connect with devices, expand the Advanced area and do the
following:
a) Click the names of the protocols that you want to use. A green check mark indicates that the protocol is selected.
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Valid protocols are SSH (default) and Telnet.

b) Drag and drop the protocols in the order that you want them to be used.

NETCONF is disabled if you choose the Telnet protocol in the Advanced area of the Add Discovery
window.

Note

Step 15 Click Discover.
Step 16 To run Discovery now, click the Now radio button in the Discover Devices slide-in pane and click Start. Otherwise,

proceed to the next step.

If you want to discover only new devices, click the Discover only new devices toggle button.

Step 17 To schedule Discovery for a later time, do the following:

a. Click the Later radio button.

b. Define the start date and time.

c. From the Time Zone drop-down list, choose a time zone.

d. In the Recurrence area, click None, Daily, or Weekly.

• None: Discovery will not recur.

• Daily: Enter the interval in days in the Run at Interval (Days) field.

• Weekly: Enter the interval in weeks in the Run at Interval (Weeks) field.

e. If you have chosen Daily or Weekly for recurrence, check the Set Schedule End check box to define the end date
and time.

You can discover only new devices in recurrence. The Discover only new devices toggle button at
the top is enabled by default.

Note

f. Click End Date or End After.

• End Date: Enter month, date, and year for recurrence to end.

• End After: Enter the number of occurrences after you want recurrence to end.

g. Click Start.

Click the notifications icon to view the scheduled Discovery. Before Discovery starts, you can click Edit to edit it, or
Cancel to cancel it.

The Discoveries window displays the results of your scan.

The Discovery Details pane shows the status (active or inactive) and the Discovery configuration. The Discovery
Devices pane displays the hostnames, IP addresses, and status of the discovered devices.

Discover Your Network Using an IP Address Range
You can discover devices using an IP address range, CDP, or LLDP. This procedure shows you how to discover
devices and hosts using an IP address range.
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Before you begin

Your devices must have the required device configurations, as described in Discovery Prerequisites, on page
5.

Step 1 Click the menu icon ( ) and choose Tools > Discovery.
Step 2 In the Discovery window, click Add Discovery.
Step 3 In the New Discovery window, enter a name in the Discovery Name field.
Step 4 If the IP Address/Ranges area is not already visible, expand it and configure the following fields:

• Discovery Type: Discover devices using an IP address or address range by clicking the IP Address/Range radio
button.

• From and To fields: Enter the beginning IP address in the From field and the ending IP address in the To field.

Click the add icon (+) to add more IP address ranges.

CiscoWireless Controllers must be discovered using the management IP address instead of the service
port IP address. If not, the related wireless controller 360 and AP 360 windows will not display any
data.

Note

• Subnet Filters: Exclude an IP address or subnet from the Discovery scan. To exclude an IP address, enter an
individual IP address (x.x.x.x). To exclude a subnet, enter a classless inter-domain routing (CIDR) address (x.x.x.x/y),
where x.x.x.x is the IP address and y is the subnet mask. The subnet mask can be a value from 0 to 32.

To exclude more IP addresses and subnets, click the add icon ( ).

• Preferred Management IP Address: Click one of the following radio buttons:

• None: Allow the device to use any of its IP addresses.

• Use Loopback IP: Specify the device loopback interface IP address.

If you choose Use Loopback IP and the device does not have a loopback interface, Cisco DNA
Center chooses a management IP address using the logic described in Preferred Management IP
Address, on page 5.

Note

Step 5 Expand the Credentials area and choose the credentials that you want to use.

Choose any of the global credentials that have already been created or configure your own Discovery credentials.

Step 6 To use existing credentials, select the global credentials that you want to use and proceed to Step 14. If you do not want
to use a credential, deselect it.

Step 7 To configure new credentials, click Add Credentials.

If you configure your own credentials, you can save them future Discovery jobs by checking the Save as
global settings check box.

Note

Step 8 For CLI credentials, do the following:
a) Configure the following fields:
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Table 6: CLI Credentials

DescriptionField

Name or phrase that describes the CLI credentials.Name/Description

Name that is used to log in to the CLI of the devices in your network.Username

Password that is used to log in to the CLI of the devices in your network.

For security reasons, re-enter the password as confirmation.

Passwords are encrypted for security reasons and are not displayed
in the configuration.

Note

Password

Password used to move to a higher privilege level in the CLI. Configure this
password only if your network devices require it.

For security reasons, re-enter the enable password.

Passwords are encrypted for security reasons and are not displayed
in the configuration.

Note

Enable Password

b) If you want to save these credentials for future use, click the Save as global settings check box. If you don't check
this check box, the credentials can be used only for the current Discovery job.

c) Click Save.

Step 9 For SNMP v2c credentials, click SNMP v2c and do the following:
a) Configure the following fields:

Table 7: SNMPv2c Credentials

DescriptionField

• Name/Description: Name or description of the SNMPv2c settings that you are adding.

• Read Community: Read-only community string password used only to view SNMP
information on the device.

Passwords are encrypted for security reasons and are not displayed in the
configuration.

Note

Read

• Name/Description: Name or description of the SNMPv2c settings that you are adding.

• Write Community: Write community string used to make changes to the SNMP
information on the device.

Passwords are encrypted for security reasons and are not displayed in the
configuration.

Note

Write

b) If you want to save these credentials for future use, click the Save as global settings check box. If you don't check
this check box, the credentials can be used only for the current Discovery job.

c) Click Save.

Step 10 (Optional) For SNMP v3 credentials, click SNMP v3 and do the following:
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a) Configure the following fields:

Table 8: SNMPv3 Credentials

DescriptionField

Name or description of the SNMPv3 settings that you are adding.Name/Description

Name associated with the SNMPv3 settings.Username

Security level that an SNMP message requires. Choose one of the following modes:

• noAuthNoPriv: Does not provide authentication or encryption.

• AuthNoPriv: Provides authentication, but does not provide encryption.

• AuthPriv: Provides both authentication and encryption.

Mode

Authentication type to be used. (Enabled if you selectAuthPriv or AuthNoPriv asMode.)
Choose one of the following authentication types:

• SHA: Authentication based on HMAC-SHA.

• MD5: Authentication based on HMAC-MD5.

Auth Type

SNMPv3 password used for gaining access to information from devices that use SNMPv3.
These passwords (or passphrases) must be at least eight characters in length.

Note • Some wireless controllers require that passwords (or passphrases) be at
least 12 characters long. Be sure to check the minimum password
requirements for your wireless controllers. Failure to ensure these required
minimum character lengths for passwords results in devices not being
discovered, monitored, or managed by Cisco DNA Center.

• Passwords are encrypted for security reasons and are not displayed in
the configuration.

Auth Password

Privacy type. (Enabled if you select AuthPriv as Mode.) Choose one of the following
privacy types:

• AES128: 128-bit CBC mode AES for encryption.

• CISCOAES192: 192-bit CBC mode AES for encryption on Cisco devices.

• CISCOAES256: 256-bit CBC mode AES for encryption on Cisco devices.

Note • Discovery and Inventory features support only CISCOAES192 and
CICSOAES256 privacy types.

• Cisco DNA Assurance does not support any of these privacy types.

Privacy Type
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DescriptionField

SNMPv3 privacy password that is used to generate the secret key for encrypting messages
that are exchanged with devices that support encryption standards. Passwords (or
passphrases) must be at least eight characters long.

Note • Some wireless controllers require that passwords (or passphrases) be at
least 12 characters long. Be sure to check the minimum password
requirements for your wireless controllers. Failure to ensure these required
minimum character lengths for passwords results in devices not being
discovered, monitored, or managed by Cisco DNA Center.

• Passwords are encrypted for security reasons and are not displayed in
the configuration.

Privacy Password

b) If you want to save these credentials for future use, click the Save as global settings check box. If you don't check
this check box, the credentials can be used only for the current Discovery job.

c) Click Save.

Step 11 (Optional) To configure SNMP properties, click SNMP PROPERTIES and do the following:
a) Configure the following fields:

Table 9: SNMP Properties

DescriptionField

Number of times Cisco DNA Center tries to communicate with network devices
using SNMP.

Retries

Amount of time, in seconds, between retries.Timeout

b) If you want to save these credentials for future use, click the Save as global settings check box. If you don't check
this check box, the credentials can be used only for the current Discovery job.

c) Click Save.

Step 12 (Optional) To configure HTTP(s) credentials, click HTTP(S) and do the following:
a) Configure the following fields:

Table 10: HTTP(S) Credentials

DescriptionField

Specifies the kind of HTTPS credentials you are configuring. Valid types are Read or
Write.

Type
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DescriptionField

You can configure up to 10 HTTPS read credentials:

• Name/Description: Name or description of the HTTPS credentials that you are adding.

• Username: Name used to authenticate the HTTPS connection.

• Password: Password used to authenticate the HTTPS connection. Passwords are
encrypted for security and are not displayed in the configuration.

• Port: Number of the TCP/UDP port used for HTTPS traffic. The default is port number
443 (the well-known port for HTTPS).

The password must contain between 7 and 128 characters, including at least one of the
following:

• Lowercase letter (a to z)

• Uppercase letter (A to Z)

• Number (0 to 9)

• Special character: # _ * ? –

The password cannot contain spaces or angle brackets (< >). Note that some Cisco IOS XE
devices do not allow a question mark (?).

Read

You can configure up to 10 HTTPS write credentials:

• Name/Description: Name or description of the HTTPS credentials that you are adding.

• Username: Name used to authenticate the HTTPS connection.

• Password: Password used to authenticate the HTTPS connection. Passwords are
encrypted for security and are not displayed in the configuration.

• Port: Number of the TCP/UDP port used for HTTPS traffic. The default is port number
443 (the well-known port for HTTPS).

The password must contain between 7 and 128 characters, including at least one of the
following:

• Lowercase letter (a to z)

• Uppercase letter (A to Z)

• Number (0 to 9)

• Special character: # _ * ? –

The password cannot contain spaces or angle brackets (< >). Note that some Cisco IOS XE
devices do not allow a question mark (?).

Write

b) (Optional) If you want to save these credentials for future use, click the Save as global settings check box. If you
don't check this check box, the credentials can be used only for the current Discovery job.

c) Click Save.
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Step 13 (Optional) If you have network devices with NETCONF enabled and want Cisco DNA Center to use NETCONF to
install, manipulate, and delete the configurations of these devices, click NETCONF and do the following:
a) In the Port field, enter a port number. You can use one of the following ports:

• Port 830 (default).

• Any other port that is available on the device.

• A custom port that Cisco DNA Center configures. (You can use a custom port only if Device Controllability
is enabled. For more information, see the Device Controllability section in theCisco DNA Center Administrator
Guide.)

NETCONF is disabled if you choose the Telnet protocol in the Advanced area of the Add Discovery
window.

Note

To discover Cisco Catalyst 9800 Series Wireless Controller devices, you must enable NETCONF.Note

b) If you want to save these credentials for future use, click the Save as global settings check box. If you don't check
this check box, the credentials can be used only for the current Discovery job.

c) Click Save.

Step 14 (Optional) To configure the protocols that are used to connect with devices, expand the Advanced area and do the
following:
a) Click the names of the protocols that you want to use. A green check mark indicates that the protocol is selected.

Valid protocols are SSH (default) and Telnet.

b) Drag and drop the protocols in the order that you want them to be used.

NETCONF is disabled if you choose the Telnet protocol in the Advanced area of the Add Discovery
window.

Note

Step 15 Click Discover.
Step 16 To run the discovery now, click the Now radio button and click Start. Otherwise, proceed to the next step.

If you want to discover only new devices, click the Discover only new devices toggle button.

Step 17 To schedule the discovery for a later time, do the following:

a. Click the Later radio button.

b. Define the start date and time.

c. From the Time Zone drop-down list, choose a time zone.

d. In the Recurrence area, click None, Daily, or Weekly.

• None: Discovery will not recur.

• Daily: Enter the interval in days in the Run at Interval (Days) field.

• Weekly: Enter the interval in weeks in the Run at Interval (Weeks) field.

e. If you have chosen Daily or Weekly for recurrence, check the Set Schedule End check box to define the end date
and time.
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You can discover only new devices in recurrence. The Discover only new devices toggle button at
the top is enabled by default.

Note

f. Click End Date or End After.

• End Date: Enter month, date, and year for recurrence to end.

• End After: Enter the number of occurrences after you want recurrence to end.

g. Click Start.

Click the notifications icon to view the scheduled Discovery. Before Discovery starts, you can click Edit to edit it, or
Cancel to cancel it.

The Discoveries window displays the results of your scan.

The Discovery Details pane shows the status (active or inactive) and the Discovery configuration. The Discovery
Devices pane displays the hostnames, IP addresses, and status of the discovered devices.

Discover Your Network Using LLDP
You can discover devices using Link Layer Discovery Protocol (LLDP), CDP, or an IP address range. This
procedure shows you how to discover devices and hosts using LLDP.

• Discovery requires the correct SNMP read-only community string. If one is not provided, Discovery
uses the default SNMP read-only community string, public, as a best effort.

• CLI credentials are not required to discover hosts; hosts are discovered through the network devices to
which they are connected.

Note

Before you begin

• Enable LLDP on your network devices.

• Configure your network devices, as described in Discovery Prerequisites, on page 5.

• Configure your network device's host IP address as the client IP address. (A host is an end-user device,
such as a laptop computer or mobile device.)

Step 1 Click the menu icon ( ) and choose Tools > Discovery.
Step 2 In the Discovery window, click Add Discovery.
Step 3 In the Discovery Name field of the New Discovery window, enter a name.
Step 4 If the IP Address/Range area is not already visible, expand it and configure the following fields:

• Discovery Type: Enable LLDP by clicking the LLDP radio button.

• IP Address: Enter a seed IP address for Cisco DNA Center to start the Discovery scan.
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• Subnet Filters: Exclude an IP address or subnet from the Discovery scan. To exclude an IP address, enter an
individual IP address (x.x.x.x). To exclude a subnet, enter a classless inter-domain routing (CIDR) address (x.x.x.x/y),
where x.x.x.x is the IP address and y is the subnet mask. The subnet mask can be a value from 0 to 32.

To exclude more IP addresses and subnets, click the add icon ( ).

• LLDP Level: Enter the number of hops from the seed device that you want to scan.

Valid values are from 1 to 16. The default value is 16. For example, CDP level 3 means that CDP will scan up to
three hops from the seed device.

• Preferred Management IP Address: Click one of the following radio buttons:

• None: Allow the device to use any of its IP addresses.

• Use Loopback IP: Specify the device loopback interface IP address.

If you choose Use Loopback IP and the device does not have a loopback interface, Cisco DNA
Center chooses a management IP address using the logic described in Preferred Management IP
Address, on page 5.

Note

To use the loopback interface IP address as the preferred management IP address, make sure that
the IP address of the LLDP neighbor is reachable from Cisco DNA Center.

Note

Step 5 Expand the Credentials area and configure the credentials that you want to use for the Discovery job.

Choose any of the global credentials that have already been created, or configure your own Discovery credentials. If you
configure the credentials, you can choose to save them for future jobs by checking the Save as global settings check
box.

a) Make sure that the global credentials that you want to use are selected. If you do not want to use a credential, deselect
it.

b) To add additional credentials, click Add Credentials.
c) For CLI credentials, configure the following fields:

Table 11: CLI Credentials

DescriptionField

Name or phrase that describes the CLI credentials.Name/Description

Name that is used to log in to the CLI of the devices in your network.Username

Password that is used to log in to the CLI of the devices in your network.

For security reasons, re-enter the password as confirmation.

Passwords are encrypted for security reasons and are not displayed
in the configuration.

Note

Password

Password used to move to a higher privilege level in the CLI. Configure this
password only if your network devices require it.

For security reasons, re-enter the enable password.

Passwords are encrypted for security reasons and are not displayed
in the configuration.

Note

Enable Password
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d) Click SNMP v2c and configure the following fields:

Table 12: SNMPv2c Credentials

DescriptionField

• Name/Description: Name or description of the SNMPv2c settings that you are adding.

• Read Community: Read-only community string password used only to view SNMP
information on the device.

Passwords are encrypted for security reasons and are not displayed in the
configuration.

Note

Read

• Name/Description: Name or description of the SNMPv2c settings that you are adding.

• Write Community: Write community string used to make changes to the SNMP
information on the device.

Passwords are encrypted for security reasons and are not displayed in the
configuration.

Note

Write

e) (Optional) Click SNMP v3 and configure the following fields:

Table 13: SNMPv3 Credentials

DescriptionField

Name or description of the SNMPv3 settings that you are adding.Name/Description

Name associated with the SNMPv3 settings.Username

Security level that an SNMP message requires. Choose one of the following modes:

• noAuthNoPriv: Does not provide authentication or encryption.

• AuthNoPriv: Provides authentication, but does not provide encryption.

• AuthPriv: Provides both authentication and encryption.

Mode

Authentication type to be used. (Enabled if you select AuthPriv or AuthNoPriv as Mode.)
Choose one of the following authentication types:

• SHA: Authentication based on HMAC-SHA.

• MD5: Authentication based on HMAC-MD5.

Auth Type
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DescriptionField

SNMPv3 password used for gaining access to information from devices that use SNMPv3.
These passwords (or passphrases) must be at least eight characters in length.

Note • Some wireless controllers require that passwords (or passphrases) be at
least 12 characters long. Be sure to check the minimum password
requirements for your wireless controllers. Failure to ensure these required
minimum character lengths for passwords results in devices not being
discovered, monitored, or managed by Cisco DNA Center.

• Passwords are encrypted for security reasons and are not displayed in the
configuration.

Auth Password

Privacy type. (Enabled if you selectAuthPriv asMode.) Choose one of the following privacy
types:

• AES128: 128-bit CBC mode AES for encryption.

• CISCOAES192: 192-bit CBC mode AES for encryption on Cisco devices.

• CISCOAES256: 256-bit CBC mode AES for encryption on Cisco devices.

Note • Discovery and Inventory features support only CISCOAES192 and
CICSOAES256 privacy types.

• Cisco DNA Assurance does not support any of these privacy types.

Privacy Type

SNMPv3 privacy password that is used to generate the secret key for encrypting messages
that are exchanged with devices that support encryption standards. Passwords (or passphrases)
must be at least eight characters long.

Note • Some wireless controllers require that passwords (or passphrases) be at
least 12 characters long. Be sure to check the minimum password
requirements for your wireless controllers. Failure to ensure these required
minimum character lengths for passwords results in devices not being
discovered, monitored, or managed by Cisco DNA Center.

• Passwords are encrypted for security reasons and are not displayed in the
configuration.

Privacy Password

f) (Optional) Click SNMP PROPERTIES and configure the following fields:

Table 14: SNMP Properties

DescriptionField

Number of times Cisco DNA Center tries to communicate with network devices
using SNMP.

Retries

Number of seconds between retries.Timeout

g) (Optional) Click HTTP(S) and configure the following fields:
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Table 15: HTTP(S) Credentials

DescriptionField

Specifies the kind of HTTPS credentials you are configuring. Valid types areRead orWrite.Type

You can configure up to 10 HTTPS read credentials:

• Name/Description: Name or description of the HTTPS credentials that you are adding.

• Username: Name used to authenticate the HTTPS connection.

• Password: Password used to authenticate the HTTPS connection. Passwords are
encrypted for security and are not displayed in the configuration.

• Port: Number of the TCP/UDP port used for HTTPS traffic. The default is port number
443 (the well-known port for HTTPS).

The password must contain between 7 and 128 characters, including at least one of the
following:

• Lowercase letter (a to z)

• Uppercase letter (A to Z)

• Number (0 to 9)

• Special character: # _ * ? –

The password cannot contain spaces or angle brackets (< >). Note that some Cisco IOS XE
devices do not allow a question mark (?).

Read

You can configure up to 10 HTTPS write credentials:

• Name/Description: Name or description of the HTTPS credentials that you are adding.

• Username: Name used to authenticate the HTTPS connection.

• Password: Password used to authenticate the HTTPS connection. Passwords are
encrypted for security and are not displayed in the configuration.

• Port: Number of the TCP/UDP port used for HTTPS traffic. The default is port number
443 (the well-known port for HTTPS).

The password must contain between 7 and 128 characters, including at least one of the
following:

• Lowercase letter (a to z)

• Uppercase letter (A to Z)

• Number (0 to 9)

• Special character: # _ * ? –

The password cannot contain spaces or angle brackets (< >). Note that some Cisco IOS XE
devices do not allow a question mark (?).

Write
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Step 6 (Optional) To configure the protocols to be used to connect with devices, expand theAdvanced area and do the following
tasks:
a) Click the names of the protocols that you want to use. A green check mark indicates that the protocol is selected.

Valid protocols are SSH (default) and Telnet.
b) Drag and drop the protocols in the order that you want them to be used.

Step 7 Click Discover.

The Discover Devices slide-in pane appears.

Step 8 To run the discovery now, click the Now radio button and click Start.

If you want to discover only new devices, click the Discover only new devices toggle button.

Step 9 To schedule the discovery for a later time, do the following:

a. Click the Later radio button.

b. Define the start date and time.

c. From the Time Zone drop-down list, choose a time zone.

d. In the Recurrence area, click None, Daily, or Weekly.

• None: Discovery will not recur.

• Daily: Enter the interval in days in the Run at Interval (Days) field.

• Weekly: Enter the interval in weeks in the Run at Interval (Weeks) field.

e. If you have chosen Daily or Weekly for recurrence, check the Set Schedule End check box to define the end date
and time.

You can discover only new devices in recurrence. The Discover only new devices toggle button at the
top is enabled by default.

Note

f. Click End Date or End After.

• End Date: Enter month, date, and year for recurrence to end.

• End After: Enter the number of occurrences after you want recurrence to end.

g. Click Start.

Click the notifications icon to view the scheduled Discovery. Before Discovery starts, you can click Edit to edit it, or
Cancel to cancel it.

The Discoveries window displays the results of your scan.

TheDiscovery Details pane shows the status (active or inactive) and the Discovery configuration. TheDiscovery Devices
pane displays the host names, IP addresses, and status of the discovered devices.

Manage Discovery Jobs
The following sections provide information about how to manage the Discovery jobs.
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Stop and Start a Discovery Job

Step 1 Click the menu icon ( ) and choose Tools > Discovery.
Step 2 In the Discovery window, click All discoveries page from previous release.
Step 3 To stop an active Discovery job, perform these steps:

a) In the left Discoveries pane, click a Discovery job.
b) In the bottom pane, on the right side, click Stop.

Step 4 To restart an inactive Discovery job, perform these steps:
a) In the left Discoveries pane, click a Discovery job.
b) In the bottom pane, on the right side, click Re-discover.

Clone a Discovery Job
You can clone a Discovery job and retain all the information defined for that job.

Before you begin

You should have run at least one Discovery job.

Step 1 Click the menu icon ( ) and choose Tools > Discovery.
Step 2 In the Discovery window, click All discoveries page from previous release.
Step 3 In the left Discoveries pane, click a Discovery job.
Step 4 In the bottom pane, on the right side, click Copy & Edit.

Cisco DNA Center creates a copy of the Discovery job, named Clone of Discovery_Job.

Step 5 (Optional) To change the name of the Discovery job, replace the default name in the Discovery Name field with a new
name.

Step 6 Define or update the parameters for the new Discovery job.

Delete a Discovery Job
You can delete a Discovery job whether it is active or inactive.

Step 1 Click the menu icon ( ) and choose Tools > Discovery.
Step 2 In the Discovery window, click All discoveries page from previous release.
Step 3 In the left Discoveries pane, click the Discovery job that you want to delete.
Step 4 In the bottom pane, on the right side, click Delete.
Step 5 Click OK to confirm.
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View Discovery Job Information
You can view information about a Discovery job, such as the settings and credentials that were used. You
also can view the historical information about each Discovery job that was run, including information about
the specific devices that were discovered or that failed to be discovered.

Before you begin

Run at least one Discovery job.

Step 1 Click the menu icon ( ) and choose Tools > Discovery.
Step 2 In the Discovery window, click All discoveries page from previous release.
Step 3 In the left Discoveries pane, select the Discovery job. Alternatively, use the Search function to find a Discovery job by

device IP address or name.
Step 4 Click the down arrow next to one of the following areas for more information:

• Discovery Details: Displays the parameters that were used to run the Discovery job. Parameters include attributes
such as the CDP or LLDP level, IP address range, and protocol order.

• Credentials: Provides the names of the credentials that were used.

• History: Lists each Discovery job that was run, including the time the job started, and whether any devices were
discovered.

To successfully discover embedded wireless controllers, the NETCONF port must be configured. If the NETCONF
port is not configured, wireless data is not collected.

Use the Filter function to display devices by any combination of IP addresses or ICMP, CLI, HTTPS, or NETCONF
values.

Design Network Hierarchy
You can create a network hierarchy that represents your network's geographical locations. Your network
hierarchy can contain sites, which contains buildings and areas.

Network Hierarchy Overview
You can create a network hierarchy that represents your network's geographical locations. The hierarchical
organization enables you to easily apply design settings or configurations to a specific hierarchical element.
For example, you can apply design settings to an entire area or to only a floor.

You can name hierarchical elements to help you identify where to apply design settings later.

The hierarchical elements that you can create have rules that dictate under which elements they can reside
and which elements can reside under them.

• Global: Default element under which all other hierarchical elements reside. Areas and sites are the only
elements that can reside directly under Global.
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• Areas and Sites: Areas and sites reside under Global or under other areas or sites. They do not have a
physical address. As the largest element, they identify a geographic region. They provide a way to group
areas and sites.

• Buildings: Buildings reside under areas or sites. When you create a building, you need to specify a
physical address or latitude and longitude coordinates. Buildings can't contain areas. However, they can
contain floors.

• Floors: Floors reside under buildings. You can add floors to buildings with or without maps that contain
various building components, like walls and windows. If you decide to use floor maps, you can manually
create them or import them from files, such as DXF, DWG, JPG, GIF, PNG, or PDF file types. Then
you can position your wireless devices on the floor maps to visualize your wireless network coverage.

You can change the site hierarchy for unprovisioned devices while preserving AP locations on floor
maps. Note, however, that you can't move an existing floor to a different building.

To get started, build your network hierarchy using one of the following methods:

• Create a new network hierarchy. For more information, see Design a New Network Hierarchy, on page
27.

• Import an existing network hierarchy from Cisco Prime Infrastructure or Ekahau Pro. For more
information, see the Cisco DNA Center User Guide.

Design a New Network Hierarchy
The Design area is where you create the structure and framework of your network, including the physical
topology, network settings, and device type profiles that you can apply to devices throughout your network.
Use the Design workflow if you do not already have an existing infrastructure. If you have an existing
infrastructure, use the Discovery feature. For more information, see Discovery Overview, on page 4.

You can perform these tasks in the Design area:

Step 1 Create your network hierarchy.
Step 2 Define global network settings.
Step 3 Define network profiles.

Use an Existing Cisco Network Hierarchy
If you have an existing network hierarchy in Cisco Prime Infrastructure, you can export it and then import it
into Cisco DNA Center, saving time and effort spent in creating a new network hierarchy.

The following information is available for you to re-create your network hierarchy:

• Site Hierarchy: Your existing site hierarchy is downloaded in a CSV file format. The CSV file contains
details such as site names, parent hierarchy, number of floors, location, and site address.

• Map Archive: Map information is downloaded as a map archive in a TAR file format. The map archive
file contains data such as the date and time, number of floors, and APs. Depending on what you choose
to download, the map archive can also include map information, such as floor dimensions (length, width,
and height) and details about the APs and overlay objects that have been placed on the floor maps. You
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can also choose to download calibration information, such as the RF attenuation model that has been
applied to each floor.

You can choose to base the map archive on the global hierarchy or the hierarchy of a single site, building,
or floor, as follows:

• Site: The chosen site and all of its subsites, buildings, and floors are exported.

• Building: The chosen building and all of its floors are exported.

• Floor: The chosen floor is exported.

Cisco DNA Center supports the United States' Federal Information Processing
Standards (FIPS). FIPS is an optional mode that can be enabled when installing
the Cisco DNA Center image. By default, FIPS mode is disabled.

Note

FIPS mode has the following impact on the export and import of map archives.

If FIPS mode is enabled:

• Exported map archives are unencrypted.

• Only unencrypted map archives can be imported.

If FIPS mode is disabled:

• Exported map archives are encrypted.

• Both encrypted and unencrypted map archives can be imported.

For details, see the Cisco DNA Center User Guide.

Guidelines for Image Files to Use in Maps
Follow these guidelines to use map image files:

• Use a graphical application that can save the map image files to any of these formats—.jpg, .gif, .png,
.pdf, .dxf, and .dwg.

• Ensure that the dimension of an image is larger than the combined dimension of all the buildings and
outside areas that you plan to add to the map.

• Map image files can be of any size. Cisco DNA Center imports the full definition of the original images
to its database, but during display, it automatically resizes them to fit the workspace.

• Obtain the horizontal and vertical dimensions of the site in feet or meters before importing. This helps
you to specify these dimensions during map import.

Create a Site in a Network Hierarchy
Cisco DNA Center allows you to easily define physical sites and then specify common resources for those
sites. The Design area uses a hierarchical format for intuitive use, while eliminating the need to redefine the
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same resource in multiple places when provisioning devices. By default, there is one site called Global. You
can add more sites, buildings, and areas to your network hierarchy. You must create at least one site before
you can use the provision features.

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.

A world map appears in the right pane.

Step 2 From the map toolbar, click + Add Site and choose Add Area.

You can also hover your cursor over the ellipsis next to the parent site in the left pane, and then choose
Add Area.

Note

Step 3 Enter the site name in the Area Name field.

The Area Name field has the following restrictions:

• The area name cannot exceed 40 characters.

• Special characters & > < ? ' " / [ ] aren't allowed.

Step 4 From the Parent drop-down list, choose a parent node.

By default, Global is the parent node.Note

Step 5 Click Add.

The site is created under the parent node in the left pane.

Add a Building

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
Step 2 In the Network Hierarchy window, click +Add Site > Add Building.

Alternatively, you can hover your cursor over the ellipsis next to the parent site in the left pane, and choose Add
Building.

Step 3 In the Add Building dialog box, add the building details:
a) In the Building Name field, enter a name for the building.

The Building Name field has the following restrictions:

• The building name cannot exceed 40 characters.

• Special characters & > < ? ' " / [ ] aren't allowed.

b) From the Parent drop-down list, choose a parent node. Global is the default parent node.
c) In the Address field, enter an address.
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Alternatively, you can click on the map to input the address. Adding an address causes the Longitude and Latitude
coordinate fields to be automatically populated. You can manually change the longitude and latitude coordinates to
change the address.

Step 4 Click Add.

The building is created and appears under the parent site in the left pane.

Add a Basic Floor to a Building
After you add a building, you can add floors to it. You can add a basic floor that doesn't have a floor map, or
you can add a floor and include a floor map at the same time.

To add a basic floor to a building, use this procedure.

To add a floor with a CAD, non-CAD, or Ekahau file floor map, see the Cisco DNA Center User Guide.:

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
Step 2 In the left pane, hover your cursor over the ellipsis next to the desired building and choose Add Floor.
Step 3 In the Floor Name field, enter a name for the floor.

The Floor Name field has the following restrictions:

• The floor name cannot exceed 40 characters.

• Special characters & > < ? ' " / [ ] aren't allowed.

Step 4 For the Type (RF Model) drop-down list, choose the RF model to apply to the floor.

The RF model determines how the RF is calculated based on the characteristics of the floor.Note

Step 5 Click Add.

Manage Network Hierarchy

Import Your Site Hierarchy to Cisco DNA Center
You can import a site hierarchy that you exported fromCisco Prime Infrastructure as a CSV file. For information
about exporting the site hierarchy, see the Cisco DNA Center User Guide.

Before you begin

• Make sure that you have Cisco Wireless Controllers and APs in your Cisco DNA Center inventory. If
not, discover them using the Discovery feature.

• Add and position APs on a floor map.

• If you manually created sites in Cisco DNA Center that are present in Cisco Prime Infrastructure, you
must remove them from Cisco DNA Center before you can import them.
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Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
Step 2 From the map tool bar, click Import and choose Import Sites.
Step 3 In the dialog box, click one of the following radio buttons:

• Merge with Existing Sites: The downloaded site information is combined with the existing site information.

• Overwrite Existing Sites: If the same site already exists in Cisco DNA Center, the existing site information is
overwritten with the downloaded site information.

Step 4 In the dialog box, drag and drop your CSV file into the download area. Alternatively, you can click Choose a file and
navigate to where your CSV file is located, then click Upload.

If you do not have a CSV file, click Download Template to download a CSV file that you can edit and
upload.

Note

Export Your Map Archive from Cisco Prime Infrastructure

You can export map archive files from Cisco Prime Infrastructure and import them into Cisco DNA Center.
Map archives contain map information, such as floor dimensions, and calibration information, such as the
Radio Frequency (RF) attenuation model that has been applied to each floor in Cisco Prime Infrastructure.

Step 1 From the Cisco Prime Infrastructure GUI, choose Maps > Wireless Maps > Site Maps (New).
Step 2 From the Export drop-down list, choose Map Archive.

The Export Map Archive window opens, and the Select Sites window opens by default.

Step 3 Check the check box of a specific site, campus, building, or floor that you want to export. Alternatively, check the Select
All check box to export all the maps.

Step 4 Select at least one of the following options:

• Map Information: Click the On button to export floor dimensions (length, width, and height) and details about the
APs and overlay objects that have been placed on the floor maps.

• Calibration Information: Click the On button to export the RF attenuation model that has been applied to each
floor. It is a good practice to export the existing calibration data from Cisco Prime Infrastructure. Otherwise, you
must reenter the calibration details manually.

If you choose to include calibration information, you also need to specify whether to include information for selected
maps or all information, as follows:

• Calibration Information for selected maps: Calibration information for the selected site maps is exported.

• All Calibration Information: Calibration information for the selected map and any additional calibration
information that is available in the system is exported.

Step 5 Click Generate Map Archive.

The following message shows the progress of the operation:

Exporting data is in progress
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A TAR file is created and is saved to your local machine.

Step 6 Click Done.

Search the Network Hierarchy
You can search the network hierarchy to quickly find a site, building, or area. This is particularly helpful after
you have added many sites, areas, or buildings.

Step 1 To search the hierarchy, from the Search Hierarchy search field in the left pane, enter either the partial or full name of
the site, building, or floor name that you are searching.

The hierarchy is filtered based on the text you enter in the search field.

Step 2 To search the hierarchy by Site Name and Site Type filter criteria, click the filter icon in the Search Hierarchy search
field and do the following:

a. In the Site Name name field, enter the name of the site that you want to search.

b. Check the Include Address for all Building check box to include the address of all building in the search result.

c. In the Site Type area, check the check boxes next to Area, Outdoor Area, Building, or Floor that you want to
include in filter criteria.

d. Click Search.

The hierarchy is filtered based on the filter criteria.

e. To exclude the search criteria in the left pane, click the cross-mark next to respective criteria.

Edit a Site

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
Step 2 In the left pane, hover your cursor over the ellipsis next to the site and choose Edit Area.
Step 3 In the Edit Area dialog box, make the necessary edits.
Step 4 Click Update to save your changes.

Delete a Site

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
Step 2 In the left pane, hover your cursor over the ellipsis next to the site and choose Delete Area.
Step 3 In the dialog box, click OK to confirm the deletion.
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Edit a Building

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
Step 2 In the left pane, hover your cursor over the ellipsis next to the building and choose Edit Building.
Step 3 In the Edit Building dialog box, make the necessary edits.
Step 4 Click Update to save your changes.

Delete a Building
Deleting a building deletes all its container maps. APs from the deleted maps are moved to the Unassigned
state.

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
Step 2 In the left pane, hover your cursor over the ellipsis next to the building and choose Delete Building.
Step 3 In the dialog box, click OK to confirm the deletion.

Edit a Floor
After you add a floor, you can edit the floor map so that it contains obstacles, areas, and APs on the floor.

Step 1 Click the Menu icon and choose Design > Network Hierarchy.
Step 2 In the left pane, hover your cursor over the ellipsis next to the floor and choose Edit Floor.
Step 3 In the Edit Floor pop-up, make the necessary changes.
Step 4 Click Update to save the changes.

Monitor a Floor Map in 2D
The floor view navigation pane provides access to multiple map functions like:

• Use the Find feature located at the top-right corner of the floor map window to find specific floor elements
such as APs, sensors, clients, and so on. The elements that match the search criteria are displayed on the
floor map along with a table in the right pane. When you hover your mouse over the table, it points to
the search element on the floor map with a connecting line.

• Click the icon at the top-right corner of the floor map window to:

• Export a floor plan as a PDF.

• Measure the distance on the floor map.

• Set the scale to modify the floor dimensions.
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• Click the icon at the bottom-right of the floor map window to zoom in on a location. The zooming
levels depend upon the resolution of an image. A high-resolution imagemight provide more zoom levels.
Each zoom level comprises of a different style map shown at different scales, each one showing the
corresponding details. Some maps are of the same style, but at a smaller or larger scale.

• Click the icon to see a map with fewer details.

• Click the icon to view the map icon legend.

Configure Floor Map Elements and Overlays in 2D Maps
While viewing a 2D map, click Add/Edit from the map toolbar to enter edit mode. While in edit mode, you
can do the following:

• Add, position, and delete the following devices:

• Access points (APs) and planned access points (PAPs)

• Sensors

• Add, edit, and delete the following overlay objects:

• Coverage areas

• Location regions

• Walls

• Shelving units

• Markers

• GPS markers

• Align points

Work with APs on a Floor Map

CiscoDNACenter computes heatmaps for the entiremap that show the relative intensity of the Radio Frequency
(RF) signals in the coverage area. For 2D wireless maps, the heatmap is only an approximation of the actual
RF signal intensity because it does not consider the attenuation of various building materials, such as drywall
or metal objects, nor does it display the effects of RF signals bouncing off obstructions.

Follow these guidelines while placing APs on the floor map:

• Place APs along the periphery of coverage areas to keep devices close to the exterior of rooms and
buildings. APs placed in the center of these coverage areas provide good data on devices that would
otherwise appear equidistant from all other APs.

• Location accuracy can be improved by increasing overall AP density and moving APs close to the
perimeter of the coverage area.

• In long and narrow coverage areas, avoid placing APs in a straight line. Stagger them so that each AP is
more likely to provide a unique snapshot of the device location.

• Although the design provides enough AP density for high-bandwidth applications, location suffers
because each AP view of a single device is not varied enough. Therefore, location is difficult to determine.
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Move the APs to the perimeter of the coverage area and stagger them. Each has a greater likelihood of
offering a distinctly different view of the device, resulting in higher location accuracy.

• For optimal heatmap visibility on floor maps, configure the AP height to approximately 10 feet (3 meters)
or lower.

Add, Position, Edit, and Delete APs

CiscoDNACenter computes heatmaps for the entiremap that show the relative intensity of the Radio Frequency
(RF) signals in the coverage area. For 2D wireless maps, the heatmap is only an approximation of the actual
RF signal intensity because it does not consider the RF signal reflection and other effects impacting the signal.

Before you begin

Make sure that you have Cisco APs in your inventory. If not, discover APs using the Discovery feature. See
Discovery Overview.

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
Step 2 In the left pane, click a site, then a building, and finally, the floor you are interested in.
Step 3 Ensure the APs toggle button is enabled in the map toolbar.
Step 4 From the map toolbar, click Add/Edit.
Step 5 From the map, you can add, edit, position, reposition, and remove APs. See the following table for details.

StepsAction

a. From the map left pane, click Add APs.

b. From the Add APs slide-in pane, do one of the following:

• To add a single AP: ClickAdd next to an AP that you want to add.

• To add multiple APs: Check the check boxes next to APs you
want to add and click Add Selected.

Newly added APs appear in the Unpositioned category in the map
left pane.

c. Click Save.

Add APs

a. From the Unpositioned category in the map left pane, click an AP.

b. Click the location on the floor map where you want to position the AP.

c. Click Save.

Position an AP

a. In the map, click an AP to select it.

b. Drag and drop the AP in its new position.

c. Click Save.

Reposition an AP
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StepsAction

a. In the map, click an AP.

b. From the Edit AP slide-in pane, configure the AP settings, as needed.

c. Click Save.

Edit an AP

a. Select the APs, using one of the following methods:

• Click the first device, then press and hold the Shift key while you
click the rest of the devices.

• In the map navigation toolbar, click Select by rectangle. Then click
an area of the map and drag the highlighted rectangle to select APs
in a contiguous area. All the highlighted APs within the rectangle
are selected.

b. From the Edit AP slide-in pane, configure the AP settings, as needed.

c. Click Apply.

d. Click Save.

Edit Multiple APs

When you edit multiple APs,
attribute values are displayed
if they are the same value.
Otherwise, they are blank.
Antenna values are editable
only when the selected APs
have the samemodel number
and radio (number of radios
and operating band). You
can change the model
numbers of planned APs, but
not added APs.

Note

a. Click the AP or planned AP.

b. From the map left pane, click Remove APs.

c. Click Save.

Remove APs

Quick View of APs

Hover your cursor over the AP icon on the floor map to view AP details, Rx neighbor information, client
information, and Device 360 information.

• Click Info to view the following AP details:

• Associated: Indicates whether an AP is associated or not.

• Name: AP name.

• MAC Address: MAC address of the AP.

• Model: AP model number.

• Admin/Mode: Administration status of the AP mode.

• Type: Radio type.

• OP/Admin: Operational status and AP mode.

• Channel: Channel number of the AP.

• Antenna: Antenna name.
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• Azimuth: Direction of the antenna.

• Click the Rx Neighbors radio button to view the immediate Rx neighbors for the selected AP on the
map with a connecting line. The floor map also shows whether the AP is associated or not along with
the AP name.

• Click Device 360 to get a 360° view of a specific network element (router, switch, AP, or Cisco wireless
controller).

For Device 360 to open, you must have the Assurance application installed.Note

Add Sensors to a Map

Make sure you have the Cisco AP 1800S sensor in your inventory. The Cisco Aironet 1800s Active Sensor
must be provisioned using Plug and Play for it to show up in the Inventory.

Note

A sensor device is a dedicated AP 1800s sensor. The Cisco Aironet 1800s Active Sensor gets bootstrapped
using PnP. After it obtains the Assurance server reachability details, it directly communicates with the Assurance
server. For more information, including information about sensor tests, see the Cisco DNA Assurance User
Guide.

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
Step 2 In the left hierarchy tree, choose a floor.
Step 3 From the map toolbar, click 2D > Add/Edit > Sensors.
Step 4 From the Add Sensors slide-in pane, check the check boxes of the sensors that you want to add. Alternatively, click Add

next to the sensor row.

You can search for specific sensors using the Filter field. Search using the name, MAC address, or model
of a sensor. The search is not case-sensitive. The results are displayed in the table. Click Add to add one or
more of these sensors to the floor area.

Note

Newly added sensors appear in the Unpositioned category from the map left pane in edit mode.

Step 5 When you are done, click Save.

Add, Edit, and Delete Coverage Areas

By default, any floor area or outside area defined as part of a buildingmap is considered as a wireless coverage
area.

If you have a building that is nonrectangular or you want to mark a nonrectangular area within a floor, you
can use the map drawing tool to create a coverage area or a polygon-shaped area.

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
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Step 2 In the left hierarchy tree, choose a floor.
Step 3 From the map toolbar, click 2D > Add/Edit > Overlays > Coverage Areas.
Step 4 To add a coverage area, do the following:

a) In the Coverage Area dialog box, enter a name for the coverage area in the field.
b) Click Add Coverage.
c) Click on the map to create a point and initiate the drawing tool.
d) Continue creating points to define the coverage area shape.

The coverage area shape must have at least 3 points. Click and drag a point to redefine the coverage area
shape.

Note

e) Double-click to exit the drawing tool and finalize the coverage area shape.
f) From the map toolbar, click Save.

Step 5 To edit a coverage area, do the following:
a) From the map toolbar, click Add/Edit > Coverage Areas.
b) To redefine the shape of a coverage area, click and drag a point.
c) To edit a coverage area name, right-click the coverage area and choose Edit.
d) When you are done, in the map toolbar, click Save.

Step 6 To delete a coverage area, do the following:
a) From the map toolbar, click Add/Edit > Coverage Areas.
b) Right-click the coverage area and choose Delete.
c) After the coverage area is deleted, from the map toolbar, click Save.

Create Obstacles

You can create obstacles so that they can be considered while computing Radio Frequency (RF) prediction
heatmaps for access points.

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
Step 2 In the left pane, select the floor.
Step 3 Click Edit, which is located above the floor plan in the middle pane.
Step 4 In the Overlays panel, next to Obstacles, click Add.
Step 5 In the Obstacle Creation dialog box, choose an obstacle type from the Obstacle Type drop-down list. The type of

obstacles that you can create are Thick Wall, Light Wall, Heavy Door, Light Door, Cubicle, and Glass.
The estimated signal loss for the obstacle type you selected is automatically populated. The signal loss is used to
calculate RF signal strength near these objects.

Step 6 Click Add Obstacle.
Step 7 Move the drawing tool to the area where you want to create an obstacle.
Step 8 Click the drawing tool to start and stop a line.
Step 9 After you have outlined the area, double-click the area to highlight it.
Step 10 In the Obstacle Creation window, click Done.
Step 11 Click Save to save the obstacle on the floor map.
Step 12 To edit an obstacle, in the Overlays panel, next to Obstacles, click Edit.
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All the available obstacles are highlighted on the map.

Step 13 Click Save after the changes.
Step 14 To delete an obstacle, in the Overlays panel, next to Obstacles, click Delete.

All the available obstacles are highlighted on the map.

Step 15 Hover your cursor over the obstacle and click to delete.
Step 16 Click Save.

Add, Edit, and Delete Location Regions

You can create inclusion and exclusion areas to further refine location calculations on a floor. You can define
the areas that are included (inclusion areas) in the calculations and those areas that are not included (exclusion
areas). For example, you might want to exclude areas such as an atrium or stairwell within a building, but
include a work area, such as cubicles, labs, or manufacturing floors.

Use the following guidelines to define inclusion and exclusion areas on a map:

• Inclusion and exclusion areas can be any polygon-shaped area and must have at least 3 points.

• You can only define one inclusion region on a floor. By default, an inclusion region is defined for each
floor area when it is created. The inclusion region is indicated by a solid aqua line, and generally outlines
the entire floor area.

• You can define multiple exclusion regions in a floor area.

Define Inclusion and Exclusion Areas on a Map

Use the following guidelines to define inclusion and exclusion areas on a map:

• Inclusion and exclusion areas can be any polygon-shaped area and must have at least 3 points.

• You can only define 1 inclusion region on a floor. By default, an inclusion region is defined for each
floor area when it is created. The inclusion region is indicated by a solid aqua line, and generally outlines
the entire floor area.

• You can define multiple exclusion regions in a floor area.

Add, Edit, and Delete an Inclusion Region

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
Step 2 In the left hierarchy tree, choose a floor.
Step 3 From the map toolbar, click 2D > Add/Edit > Overlays > Location Regions.
Step 4 From the map left pane, click the Inclusion icon.
Step 5 To create an inclusion region, use the drawing tool:

a) Click the map to create a point where you want the inclusion region to begin.
b) Move the cursor to the next point and click again.
c) Continue creating points to define the inclusion region shape.
d) To finalize the shape, double-click the map.
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Alternatively, from the map left pane, click the Inclusion icon.

e) To exit the drawing tool, double-click the map again.

Step 6 To edit the location of an inclusion region, drag and drop the shape to the new location.
Step 7 To delete an inclusion region, right-click the shape and choose Delete.
Step 8 From the map toolbar, click Save.

Add, Edit, and Delete an Exclusion Region

To further refine calculations for a floor, you can define regions to exclude (exclusion regions) from the
calculations. For example, you might want to exclude regions such as an atrium or stairwell within a building.
As a rule, exclusion regions are defined within the borders of an inclusion region.

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
Step 2 In the left hierarchy tree, choose a floor.
Step 3 From the map toolbar, click 2D > Add/Edit > Overlays > Location Regions.
Step 4 From the map left pane, click the Exclusion icon.
Step 5 To create an exclusion region, use the drawing tool:

a) Click the map to create a point where you want the exclusion region to begin.
b) Move the cursor to the next point and click again.
c) Continue creating points to define the exclusion region shape.
d) To finalize the shape, double-click the map.

Alternatively, from the map left pane, click the Exclusion icon.

e) To exit the drawing tool, double-click the map again.

Step 6 To edit the location of an exclusion region, drag and drop the shape to the new location.
Step 7 To delete an exclusion region, right-click the shape and choose Delete.
Step 8 From the map toolbar, click Save.

Edit Location Regions

Step 1 In the Overlays panel, next to Location Regions, click Edit.
The available location regions are highlighted on the map.

Step 2 Make the necessary changes, and click Save.

Delete Location Regions

Step 1 In the Overlays panel, next to Location Regions, click Delete.
The available location regions are highlighted on the map.

Step 2 Hover your cursor over the region that you want to delete, and click Delete.
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Step 3 Click Save.

Create a Rail

You can define a rail line on a floor that represents a conveyor belt. Also, you can define an area around the
rail area known as the snap-width to further assist location calculations. This represents the area in which you
expect clients to appear. Any client located within the snap-width area is plotted on the rail line (majority) or
outside of the snap-width area (minority).

The snap-width area is defined in feet or meters (user-defined) and represents the distance that is monitored
on either side (east and west or north and south) of the rail.

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
Step 2 In the left pane, select the floor.
Step 3 Click Edit, which is located above the floor plan in the middle pane.
Step 4 In the Overlays panel, next to Rails, click Add.
Step 5 Enter a snap-width (feet or meters) for the rail, and click Add Rail.

A drawing icon appears.

Step 6 Click the drawing icon at the starting point of the rail line. Click again when you want to stop drawing the line or change
the direction of the line.

Step 7 Click the drawing icon twice when the rail line is drawn on the floor map. The rail line appears on the map and is
bordered on either side by the defined snap-width region.

Step 8 Click Save.
Step 9 In the Overlays panel, next to Rails, click Edit.

The available rails are highlighted on the map.

Step 10 Make changes, and click Save.
Step 11 In the Overlays panel, next to Rails, click Delete.

All the available rail lines are highlighted on the map.

Step 12 Hover your cursor over the rail line that you want to delete, and click Delete.
Step 13 Click Save.

Add, Edit, and Delete Markers

Step 1 Click the menu icon ( ) and choose Design > Network Hierarchy.
Step 2 In the left hierarchy tree, choose a floor.
Step 3 From the map toolbar, click 2D > Add/Edit > Overlays > Markers.
Step 4 From the map left pane, click the Markers icon.
Step 5 In the Place Markers dialog box, enter the name for the marker, and click Add Marker.
Step 6 To place the marker, click the map where you want to place the marker.
Step 7 To move a marker, hover your cursor over the marker until it turns blue. Then drag and drop it in the new location.
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Step 8 To edit a marker, right-click the marker and choose Edit.
Step 9 To delete a marker, right-click the marker and choose Delete.
Step 10 From the map toolbar, click Save.

Floor View Options
Click the View Options, which is located above the floor plan in the middle pane. The floor map along with
these panels appear in the right pane: Access Points, Sensor, Overlay Objects, Map Properties, and Global
Map Properties.

You can modify the appearance of the floor map by selecting or unselecting various parameters. For example,
if you want to view only the access point information on the floor map, check the Access Point check box.
You can expand each panel to configure various settings available for each floor element.

View Options for Access Points

To view access points on a map, click the On/Off button next to Access Points. Expand the Access Points
panel to configure these settings:

• Display Label: From the drop-down list, choose a text label that you want to view on the floor map for
the AP. The available display labels are:

• None: No labels are displayed for the selected access point.

• Name: AP name.

• AP MAC Address: AP MAC address.

• Controller IP: IP address of Cisco Wireless Controller to which the access point is connected.

• Radio MAC Address: Radio MAC address.

• IP Address

• Channel: Cisco Radio channel number or Unavailable (if the access point is not connected).

• Coverage Holes: Percentage of clients whose signal has become weaker until the client lost its
connection. It shows Unavailable for access points that are not connected and MonitorOnly for
access points that are in monitor-only mode.

• TX Power: Current Cisco Radio transmit power level (with 1 being high) or Unavailable (if the
access point is not connected). If you change the radio band, the information on the map changes
accordingly.

The power levels differ depending on the type of access point. The Cisco Aironet 1000 Series
Lightweight Access Point accepts a value between 1 and 5; the Cisco Aironet 1230AG Series Access
Point accepts a value between 1 and 7; and the Cisco Aironet 1240AG Series Access Point and
Cisco Aironet 1100 Series Access Point accept a value between 1 and 8.

• Channel and Tx Power: Channel and transmit power level (or Unavailable if the access point is
not connected).

• Utilization: Percentage of bandwidth used by the associated client devices (including receiving,
transmitting, and channel utilization). Displays Unavailable for disassociated access points and
MonitorOnly for access points in monitor-only mode.
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• Tx Utilization: Transmitted (Tx) utilization for the specified interface.

• Rx Utilization: Received (Rx) utilization for the specified interface.

• Ch Utilization: Channel utilization for the specified access point.

• Assoc. Clients: Total number of clients associated.

• Dual-Band Radios: Identifies and marks the XOR dual-band radios on the Cisco Aironet 2800 and
3800 Series Access Points.

• Health Score: AP health score.

• Issue Count

• Coverage Issues

• AP Down Issues

• Heatmap Type: Heatmap is a graphical representation of Radio Frequency (RF) wireless data where
the values taken by variable are represented in maps as colors. The current heatmap is computed based
on the RSSI prediction model, antenna orientation, and AP transmit power. From the Heatmap Type
drop-down list, select the heatmap type:

• None

• AP RSSI: Coverage heatmap, which identifies the strength of wireless signal in the specific band.

• RSSI Cut off (dBm): Drag the slider to set the RSSI cutoff level. The RSSI cutoff ranges from
-60 dBm to -90 dBm.

• Heatmap Opacity (%): Drag the slider between 0 to 100 to set the heatmap opacity.

• Heatmap Color Scheme: The color green indicates good heatmap coverage, and the color red
indicates poor heatmap coverage.

• Client Density: Density of associated clients.

• Map Opacity (%): Drag the slider to set the map opacity.

• IDS: Heatmap that shows the monitor mode access point coverage provided to the wireless clients
on a floor map.

• Planned Heatmap: A planned heatmap is a hypothetical heatmap that shows the possible coverage
of planned access points on a floor map.

• Coverage: Heatmap that excludes monitor-mode access points. (Available only if monitor-mode
access points are on the floor plan.)

The AP details are reflected on the map immediately. Hover your cursor over the AP icon on the map to view
AP details, RX neighbors details, client details, and switch information.

View Options for Sensors

Click the Sensors button to view sensors on the map. Expand the Sensors panel to configure these settings:
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• Display Label: From the drop-down list, choose a text label that you want to view on the floor map for
the selected access point. The available display labels are:

• None

• Name: Sensor name.

• Sensor MAC Address: Sensor MAC address.

View Options for Overlay Objects

Expand the Overlay Objects panel to configure these settings. Use the On/Off buttons to view these overlay
objects on the map.

• Coverage Areas

• Location Regions

• Obstacles

• Rails

• Markers

Configure Map Properties

Expand the Map Properties panel to configure:

• Auto Refresh—Provides an interval drop-down list to set how often you want to refresh maps data from
the database. From the Auto Refresh drop-down list, set the time intervals: None, 1 min, 2 mins, 5
mins, or 15 mins.

Configure Global Map Properties

Expand the Global Map Properties panel to configure:

• Unit of Measure—From the drop-down list, set the dimension measurements for maps to either Feet
or Meters.

Filter Device Data in a Network Hierarchy Map
For 2Dwireless maps, you can apply various filters to access points and sensors. ClickData in the map toolbar
to begin. Based on the filter criteria, the search results appear in a table.

Manage Inventory
The Inventory function retrieves and saves details, such as host IP addresses, MAC addresses, and network
attachment points about devices in its database.

About Inventory
The Inventory function retrieves and saves details, such as host IP addresses, MAC addresses, and network
attachment points about devices in its database.
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The Inventory feature can also work with the Device Controllability feature to configure the required network
settings on devices, if these settings are not already present on the device.

Inventory uses the following protocols, as required:

• Link Layer Discovery Protocol (LLDP).

• IP Device Tracking (IPDT) or Switch Integrated Security Features (SISF). (IPDT or SISFmust be enabled
on the device.)

• LLDP Media Endpoint Discovery. (This protocol is used to discover IP phones and some servers.)

• Network Configuration Protocol (NETCONF). For a list of devices, see Discovery Prerequisites, on page
5.

After the initial discovery, Cisco DNA Center maintains the inventory by polling the devices at regular
intervals. The default interval is every 24 hours. However, you can change this interval as required for your
network environment. For more information, see Update the Device Polling Interval, on page 45. Also, a
configuration change in the device triggers an SNMP trap, which in turn triggers device resynchronization.
Polling occurs for each device, link, host, and interface. Only the devices that have been active for less than
one day are displayed. This prevents stale device data, if any, from being displayed. On average, polling 500
devices takes approximately 20 minutes.

Update the Device Polling Interval
You can update the polling interval at the global level for all devices by choosing System > Settings >Network
Resync Interval or at the device level for a specific device by choosing Device Inventory. When you set the
polling interval using the Network Resync Interval, that value takes precedence over the Device Inventory
polling interval value.

If you do not want a device to be polled, you can disable polling.

Before you begin

Make sure that you have devices in your inventory. If not, discover devices using the Discovery feature.

Step 1 Click the menu icon ( ) and choose Provision > Network Devices > Inventory.
Step 2 Select the devices that you want to update.
Step 3 Click Update Polling Interval.
Step 4 From the Update Resync Interval dialog box, in the Status field, click Enabled to turn on polling or click Disabled to

turn off polling.
Step 5 In the Polling Time field, enter the time interval (in minutes) between successive polling cycles. Valid values are from

25 to 1440 minutes (24 hours).

The device-specific polling time supersedes the global polling time. If you set the device-specific polling
time and then change the global polling time, Cisco DNA Center continues to use the device-specific polling
time.

Note

Step 6 Click Update.
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Display Information About Your Inventory
The Inventory table displays information for each discovered device. Click the column header to sort the
rows in ascending order. Click the column header again to sort the rows in descending order.

To choose which columns to show or to hide in the table, click . Note that the column selection does not
persist across sessions.

When you select devices and choose a different view from the Focus drop-down list, your selection persists
in each new view.

If you choose the Default view from the Focus drop-down list, the Inventory table displays only the Device
Name, IP Address, Device Family, and MAC Address of listed devices.

By default, 25 entries are shown in the Inventory table. Click Show More to view more entries. You can
view up to 500 entries in the Inventory table.

If there are more than 25 entries in the Inventory table and you choose a different view from the Focus
drop-down list, the number of entries persists in each new view.

Before you begin

Make sure that you have devices in your inventory. If not, discover devices using the Discovery feature.

Click the menu icon ( ) and choose Provision > Network Devices > Inventory.
The Inventory window displays the device information gathered during the discovery process. The following table
describes the information that is available.
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Table 16: Inventory

DescriptionColumn

Device Name
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DescriptionColumn

Name of the device.

Click the device name to view the following device details:

Details: Displays details such as the device name, reachability status, manageability status, IP address,
device model, role, uptime, site, and so on.

• View Assurance 360: Displays theAssurance 360 window. For the window to open, you must
have installed the Assurance application.

• Interfaces

• Ethernet Ports (for all devices): Displays the operational status and administrative status
of the Ethernet ports.

Use the toggle button ( ) to switch between Ports view and Ports table. Click a
port in the Ports view or click a port name in the Ports table to view the details about the
port.

For Cisco Catalyst 4000 Series, 6000 Series, and 9000 Series switches and Cisco ASR
1000 Series Aggregation Services Routers, the Ports view displays the details of line cards
and supervisor cards if they are available.

Line card details include information about the platform, address, serial number, role, and
stack member number. Supervisor card details include information about the part number,
serial number, switch number, and slot number.

The Ports table displays the operational status, admin status, type, Native VLAN, Voice
VLAN, MAC address, PoE status, speed, MTU, and description details of the port.

For Cisco Catalyst 2000, 3000, and 9000 Series switches, either click a port in the Ports
view or click a port name in the Ports table to view the maximum allocated power and
power drawn details of that port.

• Neighbor Details:

Click a port in the Ports view or a port name in the Ports table to view the port details.
The Port Details window displays the details of the device connected to the port. In the
Neighbor Details area, the device name, the name of the port to which the device is
connected, and the capabilities of the device are shown.

The port shows the details of the CDP neighbor. If CDP is not present, the LLDP neighbor
details are shown. If both CDP and LLDP neighbors are not present, Neighbor Details is
hidden from the Port Details window.

• Color Code: This drop-down list catalogs the following views:

• Status: Displays the default view of Ethernet ports.

• VLANs: Displays the VLAN assigned to a particular port. The VLANs view allows
you to select a maximum of five VLANs and list only the VLANs that are associated
with the port.

The VLANs view displays the Selected, Not Configured, Default, andVLAN color
code of the VLAN port mapping.

• Port Channels: Displays the top five port channels configured on the device.
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The Port Channels view displays the Selected and the Port-channel color code of
the configured port channels on the device.

• Port Actions:

• Clear Mac Address: You can clear the MAC address of a port. Click a port in the
Ports view, and then, from the Port Actions drop-down list, choose Clear Mac
Address.

• Port Shut: You can shut down a port. Click a port in the Ports view, and then, from
the Port Actions drop-down list, choose Port Shut. Click Okay to confirm. The
admin status of the port changes to Down.

To change the admin status of the port to Up, from the Port Actions drop-down list,
choose Port No Shut, and click Okay.

Error-disabled ports are shown in yellow. Click an error-disabled port in the Ports view
to view the error reason. To activate an error-disabled port, clear the MAC address and
shut down the port.

• Port Description: Click theEdit icon next to PORT DESCRIPTION, enter a description,
click Save, and then click Okay to add a description to the port. Click the Delete icon to
delete the description.

• Update Native VLAN: Click the Edit icon next to Native VLAN, choose a VLAN from
the Edit Native VLAN drop-down list, and then click Save to update the VLAN. You
cannot update VLAN for the ports that have two VLANs preconfigured.

• The device software type must be Cisco IOS or Cisco IOS-XE to update a VLAN,
add a port description, clear the MAC address, and shut down the port.

• For wireless controllers, VLAN update, clear MAC address, and port shutdown are
not supported.

• VLAN update, clear MAC address, and port shutdown are supported only on access
ports.

• Port shutdown disrupts traffic on the port.

• Update Voice VLAN: Click the Edit icon next to Voice VLAN, choose a VLAN from
the Edit Voice VLAN drop-down list, and then click Save to update the VLAN.

• Native VLAN (only for switches and hubs): Displays the operational status, admin status,
VLAN type, and IP address. The table also displays the ID of the following types of
VLANs:

• VLAN ID of the manufacturing-supplied default VLAN

• VLAN ID of the configured default VLAN

• VLAN ID of the configured VLAN

Click Search or Filter to view the details of a VLAN.
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• Virtual Ports (only for wireless devices, controllers, and routers): Displays the operational
status, admin status, type, MAC address, PoE status, speed, and MTU. Click Search or
Filter to view the details of a port.

• Hardware and Software: Displays the hardware and software details of the device.

• Configuration: Displays detailed configuration information that is similar to what is displayed
in the output of the show running-config command.

This feature is not supported for APs and wireless controllers. Therefore, configuration data is
not returned for these device types.

• Power: Displays details about the power budgeted for, power consumed by, and power remaining
for the device. The Power Supplies table shows the operational status, serial number, and
vendor equipment type details.

• Fans: Displays the operational status, serial number, and vendor equipment type of fans.

• SFP Modules: Displays the details of the platform, serial number, manufacturer, and ports to
which Small Form-Factor Pluggable (SFP) modules are connected. Click Search or Filter to
view the details of ports.

• User Defined Fields: Displays the user-defined fields associated with the device.

• Config Drift: Displays the configuration changes and allows you to pick any two versions of
the same device and compare their running configuration data.

Running configuration data is not supported for devices such as wireless or legacy
controllers.

Note

• Wireless Info: Displays the primary and secondary managed locations.

• Mobility: Displays the mobility group name, RF group name, virtual IP, and mobility MAC
address.

A device name that is displayed in red means that inventory has not polled the device
and updated its information for more than 30 minutes.

Note

IP address of the device.IP Address
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Shows the device support level:

• Supported: The device pack is tested for all applications on Cisco DNA Center. You can open
a service request if any of the Cisco DNA Center functionalities for these devices do not work.

• Limited: The Device Pack for legacy devices is tested only for the following features on Cisco
DNA Center.

• Discovery

• Topology

• Device Reachability

• Config Change Audit

• Inventory: Support is provided for device details such as Device Name, IP Address, Support
Type, Device Family, Site, Reachability, MAC Address, Device Role, Image Version,
Uptime, Last Sync Status, Last Updated, Serial Number, Device Series, and Platform.

• Software Image Management: Software images may not be available for EOL devices on
cisco.com. Not recommended for EOL devices.

• Template Provisioning: Applicable only for switches.

For more information, see Cisco DNA Center Compatibility Matrix.

• Unsupported: All remaining Cisco and third-party devices that are not tested and certified on
Cisco DNA Center. You may try out various functionalities on Cisco DNA Center for these
devices, as a best effort. However, we do not expect you to raise a service request or a bug if
Cisco DNA Center features do not work as expected.

• Third Party: Device pack is built by customers or business partners and goes through the
certification process. Third-party devices will support base automation capabilities such as
Discovery, Inventory, Topology, and so on. Cisco TAC provides an initial level of support for
these devices. However, if there is a problem with the device pack, you need to contact the
business partner.

Support Type

The following is a list of the various statuses:

• Reachable: The device is reachable by Cisco DNA Center using SNMP, HTTP(S), and
NETCONF polling.

• Ping Reachable: The device is reachable by Cisco DNA Center using ICMP polling and not
reachable using SNMP, HTTP(S), and NETCONF polling.

• Unreachable: The device is not reachable using SNMP, HTTP(S), NETCONF, or ICMP polling.

Reachability
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DescriptionColumn

Shows the EoX scan status:

• Success: The device is scanned for EoX alerts successfully.

• Not Scanned: The device is not scanned for EoX alerts.

• Scan Failed: Cisco DNA Center is not able to scan the device for EoX alerts.

• Scanning: Cisco DNA Center is scanning the device for EoX alerts.

For the devices that are scanned successfully, the EoX Status column shows the number of alerts,
if any.

Click the number of alerts to view the alerts in detail.

In the slide-in pane, click theHardware, Software, andModule tabs to view the hardware, software,
and module EoX alerts.

EoX Status

Shows the device status:

• Managed with green tick icon: Device is reachable and is fully managed.

• Managed with orange error icon: Device is managed with some error such as unreachable,
authentication failure, missing NETCONF ports, internal error, and so on. You can hover the
cursor over the error message to viewmore details about the error and the impacted applications.

• Unmanaged: Device cannot be reached and no inventory information was collected due to
device connectivity issues.

Manageability

MAC address of the device.MAC Address

Cisco IOS software that is currently running on the device.Image Version

Cisco product part number.Platform

Cisco device serial number.Serial Number

Period of time that the device has been up and running.Uptime
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Role assigned to each discovered device during the scan process. The device role is used to identify
and group devices according to their responsibilities and placement within the network. If Cisco
DNA Center is unable to determine a device role, it sets the device role to Unknown.

If you manually change the device role, the assignment remains static. Cisco DNA
Center does not update the device role even if it detects a change during a subsequent
device resynchronization.

Note

If required, you can use the drop-down list in this column to change the assigned device role. The
following device roles are available:

• Unknown

• Access

• Core

• Distribution

• Border Router

Device Role

The site to which the device is assigned. Click Assign if the device is not assigned to any site. Click
Choose a Site, select a site from the hierarchy, and click Save. For more information, see Network
Hierarchy Overview, on page 26.

Site

Most recent date and time that Cisco DNA Center scanned the device and updated the database with
new information about the device.

Last Updated

Group of related devices, such as routers, switches, hubs, or wireless controllers.Device Family

Series number of the device, such as Cisco Catalyst 4500 Series Switches.Device Series

The polling interval for the device. This interval can be set globally in Settings or for a specific
device in Inventory. For more information, see the Cisco DNA Center Administrator Guide.

Resync Interval

Status of the last Discovery scan for the device:

• Managed: Device is in a fully managed state.

• Partial Collection Failure: Device is in a partial collected state and not all the inventory
information has been collected. Hover the cursor over the Information (i) icon to display
additional information about the failure.

• Unreachable: Device cannot be reached and no inventory information was collected due to
device connectivity issues. This condition occurs when periodic collection takes place.

• Wrong Credentials: If device credentials are changed after adding the device to the inventory,
this condition is noted.

• In Progress: Inventory collection is occurring.

Last Sync Status
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DescriptionColumn

Shows the status of the last provisioning operation attempted on a device. Click See Details to view
the status of past provisioning operations.

• Success: The latest operation on the device was successful.

• Success with a warning icon: The latest operation on the device was successful. But there are
failures from past provisioning operations that may need user attention.

• Failed: The latest operation on the device has failed.

• Failed with a warning icon: The latest operation on the device has failed and there are failures
from past provisioning operations that may need user attention.

• Configuring: The device is currently being configured.

• Pending: The system is trying to determine if the device will be impacted by an ongoing
provisioning operation.

• Not Provisioned: The device has not been provisioned ever once.

• Out of Sync: The Network Settings or Network Profiles of a device has been modified after
the last provisioning operation.

Provisioning Status

Shows the device credential status:

• Not Applied: The device credential is not applied on the device.

• Success: The device credential is applied on the device successfully.

• Failed: The device credential failed on the device.

Click See Details to view the details about the credentials.

The Credential Status slide-in pane shows the Type, Name/Description, Status, and Details of
the credential.

For a device whose status is Failed, hover the cursor over the ellipsis icon ( ) in the Actions
column and choose Retry or Clear.

• Retry: Applies the credential on the device.

• Clear: Clears the device credential.

Credential Status

Displays details about the AP Ethernet MAC address.AP Ethernet Mac Address

Displays details about the switch and port connected to an AP in the inventory listing page. The
inventory listing page displays the information about AP CDP neighbors, even if the connected
access switch is managed by Cisco DNA Center.

AP CDP Neighbors
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Delete a Network Device
You can delete devices from the Cisco DNA Center database, as long as they have not already been added to
a site.

When you remove a wireless sensor from the inventory, the sensor is reset to the factory defaults so that when
it rejoins, it gets the current configuration.

Before you begin

You must have administrator (ROLE_ADMIN) permissions and access to all devices (RBAC Scope set to
ALL) to perform this procedure.

Step 1 Click the menu icon ( ) and choose Provision > Network Devices > Inventory.
The Inventory window displays the device information gathered during the Discovery process.

Step 2 Check the check box next to the device or devices that you want to delete.

You can select multiple devices by checking additional check boxes, or you can select all the devices by
checking the check box at the top of the list.

Note

Step 3 From the Actions drop-down list, choose Inventory > Delete Device.
Step 4 In theWarningwindow, check theConfig Clean-Up check box to remove the network settings and telemetry configuration

from the selected device.
Step 5 Confirm the action by clicking OK.

Add a Device to a Site
Adding devices to a site configures Cisco DNA Center as the syslog and SNMP trap server, which enables
Syslog Level 2 and configures global telemetry settings.

Step 1 Click the menu icon ( ) and choose Provision > Network Devices > Inventory.
The Inventory window displays the device information gathered during the Discovery process.

Step 2 Check the check box for the devices that you want to assign to a site.
Step 3 From the Actions menu, choose Provision > Assign Device to Site.

Step 4 In the Assign Device to Site slide-in pane, click the link next to the icon for the device.
Step 5 In the Choose a floor slide-in pane, select the floor to assign to the device.
Step 6 Click Save.
Step 7 (Optional) If you selected multiple devices to add to the same location, you can check the Apply to All check box for

the first device to assign its location to the rest of the devices.
Step 8 Click Next.
Step 9 In the Task Name name field, enter a task name of your choice.
Step 10 To immediately assign the device to a site, click the Now radio button and click Assign.
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Step 11 To schedule the device assignment to a site for a later date and time, click the Later radio button to define the date and
time of the deployment and click Assign.

Step 12 To preview the CLI configuration, click the Generate Configuration Preview radio button and do the following:

• In the Task Name name field, enter a task name of your choice and click Preview.

Later, you can use the created configuration preview to deploy to the selected devices.

• In the Task Submitted message, click the Work Items link.

If you didn't notice the Task Submitted message, click the menu icon and choose Activities > Work
Items.

Note

• In theWork Itemswindow, click the CLI preview task for which you submitted the configuration preview request.

• View the CLI configuration details and click Deploy.

• To immediately deploy the device, click the Now radio button, and click Apply.

• To schedule the device deployment for a later date and time, click the Later radio button and define the date and
time of the deployment.

• In the confirmation window, click Yes.

The CLI task is marked as completed in theWork Itemswindow. You can view the CLI configuration
for this task, but you cannot deploy it again.

Note

Step 13 When assigning devices to a site, if Device Controllability is enabled, a workflow is automatically triggered to push
the device configuration from the site to the devices.
From the Focus drop-down list, choose Provision and click See Details in the Provision Status column. The
configuration that is pushed to the device is shown in a separate window if you enabled Device Controllability.

About Cisco ISE Configuration for Cisco DNA Center
If your network uses Cisco ISE for user authentication, you can configure Cisco DNA Center for Cisco ISE
integration. This enables you to see more information about wired clients, such as the username and operating
system.

Cisco ISE configuration is centralized within NCP (Network Control Platform), which enables you to configure
Cisco ISE at one GUI location. The workflow for configuring Cisco ISE is as follows:

1. Click the menu icon ( ) and choose System > Settings > External Services > Authentication and
Policy Servers, and enter the Cisco ISE server details.

2. After the Cisco ISE server is successfully added, NCP establishes a connection with NDP (Network Data
Platform) and sends the details of the pxGrid nodes, keystore, and truststore files.

3. NDP uses the configuration received from NCP to establish a pxGrid session.

4. NCP automatically detects pxGrid node failovers, persona moves, and communicates it to NDP.

5. If there are ISE deployment changes, NDP starts a new pxGrid session with a new pxGrid ACTIVE node.
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Configure Authentication and Policy Servers
Cisco DNA Center uses AAA servers for user authentication and Cisco ISE for both user authentication and
access control. Use this procedure to configure AAA servers, including Cisco ISE.

Before you begin

• If you are using Cisco ISE to perform both policy and AAA functions, make sure that Cisco DNACenter
and Cisco ISE are integrated.

• If you are using another product (not Cisco ISE) to performAAA functions, make sure to do the following:

• Register Cisco DNA Center with the AAA server, including defining the shared secret on both the
AAA server and Cisco DNA Center.

• Define an attribute name for Cisco DNA Center on the AAA server.

• For a Cisco DNA Center multihost cluster configuration, define all individual host IP addresses and
the virtual IP address for the multihost cluster on the AAA server.

• Before you configure Cisco ISE, confirm that:

• You have deployed Cisco ISE on your network. For information on supported Cisco ISE versions,
see the Cisco DNA Center Compatibility Matrix. For information on installing Cisco ISE, see the
Cisco Identity Services Engine Install and Upgrade guides.

• If you have a standalone ISE deployment, you must integrate Cisco DNA Center with the Cisco
ISE node and enable the pxGrid service and External RESTful Services (ERS) on that node.

Although pxGrid 2.0 allows up to four pxGrid nodes in the Cisco ISE deployment,
Cisco DNA Center releases earlier than 2.2.1.x do not support more than two
pxGrid nodes.

Note

• If you have a distributed Cisco ISE deployment:

• You must integrate Cisco DNA Center with the primary policy administration node (PAN),
and enable ERS on the PAN.

We recommend that you use ERS through the PAN. However, for backup, you
can enable ERS on the PSNs.

Note

• You must enable the pxGrid service on one of the Cisco ISE nodes within the distributed
deployment. Although you can choose to do so, you do not have to enable pxGrid on the PAN.
You can enable pxGrid on any Cisco ISE node in your distributed deployment.

• The PSNs that you configure in Cisco ISE to handle TrustSec or SD Access content and PACs
must also be defined in Work Centers > Trustsec > Trustsec Servers > Trustsec AAA
Servers. For more information, see the Cisco Identity Services Engine Administrator Guide.
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• You must enable communication between Cisco DNACenter and Cisco ISE on the following ports:
443, 5222, 8910, and 9060.

• The Cisco ISE host on which pxGrid is enabled must be reachable from Cisco DNA Center on the
IP address of the Cisco ISE eth0 interface.

• The Cisco ISE node can reach the fabric underlay network via the appliance's NIC.

• The Cisco ISE admin node certificate must contain the Cisco ISE IP address or FQDN in either the
certificate subject name or the Subject Alternative Name (SAN).

• The Cisco DNACenter system certificate must list both the Cisco DNACenter appliance IP address
and FQDN in the SAN field.

For Cisco ISE 2.4 Patch 13, 2.6 Patch 7, and 2.7 Patch 3, if you are using the
Cisco ISE default self-signed certificate as the pxGrid certificate, Cisco ISEmight
reject that certificate after applying those patches. This is because the older
versions of that certificate have the Netscape Cert Type extension specified as
the SSL server, which now fails (because a client certificate is required).

This issue does not occur in Cisco ISE 3.0 and later. For more information, see
the Cisco ISE Release Notes.

Note

Step 1 Click the menu icon ( ) and choose System > Settings > External Services > Authentication and Policy Servers.
Step 2 From the Add drop-down list, choose AAA or ISE.
Step 3 To configure the primary AAA server, enter the following information:

• Server IP Address: IP address of the AAA server.

• Shared Secret: Key for device authentications. The shared secret can contain up to 100 characters.

Step 4 To configure a Cisco ISE server, enter the following details:

• Server IP Address: IP address of the ISE server.

• Shared Secret: Key for device authentications.

• Username: Username that is used to log in to the Cisco ISE CLI.

This user must be a Super Admin.Note

• Password: Password for the Cisco ISE CLI username.

• FQDN: Fully qualified domain name (FQDN) of the Cisco ISE server.

• We recommend that you copy the FQDN that is defined in Cisco ISE (Administration >
Deployment > Deployment Nodes > List) and paste it directly into this field.

• The FQDN that you enter must match the FQDN, Common Name (CN), or Subject Alternative
Name (SAN) defined in the Cisco ISE certificate.

Note
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The FQDN consists of two parts, a hostname and the domain name, in the following format:

hostname.domainname.com

For example, the FQDN for a Cisco ISE server can be ise.cisco.com.

• Virtual IP Address(es): Virtual IP address of the load balancer behind which the Cisco ISE policy service nodes
(PSNs) are located. If you have multiple PSN farms behind different load balancers, you can enter a maximum of
six virtual IP addresses.

Step 5 Click Advanced Settings and configure the settings:

• Connect to pxGrid: Check this check box to enable a pxGrid connection.

If you want to use the Cisco DNA Center system certificate as the pxGrid client certificate (sent to Cisco ISE to
authenticate the Cisco DNA Center system as a pxGrid client), check the Use Cisco DNA Center Certificate for
pxGrid check box. You can use this option if all the certificates that are used in your operating environments must
be generated by the same CA. If this option is disabled, Cisco DNA Center will send a request to Cisco ISE to
generate a pxGrid client certificate for the system to use.

When you enable this option, ensure that:

• The Cisco DNA Center certificate is generated by the same Certificate Authority (CA) as is in use by Cisco
ISE (otherwise, the pxGrid authentication fails).

• The Certificate Extended Key Use (EKU) field includes "Client Authentication."

• Protocol: TACACS and RADIUS (the default). You can select both protocols.

If you do not enable TACAS for a Cisco ISE server here, you cannot configure the Cisco ISE server as
a TACACS server under Design > Network Settings > Network when configuring a AAA server for
network device authentication.

Attention

• Authentication Port: Port used to relay authentication messages to the AAA server. The default UDP port is 1812.

• Accounting Port: Port used to relay important events to the AAA server. The default UDP port is 1813.

• Port: The default TACACS port is 49.

• Retries: Number of times that Cisco DNA Center attempts to connect with the AAA server before abandoning the
attempt to connect. The default number of attempts is 3.

• Timeout: The time period for which the device waits for the AAA server to respond before abandoning the attempt
to connect. The default timeout is 4 seconds.
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After the required information is provided, Cisco ISE is integrated with Cisco DNA Center in two phases.
It takes several minutes for the integration to complete. The phase-wise integration status is shown in the
Authentication and Policy Servers window and System 360 window:

Cisco ISE server registration phase:

• Authentication and Policy Servers window: "In Progress"

• System 360 window: "Primary Available"

pxGrid subscriptions registration phase:

• Authentication and Policy Servers window: "Active"

• System 360 window: "Primary Available" and "pxGrid Available"

If the status of the configured Cisco ISE server is shown as "FAILED" due to a password change, click
Retry, and update the password to resynchronize the Cisco ISE connectivity.

Note

Step 6 Click Add.
Step 7 To add a secondary server, repeat the preceding steps.

Configure Syslog, SNMP Traps, NetFlow Collector Servers, and
Wired Client Data Collection Using Telemetry

With Cisco DNA Center, you can configure global network settings when devices are assigned to a specific
site. Telemetry polls network devices and collects telemetry data according to the settings in the SNMP server,
syslog server, NetFlow Collector, or wired client.

Before you begin

Create a site and assign a device to the site. See Create a Site in a Network Hierarchy, on page 28.

Step 1 Click the menu icon ( ) and choose Design > Network Settings > Telemetry.
Step 2 In the SNMP Traps area, do one of the following:

• Check the Use Cisco DNA Center as SNMP trap server check box.
• Check theAdd an external SNMP trap server check box and enter the IP address of the external SNMP trap server.
The selected server collects SNMP traps and messages from the network devices.

Step 3 In the Syslogs area, do one of the following:

• Check the Use Cisco DNA Center as syslog server check box.
• Check the Add an external syslog server check box and enter the IP address of the external syslog server.

Step 4 In the NetFlow area, do one of the following:

• Click the Use Cisco DNA Center as NetFlow collector server radio button. The NetFlow configuration on the
device interfaces is completed only when you enable application telemetry on the device. Select the NetFlow collector
at the site level to configure the NetFlow destination server to the device.
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• Click the Add Cisco Telemetry Broker (CTB) radio button and add the IP address and port number of the Cisco
Telemetry Broker. The Cisco Telemetry Broker collects NetFlow records from the device and sends the information
to the destination.

Cisco DNA Center must be configured as a destination in Cisco Telemetry Broker to receive NetFlow
records. If Cisco DNA Center is not configured as a destination, the Application Experience does not
work.

Note

Step 5 In the Wired Client Data Collection area, click the Enable Cisco DNA Center IPDT on all devices radio button to
turn on IP Device Tracking (IPDT) on the access devices of the site.

If you don't want to enable IPDT for the site, click the Disable radio button (the default).

You must enable IPDT to preview the CLI configuration. When provisioning a device, you can preview the
CLI configuration before deploying it on the device.

Note

Step 6 In the Wireless Controller, Access Point and Wireless Clients Health area, check the Enable Wireless Telemetry
check box to monitor the health of the wireless controllers, APs, and wireless clients in your network.

Step 7 Click Save.

Configure Cisco AI Network Analytics Data Collection
Use this procedure to enable Cisco AI Network Analytics to export network event data from network devices
as well as the site hierarchy to the Cisco DNA Center.

Before you begin

• Make sure that you have the Cisco DNA Advantage software license for Cisco DNA Center. The AI
Network Analytics application is part of the Cisco DNA Advantage software license.

• Make sure that you have downloaded and installed the AI Network Analytics application. See the
"Download and Install Packages and Updates" topic in the Cisco Digital Network Architecture Center
Administrator Guide.

• Make sure that your network or HTTP proxy is configured to allow outbound HTTPS (TCP 443) access
to the following cloud hosts:

• api.use1.prd.kairos.ciscolabs.com (US East Region)

• api.euc1.prd.kairos.ciscolabs.com (EU Central Region)

Step 1 Click the menu icon ( ) and choose System > Settings.
Step 2 Scroll down to External Services and choose Cisco AI Analytics.

The AI Network Analytics window appears.
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Step 3 Do one of the following:

• If you have an earlier version of Cisco AI Network Analytics installed in your appliance, do the following:

a. Click Recover from a config file.

The Restore AI Network Analytics window appears.

b. Drag-and-drop the configuration files in the area provided or choose the files from your file system.

c. Click Restore.

Cisco AI Network Analytics might take a few minutes to restore, and then the Success dialog box appears.

• If this is the first time you are configuring Cisco AI Network Analytics, do the following:

a. Click Configure.

b. In the Where should we securely store your data? area, choose the location to store your data. Options are:
Europe (Germany) or US East (North Virginia).

The system starts testing cloud connectivity as indicated by the Testing cloud connectivity... tab. After cloud
connectivity testing completes, the Testing cloud connectivity... tab changes to Cloud connection verified.

c. Click Next.

The terms and conditions window appears.
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d. Click the Accept Cisco Universal Cloud Agreement check box to agree to the terms and conditions, and then
click Enable.

Cisco AI Network Analytics might take a few minutes to enable, and then the Success dialog box appears.

Step 4 In the Success dialog box, click Okay.
The AI Network Analytics window appears, and the Enable AI Network Analytics toggle button displays .

Step 5 (Recommended) In the AI Network Analytics window, click Download Configuration file.

Disable Cisco AI Network Analytics Data Collection
To disable Cisco AI Network Analytics data collection, you must disable the AI Network Analytics feature,
as follows:

Step 1 Click the menu icon ( ) and choose System > Settings.
Step 2 Scroll down to External Services and choose Cisco AI Analytics.

For each feature, a check mark ( ) indicates that the feature is enabled. If the check box is unchecked ( ), the
feature is disabled.

Step 3 In the AI Network Analytics area, click the Enable AI Network Analytics toggle button so that it is unchecked (
).

Step 4 Click Update.
Step 5 To delete your network data from the Cisco AI Network Analytics cloud, contact the Cisco Technical Response Center

(TAC) and open a support request.
Step 6 (Optional) If you have misplaced your previous configuration, click Download configuration file.
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Update the Machine Reasoning Knowledge Base
Machine Reasoning knowledge packs are step-by-step workflows that are used by the Machine Reasoning
Engine (MRE) to identify security issues and improve automated root cause analysis. These knowledge packs
are continuously updated as more information is received. The Machine Reasoning Knowledge Base is a
repository of these knowledge packs (workflows). To have access to the latest knowledge packs, you can
either configure Cisco DNA Center to automatically update the Machine Reasoning Knowledge Base on a
daily basis, or you can perform a manual update.

Step 1 Click the menu icon ( ) and choose System > Settings.
Step 2 Scroll down to External Services and choose Machine Reasoning Knowledge Base.

The Machine Reasoning Knowledge Base window shows the following information:

• INSTALLED: Shows the installed version and installation date of theMachine Reasoning Knowledge Base package.

When there is a new update to the Machine Reasoning Knowledge Base, the AVAILABLE UPDATE area appears in
the Machine Reasoning Knowledge Base window, which provides the Version and Details about the update.

• AUTO UPDATE: Automatically updates the Machine Reasoning Knowledge Base in Cisco DNA Center on a daily
basis.

• CISCO CX CLOUD SERVICE FOR NETWORK BUG IDENTIFIER AND SECURITY ADVISORY:
Integrates Cisco DNA Center with CX Cloud that allows you to perform an automated config. This integration
provides enhanced vulnerability detection on devices directly from security advisories tool on Cisco DNA Center.

Step 3 (Recommended) Check the AUTO UPDATE check box to automatically update the Machine Reasoning Knowledge
Base.
The Next Attempt area shows the date and time of the next update.

You can perform an automatic update only if Cisco DNA Center is successfully connected to the Machine Reasoning
Engine in the cloud.

Step 4 To manually update the Machine Reasoning Knowledge Base in Cisco DNA Center, do one of the following:

• Under AVAILABLE UPDATES, click Update. A Success pop-up window appears with the status of the update.
• Manually download theMachine ReasonKnowledge Base to your local machine and import it to Cisco DNACenter.
Do the following:

a. Click Download.

The Opening mre_workflow_signed dialog box appears.

b. Open or save the downloaded file to the desired location in your local machine, and then click OK.

c. Click Import to import the downloadedMachine Reasoning Knowledge Base from your local machine to Cisco
DNA Center.

Step 5 Check the CISCO CX CLOUD SERVICE FOR NETWORK BUG IDENTIFIER AND SECURITY ADVISORY
check box to enable Cisco CX Cloud connection with network bug identifier and security advisory.

Step 6 In the Security Advisories Settings area click the RECURRING SCAN toggle button to enable or disable the weekly
recurring scan.
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Step 7 Click the CISCO CX CLOUD toggle button to enable or disable the Cisco CX cloud.

Enable Localization
You can view the Cisco DNA Center GUI screens in English (the default), Chinese, Japanese, or Korean.

To change the default language, perform the following task:

Step 1 In your browser, change the locale to one of the supported languages: Chinese, Japanese, or Korean.

• From Google Chrome, do the following:

a. Click the icon in the top-right corner, and then choose Settings.

b. Scroll down and click Advanced.

c. From the Languages > Language drop-down list, choose Add languages.

The Add languages pop-up window appears.

d. Choose Chinese, Japanese, or Korean, and then click Add.

• From Mozilla Firefox, do the following:

a. Click the icon in the top-right corner, and then choose Options.

b. From the Language and Appearance > Language area, choose Search for more languages.

The Firefox Language Settings pop-up window appears.

c. From the Select a language to add drop-down list, choose Chinese, Japanese, or Korean.

d. Click Ok.

Step 2 Log in to Cisco DNA Center.

The GUI screens are shown in the selected language.
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Figure 2: Example Localized Login Screen
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