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Floor Maps Overview
There are several reasons to add floors with floor maps. One reason is to see your wireless network the way
it exists today. Another reason is to help you plan and visualize future changes.

You can visualize your wireless network by creating or importing a floor map that contains various building
components, like walls and windows, and then positioning your wireless devices on it.

Interactive planning helps you plan a floor layout by drawing planned, or hypothetical, APs and obstacles
with a raster image or a CAD floor plan as the backdrop. You can export the floor map as a PDF and share it
with the technicians who are mounting the APs. The floor drawing helps the technicians to visualize the floor
layout and the exact AP mount locations.

With interactive floor planning, you can:

• Create a floor layout with a raster or CAD floor plan as the canvas.

• Place the planned APs or hypothetical APs on the floor map based on the signal coverage requirement.
These hypothetical APs or planned APs are not yet installed or discovered by Catalyst Center.

• Assign the antenna type and orientation.

• Draw obstacles, such as walls and shelving on the floor, that impact the signal attenuation.

• Plan all APs in sequence.

• Export the floor map as a PDF.
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Heatmap Overview
A heatmap is a visual representation of the Radio Frequency (RF) signal coverage of the wireless network
devices in a particular area. In Catalyst Center, you can generate a heatmap on a per floor basis by creating
or importing a floor map that contains various building components, like walls and windows, and then
positioning your wireless devices on it.

Using the floor map, Catalyst Center computes 2D and 3D heatmaps that show the relative intensity of the
RF signals in the coverage area. For 2D wireless maps, the heatmap is computed at height of 3 feet from the
floor, while in 3D wireless maps, the heatmap is computed using the entire volume of the floor (from
floor-to-ceiling). For this reason, using 3Dwireless maps is especially useful for computing wireless coverage
in high-ceiling environments, like warehouses.

In addition, the 3D wireless heatmap can compute the effect of a floor's signal coverage on its neighboring
floors. Neighboring floors are the two floors directly above and below the selected floor. Neighboring floors
are configurable, meaning you can choose which neighboring floors you want to use in a heatmap computation.
(See Contributing Floors in 3D Map View Options, on page 47.) In this way, you can detect, visualize, and
analyze the impact of a floor's signal coverage on other floors. For example, you might have clients on the
first floor who are connecting with APs on the second floor, or clients might be competing for signal on the
same channel (called cochannel interference). In some cases, this might be an intentional design. However,
if this design isn't intentional, you can take steps to change it.

The legacy heatmap generator is still available to be used. However, we recommend that you use the enhanced
3D-computed heatmap generator for both 2D and 3D heatmaps, because it can generate heatmapsmuch faster.

3D-Computed Heatmap Generator

The 3D-computed heatmap generator, which is enabled by default, offers several advantages over the legacy
heatmap generator. It uses the specialized graphics processing unit (GPU) to accelerate graphics rendering.
Therefore, it can generate heatmaps substantially faster than the legacy heatmap generator. In addition, you
can set a limit to the number of walls that are included in a heatmap computation, which also helps to enhance
processing speed.

The 3D-computed heatmap generator automatically removes small obstructions (under 0.75 ft) and the second
sides of the walls, leaving only one side per wall. (Catalyst Center applies an attenuation value for each wall,
not for each side of a wall.)

Legacy Heatmap Generator

The legacy (server-based) heatmap generator is still available to be used. However, we recommend that you
use the enhanced 3D-computed heatmap for 2D heatmaps because performance and accuracy are much better.

The legacy server-based heatmap generator has a limit on the number of walls that can used to compute 2D
and 3D heatmaps. The maximum number of walls for a 2D heatmap is 300, after optimization. If your CAD
file contains more, Catalyst Center alerts you and preserves the 300 most relevant walls (based on the length
of the wall multiplied by its attenuation). The maximum number of walls for a 3D heatmap is 3000, after
optimization. If your CAD file contains more, Catalyst Center alerts you and preserves the 3000 most relevant
walls (based on the length of the wall multiplied by its attenuation).

Although the 3D-computed heatmap generator is enabled by default, you can disable it and use the legacy
heatmap generator instead.
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Wireless Maps Prerequisite
The system you use to compute and display both 2D and 3D wireless heatmaps must have a Graphical
Processing Unit (GPU) installed and enabled on it. For example, if you're using a Windows virtual machine
(VM), you need to make sure that it has a GPU.

Add a Floor with a Map File
When you create a floor, you can include a floor map at the same time. The following topics help you understand
the different floor creation methods depending on the floor map file type that you use. Procedures for each
method are also provided.

Floor Map Creation Methods
To view a wireless map, first you need to create or import a floor map:

• Create a Floor Map: To create a floor map from scratch, you need to add the floor elements manually.
The floor elements, like walls, windows, shelving, and so on, are displayed in the wireless map and used
for heatmap computations. For details, see 2D Floor Map Devices and Overlay Objects, on page 8.

• Import a CAD file: When you use a CAD file (DXF or DWG file type) to import a floor map, Catalyst
Center converts the CAD layers into the floor elements (walls, windows, shelving, and so on) that you
specify. The floor elements are displayed in the wireless map and are used for heatmap computations.

Previously, Catalyst Center didn't limit the number of walls that could be imported from a CAD file.
Now, however, Catalyst Center allows you to set a limit. The fewer walls you import, the less time it
takes for the heatmap to be computed. For more information about heatmap generation, see Heatmap
Overview, on page 2.

When deciding which layers and elements to import, focus on obstacles that create the most signal
attenuation. In principle, the longer, thicker, and denser a wall is, the higher its attenuation. Low walls,
like cubicles, and narrow walls, like columns, have low attenuation and have little effect on the heatmap.
However, even if a material of an obstacle is dense, the attenuation might not be significant if the signal
can radiate around it. If you're not interested in the coverage outside of a building, don't include external
walls or windows. Doing so provides better 3D visualization of the inside of the building.

If your CAD file doesn't have walls in specific layers but has walls mixed with other elements, don't
select them for import. You can add walls manually later. For information, see Add, Edit, and Remove
Walls, on page 27.

Block inserts and proxy entities can't be imported. Imported layers must contain only native elements
like lines, polylines, arcs, and so on.

For the procedure, see Add a Floor with a CAD Map File, on page 4.

• Import a non-CAD image file: You can use JPG, GIF, PNG, or PDF files to import the floor plan.
Typically, this type of file is used to create 2D floor maps. However, you need to manually create the
floor elements, such as the walls and shelving, for them to be represented in the wireless map. For the
procedure, see Add a Floor with a Non-CAD Map File, on page 5.

• Import a Ekahau Pro Project plan: You can import Ekahau project data, such as the obstacles, APs,
and more, to create a wireless map. For the procedure, see Import an Ekahau Project to Catalyst Center.

Work with Wireless 2D and 3D Floor Maps
3

Work with Wireless 2D and 3D Floor Maps
Wireless Maps Prerequisite

b_cisco_catalyst_center_user_guide_237_chapter7.pdf#nameddest=unique_209


Guidelines for Image Files to Use in Maps
Follow these guidelines to use map image files:

• Use a graphical application that can save the map image files to any of these formats—.jpg, .gif, .png,
.pdf, .dxf, and .dwg.

• Map image files can be of any size. Catalyst Center imports the full definition of the original images to
its database, but during display, it automatically resizes them to fit the workspace.

• Obtain the horizontal and vertical dimensions of the site in feet or meters before importing. This helps
you to specify these dimensions during map import.

• Avoid using floor map images with rotation metadata, because the images might not render correctly
when synced to CMX or Cisco Spaces. Although the floor map images might be in formats that are
supported by Catalyst Center, the ways in which certain tools add the metadata can be rendered differently.
For example, an image file with rotation metadata that is opened in three different applications might
render horizontally in two applications and vertically in the other.

Add a Floor with a CAD Map File
You can use CAD files (DXF or DWG file types) to create a floor map.

For 2D floor maps, you must choose the CAD layers that you want to be used in the 2D view. For 3D floor
maps, Catalyst Center converts the CAD layers you choose into the floor elements that you define. You can
define floor elements as walls, shelving, windows, obstacles, and so on.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, hover your cursor over the ellipsis next to the building and choose Add Floor.
Step 3 In the Floor Name field, enter a name for the floor.
Step 4 From the Type (RF Model) drop-down list, choose the RF model to apply to the floor. The RF model determines how

the RF is calculated based on the characteristics of the floor.
Step 5 Drag and drop the CAD file (the DXF or DWG file type) to the Floor Image area.

When importing a CAD file, Catalyst Center will only import entities of the following types:

• Lines, open polylines, and closed polygons: LINE, LWPOLYLINE, POLYLINE, and SOLID

• Radius-based: ARC, CIRCLE, ELLIPSE (including arcs of ellipse)

• Other geometry elements: SPLINE

• Texts: ATTRIB, MTEXT, TEXT

• Block insertions (normally used for furniture): INSERT

By default, overlays are not displayed after you import a map. So, after you import a floor plan, make sure
that you enable the overlay visibility. From the map toolbar, clickView Options. From the right pane, expand
Overlay Objects and click the toggle button for each object you want to display.

Note

Step 6 In the Floormap window, choose the CAD layers that you want to include in the floor map:
a) In the 2D column, check the check boxes corresponding to the CAD layers that you want in the 2D floor map.
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If some elements aren’t displayed on the map (even when the 2D check boxes are checked for the
corresponding CAD layers), go to AutoCAD, open the required CAD file, select all the elements in the
required layers, run the Explode command, and save it as a new DWG file. This action converts
unsupported wrapper entities, like group and proxy entities, to entities that Catalyst Center can read.
Then close the Floormap window and upload the updated CAD file (see Step 5, on page 4).

Tip

b) In the Wall/Shelving Type column, click the drop-down and, for each CAD layer that you want converted, choose
the wall or shelving type that you want the CAD layer converted into.

Each wall or shelving type has a decibel (dB) value associated with it. This dB value is used to compute signal
attenuation in the heatmap. For more information, see Floor Map Creation Methods, on page 3.

After a wall/shelving type is selected, the Counter column is updated with the number of units detected in the CAD
file and the Total Selected Walls Counter is incremented. If the total number of selected walls exceeds the import
walls limit, you have three options to proceed:

• Add the floormap with the current number of walls. In this case, Catalyst Center imports only the most relevant
walls (equal to the import walls limit).

• Increase the import walls limit. Keep in mind that the more walls you import, the longer it takes for the heatmap
to be computed.

• Decrease the total number of selected walls to a number that doesn't exceed the import walls limit by deselecting
one or more wall/shelving types.

c) Click Use Selected Layers.

Step 7 Enter the floor map dimensions in the Width, Length, and Height fields.
Step 8 Click Add.

By default, the map is displayed with a grid. To turn the grid off or on, use the Show Grid toggle button at the bottom-left
side of the map.

After you import a floor plan, make sure that you enable the overlay visibility. (From the floor, click View
Options and enable the overlay toggles in Overlay Objects). By default, overlays are not displayed after
you import a map.

Note

Add a Floor with a Non-CAD Map File
You can use non-CAD files (JPG, GIF, PNG, or PDF file types) to create a floor map. However, when using
a non-CAD file, the 3D floor elements, such as walls and shelvings, cannot be imported, and you must add
them manually later. For more information, see 2D Floor Map Devices and Overlay Objects, on page 8.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, hover your cursor over the ellipsis next to the building and choose Add Floor.
Step 3 In the Floor Name field, enter a name for the floor.
Step 4 In the Global Unit System area, select Feet or Meters.

When the floor is added, all the floors across all the sites sync to display all measurements in your chosen unit system.
To update the global unit system, see 2D Map View Options, on page 35.
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Step 5 From the Type (RF Model) drop-down list, choose the RF model to apply to the floor. The RF model determines how
the RF is calculated based on the characteristics of the floor.

Step 6 Drag and drop the non-CAD file (JPG, GIF, PNG, or PDF file type) onto the Floor Image area.

Ensure to provide the precise dimensions of floors that are in the PDF format, because the image width
and height ratio cannot be extracted from them.

Note

Step 7 Click Add.

The floor map is created.

After you import a floor plan, make sure that you enable overlay visibility. (From the floor, click View
Options and in Overlay Objects, enable overlay visibility by clicking the overlay object's corresponding
toggle button.) By default, overlays are not displayed after you import a map.

Note

Step 8 To add walls as a 3D floor element, do the following:
a) From the map toolbar, click 2D > Add/Edit > Overlays > Walls.
b) From the left pane of the map, click the wall type that you want to add.

If the wall type is not in the list, click Add Wall Type to create a new wall type.

c) Use the drawing tool to create a wall on the map:

• Click where you want to begin the wall. Then move your cursor to the next point and click again. Continue
this process until you have created the wall in the shape you want.

• To finalize the wall, double click where you want the wall to end. To cancel the drawing, right-click the map.

• To change the type of an existing wall, right-click the shape and choose Change Type.

• To move an existing wall, drag and drop the shape to the new location.

• To remove an existing wall, right-click the shape and choose Delete.

Figure 1: Adding a Wall with the Drawing Tool

Step 9 To add shelving units as a 3D floor element, do the following:
a) In the map toolbar, click 2D > Add/Edit > Overlays > Shelving Units.
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b) In the left pane of the map, click the shelving type that you want to add.

• In the Shelving dialog box, you can edit the name, dimensions, and orientation of the shelving type. Orientation
refers to the angle of the shelving, for example, 0 means that the shelving is vertical and parallel to the y axis.

• If a shelving type is not in the list, click Add Shelving Type to create a new shelving type.

Figure 2: Choosing a Shelving Type to Add

c) In the Shelving dialog box, click Add Shelving to add the shelving to the floor map.
d) Drag and drop the shelving to move it to a location on the floor map.
e) Right-click the shelving and choose one of the following actions:

• Edit: Edit the name, dimensions, and orientation of the shelving.

• Clone: Create a copy of the shelving.

• Array: Create an array of shelving by specifying the number of shelves and the distance between them.

• Remove: Remove the shelving from the floor map.

Step 10 When you're done, click Save in the map toolbar.
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Work with 2D Maps
2D maps are primarily used to configure elements on a floor map and view heatmaps.

Using 2D maps, you can add floor map elements and overlays. While viewing a 2D map, you can manipulate
the display of the various elements and overlays. You can also filter device data and identify wireless interferers.

Catalyst Center calculates the strength and quality of wireless signals. These RF predictions are commonly
known as heatmaps, because they show the relative intensity of the RF signals on the 2D wireless coverages
area map.

2D Floor Map Devices and Overlay Objects
In 2D maps, you can configure devices and overlay objects on your floor maps.

Devices

• APs: An access point (AP) serves as the connection point between wireless and wired networks or as
the center point of a standalone wireless network. In 2D maps, an AP represents an actual, installed
device. For a list of APs that Catalyst Center supports, see the Cisco Catalyst Center Compatibility
Matrix.

• Planned APs: Planned APs are representations of APs that have not been installed yet. By placing
planned APs on a map, you can envision your wireless network RF coverage and make changes before
you actually install the APs.

• Sensors: A sensor is a dedicated Cisco Aironet 1800S Active Sensor that gets bootstrapped using Cisco
PnP. After it obtains the Assurance server reachability details, it communicates directly with the Assurance
server. For more details, including information about sensor tests, see theCisco Catalyst Assurance User
Guide.

Overlay Objects

• Coverage Areas: By default, any area defined as part of a floor map is considered as a wireless coverage
area. However, if you have a building that is nonrectangular or you want to mark a nonrectangular or
polygon-shaped area on a floor, you can use the Coverage Areas drawing tool to create a coverage area.

• Openings: An opening, also called an atrium, is an open-air or skylight-covered area within a building.
An opening can extend through multiple floors and can affect wireless signal coverage areas.

• Location Regions: Location regions define areas that are included in or excluded from the computation
of heatmaps. Inclusion areas are included in the calculations. and exclusion areas are not included. For
example, you might want to exclude areas such as openings, atriums, or stairwells within a building, but
include a work area, such as cubicles, labs, or manufacturing floors.

• Walls: Walls define any exterior or interior vertical structures in a building, such as windows, cubicles,
and doors. Because they can be made of different materials and have different densities, they can
significantly impact RF signal attenuation and heatmap calculation. For example, the more walls you
include in a floor map, the longer it can take to compute a heatmap. Although, even if you have a high
number of walls on your floormap, you can adjust the number used to compute the heatmap For
information, see 2D Map View Options, on page 35 and 3D Map View Options, on page 47.
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• Shelving Units: Shelving units are obstacles that can significantly impact RF signal attenuation and
heatmap calculation. A high-ceiling warehouse is an example of a location with shelving units.

• Markers: A marker identifies a location on a map. When you create a marker, you can name it and
position it to help you identify it later.

• GPS Markers: When integrated with Catalyst Center, location services, such as Cisco Spaces or Cisco
Connected Mobile Experiences (CMX), use GPS markers to calculate the approximate geographical
location of clients.

• Align Points: Align points are markers that are used to position multiple floors that have different physical
shapes. In 3D maps, floors are aligned at the top-left corner of the map (point 0,0). If you manage each
floor independently, the misalignment is not a problem. However, to use some of the features of 3D
maps, the floors need to be aligned as they are in reality. To compensate this misalignment, you can
insert one or more align points on two or more floors, so that the floors align properly one on top of the
other in a 3D map.

Work with APs on a Floor Map
Catalyst Center computes heatmaps for the entire map that show the relative intensity of the Radio Frequency
(RF) signals in the coverage area. For 2D wireless maps, the heatmap is only an approximation of the actual
RF signal intensity because it does not consider the attenuation of various building materials, such as drywall
or metal objects, nor does it display the effects of RF signals bouncing off obstructions.

Follow these guidelines while placing APs on the floor map:

• Place APs along the periphery of coverage areas to keep devices close to the exterior of rooms and
buildings. APs placed in the center of these coverage areas provide good data on devices that would
otherwise appear equidistant from all other APs.

• Location accuracy can be improved by increasing overall AP density and moving APs close to the
perimeter of the coverage area.

• In long and narrow coverage areas, avoid placing APs in a straight line. Stagger them so that each AP is
more likely to provide a unique snapshot of the device location.

• Although the design provides enough AP density for high-bandwidth applications, location suffers
because each AP view of a single device is not varied enough. Therefore, location is difficult to determine.
Move the APs to the perimeter of the coverage area and stagger them. Each has a greater likelihood of
offering a distinctly different view of the device, resulting in higher location accuracy.

• For optimal heatmap visibility on floor maps, configure the AP height to approximately 10 feet (3 meters)
or lower.

Export APs from Cisco Prime Infrastructure and Import into Catalyst Center
Catalyst Center allows you to import, assign, and position a collection of APs to the floor map. If you have
an existing collection of APs on Cisco Prime Infrastructure, you can import it into Catalyst Center, saving
time and effort spent in importing, assigning, and positioning APs to the floor map.

This procedure describes how to export an existing collection of APs from Cisco Prime Infrastructure and to
import it into Catalyst Center.
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Before you begin

• To perform the following task, you must be a Super Admin or Network Admin.

• Make sure that you have APs in your inventory. If not, discover them using the Discovery feature.

• Add and position APs on a floor map.

• The area, building, and floor must be present in the site hierarchy.

Step 1 Export the AP positions from Cisco Prime Infrastructure as a CSV file to your workstation.
Step 2 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 3 From the left hierarchy tree, hover your cursor over the ellipsis next to the site and choose Import Access Points.

Alternatively, from the map toolbar, you can click Import and choose Import Access Points.

Step 4 In the Import Access Points dialog box, drag and drop the AP file, or click Choose a file to select the file from your
workstation.

• To manually create the AP Positions CSV file with the Prime template, export the Prime template to
your workstation by clicking Download Prime Template. The Prime template does not support nested
files.

• To manually create the AP Positions CSV file with the Catalyst Center template, export the Catalyst
Center template to your workstation by clickingDownload Cisco DNA Center Template. The Catalyst
Center template supports nested files.

Wait for the CSV file to download. The CSV file contains information about the AP positions of various
sites in the network.

Note

Step 5 Click Import.

The Import Summary window is displayed.

• The Information tab shows the list of successfully imported APs.

• Click the Warning tab to see the list of warnings.

• Click the Error tab to see the list of errors.

Step 6 In the top-right corner of the Import Summary window, click Done to return to the Network Hierarchy window.

Add APs to a Map
This procedure describes how to add APs to a map.

Before you begin

Make sure that you have Cisco APs in your inventory. If not, discover them using the Discovery feature. See
Discovery Overview.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
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Step 2 From the left hierarchy tree, choose a floor.
Step 3 From the map toolbar, click 2D > Add/Edit.

By default, the Devices and Access Points toggle buttons are chosen.

Step 4 In the left pane of the map, click Add Access Points.
Step 5 In the Add Access Points slide-in pane, do one of the following in the table:

• To add a single AP: Locate the AP that you want to add, and scroll to the right and click Add.
• To add multiple APs: Check the check boxes next to the APs you want to add, and click Add Selected.

You can search for APs using the search option available. Use the Filter field to search for APs using the
AP name, MAC address, model, or Cisco Wireless Controller. The search is case-insensitive. The search
results appear in a table. Click Add to add one or more of these APs to the floor area.

Note

In edit mode, newly added APs are displayed in the Unpositioned category in the map left pane. For more information,
see Position an AP on a Map, on page 14.

Step 6 After adding the APs to a floor, close the Add Access Points slide-in pane.

What to do next

When you add an AP to a map, the wireless map automatically stores the following data even after the AP is
deleted from the inventory:

• AP name

• AP MAC address

• Current site of the AP

• Current position of the AP on the map

If you delete the corresponding site from the network hierarchy, the stored AP data is also removed.Note

When you delete the wireless controller with all its managed APs from the inventory, Catalyst Center displays
a planned AP icon for the corresponding APs on the map. For more information, see About the AP Icon and
Planned AP Icon, on page 38.

If the same AP is rediscovered in the inventory later, Catalyst Center automatically places it back on the map
at the same site and position even if a different wireless controller manages it.

To remove the AP data from the map when the AP is deleted from the inventory, you can do one of the
following:

• Before deleting the wireless controller from the inventory, assign the corresponding APs to the Global
site. For more information, see Add a Device to a Site.

• After deleting the wireless controller from the inventory, remove the corresponding planned APs from
the map. For more information, see Remove APs from a Map, on page 22.
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Add Planned APs to a Map
This procedure shows you how to use the AP Model Catalog feature to add a planned AP to a floor and
configure its model, antenna type, azimuth, and elevation orientation. Using the planned AP that you just
created and placed, you can add more planned APs with the same properties.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit.

By default, the Devices and Access Points toggle buttons are chosen.

Step 4 In the left pane of the map, in the Planned AP Models area, click the AP model of the planned AP that you want to
add.

If the AP model isn't listed, click Add Model and choose the AP model to add to the list.Note

Step 5 On the floor map, click the location where you want to place the planned AP.

A planned AP of the selected model is added to the floor map, and the Edit Planned AP slide-in pane is displayed
with an AP name added to it by default.

Step 6 In the Edit Planned AP slide-in pane, click the gear icon that is located next to the AP Name field.

The Name pattern dialog box is displayed.

Step 7 When you add the first AP to the floor, make sure that you enter a valid name pattern, for example,
SJC-BLD21-FL2-AP####, and then click Set name pattern.

The planned APs must be unique within Catalyst Center. So, make sure that the name pattern identifies
the floor.

Note

The #### in the name pattern is replaced by numbers in the AP Name, for example, SJC-BLD21-FL2-AP0001,
SJC-BLD21-FL2-AP0002, and so on.

Step 8 From the Antenna drop-down list, choose the appropriate antenna type, including dual antennas, for the AP.

The antenna image reflects the selected antenna.Note

Step 9 Depending on the antenna type, enter the Azimuth and Elevation orientation in degrees.
Step 10 (Optional) Configure any of the other settings, as needed. For information about these settings, see Edit an AP, on page

18.
Step 11 Perform the following actions, as needed:

• To add another planned AP with the same properties as that of the planned AP that you just added, on the floor
map, click a location where you want to position the new AP.

A newAP icon is displayed on the map with all of the properties inherited and the AP name appended, for example,
BLD1-AP0002-TX.

• To add more planned APs with the same properties and appended AP name, click the floor map.

• To stop adding planned APs to the floor map, press Esc or right-click the floor map.

• To reposition the planned APs, drag and drop them to the appropriate location in the floor map.
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• To delete a planned AP, right-click the AP icon and click Remove.

• To edit a planned AP, right-click the AP icon and click Edit.

• To autoplace a planned AP, see Autoplace Planned APs on a Map, on page 13.

Step 12 In the map toolbar, click Save.

Autoplace Planned APs on a Map
Autoplacing planned APs on a floor map allows you to see how many planned APs can be placed within the
dimensions of the map. Using the planned APmodel, maximum distance you'd like between the planned APs,
and coverage area dimensions, the system calculates the maximum number of planned APs placements and
adds them to the floor map.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit.

By default, the Devices and Access Points toggle buttons are chosen.

Step 4 In the left pane of the map, click Autoplace Planned APs.
Step 5 In the Autoplace Planned APs dialog box, choose the AP model, enter the maximum distance you'd like between the

planned APs, and enter a valid name pattern.

The #### in the name pattern is replaced by numbers in the planned AP name—for example, AP-0001, AP-0002, and
so on.

Step 6 Click Create.

The system calculates the maximum number of planned APs placements and adds them to the floor map. The system
automatically selects all the newly placed planned APs, and the Edit APs slide-in pane, where you can collectively
edit all the new planned APs, is displayed.

Step 7 From the Antenna drop-down list, choose the antenna type.
Step 8 (Optional) To collectively update the planned APs, edit the available fields.
Step 9 Click Apply to apply the update to all the autoplaced planned APs.
Step 10 (Optional) Perform the following actions, as needed:

• To edit a planned AP, either click the planned AP icon or right-click the planned AP icon and choose Edit.

• To stop editing a planned AP, press Esc, right-click the floor map, or close the Edit Planned AP slide-in pane.

• To reposition the planned APs, drag and drop them to the appropriate location in the floor map.

• To remove a planned AP, right-click the planned AP icon and choose Remove.

Step 11 When you're ready, click Save to save the changes to the map.
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Assign Actual APs to Planned APs
After you install the actual APs in your wireless network, you can assign them to the planned APs on your
map. This procedure describes how to assign planned APs to actual APs.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit.

By default, the Devices and Access Points toggle buttons are chosen.

Step 4 In the left pane of the map, click Assign Planned APs.
Step 5 On the floor map, click a planned AP.
Step 6 In the Assign Planned APs slide-in pane, check the check box next to the AP that you want to assign.
Step 7 Click Assign.
Step 8 In the map toolbar, click Save.

Position an AP on a Map
After adding an AP to a floor, you must position it on the map using one of the following methods:

• Manually position it on the map. Use this method if you can approximate the location of the AP using
reference points in the building that you can correlate to the detail on the floor map.

• Define its x and y coordinates. Use this method if you have the exact coordinates of the AP and you want
its position on the map to be as accurate as possible.
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• Triangulate it using 3 points. Use this method if you have large open space with only a few points from
which to measure the distance to the AP. For example, you might measure from the AP to each corner
of the room.

• Intersect it based on its distance from two walls. Use this method if the AP is located in a space where
you have two walls that intersect, even if they aren't perpendicular to one another.
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For all but the first method (manual positioning), you need to have your measurements on hand, and make
sure the unit of measure is specified correctly in the Global Map Properties settings. For information, see
in 2D Map View Options, on page 35.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit.

By default, the Devices and Access Points toggle buttons are chosen.

Step 4 From the left pane of the map, in the Unpositioned area, click an AP.

Figure 3: Unpositioned APs
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Step 5 To position the AP, use one of the following methods:

• Click the location on the floor map where you want to position the AP.
• Define its x and y coordinates in the Edit AP slide-in pane.
• Triangulate its location:

a. In the Edit AP slide-in pane, click 3 points.

b. Click on floor map to draw the first point.

c. In the dialog box, set the distance from the AP to the first point and click Set Distance.

d. Define the second and third points similarly, and click Save.

• Define two walls on the floor map and position the APs between the defined walls:

a. In the Edit AP slide-in pane, click 2 walls.

b. To define the first wall, click the floor map to start drawing the line. Click again to finish drawing the line.

A dialog box is displayed to set the distance from the AP to the first wall.

c. Enter the distance in meters, and click Set Distance.

d. Define the second wall similarly, making sure that the distance to the AP from the first and second walls create
an intersecting point.

e. Click Save.

The AP is placed based on the defined distance between the walls.

Step 6 In the map toolbar, click Save.

If Cisco Connected Mobile Experiences (CMX) is synchronized with Catalyst Center, you can view the
location of clients on the heatmap. See Create Cisco CMX Settings.

Note

Reposition an AP on a Map
After you position APs on a map, you can reposition them. This procedure shows you how to reposition an
AP on a map.

You can perform this task in a 2D or 3D map.Note

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 For 2D, do the following:

a) In the map toolbar, click 2D > Add/Edit.
b) On the map, drag and drop the AP to the new position.

Step 4 For 3D, do the following:
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a) In the map toolbar, click 3D > Edit/Clone.
b) On the map, right-click the AP and choose Move.
c) On the map, drag and drop the AP to the new position.

Step 5 In the map toolbar, click Save.

Edit an AP
This procedure shows you how to change the configuration of a single AP or planned AP. To change the
configuration of multiple APs at the same time, see Edit Multiple APs, on page 20.

You can perform this task in a 2D or 3D map.Note

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 For 2D, do the following:

a) In the map toolbar, click 2D > Add/Edit.
b) On the map, right-click the AP and choose Edit.

Step 4 For 3D, do the following:
a) In the map toolbar, click 3D > Edit/Clone.
b) On the map, click the AP that you want to edit.

Step 5 In the slide-in pane, change any of the following AP and planned AP settings, as available:

• AP Name or Planned AP Name: Name of the AP.

• MAC Address: MAC address of the selected AP.

• AP Model: Model of the selected AP.

For APs in 3D maps, you can change the AP Model field to visualize its impact, but the changes aren't
saved and don't persist across floors. Instead, you can update this AP field from the Inventory window.

Note

• x (ft): X-axis coordinate of the AP.

• y (ft): Y-axis coordinate of the AP.

• AP Height (ft): Height of the AP.

• Antenna: Antenna type for this AP.

For external APs, you must select an antenna. If you don't select an antenna, the AP will not be present
on the map.

Note

• Channel: Channel to be used by the AP. Only channels that are supported by the AP model are displayed.

For APs in 3D maps, you can change the Channel field to visualize its impact, but the changes aren't
saved and don't persist across floors. Instead, you can update this AP field from the Inventory window.

Note
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• Tx Power (dBm): Transmit power for the channel. Only power levels that are supported by the channel are displayed.

For APs in 3D maps, you can change the Tx Power (dBm) field to visualize its impact, but the changes
aren't saved and don't persist across floors. Instead, you can update this AP field from the Inventory
window.

Note

• Azimuth: Angle of the antenna, measured relative to the x axis, clockwise. The azimuth range is from 0 through
360. In Catalyst Center, pointing right is 0 degrees or 360 degrees; pointing down is 90 degrees.

You can manually enter the value or use the blue arrow under the field to change the value.

For omnidirectional antennas, the azimuth is not relevant if the elevation is 0.Note

• Elevation: In degrees. You can manually enter the value or use the blue arrow under the field to change the value.

For APs and antenna models that are designed to be placed on a ceiling, 0 elevation means pointing down.
For APs and antennamodels that are designed to be placed on a wall, 0 elevationmeans pointing horizontally
and negative values mean pointing down.

Note

Figure 4: Edit AP Slide-In Pane

Step 6 Do one of the following:
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• For 2D, after making the changes, close the slide-in pane.

• For 3D, click Apply to apply the changes.

Step 7 In the map toolbar, click Save.

Edit Multiple APs
When you select only one AP or planned AP, you can change all editable attributes. However, when you
select multiple APs or planned APs, only some attributes are editable, as follows:

• When the selected devices have the same value for an attribute, the value is displayed. Otherwise, the
value is blank. In either case, if you change the value, the new value is applied to all the selected devices.

• When the selected APs have the same model number and radios (number of radios and operating band),
the antennas are editable. Otherwise, they are not editable.

• You can change the model numbers of planned APs but not added APs. So, if you select an AP, the
model number is not editable.

• Because bulk changes affect more devices, they do not take effect immediately. You must click Apply
to apply your changes.

This procedure shows you how to update the editable attributes for multiple APs at the same time.

You can perform this task in a 2D or 3D map.Note

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 Do one of the following:

• For 2D, in the map toolbar, click 2D > Add/Edit.

• For 3D, in the map toolbar, click 3D > Edit/Clone.

Step 4 Select the APs, using one of the following methods:

• Click the first device, then press and hold the Shift key while you click the rest of the devices.

• In the 2D map navigation controls toolbar, click the select by rectangle icon ( ). Then click an area of the map
and drag the highlighted rectangle to select APs in a contiguous area. All the highlighted APs within the rectangle
are selected.

To deselect APs, use one of the following methods:

• To deselect a single AP, press and hold the Shift key while you click the AP.

• To deselect all APs except one, click the AP you want to remain selected. All others are deselected.

• To deselect all APs, press the ESC key or close the Edit pane.
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Step 5 In the slide-in pane, configure the settings of the APs, as available:

• AP Name or Planned AP Name: Name of the AP.

• MAC Address: MAC address of the selected AP.

• AP Model: Model of the selected AP.

For APs in 3D maps, you can change the AP Model field to visualize its impact, but the changes aren't
saved and don't persist across floors. Instead, you can update this AP field from the Inventory window.

Note

• x: X-axis coordinate of the AP. You can manually enter the value.

• y: Y-axis coordinate of the AP. You can manually enter the value.

• AP Height: Height of the AP. You can manually enter the value.

• Antenna: Antenna type for this AP.

For external APs, you must select an antenna, or the AP will not be present in the map.Note

• Channel: Channel to be used by the AP. Only channels that are supported by the AP model are displayed.

For APs in 3D maps, you can change the Channel field to visualize its impact, but the changes aren't
saved and don't persist across floors. Instead, you can update this AP field from the Inventory window.

Note

• Tx Power (dBm): Transmit power for the channel. Only power levels that are supported by the channel are displayed.

For APs in 3D maps, you can change the Tx Power (dBm) field to visualize its impact, but the changes
aren't saved and don't persist across floors. Instead, you can update this AP field from the Inventory
window.

Note

• Azimuth: Angle of the antenna, measured relative to the x axis, clockwise. The azimuth range is from 0 through
360. In Catalyst Center, pointing right is 0 degrees or 360 degrees; pointing down is 90 degrees.

You can manually enter the value or use the blue arrow under the field to change the value.

For omnidirectional antennas, the azimuth is not relevant if the elevation is 0.Note

• Elevation: In degrees. You can manually enter the value or use the blue arrow under the field to change the value.

For APs and antenna models that are designed to be placed on a ceiling, 0 elevation means pointing down.
For APs and antennamodels that are designed to be placed on a wall, 0 elevationmeans pointing horizontally
and negative values mean pointing down.

Note
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Figure 5: Edit APs Slide-In Pane

Step 6 In the slide-in pane, click Apply to apply the changes.
Step 7 In the map toolbar, click Save.

Remove APs from a Map
This procedure shows you how to remove APs and planned APs (PAPs) from a map.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit.
Step 4 To remove APs (including planned APs), do the following:

a) Click the AP. To select multiple APs, click the first AP and while pressing the Shift key, click the rest of the APs.
b) In the slide-in pane, click Remove.
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Step 5 In the map toolbar, click Save.

Work with Sensors on a Floor Map
The following topics show you how to add sensors to floor maps and position, reposition, and delete them, if
needed.

For more information about sensors, see 2D Floor Map Devices and Overlay Objects, on page 8.

Add Sensors to a Map
This procedure shows you how to add sensors to a map.

Before you begin

Make sure you have the Cisco AP 1800S sensor in your inventory. The Cisco Aironet 1800s Active Sensor
must be provisioned using Plug and Play for it to show up in the Inventory. See the "Provision the Wireless
Cisco Aironet 1800s Active Sensor" topic in the Cisco Catalyst Assurance User Guide.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit > Sensors.
Step 4 In the Add Sensors slide-in pane, check the check boxes of the sensors that you want to add. Alternatively, click Add

next to the sensor row.

You can search for specific sensors using the Filter field. Search using the name, MAC address, or model
of a sensor. The search is not case-sensitive. The results are displayed in the table. Click Add to add one or
more of these sensors to the floor area.

Note

Newly added sensors are displayed in the Unpositioned category in the left pane of the map in edit mode.

Step 5 In the map toolbar, click Save.

Position Sensors on a Map
Newly added sensors are displayed in the Unpositioned category in the left pane of the map in edit mode.
This procedure shows you how to position a sensor after initially adding it.

Before you begin

Sensors must be added to the map before they can be positioned. For information, see Add Sensors to a Map,
on page 23

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit > Sensors.
Step 4 In the left pane of the map, click a sensor in the Unpositioned category to position the sensor.
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Step 5 On the floor map, click the location where you want to position the sensor.

You can use the x, y, and Height fields in the Sensor Details slide-in pane to enter the exact x, y, and z coordinates for
the sensor.

Step 6 In the map toolbar, click Save.

Reposition a Sensor on a Map
After you position sensors on a map, you can reposition them. This procedure shows you how to reposition
a sensor on a map.

You can perform this task in a 2D or 3D map.Note

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, do one of the following:

• Click 2D > Add/Edit.

• Click 3D > Edit/Clone.

Step 4 On the map, drag and drop the sensor to the new position.
Step 5 In the map toolbar, click Save.

Remove Sensors from a Map
This procedure shows you how to remove sensors from a floor map.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit.
Step 4 To remove sensors, do the following:

a) Click the sensor, or to select multiple sensors, click the first sensor and while pressing the Shift key, click the rest of
the sensors.

b) In the Edit pane, click Remove.

Step 5 In the map toolbar, click Save.
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Add, Edit, and Remove Coverage Areas
This procedure shows you how to mark a nonrectangular or polygon-shaped area as a coverage area on a floor
map.

For more information about coverage areas, see 2D Floor Map Devices and Overlay Objects, on page 8.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit > Overlays > Coverage Areas.
Step 4 To add a coverage area, do the following:

a) In the Coverage Area dialog box, enter a name for the coverage area in the field.
b) Click Add Coverage.
c) Click on the map to create a point and initiate the drawing tool.
d) Continue creating points to define the coverage area shape.

The coverage area shape must have at least three points. Click and drag a point to redefine the coverage
area shape.

Note

e) Double-click to exit the drawing tool and finalize the coverage area shape.

Step 5 To edit a coverage area, do the following:
a) In the map toolbar, click Add/Edit > Coverage Areas.
b) To redefine the shape of a coverage area, click and drag a point.
c) To edit a coverage area name, right-click the coverage area and choose Edit.

Step 6 To delete a coverage area, do the following:
a) In the map toolbar, click Add/Edit > Coverage Areas.
b) Right-click the coverage area and choose Remove.

Step 7 In the map toolbar, click Save.

Add, Edit, Copy, and Remove Openings
Creating an opening is similar to creating an open space or atrium on a floor. On multifloor buildings, typically
the opening extends vertically through multiple floors. This procedure shows you how to add, edit, and remove
openings on a floor map. It also shows you how to copy openings to other floors.

For more information about openings, see 2D Floor Map Devices and Overlay Objects, on page 8.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit > Overlays > Openings.
Step 4 To add an opening, do the following:

a) From the left pane of the map, click Opening.
b) Click on the map to create a point and initiate the drawing tool.
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c) Continue creating points to define the opening shape.

The opening shape must have at least three points. Click and drag a point to redefine the opening shape.Note

d) Double-click to exit the drawing tool and finalize the shape.

Step 5 To edit an opening, do the following:
a) In the map toolbar, click Add/Edit > Openings.
b) To redefine the shape of an opening, click and drag a point.
c) To move an opening, click inside the shaded area. Then, drag and drop the opening where you want to place it.

Step 6 To copy an opening from one floor to another, do the following:
a) In the map toolbar, click Add/Edit > Openings.
b) Right-click the opening and choose Copy to other floors.
c) In the dialog box, check the check boxes next to the relevant floors.
d) Click Copy.
e) Click Close.

Step 7 To remove an opening, do the following:
a) In the map toolbar, click Add/Edit > Openings.
b) Right-click the opening and choose Remove.

Step 8 In the map toolbar, click Save.

Add, Edit, and Remove Location Regions
Location regions are areas on the map that are either included in or excluded from the heatmap calculation.
The following topics show you how to add, edit, and remove location regions.

Add, Edit, and Remove an Inclusion Region
This procedure shows you how to add, edit, and remove an inclusion region. Use the following guidelines to
define an inclusion region on a floor map:

• Inclusion regions can be any polygon-shaped area and must have at least three points.

• You can only define one inclusion region on a floor. By default, an inclusion region is defined for each
floor area when it is created. The inclusion region is indicated by a solid aqua line, and generally outlines
the entire floor area.

For more information about inclusion regions, see 2D Floor Map Devices and Overlay Objects, on page 8.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit > Overlays > Location Regions.
Step 4 In the left pane of the map, click the Inclusion icon.
Step 5 To create an inclusion region, use the drawing tool:

a) Click the map to create a point where you want the inclusion region to begin.
b) Move the cursor to the next point and click again.
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c) Continue creating points to define the inclusion region shape.
d) To finalize the shape, double-click the map.

Alternatively, from the left pane of the map, click the Inclusion icon.

e) To exit the drawing tool, double-click the map again.

Step 6 To edit the location of an inclusion region, drag and drop the shape to the new location.
Step 7 To remove an inclusion region, right-click the shape and choose Remove.
Step 8 In the map toolbar, click Save.

Add, Edit, and Remove an Exclusion Region
This procedure shows you how to add, edit, and remove an exclusion region. Use the following guidelines to
define exclusion regions on a floor map:

• Exclusion regions can be any polygon-shaped area and must have at least three points.

• Exclusion regions are defined within the borders of an inclusion region.

• You can define multiple exclusion regions on a floor map.

For more information about exclusion regions, see 2D Floor Map Devices and Overlay Objects, on page 8.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit > Overlays > Location Regions.
Step 4 From the left pane of the map, click the Exclusion icon.
Step 5 To create an exclusion region, use the drawing tool:

a) Click the map to create a point where you want the exclusion region to begin.
b) Move the cursor to the next point and click again.
c) Continue creating points to define the exclusion region shape.
d) To finalize the shape, double-click the map.

Alternatively, from the map left pane, click the Exclusion icon.

e) To exit the drawing tool, double-click the map again.

Step 6 To edit the location of an exclusion region, drag and drop the shape to the new location.
Step 7 To remove an exclusion region, right-click the shape and choose Remove.
Step 8 In the map toolbar, click Save.

Add, Edit, and Remove Walls
This procedure shows you how to add, edit, move, and remove walls on a floor map.

For information about how walls impact RF signal attenuation and heatmap calculation, see 2D Floor Map
Devices and Overlay Objects, on page 8.
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Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit > Overlays > Walls.
Step 4 To add walls, do the following:

a) In the left pane of the map, click a wall type from the Others or On this floor category.

If a wall type isn't listed, click Add Wall Type to create a custom wall type.Note

b) Click the map to create a point where you want the wall to begin.
c) Move the cursor to the next point, where you want to end the wall or where you want to create a corner and click

again.
d) Continue creating points to define the wall shape.
e) To end a wall, double-click the map.

Alternatively, from the left pane, click the wall type.

f) To exit the drawing tool, double-click the map again.

Step 5 To change a wall type, and depending on the wall type also configure its parameters, do the following:
a) Click the wall that you want to change.

The Wall Type dialog box opens.

b) From the Wall Type drop-down list, choose the type of wall.
c) Configure any other parameters that are appropriate for the new wall type.
d) Click Update.

Step 6 To move a wall, do the following:
a) Hover your cursor over the wall that you want to move.

The wall turns black, which means it's selected.

b) Click the wall and drag and drop it to the new location.

Step 7 To remove a wall, right-click the wall and choose Remove.
Step 8 In the map toolbar, click Save.

Add, Copy, Edit, and Remove Shelving Units
This procedure shows you how to add, copy, edit, and remove shelving units on a floor map.

For information about shelving units, see 2D Floor Map Devices and Overlay Objects, on page 8.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit > Overlays > Shelving Units.
Step 4 To add shelving units, do the following:

a) In the left pane of the map, click the shelving type you want to add.
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b) In the shelving dialog box, configure the name, dimensions, orientation, and whether the unit is double-sided, or
leave the default values. Orientation means the angle of the shelving unit. A shelving unit with an orientation of 0
means that the shelving unit is vertical and parallel to the y-axis.

If a shelving type is not in the list, click Add Shelving Type to create a shelving type.

c) Click Add Shelving.

The shelving unit is displayed on the map.

d) Drag and drop the shelving unit to its location on the map.

Step 5 To create a copy or an array of a shelving unit, do one of the following:

• To create a copy, right-click the shelving unit and choose Clone.

• To create an array, right-click the shelving unit and choose Array. Then specify the number of units and the distance
between them.

Step 6 To edit the name, dimensions, orientation, and whether it is two-sided, right-click the shelving unit and choose Edit.
Step 7 To remove a shelving unit, right-click the shelving unit and choose Remove.
Step 8 In the map toolbar, click Save.

Add, Edit, and Remove Markers
The following procedure shows you how to add, edit, and remove markers.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit > Overlays > Markers.
Step 4 In the left pane of the map, click the Markers icon.
Step 5 In the Place Markers dialog box, enter the name for the marker, and click Add Marker.
Step 6 To place the marker, click the map where you want to place the marker.
Step 7 To move a marker, hover your cursor over the marker until it turns blue. Then drag and drop it in the new location.
Step 8 To edit a marker, right-click the marker and choose Edit.
Step 9 To remove a marker, right-click the marker and choose Remove.
Step 10 In the map toolbar, click Save.

Add, Edit, and Remove GPS Markers
This procedure shows you how to add, edit, and remove GPS markers. For more information about GPS
markers, see 2D Floor Map Devices and Overlay Objects, on page 8.

The GPS marker is an attribute of the building. You can apply it to all the floors of the building.Note
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Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit > Overlays > GPS Markers.
Step 4 To add a GPS marker, do the following:

a) In the left pane of the map, click the GPS Markers icon.
b) On the map, click the location where you want to place the GPS marker.

GPS markers must be positioned inside the outer-perimeter walls, typically at the building corners.

c) In the Place Markers dialog box, enter the name, latitude, longitude, and the x and y coordinates in the appropriate
fields.

The latitude and longitude coordinates of the GPS marker located in the northwest corner of a floor must match the
building coordinates.

d) Click Add GPS Marker.

Step 5 To edit a GPS marker, right-click the GPS marker and choose Edit.
Step 6 To remove a GPS marker, right-click the GPS marker and choose Remove.
Step 7 In the map toolbar, click Save.

Add, Edit, and Remove Align Points
This procedure shows you how to add, edit, and remove align points. For more information about align points,
see 2D Floor Map Devices and Overlay Objects, on page 8.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D > Add/Edit > Overlays > Align Points.
Step 4 To add an alignment point, do the following:

a) In the left pane of the map, click the Align Points icon.
b) On the map, click the location where you want to place the alignment point.

Step 5 To edit the name of an alignment point, do the following:
a) Right-click the alignment point and choose Edit.
b) Change the name and click Edit Marker.

Step 6 To change the location of an alignment point, do the following:
a) Right-click the alignment point and choose Edit.
b) Click Edit Marker.
c) Drag and drop the alignment point to the new location.

Step 7 To remove an alignment point, right-click the alignment point and choose Remove.
Step 8 In the map toolbar, click Save.
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View a 2D Wireless Heatmap
Use the 2D heatmap to view information about your wireless network.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D.

The wireless 2D map opens.

Step 4 To display specific details about devices, do the following, based on the device type:

• APs: The AP icon indicates the number of radios, their frequency and health, overall health score of the device, and
the AP name and mode. For more information about interpreting the AP icon, see About the AP Icon and Planned
AP Icon, on page 38.

To display device details, hover your cursor over an AP icon. Information, such as the AP's Rx neighbors, clients,
interferers, and health score, is displayed.

For more details about an AP, in the dialog box, click the Device 360 link.

For Device 360, the Assurance - Base package is required.Note

• Mesh APs: To display device details, hover your cursor over a mesh AP icon. Information, such as mesh, backhaul,
and access data, is displayed.

• Clients: To display client information, including a link to its associated AP, hover your cursor over or click a client.
For more details about a client, in the dialog box, click the Client 360 link.

• Sensors: To view the status and test results of a sensor, click a sensor icon.

• Switches and Switch Stacks: To display the member switches of a switch stack, click the arrow next to the switch
stack icon. To display the connections between a switch and its associated APs, hover your cursor over the switch
or switch stack icon. The map displays a line showing the connections from the switch and its associated APs. You
can also identify switch and AP associations by color. APs connected to one specific switch have labels that match
the color code on the switch icon.

Using CiscoDiscovery Protocol (CDP), Catalyst Center can detect and display unmanaged switches that are connected

to managed APs. An unmanaged switch is depicted as a typical switch icon with a "U" for unmanaged ( ).

To display device details, click a switch or switch stack icon. A slide-in pane opens and displays the device details
and options for the heatmap display. Under Select Heatmap, you can click any of the following radio buttons:

• All visible switches: Computes and displays the heatmap for all the switches in the visible map area.

• This switch: Computes and displays the heatmap for the selected switch only.

• Rest of visible switches: Computes and displays the heatmap for all of the visible switches, except for the
selected switch.

• None: Does not include any switch in the heatmap computation and heatmap display.

Step 5 To display information about a link, click the link. Depending on the type of link, information such as link health and
other statistics are displayed.
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For a mesh link, you can perform a link test between two mesh APs.

Step 6 Use the tools and options shown in the following figure to gain insights about your wireless network.

Figure 6: 2D Wireless Map Showing Tools and Options

DescriptionCallout

Map Toolbar: In above the map, use the toolbar options to control what's displayed on the
heatmap. For details, see 2D Map Toolbar, on page 32.

1

View Options Slide-In Pane: In the slide-in pane, use the view options to customize the heatmap
display. For details, see 2D Map View Options, on page 35.

2

Navigation Controls: From the bottom-right corner of the map, use the map navigation controls
to manage the heatmap display. For details, see 2D Map Navigation Controls, on page 37.

3

2D Map Toolbar
To access the 2Dmap, from the top-left corner, click the menu icon and chooseDesign >Network Hierarchy.
From the left hierarchy tree, choose a floor, and in the map toolbar, click 2D.

The map toolbar consists of two bars and is located above the map. Use the map toolbar for the following
actions and settings:

DescriptionItem

Click 2D to view the wireless map in 2D, or click 3D to view it in 3D.

Wi-Fi Band Filter: Hover your cursor over the Wi-Fi band filter, and from the drop-down
list, choose a Wi-Fi band.
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DescriptionItem

Click this button to add, edit, and remove the following devices and overlay objects:

• Devices

• Access points: For details, see Work with APs on a Floor Map, on page 9.

• Sensors: For details, see Add Sensors to a Map, on page 23.

• Overlay Objects

• Coverage areas: For details, see Add, Edit, and Remove Coverage Areas, on page
25.

• Openings: For details, see Add, Edit, Copy, and Remove Openings, on page 25

• Location regions: For details, see Add, Edit, and Remove Location Regions, on
page 26.

• Walls: For details, see Add, Edit, and Remove Walls, on page 27.

• Shelving Units: For details, see Add, Copy, Edit, and Remove Shelving Units,
on page 28.

• Markers: For details, see Add, Edit, and Remove Markers, on page 29.

• GPS markers: For details, see Add, Edit, and Remove GPS Markers, on page
29.

• Align points: For details, see Add, Edit, and Remove Align Points, on page 30.

Add/Edit

Click Data/Filters to open the Data/Filters slide-in pane that displays a device type list.
Choose a device type to view and filter the device data that displays in the wireless map.
For details, see Filter Device Data on a Floor, on page 41.

Data/Filters

Click View Options to open the View Options slide-in pane, which contains the options
for controlling the display of the map, devices, and overlay objects. For details, see 2DMap
View Options, on page 35.

View Options
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DescriptionItem

Hover your cursor over More, and from the drop-down list, choose one of the following
options:

• Recompute: Recompute the heatmap.

• Export: Export the floor map to a PDF or CSV file format.

• Edit Floor: Change the floor details, such as its name.

• Set Scale: Change the map scale by providing a known measurement on the map:

1. Click the map to specify the starting point of the measurement.

2. Click the map again to specify the ending point of the measurement.

3. In the New line length (ft) field, enter the length of the measurement.

4. Click OK.

The floor map dimensions are recalculated based on the new measurement.

• Measure Distance: Measure a distance on the floor map. Click the map to specify a
starting point. Click the map again to specify an ending point. The distance of the
measurement is displayed.

• CMX/Cisco Spaces Sync History: Display a log that shows when Cisco Connected
Mobile Experiences (CMX) and Cisco Spaces synchronized data. The log entries include
the request received time, start and end times, status, and failure message (if the
operation failed).

• Floor Import History: Display the floor import history logs of importing map archive
files. The logs detail the successfully and unsuccessfully imported APs, planned APs,
and overlay objects.

More

Full Hierarchy Path: Displays the full navigational path of the floor, including its associated
building and area or site. Click the down arrow to navigate to a different floor.

Refresh: Click this icon to update the device and map data. To the left of the icon is the
timestamp for the last refresh

Cisco Spaces Connector: Click this icon to display information, such as the IP address,
status, and version, about the Cisco Spaces Connector.

Map Notification: Hover your cursor over this icon to display map information, such as
the number of unpositioned APs or planned APs and filters applied to the map. To remove
the filters, click Click to clear.

Search: Use the Search field to find specific floor map elements such as APs, sensors,
clients, and so on. The results of your search are listed in a slide-in pane below the Search
field.

When you hover your cursor over an element in the list, an indicator points to the element
on the map. If the element is outside the field of view, the indicator is displayed as a broken
red line. Reorient the map to see the element.
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2D Map View Options
To access the 2Dmap, from the top-left corner, click the menu icon and chooseDesign >Network Hierarchy.
From the left hierarchy tree, choose a floor, and in the map toolbar, click 2D > View Options.

The View Options slide-in pane opens. Expand the categories to view the settings:

• Map: Contains various floor map and heatmap settings:

DescriptionItem

Click this toggle button to enable or disable a grid on the floor map. The grid provides the
dimensions of the floor map.

Show Grid

Use this slider to customize the opacity or transparency of the floor map.Map Opacity %

The heatmap provides a graphical representation of Radio Frequency (RF) wireless data where the
values taken by a variable are represented in maps as colors. RSSI heatmaps are computed based
on a floor's RSSI prediction model, antenna type, and its orientation.

2D heatmaps use fixed transmit powers: 18 dB for 2.4-GHz; 15 dB for 5-GHz; and 5 dB for 6-GHz.

3D heatmaps use real-time transmit power of operational APs and 11 dB for planned APs.

Use the drop-down list to choose the heatmap type:

• Operational RSSI: Coverage heatmap, which identifies the wireless signal strength of
operational APs.

• Planned RSSI: Hypothetical heatmap that shows the coverage that planned APs would have
on a floor.

• Operational + Planned (3D-only): (Visible only if the legacy heatmap generator is enabled.)
In the 2D map, only operational APs are used to compute the heatmap. To use operational
and planned APs in the heatmap computation, you can either enable the 3D-computed heatmap
generator or navigate to the 3Dmap. For information, see theDisable 3D-Computed Heatmap
field in this topic.

• Operational + Planned: (Visible only if the 3D-computed heatmap generator is enabled.)
Coverage heatmap created using both operational and planned APs.

• Client Density: Density of associated clients.

• IDS: Heatmap that shows the monitor mode AP coverage provided to the wireless clients on
a floor map.

Heatmap Type

Use this slider to set the threshold for the RSSI value to appear on the heatmap. RSSI values that
do not meet the threshold are faded.

RSSI Cut off (dBm)

Use this slider to customize the opacity or transparency of the heatmap.Heatmap Opacity %

Customize the color scheme of the power level for the heatmap. The options are Legacy, Natural,
and Monochrome. Note that Monochrome only supports the Contour option for the Heatmap
Shape.

Heatmap Color Scheme

Customize the color progression of the power level on the heatmap. The options are Contour and
Gradient.

Heatmap Shape
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• Access Points: Click this toggle button to enable or disable the AP icons on the floor map.

Expand this category to configure the type of label to display with each AP. Valid label types are Name,
MAC address, IP address, Bridge Group Names, and so on. From the Display Label drop-down list,
choose a label type.

To display other details about APs, see View a 2D Wireless Heatmap, on page 31.

• Planned Access Points: Click this toggle button to enable or disable the appearance of planned AP icons
on the floor map.

Expand this category to display labels with the planned AP name. From the Display Label drop-down
list, choose a label type.

• Switches: Click this toggle button to enable or disable the appearance of switch or switch stack icons on
the floor map. Using Cisco Discovery Protocol (CDP), Catalyst Center can detect and display unmanaged
switches that are connected to managed APs. An unmanaged switch is depicted as a typical switch icon
with a "U" for unmanaged.

Expand this category to display labels with the switch name,MAC address, or AP count. (For unmanaged
switches, only the switch name and AP count are available.) From the Display Label drop-down list,
choose a label type.

To display other details about switches, see View a 2D Wireless Heatmap, on page 31.

• Sensors: Click this toggle button to enable or disable the appearance of sensor icons on the floor map.

Expand this category to display labels with the sensor name, MAC address, or AP count. From the
Display Label drop-down list, choose a label type.

To display other details about sensors, see View a 2D Wireless Heatmap, on page 31.

• Mesh: Click this toggle button to enable or disable the appearance of mesh APs on the floor map.

Expand this category to configure options that control how the mesh AP-to-root AP link relationships
are displayed:

• Link Label: To disable link labels, click the None radio button. To display labels for link
signal-to-noise ratios, click the Link SNR radio button. To display labels for packet error rates,
click the Packet Error Rate radio button. The link label setting is reflected on the map immediately.

• Link Color: To disable link color, click theNone radio button. To display link signal-to-noise ratios
in color, click the Link SNR radio button. To display packet error rates in color, click the Packet
Error Rate radio button.

The link color settings are reflected on the map immediately. See the following table for color
definitions.

Packet Error Rate (PER)Link Signal Noise Ratio (SNR)Link Color

Represents a PER of one percent (1%)
or lower

Represents an SNR above 25 dB (high
value)

Represents a PER that is less than ten
percent (10%) and greater than one
percent (1%)

Represents an SNR between 20 dB and
25 dB (acceptable value)

Represents a PER that is greater than
ten percent (10%)

Represents an SNR below 20 dB (low
value)
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• Mesh Parent-Child Hierarchical View: Choose which mesh APs to display. From this drop-down
list, choose Select Only Root APs, Select up to 1st hops, Select up to 2nd hops, Select up to 3rd
hops, Select up to 4th hops, or Select All.

• Overlay Objects: Expand this category and click any of the overlay objects to enable or disable the
overlay objects on the floor map.

• Clients: Click this toggle button to enable or disable the appearance of client icons on the floor map.

Expand this category to display labels with the client name,MAC address, or AP count. From theDisplay
Label drop-down list, choose a label type.

To enable or disable clients in close proximity to be grouped together, click the Show Client Clusters
toggle button.

• Interferers: Click this toggle button to enable or disable the appearance of client icons on the floor map.

Expand this category to enable or disable the appearance of a zone of impact from interferers. Click the
Show Zone of Impact toggle button.

• Map Properties: Expand this category to configure the following settings on the map:

• Auto Refresh: From this drop-down list, choose a time interval for the map display to be refreshed.

• Heatmap Walls Limit: (Available only with the 3D-computed heatmap generator.) Enter the number
of walls to be used in the heatmap computation. The more walls included, the longer it takes to
compute the heatmap. The default and recommended limit is 3000.

• Mesh SNR Colors and Mesh PER Colors: (Available only when mesh devices are present.) Enter
the threshold ranges and their corresponding colors.

• Global Map Properties: Expand this category to configure the following settings for all wireless maps:

• Units of Measure: From the drop-down list, choose eitherFeet (imperial system) orMeters (metric
system).

• Disable 3D-Computed Heatmap: Click this toggle button to disable the default 3D-computed
heatmap generator and enable the legacy heatmap generator. Be aware that computation and rendering
using the legacy heatmap generator is not as fast as the 3D-computed heatmap, and you can't
configure a limit on the number of walls to be included to compute the heatmap. (The Heatmap
Walls Limit field is removed from the display.) The maximum number of walls using the legacy
heatmap generator is 300, after optimization. If your floor map contains more, Catalyst Center alerts
you and preserves the 300 most relevant walls (based on the length of the wall multiplied by its
attenuation).

The 3D-computed heatmap generator offers several advantages over the legacy heatmap generator.
It uses the specialized graphics processing unit (GPU), which allows it to generate the heatmaps
substantially faster than the legacy heatmap generator. In addition, you can set a limit to the number
of walls that are included in a heatmap computation, which also helps to enhance processing speed.

2D Map Navigation Controls
To access the 2Dmap, from the top-left corner, click the menu icon and chooseDesign >Network Hierarchy.
From the left hierarchy tree, choose a floor, and in the map toolbar, click 2D.
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The 2D map navigation controls are located at the bottom-right of the map. For details about the map, see
View a 2D Wireless Heatmap, on page 31.

Use the map navigation controls for the following functions:

DescriptionMap Navigation
Controls

Select by rectangle: Displays only in editing mode. Use this icon to select multiple
APs in a contiguous area on the map. First click this icon, then click an area on the
map, and drag the highlighted rectangle. All the highlighted APs within the rectangle
are selected.

Alert: This icon displays when you choose to remove a banner notification without
first resolving the error by clicking Do not show this alert anymore. When the error
is resolved, the system doesn't display this alert icon.

Default Map View: Click to reset the map view to the default.

Zoom In / Zoom Out: Click the zoom in and out icons to enlarge and reduce the size
of the map. Alternatively, you can use your mouse wheel to zoom in and out.

Map Legend: Click this icon to view the map legend, which describes the map icons
such as the device type, average health score, and AP status. For more information
about the AP icon and planned AP icon, see About the AP Icon and Planned AP Icon,
on page 38.

About the AP Icon and Planned AP Icon

AP Icon

AP icons provide information about the configuration and health of the APs in your network. The circular
AP icon is divided into radio bands that are color coded to show the radio status. Its center circle displays a
letter for the AP mode. The background color of or "X" over its center circle shows the AP status. The
color-coded small circle in the upper-right corner of the AP icon displays the health score. For the color-coding
details of the radio status, AP status, and the health score, see the map legend in a 2D floor map.

The following diagram shows all the elements of an AP icon:
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Planned AP Icon

Planned AP icons provide information about the configuration of the planned APs in your network. The
circular planned AP icon is divided into radio bands and displays a "P" in its upper-left corner. For more
information about the radio mode, see the map legend in a 2D floor map.

The following diagram shows all the elements of a planned AP icon:
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View an Unmanaged Switch Connected to Managed APs
Catalyst Center can detect the unmanaged switches in your network and the managed APs to which they are
connected. The unmanaged switches and their connections to APs can be displayed in a 2D floor map. This
capability is helpful if you have switches that you don't want to manage using Catalyst Center, but you still
want to view them in relation to your managed APs.

This feature is not supported on Cisco AireOS Wireless LAN Controllers.Note

Before you begin

• Install and configure Catalyst Center Platform. For information, see the Cisco Catalyst Center Platform
User Guide.

• Enable Cisco Catalyst Assurance. For information, see the Cisco Catalyst Assurance User Guide

• Enable Cisco AI Network Analytics data collection. For information, seeCisco Catalyst Assurance User
Guide

• Add wireless controllers to the Catalyst Center Inventory and provision them so that their telemetry data
is available to Catalyst Center. For information, see Provision Embedded Wireless on Cisco Catalyst
9000 Series Switches or Provision a Cisco Catalyst 9800 Series Wireless Controller, as appropriate.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D.

The wireless 2D map opens and displays the APs that have been added.

Step 4 Add APs to the floor map. For information, see Add APs to a Map, on page 10.

If an AP is in Local, Bridge, or FlexConnect mode, connect it to the unmanaged switch and join it to a wireless
controller.

Note

After Catalyst Center refreshes the display, any unmanaged switches are listed in the right pane.

An unmanaged switch is depicted as a typical switch icon with a "U" for unmanaged ( ).
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Step 5 (Optional) Hover your cursor over an unmanaged switch to display links between the switch and the APs to which it is
connected.

Step 6 (Optional) Click the unmanaged switch to display additional details about the switch in a slide-in pane. All information
that is available for managed switches is also available for unmanaged switches, except for the MAC address and its
reachability status.

For more information about the elements, tools, and options available on 2D maps, see View a 2D Wireless Heatmap,
on page 31.

Filter Device Data on a Floor
For 2Dwireless maps, you can apply various filters to network devices such as APs, sensors, and so on. Based
on the filter criteria, the search results display in a table. Filtering device data is helpful in locating specific
devices on floors with many devices.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D.
Step 4 In the map toolbar, click Data/Filters.
Step 5 In the Data/Filters slide-in pane, click the device type that you want to apply a filter to.
Step 6 Define the filter rules by using the drop-down lists to choose the parameters.
Step 7 To add more filter rules, click the + icon near the top of the slide-in pane.
Step 8 To customize the columns displayed in the table, do the following:

a. In the top-right corner of the table, click the three vertical dots.

b. To display a column, check the check box next to the column name.

c. To hide a column, uncheck the check box next to the column name.

d. Click Apply.
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Step 9 When you’re done, you can do any of the following:

• To display the results of your filter in the table, click Apply Filters to List.

• To display the results of your filter in the map, click Show Selected on Map.

• To locate the position of a device on the map, hover your cursor over the device in the table. A line is displayed
from the device to its position on the map.

Figure 7: Locating a Device from the Filter Results

Step 10 To remove applied filters, in the lower map toolbar, hover your cursor over the notifications icon and click Click to
clear.

Step 11 To return to the Data/Filters slide-in pane, click Data/Filters from the navigation path in the top-left corner.
Step 12 To close the slide-in pane and save the filter, click x.

Identify Wireless Interferers on the Floor Map
This feature is a 2D map feature.

Catalyst Center can detect interference and disable the interference source for a specific band on a floor map.
Any interference in the 2.4-GHz band disrupts the network traffic of the 802.11 wireless network.

Catalyst Center can identify the position, area of impact, and intensity of the interferer.

This procedure shows how to identify network interferers on a floor map.

Before you begin

Ensure that either Cisco Connected Mobile Experiences (CMX) or Cisco Spaces is integrated with Catalyst
Center. For information, see About Cisco Spaces Integration.
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Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 2D.
Step 4 In the Network Hierarchy window, click View Options.
Step 5 In the View Options window, scroll down and click the Interferers toggle button to enable interferers to be displayed

on the floor map.
Step 6 Expand the Interferers category and click the Show Zone of Impact toggle button to enable the zone of impact of

interferers to appear on the floor map.

By default, Zone of Impact is disabled.Note

Step 7 On the floor map, hover your cursor over the interferer icon and click the impacted channel to view the interferer device
details.

Work with 3D Maps
3D maps are primarily used to plan and analyze a wireless network on a floor. As such, there are minimal
configuration and edit functions that you can perform in 3D maps.

With 3Dwireless maps, you can view a 3D representation of your wireless network. A near real-time predictive
model dynamically updates the 3D map to show changes in RF coverage.

Prerequisite

The system you use to compute and display 3D wireless heatmaps must have a Graphical Processing Unit
(GPU) installed and enabled on it. For example, if you're using a Windows virtual machine (VM), you need
to make sure that it has a GPU.

3D Maps Features and Functionality

Here are some of the unique features and functionality that 3D wireless maps offers:

• Navigate through your wireless network in a 3D environment with a first person view or third person
view.

• Gain insights into the areas in your wireless network where service-level agreements (SLAs) are not
being met.

• Run an optimizer tool to compute the best AP layout to meet your SLAs.

• View the RF coverage for different elevations and use the Scanner tool to view the RF coverage for
specific elevations.

• Crop the Key Performance Indicator (KPI) heatmap with the clipping tools.

• Predict the x, y, z coordinates of a specific point on the floor plan with the pin tool to better plan for
placement of APs or sensors.

• Visualize floor plan elements, such as walls, in 3D to see how they affect RF coverage and attenuation.
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• Simulate your wireless network in various configurations to see how the wireless coverage on a floor is
affected. You can save these simulations and open them later to make more changes.

• Modify KPIs, telemetry, and 3D map element settings to customize your map display.

Configure Floor Map Elements and Overlays in 3D Maps
In 3D maps, you are limited to the following configuration and edit functions:

• Clone an AP, on page 44

• Edit an AP, on page 18

• Edit Multiple APs, on page 20

• Reposition an AP on a Map, on page 17

• Reposition a Sensor on a Map, on page 24

To configure other floor map elements or overlays, you need to use the 2D map. For details, see 2D Floor
Map Devices and Overlay Objects, on page 8.

Clone an AP
You can duplicate an AP with its configuration by cloning it.

Before you begin

You must have actual APs to clone.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 3D.
Step 4 In the map toolbar, click the Simulation toggle button to view the map in simulation mode.
Step 5 In the map toolbar, click Edit/Clone.
Step 6 On the map, click an AP.
Step 7 In the AP Details slide-in pane, click Clone.

A duplicate AP is created and displayed below the original AP. Its name is appended with -1. If you keep cloning the
same AP, the name continues to be incrementally appended. For example, the first clone for a-floor1-ap01 is named
a-floor1-ap01-1, the second clone for the same AP is named a-floor1-ap01-2, and so on.

Step 8 On the map, right-click the cloned AP and choose Move.
Step 9 Drag and drop the AP to its new position.
Step 10 Click Save.
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View a 3D Wireless Heatmap
Use this procedure to view a 3D wireless map.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 3D.

The 3D wireless map opens.

A 3D heatmap is delimited by its coverage area, which is the full floor width and length, by default. To
specify a polygon for the heatmap boundaries, click 2D > Add/Edit > Overlays and, in the left pane of the
map, clickCoverage Area. You can add and edit the coverage area in the 2Dmap. However, these boundaries
don’t apply to the 2D map view because the full floor width and length are used for the 2D map view.

Note

Step 4 To display specific details about devices, hover your cursor over the device icon. Information about the device is displayed
in a dialog box.

If the Assurance - Base package is installed, a link to the Device 360 window is also displayed in the dialog
box.

Note

Step 5 To view the heatmap for one or more APs, select and deselect the APs using one of the following methods:

• To select a single AP, click the AP.

• To select multiple APs, press the Shift key while clicking each AP, and then release the Shift key.

• To deselect a single AP, click the AP.

If no APs are selected, the heatmap includes all APs.Note

• To deselect all APs, press the ESC key or double-click an area of the map that doesn't have any APs.

Step 6 Use the tools and options shown in the following figure to gain insights about your wireless network.
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Figure 8: 3D Wireless Map Showing Tools and Options

DescriptionCallout

Insights Option: In the top-right corner of the map, click Insights to view and understand
potential issues in your wireless network. For details, see Gain Insights from a 3D Wireless
Map, on page 56.

1

Map Toolbar: Above the map, use the toolbar options to control what's displayed on the
heatmap. For details, see 3D Wireless Map Toolbar, on page 46.

2

View Options Slide-In Pane: In the slide-in pane, use the view options to control the heatmap
display. You can manipulate elements, such as which floors are displayed, heatmap coverage
and metrics, telemetry thresholds, devices and clients, overlay objects, and the depiction of a
floor and sky. For details, see 3D Map View Options, on page 47.

3

Navigation Controls: In the bottom-right corner of the map, use the map navigation controls
to view the heatmap from various perspectives. For details, see 3D Map Navigation Controls,
on page 50.

4

3D Wireless Map Toolbar
To access the 3Dmap, from the top-left corner, click the menu icon and chooseDesign >Network Hierarchy.
From the left hierarchy tree, choose a floor, and in the map toolbar, click 3D.

The map toolbar consists of two bars and is located above the map. Use the map toolbar for the following
actions and settings:

DescriptionItem

Click 3D to view the wireless map in 3D, or click 2D to view it in 2D.
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DescriptionItem

Wi-Fi Band Filter: Hover your cursor over the Wi-Fi band filter, and from the
drop-down list, choose a Wi-Fi band.

Click Edit/Clone to edit or clone existing or planned APs. For details, see Clone
an AP, on page 44.

Adding operational APs from the inventory is not available in the
3D map. To add operational APs, click Add/Edit in the 2D map
toolbar.

Note

Edit/Clone

Click View Options to open the View Options slide-in pane, which contains the
options for controlling the display of the contributing floors, map, telemetry,
devices, overlay objects, and floor geometry. For details, see 3D Map View
Options, on page 47.

View Options

Hover your cursor over More, and click Insights Configuration to customize
the conditions for insights. For details, see Gain Insights from a 3D Wireless
Map, on page 56.

More

Click the Simulation toggle button to view the map in simulation mode. When
the 3D wireless map enters simulation mode, the lower map toolbar displays the
message: "You are in Simulation Mode". For details, see Create Simulations for
3D Wireless Maps, on page 58.

Simulation mode is available only in 3D maps, not in 2D maps.Note

Simulation

Full Hierarchy Path: Displays the full navigational path of the floor, including
its associated building and site.

Refresh: Click the refresh icon to update the device and map data.

Search: Use the Search field to find specific floor map elements such as APs,
sensors, clients, and so on. The results of your search are listed in a slide-in pane
below the Search field.

When you hover your cursor over an element in the list, an indicator points to
the element on the map. If the element is outside the field of view, the indicator
is displayed as a broken red line. Reorient the map to see the element.

3D Map View Options
To access the 3Dmap, from the top-left corner, click the menu icon and chooseDesign >Network Hierarchy.
From the left hierarchy tree, choose a floor, and in the map toolbar, click 3D > View Options.

The View Options slide-in pane opens. Expand the categories to view the settings:

• Contributing Floors: Expand this option to include more floors in the heatmap computation. When
including a floor, you can choose to add its APs in the heatmap computation and display its APs and
floor geometry. Click Apply to generate the heatmap with your settings.
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Figure 9: 3D Map of Multiple Floors

DescriptionItem

Check this check box to include a floor's APs when computing the heatmap.Compute APs

Check this check box to display a floor's APs in the heatmap.Display APs

Check this check box to display a floor's physical attributes in the heatmap.Display Geometry

• Heatmap: Click the Heatmap toggle button to display the heatmap, and expand this option to configure
the settings using the following table:

DescriptionItem

Use this drop-down list to choose the RF model.

The RF model determines how RF is calculated based on the floor geometry.
Available models include drywall offices, cubes and walled offices, free
space, outdoor open space, and indoor high ceiling.

We recommend that you choose Free Space if you manually
placed the walls or imported them from a CAD file or Ekahau
project. If you didn't manually place the walls, use an RFmodel
other than Free Space.

Note

3D RF Model

Use this drop-down list to choose whether to display operational devices,
operational and planned devices, or only planned devices on the heatmap.

Heatmap Devices

Use this slider to customize the opacity or transparency of the heatmap.Heatmap Opacity
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DescriptionItem

Choose the type of metrics to display on the heatmap:

• RSSI: Displays the Received Signal Strength Indicator (RSSI) values.

• SNR: Displays the signal-to-noise ratio (SNR) values.

• Interference: Displays the SNR that is caused by co-channel interference
(CCI) or adjacent channel interference.

• Leakage: Displays signal leakage between floors. For this option to be
available, you must compute the heatmap with two or more contributing
floors.

Heatmap Metrics

Choose the heatmap type:

• Point Cloud: Provides a collection of data points in space. Each data
point has x, y, and z coordinates.

• Isosurface: Represents the RSSI with isolines or lines of a contiguous
value.

• Scanner: Displays the RSSI for a specific elevation.

Heatmap Type

Check this check box to show signal reflection, which can be caused when a
signal bounces off materials such as glass, whiteboards, and plastic.

Apply Reflection

• Telemetry: Click theTelemetry toggle button to enable and disable telemetry.When telemetry is enabled,
click a sensor or AP to view its telemetry:

• The telemetry for a sensor displays the predicted and measured RSSI values between a sensor AP
and other APs.

• The telemetry for an AP displays the predicted and measured RSSI values between neighbor APs.

Expand this option to use the Telemetry Threshold slider to set the threshold for telemetry sources to
be displayed on the heatmap. Telemetry sources with predicted values that do not meet the threshold are
faded.

• Devices: Expand this option to configure the settings using the following table:

DescriptionItem

Check this check box to display APs on the map.APs

Check this check box to display planned APs on the map.Planned APs

Check this check box to display sensors on the map.Sensors
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DescriptionItem

Check this check box to display clients on the map. Additionally, you
can do the following:

• Display clients in their default blue color (None) or by their RSSI,
SNR, or Health Score. For RSSI, SNR, andHealth Score, clients
are colored blue, yellow, or red, depending on their current
condition.

• Use theBall Size slider to change the size of the ball that represents
a client on the map.

Clients

• Overlay Objects: Expand this option to configure the settings using the following table:

DescriptionItem

Check this check box to display the floor geometry.Geometry

Use this slider to set the height of walls on the heatmap.Height

• Map: Expand this option to configure the settings using the following table:

DescriptionItem

Check this check box to display the sky in the heatmap.Sky

Check this check box to display the floor in the heatmap.Floor

3D Map Navigation Controls
To access the 2Dmap, from the top-left corner, click the menu icon and chooseDesign >Network Hierarchy.
From the left hierarchy tree, choose a floor, and in the map toolbar, click 3D.

The 3D map navigation controls are located at the bottom-right corner of the map. For details about the map,
see View a 3D Wireless Heatmap, on page 45.

Use the map navigation controls at the bottom-right corner of the map to control the map view.
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DescriptionMap Navigation
Control

Use clip box: Click this icon to crop the heatmap using a box shape. Use the clipper at
the bottom-left corner of the map to specify the crop:

• Click and drag one of the anchor points to change the size of the crop.

• Click and drag one of the anchor points on the right vertical slider to specify the
height range of the crop.

Figure 10: Clip Box
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DescriptionMap Navigation
Control

Use clip planes: Click this icon to crop the heatmap using a donut shape. Use the clipper
at the bottom-left corner of the map to specify the crop:

• Click and drag the anchor point in the center of the donut to reposition the donut.

• Click and drag the two outer anchor points to change the shape of the crop.

Figure 11: Clip Planes in Use

First Person View: Click this icon to switch between first-person view and third-person
view.

The blue sphere indicates your position on the map. As you move throughout the map,
your field of view changes. You can use the mini map at the lower-left corner to get an
idea of your field of view and orientation.

If you have more than one floor selected for display, the First Person
View automatically positions you on the current floor.

Note

For details, such as the controls for view, see Use First-Person and Third-Person Views
for 3D Wireless Maps, on page 54.
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DescriptionMap Navigation
Control

Third Person View: Click this icon to switch between first person view and third person
view. You can also drag and drop the icon on the map where you want to be positioned.

The blue sphere indicates your position on the map. As you move throughout the map,
your field of view changes. You can use the mini map at the lower-left corner to get an
idea of your field of view and orientation.

For details, such as the controls for view, see Use First-Person and Third-Person Views
for 3D Wireless Maps, on page 54.

Place a pin: Click this icon to view a predicted measurement (x, y, and z coordinates)
of a specific point on the floor map. By placing a pin, you can view the measurements
of the distance from the pin to the end of the yard stick. As you zoom in or zoom out,
the position of the measurements is adjusted to stay in your view. Drag and drop the pin
to change its position, as follows:

• To move the pin horizontally: Click the horizontal arrows and drag the pin left,
right, forward, or backward. The selected arrows and yard stick are highlighted
while active.

• To move the pin vertically: Click the vertical arrows and drag the pin up or down.
The selected arrows and yard stick are highlighted while active.

For a video demonstration, click here.

Figure 12: Adjusting a Pin

Zoom In: Click this icon to enlarge the view. Alternatively, you can use your mouse
wheel to zoom in.
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DescriptionMap Navigation
Control

Zoom Out: Click this icon to reduce the size of the image and to increase your field of
view. Alternatively, you can use the scroll wheel on your mouse to zoom out.

Map Rotation and Default Map View: Click the directional arrows to change the
camera angle.

Click the Return Home icon to reset the map to the default view.

Use First-Person and Third-Person Views for 3D Wireless Maps
You can use the first-person and third-person views to gain different perspectives of your wireless network.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 3D.

Step 4 To use the first-person view, click the first-person view icon in the map navigation controls. Optionally, you can

drag and drop the person icon to a specific location on the map.

The map view changes to the first-person view.

Figure 13: First-Person View
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Step 5 You can control the first-person view by doing the following:

ControlsAction

Use the W, A, S, and D keys or arrow keys.Move forward/backward and right/left.

Click and hold the left mouse button on the map and move
the mouse wheel.

Change the camera angle.

Hold the Spacebar.Raise the altitude of the camera angle.

Hold Shift + Spacebar.Lower the altitude of the camera angle.

Step 6 To use the third-person view, click the third-person view icon from the map navigation controls.

The map view changes to the third-person view.

Figure 14: Third-Person View

Step 7 You can control the third-person view by doing the following:

ControlsAction

Use the W, A, S, and D keys or arrow keys.Move forward/backward and right/left.

Click and drag on the map.Change the camera angle.

Hold the Spacebar.Raise the altitude of the camera angle.
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ControlsAction

Hold Shift + Spacebar.Lower the altitude of the camera angle.

Step 8 To return to the default view, click the return home icon .

Display Details About APs and Clients
If you have a location service, such as Cisco Spaces or Cisco ConnectedMobile Experiences (CMX), installed
on Catalyst Center, you can view the locations of clients on a floor. Clients are identified as a small blue ball
( ) on the map.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 3D.

A 3D heatmap is delimited by its coverage area, which is the full floor width and length, by default. To
specify a polygon for the heatmap boundaries, edit the Coverage Area field value in the 2D map view.
However, these boundaries do not apply to the 2D map view because the full floor width and length are used
for the 2D map view.

Note

Step 4 To display details about an AP, click the AP.
Step 5 To display information about a client, hover your cursor over the ball (client).

A line is drawn between the client and its associated AP. A dialog box is displayed with information, such as the client's
IPv4 address, IPv6 IP address, RSSI value, and so on. To open the Client 360 window, click the Client 360 link in the
dialog box.

Step 6 To display the client in a color that corresponds to its RSSI, SNR, or health score, do the following:
a) Click View Options > Devices and Clients.
b) Check the Clients check box.
c) Under the Clients check box, click None (default blue color), RSSI, SNR, or Health Score.

Step 7 To resize the ball, use the Ball Size slider in the View Options pane. This feature helps you to view clients in cases where
there are many clients or only a few. For example, in cases where there are many clients, you can make the ball smaller,
and in cases where there are only a few clients, you can make the ball larger.

Gain Insights from a 3D Wireless Map
Catalyst Center actively monitors the network performance of 3D wireless maps and provides insights into
areas where service-level agreements (SLA) are not being met.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
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Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 3D.
Step 4 At the top-right corner of the map, click Insights.

The Insights area opens and displays information about the coverage areas that don't meet a specific KPI threshold, for
example, RSSI is > -70 dBm.

Figure 15: Insights Area

Step 5 In the Insights area, you can do any of the following actions:

DetailsItem

Click this link to display the wireless coverage area. Red areas showwhere the SLA
is not being met. Green areas show where it’s being met.

View coverage gaps

Click this link to have Catalyst Center analyze the wireless coverage area. You can
indicate the maximum number of APs that you are willing to move and add, and
Catalyst Center computes a configuration where the wireless coverage is maximized.

For more information, see Run the Wireless Coverage Optimizer, on page 57.

Optimizer

Click this button to exclude an insight from displaying in the Insights dialog box.

Muted insights appear at the bottom of the list in the All Insights slide-in pane.

Mute This Insight

Click this button to display all active and muted insights.

For each insight, you can click Mute or Unmute to exclude or include its display
in the Insights dialog box.

Click Edit Configuration to customize the insight KPI settings.

Another way to customize insight KPI settings is from the map toolbar. Hover your
cursor over the gear icon in the map toolbar and choose Insights Configurations.

View All Insights

Run the Wireless Coverage Optimizer
For wireless areas that aren't meeting their SLA, the optimizer takes your input of the maximum number of
APs that you are prepared to move and add, and computes a configuration where the wireless coverage is
maximized.

This procedure shows you how to run the wireless coverage optimizer.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
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Step 3 In the map toolbar, click 3D.
Step 4 At the top-right corner of the map, click Insights.

The Insights area opens and displays information about the coverage areas that don't meet a specific KPI threshold,
for example, RSSI is > -70 dBm.

Step 5 (Optional) To display the wireless coverage area, click View.

Red areas show where the SLA is not being met. Green areas show where the SLA is being met.

Step 6 (Optional) If there are specific APs that you don't want the optimizer to move, you can right-click them and choose
Lock to lock their position. To remove the lock, right-click the AP and choose Unlock.

Step 7 Click Optimizer.
Step 8 In the Coverage Optimizer dialog box, enter the maximum number of APs that you are prepared to move and add.

If you don't want to move or add APs, leave the corresponding field blank or enter 0.

Step 9 Click Run Optimizer.

If needed, you can manually move any of the APs to other locations.

Step 10 When the analysis is complete, click View Results.

Catalyst Center displays a proposed layout that increases the wireless coverage to maximize the SLA. If the optimizer
recommends moving an AP, the new layout displays a blue line to the recommended new location. Any new APs that

have been added to the layout are displayed as blue markers ( ).

Step 11 To save the new layout as a simulation, click Save as a plan. To exit without saving, click the x at the top-right corner
of the map.

Later, if you implement the recommended changes to your physical wireless network, you can save the simulation as
an operational map. For information, see Create Simulations for 3D Wireless Maps, on page 58.

Create Simulations for 3D Wireless Maps
You can create simulations for 3D wireless maps.

Simulation mode is available only in 3D maps, not in 2D maps.Note

Simulations allow you to change device configurations without actually implementing them. You can create
multiple simulations and load them at any time.

Step 1 From the top-left corner, click the menu icon and choose Design > Network Hierarchy.
Step 2 From the left hierarchy tree, choose a floor.
Step 3 In the map toolbar, click 3D.
Step 4 In the map toolbar, click the Simulation toggle button to view the map in simulation mode.

The lower map toolbar displays the message: "You are in Simulation Mode".

Work with Wireless 2D and 3D Floor Maps
58

Work with Wireless 2D and 3D Floor Maps
Create Simulations for 3D Wireless Maps



Step 5 In the map toolbar, click Edit/Clone.

In simulation mode, only particular attributes are editable for previewing the impact of changes on the heatmap.

Step 6 Make any changes to the devices, as needed, for the simulation, and then click Apply.

• APs: You can change the model, channel, antenna, and more.

• PAPs: You can change the model, channel, antenna, and more.

Step 7 In the map toolbar, hover your cursor over the vertical ellipsis and choose Save changes as to save the configuration
as a new simulation.

Figure 16: Saving as a Simulation

Choose Save changes when you want to saves any changes to an existing simulation.

Choose Commit when you want to commit the simulation to the production environment. Note that you
can only commit planned APs.

Note

Step 8 In the Save Simulation dialog box, enter a name for the simulation and click Save.

The new simulation is displayed on the map.

Step 9 (Optional) To display a different simulation, do the following:

a. Make sure that you are in simulation mode and are not editing any devices.

b. From the Select Simulation drop-down list, choose a simulation.

If you have no saved simulations, None available is displayed instead of the Select Simulation drop-down list.

Step 10 (Optional) To delete a simulation, do the following:

a. From the Select Simulation drop-down list, choose a simulation.

b. Click the delete icon next to the Select Simulation drop-down list.
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