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CHAPTER 1

Ul overview

This section covers the following topics:

* Ul overview, on page 1
» Workflows, on page 1
* Jobs, on page 3

Ul overview

The Cisco CWM user interface allows you to access all of the product's core functions. You can access them
through four main menu selection paths:

» Dashboard: Add customizable dashboards with dashlets that monitor the status of many CNC functions,
including CWM workflows, adapters, workers, and active tasks.

* Design: Add, manage, and delete workflow definitions, and forms.

* Operate: Run new workflows, check the status of particular workflow executions (jobs), view schedules,
or manage manual tasks that are triggered by workflow execution callback states.

» Administration > Workflow Administration: Add and manage workers, adapters, secrets, resources,
event types, and system settings.

Workflows

The main Wor kflows view consists of a list of workflows added to CWM with details and possible actions.
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. Workflows table

Workflows table

Figure 1: All Workflows tab

() Workflow definition nanr Workflow ID Version Description Workflow tags

The Wor kflows table consists of the following columns:
* A) Workflow definition name: unique name of the workflow.
* B) Workflow I D: unique identifier assigned automatically after workflow creation.

* D) Version: indicates the current workflow version number, allows keeping track of the workflow
versioning.

* C) Description: optional field used for describing your workflow functionality.
*» E) Workflow tags: shows tags assigned to a given workflow.
* F) Actions: shows possible actions for a given workflow:

* Run: starts a single execution of a given workflow (job).

* Delete: removes an added workflow from CWM (this action is irreversible).

Figure 2: Gear icon

Show/Hide Columns X

Workflow definition name
Workflow ID

Version
Description

Workflow tags

@ Updated

To show/hide the columns displayed in the table, use the gear icon on the right side above the table.
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Bulk actions on workflows .

Figure 3: Filter option

[ Q age ® ] 4 matching results

To search the table for the specified value(s), provide your input in the Search field above the table. The
search is performed in all the columns, whether they are currently displayed in the table .
Bulk actions on workflows

You can perform bulk actions on multiple workflows at once. To select a workflow, tick the checkbox on the
right-side of the All Workflows table. You have three possible bulk actions:

« Edit tags: modifies tags for selected workflows by adding one or more or resetting them.
» Delete Selected: removes selected workflows from the list and CWM (this action is irreversible).

» Export: exports selected workflow entries to a CSV file.

Figure 4: Bulk actions

® ] 4 matching results

Jobs

The Jobs view lets you monitor job statuses and rerun or cancel jobs (workflow executions).

Job Tabs

At the top of the Jobs view, status tabs display an overview of the number of jobs and serve as status filters.
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There are four available status tabs:

Figure 5: Jobs status tabs

< Operate
Jobs
0 Active ° 6 Completed ° 0 Scheduled @ 8 Cancelled/Failed °
[ Status v ] [ 7 Status ® v ] 14 matching results
() status Job name Run ID Job tags wor &
D © Completed NSONetbox2 01076327-d799-49dc-91
D @ Completed NSONetbox1 24c7a0f7-4823-4072-at
D © Completed da 5939a623-927b-49d6-8¢
[ @ completed da 1e524da7-4264-483d-8"
D @ Completed dna dccffd3a-b9af-4830-at
D © Completed CreateL3VPN 6bd77ef9-chle-417a-8¢
D © Failed CreateL3VPN 8662abe9-95d0-4edc-ac

Active: The number of jobs currently running.
Completed: The number of jobs that have completed successfully.

Scheduled: The number of jobs currently scheduled to run.

A w0 D

Cancelled/Failed: The number of jobs that were manually terminated by users or that failed during
execution.

To see all the jobs with a particular status, click on the appropriate status tab. For example, to see all the active
jobs, click on the Active status tab. The Active jobs will then be shown in the table below the tabs.

The Scheduled status tab will display only scheduled jobs and their details in the table. You may also find
particular jobs on a given schedule under other tabs, according to their completion status (for example, a
Scheduled job may also be Active or Completed).

The Jobsview shows all jobs (workflow executions) run in the last 24 hours. You can also use the filter table
option to search the table for specified values.

While filtering based on tags, you can filter on only one tag at once. You can filter on multiple job tags only
while using the APIL.

Bulk actions on jobs

The Jobs view enables you to perform bulk actions on many jobs at once.

To select one or more jobs, first click one of the four job status tabs, then click the checkbox next to the jobs
you want. Then click the more icon (...) on the right side of the table.

The actions available to you will vary depending on the job status tab you have currently selected:

» Export Selected: Exports all the selected job entry details to a CSV file. Available for Active, Completed,
Scheduled, and Cancelled/Failed jobs..
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Bulk actions on schedules .

* Cancel Selected: Terminates the selected jobs that are currently running. Available only for Activejobs.

» Delete Selected: Deletes the selected scheduled jobs from the list and from the database. Available only

for Scheduled jobs; this action is irreversible.

Bulk actions on schedules

Job details

You can perform bulk actions on many schedules at once. To select a schedule, tick the checkbox on the right

side of the Scheduled jobs table.

» Export Selected: exports selected schedule entries to a CSV file.

* Delete Selected: removes selected schedules from the list and CWM (this action is irreversible).

To check the details of a job, in the Job Manager choose the appropriate tab (Active, Completed, Cancelled

). In the table, click on the name of the job entry you want to check.
Figure 6: Details tab

< Job Manager Last Refresh: 29-Jul-2024 09:09:14 AM CEST | Refresh

age @ Completed Duration: 3m 25s Back m
Details

Job name Run ID Start time Close time

Workflow definition name Attempts

age

Version

Worker

Job tags Workflow tags

The Details tab lets you check the following data for the selected job:

+ Job name: name of the particular workflow execution; by default, it is the workflow definition name.

* Run I D: unique identifier for workflow execution.

» Workflow definition name: name of the workflow definition used to run a particular job.

« Version: version of the executed workflow definition.

» Worker: worker assigned to the workflow definition.

« Job tags: keyword(s) assigned to the job that allows filtering/sorting jobs based on them.
» Wor kflow tags: keyword(s) assigned to the workflow definition used to run a particular job.

 Start time: date and time when workflow execution started, for example 05-May-2023 02:59:25 PM

CEST.
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* Closetime: date and time when workflow execution ended, for example 05-May-2023 03:59:25 PM
CEST. If the execution is still running or it was failed/canceled, the appropriate status is displayed instead.

» Attempts: indicates the number of tries needed to execute the workflow successfully; the maximum
number of attempts can be limited by the workflow definition.

* The Parent Run ID field may be displayed if your job was executed as a child workflow.

Job summary

The Job summary panel displays the following data:

* To check the details of a job, in the Job Manager choose the appropriate tab (Active, Completed,
Cancelled or All).

* In the table, click on the name of the job entry you want to check.

* In the Detailstab, you can check the following data for the given job:
Figure 7: Job details

* A) Run ID: unique identifier for workflow execution.

* B) Execution status: the current condition or final outcome of workflow execution.

* C) Job tags: keyword(s) assigned to the job that allows filtering/sorting jobs based on them.
+ D) Definition name: name of the workflow definition used to run a particular job.

* E) Definition version: version of the executed workflow definition.

+ F) Start time: date and time when workflow execution started, for example 05-May-2023 02:59:25
PM CEST.

* G) Closetime: date and time when workflow execution ended, for example 05-May-2023 03:59:25
pM cEsT. Ifthe execution is still running or it was failed/canceled, the appropriate status is displayed
instead.

» H) Duration: the elapsed time between the start and completion of the workflow execution.

« ]) Attempts: indicates the number of tries needed to execute the workflow successfully; the maximum
number of attempts can be limited by the workflow definition.

* Optionally, the Parent Run I D field may be displayed if your job was executed as a child workflow.

Results and event history

The Resultsand Event history present the workflow input and final result as well as the series of events that
the workflow engine has performed while executing the workflow definition.

The panel consists of the following data:
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Figure 8: Job Event Log
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. Tasks

The Input and results panel present the input data (on the left) provided on the workflow definition run and
the final output data returned from by the workflow upon completion of the workflow events.

Event history is a comprehensive, ordered log of all Events generated during a workflow execution. These
events are produced in response to external occurrences and actions issued by the workflow. The Event history
serves as the definitive record of a workflow lifecycle, capturing every state transition and action taken.

Tasks

Tasks allow operators to intervene manually during workflow execution. You configure tasks using the Forms
view in the Design menu, and refer to them as part of the Callback state inside the workflow definitions.

The Task List displays tasks that are currently pending for input by the operator.

Tasks

p Tasks
[ a searcn | status v | 2matching resuits

[] Taskname Job name Status Assigne Created @

() Please provide your age age ® Running 12-Jul-2024 09:14
(

] Applicant age check age @ Running 23-Jul-20624 106:20

Rows per page [ 50 v |

To use the task list:
1. Click on a task name to see the task prompt and provide input.
2. Use Search to find a specific task or the Status filter to filter out tasks according to their status.

3. Select task(s) to export them to a CSV format.

Workflow Administration

The Wor kflow Administration view allows you to manage adapters, workers, secrets, resources, event types,
system settings, and public keys through dedicated tabs.
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Figure 9: Admin view

Y Workflow Administration

Design
n Workers
Operate
Secrets
do
Administration

System Settings

{style="border: 1px solid gray;"}

Adapters

The Adapterstab displays a table listing all uploaded adapters. Above the table, there is the Add adapter
action button that allows you to upload adapter to CWM and and install it.

I! note To export all details of selected adapter(s) to a CSV file, check them in the list and click the Export
action button.

» A) Adapter name: unique adapter name.
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* B) Version: version of the added adapter.
* C) Vendor: vendor name, as specified in the adapter properties.

* D) Set asdefault: in this column, the adapter can have one of two possible statuses, depending on whether
it is set as a default adapter to be used by workflow.

* True: indicates the adapter is the default one for accociated activities.
* False: indicates the adapter is not set as the default one.
* E) In Use: in this column, the adapter can have one of two possible statuses, depending on whether it is
currently in use, which determines if it can be deleted.

* True: indicates the adapter is currently in use by one or more workflows and therefore cannot be
deleted.

* False: indicates the adapter is not in use by any workflow and can be deleted.

* F) Actions:
* Delete: deletes the uploaded adapter from CWM.

* Install installs the already uploaded adapter to CWM.

Workers

The Worker stab displays a table listing all existing workers. When you check worker(s) in the table, various
action buttons appear:

» Add Worker: allows you to create a new worker and assign to it activities from already installed adapters.

* Start Worker: starting the worker allows it to execute assigned tasks and changes the worker's status
to running.

* Stop Worker: stopping the worker allows it to execute pending actions but blocks its ability to accept
new tasks. After clicking on the Stop Worker button, the confirmation modal Stop worker(s) appears. If
the worker actively executes an ongoing task, you won't be able to stop it, unless you tick the checkbox
Force stop. This action stops the worker regarding whether it performs any task and might cause the
failure of ongoing jobs.

* Delete: deletes the worker permanently (this action is irreversible). If the worker is running, it's force
stopped before deleting.

» Export selected: downloads the CSV file with the details of the selected workers, including worker
name, status and nr of activities.

The Worker stable has the following columns:
* A) Worker Name: unique worker's name. Once created, it cannot be modified.
* B) Status: worker has three possible statuses visible in the CWM UI:
* Initialized: worker status after creation, if you don't choose to start it immediately.
* Running: indicates started worker available to execute tasks.

* Stopped: indicates stopped worker unavailable for task execution.
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» C) Nr of activities: shows how many adapters' activities are assigned to the worker.

Resources

The Resources tab displays a table listing all existing resources. Above the table, there are various action
buttons:

» Add Resource: allows you to add resource to CWM.

» Export: downloads the CSV file with all details of selected resources.

The Resour ces table has the following columns:

» A) Resource name: unique resource name.

* B) Resourcetype: resource type specified in the adapter files.
* C) Secret |1D: associated secret ID.

* D) Actions:

» Delete: removes resource from CWM

Secrets
The Secretstab displays a table listing all existing secrets. Above the table, there are various action buttons:

» Add Secret: allows you to add secret to CWM.

» Export: downloads the CSV file with all details of selected secrets.

The Secretstable has the following columns:

* A) Secret | D: unique secret name.
* B) Secret type: secret type specified in the adapter files.
» C) Actions:

» Delete: removes secret from CWM

Event system
In the Event system tab, you define Kafka events that your workflows will consume or produce.

» Add event type: allows you to define a new Kafka (or other) event in CWM. They can be of either
consume OI produce kind.

* Delete Selected: deletes selected event types from the list and from CWM (this action is irreversible).

* Export: downloads the CSV file with all details of the selected event types.
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System Settings

With the System settingstab, you can manage job retention, retry policies, and timeouts. It controls how long
completed jobs are kept, retry behavior (delay, jitter, max attempts), and various timeout settings for actions,
events, states, system activities, and workflows.

Public keys

The Public keys tab in the CWM Ul is used to manage public keys for adapter signature verification. These
keys allow CWM to validate that uploaded adapters are signed by trusted developers and have not been
modified.

< Administration

Public Keys

[ Q Search ] 1 matching results

Enabled Name Key Form Key

o default PKCS#8  RSA

Each public key entry includes:
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* Name: logical name of the key
» Key Form: currently PKCS#8
» Key Algorithm: currently RSA
* Author: adapter author associated with the key
» Status: enabled or disabled
When adding a public key, the user must specify the Author. The author value is case-sensitive and must

exactly match the author field defined in the adapter’s adapter.properties file. During adapter upload, CWM
selects the public key based on this author and verifies the adapter’s signature.

Public keys can be enabled or disabled at any time, allowing administrators to control which signed adapters
can be uploaded to CWM.
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Initial setup

This section covers the following topics:

* Initial setup, on page 15

Initial setup

This section provides instructions to guide you through your first steps in using CWM. This initial setup
allows you to prepare your workplace and start executing workflows.

CHAPTER 2

Use these guidelines to accomplish the following:

Procedure

Command or Action

Purpose

Step 1

Install adaptersand create workers.

First, you need to add and install adapters that allow
workflows to interact with external systems. In this guide,
it's assumed that you will use the default adapters shipped
with CWM, or that you have custom adapters developed
and ready to use. For execution of your adapter activities
and code, you need workers. You can create a worker
directly during adapter installation.

Step 2

Configure secretsand resources.

Adapters mostly communicate with external entities via
APIs, and they need to have connection data, like port or
host, and authentication data, like username with password.
This information is kept in secrets and resources. The
structure and schema for each resource and secret type are
defined in the adapter files. As an operator, you can add
secrets and resources to CWM. Once created, they can be
reused by different workflow definitions and passed on
when needed.

Step 3

Add your workflow definition.

Workflow definitions, often referred to as workflows, are
pieces of code intended to automate operations. They are
written in JSON or YAML and follow the Serverless
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. Install an adapter

Command or Action Purpose

Workflow Specification. Before workflows can be executed,
they must be to be added to CWM.

When you complete this setup you are ready to run your
first job.

Install an adapter

Follow these steps to upload an adapter file and then install (deploy) it.

Procedure

Command or Action Purpose

Step 1 In CWM, choose Administration > Wor kflow
Administration > Adapters.

Step 2 Click the Add adapter button.

Step 3 In the Install adapter window, click on or drag an Note

installable adapter file to the file uploader area and then | The only supported installable adapter file format is tar.gz.
click Install Adapter. You can find adapter files in the
CWM software package.

Install adapter

X Click or drag adapter file to this area to upload

«

Cancel

Step 4 After the adapter file is uploaded to the CWM database, | If the installation is interrupted or you chose Cancel, the
optionally tick Automatically create worker for this adapter will be added to the CWM database and visible in
adapter checkbox if you want to create one, then click the adapters list, but will not be installed and will be
Install Adapter to finish the installation process. unusable by workflows. If you canceled the installation
intentionally and want to remove the adapter from the list,
click Delete under the Actions column.
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Set adapter as default for associated activities .

Command or Action

Purpose

Install adapter

& cwm.v2.0.0.generic.rest.v1.0.3.tar.gz

p Automatically create worker for this adapter
X

Cancel Install Adapter,

X

Step 5

If your adapter was installed, you should see the message

"Your_adapter's_name has been fully installed!". Click
Done.

Install adapter

& Administration

Adapters

cwm.v2.0.0.generic.rest.v1.0.3.tar.gz has been fully installed!

Adapter not installed: If the process failed or was

interrupted, you can finalize it later by clicking the | nstall
button under the Actions column.

3 matching results + Add adapter
[} Adapter name Version Vendor Setas default Inuse @
[ cisco.nson1.0.3 v1.0.3 © True © True
[J generic.restv1.0.3 v1.0.3 generic O False © True
() generic.emailv1.0.2 v1.8.2 generic © False © False

Delete
Rows per page | 50 Install
]

Set adapter as default for associated activities

You can set which adapter should be the default one for associated activities. To do so, follow the steps below.

Procedure

Command or Action Purpose
Step 1 In CWM, choose Administration > Wor kflow

Administration > Adapters
Step 2 In the Adapterslist, click the name of the chosen adapter

to open the adapter's details view.

Cisco Crosswork Workflow Manager 2.1 Operator Guide [JJj
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Command or Action Purpose

Step 3 In Use as default version, select True.

Administration > Adapters

generic.rest.v1.0.3 ©inuse Back

A\ Adapters in use can't be deleted.

Adapter details

Adapter ID Vendor Product Version [
generic.rest.v1.0.3 generic rest v1.0.3 F
Description Resource type Created Updated |

Cisco Generic Rest Adapter generic.rest.resource.v1.0.0 05-Mar-202512:41:38 PM ...  05-Mar-2025 12:46:28 PM ...

In-use
© True

Use as default version

(o )

© True ¥ ]

N
O False J
Step 4 Click Save Changes. After setting the adapter as the default one, you should see

a relevant status under Set as default column on the
adapters list.

Delete adapter
You can delete an adapter if it has the status Not in use under the In Use column in the adapters list.

You cannot delete an adapter that is in use by one or more running workflows. The adapter will be shown
with an In use status and the Delete button will be disabled. To delete the adapter, you must first terminate
the running workflows and remove the associated workers.

Procedure

Command or Action Purpose

Step 1 In CWM, choose Administration > Wor kflow
Administration > Adapters.

Step 2 In the Adapters list, find the adapter you want to remove
and click the Delete button in the same row under the
Actions column.

Step 3 In the Delete Adapter window, confirm by clicking the
Delete Adapter button.

Add worker

This topic explains how to create a worker in CWM.
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Before you begin

Be sure to add and deploy one or more adapters.

Procedure

Command or Action Purpose

Step 1 In CWM, choose Administration > Wor kflow
Administration > Workers.

Step 2 In the Worker s view, click Add worker.

Step 3 In the Create new worker window, provide the required
input: Create new worker

Administration > Workers

General Worker name*

[ MyNewWorker

Start worker after creation

Acthities & 18 available Expand All () 5selected
v cisco v [ generic
v = nso e D rest
. @ o3 ’ vOv
> [) device " n
> restconf

» Worker name: Type a name for your worker; for

example, MyNewWorker. Once created, it cannot be
modified.

» Start worker after creation: Check the checkbox to
automatically start the worker as soon as you click
Create worker.

« Activities: Check the checkboxes for selected adapter
activities you want to assign to your worker, then click
the right-pointing arrow to and move them to the
selected field . In our example, a worker for the
Generic Rest adapter's activities is created.

If you want to remove any of the previously selected
activities from the worker, check the checkbox next to each
selected activity you want to remove and then use the
left-pointing arrow to remove it.

Step 4 Click Create worker.
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. Create secrets and resources

What to do next

The Worker Profiles tab in the CWM UI lets administrators manage worker configurations. From this page,
users can view existing profiles, create new ones, and adjust CPU and memory limits. To add a profile, click
Add worker profile, provide a profile name, set the minimum and optional maximum CPU and memory
values, and save the changes. Once created, you can select the specific worker profile when creating a new
worker. The default worker profile for CWM 2.1 has 500m CPU min and 250Mi MEM min as default values.

Create secrets and resources

The following topics explain how to add secrets and resources to CWM. Be sure to upload adapters with
workers, and add secrets before adding resources, as resources use secrets.

Add a secret

Procedure

Command or Action Purpose

Step 1 In CWM, choose Administration > Wor kflow
Administration > Secrets

Step 2 In the Secrets view, click Add secret.
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Add a resource .

Command or Action Purpose
Step 3 In the New secret view, provide the required input: N
Administration > Secrets
New secret

General Secret ID*

[ testSecret ]
Secret type*

awsS4

basicAuth

token

bearer

* Secret | D: Enter a unique name for your secret.

* Secret type: Select a Secret type from the drop-down
menu. Secret types are defined in adapters and are
added during adapter installation.

Step 4 After selecting the secret type, CWM displays a set of pdinistration > Secrets

additional fields (for example, Username and Passwor d)

in the Secret type details section. The adapter specifies New secret

these detail fields, and they will vary with the adapter and "

egq . . . General Secret ID

secret type. Fill in the fields with values, as appropriate. [ o—— ]
Secret type*
[ basicAuth v ]

Secret type details password*

- fem
username*
C- | G=)
Step 5 Click Create Secret. Once you've added a secret and its details, create a resource
in CWM and associate it with the secret, as explained in
Add a resource, on page 21.

Add a resource

Before you begin

Ensure that you have already created a secret, as explained in Add a secret, on page 20
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. Add a resource

Procedure

Command or Action Purpose

Step 1 In CWM, choose Wor kflow Administration > Resour ces

Step 2 In the Resour ces view, click Add resource.

Step 3 In the New resour ce view, provide the required input: * Resource name: Enter a unique name for your
resource. Once created, it cannot be modified.

* Resourcetype: Select a Resource type from the
drop-down menu. Resource types are defined inside
adapters and are added to during adapter installation.

New resource

General Resource name*

[ testResource ]

Resource type*

| 4

Secret ID

[ ~)

Connection

Step 4 After selecting the Resour cetype, the Connection section
displays a set of additional fields (for example, host and
port) . The adapter specifies these extra fields, and they
will vary with the adapter and resource type. Fill in the
fields with appropriate information.
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Command or Action Purpose
Step 5 Select a Secret 1D from the drop-down menu to associate
- . - New resource
a previously created secret with this resource.
General Resource name*
[ testResource ]
Resource type*
[ cisco.nso.resource.v1.0.0 ® v ]
Secret ID
[ NSOSecret ® v ]
Connection host*
[ 127.0.01 ]
port
[ 8080 ]
config
scheme
[ https ]
timeout
(= )
allowlnsecure
[ False ® v ]

Step 6 Click the Create resour ce button. You are not required to fill in the Secret 1D and Connection
details when creating the resource. You can insert the proper
values later, but you must fill them in before attempting to
use the resource or it will not work properly.

Once created, your resource is displayed on the list in the
main Resources view.

Add workflow

This topic explains how to add a workflow definition to CWM.

\)

Note These steps create a workflow entry in CWM with dummy code that needs further editing. After you create
the workflow, go to the Designer tab to insert your workflow definition.
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Procedure

Command or Action Purpose

Step 1 In CWM, choose Design > Workflows.
Step 2 Click Create workflow.

Step 3 In the Create workflow page, provide the required input: » Workflow definition name: Enter the name for your
workflow definition, for example, test workflow.

* Version: Enter your workflow definition version, for
example, 1.0.

Step 4 Cllck Cr%.te Design > Workflows
Create Workflow o vaiid

Details Designer

Details Workflow definition name*

[ test_workflow ]

Version*
@ )

Tags

[ test, demo ]

Description

[ This is a test description. ]

Use form as input

[ not set v ]

Workflow export/import

Workflow export/import allows workflows to be moved between environments or backed up. A
workflow can be exported to a JSON file, which contains the full workflow definition, including
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Workflow editing .

structure, activities, and configuration. To import workflows back into CWM, use the Import
wor kflows button and upload the JSON file with exported workflows

Workflow editing
Procedure
Command or Action Purpose
Step 1 To edit an existing workflow, first choose Design >

Workflows to display the Wor kflows list.

Step 2 In the list, find the workflow definition you want to edit. * Change the Wor kflow definition name.
Then click on that definition's Wor kflow name to display

the workflow's Details tab. You can then: * Change the workflow's Version number.

* Change, delete, or add new Tags to the workflow. To
add more workflow tags, separate them with a comma.
Workflow tags are separate from job tags, and are
passed to every execution of this workflow definition
(job run). You can edit workflow tags from the
workflow definition details level, but once you add
them to a run, they cannot be changed.

* Add or edit the workflow's Description.

» Useform asinput. The form you set as input to the
workflow must already exist.

Step 3 To edit the workflow definition itself, click the Designer
tab By default, after creating a new workflow, the Code
view contains a dummy piece of code that you need to
replace with the actual developed workflow definition in
JSON format, based on the Serverless Workflow
Specification.

Step 4 After making your changes, you can:
test_workflow

Details Code

Workflow definition name* Version*

l test_workflow ‘ ” 1.0 “

* Back: Reject all the changes and go back to the
previous page.

» Delete: Remove the workflow definition from CWM.

+ Save Changes: Save the changes for the current
workflow definition.

* Save as new wor kflow: Createsa new workflow
definition with inserted changes and keep the
previously saved version of the workflow definition
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Initial setup |
. Workflow designer

Command or Action Purpose

(do not overwrite the changes on the same workflow
definition, but create a separate, new workflow
definition).

* Run: Execute the workflow definition as a single job.

Note
You can update the workflow definition and up-version it
without affecting the currently running job.

Workflow designer
With Designer, you can view a graphic representation of your workflow code.

To use the Designer, choose Design > Workflows, click on any workflow to see its details, then click the
Designer tab.

Details Designer

° No errors found when validating JSON

"functions": [ @

@© Allocate Prefixes

}

"operation":

Run Allocate Prefixes Workflow NSO

> Check Status

“name": " tconfPut",
“metadat

"worke .v1.0.1" © Defautt S{terminate == true}
}
“operation”: "cisco v1.0.1. restconf.Put’ © Sync From © Report on Web X

Sync From NSO Report Nso

"name": "NSO.RestconfDelete", O sykeiror
"metadat: { Z

"worke cisco.ns0.v1.0.1" © Cronta VN ()
} R
“operation" 5€0.ns0.v1.0.1.restconf.Dele Create VPN NSO

© Create VPNError

1,
“description"

"specVersion' @ Configure Endpoints

[— e

The Designer provides multiple viewing options for your workflow:
* View modes: Use the toggle buttons at the top to switch between:

* Code view: displays the workflow's code.
* Graph view: visualizes the workflow as a graph.

* Split view: shows both the code and graph side by side.

* Graph controls:

* Click the magnifying glass icons to zoom in or out.

* Enable dark mode by clicking the brush icon.
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Inside a node

Inside a node .

* Top-Right controls:

* Errors: Show or hide onErrors definitions.
» Compensation: Show or hide compensation actions.

* Validate definition: Check for syntax errors, missing required fields, and other issues in the workflow.

Successful validation is required in order to save the workflow definition.

Nodes are the visualized steps of a workflow. The main element of a node is the state. States are represented
inside state headers along with a label denoting the timeout defined for the particular state (if timeout is given):

L callback State

If an action is defined inside the state, it is displayed under the state header along with the name of the adapter
that is assigned to perform it:

Q callback State

Action with function REST

Cwm.forms.Test_dynamic_data

An event might be assigned to an action. In this case it will be represented by a green tag under the action
element.

If a child workflow is defined inside a state, it is displayed as an action element under the state header with
an icon:

® Operation State

Data conditions are represented as decision points, displayed along the arrows branching down from one
node to another within the tree. If a condition is marked as default, it will be shown inside a green label with
a green checkmark icon.
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. Bulk tags editing

© Reject

<> Switch State 2

Start © Reject

© Operation State
' Inject State

Bulk tags editing

You can edit Tags for many workflow definitions at once. You can also add one or more Tags to all selected
workflows or remove all Tags by resetting them.

Procedure

Command or Action Purpose

Step 1 In CWM, choose Design > Workflows.

Step 2 Select chosen workflows by checking the checkbox on the | workflows

left side of the Wor kflowstable, then click on the Edit tags

button.
Q Searc 7 matching results
B items selected  select All Cancel [ Edit tag

)

= Workflow definition narr  Workflow ID Version Description Workflow tag
test_workflow f8d1d263-7eed-4eaf-8f2c-ead78e7ab91 1.0
age e5c14f46-6485-4718-8c68-0146aa00608 1.0.0 Determine if applicant req
D Call Back Test ba32d8c9-eb56-419a-b7ef-2d5719655b1 1.0.0 Callback test workflow
C] vpn 71b78cd5-3e98-4cde-a21e-6170a2e@9ca 1.0
D Age checker a907c2bd-1f11-4e4c-b6d9-067e9234eb7 1.1
() Applicant Request Decisi 22e454f2-b4cb-4c85-96dc-c46b79d13c6 1.8.0 Determine if applicant req
[ Applicant 5d152db1-7899-4c36-92ac-5edcf73128a 1.0.0 Determine if applicant req

Rows |

Step 3 In the Edit tags window, under the Select action section, Add tagsto all: Assign one or more tags (separated
click on the chosen radio button, depending on whether you by a comma) to all selected workflows.
plan to add tags or reset them:

Reset tagsfor all: Remove all tags for selected
workflows.
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Bulk tags editing .

Command or Action

Purpose

Edit tags
Are you sure you want to edit tags for the selected workflow(s)?

Workflow(s)

Test workflow

Demo NSO workflow
Select action

@ Add tags to all
Tags *

[ new_tag| ]

O Reset tags for all

Cancel @
N

Step 4

Click Save.

You can see the result under the Wor kflow tags column.
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. Bulk tags editing
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Jobs

This section covers the following topics:

« Jobs, on page 31
* Run a Job, on page 31
* Schedule a job, on page 37

Jobs

After completing the instructions described in Initial setup chapter, you are ready to start executing workflows.

In CWM, a particular execution of a workflow definition is called a job. By following the guidelines in this
chapter, you can:

* Run a Job, on page 31 so that it starts immediately, or

* Schedule a job, on page 37 to run at one or more points in the future.

Run a Job

This topic explains how to run a job (workflow execution).

Before you begin

Ensure you have created a workflow definition and have uploaded one or more adapters with workers.

Procedure

Command or Action Purpose

Step 1 In CWM, choose Design > Workflows> Find the
workflow you want to execute and click Run under the
Actions column.
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. Run a Job

Jobs |

Command or Action Purpose
Step 2 In the Run job window, insert the initial workflow data
input in the I nput field.
Step 3 By default, your job’s name is the same as your workflow
definition, but you can change it in the Job name field.
Step 4 Optionally, you can assign tags to your job. To insert more | Note
than one tag, separate them with a comma. Tags are case-sensitive. Once added to the job, you cannot
edit them.
Step 5 Leave Run directly selected to run your job immediately.
If you want to create a schedule for a future run, follow the
steps in Schedule a job, on page 37.
Step 6 Click Run job to start the workflow execution. G
Runjob
General Workflow definition Workflow definition ID Workflow definition
name 12fb37a2-2cf8-41f6-  version
CreateL3VPN 968c-825afadce642 1.0
Job name*
[ CreateL3VPN
Tags
[ cisco, NSO
Log Level
Input Input*
{
"deviceOName": "ce0",
"devicelName": "cel",
"nsoResource": "NSOLocal"
} 4
Time Time*

W\ Cancel

@® Run directly

(O schedule for specific date and time

O cron
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Check job status

Procedure

Check job status .

Command or Action

Purpose

Step 1

In CWM, choose Operate > Jobs.

Step 2

In the Jobs table, find your job and check the status of the
workflow execution in the Status column.

* If the workflow was executed correctly, a green icon
and the status Completed is displayed.

« If the workflow execution is still in progress or the
workflow engine is retrying an action, a blue icon with
three dots and the status Running is displayed.

« If the workflow execution failed, a red icon and the
status Failed is displayed.

Check job result

You can check results for any failed or completed job.

Procedure

Command or Action

Purpose

Step 1 In CWM, choose Operate> Jobs

Step 2 In the Jobs table, find the job you want and click the job
name to view its details.

Step 3 To see basic information about the job, review the Job
summary tab at the top of the table.

Step 4 To check the input and result of the execution, click the | Click Copy to copy the contents of the Input or Results
Input and results tab in the middle of the table. panel to the clipboard.

Step 5 In Event history tab, you can expand each Wor kflow event | Click Copy to copy the contents of any Workflow event

entry by clicking on the arrow icon on the left-hand side.

panel to the clipboard. Or click Download to download the
entire event history as a JSON file.

Cisco Crosswork Workflow Manager 2.1 Operator Guide [JJj



. Find child workflow runs in Event History

Jobs |

Command or Action

Purpose

Event history

[ Q Search 33 matching results

Workflow event Duration

Start Time

v 33 WorkflowExecutionCompleted
O Copy
"data": {
"Data": {
"checkSyncResult@": "in-sync",
"checkSyncResult1": "in-sync",
"createServiceResult": 201,
"device@Name": "ce®",
"devicelName": "cel",
"nsoResource": "nsoResource"
}
i
}
1
h
"workflowTaskCompletedEventId": "32"
> 32 WorkflowTaskCompleted os

Find child workflow runs in Event History

If a given job run triggers child workflow executions, you can check them under the Event history log of the
parent run. Child workflow names are created using the following schema:

parent_job_run_name.child_workflow_def _name.child_workflow def version.

For example, if a parent job-run name happens to be parent, the child workflow definition name is child,
and the child workflow definition version is 1.0, the job run executed as a child workflow will be named

Parent.Child.1.0. .

Procedure

Command or Action

Purpose

Step 1

In CWM, choose Operate > Jobs

Step 2

In the Jobstable, find the parent job you want and click the
job name to view its details.

Step 3

In Event history, under the Workflow events column,
search for a childWorkflowExecutionStarted Or
ChildWorkflowExecutionCompleted entry. Click on its
event name; you will be redirected to the job details page
of this child workflow execution.

Step 4

On the child job's Details page, in addition to the standard
fields, you will find the Parent Run ID that redirects you
to the details of the parent job run.

Note
Child workflow runs do not inherit tags applied to their
parent job runs.
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| Jobs

Rerun job .

Rerun job

Procedure

Command or Action Purpose

Step 1 In CWM, choose Operate> Jobs.

Step 2 In the Jobstable, find the job that you want to rerun.

Step 3 Click the Rerun button in the Actions column in the same
row as the job you want to rerun.
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. Rerun job

Jobs |

Command or Action Purpose

Step 4 In the Rerun job window, you can edit the Job name, tags |
and I nput (data input) or use the same values as the .
previous run. Rerun job

Job name *

[ test workflow

Tags

[ cisco, update_device, NSO

Workflow definition name Workflow definition versi

test workflow 1.2

Workflow definition ID
656df887-81d4-4e1a-8e0b-ad1b75274ace

Input variables *

{

"deviceOName": "ce0"

"devicelName": "ce1",

"nsoResource": "NSOLocal"
1

When*
(® Start directly

() Schedule for specific date and time

() Cron

Step 5 Click Run jab.

You can also rerun the job from the job's Details tab.
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Cancel job .

Cancel job

Procedure

Command or Action Purpose

Step 1 In CWM, choose Operate> Jobs.

Step 2 Select the Activefilter at the top of the table, find a job that
you want to cancel and click the Cancel button in the same
row under the Actions column.

Step 3 In the Cancel job window, you can enter an optional
Reason for cancelling.

Step 4 Check the Forceter minate checkbox if you want to cancel |
the running job immediately. If you leave this checkbox
unticked, the workflow worker will complete the ongoing | A yeusurevouwantto cancel the selected job?

task execution from the workflow definition and then cancel | **™™'*""
the job age [ 4ee427d5-58e6-456c-be91-869805¢9b17

Cancel job

Reason

C] Force terminate

Cancel Cancel job,
L

Step 5 Click Cancel Job. You can also cancel the job from the job's Details tab.

Schedule a job

This topic explains how to schedule a single job run (workflow execution) or recurring runs that are invoked
in the future.

Before you begin

Ensure that you have added a workflow definition and listed it in the Workflows view, and uploaded one or
more adapters with workers.
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. Schedule a job

Procedure

Command or Action

Purpose

Write or paste in a cron string to generate

Step 1 In CWM, choose Design > Wor kflows.
Step 2 Select the workflow you want to schedule and click Run
under the Actions column.
Step 3 In the Run job window, insert the initial workflow data
input in the Input field. Each scheduled run of a workflow
receives identical input variables.
Step 4 By default, your job name is the same as your workflow
definition name, but you can change it in the Job name
field.
Step 5 Optionally, you can assign tags to your scheduled job(s).
To insert more than one tag, separate them with a comma.
All jobs in the schedule will have the same tags set.
Step 6 Choose one scheduling option depending on whether you * A) Schedulefor specific date and time: Pick a
planned a single run in the future or a recurring series of specific time and date for a single run.
runs:
* B) Cron: set recurring runs based on cron expressions
When * = When *
O Start directly e (O Start directly
@ Schedule for specific date and time O Schedule for specific date and time
Schedule ID*
[ My First Schedule @® cCron
Schedule ID*
Time Date [ My First Schedule
[ 05:15 €] ] [ Oct 27, 2023 ]
Cron*
O cCron [ 001%*
Step 7 Type a unique name for your schedule in the Schedule ID

field.
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Schedule a job .

Command or Action

Purpose

Step 8

Click Schedule Job to schedule the workflow execution(s).

Runjob

Job name *

[ Test cisco workflow

Tags

[ NSQ, cisco, update_device

Test cisco workflow 11

Workflow definition ID
8730bb23-a76b-40bf-9239-2052285f8a08

Input variables *

Workflow definition name Workflow definition v

T

"deviceOName": "ceQ",
"devicelName": "ce1",
"nsoResource": "NSOLocal"

When *
(O Start directly

(® Schedule for specific date and time

Schedule ID *

[ Test Schedule ]

Time Date

[ 06:06 ® ] [ Oct 29, 2023 ]
Note

Overlap policy: By default, the schedule overlap policy
prevents overlapping runs in one schedule. If the previous
job from a given schedule is still being executed while it's
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. Check scheduled jobs

Command or Action Purpose

time to start the next scheduled job, the next run will be
skipped. If you want to allow overlapping runs, you can
change the overlap policy via the APL

Check scheduled jobs

All schedule jobs are displayed in the Operate > Jobs window, under the Scheduled jobstab. When a
scheduled job is executed, it will be shown in the Activejobstab. When the job is completed, it will display
in the Completed jobs tab.

A schedule job does not have an expiration date. This means that you can update the scheduled job anytime
and retrieve some of its details. A scheduled job is displayed on the Scheduled job table even if it only one
job is scheduled for a specific date and time, and that job has already been executed. If you don’t want the
scheduled job to be displayed in the list of scheduled jobs, you must delete it.

Procedure

Command or Action Purpose

Step 1 In CWM, choose Operate > Jobs.
Step 2 Click the Scheduled jobstab at the top of the window.

Step 3 In the Scheduled jobstable, you can find all the schedule | Jobs
jobs, with details:

3 matching results

0 active (] 7 completed ° 3 scheduled © 14 c

[) scheduleld "2~ Job name Workflow Definition “~ Next scheduled run Type = Jobtags -

0O a0 CreateL3VPN CreateL3VPN 20-Mar-2025 88:18:60 PM CET  Specific date and time
[ fios3aze Configure Endpoints Configure Endpoints 18-Mar-2625 61:01:00 AM CET  Specific date and time

0O m Check applicant age Check applicant age 18-Mar-2625 11:61:86 AM CET  Specific date and time

+ A) Schedule I D: unique identifier for every schedule

* B) Job Name: name of the scheduled workflow
execution; shared between all runs in a schedule

* C) Workflow Definition: name of the workflow
definition used to run a scheduled job(s)

* D) Next scheduled run: the date and time of the next
upcoming run in the schedule, for example
05-May-2023 03:59:25 PM CEST

* E) Type: indicates whether the scheduled run is
planned once in the future (Specific date and time),
whether there are recurring runs (Cron) or recurring
runs based on frequency (Frequency).
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Delete scheduled jobs .

Command or Action Purpose
* F) Job tags: keyword(s) assigned to the scheduled job
run

* G) Workflow tags: keyword(s) assigned to the
workflow definition used for that planned run plus its
version

+ H) Actions: displays possible actions for the schedule.

Delete scheduled jobs

Deleting a scheduled job will delete all future planned jobs in that schedule, but will not affect a job that is
already in execution. You can cancel a scheduled job that is already being executed using the Cancel job, on
page 37 action.

Procedure

Command or Action Purpose

Step 1 In CWM, choose Operate> Jobs.

Step 2 Click the Scheduled jobstab at the top of the window.

Step 3 In the Scheduled Jobstable, find a scheduled job that you
want to delete and click the Deletebutton under the Actions
column in the same row as the job you want to delete.
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CHAPTER 4

Adapters

This section covers the following topics:

* Use the generic-email adapter, on page 43

* Add an SMTP secret, on page 43

* Add an SMTP resource, on page 44

* Define the Send activity in a workflow, on page 45

Use the generic-email adapter

The generic email adapter (generic-email) enables you to add email reporting into your workflows. The
adapter provides the ability to send emails using an SMTP server. For the latest adapter version, you can use
the send activity to send an email with a message defined inside the workflow definition.

You can get the generic email adapter by downloading the CWM package
cwm.v2.0.generic.email.v1.0.3.tar.gz from the Cisco Software Download page.

To install the adapter, follow the instructions in Install an adapter, on page 16.

Add an SMTP secret

Let's start by defining an SMTP secret.

Before you begin

Before going into the details of defining your email message inside a workflow, you need to add an SMTP
secret and resource to CWM. You will later need to reference them inside your workflow.

Procedure

Command or Action Purpose

Step 1 In CWM, choose Administration > Wor kflow
Administration > Secrets.

Step 2 In the Secrets view, click Add secret.
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. Add an SMTP resource

Adapters |

Command or Action

Purpose

Step 3 In the New secret view, provide the required input: * Secret | D: Name your secret. You'll need to reference
this secret ID later in the resource and inside the
workflow. E.g. emailsecret.

* Secret type: Select basicauth.
Step 4 After selecting the secret type, a set of additional fields is * Passwor d: Enter the password for the sender's email
displayed under the Secret type details section. Fill in the address.
fields with the following: . )
e Username: Enter the sender's email address, in the
following format: sender@address.com.
Step 5 Click the Create Secret button. You can edit the secret type and its details later.

Once you've added a secret and its details, create a resource
in and associate it with the secret, as explained in Add an
SMTP resource, on page 44.

Add an SMTP resource

Now we can create the resource.

Before you begin

Ensure that you have already created an email secret, as explained in Add an SMTP secret, on page 43

Procedure
Command or Action Purpose
Step 1 In CWM, choose Administration > Wor kflow
Administration > Resour ces.
Step 2 In the Resour ces view, click Add resource.
Step 3 In the New resour ce view, provide the required input: * Resource name: Name your resource. You'll need to
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provide the resource ID later inside the workflow as
a reference. For example: emailResource.

* Resourcetype: Select

generic.email.resource.v2.0.0.
« Connection:

» Host: Enter the URL or IP address of the SMTP
email server to be used.

* Port: Enter the outgoing SMTP port on the server.
The default outgoing SMTP port for encrypted
email transmission is 587. Port 465 is still
supported by some providers, 25 is supported for



| Adapters
Define the Send activity in a workflow .

Command or Action Purpose

SMTP relay, and 2525 is a popular alternative
when 587 is blocked.

* Scheme: Leave blank (it's not required for this
workflow).

* Timeout: Leave blank (it's not required for this
workflow).

» Allow insecure: Select true.

Step 4 Select a Secret ID from the drop-down menu to associate
a previously created secret with this resource.

Step 5 Click the Create resour ce button. Once created, your resource is displayed on the list in the
main Resources view.

Define the Send activity in a workflow

Once you've created the adapter, secret and resource, you can use it in a workflow.

Set activity reference

In CWM, the adapter send activity is referred to as generic.email.smtp.Send. When defining a workflow,
you need to specify it as the value of the operations parameter under functions:

"functions": [
{
"name": "smtp.send",
"operation": "generic.email.v2.0.0.smtp.Send"

}
]

Inside the name parameter, provide an activity name that you will later refer to in the re fName parameter while
defining the action.

Define email message in actions

Now you can define an action in which an email will be sent as part of a workflow state.

The available input parameters for the action are:

Field | Type | Label |Description

from | sting Sender email address

to string | repeated | List of recipient email addresses

cc string | repeated | List of recipient cc email addresses

bece | sting | repeated | List of recipient bee email addresses
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Define email message in actions

Field | Type | Label |Description

subject | sting Email title

text | sting Email body as text
html | sting Email body as html

Use the available fields as the input key/value pairs within the arguments that define the sendEmail example
action, as shown below:

"states": [

{

"name":"EmailState",

"type":"operation",
"end": true,
"actions": [
{
"name": "SendEmail",
"functionRef": {
"refName": "smtp.send",
"arguments": {
"input": {
"to": ["recipientl@address.com", "recipient2@address.com"],
"from": "sender@address.com",
"text": "Hello, this is some placeholder email text.",
"subject": "A test email from CWM"
}!
"config": {
"resourceId": "emailResource"
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CHAPTER 5

Guided tasks

This section covers the following topics:

* Forms and guided tasks, on page 47

* Forms list, on page 47

* Forms Designer, on page 48

* Dynamic data: Create a form with custom component values, on page 52
* Dynamic data example: Create a dry-run approval form, on page 53

* Use a form as workflow input, on page 55

* Guided task: Check an applicant's age, on page 56

* Guided task: Create an L3 VPN, on page 59

Forms and guided tasks

Forms list

Forms are customizable templates that are used to create what we can call guided tasks. These forms serve to
introduce an element of human intervention into an automated workflow. They are configurable using the
drag-and-drop Forms Designer in the CWM user interface. Forms can contain a number of different optional
input components (such as text, dropdowns, radio buttons, and checkboxes) and layout components (such as
tabs, columns, cards, HTML elements, and more).

With forms, you define what kind of input you want to include in your manual task and how it will be laid
out in the task prompt itself. Forms can be set to contain static form elements (set values) or dynamic data
elements (where values can be set using jq expressions).

Choose Design > Formsto access Forms view. Here, you can view, edit, export, and delete all the existing
forms, or access the Forms Designer by clicking Create form.

To export forms to a CSV file, check one or more of the check boxes shown next to the Form names in the
list and then click Export.
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. Forms Designer

Forms Designer

The Forms Designer is a user-friendly drag-and-drop editor accessible via the Formsin the CWM UL To
get started, simply click the Create form button. The designer consists of three main panels:

» Basic configuration: Here, you provide a name and a description for your form. Those are required
fields.

A

Note Important: The name you provide for your form determines the Form 1D that
you will need to provide inside your workflow. To retrieve the Form 1D, click
on the name of the newly added form in the forms list.

* Submit button: You can customize the Submit button label here. The button is automatically added to
every form you create.

« Form elements: This is where you design and preview your form.

Within the Form elementspanel, the Designer field is where you craft the input, structure, and visual layout

of your form.
Design > Forms
New form Back

Basic configuration  Form name*

[ Applicant age check ]

Form description*

[ This is a form description. ]
Submit button Submit button label*
Submit
Form elements
Designer ~
Search fiel(s) Drag and Drop a form component

Basic

>_ Text Field

Checkbox

The Forms Designer's components are grouped into four categories:

* Basic
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Input components .

» Advanced
* Layout

* Data

Input components

The Basic and Advanced categories contain customizable input components. Using those components you
can define how you would like to structure your task and what type of input(s) would be required to proceed.
It can be:

* text fields or areas,

* numbers,

* passwords,

» checkboxes or select boxes,

* drop-down lists (called selects in the UI),
« radio buttons,

* email fields,

* date and time fields, and

* signatures.
Inside a component

To add and customize a component, drag and drop it onto the blue rectangle inside the Designer field. A panel
will appear containing a few tabs and a Preview field.
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Text Field Component

Display Data Validation APl Conditional Preview

Label @ * Text Field

Text Field
Label Position @
Top - Cancel Remove
Placeholder @
Placeholder
Description @
1 Description for this field.
Tooltip @
1 To add a tooltip to this field, enter text here.
Widget ©
Input Field v

Tab Index @
0
Autocomplete @

on

Hidden @

» The Display tab is where you customize your input field. It features options like placeholder, description,
tooltip and others. Those options may differ depending on the type of component that you selected, but
there is one that is required:

* Labél: provide a name for the field that will appear next to it in the task prompt. The name you
provide in the the L abel field will be used for the Property Name field in the API tab of the
component.

* The Data tab allows you to add default values in the input and modify the way those values are handled.
This tab is available for selected components.

* The Validation tab features a number of options that you can use to enforce input rules for your
component:

* Required: ensures that input field will not be left empty before submission. The form will not
submit unless a value is provided.

* Minimum Length: Sets the minimum number of characters required in the input.
* Maximum Length: Limits the number of characters allowed in the input.
* Regular Expression Pattern — Uses a regex pattern to enforce specific formatting or constraints.

* Error Label — Specifies the label for this field when an error occurs.

*» The API tab features the Property Name field which you need to provide as the component name inside
your workflow.

* The Conditional tab lets you configure the behavior of the component in relation to the input provided
in any other component inside yur task prompt.

To edit an added component, hover over the component and click the cogwheel icon.
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Layout components

Use a Layout component to change the general layout and position of fields on a form. It allows you to add
logos, headers, or static contextual language to your form.

Data components

Data components are special components that are used to not only visually show the data being collected in
a data structured way, but will also change the data structure of the submissions being produced by the rendered

form.

Sample form

Layout components .

Let's create an advanced form with headlines, graphics, and data inputs that would allow the workflow operator
to validate or update specific VPN endpoint attributes in Cisco NSO.

aaaaaa

VPN details

VPN Name

Endpoints

Endpoint Id

Location

Device Name *

1P Network *

Capture Endpoint Details

se use the grid below to provide detals for each endpoint. Based on the location, provide the correct device wher

ote that all endpoints will be terminated on port GigabitEthernet0/2 for this demo

re endpoint should be deployed, and ipnetwork to be

Route Distinguisher

Go through the elements of the form one by one to see how you can set it up:

» Header : use the HTML element (L ayout tab). Type your title and provide the relevant HTML tag (h3

in the example).

* Image: use the HTML element (L ayout tab). Type img in the HTML tag field and use the Attributes
for defining image source, description, and other properties. Alternatively, provide your image address
inside the ing HTML tag in the Content field (for example: <img
src="https://your-image-url.com/image.jpg" alt="Description" width="300" > )

* Description: use the HTML element (L ayout tab). Provide your description. You may want to use
HTML formatting like </or></br> for better text layout.

* VPN details panel: use the Panel element (L ayout tab). It will serve as a container for other elements.

* Read-only VPN name and RD fields: use the Columns element (L ayout tab). Note that these
fields will be populated with workflow data and are therefore read-only.
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. Dynamic data: Create a form with custom component values

* VPN Namefield: use the Text field component. Label position is L eft-aligned in the example.
Check the Disabled box to make the field read-only. In the Data tab, click on Custom Default
Value and provide dynamic value for the field so that it can be populated by the workflow
input(value = form.dynamicData.input.vpnName)

* Route Distinguisher field: use the Number component. Label position is L eft-aligned in the
example. Check the Disabled box to make the field read-only. In the Data tab, provide dynamic
value for the field so that it can be populated by the workflow input (value =

form.dynamicData.input.rd)

» Endpoint information grid: Use the edit grid component (Data tab). Edit grid is for capturing
endpoint details, where you can view and edit information about endpoints. Note that the read-only
fields will be populated with workflow data, so be sure to provide dynamic value in the Custom
Default Value field of the Data tab inside the component (value =

form.dynamicData.input.endpoint}

 Endpoint 1d, Location, Bandwidth fields: use the Text field component. Label position is
Top in the example. Check the Disabled box to make the field read-only.

» Device name and | P Network: use the Text field component. Label position is Top in the
example. Keep the Disabled box unchecked so that the operator can pass the data once the
task is triggered. In the Validation tab, check the Required box.

To learn how you can use dynamic data in forms, see:

» Dynamic data: Create a form with custom component values, on page 52

* Dynamic data example: Create a dry-run approval form, on page 53

Dynamic data: Create a form with custom component values

You can use jq expressions to display data accessed by the workflow within a guided task, then filter or modify
the data before passing it to the task prompt.

One example might be populating the Select component options for a workflow with custom values by means
of form.dynamicData. Here is how you configure the use of dynamic data for this case when creating a form.

Procedure

Command or Action Purpose

Step 1 In Forms Designer, click Basic to expand it. From there,
drag and drop the Select component.

Step 2 Go to the Data tab and in Data Source Type, select
Custom.

Step 3 In the Custom values field, provide the following: values

= form.dynamicData.options;

Step 4 Click Save.
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Dynamic data example: Create a dry-run approval form .

Command or Action Purpose
Step 5 Now let's configure the workflow side of the dynamic data:
In your workflow definition, find the callback state.
Step 6 Inside the cal1back state, add the metadata key. Then,
inside it, add formpata and provide a value in the following
format: "${ { options : .options } }".
Step 7 A sample workflow with the dynamic data part configured { o
may look like this: name®: "decision®,
"type": "callback",
"action": {
"name": "decision point",
"actionDataFilter": {
"toStateData": "${ .result }"
}
} 4
"eventRef": "cwm.forms.Options",
"metadata": {
"formData": "${ { options : .options
POty
"taskName": "Select option"
} 4
}
Step 8 To provide the option labels and values for the Select o
component, use the Input when running the workflow: Opt?OHS o
"label": "First option",
"value": "Valuel"
} 4
{
"label": "Second option",
"value": "Value2"

}

Dynamic data example: Create a dry-run approval form

You can use jq expressions to display data accessed by the workflow within a guided task, then filter or modify

the data before passing it to the task prompt.

Here's an example: Let's say we want to retrieve the dry run of a network configuration change in Cisco NSO
and present its payload for approval or rejection by a network operator. The following steps show how to use
dynamic data when creating a form to use in this case.

Procedure

Command or Action

Purpose

Step 1

In FormsDesigner, click L ayout to expand it. From there,
drag and drop the HTML element component.

Cisco Crosswork Workflow Manager 2.1 Operator Guide [JJj


https://jqlang.org/manual/

. Dynamic data example: Create a dry-run approval form

Guided tasks |

Command or Action Purpose
Step 2 In the Content field, provide the jq expression inside the | Note
code brackets, for example: <code>${ .dryrunPre The expression begins with a $ and is enclosed in curly
}</code>. brackets. The text inside the brackets can be custom, but
it needs to be a jq expression. You will later reference it
in the workflow definition and the input from the workflow
will be presented inside the HTML element once the task
is prompted. For more about how to build jq expressions,
refer to the jq manual.
Step 3 Click Save.
Step 4 Now let's configure the workflow side of the dynamic data:
In your workflow definition, find the callback state.
Step 5 Inside the cal1back state, add the metadata key. Then, Note
inside it, add formpata and provide a value in the following | Note that dryrunpre refers to the expression defined within
format: "${ { dryrunPre : .result.data } }". the HTML element inside the form, whereas the other part
refers to the value of the tostatepata key inside
actionDataFilter.Inthjscase,actionDataFilter
handles and filters the payload provided by NSO during
the execution of a dry run for the Create L 3V PN operation.
Be sure to customize the provided example according to
your specific use case.
Step 6 A sample workflow with the dynamic data part configured | ¢

may look like this:

"name": "decision",
"type": "callback",
"action": {
"name": "show-dry-run",
"actionDataFilter": {
"toStateData": "${ .result }"
}
}I
"eventRef": "cwm.forms.NSO dry run",
"metadata": {
"formData": "${ { dryrunPre : .result.data
Py
"taskName": "Create L3VPN with dry run"

}I
}
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Use a form as workflow input .

Command or Action

Purpose

Step 7

Once you start the workflow and the task is invoked, you
will see the payload presented inside the prompt.

Dry run result

{"dry-run-result":{"cli":{"local-node":{"data":" devices {
device ced {
config {
+ policy-map Test11l {
+ class class-default {
+ shape {
+ average {
+ bit-rate 10000;
+ }
+ }
+ }
+ }

interface {
GigabitEthernet 0/2 {

Use a form as workflow input

Useform asinput is an option that allows you to provide initial input for a workflow by selecting a prebuilt
form instead of manually entering JSON data. It helps to standardize input collection by providing a structured

interface for initial workflow data.
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Design > Workflows

Create Workflow © valid

Details Designer

Details Workflow definition name*

[ test_workflow ]

Version*

(10 )
Tags

Description

[ )

Use form as input

[ not set

Device Out Of Sync
NSO dry run

Capture Endpoint Details

Oomin. oo

To use this option, select the Use form asinput option when creating a workflow and choose an existing
form. When running the workflow, you will be able to submit data so that it is automatically mapped to the
workflow’s input, ensuring consistency and reducing manual errors.

Guided task: Check an applicant's age

About this example
In this example, we create a simple employment application form that check's an applicant's age.

Click here to download and extract the Check Age Workflow file, including the JSON form file.

Step 1: Create a form

There are two ways you can create a form in CWM. To create the form without For ms Designer, use the
posT/form API endpoint to send a JSON object that defines the form schema. The other option is to use the
CWM user interface and create the form in a step-by-step process. Follow the steps below to create the form
using the user interface.

1. In CWM, select Design > Forms, then click Create form.
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Guided task: Check an applicant's age .

2. In Basic configuration, enter:
* Form name: type check applicant age.
« Submit button: A label for the Submit button.

* Description: A short description, such as "Applicant form".

Step 2: Add Number component
The number component will add a field in the guided task that the operator will use to type the applicant age.

1. In Form elements, click the Designer to expand it.

2. In Basic components, locate the Number component and drag and drop it onto the blue rectangle in the
center space. This will open a new dialog.

3. nthe Labdl field, change the default name to Provide applicant age:.

A\

Note In the API tab of the component, you'll find the Property name which will be needed later when defining
the task on the workflow side.

4. Click Saveto create the component.

Step 3: Define a task in the workflow

After you create a form, you can proceed to define how it will be employed by the workflow. The workflow
that will serve as an example consists in a simple action: checking applicant age using the guided task feature
and then rejecting or accepting an application based on the provided input. In the workflow definition, let's
start by setting up the events parameter with the data of the form we created.

"events": [
{
"kind": "consumed",
"name": "cwm.forms.Check applicant age",
"type": "cwm.forms.Check applicant age",
"source": "system.internal.cwm"

}
] 4

The key values here are:

* kind: The event is consumed, since the input provided in the task is treated as external and will be
consumed by the workflow.

* name: It's the Form I D which you can find in the form details when selecting it from the Forms list.
* type: It takes the same value as the name key.

* source: It needs to be system. internal.cwn as the source

Next, we want to enter a callback state into the workflow and refer to the event (the form ID) that it will use
to invoke the task.

"states": [

{
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Guided task: Check an applicant's age

"name": "start",
"type": "callback",
"action": {
"name": "no operation",
"functionRef": {
"refName": "noop",
"arguments": {}
}
}I
"eventRef": "cwm.forms.Check applicant_age",
"metadata": {
"formData": "${ {user : .user} }",
"taskName": "Provide applicant age"
}I
"timeouts": {
"eventTimeout": "PT158",
"stateExecTimeout": "PT15M",
"actionExecTimeout": "PT153"

}I

"transition": "evaluate"

}I

]

The callback state requires the action parameter to be stated. The name and functionref keys need to have
values provided even if no action is expected to happen during this state. Therefore, a mock action needs to
be provided. For this, you can use a utility function, like noop, or any activity of your custom adapter, but
keep in mind that the action needs to complete successfully for the workflow to pass to another step.

The key values here are:
* eventRef: provide the ID of the form.
* taskName: this can be an arbitrary name that refers to the task.
The next state in the example workflow is a switch state. It is where you provide conditions for the task input.

If the age of the applicant is stated to be under 18, the application is rejected. If it is 18 or more, the application
is approved.

{

"name": "evaluate",
"type": "switch",
"dataConditions": [
{
"name": "adult",
"condition": "${ .provideApplicantAge = 18 }",
"transition": "approve"
}7
{
"name": "underage",
"condition": "${ .provideApplicantAge 18 }",
"transition": "reject"
}
]7
"defaultCondition": {
"transition": "reject"

}
}7

The key value here is condition. Here is where you refer to the Property name of the component that you
can find under the API tab inside the component. The component property name needs to be referred to inside
a jq expression that starts with s. The condition is stated in form of an inequality: .provideApplicantAge =
18.
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Guided task: Create an L3 VPN .

The last two states would be the inject states where the workflow either accepts or rejects the application and
prints the result in the job execution logs.

{

"end": true,

"data": {
"application": "approved"
}I
"name": "approve",
"type": "inject"

"end": true,

"data": {
"application": "rejected"
}I
"name": "reject",
"type": "inject"

Step 3: Run the workflow and submit task

If you have created a workflow definition based on the example, you may want to test it against the system.
To do that, follow the steps below.

1.

In CWM, choose Design > Wor kflows.

Click Create wor kflow, provide a Wor kflow definition name and Version for the new workflow, and
click Create.

Click the Designer tab and, in the Code tab, paste your workflow definition. Click Save.

Find your workflow in the list of workflow definitions, enter it and click Run. In the dialog, click Run
job.

Choose Wor kflow Automation > Operate > Tasks and look for the Applicant age check task (or
whatever custom name you assigned to this task).

Click the task, provide input (in this example, it will be a number) in the field and click Submit.
The workflow will process the input given in the task and finish execution.

You can see the result by selecting to Wor kflow Automation > Operate> Jobsand looking up the logs
of your job.

Guided task: Create an L3 VPN

About this example

To complete and test the following example, you will need to have a running instance of Cisco Network
Service Orchestrator (NSO).

This example creates an L3 VPN with the given parameters in Cisco NSO. Before executing the operation,
CWM performs a dry run to simulate the configuration. During execution, the dry-run payload is displayed
in the task prompt, allowing the user to either accept or reject the operation based on the previewed results.

Click here to download and extract the Create NSO L3VPN file, including the JSON form file.
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. Guided task: Create an L3 VPN

Step 1: Create a form

For the purpose of this example, we will focus on creating the example form using the posT/form API endpoint.
1. Go tothe CWM API in Postman and use the posT/form endpoint.

2. Copy the content of the JSON form file from the download and paste it into the request field.

3. Click Send. The form has been created in CWM.

Step 2: Define task in the workflow

Let's see how the task that will employ the created form is defined inside the workflow definition. In the
workflow definition, let's start by setting up the events parameter with the data of the form we created.

"events": [
{
"kind": "consumed",
"name": "cwm.forms.NSO_dry run",
"type": "cwm.forms.NSO dry run",
"source": "system.internal.cwn"

}
1y

The key values here are:

* kind: The event is consumed, since the input provided in the task is treated as external and will be
consumed by the workflow.

* name: It's the Form I D which you can find in the form details when selecting it from the Forms list.
* type: It takes the same value as the name key.

* source: It needs to be system. internal.cwn as the source.

Next, we want to include the callback state into the workflow and refer to the event (the form ID) that it will
use to invoke the task. For this, we need to add the eventref key and its accompanying metadata: formbata,
where you refer to the variable used to retrieve the result of the dry run operation.

Note that inside the callback state, we need to state the action parameter. Inside the functionref key we
state refName and give the name of the NSO adapter activity there: NSO. restconfPost.

"states": [
{
"name": "decision",
"type": "callback",
"action": {
"name": "show-dry-run",
"functionRef": {
"refName": "NSO.restconfPost",
"arguments": {
"input": {
"data": {
"13vpn": [
{
"name": "${ .vpnName }",
"endpoint": "${ [range ( .endpoint | length) as $i
| {id: .endpoint[$i].name,
\"ce-device\":.endpoint[$i].device, \"ce-interface\":\"GigabitEthernet0/2\" ,
\"ip-network\":.endpoint[$i].ipNetwork,
bandwidth: .endpoint[$i].bandwidth, \"as-number\":65002 }] }",
"route-distinguisher": "${ .rd }"
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Guided task: Create an L3 VPN .

}I

"path": "restconf/data/13vpn:vpn",
"queries": {
"additional": {
"dry-run": "cli"
}
}
}I
"config": {
"resourceId": "${ .nsoResource }"
}
}
}I
"actionDataFilter": {
"toStateData": "${ .result }"
}
}I
"eventRef": "cwm.forms.NSO_dry run",
"metadata": {
"formData": "${ { dryrunPre : .result.data } }",
"taskName": "Approve/reject dry run operation"

}I
}I

The key values here are:
* eventRef: provide the ID of the form.
* metadata: use this key to decide what data will be presented in the task:

* formData: build a jq expression to make the dry run result appear inside the task prompt. Note that
the first element of the expression, dryrunPre, is what is provided in the HTML component in the
form so that whatever the dry run result is, it will be displayed in the task. The other element is the
part of the expression that specifies what data exactly is to be shown out of the whole payload of
the dry run operation collected by the tostatebata key inside actionDataFilter.

* taskName: this can be an arbitrary name that refers to the task.

The next state in the example workflow is a Switch state. It is where you provide conditions for the task input.
If the configuration shown by the dry run result is correct, the operator approves the operation. If it is not
correct, the operator rejects the change.

"name": "evaluate-decision",
"type": "switch",
"dataConditions": [
{
"name": "start-application",
"condition": "${ .approve == true }",
"transition": "commit-service"
}l
{
"name": "reject-application",
"condition": "${ .approve == false}",
"transition": "abandon-service"
}
]l
"defaultCondition": {
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"transition": "abandon-service"

}

The key value here is condition. Here is where you refer to the Property name of the component that you
can find under the API tab inside the component. The component property name needs to be referred to inside
a jq expression that starts with s. The condition is stated in form of an equality: .approve == true.

The last two states would be the operation states where the workflow either creates the VPN or rejects the
operation and prints the result in the job execution logs.

Step 3: Run workflow and submit task
If you have created a workflow definition based on the example, you will want to test it against the system.
1. In CWM, choose Design > Wor kflows.

Click Create wor kflow, provide a Wor kflow definition name and Version for the new workflow, and
click Create.

Click the Designer tab and, in the Code tab, paste your workflow definition. Click Save.

2. Find your workflow in the list of workflow definitions, enter it and click Run. In the dialog, click Run
job.

3. Choose Operate> Tasks and look for the Approve/reject dry run operation task (or whatever custom
name you assigned to this task).

4. Click the task, provide your signature and click Approve.

The workflow will process the input given in the task and finish execution. To see the result, choose
Workflow Automation > Operate > Jobs and look up the logs of your job.
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