
Configure MPLS Routing

This chapter describes how Cisco Crosswork Planning configures MPLS routing. All LSPs other than SR
(segment routed) LSPs are routed like RSVP LSPs. For MPLS simulation information specific to these types
of LSPs, see Configure RSVP-TE Routing and Configure Segment Routing.

• LSPs are established under normal operation: that is, with failures not taken into account.

• Any LSPs that are affected by the failures are rerouted. Depending on the LSP path settings, reroutes
might involve moving to a secondary path, dynamically rerouting the LSPs, or rerouting based on a
segment list.

• Demands are routed using the established LSPs using the specified IGP protocols given the specified
failure scenarios.

• LSP utilizations are calculated from the demand traffic using the specified traffic level.

This section contains the following topics:

• Supported LSP types, on page 1
• Create and visualize LSPs, on page 2
• LSP paths, on page 3
• Route demands through LSPs, on page 5
• Set global simulation parameters, on page 11
• Troubleshoot LSP simulation, on page 12

Supported LSP types
Cisco Crosswork Planning supports the following LSP types:

• SR LSPs—Segment Routing LSPs, which do not use RSVP for routing. You can create SR LSPs using
the Cisco Crosswork Planning UI. They are identified with aType property of SR. For more information,
see Configure Segment Routing.

• RSVP LSPs—LSPs that are established through RSVP. These are commonly known asMPLS TE tunnels.
Cisco Crosswork Planning discovers RSVPLSPs, and you can also create them using the Cisco Crosswork
Planning UI. They are identified with a Type property of RSVP. For more information, see Configure
RSVP-TE Routing.
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Cisco Crosswork Planning does not model LDP tunnels as LSPs.Note

Create and visualize LSPs
To simulate MPLS LSPs in the network, you must first set up the LSPs to be routed. Follow these steps to
create and visualize LSPs in the Cisco Crosswork Planning UI.

Procedure

Step 1 Open the plan file (see Open plan files). It opens in the Network Design page.
Step 2 From the toolbar, choose Actions > Insert > LSPs > LSP

OR

In the Network Summary panel on the right side, click > LSPs in the LSPs tab.

The LSPs tab is available under the More tab. If it is not visible, then click the Show/hide tables icon ( ) and check
the LSPs check box.

Step 3 Choose the Type, which determines whether this is an RSVP LSP or an SR LSP.
Step 4 In the Name field, enter the name of the LSP.
Step 5 Select the Active or FRR enabled check box.
Step 6 Expand the Source & destination panel. Choose the appropriate source and destination site and node details.
Step 7 (Optional) Expand the other panels (Routing, CSPF, and Other) and enter the relevant parameters.
Step 8 Click Save.
Step 9 To visualize the LSP in the network plot, select the LSP from the LSPs table. They appear in the plot as a purple arrow.

Figure 1: LSP visualization

You can also add a mesh of LSPs between the selected nodes using any of the following options:

• From the toolbar, choose Actions > Insert > LSPs > LSP mesh

• In the Network Summary panel on the right side, click > LSP mesh in the LSPs tab.

You can filter to related information, such as related interfaces, source and destination nodes, demands, or
LSP paths. To do this, select the LSP, click theCross table filter icon ( ), and choose the appropriate option.
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LSP paths
LSPs can be assigned one or more LSP paths. Like LSPs, LSP paths have properties that vary depending on
whether the path is for an RSVP LSP or SR LSP. If these properties are omitted, then they are inherited from
the LSP. If these properties are set in the LSP path, they override the LSP settings. For information on these
properties, see Configure RSVP-TE Routing and Configure Segment Routing.

Path options and active path
Each LSP path has a Path option property in the Add/Edit LSP Path window. The LSP is routed using the
first LSP path that can successfully be established. LSP paths are established in increasing order of their path
option, where path option 1 is established first.

Alternatively, in the Active path field under the Routing section (Add/Edit LSP page), you can enter which
LSP path to use.

Create LSP paths
To create LSP paths, do the following:

Procedure

Step 1 Open the plan file (see Open plan files). It opens in the Network Design page.
Step 2 In the Network Summary panel on the right side, from the LSPs table, choose the LSPs to which you are adding LSP

paths.

Step 3 From the toolbar, choose Actions > Insert > LSPs > LSP Paths, or click in the LSP Paths table.

The Insert LSP Path window appears.

Step 4 If you are satisfied with the LSPs that you selected in Step 2, click Next. Make changes to the selection, if required.
Step 5 In the Path option field, enter the order in which the LSP path is activated. Lower numbers have preference over higher

numbers.
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Step 6 If you are creating an LSP path from SR LSPs, proceed to Step 7. If this is an RSVP LSP path, optionally set these
properties. For information on these properties, see Configure RSVP-TE Routing.
a) To set the bandwidth, specify the Setup Bandwidth for the LSP path, or specify that it should inherit the bandwidth

from the LSP.
b) To create associated named paths, check this option and complete the name using $1 for the LSP name and $2 for

the path option.
c) If this is a standby LSP path, check Standby, which ensures the paths are always active.

Step 7 Click Next.
Step 8 Make the required changes in the Affinities page to associate the LSP path with affinities.

a. For each rule (Include, Include any, Exclude), choose whether the LSP path should inherit the LSP affinity rule or
whether it should be based on rules defined in the table below these options.

b. If you chose to use the table, choose the rule for each affinity you are associating with the LSP path.

Step 9 Click Submit.

Path latency calculations
Cisco Crosswork Planning calculates shortest latency paths for LSPs and demands as follows:
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• By default, Cisco Crosswork Planning uses the shortest path from the source to the destination of the
LSP or demand, where the weight on each interface is the delay value for that interface.

• If the delay for any interface is zero (as it is by default), a small (0.00001 ms) delay is used instead. This
means that if all the delays for the interfaces in the plan are zero, the path with the smallest number of
hops is selected.

• If two paths have the same latency, paths with the smaller number of hops are preferred.

Route demands through LSPs

Route demands through intra-area LSPs
Intra-area LSPs are modeled as IGP shortcuts. That is, the source of the demand using the LSP can be a node
other than the ingress node into the IGP, and the destination node of the LSP can be a node other than the
egress node from the IGP. A demand through intra-area LSPs does not require the LSP to traverse the full
demand path.

Each intra-area LSP has a metric that helps determine which traffic is routed through the LSP. By default,
autoroute LSPs have a metric equal to the shortest IGP distance from the source to the destination. However,
you can configure static metrics for these LSPs that override this default. Static metrics can also be defined
as relative to the shortest IGP distance, but these relative metrics are not currently supported in Cisco Crosswork
Planning.

Forwarding adjacency LSPs always have a metric. If not specified, the default is 10. Forwarding adjacency
LSP metrics are injected into the IGP so that nodes other than the source node of the LSP are aware of the
path length through the forwarding adjacency LSP, and use it in their shortest path calculations.

To edit Autoroute and Forwarding adjacency (FA) settings, choose one or more LSPs from the LSP table,

click to open the Edit window, and edit the values in the Routing section.

Inter-area LSPs
Because it is not possible to define metrics distances across ISP areas, there can be no well-defined metric
for inter-area LSPs. Therefore, in Cisco Crosswork Planning, a demand only routes through an inter-area LSP
if the demand’s endpoints are nodes matching the source and destination of the LSP, interfaces on these nodes,
or external ASes whose ingress and egress points through the IGP are these nodes. This requirement is true
regardless of the network option settings.

To be routed, these demands must also match the privacy requirements. Autoroute, Forwarding adjacency
(FA) properties, and LSPmetrics are ignored. For information on privacy, see Route demands through specific
LSPs (Private LSPs), on page 6.

Routing inter-area LSPs
In Cisco Crosswork Planning, all nodes in a single AS are assumed to belong to a single IGP. If the plan file
contains more than one AS, all IGPs defined in these ASes are of the same type. For information on how
nodes are assigned to areas or levels, see Simulate Traffic Flow from Source to Destination Using Demands.
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An inter-area LSP is an LSP whose source node and destination node have no areas in common. If available,
inter-area LSPs follow actual paths, regardless of whether doing so violates the required order of routing
through areas. For example, if following an actual path, an inter-area can enter and leave an OSPF area 0 more
than once.

Other factors that determine how the inter-area LSPs are routed include whether the LSP type is RSVP or SR,
and whether you have selected to require explicit hops at ABRs. (See Explicit versus dynamic inter-area LSP
routing, on page 6.)

Inter-area Fast Reroute LSPs and inter-area IGP shortcut LSPs are not supported. If the source and destination
nodes of a Fast Route LSP are in different areas, the LSP is not routed.

Note

Order of routing through areas

Regardless of the LSP type and whether explicit hops are required, inter-area LSPs route through the backbone
areas, as follows, where “backbone” means area 0 for OSPF or the Level 2 area for IS-IS.

• If there are three or more areas, backbone areas must be between the source and destination nodes.
Typically, there are no more than three areas and therefore, the backbone area must be in the middle.
For example, an OSPF inter-area LSP would route from area 1 to area 0 (backbone) and then to area 2.

• If there are only two areas, there can only be one backbone area, and either the source or the destination
node must be in the backbone area.

Explicit versus dynamic inter-area LSP routing

An OSPF ABR is a node that belongs to both area 0 and other OSPF areas. An IS-IS ABR is a node that
belongs to both the Level 2 area and another IS-IS level.

There are two modes of routing inter-area LSPs. One requires that explicit hops be set on ABR nodes. This
mode correctly simulates actual router behavior where ABR explicit hops are required. The other mode does
not require explicit hops at ABR nodes and can route an LSP fully dynamically across multiple areas. While
this mode does not simulate actual router behavior, it is useful for planning inter-area LSP routes. These modes
are specified using the network option labeled LSP routing requires ABR explicit hops under the Label
switched paths section.

If this option is selected, inter-area LSPs are routed based on explicit hops set on the ABR nodes.

• An inter-area RSVP LSP must contain a named path, and the named path must contain explicit hops at
ABRs for each required area crossing.

• An inter-area SR LSP must contain a segment list, and the segment list must contain explicit node hops
at ABRs for each required area crossing.

If this option is not selected, inter-area LSPs are routed dynamically and explicit hops at ABRs are not required.
To leave one area and enter another, the inter-area LSP routes to the closest ABR in the current area that also
borders the area it is entering.

Route demands through specific LSPs (Private LSPs)
Cisco Crosswork Planning provides two ways to route selected traffic demands through specific LSPs. One
way is to dedicate the traffic for specific demands to a private LSP, which is a special LSP that carries those
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demands only. This type of LSPmodels anMPLS Layer 2 VPN, providing an exclusive route for the associated
demands. If the LSP goes down, all traffic associated with the LSP is interrupted.

To configure LSPs that simulate Layer 2 VPNs, use one of these two tools.

• One tool creates dedicated demands for existing LSPs. The created demands will match the LSPs in
source and destination. For details, see Create private demands for existing LSPs, on page 7.

• One tool creates private LSPs from existing demands. The created LSPs will match the existing demands
in source and destination. For details, see Create private LSPs for demands, on page 8.

The LSP Private column is set to true in the LSPs table, and the Private LSP Name and Private LSP Source
columns in the Demands table are set.

Create private demands for existing LSPs

Before you begin

Ensure that LSPs currently exist in the network model.

To create private demands for existing LSPs, do the following:

Procedure

Step 1 Open the plan file (see Open plan files). It opens in the Network Design page.
Step 2 From the toolbar, choose Actions > Insert > LSPs > Demands for LSPs.

OR

In the Network Summary panel on the right side, click > Demands for LSPs in the LSPs tab.

The LSPs tab may be available under the More tab. If it is not visible, then click the Show/hide tables icon ( ) and
check the LSPs check box.
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Figure 2: Create demand for LSPs page

Step 3 From the LSPs list, select the LSPs for which you want to create demands.
Step 4 Select the service class to which these LSPs belong.
Step 5 Set the demand traffic to equal the LSP setup bandwidth, the LSP traffic measurements, or zero.
Step 6 Check the Mark LSPs as private check box.
Step 7 Click Submit. The newly created demands are highlighted in the Demands table.

Create private LSPs for demands

Before you begin

Ensure that demands currently exist in the plan file. See Simulate Traffic Flow from Source to Destination
Using Demands.

To create private LSPs for demands, do the following:

Procedure

Step 1 Open the plan file (see Open plan files). It opens in the Network Design page.
Step 2 From the toolbar, choose Actions > Insert > LSPs > LSPs for demands.
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OR

In the Network Summary panel on the right side, click > LSPs for demands in the LSPs tab.

The LSPs tab may be available under the More tab. If it is not visible, then click the Show/hide tables icon ( ) and
check the LSPs check box.

Figure 3: Demands selection page

Step 3 In the list of demands, select the demands for which you want to create LSPs.
Step 4 Set the bandwidth traffic to a specific demand traffic or to zero.
Step 5 Check the Mark LSPs as private check box.
Step 6 Click Submit. The newly created LSPs are highlighted in the LSPs table.

Delete demands when deleting private LSPs
You can choose to delete a demand when deleting a Private LSP. By default, when a private LSP is deleted,
the corresponding demand is not deleted.

Procedure

Step 1 Open the plan file (see Open plan files). It opens in the Network Design page.
Step 2 In the toolbar, click Network options or choose Actions > Edit > Network options.
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The Network options page opens.

Step 3 Click the Advanced tab.
Step 4 In the Demands section, ensure that these check boxes are checked.

• Unrouted if the private LSPs are unrouted

• Removed if the private LSPs are removed

Step 5 Click Save.

Load sharing between LSPs
Two or more LSPs with the same source and destination (and metrics, if these are defined) loadshare traffic
between them. How the load is shared between the LSPs is determined by the LSP Loadshare property. By
default, LSPs have a Loadshare property of 1, and thus route traffic between them in equal proportions.
Changing the Loadshare value changes the distribution of LSP traffic and interface traffic in proportion to
these values.

Example: If two LSPs are parallel, and one has a Loadshare property of 2 and one has a Loadshare property
of 1, there will be a 2-to-1 ratio of traffic shared between them. The top half of Figure 4: Examples of two
parallel LSPs with equal loadsharing and 2:1 loadsharing, on page 11 shows an example of two parallel LSPs
that are routed using strict explicit paths. Each has a Loadshare value of 1, which means the traffic is routed
using a 1:1 loadshare ratio so that each LSP carries 50% of the traffic. In contrast, the lower half shows the
same parallel LSPs with a 2:1 ratio. That is, one LSP has a Loadshare value of 2, and one has a Loadshare
property value of 1. The LSP with a Loadshare value of 2 carries 66% of the traffic, while the other carries
33%.

Each LSP has a path showing the percentage of traffic that crosses the LSP as a result of the Loadshare value
for that LSP. The format is <path option> :<loadshare percentage>. Although loadshare applies only to path
option 1, the LSP itself might be routed along a different path.

Note that this percentagemay or may not be the same as the Loadshare value in the LSPs table. This is because
the Loadshare value is relative to the other Loadshare values for parallel LSPs. For this reason, if manually
editing the Loadshare property, we recommend that you consider the entire set of parallel LSPs. Note also
that because an LSP can be in multiple sets of parallel LSPs, the percentage on its path can differ.

To optimize these Loadshare values, use the LSP Loadshare Optimization tool. For information, see Optimize
LSP loadshare .
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Figure 4: Examples of two parallel LSPs with equal loadsharing and 2:1 loadsharing

Set global simulation parameters
Cisco Crosswork Planning lets you set global parameters that affect how LSPs are routed or rerouted. To
access these options, click Network options or choose Actions > Edit > Network options in the toolbar.
Then, click the Simulation tab.
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By default, Cisco Crosswork Planning simulates the state of the network once it has fully responded to a
failure. Specifically, this is the network state after LSPs have re-established new routes around the failure,
and the IGP has fully reconverged. This is called the IGP and LSP reconvergence simulation mode.

Other simulation modes include Fast reroute (FRR), Autobandwidth convergence, and Autobandwidth
convergence (including failures). For information, see Configure RSVP-TE Routing.

The Optimization tools only work in IGP and LSP reconvergence mode. If you try to run one while in a
different convergence mode, you are prompted whether to continue, and if you do, the simulation changes to
IGP and LSP reconvergence mode.

Set LSP establishment order
Cisco Crosswork Planning establishes LSPs in the order in which they appear in the plan. The routing of a
specific LSP might depend on previously established LSP routes. You can modify this order by changing a
random seed. Cisco Crosswork Planning then establishes LSPs in a random order that is determined by this
number. Although you cannot predict the order based on the number, if you use the same number multiple
times, Cisco Crosswork Planning establishes the LSPs in the same order each time. Varying the LSP
establishment order lets you check, for example, whether certain orders result in higher utilizations.

Procedure

Step 1 In the toolbar, click Network options or choose Actions > Edit > Network options.

The Network options page opens.

Step 2 In the Label switched paths section under the Simulation tab, enter a number in the LSP establishment order seed
field. The default is 0.

Step 3 Click Save.

Troubleshoot LSP simulation
To help troubleshoot RSVP LSP and LSP path simulations, Cisco Crosswork Planning analyzes simulation
routes and provides reasons for certain types of routing behavior. The simulation diagnostics tool identifies
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why an LSP is not routed, why an LSP is routed away from its actual path, and why an LSP is not following
the shortest TE path.

These routing diagnostics assume that all other LSPs, except for the one being tested, have been routed. That
is, Cisco Crosswork Planning calculates whether an LSP can route on the actual path after all other routed
LSPs have had their bandwidth reserved.

Note that running a report overwrites the previous report of the same type. For example, an LSPs diagnostic
report would overwrite the previous LSPs report, but not the LSP path diagnostic report.

Run LSP simulation diagnostics
To run LSP simulation diagnostics, do the following:

Procedure

Step 1 Open the plan file (see Open plan files). It opens in the Network Design page.
Step 2 From the toolbar, choose Actions > Tools > Diagnostics > LSP simulation or LSP path simulation.
Step 3 Select the LSPs or the LSP paths you want to optimize.
Step 4 Click Submit.

A diagnostic report is automatically generated. You can access this report at any time by choosing Actions > Reports >
Generated reports, and then clicking the LSP Routing Diagnostics or LSP Path Routing Diagnostics link in the right
panel.

What to do next

See Use simulation diagnostics to troubleshoot, on page 13.

Use simulation diagnostics to troubleshoot
The following information is provided to help you troubleshoot LSP and LSP path issues.

DescriptionReason

The affinity settings prevent the LSP or LSP path from routing.Affinities

There is insufficient bandwidth to route the LSP or LSP path.Available BW

The route is determined by a named path that contains one or more explicit hops.Explicit Hops

The hop limit is too low.Hop Limit

The actual path is invalid and cannot be interpreted as an LSP route.InvalidActual Path

The LSP does not have an actual path.No Actual Path

The LSP path is not routed because it is not a standby path and it is not the lowest
routable path option for the LSP.

No Attempt
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DescriptionReason

There is no destination defined. The collected network might not contain the destination
node of the LSP.

No Destination

The simulation option for following actual paths is not enabled.Simulation Option

There are interfaces that the LSP or LSP path traverses that are not TE enabled.TE not enabled

The source and destination are disconnected.Topology
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