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I ntroduction

This document describes the detailed process of AP Boot Process, AP Upgrade Path, and AP Image
Download Methods.

Prerequisites
Requirements

Cisco recommends that you have knowledge of these topics:

» Basic knowledge of Catalyst WirelessLAN Controllers

Components Used

» Catalyst 9800-CL, Cisco |IOS® XE 17.15.3



o Catalyst 9162 Access Point
» Cisco Aironet 3802 Access Point

The information in this document was created from the devices in a specific lab environment. All of the

devices used in this document started with a cleared (default) configuration. If your network islive, ensure
that you understand the potential impact of any command.

AP Boot Process
U-Boot

U-Boot Startup Sequence

Cisco APs begin the boot process in U-BOOT mode which occurs prior to the main COS shell. To reach U-
BOOT mode, review these steps.

1. Connect a console cable to the AP console port.

2. Open aterminal emulator program on your PC and set the session to the proper serial COM port.
Verify the COM port to be used on your device.

3. Set the terminal emulator software to use 115200 bps baud rate.



Note: If there is no output from the AP, set the baud rate to 9600.

4. Connect power to the AP.

5. Enter U-Boot mode by viathe escape (esc) button on your keyboard, you see the option to Hit ESC to
stop autoboot as seen in the screenshot. This message appears upon reboot of the Access Point while
connected to the console port.
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U-Boot 2013.01-gelc49d93a (Jul 28 2023 - 09:08:14) SDK version: 2015_T2.0pl0

Board: Barbados-3K
SoC: MV88F6920 Rev Al
running 2 CPUs
CPU: ARM Cortex A9 MPCore (Rev 1) LE

CPU O
CPU @ 1800 [MHz]
L2 @ 900 [MHz]

TClock @ 250 [MHz]

DDR4 @ 900 [MHz]

DDR4 32 Bit width,FastPath Memory Access, DLB Enabled, ECC Disabled
DRAM: 1 GiB

RST I2CO

NAND: ECC 4bits, 256 MiB

SF: Detected N25Q32A with page size 64 KiB, total 4 MiB

PCI-e 1 (IF O - bus 0) Root Complex Interface, Detected Link X1, GEN 2.0
PCI-e 2 (IF 1 - bus 1) Root Complex Interface, Detected Link X1, GEN 2.0

Map : Code: 0x3fed7000: 0x3ffad848
BSS: 0x3ffef314
Stack: 0x3f9c6f20
Heap: 0x3f9c7000: 0x3fed7000
U-Boot Environment: 0x00100000:0x00110000 (SPI)

Board configuration:
| port | Interface

I
| egigal | SGMII 0x01 |
| egigaz | SGMII | In-Band |
Net: egigal. eqgigaz? [PRTIME]

Hit ESC key to stop autoboot: O]
U-boot>>

U-Boot Startup Screen

Use the command printenv from U-Boot mode to list the various U-Boot environment details for the
Access Point.



BOOT=part
CASset=max
ENABLE_BREAK=1
FACTORY_RESET=0
MALLOC_len=5
MANUAL_BOOT=0
MEMORY_DEBUG=0
MPmode=SMP
PART_BOOTCNT=3
autoload=yes

baudrate=9600

This output indicates that the boot partition is partl. This boot partition can be modified within U-Boot
mod.

M odify U-Boot Boot Partition

1. Adjust the current boot partition with the setenve BOOT part <1-2> command.
2. Save the partition adjustment with the command saveenv command.
3. Verify the current boot partition with the printenv command.

u-boot>> setenv
u-boot>> saveenv



Saving Environment to SPI Flash...

SF: Detected N25Q32A with page size 64 KiB, total 4 MiB
Erasing SPI flash....Writing to SPI flash..... done
u-boot>> printenv

BOOT=part 2

4. Boot the AP with the newly configured boot partition with the boot command.

u-boot>> boot

Creating 1 MTD partitions on "nand0":
0x000000200000-0x000010000000 : "mtd=2"
UBI: attaching mtdl to ubiO

ubifsmount - mount UBIFS volume

Usage:
ubifsmount <volume-name>
- mount 'volume-name' volume
UnabTle to ubi mount UBIFS partition part 2
Trying alternate partition part2
UBIFS: mounted UBI device 0, volume 0, name "part2"

5. Access point boots from the selected boot partition.
COS Shell

AP Filesystem Check



Note: It isrecommended to reload the AP(s) prior to the upgrade. This allows all cached
filesystems to be refreshed and temporary files to be flushed prior to the upgrade.

From CLI on the AP, enter Privilegedmode and run these commands to verify the current AP images and
tmp directory size.

show image integrity Command

This output indicates the current versions on the AP.
The Primary partition version indicates the current AP boot version.

The Backup partition version indicates the AP backup version.

AP-CW9162#show image integrity
/partl(primary) 17.15.3.28
part.bin : Good
ramfs_data_cisco.squashfs : Good
iox.tar.gz : Good



/part2(Backup) 17.9.6.40
part.bin : Good
ramfs_data_cisco.squashfs : Good
iox.tar.gz : Good

Y ou can switch between the current AP boot version with the bold commands. The AP boots with the
selected partition after the next AP reload:

configur e boot path 1 (boots AP with partl version)
or

configur e boot path 2 (boots AP with part2 version)
show filesystems Command

The output indicates the filesystem structure of the AP.

Note: The /tmp row within the Mounted on column shows the filesystem entry that is used for AP



image storage for an AP upgrade.

<#root>

AP-CW9162#show filesystems
Filesystem Size Used Available Use% Mounted on

none 114. 4M 4. 7M 109.7M 4% /tnp

It isimportant that the AP /tmp filesystem has a size of 100M or higher. The /tmp filesystem is used to store
the AP image upgrade.

Note: If the /tmp filesystem entry is not 100M or larger, there could be issues with AP images that
are too large for the partition. Y ou need to upgrade the AP to version 17.6.6 viaany of the AP
Image Download Methods which expands the partition.



AP Upgrade Path

Cisco APsrequire a specific upgrade path with reference to the current and destination version. In this
guide, Cisco |OS XE version 17.15.3 is used.

1. Browse for the r elease notes document and Upgrade Path to Cisco 10S XE for your chosen upgrade
version.

CISCO Products and Services Solutions Support Leamn Why Cisco Trials and demos Q

[ Cisco Catalyst 9800 Senies Wireless Controllers | Release Motes |

Release Notes for Cisco Catalyst 9800 Series Wireless Controller, Cisco |I0S XE
17.15.x

Notes for Cisco... i sae K4 Downicad  fly Print
Updated: September 22, 2025 Was this Document
?
Bias-Free Language Helpful.
Contents Yes No
Release Notes for Cisco Catalyst 9800 Series Wireless Controller, Cisco 10S XE 17.15.x
= Feedback

Introduction to Cisco Catalyst 9800 Series Wireless Controllers

Revision History

What's New in Cisco I0S XE 17.15.4b Customers Also Viewed
What's New in Cisco 105 XE 17.15.3

What's New in Cisco IOS XE 17.15.2b

(] Recommended Cisco 10S XE
Releases for Catalyst 9800
What's New in Cisco 105 XE 17.15.2 Wireless LAN Controllers
What's New in Cisco 105 XE 17.15.1

Product Analytics Contact Cisco

Behavior Change

Interactive help Open a Support Casea
Impartant Notes (Requires a Cisco Service
Supported Hardware Contract)

Network Protocols and Port Matrix

Supported APs This Document Applies to
Compatibility Matrix These Products

GUI System Reguirements

Catalyst 9800 Series Wireless

Before You Upgrade
Controllers

Upgrade Path to Cisco 105 XE 17.15.x

Release Notes 17.15.X

2. The Before Y ou Upgrade section provides key details about the upgrade version. It is recommended to
review thisinformation.

3. The Upgrade Path to Cisco 10S XE Cupertino 17.15.X table contains details about which versions you
can directly upgrade from.


https://www.cisco.com/c/en/us/support/wireless/catalyst-9800-series-wireless-controllers/products-release-notes-list.html

Upgrade Path to Cisco |10S XE 17.15.x

Table 15, Upgrade Path to Cisco 105 XE Dublin 17.15.x {(where x = 1)

Current Software Upgrade Path for Deployments with Upgrade Path for Deployments
9130 0r 9124 Without 9130 or 9124
16.10.x = Upgrade first to 16.12.5 or 17.3.x and

then to 17.15.%.

16.11.% - Upgrade first to 16.12.5 or 17.3.x and
then to 17.15.x.

16.12.x Upgrade first to 17.3.5 or later or 17.6.x | Upgrade first to 17.3.5 or later or 17.6.x
or later, then to 17.9.6 or later or 17.12.x | or later, and then to 17.15.x.
or later, and then to 17.15.x.

17.1.x Upgrade first to 17.3.5 or later, then to Upgrade first to 17.3.5 or later and then
17.9.6 or later or 17.12.% or later, and to 17.15.x.
then to 17.15.x.

17.2.x Upgrade first to 17.3.5 or later, then to Upgrade first to 17.3.5 or later and then
17.9.6 or later or 17.12.x or later, and to 17.15.x,
then to 17.15.x.

173110 17.3.4 Upgrade first to 17.3.5 or later or 17.6.x | Upgrade directly to 17.15.x.
or later, then to 17.9.6 or later or
17.12.x or later, and then to 17.15.x.

17.3.4c or later Upgrade to 17.9.6 or later or 17.12.x or | Upgrade directly to 17.15.x.
later, and then to 17.15.x.

17.4.x Upgrade first to 17.6.x and then to Upgrade directly to 17.15.x.
17.15.x.

17.5.x Upgrade first to 17.6.x and then to Upgrade directly to 17.15.x.
17.15.x.

17.6.x Upgrade to 17.9.6 or later or 17.12.x or | Upgrade directly to 17.15.x.
later, and then to 17.15.x.

17.7.x Upgrade to 17.9.6 or later or 17.12.x or | Upgrade directly to 17.15.x.
later, and then to 17.15.x.

17.8.x Upgrade to 17.9.6 or later or 17.12.x or | Upgrade directly to 17.15.x.
later, and then to 17.15.x.

17.9.11t0 17.9.5 Upgrade to 17.9.6 or later or 17.12.x or | Upgrade directly to 17.15.x
later, and then to 17.15.x

17.9.6 or later Upgrade directly to 17.15.x Upgrade directly to 17.15.x

17.10.x Upgrade to 17.12.x or later, and then to | Upgrade directly to 17.15.x
17.15.x

17.11.x% Upgrade to 17.12.x or later, and then to | Upgrade directly to 17.15.x
17.15.x

17.12.x% Upgrade directly to 17.15.x Upgrade directly to 17.15.x

17.13.x% Upgrade directly to 17.15.x Upgrade directly to 17.15.x

17.14.% Upgrade directly to 17.15.x Upgrade directly to 17.15.x

8.9.x or any 8.10.x version prior to Upgrade first to 8.10.171.0 or later, Upgrade directly to 17.15.x.

8.10.171.0 17.3.5 or later or 17.6.x or later, then to

17.9.6 or later or 17.12.x or later, and
thento 17.15.x

Upgrade Path to 17.15.X

3. The Cisco Wireless Solutions Software Compatibility Matrix indicates which AP models are compatible
with your chosen version.


https://www.cisco.com/c/en/us/td/docs/wireless/compatibility/matrix/compatibility-matrix.html

Note: The Access Point Release column corresponds to the AP version codename. This Access
Point Release is used viathe Manual AP Image Download method and must be notated.

Table 5. Cisco Catalyst 9800 Wireless Controller and Supported Access Points

10S XE Release Access Point Image Access Point Supported Access Points
Version Number Release



isco |0S XE 17.15.3.28 15.3(3)JPT2 Cisco Wireless Wi-Fi 7 APs: 9176 (I/D1),
17.15.3 9178l, 9172(1)
Cisco Catalyst Wi-Fi 6E APs: 9136 (I)§ 9162

(1), 9163 (E), 9164 (1), 9166 (I/D1)

Cisco Catalyst Wi-Fi 6 APs: 9105AX (I/W),
9115AX (I/E), 9117AX (1), 9120AX (I/E/P),
9130AX (I/E)

Cisco Aironet APs: 1815 (I/W/M/T), 1830
(1),1840 (1), 1852 (I/E), 1800i, 2800 (I/E),
3800 (I/E/P), 4800 (1)

Outdoor and Industrial APs: 1542, 1560,
1570, and IW3702

Integrated Access Point in Cisco 1100 ISR
(ISR-AP1100AC, ISR-AP1101AC, and ISR-
AP1101AX)

Cisco Catalyst Industrial Wireless 6300
Heavy Duty Series Access Point, Cisco 6300
Series Embedded Services Access Point,
Cisco Catalyst 9124AX (I/D/E) Access
Points, Cisco Catalyst Industrial Wireless
9167 (I/E) Heavy Duty Access Points, Cisco
Catalyst IW9165D Heavy Duty Access Points,
Cisco Catalyst IW9165E Rugged Access
Points

Sensors: Cisco Aironet 1800s Active Sensor
Pluggable Modules: Wi-Fi 6 Pluggable
Module for Industrial Routers

Wireless Compatibility Matrix 17.15.3

4. Utilize the Software Download webpage to obtain the upgrade package, then proceed with an AP Image
Download method .

AP Image Download Methods

Utilize the 9800 WL C to upgrade the AP. This process involves download of the Cisco |OS XE upgrade on
the 9800 chassis and initiation of the image download to joined access points.

There are two methods to upgrade AP images. AP Image Predownload and Standard WL C Upgrade.

* AP Image Predownload allows preload of the AP image software prior to reload of the AP.
 Standard WL C Upgrade completes the upgrade on the WL C, rel oads the WL C and then APs
download the new version upon the AP join process.

AP Image Predownload

AP Image Predownload via GUI

1. Download the preferred Cisco 10S XE image version from the Cisco Software Download Site .

2. Upload the Cisco |OS XE image to the WL C via Web GUI Administration > Software Management >
Software Upgrade > Source File Path > Select File > Select the 9800 Upgrade File to be uploaded to
the controller.


https://software.cisco.com/download/home
https://software.cisco.com/download/home
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5. APs are upgraded per the AP Image Predownload method.

Status
4. Download Image/Package.
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» Install Image/Package
» AP Image Predownload
¥ Activate Image/Package

2 Commit




AP Image Predownload via CL |

1. Add and expand the controller image to the WLC.

install add file bootflash:image.bin

2. Download the image to all APs or a specific AP joined to the controller.

ap image predownload

or

ap hame <ap-name> image predownload

3. Verify the AP predownload status for all APs or a specific AP .

show ap image

or

show ap name <ap-name> image

4. Swap images of al APs, specific APs, or APs that have completed pre-download.

ap image swap

or

ap name <ap-name> image swap

or



ap image swap completed

5. Activate the newly installed image. This causes the WL C to reload and start with the new version.

install activate

6. Once the WL C is online and reachable, commit the image.

install commit

Standard WL C and AP Upgrade
Standard WL C and AP Upgrade via GUI

1. Download the preferred Cisco 10S XE image version from the Cisco Software Download Site .

2. Upload the Cisco |OS XE image to the WLC viaWeb GUI Administration > Software Management >
Software Upgrade > Source File Path > Select File > Select the 9800 Upgrade File to be uploaded to
the controller.

n -'C|I'S-":|c')' Cisco Catalyst 9800-CL Wireless Controller
17.15.3 Welcome cisco fH ﬁ A. Q %H 0 8

Administration - > Software Management

Software
Upgrade
Software Upgrade INSTALL v
Maintenance Mode - =
Current Mode (until next reload): INSTALL
) Upgrade (SMU)
.. Configuration
/ One-Shot O
AP Service Install
rade (i)
Package (APSP) Upgrade ()
) lransport My Desktop v
Licensing AP Device Type
Package (APDP)
File System bootflash v Free Space: 4203.53 MB

Troubleshooting

Source File :
Dt & Select File

Software Management GUI

3. After the sourcefile is chosen for upload, choose which option best fits your needs: Standard WLC
Upgrade or AP Image Predownload .

4. Click Download and I nstall.


https://software.cisco.com/download/home

5. The progress bar reaches 100% and Install Image/Package status is reached.

Administration~ > Software Management

Software There is an upgrade in progress. Please wait till it completes...
Upgrade
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Upgrade (SMU) Upgrade INSTALL Status
Mode
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il bige "> Download Image/Packa
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Install
AP Device Upgrade (i) ¥ Install Image/Package
Package (APDP) ¥ Activate Image/Package
Transport My Desktop g g
Type 2 Commit
File System bootflash Free Space: 5691.86 MB [ Show Logs
Source File 2
Path* v
(O C9800-CL-universalk9.1... 0%
AP Image O
Predownload
@

Hitless Software Upgrade (N + 1 Upgrade)

Enable O
Hitless
Upgrade

Sandard WLC Upgrade - Install Image

6. After the WL C performsthe final checks, click Save Configuration & Activate. This causes the WLC to
reload and start with the new version.

7. After the WLC isreachable via GUI, commit the upgraded version.



Administration - » Software Management 4 Click here for Latest Recommended Software
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Upgrade

& Download & Install Commit
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Standard WL C and AP Upgradevia CL I

1. Upload image to the controller.

copy tftp|ftp|sftp://<SERVER_IP>/<IMAGE_PATH> bootflash:

2. Install image on the controller.

install add file bootflash:<IMAGE_NAME>

3. Activate the new image. This causes the WLC to reload and start with the new version.

install activate

4. Once the WLC is online and reachable, commit the image.

install commit

Manual AP Image Download

Utilize afile server application of your choice on your computer or server. Thisfile server isthe server that



supplies the AP with the preferred upgrade files.

1. Download the preferred AP image version from the Cisco Software Download Site.
2. Save the AP software file on your file server directory.
3. Utilize the ar chive download-sw command to initiate the file upgrade from the CLI of your AP.

Note: Transport methods available for the ar chive download-sw command are limited to TFTP
and SFTP

#archive download-sw /reload <tftp|sftp>://[your TFTP server's IP address]/[image filename.tar]

4. AP downloads the .tar upgrade file from the file server as directed. This takes some time dependent on the
transfer rate between the AP and the file server.

5. Upon completion of the file transfer, the AP automatically reloads and boots the newly downloaded AP
image.


https://software.cisco.com/download/home

Note: If the ar chive download-sw command is not accepted by your AP, enter the command
debug capwap console cli to enable the ar chive download-sw command

Verify

After the AP upgrade process has completed, verify the AP version, image integrity, and boot partition with
the commands.

1. Verify AP version.
show version
2. Verify image integrity.

show image integrity



3. Verify boot partition.

show boot

Related | nfor mation

* Repair C9120/C9115 Access Points from U-boot
* Predownloading an Image to an Access Point
* Upgrading the Cisco Catalyst 9800 Wireless Controller Software



https://www.cisco.com/c/en/us/support/docs/wireless/catalyst-9120axi-access-point/217537-repairing-c9120-c9115-access-points-from.html
https://www.cisco.com/c/en/us/td/docs/wireless/controller/9800/17-15/config-guide/b_wl_17_15_cg/m_predwnld_image_ap_ewlc.html
https://www.cisco.com/c/en/us/td/docs/wireless/controller/9800/17-15/config-guide/b_wl_17_15_cg/m_upgrade_9800cl.html

